


METTLE SKYBOX & SKYBOX STUDIO - USER MANUAL 
The SkyBox fanily of products are a series of Scripts & Plugins  
to Generate Environment/Reflection Maps as well as for use in 
360 | VR productions. 
 
Mettle SkyBox & SkyBox Studio are innovative “Hybrid” solutions for Adobe After 
Effects CS5 and higher. They consist of both scripted and plugin solutions. The scripted 
portions automate complex set-ups for 360 production, they take all of the guess work 
out of 360 | VR productions 
..............................................................................................
Mettle’s SkyBox includes 2 modules: 

SkyBox Creator (script) automates the creation of all necessary comps and camera relation-
ships to create a 360 | VR authoring Environment in After Effects. 
SkyBox Converter (plugin) takes a complex process and makes it super easy. It will convert 
between A 2D Source, Cubic - Spherical - Equirectangular Maps. 
 
 
 

................................................................................................
Mettle’s SkyBox Studio consists of 4 modules: 

SkyBox Creator (script) automates the creation of all necessary comps and camera relation-
ships to create a 360 | VR authoring Environment in After Effects. 
SkyBox Converter (plugin) takes a complex process and makes it super easy. It will convert 
between A 2D Source, Cubic - Spherical - Equirectangular Maps.  
SkyBox Extractor (script) converts stitched equirectangualr footage into a working envi-
ronent in After Effects where you can motion, track do object removal, add motion graphics 
graphics, vfx etc. It automates the creation of all necessary comps and camera relationships to 
create a 360 | VR post production  Environment in After Effects. 
SkyBox Viewer (plugin)emulates what you will see in youtube 360, Oculus Rift and other 
formats. This is excellent for pre-flight testing of your composites and animations.



................................................................................................
Use SkyBox generated Maps with: 
After Effects  3D PLUG-INS
You can create reflection maps and/or environment maps for use with After Effects 3D plugins like Element 
3D, FreeForm Pro, Shapeshifter & Zaxwerks. Pretty much any 3D plugin that will accept and use AE layers as 
reflection or environment maps. 

3D APPLICATIONS
Use these reflection maps and/or environment maps with 3D applications like 3ds Max, Blender, Cinema 4D, 
Lightwave, Maya, Modo etc. Create amazing environments by tapping into the rich motion graphics offerings 
in After Effects to generate stills and sequences that cannot be done as easily in 3D.

3D GAMES
Use SkyBox with the Unreal Engine or Unity 3D to create elements for your level design. Create a unique world 
of your own.

WEBGL
SkyBoxes have been supported in hardware in openGL and now in webGL for quite a while. With Mettle’s 
SkyBox you can now create rich & unique environments using After Effects for your webGL projects.

YOUTUBE 360 | VR FORMAT
Google’s Youtube 360 format is growing in popularity and Mettle’s SkyBox is the perfect tool to help you bring 
your own creations into this format. Youtube 360 requires the Equirectangular map format. SkyBox Converter 
supports this format (along with Cubic Maps and Spherical Maps). You will also need to add some data to your 
file. Google made this easy, please see: https://support.google.com/youtube/answer/6178631?hl=en 
 

VR APPLICATIONS LIKE OCULUS RIFT
SkyBox Converter can take any Cubic Cross or Spherical (as pictured on the next page) and can convert to the 
Equirectangular format that many VR applications like Oculus Rift require.
 
 
 
 

 



HOW TO INSTALL METTLE’S SKYBOX
Simply launch the installer that was sent you and follow the instructions.  
Please note, make sure to disable any anti-virus software temporarily to assure a proer 
install. Also make sure that After Effects is located in the default location that the Adobe 
Creative Clouds has designated. Nesting After Effects in another lcoation or folder on your 
drive is not standard practise and may result in installation problems. 

 
HOW TO REGISTER METTLE’S SKYBOX
Step 1
Launch After Effects then go to After Effects > Preferences > General and make sure that 
“Allow Scripts to write files and Access network” is checked. 

Step 2 
If you have already created a SkyBox Master composition by using SkyBox Creator or 
SkyBox Extractor, then look in the “SkyBox Output comp”. Select the “SkyBox Output (from 
SkyBox Master)” and then go to the Effects Control Window. Click on the SkyBox Converter 
Register Window and enter your email address and license key information exactly as you 
received them by email when you ordered SkyBox. 
 
Or simply apply SkyBox Converter to any Ae layer, then simply click on the Register 
window and add your email address and license key exactly as it was sent to you by email 
when you bought SkyBox.

To use SkyBox products on more than one computer you need to either buy more activa-
tions or  go to the Register Window and click “Deactivate” . You can then “Activate” your 
license on another system.



HOW TO USE SKYBOX CREATOR
Step 1
To launch SkyBox Creator simply go to: File > Scripts > SkyBox Creator.jsx.bin

Step 2
If you wish to Create a new SkyBox Master from scratch then choose the size you need,  
1024 x 1024 will do for most applications of SkyBox. Choose the frame rate and duration of 
your SkyBox Master, then simply click on “Create New SkyBox Master”.



Step 5 
You can switch to 4 views and verify that objects are in frame in all 6 views (see above). Try to 
avoid having things come too close to the centre of you scene, clipping on one or more of the 
views may occur or one or more of the views may be obscurred. If this happens then adjust the 
3D plugin parameters to avoid this.  
 

Step 3
Switch to Custom View 1 and proceed to creating your SkyBox world by adding your favorite Ae 
3D plugins and/or AE 3D layers. In the screen capture above, we added Trapcode Horizon, Form 
& Rowbyte’s Plexus. 

Step 4
Once you are happy with your creation, simply click on “Generate SkyBox Output”. SkyBox Cre-
ator takes over from here and creates all the necesseary compositions, adds all the cameras and 
distortion as well as all the expressions that are required to create a Cubic Map. You can then 
use SkyBox Converter to switch between various output formats. More on that later. 
 



Step 6
Want to modify your SkyBox Master and apply these changes to your SkyBox Output comp? 
Simply click on 'Refresh SkyBox Output' once you are done with your modifications. SkyBox 
Creator will take care of deleting all comps and recreating them based on the last set of modifi-
cations you made to your “SkyBox Master” composition.

Use the “3D Null | Camera Control” if you know you want to control your SkyBox Camera via 
a 3D Null layer. Using the pick whip to Parent to the AE camera will
not work well. You need to do this via a proper Expression, we dio that for you by simply mak-
ing sure that this check box is selected. 
 
Make sure to keep the “I am using 3D Plugins” box checked if you know that you will be 
using 3D plugins. Due the After Effects architecture, third party 3D plugins and even AE’s very 
own Shatter are treated very differently than AE 3D layers. As a result, SkyBox creator will set 
things up very differently if you plan on only using AE 3D layers versus including 3D plugins. 
 
Some 3D plugins like Mettle’s FreeForm Pro, Shapeshifter,  Video Copilot’s Element 3D, Trapcode 
Mir, are true 3D plugins so they do not need the “Edge Blending” enabled. Others like, 
Rowbyte’s Plexus, Trapcode 3D Stroke, Form & Particular exhibit issues at times. This is where 
“Edge Blending”  can help but it will not comletely resolve these issues. Ultimately Boris, 
Cycore Systems, Rowbyte & Trapcode (amongst others) need to address this, internally in their 
code, with their offerings.



HOW TO USE SKYBOX CONVERTER
SkyBox Converter is an After Effects Plugin. As such, you can load it from Effect  > Mettle > 
SkyBox Converter. You can use SkyBox Converter in conjunction with SkyBox Creator, Extractor 
& Viewer. You can also use SkyBox Converter on its own if you want to convert images from 
your stock library from Cubic to Spherical or Equirectangular. You can also change the camera 
orientation in your footage. Or even add simple supers, logos or images patches that you 
retouch in Photoshop to your footage.

SkyBox Converter Can Convert Between Various Formats 
Following are just a few formats that you can convert to for Output. The “Input” should match 
the original format, then select the “Output” format you wish to convert to and SkyBox Con-
verter will take care of the rest.



SkyBox Converter - Reorient Camera Controls 
Tilt (X-Axis), Pan (Y Axis) & Roll (Z Axis) controls are available in SkyBox Converter. No need to 
re-stitch your camera views or shoot just to change the camera orienation. Pictured below is 
one posible use. In this case the camera rig front face the front view of the automobile, with a 
simple Pan (180 degree roation on the Y Axis), we now face the car. 
 
The controls are also keyframeable so animated Camera Tilts, Pans & Rolls are possible as well. 



SkyBox Converter - Input - 2D Source 
On many occasions 360 | VR prodcutions may call for you to either add watermarks to yourt 360 
footage, add simple supers or even logos. This feature in Converter will come in very handy. 
Pictured below is one use of 2D Source as an Input type.  
 
This example consists of a pre-composition, “Supers & Logos”. This pre-comp needs to be 
created to the same size as your master, in this case 4096 x 2048 pixels. We added AE text and 
the Mettle Logo. This pre-comp is then added to your master comp that contains the stitched 
360 footage. SkyBox Converter is applied to this “Supers and Logos” layer and we simply added 
a Camera tilt (X Axis) to position the text on top of the hood of the car. Animation is possible 
both in the pre-comp as well as via the Re-orient camera controls.  
 

Footage courtesy Ben Kidd - Hamilton & Kidd - UK



How To Use SkyBox Extractor 
SkyBox Extractor is only available in SkyBox Studio. Extractor makes dealing with stitched 360 
footage easy. SkyBox Extractor is a Scripted soltuion.

To access SkyBox Extractor go to File > Scripts > SkyBox Extractor.



SkyBox Extractor removes the Equirectangualar distortion in 360 footage and then extracts 
6 camera views. Extractor then then postions them in a cube formation in After Effects in an 
“SkyBox Edit” comp pictured below.

In the “SkyBox Edit” comp, you can render the view(s) you need so that you can then motion 
track, camera track much more easily. You can also do object removal, add motion graphics, 
CG and VFX etc. SkyBox Studio modules play well with third party 3D products like Mettle’s 
FreeForm Pro, ShapeShifter, Video CoPilot’s Element 3D, Trapcode products etc. 

Notice thatExtractor adds a  Master SkyBox Camera as well as 6 more camera views that are 
parented to the Master Camera. Also notive that we generate 6 “Faces”... Front, Right, Back, 
Top, Left & Bottom. These are strategically positioned to form the cube you see pictured above.



SkyBox Extractor creates a “SkyBox Output” Comp. This what you will render out for youtbe 
360 etc. once you are done. All the work you do in your “SkyBox Edit”  will make it’s way 
through to the “SkyBox Output” comp. SkyBox Extractor harnesses the power of SkyBox 
Converter to convert from a Cube Map formation (as is set up in the SkyBox Edit comp) to 
equirectangualr which is neceszary for yooutube 360 and many other 360 | VR formats.



SkyBox Extractor adds a “SkyBox Viewer” Comp. Another SkyBox Studio module is used to 
achieve this, SkyBox Viewer. This module is only included in the SkyBox Studio offering. 
 
The  “SkyBox Viewer”  is meant to simulate the view you see in youtube 360 and other 360 | VR 
formats. This is excellent to check you work before rendering out, compressing and uploading 
to youtube 360 or other 360 players.



PREPARING YOUR SKYBOX CREATION FOR YOUTUBE 360
Mettle’s SkyBox Studio is excellent to help get your SkyBox creations in After Effects to the You-
tube 360 format. Make sure you use the Equirectangular format, then follow  the instructions 
in this link: https://support.google.com/youtube/answer/6178631?hl=en
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