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Quick Description 

 

 The FloChec
TM

 System provides graphical information about pulsatile blood flow 

in an extremity. This enables assessment of effects on blood flow, such as partial or total 

occlusion on vasculature proximal to the extremity being monitored. 

 

FloChec uses an infrared sensor to collect light measurements of the pulsed blood 

flow from fingers and toes, and then employs an algorithm to convert these 

measurements into a digital signal which is displayed on a workstation. The display 

shows changes in the pulsed blood flow in the extremity during an adjustable time period, 

and since the information is displayed while the patient is being monitored, effects on 

pulsed blood flow, such as the Valsalva maneuver, changes in proximal occlusion of a 

blood vessel (including external compression), or other vascular flow-affecting events 

may be observed in real time. This helps measure the effect on distal blood flow resulting 

from such events. 

 

 Once the information is collected and the test is complete, the results display on a 

PDF file that can be stored or printed out. 

 

 

 

Included Devices 

Reusable Sensor Netbook PC Printer 

  
 

Infrared sensor used to collect 

light measurements of the 

blood flow from fingers and 

toes. 

Portable, wireless PC 

specially configured with 

the FloChec Application 

Wireless printer 

 

Caution Statement 
 

Federal Law restricts this device to sale by or on the order of a licensed healthcare 

provider. 
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Intended Use 

 

This system is intended to measure arterial blood in the extremities. 

 

 

Indications for Use 

 

To monitor relative blood flow changes distal to the occlusion of a brachial, 

radial, ulnar, or femoral artery. 

 

 

From the physician history and clinical findings, the person has pain, claudication, 

or changes in blood flow to an extremity. 

 

Contraindications for Use 

 

The device cannot be used on persons with no fingers or toes, or any person under 

18 years of age. 

 

 

 

Installation Instructions 
 
The application can either be installed on a workstation or run from the Software Drive. 

Running the application from the Software Drive means that you can run the application 

on any workstation (that meets the specified requirements) by simply inserting the 

Software Drive into a USB port. 

 
Running the Application from the Software Drive 
(also listed on the Quick Start Guide) 

 

1. Insert the Software Drive into a USB port. 

2. Two autoplay windows will appear: the U3 System window and the FloChec App 

window. 

o If the autoplay windows do not appear:  

 Select Start/Windows icon> Computer in MS Windows. This will 

open a window that displays any removable devices attached to the 

workstation.  

 Open the option labels “U3 System.” 

 Select Launch U3. 

 Skip to Step 5.  

3. Select “Run U3 Launchpad” from the U3 System window. 

4. The program will initialize and then add a U3 icon to the bottom right hand corner 

of the MS Windows taskbar.  

5. Click on the U3 icon to open the U3 Launchpad. 
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 If the U3 icon does not appear on the MS Windows taskbar, select “Open 

folder to view files” on the FloChec App window, then select Launch U3 from 

the new window that opens. This will open the U3 Launchpad. 

6. Select Install Drivers if this is the first time the application has been run on the 

workstation. This will install the drivers on the workstation. 

o If the drivers are not installed, you will receive an error when you try to 

Start a measurement  

7. Select FloChec Application on the U3 Launchpad menu. The FloChec application 

will begin. 

 

 

Installing the Application on a Workstation 
(also listed on the Quick Start Guide) 

 

1. Insert the Software Drive into a USB port. 

2. Two autoplay windows will appear: the FloChec application window and the U3 

System window. 

3. Select “Open folder to view files” from the FloChec App window. This will open 

a new window. 

4. Select FloChec Installation. This will begin the Setup Wizard. 

5. Proceed through the steps of the Setup Wizard, entering any required information. 

 Agree to the license agreement. 

 Select the path where you would like the application installed, or leave it 

set to the default location. 

 Select the Everyone toggle if all users on the workstation should have 

access to the FloChec application. 

 Proceed to the final step.  

6. A window will appear, confirming that the FloChec application is allowed to 

write files to your workstation. Click Accept to proceed. 

7. Another window will appear, confirming that you would like to install the 

FloChec drivers. Click the Install Drivers button. 

8. Once the Installation Wizard is successfully complete and the drivers have been 

installed, a FloChec  icon will be added to the desktop.  

9. Click on the FloChec icon to launch the application. 
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Instructions for Use 
 

Setting up the Application 
 

Once the application is installed, follow the steps in this section to configure the software. 

 

1. Setup the basic features of the application. 

 Open the application by clicking on the FloChec icon         on the MS 

Windows desktop. 

 

 

 Open the Options Form (         Settings >Options from the main FloChec 

Blood Flow window). 

 Open the General tab. 

Illustration 1: Flo Chec Main Form 
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 The functionality of the Show Event button toggle is covered in the Advanced 

Users section of the user manual.  

o Leave this toggle unchecked or see the user manual section titled Using 

the Event and Data Logging features. 

 Check the Session Information must be completed toggle if all patient and 

technician information must be entered before a test can be performed. 

o When this toggle is checked, the patient’s First and Last Name or ID, 

Sex, and Birth Date, and a technician name must be entered into the 

Session Form before measurements can be taken. 

o When this toggle is not checked, no patient or technician information is 

required before a test is performed. 

 Check the Session Barcode Entry Visible toggle if you would like the option of 

entering a barcode when entering patient information. 

o When this toggle is checked, a Barcode field will be added to the Session 

Form (Open Session button from the main FloChec Blood Flow window). 

The technician can tab to the Barcode field, scan a barcode, and the 

barcode will be stored in the field.  

 The Data Logging tab is covered in the Advanced Users section of the user 

manual. 

o For information on Data Logging, see the section titled Using the Event 

and Data Logging features. 

 Click the Accept button when complete to save the selections. 

o If you click the Cancel button, no changes to the Directory Settings Form 

will be saved. 

 

2. Enter your company information into the application. 

 The Company Information Form (  Settings> Company) is used to enter 

Illustration 2: Options Form (General Settings) 
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your company information into the application. Depending on how you setup the 

report that displays the test results, some or all of this information will display on 

that report. 

o Setting up the report will covered during the user manual section titled 

Performing a test.  
 

 

 Open the Company Information Form by selecting Settings and Company 

Information from the FloChec Blood Flow main application window. 

 Enter your company information into the window. 

 

3. The basic setup is now complete. Proceed to the manual section titled Creating and 

Editing protocols to define how tests should be performed. 

 

 

Illustration 3: Company Information Form 
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Creating and Editing Protocols 
 

Protocols are the parameters used when taking measurements during a test, such as which 

appendages should be measured and the length of time they should be recorded. Use the 

Protocol Edit Form to create new protocols or modify existing ones.  

 

 Open the Protocol Edit Form by selecting Settings, then Protocols from 

the main FloChec Blood Flow window.  

o This window can also be opened just before performing a test so that 

measurements can be customized for specific patients by clicking the Edit 

Protocol link on the New Test Form while opening a new session (Open 

Session button> Start Session button).  

 The Current Protocols field displays all of the saved protocols.  

o Select a protocol and the fields in the window will populate with the 

settings of that protocol. 

o Click the Edit button if you would like to edit the selected protocol. This 

will enable the fields in the window. 

o Click the Plus button to create a new protocol, and then click the Edit 

button to modify the new protocol. 

o Click the Minus button to delete the selected protocol. 

o The Up and Down buttons are used to change the placement of the 

protocol on the drop down menu when a new test is being performed. For 

example, you might want the protocol that is performed the most often to 

be at the top of the list. 

 The Protocol Name field is the name of the protocol.  

o This is the name that will display in the Protocol to Use drop down menu 

on the New Test Form window when a new test is being performed.  

Illustration 4: Protocol Edit Form 
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o The name entered in this field should be something a technician can easily 

identify. 

 The Pulse Graph Length field is used to select the length of the x-axis on the 

Pulse Graph that will display on the screen and on the reports generated during 

the test. This is a length of time in seconds.  

o For example, if you would like fifteen seconds of recorded measurements 

to display on the screen and on the report, select 15 from the drop down 

menu. 

o HINT: The selection in this field does not affect the duration of the 

measurement, it only affects the amount of information that will be 

displayed on the screen and on the report. For example, if the duration of 

the measurement is 30 seconds but the Pulse Graph Length is 15 seconds, 

the screen and report will only display the last fifteen seconds of 

measurements. If you would like the entire duration of the measurement to 

display on the graph, the Duration field and the Pulse Graph Length 

field should be set to the same value. 

o The value selected in this field is only the default value for the protocol. 

You can use the Graph Settings Form (                Settings> Graph 

Settings) to modify the length of the Pulse Graph and Blood Flow Graph 

before the measurements are made to customize a test.  

 The Blood Flow Length field determines the length of the x-axis of the Blood 

Flow graph and it functions the same way as the Pulse Graph Length field. 

 The Measurements field is used to modify the measurements that will be made 

during the test. For example, if the left hand should be measured for 30 seconds 

during this protocol, this is the place to add that information. The function of this 

field is very similar to the Current Protocols field. 

o Click the Plus button to add a new measurement. This will add a record to 

the Measurements field and enable the fields in the Measurement 

Attributes section. 

o Highlight a record in the Measurements field and the fields in the 

Measurements Attributes section will populate with the values of the 

selected measurement. 

o Click the Edit button to enable the fields in the Measurement Attributes 

section and modify the values. 

o Highlight a record and click the Minus icon to delete the selected 

measurement. 

 The fields in the Measurement Attributes section are used to modify the 

measurement selected in the Measurements field. These fields are only enabled 

when a measurement is highlighted and the Edit button is clicked. 

o The Location field is used to select the location of the measurement. For 

example, foot or hand. 

o The Side field is used to select which side, left or right, the measurement 

should be performed on. 

o The Digit (Finger/Toe/etc) field is used to select which digit the 

measurement should be performed on.  
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o The Duration field is used to select the duration of the measurement. For 

example, if the appendage should be measured for 30 seconds, select 30 

from the drop down menu. 

 If the value selected in this field is greater than the value in the 

Pulse Graph Length and Blood Flow Graph Length fields, all of 

the measurement will not display on the screen and the reports 

when the protocol is performed. For example, if the duration is set 

to 30 seconds but the graph lengths are set to 15, only the last 

fifteen seconds of measurements will show on the screen and on 

the report when the measurement is complete. 

 Select Infinity from the drop down menu if the technician should 

be allowed to control the length of the measurement. When the 

measurement is being gathered, a timer will display on the screen 

showing how many seconds have elapsed. The technician will be 

able to stop the measurement once they feel enough data has been 

gathered. 

o Click the Accept button in the Measurement Attributes section to save 

the entered data. 

 If you click the Cancel button, all changes to the Measurement 

Attribute fields will be lost.  

 Once all of the measurements have been added to a protocol and all changes have 

been made, click the Accept button next to the Measurements field. This will 

save all of the information associated with the protocol selected in the Current 

Protocols field. 

o If you click the Cancel button, all changes made will be lost. 

 Click the Close button once all protocols have been setup. This will close the 

Protocol Edit Form. 
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Performing a Test 
 

Once the software has been installed and configured, and the protocols have been 

defined, you are ready to perform a test. Follow the steps below to take measurements 

and perform a test. 

 

1. Open a New Patient and Start Test 

 

 

 Plug the USB Signal Acquisition device into a USB drive on the workstation, and 

then plug the Reusable Sensor into the USB Signal Device. The status of the 

Device Connection is shown in several manners.   

o The Connection status is displayed in the status bar at the bottom of the 

screen. 

o A checkbox symbol is shown in the top right corner 

   Indicates that the device is 

Disconnected 

   Indicates that the device is Connected 

 

o If you are still having trouble, see the troubleshooting section of the user 

manual.  

 

 

Illustration 5: Flo Chec Main Form 
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Reusable Sensor and USB Signal Acquisition Device 

 

 Once the Reusable Sensor is connected, start a Session by Creating a new Patient 

by clicking the   Patient >New Patient on menu bar. This will open the 

Patient Information Form, which is used to enter the patient 

information. The patient information entered into this window will display on all 

reports generated during this session. 

 

 If the Patient Information must be completed toggle on the Option Settings 

window is checked, the fields in this window must be complete before proceeding 

to the next step. 

o Only the Full Name or ID must be entered not all three. 

 Enter the Name or ID or both, and select a Sex from the drop down menu. 

 The Birth Date field is a calendar field used to select the patient’s birth date. 

o Enter a birth date using the arrow keys to move between month, date, and 

year, or click the Calendar icon to select a birth date using a graphical 

calendar. 

o HINT: When using the graphical calendar, click on the calendar heading 

to change what is displayed and quickly select data. 

 The Technician field is used to enter the name of the technician performing the 

test. 

o This field is automatically filled with the last Technician used while the 

application is opened.   

Illustration 6: Patient Information Form 
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 The Barcode field is an optional field used to enter a barcode associated with the 

patient.  

o If there is a barcode scanner attached to the workstation, tab to the 

Barcode field and scan the barcode. The barcode will populate in the 

Barcode field.   

o This field will only display if the Session Barcode Entry Visible toggle is 

checked on the Options Settings window (Settings> Options> General). 

 Click the Accept button when complete. 

o If all of the required information has not been entered, the Missing 

Information window will display. Click the OK button to return to the 

Session Form and then complete the information. 

 If you click the Cancel button, all information entered into the window will be 

lost and the Patient Information Form window will close. 

 

 
 

2. Select a test to perform 

 The New Test Form window is used to select which test to perform on the patient. 

 Select a protocol in the Protocol to Use drop down menu to select a test. 

 Click on the Edit Protocol link below the drop down menu if you would like to 

view the settings of the selected protocol or you would like to create a new 

protocol. This will open the Protocol Edit Form window. 

o This is the same window that opens when you select Settings> Protocols 

from the toolbar at the top of the FloChec Blood Flow window. For more 

information on the Protocol Edit Form, see the user manual section titled 

Creating and Editing Protocols. 

 Click the OK button on the New Test Form once a protocol has been selected. 

o If you select Cancel, the New Test Form window will close and all patient 

information will be lost. 

 

Illustration 7: New Test Form 
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3. Perform the selected test. 

 

 The toolbar on the left hand side of the FloChec Blood Flow window will vary 

depending on the test selected and how that test is setup. For example, if you are 

performing the standard Digital ABIs test, there will be an option to measure the 

left and right foot, and left and right hand. 

o For more information on defining how tests are performed, see the user 

manual section titled Creating and Editing Protocols. 

 Click on a Measure button to record the measurements of a selected appendage. 

o The left hand toolbar will change, displaying instructions on how to record 

the measurement. 

 

 

Illustration 8: Test Measurement Shown 

Illustration 9: Measure Controls 
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 Place the Reusable Sensor on the selected appendage, making sure the correct 

side is facing up. 

 

 
 

 Controls 
o The Event button will display on the toolbar if you have enabled the 

Event feature (Settings> Options> General tab> Show Event Button 

toggle). This is an optional feature covered in the Advanced Users section 

of the user manual. 

o The Event button when pressed will store an event in the log file 

o  The Start button is used to start the measurement.  

Make sure the sensor is attached to correct appendage. 

o    The Stop button is used to stop a measurement when it 

is active.      

o    The Cancel button is used to Cancel the measurement 

if it is active or not. 

 

 When a measurement is started, there may be a pause before the Pulse Graph 

shows data.  The device is adjusting to the patient during this time.  

 If the device cannot adjust for the patient, the measurement will be canceled after 

40 seconds. 

 

 Illustration 11: Pulse Data Graph 

Illustration 10: Reusable Sensor 
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 There is an 8 second delay for the Blood Flow Data to be calculated. 

 

 

 If either the Pulse Graph or Blood Flow Graph do not display on the FloChec 

Blood Flow window, select  View> Graphs from the main menu and 

place a check next to the graph you would like displayed. This will 

add the selected graph to the main application window. 

 The protocols of the selected test will determine how the measurements will end. 

o If the duration of the measurement is continuous, a Stop button will 

appear as well as a timer indicating the duration of the measurement being 

taken. Click the Stop button once the necessary data has been collected. 

o If the duration of the measurement is a specific length of time, for example 

15 seconds, the toolbar will display a countdown until the data has been 

collected. 

o The duration of the measurement is defined when the protocol is created 

using the Protocol Edit Form (Settings> Protocols> Duration field). For 

more information on protocols options, see the user manual section titled 

Creating and Editing Protocols. 

 The Blood Flow number listed for each measurement is an average of the Blood 

Flow during the measurement (calculations are performed once a second) 

 Once data has been collected from one appendage, take measurements on the 

remaining appendages to complete the test. 

 The Current Blood Flow field at the top of the left hand toolbar will always 

display the current blood flow of the last appendage measured.  

o For example, if you start with the left hand and then move to the right 

hand, the blood flow of the right hand will display once the measurement 

on the right hand is complete. 

 The  Notes button is used to add notes to the test which will display on 

the report. 

o Click the Notes button and the Session Notes Form will 

open.  

o Enter any information that you would like to display on the report into the 

Session Notes Form. 

o Click the Save button when complete. 

Illustration 12: 
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o HINT: The Notes field on the report is limited to seven lines of text, so 

any information added after the seventh line in this window will not 

display on the report. 

 

4. View/Save/Print a report. 

 At any time during a session a report can be created, saved or printed with the 

available data.   

  The Show Report button opens a preview of the Report 

o The preview screen is shown in Illustration 13. 

 

o The user can change the Zoom Level using the options in the toolbar 

 Click the Larger or Smaller buttons to zoom in or zoom out of the 

report. 

 This will only affect how the report displays in the window, not 

how the report prints out.  

o If the format of the report is good, then either print the report or save it. 

Illustration 13: Report Preview Screen 
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 Click the Print button to print the report. This option will only 

work if there is a printer attached to the workstation and that 

printer is also installed in MS Windows. 

 You can view the printers installed on a workstation by 

opening the Devices and Printers folder in MS Windows 

(Windows icon on the Windows taskbar> Select Devices 

and Printers). 

o The user can create a PDF document and open it in Adobe by clicking the 

Create Report Icon 

o The user can Save a PDF document by clicking the Export Report Icon 

o The user can modify what is displayed on the report by clicking the Report 

Settings Icon (see the Modifying Report Section below for more details). 

 The report is a single page document that displays the collected data. 
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 Once the report has been printed or saved, then the test is complete and you can 

skip the last step of this user manual section.  

o If you would like to change the format of the report, then move to the next 

step. 

 

5. Modifying the report. 

 Click the Report Settings button if you would like to modify how the 

information displays on the report. This will open the Report Configuration 

window. 

Illustration 14: Report Description 
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 Changes made in this window will not only affect the current report, but it will 

affect all reports created in the application, so you will probably only need to do 

this once.  

 Check the Show Company Information toggle if you would like your company 

information, such as address, phone number, and/or website URL to show up on 

the report. This will enable the fields in the Company Information section. 

o Company information is entered using the Company Information Form 

(Settings> Company Information). 

o For more information on entering your company information into the 

application, see the user manual document titled Setting up the 

Application. 

 The following toggles will only be enabled if the Show Company Information 

toggle is checked. 

o Check the Show Address toggle if you would like the Street Address, 

City, State, and Zip Code to display on the report below the company 

name. 

o Check the Show Phone Number and/or Show Fax Number toggles if 

you would like to include the phone and/or fax number on the report. This 

information will display on the line below the address at the top of the 

report if the address is included. 

Illustration 15: Report Configuration Form 
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o Check the Show E-Mail Address and/or Show Web Address toggles if 

you would like to include that information on the report. 

o If you check the Show Company Information toggle, but leave all of the 

other toggles in the Company Information section unchecked, only the 

company name will display on the report. 

 Check the Show Body Image toggle if you would like to include a simple body 

silhouette in the center of the report. If this toggle is not checked, nothing will 

display in its location. 

 Check the Show Captured Images toggle if you would like to include the Pulse 

Graph on the report.  

o A Pulse Graph will display on the report for each appendage measured 

during the test.  

o The x-axis of the Pulse Graph (time in seconds) that will display on the 

report is setup using the Protocol Edit Form (Settings> Protocols). For 

more information on the Protocol Edit Form, see the user manual section 

titled Creating and Editing Protocols. 

 The Ratios section is used to select which ratios you would like to display on the 

report. 

o Check the Show Only Known Ratios if only ratios with adequate data 

should be included on the report.  

 For example, if only the right hand and left hand are measured, the 

left leg and right leg dABI ratios will not display on the report. 

o Check Show All Ratios toggle if all ratios should be included on every 

report. 

 Check the Show Signature Box toggle if you would like to include a signature 

box at the bottom of the form. This allows the technician to sign the report. 

o Check the Show Physician/Technician Name under Box toggle if you 

would also like to include the technician name entered when the session 

was created on the report below the signature box. 

 This toggle will only be enabled when the Show Signature Box 

toggle is checked. 

 The Session Information section is used to select which information entered 

during the session should be included on the report. 

o Check the Show Patient Age toggle if you would like the patient’s age 

included on the report. The application will calculate the patient’s age 

based on the session date and the patient’s birth date. 

 The patient’s age will display below the patient’s name and sex at 

the top of the report. 

o Check the Show Patient Birth Date toggle if you would like the patient’s 

birth date included on the report. This will display under the patient’s 

name and sex at the top of the report. 

o Check the Show Session Date, Show Session Time, and/or Show Session 

Duration toggles if you would like to include this information on the 

report.  

 When these toggles are checked, this information will display just 

above the patient information on the report. 
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 The Session Duration will display on the report in seconds. It is 

the length of time between when the session is opened and closed. 

If a session is still open while you are viewing the report, the 

Session Duration will continue to increase each time you view the 

report. 

 Click the Accept button when complete. This will return you to the report.  

o If you click the Cancel button, all changes will be lost. 

 Once the report is formatted correctly, print or save it. 
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Advanced Features  
 

The features covered in this section are optional features for advanced users.  

 

Using the Event and Data Logging Features 

 
1. Choosing to use the Event feature. 

 The application displays changes in pulsed blood flow, and since the information 

is displayed while the patient is being monitored, the effects on pulsed blood 

flow, such as a Valsalva’s maneuver,  changes in proximal occlusion of a blood 

vessel (including external compression), and other vascular flow-affecting events 

can be observed in real time. 

 The Event feature is used to highlight an event that takes place while a 

measurement is being taken, such as highlighting the effects on blood flow when 

external compression is applied to an extremity. This highlighted information can 

then be viewed using the Data Analyzer, an optional graphing feature that allows 

you to zoom in and print out specific portions of a chart that includes pulse and 

blood flow information. 

 How it works: 

o Enabling the Event feature will add an Event button to the application 

when measurements are being taken. A technician can then click the Event 

button, which will begin recording the event. A clock will appear, 

displaying the seconds that have elapsed since the event began. The 

technician can then click the Event button again to stop recording. When 

the measurements are complete, the technician can view the information 

gathered during the test using the Data Analyzer. The data recorded during 

the event will be highlighted on the graph. 

o Any event highlighted during a measurement will only display when 

opening the test data in the Data Analyzer. Events will not display on the 

Pulse Graph on the report that prints out when the test is complete. 

 In order to use the Event feature, all tests must be saved using the Data Logging 

feature. This saves all tests to a specific directory on a workstation or on a 

network. 

 

2. Setting up the Event and Data Logging features. 

 If you would like to use the Event and Data Logging features, open the Options  

Form using the toolbar at the top of the main application window (Settings> 

Options). 
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 Check the Show Event Button. This will add the Event button to the application 

window when measurements are being taken. The technician can then click this 

button to record the event. 

 

 

 Open the Data Logging tab. 

 Check the Enable Data Logging toggle. 

o The data logging feature saves all pulse and blood flow data in a .csv file. 

These files can then be opened using the Data Analyzer feature (Tools> 

Data Analyzer), where the information can be viewed and printed. 

o The Enable Data Logging toggle must be checked if you are using the 

event feature.  

Illustration 16: Options Form 

Illustration 17: Options Form (Data Logging) 
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 The Path field is used to select where the data logs will be stored. The application 

will create a folder in the selected path titled DataLog. 

 Click the Accept button to save the selections. 

 

3. Record an event. 

 Open a new session from the main application window. 

 Enter the patient information into the Session Form window. 

 Select a test to perform in the New Test Form. 

 Click on a Measure button to take a measurement. 

 

 

 Click the Start button to begin taking measurements on an appendage. 

 Click the Event button to begin recording an event.  

o A timer will display, showing the number of seconds that have elapsed 

since you began recording the event. 

 Click the Event button again to stop recording. 

 

Illustration 18: Measure  
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Using the Session Viewer 
 
All Patient Sessions can be saved using the Patient >Save option.  The user can then 

choose the name and location to save the session file.   

 

To open or review a session you can use the Session Viewer tool.  To open the Viewer 

select  Tools >Session Viewer.  The Session Viewer is shown in Illustration 19. 

 

 Open a file:  Select File >Open to open a recorded session file. 

◦ The file shall open if it a true Session file 

◦ Displayed are: 

▪ Patient Information 

▪ Session Information 

▪ Measurements recorded (checkbox) 

▪ Pulse Data Graph 

▪ Blood Flow Graph 

 The user can show or hide Measurements by checking or unchecking the 

measurements listed in the top right box 

 The user can scroll through the recording using the scroll bar at the bottom of the 

form. 

 To close the current Session select File >Close. 

 To close the Session Viewer select File >Exit. 

 To view the revision of the Viewer select Help >About 

 

 

Illustration 19: Session Viewer 
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Trouble Shooting 
 

Connecting the Reusable Sensor to the Workstation 
 

When the Reusable Sensor is properly connected to the workstation, Connected will 

appear at the bottom of the main FloChec Blood Flow application window. If Connected 

does not appear, make sure the Reusable Sensor is connected to the USB Signal 

Acquisition Device, and the USB Signal Acquisition Device is plugged into a USB port 

on the workstation. If the devices are properly connected and Disconnected still appears 

at the bottom of the main application window, try the following: 

 

1. Close the FloChec application. 

2. Unplug the USB Signal Acquisition Device from the workstation. 

3. Restart the FloChec application. 

4. Plug the USB Signal Acquisition Device back into the workstation, making sure it 

is still connected to the Reusable Sensor. 

 

If this does not work, contact Technical Support at 1.877.SSI.4211. 

 

Recommended Cleaning Instructions 

 

The Reusable Sensor and USB Signal Acquisition Device can be cleaned using a 

T-Spray Transducer Detergent Disinfectant Spray. Other forms of cleaning 

material may damage or cause them to function incorrectly. When cleaning the 

USB Signal Acquisition Device, make sure it is not connected to the workstation. 

 

 

  

Warnings 

 

The device possesses cables between different parts of the device. Precaution 

should be taken towards the placement and movement of the device. These cables 

may also present a tripping hazard and precaution should be taken for placement 

and movement around device. 

 

 

If any damage occurs to the device, unplug it and return it to the manufacturer. 

 

 

Do not tamper or open the device as harm may occur to you. 

 

 

The device is an indicator and should be used in correlation with other 

information about the patient. It is not a diagnostic device. 
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User intervention may be required under certain electrostatic conditions. 

 

 

The device is not specified for use at high atmospheric pressures. 

 

 

The device should not come in contact with liquid except as instructed for 

cleaning. If liquid comes into contact with any connectors or is believed to have 

entered the USB Signal Acquisition Device or Usable Sensor, do not use it. 

Contact the manufacturer and return the device. 

 

 

The results may be subject to motion or movement artifacts. The device was not 

tested on patients with gross tremors. 

 

 

In some cases in diminished pulsatility and bright light, it is advisable to cover the 

Usable Sensor with a dark cloth. 

 

 

System Requirements 

Hardware Software 

 

 1GHz or faster processor with at 

least 256 MB of RAM 

 A 32 or 64 bit architecture 

 At least 100 MB’s of free hard 

drive space, plus additional space if 

any log data will be stored 

 At least (1) USB drive for the USB 

Signal Acquisition Device 

 

 

 Windows XP, Windows Vista, or 

Windows 7 

 Microsoft .NET 3.5 Framework 

 Adobe Acrobat Reader 9.0 or 

higher 

  

Environmental Conditions 
 Operating Conditions 

◦ 40 – 90 F 

◦ 5% - 95% Humidity (non condensing) 

 Storage Conditions 

◦ 20 – 110 F 

◦ 5% - 95% Humidity (non condensing) 

 

Contact Information 

 

If you have any questions, contact Technical Support at 1.877.SSI.4211. 
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Notes 


