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1 Overview 
 

AMIGO (Advanced MIb Group Operator) is a MIB browser that comes with 
AlliedView-EMS. It is a tool for viewing or editing MIB variables on an SNMP 
agent. 

Topics: 

• Starting AMIGO  
• Main Window  
• Menus  

 
1 Overview 
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2 Starting AMIGO 
 

AMIGO can be started from Device Manager or from the command line. In a 
Windows environment, AMIGO can be started from the Start menu or from 
the Run command in the File menu. 

Topics: 

• Starting From the Command Line  
• Configuring AMIGO  
• Starting from Device Manager  

 
2 Starting AMIGO 
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2.1 Starting From the Command Line 
 

The command line interface is the most basic way to start AMIGO. 

Topics: 

• Command Syntax 
• Target Host 
• SNMP Version 
• Get Community 
• Set Community 
• User Account Name 
• Security Level 
• Authentication Protocol 
• Authentication Password 
• Privacy Protocol 
• Privacy Password 
• Configuration File 
• Parameter File 

2.1.1 Command Syntax 

To start AMIGO from the command line, use the following syntax. 

 
Amigo [options] 

 

You can specify the following options. 

TargetHost 
The IP address or hostname of the target host. 
  

SnmpVersion 
SNMP version to be used. 
  

GetCommunity 
SNMP Get community string. This is used to retrieve MIB values. 
  

SetCommunity 
SNMP Set community string. This is used to modify MIB values. 
  

UserName 
User account name to be used for accessing the MIB. This is required 
when using SNMPv3. 
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SecLevel 

Security level that is configured for the User Name. This is required when 
using SNMPv3. 
  

AuthProtocol 
Authentication protocol that is configured for the User Name. This is 
required when using SNMPv3. 
  

AuthPassword 
Authentication password that is configured for the User Name. This is 
required when using SNMPv3. 
  

PrivProtocol 
Privacy protocol that is configured for the User Name. This is required 
when using SNMPv3. 
  

PrivPassword 
Privacy password that is configured for the User Name. This is required 
when using SNMPv3. 
  

xxx.amg file 
The name of the AMIGO configuration file. This has the extension .amg. 

Note - If a configuration file is specified along with the other parameters, the 
contents of the configuration file will take precedence. 

2.1.2 Target Host 

The target host can be specified as a dotted IP address or as a host name. 

Example: 

 
Amigo -TargetHost 172.16.18.34 Amigo -TargetHost dvcmgrhub 

 

2.1.3 SNMP Version 

The Device Manager can use SNMPv1, SNMPv2c and SNMPv3. You may specify 
a value of 1, 2 or 3. If the SNMP Version is not specified, the default value of 1 
(SNMPv1) will be used. 

Examples: 
 

Amigo -TargetHost 172.16.99.123 -SnmpVersion 1 
Amigo -TargetHost 172.16.99.123 -SnmpVersion 2 
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2.1.4 Get Community 

Get Community is an SNMP community string used to get MIB values from the 
agent. You must specify the same community string as the one configured on 
the target host. If the string is not specified, the default community string 
"public" is used. 

Example: 
 

Amigo -TargetHost 172.16.18.34 -GetCommunity dvcmgrget 

 

2.1.5 Set Community 

Set Community is an SNMP community string used to change the values of the 
agents' MIB variables. You must specify the same community string as the one 
configured on the target host. If the string is not specified, the default 
community string "private" is used. 

Example: 
 

Amigo -TargetHost 172.16.18.34 -SetCommunity dvcmgrset 

 

2.1.6 User Account Name 

If you specified 3 (SNMPv3) for the SNMP Version, you must also specify a User 
Account Name that is already configured on the target host. 

Examples: 
 

Amigo -TargetHost 172.16.99.123 -SnmpVersion 3 -UserName AlliedView  
      -SecLevel noAuthNoPriv 
Amigo -TargetHost 172.16.99.123 -SnmpVersion 3 -UserName AlliedView1  
      -SecLevel authNoPriv -AuthProtocol SHA -AuthPassword PASS1233 

 

2.1.7 Security Level 

If you specified 3 (SNMPv3) for the SNMP Version, you must also specify a 
Security Level that is configured for the User Account Name on the target host. 
The available Security Levels are noAuthNoPriv, authNoPriv, and authPriv. 
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Examples: 
 

Amigo -TargetHost 172.16.99.123 -SnmpVersion 3 -UserName AlliedView  
      -SecLevel noAuthNoPriv 
Amigo -TargetHost 172.16.99.123 -SnmpVersion 3 -UserName AlliedView1  
      -SecLevel authNoPriv -AuthProtocol SHA -AuthPassword PASS1233 

 

2.1.8 Authentication Protocol 

If you specified 3 (SNMPv3) for the SNMP Version, and your Security Level is 
authNoPriv or authPriv, then you must specify an Authentication Protocol that is 
configured for the User Account Name on the target host. The available 
Authentication Protocols are MD5 and SHA. 

Examples: 
 

Amigo -TargetHost 172.16.99.123 -SnmpVersion 3 -UserName AlliedView  
      -SecLevel authNoPriv -AuthProtocol MD5 -AuthPassword PASS1234 
Amigo -TargetHost 172.16.99.123 -SnmpVersion 3 -UserName AlliedView1  
      -SecLevel authNoPriv -AuthProtocol SHA -AuthPassword PASS1233 

 

2.1.9 Authentication Password 

If you specified 3 (SNMPv3) for the SNMP Version, and your Security Level is 
authNoPriv or authPriv, then you must specify an Authentication Password that is 
configured for the User Account Name on the target host. 

Examples: 
 

Amigo -TargetHost 172.16.99.123 -SnmpVersion 3 -UserName AlliedView  
      -SecLevel authNoPriv -AuthProtocol MD5 -AuthPassword PASS1234 
Amigo -TargetHost 172.16.99.123 -SnmpVersion 3 -UserName AlliedView1  
      -SecLevel authNoPriv -AuthProtocol SHA -AuthPassword PASS1233 

 

2.1.10 Privacy Protocol 

If you specified 3 (SNMPv3) for the SNMP Version, and your Security Level is 
authPriv, then you must specify a Privacy Protocol that is configured for the User 
Account Name on the target host. The available Privacy Protocol is DES. 
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Examples: 
 

Amigo -TargetHost 172.16.99.123 -SnmpVersion 3 -UserName AlliedView  
      -SecLevel authPriv -AuthProtocol MD5 -AuthPassword PASS1234 
      -PrivProtocol DES -PrivPassword PASS5678 
Amigo -TargetHost 172.16.99.123 -SnmpVersion 3 -UserName AlliedView1  
      -SecLevel authPriv -AuthProtocol SHA -AuthPassword PASS1236 
      -PrivProtocol DES -PrivPassword PASS5675 

 

2.1.11 Privacy Password 

If you specified 3 (SNMPv3) for the SNMP Version, and your Security Level is 
authPriv, then you must specify a Privacy Password that is configured for the User 
Account Name on the target host. 

Examples: 
 

Amigo -TargetHost 172.16.99.123 -SnmpVersion 3 -UserName AlliedView  
      -SecLevel authPriv -AuthProtocol MD5 -AuthPassword PASS1234  
      -PrivProtocol DES -PrivPassword PASS5678 
Amigo -TargetHost 172.16.99.123 -SnmpVersion 3 -UserName AlliedView1  
      -SecLevel authPriv -AuthProtocol SHA -AuthPassword PASS1236  
      -PrivProtocol DES -PrivPassword PASS5675 

 

2.1.12 Configuration File 

The configuration file is created by selecting File > Save As. It contains the 
environment settings for AMIGO. 

Example: 
 

Amigo test.amg 

 

2.1.13 Parameter File 

Parameters can be written in a file. You can specify the file from which AMIGO 
is to read the parameters. The parameter file is a plain text file which contains a 
name-value pair in each line. 
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Example: 
 

Amigo -TargetHost TEST @para1.txt 

 

where para1.txt contains: 

 
      -SetCommunity set 
      -GetCommunity get 

 
2 Starting AMIGO 
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2.2 Configuring AMIGO 

 

AMIGO's general configuration can be changed from the File > Property menu. 
This includes MIB files, target IP addresses or host names, web browser settings, 
and window layout settings. 

When you first run AMIGO, a dialog box opens in which you can enter these 
settings. By default, you can browse the MIB-II tree only. If this is all you require, 
click Cancel to close the dialog box. This configuration can be changed later. 

 
Configuration window for AMIGO 

When you start AMIGO from Device Manager, AMIGO automatically 
configures this information according to the target device. 

 
2 Starting AMIGO 
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2.3 Starting From Device Manager 

 

You can start AMIGO from Device Manager by clicking on Tool > AMIGO or by 
clicking on the AMIGO button on the toolbar. Device Manager automatically 
passes the MIB file information of the target host to AMIGO so that a user can 
browse the MIB tree on the target host without manual configuration. 

 
2 Starting AMIGO 
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3 Main Window 
 

The three panels in AMIGO's main window display related information about 
the SNMP agents and MIB objects on target hosts. This section describes these 
three panels. 

Topics: 

• MIB Tree Panel  
• Detailed Information Panel  
• MIB Operation Panel  

 
Main Window  

The panels can be resized by dragging the borders. 
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3 Main Window 

3.1 MIB Tree Panel 
 

The left half of AMIGO's main window is the "MIB Tree Panel", which shows the 
MIB object structure for the target device. This panel has two tabs, "General 
MIB tree" and "Personal MIB tree". 

Topics: 

• General MIB Tree  
• Personal MIB Tree  
• Target Device  

 
MIB Tree Panel  

3.1.1 General MIB Tree 

The General MIB tree shows the tree structure based on MIB files that are read 
by AMIGO. The general MIB tree cannot be edited. To create your own tree 
structure, use the Personal MIB tree tab. 

3.1.2 Personal MIB Tree 

The Personal MIB tree is a customizable tree of your own. This tree can be 
constructed from any subtree of an existing MIB or any leaf objects copied from 
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the General MIB tree. Using the Personal MIB tree, you can create a tree 
containing only objects that you want to monitor. 

When you first run AMIGO, the Personal MIB tree is empty (root node only). 
To create your own tree, follow the steps below. 

1. On the General MIB tree tab, copy MIB objects to the clipboard by 
selecting Edit > Copy. Select multiple objects by using the Shift or Ctrl 
keys.  

2. On the Personal MIB tree tab, click the place where you want to insert 
the copied objects.  

3. Paste previously copied objects by selecting Edit > Paste.  

Copy and Paste operations can also be done using the toolbar buttons. 

To delete MIB objects from the Personal MIB tree, follow the steps below. 

1. Select the MIB object(s) to delete on the Personal MIB tree.  
2. Select Edit > Delete.  

Note - You cannot paste or delete objects on the General MIB tree. You can only 
copy objects. 

3.1.3 Target Device 

You can add target devices to the General MIB tree. To add a target device, 
open the "Setting target devices" window by selecting File > Target Device. 
Enter the host name, then click Add to include the new target device in the 
General MIB tree. 

Note - You can also add a target device to the General MIB tree by selecting File 
> Property. This opens the "Setting environment for Amigo" window. Click the 
"Setting target devices tab" and add the new target device. 
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Set target device  

Operations on the MIB tree are applied to the currently selected target device. 
To change the current target, click the target device on the General MIB tree 
once. After that, all operations on the tree are applied to the new device until 
another device is selected. 

The currently selected device is displayed in the field under the MIB tree. 

 
3 Main Window 
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3.2 Detailed Information Panel 

 

The Detailed Information Panel is the area at the top right corner of AMIGO's 
main window. It shows detailed information about the MIB object (variable) 
selected in the MIB tree. The information includes the variable name, object 
identifier, syntax and description. 

 
Detailed Information Panel  

 
3 Main Window 
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3.3 MIB Operation Panel 
 

The MIB Operation Panel is the area at the bottom right corner of AMIGO's 
main window. It shows the value of the variables selected in the MIB tree. To 
display the values of the MIB objects, first select the object(s) on the MIB tree 
panel, then select an appropriate SNMP command from the menu bar or 
toolbar. 

In this panel, you can also change (set) the value of the variables. 

Note - The threshold button cannot be used in AMIGO. 

Topics: 

• Checkbox Column 
• MIB Variable Column 
• MIB Value Column 
• Select All Button 
• Clear Button 
• Reverse Button 
• Get MIB Value Button 
• Set MIB Value Button 

 
MIB Operation Panel 

This panel shows a table with the following columns. 

3.3.1 Checkbox Column 

The leftmost column shows whether or not the variable can be changed. If the 
column has a checkbox in it, the variable can be changed. 

To change the value, check the variables to be changed before clicking the Set 
MIB Value button. AMIGO will send the checked values in a batch. 
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3.3.2 MIB Variable Column 

The second column shows the name of the variable. 

3.3.3 MIB Value Column 

The third column shows the value of the variable. If the variable has write-
access, you can input the value to be set in this column. If the variable takes a 
value from a fixed set of values, this column is a drop-down listbox. To change 
the variable value, input or select the value to set/change, check the boxes for 
the variables to change, then click the Set MIB Value button. 

Data displayed in the MIB Value column is not automatically updated. To see 
the latest value, click the Get MIB Value button again. 

Note - To put into effect values entered in the MIB Value column, press the 
Enter key or move the cursor to another column. 

Note - SNMPv3: Depending on the READ VIEW access settings of the User 
Account Name used, there is a possibility that AMIGO may not be able to 
access some MIB values. When this happens, the values for the affected MIB 
variables will be blank. 

3.3.4 Select All Button 

: checks all variables. 

3.3.5 Clear Button 

: unchecks all variables. 

3.3.6 Reverse Button 

: flips the states of all checkboxes, that is, unchecks all variables currently 
selected and checks all variables currently not selected. 

3.3.7 Get MIB Value Button 

: gets the value of the variable selected in the MIB Variable column. 

3.3.8 Set MIB Value Button 

: sets values in the MIB Value column for the variables checked in the 
checkbox column. 
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Note - SNMPv3: Depending on the WRITE VIEW access settings of the User 
Account Name used, there is a possibility that AMIGO may not be able to set 
some MIB values. When this happens, a "No access error." value will be 
displayed on the affected MIB Value cells. 

Note - SNMPv3: When a Set operation is performed using a user account that 
has No Read access but has Write access to the target MIB variable, the error 
message, "No access error." is displayed but the new value is still saved on the 
device. 

 
3 Main Window 
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4 Menus 
 

This section describes AMIGO's menu bar items. These menu commands can 
also be accessed from the toolbar. 

Topics: 

• File  
• Edit  
• Mark  
• SNMP  
• Help  

 
4 Menus 
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4.1 File 
 

From the File menu, you can open, change, or save AMIGO's configuration. 

Topics: 

• New File 
• Open 
• Save 
• Save As 
• Target Device 
• Property 
• Exit 

4.1.1 New File 

Creates a new configuration file. Selecting File > New File opens the "Setting 
environment for AMIGO" window. Specify appropriate parameters in this 
dialog box then click OK. You can specify which MIB files to use, which device to 
browse, which web browser to use to view the online manual, and the 
appearance of AMIGO. 

4.1.2 Open 

Opens a previously created AMIGO configuration file (.amg). 

4.1.3 Save 

Saves the current configuration to an existing file. 

4.1.4 Save As 

Saves the current configuration to a file. 

4.1.5 Target Device 

Opens the "Setting target devices" dialog box. Use this dialog box to add a 
target device to the General MIB tree in AMIGO's main window. 

4.1.6 Property 

Changes the AMIGO configuration. The "Setting environment for AMIGO" 
dialog box opens. The dialog box has the following tabs. 
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4.1.6.1 Setting MIB-Files Tab 

In the Setting MIB-Files tab, you can specify which MIB files AMIGO uses to 
draw the MIB tree. To add a MIB file, enter a file name in the MIB-File name 
textbox then click Add or select a MIB file using the Browse button. To remove 
a MIB file, select a file from the list then click Delete. 

Auto Add 
Using the "Auto Add" button, you can automatically add the MIB files 
which are required to manage the target device. When you click "Auto 
Add", MIB files which are needed by the target hosts specified in the 
"Setting target devices" tab are added to the MIB files list. 
  
You can automatically add MIB files only if the target device is supported 
by AlliedView-EMS. 

 
Select MIB-Files tab 

4.1.6.2 Setting Target Devices Tab 

In the "Setting target devices" tab, you can add or remove a target device 
to/from which MIB values are set or retrieved. You can also configure the SNMP 
connection properties of a target device. 
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To add a target device, input a dotted IP address or a host name in the Host 
name textbox, then click Add. 

To change the properties of a specific target device, select the target device 
from the list, then click the Property button. The "Target host property" dialog 
box opens. Change the properties, then click OK. 

To remove a target device from the list, select a device in the list then click 
Delete. 

 
Setting target devices tab 

4.1.6.3 Target Host Property 

In the "Target Host Property" dialog box, you can change various properties for 
a specific target device by selecting a host, then clicking on the Property button. 

Timeout  
The time in seconds before AMIGO determines that the target device is 
not responding. 
  

Retry count  
The number of SNMP messages to send before giving up. 
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Port number  

The UDP port number on which the target device is listening for SNMP 
messages. If the target device is using a non-standard port for SNMP 
operations, you must change this value. 
  

SNMP version  
The version of SNMP that the device will use to send and receive device 
information. After choosing the version of SNMP to use, click on the 
Settings button to specify the SNMP parameters that correspond with 
the chosen version. If the SNMP version is set to "v1" or "v2c", then the 
SNMP v1/v2c Settings dialog box will be displayed. Otherwise, if the 
SNMP version is set to "v3", then the SNMP v3 Settings dialog box will be 
displayed. 
  

 
Target Host Property dialog box 

4.1.6.3.1 SNMP v1 / v2c Settings 

Community for read/Community for write  
The community strings used to perform SNMP operations on the device. 
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SNMP v1/v2c Settings dialog box 

4.1.6.3.2 SNMP v3 Settings 

User Account Name  
This is the SNMPv3 User Account to be used for accessing the MIB of the 
target device. Make sure to specify a User Account that has already been 
configured on the target device. 
 

Security Level  
This is the Security Level for the User Account Name that you have 
specified. Make sure to set the Security Level to be the same as what is 
configured on the target device. 
These are the available Security Levels: 
 
No Auth / No Priv  

This Security Level uses no authentication and no privacy. 
 
Auth / No Priv  

This Security Level uses authentication without privacy. 
 
Auth / Priv  

This Security Level uses authentication and privacy. 
 

Authentication Protocol  
If the Security Level is "Auth / No Priv" or " Auth / Priv", you need to 
specify an Authentication Protocol. Make sure to set the Authentication 
Protocol to be the same as what is configured on the target device. 
 
These are the available Authentication Protocols: 
 
MD5  

Use HMAC-MD5-96 protocol 
 
SHA  

Use HMAC-SHA-96 protocol 
 

Authentication Password  
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If the Security Level is "Auth / No Priv" or " Auth / Priv", you need to 
specify an Authentication Password. Make sure to set the Authentication 
Password to be the same as what is configured on the target device. 
 

Privacy Protocol  
If the Security Level is "Auth / Priv", you need to specify a Privacy 
Protocol. 
 
This is the available Privacy Protocol: 
 
DES  
Use Data Encryption Standard 
 

Privacy Password  
If the Security Level is "Auth / Priv", you need to specify a Privacy 
Password. Make sure to set the Privacy Password to be the same as what 
is configured on the target device. 

 
SNMP v3 Settings dialog box  

4.1.6.4 Setting WWW Browser Tab 

In the "Setting WWW browser" tab, you can specify the path of the web 
browser to use for viewing the online user's guide. 
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Setting WWW browser tab 

4.1.6.5 Window Layout Setting Tab 

In the "Window layout setting" tab, you can customize the appearance of 
AMIGO windows and the way information is displayed in the windows. To 
access each of the following submenus, select a node in the "How to show 
Amigo" tree. The submenu options appear on the right side of the dialog box. 

4.1.6.5.1 How to Show AMIGO 

You can specify the "look and feel" of the AMIGO windows and dialog boxes. 
Your options are Windows, CDE/Motif, and Metal. 
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Window display options for AMIGO 

4.1.6.5.2 Toolbar Area 

You can select the appearance of the toolbar buttons. 
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Toolbar area submenu 

4.1.6.5.3 MIB Tree Panel 

You can change the placement for the MIB Tree Panel, Detailed Information 
Panel, and MIB Operation Panel. 
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MIB tree panel submenu 

4.1.6.5.4 Personal MIB Tree Area / General MIB Tree Area 

You can change the background colors for each of the MIB tree panels. 
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Background color setting 

4.1.6.5.5 MIB Node Description Area 

You can choose how to display the text in the Detailed Information Panel in the 
main window of AMIGO. You also have the option to change the background 
color of the panel. 
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Detailed information panel settings 

4.1.6.5.6 MIB Operation Panel Submenu 

You can select the format of the MIB variable name in the MIB Operation Panel. 
This is the same as the Option > Option > Other tab of Device Manager. You 
also have the option to show or hide the MIB Operation Panel in/from the main 
window of AMIGO. 

4.1.6.5.7 Omit Display 

Check this box if you want to shorten the MIB variable name. Refer to the 
AlliedView-EMS Device Manager User's Guide for more detail. 
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MIB variable name display type 

4.1.7 Exit 

Quit AMIGO. 

 
4 Menus 
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4.2 Edit 
 

From the Edit menu, you can perform copy and paste operations on the MIB 
tree panel. These operations can also be performed by clicking toolbar buttons. 

Topics: 

• Cut  
• Copy  
• Paste  
• Delete  
• Find  

4.2.1 Cut 

Cuts the selected objects from the Personal MIB tree tab. 

4.2.2 Copy 

Copies the selected objects from the General or Personal MIB tree tab to the 
clipboard. Copied objects can be pasted to the Personal MIB tree. 

4.2.3 Paste 

Pastes the copied objects into the Personal MIB tree tab. 

4.2.4 Delete 

Deletes the selected objects from the Personal MIB tree tab. 

4.2.5 Find 

Finds objects in the MIB tree which contain the specified string. When you 
select this menu item, the "Search" dialog box opens. To search for objects, 
input a search string in the Search string textbox, then click Start. When the 
search is finished, all matching objects found are listed at the bottom of the 
dialog box. To jump to one of the objects, select the object, then click the 
"Jump" button. 

AlliedView™-EMS 3.10 AMIGO USERS GUIDE Page 36 of 43

 



 
 
 

       
      

 
Search dialog box 

 
4 Menus 
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4.3 Mark 
 

From the Mark menu, you can mark particular MIB objects for later reference. 
After marking, you can access the object by selecting it from the "Jump to 
mark" menu. 

Topics: 

• Mark  
• Delete Mark  
• Jump to Mark  

4.3.1 Mark 

Adds a mark to the selected MIB object on the MIB tree. To add a mark, select 
the object on the tree, then select Mark > Mark. Marked objects are listed in the 
Mark > Jump to mark menu. 

4.3.2 Delete Mark 

To remove a mark, select Mark > Delete mark. The "Delete mark" dialog box 
opens, containing a list of the currently configured marks. Select the mark to be 
deleted, then click Delete. If you want to delete all marks, click the Delete all 
button. 

 
Delete mark dialog box  

4.3.3 Jump to Mark 

To jump to a marked object on the tree, select Mark > Jump to mark > [marked 
object]. 

 
4 Menus 
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4.4 SNMP 
 

From the SNMP menu, you can perform the following SNMP operations. 

Topics: 

• Get Values  
• Get Values and Next To  
• Set Values  
• Save Values  
• Load Values From a File  

4.4.1 Get Values 

Gets MIB values for variables selected on the MIB tree. These MIB values are 
retrieved from the SNMP agent on the currently selected device. The currently 
selected device is displayed in the area under the MIB tree. Retrieved values are 
displayed in the MIB Operation Panel. 
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Get SNMP values of selected device 

Note - If you select a node containing many variables, for instance, the whole 
mib-2 subtree, it might take a while to get all the values of these variables.  

4.4.2 Get Values and Next To 

Gets MIB values for the variable or node selected in the MIB tree, then select 
the next variable or node. This is useful when you want to get MIB values 
continuously. 

4.4.3 Set Values 

Sets values to the variables. 
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4.4.4 Save Values 

Saves MIB values to a file. 

4.4.5 Load Values From a File 

Loads MIB values from a file to which AMIGO has saved them, then repeats the 
Get operation previously done.  

 
4 Menus 
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4.5 Help 
 

From the Help menu, you can view the online user's guide and version 
information for AMIGO. 

Topics: 

• Display Help  
• About  

4.5.1 Display Help 

Displays the main page of the online user's manual in your chosen web browser. 
You must first specify the web browser in the "Setting WWW browser" tab of 
the File > Property menu. 

4.5.2 About 

Displays version and copyright information for AMIGO. 

 
4 Menus 
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