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Chapter 1
OVL Checkers Manager Basic Operation

The Open Verification Library (OVL) provides designers, integrators, and verification 
engineers with a single, vendor-independent set of assertion checkers that verify specific 
properties of a design. Using a single, well-defined set of assertion checkers, the OVL makes 
more advanced verification tools and techniques available for non-expert users.

The Questa OVL Checkers Manager simplifies the verification process further by providing a 
graphic interface (Figure 1-1) for accessing, customizing, and compiling OVL assertion 
checkers for SVA, Verilog, PSL (Verilog), and VHDL.

Figure 1-1. The OVL Checkers Manager
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Usage Flow for the OVL Checkers Manager
The recommended usage flow for using the OVL Checkers Manager is described by the 
following steps:

1. Invoke the OVL Checkers Manager.

The OVL Checkers Manager can be invoked from a UNIX/Linux shell or from a 
Windows directory. 

• UNIX/Linux — Access the Questa install directory then type vovl at prompt.

• Windows — Open the win32 or win64 directory the Questa installation directory 
and double-click vovl.exe.

The OVL Checkers Manager currently supports only version 2.6 of the Open 
Verification Library. 

2. Select an implementation language.

The Global Properties dialog (Figure 1-2) allows you to select an implementation 
language for the OVL checkers in your design. 

Open the Global Properties dialog with either of the following methods:

• Click the Global Properties toolbar button. 

• Select Edit > Global Properties from the menus.

Figure 1-2. Select an Implementation Language
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3. Configure the library settings for customizing assertion checkers.

The Settings dialog (Figure 1-3) allows you to configure the location for the OVL Core 
library to be compiled, the Target library for customized assertion checkers, and where a 
copy of the customized OVL Wrapper Files will be stored. You can open the Settings 
dialog with either of the following actions:

• Click the Settings toolbar button. 

• Select Tools > Settings from the menus.

Figure 1-3. Settings Dialog

These setting apply to all customized checkers and will be persistent from one 
invocation of the OVL Checkers Manager to the next.

4. Add an assertion checker to the Customized Checker list.

Right-click any assertion checker from the All Library Checkers list and select 
“Customize” from the popup menu that appears (Figure 1-4).
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Figure 1-4. Right-Click Checker in All Library Checkers List

Or, select any assertion checker in the All Library Checkers list and click the Customize 
Library Checker button in the toolbar. 

The selected assertion will appear in the Customized Checkers list.

5. Review the description, diagram, and usage model in the Description tab.

The Usage Example shows how input and output ports are connected.

Figure 1-5. Description for ovl_fifo_index
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6. Customize the assertion checker in the Properties tab.

Make sure the assertion checker is selected in the Customized Checkers. You can now 
use the Properties tab to edit the available properties (Figure 1-6). 

Figure 1-6. Edit Properties in the Properties Tab

Some properties can be edited by choosing from a drop-down menu (Figure 1-7).

Figure 1-7. Drop-Down Menu Options

Other property values can be edited by highlighting the current value and typing in a 
new one. In Figure 1-6, the depth property was changed to from 1 to 16.
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7. Rename the customized assertion checker. (This step is optional.)

Click any assertion checker in the Customized Checkers list to select it, then open the 
Rename dialog (Figure 1-8) with any of the following three actions:

• Select Checker > Rename from the menus.

• Click the Rename button in the toolbar. 

• Right-click the selected checker and choose Rename from the popup menu.

Figure 1-8. Rename Dialog

8. Compile customized assertion checkers.

You can compile a single checker in the Customized Checkers list by selecting it, then 
taking any of the following actions:

• Select Checker > Compile from the menus.

• Click the Compile button in the toolbar. 

• Right-click the selected checker and choose Compile from the popup menu.

Figure 1-9. Right-Click Compile Selection

You can compile all assertion checkers in the Customized Checkers list with either of 
the following:

• Select Checker > Compile All from the menus.

• Click the Compile All button in the toolbar. 

The Transcript Window will display the progress of compile operations (Figure 1-10).
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Figure 1-10. Compile Operations Displayed in Transcript

9. Save customized assertion checkers to a .xml file.

• Select File > Save or File > Save As from the menus.

• Click the Save button in the toolbar. 

10. Create an instance of the customized assertion checker(s) in your code and compile the 
code.

Handling Compile Errors
If a compile operation fails, any compile errors will be displayed in red text in the Transcript 
window.

Figure 1-11. Errors Appear in Red Text in Transcript
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You can double-click any error text to open a Source Code Editor to the relevant place within 
your code.

Figure 1-12. Source Code Editor

After correcting a bad parameter value that generated the error, you can save the corrected code, 
and recompile.

Using Tooltips
The OVL Checkers Manager provides popup tooltips to display compile status when you hover 
the mouse cursor over OVL assertions checker names in the All Library Checkers list or the 
Customized Checkers list (Figure 1-13).

Figure 1-13. Tooltips Reveal Compile Status



OVL Checkers Manager Basic Operation
Related Reading

OVL Checkers Manager User’s Guide, v10.2c 15
 

You can also hover the mouse over any property name in the Properties tab to reveal 
information about a specific property (Figure 1-14).

Figure 1-14. Tooltips for Properties

Related Reading
A PDF file of the Open Verification Library Language Reference Manual can be found in:

<your_install_directory>\verilog_src\std_ovl\docs

or,

<your_install_directory>\vhdl_src\std_ovl\docs

In the same directory you will find an assertion and an OVL Quick Guide (in pdf format) as well 
as assertion and OVL timing diagrams.
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Chapter 2
Graphical User Interface (GUI)

The OVL Checkers Manager GUI is composed of two windows — an OVL Manager window 
(Figure 2-1) and a Transcript window.

The OVL Manager window includes:

• All Library Checkers List — displays a list of all available OVL Checkers for the 
selected language.

• Customized Checkers List — displays a list of Customized Checkers created from the 
standard OVL assertion checkers.

• Properties Workspace — displays a workspace where checker properties can be edited 
to create customized assertion checkers.

• Description Tab — displays a description of the OVL checker which includes the 
datasheet model and a usage example.

Figure 2-1. OVL Manager Window

The Transcript window displays commands that are invoked and messages that occur as you 
work with the OVL Manager.
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The GUI also contains toolbars and menus for operating the OVL Checkers Manager and 
customizing assertion checkers.

OVL Manager Window

All Library Checkers List
The All Library Checkers list contains all OVL checkers available in Version 2.6 of the OVL 
software for the selected implementation language. The number of checkers available for each 
language is indicated in parenthesis. For example, 55 OVL checkers are available for SVA 
implementations and 33 are available for VHDL (Figure 2-2).

Figure 2-2. Library Checkers List

The implementation language is selected in the Global Properties dialog, which is invoked by 
either of the following actions:

• Click the Global Properties button in the toolbar.  

• Select Edit > Global Properties from the menus.

This opens the Global Properties dialog where you can select your implementation language 
from a drop-down list in the Language field (Figure 2-3).

SVA Checkers VHDL Checkers
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Figure 2-3. Select a Language

Customized Checkers List
The Customized Checkers list contains the OVL checkers that have been added from the All 
Library Checkers list. Four colors are used for the checker names in this list to indicate the 
compiled status of the checker (Figure 2-4):

• Light Gray indicates when the checker is not supported for the selected language

• Red indicates a checker that failed to compile and an error is reported in the transcript.

• Black indicates a checker that compiled successfully.

• Blue indicates a checker that is uncompiled.

Figure 2-4. Colors Indicate Compiled Status

You can add checkers to the Customized Checkers list by selecting a checker from the All 
Library Checkers list then clicking the Customize Library Checker button in the toolbar. 

You can remove checkers from the Customized Checkers list by selecting a checker in the list 
and clicking the Remove Customized Checker button in the toolbar. 
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Properties Workspace
The Properties tab allows you to customize OVL assertion checkers to meet your specifications. 
Properties Tab

The Properties tab displays the properties of the selected OVL assertion checker. When an 
assertion checker is selected in the All Library Checkers list the Property Value fields in the 
Properties tab are grayed out and the values cannot be edited (Figure 2-5).

Figure 2-5. Property Value Cannot Be Edited

When an assertion checker is selected in the Customized Checkers list the Property Value 
fields are white and the property values can be edited to create a customized checker 
(Figure 2-6).

Figure 2-6. Property Value Can Be Edited

Some property values can be edited by simply selecting a different value from a drop-down 
menu of options (Figure 2-7).
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Figure 2-7. Drop-Down Menu Options for Properties

Other property values can be edited by highlighting the current value and typing in a new one. If 
you enter an incorrect value for a property, an Information icon appears immediately next to the 
value field. 

If you hover the mouse cursor over the icon a tooltip appears, as shown in Figure 2-8, indicating 
the error.

Figure 2-8. Information Icon Tooltip

Description Tab
The Description tab (Figure 2-9)simply allows you to view the data sheet model as presented in 
the OVL Language Reference Manual (LRM), and a usage example. It cannot be edited. A PDF 
file of the OVL LRM, version 2.6 can be found in:

<install_dir>/verilog_src/std_ovl/docs/

or,

<install_dir>/vhdl_src/std_ovl/docs/
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Figure 2-9. The Description Tab

Toolbars
Two toolbars are available with the OVL Checkers Manager – a Standard toolbar and a Checker 
toolbar. 

Figure 2-10. Standard Toolbar

Table 2-1. Standard Toolbar Buttons 

Button Name Menu Shortcuts Description

New File > New Opens a new OVL Checker Manager
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Figure 2-11. Checker Toolbar

Open File > Open Opens the last library where you 
have saved OVL assertion checkers

Save File > Save Saves the selected OVL assertion 
checker to the library you designate

Table 2-2. Checker Toolbar Buttons 

Button Name Menu Shortcuts Description

Compile Checker > Compile Compile the selected assertion 
checker in the Customized Checkers 
list

Compile All Checker > Compile All Compile all assertion checkers in the 
Customized Checkers list

Customize 
Library Checker

Checker > Customize Add the selected assertion checker 
(in the All Library Checkers list) to 
the Customized Checkers list

Remove 
Customized 
Checker

Checker > Remove Remove the selected assertion 
checker from the Customized 
Checkers list

Rename 
Customized 
Checker

Checker > Rename Rename the selected assertion 
checker in the Customized Checkers 
list

Global Properties Checker > Global 
Properties

Opens the Global Properties dialog

Settings Tools > Settings Opens the Settings dialog where you 
can configure OVL Core, Target, and 
Wrapper Files libraries

Table 2-1. Standard Toolbar Buttons (cont.)

Button Name Menu Shortcuts Description
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Menus
The OVL Checkers Manager contains a number of menus to aid in customizing and compiling 
OVL assertion checkers.

File Menu

Checker Menu

Table 2-3. File Menu — Item Description 

Menu Item Description

New Open new OVL Checkers Manager

Open Opens the last library where you have saved OVL assertion 
checkers.

Save
Save as

Saves the selected OVL assertion checker to the library you 
designate

Close Window Close the current active window

Quit Quit the application

Table 2-4. Checker Menu — Item Description 

Menu Item Description

Compile Compile selected assertion checker in Customized Checkers 
list

Compile All Compile all assertion checkers in Customized Checkers list

Customize Add the selected assertion checker (in the All Library Checkers 
list) to the Customized Checkers list

Remove Remove the selected assertion checker from the Customized 
Checkers list

Rename Rename the selected assertion checker in the Customized 
Checker list

Global Properties Open the Global Properties dialog
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View Menu

Transcript Menu

Table 2-5. View Menu — Item Description 

Menu Item Description

OVL Manager Displays the OVL Manager section of the OVL Checkers 
Manager GUI

Transcript Displays the Transcript in the OVL Checkers Manager GUI

Table 2-6. Transcript Menu — Item Description

Menu Item Description

Adjust Font Scaling Displays the Adjust Scaling dialog box, which allows you to 
adjust how fonts appear for your display environment. 
Directions are available in the dialog box.

Transcript File Allows you to change the default name used when saving the 
transcript file. The saved transcript file will contain all the text 
in the current transcript file.

Command History Allows you to change the default name used when saving 
command history information. This file is saved at the same 
time as the transcript file.

Save File Allows you to change the default name used when selecting 
File > Save As.

Saved Lines Allows you to change how many lines of text are saved in the 
transcript window. Setting this value to zero (0) saves all lines.

Line Prefix Allows you to change the character(s) that precedes the lines in 
the transcript.

Update Rate Allows you to change the length of time (in ms) between 
transcript refreshes.

OVL Checkers Manager 
Prompt

Allows you to change the string used for the command line 
prompt.

VSIM Prompt Allows you to change the string used for the simulation 
prompt.

Paused Prompt Allows you to change the string used for when the simulation 
is paused.
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Tools Menu

Window Menu

Help Menu

Table 2-7. Tools Menu — Item Description 

Menu Item Description

Settings Open the Settings dialog where you can configure the OVL 
Core, Target, and Wrapper Files libraries.

Table 2-8. Window Menu — Item Description 

Menu Item Description

Cascade
Tile Horizontally
Tile Vertically

Arrange all undocked windows. These options do not impact 
any docked windows.

Icon Children
Icon All
Deicon All

Minimize (Icon) or Maximize (Deicon) undocked windows. 
These options do not impact any docked windows.

Keyboard Shortcuts Opens the Keyboard Shortcuts dialog box where you may 
create Keyboard Shortcuts.

Customize Toolbar Add a button to the toolbar frame.

window name Make the selected window active.

Windows Display the Windows dialog box, which allows you to activate, 
close or undock the selected window(s).

Table 2-9. Help Menu — Item Description 

Menu Item Description

About Display OVL Checkers Manager application information.

Command Completion Toggles the command completion dropdown box in the 
transcript window.
When you start typing a command at the Transcript prompt, a 
dropdown box appears which lists the available commands 
matching what has been typed so far. You may use the Up and 
Down arrow keys or the mouse to select the desired command. 
When a unique command has been entered, the command 
usage is presented in the drop down box.

User Manual Open the PDF version of the User’s Manual.
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Right-Click Menus
You can click the right-mouse-button on a library checker or a customized checker to invoke a 
related operation. When you right-click a checker in the All Library Checkers list the Customize 
selection allows you to add it to the Customize Checkers list (Figure 2-12).

Figure 2-12. Right-Click Menu in the All Library Checkers List

The right-click menu in the Customized Checkers list gives you the option to Compile, Rename, 
or Remove the selected assertion checker (Figure 2-13).

Figure 2-13. Right-Click Menu in the Customized Checkers List

Tcl Help Open the Tcl command reference (man pages) in Windows 
help format.

Tcl Syntax Open the Tcl syntax documentation in your web browser.

Tcl Man pages Open the Tcl/Tk manual in your web browser.

Table 2-9. Help Menu — Item Description (cont.)

Menu Item Description
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End-User License Agreement

The latest version of the End-User License Agreement is available on-line at:
www.mentor.com/eula

END-USER LICENSE AGREEMENT (“Agreement”)

This is a legal agreement concerning the use of Software (as defined in Section 2) and hardware (collectively “Products”)
between the company acquiring the Products (“Customer”), and the Mentor Graphics entity that issued the
corresponding quotation or, if no quotation was issued, the applicable local Mentor Graphics entity (“Mentor
Graphics”). Except for license agreements related to the subject matter of this license agreement which are physically
signed by Customer and an authorized representative of Mentor Graphics, this Agreement and the applicable quotation
contain the parties’ entire understanding relating to the subject matter and supersede all prior or contemporaneous
agreements. If Customer does not agree to these terms and conditions, promptly return or, in the case of Software
received electronically, certify destruction of Software and all accompanying items within five days after receipt of
Software and receive a full refund of any license fee paid. 

1. ORDERS, FEES AND PAYMENT. 

1.1. To the extent Customer (or if agreed by Mentor Graphics, Customer’s appointed third party buying agent) places and
Mentor Graphics accepts purchase orders pursuant to this Agreement (“Order(s)”), each Order will constitute a contract
between Customer and Mentor Graphics, which shall be governed solely and exclusively by the terms and conditions of
this Agreement, any applicable addenda and the applicable quotation, whether or not these documents are referenced on the
Order. Any additional or conflicting terms and conditions appearing on an Order or presented via any electronic portal or
other automated order management system will not be effective unless agreed in writing by an authorized representative of
Customer and Mentor Graphics.

1.2. Amounts invoiced will be paid, in the currency specified on the applicable invoice, within 30 days from the date of such
invoice. Any past due invoices will be subject to the imposition of interest charges in the amount of one and one-half
percent per month or the applicable legal rate currently in effect, whichever is lower. Prices do not include freight,
insurance, customs duties, taxes or other similar charges, which Mentor Graphics will state separately in the applicable
invoice(s). Unless timely provided with a valid certificate of exemption or other evidence that items are not taxable, Mentor
Graphics will invoice Customer for all applicable taxes including, but not limited to, VAT, GST, sales tax, consumption tax
and service tax. Customer will make all payments free and clear of, and without reduction for, any withholding or other
taxes; any such taxes imposed on payments by Customer hereunder will be Customer’s sole responsibility. If Customer
appoints a third party to place purchase orders and/or make payments on Customer’s behalf, Customer shall be liable for
payment under Orders placed by such third party in the event of default.

1.3. All Products are delivered FCA factory (Incoterms 2010), freight prepaid and invoiced to Customer, except Software
delivered electronically, which shall be deemed delivered when made available to Customer for download. Mentor
Graphics retains a security interest in all Products delivered under this Agreement, to secure payment of the purchase price
of such Products, and Customer agrees to sign any documents that Mentor Graphics determines to be necessary or
convenient for use in filing or perfecting such security interest. Mentor Graphics’ delivery of Software by electronic means
is subject to Customer’s provision of both a primary and an alternate e-mail address.

2. GRANT OF LICENSE. The software installed, downloaded, or otherwise acquired by Customer under this Agreement,
including any updates, modifications, revisions, copies, documentation and design data (“Software”) are copyrighted, trade
secret and confidential information of Mentor Graphics or its licensors, who maintain exclusive title to all Software and retain
all rights not expressly granted by this Agreement. Mentor Graphics grants to Customer, subject to payment of applicable
license fees, a nontransferable, nonexclusive license to use Software solely: (a) in machine-readable, object-code form (except
as provided in Subsection 5.2); (b) for Customer’s internal business purposes; (c) for the term of the license; and (d) on the
computer hardware and at the site authorized by Mentor Graphics. A site is restricted to a one-half mile (800 meter) radius.
Customer may have Software temporarily used by an employee for telecommuting purposes from locations other than a
Customer office, such as the employee’s residence, an airport or hotel, provided that such employee’s primary place of
employment is the site where the Software is authorized for use. Mentor Graphics’ standard policies and programs, which vary
depending on Software, license fees paid or services purchased, apply to the following: (a) relocation of Software; (b) use of
Software, which may be limited, for example, to execution of a single session by a single user on the authorized hardware or for
a restricted period of time (such limitations may be technically implemented through the use of authorization codes or similar
devices); and (c) support services provided, including eligibility to receive telephone support, updates, modifications, and
revisions. For the avoidance of doubt, if Customer provides any feedback or requests any change or enhancement to Products,

 IMPORTANT INFORMATION 

USE OF ALL SOFTWARE IS SUBJECT TO LICENSE RESTRICTIONS. CAREFULLY READ THIS LICENSE 
AGREEMENT BEFORE USING THE PRODUCTS. USE OF SOFTWARE INDICATES CUSTOMER’S 

COMPLETE AND UNCONDITIONAL ACCEPTANCE OF THE TERMS AND CONDITIONS SET FORTH IN 
THIS AGREEMENT. ANY ADDITIONAL OR DIFFERENT PURCHASE ORDER TERMS AND CONDITIONS 

SHALL NOT APPLY.

http://www.mentor.com/eula


whether in the course of receiving support or consulting services, evaluating Products, performing beta testing or otherwise, any
inventions, product improvements, modifications or developments made by Mentor Graphics (at Mentor Graphics’ sole
discretion) will be the exclusive property of Mentor Graphics.

3. ESC SOFTWARE. If Customer purchases a license to use development or prototyping tools of Mentor Graphics’ Embedded
Software Channel (“ESC”), Mentor Graphics grants to Customer a nontransferable, nonexclusive license to reproduce and
distribute executable files created using ESC compilers, including the ESC run-time libraries distributed with ESC C and C++
compiler Software that are linked into a composite program as an integral part of Customer’s compiled computer program,
provided that Customer distributes these files only in conjunction with Customer’s compiled computer program. Mentor
Graphics does NOT grant Customer any right to duplicate, incorporate or embed copies of Mentor Graphics’ real-time operating
systems or other embedded software products into Customer’s products or applications without first signing or otherwise
agreeing to a separate agreement with Mentor Graphics for such purpose.

4. BETA CODE. 

4.1. Portions or all of certain Software may contain code for experimental testing and evaluation (which may be either alpha or
beta, collectively “Beta Code”), which may not be used without Mentor Graphics’ explicit authorization. Upon Mentor
Graphics’ authorization, Mentor Graphics grants to Customer a temporary, nontransferable, nonexclusive license for
experimental use to test and evaluate the Beta Code without charge for a limited period of time specified by Mentor
Graphics. This grant and Customer’s use of the Beta Code shall not be construed as marketing or offering to sell a license
to the Beta Code, which Mentor Graphics may choose not to release commercially in any form.

4.2. If Mentor Graphics authorizes Customer to use the Beta Code, Customer agrees to evaluate and test the Beta Code under
normal conditions as directed by Mentor Graphics. Customer will contact Mentor Graphics periodically during Customer’s
use of the Beta Code to discuss any malfunctions or suggested improvements. Upon completion of Customer’s evaluation
and testing, Customer will send to Mentor Graphics a written evaluation of the Beta Code, including its strengths,
weaknesses and recommended improvements.

4.3. Customer agrees to maintain Beta Code in confidence and shall restrict access to the Beta Code, including the methods and
concepts utilized therein, solely to those employees and Customer location(s) authorized by Mentor Graphics to perform
beta testing. Customer agrees that any written evaluations and all inventions, product improvements, modifications or
developments that Mentor Graphics conceived or made during or subsequent to this Agreement, including those based
partly or wholly on Customer’s feedback, will be the exclusive property of Mentor Graphics. Mentor Graphics will have
exclusive rights, title and interest in all such property. The provisions of this Subsection 4.3 shall survive termination of
this Agreement.

5. RESTRICTIONS ON USE. 

5.1. Customer may copy Software only as reasonably necessary to support the authorized use. Each copy must include all
notices and legends embedded in Software and affixed to its medium and container as received from Mentor Graphics. All
copies shall remain the property of Mentor Graphics or its licensors. Customer shall maintain a record of the number and
primary location of all copies of Software, including copies merged with other software, and shall make those records
available to Mentor Graphics upon request. Customer shall not make Products available in any form to any person other
than Customer’s employees and on-site contractors, excluding Mentor Graphics competitors, whose job performance
requires access and who are under obligations of confidentiality. Customer shall take appropriate action to protect the
confidentiality of Products and ensure that any person permitted access does not disclose or use Products except as
permitted by this Agreement. Customer shall give Mentor Graphics written notice of any unauthorized disclosure or use of
the Products as soon as Customer becomes aware of such unauthorized disclosure or use. Except as otherwise permitted for
purposes of interoperability as specified by applicable and mandatory local law, Customer shall not reverse-assemble,
reverse-compile, reverse-engineer or in any way derive any source code from Software. Log files, data files, rule files and
script files generated by or for the Software (collectively “Files”), including without limitation files containing Standard
Verification Rule Format (“SVRF”) and Tcl Verification Format (“TVF”) which are Mentor Graphics’ proprietary
syntaxes for expressing process rules, constitute or include confidential information of Mentor Graphics. Customer may
share Files with third parties, excluding Mentor Graphics competitors, provided that the confidentiality of such Files is
protected by written agreement at least as well as Customer protects other information of a similar nature or importance,
but in any case with at least reasonable care. Customer may use Files containing SVRF or TVF only with Mentor Graphics
products. Under no circumstances shall Customer use Software or Files or allow their use for the purpose of developing,
enhancing or marketing any product that is in any way competitive with Software, or disclose to any third party the results
of, or information pertaining to, any benchmark.

5.2. If any Software or portions thereof are provided in source code form, Customer will use the source code only to correct
software errors and enhance or modify the Software for the authorized use. Customer shall not disclose or permit disclosure
of source code, in whole or in part, including any of its methods or concepts, to anyone except Customer’s employees or
on-site contractors, excluding Mentor Graphics competitors, with a need to know. Customer shall not copy or compile
source code in any manner except to support this authorized use.

5.3. Customer may not assign this Agreement or the rights and duties under it, or relocate, sublicense or otherwise transfer the
Products, whether by operation of law or otherwise (“Attempted Transfer”), without Mentor Graphics’ prior written
consent and payment of Mentor Graphics’ then-current applicable relocation and/or transfer fees. Any Attempted Transfer
without Mentor Graphics’ prior written consent shall be a material breach of this Agreement and may, at Mentor Graphics’
option, result in the immediate termination of the Agreement and/or the licenses granted under this Agreement. The terms



of this Agreement, including without limitation the licensing and assignment provisions, shall be binding upon Customer’s
permitted successors in interest and assigns.

5.4. The provisions of this Section 5 shall survive the termination of this Agreement.

6. SUPPORT SERVICES. To the extent Customer purchases support services, Mentor Graphics will provide Customer with
updates and technical support for the Products, at the Customer site(s) for which support is purchased, in accordance with
Mentor Graphics’ then current End-User Support Terms located at http://supportnet.mentor.com/about/legal/.

7. LIMITED WARRANTY. 

7.1. Mentor Graphics warrants that during the warranty period its standard, generally supported Products, when properly
installed, will substantially conform to the functional specifications set forth in the applicable user manual. Mentor
Graphics does not warrant that Products will meet Customer’s requirements or that operation of Products will be
uninterrupted or error free. The warranty period is 90 days starting on the 15th day after delivery or upon installation,
whichever first occurs. Customer must notify Mentor Graphics in writing of any nonconformity within the warranty period.
For the avoidance of doubt, this warranty applies only to the initial shipment of Software under an Order and does not
renew or reset, for example, with the delivery of (a) Software updates or (b) authorization codes or alternate Software under
a transaction involving Software re-mix. This warranty shall not be valid if Products have been subject to misuse,
unauthorized modification, improper installation or Customer is not in compliance with this Agreement. MENTOR
GRAPHICS’ ENTIRE LIABILITY AND CUSTOMER’S EXCLUSIVE REMEDY SHALL BE, AT MENTOR
GRAPHICS’ OPTION, EITHER (A) REFUND OF THE PRICE PAID UPON RETURN OF THE PRODUCTS TO
MENTOR GRAPHICS OR (B) MODIFICATION OR REPLACEMENT OF THE PRODUCTS THAT DO NOT MEET
THIS LIMITED WARRANTY. MENTOR GRAPHICS MAKES NO WARRANTIES WITH RESPECT TO:
(A) SERVICES; (B) PRODUCTS PROVIDED AT NO CHARGE; OR (C) BETA CODE; ALL OF WHICH ARE
PROVIDED “AS IS.”

7.2. THE WARRANTIES SET FORTH IN THIS SECTION 7 ARE EXCLUSIVE. NEITHER MENTOR GRAPHICS NOR
ITS LICENSORS MAKE ANY OTHER WARRANTIES EXPRESS, IMPLIED OR STATUTORY, WITH RESPECT TO
PRODUCTS PROVIDED UNDER THIS AGREEMENT. MENTOR GRAPHICS AND ITS LICENSORS
SPECIFICALLY DISCLAIM ALL IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE AND NON-INFRINGEMENT OF INTELLECTUAL PROPERTY.

8. LIMITATION OF LIABILITY. EXCEPT WHERE THIS EXCLUSION OR RESTRICTION OF LIABILITY WOULD BE
VOID OR INEFFECTIVE UNDER APPLICABLE LAW, IN NO EVENT SHALL MENTOR GRAPHICS OR ITS
LICENSORS BE LIABLE FOR INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES (INCLUDING
LOST PROFITS OR SAVINGS) WHETHER BASED ON CONTRACT, TORT OR ANY OTHER LEGAL THEORY, EVEN
IF MENTOR GRAPHICS OR ITS LICENSORS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN
NO EVENT SHALL MENTOR GRAPHICS’ OR ITS LICENSORS’ LIABILITY UNDER THIS AGREEMENT EXCEED
THE AMOUNT RECEIVED FROM CUSTOMER FOR THE HARDWARE, SOFTWARE LICENSE OR SERVICE GIVING
RISE TO THE CLAIM. IN THE CASE WHERE NO AMOUNT WAS PAID, MENTOR GRAPHICS AND ITS LICENSORS
SHALL HAVE NO LIABILITY FOR ANY DAMAGES WHATSOEVER. THE PROVISIONS OF THIS SECTION 8 SHALL
SURVIVE THE TERMINATION OF THIS AGREEMENT.

9. HAZARDOUS APPLICATIONS. CUSTOMER ACKNOWLEDGES IT IS SOLELY RESPONSIBLE FOR TESTING ITS
PRODUCTS USED IN APPLICATIONS WHERE THE FAILURE OR INACCURACY OF ITS PRODUCTS MIGHT
RESULT IN DEATH OR PERSONAL INJURY (“HAZARDOUS APPLICATIONS”). EXCEPT TO THE EXTENT THIS
EXCLUSION OR RESTRICTION OF LIABILITY WOULD BE VOID OR INEFFECTIVE UNDER APPLICABLE LAW, IN
NO EVENT SHALL MENTOR GRAPHICS OR ITS LICENSORS BE LIABLE FOR ANY DAMAGES RESULTING FROM
OR IN CONNECTION WITH THE USE OF MENTOR GRAPHICS PRODUCTS IN OR FOR HAZARDOUS
APPLICATIONS. THE PROVISIONS OF THIS SECTION 9 SHALL SURVIVE THE TERMINATION OF THIS
AGREEMENT.

10. INDEMNIFICATION. CUSTOMER AGREES TO INDEMNIFY AND HOLD HARMLESS MENTOR GRAPHICS AND
ITS LICENSORS FROM ANY CLAIMS, LOSS, COST, DAMAGE, EXPENSE OR LIABILITY, INCLUDING
ATTORNEYS’ FEES, ARISING OUT OF OR IN CONNECTION WITH THE USE OF MENTOR GRAPHICS PRODUCTS
IN OR FOR HAZARDOUS APPLICATIONS. THE PROVISIONS OF THIS SECTION 10 SHALL SURVIVE THE
TERMINATION OF THIS AGREEMENT.

11. INFRINGEMENT. 

11.1. Mentor Graphics will defend or settle, at its option and expense, any action brought against Customer in the United States,
Canada, Japan, or member state of the European Union which alleges that any standard, generally supported Product
acquired by Customer hereunder infringes a patent or copyright or misappropriates a trade secret in such jurisdiction.
Mentor Graphics will pay costs and damages finally awarded against Customer that are attributable to such action.
Customer understands and agrees that as conditions to Mentor Graphics’ obligations under this section Customer must:
(a) notify Mentor Graphics promptly in writing of the action; (b) provide Mentor Graphics all reasonable information and
assistance to settle or defend the action; and (c) grant Mentor Graphics sole authority and control of the defense or
settlement of the action.

http://supportnet.mentor.com/about/legal/


11.2. If a claim is made under Subsection 11.1 Mentor Graphics may, at its option and expense: (a) replace or modify the Product
so that it becomes noninfringing; (b) procure for Customer the right to continue using the Product; or (c) require the return
of the Product and refund to Customer any purchase price or license fee paid, less a reasonable allowance for use.

11.3. Mentor Graphics has no liability to Customer if the action is based upon: (a) the combination of Software or hardware with
any product not furnished by Mentor Graphics; (b) the modification of the Product other than by Mentor Graphics; (c) the
use of other than a current unaltered release of Software; (d) the use of the Product as part of an infringing process; (e) a
product that Customer makes, uses, or sells; (f) any Beta Code or Product provided at no charge; (g) any software provided
by Mentor Graphics’ licensors who do not provide such indemnification to Mentor Graphics’ customers; or
(h) infringement by Customer that is deemed willful. In the case of (h), Customer shall reimburse Mentor Graphics for its
reasonable attorney fees and other costs related to the action.

11.4. THIS SECTION 11 IS SUBJECT TO SECTION 8 ABOVE AND STATES THE ENTIRE LIABILITY OF MENTOR
GRAPHICS AND ITS LICENSORS, AND CUSTOMER’S SOLE AND EXCLUSIVE REMEDY, FOR DEFENSE,
SETTLEMENT AND DAMAGES, WITH RESPECT TO ANY ALLEGED PATENT OR COPYRIGHT
INFRINGEMENT OR TRADE SECRET MISAPPROPRIATION BY ANY PRODUCT PROVIDED UNDER THIS
AGREEMENT.

12. TERMINATION AND EFFECT OF TERMINATION. 

12.1. If a Software license was provided for limited term use, such license will automatically terminate at the end of the
authorized term. Mentor Graphics may terminate this Agreement and/or any license granted under this Agreement
immediately upon written notice if Customer: (a) exceeds the scope of the license or otherwise fails to comply with the
licensing or confidentiality provisions of this Agreement, or (b) becomes insolvent, files a bankruptcy petition, institutes
proceedings for liquidation or winding up or enters into an agreement to assign its assets for the benefit of creditors. For
any other material breach of any provision of this Agreement, Mentor Graphics may terminate this Agreement and/or any
license granted under this Agreement upon 30 days written notice if Customer fails to cure the breach within the 30 day
notice period. Termination of this Agreement or any license granted hereunder will not affect Customer’s obligation to pay
for Products shipped or licenses granted prior to the termination, which amounts shall be payable immediately upon the
date of termination.

12.2. Upon termination of this Agreement, the rights and obligations of the parties shall cease except as expressly set forth in this
Agreement. Upon termination, Customer shall ensure that all use of the affected Products ceases, and shall return hardware
and either return to Mentor Graphics or destroy Software in Customer’s possession, including all copies and
documentation, and certify in writing to Mentor Graphics within ten business days of the termination date that Customer no
longer possesses any of the affected Products or copies of Software in any form.

13. EXPORT. The Products provided hereunder are subject to regulation by local laws and United States (“U.S.”) government
agencies, which prohibit export, re-export or diversion of certain products, information about the products, and direct or indirect
products thereof, to certain countries and certain persons. Customer agrees that it will not export or re-export Products in any
manner without first obtaining all necessary approval from appropriate local and U.S. government agencies. If Customer wishes
to disclose any information to Mentor Graphics that is subject to any U.S. or other applicable export restrictions, including
without limitation the U.S. International Traffic in Arms Regulations (ITAR) or special controls under the Export
Administration Regulations (EAR), Customer will notify Mentor Graphics personnel, in advance of each instance of disclosure,
that such information is subject to such export restrictions.

14. U.S. GOVERNMENT LICENSE RIGHTS. Software was developed entirely at private expense. The parties agree that all
Software is commercial computer software within the meaning of the applicable acquisition regulations. Accordingly, pursuant
to U.S. FAR 48 CFR 12.212 and DFAR 48 CFR 227.7202, use, duplication and disclosure of the Software by or for the U.S.
government or a U.S. government subcontractor is subject solely to the terms and conditions set forth in this Agreement, which
shall supersede any conflicting terms or conditions in any government order document, except for provisions which are contrary
to applicable mandatory federal laws.

15. THIRD PARTY BENEFICIARY. Mentor Graphics Corporation, Mentor Graphics (Ireland) Limited, Microsoft Corporation
and other licensors may be third party beneficiaries of this Agreement with the right to enforce the obligations set forth herein.

16. REVIEW OF LICENSE USAGE. Customer will monitor the access to and use of Software. With prior written notice and
during Customer’s normal business hours, Mentor Graphics may engage an internationally recognized accounting firm to
review Customer’s software monitoring system and records deemed relevant by the internationally recognized accounting firm
to confirm Customer’s compliance with the terms of this Agreement or U.S. or other local export laws. Such review may include
FlexNet (or successor product) report log files that Customer shall capture and provide at Mentor Graphics’ request. Customer
shall make records available in electronic format and shall fully cooperate with data gathering to support the license review.
Mentor Graphics shall bear the expense of any such review unless a material non-compliance is revealed. Mentor Graphics shall
treat as confidential information all information gained as a result of any request or review and shall only use or disclose such
information as required by law or to enforce its rights under this Agreement. The provisions of this Section 16 shall survive the
termination of this Agreement.

17. CONTROLLING LAW, JURISDICTION AND DISPUTE RESOLUTION. The owners of certain Mentor Graphics
intellectual property licensed under this Agreement are located in Ireland and the U.S. To promote consistency around the
world, disputes shall be resolved as follows: excluding conflict of laws rules, this Agreement shall be governed by and construed
under the laws of the State of Oregon, U.S., if Customer is located in North or South America, and the laws of Ireland if



Customer is located outside of North or South America. All disputes arising out of or in relation to this Agreement shall be
submitted to the exclusive jurisdiction of the courts of Portland, Oregon when the laws of Oregon apply, or Dublin, Ireland when
the laws of Ireland apply. Notwithstanding the foregoing, all disputes in Asia arising out of or in relation to this Agreement shall
be resolved by arbitration in Singapore before a single arbitrator to be appointed by the chairman of the Singapore International
Arbitration Centre (“SIAC”) to be conducted in the English language, in accordance with the Arbitration Rules of the SIAC in
effect at the time of the dispute, which rules are deemed to be incorporated by reference in this section. Nothing in this section
shall restrict Mentor Graphics’ right to bring an action (including for example a motion for injunctive relief) against Customer in
the jurisdiction where Customer’s place of business is located. The United Nations Convention on Contracts for the
International Sale of Goods does not apply to this Agreement.

18. SEVERABILITY. If any provision of this Agreement is held by a court of competent jurisdiction to be void, invalid,
unenforceable or illegal, such provision shall be severed from this Agreement and the remaining provisions will remain in full
force and effect.

19. MISCELLANEOUS. This Agreement contains the parties’ entire understanding relating to its subject matter and supersedes all
prior or contemporaneous agreements. Some Software may contain code distributed under a third party license agreement that
may provide additional rights to Customer. Please see the applicable Software documentation for details. This Agreement may
only be modified in writing, signed by an authorized representative of each party. Waiver of terms or excuse of breach must be
in writing and shall not constitute subsequent consent, waiver or excuse.

Rev. 130502, Part No. 255853
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