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Introduction 3

1. Introduction

This document is a basic guide for configuring a new Patapsco Liberator S. A full User Manual for configuring all settings on the unit is supplied on the
DbManager Installation Disk. Patapsco offers an optional Pre-Configuration Service and optional Telephone Support Agreements at minimal cost.
Information on these options can be found in the Support document on the DbManager installation disk.

1.1. Transition Networks - Patapsco

Patapsco Liberator and Simulator products offer a wide range of functions for switching, cross connecting and converting ISDN calls and elements. More
than just a PRI/BRI converter; Liberator allows services using different protocols, such as E1 and T1 to be interfaced together and managed using a large
suite of call routing and manipulation options. Simulator offers much the same functionality as the Liberator products, but all of its ports are configured as
NT (network Termination) for use with end user equipment, offering a completely configurable network simulation environment.

1.2. Safety warnings

L
- A Caution: Danger of electric shock. The device may be connected to mains voltages. Switch to power-off state before
working on the device.

-

"+ A Cqution: Danger of electrostatic discharge. Electronic components are sensitive fo electrostatic discharges that might
damage the device. Protect the device from electrostatic discharges by wearing an electrostatic wristband.

= A Cqytion: Interruption of data fransmission. Data fransmission will be inferrupted during any work on the transmission
line and/or deactivation of the power supply. Make sure that that any work will only be carried out on inactive lines
(without data transmission) or during quiet times fo reduce inferference to live systems.

= Caution: Danger of damage to devices or service interruption. Access by unauthorized third persons may cause damage
to devices and/or interrupt services. Make sure that subracks are only installed in lockable locations.

+ A Cqytion: Danger of overvoltage. During faults, dangerous unprotected voltages may be present. Ensure sufficient
grounding of the housings, i.e. by connecting the grounding contact.

e  Safety requirements are not fulfilled unless this equipment is connected to a wall socket outlet with a protective earth (PE)
contact.

e  The power cord used to connect this equipment must be HAR marked and fitted with an IEC320 connector and an ASTA
approved moulded plug.

e  There are no user serviceable parts in this equipment. All servicing and repair tasks must be undertaken by qualified service
personnel.

e Isolation from mains power is achieved by the removal of the main power cord.

2. Getting Started

This section will describe how to make the physical connections between Liberator S and the other system devices, and install the Patapsco management
application, DbManager.

© 2012 Patapsco Designs Ltd
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2.1. Rack Mounting Instructions

The Rack Mounting Kit is comprised of the following:

All Patapsco units can be mounted in a standard 19" rack housing. To allow units to fit info a 19" rack, a Rack Mounting Kit must be purchased for the unit
(s). There are various rack mounting options depending on the size of the unit ordered. The following guide will explain how to use the Rack Mounting Kit

with Patapsco units.

1. Remove the four short screws near the front or rear panel on the left and right hand sides of the Patapsco unit. The unit can be mounted with the front

Photo Description Quantity
‘ L-Bracket 2
d Long Patapsco case screw 4
b Cage Nut 4
° washer 4
ﬂ Rack Mount Screw 4

panel facing forward or with the ports facing forward as required.

2. Fit one of the L-Brackets to the side of the unit. The four small fixing holes allow the unit to protrude forward or sit further back depending on the desired

position of the unit. The bracket may also face forwards or backwards depending on the desired position of the unit.

3. Fixthe L-Bracket in place using the Long Patapsco case screws.

4. Fix the second L-Bracket to the other side of the case in the same way.

5. Put the Rack Mount screws through the Rack Mount washers.

6. Offer the unit up to the rack and fix it in place using the Rack Mount Screws and Rack Mount cage nuts.

2.2. Accessories

The following accessories are supplied with all Patapsco units:

ltem

Description

DbManager CD

Installable DbManager application, technical documents and manuals

Controller Cable

Cable Spec
Management cable. Connects to RJ12 DB9S
Liberator S'sTerminal port Pin Function Pin
1 Rx 3
2 TX 2
3 Gnd 5

|IEC Mains Cable

Connects Liberator S to the mains supply

2.3. Optional Accessories

The following items can be ordered from Patapsco, or will be supplied with some units depending on the nature of the device.

ISDN Cables -

Rack Mounting Kit -

Cables to connect the Patapsco device to a CPE or network. Please see the full manual for cable specs on all

Patapsco cables

All Patapsco units can be monuted in a 19" rack using this kit

© 2012 Patapsco Designs Ltd
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2.4. Making Connections

First, connect the ISDN cables to Liberator S followed by the Terminal Port management cable (if required), LAN Port cable and lastly the Mains cable. If the
unit has a DC power supply connection, use the screw terminals to connect the DC power source.

&4 Warning: The -48VDC power terminals are marked OV, -48VY, and GND. Patapsco -48VDC products are designed for use
with negative voltage DC supplies, and therefore expect the positive voltage to be connected to the OV terminal, and the
negative connected to -48VY. Please be sure about the polarity of this connection before connecting power to the terminals.
Units which have a positive +24VDC power source will be marked +24VDC, OV and GND respectively. Please ensure that
the positive connection is made on the +24VDC terminal.

2.5. Installing DbManager

DbManager is required in order to monitor and manage Patapsco devices. Management can be made using the Terminal (serial) port, or using TCP/IP over
a LAN or WAN. DbManager is installed using the CD provided with Patapsco equipment.

1. Insert the DbManager Installation Disk into the drive of the PC which will be used for management of Liberator S.
2. InstallShield Wizard will start up. Follow the steps to install DbManager.
3. Serial Number — Enter the Serial Number on the case of the DbMgr Disk.

i b

1]
“=" Info: DbManager is supplied as a 'Lite' version by default. This allows configuration and monitoring of devices, but only allows
configuration of a single device node and a single user account. To use DbManager in 'Lite' mode, do not enter a serial
number during installation. Please see the full DbManager User Manual for more information on configuring and using

DbManager.

L
—*_ Warning: If an older version of DbManager is already installed on the management PC, it is necessary to update to the
version supplied on the new DbManager CD. This can be done by consulting the ‘Upgrade’ folder on the DbManager CD. The
‘readme.txt’ file explains how to upgrade to the new DbManager without reinstalling the program.

3. Configuring Liberator S

Follow these steps to connect to Liberator S with DbManager and configure the unit for use.

Configuration of Liberator S is carried out by setting up DbManager to make a management connection, and then setting up the elements of Liberator S in

this order:
Device Settings -

Clock Sources -

ISDN Ports -

Link Configuration -

Call Routing -

The unit-specific settings of the Liberator S such as the IP Address and Identifier

configure which interface Liberator S is to take synchronisation clock from, typically a PSTN
network connection or network

Each ISDN port can be individually configured with the correct settings to interface with another
device or network

Configure seftings to carry ISDN channels across a PSN between Liberator S units

Configure routes for the traffic Liberator S will pass between connected devices and networks

© 2012 Patapsco Designs Ltd
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3.1. Connecting to Liberator S

1. Start up the DbManager Application
2. Login as Super User (no password required)
3. Four windows will be displayed:

[ Cpevices =T |
DB DbMgr Default E|‘
Mdp A network map showing Nodes and Links between Patapsco devices

Terminal A view of the communications between DbMgr and Liberator S

Event HiS‘l'Ol'y All events which occur while connected to Liberator §

Outsta nding Events Current events

4. Select View > Properties > Terminal from the DbMgr toolbar.

5. Choose the COM port which is in use. Leave the Serial Port Rate at the default setting of 19200bps. Click OK.

6. Select the Devices in World window and double click the Device node

7. The Connected to Device window should appear, showing the front and rear panels of Liberator S. If it does not, check the COM port settings and re-

try

L
—* Warning: If management via the Terminal port is not possible, it could be that the management PC has another application
running which uses the COM ports of the PC. Even when some programs which use the COM ports are closed down, other
programs cannot access the COM ports. Rebooting the PC is required in order to release the COM ports so that DbManager
can use them.

If the PC and Liberator S are connected to the same LAN, management is possible using TCP/IP. All Patapsco products use the default IP settings:

IP Address 192.168.0.1
Subnet Mask 255.255.0.0
Gateway 0.0.0.0

To configure DbManager to access Liberator S using TCP/IP, please follow these steps:

1. Select View > Properties > Terminal > Device |P Addresses from the DbMgr toolbar
2.192.168.0.1 should already be configured. If using another IP address, add it to the list using the Add button
3. Click OK > OK

4. Select the Devices in World window and double click the Device node

5. The Connected to Device window should appear, showing the front and rear panels of Liberator S

The Device node can be made to connect to other IP addresses configured in the Device IP Addresses list by right-clicking the node, selecting

Properties and choosing an IP address from the IP List.

Y Info: TCP/IP management requires TCP port 3001 (dec) to be open between the management PC and Liberator S. Any
switches, hubs or routers must be configured to allow communication on this port in order o manage Liberator S via TCP/IP.

© 2012 Patapsco Designs Ltd
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A successful management connection will open up the Connected to Device window:

=/Connected to A3050° BEE

LIBERATOR

3.2. Notes on configuring Liberator S

o Uploading

Changes to config can be made on each window and saved using the OK key when exiting each window. When happy with the
configuration, it must be uploaded to Liberator S for the new settings to come into effect.

To upload, go 1o File > Upload and wait until the progress bar completes.

o Saving Files

Configuration files can be saved in order to backup seftings or copy seftings across to another unit. Once configuration has been
uploaded, go to File > Save File and choose a location to save the file to. The file extension of any saved config files is .dbc

o Loading Files

Once connected to a unit, an existing configuration file can be loaded to the device. Go to File > Open File and navigate to the
saved file. Click Open. Now the file must be uploaded to Liberator S. Go to File > Upload and wait until the progress bar
complefes.

B
L= Warning: When loading existing configuration files to a unit, please ensure that the correct configuration files are used for the
unit type in use. Liberator S configuration files are not compatible with other Patapsco platforms.

3.3. Device Settings

This menu controls unit-specific features of the Liberator S such as the IP Address, |dentifier, Serial Number, Configuration Number, Time & Date and Event
Reporting. These features are all fully explained in the Liberator S User Manual on the DbManager Installation Disk.

3.4. Clock Sources

Liberator S must be configured to either receive clock from an ISDN interface (typically a port connected to the PSTN) or generate clock intemnally. Different
priorities can be set for each port, so if one port is unavailable, Liberator S will clock from the next available port in the Clock Source hierarchy.

1. Select Clock Sources from the Terminal port menu.

2. Enter a digit to mark the priority of each ISDN port and the intemal clock. O will denote the highest priority Clock Source and 19 will denote the lowest.
Ports which are not to be used for clocking can have their values left at 19.

3. Click OK to save the sefting.

© 2012 Patapsco Designs Ltd
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L . . .
—* Warning: Clock Sources must be configured correctly to ensure error-free operation when Liberator S is connected to any other
clock-locked system or network. Please consult the full Liberator S manual if unsure how to configure Clock Sources.

3.5. PRI Ports

Liberator S units are switchable between NT and TE operation modes. All PRI ports are switchable between NT and TE modes. Using a port in a mode other
than its hardware set port layout will require a crossover cable. Crossover cables will be supplied with units as necessary.

Ports 21 and 22 are TE and NT respectively so that in the event of a power failure they can be connected together by interal relays (Relay Protection). The
same is true of ports 23 and 24. If a port is sef to run in a mode other than its hardware layout (see above) a Crossover cable must be used. This table shows
which cable is required for each operating mode and the colour of any cables ordered with the unit which should be used:

Port Polarity | Cable Required Cable Colour
21 TE Straight Green
21 NT Crossover Yellow
22 TE Crossover Yellow
22 NT Straight Green
23 TE Straight Green
23 NT Crossover Yellow
24 TE Crossover Yellow
24 NT Straight Green

There are two LEDs for each PRI port, and the LED states are as follows:

Top LED on - Layer 1 and 2 established
Top LED flashing - Layer 1 established, trying to synchronize with Layer 2
Bottom LED on - Calls active on interface

1. Click on an enabled PRI port.

2. The configuration settings for the port are displayed.
3. Configure the settings as required for the port.

4. Click OK to save the settings.

3.6. BRI Ports

Liberator S units are switchable between NT and TE operation modes. BRI ports are optionally switchable between NT/TE in blocks of 4. If the switchable BRI
port option is not taken, all BRI ports will be NT. Using a port in a mode other than its hardware set port layout will require a crossover cable. Crossover
cables will be supplied with units as necessary.

BRI ports can have optional Relay Protection in blocks of 4, so BRI 1-4 (NT) can be Relay Protected to BRI 5-8 (TE) for example. If a port is set to run in a
mode other than its hardware layout (see above) a Crossover cable must be used. This table shows which cable is required for each operating mode and the
colour of any cables ordered with the unit which should be used:

Port Polarity | Cable Required Cable Colour
BRI 1-16 TE Crossover Red
BRI'T-16 NT Straight Green

There are two LEDs for each BRI port, and the LED states are as follows:

© 2012 Patapsco Designs Ltd
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Top LED on - Calls active on B channel number 1
Bottom LED on - Calls active on B channel number 2
LEDs off - No calls active on interface

1. Click on an enabled BRI port.

2. The configuration settings for the port are displayed.
3. Configure the settings as required for the port

4. Click OK to save the settings.

uNofe: Each block of 4 BRI ports can be switched to TE mode (if the switchable BRI option is taken). Switching a single port to
TE mode will change the whole block to TE. The setting must then be uploaded, Liberator S must be rebooted and a crossover
cable must be used in order to use the port in TE mode.

3.7. Configuring Routing Profiles

It is strongly recommended that you draw a simple diagram showing the Liberator S, its ISDN ports in use, the DDI numbers, and any local devices and the
number ranges used to access them. An example is shown below.

P ..‘./- -.\-_.- -
-~ Dy v
{ II b
PSTN - | 4
i |
| D} =
e MNumber Range

900-999

Number Range
ga1-bas

This example requires that Liberator S routes calls as follows:

1. Route calls from PSTN ending 981-988 to the VC (user will dial call ending 981)
2. Route calls from PSTN notending 981-988 to the PABX

3. Route all calls from the PABX to the PSTN

4. Route all calls from the VC to the PSTN

All of these actions can be catered for using three Call Routing Profiles. A Call Routing Profile is used to direct traffic from one port or group of ports to
another. A Routing Profile has many options to control how calls are routed, but in this case and in most applications the Routing Profile will consists of the
following elements:

Name, Source, Destination(s), DDIs
Click on the Terminal port and select Call Routing from the Drop-Down menu to configure routing profiles for Liberator S.

1. The Call Routing Profiles List is displayed. This will show all Routing Profile details when they are configured.

2. Select Add Profile and choose Add Routing Profile.

3. Name the profile and tick the Enable check-box.

4. Move the SOURCE PORTS radio button to Select and enter a source forincoming calls. A source can be designated by entering a port number, port
and channel number or by using a Group of ports and/or channels:

© 2012 Patapsco Designs Ltd
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To use a port: Enter the port number (e.g. 21 for PRI 21, 1 for BRI 1)

To use a port and Enter the port number followed by a full stop and then the channel number (e.g. 21.1 for PRI 21 channel 1, 1.1 for BRI 1
channel: channel 1)

To use a Group: Configure a group and select it from the Drop-Down menu (see 5.2 for instructions on configuring a group)

5. Move the DESTINATION PORTS radio button to Select, and enter a destination for calls in the same way as the SOURCE PORTS
6. Select the Incoming Numbers tab to choose numbers which Liberator S will use to route the calls.

'~ Note: If no Incoming Numbers are configured (*/*), Liberator S will route all calls received on the Source ports to the
Destination ports, regardless of the DDI, CLI or SubAddress numbers of the call.

7. The DDI Listing defaults to */* which represents any number and any SubAddress (Number/SubAddress).

8. Double click the */* to edit the number values. An entry of *1284/* would route any call with a DDI ending in 1234 with any SubAddress. Right-clicking
an existing entry will present more options.

9. Enter a CLI value if required. This is entered in the same way as the DDI. The default value; * will route calls with any CLI.

=" Note: More routing options may be used to configure complex routing profiles. These are all explained in the Liberator S
manual on the DbManager installation disk.

10. Click OK on the two active windows and the new routing profile will appear in the Call Routing Profiles List.
11. Click Exit to return to the Connected to Device window.

Prioritizing Routing Profiles

The Call Routing Profiles List shows all configured Call Routing Profiles in order of priority. These priorities can be rearranged to allow diverse routing
possibilities. When Liberator S receives a call, it will check each profile in order from the top of the list for any routing parameters matching those of the call.
It will route the call based on the first matching profile.

1. Select Call Routing from the Terminal port Drop-Down menu.

2. All configured routing profiles are displayed.

3. Right click on a profile in the Type column to display options. The profile can be promoted or demoted in the priority list. There are also options to edit
and delete the profile.

This table shows the profiles which would be required to carry out the call routing shown in the diagram above:

Profile Number |Profile Name [Source Primary Destination Secondary Destination | DDlIs

0 ISDN to VC 21 1 Group: BRI 1-4 *981/* - *988/*
1 ISDN to PABX 21 22 A

2 Outgoing All Ports 21 A

Provided profile O is at the top of the priority list (see Prioritizing Routing Profiles, above), Liberator S will route calls with DDI ending in 981-999 to
the VC and all other calls to the PABX. The first profile uses both a Primary and Secondary destination because VC equipment requires the first call from the
ISDN to arrive on BRI 1. This VC feature (Channel Bonding) is explained further in the Liberator S manual. Note that in this case, all the DDI numbers from
*980/* to *999/* are configured in the DDI list of profile 0. All calls going out to the PSTN from both the VC and PABX will be routed out using profile 2.

With all of these profiles configured, the Call Routing Profile List screen should look like this:

Type | |ndex I Identifier | Enabled I Source | 13t Destination | 2nd Destination | DDl Mumber I
ROUTIMNG n I50M toWC YES 21 1 BRI 1-4 =

EHDUTING 1 ISDM to PABX  YES 21 22 Ay

ﬁ ROUTIMG 2 COutgoing YES All Ports 21 Any
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Clicking on Sort on DDls shows all of the DDI numbers configured in the Incoming Numbers listing:

DO Murnber | |ndex | | dentifier | Type | E nabled | Source | 1zt D estination | Znd Deztination |
0: =881~ 1] ISOM ta T ROUTIMG  YES 21 1 BRI 1-4
1. #8982~ 1] ISOM b T ROUTING  YES 21 1 BRI 1-4
s o T 1] ISOM ta T ROUTIMG  YES 21 1 BRI 1-4
s o M 1] ISOM b T ROUTING  YES 21 1 BRI 1-4
4 #9ERM~ 1] ISOM ta T ROUTIMG  YES 21 1 BRI 1-4
B *9B6/~ 1] ISOM b T ROUTING  YES 21 1 BRI 1-4
B *987. 1] ISOM ta T ROUTIMNG  YES 21 1 BRI 1-4
Fs =i T 1] ISOM b T ROUTIMG  YES 21 1 BRI 1-4
0 = 1 ISOM ta PABX  ROUTING  YES 21 22

0 == 2 Cutgaoing ROUTIMG  YES All Portz il

3.8. Using Groups

When more than one port needs to be configured as a source or destination for calls, a Group of ports can be set.

1. Select Add Group from the Add Routing Profile screen.
2. The Group Configuration screen is displayed.
3. Name the Group you wish to configure.

i .\I

“=" Note: The names of any Routing Profiles, Groups and Identifiers must not contain the following characters: < > ~

4. Use the All and None buttons to add blocks of PRI and BRI ports to the Group, or select individual channels from each port by using the tick-boxes.
5. Click OK to save the group.

6. The new Group will now appearin the SOURCE and DESTINATION drop-down menus. Select this Group from the drop-down to use it in a Call
Routing Profile.

3.9. Finishing Configuration

" Note: Please remember fo Upload when configuration of Liberator S is complete. To upload, go to File > Upload and wait
until the progress bar completes.

3.10. More Resources
All Patapsco products and the DbManager application have their own User Manuals which can be found in the 'Documents & Manuals' folder on the
DbManager installation disk. Please consult these manuals for more detailed information on any aspect of using Patapsco products. All documentation can

also be obtained by registering at the Patapsco website:

http://www.patapsco.co.uk/Top Level/Logln Register.asp

For help with a specific problem, please click on the On-Line Help icon on the website, or email a request to support@patapsco.co.uk
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