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Map printing (T46)
If you are using the Windows version of INTREPID you can print map compositions 
direct to any printer18.  You can also output your composition in a range of graphics 
file and output language formats.  INTREPID uses its Print Map tool for all printing.

If you are using the Unix version of INTREPID you can output map compositions in a 
range of graphics file and output language formats.  You can then use normal Unix 
commands to send these files to a printer if required.

Printing under Windows
If you are using the Windows version of INTREPID you can use the Print Map tool to 
print compositions in the following ways:
• Using the Windows Print Manager,
• Using commands to output compositions in a range of graphics file and output 

language formats.

Printing from the (Windows) Map Composition tool
You can launch the Print Map tool directly from the Map Composition tool.  
INTREPID will automatically load the current composition.

>> To launch the Print Map tool with the current composition
1 Ensure that the composition is ready to print.  We recommend that you save it 

before proceeding.  
2 Choose Print from the File menu in the Map Composition window.

1.8  The printer must be capable of printing graphics.  Printers such as daisy wheel or line 
printers cannot print INTREPID map compositions
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3 If your composition has more than one sheet, INTREPID displays the Print Sheet 
Options dialog box.  Otherwise go to step 5.

4 If you wish to modify the current sheet or selected sheets settings choose Sheet 
Layout.  INTREPID displays the Select Sheets dialog box.  Modify the settings as 
required, then choose OK. "Selecting sheets for printing or display" in Including 
datasets in a map composition (T45b) for instructions on selecting sheets.

5 Decide whether you wish to print the current sheet, the selected sheets or all 
sheets, selecting the corresponding option.  Choose Print.

6 INTREPID will launch Print Map and load a copy of the current composition that 
contains your sheet selections.

7 Preview and/or print the composition as described in Section Using (Windows) 
Print Map interactively.  Map Composition will remain in memory as a task with 
the current composition loaded.

Launching (Windows) Print Map for interactive use
You can launch Print Map using the following methods.
• Choose Print from the File menu in Map Composition.  See Printing from the 

(Windows) Map Composition tool for details.
• Choose Print_Hardcopy from the Printing menu in the Project Manager. 
• Use the command mapprint.exe.
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Using (Windows) Print Map interactively

>> To print a composition interactively with the Print Map tool
1 Launch Print Map using one of the methods described in Launching (Windows) 

Print Map for interactive use.  INTREPID displays the Print Map window.  

Depending on the method of launching the tool, Print Map may also load a 
MAPCOMP file (e.g., the current composition if you launched it from the Map 
Composition tool).
2 If INTREPID has not already loaded the required MAPCOMP file, load it using 

Load from the File menu.  (See Loading MAPCOMP files for instructions.)  
INTREPID displays an icon in the Print Map window for each loaded file.

3 If there are several MAPCOMP files loaded, select the one you require from the 
Window menu.  See Selecting and arranging loaded MAPCOMP files for details.

4 If you wish to preview the selected file choose Preview from the File menu.  
INTREPID displays the Print Preview window.  (See Printing compositions for 
details.)  Otherwise go to step 6.

5 If you wish to print the composition, choose Print and proceed to the next step.  If 
you do not wish to print the composition, choose Close and go to step 9.

6 If you need to configure the printer, choose Print Setup from the File menu.  
INTREPID displays the Print Setup dialog box for your printer.  Configure the 
printer as required and choose OK.  See your Windows and printer documentation 
for further information.
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7 If you wish to print the composition, choose Print from the File menu.  INTREPID 
displays the Print dialog box. 

8 Set options in the Print dialog box as required, then choose OK.  INTREPID will 
print the composition.  (See Printing compositions for detailed instructions about 
the Print dialog box.)

9 If you wish to print other loaded MAPCOMP files, go to step 3.
10 If you wish to load other MAPCOMP for printing or previewing, go to step 2.
11 Exit from Print Map.  Choose Exit from the File menu.
You can choose whether to display the tool bar and status bar in the Print Map 
window, using options from the View menu.  See Print Map window options for 
detailed instructions
Loading MAPCOMP files
You can load several MAPCOMP files into the Print Map window using Open from 
the File menu.  

If there are no MAPCOMP files currently loaded the File menu appears as in the left 
hand illustration below.  

If one or more MAPCOMP files are currently loaded the File menu appears as in the 
right hand illustration below.  

When you launch Print Map, it may already have a MAPCOMP file open.  This 
section describes both how to load the first file if it is not already loaded and 
additional files.

>> To load a MAPCOMP file into the Print Map tool
Choose Open from the File menu. INTREPID displays an Open dialog box.  Use the 
directory and file selector to locate the file you require.  (See "Specifying input and 
output files" in Introduction to INTREPID (R02) for detailed instructions.)
Selecting and arranging loaded MAPCOMP files
If you have several loaded MAPCOMP files, you can 
• Select one of them to be the current loaded file using the Window menu or by 

clicking its icon.
• Automatically arrange their icons.
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>> To select one of the loaded MAPCOMP files to be the current loaded file
Choose the option corresponding to the file from the Window menu.

OR

Left button click the icon in the Print Map window corresponding to the file.

>> To automatically arrange the loaded MAPCOMP file icons
Choose Arrange Icons from the Window menu.
Closing MAPCOMP files

>> To close a loaded MAPCOMP file
1 Switch to the file you wish to close using options from the Window menu.  (See 

Selecting and arranging loaded MAPCOMP files for instructions).
2 Choose Close from the File menu.  INTREPID will close the file and its icon will 

disappear.

>> To close all loaded MAPCOMP files
Choose Close All from the File menu.
Previewing compositions
You can print preview compositions, zoom the preview in and out, and print directly 
from the preview if desired.

>> To print preview a composition
1 If there are several loaded compositions, select the one you wish to preview.  See 

Selecting and arranging loaded MAPCOMP files above for instructions.
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2 Choose Print Preview from the File menu.  INTREPID displays the composition in 
the Print Preview window.

3 If you wish to zoom in on the preview, click anywhere in the preview display.  
Zoom in and out works in a three step cycle.  The first click zooms in.  The second 
click zooms in further.  The third click zooms out to the full page view again.  You 
can also use the Zoom In and Zoom Out buttons at the top of the window.  They 
become available and dim in accordance with the three step zoom cycle.

4 If you wish to print directly from the Preview, choose Print.  INTREPID displays 
the Print dialog box.  See Printing compositions for further instructions.
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5 When you have finished with the preview, choose Close.  INTREPID will close the 
Print Preview window.

Note:  The Next Page, Prev Page, Two Page buttons do not have a function in this 
version of Print Map.
Printing compositions

>> To print the current composition
1 Choose Print from the File menu.  INTREPID displays the Print dialog box.

2 Change the settings required, then choose OK.  INTREPID will print the 
composition.

Printer Name You can use this drop down list to select the printer to be used.
Printer Properties Choose properties to display the Printer Setup dialog box.  This 

is the same as using Printer Setup in the File menu.
Print to file  Turn on this check box if you wish to output the composition to a file 

instead of sending it to the printer.  INTREPID will create the file in the output 
language of the selected printer.  INTREPID provides a range of other 'print to 
file' operations.  See Using Print Map with commands for details. 

Print range This is permanently set to All.  If you wish to only print certain sheets, 
select them before loading the MAPCOMP file into Print Map.  See Printing from 
the (Windows) Map Composition tool and "Selecting sheets for printing or display" 
in Including datasets in a map composition (T45b) for instructions.

Number of copies You can use this scrolling text box to set the number of copies of 
the composition you require.

Print Map window options
You can turn Toolbar and Status Bar display on and off as required using the 
corresponding options from the View menu.
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Help
You can use the Help menu to display help text on the Print Map tool.

Using Print Map with commands
You can use commands with Print Map to output compositions in a range of graphics 
file and output language formats.  You can send this output file to your printer by 
drag and drop or by command, or send it to your printing service.  Alternatively you 
can use the Print to File option in the Windows Print dialog box.
Outputting a composition to a file using commands

>> To output a composition to a file using commands 
1 Ensure that the MAPCOMP file is correctly prepared as described in section 

Preparing for output to file by command.
2 Use the command

mapprint  –file mapfile outfile

where 

mapfile is the path and file name of the MAPCOMP file to be processed.

outfile is the path and file name of the output file.

For example

mapprint –file /disk1/srv/mlev.map /disk1/srv/mlev.prn

'Print to file' option in the Print dialog box
If you are using Print Map interactively you can output your composition to a file in 
the output language of the selected printer.  See Printing compositions.
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Printing under Unix
Printing interactively under Unix

>> To print the current composition in the Map Composition tool window, 
1 Choose the format or output language you require from the Print cascade in the 

File menu.  (See "Map output formats" in Map composition configuration files 
(R21) for a details of the output file formats available.)

INTREPID displays the Print Options dialog box.

2 Select the Print option you require (current sheet, selected sheets, all sheets).
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3 If you are printing the current sheet or selected sheets and wish to check or alter 
the current sheet or selected (active) sheets, choose Sheet Layout.  INTREPID 
displays the Sheet Selection dialog box.  Otherwise go to step 5.

4 Set the current sheet or select/deselect the sheets you require, then choose OK.  
(See "Selecting sheets for printing or display" in Including datasets in a map 
composition (T45b) for detailed instructions.)

5 Choose Print in the Print Options dialog box.  INTREPID displays a Save As 
dialog box for you to name an output file.  Specify the output file and choose OK.

6 Print the output file using the appropriate Unix command.  For example, if you 
have created an output file surv145.prn and are printing to a device HP650C, 
you might use the command
lp –dHP650C surv145.prn 

Printing with commands under Unix

>> To output a composition to a file and print it using commands 
1 Ensure that the MAPCOMP file is correctly prepared with the device macro as 

described in section Preparing for output to file by command.
2 Output the map language file using the command

mapprint.exe mapfile outfile

where 
mapfile is the path and file name of the MAPCOMP file to be processed.
outfile is the path and file name of the output file.
For example
mapprint.exe /usr/surv/mlev.map /usr/surv/mlev.prn

If you type mapprint.exe without parameters INTREPID displays a brief help 
message about command usage.
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3 Print the output file using the appropriate Unix command.  For example, if you 
have created an output file surv145.prn and are printing to a device HP650C, 
you might use the command
lp –dHP650C surv145.prn 

Preparing for output to file by command
If you wish to use a command to output a MAPCOMP file to a file in output device 
language (e.g., PostScript, HP–GL/2), you must include a device configuration macro 
reference in the composition's MAPCOMP file. 

The reference must be the first line (not counting comments) of the file, and must 
take the form 

call = devicemacro

where devicemacro is the name of a device configuration macro.

For example, if you wish to output a composition in HP–GL/2, include the following 
line as the first line in the MAPCOMP file.

call = hpgl2Map output formatsposition configuration files for a list of the 
output file formats and their corresponding device configuration macro names.

See "Internal MAPCOMP Macros" in MAPCOMP Map Specification Language (R20) 
for general information about macros in MAPCOMP.

Automatic recalculation of legend files
Each time INTREPID draws a print preview of a composition or prints it, it will 
• Recalculate and save new copies of any associated Histogram legend files;
• Calculate cutoff values for any associated dynamic range Level legends.
See Map legend files (R23) for details about legend files.
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