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Chapter 1 – Introduction 

This chapter describes both the ROCLINK™ 800 Configuration software 
(“ROCLINK 800”) you use to configure and monitor the FloBoss™ 107 
Flow Manager (“FB107”) and the FB107’s dynamic user interface.  

In This Chapter 

1.1 ROCLINK 800 Software Description ...............................................1-1 
1.2 Computer Requirements .................................................................1-2 
1.3 Contacting Technical Support .........................................................1-2 
1.4 Software Installation ........................................................................1-2 

1.4.1 Manually Creating a Desktop Shortcut...............................1-3 
1.4.2 Un-installing ROCLINK 800................................................1-4 

1.5 Starting ROCLINK 800 Software.....................................................1-4 
1.5.1 Logging On.........................................................................1-5 

1.6 User Interface Basics ......................................................................1-6 
1.6.1 The FloBoss 107 Dynamic Interface ..................................1-7 
1.6.2 Actual versus Installed Module.........................................1-10 
1.6.3 Standard Buttons..............................................................1-11 
1.6.4 Toolbar Buttons ................................................................1-11 
1.6.5 Configuration Tree Menu..................................................1-13 
1.6.6 Keystrokes........................................................................1-14 
1.6.7 Help System .....................................................................1-15 
1.6.8 Basic Navigation...............................................................1-15 

 

1.1 ROCLINK 800 Software Description 
ROCLINK 800 Configuration software enables you to monitor, 
configure, and calibrate FloBoss 107 Flow Managers. Emerson Process 
Management provides the software and user documentation on a CD-
ROM. 

ROCLINK 800 is designed for ease of use. Drop-down menus simplify 
accessing the functions provided by the software. Dialog boxes and drop-
down list boxes help to direct selections and data entry. You can perform 
actions with the keyboard or a pointing device, such as a mouse. Refer to 
Section 1.6, User Interface Basics for a description of the user interface. 

You access help screens either from the Help menu or in a context-
sensitive fashion using the F1 key. This feature makes it easy to access 
on-line information for any ROCLINK 800 topic. 

You can build custom displays for the FB107 that combine both graphic 
and dynamic data elements, and then use these displays to monitor the 
FB107’s operation either locally or remotely. 

The software also provides multiple levels of security to control access to 
ROCLINK 800 functions as well as the FB107 database.  
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1.2 Computer Requirements 
ROCLINK 800 runs on most IBM-compatible personal computers (PCs). 
The PC can be a desktop or a portable computer, but must meet the 
following minimum requirements: 

 Pentium-class processor (233 MHz or greater recommended). 
 CD-ROM drive. 
 Windows NT 4.0 (Service Pack 6), 2000 (Service Pack 2), or XP. 
 64 MB of RAM (random access memory). 
 SVGA color monitor, 800 by 600 pixels, small fonts. 
 15 to 50 MB of available hard disk space depending on operating 

system and revision level. 
 EIA-232 (RS-232) serial connection or a dial-up modem connection.  

1.3 Contacting Technical Support 
For technical support, please contact your local sales representative. You 
may also contact Remote Automation Solutions directly. 

Emerson Process Management  
Remote Automation Solutions 
Marshalltown, IA 50158 USA 
Houston, TX 77065 USA 
Pickering, North Yorkshire UK Y018 7JA 

E-mail: supportnet@emersonprocess.com 

Website: http://www.emersonprocess.com/Remote/  

Technical Support Website: 
http://www.emersonprocess.com/flow/Emerson/support/ 
support_index.html  

Telephone: 641.754.3449 
Toll Free: (US and Canada) 800.807.0730 
Hours: Monday through Friday 7:30 AM to 4:30 PM Central Standard 

Time USA. 

1.4 Software Installation 
To install ROCLINK 800: 

1. Start the installation using either of the following methods. 

 Method 1 – If you have a CD-ROM that contains the ROCLINK 
800 installation files: 
A. Place the ROCLINK 800 installation CD-ROM into your 

drive. 
B. If the CD-ROM runs automatically, click Install a 

ROCLINK Product on the Main Menu.  
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C. Click the Install ROCLINK 800 button in the Installation 
Screen. 

Note:  If the CD-ROM does not run automatically, click Windows 
Start > Run. When the Run dialog box opens, click 
Browse and navigate to the CD-ROM drive and select 
setup.exe. Click Open. If the CD-ROM is drive D, the 
location will be 
D:\Installs\ROCLINK800_W68130\Setup.exe. Click OK 
in the Run dialog box. 

 Method 2 – If you have a .zip file that contains the ROCLINK 
800 installation files: 
A. Extract the .zip file to the local hard drive (for example, in the 

C:\TEMP\directory). 
B. Run setup.exe from the extraction directory (for example, run 

C:\TEMP\SETUP.EXE). 
The Installation Wizard screen appears. 

2. The Installation Wizard determines whether you have previously 
installed ROCLINK 800. 

 If this is an upgrade, a dialog box appears asking whether to 
continue with the upgrade. Click Yes to begin the installation. 
Click Next when prompted. 

 If this is a new installation, click Next on the ROCLINK 800 
Welcome screen. Read the License Agreement and click Yes to 
accept it. Enter your Name and Company name, and click Next. 

3. The program installs the software in the default recommended 
directory C:\Program Files\ROCLINK800. Select an alternative 
destination folder if you want to install the software in a folder other 
than the default.  

4. Click Next. A confirmation screen appears when you are ready to 
start copying files. 

5. Click Next in the Setup Status screen. 

6. Click Finish in the Wizard Complete screen. 

7. If you installed the software from a CD-ROM, select View Manual 
or Exit on the Main Menu screen. Once you have exited the Main 
Menu, remove the installation CD-ROM. 

Note:  You may need to restart your PC to complete the installation. 

1.4.1 Manually Creating a Desktop Shortcut 
The ROCLINK 800 installation should automatically create a desktop 
shortcut on your computer. To manually create a desktop shortcut:  

1. Double-click the My Computer icon.  
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2. Navigate to the C:\Program Files\ROCLINK800 folder or the folder 
where you installed ROCLINK 800.  

3. Right-click the ROCLINK.exe file.  

4. Select Send To and Desktop from the drop-down menu.  

5. The icon appears on your desktop.  

1.4.2 Un-installing ROCLINK 800 
To remove ROCLINK 800 from your PC:  

1. Click the Windows Start button. 

2. Select Settings > Control Panel. 

3. Double-click the Add/Remove Programs icon. 

4. Select ROCLINK 800. 

5. Click Add/Remove. 

6. Follow the displayed instructions. 

1.5 Starting ROCLINK 800 Software 
To use ROCLINK 800 to configure a hardware device, you must first 
properly connect the device to power. Refer to the appropriate hardware 
instruction manual. You must also connect the PC to the device’s Local 
Operator Interface (LOI), serial, or modem port. 

To run ROCLINK 800, perform one of the following steps: 

 Double-click the Desktop Shortcut. 

 Select Start > Programs > ROCLINK 800 > ROCLINK 800. 

The software loads and initializes.  

Note:  You can only run one version of ROCLINK 800 at a time. 
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1.5.1 Logging On 
To log on to ROCLINK 800 software:  

1. Connect the FB107 to the Local Operator Interface (LOI – Local 
Port) and launch ROCLINK 800. 

 
Figure 1-1. Logon 

2. Type your assigned 3-character identifier in the User ID field and 
press Enter or Tab.  

Note:  The User ID is case sensitive. 

Typically, your initials are your user ID. If user IDs have not yet been 
assigned, try using the default user ID of LOI. You assign user IDs by 
using the ROC > Security features of ROCLINK 800. 

3. Type your assigned 4-digit password and click OK. For added 
security, the software displays an asterisk for each number that you 
type. If passwords have not yet been assigned, use the default 
password of 1000 (valid only with the default user ID of LOI).  

ROCLINK 800 validates the user ID and password you enter against a 
predefined list.  

If the log on is not valid, a dialog box appears. Click OK and re-enter 
the user ID and password. You can repeat the procedure as many 
times as needed until you successfully enter a valid User ID and 
password. If the log on is valid, ROCLINK 800 displays the Device 
Directory screen (see Figure 2-1).  

To exit the log on screen, click Cancel or press Esc. This closes 
ROCLINK 800 and returns you to the point where you started ROCLINK 
800. 
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1.6 User Interface Basics 
You interact with ROCLINK 800 using various displays on the computer 
monitor, keyboard, and pointing device.  

The major components of ROCLINK 800 user interface are: 
 Graphical Interface (Splash Screen) 
 Menu bar and menus. 
 Toolbar. 
 Function screens. 
 Dialog boxes. 
 Help system, including the Status bar and message boxes. 
 Device Directory or Configuration Tree menu. 

ROCLINK 800 employs a dynamic graphical user interface (GUI) with a 
standard Windows menu structure. After you log on to ROCLINK 800, 
available functions display in a menu bar with drop-down menus. A 
Status Line at the bottom left of the display contains pertinent 
information about the highlighted item, such as a menu option or a 
parameter.  

Buttons display dialog boxes for further configuration details or perform 
a desired action, such as the Update button. To activate the button: 
 Click the button with a left click of the mouse. 
 When a button is active, press Enter or a function key. 

Dialog boxes are areas that “pop up” inside the current screen allowing 
you to make further selections or enter values. Dialog boxes can also 
provide messages or more detailed information. 

The menu structure lists choices from which you can select the desired 
function. Once you select a function, the screen or dialog box for that 
function displays. This screen or dialog box provides the requested 
information and lets you enter the applicable configuration data.  

Table 1-1. Menu Listing for ROCLINK 800 

Menu Menu Options 
File New, Open, Download, Close, Save Configuration, Print 

Configuration, Print, Print Setup, [List of recent files], Exit
Edit Undo, Cut, Copy, Paste. 

Note: This option is not available in the current release.  
View Directory, EFM Report, Calibration Report, History, 

Alarms, Events, Display, I/O Monitor, Toolbar 
ROC Direct Connect, Disconnect, Collect Data, Clock, 

Security, Comm Ports, Memory, Information, Flags 
Configure I/O, Control, History Points, Opcode Table, MODBUS, 

LCD User List, User Data 
Meter Setup, Calibration, Values, Plate Change 
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Menu Menu Options 
Utilities Update Firmware, License Key Administrator, Convert 

EFM File, User Program Administrator, ROCLINK 800 
Security, AI Calibration Values, MVS Calibration Values, 
FST Editor, Communications Monitor 

Tools Options 
Window Cascade, Tile, Device Directory, [List of open windows] 
Help Help Topics, About ROCLINK 800 

1.6.1 The FloBoss 107 Dynamic Interface 
You can navigate the FB107 options either by using the ROCLINK menu 
structure or by clicking on the FB107 graphical dynamic interface and 
selecting a tab or button. The dynamic interface display shows the current 
settings of the point including alarms and integrity.  

The system displays a white line around objects that are links when you 
hover your cursor over them. A link descriptor displays indicating what 
the link is for. The system displays a yellow line around currently 
selected components. The configuration for the selected hardware 
displays at the bottom of the screen.  

Note:  For more information on using the dynamic interface, refer to 
SupportNet course RAS-0044 FB107 Dynamic Interface. 
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Figure 1-2. FloBoss 107 Dynamic Interface 

  
Figure 1-3. Integrity Alarm 
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Alarms The FB107 supports two kinds of alarms: integrity (which indicate 
hardware problems) and alarms (which indicate software or field 
device problems).  

Alarm notifications display on both the graphical representation of the 
FB107 and on the tabbed screen below the graphical FB107. ROCLINK 
800 color-codes the notifications to help you quickly identify and resolve 
the alarms. Integrity notifications display as an I in a red box and alarm 
notifications display as an A in a yellow box (see Figure 1-2). Moving the 
mouse over these alarm icons displays a definition. ROCLINK 800 also 
displays definitions in the Integrity field.  

Integrity Integrity notifications indicate hardware problems related to the CPU 
module, I/O modules (Auxiliary 6-Point IO), the CPU module’s 
optional I/O assembly (On-Board 6-Point IO), MVS modules, 
communication modules, and smart application modules. 

Other integrity notifications can include:  

Red “I” – Integrity. The point is out of the user-defined or default range. 
For example, when an AI is open, the actual AD count is 0 but the default 
range is 643 to 3220 or loss of communications occurred. 

 Communication Failure: The FB107 sets a diagnostic error 
indicating Communication Failure if the Actual Module field is 
empty and the Installed Module field displays a value or if 
communications is lost between the FloBoss and the module. Refer to 
Section 1.6.2, Actual versus Installed Module.  

 Module Mismatch: Displays if you install a different module type 
than the one currently displayed in the Installed Module field, which 
draws from information residing in the CPU configuration.   

 Out of Range: Indicates that the point is not within the user-defined 
configured parameters.  

 Integrity Failure: Displays when the FB107 cannot read or 
communicate with the associated hardware. The hardware reports a 
malfunction.  

Alarm Alarm notifications indicate problems related to field or other user-
defined values.  

The FB107 dynamic interface displays an A in a yellow box to indicate 
an alarm condition (see Figure 1-2). The alarm condition indicates the 
type of point and location associated with the installed hardware point. 

ROCLINK 800 displays alarms when you enable the  

 Yellow “A” – Alarm. The point is in alarm condition. The Active 
Alarms fields indicate any alarms that are active for this point. When 
Alarming is set to Enabled, the active alarms appear. If Alarming is 
set to Enabled, an alarm is generated when Scanning is Disabled. 
Even if Alarming is Disabled, the Integrity Failure (hardware 
malfunction) alarm indicator can still appear.  
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1.6.2 Actual versus Installed Module 
As a diagnostic tool, the General tab in the window underneath the FB107 
dynamic interface includes two fields, Installed Module and Actual 
Module. The Actual Module field indicates what module is physically 
installed in the backplane. The system updates this field whenever you 
restart the FB107. The Installed Module field indicates the module 
identified in the configuration file currently residing in firmware.  

If the contents of the Actual Module and Installed Module fields are not 
identical, the system displays integrity alarms. You then correct the 
integrity errors. The FloBoss 107 remembers the “Installed Module” type 
until you “Uninstall” it. 

The FB107 uses a plug and play system to install newly inserted modules 
to the backplane. For example, in a new FB107 with no installed 
modules, the Actual Module field displays “Empty” for all slots. The 
Installed Module field also displays “Empty” for all slots.  

When you insert an I/O module in slot 2 and power up the FB107, the 
FB107 displays Aux IO in the Actual Module field. The FB107 also 
displays Aux IO in the Installed Module field (since there was not a 
module previously installed in slot 2) and creates the I/O points 
associated with the I/O module. 

If you remove the I/O module from slot 2 and power up the FB107, the 
Actual Module field now displays Empty, but the Installed Module field 
still displays Aux IO. The FB107 “remembers” what was previously 
installed. Additionally, the FB107 sets an integrity error (specifically, 
“Communication Failure”) on slot 2 because the slot is now physically 
empty and the Installed Module field indicates Aux IO. You can still 
define and manage the I/O points associated with the Installed Module 
(Aux I/O), but because of the unresolved integrity error any I/O points are 
marked in point fail. 

A Module Mismatch error occurs if you install a different type of 
module than currently displays in the Installed Module field.  

To completely remove a module from the FB107 click Uninstall. This 
resets the value in the Installed Module field to Empty and deletes any 
I/O points associated with the previously installed module. 

Note: The FB107 completely re-scans for actual and installed modules if 
you select ROC > Flags, click Flash Memory Clear on the Flags 
screen, and click Cold Start & Clear All.  
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1.6.3 Standard Buttons 
Several buttons appear on most ROCLINK 800 screens.  

Button Description  

 

Minimizes and hides windows. 

 

Maximizes the size of the windows to fit in the screen area. 

 

Restores window to original size. 

 

Closes a window. 

 
Expands options listed in the Device Directory or 
Configuration Tree Menu.  

 
Hides options listed in the Device Directory of 
Configuration Tree Menu.  

 
Prints the active display.  

 
Updates contents of the active window from the device.  

 
Applies changes on the active window to the device and 
closes the active window. A Confirm Save dialog box 
displays if there are unsaved changes.  

 
Cancels without saving changes and close the active 
window.  

 
Applies changes on the active window to the device. 
Clicking Apply does not close the active window.  

 
Starts automatic device polling.  

 
Stops automatic device polling.  

1.6.4 Toolbar Buttons 
The following buttons appear in the ROCLINK 800 toolbar. ROCLINK 
800 grays out a button if it is not applicable to the current screen.  

Button Description  

 

Creates a new configuration file. You specify available 
configuration parameters using menu selections. Configure the 
file as if you were connected to the device. Functions requiring a 
live connection are unavailable in this mode.  

 
Opens an existing configuration file. You create configuration 
files using the New Device or Save Configuration functions.  

 
Saves the current configuration of the connected device to a 
disk file.  
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Button Description  

 
Deletes currently selected text and place it in the Clipboard. 
Note: Currently not available.  

 
Copies currently selected text and places it in the Clipboard. 
Note: Currently not available. 

 
Pastes text currently in the Clipboard at the cursor’s current 
location. 
Note: Currently not available. 

 
Prints the configuration file. 
Note: Currently not available.  

 
Connects to a device locally using the (LOI) Local Operator 
Interface port. 

 
Disconnects from a device. 

 
Displays the first of two .DSP files loaded on the device.  
Note:  Not available on the FB107. 

 
Displays the second of two .DSP files loaded on the device.  
Note:  Not available on the FB107. 

 
Displays the Analog Input (AI) screen. 

 

Displays the Discrete Input (DI) screen. 

 
Displays the Pulse Input (PI) screen. 

 

Displays the Analog Output (AO) screen. 

 

Displays the Discrete Output (DO) screen. 

 
Displays the Comm Port screen. 

 
Displays the Flags screen.  

 
Displays the Clock screen. 

 
Displays the Meter Setup screen.  

 
Displays the Plate Change screen.  

 
Displays the PID Loop screen.  
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Button Description  

 
Opens the Function Sequence Table (FST) Editor.  

 
Displays an About ROCLINK 800 screen providing program 
information, version, creation date, and copyright for ROCLINK 
800.  

 
Launches the ROCLINK 800 on-line help system.  

 

1.6.5 Configuration Tree Menu 
When you open a configuration file or go on-line with an FB107, the 
Configuration Tree appears on the left-hand side of the screen. The tree 
hierarchically displays the parts of a configuration (such as I/O, Meter 
Runs, and History) that you can change.  

 
Figure 1-4. Configuration Tree 

Option Description  
Modules Lists all installed modules. 
I/O Lists all available inputs and outputs by type. 
Control Displays the FST and PID options enabled on the ROC > 

Information screen. 
Meter Lists all available meters. 
System Displays ROC > Information system folders, Comm Port, 

Device Flags, and the Opcode Table. 
History Displays all available History Points. 
User Programs Displays all installed user programs. 
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User Display Accesses custom displays stored in the FB107. The 
FB107 can store a maximum of 40 displays (including 
both custom user displays and user program displays). 

 
From the Configuration Tree, you may change the configuration or 
monitor current operations. Once you are in the Configuration Tree menu, 
you can use the + and – symbols to display or hide various options. 

Double-click the desired function in the Configuration Tree to display the 
associated screen. Double-clicking an icon is the same as selecting the 
menu bar or Toolbar button option. 

If this is the first time that you have connected to the FloBoss, refer to 
Section 6.4, Setting the Clock. 

1.6.6 Keystrokes 
If you are using the keyboard, you may use the Alt key plus one or more 
letters to access menus. Windows underlines the appropriate letter in the 
menus. For example, to access the Open File dialog box, press Alt + F 
and press O. You may also use the Left Arrow (←) and Right Arrow (→) 
keys to highlight a menu bar item (the help Status Line at the bottom of 
the screen provides a description of the menu) and press the letter.  

With a menu displayed, you can highlight the desired item by using the 
Down Arrow (↓) and Up Arrow (↑) keys or the mouse. Once you have 
highlighted an item, press Enter to activate the function.  

To leave a menu or submenu, press Esc. You can then select another 
menu. You can also access another menu using ← and →. 

The text scrolling keys are Page Up and Page Down. 

To use the keyboard in configuration screens and dialog boxes, press Tab 
to move in a predetermined sequence from one parameter field or button 
to the next. The selected field or button becomes highlighted. Fields 
unavailable for changes are automatically skipped. 

When you Tab to the last field or button in the screen or dialog box, 
pressing Tab again jumps back to the first field or button. To go back to a 
previous field or button, press Shift + Tab. 

In an option field, the currently selected option is highlighted. To select 
one of the other options, use ↓ or ↑ to highlight the desired option and 
then press Enter.  

In a field that requires a text or numerical entry, type in the required 
characters or numbers from the keyboard. Use Backspace or Delete to 
erase unwanted characters. Use ← and → to move the cursor one 
character at a time and Home and End to place the cursor at the 
beginning and end of the field, respectively. 

Other keys or key combinations include: 
 F1 – Launches ROCLINK 800 on-line help. 



ROCLINK 800 User Manual (FB107) 

Issued Jan-08 Introduction 1-15 

 Esc – Cancels the current activity, closes the screen, and returns you 
to the last-used place in the menu structure, screen, or other place 
from which the dialog box originated. If a menu is active, Esc closes 
the last-opened menu, taking you up one level in the menu structure. 
If the menu bar is active, Esc de-selects all menu options. Press Alt or 
click with the mouse to reactivate the menu bar. 

 Ctrl + N – Creates a new configuration file. 
 Ctrl + O – Opens a configuration file. 
 Ctrl + S – Saves the current configuration file. 

1.6.7 Help System 
The Help menu provides detailed on-screen information about getting 
started with ROCLINK 800 and performing keyboard operations, a list of 
the Help topics, and the ROCLINK 800 version.  

To display context sensitive help on a menu item, a parameter, or a 
button, press F1 while the item, parameter, or button is highlighted. A 
help window appears on the screen.  

To view detailed help, select Help > Help Topics from the menu bar. 

Option Description  
Contents Presents a list of Help Topics that display based on task-

oriented situations. Each screen, tab, and field has a help 
topic associated with it. For example: the Modbus Scale 
Values tab is located under Modbus > Modbus 
Configuration > Scale Values tab. 

Index Locates specific Help Topics. The Index lists each field by the 
tab or screen in which the field appears. 

Search Activates a search function on a specific word. 
Back Returns to the last topic that you viewed. 
Print Sends the currently displayed topic to the PC’s default printer. 
See Also Displays topics related to the currently selected topic. 

<< / >> Navigates forward (>>) or backwards (<<) through the help 
system on a per topic basis. The Browse Sequence follows 
the order of the topics as displayed in the Contents tab. 

1.6.8 Basic Navigation 
When you start ROCLINK 800, the Device Directory displays. After you 
connect to an FB107, the Configuration Tree displays (see Figure 1-4).  

Use the + and – symbols to display or hide various options. Double-click 
a point to display the associated parameter configuration screen. You can 
also use the menu options and buttons to display the associated parameter 
configuration screen. 
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The Status Line at the bottom of the Device Directory and Configuration 
Tree provides critical information. The left side displays brief information 
about the device being connected. The right side displays the device 
status (on-line or off-line) and system time. 

TLP Selections 

 

In many locations in ROCLINK 800, you can click Browse (a button 
with three dots) to view the Select TLP dialog. The Select TLP dialog 
allows you to assign specific inputs and outputs to parameters. 
ROCLINK 800 uses Point Type (T), Logical Number (L), and 
Parameter (P) to define point locations.  

 

 
Figure 1-5. Select TLP 

To use the Select TLP dialog box: 

1. Select the Point Type from the list. This opens a list of logical 
numbers and parameters that belong to that Point Type. 

2. Select the Logical Number. In the configuration screens, the Logical 
Number is generally referred to as Point Number or Number.  

3. Select the specific Parameter. These are usually called by the same 
term as the Tag on the configuration screen. Click OK. 

The field at the bottom of the Select TLP dialog displays the numeric 
point location of the TLP point or a text abbreviation, depending on 
the setting in the Tools > Options window. 

AutoScan Update 
Interval Option 

Select Tools > Options to set the time interval, in seconds, at which the 
AutoScan feature on various screens in ROCLINK 800 polls the FB107. 
Clicking AutoScan causes ROCLINK 800 to poll the device 
automatically, until you click StopScan. 
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Chapter 2 – Device Directory and Device Root 

This chapter describes the Device Directory screen and the Device Root, 
the graphical representation of all devices, which appears on that screen. 

In This Chapter 

2.1 Device Directory ..............................................................................2-1 
2.1.1 Communication Parameter Setup Screen..........................2-2 

2.2 Device Root .....................................................................................2-4 
2.2.1 Backing Up Configurations.................................................2-4 
2.2.2 Adding a Group ..................................................................2-5 
2.2.3 Deleting a Group ................................................................2-5 
2.2.4 Deleting a Device ...............................................................2-5 
2.2.5 Adding a Device .................................................................2-6 
2.2.6 Deleting All Devices ...........................................................2-6 
2.2.7 Renaming a Group or Device.............................................2-7 

 

2.1 Device Directory 
The Device Directory is the first screen that displays after you 
successfully log onto ROCLINK 800 but before you connect to a device.  

 

Figure 2-1. Device Directory and Device Root 

Note:  Once you connect to a device, ROCLINK 800 replaces the Device 
Directory screen with a device-specific configuration tree screen 
(see Figure 2-2). 
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Figure 2-2. Configuration Tree 

You use the Device Directory screen (Figure 2-1) to create and maintain 
communications setup configurations for a PC running ROCLINK 800. 
You can uniquely configure the communication ports on the PC to send 
data to a specified FB107. You may add, delete, or modify these 
communications setups and establish a tree of groups and devices. 

Use the + and – symbols to display or hide various options. 

Note:   You can only configure a PC’s communications ports from the 
Device Directory screen. To redisplay the Device Directory screen 
at any time, select Window > Device Directory or View > 
Directory. 

2.1.1 Communication Parameter Setup Screen 
The ROCLINK 800 Communication Parameter Setup screen allows you 
to change your PC communications port, time-out settings, and other 
variables ROCLINK 800 uses when establishing a connection to a device.  

In order for ROCLINK 800 to communicate with a device, ROCLINK 
800 must know to which device it is communicating. Each device within 
a group is given a unique device address. 
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To set the PC communication parameters: 

1. Right-click the label in the Device Directory that corresponds to the 
PC port you want to use.  

 

Figure 2-3. Device Pop-up Menu 

2. Select Properties. The ROCLINK 800 Communication Parameters 
screen displays.  

 

Figure 2-4. Communication Parameters 
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3. Configure the ROCLINK 800 communications parameters (refer to 
Chapter 3, Communications and Security for a complete discussion of 
this screen).  

4. Click Apply. You are ready to connect to the FB107. 

2.2 Device Root 
The device root graphically represents the devices and their 
organizational structure on the Device Directory screen. When you open 
ROCLINK 800, the device root displays the default device labels. Using 
the Communication Parameters screen, you can modify the 
communications setup configurations for these devices or add new 
devices with new configurations. Each icon on the device root represents 
a different type of communications connection. 

 

Figure 2-5. Device Root 

The default device labels, which correspond to available communication 
ports, include: 
 COM1 Device. 
 COM2 Device. 
 Modem Device. 
 Ethernet Device. 
 New Group1. 

You may add, delete, or modify the communication configurations for 
each of these devices. You can also define device groups.   

2.2.1 Backing Up Configurations 
After you configure your device settings, we strongly recommend that 
you create a back-up file of those settings. ROCLINK 800 stores these 
values in the file ROC_USER.mdb. Use Windows Explorer to find the 
ROC_USER.mdb file, then copy the file and store it in a safe place. This 

Device Root
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backup file enables you to restore your settings in case they ever become 
corrupted.  
You can configure devices on-line communications using the Local 
Operator Interface (LOI) Port (also known as the “local port”) or a 
communication port, such as a modem. 
For differentiation, each FB107 has a tag and a unique device address 
which you define on the ROCLINK 800 Communications Parameters 
screen (see Figure 2-4). The Device Address must be different from any 
other host system that may access the network.  

2.2.2 Adding a Group 
You can organize devices into groups. Typically, groups contain devices 
in the same geographical area or with another common feature. When you 
double-click a group icon, ROCLINK 800 displays all devices or 
subgroups associated with that group.  

To add a new group to the device root directory:  
1. Right-click the Device Root icon. A pop-up menu displays. 
2. Select Add a Group. ROCLINK 800 adds the new group icon to the 

device root graphic. 

To add a subgroup to an existing group:  
1. Right-click the group icon. A pop-up menu displays.  
2. Select Add a Group. ROCLINK 800 adds the new group icon to the 

selected group.  

2.2.3 Deleting a Group 
To delete a group:  
1. Right-click a group icon. A pop-up menu displays.  
2. Select Delete Group. A Confirm Delete dialog box displays.  

 

Figure 2-6. Delete Group 

3. Click Yes to delete the group and all subordinate groups and devices 
in that group.   

2.2.4 Deleting a Device 
To delete a device:  
1. Right-click a device icon. A pop-up menu displays.  
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2. Select Delete Device. A Confirm Delete dialog box displays.  

 

Figure 2-7. Delete Device 

3. Click Yes to delete the device. 

2.2.5 Adding a Device 
To add a new device to the device root:  
1. Right-click the device root icon. A pop-up menu displays.  

2. Select Add a Device. ROCLINK 800 adds a device icon to the device 
root.  

3. Configure the new device’s communication parameters (see Chapter 
3, Communications and Security). 

To add a device to an existing group:  

1. Right-click the group icon. A pop-up menu displays.  

2. Select Add a Device. ROCLINK 800 adds a device icon in the 
selected group.  

3. Configure the new device’s communication parameters (see Chapter 
3, Communications and Security).  

2.2.6 Deleting All Devices 
To delete all device communication parameter configurations in the 
device root directory: 

Note: This deletes all devices you currently have configured. 

1. Right-click the device root icon. A pop-up menu displays.  

2. Select Delete All Devices. A Confirm Delete dialog box displays.  

 

Figure 2-8. Delete All Devices 
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3. Click Yes. ROCLINK 800 deletes all devices in the device root.  

2.2.7 Renaming a Group or Device 
You can easily replace the ROCLINK 800-provided default group or 
device names with names you choose. To rename a group or device in the 
Device directory:  

1. Right-click the device or group icon. A pop-up menu displays.  

2. Select Rename. Enter a name.  

Note: Although your label can be up to 72 characters in length, keep 
the label short for easy recognition.  

3. Press Enter when finished. ROCLINK 800 adds the new label to the 
device or group. 
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Chapter 3 – Communications and Security 

This chapter describes how to configure the communication ports on a PC 
and on an FB107. It also describes how to use the Connect and Direct 
Connect features in ROCLINK 800 and how to define security to control 
access to the FB107 and ROCLINK 800. 

In This Chapter 

3.1 Communications..............................................................................3-1 
3.2 ROCLINK 800 Communications......................................................3-2 

3.2.1 ROCLINK 800 Communications Parameters General Tab 3-2 
3.2.2 ROCLINK 800 Communications Parameters Advanced Tab3-5 

3.3 Communication Ports on the FB107 ...............................................3-6 
3.3.1 Communication Modules....................................................3-7 

3.4 Configuring FB107 Communications Ports .....................................3-9 
3.4.1 Comm Ports General Tab ................................................3-10 
3.4.2 Comm Ports Modem Tab .................................................3-12 
3.4.3 Comm Ports RBX Tab......................................................3-13 

3.5 Connecting to an FB107................................................................3-15 
3.5.1 Direct Connect..................................................................3-15 
3.5.2 Local Port (LOI) ................................................................3-16 
3.5.3 Connect to a FloBoss .......................................................3-16 
3.5.4 Successful Logon .............................................................3-17 
3.5.5 Disconnecting from a FloBoss..........................................3-17 

3.6 Troubleshooting Connection Errors ..............................................3-18 
3.6.1 Troubleshooting ROCLINK 800 Communications............3-18 

3.7 Security..........................................................................................3-18 
3.7.1 ROCLINK 800 Security ....................................................3-19 
3.7.2 Device Security ................................................................3-21 

 

3.1 Communications 
Before you attempt to connect to an FB107, you must configure 
communication parameters in two places:  

 ROCLINK 800 Communications 
Configure device communications on the Device Directory screen 
(see Chapter 2, Device Directory and Device Root). This sets the 
PC’s comm ports to communication with a specific device.   

 Communication Ports on the FB107 
Select ROC > Comm Ports to access the Comm Port screen and 
configure the FB107’s communication ports for incoming or outgoing 
communications. Refer to Section 3.3, Communication Ports on the 
FB107.  
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3.2 ROCLINK 800 Communications 
The Device Directory communication configurations allow ROCLINK 
800 to communicate to an individual FB107.   

3.2.1 ROCLINK 800 Communications Parameters General Tab 
The Device Directory screen is the first screen that displays after you 
successfully log onto ROCLINK 800 but before you connect to a device.  

To display the ROCLINK 800 Communication Parameters screen, right-
click on a device icon in the device root and select Properties. The 
ROCLINK 800 Communication Parameters screen displays, showing the 
General tab. 

Use the General tab to configure basic communications for the PC 
running ROCLINK 800.  

 

Figure 3-1. ROCLINK 800 Communications, General tab  

Field Description 
Tag Sets a unique name for the FB107. Enter up to 50 

alphanumeric characters to identify the FB107. 
Connect Click to communicate with the PC using the 

parameters configured for this PC’s communications 
port.  
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Field Description 
Device Address Sets the address of the specific FB107 with which 

you desire to communicate. If you are connected to a 
multi-drop series of devices, enter the device 
address and device group of a specific device.   
Note:  The default device address is 240.  

Device Group Associates the FB107 with a specific group. The 
default device group is 240.  
Note:  If you connect a PC running ROCLINK 800 

directly to the device’s LOI (Local Port), 
ROCLINK 800 makes a request to Device 
Group of 240 and Device Address of 240. The 
Local Port of a device always responds to a 
request for Address 240 and Group 240, no 
matter what Device Address and Device 
Group is configured in the device if the LOI 
Security is valid. 

Host Address Identifies the PC’s host address, which by default is 
Address 3. If more than one computer running 
ROCLINK 800 communicates with a group of 
devices (either by radio or by other multi-drop 
communications), you must define unique host 
address for each device to avoid multiple responses. 
The host address must also be different from any 
other host system that may access the 
communications link.   
Use the following host group and host address 
conventions: 0 and 240 are reserved.   

Host Group Identifies the PC’s host group, which by default is 1. 
When using ROC Protocol, the group address must 
match the address defined at the destination device 
in order for communications to properly transmit.   
Use the following host group and host address 
convention: 0 and 240 are reserved.  

Use Sets the type of connection. Valid values are Comm 
Port, Modem, or TCP/IP.   
Note:  If you select TCP/IP, ROCLINK 800 applies 

only the Time Out parameter you define on 
the Advanced tab. No other parameters 
defined on that tab apply. 

PC Comm Port Sets the comm port on the PC ROCLINK 800 uses 
for this setup. The FB107 can communicate through 
any of the PC’s configured comm ports. The default 
comm port is 1.   
Note:  This field is available only if you select the 

Comm Port option. Before you select this 
parameter, check to see which 
communications ports are assigned in the PC. 
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Field Description 
PC Baud Rate Sets the baud rate ROCLINK 800 uses to 

communicate with the device through a serial port 
(COM port). For successful communications, the 
baud rate you set here must match the baud rate on 
the PC. The default value is 19200.    
Note:  This field is available only if you select the 

Comm Port option. 
Modem Indicates the modem ROCLINK 800 uses. Click  to 

list all available modems. Only the modems defined 
in the Windows’ Control Panel display here. Ensure 
that the modem you select is properly set up.   
Note:  This field is available only if you selected the 

Modem option. 
Phone Number Sets the telephone number for the modem ROCLINK 

800 uses. If you select Modem in the Use field, enter 
the phone number of the device ROCLINK 800 dials. 
Note:  This field is available only if you selected the 

Modem option.  
Override Default 
TAPI Init String 

Indicates that ROCLINK 800 should use an override 
initialization string configuration. When you select 
this optoin, you must provide an override initialization 
string.    
Note:  This field is available only if you selected the 

Modem option. 
IP Address Indicates the IP address for the TCP/IP connection.   

Note:  This field is available only if you selected the 
TCP/IP option. 

Port Number Indicates the port for the TCP/IP connection.    
Note:  This field is available only if you selected the 

TCP/IP option. 
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3.2.2 ROCLINK 800 Communications Parameters Advanced Tab 
Use the Advanced tab on the ROCLINK 800 Communication Parameters 
screen to configure advanced communications features. 

 

Figure 3-2. ROCLINK 800 Communications, Advanced tab 

 

Field Description 
Number of Retries Sets the number of times (after the initial attempt) 

ROCLINK 800 tries to request data from the 
specified device before reporting a timeout error. 
Valid values are between 0 and 25. The default is 3. 
Use the Time Out parameter to adjust the amount of 
time between retries.   
Note:  This parameter does not apply to the dial-up 

modem, which only tries to establish a 
connection once. 
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Field Description 
Tx Delay Sets, in seconds, the amount of time ROCLINK 800 

waits before transmitting data. This delay enables the 
request-to-send (RTS) line for the amount of delay 
specified before transmitting data. The default is 
0.05.  

Typically, this value allows a radio to fully stabilize 
before the system applies data for transmission.  
 For EIA-232 (RS-232) and dial-up modem 

communications, set this value (and the value in 
the Key Off Delay field) to 0 (zero) or the default 
of 0.05 seconds.  

 For EIA-485 (RS-485) and radio communications, 
set this value to 0.1. 

Note:  These variables may change, based on your 
situation. These are general values which you 
need to assess for each circumstance.  

Time Out Sets, in seconds, the actual amount of time that 
ROCLINK 800 waits to receive a valid message after 
it sends a request to a device. The default is 3. 
Modem users typically accept the default value.  
Do not set this field to 0 (zero). This prevents 
ROCLINK 800 from timing out, and quickly exhausts 
the Retries.   
Note:  If you select TCP/IP as the communications 

method on the General tab, ROCLINK 800 
applies only the Time Out parameter. No 
other parameters defined on that tab apply. 

Key Off Delay Sets, in seconds, the amount of time ROCLINK 800 
waits after transmitting a message before turning off 
the ready to send (RTS) signal. The default is 0. You 
can change this value to optimize communications.  
The default value should be sufficient for dial-up 
modems and EIA-232 (RS-232) connections. For 
radios, a value of 0.01 may be appropriate. 

Host CRC Check Indicates whether ROCLINK 800 uses cyclical 
redundancy checking. The default value is Enabled.  

3.3 Communication Ports on the FB107 
In addition to configuring the communications ports on the PC, you also 
configure the device-specific communication parameters.  

While in a configuration and on-line with an FB107, select ROC > 
Comm Ports to display the Comm Port screen. Each communications 
port has a unique set of parameters on the screen. 

Use the Comm Ports screen to set up the communications ports that are 
available for incoming and outgoing communications with the FloBoss.  

Note:  Use the Device Directory to define PC communication ports.  
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The communication ports located on the FB107 provide a data link to 
ROCLINK 800, other devices, and host systems. The type of module 
enables the following communications:  
 EIA-232 (RS-232) serial communications. 
 EIA-485 (RS-485) multi-point serial communications. 

Table 3-1. Communication Ports for the FloBoss 107  

Comm Port Port Location Type Protocols 
LOI CPU Local Port / RS-232C ROC or Modbus slave 

COM1 CPU EIA-485 (RS-485) ROC or Modbus host/slave 
COM2 CPU EIA-232 (RS-232) − Default ROC or Modbus host/slave 
COM3 Module Slot 1 EIA-232 (RS-232) or EIA-485 (RS-485) ROC or Modbus host/slave 
COM2 Module Slot 2 EIA-232 (RS-232) or EIA-485 (RS-485) 

Note:  When installed in Slot 2, the module 
replaces COM2 on the CPU. 

ROC or Modbus host/slave 

DISPLAY DISPLAY EIA-232 (RS-232) [Limited Function]  ROC or Modbus slave 
 

3.3.1 Communication Modules 
You can navigate FB107 options using the ROCLINK menu structure or 
by clicking on components of the FB107 graphic (such as modules, tabs, 
or buttons). The graphical interface display shows the current settings of 
the point including alarms and integrity.  

To display the communication port for the FloBoss 107, click the 
communications module on the graphical interface. 

The currently selected hardware displays at the bottom of the screen. 



ROCLINK 800 User Manual (FB107) 

3-8 Communications and Security Issued Jan-08 

 

Figure 3-3. Communications Port 

Field Description 
Installed Module This read-only field shows the module currently 

defined in the active FB107 configuration. ROCLINK 
800 does not require that a module be physically 
installed to display. Refer to Section 1.6.2, Actual 
versus Installed Module.  

Description This read-only field shows a description of the 
hardware currently installed in the FB107.  

Part Number This read-only field shows the part number of the 
hardware currently installed in the FB107.  

Serial Number This read-only field shows the serial number of the 
hardware currently installed in the FB107.   
Note:  Not associated with communications modules. 

Actual Module This read-only field shows the module physically 
installed in the backplane. ROCLINK 800 updates 
this field whenever you restart the FB107. Refer to 
Section 1.6.2, Actual versus Installed Module.  

Revision This read-only field shows the firmware revision for 
the hardware currently installed in the FB107.  
Note:  Not associated with communications modules. 
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Field Description 
Build Date This read-only field shows the date the firmware was 

built for the hardware currently installed in the 
FloBoss 107.  
Note:  Not associated with communications modules 

Boot Revision This read-only field shows the version for the main 
startup (“boot”) firmware currently installed in the 
module.  
Note:  Not associated with communications modules 

Boot Build Date This read-only field shows the build date for the 
main startup (“boot”) firmware currently installed in 
the module.  
Note:  Not associated with communications modules 

Integrity This read-only field shows a message regarding the 
status of the hardware currently installed in the 
FB107.   
The user interface displays alarms that indicate the 
state of the hardware (CPU, I/O modules, CPU I/O 
assembly, MVS modules, and communication 
modules). Mousing over an alarm displays a short 
explanation of the alarm. Refer to Section 1.6.1, 
FloBoss 107 User Interface. 

Uninstall Click to remove the hardware definition currently 
installed in the active FB107 configuration. The 
Installed Module field displays the type of module the 
FB107 is using for point configuration. It does not 
require that the module is physically installed in the 
FB107 to display. The FloBoss 107 “remembers” the 
type of installed module until you use this button to 
uninstall it. Refer to Section 1.6.2, Actual versus 
Installed Module.  

Comm Port 
Configuration 

Click … to display the Comm Port screen. Refer to 
Section 3.4, Configuring FB107 Communication 
Ports.  

3.4 Configuring FB107 Communications Ports  
The FB107 communication (“comm”) ports link the device to computers, 
such as the one running ROCLINK 800 or a host computer.  

You use the Comm Port screen to configure comm ports. After you select 
a communications module on the FB107 graphic, click … in the lower 
right portion of the screen. ROCLINK 800 displays the Comm Port 
screen for that module or comm port.   

Note:  You also access the Comm Port screen by selecting ROC > 
Comm Ports from the ROCLINK 800 menu bar and then 
selecting the appropriate comm port from the drop-down menu or 
by selecting the (Comm) icon from the configuration tree.   
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After you completely configure all comm ports, save that configuration to 
Flash memoryusing the Save Configuration button on the Flags screen 
(ROC > Flags)  

3.4.1 Comm Ports General Tab 
Select a comm module from the FB107 graphic, and then click … in the 
lower right corner of the screen. ROCLINK 800 displays the Comm Port 
screen for the selected module, which shows the General tab.   

 

Figure 3-4. Comm Port, General tab 

Field Description 
Comm Ports Indicates the specific comm port to be configured. 

Click  to display all valid selections.  
Tag Sets a 10-character name (“tag”) to help identify the 

comm port. 
Baud Rate Sets, in bits per second, the transmit and receive 

data baud rate for the comm port.  
Parity Indicates whether the communications controller 

performs parity checks and, if selected, the parity 
value (odd or even).  

Data Bits Sets the number of data bits contained in an 
asynchronous byte, or character. The default is 8.  

Stop Bits Sets the number of stop bits contained in an 
asynchronous byte, or character. The default is 1.  



ROCLINK 800 User Manual (FB107) 

Issued Jan-08 Communications and Security 3-11 

Field Description 
Port Owner Sets the communications protocol this port uses. 

Valid values are ROC/Modbus Slave Protocol 
(which configures the port to automatically switch 
between Modbus and ROC Protocol messages) and 
Modbus Master (which configures the port to allow 
the FB107 to poll Modbus devices).   

Key On Delay Sets, in seconds, the amount of time ROCLINK 800 
waits after turning on the ready to send (RTS) signal 
before beginning transmission. The default is 0. You 
can change this value to optimize communications.  
The default value should be sufficient for dial-up 
modems and EIA-232 (RS-232) connections. For 
older radios, you may need to set this value to 0.2 
seconds. For newer radios, 0.02 seconds should be 
sufficient. 

Key Off Delay Sets, in seconds, the amount of time ROCLINK 800 
waits after transmitting a message before turning off 
the ready to send (RTS) signal. The default is 0. You 
can change this value to optimize communications.   
The default value should be sufficient for dial-up 
modems and EIA-232 (RS-232) connections. For 
radios, a value of 0.01 may be appropriate. 
Note:  These variables may change, based on your 

situation. These are general values which you 
need to assess for each circumstance. 

Valid Receive Ctr Sets the number of valid messages received by the 
FloBoss on this communication port. This counter 
can be preset to a value or cleared.  

Idle Time Sets, in milliseconds, the amount of time the FloBoss 
waits between communication events.  
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3.4.2 Comm Ports Modem Tab 
Use the Modem tab on the Comm Ports screen  to configure the device’s 
modem communication ports. 

 

Figure 3-5. Comm Ports, Modem tab 

Field Description 
Modem Type Sets the modem type. Valid values are None (using 

a serial link to the host), External (using an external 
modem), and Internal (not available in the release). 
The default is None.  

Connect Time Sets, in seconds, the amount of time that ROCLINK 
800 waits after initiating a call to receive a connect 
message from a device (typically the modem) before 
it terminates the call. The default is 60 seconds.  
The Connect Time varies from system to system 
and can take up to 60 seconds to make and 
complete a dial up connection. If a successful 
connection is made, the Disconnect Time begins. 

Disconnect Time Sets, in seconds, the amount of time that ROCLINK 
800 waits for further activity on the line before it 
hangs up. ROCLINK 800 resets this timer after each 
valid receive signal.  

Inactivity Time Sets, in seconds, how long ROCLINK 800 waits 
without receiving a signal before resetting the 
modem. The inactivity timer looks at the valid receive 
counter to determine if the signal has been received.  

Config Command Sets the string of characters required to initialize the 
modem. For external modems, refer to the 
manufacturer’s literature. For an internal modem, use 
the default value or the modem card may not operate 
correctly. Refer to your modem’s documentation for 
default Config Command characters.  
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Field Description 
Connect Command Sets the Hayes-style Connect Command required to 

contact the host. Typically, this is the command 
ATDT followed by the telephone number (for 
example, ATDT5155551212). This parameter is 
required only for dial-out operations, such as for 
SRBX Alarming.  

Modem Status This read-only field shows the modem’s current 
status result code.  Valid values are: 

 OK Successfully executed 
command line 

 CONNECT Connection established 
 RING Ring signal detected 
 NO CARRIER Carrier not detected/lost 
 ERROR Error in command line 
 NO DIAL TONE No dial tone detected 
 BUSY Busy signal detected 
 NO ANSWER Line not picked up on the 

called end 

3.4.3 Comm Ports RBX Tab 
Use the RBX tab to configure the Spontaneous-Report-by-Exception 
alarming features.  

The RBX or SRBX (Spontaneous Report-by-Exception) alarming feature 
is available for serial communication ports. This feature allows the device 
to call in to a host computer when a configured alarm occurs. If you wish 
to configure dial-up RBX, then a modem must be present and 
appropriately configured. 

When you use RBX alarming, ensure that you enable and configure 
alarms for each point you wish to monitor. Configure the alarm 
parameters so that an alarm occurs only when desired. This prevents 
“nuisance” alarms. You configure RBX alarm parameters on the Alarms 
tab on the I/O, MVS, and Meter Setup configuration screens.  
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Figure 3-6. Comm Ports, RBX tab 

Field Description 
RBX Mode Sets the RBX Mode for Spontaneous-Report-by-

Exception alarming on this comm port. The default is 
Disabled.  

Address Sets the address of the host to which the RBX 
feature communicates.  

Group Sets the group of the host to which the RBX feature 
communicates.  

Delay Sets, in seconds, the time the device waits between 
attempts to transmit an RBX message. Each RBX 
Attempts parameter has an associated delay 
parameter. The default for Delay #1 is 20 seconds, 
the default for Delay #2 is 30 seconds, and the 
default for Delay #3 is 45 seconds.  

RBX Attempts Sets the number of times the device attempts to 
resend a message if it does not obtain a valid 
response on the first try. “Attempt” refers to the initial 
message plus any retries.  

ROCLINK 800 provides three parameters. The 
default for all parameters is Fixed Number. The 
default value for RBX Attempt #1 is 1, for RBX 
Attempt #2 is 2, and for RBX Attempt #3 is 3. 

Select Fixed Number to set how many times 
ROCLINK 800 retries sending a message after the 
first unsuccessful attempt. If you enter 0, no retries 
occur. Select Continuous (255) to start continuous 
retries that stop only when the host acknowledges 
the SRBX alarm. 
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Field Description 
Extra Key On Delay Indicates whether ROCLINK 800 adds additional 

delay time to the amount of time it waits after turning 
on the ready to send (RTS) signal before sending an 
RBX message.   

Valid values are Disabled (the default) or Enabled. 
If you select Enabled, you must also indicate the 
number of seconds for the extra delay.  

Note:  This parameter may be required for radio 
communications. 

RBX Alarm Index This read-only field shows the alarm currently being 
reported through RBX.  

RBX Status This read-only field shows the status of RBX 
messaging. Valid values are Active (an RBX alarm 
is being processed) or Inactive.  

 

3.5 Connecting to an FB107 
Once you have configured ROCLINK 800 communication parameters, 
you can connect to the FB107 using any one of the following methods: 
 Direct Connect 

Click the Direct Connect icon on the ROCLINK 800 tool bar to 
connect to the FB107.   

 Device Directory 
Double-click the device icon on the Device Directory to connect 
using the parameters currently set for that port.  

 ROC > Connect 
Select a comm port icon on the Device Directory and select menu 
options from the ROCLINK 800 menu bar.  

Note:  Once you are connected (on-line), ROCLINK 800 displays the 
Configuration Tree screen. 

3.5.1 Direct Connect 

 
Click the Direct Connect icon to establish a connection with a FloBoss. 
ROCLINK 800 attempts to establish communications through all PC 
comm ports PC at various baud rates. If unsuccessful, the program then 
attempts to establish communications through the remaining comm 
ports on the PC, successively, until it receives a valid reply.  

By default, ROCLINK 800 tags the LOI Port as the local port (comm 1), 
as shown on the Comm Port screen (ROC > Comm Ports). 
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For the Direct Connect option to work, security conditions must be met, 
and the PC must be connected to the Local Operator (LOI) port of the 
device with communication settings of: 
 8 Data Bits. 
 1 Stop Bit. 
 No Parity. 

When you click Direct Connect, ROCLINK tries to initiate 
communications with the device by performing a search of the PC 
communication ports at various baud rates. ROCLINK then “locks on” to 
the first comm port and baud rate that are successful in communicating 
with a device. 

To use Direct Connect: 

1. Physically connect cable to the FloBoss. 

2. Launch and log into ROCLINK 800. 

3. Do one of the following: 
 Click on the Direct Connect icon in the Device Directory. 
 Click the Direct Connect button on the toolbar. 
 Select ROC > Direct Connect. 

4. If this is the first time that you have connected to the FloBoss, refer to 
Section 6.4, Setting the Clock. 

3.5.2 Local Port (LOI) 
The PC running ROCLINK 800 physically connects to the device through 
a cable. For a local connection, this cable is typically a prefabricated local 
operator interface (LOI) cable (available from Remote Automation 
Solutions). One end of the cable (a 9-pin, D-shell, female connector) 
plugs into a serial communications port on the PC running ROCLINK 
800. The other end of the cable plugs into the FloBoss operator interface 
connector called the Local Port.  

Note:  If your PC does not have a serial port, you may use a USB-to-
serial connector for the LOI connection.  

3.5.3 Connect to a FloBoss 
To connect the computer to a remotely located FloBoss, a serial, dial-up 
modem, radio, satellite, or other communications line should be installed. 
This connection may be made through the LOI (Local Port) or other 
Communications Port on the FloBoss.  

Use the Connect command to connect to a serial or dial-up modem. To 
use Connect: 

1. Physically connect the FloBoss. 

2. Launch and log in to ROCLINK 800. 
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3. Perform one of the following: 
 Select a device from the Device Directory and press Enter. 
 Double-click a device in the Device Directory. 
 Select a device from the Device Directory and click Connect on 

the toolbar. 
 Select ROC > Connect to connect to the device currently selected 

in the Device Directory.  

3.5.4 Successful Logon 
A successful logon produces an on-line connection and displays both a 
tree representing the configuration in the FB107 and the FB107 graphic. 
Refer to Configuration Tree Menu. 

 

Figure 3-7. Successful Login 

3.5.5 Disconnecting from a FloBoss 
To disconnect an on-line connection, close the screen by clicking the 
lower of the two Close buttons ( ) located in the upper-right corner of 
the device screen, select the Disconnect button ( ) located on the 
Toolbar, or select File > Close. This automatically closes the connection.  
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3.6 Troubleshooting Connection Errors 
Several events can cause a connection problem:  
 If the parameters used by ROCLINK 800 when establishing a 

communications link to your PC are incorrect, a Direct Connect 
connection cannot be made.  

 If ROCLINK 800 stands idle for too long and exceeds the timeout 
value for a device, a communications failure can also occur. In this 
case, simply log back into ROCLINK 800 and use the Direct Connect 
or Connect features.  

 If you do not have security access to the FloBoss, you cannot make a 
connection. You must configure a valid User ID and Password (using 
the ROC > Security option) for each user who can connect to a 
FloBoss. 

3.6.1 Troubleshooting ROCLINK 800 Communications 
Occasionally, you may need to alter your PC communications options 
when you are having problems communicating with your FloBoss. 

1. Select the desired device in the Device Directory. Right-mouse click 
and select Properties. 

2. Make sure you have specified the correct Device Address and Device 
Group of the FloBoss with which you are trying to communicate. If 
you are communicating through the LOI port of the device, the 
Device Address is 240 and Group Address is 240, which is the 
universal address. 

3. Click the Advanced tab. Try increasing the Time Out and/or Tx 
Delay.  

4. Click Apply. Return to the General tab, and click Connect. 

5. If you are still having trouble communicating, try increasing the 
Number of Retries field in the Advanced tab screen. Click Apply. 
Return to the General tab, and click Connect. 

6. If you are still having trouble communicating, try increasing or 
decreasing the Key Off Delay field in the Advanced tab screen. Click 
Apply. Return to the General tab, and click Connect. 

7. Check the security settings of ROCLINK 800. 

3.7 Security 
You control security in two ways: 

 ROCLINK 800 Security – Enables who can access (log on) 
ROCLINK 800 and the Access Level assigned to a user.  

 Device Security – Enables who has access to the FB107 comm ports.  
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Note:  Security Access Levels enable you to control which users have 
access to specific ROCLINK 800 functions.  

3.7.1 ROCLINK 800 Security 
Use the ROCLINK 800 Security screen to set access to ROCLINK 800.  

Note:  Refer to Section 3.7.2, Device Security for instructions on securing 
the FB107.  

To access this screen, select Utilities > ROCLINK 800 Security. The 
ROCLINK 800 Security screen displays. Its table format enables you to 
define, by operator ID, password, and security level, who can log on to 
ROCLINK 800 and the screens which those IDs can access. You may 
define up to 32 different users.  

 

Figure 3-8. ROCLINK 800 Security 

Note:  The default Operator ID is LOI. The default Password is 1000. 

1. Enter three alphanumeric characters for the Operator ID, which is 
typically the initials of the person who operates the device. Each 
Operator ID must be unique and is case-sensitive. 

2. Enter four numeric characters (between 0000 and 9999) to define the 
operator password. More than one user can have the same password. 

3. Enter the desired access level for the user. 0 is the lowest (least 
inclusive) access level and allows access to the fewest number of 
screens. 5 is the highest (most inclusive) access level and alows 
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access to all screens. Each access level permits access to screens at 
that level and any inherited from lower access levels. For example, an 
operator ID with Access Level 3 can access screens with levels 0, 1, 
2, and 3. Refer to Security Access Levels. 

Security Access 
Levels 

Table 3-2 lists the system screens and their system-assigned security 
access levels. The Menu Options focus on the activity while you use 
the Access Levels to increase or decrease responsibility levels within 
the Menu Options.  

Notes:  
 If you enable security on any port, at least one operator ID must have 

the highest level of security (level 5). 
 ROCLINK 800 rejects login requests if access levels are greater than 

device security.  

Table 3-2. Security Access Levels  

Menu Menu Option Access Level 
ROC Security 5 
Utilities License Key Administrator 5 
Utilities ROCLINK 800 Security 5 
Utilities Update Firmware 4 
Utilities User Program Administrator 4 
Configure Control > FST Registers 3 
Configure Control > PID Loop 3 
Configure History Points 3 
Configure I/O > AI Points 3 
Configure I/O > AO Points 3 
Configure I/O > DI Points 3 
Configure I/O > DO Points 3 
Configure I/O > MVS Sensor 3 
Configure I/O > PI Points 3 
Configure I/O > Soft Points 3 
Configure LCD User List 3 
Configure Modbus > Configuration 3 
Configure Modbus > History 3 
Configure Modbus > Master Modem 3 
Configure Modbus > Master Table 3 
Configure Modbus > Registers 3 
Configure Opcode table 3 
Configure User Data 3 
File Download 3 
File New 3 
File Save Configuration 3 
ROC Clock 3 
ROC Comm Ports 3 
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Menu Menu Option Access Level 
ROC ROC Flags 3 
ROC ROC Information 3 
Tools Options 3 
Utilities AI Calibration Values 3 
Utilities Convert EFM File 3 
Utilities FST Editor 3 
View Display > New 3 
Meter Calibration 2 
Meter Plate Change 2 
Meter Setup  2 
Meter Values  2 
ROC Collect Data 2 
View Calibration Report 2 
View EFM Report 2 
File Close 1 
File Open 1 
File Print Configuration 1 
File Recent Files 1 
ROC Memory 1 
View Alarms > From File 1 
View Alarms > From Device 1 
View Events > From File 1 
View Events > From Device 1 
View History > From File 1 
View History > From Device 1 
View I/O Monitor 1 
File Exit 0 
File Print 0 
File Print Setup 0 
Help About ROCLINK 0 
Help Help Topics 0 
ROC Connect 0 
ROC Direct Connect 0 
Tools Customize 0 
Utilities Communications Monitor 0 
View Directory 0 
View Display > From File 0 
View Toolbar 0 
Window Cascade 0 
Window Currently Open Files 0 
Window Tile 0 

3.7.2 Device Security 
Use the Device Security screen to control who has access to the Comm 
Ports on a specific  device.  When you enable this feature, you must log 
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onto ROCLINK 800 to use the communications port. You can enable this 
feature on each communications port separately.  

To access the Device Security screen, select ROC > Security. The 
Device Security screen displays.  

 

Figure 3-9. Device Security 

Field Description 
User Table Click an operator ID in the table. The Device Security 

dialog box displays.   

 

Figure 3-10. Device Security 
Use this dialog box to edit the security on an existing 
operator ID. To add an operator ID, click on an 
empty cell in the table. The Device Security dialog 
box displays. Complete the dialog box as described 
below. To delete an operator ID, click a cell in that 
line. When the Device Security dialog box appears, 
click Remove. Answer Yes to the confirmation dialog 
box that displays. ROCLINK 800 removes the 
operator ID from the table.  
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Field Description 
Operator ID Sets the three alphanumeric characters for the 

operator ID, which is typically the initials of the 
person who operates the device through that 
communications port. The operator ID is case-
sensitive. Each operator ID must be unique.  

Password Sets the four numeric characters between 0000 and 
9999 for the password. More than one operator ID 
can have the same password.  

Confirm Password Validates the password you entered in the previous 
field. 

Access Levels Sets the access permitted to this operator ID.  Click 
 to display all options. 0 is the lowest access level 

and allows access to the fewest number of screens. 
5 is the highest access level and permits access to 
all screens. Each access level permits access to 
screens at that level and any inherited from lower 
access levels. For example, the IDs with access level 
3 can access screens with levels 0, 1, 2, and 3. 
Refer to Security Access Levels. 

Security One Enables security for each comm port. Valid values 
are: 
 Disabled: Accepts all login requests. This is the 

default.  
 User ID Enabled: Accepts login requests if the 

user (operator) ID and password are valid. On 
successful login, full access is allowed (access 
level 5). 

 User Access Level Enabled: Accepts login 
requests if the user (operator) ID and password 
are valid. Upon successful login, the user is 
restricted by access level. Refer to Security 
Access Levels. 

 
When you are finished, click Apply and then click OK to exit the screen.   
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Chapter 4 – The File Menu 

Use the File menu options to print, open, close, and save configuration 
files.  

 

Figure 4-1. File Menu  
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4.1 New Configuration 
You configure a FloBoss either by modifying an existing configuration 
file or by starting a new configuration file.  

The full configuration procedure involves using the menu functions or 
Configuration Tree Menu to access the configuration screens. Some of 
the configuration screens may not be required for your application or may 
not be available for your type of FloBoss. 

The following checklists present the order of configuration in a typical 
application. Omit configuration screens for modules and accessories that 
do not appear in your hardware configuration and for control elements 
(PID, FST, and such) that do not apply to your application. 

4.1.1 Configuration Checklist 
For a FloBoss 107:  
 ROC menu > ROCLINK 800 Security (logon) 
 Device Directory > Comm Port > Properties (PC communication 

configurations) 
 ROC menu > Security (User List and Comm Port Security) 
 ROC menu > Clock 
 ROC menu > Information (system variables) 
 ROC menu > Comm Ports (FloBoss communication configurations) 
 Configure menu > I/O menu > AI, AO, DI, DO, MVS, DVS, PIM, 

and PI 
 Meter menu > Setup 
 Configure menu > Control menu > PID Loop 
 Configure menu > Control menu > FST Registers 
 Configure menu > History Points 
 Utilities menu > FST Editor 
 View menu > Display > New or from File (for custom PC displays) 
 ROC menu > Flags (for saving and system variables to Flash 

memory) 

4.1.2 Duplicating a Configuration 
You can duplicate the configuration for another FloBoss by using these 
menu functions in the following order:  

1. File > Save Configuration to save a device’s configuration to a 
specified file. 

2. ROC > Direct Connect (Local Port) or Connect (modem) to connect 
physically to the second unit, and then communicate. 

3. File > Download loads the configuration into the unit. 
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After you have loaded configuration data into the second FloBoss (Step 
3) and changed it as needed, you can save the configuration to its own 
disk file by using Step 1. 

4.1.3 Creating a New Configuration File 
The New Configuration File screen allows you to create a configuration 
file off-line with the basic information about the meters and modules that 
will be installed on the FloBoss for which the new configuration was 
created.  

1. Select File > New. The New Configuration File screen displays.  

 
Figure 4-2. New File Configuration  

2. Select FB107 from the File Type frame. The lower portion of the 
New File Configuration screen changes to reflect the FB107.  

Note:  As you define the modules and place them in slots on the 
FB107, additional fields appear on the New Configuration 
File. Figure 4-3 shows a sample completed configuration.   
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Figure 4-3. New File Configuration (completed)  

3. Review and complete the following fields: 

Field Description 
File Type Associates the file type with a specific device. Select 

FB107 to build an off-line configuration file for the 
FB107.  

Control 
Configuration 

Indicates the number of PID loops, FSTs, and Meter 
Runs (AGAs) for the configuration.  
Note:  Activate only the necessary number of 

devices for your device.  
History Sizing Selects the maximum number of history points in 

Standard and Extended History (History Sizing).  
Caution: Select this value carefully: you cannot later 

add History Points without first clearing 
current history present in the unit. 

 Standard History archives up to 100 points of 
minimum/maximum (min/max), minute, hourly, 
and daily values. The min/max values are from 
today and yesterday; the minute values are from 
the last 60 minutes; hourly values are from the 
last 35 days; and daily values are from the last 
35 or 60 days.  

 Extended History can be configured to archive 
up to 25 points of user-selectable values, from 1 
second to 60 minute periods. Extended History 
archiving provides a monitoring resolution for the 
FloBoss that is similar to a chart recorder or data 
logger. 

Modules Indicates the type and number of modules you can 
install in the FB107.: Click  to display valid choices. 
 On-Board No I/O – CPU does not have an I/O 

assembly installed. Available only for slot 0.  
 On-Board 6-Pt I/O – CPU has an I/O assembly 

installed. Available only for slot 0.  
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Field Description 
 None – No module is installed in the slot. 
 RS-232 – Slot has an RS-232 communications 

module installed. Available only for slot 1 or 2. 
 RS-485 – Slot has an RS-485 communications 

module installed. Available only for slot 1 or 2.  
 MVS – Slot has an MVS module installed.  
 Aux 6-Pt I/O – Slot has an I/O module installed. 

Note:  FB107 modules are slot-specific. As you 
define the type and location of modules, 
ROCLINK 800 displays only those modules 
available for installation in any slot. .  

I/O Configuration Sets the configuration of I/O points for either a 6 
point CPU I/O assembly (On-Board 6 Point IO) or I/O 
module (Auxiliary 6 Point IO).  
Note:  This option displays only if you select the I/O 

module.  
250 Ohm Resistor 
Installed 

Sets, for analog inputs, whether the module supports 
4–20 mA or 0–5 V dc.  
Valid values are Yes (250 ohm resistor is installed 
and input uses 4–20 mA current) or No (250 ohn 
resistor is not installed and input uses 0–5 V dc 
current). The default is Yes.  

Integral Sensor Displays the type of Integral Sensor installed in the 
new configuration.  Valid values are None, a Dual-
Variable Sensor (DVS), or Pulse Input Module (PIM). 

 

4. Once you have completed the configuration, click Start. The Save As 
dialog box displays.   

5. Enter a file name for the configuration file. Configuration files for 
ROCLINK 800 use the extension .800. 

6. Click Save. ROCLINK 800 saves the new configuration file, and 
displays the following dialog.   

 
7. Click No to save the new configuration file and return to the New 

Configuration File screen.   
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4.2 Opening a Configuration File 
Use the Open option to open an existing configuration file either on-line 
(from a FloBoss) or off-line (from the PC’s hard drive or disk).  You use 
the Save Configuration function to create configuration files (see Section 
4.1.3, Creating a New Configuration File). To open a configuration file: 

1. Establish an on-line connection to the FloBoss, if opening a file on-
line.  

2. Select File > Open. The Open dialog box displays.  

3. Select the configuration file name. ROCLINK 800 files have the 
extension .800. 

4. Alter the parameters and point assignments as necessary. 

Once you open the configuration file, it automatically becomes the active 
configuration file and you may edit the file off-line. You can also load the 
configuration file into the FB107 using the Download function. 

4.3 Downloading a Configuration 
Use the Download option to download a saved configuration to a FloBoss 
device. You create configuration files using File > New Configuration. 
To download a saved configuration file: 

1. Connect to the FloBoss. 

2. Select File > Download. The Select File to Download dialog box 
displays.  

3. Select the configuration file name. ROCLINK 800 files have the 
extension .800. 

4. Click Open. The Download Configuration screen displays.  

 
Figure 4-4. Download Configuration 
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5. Select only the Configuration Points you desire to download. 
ROCLINK 800 grays out any items not configured in your 
configuration.  

Note:  Once you select a point, ROCLINK 800 activates the 
Download button.   

6. Click Download. ROCLINK 800 begins to download the 
configuration points you have chosen, and displays the status, point 
type, and point number information as the download progresses.  

7. Click OK when the download completes. 

8. Select ROC > Flags and click the Save Configuration for Flash 
Memory button. 

4.4 Saving a ROC User File 
In addition to keeping backup copies of the configuration file, it is also 
good practice to keep a backup copy of the ROC_USER.mdb file. This 
file contains the communications, security, and password settings for the 
FloBoss. 

To create a backup copy of the file: 

1. Open Windows Explorer and navigate to the folder where ROCLINK 
800 software is located. Typically, this folder is C:\Program 
Files\ROCLINK800. 

2. Create a copy of the ROC_USER.mdb file. 

3. Paste the copy into another folder on the PC or a disk. 

4.5 Saving a Configuration 
The Save option saves the current configuration of a connected device to 
a disk file. This feature is useful when creating a backup, when 
configuring similar FloBoss units for the first time, or when making 
configuration changes off-line. Once a backup configuration file is 
created, it can be loaded into a device using File > Download. 

1. Select File > Save Configuration. The Save As dialog box appears.  

2. Type the desired File name of the backup file. 

3. Click Save.  

ROCLINK 800 configuration files have the extension .800. 

4.5.1 Print Configuration 
Use the Print Configuration option to specify the point types that you 
desire to print.  

1. Select File > Print Configuration. The Print Configuration Setup 
screen displays.  
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Figure 4-5. Print Configuration 

Note:  This screen initially displays with all point types selected (as 
shown in Figure 4-5).  

2. Select the specific point types you desire to print. Use the Select All 
or Deselect All buttons to select multiple point types, point numbers, 
or parameters. Use your mouse to select/deselect individual point 
types, point numbers, or parameters.  

3. Click OK. ROCLINK 800 reads the configuration from the device 
and displays the Print Preview screen:  
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Figure 4-6. Print Preview 

4. Use screen option buttons (located on the toolbar) to either directly 
print the preview or export it (with a file name you specify) to your 
PC’s hard drive in one of the following formats:  
 PDF to create a .pdf (Portable Document File). 
 Excel to create an .xls spreadsheet file. 
 RTF to create an .rtf (Rich Text Format) file. 
 TXT to create a .txt text file. 
 HTML to create an .htm Internet browser file. 

4.6 Print 
Click Print or select Print from the File menu to print ROCLINK 800-
generated historical, event, and alarm log reports.  

4.7 Print Setup 
Use Print Setup to change the default printer for ROCLINK 800 
information.  



ROCLINK 800 User Manual (FB107) 

4-10 File Menu Issued Jan-08 

To change printers: 

1. Select File > Print Setup. 

2. Select the printer you desire to print to from the Name drop-down list.  

4.8 Recent Files 
The File menu also displays the configuration files that you have recently 
opened or saved:   

 
Figure 4-7. Recent Files 

4.9 Close 
Select Close from the File menu to close the active screen.  

Note:  Because the FB107’s graphic display is an active screen, selecting 
Close can terminate the online connection.   

4.10 Exit 
Select Exit under the File menu to exit the ROCLINK 800 program.  
Depending on your situation, the following occurs:  
 If you are currently editing a configuration file, ROCLINK 800 closes 

the file.  
 If you are currently connected to a dial-up FloBoss, ROCLINK 800 

issues a hang-up command to the modem.  
 If you are currently online with a FloBoss, ROCLINK 800 

automatically terminates the connection. 
 



ROCLINK 800 User Manual (FB107) 

Issued Jan-08 View Menu 5-1 

Chapter 5 – The View Menu 

Use the View menu options to view the Device Directory; electronic 
flow management (EFM) reports; calibration logs; history, alarms, and 
events logs; create and manage custom displays, and view the I/O 
monitor.  

 
Figure 5-1. View Menu Options  
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5.1 Directory 
Select View > Directory to replace the FB107 graphic image with the 
Device Directory.  The Device Directory displays the root level of all 
devices and groups configured in ROCLINK 800. 

Note:  You can also switch displays between the Device Directory and 
the online device using the Windows option on the ROCLINK 
800 menu bar.  

5.2 EFM Report  
Select View > EFM Report to generate printed and on-screen reports of 
the configuration, alarms, events, and historical flow data for a meter 
point.  ROCLINK 800 uses EFM (Electronic Flow Measurement) 
reports in conjunction with the FB107’s AGA flow calculation 
capabilities to display or print previously collected flow data. An EFM 
report file contains all flow data, which includes the operational 
characteristics (configuration parameters, history, events, and alarms) of 
each measured meter run configured in the FloBoss.  

5.2.1 Creating the EFM File  
Before you can view the EFM report data, you must first create the 
report file.  To create this file:  

1. Select ROC > Collect Data while the FloBoss is connected and 
communicating. A Collect Device Data dialog box displays.  

 
Figure 5-2. Collect Device Data (initial)  

2. Click OK. ROCLINK 800 collects information about the device to 
the designated .efm file. When the collection completes, the system 
displays a message at the bottom of the screen.  
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Figure 5-3. Collect Device Data (complete)  

Note:  Select Convert EFM File to convert the data to AGA/DET 
data format. 

3. Click Close. This creates the .efm file.  

Once you create this file, you can generate a report at any time (such as 
in the office) and a connection with the device is no longer necessary. 
The EFM Reports utility retrieves the data associated with the requested 
meter run and time period from the *.efm file and formats this report for 
each meter run covering a specified period of time. 

Note:  For the EFM Reports utility to function correctly, you must 
configure the historical database in the FloBoss so that the 
system can retrieve flow values from memory. Refer to 
Configuring History Points in Chapter 7.  

5.2.2 Viewing EFM Reports  
To view the EFM report:   

1. Select View > EFM Report. An Open dialog box displays, showing 
all files with an .EFM file extension.   

2. Select an .EFM file and click Open. The View EFM Report screen 
displays.  
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Figure 5-4. View EFM Report 

Field Description 
File  Displays the name of the EFM Report you have 

open. Information about the FloBoss displays in the 
Station Address and Station Name fields. 

Meter Run Select the Meter Run from drop-down list box to 
select the Meter Run on which you desire to report. 

Start Date/End Date Enter the Start Date. Enter the End Date. These are 
the dates for the period of the report you desire to 
cover.  
Note: Click  to view a calendar and select report 
          dates.  

Report Sections Select the Report Sections for the data to include in 
the EFM Report. 

 

3. Complete the fields (identifying the meter run, start and end report 
dates, and any report sections) and click Print Preview. A Print 
Preview screen displays.  
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Figure 5-5. Previewed EFM Report 

4. Use this screen to print the report at a printer or convert the report 
file to another format. Figure 5-6 shows the first page of a printed 
sample report.  
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Figure 5-6. Sample EFM Report 

5.3 Calibration Reports 
Create a calibration report to record the calibration procedure. 

5.3.1 Creating a Calibration Report 
To create a calibration report:  

1. Select Meter > Calibration. The Meter Calibration screen displays. 
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Figure 5-7. Meter Calibration 

2. Click Freeze to stop the system from updating the values of the 
analog, MVS, and temperature (RTD) inputs during verification or 
calibration. 

3. Click Yes in the confirmation dialog to create a calibration report. 

4. Enter the file name of the calibration report and use the default 
extension of .800 or .cal to represent calibration.  

5. Click Save. 

The system creates the calibration report file in the default directory 
C:/Program Files/ROCLINK 800, unless you specify another drive/ 
directory.  

Once the calibration is complete, you can view the report using View > 
Calibration Report or a text editor. 

5.3.2 Viewing an Existing Calibration Report 
To view a calibration report:  

1. Select View > Calibration Report. An Open dialog box displays.  

2. Select the Calibration Report you desire to view.  

3. Click Open. The View Calibration Report screen displays.  
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Figure 5-8. View Calibration Report 

4. Click Print Preview. The Print Preview screen displays.  

 
Figure 5-9. Calibration Report Print Preview 

5. Click Print… to print the report. ROCLINK 800 displays a Print 
window that allows you select the printer, number of copies, and 
other options.  

You can also export the report to different formats using the PDF, 
RTF, TXT, and HTML buttons on the tool bar. 

5.4 History, Alarm, and Event Log Reports 
The View menu option enables you to access and display the Minute, 
Hourly (Periodic), and Daily History Log reports (View > History); the 
Alarm Logs (View > Alarms); or the Event Logs (View > Events).  

You can retrieve these logs either from the device itself (if ROCLINK 
800 is currently connected) or from a previously saved file on your PC.  

Once you select the view, the system displays the log. ROCLINK 800 
provides several option buttons you can use to manage report data:  
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Option Description 
Plot  Graphically displays history data based on criteria 

you select.  
Note  This option is available only for history values 

obtained either from a connected device or 
from a file. Refer to Section 5.4.3, Plotting 
History.  

Select New Redisplays the Select History Points screen, which 
you can use to select new history values.  
Note:  This option is available only if you are viewing 

history data from the device.  

Save Saves the log as a file on your PC, using one 
following file name extensions you select:   

 .ALM Alarm log file 
 .EVT Event log file 
 .MDB Minute-based history log file.  
 .PDB Hourly (period) based history log file.  
 .DAY Daily based history log file. 
 .EDB Extended history log file.  
Print Preview Displays a preview of the report data. Refer to 

Section 4.5.1, Print Configuration for information on 
managing the print preview.  

Close Closes the display.  
 

5.4.1 Viewing History Logs from a Device 
When you choose to view history logs from a connected device, 
ROCLINK 800 displays a dialog box. You use this dialog to specify the 
report contents.  

1. Select View> History > From Device. The Select History to View 
screen displays.  
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Figure 5-10. Select History to View 

Note:  This screen initially displays with all points selected.  

2. Select or de-select the history points and history types to include on 
the view.  

3. Click OK. ROCLINK 800 retrieves the data you have selected and 
displays it on a preview screen.  
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Figure 5-11. History (from device)  

Note:  Click the Save button at the bottom of the screen to save the 
displayed contacts in a file. You can then view history logs 
without being connected to the FB107.  

4. Review the report and click Close to return to the FB107 graphic 
screen.   

5.4.2 Viewing History Logs from a File 
When you generate a history report, you can save it to a file (with a 
filetype of .mdb) for off-line viewing and analysis. However, you must 
save the report file to view it. ROCLINK 800 provides additional tools 
you can use to manipulate the data.   

1. Select View > History > From File. An Open dialog box displays.  

2. Select a file and click Open. A preview screen displays  

Note:  Refer to Section 5.4, History, Alarm, and Event Log Reports 
for valid file name extensions for history files.  
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Figure 5-12. History (from file)  

3. Review the file. Click Close to return to the FB107 graphic display.  
Note:  Click Print Preview to print the report contents (see Section 

4.5.1, Print Configuration) or Plot to create a graphic display 
of the report contents.   

5.4.3 Plotting History  
For history data from either a connected device or a file, ROCLINK 800 
provides an option on print preview screens that enables you to 
graphically present the report results.  

After you select the report data and display the preview screen, click 
Plot. ROCLINK 800 displays a graphical version of the selected data.  
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Figure 5-13. Plotted History 

The plot displays each series of lines as connected points of data, based 
on the time the data was archived and the current value at that time. The 
plot chart displays the type of history, device type, date, time, and the 
Operator ID in the header. The left (Y) axis displays the value and the 
bottom (X) axis displays the date and time the value was read. A legend 
at the bottom of the graph corresponds with the lines within the graph. 

Use the scroll bar to the left of the graph to change the Y-axis.  

Graphics zoom enlarges the selected area of a chart, while not 
necessarily showing the axes. 

Axis zoom changes the minimum and maximum data values to those 
selected and redraws only that data with the axes. 

Graphics Zoom 
an Area 

To zoom into an area of the plot:  

1. Press Ctrl and hold down the left mouse button. 

2. Drag the mouse to select zoom area and release the mouse button.  
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3. Press r to remove the effect and restore the original plot.  

Axis Zoom 
the Chart 

To zoom into a particular axis of the plot:  

1. Press Shift and hold down the left mouse button. 

2. Drag the mouse to select the zoom area and release the mouse 
button. 

3. Press r to remove the effect and restore the original plot.  

5.4.4 Viewing Alarm Logs 
You can view a log of all alarms on your connected FloBoss. 

1. Select View > Alarms > From Device. An alarm preview screen 
displays.  

  
Figure 5-14. Alarm Preview 

2. Review the alarms preview, and click Close to return to the FB107 
graphic display.  

Note:  Click Print Preview to print the report contents (see Section 
4.5.1, Print Configuration) or Save to save the preview to a 
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file for off-line viewing (select View > Alarms > From 
File).   

5.4.5 Viewing Event Logs  
 You can view a log of all events on your connected FloBoss.  

1. Select View > Events > From Device. An events preview screen 
displays.  

  
Figure 5-15. Events Preview 

2. Review the events preview, and click Close to return to the FB107 
graphic display.  

Note:  Click Print Preview to print the report contents (see Section 
4.5.1, Print Configuration) or Save to save the preview to a 
file for off-line viewing (select View > Events > From File).   
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5.5 Display Administrator 
Use the Display Administrator screen to manage custom displays stored 
in the FB107.  The FB107 can store a maximum of 40 displays, which 
includes both custom user displays (that your organization may create) 
and user program displays (that accompany User C programs).   

To view the display files stores in the FB107:  

1. Select View > Display > From Device > Administrator. The 
Display Administrator screen displays, showing all displays 
currently loaded in the FB107.   

 
Figure 5-16. Display Administrator 

2. Select an empty slot.  
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Figure 5-17. Display Administrator 

3. Click Browse to open the Select User Display File. Double-click a 
display file to load. The Display Administrator screen redisplays 
with Download now active.  

4. Click Download to add the user display to the FB107.  

 
Figure 5-18. Display Administrator 

ROCLINK 800 prompts you to verify the installation, loads the file, 
displays a verification message, and updates the display.   
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Note:  Use the Flash File System frame on this screen to monitor the 
number of available bytes used and remaining. Use Remove 
to delete a display file from the FB107.    

5. Click Close to return to the FB107 graphic display.   

5.6 Custom Displays 
The custom display option in ROCLINK 800 software allows you to 
create customized FB107 displays or load a display from a file. The 
FB107 can store up to 40 displays (including both custom user displays 
you create and user program displays that accompany user programs).  
 

 Caution You should be familiar with Visual Basic before attempting to create 
custom displays.  

 
You can add fields to monitor flow, I/O points, and other TLPs. Select 
View > Display > New. A blank Display Editor screen displays.   

 
Figure 5-19. Display Editor 

By adding objects (tabs, fields, labels, text, etc.) to the display, you can 
incorporate “live” data as well as images and other information you 
wish to convey. One use of custom displays is to graphically represent 
the application that an FB107 monitors and controls. Another use is to 
monitor the FB107, giving you to opportunity to change commonly used 
parameters from a single screen.  

Object buttons on toolbar 

Object Properties box 

Display Editor 
toolbar 
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Each custom display has parameters specific to the entire display that 
you are creating. By default, the system places the Display object 
properties box at the upper right of the screen in a pop-up window. A 
similar object properties box displays for each object you add to the 
display.  

Drag and drop the object buttons from the toolbar to the Display Editor 
screen and set the associated parameters. Each option has parameters 
associated with it depending on the type of option you have selected and 
you can customize the parameters in the object properties box.  

Note:  Custom displays are not compatible between ROCLINK for 
Windows and ROCLINK 800 Configuration software. 

Sections 5.6.1 and 5.6.2 discuss the process of creating a new custom 
display and adding and arranging objects on that display.  

5.6.1 Creating a New Custom Display 
To create a new display:  

1. Select View > Display > New. A blank Display Editor screen 
displays.  
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Figure 5-20. Display Editor (blank)  

Note:  You can also click the New Display button (at the extreme 
left of the Display Editor toolbar) to create a new display.  

2. Specify the properties for the new custom display:   

Field Description 
Display Name  Names the display. Although you can enter up to 

120 characters for a screen name, a maximum of 
10-20 characters should be sufficient to uniquely 
name the screen.  

Logical Point List Indicates whether the display is unique or one of 
several iterations. Click  (which appears when you 
click the field) to display the values. Valid values are 
Disabled (screen is unique) or Enabled (number of 
screens equals the number of logicals). The default 
is Disabled.   
Note:  The number of screens is based of the 

number of logicals for the first point type 
selected in the Point Type field.  

New Display button 
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Field Description 
Point Type(s)  Sets, if you enable the Logical Point List option, the 

point type(s) whose logicals track the iteration of the 
display. Click … (which appears when you click the 
field) to display the Select Point Type(s) screen. Use 
that screen to associate one or more point types 
with this Logical Point List.   

Picture  Identifies a graphic used for the background of the 
display. Click … (which appears when you click the 
field) to display a Select Picture File screen. Use 
that screen to associate an image with the display.  

Menu Location  Allows you to hide, replace, or rename a menu 
selection in the ROCLINK 800 menu. This option 
applies only to displays physically residing in the 
FB107.  

 Hide Hides a menu selection in the Meter, 
View, or ROC menu. Requires the 
syntax H:menuname.submenuname 
(as in H:Meter.Plate Change).  

 Replace Replaces a screen in the Meter menu 
with the current custom display. 
Requires the syntax 
R:menuname.submenuname (as in 
R:Meter.Setup).  

 Rename Replaces a menu in the Meter, View, or 
ROC menu with the current display 
using the indicated name. Requires the 
syntax N:menuname.submenuname: 
newsubmenuname (as in 
N:Meter.Calibration:Coriolis Cal).  

 Note:  Use a comma to hide, replace, or rename 
multiple features, as in 
N:Meter.Calibration:Coriolis 
Cal,N:Meter,Calibration:Central Cal.  

Tree Location  Currently unavailable.   
Update Mode  Sets when the system updates data on this screen. 

Valid values are Normal (system does not update 
the screen content) or AutoScan (system updates 
the screen content based on the interval you specify 
in the Auto Scan Update Interval field on the 
Options screen (Tools > Options). The default 
value is Normal.  
Note:  If you include dynamic content on your 

custom display, you may want the system to 
refresh that content for the most current 
values.  

 

3. Add display content to the custom display. You can either drag an 
object from the toolbar and place it on the custom display or place 
the cursor on the display where you want the object, right-click, and 
select from the pop-up menu. Refer to Section 5.6.2, Adding Custom 
Display Objects, for a description of each object and its properties. 



ROCLINK 800 User Manual (FB107) 

5-22 View Menu Issued Jan-08 

 Add as many objects to the screen as you need. You can place 
objects anywhere on the Display Editor screen. Use a frame with 
a label to logically group certain options (such as option buttons 
or check boxes) to ensure that others know the use context for 
the options.  

 For each object you enter, complete that object’s Properties box. 
Each object’s Properties box has different items, and you can 
edit those properties at any time.   

 Move and re-shape objects within the display as necessary. To 
modify an object’s placement or shape:  
o Click and drag on the control squares to change the size of 

the object.  
o Press Shift + arrow keys to change an object’s size. Press 

Shift +Alt + arrow keys for smaller changes. 
o Press Ctrl + arrow keys to move an object to the desired 

position. Press Ctrl + Alt + arrow keys for smaller moves. 
o Select the Align Lefts icon to align all selected objects to the 

furthest left point in the group. 
o Select the Size to Widest icon to change the width of all 

selected objects to the width of the widest element. 
o Select the Make Vertical Spacing Equal icon to evenly 

adjust the vertical spacing between all the selected objects. 
o Select the Make Horizontal Spacing Equal icon to evenly 

adjust the horizontal spacing between all the selected objects. 
o Remove objects by selecting the object and pressing Delete.  

4. Click the Test icon to verify that the completed custom display 
works correctly.  

5. Click the Save Display to File icon to save the completed and tested 
custom display. ROCLINK 800 displays use the suffix .DSP (as in 
TestScreen.dsp).  



ROCLINK 800 User Manual (FB107) 

Issued Jan-08 View Menu 5-23 

5.6.2 Adding Custom Display Objects 
The right-hand side of the Display Editor toolbar includes a number of 
buttons for custom objects (see Figure 5-21).  

 
Figure 5-21. Custom Display Objects 

Tab Control 
 

Adds an eight-tab image, which you can size appropriately and edit to 
fewer tabs. You can then drag and drop objects onto each tab.   
This object has the following properties:  

 
Property Description 
Tabs Sets the number of tabs (up to 8) on the screen. 

Click  (which displays when you click in the field) to 
specify the number of tabs.  

Caption 1 through 8  Sets a label or caption for each tab. The size of the 
tab increases to accommodate the text.  

Allow Data Entry Sets whether the user can edit the object. Click  
(which displays when you click in the field) to display 
the valid values:  

 Yes Allows editing. This is the default.  
 No Does not allow editing.   
 Expression Editing is permitted based on a Visual 

Basic expression. This option opens 
an Expression Builder window which 
you use to determine the conditions 
under which the data entry is allowed. 
Refer to Section 5.6.4, Adding an 
Expression to an Object. 

Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  
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 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section 5.6.4, Adding an Expression 
to an Object.  

Tab Order  Sets the object-to-object order the cursor follows on 
the custom display when you press the Tab key.  
Note:  For greatest efficiency, use the Set Tab-Key 

Order option (accessed through the Other 
Tools button on the toolbar) to set this 
sequence when you have finished defining all 
the objects on the custom display.  

 
Frame 

 
Adds an organizing frame, which you use to group similar user 
selections. Once a frame is in place, drag and drop objects onto the 
frame. 
This object has the following properties:  

 
Property Description 
Caption  Sets a label or caption for the object. The default is 

Frame(1); the system uniquely names each object 
until you rename it.   

Allow Data Entry Sets whether the user can edit the object. Click  
(which displays when you click in the field) to display 
the valid values:  

 Yes Allows editing. This is the default.  
 No Does not allow editing.   
 Expression Editing is allowed based on a Visual 

Basic expression. This option opens 
an Expression Builder window which 
you use to determine the conditions 
under which the data entry is allowed. 
Refer to Section 5.6.4, Adding an 
Expression to an Object. 

Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   
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 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section 5.6.4, Adding an Expression 
to an Object.  

Tab Order  Sets the object-to-object order the cursor follows on 
the custom display when you press the Tab key.  
Note:  For greatest efficiency, use the Set Tab-Key 

Order option (accessed through the Other 
Tools button on the toolbar) to set this 
sequence when you have finished defining all 
the objects on the custom display.  

 
Label 

 
Adds labels to identify objects. This object has the following properties: 

 
Property Description 
Caption  Sets a label or caption for the object. The default is 

Label(1); the system uniquely names each object 
until you rename it.  

Alignment Indicates where the label text displays. Click  
(which displays when you click in the field) to display 
the valid values: Left (text is flush left), Right (text is 
flush right), or Center (text is centered).  

TLP Associates the object with a TLP. Click … (which 
displays when you click in the field) to display a 
Select TLP screen you use to define the associated 
TLP.  

Expression Associates the object with a Visual Basic expression. 
Click … (which displays when you click in the field) to 
display an Expression Builder window which you use 
to define the expression. Refer to Section 5.6.4, 
Adding an Expression to an Object. 
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Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section 5.6.4, Adding an Expression 
to an Object.  

Tab Order  Sets the object-to-object order the cursor follows on 
the custom display when you press the Tab key.  
Note:  For greatest efficiency, use the Set Tab-Key 

Order option (accessed through the Other 
Tools button on the toolbar) to set this 
sequence when you have finished defining all 
the objects on the custom display.  

 
Text Box 

 
Adds a data entry field. This object has the following properties:   

 
Property Description 
Text  Sets text that appears in the object. You can enter as 

many characters as necessary. Use the control 
squares to change the size of the text box. The 
default is TextBox(1); the system uniquely names 
each object until you rename it. 

TLP Associates the object with a TLP. Click … (which 
displays when you click in the field) to display a 
Select TLP screen you use to define the associated 
TLP.  

Allow Data Entry Sets whether the user can edit the object. Click  
(which displays when you click in the field) to display 
the valid values:  

 Yes Allows editing. This is the default.  
 No Does not allow editing.   
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 Expression Allows editing based on a Visual 
Basic expression. This option opens 
an Expression Builder window which 
you use to determine the conditions 
under which the data entry is allowed. 
Refer to Section 5.6.4, Adding an 
Expression to an Object.  

Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section 5.6.4, Adding an Expression 
to an Object. 

Tab Order  Sets the object-to-object order the cursor follows on 
the custom display when you press the Tab key.  
Note:  For greatest efficiency, use the Set Tab-Key 

Order option (accessed through the Other 
Tools button on the toolbar) to set this 
sequence when you have finished defining all 
the objects on the custom display.  

 
Option Button 

 
Adds a radio button to limit input to a single selection. This object has 
the following properties:  

 
Property Description 
Caption  Sets a label or caption for each object. The default is 

OptionButton(1); the system uniquely names each 
object until you rename it. 

TLP Associates the object with a TLP. Click … (which 
displays when you click in the field) to display a 
Select TLP screen you use to define the associated 
TLP.  
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Mask Value Identifies individual bits of an 8-bit integer ROCLINK 
uses when calculating the value to be compared to 
the value specified in the Selected When or 
Checked When fields. ROCLINK performs a 
mathematical AND comparing this masked value and 
the value in the Selected When or Checked When 
field and activates the button or box if the values are 
equal. The default value is 255. 

Selected When = Specifies the value at which the option button 
activates. Works in conjunction with the value in the 
Mask Value field.   

Allow Data Entry Sets whether the user can edit the object. Click  
(which displays when you click in the field) to display 
the valid values:  

 Yes Allows editing. This is the default.  
 No Does not allow editing.   
 Expression Allows editing based on a Visual 

Basic expression. This option opens 
an Expression Builder window which 
you use to determine the conditions 
under which the data entry is allowed. 
Refer to Section 5.6.4, Adding an 
Expression to an Object.   

Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section 5.6.4, Adding an Expression 
to an Object.  

Tab Order  Sets the object-to-object order the cursor follows on 
the custom display when you press the Tab key.  
Note:  For greatest efficiency, use the Set Tab-Key 

Order option (accessed through the Other 
Tools button on the toolbar) to set this 
sequence when you have finished defining all 
the objects on the custom display.  
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Check Box 
 

Adds a check box for multiple selections. This object has the following 
properties:  

 
Property Description 
Caption  Sets a label or caption for the object. The default is 

CheckBox(1); the system uniquely names each 
object until you rename it.  

TLP Associates the object with a TLP. Click … (which 
displays when you click in the field) to display a 
Select TLP screen you use to define the associated 
TLP.  

Mask Value Identifies individual bits of an 8-bit integer ROCLINK 
uses when calculating the value to be compared to 
the value specified in the Selected When or 
Checked When fields. ROCLINK performs a 
mathematical AND comparing this masked value and 
the value in the Selected When or Checked When 
field and activates the button or box if the values are 
equal. The default value is 255. 

Checked When = Specifies the value at which the checkbox activates. 
Works in conjunction with the value in the Mask 
Value field.   

Allow Data Entry Sets whether the user can edit the object. Click  
(which displays when you click in the field) to display 
the valid values:  

 Yes Allows editing. This is the default.  
 No Does not allow editing.   
 Expression Allows editing based on a Visual 

Basic expression. This option opens 
an Expression Builder window which 
you use to determine the conditions 
under which the data entry is allowed. 
Refer to Section 5.6.4, Adding an 
Expression to an Object.  

Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
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 Expression Visibility is based on a Visual Basic 
expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section 5.6.4, Adding an Expression 
to an Object. 

Tab Order  Sets the object-to-object order the cursor follows on 
the custom display when you press the Tab key.  
Note:  For greatest efficiency, use the Set Tab-Key 

Order option (accessed through the Other 
Tools button on the toolbar) to set this 
sequence when you have finished defining all 
the objects on the custom display.  

 
Combo Box 

 
Adds a list of options that opens when you click . This object has the 
following properties:  

 
Property Description 
TLP Associates the object with a TLP. Click … (which 

displays when you click in the field) to display a 
Select TLP screen you use to select the associated 
TLP.  

Item List Enables you to build a drop-down list of up to 30 
selectable items. Click … (which displays when you 
click in the field) to display an Item List screen:  

 
Use this screen to add items to the drop-down menu. 
ROCLINK 800 expands the list as you add items. 
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 Item Value Associates the label in the drop-down 
menu with a value in the designated 
TLP.  

 List Item Sets the label that appears in the 
drop-down menu.  

Allow Data Entry Sets whether the user can edit the object. Click  
(which displays when you click in the field) to display 
the valid values:  

 Yes Allows editing. This is the default.  
 No Does not allow editing    
 Expression Allows editing based on a Visual 

Basic expression. This option opens 
an Expression Builder window which 
you use to determine the conditions 
under which the data entry is allowed. 
Refer to Section 5.6.4, Adding an 
Expression to an Object.  

Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section 5.6.4, Adding an Expression 
to an Object 

Tab Order  Sets the object-to-object order the cursor follows on 
the custom display when you press the Tab key.  
Note:  For greatest efficiency, use the Set Tab-Key 

Order option (accessed through the Other 
Tools button on the toolbar) to set this 
sequence when you have finished defining all 
the objects on the custom display.  
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Line 
 

Adds a line to mark borders between objects. This object has the 
following properties:  

 
Property Description 
Line Width Sets the thickness of the line. The default is 1.   
Color  Sets the color of the object. Enter a hexadecimal 

color value or click in the field to display a Color 
screen, which you use to assign a color to the object. 

Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section 5.6.4, Adding an Expression 
to an Object. 
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Rectangle 
 

Adds a rectangle to mark borders between objects. This option has the 
following properties:  

 
Property Description 
Color  Sets the color of the object. Enter a hexadecimal 

color value or click in the field to display a Color 
screen, which you use to assign a color to the object. 

Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section 5.6.4, Adding an Expression 
to an Object. 

 
Oval 

 
Adds an oval to mark borders between objects. This object has the 
following properties:  

 
Property Description 
Color  Sets the color of the object. Enter a hexadecimal 

color value or click in the field to display a Color 
screen, which you use to assign a color to the object. 
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Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section 5.6.4, Adding an Expression 
to an Object.  

 
Image 

 
Adds an image (.JPG, .BMP, .PNG, .GIF, or other graphic formats) 
from a file. This object has the following properties:  

 
Property Description 
Picture  Sets an image (.JPG, .BMP, .GIF, or other graphic 

formats) to display with the object. Click in the field to 
display a Select Picture File screen which you use to 
indicate the appropriate image. The default is None.  

Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section 5.6.4, Adding an Expression 
to an Object. 
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Chart 
 

Adds a chart to represent data graphically.  
Note:  You can view real-time data by configuring what figures display 

on the chart. After you configure the chart, view the display and 
select Auto-Scan. The chart displays the collected data in real-
time. You cannot save the chart data to system memory. 

This option has the following properties:  

 
Property Description 
Header  Sets a title for the object.  
TLP 1  through 4 Associates up to four TLPs with the chart. Click … 

(which displays when you click in the field) to display 
a Select TLP screen you use to define the TLPs. 

 
Button 

 
Adds a button to the screen. This object has the following properties:  

 
Property Description 
Caption  Sets a label or caption for the object. The default is 

Button(1); the system uniquely names each object 
until you rename it.  

Action Associates an activity with the button. Write Value is 
the only action currently associated with this control. 
The system writes the value identified in the Value 
property   

TLP Associates the object with a TLP. Click … (which 
displays when you click in the field) to display a 
Select TLP screen you use to define the TLP.  
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Value Opens an Expression Builder window which you use 
to determine the conditions under which the object is 
visible. Refer to Section 5.6.4, Adding an Expression 
to an Object. 

Enabled Indicates whether the button is active. Valid values 
are:  

 Yes Object is always active. This is the 
default.  

 No Object is not active.  
 Expression Selection is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section 5.6.4, Adding an Expression 
to an Object.  

Visible Indicates whether the object appears in the final 
version of the display. Click  (which displays when 
you click in the field) to display the valid values:   

 Yes Object is always visible. This is the 
default.  

 No Object is not visible.  
 Expression Visibility is based on a Visual Basic 

expression. This option opens an 
Expression Builder window which you 
use to determine the conditions under 
which the object is visible. Refer to 
Section 5.6.4, Adding an Expression 
to an Object.  

Tab Order  Sets the object-to-object order the cursor follows on 
the custom display when you press the Tab key.  
Note:  For greatest efficiency, use the Set Tab-Key 

Order option (accessed through the Other 
Tools button on the toolbar) to set this 
sequence when you have finished defining all 
the objects on the custom display.  

5.6.3 Managing Custom Display Objects 
The left-hand side of the Custom Display toolbar provides utilities you 
use to manage the objects placed on the custom display (see Figure 5-
22).  

 
Figure 5-22. Object Management Tools 
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New Display 
 

Creates a new custom display file.   

 
Open Display File 

 

Opens an existing custom display file. Click this button to display an 
Open screen that shows all available .DSP files in the default 
ROCKLINK 800 directory. If you store .DSP files elsewhere, use this 
screen to navigate to that location and select a file.   

 
Save Display to File 

 
Saves the current display. Click this button to display a Save As screen 
that shows the .DSP files in the default ROCKLINK 800 directory. If 
you store .DSP files elsewhere, use this screen to navigate to that 
location and save the display file.   

 
Test 

 
Closes edit mode for the custom display and shows the custom display 
as defined. If any errors exist, the system displays appropriate error 
messages.   

 
Align Lefts 

 
Aligns selected objects to the left. Click  to display a drop-down 
menu that provides more specific alignment options:   

 

 
 

Size to Widest 

 

Adjusts the size of the selected objects to the width of the widest object. 
Click  to display a drop-down menu that provides more specific sizing 
options:   
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Make Vertical Spacing 
Equal 

 

Equalizes the vertical spacing between the selected objects. Click  to 
display a drop-down menu that provides more specific spacing options:  

 

 
 

Make Horizontal 
Spacing Equal 

 

Equalizes the horizontal spacing between the selected objects. Click  
to display a drop-down menu that provides more specific spacing 
options:   

 

 
 

Other Tools 
 

Provides additional object-management tools. Click  to display a 
drop-down menu that provides more specific spacing options:   

 

 
 
Option Description 
Set Tab-Key Order Allows you to specify the object-to-object sequence 

for the cursor on the custom display when you press 
Tab. When you click this option, the system displays 
a message:  
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Import Display 
Objects 

Allows you to import another custom display into the 
current custom display. Use this to quickly duplicate 
custom displays or build similar custom displays.  
When you click this option, the system displays an 
Import screen that you use to select the .DSP file to 
import.  

Export Display 
Objects 

Allows you to save the current custom display.  
When you click this option, the system displays a 
Save As screen. Use it to save the .DSP file to the 
default (or other) ROCLINK 800 directory.  

 
Lock Controls 

 
Restricts the movement of objects on the custom display. This control is 
helpful when you want to make minor changes to the custom display 
without accidentally modifying the location of objects.   

5.6.4 Adding an Expression to an Object 
Some custom display objects—tab, label, button, text box, option, check 
box, combo box, line, circle, square, and image—allow you to add 
Visual Basic expressions that cause the display to change under specific 
conditions.   

The Expression Builder screen enables you to quickly build and test a 
Visual Basic expression to provide customized functioning. For 
example, you could set a frame’s Visible property to Expression and 
then specify the conditions (such as a particular TLP value) under which 
the frame displays. Until that value occurs, the frame does not appear on 
the custom display.  
 

 Caution We strongly suggest prior experience in Visual Basic programming if you 
want to create display element expressions. 

 
To add an expression:  

1. Click an object’s property that includes Expression as an option.  

2. Click  and select Expression.  

3. Click … (which displays as part of the Expression option). The 
Expression Builder screen displays:  
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Figure 5-23. Expression Builder 

Note:  If you are skilled in Visual Basic or already know the specific 
expression you want to add, you can enter the desired 
expression directly in the upper (Expression) box on this 
screen.  

4. Build an expression using the buttons immediately under the 
Expression box and/or the three boxes in the center of the screen. 
Click Add to include each expression component to the screen.   

Note:  Based on your selected expression category, ROCLINK 800 
changes the options displayed in the other two boxes to help 
you in the building process. Additionally, ROCLINK 800 
displays definitions and explanations at the bottom of the 
screen.  

5. When your expression is complete, click Evaluate. ROCLINK 800 
checks your expression for errors. Correct any errors.   

6. Click OK when your expression is complete. The Display Editor 
screen displays.  

Note:  At this point it is strongly recommended that you save the 
custom display to save the expression.  
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5.6.5 Editing a Custom Display from a File  
Once you have created a custom display, you save the display as a .DSP 
file you can later edit. Click Save Display to File on the Display Editor 
toolbar and indicate the name and location for the saved display.   

To edit a saved display, select View > Display > From File. An Open 
screen displays. Select the .DSP file and click Open. ROCLINK 800 
opens that display.  

If Edit is not included in the buttons displayed at the bottom of the 
ROCLINK 800 screen, you need to change the attributes of the .DSP 
file. Using Window’s Explorer, access the directory that houses your 
.DSP files (typically C:\Program Files\ROCLINK800\Displays, if you 
accepted defaults during system installation). If you store your .DSP 
files in another location, access that directory. Locate the .DSP file and 
left-click the file to display a pop-up menu. Select Properties. A 
window similar to this one should appear:  

 
Figure 5-24. Properties 

Uncheck the Read-only Attributes box and click Apply. You can now 
edit the .DSP file.  

5.7 I/O Monitor 
Use I/O Monitor to view all installed and active I/O points, MVS 
values, and flow calculations that provide information configured in the 
FloBoss and its operating environment.   
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1. Select View > I/O Monitor. The Select Points to Monitor dialog 
box displays.   

 
Figure 5-25. Select Points to Monitor 

2. Select the points you want to monitor. Click the plus sign next to 
each item to expand the selection. Click Select All or Deselect All 
to select or deselect all points.  

3. Click OK. ROCLINK 800 displays a screen showing the point 
information you have requested and automatically updates the on-
screen values.  
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Figure 5-26. I/O Monitor 

5.8 Toolbar 
Select View > Toolbar to display or hide the ROCLINK 800 toolbar. A 
checkmark appears next to the menu option when the toolbar is 
available.  

For information on buttons in the toolbar refer to Section 1.6.4, Toolbar 
Buttons.  
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Chapter 6 – The ROC Menu 

Use the ROC menu options to set system information for the FloBoss.   

 
Figure 6-1. Collect Device Data 

In This Chapter 

6.1 Direct Connect.................................................................................6-1 
6.2 Disconnect.......................................................................................6-2 
6.3 Collecting ROC Data .......................................................................6-2 
6.4 Setting the Clock .............................................................................6-3 
6.5 ROC Security...................................................................................6-3 
6.6 ROC Comm Ports ...........................................................................6-4 
6.7 ROC Device Memory ......................................................................6-4 
6.8 Configuring Device Information .......................................................6-4 

6.8.1 Device Information General Tab..........................................6-5 
6.8.2 Device Information Points Tab.............................................6-6 
6.8.3 Device Information Other Information Tab...........................6-7 
6.8.4 Device Information Revision Info Tab..................................6-8 

6.9 CPU Information..............................................................................6-8 
6.9.1 CPU Information General Tab .............................................6-8 
6.9.2 CPU Information Advanced Tab ........................................6-10 
6.9.3 CPU Information I/O Points Tab ........................................6-11 
6.9.4 CPU Information Meter Points Tab....................................6-12 
6.9.5 CPU Information Diagnostic Tab .......................................6-13 

6.10 Flags..............................................................................................6-14 
6.10.1 Flags General Tab .............................................................6-14 
6.10.2 Returning a Device to Factory Default Settings.................6-17 
6.10.3 Flags Advanced Tab ..........................................................6-17 

 

6.1 Direct Connect  
Use this option to connect to the FB107 via the LOI port. You can also 
directly connect to the FB107 by clicking the Direct Connect icon ( ) 
on the ROCLINK 800 menu bar.   
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6.2 Disconnect  
Use this option to disconnect from the FB107. You can also disconnect 
by clicking the Disconnect icon ( ) on the ROCLINK 800 menu bar.   

6.3 Collecting ROC Data 
Use this option to save FloBoss electronic flow management (EFM) data 
to disk files.  Data includes:  
 Configuration data. 
 Hourly volume data. 
 Daily volume data. 
 Alarm Log data. 
 Event Log data. 

Once you select ROC > Collect Data, the Collect Device Data screen 
displays.  

 
Figure 6-2. Collect Device Data 

Field Description 
Collect   This read-only check box allows the Collect Data 

function to save all values for EFM parameters in a 
.EFM file.  

Save As Sets a file name (other than the default shown) to 
which the FB107 saves .EFM information.  

Convert EFM File Launches the EFM file conversion utility. After the 
system collects EFM data, you can convert the data 
to an .AGA, .CFX, or .DET file for subsequent import 
into the PGAS or Flow-Cal metering report 
applications.  
Note:  You can also select this utility by selecting 

Utilities > Convert EFM File.  
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6.4 Setting the Clock 
Immediately after connecting to a FloBoss for the first time, you should 
set the clock to ensure that the FB107 properly logs history.  

The internal real-time clock provides time-stamping and control of the 
historical databases, Event Log, and Alarm Log.  

Note:  The user-selectable time stamp in the FloBoss reflects the time 
either at the beginning or at the end of the period. Select 
Configure > History Points > Setup tab to adjust this preference 
in the History Time Stamp field.  

1. Select ROC > Clock or click the Clock icon in the toolbar. The 
Clock screen displays.  

 
Figure 6-3. Clock 

2. If the clock in your PC is set correctly, you can use it to set the 
FloBoss clock. Click Today at the bottom of the calendar.  

3. If the PC clock is not correct: 
 Use the arrow buttons to select the correct Month and Year. You 

can also click the Month to select the exact month or the Year and 
use the arrows to select the desired Year. 

 Click on the desired day of the month. 
 Click on the time field and type in the desired value (type P or A 

for the AM/PM field) or use the arrows.  

4. Click Apply if you changed any fields on this screen.  

5. Click OK. 

6.5 ROC Security 
For a complete discussion of device security, refer to Section 3.7.2, 
Device Security.  
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6.6 ROC Comm Ports 
For a compete discussion on configuring communication ports, refer to 
Section 3.4, Configuring FB107 Communications Ports.  

6.7 ROC Device Memory 
Use this option in troubleshooting and advanced diagnostics to display a 
screen that shows the memory address as a single hex address for the 
FloBoss.   

1. Select ROC > Memory. The Device Memory screen displays.  

 
Figure 6-4. Device Memory 

2. Complete the Address field with a vallid range of memory location 
and click Update.  

ROCLINK 800 updates the display to show the contents of 240 bytes 
of memory. The hexadecimal values appear on the left side of the 
screen; ASCII character equivalents appear on the right.  

Click Next Block and Previous Block to view the previous or next 
block (240 bytes) of memory. If you are viewing data that may be 
changing, click the Update button to refresh the screen with the most 
recent values from the FloBoss. 

3. Click Close to exit the Device Memory screen. 

6.8 Configuring Device Information 
Use this option to set a number of variables—including station name, 
address, group, active PIDs and associated history points, and other 
global variables—as well as review device information that differentiates 
each individual FB107.  

The Device Information screen has four tabs:   
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 General tab, which provides basic information about the FB107. 
 Points tab, which allows you to change point-related information.  
 Other Information, which displays customer information.  
 Revision Info, which displays firmware and boot information.  

6.8.1 Device Information General Tab 
The General tab has basic information about the FloBoss.  

1. Select ROC > Information. The Device Information screen displays, 
showing the General tab.  

 
Figure 6-5. Device Information, General tab 

2. Review the following fields for your organization’s values:  

Field Description 
Station Name   Sets the station name logged into EFM reports.   
Device Type  This read-only field shows the currently attached 

device.  
Address Sets a unique address for this FB107 that 

differentiates it from all other FB107s in a 
communication group. Valid values are 1 to 255.  
Note:  To avoid communications problems, do not 

use 240.  
Group Sets a number that identifies a group of FB107s for 

communication purposes. All FB107s defined as an 
area in the host must have the same group. Valid 
values are 1 to 255.  
Note:  To avoid communications problems, do not 

use 240. With ROC Protocol, the values in the 
Address and Group fields must match the 
address defined in the destination device for 
communications to work.   

Contract Hour Sets the hour at which the system totals values for a 
single day of production, clears accumulators, and 
logs data to the Daily History database. The contract 
hour is based on a 24-hour clock using 0 as the 
midnight hour.  
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Field Description 
Force End of Day Logs, when you select this check box and click 

Apply, the current day and its hourly values into 
memory for all historical data, with the exception of 
station totals. This field also resets the daily and 
hourly accumulator.  
Note:  This option uses of the 35 possible slots for 

storing daily data.  
Units Sets the engineering units of measure. If you select 

Metric, the AGA calculations expect all input in the 
terms of the indicated units (such as kPa for static 
pressure input). The system expresses calculation 
results in the selected units.  

FST Execution  Specifies how many FST instructions can be 
executed per FST execution cycle. Execution period 
is based on system scan speed. The default number 
of instructions is 20. Under the default value, an FST 
with 30 sequential instructions runs in two execution 
periods, with 20 instructions in the first cycle and 10 
in the second.  
Note:  Any changes to this value take effect in the 

next execution cycle. Re-start is not required. 
To reduce the potential risk of loading on the 
FB107, monitor the MPU loading when 
making changes to this parameter. See 
Section 6.8.3, Device Information Other 
Information Tab. 

 

3. Click Apply if you change any parameters on this screen.   

4. Proceed to Section 6.8.2, Device Information Points Tab.   

6.8.2 Device Information Points Tab 
The Points tab displays history point information.  

1. Select the Points tab on the Device Information screen. The Points 
tab displays.  

 
Figure 6-6. Device Information, Points tab 

2. Review the following fields for your organization’s values:  
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Field Description 
Maximum  This read-only field shows the maximum number of 

PID loops or AGA points (meter runs) allowed in the 
FB107.   

Active   Sets the number of active PIDs loops or AGA points 
on the currently attached device.  
Note:  This value cannot exceed the value shown in 

the Maximum number field. To conserve 
processor executions, set this value to the 
minimum value your application requires. 

History Points This read-only field shows, for both Standard History 
and Extended History, the number of points allocated 
for each.  
Note:  You can configure these values on the Setup 

tab of the History Setup screen (Configure > 
History Points).   

 

3. Click Apply if you change any parameters on this screen.    

4. Proceed to Section 6.8.3, Device Information Other Information Tab. 

6.8.3 Device Information Other Information Tab 
The Other Information tab displays customer information.  

1. Select the Other Information tab on the Device Information screen. 
The Other Information screen displays.   

 
Figure 6-7. Device Information, Other Information tab 

2. Review the information on this screen.  

Field Description 
Customer Name  This read-only field shows the information about the 

customer or owner associated with this device.    
Version Name   This read-only field shows the version number for 

this device.    
ID This read-only field shows the vendor associated 

with this device.  
Time Created This read-only field shows the date the firmware 

was created.    
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Field Description 
ROM Serial# This read-only field shows The serial number 

assigned by the factory to the read only memory 
(ROM) installed in the device.    

MPU Loading This read-only field shows the processes in the 
processor (MPU Loading) .   

 

3. Proceed to Section 6.8.4, Device Information Revision Info Tab 

6.8.4 Device Information Revision Info Tab 
The Revision Info tab displays information about the applicaton firmware 
or accessory software installed in the FB107.  

1. Select the Revision Info tab on the Device Information screen. The 
Revision Info screen displays.   

 
Figure 6-8. Device Information, Revision Info tab 

2. Review the information on this screen.  

3. Click OK to close the Device Information screen.  

6.9 CPU Information 
You can navigate FloBoss 107 options using the ROCLINK menu 
structure or by clicking on the FloBoss 107 graphic and selecting a tab or 
button.  The graphical interface display shows the current settings of the 
point, including alarms and integrity.  

To display the CPU information for the FloBoss 107, click the CPU 
module on the graphical interface. 

The currently selected hardware displays at the bottom of the screen. 

6.9.1 CPU Information General Tab 
The CPU Information screen’s General tab displays hardware and 
firmware information about the CPU.  

1. Click the CPU module on the FB107’s dynamic interface. The CPU 
Information displays the General tab.  
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Figure 6-9. CPU Information, General tab 

2. Review the following fields:  

Field Description 
Installed Module  This read-only field shows the type of module the 

FloBoss 107 is using for point configuration and does 
not require that a module be physically installed to 
display.  The FloBoss 107 remembers the “Installed 
Module” type until you “Uninstall” it. Refer to Section 
1.6.2, Actual versus Installed Module.    

Description  This read-only field shows a description of the 
hardware currently installed in the FloBoss.  

Part Number This read-only field show the Part Number of the 
firmware currently installed in the FloBoss 107.  

Serial Number This read-only field shows the Serial Number of the 
hardware currently installed in the FloBoss.  

Actual Module This read-only field shows the module physically 
installed in the backplane.  ROCLINK 800 updates 
this field whenever you restart the FloBoss 107. 
Refer to Section 1.6.2, Actual versus Installed 
Module. 

Revision This read-only field shows the firmware revision for 
the hardware currently installed in the FloBoss 107.  

Build Date This read-only field shows the date the firmware 
was built for the hardware currently installed in the 
FloBoss 107.  

Boot Revision This read-only field shows the revision of the main 
startup firmware currently installed in the FloBoss or 
the smart application module.  

Boot Build Date This read-only field shows the date the main startup 
firmware was installed in the FloBoss or smart 
application module.  
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Field Description 
Integrity This read-only field shows the status of the 

hardware currently installed in the FloBoss.  
Alarms display on the dynamic user interface to 
indicate the state of the hardware, including the 
CPU, I/O modules, CPU I/O assembly, MVS 
modules, communication modules, and smart 
application modules. You can mouse over an alarm 
icon to display the definition and they also display at 
the bottom of the screen under the I/O Points tab. 
Refer to Section 1.6.1, FloBoss 107 Dynamic 
Interface.   
Integrity indicates the point is out of the user defined 
or default range. For example, when an AI is open 
the actual AD count is 0 but, the default range is 643 
to 3220 or when a module was installed and 
improperly removed or loss of communications 
occurred. 

Uninstall Click to remove the hardware firmware currently 
installed in the FloBoss 107.  The Installed Module 
field displays the type of module the FloBoss 107 
uses for point configuration and does not require that 
a module be physically installed to display. The 
FloBoss 107 remembers the “installed module” type 
until you “uninstall” it. Refer to Section 1.6.2, Actual 
versus Installed Module. 
Note:  Uninstall is valid for all modules except the 

CPU.  

 

3. Proceed to Section 6.9.2, CPU Information Advanced Tab.  

6.9.2 CPU Information Advanced Tab 
Use the Advanced tab to configure CPU clock speed, scan period, sleep 
modes, and the loop output voltage.  

1. Select the Advanced tab. The CPU Information Advanced screen 
displays.  

 
Figure 6-10. CPU Information, Advanced tab 

2. Review the following fields. 
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Field Description 
Clock Speed Sets the desired clock speed for the FloBoss 107 

CPU. This value determines the speed at which the 
CPU executes code.  

Scan Period Sets the amount of time between updates of each 
scan. The system updates all inputs, such as FSTs, 
PIDs, and I/O, based on their individual scan periods. 
The FloBoss 107 has three configurable scan rate 
resolutions: 50 milliseconds, 100 milliseconds, and 
1000 milliseconds (1 second). The minimum scan 
period allowed is 50 milliseconds.  

Sleep Mode Indicates whether the CPU uses a conserve power 
mode. Valid values are Enabled or Disabled; default 
is Disabled.  

Loop Output Voltage Sets the loop output power for I/O to 10 volts dc or 
24 volts dc. The I/O module only supports 24 volts dc 
loop output power.  
Note:  The CPU I/O assembly uses the CPU’s loop 

power output and ground connections.  
The loop output powers field devices or transmitters 
that require 24 volts dc to ground, allowing the 
external device to send the FB107 a 4 to 20 mA 
signal based on pressure, temperature, level, and 
such.  
The 10-volt loop output power is intended for low 
power transmitters. The loop current is designed to 
deliver 80 mA to power two field devices that connect 
back to the two analog inputs. 
Note:  If the input voltage is greater than the 10-volt 

loop, then the loop voltage equals the input 
voltage. For example, if the PWR IN is 14 
volts dc and you select a 10-volt loop, the loop 
output equals 14 volts dc.  

You can use current analog inputs of 4 to 20 mA 
when the 250-ohm resistor is selected in the AI 
configuration using ROCLINK 800.  

 

3. Click Apply if you change any parameters on this screen.  

4. Proceed to Section 6.9.3, CPU Information I/O Points Tab.  

6.9.3 CPU Information I/O Points Tab 
Use the I/O Points to configure the CPU’s system analog inputs.  

1. Select the I/O Points tab. The CPU Module I/O Points screen 
displays.   
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Figure 6-11. CPU Information, I/O tab 

2. Review the following fields. 

Field Description 
Point Type This read-only field shows the database points 

associated with the installed hardware and CPU.  
The built-in inputs and outputs (I/O) on the CPU 
consist of a resistance thermal detector (RTD) input 
interface and five diagnostic analog inputs (AI) that 
monitor the:   
 Logical voltage 
 Battery voltage from the backplane voltage input 

connector 
 Charge in voltage originating from the CPU 

power input.  
 System milliamps originating from the power 

input from the CPU. (Use to determine current 
draw for battery sizing.)  

 Battery temperature originating at the CPU.  
Tag Displays the tag associated with each point type.  
Configuration Click … to display an analog input screen you use to 

configure the point associated with the hardware. 
 

3. For information on integrity or active alarms, refer to Section 1.6.1, 
FloBoss 107 Dynamic Interface.  

4. Proceed to Section 6.9.4, CPU Information Meter Points Tab.  

6.9.4 CPU Information Meter Points Tab 
Uset the Meter Points tab to configure the meter run for the FloBoss.  

1. Select the Meter Points tab. The CPU Information Meter Points 
screen displays.  



ROCLINK 800 User Manual (FB107) 

Issued Jan-08 ROC Menu 6-13 

 
Figure 6-12. CPU Information, Meter Points tab 

2. Review the following fields. 

Field Description 
Meter This read-only field shows the number associated 

with this meter.    
Tag Displays the tag associated with each point type.  
Configuration Click … to display a Meter Setup screen you use to 

configure the meter. 
 

3. For information on active alarms, refer to Section 1.6.1, FloBoss 107 
Dynamic Interface. 

4. Proceed to Section 6.9.5, CPU Information Diagnostic Tab.  

6.9.5 CPU Information Diagnostic Tab 
Use the Diagnostic tab to display hardware statistics about the CPU.  

1. Select the Diagnostic tab. The CPU Information Diagnostic screen 
displays.  

 
Figure 6-13. CPU Information, Diagnostic tab 

2. Review the following fields. 

Field Description 
Aux Pwr In This read-only field shows the current input power 

the FB107 is acquiring at the battery.   
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Field Description 
Average I/O Scan 
Time 

This read-only field shows the average time, in 
seconds, the PIDs, FSTs, and backplane scans have 
taken.    

Good I/O SPI 
Messages 

This read-only field shows the number of good 
Synchronous Peripheral Interface (SPI) messages 
that occurred at the backplane. SPI is the 
communications protocol used between the modules 
in the backplane and the CPU.   

Bad I/O SPI 
Messages 

This read-only field shows the number bad SPI 
messages that occurred at the backplane.   

 

3. This completes the process for configuring I/O points on the CPU 
module.   

6.10 Flags 
Use the Flags screen to perform actions that affect the overall operation 
of the FloBoss. From this screen, you can save a configuration to Flash 
memory and, if necessary, re-initialize the FloBoss. 

When you select ROC > Flags, ROCLINK 800 displays the Flags screen.    

 
Figure 6-14. Flags 

6.10.1 Flags General Tab 
Use the General tab on the Flags screen to restart the FB107 or save your 
configuration to flash memory.  
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Notes:   
 Be very careful when using the system flags. Certain flags lose data, 

change parameter values, and clear configuration memory. Be sure 
you understand the function of the Flags before changing them.  

 If you select Cold Start & Clear Displays, the FB107 performs the 
cold start but does not clear any displays.   

1. Select ROC > Flags. The Flags screen opens, displaying the General 
tab.  

 
Figure 6-15. Flags, General tab 

2. Click one of following buttons:  

Button Action 

Warm Start  Following a warm start, ROCLINK 800 initializes SRAM 
memory. If the configuration is valid, databases and 
FSTs remain intact. If the configuration is not valid, 
ROCLINK 800 uses the last configuration saved to flash 
memory. To save a valid configuration, click Save 
Configuration. A user program remains on after a warm 
start. 
Note:  Refer to Appendix B, The FST Editor, for details 

concerning an FST’s state on a restart.  
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Button Action 

Cold Start  Initializes the FB107 from the last valid restart 
configuration saved in flash memory. If the configuration 
memory does not have a valid configuration written to it, 
the process uses the factory defaults.  
Use a cold start if a FloBoss is performing erratically, 
when the memory appears to be corrupted, or when 
resetting the unit to the last saved configuration.  
Note:  Cold Start reloads all restart configuration data 

and may also clear logs, displays, and FSTs. 
Additionally, it may change outputs, load new 
accumulator values, and disable user program 
tasks and user data types. Generally, do not use 
Cold Start on a FloBoss that is actively 
gathering data or performing control. Save or 
document all required data and parameter values 
that could be affected before you perform a cold 
start.  

During a cold start, logs and FSTs may clear. If you 
performed a Save Configuration (which includes the FST and 
FST point in flash memory) before the cold start, the system 
reloads the saved FST reloads in place of the cleared one. 

Cold Start & Clear 
Alarms/Events  

Restores a configuration from default values stored in 
flash memory and clears the Alarm Log and Event Log. 

Cold Start & Clear 
Displays  

Restores a configuration from default values stored in 
flash memory but does not clear displays.  

Cold Start & Clear 
FSTs  

Restores a configuration from default values stored in 
flash memory and clears all FSTs. 

Cold Start & Clear 
History  

Restores a configuration from default values stored in 
flash memory and clears all History database files. 

Cold Start & Clear All Restores a configuration from default values stored in 
flash memory and clears all History database files, alarm 
logs, event logs, and FSTs. 

Save Configuration Saves the current configuration to flash memory. 

Clear  Clears flash memory.  

Status This read-only field shows the status of the selected 
activity.  

 
3. Proceed to Section 6.10.3, Flags Advanced Tab.  

Reset Switch The CPU module provides a reset (RST) switch which you can use to 
restart the FB107 from the boot block of flash memory (essentially a 
cold start) rather than from RAM (a warm start).  

However, a CPU-based reset reconfigures all comm ports back to their 
factory defaults, shuts off all user programs and FSTs. All other data 
remains intact.  

Note:  Performing a reset using the CPU module’s RST switch reloads 
the factory default settings for the communication ports and 
disables all FSTs and user programs.  
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6.10.2 Returning a Device to Factory Default Settings 
Sometimes you may find it necessary to return a device to its original 
factory default settings.  Use the following procedure to clear all saved 
restart configuration data contained in flash memory, retaining only the 
factory defaults.  

1. Select ROC > Flags.  

2. Click Clear in the Flash Memory frame. ROCLINK 800 displays a 
verification dialog box.  

3. Click Yes. ROCLINK 800 displays a completed dialog box when the 
process completes.   

4. Click OK.  

5. Click Cold Start & Clear All to perform a cold start. ROCLINK 800 
displays a verification dialog box.  

6. Click Yes. ROCLINK 800 displays a dialog box when the process 
completes.  

7. Click OK. 

Note:  You may need to re-connect as the factory default settings may be 
altered from the stored data. 

6.10.3 Flags Advanced Tab 
Use the Advanced tab to perform actions that affect the CRC checking 
and the I/O scanning.  

1. Select the Advanced tab. The Flags Advanced screen displays.   
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Figure 6-16. Flags, Advanced tab 

2. Review the following fields.  

Field Description 
CRC Check  Activates Cyclical Redundancy Checking (CRC) on 

ROC protocol communications. Valid values are 
Enabled or Disabled. The default is Enabled.  

I/O Scanning  Activates I/O scanning for read-only field shows the 
average time, in seconds, the PIDs, FSTs, and 
backplane scans have taken.    
Note:  You can also enable or disable I/O scanning 

on the I/O point displays.  
Set RTS High for 30 
Seconds 

Sets the respective port (Local Port, COM2, or 
COM3) for the Set RTS to High for 30 Sec option 
and click Apply to activate the RTS (Request-to-
Send) signal. The RTS signal turns on for 30 
seconds.  
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Field Description 
Pass Through Mode Sets a communications option to send Pass Through 

messages.  By using any of the FloBoss 
communications ports, Pass Through Mode allows 
data to be received by one unit (source) and then 
passed through to other devices (destinations) 
connected on any other communications port. Select 
the Source and the Destination. 
For example, the host communicates via a radio on 
the FloBoss COM2 port. Other FloBoss units can 
then be connected via EIA-485 (RS-485) on the 
COM1 port of the first FloBoss, and then all the 
FloBoss can use the one radio to communicate to 
the host using the COM1 or COM2 option.  
Note:  The group number of the FloBoss receiving 

the data must match the group number of the 
FloBoss units to which the data will be 
passed. If the Group number does not match, 
the data will be forwarded, but not received. 
Refer to ROC > Information to view or 
change the Group number. 

 

3. Click Apply if you change any parameters on this screen.   

4. Click OK to close this screen.   
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Chapter 7 – The Configure Menu 

Use the Configure menu options to define points for inputs/outputs, control 
functions, user programs, Modbus, the optional FB107 Touchpad, and User 
C program data.   

 
Figure 7-1. Configure Menu 
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7.1 Configuring Input/Output (I/O) 
The I/O module rack provides slots for up to seven I/O modules. The 
available expansion rack plugs directly into the FB107 module rack 
connector on the bottom edge of the MCU. Figure 7-2 shows the positions 
of point numbers on the racks: 

Slot Point Number Supported Module Types 
0 A1-A14 CPU  
1 B1-B8 Com, I/O, or Smart Module  
2 B9-B16 Com, I/O, or Smart Module  
3 C1-C8 I/O or Smart Module  
4 C9-16 I/O or Smart Module  
5 D1-D8 I/O or Smart Module  
6 D9-D16 I/O or Smart Module  
7 NA Smart Module  
7 B1-B8 I/O (if no I/O in slot 1)  

 
Figure 7-2. FloBoss 107 I/O Module Racks 

Slot 0: CPU  

Slot 1 or 2: 
Com, I/O, or Smart  

Slot 7: 
I/O or Smart 

Slot 3, 4, 5, or 6: 
I/O, or Smart  
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Note:  Slot 1 and Slot 7 share the I/O file/rack address. The address of slot 
1 (B1-B8) is valid as long as no I/O module is installed in slot 7. 
The address of slot 7 (B1-B8) is valid as long as no I/O module is 
installed in slot 1.  

You can configure many items for the I/O points in the FloBoss 107. For 
more information on the types of I/O available and their functions, refer to 
the FloBoss 107 Flow Manager Instruction Manual (Form A6206). 

Note:  You may also refer to Section 1.6.1, FloBoss 107 Dynamic Interface 
and Section 1.6.2, Actual versus Installed Module in this manual. 

The graphical interface display shows the current settings of the point 
including alarms and integrity.  

7.1.1 I/O Interface General Tab 
You can navigate FloBoss 107 options using the I/O menu options or by 
clicking on the FloBoss 107 graphic and selecting a tab or button. The 
graphical interface display shows the current settings of the point including 
alarms and integrity.  

The currently selected hardware displays at the bottom of the screen. This 
applies to the software-selectable AI/DI, DO, PI/DI channels, 
communications modules, and smart modules. 

 
Figure 7-3. I/O Interface, General tab 

Field Description 
Installed Module   This read-only field shows the type of module the 

FloBoss 107 uses for point configuration and does 
not require that a module be physically installed to 
display. The FloBoss 107 remembers the “Installed 
Module” type until you “Uninstall” it. Refer to Section 
1.6.2, Actual versus Installed Module. 

Description This read-only field shows a description of the 
hardware currently installed in the FloBoss.  

Part Number This read-only field shows the part number of the 
hardware currently installed in the FloBoss 107.  
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Field Description 
Serial Number This read-only field shows the serial number of the 

hardware currently installed in the FloBoss.  
Actual Module  This read-only field shows the module is physically 

installed in the backplane. This field is updated 
whenever the FloBoss 107 is restarted. Refer to 
Section 1.6.2, Actual versus Installed Module.  

Revision  This read-only field shows the firmware revision for 
the hardware currently installed in the FloBoss 107.  

Build Date  This read-only field shows date the firmware was 
built for the hardware currently installed in the 
FloBoss 107.  

Boot Revision  This read-only field shows Displays the revision of 
the main startup firmware currently installed in the 
FloBoss or hardware.  

Boot Build Date  This read-only field shows the date the main startup 
firmware currently installed in the FloBoss or 
hardware.  

Integrity  This read-only field shows the status of the 
hardware currently installed in the FloBoss 107. 
Alarms display on the user interface indicating the 
state of the hardware including the CPU, I/O 
modules, CPU I/O assembly, MVS modules, 
communication modules, and smart application 
modules. You can mouse over an alarm icon to 
display the definition. 

Uninstall Click to remove the hardware currently installed in 
the FloBoss 107.  This field displays the type of 
module the FloBoss 107 uses for point configuration 
and does not require that a module be physically 
installed to display. The FloBoss 107 remembers the 
“Installed Module” type until you “Uninstall” it. Refer 
to Section 1.6.2, Actual versus Installed Module. 

 

7.1.2 I/O Interface I/O Setup Tab 
Use this tab to assign types of I/O to each channel before you configure the 
I/O points.  This applies to the software-selectable AI/DI, DO, and PI/DI 
channels only.  

Note:  You can also use the configuration tree (at the left of the ROCLINK 
800 screen) to navigate to this screen.  

1. Select the I/O Setup tab. The I/O Setup screen displays.  



ROCLINK 800 User Manual (FB107) 

Issued Jan-08 Configure Menu 7-5 

 
Figure 7-4. I/O Interface, I/O Setup tab 

2. Review the following fields for your organization’s values:   

Field Description 
I/O Type   Sets the types of I/O assigned to each channel be 

before you configure the I/O points. This applies to 
the software-selectable AI/DI, DO, and PI/DI 
channels only. 

250 Ohm Resistor 
Installed  

Indicates whether a 250-ohm resistor is used for the 
analog inputs. Valid values are Yes (configures 
inputs to 4 to 20 mA) or No (configures inputs to 0 to 
5 V dc input). The default is Yes. A 250-ohm resistor 
is required for use between the + and – analog 
inputs when you implement 4 to 20 mA inputs.   
Note:  This field displays only if you select AI-1 or 

AI-2 as an I/O Type.  
 

3. Click Apply if you change any parameters on this screen.   

4. Proceed to Section 7.1.3, I/O Interface I/O Points Tab.   

7.1.3 I/O Interface I/O Points Tab 
Use the I/O Points tab to configure assigned points on the FB107.  

1. Select the I/O Points tab. The I/O Points screen displays.  

 
Figure 7-5. I/O Interface, I/O Points tab 

2. Review the following fields for your organization’s values:  
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Field Description 
Point  Defines the database point to be one of the possible 

types of points available to the system.  The point 
type determines the basic functions of a point. Point 
type displays the database points associated with the 
installed hardware and CPU. The point type indicates 
the location of the point at the slot number of the I/O 
module and channel number. For example, DO-2 
indicates the point number for a discrete output at 
module slot zero, channel two.  

Tag Sets a short (10 alphanumeric characters) identifier 
for the point.  

Configuration  Click …(the TLP button) to display a configuration 
screen you use to configure the point associated with 
the hardware. 

Integrity  This read-only field shows Displays the status of the 
hardware currently installed in the FloBoss 107. 
Alarms display on the user interface indicating the 
state of the hardware including the CPU, I/O 
modules, CPU I/O assembly, MVS modules, 
communication modules, and smart application 
modules. You can mouse over an alarm icon to 
display the definition. Refer to Section 1.6.1, FloBoss 
107 Dynamic Interface.  
Integrity indicates the point is out of the user defined 
or default range. For example, when an AI is open 
the actual AD count is 0, but the default range is 643 
to 3220 or when a module was installed and 
improperly removed or loss of communications 
occurred. 

Active Alarms This read-only field shows any alarms that are 
active for this point. When Alarming is set to 
Enabled, the limit alarms (such as Low Alarm and 
Rate Alarm) that are active appear. If Alarming is 
Disabled, the Point Fail (hardware reports a 
malfunction) alarm and Manual (Scanning Disabled) 
indicators can still appear. Refer to Section 1.6.1, 
FloBoss 107 Dynamic Interface. 

 

3. Click Apply if you change any parameters on this screen. 

7.2 Analog Input (AI) Configuration 
Analog inputs are analog signals that measurement devices (such as 
pressure and temperature transmitters, including RTD probes and pressure 
sensors) generate. 

Note:  Use the AI configuration screens to configure a DVS and RTD 
inputs for the FloBoss 107. DVS points, Differential Pressure, and 
Static Pressure are visible once you connect a DVS sensor.  

Select Configure > I/O > AI Points. The Analog Input screen displays.  
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Figure 7-6. Analog Input  

The Analog Input screen has four tabs. Use each tab to configure a 
component of the input.  

 Use the General tab to set the basic parameters for the analog input 
point.  

 Use the Advanced tab to configure features, such as filtering, A/D 
conversions, and clipping for the selected analog input.  

 Use the AI Calibration tab to calibrate the AI point while on-line.  

 Use the Alarms tab to set the alarm parameters for this AI point.  

Note:  If you enable Alarming (Configure > I/O > AI Points > 
General tab), configure the limit alarms (four levels, rate, and 
deadband) on the Alarms tab. To conserve alarm log space, 
enable alarms only when necessary. If you do not plan to use all 
the alarms, check and adjust the value of each one to prevent the 
generation of false alarms.  

Refer to Sections 7.2.1 through 7.2.4 for a complete description of the 
fields on each tab. 

Note:  After you configure a point and click Apply, click Flash Memory 
Save Configuration (on the ROC > Flags screen) to save I/O 
configuration to permanent memory in case you must perform a cold 
start.  
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7.2.1 AI General Tab 
The Analog Input screen initially displays the General tab. Use this tab to 
set the basic parameters for the analog input point.  

 
Figure 7-7. AI, General tab 

1. Review the following fields for your organization’s values: 

Field Description 
Analog Inputs Selects the analog input to be configured. The inputs 

are listed by both Point Number and Tag.  
Note:  This selection in this field applies to each tab 

on this screen.  
Tag  Sets a short (10 alphanumeric characters) identifier 

for the point.  
Note:  This selection in this field applies to each tab 

on this screen. 
Point Number This read-only field identifies the rack location for 

this point.  
Value Reads value from a field device.  

Note:  When scanning is disabled, enter a value to 
override the input. If scanning is enabled, this 
field displays the last analog scan in 
engineering units.  

Units  Sets the engineering units for the I/O (such IN H20, 
PSIG, MCF, degrees F, milliamps, volts, etc.).  

Scan Period  Sets the amount of time between updates of the 
Filter value.  All analog inputs are updated based on 
their individual Scan Periods. The default value is 
100 milliseconds. The minimum Scan Period 
allowed is 50 milliseconds. 
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Field Description 
Low Reading EU Sets the engineering unit (EU) for the low reading to 

zero percent input.  For example, if a temperature 
transmitter is connected to the analog input with a 
range of –40 to 160 degrees F, the Low Reading EU 
would be set to –40. 

High Reading EU Sets the engineering unit (EU) for the high reading to 
100 percent input.  For example, if a temperature 
transmitter is connected to the analog input with a 
range of –40 to 160 degrees F, the High Reading EU 
would be set to 160. 

Scanning  Sets the scanning option for this point.  Valid values 
are Enabled (automatically process the field input 
and display the last analog input scan in the Value 
field) or Disabled (permit only manual updates of the 
Value field).  
Note:  If you enable alarming, the FB107 generates 

a Manual Mode alarm when scanning is 
disabled. If Scanning is set to Disabled, you 
must manually enter a value in the Value field 
to override the input.  

Alarming  Sets the alarm option for this point. Valid values are 
Enabled (configures the limit alarms - four levels, 
Rate, and Deadband - on the Alarms tab) or 
Disabled (does not generate limit alarms).  
Note:  The Point Fail alarm may appear in the Active 

Alarms field, but is not logged in the Alarms 
file. If you Enable alarming, the system 
generates an alarm if you disable scanning.  

Active Alarms This read-only field shows any active alarms for this 
point. When you Enable alarming, the limit alarms 
(such as Low Alarm and Rate Alarm) that are active 
appear. Even if you Disable alarming, the Point Fail 
(hardware reports a malfunction) alarm and Manual 
(Scanning Disabled) indicators can still appear. Refer 
to Section 1.6.1, FloBoss 107 Dynamic Interface. 

 

2. Click Apply if you change any parameters on this screen. 

3. Proceed to Section 7.2.2, AI Advanced Tab.  

7.2.2 AI Advanced Tab 
Use the Advanced tab to configure features, such as filtering, A/D 
conversions, and clipping for the selected analog input.  

1. Select the Advanced tab. The Advanced screen displays.   
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Figure 7-8. AI, Advanced tab 

2. Review the following fields for your organization’s values:  

Field Description 
Filter Sets the value for a weighted sample using a 

percentage of the last value plus a percentage of the 
new value.  The entered value is the percentage of 
the last value used. The filter is calculated every 
scan period by the formula:  
(Last Value x Entered %) + [New Value x (100 – 
Entered %)] = Filtered Value 

Adjusted A/D 0% Sets the calibrated Analog-to-Digital count 
corresponding to zero percent input.  In the Calibrate 
function, this value is altered to set the zero percent 
input exactly at the Low Reading EU value. 

Adjusted A/D 100% Sets the calibrated Analog-to-Digital count 
corresponding to 100 percent input.  Use this value 
to convert the input to engineering units. In the 
Calibrate function, this value is altered to set the 100 
percent input exactly at the High Reading EU value. 

Raw A/D Input This read-only field shows the current digital count 
directly from the Analog-to-Digital converter.  

Actual Scan This read-only field shows the actual amount of 
time, in seconds, taken to complete the entire list of 
tasks.  This value should be the same as the value in 
the Scan Period field on the General tab if the 
system is not overloaded. 

Average Raw Value Sets whether the system averages raw values during 
the scan period. Valid values are Enabled (average 
and calculate the raw readings during the scan 
period and use the results as the Raw A/D Input 
during calculations) or Disabled (acquire 
instantaneous values).  
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Field Description 
Clipping Forces the filtered EUs within a defined limit set on 

the Alarms tab.  Valid values are Enabled (forces the 
filtered EUs to stay within a range defined by the cut 
off limits, set by using the LoLo Alarm and HiHi 
Alarm parameters defined on the Alarms tab) or 
Disabled (do not force clipping). 

Action on Failure Sets how the system acts on point failure. Valid 
values are Hold Last Value (retain the last input 
value on point fail) and Set to Fault Value (write the 
value in the Fault Value field to the Filtered Value on 
point fail). 

 

3. Click Apply if you change any parameters on this screen.  

4. Proceed to Section 7.2.3, AI AI Calibration Tab.  

7.2.3 AI AI Calibration Tab 
Use this tab to select an RTD input or analog input to calibrate. 

The calibration routine provides Verify, Calibrate, and Zero Shift functions 
for AI, DVS, and RTD inputs. You can calibrate differential pressure 
(orifice metering may be High or Low Differential Pressure, depending on 
the device), static pressure, or temperature readings for each meter run.  

1. Select the AI Calibration tab. The AI Calibration screen displays.  

 
Figure 7-9. AI, AI Calibration tab 

2. Select either an RTD input or analog input. 

3. Click Update to request one value update from the input. 

4. Click Freeze to stop the system from updating input values during 
verification or calibration.  



ROCLINK 800 User Manual (FB107) 

7-12 Configure Menu Issued Jan-08 

5. Click Update and then Freeze to create the freeze value the system 
uses in ongoing processing (such as flow calculations and history 
logging) while performing calibration.  

Note:  The Freeze Value field displays the value received from the AI 
or RTD input when you last clicked Update.   

6. Review the value in the Scan Mode field. Valid values are Normal 
(point scanning is enabled and is updated each scan period) or Manual 
(the point is not in scanning mode).  

7. If you are calibrating a temperature input, disconnect the RTD sensor 
and connect a decade box (or comparable equipment) to the RTD 
terminals of the FloBoss.  

Note:  You can also use a pocket current source or another deadweight 
test input source to test this value.   

8. Press Calibrate. A Set Zero dialog box displays.  

 
Figure 7-10. Set Zero  

9. Enter a value in the Dead Weight/Tester Value field and click Set Zero 
to set a zero value. Note that ROCLINK 800 changes the screen name 
and button name to Set Span.  
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Figure 7-11. Set Span 

For the Set Zero entry in the calibration log, ROCLINK 800 records the 
As Found and As Left values and calculates the Deviation and % 
Deviation values (between the Dead Weight/Tester Value and the Live 
Reading values).  

10. Enter a value in the Dead Weight/Tester Value for the span and click 
Set Span to set a span value and record the values in the calibration log. 
Note that ROCLINK 800 changes the screen name and button name to 
Set Mid 1.  

 
Figure 7-12. Set Midpoint 1 
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11. If you do not wish to configure midpoints, click Done. The AI 
Calibration screen displays. If you wish to configure midpoints, click 
Set Mid 1 to define the first midpoint value. You can define up to three 
midpoints (typically at 25%, 50%, and 75%). Click Done when you 
finish configuring midpoints.  

When the AI Calibration screen displays, you can calibrate inputs for 
another AI or RTD by starting again at step 1. Otherwise, proceed to 
Section 7.2.4, AI Alarms Tab.  

7.2.4 AI Alarms Tab 
Use this tab to set the alarm parameters for this AI point.  

Note:  You must enable alarming on the General tab to configure the limit 
alarms (Low, High, LoLo, HiHi, Rate, and Deadband) on this tab.   

To conserve alarm log space, enable alarms only when necessary. Even if 
you do not plan to use all the alarms, check and adjust the value of each one 
alarm to prevent the generation of false alarms. 

1. Select the Alarms tab. The Alarms screen displays.  

 
Figure 7-13. AI, Alarms tab 

2. Review the following fields for your organization’s values.  

Field Description 
Low Alarm Sets, in engineering units, a limit value to which the 

input value must fall to generate a Low alarm.  
High Alarm Sets, in engineering units, a value to which the input 

value must rise to generate a High alarm. 
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Field Description 
LoLo Alarm  Sets, in engineering units, a value to which the input 

value must fall to generate a LoLo alarm.   
Note:  Typically you set the value for the LoLo Alarm 

lower than the value for the Low alarm. 
HiHi Alarm Sets, in engineering units, a value to which the input 

value must rise to generate a HiHi Alarm. 
Note:  Typically you set the value for the HiHi Alarm 

higher than the value for the High alarm. 
Rate Alarm Sets, in engineering units, a value that represents 

the maximum amount of change allowed in the 
calculated rate between updates before an alarm 
generates. If the change is equal to or greater than 
this value, an alarm occurs,  
Note:  To disable the rate alarm without disabling the 

other alarms, you can set the rate alarm value 
greater than the scan of the analog input. 

Alarm Deadband Sets, in engineering units, an inactive zone above 
the Low Alarm limits and below the High Alarm limits. 
The Alarm Deadband prevents the alarm from being 
set and cleared continuously when the input value is 
oscillating around the alarm limit. This prevents the 
Alarm Log from being over-filled with data. 

RBX Alarming Sets the Spontaneous-Report-by-Exception (SRBX 
or RBX) alarming for this point. Valid values are:  

 Disabled Turns off RBX alarming. This is 
the default.  

 On Alarm Set Generates an RBX message to 
the host when the point enters an 
alarm condition.  

 On Alarm Clear Generates an RBX message to 
the host when the point leaves 
an alarm condition. 

 On Alarm Set 
and Clear 

Generates an RBX message to 
the host when the point enters or 
leaves an alarm condition. 

 Note:  RBX Alarming requires you to configure the 
communications port. Refer to Section 3.4.3, 
Comm Ports RBX Tab. 

 

3. Click Apply if you change any parameters on this screen.   

Note:  After you configure a point and click Apply, click Flash Memory 
Save Configuration (on the ROC > Flags screen) to save I/O 
configuration to permanent memory in case you must perform a cold 
start.  
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7.3 Analog Output (AO) Configuration 
Analog outputs are analog signals the FB107 generates to regulate 
equipment such as control valves or any device requiring proportional 
control.   

Select Configure > I/O > AO Points. The Analog Output screen displays.  

 
Figure 7-14. Analog Output 

The Analog Output screen has two tabs. Use each tab to configure a 
component of the output.  

 Use the General tab to set the basic parameters for the analog output 
point.  

 Use the Advanced tab to configure features, such as on-restart power 
settings and RBX alarming.  

Note:  After you configure a point and click Apply, click Flash Memory 
Save Configuration (on the ROC > Flags screen) to save I/O 
configuration to permanent memory in case you must perform a cold 
start.  

7.3.1 AO General Tab 
The Analog Output screen initially displays the General tab. Use this tab to 
set the basic parameters for the analog output point.   
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Figure 7-15. AO, General tab 

1. Review the following fields for your organization’s values.  

Field Description 
Analog Outputs Selects the analog output to be configured. The 

outputs are listed by both Point Number and Tag.  
Note:  This selection in this field applies to each tab 

on this screen.  
Tag  Sets a short (10 alphanumeric characters) identifier 

for the point.  
Note:  This selection in this field applies to each tab 

on this screen. 
Point Number This read-only field identifies the rack location for 

this point.  
Value Sets a value to override the output. 

Note:  When scanning is disabled, enter a value to 
override the output. If scanning is enabled, 
this field displays the last analog scan in 
engineering units.  

Units  Sets the engineering units for the I/O (such IN H20, 
PSIG, MCF, degrees F, milliamps, volts, etc.).  

Low Reading EU Sets the engineering unit (EU) for the low reading to 
zero percent output (low end of the EU range).  
Based on the EU range determined in part by this 
parameter, the EU value is converted to a 
corresponding analog signal.  

High Reading EU Sets the engineering unit (EU) for the high reading to 
100 percent output (or high end of the EU range).  
Based on the EU range determined in part by this 
parameter, the EU value is converted to a 
corresponding analog signal 
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Field Description 
Active Alarms This read-only field shows any active alarms for this 

point. When you Enable alarming, the limit alarms 
(such as Low Alarm and Rate Alarm) that are active 
appear. Even if you Disable alarming, the Point Fail 
(hardware reports a malfunction) alarm and Manual 
(Scanning Disabled) indicators can still appear. Refer 
to Section 1.6.1, FloBoss 107 Dynamic Interface.  
Note:  A read-back error indicates the AO is driving 

the output to a set level, but the loop is not 
responding. Example: An I/P converter is 
connected to the A/O and set to 25%. If the 
I/P is not connected or an open wire occurs, a 
read-back error would display. 

Scanning  Sets the scanning option for this point. Valid values 
are Enabled (automatically process the field input 
and display the last analog output scan in the Value 
field) or Disabled (permit only manual updates of the 
Value field).  
Note:  If you enable alarming, the FB107 generates 

a Manual Mode alarm when scanning is 
disabled. If Scanning is set to Disabled, you 
must manually enter a value in the Value field 
to override the input.  

Alarming  Sets the alarm option for this point.  Valid values are 
Enabled (configures the limit alarms - four levels, 
Rate, and Deadband - on the Alarms tab) or 
Disabled (does not generate limit alarms).  
Note:  The Point Fail alarm may appear in the Active 

Alarms field, but is not logged in the Alarms 
file. If you enable alarming, the system 
generates an alarm if you disable scanning.  

 

2. Click Apply if you change any parameters on this screen.  

3. Proceed to Section 7.3.2 AO Advanced Tab.  

7.3.2 AO Advanced Tab 
Use the Advanced tab to configure features, such as resetting and RBX 
Alarming for the analog output.  

1. Select the Advanced tab. The Advanced screen displays.   
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Figure 7-16. AO, Advanced tab 

2. Review the following fields for your organization’s values. 

Field Description 
Raw D/A Input This read-only field shows the current counts written 

to the digital-to-analog converter. The D/A value set 
to the AO is the raw D/A output. The default value is 
0. 

Adjusted D/A 0% Sets the count the digital-to-analog converter uses 
for zero percent output.  This value is also used to 
scale the output to engineering units. The default is 
0. 

Adjusted D/A 100% Sets the count decoded by the digital-to-analog 
converter for 100 percent output.  This value is also 
used to scale the output to engineering units. The 
default is 3250. 

Value on Power 
Reset 

Sets what value the system uses on a power restart 
or a warm start. Valid values are Low EU (sets Value 
parameter on General tab to value in Low Reading 
EU field value) or Retain Last Value (maintain last 
output value). Retain Last Value is the default.   
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Field Description 
RBX Alarming Sets the Spontaneous-Report-by-Exception (SRBX 

or RBX) alarming for this point. Valid values are:  
 Disabled Turns off RBX alarming. This is 

the default.   
 On Alarm Set Generates an RBX message to 

the host when the point enters an 
alarm condition.  

 On Alarm Clear Generates an RBX message to 
the host when the point leaves 
an alarm condition. 

 On Alarm Set 
and Clear 

Generates an RBX message to 
the host when the point enters or 
leaves an alarm condition. 

 Note:  RBX Alarming requires you to configure the 
communications port. Refer to Section 3.4.3, 
Comm Ports RBX Tab. 

 

3. Click Apply if you change any parameters on this screen.   

Note:  After you configure a point and click Apply, click Flash Memory 
Save Configuration (on the ROC > Flags screen) to save I/O 
configuration to permanent memory in case you must perform a cold 
start.  

7.4 Discrete Input (DI) Configuration 
Discrete Input (DI) modules monitor the status of relays, open 
collector/open drain type solid-state switches, and other two-state devices.  
Each DI channel can also be software configured to function as a “latched” 
DI, which remains in the active state until reset. Other parameters can 
invert the field signal and gather statistical information on the number of 
transitions and the time accumulated in the on or off state.  

Select Configure > I/O > DI Points. The Discrete Input screen displays.  
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Figure 7-17. Discrete Input 

The Discrete Input screen has three tabs. Use each tab to configure a 
component of the input.  

Examine the default settings and adjust the parameters to suit your 
application on each of the tabs in the order given below. 

 Use the General tab to set the basic parameters for the DI point.  

 Use the Advanced tab to configure features, such as filtering, input 
inversion, and counter values for the discrete output.  

 Use the Alarms tab to set alarm parameters for this DI point. 

Note:  After you configure a point and click Apply, click Flash Memory 
Save Configuration (on the ROC > Flags screen) to save I/O 
configuration to permanent memory in case you must perform a cold 
start.  

7.4.1 DI General Tab 
The Discrete Input screen initially displays the General tab. Use this tab to 
set the basic parameters for the discrete input point. 
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Figure 7-18. DI, General tab 

1. Review the following fields for your organization’s values:  

Field Description 
Discrete Inputs Selects the discrete input to be configured. The 

inputs are listed by both Point Number and Tag.  
Note:  This selection in this field applies to each tab 

on this screen.  
Tag  Sets a short (10 alphanumeric characters) identifier 

for the point.  
Note:  This selection in this field applies to each tab 

on this screen. 
Point Number This read-only field identifies the rack location for 

this point.  
Scan Period  Sets, in seconds, how frequently the system scans 

the input.    
DIN Type Sets how the DI works. Valid values are:  
 Standard Follow the actual field input.  
 Latched Maintains the input status. For 

example, in an active transition from 
off to on, the DI remains in the on state 
until you clear the Status parameter 
either manually or through the 
software.  

Status Sets the state of the discrete input. Valid values are 
On (indicates that a contact is closed or input is on) 
or Off (indicates that a contact is open or input is off). 
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Field Description 
Scanning  Sets the scanning option for this point.  Valid values 

are Enabled (automatically process the field input 
and display the last analog input scan in the Value 
field) or Disabled (permit only manual updates of the 
Value field).  
Note:  If you enable alarming, the FB107 generates 

a Manual Mode alarm when scanning is 
disabled. If Scanning is set to Disabled, you 
must manually enter a value in the Value field 
to override the input.  

Alarming  Sets the alarm option for this point. Valid values are 
Enabled (configures the limit alarms - four levels, 
Rate, and Deadband - on the Alarms tab) or 
Disabled (does not generate limit alarms).  
Note:  The Point Fail alarm may appear in the Active 

Alarms field, but is not logged in the Alarms 
file. If you Enable alarming, the system 
generates an alarm if you disable scanning.  

Active Alarms This read-only field shows any active alarms for this 
point. When you Enable alarming, the limit alarms 
(such as Low Alarm and Rate Alarm) that are active 
appear. Even if you Disable alarming, the Point Fail 
(hardware reports a malfunction) alarm and Manual 
(Scanning Disabled) indicators can still appear. Refer 
to Section 1.6.1, FloBoss 107 Dynamic Interface. 

 

2. Click Apply if you change any parameters on this screen.  

3. Proceed to Section 7.4.2, DI Advanced Tab.  

7.4.2 DI Advanced Tab 
Use the Advanced tab to configure features (such as filtering, input 
inversion, and counter values) for the discrete input. 

1. Select the Advanced tab. The Advanced screen displays.   
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Figure 7-19. DI, Advanced tab  

2. Review the following field for your organization’s values.  

Field Description 
Filter Intervals Sets, with the Filter parameter, the amount of time 

that the discrete input must remain in the On (high) 
state before it is recognized as such.  Valid values 
are 0.1 Seconds and 15.0 Seconds. Enter the Filter 
value as a number from 0 to 255; the Filter Intervals 
selection determines the time basis. The discrete 
input returns to the Off state immediately upon 
detection of the On to Off transition; there is no 
filtering for this transition.  

Input Sets the state of the input. Valid values are Normal 
(field input operates normally, so that On is On) or 
Inverted (inverts the field input in the Status field so 
that On becomes Off and vice-versa).  
In the Inverted state, an open circuit in the field 
would then be indicated as On in the Status field, 
and closed contacts would be indicated as Off. 

Filter Sets, in conjunction with the Filter Intervals field, the 
amount of time that the discrete input must remain in 
the On (high) state before it is recognized as such. 
Enter the Filter value as a valid between 0 to 255. 
The discrete input returns to the Off state 
immediately upon detection of the On to Off 
transition; there is no filtering for this transition. 

Accumulated Value Counts the number of times the discrete input goes 
from Off to On.  The accumulator is a 32-bit number 
with a maximum count of 4,294,967,295. You can 
preset the accumulator by entering the desired value 
or clear the accumulator by entering 0. 
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Field Description 
On Counter Counts the number of 50-millisecond periods when 

the Status parameter is in the On state.  The On 
Counter is a 32-bit number that automatically “rolls 
over” when it reaches its maximum value. You can 
preset the On Counter by entering the desired value 
or clear the counter by entering 0. 
Note:  The On Counter does not function if you 

disable scanning.  
Off Counter  Conts the number of 50-millisecond periods when 

the Status parameter is in the Off state.  The Off 
Counter is a 32-bit number that automatically “rolls 
over” when it reaches its maximum value. You can 
preset the Off Counter by entering the desired value 
or clear the counter by entering 0. 
Note:  The Off Counter does not function if you 

disable scanning.  
 

3. Click Apply if you change any parameters on this screen.   

4. Proceed to Section 7.4.3, DI Alarms Tab.  

7.4.3 DI Alarms Tab 
Use the Alarms tab to configure the alarm parameters for this discrete 
input.  

1. Select the Alarms tab. The Alarms screen displays.  

 

Figure 7-20. DI, Alarms tab  
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2. Review the following field for your organization’s values.  

Field Description 
RBX Alarming Sets the Spontaneous-Report-by-Exception (SRBX 

or RBX) alarming for this point. Valid values are:  
 Disabled Turns off RBX alarming. This is 

the default.   
 On Alarm Set Generates an RBX message to 

the host when the point enters an 
alarm condition.  

 On Alarm Clear Generates an RBX message to 
the host when the point leaves 
an alarm condition. 

 On Alarm Set 
and Clear 

Generates an RBX message to 
the host when the point enters or 
leaves an alarm condition. 

 Note:  RBX Alarming requires you to configure the 
communications port. Refer to Section 3.4.3, 
Comm Ports RBX Tab. 

 

3. Click Apply if you change any parameters on this screen.   

Note:  After you configure a point and click Apply, click Flash Memory 
Save Configuration (on the ROC > Flags screen) to save I/O 
configuration to permanent memory in case you must perform a cold 
start.  

7.5 Discrete Output (DO) Configuration 
DOs are high/low outputs used to turn equipment on and off.  You can set a 
discrete output to send a pulse to a specified device. You can also configure 
a discrete output as latched, momentary, toggle, Timed Duration Output 
(TDO), and TDO toggle.  

Select Configure > I/O > DO Points. The Discrete Output screen displays.  
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Figure 7-21. Discrete Output 

The Discrete Output screen has four tabs. Use each tab to configure a 
component of the output.  

 Use the General tab to set the basic parameters for the DO point.  

 Use the Advanced tab to configure accumulated value and state for 
reset for the selected DO.  

 Use the TDO Parameters tab to configure time duration parameters. 

Note:  This tab does not display if you choose Latched in the DOUT 
Type field on the General tab.   

 Use the Alarms tab to set the alarm parameters for the DO point.  

Note:  After you configure a point and click Apply, click Flash Memory 
Save Configuration (on the ROC > Flags screen) to save I/O 
configuration to permanent memory in case you must perform a cold 
start.  

7.5.1 DO General Tab 
The Discrete Output screen initially displays the General tab. Use this tab 
to configure the basic parameters for the DO point.  
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Figure 7-22. DO, General tab 

1. Review the following fields for your organization’s values.  

Field Description 
Discrete Outputs  Selects the discrete output to be configured. The 

outputs are listed by both point number and tag.  
Note:  This selection in this field applies to each tab 

on this screen.  
Tag Sets a short (10 alphanumeric characters) identifier 

for the point.  
Note:  This selection in this field applies to each tab 

on this screen. 
Point Number This read-only field identifies the rack location for 

this point.  
State Indicates the State of the discrete output. Valid 

values are Off (indicating that the output is off or that 
a contact is open) or On (indicating that the output is 
on or that a contact is closed).  

Momentary  Activates the one-shot Momentary mode.  
If you select On, set the value in the DOUT Type to 
Latched, set a value in the Time On field, and then 
click Apply, ROCLINK 800 activates the discrete 
output for the amount of time defined in the Time On 
field. At the end of that time, ROCLINK 800 resets 
this value to Off.   

Time On Sets, in seconds, the amount of time for momentary 
operation. The default value is 1 second.  
Note:  In Momentary mode, this is the amount of 

time (in seconds) that the momentary contact 
is energized. In the Toggle mode, this is the 
time (in seconds) between switching On or 
Off. In the TDO and TDO Toggle modes, the 
TDO configuration calculates this value. 
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Field Description 
DOUT Type  Selects the function of this discrete output.  Valid 

values are: 
 Latched Changes – on an active transition of the 

output (from off to on) – the discrete 
output status to On and leaves the 
output in that state until cleared (by 
selecting the Off in the Status field). 

 Time 
Duration 

Enables the discrete output to have a 
time duration.  
Note:  Selecting this option displays the 

TDO Parameters tab on the 
Discrete Output screen. Use that 
tab to define time-related 
parameters (see Section 7.5.3, 
DO TDO Parameters Tab).  

 Toggle Enables the discrete output to enter the 
Toggle mode. Toggle mode enables a 
square-wave output for which both the 
Time On and Time Off are defined by the 
value in the Time On field. Time On and 
Time Off are equal.  
Note:  Selecting this option displays the 

TDO Parameters tab on the 
Discrete Output screen. Use that 
tab to define time-related 
parameters (see Section 7.5.3, 
DO TDO Parameters Tab).  

 TDO 
Toggle 

Enables the discrete output to use the 
TDO Toggle mode.  The DO 
continuously repeats in a cycle defined 
by the value in the Cycle Time field (on 
the TDO Parameter tab) where the EU 
Value controls the on-time duration.  
Note:  Selecting this option displays the 

TDO Parameters tab on the 
Discrete Output screen. Use that 
tab to define time-related 
parameters (see Section 7.5.3, 
DO TDO Parameters Tab). 

Scanning Sets the scanning option for this point. Valid values 
are Enabled (automatically process the field input 
and display the last analog output scan in the Value 
field) or Disabled (permit only manual updates of the 
Value field).  
Note:  If you enable alarming, the FB107 generates 

a Manual Mode alarm when scanning is 
disabled. If Scanning is set to Disabled, you 
must manually enter a value in the Value field 
to override the input.  
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Field Description 
Alarming  Sets the alarm option for this point.  Valid values are 

Enabled (configures the limit alarms - four levels, 
Rate, and Deadband - on the Alarms tab) or 
Disabled (does not generate limit alarms).  
Note:  The Point Fail alarm may appear in the Active 

Alarms field, but is not logged in the Alarms 
file. If you enable alarming, the system 
generates an alarm if you disable scanning.  

Active Alarms This read-only field shows any active alarms for this 
point. When you Enable alarming, the limit alarms 
(such as Low Alarm and Rate Alarm) that are active 
appear. Even if you Disable alarming, the Point Fail 
(hardware reports a malfunction) alarm and Manual 
(Scanning Disabled) indicators can still appear. Refer 
to Section 1.6.1, FloBoss 107 Dynamic Interface. 

 

2. Click Apply if you change any parameters on this screen.  

3. Proceed to Section 7.5.2, DO Advanced Tab.  

7.5.2 DO Advanced Tab 
Use this tab to configure accumulated value and state for reset for the 
selected DO.  

1. Select the Advanced tab. The Advanced screen displays.   

 
Figure 7-23. DO, Advanced tab 
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2. Review the following fields for your organization’s values.  

Field Description 
Accumulated Value Sets a value for the accumulated number of off-to-on 

transitions for the discrete output.  The accumulator 
is a 32-bit number with a maximum count of 
4,294,967,295. You can preset the accumulator to a 
desire value or clear it by enter zero (0).  

Status on Power 
Reset 

Indicates how the FloBoss handles the discrete 
output state on power resets.  Valid values are Off 
(discrete output is off on power reset) or Retain Last 
Status (FB107 retains the DO status, whether off or 
on).  

 

3. Click Apply if you change any parameters on this screen.  

4. Proceed to Section 7.5.3, DO TDO Parameters Tab.   

7.5.3 DO TDO Parameters Tab 
Use this tab to configure time duration parameters for this DO point.  

Note:  This tab does not display if you choose Latched in the DOUT Type 
field on the General tab.  

1. Select the TDO Parameters tab. The TDO Parameters screen displays.  

 
Figure 7-24. DO, TDO Parameters tab 

2. Review the following fields for your organization’s values.   

Field Description 
Cycle Time Sets, in seconds, the total amount of time the cycle 

spends in the on and off positions.  
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Field Description 
0% Count  Sets, in seconds, the amount of time the cycle is in 

the on position when the EU is at zero percent.  
Note:  0% and 100% should equal the cycle time.  

100% Count  Sets, in seconds, the amount of time the cycle is in 
the on position when the EU is at 100 percent.  
Note:  0% and 100% should equal the cycle time.  

Low Reading EU Sets the engineering unit (EU) for the low reading to 
zero percent output (low end of the EU range).  
Based on the EU range determined in part by this 
parameter, the EU value is converted to a 
corresponding analog signal.  

High Reading EU Sets the engineering unit (EU) for the high reading to 
100 percent output (or high end of the EU range).  
Based on the EU range determined in part by this 
parameter, the EU value is converted to a 
corresponding analog signal 

EU Value Current value, displayed in Engineering Units. 
Units  Sets the engineering units for the discrete output 

(such as percentage, IN H20, PSIG, MCF, degrees 
F, milliamps, volts, etc.).  

 

3. Click Apply if you change any parameters on this screen.  

4. Proceed to Section 7.5.4, DO Alarms Tab.  

7.5.4 DO Alarms Tab 
Select Configure > I/O > DO Points > Alarms tab to configure the alarm 
parameters for this DO point. 

1. Select the Alarms tab. The Alarms screen displays.   

 
Figure 7-25. DO, Alarms tab 
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2. Review the following fields for your organization’s values.   

Field Description 
RBX Alarming Sets the Spontaneous-Report-by-Exception (SRBX 

or RBX) alarming for this point. Valid values are:  
 Disabled Turns off RBX alarming. This is 

the default.   
 On Alarm Set Generates an RBX message to 

the host when the point enters an 
alarm condition.  

 On Alarm Clear Generates an RBX message to 
the host when the point leaves 
an alarm condition. 

 On Alarm Set 
and Clear 

Generates an RBX message to 
the host when the point enters or 
leaves an alarm condition. 

 Note:  RBX Alarming requires you to configure the 
communications port. Refer to Section 3.4.3, 
Comm Ports RBX Tab. 

 

3. Click Apply if you change any parameters on this screen.  

Note:  After you configure a point and click Apply, click Flash Memory 
Save Configuration (on the ROC > Flags screen) to save I/O 
configuration to permanent memory in case you must perform a cold 
start.  

7.6 Pulse Input (PI) Configuration 
Pulse Input (PI) modules accept pulse trains (square wave signals) that 
measurement devices (such as turbine meters) generate.  The pulse input 
accepts digital level on/off signals from an external device and accumulates 
the changes over a configured period of time. The PI can also determine a 
rate from the accumulated pulses over a configured period of time.  

Select Configure > I/O > PI Points. The Pulse Input screen displays. 
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Figure 7-26. Pulse Input  

The Pulse Input screen has three tabs. Use each tab to configure a 
component of the input. 

 Use the General tab to set the basic parameters for the PI point.  

 Use the Advanced tab to configure features, such as EU Options, Rate 
Period, Rollover value, and Conversion for the pulse input.  

 Use the Alarms tab to sets the alarm parameters for this PI point. 

Note:  If you enable Alarming (Configure > I/O > PI Points > 
General tab), configure the limit alarms (four levels, rate, and 
deadband) on the Alarms tab. By disabling alarms, you can 
prevent alarms from generating for this point. To conserve alarm 
log space, enable alarms only when necessary. If you do not plan 
to use all the alarms, check and adjust the value of each one to 
prevent the generation of false alarms.   

Note:  After you configure a point and click Apply, click Flash Memory 
Save Configuration (on the ROC > Flags screen) to save I/O 
configuration to permanent memory in case you must perform a cold 
start.  

7.6.1 PI General Tab 
The Pulse Input screen initially displays the General tab. Use this tab to set 
the basic parameters for the pulse input point.  
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Figure 7-27. PI, General tab  

1. Review the following fields for your organization’s values:  

Field Description 
Pulse Inputs Selects the pulse input to be configured. The inputs 

are listed by both Point Number and Tag. 
Note:  The selection in this field applies to each tab 

on this screen.   
Tag Sets a short (10 alphanumeric characters) identifier 

for the point.  
Note:  This selection in this field applies to each tab 

on this screen. 
Point Number This read-only field identifies the rack location for 

this point.  
EU Value Sets the value for engineering units (EUs).   

The EU Value is dependent on how you set the EU 
Options on the Advanced tab. If you set up the PI as 
a Rate (Max Rollover), then the system assigns the 
Current Rate to the EU Value. If you set up the PI as 
an accumulator using Today’s Total (Max Rollover), 
then the system assigns Today’s Total to the EU 
Value. 
If you set up the PI as an accumulator using Running 
Total (Entered Rollover), then the EU Value 
corresponds to the accumulated pulses times the 
Conversion. The system compares the EU Value to 
the value entered for the Rollover Value. If the EU 
Value is greater than or equal to the entered Rollover 
Value, the system sets the EU Value here to zero. 

Units Sets the engineering units for the I/O (such IN H20, 
PSIG, MCF, degrees F, milliamps, volts, etc.).  
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Field Description 
Scan Period Sets, in seconds, the amount of time between scans 

of the EU Value.  The system calculates this rate by 
counting the number of pulses during the scan 
interval and dividing by the time interval.  
To avoid highly fluctuating calculation results, 
typically at least 10 pulses should occur between 
scans at low flow conditions. For example, if a flow 
meter produces one pulse per second at low flow, 
then set the Scan Period value to a minimum of 10 
(10 seconds).  
Note:  Once the system reaches the scan period, it 

updates the values in the Accum’d Pulses, 
Pulses Today, Today’s Total, Yesterday’s 
Total, and Current Rate fields.  

Accum’d Pulses Sets the number of raw counts stored in the 
accumulated value counter in firmware. For each 
scan period, the FloBoss determines the number of 
raw counts that have occurred since the last scan 
period and adds them to the accumulated value 
counter. The accumulated value rolls over to zero 
after reaching 16,777,216. 

Today’s Total Displays the total EU Values accumulated for the 
current contract day, calculated by multiplying the 
conversion value by the accumulated pulses. The 
system resets this value to zero at the contract hour.  

Yesterday’s Total This read-only field shows the total EU Value 
accumulated the previous contract day, calculated as 
the previous day’s Today’s Total value at the 
contract hour before being cleared.  

Current Rate This read-only field shows the calculated rate as of 
the most recent scan expressed in EUs per unit of 
time.  You select time units using the Rate Period 
field on the Advanced tab. The system calculates the 
rate at the end of each scan period by multiplying the 
number of pulses received by the conversion value 
divided by the rate period.  

Active Alarms This read-only field shows any active alarms for this 
point. When you Enable alarming, the limit alarms 
(such as Low Alarm and Rate Alarm) that are active 
appear. Even if you Disable alarming, the Point Fail 
(hardware reports a malfunction) alarm and Manual 
(Scanning Disabled) indicators can still appear. Refer 
to Section 1.6.1, FloBoss 107 Dynamic Interface. 

Frequency This read-only field shows, in pulses/second, the 
frequence of incoming pulses.   
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Field Description 
Scanning Sets the scanning option for this point.  Valid values 

are Enabled (automatically process the field input 
and display the last pulse input scan in the Value 
field) or Disabled (permit only manual updates of the 
Value field).  
Note:  If you enable alarming, the FB107 generates 

a Manual Mode alarm when scanning is 
disabled. If Scanning is disabled, you must 
manually enter a value in the Value field to 
override the input.  

Alarming  Sets the alarm option for this point. Valid values are 
Enabled (configures the limit alarms - four levels, 
Rate, and Deadband - on the Alarms tab) or 
Disabled (does not generate limit alarms).  
Note:  The Point Fail alarm may appear in the Active 

Alarms field, but is not logged in the Alarms 
file. If you Enable alarming, the system 
generates an alarm if you disable scanning.  

 

2. Click Apply if you change any parameters on this screen.  

3. Proceed to Section 7.6.2, PI Advanced Tab.  

7.6.2 PI Advanced Tab 
Use this tab to configure features, such as EU Options, Rate Period, 
Rollover value, and Conversion for the pulse input. 

1. Select the Advanced tab. The Advanced screen displays.   

 
Figure 7-28. PI, Advanced tab 
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2. Review the following fields for your organization’s values:  

Field Description 
EU Options Sets how the system assigns the value of the 

engineering units (EU).  Valid values are:  
 Rate Uses the value of the Current 

Rate parameter (as shown on the 
General tab).   

 Today’s Total Uses the value of Today’s Total 
parameter (as shown on the 
General tab).  

 Running Total Uses a value calculated by 
multiplying the accumulated 
pulses (shown on the General 
tab) by the Conversion factor.  If 
the EU Value exceeds the 
Rollover value, it is cleared and 
starts to accumulate again from 
0.  
Note: This option does not clear 

EU values at the contract 
hour.  

Conversion Sets the conversion value if you selected Rate as an 
EU option.  Valid values are EUs/Pulse (associates 
a specific number of engineering units, typically 
fractional parts such as 0.01, with a single pulse)  or 
Pulses/EU (associates a specific number of pulses, 
such as 100, with one engineering unit).   
Note:  If you use the PI as input to the AGA7 

calculations, complete the Conversion 
Factor field to produce the EU value as MCF 
or kM3.  

Slow Pulse Filter 
Time 

Sets the amount of time, in seconds, between the 
start of a pulse and the recognition of that pulse.. 
Click  to display all valid values. Estimate the 
amount of signal “bounce” time so that the FloBoss 
does not count noise as actual pulses. If you select 
None (the default value, the FloBoss recognizes all 
pulse signal movement as actual pulses. 

Rollover Value Sets a value in EUs (not pulses) to indicate when 
rollover should occur. 
Note:  This field is available only if you select 

Running Total as an EU Option value.  
Rate Period Sets how the system calculates rates, if you selected 

Rate as an EU Option.  Valid values are:   
 EU/min Calculates based on EU minute 

totals.  
 EU/hour Calculates based on EU hour 

totals.  
 EU/day Calculates based on EU day 

totals.  
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Field Description 
Rate Period (cont.) Note:  If you select EUs/Pulse as a conversion rate 

and EU/min as a rate period, the system 
calculates Current Rate as (accumulated 
pulses x Conversion) ÷ (Scan Period x 
conversion from seconds to minutes). If you 
select Pulses/EU as a conversion rate and 
EU/hour as a rate period, the system 
calculates Current Rate as (accumulated 
pulses ÷ Conversion) ÷ (Scan Period x 
conversion from seconds to minutes). 

 

3. Click Apply if you change any parameters on this screen.  

4. Proceed to Section 7.6.3, PI Alarms Tab.  

7.6.3 PI Alarms Tab 
Use this tab to configure the alarm parameters for this PI point. 

Note:  You must enable alarming on the General tab to configure the limit 
alarms (Low, High, LoLo, HiHi, Rate, and Deadband) on this tab. If 
you disable alarming, no limit alarms generate for this point. The 
Point Fail alarm appears in the Active Alarms field on the General 
tab, but the system does not log it in the Alarms Log.  

To conserve alarm log space, enable alarms only when necessary. Even if 
you do not plan to use all the alarms, check and adjust the value of each one 
alarm to prevent the generation of false alarms. 

1. Select the Alarms tab. The Alarms screen displays.  

 
Figure 7-29. PI, Alarms tab 

2. Review the following fields for your organization’s values.  
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Field Description 
Low Alarm Sets, in engineering units, a limit value to which the 

input value must fall to generate a Low alarm.  
High Alarm Sets, in engineering units, a value to which the input 

value must rise to generate a High alarm.. 
LoLo Alarm  Sets, in engineering units, a value to which the input 

value must fall to generate a LoLo alarm.   
Note:  Typically you set the value for the LoLo Alarm 

lower than the value for the Low alarm. 
HiHi Alarm Sets, in engineering units, a value to which the input 

value must rise to generate a HiHi Alarm. 
Note:  Typically you set the value for the HiHi Alarm 

higher than the value for the High alarm. 
Rate Alarm Sets, in engineering units, a value that represents 

the maximum amount of change allowed in the 
calculated rate between updates before an alarm 
generates. If the change is equal to or greater than 
this value, an alarm occurs,  
Note:  To disable the rate alarm without disabling the 

other alarms, you can set the rate alarm value 
greater than the scan of the analog input. 

Alarm Deadband Sets, in engineering units, an inactive zone above 
the Low Alarm limit and below the High Alarm limit.  
The Alarm Deadband prevents the alarm from being 
set and cleared continuously when the input value is 
oscillating around the alarm limit. This prevents the 
Alarm Log from being over-filled with data. 

RBX Alarming Sets the Spontaneous-Report-by-Exception (SRBX 
or RBX) alarming for this point. Valid values are:  

 Disabled Turns off RBX alarming. This is 
the default.  

 On Alarm Set Generates an RBX message to 
the host when the point enters an 
alarm condition.  

 On Alarm Clear Generates an RBX message to 
the host when the point leaves 
an alarm condition. 

 On Alarm Set 
and Clear 

Generates an RBXmessage to 
the host when the point enters or 
leaves an alarm condition. 

 Note:  RBX Alarming requires you to configure the 
communications port. Refer to Section 3.4.3, 
Comm Ports RBX Tab. 

 

3. Click Apply if you change any parameters on this screen.   

Note:  After you configure a point and click Apply, click Flash Memory 
Save Configuration (on the ROC > Flags screen) to save I/O 
configuration to permanent memory in case you must perform a cold 
start.  
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7.7 Soft Points 
Softpoints are global data storage areas that any FloBoss application can 
use. A softpoint may store the results of a specified calculation from an 
FST or an intermediate result of a specified value an FST acquires. 
Softpoints consist of a ten-character identifier (“tag”), one integer value 
(16-bits from 0 to 65,535), and up to 20 floating point values. The FB107 
supports up to 32 softpoints. 

1. Select Configure > I/O > Soft Points. The Soft Point screen displays.  

 
Figure 7-30. Soft Point 

2. Review the following fields for your organization’s values.  

Field Description 
Softpoints Sets the softpoint to configure. Click  to display all 

available softpoints.  
Tag Sets a 10-character identifier for the softpoint. 
Integer Flag Sets a 16-bit unsigned integer value the system uses 

to indicate a status. The value may be under the 
control of an FST or a user program. 

Data #1 through  
Data #20 

Sets up to 20 parameters (Data #1 to Data #20) to 
provide storage for IEEE floating point values for the 
softpoint. 

 

3. Click Apply if you change any parameters on this screen.   

Note:  After you successfully configure a softpoint, access the Flags screen 
(ROC > Flags) and click Save Configuration. This saves a 
configuration (and associated softpoints) to permanent memory in 
case you must perform a cold start.  
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4. Click OK to display the FB107 graphic.  

7.8 Multi-Variable Sensor (MVS) Configuration 
The MVS Sensor setup screens provide you with an interface to configure a 
multi-variable sensor, a smart device that can measure temperature, static 
pressure, and differential pressure.   

Because of the FB107’s graphical interface, you can either use the 
Configure option on the ROCLINK 800 menu (Configure > I/O > MVS 
Sensor) or click on the FloBoss 107 MVS module graphic. (You can also 
use the configuration tree.) The FB107’s graphical interface display shows 
the current settings of the point (including alarms and integrity) and 
provides access to the I/O configuration screens.  

Note:  If you change a parameter on the MVS screens, you must update the 
sensor configuration using the Write button on the Multi-Variable 
Sensor screen’s General tab.   

When you click the MVS module on FloBoss 107 graphical display, the 
two-tab MVS screen displays.   

 
Figure 7-31. MVS Interface 

7.8.1 MVS Module General Tab 
The MVS display shows the General tab, which shows the current settings 
including any alarms and integrity alerts.  
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Figure 7-32. MVS Interface, General tab 

Field Description 
Installed Module  This read-only field shows the type of module the 

FB107 uses for point configuration. It does not 
require that a module be physically installed to 
display. The FloBoss 107 remembers the “installed 
module” type until you “uninstall” it. Refer to Section 
1.6.2, Actual versus Installed Module. 

Description This read-only field shows a description of the 
hardware currently installed in the FB107.  

Part Number This read-only field shows the part number of the 
hardware currently installed in the FB107.  

Serial Number This read-only field shows the serial number of the 
hardware currently installed in the FB107.  

Actual Module  This read-only field shows the module is physically 
installed in the backplane. This field is updated 
whenever you restart the FB107. Refer to Section 
1.6.2, Actual versus Installed Module.  

Revision  This read-only field shows the firmware revision for 
the hardware currently installed in the FB107.  

Build Date  This read-only field shows the date the firmware 
was built for the hardware currently installed in the 
FB107.  

Boot Revision  This read-only field shows the revision number for 
the main startup firmware currently installed in the 
FB107 or hardware.  

Boot Build Date  This read-only field shows the date the main startup 
firmware currently installed in the FloBoss or 
hardware.  

Integrity  This read-only field shows the status of the 
hardware currently installed in the FloBoss 107. 
Alarms display on the user interface indicating the 
state of the hardware including the CPU, I/O 
modules, CPU I/O assembly, MVS modules, 
communication modules, and smart application 
modules. You can mouse over an alarm icon to 
display the definition. 
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Field Description 
Uninstall Click to remove the hardware currently installed in 

the FB107.  This field displays the type of module the 
FB107 uses for point configuration and does not 
require that a module be physically installed to 
display. The FB107 remembers the “installed 
module” until you “uninstall” it. Refer to Section 1.6.2, 
Actual versus Installed Module. 

 

7.8.2 MVS Module I/O Points Tab  
Use this tab to assign types of I/O to each channel before you configure the 
I/O points.  You can navigate FloBoss 107 options using the I/O menu 
options, by clicking on the FloBoss 107 graphic and selecting a tab or 
button, or by clicking on MVS in the configuration tree.  

1. Select the I/O Points tab. The I/O Points screen displays.  

 
Figure 7-33. MVS, I/O Points tab 

2. Review the following fields for your organization’s values:  

Field Description 
Point Type Defines the database point to be one of the possible 

types of points available to the system.  The point 
type determines the basic functions of a point. Point 
type displays the database points associated with the 
installed hardware and CPU. The Point type 
indicates the location of the point at the slot number 
of the I/O module and channel number. For example, 
DI 2-1 indicates the Point Number for a discrete input 
at module slot number two, first channel. 

Tag Sets a short (10 alphanumeric characters) identifier 
for the point.  

Configuration  Click … (the TLP button) to display a configuration 
screen you use to configure the point associated with 
the hardware. See Sections 7.8.3 through 7.8.6.  
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Field Description 
Integrity  This read-only field shows the status of the 

hardware currently installed in the FloBoss 107. 
Alarms display on the user interface indicating the 
state of the hardware including the CPU, I/O 
modules, CPU I/O assembly, MVS modules, 
communication modules, and smart application 
modules. You can mouse over an alarm icon to 
display the definition. Refer to Section 1.6.1, FloBoss 
107 Dynamic Interface.  

Active Alarms This read-only field shows any alarms that are 
active for this point. When you enable alarming, any 
active limit alarms (such as Low Alarm and Rate 
Alarm) appear. If you disable alarming, the Point Fail 
(hardware reports a malfunction) alarm and Manual 
(Scanning Disabled) indicators can still appear. Refer 
to Section 1.6.1, FloBoss 107 Dynamic Interface. 

 

3. Click Apply if you change any parameters on this screen.  

4. Proceed to Section 7.8.3, MVS General Tab to configure the point.  

7.8.3 Multi-Variable Sensor General Tab 
The Multi-Variable Sensor (MVS) screens provide you with an interface to 
configure a multi-variable sensor.   

Note:  If you have a dual-variable sensor (DVS) attached to the MVS 
module, you configure it as part of the MVS module. If you attach 
the DVS to the DVS connector on the FB107 base unit, you 
configure the DVS as an analog input. Refer to the ROC Protocol 
Configuration Manual (Form A4199).  

1. Select Configure > I/O > MVS Sensor. The Multi-Variable Sensor 
screen displays, showing the General tab.  

Note:  You can also access this screen by clicking the TLP button on 
the graphic interface’s I/O Points screen (see Section 7.8.2).   



ROCLINK 800 User Manual (FB107) 

7-46 Configure Menu Issued Jan-08 

 
Figure 7-34. Multi-Variable Sensor, General tab 

2. Review the following fields for your organization’s values. 

Note:  If you change any values on this tab – or on the Advanced, 
Calibration, or Alarms tabs – other than the MVS or Tag fields, 
you must click Write in the Sensor Configuration field to apply 
those changes to the sensor configuration.  

Field Description 
MVS Selects the MVS sensor to configure. Each MVS has 

a unique address number to differentiate it from other 
MVS units, because MVS sensors can be multi-
dropped. 

Tag Sets the ten-character identifier that resides in the 
MVS. 

Address Sets the unique address for this device used in the 
device communications protocol. The default 
address is 1. If the MVS is used in the multi-drop 
mode, each MVS must have a unique address. 
Address 240 can be used to poll the sensor to 
determine the address of the connected sensor. This 
is similar to polling a FloBoss using Address and 
Group 240. When Address 240 is used, the sensor 
will respond with its address by updating the Address 
field. 
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Field Description 
Voltage This read-only field shows the voltage input to the 

sensor.  
If the MVS interface version (as shown on the 
Advanced tab’s Sensor Interface Version field) is 6 or 
greater, this field should read approximately 5, which 
is the voltage to the microcontroller in the sensor. If 
the MVS interface version is less than 6, this field 
shows the input voltage to the sensor.  
Note:  For proper operation, the input voltage to the 

sensors with versions less than 6 must be at 
least 10.5 volts dc. 

Sensor 
Configuration 

Click Write to update the sensor with the current 
values on the screen or click Read to read the 
sensor’s current configuration data and process 
variables.  

Pressure/ 
Temperature Values 

These read-only fields show scaled differential 
pressure readings from the sensor. The units display 
as either InH2O or kPa. The scaled Differential 
Pressure (Reverse DP) reading is from the sensor 
times a negative “1” for flow in the reverse direction. 
The scaled absolute Pressure (Static Pressure) 
reading from the sensor displays in either PSI or 
kPa. The scaled process Temperature reading from 
the sensor displays in either degrees Fahrenheit or 
degrees Celsius, based on global settings (ROC > 
Information).  

Scanning Sets whether the input communicates with the MVS 
sensor. Valid values are Enabled (allow 
communications to the MVS sensor) or Disabled 
(the system does not update information from the 
sensor).  
Note:  The field in this frame displays scanning 

status messages. Additionally, the system 
generates an alarm when you Disable 
scanning.  

Sensor Alarms Sets the alarm conditions of the sensor or any 
alarms that are active for this point. Valid values are 
Enabled (display any active failed alarms, such as 
point fail or sensor fail) or Disabled (do not display 
alarms).   
Note:  When you enable sensor alarms, the system 

displays any loss of communications to the 
sensors by displaying an RS-485 
Communications Failure. If you disable 
scanning, an Off Scan Mode alarm displays.  

Active Alarms These read-only fields indicate any alarms that are 
active for this point. If you enable alarming, any 
active limit alarms (such as Low Alarm and Rate 
Alarm) appear. Even if you disable alarming, the 
Point Fail (hardware reports a malfunction) alarm 
and Manual (Scanning Disabled) indicators can still 
appear. 
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3. Click Write if you change any parameters (other than the MVS 
identifier or Tag) on this screen.   

4. Proceed to Section 7.8.4, MVS Advanced Tab.  

7.8.4 Multi-Variable Sensor Advanced Tab 
Use the MVS Advanced screen to configure how the FB107 retains 
information on failure, what it uses as a reference temperature, and reports 
pressure.   

1. Select the Advanced tab. The Advanced screen displays.  

 
Figure 7-35. Multi-Variable Sensor, Advanced tab 

2. Review the following fields for your organization’s values.  

Field Description 
Sensor Interface 
Version 

This read-only field shows the version of the sensor 
interface firmware for the sensor.   

Units This read-only field shows the engineering units 
selected for the process variable.  You define this 
value on the Device Information screen (ROC > 
Information); the MVS reads this value from the 
system.  
Note:  If you change this value, click Write on the 

General tab to save the new configuration.  



ROCLINK 800 User Manual (FB107) 

Issued Jan-08 Configure Menu 7-49 

Field Description 
Report Pressure As Sets the location of the static pressure tap in relation 

to the orifice and normal flow. Valid values are 
Upstream or Downstream. Upstream is the default. 
If you select Downstream, the system subtracts the 
Diff Pressure (DP) (in PSI) from the Static Pressure 
(SP) reading to obtain a Downstream Pressure 
measurement for archiving. For Downstream 
operation, adjustments to the calibration procedure 
may be required when setting the Span value. 
Note:  If you change this value, click Write on the 

General tab to save the new configuration. 
Action on Failure Sets how the sensor retains values on failure of the 

sensor, an input point, or communications.  Valid 
values are Hold Last Value (retains the last values 
before the failure) or Set to Fault Value (returns to 
the configured fault values).  
Note: See the Alarms tab for the Fault Value.  

Reference 
Temperature  

Sets a reference temperature the sensor uses when 
reporting differential pressure. The default value is 
60 °F (15.6 °C).  
The system uses this value only when you change 
the Units selection is changed or when you select the  
Downstream option is selected in Metric units. 
Note:  If you change this value, click Write on the 

General tab to save the new configuration. 
 

3. Click Write if you change any parameters on this screen. 

4. Proceed to Section 7.8.5, MVS Calibration Tab. 

7.8.5 Multi-Variable Sensor Calibration Tab 
Use this tab to calibrate the MVS points.  

Note:  You can calibrate sensors at up to five points: zero, span, and up to 
three mid-points. You must define at least zero and span points for 
calibration.  

1. Select the Calibrate tab. The Calibrate screen displays.   
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Figure 7-36. Multi-Variable Sensor, Calibration tab 

2. Review the following fields for your organization’s values. 

Field Description 
Freeze Click to stop the system from updating analog, MVS, 

or temperature (RTD) inputs during verification or 
calibration.  Once you click this button, the system 
grays it out as a reminder.  

Scan Mode This read-only field shows the input status.  Normal 
Poll indicates the system is functioning normally. 
After you click Freeze, the software changes the 
displayed message to Input Freeze for the 
verification or calibration process and activates all 
buttons in the Freeze Values frame.  

Differential 
Pressures, Static 
Pressure, 
Temperature 

These read-only fields show the values for the 
differential pressure, static pressure, and 
temperature received from the analog, MVS, or 
temperature (RTD) input.  

 

At this point, you can verify or calibrate the values for differential pressure, 
static pressure, or temperature. ROCLINK 800 displays similar screens for 
each activity. Typically the process is to first perform a verification. If the 
results are within contractual limits, the process ends. However, if the 
results are not within contractual parameters, perform a calibration 
followed by a repeat verification.  

3. Click Freeze. ROCLINK 800 freezes the input for the sensor.  

4. Click Verify. ROCLINK 800 displays a verification screen:  
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Figure 7-37. Verify Calibration 

5. Complete the Dead Weight/Tester Value field using a pre-determined 
calibration value. Review the other fields on this screen:  

Field Description 
Point  Identifies the point (differential pressure, static 

pressure, or temperature) being verified. 
Action Shows the activity (here, Verify) being performed as 

well as various values:  
 Actual Shows the current value from the 

sensor.  
 Expected Shows the expected value (as 

entered in the Dead Weight/Tester 
Value field).  

 Deviation Shows the difference between the 
expected value and the actual 
value. (Deviation = Expected – 
Actual.)   

 % Deviation Shows the deviation as a 
percentage of range. 

 Note: Click Log Verify to add lines to this screen.   
Dead Weight/Tester 
Value 

Sets the expected value against which the system 
tests.  
Note: This is the Expected value in the Action field.   

Live Reading This read-only field shows the current reading from 
the sensor.  

Deviation  This read-only field shows the deviation between the 
expected and actual values. (%Deviation = Deviation 
÷ [(Span EU – Zero EU) x 100%]) Use this value to 
determine the need for calibration or adjustment.  

Log Verify Click to write displayed data to the Event Log.  
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6. Click Log Verify to write the displayed data to the Event Log.  

7. Click Done when you have completed the verification. The system 
displays the Calibrate screen.  

8. Click Calibrate if the values resulting from step 4 are outside the 
contractual limits. The system displays a Set Zero screen:  

 
Figure 7-38. Set Zero Calibration 

9. Complete the Dead Weight/Tester Value field using a pre-defined 
zero calibration point.  

10. Click Set Zero. The system adds a line to the online display, changes 
the value in the Dead Weight/Tester Value field to the pre-defined 
zero value, and changes the button label to Set Span.  

11. Click Set Span. The system adds a line to the online display, changes 
the value in the Dead Weight/Tester Value field to the pre-defined 
span value, and changes the button label to Set Mid1. 

12. If appropriate, define up to three midpoints for calibration. Review the 
following fields on the screen:  

Field Description 
Point Identifies the point (differential pressure, static 

pressure, or temperature) being calibrated. 
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Field Description 
Action Shows the activity being performed as well as 

various values:  
 As Found  Shows the sensor’s initial value.  
 As Left Shows the sensor’s value after 

calibration.  
 Deviation Shows the difference between the 

As Found value and the As Left 
value.   

 % Deviation Shows the difference between the 
As Found and As Left values as a 
percentage.  

Dead Weight/Tester 
Value 

Sets the expected value against which the system 
calibrates.  
Note: This is the Expected value in the Action field.   

Live Reading This read-only field shows the current reading from 
the sensor.  

Deviation  This read-only field shows the deviation between the 
expected and actual values. (%Deviation = Deviation 
÷ [(Span EU – Zero EU) x 100%]) 

 

13. Click Done when you have completed the calibration. The Calibrate 
screen displays.  

14. If the calibration results indicate that you need to adjust the sensor, 
click Zero Shift/Offset/RTD Bias (depending on the point you are 
adjusting). The system displays a Set Zero Shift (Offset) screen.  

 
Figure 7-39. Set Zero Shift (Offset) 

15. Perform one of the following: 
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For… Choose… 
Differential Pressure Click Set Offset. 
Static Pressure Complete the Measured Pressure Reading field.  
Temperature Complete the Temperature Standard Reading field. 
 

16. Click Set Offset (for static pressure and temperature). Review the 
following fields.  

Field Description 
Point Identifies the point (differential pressure, static 

pressure, or temperature) being adjusted.  
Action Shows the activity being performed as well as 

various values:  
 As Found  Shows the sensor’s initial value.  
 As Left Shows the sensor’s value after 

calibration.  
 Deviation Shows the difference between the 

As Found value and the As Left 
value.   

 % Deviation Shows the difference between the 
As Found and As Left values as a 
percentage.  

Temperature 
Standard Reading 

Sets the temperature as read from a calibrated 
temperature probe.  
Note:  This field displays only for temperature 

points.  
Measured Pressure 
Reading 

Sets the pressure as read from a calibrated pressure 
sensor. 
Note:  This field displays only for static pressure 

points.  
Live Reading This read-only field shows the normal temperature 

or pressure, as taken from the FB107.   
Temperature Bias This read-only field shows the difference between 

the live temperature reading and the entered 
standard temperature reading that ROCLINK 800 
applies to the temperature value.   
Note:  This field displays only for temperature 

points.  
Pressure Offset This read-only field shows the difference between 

the live pressure reading and the measured pressure 
reading that ROCLINK 800 applies to the pressure 
value.   
Note:  This field displays only for static pressure 

points.  
Deviation  This read-only field shows the difference between 

the live pressure or temperature reading and the 
measured pressure or temperature reading.  
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17. Click Done. ROCLINK 800 displays the Calibrate screen. This 
completes the calibration process.   

7.8.6 Multi-Variable Sensor Alarms Tab 
Use this tab to establish limits for differential pressure, pressure, 
temperature, and RBX alarms.  

1. Select the Alarms tab. The Alarms screen displays.  

 
Figure 7-40. Multi-Variable Sensor, Alarms tab 

2. Review the following fields for your organization’s values:  

Field Description 
Enabled/Disabled Sets whether, for the particular input, alarms are 

active. Valid values are Enabled (configure alarms 
using the set parameters) or Disabled (do not 
generate an alarm, regardless of configuration). 
The system logs alarms to the alarm log. To 
conserve log space, enable alarms only when 
necessary.  
Note:  If you disable an alarm, the system does not 

generate an alarm for this point, regardless of 
the alarm configuration. Alarm statuses 
display in the read-only Status field on the 
General tab.  

Low Alarm  Sets, in engineering units, a limit value to which the 
input value must fall to generate a Low alarm.  

High Alarm Sets, in engineering units, a value to which the input 
value must rise to generate a High alarm.. 
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Field Description 
Alarm Deadband Sets, in engineering units, an inactive zone above 

the Low Alarm limit and below the High Alarm limit.  
The Alarm Deadband prevents the alarm from being 
set and cleared continuously when the input value is 
oscillating around the alarm limit. This prevents the 
Alarm Log from being over-filled with data. 

Fault Value Sets the point’s value on failure. If a point fails and 
you have previously set the value on the Advanced 
tab’s Action on Failure field to Set to Fault Value, 
the system uses the value entered in this field as the 
EU value for that point.  
Note: Fault Values are only used in Modify Limits. 

RBX Alarming Sets the Spontaneous-Report-by-Exception (SRBX 
or RBX) alarming for this point. Valid values are: 

 Disabled Turns off RBX alarming. This is 
the default.  

 On Alarm Set Generates an RBX message to 
the host when the point enters an 
alarm condition.  

 On Alarm Clear Generates an RBX message to 
the host when the point leaves 
an alarm condition. 

 On Alarm Set 
and Clear 

Generates an RBX message to 
the host when the point enters or 
leaves an alarm condition. 

 Note:  RBX Alarming requires you to configure the 
communications port. Refer to Section 3.4.3, 
Comm Ports RBX Tab. 

 

3. Click Apply if you change any parameters on this screen.  

7.9 Control Menu 
Use the Control menu options to configure FST Registers and PID Loops.  

Note:  The FB107 currently does not support the Radio Power Control and 
DS800 menu options.  

7.9.1 Function Sequence Table (FST) Registers 
Use the FST Registers screen to configure FST registers and add timers and 
other execution controls. Refer to Appendix B for a detailed discussion of 
these screens and the FST Editor.  

Select Configure > Control > FST Registers. The FST Registers screen 
displays. 
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Figure 7-41. FST Registers 

The FST Registers screen has two tabs. Use each tab to configure a 
component of the FST.  

 Use the General tab to configure and enable the FST registers.    

 Use the Advanced tab to add timers, execution controls, and other 
features to the FSTs.  

Note:  After you configure a point and click Apply, click Flash Memory 
Save Configuration (on the ROC > Flags screen) to save I/O 
configuration to permanent memory in case you must perform a cold 
start.  

7.9.1.1 FST Registers General Tab 
The FST Registers screen initially displays the General tab. Use this tab to 
enable and configure the FST registers.  
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Figure 7-42. FST Registers, General tab 

1. Review the following fields for your organization’s values.  

Field Description 
FST Selects the FST to configure. Click  to display all 

available FSTs.  
Tag Sets the ten-character identifier for the FST. 
Version This read-only field shows the version (if assigned) 

of the FST on download.  
Description  This read-only field shows the description (if 

assigned) for the FST on download.  
Status Sets the current state and enables you to start or 

stop the FST.  Valid values are Enabled (FST is 
active) or Disabled (FST is not active).  
Note:  If you change the value in this field, you must 

also click Apply.  
Registers #1 through
#10 

Provides up to 10 storage points for FST floating 
point values.  
Use FST registers to store calculated or manually-
entered values. You can also those values from one 
FST to another. For example, an FST can write 
values to the registers and also read the values 
stored in the FST Register storage points. Registers 
may be read from, or written to, any FST configured 
for the FloBoss. 

 

2. Click Apply if you changed any parameters on this screen.  

3. Proceed to Section 7.9.1.2, FST Registers Advanced Tab.  

7.9.1.2 FST Registers Advanced Tab 
Use the Advanced tab to add timers, execution controls, and other features 
to the FSTs. 
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1. Select the Advanced tab. The Advance screen displays.   

 
Figure 7-43. FST Registers, Advanced tab 

2. Review the following fields for your organization’s values. 

Field Description 
Timer #1 through #4 Sets up to four countdown timers that signal certain 

periods or times have elapsed.  You set the time, 
and the FST updates the time. These four timers, 
when set to values greater than 0, decrement by 1 
every cycle time. The scan period determines the 
cycle times.  

Misc #1 through #4 Sets up to four unsigned 8-bit integers (with valid 
values from 0 to 255) the FST can use for global 
storage.  

Mesg #1 and #2 Provides two 30-character fields for storing 
messages that display in the FST Message area.  

Execution Delay Sets a period, in seconds, between the execution of 
successive FST command steps.  The default is 0 
seconds. The minimum delay is 0.1.  

Result Register Sets a special-purpose register that stores the 
floating point result from the most currently executed 
command. The Result Register (RR) may also be 
known as the Signal Value Analog (SVA).   

Compare Flag Sets a special-purpose 8-bit register that stores an 
integer representing the numbers 0 through 255. The 
logic commands manipulate the Compare Flag. The 
Compare Flag may also be known as the Signal 
Value Discrete (SVD).   

Code Size This read-only field shows the number of bytes the 
FST uses.  

Code Pointer Byte This read-only field shows the pointer byte for the 
FST.  
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3. Click Apply if you changed any parameters on this screen.  

7.9.2 Proportional, Integral, and Derivative (PID) Loops 
Proportional, Integral, and Derivative (PID) controls enable you to provide 
smooth and stable operation for feedback control loops that employ a 
regulating device, such as a control valve or a motor.  The typical use for 
PID is to control a process variable to a setpoint.  

PID is the most common control methodology in process control. PID is a 
continuous feedback loop that keeps the process flowing normally by 
taking corrective action whenever any deviation from the desired value 
(“setpoint”) of the process variable (rate of flow, temperature, voltage, and 
such) occurs. An “error” occurs when an operator manually changes the 
setpoint or when an event (such as a valve opening or closing) or a 
disturbance changes the load, thus causing a change in the process variable. 

The PID controller receives signals from sensors and computes corrective 
action to the actuators from a computation based on the error 
(proportional), the sum of all previous errors (integral) and the rate of 
change of the error (derivative). 

7.9.2.1 Enabling PID Loops  
Before you can configure a PID loop, you must first enable the FloBoss to 
recognize them.  

1. Select ROC > Information. The Device Information screen displays.  

2. Select the Points tab. The Points screen displays.  

 
Figure 7-44. Device Information, Points tab 

3. Complete the PIDs Active field with the number of PIDs you want to 
configure.   
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Note:  The read-only Maximum field shows the maximum number of 
PIDs you can define.   

4. Click Apply to save the value and then OK to close the Device 
Information screen and return to the ROCLINK 800 menu.  

7.9.2.2 Configuring PID Loops  
Select Configure > Control > PID Loop. The PID Loop screen displays.  

 
Figure 7-45. PID Loop 

For any given PID point you can define two separate PID loops, Primary 
Only and Override Only. You indicate which loop is active with a selection 
in the Control Type field. Primary Only disables the Override Control loop 
(if defined), leaving only the Primary loop active. Similarly, Override Only 
disables the Primary loop, leaving only the Override loop active.  

If you select Override Control in the Control Type field, both loops are 
active. The system then selects a change in output based on either a low or 
high limit selection, configured in the Override Type Select field.  

To control the regulating device, the PID control loop uses either one 
analog output or two discrete outputs. If you use discrete output control, 
one DO provides open/forward control and the other DO provides 
close/reverse control. (You define these outputs on the PID Loop screen’s 
Inputs/Outputs tab.) 

Each active PID loop acquires its process variable input and calculates the 
change in output required to maintain its setpoint. If you enable Override 
Control, what calculation result the system applies to the output depends on 
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whether you select the High or Low option in the Override Type Select 
field.  

If you have chosen an analog output type, the system adds the selected 
change in output to the current value of the output. If you have chosen a 
discrete output type, the system sends the change in output to one of the 
two discrete outputs. The magnitude of the correction determines the 
amount of time that an output is energized. A positive correction routes to 
the open/forward DO. A negative correction routes to the close/reverse DO. 

One application of Override PID control allows pressure control to override 
flow control when the pressure exceeds a setpoint value. For example, the 
system selects the output of the Primary flow control loop until the pressure 
input approaches the Override setpoint of 700 PSIG. As the pressure input 
approaches its setpoint, the pressure loop tries to close the valve and take 
over control at the point when the output calculated by the pressure loop is 
less than the output calculated by the flow loop. Control returns to the 
Primary flow control loop, when the change in output required to maintain 
the override setpoint no longer outweighs the flow loop’s attempts to 
maintain its setpoint. 

Through the use of an FST, you may implement a switchover algorithm. 
When the input exceeds a predetermined switchover value, the FST can 
switch the mode to Override only. When the FST determines that the input 
value is no longer in a critical range, the PID mode can be switched back to 
Primary only. 

7.9.2.3 PID Loop General Tab  
The PID Loop screen initially displays the General tab. Use this tab to 
configure general PID loop parameters.  
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Figure 7-46. PID Loop, General tab 

1. Review the following fields for your organization’s values.  

Field Description 
PID Selects the PID point to configure. Click  to display 

all available PIDs.  
Note:  The selection in this field applies to each tab 

on this screen. 
Tag Sets the ten-character identifier for the PID.  

Note:  The selection in this field applies to each tab 
on this screen. 

Scanning Sets controls for scanning the on and off status of 
the PID loop.  Valid values are Enabled (output is 
calculated and updates sent to the output point) or 
Disabled (no new output is calculated and no update 
is sent to the output point. ).  
Note:  Enable scanning only after you have defined 

the process variable and output values of a 
Primary Only loop or the process variable, 
override, and output values for a dual control 
loop.  
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Field Description 
Mode Sets the mode for the PID loop.  Valid values are 

Manual (no loops are active and the system writes 
the PID output parameter to the assigned control 
output, allowing you to adjust the output as required) 
or Auto (PID loops are active as configured under 
Control Type; you enter the setpoint of the loops and 
the system automatically sends any change in the 
calculated output to the configured output point).  

Output Type Sets the output type for the PID loop.  Valid values 
are Analog (the system writes the PID output to the 
assigned analog output point EU value) or Discrete 
(the system writes the PID output to the assigned DO 
Open Point EU value if the change in output is 
positive or writes to the assigned DO Close Point EU 
value if the change in output is negative). Any 
discrete outputs must be configured as Timed 
Duration Outputs [TDO].  

Control Type Sets the control type for PID loop. Valid values are:  
 Primary Only Sets the Primary loop as the only 

active loop. The system uses the 
output the Primary loop 
calculates to adjust the control 
output. 

 Override Only Sets the Override loop as the 
only active loop. The system uses 
the output the Override loop 
calculates to adjust the control 
output.  
Note:  This control type is used 

mainly for tuning the 
Override loop or when 
loop selection is controlled 
by an FST or other logic 
external to the PID 
algorithm. 

 Override 
Control 

Sets both the Primary and 
Override loops as active. The 
system compares the outputs 
from the two loops and uses 
either the lesser or greater of the 
two outputs (based on the 
selection in the Override Type 
Select field) to adjust the control 
output. 

Primary Setpoint Defines a setpoint for controlling the Primary PID 
loop’s process variable.   
Note:  This field does not display if you select 

Override Only as a Control Type.  
Override Setpoint Defines a setpoint for controlling the Override PID 

loop’s process variable.  
Note:  This field does not display if you select 

Primary Only as a Control Type.  
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Field Description 
Process Variable This read-only field shows the value and units for 

the Primary or Override process variable, as defined 
on the Inputs/Outputs tab.  
Note:  If you select Primary Only as a Control Type, 

the Override Process Variable field does not 
display. Likewise, if you select Override Only 
as a Control Type, the Primary Process 
Variable field does not display.  

Output Change This read-only field shows the calculated change in 
output from the associated loop. You define these 
values on the Inputs/Outputs tab. 
Note:  If you select Primary Only as a Control Type, 

the Override Output Change field does not 
display. Likewise, if you select Override Only 
as a Control Type, the Primary Output 
Change field does not display. 

Output This read-only field shows, for Auto Mode, the 
current output of the PID Loop.  
Note:  In Manual Mode, enter a value at which the 

output should remain.  
Override Type Select Sets the control output for the Override Type.  Valid 

values are High (system selects as the control 
output the higher of the Primary Output Change 
value or the Override Output Change value) or Low 
(system selects as the control output the lesser of 
the Primary Output Change value or the Override 
Output Change value).  

Loop Selected This read-only field shows the active PID loop. 
Tuning Sets parameters the system uses to tune each PID 

loop.  
Note:  The Primary Tuning fields do not display if 

you choose Override Only as a Control Type. 
Likewise, the Override Tuning fields do not 
display if you choose Primary Only as a 
Control Type.  

Gain Sets proportional gain as the ratio of the change in 
output to the change in the error.   
Typically calculated as either (Primary Process 
Variable – Primary Setpoint) or (Override Process 
Variable – Override Setpoint).  

Reset Sets integral gain or reset as the ratio of the change 
in output to the change in the integral of the error 
with respect to time. ) This value is in terms of 
repeats per minute.  
Typically calculated as either (Primary Process 
Variable – Primary Setpoint) or (Override Process 
Variable – Override Setpoint).  
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Field Description 
Rate Sets the derivative gain or rate as the ratio of the 

change in output to the change in the error with 
respect to time. This value is in terms of minutes.  
Typically calculated as (Primary Process Variable ÷ 
Primary Setpoint) or (Override Process Variable ÷ 
Override Setpoint). 

Scale Factor Sets values representing the ratio of the output span 
to input (Process Variable) span.  The sign of the 
number specifies the action of the loop: negative for 
reverse action (the default), or positive for direct 
action. Reverse action causes the PID loop point to 
produce a “decrease” in output (to close a valve, for 
example) when the process variable exceeds the 
setpoint.  

 

2. Click Apply if you change any parameters on this screen.  

3. Proceed to Section 7.9.2.4, PID Loop Inputs/Outputs Tab.  

7.9.2.4 PID Loop Inputs/Outputs Tab  
Use this tab to define and control inputs and outputs on the PID.  

1. Select the Inputs/Outputs tab. The Inputs/Outputs screen displays.   

 
Figure 7-47. PID Loop, Inputs/Outputs tab 

2. Review the following fields for your organization’s values.  
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Field Description 
Primary Process 
Variable 

Click … to select a process variable for the Primary 
PID loop, which displays on the General tab.    

Primary Units Sets the units for the Primary process variable.   
Override Process 
Variable 

Click … to select a process variable for the Override 
PID loop, which displays on the General tab.   

Override Units Sets the units for the Override process variable.   
Output Point Click … to select an analog output point for the loop.  

Note:  This field displays only if you select Analog 
as an Output Type on the General tab.  

DO Open Point/ 
DO Close Point 

Click … to select a discrete open point and discrete 
close point for the loop. These values, respectively, 
open or close the valve or other device. You must 
configure these values as TDO (Time Duration 
Output) discrete output mode.  
Note:  These fields display only if you select 

Discrete as an Output Type on the General 
tab.  

Units Sets the units for the analog or discrete output 
points.   

Output Low Limit Sets the low limit for the analog or discrete output.  If 
a change in output causes the current value to drop 
below this value, the system sets the output to this 
value.  

Output High Limit Sets the high limit for the analog or discrete output.  
If a change in output causes the current value to rise 
below this value, the system sets the output to this 
value.  

 

3. Click Apply if you change any parameters on this screen.   

4. Proceed to Section 7.9.2.5, PID Loop Advanced Tab.  

7.9.2.5 PID Loop Advanced Tab  
Use this tab to define advanced loop control features. 

1. Select the Advanced tab. The Advanced screen displays.  
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Figure 7-48. PID Loop, Advanced tab 

2. Review the following fields for your organization’s values. 

Field Description 
Loop Period Sets, in seconds, the period of time between 

executions of the PID algorithm.  This is the amount 
of time between executions from the beginning of 
one execution to the beginning of the next.  
Note:  If you select Override Control, both loops 

executed in this time period. 
Actual Period This read-only field shows the actual amount of time 

(in seconds) from the beginning of the last execution 
of the loop to the beginning of the current execution 
of the loop.  

Halt PID On Reset Sets the status of the PID control loop following a 
power restart or a warm start.  Valid values are 
Enabled (activate the PID loop) or Disabled (do not 
activate the PID loop).  

Primary Integral 
Deadband 

Sets a “window” around the setpoint for the Primary 
PID.  When the process variable is within this 
window, the system does not recalculate a change in 
output. If you enter 5, the deadband is a region of 5 
units above and 5 units below the setpoint in which 
the process variable can move without affecting the 
output.  
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Field Description 
Primary SP Ramp 
Rate 

Sets the maximum rate at which the Primary PID 
setpoint can ramp to a new value.  Maximum rate is 
in EU per minute where engineering units are the 
units of the process variable. 

Override Integral 
Deadband 

Sets a “window” around the setpoint for the Override 
PID.  When the process variable is within this 
window, the system does not recalculate a change in 
output. If you enter 5, the deadband is a region of 5 
units above and 5 units below the setpoint in which 
the process variable can move without affecting the 
output.  

Override SP Ramp 
Rate 

Sets the maximum rate at which the Override PID 
setpoint can ramp to a new value.  Maximum rate is 
in EU per minute where engineering units are the 
units of the process variable. 

Threshold Sets the threshold to prevent premature selection of 
the Override loop.  If the Override process variable is 
outside of this threshold on the safe side of the 
Override setpoint, the system always selects the 
Primary loop. However, if the Override process 
variable is within the threshold of the Override 
setpoint or is on the unsafe side of that setpoint, the 
system can select the Override loop. 
Note:  If you set the override Threshold to 0.0, the 

system uses the high/low value of the 
Override Type Select field (defined on the 
General tab) to select the appropriate change, 
regardless of the error in the Override loop. 

Manual Tracking Sets how the system tracks setpoint and process 
variable values in moving between Auto and Manual 
Modes (defined on the General tab). Valid values are 
Enabled (sets the Primary loop’s setpoint equal to 
the process variable when the PID point is in Manual 
mode) or Disabled (does not equalize these values). 
This is typically used to eliminate a value “bump” 
when transferring from Manual to Auto mode.  

 

3. Click Apply if you change any parameters on this screen.  

7.9.2.6 Example PID Configuration  
The following example describes how to configure a PID point and 
associated inputs and outputs to implement flow control with pressure 
override to protect against over-pressuring the line.  

In this example, the Primary process variable (Primary PV) is the 
volumetric flow rate per day obtained from an orifice meter run point. The 
system obtains the Override process variable (Override PV) from the static 
pressure value from an MVS or analog input. Both the Primary and 
Override loops require you to define a setpoint (the value at which you 
wish to control the loop). The example describes the process for setting up 
either discrete or analog control for the control output. 
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If a 4 to 20 mA signal to an I/O converter controls the control valve:  

 Configure an analog output with the appropriate Low and High Reading 
EU (engineering units). The units can either be in terms of the valve 
position (0 to 100%) or in terms of flow capacity (0 to 1000 MCF/Day).  

 Set the Output Type on the PID screen to Analog.  

 On the Inputs/Outputs tab, define an output point TLP using as an 
analog input, the desired Logical Number, and EU Value parameter. 

If a motorized actuator on the valve controls the control valve:  

 Configure two discrete output points for the open and close contacts as 
TDO (Time Duration Output) DOUT types. Set the Low Reading Time 
to the minimum amount of time (in seconds) the TDO can be energized 
to move the motor. Set the High Reading Time to the amount of time 
(in seconds) the TDO must be energized for full travel. Set the Low and 
High Reading EU values. The units can either be in terms of the valve 
position (0 to 100%) or in terms of flow capacity (0 to 1000 MCF/Day). 

 Set the Output type on the PID screen to Discrete. Under DO Open 
Point and DO Close Point, select a TLP with Point Type of Discrete 
Outputs, the desired logical number, and EU Value parameter. 

 Configure the PID point with a Control Type of Override Control. This 
causes available fields to appear on the PID screen to enter the I/O 
definition of the process variable and setpoint for both the Primary and 
Override loops. Select a TLP with Point Type of Orifice Meter Run 
Values, the desired Logical Number, and a parameter of Flow Rate Per 
Day for the Primary process variable. For the Override process 
variable, select a TLP with Point Type of MVS, the desired Logical 
Number, and a parameter of SP Reading. Leave the Setpoint I/O 
Definition undefined, because you enter the values. The setpoint for the 
Primary loop is the desired amount of flow per day. The setpoint for the 
Override loop is the pressure value where control should switch to the 
override loop. Set the Loop Period in seconds, typically one-fourth of 
the time required for the actuator to move the valve from fully open to 
fully closed.  

 On the Tuning tab, select the Override Type Select of Low. This selects 
the lower of the change in outputs from the primary and secondary 
loops. As the pressure approaches the Override setpoint, the pressure 
(Override) loop pinches back the output. At the point that the pressure 
loop requests an output change less than the flow (primary) loop, the 
output from the pressure loop is selected and controls the valve. Set the 
Scale Factor for each of the Primary and Override loops as (span of 
output)/(span of input).  

Both loops have scale factors, which permit the control action to close the 
valve when the process variable is above the setpoint. With the scale factor 
set according to the above formula, the initial settings for gain, reset, and 
rate produce stable control (under most circumstances). Gain controls the 
magnitude of the initial change in output for a given change in the process 
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variable (or setpoint). Reset controls the magnitude of the change in output 
based on the continuing difference between the process variable and the 
setpoint over time. You can then adjust these values to produce the desired 
control actions. 

7.10 Configuring History Points 
The History options allow you to copy and store to the historical database 
(for up to 35 days) data values and calculated variables stored in the current 
value database. You then configure the historical database to log only the 
values that need to be logged. The system logs values in the standard 
(minute, hourly, daily) time base of the FloBoss, unless you use FST 
control. By using the FST Editor utility, the period in which the data is 
logged can be placed under FST program control. 

Note:  Configure the History Points for each meter run to allow the EFM 
Report utility to properly access data.  

Select Configure > History Points. The History Setup screen displays.  

 
Figure 7-49. History Setup 

Use this screen to define the History Points archived for any numeric 
parameter in the FloBoss and to select which archiving method the system 
uses for each parameter.  
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7.10.1 History Setup Setup Tab 
ROCLINK 800 saves history information to either of two databases, 
Standard and Extended History. Use the Setup tab to configure what 
information the system saves to which database. For that reason, we discuss 
the Setup tab before discussing the Standard History or Extended History 
tabs. 

History is one block of memory divided into two areas, one for standard 
history and one for extended history. Standard history uses all of the 
memory that it requires for the configured number of points. Extended 
history only receives the surplus memory not used by the standard history. 
Additionally, you can configure (within boundaries) the number of 
entries/logs available to Standard and Extended History.  

You can select the number of history points to archive, the number of 
points, the number of days to archive, and whether history data logs at the 
beginning of the period or the end of the period. 

Note:  When you make changes on the Setup tab ROCLINK 800 
automatically performs a Cold Start & Clear History when you 
click Apply. The system displays a dialog box to remind you of 
this. To avoid losing data, save any changes you make on the Setup 
tab before you proceed to any other tab on the History Setup screen.  

1. Select the Setup tab on the History Setup screen. The Setup screen 
displays.   

 
Figure 7-50. History Setup, Setup tab 
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2. Review the following fields for your organization’s values.  

Note:  When you configure the number of Standard and Extended 
history points, specify enough points to meet both your 
immediate need and any foreseeable changes. Changing the 
number of points later requires you to run Cold Start & Clear 
History. If you must change the number of points, make a back-
up of the history log before you make any changes.   

Field Description 
Standard History 
Number of Points 

Sets the number of Standard History points the 
system uses.  You can define up to 100 points; the 
default is 30. Although the first eight Standard 
History Points are pre-configured, you can change 
them.  
The Standard History database logs entries for each 
point at three intervals: minute, hour, day.  
Additionally, at contract hour every day the database 
logs a min/max entry. The min/max values are from 
today and yesterday; the minute values are from the 
last 60 minutes, the hourly values are from the last 
35 hours, and the daily values are from the last 35 or 
60 days.  

Extended History 
Number of Points 

Sets the number of Extended History points the 
system uses. You can define up to 25 points; the 
default is 5. 
Extended History archiving provides a monitoring 
resolution that is similar to a chart recorder. The 
default interval for Extended History is 10 minutes.  
Note:  If you are replacing a chart recorder, select a 

10 minute interval for 4 points. 

The Extended History database creates one entry for 
each point at the user-specified interval.  
Use the Sample Interval field to determine how 
frequently samples occur, to a maximum of 25 points 
of user-selectable minute or second values from the 
last 35 or 60 days.  
The system can maintain a maximum of 10080 
Extended History log entries. 
The maximum number of days depends on the 
Sample Interval.Use the Daily History Size field to 
select the number of days to archive (35 or 60). Use 
the History Time Stamp field to determine whether 
history data logs at the beginning or the end of the 
period.  
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Field Description 
Sample Interval Sets how frequently the system samples for 

Extended History data. The intervals are 1, 2, 3, 4, 5, 
10, 12, 15, 20, 30, and 60 in either minutes or 
seconds. The default is every 10 minutes.  
Note:  The more frequent the sample, the fewer days 

of history are available. If you sample every 
60 minutes with 10080 maximum log entries, 
you have 420 days. But if you sample each 
second with 10080 maximum log entries, you 
have 10080 seconds or 0.117 days. 

Number of Entries This read-only field shows how many Standard and 
Extended History points you have defined.  The 
value dynamically changes as you change the 
number of history points. The maximum number of 
entries is 10080.  

Number of Days This read-only field shows the number of days of 
Standard and Extended History the system can 
maintain, based on your current settings.   

Daily History Size Sets the number of days Standard History can hold 
up to 100 points of user-selectable data. Valid values 
are 35 or 60 days; the default is 35 days.  

History Time Stamp Sets whether the system logs (“stamps”) history data 
from the beginning of a period or from the end of the 
period. This option affects both Standard and 
Extended History values.  
For example, if you select At End of Period, the 
system time-stamps data it collects from 8:00 to 9:00 
as 9:00.  

 

3. Click Apply if you change any parameters on this screen. 

Note:  If you make changes on the Setup tab you must run Cold Start & 
Clear History on the ROC Flags screen (ROC > Flags). The 
system displays dialog boxes to walk you through the process. To 
avoid losing data, save any changes you make on the Setup tab 
before you proceed to any other tab on the History Setup screen.  

4. Proceed to Section 7.10.2, History Setup Standard History Tab. 

7.10.2 History Setup Standard History Tab 
Use the Standard History tab to define up to 100 Standard History points.  

Note:  Use the Setup tab to define the total number of Standard History 
points. The first eight Standard History points are pre-defined for a 
EFM report on meter run #1, but can be reassigned to suit your 
application. Refer to Table 7-1.  

Select the Standard History tab. The Standard History screen displays.  
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Figure 7-51. AGA 3 History Setup, Standard History tab 

Table 7-1. EFM History Points (AGA 3) 

History Point 
Definition Point Type Logical Number Parameter Archive Type Archive Point

Flowing Minutes 
Today Meter Flow Values FLWNEW1 Minutes Today Totalize FLWNEW1, 

MINTDY 

Meter Input 
Differential 
Pressure  

Meter Configuration 
Parameters 

AGANEW1 - Meter 
#1 

hw|Uncorrected Flow 
Rate 

Average Flow 
Dependent Linear 

AGANEW1, 
CUR DP 

Meter Input 
Static Pressure  

Meter Configuration 
Parameters 

AGANEW1 - Meter 
#1 Pf - Static Pressure  Average Flow 

Dependent Linear 
AGANEW1, 
CUR SP 

Meter Input 
Temperature  

Meter Configuration 
Parameters 

AGANEW1 - Meter 
#1 Tf - Temperature Average Flow 

Dependent Linear 
AGANEW1, 
CUR TP 

IMV or BMV Meter Flow Values FLWNEW1 IMV | BMV Average Flow 
Dependent Linear 

FLWNEW1, 
IMV/BMV 

hwPf Pressure 
Extension Meter Flow Values FLWNEW1 hwPf - Pressure 

Extension 
Average Flow 
Dependent Linear 

FLWNEW1, 
HWPF 

Instantaneous 
Flow Meter Flow Values FLWNEW1 Flow Rate per Day Accumulate/Day FLWNEW1, 

FLOWDY 

Instantaneous 
Energy Meter Flow Values FLWNEW1 Energy Rate per Day Accumulate/Day FLWNEW1, 

ENGDAY 

 FLW stands for the flow calculation point type. 
 DP stands for differential pressure point type.  
 SP stands for static pressure point type.  
 TP stands for temperature point type.  
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Figure 7-52. AGA 7 History Setup, Standard History tab 

Table 7-2. EFM History Points (AGA 7) 

History Point 
Definition Point Type Logical Number Parameter Archive Type Archive Point

Flowing Minutes 
Today Meter Flow Values FLWNEW1 Minutes Today Totalize FLWNEW1, 

MINTDY 

Total Pulses Meter Flow Values AGANEW1 - Turbine
#1 Pulses Accumulated Totalize FLWNEW1, 

PULACC 

Meter Input 
Static Pressure  

Meter Configuration 
Parameters 

AGANEW1 - Turbine
#1 Pf - Static Pressure  Average Flow 

Dependent Linear 
AGANEW1, 
CUR SP 

Meter Input 
Temperature  

Meter Configuration 
Parameters 

AGANEW1 - Turbine
#1 Tf - Temperature Average Flow 

Dependent Linear 
AGANEW1, 
CUR TP 

IMV or BMV Meter Flow Values FLWNEW1 IMV | BMV Average Flow 
Dependent Linear 

FLWNEW1, 
IMV/BMV 

Uncorrected 
Pulses Meter Flow Values FLWNEW1 Uncorrected Today Totalize FLWNEW1, 

UCCTDY 

Instantaneous 
Flow Meter Flow Values FLWNEW1 Flow Rate per Day Accumulate/Day FLWNEW1, 

FLOWDY 

Instantaneous 
Energy Meter Flow Values FLWNEW1 Energy Rate per Day Accumulate/Day FLWNEW1, 

ENGDAY 

 FLW stands for the flow calculation point type. 
 SP stands for static pressure point type.  
 TP stands for temperature point type.  

 

You can configure the historical database to log only the values that you 
require. Unless you implement FST controls, the values log in the standard 
(minute-hourly-daily) time base of the FloBoss. By using the FST Editor 
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utility, you can place the period at which the data logs under FST program 
control.  

The FB107 maintains the following types of historical databases: 
 Minimum/Maximum (Min/Max) Database. 
 Minute Database. 
 Extended. 
 Hourly Database. 
 Daily Database. 
 The Min/Max Database is for viewing only and cannot be saved to a 

disk file.  
You can collect history values from the FB107 using ROCLINK 800 or 
other third-party host systems. Select View > History selection to directly 
view history from the device or from a previously saved disk file. 

Several options are available for the type of history values archived (listed 
under the Archive Type heading). Linear averaging is available for all 
parameters. Meter run parameters may be averaged using one of the four 
averaging techniques recommended in API Chapter 21, Section 1 (flow 
dependent linear, flow dependent formulaic, flow weighted linear, and flow 
weighted formulaic).  

You can accumulate (integrate) parameters that represent a rate 
(engineering units/time period) to give total values when you specify a time 
period for the rate. You can totalize parameters that represent an 
accumulated total by taking the difference between the value at the end of 
the current logging period and the value at the end of the previous logging 
period. Finally, you can log the current value of any parameter at the end of 
each logging period. 

Table 7-3 details various kinds of archive types on the Standard History 
screen. These archive types specify how the system calculates logged data.  

Table 7-3. Archive Types 

Archive Type Description  
Undefined Point not configured. 
Avg – Flow Dependant 
Linear 

Discards samples when there is no measurable flow and performs a 
straightforward (linear) average of the remaining samples to compute the 
minute and hour values. This is the default method for calculating the 
average for the flow input and is the simplest and most commonly used 
method.  
For differential meters with analog input values, no flow conditions are 
defined as the differential pressure meter input less than or equal to the 
Low Flow Cutoff.  
For pulse meters with a pulse input values, no flow conditions are 
defined as the no flow time elapsing without receiving a pulse. A linear 
average of all samples is performed if there is no flow during the logging 
period. 
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Archive Type Description  
Avg – Flow Dependant 
Formulaic 

Discards samples for periods when there is no flow (like the Flow-
Dependent Linear method), but when calculating the average, this 
method typically takes the square root of each sample before averaging 
the samples together and then squares the result. This formulaic method 
typically produces a slightly lower value than the linear method. 

Avg – Flow Weighted Linear Determines a relative “weight” for each sample (without discarding any 
samples) by first multiplying the sample by a flow value (square root of 
the differential pressure measured during the sample period) and then 
calculates a linear average by dividing the sum of the flow-weighted 
sample by the sum of the flow values. This results in minute and hourly 
values that are more reflective of short periods of high flow. 

Avg – Flow Weighted 
Formulaic 

Combines the flow-weighting action with the formulaic averaging 
technique, both of which were described previously. 

Avg – Linear Averages one-second samples to compute minute, periodic, and daily 
values. 

Accumulate/Second Sums one-second samples of a per second rate value over the logging 
interval to compute the archived value. Select this archive type when the 
History Point being archived is a rate in EUs/second. 

Accumulate/Minute Converts the one-second samples of a per minute rate value to a per 
second rate and sums them over the logging interval to compute the 
archived value.  
Select this archive type when the History Point being archived is a rate in 
EUs/minute. 

Accumulate/Hour Converts the one-second samples of a per hour rate value to a per 
second rate and sums them over the logging interval to compute the 
archived value.  
Select this archive type when the History Point being archived is a rate in 
EUs/hour. 

Accumulate/Day Converts the one-second samples of a per day rate value to a per second 
rate and sums them over the logging interval to compute the archived 
value.  
Select this archive type when the History Point being archived is a rate in 
EUs/day. 

Current Value Logs a snapshot of the current sampled value. 
Totalize Logs the difference between the current value at the end of the period 

and the current value at the last logging interval.  
Minimum Value Archives the minimum value read. 
Maximum Value Archives the maximum value read. 
FST Data Allocates space for the FST to write values to the periodic archive using 

the WDB command.  
Note:  The number of periodic entries in the segment determines the 

number of values that can be written. The FST determines which 
index in the periodic archive to write to independently of the 
segment’s current index.  

FST Time - Minute Allocates space for the FST to write time-stamps to the periodic archive 
using the WTM command.  
Note:  The number of periodic entries in the segment determines the 

number of time-stamps that can be written. The value takes the 
format MM:DD:HH:MM. The FST determines which index in the 
periodic archive to write to independently of the current index for 
the segment. 
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Archive Type Description  
FST Time - Second Allocates space for the FST to write time-stamps to the periodic archive 

using the WTM command.  
Note:  The number of periodic entries in the segment determines the 

number of time-stamps that can be written. The value takes the 
format DD:HH:MM:SS. The FST determines which index in the 
periodic archive to write to independently of the current index for 
the segment. 

 
Once you have determined what archive type to use, set the archive point 
by clicking the TLP button that displays at the right-hand side of each 
Archive Point field. This displays a Select TLP dialog box you use to 
configure the associated TLP.  

7.10.3 History Setup Extended History Tab 
Use the Extended History tab to define up to 30 additional values for the 
FB107 to record.    

Select the Extended History tab. The Extended History screen displays.  

 
Figure 7-53. History Setup, Extended History tab 

See Section 7.10.2, History Setup Standard History Tab for a description of 
the fields on this screen. 

7.10.4 Configuring History: An Example 
Following is a quick step-by-step example for configuring history.   

1. Verify that you are on-line with the FloBoss. 

2. Select Configure > History Points.  

3. Click the Setup tab. The Setup screen displays.  
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4. Enter the required number of Standard History Points.  

5. Enter the required number of Extended History Points.  

Note:  Specify enough Standard and Extended History Points to 
accommodate your present application and any foreseeable 
changes. Changing the number of points later initiates a Cold 
Start & Clear History. If you must change the number of 
points later, make a back-up of the history log before you make 
changes.  

6. Define the Sample Interval for the history points.  

7. Review the values displayed in the Number of Entries and Number of 
Days fields to determine whether they are adequate for your 
application. If not, adjust the number of defined history points and 
sampling interval.  

Note:  The Number of Entries and Number of Days fields 
dynamically adjust their values, depending on the total number 
of defined history points and the sampling interval.  

8. Click Apply. The system displays a dialog box reminding you that your 
changes require a Cold Start & Clear History.  

 
9. Click Yes to continue. The system performs a Cold Start and Clear 

History and displays a dialog box when complete:  

 
10. Click OK to continue.  

11. Click the Standard History tab. The Standard History screen displays. 

12. Select Archive Types and assign Archive Points, if you are configuring 
more than the eight pre-configured points.   

13. Click Apply. 

14. Select the Extended History tab. The Extended History screen 
displays.  

15. Assign Archive Types and Archive Points. 
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16. Click Apply.  

This completes the process of configuring history points.  

7.11 Opcode Table 
Use the Opcode table to group data being polled for more efficient 
communications. You can assign parameters from different point types to 
the opcode table data points, which can substantially reduce the number of 
polls from a host computer.  

Note:  Use of the term opcode in this context does not refer to the operator 
identification codes in ROC protocols. 

1. Select Configure > Opcode Table. The Opcode Table Settings screen 
displays.  

 
Figure 7-54. Opcode Table Settings 

2. Review the following fields for your organization’s values. 

Field Description 
Table No. Selects an opcode table.  You can define up to 8 

opcode tables.  
Version No. Associates a version number with the opcode table. 

By default, the version number (a floating point 
number) is one less than the number of the opcode 
table.  
Note:  If you change the configuration of data points, 

update the version number of the table.  
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Field Description 
Data Assigns a TLP value to each opcode data point.  

Click the TLP button to display a Select TLP dialog 
box. Use the dialog box to map TLP values into the 
opcode table data point. If a host computer asks for a 
specific opcode data point, the FloBoss returns the 
value that is referred by the mapped TLP.  

 

3. Click Apply if you change any parameters on this screen. 

7.12 Modbus Communications 
This section describes how to configure the FB107 to communicate using 
the Modbus protocol and integrate the FB107 and Modbus devices into the 
same host/slave system.  

Note:  A FloBoss can act as a Modbus slave device on LOI, COM1, 
COM2, and COM3, and as a Modbus host device on COM1, 
COM2, and COM3. 

In addition to a general configuration screen, you can use the options in this 
section to define Modbus registers, history, and the Modbus master/slave 
relationship.  

7.12.1 Modbus Configuration 
Use this option to set basic Modbus communication parameters. The 
General tab sets the basic communication parameters. The Scale Values tab 
allows you to enter eight low and high floating-point scale values with one 
low and high integer values for converting floating-point numbers to a 
scaled integer. Select Configure > Modbus > Configuration. The Modbus 
Configuration screen displays.  
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Figure 7-55. Modbus Configuration 

The Modbus Configuration screen has two tabs. Use each tab to configure a 
Modbus component.  

 Use the General tab to configure Modbus communication parameters.   

 Use the Scale Values tab to convert floating point numbers to scaled 
integers.   

Note:  After you configure a point and click Apply, click Flash Memory 
Save Configuration (on the ROC > Flags screen) to save the 
configuration to permanent memory in case you must perform a cold 
start.  

7.12.2 Modbus Configuration General Tab 
The Modbus Configuration screen initially displays the General tab.  Use 
this tab to configure basic Modbus communication parameters. 
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Figure 7-56. Modbus Configuration, General tab 

1. Review the following fields for your organization’s values.  

Note:  This screen initially displays with Local Port as the default comm 
port. The example screen uses the RS485 choice so that all the 
possible fields on this screen display.   

Field Description 
Comm Port Selects a comm port to configure. Click  to display 

all defined comm ports.  
Note:  This screen’s Master Mode frame does not 

display if you select either Local Port or LCD 
Port as a comm port option.  
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Field Description 
Comm Mode Sets the communications mode for the selected 

comm port. The Modbus protocol supports two 
modes of transmission, ASCII and RTU. RTU is the 
default.  
Note:  You must configure all devices in the same 

communications network with the same mode 
of transmission. Additionally, In either ASCII 
or RTU mode, the transmitting device places 
the Modbus message into a frame that has a 
known beginning and ending point. See Table 
7-4, Modbus Message Framing.   

 ASCII American Standard Code for 
Information Interchange mode 
represents each 8-bit byte of data as 
two ASCII characters that are the 
hexadecimal representation of the 
value.  This allows the messages to be 
read with the use of a dumb terminal, 
but uses twice as many characters as 
the RTU mode. Each character sent is 
composed of a start bit, 7 or 8 data bits, 
and one or two stop bits with Even, 
Odd, or No parity. ASCII mode uses 
Longitudinal Redundancy Checking 
(LRC) error checking. 

 RTU Remote Terminal Unit mode allows for 
greater character density and better 
data throughput than ASCII for the 
same baud rate.  Each message is 
transmitted in a continuous stream. 
Data is sent in 8-bit binary characters. 
RTU mode uses Cyclic Redundancy 
Check (CRC) error checking. By 
default, RTU is enabled.  

 

Table 7-4. Modbus Message Framing  
ASCII Message Framing 

Begin of Frame Address Function Data LRC Error Check End 
: 2 Characters 2 Characters N Characters 2 Characters CRLF 

 
RTU Message Framing 

Begin of Frame Address Function Data CRC Error Check End 
T1-T2-T3-T4 1 Byte 1 Byte N * 1 Byte 2 Bytes T1-T2-T3-T4 
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Field Description 
Byte Order Sets the order of data bytes in a transmission or 

requests, which can be reversed.  This only affects 
the Data field of a Modbus message and has no 
effect on the data bytes for Function Codes 01, 02, 
and 05. Valid values are Least Significant Byte 
First (places the Least Significant Byte first; this is 
the default value) and Most Significant Byte First 
(places the Most Significant Byte first).  

Exception Status This read-only field shows the error message for the 
last Modbus message received.  
Note: This field applies only in Slave mode. 

Event Logging Sets whether the system logs to the Event log all 
parameter changes made via Modbus. Valid values 
are Enabled (logs all events) or Disabled (does not 
log events). Enabled is the default.  

Start Polling Controls whether the system begins a Modbus 
Master polling sequence. The default is off. The 
system clears this field when the polling sequence 
completes.  
Note:  You must have previously selected Modbus 

Master as the port owner on the Comm Port 
screen (ROC > Comm Ports). The ROC 
begins polling at the value defined in the 
Starting Request field and proceeds through 
the entries in the table.  

Starting Request Sets a beginning value from which the Modbus 
Master polling sequence begins. This number 
corresponds to a line number on the Modbus Master 
Table associated with this comm port.  

Number of Requests Sets the total number of requests the Modbus Master 
makes for this polling sequence.  This value specifies 
the total number of lines in the Master tables on 
which to execute the polls. The default value 0 
prevents the polling from occurring.  
Note:  You can define up to three Modbus Master 

tables for this comm port. The tables are 
contiguous. If you indicate more requests that 
are on a single table, the system accesses the 
second or third table to complete the request. 
For more information, see Section 7.12.7, 
Modbus Master Table.  

Timeout Sets the amount of time, in seconds, that the Master 
(Host) waits to receive a valid message after the 
FloBoss sends a request to a device. 
Note:  Do not enter 0 (zero) in this field. 

Retries Sets the number of times (after the initial try) that the 
Master FloBoss attempts to establish 
communications with the specified device before 
reporting a timeout error. Valid values are between 0 
and 25; the default is 2.  
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Field Description 
Continuous Polling Indicates whether the system continually executes 

the Modbus Master polling sequence. Valid values 
are Enabled (polling occurs continually) or Disabled 
(polling occurs only as requested).  
Note:  Use the Request Delay field to schedule the 

continual polling.  
Request Delay Sets a delay time, in seconds, between polling 

request sequences. This field is valid only when you 
enable Continuous Polling. 
Note:  The system consideres each line in a Modbus 

Master Table as a request. 
 

2. Click Apply if you change any parameters on this screen.  

3. Proceed to Section 7.12.3, Modbus Configuration Scale Values Tab.  

7.12.3 Modbus Configuration Scale Values Tab 
Use the Scale Values tab to define eight low and high floating-point scale 
values, each with a low and high integer values, used to convert floating-
point numbers to a scaled integer.   

The system uses integer scale values and the float scale values in 
conjunction with one another whenever you use the Convert Code 1 
through 8. In older Modbus devices, the system exchanged data without 
applying scaling using raw A/D counts sent between devices.  

Scaling factors allow values to be exchanged between Modbus, emulating 
raw, unscaled values. For example, a 4 to 20 mA loop might have a raw 
A/D value in which 4 mA equaled 800 counts and 20 mA equaled 4095 
counts. At midrange (12 mA), the raw A/D count would be 2448. If this AI 
signal was representative of a 0 to 250 pound pressure, 4 mA would equal 
800 counts (or 0 PSIG), 20 mA would equal 4095 counts (or 250 PSIG), 
and midrange at 12 mA would equal 2448 counts (or 125 PSIG). 

Convert Codes 1 to 8 support both reads and writes.  

1. Select the Scale Values tab. The Scale Values screen displays.  
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Figure 7-57. Modbus Configuration, Scale Values tab 

2. Review the following fields for your organization’s values. 

Field Description 
Low Value and  
High Value  

Sets values the system uses to scale analog I/O to 
integer values with an implied decimal point.   
The Low Value represents the lowest integer value 
and the High Value represents the highest integer 
value used the scale the data.  
The High Value and Low Value fields are signed 
integers and can range from –32768 to 32767.  

Float Scale # Scales data in conjunction with the Low and High 
Integer Scale values. Provide high and low values for 
each float scale #.  
For host systems that do not accept floating-point 
numbers, you can specify eight sets of floating-point 
ranges for values. This allows the host to read and 
set floating-point values (such as PID setpoints, 
softpoint values, and flow values) as integer values. 
The system converts floating-point values to integers 
by configuring a register or range of registers with 
the Conversion field set in the Modbus Registers 
definition configuration to a Convert Code from 1 to 
8. 
The system uses the following equations to convert 
floating point values to integers.  
Float Range = High Value Float Scale – Low Value 
Float Scale (for example, 100.0 = 120.0 – 20.0)  
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Field Description 
Integer Range = High Value Integer Scale – Low 
Value Integer Scale (for example, 6000 = 7000 – 
1000)  
Adjusted Reading = Float Reading – Low Value Float 
Scale (for example, 50.0 = 70.0 – 20.0)  
Integer = [(Integer Range x Adjusted Reading) ÷ 
Float Range] + Low Integer Scale (for example, 3500 
= [(6000 x 50.0) ÷ 100.0] + 1000)  
The system uses the following equations to convert 
integers to floating point values: 
Float Range = High Value Float Scale – Low Value 
Float Scale (for example, 100.0 = 120.0 – 20.0) 
Integer Range = High Value Integer Scale – Low 
Value Integer Scale (for example, 6000 = 7000 – 
1000) 
Adjusted Integer = Integer Sent – Low Value Integer 
Scale (for example, 3000 = 4000 – 1000) 
Float Value = [(Adjusted Integer x  Float Range) ÷ 
Integer Range] + Low Float Scale (for example, 70.0 
= [(3000 x 100) ÷ 6000] + 20) 

 

3. Click Apply if you change any parameters on this screen. 

4. Proceed to Section 7.12.4, Modbus Registers.   

7.12.4 Modbus Registers 
Use Modbus Register tables to map Modbus registers to specific TLP 
numbers. You can map one line in the Modbus Register table to more than 
one register or TLP pair by using either Point Indexing or Parameter 
Indexing.  
 Point Indexing maps the starting register to the selected TLP. 

Subsequent registers (through the ending register) map to the same 
point type and parameter and increment the point logical number.  

 Parameter Indexing maps the starting register to the selected TLP. 
Subsequent registers, (through the ending register) map to the same 
point type and point logical number and increment the parameter 
number.  

 
Point Indexing 

Example 
When using Point Indexing the configuration of  

 Starting 
Register 

Ending 
Register 

Device 
Parameter(s) Indexing Conversion 

 100 103 AIN, 4-1, EU Point 0 

specifies four registers (100, 101, 102, and 103) that are mapped to a group 
of analog input (AIN) values in engineering units (EU) starting at the 
analog input in the fourth module location, first position (4-1):   
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 Register 100 = EU of AIN point in location 4-1. 
 Register 101 = EU of AIN point in location 4-2. 
 Register 102 = EU of AIN point in location 4-3. 
 Register 103 = EU of AIN point in location 4-4. 

 
Parameter Indexing 

Example 
When using Parameter Indexing the configuration of  

 Starting 
Register 

Ending 
Register 

Device 
Parameter(s) Indexing Conversion 

 109 114 FST 1, R1 Parameter 1 

specifies six registers (109, 110, 111, 112, 113, and 114) that are mapped to 
a group of FST 1 parameters starting at FST Register 1:   
 
 Register 109 = Register 1 of FST Point Number 1. 
 Register 110 = Register 2 of FST Point Number 1. 
 Register 111 = Register 3 of FST Point Number 1. 
 Register 112 = Register 4 of FST Point Number 1. 
 Register 113 = Register 5 of FST Point Number 1. 
 Register 114 = Register 6 of FST Point Number 1.  

 
Use conversion code 1 (Float to Integer, Float Scale 1) to convert the 
floating point value to an integer before the response message returns to the 
host. Once you map a register, you can reference it in any Modbus request, 
providing the data type of the TLP is appropriate for the Function Code.  

Note:  If the native FloBoss data type does not meet the requirements of the 
Modbus host device, conversion codes are available to convert the 
data to the required data type. Refer to Section 7.12.6, Modbus 
Conversion Codes. 

When a device receives a Modbus request, it searches for the referenced 
register(s). If it finds a register number match, it builds a response based on 
the device point type and parameter configured in the table. If the device 
cannot find a register number match, it returns an error message.  

1. Select Configure > MODBUS > Registers. The Modbus Registers 
screen displays.   
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Figure 7-58. Modbus Registers 

2. Review the following fields for your organization’s values. 

Field Description 
Table Selects a table to which you map regsters.  You can 

define up to 12 register tables for an FB107.  
Each table entry can define multiple registers by 
using either Point Indexing or Parameter Indexing. 
By making the registers continuous (when the Start 
Register address of a new line is one greater than 
the End Register address of the previous line) you 
can create a continuous data table for Modbus 
Function Codes 3, 4, or 16 (see Table 7-5) up to the 
limit of 240 bytes per request. This type of data table 
allows access to all its data with one request.  
Map Periodic (Hourly) or Daily History Index registers 
to the TLP for the Periodic Index (Point Type 124, 
Parameter 5) or Daily Index (Point Type 124, 
Parameter 6).  

Table 7-52. Modbus Function Codes 

Code Meaning Action 
01 Read Logic Coil Status Obtain current status (ON/OFF) of a group of logic coils (outputs). 

02 Read discrete input status Obtain current status (ON/OFF) of a group of discrete inputs. 

03 Read Output Registers (Holding) Obtain current binary value in one or more holding registers. 

04 Read Input Registers Obtain current binary value in one or more input registers. 

05 Force Single Logic Coil Force logic coil to a state of ON or OFF. Acknowledge Alarm or 
Event request. 

06 Preset Single Holding Register Place a specific binary value into a holding register. 
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Code Meaning Action 

15 Force Multiple Logic Coils Force a series of consecutive logic output coils to defined ON or 
OFF states. 

16 Preset Multiple Holding Registers Place specific binary values into a series of consecutive holding 
registers. 

 

Field Description 
Tag Sets a 10-character alphanumeric identifier for this 

table. 
Start Register Sets the first data register in the address span.   

Any number from 0 to 65535 is valid. You can 
duplicate register numbers as long as you assign 
them to separate communication ports. Number The 
tables should be numbered from smallest to largest. 
In certain Modbus Host devices, the register 40101 is 
actually transmitted as “100.” The value “100” should 
be placed in the Start Address field because the 
FloBoss uses the actual number sent by the Host. 
For example, the Host device requests the Starting 
Register 500 through Ending Register 700. The 
Starting Register is 400 and the Ending Register is 
700. All register numbers requested by the Host (500 
through 700) are valid and would be responded to 
because the requested register numbers match or 
fall in between the Start Register and Ending 
Register numbers (400 through 700). 

End Register Sets the last register in the address span.  Compute 
the value for this field by adding the total number of 
registers used to the Start Register number and 
subtracting 1.  

Device Parameter Defines the parameter of the point types to set or  to 
acquire. Be aware of the different data types 
(Character, Integer, Long, Float) and the size of the 
data types. Use the TLP button to select parameters. 
This field indicates the type of data associated with 
an address (defined by the Start Register through the 
End Register). When the host requests a valid range 
of register numbers, the function code tells the slave 
what to do and between which registers (Start 
Register through End Register).  
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Field Description 
Indexing Sets a block of register values as successive Logical 

Point Numbers or Parameters without having to 
define each separately. Valid values are Point 
Indexing or Parameter Indexing. 
Point Indexing maps the Start Register to the 
selected Device Parameter. Subsequent registers, 
through the End Register, are mapped to the same 
Point Type and Parameter and increment the point 
Logical Number.  
Parameter Indexing maps the Start Register to the 
selected Device Parameter. Subsequent registers, 
through the End Register, are mapped to the same 
Point Type and point Logical Number, and increment 
the Parameter Number. 

Conversion Sets the type of conversion performed (if any) , on 
data before it is either sent to the Host or written to 
the FloBoss device. The conversions are used to 
allow for differences in data types between the 
Master and Slave devices. Conversion Codes affect 
Function Codes 3, 4, 6, 8, and 16.  

Comm Port This read-only field shows the comm ports affected 
by the register.  

 

3. Click Apply if you change any parameters on this screen.  

4. Proceed to Section 7.12.5, Modbus History Table.  

7.12.5 Modbus History Table 
Use the Modbus History Table to configure the Hourly and Daily history 
values, event records, and alarm records for retrieval using function code 
03 of the Modbus protocol.  

To simplify setup, ROCLINK 800 predefines several registers, which you 
can reconfigure to your organization’s requirements:  

 Daily Index = Register 7160  
 Hourly Index = Register 7161  
 Extended Index = Register 7162 
 Events/Alarms = Register 32 
 Current Date = Register 7046  
 Current Time = Register 7047  
 Hourly Data = Register 703 
 Daily Data = Register 704 

You may also configure the Hourly and Daily registers for up to ten groups 
of history points. The Current Date and Current Time values may be useful 
when you need the date and time as floating point numbers in the formats, 
respectively, of DDMMYY and HHMM. 
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Note:  Before you configure the Modbus History, complete the History 
Setup screen (Configure > History Points). 

1. Select Configure > MODBUS > History. The Modbus History Table 
screen displays.  

 
Figure 7-59. Modbus History Table 

2. Review the following fields for your organization’s values. 

Field Description 
Daily Index Sets the register number to acquire daily index 

values.  The default is 7160. 
Hourly Index Sets the register number to acquire hourly index 

values.  The default is 7161. 
Extended Index Sets the register number to acquire extended history 

values.  The default is 7162.  
Events/Alarms Sets the register number to acquire the most current 

event and alarm log entry.  The default is 32.  
Current Date Sets the register number to acquire the current date.  

The default is 7046.  
Current Time Sets the register number to acquire the current time.  

The default is 7047.  
EFM Modbus Sets whether the system uses the RAS EFM Modbus 

reporting option for date and time.  Valid values are 
Enabled (use the EFM Modbus option) or Disabled 
(use standard Modbus reporting). The default is 
Enabled.  
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Table 7-6. Modbus History, Event, and Alarm Functionality 

Function 
Code Register Field Data Field Description 

03 32 – Event/Alarm 
Register 

Ignored1 Response contains Event and Alarm records2. Maximum 
number of bytes returned is 240 (12 records of 20 bytes 
each). Events are returned before Alarms are returned. 
The format is displayed in Table 7-12, Modbus Events and 
Alarms Log Contents. 

05 32 – Event/Alarm 
Register 

Ignored After Events and Alarms have been returned, there must 
be an acknowledgment made so that the same Events and 
Alarms are not returned on the next request. 

03 703 – Daily 
History 

Daily History 
Archive Register 
Index (0 to 34) 

Response contains two floating point values for the time 
and date stamp of the history archive (time stamp = 
HHMMSS and date stamp = MMDDYY) and floating point 
values for each of the defined History Points for that 
History Archive Register. 

03 704 – Hourly 
History 
 

Hourly or Periodic 
History Archive 
Register Index (0 
to 839) 
 

Response contains two floating point values for the time 
and date stamp of the history archive (time stamp = 
HHMMSS and date stamp = MMDDYY) and floating point 
values for each of the defined History Points for that 
History Archive Register. 

03 X – Extended 
History 
 

Extended History 
Archive Register 
Index (0 to Max) 
 

Response contains two floating point values for the time 
and date stamp of the history archive (time stamp = 
HHMMSS and date stamp = MMDDYY) and floating point 
values for each of the defined History Points for that 
History Archive Register.  

1. The Hourly (periodic) Index, Daily Index, Event, and Alarm Log data fields are used to address a history index number. 

2. The Event and Alarm Log record consists of the bytes shown in Table 7-12, Modbus Events and Alarms Log Contents. Table 
7-13, Event & Alarm Change Bit Map Contents breaks down the bit map in bytes 1-2. 

 

Field Description 
Register Number Sets the register number to acquire the group of 

history points defined by the values in the Starting 
History Points and Ending History Points fields.   

Starting History 
Point 

Sets the starting history point (first retrieved history 
point) for a group of points, as defined in the Register 
Number field.  You must complete both this field and 
the Ending History Points field, and the value in the 
Ending History Points field must be different and 
larger than this value.  

Ending History Point Sets the ending history point (last retrieved history 
point) for a group of points, as defined in the Register 
Number field.  You must complete both this field and 
the Starting History Points field, and the value in the 
Starting History Points field must be different and 
smaller than this value.  

Archive Type Sets the type of history returned from the Modbus 
request. Select Hourly or Daily to return Standard 
History Points; select Extended to return Extended 
History Points.  
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Field Description 
Conversion Sets the type of data conversion required (if any) 

before the data returns to the host or is written to the 
FloBoss.  Conversions allow floating point values to 
be transmitted or received as integer values. Refer to 
Section 7.12.6, Modbus Conversion Codes.   

 

3. Click Apply if you change any parameters on this screen. 

4. Proceed to Section 7.12.6, Modbus Conversion Codes.  

7.12.6 Modbus Conversion Codes 
Modbus conversion codes convert data into a format that is compatible to a 
Modbus device.  

Use the Conversion field (located on either the Modbus Registers or 
Modbus History screen) to specify the type of conversion required, if any, 
on the data before it is either sent to the Host or written to the FloBoss 
device. Conversions account for differences in data types between the 
master and slave devices.  

Conversion codes 65 to 72 allow a 4-byte IEEE formatted floating-point 
number to be sent or received in two Modbus registers with the byte orders 
configurable. A check is made to ensure that an even number of registers is 
requested, that the Start Register number does not begin in the middle of a 
register pair, and that the number of registers does not exceed the number 
of registers configured. 

Table 7-7. Modbus Convert Codes 

Convert 
Code Description Slave 

Function Definition 

0 No Conversion N/A N/A 
1 Float to integer, 

Float Scale 1 
3,4 

2 Float to integer, 
Float Scale 2 

3,4 

3 Float to integer, 
Float Scale 3 

3,4 

4 Float to integer, 
Float Scale 4 

3,4 

5 Float to integer, 
Float Scale 5 

3,4 

6 Float to integer, 
Float Scale 6 

3,4 

7 Float to integer, 
Float Scale 7 

3,4 

8 Float to integer, 
Float Scale 8 

3,4 

The Float to Integer conversion changes FloBoss floating point 
data to an integer for transmission to the Host. The number of the 
Convert Code specifies which floating point scaling value is to be 
used for the conversion. 
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Convert 
Code Description Slave 

Function Definition 

25 Any type to Float, 
No Scaling 

3,4,6,16 

26 Any type to Signed 
Short Integer 

3,4,6,16 

27 Any type to Signed 
Long Integer 

3,4,6,16 

28 Any type to 
Unsigned Short 
Integer 

3,4,6,16 

29 Any type to 
Unsigned Long 
Integer 

3,4,6,16 

When using Function Code 03 or 04, this conversion changes any 
data type (unsigned or signed Character, Integer, or Long) in the 
ROC to a specific point value for transmission to the Host. When 
using Function Code 6 or 16, this conversion changes a 
transmitted floating point value to the correct data type for the ROC
TLP. 

30 to 32 No Conversion N/A N/A 
65 IEEE Floating Point 

Number 
3,4,16 

66 IEEE Floating Point 
Number 

3,4,16 

Code 65 places byte 0 and byte 1 in register xxxxx; byte 2 and byte 
3 are placed in register xxxxx + 1. This places a 4-byte floating 
point value into two, 2-byte registers to allow integer values to be 
transmitted. Code 66 does the same as Code 65 regardless of the 
Byte Order field in the Modbus Configuration screen. 
Register xxxxx byte 0, byte 1 
Register xxxxx + 1 byte 2, byte 3 

67 IEEE Floating Point 
Number 

3,4,16 

68 IEEE Floating Point 
Number 

3,4,16 

Code 67 reverses byte 0 and byte 1 order in register xxxxx; 
reverses byte 2 and byte 3 order in register xxxxx + 1. This places 
a 4-byte floating point value into two, 2-byte registers to allow 
integer values to be transmitted. Code 68 does the same as Code 
67 regardless of the Byte Order field in the Modbus Configuration 
screen. 
Register xxxxx byte 1, byte 0 
Register xxxxx + 1 byte 3, byte 2 

71 IEEE Floating Point 
Number 

3,4,16 

72 IEEE Floating Point 
Number 

3,4,16 

Code 71 reverses byte 2 and byte 3 order in register xxxxx; 
reverses byte 0 and byte 1 order in register xxxxx + 1. This places 
a 4-byte floating point value into two, 2-byte registers to allow 
integer values to be transmitted. Code 72 does the same as Code 
71 regardless of the Byte Order field in the Modbus Configuration 
screen. 
Register xxxxx byte 3, byte 2 
Register xxxxx + 1 byte 1, byte 0 

73 IEEE Floating Point 
Number 

3,4.6,16 

74 IEEE Floating Point 
Number 

3,4,6,16 

FloBoss 103/104 Only. Convert Codes 73 and 74 send the IEEE 
formatted floating point number as four bytes with a single register 
request. Only the byte order is changed: Function Code 73 loads 
register xxxxx in byte 2, byte 3, byte 0, byte 1 order. Function Code 
74 does the same as Function Code 73 regardless of the Byte 
Order field in the Modbus Configuration screen. 

75 to 255 No Conversion N/A N/A 
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7.12.7 Modbus Master Table 
The Modbus Master mode of operation allows a FloBoss to simulate a 
master device that can poll other devices for data and to store that data 
within the ROC in any valid TLP.  The FloBoss can also send commands to 
set outputs and write data to a slave device. 

Note:  You can configure the Modbus Master functionality on COM1, 
COM2, and COM3.  

Each command can transmit or receive up to 240 bytes of data. ROCLINK 
800 supports Modbus function codes 1, 2, 3, 4, 5, 6, 15, and 16. Function 
codes 1 to 4 request data from slaves, while function codes 5, 6, 15, and 16 
transmit data to a slave device. 

Each master request you configure uses data read from or written to 
registers defined in the Modbus Registers table. When using Modbus 
function codes 1 to 4, the FloBoss reads data from a slave device and writes 
it to the TLP specified in the Modbus Registers table. When using Modbus 
function codes 5, 6, 15, and 16, the FloBoss reads data from the TLP 
specified in the Modbus Registers table and writes it to the slave device. 

You can use an FST or User C program to schedule Modbus master 
requests. Enable the comm port on the Comm Port screen (ROC > Comm 
Ports). Set the Start Polling option on the Modbus Configuration screen 
(Configure > Modus > Configuration) if continuous polling is desired. 
Alternately, you can manage, enable, or disable master polling using a 
control application. Using FSTs, the FloBoss can dial other Modbus slave 
devices at regular intervals. 

1. Select Configure > MODBUS > Master Table. The Modbus Master 
Table screen displays.  
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Figure 7-60. Modbus Master Table 

2. Review the following fields for your organization’s values.  

Field Description 
Logical Point Sets the logical point for the communication port.  

Note: You can define up to three logical points for 
Modbus master and slave functionality on 
COM1, COM2, and COM3. 

Tag Sets a 10-character alphanumeric identifier for the 
master table.  

RTU Address Sets the RTU address for the slave device to be 
queried.   

Function Code Sets the Modbus function code to be sent to the 
slave device.  Click  at the right edge of this field to 
display all valid function codes.  

Slave Register Sets the starting register number from which data is 
drawn from the slave device.   

Master Register Sets the starting register number into which data is 
stored on the master device.   

Number of Registers Sets the total number of registers to poll.   
Comm Status This read-only field shows the status of the query. 

See Table 7-8. 

Table 7-8. Status of Host Request or Command 

Status Description 
0 Inactive or start of transmission 
1 Receive timeout error 
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Status Description 
2 Received Address check 
3 Received Function Number check 
4 Number of expected bytes check 
5 Receiving Slave response 
6 CRC or LRC check 
7 CRC or LRC check 
8 Valid Slave response 

128 Write Device Data error 
129 Access Device Data error 
130 Host Function Table error 
131 Transmit Timeout error 
144 Transmit or Receive buffer overflow 
145 Invalid Function Number in request 

 

3. Click Apply if you change any parameters on this screen.  

4. Proceed to Section 7.12.8, Modbus Events and Alarms.   

7.12.8 Modbus Events and Alarms 
To view the Modbus Event Log and Alarm Log, select Configure > 
Modbus > History.  

The record formats for the event log and alarm log are the same size and 
have similar contents. The first word in a record is a bit map in which bit 9 
indicates if the log record is an event (1) or an alarm (0). The meanings of 
the other bits are specific to either the event or the alarm log records. Refer 
to Table 7-13. Event & Alarm Change Bit Map Contents. 

The FB107 supports Modbus using the EFM extensions method for 
retrieving alarms and events. When the FB107 receives a Function Code 03 
request referencing the defined Events and Alarms Register (usually 32), 
the FB107 begins to collect records, first from the event log and then from 
the alarm log, starting where the last poll left off. The FB107 collects 
records until either there are no more new events and alarms or the it 
collects the maximum of 12 records. The FB107 sends the information 
back to the host, which in return replies with Function Code 05, referencing 
the same Events and Alarms Register, indicating that the points have been 
received and that the host is ready for the next 12 records. 

The following paragraphs detail how ROCLINK 800 places event log and 
alarms log information in Modbus event and alarm messages and how (or 
what) is generated upon the event or alarm condition. 
Normal Event Record 
Following is a normal event record format:  
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System Text Events 
When you set the System Command Change Bit (bit 7) in the Operator 
Change Bit Map of the event, it sets the register number for all System 
Command Change events to the Event/Alarm Register number (default is 
32). 

 
ROCLINK 800 uses this format for the following event codes: 
 144 Initialization Sequence 
 146 Initialize From Defaults 
 147 ROM CRC Error 
 148 Database Initialization 
 150 Program Flash 
 248 Text Message 
 249 Download Configuration 
 250 Upload Configuration 
 251 Calibration Timeout 
 252 Calibration Cancel 
 253 Calibration Success 

FST Events 
For FST Events, the code is the FST number (1 to 6). Unused is set to zero. 

 
Time Related System Events  
Time represents the number of seconds since January 1, 1970. Unused is 
set to zero. 

 
Events are formatted as: 
 145 All Power Removed 
 200 Clock Set 

Alarms 
Use the Alarms table to determine the alarming source. The Register 
number for all unmapped Alarms is set to the Event/Alarm Register number 
(default is 32). 

Following is a normal alarm record format: 
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Unmapped Parameter Alarms 
If the alarming point is not mapped to a Modbus Register, identify the point 
using the following table. The TLP is the source TLP of the alarm. The 
type is set to 1. 

 
FST Alarms 
If the Alarm is an FST Alarm, ROCLINK 800 uses the following format. 
The FST Number is the source FST Number that generated the alarm. 
Unused is set to zero and the type is set to 2. 

 
User Text Alarms 
If the Alarm is a User Text Alarm, the following format will be used. Text 
is filled in with seven bytes of User Text and the Type will be set to 3. 

 
User Value Alarms 
If the alarm is a User Value Alarm it uses the following format. Unused is 
set to zero and the Type is set to 4. 

 
Reading Events and 

Alarms Register 
The Modbus request to read the Event Log and Alarm Log uses the 
standard read Function Codes 03 or 04 and the Register Number defined 
in the History Access configuration. In this request, the number of registers
is included to maintain format compatibility, but is ignored by 
the receiving FloBoss. 

Twenty bytes are returned for each event and alarm in the response. Up to 
12 events and alarms can be returned in a single response. If no events and 
alarms have occurred since the last collection, the response contains zero 
(0) data bytes. 

For the date stamp in the events and alarms returned, the year (YY) is really 
the number of years since 1980. For example, if the current year is 2007, 
the year (YY) for the date stamp would be 27. 

Following is an example of a request for events and alarms with the history 
access event/alarm register defined as 32 (0x0020 hex). 
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Table 7-9. Host Event/Alarm Request Example Message 

Message Field Device Address Function Code Register Offset Num Reads 
(ignored) Error Check 

Bytes 1 1 2 2 2 

TX Order   MS LS MS LS LS MS 

Value 01H 03H 00H 20H 00H 01H CRC-16 

The following example shows a response returning three events and alarms.  

Table 7-10. Event/Alarm Response Example Message 

Message 
Field 

Device 
Address 

Function  
Code 

Byte 
Count Data Error Check 

Bytes 1 1 1 (20 bytes per event or alarm) 2 

Integers — MS LS LS MS TX Order    

Floats — Selectable 

Value 01H 03H 3CH  CRC-16 

 

Acknowledging  
Events and Alarms 

After the host has correctly received event and alarm data, it transmits 
an acknowledgement message to the ROC to clear these events and 
alarms from the Modbus buffer.   

Until acknowledged, the ROC continues to send the same event and alarm 
records to the host. The Modbus acknowledgement (to clear the Event Log 
and Alarm Log buffer) uses Function Code 05 and the Register Number 
defined in the History Access configuration. In this request the data value is 
always one (1). 

Table 7-11. Event and Alarm Acknowledgement Response Example Message 

Message 
Field 

Device 
Address 

Function 
Code Register Data Error 

Check 
Bytes 1 1 2 2 2 

TX Order   MS LS MS LS MS LS 

Value 01H 05H 00H 20H FFH 00H CRC-16 

Table 7-12. Modbus Events and Alarms Log Contents 

Byte Contents of Event Log Record Contents of Alarm Log Record 
1 to 2 Operator change (Event Log) bit map (16-bit 

integer) – Refer to Table 7-13. Event & Alarm 
Change Bit Map Contents.  

Alarm change bit map (16-bit integer) – Refer to 
Table 7-13. Event & Alarm Change Bit Map 
Contents. 

3 to 4 Modbus Register number of variable (16-bit 
integer) 

Modbus Register number of variable (16-bit integer)

5 to 8 Time Stamp (HHMMSS; 32-bit floating point) Time Stamp (HHMMSS; 32-bit floating point) 
9 to 12 Date Stamp (MMDDYY; 32-bit floating point) Date Stamp (MMDDYY; 32-bit floating point) 
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Byte Contents of Event Log Record Contents of Alarm Log Record 
13 to 16 Previous value of variable (32-bit floating point) Current (alarmed) value of variable (32-bit floating 

point) 
17 to 20 Current (New) value of variable (32-bit floating 

point) 
Unused at the current time (zero filled when 
transmitted to the Master) 

Table 7-13. Event & Alarm Change Bit Map Contents 

Bit Operator Change Bit Map Alarm Change Bit Map 
0 Fixed value – change to an EU value on an I/O point in Manual Mode Not Used 
1 Zero scale – change to the 0% Adjusted on an AO or AI Not Used 
2 Full scale – change to the 100% Adjusted on an AO or AI Not Used 
3 Operator entry work value – change to any parameter other than those 

described 
Not Used 

4 Boolean fixed bit – change to Status in DO or DI Not Used 
5 Fixed/variable flag – change to Manual Mode for an I/O point Manual Alarm 
6 Table entry change – change to Modbus Function Tables Status Change Alarm 
7 System command change – events logged by system (Power up) No Flow Alarm 
8 Not Used Point Fail Alarm 
9 Operator change (Event Log) identifier bit 0 for Alarm 

10 Low Low Limit – change to Low Low Alarm parameter Low Low Alarm 
11 Low Limit – change to Low Alarm parameter Low Alarm 
12 High Limit – change to High Alarm parameter High Alarm 
13 High High Limit – change to High High Alarm parameter High High Alarm 
14 Rate of Change Limit – change to Rate Alarm parameter Rate Alarm 
15 Not Used Set/Clear Alarm 

(1 = Set or 0 = Clear) 

7.13 LCD User List 

Note:  You can configure the LCD user lists, but you cannot display the 
LCD user lists without the optional FB107 LCD (“Touchpad”). For 
complete documentation on configuring and using the Touchpad, 
refer to the FloBoss™ 107 Flow Manager LCD Program User 
Manual, Form A6236.  

Use the Configure menu’s LCD User List option to configure displays on 
the optional Touchpad.  

The Touchpad has three operating modes: Standard, Basic List Mode 
(BLM), and Chart. Standard mode requires that you complete a log-on 
sequence to access user list information. BLM mode automatically scrolls 
through a display of up to 32 parameter values you define. Finally, Chart 
enables the Touchpad to serve as a dynamic, real-time chart recorder 
displaying a variety of history points you define.  
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7.13.1 LCD User List (Standard)  
You can define up to four user lists, which you can access after you log 
onto the Touchpad. Each user list provides easy access to up to 16 
parameter values (or a total of 64 parameters).  

To define the contents of each user list:   

1. Select Configure > LCD User List > Standard. The LCD User List 
screen displays.   

 
Figure 7-61. LCD User List 

2. Complete the following fields to define the contents of each user list.   

Field Description 
List No. Sets the number of the LCD User List you want to 

configure. Click  to display all defined lists. You can 
define up to four user lists.   

Title Sets a 10-character alphanumeric identifier for the 
user list.  

Scroll Time Indicates the number of seconds the Touchpad 
displays each parameter set before scrolling to the 
next parameter set. (Typically the Touchpad displays 
two parameters at a time.)  Valid values are 0 (do not 
scroll) to 255.  
Note:  If you set this value to 0, you must use the  

and  keys on the Touchpad to manually 
scroll through the parameters defined in the 
list.  
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Field Description 
Device Parameter  Sets the parameter that you want to display on the 

Touchpad. Click … to display a Select TLP screen 
you can use to define the parameter.  

Text Sets a 10-character alphanumeric identifier for the 
parameter.  

Units This read-only field shows the engineering units for 
the associated parameter.  

 

3. Click Update if you make any changes to this screen.   

4. Click OK to close the LCD User List screen.   

7.13.2 LCD User List – BLM  
In basic list mode (BLM), the Touchpad continually displays a series of up 
to 32 parameters you define. This enables service technicians to quickly 
review a dynamic display of current values without logging onto the 
Touchpad.  

To define the BLM display:   

1. Select Configure > LCD User List > BLM. The LCD User List - 
BLM screen displays.   

 
Figure 7-62. LCD User List - BLM 

2. Complete the following fields to define the first 16 parameters of the 
BLM list.   
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Field Description 
Title Sets a 10-character alphanumeric identifier for the 

list.  
Scroll Time Indicates the number of seconds the Touchpad 

displays each parameter set before scrolling to the 
next parameter set. (Typically the Touchpad displays 
two parameters at a time.)  Valid values are 0 (do not 
scroll) to 255.  
Note:  If you set this value to 0, you must use the  

and  keys on the Touchpad to manually 
scroll through the parameters defined in the 
list.  

Device Parameter  Sets the parameter that you want to display on the 
Touchpad. Click … to display a Select TLP screen 
you can use to define the parameter.  

Text Sets a 10-character alphanumeric identifier for the 
parameter.  

Units This read-only field shows the engineering units for 
the associated parameter.  

 

3. Click the 17-32 tab to define 16 additional parameters.  

4. Click Update if you make any changes to this screen.   

5. Click OK to close the LCD User List – BLM screen.  

7.13.3 LCD User List – Chart  
In Chart mode, the Touchpad functions as a chart recorder, displaying 
historical or dynamic values for up to 16 parameters you define. To access 
the chart function, you must first log onto the Touchpad.  

To define the chart display:   

1. Select Configure > LCD User List > Chart. The LCD User List -
Chart screen displays.   
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Figure 7-63. LCD User List - Chart 

2. Complete the following fields to define the chart display values.   

Field Description 
Data Source Sets the source for data included in the chart.  Valid 

values are:  
 Standard 

History 
Sets a standard history point to chart. 
Click … to open a Select History Point 
dialog box you can use to select a valid 
standard history point.  

 Extended 
History 

Sets an extended history point to chart. 
Click … to open a Select History Point 
dialog box you can use to select a valid 
extended history point.  

 Dynamic Sets a dynamic data point to chart. Click 
… to open a Select TLP dialog box you 
can use to select a valid TLP.  

Data Point  This read-only field shows the data point selected.  
Text  Sets a 10-character alphanumeric identifier for the 

data point.  
Units  This read-only field shows the engineering units for 

the associated parameter.  
Scaling  Indicates whether the system applies automatic or 

manual scaling factors to the charted results. Valid 
values are Auto (apply automatic values) or Manual 
(apply defined values).  

High Scale  Sets the high scaling value for the data point. 
Note:  This field is available only if you select Manual 

as a scaling option.  
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Field Description 
Low Scale  Sets the low scaling value for the data point. 

Note:  This field is available only if you select Manual 
as a scaling option.  

 

3. Click Update if you make any changes to this screen.   

4. Click OK to close the LCD User List – Chart screen.   
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Chapter 8 – The Meter Menu 

Use the Meter menu options to define, configure, and calibrate meter 
runs; review meter runs; and perform plate changes.   

 
Figure 8-1. Meter Menu 
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8.1 Configuring the Meter Setup 
Use Meter Setup to configure meter runs. The Meter configuration 
screens contain the functions directly associated with measuring and 
logging flow, including setup of American Gas Association (AGA), 
American Petroleum Institute (API), or International Standards 
Organization (ISO) calculation configuration parameters, and 
calibrating the meter depending on the device that you are configuring. 

The FloBoss 107 can support up to four pulse or differential meters. 
Table 8-1 shows the units of the flow parameters in Metric and US 
engineering units (EUs). 

Table 8-1. Meter Run Engineering Units (EU)  

Flow Parameter U.S. Units Metric Units 
Meter Input (AGA3, ISO5167) InH2O kPa  
Meter Input (AGA7) MCF/Day kM3/Day 
Static Pressure PSIG or PSIA kPaG or kPaA 
Temperature Deg F Deg C 
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Flow Parameter U.S. Units Metric Units 
Instantaneous Volume/Hour CF/Hour M3/Hour 
Instantaneous Volume/Day MCF/Day kM3/Day 
Instantaneous Energy/Hour BTU/Hour MJ/Hour 
Instantaneous Energy/Day MMBTU/Day GJ/Day 
Volume Flow Today/Yesterday MCF kM3 
Energy Today/Yesterday MMBTU GJ 
Viscosity Lbm/Ft-Sec Cp 
Diameters Inches Millimeters 
Elevation Feet Meters 
Inst Mass/Hour Lb/Hour Kg/Hour 
Inst Mass/Day Mlb/Day Tonnes/Day 
Mass Flow Today/Yesterday Mlb Tonnes 
Density Lb/Cf Kg/M3 
Heating Value BTU/CF or BTU/Lb MJ/M3 or MJ/Kg 

To configure the meter runs, select Meter > Setup. The Meter Setup 
screen displays:   

 
Figure 8-2. Meter Setup 

Note:  You can also access this screen by clicking an individual meter 
icon on the configuration tree.   

Configure the parameters on each tab as they relate to your application. 

 Use the General tab to set basic parameters for the meter.  
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 Use the Inputs tab to define the field inputs for differential pressure 
(AGA3, ISO 5167), uncorrected volume or mass (AGA7), static 
pressure, and temperature to be used in the flow calculation.  

 Use the Advanced tab to specify additional parameters for the 
meter. 

 Use the Fluid Properties tab to define the mole percentages for up 
to twenty gas components, as well as the Heating Value Basis, the 
Heating Value, and the Specific Gravity.  

 Use the Sampler tab to set up the discrete output (DO-2) of the 
FB107 to send a pulse output to another device, such as an odorizer, 
and control a gas sampler for a meter run.  

Note:  To use this feature, select Enabled under Sampler Control. 

 Use the Calibration Factors tab displays parameters that allow you 
to select and perform calculation of optional flow adjustment factor 
to compensate for the difference in condition between the meter 
location and the location where the calibration instruments were 
certified. 

 Use the Alarms tab to set alarm parameters for the meter.  

Note:  After you configure a meter and click Apply, click Flash 
Memory Save Configuration (on the ROC > Flags screen) to 
save the configuration to permanent memory in case you must 
perform a cold start.  

8.1.1 Meter Setup General Tab 
Use the General tab to define basic parameters for the meter.  The 
General tab displays when you first access the Meter Setup screen.  
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Figure 8-3. Meter Setup, General Tab 

1. Review the following fields for your organization’s values:  
Field Description 
Meter Number Selects the number of the meter to be configured.   

Note:  This selection in this field applies to each tab 
on this screen.  

Meter Tag  Sets a short (10 alphanumeric characters) identifier 
for the meter.  
Note:  This selection in this field applies to each tab 

on this screen. 
Meter Description Sets a unique description, up to 30 alphanumeric 

characters in length, that further identifies or provides 
information about this meter.  

Calculation Standard Sets the standard the system uses for flow 
calculations. Valid values are:  

 AGA3-92  AGA3 (1992) for orifice or 
differential metering.  

 AGA7-96  AGA7 (1996) for turbine, pulse, 
rotary, or other linear meters.  

 ISO5167-2003 ISO5167-2003 firmware calculates 
flow.  

 User C Flow 
Program 

User C program calculates flow. 

 Note:  The calculation of flow in a meter run depends 
on the type of FloBoss or ROC being 
configured.  
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Field Description 
Type of Units Sets the units for the meter that you are configuring.  

Valid values are Volume (volume metering device 
like a turbine meter) or Mass (Micro Motion Coriolis 
Mass Meter or similar mass meter).  

Flow Alarming Enables or disables flow alarming for the meter. 
If you enable alarms, use the Alarms tab to configure 
the alarms. If Enabled, alarms also log to the Alarm 
Log. If you disable alarms, no alarm generates for 
this meter, regardless of the alarm configuration. 
However, the system displays alarm conditions in the 
Active Flow Alarms field. 

Integral Multiplier 
Period 

Sets, in minutes, how frequently the system 
calculates the combined correctional factors known 
as the Integral Multiplier Value (IMV) (per the API 
measurement standard Chapter 21, Section 1) for 
the orifice flow equation.   
The default IMP is 15 minutes; it can be no more 
than 60 minutes in length and cannot be less than 1 
minute.  
The system calculates the Integral Value (IV) 
portion of the flow equation once per second. 
Note:  This option displays only if you select either 

AGA3-92 or ISO5167-2003 as the calculation 
standard.  

Base Multiplier 
Period 

Sets, in minutes, how frequently the system 
calculates the turbine calculations of the combined 
correctional factors, known as the Base Multiplier 
Value (BMV) (per the API measurement standard 
Chapter 21, Section 1) for the turbine flow equation.   
The default BMP is 15 minutes; it can be no more 
than 60 minutes in length and cannot be less than 1 
minute.  
Note:  This option displays only if you select AGA7-

97 as the calculation standard.  
The BMV is multiplied by the actual (uncorrected) 
volume to arrive at the quantity accumulated for the 
period.  
To determine if flow was occurring over the BMP, the 
system views the number of counts over the period. 
If there is an absence of counts or you have set the 
BMP shorter than the normal time it takes to get a 
pulse, the following occurs:  
 Meter run is defined in a No Flow condition. 
 Accumulated flow is stored as zero for historical 

data over that time period.  
 Accumulated Energy is stored as zero for 

historical data over that time period.  
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Field Description 
Averaging Technique Sets an averaging technique for the meter run.  Valid 

values are:  
 Flow 

Dependant 
Linear 

This is the simplest and most 
commonly used method.  This 
method discards samples for 
periods when there is no 
measurable flow, and performs a 
straightforward (linear) average of 
the remaining samples to compute 
the minute and hour values. The 
value specified in the Low Flow 
Cutoff of the Meter setup 
determines the values. When no 
flow occurs, all values are sampled. 

 Flow 
Dependant 
Formulaic 

This method discards samples for 
periods when there is no flow.  
However, in calculating the 
average, this method typically takes 
the square root of each sample 
before averaging the samples 
together, and then squares the 
result. This formulaic method 
produces a slightly lower value than 
the linear method. 

 Flow 
Weighted 
Linear 

This method does not discard any 
samples; instead, it "weights" each 
sample by multiplying it by a flow 
value (square root of the differential 
pressure measured during the 
sample period). Next, a linear 
average is calculated by dividing 
the sum of the flow-weighted 
sample by the sum of the flow 
values. This result includes minute 
and hourly values that are more 
reflective of short periods of high 
flow. 

 Flow 
Weighted 
Formulaic 

This method combines the flow-
weighting action with the formulaic 
averaging technique, both of which 
were described previously.  

Active Flow Alarms This display-only field shows any alarm currently 
active.  For example, Low indicates that the 
calculated flow is below the Low Alarm limit. Other 
alarms can include High, No Flow, and Manual 
Mode. 

 
2. Click Apply if you change any parameters on this screen.  
3. Proceed to Section 8.1.2, Meter Setup Inputs Tab.  
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8.1.2 Meter Setup Inputs Tab 
Use the Inputs tab to define the field inputs for differential pressure, 
uncorrected volume, static pressure, and temperature, which the system 
uses in the flow calculation. 

1. Select the Inputs tab. The Inputs screen displays.   

  
Figure 8-4. Meter Setup, Inputs tab (Orifice 

Meter) 
Figure 8-5. Meter Setup, Inputs tab (Turbine 

Meter) 

Note:  Which screen displays depends on the calculation standard you 
selected on the General tab. Select AGA3-92 or ISO5167-2003 
(orifice calculations) to display Figure 8-4. Select AGA7-92 
(turbine calculations) to display Figure 8-5.  

2. Review the following fields for your organization’s values.  
Field Description 
Differential Pressure Sets the input that senses the differential pressure 

(or high differential pressure, if you enabled Stacked 
DP).  Click … to display a Select TLP dialog box you 
use to assign the input. The system assumes the 
units for the input to be inches of water column (In 
H20) or kPa.  
If Manual appears, use the Values field to enter an 
engineering units value for the meter input. 
Otherwise, the Values field indicates the current 
input value.  
Note:  This field displays only for an orifice meter. 

Uncorrected Volume Sets the input that senses the input (typically pulses) 
from a turbine meter.  Click … to display a Select 
TLP dialog box you use to assign the input. The 
system assumes the units for the input to be MCF 
per day (1000 ft3/day) or 1000 cubic meters per day 
(kM3/day).  
If Manual appears, use the Values field to enter an 
engineering units value for the meter input. 
Otherwise, the Values field indicates the current 
input value, based on non-adjusted pulses from the 
turbine meter. 
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Field Description 
Note:  This field displays only for a turbine meter. 

Static Pressure Sets the input that senses static pressure. Click … to 
display a Select TLP dialog box you use to assign 
the input. The system assumes the units for the input 
to be PSIG/PSIA or kPaG/kPaA.  
If Manual appears, use the Values field to enter a 
engineering units value for the static pressure input. 
Otherwise, the Values field indicates the current 
input value.  

Temperature Sets the input that senses the temperature of the 
flowing gas. Click … to display a Select TLP dialog 
box you use to assign the input. The system 
assumes units for the input to be degrees Fahrenheit 
or degrees Celsius.  
If Manual appears, use the Values field to enter an 
engineering units value for the temperature input. 
Otherwise, the Values field indicates the current 
input value. 

Type of Primary 
Element 

Sets the element type associated with the orifice 
meter.  
Note:  This field displays only for an orifice meter. 

Pipe Diameter Sets the inside diameter for the pipe near the orifice 
plate in this meter run. The units are inches or 
millimeters. 
Note:  This field displays only for an orifice meter. 

Orifice Diameter Sets the diameter of the orifice plate in this meter 
run. The units are inches or millimeters.  
Note:  This field displays only for an orifice meter. 

Low Flow Cutoff Sets the low flow cutoff point. When the differential 
pressure value of the metering device is less than 
this value, the system sets the calculated flow rate to 
zero and, if alarming is enabled, records a No Flow 
alarm in the Alarm Log.   
For the AGA3-92 or ISO5167-2003 standard, this 
value is in terms of inches of water column or kPa. 
For the AGA7-96 standard, this value is in terms of 
MCF/day.  

Static K Factor Sets a K factor, expressed as counts/pulses per unit 
volume (such as 4 pulses per cubic foot or 235 
pulses/ft3), that the AGA7 calculations use for various 
low and high flow conditions, as received from a 
specified input.  The K Factor cannot be less than 
zero. The system assumes units for the input to be 
either in ft3 or m3. 
If you disable the Variable K Factor, the system uses 
the Static K Factor.  
Note:  This field displays only for a turbine meter. 
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Field Description 
Stacked DP Enables the use of standard differential pressure 

transmitters for low and high pressure ranges. Valid 
values are Enabled (use stacked DP transmitters) or 
Disabled (do not allow use of stacked DP 
transmitters).  
Note:  This field displays only for an orifice meter. 

Low DP Input Sets the input for monitoring low differential 
pressure.  Click … to display a Set TLP dialog box 
you use to assign the input.   
You must Enable the Stacked DP parameter must to 
use this input or you can leave this input in Manual 
Mode when you Disable Stacked DP. 
Note:  This field displays only for an orifice meter. 

Low DP Setpoint Sets the differential pressure point at which the 
system switches over to the low differential pressure 
input. 
When the High DP input is active and the High DP 
reading drops below this value, the Low DP input 
becomes the active input. The system assumes the 
units for this input to be inches of water column (In 
H2O) or kPa. 
Note:  This field displays only for an orifice meter. 

High DP Setpoint Sets the differential pressure point at which the 
system switches over to the high differential pressure 
input.  
When the Low DP input is active and the Low DP 
reading rises above this setpoint, the High DP input 
becomes the active input. The system assumes the 
units for this input to be inches of water column (In 
H2O) or kPa. 
Note:  This field displays only for an orifice meter. 

Variable K Factors Enables the variable K Factor and sets the K Factor 
values over a range to be measured. If this field is 
Disabled, the system uses the Static K Factor.  
The AGA7 calculations use a K Factor. You can 
specify a variable K factor to keep the K Factor value 
more linear by equating it to a EU Value, as received 
from a specified Input. The K Factor values cannot 
be less than zero. 
Note:  This field displays only for a turbine meter. 

 
3. Click Apply if you change any parameters on the screen.   
4. Proceed to Section 8.1.3, Meter Setup Advanced Tab.  

8.1.3 Meter Setup Advanced Tab 
Use the Advanced tab to specify additional meter parameters.  

1. Select the Advanced tab. The Advanced screen displays.  



ROCLINK 800 User Manual (FB107) 

8-10 Meter Menu Issued Jan-08 

  
Figure 8-6. Meter Setup, Advanced tab (Orifice 

Meter) 
Figure 8-7. Meter Setup, Advanced tab (Turbine 

Meter) 

Note:  Which screen displays depends on the calculation standard you 
selected on the General tab. Select AGA3-92 or ISO5167-2003 
(orifice calculations) to display Figure 8-6. Select AGA7-96 
(turbine calculations) to display Figure 8-7. 

2. Review the following fields for your organization’s values.  
Field Description 
Atmospheric 
Pressure 

Sets how the system determines the value of 
atmospheric pressure at the metering location. Valid 
values are Calculate (the system uses the value in 
the Elevation field) or Enter (calculates the value 
from the value or Enter (use the specified pressure 
value). If entered, the value must be greater than 
zero, and is expressed in PSIA. 

Gravitational 
Acceleration 

Sets how the system determines the value for 
gravitational acceleration at the metering location. 
Valid values are Calculate (the system calculates the 
value from Elevation and Latitude) or Enter (use the 
specified acceleration value). If entered, the value 
must be greater than zero, and is expressed in ft/sec2 
or M/sec2.  

Base Pressure Sets the base pressure as specified in the gas 
contract, expressed as PSIA.  

Base Temperature Sets the base temperature as specified in the gas 
contract, expressed as degrees Fahrenheit or 
degrees Celsius.  

Elevation Sets the elevation of the metering location, 
expressed in feet or in meters. This value is required 
for the calculation of atmospheric pressure and 
gravitational acceleration. 

Latitude Sets the geographical location for the metering 
location, expressed as degrees and minutes 
separated by a decimal point (such as 46.15 for 46 
minutes and 15 degrees).  
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Field Description 
Orifice Material Indicates the material from which the orifice is made. 

Nearly all natural gas applications use stainless steel 
orifice plates.  
You must also complete the Ref Temperature field. 
This indicates the reference temperature at which the 
bore diameter of the orifice plate was measured, 
expressed in degrees Fahrenheit or degrees Celsius. 
Note:  This field displays only for a turbine meter. 

Pipe Material  Indicates the material from which the orifice meter 
tube material is made. Nearly all natural gas 
applications use carbon steel meter tube.  
You must also complete the Ref Temperature field. 
This indicates the reference temperature at which the 
internal diameter of the pipe was measured, 
expressed in degrees Fahrenheit or degrees Celsius. 
Note:  This field displays only for a turbine meter. 

Force Recalculation Forces (after you select this value and click Apply) 
the system to fully recalculate the flow without waiting 
for the next normal recalculation.   
You set normal recalculation periods using the 
Integral Multiplier Period or the Base Multiplier Period 
fields on the General tab of the Meter Setup screen. 
After a forced recalculation, the system zeros 
accumulations logs the flow value as a new entry.  
Note:  The system automatically resets this 

parameter to Clear after the recalculation 
completes. 

Limit Meter Events Sets the logging of AGA events.  The system logs 
AGA limit events when an input to the AGA 
calculation is either outside the specified limits or the 
calculation fails. Valid values are Enabled (log all 
AGA limit events) or Disabled (ignore AGA 
calculation related events). 
Note:  Disabling this parameter prevents the event 

log from filling with AGA limit events.  
Pressure Tap Indicates the pressure tap type and location for this 

meter run.  Valid values are: 
 Gauge/Absolute Indicates the type of pressure 

tap.  This choice must match the 
static pressure type as actually 
measured by the sensor. Order 
the MVS sensor, DVS sensor, or 
other pressure transmitter to 
provide absolute or gauge 
measurements.  

 Upstream/ 
Downstream 

Indicates the location of the 
orifice static pressure tap in 
relation to the orifice and normal 
flow.  Upstream is the default. 
Note:  This field displays only for 

an orifice meter.   
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3. Click Apply if you change any parameters on the screen.   
4. Proceed to Section 8.1.4, Meter Setup Fluid Properties Tab.   

8.1.4 Meter Setup Fluid Properties Tab 
Use the Fluid Properties tab to define the mole percentages of up to 21 
gas components, as well as the Heating Value Basis, the Heating Value, 
and the Specific Gravity. 

Note:  If other runs have similar characteristics, you can use Copy and 
Paste to create gas quality configurations. 

1. Select the Fluid Properties tab. The Fluid Properties screen 
displays.  

 
Figure 8-6. Meter Setup, Fluid Properties tab 

2. Review the following fields for your organization’s values.   

Field Description 
Gas Component Sets the mole percent for each gas component. The 

default values are 96% Methane, 3% Ethane, and 
1% Nitrogen. Under the system default AGA8 
detailed method of properties calculations, the value 
in the Total Mole % field must equal 100% after you 
define (or accept the default) mole percentages.  

FPV Method Sets the method of determining a compressibility 
factor for AGA calculations.  Value values are: 

 Detailed Requires the natural gas composition 
in mole percent to be entered for all 
components. 
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Field Description 
FPV Method 
(continued) 

Gross1 Uses the specific gravity of the natural 
gas; the real gas gross heating value 
per unit volume; and the mole % of 
CO2 as the quantity of non-
hydrocarbon components.  

 Gross2 Uses the specific gravity of the natural 
gas; the real gas gross heating value 
per unit volume; and the mole % of 
CO2 and the mole % of N2 as the 
quantity of non-hydrocarbon 
components.  

 Note:  If you choose either Gross1 or Gross2, you 
must manually enter values for Specific 
Gravity and Heating Value on this screen. 
Gross2 requires a value for Heating Value 
only for calculating the gas energy flow. 

While the Detailed method provides the highest 
accuracy in a broad range of measurement 
conditions, you can use either of the Gross methods 
when:  
 Temperature is between 0 °C and 54 °C (32 °F 

and 130 °F). 
 Pressure is between 0 and 8274 kPa (0 and 

1200 PSIA). 
 Gas composition is within the Normal range, as 

defined in the 1992 AGA8 report.  
Heating Value Sets how the system determines the heating value 

for a specified quantity of gas.  Valid values are 
Calculate (allow the system to calculate the heating 
value from the gas composition data) or Enter (use 
the value specified in the energy calculation).   
Note:  Use the Type of Units parameter on the 

General tab to toggle between volume or 
mass measurement in English units 
(expressed as BTU/CF or BTU/Lb) and metric 
units (MJ/m3 or MJ/Kg). 

Heating Value Basis Identifies the property basis the system used to 
determine the heating value for the flow or energy 
calculations. Valid values are:  

 Dry No water vapor present in gas.   
 Wet Saturated water vapor present in gas.   

Note:  When you select this option, the 
FB107 calculates the mole 
percentage of water based on 
the algorithm from IAPWS—
IF97 standards and adjusts the 
other mole percentages 
accordingly. 

 As 
Delivered 

Gas may contain some water vapor.   
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Field Description 
Specific Gravity Sets the ratio of the molar mass of the gas to the 

molar mass of the air, a value used in the flow 
calculation.  Valid values are Calculate (the system 
calculates the value) and Enter (use the specific 
value for the flow calculation).  
Note:  If you select Enter, the value should represent 

the gas at standard conditions and cannot be 
less that 0.07.  

Viscosity Sets the dynamic viscosity of the flowing gas.  Units 
of measure are either lbm/Ft-Sec (for English units) 
or cP (for metric units).  

Sp Heat Ratio Sets the specific heat ratio of the gas (defined as the 
specific heat of the gas at constant pressure divided 
by the specific heat of the gas at constant volume). 
Accepted practice for natural gas applications is to 
use a value of 1.3, which was used to develop the 
expansion factor tables in the AGA 3 Report – Part 3. 
If entered, the value must be greater than zero. 

Gas Quality Sets the source for determining gas quality readings.  
Valid values are Constant (readings are entered in 
the event log) or Live (readings come from a gas 
chromatograph or are periodically downloaded from 
a host and are not entered in the event log).  

Log Methane Adjust Logs automatic system adjustments to methane 
percentages. Valid values are Enabled (log 
adjustments) or Disabled (allow adjustments but do 
not log them).  

 

3. Click Apply if you change any parameters on this screen.   

4. Proceed to Section 8.1.5, Meter Setup Sampler Tab.  

8.1.5 Meter Setup Sampler Tab 
Use the Sampler tab to set up the discrete output (DO) to send a pulse 
output to another device, such as an odorizer, and to control a gas 
sampler for a meter run.   

Note:  To use this option, select the Enabled option in the Sample 
Control field.  

1. Select the Sampler tab. The Sampler screen displays.  
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Figure 8-7. Meter Setup, Sampler tab 

2. Review the following fields for your organization’s values.   

Field Description 
Sampler Control  Allows the sampler to override the DO located on the 

CPU I/O assembly or on an I/O module.  Valid values 
are Enabled (override CPU-based I/O) or Disabled 
(permit CPU-based I/O). The default is Disabled.  

Output Point  Sets the DO point to be used. Click … to display a 
Select TLP dialog box you use to define the point.  

Sample Accum  Sets the volume of gas to be metered between 
pulses, expressed either in cubic meters or cubic 
feet. For example, if an odorizer needs to track every 
100 cubic feet of gas being metered, enter 100. The 
Sampler Volume Accum value is based upon the 
instantaneous flowrate. 

Sample Duration  Sets, in seconds, how long the pulse to the device 
needs to remain on. Whenever the sampler exceeds 
the defined accumulated volume (Sample Accum), 
the system turns on the discrete output for the 
amount of time set in this field.   

 

3. Click Apply if you change any parameters on this screen.   

4. Proceed to Section 8.1.6 Meter Setup Calibration Factors Tab.   
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8.1.6 Meter Setup Calibration Factors Tab 
Use the Calibration Factors tab to define instrument-specific parameters 
that can affect calibration of the meter inputs.   

1. Select the Calibration Factors tab. The Calibration Factors screen 
displays.   

  
Figure 8-8. Meter Setup, Calibration Factors tab 

(Orifice Meter) 
Figure 8-9. Meter Setup, Calibration Factors tab 

(Turbine Meter) 

Note:  Which screen displays depends on the calculation standard you 
selected on the General tab. Select AGA3-92 or ISO5167-2003 
(orifice calculations) to display Figure 8-8. Select AGA7-96 
(turbine calculations) to display Figure 8-9. 

2. Review the following fields for your organization’s values.  

Field Description 
Dead Weight 
Calibration: Static 
Pressure 

Sets whether any corrections occur for local gravity’s 
effects on dead weight calibrations to static pressure. 
The system multiplies the factor Fpwl by the base 
volume flow equation.  
The system uses the factor Fpwl to correct for the 
effect of local gravity on the weights of a dead weight 
calibrator, which are usually sized for use at a 
standard gravitational force or at some specified 
gravitational force. A correction factor must then be 
applied to correct the calibrations to the local 
gravitational force.  
Note:  When a dead weight calibrator is used for the 

differential pressure and the static pressure, 
both must be corrected for local gravity. This 
involves using Fpwl twice.  
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Field Description 
Dead Weight 
Calibration: Diff 
Pressure 

Sets whether any corrections occur for local gravity’s 
effects on dead weight calibrations to differential 
pressure. 
Note:  This field displays only for an orifice meter. 
For each selection, the system multiplies the factor 
Fpwl by the base volume flow equation once for each 
selection.  
The system uses the factor Fpwl to correct for the 
effect of local gravity on the weights of a dead weight 
calibrator, which are usually sized for use at a 
standard gravitational force or at some specified 
gravitational force. A correction factor must then be 
applied to correct the calibrations to the local 
gravitational force. When a dead weight calibrator is 
used for the differential pressure and the static 
pressure, both must be corrected for local gravity. 
This involves using Fpwl twice. 

Calibrated Grav 
Accel 

Sets a gravitational acceleration value if the tester 
value differs from the indicated value.  
The system assumes the units to be Ft/Sec2 or 
m/Sec2. 

User Correction 
Factor 

Sets a factor the system multiplies by the base 
volume flow equation to make a desired adjustment 
to the flow.  
Note:  If you use the default value of 1, the system 

does not apply any correction.  
 

3. Click Apply if you change any parameters on this screen.   

4. Proceed to Section 8.1.7 Meter Setup Alarms Tab.   

8.1.7 Meter Setup Alarms Tab 
Use the Alarms tab to configure alarm parameters.  You can either 
enable or disable alarming for each meter run. You can configure alarms 
for the individual meter runs and identify meter-specific alarm 
conditions.  

If you enable alarms, the system logs alarms on the alarm log. To 
conserve log space, enable alarms only when required. If you disable 
alarms, the system does not generate an alarm for this point, regardless 
of the alarm configuration. However, the system displays alarm 
conditions in the Active Alarms field on the Meter Setup screen’s 
General tab. 

Even if you do not plan to use all the alarms, check and adjust the value 
of each alarm to prevent the generation of false alarms.  

1. Select the Alarms tab. The Alarms screen displays.   
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Figure 8-10. Meter Setup, Alarms tab 

2. Review the following fields for your organization’s values.  

Field Description 
Time Basis for 
Alarming 

Sets how frequently the system generates alarms.  
Valid values are Alarm on Daily Flow Rate or Alarm 
on Hourly Flow Rate. The default is Alarm on Daily 
Flow Rate.  

Low Alarm Limit Sets the value to which the calculated flowrate must 
fall to generate a low alarm.  For the FB107, the 
system assumes the engineering units for the input to 
be MCF per day (1000 ft3/day) or cubic meters per 
day (m3/day). 

High Alarm Limit Sets the value to which the calculated flowrate must 
rise to generate a high alarm. For the FB107, units 
assumed for the input are MCF per day (1000 ft3/day) 
or cubic meters per day (m3/day). 

Alarm Deadband Sets a value that defines an inactive zone above the 
Low Alarm limits and below the High Alarm limits.  
This deadband prevents the system from setting and 
clearing the alarm continuously when the input value 
is oscillating around the alarm limit. For the FB107, 
units assumed for the input are MCF per day (1000 
ft3/day) or cubic meters per day (m3/day) 

RBX Alarming Sets the Spontaneous Report-by-Exception (RBX or 
SRBX) alarming options for the meter run.   
Note:  SRBX Alarming requires you to properly 

configure your communications ports.  
Valid values are: 

 Disabled RBX Alarming is turned off. 



ROCLINK 800 User Manual (FB107) 

Issued Jan-08 Meter Menu 8-19 

Field Description 
 On Alarm Set When the point enters an alarm 

condition, the FB107 generates a 
Spontaneous-Report-by-Exception 
message to the host. 

 On Alarm 
Clear 

When the point leaves an alarm 
condition, the FB107 generates a 
Spontaneous-Report-by-Exception 
message to the host. 

 On Alarm Set 
and Clear 

In either condition, an RBX 
message generates to the host. 

 

3. Click Apply if you change any parameters on this screen.  

4. Click OK to display the FB107 graphic.   

5. This completes the process of configuring the meters. Proceed to 
Section 8.2, Calibration Basics.  
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8.2 Calibration Basics 
Use the Calibration option to verify the accuracy of your input within 
contractual parameters, to calibrate those inputs to desired parameters, 
or to establish calculation adjustment factors to assure the inputs are 
within desired parameters.  

The calibration routine provides Verify, Calibrate, and Zero 
Shift/Offset/RTD Bias functions for AI, MVS, and RTD inputs. You 
can calibrate differential pressure (orifice metering may be High or Low 
Differential Pressure, depending on the device), static pressure, or 
temperature readings for each meter run.  Calibration parameters include 
zero, span, and up to three midpoints.  

The system automatically logs all new calibration values in the Event 
Log and optionally to a calibration log.  

Select Meter > Calibration. The Meter Calibration screen displays.  

 
Figure 8-11. Meter Calibration 

Note:  ROCLINK 800 removes input categories from the Freeze Values 
frame of this screen depending on the selected meter. For orifice 
meters, you can calibrate differential pressure, static pressure, 
and temperature inputs. For a turbine meter, you can calibrate 
static pressure and temperature inputs. When calibrating stacked 
differential pressure, you can calibrate either high differential 
pressure (Diff Pressure) input or low differential pressure (Low 
DP) input.  
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Field Description 
Meter Selects the meter for verification or calibration. Click 

 to display all defined meter runs.  
Meter Tag This read-only field shows the short description 

associated with the selected meter.  
Freeze Click to stop the system from updating the values of 

the analog, MVS, and temperature (RTD) inputs 
during verification or calibration.  

Freeze Values These read-only fields show the value received from 
the analog input, MVS, or RTD input when the 
Update button was last clicked.  
The system uses these values in ongoing processing 
(such as flow calculations, history logging, or control) 
while calibration occurs. 

Verify Click to start the verification process.  
Calibrate Click to start to calibration process.  
Zero Shift/Offset/ 
RTD Bias 

Click to set adjustment factors for the input.  

Auto Scan/ 
Stop Scan 

Click to automatically request values each second 
from the meter. The request continues until you click 
Freeze.  

 

 Caution If you have an MVS transmitter or a DVS sensor, refer to Chapter 6, 
Sensor/Transducer Accessories, in the ROC/FloBoss Accessories 
Instruction Manual (Form A4637) for the recommended way to remove 
or restore the device from or to working pressure during calibration. 
Failure to follow recommendations may damage the device.  

 

8.2.1 Verifying an Input  
To verify an input:  

1. Select Meter > Calibration. The Meter Calibration screen displays.  

2. Select a meter input to verify.  

Note:  ROCLINK 800 retains or removes the appropriate inputs 
from the Meter Calibration screen. The following example 
verifies a temperature sensor for a turbine meter.  
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Figure 8-12. Turbine Meter Verification 

3. Click Freeze. ROCLINK 800 displays a dialog asking if you want 
to create a calibration report file:  

 

4. Click Yes to display a Save As dialog box and specify a storage 
location for the report, which you can review later. Click No to 
proceed with verification without generating a report. ROCLINK 
800 displays the Meter Calibration screen with frozen values and 
active buttons.  
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Figure 8-13. Verification – Frozen Values 

5. Click Verify. A Verify screen displays.  

 
Figure 8-14. Verify 

6. Complete the Dead Weight/Tester Value field with a value against 
which the test equipment verifies.  
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Figure 8-15. Dead Weight/Tester Value 

When you enter a value in the Dead Weight/Tester Value field, 
ROCLINK immediately begins comparing it to the value in the Live 
Reading field (obtained from the temperature probe) and calculating 
the percentage deviation between the two values.  

7. Click Log Verify. ROCLINK 800 completes the first log entry on 
the screen.   

 
Figure 8-16. Verify Log Entry 

Field Description 
Action Indicates the current action. Valid values are Verify 

or Calibrate.  
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Field Description 
Actual Displays the value in the Live Reading field.  
Expected Displays the value in the Dead Weight/Tester Value 

field.  
Deviation Displays the amount of deviation between the actual 

and expected values.   
% Deviation Displays a percentage deviation between the Actual 

and Expected values.  
 

8. As the live reading value changes, click Log Verify as many times 
as necessary to establish the verification log.  

Typically you verify the same points you calibrate (zero, span, and 
mids). Temperature might be an example (–100, 200, 50). For each 
test point, you set your test equipment to produce the expected 
value, enter that expected value in the Tester Value field, wait for 
live input to stabilize, and then click Log Verify. You can verify as 
many points as you want.   

Note:  If you have chosen to save the verification log, ROCLINK 
800 saves it in the location you specified in step 3.  

 
Figure 8-17. Verify Log Entry 

9. Review the verification log and determine whether the results are 
within contractual limits. If they are not, you may need to calibrate 
the temperature probe. See Section 8.2.2, Calibrating an Input.  

10. Click Done. The Meter Calibration screen displays.   
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8.2.2 Calibrating an Input  
 

 Caution If you have a Multi Variable Sensor (MVS), refer to the Sensor 
Calibration section in the FloBoss Accessories Instruction Manual 
(Form A4637) for the recommended way to remove/restore the MVS 
from/to working pressure during calibration. Failure to follow 
recommendations may cause sensor damage.  

If you are calibrating a pressure input, isolate the sensor from the 
process. Set up the pressure calibrator and make the necessary 
connections to the sensor.  

If you are calibrating a temperature input, disconnect the RTD sensor 
and connect a decade box (or comparable equipment) to the FB107’s 
RTD terminals. 

 

Following verification, you may determine that the input needs to 
calibrated. A standard calibration requires you to define a zero and a 
span point; you can also define up to three midpoints which can 
represent 25%, 50%, and 75% of the span. 

Note:  You can exit a calibration without saving the changes. The 
system retains the previous calibration settings but logs the event 
in the event log.  

To calibrate an input (in this example, the static pressure input):  

1. Select Meter > Calibration. The Calibration screen displays.  

2. Select a meter input to calibrate.   

Note:  ROCLINK 800 retains or removes the appropriate inputs 
from the Meter Calibration screen. The following example 
calibrates a static pressure sensor for a turbine meter.  

 
Figure 8-18. Turbine Meter Calibration 
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3. Click Freeze. ROCLINK 800 displays a dialog asking if you want 
to create a calibration report file.  

 

4. Click Yes to display a Save As dialog box and specify a storage 
location for the report, which you can review later. Click No to 
proceed with verification without generating a report. ROCLINK 
800 displays the Meter Calibration screen with frozen values and 
active buttons.  

 
Figure 8-19. Calibration – Frozen Values 

5. Click Calibrate. A Set Zero screen displays.  
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Figure 8-20. Set Zero 

Note:  You can click Cancel to exit the calibration without saving the 
changes. The system retains the previous calibration settings but 
logs the event in the event log.  

6. Set test equipment to produce the expected results.  

7. Complete the Dead Weight/Tester Value field. This value 
represents the low range (0%) of the instrument’s measurement 
range.    

 
Figure 8-21. Dead Weight/Tester Value 

When you enter a value in the Dead Weight/Tester Value field, 
ROCLINK immediately begins comparing it once each second to 
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the value in the Live Reading field (obtained from the static 
pressure sensor) and calculating the percentage deviation between 
the two values. 

8. Click Set Zero when the live reading stabilizes. ROCLINK 800 
adds the first line in the calibration log, renames the screen to Set 
Span, and changes the label on the Set Zero button to Set Span.  

 
Figure 8-22. Set Span 

9. Set test equipment to produce the expected results.  

10. Complete the Dead Weight/Tester Value field with a value 
represents the upper limit (100% or “span”) of the instrument’s 
measurement range.    

Note:  ROCLINK 800 provides 100 as a default span value. Edit 
this default as necessary.  
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Figure 8-23. Set Span 

When you enter a value in the Dead Weight/Tester Value field, 
ROCLINK immediately begins comparing it once each second to 
the value in the Live Reading field (obtained from the static 
pressure sensor) and calculating the percentage deviation between 
the two values. 

11. Click Set Span when the live reading stabilizes. ROCLINK 800 
adds the next line in the calibration log, renames the screen, and 
changes the label on the Span button to Set Mid 1.   

 
Figure 8-24. Set Span 
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Note:  You can click Done at this point to complete the calibration 
or continue the calibration and define up to three calibration 
midpoints.   

12. Set test equipment to produce the expected results.  

13. Complete the Dead Weight/Tester Value field with the first 
midpoint calibration value (which in this example represents 50% of 
the instrument’s range).  

Note:  ROCLINK 800 provides the previous midpoint value as a 
default value. Edit this default as necessary.  

 
Figure 8-25. Set Midpoint 1 

When you enter a value in the Dead Weight/Tester Value field, 
ROCLINK immediately begins comparing it once per second to the 
value in the Live Reading field (obtained from the static pressure 
sensor) and calculating the percentage deviation between the two 
values. 

14. Click Set Mid 1 when the live value stabilizes. ROCLINK 800 adds 
the next line in the calibration log, renames the screen, and changes 
the label on the Set Mid 1 button to Set Mid 2.  
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Figure 8-26. Set Midpoint 1 

Note:  To define up to two more midpoints, repeat steps 13 and 14.   

15. Click Done when you have sufficient calibration information. The 
Meter Calibration screen displays.  

Note:  Following a calibration, you may re-run a verification to 
demonstrate to the customer that the measurement results are 
now within contractual parameters.    

8.2.3 Zero Shift, Offset, and RTD Bias  
Use these buttons on the Meter Calibration screen to make adjustments 
to calibrated values. These allow you to adjust the calibrations at 
flowing conditions. The following example shows a zero shift 
adjustment. 

Note:  Because these adjustments can affect the contractual delivery of 
product, exercise caution in using these options.   

1. From the Meter Calibration screen, click Offset. The Set Zero Shift 
(Offset) screen displays.  
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Figure 8-27. Set Zero Shift 

2. Complete the Measured Pressure Reading field with a line pressure 
value obtained from an independent pressure measurement device 
and begin monitoring the value in the Pressure Offset field. Each 
second the system compares the live reading against the value you 
enter. When the value in the Pressure Offset field stabilizes, press 
Set Offset. ROCLINK 800 sets the pressure offset and adds a line to 
the calibration log.  

  
Figure 8-28. Set Zero Shift 

3. The system then reflects this offset as an adjustment in calculations 
and lists this value on the AI Calibration Values screen (Utilities > 
AI Calibration Values):  
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Figure 8-29. Set Zero Shift 

8.3 Meter Values 
The Meter Values screen displays a variety of values from the orifice or 
turbine meter. You can use these for diagnostics or monitoring. Click 
Update to refresh the displayed values. These may be used for 
diagnostics or monitoring 

1. Select Meter > Values. The Meter Values screen displays.   

 
Figure 8-30. Meter Run Values Example  

2. Click  in the Run field to select a defined orifice or turbine meter. 
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3. Review the screen’s contents. You can click Update to refresh the 
display on demand or Auto Scan to start updating the display once 
per second.  

4. Click Cancel to return to the FB107 graphic.   

8.4 Plate Change 
Use the Plate Change option to change the size of an orifice plate under 
flowing or non-flowing conditions. 

1. Select Meter > Plate Change. The Plate Change screen displays.   

 
Figure 8-31. Plate Change 

2. Review the following fields for your organization’s values.  

Field Description 
Meter Number Sets the meter number to be changed. Click  to 

display all defined meters.   
Meter Type Sets the meter (orifice or turbine).  
Will Plate Change… Indicates the conditions during the plate change. 

Valid values are Yes (plate change occurs during 
flowing conditions) or No (plate change occurs during 
non-flowing conditions).  
Note:  If you choose Yes, you can freeze inputs for 

the duration of the plate change.  
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Field Description 
Freeze Click to freeze input values for the duration of the 

plate change.  
Note:  This button is active only if you are 

performing the plate change under flowing 
conditions. The system holds all I/O values in 
Manual Mode at the current value. Click OK to 
return values to an active state at the 
completion of the plate change.  

Differential Press This read-only field shows the frozen differential 
pressure value during the plate change.  

Static Press  This read-only field shows the frozen static pressure 
value during the plate change.  

Temperature This read-only field shows the frozen temperature 
value during the plate change.  

Pipe Diameter This read-only field shows the size of the pipe 
diameter for the selected meter.  

Orifice Diameter Sets, in inches or millimeters, the exact size of the 
orifice diameter of the new plate.  

 

3. Click Apply if you change any parameters on this screen.  

4. Click OK when you complete the plate change. If you have frozen 
values, this returns system values to flowing conditions.   
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Chapter 9 – The Utilities Menu 

Use the Utilities menu options to update firmware, manage software 
licenses, convert EFM files, manage user programs, set ROCLINK 800 
security, view AI and MVS calibration values, access the FST Editor, 
and monitor communications. 

 
Figure 9-1. Utilities Menu 

Note:  Refer to Appendix B, The FST Editor, for detailed information on 
using FSTs.  
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9.1 Update Firmware 
Use the Update Firmware option to update the internal software 
(stored in Flash ROM) of FB107 components by loading the update 
from a file.  

Note:  This option does not update ROCLINK 800 software.  
 

 Caution The Update Firmware option disables measurement and control while 
updating.  
It is a good practice to preserve the contents of the event and alarm 
logs. Save them to a file (Collect Data) BEFORE you update any 
firmware. You cannot reload event logs or alarm logs.   

 

1. Create a backup copy of the firmware update disk or download the 
firmware file from the Remote Automation Solutions website 
(www.EmersonProcess.com/Remote).  

2. Read the README text file included with the firmware update.  

3. Select Utilities > Update Firmware. The Update Firmware screen 
displays. 

 
Figure 9-2. Update Firmware 

Note:  By default, the system selects the Device Configuration options 
Save Device Configuration Before Firmware Update and 
Restore Device Configuration After Firmware Update. This 
saves your current configuration, calibration, communication 
settings, and FSTs to the file name you specify.  
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4. Click Browse to select or specify a file name the system uses to save 
and restore the system configuration file. The default location is 
C:\Program Files\ROCLINK800. The default file extension is .800.  

Note:  You can also save the configuration to Flash memory using 
the Flags screen (ROC > Flags).   

5. In the Firmware Image to Download frame, click Browse to specify 
the location of the updated firmware code. The default file extension 
is .bin.   

Note:  You can obtain firmware updates either from your factory 
representative or from the Remote Automation Solution 
SupportNet website (access 
www.EmersonProcess.com/Remote and select the Support 
option). Regardless of source, you must store the firmware 
update files on your PC before you can apply them.  

6. Once you select a firmware upgrade, ROCLINK 800 completes the 
lower portion of the Firmware Image to Download frame with 
information related to that upgrade. Review the information to make 
sure you want to apply that upgrade. 

7. Click Start. The system displays a confirmation dialog box.  

8. Click Yes to confirm the firmware update.  

Note:  The loading process typically takes several minutes. Do not 
disturb your FB107 during this time.  

When the firmware load completes, a completion dialog box 
displays.  

9. Click OK to accept the dialog box.  

ROCLINK 800 automatically loads the configuration files into the 
FB107 (if you selected the Restore Device Configuration option) 
and records the actions in the event log.  

When the backup reload completes, a “Reconnect to Device 
Completed” message displays in the Status field at the bottom of the 
Update Firmware screen. ROCLINK 800 also adds an “Updated” 
flag to the information displayed in the Firmware Image to 
Download frame. You can also verify the upgrade on the Device 
Information screen (ROC > Information > Revision Info). 

10. If you saved the configuration to Flash memory, ROCLINK 800 
performs a cold start to reload the configuration.  

Note:  If you selected the Restore Device Configuration After 
Firmware Update option on the Update Firmware screen, 
this step is not required.  
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11. Check the configuration and FSTs. If they are not correct, reload 
them (using File > Download) from the files you created in Step 4.  

12. Save the configuration (using ROC > Flags > Save Configuration) 
to permanent FB107 memory.  
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9.1.1 Update Firmware CPU Tab  
The Update Firmware screen initially displays the CPU tab.  Use this 
tab to view the currently installed firmware version and, if necessary, 
download a new firmware image. 

 
Figure 9-3. Update Firmware, CPU tab 

9.1.2 Additional Update Firmware Tabs 
The additional tabs on the Update Firmware screen display the hardware 
installed in the FB107 (see Figure 9-4, which shows the Aux 6-Pt IO 
tab) and enable you to update the firmware for the selected hardware.  
These additional tabs include:  
Tab Description 
LCD Controller Updates the firmware for the optional Liquid crystal 

display (the “Touchpad”).  
On-Board IO Updates the firmware for the CPU’s optional internal 

input/output including system analog inputs, 
communications, and the RTD.   

Aux 6-Pt IO Updates the firmware for the I/O modules. The tab 
lists each module and its current slot (see Figure 9-
4).  

MVS Updates the firmware for the optional Multi-Variable 
Sensor module.   
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Figure 9-4. Update Firmware, Additional tabs 

9.2 License Key Administrator 
Use ROCLINK 800’s License Key Administrator screens to view and 
manage information on any software licenses currently installed on the 
FB107. Some applications require that you install a license in the CPU 
to run the application. This license software is specific to these 
applications and is the property of the individual vendor (shown in the 
Vendor Name field on the License Key Administrator screens).  

9.2.1 Distributing Software Licenses 
RAS (and other authorized vendors) can distribute software licenses 
either on security-enhanced universal serial bus (USB) drives known as 
“keys” or as 105-character strings. 

Key-based FB107 software licenses delivered on security-enhanced USB keys, 
which connect to the USB port on your PC, have both benefits and 
limitations.  

RAS uses encrypted USB keys to distribute software licenses. This 
prevents unauthorized access to software licenses if the keys are lost or 
stolen. Typically, key-based licenses do not have an expiration date, 
since they are intended to provide permanent access to an application.  

USB keys can contain up to 255 iterations of a program (and up to four 
different programs). Using ROCLINK 800, you can install or remove 
these iterations onto a number of FB107s or even move the iterations to 
other encrypted USB keys. The security-enhanced USB key provides an 
excellent medium for quickly and securely distributing software licenses 
to a large geographic area.  
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String-based FB107 software licenses delivered as 105-character strings (or “files”) 
also have both benefits and limitations.  

First, these strings are encrypted and can be safely emailed for rapid 
receipt. Typically, string-based licenses have an expiration date, since 
they are intended for demonstrations or evaluations or to provide 
temporary access to an application.  

Each string contains the license for a specific software application, but 
there is no limit to the number of iterations of that license on the string. 
This enables you to copy the application to demonstration devices, 
knowing that the license has an expiration date.  

Regardless of the delivery method, you use the two License Key 
Administrator screens to install and manage software licenses on your 
FB107.  

9.2.2 Installing a License (Key-based) 
To install a USB key-based license on the FB107:  

1. Insert the USB license key in a USB port on your PC.  

2. Select Utilities > License Key Administrator > Transfer Between 
Device and Key from the ROCLINK 800 menu bar. The Transfer 
Licenses Between a Device and a Key screen displays.  

 
Figure 9-5. Transfer Licenses Between a Device and a Key 

Note that this screen has three sections. The upper portion (Licenses 
on Device) shows any software licenses currently installed on the 
FB107. The middle portion (Licenses on Key) shows software 
licenses on the license key. The lower portion of the screen (License 
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Key Event Log) provides a rolling log of the last eight events 
related to this license key.  

3. Select the key-based license you want to transfer to the FB107 
(Props Example, as shown in Figure 9-6).  

4. Click Move to Device. ROCLINK moves the license from the key 
to the FB107 and updates the screen.  

 
Figure 9-6. License Installed 

Note:  An FB107 can hold up to six different licenses, although you 
can install only one instance of each license on the FB107. 
When you click Move to Device, ROCLINK 800 moves only 
one instance of the license onto the FB107 and automatically 
decreases the license quantity on the USB key by one.   

You can also use this same screen to move a license from an FB107 and 
place it on a USB license key.  

5. Select the device-based license you want to remove. Note that 
ROCLINK 800 re-labels the Move to Device button as Move to 
Key.  
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Figure 9-7. License Moved 

6. Click Move to Key. ROCLINK moves the license from the device 
to the key and updates the screen.  

Fields The fields and buttons on the Transfer Licenses Between a Device and a 
Key screen provide additional information about the software licenses.  
 
Field Description 
Application Name Shows the name of the software application (such as 

Flow Example).  
Vendor Name Identifies the company that developed or distributed 

this application.  
App Code Indicates a code the vendor or developer has 

associated with the particular application. Refer to 
the vendor’s application documentation for a 
meaning of the application code.  
Note:  Do not mistake the Application Code for the 

license quantity. 
Version Indicates the version number of this application.  
Quantity Indicates the number of licenses assigned to this 

application.  
Note:  ROCLINK 800 manages this value as you 

install or move licenses. 
License Source Indicates the original source for the software license. 

Valid values are Key (the license came from a USB 
key and has no expiration date), File (the license 
came from a string and has no expiration date), or 
Temporary (the license came from either a string or 
key but has an expiration date.   
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Field Description 
Expiration Indicates the date the license expires and becomes 

invalid for use.  
Time Created  Shows the date and time the application was 

compiled.  
Connect to Key Click to refresh the screen display. If you insert a 

USB license key while displaying this screen, click 
Connect to Key to allow ROCLINK 800 to refresh 
the Licenses on Key portion of the screen with the 
contents of the inserted USB license key. 

Move to Device or 
Move to Key 

Click to move the selected license from the license 
key to the FB107.  
Note:  ROCLINK 800 re-labels this button as Move 

to Key if you select a license currently 
installed on the FB107. ROCLINK 800 also 
grays out this button if you select a permanent 
(non-moveable) license.  

Add License Click to add either a key-based or string-based 
license to the FB107 or move a string-based license 
to a key (if allowable).  This button activates when 
you click on the device, and opens a dialog box for 
the load.  
Note:  You can move a string-based license from the 

FB107 to a USB key only if the license is not 
registered to the specific FB107.  

Remove Click to remove the selected permanent (file-based) 
license from the FB107.  
Note: ROCLINK 800 grays out this button if you 

select a moveable (USB key-based) license. 
You can transfer a moveable license to a USB 
key, but you cannot remove it. If you need to 
restore a permanent license, you can re-install 
it from the PC file location where you stored it.   

Serial Number Shows the serial number for the USB license key.  
Close Click to close the Transfer Licenses Between a 

Device and a Key screen and display the FB107 
graphic.  

9.2.3 Installing a License (String-based) 
Note:  You must have previously obtained a 105-character string-based 

license to successfully complete this process.   

To install a string-based license on the FB107:  

1. Select Utilities > License Key Administrator > Transfer Between 
Device and Key from the ROCLINK 800 menu bar. The Transfer 
Licenses Between a Device and a Key screen displays.   
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Figure 9-8. Transfer Licenses Between a Device and a Key 

2. Click Add License. The Enter License String dialog box displays.  

 
Figure 9-9. Enter License String 

3. Enter the 105-character license string in the dialog box and click 
OK. ROCLINK 800 immediately installs the license on the FB107:  

Note:  Use the Windows Copy and Paste functions to decrease the 
chances of mis-keying the character string.   
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Figure 9-10. Installed String-based License 

9.2.4 Transferring Licenses 
With sufficient security authority, you can transfer moveable licenses 
from one USB license key to another.  This is helpful when you need to 
perform field upgrades. You must have two available USB ports on 
your PC and use enhanced security USB license key drives.  

To transfer a license from one license key to another: 

1. Insert the USB license keys in available USB ports on your PC.  

Note:  ROCLINK 800 designates the first USB key you install as 
License Key 1 and the second USB key you install as 
License Key 2.  

2. Select Utilities > License Key Administrator > Transfer Between 
Keys from the ROCLINK 800 menu bar. The Transfer Licenses 
Between Keys screen displays.  
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Figure 9-11. Transfer Licenses Between Keys 

This screen has two sections. The upper portion (License Key 1) 
shows any software licenses on the first license key. The lower 
portion (License Key 2) shows any software licenses on the second 
license key.  

3. Select a license to transfer (in this case, IAPWS-1997 on License 
Key 2).  

4. Click Move License from License Key 2 to License Key 1. 
ROCLINK 800. Since this license actually has three distinct licenses 
(as shown in the Quantity field), ROCLINK 800 displays a dialog 
box you use to indicate the number of licenses to transfer.  

Note:  ROCLINK 800 relabels this button if you select a license on 
key 1 to transfer to key 2.  

 
Figure 9-12. Number of Licenses 

5. Indicate the number of licenses (Quantity) you want to transfer and 
click OK. ROCLINK 800 transfers the license and refreshes the 
screen. 
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Figure 9-13. License Transferred 

6. Review the Quantity fields and note that License Key 1 now has one 
IAPWS-1997 license and that License Key 2 now has two IAPWS-
1997 licenses. 

9.2.5 Removing a License 
For internal security, ROCLINK 800 protects software licenses.  You 
cannot actually delete a license you have installed from a USB key (a 
“moveable” license). Instead, you can transfer it from the FB107 back 
onto a USB key. Refer to Section 9.2.4, Transferring Licenses.  

However, you can remove a software license you have installed from a 
string. Remember that the license you installed on the FB107 is actually 
a copy of the original license, which still resides on your PC. 
Additionally, a USB key can contain up to 255 separate iterations of a 
license. A string-based license has no limit on the number of reuses.  

To remove a license:  

1. Select Utilities > License Key Administrator > Transfer Between 
Device and Key from the ROCLINK 800 menu bar. The Transfer 
Licenses Between a Device and a Key screen displays.   

2. Review the Transfer Mode field at the top of the screen and select a 
permanent license (here, V-Cone Flow Calc). Note that ROCLINK 
800 activates the Remove button.  
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Figure 9-14. Transfer Licenses Between a Device and a Key 

3. Click Remove. A Confirm Remove License dialog box displays.   

 
Figure 9-15. Confirm Remove License Dialog 

4. Click Yes. A second confirmation dialog displays:  

 
Figure 9-16. Confirm Removal Dialog 

5. Click Yes. ROCLINK 800 displays the Transfer Licenses Between a 
Device and a Key screen, showing that the license for V-Cone Flow 
Calc (the permanent license) is gone.  
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Figure 9-17. License Removal Completed 

Note:  Although you have removed this license from the FB107, the file 
you used to install the license still resides on your PC. You have 
deleted only the installed license iteration, not the original 
license.   

9.3 Converting EFM Report Files 
Use the Convert EFM File option to convert EFM Report files (.EFM 
database file) to the Flow-Cal or .AGA/.DET report file format.  

1. Select Utilities > Convert EFM File. The Convert EFM File screen 
displays.  
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Figure 9-18. Convert EFM File 

2. Select the appropriate device type (ROC306/312/364, 
FB103/104/107/407/503/504) in the Device Type frame.  

3. Select a conversion option in the Convert To field.  

Note:  The .AGA/.DET option contains standard history points for 
the meter run. The Flow-Cal option requires that you 
indicate the meters involved and provide a start and stop date 
for the involved files.   

4. Click … in the Select Efm File(s) to Convert field. The Select 
EFM Files to Convert screen displays.  
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Figure 9-19. Select EFM Files to Convert 

5. Use this screen to locate and select the EFM files stored on your PC.   

Note:  By default, ROCLINK 800 selects all the displayed files. 
Click Deselect All to individually select specific files.   

6. Click OK. The system internally validates each file type. If any of 
the files are invalid, an error message displays. If this occurs, click 
OK. The system automatically removes any invalid files and 
displays a log in the Log frame at the right side of the screen.   

7. Click … in the Select Folder for Converted File(s) field. The 
Select Folder for Converted Files screen displays.  
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Figure 9-20. Select Folder for Converted Files 

8. Select the folder in which ROCLINK 800 should store the converted 
files and click OK. 

Note:  If you have selected .AGA/.DET as a format, skip to step 12. 
If you have selected Flow-Cal as a format, proceed to the 
next step.   

9. Select the options for file name prefix. If applicable, you can select 
both Station Address & Group and EFM File Collection Date & 
Time.  

10. Select the meter runs.  

Note:  By default, ROCLINK 800 selects all the displayed meter 
runs. Click Deselect All to individually select specific runs.   

11. Select a starting and ending period for the records to be converted. 
Click  to display a calendar.  

12. Click Start Conversion. ROCLINK 800 converts the files using the 
options you have selected. When the conversion completes, a 
message appears in the Log frame on the right-hand side of the 
screen and a message displays.  
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13. Click OK and click Cancel to display the FB107 graphic.   

Note:  Click Cancel to stop a conversion in progress. ROCLINK 
800 displays a dialog box (click OK) to acknowledge the 
cancellation.   

9.4 User Program Administrator 
User programs provide the FB107 with extended functions and 
applications (such as gas chromatograph support or GOST calculations). 
Use this option to download, start, stop, and remove user programs.  

Note:  Extensive documentation covering configuration and usage 
information accompanies each user program.   

1. Select Utilities > User Program Administrator. The User Program 
Administrator screen displays.   

  
Figure 9-21. User Program Administrator 

 

2. Review the following fields for your organization’s values.  

Field Description 
User Programs 
Installed in Device 

Displays any user programs currently installed in the 
FB107. 
If you select a currently installed program (for 
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Field Description 
example, 07Q0232, V-Cone Flow), the system 
completes the upper portion of the screen, as shown 
on the right-hand portion of Figure 9-21.  

Status This read-only field indicates the status of the 
selected program. Valid values are:  

 Empty No program installed.  
 Loaded Program installed but not running.  
 Running Program active.  
 License Not 

Found 
Program requires a license to 
operate (see Section 9.2).  

Clear  Click to delete the selected user program from 
memory.  

Start  Click to start the selected user program.  
Stop  Click to stop the selected user program from running. 
Download User 
Program File 

Identifies the program file to be downloaded.  

Download & Start  Click to download and start the identified user 
program running.  

Download  Click to download but not start the identified user 
program. 
Note:  If you download several programs, they may 
need to be started in a particular order. Use this 
button to download without starting the programs.  

 

3. Click Close to display the FB107 graphic.   

9.4.1 Downloading a User Program 
You can use the User Program Administrator screen to download a user 
program to the FB107.  

Note:  For the FB107, ROCLINK 800 automatically determines in 
which of six slots to install a downloaded program.  

1. Select Utilities > User Program Administrator. The User Program 
Administrator screen displays.  

2. Click Browse in the Download User Program File frame. The Select 
User Program File screen displays.  
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Figure 9-22. Select User Program File 

Note:  User Program files are typically located in the Program Files 
folder on the distribution CD. The screen displays the names of 
all files that have the .bin extension.   

3. Select a file name to load and click Open. The User Program 
Administrator screen displays.  

 
Figure 9-23. User Program Administrator 



ROCLINK 800 User Manual (FB107) 

Issued Jan-08 Utilities Menu 9-23 

4. Click Download & Start to download and automatically start the 
selected user program (or click Download to download the user 
program without starting it). A message dialog displays.  

 
Figure 9-24. Confirm Download 

Note:  ROCLINK 800 automatically assigns the program number.  

5. Click Yes to begin the download. During the download, the program 
performs a warm start, creates an event in the Event Log, and—
when the download completes—displays the following message.  

 
Figure 9-25. Successful Download Confirmation 

6. Click OK. The User Program Administrator screen displays (see 
Figure 9-26). Note that:  

 The User Programs Installed in Device frame now identifies the 
loaded program.   

 The Status field indicates that the program is running.  
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Figure 9-26. User Program Administrator 

7. Access ROCLINK 800’s Flags screen (ROC > Flags), click Save 
Configuration, and click Yes. This ensures that the program 
automatically restarts after a cold start.  

9.5 ROCLINK 800 Security  
Use this option to access a table and define up to 32 user IDs with 
passwords and levels of system access. For a complete description of 
system security, refer to Section 3.7, Security.  

1. Select Utilities > ROCLINK 800 Security. The ROCLINK 800 
Security screen displays.   
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Figure 9-27. ROCLINK 800 Security 

Note:  The default Operator ID is LOI. The default Password is 
1000, and the default access level is 5.  

2. Enter three alphanumeric characters for the Operator ID, which is 
typically the initials of the person who operates the device. Each 
Operator ID must be unique and case-sensitive. 

3. Enter four numeric characters (between 0000 and 9999) to define the 
password for this ID. More than one user can have the same 
password.   

4. Enter the desired access level for the operator ID. 0 is the lowest 
(least inclusive) access level and allows access to the fewest number 
of screens. 5 is highest (most inclusive) access level and allows 
access to all screens.  

Note:  Each access level permits access to screens at that level and 
any inherited from lower access levels. For example, an 
operator ID with access level 3 can access screens with levels 
0, 1, 2, and 3. Refer to Table 3-2 for a listing of menu options 
and their security levels. 

5. Click Save if you have changed the contents of this screen.  

6. Click Close to display the FB107 graphic.  
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9.6 Analog Input Calibration Values  
Use this option to review all the calibration values for a specific analog 
input point.  

1. Select Utilities > AI Calibration Values. The AI Calibration 
Values screen displays.   

 
Figure 9-28. AI Calibration Values 

2. Review the following fields for your organization’s values.  

Field Description 
Point Click  to select the AI point to view.  
Raw Value (1 – 5) These read-only fields show the calibrated raw A/D 

input, where Value 1 is the lowest calibrated input 
and Value 5 is the highest calibrated input.  

Press Effect This read-only field shows the zero shift adjustment 
value for a differential pressure input. This value is 
an offset to the calibrated EU Values, and 
compensates for the effect of working static pressure 
on a DP transmitter that was calibrated at 
atmospheric pressure. 

Set EU Value This read-only field shows the Tester Value 
specified for the last calibration. 

Manual EU Value  This read-only field shows the Live Reading for the 
last calibration.  

EU Value (1 – 5)   These read-only fields show the five calibration 
settings in Engineering Unit values, converted from 
the raw values, based on the low reading EU and the 
high reading EU defined for the point. Value #1 is the 
zero value, value #5 is the span value, and values 2, 
3, and 4 are midpoint values.  
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Field Description 
Timer This read-only field shows the last inactivity count-

down in seconds (typically starting from 3600 
seconds) that occurred during the last calibration 
session. Had the countdown reached 0, time-out 
would have taken place, automatically ending the 
calibration mode.  

Mode This read-only field shows the status of the 
calibration. Valid values are:  

 0 Use Current Calibration 
 1 Start Calibration 
 2 Calibrate 
 3 Restore Previous Calibration 
 4 Stop Calibration 
Type This read-only field shows the currently set 

calibration value. Valid values are:  
 0 Inactive (no value) 
 1 Zero 
 2 Span 
 3 Midpoint 1 
 4 Midpoint 2 
 5 Midpoint 3 
 6 Zero Shift 
 

3. Click OK to display the FB107 graphic screen.  

9.7 MVS Input Calibration Values 
Use this option to display a screen that shows all the current calibration 
values for MVS sensor points.   

1. Select Utilities > MVS Calibration Values. The MVS Calibration 
screen displays.   
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Figure 9-29. MVS Calibration Values 

2. Review the following fields for your organization’s values.  

Field Description 
MVS Sensor  Click  to select the MVS sensor point (sensor 

number) to view.  
Sensor Tag This read-only field shows the label associated with 

the chosen MVS sensor point.  
Differential Pressure These read-only fields display the Differential 

Pressure calibration values the selected MVS 
sensor currently uses.  
Note:  Manual Value represents the value of the 

input at the time of the last meter “Freeze.” 
Static Pressure These read-only fields display the Static Pressure 

calibration values the selected MVS sensor uses.  
Note:  Manual Value is the value of the input at the 

time of the last meter “Freeze.”  
Temperature These read-only fields display the Temperature 

calibration values the selected MVS sensor currently 
uses.  
Note:  Manual Value is the value of the input at the 

time of the last meter “Freeze.”  
Set To Factory 
Defaults 

Click to return MVS calibration values to their original 
values and reset the MVS. 
Note:  You must answer Yes to a verification dialog 

before the reset occurs. When the reset 
completes, a verification dialog box displays. 
This resets the MVS address to the default 
value of 1 and the Sensor Tag to MV Sensor. 

 
3. Click OK to display the FB107 graphic screen.  
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9.8 FST Editor 
ROCLINK 800’s Function Sequence Table (FST) provides an 
instruction list programming language you can use to define and 
perform a set of specific actions when a set of conditions exists.  

Note:  Refer to Appendix B, The FST Editor, for FST commands and 
more detailed information. 

9.9 Communications Monitor 
Select Utilities > Communications Monitor to display the data bytes 
(in hexadecimal format) sent and received from the ROCLINK 800 
software during that operation.   

Note:  Refer to the ROC Protocol Manual, Form A4199, for further 
information on protocol requirements.  

Bytes sent are shown in black; bytes received are shown in red. Data 
received since the last good response (and before a request) are shown 
in aqua.  

Right-click on the display a menu that allows you to Copy highlighted 
data, Clear All data, or Unselect. You can then paste copied data into a 
file for analysis.  

 
Figure 9-30. Communications Monitor 
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Chapter 10 – The Tools Menu 

Use the Tools menu option to configure how your TLP options display 
and to customize your toolbars.  

 
Figure 10-1. Tools Menu 

In This Chapter 

10.1 Customize ......................................................................................10-1 
10.2 Options...........................................................................................10-1 
 

10.1 Customize 
This ROCLINK 800 menu option is currently unavailable.   

10.2 Options 
ROCLINK 800 enables you to display TLP selections as either text or 
numbers (see Figure 10-2).  

 

Figure 10-2. TLP Displays 

Select Tools > Options to display the Options dialog box.  
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Figure 10-3. Options 

Field Description 
Display TLP Displays values on the Select TLP screen as either 

text or numbers.  See Figure 10-2.  
Auto Scan Update 
Interval 

Sets, in seconds, the time interval at which the Auto 
Scan feature (present on numerous ROCLINK 800 
screens) polls a FloBoss 107.  
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Chapter 11 – The Window Menu 

Use the Windows menu options to configure how your screens display 
and to select the ROCLINK 800 screen you desire to view.  

 
Figure 11-1. Window Menu  

In This Chapter 

11.1 Cascade.........................................................................................11-1 
11.2 Tile .................................................................................................11-2 
11.3 Active View ....................................................................................11-2 

11.1 Cascade 
Select Window > Cascade to view all open ROCLINK 800 windows in 
a Cascade view.  

 
Figure 11-2. Cascade  

Button Description 

 
Minimizes the size of the window and places it at the bottom 
of the screen. 

 
Maximizes the size of the window to fill the screen area. 
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Button Description 

 
Restores the original size of the window. 

 
Closes a window. 

11.2 Tile 
Select Window > Tile to view all open ROCLINK 800 windows in a 
Tile view.  

 
Figure 11-3. Tile 

11.3 Active View 
To switch between active views in ROCLINK 800, select Window > 
View. A check mark appears next to the active view (as shown in 
Figure 11-4). A view must be active before you can alter information on 
that screen. 

 
Figure 11-4. Active View  
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Chapter 12 – The Help Menu 

Use the Help menu to access the on-line help system and view the 
About ROCLINK 800 screen.  

 
Figure 12-1. Help Menu 

In This Chapter 

12.1 Help Topics ....................................................................................12-1 
12.2 About ROCLINK 800 .....................................................................12-2 
 

12.1 Help Topics 
ROCLINK 800 has a comprehensive help system.  To acquire help 
using the menu structure, click Help Topics from the Help menu. To 
display context-sensitive help on a specific issue, select the item, 
parameter, field, or button, and press F1.  

When you select Help > Help Topics, you display the ROCLINK 800 
main help screen. A table of contents for all help topics appears on the 
left of the help topic contents. The Help Topics consist of parameter 
names and menu options. Note that some topic names have been 
abbreviated. For example: analog input functions appear with “AI” in 
front of the name, such as in AI Alarms, AI Scanning, or AI-analog 
inputs.  

 
Figure 12-2. ROCLINK 800 Software Help 
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12.2 About ROCLINK 800 
Select Help > About ROCLINK 800 to display the About ROCLINK 
800 dialog box.  

 
Figure 12-3. About ROCLINK 800 

The dialog box displays a variety of information, including the version 
number, license agreement, creation (software build) date, and version 
information for supporting files. Click OK to close the dialog box. 

Note:  Figure 12-3 represents the current version as of the publication 
date of this manual. Newer versions may be available. Consult 
with your LBP.   
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Appendix A – Glossary 

Note:  This is a generalized glossary of terms. Not all the terms may 
necessarily correspond to the particular device or software 
described in this manual. For that reason, the term “ROC” is 
used to identify all varieties of Remote Operations Controllers.  

A 
A/D Analog to Digital signal conversion.  
ABS Acrylonitrile Butadiene Styrene. 
ADC Analog to Digital Converter. Used to convert analog inputs (AI) to a format the flow 

computer can use.  
Additive A liquid that is injected into a primary liquid component in relatively small quantities, 

usually less than four percent of the delivered volume total. Additives are injected into 
the primary liquid component by an injector mechanism which places a known, fixed 
volume of the additive into the primary liquid component stream for each injector pulse 
received from the DL8000 Preset.  

AGA American Gas Association. A professional organization that oversees the AGA3 
(orifice), AGA5 (heating value), AGA7 (turbine), AGA8 (compressibility), and AGA11 
(ultrasonic) gas flow calculation standards. See http://www.aga.org. 

AWG American Wire Gauge. 
AI Analog Input. 
AO Analog Output. 
Analog Analog data is represented by a continuous variable, such as an electrical current 

signal. 
Annubar A device that uses Pitot tubes to measure the gas flow rate within a pipeline. The gas 

volume is calculated from the difference between the flowing pressure and the static 
pressure of the gas. 

AP Absolute Pressure. 
API American Petroleum Institute. See http://www.api.org. 
Area A user-defined grouping of database entities.  
Arm A movable pipe or hose assembly used at a tanker truck loading island (also: swing 

arm, loading arm). The arm can be designed for either top loading or bottom loading to 
the tanker compartments. A swing arm can be positioned to load at either side of the 
loading island or the parked state. 

ASCII American (National) Standard Code for Information Interchange. 
Attribute A parameter that provides information about an aspect of a database point. For 

example, the alarm attribute is an attribute that uniquely identifies the configured value 
of an alarm. 

B 
Batch A preset, quantity-based product delivery or blended component delivery of a single 

recipe. 
Blend Stream A product stream blended of both gasoline and ethanol. 
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Blending The process of mixing two or more liquid components to form a composite delivered 
stream. The DL8000 controls blending based on a predetermined recipe by either the 
sequential (automatic or manual) or the inline (proportional or non-proportional) 
method. The quantity of each component in a blend is typically greater than two to four 
percent of the blended product. Injection of very small quantities of liquids, less than 
four percent of the blended product, is usually controlled by the additive injection 
process. 

BMV Base Multiplier Value, used in AGA7 (turbine) calculations.  
BPS Bits Per Second, associated with baud rate. 
BTU British Thermal Unit, a measure of heat energy. 
Built-in I/O I/O channels that are fabricated into the ROC and do not require a separate option. 

Also called “on-board” I/O. 

C 
CID2 Class I, Division 2 hazardous area 
CF Compare Flag; stores the Signal Value Discrete (SVD). 
CMOS Complementary Metal Oxide Semiconductor, a type of microprocessor used in a ROC. 
Coil Digital output, a bit to be cleared or set.  
COL Ethernet Packet Collision. 
COM Communications port on a personal computer (PC).  
COMM Communications port on a ROC used for host communications.  
Comm Module Module that plugs into a ROC to provide a channel for communications via a specified 

communications protocol, such as EIA-422 (RS-422) or HART. 
Component Any liquid metered and controlled by the DL8000. Liquid hydrocarbons refined from 

crude oil and LPGs (such as propane) are usually referred to as products. Components 
are base products or tank products stored at a distribution terminal. The component is 
measured before being blended with other components. Additives may be injected 
before (upstream of) or after (downstream of) the component meter. 

Configuration Refers either to the process of setting up the software for a given system or the result 
of performing this process. The configuration activity includes editing the database, 
building schematic displays and reports, and defining user calculations. Typically, the 
software set up of a device that can often be defined and changed. Can also mean the 
hardware assembly scheme. 

Configuration 
Tree 

In ROCLINK 800, the graphical display that appears when a configuration file opens 
(also Directory Tree). It is a hierarchical branching (“tree-style”) method for navigating 
within the configuration screens.  

CPU Central Processing Unit. 
CRC Cyclical Redundancy Check error checking. 
Crosstalk The amount of signal that crosses over between the receive and transmit pairs, and 

signal attenuation, which is the amount of signal loss encountered on the Ethernet 
segment. 

CSA Canadian Standards Association. See http://www.csa.ca. 
CSMA/CD Carrier Sense Multiple Access with Collision Detection. 
CTS Clear to Send modem communications signal. 

D 
D/A Digital to Analog signal conversion.  
DB Database. 



ROCLINK 800 User Manual (FB107) 

Issued Jan-08 Glossary A-3 

dB Decibel. A unit for expressing the ratio of the magnitudes of two electric signals on a 
logarithmic scale. 

DCD Data Carrier Detect modem communications signal. In addition, Discrete Control 
Device – A discrete control device energizes a set of discrete outputs for a given 
setpoint and matches the desired result against a set of discrete inputs (DI).  

DCE Data Communication Equipment. 
Deadband A value that is an inactive zone above the low limits and below the high limits. The 

purpose of the deadband is to prevent a value (such as an alarm) from being set and 
cleared continuously when the input value is oscillating around the specified limit. This 
also prevents the logs or data storage location from being over-filled with data. 

Device 
Directory 

In ROCLINK 800, the graphical display that allows navigation through the PC Comm 
Ports and ROC Comm Ports set up screen.  

DI Discrete Input. 
Discrete Input or output that is non-continuous, typically representing two levels (such as on/off). 
DMM Digital multimeter.  
DO Discrete Output. 
Download The process of sending data, a file, or a program from a PC to a ROC. 
DP Differential Pressure. 
DSR Data Set Ready modem communications signal. 
DTE Data Terminal Equipment. 
DTR Data Terminal Ready modem communications signal. 
Duty Cycle Proportion of time during a cycle that a device is activated. A short duty cycle 

conserves power for I/O channels, radios, and so on. 
DVM Digital voltmeter. 
DVS Dual-Variable Sensor. A device that provides static and differential pressure inputs to a 

ROC.  

E 
EDS Electronic Static Discharge. 
EEPROM Electrically Erasable Programmable Read-Only Memory, a form of permanent memory 

on a ROC. 
EFM Electronic Flow Metering or Measurement. 
EIA-232  
(RS-232) 

Serial Communications Protocol using three or more signal lines, intended for short 
distances. Concerning RS232D and RS232C, the letters C or D refer to the physical 
connector type. D specifies the RJ-11 connector where a C specifies a DB25 type 
connector. 

EIA-422 
(RS-422) 

Serial Communications Protocol using four signal lines. 

EIA-485 
(RS-485) 

Serial Communications Protocol requiring only two signal lines. Can allow up to 32 
devices to be connected together in a daisy-chained fashion. 

EMF Electro-Motive Force. 
EMI Electro-Magnetic Interference. 
ESD Electro-Static Discharge. 
EU Engineering Units. Units of measure, such as MCF/DAY. 

F 
FCC Federal Communications Commission. See http://www.fcc.gov.  
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Firmware Internal software that is factory-loaded into a form of ROM. In a ROC, the firmware 
supplies the software used for gathering input data, converting raw input data values, 
storing values, and providing control signals. 

FlashPAC 
module 

ROM and RAM module for a ROC300-Series unit that contains the operating system, 
applications firmware, and communications protocol. 

Flash ROM A type of read-only memory that can be electrically re-programmed. It is a form of 
permanent memory (requires no backup power). Also called Flash memory. 

FloBoss A microprocess-based device that provides flow calculations, remote monitoring, and 
remote control. A FloBoss is a type of ROC.  

FM Factory Mutual. 
Force Write an ON/OFF, True/False, or 1/0 value to a coil. 
FPV Compressibility Factor. 
FSK Frequency Shift Keypad.  
FST Function Sequence Table, a type of user-written program in a high-level language 

designed by Emerson Process Management’s Remote Automation Solutions Division.  
Ft Foot or feet. 

G 
GFA Ground Fault Analysis. 
GND Electrical ground, such as used by the ROC unit’s power supply. 
GP Gauge Pressure. 
Gross Quantity The indicated quantity times the meter factor derived from a meter proving of the flow 

meter at a specific flow rate. Calculation: gross quantity = indicated quantity times 
meter factor.  

H 
HART® Highway Addressable Remote Transducer.  
Holding 
Register 

Analog output number value to be read. 

Hw Differential pressure. 
Hz Hertz.  

I, J 
IC Integrated Circuit. Also, Industry Canada (more recently known as Measurement 

Canada), an organization that grants custody transfer approvals on certain ROC units.  
ID Identification. 
IEC Industrial Electrical Code or International Electrotechnical Commission. See 

http://www.iec.ch.  
IEEE Institute of Electrical and Electronic Engineers. A professional organization that, in 

conjunction with the International Standards Organization (ISO), establishes and 
maintains the Open System Interconnection (OSI) reference model and an international 
standard for the organization of local area networks (LANs). Refer to 
http://www.ieee.org. 

IMV Integral Multiplier Value, used in AGA3 (orifice) calculations.  
Indicated 
Quantity 

The change in the flow meter reading that occurs during a product flow measurement 
operation. (Not displayed by the DL8000 calculation: indicated quantity = end reading 
minus start reading.) 

Input Digital input, a bit to be read. 
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Input Register Input numeric value to be read. 
I/O Input/Output. 
I/O Module Module that plugs into an I/O slot on a ROC to provide an I/O channel. 
IP-252 Institute of Petroleum standard 252. A British standard for pulse fidelity and security for 

pulse output type flow meters. Program codes 233 and 234 define the operation of this 
function.  
Note:  Equivalent standard is API Manual of Petroleum Measurement Standards / 

Chapter 5 - Metering / 
IRQ Interrupt Request. Hardware address oriented. 
ISO International Standards Organization. See http://www.iso.ch. 
IV Integral Value. 

K 
KB Kilobytes. 
KHz KiloHertz. 
K-factor The pulses per unit quantity generated by a pulse output type flow meter (also system 

factor). The nominal value is determined by flow meter design and factory water flow 
calibration. The “average” K-factors for the flow meters are usually indicated on the 
flow meter nameplates. 

L 
LCD Liquid Crystal Display.  
LDP Local Display Panel, a display-only device that plugs into ROC300 (via a parallel 

interface cable) used to access information stored in the ROC. 
LED Light-Emitting Diode. 
Load For sequential blending: In multi-component blending, a load is the completed 

delivery of one component of a batch. The completion of loading all components in the 
batch completes the batch delivery. If the recipe only loads one component, a load 
corresponds to a batch delivery.  
For inline blending:  Each component of the blend is loaded simultaneously. 
Depending on the blend ratio, the low-proportion components are loaded completely 
during the time that the high proportion component(s) are being loaded. After loading of 
the highest proportion component has been terminated, all component loads and the 
batch delivery are complete. 

Loading Island Also loading rack; an installation of one or more loading arms or risers used to deliver 
liquid components to a tanker vehicle located on one or both sides of the island, 
depending on the design of the island.  

Loading Riser The related instruments and devices, located in a meter stream, that provide the liquid 
component loading capability to a mobile tanker vehicle. 
Note:  The flow meter piping can also be installed horizontally, if desired.) 

Load Spot Also bay or lane; one side of a loading island, a position where a tanker vehicle parks 
for a loading operation. One load spot can have one or more loading arms. 

Local Port Also LOI; the serial EIA-232 (RS-232) port on the ROC through which local 
communications are established, typically for configuration software running on a PC.  

Logical Number The point number the ROC and ROC Plus protocols use for I/O point types are based 
on a physical input or output with a terminal location; the point numbers for all other 
point types are “logical” and are simply numbered in sequence.  

LNK Ethernet has linked. 
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LOI Local Operator Interface (or Local Port). Refers to the serial  EIA-232 (RS-232) port on 
the ROC through which local communications are established, typically for 
configuration software running on a PC. 

LPM Lightning Protection Module; a device that provides lightning and power surge 
protection for ROCs. 

LRC Longitudinal Redundancy Checking error checking. 

M 
m Meter. 
mA Milliamp(s); one thousandth of an ampere. 
MAC Address Media Access Control Address; a hardware address that uniquely identifies each node 

of a network.  
Manual mode For a ROC, indicates that the I/O scanning has been disabled.  
MAU Medium Attachment Unit. 
MCU Master Controller Unit.  
Meter Factor A number obtained by dividing the actual volume of liquid passed through a flow meter 

during a meter proving operation by the volume registered by the flow meter. The 
meter factor is used in flow calculations to correct the indicated volume (end flow meter 
registration minus start flow meter registration) to the observed gross volume (actual 
flow meter throughput at operating conditions). 
Meter factor = (Meter prover volume corrected to standard conditions) ÷ (Flow meter 
indicated volume corrected to std conditions)  

Meter Proving A procedure used to determine the meter factor for a flow meter. The K-factor (exact 
number of pulses per a volume unit that a flow meter generates) is determined at the 
factory. The K-factor is used to derive a mathematical factor, known as meter factor, 
which is used to adjust results of the internal flow calculations the DL8000 performs.  
Note:  The flow meter is not re-calibrated; determining the meter factor allows the 

operator to manually re-calibrate the DL8000 so that the flow meter’s 
nonadjustable calibration characteristic [pulses per volume unit (K-factor)] are 
incorporated into the flow calculations.  

Modbus A popular device communications protocol developed by Gould-Modicon. 
MPU Micro-Processor Unit.  
mm Millimeter. 
MMBTU Million British Thermal Units. 
msec Millisecond, or 0.001 second. 
MVS Multi-Variable Sensor. A device that provides differential pressure, static pressure, and 

temperature inputs to a ROC for orifice flow calculations.  
mV Millivolts, or 0.001 volt. 
mW Milliwatts, or 0.001 watt. 

N 
NEC National Electrical Code. 
NEMA National Electrical Manufacturer’s Association. See http://www.nema.org. 

O 
OH Off-Hook modem communications signal. 
Off-line Accomplished while the target device is not connected (by a communications link). For 

example, “off-line configuration” refers to configuring an electronic file that is later 
loaded into a ROC.  
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Ohms Units of electrical resistance. 
On-line Accomplished while connected (by a communications link) to the target device. For 

example, “on-line configuration” refers to configuring a ROC800-Series unit while 
connected to it, so that you can view the current parameter values and immediately 
load new values. 

Opcode Type of message protocol the ROC uses to communicate with the configuration 
software, as well as host computers with ROC driver software. 

Operator 
Interface 

Also LOI or Local Port; the serial EIA-232 (RS-232) port on the ROC through which 
local communications are established, typically for configuration software running on a 
PC.  

Orifice meter A meter that records the flow rate of gas through a pipeline. The flow rate is calculated 
from the pressure differential created by the fluid passing through an orifice of a 
particular size and other parameters.  

P, Q 
Parameter A property of a point that typically can be configured or set. For example, the Point Tag 

ID is a parameter of an Analog Input point. Parameters are normally edited by using 
configuration software running on a PC. 

PC Personal Computer. 
Permissive A discrete signal from a device that is input to a discrete input in the DL8000. The 

DL8000 uses this signal to allow a product delivery to be initiated or allow a product 
delivery to continue. Permissive contacts are CLOSED in the normal or safe state and 
OPEN in the abnormal or unsafe state. 

Pf Flowing pressure. 
P/DP Pressure/Differential Pressure. 
PI Pulse Input. 
PID Proportional, Integral, and Derivative control feedback action. 
PIT Periodic Timer Interrupt. 
PLC Programmable Logic Controller.  
Point Software-oriented term for an I/O channel or some other function, such as a flow 

calculation. Points are defined by a collection of parameters. 
Point Number The physical location of an I/O point (module slot and channel) as installed in the ROC. 
Point Type Defines the database point to be a specific type of point available to the system. The 

point type determines the basic functions of a point. 
Preset Number value previously determined for a register.  

Also: 
A generic term that describes the functional instrument group to which the DL8000 
belongs. The term originated from mechanical and electrical preset counters. The 
DL8000 provides much more versatility and capability compared to a simple 
mechanical or electrical preset counter. 

PRI Primary PID control loop. 
Primary Blend 
Stream 
Component 

A blended product measured by a primary blend stream meter.  

Primary Blend 
Stream Meter 

A meter measuring the gasoline-ethanol blend. 

Protocol A set of standards that enables communication or file transfers between two 
computers. Protocol parameters include baud rate, parity, data bits, stop bit, and the 
type of duplex.  



ROCLINK 800 User Manual (FB107) 

A-8 Glossary Issued Jan-08 

PSTN Public Switched Telephone Network. 
PT Process Temperature. 
PTT Push-to-Talk signal. 
Pulse Transient variation of a signal whose value is normally constant. 
Pulse Interface 
module 

A module that provides line pressure, auxiliary pressure, and pulse counts to a ROC. 

PV Process Variable or Process Value. 
Quantity The resulting amount of product measured after compensation for operational 

temperature and pressure, indicated in one of the following corrected units: cubic 
meters, liters, barrels, gallons. 

R 
Rack A row of slots on a ROC into which I/O modules can be plugged. Racks are given a 

letter to physically identify the location of an I/O channel (such as “A” for the first rack). 
Built-in I/O channels are assigned a rack identifier of “A” while diagnostic I/O channels 
are considered to be in “E” rack.  

RAM Random Access Memory. RAM is used to store history, data, most user programs, and 
additional configuration data. 

RBX Report-by-exception. RBX always refers to Spontaneous RBX in which the ROC 
contacts the host to report an alarm condition. 

RR Results Register; stores the Signal Value Analog (SVA). 
Recipe A pre-entered delivery/blending/control description that allows the DL8000 to 

automatically control the product quantity or total quantity based on percentages of 
multiple components during a batch delivery operation. The DL8000 supports up to 
thirty recipes. 

RFI Radio Frequency Interference. 
RI Ring Indicator modem communications signal. 
ROC Remote Operations Controller microprocessor-based unit that provides remote 

monitoring and control. 
ROCLINK 800 Microsoft® Windows®-based software used to configure functionality in ROC units.  
ROM Read-only memory. Typically used to store firmware. Flash memory. 
Rotary Meter A positive displacement meter used to measure flow rate, also known as a Roots 

meter. 
RTC Real-Time Clock. 
RTD Resistance Temperature Device. 
RTS Ready to Send modem communications signal. 
RTU Remote Terminal Unit. 
RTV  Room Temperature Vulcanizing, typically a sealant or caulk such as silicon rubber.  
RS-232  Serial Communications Protocol using three or more signal lines, intended for short 

distances. Also referred to as the EIA-232 standard.  
RS-422 Serial Communications Protocol using four signal lines. Also referred to as the EIA-422 

standard.  
RS-485 Serial Communications Protocol requiring only two signal lines. Can allow up to 32 

devices to be connected together in a daisy-chained fashion. Also referred to as the 
EIA-485 standard. 

RX or RXD Received Data communications signal. 
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S 
SAMA Scientific Apparatus Maker’s Association.  
Script An uncompiled text file (such as keystrokes for a macro) that a program interprets in 

order to perform certain functions. Typically, the end user can easily create or edit 
scripts to customize the software. 

Side Stream The controlled stream, often called the ethanol product. The side stream is metered 
and can be controlled and measured. 

Side Stream 
Component 

A mix component measured by both a side stream meter and a primary blend stream 
meter. Ethanol is often referred as a side stream component.  

Side Stream 
Meter 

A meter that measures the side component (ethanol).  

Smart module A module, typically for the ROC800-Series or FloBoss 107 devices, having an on-
board processor which can execute a program.  

Soft Points A type of ROC point with generic parameters that can be configured to hold data as 
desired by the user. 

SP Setpoint, or Static Pressure. 
SPI Slow Pulse Input. 
SPK Speaker.  
SRAM Static Random Access Memory. Stores data as long as power is applied; typically 

backed up by a lithium battery or supercapacitor. 
SRBX Spontaneous Report-By-Exception. SRBX always refers to Spontaneous RBX in which 

the ROC contacts the host to report an alarm condition.  
Standard 
Quantity 

The gross quantity corrected to standard temperature and/or pressure. This is a 
quantity measurement. Calculation: standard quantity = gross quantity times CTLM 
(correction factor for the effect of temperature on the liquid in the meter) times CPLM 
(correction factor for the effect of pressure on the liquid in the meter)  

SVA Signal Value Analog. Stored in the Results Register, it is the analog value that is 
passed between functions in an FST.  

SVD Signal Value Discrete. Stored in the Compare Flag, it is the discrete value that is 
passed down the sequence of functions in an FST. 

System 
Variables 

Configured parameters that describe the ROC; set using ROCLINK software.  

T 
T/C Thermocouple Input. 
TCP/IP Transmission Control Protocol/Internet Protocol.  
TDI Time Duration Input. 
TDO Time Duration Output. 
Tf Flowing temperature. 
TLP Type (of point), Logical (or point) number, and Parameter number. 
Transaction Group of one or more consecutive batch deliveries for accounting purposes. The 

batches that comprise a transaction always use one recipe, one additive selection, and 
one loading side. An example of a transaction is the delivery of multiple batches to 
different compartments in a single tanker vehicle. 

Turbine meter A device used to measure flow rate and other parameters.  
TX or TXD Transmitted Data communications signal. 
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U 
Upload Send data, a file, or a program from the ROC to a PC or other host.  

V-Z 
V Volts. 
Volume The actual space occupied by the product measured, indicated in one of the following 

actual units: cubic meters, liters, barrels, gallons.  
Wild Stream Wild stream is the uncontrolled stream, often referring to the gasoline product. This is 

because the gasoline product cannot be exclusively metered, controlled, or measured. 
Wild Stream 
Component 

A product component measured as part of (Primary Blend Stream Component – Side 
Stream Component) a primary blend stream component by a primary blend stream 
meter is called a wild stream component. Gasoline is referred as wild stream 
component.  
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Appendix B – The FST Editor 

ROCLINK 800’s Function Sequence Table (FST) provides an 
instruction list programming language you can use to define and 
perform a set of specific actions when a set of conditions exists.  

In This Chapter 

B.1 FST Editor Overview....................................................................... B-1 
B.1.1 Using the FST Editor ......................................................... B-3 
B.1.2 FST Label Field ................................................................. B-4 
B.1.3 FST Command Field.......................................................... B-5 
B.1.4 FST Argument Fields......................................................... B-5 
B.1.5 FST Comment Fields......................................................... B-6 
B.1.6 FST Storage and Restart................................................... B-7 
B.1.7 Creating an FST ................................................................ B-7 
B.1.8 Creating an FST from an Existing File............................... B-8 
B.1.9 Compiling to Build and Viewing an FST ............................ B-8 
B.1.10 Downloading the FST to the FloBoss ................................ B-8 
B.1.11 Saving an FST ................................................................... B-9 
B.1.12 Starting the FST................................................................. B-9 
B.1.13 Stopping an FST................................................................ B-9 
B.1.14 Deleting an FST using Clear............................................ B-10 
B.1.15 Reading an FST From Device ......................................... B-10 
B.1.16 Reading an FST From File .............................................. B-10 
B.1.17 Closing an FST ................................................................ B-10 
B.1.18 Printing an FST................................................................ B-10 
B.1.19 Altering an FST Menu...................................................... B-10 
B.1.20 Troubleshooting an FST .................................................. B-11 

B.2 FST Monitor Mode ........................................................................ B-11 
B.3 FST Trace Mode........................................................................... B-12 
B.4 FST Command Library ................................................................. B-14 

B.4.1 FST Control-Related Commands .................................... B-16 
B.4.2 Defining a FST History Point ........................................... B-23 

B.5 Example FST ................................................................................ B-25 
 

B.1 FST Editor Overview 
You can write FSTs specifically for applications that require special 
control features, such as logic sequencing capability. For example, you 
can use an FST for emergency shutdown control when a parameter 
exceeds a low or high limit or in any application that requires logic 
sequencing capability. You program and configure FSTs using the FST 
Editor, which is included in ROCLINK 800 (Utilities > FST Editor).   

An FST defines the input-to-output (I/O) relationships in the FloBoss 
through a set of user-selected instructions, called functions. Functions 
define the specific actions to be performed and are executed in their 
specified sequence. Functions normally execute in top-to-bottom order; 
however, the sequence may be altered by certain decision-making 
functions. Functions consist of a command, an argument, and an 
optional label. 
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You build an FST from a library of commands that provide 
mathematical and logical operations, database access operations, 
historical commands, testing, branching operations, and control-related 
operations. Table B-1 displays the FloBoss FST capabilities.  

Table B-1. Device-specific FST Functionality 

Maximum Number  
of FSTs 

Maximum Byte Size per 
FST Maximum Line Length*

4 3000 400 
* Maximum number of steps 
 

Each FST may consist of as many functions as can fit into the memory 
reserved for the FSTs. Reserved memory is pre-determined by the 
FloBoss with a set amount of steps allocated for each FST. The byte 
size of an FST displays in the Code Size field on the Advanced tab of 
the FST Registers screen (Configure > Control > FST Registers).  

Because of the potential loading increase on the system, we recommend 
that you monitor the Master Processor Unit (MPU) loading, displayed 
on the Other Information tab on the Device Information screen (ROC > 
Information) to ensure that the FST is not consuming too much of the 
MPU’s resources.  

Note:  To reduce processor loading, use WAIT (WT) commands. 
Include an END command at the end of your FST.  

As the sequence of functions executes, two memory locations store 
intermediate results from one function to the next.  
 One location, called the Results Register (RR), stores a floating-

point value referred to as the Signal Value Analog (SVA).  
 The other location, called the Compare Flag (CF), stores a discrete 

value called the Signal Value Discrete (SVD).  

Depending on the command, the Results Register (RR) and the 
Compare Flag (CF) may be loaded, stored, tested, modified, or left 
unchanged.  

Note:  Since restart always clears FST registers (including the Run 
Flag), use softpoints to load initial values for the FST. 
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B.1.1 Using the FST Editor 
Using the FST Editor, you create, compile, debug, and download FSTs 
to the device. The FST Editor consists primarily of a workspace and 
menus, similar in structure to spreadsheet programs. The FST Editor 
also allows you to monitor and trace of an FST while it runs. 

Select Utilities > FST Editor or click the FST Editor button ( ) to 
launch the FST Editor. The FST Editor screen displays.  

 
Figure B-1. FST Editor 

The FST Editor provides a workspace, menus, and buttons for creating a 
Function Sequence Table. The title bar at the top of the workspace 
window identifies the FST being created or edited.  

The workspace area is a table, divided into rows and columns with the 
intersection called a cell. Cells are denoted by a box containing the 
cursor and a gray line around the cell. Use Tab and the arrow keys to 
move between cells, or you can go directly to a cell by clicking it with 
the mouse.  

The Header Line of the workspace contains the function structure 
column names. The STEP column contains the numbers that correspond 
to the number of rows or steps available in the workspace.  

The LABEL, CMD, ARGUMENT1, and ARGUMENT2 columns 
correspond to the structure of the functions. The Comment column 
allows you to insert comments about the FST.  

Note:  Comments are not downloaded (sent) to the FB107; they are only 
included in the FST when you save it to a file.  
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Table B-2. Workspace and Output Keystrokes 

Key Action 
→ Move cursor to the right cell or character. 

← Move cursor to the left cell or character. 

↑ Move cursor to the cell above it. 

↓ Move cursor to the cell below it. 
Backspace Delete the previous character. 
Ctrl + Home Move cursor to top left cell of Workspace. 
Ctrl + End Move cursor to bottom right cell of Workspace. 

Delete Delete character in front of the cursor position. 
End Within a cell, move cursor to the right-most position within the cell. 

Within a row, move cursor to the right-most position in the row 
Enter Process saves contents of cell entry and moves to the next cell. 
Esc Undo entry and display original or prior contents of the cell. 
F1 Help. 

Home Within a cell, move cursor to the left-most position within the cell. 
Within a row, move cursor to the left-most position within the row. 

Page Down Display next page of Workspace. 
Page Up Display previous page of Workspace 

Tab Move to the next cell. 
 

FST Function 
Structure 

Each function consists of a STEP number, a LABEL (optional), a 
command (CMD), and up to two arguments (ARGUMENT1 and 
ARGUMENT2). See Table B-3. 

Table B-3. FST Function Structure 

STEP LABEL CMD ARGUMENT 1 ARGUMENT 2 
0     

The FST program automatically provides the step numbers for each 
FST. You complete the other fields in the structure to build a function. 

Note:  Do not skip any steps. The FST program treats a blank step as 
the end of a program and does not compile correctly. 

B.1.2 FST Label Field 
The optional Label field allows you to uniquely identify a function. A 
label consists of up to six alphanumeric characters in any combination. 
A common practice is to use the label to identify the action the function 
performs. For example, the label “PUMPON” describes a function that 
activates a pump. 

Note:  Do not use the names of commands as labels.   
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Labels enable branching, the ability to direct the execution to a function 
other than the next function in the sequence. Table B-4 shows an 
example of branching. Step 0 instructs the program to GO to the label 
PMPOFF, as established by Argument 1 in step 0. The program then 
branches to step 2, where the LABEL PMPOFF is located, and performs 
that function.  

Table B-4. FST Label Field 

STEP LABEL CMD ARGUMENT 1 ARGUMENT 2
0  GO PMPOFF  
1 PUMPON DO DOU 4-1 1 
2 PMPOFF DO DOU 4-2 0 

B.1.3 FST Command Field 
The FST command (CMD) field specifies the action a function takes.  
Each command cell provides a drop-down list that shows the function 
commands and provides a brief description of how they operate on the 
RR, CF, and Argument values. You can also type commands directly. 
Table B-5 shows the use of the GO command. Refer to Table B-9 for a 
summary of each command.  

Table B-5. FST Command Field 

STEP LABEL CMD ARGUMENT 1 ARGUMENT 2 
0  GO PMPOFF  
 .    
 .    

12 PMPOFF VAL 3  

B.1.4 FST Argument Fields 
Depending on the command, arguments can be unused, references to 
parameters in the FloBoss (TLPs), numerical constants, or ASCII 
characters.  
Once you select a command, the argument cell requires that you either 
typing a numerical constant or ASCII text or click the TLP button for 
data selection.  
Depending on whether you have selected TLPs to display as numbers or 
as text (via Tools > Options in ROCLINK 800), the TLP appears in the 
argument cells as a number sequence or as a text abbreviation of the 
Type, Point number and Parameter.  
For example, the text abbreviation of the status parameter of discrete 
input module 4 channel 1 would be DIN4-1,STATUS. The Data #3 
parameter for softpoint 3 would be SFP 3,DATA3. 
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B.1.5 FST Comment Fields 
Use the Comment field to enhance readability and provide a place to 
document the purpose of an FST, Step, group of Steps, and save 
information within the FST. Comments are discarded when an FST is 
compiled and downloaded to the device. Comments remain with the 
FST when it is saved to a disk file. 

FST Function 
Examples 

A function consists of a command, its associated arguments, and an 
optional label. In the example shown in Table B-6, the Value (VAL) 
command in Step 0 writes the current process value of analog input 
(module 3, channel 1) in EUs to the Result Register (RR), which is 
implied. The label in this example (CKHIAL) serves only as a 
comment, since no other function branches to it. 

Table B-6. FST Function Examples 

STEP LABEL CMD ARGUMENT1 ARGUMENT2 
0 CKHIAL VAL AIN 3-1,EU  
1  >= AIN 3-1,HIAL PUMPON 

In this example, when the RR value from step 1 equals or exceeds (>=) 
the High Alarm value (VAL) in step 2 and the High Alarm limit 
(HIAL) condition is met, the FST branches to the PUMPON label to 
turn the pump on. 

Note:  Refer to the FST User Manual (Form A4625) for additional 
examples. 

Basic Rules for 
Creating FSTs 

You should be aware of several rules when creating FSTs.  

 An END command is required at the end of every FST. The END 
command tells the FST to return to the top of the first step and begin 
to run from the first line at step 0 or to the step where the FST 
begins. However, you can use a branching function to force the FST 
to immediately return to step 0 if you do not want to wait for the 
next execution cycle to begin. If an END command is not present, 
the FST Editor automatically adds the END command when 
compiling. 

 The first blank line found in an FST is automatically converted to 
the END command. Any commands following a blank line are lost.  

 Each FST can have only one END.  
 Avoid internal loops and direct the program flow to the END 

Command. Use Wait states (WT command) to suspend operation of 
the FST whenever possible to reduce MPU processor overload, 
especially in a loop in which a condition is being repeatedly 
checked. 

 Configure the I/O parameters before referencing them in an FST. 
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 When using any branching command (GO, <, >, <=, >=, ==), make 
sure that you have defined the label that the command references.  

B.1.6 FST Storage and Restart 
This section details what FST configuration data is stored when a write 
to Internal Configuration Memory (EEPROM) is performed, and what 
happens to the FST after a Cold Start, Warm Start, or after upgrading 
the FloBoss firmware. 
 Write to Internal Config Memory – FSTs are permanently saved 

to memory. 
 Warm Start – If an FST is saved to memory and it is active 

(running) when a restart occurs, FSTs automatically restart at the 
beginning STEP.  

 Cold Start – On a Cold Start, FST Registers will be cleared, but 
will be restored from Internal Config Memory if valid. However, if 
you perform a “Cold Start & Clear FSTs” or a “Cold Start & Clear 
ALL” type of Cold Start, the FSTs are permanently cleared from 
Internal Config Memory. 

 Upgrading Firmware – If an FST is saved to memory and it is 
active (running) when a firmware upgrade occurs, FSTs will be 
turned off and need to be MANUALLY restarted. 

B.1.7 Creating an FST 
You can create an FST either by entering the steps in a blank workspace 
or by editing an existing file from a device or from a disk file.   

To create an FST while on-line with an FB107:  

1. Start the ROCLINK 800 software and connect to the device.  

2. Select Utilities > FST Editor. 

3. Select the tab of the FST (FST 1 through FST 6, depending on the 
device). 

4. Fill in each step with the appropriate labels, commands, tags, and 
arguments.  

 When you select the Command field, the  button appears. 
Click this button to display a list of commands from which to 
choose. Alternately, you can type the three-character command 
in the Command field.  

 Depending upon which command you choose, the argument 
fields prompt you to type in a label, choose a TLP, or enter some 
other data. 

 The Label field is optional, but are may be required if you are 
using a label within a command. Enter all required labels to 
prevent a compile error. 

 Place an End command at the end of your FST. 
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B.1.8 Creating an FST from an Existing File 
Use the following steps to create an FST by editing an existing FST. 
You may use either a FST from the device or a FST file on your PC.  

If you are using a file from the device, connect the FB107 to the 
computer running ROCLINK 800 software. 

1. Select Utilities > FST Editor. 

2. Select File > Read > From File or File > Read > From Device. 

3. Open an existing FST file with the .FST extension. 

4. Edit each step with the appropriate command, label, and arguments.  

 The Label field is optional, but are may be required if you are 
using the label within a command. Enter all required labels to 
prevent a compile error. 

 When you select the Command field, the  button appears. 
Click this button to display a list of commands from which to 
choose. Alternately, you can type the three-character command 
in the Command field.  

 Depending upon which command you choose, the Argument 
fields prompt you to type in a label, choose a TLP, or enter some 
other data. 

 Place an End command at the end of your FST.  

B.1.9 Compiling to Build and Viewing an FST 
To build and compile an FST:  

Select FST Build > Compile or click Build. 

The compiled file displays in the Output FST field. If invalid points 
exist in the FST during compilation, you receive an error indicating 
which Point Number is missing.  

Note:  If an error occurs during the compile process, the Output field 
lists the error type and the cell in question turns red. Correct all 
errors and recompile. 

Compile errors occur when you:  
 Enter invalid arguments or commands in the FST.  
 Perform a compile. The error displays in the Output field. 
 Open an FST from a FloBoss or disk file. 

B.1.10 Downloading the FST to the FloBoss 
To download the FST to FloBoss memory: 

1. Click Download on the toolbar or select File > Download.  
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2. If the FST currently loaded is operating, you will be prompted to 
stop the FST and continue with the download or to stop the FST 
without downloading. 

3. Enter the Version number and Description of the FST, for later 
identification, and click OK.  

Note:  This step is not required, but is extremely helpful when you 
need to identify or debug your FST.  

Following the download, you will be prompted to start the FST or you 
can start the FST in Monitor Mode or the FST Register screen. To 
verify the FST logic, you may desire to start the FST in Trace Mode. 

B.1.11 Saving an FST 
To save the FST as an individual disk file: 

1. Select FST > Save as or click the Write to file button in the FST 
Editor (see Figure B-1).  

2. Enter the File name and click Save. The FST file will be saved with 
an .fst extension. 

 

 
Figure B-2. FST Editor Toolbar 

B.1.12 Starting the FST 
Once an FST is compiled (Build > Compile) without errors and is 
downloaded to the FloBoss, you must start the FST before it can run.   

1. Connect the FloBoss to the computer running ROCLINK 800. 

2. Select Configure > Control > FST Register. 

3. Select the desired FST from the drop-down list box.  

4. Select the Status Enabled radio button. 

5. Click Apply and click OK. 

B.1.13 Stopping an FST 
To stop the execution of an FST:  

1. Connect the FloBoss to the computer running ROCLINK 800. 

2. Select Configure > Control > FST Register. 
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3. Select the desired FST from the drop-down list box.  

4. Select the FST Status Disabled radio button. 

5. Click Apply and click OK. 

B.1.14 Deleting an FST using Clear 
To permanently delete an FST: 

1. Select FST > Clear. 

2. Select the desired FST (FST1 to FST4). 

B.1.15 Reading an FST From Device 
The FST menu allows you to select FSTs to Read. 

 
Select FST > Read > From Device to retrieve the contents of 
the FloBoss memory and load the FST in the selected 
Workspace.  

B.1.16 Reading an FST From File 
The FST menu allows you to select FSTs to Read. 

 
Select FST > Read > From File to retrieve the contents of a 
disk file and display the FST in the selected Workspace.  

 Notes:  
 If invalid points exist in the FST, you receive an error 

indicating which Point Number is missing. 
 The Output view is populated with data when a Compile 

operation is performed or when an FST is read from the 
FloBoss.  

B.1.17 Closing an FST 
Select FST > Close to exit the FST Editor or Monitor screen.  

B.1.18 Printing an FST 
In the FST Editor, select FST > Print Preview to print an FST or export 
it to a file. A printed FST can help you in troubleshooting. 

When the Print Preview screen appears, click the Print button to send 
the FST to a printer. You may also select the PDF, Excel, or RTF 
buttons to export the FST as a file in those formats. 

B.1.19 Altering an FST Menu 
The FST Editor Edit menu provides options for altering a FST.  
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Select Edit > Insert Step to place a blank line in the Workspace 
before the current line. Use this option to add a function between 
two existing functions.  

 
Select Edit > Delete Step to delete the current line from the 
Workspace.  

 
Select Edit > Erase Workspace to erase the contents of the 
current Workspace permanently. You can save the FST to a file 
before you erase the Workspace.  

 

 Caution Avoid using the Windows Cut (Ctrl+X), Copy (Ctrl+C), and Paste (Ctrl+V) 
commands to manipulate text in the FST Editor. Also, be aware that the 
FST Editor does not insert but OVERWRITES existing fields.   

 
Monitor and Trace are two additional modes of operation for the FST 
Editor. Monitor mode allows you to continually view the present 
contents of the FST structure in the device as it is modified. Trace mode 
allows you to examine execution of an FST one step at a time for 
debugging purposes.  

B.1.20 Troubleshooting an FST 
An execution error, which occurs when the FST references a Point 
Number that has been removed or changed, will stop an FST.  

If a compile error occurs during the compile process (Build > 
Compile), the Output field lists the error type and the cell in question 
turns red. Execution errors are caused by changes in the FloBoss 
configuration after the download of an FST. This may include removal 
of I/O or other logical points the FST uses. 

In Monitor mode, the Run Flag Status (RF) indicates execution errors:  
RF Meaning 
0 Indicates the FST is not running. 
1 Indicates the FST is running. 

5 Indicates the FST has shut down due to an invalid point reference 
(usually an out-of-place or unexpected I/O). 

8 Indicates the FST Editor has initiated Trace mode. 
 
When an FST fails (as indicated by an RF value of 5), you can view at 
which Instruction Pointer (IP) the FST failed. 

B.2 FST Monitor Mode 
When on-line, use the FST Monitor menu to select which FST to 
monitor; turn Trace mode on and off; close the FST; pause or resume an 
FST; monitor registers, timers, miscellaneous registers, messages; or to 
compare flag options. 
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To start Monitor mode to display the selected FST, select the desired 
FST from the Monitor menu while on-line with the FloBoss or click the 
Monitor button from within the open workspace to monitor that FST. 
You can edit FST fields located on the right side of the Monitor screen 
by highlighting the field, typing the value, and pressing Enter. The new 
value is written to the FST and read back on the next update. 

The Help Status Line at the top of the Monitor indicates the status of the 
Monitor and Trace Modes. 

The Parameter and Data fields include:  

Field Description 
CF Compare Flag, an 8-bit integer representing the 

numbers 0 through 255. Often referred to as the 
Signal Value Discrete (SVD).  

CF Bny The Compare Flag displays as both the integer value 
and the binary value (bit 7 to the left and bit 0 to the 
right).  

RF Run Flag. Valid values are:  

 0 Indicates the FST is not running. 
 1 Indicates the FST is running. 
 5 Indicates FST has shut down due to an invalid 

point reference (usually an out-of-place or 
unexpected I/O). 

 8 Indicates the FST Editor has initiated Trace 
mode. 

 When an FST fails (as indicated by an RF value of 
5), you can view at which Instruction Pointer (IP) the 
FST failed. 

IP Instruction Pointer. Indicates the storage location in 
the FST of the next function to be executed. One 
storage location is used for each byte that stores the 
function. 

Size The number of bytes reserved for the FST program 
in bytes. Equivalent to the end pointer value minus 
the start pointer value. 

Brk The delay, in 100 millisecond intervals, between the 
execution of successive FST Commands or 
functions.  

RR The Results Register or accumulator, sometimes 
referred to as the Signal Value Analog (SVA), is a 
floating-point value passed between functions or 
FSTs.  

R1 through R10 Ten floating-point registers for each FST. The 
floating-point registers are used for global storage, 
and register contents can be called into any of the 
FSTs configured for a FloBoss. 

Timer 1 through 
Timer 4 

Four timers. When set greater than “0”, they 
decrement by “1” every 100 milliseconds. A timer can 
be set using the Set Timer (ST) Command or by 
saving the RR (Results Register) directly to the timer 
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Field Description 
parameter using the SAV Command. The Check 
Timer (CT) Command is used to compare the timer 
to “0”. When greater than “0”, it branches to the 
desired LABEL. 

MSG1 Character field for storing a message.  
MSG2 Not used by the FST. A value can be written to 

MSG2 using the FST Registers point or a ROC 
Display field and viewed while monitoring or tracing 
the FST.  

MSG Data Displays any values associated with MSG1.  
MISC 1 through  
MISC 4 

Single-byte registers that can be written to and the 
value can be used by the FST. Valid value is 0 to 
255.  

 

Table B-7. Monitor and Trace Mode Keystrokes 

Key Action Key Action 
↑ Move cursor to the cell above it. End Move cursor to the right-most cell. 

↓ Move cursor to the cell below it. F1 Help. 
Ctrl + End Display last entry in Workspace. F6 Execute current FST command. 

Ctrl + Home Display beginning of Workspace. Home Move cursor to the left-most cell. 
Page Down Display next page of Workspace. Page Up Display previous page of Workspace.

B.3 FST Trace Mode 
In Trace mode, you can view at which Instruction Pointer (IP) the FST 
failed. Print the FST to assist in troubleshooting. 

When on-line, the FST Editor uses a Trace mechanism that provides the 
ability to debug FST program logic. Trace executes the FST function 
indicated by the Instruction Pointer (IP), moves the Instruction Pointer 
to the next FST function to be executed, and then stops. You are given 
the opportunity to examine the results of the FST function and 
determine the next FST function to be executed. The location of the 
action depends on the nature of the command. The action may be traced 
to the history log, I/O value, Point Numbers, softpoint, and so on. 

The command executed is determined by comparing the Instruction 
Pointer (IP) shown on the Monitor screen to a list of all Instruction 
Pointers and their corresponding commands. Trace thereby verifies 
proper execution and sequencing of the FST functions. 

Note:  Before entering Trace mode, print out an Instruction Pointer 
listing of the FST. 

After entering Trace mode from a newly compiled FST, the FST starts 
at the first STEP. After entering Trace mode from an executing FST, the 
FST starts at the STEP being executed.  
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Note:  When you attempt to Trace an FST that contains WT, BRK, ST, 
or CT commands, a pause in the sequencing can occur until the 
command conditions are met. 

Other Trace commands include: 
 Select Monitor > Trace On to turn on Trace mode. 
 Select Monitor > Pause to stop the FST at the current command. 
 Select Monitor > Resume to start the FST at the current command. 
 Select Monitor > Trace Off to turn off Trace mode. 
 Select Monitor > Next Step to turn off Trace mode. 

B.4 FST Command Library 
Commands are identified by a name that consists of one or more 
characters or mathematical symbols. In the FST Editor, select the CMD 
field and perform one of the following: 
 Type the Command. 

 Click the  button.  
This opens a list of commands, the command names, and their 
descriptions (actions). See Table B-8, which describes the terms RR 
and CF used in the command descriptions (actions). 

Table B-9 presents each command name along with a brief description 
(action), the Arguments (ARGUMENT1 or ARGUMENT2) required, and 
the effect each operation has on the RR and CF. In the explanation of the 
operation, if RR or CF is not mentioned, then the current content is not 
affected and remains unchanged. In general, the CF is affected only by 
logical commands. 

Table B-8. FST Command Library Conventions 

Convention Description 
RR (in) The value or contents of the Results Register (RR), Signal Value Analog (SVA) prior to 

execution of the function (command). 
RR (out) Output value from Results Register (RR). 
CF (in) The value or contents of the Compare Flag (CF), Signal Value Discrete (SVD), prior to 

execution of a function (command). 
CF (out) The contents of the Compare Flag (CF), following execution of the function (command). 

Table B-9. FST Command Summary 

Category Command Action 
Math + RR = RR + ARGUMENT1 (add) 
 – RR = RR – ARGUMENT1 (subtract) 
 * RR = RR * ARGUMENT1 (multiply) 
 / RR = RR / ARGUMENT1 (divide) 
 ** RR = RR raised to power of ARGUMENT1 
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Category Command Action 
 ABS RR = Absolute value of RR 
 EXP RR = “e” (2.71828) raised to power of RR 
 INT RR = Integer value of RR 
 LOG RR = Log (base 10) of RR 
 LN RR = Natural Log of RR 
 SQR RR = Square root of RR 
 P3 RR = 3rd-order polynomial (R1, R2, R3, R4) 
Logical NOT SVD = NOT SVD (0 ≥ 1; > 0 ≥ 0) 
 AND SVD = SVD AND ARGUMENT1 
 OR SVD = SVD OR ARGUMENT1 
 XOR SVD = SVD XOR ARGUMENT1 
Comparison == If RR = ARGUMENT1, go to ARGUMENT2 LABEL 
 != If RR <> ARGUMENT1, go to ARGUMENT2 LABEL 
 < If RR < ARGUMENT1, go to ARGUMENT2 LABEL 
 <= If RR <= ARGUMENT1, go to ARGUMENT2 LABEL 
 > If RR > ARGUMENT1, go to ARGUMENT2 LABEL 
 >= If RR >= ARGUMENT1, go to ARGUMENT2 LABEL 
Time ST Set Timer # ARGUMENT1 to ARGUMENT2 100 mSec intervals 
 CT If Timer # ARGUMENT1 > 0, go to LABEL ARGUMENT2 
 WT Suspend FST execution for ARGUMENT1 sec 
 DWK RR = Day of Week (1=Sunday, 7=Saturday) 
 MND RR = Minutes since midnight 
Control AO Set AO# ARGUMENT1 output = ARGUMENT2 EUs 
 DO Set DO# ARGUMENT1 status = ARGUMENT2 
 TDO Force discrete output Recalculation 
Database VAL RR = Value specified in ARGUMENT1 
 SAV Write RR to variable specified in ARGUMENT1 
 RDB Read History Value into RR 
 WDB Write RR Value to History 
 WTM Write Current Time to History 
 DHV Read Daily History Value into RR 
 DHT Read Daily History Time Stamp into RR 
 PHV Read Periodic History Value into RR 
 PHT Read Periodic History Time Stamp into 
 MHV Read Minute History Value into RR 
 DIS Read Starting Daily History Index into RR 
 DIN Read Number of Daily History Indexes into RR 
 PIS Read Starting Periodic History Index into RR 
 PIN Read Number of Periodic History Indexes into RR 
 GTE Extract Time Element from Time Stamp into RR 
Miscellaneous GO Jump to STEP pointed to by ARGUMENT1 LABEL 
 MSG MSG String #1 = ARG1; MSG Data = ARG2 



ROCLINK 800 User Manual (FB107) 

B-16 FST Editor Issued Jan-08 

Category Command Action 
 END End of FST...restart at beginning 
 BRK Delay ARGUMENT1 100 mSec intervals  
 ALM Log 10-character message and a current value 
 EVT Log 10-character message and a current value 

B.4.1 FST Control-Related Commands 
Use analog output (AO), discrete output (DO), and Timed Duration 
Output (TDO) control-related commands to control outputs.  

Table B-10. FST Control-Related Commands 

Name Description Arguments Results 
AO Analog output. Sets the analog output 

point EUs to the argument value. If the 
analog output is in Manual, no output is 
sent. 

1. Output: AO Point 
Database Value 

2. Input: Database or 
Constant Value 

AO Output (ARG1) = ARG2 
 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

DO Discrete output. Sets the discrete output 
point status to the argument value. If the 
discrete output is in Manual, no output is 
sent. 

1. Output: DO Point 
Database Value 

2. Input: Database or 
Constant Value 

DO Output (ARG1) = ARG2 
 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

 

Note:  To trigger outputs, use the corresponding output command (see 
Table B-9). These commands trigger the mechanism that changes 
the output value. 

The analog output (AO) command sends the analog value specified in 
ARGUMENT2 to the analog Point Number specified in ARGUMENT1. 
The analog value is not sent if the analog Point Number is in Manual 
Mode. The check for Manual Mode is included as a safety feature and 
permits the FST to continue operation if the device connected to the 
analog output is being serviced.  

If a PID loop is controlling the analog output, placing the PID loop into 
Manual Tracking Mode allows the FST to send a value to the output 
parameter of the PID. For other active PID modes, the FST and PID will 
be in conflict. 

FST Mathematical  
Commands 

The mathematical commands provide simple arithmetic or mathematical 
operations. Such operations include addition (+), subtraction (–), 
multiplication (*), division (/), raise to power (**), absolute value 
(ABS), “e” raised to a power (EXP), truncate to integer (INT), base 10 
logarithm (LOG), natural logarithm (LN), square root (SQR), and 3rd-
order polynomial (P3). 

Note:  No operation occurs with the LOG, LN, power (**), and SQR 
commands if the Results Register is less than or equal to zero.  

Table B-11. FST Mathematical Commands 
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Name Description Arguments Results 
+ Add value to RR(in) 1. Input: Database or 

Constant Value 
RR(out) = RR(in) + ARG1 
SVD(out) = SVD(in) 

– Subtract value from RR(in) 1. Input: Database or 
Constant Value 

RR(out) = RR(in):ARG1 
SVD(out) = SVD(in) 

* Multiply RR(in) by value 1. Input: Database or 
Constant Value 

RR(out) = RR(in) * ARG1 
SVD(out) = SVD(in) 

/ Divide RR(in) by value 1. Database or Constant 
Value 

If ARG1 = 0.0: 
RR(out) = RR(in), SVD(out) = SVD(in) 

   Otherwise:  
RR(out) = RR(in) / ARG1 

** Raise RR(in) to a power 1. Input: Database or 
Constant Value 

RR(out) = RR(in) ** ARG1 

ABS Absolute Value of RR(in) None RR(out) = |RR(in)| 
SVD(out) = SVD(in) 

EXP “e” to the power of RR(in) None RR(out) = e ** RR(in) 
SVD(out) = SVD(in) 

INT Integer part of RR(in) None RR(out) = (int) RR(in) 
SVD(out) = SVD(in) 

LOG Logarithm (base 10) of 
RR(in) 

None If RR(in) > 0.0: 
RR(out) = LOG[RR(in)], SVD(out) = 
SVD(in) 
Otherwise: 
RR(out) = RR(in), SVD(out) = SVD(in) 

LN Natural Logarithm of 
RR(in) 

None If RR(in) > 0.0: 
RR(out) = LN[RR(in)], 
SVD(out) = SVD(in) 
Otherwise: 
RR(out) = RR(in), 
SVD(out) = SVD(in) 

SQR Square Root of RR(in) None If RR(in) >= 0.0: 
RR(out) = SQRT[RR(in)], 
SVD(out) = SVD(in) 
Otherwise: 
RR(out) = RR(in), 
SVD(out) = SVD(in) 

P3 3rd-order Polynomial None RR(out) = [reg1 * (RR(in) ** 3)] 
+ [reg2 * [RR(in) ** 2)] 
+ [reg3 * [RR(in) ** 1)] 
+ reg4 
where reg1 through reg4 are the current 
constant values of Register 1 through 
Register 4 of the respective FST 
SVD(out) = SVD(in) 

 

FST Logical  
Commands 

You can store a discrete value called the Signal Value Discrete (SVD) 
in the Compare Flag (CF). The SVD is stored as an 8-bit byte.  The CF 
is true whenever non-zero, and the CF is false when zero. 
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Logical commands operate upon the Compare Flag (CF). Prior to 
execution of a logical command, the CF must be loaded with an 8-bit 
value by using the SAV command. 

The bit-wise logical commands (AND, OR, NOT, and XOR) apply 
Boolean operations on two 8-bit integers, bit-by-bit. The two 8-bit 
integers are the CF and the value defined by ARGUMENT1 of the 
logical command. Note that this value is then converted by the software 
into an 8-bit unsigned integer. This value is used as a binary number 8 
bits long as described next. 

Each bit is weighted as a power of two, and the bit position determines 
which power of two. The bit, either 0 or 1, is multiplied by the 
respective bit weight. The resulting binary number is read from right to 
left, with the right-most bit representing bit 0, and the left-most bit 
representing bit 7. 

For example, the integer 42 is equivalent to the binary number 
00101010 as shown next, where bit 0 is the right-most bit: 

Bit Binary # * Weight = 
Bit 7 = 0 * 27 = 0 * 128 = 0 
Bit 6 = 0 * 26 = 0 * 64 = 0 
Bit 5 = 1 * 25 = 1 * 32 = 32 
Bit 4 = 0 * 24 = 0 * 16 = 0 
Bit 3 = 1 * 23 = 1 * 8 = 8 
Bit 2 = 0 * 22 = 0 * 4 = 0 
Bit 1 = 1 * 21 = 1 * 2 = 2 
Bit 0 = 0 * 20 = 0 * 1 = 0 

Total = 42 

Table B-12. FST Logical Commands 

Name Description Arguments Results 
NOT Logical NOT of SVD(in) None If SVD(in) > 0, SVD(out) = 0 

Otherwise: SVD(out) = 1 
RR(out) = RR(in) 

AND Logical AND ARG1 with SVD(in) 1. Input: Database or Constant 
Value 

RR(out) = RR(in), 

RR(out) = RR(in), OR Logical OR ARG1 with SVD(in) 1. Input: Database or Constant 
Value SVD(out) = [SVD(in) OR ARG1] 

RR(out) = RR(in), XOR Logical XOR ARG1 with SVD(in) 1. Input: Database or Constant 
Value SVD(out) = [SVD(in) XOR ARG1]

 

FST Comparison  
Commands 

Use comparison commands to compare values. Comparison commands 
conditionally compare two values, and branch to a different sequence of 
commands if the comparison is determined to be true. Otherwise, if the 
comparison is determined to be false, no branching occurs and the next 
command in sequence is executed. Comparison commands test values 
for equivalence (==), non-equivalence (!=), less than (<), less than or 
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equal to (<=), greater than (>) , and greater than or equal to (>=). 

Table B-13. FST Comparison Commands 

Name Description Arguments Results 
== Test If RR(in) equals ARG1. 

Note that this command performs in a 
bit-wise fashion, so two floating Point 
Numbers displayed as equal may not 
match. 

1. Input: Database or Constant 
Value 
2. LABEL 

If RR(in) = ARG1, Goto ARG2 
Otherwise: continue to next 
command 
SVD(out) = SVD(in) 

!= Test If RR(in) Not Equal to 
ARG1. 

1. Input: Database or Constant 
Value 
2. LABEL 

If RR(in) != ARG1, Goto ARG2 
Otherwise: continue to next 
command 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

< Test If RR(in) less than ARG1. 1. Input: Database or Constant 
Value 
2. LABEL 

If RR(in) < ARG1, Go to ARG2 
Otherwise: continue to next 
command 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

<= Test If RR(in) less than or equal 
to ARG1. 

1. Input: Database or Constant 
Value 
2. LABEL 

If RR(in) <= ARG1, Go to ARG2  
Otherwise: continue to next 
command 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

> Test If RR(in) greater than 
ARG1. 

1. Input: Database or Constant 
Value 
2. LABEL  

If RR(in) > ARG1, Go to ARG2 
Otherwise: continue to next 
command 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

>= Test if RR(in) greater than or 
equal to ARG1. 

1. Input: Database or Constant 
Value 
2. LABEL 

If RR(in) >= ARG1, go to ARG2  
Otherwise: continue to next 
command 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

 

FST Time-Related  
Commands 

Use time-related commands (FST Timers) to implement simple time-
related operations, such as setting Timers, checking Timers, 
determining if Timers have elapsed, wait time before continuing, and 
imposing a delay upon each command executed.  

Timers are used to branch the FST to a specific Label after a specified 
period of time following an action. Up to four Timers are available for 
use in an FST and each Timer has a time interval of 100 milliseconds. 
Each FST Timer decreases by 1 interval if the Timer value is greater 
than 0.  

Command Description 
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Command Description 
Set Timer (ST) The ST command sets any one of the four available 

Timers for any of the available FSTs. ARGUMENT1 
specifies the number of the Timer to set and 
ARGUMENT2 specifies the number of intervals to 
which the Timer is set. 

Check Timer (CT) When executing a loop repeatedly in an FST, it is 
recommended a timer (CT) be included so the loop 
executes only once every time interval. This prevents 
the loop from executing several times within the 
allotted task period, eliminating unnecessary 
calculations that could deprive time from other tasks. 

Wait (WT) The Wait (WT) command imposes a delay, entered 
in seconds and tenths of seconds, before executing 
the next command. For example, entering a value of 
0.1 implies a 100-millisecond delay and a value of 
1.0 implies a one-second delay.  

Day of Week (DWK) 
and Minutes Since 
Midnight (MND) 

These commands are written to the Results Register. 
For DWK, 1=Sunday through 7=Saturday. 

 

Table B-14. FST Time-Related Commands 

Name Description Arguments Results 
ST Set Timer for specified FST with 

value in 100 mSec intervals.  
1. Output: FST Point 
Database Value 
2. Input: Database or 

Constant Value 

FST Timer (ARG1) = ARG2 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

CT Check Timer for specified FST with 
value in 100 mSec intervals.  

1. Input: FST Point Database 
Value 
2. LABEL 

If FST Timer (ARG1) = 0, 
continue to next command.  
Otherwise, Goto ARG2. 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

WT Wait – suspend FST until specified 
number of seconds (ARG1) have 
elapsed. The number of seconds 
can be from 0.1 to 999,999.  

1. Input: Database or 
Constant Value 

Delay ARG1 seconds 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

DWK Day of Week – sets RR (out) to the 
day of the week (1=Sunday, 
7=Saturday). 
Note:  The DWK function requires 

that you correctly set the real-
time clock.  

None RR(out) = Day of Week 
SVD(out) = SVD(in) 

MND Minutes Since Midnight – sets RR 
(out) to the number of minutes past 
midnight. 

None RR(out) = Minutes 
SVD(out) = SVD(in) 

 

FST Miscellaneous 
Commands 

Use the miscellaneous commands to move around FSTs and end FSTs. 
Miscellaneous commands provide operations, such as an unconditional 
go to (GO), message to local display panel (MSG), alarms (ALM), and 
event (EVT) generation, end of the FST (END), and delay (BRK). 
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Command Description 
GO Executes an unconditional branch to the LABEL in 

ARGUMENT1. Branching can direct the FST to a 
step before or after the current step.  

Message Provides a 30-character message and value for 
viewing on the local display panel.  

Break Imposes a delay (Break period), in 100-millisecond 
intervals, before executing the next command. Once 
the break period is set to a value other than zero, a 
delay in 100-millisecond or 1 second intervals occurs 
between the executions of each subsequent 
command. 

End Completes execution of the FST and waits for the 
next FST execution cycle before returning to the first 
STEP of the FST. The END command can only be 
used once in an FST. If omitted, End is appended to 
the FST by the FST Editor at compile time following 
the first empty Command field. 

Alarm and Event Log Log a 10-character message and the current value of 
the selected parameter to the respective log.  

 

Table B-15. FST Miscellaneous Commands 

Name Description Arguments Results 
GO Go to specified LABEL. 1. LABEL Goto ARG1 

RR(out) = RR(in) 
SVD(out) = SVD(in) 

BRK Break delays execution of each 
command after this one for the 
number of 100 millisecond intervals 
defined by ARGUMENT1. 

1. Input: Database or Constant 
Value 

FST break time = ARG1 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

END End of FST returns to first 
command. 

None Execute FST starting with first 
command. 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

MSG LCD Message sends message 
(ARGUMENT1) and value 
(ARGUMENT2) to local display 
panel. One 30 character message 
can be sent by each FST as shown 
next: 
 
xxxxxxxxxxxxxxxxxx 
xxxxxxxx ARG2 VAL 
yyyyyyyy zzzzz.zz 
SCAN NEXT PREV MENU 
xxxx ...message 
yyyy ...FST Tag name 
zzzz ...ARGUMENT2 value 

1. Input: Message 
2. Input: Database or Constant 
Value 

FST Message String(ARG1) 
FST Message Value(ARG2) 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

ALM Log Alarm records message 1 .Input: Message Log Alarm(ARG1, ARG2) 
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Name Description Arguments Results 
(ARGUMENT1) and value 
(ARGUMENT2) in the Alarm Log. 
Only the first 10 characters of the 
30 character messages are used. 

2. Input: Database or Constant 
Value 

RR(out) = RR(in) 
SVD(out) = SVD(in) 

EVT Log Event records message 
(ARGUMENT1) and value 
(ARGUMENT2) in the Event Log. 
Only the first 10 characters of the 
30 character message are used.  

1. Input: Message 
2. Input: Database or Constant 
Value 

Log Event(ARG1,ARG2) 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

Note: The ALM and EVT functions can quickly overfill the allotted log space of alarms and events. It is 
important to assure that these two functions do not operate continuously. 

 

FST Database 
Commands 

Database commands provide access to the configuration and historical 
databases. Operations include reading and writing configuration 
parameters and reading, writing, storing values from historical 
databases, and time stamping values to a History Point. 

 

Command Description 
VAL Loads the Results Register (RR) with the value 

defined in ARGUMENT1. ARGUMENT1 can be a 
constant or any database parameter available to the 
FST. The value defined in ARGUMENT1 is 
converted to floating point data type and written to 
the Results Register. 

SAV Writes the Results Register (RR) value to any 
database parameter available to the FST as defined 
in ARGUMENT1.  

WDB, WTM, and RDB These historical database commands, Write to 
Historical Database (WDB), Write Time to Historical 
Database (WTM), and Read Historical Database 
(RDB), allow you to establish a non-periodic history 
database (one that has no specific time interval), a 
periodic history database (one that has a specific 
time interval), or a storage array for data (similar to a 
softpoint).  
For the FST historical database commands to work, 
a History Point has to be configured correctly for a 
FST History Point as either FST Time Archive Type 
or FST Data Archive Type. Refer to Section B.4.2, 
Defining a FST History Point.  
The FST for a History Point uses one of the historical 
database commands and two Arguments. 
ARGUMENT1 contains the history database point 
number. ARGUMENT1 can be a constant or a 
parameter with a value between 1 through 87. 

ARGUMENT2 Provides an index or pointer to the history storage 
array. The history storage array holds entries taken 
at either set intervals (typically daily, hourly, and 
each minute) or user-configurable intervals. For 
information on the intervals and number of entries, 
refer to the history database specifications instruction 
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Command Description 
manual. ARGUMENT2 should be a Soft point or FST 
register. The history point defined by ARGUMENT1 
will be logged at the index location defined by 
ARGUMENT2. 

 

Table B-16. FST Database Commands 

Name Description Arguments Results 
VAL Load RR sets the RR(out) to the argument 

value. 
1. Input: Database 

or Constant 
Value 

RR(out) = ARG1 
SVD(out) = SVD(in) 

SAV Store RR sets the argument to the RR(in). 1. Output: 
Database Value

ARG1 = RR(in) 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

RDB Read Historical Database sets the RR(out) 
to the historical database value of the 
specified database point (ARGUMENT1) 
and the specified pointer (ARGUMENT2) 
to the historical database value. Applies to 
historical database points defined for the 
FST only.  
If ARGUMENT2* is a floating database 
value (for example: @FST1, FST SEQ# 1, 
R8), the command increments 
ARGUMENT2 to the next historical 
database value and sets it to 0 when the 
number of archived historical periods are 
exceeded. Otherwise, no effect occurs to 
ARGUMENT2. 
Note:  Each ARGUMENT2 must be 

unique.   

1. Input: Database 
or Constant 
Value 

2. Output: 
Database or 
Constant Value 

For FST History Point: 
RR(out) = History Value(ARG1,ARG2)
For floating database value ARG2: 
If ARG1 >= No. of archived periods 
(ARG1), then ARG2 = 0 
Otherwise, ARG2 = ARG2 + 1 
For all other cases: 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

WDB Write To Historical Database sets the 
RR(in) to the value of the database point 
(ARGUMENT1) and the pointer 
(ARGUMENT2). Applies to historical 
database points defined for the FST only.  
If ARGUMENT2* is a floating database 
value (for example: @FST1, FST SEQ# 1, 
R8), the command increments 
ARGUMENT2 to the next historical 
database value and sets it to 0 when the 
number of archived historical periods are 
exceeded. Otherwise, no effect occurs to 
ARGUMENT2. 
Note:  Each ARGUMENT2 must be 

unique. 

1. Output: 
Database or 
Constant Value

2. Output: 
Database or 
Constant Value

For FST History Point: 
History Value (ARG1, ARG2) = 
RR(in).  
For floating database value ARG2: 
If ARG2 >= No. of archived periods 
(ARG1), then  
ARG2 = 0. 
Otherwise, ARG2 = ARG2 + 1. 
For all other cases: 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

WTM Write Time To Historical Database sets the 
value of the database point 
(ARGUMENT1) and the pointer 
(ARGUMENT2) to the historical database 
time string with either minutes or seconds 
resolution. The time format for minute's 
resolution is [min,hr,day,mon] and for 

1. Output: 
Database or 
Constant Value

2. Output: 
Database or 
Constant Value

For FST History Point: 
If minute resolution, then 
History Value (ARG1, ARG2 = minute 
format.  
Otherwise: History Value 
(ARG1,ARG2) = second format.  
For floating database value ARG2: 



ROCLINK 800 User Manual (FB107) 

B-24 FST Editor Issued Jan-08 

Name Description Arguments Results 
seconds resolution is [sec,min,hr,day]. 
Applies to historical database points 
defined for the FST only. 
If ARGUMENT2* is a floating database 
value (for example: @FST1, FST SEQ# 1, 
R8), the command increments 
ARGUMENT2 to the next historical 
database value and sets it to 0 when the 
number of archived historical periods are 
exceeded. Otherwise, no effect occurs to 
ARGUMENT2. 
Note:  Each ARGUMENT2 must be 

unique. 

If ARG2 >= number of archived 
periods (ARG1), then  
ARG2 = 0.  
Otherwise: ARG2 = ARG2 + 1. 
For all other cases: 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

 

B.4.2 Defining a FST History Point 
When defining history database points for WDB, WTM, and RDB, you 
must define at least one History Point as an FST Time type (minute or 
second) to provide a time stamp for the values logged. The time stamps 
represent what time each portion of the accumulated data was logged. 

To define an FST History Point: 

1. Select Configure > History Points. 

2. Select the desired History Point. 

3. Click the Archive Type TLP button and select FST Time or FST 
Data. 

4. Click the Archive Point TLP button and select any TLP, such as 
FST Register 2 to contain the data or time stamp. The Archive Point 
selection is ignored by the FST. 

5. Click OK. 

Historical 
Commands 

The FST for a History Point uses one of the historical database 
commands and two Arguments. ARGUMENT1 typically contains the 
history database History Point number with a value between 1 through 
200. 

ARGUMENT2 is the History Index or database pointer to the history 
storage array. The history storage array holds entries taken at either set 
intervals (typically daily, hourly, and each minute) or user-configurable 
intervals. 

For the DHV, DHT, PHV, PHT, and MHV commands, select the 
History Segment and the corresponding History Point that you desire to 
log in Argument 1. In Argument 2, select either a database point or a 
constant value, which is the actual History Index where the data resides 
in the historical database. 

The Minute History Value (MHV) History Index is the same as the 
minute of the hour. Read the clock’s minutes to get the last History 
Index value. For example, if it is 8:10 then the History Index is 10. 
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For the Extract Time Element (GTE) command, select the database 
point or a constant value, which is the actual History Index value where 
the data resides in the historical database. In Argument 2, select the 
Time Element to log the exact time of the database point or History 
Index value. The GTE command is used to extract the time element 
from the time stamp received back from the CHT and PHT commands. 

For DIS, DIN, PIS, and PIN commands, select the History Segment 
and the corresponding History Point that you desire to log in Argument 
1. In Argument 2, select the Month and Date on which to log the 
History Index value. 

To acquire the Daily History Value (DHV), perform a Starting Daily 
Index (DIS) command to locate the starting History Index value for a 
specific day. Using the DIS History Index value, use the DHV 
command to locate the Daily History Value. 

To find specific data in history, such as the data entered at 9:00 AM 
yesterday, first use the Starting Periodic Index (PIS) command to find 
the starting History Index value for yesterday’s date and then count 
forward nine to acquire the History Index value for 9:00 AM. Use this 
new History Index with the Periodic History Value (PHV) command to 
locate the data.  

Table B-17. FST Historical Commands 

Name Description Arguments Results 
DHV Daily History Value 1. Input: History Segment, History Point

2. Input: DB Point or Constant (History 
Index) 

Stores value in RR.  
Halts on invalid History Index. 

DHT Daily History Time 
Stamp 

1. Input: History Segment, History Point
2. Input: DB Point or Constant (History 
Index) 

Stores value in RR. 
Halts on invalid History Index. 

PHV Periodic History Value 1. Input: History Segment, History Point
2. Input: DB Point or Constant (History 
Index) 

Stores value in RR. 
Halts on invalid History Index. 

PHT Periodic History Time 
Stamp 

1. Input: History Segment, History Point
2. Input: DB Point or Constant (History 
Index) 

Stores value in RR. 
Halts on invalid History Index. 

MHV Minute History Value 1. Input: History Segment, History Point
2. Input: DB Point or Constant (History 
Index) 

Stores value in RR. 
Halts on invalid History Index. 

DIS Starting Daily Index 1. Input: History Segment, History Point
2. Input: Month/Day 

Stores value in RR. 
Returns –1 if Month/Day not 
found. 

DIN Number of Daily 
Indexes 

1. Input: History Segment, History Point
2. Input: Month / Day 

Stores value in RR. 
Returns –1 if Month/Day not 
found. 

PIS Starting Periodic Index 1. Input: History Segment, History Point
2. Input: Month / Day 

Stores value in RR. 
Returns –1 if Month/Day not 
found. 

PIN Number of Periodic 1. Input: History Segment, History Point Stores value in RR. 
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Name Description Arguments Results 
Indexes 2. Input: Month / Day Returns –1 if Month/Day not 

found. 
GTE Extract Time Element 1. Input: DB Point or Constant (History 

Index) (Time in Seconds since 
1/1/1970) 
2. Input: Time Element 

Stores value in RR. 
Valid Time Elements: 
0 – Month 
1 – Day 
2 – Year 
3 – Hour 
4 – Minute 
5 – Second 

 

B.5 Example FST  
This example FST shows how to configure history and then write an 
FST to submit data to the historical database.  

1. Access the History Setup screen (Configure > History Points). The 
History Setup screen displays.   

 
Figure B-3. History Setup 

2. Add two new definitions, one for point 9 (FST Data at FST 1, R1) 
and one for point 10 (FST Time – Second at FST 1, R2). You use 
these points when you define the FST.  
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3. Access the FST Editor (Utilities > FST Editor). A blank FST 
Editor screen displays.  

 
Figure B-4. Blank FST Editor 

4. Complete steps 0 through 4 with the commands and arguments as 
shown below:  

 
Figure B-5. Sample FST 
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a. Get the value (VAL) from softpoint 1, data 1, and save it to the 
first results register.  

b. Write the value saved in the Results Register to the historical 
database (WDB), placing it at point 9 (FST Data at FST 1, R1, 
as defined on the History Setup screen in Figure B-3). The 
system also creates an historical index for point 9 in FST1.  

Note:  For steps b and c, you must use the number of the point 
as Argument 1.  

c. Write the current time (WTM) to the historical point 10 (FST 
Time – Second at FST 1, R2, as defined on the History Setup 
screen). The system also creates an historical index for point 10 
in FST1.  

Note:  It is possible (and very likely) that the historical time 
intervals will not match the same intervals the FST uses 
when it records historical data. This step gives the 
periodic history report a time stamp when the FST 
records data. 

d. Suspend the FST execution (WT) for 5 seconds.  

e. Stop the FST execution (END) and restart at step 0.  

5. Click the Compile FST button ( ) on the FST Editor menu bar. 
The FST Editor compiles the FST and determines whether it 
contains any errors in the area below the FST:   

 
Figure B-6. Compiled FST 
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6. Click the Save to .FST button ( ) on the FST Editor menu bar. A 
Save As dialog box displays.   

 
Figure B-7. Save As 

7. Use this screen to name and save your FST. When you click Save, 
the FST Editor displays.   

Finally, you have to download the FST to the FB107 to make it active.   

8. Click the Download button ( ) on the FST Editor menu bar. An 
FST Details dialog box displays.  

 
Figure B-8. FST Details 

9. Complete at very least the Description field, providing a brief (up to 
40 characters) description of the FST. 

Note:  If you anticipate developing several versions of an FST, 
complete the Version field so you can easily tell one version 
from another.  
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10. Click OK. When the download completes, ROCLINK 800 prompts 
you to start the FST.  

 
Figure B-9. FST Download completed 

At this point the FST is stored in one of the four FST “slots” in the 
FB107. Click Yes to start the FST or No to return to the FST Editor.   
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If you have comments or questions regarding this manual, please direct them to your local sales representative 
or contact: 

Emerson Process Management 
Remote Automation Solutions 
Marshalltown, IA 50158 U.S.A. 
Houston, TX 77065 U.S.A. 
Pickering, North Yorkshire UK Y018 7JA 
Website: www.EmersonProcess.com/Remote 
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