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1  Introduction 
This manual describes how to connect a PC to a flexiBox chassis containing one 
or more DT-2 cards and how to use the DT-2 Setup Software to programme non-
standard configurations into the DT-2 hardware.  
Many applications of the DT-2 do not require the use of the DT-2 Setup Software 
to configure the DT-2 hardware as the units can be manually configured from 
their operational menus (see separate DT-2 User Manual).  
The DT-2 Setup Software and DG-9 dongle are required to complete the 
following advanced configuration tasks 

• Copy settings from one DT-2 to another  

• Customize user AFD and AR representations 

• Manipulate VI and WSS extra bits using data masking (not available when 
transcoding) 

• Customize user mapping tables 

• Edit the failure text displayed when the input signal is lost 

1.1 System Requirements 

Microsoft Windows™ PC running either Windows 2000 Professional™ or 
Windows XP Professional™ with:- 

• An available serial port. 

• Microsoft .NET Framework installed 

• The latest DT-2 Setup software downloaded from www.eyeheight.com and 
unzipped 
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2 Installation 

2.1 Cabling the PC, Dongle and Boxes 

The PC communicates with the boxes through an Eyeheight DG-9 ‘Dongle’ 
connected to a COM port on the PC and to the I-BUS port on the first box. 
N.B. For a single chassis system connect the chassis and PC using a straight 
through pin-to-pin cable. 
 

(The 100 Ohm I-Bus Terminators are fitted across pins 2 and 7). 

 

Figure 1 - Cabling the PC, DG-9 and Boxes 
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2.2 Setting Up The DG-9 

The DG-9 is required to convert the signal voltages from RS232 to I-Bus levels 
and to mediate between the RS232 and I-Bus transmission speeds. It also 
carries out protocol conversion and checking and message identification (in order 
to block unwanted messages). 
  
To Set the DG-9 ready to communicate with the PC and the box’s I-BUS: 

• Disconnect the DG-9 from the PC COM port.  

• Short pins 7 and 8 on the RS232 side of the DG-9.  

 

Figure 2 - Resetting The DG-9 

• Connect the DG-9 to the I-BUS port on a chassis. The LEDs on the DG-9 
will flash and then both LEDs will remain red.  

• Remove the short from pins 7 and 8.  

• Disconnect the DG-9 from the I-BUS port on the chassis.  

• Re-connect the DG-9 to the I-BUS port on the chassis. Both LEDs on the 
DG-9 should flash Red and Green and then go out. 

For more in depth programming of the dongle use the “DongleSetup” 
program which can be downloaded from www.eyeheight.com 

 

2.3 Setting up the PC’s COM port 

The COM port on the PC will be set up automatically by the DT-2 Setup software. 
It will be set to the default state of the Dongle: 
 

• Baud Rate  38400 

• Parity  No Parity 

• Data Bits 8 
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• Stop Bits 1 

• Flow Control None 

2.4 Ascertaining the box number 

Each chassis in a system must be given a unique Box Number. This Box Number 
is configured on a DIPswitch on the Flexi-box motherboard. To access the switch 
The user must remove the top lid of the flexiBox by removing the 14 off M2.5 
screws on top of the lid. The location of the switch is then shown below. Ensure 
the box is disconnected from any mains supply before removing the lid.  
N.B. A single chassis system will be factory preset to Box Number 1 

 
Figure 3 - Open Flexi Box showing Chassis Number DIP Switches 

The chassis/box number is calculated by adding 1 to the binary value of the 
DIPswitches that are in the ON position. Please note that the switch is ON if it is 
DOWN and OFF if it is UP.  
If all switches are in the UP position the box number is: 
 1 + (0 + 0 +0 + 0) = 1 
If all switches except Switch 1 and Switch 8 are up the box number is: 
 1 + (1 + 0 + 0 + 8) = 10 

2.5 Ascertaining the Slot Number of the Module 

The Slot Number can be calculated by viewing the box from the rear as shown in 
the following diagram: 
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Figure 4 - Rear view of Chassis showing Slot Numbering. 

2.6 Software Installation 

Double click the setup.exe and follow the installer instructions to complete the 
install. If an earlier version of the software is already installed it will need to be 
removed first by using the Add/Remove Programs option in the control panel. 
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3 Fundamentals of DT-2 Operation 
The DT-2 unit is primarily a data trans-coder taking AFD & AR data from one 
source format and trans-coding it to a destination format. Each destination format 
can be separately configured and all destinations can be active simultaneously. 

3.1 Available AR & AFD Source Formats 

Wide-Screen Signalling (WSS) extraction in either ETSI format (AR info only) or 
UK Line 23 format (AR & AFD info) 
Video Index (VI) extraction of Class 1.1, first Octet (AR & AFD info) 
GPI Input either 7 bit latched or 8 bit linear interface (AR and/or AFD info 
depending on GPI coding selection) 
RS-232 serial communications (AR & AFD info) 
User panel configuration (AR & AFD info) 

3.2 Available AFD & AR Destination Formats 

Wide-Screen Signalling (WSS) insertion in either ETSI format (AR info only) or 
UK Line 23 (UK_L23) format (AR & AFD info) 
Video Index (VI) insertion Class 1.1, first Octet (AR & AFD info) 
GPI’s 8 bit linear interface (AR and or AFD info depending on GPI coding 
selection) 
RS-232 serial communications (AR & AFD info) 
User panel display (independent AR & AFD info for VI and WSS inserters) 

3.3 VI & WSS Additional Data Handling 

In addition to its primary role as an AR & AFD trans-coder the DT-2 also allows 
control over all of the extra data available in the ETSI WSS, UK_L23 WSS and VI 
signals when using identical source and destination formats. The DT-2 Setup 
software and DG-9 dongle are required to allow extra data to be passed or forced 
to known values on a bit by bit basis. By default all extraneous data is passed as 
is if present. When using different source and destination formats all extra data in 
the destination format is forced to ‘0’. 

3.4 Failsafe Features 

The DT-2 also incorporates a number of failsafe features that include an 
internally generated ident signal in the event of a loss of input video and a fall-
back source option for each destination format in the event that no data is 
present on the selected primary source. 
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3.5 Native AR & AFD representation 

The DT-2 represents the AR & AFD data as two 3 bit binary numbers 
corresponding to AR & AFD values from 0-7. In situations where the AR & AFD 
data is combined the data is represented as a 6 bit binary concatenation of the 
AR & AFD data with the AR data represented by bits 5-3 and the AFD by bits 2-0. 

3.6 User AR & AFD representation 

The DT-2 enables users to map the native AR & AFD binary representations to 
more meaningful text representations by selecting sets of AR names and AFD 
names. The name sets and the names of the name sets themselves can be 
modified using the DT-2 Setup software and dongle. 

 Number Defn’d ETSI BBC User 1 User 2 

AR=000 AR =0 NoInfo 4:3 AR =8 AR =0 AR =0 

AR=001 AR =1 4x3 –5 14:9 C AR =9 AR =1 AR =1 

AR=010 AR =2 4x3 –6 14:9 T AR =10 AR =2 AR =2 

AR=011 AR =3 Reserv 16:9 C AR =11 AR =3 AR =3 

AR=100 AR =4 Reserv 16:9 T AR =12 AR =4 AR =4 

AR=101 AR =5 16x9-5 >16:9C AR =13 AR =5 AR =5 

AR=110 AR =6 16x9-6 4:3SPC AR =14 AR =6 AR =6 

AR=111 AR =7 Reserv 16:9An AR =15 AR =7 AR =7 

Figure 5 - Text Representations of AR for Built-In AR Name Sets 

 Number Defn’d BBC User 1 User 2 User 3 

AFD=000 AFD =0 Raster FAULT AFD =0 AFD =0 AFD =0 

AFD=001 AFD =1 4x3 12F12C AFD =1 AFD =1 AFD =1 

AFD=010 AFD =2 16x9 16F16A AFD =2 AFD =2 AFD =2 

AFD=011 AFD =3 14x9 14P16B AFD =3 AFD =3 AFD =3 

AFD=100 AFD =4 Reserv FAULT AFD =4 AFD =4 AFD =4 

AFD=101 AFD =5 4x3STP 14L12B AFD =5 AFD =5 AFD =5 

AFD=110 AFD =6 16x9SP 16F16B AFD =6 AFD =6 AFD =6 
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AFD=111 AFD =7 Reserv 16F16C AFD =7 AFD =7 AFD =7 

Figure 6 - Text Representations of AFD for Built-In AFD Name Sets 

N.B. changing the AR or AFD names does not alter the underlying binary 
representation or the data handled by the destination format only the way that 
data is represented to the user via the panel. 

3.7 GPIs – Latched Vs Linear 

The GPI inputs can be configured to operate in either 8 bit linear mode where the 
bits represent an 8 bit binary encoded value with GPI1 = bit 0 and GPI8 = bit 7 or 
a 7 bit latched mode where GPI1-7 represent a 7 bit binary encoded value but the 
value is latched into the DT-2 on the rising edge of GPI8 which does not 
contribute to the binary encoded value. 

3.8 Built-In Mapping Tables 

The DT-2 uses mapping tables to control how source data is transformed to 
destination data. The source data essentially provides an address to the mapping 
table and the data stored at that location in the mapping table is used as data by 
the destination. 
The DT-2 has the following 6 built-in mapping tables:- 

OFF 
All source data maps to all ‘0’s 

BYPASS 
Source data is unchanged by the mapping table 

AFD IP 
Designed to allow the GPI inputs to provide the AFD data as highest-bit-takes-
precedence i.e. if the highest GPI input set is GPI4(bit 3 as GPI’s number 1 to 8) 
then the AFD is taken to be 4 (“100”) irrespective of the lower GPI inputs. The AR 
is always taken as 0 (“000”). 

AR IP 
Designed to allow the GPI inputs to provide the AR data as highest-bit-takes-
precedence i.e. if the highest GPI input set is GPI4(bit 3 as GPI’s number 1-8) 
then the AR is taken to be 4 (“100”) irrespective of the lower GPI inputs. The AFD 
is always taken as 0 (“000”). 

AFD OP 
Designed to allow the GPI outputs to represent the AFD data by setting the 
appropriate GPI and clearing all others i.e. if the AFD is 6 (“110”) then GPI6 will 
be set and all others cleared. 
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AR OP 
Designed to allow the GPI outputs to represent the AR data by setting the 
appropriate GPI and clearing all others i.e. if the AR is 6 (“110”) then GPI6 will be 
set and all others cleared. 

3.9 User Mapping Tables 

In addition to the 6 built-in mapping tables the DT-2 provides 4 user mapping 
tables which can be named and edited using the DT-2 Setup software and DG-9 
dongle. By default these 4 tables are the same as the BYPASS built-in table. 
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4 Using the DT-2 Setup Software 

4.1 Setting communications preferences 

When first run the software will start with the default preferences for comm port, 
box and slot numbers and will display the expert menus. All of these preferences 
can be changed using the Edit->Preferences menu to display the preferences 
form. 

 
Figure 7 - Preferences Form 

This form allows the comm port connected to the DG-9 to be specified along with 
the box and slot numbers for the DT-2 card with which to communicate. 
The Operation Mode tick box allows you to show or hide the expert File menus. 
These menus allow only specific elements of the DT-2 configuration to be 
uploaded to the card, shortening the upload time, but should be used with caution 
to avoid unexpected behaviours. 

4.2 Saving and Loading System Setups with Files 

When first run the software will load the default DT-2 configuration file and this 
will be indicated by “System Setup Name = Default” showing in the title bar. If you 
edit the configuration you can then use the File -> Save System Setup menu to 
specify a name for the edited configuration and all DT-2 setting will be saved. 
N.B. Communications preferences are not saved as part of the System Setup. 
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The File->Load System Setup menu will allow you to select a previously saved 
configuration file. The software will automatically load the last configuration used 
when started. 

4.3 Getting System Settings from a DT-2 

Make sure the communications preferences are set for the DT-2 you wish to 
communicate with then use File->Get System Setup. The software will load all 
the card’s settings into the current configuration. 

4.4 Uploading System Settings to a DT-2 

Make sure the communications preferences are set for the DT-2 you wish to 
communicate with then use File->Upload System Setup. The software will load all 
the current configuration settings into the DT-2 card. 

4.5 Copying Settings Between DT-2 cards 

• Connect the PC and set the communications preferences to talk to the DT-
2 you wish to copy, using Edit->Preferences. 

• Use File->Get System Setup to retrieve the card’s setting to the current 
configuration. 

• Change the connections and communications preferences to talk to the 
destination card. 

• Use File->Upload System Setup to reprogram the card. 

4.6 Editing AFD & AR Representations 

Native AFD and AR data can be displayed using different nomenclatures on the 
DT-2 panel using different representations depending on the application. There 
are 6 sets of AFD representations and 6 sets of AR representations. Each set of 
representations contains 8 entries and maps the native binary values “000” to 
“111” to a text representation. Each set has a set name which is displayed on the 
panel when the user wishes to select which set of representations to use. These 
set names can be edited using the Edit->AFD & AR Names menu to display the 
form below. 
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Figure 8 - AFD & AR Names Form 

  
Each set name can be edited by typing in the text box. The maximum name 
length is 6 characters. 
Edit->AFD & AR Data brings up the form below allowing you to edit the text 
representations which make up each set of representations. 

 
Figure 9 - AFD & AR Data Form 

The named tabs reflect the names specified using the Edit->AFD & AR Names 
menu and each tab allows the associated 8 text representations to be edited. The 
maximum length is 6 characters. 
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4.7 Manipulating VI & WSS Extra Data 

The WSS and VI standards allow for more data than AFD and AR to be encoded 
but this extra data is rarely used. The DT-2 allows for manipulation of this extra 
data using input masking when the source and destination formats are the same 
i.e. VI->VI or WSS->WSS. 

4.7.1 Manipulating WSS Extra Data 
The Edit->WSS Extra Data menu will display the form below allowing the WSS 
extra data to be manipulated. 

 
Figure 10 - WSS Extra Data Form 

The above form also controls whether the  incoming WSS is interpreted as ETSI 
or UK_L23 standard and whether ETSI or UK_L23 or no WSS is inserted. 
The input masking section of the form changes in response to the selection of 
input standard and input masking should only be used when the input standard 
and output standard are the same. 
Each data bit present in the WSS input is presented as a check box and clicking 
on the check box toggles the contents of the box through ‘X’ do nothing, ‘0’ force 
low and ‘1’ force high. This bit manipulation is performed on the incoming data. 

4.7.2 Manipulating VI Extra Data 
Edit->VI Extra Data brings up the form below. 
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Figure 11 - VI Extra Data Form 

This form behaves similarly to the WSS Extra data form but there is no need to 
select the input or output standard. Whether VI data is inserted by the unit can be 
controlled using the ‘Insert” setting. 
Because the VI format allows for so much extra data this form provides a means 
of manipulating groups of bits. Clicking on the class labels e.g. “Class 1” will 
cause all the bits within that class to progress through the sequence ‘X’, ‘0’ and 
‘1’. Equally clicking on any of the sub-class labels e.g. “2.3.3” will cause all the 
bits within that sub-class to progress through the sequence ‘X’, ‘0’ and ‘1’. 
Individual bits can also be clicked to manipulate them individually. 

4.8 Editing the User Mapping Tables  

Editing the user mapping tables is the basis of any advanced transcoding 
operation. As with the AFD & AR Representation sets the names of the user 
mappings and the mappings themselves can be edited separately. 
Edit->Lut Names brings up the form to change the names of the 4 user mapping 
tables. The 6 built in tables can not be edited. The maximum name length is 6 
characters. 
The mapping tables themselves can only be edited from within the WSS, VI or 
GPI output configuration forms (Edit->WSS O/P, Edit->VI O/P and Edit->GPI O/P 
respectively). 
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4.8.1 Editing WSS & VI Output Mapping Tables 
Editing the WSS and VI mapping tables is identical. Figure 12 shows the WSS 
output configuration form. Section 1 allows configuration of the data source, 
failsafe source and the panel setting. In this instance the main data source is VI 
so the AR & AFD data received from the VI will be used to address the mapping 
table. In the event that no VI data is detected the unit will use the fall back source 
which in this case is panel and that is set to 0. 

 
Figure 12 - WSS Output Form 

Section 2 varies depending on the source selected. For VI or WSS sources the 
display will be similar to Figure 12 where it shows a section of the mapping table 
input data represented according to the representations selected at the top of 
section 2. Changing these options only effects the way the data is represented 
not the underlying data. 
For the GPI source section 2 will appear as in Figure 13 where the state of the 
input GPI’s are presented. 
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Figure 13 - WSS Output Form GPI source 

Section 3 shows the mapping table output data represented according to the 
representation selected at the top of section 3. Each entry in the mapping table is 
therefore represented by a line in the table showing how the input data in section 
2 is mapped to output data in section 3. When a user mapping table is selected 
the data in section 3 is editable and can be modified to implement a custom data 
mapping. When a built-in mapping table is selected the data in section 3 is not 
editable and will appear greyed. 
Section 4 indicates the current output being configured and allows the bypass 
GPI to be selected. When set to a GPI number the data inserter will be bypassed 
when the GPI input identified is activated. 

4.8.2 Editing GPI Output Mapping Tables 
Figure 14 shows the GPI Output Mapping form accessed via the Edit->GPI O/P 
menu. 
Section 1 is similar to the combination of sections 2 & 3 in Figure 12 with each 
line of the table representing how VI input data is mapped to the GPI outputs. 
The representation of the VI input data is automatically matched to the 
representation selected in the VI output configuration form. 
Section 2 is as for section 1 but configures the mapping relating to GPI input 
data. 
Section 3 allows for selecting a suitable mapping table, configuring the absent 
GPI output which is asserted when no VI data is detected and selecting whether 
the GPI outputs should be cleared or reflect the last received data when VI input 
data is lost (GPO valid). 
Section 4 is as for section 3 but configures the settings relating to GPI input data. 
The final GPI output is a logical OR of all the VI and WSS mapping tables and the 
absent GPO settings. 
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Figure 14 - GPI Output Mapping Form 

4.9 RS-232 Settings 

Edit->RS232 O/P brings up the form below which allows you to enable the RS-
232 information protocol for either the outgoing VI or WSS data. When configured 
the unit can be queried for the current inserted AFD and AR data. 
The port operates at 19200 baud, 8 data bits, 1 stop bit, no parity and n6 flow 
control. 
Sending ‘?A000<CR>’ to the unit will cause the unit to respond with %A00x 
where x is the current AFD on the DT-2. 
Sending ‘?R000<CR>’ to the unit will cause the unit to respond with %R00x 
where x is the current AR on the DT-2. 
The inserted AFD and AR can also be controlled from the serial interface, if set 
appropriately in the VI O/P or WSS O/P configuration screens, by sending 
‘!A00x<CR>’ where x is the required AFD and ‘!R00x<CR>’ where x is the 
required AR 

 
Figure 15 - RS-232 Settings Form 
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4.10  Configuring the Failure Settings 

The DT-2 includes an integrated backup video source which is automatically 
displayed when the input signal is lost. The setting can be altered using the Edit-
>Failure Text menu to display the form below. 

 
Figure 16 - Failure Text Form 

The two lines of text to be displayed can be edited by typing in the text boxes. 
The maximum length of each line is 16 characters. The FG Colour & BG Colour 
allow for selection of the text colours and the Show Text & Show Background tick 
boxes can be used to disable the text elements. The Test Pattern drop-down 
selects which of the built-in sources is displayed. 

4.11 Configuring Line Blanking 

The DT-2 includes a half-line blanker for WSS data and two multiple line blankers 
which can be used to blank any data in the VBI or active picture region. These 
blankers can be configured from the Edit -> Line Blanking menu which displays 
the form below. 
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Figure 17 - Line Blanking Configuration Form 

The half line blanker blanks the just over the first half of the specified line when 
enabled to ensure that any WSS data is removed. 
The two line blankers blank the whole of the active picture area or VBI area for 
each of the lines included in the specified range. Line numbers are based on the 
format and not picture lines. 
  


