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Introduction to ANSYS ICEM CFD

ANSYS ICEM CFD provides advanced geometry acquisition, mesh generation, and mesh optimization
tools to meet the requirement for integrated mesh generation for today’s sophisticated analyses.

Maintaining a close relationship with the geometry during mesh generation, ANSYS ICEM CFD is used
especially in engineering applications such as computational fluid dynamics and structural analysis.

ANSYS ICEM CFD’s mesh generation tools offer the capability to parametrically create meshes from
geometry in numerous formats:

+ Multiblock structured

* Unstructured hexahedral

+ Unstructured tetrahedral

+ Cartesian with H-grid refinement

+ Hybrid meshes comprising hexahedral, tetrahedral, pyramidal and/or prismatic elements
* Quadrilateral and triangular surface meshes

ANSYS ICEM CFD provides a direct link between geometry and analysis. In ANSYS ICEM CFD, geometry
can be input from just about any format, whether from a commercial CAD design package, 3rd party
universal database, scan data or point data. Beginning with a robust geometry module which supports
the creation and modification of surfaces, curves and points, ANSYS ICEM CFD’s open geometry database
offers the flexibility to combine geometric information in various formats for mesh generation. The
resulting structured or unstructured meshes, topology, inter-domain connectivity and boundary conditions
are then stored in a database where they can easily be translated to input files formatted for a particular
solver.

Overall Process

The ANSYS ICEM CFD GUI

Using the Help System

Overall Process

The generic working process involves the following:
1. Open/Create a project.

2. Create/Manipulate the geometry.

3. Create the mesh.

4. Check/Edit the mesh.

5. Generate the input for the solver.

ANSYS ICEM CFD 15.0 - © SAS IR, Inc. AlTrights reserved. - Contains proprietary and confidential in-
formation of ANSYS, Inc. and its subsidiaries and affiliates. 1
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Figure 1: The Overall Process
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Opening/Creating a Project

All the files required for a particular analysis are contained within a Project. You can either open an
existing project or create a new project. The Project directory typically contains one or more of the
following file types:

Tetin (*.tin)
contains geometry entities, material points, part association, and global and entity mesh sizes.

Project Settings (*.prj)
contains the project settings.

Domain (*.uns)
contains the unstructured mesh.

Blocking (*.blk)
contains the blocking topology.

Boundary Conditions (*.fbc)
contains boundary conditions.

Attributes (*.atr)
contains attributes, local parameters, and element types.

Parameters (*.par)
contains model parameters and element types.

ANSYS ICEM CFD 15.0 - © SAS IR, Inc. AlTrights reserved. - Contains proprietary and confidential in-
2 formation of ANSYS, Inc. and its subsidiaries and daffiliates.



Overall Process

Journal (*.jrf)
contains a record of operations performed (echo file).

Replay (*.rpl)
contains the replay script.

Creating/Manipulating the Geometry

ANSYS ICEM CFD includes a wide range of tools for creating new and/or manipulating existing geometry.
You can either alter complex geometry or create simple geometry without having to go back to the
original CAD. This can be done for CAD (NURBS surfaces) and triangulated surface data. The ANSYS

ICEM CFD Direct CAD Interfaces provide the bridge between parametric geometry creation tools available
in CAD systems and the computational mesh generation and mesh optimization tools available in ANSYS
ICEM CFD, allowing users to operate in their native CAD systems. ANSYS ICEM CFD currently supports
Direct CAD Interfaces for CATIA, I-deas, Creo Parametric, and Unigraphics.

The ANSYS ICEM CFD environment can combine CAD surface geometry and triangulated surface data

into a single geometry database (tetin file) using the geometry interfaces. All geometry entities, including
surfaces, curves and points are tagged or associated to a grouping called a part. With this part association,
you can enable or disable all entities within the parts, visualize them with a different color, assign mesh
sizes on all entities within the part and apply different boundary conditions by part.

ICEM CFD also supports several geometry interfaces which allow you to import geometry from other
formats (CAD, 3rd party geometry, Faceted Data and Mesh formats). For a complete list of supported
geometry interfaces, see Import Geometry in the Help manual.

Although most of the meshing modules within ANSYS ICEM CFD allow minor gaps and holes in the
geometry, in some cases it is necessary to find and close large gaps and holes without returning to the
original CAD software. ANSYS ICEM CFD provides tools for such operations on either CAD or triangulated
surfaces. Finally, curves and points can be automatically created to capture certain key features in the
geometry. These curves and points will act as constraints for the mesher, forcing nodes and edges of

the elements to lie along them, and thus capturing the feature.

Creating the Mesh

The meshing modules available include the following:

Tetra
The ANSYS ICEM CFD Tetra mesher takes full advantage of object-oriented unstructured meshing
technology. With no tedious up-front triangular surface meshing required to provide well-balanced
initial meshes, ANSYS ICEM CFD Tetra works directly from the CAD surfaces and fills the volume
with tetrahedral elements using the Octree approach. A powerful smoothing algorithm provides
the element quality. Options are available to automatically refine and coarsen the mesh both on
geometry and within the volume. Also included are a Delaunay algorithm and an Advancing Front
algorithm to create tetras from an existing surface mesh and also to give a smoother transition in
the volume element size. The Delaunay method is robust and fast; the advantage of the Advancing
Front method is its ability to generate a smoothly transitioning Tetra mesh with a controlled volume
growth ratio.

Hexa
The ANSYS ICEM CFD Hexa mesher is a semi-automated meshing module which allows rapid gen-
eration of multi-block structured or unstructured hexahedral volume meshes. ICEM CFD Hexa rep-
resents a new approach to grid generation where the operations most often performed by experts

ANSYS ICEM CFD 15.0 - © SAS IR, Inc. AlTrights reserved. - Contains proprietary and confidential in-
formation of ANSYS, Inc. and its subsidiaries and affiliates. 3
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are automated and made available at the touch of a button. Blocks can be built and interactively
adjusted to the underlying CAD geometry. This blocking can be used as a template for other similar
geometries for full parametric capabilities. Complex topologies, such as internal or external O-grids
can also be generated automatically.

Prism
ANSYS ICEM CFD Prism generates hybrid tetrahedral grids consisting of layers of prism elements
near the boundary surfaces and tetrahedral elements in the interior for better modeling of near-
wall physics of the flow field. Compared to pure tetrahedral grids, this results in smaller analysis
models, better convergence of the solution and better analysis results.

Hybrid Meshes
The following types of hybrid meshes can be created:

+ Tetra and Hexa meshes can be united (merged) at a common interface in which a layer of pyramids
is automatically created at a common interface to make the two mesh types conformal. These
meshes are suitable for models where it is preferred to have a “structured” hexa mesh in one part
and is easier to create an “unstructured” tetra mesh in another more complex part.

+ Hexa-Core meshes can be generated where the majority of the volume is filled with a Cartesian
array of hexahedral elements essentially replacing the tetras. This is connected to the remainder
of a prism/tetra hybrid by automatic creation of pyramids. Hexa-Core allows for reduction in
number of elements for quicker solver run time and better convergence.

Shell Meshing
ANSYS ICEM CFD provides a method for rapid generation of surface meshes (quad and tri), both
3D and 2D. Mesh types can be All Tri, Quad w/one Tri, Quad Dominant, or All Quad. The following
methods are available:

+ Mapped based shell meshing (Autoblock): Internally uses a series of 2D blocks, resulting in a
mesh better lined up with geometry curvature.

+ Patch based shell meshing (Patch Dependent): Uses a series of “loops” which are automatically
defined by the boundaries of surfaces and/or a series of curves. This method gives the best quad
dominant quality and capturing of surface details.

+ Patch independent shell meshing (Patch Independent): Uses the Octree method. This is the
best and most robust method for unclean geometry.

+ Shrinkwrap: Used for quick generation of mesh. As it is used as the preview of the mesh, hard
features are not captured.

Checking/Editing the Mesh

The mesh editing tools in ANSYS ICEM CFD allow you to diagnose and fix problems in the mesh. You
can also improve the mesh quality. A number of manual and automatic tools are available for operations
such as conversion of element types, refining or coarsening the mesh, smoothing the mesh, etc.

The process typically involves the following:

1. Check the mesh for problems such as holes, gaps, overlapping elements using the diagnostic checks
available. Fix the problems using the appropriate automatic or manual repair methods.

2. Check the elements for bad quality and use smoothing to improve the mesh quality.

ANSYS ICEM CFD 15.0 - © SAS IR, Inc. AlTrights reserved. - Contains proprietary and confidential in-
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The ANSYS ICEM CFD GUI

3. If the mesh quality is poor, it may be appropriate to fix the geometry instead or recreate the mesh
using more appropriate size parameters or a different meshing method.

Generating the Input for the Solver

ANSYS ICEM CFD includes output interfaces to various flow and structural solvers, producing appropriately
formatted files that contain complete mesh and boundary condition information. After selecting the
solver, you can modify the solver parameters and write the necessary input files.

More information about the ANSYS ICEM CFD Output Interfaces is available from the Help menu. The
Output Interfaces option opens the ANSYS ICEM CFD Output Interfaces information in a browser. For
information about a specific interface, refer to the Table of Supported Solvers and click the name of
the interface.

The ANSYS ICEM CFD GUI

The ANSYS ICEM CFD GUI offers a complete environment to create and manage your computational
grids. As shown in Figure 2: ANSYS ICEM CFD GUI Components (p. 6), the GUI window contains several
functional areas, which are described below.

ANSYS ICEM CFD 15.0 - © SAS IR, Inc. AlTrights reserved. - Contains proprietary and confidential in-
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Figure 2: ANSYS ICEM CFD GUI Components
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Note

The GUI style shown is the default, Workbench style. For more information about the GUI
Style options, refer to the Product-Selection settings.

Main Menu
The Main Menu is in the top, left corner of the GUI, and provides access to the following pull-down
menus. Full details are available in the Main Menu Area of the Help Manual.
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The ANSYS ICEM CFD GUI

File Menu

contains options for creating new or opening existing projects, loading and saving files, importing
and exporting geometry, and initializing scripting.

Edit Menu

contains Undo/Redo options, the option to open a shell window, and various internal mesh/geometry
conversion commands.

View Menu

contains options for managing the look of the model in the graphics window. These include standard
views, view controls, and annotations.

Info Menu
contains options for presenting statistics and other data about your geometry, mesh or other entities.

Settings Menu

contains options for managing many of the program preferences. Typically the default settings for
performance, graphics, and others are suitable more than 90% of the time by a specific user.

Help Menu
contains links to Help Topics, tutorials, other documentation modules, and version information.

Utilities
The Utilities are icon representations of some of the most commonly used functions in the Main Menu,
including opening/closing a project, or managing geometry, mesh or blocking files. Also included are
quick access icons for undo/redo, measurement options, local coordinate system controls, and display
options. Full details are available in the Graphical Main Menu, Utilities, and Display Options section of
the Help Manual.

Display Control Tree
The Display Control tree, also referred to as the Display tree, along the upper left side of the screen,
allows control of the display by part, geometric entity, element type and user-defined subsets. The tree
is organized by categories. Each category can be enabled or disabled by selecting the check box. If the
check mark is faded, some of the sub-categories are enabled and some disabled. Each category can be
expanded or collapsed by selecting the “+” or “-“ symbol, respectively.

Since some functions are performed only on the entities shown, the tree is an important feature to
use when isolating the particular entities to be modified. Use the right mouse button on a category
or type to reveal several display and modification options. Full details are available in the Display
Tree section of the Help Manual.

Function Tabs
The Function Tabs, across the top of the GUI window, allow you to access the main functionality for
the entire grid generation process. The function tabs are laid out from left to right in the order of a
typical meshing process - Geometry, Mesh, Blocking, Edit Mesh, Properties, Constraints, Loads, Solve
Options, and Output. Full details for each tab are available in the Help Manual.

Selection Toolbar
The Selection Toolbar contains icons for the tools and filters applicable to your current function as
identified in the Data Entry Zone. Some tools and filters are linked to the hotkeys available in the par-
ticular selection mode. Full details are available in the Selection Options section of the Help Manual.

If a Selection Toolbar is present, you are operating in Selection Mode and the mouse is used to
identify locations or entities. If there is no Selection Toolbar, you are operating in Dynamic Mode

ANSYS ICEM CFD 15.0 - © SAS IR, Inc. AlTrights reserved. - Contains proprietary and confidential in-
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and the mouse is used to manipulate the graphical model display. See MouseBindings/Spaceball
in the Help manual.

The Data Entry Zone (DEZ)
Clicking on a Function Tab brings its action icons to the fore front. Clicking on any of these icons will

activate the associated Data Entry Zone (DEZ). The DEZ provides access to the controls and parameters
associated with a particular operation.

The controls utilized by the DEZ are described here:

Button

Compute params

A button is used to perform a function indicated by the button label.

Check Box

¥ Smooth mesh

A check box is used to enable/disable an item or action indicated by the check box label.

Radio Buttons
Method
* Update 2l
" Keep Distibutions
" Keep Counts

Curve->Edge
bunching

Radio buttons are a set of check boxes with the condition that only one can be enabled at a
time. When you click the left mouse button on a radio button, it will be enabled, while all others
will be disabled.

Drop-Down List

tesh twpe |CQuad Dominant '-v

Al Tri
[uad wione Tri
Buad Daominant

Al Quad

A drop-down list is a hidden single-selection list that shows only the current selection. Click the
arrow button to display the list.

Text Entry

Name |CURVEDD
Text entries allow you to enter text associated with the label for the field.
Number Entry
Min quality 0.4

Number entries allow you to enter numerical values for the parameter indicated by the label
for the field.

Iterations [5 ﬁ

Some number entry fields may have arrow buttons which allow you to increase or decrease
the value in entry field.
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Using the Help System

Selections
Poirts [(E00T50 500 Sy

Selection fields indicate the entities selected for a particular operation. Click the button adjacent
to the selection field to invoke the selection mode. The selection toolbar associated with the
operation will appear. After confirming the selections, the selected items will be listed in the
selection field.

Apply/OK/Dismiss

Apply | ] | Dizmizz

At the bottom of the DEZ, these buttons are used to accept or reject the parameters.

Apply
accepts your parameters and leaves the DEZ open.

OK
accepts your parameters and closes the DEZ.

Dismiss
rejects your parameters and closes the DEZ.

The Histogram Window
The Histogram Window shows a bar graph representing the mesh quality. The X axis represents element
quality (usually normalized to between 0 and 1) and the Y axis represents the number of elements.
Other functions which utilize this space will become pop-up menus if the quality or histogram is enabled.

The Message Window
The Message Window contains all the messages that ANSYS ICEM CFD writes out to keep the user in-
formed of internal processes. The Message Window displays the communication between the GUI and
the geometry and meshing functions. Any requested information, such as measure distance, surface
area, etc. will be reported in the message window. You can use the scroll bar to review the information
from your entire session. Also, internal commands can also be typed and invoked from within the message
window.

The Save command will write all message window contents to a file. This file will be written to the
folder from which ICEM CFD was launched. The Log check box allows only user-specified messages
to be saved to a file.

Note

The Log file is unique from the file created with the Save button. This file will be
written to the starting directory, and it automatically updates as more messages are
recorded. If the check box is disabled, you can append to a file by enabling Log and
accepting an existing file name. Log will then append to this file.

Using the Help System

Click Help on the main menu and select the appropriate option from the menu.
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Figure 3: Help Menu Options
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Show Customer Number
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Online Help Interface
The ANSYS Help Viewer provides easy access to the documentation for the entire ANSYS family.

Click ICEM CFD on the hierarchical list and select the appropriate option from the menu.
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Using the Help System

Figure 4: The Online Help Interface
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FE Modeler User's Guide elements, and theoretical details needed to use
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g IF(LUEEQE:FD ICEM CFED products. A brief description of each
Help Manual document follows. i
User's Manual
Tutorials o

i F‘Lngrammers Guide ANSYS ICEM CFD Help Manual contains

Icepa . . . . -

Internal Combustion Engines in Workbench detailed information about using ANSYS ICEM

Mechanical Applications CFD, including full descriptions of all the menm

Mechanical APDL . . .

Meshing User's Guide and tab options. This document is structured to

Polyfiow follow the tvpical sequence vou would follow in

Remote Solve Manager (RSM) . e ) .

TurboGrid progressing from initiating a project through to

TurboSystem ; :

Vrfem e e sls creating the output for a Solver.

Installation and Licensing Documentation ANSTYS ICEM CFD User's Manual contains

=1 Using Help . . \ \

1, Navigation theoretical information about setting up a problem
2. Searching o ARTENTE TAOTAN ST Al el STTT
3. Errors and Motes
Legal Motices search in page... [ a ] [ o ]
4,1, Spedial Help Manual
Considerations for
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Full instructions for navigating the ANSYS Help Viewer are accessed by expanding the Using Help
hierarchy in the Viewer.
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Figure 5: Using the Help Viewer
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CAD Repair

Before generating the mesh, you should confirm that the geometry is free of any flaws that would in-
hibit optimal mesh creation. If you wish to save the changes in the native CAD files, the following checks
should be performed in a direct CAD interface:

+ To create a mesh, the Tetra mesher requires that the model contains a closed volume. If there are
any holes (gaps or missing surfaces) in the geometry that are larger than the local tetras, the Tetra
mesher will be unable to find a closed volume. Thus, if you notice any holes in the model prior to
mesh generation, you should fix the surface data to eliminate these holes.

+ The Build Topology operation will find holes and gaps in the geometry. It should display yellow
curves where there are large (in relation to a user-specified tolerance) gaps or missing surfaces.

* During the Tetra process any leakage path (indicating a hole or gap in the model) will be indicated.
The problem can either be corrected on a mesh level, or the geometry in that vicinity can be repaired
and the meshing process repeated. For further information on the process of interactively closing
holes, see the section Tetra > Tetra Generation Steps > Desired Mesh Region.

Close Holes

You can use the Close Holes option if the hole is bounded by more than one surface. For example, in
Figure 6: Hole Bounded by Multiple Surfaces (p. 13), the yellow curves represent the boundary of the
hole. It is clear that this hole is bounded by more than one surface.

Figure 6: Hole Bounded by Multiple Surfaces

Figure 7: Closed Hole (p. 14) shows the geometry after the Close Holes operation is completed. A new
surface is created to close the hole.

ANSYS ICEM CFD 15.0 - © SAS TP, Inc. Allrights reserved. - Contains proprietary and confidential in-
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CAD Repair

Figure 7: Closed Hole

Remove Holes

You can use the Remove Holes option if the hole lies entirely within a single surface, such as a trimmed
surface. For example, in Figure 8: Hole Within a Single Surface (p. 14), the two yellow curve loops rep-
resent the boundaries of the holes, which lie entirely in one surface.

Figure 8: Hole Within a Single Surface

BB
Figure 9: After Remove Holes (p. 14) shows the geometry after the Remove Holes operation is completed

for one of the holes. The existing surface is modified by removing the trim definition.

Figure 9: After Remove Holes
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Fill, Trim and Blend in Stitch/Match Edges

Fill, Trim and Blend in Stitch/Match Edges

Consider the case of a geometry with a gap shown in Figure 10: Geometry With a Gap (p. 15).

Figure 10: Geometry With a Gap

Figure 11: Using the Fill Option (p. 15) shows the use of the Fill option.

Figure 11: Using the Fill Option

Figure 12: Using the Trim Option (p. 15) shows the use of the Trim option.

Figure 12: Using the Trim Option

Figure 13: Using the Blend Option (p. 16) shows the use of the Blend option.
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CAD Repair

Figure 13: Using the Blend Option

Match in Stitch/Match Edges

The Match option is generally used in those cases where curves lie very close to each other, specifically
when the two ends meet together (see Figure 14: Geometry With Mismatched Edges (p. 16) and Fig-
ure 15: Geometry After Using the Match Edges Option (p. 17)). You should have the two sets of curves
within some tolerance for this option to work.

Figure 14: Geometry With Mismatched Edges
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Match in Stitch/Match Edges

Figure 15: Geometry After Using the Match Edges Option
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Tetra Meshing

Automated to the point that you have only to select the geometry to be meshed, the Tetra mesher
generates tetrahedral meshes directly from the CAD geometry or STL data, without requiring an initial
triangular surface mesh.

Introduction

Tetra Generation Steps

Important Features in Tetra

Introduction

The Tetra mesher can use different meshing algorithms to fill the volume with tetrahedral elements

and to generate a surface mesh on the object surfaces. You can define prescribed curves and points to
determine the positions of edges and vertices in the mesh. For improved element quality, the Tetra
mesher incorporates a powerful smoothing algorithm, as well as tools for local adaptive mesh refinement
and coarsening.

Tetra Mesh Generation

The Tetra mesher is suitable for complex geometries, and offers several advantages, including:
+ Rapid model setup

+ Mesh independent of underlying surface topology

+ No surface mesh necessary

+ Generation of mesh directly from CAD or STL surfaces

+ Definition of element size on CAD or STL surfaces

+ Control over element size inside a volume

+ Nodes and edges of tetrahedra are matched to prescribed points and curves

+ Curvature/Proximity Based Refinement automatically determines tetrahedra size for individual
geometry features

+ Volume and surface mesh smoothing, merging nodes and swapping edges

+ Tetrahedral mesh can be merged into another tetra, hexa or hybrid mesh and then can be smoothed
+ Coarsening of individual material domains

+ Enforcement of mesh periodicity, both rotational and translational

+ Surface mesh editing and diagnostic tools

* Local adaptive mesh refinement and coarsening

ANSYS ICEM CFD 15.0 - © SAS IR, Inc. AlTrights reserved. - Contains proprietary and confidential in-
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Tetra Meshing

+ One consistent mesh for multiple materials
+ Fast algorithm: 7500 elements/second
+ Automatic detection of holes and easy way to repair the mesh

+ For more details, go to Run Tetra - The Octree Approach

Input to Tetra

The following are possible inputs to the Tetra mesher:

+ Sets of B-Spline curves and trimmed B-Spline surfaces with prescribed points
+ Triangular surface meshes as geometry definition

+ Full/partial surface meshes

B-Spline Curves and Surfaces

When the input is a set of B-Spline curves and surfaces with prescribed points, the mesher approximates
the surface and curves with triangles and edges respectively; and then projects the vertices onto the
prescribed points.

The B-Spline curves allow the Tetra mesher to follow discontinuities in surfaces. If no curves are specified
at a surface boundary, the Tetra mesher will mesh triangles freely over the surface edge. Similarly,
prescribed points allow the mesher to recognize sharp corners in the geometry. ANSYS ICEM CFD
provides tools (Build Topology) to extract points and curves to define sharp features in the surface
model.

Triangular Surface Meshes as Geometry Definition

Prescribed curves and points can also be extracted from triangulated surface geometry. This could be
stereolithography (STL) data or a surface mesh converted to faceted geometry. Though the nodes of
the Tetra-generated mesh will not exactly match the nodes of the given triangulated geometry, they
will follow the overall shape. A geometry for meshing can contain both faceted and B-Spline geometry.

Full/Partial Surface Mesh

Existing surface mesh for all or part of the geometry can be specified as input to the Tetra mesher. The
final mesh will then be consistent with and connected to the existing mesh nodes.

Tetra Generation Steps

The steps involved in generating a Tetra mesh are:
+ Repairing/cleaning up the geometry

+ Specifying geometry details

+ Specifying sizes on surfaces/curves

+ Meshing inside small angles or in small gaps between objects
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*+ Desired mesh region

+ Computing the mesh

+ Checking the mesh for errors

+ Editing the mesh to correct any errors

* Smoothing the mesh to improve quality

The mesh is then ready to apply loads, boundary conditions, etc., and for writing to the desired solver.

Repairing the Geometry

Refer to the CAD Repair section.

Geometry Details Required

In addition to a closed set of surfaces, the Tetra mesher requires curves and points where hard features
(hard angles, corners) are to be captured in the mesh. Figure 16: Curves and Points Representing Sharp
Edges and Corners (p. 21) shows a set of curves and points representing hard features of the geometry.

Figure 16: Curves and Points Representing Sharp Edges and Corners

Figure 17: Mesh with Curves and Points (p. 21) shows the resultant surface mesh if the curves and points
are preserved in the geometry. Mesh nodes are forced to lie along the curves and points to capture
the hard features of the geometry.

Figure 17: Mesh with Curves and Points

Figure 18: Mesh Without Curves and Points (p. 22) shows the resultant surface mesh if the curves and
points are deleted from the geometry. The hard features of the geometry are not preserved, but rather
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Tetra Meshing

are neglected or chamfered. The boundary mesh nodes lie on the surfaces, but they will only lie on the
edges of the surfaces if curves and points are present. Removal of curves and points can be used as a
geometry defeaturing tool.

Figure 18: Mesh Without Curves and Points

Sizes on Surfaces and Curves

To produce the optimal mesh, it is essential that all surfaces and curves have the proper tetra sizes as-
signed to them. For a visual representation of the mesh size, select Geometry > Surfaces > Tetra Sizes
from the Display Tree. The same can be done with Curves. Tetra icons will appear, representing the
element size of the mesh to be created on these entities. Using the mouse, you may rotate the model
and visually confirm that the tetra sizes are appropriate. If a curve or surface does not have an icon
plotted on it, the icon may be too large or too small to see. In this case, modify the mesh parameters
so that the icons are visible in a normal display.

To modify the mesh size for all entities, adjust the Scale Factor, which is found under Mesh > Global
Mesh Setup. Note that if the Scale Factor is assigned a value of 0, the Tetra mesher will not run.

Meshing Inside Small Angles or in Small Gaps Between Objects

Examine the regions between two surfaces or curves that are very close together or that meet at a small
angle. (This would also apply if the region outside the geometry has small angles.) If the local tetra sizes
are not small enough so that at least 1 or 2 elements would fit through the thickness, you should define
thin cuts. This option is in the Mesh > Global Mesh Setup > Volume Meshing Parameters section.

To define a thin cut, the two surfaces have to be in different Parts. If the surfaces meet, the curve at

the intersection of the surfaces will need to be in a different part.

If the tetra sizes are larger or approximately the same size as the gap between the surfaces or curves,
the surface mesh could have a tendency to jump the gap, thus creating non-manifold vertices. These
non-manifold vertices would be created during the meshing process. The Tetra mesher automatically
attempts to close all holes in a model. Since the gap may be confused as a hole, you should either
define a thin cut, in order to establish that the gap is not a hole; or make the mesh size small enough
so that it will not close the gap when the meshing is performed. A hole is usually considered a space
that is greater than 2 or 3 elements in thickness.

Desired Mesh Region

During the process of finding the bounding surfaces to close the volume mesh, the mesher will determine
if there are holes in the model. If holes are found, the Message window will display a message like
"Material point ORFN can reach material point LIVE." You will be prompted with a dialog box saying,
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"Your geometry has a hole, do you want to repair it?" A jagged line will display the leakage path from
the ORFN part to the LIVE part. The elements surrounding the hole will also be displayed. To repair the
hole, select the single edges bounding it - and the mesher will loft a surface mesh to close the hole.
Further holes would be flagged and repaired in the same manner. If there are many problem areas, it
may be better to repair the geometry or adjust the meshing parameters.

The Octree Mesh Method

The Octree method starts with generating a volume mesh using a top-down approach. Then the mesh

is made conformal to the geometry and patch independent surface mesh is created at all the boundaries
and internal walls. Expert users often use the robust Octree approach to generate a surface mesh and
then regenerate the volume mesh using a bottom-up approach such as the Delaunay method or Ad-
vancing Front method. See Tetra/Mixed Mesh Type in the Help document for more information on

these methods.

The Octree mesh method is based on the following spatial subdivision algorithm: This algorithm ensures
refinement of the mesh where necessary, but maintains larger elements where possible, allowing for
faster computation. Once the "root" tetrahedron, which encloses the entire geometry, has been initialized,
Tetra subdivides the root tetrahedron until all element size requirements are met.

Figure 19: Geometry Input to Tetra

At this point, the Tetra mesher balances the mesh so that elements sharing an edge or face do not
differ in size by more than a factor of 2.
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Figure 20: Full Tetra Enclosing the Geometry

Figure 21: Full Tetra Enclosing the Geometry in Wire Frame Mode
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Figure 22: Cross-Section of the Tetra

After this is done, Tetra makes the mesh conformal - that is, it guarantees that each pair of adjacent
elements will share an entire face. The mesh does not yet match the given geometry, so the mesher
next rounds the nodes of the mesh to the prescribed points, prescribed curves or model surfaces. Tetra
then "cuts away" all of the mesh, which cannot be reached by a user-defined material point without
intersection of a surface.

Figure 23: Mesh after it captures surfaces and separation of useful volume
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Figure 24: Final Mesh before smoothing

Finally, the mesh is smoothed by moving nodes, merging nodes, swapping edges and in some cases,
deleting bad elements.

Figure 25: Final Mesh after smoothing

Important Features in Tetra

The following sections describe important features of tetra meshing.
Curvature/Proximity Based Refinement
Tetrahedral Mesh Smoother
Tetrahedral Mesh Coarsener
Triangular Surface Mesh Smoother
Triangular Surface Mesh Coarsener
Triangular Surface Editing Tools
Check Mesh
Smooth Mesh Globally
Quality Metrics
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Important Features in Tetra

Advanced Options for Smoothing Mesh

Curvature/Proximity Based Refinement

If the maximum tetrahedral size defined on a surface is larger than needed to resolve the feature, you
can employ Curvature/Proximity Based Refinement to automatically subdivide the mesh to capture
the feature. The value specified is proportional to the global scale factor, and is the smallest size to be
achieved through automatic element subdivision. Even with large sizes specified on the surfaces, the
features can be captured automatically.

The Curvature/Proximity Based Refinement value is the minimum element size to be achieved via
automatic subdivision. If the maximum size on a geometry entity is smaller than the Curvature/Prox-
imity Based Refinement value, the Tetra mesher will still subdivide to meet that requested size. The
effect is a geometry-based adaptation of the mesh.

Tetrahedral Mesh Smoother

In smoothing the mesh, the tetrahedral smoother calculates individual element quality based on the
selection from the list of available criteria.

The smoother modifies the elements with quality below the specified Up to quality value. Nodes can
be moved and/or merged, edges are swapped, and in some cases elements are deleted. This operation
is then repeated on the improved grid, up to the specified number of iterations. You can choose to
smooth some element types while freezing others.

Tetrahedral Mesh Coarsener

During the coarsening process you can exclude surface or material domains. If the Maintain surface
sizes option is enabled during coarsening, the resulting mesh satisfies the specified mesh size criteria
on the geometric entities.

Triangular Surface Mesh Smoother

The triangular surface mesh inherent in the Tetra mesh generation process can also be used independ-
ently of the volume mesh. The triangular smoother marks all elements that are initially below the
quality criterion and then runs the specified number of smoothing steps on the elements. Nodes are
moved on the actual CAD surfaces to improve the quality of the elements.

Triangular Surface Mesh Coarsener

In the interest of minimizing grid points, the coarsener reduces the number of triangles in a mesh by
merging triangles. This operation is based on the maximum deviation of the resultant triangle center
from the surface, the aspect ratio of the merged triangle and the maximum size of the merged triangle.

Triangular Surface Editing Tools

There are tools available under the Edit Mesh menu for interactive mesh editing, where nodes can be
moved on the underlying CAD surfaces, merged or even deleted. Individual triangles of the mesh can
be subdivided or tagged with different names. You can perform quality checks, as well as local
smoothing.
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Diagnostic tools for surface meshes allow you to fill holes easily in the surface mesh. Also there are
tools for the detection of overlapping triangles and non-manifold vertices, as well as detection of
single/multiple edge and duplicate elements.

Check Mesh

Check the validity of the mesh using Edit Mesh > Check Mesh.

You can opt to use the Create subsets option for each of the problems so that they can be fixed later
or can opt to use the Check/fix each option to check and fix each one of them. Using subset manipu-
lation and mesh editing techniques, you can diagnose the problem and resolve it through merging
nodes, splitting edges, swapping edges, delete/create elements, etc.

For ease of use when working with subsets, it is usually helpful to add elements to the subset in order

to see what is happening around the problem elements. To do this, right-click on the Subset name in

the Display tree and then add layers of elements to the subset. It is also useful to display the element
nodes and/or display the elements slightly smaller than actual size. Both of these options can be accessed
by right-clicking on Mesh in the Display Tree.

Keep in mind that after mesh editing, the diagnostics should be re-checked to verify that no mistakes
were made.

There are several checks for Errors as well as Possible problems. The descriptions of each of these
checks can be found in the Edit Mesh > Check Mesh section of the Help Manual.

Smooth Mesh Globally

After eliminating errors/possible problems from a tetra mesh, you need to smooth the grid using Edit
Mesh > Smooth Mesh Globally to improve the quality.

Smoothing iterations
This value is the number of times the smoothing process will be performed. Models with a more com-
plicated geometry will require a greater number of iterations to obtain the desired quality, which is
specified for Up to quality.

Up to quality
The Min value represents the worst quality, while the Max value represents the highest quality elements.
Usually, the Min value is set to 0.0 and the Max value is set to 1.0. The Up to quality value gives the
smoother a quality to aim for. Ideally, after smoothing, the quality of the elements should be higher
than or equal to this value. If this does not happen, you should employ other methods of improving the
quality, such as merging nodes and splitting edges. For most models, the elements should all have ratios
of greater than 0.3, while a ratio of 0.15 for complicated models is usually sufficient.

Freeze
If the Freeze option is selected for an element type, the nodes of this element type will be fixed during
the smoothing operation. As a result, this element type will not be displayed in the histogram.

Float
If the Float option is selected, the nodes of the specified element type will be capable of moving freely,
allowing nodes that are common with another type of element to be smoothed. The quality of elements
set to float is not tracked during the smoothing process and so the quality is not displayed in the histo-
gram.
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Important Features in Tetra

The tetrahedral quality will be displayed within the Quality Histogram , where 0 represents the worst
aspect ratio and 1 represents the best aspect ratio. You may modify the display of the histogram by
adjusting the values of Min, Max, Height, and Bars. Right-click on the histogram to access the following
options for modifying its display attributes.

The Replot option opens a small window that allows you to change the following parameters.
Clicking Accept replots the histogram to the newly set values.

Min X Value
This minimum value, which is located on the left-most side of the histogram's x-axis, represents
the worst quality elements.

Max X Value
This maximum value, which is located on the right-most side of the histogram's x-axis, represents
the highest quality that elements can achieve.

Max Y height
You can adjust the number of elements that will be represented on the histogram's y-axis. Usually
a value of 20 is sufficient. If there are too many elements displayed, it is difficult to discern the
effects of smoothing.

Num bars
This represents the number of subdivisions within the range between the Min X and Max X values.
The default Bars have widths of 0.05. Increasing the number of displayed bars will decrease their
width.

The Reset option will return all of the values back to their original settings.

Show: Click the left mouse button on any of the bars in the histogram to select elements that fall
within that selected Quality range. If Show is enabled, the selected elements on the model will become
visible in the main viewing window. The following options control how the selected elements are
displayed.

Solid: Enabling this option will display the elements as solid, rather than the default grid representation.
(Show must be enabled.)

Color by Quality: If available, enabling this option will display the elements in the same color as the
selected Quality bar in the histogram. (Show must be enabled.)

Highlight: If available, this option allows you to display one or two additional layers adjacent to the
selected elements. (Show must be enabled.)

Subset: Allows you to create a Subset containing only the elements chosen from the Quality histogram.
The visibility of this subset is controlled by Subset in the Display Tree. The Add select option allows
you to add elements to an already established subset.

Quality Metrics

This option allows you to modify the histogram display.

The histogram displays the overall quality of the mesh. The x-axis measures the quality, with O repres-

enting poor quality and 1 representing high quality. The y-axis measures the number of elements that
belong within each quality sub-range.
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For descriptions of all the quality metrics, refer to the Edit Mesh > Display Mesh Quality section in the
Help Manual.

Advanced Options for Smoothing Mesh

Prism Warpage Ratio
Prisms are smoothed based on a balance between prism warpage and prism aspect ratio. Values from
0.01 to 0.50 favor improving the prism aspect ratio, while those from 0.50 to 0.99 favor improving prism
warpage. A value of 0.5 favors neither. The farther the value is from 0.5, the greater the effect.

Stay on geometry
The default is, when a grid is smoothed, the nodes are restricted to the geometry -- surface, curves and
points -- and can be moved only along the geometrical entities to which they are associated.

Violate Geometry
Enabling this option allows the smoothing operation to yield a higher quality mesh by violating the
constraints of the geometry. The nodes can be moved off the geometry to obtain better mesh quality,
as long as the movement remains within the absolute distance specified.

Relative Tolerance
This option works in the similar fashion as Violate Geometry except that the distance is relative here.

Allow refinement
If the quality of the mesh cannot be improved through normal algebraic smoothing, the Allow refinement
option will allow the smoother to automatically subdivide elements to obtain further improvement. After
smoothing with Allow refinement enabled, it may be necessary to smooth further with the option dis-
abled. The goal is to reduce the number of elements that are attached to one vertex by refinement in
problem regions.

Laplace smoothing
This option will solve the Laplace equation, which will generally yield a more uniformly spaced mesh.

Note

This can sometimes lead to a lower determinant quality of the prisms. Also, this option
works only for the triangular surface mesh.

Allow node merging
This option will collapse and remove the worst tetra and prism elements when smoothing in order to
obtain a higher quality mesh. This is enabled by default, and is often very useful in improving the grid
quality.

Not just worst 1%
This option will smooth all of the geometry's elements to the assigned quality (specified under Up to
quality) not just focus on the worst 1% of the mesh. Typically, when a mesh is smoothed, the smoother
concentrates on improving the worst regions; this option will allow the smoother to continue smoothing
beyond the worst regions until the desired quality is obtained.

Surface fitting
This option will smooth the mesh, keeping the nodes and the new mesh restricted to the surface of the
geometry. Only Hexa models will utilize this option.
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Important Features in Tetra

Ignore PrePoints

This option will allow the smoother to attempt to improve the mesh quality without being bound by
the initial points of the geometry. This option is similar to the Violate geometry option, but works only
for points located on the geometry. This option is available only when there are hexahedral elements
in the model. Usually, the best way to improve the quality of grids that cannot be smoothed above a

certain level is to concentrate on the surface mesh near the bad elements and edit this surface mesh to
improve the quality.
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Prism Mesh

Tetra meshing is not efficient for capturing shear or boundary layer physics. Prism mesh efficiently
captures these effects near the surface while maintaining the ease and automation of Tetra mesh. Prism
has always been necessary for CFD customers, but now that the option is more widely available, many
other branches of CAE have started using prisms to better resolve the physics perpendicular to the
surfaces of their models. With ANSYS ICEM CFD, Prism and Tetra generation is automatic and intelligent.

The spacing of the prism layers to capture the Y+ for Navier-Stokes mesh is the primary concern. The

rate of volume change between cells is also important. Calculations are done between nodes or elements,
and Prism mesh gives you more elements perpendicular to the surface. This is an efficient way to achieve
better resolution (more calculations per unit distance) of the solution normal to the surface, without
increasing the number of elements along the surface. This gives you a quicker and more accurate

solution than can be achieved with a very fine tetra mesh.

The height and direction of the prism layer extrusion are calculated on an element by element basis
and may vary due to global or local controls, or for improved quality. You may choose to set the initial
height, number of layers and growth ratio, which are then used to determine the Prism height limit
factor. Or you may prefer to set only the number of layers and growth ratio, which then allows Prism
to adjust the initial height and locally optimize the volume transition between the prisms and tetras.
Users concerned about Y+ can then adjust the first cell height using Edit Mesh > Split Mesh > Split
Prisms.

Prism parameters are set globally, but can then be adjusted on a part by part or entity by entity basis.
Entity settings override global settings, and between entities the smaller size overrides the larger. For
instance, 3 layers could be set for a growth rate of 1.2 globally, but a certain part could be set for 5
layers. Setting a specific parameter on a single entity within that part or another part is handled intelli-
gently. For example, if you set a local parameter such as height on a single curve entity, Prism will in-
terpolate that parameter smoothly across the surface between curves.

You may notice that you can also select volume parts for prism. If no volume parts are selected, it will
assume that you want to grow prisms into all volumes bordering the prism surfaces. If you select spe-
cific volume parts, then prism will be grown only into those volumes.

After each layer is extruded, smoothing is done according to the global settings. The layers are grown
one at a time. This continues until all the requested layers are grown. You can add prisms to exiting
layers or you can subdivide and redistribute layers at a later date. You can save time by growing only
a few thicker layers and then subdividing them into many layers. The smoothing is the most time con-
suming part, so for simple configurations, it may be best to turn off all smoothing but grow all the
layers one at a time. This allows you to take advantage of the variable height feature.

There are two ways to generate prism mesh:
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Compute Mesh > Prism Mesh
This option is used to grow prism layers next to wall geometries. You can define the local initial height,
growth ratio, and number of layers at Mesh > Global Mesh Setup > Global Prism Settings. This option
can create prisms from existing volume or surface mesh.

Note

If the existing volume mesh is tet/hexa mesh, on the hexa side the prisms will be added
within the first hexa layer.

Compute Mesh > Volume Mesh > Create Prism Layers
This option allows you to directly create tetra mesh with prisms next to wall geometries. You can choose
whether to create prism mesh from the geometry and/or the surface mesh.

Note

+ If many prism layers are needed, it is faster and can be more robust to create initial thick prism
layers and then split them to create the total desired number of prism layers using Edit Mesh
> Split Mesh > Split Prisms.

+ You can compute a prism mesh without an input surface model loaded. Prism will generate a
temporary faceted surface model from the input mesh.

Prism Mesh Process

The prism mesh process generates prism elements near boundary surfaces from tetrahedral volume or
triangular surface mesh. This batch process creates prisms by extrusion of the surface mesh, and the
resulting prisms are made conformal with any existing tetrahedral volume mesh. The prism mesh can
be smoothed to yield the necessary quality.

Prism Mesh Preparation

When generating prism mesh, preparation is key. It is easier to edit a tetra mesh than a tetra prism
mesh. Prism mesh can also be difficult to smooth, so it will save time to start with good quality tetra
or tri surface mesh.

Start with the best possible initial hybrid mesh quality
Hybrid mesh is generally difficult to smooth.

Start with good Tetra or Tri surface mesh
+ Choose prism options carefully
+ Check aspect ratios / quality.

+ Check and fix all diagnostics. Single/multiple edges, Non-manifold vertices, and Duplicate elements
will crash the prism mesher.

+ Visually scan the surface mesh. Look for any surface discrepancies or sharp tent-like structures in
the mesh.
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Prism Mesh Process

+ Make sure part associations are correct.

Look for a few elements of one part scattered among another part. Extruding from a few
isolated elements will likely crash the prism mesher. Modify part assignments of such elements.

+ Use the Smoothing Options for Tetra and Tri surface mesh under Mesh > Prism before creating
prism mesh.

+ Laplace Triangle Quality type is typically best for eventual prism quality.
Smoothing Tetra/Prism Mesh
First smooth the tetra and tri elements (set PENTA_6 to Freeze). Once the tetra and tri elements are as

smooth as possible, then smooth all elements at the same time (including PENTA_6). Decrease the Up
to quality value, so that the prism elements are not distorted too much.
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Hexa

Hexa is a 3D object-based, semi-automatic, multi-block structured and unstructured, surface and volume
mesher.

Introduction

Features of Hexa

Mesh Generation with Hexa

The Hexa Database

Intelligent Geometry in Hexa

Unstructured and Multi-block Structured Meshes

Blocking Strategy

Automatic O-grid generation

Edge Meshing Parameters

Smoothing Techniques

Refinement and Coarsening

Replay Functionality

Periodicity

Pre-Mesh Quiality

Most Important Features of Hexa

Introduction

Hexa represents a new approach to hexahedral mesh generation. The block topology model is generated
directly on the underlying CAD geometry. Within an easy-to-use interface, those operations most often
performed by experts are readily accessible through automated features.

There is access to two types of entities during the mesh generation process in Hexa: block topology
and geometry. After interactively creating a 3-D block topology model equivalent to the geometry, the
block topology may be further refined through the splitting of edges, faces and blocks. In addition,
there are tools for moving the block vertices, either individually or in groups, onto associated curves
or CAD surfaces. You may also associate specific block edges with important CAD curves to capture
important geometric features in the mesh.

Moreover, for models where you can take advantage of symmetry conditions, topology transformations
such as translate, rotate, mirror and scaling are available. The simplified block topology concept allows
rapid generation and manipulation of the block structure and, ultimately, rapid generation of the
hexahedral meshes.

Hexa provides a projection-based mesh generation environment where, by default, all block faces
between different materials are projected to the closest CAD surfaces. Block faces within the same
material may also be associated to specific CAD surfaces to allow for definition of internal walls. In
general, there is no need to perform any individual face associations to underlying CAD geometry,
which further reduces the difficulty of mesh generation.

Features of Hexa

Some of the more advanced features of Hexa include:
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O-grids: For very complex geometry, Hexa automatically generates body-fitted internal and external
O-grids to parametrically fit the block topology to the geometry to ensure good quality meshes.

Edge-Meshing Parameters: Hexa's edge-meshing parameters offer unlimited flexibility in applying
user specified bunching requirements.

Time Saving Methods: Hexa provides time saving surface smoothing and volume relaxation algorithms
on the generated mesh.

Mesh Quality Checking: With a set of tools for mesh quality checking, elements with undesirable
skewness or angles may be displayed to highlight the block topology region where the individual blocks
need to be adjusted.

Mesh Refinement/Coarsening: Refinement or coarsening of the mesh may be specified for any block
region to allow a finer or coarser mesh definition in areas of high or low gradients, respectively.

Replay Option: Replay file functionality enables parametric block topology generation linked to para-
metric changes in geometry.

Symmetry: As necessary in analyzing rotating machinery applications, for example, Hexa allows you
to take advantage of symmetry in meshing a section of the rotating machinery thereby minimizing the
model size.

Link Shape: This allows you to link the edge shape to existing deforming edge. This gives better control
over the grid specifically in the case of parametric studies.

Adjustability: Options to generate 3D surface meshes from the 3D volume mesh and 2D to 3D block
topology transformation.

Mesh Generation with Hexa

To generate a mesh within Hexa you need to:
+ Import a geometry file using any of the direct, indirect or faceted data interfaces.

+ Interactively define the block model through split, merge, O-grid definition, edge/face modifications
and vertex movements.

+ Check the block quality to ensure that the block model meets specified quality thresholds.

+ Assign edge meshing parameters such as maximum element size, initial element height at the
boundaries and expansion ratios.

+ Generate the mesh with or without projection parameters specified. Check the Mesh quality to ensure
that specified mesh quality criteria are met.

+ Write Output files to the desired solvers.

If necessary, you may always return to previous steps to manipulate the blocking if the mesh quality
does not meet the specified threshold or if the mesh does not capture certain geometry features. The
blocking may be saved at any time, thus allowing you to return to previous block topologies.
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Unstructured and Multi-block Structured Meshes

Additionally, at any point in this process, you can generate the mesh with various projection schemes
such as full face projection, edge projection, point projection or no projection at all.

Note

In the case of no projection, the mesh will be generated on the faces of the block model
and may be used to quickly determine if the current blocking strategy is adequate or if it
must be modified.

The Hexa Database

The Hexa database contains both geometry and block topology data, each containing several sub-en-
tities.

The Geometric Data Entities:

+ Points: x, y, z point definition

+ Curves: trimmed or untrimmed NURBS curves

+ Surfaces: NURBS surfaces, trimmed NURBS surfaces

The Block Topologic Data Entities:

+ Vertices: corner points of blocks, of which there are at least eight, that define a block
+ Edges: a face has four edges and a block twelve

+ Faces: six faces make up a block

+ Blocks: volume made up of vertices, edges and faces

Intelligent Geometry in Hexa

Using ANSYS ICEM CFD's Direct CAD Interfaces, which maintain the parametric description of the
geometry throughout the CAD model and the grid generation process, hexahedral grids can be easily
remeshed on the modified geometry.

The geometry is selected in the CAD system and tagged with information (made intelligent) for grid
generation such as boundary conditions and grid sizes, and this intelligent geometry information is
saved with the master geometry.

In Hexa, by updating all entities with the update projection function, blocking vertices projected to
prescribed points in the geometry are automatically adapted to the parametric change and one can
recalculate the mesh immediately. Additionally, with the use of its Replay functionality, Hexa provides
complete access to previous operations.

Unstructured and Multi-block Structured Meshes

The mesh output of Hexa can be either unstructured or multi-block structured, and need not be de-
termined until after you have finished the whole meshing process when the output option is selected.
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Unstructured Mesh Output

The unstructured mesh output option will produce a single mesh output file where all common nodes
on the block interfaces are merged, independent of the number of blocks in the model.

Multi-Block Structured Mesh Output

Used for solvers that accept multi-block structured meshes, this output option will produce a mesh
output file for every block in the topology model. For example, if the block model has 55 blocks, there
will be 55 output files created in the output directory.

Additionally, without merging any of the nodes at the block interfaces, the Output Block option allows
you to minimize the number of output files generated with the multi-block structured approach.

Blocking Strategy

With Hexa, the basic steps necessary to generate a hexahedral model are the same, regardless of

model complexity. The blocking topology, once initialized, can then be modified by splitting and merging
the blocks, as well as through the use of an operation called O-grid (Refer to the next section). While
these operations are performed directly on the blocks, the blocks may also go through indirect modific-
ation by altering the sub-entities of the blocks (i.e.: the vertices, edges, faces).

Upon initialization, Hexa creates one block that encompasses the entire geometry. The subsequent
operations under the Blocking menu of developing the block model, referred to as "blocking the geo-
metry," may be performed on a single block or across several blocks.

Note
The topologic entities in Hexa are color-coded based on their properties.
Colors of Edges:

White Edges and Vertices
These edges are between two material volumes. The edge and the associated vertices
will be projected to the closest CAD surface between these material volumes. The
vertices of these edges can move only on the surfaces.

Note

These display in black if you have chosen a light colored background
for the graphics display window.

Blue Edges and Vertices
These edges are in the volume. The vertices of these edges, also blue, can be moved
by selecting the edge just before it and can be dragged on that edge.

Green Edges and Vertices
These edges and the associated vertices are being projected to curves. The vertices
can be moved only on the curve(s) to which they are being projected.

Red Vertices
These vertices are projected to prescribed points.
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Automatic O-grid generation

Hexa Block Types

When blocking a model, it is important to note that the block type affects many operations within Hexa
and the entire approach to mesh generation. For example, if you split a model with mapped blocks,

the split will propagate through faces that have a mapped relationship on the opposite side. For free
blocks, a split will terminate at the free face. Similarly, if you set edge parameters on a mapped face
edge, opposite edges will have a similar number of nodes. If however, that edge is attached to a free
face, the number of nodes on the opposite side will not be adjusted. Using this free/mapped relationship,
you can shape the blocking and resulting mesh.

The ability to convert blocks from free to mapped or vice versa imposes constraints on the blocking
and resulting mesh. By imposing more constraints, you can enforce a greater number of hexa elements,
while reducing the constraints can sometimes improve mesh transitioning.

Figure 26: Hexa Block Types
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The Split function, which divides the selected block interactively, may be applied across the entire block
or to an individual face or edge of a block by using the Split face or Split edge options, respectively.
Blocks may be isolated using the Index control.

Merge

The Merge function works similar to split blocks; one can either merge the whole block or merge only
a face or an edge of the block.

While some models require a high degree of blocking skill to generate the block topology, the block
topology tools in Hexa allow you to quickly become proficient in generating a complex block model.

Automatic O-grid generation

Generating O-grids is a very powerful and quick technique used to achieve a quality mesh to model
geometry when the you desire a circular or "O"-type mesh either around a localized geometric feature
or globally around an object. This process would not have been possible without the presence of O-
grids.
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Using the Automatic O-grid

The O-grid creation capability is simply the modification of a single block or blocks to a 5 sub-block
topology as shown below. There are several variations of the basic O-grid generation technique and
the O-grid shown below is created entirely inside the selected block.

Figure 27: Initial block, Block with O-Grid, O-Grid with Add Face
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Using the Add face option, an O-grid may be created such that the O-grid passes through the selected
block face(s). In Figure 27: Initial block, Block with O-Grid, O-Grid with Add Face (p. 42), the Add Face
option was used on the last block to include one face on the block prior to generating the O-grid.

Important Features of an O-grid

Generation of Orthogonal Mesh Lines at an Object Boundary
The generation of the O-grid is fully automatic and you simply select the blocks needed for O-grid
generation. The O-grid is then generated either inside or outside the selected blocks. The O-grid may
be fully contained within its selected region, or it may pass through any of the selected block faces.

Rescaling an O-grid After Generation
When the O-grid is generated, its size is scaled based upon a factor in the Blocking > O-grid parameter
window. The Re scale O-grid option allows you to re-scale the previously generated O-grid.If a value
less than 1 is assigned, the resulting O-grid will be smaller than the original. Conversely, a value larger
than 1, will result in a larger O-grid.
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Edge Meshing Parameters

The blocks may also be modified by moving the vertices of the blocks and by defining specific rela-
tionships between the faces, edges and vertices to the geometry.

Edge Meshing Parameters

The edge meshing parameter task has been greatly automated to provide you with unlimited flexibility
in specifying bunching requirements. Assigning the edge meshing parameters occurs after the develop-
ment of the block topology model. This option is accessible by selecting Meshing > Edge params.

You can use the following pre-defined bunching laws or Meshing laws:
+ Default (Bi-Geometric Law)
+ Uniform

* Hyperbolic

*+ Poisson

+ Curvature

+ Geometric 1

+ Geometric 2

+ Exponential 1

+ Exponential 2

* Bi-Exponential

* Linear

+ Spline

You may modify these existing laws by applying pre-defined edge meshing functions, accessible through
the Meshing > Edge Params > Graphs option in Hexa.

This option yields these possible functions:
+ Constant

*+ Ramp

+ Scurve

+ Parabola Middle

+ Parabola Ends

+ Exponential

+ Gaussian

* Linear
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+ Spline

Note

By selecting the Graphs option, you may add/delete/modify the control points governing
the function describing the edge parameter settings. Additional tools such as Linked
Bunching and the multiple Copy buttons provide you with the ability to apply the
specified edge bunching parameters quickly to the entire model.

Smoothing Techniques

In Hexa, both the block topology and the mesh may be smoothed to improve the overall block/mesh
quality either in a certain region or for the entire model. The block topology may be smoothed to improve
the block shape prior to mesh generation. This reduces the time required for development of the block
topology model.

The geometry and its associative surfaces, curves, and points are all constraints when smoothing the
block topology model. Once the block topology smoothing has been performed, you may smooth the
mesh after specifying the proper edge bunching parameters.

The quality criteria for smoothing are described in the Help Manual, under Blocking > Pre-Mesh Quality.

Refinement and Coarsening

The refinement function, which is found through Blocking > Pre-Mesh Params > Refinement, can be
modified to achieve either a refined or a coarsened result. The refinement/coarsening may be applied
in all three major directions simultaneously, or they may be applied in just one major direction.

Refinement

The refinement capability is used for solvers that accept non-conformal node matching at the block
boundaries. The refinement capability is used to minimize the model size, while achieving proper mesh
definition in critical areas of high gradients. Entering a scale factor greater than 1 will result in refinement.

Coarsening

In areas of the model where the flow characteristics are such that a coarser mesh definition is adequate,
coarsening of the mesh may be appropriate to contain model size. Entering a scale factor less than 1
will result in coarsening.

Replay Functionality

Parametric changes made to model geometry are easily applied through the use of Hexa's replay
functionality, found in File > Replay Scripts. Changes in length, width and height of specific geometry
features are categorized as parametric changes. These changes do not, however, affect the block topology.
Therefore, the Replay function is capable of automatically generating a topologically similar block

model that can be used for the parametric changes in geometry.

If any of the Direct CAD Interfaces are used, all geometric parameter changes are performed in the
native CAD system.
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Periodicity

You can also use variables in the replay script to parameterize edge parameters. Refer to Using Variables
in the Replay Script in the User's Guide for details.

Generating a Replay File

The first step in generating a Replay file is to activate the recording of the commands needed to gen-
erate a custom meshing process. All of the steps in the mesh development process are recorded, including
blocking, mesh size, edge meshing, boundary condition definition, and final mesh generation. The next
step in the process is to make the parametric change in the geometry and then replay the recorded

file on the changed geometry. All steps in the mesh generation process are automated from this point.

Advantage of the Replay Function

With the Replay option, you may analyze more geometry variations, thus obtaining more information
on the critical design parameters. This can yield optimal design recommendations within the project
time limits.

Using Variables in the Replay Script

You can use variables in the replay script as a means to parameterize edge parameters. An example of
the use of variables in a replay script is as follows:

#vari abl es

set n 10

set hl 0.01

set r1 1.2

ic_load_tetin nmyfile.tin

i c_hex_surface_blocking -inherited -swept -nmin_edge 0.0

ic_geo_new famly SCLID

ic_hex_twod_to_threed SOLID -swept

ic_hex_set_mesh 19 18 n $n hl $hl h2rel 0.0 r1 $r1 r2 2 Inax O default unl ocked

i c_hex_create_nmesh SURFS SOLID proj 2 dimto_nesh 3

ic_hex_wite_file hex.uns SURFS SOLID proj 2 dimto_nmesh 3 -fanmily_boco fam|y_boco. fbc

ic_uns_load hex.uns 3 0 {} 2

The variables for the edge parameters are set at the top of the replay file. Within the script, the '$" in-
dicates a variable. To parameterize the edge parameters, you may update the variables at the top of
the script and then rerun the script.

Periodicity

Periodic definition may be applied to the model in Hexa. The Periodic nodes function, which is found
under Blocking > Periodic nodes, plays a key role in properly analyzing rotating machinery applications,
for example. Typically, you will model only a section of the rotating machinery, as well as implement
symmetry, in order to minimize the model size. By specifying a periodic relationship between the inflow
and outflow boundaries, the particular specification may be applied to the model—flow characteristics
entering a boundary must be identical to the flow characteristics leaving a boundary.

Applying the Periodic Relationship

The periodic relationship is applied to block faces and ensures that a node on the first boundary have
two identical coordinates to the corresponding node on the second boundary. You will be prompted

to select corresponding vertices on the two faces in sequence. When all vertices on both flow boundaries
have been selected, a full periodic relationship between the boundaries has been generated.
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Hexa

Pre-Mesh Quality

The pre-mesh quality functions are accessible through Blocking > Pre-Mesh Quality. Applying any of
the quality checks will yield a histogram plot.

Determining the Location of Elements

By clicking on any of the histogram bars with the left button, you may determine where in the model
these elements are located. The selected histogram bars will be highlighted by a change in color. After
selecting the bar(s), the Show option is selected to highlight the elements in this range. If the Solid
option is enabled, the elements marked in the histogram bars will be displayed with solid shading.

Some of the quality metrics are explained below.
Determinant
Angle
Volume
Warpage

Determinant

The Determinant check computes the deformation of the elements in the mesh by first calculating of
the Jacobian of each hexahedron and then normalizing the determinant of the matrix. A value of 1
represents a perfect hexahedral cube, while a value of 0 is a totally inverted cube with a negative
volume.

The mesh quality, measured on the x-axis, of all elements will be in the range from 0 to1. If the determ-
inant value of an element is 0, the cube has one or more degenerated edges. In general, determinant
values above 0.3 are acceptable for most solvers. The subdivision across the quality range is determined
by the number of assigned Bars

The y-axis measures the number of elements that are represented in the histogram. This scale ranges
from 0 to a value that is indicated by the Height.

Angle

The Angle option checks the maximum internal angle deviation from 90 degrees for each elements.
Various solvers have different tolerance limits for the internal angle check. If the elements are distorted
and the internal angles are small, the accuracy of the solution will decrease. It is always wise to check
with the solver provider to obtain limits for the internal angle threshold.

Volume

The Volume check will compute the internal volume of the elements in the model. The units of the
volume will be displayed in the unit that was used to create the model.

Warpage

The Warpage check will yield a histogram that indicates the level of element distortion. Nodes that are
in-plane with one another will produce an element with small warpage. Nodes that make elements
twisted or distorted will increase a element's distortion, giving a high degree of warpage. The y-axis is
the scale for the number of elements represented in the histogram - a value determined by the assigned

ANSYS ICEM CFD 15.0 - © SAS IR, Inc. AlTrights reserved. - Contains proprietary and confidential in-
46 formation of ANSYS, Inc. and its subsidiaries and daffiliates.



Most Important Features of Hexa

Height. The x- axis, which ranges from a Min of 0 to a Max of 90, is the degree of warpage that an
element experiences.

Most Important Features of Hexa

Hexa has emerged as the quickest and most comprehensive software for generating large, highly accurate,
3D geometry-based hexahedral meshes. Now, in the latest version of Hexa, it is also possible to generate
3D surface meshes with the same speed and flexibility.

+ CAD- and projection-based hexahedral mesh generation

+ Easy manipulation of the 3D object-based topology model

+ Modern GUI and software architecture with the latest hexahedral mesh technology
+ Extensive solver interface library with over 100 different supported interfaces

+ Automatic O-grid generation and O-grid re-scaling

+ Geometry-based mesh size and boundary condition definition

+ Mesh refinement to provide adequate mesh size in areas of high or low gradients
* Smoothing/relaxation algorithms to quickly yield quality meshes

+ Generation of multi-block structured, unstructured, and super- domain meshes

+ Ability to specify periodic definitions

+ Extensive replay functionality with no user interaction for parametric studies

+ Extensive selection of mesh bunching laws including the ability to graphically add/delete/modify
control points defining the graph of the mesh bunching functions

+ Link bunching relationships between block edges to automate bunching task

+ Topology operations such as translate, rotate, mirror, and scaling to simplify generation of the topology
model

« Automatic conversion of 3D volume block topology to 3D surface mesh topology

+ Automatic conversion of 2D block topology to 3D block topology

+ Block face extrusion to create extended 3D block topology

+ Multiple projection options for initial or final mesh computation

+ Quality checks for determinant, internal angle and volume of the meshes

+ Domain renumbering of the block topology

+ Output block definition to reduce the number of multi-block structured output mesh files

+ Block orientation and origin modification options
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Properties

The Properties menu allows you to create different materials by specifying material or element properties,
such as type, the Young's Modulus, and Poisson's ratio. Once the material is created, you can apply
those properties to the elements.

Create Material Property

Save Material

Open Material

Define Table

Define Element Properties

Create Material Property

You can define a material by specifying a name of the material, define whether isotropic, enter in values
for Young's Modulus, Shear modulus, Poisson's ratio, Mass Density, and Thermal expansion coefficient.

Save Material

The Write Material File option allows you to save the material specification so that it may be reused
whenever necessary. The material file will be saved with the .mat extension.

Open Material

The Load Material From File option allows you to open a material file to be used in your design, or
modified and saved for future use.

Define Table

The Create Table option allows you to create your material property empirically by entering values for
x and y ,You may even visualize the graph of the property.

Define Element Properties

These options allow you to apply your material properties to their respective elements. Different types
of elements that can be defined include: Point, Line, Shell, and Volume. After choosing the part, the
various properties are applied to its elements.
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Constraints

From the Constraints tab, you can define the motion restrictions on different entities such as points,
curves, surfaces, or subsets, as well as define other options such as Contact definition, Velocity and
Rigid Wall.

Create Constraint / Displacement

Define Contact

Define Single Surface Contact

Define Initial Velocity

Define Planar Rigid wall

Create Constraint / Displacement

This option allows you to apply a directional or rotational constraint on an entity, in any direction.
Define Contact

This option allows you to define contacts by Automatic Detection or Manual Definition.
Define Single Surface Contact

This is mainly used for LS-DYNA Solver, where you can pick the contact surface.

Define Initial Velocity

This allows you to define initial nodal point velocities by specifying the translational and rotational ve-
locity for nodal sets.

Define Planar Rigid wall

You can define a Planar Rigid Wall by specifying the Head and Tail coordinates.
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Loads

In this tab, there are several options available for applying internal and external loads, such as force,
pressure, and temperature. How ICEM CFD treats the load depends on how the load is applied - to a
curve, a surface, or a mesh. In all cases, the load information is not calculated until the user is creating
the output files for one of the supported "Common Structural” solvers, — ANSYS, Autodyn, LS-DYNA,
ABAQUS, or NASTRAN. That is, the output file is generated thru the Solve Options Tab, and at this time,
the loads will be written out according to the selected solver's published format.

Theory
Applied forces are distributed as follows.
By Curve

The total Force 'F;' may be applied on a curve as shown below. Applying the load to a geometry entity

simplifies the process for you and keeps the load information at the geometry level so the mesh can
be regenerated without losing the setup information.

Figure 28: Force on a Curve

Nodes are numbered 0, 1, 2, and so on. Elements between the nodes have lengths L,, L, and so on.
The total length is Ly

Then the force on the Nodes, as per FEA concepts, is distributed linearly in proportion to the Element
length as shown in the figure below.
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Loads

Figure 29: Linear Force Distribution
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For a Linear distribution, the load at each node is calculated as follows.
Node 0: F, = 0.5 * Fr * (L, / Ly)

Node 1: F; =05 *F; * (L, /Ly) + 0.5 * Fr * (L, / Ly)

Node 2: F, =05 *F+ * (L, / Ly) + 0.5 * Fr * (L3 / Ly)

Node 3: F3=05*F; * (L3 / Lp) + 0.5 * F * (L, / Ly)

Node 4: F, =05 *F; * (L, / Ly)

In general, the force at any Node is: F; = Sum [ F * (L; / L7) * (1 / N;) 1, where i is the node number, j
is the element number, L; is the length of element j, and N; is the number of Nodes attached to element

j-
As a check, if you add the individual node forces, Fy + F; + F5 + F3 + F4, then the result equals Fy.
By Mesh Elements

You may also apply loads directly to the elements (select the elements directly rather than the geometry
entities).This may occur, for example, if you don’t have the geometry in a particular model or area of a
model. In this case, the load is distributed element-by-element using a Quadratic distribution as shown.
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Figure 30: Force on Elements with mid-side nodes
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Node numbers and element lengths are defined as before. In addition, each element has a mid-side
node labelled m;, m,, and so on.

The Quadratic Load distribution, as per FEA concepts on an element-by-element basis is shown in Fig-
ure 31: Quadratic Load Distribution (p. 55).

Figure 31: Quadratic Load Distribution
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The distribution of the Total Force, Fy, at the boundary nodes is as follows:
Node 0: Fo, = 1/6 * Fr * (L; / Ly)

Node 1: Fyq=1/6 * Fr * (Ly / Ly) + 1/6 * Fr * (Ly / Ly)
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Loads

Node 2: F,, = 1/6 * Fr * (L, / Ly) + 1/6 * Fr * (L3 / Ly)
Node 3: F3, = 1/6 * Fy * (L3 / Ly) + 1/6 * Fr * (L / Ly)
Node 4: F,, = 1/6 * F1 * (L4 / Ly)

And the distribution at mid-side nodes is:

Node m: F i =2/3*Fr* (L, / Ly)

Node my: F, =2/3*Fr* (L, / Ly)

Node m3: F 5 =2/3 *Fr * (L3 / Ly)

Node my: F s =2/3*Fr* (Ly/ Ly)

As in the previous case of linear distribution, you can check the total Force by adding the individual
nodal forces:

FT = Foq + F]q + qu + F3q + F4q + Fm-l + sz + Fm3 + Fm4.
By Surface

If you choose to set a load on a surface entity, then the load distribution follows the Nine Node, Two
Dimension, Lagrange distribution. See the Figure 32: QUAD 9 Element (p. 56) for an illustration.

Figure 32: QUAD 9 Element
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Nine nodes are identified: N;-N, at the corners; N5-Ng at the mid-sides; and Ng in the middle. The symbols

¢ and n define a local coordinate system for the development of the load distribution, and vary from
-1 to +1 over the surface of the element.

The Shape function for the distribution at a Corner Node is:

N =y F- 1l -1

At a Mid-Side Node, the Shape function for the distribution is:
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And finally, the Shape function for the Middle Node load distribution is:

Ny, (&) = (1=-E%)-(1-7%)

Suppose a Force F is uniformly distributed over the whole Area. Then the pressure is P = F / 4. (Because
in the £-1 coordinate system the area of the surface is 4.)

To find the Consistent Load at each Node, we must integrate the Shape function over the surface area:

Consistent Load at Node 1 =L;:

¢=1 =1 4P
Li=Pfz= [y = - (Ndédn ==

Consistent Load at Node 5 = Ls:

=1 ;7:1 4P
Li=Pfeo —4fy = - (Nsdédn ==

Consistent Load at Node 9 = Lg:

16P

¢=1 =1
Ly=P-fz2 4], = — 1 Nodcdn ==

Now F =4 P.

Substituting this value in the above equations we get the Consistent Load as

L,=F/36
Ly=4F /9

By symmetry, the Consistent Load on all corner nodes N;, N, N3, and N, are equal.
Similarly, the Consistent Load on all mid-side nodes Ns, Ng, N5, and Ng are equal.

As with the Linear and Quadratic distributions, a check against the Total can be performed.

The sum of the Consistent Loads =4 * L; + 4 * Ls + Lg

=F/9+4F/9+4F/9
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Note

A similar process for calculating the Consistent Load on a QUAD8 element load distribution
is available. Again, the output file is generated thru the "Solve Options" Tab, and during
output, the distributed load information will be written out according to the selected solver's
published format.

Force

Using this option, you can apply translational (force) or rotational (moment) loads on entities in all three
directions.

Forces can be applied by two different options. The Uniform option applies the stated force at all selected
entities. For example with curves, the Uniform option will apply the full force to all nodes attached to

the curve. The Total option means that the force gets distributed among all the nodes of the selected
entities according to FEA concepts.

Pressure

You can apply pressure loads to surfaces, subsets, or parts. See the Help for more detail.

Temperature

This option allows you to apply temperature to points, curves, surfaces, bodies, and subsets.See the
Help for more Detail.
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Solve Options

Setup Solver Parameters has options for specifying the solver parameters. You can also specify the
analysis solution parameters.

Setup Solver Parameters

You can select from the following solvers: ANSYS, Nastran, ABAQUS, Autodyn, and LS-DYNA.

Setup Analysis Type

Depending on the selected solver, different options are available. For the ANSYS solver, you can select
either Structural or Thermal. If Nastran solver is selected, then you have the choice of more Analysis

types.
Setup Sub-Case

You can create subcases to apply the load in different steps.

Write/View Input file

You can create and view the input file generated for the solver.

Submit Solver Run

Using this option, you can solve the input file generated for a particular solver.

FEA Solver Support

More information about the supported solvers is available from the Help menu. The Output Interfaces
option opens the ANSYS ICEM CFD Output Interfaces information in a browser. For information about
a specific solver, refer to the Table of Supported Solvers and click the name of the solver.
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Workbench Integration

The data-integrated ICEM CFD component system, or “ICEM CFD Add-in’ enables you to launch ICEM
CFD from ANSYS Workbench and use it to build a project, with the option of adding upstream data
from Geometry, Mesh, Mechanical Model, or combined Geometry and Mesh system components. You
can also use ICEM CFD to provide data to downstream component systems, such as ANSYS Fluent,
ANSYS CFX, ANSYS Polyflow, Mechanical APDL, and FE Modeler.
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The additional features available through the ICEM CFD add-in are described in the following sections:

Elements of the ICEM CFD Component (p. 62)

Creating an ICEM CFD Component (p. 63)

Updating ICEM CFD Projects (p. 64)

Interface Differences in the Data-Integrated ICEM CFD (p. 67)

Setting Parameters (p. 69)

+ User-Defined Parameters Example (p. 75)
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Workbench Integration

Elements of the ICEM CFD Component

- B
. BT
——a2i@ Model F

> 3 |[pd Parameters
ICEM CFD

[pd Parameter Set

The ICEM CFD Component system contains the following cells:

+ ICEM CFD system header. The System Header identifies the component type and provides access to
Workbench context menu options. The ICEM CFD system header context menu options include:

Refresh

Update

Duplicate

Delete

Rename

Properties

Add/Edit Note

These standard actions are described in the System Header Context Menu Options and Duplicating, Moving,
Deleting, and Replacing Systems sections of the Workbench User's Guide.

Note

If available, Update will use the ICEM CFD Replay file to update the ICEM CFD project.

Note

Scripts written in ICEM CFD may not be parametric with upstream or downstream projects.
Care should be taken to write scripts whose functions do not exceed the capabilities of the
upstream or downstream component systems.

+ Model cell. The Model Cell is associated with the ICEM CFD application. You can use the Model Cell to
modify some aspects of the project. You can also double-click the Model Cell to open the project in ICEM
CFD. The Model cell context menu items include the following:

- Edit: Opens the ICEM CFD application and loads an existing Geometry/ICEM CFD file.
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Creating an ICEM CFD Component

- Duplicate: Copies the entire geometry and mesh data, enabling you to edit the Model cell in the du-
plicate system to investigate an alternative modeling approach.

- Transfer Data From New: Enables the transfer of data from upstream Geometry, Mesh, Mechanical
Model, or combined Geometry and Mesh components.

Note

If the geometry cell option Use Associativity is On (its default setting), Part Reference
IDs are stored in a Workbench database and remain persistent in ICEM CFD even if the
topology of the geometry is changed.

- Transfer Data to New: Enables the transfer of data from an ICEM CFD project to downstream data-in-
tegrated system projects, such as:

- Fluent

- CFX

— FE Modeler

- Polyflow

— Mechanical APDL

- Update, Refresh, Reset, Rename, Properties, and Add/Edit Note. These standard actions are described
in System Header Context Menu Options and Duplicating, Moving, Deleting, and Replacing Systems sections
of the Workbench User's Guide.

An additional property is Create Subset(s) from Named Selection. If this option is set, then
overlapping named selections are transferred to multiple subsets instead of to exclusive parts. This
enables the creation of geometry subsets instead of parts, allowing you to decide which part the
geometry entity (point/curve/surface) should be associated to. When this option is disabled each
geometry is assigned to only one part, thereby losing association with other Named Selections
(which are mapped to parts).

+ Parameters cell (optional). The Parameters Cell enables you to see and edit Input and Output parameters
for ICEM CFD.

Creating an ICEM CFD Component

You can create an ICEM CFD component system in Workbench using any of these methods:
* Double-click the ICEM CFD system template in the Toolbox.

+ Drag-and-drop the ICEM CFD system template onto the Project Schematic.

* Right-click on a Geometry or Mesh project and select Transfer Data to New> ICEM CFD.

+ Choose File>Import to import a standalone ICEM CFD project into Workbench. When the Import dialog
opens, choose ICEM CFD Project File (*.prj) and navigate to the project you want to import.
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Workbench Integration

Updating ICEM CFD Projects

Updating a project in Workbench brings the entire ICEM CFD system up to the most current status, in-
cluding upstream and downstream data.

Changes that require you to update your ICEM CFD project include changes to upstream data and
changes you make in the ICEM CFD editor. When changes are made, the cell in the Project Schematic
window indicates that an update is required. Note, however, that changes made in the ICEM CFD editor
will not cause the system to go out of date until the project, tetin file (geometry), blocking file, and/or
Replay file are saved.

Note

Named selections defined in Mesh systems are available only within the Mesh system. They
are not available to downstream systems like ICEM CFD.

The actions taken by Workbench when the system is updated depends on whether the following con-
ditions are met:

+ Blocking exists.

+ A Replay file exists.

+ Blocking parameters are set.

+ Other input parameters are set.

The following table describes the actions performed by ICEM CFD according to these conditions:

Table 1: Updating ICEM CFD Projects

Blocking Replay Blocking Input Other Input Actions performed
File Parameters Parameters by ICEM CFD
No No No No 1. Runs tetra default
meshing.

2. Saves the unstruc-
tured mesh.

3. Saves the project

Yes No No No 1. Runs hexa default
meshing.

2. Saves the unstruc-
tured mesh.

3. Saves the project.

No No No Yes 1. Sets all input para-
meters.
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Updating ICEM CFD Projects

Blocking

Replay
File

Blocking Input
Parameters

Other Input
Parameters

Actions performed
by ICEM CFD

2.

Runs tetra meshing.
Runs prism meshing
if any Par t

PART _NAME:

Pri sminput para-
meters exist. (See
Setting Parameters
for Prism Mesh-

ing (p.73)

Saves the unstruc-
tured mesh.

Saves the project.

No

Yes

No

Yes

Sets all input para-
meters.

Runs the Replay file.

Saves the unstruc-
tured mesh.

Saves the project.

No

Yes

Yes

Yes

Sets all input para-
meters except block-
ing parameters.

Runs the Replay file.

If blocking now ex-
ists:

a. Sets blocking in-
put parameters.

b. Runs hexa mesh-
ing.

c. Converts pre-
mesh to unstruc-
tured.

d. Saves the unstruc-
tured mesh

Saves the project.

Yes

No

Yes

Yes

Sets all input para-
meters.
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Workbench Integration

Blocking Replay Blocking Input Other Input Actions performed
File Parameters Parameters by ICEM CFD

2. Sets blocking input
parameters.

3. Runs hexa meshing.

4. Converts pre-mesh
to unstructured.

5. Saves the unstruc-
tured mesh.

6. Saves the project.

Yes Yes Yes Yes 1. Sets all the input
parameters except
blocking.

2. Runs the Replay file.
3. If blocking still exists:

a. Sets blocking in-
put parameters.

b. Runs hexa mesh-
ing.

c. Converts pre-
mesh to unstruc-
tured.

d. Saves the unstruc-
tured mesh.

4. Saves the project.

ICEM CFD saves the unstructured mesh and project only if the ICEM CFD GUI is closed and you update
the project from Workbench. If the ICEM CFD is open, you will need to manually save the unstructured
mesh and project.

The order of operations is Meshing input parameters are set before the Replay file is run; Blocking Input
parameters are set after a replay file is run, but only if blocking exists after the replay file is run.

If no Replay file exists, the default mesher is determined by the presence or absence of blocking: if no
blocking exists in the project, tetra is the default. Conversely, if blocking exists in the project, hexa is
the default mesher.

Updating a Project

To update a project and refresh upstream and downstream data, right-click on the Model cell and
choose Update.
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Interface Differences in the Data-Integrated ICEM CFD

The data-integrated ICEM CFD interface has been modified to provide additional functionality that en-
hances the integration of ICEM CFD and Workbench:

+ One-click menus that enable you to control basic project and Replay Recording functions.

Note

If you create Workbench Input Parameters and want to step through the script line-
by-line or using a line range, you must open the Workbench Replay Control dialog
from this menu.

+ The Workbench Replay Control dialog enables you to test and edit Replay scripts created within
Workbench.

You can ensure that you are working within the data integrated environment by checking the Message
window within ICEM CFD. The first line identifies that the application is integrated in the Workbench
Framework.

ICEM CFD 14.5 in W orkbench 2.0 Framework,

Checked out ansysimd feature aieny [product ARSYS ICEM CFD) from zerver 1055@pghlnslicenze

Loading project zettings file: [Ch.prj..

Loading geometry file "ICh_tin"

Current Coordinate spstem iz global

Loading domain "ICH.uns" ...

Loading family boco data from [Ch. fhc
Current Coordinate spstem iz global

One-Click Menus

B eR
The following one-click menu options are available in the Toolbar when you open ICEM CFD from
Workbench:

+ Save Project: Saves the entire project, including Workbench data.
+ Refresh Project: Refreshes the upstream data in the ICEM CFD project.

+ Update Project: Brings the entire ICEM CFD system up to the most current status, including upstream
and downstream data.

+ Start Replay Recording: Begins recording the commands needed to generate a custom meshing
process. All of the steps in the mesh development process are recorded, including blocking, mesh
size, edge meshing, boundary condition definition, and final mesh generation. See Replay Functionality
in the ANSYS ICEM CFD User's Manual. After you click the Start Replay Recording Icon, the icon
changes to the Stop Replay Recording icon. You can click this icon to stop recording.

You can also click on the arrow to choose Pause Replay Recording, Run Replay File, Delete
Replay File, and Replay Control, which opens the Workbench Replay Control dialog.
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@ | Start Replay Recording

il | Pause Replay Recording
[l | Stop Replay Recording

P+ | Run Replay Recording

x Delete Replay File
Workbench Replay Control

Note

If you create Workbench Input Parameters and want to step line by line or using a
line range through a replay file, you must use the Replay Control item from this
menu to start the Workbench Replay Control dialog.

+ Output Mesh: You can choose to save the ICEM CFD mesh output to Fluent, CFX, or Polyflow projects.

2
@

Workbench Replay Control Dialog

The Workbench Replay Control dialog helps you create, test, and edit script files by performing oper-
ations in ANSYS ICEM CFD and recording the equivalent Tcl/Tk commands in a Replay file. You can then
use the dialog to step through and edit the script.

The Workbench Replay Control dialog works exactly the same as the standalone Replay Control
dialog that you open from the File menu, with two key exceptions:

+ The Workbench Replay Control dialog supports Workbench Input Parameters and allows you to
step through them.

+ The dialog automatically loads the current Replay script file (I CM r pl ) instead of opening a file
browser.
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- 'l

FDF{epla}r control in Weorkbench 2.0 Framew... | o || & || £2 |

Operations in scrpt

1. # Replay file ICERM CFD 15,0 in Workbench 2.0 Framewark, ﬂ
2. # unloading geometry
3. ic_unload_tetin
4. ic_empty_tetin

5. # unloading mesh
&

7

a

9

1

. ic_unload_mesh

. # unloading blocking

- ic_her_unload_blocking
. # delete empty parts

0 ic_delete_empty_parts

Rl ol

[v Record [after current] [ Al commands
Do one Do all Do range Skip
Load Save Edit Insert
Delete one Delete all Delete range Renumber
[ Always update W lgnore erars Stop Clean

Dore |

For more information, see Replay Scripts in the ANSYS ICEM CFD Help Manual.

Setting Parameters

Setting Input parameters in Workbench enables you to pass parameters to ICEM CFD and other down-
stream analysis tools. The interaction of parameters between applications provides you with greater
flexibility and capabilities to run optimization and what-if scenarios. For more information about using
parameters in Workbench, see Working with Parameters and Design Points in the Workbench User's Guide.

Parameters may be set globally or individually, with individual parameters taking precedence over
global values.

The parameters you can set are:

* Input Parameters

+ Parameters for all existing curves, surfaces, or edges
+ Mesh parameters for parts

+ User-defined Input Parameters

» Output Parameters
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Setting Input Parameters

Clicking the box to the right of certain Meshing Input parameters enables you to select whether the
parameter is controlled from within ICEM CFD or from within Workbench. A “P” in the check box indicates
that it has been selected as a Workbench Input parameter. If the check box is empty, you can control

the input from within ICEM CFD.

Surface Mesh Setup '@
Surface(z) | ﬁ =
b asirmum zize |2 P
Height |
Height ratio |

You can set the following input parameters in Workbench:

+ Global Mesh Size (See Global Mesh Size in the ANSYS ICEM CFD Help Manual).

+ Shell Meshing (See Shell Meshing Parameters in the ANSYS ICEM CFD Help Manual).

* Volume Meshing (See Volume Meshing Parameters in the ANSYS ICEM CFD Help Manual).
* Prism Meshing (See Prism Meshing Parameters in the ANSYS ICEM CFD Help Manual).

+ Surface Mesh Setup (See Surface Mesh Setup in the ANSYS ICEM CFD Help Manual).

+ Curve Mesh Setup (See Curve Mesh Setup in the ANSYS ICEM CFD Help Manual).

+ Edge Params (See Edge Params in the ANSYS ICEM CFD Help Manual).

For Surface Mesh Setup, Curve Mesh Setup, and Edge Params, you can set parameters either
on all existing surfaces or curves and edges at once, or for a single curve, surface, or edge.

Note

If you create Workbench Input Parameters and want to step line by line or using a line range
through a replay file, you must use the Workbench Replay Control item from the One-Click
menu to start the Workbench Replay Control dialog.

Setting Input Parameters
To set input parameters in Workbench:
1. Within ICEM CFD, choose any of the input parameters listed above.

2. Select the check box next to the parameter.
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3. Click the Yes button in the pop-up dialog to confirm the selection. A P in the check box indicates that
the parameter has been created for Workbench.

Note

You will not be able to edit the parameter within ICEM CFD unless you click the check
box again and deselect the parameter.

4. In Workbench, double-click on the project’s Parameters cell.

5. Edit the parameter values in the Outline of Schematic: Parameters window.

il d Froject . [pd Ferematers
Iipdiaie: AN Desky Foanis
EOTE s [T SEIEY 1552 e N
A Farmratar Crarts & L] [ o a ] - o
1 s Uk | ] | Hams ~ | PL-Sufecs Mesh Sebx Medrun i v | Pa-Mn gusiby of Guslty (TRI_STETRA 4] ~  Exported &
2 1 |Cument |z qdsam

o L #l ol -
6. Click the Project tab to return to the Project Schematic window.

You can now update the project using the new parameter settings.
Setting the parameters for a single curve, surface, or edge

1. Within ICEM CFD, open the Surface Mesh Setup, Curve Mesh Setup, or Edge Params parameters from
the Tab menu.

2. Click the Select button at the top of the Parameters window.
3. Click the Left Mouse button to select the curve, surface, or edge for which you want to set parameters.
4. Click the Middle Mouse button to complete the selection.

The surface, curve, or edge you selected are listed in the selection entry.

Surface Mesh Setup @

Surfacels) [FACEZD x|

5. Select the check box next to the parameter you want as the input parameter.

6. Click the Yes button in the pop-up dialog to confirm the selection. AP in the check box indicates that
the parameter for the single surface, curve or edge has been created for Workbench.
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Setting Parameters for All Existing Curves, Surfaces, or Edges

1.

Within ICEM CFD, open the Surface Mesh Setup, Curve Mesh Setup, or Edge Params parameters from
the Tab menu.

Leave the Surface, curve, or edge selection field empty (do not select any surface, curve or edge).
Select the check box next to the parameter you want as the input parameter

Click the Yes button in the pop-up dialog to confirm the selection. AP in the check box indicates that
the parameter for all existing surfaces, curves or edges has been created for Workbench.

Setting Workbench Mesh Parameters for Parts

The Part Mesh Setup parameters enable you to specify the mesh parameters for different parts of a
geometry. Part Mesh Setup is described in the ANSYS ICEM CFD Help Manual.

To create a Workbench mesh parameter for a part:

1.

2.

Click the Mesh tab.
Click the Part Mesh Setup icon.

In the Part Mesh Setup dialog, choose a part and assign non-zero values to one or more of its paramet-
ers.

Click in the Parameter column for the part.

A dialog asks you to confirm that you want to create a Workbench parameter for each value you've
changed.

Note

If any Workbench parameters are already set for the part, a dialog will ask if you want
to delete that Workbench parameter.

Parameters assigned as Workbench parameters are highlighted in blue.

B¥ Part Mesh Setup =0 el =
Pat ! Prism | Hesta-| Maimm | Height || Height ratiod| Hum] | Tetra | Teirs | Min sos imi | e devistion| Inbsmal wel || Spit | Parameter =
BLADE I [ [ ] I 0 2 r ] F

ILADEZ N 1] i i 0fn ] [1] 0 [ I

anﬁ B [ i 3 Do o 0 0 o | P

iFwG N [ [ 0 o0 lozf o 0 3 [ [ [ r
L 3

[ Shiow size parsms: using sesle [achat

¥ Aapk wllabon paigmeleis bo cuves

[~ Aemowe inllston pasamebsis from curves

Highlghted panlz have at least ane blank iekd because nol all enfilie: in thal pait have idenlical paramaters
Existing workbench input paameters using a bghiblue backgeound

foph | Dimies |

To delete a parameter, click in the Parameter column. A dialog will ask you to confirm that you want
to delete each individual Workbench parameter in the row.
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As with ICEM CFD, the Apply inflation parameters to curves and Remove inflation parameters from
curves options affect Workbench parameter behavior as well. The current value of Apply inflation
parameters to curves is saved to the proj ect file/.ai env_opti ons file so it is always available
in GUI or Batch mode.

Setting Parameters for Prism Meshing

You can add prism meshing parameters using the Part Mesh Setup dialog:

1. Click the Mesh tab.

2. Click the Part Mesh Setup icon.

3. In the Part Mesh Setup dialog, choose a part and check the check box in the Prism column.
4. Click in the Parameter column for the part.

5. A dialog asks you to confirm that you want to create a Workbench parameter for Part PARTNAME:
Prism.

Note

If any Workbench parameters are already set for the part, a dialog will ask if you want
to delete that Workbench parameter.

Setting User-Defined Input Parameters

Setting User-Defined Input Parameters allows for greater flexibility and control over the meshing oper-
ation. For example, parameters that can not be applied as single input parameters, may be individually
set with User-Defined Input Parameters.

1. Within ICEM CFD, choose Settings>Workbench Parameters> Workbench Input Parameters (User-
defined).

2. In the User-Defined Workbench Input Parameters window, check the Create User Defined Input
Parameter check box.

3. Enter a value for the Parameter name (for example, MY_PARAMETER).
4. Enter a value for the Parameter (for example, 1.343). This value must not be empty.
5. Click Apply or OK.

You can edit this value in the Outline of Schematic: Parameters window.

Note

See the ANSYS ICEM CFD Programmer's Guide for information about using User-Defined
Parameters with Replay Scripting.

Deleting User-defined Input Parameters
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1. Within ICEM CFD, choose Settings>Workbench Parameters> Workbench Input Parameters (User-
defined).

2. In the User-Defined Workbench Input Parameters window, check the Delete User Defined Input
Parameter check box.

3. Use the drop-down menu to choose the name of the parameter you want to delete.

4. Click Apply or OK.

Setting Output Parameters

You can set Workbench Output parameters to:

+ unstruct mesh and pre-mesh blocking quality metrics
+ list the number of mesh errors and possible problems
+ list the number of element and block types created

You set the output parameters within the ICEM CFD application, then view them in either Workbench
or ICEM CFD.

¥ Dutput Check Mash

Woakbench Dutpal Pasameters ‘@ Chack N Exsors
Set Waorkbench Dutput Parametesns — [ Druphcats gl
Mesh [ Uncowvered faces
W Outpul Quakly metncs [T Migtieg irbesnal laces
Quialy melic [Suilacs aiea = [~ Periodic problems
Blocking
L 3 I Yol Ll
Meszh tppes o check for metic “Surface arca ufie oianlahons [ Oukpul PreMesh qually
‘oz Ho [T Suface ofiertations )
Pue-#esh caaron | =]
LINE_2 C = [~ Hanging slemants
— p nong = [T Delele sl PreMesh Quably oulpuk paramebsrs
TETRA_4 = [ Perstating elements
i b
TRI_3 - I Ddzconrmcind har siameris Outpul Humbei of Blocks
— . Block types
etz 2 Cuaity metrics ouiput paamelers Check Mesh: Possible Problems
[ Humbes of Al Blocks
= Dutpul Mumber of Elemenis [ Muliple sdges I Husmbar of Mapped Blocks
Element types i
= ™ Triangls boses [~ Humbser of Free Blocks
[~ Mumbsss of Point
b of Foinkz I 2eingle adpes [ Mumbes of Swept Blocks
[ HWumbes ol Lines [ Singhemidiiple edges
[ Mumkbss of Triangles [T Stand-slane suifacs mesh ™ Dofele o Humber of Blocks oulput porameters
[ Mumbesd ol Duads ™ Singhe adge:
[ Musbes of Hesahedra [ Deelaunay vickation
I Humbes ol Telrahedia [ Ovedapping elemeant:
™ Mumkbss of Prisms [™ Morrmenifold veitices
[™ Humbes ol Pyamds [™ Uncormected vertices
™ Delete all Mumber of Elements oLtpul parameben: [ Daleta sl Check Me utpul parar

Setting Output Parameters

1. Within ICEM CFD, choose Settings>Workbench Parameters> Workbench Output Parameters.

2. Optionally, Click the Output quality metrics check box to select quality metrics.

a. Use the Quality Metrics drop-down menu to choose the metric you want to set.
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b. Click the radio buttons to select the mesh types to check for the metric.
3. Optionally, click the Output number of elements check box.

a. Check the boxes next to the element types for which you want an output number.
4. Optionally, click the Output Check Mesh check box.

a. Check the boxes next to the errors you want to have tallied in the output results. ICEM CFD will
perform an analysis as part of the meshing process and list the results in the Output window and in
the Workbench Parameters window.

5. Similarly, check the boxes for Output Pre-Mesh Quality and Output Number of Blocks to set the
Blocking Output parameters.

For more information about pre-mesh quality, see Pre-Mesh Quiality (p. 46).

For more information about Hexa Block types, see Hexa Block Types (p. 41).

Deleting Output Parameters
1. Within ICEM CFD, choose Settings>Workbench Parameters> Workbench Output Parameters.

2. In the Workbench Output Parameters window, check any applicable check box for Delete all quality
metrics output parameters, Delete all number of elements output parameters , Delete all Pre-Mesh
Quality output parameters, and Delete all Number of Blocks output parameters.

3. Click Apply or OK.

User-Defined Parameters Example

This example illustrates how you can use user-defined parameters to test different meshing scenarios
for a simple box:

1. In the Workbench Toolbox, double-click the ICEM CFD component to start the data-integrated ICEM
CFD component system.

2. Double-click the Model cell to open ICEM CFD.

3. First, create an Input parameter, ZSIZE, that you can manipulate from Workbench.
a. Choose Settings>Workbench Parameters> Workbench Input Parameters (User-Defined).
b. Click Create User-Defined Input Parameter.
¢. Name the Parameter ZSIZE and set the Parameter Value as 2

d. Click OK to finish.
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Uszer Defined Workbench Input .@
Parameters a

User Defined Workbench Input Parameters

I+ Create Uszer Defined lnput Parameter

Parameter name |ZSIZE

Parameter walie | 2

| Delete Uszer Defined Input Parameter

Pararmeter name | J

4. Now create a box model upon which you will perform a meshing operation. Record the process so the
operation can be performed again when you update it from Workbench.

a. Click the Start Replay button.
b. Click the Geometry tab and choose Create/Modify Surface.
c. Choose Standard Shape from the Create/Modify Surface window.
d. Choose Box and click Apply.
e. Click the Mesh tab and choose Compute Mesh.
f. Choose Volume Mesh and click Compute.
g. Click Yes on the pop-up dialog to use autosizing for the mesh size.
h. Click the Stop Replay Recording button.
i. Choose File>Save Project to save the project.
5. Next, edit the script to use the input parameter.
a. Choose Workbench Replay Control from the One-Click Replay Recording menu.
b. Click the Edit button.

c. Edit Line 16 (or whichever line is appropriate),i ¢c_vi d_obj ect box8 GEOM 00 {0 0 0} 1
1 1,to ic_vid_object box8 GEOM 00 {0 O 0} 1 1 [ic_wbh2_get_paraneter
user _defined ZSI ZE]

d. Choose File>Save.
e. Close the Edit window.
f. Click the Save button and save | CM r pl .

g. Click the Done button. Do not close ICEM CFD.
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( b:) Replay control in Workbench 2.0 Framework l = | (=] |_—‘-‘&]1

Operations in scrpt

. # Replay file ICEM CFD 15.0 in Warkbench 2.0 Framewark, i
. # unloading geomety
. ic_unload_tetin
. iz_empty_tetin
. # unloading meszh
. ic_unload_mesh
. # unloading blocking
- iz_her_unload_blocking
| # delete emply parts
10. ic_delete_empty_parts
11. ic_set_global gea_cad O toptal_userzet
12, ic_set_global geo_cad 0.0 taler
13, ic_undo_group_beqgin
14. ic_geo_new_family GEOM
15. ic_boco_szet_part_calar GEOM
5. ic_wid_object box® GEOM 004000} 1 1 [ic_wbZ_get_parameter uzer_defined Z51ZE]
17. ic_set_global gen_cad O toptol_userset
18. ic_set_global geo_cad 0.0003 toler —
19, ic_set_dormant_pickable paoint 0§}
20, ic_set_dormant_pickable curve 0}
21, ic_undo_group_end
22, ic_zet_global geo_cad 0.0003 toler
23, ic_undo_group_beqin
24 ic_set_mezhing_params global 0 gmax 0.045
25, ic_save_tetin temp_tetra.tin
2B. ic_run_tetra temp_tetra tin . Atetra_meshouns ron_cutter 1 delete_auto 1 run_smoother 0 fis_holez 1 n_processors
27, ic_set_meshing_params dlabal 0 gmax 0
28.ic geo =et modified 1

< | v -

000 =] 0 (1 = L o —

v Fecord [after curent) [ Al commands
Do one Do all Do range Skip
Load Save Edit Inzert
Delete one Delete al Delete range Fenumber
[ Abways update Iv Ignore ermors Stop Clean
. ¥

6. Now you can change the Input parameter through Workbench.

a. In the Workbench Project Schematic window, double-click on the Parameters cell of the ICEM CFD
component.

b. Change the value of ZSIZE to 5 and choose Return to Project.
c. Right click on the Model cell and choose Update.

You can watch the Replay script run using the new parameter in the ICEM CFD interface. Each time
you change the ZSIZE parameter in Workbench, will be generated and meshed with the new ZSIZE
parameter value.
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