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1.0 Program Description

2.0

3.0

4.0

This program can be used for configuring and monitoring the data on the Cyberex Main Feed Circuit
Monitor (MFCM). It can be used in either of the following communications modes: RS-232, RS-485,
or TCP. Limited configuration can be done when in the RS-485 or TCP modes.

PC System Requirements

e IBM Pentium or higher (or compatible) PC with a free serial port, network interface card, and a
minimum screen resolution setting of 1024 by 768.

e Microsoft Windows 2000 or higher.
Installation

This program can be installed by double-clicking the 'MFCM-CM_Setup_vX_ X X X.exe' file
provided and following the on-screen instructions. This setup program will put a shortcut on the
Desktop and in the Windows Start->Programs folder.

The Initial Login

When the program is started, the main window will appear as shown in Figure 4-1 below.
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Figure 4-

1 - The Main Screen

An initial login is required before using the program. Once you are logged in, you have the option of
logging out between uses, or remaining logged in for future uses. To log in, click File->Login in the
main menu bar. The Login dialog box will open as shown below.

Usger Mame:

Pasaword:

Default
|

aF. | Cancel |

There are three login levels as follows.

Default .
Level | User Name Password Permissions
0 Default Default Permission to view meter readings and settings only.
. . Permission to configure and calibrate the MFCM in addition to those of
1 Administrator | Admin
Level O (above).
Permission to upgrade/downgrade the MFCM firmware, to change the
2 Supervisor Super MFCM passwords, and to use configuration script files, in addition to
those of Level 1 (above).

When you are finished using the program, you have the option of logging out or remaining logged in
for the next use. To log out, click File->Logout in the main menu bar.
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5.0

6.0

7.0

PC Comm. Settings

Once you are logged in and you are connected to the DB9 (RS-232) connector on an MFCM unit
via a null-modem serial cable, the MFCM Configurator/Monitor program should start polling the unit.
If not, you may need to change settings on the "PC Comm. Settings" dialog box (File>PC Comm
Settings on the main menu bar) as shown below.

Mode: ,m
Comnm Port: m
PCBaud [300 -]
Slave ID: ’—_l
IPadd: [10755570

Qefault$| Qancel|

Figure 5-1 — The PC Comm Settings Dialog Box

The program defaults to the RS-232 Mode and the COML1 Port as shown above. If needed, select a
different Comm port and click the OK button to save the new setting.

General Comm. Port Usage on the MFCM

The MFCM is designed to be configured using the RS-232 Mode (via the DB9 connector). When
using this mode, the baud and Slave ID settings can be changed without affecting the
communications. The various baud and Slave ID settings on the MFCM affect only the RS-485
Mode (via the terminal block). In RS-232 Mode, the baud is always "9600" and the Slave ID is
always "7". The Baud and Slave ID settings on the "PC Comm Settings" dialog box (above) show
the settings that will be applied in RS-485 Mode. Note that these settings are disabled (grayed-out)
when RS-232 Mode is selected as shown in the figure above.

The Panel Window

When the program is started and the polling begins, the Panel window will appear as shown below.
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Figure 7-1 — Panel Window

Left-clicking on any of the CB buttons on the Main Control window will cause the associated Main
Feed window to open, as shown in a later section below. (Multiple Main Feed windows can be
opened at the same time.)

Any of the Main Feeds can be disabled or enabled by right-clicking on any of the corresponding CB
buttons on the Main Control window and clicking the Disable or Enable popup, as shown below.
Main Feed 2
[ Il
[ces] =
IEEEN | ec | 00

When a Main Feed is disabled, its CB buttons will appear grey on the Main Control window as
shown below. When a Main Feed is enabled, its CB buttons will appear green if no alarms or
warnings exist for that circuit, or will appear red or yellow if there are any alarms or warnings,

respectively.

Main Feed 2

cB4 |[ea [ oOi
cB5 |[ o8 [ Oif
“oes [ [ o

The Main Feed Windows

The metering, alarm/warning states, and configuration settings for each Main Feed can be seen in
its Main Feed window as shown below. Active alarms and warnings will appear as red or yellow,
respectively.
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8.1

\[* Main Feed| 1
— Metering
8 eB eC| Awvg || Neut. | Gnd. 8A-B eB-C| 8oC-A e
Current [A]) 199.9| 1995| 1881 193.9 1 0.87v Volts [L-L] 205 205 205
Max. [A] 2138|| 2160f 15935
Min_ [A) 1851 1825 1851 s limetNijiet M
Volts [L-N] 118 118 118
Total
"KW 03 01 1.3 1.4 Freq. (Hz) 50.2
HKVA 236 237 2.4 7.1
[kvan 711 Reset aters |
uLoad [%]) 45 45 45 43 _ Calibration-
|KW Demand 2
HPF e oo 0 iz HEaI. Ty|_:|e 1] Phaze Curent Scale __v_j
[ 0 0 0 1 | EEETE | _gend
THD-Current (%) 23 27 23 ;
THD-Voltage [%) 3 3 3
Alarme W arnings and Settings -
HNeut_ |Lmt [%)
0C Alarm a0 OV Alarm
0OC Warning 70 ' 0Y Warning
UC Alarm 3 | |U¥ Warning
Dver KW 100 f| ¥ Alarm

Rating [Amps]

Line CT Scale

Neut CT Scale

[v Main Feed Enabled

”Phase Loss

Alrm Delay [5)

USource No. |] 1 I

wrn Delay [5]

Figure 8-1 — Main Feed Window

Changing Settings on the Main Feed Windows

These windows can be opened by either clicking a corresponding CB button on the Main Control
window, or by selecting it from View->Main Feed x in the main menu bar.

When logged in on Level 1 or 2, you can change the settings in the Main Feed windows by double-
clicking in the setting you want to change. When this is done, enter the new number into the popup
dialog box that appears as shown below. Any setting inside the "Alarms/Warning and Settings"

frame can be changed like this.

Also, when logged in on Level 1 or 2, you can reset the Min/Max Currents and the KWH readings by
clicking the "Reset Meters" button on the Main Feed window.
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Figure 8-2 — Changing Settings in the Main Feed Window

Resetting Latched Alarms and Warnings

When logged in on Level 1 or 2, and the "Latching Alarms/Warnings" option is enabled (see the
"Latching Alarms/Warnings" checkbox on the System Settings window), you can reset latched
alarms and warnings by double-clicking on the red or yellow alarm/warning boxes on the Main Feed
window. This will reset all of the alarms and/or warnings that are common with a certain Modbus
register. These alarms/warnings are grouped as follows.

e OC Alarms (gA, 2B, gC, Neut.)
e OC Warnings (gA, gB, gC)
e UC Alarms (gA, @B, gC)
e Over KW Alarms (gA, @B, gC)
o All OV/UV Alarms/Warnings
¢ Phase Loss Alarm
Calibrating the MFCM
Note: This function is available only in RS-232 mode.

When logged in on Level 1 or 2, you can calibrate the MFCM using the controls on the Calibration
frame on the Main Feed windows. There are 7 calibration types that can be selected using the
dropdown box in the Main Feed window as shown below. For calibration instructions, refer the
proper Field Service procedure.
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Figure 8-3 — Calibration Type Selection in the Main Feed Window
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The System Settings Window

The system level configuration settings can be seen in the System Settings window as shown
below. This window can be opened by selecting View-> System Settings in the main menu bar.

{[7 System Settings @

O
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Figure 9-1 — System Settings Window

When logged in on Level 1 or 2, you can change the settings in the System Settings window. The
first three items are changed by double-click, just like previously mentioned for the settings on the
Main Feed windows. The remaining items can be changed by clicking the checkboxes or selecting
a different value in the combo (dropdown) boxes.

Upgrading/Downgrading the MFCM Firmware

You must be in RS-232 mode and logged in on Level 2 to use the MFCM Configurator/Monitor
application for upgrading or downgrading the MFCM firmware. To see the Upgrade page as shown
below, click on the Upgrade tab on the Main Control window.

When the program is installed, it is not configured with any "Software Upgrade File" paths, which
would appear in the combo box in the Upgrade Software page as shown below. Software upgrade
file paths can be added, removed and saved by the program so that they will still be there when the
program is closed and reopened later.

A new software upgrade file path can be added by dragging from Windows Explorer and dropping
into the white "Software Upgrade File" combo box. Then it can be saved for future use by clicking
the Save button.

You can also add a new software upgrade file path by clicking the Browse button just below the
"Software Upgrade File" combo box. A new window will open as shown in Figure 10-2 below. This
is a standard "File->Open" dialog box that lets you browse through folders so that you can find and
select the upgrade file that you need. Click the Open button after selecting the correct upgrade file
as shown below.

Once a new software upgrade file path selected, the Save button (below the white combo box) will
become enabled. You can then save the new software upgrade file path in the list by clicking the
Save button.

To see the software upgrade file paths in the list, click on the down-arrow button on the right-hand
side of the combo box as shown below in Figure 10-3. Then you can select the file that you want to
use for the upgrade.
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Note: To remove a path from the list, simply select the path and click the Remove button in that

frame.

When a software upgrade file is selected (like shown in Figure 10-3), you can click the "Open
Folder" button (in the same frame) to open its folder with the file selected in Windows Explorer. This

is handy for checking file dates, etc.

\[# Panel

File Transfer Progress

0

Throughput:

[ e |

Upgrade Status:

Software Upgrade File
| C:AMFChenfom_dsp_wl_30.bin |

Browse Femove | Open Folder
| seve | | |

Upgrade
Downgrade

X

Figure 10-1 — Upgrade Page
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Figure 10-2 — Browsing Software Upgrade Files
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Software Upgrade File
C:\MFCMYmfcm dsp +0 30.bin

C:AMFCMsmfcm_dsp_w0_28.bin
C:5MFChymifcm_dzp_v0_29.bin
C:AMFCMmifcm_dsp_w0_30 bin

Upgrade k

Figure 10-3 — Selecting Saved Software Upgrade Files

Once the software upgrade file is selected, click the Upgrade button to start the upgrade. The File
Transfer Progress bar should start growing and the "Upgrade in process" message should appear
as shown below. The Cancel button can be clicked to stop the upgrade, if needed.

[¥ Panel §|

Panel Uparade ] O

File Transfer Progress

Tatal bytes sent: 13440 B5536
Throughput: 868 bytes/s

LCancel

Upgrade Status:
|parade in process . . .

Software Upgrade File
|E:\M FCMAmfcm_dsp_w0_30.bin j

Browse| | Femove | Open Folder |

[ Do |
EZE

Figure 10-4 — Software Upgrade in Process

The upgrade file transfer takes about 1 ¥2 minutes. After the file transfer has completed, you should
see the following message box pop up.

Cyberex MECM Configurator-Monitor g|

The upgrade file transfer was successful,

After clicking the OK button, you should see the following message box pop up. After

acknowledging these two messages, the MFCM should start running with the new software upgrade
loaded.
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Cyberex MFCM Configurator-Monitor

The upgrade was successfully verified,
The device will now be rebooted For the upgrade to take effect,

11.0 Terminal Window

12.0

13.0

When logged in on Level 1 or 2, you can open the Terminal window as shown below by selecting
Connection>Terminal on the main menu bar.

[+ Terminal

O Connection State

Teminal Interface

SFCHM Zerial Zhell
*Wersion 0.30

=ZPAM memory test passed
=

Figure 11-1 — Terminal Window

When the Terminal window is open, enter service port commands into the smaller lower textbox.
Temporarily Closing the PCs Serial Port

The PCs serial port can be temporarily closed and reopened without exiting the MFCM
Configurator/Monitor application by selecting Connection->Disconnect and Connection->Connect
on the main menu bar. This is convenient to use when you want to temporarily communicate with
the MFCM with another application.

Creating Service Port Script Files

This application can be used to create service port script files to use for configuring MFCM units and
for verifying the settings after configuring. This feature works only in RS-232 mode and when
logged in to Security Level 2.

To open the Create Script File window, select Scripts—>Create Script in the main menu bar. The
window will open as shown below.
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% Create Script File

System Settings Script File Text

Item VYalue
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:
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Script > = imi
[0-9600: 1-15200; 2-57600: 3115200 p tlw 1 250 O (PL-MF4 UC Alarm Limit (%))
tlm 1 247 1 {PL-MFl Zource Humber)
tlm 2 247 1 {PL-MFZ Zource Humber)
R tlm 3 547 1 {P1-MFZ Source MNumber)
Panel Settings tlum 4 547 1 {P1-MF4 Source Number)
Item VYalue

calioffset 1 ALl
save

TLM Description

846 tain Feed OnA0ff . . .
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Figure 13-1 — The Create Script File Window

13.1 Procedure for Creating a New Script File

The following procedure can be used for creating a new script file.

131.1
13.111
13.1.2
13.1.21

13.1.2.2
13.1.2.3

13.1.2.4
13.1.3
13.1.3.1

13.1.3.2
13.1.3.3

Clear the Script File Text Box
Clear the Script File Text Box by clicking the Clear Text button.
Add System Settings to the Script File Text as Follows:

Starting at the upper left-hand corner of the window, select a System Setting you want to add to
the script file by clicking the item in the Item frame.

Enter the new value you want to for this item in the Value textbox.

Click the Add to Script button to add this command to the script file. The new command line
should appear in the large Script File Text box on the right-hand side of the window.

Note: The text in the Script File Text box can be manual edited or deleted, like using Notepad.
You can repeat this process to add other "System Settings" items, if required.
Add Panel Settings to the Script File Text as Follows:

Select a Panel Setting you want to add to the script file by clicking the item in the
Panel Settings — Item frame.

Enter the new value you want to for this item in the Value textbox.

Click the Add to Script button to add this item to the script file. The new command line should
appear in the Script File Text box on the right-hand side of the window.
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13.1.
13.1.
13.1.

13.1.

13.1.

13.1.

13.1.
13.1.

13.1.

13.1.

13.1.
13.1.

13.2

14.0

3.4 You can repeat this process to add other "System Settings" items, if required.
4  Add Main Feed Settings to the Script File Text as Follows:

4.1 Select a Main Feed Setting you want to add to the script file by clicking the item in the
Main Feed Settings — Item frame.

4.2 In the Selection frame, select the Main Feed/s you want to add by checking the appropriate
checkboxes. The "Select All" button can be used to select or unselect all items in all columns.

4.3 Enter the new value you want to for this item in the Value textbox. (This value will be used for
all Main Feeds selected.)

4.4 Click the Add to Script button to add this item to the script file. The new command line/s should
appear in the Script File Text box on the right-hand side of the window.

4.5 You can repeat this process to add other "Main Feed Settings" items, if required.

5 Current Offset Calibration:
This application provides the option of putting Current Offset Calibration for each panel into
script file. Perform the following steps to add Current Offset Calibration to the script file.

5.1 To open the Calibration window, click the Calibration button at the lower right-hand side of the
Main Feed Settings frame.

5.2 Click the "Add to Script" button. (See below.)

w. Calibration

Current Offzet Calibration

6 Save the Script File as Follows:

6.1 You can edit or delete text in the Script File Text box if necessary. When ready, save the
finished script file by clicking the "Save Script File" button. A "Save As" dialog box will appear,
prompting you for a new file name for the new script file. The default folder for saving script files
is the "\Scripts" subfolder in the application's folder.

Procedure for Creating a "Verify Script File"

After a new script file has been created, it may be a good idea to create another script file to use for
verifying that the new settings have been actually been saved in the MFCM after being configured.
This "Verify Script File" or "Read File" can be easily created from an existing setup script file as
follows.

With the script file text in the Script File Text box (e.g., after saving the script file in the procedure
above), click the "Make Read File" button. (This changes the text in the Script File Text box into
commands for reading data instead of writing data to the MFCM.) Then save the text to a new file
by clicking the "Save Script File" button. In the "Save As" dialog box, which will appear, enter a new
file name that distinguishes this as a "Verify Script File" or "Read File".

Running Service Port Script Files

This application can be used to run service port script files for configuring MFCM units and for
verifying the settings after configuring. This feature works only in RS-232 mode and when logged in
to Security Level 2.

To open the Script File Transfer window, select Scripts->Run Script in the main menu bar. The
window will open and the Terminal window should open a few seconds later as shown below.
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The program will load the last script file used. To load another script file, click the Browse button
and select an existing script file in the "Open" dialog box, which will appear. (The "Script File
Transfer" window can also be opened from the "Create Script File" window by click the "Run Script"
button in that window. When opened this way, the current script file in the "Create Script File"
window will be loaded into the "Script File Transfer" window.)

When you have the correct script file loaded, click the Run button in the "Script File Transfer"
window. You should see the highlighter bar shift down in the "Script" list box and the commands
being echoed in the Terminal Interface textbox in the Terminal window.
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