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1. Introduction 

1.1 The TrussMaster Program 

TrussMaster is a program for the analysis of two-dimensional truss frameworks, 

whilst exposing the underlying assembly and matrix operations. This makes it 

suitable for supplementing the teaching of the matrix stiffness method. The program 

aims to keep the user as close to the raw data and operations as possible. This is in 

contrast to many commercial programs, which can be much more ‘black box’ in 

nature. TrussMaster aims to bridge the gap between hand calculations and such 

commercial programs. 

 

A webpage is available as a central point for problems/solutions/suggestions: 

 

www.colincaprani.com/programming/trussmaster/ 

 

There is also a support email address: trussmaster@colincaprani.com.  
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1.2 The User Manual 

Purpose 

This User Manual has been written to explain the use of the TrussMaster 

program, and to explain its capabilities and limitations. It explains the user interface, 

the required input information, and the output information. 

 

This manual does not explain the stiffness method in detail, or the equation solution 

procedure used (Gauss Elimination). 

 

Conventions 

Menus 

Menu commands are written as: 

Drawing > Animate 

And mean the user should select Simulation from the Configuration menu as shown: 

 

 

 

Keyboard 

The use of shortcut keys is indicated as: 

 Ctrl+I 

And means that the user should press the Control and “I” keys simultaneously. 
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Notices 

Points of significant importance are denoted as: 

 Important! 

Typically, failure to adhere to these points will result in unexpected behaviour or a 

program crash. 
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Glossary 

User Input Grid The area which the user will input most of the data to construct 

the 2D truss. The same area will display valuable information 

once the truss is analysed. 

Truss Display The area where the truss is visually displayed, displays node 

and member location, support conditions and loading 

conditions. 

Stiffness Equations The display where the force vector, global stiffness matrix and 

deflection vector are displayed. 

Control Board Section on the User Interface where the user will enter all of the 

input data and edit the truss in the truss display.  

 

© Colin Caprani 2010 8



TrussMaster (v3)  User Manual, Version 1.0 

1.3 Release History 

TrussMaster Program 

Version Date Description 

1.0 Aug. 2001  Initial release. 

2.0 May 2008  Many changes: pan, zoom, data entry. 
3.0 Sept. 2010  Added educational features; 

 Improved interface stability; 
 Increased functionality (delete, compress); 
 Improved analysis (prestress, supports); 
 Output: picture, grid data copy. 

 

TrussMaster Manual 

Version Date Description 

1.0 Sept. 2010 Initial release. 
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2. Installing the Program 

2.1 System Requirements 

The program has been tested on Windows XP and Vista. It is expected to run on 

Windows 2000 and Windows 7 also. 

 

The program is a single-threaded application and so cannot take advantage of multi-

core processors. Therefore for maximum speed, prefer a computer with a fast single 

processor over a computer with a multi-core slower processor. 

 

 

© Colin Caprani 2010 10



TrussMaster (v3)  User Manual, Version 1.0 

2.2 Installation 

To install the program, carry out the following steps: 

1. Extract the zip-archive to a folder; 

2. In that folder, double click on the file Setup.exe; 

3. Follow the on-screen instructions to install the program. 

 

 Important! 

During the installation you may be prompted that the versions of several files 

(*.dll, *.ocx most probably) that are already installed on your machine are 

more recent than the versions that TrussMaster is trying to install. You will 

be asked whether you want to overwrite the files with the older versions or 

keep your existing files. You should keep your existing (more recent) files. 

TrussMaster will be able to run with the newer versions of these files as 

they are backward-compatible. 
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3. About TrussMaster 

3.1 Introduction 

TrussMaster broadly performs the following steps: 

1. Data is entered into TrussMaster; 

2. TrussMaster compiles this information and forms the basis of  a 2-D truss; 

3. The analysis commences; 

4. The Truss Display displays the results in diagrammatic format; 

5. The stiffness matrices then calculate the nodal deflections; 

6. The final results are displayed in tabular format. 
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3.2 TrussMaster: Capabilities and Limitations 

Capabilities 

TrussMaster is able to: 

 Read data from pre-existing TrussMaster files; 

 Simulate 2 dimensional trusses; 

 Model trusses up to a maximum number of 5000 nodes and members; 

 Apply loads in both the x and y directions; 

 Apply loads at inclined angles;  

 Take into account self -strained structures; 

 Allows the user define the Young’s Modulus and cross sectional area for 

members in the truss; 

 Simulate up to three different types of supports; 

 Output member forces, stresses and reactions in truss under loading;  

 Output nodal deflections in truss under loadings; 

 Allow user visualise the deformations the truss goes under by animating the 

loading process; 

 Use  the Stiffness Method to determine nodal displacements of truss; 

 Output Force vector, Global Stiffness matrix and Displacement vector for user 

to visualise the Stiffness Method process. 
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Limitations 

TrussMaster is not able to: 

 Analyse three dimensional structures; 

 Analyse Beams or Plane Frames; 

 Calculate prestress forces; 

 Apply loading between truss nodes; 

 Generate output reports. 
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4. The TrussMaster User Interface 

4.1 Introduction 

The TrussMaster program has a Single Document Interface (SDI). This means 

only a single TrussMaster file can be opened at any one time – similar to the way 

Notepad in Windows operates. The menu and toolbar commands, whilst being 

specific to the program, are operated in the same way as standard Windows 

programs. 

 

Of note, for ease of use, there is extensive support for keyboard shortcuts in 

TrussMaster. 
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4.2 Menu 

File 

 File > New: 

Opens a new TrussMaster file with the default settings selected. 

 File > Open: 

Open an existing TrussMaster file. 

 File > Save: 

Save the current file. 

 File > Save As: 

Save the current file under a new name. 

 File > Exit: 

Close TrussMaster. 

 

Drawing 

 Drawing > Refresh: 

Updates the screen display with the grid data and redraws. 

 Drawing > Animate: 

Animates the truss deflection under the loads for ease of interpretation. 

 Drawing > Zoom out: 

Current view of grid is increased. 

 Drawing > Zoom extents: 

Changes the drawing scale such that the whole structure is visible. 

 Drawing > Save picture: 

Saves the current view to user-defined *.bmp file. 
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Tools 

 Tools > Analyse: 

Analyzes the truss for the member forces and nodal deflections. 

 Tools > Results: 

Not currently implemented. 

 Tools > Truss Generator: 

Not currently implemented. 

 Tools > Options: 

Displays the progam Options dialog. 

 

Window 

 Windows > Truss Display: 

Shows the truss display window. 

 Windows > Stiffness Equations: 

Displays the stiffness matrix calculations view. 

 

Help 

 Help > TrussMaster Help 

Not currently implemented. 

 Help > About 

Displays information about the copyright/developers and program version. 
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4.3 Toolbar 

The TrussMaster toolbar is as follows: 

 

 

 

The buttons above provide a shortcut to the menu commands as follows 

 New: File > New; 

 Open: File > Open; 

 Save: File > Save; 

 Truss Generator: Tools > Truss Generator (not currently used); 

 Run Analysis: Tools > Analyse; 

 Save Picture: Drawing > Save Picture; 

 Options: Tools > Options; 

 About: Help > About. 

 

New 

Open 

Save Analyse 

Save 
Picture

Truss 
Generator

Options 

About
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4.4 Shortcut Keys 

Support for shortcut keys is included in TrussMaster. Some commands are only 

accessible through the keyboard and mouse. 

 

F1: Tools > Analyse 

F2: Drawing > Animate 

F3: Drawing > Zoom out 

F4: Drawing > Zoom extents 

F5: Drawing > Refresh 

F6: Drawing > Save picture 

 

Esc: Changes cursor mode to Mouse Mode (from TrussMaster v.3.0.1). 
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4.5 Truss Display Interface 

The region in which the truss is displayed is termed the Truss Display. In this display, 

the user can be in any one of a number of ‘Screen Modes’ which are accessible 

through the right-click menu. 

 

 

 

The image above shows the Truss Display above the maximised Control Board, the 

two solid lines indicate the x and y axes in the truss display. The dashed gridlines 

indicate the user-defined grid. 
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Screen Modes 

The screen modes are: 

 Mouse Mode: 

This is the default mode upon opening the program and is superseded by the 

user selecting any of the alternative modes. It may be re-entered by pressing 

the Esc key (from TrussMaster v.3.0.1 and on). 

 Pan Mode: 

Allows the user to move the centre of the display to view different parts of the 

structure; 

 Draw Nodes Mode: 

Selecting this option will allow user to place joints or nodes at intersections of 

the user-defined grid; 

 Draw Members Mode: 

This allows the user to create members between nodes previously defined. This 

is done by left-clicking on the first node and then left-clicking on the end node. 

 Select Members Mode: 

In this mode, clicking on a member displays the Member Properties Dialog 

box; 

 Select Nodes Mode: 

In this mode, clicking on a node displays the Node Properties Dialog box; 

 Delete Mode: 

Allows the user to clock on and delete either a member or node. 

 

The Screen Modes are entered into through the mouse right-click menu, accessible by 

right-clicking in the truss display area. The Screen Modes remain in place until an 

alternative is selected. The current mode is indicated in the program Status Panel.  
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Right-Click Menu 

The mouse right click menu is found by right-clicking in the truss display area.  

 

 

 

The commands accessible through this menu are: 

 Pan: Turns on Pan Mode; 

 Draw nodes: Turns on Draw Nodes Mode; 

 Draw members: Turns on Draw Members Mode; 

 Select members: Turns on Select Members Mode; 

 Select nodes: Turns on Select Nodes Mode; 

 Delete: Turns on Delete Mode; 

 Zoom window: Allows the user to left-click and drag a window around an area 

to zoom in on; 

 Zoom out: Zooms view out of grid, and can be repeated by the user to get to a 

desired view; 

 Zoom extents: Returns the view of the grid to its default position where the 

full structure is displayed. 
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4.6 Control Board 

The Control Board is where most data input and preparation is carried out. It can be 

minimized to allow easier viewing of the structure. 

 

 

 

The Control Board is made up of three main areas (highlighted above); 

 User Input grid (highlighted blue); 

 Member data and node data (highlighted green); 

 Truss Display option (highlighted red). 

 

User Input Grid 

The grid allows the user edit the truss by entering type and locations of supports and 

loads. It also allows the user to check the designation of physical properties and 

prestress forces. After an analysis, it gives the nodal and member results by clicking 

on the corresponding tabs denoted. 
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Member data and Node data 

This area allows the user to designate the values for Young’s Modulus and cross 

sectional area for each individual member in the truss. It also allows the designation 

of loads of the same value on more than one node and also draws a sequence of nodes 

of equal spacing. 

 

Linear node generation 

This function allows the user to draw a linear sequence of nodes in one step. The user 

specifies how many nodes they want and the location of these nodes. 

 

 

 

In the above screenshot, it can be seen that in the designated input box the user has 

specified a line of eleven nodes and it will run on the x–axis from 0 to 10 m and at 0 
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m on the y–axis.  This process can be repeated by changing the coordinates of the 

node line on the x and y–axes.  

 

Repeated load designation 

This function allows loads to be specified to nodes in the truss faster than it would be 

to designate loads using the User Input grid. 

 

 

 

Above is a screenshot of a simple truss. To apply a downwards load of 10 kN to 

nodes 6 through 10, the user can specify a load of “-10” kN in the y-node load box 

and specify the nodes by entering “6-10” in the node box. 
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The above two editing options are very useful in speeding up the construction of 

large trusses. 

 

Truss Display options 

This area is concerned with options that alter the truss display.  

The user can choose to;  

 Animate the truss deflections 

 Alter the force and deflections scales 

 Turn on/off  the display for  

o Loads 

o Supports 

o Defection 
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o Grid 

o Member forces 

o Grid 

o Member number 

o Node number 

 

 Important! 

When editing the Truss Display, it is necessary to refresh the grid (pressing F5) 

to update the grid to show new supports and loads once defines in the input 

grid. 
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4.7 Stiffness Equations Display 

To help the student gain a better understanding of the stiffness method of analysing 

structures one of the features of TrussMaster is to display step by step how the 

stiffness method works for the structure being analysed. 

 

 

 

There are five buttons located in the Stiffness Equations Display which carry out the 

following functions; 

1. Show Force: Displays the Trusses Force Vector; 

2. Add Member: Enters each members stiffness matrix into the Global Stiffness 

separately; 

3. Show Global K: Automatically shows the trusses Global Stiffness Matrix; 

4. Restrict DOFs: Imposes the structure restraints upon the Global Stiffness Matrix 

according to the supports used; 
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5. Solve: Solves for the Displacement Vector. 

 

Use of this facility follows these rough steps: 

1. On entering, display the force vector for the structure. Note that this will include 

any nodal loads necessary to account for member prestress. 

2. Each member can be successively added to the Global Stiffness Matrix. This 

allows the student see how each member contributes.  

3. At any time, the user can proceed to complete the filling of the Global Stiffness 

matrix by clicking on “Show Global K”. 

4. After the global stiffness matrix has been populated, the structure restraints can be 

imposed by clicking “Restrict DOFs”. 

5. Only now is the Solve button enabled, and the structure can be solved. 
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4.8 Other Display Elements 

Status Bar 

The Status Bar is located at the bottom left of the program window. 

    

 

 

The Status Bar gives the user the following information: 

 Panel 1: The current x- and y-coordinates of the mouse cursor; 

 Panel 2: The current Screen Mode is displayed; 

 Panel 3: The current status of the analysis on the structure. 
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Node Properties Dialog 

The Node Properties dialog is accessed by clicking on a node when in “Select Node” 

screen mode. 

 

 

 

The node properties dialog window gives the user: 

 

Properties 

 Node locations in x and y axes; 

 Forces on the node in the x and y direction; 

 Supports conditions in the x and y direction; 

 

Results 

 Will return resulting deformations in the x and y direction (if available); 

 

Specify node load 

 This option allows the user define loads action on the node selected which are 

at an inclined angle. 
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Member Properties Dialog 

This dialog can be accessed by clicking on a member when in Select Member screen 

mode. 

 

 

 

The member properties dialog window gives the user: 

 

Properties 

 Member number and location of members nodes in the x and y location; 

 The Cos and Sin of the member’s angle with the x-axis; 

 Physical properties of member (i.e. Young’s Modulus and cross-sectional 

area); 

 Length of member; 

 Prestressed force in member (if any); 

 

Stiffness Matrix 

 Gives the member’s element stiffness matrix. 
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Results 

 The force in the member; 

 Indicates whether member is in tension or compression; 

 The elongation or stretch of the member; 

 Gives the stress in the member. 
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Program options 

The options dialog window is accessed in the toolbar through Tools > Options. 

 

 

 

There are two tabs in the options window, General and Node Snap Mode. 

 

General 

 Select the type of line for the truss display (i.e. solid or dashed lines); 

 Select the amount of nodes and members to be used in the truss display; 

 Sets the number of files in the recently-used files list. 

 

Node Snap Mode 

 Sets the grid spacing; 

 Sets the click radius – nodes within this distance of a click will be selected. 
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5. Data Input and Editing 

5.1 Introduction 

The output from TrussMaster is only of use if the input data is representative of 

the truss of interest. The user must run the program to get results that may be 

compared to the calculations carried out by hand. The user can then easily alter the 

truss by editing the member’s properties, adding of additional members or taking 

members out and adding additional loads or removing loads. 
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5.2 Node Data 

Selecting the Joints Data tab gives the user the following grid for input: 

 

 

 

In this grid, the user can; 

 specify the location of nodes placed by the user by giving the x and y coordinate 

of the node; 

 define the loading on the nodes by entering values into the ForceX and ForceY 

columns; 

 define the support conditions for each node in the truss (enter a 1, 2 or 3). 

 

 Important! 

The support conditions are: 

 Horizontal roller support – enter 1; 

 Vertical roller support – enter 2; 

 Pinned support – enter 3. 
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5.3 Member Data 

Selecting the Member Data tab gives the following input grid. 

 

 

 

In this gird, the user can; 

 set the connectivity (i.e. identify the nodes it connects to) for each member 

placed in the truss display; 

 set the material and geometric properties for each member; 

 define any prestress force in a member. 
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5.4 Editing 

Editing data already entered in TrussMaster is reasonably straightforward.  

 

Deleting  

Deletion of nodes or members can be done in two ways: 

1. In the input grid, select the row corresponding to the node or member.  Right 

click and select Delete from the right-click menu (or press Delete on the 

keyboard). Next, right click again and select Compress. This will remove zero 

rows from the input grid. 

2. In the Truss Display, right-click and select Delete from the menu then select 

whatever feature you wish to delete. Multiple deletions can be carried out 

successively. 

 

Moving Nodes through the grid 

Once a truss has been analysed it is possible to move the node by selecting the nodes 

coordinates columns in the joint data tab. By entering new coordinates into these cells 

and refreshing the display (Drawing > Refresh or F5) the node will have moved to the 

new position.  
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6. TrussMaster Output 

6.1  Introduction 

TrussMaster has the ability to output large amounts of information. Especially for 

trusses which contain a large amount of members and nodes. The output data which 

TrussMaster yields can be read by any spreadsheet viewer, such as MS Excel. 
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6.2 Data Grid 

The Data Grid is the main source of output information in TrussMaster. This grid 

will output data which includes: 

 Nodal deflections 

 Member deflections 

 Member forces and force direction 

 Member stresses 

 

 

 

Window box indicating nodal deflections 

 

 

Window box indicating members forces, deflections and stresses 

 

All these results are displayed in the grid format and can be extracted by copying. 

Right-click and choose Select All. Next, right-click and select Copy from the menu. 

These values can then be pasted into MS Excel (for example). 
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6.3 Picture Command 

At any point, the current view in the Truss Display can be saved to a Bitmap file. 

Selecting the Save Picture icon on the toolbar or Drawing > Save Picture, the user 

can save a Bitmap file of the truss display. This can then be used in another 

application. 

 

 

 

As per the above image, the user can select the filename and location where the Truss 

Display picture will be saved. 
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7. FAQs and TroubleShooting 

7.1 FAQs 

First please check the program website: 

 

www.colincaprani.com/programming/trussmaster/ 

 

If your problem is not solved here, please forward your query to 

trussmaster@colincaprani.com  
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7.2 TroubleShooting 

As this is the first major release of this program it is likely that there are some bugs 

and inconsistent behavior. Please check the TrussMaster website for some 

possible solutions. If the problem persists, please send a copy of the *.trm and the 

exact steps to reproduce the problem. Please also include your system setup 

information. Please send this information to trussmaster@colincaprani.com.  

 

It is envisaged that this section of the document will be updated frequently as the 

program matures. 
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8. Appendices 

8.1 Appendix 1 - Stiffness Method 

Truss Element Stiffness Matrix 
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Prestress Forces 

Prestress forces from different sources are: 

 Lack of Fit: 

 

 L
o

L
F EA

L


  (1) 

 

Where L = the lack of fit; 

 LO = Original length of member. 

 

 Temperature Change: 

 

 TF EA T   (2) 

 

Where  = coefficient of thermal expansion; 

 T = change in temperature. 
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8.2 Appendix 2 - Tutorial 

Introduction 

The usual procedure followed when using the program is: 

1. determine layout of nodes on grid 

2. place members between nodes on grid 

3. Assign physical properties to members in frame 

4. Assign support conditions to nodes of choice 

5. Place loads on nodes of structure 

6. Run analysis of structure 

7. Read off member forces and force direction on truss display 

8. View global stiffness matrix of structure in stiffness equations display 

9. Determine displacement of nodes of structure from applied loads 

 

The following tutorial is illustrates the solution of the 2006/2007 Semester 1 Exam 

question on the topic of Stiffness Matrices. 

 

© Colin Caprani 2010 45



TrussMaster (v3)  User Manual, Version 1.0 

Problem 

Question 1 – Semester 1 2006/7: 

 

1.  Using the stiffness method, determine the displacement of the joints and the forces in the members of the pin-
jointed truss shown in Fig. Q1, allowing for: 

 
(i) The 100 kN vertical load as shown, and; 
 
(ii) A lack of fit of member 12, which was found to be 5 mm too short upon arrival at site, and 

which was then forced into place. 
 

 Take EA = 2×104 kN and the cross sectional areas of the members as: 
• Members 12:  3A; 
• Members 13 and 14:  3√2A. 

(25  marks) 
 
 

FIG. Q1

100 kN

1

3 m 3 m

2

3

3 
m

4

 
 

 

The solution to this problem using TrussMaster follows. 
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Define Truss Geometry 

Once TrussMaster is open the user will be met with the following screen. 

 

 

 

The first step to drawing a structure is to determine the layout of the nodes (i.e. 

joints) of the structure. Right clicking the mouse in the Truss Display will bring up 

the right-click menu:  
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Selecting the option Draw Nodes will turn on Draw Nodes Mode which lets the user 

place nodes at the grid intersections: 

 

 

 

Next, Right click > Draw Members will allow the user to join the nodes to form the 

basis of the structure 
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Supports 

The next step is to define the type of supports for the structure, these can be entered 

in the input grid under the column support to the corresponding nodes, shown 

highlighted in the below picture 

 

There are three types of supports available to the user in TrussMaster, these are: 

1. Horizontal roller: restraint  provided in the y-direction only; (press 1) 

2. Vertical roller: restraint provided in the x-direction only; (press 2) 

3. Pin support: restraint is provided in both directions; (press 3). 
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To use one of the above supports, enter the number corresponding to the desired 

support type above. Next press F5, or use Drawing > Refresh, to update the screen 

display with the new grid information. 

 

 

 

Define Member Properties 

The next step is to assign the members physical properties from the member data 

block on the control board, which is highlighted below on the control board. 
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The two physical properties that need to be determined are Young’s Modulus (E) and 

the member cross-sectional area (A).  

 

 Important! 

Failure to define these properties for members will result in the structure being 

unstable. 

 

By clicking on the Member Data button below the Data Input Grid on the Control 

Board allows the user to check if these properties have been correctly assigned which 

is also highlighted above.  
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Define Loads 

The loadings are entered by the user in the User Input Grid under the columns 

ForceX and ForceY, which define loads in the horizontal and vertical directions 

respectively. 

 

 

 

The program adopts the Cartesian coordinate system so the y-axis runs positive 

upwards and the x-axis positive to the right. 

 

Note: It is also possible to define loads at inclined angles by entering the node 

properties dialog window. As described in section 4.8 above. 
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 Secondly the user has to define the self strained forces which occur in the member 

no.3. To determine this force the user must calculate this prestressed force themselves 

and enter the value into the User Input grid.  

 

The location for entering this prestress force is in the Member Data grid, accessed 

by clicking on the Member Data tab under the User Input grid. 

 

 

 

The above highlighted column indicated the location where the user enters the values 

for each of the member’s prestress forces.  

 

Important! 

Defining the prestess force with the correct sign is of major importance, failure 

to do so will still yield an answer but an incorrect one. 
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The user must recognise that the fore is being applied to the truss; (i.e. stage 2 in the 

theoretical analysis). 

 

Analysing the Structure 

Once all geometry, supports, properties, and loads have been defined the truss may be 

analysed. Use F1, Tools > Analyse, or run analysis button on toolbar to execute the 

analysis. 

 

 

 

Following the analysis, TrussMaster will display the structure with the following 

results displayed: 

 Member forces; 
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 Force direction; 

 Reaction direction; 

 Deflected shape. 

 

To make it easier to visualise certain results, the user can select and deselect each of 

these, as shown on the bottom right of the screen. 

 

The more detailed numerical results are shown in the User Input Grid, as follows. 

 

Joint Results 

 Displacement in x- direction (mm); 

 Displacement in y- direction (mm); 

 Force in x- direction (kN); 

 Force in y- direction (kN). 

 

 

 

Member Results 

 Force (kN); 

 Indicate whether member is in tension or compression (T/C); 

 Stress (N/mm2); 

 Displacement (mm). 

 

 

 

© Colin Caprani 2010 55



TrussMaster (v3)  User Manual, Version 1.0 

The user can also access these results through the Member or Node Properties dialog 

boxes. 

 

Stiffness Equations Display 

Upon selecting the option stiffness equations the below display will meet the user. 

 

 

 

To begin using this function of TrussMaster firstly the user will select the Show 

Force button, this will show the force vector containing the appropriate forces on the 

corresponding nodes: 
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The global stiffness matrix is the second step in the process. At this point the user can 

complete the global stiffness matrix by: 

 Adding each member individually: 

This method allows the user to see the contribution each member makes to the 

global stiffness matrix. 

 Pressing Show Global K button: 

This allows the user to see the global stiffness matrix with all member 

contributions accounted for. 

Either way yields the same result of course. 
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At this stage the global stiffness matrix does not account for the restraints which the 

supports provide to the structure. The button Restrict DOFs applies the support 

restraints to the entries in the global stiffness matrix. 
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Once the user has completed the above steps they can press the Solve button and 

determine the Displacement Vector: 

 

 

 

Note that the grids can be copied at any stage for use in other software (such as MS 

Excel). The user selects the option select all and then copy from the right click menu. 

Once the data is copied it can be pasted into excel in its matrix format for ease of 

formatting.  

 

The user can return to the Truss Display (Window > Truss Display, Ctrl+D) to 

observe that the truss has been solved as before. 
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Hand Solution to Problem 
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8.3 Appendix 3 – References 

[1] Caprani, C.C. (2010), Matrix Stiffness Method, DT024/4 Course Notes, 

available at: www.colincaprani.com/structural-engineering/courses/structural-

analysis-iv/ 
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