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Introduction 
The Text Information Extraction System (TIES) is a web-based application that lets researchers 
affiliated with University of Pittsburgh and University of Pittsburgh Medical Center search 
pathology reports and order tissue from the paraffin archive or frozen stores. Honest broker 
services are also supported in TIES. Pathology reports from MARS are imported into TIES on a 
weekly basis. 

Some examples of potential TIES users include: 

• Attending physicians  
• Fellows  
• Department of Pathology Residents  
• Translational researchers  
• Oncologists  
• Basic scientists  
• Epidemiologists  
• Molecular biologists  
• Tissue Bank Personnel  

User Roles 
Four types of user roles are available in TIES, each having access to different functions in TIES: 

1. Preliminary users - have access to aggregate data only (not individual reports). 
2. Researchers – can search de-identified pathology reports and create case sets/orders. 
3. Honest brokers – can search pathology reports and process orders. 
4. Administrators – perform administrative functions such as creating new users and studies 

and assigning user roles. 
 

Users can be assigned multiple roles as appropriate for their work needs. 
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Logging In 
Logging into TIES can be done from the TIES webpage: http://ties.upmc.com  

To log into TIES: 

1. Click the  button on the TIES webpage. 
2. If a security popup window appears, click the Run button. 
3. Select the appropriate data network from the dropdown, and click OK. 

Note: The Production Data Network provides access to real data The Test Data 
Network contains fake data, and can be used to try out the system. 

4. Type in your username and password, and click Login. 
5. Select what role you want to be logging in as from the dropdown menu. 
6. Select the appropriate study (if logging in as a preliminary user, researcher, or honest 

broker) and click OK. 
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Query Functions 

Creating Queries 
Querying allows TIES users to search for cases and reports that are relevant to their research 
interests. To query reports, the user must be logged in as a Preliminary User, Researcher, or 
Honest Broker.  

There are two basic views for querying reports: Dashboard and Diagram. The Dashboard View is 
similar to Google or other search tools that you might use. The Diagram View is more visual and 
allows for more complex queries. In the Diagram View, users create queries by adding filters and 
constructing a diagram.  

Types of Searching 
When creating queries, users can use two main types of searches: 

 Text searching - only returns reports that contain EXACT matches to the search term. 

 Concept searching - returns documents that contain the exact search term as well as 
documents containing synonyms of the search term. Concept searching generally returns 
more accurate results. 

In TIES, concept searching is the default search type. 

One difference between concept and text searching is how NOT (negation) searches are treated. 
For text searches, reports not containing the search term anywhere in the report will be returned. 
In contrast, for concept searches, reports containing the search term in the negated form are 
returned (such as “No evidence of …”). 

Dashboard View 
The Dashboard View is the default view for querying reports, and is pictured below. 
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To query reports: 

1. Type any specific search terms you want reports to contain into the text box, separating 
search terms with commas. 

2. Select the report type(s) you wish to search by clicking the appropriate checkboxes. By 
default, all report types available for the study you logged into will be searched. 

3. Select the sections you wish to search in by clicking the appropriate checkboxes. If you 
do not select any sections to search, the entire report will be searched. NOTE: you must 
select a document type first in order to select particular report sections. 

4. Restrict age as desired by clicking the appropriate radio button and setting values.  
5. Select the appropriate gender and race from the choices provided.  
6. Restrict the event year as desired. 
7. Select the number of reports desired from the drop-down list on the right-hand side of the 

screen. If you want a random selection of reports, check the “Randomize results” 
checkbox. 
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8. Click . 
 
Note that when a search term is matched to a concept, the search term will turn blue, and you 
can mouse over the search term to see what concept it matched to. 

 
Additional search options are available by clicking the Try Advanced Dashboard link. These 
options include being able to use text searching (rather than concept searching), searching for 
any concepts listed (equivalent to “or” searching), and searching for concepts in the negated form 
(equivalent to “not” searching). A screenshot of the Advanced Dashboard is shown below. 

 

Same as ‘Basic Dashboard’ box

Additional search boxes let you 
specify Boolean OR and NOT logic

Select ‘Concept’ to map to NCI 
Metathesaurus concepts and 
search with those.  

Select ‘Text’ to treat the search 
terms as text. 
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 Diagram View 
The Diagram View allows users to visually construct complex Boolean queries and temporal 
queries. Query diagrams consist of boxes connected by arrows. The boxes represent filters to 
the query and will cause reports to be filtered out. The arrows indicate the order in which all of the 
filters are checked on any report. Query results will be any reports that make it through all of the 
filters to the Filtered Reports placeholder. Below is a picture of the Diagram View: 

 

Filters on the same path connected by arrows are AND filters – all of these conditions must be 
met for reports to be returned. Forks in the path indicate OR filters to the query. 

Types of filters that can be added include: 

 Report type 
 Search term 
 NOT search term – include reports that do not contain the search term 

Filters panel for 
adding and 
deleting filters. 
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 Event year 
 Gender 
 Age 
 Race 

 

Filters are added to the diagram either using the Filters panel on the left-hand side of the Diagram 
View, or by right clicking one of the placeholders or existing filters.  

To add filters using the Filters panel, click the appropriate filter type button in the Filters panel. 
This will add a filter box below whatever was selected in the Diagram (with the exception of the 
Report Type filter, which is always placed at the top of the Diagram). 

Inserting or deleting filters by right clicking items in the diagram simply involves selecting the 
appropriate option when right clicking. Options available when right clicking depend on what is 
clicked – for example, if you right click on the All Reports placeholder, the only option available is 
to add an AND filter below the placeholder since the All Reports placeholder must always appear 
at the top of the diagram and cannot be deleted. Then select the appropriate filter type from the 
dropdown and click OK. Note that filters for Race and Tags can only be added by right-clicking – 
they do not appear in the Filters panel. 

Specifying Filters 

In the Diagram View, filters are specified in pop-up windows that appear after inserting the filter. 
In general, these pop-up windows function in the same manner as specifications made in the 
Dashboard View. However, specifying search terms requires additional steps. 

 For each search term added, you need to specify whether you want it to be a concept search or 
text search by clicking the appropriate button. If a concept search is performed, a pop-up window 
will appear where you type in the search term, click Find, and then choose from the list of 
concepts provided. Select the concept that most closely matches what you intend to search for. 
Note that you can select multiple concepts if desired. This step is performed automatically in the 
Dashboard View.  
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If you do not see the desired concept in the pop-up window, you can modify the search term by 
changing the term at the top of the pop-up window and clicking the Find button. 

Start Over 
In both the Dashboard and Diagram Views, you can click the  button at any time to 
clear the query. After clicking the Start Over button, a pop-up window will appear asking if you are 
sure you want to start over with a blank query. Click Yes to clear the query, or click No or Cancel 
to go back to the current query. 

Save a Query 
Queries created using either the Dashboard or Diagram view can be saved for later use.  To save 
a query: 

1. Click the  button, or choose either the Save Query or Save Query As option 
from the File menu. A popup window will appear. 

2. Type the name you would like the query to be saved under in the Name field.  
3. If desired, type a more detailed description of the query in the Description field.  
4. Click the Save button to save your query. 

Open a Query 
To open a previously saved query: 

Indicate for each 
search term whether 
you want to search as 
Concept or Text 

Select concept(s) to search
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1. Click the  button, or select the Open Query option from the File menu.  
2. Click the name of the query you want to open from the dialog box that appears.  
3. Click Open. 

 
 You can also open queries saved by other users on the same study by selecting a different user 
from the drop-down list at the top of the Open Query window. 

Viewing Query Results 
After running a query, results will be displayed in a separate tab. The left-hand side of the screen 
displays a tree list of all reports returned from the query. Reports from the same institution are 
grouped together within the tree, as well as all reports for the same patient – if a patient has 
multiple reports, they will be kept together.  

To view a particular report, click on the report in the tree list. The report will then be displayed on 
the right-hand side of the screen.  

Highlighting Reports 
When a report is selected, search terms or annotations can be highlighted. Click the appropriate 
button in the De-Identified Pathology Report area of the screen if you want items to be highlighted 
in the report. 

Changing Query 
If after viewing query results you want to make changes to your query, click the  link at 
the top of the Results page to go back to the query view you used to construct the query. You can 
also click on the Query tab (located to the left of the Results tab) at any time. 

Report Options 
Once a report is in view, a number of options are available. The report can be printed, exported 
(saved locally), reviewed, or quarantined. The report can also be added to a case set/order. 
Ordering is explained in the next section. 

Print a Report 
Individual reports resulting from queries can be printed. To print a report: 

1. Select Print Report from the File menu, or right click the report and select Print.  
2. Select what you would like to print from the popup window that appears. 
3. Click OK.  
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4. Select the appropriate print settings and click OK. 

Export a Report 
Reports can be saved to your local computer using the export option. To export a report, select 
Export Report from the File menu. A popup window will appear. Navigate to the location that you 
want the report saved to, and type the name of the file you want the report saved as. Click Export 
to save the report. The report is saved as a text file. 

Request Report Review 
If you come across a problematic report (for example, the report doesn’t fit the search you 
conducted or concepts are not colored correctly in the annotations), you can request that the 
report be reviewed by using the Request Review option. Note that once a report is flagged for 
review, it can only be un-flagged by a System Administrator. To request that a report be 
reviewed: 

1. Select Request Review from the File menu, or right click the report and select Request 
Review. 

2. Explain why you are requesting a review in the comments area. 
3. Click OK. 

Quarantine Report 
If you come across any reports that are not completely de-identified (as occurs in less than 2% of 
the reports available), these reports must be quarantined so they are not available for searches. 
Reports can only be un-quarantined by a System Administrator. 

To quarantine a report: 

1. Select Quarantine Report from the File menu, or right click the report and select 
Quarantine.  

2. Confirm that you want to quarantine the report by clicking Yes. 

Charts Tab 
Query results can be viewed by looking at individual reports, or by looking at charts showing the 
distribution of reports. Charts are the only information available to Preliminary Users. 

To view a summary chart for a query: 
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1. Click the  button, or select Charts from the View menu. This will open the Charts 
tab. 

2. Create a query in either the Dashboard or Diagram View. 
3. Select the type of chart to view by clicking the appropriate button. The default chart type is 

bar chart. 
4. Select the type of filter to categorize query results by in the Categorize By drop-down list. 

5. Click . 
 

Query results will be shown as a chart rather than individual results. Note that for pie charts, only 
one category type can be selected, while subcategories are allowed when making bar charts. 
Categories are the primary category, while subcategories allow categories to be subdivided. For 
example, if you choose age as the primary category and gender as the subcategory, each age 
group will be subdivided into males and females. 

Charts can be revised after they are created. You can change the chart type and categories used 

in creating the chart. Make the appropriate changes and click . 

Several options are available if you right-click the chart, including Copy, Save As, and Print. 
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Order Functions 
Ordering tissue in TIES is a multi-step process involving communication with the honest broker to 
confirm the order. Orders can be created by Researchers or Honest Brokers. Honest Brokers can 
fill orders and update order status. The basic order procedure is as follows: 

1. An order is created by a Researcher (or Honest Broker). 
2. The order is submitted and is added to an Honest Broker’s queue. 
3. The Honest Broker verifies the order, performing the following steps: 

a. Examining IRB approval 
b. Verifying tissue availability 
c. Updating the status of each order item 

4. The Honest Broker requests confirmation from the Researcher after updating the status of 
all order items and setting the order status to either Retrieved or Incomplete (depending 
on whether all requested items were available or not). The order is then added to the 
Researcher’s awaiting confirmation queue. 

5. The researcher confirms the order. The order is added to the Honest Broker’s confirmed 
queue. 

6. The Honest Broker fulfills the order by performing the following steps: 
a. Cutting tissue/slides 
b. Shipping tissue to the PI or holding tissue for collection by the PI 
c. Setting the order status to Distributed. 
 

Each of these steps is explained in more detail below. Steps for Researchers and Honest 
Brokers are described separately. 

Ordering Steps for Researchers (Person Placing an Order) 

Ordering Tissue 
After running a query, tissue can be ordered. A new order can be created, or tissue can be added 
to an existing order. You must be in the query results tab to order tissue. 

Create a New Case Set/Order 

To create a new case set: 

1. Click the  button in the My Case Sets area of the Results tab. 
2. Type in a name for the case set. 
3. Click OK. 
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Add an Item to an Existing Case Set 

To add an item to an existing case set, simply drag and drop the desired report to the appropriate 
case set in the My Case Sets area. Alternatively, you can right click the report, select Add Report 
to, and choose the appropriate case set. 

Options for Created Case Sets 
Once a case set is created, individual case set items or the entire case set can be deleted, 
instructions to the honest broker can be specified, items can be printed and exported, and the 
order can be submitted. All of these actions are performed in the My Case Sets tab. The My Case 
Sets tab is organized as a tree, similar to query results. The main headings are case set names, 
and individual items appear underneath each order. 

Remove an Item from an Existing Case Set 

To remove (delete) an item from a case set: 

1. Select the particular report you want to delete from the Case Sets pane. 
2. Click the  button under Available Tasks. 

Delete a Case Set/Order 

To delete an entire case set/order: 

1. Select the case set you want to delete from the Case Sets pane. 
2. Click the  button under Available Tasks. 
3. Click Yes in the Confirm Order Deletion popup window that appears. 
4. Click Ok in the Order Deleted popup window that appears. 

Specify Tissue Requirements 

Tissue requirements can be specified for individual items. To insert instructions/tissue 
requirements: 

1. Select the particular item you want to insert tissue requirements for. 
2. Under Available Tasks, specify your requirements from the options provided, and type in 

any additional instructions in the Additional Notes textbox. 
3. Click the  button located under Available Tasks. 
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Order instructions can also be modified by clicking the Specify Ordering Instructions textbox and 
making the desired changes to the instructions. Be sure to click the Save button to save any 
changes made. Requirements/instructions can also be added after orders have been submitted. 

Print Order Items 

Individual order items can be printed.  

To print all items in a case set/order: 

1. Select the case set from the Case Sets pane. 
2. Click the  button located under Available Tasks.  
3. Select the contents you wish to print by selecting the appropriate checkboxes. 
4. If desired, make revisions to the Page Setup by clicking the Page Setup button. 
5. Click Print. 
6. Select the appropriate print settings and click OK. 

 
To print an individual case set item: 

1. View the item by expanding the case set and clicking the case set item in the Case Sets 
pane. 

2. Click the  button located under Available Tasks. 
3. Select the appropriate print parameters in the popup window that appears. 
4. Select the appropriate print settings and click Ok. 

Export Order Items 

Information about order items can be saved to your local computer using the export option. The 
data is saved as a text file. 

To export all items in a case set/order: 

1. Select the case set from the Case Sets pane. 
2. Click the  button located under Available Tasks.  
3. Select the contents you wish to export by selecting the appropriate checkboxes. 
4. Click the  button. 
5. Navigate to the location that you want the order items saved to, and type the name of the 

file you want it saved as. 
6. Click Export to save the order items.  

 
To export a single case set item: 
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1. View the item by expanding the case set and clicking the case set item in the Case Sets 
pane. 

2. Click the  button located under Available Tasks.  
3. Navigate to the location that you want the order items saved to, and type the name of the 

file you want it saved as. 
4. Click Export to save the item.  
 

Submit an Order 

Once you have added all the items you wish to order to a particular order, the order should be 
submitted so an Honest Broker can fill the order and update the status of order items. Tissue 
orders may not be completely filled by the Honest Broker due to unavailability of some of the 
order items requested. 

To submit an order: 

1. Select the order you want to submit from the Case Sets pane. 
2. Click the  button located under Available Tasks. 
3. Click Yes to confirm that you want to submit the order. 

 
After an order is submitted, its status is changed to “submitted”. The order will appear in the 
Submitted Orders pane. 

Options for Submitted Orders 

Cancel an Order 

To cancel an order that has been submitted: 

1. Select the order you want to cancel from the Submitted Orders pane in the My Case Sets 
tab. 

2. Click the  button located under Available Tasks. 
3. Click Yes to confirm that you want to cancel the order. 

Confirm an Order for Shipping 

Confirming an order for shipping is the second step in the two-step process of ordering tissue. 
The first step involves the Researcher submitting the order to the Honest Broker, after which the 
Honest Broker updates the availability status of the items. Tissue orders may not necessarily be 
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completely filled by the Honest Broker due to unavailability of some of the order items requested 
in the order. 

If the order cannot be filled in its entirety, the Researcher may or may not want the order to be 
shipped. Therefore, before an order is shipped, the Researcher must confirm shipment of the 
order. 

To confirm an order for shipping: 

1. Select the order to confirm for shipping from the Submitted Orders pane in the My Case 
Sets tab. 

2. Click the  button located under Available Tasks. 
3. Click Yes to confirm that you want to confirm the order for shipping. 
 

Note that after an order is submitted, the Researcher may only add additional ordering 
instructions to the order items. He/she may not modify, add or remove order items. When the 
honest broker updates the status of all order items and requests confirmation from the 
Researcher, the Researcher then has an option to modify the order and resubmit if he/she is not 
happy with the order status. To modify the order, simply click the  button located 
under Available Tasks. At that point, the order will be moved back to the Open Orders pane, and 
items can be added and removed from the order. 

Order Options for Honest Brokers 
Once an order is submitted, Honest Brokers can update the status of orders in the Manage 
Orders tab. To view the Manage Orders tab, click the  button, or choose Manage 
Orders from the View menu. In the Manage Orders tab, all orders from a particular study are 
grouped together, and individual order items are listed underneath each order. Orders that are 
new to your queue and have not been viewed yet are listed under the New Orders Pane. 

Update Status for Orders and Order Items 

The status of orders and individual order items should be updated by the honest broker as they 
go through steps. Below is a table listing the different statuses available: 

Order/Order Item Status Description

Order Item Retrieved Actual tissue was retrieved
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Order Item Not Found Tissue could not be located

Order Item Reviewed Order item was approved

Order Item Unusable Tissue was located, but is not usable (e.g. not 
enough left) 

Order Item Processed New slides have been made and are ready for 
pickup/shipping 

Order Item Distributed Tissue has been approved, processed, and 
picked up/shipped 

Order Not Submitted Not sent to Honest Broker (not visible in 
Honest Broker Queue) 

Order Pending In Honest Broker Queue

Order Requested Honest Broker requested tissue to be retrieved

Order Incomplete Not all of the order items were found or some 
were unusable 

Order Retrieved All order items were retrieved

Order Cancel Researcher cancelled order

Order Confirmed Researcher confirms the order after Honest 
Broker accepts ore rejects all order items 

Order Processed All order items have been processed 

Order Distributed All order items have been picked up/shipped 

 

To update the status of individual order items and orders: 

1. Select the particular order item or order to be updated from the appropriate orders pane 
(New Orders, In Process Orders, etc.) in the Manage Orders tab.  

2. Select the appropriate status from the Status drop-down list. 
3. Click the  button. 
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The status of order items and orders should be continually updated as appropriate. 

Add Comments to an Order 

There may be times where Honest Brokers want to add a comment concerning the status of an 
order item. A common example of an Honest Broker comment is the reason why an order item 
cannot be fulfilled. 

To add comments to an order: 

1. Select the particular order item to comment on from the New Orders pane in the Manage 
Orders tab. 

2. Click in the Honest Broker Comments textbox and enter the comments. 
3. Click the  button to save changes. 
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Administrator Functions 
Administrators in TIES manage accounts and can create new users and protocols. Upon logging 
in as an Administrator, the Manage Accounts tab is available. In this tab, you can see users and 
studies in the system. 

A screenshot of the Manage Accounts tab is shown below. 

 

Add a TIES User 
To add a new user: 

1. Click the  button or select New User from the File menu. 
2. Enter a username for the user. A temporary password is already provided. 
3. Fill in user information fields as applicable. 
4. Select the role to assign the user from the drop-down list. 
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5. Click OK. 
 

The user will now be included in the Users list. 

Edit a TIES User 
Once created, TIES users can be modified. Roles can be added or modified (set to expire or 
never expire), contact information can be updated, and user passwords can be reset.  

Add a Role to a User 
Users can be assigned multiple roles. To add a role to an existing user: 

1. Click on the Users pane in the Manage Accounts tab. 
2. Select the name of the user you want to edit from the list of users. 
3. Select the appropriate role from the drop-down list and click . 
4. Click Yes to confirm that you want to add the role. 
5. Click the  button located under Available Tasks. 

Edit User Information 
Contact information can be changed, and roles previously assigned to users can be set to expire 
or not expire. To edit user information or modify role assignments: 

1. Click on the Users pane in the Manage Accounts tab. 
2. Select the name of the user you want to edit from the list of users. 
3. Make changes to the user as applicable. 
4. Click the  button located under Available Tasks after all changes have been 

made. 

Reset Password 
To reset a user’s password: 

1. Click on the Users pane in the Manage Accounts tab. 
2. Select the name of the user you want to edit from the list of users. 
3. Click the  button, or select Reset Password from the File menu. 
4. Click Yes to confirm that you want to reset the password. A temporary password will 

automatically be generated. 
5. Click Yes to send a notification email to the user. 

Add a TIES Study 
New studies can be added to an organization by the administrator. To add a new study: 
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1. Click the  button, or select New Study from the File menu. 
2. Enter a title and abbreviated name for the study. 
3. Select the type of study from the dropdown. Options are Data Only, or Data & Tissue. 
4. Enter the IRB approval number. 
5. Set the expiration date for the study. If the study does not expire, click the Never Expires 

checkbox. 

6. Select the report types allowed by clicking  and making the appropriate selections. 
7. Click OK. 

 
The study will now be included in the Studies list. 

Edit a TIES Study 
In general, here are the steps to edit an existing study: 

1. Click on the Studies pane in the Manage Accounts tab. 
2. Select the name of the study you want to edit from the list of studies. 
3. Make the desired changes. 

 
Some specific changes you may wish to make are adding an institution to a study, adding a user 
to a study, editing the type of study, and approving access for users. 

Add an Institution to a Study 
Some studies require access to data from other institutions. To request access to another 
institution’s data for a study: 

1. Click on the Studies pane in the Manage Accounts tab. 
2. Select the name of the study you want to edit from the list of studies. 

3. Click the  button under Institution Memberships. 
4. Select the institution from the dropdown list. 
5. Select the type of access needed from the dropdown list. 
6. Click OK. 

 
Access to an institution’s data can only be granted by that institution. 

Add a User to a Study 
In addition to being assigned multiple roles, users can also be assigned to multiple studies. To 
add a user to a study: 

1. Click on the Studies pane in the Manage Accounts tab. 
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2. Select the name of the study you want to edit from the list of studies. 

3. Click the  button under User Memberships. 
4. Select the appropriate user from the dropdown. 
5. Select the role the user should take for this study from the dropdown (if the user has 

multiple role assignments). 
6. Click OK. 

Edit the Study Type (Data Only or Data & Tissue) 
To edit the type of study: 

1. Click on the Studies pane in the Manage Accounts tab. 
2. Select the name of the study you want to edit from the list of studies. 
3. Select the appropriate option from the Type dropdown. 

4. Click the  button to save changes. 

Approve Access for Users 
For cross-institutional studies, access to an institution’s data can only be granted by that 
institution. To grant or revoke access to your institution’s data: 

1. Click on the Studies pane in the Manage Accounts tab. 
2. Select the name of the study you want to edit from the list of studies. 
3. Mouse over any data access requests that need to be modified. When mousing over, the 

status will display what it can change to. For example, requested access can be 
approved, and approved access can be revoked. 

4. To make the access change, simply left-click. 
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Frequently Asked Questions 

Query Functions 

What is the difference between text searching and concept searching? When 
should I use these search types? 
Concept searching searches for the search term(s) you typed in, as well as any synonyms of 
those terms. Text searching only returns reports containing EXACTLY what you typed. Concept 
searching generally returns more accurate results because different wordings may be used 
across reports. Note that negation (NOT searching) is treated differently in concept and text 
searching. In concept searches, negation searching looks for reports saying things like “No 
evidence of ….” – the search term is negated in the report. In text searches, negation searching 
returns reports not containing the search term anywhere in the report. 

When should I use the Diagram View for querying? What benefits does it have 
over the Dashboard View? 
Querying in the Diagram View allows several features that the Dashboard View does not. When 
using the Diagram View, you can use concept searching AND text searching in the same query – 
you can search for some search terms as concept searches, and others as text searches. 
Additionally, the Diagram View allows temporal searching. These features are not available in the 
Dashboard View. In general, the Diagram View allows for more complex queries. All features 
available in the Dashboard View are also available in the Diagram View. 

I created a query in the Diagram View. Why can’t I see it in the Dashboard View? 
If you create a query in the Diagram View that contains features not available in the Dashboard 
View, such as temporal searching, the query cannot be displayed in the Dashboard View. 

 


