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Cautions and disclaimer 

VivoSense
TM

 software is not a medical diagnostic tool. It is for research and investigational purposes only and 
is not intended to be, or to replace, medical advice or review by a physician. 

 

Copyright Notice 

Copyright © 2012 Vivonoetics.  All rights reserved. 
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1. Introduction 
Vivosense is a visualization and analysis tool designed for compact user interaction and is ideal for 
processing recording sessions individually. VNBatch.exe is a non-interactive stand-alone application 
designed to apply the same sequence of commands (Batch Procedure) on an entire list of recording sessions 
(File List) in VivoSense.  

The VivoSense Batch Processing Module consists of three components within the Vivosense application: the 
Batch Manager, an additional menu item to launch a Batch Process, and the actual executable called 
VNBatch.exe.   

This manual describes how to use the Batch Manager for configuring a Batch Procedure and for the creation 
of File Lists, both used as input to a Batch Process. 

It is assumed that the user is familiar with the VivoSense application and it is recommended to read the 
Vivosense Core manual prior to reading this manual on Batch Processing.  

A Batch process allows the user to apply the same set of commands to a set of files to save time, eliminate 
human errors or to easily reproduce previous results. 

1.1. System Requirements 
This module is an add-on processing module and requires the VivoSense core software.  
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2. Batch Process 
A Batch Process is executed as a stand-alone application called VNBatch.exe. It is set up and configured 
from within Vivosense via the 'Batch Manager.' Note, VNBatch.exe is a separate application that will continue 
to execute even if Vivosense is terminated. 

2.1. Use Case 

The Batch Process is intended to standardize the processing of multiple sessions. Depending on the details 
of the Batch Procedure it is expected that all the sessions have certain commonalities with respect to 
duration, available channels and the type of hardware use to collect the data in order to get consistent results 
across all sessions. 

2.2. Setting up a Batch Process 
Setting up a Batch Process follows three steps: 

 

1. Create a Batch Procedure using Batch Manager. 

2. Compile a File List using Batch Manager. 

3. Launch VNBatch.exe via 'Tools->Launch Batch Process'. 
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3. Batch Manager 
The Batch Manager is a graphical component of Vivosense used to set up and manage Batch Procedures 
and File Lists. It is launched by selecting ‘View->Batch Manager’, pressing the ‘F8’ keyboard button or 
clicking the ‘Batch Manager’ icon. 

 

The Batch Manager consists of two components: the top component is a collection of all the Batch 
Procedures organized in a tree view within the root directory 'User'. On opening the Batch Manager the ‘User’ 
root folders will be empty. Figure 1 shows an example of the Batch Manager after it has been populated with 
relevant Batch Procedures and File Lists. 

 

 

Figure 1: Batch Manager 
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3.1. Managing Batch Procedures 
A Batch Procedure is a set of commands that is to be performed on a single file in a defined order. Since the 
Batch Process does not accept user input other than to ‘Cancel’ the batch procedure, therefore all command 
properties must be predefined. The time location or time range cannot be selected for a batch procedure. 
Therefore all commands listed under the ’Session’ menu are available as options for a batch procedure 
however the commands listed in the sub menus on the Synchronized Chart Panel (SCP) will not be available.  

Creating a Batch Procedure 

Every Batch procedure is initiated by loading a recording session either by opening a vsn file or by importing 
raw data from any of the supported sensor formats.  

Opening a vsn file: 

The Batch Procedure is started by right clicking on 'User->New Vivosense Batch Procedure'  

Importing a support sensor format: 

The Batch Procedure is started by right clicking on 'User->New Import Batch Procedure->Import file', where 
‘Import file’ is a generic placeholder for the specific import type used with this Batch Procedure. Depending 
on the type of import the user may be prompted to specify additional information related to the import in the 
same way as he would by importing a file of this type via ‘File->Import Hardware File->Import file’. This 
additional information will be stored together with any other Batch Procedure configurations for the later use 
in a Batch Process. The default name for the procedure is ’New Config n’ (where ‘n = 1,2,3,..’) and can be 
changed by the user. A Batch Procedure can be deleted by right clicking on the corresponding menu item in 
the Batch Procedure tree and selecting ‘Delete’. 

Adding Commands to a Batch Procedure 

A command can be added to a Batch Procedure by right clicking on the corresponding menu item in the 
Batch Procedure tree and selecting ‘Add Command’.  

There are some universal commands that apply to all sessions such as all the Export commands, Template 
commands or the ‘Set Start Time’ command. However, most commands are specific to the particular session 
import type and depend on the user license. Therefore, the Batch Manager requires that there be an open 
session (preferably of the same type as the ones the Batch Procedure is intended for) or the user will be 
prompted to open a session (Figure 2).   

 

Figure 2: Adding a command without an active session 
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Since a Batch Process is non-interactive, the batch commands must be pre-configured. There are three types 
of user interactions that can be performed after launching a command: 

Set user defined parameters prior to performing a calculation. 

This interaction is implemented by setting up a Batch Command in the same way in which a command is 
executed on a session in the interactive mode (not in batch mode). Note: there are small differences between 
executing a command in interactive and batch mode: e.g. launching an export file with the default application  
after a command is completed is convenient in interactive mode but launching an export file for every session 
being processed by a Batch Process will slow the process and may be undesirable . 

Make a decision based on the outcome of a calculation. 

This interaction is implemented by automatically selecting the default option rather than asking for user input. 

Display the result of the calculation to the user. 

This interaction is implemented by writing any output to a log file (see section 4.4).  

Deleting Command from a Batch Procedure 

A Batch Command can be deleted by right clicking on the command in the Batch Procedure tree and 
selecting ‘Remove’ to remove it from the tree. 

Renaming a Batch Procedure 

A Batch Procedure can be renamed by right clicking on the corresponding menu item in the Batch Procedure 
tree and selecting ‘Rename’ and entering a desired name. 

Changing Settings of Batch Procedure Command 

A Batch Command that has been configured and added to a Batch Procedure can be edited at any time. To 
edit the Batch Procedure, view the Property Window by pressing ‘F4’ or the ‘Property Window’ icon on the 
toolbar (see the VivoSense Core Manual). By selecting the Batch Command in the Batch Manager we will be 
able to edit that Batch Command’s properties. 

Rearranging the Order of Batch Command 

The Batch Commands are executed in the order they appear within a Batch Procedure. A Batch Command 
can be moved up or down within the Batch Procedure by right clicking on the Batch Command menu item in 
the Batch Procedure tree and selecting ‘Move Up’ or ‘Move Down’. 

 

3.2. Managing File Lists 
A File List is a collection of sessions used by a Batch Process. It is a convenient way of organizing sessions 
for multiple uses. All the files within one File List must be of the same type in order to guarantee that they can 
be processed by the same Batch Procedure. 

The File List can be found in the Batch Manager in the panel below the Batch Procedures. 
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File List Folders 

File Lists are organized under the User directory and can be saved in new or existing folders. To create a 
new File List folder, right click on the “User” folder and choose “New Folder” from the subsequent menu. File 
List folders can be created, renamed or deleted by right clicking and selecting ‘New Folder’, ‘Rename’ or 
’Delete’. See Figure 1. 

Creating a File List 

A File List is created by right clicking on the corresponding Folder in the File List tree going to ‘New Filelist’ 
and selecting the desired file type from the list of imports. A ‘Select Files’ dialog will pop up and prompt the 
user to select files to be added to the newly created File List. The user may select to add files now or add 
files at any time thereafter. See Figure 1. 

Adding Files to an Existing File List 

Additional files can be added to a File List by right clicking on the File List, selecting ‘Add Files’  and adding 
the new files using the resulting dialog. During a Batch Process the sessions within a File List are processed 
in the order they are shown in the Batch Manager. It may be desirable to arrange these files in a specific 
order, particularly if an export Batch Command is used as exported data will be appended in this specific 
order to the export file. Files can be ordered and moved by dragging and dropping the file in order to obtain 
the desirable file order. 

Renaming a File List 

A File List can be renamed by right clicking on the corresponding menu item in the File List tree, selecting 
‘Rename’ and entering a new file list name. 

Deleting a File List or a File List Folder 

A File List or any File List Folder can be deleted by right clicking on the corresponding menu item in the File 
List tree, and selecting ‘Delete’. 

 

3.3. Launching a Batch Process 
 

A Batch Process is launched from the main menu in Vivosense by going to ‘Tools->Launch Batch Process’. 
See Figure 3: 
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Figure 3: Configuring and Launching a Batch Process 

 

One of the previously created Batch Procedures as well as a corresponding File List is selected from the 
“Launch Batch Process” dialog box. The selection of the batch procedure is required input, while the File List 
is optional. If no File List is selected the user is prompted with a File Dialog asking to select one or more files. 
This allows the Batch Process to be run without first having to create a File List in the “Batch Manager”. Only 
.vsn files can be batch processed in this way.  

Note that while a Batch Process is configured and launched from within Vivosense it is runs as a stand-alone 
application that will continue to execute even after Vivosense is shut down.  
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4. The VNBatch.exe Application 
 

 

Figure 4: VNBatch.exe during execution 

VNBatch.exe is intended to be executed without user interaction. It opens all the session specified in the File 
List in order and performs all the Batch Commands specified in the Batch Procedure. Figure 4 shows a 
screenshot of VNBatch.exe during execution while Figure 5 shows the same process after the execution is 
completed. 

 

4.1. Pause/Continue 
The Pause/Continue button allows the user to temporarily interrupt the execution of the Batch Process. This 
is useful if one wants to minimize the CPU usage of VNBatch.exe in order to perform other tasks. This option 
is grayed out after completion of the process (Figure 5) 

4.2. Status Bar 
There are up to two progress bars in the status bar of the application. The first one indicates the overall 
progress of the Batch Process, the second one indicates the progress of the session in process. When the 
Batch Process is finished executing the status bar will read ‘Batch process completed’ (see Figure 5). 

4.3. Sessions Listbox 
The list box under ‘Sessions’ shows all the file names of all the sessions in the File List. The status is 
indicated in the ‘Status’ column and reflected by an icon 
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4.4. Log Information 
The Log information list box on the right side of VNBatch.exe displays details regarding the processing of a 
particular session. It can be viewed by selecting the corresponding file name in the Sessions list box. In 
general, there is one entry for every Batch Command with the icon indication failure (red x) or success (green 
check mark).  Additional information may be available for some commands (info icon) 

 

 

Figure 5: VNBatch.exe after execution is completed 

4.5. Log File 
Every Batch process writes out a log file called: 

DOC\Vivonoetics\VivoSense\Logs\Logfile [Time Date].txt 

Where DOC is the user Document folder, Time is the creation time in the format hh.mm.ss and Date is the file 
creation date in the format mm-dd-yyyy. 
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5. Additional Commands 
It is often desirable to perform a command only on a subset of a session. In this case it is useful to identify 
the region by an annotation. In addition, there a commands for the management of annotations that can be 
used from batch mode. 

5.1. Annotation based Commands 

‘Export Data by Annotation’ menu item 

The command ‘Session->Annotations->Export Data by Annotations’ will export all the data within the time 
range of any visible annotation. Multiple visible annotations yield multiple exports to the same file separated 
by a blank line. Overlapping annotations will result in the same data being exported multiple times. 

‘Export Statistics by Annotation’ menu item 

The command ‘Session->Annotations->Export Statistics by Annotations’ will export all the statistics within the 
time range of any visible annotation. Multiple visible annotations yield multiple exports to the same file 
separated by a blank line. Statistics will be calculated over the entire annotation regardless of any potential 
overlap. 

‘Duplicate Annotations’ menu item 

The command ‘Session->Annotations->Duplicate Annotations’ will create duplicates of all currently visible 
annotations. A dialog will pop up that lets the user enter a shift (in seconds) of the start and end time of the 
annotation. In addition, the user can enter annotation name and description. It is recommended to choose 
unique names so that the resulting annotations can be removed easily. 

If the resulting start time of the duplicate annotation is earlier than the session start time then the start time 
shall be set to the session start time.  

If the resulting end time of the duplicate annotation is later than the session end time then the annotation end 
time shall be set to the session end time.  

If the resulting end time of the duplicate annotation is earlier than the annotation start time then the 
annotation end time shall be set to the annotation start time.  

‘Merge Annotations’ menu item 

The command ‘Session->Annotations->Merge Annotations’ creates a new annotation for every consecutive 
pair of visible annotations. The earlier (later) of the two annotations will define the start (end) time of the new 
annotation. When this item is selected a dialog will pop up and let the user enter an annotation name and 
description for the newly created annotations. It is recommended the user chose unique names such that the 
resulting annotations can be removed easily. 

‘Clone Annotations as HRV Regions’ menu item 

The command ‘Session->Annotations->Clone Annotations as HRV Regions’ creates a new HRV Region 
annotations that match the start and end times of the currently visible annotations. The resulting HRV region 
must not overlap with an already existing HRV region.   

By default, all annotations created by command are visible. 
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‘Remove Annotations’ menu item 

The command ‘Session->Annotations->Remove Annotations’ will PERMANENTLY remove all the visible 
AND removable annotations. 

5.2. Annotation Management 
This is a set of commands for managing annotation properties such as adding/deleting and showing/hiding 
annotations based on the text and description. The purpose is to streamline the annotation management and 
to make the capability available in batch mode. 

Make all annotations visible 

A menu item called ‘Show all Annotations’ will be added to the ‘Session->Annotations’ menu. When this item 
is selected all annotations will be made visible.  

Make all annotations invisible 

A menu item called ‘Hide all Annotations’ will be added to the ‘Session->Annotations’ menu. When this item is 
selected all annotations will be made invisible.  

Make selected annotations visible 

A menu item called ‘Show Annotations’ will be added to the ‘Session->Annotations’ menu. When this item is 
selected a dialog opens as shown in Figure 6 

 

Figure 6: Select annotations by name and description 
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After clicking ‘ok’ the application will select all annotations that match (don’t match) the search strings if the 
option ‘match search string’ is selected (de-selected) and make them visible. In addition, there is the option to 
set the matching to case sensitive. 

Make selected annotations invisible 

Same as last command except that the selected annotation will be made invisible. 

 



VivoSense – Batch Processing Module 

User Documentation HRV Standard Edition Module  
Page 16 of 16 

6. Appendix A – Glossary of Terms 
The following is a list of frequently used Batch Process terminology: 

Batch Command 

A Batch Command is any procedure performed on an open Vivosense session. Currently, any interactive 
Vivosense command launched from within the Session menu in Vivosense is a valid Batch Command. Note, 
the list of commands available is session depended. (For instance, the command ‘Automatic Artifact Marking’ 
is only available for sessions containing an ECG waveform.) 

Batch Procedure 

A Batch Procedure is a sequence of Batch Commands. Batch Procedures are created, configured and stored 
using the Batch Manager  

Batch Process 

A Batch Process is the execution of a windows application that performs a selected Batch Procedure on a list 
of selected files. The files used can either be .vsn files or any files of the supported import types. Note, only 
files of the same type can be processed within the same Batch Process. 

Batch Manager 

The Batch Manager is the graphical component in Vivosense used to manage Batch Procedures and File 
Lists 

File List 

A File List is a either a collection of .vsn files or a collection of files of any of the supported import files. Note, 
all the files within a File List must be of the same type. 

VNBatch.exe 

VNBatch.exe is the stand alone Windows application that executes the Batch Processes.   


