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| ntroduction

The Columbia River Salmon Passage model (CRiSP.1) tracks the downstream migration and survival of
migratory fish through the tributaries and dams of the Columbia and Snake Rivers to the estuary. CRiSP.1
describes in detail the movement and survival of individua stocks of natural and hatchery-spawned juvenile
salmonids and steelhead through hundreds of miles of river and the major dams. Constructed from basic
principles of fish ecology and river operation, CRiSP.1 provides a synthesis of current knowledge on how the
major hydroelectric system in the country interacts with one of its magjor fisheries. Biologists, managers and
others interested in the river system can use this interactive tool to evaluate the effects of river operations on
smolt survival.

There are five magjor uses of the model:

1) educate users on the state of knowledge of the system

2) develop experiments

3) evaluate sensitivity of fish survival to different system factors

4) predict survival and travel time for usein life-cycle models and inseason management
5) estimate uncertainty in predictions.

There are two modes in which CRiSP.1 can be executed. Scenario Mode illustrates the interactions of model
variables. Monte Carlo Mode, which is stochastic, provides measures of variability and uncertainty in predicting
passage survival. Using Monte Carlo Mode, estimates of probability distributions for survival and travel time
can be determined for any stock between any two pointsin the river system.

CRIiSP.1 has advanced programming features including:

- graphical user interface to access and change model variables and equations

- flexible data structure that allows expansion of the model while assuring backwards compatibility
with earlier versions

- reconfigurability to adifferent river without reprogramming
- on-line help system.

The model is designed to run on Windows 95/NT operating systems or Sun SPARC workstations running
Solaris2.X operating system. CRiSP.1 has been tested in both environments.

CRIiSP.1 was developed at Columbia Basin Research, School of Fisheries, University of Washington, under a
contract from Environment, Fish and Wildlife, Bonneville Power Administration (BPA).

The model is being applied to the Columbia River. As aresult, the files describing the river and rel ease points
of fish into the river are an essential part of the model. A list of references pertaining to model theory and
calibration can be found in the Theory, Calibration and Validation Manual (updated version due in 2000).

General Description

CRIiSP.1 models passage and survival of multiple salmon substocks through the Snake and Columbia rivers
and their tributaries and the Columbia River Estuary.
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The model recognizes and accounts for the following aspects of the life-cycles of migratory fish and their
interaction with the river system in which they live.

Fish survival through reservoirs depends on:

- predator density and activity
- tota dissolved gas supersaturation level s dependent on spill
- travel timethrough areservoir.

Fish migration rate depends on:

- fish behavior and age
- water velocity which depends on flow, cross-sectional area of areach, and reservoir elevation.

Fish passage through dams depends on:

- water spilled over the lip of the dam

- turbine operations

- bypass screens at turbine entrances and fish guidance sluiceways
- fish diel behavior.
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Turbine

Cross-section of a dam showing fish passage routes. Fish collected in bypass systems are
returned to the tailrace or transported downstream.

CRISP.1in Context with Other Models

CRIiSP.1 is one of several models describing the passage of juvenile salmon through the Columbia Basin
system. The major mainstem passage models and their time steps are outlined below. All of these models
describe fish survival through the river system but differ in the detailsincluded. The simplest model is PAM and
the most complex is CRiSP.1.6. With increasing complexity, the other modelsfall in between. CRiSP.0 isclose
to PAM, FLUSH liesin the middle and CREM and RESPRED are in turn more complex.

- PAM - Smolt passage and survival is described through aflow relationship, and dam survival through
passage efficiencies and mortalities. Time step is one year.

- CRiSP.0 - Smolt reservoir survival is through aflow relationship. Dam survival is through passage
efficiencies and mortalities. Time step is daily.

- FLUSH - Reservoir survival in terms of fish residence time depending on flow and fish sizeand a
predation mortality rate that depends on temperature. Dam survival is through passage efficiencies
and mortalities. Time step isdaily for fish passage and monthly for flow.

- CREM/RESPRED - Smolt passage and survival through areservoir depends on interactions of
temperature, smolt run timing, size and number of both predator and prey. Dam survival is modeled
with passage efficiencies and mortalities. Time step is afraction of an hour.

- CRiSP1
- version 3 - Smolt reservoir survival depends on travel time, which depends on flow and
mortality rates which in turn depends on temperature, predator abundance and nitrogen
supersaturation. Dam survival depends on diel passage mortalities and passage efficiencies.
Time step isafraction of aday.

- version 4 - Smolt reservoir survival depends on travel time, which depends on flow, reservoir
elevation, smolt age and mortality rate which in turn depends on fish age, temperature,
predator abundance and nitrogen supersaturation. Mortality in dam passage isidentified
separately for the forebay, dam passage routes and the tailrace. These mortalities depend on
diel factors and passage efficiencies, which may depend on smolt age. Time step isafraction
of aday.

- version 5 - Smolt reservoir survival depends on travel time, which depends on flow, reservoir
elevation, smolt age and release date, temperature, predator abundance and nitrogen
supersaturation and fish depth. Mortality in dam passage isidentified separately for the
forebay, dam passage routes and the tailrace. These mortalities depend on diel factors and
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passage efficiencies, which may depend on smolt age. Time step is a fraction of a day. Several
options are available to define mortality ratesin transportation.

- version 6 - Same asversion 5 with an improved dam delay submodel, an improved predation
submodel, and a new gas generation and mortality submodel.

Simple and complex models each have advantages and disadvantages and the choice depends in part on the
types of questions being addressed. Simple models are easy to understand and do not require large amounts of
data since they are generally developed to the degree of resolution of the available data. Unfortunately, since
they are designed to fit existing data, the variables are identified from past studies and there isno formal process
to assessif chosen variables areinsignificant or the driving variables. Simple models, being empirical and based
on existing data, typically fit the available databut it is not clear that they would still represent the system if the
system were to change.

In general, complex models are based on underlying mechanisms which are inferred from anal ogous systems.
As such, they often can be extended beyond the data of the system they are modeling. Mechanistic models are
particularly useful for developing hypotheses that are to be tested through experimentation. A disadvantage of
such modelsis that they require a considerable effort to understand and calibrate, and there is a chance that the
underlying mechanisms may be misapplied or inappropriate, this can aso be the case with simple empirical
models.

Thetags of “simpleand empirical” vs. “complex and mechanistic” are, in fact, only points along a continuum.
Even the simplest models have some underlying mechanism and complex models, at some level of detail,
contain empirical descriptions in which the parameters have no mechanistic foundation and are applied because
they fit data or a desired mathematical form. The level of detail at which a model switches to empirical
formulations distinguishes its degree of mechanism.

All of the existing mainstem fish passage models leave out some variables which may be important. The
simplest models, such as PAM and CRiSP.0, rely solely on flow to describe survival and are of limited value for
investigating other factors. Although FLUSH and CRiSP.1.6 consider the effects of fish age on survival, none
of the models considers differences in fish conditions, fish bioenergetics, or the river and tributary carrying
capecities.

CRIiSP.1in the Decision Making Process

The CRIiSP.1 model provides one tool for decision makers. In the Monte Carlo Mode, model parameters are
varied and a probability distribution of survival iscalculated for a particular management action. Taken on their
own, model runs provide compelling evidence for selecting management action.

The question arises. Can the results of a model be trusted? Answering this question is difficult and involves
good judgement which must also include societal, economic and political considerations. To proceed, decision
makers need to know if amodel isin agreement with the existing data, with other models, and with the general
qualitative understanding of how the system works. The CRiSP.1 model has tools to address these needs.

- Qualitative understanding. Users are provided with several toolsto develop a qualitative intuition of
how the model works.

- Runs of the model done in Scenario Mode allow a decision maker to study how each model
element affects fish migration and survival.

- The Theory, Calibration and Validation Manual provides information on how CRiSP.1is
formulated.

- Comparison with data. The calibration portion of the Theory, Calibration and Validation Manual
provides users with information on how CRiSP.1 fits data.

9 CRiSP.1



- Predictive understanding. Users can obtain quantitative, probability-based predictions of surviva and
travel time using the Monte Carlo Mode of CRiSP.1. Results can be compared to the quantitative
results of other models such as those mentioned in the previous section.

Fish Passagein CRiSP.1

- Species and Stocks
- Passage Algorithms
- Survival and Migration

Species and Stocks

The species and stocks of fish entering the river system are arbitrarily defined. Species are identified as:

- Yearling chinook usually the progeny of “spring” run chinook salmon;

- Subyearling chinook usually the progeny of “fall” run chinook salmon on the Snake River;

- Subyearling chinook usually the progeny of “summer” run chinook on the mid-Columbia River; and
- Steelhead.

Stocks are identified by their species, spawning stream, and season. The number of fish released at each siteis
identified on adaily basis. Each release group has aunique set of passage parameters and corresponding model
results are tabulated separately.

Note. Wild and hatchery migrants do not necessarily need to be defined as separate stocks if
separate tracking is not desired, but definition as separate stocks is required if you assign them
different parameter values (e.g. different vulnerability to predation, swimming behavior, etc.). If
you want to keep track of different stocks as different releases with the same parameters, CRiSP.1
tracks each release separately in both Monte Carlo Mode and Scenario Mode.

Passage Algorithms

CRiSP.1 caculatesarrival of al fish on each day to each river segment (a section of river between confluences,
dams, or headwaters) before calculating passage of fish to the next downstream segment. With this set of arrival
information, it is possible to assign rules for fish transportation based on a percentage of the total run that will
arrive at a dam. Thus, CRiSP.1 moves fish downstream a segment at a time, adding smolts coming from
tributaries or hatcheries on a daily basis. The number of fish leaving ariver segment on any given day depends
on:

- the number arriving on the same and previous days,
- water flow rate in kcfs (1,000 cubic feet per second), and
- mortality factors related to predation and gas bubble disease.

Dam operations control important variables of CRiSP.1. Thethree major variables are daily total flows, spills,
and fish transportation.

Dam passage survival depends on the pathway fish takethrough adam. At all dams, fish arriving at the forebay
can pass over the spillway or through the powerhouse. The fraction of fish entering the spillway depends on:

- percentage of total flow spilled,
- spill efficiency at the dam, and
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- timing of the spill period.

Fish entering the powerhouse can pass through the turbines or be guided by traveling screens. The propensity
of apopulation to be guided isrepresented by afish guidance efficiency (fge) which can be set constant or varied
over aseason for each project and population. (See FGE and FGE Equation sections for more details.) Mortality
depends on the pathway chosen which accrues for spillway passage, collection, and turbine passage. Dam
activities are calculated on a six hour basis and summed over a day to provide a daily fish input to the next
reservoir.

Bypassed fish at specified dams may be transported in barges or trucks to any point in the river downstream
of the collection site. Bypassed fish not transported are released into the tailrace. CRiSP.1 removes transported
fish at adam, computes a mortality, and releases fish at the transportation site at alater time as determined by a
transportation velocity. Whether collected fish are transported depends on rules developed to simulate actua
transportation decisions. Transportation factors are set with the Transport Tool and include:

- numbers of fish collected,

- afraction of the total run of aspecies passing a project,
- fish arrival on a given Julian Day,

- transport onset set by number of fish or Julian Day,

- transport termination set by number of fish passing within a specified number of days or by Julian
Day, and

- separator operation determined by flow and fraction of run passing a project.

Survival and Migration

Survival and migration of fish in CRiSP.1 can be modeled in two modes: Scenario Mode and Monte Carlo
Mode.

Scenario Mode runs one year with as many releases as desired. It can be used to gain insight on the effects of
changes in system parameters on the survival and migration of fish during a single water year. In this mode,
natural unregulated inflows are specified. These flow into the mainstem rivers and storage reservoirs at
headwaters. System operation and fish biological parameters can be varied stochastically according to user
specifications.

Monte Carlo Mode runs CRiSP.1 with as many releases as desired for one or more combinations of water year
and system operations. The main variable changed in each run is river flow. Flows are specified at the project
(dam), not headwaters. In each run, a different flow regime and other model parameters are used. Fish survival
is determined for each run and the distribution of survivalsfrom all runs provides an estimate of the probability
distribution of survival under the specified conditions. Flow is generated from runs of the hydroregulation
models maintained by the Army Corps of Engineers (HY SSR) and the BPA (HYDROSIM). The
hydroregulation models use historical water data and a projection of electrical demand to simulate system
flows, which are designated f | ow. ar chi ve files. These files give period-averaged flows at operating projects
which are modulated by CRIiSP.1 to represent daily flows. CRiSP.1 uses the modulated flows along with yearly
input data files describing the system operations and fish biological parameters to produce histograms of
survival.
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Interaction of hydroregulation model and CRiSP.1 in Monte Carlo Mode

CRISP.1 Submodels

CRIiSP.1 integrates a number of submodels that describe interactions of isolated components. Together they
represent the complete model. These elements include submodels for: fish travel time, reservoir mortality, dam
passage, total dissolved gas supersaturation, and flow/vel ocity relationship. The structure of CRiSP.1 allowsyou
to select different formulations of these submodels at run time. In this sense, CRiSP.1 can be configured for
simple interactions or it can be set up to consider many ecologica interactions. CRiSP.1, as it is presently
calibrated, has an intermediate level of complexity: age dependent travel time is implemented, but other age
dependent factors are switched off. A brief description of submodels follows.

Travel Time

The smolt migration submaodel, which moves and spreads rel eases of fish down river, incorporates flow, river
geometry, fish age and date of release. The arrival of fish at a given point in the river is expressed through a
probability distribution. All travel time factors can be applied or they can be switched off individually, resulting
in asimplified migration model.

The underlying fish migration theory was developed from ecological principles. Each fish stock travels at a
particular velocity relative to the water velocity. The relative velocity can be set to vary with fish age. In
addition, within a single release, fish spread as they move down theriver.
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Predation Rate

The predation rate submodel distinguishes mortality inthe reservoir, and the forebay and tailrace of dams. The
rate of predation can depend on temperature, diel distribution of light, smolt age, predator density, and reservoir
elevation.

Gas Bubble Disease

CRIiSP.1 incorporates a separate component of mortality due to gas bubble disease which is produced by total
dissolved gas supersaturation. The mortality rate is species specific and is adjusted to reflect the effect of fish
length and population depth distribution.

Dam Passage

Timing of fish passage at dams is developed in terms of a species dependent distribution factor and the
distribution of fish in the forebay, which can change with daily and seasonal light levels. Fish guidance
efficiency can be held constant over a season or it can vary with fish age and reservoir level.

Transportation Passage

Transportation of fish at collection dams is in accordance with the methods implemented by the U.S. Army
Corps of Engineers. The start and termination of transportation and separation of fish according to species can
be determined for any dam under the same rules used to manage the transportation program. Time in
transportation and transportation mortality can also be set.

Total Dissolved Gas Supersaturation

Total dissolved gas supersaturation, resulting from spill at dams, can be described with a mechanistic
submodel that includes information on the geometry of the spill bay and physics of gas entrainment.
Alternatively, supersaturation can be described by empirical models.

Flow

Flow ismodeled in two ways: it can be specified at dams using results of system hydroregulation models or it
can be described in terms of daily flows at system headwaters. When flow is described in headwater streams,
the flow submodel generates a random set of seasonal flows that have statistical properties in accordance with
the available water over ayear. In thisfashion, the model statistically reproduces flow for wet, average and dry
years. The user controls the mainstem river flows by adjusting the outflow of the storage reservoirs within their
volume constraints.

Water Velocity

Water velocity isused in CRiSP.1 as one of the elements defining fish migration. Velocity is determined from
flow, reservoir geometry and reservoir elevation.

Reservoir Drawdown

Reservoir elevationis set on adaily basis from elevation information in the system hydroregulation models or
from user specified files. As water levels drop, part of the reservoir may become afree-flowing stream.

Stochastic Processes

CRIiSP.1 can be run in a Monte Carlo Mode in which flows and model parameters vary within prescribed
limits. In this mode, survival to any point in the river can be determined as a probability distribution.
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Geographical Extent

CRIiSP.1 can describe ariver to any desired level of detail by changing asingle file containing the latitude and
longitude of river segments, dams and rel ease sites. In its present configuration, threeriver description files are
available. One file contains an abbreviated river map with the major tributaries and about thirty representative
rel ease sites, although more can be added easily. The two other river description files contain drawdown
aternatives. See the River Description File section for more information.

Calibration Issues

The CRiSP.1 submodels are individually calibrated. Thus CRiSP.1 was not directly calibrated from mark-
recapture survival studies. Instead, such studies provided a check on the calibrations of the individual
mechanisms of the model (model validation). Notes on the submodel calibrations are detailed below.

Travel Time

The travel time submodel was calibrated for subyearling chinook, yearling chinook, and steelhead using
tagging data from the entire river system and over the entire migration season. Two separate calibration
processes were applied: one to measure the spread of fish as they moved through the reservoir, and the other to
measure the change in relative migration velocity with fish age. Thefirst used marked, individual stock releases
over a short period of time, and the second used marked and recaptured fish over entire seasons.

Predation Rate

Predator-prey interactions in CRiSP.1 were calibrated with information from predation studies in John Day
Reservoir and information on predator densities for each of the major reservoirs.

Gas Bubble Disease

The rate of mortality due to gas bubble trauma was calibrated from dose-response studies conducted in both
field and laboratory conditions.

Dam Passage

Diel passage elements of CRiSP.1 were calibrated from hydroacoustic and radio-tagging studies at dams. Fish
guidance efficiency and spill efficiency were calibrated from a number of studies at a variety of dams. Fish
guidance efficiency can be set to change with fish age and reservoir level or it can be set constant over the year.
Mortalities in dam passage were determined from mark-recapture studies at dams.

Transportation Passage

Separation of large and small fish in transportation was applied from general information on the efficiency of
the separators in the transportation facilities at dams. A transportation mortality was determined for each
species, based on transport-benefit studies. In addition, time to transport fish through the river system was
specified.

Total Dissolved Gas Supersaturation

Total dissolved gas supersaturation models were calibrated with data from the Army Corps and includes
information collected in the 1992 drawdown study in Lower Granite and Little Goose reservoirs, as well as
monitoring data from recent aggressive spill programs.
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Fl

Headwater flows in Scenario Mode were calibrated from information on stream flows provided by the U.S.
Geological Survey. In Monte Carlo Mode, the modulators of the period average hydroregulation model flows
were calibrated against historical daily flow records at dams.

Water Velocity

Water velocity requires information on reservoir and geometry. The relationship between geometry and
elevation and free stream vel ocities were determined from Lower Granite Reservoir drawdown studies.

Stochastic Processes

The ranges for variables used in the Monte Carlo Mode have been calibrated to available data in the above
mentioned studies.
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Getting Started

The cross-platform Help providesinstructions for using ColumbiaRiver Salmon Passage model (CRiSP.1) on
both Unix and Windows 95/NT operating systems. Any differences in the commands used or the operation of
CRIi SP.1 between the operating systemsare noted in the text. Help is designed to meet the needs of awide variety
of users, from a novice user of Solaris2.X or Windows 95/NT operating systems to programmers familiar with
the C++ language in which the CRiSP.1 model was written.

| nstallation

CRIiSP.1 is designed to run on a Sun SPARC workstation running Solaris2.X or on a personal computer
running Windows 95/NT operating systems. CRiSP.1 should run as expected on Windows 98, 2000, ME and
XP. Thefirst stepistoinstall the model on your computer.

- Internet Access and Communication
- Windows 95/NT Installation

- Unix Installation

- Required Files

I nter net Access and Communication

CRIi SP Passage information and files are available to users via the World Wide Web (web). Questions about
CRIiSP.1 can be sent to the CRi SP Passage email address listed below.

- CRIiSP Passage web page:

http://ww. cbr.washi ngton. edu/ crisp/crisp.html
- CRIiSP Passage e-mail:

cri sp- passage@br . washi ngt on. edu

Windows 95/NT Installation

Minimum System Requirements

- Windows 95 or Windows NT 4.0 or later
- 486/66 Mhz

- 16 MB of RAM

- 40 MB available hard disk space to install

Download and | nstall

1) Download the current version of CRiSP.1 (Win32) from the Columbia Basin Research web site
(http://www.cbr.washington.edu/crisp/crisp.html). With a 28.8 modem, downloading the model takes
approximately 30 minutes.

2) Save to the directory of your choice when downloading.

3) Double click on the self-extracting filecri sp1. exe icon or launchcri spl. exe from aRun dialog
box.
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4) A "WinZip Self-Extractor” dialog box will open. Select a destination directory for the install
directory (Install) and subdirectories (Disk1 - Disk5).

5) Click Unzip to start the extracting process.

Note. You can leave the check mark on "Overwrite Files Without Prompting" to shorten the upgrade
process.

6) When the extracting process finishes, click OK.

7) Click Close to quit the "WinZip Self-Extractor” dialog box.

8) Change to the specified unzip destination directory.

9) Open the Install\Disk1 directory and double-click on the set up. exe icon.
10) Follow the on-screen instructions.

11) When you have finished installing CRiSP Passage, you can delete the Install directory and the self-
extracting filecri spl. exe.

Unix Installation

Minimum System Requirements

. Solaris2.X with graphical interface
- 45 MB available hard disk space to install

Download and | nstall

1) Download the current version of CRiSP.1 (Unix) from the Columbia Basin Research web site (http://
www.cbr.washington.edu/crisp/crisp.html). The tar file includes all help files, sample data files, and
executable files.

2) Save to the directory of your choice when downloading.

3) To extract the files, copy the tar fileinto your desired installation directory and type the following
commands:

gunzip rl.6.tar.gz
tar -xf rl.6.tar

4) Thiswill create the directory “r1.6” containing all the data files and executable files.
5) When you have finished installing CRiSP Passage, you can delete the rl.6.tar file.

Required Files
There are four files required to run CRiSP.1 in both Scenario and Monte Carlo modes:

- col unbi a. desc - definesthe river segments, locations of dams, and rel ease sites
. crispl. exe - CRiSP.1 executable code
- base. dat - adatabase file that can be read into CRiSP.1

- fl ow. archi ve - A file of flows, spills and reservoir elevations (elevations are given in HY SSR files)
initially generated from a hydroregulation model such as SAM, HY SSR or HY DROSIM. Outputs of
these models are converted to CRiSP.1 compatible flow files using a preprocessor.

In the simplest file arrangement, al files are placed in the same folder (or directory). For example, the
configuration below shows these files contained within the folder named CRi SP Passage. By default, output
files are written to the directory from which CRiSP.1 was executed (the CRiSP.1 “home directory”). On
Windows 95/NT operating systems, thisisthe source directory for cri spl. exe. When saving filesto theloca
system, you can override the default directory to specify any output directory. On the Unix system, the files can
bewritten out to any directory for which the you have write permissions. For more information about these files
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and other input and output files, see the CRiSP.1 Files section.

File Edit “iew Help

I ame | Size | Type |
0 flow data ; File Folder
5] yearly. data File Folder
baze.dat 187KB  DAT File

base. sample.ls 4B RLS File
colurmbia. desc 120EE  DESC File
columbia_drawdown, desc 114KE  DESC File
columbia_snakedraw. desc 114KE  DESC File
E Crizpl.exe 2.272KB  Application
crispl.zhp J3BKE  ZHP File
E crisplbexe HEE  Application

Flow. archive 324KB  ARCHIVE File
Feadme 17KE  File

THECOR'Y . pdf 1,960KE  Adobe Acrobat...
Urirngt.isu 18KB 15U File
wiz_ftp.log 1B LOG File

@' zhelp.exe 415KE  Application

Windows 95/NT installation of CRiSP.1

Starting CRiSP.1

- Starting from the Desktop (Windows 95/NT)
- Starting from the Command Prompt
- Running in Batch Mode

Starting from the Desktop (Windows 95/NT)

There are several ways to start CRiSP.1 using the graphical interface from your Desktop.

. . . Cc1
. Double-click the CRiSP.1 icon 2

OR
- Click the Start button, point to Programs, and click CRiSP Passage.
OR
- Click the Start button, point to Run, and click Browse to find and open CRiSP.1 on your computer.

Wait for the CRiSP.1 Graphical User Interface and River Map to appear. Basic information about CRiSP.1,
model parameters, and running CRiSP.1 are covered in later sections.
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Starting from the Command Prompt

To start CRiSP.1 from a command prompt, the model must be in the current directory (or, on Unix only, in the
path). At acommand prompt, type a command with the following syntax:

crispl [-I{wnrd}] [-bsmi] [-r river_desc] [-f data_file] [-0 output _file]
[-c output_control _file] [-u]

The arguments delimited by “[ ]" are al optiona and can be given in any order. If an argument is not present,
the default valueis used.

- -1 {wnr d} controlsthe logging level. Five separate classes of logging messages are defined: Errors
which are always logged, Warnings, M essages, Raw output, and Debug output. By default, Warnings
are logged and the others are not. If - | is given, then the default isignored and the characters which
follow define what is logged. For example - | wmcauses Warnings and M essages to be logged, - |
causes nothing (except Errors) to belogged, - | d causes only Debug output to be logged, and - | r
causes Raw output to be logged.

- -bsmi controlsthe running mode. b selects Batch Mode (the default is Graphical User Interface
mode). s selects Scenario Mode. mselects Monte Carlo Mode (which isthe default in Batch Mode). i
selects Reatime Mode. The letters can be combined in various ways and not al need to be included. -
bsi would select Batch Realtime Scenario Mode. - b selects Batch Monte Carlo Mode (since Monte
Carlo Modeisthe default for Batch Mode). Batch Monte Carlo M ode runs depend on the existence of
a.crisp-al ts filewhich specifieswhich aternatives to run.

Note. Please see the Running in Batch Mode section for special instructions on running CRiSP.1in
batch mode.

Note. Realtime Mode is only active in batch mode, not through the GUI. In either Scenario or Monte
Carlo mode, the model default isto run with ayearly datafiler eal ti me. dat unless an aternate
yearly datafileisindicated with the - f flag. Running in Realtime Mode will create ar eal ti ne
subdirectory with several default files, of particular interestisr eal ti me. r eal filewhichisthe
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output file. For Realtime Monte Carlo mode runs, aflow file named f | ow. ar chi ve must residein
the run directory. In Realtime Monte Carlo Mode, the model does not depend onthe. cri sp-alts
file to determine which alternative and which files to use.

- -1 river_desc specifiesthe name of the river description file. The default fileis col unbi a. desc.
. -f data_fil e specifies the name of the yearly datafile. The default fileisbase. dat .

- -0 out put_fil e specifies the name of the parameter datafile to output at the end of a batch run.
This option can only be used in conjunction with the - b argument. Only one - o option is allowed for
any given batch run. The extension of the output filename determines what parameter data used
during the model run will be written to the file. See the Model Parameter Data Files section for further
details. For example,

- nane. dat writesout a parameter datafile with al information in it
- nane. r | s writes out a parameter datafile with only the release information

- nane. ctrl writesout acontrol filewith “include” directives and the 8 parameter data subset
files which contain the whol e database between them.

- -c output_control _fil e givesthe name of the parameter data configuration file to be used for
the entire batch run. This option can only be used in conjunction with the - b argument. Either afile of
type. dat or. cnf may be specified. If thisoption is given, the program as it starts up first reads
col unbi a. desc, then it reads the "output_control_file" and turns on the Lock Output Settings
feature, then it reads the yearly input data file (ignoring any output settings contained therein), and
then it runs the model in batch mode, as specified by the other command line arguments. This option
isintended to facilitate control of data output in batch mode processing.

- -u indicatesthat asunmary. al t # file should be written for each alternative run, exactly asif the
"Write Supplemental Data" check box had been checked in the GUI Monte Carlo window. Data
written to the file is based on the output settings in the yearly input data file(s) specified in each
aternative. This option can only be used in conjunction with the - b{mi } argument.

Example commands that open the CRiSP.1 Graphical User Interface

crispl
crispl -Ilmwv -r col unbi a_drawdown. desc -f new. dat
crispl -f test. dat

Example commands that run CRiSP.1 in batch mode

crispl -b -0 batch.ctrl

crispl -b -c batch. dat

crispl -bsi -f realtime.alt. dat
crispl -b -u

Running in Batch Mode

The CRIiSP Passage model can be executed in batch mode for either Monte Carlo or Scenario runs. See the
Starting from the Command Prompt section for command options. The following are special instructions on
running in batch mode for both Unix and Windows 95/NT operating systems.

Unix

On the Unix system, batch mode runs can be executed from the command prompt using any of the options
detailed in the Starting from the Command Prompt section. There are afew specia considerations for running
CRiSP.1 in batch mode on Unix systems. The CRiSP.1 Unix distribution includes the program cri splbat,
which isthe simulation engine of CRiSP.1 without the graphical user interface. Using this program, you can run
CRIiSP.1 in batch mode without having to set the DISPLAY environment variable. Thismakesit possible to run
the CRiSP.1 model in batch mode from a dial-up connection or from a detached process, i.e. left running after
logging off the workstation. The cri splbat program uses the same command prompt argumentsascri spi,
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except that the - b is assumed.

Example commands

crisplbat -o batch.ctrl
crisplbat -c batch. dat
crisplbat -u

Windows 95/NT

There are afew special considerations for running CRiSP.1 in batch (non-graphics) mode on Windows 95/NT
systems. These derive from the architecture of Windows 95 and Windows NT, which make sharp distinctions
between MS-DOS-based programs and Windows-based programs.

If you are running CRiSP.1 from the MS-DOS prompt, you have two choices: 1) redirect the program’s
standard and error output streamsto text files or 2) have standard and error output streamswrite to the MS-DOS
shell.

Example command to redirect the output streams to text files
crispl -bs -f base.dat >output.txt 2>error.txt

Example command to redirect both of the output streams to the same file
crispl -bs -f base.dat 1>output.txt 2>&1

To let the batch mode program’s output streams write to the MS-DOS shell, you must use a second program
calledcri splb that runscri spl in batch mode and isequivalenttocri spl -b.

crisplb -s -f base. dat

For this to work properly, thefilescri spl. exe and cri splb. exe must residein the same directory.

Warning. It would be amistake to run the cr i sp1b program and then redirect its standard output
streams.

CRISP.1 Files

- River Description File (col unbi a. desc)
- Yearly Input Data File (base. dat)
- Flow Archive File (f | ow. ar chi ve)
- Output Files and Directories
- Model Parameter Data Files
- Control File
- Reading Datainto CRiSP1

River Description File: col unbi a. desc

The River Description File (col unbi a. desc) contains all the information necessary to define the physical
river system from the ocean to the various headwaters. This includes latitudes and longitudes of all possible
release sites, dams, and river segments as well as many of the physical parameters of these features. All menus
and input and output tools automatically configure from the information in this file. See the Technical Details
section on the River Description File Structure for details on file structure, rules of construction, and parameter
definitions. The Parameter Glossary contains definitions of the parameters and tokens found in thisfile.
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Thecol unbi a. desc fileisan ASCII file that you can edit and contains the following information:

- hames of species

- names and locations of release sites on the river

- nhames of dams, positions on the river and basic dimensions

- names of river segments, latitude, longitude, widths and depths.

Thedefault col unbi a. desc file containsan abbreviated description of the ColumbiaBasin river system with
about thirty fish release points and major dams. Some riversin the basin are not represented in this map (for
example, Imnaha River or Grande Ronde River).

Additional River Description Files are also available in the CRiSP.1 distribution. They have been modified
to reflect changes in the river that could occur under certain proposed management actions. The file
col unbi a_snakedr aw. desc does not have any of the Snake River damsin it. This smulates a Snake River
drawdown in order to make the Snake River free-flowing. It has four dams removed that are in the default
col unmbi a. desc file: Lower Granite, Little Goose, Lower Monumental, and Ice Harbor dams. The file
col unbi a_dr awdown. desc issimilartocol unbi a_snakedr aw. desc. In addition to the removal of the four
Snake River dams, it also has the John Day dam removed. This represents the most drawdown being considered.
Five dams are removed that are in the default col unbi a. desc file. A River Description File can only be read
when CRiSP.1 isinitidly started. In order to use one of the adternative files, you must start CRiSP.1 from a
command prompt with the - r flag. See the Starting from the Command Prompt section for more information.
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Yearly Input Data File: base. dat

The Yearly Input Data File (base. dat ) contains all model parameter data for a single year run. If no other
yearly input datafileis specified when CRiSP.1 is started, the model will initially read the file base. dat . The
CRIiSP.1 Graphical User Interface menus are used to create and modify the parameter datafor arun or for storage
in data files. The data can be saved as either asingle file or as a group of parameter data files corresponding to
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predefined data groupings. These files can be read into the model individually or in agroup prior to arun. See
the Reading Data into CRiSP.1 section for further details. A file containing all model parameter data is
designated . dat and isreferred to asayearly input datafile.

Parameter Data File Name Extensions

- dat - al model parameter data

- beh - parameters related to fish travel time and mortality

- res - predator density in reservoirs

- spill -gpill schedulesat al dams

- f1 ow- headwater flows, losses, elevations, storage reservoirs
- dam- all parameters related to dam operation

- rl s - al parameters describing fish rel eases

- river - headwater temperature and river parameters

- cnf - runtime settings and output settings

The Model Parameter Data Files section discusses the dataand file name extensionsin further detail. A yearly
input data file containing all the data used in CRiSP.1 may be over 1M in size, depending on the number of
releases and tributaries defined in the river. Typica data files are about 200K in size. See Technical Details
section on the Y early Input Data File Structure for details on file structure, rules of construction, and parameter
definitions. The Parameter Glossary contains definitions of the parameters and tokens found in thisfile.

Model Parameter Data Files

CRIiSP.1 contains eight predefined model parameter data file name extensions. The model parameter datafiles
are subsets of the datain CRiSP.1. All datain CRiSP.1 can be contained in these eight parameter data file types.
All eight files combined would contain the same information asaY early Input DataFile (. dat ). By using Save
As and a predefined extension, specific model parameter data groupings can be saved to afile for future use. In
a similar manner, specific model parameter data groupings can be read into CRiSP.1 by using Open. See the
Reading Data into CRiSP.1 section for further details. All eight parameter data files can be written out
simultaneously using a Control File.

The following is a list of data parameters stored in each file as determined by the file name extension.
Following each extension is a short description and in parentheses is the GUI menu location for editing these
parameters.

- . rls -releaseinformation (Release)
- species and stock
- day of the start of release
- number released each day
- day of the smoltification onset and finish
- smolt length and vitality
- . res -reservoir parameters (Reservoir)
- predator densitiesin reaches
- reach gastheta
- deltawater temperature
- . beh - behavior parameters (Behavior)
- predation coefficient in reach, forebay and tailrace
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- migration variance
- migration equation coefficients
- gas mortality equation parameters
- fish depth equation parameters
- predator temperature response equation parameters
- simple mortality equation parameters
- FLUSH transport figure of merit equation parameters
. . f1 ow- flow parameters (Flow)
- headwater flow
- headwater modulation
- reservoir and reach loss (kcfs) on adaily basis
- reservoir and reach elevation below full pool (ft) on adaily basis
- flow maximum in headwaters (kcfs)
- daily storage reservoir volume and output flow
- reservoir output gas on adaily basis (if desired)
- . dam- dam guidance and mortality factors (Dam)
- transportation parameters
- mortality in dam passage routes
- tdg saturation equation parameters
- predator density in forebay, and tailrace
- predation probability
- separation probability
- day and night fish guidance efficiency
- spill equation parameters
- fge equation parameters
- transportation mortality equation parameters
- powerhouse capacity and schedule
- additional powerhouse information if any
- .spill -spill information at each dam (Dam)
- spill cap
- planned spill schedule information
- .river -river information (Reservoir)
- gas dissipation exponent
- headwater flow proportion
. ufree
- headwater temperature
. . cnf - configinformation (Run)
- runtime settings
- output settings

Control File

A Control File allows you towrite out or read in a set of parameter datafiles. In this manner, subsets of model
parameter data can be replaced while other elements are unchanged. Control files are designated by the
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extension.ctrl.

Control files contain a list of Model Parameter Data Files which are identified in the lines below the Control
File line (see file sample). You can save to disk al eight parameter data files with the same base name as the
Control File by selecting Control Files (*.ctrl) for Save as type (Unix users will need to specify the file name

extension) from File » Save As.

When reading control filesinto CRiSP.1, the parameter data files specified in a Control File can have different
base names. By editing the Control File, you can mix parameter data files from different alternatives and
sessions. Y ou can use any text editor to edit a Control File. Each specific combination of parameter data files

listed in a Control File can be read into CRiSP.1 by selecting the control file you want from File » Open.

Sample Control File with alist parameter data files from different alternatives.

#:::::::::::::::::::::::::::::::::::::::::::::::::::#
# CRi SP Control File CRi SP v1.6.0 (Solaris 2.x)
#

#Witten on Fri Jun 25 11:53:20 1999
#:::::::::::::::::::::::::::::::::::::::::::::::::::#
version 6

ncl ude sessi on. beh
ncl ude sessionl.res
ncl ude sessi on3. spil
ncl ude session. flow
ncl ude sessi on2. dam
ncl ude session.rls
ncl ude sessiond.river
ncl ude sessi on. cnf

Flow ArchiveFile: fl ow. ar chi ve

The Flow Archive File (f1 ow. ar chi ve) contains flow, spill and elevation data generated from
hydroregulation models such as SAM, HY SSR or HY DROSIM. The flow archive file can be used in Monte
Carlo Mode as the source for flow, planned spill, and elevation. Information contained in af | ow. ar chi ve file
includes:

- number of water years (number of gamesin flow archive header),
- number of power years (number of yearsin flow archive header),
- number of dams,

- number of periods within years (i.e. weeks, months),

- spill information,

- reservoir elevation information,

- flow information.

See Technical Details section on the Flow Archive File Structure for details on file structure and parameter
definitions.

Output Filesand Directories

A CRISP.1 run generates and stores various information in output files and directories. Without making any
selections with Output Settings (Run Menu), a model run in either mode generates travel time and survival
information at the Estuary. All other data output must be specified prior to the run in Output Settings or specified
in the datafiles used during the run. The following files and directories result from model runs and are stored in
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the CRiSP.1 home directory.

- summary. dat - Anoutput file that contains results from the most recent run of CRiSP.1 in the
Scenario Mode. Thisincludes for each selected passage point:

- number released

- nhumber passing specified pointsin river system

- nhumber transported

- number censored, i.e. fish remaining in river after tracking time has elapsed (end of the year)

- statistics to lowest point in system including: percent survival; first and last passage days;
average number passing; mean, median, mode, and standard deviation of passage days
between points.

Note. A copy of thisfile can be written to the Message L og window by selecting M essage from the
Logging menu.

- summary. al t # - An output file that contains results from the most recent run of an alternative in
Monte Carlo Modeif the “ Write supplemental data” check box is selected in the Monte Carlo window
or if the- u command line option is used in batch mode. Run resultswritten to thisfile are determined
by the Output Settings specified in the yearly input data files used in each alternative.

. al tern# - A Monte Carlo Alternative directory that contains three output files. The files should only
be modified by using the Monte Carlo tools to make any changes. The files are asfollows:

. al tern#. al t - name of flow archive, names of input files in an alternative, number of games
and years in the archive file, and number of times each archive flow file year is used

- al tern#. ind - internal index file generated by CRiSP.1
- al ter n#. out - output information used in Monte Analysis.

Reading Data into CRiSP.1

By default, data stored in CRiSP.1 is replaced by dataread from afile, if and only if, that data item appearsin
the file. For each appearing dataitem, this is referred to as a "replace” operation. For example, this allows you
to read in new flow information from a . f | ow file without affecting the rest of the data currently stored in
CRiSP.1.

There are three types of data that are exceptions to this rule: spill schedules, transport records, and rel eases.
For these three types of data, a decision is made as to whether to delete existing data prior to reading thefile. In
al cases and all modes, once data reading has begun, multiple specifications of transport, spill, or release data
are merged with each other.

In interactive (GUI) mode, CRiSP.1 performs Replace or Merge operations according to file extension and
user response.

- Replace - The default behavior isto delete all existing data records of type spill schedule, release, and
transport before adata file is read. If subsequent data of the same type appearsin thefile, it is then
effectively areplacement.

- Merge- Under certain circumstances (see following list), existing datafor spill schedule, release, and
transport is retained, and subsequently read data is merged with the pre-existing data.

Depending on the file name extension, Replace or Merge operations are as follows:

. .dat,.ctrl,or unknown
- Delete spill, transport, and releases prior to reading file, and
- replace all data appearingin file.

26 CRiSP.1



« .spill,.spi

- Prompt user whether to “ Reset all spill?” and Replace or M erge new spill depending on user
response,

- merge any transport or release data, and
- replace all other data appearing in file.
. .dam

- Prompt user whether to “ Reset all dams?’ and Replace or M er ge new transports depending on
user response,

- merge any spill or release data, and
- replace all other data appearing in file.
«.rls

- Prompt user whether to “ Reset dl releases?’ and Replace or M er ge new releases depending on
user response,

- merge any transport or spill data, and
- replace all other data appearing in file.
« .beh,.res,.flo,.flow,.riv,.river,.cnf
- Merge any transport, spill, or release data, and
- replace all other data appearing in file.

Fileswhich are"included" from other filesare not subject to the above determinations (see the CRi SP.1 Parser
section for information on file includes). Only the top-level file to be read (not included) will have its extension
examined. The above list then holds for al dataread from that file or from any file subsequently “included.”

In batch mode runs, a replace operation is aways performed. All spill, transport, and release data are first
deleted, and then replaced with data appearing in the file. All other data appearing in the file is replaced as per
the standard default. Note that in batch mode, since the pre-existing data consists of hard-coded defaults which
may be questionable, it is advisable to make sure that files used in batch mode runs provide full coverage for all
parameters.

Standard CRiSP.1 Features

Interactive operation of CRiSP.1 isthrough agraphica user interface (GUI) using atwo-button or three-button
mouse. CRiSP.1 standard features and tools are detailed in the following sections.

- Standard Window Features

- Menus and Submenus

- Help Tools

- Two Level Editing and Display
- Slider Input

- Editable Graph

- Schedule Tool

- Julian Day Output

- Equation Input
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Standard Window Features

CRIiSP.1 uses standard window features found on Windows 95/NT and Unix systems for opening, closing,
resizing, and shrinking windows to an icon. If you have questions, please refer to your operating system and
software documentation.

The following are definitions of mouse operations as used in this documentation.

- Click: clicking the left mouse button when the mouse pointer (pointer) is on an element of CRiSP.1.
- Right-click: clicking the right mouse button when the pointer is on an element of CRiSP.1.

- Drag: clicking, holding down the mouse button, moving the mouse, and then releasing the mouse
button on an element of CRiSP.1.

M enus and Submenus

Both the mouse and the keyboard can be used to open and select from the menus and submenus found in
CRiSP.1.

Using the mouse, you can open windows from menus and submenus.

- Click the menu, point to a selection, and click the desired option.
OR
- Click the menu and drag the pointer to desired selection in submenu.

Using the keyboard, you can open windows from menus and submenus.

- Press ALT+ the underlined letter key to open a menu and press the underlined letter key to make a
selection or open a submenu.

OR

- Press ALT+ the underlined letter key to open a menu, press the keyboard arrow keys to navigate
within amenu, and press ENTER to open the selected menu item.

Help Tools

Open context-sensitive help information by clicking =~ Help | or ll in a window. The context-sensitive
help and additiona information is accessible from Help in the Main Panel.

Two Level Editing and Display: Reset All, Apply All, Reset, Apply, Cancel, OK

Throughout the model, CRiSP.1 uses the concept of two level editing and display. The data being displayed

on the screen may be different from the datain the underlying database. A red dot @ in each corner of awindow
indicates that the data being displayed is different from the data currently stored in the model and that changes
have not been applied to the underlying database, yet. For changes to take effect, click Apply or Apply All.
M odifications that have not been applied can be discarded by clicking Reset or Reset All.

Note. For example, if you open windows for al three damsfor Flows / Reservoirs and modify the
Outflow at each dam, you can apply the changes in two ways. If you click Apply in the Chief
Joseph Dam Outflow window, that will only save the changes made to Chief Joseph Dam Outflow.
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If you click Apply All in any of the three dam Outflow windows, that will save changes made to
Ouitflow at all three dams.

All input windowsin CRiSP.1 contain all or acombination of the Standard Commands.

- Reset All: Discard all changes and revert back to the last saved changes for the data set.

- Apply All: Saves dl changes made to the same data parameter set.

- Reset: Discard only changes made to the currently displayed parameter data in a particular window.

- Apply: Savesonly the changes made to the currently displayed parameter datain a particular window.
- Cancel: Restores all valuesto last saved and closes window.

- OK: Applies all changes and closes window.

Powerhouse Schedule [ ] Powerhouse Schedule 1]
* *
Powerhouse Schedule Powerhouse Schedule
IBUnneviIIE Dam E Start Day IBunnEvi\Is Dam B Start Day
ID ID
Stop Day Stop Day
] |385
Start Hour Start Hour
ID ID
Hour List Stop Hour Hour List Stop Hour
|24 |3
e T
Day List ¥ On Dap List ¥ On

Heln | FResstan | apohat | Reset | apph | Cancel [£7HE Help | Resetal | apppatl | Reset | apply | Caneel | ok |
*

Powerhouse Schedule window (default) and before applying changes

In general, any number of windows of the same type can be active at the same time - just select the same menu
item several timesto create several copies of the same type of window. For input windows (dialogs and editable
graphs), it is possible to have multiple windows displaying the same data at the same time. If the datais changed
in one window, the others will update automatically to reflect the changes.

Yellow dots  will be displayed in the corners of all output graph windows when any input data has been
changed, but the model has not been re-run to create new outputs. Y ellow dots do not imply correlation between
the data displayed in the output window and the changes to model input.

To demonstrate this, run the program in Scenario Mode, and the open a Passage graph for the Estuary and
the Vvar window. After you click Apply in the VVvar window, the passage graph will display yellow dots. VVar
has changed, but passage has not been recalculated. Now run the model again. Passage is now up to date with
respect to model inputs, so the yellow dots disappear. Please take note that yellow dots would aso appear on a
TDG Saturation output graph, even though VVar does not influence total dissolved gas.
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Passage for Estuary
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0.00 I I . I I I I
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total passage 1672280 = 38%
. Fish leaving [per day]

Yellow Dots in Passage for Estuary window

Slider Input

Slider Input windows are one type of data input windows found in CRiSP.1. Red dliders represent parameter
settings and are changed using the mouse or the keyboard as described in the following sections. CRiSP.1
variables that incorporate sliders include:

- Unregulated Headwater Flow Max

- Predation Coefficients in Reach, Tailrace, Forebay
- Velocity Variance Parameters

- Powerhouse Spill Thresholds

- Predation Probability

- Mortality

- FGE

- River Parameters.

As shown below, there are several formats for Slider Input windows. The Unregulated Headwater Flow
Maximum window is an example of the Slider Input window in its simplest form. The Migration Rate Variance
window containsa“tab” list wherethe list of variablesislonger than alowed for one screen (ten variables) and
isaccessible by clicking on thetabs (Iabeled A, B, etc.) at the top of the window. Also illustrated in this window
is the concept of setting Mean, Low and High values for each variable. The Dam Predation Probability window
illustrates a Slider Input window containing time-specific, dam-specific and species-specific settings.
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Various Slider Input windows

Slider Input Window Features

- Edit Single Slider Vdue

- Edit Multiple Slider Values Simultaneously
- Edit All Slider Vaues Simultaneously

- Slider Input Additional Features

Edit Single Slider Value
There are three waysto edit the value of an individual slider.

- Move the pointer to the slider (1) and drag the slider to adjust the value.
OR

- Click on either side of the current value of adlider to “jump” the slider value to the point clicked.
OR

- Right-click on desired dlider to open the Slider Value dialog box (2), type avalue in the text box, and

click OK to update the display in the Slider Input window. The values displayed above the text box in
the Slider Value dialog are the minimum and maximum values allowed for that particular parameter.

All changes made to slider values need to be applied by clicking Apply / Apply All / OK beforethe valueswill
take effect.
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Slider Input window and Slider Value dia og box

Some Slider Input windows contain a tab list (variable list is longer than ten items), click on aletter tab to
access a portion of the list and edit the desired dlider as directed above. Some Slider Input windows contain
Mean, Low, and High value sliders which are separate entities and are edited separately.

There are several Slider Input windows which involve setting time-specific, dam-specific and species-specific
values for each dlider.

- Predation Probability (time, dam, and species)
- Mortality (dam and species)
- FGE (dam and species)

Parameter values can be set individually for each species at each dam by sel ecting the desired species from the
species menu, selecting the desired dam from the dam menu, and then following the directions above. If you
make multiple changes to dam and species parameter settings, click Apply All to save all the changes made.
Parameters can be grouped across Time (T), Dam (D) and Species (S) by selecting the appropriate check boxes
to the right of the slider. See the Edit Multiple Slider Values Simultaneously and Edit All Slider Vaues
Simultaneously sections for directions.

Dam Predation Probability |- =] =]

IBonneviIIe Cram 'I

1T b [ s

Gl 20 NN
18:00-24:00 ’ﬁ T o s

Help | Reset Al | Apply Al | He&etl Apply | Eancell Ok |

Dam Predation Probability window.
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Edit Multiple Slider Values Simultaneously

Editing multiple slider values simultaneously uses the “group” concept. For the majority of Slider Input
windows, there is only one column of check boxes on the right side of the slider labeled G. There are several
Slider Input windows in CRiSP.1 which involve setting time-specific, dam-specific and species-specific values.
These Slider Input windows have check box columnslabeled T (time), D (dam) and S (species). For Slider Input
windows containing sliders for mean, low and high values, sliders are grouped for mean, low or high values

separately.
1) Click the corresponding check box on right side of slider window (1) for each parameter in the group,

2) Movethe pointer to any slider in the group, and
3) Follow the directions to Edit Single Slider Value.

All changes made to slider values need to be applied by clicking Apply / Apply All / OK beforethe valueswill
take effect.

river parameters [ _ (=] =]
[ G
river params
nas dissp exp [F107-4 cm”™2/sec) |_DQDD ¥l
Ufree (ks *107-1)

o045
[ C. 100 v &

Help | Feszet | Apply | Eancell ] |

fark threzhaold

Multiple sliders grouped

Edit All Slider Values Simultaneously

Editing al dider values simultaneously uses the “group” concept. For the magjority of Slider Input windows,
there is only one column of check boxes on the right side of the slider labeled G. For Slider Input windows
containing sliders for mean, low and high values, sliders are grouped for mean, low or high values separately.
There are several Slider Input windows in CRiSP.1 which involve setting time-specific, dam-specific and
species-specific values. These Slider Input windows have check box columns labeled T (time), D (dam) and S

(species).

1) Click the top check box (G, T, D or S) on right side of slider window (1),
2) Movethe pointer to any slider in the group, and
3) Follow the directions to Edit Single Slider Value.

All changes made to slider values need to be applied by clicking Apply / Apply All / OK beforethe valueswill
take effect.
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Slider Input Additional Features

- Help: Opens context-sensitive help information.

- Reset: Restores valuesto last saved values of that specific set of data.
- Apply: Saves changes to the specific set of data.

- Cancel: Restores all valuesto last saved and closes window.

- OK: Applies al changes and closes window.

Slider Input windows that involve setting time-specific, dam-specific and species-specific va ues include the
following features:

- Reset All: Restores all valuesto last saved values for the data set.
- Apply All: Saves dl changes made to the data set.

Editable Graph

Editable Graph windows allows rapid input and visualization of data that varies from day to day. Open
Editable Graph windows by making a selection from a menu. Depending on the settings in the Mouse Toal,
some Editable Graph windows can be opened from the River Map by clicking on a dam, reach or headwater.
CRIiSP.1 variables that can be set with a Editable Graph window include:

- Headwater Temperature

- Headwater Flow

- Reach Flow Loss

- Reach Elevation

- Storage Reservoir Outflow
- Storage Reservoir Volume.

Inall cases, Julian day is given asthe horizontal coordinate (X-axis) with day zero corresponding to December
31. Thevertical axis (Y-axis) is defined below the graph, naming the parameter and its unit of measurement.

Editable Graph Window Features

- Editable Graph Viewing Features
- Editable Graph Input Features
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- Editable Graph Additional Features

Editable Graph Viewing Features

- Read X,Y coordinates and the corresponding calendar date from the display above the graph.
Coordinates actively update as the pointer moves over the graph (1).

. él Actively update the graph display for dam, reach, or headwater as the pointer moves over the
location on the River Map.

- Ymax: Set the maximum value for the Y-axis by typing avalue in the text box.

- Ymin: Set the minimum value for the Y-axis by typing a value in the text box.

. M Fix scale to current settings in order to visually compare graphs.

. ﬁ Increase vertical graph scale. Or right-click in the upper-half of graph (2). This doubles the
vertical scale.

. M Decrease vertical graph scale. Or right-click in lower-half of graph (3). This halves the vertical
scale.

- Bnd Round scale up to next significant number.
. M Display graph with continuous line connecting the data points (default view).

. ﬂ Display the graph with horizontal lines connecting the data points.

- [H| Display the graph as hollow bar chart.

- mall| Display graph as solid bar chart.

. E Group severa graphs together to simultaneously change the scale when using Ymax, Ymin,

Fix. Rnd. AN, or A/,

P water Temperature for Snake Headwater M=l E3

X 63 1 v:11.61 March 4 H|S| 7| =
Ymaxeaso  Ymini[o.00 Fix| AN| Rod| 0[] Gr]

Yater Temperature for Snake Headwater

24.50

12.25

. Water Temperature (C)
Schedulel ResetAIIl Apply All | Resell Apply |Cance||§”6k'"|

Editable Graph window
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Editable Graph I nput Features
There are three waysto edit the values in a Editable Graph window.

- Continuous input by dragging the pointer over graph and drawing a curve.
OR

- Step function input by clicking once, moving mouse to new position, and then click again. This action
will produce a straight line between the two points.

OR

- Keyboard input by clicking Schedule in the lower portion of the window to open a Schedule Tool
window.

- Create anew period: Identify Start Day, End Day and Value over the specified period by typing

in the corresponding text boxes, and then click =« | to update the display list with the
new values and redraw the corresponding graph.

- Modify an existing period: Click on the desired period in the Schedule Tool list to copy the
values into the Start Day, End Day and Vaue text boxes, modify the desired values, and then

click = «= | to update the display list with the new values and redraw the corresponding
graph.

All changes need to be applied by clicking Apply All / Apply / OK for changesto take effect.

Editable Graph Additional Features

. El Opens Save dialog box to save data pointsto atext file.
. @l Opens Print dialog box to print graph to a selected printer.

. il Opens context-sensitive Help for the active graph window variable.
- Reset All, Apply All, Reset, Apply, Cancel, OK.

Schedule Tool: Create a New Period and Modify an Existing Period

Schedule Tool windows allow for keyboard input of data by time periods in days or hours. Schedule Tool
windows occur two ways in CRiSP.1. Every Editable Graph window includes a Schedule button which opens
acompanion Schedule Tool window for editing the data. In addition, CRi SP.1 contains Schedule Tool windows
that exist separately from Editable Graph windows, for example, Powerhouse Schedule (Dam Menu).

Create a New Period

1) Identify Start Day, End Day and Value for the specified period by typing in the corresponding text
boxes, and

2)click = <= | to update the display list with the new values and redraw the corresponding graph.

Y ou can define a period to be asingle day or arange of days. A single value can be applied to arange of days
even if values are aready specified for the days. Use the steps outlined above (create a new period) to create a
new range of days.
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Modify an Existing Period

1) Click on the desired period in the Schedule Tool list to copy the valuesinto the Start Day, End Day
and Value text boxes,

2) modify the desired values, and
3)click ' <= | to update the display list with the new values and redraw the corresponding graph.

Schedule Tool features and functions

- Help: Opens context-sensitive help information.
- Reset All, Apply All, Reset, Apply, Cancel, OK.

i Schedule Tool ME E

' ater Temperature for Snake Headwater Start Day
100-1071: 9.6 ~ [
1024102 91
103103 8.9
104-104: 9 Stop Day
105105; 9.2
106-10; 9.6 — [i11
107-107; 9.5
108-108: 10 Ll
109-109; 10.6 Walue
110-110: 11,3
11111 11.0 [1e
112112121
113113 11.3
114114: 10.2
115115 10.3
116-116: 10.8 -

wiater Temperature [C)

Help Reset Al Apply Al | Reset | Apply |Cancel| DKI

Schedule Tool window

Julian Day Output

Julian Day Output windows allow visualization of data calculated by CRiSP.1. The viewing features are the
same as the Editable Graph; however, the Julian Day Output window has no input features. Open Julian Day
Output windows by making a selection from a menu. Depending on the settings in the Mouse Tool, Julian Day
Output windows can be opened from the River Map by clicking on a dam or reach. CRiSP.1 includes the
following dam and reach specific Julian Day Output windows:

- Reach Temperature

- TDG Saturation

- Flow at Dams

- Flow through Reservoirs
- Spill at Dams

- Fish Passage at Dams

- Fish Passage in Reaches.
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Julian Day Output window

Julian Day Output Window Features

- Julian Day Output Viewing Features
- Julian Day Output Additiona Features

Julian Day Output Viewing Features

- Read X,Y coordinates and the corresponding calendar date from the display above the graph.
Coordinates actively update as the pointer moves over the graph.

. él Actively update the graph display for dam, reach, or headwater as the pointer moves over the
location on the River Map.

- Ymax: Set the maximum value for the Y-axis by typing avalue in the text box.
- Ymin: Set the minimum value for the Y-axis by typing a value in the text box.

. M Fix scale to current settings in order to visually compare graphs.

. ﬁ Increase vertical graph scale. Or right-click in the upper-half of graph. This doubles the vertical
scale.

. M Decrease vertical graph scale. Or right-click in lower-half of graph. This halves the vertical
scale.

- Bnd Round scale up to next significant number.
. M Display graph with continuous line connecting the data points (default view).

. ﬂ Display the graph with horizontal lines connecting the data points.
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- [H| Display the graph as hollow bar chart.

- mall| Display graph as solid bar chart.

. E Group severa graphs together to simultaneously change the scale when using Ymax, Ymin,
Fix . Rnd. AN, or A/,

Julian Day Output Additional Features
- Done | Closes the Julian Day Output window.
. El Opens Save dialog box to save data pointsto atext file.
. @l Opens Print dialog box to print graph to a selected printer.

. il Opens context-sensitive Help for the active graph window variable.

Equation I nput

Equation Input windows alow you to view and edit equation settings and parameters which are, in effect,
submodels of CRiSP.1. The response of the equation to the parameters over the possible range of the
independent variable isillustrated in the equation window as each parameter is changed. Note that for equation
inputs, if you alter an equation and wish to use that altered equation in subsequent model runs you must click
the Apply button to activate it, otherwise the model will revert to the previously-displayed equation and values.

Equation name Independent variable | Dependent variable
migration Julian day migration rate in miles/day
spill % river spill % fish passage with spill
tdg saturation spill in kcfs % tdg sat above 100%

gas mortality % tdg sat above 100% % mortality/day

depth distribution depth (ft) density, % of population/ft
fge fish age fish depth parameters
transportation mortality | water particle travel time | % transportation mortality

39 CRiSP.1



Equation I nput Features
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Equation Input window

Equation Input features and functions

Equation Input windows contain all or a combination of these features and functions.

- Location (1): Identifies the location (dam) to which the equation and parameter values apply.

- Species (2): Identifies the species to which the equation and parameter val ues apply.

- Equation (3): Identifies the active equation from alist of equations. The calibrated equation is the
default selection.

- X, Y Coordinates (4): Displays X, Y Coordinates which actively update as the pointer moves over
graph.

- Graph Title (5): Displays the Equation Input window title in the graph for printing purposes.

.- Y-axis Label (6): Identifies the unit of measurement for the Y-axis. Thisisthe dependent variablein
the equation.

. X-axisLabel (7): Identifies the unit of measurement for the X-axis. Thisis the independent variable
in the equation.

- Equation Curves (8): Displays curve representing the active equation. If there are three curves, the
red line isthe average value and the blue lines are the minimum and maximum val ues.
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- Parameter Sliders(9): Displays the parameter values for the active equation selected in the Equation
menu. Modify the equation parameters with sliders (see Edit Single Slider Value).

- Horizontal Black Line: Indicates that the parameter sliders above the line actually influence the
running model, whereas parameters below the line are only included for visual effect only while
editing. If thereisno line, that meansthat all parameters shown influence the running model.

- Increase vertical graph scale by right-clicking in the upper-half of the graph.
- Decrease vertica graph scale by right-clicking in the lower-half of the graph.
- Help: Opens context-sensitive help information.
- Reset All, Apply All, Reset, Apply, Cancel, OK.

CRIiSP.1 Graphical User Interface

The Graphical User Interface of CRiSP.1 contains the Title Bar, Menu Bar, Toolbar, Status Bar, and River
Map.

B CRiSP v1.6 M= B

File iew FRelease Beservoir Behavior Flow Dam  Paszage Run  Analpsiz Help

3, @3' ﬂl%l @E{g . UnZunlm | il & ll

JReach: Cleamater River |Release: Dworshak |LON: 11667 | LAT: 4666 | 9:02 P

Main Panel of CRiSP.1

- Title Bar (1): Displays the version number of CRiSP Passage.

- Menu Bar (2): Provides access to model variables, datainput and output controls, CRiSP.1 runs, and
toolsfor analyzing results. The Menu Bar contains the following menus which are discussed in
separate sections.

. File
. View
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- Release

- Reservoir

- Behavior

- Flow

- Dam

- Passage

+ Run

- Anadlysis

- Help

- Toolbar (3): Contains buttons for commonly used model functions and features. These items are
discussed in further detail in later sections.

2?, Open/Read a parameter datafile into the model (see Reading Datainto CRiSP.1 for details)

El Save parameter data to afile (see Model Parameter Data Files for details on file types)

‘ﬁl Print Map
ﬁl Display or hide River Map

=t Display or hide Latitude/Longitude (LatLon) Grid

*& | Run model in Scenario M ode
M Cancel arunin either Scenario or Monte Carlo Mode

L3 | Open Mouse Tool to redefine mouse button functions on the River Map
- Status Bar (4): Displaysinformation about the pointer position on the River Map and information
about the running model. From left to right:

- Indicates which Reach, Dam or Headwater is active. This is determined by the position of the
pointer asit is moved across the map. Opening windows with the Mouse Tool is dependent on
which Reach, Dam or Headwater is active in the Status Bar. In addition, it shows the status of
the model as each segment is computed during arun in either Scenario or Monte Carlo mode.

- Indicates which Release Site is active. Thisis determined by the position of the pointer asitis
moved across the map.

- Displays the longitude and latitude coordinates of the pointer asit is moved across the map.
- Displays the current time as determined by the local system.

River Map

The River Map identifies river segments, dams, headwaters, and release sites as determined by the
col unbi a. desc file. The majority of model variables, such asriver flow or fish passage, can be accessed from
any site on the map by positioning the pointer on the location and clicking a mouse button (Mouse Tool settings
determine which windows open). The River Map contains the following features and functions:

== Potential Release Site
- =7 Existing Release Site
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®w Dam, Potential Transport Site
. Existing Transport Site

- To Zoom In: Drag pointer across the map to select or outline an area and rel ease the mouse button (1);
the map will be redrawn to show only this area.

- To Zoom Out: Click on an undefined area of the map (2).

Alternatives. Click  UnZoem | in the Toolbar or select UnZoom from the View menu.

River Map with river segments, dams and release sites

File
The File menu contains general model functions and features.

« Open

. Save As

- Print Map

- Mouse Tool
« Message Log
- Exit

Open

Selecting File » Open opens afile selection dialog box to read data files into the model. You can use this

menu option to open any datafile in the proper format, either manually created or saved from CRiSP.1. Y ou can
revert to all default settings and parameter values for CRiSP.1 by using this menu option to open a Year | y

Input Data File (.dat).In addition, the Open command is represented by E?vl in the Toolbar. Several
parameter datafiles can be read into CRiSP.1 simultaneously by using a Control File.
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Save As

Selecting File » Save As opensafile selection dialog box to save part or all of the current database to asingle
file or to multiple parameter data files. The data files use a file name concatenated with predefined extensions
(described in the Model Parameter Data Files section) identifying the type of data to be written out to that file.
All the parameter information can be written out to separate data files by using a Control File. In addition, the

Save As command is represented by | E| in the Toolbar.

The Save As function allows you to store model parameter changes, i.e. parameter values that have been set
with the various input parameter tools, on disk for reuse. This gives you the flexibility to manipulate and store
al dataused in CRiSP.1 except flow archive data. Each parameter data file can be written separately by naming
the file and choosing from the Save as type selection menu or specifying the appropriate datafile extension (see
Model Parameter Data Files section for further details). Currently, the Save as type selection menu is available
for Windows 95/NT only.

Print Map

Selecting File » Print Map opens a printer control dialog to print the River Map. In addition, the Print Map

command is represented by ‘ﬁl in the Toolbar.

Mouse Tool: Redefining M ouse Functions on River Map

Y ou can define the function of the mouse buttons when used on the River Map by selecting File » Mouse

Tool. In addition, the Mouse Tool command is represented by LI in the Toolbar. Location-specific output
windows can be opened by placing the pointer on the desired location on the River Map and clicking the
appropriate mouse button. The Status Bar displays which Dam, Reach, or Headwater is active. The exact
function of the mouse button depends on where the pointer is located, which button is pressed, and how the
functions have been assigned. For example, On Release can be set to open a Release Tool or to have No
Operation; the default setting opens a Release Tool window with aright-click on a Release Site. Four categories
of selection are available: On Dam, On Reach, On Release, and On Headwater.

The actions of each mouse button are changed by selecting the desired function from each category. Any
changes you make take effect immediately and do not need to be applied. The Middle Button selections are
provided for a three-button mouse; the settings are unavailableif you are using a two-button mouse.

- Done: Closes Mouse Tool window.
- Help: Opens context-sensitive help information
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Mouze Tool

Left Buttan Middle Button Right Button
(ERNSET I P s sage Histogram ISpiII R ate j
On FRelease IND Operation j IHeIease Tool j
On Beach IF'assage Histogram j IWater Temperature j
On Headwater IND Operation j IHeadwater Temperature j

Dione | Help |

Mouse Tool identifies mouse button functions on the River Map

Message L og

Selecting File » Message Log opens or restores the Log window. The Log window provides a number of

messages from model runs. CRiSP.1 will alert you in the Log window if model operations encounter unexpected
or incorrect model parameters. Error messages that warn of data problems that will cause CRiSP.1 to stop are
always displayed in the Log window. Y ou can choose which other types of messages will be displayed by
choosing one or more of the options from the Logging menu in the Log window.

Please send email to “ crisp-passage@chbr.washington.edu” if you have questions about any of the messages
you get when running the model.

Log window features
- File
- New - Clears Log window of all messages.
- Save As - Saves dl text in the Log window to afile.
- Print - Opens print dialog to print contents of Log window.
- Close - Discards all messages and closes L og window.
- Edit
- Copy - Copies selected text to the system clipboard.
- Select All - Selects the whole contents of the Log window.
- Logging
- Warning - Reports non-lethal error information including extra and missing keywords in data
files. By default, thisoption isturned on.

- Message - Reports two types of information: 1) summary of survival and travel time for all
releases (thisinformation isalso saved in sunmary. dat ) and 2) any data requested by making
selectionsin the Output Settings windows before run execution.

- Raw - Reports the same data as in Message but with greater detail. For example, if TDG
Saturation is selected in Output Settings for some reach, the Message option will give
averaged levelsfor each day, whereas the Raw setting will give TDG levels for each dam time
dlice (four per day) in the entire year.

- Debug - Reports information on river velocity and other parametersat Julian Day 0 in each
river segment. This information is used to debug a col unbi a. desc file by checking if flows
and cross-sectiona area of segments are reasonable.

- Help - Opens context-sensitive help information.
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Sample output showing the beginning of a Scenario Mode run summary

transportation started at Lower G anite Dam day 92
transportati on stopped at Lower Granite Dam day 300
transportation started at Little Goose Dam day 92
transportation stopped at Little Goose Dam day 300
transportation started at Lower Mnunental Dam day 94
transportati on stopped at Lower Mnunental Dam day 300
transportation started at McNary Dam day 160
transportati on stopped at McNary Dam day 300

CRi SP1 Summary Qutput File
Mon Jun 21 10:51:58 1999

Scenari o Mbde
No average flows were calculated for this simulation.

Statistics fields: first day, l|ast day, total passage, nean day
medi an day, node day, std.dev day, avg.flow
bypass out, spillway out, turbine out, transport out
total in, bypass in, spillway in, turbine in, transport in

The preceding line was repeated 2 tines.

Rel ease: Dwor shak Speci es: Steel head Stock: Ceneric Start date:
119 Rel eased: 1192503
Survi val Bel ow Lower Granite Pool
Passed: 1078314
Sur vi val : 90. 4%
stats: 120 165 1078314. 38 127. 03 126. 33
125. 00 3. 45 0.00 0. 00 0.00 0. 00 0.00 1179277. 88

0. 00 0. 00 0.00 0.00
Exit

Selecting File » Exit discardsall unsaved changes and quits the CRiSP.1 program. If you have made changes

to parameter values and settings in CRiSP.1 that you want to use at a later time, you should first save your
changes to the appropriate parameter data file or save the whole database as a Yearly Input Data File (. dat ).
See the Save As section for further information on writing out settings and parameter values.

View
The View menu contains functions related to the display of the River Map.

- UnZoom
. Grid
. Map

UnZoom

Selecting View » UnZoom clearsonelevel of the River Map zoom stack. In addition, the UnZoom command

is represented by | UnZoom: | in the Toolbar. This action can also be accomplished by clicking on an

undefined area on the River Map. See the River Map section for more details.
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Grid

Selecting View » Grid turns on or off the display of the latitude / longitude (latlon) grid on the River Map.
The default setting for CRiSP.1 is to display the latlon grid. In addition, the Grid command is represented by

Sy .
ﬁiﬂ in the Toolbar.

Map
Selecting View » Map turnson or off the display of the River Map. The default setting for CRiSP.1isto display
the River Map. In addition, the Map command is represented by ﬁl in the Toolbar.

Release

The Release menu provides access to the Release Tool and its companion graph window, the Release
Schedule. By opening these windows, you can create, modify, or delete releases. On the River Map, ==

designates the location of possible releases as defined in the col unbi a. desc file and =21 designates the
location of existing releases as defined ina Yearly Input DataFile (. dat) ora. rl s file.

- New
. Release Tool

New: Release

Selecting a release site from Release » New opens the Release Tool and its companion graph window, the
Release Schedule, for creating a release at this site. The list of possible release sites is determined by the

specificationsin the River Description File (col unbi a. desc). See the Release Tool section for further details
on creating, editing, and deleting releases.

Release Tool

Selecting Release » Release Tool opens the Release Tool window and its companion graph window, the

Release Schedule. In these windows, you can control release parameters including the timing and numbers of
fish released and their level of smolt development. Y ou can save your release specifications to a Yearly Input
DataFile (. dat) or a. rl s file for subsequent use (see Save As).

Details on creating, editing, and deleting releases are covered in the following sections:

- Open Release Tool

- Create New Release

- Delete Existing Release Site

- Release Tool Features - modify release parameters
- Release Schedule.
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Open Release Tool

- Select arelease site from Release » New - Opens the Release Tool and editable Release Schedule

window for the selected site. After anew releaseis created (see Create New Release section) and

applied, the River Map and the Existing releases sitelist will automatically update to show the newly
created release.

OR

- Select Release » Release Tool - Opensthe Release Tool and editable Release Schedule window.
OR

- Right-click =4 or = on the River Map (unless you reconfigure the Mouse Tool).

After anew release is created and applied, the River Map and the Existing releases menu will automatically
update to show the newly created release. On the River Map, if there where no previous rel eases specified at the
release site, the release icon ==1 will change to the existing releaseicon = .

Create New Release

1) Open the Release Tool window as directed in Open Release Tool,
2) Select desired Release Site, Species, and Stock from the menus at the top of the window,

- Release Site - |dentifies release site. Select release site (menu includes both existing and
possible release sites) from list.

- Species - Identifies species of release; Chinook 0, Chinook 1, Chinook Summer, or Steelhead.
Select species from list.

- Stock - Identifies stock of release. This can be set to “Generic” or a specific stock can be
selected, e.g. Catherine Creek Chl. Select stock from list.

3) Click Create This Release, and
4) Set release parameters as directed in Release Tool Features.

Helease Tool: Pahsimeroi [Chinook 1. Composite Chi)

Feleaze Site Species

IPahsimeroi j II:hincu:k 1

Existing releazes

| [

Release Start ﬂ j Ian
Smoltification Orset ﬂ j I?U
Smoltification Done ﬂ j I?D

Fieleaze Length ﬂ j ID

Create This Release I Welete ke Eease I [T Select 'With Mouse

Help | Reset Al I Apply Al I Fieset I Ay I Cancel I Ok I

Release Tool window
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Delete Existing Release Site

1) Open the Release Tool window as directed in Open Release Tool,
2) select the desired Release from Existing releases,

3) click on Delete This Release, and

4) apply changes by clicking Apply All / Apply / OK.

After an existing release is deleted and applied, the River Map and the Existing releases menu will
automatically update to reflect this change. On the River Map, therelease icon == will change to the possible
release siteicon == if there are no other releases specified at that rel ease site.

Release Tool Features

Parametersfor individual releases are set in the Release Tool window. Multiple releases can be identified for
any site. Setting release parameters uses the Release Tool window and the Release Schedule graph window.

Healtime Release [Chinook 1. 5 Fork Salmon River Chl]) !EIE
1 Exizting Release
2 Releaze Site 3 Species 4 Stock,
IHeaItime Releaze j IEhinu:u:uk'I j IS Fark Salmon River Chi j

5 Existing releazes

Fealtime Releasze

6 FReleaze Start ﬂ b J c

7 Smaltification Onzet j J
8 Smoltfication Daone ﬂ J

9 Release Length 4| |

134

30

30

[~ |~ = L=

11 12
Create Thiz Release | Delete Thiz Release | [ Select With Mouse

Help | Rezet Al | Apply Al | Rezet | Apply | Eancell k. |

Release Tool window

Release Tool features and functions

- Existing Release (1) - Indicates whether the release information currently displayed is an existing
release or anew release. If the window does not show text on thisline, then select a release from the
Existing releases (5) or follow the directionsto Create New Release.

- Release Site (2) - Identifies release site. Select release site (includes both existing and possible
release sites) from the list.

- Species (3) - Identifies species of release: Chinook 0, Chinook 1, Chinook Summer, or Steelhead.
Select species from the list.

- Stock (4) - Identifies stock of release. This can be set to “ Generic” or a specific stock can be selected,
e.g. Catherine Creek Chl. Select stock from the list.
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- Existing releases (5) - Identifies the active existing release. You can select another existing release
from thelist.

- Release Start (Julian Day) (6) - Specifiesthe first day of arelease. This parameter can be changed
by:
- typing in the text box on the right of the slider (a), or
- dragging the slider box (b), or

- clicking on either side of the dlider box (c) to adjust the Julian Day va ue by increments of 10,
or

- clicking on the end-arrows (d) of the dlider to adjust the Julian Day value by an increment of
one.

- Smoltification Onset (Julian Day) (7) - Specifiesthe Julian Day at which fish will begin to migrate.
This parameter is used by the Migration Equation to determine onset of migration. This parameter can
be edited the same as Release Start.

- Smoltification Done (Julian Day) (8) - Specifies the Julian Day by which all fish in the release will
have started migration. This serves to “spread fish out” in arelease. This parameter can be edited the
same as Release Start.

- Release Length (mm) (9) - Specifies the average length of the fish when rel eased.
- Create This Release (10) - Creates a new release with the specified Rel ease Site, Species, and Stock.
- Delete This Release (11) - Deletes the release currently displayed in the Release Tool.

- Select With Mouse (12) - Actively updates display of release information as mouse moves over the
River Map when box is checked.

- Help: Opens context-sensitive help information.
- Reset All, Apply All, Reset, Apply, Cancel, OK.

Release Schedule

Open the Release Schedule window, companion to the Release Tool window, by opening the Release Tool
window. See the Open Release Tool section for details. In the Release Schedule window, you can change the
number of fish released and the release range (the number of days over which the release is spread) following
the Release Start day set in the Release Tool window. The range of the release and the number of fish released
is displayed using Julian Day in the Release Schedule window. Please note that you are not actually setting
release numbers to occur on specific days. CRiSP.1 will ignore attempts to set part or all of the release range
before the Release Start day. After setting the range of the release, if you change the Release Start day in the
Release Tool window, the whole release range will shift in respect to the change in that date (the length of the
release range will remain the same). For example, if the range of the release isfive days and the Release Start
day isadjusted in the Release Tool window, the release will remain spread over five days. If you make changes
in release counts or the number of days of release, you must click Apply for changes to take effect.

Thisisan Editable Graph window.

- Editable Graph Viewing Features

- Editable Graph Input Features

- Editable Graph Additional Features
- Schedule Tool
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W Release Schedule | [O] x|

X: 197 Y: 383.89 July 16 CIETRIIEY
¥max[3000.00  Ymin:[o.00 Fix| AN y| Rod| A/|nn|rtn|sd] 6r|

Realtime Release [Chinook 1, S Fork Salmon River Ch1]

3000.00

1400.00 1

. Fish Released
Schedulel Reset Alll Apply All | Resetl Apply |CanceI|OK|

Release Schedule window, the Release Tool companion window

Reservoir

The Reservoir menu allows modification of predator densities, water temperature at the headwaters, and
several global river parameters.

- Reach Predator Density
- Predator Distribution Coefficient
- Reach Gas Theta
- Gas Distribution
- TDG Saturation > 100%
- Dam
- Reach
- Water Temperature
- Dam
- Reach
- Headwater Temperature
- Velocity
- River Parameters

Reach Predator Density

Selecting Reservoir » Reach Predator Density opens awindow for setting predator densities for each river
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segment. Densities are given as number of northern pikeminnows per square kilometer of reservoir, excluding
the tailrace and forebay (set in Dam » Predator Density). This measure, based on full pool dimensions, is

effectively a measure of the relative number of predatorsin ariver segment. A segment is defined as a section
of river between river elements (such as dams and confluences). Predation mortality in CRiSP.1 is related to
predator abundance, predator temperature response, and a predator activity coefficient. These factors combine
to determine a predation rate which is applied to the smolt population on a time-step basis. To use these

parameter values during a run, select Gas and Pred Mortality as the Mortality Model in Run » Runtime
Settings.

Thisisa Slider Input window. Click on the letter tabs to page through the Reach list.

- Edit Single Slider Vdue

- Edit Multiple Slider Values Simultaneously
- Edit All Slider Vaues Simultaneously

- Slider Input Additional Features

reach predator density [predators km™-2] == B3
IChinoc-H 'l
A I B | E | D |
R s
mear
E stuary |-2192.11 R 5
Jones Beach |-2192.11 "R "5
Columbia Gorge |-2192_11 "R "5
Bannevils Taiace |-2192_11 L
Borneville Paol |.118?_56 LIRS I
The Dalles Pool e s R s
Deschutes Confluence |.1187.55 'R I 5
Jahn Day ool [ 1157 5 LI
tdchary Pool |.118?',58 R [ls
Columbia above Snake |I539 oo R [ 5
Confluence :

Reach Predator Density window

Predator Distribution Coefficient

Selecting Reservoir » Predator Distribution Coefficient opens a window for setting the predator

distribution coefficient of the predator density/volume interaction for each river segment. The main purpose of
the predator density/volume interaction is to properly scale the effect of initial predator densities on predation
rate during reservoir drawdown. To use these parameter values during arun, turn on predator density / volume

interaction in Run » Runtime Settings.

Thisisa Slider Input window. Click on the letter tabs to page through the Reach list.

- Edit Single Slider Vdue
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- Edit Multiple Slider Values Simultaneously
- Edit All Slider Vaues Simultaneously
- Slider Input Additional Features

pledalm diztribution coefficient

alelelo]

G

coefficient
E stuary E'].DU G
Jones Beach E'],DD G
Calurnbia Gaorge E'],DD G
Bannevills T ailkace E'] an G
Bannevills Pool E'] ao G
The Dalles Paol ’i1 00 [
Dezchutes Confluence |.1.UD G
John Day Pool |.1 oo [ G
et any Poal |.1 .00 G
Columnbia above Snake
Confluence |.1'DD me
[Tidp ] Feset | oy | Concel | k|

Predator Distribution Coefficient window

Reach Gas Theta

Selecting Reservoir » Reach Gas Theta opens awindow for setting the mixing parameter for dissolved gas

in a specified reach. Gas Theta determines the rate of mixing between the gas levelsin the left-bank and right-
bank flows of the river (facing downstream). These flows often have different levels of gas upon exiting a dam
and become more mixed as the river flows downstream. The mixing rate is with respect to time and is set by
default to be 0.075 (mile)™-1, which leads to roughly 95% mixing after 40 miles. A value of zero for Reach Gas
Theta resultsin no mixing between the flows and a value of 10 allows for complete mixing between the flows.

Thisisa Slider Input window. Click on the letter tabs to page through the Reach list.

- Edit Single Slider Vdue

- Edit Multiple Slider Values Simultaneously
- Edit All Slider Vaues Simultaneously

- Slider Input Additional Features
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4 Reach Gas Theta I ES

alelelo]

[ G

Gaz Theta

E stuary 0.075 [ &
Jones Beach 0.075 G
Columbia Gorge |0.075 [ G
Bonnevile Tairace |0.075 [ G
Bonnerille Pool |D_|:|?'5 [ G
The Dalles Pool 0075 [ G
Deschutes Confluence 0.075 i
Joh Dy Pool 0.075 LR
tdchary Pool |D_D?5 [ G
EgHTEi:ibove Snake |D_D?5 [ G

Reach Gas Theta window

Gas Distribution

Selecting Reservoir » Gas Distribution opens agraph of the level of dissolved gasin areach from the start
of the reach to the end. Both the left-bank flow and right-bank flow levels are marked on the same graph, with
the left-bank flow in red and the right-bank flow in blue. These flows often have different levels of gas upon
exiting adam and become more mixed as the river flows downstream. The total amount of gasin the reach also
decreases dueto the dissipation in thereach. A slider for thegraph is provided to change the Julian day for which
gasisdisplayed. The X-axis is the distance downstream in miles from the start of the reach, mile 0. The Y-axis
is the gaslevel measured in percent above 100, the equilibrium level. For example, if saturations vary between
100% and 110%, the Y -axis will range from 0 to 10.

Thiswindow emulates an Equation Input window, but it is display only.

- Equation Input Features
- Edit Single Slider Vdue
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4 Gas Distribution IS E3

40 Y. 7.29
% TDG Sat = 100 Gas Distribution
40.00
20.00 1 _\—___.__\_/_ﬂ
0.00 | | | | | I I
0 11 hal 32 42 a3 63 T4
distance along reach {mi) - red=left, blue=right
day [ 150.00 |
Help | Feset All | Apply Al | Fieset | Apply | Cancel | QK |

Gas Distribution window

TDG Saturation > 100%: Dam

Selecting aDam from Reservoir » TDG Saturation > 100% » Dam opens ahistogram of the total dissolved
gas (tdg) level exiting the dam for viewing only. This corresponds to the tailrace dissolved gas level. Tdg
saturation for both the powerhouse flow (red) and spill flow (blue) levels are marked on the same graph. These
flows often have different level s of gas upon exiting adam because of the gas production from spill. Consult the
table below to determine whether the spill side is left or right, looking downstream, at a specific dam.
Histograms of the daily tdg level are displayed in percent above 100, the equilibrium level. For example, if
saturations vary between 100% and 110%, the Y -axis will range from O to 10.

DAM spill side
Chief Joseph right
Wells left
Rocky Reach | eft
Rock Island right
Wanapum right
Priest Rapids right
McNary right
John Day right
The Dales right
Bonneville right
Dworshak left
Hells Canyon right
Lower Granite right
Little Goose right
Lower Monumental left
Ice Harbor right

ThisisaJulian Day Output window.

- Julian Day Output Viewing Features
- Julian Day Output Additiona Features
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TDE Saturation > 100 Output for Ice Harbor Dam | [O] x|

Done| X:100 Y:12.25 April 10 832 &
Ymaxllz?.54 Ymin:lﬁ@ 1' ||ﬂ| N||'”'l||'|'|'l|ll| EI

TDG Saturation > 100% Output for lce Harbor Dam

2784 -

18.36 1

1
1] 52 105 147 2049 261 4 366

. Powerhouse side . Spill side

TDG Saturation > 100% for Ice Harbor Dam

TDG Saturation > 100%: Reach

Selecting aReach from Reservoir » TDG Saturation >100% » Reach opensa histogram of thelevel of total
dissolved gas (tdg) exiting the reach for viewing only. Tdg saturation for both the | eft-bank flow (red) and right-
bank flow (blue) levels are marked on the same graph. These flows often have different levels of gas upon
exiting a dam because of the gas production from spill. As the water flows downstream, the level of total
dissolved gas decreases due to dissipation across the air-water surface. For reaches directly above a dam, this
corresponds to the forebay dissolved gas level. Histograms of the daily tdg level are displayed in percent above
100, theequilibrium level. For example, if saturations vary between 100% and 110%, the Y -axiswill range from
0 to 10 with the Julian date on the X-axis.

ThisisaJulian Day Output window.

- Julian Day Output Viewing Features
- Julian Day Output Additiona Features
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TDE Saturation > 1002 Output for Columbia above Snake Confluence
Done | X:75 Y:10.97 March 16 H|S| 7| =]
Ymax:l] 9.76 Ymin:lu_uu EI ml :I:l Rndl /\/||1J'|_||'|-|'|| ul EI
TDG Saturation > 1002 Output for Columbia above Snake Confluence
19.76 7
1317 1
6.59
0.00 ! | | I | ] T {\I
1] 52 104 157 209 261 4 366
. Left . Right

TDG Saturation > 100% for Columbia above Snake Confluence

Water Temperature: Dam

Selecting a Dam from Reservoir » Water Temperature » Dam opens a histogram of water temperature at

the dam for viewing only. Water temperature is set on a daily basis in the headwaters. River temperatures in
downstream segments are computed according to the fractions of the incoming flow which are derived from
different headwaters in the segment and the temperature of the headwaters on a given day.

ThisisaJulian Day Output window.

- Julian Day Output Viewing Features
- Julian Day Output Additiona Features
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W’aler Temperature [C] for Dworshak Dam | [O] x|

Done| X: 179 Y: 7.37 June 28 8&[2] &
Ymax:l]a_gu Ymin:lrﬁl ml Il ml /\/||'”1||'|1'||IJ| EI

‘YWater Temperature [C] for Dworshak Dam

18.30 7

12.20 1

B.10 7

0.00 | | | | | | I
] a2 104 187 204 261 314 366

. Water Temperature [C)

Water Temperature for Dworshak Dam

Water Temperature: Reach

Selecting a Reach from Reservoir » Water Temperature » Reach opens a histogram of water temperature

in the reach for viewing only. Water temperature is set on adaily basisin the headwaters. River temperaturesin
downstream segments are computed according to the fractions of the incoming flow which are derived from
different headwaters in the segment and the temperature of the headwaters on a given day.

ThisisaJulian Day Output window.

- Julian Day Output Viewing Features
- Julian Day Output Additiona Features
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W’aler Temperature [C] for Clearwater River | [O] x|

Done X149 Y: 10.62 May 29 ul@l ? | éI
Ymax:l]a_gu Ymin:lﬁ@ 1' Il ml /\/||'”1||'|'|'I|IJ| E|

‘Water Temperature [C] for Clearwater River

18.30 7

12.20 1

B.10 7

0.00 | | | | | | I

. Water Temperature [C]

Water Temperature for Clearwater River

Headwater Temperature

Selecting a Headwater from Reservoir » Headwater Temperature opens a window for setting water

temperature for the selected headwater. Headwater temperature is specified on a daily basis. Daily water
temperature at a headwater isread in to CRiSP.1 asinput from the Y early Input Data File (. dat ). Thiswindow
can be opened by right-clicking on a headwater on the River Map (unless you reconfigure the Mouse Tool).

Thisis an Editable Graph window.

- Editable Graph Viewing Features

- Editable Graph Input Features

- Editable Graph Additional Features
- Schedule Tool
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Headwater Temperature for Clearwater Headwater

Velocity: River velocity in areach

Selecting a Reach from Reservoir » Velocity opens a histogram of the daily river velocity in miles per day

for the reach for viewing only. The river velocity through a reach is calculated based on water elevation,
bathymetry, and the daily flow level in the segment. Bathymetry data is read in to CRiSP.1 from the River
Description File (col unbi a. desc).

ThisisaJulian Day Output window.

- Julian Day Output Viewing Features
- Julian Day Output Additiona Features
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River Parameters

Selecting Reservoir » River Parameters opens a window for setting several parameters that are applied

throughout the river system and do not depend on species or day. The model is fairly sensitive to changes in
these parameters; caution is recommended when making changes to these parameters.

- gas dissp exp - An exponent controlling degassing of total dissolved gas from the water (* 10°-
4cm2/sec). This depends on river velocity and depth.

- Ufree - River velocity in free flowing portions of river (in kcfs*10-1).
- fork threshold - Defines how big ariver fork must be before el evation changes propagate up it.

Note. In Monte Carlo Mode, it is possible to read the river elevation (at selected dams and reaches)
from aflow archivefile. If thisis done, the elevation changes are then propagated upriver under
certain rules. One of the rules concerns how to handle afork. As CRiSP.1 propagates an elevation
change upriver, it will cometo a place wheretheriver forks. CRiSP.1 always propagates up the larger
of the two forks; however, it may or may not propagate up the smaller aswell, depending on the fork
threshold and the ratio of the flow max value for the smaller fork to the flow max value for the reach
below the fork. For example, suppose the flow max for fork A is 80, fork B is 20, and flow max for
the river below the fork is 100. If the fork threshold is .19999999 or less, the model will propagate
elevation changes up both forks. If the fork threshold is .2 or more, CRiSP.1 will only propagate up
fork A (the main branch).

Thisisa Slider Input window.

- Edit Single Slider Vdue
- Edit Multiple Slider Values Simultaneously
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- Edit All Slider Vaues Simultaneously
- Slider Input Additional Features

river parameters IS E3
[ G
fiver params
gas dissp exp [F10™-4 cm”™2/sec) ‘_D_EDD G
Ufree [kfs *10°-1] ‘.9_945 G
fark threshold ‘-D 100 —
. G
Helpl Reset | Apply | Eancel| ok |

River parameters window

Behavior

The Behavior menu allows you to set coefficients that model the rate of migration and survival. These
parameters are species-specific and are applied uniformly in all reservoirs.

- Predation Coef
+ Reach
- Forebay
- Tailrace
- VVar
- Migration Rate Variance
- Predation Temperature Response Equation
- Migration Equation
- Gas Mortality Equation
- Simple Mortality Equation
- FLUSH Transport Merit Equation

Predation Coef: Reach Activity, Forebay, and Tailrace

Predation coefficients effect the rate of predation activity by northern pikeminnows on smolt for a given
predator density. The coefficients are species specific and are defined separately for reaches, dam forebays and
dam tailraces. Predation mortality in CRiSP.1 is related to predator abundance, predator temperature response,
and a predator activity coefficient. These factors combine to determine a predation rate which is applied to the
smolt population on atime-step basis.

Behavior » Predation Coef » Reach Activity opens awindow for setting the predator activity coefficient
which scales the maximal consumption rate to represent in situ conditions where predator-prey encounters may
be less frequent, alternative prey may exist, and predators may not be feeding to satiation. Functions with
settings in Reach Predator Density and Predation Temperature Response Equation to set a rate of predation
mortality. To use these parameter values during a run, select Gas and Pred Mortality for the Mortality Model
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in Run » Runtime Settings. Thisis a Slider Input window.

Selecting Behavior » Predation Coef » Forebay or Behavior » Predation Coef » Tailrace opensaSlider
Input window for setting the predation coefficients in dam forebays or tailraces, respectively, which effect the
rate of predation activity on a species as they travel through that segment.

Each Slider Input window contains three sliders for setting mean, low, and high values by species. When the
low and high values are set to zero, or when the low and high are set to the mean value, CRiSP.1 uses the mean
value at al times (the term becomes deterministic). When the low and high values are not equal, CRiSP.1 uses
the mean, low and high values to randomly generate a value when executed with variance suppression turned
off in the Runtime Settings window under the Run Menu. With variance suppression turned on, CRiSP.1 uses
the mean value and ignores the high and low values. In either case, the mean value must lie within the central
two quartiles of the distribution (i.e., the middle 50%). For example, if the low value is set to 0 and the high
value is set to 100 then the mean value must be set between 25 and 75. If values are set that do not conform to
this restriction, CRiSP.1 will abort the run and generate an error message in the Message Log (if open)
specifying which species have bad parameters.

ERROR bad stochastic paramreach pred coeff for Chinook O.
-->mean not in range 12.386550 <= nmean <= 17.341249
ERROR aborting run due to bad paraneter val ues.

Slider Input window features.

- Edit Single Slider Vdue

- Edit Multiple Slider Values Simultaneously
- Edit All Slider Vaues Simultaneously

- Slider Input Additional Features

leat:h predation coefficient [km”~2 predator™-1 day™-1) fnlehay predation coefficient (km™2 predator™-1 day™-1]
I G L
mean [x10°-7] low [x10°-7) high [10"-7) mean [¥107-7) law [x107-7) high [10"-7)
Cifinosl: @ 14.79 |9 a1 |19.52 & itieets @ 11.70 |?.84 |15.88 &
el 12.70 0.000 0.000 & Elincel) 18.00 0.000 0.000 i
Ehinook Summer 1y 0.000 0.000 s Ehinook Surmer ) g 0.000 0.000 I G
Steshead E;E_Es |!49_35 .95.59 -5 Steehead E74.47 IE49.89 .99.?9 il
Helpl Fieset | Apply | Eancell 0K | HE'Dl Reset | Apply | I::‘3""3'3|| 0K |

taillace predation coefficient (km™2 predator™-1 day™-1]

I |G
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Chinoak 0 Igu_za |13_5? Ilz?.m G
Chinack 1 2 350-004 0.000 |D.DDD r g
Chinook Summer [ nog 0.000 |D.DDD G
Steehead E?a.aa Esz.su Ems.uﬂ ria

Helpl Fieset | Apply | Eancell 0K |

Predation Coefficient Reach, Forebay and Tailrace windows
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VVar: Migration Variance

Selecting Behavior » VVar opens awindow for setting the migration variance parameter which describes the

along-stream spreading of a group of fish migrating through the river segments. This valueisheld constant over
the year. It is also called the velocity variance parameter.

Thisisa Slider Input window. Click on the letter tabs to page through the species and stock list.

- Edit Single Slider Vdue

- Edit Multiple Slider Values Simultaneously
- Edit All Slider Vaues Simultaneously

- Slider Input Additional Features

velocil_l,l wariance parameter PRI 3

ale|

[ G

war
Chinook 0 I >+ 0 [ G
Chinock 1 W=7 .45 [ &
Chinook Surmmer |.54_DI:I [ G
Steelhead |_225_DD G
Catherine Creek Chi |.41 42 [ G
Imnaha River Chl |!37_15 G
Losting River Chi |i37_6|:| [ G
Minarn Riiver Chi [Wao.41 G
5 Fork Wenaha River Chi 7305 [ G
5 Fork Salmon River Chi |-74.98 [ G
Help| Resst | Apply | Eancell oK. |

VVar window

Migration Rate Variance: Variancein Velocity

Selecting Behavior » Migration Rate Variance opens awindow for setting the variability of the velocity of
each stock. This window contains three sliders for each stock, denoting a mean, low, and high value. These
values produce the envelope around the velocity for each release of each stock: alarger envelope around the
mean value means that stock velocity is highly variable from model run to model run. Migration rate variation
differs from VVar in that it applies to the entire stock and produces variation in velocity on a game by game
basis. VVAR, conversely, operates to produce “spread” in arelease over the entire course of migration.

Warning. The impact of large variance in velocity can be substantial; it is not recommended to
ater the calibrated values of migration rate variance.

Migration rate variance is defined by a piecewise linear distribution within the range identified by low and
high values. When the low and high values are set to zero or when the low and high are set to the mean value,
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CRIiSP.1 uses the mean value at all times (the term becomes deterministic). When the low and high values are
not equal, CRiSP.1 uses the mean, low and high values to randomly generate a value when executed with
variance suppression turned off in the Runtime Settings window under the Run Menu. With variance
suppression turned on, CRiSP.1 uses the mean value and ignores the high and low values. In either case, the
mean value must lie within the central two quartiles of the distribution (i.e., the middle 50%). For example, if
the low value is set to 0 and the high value is set to 100 then the mean value must be set between 25 and 75. If
the mean value does not conform to this restriction, CRiSP.1 will abort the run and generate an error message
in the Message Log (if open) specifying which species or stocks have bad values.

Thisisa Slider Input window. Click on the letter tabs to page through the species and stock list.

- Edit Single Slider Vdue

- Edit Multiple Slider Values Simultaneously
- Edit All Slider Vaues Simultaneously

- Slider Input Additional Features

migration rate variance |- =] =]
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G
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5 Fork "Wenaha
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5 Forkc5e |-1_nn 0.100 0.100 G

He|p| Reset | Apply | Eancell Ok |

Migration Rate Variance window

Predation Temper ature Response Equation

Selecting Behavior » Predation Temperature Response Equation opens a window for setting the
temperature response component of predator activity which determines maximum consumption rates as a
function of temperature. These functions are based on |aboratory experiments. Predation mortality in CRiSP.1
is related to predator abundance, predator temperature response, and a predator activity coefficient (see the
Predation Coef section for further details). These factors combine to determine a predation rate which is applied
to the smolt population on a time-step basis. There are three choices for Predation Temperature Response
Equation: two exponential formsand asigmoidal form. Inthe sigmoidal form (the recommended equation), the
variables are as follows:
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- Cmax: Represents the maximum consumption rate.
- alpha: Determines the steepness of the sigmoidal.
- T_inf: Setsthe inflection point temperature.

Thisisan Equation Input window.

- Equation Input Features
- Edit Single Slider Vdue

Predator Temperature Hesponse |- =] =]

| = C_maw / (1 +expl -alpha * (T - T_irt 7]

Catherine Creek, Chi

o d Y. 15.97
Fred Tmp Rsp Fredator Temperature Response
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0.00 | ] | | | | I
] 4 ] 13 17 21 25 30
Temperature {deg C)

Cma | 205 41 |

alpha |||:|521 |
T_int | 1535 |

Help I Reset Al I Apply Al | Hesetl Apply | Eancell Ok |

Predation Temperature Response Equation window

Migration Equation: Active Fish Migration Equation

Selecting Behavior » Migration Equation opens a window for setting the migration rate equations for each

stock. Several migration rate equations are available, ranging from a simple model with a constant migration
rate to amore complex model which relates migration rate to river velocity, date in the season, and downstream
acceleration. In addition, other equations relate migration rate to fish length and temperature. For the given
stock, the parameter sliders in the equation window change the shape of the migration pattern in well-defined

ways.

Migration rate equations parameter definitions
- BO: Constant migration rate term (m/day).
- Bmin: Minimum flow independent migration rate (m/day) at the time of release.
- Bmax: Maximum flow independent migration rate (m/day).

Note. With Bmax > Bmin, the fish have atendency to migrate faster the longer they have been in the
river. This tendency can be “turned off” by setting Bmax = Bmin. Also, flow independent migration
can be turned off entirely by setting Bmax = Bmin = 0.
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- Bflow: Determines the proportion of the river velocity used for downstream migration when the
migrants are fully smolted.

- Btemp: Coefficient that relates temperature (degrees C) to migration rate.
- Blen: Coefficient that relates fish length to migration rate.

- Alpha: Slope parameter that determines how quickly fish change from early season to late season
behavior in terms of flow response (1/days).

- Tseas: Inflection point of the flow dependent term that has the effect of shifting the flow effect
through the season (Julian Days).

- Alpha2: Slope parameter that determines rate of change from the minimum flow-independent
migration rate (Bmin) to the maximum flow-independent migration rate (Bmax).

Inaddition to parametersthat vary the migration rate parameters, you may vary covariatesthat affect migration
rate. These covariates are varied in the display only.

- River vel (display only): Averageriver velocity during the average migration period for each of the
reaches (mi/day).

- Release date (display only): Release date in Julian days.
- Fish len (display only): Length of fish at release (mm).
- River temp (display only): River temperature (degrees C).

Thisisan Equation Input window.

- Equation Input Features
- Edit Single Slider Vdue
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Migration Equation window

GasMortality Equation

Selecting Behavior » Gas Mortality Equation opens companion windows, the Gas Mortality window and
the Popul ation Density vs. Depth window. Thesetwo windows areinterrel ated, and together define the mortality
due to gas relationship. The average gas mortality for areach is calculated by averaging over al gaslevelsina
reach and also using a fish depth distribution. There is roughly athree percent per foot compensation for every
foot below the surface. The average is computed by multiplying the gas mortality equation by the fish depth
distribution and integrating over the length and depth of the reach. The percent mortality per day for the reach

is aflow-weighted average of the mortality in each flow.

Gas Mortality

The Gas Mortality window displays the average mortality due to gas for each species in areach specified by
aset of adjustable parameters. Gas Mortality is displayed in %mortality/day versus the percent of dissolved gas
saturation above 100 in the right-bank flow. The Gas Mortality Equation uses the following parameters:

- mlow: Mortality rate for gas levels below the gas level specified by crit.

- mhi: Mortality rate for gas levels above the gas level specified by crit.
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- crit: Critical dissolved gas saturation level (in percent above 100) which determinesthe switch from a
low to high mortality rate. The critical gas saturation level at the surface of the water is assumed to be
the same throughout the water column in this particular model.

The remaining parameters in this window are for display purposes only in order to describe and display
attributes of areach that affect its average gas mortality rate:

- TDG2: Gaslevd in the left-bank flow in percent above 100.
- SplFr: Percentage of flow in the right bank flow.

- theta: Vaue for the Reach Gas Theta parameter, which determines the amount of mixing between
flows in the reach.

- Reach length: Length of the reach in miles.
- River vel: River velocity in the reach in miles/day.

Thisisan Equation Input window.

- Equation Input Features
- Edit Single Slider Vdue
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Gas Mortality Window
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Population Density vs.

Selecting Behavior » Gas Mortality Equation opens companion windows, the Gas Mortality window and
the Population Density vs. Depth window. These two windows are interrelated, and together define the
mortality due to gas relationship. The average gas mortality for areach is calculated by averaging over all gas
levelsin areach and also using afish depth distribution. There is roughly athree percent per foot compensation
for every foot below the surface. The average is computed by multiplying the gas mortality equation by the fish
depth distribution and integrating over the length and depth of the reach. The percent mortality per day for the

Depth

reach is aflow-weighted average of the mortality in each flow.

The Population Density vs. Depth window usesthree parametersto describe the depth profile for each stock

modeled, where:

- Dmode: Modal depth, the most commonly used depth.
- Dbot: Deepest level at which afish will swim.
- depth (display only): Depth of the pool.

Thisisan Equation Input window.

- Equation Input Features
- Edit Single Slider Vdue
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Population Density vs. Depth window

Simple Mortality Equation: FLUSH Model

Selecting Behavior » Simple Mortality Equation opens a window for setting the parameters used in the
Simple Mortality Model based onthe FLUSH Model (see CRiSP.1 in Context with Other Models). In the Simple
Mortality Model, reservoir survival isafunction of fish travel time. To use these parameter values during arun,
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select Simple Mortality for the Mortality Model in Run » Runtime Settings. There are four choices for the
Simple Mortality Equation where:

- A: Constant known per species.
- B: Constant known per species.

Thisisan Equation Input window.

- Equation Input Features
- Edit Single Slider Vdue
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Simple Mortality equation window

FLUSH Transport Merit Equation: FLUSH M odel

Selecting Behavior » FLUSH Transport Merit Equation opens awindow for setting the parameters used in
the Simple Mortality Model based on the FLUSH Model (see CRiSP.1 in Context with Other Models). To use
these parameter values during a run, select Simple Mortality for the Mortality Model in Run » Runtime

Settings. The Y-axis is the merit of transport value D and the X-axis is the percent survival. There are four
choicesfor the FLUSH Transport Merit Equation--used in PATH for spring chinook (Marmorek 1996)--where:

- a: Constant known per species.
- b: Constant known per species.
- Vt: Direct survival of transported fish.

Thisisan Equation Input window.

- Equation Input Features
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- Edit Single Slider Vdue
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FLUSH Transport Merit Equation window

Marmorek, D.R., et a. 1996. Plan for Analyzing and Testing Hypotheses (PATH): Final report on the
retrospective analysis for fiscal year 1996. Compiled and edited by ESSA Technologies Ltd., Vancouver, B.C.

Flow

The Flow menu controls input of flowsto theriver system at headwaters, removal of water for irrigation, and
changesin both the reservoir and river segment elevation levels. The computation of flow in any river segment
depends on the way CRiSP.1 isrun.

. Dams
- Reaches
- Headwaters
- Flows
- Unregulated Max
- Loss
- Elevation
- Reservoirs
- Headwater Modulation

In the Scenario Mode, flows in all river segments are determined from the flows generated in headwaters and
flow inputs and losses in each river segment from irrigation. Outflows from storage reservoirs are specified
according to the volume constraints of the reservoirs. Finally, river flows are produced using the downstream
propagation algorithm which combines storage reservoir flows and unregul ated headwater flows.
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In Monte Carlo Mode, average flows over defined periods at the dams are read asinput from flow archivefiles
produced by hydroregul ation models. The period average flows are then modulated to give simulated daily flows
at the dams. Using this information, flows in the headwaters are calculated with an upstream propagation
algorithm. Finally, flows through river segments are calculated from the headwaters with the downstream
propagation algorithm.

Dams:. Flow at Dams

Selecting a Dam from Flow » Dams opens aflow histogram at the dam for viewing only. Flows at dams are

determined by input flows specified at the headwater and losses over intervening reaches. You can edit
headwater Flows or reservoir Flow Loss, but not the flow at the dam. In addition, flow output windows can be
opened by configuring the Mouse Tool and selecting a dam on the River Map.

ThisisaJulian Day Output window.

- Julian Day Output Viewing Features
- Julian Day Output Additiona Features

¥4 Flow for Bonneville Dam | [O] x|

Done| X: 170 Y:124.55 June 19 FIEEIE
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Flow for Bonneville Dam

419.91 1

279.94 1

139.97 1

. Flow Rate [kcfs)

Flow at Bonneville Dam

Reaches; Flow at Reaches

Selecting a Reach from Flow » Reaches opens a flow histogram at the reach for viewing only. Flows at
reaches are determined by input flows specified at the headwater and losses over intervening reaches. Y ou can
edit headwater Flows or reservoir Flow Loss, but not the flow at the reach. In addition, individual output
windows can be opened by configuring the Mouse Tool and selecting the reach on the River Map.
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ThisisaJulian Day Output window.

- Julian Day Output Viewing Features
- Julian Day Output Additiona Features
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Flow at Hanford Reach

Headwaters; Flow at Headwaters

- Flows
- Unregulated Max

Flows

Selecting a Headwater from Flow » Headwater » Flows opens awindow for setting flows for the selected
headwater for Scenario Mode runs. Headwater flows are specified on a daily basis. These are combined at
confluences to produce flows through al segments of the river system. Flows at dams are determined by input
flows specified at the headwater and losses over intervening reaches. Y ou can change the headwater flows or

the reservoir losses, but not the flow at the dams.

The mode used to run CRiSP.1 determines how headwater flow is created. In Scenario Mode, flows can aso
be randomly set by using the Headwater Modulation function. In Monte Carlo Mode, headwater flows can be

calculated from flows at the dams as input by thef | ow. ar chi ve file.

Thisisan Editable Graph window.

- Editable Graph Viewing Features
- Editable Graph Input Features
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- Editable Graph Additional Features
« Schedule Tool
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Flow Submenus

Unregulated Max

Selecting Flow » Headwater » Unregulated Max opens a window for allocating flows to unregulated

headwaters, that is streams with a confluence downstream of a dam. Thisis a 100-year flow used to determine
how flow is distributed among unregulated headwaters in the Monte Carlo Mode, when flows at the dams are
specified. Itisnot used asalimit and will be automatically reset to the maximum flow placed, if greater than the
initial value assigned. Default values are determined by relative cross-sectional areas of the streams.

Thisisa Slider Input window.

- Edit Single Slider Vaue

- Edit Multiple Slider Values Simultaneously
- Edit All Slider Values Simultaneously

- Slider Input Additional Features
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Headwater Unregulated Flow Maximum window

L oss: Flow Loss

Selecting a Reach from Flow » Loss opens awindow for setting flow loss for the selected river segment.

Flow loss in each segment is the loss of flow due to withdrawal, mainly from irrigation, on a daily basis or
groundwater input on a daily basis. In the Loss window, positive values represent withdrawals and negative
values represent return flows.

The loss data in a segment represents the change in flow that occurs between the flow input (calculated from
the flow of upstream segments) and the flow output (stored as data in the segment). Where not specified, flow
lossis set to zero.

Thisisan Editable Graph window.

- Editable Graph Viewing Features

- Editable Graph Input Features

- Editable Graph Additional Features
- Schedule Tool
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Flow Loss window for Columbia above Snake Confluence

Elevation: Reservoir Elevation

Selecting a Reach from Flow » Elevation opensawindow for setting the elevation of the selected reach on a

daily basis. For storage reservoirs, see Reservoirs. In Scenario Mode, the values set in this window are used to
control the reservoir elevation. In Monte Carlo Mode, the reservoir el evation can be input from the Flow Archive
Fileif it contains reservoir elevation, otherwise, it is taken from the specified Y early Input Data File.

Thisisan Editable Graph window.

- Editable Graph Viewing Features

- Editable Graph Input Features

- Editable Graph Additional Features
- Schedule Tool

Drawdown Alternatives information

- Inthecol unmbi a. desc file, full pool reservoir elevations are defined using f or ebay_el evati on
andtai l race_el evati on. Reservoir elevations may be computed from volume and surface area if
no other information is present. They may also be input directly as average depth using the dept h
token.

- Elevation changes at full pool are designated zero feet with drawdowns below full pool measured in
negative feet.

. Effective predator density can increase asthe reservoir elevation (and volume) islowered. Turning on
predator density / volume interaction in Run » Runtime Settings causes predator density to increase

with elevation lowering. Thisincrease may counteract the benefits of faster migration velocity and
may result in no change in smolt survival.
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Elevation window for McNary Pool

Reservoirs: Storage Reservoir Inputs

Selecting a Reservoir from Flow » Reservoirs opens two windows, Basin Volume and Outflow, for the

selected storage reservoir. Flow out of storage reservoirsis set by specifying either daily outflow (in kcfs) in the
Outflow window or daily volume of the storage reservoir in kilo-acre feet (kaf) in the Basin Volume window.
The Basin Volume window takes into account the amount lost to outflow and the amount added by inflow and
runoff. These are Editable Graph windows.

- Editable Graph Viewing Features

- Editable Graph Input Features

- Editable Graph Additional Features
- Schedule Tool

In Scenario Mode, flows from storage reservoirs such as Dworshak, Chief Joseph, and Hells Canyon are
controlled through these two windows and interact with the headwater flow (accessed through the Headwaters
submenu). The input flow (output flow from the headwater), outflow, and volume values set by these windows
are constrained as follows:

- With full reservoir, outflow equals input flow
- With an empty reservoir (minimum reservoir volume), output is less than or equal to input flow.

Adjusting storage reservoir flowsisan interactive process. Outflow and volume are modified according to the
above constraints given the input flow. When either the Outflow or the Basin Volume are adjusted with the
mouse buttons, both windows are updated immediately when the mouse button is released. These windows
alow you to examine the effect of adding new storage to the system, applying a water budget using existing
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storage, or pulsing outflow from storage facilities. To update the effect of anew input flow on storage reservoir
volume, run the Scenario Mode of CRiSP.1. The three windows -- Basin Volume, Outflow, and Flow -- will be
updated according to the constraints.

B Ounfiom for Dworshak Dam
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Basin Volume, Outflow and Input Flow windows for Dworshak to control storage reservoir
flows

Headwater M odulation: Headwater Flow

Selecting Flow » Headwater Modulation opens awindow for setting overall water availability in the system

relative to an average water year for Scenario Mode runs. Setting the water year level asa proportion of the mean
flow and computing flows places modulated flows into all the headwaters. The slider for proportion of mean
flow setsthe total available water as the fraction of an average water year. The average water year (proportion
of the mean flow set to 1) isthe total runoff as determined from flows over the 1980’s. Y ou can determine how
wet or dry the year is during a Scenario run. The proportion of mean flow can be set from 0 (extremely dry) to
2 (extremely wet). This scaling factor appliesto all unregulated headwaters.

Caution. Changing this value causes flows to change, perhaps dramatically, throughout the model.
Thisisa Slider Input window.

- Edit Single Slider Vaue
- Slider Input Additional Features
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Dam

The Dam menu includes many parameters that can be atered at each dam. These elements can be applied to
specific dams and in some instances to specific species.

- Transport

- Transport Mortality Equation
- Spill Efficiency

- Spill

- Spill Schedule

- Spill Cap

- Predator Density

- Predation Probability

- TDG Saturation Equations

- Dam Gas Theta

- K Entrain

- Delay Equation

- Powerhouse Capacity

- Powerhouse Schedule

- Powerhouse Priority

- Powerhouse Spill Thresholds
- Mortality

- FGE

- FGE Equation

Transport: Transport Tool

Selecting Dam » Transport opens the Transport Tool. By using the Transport Tool, you can control
transport parameters which include the timing and numbers of fish transported. Y ou can specify transportation

of fish from any transport point (dam) to any river segment downstream. On the River Map, the Wl icon

designates thelocation of possible transport sites and the icon designates the location of existing transports
asdefined inaYearly Input DataFile (. dat ) or a. damfile.
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Note. Rules of transportation are made to conform to the regul ations according to the Fish Passage
Plan for 1991. (Corps of Engineers Projects, US Army Corps of Engineers North Pacific Division
report CENPD-PE-WM March 1991.)

Steps for creating, deleting, and editing transports are covered in the following sections:

« Create New Transport

- Delete Existing Transport

« Set Transport Parameters

- Separation Success Fractions.

Create New Transport

1) Open the Transport Tool window by selecting Dam » Transport,
2) select the desired Transport Dam and Release Reach,

3) select indicator speciesfor Terminate when (in Separation section),
4) click Create This Transport, and

5) Set Transport Parameters (steps 1-4 must be completed first).

After anew transport is created and applied, the River Map and the Existing Transport list will automatically
update to show the newly created transport. On the River Map, the dam icon Wl will change to the transport
icon .

Delete Existing Transport

1) Open the Transport Tool window by selecting Dam » Transport
2) select the desired Transport Dam,

3) click Delete This Transport, and

4) apply changes by clicking Apply All or OK.

After a transport is deleted and the changes are applied, the River Map and the Existing Transport list will
automatically update to reflect this change. On the River Map, the transport icon will change to the dam
icon Il .

Set Transport Parameters

Parameters for each transport are set in the Transport Tool window. Each element of the Transport Tool
window is described below. There are severa ways to edit each dlider in this window.

- Type anew value into the text box to the left of the dlider (a).

- Move the pointer to the slider (b) and drag the slider to adjust the value.

- Click on either side of the slider box (c) to adjust the value by increments of 10.
OR

- Click on the end-arrows (d) of the slider to adjust the value by an increment of one.
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Transport Tool window

Transport Tool features and functions

- Transport Record Type (1) - Defines the state of the transport.
- Nottitleindicates a transport record is not active in CRiSP.1.
- Existing Transport: Indicates an active transport record.

- Transport Dam (2) - Select dam from which transported fish are collected.

- Release Reach (3) - Select river reach into which fish are released.

- Existing Transport (4) - List of existing transport sites

- Start Transportation (5) - Conditions to start transportation. Select from the menu to begin transport:
- On day: Julian day to start transportation, or

- If daily count above: Number of fish that pass the dam in aday. (Unless realistic numbers of
fish are modeled in the system, transport by count will not itself be realistically simulated.)

- Restart Transportation (6) - Conditions to restart transportation. Choices are;
- never: Indicates transportation is never restarted.

- once: Restarts transportation once on a specific Julian day (On day) or if passage exceeds a
given count on aday (If daily count above).

- as necessary: Restarts transportation every time passage is above the specified count (If daily
count above).

- Stop Transportation (7) - Conditions to stop transportation. Choices are:
- on day: Julian day to stop transportation, or
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- if daily count below: Number of fish that pass the dam in a day for the specified number of
sequential days (for # required days).

- Separation (8) - Separation refers to those fish which will be separated and returned to the tailrace
instead of being transported. Separators in bypass systems of dams will separate and return smaller
fish to the tailrace when flow is above a specified level. Separation isterminated and all fish are
collected when passage of a specified stock, the indicator species, exceeds a specified percentage. All
species are separated with likelihood defined by separation probability (see Separation Success
Fractions). Separator efficiency of each speciesis set for each dam. Criteriafor starting and stopping
separation:

- when flow > (kcfs): Identifies flows above which separation starts.
- Terminate when: Identifies indicator species (Chinook 0, Chinook 1, Chinook Summer,
Steelhead) for which its passage will terminate separation.

- passage > (%): ldentifies what percent of the indicator species must pass to terminate
separation. If thisvalueis set to 0, then separation will never start and all bypassed fish will be
transported. If thisvaueis set to 100, then separation will always occur and fish will be
returned to the river as specified in Separation Success Fractions window.

Note. At McNary Dam separation typically begins with flows of 220 kcfs and at Little Goose and
Lower Monumental Dams with flows of 100 kcfs. Separation is stopped if 80 percent of spring
chinooks (Chinook 1) have passed and all bypassed fish are then transported thereafter.

- Transport speed (mi/day) (9) - Identifies barge or truck transportation speed in miles per day from
collection site to release site.

- Separation Success Fractions (10) - Opensthe Separation Success Fractions window which defines
percent of each speciesreturned to the river at each dam.

- Help: Opens context-sensitive help information.
- Reset All, Apply All, Reset, Apply, Cancel, OK

Separation Success Fractions

Selecting Separation Success Fractions from the Transport Tool window allows you to set the percent of
each species returned to the river at each dam when separating. See the Set Transport Parameters section for
details on setting other transportation parameters.

ThisisaSlider Input window where the slider value for a specific species can be “grouped” for al dams using
the D check box. This allows you to simultaneously set the separation probability for Chinook O to the same
value at all dams.

- Edit Single Slider Vdue

- Edit Multiple Slider Values Simultaneously
- Edit All Slider Vaues Simultaneously

- Slider Input Additional Features

83 CRiSP.1



hacliun returned to niver when separating

Bonneville Dam

o

separation probability

-0.20 o

Helpl Reset All | Apply All |P\eset|AppIy|CanceI| OK |

Chinook 0

Chinook 1

Chinook Summer

Steelhead

Separation Success Fractions window

Transport Mortality Equation: Relating Transport M ortality to Flow

Selecting Dam » Transport Mortality Equation opens awindow for specifying arelationship between water

particle travel time (WPTT) and transport survival. Therelationship is based on the assumption that changesin
flow affect how well fish survive transportation. Y ou can set four parameters in the Transport Mortality
Equation window:

. tt1 - Shorter of two WPTT values.

- m1+ - Determinesthe increase over the base mortality level (set in the Mortality window) for transport
that you want to associate with WPTT values of tt1 or shorter.

- tt2 - Longer of thetwo WPTT values.

- m2+ - Associates an increase over the base mortality level (set in the Mortality window) for transport
where WPTT values are tt2 or longer.

Between tt1 and tt2, CRiSP.1 interpolatesin alinear fashion. Thisis an Equation Input window.

- Equation Input Features
- Edit Single Slider Vaue
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Transport Mortality Equation window

Spill Efficiency: Efficiency of Passing Fish with Spill

Selecting Dam » Spill Efficiency opens a window for setting parameters that describe the efficiency of
passing fish with spill water at dams. Spill efficiency is set for each dam on a species-specific basis. The spill
efficiency equations are of theform, Y =f (X: a, b, c, €), where:

- Y = Percent fish passed in spill.

- X = Percent of river spilled during the spill period.

- a, b, c = Depend on functional form selected.

- var = Equation variance parameter set by slider bar (e in equations).

The average efficiency is displayed by ared line in the equation window and the blue lines determine the bound
for the variance as set by var. Thisis an Equation Input window.

- Equation Input Features
- Edit Single Slider Vdue
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Spill Efficiency equation window

Spill: Spill Fraction at Dams

Selecting a Dam from Dam » Spill opens a spill fraction histogram at the specified dam for viewing only.
Spill refersto water that flows over the top of the dam.

Caution. Care must be taken to distinguish between the displayed day-averaged spill percentage
(thiswindow) and the percentage of instantaneous flow that isto be spilled during spill hours (set in
the Spill Schedule windows).

ThisisaJulian Day Output window.

- Julian Day Output Viewing Features
- Julian Day Output Additiona Features
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Spill Schedule: Spill at Dams

Selecting Dam » Spill Schedule opens two companion windows, Planned Spill Days and Preferred Fish Spill
Periods. Y ou can adjust spill operations at dams using these two windows. Spill refersto water that flows over
the top of the dam.

CRIiSP.1 considers three types of spill: Planned Spill, Overgeneration Spill, and Forced Spill. The Scenario
M ode considers Planned Spill and Forced Spill only. Inthe Monte Carlo Mode, Overgeneration Spill isobtained
from thef | ow. ar chi ve file, and Planned Spill can be obtained from the flow archive file or set with the Spill
Schedule windows. It is recommended that Planned Spill be set with the Spill Schedule windows--Planned
Spill Days and Preferred Fish Spill Periods--when making Monte Carlo runs by selecting “user data’ as the
source for Planned Spill in the Monte Carlo window.

- Planned Spill is set by agreement with fisheries agencies and can be adjusted by using the Spill
Schedule windows. Spill isidentified as a percentage of the instantaneous flow and is specified for
given days and hours of the day.

- Overgeneration Spill results when the electrical generation demand is less than the dam’s generating
capacity and the excesswater is spilled instead of being passed through the turbines. This type of spill
is established from f | ow. ar chi ve files and is defined over periods of either two weeks or one
month.

- Overgeneration Spill is added to the Planned Spill in Fish Spill Hours every day in aflow
archive period.

- If total spill in Fish Spill Hours is then greater than 100% of the river flow over the hours
identified, excess Overgeneration Spill is distributed over the rest of the day.
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- If total spill for the entire day is greater than 100% then the excess Overgeneration Spill is
ignored.

- Forced Spill results when river flow exceeds the hydraulic capacity of the dam and excess water is
spilled.

Planned Spill Days

Selecting Dam » Spill Schedule opensthe Planned Spill Days window and its companion window Preferred

Fish Spill Periods for adjusting spill operations at dams. The Planned Spill section discusses how the settingsin
these two windows work together. The Planned Spill Days window controls Spill Fraction, the fraction of river
flow spilled on an instantaneous basis, and Planned Spill Days, the Julian days when spill fractions are planned
as part of the water budget and spill alocation agreements.

Thisisa Schedule Tool window with the following features:

- Dam Menu - List of dams at which to set spill days and spill fraction information.

- Spill Days list - Displays the days of Planned Spill and the instantaneous fraction of theriver that is
spilled within a period. Use the Start Day, Stop Day and Spill Fraction keyboard input boxesto
create new periods or modify existing periods of spill.

1. Select aperiod (one line) in the Spill Days list to transfer the values into the text boxes.
2. Modify any of the values (Start Day, Stop Day, Spill Fraction).

3.Click = «= | to transfer the values from the text boxes back into the Spill Days list.

The new/modified valuesonly take effect after clicking Apply / Apply All/ OK. Click Reset / Reset All / Cancel
to revert back to the last saved values.
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Planned Spill Days window
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Preferred Fish Spill Periods

Selecting Dam » Spill Schedule opensthe Preferred Fish Spill Periods window and its companion window

Planned Spill Days for adjusting spill operations at dams. The Planned Spill section discusses how the settings
in these two windows work together. The Preferred Fish Spill Periods window controls Fish Spill Days, the
Julian days when spill is alocated for fish passage, and Fish Spill Hours, the hours of the day when water will
actually be spilled.

Thisisa Schedule Tool window with the following features:

- Dam Menu - Designates the dam to which fish spill days and hours apply.
- Preferred Days list - Designates the actual days on which spill occurs.

- Preferred Hours list - Designates the hours of spill for aperiod of fish spill days highlighted in the
Preferred Days list.

In the figure below, fish spill isidentified for days 0 to 365 and fish spill hours O to 24 (fish spill operates all
day, all year-round). Use the Start Day, Stop Day, Start Hour, and Stop Hour text boxes to create new periods
or modify existing preferred fish spill periods. In order to set periods where fish spill is not occurring, you must
clear the Preferred check box and set the values for Start Day, Stop Day, Start Hour, and Stop Hour during
which fish spill is not to occur. For example, if you want fish spill to only occur at night and not during the day
hours (6-18):

. Clear the Preferred check box,
- enter the 6 for Start Hour and 18 for Stop Hour, and

. click <<== |to transfer the values from the text boxes to the Spill Days and Spill Hours list.

The new/modified values only take effect after clicking Apply / Apply All / OK.

Pleferred Fizh Spill Periods

Frefened Fish Spill Periods

Start Day

—

Stop Day

|355
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Preferred Fish Spill Periods window
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Planned Spill

The separation of Planned Spill Days and Preferred Fish Spill Periodsis an arbitrary convention that arose out
of the 1989 Spill Agreements. In practice, the spill fraction should be indicated in the fish spill days and planned
spill days should be eliminated; however, thisis not the way the agreement was written.

The relationship between these spill operation variablesisillustrated in the figure below. Planned Spill Days
alocate a certain fraction of the river flow to be spilled during specified blocks of days as given in the water
budget. Different fractions can be set for different blocks of days. Preferred Fish Spill Periods, however,
indicate the actual days that spill will occur. The Fish Spill Hours specify blocks of time in each Fish Spill Day
when spill occurs. In the example below, two Planned Spill Day periods are given. In the first period 50% of the
daily averaged flow is planned to be spilled between Julian Day 0 and 100 and in the second period 70% spill is
planned between day 125 and 300. These spills are computed as percentages of the average flow over the day.
In this example, Fish Spill is identified for Julian Days 50 to 75 and 150 to 300. Spill will be 50% and 70%,
respectively, of the daily averaged flows during these periods. The spill planned during days 125 and 150 will
not occur. The Fish Spill Days period 150 to 300 has Fish Spill Hours 0 to 12.

1
25
[eR™1
T8
L1 o5 0.7 Planned Spill Days
V=3
[} . .
8 Fish Spill Days
N
c
(@]
Fish Spill Hours

Schematic of possible Planned Spill variables

Note. In the example above, the second spill period demands 70% of total river flow, but only
alocates 12 hours per day to spill it in. Thiswill produce a warning message from CRiSP.1 since
the model will be unable to achieve the 70% spill requirement by spilling only 50% of the time.
Users should be careful to make their spill requests consistent with realistic dam operations.

Spill Cap: Maximum Allowable Spill

Selecting Dam » Spill Cap opens a window for setting a maximum flow which can be passed over the

spillway at each dam. Spill Cap only applies to Planned Spill; if Forced Spill (see Spill Schedule section)
requires exceeding the spill cap, the cap isignored.
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Thisisa Slider Input window. Click on the letter tabs to page through the list of dams.

- Edit Single Slider Vaue

- Edit Multiple Slider Values Simultaneously
- Edit All Slider Values Simultaneously

- Slider Input Additional Features
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Spill Cap window

Predator Density

Selecting Dam » Predator Density opens awindow for setting predator densities in the forebay and tailrace

at each dam (reaches are set in Reservoir » Reach Predator Density). Predator numbers are expressed on a

square kilometer basis. Thisfunction accountsfor theincreasein predator density at the dam relativeto densities
in the reservoirs. As forebay and tailrace depths change with pool elevations, the predator density can be
specified to adjust according to the change in depth from full pool by turning on predator density / volume

interaction in Run » Runtime Settings.

ThisisaSlider Input window. Click onthe letter tabsto page through thelist of dams. Thisdlider input window
groups forebay values separately from tailrace values.

- Edit Single Slider Vaue

- Edit Multiple Slider Values Simultaneously
- Edit All Slider Values Simultaneously

- Slider Input Additional Features
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Dam Predator Density in forebay and tailrace

Predation Probability: Diel Predation Probability

Selecting Dam » Predation Probability opens a window for adjusting the predation rate to some fraction

below the maximum rate for each dam and species. Since predators typically use visual cuesto find and capture
prey, light levels should effect the rate of predation of fish in the forebay of the dam. Since dam passage varies
between day and night, CRiSP.1 alows for the probability of predation to change over a24 hour period in dam
time increments (6 hours). A diel variation in reservoir predation is not applied since CRiSP.1 only uses two
time steps over the day for reservoirs.

Thisisa Slider Input window.

- Edit Single Slider Vdue

- Edit Multiple Slider Values Simultaneously
- Edit All Slider Vaues Simultaneously

- Slider Input Additional Features

This Slider Input window includes menus for selecting by Dam and by Species. You can group sliders by:
Time-Step (T), Dam (D), or Species (S).

- If you group sliders by Time-Step (T), you are only modifying the grouped Time-Step values for the
specific Dam and Species currently selected in the menus.

- If you group sliders by Dam (D), you are modifying the value for the corresponding Time-Step(s) for
the specified Species at al dams.

- If you group sliders by Species (S), you are modifying the value for the corresponding Time-Step(s) at
the specified Dam for all species.
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- If you group slider by both Dam (D) and Species (S), you are modifying the value for the
corresponding Time-Step(s) at all dams for all species.

Dam Predation Probability [ (=] =]
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Dam Predation Probability window

TDG Saturation Equations: Total Dissolved Gas Super saturation

Selecting Dam » TDG Saturation Equations opens three gas production equation windows--Day, Night and
Backup--for defining the production of total dissolved gas supersaturation due to spilling at dams. The
relationship between spill in kcfs and total dissolved gas above 100% saturation in the water isillustrated in the
equation windows.

Operations at many dams differ during the day and night hours as a result different gas production equations
are specified for each dam. Night is defined as hours 0-6 and 18-24 in the model. If the gas production
characteristics are not significantly different for Night and Day, then these equations are specified to be the
same.

The Backup equation is intended to supply athird equation in case the spill value falls out of a reasonable
range for the equations provided for Day and Night characteristics. For example, the linear equations work best
for McNary and Bonneville under normal spill operations; however, extremely high spills could create gaslevels
too high in an unbounded linear equation. Spill values less than |b (lower bound) or greater than ub (upper
bound) determine the switch to the Backup equation.

There are six different gas production curvesto choose from in each of the gas production windows. Bounded
Linear and Bounded Exponential are the new and recommended production equations. Gas spill 1, Gas spill 2,
and the other two equations offer other choicesfor gas production characteristics but are not implemented at any
dam. The Gas spill equations have been the calibrated equationsin previousversions of CRiSP.1. In general, the
gas production equation parameters have been calibrated to existing data sets, and we recommend that you do
not alter these values.

- Bounded Linear
- b, m = model parameters determining the gas production
- Ib, ub =lower and upper bound limits
- Bounded Exponential
- a, b, c = model parameters determining the gas production
- Ib, ub =lower and upper bound limits

- Gas Spill models: models of supersaturation based on entrainment of gas bubblesin the tailrace (gas
spill 1 and gas spill 2). These models are mechanistic, taking into account dam geometry and
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hydrodynamics, but do not respond to reservoir elevation changes. They differ from each other in the
way each computes gas bubble entrainment.

- Empirical models: these are simple empirical models and not responsive to changesin reservoir
elevation. The two equations contain the parameters:

- Y = tdg supersaturation in percent above 100% saturation
- X =river spilled in kcfs
+ a, b, h ork =modd coefficients set with dliders.

These are Equation Input windows.

- Equation Input Features
- Edit Single Slider Vaue
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TDG Supersaturation Equation windows

Dam Gas Theta

Selecting Dam » Dam Gas Theta opensawindow for setting the mixing parameter Gas Theta for each dam.
This mixing parameter determines the level of mixing between the left-bank and right-bank flowsin thetailrace
of thedam and theresulting gas levelsin each flow upon exiting thedam. This essentially determines the amount
of mixing between the spill flow and the powerhouse flow in the tailrace. Seethe TDG Saturation > 100%: Dam
section to determine whether the spill side is left or right, looking downstream, at a specific dam. Setting Gas
Theta to zero resultsin no mixing between the spill and powerhouse flows and avalue of 10 allows for complete
mixing between the flows.

Gas Theta is different from K Entrain in that it determines how much mixing is happening between the
powerhouse and spill flows in the tailrace where as K Entrain determines how much more gasis added to the
system. Gas Theta will result in an exchange of gas between flows but the total amount of gasremains the same.

Thisisa Slider Input window. Click on the letter tabs to page through the list of dams.
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- Edit Single Slider Vdue

- Edit Multiple Slider Values Simultaneously
- Edit All Slider Vaues Simultaneously

- Slider Input Additional Features

i Dam Gas Theta s

*]el

[ G

Gas Theta
Bonneville 0am @I‘ G
The Dalles Dam N 1 0.00( G
John Day Dam 0.00 G
i ary Dam 0.00 G
Priest Rapids Dam 0.00 G
‘wanapum Dam .00 G
Fock Island Dam 0.00 G
Rocky Reach Dam 0.00 G
‘wells Dam 0.00 G
Chief Jaseph Dam 0.0o0 G
Help | Reset | Apply | Cancel | Ok |

Dam Gas Theta window

K Entrain

Selecting Dam » K entrain opens a window for setting the entrainment coefficient at a dam. K entrain
determines how much additional gasisadded to the powerhouse flow in the tailrace as afunction of the amount
of water going over the spillway into the tailrace of the dam and the spill flow gas level. The higher the amount
of spill the more gas that is added to the powerhouse flow with the level of tota dissolved gas (tdg) in the
powerhouse flow ranging from the forebay tdg level to the tdg level in the spill flow. A K entrain value of zero
results in no entrainment and the powerhouse flow will exit the dam at the same gas level it entered. A value of
10 resultsin maximum entrainment and the powerhouse flow will exit the dam at the same gaslevel that the spill
produced in the spill flow.

K entrain isdifferent from the Dam Gas Thetain that it determines how much more gasis added to the system
where as the mixing parameter Gas Theta determines how much mixing is happening between the powerhouse
and spill flows in the tailrace. Gas Theta will result in an exchange of gas between flows but the total amount
of gas remains the same.

Thisisa Slider Input window. Click on the letter tabs to page through the list of dams.

- Edit Single Slider Vdue

- Edit Multiple Slider Values Simultaneously
- Edit All Slider Vaues Simultaneously

- Slider Input Additional Features
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K Entrain window

Delay Equation: Delay at Dams

Selecting Dam » Delay Equation opensthe Passage Delay window which displays the passage probability
in six hour intervas. The Delay Equation is a CRiSP.1 submodel that delays fish at a dam depending on the
species, time of day, season, and flow. The delay is expressed in terms of a passage probability, not in terms of
observed passage. The probability of passage depends on the model parameters; in all cases, increasing the
parameters decreases the probability of delay and thus time spent in the forebay. The parameters are;

- A day - Constant term that determines probability of delay during daytime hours.

- A night - Constant term that determines probability of delay during nighttime hours.
- B flow - Coefficient that relates delay probability to river flow.

- B Spill - Coefficient that relates delay probability to percent river spilled.

- B date - Coefficient that relates delay probability to date in the season.

Several factors which affect delay are included in the display. Adjusting these factors does not change model

data

- River vel (display only) - River velocity in the reservoir in miles/day.
- Spill Fraction (display only) - Percentage of water spilled at the dam.
- Julian date (display only) - Julian Day.

Thisisan Equation Input window.

- Equation Input Features
- Edit Single Slider Vdue
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Dam Passage Delay window

Power house Capacity

Selecting Dam » Powerhouse Capacity opens a window for setting how much flow each dam can put

through its powerhouse before being forced to spill theremaining flow. Damsdiffer intheir design, and different
dams can accommodate differing amounts of flow through each powerhouse before being forced to spill excess
flow.

Thisisa Slider Input window. Click on the letter tabs to page through the list of dams.

- Edit Single Slider Vdue

- Edit Multiple Slider Values Simultaneously
- Edit All Slider Vaues Simultaneously

- Slider Input Additional Features
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Powerhouse Capacity window

Power house Schedule

Selecting Dam » Powerhouse Schedule opens a window for setting the days and hours in which any
powerhouse is used. Dams with two powerhouses can operate on a schedule to optimize surviva during thefish
passage season. The strategy isto operate the highest priority powerhouse up to its hydraulic capacity, then spill
water up to another level called the spill threshold (set in Powerhouse Spill Thresholds window). Above this
threshold, the second powerhouse is used. If the hydraulic capacity of the second powerhouse is exceeded,
excess flow is spilled. For times when the second powerhouse is not scheduled, the spill threshold is not applied
and al flow exceeding the hydraulic capacity of the first powerhouse is put into spill only. In the example, the
Bonneville Dam primary powerhouse (set in Powerhouse Priority window) ison al day, every day.

- Powerhouse Dam menu - Designates dam to which powerhouse activity applies.

- Day List - Designates days of activity.

- Hour List - Designates hours of activity for the selected period in the Day List.

. Start Day and Stop Day - Text boxes to create or modify powerhouse activity periods.

- Start Hour and Stop Hour - Text boxes to create or modify powerhouse activity periods.

- On check box - Indicates that powerhouse operations are on for the period selected. Clear check box
and modify powerhouse schedul e to turn off powerhouse activity for the desired period of hours and/
or days.

In the figure below, the powerhouse is set to operate all day, all year-round. Use the Start Day, Stop Day, Start
Hour, and Stop Hour keyboard input boxes to create new periods or modify existing periods of activity. In order
to have periods where the powerhouse is not in operation, you must clear the On check box and set Start Day,
Stop Day, Start Hour, and Stop Hour for the period in which powerhouse operations are not to occur.
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- For example, if you want the powerhouse to operate only at night and not during the day hours (6-18)
then you would clear the On check box and enter the 6 for Start Hour and 18 for Stop Hour and click

<<== | button to transfer the values from the keyboard input boxes to the Days and Hours lists.
- The new/modified values only take effect after clicking Apply / Apply All / OK.

Thisisa Schedule Tool window.

Powerhouse Schedule ME E

Powerhouse Schedule
Start Day
IIJ
Stop Day
|355
Start Hour
IIJ

Haour List Stop Hour
|24

(== |
Dray List v On
Help | Feset Al I Apply All I Hesetl Apply I Eancell Ok, |

Powerhouse Schedule window

Powerhouse Priority

Selecting Dam » Powerhouse Priority opens a window for setting which powerhouse is designated the
primary powerhouse. There are two dams that require a primary powerhouse to be set: Bonneville Dam and
Rock Island Dam.
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Powerhouse Priority window

Power house Spill Thresholds

Selecting Dam » Powerhouse Spill Thresholds opens a window for setting the maximum amount of spill

allowed (in kcfs) at each primary powerhouse, set in Powerhouse Priority window, before the secondary
powerhouseis used.

Thisisa Slider Input window.

- Edit Single Slider Vdue

- Edit Multiple Slider Values Simultaneously
- Edit All Slider Vaues Simultaneously

- Slider Input Additional Features

powerhouse spill thresholds |- =] =]
G
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Powerhouse Spill Thresholds window

Mortality: Mortality in Dam Passage

Selecting Dam » Mortality opensawindow for setting the fish mortality ratesfor each dam and speciesin the

various passage routes: spillway, bypass, turbine, and transport. Transportation mortality can be altered using
parameters available in the Transport Mortality Equation window.

The probability distribution of mortality for each passage route is defined by a piecewise linear distribution
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within the range identified by low and high values. When the low and high values are set to zero or when the
low and high values are set to the mean value, CRiSP.1 uses the mean value at al times (the term becomes
deterministic). When the low and high values are not equal, CRiSP.1 uses the mean, low and high values to
randomly generate a value when executed with variance suppression turned off in Runtime Settings (Run
Menu). With variance suppression turned on, CRiSP.1 uses the mean value and ignores the high and low
values. In either case, the mean value must lie within the central two quartiles of the distribution (i.e., themiddle
50%). For example, if the low vaue is set to 0 and the high value is set to 100 then the mean value must be set
between 25 and 75. If the mean value does not conform to this restriction, CRiSP.1 will abort the run and
generate an error message in the Message L og (if open) specifying which species at which dams have bad values.

Thisisa Slider Input window. In this slider input window, you can group sliders by: Dam (D) or Species (S).
If you group sliders by Dam (D), you are modifying the mean, low or high value for the corresponding passage
routes for the specified Species at all dams. If you group sliders by Species (S), you are modifying the mean,
low or high value for the corresponding passage routes at the specified Dam for al species.

- Edit Single Slider Vdue

- Edit Multiple Slider Values Simultaneously
- Edit All Slider Vaues Simultaneously

- Slider Input Additional Features

mortality IS B3
B aonnevile Dam IChinook 1 'I
o /s
mean = high
Spillovay 0.020 0.000 Jo.07o o s
Bypass 0.020 0.000 Jo.0s0 o s
Turbine Jo.o7o 1.00e002  []0.100 o s
Transport 0.000 0.000 |D.DDD o s
Hep | Resetal | appban | Reset | appl | cancel | ok |

Dam Mortality window

FGE: Constant Fish Guidance Efficiency

Selecting Dam » FGE opensawindow for defining the fish guidance efficiency of the bypass systemsat dams
for day and night periods.

One of two possible functional relationships can be specified for fge: constant fge or timevarying fge (see FGE
Equation). When age dependent fge is turned off (Run » Runtime Settings), the model will use the constant
fge condition and the values set in thiswindow. Day and night fge then vary randomly on each dam timeinterval
according to afixed probability distribution, i.e. the distribution has no seasonal trend. Fgeis specific to agiven
dam and species and its random variations occur for each dam time interval (6 hours).

The probability distribution of constant fge is defined by a piecewise linear distribution within the range
identified by the low and high values. When the low and high values are set to zero, or when the low and high
are set to the mean value, CRiSP.1 uses the mean value a all times (the term becomes deterministic). When the
low and high values are not equal, CRiSP.1 uses the mean, low and high values to randomly generate a value
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when executed with variance suppression turned off (Run » Runtime Settings). With variance suppression

turned on, CRIiSP.1 usesthe mean value and ignoresthe high and low values. In either case, the mean value must
lie within the central two quartiles of the distribution (i.e., the middle 50%). For example, if the low valueis set
to 0 and the high value is set to 100 then the mean value must be set between 25 and 75. If values are set that do
not conform to thisrestriction, CRiSP.1 will abort the run and generate an error message in the Message Log (if
open) specifying which species at which dams have bad values.

The probability distributionsfor day and night fge set in thiswindow are used in the calculation of time varying
fge and the night fge values are displayed in the FGE Equation window. Changes applied to the probability
distributions will automatically update the display in the FGE Equation window.

Thisisa Slider Input window.

- Edit Single Slider Vdue

- Edit Multiple Slider Values Simultaneously
- Edit All Slider Vaues Simultaneously

- Slider Input Additional Features
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Fge window

FGE Equation: Time Varying FGE

Selecting Dam » FGE Equation opens a window for setting parameters for time varying fge which differs
from constant fge set in the FGE window. In order to execute amodel run using the time varying fge condition,
you must turn on age dependent fge (Run » Runtime Settings). When the model is run under this condition,
day and night fge change randomly for each dam time interval (6 hours) according to probability distributions
that change with fish age and reservoir elevation. Variationsin fge from the initial condition depends on Julian
day, the day since the onset of smoltification, set in the Release Tool window, and reservoir elevation for each
day, set in the Elevation window. The FGE Equation window displays the values for night fge only; however,
both day and night values are calculated using the parameters set in this equation window as well as the mean,
low and high fge values set in the FGE window. The difference between day and night fge is determined by the
sliders describing the probability distribution in the FGE window. Changes applied to the probability
distribution will automatically update the display in the FGE Equation window. In the FGE Equation window,
mean fge is depicted as a red line and the blues lines designate the low and high values. Fge is plotted against
fish age relative to the onset of smoltification. To coordinate effects of age dependent behavioral factorsin fge
and the seasona dependent reservoir level factor, you must select the Julian day of the onset of smoltification.
The fge submodel parameters are as follows:

- z0 - Fish forebay depth at age (t0) where fish passage behavior starts changing.
- z1 - Fish forebay depth at age (t0 + dt) where fish passage behavior stops changing.
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- t0 - Fish age since the onset of smoltification at which fish passage behavior starts changing.
. dt - Time interval over which fge changes due to fish behavior.

- Smolt date (display only) - Julian day for onset of smoltification. Smoltification onset of actual
releases is set with the Release Tool.

Thisisan Equation Input window.

- Equation Input Features
- Edit Single Slider Vdue
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Night Fge Equation window.

Passage: Passage Histograms

CRIiSP.1 computes daily fish passage on a release-specific basisfor al river sesgments and dams. In CRiSP.1,
passage and survival of fish through areservoir isexpressed in terms of the fish travel time through thereservair,
the predation rate in the reservoir, and a mortality rate resulting from fish exposure to total dissolved gas
supersaturation, an effect called Gas Bubble Disease. Fish enter the forebay of a dam from the reservoir and
experience predation during delays due to diel and flow related processes. They leave the forebay and pass the
dam mainly at night through spill, bypass or turbine routes, or the fish are diverted to barges or trucks for
transportation. Once they leave the forebay, each route has an associated Mortality rate and fish returning to the
river are exposed to predatorsin the dam tailrace before they enter the next reservaoir.

The Passage menu provides access to passage histograms for each reach and dam in the model and for each
of the four dam passage methods: bypass, turbine, spillway, and transport. Passage histograms are also
accessible by clicking on the desired location of the River Map (unless the Mouse Tool options have been
redefined). In order to view passage data and histograms, the desired passage output data must be specified
before running CRiSP.1.
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1) Open Output Settings.

2) Select desired passage pointsfor each passagetypein Output Settings for Dams or Output Settings
for Reaches windows and click OK.

3) Run CRiSP.1 in Scenario Mode.

4) Select passage type and passage point from the Passage menu.

- Passage » Dam/Reach - Opens fish passage histogram for selected dam or reach. (Select
Passage for the desired passage pointsin Output Settings for Dams or Output Settings for

Reaches windows.)

- Bypass » Dam - Opens fish passage histogram for fish travelling through the bypass route
a the dam. (Select Routing in Output Settings for Dams window for the desired dams.)

- Turbine » Dam - Opens fish passage histogram for fish travelling through the turbines at
the dam. (Select Routing in Output Settings for Dams window for the desired dams.)

- Spillway » Dam - Opensfish passage histogram for fish travelling through the spillway at
the dam. (Select Routing in Output Settings for Dams window for the desired dams.)

- Transport » Dam - Opensfish passage histogram for fish transported from the dam. (Sel ect
Routing in Output Settings for Dams window for the desired dams.)

All Passage menu windowsinclude acouplefeatures which are not found in other Julian Day Output windows.
Each passage histogram includes a species menu (1) in the upper-right corner of the window which allows you
to view the survival and timing data for each speciesindividualy (Chinook 0, Chinook 1, Chinook Summer, or
Steelhead) or for All species combined at the dam or reach. The default view is al species combined. Below the
X-axis of the graph istheline “total passage# = %.” Thisisthe total number of fish passing the selected point-
-dam or reach--for each day (2) and the percentage of the total number of fish released for the entire system that
pass through the selected point (3). For example, in a run where the total number of fish released is 1,000,000
and total passage at Bonneville Dam is 281,029, then the passage at Bonneville Dam is 28% of the total number
of fish released. When you view passage for a specific species the percentage is of the total number of species

released. If you are viewing Spillway, Bypass, Turbine, or Transport Passage, the percentage shown is the
percent of the total number of fish released.

- Julian Day Output Viewing Features
- Julian Day Output Additiona Features
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Run

The Run menu contains selections related to running CRiSP.1 in both Scenario Mode and Monte Carlo Mode.

- Run Scenario

- Cancel Run

- Monte Carlo

- Lock Output Settings
- Output Settings

- Runtime Settings

Run Scenario: Scenario M ode

Selecting Run » Run Scenario executes a Scenario Mode run using the data currently stored in the model.
The data is a combination of parameter data read into the model and any changes in settings you have applied.

In addition, the Run Scenario command is represented by ll in the Toolbar. Scenario Mode is used for
determining migration and survival for asingleyear at atime. The model can be run in the Scenario M ode using
its default settings as determined by base. dat . Normally, the default settings are replaced by reading user-
specified parameter datainto the model, selecting rel ease sites, and running CRiSP.1. The results can be viewed
in Passage Histograms, and statistical results can be viewed in the Message Log or in the summary. dat file
which contains results from the most recent Scenario Mode run.

- Run Scenario Mode Interactively
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- Run Scenario Mode in Batch Mode
- Scenario Mode Results (summary.dat)

Run Scenario Maode | nteractively

1) Read parameter datainto CRiSP.1

- CRiSP.1 reads in parameter data and model settings from abase. dat filewhen initialy
opened. Other parameter data can be read into the model by selecting File » Open or by

clicking Eﬁ;, The CRiSP.1 distribution includes the “yearly.data” directory which contains

. dat fileswith actual data for each year from 1965 to 1998. All changes applied during a
session will be used in the Scenario Mode run. In order to save changes made to parameter data
and settings for another session, use the Save As feature to save parameter data files or the
whole database to afile.

2) Set Releases
- New releases can be defined by right-clicking on azf= on the River Map to open aRelease

Tool or by selecting Release » New. Existing releases are represented by 27 on the River
Map. See the Release Tool section for further information on creating, deleting, and editing
releases.

3) Set Transports

- Transports can be defined for any dam by selecting Dam » Transport. See the Transport Tool
section for further information on creating and editing transports. Existing transports are

represented by on the River Map.

4) Select Output Data by selecting Run » Output Settings

a. Set Passage Points. CRiSP.1 computes daily fish passage on arelease-specific basis through al
river segments and dams. Fish survival and migration time at specific points along theriver is
displayed in Passage Histograms and in the Message L og after the run completes. You can request
specific passage points by setting the options you want in the Output Settings for Dams and Output
Settings for Reaches windows. See the Passage Histograms section for further information on
passage datatypes.

b. Set Flow Observation Point: A representative river flow over the travel time of arelease can be
obtained by selecting the dam you want as the Flow Ind. in the Output Settings for Dams window.
The average flow will be reported in the Message Log and in the surmar y. dat file. Only one flow
point can be specified.

c. Set Other Data: Other data such as water temperature at a dam can be requested by setting the
options you want in the Output Settings for Dams, Output Settings for Reaches and Output
Settings for Headwaters windows.

Note. During a CRiSP.1 session, the selected output settings can be used for multiple runs with
various parameter data files by using the Lock Output Settings option (Run menu) to lock the output
settings and override any output settings contained in a parameter data file subsequently read into the
model.

5) Set Model Configurations
« CRIiSP.1 can be run with different functions that affect the movement and survival of fish

through the river system. Specific functions can be set by selecting Run » Runtime Settings
and setting the runtime options you want.

6) Set Logging Options by selecting File » Message Log
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- Select Messages from the Logging menu in the window to write results from the run to the log
window. See Message Log for other logging options.

7) Begin Scenario Run by selecting Run » Run Scenario or clicking *& |
Note. The progress of Scenario Mode run calculations will be displayed in the Status Bar of the
GUI, lower-left corner.

8) View Scenario Mode Results (summary.dat).

Y ou can produce the same output parameters from a model run during another session by saving output
settings and runtime settingsto a. cnf file.

Run Scenario Mode in Batch Mode

CRiSP.1 can be run in batch scenario mode from a shell which would otherwise not be able to run the model
using the graphical user interface. Please see the Running in Batch Mode section for special instructions on
running CRiSP.1 in batch mode.

1) All parameter data and model settings should be set and saved to files on disk before running
CRiSP.1 in batch scenario mode. See the Run Scenario Mode Interactively section for details on
setting up a Scenario Mode run.

2) You can start batch scenario mode runs from the command prompt by typing any of the following
example commands.
- Unix usingcri spl
crispl -bs
- Unix using the batch mode only program, cri splbat
crisplbat -s -c batch.cnf
- Windows 95/NT using cr i spl (redirects both output streams to the same file)
crispl -bs -f batch.dat 1>output.txt 2>&1
- Windows 95/NT using cri splb (redirects output streams to shell)
crisplb -s -r col unbi a. desc
3) View Scenario Mode Results (summary.dat).

See the Starting from the Command Prompt section for further information on command prompt options for
CRiSP.1.

Warning. Do not quit while the model is running.

Scenario Mode Results (summary.dat)

Results produced by executing CRiSP.1 in Scenario Mode are written to the sunmary. dat file and the
Message Log which includes survival and travel time information for all selected points. Reports of parameter
values used during the most recent Scenario Mode run can be generated from the Input Data Report window
(Analysis menu).

To see the number of fish passing a river segment or dam each day, the cumulative number that eventually
pass over the whole season, and percent survival on a species-specific basis open Passage Histograms by
clicking the desired river segment or dam on the River Map.

Information generated from the run is written to the sunmary. dat file and the Message Log. The output
begins with each Release followed by the survival information for each passage point requested (see Run
Scenario Mode Interactively). Following the release survival information is a summary statement for all

107 CRiSP.1



releases. Any other data you selected in Output Settings, e.g. water temperature, will follow all the release and
surviva information.

Release

- Dam or Reach, Species, Stock
- Start date - first day of initial release
- Released - number of fish in the specific release

Survival Below Reach or Dam Passage Point for Specific Release

- Passed - number of fish exiting the dam or reach.
- Transported Out (transport dam only) - number of fish transported out from the dam

- Vn (transport dam only) - survival fraction for non-transported fish from tailrace of transport dam to
point of transport release based on Simple Mortality model, see Simple Mortality Equation

- FLUSH D (transport dam only) - transport figure of merit based on Simple Mortality model, see
FLUSH Transport Merit Equation

- Survival - percent survival for the release through this river segment (total passage/ tota in)
. stats - see statistics fields below

Summary for all Releases

- Released - total number of fishin all releases
- Passed - total number of fish passed (survived) for al releases
- Survival - percent surviva for al fishin all releases through the whole system

Statistics fields:

- first day - first day of passage

- last day - last day of passage

- total passage - number of fish exiting (surviving) the reach or dam

- mean day - mean passage day

- median day - median passage day

- mode day - mode passage day

. std.dev day - standard deviation of passage

- avg.flow - average flow at a site while fish are migrating

- bypass out - number of fish that survived the bypass route (dam only)
- spillway out - number of fish that survived the spillway (dam only)

- turbine out - number of fish that survived the turbine (dam only)

- transport out - number of fish transported from the dam (dam only)

- total in - total number of fish entering the reach or dam

- bypassin - number of fish entering the bypass route (dam only)

- spillway in - number of fish entering the spillway (dam only)

- turbinein - number of fish entering the turbine route (dam only)

- transport in - number of fish transported to a site and released (reach only)

Sample portion of the sunmary. dat file

CRi SP1 Summary Qutput File
Wed Jun 23 10:49: 36 1999
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Scenari o Mbde

McNary Dam was used as the average flow indicator.

Statistics fields: first day, l|ast day, total passage, nean day
medi an day, node day, std.dev day, avg.fl ow
bypass out, spillway out, turbine out, transport out
total in, bypass in, spillway in, turbine in, transport in
Rel ease: Dwor shak Speci es: Steel head Stock: Ceneric Start date
119 Rel eased: 1192503
Survi val Bel ow Lower Granite Pool
Passed: 1078314
Survi val : 90. 4%
stats: 120 165 1078314. 38 127. 03 126. 33
125. 00 3. 45 238.74 0. 00 0.00 0. 00 0.00
1179277. 88 0.00 0.00 0. 00 0.00
Survi val Bel ow Lower Granite Dam
Passed: 229929
Transported CQut: 783159
Vn: 0. 140
FLUSH D: 0.272
Sur vi val : 19. 3%
stats: 120 160 229928.91 128. 20 127. 24
127. 00 4.05 238. 67 0.00 23894. 62 230001. 47
712674. 81 1054854. 88 783159. 00 24382. 27 247313. 36
783159. 00
Summary for all Rel eases
Rel eased: 4411986
Passed: 1780767
Sur vi val : 40. 4%

Cancda Run

Selecting Run » Cancel Run or clicking x during arun stops both Scenario Mode and Monte Carlo Mode

runs. In addition, the Monte Carlo window includes a“Cancel Run” button to stop Monte Carlo Mode runs.
Monte Carlo Mode runs may take a while to stop processing.

Monte Carlo: Monte Carlo Mode

Selecting Run » Monte Carlo openstheMonte Carlo window for creating, deleting and editing Monte Carlo
alternatives. Monte Carlo Mode runs CRiSP.1 for one or more combinations of water year and system
operations. Flows are specified at dams or reaches and propagated upstream to the headwaters. In each run, a
different flow regime and other model parameters are used. Fish survival is determined for each run and the
distribution of survivasfrom all runs provides an estimate of the probability distribution of survival under the
specified conditions.

The main variable changed in each run is river flow. Flow is generated from runs of the hydroregulation
models maintained by the Army Corps of Engineers (HY SSR) and BPA (HYDROSIM). The hydroregulation
models use historical water data and a projection of electrical demand to simulate system flows, which are
designated a Flow Archive File. These files provide period-averaged flows at operating projects which are
modulated by CRiSP.1 to represent daily flows. CRiSP.1 uses the modulated flows along with a Yearly Input
Data File for each power year to describe the system operations and fish biological parameters to produce
histograms of survival and travel time. The CRiSP.1 distribution includes the “flow.data” directory which
contains weekly averaged flow filesfor each year from 1961 to 1994.
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In Monte Carlo Mode, you can run CRiSP.1 with one or more aternatives. An alternative is afile containing
the flow file name, the number of games (runs), the number of years (power years), and the name of the Yearly
Input Data File to use for each power year in the aternative. The Monte Carlo window contains three panels:
Alternatives to run, Alternative being edited, and Run control. In the following sections, you will find details on
creating, deleting, editing and running Monte Carlo alternatives.

- Create New Alternatives

- Delete Existing Alternatives

- Set Monte Carlo Parameters

- Set Monte Carlo Output and Runtime Settings
- Run Monte Carlo Interactively

- Run Monte Carlo in Batch Mode

- Monte Carlo Results

Create New Alternatives

1) Select Run » Monte Carlo.

2) Click New (upper-right corner of window) to create an alternative.

3) Type the name of new alternative in Monte Carlo Tool dialog box and click OK. The default nameis
al t er n#. It isrecommended to assign a more descriptive name to the alternative to simplify later
interpretation.

4) Follow the instructionsin Set Monte Carlo Parameters.

After you create a new alternative, the Alternatives to run list and the Alternative being edited list in the
Monte Carlo window will update to include the new alternative. At the same time, an al t er n# directory has
been created on disk which contains the Monte Carlo files.

See the Monte Carlo section for the list of related sections.

Delete Existing Alternatives

1) Select Run » Monte Carlo.

2) Select the alternative to be deleted in the Alternative being edited list and click Delete.
3) Click OK inthe Monte Carlo Tool dialog box when prompted, “ Realy delete altern# 7’
After you delete an alternative, the Alternatives to run list and the Alternative being edited list in the Monte
Carlo window will update to reflect this change. At the sametime, theal t er n# directory will be deleted from
disk.

See the Monte Carlo section for the list of related sections.

Set Monte Carlo Parameters

Parameters for each alternative are set in the Monte Carlo window. The Monte Carlo window is divided into
three panels: Alternatives, Alternatives being edited and Run control. Each panel is described separately.
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Monte Carlo window

Alternatives

Inthe Alternatives panel (upper portion of the window), you can select alternativesto run, select an alternative
to edit, Create New Alternatives, and Delete Existing Alternatives. It has the following controls:

- Alternatives to run (1) - Displaysalist of existing alternatives you can edit and run. Selected
aternativesin thislist will be computed when you click Run.

- Current directory (2) - Identifies the working directory where files are located and where output files
will be written, initially thisis the CRiSP home directory.
Go | changes the current directory to adirectory you specified by typing in the text box.

_I browses your loca system to select the working directory. Note. Unix users, this function does

not work properly. Use the text box and Ga | to change working directory.

- New (3) - Opensadiaog box in which you can type the name of a new aternative and adds the new
aternative nameto the Alternatives to run list and the Alternative being edited list (see Create New
Alternatives).

- Delete (4) - Removesthe selected alternative in the Alternative being edited list from disk (see
Delete Existing Alternatives).
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- Rename (5) - Opens adialog box in which you can type the new name for the selected alternative in
Alternative being edited list.

- Alternative being edited (6) - Displaysalist of existing alternatives you can edit. The selected
dternative isloaded into the Alternative being edited panel and isready to be edited.

Alternative being edited

The Alternative being edited control panel displays information based on the alternative selected in the
Alternative being edited list (6) in the Alternatives panel, and sets flow and other model information. It
contains the following controls:

1) Flow from (7) - Specify the source of flow from an archive file or user data.
A. If you select archive as source of flow, follow these steps:
- flow archive - Identify thef | ow. ar chi ve file by typing the name of the file in the text box

and click Use, or by clicking _I to browse your local system to select the appropriate file.
Thisfile must be in aformat that CRiSP.1 can read. The CRiSP.1 distribution includes single
year flow files (flow.data directory) for 1961 through 1994. Flow archive files typically
contain period averaged flows and spills at dams as computed by a hydroregulation model such
as HYSSR or HYDROSIM for anumber of water years, or games, each identified by a year
(e.g. 1938).
- Typically, the archive will contain specifications for spill amounts at each dam. This
information, however, is also specified in the yearly input files. To avoid confusion, CRiSP.1
requires that you decide which spill information to use: the data from the archive or the data
from the . dat file. In the same manner, you will also need to specify the source of the
elevation information.

- Planned spill from (8) - Select source of planned spill information from period averaged data
in the flow archivefile (archive) or from hourly spill in yearly input (11) file (user data).

- Elevation from (9) - Select source of reservoir elevation information from period averaged
elevationin aflow archivefile (archive) or from daily elevationin yearly input (11) file (user
data).

. Customize games (10) - Customize games with this control to run multiple games of different
water years. After you select an archive, thiswindow displaysalist of al the water yearsin the
archive, e.g. 1929:1. Type the preferred number of games for each water year (zero is
acceptable). Select awater year to edit the number of times to run each year in the text box.

Click  <¢== to update the changes to the number of games. Click ====All | to update al

water years for the number of gamestyped into the # games text box. Click Apply All / Apply
to save changes made to the alternative.

B. If you select user data as source of flow, follow these steps:

- Planned spill and Elevation dataare automatically read from a Yearly Input Data File. Use
Spill Schedule and Elevation windows, respectively, to change the values and make sure to
save your changesto the yearly input datafilesthat will be used. The changes must be saved to
disk.

- # games (10) - set the number of games to run for each yearly input datafile. Apply the
changes by clicking Apply. You must first turn off variance suppression in Runtime Settings
(Run menu) and save the settings to the yearly input data file being used.

2) yearly input files (11) - Specify a Yearly Input Data File to be used for each power year in the
aternative. You can specify any number of yearsfor the alternative. Yearly input datafiles contain all
the parameters that describe fish behavior, reservoir properties, spill schedules, elevation and loss
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information, dam parameters, releases, and river information. You can use a Control File to "mix and
match” pieces of information from various files. Once you have put together the pieces of interest, it
is recommended that you write this information to aseparate . dat filefor later use.

- Use # files (12) - Specify the number of years to be used in the alternative by typing the number
in the text box and clicking Use. Theyearly input files list will update to contain the specified
number of entries. If you want to specify only one year, you do not need to enter avaluein this
box.

- filename (13) - Select alinein the yearly input files list and identify the yearly input file by
typing the name of the file in the text box or by clicking _I to browse the local file system to
select afile. Click ~ <<==  to update the yearly input files list with your selection. Click

o ==All | to update al yearly input file entries to use the file specified in the text box even if

other selections have already been applied. Click Apply All / Apply to save changes made to
the alternative.

Run control

The Run control panel displaysinformation about the alternatives and the status of a Monte Carlo run. It has
the following controls:;

- Alt Games (14) - Identifies the number of model runs to be completed for each year input datafile of
the alternative selected in the Alternative being edited list. After Run execution has begun, the
display will update the information and status of completion of the alternative being run.

Note. Thisis not the total number of gamesto be run when Monte Carlo is started.
- Alt Years (15) - Identifies the number of years to be run of the alternative selected in the Alternative

being edited list. After Run execution has begun, the display will update the information and status of
completion of the alternative being run.

Note. Thisisnot the total number of yearsto be run when Monte Carlo is started.

- Alternatives (16) - Identifies the total number of alternatives to be run determined by the aternatives
highlighted in the Alternatives to run list.

- Lock current output settings check box (17) - If selected (on), output settings specified in the Output
Settings windows will override any output settings specified in the yearly input data files for each
Monte Carlo alternative run. Lock current output settings is paired with Lock Output Settings (Run

menu). You can turn the option on or off in by selecting Run » Lock Output Settings or selecting
Lock current output settings (i.e. making a selection in either place automatically updates both).

- Write supplemental data check box (18) - If selected (on), CRiSP.1 writes M essages from Log
Window to thesummar y. al t er n# file on disk (default setting is off).

- Run (19) - Startsthe Monte Carlo Mode run using the alternatives highlighted in the Alternatives to
run list. See the Run Monte Carlo Interactively, Run Monte Carlo in Batch Mode and Set Monte
Carlo Output and Runtime Settings sections for important information about running CRiSP.1in
Monte Carlo Mode.

- Cancel Run (20) - Stops the Monte Carlo run currently in progress. It may take some time for the
model to stop a Monte Carlo run process.

The Monte Carlo window a so includes the following:

- Help: opens context-sensitive help information.
- Reset All, Apply All, Reset, Apply, Cancel, OK.

See the Monte Carlo section for the list of related sections.
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Set Monte Carlo Output and Runtime Settings

When running in M onte Carlo mode, anumber of results are cal culated by the model, but only those requested
by you will be available following the run. Before starting aMonte Carlo simulation, al output dataand runtime
settings must be specified.

Output Settings

To view and analyze survival and travel time information for any point in the river, the appropriate passage
points must be specified before the run. Other output data also must be specified including water temperature
and the average flow experienced by fish between the mean release date and mean passage date to any point in
the river. There are two ways to save output data from Monte Carlo runs.

Y ou can specify the output settings in each yearly input datafile before running Monte Carlo alternatives.

1) Select File » Open and select ayearly input data file specified in the Monte Carlo alternative.

2) Select Run » Output Settings and set the desired optionsin the Output Settings for Dams, Output
Settings for Reaches and Output Settings for Headwaters windows.

3) Select File » Save As to save the yearly input data file to disk.
4) Repeat steps 1-3 for each yearly input data file specified in the alternative.

OR

Y ou can Lock Output Settings during the run.

1) Select Run » Output Settings and set the desired optionsin the Output Settings for Dams, Output
Settings for Reaches and Output Settings for Headwaters windows.

2) Select the Lock current output settings check box in the Monte Carlo window to override any
output settings specified in the yearly input datafiles for each Monte Carlo simulation. Thisis the

same as selecting Run » Lock Output Settings.

Runtime Settings

CRIiSP.1 can be run with different functions that effect the movement and surviva of fish through the river
system. Any specifications for Runtime Settings must be selected, applied and saved to the appropriate yearly
input data files before running Monte Carlo.

For example, if you forget to turn off variance suppression in aparticular yearly input datafile, you need to:

1) Select File » Open and select the yearly input data file being used in alternative to read the file into
CRiSP.1.

2) Select Run » Runtime Settings.
3) Turn off variance suppression and click OK.
4) Select File » Save As to save the yearly input datafileto disk.

After making al settings for parameters and output for each aternative, you are ready to Run Monte Carlo
Interactively or Run Monte Carlo in Batch Mode.

See the Monte Carlo section for the list of related sections.
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Run Monte Carlo I nteractively

The steps to run CRiSP.1 in Monte Carlo Mode are as follows:

1) Select Run » Monte Carlo to open Monte Carlo Tool.

2) Edit aternatives, if necessary, using the three panels of the Monte Carlo window described in Set
Monte Carlo Parameters.

3) Set Monte Carlo Output and Runtime Settings.

4) Select each desired alternative in the Alternatives to run list; you can run multiple alternatives at the
sametime.

5) Select if supplemental dataisrequired. The Write supplemental data check box islocated in the
Run control panel. Thiswill produce asunmary. al t # filewith all the data specified by Output
Settingsin the yearly input data files for each aternative in the run. In addition, you can choose to
have thisinformation also recorded in the Message L og by turning on Messages (this produces a
considerable amount of information in the log window).

6) Click Run. The Run control panel contains three progress bars: Alt Games, Alt Years, and
Alternatives.

7) View Monte Carlo Results.

Monte Carlo runs are time-consuming. A 500-game run may take several hours, or more, to run. It is
recommended to select several alternativesto run, start therun, and let it run overnight. Y ou can shrink CRiSP.1
into an icon whileit is running. Do not quit while the modé isrunning.

See the Monte Carlo section for the list of related sections.

Run Monte Carlo in Batch Mode
M onte Carlo alternatives can berun in batch mode. The stepsto running CRiSP.1 in batch mode are asfollows:

1) Usethe graphical user interface to Create New Alternatives and Set Monte Carlo Parameters, making
sure to specify the flow archive, the yearly input data files, and the desired output data. All
alternatives must be saved on disk.

2) Create or modify afilenamed . cri spl-al t s. Thefile must exist in the same directory where your
CRiSP.1 program and all the aternatives reside. The model will run all the aternatives listed in the
.crispl-alts filebefore concluding. Thisfile can be created using any text editing toal. It simply
contains alist of the names of the alternatives to be run, one on each line. For example,

alternl
altern2

3) Once you create your alternativesand a. cri spl-al t s filein place, CRiSP.1 can be runin batch
mode from a shell which would otherwise not be able to run the model using the graphical user
interface. Batch mode is executed from the command prompt. Please see the Running in Batch Mode
section for special instructions on batch mode operations. You can start batch monte carlo mode runs
from the command prompt by typing any of the following example commands.

- Unix usingcri spl
crispl -b -u

- Unix using the batch mode only program, cri splbat
crisplbat -c batch. cnf

- Windows 95/NT using cr i spl (redirects both output streams to the same file)
crispl -bm 1>output.txt 2>&1

- Windows 95/NT using cri splb (redirects output streams to shell)
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crisplb -r colunbia.desc -u
4) View Monte Carlo Resullts.

See the Starting from the Command Prompt section for further information on command line options for
CRiSP.1.

Monte Carlo runs are time-consuming. A 500-game run may take several hours, or more, to run. It is
recommended that you select several alternativesto run, start therun, and let it run overnight. Windows 95/NT
users, do not quit while the model isrunning.

See the Monte Carlo section for the list of related sections.

Monte Carlo Results

CRIiSP.1 contains three tools in the Analysis menu for interpreting the results of Monte Carlo simulations and
analyzing and comparing Monte Carlo runs.

- Monte Data Report - View and print data produced by Monte Carlo runs; summarize results from
runs. Only output data requested before run execution will be available for viewing and printing. See
the Set Monte Carlo Parameters section for more details.

- Monte Alt. Comparison - Compare two alternatives.
- Monte Analysis- Analyze asingle alternative and view survival and travel time histograms.

See the Monte Carlo section for the list of related sections.

L ock Output Settings

Selecting Run » Lock Output Settings turns on or off the Lock Output Settings feature. When running in

either Scenario or Monte Carlo mode, anumber of results are calculated by the model; however, only the output
data you have specified will be available following the run.

When Lock Output Settings is not selected (off), CRiSP.1 will use the output settings specified in a yearly
input datafile or . cnf fileto determine which results will be available to view and analyze after arun. Be sure
to specify the desired outputs and save them to the yearly input data files to be used in the Monte Carlo
aternatives. For Scenario Mode runs, you can view the output either in histograms, e.g. Passage Histograms, or
in the Message Log. For Monte Carlo Mode runs, you can view the output with the Monte Data Report and
Monte Analysis under the Analysis Menu.

When selected (on), CRiSP.1 will override all output settings specified in any parameter data files read into
the model or read during interactive Monte Carlo simulations. Instead, CRi SP.1 will generate output datafor the
current selections in the Output Settings windows for dams, reaches and headwaters. This allows a user, for
example, to change the output data produced by a Monte Carlo run without editing all of the yearly data files
used by that run.

In Monte Carlo Mode, this feature can be used both in batch mode and interactively. In batch mode, the
command option - ¢ out put _control _fil e can be used to override any output settings for an individua
dternative. Intheinteractive mode, the locking option can be set using this feature or by selecting the check box
Lock current output settings inthe Run control panel of the Monte Carlo window. The current output settings
specified in the Output Settings windows for dams, reaches and headwaters will be used during run execution.
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Output Settings: Specifying Desired Outputs

Selecting Run » Output Settings opens three windows for configuring dam, reach and headwater output to

save for examination after run completion: Output Settings for Dams, Output Settings for Reaches and
Output Settings for Headwaters. When running in either Scenario or Monte Carlo mode, a number of results
are calculated by the model; however, only those requested by you will be available following the run. For
Scenario Mode runs, you can view the output either in histograms, e.g. Passage Histograms, or in the Message
Log. For Monte Carlo Mode runs, you can view the output with the Monte Data Report and Monte Analysis
under the Analysis Menu.

Note. Be sure to specify the desired outputs and save them to the yearly input data files to be used
in the Monte Carlo alternatives or use the Lock Output Settings feature.

Output Settings for Dams
For Dams, you can select to record output from the following parameters.

- Passage - total fish passage (survival)
- Transport - total fish transport passage and percent of total run

- Routing - total fish passage through turbine, bypass and spillway routes at the dam and the percent of
total run

- Flow - flow (in kcfs) exiting a dam based on headwater input flows and reservoir losses

- WTemp - daily water temperature at the dam based on water temperature set in the headwaters

- TDG Sat - level of total dissolved gas saturation above 100% exiting a dam for both powerhouse and
spill flow

- Spill - day-averaged spill fraction at a dam

- Flow Ind. - Flow Indicator dam keeps track of the average flow at the indicator dam during passage of
the various stocks. Only one dam can be selected as the flow indicator.

Click the check boxes to select the desired outputs. A whole row or column can be selected by clicking the all
check box in a dam row (selects all parameters for that dam) or parameter column (selects all dams for that
parameter). All check boxes can be selected by clicking the all column check box in the all row.
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Output Settings for Dams window

Output Settings for Reaches
For Reaches, you can select to record output from the following parameters.

- Passage - total fish passage through the reach and the percent of the total run
- Flow - flow (in kcfs) exiting a reach
- WTemp - daily water temperature in the reach based on water temperature set in the headwaters

- TDG Sat - level of total dissolved gas saturation above 100% exiting a reach for both left-bank and
right-bank flow

- Velocity - daily river velocity in miles per day based on water elevation, bathymetry and daily flow
level

- Loss - flow lossin ariver segment due to withdrawal, mainly from irrigation, and groundwater input
(flow returned to the segment)

- Elevation - the mode used to run CRiSP.1 determines how elevation is calculated. In Scenario Mode,
daily elevation is based on user input. In Monte Carlo M ode, elevation is input from either the
f1 ow. archi ve fileif it contains reservoir elevation or from specified yearly input files specified by
you.

Click the check boxes to select the desired outputs. A whole row or column can be selected by clicking the all
check box in areach row (selects all parameters for that reach) or parameter column (selects all reaches for that
parameter). All check boxes can be selected by clicking the all column check box in the all row.
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| Rezet | Apply | Cancel | Ok |

Output Settings for Reaches window

Output Settings for Headwaters
For Headwaters, Flow and Water Temperature are the only available output parameters.

- Flow - the mode used to run CRiSP.1 determines how headwater flow is created. In Scenario Mode,
daily flows are based on specified input flows or randomly set using the Headwater M odulation
function. In Monte Carlo Mode, headwater flows are calculated from flows at the dams asinput by the
f1 ow. ar chi ve file, or as specified in the yearly input datafile(s) used for the alternative.

- WTemp - daily headwater temperature based on user input.

Click the check boxes to select the desired outputs. A whole row or column can be selected by clicking the all
check box in a headwater row (selects all parameters for that headwater) or parameter column (selects all
headwaters for that parameter).
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Output Settings for Headwaters window

Runtime Settings. Different Model Configurations

Selecting Run » Runtime Settings opens a window for specifying several functional relationships for run

execution. CRiSP.1 can be run with different functions that effect the movement and survival of fish through the
river system. Settings are selected or cleared by clicking the respective check box. Each relationship is described
in the following sections. Any Runtime Settings you want to take effect during a Monte Carlo Mode run must
be applied and saved to ayearly input datafile (. dat or . cnf) specified in the Monte Carlo adternative.

- variance suppression

- predator density / volume interaction
- age dependent fge

- Mortality Model
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Runtime Settings window

variance suppression

The variance suppression option in Runtime Settings controls the stochastic parts of the model. When
variance suppression isturned on, each subsequent run of the model uses exactly the same value for
parameters that would otherwise be drawn from a distribution (the term becomes deterministic). Thisis useful
for doing quick tests of sensitivity. By default, it isturned on. Variance suppression should be turned off when
running multiple games in Monte Carlo Mode. Any Runtime Settings you want to take effect during a Monte
Carlo Mode run must be applied and saved to a yearly input data file (. dat or . cnf) specified in the Monte
Carlo aternative.

Predation Coef, Migration Rate Variance, Mortality, and FGE are examples of stochastic parametersin
CRIiSP.1. Each window contains sliders for setting the mean, low, and high values by species or by dam and
species. When the low and high values are set to zero or the low and high are set to the mean value, CRiSP.1
uses the mean value at all times (the term becomes deterministic). When the low and high values are not equal,
CRIiSP.1 uses the mean, low and high values to randomly generate a value when executed with variance
suppression turned off. With variance suppression turned on, CRiSP.1 uses the mean value and ignores the
high and low values. In either case, the mean value must lie within the central two quartiles of the distribution
(the middle 50%). For example, if thelow valueisset to 0 and the high valueis set to 100, the mean value must
be set between 25 and 75. If values are set that do not conform to thisrestriction, CRiSP.1 will abort the run and
generate an error message in the Message Log (if open) specifying which parameters have bad values.

ERROR bad stochastic paramreach pred coeff for Chinook O.
-->mean not in range 12.386550 <= nmean <= 17.341249
ERROR aborting run due to bad paraneter val ues.

predator density / volume interaction

Thepredator density/volume interaction option in Runtime Settings servesto increase the mortality rate due
to predation in CRiSP.1 runs. This runtime setting allows you to specify that predator density should increase
as pool volume decreases, that is when the pool is drawn down. This interaction is based on the possibility that
concentrating predatorsin adam forebay or tailrace increases the encounter rate between predators and prey and
thus effectively increases the mortality rate.

If predator density/volume interaction is selected (on), predator density is a function of pool elevation for
reservoir, forebay and tailrace regions. This setting increases the effective predator density as pools are lowered
which in turn increases the predation rate. By default, this option is turned off.
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Any Runtime Settings you want to take effect during a Monte Carlo Mode run must be applied and saved to
ayearly input datafile (. dat or. cnf) specified in the Monte Carlo alternative.

age dependent fge

The age dependent fge option in Runtime Settings specifies one of two possible functiona relationships for
fish guidance efficiency (fge): constant fge or time varying fge. When age dependent fge is turned off, the
model will use the constant fge condition and the values set in the FGE window. Day and night fge then vary
randomly on each dam timeinterval according to fixed probability distributions (the distribution has no seasonal
trend). Fgeis specific to agiven dam and species and its random variations occur for each dam time interval (6
hours).

When age dependent fge isturned on, the model run varies fge at dams according to the settings in the FGE
Equation window and the mean, low and high fge values set in the FGE window. When the model is run under
this condition, day and night fge change randomly at each dam time interval according to probability
distributions that change with fish age and reservoir elevation. Variations in fge from the initial condition
depends on the day since the onset of smoltification which is set in the Release Tool window, and reservoir
elevation for each day which is set with the Elevation window.

Any Runtime Settings you want to take effect during a Monte Carlo Mode run must be applied and saved to
ayearly input datafile (. dat or. cnf) specified in the Monte Carlo alternative.

Mortality Model

The Mortality Model option in Runtime Settings specifies which of the two mortality modelsto use during run
execution: Gas and Pred Mortality or Simple Mortality. CRiSP.1 is currently calibrated for the Gas and Pred
Mortality model.

- Gas and Pred Mortality - Uses a predation model and new gas model to calculate mortality due to
predation and gas based on parameter settings from several windows. Reach Predator Density,
Predator Distribution Coefficient, Predation Temperature Response Equation, Gas Mortality
Equation, and Predation Coef for reaches, forebays, and tailraces.

- Simple Mortality - See Simple Mortality Equation under the Behavior Menu for details. Thisoptionis
based on the FLUSH Model.

Any Runtime Settings you want to take effect during a Monte Carlo Mode run must be applied and saved to
ayearly input datafile (. dat or. cnf) specified in the Monte Carlo alternative.

Analysis
The Analysis menu providestools to analyze CRiSP.1 results.

« Input Data Report

- Monte Data Report

- Monte Alt. Comparison
- Monte Analysis

Input Data Report: Input Report Tool

Selecting Analysis » Input Data Report opens the Input Report Tool for generating lists of model
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parameters. This tool provides an easy way for you to determine the precise values currently in memory in
CRIiSP.1 and what values would be used in a Scenario Mode run. Y ou can write the parameters val ues into tables
that can be viewed on the screen, saved to afile, or printed. Any groupings of data can be written into the tables
using the Input Report Tool. The Parameter Glossary contains definitions for al the parameters found in the
Input Report Tool except for theindividual parameters used in each model equation.

A similar option is available for batch mode runs using the - o out put _fi | e argument to generate a
parameter datafile. See Starting from the Command Prompt section for more information.

Input Report Tool features

. Category - Select the types of information that will be reported: dam/species, dam, headwater,
reservoir, global, species, and transport. To view selections made from multiple categories, select each
category of interest and highlight the desired parameters. When all the parameters of interest have
been selected, click View All to generate areport for al selections.

- Line Length - Specifies the line length of datawritten to the Output Window.

- View - Opens the Output Window, atext window containing the values for the parameters selected
under the currently highlighted category.

- View All - Opens the Output Window, atext window containing the values for the parameters selected
under all categories.

. Clear - Clears selections for the current category.

- Clear All - Clearsal selections for al the categories.

- Done - Closes Input Report Tool.

- Help - Displays context-sensitive help information.

- Parameter - Select parameters by clicking on an item. Click on a selected item to clear it. Thelist of
parameters is determined by which category is selected in Category. CRiSP.1 keeps in memory the
selections made in the Input Report Tool for al categories for the duration of the session or until
selections are cleared by clicking Clear or Clear All. Thisisto facilitate generating reports of the same
parameters for multiple data files and multiple runs.
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Input Report Tool

Cateqgary:

Line Lenath:

80

View | Viewal | Clear | Clearal | Done | Heln |

= E3

Dams Species

Bonneville Dann Chinaak. 0 spill_mort_mean -
Bonneville Dam 2 Chinoaok. 1 =pill_rnort_low —
The Dalles Dam Chinook. Summer spill_rmort_high

John Day Dam Steelhead bypaszs_mort_mean

kM amy Dam
Priest Rapids Dam
‘wanapumn D ann
Rock lsland Dam
Rock Island Dam 2
Rocky Reach Dam
wiells Diam

Chief Jozeph Dam
|ce Harbor Dam
Lower Monumental D am
Litlle Goose Dam

bypazs_mort_low
bwpaszs_mort_high
turbire_rnart_mean
turbire_mart_low
turbire_mort_high
tranzport_mork_rean =
tranzport_rmort_low
trangpart_mmart_high
separation_prob
mean_forebay_transit_time
day_fge_mean

Lower Granite Darm day_fae_low

Hells Canyan Dam day_fge_high

Dwarshak Dam night_fge_mean
night_fge_low -
ikt Faa hink

1| | > 1] | 3|

Input Report Tool for generating tables of model parameters

Monte Data Report: Monte Report Tool

Selecting Analysis » Monte Data Report opensthe Monte Report Tool for generating summary reportsfrom
Monte Carlo runs that are tailored to individual needs.

M onte Report Tool features

Category - Unavailable.

Line Length - Specifies the line length of datawritten to the Output Window.

View - Opens the Output Window, atext window of the parameters selected in the currently
highlighted category.

View All - Unavailable.

Clear - Clears highlighted selectionsin al four columns.

Clear All - Unavailable.

Done - Closes Monte Report Tool.

Help - Displays context-sensitive help information.

Altern Years - Select the alternative years of interest from the list of alternatives available for anaysis
in the CRiSP.1 home directory.

Releases - Select the releases of interest from the list of releases that are available for analysis.

Segments - select the segments of interest from the list of sitesthat are available for analysis. Thelist
is based on siteswhere data was stored in the Monte Carlo runs. Thiscolumn lists ALL sitespresent in
ANY of the alternatives, some alternatives may not have the same sites as others, and the report tool
will skip lines or leave output values blank for those cases.
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- Parameters - Select the parameters of interest from the list of parametersthat are available for
analysis. Similar to Segments, thislist includes all parameters present in any of the alternatives, so
some parameters may not be available for some alternatives.

The amount of time required to generate output from this tool depends on the number of alternatives and the
number of games in each alternative. CRiSP.1 keeps in memory the selections made in the Monte Report Tool
for the duration of the session or until selections are cleared by clicking Clear. Thisisto facilitate generating
reports of the same parameters for multiple Monte Carlo runs. During a session, CRiSP.1 attempts to preserve
sensible selections if new model runs are performed, alternatives are deleted, or the working directory is
changed.

Monte Report Tool ME E
Categon: Ialtems vI Line Length: [ -
View || wiEmal Clear sl | Done | Heln |
Altern Years Feleazes Segments
alternl, year 1 WWild Shake B Stocks(Chinoo Bonneville Tailrace Mean_passage -
alternz, year 1 *wild Skake B Stocks(Chinoo) Baonneville Dram pazzage_std dev
alterna, year 1 *WWild Snake B Stocks(Chinoo) The Dalles Dam pazsage_coefl_varance
Wild Snake B Stocks[Chinoo John Day Dam pazsage_skew
WWild Snake B Stocks[Chinoo kM amy Dam pazzage_kurtosiz
YWild Snake B Stocks(Steelhy |ee Harbor Dam mean_travel_time
Wild Shake B Stocks(Steelhd Lawer Monumental D arn travel_time_std_dev
WWild Snake B Stocks(Steelhd Litlle Goose Dam travel_time_coeff_varianc
Wild Snake B Stocks[Steelhy Lower Granite Dam travel_time_skew
WWild Snake B Stocks[Steelhy travel_time_kurt

average flow
bypazs_pazzage
turbine_passage
spill_paszage
transport_paszage
premart_transport_total
poztmort_tratizport_tatal
fpe

bypaszs_input -
Hirhine ine ik
1| | 3 1| 3 4 r | 3|

Monte Report Tool for generating model output reports

- mean_passage, passage_std_dev, passage_coeff variance, passage_skew, passage kurtosis. Statistics
for the survival of the release for the passage point.

- mean_travel_time, travel_time_std_dev, travel_time_coeff_variance, travel_time_skew,
travel_time_kurt: Statistics for the travel time of the release from the point of release to the passage
point.

- average flow: An average water flow at the indicator dam during passage of the various stocksiif a
Flow Ind. dam was selected in Run » Output Settings. The average is taken over the period of time

in which the fish traveled from release to the passage point. Only one dam can be selected as the flow
indicator.

- bypass_passage: Percent of the release that survived that passed the dam through the bypass.

- turbine_passage: Percent of the release that survived that passed the dam through the turbine.

- spill_passage: Percent of the release that survived that passed the dam through the spillway.

- transport_passage: Percent of the release that survived transport collection at the dam.

- premort_transport_total: Number of fish in the release which were captured for transport.

- postmort_transport_total: Number of fishin the release which survived transport to the release point.
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- fpe: Fish passage efficiency.

- bypass_input: Percent of the release that entered the bypass route.
- turbine_input: Percent of the release that entered the turbines.

- spill_input: Percent of the release that entered the spillway.

- project_input: Number of fish entering the dam segment.

Output Window

Selections made in either in the Input Report Tool or the Monte Report Tool are displayed in the Output
Window when you click View or View All. Information in the Output Window can be printed, saved to afile, or
copied to afile.

Output Window features
- File
- Save As - Saveinformation to atext file in the CRiSP.1 home directory (the directory from
which CRiSP.1 was started) or another location on your local system.

- Print - Print the information displayed in the Output Window.

- Close - Close the Output Window.
- Edit

- Copy - Copy selected text to another document.

- Select All - Select all text in the window in order to copy the results into another document.
- Help - Open context-sensitive help window.

Dutput Window | [O] x|

File Edit Help

f============================================================================

t Report Data CRiSF w1.6.0 (WIH3Z2)

L3

#Written on Thu Jun 17 18:55:28 1999

#============================================================================}
spill bypa=s turbine dav night
mort mort mort fge fge
nean nean mean nean mean

Bonnewille Dam

Chinook 1 0.0z 0.02 o.o7 0.30 0.30
HcHary Dam
Chinook 1 o.0z n.0z2 o.o7 o7z 0.7z
Lower Granite Dam
Chinool 1 n.0z n.0z o.ov 1.00 1.00
K| 2l
Output Window

Monte Alt. Comparison: Comparing Two Distributions

Selecting Analysis » Monte Alt. Comparison opens the Alternative Comparison window for comparing

two alternatives. Y ou can compare two aternatives to determine if the probability distributions are statistically
different.
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Alternative Comparison features
- Alternative 1 and 2: Select alternatives to be compared.
- Year: Select (power) year for each aternative.
- Release: Select release points for each alternative.
- Passage Point: Select passage point.
- Data Type: Select Survival or Travel Time.
- Compute: Performsthe Kolmogorov-Smirnov test for the selections made.
- Done: Closes the Alternative Comparison window.
- Help: Opens context-sensitive help window.

The Alternative Comparison window uses the Kolmogorov-Smirnov test. The null hypothesis tested is that
the two distributions are drawn from the same population, i.e. they are identical. To test this hypothesis, the d
statisticisused. Resultsfrom the Kolmogorov-Smirnov test are displayedin the lower-1eft corner of the window.

. The d statistic is the maximum val ue of the absolute difference between the two cumulative
distributions being tested.

- Theprobability measure isthe fraction of times that a sample drawn from a distribution would be less
than d if the two distributions were the same.

Probability (d > observed by chance if pdf the same)

The closer the probability isto zero the more likely the two distributions are statistically different. Asatypica
example, we would reject the hypothesis that the two distributions are the same for probability < 0.01.

[ Alternative Comparison ME E
Alternative 1 Alternative 2
Ialterrﬂ j Ialtem2 j
Year: |-| vI el |-| vl
Rielease: {\/id Snake A Stocks (Chinook 1] 7] Releass:  [yyid Snake i Stocks (Chinock 1] |
Pazzage Paint: |McN ary Dam j
[Data Type:
Kaolmogoroy - Smirnaoy test € Survival
T | Ti
probabilty: 0.004403 d: 0322034 favE e
Help Done

Alternative Comparison window

Monte Analysis. Monte Analysis Tool

Selecting Analysis » Monte Analysis opens the Monte Analysis Tool and its companion window the
Analysis Tool graph window. Using these windows, you can visually examine the results of aMonte Carlo run.
You can plot either the survival or travel time results as a straight frequency histogram or as a cumulative
probability histogram.
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Monte Analysis Tool features

- Alternative: Select an Alternative from the list of possible alternativesin the CRiSP.1 home directory
(the directory from which CRiSP.1 was started).

- Year: Select Year for the dternative.

- Release: Select Release for the dternative.

- Passage Point: Select Passage Point for the alternative.
- Data Type: Select Survival or Travel Time.

- Graph Type: Select Frequency or Cumulative.

- Histogram Statistics

- Mean, Std Dev, Coeff Var, Skew, Kurtosis. Statistics for survival or travel time depending on
the Data Type selection.

- # of Games. Number of games completed in the selected alternative.
- Day of Passage
- Mean, Median, Mode, Std Dev: Passage statistics for the release at the passage point.
- First: First day of passage for the release at the passage point.
- Last: Last day of passage for the release at the passage point.
- Route Passage Fractions
- Bypass:. Percent of the release that survived that passed the dam through the bypass.
- Turbine: Percent of the release that survived that passed the dam through the turbine.
- Spillway: Percent of the release that survived that passed the dam through the spillway.

- Transport: Percent of the release that survived the entire transportation process from the dam to
therelease site.

- FPE: Fish passage efficiency.

- Premort Transport: Number of fish in the release which were captured for transport.

- Postmort Transport: Number of fish in the release which survived transport to the rel ease point.
- Histogram Control

- Bin Size - set the size of each bin for survival histogram. In the example, the bin size is set to
.02 (2%) for the survival histogram. The X-axis rangeisfrom 0to 1 (0 to 100%). Each bar in
the histogram represents 2%. With the bin size set to 2%, the games of the alternative are
divided into 50 bins. The histogram represents what percent of the games (Y-axis) in the
aternative fell within each 2% range. For travel time, the Bin Size entry field has been
deactivated; the bin sizeis set to 1.

- Print: Opens the Output Window with the survival or travel time statistics. Use the functions of the
Output Window to print the information or saveit to afile.

- Plot: Calculates survival or travel time statistics and draws graph in the Analysis Tool graph window
based on the sel ections made.

- Help: Opens context-sensitive help window.
- Done: Closes Monte Analysis Tool window.
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™ Monte Analysis Tool ME E

Alterrative lternd -
Ia il J Data Type Graph Type
earn I -I )
S | " Supvival ' Frequency
Release: [yyid Snake R Stocks [Chinook 11 ||| ) Travel Time ' Cumulative
Pazzage Paint: IMcNal_l,J Dam j
— Hiztogram Statistics —Day of Passage———— [~ Route Paszsage Fractions
tean: 7.54 tean: 131.04 Bypazz: 51.49
StdDew: 549 tedian: 130.69 Tuirbire: 1.97
CoeffWar, 073 b ode: 13036 Spillvsay: 4654
Skew: 1.2 First: 121.33 Trangpork:  0.00
Furtosis: -1.42 Last; 14796 FFE: 97.86
# of Gamesz 53 Std Dew: 315 Fremaort 0.0
Tranzport: -
— Hist Cantrol Paostrort
istogram Contra Transport 0.00
Bin Size: 0.0z
Frirt Help Diane
Monte Analysis Tool
Analysis Tool

Selecting Analysis » Monte Analysis opensthe Analysis Tool graph window and its companion window the

Monte Analysis Tool for visualy examining the results of aMonte Carlo run. The Analysis Tool graph window
has the same features as a Julian Day Output window; however, Julian days are not the unit of measurement for
the X-axis. Survival or travel time between the point of release and points downstream can be viewed as either
a histogram or cumulative distribution based on the selections made in the Monte Analysis Tool window.

By selecting Survival or Travel Time for Data Type and clicking Plot inthe Monte Analysis Tool, afrequency
histogram or cumulative probability distribution of survival or travel time between release and river segment
can be opened for passage points of any release.

- Julian Day Output Viewing Features
- Julian Day Output Additiona Features
- Survival Graph
- Y-axis - percent of games falling within the range of each bin
- X-axis - percent survival for the release through the segment for the selected alternative
- Bin Size set in the Monte Analysis Tool determines the size of each bin. In the example, each
binis 2% and
. 20.34% of the games fall within the survival range of 0-1%
- 11.86% of the gamesfall within the survival range of 1-3%
. 13.56% of the games fall within the survival range of 3-5%
- 11.86% of the gamesfall within the survival range of 5-7%
- 6.78% of the games fall within the survival range of 7-9%
- 5.08% of the games fall within the survival range of 9-11%
- 11.86% of the gamesfall within the survival range of 11-13%
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- 13.56% of the games fall within the survival range of 13-15%
- 5.08% of the games fall within the survival range of 15-17%
- Travel Time Graph
- Y-axis - percent of games falling within the range of each bin (1 day)
- X-axis - travel timein daysfor the release from the rel ease site through the river segment for the

selected alternative
Anal_l,lsis Tool | [O] x|
Done | X:0.43 Y:11.98 H|&| 7| =
Ymax:l] 0.00 Ymin:lu_uu EI ml :I:l Rndl /\/||1J'|_||'|-|'|| ul EI
alternl, year 1, Survival Analysis
20.34 1
1356 7| M
B.78
0.00 —‘ I
a 1
Wild Snake R Stocks (Chinook 1) at McrMary Dam
. percent

Monte Analysis Tool Survival histogram

Help

The Help menu contains the major categories of the Help system.

- Contents: Opens the table of contents for Help system.

- Introduction: Opens the Introduction section which provides introductory and background
information about the CRiSP.1 model.

- Getting Started: Opens the Getting Started section which details the features and functions of the
CRiSP.1 model.

- Glossary: Opens the Keyword Glossary section which is aglossary of terms used in CRiSP.1.

- Parameter Glossary: Opens the Parameter Glossary section which isa glossary of parameters found
in the two key filesused by CRiSP.1: col unbi a. desc and base. dat .

- Technical Details: Opens the Technical Details section which contains descriptions of the three key
filesused by CRiSP.1 (col unbi a. desc, base. dat, and f | ow. ar chi ve) and the CRiSP.1 Parser.

- About CRiSP1: Opensawindow displaying the version number of CRiSP.1 currently running.

The Help system window has five navigation functions:
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- Contents: Returns to the Help table of contents page.

- Back: Displaysthe previously viewed page. This may be different from the Previous page if you
followed alink (blue, underlined text) on a page.

- Search: Allowsyou to select atopic from alist of topicsin the Help system.
- Prev: Displaysthe previous page within the Help system.
- Next: Displaysthe next page within the Help system.
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Keyword Glossary

- anadromous fish: Fish such as salmon or steelhead that hatch in freshwater, migrate to the ocean
where they mature, and then return to freshwater to spawn.

- bubble entrainment: The capture of bubbles into moving water, from the surface to the depths, at
dam intakes and diversions.

- bypass: A channel or conduit designed to route juvenile fish around the dam’s turbines.

- chinook 0: Subyearling chinook smolts. Also known as fall chinook for the season when the adults
run.

- chinook 1: Yearling chinook smolts. Also known as spring chinook for the season when the adults
run.

- coeff variance: Coefficient of variation (cv). The standard deviation divided by the mean.

. dam: Federally funded and maintained dams on the Snake and Columbiarivers.

- didl: Varying on aday/night basis, e.g. “diel variation in fge.”

- entrainment: Gasis added into the powerhouse flow, increasing the level of total dissolved gas, asthe
result of the amount of spill going over the spillway into the tailrace of the dam.

- fge: Fish Guidance Efficiency (fge) is the percentage of total number of juvenile fish approaching a
turbine intake that are successfully “guided” away from the turbine by a guidance device such asa
submersible traveling screen.

- forebay: Portion of the reservoir from which water is taken to run the turbines of a dam.

- gasbubble disease: Adverse effect to fish caused by absorbing dissolved gas from supersaturated
water.

- headloss. The difference between the elevations of surfacesin avolume of water before and after
drawdown in the flow.

- headwater: The source and extreme upper reaches of a stream or river.
- hydraulic capacity: The maximum flow a dam can pass through its turbines.

- HYDROSIM: A model that produces estimated flows at points along the Columbia and Snake Rivers
based on power and flood control requirements. This model isadministered by the BPA for use by the
River Operations System Experts (ROSE) Group.

- hydrostatic pressure: The pressure exerted or transmitted by water at rest.

- HYSSR: HY dro System Seasona Regulation model, simulates power generating and flood control
characteristics of the Columbia/Snake Basin, producing predicted flows at federal projects along the
river. This model is administered by the Army Corps of Engineers.

- input: Refersto datain afilethat isread by CRiSP.1 to set certain values when the model isrun. It
aso refersto any addition or change in the number or va ue of something, such as “input of fishto a
reservoir.”

- kcfs: Thousand cubic feet per second.

- latlon: The latitude and longitude coordinate for a point in the river system,

e.g. latlon 46 09 00 N 123 16 00 W marks 46 degrees 9 minutes north latitude, 123 degrees 16 minutes
west longitude.

- model: Refersto either CRiSP.1 or some other mathematical representation of a process.

- Monte Carlo: A technique for producing estimates of “true” outcomes of stochastic processes by
simply running many iterations of the model process and averaging the outcomestogether. Results are
given as statistics, e.g. mean and standard deviation of variable X.

- hitrogen supersaturation: Thisterm is no longer used. See total dissolved gas super saturation.
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- output: Refersto aresult that isreported by CRiSP.1 or some other outcome or product such as“flow
output from an upstream segment.”

- PIT tag: Passive Interrogative Transponder tag; atag that is typically inserted into the peritoneal
cavity and allows identification of individual fish when they pass a detection facility.

- predator: Northern pikeminnow (Ptychocheilus oregonensis).

- primary powerhouse: At dams with more than one powerhouse (e.g. Bonneville), the powerhouse
that is operated preferentialy.

- reach: A continuous stretch or expanse of theriver.
- regulated: Condition whereby stream flow is constrained by a dam.

- release group: A group of fish either wild or released from a hatchery identified by a unique set of
parameters.

- reservoir: An artificial lake where water is collected and kept in quantity for use.
- roller: Turbulent, aerated water in the stilling basin below the spillway.

- runoff: Portion of rain or snowmelt that runs across the land surface and flows through the surface
soil, ultimately reaching the stream or river.

- salmonid: A member of the family Salmonidae, which includes salmon, trout and whitefish.

- SAM: System Analysis Model which produces predicted flows at proj ects on the Columbiaand Snake
Rivers based on power and flood control requirements. This model is administered by the BPA.

- scenario: A single set of parameter va ues run through the model for a single year simulation.

- secondary power house: At dams with more than one powerhouse, the powerhouse that operates
second.

- dluiceways: Routes for water around a dam. Also considered a bypass for fish.

- smolt: A juvenile sailmonid migrating to the ocean and undergoing physiological changes (called
smoltification) to adapt from a freshwater to a saltwater environment.

- smoltification: See smolt.
- spill: Water released through a dam’s spillway rather than through its turbines.
- spill allocation: Indicates the amount of river flow allotted to spill.

- spillway: The channel or passageway around or over a dam through which excess water is rel eased
without going through the turbines. It is a safety valve for a dam and must be capable of discharging
major floods without damaging the dam while maintaining the reservoir level below some
predetermined maximum level.

- stilling basin: Short area beyond a dam spillway where water is controlled prior to release.
- stochastic: Containing some randomness, e.g. “ stochastic process.”

- stock: A population of fish that spawn in a particular stream during a particular season. Such fish
generally do not breed with fish spawning in a different stream or at a different time.

- substock: A portion of a stock.

- subyearling: A juvenile anadromous fish that is less than one year old. Thisterm isused primarily to
refer to juvenile salmon such as fall chinook, which become smolts and migrate from freshwater
production areas to the ocean at an age of less than one year. Also referred to as chinook 0. Fall
chinook refers to the season when adults migrate upstream.

- tailrace: An area of rapidly-moving water immediately downstream from a dam, typically about a
kilometer in length.

- thalweg volume: A portion of the total calculated volume of the river, essentialy the middle of the
river.

- total dissolved gas (tdg) supersaturation: When water plunges over the spillway of a dam into the
stilling basin, additiona air isforced into the water. This resultsin an amount of total dissolved gasin
the water which is greater than the saturation amount (greater than the maximum amount which can
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remain dissolved for along period). Over time, the excess dissolved gas will return to the atmosphere.
Until then, the water isreferred to as“ supersaturated.” TDG ismeasured in terms of the percentage of
gasin excess of the saturation amount.

- transportation: Collecting migrating smolt at collection facilities and transporting them in trucks or
barges around dams.

- transportation velocity: Speed at which fish are moved downstream via barge or truck.

- turbine: A mechanism in adam that rotates with the force of water and produces el ectricity.

- unregulated: Condition whereby streams flow into another stream with no intervening dam.

- upstream propagation: Back-calculation of flows at upstream locations based on flows at
downstream locations.

. water budget: A volume of storage water in acre-feet that is reserved to augment spring and summer
flows through the hydrosystem.

. yearling: Juvenile anadromous fish that are one year old or older. Thisterm is used primarily to refer
to juvenile salmon such as coho or spring chinook or steelhead that become smolts and migrate from
freshwater production areas to the ocean at an age of one or more years. Also referred to as chinook 1.
Spring chinook refers to the season when adults migrate upstream.
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Parameter Glossary

The Parameter Glossary includes terms that occur in the CRiSP.1 input files: col unbi a. desc and
base. dat . (Seethe River Description File Structureand Y early Input Data File Structure sections, respectively,
for further details.) Terms that are not in bold designate parameters not recommended for use in model
operations or parameters not currently in use.

Keyword / Token [Category]: Description

- abbrev [Dam]: Abbreviation by which this dam will be referred to in flow archives, e.g. BON for
Bonneville.

- additional_powerhouse [Dam]: Names a second powerhouse if one exists at the project. This
powerhouse has separate specificationsfor capacity, priority, schedule, threshold, passage mortalities,
and fge. It must have a closing end statement.

- basin_length [Dam]: Length, in feet, of the stilling basin.
- bypass _elevation [Dam]: The elevation, in feet, of the bypass orifice of a bypass system. When

surface is below thislevel fish bypassis zero. When term is missing the bypass_elevation defaults to
the floor_elevation.

- bypass mort_* (Species) [Dam]: Species-specific value for mortality suffered in the bypass system.
Thisisastochastic parameter.

- dam [Dam]: 1) Marksthe beginning of a dam specification and the name of the dam in the
col unbi a. desc file, e.g. dam Bonneville Dam. 2) [Dam] Names the dam and marks the beginning
of parameter data for the dam. The dam name must be present in the col unbi a. desc file, and must
be paired with an end statement.

- day_fge * (Species) [Dam]: Species-specific parameter describing fge during daylight hours. Thisis
a stochastic parameter.

. delay_equation (Species) [Dam]: Definesthe delay of fish at adam depending on the species, time of
day, season, and flow relative to hydraulic capacity. The delay is expressed in terms of a passage
probability, not in terms of observed passage. The number following the token dictates the form of the
equation used. This must be paired with an end statement.

- delta_water_temp [Reach]: Array of values (can be positive or negative) in degrees Celsiusto be
applied to the water temperature that comes from upstream. For example, if thisis set to 1 then the
water temperature in the reach will be adjusted to be 1 degree Celsius warmer than the value that
CRiSP.1 caculates for the reach. There is no GUI for this parameter.

- depth [Reach]: Not recommended. Average depth in the reach, in feet. When possible, use the
preferred parameters upper_depth and lower_depth.

- elevation_change [Reach]: Deviation in elevation from full pool, on adaily basis. The value for
elevation_changeis zero or less, pools may be drawn down but not over-filled.

- end: Thistoken isneeded to mark the end of adam specification, a particular reach, a species or stock
specification, and equations.

- fge_equation (Species) [Dam]: Equation defining time varying fge which differs from constant fge.
Used when age dependent fge isturned on (Run » Runtime Settings). The number following the
token dictates the form of the equation used. This must be paired with an end statement.

- fish_depth_eqn [Species]: Defines the depth profile for each stock modeled. Used together with gas
mortality to define the mortality of fish due to gas relationship. The average gas mortality for areach
is calculated by averaging over all gaslevelsin areach and also using afish depth distribution. The

number following the token dictates the form of the equation used. This must be paired with an end
statement.
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- fish_spill [Dam]: Days and hours of the day during which planned spill is alocated. These periods
indicate the actual hours and daysthat spill will occur. See Planned Spill section for more information
on how fish_spill and planned_spill work together to determine spill operations.

- floor_elevation [Dam]: Elevation in feet above sealevel of the floor of the forebay above the dam as
well as the tailrace downstream from the dam.

- flow [Headwater]: An array of daily flow values, in kcfs.

- flow_coef (calculated): The flow coefficient isavalue between 0 and 1, showing how much of the
flow is apportioned to each headwater. When reading from a flow archive file, flows are propagated
upstream from dams. If a dam has no other dams upstream of it, then its flow will be apportioned
amongst all unregulated headwaters above it (after allowing for any contributions of regulated
headwaters above it or losses in intervening reaches). The flow to be apportioned amongst

unregul ated headwaters is divided up according to their flow_max values.

- flow_max: 1) This defines avalue for the maximum flow measured in ariver over the last century.
CRIiSP.1 uses this value to cal culate how to divide up flows that are propagated upstream. This should
follow theriver designation. Token used in col unbi a. desc file. 2) [Headwater] 50-year maximum
flow in the headwater; thisis used to distribute flows at confluences during upstream propagation.

- flow_mean [Headwater]: Mean flow for the year at the headwater. Thisis used as a scale factor for
headwater modulation.

- flow_min: 1) This defines the lowest flow alowed in ariver. This should follow theriver
designation. Token used in col unbi a. desc file. 2) [Dam]: Minimum flow allowed at a dam, in kcfs.

- flush_trans_equation [Species]: This equation is used to calculate the FLUSH Transport Figure of
Merit. The number following the token dictates the form of the equation used. This must be paired
with an end statement.

- forebay_elevation [Dam]: Elevation of forebay, in feet above sealevel, at full pool.

- forebay pred_coef * [Species]: The dam forebay predation coefficient which effects the rate of
predation activity by northern pikeminnows on smolt for agiven predator density. The coefficientsare
species specific and are defined separately for reaches, dam forebays and dam tailraces. Used as part
of the gas and predation Mortality Model. Thisis a stochastic parameter.

- fork_threshold [Global]: Defines how big ariver fork must be before el evation changes propagate up
it. See River Parameters for further details on how thisisused in CRiSP.1 operations.

- gas_dissp_exp [Global]: An exponent controlling degassing of total dissolved gas from the water
(*10"-4cm”2/sec). This depends on river velocity and depth.

- gas_mort_eqn [Species]: Defines the average mortality due to gas for each speciesin areach. Used
together with Population Density vs. Depth (fish_depth_eqgn) to define the mortality of fish dueto gas
relationship. The average gas mortality for areach is calculated by averaging over all gaslevelsin a
reach and also using a fish depth distribution. The number following the token dictates the form of the
equation used. This must be paired with an end statement.

- gas_theta[Dam]: Gas theta determines the level of mixing between the left-bank and right-bank
flows in the tailrace of the dam and the resulting gas levels in each flow upon exiting the dam. This
essentially determines the amount of mixing between the spill flow and the powerhouse flow in the
tailrace. See the TDG Saturation > 100%: Dam section to determine whether the spill side isleft or
right, facing downstream, at a specific dam.

- gas_theta[Reach]: Gastheta determines the rate of mixing between the gaslevelsin theleft-bank and
right-bank flows of theriver (facing downstream). These flows often have different levels of gas upon
exiting adam and become more mixed as the river flows downstream. The mixing rate is with respect
to time and is set by default to be 0.075 (mile)*-1, which leads to roughly 95% mixing after 40 miles.

- gate_width [Dam]: Width, in feet, of each spill gate at the dam.

- headwater [Headwater]: Names the headwater. This name must be present in the col unbi a. desc
file, and must have apaired “end” statement. e.g. headwater Columbia_Headwater, and end headwater
(Columbia_Headwater).
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- hw_flow_prop [Global]: Specifies overall water availability in the system relative to an average
water year for Scenario Mode runs. Thisisa portion of mean flow as the fraction of an average water
year. Set in the Headwater M odul ation window.

- k_entrain [Dam]: Determines how much gas is added to the powerhouse flow because of amount of
spill going over the spillway into the tailrace of the dam. The higher the spill the more gasthat is
added to the powerhouse flow, with the level of total dissolved gas (tdg) in the powerhouse flow
ranging from the forebay tdg level to the tdg level in the spill flow.

- latlon: 1) [Dam] Location of the dam in latitude and longitude in thecol unbi a. desc file. 2) [Reach]
Provides latitude and longitude for pointsin the course of the reach in the col unbi a. desc file, e.g.
latlon 46 09 00 N 123 16 00 W marks 46 degrees 9 minutes north latitude, 123 degrees 16 minutes
west longitude.

- length [Release]: Specifies the average length (in mm) of thefish at the time of the release.
- loss[Reach]: Daily loss records, in kcfs, for the reach. Thisis often O.

- loss_max [Reach]: The maximum amount of flow allowed to be removed from the reach during
model operations.

- loss_min [Reach]: The maximum amount of flow allowed to be added to the reach during model
operations.

- lower_depth [Reach]: Depth in feet of the downstream end of the reach.

- lower_elev [Reach]: Elevation above sealevel of the river bottom at the lower end of each reach.

- mean_forebay_transit_time (Species) [Dam]: Species-specific average time (in hours) that it takes
the fish to travel from the entry point of the dam segment to the dam face where it will enter the
bypass, spillway or turbine passage route. The default for each species at each dam is 2 hours. This

measure is used in calculating passage mortality and is part of the dam delay model. Thereisno GUI
for this parameter.

- migr_var_coef_* [Species]: Defines the relative variability in fish migration velocity. Thisisa
stochastic parameter.

- migration_eqn [Species]: Defines the velocity of fish as afunction of flow, age and time of release.
The number following the token dictates the form of the equation used. This must be paired with an
end statement.

- mod_* [Dam/Headwater]: Parameters used in modulation of flows.

- mod_coeffs * [Headwater]: Coefficients for a nine-term Fourier series that describes the average
annua shape of river flow.

- mod_coeffs_a[Headwater]: Cosine coefficients. The first element, a 0, isalways 1.
- mod_coeffs b [Headwater]: Sine coefficients. Thefirst element, b_0, isawaysO.
- mod_end_hi_sigma [Headwater]: Day of year to return to low variance.

- mod_hi_sigma [Headwater]: Standard deviation for modulation; used for the part of the year when
flow varianceis high.

- mod_lo_sigma [Headwater]: Standard deviation for modulation; used for the part of the year when
flow variance islow.

- mod_norm_sigma [Dam]: Standard deviation to use when modulating flows at downstream dams.

- mod_ou_r [Dam]: Specifies correlation of flow from one day to the next.

- mod_ou_r [Headwater]: Autocorrelation parameter for flow.

- mod_ou_sigma [Dam]: Standard deviation to use when modulating flows at farthest upstream dams.
- mod_start_hi_sigma [Headwater]: Day of year to start using high variance.

- mod_weekly _amp [Dam]: Amplitude of weekly variation imposed on modulation.
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- mortality_class[Global]: Indicates which Mortality Model is being used during Scenario and Monte
Carlo runs: Gas & Pred Mortality (gas_pred) or Simple Mortality (simple). The currently calibrated
Mortality Model is Gas & Pred Mortality.

- ngates [Dam]: Number of spill gates at the dam.

- night_fge * (Species) [Dam]: Species-specific parameter describing fge during nighttime hours. This
is a stochastic parameter.

- nsat_backup_equation [Dam]: Defines the production of total dissolved gas supersaturation due to
spilling at dams when the spill valuefalls out of areasonable range for the equations provided for Day
and Night characteristics. Thisis one of three equations which defines gas production at adam. The
number following the token dictates the form of the equation used. This must be paired with an end
statement.

- nsat_day_equation [Dam]: Defines the production of total dissolved gas supersaturation due to
spilling at dams during day hours (6-18). This is one of three equations which defines gas production
a adam. The number following the token dictates the form of the equation used. This must be paired
with an end statement.

- nsat_night_equation [Dam]: Defines the production of total dissolved gas supersaturation due to
spilling at dams during night hours (0-6 and 18-24). This is one of three equations which defines gas
production at a dam. The number following the token dictates the form of the equation used. This
must be paired with an end statement.

- humber [Release]: An array of numbers of fish released for aperiod of dayswhich may be asingle
day or many days. The Release Start day determines on which Julian days the releases occur. This
array represents the range of the release and the number of fish released per day.

- output_gas[Reach/Dam/Headwater]: The default setting is off. If output_gasisturned on, it replaces
the dissolved gas data at the output of the feature (dam, reach, or headwater). One set of numbers are
given, for each dam time slice in the season (366* 4, currently). The numbers are applied to both sides
of the feature. Thereisno GUI for this parameter.

- output_settings[Reach/Dam/Headwater]: Specifies what detailed information is output for a given
reach, dam, or headwater during both Scenario and Monte Carlo runs. The single valueisa
combination of up to 10 flags, each of which isasingle binary digit, arithmetically added together.
Thusavalue of "41" would indicate that flags"1", "8", and "32" were set, requesting output of
passage, flow, and TDG saturation. Flags which are declared for the wrong type of river feature (e.g.
spill at areach) are silently ignored. Thefollowingisalist of flags and where they are allowed (Dam,
Reach, and/or Headwater):

- 1=passage (d,r)

- 2 = transport passage (d)

- 4 =routing (d)

- 8=flow (d,r, h)

- 16 = water temperature (d, r, h)

. 32=TDG saturation (d, r)

- 64 = velocity (r)

- 128 =loss(r)

- 256 = spill (d)

- 512 = elevation (r)
- pergate [Dam]: Amount of flow passed through each spill gate, in kcfs.

- planned_spill [Dam]: Periods of dayswhen spill fractions are planned as part of the water budget and
spill alocation agreements and an associated fraction of river flow spilled on an instantaneous basis.
Different fractions can be set for different blocks of days. See Planned Spill section for more
information on how fish_spill and planned_spill work together to determine spill operations.
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- power house_capacity [Dam]: Total hydraulic capacity, in kcfs. Same for the second powerhouse
(power house 2_capacity).
- powerhouse_capacity [Dam]: Total hydraulic capacity, in kcfs.

- powerhouse _priority [Dam]: Dictates whether the powerhouse is the primary or secondary
powerhouse.

- powerhouse_schedule [Dam]: Array of hours during which a powerhouse may operate. This
generally defaults to 24 hours year round.

- powerhouse_threshold [Dam]: Amount of spill alowed over primary powerhouse capacity before
secondary powerhouse is turned on.

.- pred_density_forebay [Dam]: Describes the density of predatorsin the forebay.
- pred_density_tailrace [Dam]: Describesthe total predator population in the tailrace.

- pred_dist [Reach]: The Predator Distribution Coefficient of the predator density / volume interaction
for each river segment. The main purpose of the predator density/volume interaction isto properly
scalethe effect of initial predator densities on predation rate during reservoir drawdown. Used when

predator density/volume interaction isturned on (Run » Runtime Settings).

- pred_mean [Reach]: Predator densitiesin each river segment. Densities are given as the number of
northern pikeminnows per square kilometer of reservoir. This measure, based on full pool dimensions,
is effectively a measure of the total number of predatorsin ariver segment. Used as part of the Gas
and Predation Mortality Model.

- pred_temp_response_eqn [Species]: Defines the temperature response component of predator
activity as afunction of consumption rate and temperature. The number following the token dictates
the form of the equation used. This must be paired with an end statement.

- predation_prob (Species) [Dam]: Species-specific array of values describing the rel ative success of
predators during each 6-hour segment of the day; generally thisis 1 for al periods.

- reach: 1) [Reach] Designates the beginning of areach and its name. 2) [Reach] Defines areach name,
e.g. reach Estuary which matches a name defined in the col unbi a. desc file, and is paired with an
“end” statement, e.g. end reach (Estuary).

- reach_pred_coef_* [Species]: The reach predation coefficient which effects the rate of predation
activity by northern pikeminnows on smolt for a given predator density. The coefficients are species
specific and are defined separately for reaches, dam forebays and dam tailraces. Used as part of the
Gas and Predation Mortality Model. Thisis a stochastic parameter.

- release [Release]: Names release and species released, e.g. release Steelhead
Lower_Granite_Hatchery 141 where species is steelhead, release site is Lower Granite Hatchery -
whichisdefined in the col unbi a. desc file- and 141 isthe Julian date of thefirst day of fish release.
Thistoken must be paired with an end statement.

- release_site: This defines the name of arelease site in the system. A release site must have a location
associated with it in the latitude/longitude format; it must also coincide with a point also defined in a
reach, i.e. release sites must lie exactly on ariver point. Token used in col unbi a. desc file.

- river: Thisdefines a collection of reaches and assumes that some headwater exists for theriver. A
river may consist of a number of reaches (e.g. Columbia or Snake) or a single reach (e.g. Imnaha or
Grande Ronde). Token used in col unbi a. desc file.

- runtime_settings [Global]: Specifies what functiona relationships to consider during both Scenario
and Monte Carlo runs. The single value is a combination of up to 3 flags, each of whichisasingle
binary digit, arithmetically added together.

- 1 =variance suppression turned on
- 2 = predator density / volume interaction turned on
- 4 = age dependent fge turned on
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- separation_prob (Species) [Dam]: Species-specific parameter for ability to separate individual s of
that species during bypass, in percentage. Thisis used in transport operations.

- sgr [Dam]: Specific gravity of theroller; this can vary from 0 to 1.

- simple_mort_equation [Species]: This is the mortality equation for reaches when Simple Mortality
has been selected as the Mortality Model. The number following the token dictates the form of the
equation used. This must be paired with an end statement.

- dope[Reach]: Theinward slope of the sides of the reach, in degrees.
- smolt_finish [Release]: The Julian date for the finish of smoltification.

- smolt_onset [Release]: The Julian date for the onset of smoltification. Fish released prior to this date
do not actively migrate.

- gpecies. 1) Speciestokens must appear first inthe col unbi a. desc file. Any speciesto be usedin the
model must be identified by the species token, e.g. species Steelhead. There is no fixed limit on the
number of species that can be specified. 2) [Species]: This identifies the speciesin question, e.g.
species Chinook_0. Following the remaining parameter specifications there must be a paired end
token, e.g. end species (Chinook_0). The species must be identified in the col unbi a. desc file.

- spill_cap [Dam]: Maximum allowable flow that is allowed to pass through spill.

- spill_equation (Species) [Dam]: Equation describing the spill efficiency at the dam. The number
following the token dictates the form of the equation used. This must be paired with an end statement.

- spill_mort_* (Species) [Dam]: species-specific value for mortality suffered as fish pass through the
spillway. Thisis a stochastic parameter.

- spill_side [Dam]: Indicates which side looking downstream from a dam is the spill side. For dams,
total dissolved gas saturation in percent above 100 is recorded for both the left-bank flow and right-
bank flow levels. These flows often have different levels of gas upon exiting a dam because of the gas
production from spill. At each dam the two flows are marked as either the powerhouse flow or the
spill flow (spill_side). Consult the table in the TDG Saturation > 100%: Dam section to determine
whether the spill_side is left or right at a specific dam, looking downstream.

- spillway_width [Dam]: Total width, in feet, of the spillway.

- stock: 1) Stock tokens appear after the speciestokensin the col unbi a. desc file. Any specific stock
to be used in the model must beidentified by the stock token, e.g. stock Catherine Creek Chl. Thereis
no fixed limit on the number of stocks that can be specified. 2) [Release]: | dentifies the stock of
release. Thiscan be set to “Generic” or aspecific stock can be selected, e.g. Catherine Creek Chl. The
stock must be identified in the col unbi a. desc file.

- storage _basin [Dam]: Defines storage behind headwater dams. Takes two parameters: the minimum
and maximum storage capacity, in thousand acre feet, e.g. st orage_basin 0.0 5185. 5.

- storage volume [Dam]: Water volume in the reservoir, in kiloacre-feet (kaf), specified by period
(single day or range of days). This token only occursin specifications for dams that are storage
reservoirs as defined in the col unbi a. desc file, i.e. Hells Canyon, Dworshak, and Chief Joseph.

- tailrace_elevation [Dam]: Elevation of tailrace, in feet above sealevel, at full pool.

- tailrace_length [Dam]: Not in use. Length of the tailrace in feet. CRiSP.1 previously determined the
residence time of fish in the tailrace in terms of the flow, the width of the dam, and atailrace length.
Thistime was used in calculating predation in the tailrace. The time was set by adjusting the tailrace
length. Tailrace length was set to conform to the region of high flows immediately below the dam.
Thisregion also contains elevated predator densities.

- tailrace_pred_coef_* [Species]: The dam tailrace predation coefficient which effects the rate of
predation activity by northern pikeminnows on smolt for agiven predator density. The coefficientsare
species specific and are defined separately for reaches, dam forebays and dam tailraces. Used as part
of the Mortality Model. Thisis a stochastic parameter.

- trans_mort_equation (Species) [Dam]: Defines the relationship between water particle travel time
(WPTT) and transport survival based on the assumption that changes in flow affect how well fish
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survive transportation. The number following the token dictates the form of the equation used. This
must be paired with an end statement.

- transport [Dam]: Defines transport operations.

. start_by date: 0 = start transportation if daily counts exceed a specified number (start_count)
in aday; 1 = start transportation on a specified day (start_date).

. start_date: Specific Julian day to start transportation.
. start_count: Start transportation when this number of fish passthe dam in a day.

- max_restarts: 0 = transportation cannot be restarted; 1 = transportation can be restarted exactly
once; -1 = transport can be restarted as often as the conditions are met.

- restart_by_date: O = restart transportation if daily count exceeds a specified number
(restart_count); 1 = restart transportation on a specified day (restart_date).

- restart_date: Specific Julian day to restart transportation.

- restart_count: Restart transportation when this number of fish pass the dam in a day.

- end_date: Specific Julian day to stop transportation.

- end_count: Stop transportation if the daily fish count drops below this number for a given
number of sequential days (num_low_days).

- num_low_days:. Stop transportation if the daily fish count drops below a given number for this
number of sequential days.

- hfl_passed_perc: Identifies what percent of the indicator species (high_flow_species) must
pass to terminate separation. Separators in bypass systems of dams will separate and return
smaller fish to the tailrace when flow is above a specified level. The separation is terminated
and all fish are collected when passage of a specified stock exceeds a specified percentage.

- high_flow: Identifies flows above which separation starts. Separators in bypass systems of
dams will separate and return smaller fish to the tailrace when flow is above a specified level.
The separation is terminated and all fish are collected when passage of a specified stock
exceeds a specified percentage.

- high_flow_species (Species): Identifiesindicator species (Chinook 0, Chinook 1, Chinook
Summer, Steelhead) for which its passage will terminate separation. Separatorsin bypass
systems of dams will separate and return smaller fish to the tailrace when flow is above a
specified level. The separation isterminated and all fish are collected when passage of a
specified stock exceeds a specified percentage.

- transport_rate: Barge or truck transportation speed in miles per day from collection site to
release site.

- release_point: River reach into which fish are released.

- transport_mort_* (Species) [Dam]: Species-specific value for mortality suffered during the entire
transport process. Thisis astochastic parameter.

- turbine_mort_* (Species) [Dam]: Species-specific value for mortality suffered during turbine
passage. Thisis a stochastic parameter.

- ufree[Global]: River velocity in free flowing portions of river (in kcfs*107-1).

- upper_depth [Reach]: Depth in feet of the upstream end of the reach.

- V_var [Species]: Variance in velocity; this contributes to “spread” of fish.

- vitality [Release]: Not implemented, yet. A measure of the health of the fish in the release.

- vitality_change [Release]: Not implemented, yet. Incremental change in vitality for the release.

- water_temp [Headwater]: An array of water temperatures, in degrees celsius. Temperatures are
determined below confluences by averaging input temperatures weighted by flow volume.

- water_travel_upper_segment [Global]: Used in transport mortality calculations. Set by CRiSP.1 to
be Little Goose Pool. There isno GUI to set this parameter.
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- water_travel_lower_segment [Global]: Used in transport mortality calculations. Set by CRiSP.1 to
be Estuary. Thereis no GUI to set this parameter.

- water_travel_first_day [Global]: Used in transport mortality calculations. Set by CRiSP.1 to be 1.
Thereisno GUI to set this parameter.

- water_travel_last_day [Global]: Used in transport mortality calculations. Set by CRiSP.1 to be 365.
Thereisno GUI to set this parameter.

- width [Reach]: Width of the reach in feet.
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Technical Details

The purpose of this section isto provide advanced information about thefiles used by CRiSP.1 and parameters
and tokens found in each file. A novice user of CRiSP.1 does not need to be familiar with level of detail that is
discussed in the following sections.

- River Description File Structure
- Yearly Input Data File Structure
- Flow Archive File Structure

- Timein CRiSP1

- CRiSP1 Parser

River Description File Structure

The River Description File (col unbi a. desc) contains all the information necessary to define the physical
river system from the ocean to the various headwaters. This includes latitudes and longitudes of release sites,
dams, and river segments, and many of the physical attributes of these features. Sample reach and dam
designations follow as well as parameter definitions.

Rulesfor construction

The River Description File contains information specifying the physical characteristics of theriver. Thefile
must follow rules for construction of ariver map. Rules on ordering of tokens (or keywords) include:

- Speciestokens must appear first, before river description tokens. Speciestokens are followed by stock
tokens if there are any specific stocks to be identified.

speci es Chi nook 0
- Release sitestypically appear next, although they may appear anywhere in the file except within a
river stem description (bounded by the tokens “river” and “end”).

rel ease_site McNary Face
latlon 45 56 23 N 119 15 11 W
end (rel ease)

- Thefirst river specified isthe main stem, and the first river segment specified is the river mouth.
Remaining segments must appear in order (moving upstream) toward the headwater. The first latitude
and longitude coordinate (latlon) point of each successive segment must match the last latlon of the
preceding segment. Latlons within a segment should appear in order.

river Col unbi a
fl ow_max 280. 00
flowmn 4

reach Estuary

wi dt h 5930. 23

depth 60

| ower _el ev -60

latlon 46 14 8 N 123 52 19 W
latlon 46 15 3 N 123 48 44 W
[cut]

latlon 46 8 55 N 123 19 2 W
latlon 46 9 0 N 123 15 46 W
end (Estuary)

- Other complete river branch descriptions may appear in any order, and each will be attached to the
appropriate existing river branch by comparing latlon points.
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- Thefirst segment specified in any river branch istaken to be the confluence point. This segment must
be areach. Thefirst latlon in this segment must match the last latlon of some existing reach segment
on another branch.

reach The Dal | es Pool

[cut]

latlon 45 38 55 N 120 54 21 W
end (The Dall es)

reach Deschut es Confl uence
[cut]

latlon 45 38 55 N 120 54 21 W
[cut]

end (Deschutes)

- Dam segments must have exactly one latlon point, matching the last latlon of the previous segment.
No two dams may be adjacent.

- If adamisidentified asa“storage basin” then it must be the last (furthest upstream) segment on that
river branch.

dam Chi ef Joseph Dam
power house_capacity 219
fl oor_el evation 743.0
forebay_el evati on956. 0
tailrace_el evation786.0
spillway_wi dth 1320
spill_side right

pergate 2.0
ngat es 19
gate_width 40.0
basi n_l ength 180

sgr 1.0
abbrev CHJ

storage_basin0.0 5185.5
latlon 47 59 48 N 119 37 56 W
end (Chief Joseph)

end (Col unbi a)

Reach Parameters
The following is an example of areach designation from a River Description File (. desc).

reach The Dal | es Pool

wi dt h 3624.5

upper _depth 47.05

| ower _dept h70.0

sl ope 87.92

| ower _el ev 55

latlon 45 36 50 N 121 7 57 W
lon 45 37 38 N 121 6 48 W
lon 45 38 25 N 121 5 37 W
lon 45 38 58 N 121 4 46 W
lon 45 39 12 N 121 3 14 W
lon 45 39 8 N 121 1 22 W
lon 45 39 11 N 121 0 9 W
lon 45 38 57 N 120 58 52 W
lon 45 39 24 N 120 57 8 W
lon 45 39 18 N 120 56 18 W
lon 45 38 58 N 120 55 24 W
lon 45 38 55 N 120 54 21 W
(The Dall es)

Keywords and descriptions for reaches

- reach: Designates the beginning of areach and its name.
- width: Width of thereach in feet.
- upper_depth: Depth in feet of the upstream end of the reach.
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- lower_depth: Depth in feet of the downstream end of the reach.
- dope: Theinward slope of the sides of the reach, in degrees.
- lower_elev: Elevation above sealevel of the river bottom at the lower end of each reach.

- latlon: Provides|atitude and longitude for pointsin the course of the reach, e.g. latlon 46 09 00 N 123
16 00 W marks 46 degrees 9 minutes north latitude, 123 degrees 16 minutes west longitude.

- end (reach): Marks the end of a particular reach.

- depth: Not recommended. Average depth in the reach, in feet. When possible, use the preferred
parameters upper_depth and lower_depth.

Dam Parameters

The following are examples of dam specifications from a River Description File (. desc).

Storage Basin Dam

dam Chi ef Joseph Dam
power house_capacity 219
fl oor_elevation 743.0
forebay_el evati on956. 0
tailrace_el evation786.0
spillway_wi dth 1320
spill _side right

pergate 2.0
ngat es 19
gate_width 40.0
basi n_l ength 180

sgr 1.0
abbrev CHJ

storage_basin0.0 5185.5
latlon 47 59 48 N 119 37 56 W
end (Chief Joseph)

Dam with two Powerhouses

dam Bonnevi |l |l e Dam

power house_capacity 136

power house_2_ capacity 152

fl oor_elevation -16.0
forebay_elevation 77.0
tailrace_elevation 14.5
bypass_el evation 65.5
spillway_w dth 1080.0

spill _side right

pergate 2.9
ngat es 18
gate_width 60.0
basin_length 144.5

sgr 1.0
abbrev BON

latlon 45 38 41 N 121 56 21 W
end (Bonneville)

Keywords and descriptions for dam parameters

- dam: Marks the beginning of adam specification and the name of the dam, e.g. dam Bonneville Dam.

- powerhouse_capacity: Total hydraulic capacity, in kcfs. Same for the second powerhouse
(power house 2_capacity).

- floor_elevation: Elevation in feet above sealevel of the floor of the forebay above the dam aswell as
the tailrace downstream from the dam.

- forebay_elevation: Elevation of forebay, in feet above sealevel, at full poal.
- tailrace_elevation: Elevation of tailrace, in feet above sealevel, at full pool.
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- bypass_elevation: The elevation, in feet, of the bypass orifice of a bypass system. When surfaceis
below this level fish bypass is zero. When term is missing the bypass_elevation defaults to the
floor_elevation.

- spillway_width: Total width, in feet, of the spillway.

- spill_side: Indicates which side looking downstream from a dam is the spill side. For dams, total
dissolved gas saturation in percent above 100 is recorded for both the left-bank flow and right-bank
flow levels. These flows often have different levels of gas upon exiting a dam because of the gas
production from spill. At each dam the two flows are marked as either the powerhouse flow or the
spill flow (spill_side). Consult the table in the TDG Saturation > 100%: Dam section to determine
whether the spill sideisleft or right at a specific dam, looking downstream.

- pergate: Amount of flow passed through each spill gate, in kcfs.
- ngates. Number of spill gates at the dam.

- gate_width: Width, in feet, of each spill gate at the dam.

- basin_length: Length, in feet, of the tilling basin.

. sgr: Specific gravity of theroller; this can vary from 0 to 1.

- abbrev: Abbreviation by which this dam will be referred to in flow archives, e.g. BON for
Bonneville.

- storage_basin: Defines storage behind headwater dams. Takes two parameters: the minimum and
maximum storage capacity, in thousand acre feet (kaf), e.g. st orage_basin 0.0 5185. 5.

- latlon: Location of the dam in latitude and longitude.

- end (dam name): Marks the end of a dam specification.

Species, Stock, Release, and River Parameters
The following are species, stock, release and river tokens found in a River Description File (. desc).

- river: Thisdefines a collection of reaches and assumes that some headwater exists for theriver. A
river may consist of a number of reaches (e.g. Columbia or Snake) or a single reach (e.g. Imnaha or
Grande Ronde).

- flow_max: This defines a value for the maximum flow measured in ariver over the last century.
CRIiSP.1 uses this value to cal culate how to divide up flows that are propagated upstream. This should
follow theriver designation.

- flow_min: This defines the lowest flow alowed in ariver. This should follow the river designation.

- release_site: This defines the name of arelease site in the system. A release site must have a location
associated with it in the latitude/l ongitude format; it must also coincide with a point also defined in a
reach, i.e. release sites must lie exactly on ariver point.

- species: Species tokens must appear first in the file. Any species to be used in the model must be
identified by the speciestoken, e.g. species Steelhead. Thereisno fixed limit on the number of species
that can be specified.

- stock: Stock tokens appear after the species tokensin the file. Any specific stock to be used in the
model must be identified by the stock token, e.g. stock Catherine Creek Chl. Thereis no fixed limit
on the number of stocks that can be specified.

Yearly Input Data File Structure

The Yearly Input Data File (base. dat ) contains the information specific to the model run you wish to
perform, such as releases, dam mortality rates, fge, and so forth. Parameters are described for each species, each
dam, each reach, each headwater, and each release.
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During a CRiSP.1 run, information is stored according to tokens corresponding to model variables and
parameters. Token structure isillustrated below where tokens are species and gas_mort_egn. A complete list
of tokens can be found in the Parameter Glossary. For parameters that change in time, the token is followed by
atime series of values. The model containstwo time steps:. reservoir time steps (one day) and dam time steps (6
hours). Parameters at dams, therefore, are specified for 4 periods per day, while parameters in reaches (flow,
loss, elevation, temperature) are specified with one value per day. (See the Time in CRiSP.1 section for further
information.)

Mean, High and L ow

For many parameters there will be a token that possesses one of three suffixes. mean, low, and high (e.g.
day_fge mean or day_fge high). These describe the mean value and the two endpoints of the broken-stick
distribution used to draw stochastic variables. For the sake of brevity, only one description for each collection
of three such tokensis provided.

Equations

Equations have tokens ending in egn or equation, e.g. gas_mort_eqn or fge_equation. Following each such
equation will be alist of parameters - in the case of the fge equation, there are four parameters. For each
parameter there are three values specified. The first represents the value used in the model, and the second two
represent the minimum and maximum values allowed for parameter in CRiSP.1 Y ou can adjust the allowed
range for the parameter by editing these values. In the sectionsthat follow, we only list equation token itself, not
the parameters that accompany it. The number following the token dictates the form of the equation used.

fge_equation Chinook_1 22
paraneter 0 0.500000 0.000000 2.000000
paranmeter 1 10. 000000 0.000000 100. 000000
paraneter 2 30.000000 0.000000 100.000000
paraneter 3 30.000000 0.000000 100.000000
end fge_equation (Chinook_1)

Species and Stock Tokens and Parameters
The following is an example of a species specification from a 'Y early Input Datafile (. dat ).

speci es Chi nook_1

reach_pred_coef _mean 12. 700000

reach_pred_coef _| ow 0. 000000

reach_pred_coef _high 0.000000

forebay_pred_coef _mean 18. 000000

forebay_pred_coef _| ow 0. 000000

forebay_pred_coef _high 0.000000

tail race_pred_coef _nean 0.000239

tail race_pred_coef | ow 0. 000000

tail race_pred_coef _hi gh 0.000000

v_var 100. 00

m gr _var _coef _nean 1. 00

m gr_var_coef _| ow 0.70

m gr _var _coef _high 1. 30

gas_nort_eqn 34
parameter 0 0.000019 0.000000 0.001000
parameter 1 0.005580 0.000000 0.010000
parameter 2 10. 900000 5.000000 15. 000000

end gas_nort_eqgn ( )

fish_depth_eqn 27
paranmeter 0 12. 000000 0.010000 100. 000000
paranmeter 1 24.000000 0.010000 100. 000000
end fish_depth_eqgn ( )

sinmple_nort_equation 44
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par anet er
par anet er

0 0.000007 0.000000 0.100000

1 3.162000 1.000000 5.000000

end sinple_nort_equation ( )

flush_trans_equation

45

paranmeter 0 0.328100 0.000000 1.000000
paranmeter 1 0.193600 0.000000 1.000000

end flush_trans_equation ( )

mgration_eqn 24
paranmeter 0 1.340000 -10. 000000 20. 000000
paranmeter 1 20.200001 0.000000 100.000000
paranmeter 2 0.710000 0.000000 2.000000
paraneter 3 0.100000 0.000000 2.000000
paraneter 4 119.800003 50. 000000 250. 000000
paranmeter 5 0.100000 0.000000 1.000000

end migration_eqn ( )

pred_t enp_response_eqn

par anet er
par anet er
par anet er

38

0 7.551922 0. 000000 1000000. 000000

1 0.558655 0. 000000 1000000. 000000

2 16.729418 0.000000 1000000. 000000

end pred_tenp_response_eqn ( )
end species (Chinook_1)

The following is an example of a stock specification.

stock Catherine_Creek_Chl

v_var 41.37

m gr _var _coef _nean 1. 00
m gr _var _coef _| ow 0. 10
m gr _var _coef _high 0. 10

m gration_eqn
par anet er
par anet er
par amet er
par amet er
par amet er
par anet er

24

0 -5.975300 -10. 000000 20. 000000
1 4.910700 0. 000000 100. 000000

2 2.046700 0.000000 3.000000

3 0. 000000 0.000000 2.000000

4 100. 000000 50. 000000 250. 000000
5 0.154200 0. 000000 1.000000

end migration_eqn ( )

pred_t enp_response_eqn 38
paranmeter 0 205.413315 0. 000000 1000000. 000000
paranmeter 1 0.521340 0.000000 1000000. 000000
paranmeter 2 16.352169 0.000000 1000000. 000000

end pred_tenp_response_eqn ( )

end stock (Catherine_Creek_Chl)

Keywords and descriptions for species and stock tokens and parameters

- species: Thisidentifies the speciesin question, e.g. species Chinook_0. Following the remaining
parameter specifications there must be a paired end token, e.g. end species (Chinook_0). The species
must be identified in the col unbi a. desc file.

- reach_pred_coef_*: The reach predation coefficient which effects the rate of predation activity by
northern pikeminnows on smolt for a given predator density. The coefficients are species specific and
are defined separately for reaches, dam forebays and dam tailraces. Used as part of the Gas and
Predation Mortality Model. Thisis a stochastic parameter.

. forebay pred_coef *: The dam forebay predation coefficient which effects the rate of predation
activity by northern pikeminnows on smolt for a given predator density. The coefficients are species
specific and are defined separately for reaches, dam forebays and dam tailraces. Used as part of both
gas and predation Mortality Model. This is a stochastic parameter.

- tailrace_pred_coef_*: The dam tailrace predation coefficient which effects the rate of predation
activity by northern pikeminnows on smolt for a given predator density. The coefficients are species
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specific and are defined separately for reaches, dam forebays and dam tailraces. Used as part of the
Mortality Model. Thisis a stochastic parameter.

- v_var: Variance in velocity; this contributes to “spread” of fish.

- migr_var_coef_*: Definesthe relative variability in fish migration velocity. Thisis a stochastic
parameter.

- gas_mort_eqn: Defines the average mortality due to gas for each species in areach. Used together
with Population Density vs. Depth (fish_depth_egn) to define the mortality of fish dueto gas
relationship. The average gas mortality for areach is calculated by averaging over all gaslevelsin a
reach and also using a fish depth distribution. The number following the token dictates the form of the
equation used. This must be paired with an end statement.

. fish_depth_eqn: Defines the depth profile for each stock modeled. Used together with Gas Mortality
Equation to define the mortality of fish due to gas relationship. The average gas mortality for areach
is calculated by averaging over all gaslevelsin areach and also using afish depth distribution. The
number following the token dictates the form of the equation used. This must be paired with an end
statement.

- simple_mort_equation: Thisis the mortality equation for reaches when Simple Mortality has been
selected as the Mortality Model. The number following the token dictates the form of the equation
used. This must be paired with an end statement.

- flush_trans_equation: This equation is used to calculate the FLUSH Transport Figure of Merit. The
number following the token dictates the form of the equation used. This must be paired with an end
statement.

- migration_eqn: Defines the velocity of fish asa function of flow, age and time of release. The
number following the token dictates the form of the equation used. This must be paired with an end
statement.

- pred_temp_response_eqn: Defines the temperature response component of predator activity asa
function of consumption rate and temperature. The number following the token dictates the form of
the equation used. This must be paired with an end statement.

Release Tokens and Parameters

Release parameters may or may not appear in the base. dat file. The following is an example of arelease
specification from a 'Y early Input Datafile (. dat).

rel ease Chinook_1 WId_Sal non_R Stocks 115
stock Ceneric
snol t _onset 91
snmolt_finish 91
vitality 0.00
vitality_change 0.00
I ength 0.00
nunber 20860 26662 56295 35179
40586 27468 50287 46775
57106 46554 43438 63271
65714 64520 52087 62479
58712 28651 33423
[19:365] O
end rel ease (Chinook_1)

Keywords and descriptions for release tokens and parameters

- release: Names release and species released. For example,
rel ease Steel head Lower _Granite_Hatchery 141
where steelhead is the species, Lower Granite Hatchery is the release site (both of which must be
defined inthe col unbi a. desc file), and 141 isthe Julian day of thefirst day of fish release (Release
Start day). Thistoken must be paired with an end statement.
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- stock: Identifies the stock of release. This can be set to “ Generic” or a specific stock can be specified,
e.g. Catherine Creek Chl.

- smolt_onset: The Julian day for the onset of smoltification. Fish released prior to this date do not
actively migrate.

- smolt_finish: The Julian day for the finish of smoltification.

- vitality: Not implemented, yet. A measure of the health of the fish in the release.

- vitality_change: Not implemented, yet. Incremental change in vitality for the release.

- length: Specifies the average length (in mm) of the fish at the time of the release.

- number: An array of numbers of fish released for a period of dayswhich may be asingle day or many
days. The Release Start day determines on which Julian days the releases occur. This array represents
the range of the release and the number of fish released per day.

Reach Tokens and Parameters
The following are examples of reach specificationsfrom a Y early Input Datafile (. dat ).

reach Bonneville_Tailrace
out put _settings 761
pred_nmean 498. 00
pred_dist 1.00
gas_theta 0.075000
delta_water _tenp [*] 0.00
| oss_max 280. 00
| oss_mn -280.00
loss [*] 0.00
el evation_change [*] 0.00
out put _gas Of

end reach (Bonneville_Tailrace)

reach Lower _Granite_Pool

pred_nmean 1246. 60

pred_dist 1.00

gas_theta 0.075000

delta_water_tenp 0.00 -0.22 0.26 0.51
0.49 0.22 0.02 -0.68
-0.84 -0.37 0.24 0.82
1.09 0.76 0.47 0.66

0.03 0.02 0.18 0.06
-4.03 -0.88 -4.19 -3.07
-0.10 0.47 0.14 -0.51
-1.42 -1.57 0.68 -2.40
-0.39 -0.14

end reach (Lower_G anite_Pool)

Keywords and descriptions for reach tokens and parameters

- reach: Defines areach name, e.g. reach Estuary which matches a name defined in the
col unbi a. desc file, and is paired with an “end” statement, e.g. end reach (Estuary).

- output_settings. Specifies what detailed information is output for a given reach, dam, or headwater
during both Scenario and Monte Carlo runs. The single valueis acombination of up to 10 flags, each
of which isasingle binary digit, arithmetically added together. Thus avalue of "41" would indicate
that flags"1", "8", and "32" were set, requesting output of passage, flow, and TDG saturation. Flags
which are declared for the wrong type of river feature (e.g. spill at areach) are silently ignored. The
following isalist of flags and where they are allowed (Dam, Reach, and/or Headwater):

- 1=passage(d,r)

- 2 = transport passage (d)
- 4 =routing (d)
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- 8=flow (d, r, h)
- 16 = water temperature (d, r, h)
. 32=TDG saturation (d, r)
- 64 = velocity (r)
- 128 =loss(r)
- 256 = spill (d)
- 512 = elevation (r).
- pred_mean: Predator densitiesin each river segment. Densities are given as the number of northern
pikeminnows per square kilometer of reservoir. This measure, based on full pool dimensions, is

effectively ameasure of the total number of predatorsin ariver segment. Used as part of the Gas and
Predation Mortality Model.

- pred_dist: The Predator Distribution Coefficient of the predator density/volume interaction for each
river segment. The main purpose of the predator density/volume interaction is to properly scale the
effect of initial predator densities on predation rate during reservoir drawdown. Used when predator

density / volume interaction isturned on (Run » Runtime Settings).

- gas_theta: Gas theta determines the rate of mixing between the gaslevelsin the left-bank and right-
bank flows of the river (facing downstream). These flows often have different levels of gas upon
exiting adam and become more mixed as the river flows downstream. The mixing rate is with respect
to time and is set by default to be 0.075 (mile)*-1, which leads to roughly 95% mixing after 40 miles.

- delta_water_temp: Array of values (can be positive or negative) in degrees Celsius to be applied to
the water temperature that comes from upstream. For example, if thisis set to 1 then the water
temperature in the reach will be adjusted to be 1 degree Celsius warmer than the value that CRiSP.1
calculates for the reach. Thereisno GUI for this parameter.

- loss_max: The maximum amount of flow allowed to be removed from the reach during model
operations.

- loss_min: The maximum amount of flow allowed to be added to the reach during model operations.
- loss: Daily loss records, in kcfs, for the reach. Thisis often O.

- elevation_change: Deviation in elevation from full pool, on adaily basis. The value for
elevation_changeis zero or less, pools may be drawn down but not over-filled.

. output_gas: The default setting is off. If output_gasis turned on, it replaces the dissolved gas data at
the output of the feature (dam, reach, or headwater). One set of numbers are given, for each dam time
dlicein the season (366* 4, currently). The numbers are applied to both sides of the feature. Thereisno
GUI for this parameter.

Dam Tokens and Parameters
The following is an example of a dam specification from a 'Y early Input Datafile (. dat).

dam Bonnevi | | e_Dam
out put _settings O
pred_density_forebay 2042.00
pred_density_tail race 758.00
tailrace_l ength 1000. 00
nmod_ou_r 0.50
nmod_ou_sigma 12. 00
nmod_norm si gnma 11. 00
nmod_weekl y_anp 0. 00
nsat _day_equation 17

nsat _night_equation 17

nsat _backup_equation 17
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gas_t heta 0.000000

k_entrain 0.000000

spil |l _nort_nean Chi nook_0 0.020000
spill _nort_I ow Chinook_O0 0.000000
spill _nort_hi gh Chi nook_0 0.070000
bypass_nort _nean Chi nook_0 0.020000
bypass_nort _| ow Chi nook_0 0.000000
bypass_nort _hi gh Chi nook_0 0.080000
turbine_nort_mean Chi nook_0 0.070000
turbine_nort_| ow Chinook_0 0.010000
turbine_nort_hi gh Chinook_0 0.100000
transport_nort_nean Chi nook_0 0.170000
transport_nort_| ow Chinook_0 0.000000
transport_nort _hi gh Chi nook_0 0.340000
mean_f orebay_transit_tine Chinook_0 2.000000
separati on_prob Chi nook_0 0.800000
predation_prob Chinook_0O [*] 1.000000
day_fge_nean Chi nook_0 0.150000
day_fge_| ow Chi nook_0 0. 150000
day_fge_hi gh Chi nook_0 0.150000

ni ght _fge_mean Chinook_0 0. 150000

ni ght _fge_|l ow Chi nook_0 0.150000

ni ght _fge_high Chinook_0 0.150000
spill _equation Chinook 0 1

féé_equation Chi nook_0 22
i}éns_nurt_equation Chi nook_0 28
déiay_equation Chi nook_0 46

power house_capacity 136.00

power house_schedul e 0: 365 (0: 24)

power house_priority O

power house_t hreshol d 75. 00

addi ti onal _power house Bonneville_Dam 2
power house_capacity 152.00
power house_priority 1
power house_t hreshol d 75000. 00
power house_schedul e 0: 365 (0: 24)
bypass_nort _nean Chi nook_0 0.020000
bypass_nort _| ow Chi nook_0 0.000000
bypass_nort _hi gh Chi nook_0 0.080000
turbine_nort_mean Chi nook_0 0.070000
turbine_nort_| ow Chi nook_0 0.010000
turbine_nort_hi gh Chinook_0 0.100000
day_fge_nean Chi nook_0 0.240000
day_fge_| ow Chi nook_0 0.070000
day_fge_hi gh Chinook_0 0.550000
ni ght _fge_mean Chi nook_0 0.240000
ni ght _fge_| ow Chi nook_0 0.070000
ni ght _fge_hi gh Chinook_0 0.550000
fge_equation Chinook_0 22

spill _cap 235.00
fish_spill 0:365 (0:24)
pl anned_spill 0:104 = 0.00, 105:234 = 0.46, 236:365 = 0.00
flow_mn 100. 00
out put _gas Of
end dam (Bonnevil | e_Dam

Keywords and descriptions for dam tokens and parameters

- dam: Names the dam and marks the beginning of parameter datafor the dam. The dam name must be
present in the col unbi a. desc file, and must be paired with an end statement.

- output_settings. Specifies what detailed information is output for a given reach, dam, or headwater
during both Scenario and Monte Carlo runs. The single valueis acombination of up to 10 flags, each
of which isasingle binary digit, arithmetically added together. Thus avalue of "41" would indicate
that flags"1", "8", and "32" were set, requesting output of passage, flow, and TDG saturation. Flags
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which are declared for the wrong type of river feature (e.g. spill at areach) are silently ignored. The
following isalist of flags that can be designated for a dam:
- 1=passage (d,r)
. 2 = transport passage (d)
- 4 =routing (d)
- 8=flow (d, r, h)
- 16 = water temperature (d, r, h)
. 32=TDG saturation (d, r)
- 256 = spill (d).
- pred_density_forebay: Describes the density of predators in the forebay.
- pred_density_tailrace: Describes the total predator population in the tailrace.
- mod_*: Parameters used in modulation of flows.
- mod_ou_r: Specifies correlation of flow from one day to the next.
- mod_ou_sigma: Standard deviation to use when modul ating flows at farthest upstream dams.
- mod_norm_sigma: Standard deviation to use when modulating flows at downstream dams.
- mod_weekly _amp: Amplitude of weekly variation imposed on modulation.

- nsat_day_equation: Defines the production of total dissolved gas supersaturation due to spilling at
dams during day hours (6-18). Thisisone of three equations which defines gas production at a dam.
The number following the token dictates the form of the equation used. This must be paired with an
end statement.

- nsat_night_equation: Defines the production of total dissolved gas supersaturation due to spilling at
dams during night hours (0-6 and 18-24). Thisis one of three equations which defines gas production
a adam. The number following the token dictates the form of the equation used. This must be paired
with an end statement.

- nsat_backup_equation: Defines the production of total dissolved gas supersaturation due to spilling
a dams when the spill value falls out of a reasonable range for the equations provided for Day and
Night characteristics. Thisis one of three equations which defines gas production at adam. The
number following the token dictates the form of the equation used. This must be paired with an end
statement.

- gas_theta: Gastheta determines the level of mixing between the |eft-bank and right-bank flowsin the

tailrace of the dam and the resulting gas levels in each flow upon exiting the dam. This essentially

determines the amount of mixing between the spill flow and the powerhouse flow in the tailrace. See

the TDG Saturation > 100%: Dam section to determine whether the spill sideis |eft or right, facing

downstream, at a specific dam.

- k_entrain: Determines how much gas is added to the powerhouse flow because of amount of spill

going over the spillway into the tailrace of the dam. The higher the spill the more gas that is added to

the powerhouse flow, with the level of total dissolved gas (tdg) in the powerhouse flow ranging from

the forebay tdg level to the tdg level in the spill flow.

- spill_mort_* (Species): Species-specific value for mortality suffered as fish pass through the

spillway. Thisis a stochastic parameter.

- bypass mort_* (Species): Species-specific value for mortality suffered in the bypass system. Thisis

a stochastic parameter.

- turbine_mort_* (Species): Species-specific value for mortaity suffered during turbine passage. This

is a stochastic parameter.

- transport_mort_* (Species): Species-specific value for mortality suffered during the entire transport
process. Thisisa stochastic parameter.

- mean_forebay_transit_time (Species): Species-specific average time (in hours) that it takes the fish
to travel from the entry point of the dam segment to the dam face whereit will enter the bypass,
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spillway or turbine passage route. The default for each species at each dam is 2 hours. Thismeasureis
used in calculating passage mortality and is part of the dam delay model. Thereisno GUI for this
parameter.

- separation_prob (Species): Species-specific parameter for ability to separate individuals of that
species during bypass, in percentage. Thisisused in transport operations.

- predation_prob (Species): Species-specific array of values describing the rel ative success of
predators during each 6-hour segment of the day; generally thisis 1 for al periods.

- day_fge * (Species): Species-specific parameter describing fge during daylight hours. Thisisa
stochastic parameter.

- night_fge * (Species): Species-specific parameter describing fge during nighttime hours. Thisisa
stochastic parameter.

- spill_equation (Species): Equation describing the spill efficiency at the dam. The number following
the token dictates the form of the equation used. This must be paired with an end statement.

- fge_equation (Species): Equation defining time varying fge which differs from constant fge. Used
when age dependent fge isturned on (Run » Runtime Settings). The number following the token
dictates the form of the equation used. This must be paired with an end statement.

- trans_mort_equation (Species): Defines the relationship between water particle travel time (WPTT)
and transport survival based on the assumption that changesin flow affect how well fish survive
transportation. The number following the token dictates the form of the equation used. This must be
paired with an end statement.

- delay_equation (Species): Defines the delay of fish at a dam depending on the species, time of day,
season, and flow relative to hydraulic capacity. The delay is expressed in terms of a passage
probability, not in terms of observed passage. The number following the token dictates the form of the
equation used. This must be paired with an end statement.

- powerhouse_capacity: Total hydraulic capacity, in kcfs.

- powerhouse_schedule: Array of hours during which a powerhouse may operate. This generally
defaults to 24 hours year round.

- powerhouse _priority: Dictates whether the powerhouse is the primary or secondary powerhouse.

- powerhouse_threshold: Amount of spill alowed over primary powerhouse capacity before
secondary powerhouse is turned on.

- additional_powerhouse: Names a second powerhouse if one exists at the project. This powerhouse
has separate specifications for capacity, priority, schedule, threshold, passage mortalities, and fge.
This must be paired with an end statement.

- transport: Defines transport operations.

. start_by date: 0 = start transportation if daily counts exceed a specified number (start_count)
in aday; 1 = start transportation on a specified day (start_date).

. start_date: Specific Julian day to start transportation.
. start_count: Start transportation when this number of fish passthe dam in a day.

- max_restarts: 0 = transportation cannot be restarted; 1 = transportation can be restarted exactly
once; -1 = transport can be restarted as often as the conditions are met.

- restart_by_date: 0 = restart transportation if daily count exceeds a specified number
(restart_count); 1 = restart transportation on a specified day (restart_date).

- restart_date: Specific Julian day to restart transportation.
- restart_count: Restart transportation when this number of fish pass the dam in a day.
- end_date: Specific Julian day to stop transportation.

- end_count: Stop transportation if the daily fish count drops below this number for a given
number of sequential days (num_low_days).
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- num_low_days:. Stop transportation if the daily fish count drops below a given number for this
number of sequential days.

- hfl_passed_perc: Identifies what percent of the indicator species (high_flow_species) must
pass to terminate separation. Separators in bypass systems of dams will separate and return
smaller fish to the tailrace when flow is above a specified level. The separation is terminated
and all fish are collected when passage of a specified stock exceeds a specified percentage.

- high_flow: Identifies flows above which separation starts. Separators in bypass systems of
dams will separate and return smaller fish to the tailrace when flow is above a specified level.
The separation is terminated and all fish are collected when passage of a specified stock
exceeds a specified percentage.

- high_flow_species (Species): Identifiesindicator species (Chinook 0, Chinook 1, Chinook
Summer, Steelhead) for which its passage will terminate separation. Separatorsin bypass
systems of dams will separate and return smaller fish to the tailrace when flow is above a
specified level (high_flow). The separation is terminated and all fish are collected when
passage of a specified stock exceeds a specified percentage (hfl_passed perc).

- transport_rate: Barge or truck transportation speed in miles per day from collection site to
release site.

- release_point: River reach into which fish are released.
- spill_cap: Maximum allowable flow that is allowed to pass through spill.

- fish_spill: Days and hours of the day during which planned spill is allocated. These periods indicate
the actual hours and days that spill will occur. See Planned Spill section for more information on how
fish_spill and planned_spill work together to determine spill operations.

- planned_spill: Periods of dayswhen spill fractions are planned as part of the water budget and spill
alocation agreements and an associated fraction of river flow spilled on an instantaneous basis.
Different fractions can be set for different blocks of days. See Planned Spill section for more
information on how fish_spill and planned_spill work together to determine spill operations.

. storage volume: Water volume in the reservaoir, in kiloacre-feet (kaf), specified by period (single day
or range of days). Thistoken only occurs in specifications for dams that are storage reservoirs as
defined in the col unbi a. desc filg, i.e. Hells Canyon, Dworshak, and Chief Joseph.

- flow_min: Minimum flow allowed at a dam, in kcfs.

. output_gas: The default setting is off. If output_gasis turned on, it replaces the dissolved gas data at
the output of the feature (dam, reach, or headwater). One set of numbers are given, for each dam time
dlicein the season (366* 4, currently). The numbers are applied to both sides of the feature. Thereisno
GUI for this parameter.

- tailrace length: Not in use. Length of the tailrace in feet. CRiSP.1 previously determined the
residence time of fishin the tailrace in terms of the flow, the width of the dam, and atailrace length.
Thistime was used in calculating predation in the tailrace. The time was set by adjusting the tailrace
length. Tailrace length was set to conform to the region of high flows immediately below the dam.
Thisregion also contains elevated predator densities.

Headwater Tokens and Parameters
The following is an example of a headwater specification from a 'Y early Input Datafile (. dat ).

headwat er Col unbi a_Headwat er
out put _settings O
nmod_ou_r 0. 93
nmod_hi _sigma 0. 08
nmod_| o_sigma 0. 06
nmod_start_hi _sigm 96
nmod_end_hi _si gna 196
nod_coeffs_a 1.00 -0.24 0.20 0.00 -0.04
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nod_coeffs_b 0.00 0.13 -0.10 0.10 -0.02
fl ow_nmean 110. 00
fl ow_max 280. 00
flow 4.00 104.17 100.62 122.10
out put _gas Of
water_tenp [0:49] 5.08 5.21
end headwat er (Col unbi a_Headwat er)

Keywords and descriptions for headwater tokens and parameters

- headwater: Names the headwater. This name must be present in the col unbi a. desc file, and must
have apaired “end” statement. e.g. headwater Columbia_Headwater, and end headwater
(Columbia_Headwater).

- output_settings. Specifies what detailed information is output for a given reach, dam, or headwater
during both Scenario and Monte Carlo runs. The single valueis acombination of up to 10 flags, each
of which isasingle binary digit, arithmetically added together. Thus a value of "24" would indicate
that flags "8" and "16" were set, requesting output of flow, and water temperature. Flags which are
declared for the wrong type of river feature (e.g. spill a areach) are silently ignored. The followingis
alist of flags that can be designated for a headwater:

- 8=flow (d, r, h)
. 16 = water temperature (d, r, h).
- mod_*: Parameters for modulation of flows.
- mod_ou_r: Autocorrelation parameter for flow.
- mod_hi_sigma: Standard deviation for modulation; used for the part of the year when flow variance
is high.
- mod_lo_sigma: Standard deviation for modulation; used for the part of the year when flow varianceis
low.
- mod_start_hi_sigma: Day of year to start using high variance.
- mod_end_hi_sigma: Day of year to return to low variance.

- mod_coeffs *: Coefficients for a nine-term Fourier series that describes the average annual shape of
river flow.

- mod_coeffs_a: Cosine coefficients. The first element, a 0, is always 1.
- mod_coeffs_b: Sine coefficients. The first element, b_0, is always 0.

- flow_mean: Mean flow for the year at the headwater. Thisis used as a scale factor for headwater
modulation.

- flow_max: 50-year maximum flow in the headwater; thisis used to distribute flows at confluences
during upstream propagation.
- flow: An array of daily flows, in kcfs.

. output_gas: The default setting is off. If output_gasis turned on, it replaces the dissolved gas data at
the output of the feature (dam, reach, or headwater). One set of numbers are given, for each dam time
dlicein the season (366* 4, currently). The numbers are applied to both sides of the feature. Thereisno
GUI for this parameter.

- water _temp: An array of water temperatures, in degrees celsius. Temperatures are determined bel ow
confluences by averaging input temperatures weighted by flow volume.

Global Tokens
The following is an example of the global parameters specification from a 'Y early Input Datafile (. dat ).

gas_di ssp_exp 0. 20
hw_fl ow_prop 1.00
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ufree 0.045000

fork_threshold 0.100000

wat er _travel _upper_segnent Littl e_Goose_Poo
wat er _travel _| ower _segnment Estuary
water_travel _first_day 1

wat er _travel _| ast_day 365

runtime_settings 1

nortality_class gas_pred

Keywords and descriptions for global tokens and parameters

- gas_dissp_exp: An exponent controlling degassing of total dissolved gas from the water (* 10"-
4cm2/sec). This depends on river velocity and depth.

- hw_flow_prop: Specifies overall water avail ability in the system relative to an average water year for
Scenario Moderuns. Thisisaportion of mean flow asthe fraction of an average water year. Set in the
Headwater Modulation window.

- ufree: River velocity in free flowing portions of river (in kcfs*107-1).

- fork_threshold: Defines how big ariver fork must be before elevation changes propagate up it. See
River Parametersfor further details on how thisis used in CRiSP.1 operations.

- water_travel_upper_segment: Used in transport mortality calculations. Set by CRiSP.1 to be Little
Goose Pool. Thereis no GUI to set this parameter.

- water_travel_lower_segment: Used in transport mortality calculations. Set by CRiSP.1 to be
Estuary. Thereis no GUI to set this parameter.

- water_travel_first_day: Used in transport mortality calculations. Set by CRiSP.1 to be 1. Thereisno
GUI to set this parameter.

- water_travel_last_day: Used in transport mortality calculations. Set by CRiSP.1 to be 365. Thereis
no GUI to set this parameter.

- runtime_settings: Specifieswhat functional relationshipsto consider during both Scenario and
Monte Carlo runs. The single value is a combination of up to 3 flags, each of which isasingle binary
digit, arithmetically added together.

- 1 =variance suppression turned on
- 2 = predator density / volume interaction turned on
- 4 = age dependent fge turned on

- mortality_class: Indicates which Mortality Model isbeing used during Scenario and Monte Carlo
runs: Gas & Pred Mortality (gas_pred) or Simple Mortality (ssimple). The currently calibrated
Mortality Model is Gas & Pred Mortality.

Flow Archive File Structure

The Flow Archive File (f1 ow. ar chi ve) contains flow, spill and elevation data generated from
hydroregulation models such as SAM, HY SSR or HY DROSIM. The flow archive file can be used in Monte
Carlo Mode as the source for flow, planned spill, and elevation data. Users are unlikely to create flow archive
files from scratch, but the format of such afile is described in this section. Information contained in a
f1 ow. ar chi ve fileincludes:

- nhumber of games (water years)

- nhumber of years (power years)

- number of dams

- number of periods within years (i.e. weeks, months)
- spill information

- reservoir elevation information
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. flow information.

Sample portion of f | ow. ar chi ve
V0.9 CRi SP Fl ow Archive Fri Apr 2 17:07:59 1993 SOR sos2c

ganmes49 # nunber of ganes
yearsl # nunber of years

danms 19 BON TDA JDA MCN | HR LWN LGS LW5 DWR PRD WAN RI' S RRH WVEL CHJ GCL ALF
HGH LI B

peri ods 14 0:31, 32:59, 60:90, 91:105, 106: 120, 121:151, 152:181, 182:212
213: 228, 229:243, 244:273, 274:304, 305:334, 335:365

#period wat er power dam el ev pl an over t ot
# year year spill spill flow
DATA

JAN 1929 0 BON 0.0 0.0000 0.0000 122135.0
JAN 1929 0 TDA 0.0 0.0000 0.0000 118805.0
JAN 1929 0 JDA 263.5 0.0000 0.0000 114350.0
JAN 1929 0 MCN 339.0 0.0000 0.0000 116620.0
JAN 1929 0 I HR 438.7 0.0000 0.0000 22813.0
JAN 1929 0 LN 538.7 0.0000 0.0000 22813.0
JAN 1929 0 LGS 636.2 0.0000 0.0000 22313.0
JAN 1929 0 LWG 735.3 0.0000 0.0000 22313.0
JAN 1929 0 DVR 1556.9 0.0000 0.0000 1200. 0
JAN 1929 0 PRD 0.0 0.0000 0.0000 88937.0
JAN 1929 0 VAN 0.0 0.0000 0.0000 88747.0
JAN 1929 0 RIS 0.0 0.0000 0.0000 88687.0
JAN 1929 0 RRH 0.0 0.0000 0.0000 86847.0
JAN 1929 0 VEL 0.0 0.0000 0.0000 87018.0
JAN 1929 0 CHJ 953.2 0.0000 0.0000 85108.0
JAN 1929 0 GCL 1287.0 0.0000 0.0000 85108.0
JAN 1929 0 ALF 2051.0 0.0000 0.0000 11887.0
JAN 1929 0 HGH 3486.7 0.0000 0.0000 8400.0
JAN 1929 0 LI B 2388.6 0.0000 0.0000 7232.0
FEB 1929 0 BON 0.0 0.0000 0.0000 118790.0
FEB 1929 0 TDA 0.0 0.0000 0.0000 115170.0

Flow Archive Header

- V0.9: Specifies the version number of the crisppp utility used. (We have written a utility called
crisppp, CRIiSP pre-processor, which takes input files from SAM, HY SSR and HY DROSIM and
converts them into standard archive format that CRiSP.1 can read.) The date in the top lineis the date
the file was created. “sos2¢” isthe name of the original file from which the archive was created.

- games: Indicates the number of different water yearsincluded in thefile.
- years: Indicates the number of power yearsincluded in thefile.

- dams: Specifies how many projects are described in the archive and gives the abbreviations, in order,
for the dams. These abbreviations must match up with the dam abbreviations given in the
col unbi a. desc file. Dams described in the archive but not present in the col unbi a. desc file will
be discarded. Damsin the col unbi a. desc filethat are not covered in the flow archive will be given
the same flow as the nearest downstream dam that is present in the archive.

- periods - Specifies how many time periods are contained in the file and lists the Julian days covered
by each period.

Flow Archive Data

Theflow archiveitself isalong array of numeric data, and contains eight columns, delimited by tabs or spaces.
This array must be preceded by the text “DATA.” CRiSP.1 expects the data to be in the following order.
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- period: Thisisany useful period abbreviation; we generally use Jan, Feb, Mar, and so forth.
- water year: Thisisup to 4 digits naming the water year, usualy something like 1931, 1956.

- power year : This marks different conditions under which the hydro regulation was done, and thus can
be numbered arbitrarily. We begin at 0 and count upwards. If there is more than one power year in the
flow archive, then there must be along array of numeric data for each power year. This should match
with the number that isindicated in the header of the archive. If power year is more than one, the
number of yearly input data files used in Monte Carlo runs needs to match the number of power years
specified in the archive.

- dam: A column of dam abbreviations. These abbreviations must match up with the dam abbreviations
given in the col unbi a. desc file and appear in the same order as listed in the flow archive header.

- elev: Period-averaged pool e evation of the dam forebay during that period. (Older versions of crisppp
did not retain this information in the flow archive.)

- plan spill: Period-averaged planned spill, as afraction of total flow, for this period, for this dam; the
ratio of volume spilled to the total flow passed during the period.

- over spill: Period-averaged overgeneration spill as afraction of total flow. Thisis generaly zero.
- tot flow: Total flow, in cfs (not kcfs), at the dam during that period.

Timein CRISP.1

In CRIiSP.1, fish move both spatially and temporally. A distribution of fish over timeistypically represented
by an array whose index is some unit of time. There are several different time scales and references used
throughout the model.

- DAYS_I N_SEASON (366 days)

The number of daysin the model season, beginning with the Julian day specified by
SEASON_START_DAY.

. STEPS_PER DAY (2 steps/day)

The number of system time steps per day. It is the resolution (12 hours) of time-based cal culationsfor
reach segments.

. STEPS_| N_SEASON (732 steps)
Total number of system time steps (DAYS_| N_SEASON * STEPS_PER_DAY)
- DAYS_ | N_RUN (366 days)

The number of daysfor which agiven release of fish remains in the system before becoming
censored.

. STEPS_I N_RUN (732 steps)

The number of system steps during which agiven release of fishisin the system. (DAYS_| N_SEASON
* STEPS_PER_DAY)

- DAM TI ME_SLC (4 Steps/day)
The number of dam time slices per day. It is the resolution (6 hours) of time-based calculations for
dam segments.
. SLI CES_| N_STEP (2 steps)
This defines the number of dam time slicesin a system time step.
(DAM TIME_SLC / STEPS_PER_DAY)
. SEASON_START_DAY (0)
This defines the Julian day of the season start (December 31st).
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CRISP.1 Par ser

Thisisadescription of the CRiSP.1 data parser syntax whichisused for reading datainto CRiSP.1. The parser
reads and interprets parameter data files.

Description

Vocabulary

- Token: A character sequence that denotes a command, number, or other dataitem. Tokens are
separated from each other by white space (spaces, tabs, new lines).

- Exampletokens: spi | | , st eel head, 4. 6, and Bonnevi | | e.

- Command: A token that tells the parser to take an action. For example, the word “ spill” tellsthe
parser to treat numeric tokens following it as a dam spill.

- Menu: A set of commands.
- Value: A floating point or integer number.
- Index: Aninteger that usually indicates an array element.

Parser

The parser reads tokens in sequential order from the beginning of afile to the end. If it finds a syntax error, it
tries to recover by skipping the data and continuing at the beginning of the next line. The general format of the
datais: token_name value(s).

Example

dam Dwor shak_Dam

pred_density_forebay 376.53

pred_density_ tailrace 1000. 00

tailrace_l ength 1000. 00

nmod_ou_r 0.90

nmod_ou_sigma 2. 00

nmod_norm si gnma 3. 00

nmod_weekl y_anp 0. 00

nsat _day_equation 18
paranmeter 0 3.310000 -10. 000000 55.000000
paraneter 1 0.460000 -1.000000 4.000000
paraneter 2 -0.032000 -0.400000 0.100000

end nsat _day_equation ( )

power house_capacity 10.50
power house_schedul e 0: 365 (0: 24)
end dam ( Dwor shak_Dam

Syntax

Comments

Comments start with the “#” token. When the parser encounters a#, it discards the rest of the line. Y ou may
type anything between the # and the Return <cr>.

Example

# This file contains data for Dworshak Dam

dam Dwor shak Dam # Dworshak is on the Snake River
abbrev DWR # storage reservoir for North Fork Cl earwater
latlon 46 30 51 N 116 17 40 W

end (Dworshak) # another coment
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Include Command

CRIiSP.1 contains the command include which allows you to specify in a datafile that you want the model to
read data from an additional file when reading data from the top level file. The include command is followed
by the name of the file that should be read at the same time. The include command can appear anywherein the
file below thefile header and version number line. A parameter datafile can contain several include commands.
Each include command should appear on a separate line and only one file can be specified per each include
command line. Thefilesanpl e. dat which containsthe line

i ncl ude chinookl.rls

instructs the model to read the release information contained in chi nook1. r 1 s file when the model reads
sanpl e. dat . For any parameter datafile types, except a Control File, once you read the datainto CRiSP.1 and
save the information on disk, theincludeline is replaced by the actual data contained in the file. Fileswhich are
included are not subject to the same file name extension examination asthe top level file (see the Reading Data
into CRiSP.1 section for more information).

Menus

Some commands indicate that the tokens that come after it are part of a different set of commands or menu.
For example, the dam command indicates that commands after it are subcommands. This can be thought of as
switching menus or selecting a submenu. These commands must be terminated with an end command.

The End Command

The end command indicates that the current submenu is ending and to switch back to the original menu.
Everything between an end token and itsline ending is treated as a comment. The text between the end token
and the end of the line marks which menu or submenu is ending.

Example

dam The_Dal | es_Dam
power house_capacity 375.00
power house_schedul e 0: 365 (0: 24)
spill _cap 235.00
fish_spill 0:365 (0:24)
end dam (The_Dal | es_Dam

rel ease Steel head W1 d_Snake R Stocks 141
stock Ceneric
snol t _onset 91
snmolt_finish 91
vitality 0.00
vitality_change 0.00
I ength 0.00
nunber 113188 [1:365] O
end rel ease (Steel head)

Array Syntax
The simplest array syntax lists values for the parameter in sequential order.
Ar r ayNane Value Value Value...

Example
loss 0.00 2.06 0.00 0.00 4.63 4.80 3.73
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Limits

Arrays start at element 0. The last array index is one less than the number of elementsin the array (n-1). For
example, the fictional array sample has 300 numbers in it. It is defined in C as float sample[300], so its first
element is accessed as sampl€]0] and its last one as sampl€[299].

Index Numbers

The parser can be told to start adding values at a particular spot in the array by putting an index number in
brackets to indicate the location. Instead of putting the first number after the bracketsin element O, it putsitin
the element I ndex.

ArrayNane [ ndex] Value Value Value...
In the following example, the first value 45 will be applied to the element 3.
spill [3] 45 45 45 50

Index numbers do not have to be right after the command, and you can have more than one of them. For
example, the following will set elements O through 2 to be 3, elements 5 through 7 to be 45, and elements 10
through 12 to be 50:

spill 3 3 3 [5] 45 45 45 [10] 50 50 50
Ranges

A range of locations can be set to one number in an array by putting the starting index and ending index of the
range separated by a“:” inside brackets. The range is set to be the single number after the brackets.

ArrayNane [ Begi nl ndex : Endl ndex] Value
In the following example, the first value 45 will be applied to elements 0 through 12.
spill [0:12] 45

Like index numbers, ranges can appear anywherein the array specification and you can have as many of them
as you want. For example, the following will set elements 0 through 12 to be 45 and elements 13 through 50 to
be 120.

spill [0:12] 45 [13:50] 120
Global Ranges

To set one value to an entire array, put a“*” between brackets as an index. The entire array will be set to the
single value after the brackets.

ArrayName [*] Value

Example
spill [*] 10

Combinations

Y ou can combine any of the above techniques. For example, if you want to set al the elements of an array
named sample to be 1 except for the 25th and 252nd elements, which you want to be 155, you could type:

sanple [*] 1 [25] 155 [252] 155
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Most of the output routines for data use syntax similar to the following.
ArrayName [0:20] 3.45 [21:30] 4.2 5.6 4.8345 [33:200] 5.0

The current array index after setting arange of array elements is one after the last element set. For example,
ArrayNanme [0: 10] 20

sets array elements O through 10 to be 20, and the current array index is set to 11. So,
ArrayName [0: 10] 20 99

sets the 11th element of the array to be 99.

Conflicts

It is possible to specify the same index of an array several times. When this happens, the value stored is the
last value set. For example,

sanpl e 55 48 27 [2] 30 45 [3] 12 14 25 [4:50] 100

sets element 0 to 55, element 1 to 48, element 2 to 30 (value 27 is discarded), element 3 to 12 (value 45 is
discarded), and elements 4 through 50 to 100 (values 14 and 25 are discarded). In this example,

sanmple 55 46 [*] 1
al elements of sample are set to 1.

Summary of Array Syntax

ArrayNanme Value Value Value...

ArrayNanme [ Startlndex ] ValueValueValue...
ArrayNanme [ Startlndex : Endlndex ] Value
ArrayName [*] Value

Periods

Periods (time periods) are usually used for scheduling things such as spill. They can have a value associated
with them that usually indicates a degree to which something is on. Periods are analogous to sparse arrays,
except that a period can have severa sub-periods associated with it.

Period Ranges
A period range is denoted by the starting number followed by a“:” and then the ending number. For example,
0: 10

is a period range starting at 0 and ending at 10. If you only want a range of one number, you do not have to
specify the “:” and second number.

Period Values

To associate avalue to a period range, use an “=" followed by the desired value. All values are floating point
numbers. For example,

0:10 = 0.45

would associate the value 0.45 to the range 0 through 10.
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Period Lists
A period list is asequence of one or more ranges separated by commas. For example,
0: 10, 20:35, 50:360
is aperiod with three ranges. Rangesin a period list can have values. For example,
0:10 = .45, 20:35 = .5, 50:360 = .25
is aperiod with three ranges each of which have values associated with them. This can be thought of asasparse
array.
Sub-Periods

A range can have a sub-period associated with it. A sub-period uses a format identical to a period list. Sub-
periods are usualy used for fine tuning when something in a period is on or off. For example,

0:10 (0:8, 12:24), 50:360 (0:12)

is a period with two ranges which both have sub-periods.

Period Examples

fish_spill 0:365 (0:24)

pl anned_spill 0:300 = 0.00

fish_spill 3 (0:8)

pl anned_spill 0:5 =0.3, 6 =0.99, 7:10 =0

fish_spill 0:10 (0:8), 11:20 (0:12), 100:184 (0:6, 18:24)

pl anned_spill 0:105 = 0.00, 106:122 = 0.09, 123:164 = 0.53, 165:235 =
0.41, 236:365 = 0.00

Period Format

Peri odNane peri od-1i st
period-list = period {, period}

period = [range | range = value] { (sub-period) }
sub- period = period-1|ist
range = [Value | Val ue: Val ue]

Equations

Equationstell CRiSP.1 which type of equation to use on dataand what the parameters are for those equations.
The CRiSP.1 equation format is:

Equat i onNanme EqNunber
paranet er Par anet er Nunber value mn max

end Equat i onNane

where

- EquationName: Token associated with the equation, e.g. f ge_equat i on.
- EgqNumber: Number of the equation type.

- Parameter Number : Parameter number. Parameter O isthe first parameter, parameter 2 is the third,
etc.

- value: Floating point number you want that parameter to be set to.
- min: Minimum value of a parameter. It is not suggested that you change this from the default val ue.
- max: Maximum value of a parameter. It is not suggested that you change this from the default value.
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