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1 Introduction

1.1 About this manual  
This manual provides an introduction to Adobe  Configurator 1.0 
on Mac OS  and Windows .  

Chapter 1 covers the basic conventions used in this manual and 
system requirements.  

Chapter 2 offers a brief overview of Configurator and describes 
how to create a simple panel.  

Chapter 3 introduces the menu, toolbar, and palettes of 
Configurator. 

Chapter 4 explains how to package and deploy a panel. 
Chapter 5 provides information for panel developers. 

1.2 Conventions in this guide  
Code and specific language samples appear in Courier font:  
alert(“hello world”); 

1.3 System requirements 
Mac OS 

• PowerPC® G5 or multicore Intel® processor 
• Mac OS X v10.4.11–10.5.4 

• 512MB of RAM (1GB recommended) 
• 10MB of available hard-disk space for installation; additional free space required for installation 

(cannot install on a volume that uses a case-sensitive file system or on flash-based storage 
devices) 

• 1,024x768 display (1,280x800 recommended) with 16-bit video card 
• Adobe Photoshop CS4 

• AIR 1.1 

Windows 

• 1.8GHz or faster processor 



• Microsoft® Windows® XP with Service Pack 2 (Service Pack 3 recommended) or Windows Vista® 

Home Premium, Business, Ultimate, or Enterprise with Service Pack 1 (certified for 32-bit 
Windows XP and 32-bit and 64-bit Windows Vista) 

• 512MB of RAM (1GB recommended) 
• 10MB of available hard-disk space for installation; additional free space required for installation 

(cannot install on flash-based storage devices) 
• 1,024x768 display (1,280x800 recommended) with 16-bit video card 

• Adobe Photoshop CS4 
• AIR 1.1 

By default, Adobe Photoshop CS4 bundles AIR 1.1. If you don t 
have Adobe AIR installed, go to http://get.adobe.com/air/. 

1.4 Workbench overview 
 

 

1.5 Glossary 



 Custom-designed panel  a panel that is designed by the user and 
executed in Photoshop. 

 Objects - the predefined components that can be added to custom-
designed panels.

 .GPC  the file extension for saved panels.



2  Configurator basics 
 

This chapter provides an overview of Configurator and describes 
how to create your own custom-designed panels for use in 
Photoshop CS4. 

2.1 Install Configurator  
Configurator 1.0 is an AIR application. Install Adobe AIR 1.1 before 
running the Configurator installer. 

AIR can be downloaded from the Adobe website at 
http://get.adobe.com/air/. 

Configurator can be downloaded from the Adobe website at 
http://labs.adobe.com/technologies/configurator. 

Make sure the downloaded installer is saved with file extension .AIR, 
and then double-click to execute the installer.  
NOTE: AIR applications are platform independent. The same installer is used 
for Mac and Windows. 



2.2 Start Configurator  
On Mac, go to the Applications folder and double-click Adobe 
Configurator. 

On Windows, go to the Start menu, open the Adobe folder, and 
click Adobe Configurator. 



2.3 Create a panel 
Click the Create New Panel button on the Welcome page, or choose 
File > New Panel. 



2.4 Set panel name and size 
Click the Inspector palette on the right side to edit the name, height, 
and width of the panel. 

2.5 Drag objects into the panel 
Drag objects from the Object palette onto the new panel, or double-
click an object to add it to the panel. 

Click on the triangle icons to expand or collapse the palette 
sections. 
Drag a tool button to the panel. 



Drag a text widget to the panel 

and then modify the text in the Inspector palette. 



2.6 Save the panel 
Choose File > Save Panel, and then choose a folder in the dialog box 
to save the panel file. The panel is saved in a file with the 
extension .GPC. 

The default location is user s Home folder, such as C:\Documents 
and Settings\username (Windows XP) or /Users/username (Mac 
OS). 

2.7 Export the panel 
The Export command generates the required runtime assets for 
Photoshop CS4.  Choose File > Export Panel, and in the dialog box 
choose the following location:  

/Applications/Adobe Photoshop CS4/Plug-ins/Panels/ (Mac OS) 

C:\Program Files\Adobe\Adobe Photoshop CS4\Plug-ins\Panels 
(Windows XP) 

If Photoshop isn t installed in the default location, navigate to and 
the Adobe Photoshop CS4/Plug-ins/Panels folder. See section 4.2 
for more information. 

2.8 Run the panel in Photoshop CS4 
Start Photoshop CS4 and then choose Window > Extensions > panel 



name.  
NOTE: You must name the panel in Configurator in order for it to appear in 
the Photoshop CS4 Window > Extensions submenu. Otherwise, it appears as 
Untitled. 



3 Workbench

3.1 Menus and shortcuts 
 File 

 Edit 

3.2 Toolbars 
 Align 



 Distribute 

NOTE: Align and Distribute tools are enabled when two or more objects 
are selected, and they only apply to the selected objects.  

 Auto Layout  
NOTE: Auto Layout tool lays out all objects in the panel automatically, not 
just selected objects. 

3.3 Object palette 
 Tools 

The Tools area of the Object palette contains the tools found in the 
Photoshop toolbar.  



 Commands 

The Commands area of the Objects palette contains Photoshop 
menu commands. 

 Search box 

The Search box at the top of the Object palette helps you find 
features quickly. Type text in the Search box and it displays all 
matching commands. 



Drag or double-click to add a command from the search results to 
the panel. 

 Buttons 

There are three types of buttons: 

 

The Action button executes a recorded Photoshop action.  The 
Action and Action Set properties are assigned in the Inspector 
palette. 



 

The Script button executes Extended JavaScript code in Photoshop. 

Click the Editor button  in the Inspector to open a text editor to 
enter code such as alert(“hello my first script button!”); 

 

The Script File button executes an Extended JavaScript file in 
Photoshop. The file URL can be an absolute or relative path of a file 
on the local hard disk. 

See section 4.1 for more information about relative paths. 



 Widgets 

There are four kinds of widgets: 

 Simple Text widget  

The Simple Text widget creates a rectangular box that can contain 
a text message.  

Click the Editor button  in the Inspector to open the Text Editor, 



where you can enter the text message. 

 SWF/Image widget  

The SWF/Image widget loads a GIF, JPEG, PNG, or SWF file into 
the panel. The URL field accepts any of the following forms: 

 URL: http://somesite.com/picture.png 
 Absolute path: /User/user/test.jpg 

 Relative path: test.gif or ./test.gif 
See section 4.1 for more information on relative paths.  



NOTE: If the loaded SWFs are built with Flex project in Flex Builder, they 
cannot be displayed in Configurator, but they can be displayed in the created 
panel in Photoshop. 

 Movie Player widget  

The Movie Player widget plays Flash video (.FLV) files in the panel.  

The URL field for the Movie Player widget accepts the same forms 
as the SWF/Image widget. 

         
 Feature Search widget  

The Feature Search widget searches Photoshop features. To use it 
in Photoshop, you type a string in the Feature Search field in the 
Configurator panel, and it displays all matching commands. When 
you click a command in the list of results, the command is executed. 



3.4 Panel Editor 
Multiple panels can be opened at same time. Click a tab to switch 
panels.  

An asterisk * means the panel has been modified but not saved. 
Position the cursor over the tab and it displays the full path of the 
saved panel file. 



Several operations are supported in Panel Editor:  
 Select objects 

o 

o 

o 

o 

o 



 Move objects 
o 

o 

o 

NOTE: Configurator does not let you move objects past the panel s edge. 

 Resize objects 



NOTE: Configurator does not let you resize objects past the panel s edge. 

 Align or distribute selected objects 

 Auto Layout all objects  

 Resize a panel 



NOTE: Configurator does not let you resize a panel to an area too small to fit 
its contained objects. 

3.5 Inspector palette 
Inspector palette is on the right side of Configurator. The upper 
area specifies Panel attributes; the lower area specifies Object 
attributes. 

The Panel area lists the attributes of the current panel: 
 

 

 

The Object area lists attributes of the currently selected object(s). 
Different object types have different attribute sets. Some common 
attributes include the following: 

 



 

 

 

 

 

Special attributes: 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

You can use the Inspector to modify the attributes of multiple 
objects. If multiple objects are selected, the Inspector displays the 
attributes shared among the objects. If an attribute varies among 
the selected objects, the Inspector displays (multiple values) in that 
attribute field. 



If you enter a value in the Inspector, it is applied to all selected 
objects. This is a good way to align multiple objects or resize all 
buttons to the same dimensions. 
NOTE: Setting the X and Y coordinates to the same value makes selected 
objects overlap. Press Ctrl + Z (Windows) or Command + Z to undo mistakes, 
or use the Auto Layout button to automatically lay out all objects.

3.6 Preferences 
Choose Edit > Preferences or press Ctrl + K (Windows) or 
Command + K (Mac OS) to open the Preferences dialog box. It will 
include two areas. 

 General: 
Specifies a default size for new panels. 



 Export: 

Lets you generate related assets upon exporting a panel. For more 
information about the Export preferences options, see Chapter 4. 



4 Package and deploy a panel 

4.1 About relative paths 
Three types of Configurator objects accept relative paths as an 
attribute. These objects are the Script File button, the SWF/Image 
widget, and the Movie Player widget. 

A URL that starts with ./ or ../ is treated as a relative path. The base 
path used to resolve a relative path is different in Configurator and 
in Photoshop. 

Configurator resolves the relative path based on the parent folder 
of the panel .GPC file. 
NOTE: If the current panel isn t saved, Configurator cannot resolve the 
relative path. Position the cursor over the tab in the Panel Editor to see the 
full path of current panel file.

For example, if a panel is saved with the path 
/Users/user/Documents/Untitled-1.gpc and there s a file test.jpg in 
same folder, Configurator can resolve this file with the relative 
path ./test.jpg or test.jpg. 

When the panel is exported to the Adobe Photoshop CS4/Plug-



ins/Panels folder, the referenced files in the same folder, such as 
test.jpg, are automatically copied to that folder. 

After exporting the folder structure looks like this: 

 
When the panel is opened in Photoshop, Photoshop resolves the 
relative path based on the parent folder of the .GPC file. In our 
example, that s the /Applications/Adobe Photoshop CS4/Plug-
ins/Panels/Untitled-1 folder. 

In another example the relative path ../../../../Presets/Scripts/Image 
Processor.jsx is resolved in Photoshop to the absolute path 
/Applications/Adobe Photoshop CS4/Presets/Scripts/Image 
Processor.jsx. 



4.2 Export a panel 
When you choose File > Save Panel, Configurator saves the panel 
file with the file extension .GPC. This file cannot be opened 
Photoshop. To create a panel that can be opened in Photoshop, you 
must export it as a Photoshop Flash Panel extension. 

If Photoshop CS4 is installed on same computer that s running 
Configurator, the panel can be exported directly to the Adobe 
Photoshop CS4/Plug-ins/Panels folder. Then start Photoshop and 
choose Windows > Extensions to open the custom panel. 

If Photoshop CS4 is not installed on same computer that s running 
Configurator, or you need to run the panel on a different computer, 
export the panel to any folder, and see section 4.3 to learn how to 
package panel so that it can be shared with other people and used 
on other computers. 
NOTE: If you export a panel for the first time while Photoshop is open, you 
must restart Photoshop in order for it to find panel and display it in the 
Extensions menu. When Photoshop is restarted, it reloads all the Flash panels 
in the Plug-ins/Panels folder.  

4.3 Package a panel for sharing 
You must package a panel to share it with others. To package a 



panel, you must first export an .MXI file from Configurator and then 
use Adobe Extension Manager CS4 to convert it to an .MXP file.  

Select the option Generate MXI in Configurator preferences to 
generate an MXI file upon export that can be recognized by 
Extension Manager CS4.  

When a panel is exported to a folder, the file structure looks like 
this: 

Double-click the file Untitled-1.mxi to open Extension Manager CS4 
and have it save the panel as an Untitled-1.mxp file. The .MXP file 
can be deployed by Extension Manager CS4 on other computers. 

For documentation on Extension Manager, go to 
http://help.adobe.com/en_US/ExtensionManager/2.0/. 



4.4 Package a panel for CSXS Extension MXP 
When the you select the option Generate CSXS Extension Manifest 
in Configurator preferences, Configurator exports an .MXI file that 
can be packaged as a CSXS Extension MXP file. 

CSXS Extension MXP is supported by Extension Manager 2.1 or 
later. Photoshop CS4 comes with Extension Manager 2.0. To 
upgrade to 2.1, install the patch located at 
http://www.adobe.com/exchange/em_download/index.html. 
NOTE: Panels exported as CSXS extensions can contain only alpha characters 
and numbers in their names. 

4.5 Package a panel as a ZIP file 
Panels can be shared without Extension Manager by packaging the 
exported panel folder into a .ZIP file. Copy the .ZIP file to the other 
computer and extract it to the Photoshop CS4/Plug-ins/Panels 
folder. 

4.6 Working offline in Photoshop 
If you are working offline in Photoshop, Configurator SWF/Movie 



widgets that have online URLs (such as http://somesite/some.swf) 
will not be loaded. When you decide to go online, you must re-open 
the panel to load the movie. 
NOTE: To work offline in Photoshop, choose Window > Extensions > 
Connections. Then choose Offline Options from the Connections panel menu 
and select Keep Me Offline. 

 



 

4.7 Export or deploy a panel on Windows Vista 
On Windows Vista, Configurator and Adobe Extension Manager 
should be run in Administrator mode or with the system UAC  
User Account Control disabled in order to export and package 
panels.



 

5 Information for developers 

5.1 Flash panels in Photoshop 
Configurator builds on the Flash panel extensibility functionality in 
Photoshop CS4. For more information, see the Photoshop panel 
developer s guides for Windows and Mac.  
http://www.adobe.com/devnet/photoshop/. 

5.2 Extended JavaScript 
The Script button can embed Extended JavaScript code in your 
custom panel. This script code can call the Photoshop DOM API, 
which lets developers create buttons that do diverse tasks in 
Photoshop. For more information about Photoshop scripting, see 
the Adobe Photoshop CS4 Scripting Guide. A link to the guide is in 
Appendix B. 
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