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§1 FLOW OF Emu2240 OPERATIONS

The flow of the operations for creating ML2240-use data using the Emu2240 is outlined below.

1. Creating sound data beforehand
Create a WAV-formatted sound data file (file extension: ".WAV") using the sound-recording
function of the soundboard.  This WAV file must be a 16-bit or 8-bit data file of the PCM
method (creating a 16-bit is recommended).  Note that the Emu2240 does not support the
creation itself of a WAV-formatted data file.

2. Registering sound data in the worksheet and evaluating the data
Register the desired sound data in the worksheet of Emu2240.  It is possible to delete
registered data, to change the order of registration, or to specify the use of the edit ROM
function of the ML2240, as required.
Also, evaluate sounds using the soundboard.
In addition, external programs can be registered and called up for waveform processing (this
function cannot be used in the current version).

3. Creating a ROM file
Create an Intel HEX-formatted ROM file (file extension: ".HEX") based on the data that has
been registered in the worksheet.  A binary file with an extension of ".BIN" can also be
created as required.

4. Evaluating data using the dedicated evaluation board
Transfer the ROM file that has been created in the binary format to the dedicated evaluation
board, and evaluate sound data.  Sound quality evaluation closer to the final format than
evaluation on the soundboard is possible.  (The current version does not support the
dedicated evaluation board.)

5. ROM-writing with a general-purpose ROM writer
Write the ROM file into ROM using a general-purpose ROM writer.  With the
AR204/AR203/AR762 as a sound data edit tool, you can write using a dedicated ROM writer.
After writing, voice synthesis can be implemented by building the ROM and the ML2240 into
the target circuit.
The Emu2240 does not support the ROM-write operations themselves.
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§2 Emu2240 WINDOW DESCRIPTION

[Supported OS]

Microsoft Windows 98/98SE/Me/2000/Xp

[Appearance of the window]

[Worksheet]

The worksheet is a table for registering what types of WAV-formatted sound data files are to be assigned in
what order.
In a vertical direction, the worksheet has 1,024 lines, in each of which one sound data item can be registered.
In a horizontal direction, the worksheet consists of nine fields: "User Adrs" (user-assigned word), "Phrase"
(serial number of the phrase), "Name" (name of the sound data file), "Title", "Fs[kHz]" (sampling frequency),
"St/Mo" (stereo/monaural identification), "Size [word]" (data size in word count), "Time [s]" (playback time),
and "Play Method" (playback method).
The display can be scrolled vertically using the scroll bar located at the right end.  The display can also be
scrolled upward by pressing the upward arrow key while holding down the control (Ctrl) key, and downward
by pressing the downward arrow key while holding down the control key.
The expansion/contraction of the window in a horizontal direction changes only the size of the "Title" field
correspondingly.  If the window is contracted horizontally with the "Title" size minimized, each field will be
moved out from the window display area in order with the rightmost field first.

[Menu bar]

[File] menu items
[New] ... Clears the worksheet to its initial status.

[Open] ... Reads a worksheet file (ROM creation information file.  Extension:
".MKE") and displays the file on the screen.

Title bar Menu bar Toolbars

Worksheet Status bar Scroll bar
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[Save] ... Updates the worksheet file under the current file name.

[Save As] ... Names the worksheet file before saving it.

[Exit] ... Terminates the application program and closes the window.

[Edit] menu items
[Undo] ... Undoes the most recent action and restores the original status.

[Register] ... Registers sound data in the selected line.

[Cut] ... Copies onto a special clipboard the data registered in selected lines, and
then clears the data.  The selected lines are left as blank lines, without
moving the subsequent lines up.

[Copy] ... Only copies onto a special clipboard the data registered in selected lines.

[Paste] ... Pastes the contents of the clipboard to the line directly above a selected
line.

[Delete] ... Copies onto a special clipboard the data registered in selected lines, and
then deletes the data.  The selected lines are deleted and the subsequent
lines are moved up.

[Insert] ... Inserts one line of space (data-unregistered line) into the line directly
above a selected line.

[Pack] ... Moves lines up after deleting all blank lines (data-unregistered lines).

[Joining] ... Specifies that the function that integrates all selected lines into a single
phrase (the edit ROM function of the ML2240) should be used.

[Partition] ... Decomposes the lines that were integrated with [Joining] into their
respective statuses .

[Insert Silence] ... By using the silence function of the ML2240, inserts silence into the line
directly above a selected line in the phrase which was created with
[Joining].

[Re-sampling] ... (This function cannot be used in the current version.)

[Control] menu items
[Playback] ... Plays back the sound data of the selected line on the soundboard.

Sounds are played back with their original PCM sound quality.
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[Convert & Play] ... Plays back the sound data of the selected line on the soundboard.  The
quality of the playback sound is equivalent to that specified in [Play
Method].

[Stop] ... Stops the sound that is being played back.

[Translate] ... (This function cannot be used in the current version.)

[Board Play] ... (This function cannot be used in the current version.)

[Board Stop] ... (This function cannot be used in the current version.)

[Tool] menu items
[Call Tool1] ... (This function cannot be used in the current version.)

[Call Tool2] ... (This function cannot be used in the current version.)

[Call Tool3] ... (This function cannot be used in the current version.)

[Create] menu items
[ROM File] ... Creates an Intel HEX-formatted ROM data file based on the current

settings of the worksheet.

[Setup] ... Allows you to make various settings.

[View] menu items
[Information] ... (This function cannot be used in the current version.)

[Command List] ... (This function cannot be used in the current version.)

[Toolbar] ... Shows or hides the toolbar. 

[Toolbar 2] ... Shows or hides toolbar 2.

[Status Bar] ... Shows or hides the status bar.

[Help] menu items
[About Emu2240] ... Opens the program version/copyright information dialog box.

[Status bar]

Displays the following information:
- Brief explanation of the menus/toolbar, and other information
- Whether the edit ROM is present
- Whether the evaluation board is present (The current version always displays "off".)

§3 VARIOUS SETUP ITEMS

Selecting [Setup] from the [Create] menu opens the [Setup] property sheet.
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[Create] property page

[Title]
Enter the title (explanation) of the worksheet file. (Arbitrary)

[Create ROM File]
Select either "HEX only" (create HEX only) or "HEX & Binary" (create both).

[Use ROM]
(Setting disabled in the current version.)

[Re-sampling]
(Setting disabled in the current version.)

[Action] property page

[At Mouse Double Click]
Select whether, when the left button on the mouse is double-clicked on any line of the worksheet, a sound
file is to be registered ("Register"), or whether that line is to be played back ("Playback"), or whether the
file registered on that line is to be delivered and then [Call Tool1] is to be executed.
([Call Tool1] cannot be selected in the current version.)

[Control] property page

[Background Color]
Specify the displaying color for each of [Joining (1)] , [Joining (2)]), and [Selected Line]).

[COM Port]
(Setting disabled in the current version.)

[Rate]
(Setting disabled in the current version.)

[View] property page

On this page, specify what items are to be displayed in what order on the worksheet.  In other words,
worksheet display can be customized.

[Item 1] to [Item 9] each have a [View] check box, a [Contents] list box, and an [Order] list box.
[View] specifies whether the item is to be displayed or not; [Contents] specifies display contents; [Order]
specifies at what number from the leftmost position the item is to be displayed.
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§4 LINE SELECTION

For Emu2240, the operator is to first select the line(s) to undergo processing, and then to select the type of
processing.

• Left-clicking on a line selects the line, highlighting it in reverse video.
Selecting a line different from a line already selected changes the preselected line into an unselected
status, displaying the newly selected line in reverse video.

• Left-clicking while holding down the Ctrl key allows you to select multiple lines.
(If a line already selected is left-clicked while the Ctrl key is being held down, that line will be
unselected.)

• Left-clicking while holding down the Shift key means that all lines from the line that was selected
immediately before the currently selected one (last selected line) to the currently selected line have been
selected.
(All other lines, even if they include already selected ones, become unselected.)

• Left-clicking while holding down the Ctrl key and the Shift key together means that all lines from the line
that was selected immediately before the currently selected one (last selected line) to the currently
selected line have been selected.
(The selection status of all other lines will be maintained as it is.)

§5 SOUND DATA FILE REGISTRATION

1. Select the line(s) to be registered.
Alternatively, double-click the left mouse button on the desired line(s).
For registration by double-clicking, step 2 below is omitted automatically.

2. Select [Register] from the [Edit] menu.

3. The [Select Voice File] dialog box opens.  Select the sound data file to be registered.

4. The [Register] dialog box opens.  Enter the information to be registered.

The registration items are as follows:

[File], [Playback Method], [Title](arbitrary)
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5. Registered information is displayed on the worksheet.

If the registration has been made in the blank lines existing within the range of the phrases which were
created using the [Joining] function, that phrase is regarded as part of the phrase group which was created
with [Joining].

Double-clicking the left mouse button on a registered line allows the registered information to be changed.

§6 EDIT ROM ASSIGNMENT AND UNASSIGNMENT

The ML2240 has a function referred to as the edit ROM.  The use of this function allows more than one phrase
to be continuously vocalized just by specifying one user-assigned word, and the interval between sounds to be
adjusted by inserting silence into the phrases.

 
1) Joining lines with the edit ROM

Take the following procedure to join lines with the edit ROM:

1. Select all lines to be joined with the edit ROM.
The lines to be joined can include blank lines.  These blank lines are ignored during joining.

2. Select [Joining] from the [Edit] menu.

3. The selected lines are joined with the edit ROM.
All the lines that have been joined with the edit ROM take the same "User Adrs" value, and this value is
displayed only for the first of the joined lines.
After the lines have been rearranged, all "User Adrs" numbers and "Phrase" numbers are also rearranged
automatically.
The phrases that have been joined with the edit ROM are displayed in a background color different from
that of the phrases that have not been joined.

2) Decomposing the edit ROM

Execute [Partition] if it is required that the phrases that have been joined into a single user-assigned word
using the edit ROM be returned to the original independent phrases.
The decomposing procedure is as follows:

1. Select more than one line of the phrases which were joined with the edit ROM.

2. Select [Partition] from the [Edit] menu.

3. The edit ROM is decomposed to return the selected lines into the original phrase status.
As the decomposition occurs, all "User Adrs" and "Phrase" values are re-assigned.
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3) Inserting silence into the edit ROM

Silence data can be inserted into the phrase group that was created by edit ROM synthesis.  The amount of
silence data in this case can be much smaller than that of silence data included in the sounds.  The inserted
silence data can be used for sound-to-sound interval adjustment with the silence function.
(Silence cannot be inserted into the first or last phrase of the edit ROM.)

Use the following procedure to insert the silence function into the edit ROM:

1. Select any line in the phrase group that was created by edit ROM synthesis.
Silence will be inserted into the space immediately before the selected line.

2.  Select [Insert Silence] from the [Edit] menu.

3. The [Insert Silence] dialog box opens.  Enter the length of silence.

4. Inserted silence data is displayed on the worksheet.
"<Silence>" is displayed under "Name".  "Time" shows the length of the silence.
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§7 WORKSHEET PROCESSING

Data that has been registered on the worksheet can undergo various types of processing with the [Edit] menu.

1) Cutting lines

Data registered on any lines can be cleared from the worksheet after being copied onto a special clipboard.
The special clipboard mentioned above is for the Emu2240 use only and does not permit data exchange with
other application programs.
Use the following procedure to cut lines:

1. Select all lines to be cut.

2. Select [Cut] from the [Edit] menu.

3. All selected and registered lines are copied onto a special clipboard and then cleared.
The selected lines are left as blank lines without moving the subsequent lines up.
To move following lines to the left, execute [Delete], instead of [Cut].
After the selected lines have been cleared, all "User Adrs" and "Phrase" numbers are reassigned
automatically.

If any blank lines are selected, these lines will not be copied onto the clipboard.

2) Copying lines

Data registered on any lines can be copied onto a special clipboard.
Use the following procedure to copy lines:

1. Select all lines to be copied.

2. Select [Copy] from the [Edit] menu.

3. All selected and registered lines are copied onto a special clipboard.
If any blank lines are selected, these lines will not be copied onto the clipboard.
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3) Pasting lines

The contents of the clipboard can be inserted directly above any line.
Take the following procedure to paste lines:

1. Select a pasting destination line.

The contents of the clipboard are ready to be inserted directly above the selected line.
If more than one line is selected, only the uppermost line of all selected lines will be the pasting
destination.

2. Select [Paste] from the [Edit] menu.

3. The contents of the clipboard will be inserted directly above the selected line(s).

As a result of insertion, subsequent lines are moved down.  Since the worksheet consists of 1,024 lines,
the contents of the lines overstepping this range will be lost.
After the contents of the clipboard have been pasted, all "User Adrs" and "Phrase" numbers are reassigned
automatically.

The contents, if pasted into the phrases that were joined with "Joining," will all be incorporated as part of
the synthesis.
However, only when the first line in the phrases that were joined with "Joining" is selected as the pasting
destination, will the contents be incorporated as an independent phrase(s), not as part of the synthesis.

Even if the contents of the clipboard are part (or all) of the joined phrase group, when the pasting
destination is other than this phrase group, the contents of the clipboard will be pasted as independent
phrases (they will NOT be pasted by holding the joined status of the phrases as it is). 

If the clipboard contains silence data that was inserted with [Insert Silence], the silence data will be pasted
only when the clipboard contents are pasted into the phrase group that was created by "Joining".

Silence data will not be pasted if clipboard contents are pasted into a destination other than a phrase group
which was created by "Joining".
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4) Deleting lines

Data registered on any lines can be deleted from the worksheet after being copied onto a special clipboard.
Take the following procedures to delete lines:

1. Select all lines to be deleted.
Blank lines can be included in the selected lines.

2. Select [Delete] from the [Edit] menu.

3. All the selected lines are copied onto the special clipboard and then deleted.
Subsequent lines are moved up.
To keep the lines as blank lines without moving the subsequent lines up, execute [Cut] instead of [Delete].
As a result of deletion, all the [User Adrs] and [Phrase] are automatically reassigned.

When blank lines are selected, the lines are not copied onto the clipboard.

5) Inserting a blank line

Insert only one blank (unregistered) line in any line.

1. Select the line at which a blank line is to be inserted.
A blank line is ready to be inserted directly above the line that was selected.
Multiple lines can be selected.  In that case, one blank line is inserted directly above each of the lines
that were selected.

2. Select [Insert] from the [Edit] menu.

3. A line is inserted directly above the selected line.
As a result of insertion, subsequent lines are moved down.  The contents of lines exceeding line 1024
will be lost since the number of lines of a worksheet is restricted to 1024.

When a blank line is inserted in the phrase group that was joined by [Joining], the blank line will be
incorporated as a part of the editing ROM.  Using this function, a sound phrase can be added in the
middle of editing ROM.

However, if the first line of the phrase that was joined by [Joining] is selected for insertion, the blank line
that was inserted becomes an independent phrase, not a part of the editing ROM.
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6) Deleting blank lines to move lines up

Moves lines up after automatically deleting all the blank (unregistered) lines.

1. Select [Pack] from the [Edit] menu.
It is not necessary to select lines in advance.

2. All the blank lines are deleted to move remaining lines up.

7) Undoing the most recent action

Restore operation by canceling the most recent action.  (Actions that can be restored are limited.)
[Undo] itself cannot be restored (canceled).
Take the following procedure to undo an action:

1. Select [Undo] from the [Edit] menu.
The [Undo] menu item also displays the menu item to which processing can actually be restored
(displayed in brackets ([  ])).

2. The most recent action is undone and the processing is restored.
Processing can be restored up to a maximum of five steps (five menus).

§8 WRITING AND READING WORKSHEET FILES

The contents that are registered or processing in a worksheet is written/read as a worksheet file.

The extension of a worksheet file is ".MKX".

1) Write

Select either of the following.
[Save] from [File] or [Save As] from [File].

2) Read

Select [Open] from the [File] menu.
The [File] menu displays up to four files that have recently been opened.  A file can be selected from the
menu.
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§9 TESTING SOUND USING A SOUNDBOARD

The sound that is registered in a worksheet can be tested using a soundboard.

The sound quality according to the [Playback Method] that was registered can also be tested in addition to the
sound in the WAV file.

Take the following procedure to test sound.

1. Select the line(s) in which the sound to be tested has been registered.

2. Select [Playback] or [Convert & Play] from the [Control] menu.
When multiple lines are selected, the registered line at the uppermost position is tested.
When the registered line at the uppermost position is a part of the phrase group that was joined by
[Joining], the entire phrase group is tested.

3. The specified sound is played back on the soundboard.
When [Playback] is selected, the sound in the WAV file itself is played back.
When [Convert & Play] is selected, the sound is played back with the sound quality of the playback
method that was specified in [Playback Method].

To test the phrase group that was joined by [Joining], the sound in each file is played back sequentially.
Therefore, an unnecessary gap may be generated between one file and the next.

Testing ends after the sound is played back once.
To terminate testing forcibly during playback, select [Stop] from the [Control] menu.
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§10 CREATING A ROM FILE

After completing registration of all the necessary sounds in a worksheet and various necessary processing and
testing, create a ROM file in the following procedure.

1. Select [ROM File] from the [Create] menu.
It is not necessary to select a line in advance.

2. Specify the name of the ROM file.
When a common file dialog is opened, specify the folder to which the ROM file is to be written and the
name of the ROM file (.HEX).

3. Specify a ROM size.
When the [ROM Size] dialog is opened, select a ROM size.  When the selected ROM size is smaller
than the size of the data that is actually created, multiple ROM files are created.  In this case, the file
names will be created by appending serial numbers following the specified file name: "xxx1.HEX",
"xxx2.HEX", "xxx3.HEX" and so on.

4. A ROM file is created.
An information file is also created, indicating how the sound data is mapped within ROM.  The
information file is a text file with extension ".INF".

[Notes]
• The following 12 types of sampling frequencies correspond to ML2240.

4.0 kHz, 5.3 kHz, 6.4 kHz, 8.0 kHz, 10.7 kHz,
12.8 kHz, 16.0 kHz, 21.3 kHz, 25.6 kHz, 32.0 kHz,
42.7 kHz, 48.0 kHz
(When the original oscillation frequency is 4.096 MHz)

When a ROM file is created using a sample frequency other than those indicated above, 4.0 kHz is
registered.

However, when the sampling frequency is 11.025 kHz, 10.7 kHz is registered.  When the sampling
frequency is 22.05 kHz, 21.3 kHz is registered.

• When [Create] - [ROM File] is selected, the contents of the worksheet itself are not written to the file.
Select [File] - [Save] or [File] - [Save As] to write the contents of the worksheet file.


