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1. Introduction

Overview
The Remote Communications (RCOM) program for the 875 Electrochemical Analyzer is a 
PC-based software package that permits you to monitor, configure, and calibrate up to two 
875 Analyzers remotely from a personal computer (PC). The PC communicates with an 
875 Analyzer through an RS-232-C serial port. When the analyzer is direct connected to the PC, 
an external modem is not required. However, when connection is via a telephone line, modems 
are required at each end.

The major benefits of the program are:

♦ Ability to operate up to two 875 Analyzers from a remote PC.

♦ Ability to transfer measurement data from the analyzer to a PC and configuration data 
in either direction between the analyzer and a PC.

♦ Ability to use the program with several different types of 875 Analyzers, now and in 
the future, because the program obtains its configuration data from the particular 
instrument to which it is connected.

The PC must be equipped with a Windows NT, Windows 95, Windows 98, or Windows 2000 
operating system. It does not run with Windows 3.1 or Windows CE. The PC must have the 
following minimum requirements:

♦ 90 MHz Pentium with 16 MB RAM or better computer 

♦ Hard drive with 5 MB of space

♦ RS-232-C Serial Port (COM1 or COM2)

♦ Mouse or compatible pointing device

♦ 4X CD-ROM drive (8X recommended).

The program can be executed for each communication port, up to a maximum of two, as shown 
in Figure 1.
1
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Figure 1.  External Interface between a Remote PC and Two 875 Analyzers

Reference Documents
Detailed information about 875 Analyzers can be found in the documents listed below.

Table 1. Reference Documents

Document Description

MI 611-222 Instruction — 875CR Contacting Conductivity/Resistivity Analyzer

MI 611-224 Instruction — 875EC Electrodeless Conductivity Analyzer

MI 611-225 Instruction — 875PH Electrochemical Analyzer

875
Analyzer

COM2COM1

Remote PC

875
Analyzer
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2. Installation

The -F option in an 875 model code or the RCOM Configurator Utility Kit (BS810NX) consists 
of three items:

♦ Configurator CD-ROM BS809WJ

♦ Cable BS809WH

♦ Instruction MI 611-226

Verify that all three items were included with your shipment.

Connecting the Analyzer and PC 
Attach the cable provided to your computer serial port (COM1 or COM2). If the computer serial 
port has a 25-pin connector, use a 25- to 9-pin adapter. Attach the other end of the cable to the 
RS-232-C connection on your analyzer.

Installing the Software
Perform installation while running the standard Windows installation program. Close all other 
running programs before starting your installation. 

Insert the CD-ROM in your computer and if installation doesn’t automatically start, select:

Start
Settings
Control Panel
Add/Remove Programs

Then follow the instructions to install the RCOM program by typing the CD-ROM drive letter, 
disk1, and using setup.exe as the command (for example, E:\disk1\setup.exe).

The installation procedure is automatic and prompts you for necessary information. 

After installation is complete, reboot your computer.
3
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3. Operation

Running the RCOM Program
To run the program, first connect the analyzer and PC, as explained in the Installation section of 
this instruction. Then double-click the RCOM icon or access the program from the Start menu. 
The Connect screen is presented.

 

Figure 2.  Connect Screen

Enter your passcode and select OK. The factory default passcode is 0800.

NOTE
If using RCOM with an 875EC Analyzer with Version 1 software, only log in with 
a Level 1 passcode. Failure to do this results in software “crashes” if specific 
functions in the Diagnostics menu are exercised. If using Level 2 or 3 passcodes, do 
not suspend a fault or erase the history log. 
Also, if using RCOM with an 875EC Analyzer with Version 1 software, the 
passcode cannot be changed from the RCOM program.

If the RCOM program is unable to connect to your analyzer, select Comm. Setup. The 
Connections Parameter screen is displayed. Make sure that the correct Port is selected and that 
the Baud Rate, Data Bits, Parity, and Stop Bits selections match those of the connected 
analyzer. Then select OK.
5
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Figure 3.  Connections Parameter Screen

The Passcode screen reappears. Enter your passcode. If it is a valid passcode, the Top Level Menu 
Screen is displayed.
6
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Figure 4.  Top Level Screen

Top Level Screen
The Top Level Screen contains a menu bar, toolbar, status bar, and mode tree. Each is described 
below.

Menu Bar
The Menu Bar contains File, Edit, View, Settings, Actions, and Help menus. Each is described in 
the following table.

Menu Bar

Tool Bar

Mode Tree

Status Bar
7
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Toolbar
The program is equipped with a toolbar at the top of the screen. It can be shown or hidden at any 
time by using the View menu. The icons on the toolbar are shown in Figure 5. A listing of the 
features and descriptions for the toolbar is given in Table 3.

Figure 5.  Toolbar Icons

Table 2. Menu Bar — Description of Functions

Top Level 
Menu Pick Submenu Pick Description

File New* Creates a preconfiguration database using a default 
database as a template.

Open..* Edits an existing configuration database.

Close* Closes the current configuration field.

Save* Saves the active document.

Save As..* Saves the configuration to a file

Download File From Analyzer Downloads the file from the analyzer.

Upload File To Analyzer Uploads the file to the analyzer.

Recent File* Shows the most recently accessed files for quick access.

Exit Quits the application.

Edit Undo* Reverses the previous action.

Cut* Cuts selected text and graphics from the file and places 
these items on the clipboard.

Copy* Copies selected text and graphics to the clipboard.

Paste* Pastes the contents of the clipboard to the file at the 
insertion point.

View Toolbar Shows or hides the toolbar.

Status Bar Shows or hides the status bar.

Settings Loop Back For factory only - do not use.

Setup Displays the Connections parameter screen.

Actions Connect Connects the analyzer to the PC.

Disconnect Disconnects the analyzer from the PC.

Help About RCOM Displays the software version number.
*Not available at this time.

1  2 3  4 5 6 7 8 9 10
8
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Status Bar
The program is equipped with a status bar at the bottom of the screen. It can be shown or hidden 
at any time by using the View menu. The status bar displays nine items of information: 

♦ The program status: Ready, Connecting, and so forth

♦ The communication status: On Line or Off Line 

♦ The type of the connected analyzer; for example, 875EC

♦ The hardware revision level 

♦ The current date

♦ The current time

♦ The language

♦ The passcode level.

Mode Tree
The Mode Tree enables easy access to the six analyzer modes: Status, Measurement, Hold, 
Calibration, Configuration, and Diagnostics. It also provides a shortcut means to the Download 
from Analyzer and Upload to Analyzer functions.

Connecting to an Analyzer
Communication is established between your analyzer and your PC upon startup. You can 
disconnect it and/or reconnect it by selecting Disconnect or Connect in the Action menu. 

Table 3. Toolbar Features and Descriptions

Item Feature Description

1 New* Creates a new database using a default database as a template.

2 Open* Edits an existing stored configuration database.

3 Save* Saves the active configuration database to a file.

4 Cut* Cuts selected text and graphics from the file and places it on the clipboard.

5 Copy* Copies selected text and graphics to the clipboard.

6 Paste* Pastes the contents of the clipboard to the file at the insertion point.

7 Print* Not available at this time.

8 About Displays the software version number.

9 Connection 
Parameters Screen

Displays the Connection Parameters screen.

10 Connect Screen Displays the Connect or Disconnect screen
*Not available at this time
9
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Reading Analyzer Data

After connecting the RCOM to an analyzer, select Measurement from the Menu Tree. The User 
Window is displayed to the right of the Menu Tree. This window continuously reads and displays 
measurement, absolute measurement, and temperature readings.

Figure 6.  Top Level Menu Screen with User Window

Changing to Another Mode
To change from one mode to another, select the new mode in the Menu Tree. If you select 
Measurement or Status, the desired screen is displayed. If you select Hold, Calibration, 
Configuration, or Diagnostics, the Mode Change screen first appears. To proceed, click on 
Enter. To exit the selected mode, click on the Mode button and then select the next mode you 
wish to enter from the Menu Tree.

NOTE
The Help button is not active at this time.

For a detailed description of each mode, refer to the instructions listed in Table 1.
10
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Figure 7.  Mode Change Screen

Downloading a File from the Analyzer
Configuration data can be downloaded from your analyzer and saved to a file that can later be 
copied to another analyzer. Calibration data can not be downloaded at this time. The size of such 
a file is approximately 10 KB. 

To download a file from the analyzer:

1. Hardwire your analyzer to your PC (see “Connecting the Analyzer and PC” on 
page 3).

2. Connect to your device via Action -> Connect.

3. Download the file via File -> Download File From Analyzer.

4. Save the file via File -> Save As. Use the extension .MAI.
11
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Uploading a File to the Analyzer

CAUTION!
Before using this function, it is highly recommended that you save the existing 
analyzer data in your database (see “Downloading a File from the Analyzer” on 
page 11).

To upload a file from the analyzer:

1. Hardwire your analyzer to your PC (see “Connecting the Analyzer and PC” on 
page 3).

2. Connect to your device via Action -> Connect.

3. Open the desired file via File -> Open.

4. Upload the file via File -> Upload File To Analyzer.
12



  

  

4. Use With Modems

Introduction
The RCOM program usually operates with the 875 Analyzer directly connected to a PC. 
However, it can optionally operate through standard telephone data modulator/demodulators 
(modems). Though RCOM does not manage a modem, the presence of modems does not 
interfere with its operation.

Modems can be used if a telephone connection is established first, and then RCOM 
communicates through the modems unknowingly. When you have finished using RCOM, the 
telephone connection must be explicitly broken.

NOTE
Although menu operation is possible through modems, it is strongly recommended 
that 875 Analyzer firmware upgrades be performed only by direct connection and 
not using modems.

Equipment
A summary of the required equipment is shown in Figure 8 and described below.

Figure 8.  Required Equipment for Operation With Modems

1. Serial cable supplied with the 875 Analyzer.

2. Null modem at the 875 Analyzer.

3. Standard RS232 cable.

4. External, stand-alone modem at analyzer end.

5. Telephone line dedicated to the 875 Analyzer.

6. Telephone line available to the PC when needed.

7. External, stand-alone modem at PC end.

8. Standard serial cable between the modem and PC.

9. Any adapters required by the various physical connectors.

875
ANALYZER

NULL
MODEM MODEM MODEM PC

PC875

SERIAL
CABLE

SERIAL
CABLE

PC TELEPHONE LINEANALYZER TELEPHONE LINE

1 2 4 5 6 7 83

875
13
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Connection from an 875 Analyzer to a PC requires external, stand-alone modems at each end. 
Foxboro does not recommend any specific modem, but it is useful if each modem is able to ignore 
its electrical control signals such as DTR and CTS.

The 875 Analyzer serial port connects with only three wires carrying data, and does not provide 
any control signals. Either additional wiring must be supplied, or the modem connected to the 
analyzer must be capable of answering an incoming call and transmitting data without the DTR 
or CTS control signals. Most modems are wired for connection to a PC and require the input and 
output wires to be crossed at the 875 Analyzer. This crossing, and potentially the DTR and CTS 
signals, are supplied by a component called a null modem.

The PC uses two different programs to establish the telephone connection and then to 
communicate with the analyzer. When changing from one program to the other, the modem 
must retain the telephone connection. This is impossible using the Windows operating system 
with internal modems. Therefore, an external modem is required. The external modem must be 
able to ignore its DTR input so that it does not hang up the telephone between the different 
programs.

Setup
1. Select Baud Rate

First choose a baud rate for the modem connection. Today’s V.90 modems can 
connect at baud rates up to 56 K. Therefore, they should work at the highest 875 
Analyzer rate of 19.2 K. If using older modems, the analyzer baud rate should be set 
not to exceed the practical connection speed of the modem.

2. Configure the Analyzer RCOM Parameters
At the analyzer front panel, enter Configuration mode, scroll down to Remote and 
select Port Settings. Set a practical Baud Rate; Data & Parity = 8, None; Stop 
Bits = 1; and Update Rate = Off.

3. Configure the Analyzer Modem
The modem to be used at the 875 Analyzer must first be connected to a PC for 
configuration. The null modem is not used at this time. Use a standard serial cable 
and connect it to one of the PC serial ports. 

Figure 9.  Connections for Configuring the Analyzer Modem

Open a plain terminal program, such as Hyperterminal. It is best to connect to the 
associated PC serial port instead of the modem. Use the desired baud rate. Referring 
to the modem user manual, set the switches and enter the commands required to get 
the modem to function as follows:

♦ Local echo off

♦ Online echo off

875
MODEM

PC

SERIAL CABLE
14
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♦ Result code replies disabled (at least in answer mode)

♦ Answer after one ring

♦ DTR overridden (ignored)

♦ Flow control disabled, CTS ignored

♦ RTS ignored

Save this configuration as the default in case of a power failure.

4. Connect the 875 Modem Through the Null Modem
Once the analyzer modem is configured, disconnect it from the PC cable, and 
connect it through the null modem to the analyzer serial cable. Also connect a 
dedicated phone line to the modem. 

5. Configure the PC Modem
Connect the modem for the PC to one of the PC serial ports using a standard cable. 
Once again, open a plain terminal program such as Hyperterminal and connect to the 
associated PC serial port instead of the modem. Use any baud rate greater than the 
analyzer baud rate. Refer to the modem user manual, and set the switches and enter 
the commands to configure the PC modem as follows:

♦ DTR overridden (ignored)

♦ Flow control disabled, CTS ignored

♦ RTS ignored

6. Connect the PC phone line to the modem.

7. Install the RCOM Program in the PC. See “Installing the Software” on page 3.

8. Connect the PC to its Modem
On the PC, open a plain terminal program such as Hyperterminal and connect to the 
PC serial port associated with the modem. Use any baud rate greater than the analyzer 
baud rate. Refer to the modem user manual, and enter the modem commands to dial 
the telephone number dedicated to the analyzer. The modems should connect. Then 
close the terminal program without hanging up.

NOTE
You must actually close this program to release the serial port. It is not enough 
simply to minimize the window. 

9. Set the RCOM Parameters
Start the RCOM program, and click the Comm Setup button. Select the Port 
connected to the modem, and the same baud rate used in the terminal program 
(might not be the same as the analyzer baud rate). Keep Data Bits = 8, Parity = 
None, and Stop Bits = 1. You may select a name for the modem connection. Click 
OK.

10. Enter the 875 Analyzer passcode. The Top Level Menu Screen is immediately 
displayed.

11. Immediately close the RCOM window. This saves the communication settings.

12. Open the terminal program again, and enter the modem commands required to hang 
up the phone line.
15
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Operation

1. On the PC, open a plain terminal program such as Hyperterminal and connect to the 
associated PC serial port (not the modem itself ). Use any baud rate at or greater than 
the analyzer baud rate. Refer to the modem user manual, and enter the commands to 
dial the telephone number dedicated to the 875 Analyzer. The modems should 
connect.

2. Close the terminal program without hanging up.

3. Start RCOM, enter the 875 Analyzer passcode, and click OK. The RCOM main 
menu should appear quickly. Use RCOM as you would with a direct connection. 
When done, close all RCOM windows.

4. Open the terminal program again, and enter the modem commands required to hang 
up the phone line.

NOTE
If Step 4 is not done, the phone lines remain connected, accumulating toll charges.
16
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