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1 Getting Started

1.1 Download

The current version of the TextGridLab is available as a free download from

www.textgrid.de

for various operating systems. Before you can use the software, you must install a Java

Runtime Environment (JRE) version 6 or higher. You can download an appropriate

version from

http://java.com/download

1.2 Account

A lot of functionality including read-only access to published information and working

with local files is available without logging in. To be able to store your own data in

the repository, however, you need to identify yourself and login. If your institution

participates in the DFN Shibboleth federation, you may simply use your institutional

login. Alternatively, you can request a specific TextGrid account from our web site

www.textgrid.de

1.3 Welcome Screen

After installing the TextGrid Laboratory you can start the software. The Welcome

Screen (figure 1.1 on the following page) enables you to do different things:

• Login

• Start a tool: Search (� chapter 17) and Dictionary Search (� chapter 14) are

available without login.
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1 Getting Started

Figure 1.1: The Welcome Screen

Figure 1.2: Login Screen

2



1.3 Welcome Screen

Figure 1.3: Userinformation Wizard

If you click “Login”, a new window opens (figure 1.2 on the preceding page). Use

your login and password (� section 1.2) or choose the login via DFN-AAI. If you have

forgotten your password, use the button “Forgot Password?” further down. After your

first login you are asked to complete your user attributes and to accept the TextGrid

Terms of Use (figure 1.3). If you set the option “searchable”, other TextGrid users

can find you by your name, institution or e-mail-address. The fields with an * are

mandatory. You can change your attributes at any time via “Help > Authentication”

(� section 2.1.1).

After a successful login the Welcome Screen appears again, now with your TextGrid

login shown in the center of it. After this you can choose one of the tools presented on

the screen:
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1 Getting Started

Usermanagement (� chapter 3)

Search (� chapter 17)

Text-Image-Link Editor (� chapter 13)

XML Editor (� chapter 12)

Dictionaries (� chapter 14)

Aggregations (� chapter 15)

How to use these tools is explained in separate chapters of the TextGrid Help. You can

choose to visit the online help first or to use the functions possible via the menu bar

that is explained as part of the user interface (� chapter 2). In the chapter about the

User Interface you will also find information about the surface structure of the Text Grid

Laboratory working bench.

4



2 User Interface

The User Interface (figure 2.1 on the next page) consists of general bars and tool-specific

perspectives.

2.1 Bars

The menu bar at the top of the screen offers hierarchical access to most of TextGrid-

Lab’s functionality. The toolbar below offers quick access to the most used tools and

components plus some tool-specific functions (figure 2.2 on the following page). Use the

perspective bar right to the toolbar to switch between already opened tools you have

used in this session.

2.1.1 Menu Bar

The menu bar consists of several items: “File”, “Edit”, “XML”, “Tools”, “Window”,

and “Help’.

Under “File” you can manage:

• Aggregations (� chapter 15)

• Opening, saving and closing projects, objects, and local files

• Revisions (� chapter 8)

• Publish (� chapter 16)

• Opening an object via its URI

• Metadata (� chapter 9)
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2 User Interface

Figure 2.1: Exemplary User Interface with Empty Search

Figure 2.2: Menu Bar and Toolbar in Detail
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2.1 Bars

• Import (� chapter 6) and Export (� chapter 7)

• Hide network warnings

• Restart the TextGridLab

“Edit” offers operations for the XML Editor and the Text-Image-Link Editor. Under

“XML” you can find functions for working with XML code in the XML Editor (� chap-

ter 12 and chapter 13).

“Tools” allows you to open every tool at any time. With “Show” you can open the

TextGrid views, i.e. the Navigator (� chapter 4), the Dictionary Results View (� sec-

tion 14.4), the Metadata Editor (� chapter 9) and the Unicode Character Table (� chap-

ter 11) but also others that are for the most part described in the Eclipse documenta-

tion:

http://www.eclipse.org/documentation/

“Window” gives you the possibility to open a new editor if one editor is already opened.

Furthermore it has options to navigate through the Laboratory:

• Quick access defines the appearance of fast views when opened

• You can activate and switch between editors

• Activated editors can be minimized and maximized

• You can choose the previous perspective, editor or view

In “Window” you can also change the preferences. Most of the possibilities are de-

scribed in the Eclipse documentation. But some preferences affect the TextGridLab

directly:

• The “TextGrid Content Types and File Extension Mapping” configures the map-

ping between TextGrid Content Types (as regular expression matching the content

type metadata field of objects) and the internal file extensions.

• In the “TextGridLab Dialog Settings” the user can choose if CRUD warnings

should be shown to indicate Database problems.

• In “TextGridLab Server and Proxy”’ proxy server and compressed data transfer

can be configured.

Under “Help” in the menu bar you can

• open the Welcome Screen

7
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2 User Interface

• see and change your authentication data

• use the help (� chapter 18)

• report a bug and save the logfile

• see keyboard shortcuts by clicking “Key Assist...”

• handle software updates

• get information about the currently used TextGrid version

2.1.2 Toolbar

The toolbar comprises some elements that are always enabled and elements that are

only enabled if special tools are opened. The second kind of elements are described in

the entries about these tools. The permanent elements are:

opens the Welcome Screen (� section 1.3)

allows you to create new projects and aggregations (� chapter 5)

saves the currently opened document

opens the Aggregation Composer (� chapter 15)

opens the Dictionary Search (� chapter 14)

opens the Text-Image-Link Editor(� chapter 13)

opens the Project and User Management (� chapter 3)

opens the Search (� chapter 17)

opens the XML Editor (� chapter 12)

opens the Metadata Editor (� chapter 9)

opens the Unicode Character Table (� chapter 11)

opens the Help (� chapter 18)

2.1.3 Perspective Bar

The perspective bar allows access to perspectives that are currently open, as well as

providing a way to open a new perspective by clicking . By right-clicking it is possible

to customize the perspective and the toolbar structure as well. (For more information

see http://www.eclipse.org/documentation/).
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2.2 Views

2.1.4 Status Bar

The status bar always shows you in the left corner the icon to open new views. At the

right corner the user currently logged in is presented. Depending on the views open

there can be additional information in the status bar.

2.2 Views

There are components with a specific functionality that are re-used in various tools.

Building blocks like this are called views. Views can be started from icons in the toolbar

or by using the respective menu item from the “Tools” menu.

It is possible to detach a view by using the context menu so that it can be placed

wherever needed. A view can also be compiled as a “fast view” via the context menu.

They are represented by toolbar buttons on the bar initially on the bottom left of the

workbench window. By clicking the button, the view opens in the current perspective.

As soon as you click outside that view it is hidden again.

Each view has a title bar. They allows one to set several default options:

• You can move a view by dragging its title bar with the mouse.

• Resize views by dragging the border between screen components.

• Maximize or minimize or remove a view.

By right-clicking in the title bar a context menu is opened that gives you some more

possibilities:

• You can determine a view as detached or fast view.

• You can restore and close the view.

• You can also move a tab group after selecting this option in “Move” of the view’s

context menu.

• You can select a border to change the size of the view.

• You can maximize and minimize the view.

Multiple views can be stacked on top of each other. Only the topmost one of these

views is visible. Click a background view’s title bar to make it visible. For example, the

Navigator (� chapter 4), the Metadata Editor (� chapter 4) and the Unicode Character

9



2 User Interface

Table (� chapter 11) in the perspective of the XML Editor (� chapter 12) are arranged

in this way by default.

2.3 Perspectives and Editors

A specific arrangement of user interface components are defined as a perspective. Edi-

tors like the XML Editor (� chapter 12) are close relatives to views, with a few differ-

ences:

Unless re-arranged, all editors open in a central area typically in the middle of the

screen as tabs stacked on top of each other. While you typically have one view of a kind

whose contents depend on the selected object, you can open a separate editor for each

object you want to edit. The editor will stay open until you explicitly close it or the

software. Editors can contain unsaved content. In this case their title is marked with

an asterisk (*).

2.4 Selection and Context Menu

Large parts of the user interface’s contents and functionality depend on the current

selection. To select something in a list or tree, single-click it. To select multiple objects,

control-click them or command-click them on a Mac, or use shift-click to select a range of

objects. You can also combine the control and shift keys with the cursor and space keys

to select without using the mouse. In a text editor, you can select by simply dragging

the mouse or using shift and the cursor keys.

2.5 Shortcuts

[Alt+-] Show System Menu

[Alt+Shift+Q,Q] Show View

[Crtl+3] Quick Access

[Crtl+F6] Next editor

[Crtl+F7] Next view

[Crtl+F8] Next perspective

[Crtl+F10] Show View Menu

[Crtl+M] Maximize active editor or view

[Crtl+S] Save
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2.5 Shortcuts

[Crtl+Shift+F6] Previous editor

[Crtl+Shift+F7] Previous view

[Crtl+Shift+F8] Previous perspective

[Crtl+Shift+E] Switch to editor

[Crtl+Shift+L] Key Assist

[Crtl+Shift+S] Save All

[Crtl+Shift+W] Close All

[Crtl+W] Close

[F12] Activate editor
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3 Project & User Management

The Project & User Management allows you to create and manage projects, to add users

to a project and assign roles to them.

3.1 Open Project & User Management

There are several possibilities to open the Project & User Management:

• Click “Project & User Management” in the Welcome Screen (� section 1.3)

• Select the tool “Project/User Administration” from “Tools” in the menu bar

• Click the icon in the toolbar below

3.2 Project & User Management Perspective

The perspective is subdivided in two views. The Navigator on the left, the User Man-

agement View on the right side (figure 3.1 on the next page).

3.3 Navigator View

Projects in TextGrid are used to manage access to objects. Any TextGrid object belongs

to some project. Objects belonging to a project are listed in the Navigator. To manage an

already existing project select it in the Navigator by left-clicking. The users associated

with this project are shown in the User Management view. To handle objects and

projects, use the Navigator (� chapter 4).
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3 Project & User Management

Figure 3.1: Project and User Management

3.4 User Management View

When a new project has been created, project users can be added and roles can be

assigned to them. To be selected users must previously have logged into TextGridLab at

least once. You can add new members to your project by searching for them by name,

e-mail address or organization. * matches any letters. When clicking “Search Users” or

pressing the enter key, the checkbox “Show Search Results” is automatically activated

and the results are shown in the list of users above with the icon .

You can also add new members to your projects by listing users you were working with

in previous projects. Mark “Show Contacts” to do this. Your contacts are marked with

a special icon .

Choose the roles for the new user by marking the boxes and click “Apply Changes”. The

boxes become white and the icon in front of the names added to the project changes

into another symbol . Click “Revert Changes” to remove changes that are not applied

yet. Changes not yet applied are presented in red boxes. There are four possible roles

for users in TextGrid and every role has specified rights:
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3.5 Interaction with Other Components

Project Manager Delegate, create rights for projects; delegate,

publish rights for resources

Authority to delete Delete rights for resources.

Editor Read, write rights for resources.

Observer Read rights for resources.

Project Rights Resource Rights

Delegate Edit the user/role as-

signment for the project

Modify rights for the resource.

Publish Publish a resource. The

resource will be then world-

readable and cannot be

deleted or updated anymore.

Delete Delete unpublished resources

Create Create new projects Create new resources in the

project

Write Write (i.e. update) unpub-

lished resources.

Read Read resources in the project.

Rights in TextGrid are non-hierarchical. If users are meant to have full rights, they must

be assigned the roles “Project Manager”, “Authority to delete” and “Editor”.

Roles with their respective rights can be withdrawn from users by someone having the

authority to do. Click at least one role of the user in question in the list of existing users

and press “Apply Changes”.

3.5 Interaction with Other Components

The User Managements interacts with the Navigator (� chapter 4) that is mainly used

for managing projects and objects. The Navigator view is part of the Projects and

User Management perspective. By right-clicking a project in the Navigator the User

Management can be started.
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4 Navigator

The Navigator is a project browser giving the users access to all materials related to the

project on which they are working.

4.1 Open the Navigator

The navigator is, by default, part of the Project & User Management module and the

Aggregation Composer perspective. The Navigator can be opened in all perspectives or

re-opened:

• by selecting “Tools” in the menu bar and afterwards the items “Show View” and

“Navigator”

• by clicking on the Navigator icon in the toolbar.

Using the Navigator view requires authentication. At least one perspective has to be

opened to start the Navigator.

Figure 4.1: Navigator View
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4 Navigator

4.2 Navigator View

The Navigator View is used for handling TextGrid projects and objects. All projects the

user is entitled to access are displayed in a tree view that can be expanded or collapsed

by clicking on the nodes (figure 4.1 on the preceding page). The Navigator uses different

icons for different types of objects, e.g.:

XML file

Image file

Edition

Work

Collection

Aggregation

4.2.1 Menu Bar

Some functions essential for managing projects and objects can also be found in the

menu bar under the item “File”:

• Click “New Object” to create a TextGrid object and “New Project” to create a

TextGrid project.

• Objects can be opened with “Open Object” but also with “Open URI”. This

identifier can also be copied with “Copy URI”.

• Projects can be deactivated, reactivated or deleted by users having the rights to

do this. (� chapter 3)

4.2.2 The Toolbar of the Navigator View

The toolbar of the Navigator offers you a few functions. If someone else modifies the

repository contents, you might need to refresh the Navigator view manually. Click

at the top of the Navigator view to do so.

By using the other icons, you can collapse all nodes , or by clicking on the triangle next

to , you can select between sorting the projects and objects by modification date, title,

type or in their original order and if the sorting should be ascending or descending.
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4.2 Navigator View

In the view menu, which is opened by clicking the white triangle, you can refresh and

customize the view. The view can be customized by choosing a filter or selecting the

content to be shown.

4.2.3 Context Menu

Context menus will pop up when right-clicking a project or an object in the object

tree. This allows a user to manage objects or create new ones. The context menu is

different for projects and objects and it varies depending on what kind of object has

been selected.

If a project is preselected, you can deactivate, reactivate or delete it if you have the au-

thority to do. The project will disappear from the project list until it gets reactivated.

Its published resources will remain readable. You can deactivate, reactivate or delete

a project also by choosing the items from “File” in the menu bar. The Project and

User Management can be opened directly from here by right-clicking a project (� chap-

ter 3).

To open an object, double-click it or right-click it and select “Open”. In accordance

with its document type, the file will be opened in a default editor. Click “Open With”

to choose another editor. To remove an object, right-click it and select “Delete”. You

must have the rights to do so (� chapter 3.) All files can be exported from here (� chap-

ter 7). Click “Show revisions” to have a look at the files history (� chapter 8). You

can open or reload the corresponding metadata or have look at the technical metadata

(� chapter 9).

If an edition (� section 5.4), work (� section 5.5) or collection (� section 5.6) is selected,

the context menu offers “Edit”. The Aggregation Composer (� chapter 15) opens if you

click here. In the case of editions and collections, you can also publish these objects via

context menu (� chapter 16).

The context menu allows you to associate an XML file with an adaptor (� section 12.2.1).

Images and XML documents can be added to the Text-Image-Link Editor via the context

menu (� chapter 13).

By right-clicking an object, you can select “Copy”. By right-clicking a project, you can

select “Paste” to import a copied file into another project. You can also copy the URI

of a project or object to the clipboard, so that it can be used by other applications

different from TextGridLab. If you select “Show CRUD warnings”, you can see if there

are problems with the database.
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4 Navigator

Figure 4.2: Create a Project

4.3 Using the Navigator

Some of the main tasks of the Navigator View are featured in the following passages.

4.3.1 Create New Projects

To create a new project, select “New > New Project” from “File” in the menu bar or

from the context menu in the Navigator when a project is marked. Alternatively, you

can use the arrow next to in the toolbar. The project manager role, the authority to

delete and the editor role will be assigned to you (� chapter 3).

Enter a name and a description of the project (figure 4.2). By default, the Project &

User Management will be opened after finishing the process by clicking “Create”. If you

do not want that, click the check box to remove the hook.

4.3.2 Create New Objects

Click “File > New Object” in the menu bar or “New Object” in the context menu of

the Navigator when a project is marked to create a TextGrid object.

To create an object, a project and an object type has to be chosen. If a project was

preselected in the Navigator, this project is suggested in the “Create a New TextGrid

Object” dialog box (figure 4.3 on the facing page). After clicking “Next” the Metadata

Editor (� chapter 9) interface is opened. Complete the metadata and click “Next”.

Depending on the document type the following steps differ. If it is an XML file, you

can select a schema (� chapter 12). After all necessary informations are entered, click

“Finish” to complete the operation.
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4.4 Interaction with Other Components

Figure 4.3: Create an Object

4.4 Interaction with Other Components

Since the Navigator is a tool for managing projects and objects, it interacts with the

Project & User Managment (�chapter 3), the Metadata Editor (�chapter 9), and the

Aggregation Composer (�chapter 15).

4.4.1 Navigator and Project & User Management

The chapter 3 can be opened directly from the context menu of the Navigator view.

The Project & User Management will also be started by default after creating new

projects.

4.4.2 Navigator and Metadata Editor

The Metadata Editor (� chapter 9) can be opened directly from the context menu of

the Navigator view as well as metadata can be reloaded. The Metadata Editor interface

is part of the dialog for creating new objects.
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4 Navigator

4.4.3 Navigator and Aggregation Composer

The Navigator is, by default, part of the Aggregation Composer perspective (� chap-

ter 15). It is used especially for creating references between objects and aggregations, like

editions or collections. If you right-click an edition, a collection, or another aggregation

and select “Edit”, the Aggregations Composers is opened.
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5 TextGrid Objects

TextGrid manages objects and types of relations between them. These relations are

called aggregations, editions and collections, which are themselves new TextGrid objects.

To create relations between objects every object has to be identifiable. To make possible

a further identification of the objects and a cross-project search, the objects have to be

described by metadata (� chapter 9 and chapter 17).

5.1 Objects

Objects are the basic building blocks and smallest unit of data in TextGrid. If you store

something in TextGrid - be it an XML document, an image, or any other kind of data -,

it will finally live in one or more objects.

An object consists of a metadata record (� chapter 9) and some content. Both will

be handled together: When you edit an object’s contents in an editor, you can always

switch to the metadata editor to modify the object’s metadata, and the metadata record

will be saved whenever you save the object. You can view and edit mainly descriptive,

bibliographic metadata using the Metadata Editor (� chapter 9), all metadata of an

object can be reviewed in a dialog opened by “Show technical metadata” in the context

menu of the object, e.g. in the Navigator (� chapter 4 ).

Each object is identified by an URI in a form like textgrid:74k0.1. The URI is automati-

cally generated when an object is saved to the repository for the first time. New objects

that have not been saved yet will be identified by a temporary URI. You can copy the

URI to the clipboard using “Copy URI” from the object’s context menu, or you can

review it in the aforementioned “Show technical metadata” dialog.

Every object has a format or content type: This is a required metadata field that speci-

fies the (technical) format of the content. Examples are XML and JPEG, but there are

also some special TextGrid-specific content types like aggregations (� section 5.2). Each

object lives in exactly one project. Projects are containers for the user rights manage-

ment (� chapter 3). Each TextGrid object is either an item (� section 5.3 ), an editon
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5 TextGrid Objects

(� section 5.4 ), a work (� section 5.5 ) or a collection (� section 5.6 ) - these object

classes have different metadata and semantics.

5.2 Aggregations

An aggregation is a TextGrid object that consists of an ordered list of references to other

TextGrid objects which can be aggregations themselves.

Aggregations are used to organize TextGrid objects. They can be used similar to file

system folders, but are more flexible: An object can be referred to from multiple ag-

gregations, you can collect objects in your aggregation that belong other people and

that you can only read, and when you delete an aggregation, the aggregated objects will

usually prevail – unless you explicitely ask to delete them. There is a checkbox in the

delete dialog.

There are different kinds of aggregation objects which differ in their semantics and their

metadata, but all have the same sort of content: Simple aggregations, which just have

item metadata (� section 5.3) and can be used, e.g. to represent a chapter in a book, split

across various files. But also editions (� section 5.4) or collections (� section 5.6) are

aggregation defined by a characteristic set of metadata. Use the Aggregation Composer

(� chapter 15) to arrange existing objects to a nested set of aggregations.

5.3 Items

Items are the simplest, but also most common entities in TextGrid. An item may be

e.g. an XML document or an image, like a page scan or a chapter of an edition in the

form of an XML document. Descriptive metadata for an item consists of one or more

titles, notes, a rights holder, a format, and the technical metadata that is available for all

objects. To associate more sophisticated metadata like an author or a source description

with an item, put it into an edition (� section 5.4) and optionally associate a work

(� section 5.5). Items are dependent objects: They can only be published as part of an

edition or collection but not by themselves (� chapter 16).
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5.4 Editions

5.4 Editions

An edition is the manifestation of a work. An edition is a special kind of an aggregation

(� section 5.2), its metadata contains fields to describe, e.g. the people and organisations

involved in preparing the edition or the source (outside TextGrid, e.g. a book) that the

electronic edition represents (� section 9.2.3). An edition is usually associated with a

section 5.5 and it has to be so for publication. The actual content of an edition is stored

in the item objects the edition aggregates. Editions can be published if they have correct

metadata, are associated with a work, and contain at least one item. It provides the

precise structure for the publishing of items.

5.5 Works

A work is an individual creation, for example a literary opus, which can be available

in various editions, e.g. as pocket edition, as part of collected works, as theatrical

performance or as audio book. An edition (� section 5.4) is always a particular edition

of a work. To describe a work, TextGrid offers work objects: These are metadata-only

objects that contain work specific metadata like the uniform title, the date of creation

or keywords describing the work (� section 9.2.4). By the time of publication, every

edition must be linked to a work object (� chapter 16).

5.6 Collections

The collection is an aggregation of TextGrid objects formed by the membership of a

particular organisation and/or topic. Collections are intended for two use cases: In an

organizational context an edition may be part of a collection (e.g. the combination of

editions from the Blumenbach project under the “Blumenbach” label or the combination

of digitized prints of the 18th century under the label VD 18). Additionally, collections

can be used to aggregate items for which the edition/work concept is not applicable,

i.e. digitizations of museum pieces. Collections are valid starting points for publication

(� chapter 16).
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6 Import

The import function is used to open and save files in TextGrid originally not created in

the Laboratory or objects that have been previously exported from the repository and

maybe stored locally.

While files are identified using file names and paths, each TextGrid object is identified

by an URI that will be generated on import. If a set of files that link to each other is to

be imported, these links will have to be rewritten to use TextGrid URIs instead of file

names to work. The TextGridLab comes with a set of configuarations for common file

types which you can choose in the import and export tool.

You can re-import objects that have been exported before together with their metadata.

If you have a file called “filename.ext.meta” which conforms to the TextGrid metadata

format besides “filename.ext”, metadata will be read from it and the old object will be

identified. By choosing from the target project dropdown box, the object can either

be re-imported as completely new objects with a new URI or as a new revision of the

original object.

6.1 Open the Import Tool

Any view has to be opened. Click “File” in the menu bar and choose the menu item

“Import local files” (figure 6.1 on the next page).

6.2 Import Tool

Select a target project into which the files should be imported in the pull down menu

at the bottom of the tool. Drag files or folders from the file management application of

your operating system in the import tool’s list. Alternatively to dragging and dropping,

click “Add” on the top of the import tool view to replenish the list below with a file.

Use the “Remove” button to take out a file from the list.
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6 Import

Figure 6.1: Import

The import tool suggests a content type, object title, and rewrite method. You can

modify the guessed title, content type or rewrite method of an entry by directly clicking

the appropriate entry in the table, or adjust additional metadata by selecting an entry

in the list and using the Metadata Editor (� chapter 9).

Click “import” to finish. After the import has finished, a result screen lists every file

that you tried to import together with messages of warning, error or success.

You can optionally save the import specification (that is the list of original file names

imported together with their associated TextGrid URIs and rewriting methods) in order

to make it simple to re-export the same set of objects later. The specification can be

saved as TextGrid or as local file. Use the buttons at the bottom of the view.
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7 Export

The export function can be used to export TextGrid objects and their metadata to a

local hard disk.

7.1 Open the Export Dialog

Click “File” in the menu bar and choose “Export from TextGrid” or select one or more

objects in the navigator or search results and choose “Export from TextGrid”. If you

add an aggregation, all aggregated objects will also be added to the list, and appropriate

link rewriting options will be selected.

7.2 Export View

Via the drag and drop function you can add objects from the Navigator (� chapter 4)

to the export view. Use the “Remove” button to take an object out from the list. Below

the list of objects, the target directory has to be selected. Use “Browse” to specify the

target directory.

Click “Export” to finish. After the export has finished, a result screen lists every-

thing that has been exported as well as warning or error messages if anything went

wrong.

The export tool will create two files for every object that has been exported to the

target directory, one for the data named with the object’s URI and an additional file

that contains the object’s metadata in XML form. For complex objects like editions

directories are created that lists its contents.

You can optionally save the export specifications (i.e. the list of all objects exported

together with the rewriting methods and file names used) from the result screen. Despite

the export of a file, the exported file or object remains in the TextGrid Repository and

therefore in the project it has been exported from.
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8 Revisions

Revisions are a means to save a specific state of a document, e.g. as an interim result

of a digtial edition. New revisions are explicitly created by the user, and all revisions of

the same base object are in the same project.

8.1 Using Revisions

A new revision of an opened document can be created by selecting “Save as new Revision”

under the “File” item in the menu bar. If a user wants to save a file that has been changed

by another user, TextGrid sends a warning. Then he can save his document as a new

object or a new revision.

All revisions of an object can be seen by right-clicking it in the Navigator or the Search

Result View and selecting “Show Revisions”. A list appears with all revisions, the title

of the document, the corresponding project, the contributor and the creation date of the

revision. Every revision can be referenced by an URI that contains the revision nummer

(e.g. textgrid:15k34.2). To refer to the latest available revision, use the URI without

the revision number (e.g. textgrid:15k4).

8.2 Interaction with Other Components

In the cases of editions, collections and other aggregations you can right-click these

objects and select “Edit” (� chapter 5). The Aggregation Composer (�chapter 15)

opens. If you right-click the object in question again, you have the possibility to refer to

the latest revision, the revision the selected object corresponds to or any other revision

from a list.
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9 Metadata Editor

The Metadata Editor is used to create and manage the baseline metadata elements of

TextGrid objects. These metadata are used in TextGrid for cross-project searches. The

metadata input form can be adjusted to individual needs with the Metadata Template

Editor (� chapter 10).

9.1 Open the Metadata Editor

The Metadata Editor is, by default, part of the XML Editor (� chapter 12) and the

Aggregation Composer perspective (� chapter 15) and can be accessed in other perspec-

tives

1. by selecting “Tools > Show View > Metadata” in the menu bar, or

2. by clicking on the Metadata Editor icon in the toolbar.

In order to load object’s metadata into the Metadata Editor, you must authenticate and

select a TextGrid object for editing.

9.2 Metadata Editor View

Some fields in the Metadata Editor are generic, others are specific for items, editions,

works and collections (� chapter 5). Depending on the selected object the fields displayed

vary. A few fields are shown collapsed. Click the black triangle in front of the element’s

name to open it.

Some fields in the Metadata Editor belong to one of the following groups: identifiers,

keywords, dates, persons or agents. These groups do not correspond to any individual

field displayed but the fields of the elements belonging to one of these groups have the

same structure.
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9 Metadata Editor

Figure 9.1: Metadata Editor View

Identifiers are of a special type and they have a characteristic value. The type maybe the

ISBN, ISSN or URL. The value is the specific number code or address of the object.

Keywords have an “id” attribute and a value. The “id” attribute is an identification in

some controlled vocabulary. The value is the information that will be displayed.

Dates have the attribute “date” or the attributes “notBefore” and “notAfter”. The

attribute “date” is used for the information when an event occured. Additionally, the

original form given in a document can be added in the second field. Click “Switch to

Data Range” in order to use the attributes “NotBefore” and “NotAfter” for the start and

the end of the era denoted. Use the “Switch to Approx Date” button to get back.

The mandatory “Approximate Gregorian Date” field needs to contain at least four nu-

merals specifying a year. Possible values for approximate Gregorian date fields:

• year (four digits)-month (two digits)-day (two digits), e.g. 2009-01-21

• year (four digits)-month (two digits), e.g. 2009-01

• year (four digits), e.g. 2009
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9.2 Metadata Editor View

Fields of the type person have the attributes “id” and “corporate body”. Use “is” for

an identifying URI, e.g. PND or FOAF. “Is corporate body?” can be chosen if wanted.

The value to be inserted in the field is the person’s name.

Agents are specified with their name as value and the attributes “role” and “id”. “role”

means a Dublin Core relator term you can choose from the drop down menu. The “id”

attribute is used for an identifying URI like PND or FOAF.

Some fields are repeatable. They can be opened by clicking the arrow besides the designa-

tion of the different groups. To add another field, click the appropriate “Add additional”

button. Entries that are not required can be removed by clicking the corresponding “Re-

move” button.

9.2.1 Generic Metadata

The following metadata are generic:

1. object’s title

2. identifiers

3. format of object

4. notes

The mandatory title element should be used for the title and subtitles of the object.

Remove a title or add an additional title by click on the appropriate buttons.

Chose between ISBN, ISSN and URL in the drop down menu to add some kind of

identifier for the object in some controlled vocabulary. ISBN, ISSN and URI are common

default values but other types can be added if wished. Further identifiers can be added

or removed by clicking the corresponding buttons.

Use the format element to fill in the required information about the MIME type. In the

cases of editions, works and collections a default value is proposed.

The field “notes” is usable for every other kind of information.

9.2.2 Item-specific Metadata

In the case of items, names of rights holders (e.g author, contributor, editor) can be

attached. They can be identified with a name and an URI. Further rights holders can
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9 Metadata Editor
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Figure 9.2: Metadata Schema
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9.2 Metadata Editor View

be added by clicking the appropriate button. Rights holders can be removed by clicking

the corresponding button. Mark the box if it is a corporate body.

9.2.3 Edition specific Metadata

If you create an edition, the metadata form contains the following fields:

1. Edition of

2. Agent(s)

3. Source(s)

4. Form(s) of Notation

5. Language(s)

6. License/Copyright

Edition of

The “Edition of” element names the related work object with a TextGrid URI. Use the

link to open the object and the button to browse the projects and select an appropriate

work object for the edition.

Agent

The Agent element is repeatable. Add further agents by clicking the “Add additional

Agent” button. Type in the agent’s name as value and select the appropriate Dublin Core

role from the drop down menu. Agents are identified with a URI, e.g. PND or FOAF.

Personal names should be typed in the form: ”surname, first name middle name”.

Source

The source element can be an object citation or a bibliographic citation. An object

citation is used for example in the case of an artifact in a museum. Bibliographic citation

is used for example in the cases of books or journal articles. Click one of the buttons to

add this information. Use the corresponding buttons to remove source metadata.
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9 Metadata Editor

Object Citation: An object citation can consist of a title, information as well about

contributor as about the date and a special identifier. “Title” is a required and repeatable

element. The contributor element follows the structure of all agent elements as well as

date follows the structure of all date elements and object identifier the structure of all

other identifiers (� section 9.2).

Bibliographic Citation: A bibliographic citation consists of the elements

1. Author(s)

2. Editor(s)

3. Place(s) of Publication

4. Publisher(s)

5. Date of Publication

6. Edition Nr.

7. Series

8. Volume

9. Issue

10. StartPage

11. EndPage

12. Bibliographic Identifier

Only the edition title element and the StartPage element are required. Edition title,

Author, Editor, Place of Publication, Publisher and Series are repeatable by clicking the

“Add” button.

Author, editor and publisher are identified with an URI, e.g. PND or FOAF. Mark the

box if they are corporate bodies. Use the value field for the person’s name. Personal

names should be typed in the form surname, first name middle name. For date of

publication all possibilities used for date elements can be applied (� section 9.2).

Edition Nr., Series, Volume and Issue are free fields used like their bibliographic equiv-

alents. “StartPage” is required but “EndPage” is not. “Bibliographic Identifier” is a

repeatable element. Choose ISBN, ISSN or URL as type from the drop down menu. The

value has to be inserted in the “Identifier(s)” field.
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9.2 Metadata Editor View

Form(s) of Notation

Chose the notation system from the drop down menu. For cases with more than one

notation system the element is repeatable.

Language(s)

The “Language(s)” element is repeatable for documents with more than one language.

License/Copyright

The license type or description can be specified in the “License/Copyright” field. The

license itself can be identified with an URI.

9.2.4 Work-specific Metadata

“Works” are objects (� chapter 5) that are essentially defined by its metadata. In

contrast to editions and collections they do not include other objects. The metadata

form of works contains the following elements:

1. Title(s)

2. Identifier(s)

3. Agent(s)

4. Abstract

5. Date of Creation

6. Spatial(s)

7. Temporal(s)

8. Genre(s)

9. Type(s)

10. Notes

The agent element for works is required on publication and it is repeatable. It consists

of a role attribute for which a Dublin Core (DC) relator term can be chosen from the
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9 Metadata Editor

drop down menu. In the “id” attribute an identifying URI like PND or FOAF might be

added. The agent’s name can be given as value of this element. The abstract element is

optional and repeatable. It is used for any comprehensive description of the work.

The date of creation element is mandatory. Is has to be entered on the form TextGrid

supports (� section 9.2). Spatial, temporal and subject keywords can be added. Their

IDs are ideally linked to controlled vocabularies. With “Value” the display value can be

influenced.

The genre element is required and repeatable. It is used for some basic classification. For

a more detailed classification than genre the type element can be applied. It is optional

and repeatable.

9.2.5 Collection-specific Metadata

The metadata form for collections contains the following elements:

1. Title(s)

2. Identifier(s)

3. Collector(s)

4. Abstract

5. Collection Description(s)

6. Spatial(s)

7. Temporal(s)

8. Subject(s)

9. Notes

Use the collector element for a DC relator term as role attribute, an identifying URI as id

attribute and the agent’s name as value. The element is required and repeatable.

The abstract element for comprehensive informations about an object is optional and

not repeatable. The collection description field is optional and repeatable.

Spatial, temporal and subject keywords can be added. They consist of an identifier

ideally linked to a controlled vocabulary and a value as it should be displayed. These

fields are repeatable by clicking the “Add additional Identifier” button.
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9.3 Using the Metadata Editor

9.3 Using the Metadata Editor

After completing all required metadata, the record set can be saved by clicking on the

“Save Metadata” button at the bottom of the Metadata Editor view. Reload all the

entries by clicking the “Reload Metadata” button beside the “Save” button.

To copy the external metadata into the header of a TEI object, click the “Copy TEI

Header” button at the bottom of the Metadata Editor view. The Header can be pasted

into the source code presented in the XML Editor (� chapter 12).

9.4 Interaction with Other Components

The Metadata Editor is part of the XML Editor (� chapter 12) and the Aggregation

Composer perspective (� chapter 15). It shows the metadata of the currently focussed

objects (� chapter 5). The structure of the metadata depends on the kind of object

it relates to. It can adapted to special needs by using the Metadata Template Editor

(� chapter 10).
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10 Metadata Template Editor

The Metadata Template Editor enables the user to create new own fields in the Metadata

Editor for his project. You need to have the Project Manager role in order to work with

it.

10.1 Open the Metadata Template Editor

To open the Metadata Template Editor choose it from “Tools” in the menu bar. Alter-

natively, you can click on this in the toolbar. You can also right-click a project in

the Navigator (� chapter 4) and select “Edit Metadata Description”.

10.2 Metadata Template Editor View

Initially a project has to be selected. Click “Next” and “Add new Element”. Afterwards

a new element name has to be chosen. Then select a data type for this element from the

drop down menu. The element can be

• a string: strings range from a single word or character to large blocks of text.

• a date

• an integer

• boolean: that means “false” and “true” values and has to be written as “0” and

“1”

• time

• decimal: to be written with a point like in “1.5”

Mark the checkboxes “Repeatable” or “Mandatory” if wanted. An element can be

removed if you click the corresponding “Remove” button. Another element may be
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10 Metadata Template Editor

Figure 10.1: Metadata Template Editor

added by clicking the “Add new Element” button. Click “Finish” to save your input or

“Cancel” to close the editor. Click “Back” if you want to select another project.

10.3 Interaction with Other Components

The Metadata Template Editor enables the user to adapt the metadata to the needs of

a project. The surface of the Metadata Editor (� chapter 9) changes according to the

adjustments made in the Metadata Template Editor.
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11 Unicode Character Table

The Unicode Character Table enables the user to search, to copy and insert symbols

from the unicode character set into the active editor or the system clipboard. Users

can create their own custom sets of unicode symbols for use in the unicode character

table.

11.1 Open the Unicode Character Table

The Unicode Character Table is started automatically as part of the default XML Editor

perspective. Additionally, it can be opened in the following ways:

• click in the toolbar

• via “Window > Show View > Unicode Character Table” in the menu bar

The unicode character table is also started automatically together with the XML Editor

and can be found as a hidden tab behind the Navigator (� chapter 4) on the left

side.

11.2 Unicode Character Table View

The character table consists of a toolbar in the head area, a table in the body area and

an information field with function buttons in the footer (figure 11.1 on the following

page).

11.2.1 The Toolbar of the Unicode Character Table View

The toolbar in the head area offers a selection range of all unicode symbols that is sorted

by association to blocks or scripts. By default, Unicode arranges groups of characters

together in blocks. A script in Unicode is a collection of written signs used to represent

textual information in one or more writing systems. For more information see
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11 Unicode Character Table

Figure 11.1: Unicode Character Table
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11.2 Unicode Character Table View

Figure 11.2: Custom Charset Editor

http://unicode.org/

For selecting the block range, press the button for the “Toggle Block Mode” in

the toolbar and choose the intended entry in the combo box on the right-hand side of

the toolbar. For selecting the script sector, press the “Toggle Script Mode” button

instead.

To jump to a symbol at a known Unicode point, enter the Unicode into the textbox.

After that click “Filter” (on Windows) or press “Enter”. As an additional feature, the

user can enter a Unicode symbol into the textbox and the view will jump to its code

point, which is helpful for identifying a symbol or accessing additional information on

it.

Use to look for mathematical symbols and to look for musical symbols. After

you have opened the view menu of the Unicode Character Table View you can open

the mathematical and musical symbols. You can also initialize the “Custom Charset

Editor” for creating and modifying user-defined character sets.

This editor shows a list of currently existing character sets in the head area. The body

area contains a toolbar for inserting, deleting and saving the character sets. The footer
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11 Unicode Character Table

area displays the values of the currently selected character set and allows its modifications

(figure 11.2 on the previous page).

Click the “+” button to create a new set. To remove a set click “-” or right-click the set

to remove it from the list. Use the twister arrows to refresh the list. Furthermore you

can save the set outside TextGrid and import external sets by clicking or .

The name and icon of the character set can be changed as well as the content, which

consists of either a predefined unicode blockset or a custom list of Unicode characters.

These characters can be entered either as a decimal Unicode character codepoint (e.g.

“56789”), as a Unicode hexadecimal codepoint with a leading sign (e.g. “U+1D100”) or

as a directly inserted symbol from the system clipboard. The selected signs have to be

separated by semicolons. Click “Close” to save the charset.

11.2.2 The Table Area

The table area displays all symbols contained in the selected character set and enables

the user to select any of these by a single mouse click. Executing a right mouse click

on the selected symbol opens a context menu for copying the selected character into the

operating system’s clipboard.

11.2.3 The Information Field

The information field shows the unicode codepoint as well as the description text of the

currently selected symbol and displays a magnified view of the selected symbol for a

more detailed view. The “Insert” button on the right-hand side immediately inserts the

selected symbol into an open XML Editor document if one exists.

11.3 Using the Unicode Character Table

A typical case for using the Unicode Character Table is to insert special characters,

e.g. Σ (u+2211) in an XML document. The course of action could be this:

1. Start the XML Editor perspective (� chapter 12) in the TextGridLab.

2. Double-click the wanted XML document in the Navigator (� chapter 4) to open

it.
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3. Click or double-click the tab “Unicode Character Table” next to Navigator and

Metadata Editor. (� chapter 9) to open the Unicode Character Table view.

4. Place the mouse pointer in the XML document where the special character is

needed.

5. Select Σ from the table with mathematical operators and click “Insert”.

6. Σ is added in the XML document.

11.4 Interaction with Other Components

The Unicode Character Table View is automatically opened when executing the XML

Editor (� chapter 12). In this manner symbols can be included in an XML text without

opening a new view.
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12 XML Editor

The XML Editor is an interactive tool for viewing XML documents and for creating new

data or annotating text retrospectively in XML language. XML is not a programming

language like HTML. It is a markup language. That means: XML can work outside the

web and sets the meaning of the elements and (optionally) their presentation. XML is

able to organize and classify data in a text. Therefore, XML is able to facilitate the

exchange of data and information as well as to make it searchable. Additional details

on XML are not explained here. Please See

http://www.w3.org/XML/

for more information. TextGrid’s XML Editor is based on “Eclipse Web Tools Platform

Project” and “Vex” by John Krasnay et. al.:

http://www.eclipse.org/webtools and http://wiki.eclipse.org/Vex

The TextGrid help explains the XML Editor perpective (� section 12.2) and its parts

in detail and gives you some examples for using the XML Editor (� section 12.6).

12.1 Open the XML-Editor

You can open the XML-Editor

• by clicking “XML Editor” on the Welcome Screen of the TextGridLab.

• by clicking the symbol in the toolbar.

• by selecting “Tools > XML-Editor” in the menu bar.

12.2 XML Editor Perspective

As soon as you have opened the editor, you can see three main parts:
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12 XML Editor

1. the Navigator (� chapter 4) on the left

2. the Editor Field (� section 12.3) in the middle, which is blank till such time as an

XML file is opened or created

3. a separated view on the right which is split into two different tabs ’Outline’ and

’Properties’. These are blank at the outset (� section 12.4 and section 12.5).

12.2.1 Features of the XML Editor

The XML Editor in general offers some features that should make working on XML

documents easier.

Show Validation Errors

Clicking “Show Validation Errors” under the item “XML” in the menu bar opens a

new view in which error messages are listed with information about invalid XML and

offset.

Associate a Schema

If an XML file is opened, you can associate a schema to it. After clicking “Associate

a Schema” under the item “XML” in the menu bar the “Select a new schema” dialog

opens (figure 12.1 on the facing page).

Above a list of schemas there is a display of summary information if the file is associated

to any schema and, if it is, to which. You can choose one of the schemata listed with

some information about the schema name, the corresponding project, its contributor

and its creation date. Click a schema to select it and “OK” to associate it to the XML

file.

If no schema is associated, the radio button below the list is marked. A document’s

schema association will only be made persistent when the document or its metadata is

saved.

Associate a CSS Stylesheet

A Cascading Stylesheet can be added to an XML file when it is opened and “Associate

a CSS Stylesheet” is selected from the item “XML” in the menu bar.
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Figure 12.1: Associate a Schema

The CSS will be used for displaying the XML file in the WYSIWYM View (� sec-

tion 12.3.3). You can select a CSS from the list by clicking on it. By default, aTEI

stylesheet build into the editor is used. To reactivate this option mark the radio button

below the list of CSS files.

Associate an Adaptor

If a file is or more files are selected in the Navigator or opened in an Editor, an adaptor

can be associated to translate the given document to the TextGrid Baseline Encoding.

To open it, please select “Associate an Adaptor...” under the item “XML” in the menu

bar.

In the upper list the selected files are presented with information about title, project,

contributor and creation date. You can mark the box under this list to make the as-

signement persistent when clicking “OK”.

In the lower list you can select the adaptor by clicking on it. Here you can also get

additional information about the adaptors. To annul your selection, you can mark the

radio button under this list.
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12 XML Editor

XML Editor Debugging

The debugging is intended to find and reduce the number of problems. The XML

Editor Debugging works with the WYSIWYM View (� section 12.3.3). Via “XML

Editor Debugging” in “XML” in the menu bar you have the possibility to reload the

WYSIWYM View.

By selecting “Debug XML Document” you can save the WYSIWYM Debug Output. You

can also open the WYSIWYM Debugging View by clicking “Layout Debugging”.

12.2.2 Menu Bar

When you open the XML Editor, some items in the menu bar are activated. Some you

can find in “Edit”, some in “XML”.

Edit

If the XML Editor is opened, options from “Edit” in the menu bar can be used, depending

on the view opened in the Editor Field (� section 12.3).

Undo and Redo: To undo or redo a change made to a document click “Edit > Undo”

or “Edit > Redo” in the menu bar above.

Cut, Copy and Paste: Use “Edit > Cut”, “Edit > Copy” and “Edit > Paste” in the

menu bar to arrange parts of the source code.

Delete and Select All: For removing code parts use “Edit > Delete”. Use “Edit >

Select All” to mark all souce code of a file.

Find and Replace: To open the “Find and Replace” dialog box, click “Edit > Find

and Replace” in the menu bar on top. You can specify text to search for and optionally

replacement text in this dialog box. You can set:

• the search direction (“Forward” or “Backward” from the current caret position)

• the scope (“All” or “Selected lines” to search within a selected area)

• whether your search should be “Case sensitive” or not
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12.2 XML Editor Perspective

• “Whole word” to match the entire search string

• “Wrap search” at the end of the file

• “Incremental” which causes the editor focus to move to the first complete occur-

rence of the text you are typing

• the “Regular expressions” checkbox to activate the Regular Expressions mode.

Type [Ctrl+Space] over the text field to get content assistance that lists all possible

expressions

Expand selection to: For marking up passages in the Source View ”Expand selection

to” offers you the option to select the enclosing, the next or the previous element. In

addition, you can restore the last selection.

Content Assist: For more information see the explanation about the Source View

(� section 12.3.2).

Show Tooltip Description: Displays tooltip description, where applicable. It shows

the value of a hover that would appear at the current cursor location.

Word Completion: Use this to get suggestions from the program for completing a

word.

Quick fix: For more information see the explanations about the Source View (� sec-

tion 12.3.2)

Smart Insert Mode: For more information please see the explanation about the Source

View (� section 12.3.2).

XML

Some operations can be started from the menu bar item “XML”:

• Insert Elements

• Rename Current Element to
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• Source: Used for comment handling and code-formatting

• Show Validation Errors (� section 12.2.1)

• Associate a Schema (� section 12.2.1)

• Associate a CSS (� section 12.2.1)

• Associate an Adaptor (� section 12.2.1)

• Copy URI-Fragment: Clones an URI-Fragment for local addressing.

• XML Editor Debugging (� section 12.2.1)

12.2.3 Toolbar

When the XML Editor is opened, some additional functions in the toolbar are active

depending on the View that is currently selected.

Show Block Markers and Inline Markers (WYSIWYM View)

Click to show block-markers and click to see all inline-markers in the WYSIWYM

View (� section 12.3.3).

New and Previous Annotation (Source View)

By clicking on or , the next or the previous annotation in the source code can

be found. By clicking the small triangle next to this symbols a list of entities is presented

that can be checked off. Only the marked kinds of objects will be found. You can select

additions and changes as well as errors, warnings and infos. You have also the possibiliy

to jump to the next or previous.

Turn Grammar Constraints on and off (Source View)

When you edit an XML file that has a set of constraints or rules defined by a DTD or

an XML schema, you can turn the constraints on and off by clicking or . When

the constraints are turned on, the XML Editor prevents you from inserting elements,

attributes, or attribute values not permitted by the rules of the XML schema or DTD,

and from removing necessary or predefined sets of tags and values (� section 12.3.1 and

section 12.2.1).
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Reload Dependencies (Source View)

If your XML file is associated with a DTD or XML Schema that has changed, you can

reload the dependencies by clicking (� section 12.3.1 and section 12.2.1).

Available Tags (WYSIWYM View)

If the WYSIWYM View (� section 12.3.3) is selected, a few more icons are shown: You

can click on to get a suggestion of available tags that can be added as your favorites

to the toolbar. By double-clicking them, they are added to the XML file. To remove

tags from the toolbar favorite list again, click .

12.2.4 Status Bar

When a file is opened in the XML Editor the bar at the bottom of the view informs the

user if it is writable, if the smart insert mode (� namerefxml-editor:editor-field:source-

view:features) is active and lists the current coordinates of the cursor.

12.2.5 Shortcuts

[Alt+/] Word Completion (� section 12.2.2)

[Alt+Shift+Down] Restore Last Expanded Selection

[Alt+Shift+Left] Expand Selection to Previous Element

[Alt+Shift+Up] Expand Selection to Enclosing Element

[Alt+Shift+Right] Expand Selection to Next Element

[Alt+Shift+W] Show passage in Navigator (� chapter 4), Out-

line and Properties View (� section 12.4 and

� section 12.5)

[Crtl+1] Quick Fix (� section 12.3.2)

[Crtl+A] Select All

[Crtl+C] Copy

[Crtl+F] Find and replace

[Crtl+I] Format Active Elements (� section 12.3.2)

[Crtl+Shift+/] Add Block Comment (� section 12.3.2)

[Crtl+Shift+\] Remove Block Comment (� section 12.3.2)

[Crtl+Shift+C] Toggle Comment (� section 12.3.2)

[Crtl+Shift+F] Format (� section 12.3.2)
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[Crtl+Shift+Insert] Smart Insert Mode (� section 12.3.2)

[Crtl+V] Paste

[Crtl+X] Cut

[Crtl+Y] Redo

[Crtl+Z] Undo

[Delete] Delete

[F2] Show Tooltip Description

12.3 Editor Field

This section shows how to work with the Editor Field in the center when a document

is opened. At the bottom of the Editor Field you can choose between three different

editing views of the content: “Design”, “Source” and “WYSIWYM”. The Design View

shows the hierarchic structure of the document. The Source View shows the document

in XML language. It allows you to access its structure and modify it. The WYSIWYM

(=“What You See Is What You Mean”) View shows the final display and formatting of

the content for the web. You can switch between the editing views by clicking on the

tabs at the bottom of the Editor. The * in the title bar of the Editor Field shows that

the file is not saved yet.

12.3.1 Design View

The Design View provides an overview of the tree-structure of the document in the left

node column (figure 12.2 on the next page). The content column on the right side shows

the content model of elements, the values of attributes and text content.

Nodes can be opened and closed by clicking the “+” or “-” button in front of them.

You can edit the values of attributes, the content of processing instructions and the

text-content of elements by typing directly in the appropriate text-field in the ‘Content’

column. You can change the position of XML objects by left-clicking them permanently,

moving the cursor to the target and stop clicking when the line marking the new position

is highlighted.

Features of the Design View

The Design View has some special features:
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Figure 12.2: Design View

Add and Edit DTD Information: A DTD can be added by right-clicking an XML

object in the Design View. Enter the name of the root element with which the DTD

should be associated. Add a Public or System ID. If a Public ID is browsed, a window

opens to select an XML catalog entry. The catalog can be specified by key or URI.

Finish with “OK” or “Cancel”. If a System ID is browsed, a window opens to specify

the system ID. Use the radio buttons to choose between a file from the workspace or an

XML catalog entry.

To select a file from the workspace, use the “Import files” button. In the pop-up window

you can select a local directory via the “Browse” button. Previously imported workspace

files are suggested. Use to expand or to collapse all folders.

In a new window you can select the directory by clicking the directory and “OK”. Back

in the import dialog you see the chosen directory in the left column and its content on

the right. Chose all files in the directory by marking the box before the name of the

directory or clicking “Select All”. “Deselect All” removes all marks in the boxes. To

select one file, click the box in front of it. You can use “Filter Types...” so that only

selected file types are shown. You can use “Select All” or choose file types by clicking

the boxes left to them. “Deselect All” annuls your choice.
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You can use “Select All” or choose file types by clicking the boxes on their left. “Deselect

All” annuls your choice. Use the field “Other extensions” if the document type is not

offered. Click “OK”. Afterwards a folder has to be chosen in which the file will be

imported. Use “Browse” for this purpose.

Optionally, you can overwrite existing resources without warning or create a complete

folder structure. In the advanced options you can create links to the workspace. Using

this option will create virtual folders. You can create link locations relative to a selected

reference can be created. Click the red button to cancel the ongoing operation. You can

also import an XML catalog entry after selecting them on the basis of key or URI.

A DTD can be worked on by right-clicking it in the Design View and selecting “Edit

DOCTYPE...” The window popp-up up has the same structure as the “Add DTD

Information” window. The public or system ID can also be changed by left-clicking the

corresponding field in the content column.

Add and Edit Schema Information: A namespace can be chosen with the context menu

in the Design View. Select “Edit Namespaces...” and the “Edit Schema Information”

window opens. The Namespace Declarations consist of a prefix, the namespace name

and a location hint.

Click “Add” to continue. In the “Add Namespace Declarations” window you can choose

between selecting from a registered namespace or specifying a new one by using the radio

buttons.

Select registered namespaces by marking the boxes in front of them and clicking “OK”.

Alternatively, a new namespace can be specified.

The chosen namespace declarations are now shown in the “Edit Schema Information”

window. Please click “Edit...”. Enter the required prefix and namespace URI for the

namespace declaration. Click “Browse” for a location hint. The “Select File” window

will open. Click “OK” or “Cancel” to finish and get back to the “Add Namespace

Declarations” window.

When the namespace is specified, finish the operation with “OK”. If no specified names-

pace should be added, click “Cancel”. This will return you to the “Edit Schema Infor-

mation” dialog in which the previously added specified namespace is now visible.

Use “Add” to enclose further namespaces. Select “Edit” to change the particulars of al-

ready added namespaces. Use “Delete” to remove them. Finish the dialog with “Cancel”

or “OK” . Once added namespaces can be edited by right-clicking them and selecting
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“Edit Namespaces...” The namespace name can also be changed by left-clicking the

corresponding field in the Design View (� section 12.3.1).

Add and Edit Processing Instructions: Processing Instructions can be included by

right-clicking the place where it should be added and selecting “Add Child”, “Add Be-

fore” or “Add After” and afterwards “Add Processing Instruction”. This is not possible

by right-clicking attributes.

A processing instruction is specified with its target and its data. The Target field is used

to identify the application to which the instruction belongs. The Data field contains the

instructions. Click “OK” to add the instruction. An already existing processing instruc-

tion can be worked on after right-clicking it and choosing “Edit Processing Instruction”.

The window pop-up has the same format as the “Add Processing Instruction” window.

The data can also be changed by left-clicking the corresponding field in the content

column.

Add Elements: Right-click the element where a new element should be added. Choose

if the new element should be added before or after the right-clicked element or if it should

be its child element. Then click “New Element...”. Enter the element’s name and press

“OK”.

Add and Edit Attributes: Right-click an element and select “Add Attribute” and “New

Attribute”. Enter the name and the value of the attribute and click “OK”. An already

existing attribute in the Design View Editor Field can be worked on after right-clicking

it and choosing “Edit Attribute”. The popping-up window has the same structure as the

“Add Attribute” window. The value of the attribute can also be changed by left-clicking

the corresponding field in the content column.

Context Menu

• To delete an XML object, right-click it and select “Remove”.

• To insert a DOCTYPE declaration in your document, right-click at any position

in the Editing View and select “Add DTD Information”.

• To add new or edit existing namespaces in the document, right-click at any position

in the Editing View and select “Edit Namespaces”.
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• Processing instructions can be edited in a window popp-up after “Edit Processing

Instruction” has been selected.

• To add an element at a certain position relative to an element in the document,

right-click it and choose one of the elements proposed. when selecting “Add Child”,

“Add Before” or “Add After”:

– a comment

– a processing instruction

– PCDATA

– a CDATA section

– a new element

• You can add attributes to an element by right-clicking it and selecting from the

list proposed after selecting “Add Attribute”.

• To edit attributes, right-click the attribute and select “Edit Attribute”.

The lists of proposed elements and attributes are provided by Content Assist. Proposals

come from a referenced content model if a schema is specified for the document, or else

through the XML Catalog. This will give you “smarter” proposals, such as specific child

element proposals within a given element, or required attribute proposals.

12.3.2 Source View

You can edit a document’s source code in the Source View directly by manually editing,

inserting or deleting elements and attributes. Lines can be opened and closed by clicking

the +/- button on the left side. Schema-driven Content Assist will support you with a

Hover Help and lists of proposals when adding new elements (� section 12.3.2).

Features of the Source View

The Source View offers you some features for working with XML source code.

Syntax Highlighting: Tag elements (attributes, values, etc.) as well as comments in

the Source View are highlighted differently to facilitate orientation in the document and
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Figure 12.3: Source View

detection of syntax errors. You can customize the syntax highlighting in the editor-

relevant preferences.

Unlimited Undo and Redo: To undo or redo a change made to a document, click

“Edit > Undo” or “Edit > Redo” in the menu bar above. Alternatively, right-click in

the Editor Field and select the corresponding entry “Undo Text Change”. You can undo

and redo every change made to a file for the entire editing session.

Node Selection: Depending on the position of the caret in the editor, the node selection

indicator highlights the corresponding tags as well as the lines that include a node in

the vertical ruler in the left area of the Source view

Comment toggling and block commenting and uncommenting: You can toggle an

XML comment on and off by right-clicking and selecting “Source > Toggle Comment”.

To comment out a section of source code, right-click on the selected area and select

“Source > Add Block Comment”, to uncomment, select “Source > Remove Block Com-

ment.”
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Figure 12.4: As-you-type Validation

As-you-type Validation: While editing the document, errors found in the general XML

syntax (missing quotes, missing brackets, missing end tags) as well as validation errors

(in case a schema is specified) are indicated with red wavy underlines. A red icon at the

top of the vertical ruler in the right area of the Source view will show up if the Document

contains any errors (figure 12.4). To find a description of the error, mouse over the red

marks shown in the vertical ruler in the right area of the Source view. A yellow icon

indicates a warning.

Smart Insert: Typing elements and comments is supported by a Smart Insert mode:

When you type an element, Smart Insert completes the corresponding closing tag au-

tomatically. Likewise, when you type the beginning of an XML comment <!–, Smart

Insert completes the ending of the comment –>. The caret is left in the middle of the

comment tag so you can proceed directly typing the comment text. In the same line,

opening quotes in attributes are completed with closing quotes while the caret is left

between them so you can directly start typing the value of the attribute. To toggle the

Smart Insert mode on and off, click “Edit > Smart Insert Mode” in the menu bar and

tick or untick the check mark.

Hover Help: Hover Help is displayed when users mouse over an element or an attribute.

It displays the content model of the current element or attribute and additional doc-

umentation information if included in the associated schema (figure 12.5 on the next

page). Mousing over text that is indicated to be erroneous with red wavy underlines dis-

plays a description of the current problem. You can modify the Hover Help preferences

in the relevant editor preferences.

Content Assist: When typing the opening bracket < of an element in the Source View

field, Content Assist provides you with a list of suggested elements allowed at this posi-

tion. You can activate Content Assist clicking “Edit > Content Assist” in the menu bar

at the top. When activating Content Assist while the caret is at an attribute position, a
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Figure 12.5: Hover Help

list of suggested attributes allowed at this position is provided. Proposals come from a

referenced content model if a schema is specified for the document, or possibly through

the XML Catalog. You can modify the Content Assist preferences in the editor relevant

preferences.

Quick Fix: Select “Edit > Quick Fix” in the menu bar on top to see a list of sug-

gested corrections when positioning the caret on a text that with red wavy underlines

is indicated to be erroneous with red wavy underlines. Alternatively, right-click on the

underlined text and select “Quick Fix”. If there are no problems or warnings at the

selected position, Quick Assist proposals are not available.

Formatting: To make the XML document easier to read and better for printing, you

can change the formatting options in the editor relevant preferences. You can apply for-

matting to the whole document by right-clicking in a non-highlighted area in your docu-

ment and selecting “Source > Format”. To apply formatting to a highlighted area only,

right-click in the selected area and select “Source > Format Active Elements”.

Cleanup: Simple errors in the XML-document such as missing required attributes,

missing begin or end tags or unquoted attributes can be corrected with XML Cleanup.

You can open the “Cleanup” dialog box by right-clicking in the Editor and selecting

“Source > Cleanup Document”. Alternatively, you can find it in the menu bar: “XML >

Source > Cleanup Document”. Afterwards set your Cleanup preferences in the dialog

box; you can further select ’Format source’ in the box to apply formatting to the docu-

ment.
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Team and Local History: A local edit history of a file is maintained when you create or

modify a file. This history is accessible via “Team > Show Local History” in the context

menu. Each time you edit and save the file, a copy is saved so that you can replace the

current file with a previous edit or even restore a deleted file. You can also compare the

contents of all the local edits. You can also “Apply Patch(es)” after selecting “Team”

in the context menu. Select the resource that the patch was generated on in the “Patch

Input Specification” dialog. This resource should contain the same file revisions as the

line-up on which the patch was generated (� chapter 8). For more information see the

Eclipse documentation

http://www.eclipse.org/documentation/

Preferences: You can edit XML Editor-relevant Preferences by right-clicking in the

Source View editor and selecting “Preferences”. Editable are amongst other things:

• Highlighting of the syntax elements: Expand the tree “XML > XML Files >

Editor” on the left of the dialog box “Preferences” and select “Syntax Coloring”.

• Hover Help: Expand the tree “General > Editors” on the left of the dialog box

“Preferences” and then select “Structured Text Editors”. In the “Structured Text

Editors” dialog box select the “Hovers” Tab and tick off the requested modifier

preferences.

• Content Assist: Expand the tree “XML > XML Files > Editor” on the left of the

dialog box “Preferences” and select “Content Assist”. There you can choose the

appropriate settings.

• Formatting, please expand the tree “XML > XML Files” on the left of the dialog

box “Preferences” and select “Editor”. In this dialog box you can choose and tick

off the respective settings of the formatting function.

For more information see the Eclipse documentation:

http://www.eclipse.org/documentation/

Context Menu

The context menu of the Source View allows the user to realize most of the view’s

features via right-click.

• Undo changes and to revert the file to the last saved state, the current state can

also be saved
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• Highlight the file or part of the file in the Navigator (� chapter 4), Outline View

(� section 12.4) or Properties View (� section 12.5) by selecting “Show In”

• Select Cut, Copy and Paste

• Start Quick Fix

• Manage your comments, format or clean up your source code by selecting “Show

In”.

• Open the Properties View (� section 12.5)

• Use Eclipse‘s Subversive options by selecting “Team”, “Compare With” or “Re-

place With” (� section 12.3.2).

• Associate an Adaptor (� section 12.2.1), to copy an URI or URI fragment, to delete

the file, to show or reload metadata (� chapter 9), to show revision (� chapter 8)

and CRUD Warnings that inform you about database problems

• Selecting preferences

12.3.3 WYSIWYM View

The WYSIWYM (=“What You See Is What You Mean”) Editing View provides a word

processor-like interface and hides the raw XML tags from the user. It uses the TEI

schema and a standard CSS stylesheet to define the document layout (figure 12.6 on the

following page).

To edit other XML formats or define a custom layout you can use your own schema

and CSS stylesheet. Your stylesheet should declare paragraph-type elements as “dis-

play:block”.

If your document was not recognized as a TEI document, and no stylesheet association

was found, you have the alternative to associate a stylesheet (� section 12.2.1) before

proceeding. Use the Import Tool (� chapter 6) to import a CSS first or to proceed at

your own risk.

Features of the WYSIWYM View

The main features of the WYSIWYM View are:
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Figure 12.6: WYSISYM View

Block and Inline Markers: In the default setting no tags are displayed in the WYSI-

WYM Editing View. To show the Block Markers, which mark nested divisions of an

XML-file, select in the main toolbar. To show the Inline Markers, which mark the

single elements of an XML-file, select in the main toolbar (figure 12.7 on the next

page).

Insert Elements: You can insert new elements by right-clicking at a certain position

in the editor and selecting “Insert Element” (alternatively select “XML > Insert Ele-

ment(s)” in the menu bar). In case some text is highlighted in the editor when selecting

“Insert Element(s)”, the new element will surround the highlighted text fragment. In

both cases after selecting ’Insert Element(s)’ a list of suggested elements allowed at this

position will appear. You can use the Up ↑ and Down ↓ keys on your keyboard to select

an element and press “return” to insert it or double-click on an element in the list.

To insert an element not provided in the proposal list, enter the elements name in the

editing field and click “Insert New”. To rename an element in the proposal list enter

the new elements name in the editing field and click “Rename”. Placing the caret in the

WYSIWYM Editor is supported by the XPath shown in the TextGridLab status bar at

the bottom of the whole TextGridLab window. You can change the font size and weight
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Figure 12.7: Block and Inline Markers

clicking ’Fonts’ in the main toolbar (� section 12.2.3) and select your settings in the

dialog box.

Context Menu

The Context Menu in the WYSIWYM View is similar to the Source View (� sec-

tion 12.3.2). But some options you can only find here: So you can add elements to the

WYSIWYM view (� section 12.3.3).

12.4 Outline View

The Outline View facilitates navigation in large XML-documents providing an overview

of the tree-structure of the document (figure 12.8 on the following page).

12.4.1 Title Bar

By clicking , you can collapse the nodes in the view. By clicking the white downward

triangle, the View Menu is opened. It offers two operations: “Link with Editor” and

“Show Attributes”. Use the both remaining icons to minimize and to maximize the

view.
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Figure 12.8: Outline View

12.4.2 Context Menu

The context menu in the Outline View allows you to

• Associate an Adaptor (� section 12.2.1)

• Copy an URI or an URI fragment

• Delete, show metadata (� chapter 9), revisions (� chapter 8) and CRUD warnings

• Carry out the operations that can be performed with the context menu of the

Design View (� section 12.3.1)

12.5 Properties View

The Properties View shows in two columns the attributes and the corresponding values

(figure 12.9 on the next page). You can edit values by selecting an element in the

Design/Source/WYSIWYM Editing View or the Outline View and typing directly in

the appropriate text field into the value column. Press “Enter” to confirm changes made

to the attributes. It is recommended that you edit attributes in the Properties View
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Figure 12.9: Properties View

when working in the WYSIWYM View (� section 12.3.3), as attributes will not be

displayed in the WYSIWYM Editing View.

12.5.1 Title Bar

The view’s title bar offers you several icons to perform a range of operations:

• Click to pin this property view to the current selection.

• Click to show categories like “Attributes” in the view.

• Click to show advanced properties.

• Click to restore the default value.

• Click to remove the selected property.

• Click the white triangle to open the view menu. The view menu allows you

– to open a new properties view

– to pin a property to a selection
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– to show categories and advanced properties

– to remove a selected property

– after clicking “Columns”, you can define the width of the two columns “Prop-

erty” and “Value”

• Click the both remaining icons to minimize and maximize the view.

12.5.2 Context Menu

The context menu in the Properties View allows you to copy and to restore the value

of a given property. If you click in the text field of the value column, the context menu

will be borrowed from your operating system.

12.6 Using the XML Editor

Some of the main operations for which the XML Editor is intended are explained in the

following sections.

12.6.1 Open XML documents

To open XML documents from the repository in the XML-Editor, either double-click

the document in the Navigator (� chapter 4) or right-click on the document in the

Navigator and select “Open”. To open XML-documents from your local system in the

XML-Editor, click “File > Open Local File” and choose the document you want to open

from the “Open File” dialog of your local system.

Once a document or file is opened,

• the Metadata Editor (� chapter 9) shows the metadata related to the document

• in the Editor Field (� section 12.3) the document content is shown in XML lan-

guage,

• in the separated Outline View (� section 12.4) on the right, the document is

represented as a tree or hierarchic structure

• if you click on an element in the XML view, its attributes and their values are then

listed in a table within the Properties View (� section 12.5)
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At the bottom of the Editor Field in the center you can choose between three different

editing views of the document: Design, Source and WYSIWYM view. The Design View

(� section 12.3.1) shows only the hierarchic structure of the document. The Source View

(� section 12.3.2) shows the document in the XML language. It allows you to access its

structure and modify it. The WYSIWYM View (� section 12.3.3) (= “What You See Is

What You Mean” view) shows the final display and format of the content for the web.

You can switch between the editing views by clicking on the tabs at the bottom of the

Editor.

12.6.2 Create XML documents

You can create a new XML document either by selecting “File > New Object” in the

menu bar or via right-clicking a project in the Navigator (� chapter 4) and selecting

“New Object”. In the opening dialog box “New TextGrid Object” select a target project

and the document type (XML Document, XML Schema, XSLT Stylesheet). Click “Next”

and assign metadata in the metadata form. Metadata can also be added later (� chap-

ter 9). You can click “Next” to associate a schema with your XML document or click

“Finish” to leave the dialog box.

For associating a schema, you can choose between schemas that are located in projects

you have access to in the repository or schemas stocked in the built-in XML catalog. To

import your own schemas to the repository, see Import (� chapter 6). Currently only

W3C Schemas are supported in the TextGridLab. To save the document, click “File >

Save”, use the in the toolbar, or right-click in the document and select “Save”.

12.6.3 Associate an XML Schema and Validating XML Files

While working in the Source View (� section 12.3.2) it is possible to associate a schema

with your XML document. Please click “XML > Associate a Schema” in the menu

bar on top and choose one of the schemas listed in the “Select Schema” dialog box.

Click “OK” to associate the schema. To import your own schemas to the repository, see

Import (� chapter 6). In the Source View errors in the general XML syntax (missing

quotes, missing brackets, missing end tags) are indicated as well as validation errors (in

case a schema is specified) with red wavy underlines.

To check if your XML document is well-formed and valid, you can validate it. You can

validate your document in any View by clicking “XML > Show Validation Errors” in the

menu bar on top. The validation errors view will pop up below the Editor view showing

an error message and identifying the invalid XML provided that there is an error.
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12.7 Interaction with Other Components

The XML editor interacts predominantly with the Navigator, the Metadata Editor the

Unicode Character Table and the Text-Image-Link Editor.

12.7.1 XML Editor and Navigator

The Navigator (� chapter 4) is used for opening and organizing projects and objects.

By clicking on XML files, they will be opened, by default, in the XML Editor.

12.7.2 XML Editor and Metadata Editor

The Metadata Editor (� chapter 9) is used for organizing the metadata of projects and

objects. For searching XML files this information is helpful. The Metadata Editor is

able to produce a TEI Header from the metadata that can be copied into your XML

source code.

12.7.3 XML Editor and Unicode Character Table

The Unicode Character Table (� chapter 11) view can be used to insert unicode signs

into an XML document.

12.7.4 XML Editor and Text-Image-Link Editor

The Text-Image-Link Editor (� chapter 13) allows you to combine images and texts.

The text has to be given in XML and the XML Editor is used by default.
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13 Text-Image-Link Editor

The Text-Image-Link Editor can be used to link text segments to corresponding image

sections within TextGridLab. A typical application is linking of facsimile and transcrip-

tions, whereas these texts can also be created during the linking process, which allows

the use of further tools like e.g. image annotations.

XML texts and images can be opened in the their corresponding views. The correspond-

ing components are then marked by pairs and the linkage is confirmed. The results can

be saved as a new object, which contains the link information (text and image coordi-

nates, path of used XML and image files). Once a file is saved, double-clicking it suffices

to reload XML texts, images and links to continue editing.

13.1 Open the Text-Image-Link Editor

The Text-Image-Link Editor can either be started

• by clicking its icon on the initial Welcome Screen (� section 1.3), or

• as a tool from the menu bar in the TextGridLab, or

• by clicking its icon on the toolbar.

13.2 Text-Image-Link Editor Perspective

The editor contains the Navigator (� chapter 4) on the left whose context menu allows

you to open images or texts - depending on the user rights in particular. On the right-

hand are two views, one above the other which are blank if no file is selected. As soon as

an image is opened, it can be seen in the Image View (� section 13.3), the upper view on

the right side. Automatically, you will also see the Image View below the Navigator and

the detached Toolkit (� section 13.6). As soon as an XML file is opened, it can be seen

in the XML Editor (� chapter 12) below the Image View. In summary, this perspective
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13 Text-Image-Link Editor

Figure 13.1: Text-Image-Link Editor Perspective

consists of a Toolkit, two specific views and the Text-Image-Link Editor (� section 13.4)

in addition to the generic Navigator:

• Image View: shows the image or an image detail to be linked and enables the

marking of image segments

• Thumb View (� section 13.5): shows a reduced version of the entire image and the

active image detail which can easily be moved and zoomed and that is enlarged in

the Image View

• XML Editor: allows you to open or create texts as well as the mark of text parts

• Toolkit: provides functions to work in the Image View
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13.3 Image View

13.2.1 Menu Bar

If the Image View is activated, “Undo”’ and “Redo” in “Edit” of the toolbar are usable.

If the XML Editor is opened, all functions are enabled (� chapter 12).

13.2.2 Toolbar

If the Image View (� chapter 12) is activated, some special elements in the toolbar are

usable:

• Click to delete active selections

• Click to reset the Text-Image-Link Editor

If a file has been opened in the XML Editor (� chapter 12) additionally, some more

buttons in the toolbar are activated:

• links a selected text segment to a selected shape

• unlinks selected link(s)

• next to the linking icons saves the Text-Image-Link Object

• saves the Text-Image-Link Object as...

13.3 Image View

The Image View is the TextGridLab working space for editing pictures. Some of its

functions are also usable for connecting image and text elements.

13.3.1 Features of the Image View

For editing pictures the Image View provides you with several functionalities: selections,

docking lines, writing mode, rotation function and the Layer Editor. Most of them are

accessible via context menu by right-click.

77



13 Text-Image-Link Editor

Selections

A main feature of the Image View is creating and handling different selections of an im-

age. You can create rectangles and polygons to select areas of a picture (� section 13.6).

An existing selection can be selected by double-click it. You can choose more than one

selection by double-clicking the created shapes while [Ctrl] is pressed.

Docking Line Settings

You can set docking lines as an optical help after selecting the docking line mode in the

Toolkit (� section 13.6). These can be aligned horizontally or verticaly by [Shift+H] or

[Shift+V] or via the context menu. Click [Ctrl+V] to clone a docking line. The appear-

ance of docking lines can be modified by using the Docking Line Settings (figure 13.2 on

the facing page):

1. Right-click in the Image View.

2. Select “Docking lines”.

3. Select “Settings”.

4. You can choose various line styles.

5. There are five grades of line width for docking lines. The larger the number, the

thicker the line.

6. The line spacing between cloned docking lines can be defined by selecting a new

value between “10” and “150”.

The colours of active and not active docking lines can be selected by clicking on this

figure. By clicking on the squares, a palette pops up. Use the arrow to change the

colours of active and not active docking lines.

Writing Mode

In writing-mode, you can add information about the text direction to the selected sec-

tions on a facsimile. Use [Shift+S] to show or hide the writing mode of a selected shape.

The writing mode for the active selection(s) or for the active document can be changed

by right-clicking in the Image View. The following options can be chosen:

• none: this is the default value
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13.3 Image View

Figure 13.2: Docking Line Settings

• lr: from left to right

• lr-tb: from left to right and from top to bottom

• rl: from right to left

• rl-tb: from right to left and from top to bottom

• tb: from top to bottom

• tb-rl: from top to bottom and from right to left

If you want to set the writing mode for the whole document, then select “Writing Mode >

Set writing mode for active document” before creating the shapes. This changes the

writing mode for all selections which have no writing mode yet. All shapes created

afterwards will use this value. You may change it again for every single selection with

“Writing Mode > Set writing mode for active selection(s)”.

Set Rotation Angle

The “Set Rotation Angle” dialog can be opened by

• right-clicking a selection in the Image View, selecting “shape rotation” and “Set

shape rotation for active selection(s)”
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13 Text-Image-Link Editor

Figure 13.3: Set Rotation Angle

• clicking the box with information about the rotation angle in the status bar (� sec-

tion 13.3.4)

The angle can be set via the scrollbar (figure 13.3). Via context menu or [Shift+R] you

can active or deactivate the shape rotation mode. Select a created shape by double-click

it. If the rectangle, polygon or docking line mode is chosen (� section 13.6), you can

rotate the shape with your mouse. Via context menu or [Shift+P] you can show or hide

the rotation angle in the status bar of the Image View.

The Layer Editor

It is possible to create logical groups of links (e.g. verses, comments) using the Layer Edi-

tor. By clicking the box with information about layers in the status bar (� section 13.3.4)

at the far right of the Image View, you open the Layer Editor. Alternatively, you can

select “Text Layers” and “Edit Layers” from the context menu in the Image View.

It the upper part of the editor all created layers are listed. In the lower part of the

editor new layers can be created. To create a new layer, click “New/Assume”. The

layer automatically gets a number. Click in the “Name” text field to add the name of

the layer. By clicking “Color”, a palette opens from which a color can be chosen. By

default, this layer is visible. Check the second box to activate the layer. Only one layer

can be active at any time. To delete a layer, click the “Remove” button.
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13.3 Image View

Figure 13.4: Layer Editor

You can hide or show layers via the title bar of the Image View (� section 13.3.3). Press

[Shift+L] to show all layers.

13.3.2 Menu Bar

If the Image View is opened, the operations “Undo” and “Redo” in the item “Edit” of

the menu bar are activated. If the XML Editor (� chapter 12) is focussed, all other

operations are enabled, too.

13.3.3 Title Bar

The * symbol in the title bar of the Image View means that changes are not saved yet.

There are several buttons in the title bar of the Image View:

• shows all layers (if there are layers that were previously invisible)

• shows layers
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13 Text-Image-Link Editor

Figure 13.5: Working with Multiple Layers

• hides layers (� section 13.3.1)

• Open or close the Toolkit (� section 13.6)

13.3.4 Status Bar

The Image View status bar displays information on

• the activated mode (� section 13.6)

• the file format

• a warning signal if there are unlinked objects

• the rotation angle of the selected shape that can be changed in the “Set Rotation

Angle” dialog (� section 13.3.1) after clicking this field.

• the coordinates of the mouse pointer

• enabled or activated layers (� section 13.3.1)
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13.3 Image View

13.3.5 Shortcuts

The following shortcuts are available:

[Page Up]and [Page Down] Move image up or down

[+] Zoom in

[-] Zoom out

[0] Zoom original

[C] Clone active rectangle horizontally

[Ctrl+A] Select all shapes (� section 13.3.1)

[Ctrl+T] Open or close the Toolkit (� section 13.6)

[Ctrl+V] Clone active docking line (� section 13.3.1)

[Ctrl+Y] Redo

[Ctrl+Z] Undo

[Shift + C] Clone active rectangle vertically

[Shift + H] Horizontal alignment for active docking line (� section 13.3.1)

[Shift + L] Show all text layers(� section 13.3.1)

[Shift + P] Show or hide shape rotation (� section 13.3.1)

[Shift + S] Show or hide writing mode (� section 13.3.1)

[Shift + R] Activate or deactivate shape rotation mode (� section 13.3.1)

[Shift + V] Vertical alignment for active docking line (� section 13.3.1)

[Space + Mouse-Left] Move Image

[Tab] Transverse between selections (� section 13.3.1).

13.3.6 Context Menu

The Image View context menu allows several operations:

• Center selection: places the selected part of the image in the center of the view

• Link text to selected shape: connects the selected parts of the image and the text

• Unlink selected link(s): disconnects the selected link between image and text

• Delete active selection(s): removes the current selections

• Delete all shapes/links: removes all shapes and all links in an image

• Jump to linked text: selects the corresponding part in the text file

• Clone active rectangle horizontally: produces a copy of the active rectangle on the

right of it.
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13 Text-Image-Link Editor

• Clone active rectangle vertically: produces a copy of the active rectangle below it.

• Docking lines

– Alignment of active docking line

∗ Horizontal: aligns the active docking line horizontal

∗ Vertical: aligns the active docking line vertical

– Save all lines: saves all docking lines

– Delete all lines: removes all docking lines

– Show or hide all lines: shows all docking lines if hidden or vice versa

– Settings: opens the Docking Line Settings (� section 13.3.1)

• Writing Mode section 13.3.1

– Show or hide writing mode: shows writing mode if hidden or vice versa

– Set writing mode for active selection(s): changes writing mode for selected

object

– Set writing mode for active document: changes writing mode for all selections

which have no writing mode and for new created selections

• Shape rotation (� section 13.3.1)

– Activate or deactivate shape rotation mode for rotating a shape with your

mouse

– Show or hide shape rotation mode in the status bar (� section 13.3.4)

– Set shape rotation for active selection(s) via scrollbar

• Text Layers

– Edit Layers: opens the Layer Editor (� section 13.3.1)

– Edit Layers for selected shapes only: you can shift a selection to another layer

here

– Show all Layers: all layers will be visible

• Image Size

– Show original: presents the image in original size
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13.4 XML Editor View

Figure 13.6: Thumb View

– Fit Vertically: sets the height of the image to the height of the view

– Fit Horizontally: sets the width of the image to the width of the view

– Fit Window: sets the height and the width of the image to the height and

the width of the view

13.4 XML Editor View

In order to link images and XML files, the XML Editor (� chapter 12) has to be opened.

It is part of the the Text-Image-Link Editor perspective by default.

13.5 Thumb View

The Thumb View opens simultaneously with the Image View. It consists of a a slide

control bar to adjust the zoom factor in Image View and a selection frame to navigate

the active detail in Image View via mouse. Click on the part of the image on which you

want to focus.

13.6 Toolkit

All functions of the Toolkit apply to the Image View.

• Magnifier: click and drag to enlarge the selected screen area temporarily (the range

can be modified with the Ctrl key)
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13 Text-Image-Link Editor

Figure 13.7: Toolkit

• Magnifier “+”: clicking the desktop zooms in and centers the workspace at the

selected position

• Magnifier “-”: zooms out

• The sliding tool allows you to move the work space

• Rectangular selection : click and drag to select a rectangular area

• Polygonal selection : click and drag to create the edge of a polygon which can

be completed by double clicking

• changes to docking line mode (� section 13.3.1)

• Choose color: modifies foreground (= selected, active marking) or background

(= inactive marking) color, both can be modified by clicking the big colored squares

• Swap colors : interchanges fore- and background color

• Reset color: clicking the smaller pair of squares resets fore- and background color

to default colors black and white

• Raster : activates line raster to facilitate the alignment of the marking
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13.7 Using the Text-Image-Link Editor

13.7 Using the Text-Image-Link Editor

The following description describes the linking of images and texts as a typical task for

the Text-Image-Link Editor is developed.

13.7.1 Open Images and Texts

Double-clicking XML and image files in the Navigator (� chapter 4) opens the XML

files in the XML Editor and the images in the Image View. Alternatively, XML files

can be opened by selecting “Add to Text-Image-Link Editor” in the context menu of the

Navigator.

13.7.2 Select Workspace

The displayed detail can be selected with the selection rectangle in the Thumb View and

the scrollbars. The zoom factor can be changed using the slide control in the Thumb

View or the magnifier tools.

13.7.3 Create Links

Follow these steps to create links:

• The selection in the image can be selected in rectangular (default) or polygonal

mode. In rectangular mode clicking the image at one corner of the area to select

suffices to draw the rectangular selection by keeping the left button pressed. In

polygonal mode an edge can be drawn by clicking and dragging. Releasing the

left button determines the next corner of the polygon which can be completed by

double clicking. A mark which is not yet linked to a text is displayed with a dashed

border.

• Text can be selected by clicking and dragging or by double-clicking (single word)

respectively triple-clicking (whole line) or with one click on the XML tag to select

the whole XML element.

• The creation of a link can be effected using the symbol in the toolbar.

• Marked texts and images does not have to be effected in sequence. It is also possible

to mark a larger quantity of image sections and then link them successively later.
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13 Text-Image-Link Editor

Figure 13.8: Linked Text and Image

• The results can be saved as a new object, which contains the link information (text

and image coordinates, path of used XML and image files). You can use the

button next to save this text-image-link object. Once a file is saved, double-

clicking it suffices to reload XML texts, images and links to continue editing.

13.7.4 Correct and Delete Links

Links can be corrected or deleted afterwards.

• The selection of a link can be carried out by double-clicking both in the graphic

and in the text field.

• In the Image View selected links or marks are displayed in the potentially modified

fore- and background color.
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13.8 Interaction with Other components

• Selected links (i.e. marks in text and image and their link) can be deleted by right

clicking using the context menu or by clicking the button.

• Marks in the Image View can be edited subsequently. When moving over an active

marking, the cursor and its icon change: In the center it becomes a sliding tool

(four way arrow) that allows you to change the position of the marking by clicking

and dragging. Close to the boundaries it allows you to reposition the edges (two-

way arrow) or the corners (diagonal two-way arrow) in a similar way. Polygons

changes can be realized in a similiar manner with the exception that single edges

of polygons can not be moved.

13.8 Interaction with Other components

13.8.1 The Text-Image-Link Editor and the Navigator

As described above, texts, images and linking objects can be opened in the Navigator

(� chapter 4).

13.8.2 The Text-Image-Link Editor and the Metadata Editor

The Metadata Editor (� chapter 9) is used to edit and save metadata of TextGrid

objects. Images as well as text image link objects have to be associated with such

metadata to be searchable.

13.8.3 The Text-Image-Link Editor and the XML Editor

The XML Editor (� chapter 12) is by default a part of the Text-Image-Link Editor

perspective.
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14 Dictionary Search

The Dictionary Search Tool allows for browsing the dictionary network

www.woerterbuchnetz.de

at the Center for Digital Humanities at the University of Trier. The following dictionaries

may be browsed:

• General dictionaries: German Dictionary by Jacob and Wilhelm Grimm; Grammatical-

Critical Dictionary of the High German Dialect by Johann Christoph Adelung

• Author’s dictionaries: Goethe Dictionary

• Dialect dictionaries: Dictionary of the Alsatian Dialect by Ernst Martin and Hans

Lienhart; Dictionary of German-Lorrainese Dialects by Ferdinand Follmann; Dic-

tionary of the Palatine Dialect by Ernst Christmann et al.; Rhenish Dictionary;

Supplement to the Rhenish Dictionary

• Middle High German dictionaries: Middle High German Dictionary by Matthias

Lexer; Middle High German Dictionary by Georg Friedrich Benecke, Wilhelm

Müller and Friedrich Zarncke; Supplement to the Middle High German Dictio-

nary by Matthias Lexer

• Luxembourgian dictionaries: Luxembourgian Dictionary, Dictionary of the Lux-

embourgian colloquial speech; Dictionary of the Luxembourgian dialect

14.1 Open the Dictionary Search

To open the Dictionary Search perspective

• choose the Dictionary Tool from the Welcome Screen, or

• select “Tools” from the menu bar and click “Dictionary Search”, or

• click the icon in the toolbar
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14 Dictionary Search

Figure 14.1: Dictionary Search Perspective

The Dictionary Search Results view, which is part of the Dictionary Search, can also be

opened separately by

• selecting “Tools>Dictionary Search” in menu bar, or

• clicking in the toolbar

14.2 Dictionary Search Perspective

The perspective is subdivided into three views: the Dictionary Search mask view on the

upper left, the Dictionary Search Results view on the upper right and the Dictionary

Grid view at the bottom.
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14.3 Dictionary Search Mask

14.3 Dictionary Search Mask

To look up a word, fill in the Dictionary Search Mask as follows:

• Insert a keyword in the first input field. The search is not case sensitive.

• You can limit the number of results displayed. By default, the first 10 results will

be displayed.

• Choose between exact or fuzzy search. In fuzzy search similar strings will also be

found.

• Mark the box or boxes of the dictionaries to be searched.

• To start the search, click the icon “Start search”.

• You can use wildcards. The asterisk (*) substitutes any zero or more characters,

and the question mark (?) substitutes exactly one character. You can combine

these search methods.

14.4 Dictionary Search Results View

You see the number of results in the upper right corner of the view. For orientation,

the first line of the article (up to 13 words of the lemma) is displayed. If the number

of results exceeds the display limit, you can view the remaining results by clicking the

“Next” or the “Previous” button.

14.5 Dictionary Grid View

To look up the entry in the dictionary, click the short form listed in the Dictionary

Search Results view. The entry will be opened the Dictionary Grid view. The tabs

in the head of the Dictionary Grid View lead to further information about the online

dictionary and the project into which the online dictionary is embedded. The field at

the top of the left column is used for searching lemmas. This quick view starts with the

article in question. It lists the following articles as well, depending on their length. You

can use all options the online dictionaries offer to go into more detail.

In this view the context menu corresponds to the context menu of your operating sys-

tem.
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14 Dictionary Search

14.6 Interaction with Other Components

The functionality of the Dictionary Search Tool can also be used while working on an

XML document. Open the Dictionary Results view. Look up any word of your text by

double-clicking it in the XML Editor (� chapter 12).
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15 Aggregation Composer

The Aggregation Composer is used for handling TextGrid Aggregations (� chapter 5).

15.1 Open the Aggregation Composer

The Aggregation Composer can be opened by

• choosing “New” from “File” in the menu bar and selecting a kind of aggregation

• clicking in the toolbar

• right-clicking an aggregation, edition or collection in the Navigator (� chapter 4)

and selecting “Edit”

If “File > New” in the menu bar or are selected, then the “Create a new TextGrid

Object” dialog box is opened. Afterwards, the Aggregation Composer appears.

You can also open the Aggregation Composer by using

• the icon on the Welcome Screen

• “Aggregations” from “Tools” in the menu bar

• the icon in the toolbar

In these cases, a perspective opens with the navigator, the empty Metadata Editor and

the empty Aggregation Composer. To add a new aggregation, choose “New” from “File”

in the menu bar or click in the toolbar. To edit an aggregation, right-click it in the

Navigator and select “Edit”.
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15 Aggregation Composer

Figure 15.1: Aggregation Composer

15.2 Aggregation Composer View

The Aggregation Composer is part of a perspective with the Navigator (� chapter 4)

and the Metadata Editor (� chapter 9). If an aggregation is edited, the toolbar and the

context menu of the Aggregation Composer can be used.

15.2.1 Toolbar of the Aggregation Composer View

To manage aggregations, the Aggregation Composer provides several functions in its

toolbar:

• Click to create a new aggregation, edition or collection that is subordinated to

an existing one

• Click to remove a selected object from the list below

• Click or to expand or collapse all branches
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15.3 Using the Aggregation Composer

Figure 15.2: Refer to Revision

15.2.2 Context Menu

The context menu in the Aggregation Composers offers you same options as the toolbar

of the Composer as well as two more options:

• “Rename Item”: any item can be renamed

• “Revision”: you can refer to this revision, to the latest revision or to any other

existing revision

If you choose the last option, a new “Refer to Revision” window opens that lists all

revisions of an object with the number of the revision, the title, the corresponding

project and the data contributor (figure 15.2). Select the revision you want to revert to

and confirm with “OK” or double-click the desired item.

15.3 Using the Aggregation Composer

To create a reference to an object in an aggregration, collection, or edition, use the Nav-

igator (� chapter 4) to drag it from there and drop it in the tree shown the Aggregation

Composer. Save the changes by using [Crtl+S], the in the toolbar or “File > Save”

in the menu bar. Otherwise a dialog box opens that reminds you to save changes if you

quit the Aggregation Composer.
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15 Aggregation Composer

15.4 Interaction with Other Components

The Aggregation Composer is based on the conception of objects (� chapter 5) and

interacts with the schema that underlies the Metadata Editor (� chapter 9). To en-

able linking objects and aggregations, the Navigator (� chapter 4) is opened with the

Aggregation Composer by default.
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16 Publish

Only editions and collections can be published (� chapter 5). Project Managers have

the sole right to publish them (� chapter 3).

16.1 Open the Publish View

To publish an edition or collection, right-click it in the Navigator (� chapter 4) and select

“Publish in TextGridRep”. Afterwards, the Publish view opens on the right side.

16.2 Publish View

The Publish View consists of four levels (figure 16.1 on the next page).

The uppermost level informs you about the status. After initializing the view, it tells

you that the edition or collection can be proofed now. The bottommost level allows you

to “Proof”, to “Publish”(if proofed), and to “Cancel”.

After clicking “Proof”, the information in the uppermost level changes. On the next

level beyond, which is separated into three columns (“Name”, “Status” and “Actions”),

you can see how many warnings, errors and permissions have occurred and below this

some details are presented.

If some warning or error have occurred, more detailled information can be found in the

“Action” column of the list below the statistic. By clicking on an entry in the field

“Actions” of an error message, a “Call action” button appears. Click on it and you are

guided to the critical position.

If no warnings or errors appear, there is an “OK” appears in the status column line

and the “Publish” button at the bottom is activated. Click “Publish” to finish the

operation.
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16 Publish

Figure 16.1: Publish

16.3 Using TextGrid Publish

Before you publish an object, you should know that only editions and collections can be

published. For publishing they must contain a TextGrid “work” (� chapter 5). If an

edition is to be published, some metadata become mandatory that are optional for an

edition as such: “Edition of” and “License” (� chapter 9).

If a project with a least one object to be published has been created in the TextGridLab,

an edition of this object can be published in a few steps by using the Aggregation

Composer (� chapter 15) and the Metadata Editor (� chapter 9):

1. Create and save a work.

2. Create an edition.

3. Copy the object to be published and the work with the metadata in the edition.

4. Complete the metadata of the edition: “Edition of” and “License” are required for

publishing.

5. Save the edition.
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16.4 Interaction with Other Components

6. Publish the edition.

This edition is public now. This action is irreversible.

16.4 Interaction with Other Components

The Publish View can be opened directly from the Navigator (� chapter 4). “Publish”

checks the information of the Project & User Management (� chapter 3) and the object

type (� chapter 5) as well as the metadata (� chapter 9) before a TextGrid object is

published in the Repository.
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17 Search

The Search Module allows you to search the contents (e.g. TEI-encoded documents)

and the object metadata in the TextGrid Repository simultaneously.

17.1 Open the Search

The Search perspective can be opened in different ways:

• Click the icon on the Welcome Screen (� section 1.3)

• Select “Tools > Search Tool” in the menu bar

• Click on the tool bar

17.2 Search Perspective

The Search Perspective consists of two views: Search and Search Results (figure 17.1 on

the following page).

17.3 Search View

The Search View consists of the declaration of a search endpoint and a simple or advanced

search.

“Search Endpoint” declares against which search repository the request is raised. The

two possibilities are:

• “my projects”: repository that can only be used after authentication.

• “public data in the TextGrid Repository”: the public repository contains only

published objects and is also searchable without authentication.
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17 Search

Figure 17.1: Search Perspective

In simple as in advanced search wildcards can be used in the middle and at the end of

a word: * for any number of signs, ? for exactly one sign.

17.3.1 Simple Search

In the input field of the simple search that is opened by default you can enter your search

terms. There are three different search modes:

• Search Fulltext: only the fulltext section of an object is searched

• Search Metadata: only the metadata section of an object is searched

• Search Both: both the fulltext and the metadata section of an object are searched

In the simple fulltext search the search strings can be combined with “and” respectively

“or”. Words without conjunction are interpeted as “and”.

The simple metadata search works just like the fulltext search. The search strings can

be combined with “and” respectively “or”. Another way to search for metadata results

is to specify the type of metadata. The notiation is: metadata-tag:search-term. All

possible metadata tags can be used with this option.
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17.3 Search View

17.3.2 Advanced Search

In the advanced search mode you can raise a search request with the help of a given form.

This form consists of three different sections: METADATA, FULLTEXT, BASELINE

ENC. Each section can be selected via a checkbox. Selected sections sre used for the

search request. The metadata and the fulltext search can be combined by ticking off both

boxes, otherwise the baseline encoding search can also be executed separately.

In the advanced FULLTEXT search only the text section of an object is searched. In the

input field you can enter the search term. If you fill in more than one word, the words

will be “and” related for the search. By specifying the word distance you can declare

whether the words should only be found in one document or whether they should occur

within a specific word distance of each other.

The METADATA section in advanced search offers the possibility to search across dif-

ferent fields. This form is organized as a matrix. Each row represents the search for one

metadata field. The field can be selected by a combo box at the beginning of the line.

The search strings can be entered in the text boxes behind. These text boxes are “or”

related. The different lines are “and” related. The searchable metadata fields are:

• Data Contributor: a person who submits data in TextGrid, identified by its user

ID (e.g. testuser@textgrid.de)

• Identifier: an identifier in non-TextGrid context (e.g. a ISBN or ISSN, a shelf

mark, a registration or an inventory number)

• Notes: some additional information concerning the object

• Project: the TextGrid project to which the object is assigned

• Rights Holder: person or organization with copyright for an item

• TextGrid URI: the internal Uniform Resource Identifier of an object

• Title: the title of an object

The expandable labels “Text types”, “Content types” and “Languages” contain check-

able tree controls, which can be used to define the search closer. With the assistance of

the “Date field” you can be set a time frame.

Only baseline encoded TextGrid objects can be found by using the BASELINE EN-

CODING search (� http://www.textgrid.de/fileadmin/TextGrid/reports/baseline-all-

en). This search form is organized as a matrix. In the first text box of a line the

searched tag should be filled in. In the following text boxes of this line the searched
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content can be filled in. The text boxes of a line are “or” related. The different lines,

one below the other, are “and” related. To submit a search, click the button at the

bottom of the Search view labelled “Search” or click the magnifying glass in the upper

bar of the view.

17.4 Search Results View

This view lists the search hits. It initially shows the titles of the documents and the

matches in their context. The title is given with additional information about the doc-

ument type, the revision, the project, and the editor.

The items in the list can be chosen by mouse-click. A double-click opens these with the

default editor. Right-clicking allows for further actions to be applied to the document,

e.g. selecting another open action, displaying the metadata, or copying the URI to

the clipboard. The context menu is in most parts identical to that in the Navigator

(� chapter 4).
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Part of the TextGridLab is an integrated help system, which can be opened en bloc and

be searched by keywords. The TextGrid Laboratory also offers you to start a context-

sensitive help.

18.1 Static Help

The general, unspecialized help can be opened by selecting “Help” in the menu bar. You

can also choose “Help Contents”, “Open Cheat Sheet”, “Dynamic Help” and “Keyword

Search”.

18.1.1 Help Contents

After clicking “Help Contents”, the general help is shown in a new window of your

standard web browser. This new window contains a header, where you can enter a

keyword a search. If you click “Scope”, you can select an area that the search should be

restricted to. By default, all topics are searched.

The main window is separated into two parts. The left one is similar to the Navigator

view. In the toolbar you can choose different operations:

• Print the selected topic with or without all subtopics.

• Click to search for a keyword in the selected topic with or without all subtopics.

The choice between searching in a topic with or without subtopics can be made

after clicking the downward-pointing triangle for the pull down menu.

• Furthermore, you can collapse all nodes in the list below with , minimize and

maximize the window.

• Clicking keeps the navigation tree synchronized to the current topic.
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The list below shows the contents in a tree structure. Clicking “+” or “-” button the

subcontents can be expanded or collapsed. On clicking a tree item, the corresponding

content is shown in the windows right area.

In the footer you can select between

• a table of contents

• a listing of the search results

• a view of the bookmarks that can can be deleted with and it the toolbar

of the view.

• In principle you can also choose a view to search the index , but the TextGrid

Help currently has no index. Instead of this you can use the keyword search for

help contents.

The right-hand part of the “Help Contents” window shows you the selected entry of

the Help. Use the backward and forward button to navigate and to get back to the

starting point. Click to show the selected topic in the table of contents in the left-hand

part of the window. You can bookmark a document or print the page .

18.1.2 Cheat Sheet

Cheat sheets can be designed to help a user complete some task, and it lists the sequence

of steps required. Currently no cheat sheets are provided for the TextGridLab. But

you have the possibility to select cheat sheets from a local file or an URL. For more

information see

http://www.eclipse.org/documentation/

18.1.3 Dynamic Help

It is possible to initiate the dynamic help, a type of context-sensitive help from the menu

bar. A view opens with a forward and a backward button to navigate and the short

description to the currently focussed view or editor. If you change to another view, the

content of the help view changes simultaneously.
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18.1.4 Keyword Search

The keyword search can be started by a separate menu item. Enter a word or some

words in the input box and click “Go”. Click the hook in the right corner of the input

field to open a menu with the recent terms that have been searched for. You can use

wildcards (* for any string, ? for any single character and ” ” to demarcate a phrase)

and logical operators (AND, OR and NOT).

• Click to show result categories

• Click to show result descriptions.

• With and you can navigate.

Click the downward triangle in the toolbar of the view to choose between different options

available during the keyword search:

• If you select “Contents”: The result is presented in a tree structure. Use the “+”

and “-” button to open or close a branch. Click to close them all.

• By clicking “Related Topics” entries are selected in which the view or editor cur-

rently focussed is discussed.

• Click “Bookmarks” to browse you bookmarked entries.

• You can search in the Index but currently the TextGrid help has no index.

The result of the search is listed below. You can click on the title of an entry to open

it. If an entry of the Help is opened, the toolbar of the view offers you

• to show this in an external window that will open in the “Help Contents”.

• to see the item in the tree-structured table of contents

• to print and to bookmark it

• to highlighten the search term in the entry by clicking

• to navigate with the forward and backward buttons

The footer of the Keyword Search View gives you the same options as the downward

triangle in the header: “Related Topics”, “Contents”, “Index”, “Search” and “Book-

marks”.
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18.2 Dynamic Help

In most views you will find an icon with an question mark to open the context help.

Alternatively, you can always open it via “Help > Dynamic Help” in the menu bar or by

clicking on the help symbol in the toolbar. For example: The blue button in the User

Management leads you to information about the handling of role assignment.
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