
	
  

	
  

Upgrade to L4U Platinum Elite from Platinum on WindowsTM 
Systems 

Overview 
This installation document has been created to assist in the upgrade to L4U Platinum Elite 
Single User from Platinum 2.3 on Windows Computers. Please refer to page 7 if you are 
upgrading a Multi User system. This document assumes that L4U Platinum 2.3 is installed.  

L4U Platinum will remain on your computer and can be accessed at any time. In other words, 
L4U Platinum will be a snapshot of your collection at the time of the upgrade to Elite. 
However, ensure L4U Platinum Elite is used going forward and not the old copy of L4U. 

Prerequisites 
To Upgrade to Platinum Elite from Platinum you must have 

• Upgraded to Platinum 2.3.x  
• A Login Password with full access to L4U (i.e.: not a helper) 

o Please refer to page 15 of the L4U Platinum 2.3 User Manual for more 
information on Login Passwords 

• Your Platinum Elite License Number and Activation Code 
• Your L4U Customer ID # 
• Platinum Elite software installer 

The basic procedure for upgrading to L4U Platinum Elite follows these steps (which are 
explained in detail on the following pages): 

1. Before upgrading to Elite, take note of your Custom Label & Report Template 
settings/dimensions so you can re-create them in Elite 

2. Make note of the Current Data file’s location 
3. Backup Existing Data 
4. Obtain L4U Platinum Elite 
5. Install L4U Platinum Elite 
6. Run the L4U Elite Upgrade Utility 
7. Login to L4U Elite 

 

  



	
  

	
  

L4U Platinum Single User Upgrade to Platinum Elite - Windows 

Custom Report & Label 
Due to the changes in the L4U Engine, custom report and label templates from L4U Platinum 
do not work in L4U Elite. L4U Library Software apologizes for any inconvenience this may 
cause. 

Locate your Current Datafile 
You may need this information later in the upgrade process. To identify the name and 
location of a Single User Current Data File: 

1. Make sure that L4U Platinum Single User is running  
2. From the Help Menu >select About L4U (e.g.: Help > About L4U) 
3. Click the Data file Information tab  
4. Fourth field down indicates the current data file and where it is located 

• In Windows, all L4U data files end with the .4DD suffix 
5. Make note of the path to the datafile 
6. Click Done  
7. Select File > Quit 

Example: The default location of the current datafile is:	
  C:\L4U Program 
Files\L4UPlatinum\2.3.4\Database\xxx.4DD, where xxx.4DD is the name of your current 
datafile. 

Back Up Existing Data Before Upgrade 
The L4U Elite Upgrade Utility doesn’t modify the original L4U Platinum data.  

However, before performing this upgrade, we always recommend that you ensure you have a 
current backup. If you’re not sure, please refer to Manual Backup on page 347 of the Platinum 
User Manual v2.3 to perform a backup. 

Install L4U Platinum Elite 
L4U Platinum Elite Single User is available from L4U’s Client Corner or via the L4U Platinum 
Elite Install CD. Launch the Installer and follow the onscreen directions. 

Run the L4U Elite Upgrade Utility 
After L4U Platinum Elite is installed, your L4U Platinum data needs to be transferred to L4U 
Platinum Elite. Follow these steps to do so: 

1. Launch the L4U Elite Upgrade Utility 
• The default location is at C:\L4U Program Files\L4U Elite\Single\L4U Elite Upgrade 

Utility where C: is the drive where L4U Elite is located 



	
  

	
  

2. Select Administrator from the User Identification List 
3. In the Password field, enter Items 

• This password is case sensitive 
4. Click Connect  
5. The Platinum Elite Data Upgrade Utility appears 

 
Review the location of the source datafile. This will be the same as the Current Datafile 
in Step 4 in Locate your Current Datafile on page 2 

6. If the Upgrade Utility cannot locate the Current Datafile, Click Browse and navigate to 
the correct location. Please refer to Locate your Current Datafile on page 2. 

 
The default datafile location for Platinum 2.3 is C:\L4U Program 
Files\L4UPlatinum\Single\Database 
or for Platinum 2.3.4 it is at C:\L4U Program Files\L4UPlatinum\2.3.4\Database 

7. Click Continue 



	
  

	
  

8. Click OK at the confirmation Alert 

  
9. Log In Again. Click Administrator 
10. In the Password field, enter Items 

• This password is case sensitive 
11. Click Connect  
12. Click Continue at the export confirmation screen 

 
13. The Upgrade Process begins 

 



	
  

	
  

14. Click Continue when the export Process has finished 

 
15. After L4U has restarted, Select Administrator from the User Identification List 
16. In the Password field, enter Items 

• This password is case sensitive 
17. Click Connect  
18. The Import Process begins 

    
19. Click OK when prompted to Enter your License Number & Activation Code 
20. Enter the necessary Library Profile information 

• Customer ID, Library Name, Address, Telephone Number, License Number & 
Activation Code should be entered 

• Leave Replace Library Name with Location unchecked 
21. Click Activate 
22. Click OK when Activation is successful 

• If Activation fails, please contact L4U Support for an Authentication code 
23. Click Save to exit the Library Profile screen 
24. Enter your usual Librarian Client Code and PIN and login as normal 

 
Please proceed to After Upgrading on page 13 

	
    



	
  

	
  

L4U Platinum Multi-User Upgrade to Platinum Elite – Windows 
Please review page 1 before proceeding with the following steps! 

Custom Report & Label 
Due to the changes in the L4U Engine, custom report and label templates from L4U Platinum 
do not work in L4U Elite. L4U Library Software apologizes for any inconvenience this may 
cause. 

Locate your Current Datafile 
You may need this information later in the upgrade process. To identify the name and 
location of a Multi User Current Data File: 

1. At the L4U Platinum Server computer and the L4U Server program running, view the 
L4U Server Main Window 

2. Make note of the path and the Data File name listed 

 
3. Select File > Quit 

Example: If the full path name is not indicated (as in the above illustration), then the Current 
Datafile is at C:\L4U Program Files\L4UPlatinum\2.3.4Server\Server Database\, where C: is 
current volume where L4U Server software is currently located. 

Back Up Existing Data Before Upgrade 
The L4U Elite Upgrade Utility doesn’t modify the original L4U Platinum data.  

However, before performing this upgrade, we always recommend that you ensure you have a 
current backup. If you’re not sure, please refer to Manual Backup on page 347 of the Platinum 
User Manual v2.3 to perform a backup. 



	
  

	
  

Install L4U Platinum Elite 
L4U Platinum Elite Multi-User software is available from L4U’s Client Corner or via the L4U 
Platinum Elite Install CD. Install the Server software on the Server computer and install the 
Admin Utility at each of the computers where L4U Platinum Client currently exists. Launch the 
appropriate Installer and follow the onscreen directions.  

Run the L4U Elite Upgrade Utility 
After L4U Platinum Elite Server software is installed, your L4U Platinum data needs to be 
transferred to L4U Platinum Elite. Follow these steps to do so: 

1. Launch the L4U Elite Upgrade Utility 
• The default location is at C:\L4U Program Files\L4U Elite\Server\L4U Elite Upgrade 

Utility where C: is the drive where L4U Elite Server software is located 
2. Select Administrator from the User Identification List 
3. In the Password field, enter Items 

• This password is case sensitive 
4. Click Connect  
5. The Platinum Elite Data Upgrade Utility appears 

 
Review the location of the source datafile. This will be the same as the Current Datafile 
in Step 2 above in Locate your Current Datafile on page 6 

6. If the Upgrade Utility cannot locate the Current Datafile, Click Browse and navigate to 
the correct location. Please refer to Locate your Current Datafile on page 6. 



	
  

	
  

 
The default datafile location for Platinum 2.3 is C:\L4U Program 
Files\L4UPlatinum\Server\Server Database 
or for Platinum 2.3.4 it is at C:\L4U Program Files\L4UPlatinum\2.3.4Server\Server 
Database 

7. Click Continue 
8. Click OK at the confirmation Alert 

  
9. Log In Again. Click Administrator 
10. In the Password field, enter Items 

• This password is case sensitive 
11. Click Connect  



	
  

	
  

12. Click Continue at the export confirmation screen 

 
13. The Upgrade Process begins 

 



	
  

	
  

14. Click Continue when the export process has finished 

 
15. The L4U Elite Server starts and the data import begins 

 
 

16. The Server is finished importing data when the Data Import Process dialog disappears 
 

Install & Launch the L4U Platinum Elite Admin Utility (Elite Client) 
Install the L4U Platinum Elite Admin Utility at each computer that L4U Platinum Client is 
currently installed. The Elite Admin Utility installer will not delete the Platinum Client. You can 
delete it later if desired. Launch the Installer and follow the onscreen directions. 
 

1. On the Windows desktop, Double Click on the L4U Platinum Elite Admin Utility (Client) 
shortcut 

• If the shortcut is unavailable, use the Windows start menu Start > Programs > 
L4U Elite > Admin Utility > L4U Platinum Elite AU (Admin Utility) 



	
  

	
  

2. Click Continue at a possible Error screen 

 
3. In the Connection to 4D Server screen that appears, Click the L4U Elite Server 3.1 item 

from the Available tab. 

  
4. If you do not see the server computer, Click the Custom tab. Enter the IP address of the 

L4U Platinum Elite Server as displayed on the L4U Elite Server Monitor window. If you 
do not have access to the L4U Elite Server computer, contact your IT Department or 
your Computer Technician. 

 
5. Click OK 

• A screen may appear stating, Duplicating Resources Locally 
6. Select Administrator from the User Identification List 
7. In the Password field, enter Items 

• This password is case sensitive 
8. Click Connect  
9. Click OK when prompted to Enter your License Number & Activation Code 



	
  

	
  

10. Enter the necessary Library Profile information 
• Customer ID, Library Name, Address, Telephone Number, License Number & 

Activation Code should be entered 
• Leave Replace Library Name with Location unchecked 

11. Click Activate 
12. Click Ok when Activation is successful 

• If Activation fails, please contact L4U Support for an Authentication code 
13. Click Save to exit the Library Profile screen 
14. Enter your usual Librarian Client Code and PIN and login as normal 

 
Please proceed to After Upgrading on page 13 

 
  



	
  

	
  

After Upgrading 
All users should run a Utilities with No Options Selected after they log in for the first time. To do 
so: 

1. File > Utilities 
2. With no options selected, click Run Utilities 
3. A Confirmation screen appears, click Yes 
4. When the procedure is complete, an Alert message appears. Click OK 

• It is not necessary to perform a compact at this time 
 
Some features in L4U Platinum will be reset to factory defaults after the upgrade. Please 
review the following points to see if they apply to you. Relevant chapters and/or page 
numbers refer to the Platinum 2.3 User Manual (PUM) or Platinum Web Manual (PWM). The 
chapters or page numbers in square brackets refer to the recommended L4U User/Web 
Manual v3.1, the new Platinum Elite documentation. 
 

• Automatic L4U Backup will need to be reset after the upgrade. PUM Chapter 23 [LUM 
Chapter 23] 

• Access to Overdue Letters is disabled after upgrading to Elite. Login to Elite as a 
Superuser and enable Full Control to Overdue Letters in Access Management for the 
Access Levels that need Overdue Letters. This feature did not exist in Platinum and is 
disabled due to security reasons after the upgrade. PUM Chapter 2, Access Levels [LUM 
Chapter 2, p22 Access Levels] 

• Keywords & Interface Tab in Preferences. Ensure keywording of all options is enabled 
for best performance. Chapter 3, p28-31 [Chapter 3, p33-36] 

• Circulation tab in Preferences. Check Global Due Date and, if desired, enter the desired 
Due Date. Chapter 3, p37-45 [Chapter 3, p41-49] 

• Email Settings. If you emailed your overdue notices, please check the Email tab in 
Preferences>Advanced. Chapter 3, p48 [Chapter 3, p53] 

• Barcodes & Report Delimiters tab in Preferences. Please ensure Use Location 
Preferences for Accession #’s is set to No. Check your next barcode if you print your 
barcodes from L4U. Chapter 3, p53-54 [Chapter 3, p56-60] 

 
Please refer to the L4U Quick Start Guide v3.1 for a quick tour of what’s new in L4U Elite when 
you have Elite up and running. 

 

Thank you for your continued support of L4U! 

 
 

	
  


