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  Pyramix 8.1 Release Notes 

 

Installation 
 

Please consult the Installation Guide located on the Pyramix Installation Media (USB 

Memory card) for details on the hardware and software installation procedure and 

Authorization Key registration process. 

 

To install the Mykerinos board, TURN YOUR COMPUTER OFF (shut down then switch the 

power off). Next plug the Mykerinos board into one of the PCI/PCI-Express bus slots on your 

computer and turn the power back on. 

 

RAVENNA users will have to install the NET-MSC-GBEX1 PCIe Ethernet card provided by 

Merging Technologies. TURN YOUR COMPUTER OFF (shut down then switch the power off). 
Next plug the NET-MSC-GBEX1 card into one of the PCI-Express bus slots on your computer 

and turn the power back on. The NET-MSC-GBEX1 card will only be operational once the 

MassCore runtime is installed. Refer to the Pyramix Installation Guide for more details. 

 

Additional installation step for multi-board application 

In order to enable multi-board operation, all Mykerinos cards in your PC have to be 

connected together using a special HDTDM ribbon cable. This cable has to be plugged into 

the multi-pin connectors located on the top edge of the I/O daughter cards. Please contact 

your Merging Technologies Sales Partner for information on how to order this HDTDM ribbon 

cable. 

• To install the Pyramix Virtual Studio software insert the Pyramix Virtual Studio 

Installation Media - the installation program should auto-start. 

• To install MassCore launch the MT Security Settings, go to the MassCore page and 

install the MassCore RunTime (a MassCore base key is required). 

 

Updates 
  

Please check our Web site http://www.merging.com periodically for information, patches 

and updates. 
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Pyramix v8.1 Install Procedure 
Additional details on the System Requirements available in the Pyramix V8.1 Installation Guide. 
STEP 1:  
Pyramix v8.1 is compatible with the following OS 

� Windows 7 Professional (32bit): MassCore/Mykerinos, MassCore/RAVENNA, Native/RAVENNA & Native 

� Windows 7 Professional (64bit): Native & Native/RAVENNA only 

� Windows XP (32bit): MassCore/Mykerinos Native  

Notes:  

� RAVENNA users must install the NET-MSC-GBEX1 PCIe Ethernet card provided by Merging Technologies. 

Refer to the Pyramix v8.0 Install guide for details 

� MassCore/RAVENNA is only supported under Windows 7 (32bit), user should never put the MassCore 

NET-MSC-GBEX1 PCIe Ethernet card on a system that runs Windows XP or Vista or that is 64 bit. 

� Since Pyramix v8 the Mykerinos None-MassCore mode is no longer supported. 

 
STEP 2:  
Merging recommends that you remove the present Pyramix version 
Users running Pyramix v8.1beta1 or prior versions need to remove the RTX version installed see STEP 5 
Before doing so you can back up your Projects and save your settings, keyboard shortcuts, templates. 

1.   Go to Windows Control Panel 
2.   Select “Add or Remove Programs” (XP) / “Programs and Features” (Windows 7) Remove the installed 
Pyramix version (Pyramix 5.X or 6.2.X or 7.X or v8.0 versions) 

 
STEP 3: 
Install Pyramix 8.1 

1. Run the Pyramix 8.1 installer 
2. If asked to install Uncertified Microsoft Drivers please continue and confirm the install authorization (do 
not use Wizard automatic detection). You can also enable the “Always trust Merging Technologies” option 
3. Users might also be asked to install pending requirements like “Bonjour” for Windows, please proceed 
3. Reboot your System 

 
STEP 4: 
Enter your V8 keys (The Pyramix v7.1 keys are not valid with Pyramix v8) 

1. Launch MT Security Settings from Windows Start>Control Panel>MT Security Settings 
2. Enter your Pyramix v8 Keys 

 
STEP 5: 
MassCore users running Pyramix v8.1 beta1 or prior versions need to remove the RTX version installed 

1. Make sure that you are logged on to your system with the User account that installed MassCore in the 
first place (this information can be retrieved with our MassCore troubleshooting guide)  
http://download.merging.com/beta/Pyramix/pmx8.1_Beta2/IntervalZeroRTX_Uninstall_Troubleshoot.pdf 

2. Launch MT Security Settings and go to the MassCore Tab 
3. Uninstall MassCore from the uninstall MassCore Runtime button and reboot your system 
4. After the system reboot return to the MT Security Panel  
5. Re-install MassCore from the MassCore Tab Install MassCore Runtime butt and Reboot  

Warning:  Take note that a second automatic reboot will happen after the first Login. 
Note: If Interval Zero does not appear in the Windows Programs & Features please refer to the document link here 
http://download.merging.com/beta/supporttools/Docs/IntervalZeroRTX_manualremoving.pdf 

STEP 6: 
MassCore recommendations 

1. Make sure that your system is configured with the HyperThreading disabled. Refer to Pyramix v8 
Installation Guide for all details as some specific BIOS settings are recommended 
2. Reboot your system and make sure that you select the “MassCore” boot entry line at Windows Start Up 
If you do not select the MassCore boot line you could end up with an RTX blue screen. 

 
STEP 7: 
RAVENNA: Refer to the Merging RAVENNA Guide for all details. 
� Disabling Windows Firewall is recommended (no internet connection recommended) 
� Merging recommends setting the Merging MassCore NIC Ethernet card and Horus to Auto IP addressing  
� Enable RAVENNA mode from the VS3 Control Panel (NOTE: the Merging Interface must be connected) 
� We recommend the installation of the Google Chrome browser for Horus remote access 
� Use “Easy Connect” (installed with Pyramix v8) to manage the RAVENNA connection 
� Users can now connect multiple Horus’s through the Merging certified Dell network switch. Refer to the 

Merging RAVENNA MassCore guide for all details and configuration. 
 

STEP 8: 
For users with Pyramix and VCube installed on the same system, it is mandatory that you upgrade to VCube 4.1 to 
go along side this Pyramix v8.1 
Note: An MTCleanUp utility is available through Merging’s Support for those having problems with their installation.  
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Pyramix 8.1 Release Notes 

 

New Features 
 

Background Recording: 

� New Background Recording machines are available in the main Transport Window. 

� They are configurable in All Settings > Application > Background Recorders. 

� Up to 4 (arbitrary number) machines can be declared on the top-right header of the settings 

page (…. of [Number of Recorders]). 

� A direct shortcut to each recorder’s settings page is available through the third button from 

the left on the transport window. 

� Below are the Settings for each recording machines: 

• A Color. Each machine has a color to identify its mixing console easily, the media in 

the media manager while recording and the clips being edited in the timeline during 

record. The color can be defined by the user. 

• Time Stamp of recordings: 00:00:00:00 or Time of Day (or Input TimeCode when in 

Chase Mode). 

• Pre-Buffering: Number of seconds of pre-buffered data (see below for what it’s 

about). 

• Confirm Stop: If enabled a warning will be prompt and the user will then need to 

confirm the stop recording. 

• Media Set: Each machine can optionally record to two different locations at the same 

time, for redundancy, and to different formats. Selection of the number of Media Sets 

selectable as per the number of Recorders (… of [Number of Media Set]). 

1. Destination Folder. 

2. Format: For now only PMF, BWF, MTFF (The only formats that allow Editing while 

Recording is BWF).  

3. Resolution: The resolution (bit depth) is the same for both media sets. 

4. Media File Count: Single Media, One File per Track, One File per Mixer Strip 

5. Waveform: No Waveform, Waveform While Recording. 

6. Unique File Name Extension. 

7. Suffix With Strip Name. 

8. Edit in Active Project: The recording can be sent to the currently active project 

timeline (and played back) either at the end of the recording or immediately 

when the recording starts. See details below about Edit while Recording. 

 

� Each Recorder has its own Mixing Console: 

• The Mixing Console can be shown/hidden with the left-most button in the transport. 

• The Mixing Console can be configured exactly as the one present in standard 

documents, Buses, Effects, etc… 

• The Mixing Console is saved when the application exits and when the settings are 

confirmed with [OK]. 

• The Mixing Console now displays track arming. All inputs of the Console are pre-

buffered but only the Armed Strips are recorded when entering in Record. 

• The Mixing Console can be monitored in the Monitoring Section by pressing the 

monitoring button in the transport, button with the headphone on the right of the 

mixing console show/hide button 

• When a Background Recorder is selected for monitoring in the monitoring section, the 

Sources header in the Monitoring Section is colored with the Background Recorder 

color code 

 

� Each recorder acts as an independent machine like the Internal or any External Machine. 

• Pressing the Ctrl button on the transport window or selecting it in the Transport 

Toolbar box combo gives it the focus from keyboard shortcuts, Sony 9-Pin commands 

or controllers linked to the transport. 

 

� Enabling the Recorder : 
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• When pressing the Enable button, 6th button from the left in the transport window, or 

Play in the Transport Toolbar, the recorder starts pre-buffering data. 

• The amount of pre-buffered data is visible in the Duration counter in the machine 

display. 

• The In and Out counters show the timestamps for the recording that WILL be 

performed when Record is pressed. 

• Pressing the Chase button also enables the recorder and starts pre-buffering after the 

machine is locked to the selected incoming timecode. The In/Out points then refer to 

the incoming chased timecode. 

 

� Recording: 

• Pressing the Record button starts the Recording and first sends to the file(s) all pre-

buffered data. 

• Pressing Stop stops the recording and closes the file(s) of both Media Sets. Data 

starts to be pre-buffered again immediately at that moment. 

• Data stops being pre-buffered when the Enable button is un-pressed or Chase is 

disabled. 

 

� Edit while Recording 

• When recording a new file with the Background Recorders, the file(s) being recorded 

can be edited in a timeline while the recording progresses. 

• This is also possible for recordings in the timeline but only in non-dubbing mode. 

• This is possible only when using the BWF or MTFF file formats when recording. 

• When a recording starts the new media being recorded appears immediately in the 

media manager colored with the recorder color code for easy identification. 

• The media can be dragged to the timeline and edited while it grows in size. 

• The clips in the timeline are also colored with the machine color and the last portion 

of the edited clips keeps growing automatically as the recording progresses. The clips 

keep growing only if they are the last clip on the track to avoid undesired collisions. 

• Multiple recordings coming from different machines can be edited at the same time. 

• The media being recorded can be sent for editing automatically when the recording 

begins, see background recorders settings above. 

• The clips being recorded can be played back seamlessly like any other clips 

 

� Transport Toolbar Background Recorder indicator 

• Each Background Recorder displays a little square LED of its “official” color on the 

right side of the machine selector of the Transport Toolbar. The LED blinks when the 

machine is recording 

• Clicking on the LED selects that machine in the toolbar and gives it the remote 

control focus, as if it were selected in the left combo box or as if the Ctrl button of 

the main transport window has been clicked 

 

� Prebuffered Memory usage indicator 

• The memory consumption of each Background recorder is indicated in the Transport 

window. 

• The memory indication is only displayed when in pre-buffering mode. 

 

Take Logger: 

� A new Take Logger tool is available in the menu View > Tools/Windows. 

� This opens a modeless dialog allowing for controlling any of the available recorders, being the 

timeline of the currently Active Project or any of the Background Recorders. 

� At the bottom of the dialog the recorder can be chosen and a direct access to its settings is 

available. 

� For Active Projects only the Non-Dubbing mode is supported by the Take Logger. 

� The dialog allows for entering the Take Name, some Take Notes and a Take Color. This 

information can be changed any time before or during recording time and is applied at the 

end of the recording. 

� The Take Name applies to the recorded file name(s), to the recorded file(s) metadata and to 

the recorded clips in the timeline. 

� The Take Notes and Take Color only apply to the recorded clips in the timeline. This 

information is not stored in the recorded file(s). 
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� The dialog offers Start Recording, Stop Recording and Bad Take buttons to control the 

currently selected recorder. 

� The Bad Take button stops the recording, adds a “Bad (xxx)” suffix to the file(s) name and 

take name, and colors the recorded clips with the Bad Take color available in the General 

Settings > Timeline Layout page. 

� When the Take Logger has the focus all keyboard shortcuts are disabled 

� Take Logger layout additions 

• Start Recording: 

� To stop a proper recording, the take number is incremented in this 

case 

• The False Start:  

� Function no longer splits the recording but now adds a Media Marker 

with a new kind of Rating called False Start. 

� When one (or more) False Start Media Marker is/are inserted during a 

recording, the Rating line is colored in dark grey up to the last False 

Start marker and all preceding markers are also colored in dark grey 

to indicate that this portion of the recording is bad. 

� False Start markers can be edited, removed and added as normal 

markers. A new menu has been added in the Markers > Add Media 

Markers Special menu. 

� In the Take Logger, no new button has been added in the Marker 

section, the False Start button remains in the top section for this 

action. 

• Bad Take:  

� Stops the current recording, tags it as Bad Take and doesn’t 

increment the take number 

• Abort & Delete:  

� Stops the current recording, delete the recorded files and doesn’t 

increment the take number. Note: In the case of a background 

recorder with Edit while Recording, the media and clips are not 

deleted. 

� Integration of the Media Markers: 

• Media Markers can be added in the Take Logger by clicking one of the markers Rating 

buttons 

• By clicking the [>>] button the Take Logger window expands and the Markers of the 

currently happening recording can be edited. The list empties when the record ends 

up. 

• The Media Marker file saved along the media to save markers in has been renamed 

.mmd, for Media Meta Data. 

� Take Notes are now also saved in the .mmd file. 

• The Take Name and Take Notes are saved in the associated .mmd file next to the 

recorded media files recorded with the Take Logger. 

• This allows for the Take Notes to be displayed in the Media Manager Notes column, in 

the Media Properties Notes fields and in the Selection Tab > Media > Notes fields, 

whatever the recording format is chosen. 

� Added Keyboard Shortcuts for the Take Logger 

• By design the Take Logger bypasses (“eats”) all keyboard shortcuts to avoid 

misbehaving during recording. 

• To allow manipulating the Take Logger with a keyboard, a specific Take Logger 

section has been added in the keyboard shortcuts editor 

• These shortcuts are only functional when the take logger window is open. 

 

Recording Status Window: 

� The Recording Status window available in the menu View > Tools/Windows has been 

updated. 

� It now reflects the state of the recorder selected currently in the Take Logger window. 

� It can now be resized and displays the Take Name as large as the window allows for. The 

Take Name is updated in real-time as it is modified in the Take Logger window. 

� The Start time and Length of the current recording is now displayed in the window. 

� If the selected recorder is the Active Project and that project displays the Bars & Beats ruler, 

then the Start time in the Recording Status window is displayed as Bars – Beats counter. 
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Post-Effect record option: 

� Available in the Background Recorders and in the Timeline but only in non-Dubbing Mode. 

� Can be set independently per Strip. 

� There’s no real button on the console, it is only accessible through the right-click context 

menu and the little side-border [+] menus: 

• Right Click on a Strip, under Strip > Record Post Effects (with a check mark if Post). 

• On the bottom [+] menu under Record Pre Effects and Record Post Effects. 

• Right Click on the Mixer, under Mixer > All Strips Record Pre Effects and All 

Strips Record Post Effects. 

• On the right Fader section [+] menu under All Strips Record Pre Effects and All 

Strips Record Post Effects. 

• The above menus are not available in Dubbing Mode 

� When enabled to record Post Effects, the Track Arming button changes to Purple instead of 

Red as an indicator. 

Important: Pyramix v8.1 projects are NOT compatible with the previous Pyramix v8.1 Release. In 

order to open such projects in an older Pyramix version please make sure that you perform the 

proper Save Special option. A Save Special “Save as Version 8.0” was added to the list. 

 

Secondary Audio Device Host: 

� The Audio Bridge has been improved to now allow users to connect to an existing Audio 

Device in the system, being either the built-in sound card or an external ASIO-type device, as 

a Secondary Audio Device for Pyramix, in addition to the standard MassCore or ASIO 

“Primary” card. 

� This is typically a solution for monitoring locally on a secondary audio device the signal 

coming from a primary MassCore or ASIO based Horus unit, typically deployed remotely as a 

stage box through RAVENNA. 

� As this Secondary Audio Device Hosting Mode is bidirectional it also provides the talkback 

support to talk locally to a person near the remote primary unit. 

� The secondary audio device should not be used to record from as it includes a constant SRC 

to maintain perfect sync with the main unit even without any external hardware based sync 

being required. Recording should only be performed from signal coming from the primary 

unit. The secondary unit should only be used for monitoring and talkback. 

� It’s been integrated in the Audio Bridge setting in the VS3 Control Panel, which now offers 

the three following choice: 

• Disabled 

• Audio Device mode (to create a virtual ASIO Device in the system) 

• Secondary Audio Device Host Mode (to connect to an existing Audio Device in the 

system as a secondary I/O) 

• Rewire Mixer Mode (to create a Rewire Mixer in the system) 

� Configuration: 

• Launch the VS3 Control Panel and enable the Secondary Audio Device Host Mode ( 

bottom) 

• You can chose between 8 to 96 I/O channels (depends of the secondary Host 

capabilities) 

• Launch Pyramix and go under Settings>Hardware>MassCore. The Secondary 

Audio Device allows users to configure the host. 

� Type: ASIO or Windows Audio or DirectSound. 

� Output: ASIO4All or other. 

� Input: Windows Audio or DirectSound only. 

Not available with ASIO type. 

• Select one device from the Audio Devices list and press Ok to use it for monitoring 

target/talkback source. 

• Open the Monitoring Panel and go to the configure tab: 

� Patch the mixer or the monitoring session accordingly. 

� The AudioBridge I/O entries will be labeled as AB1 to ABn. 

� The Talkback Monitor tab can be configured for talkback purposes.  

Known Issues: 

Depending on driver type/device you can lose the connection to the Secondary audio device at 

restart or when sampling rate changes.  

Workaround: go to PMX settings and reapply the Audio Device Bridging property page. 
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Media Markers: 

       Media Files and Libraries MasterClips can now store Markers, called Media Markers: 

� Media Markers can be added in any Media File, whatever its format. 

� Media Markers are stored in the Media object or MasterClip in the Media Manager, Libraries 

and Projects referencing the Media. 

� Multiple Clips referencing the same Media share the same Markers within the same Project or 

Library. 

� When saving a Project with two different versions (with Save As for instance), the Media 

Markers within both versions can evolve differently as they are saved in the Projects and/or 

in different Libraries, but: 

� Media Markers can be saved along with the physical Media File by calling the menu Markers > 

Update Media Markers to Files. A file with the same name as the physical Media File with a 

.mmd extension is saved next to the Media Files and contains all the Markers for this Media. 

� When adding Markers to a Media being recorded the .mmd file is automatically saved when 

the recording ends up. 

� When mounting a Media file with no reference to any Projects or Libraries, its associated 

Markers are only available in its associated .mmd file. 

� Clips in a Project or Master Clip in a Library carry a copy of the Markers and can be edited 

separately. The original version of the Markers created during recording can be retrieved in 

the .mmd file. This .mmd file can be updated after modification of the Markers with the menu 

Markers > Update Media Markers to Files, as explained above. 

 

Media Markers contain: 

� A Number (not editable) 

� A TimeCode (the offset from the beginning of the Media) 

� A Name 

� A Comment 

� A Rating (a choice from: Excellent, Good, OK, Bad, Ridiculous) 

 

Media Markers are displayed: 

� In the Media Manager or Library Trimmer (not editable here) 

� In the Clips referencing a Media containing Markers (editable in this case) 

� The Media Markers have a color based on their Rating: 

• Excellent = Green 

• Good = Blue 

• OK = Yellow 

• Bad = Orange 

• Ridiculous = Red 

� Rating information, Media Markers can now have a Custom information associated with 

instead 

� Next to the 5 Ratings and False Start button there are 10 Custom buttons in both the Add 

New Media Marker dialog and in the Take Logger. 

� These 10 Customs Name and Color can be defined by the user. 

� The Rating Line is not impacted by the Custom Markers when inserted between Rating 

Markers 

� Media Markers are displayed only when a Clip is selected. 

� Markers outside of a Clip boundaries (trimmed Clips) are displayed only if the menu View > 

Show Media is enabled 

� A Rating Line is displayed on Clips containing Media Markers, even if the Clips are not 

selected. 

• This allows for easily viewing the parts of a recording with a good or bad rating. 

• This Rating Line can be shown/hidden through the menu Markers > Display Media 

Markers Rating Line 

Note/Trick about adding Media Markers related to the Rating Line feature: 

• A nice feature is to map for instance the “Add Media Marker Excellent Rating” function 

to a Key of your choice, and then map the “Add Media Marker OK Rating” to the same 

Key but on Key Up. Do the same with Good, Bad and Ridiculous with three other 

Keys. 

• Pressing any of these keys will actually “color” your recording as long as the key is 

pressed and resume to “normal” when released. This allows for marking regions of 

your recording that will be easily retrieved during editing if the Rating Line is 

displayed. 
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Show Media Markers on Clips 

� In the Markers menu, this goes along with the Display Media Markers only on Selected Clips 

and Display Media Markers Rating Line. 

� It allows completely hiding the media markers on clips, while still showing them in the media 

manager trimmer. 

� When both the media markers and the rating line are hidden then the Nudge Cursor to 

Next/Previous Edit and the Nudge Clips to Next/Previous Edit doesn’t stops at Media Markers 

position. 

� To navigate from a marker to the other can be achieved by selecting the media and using the 

Tab keyboard key.  

Note: Make sure that under your keyboard editor under “Cursor and Marks” you must have 

TAB in the Nudge Cursor to Next edit command. You can also map TAB +Shift for the Cursor 

Previous Edit navigation. 

 

Media Markers can be edited the following way: 

� Grab and move Media Markers directly on Clips. 

� Add Markers in the selected Clip with the menu Markers > Add Media Marker to Cursor 

� Add a Rating based Media Marker with the menu Markers > Add Media Markers Special > Add 

Media Marker with Rating XXX 

� Delete a Media Marker with the menu Markers > Delete Selected Media Marker 

� In the Marker Tab: 

• A new Media Marker Section has been added in the Marker Tab, on the right side of 

the standard Markers section in the Tab 

• This section displays the list of Media Markers of the currently selected Clip 

• Media Markers can be added, deleted and modified here like standard Markers. 

 

Markers Undo/Redo 

� When Adding, Deleting and Modifying Media Markers of an existing clip/media will simply 

Undo/Redo as expected.  

� When Adding, Deleting and Modifying Media Markers while Recording a Media: 

• In the Timeline: Undo/Redo works as long as the recording keeps running. When the 

recording is stopped nothing can be undone that have been done during recording 

time. However, following operations are undoable/redoable. 

� With Background Recorders which Recording is being Edited in the 

Active Document: Undo/Redo works during the recording and actions 

performed during recording time can even be undone/redone after 

the recording is stopped. 

� With Background Recorders which Recording is NOT being Edited in 

the Active Document (meaning using the Take Logger): No 

Undo/Redo. 

  

Editing Media Markers during a Recording in the Timeline: 

� If there is a Recording happening in the Project Timeline (and there are no selected Clips), 

the Marker Tab displays the Markers for the current Recording. 

� Media Markers for the current Recording can be added, deleted and modified exactly like for 

the selected Clips. 

� Media Markers created during a Recording are automatically saved in a .mmd file associated 

with the recorded File. 

� This is available only in non-Dubbing Mode. 

 

Editing Media Markers during a Background Recording: 

� Media being recorded with a Background Recorder can be added Media Markers by using the 

Edit while Recording option. 

� The growing Media in the timeline being recorded by a Background Recorder can be added 

Media Markers exactly as any other Media placed in the timeline 

� Media Markers created during a Background Recording are automatically saved in a .mmd file 

associated with the recorded File 

 

Rate Selected Region 

� There’s a new sub menu in the Markers menu after the Add Media Marker Special called “Rate 

Region” 
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� This allows applying a Rating to the selected region. 

� This set a Media Marker with that Rating at the beginning of the region and end that rating at 

the end of the region with either an OK rating marker or a rating of what was at that location 

before. 

� Any other rating markers in that region are deleted. 

 

Rate Playback/Record Zone 

� This allows rating a region/zone while playing it back or recording it. 

� When pressing the keyboard shortcut associated to that command the corresponding rating 

starts to be applied at the current cursor position and stops when the key is released. 

� This therefore only works while playing back or recording AND when these commands are 

given a keyboard shortcut (because we need the key up message to stop the rating process), 

and this is why there is no menu for it, these commands are only available in the keyboard 

shortcut editor. 

 

The Menu “Cursor & Marks” has been split in two menus:  

� “Cursor & Marks”  

� “Markers” 

 

 

Automation preview mode: 

� New Preview button option was added next to Off-Read-Write buttons on the main 

automation bar. 

� In Preview mode 

• We are in Read mode until a control is grabbed. This control stays at its last position 

until a snapshot is validated. When stopping the playback, the snapshot dialog popup 

and shows which controls have changed.  

• The Snapshot range action shows which parameters have been changed since the 

previous snapshot 

• Optional, apply Preview feature to automated controls in Play mode only 

 

 

Horus/RAVENNA PreAmps support: 

� When a RAVENNA PreAmp/AD module is enabled and connected in the Pyramix Mixer the 

PreAmps parameters will appear within the Pyramix Mixer. 

� The Mixer PreAmps Parameters are: 

• Mic or Line selector. 

• Low Cut filters. 

• Phase. 

• 48V phantom power. 

• Pad. 

• Gain PreAmp button adjustment 

� The Mixer PreAmps Gain can be increase using either the button itself of the keyboard 

up/down arrows (for 0.5dB step precision). 

� You can reset the Mixer PreAmps Gain by doing a Mouse+Double Click on the Gain button. 

� For Stereo/MS strips  

• PreAmps for Stereo/MS strips Gain control will display the absolute gain value 

• Stereo/MS strips have their details state available through the "+" button beside 

Line/Mic selection 

• Gain control of Stereo/MS shows gain of each channel 8V button popup a small menu 

allowing users to confirm the right choice. 

� Mix PreAmps support is also available for Pyramix when running in RAVENNA ASIO.  

� VCA support for PreAmps mixer grouping. 

If a user wants to group Strip PreAmps controls simply add a VCA and enable the Strip group 

assignation. Then by using the VCA PreAmps control the user will be able to control all 

parameters of the assigned group strips. 

Note: All controls will follow, but if the Gains of each strip are different we will not go below 

0dB for the lowest strip PreAmp Gain if using the VCA adjustment control. In order to break 

the 0dB barrier the user can use Ctrl and turn the gain down with the risk losing its gain level 

balance for the other PreAmps strips which are members of the group. 

Note: GPS strips do not support the PreAmps control but VCA strips do. 

� Horus/RAVENNA Settings: 
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• A new setting entry was added within Pyramix under Settings>Hardware>MicPre 

Remote 

• Users can configure their Settings so that either the PreAmps parameters of the Horus 

are recalled or the parameters of the Mixer itself are. 

 

DSD render  

For DSD64/DSD128/DSD256 rendering: 

� A new feature (Project > DSD Render) allows the processing of edits (Fades/Gains/Cuts) of a 

DSD Timeline. 

� This applies to DSD64, DSD128, DSD256 and DXD projects. For the latter, the user has to 

specify which DSD sampling rate the processor will be setup with. With DSD projects, this 

sampling rate is forced to the project's sampling rate. 

� Supported input file formats and sampling rates: 

• DSDIFF (.dff) at 64 Fs (2.8224 MHz), 128 Fs (5.6448 MHz) and 256 Fs (11.2896 

MHz) 

• DSF (.dsf) at 64 Fs (2.8224 MHz) and 128 Fs (5.6448 MHz) 

• WSD (.wsd) at 64 Fs (2.8224 MHz) and 128 Fs (5.6448 MHz) 

• DSD MTFF (.mtff) at 64 Fs (2.8224 MHz), 128 Fs (5.6448 MHz) and 256 Fs (11.2896 

MHz) 

� Supported output file format and sampling rates: 

• DSDIFF (.dff) at 64 Fs (2.8224 MHz), 128 Fs (5.6448 MHz) and 256 Fs (11.2896 

MHz) 

� User also specifies the range, i.e. whether he/she wants to process 

• The whole composition 

• The region between Mark-In and Mark-Out markers 

• Or a selection, if any.   

Note: If selection is chosen all tracks will still be taken into account, only retaining 

the clips between start and end of selection's time range 

� The processor will then parse the composition, ignoring any clip which has a different 

sampling rate than the specified one. Any portion of a DSD clip which involves a fade-in/ 

fade-out or gain different than 0dB will be requantized, while preserving the rest of DSD 

data, yet resyncing the DSD stream on cut points. At the end of the process, the resulting 

media is a DSDIFF file with the same number of channels as the number of track in the 

Pyramix's composition. Its sampling rate is the same as specified one, and its length is the 

same as the specified range, with 2 seconds post roll. 

Dirac Time-stretch and Pitch-shift support 

� New Time-stretch & pitch shifting renderer 

� New Dirac Merging key needed 

� The Default Time-stretch tool in Editing replaces the Timezone  

• It can also be defined under Settings>Application>Editing>Time Stretch Tool 

• TimeZone is deprecated and no longer available 

� Dirac configuration is available in the Pyramix Settings  

• Under Settings>Application>Time Stretch>Dirac 

• Three quality modes are available: Good, Better, Best 

• Time/Frequency localization setting 

1: Selects full time localization. Good setting for single instruments and voice 

2: Time/frequency localization with emphasis on time localization. If setting #1    

produces echoes this might be a better 

3: This sets the time/frequency localization halfway between time and frequency 

domains. It is the best setting for all general purpose signals and should be set as 

default for non-preview processing 

4: Higher frequency localization and less time localization. Might be a better choice 

for classical music than the lower Time/Freq localization settings 

5: Highest frequency localization. This might not be an ideal choice if you’re dealing 

with signals that have very sharp attack transients 
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Improvements 
 

New MassCore (RTX) version (since Pyramix v8.1 beta2) 

� RAVENNA/Horus users will no longer have a blue screen or automatic reboot at system 

shutdown. 

� Horus discovery after the system login will now take less than 20 seconds (instead of up to 4 

minutes). 

� The RAVENNA MassCore NET-MSC-GBEX1 PCIe Ethernet card will no longer be un-recognized 

after a system restart (Red X under Windows network connections). 

� Workaround: If the Horus is not discovered you can launch a script that will help the Horus 

discovery. The resetMassCoreNic.bat script is available for RAVENNA MassCore users, launch 

it from:  C:\Program Files\Common Files\Merging Technologies\VS3\resetMassCoreNic.bat 

 

RAVENNA MassCore configuration file relocation 

� The Configuration file which saves the Ravenna EasyConnect configuration have been move 

from C:\ to X:\Users\ UserNAME \AppData\Roaming\Merging Technologies 

� This now allows non-administrator users to have the rights to write in this fil. 

Note: Once updating to v8.1Beta4 or higher such user will lost his current Easy Connect 

configuration and will have to redo it (once). 

 

RAVENNA MassCore DXD & DSD playback/record Support  

Based on our RAVENNA MassCore certified platforms http://www.merging.com/pages/pcconfig  
Note: The specifications below are based on single media multitrack files (not one file per track) 

� DXD support to/from Horus (DXD project) 

• Playback of DXD files. Up to 48 tracks with 48 Outputs 

• Record of DXD files, DSD64, DSD128, DSD256 (configure the Horus Format page 

accordingly). Up to 48 inputs 

• Playback of DSD64 files (Enable Hepta SRC). Up to 48tracks* with 48 Outputs 

• Playback of DSD128 files (Enable Hepta SRC). Up to 48tracks* with 48 Outputs 

• Playback of DSD256 files (Enable Hepta SRC). Up to 48tracks* with 48 Outputs 

Note: Merging recommends users to record in DXD in a DXD project. 

� DSD64 support (DSD64 project). 

• Playback of DSD64 files. Up to 48 tracks with 48 Outputs 

• Record of DSD64. Up to 48 inputs 

� DSDIFF file format supported 

� DSDIFF Edited Master file format supported 

� DSF file format supported 

� MTFF file format supported 

� DSD128 support (DSD128 project). 

• Playback of DSD128 files. Up to 48 tracks with 48 Outputs 

• Record of DSD128. Up to 48 inputs 

� DSDIFF file format supported 

� DSF file format supported 

� MTFF file format supported 

� DSD256 support (DSD256 project). 

• Playback of DSD256 files. Up to 48 tracks with 48 Outputs 

• Record of DSD256 files. Up to 48 inputs 

� DSDIFF file format supported 

� MTFF file format supported 

� Background Recorders: 

• Supports DSD256, DSD 128 and DSD64  

• The supported recording formats in the Background Recorders for DSD64/128/25 is 

the MTFF file format 

 

Merging RAVENNA ASIO driver 

Note: The specifications below are based on single media multitrack files (not one file per track) 

� The Driver supports 8 I/O channels in DXD, DSD64, DSD128 or DSD256 

� DXD support to/from Horus (DXD project) 

• Record only DXD format into a DXD project (Pyramix Native users cannot perform 

cross format recording like it is possible in RAVENNA MassCore mode). Up to 8 inputs 
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• Playback of DSD64 files (Enable Hepta SRC). Up to 48tracks* with 8 Outputs 

• Playback of DSD128 files (Enable Hepta SRC). Up to 48tracks* with 8 Outputs 

• Playback of DSD256 files (Enable Hepta SRC). Up to 48tracks* with 8 Outputs 

� DSD64 support (DSD64 project). 

• Playback of DSD64 files. Up to 48 tracks* with 8 Outputs 

• Record of DSD64. Up to 8 inputs 

� DSD128 support (DSD128 project). 

• Playback of DSD128 files. Up to 48 tracks* with 8 Outputs 

• Record of DSD128. Up to 8 inputs 

� DSD256 support (DSD256 project).  

• Playback of DSD256 files. Up to 48 tracks* with 8 Outputs 

• Record of DSD256. Up to 8 inputs 
• The performance will depend of the System and Disk configuration. 

 

Note: If using a external USB drive not performing enough, Merging might advise you 

with a message box to set the disk for better performance. If you see this 

”Would you like enabling the Better Performance setting now? » we highly recommend to 

confirm this setting 

 

Timestretch: Prosoniq MPEX4 update 

� We’ve updated the Timestretch library from MPEX3 to MPEX4 

� User that had the MPEX3 are automatically upgraded to MPEX4 

 

Designated Bus selector for Fader Alignment 

� The Selector is available in the Automation Transport bar 

� For Automation delay compensation alignment with output Bus 

� The users can now select one Bus that will be aligned with Automation 

 

MTFF LRC disable 

� The MTFF file format now has the LRC Loss-Less compression disabled by default to ensure 

possible recovery of the file. 

 

Hepta SRC 

� Enhanced performance for DSD to PCM conversion 

� Performance enhancement for DSD64/128/256 Live Input conversion in DXD project mixer 

 

ISRC Support in BWF files 

� ISRC code added in any Tracks of a CD Album edited in the CD View will be written in any 

corresponding BWF file generated by the Album Publishing function. 

 

� Mounted BWF files containing an AXML chunk containing an ISRC will have the ISRC 

displayed in: 

• A Media Manager new ISRC column 

• The Media Property Page 

• The Selection TAB > Media section for any selected Clip referencing that Media. 

Algorithmix ReNOVAtor now bundled in Pyramix 

� ReNOVAtor is now included in Pyramix  

� A New ReNOVAtor Merging key is needed 

Note: Users currently running ReNOVAtor can either run it on Merging’s VS3 key or on 

Algorithmix’s protection dongle. Both versions are similar be the installations differs. At the 

Pyramix installation you might be prompt of which version you want to use. 

MTDSD Converter utility 

� This new conversion tool is available from the start up menu under: 

Windows Start Menu>All Programs>Merging Technologies>Pyramix> MTDSD Converter 

� Users can select an input file format such as 8FS/DXD/DSD file and convert it to the desired 

DSD output file format and Sampling rates such as DSD64, DSD128 or DSD256. 
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Bugs fixed Pyramix v8.1.10 Hotfix 
� MT5558: Fixed. DSDIFF record wrong channel mapping in 5.0/5.1 

� MT5597: Fixed. Shift + Drag and Select does not change clip colour on selection 

� MT5594: Fixed. Open most recent icon makes Pyramix crash at start up  

� MT5560: Fixed. Automation: wrong mode at application start  

� MT5546: Fixed. Mic PreAmps: Settings missing from Pyramix when in NATIVE  

� MT5569: Fixed. VS3 plugins cannot be set to Automation Isolate from insert GUI  

� MT5527: Fixed. ReNOVAtor crash when hitting cancel during playback (fixed in Build-in version) 

� MT5588: Fixed. Waveforms while recording should display x1 only if the display Auto-Scale mode 

was selected, not all the time.  

� MT5496: Fixed. Pyramix PreAmp improvements. Gain accuracy & communication (latest Horus 

firmware required)  

� Fixed. Record Stream's limitation issue in Native  

� Fixed. When ratio of sampling rates is not 2 or 1/2, the timestamp is still wrong after SRC. 

� Fixed. DSD support in ASIO Host. Mytek and Playback Designs (DSD128 support)  

 

Bugs fixed Pyramix v8.1.9 Hotfix 
� MT5547: Fixed. Document not updating when changing from 352.8 PCM to DXD mode 

� MT5551: Fixed. Mixdown: Random Audio glitches in Mixdown (due to BWF & Wave timeline media 

format)  

Bugs fixed Pyramix v8.1.8 Hotfix 
� MT5537: Fixed. MT DSD converter: Cannot convert .Wav DXD file to DSDiff or DSF 

� MT5536: Fixed. Take logger Media Markers duplicated 

� MT5529: Fixed. Grouped clip move with crossfade can shift down the automation tracks 

� MT5528: Fixed. DSD render: cannot cancel render if replacing existing file name of a mounted 

folder 

� MT5525: Fixed. Media Manager needs a refresh to display new name of a renamed file 

� MT5522: Fixed. Source-Destination Undo can erase the automation 

� MT5521; Fixed. Arm/Unarm tracks from OASIS controller do not update mixer rec ready led 

� MT5517: Fixed. Detect Picture Change & Reconform messes up Automation 

� MT5516: Fixed. Automation Paste to mouse only paste to Cursor 

� MT5513: Fixed. m4a handler introduces a glitch at start of file. 

� MT5512: Fixed. Album Publishing - End of Last File Missing 587 Samples 

� MT5511: Fixed. DSD Render: Should not un-mount and remount medias for processing. 

� MT5380: Fixed. Final Check bus output selection get reset after a mixdown 

� MT4313: Fixed. Mixdown with SRC mismatch TC of the file (timestamp multiplied by 2) 

� MT4836; Fixed. Pyramix playback not working after reconform 

 

Bugs fixed Pyramix v8.1 RC2 
� MT5505: Fixed. BG Record & Mixer track arming not working in DSD mode 

� MT5504: Fixed. One file per track DSDIFF waveforms while recording will display the input 1 level 

in all the tracks 

� MT5500: Fixed. DSD Render: Option to remove the 2 seconds Post Roll 

� MT5495: Fixed. DXD to DSD project conversion: possibility to convert to DSD128 & DSD 256 

� MT5494: Fixed. Report Printer ‘EDL’  can hang pyramix 

� MT5492: Fixed. Ravenna ASIO Driver reports wrong sampling rate 

� MT5484: Fixed. Multiple Mixer Invalid dialog with DXD or DSD project 

� MT5483: Fixed. All recorded file format above 128 Tracks will show track A1 in MM 

� MT5482: Fixed. Mixer: reaching the max record streams prevents files to be recorded 

� MT5480: Fixed. Mixdown to wave numbering of tracks and Media Manager confusion. 

� MT5478: Fixed. Crash upon Fader delay refresh after the 2nd open and convert DSD project 

� MT5477: Fixed. Delay compensation value not updated when removing VS3 plugins from Mixer 

main page 

� MT5474: Fixed. Render to DSDIFF will generate unwanted noise in files 

� MT5473: Fixed. ReNOVAtor: security of Algorithmix bypassed 

� MT5472: Fixed. Mixdown to BWF/Wave can generate glitches on some external disk 
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� MT5469: Fixed. Record performance regression in BWF (one file per track) 

� MT5468: Fixed. Dirac Key not seen in MT Security panel and Settings> Keys page 

� MT5460: Fixed. DSD256: Recording in DSDIFF file format will generate inaccurate waveforms 

� MT5376: Fixed. DSD256 project with medias converted to DXD project will have invalid mixer and 

generate bad renders 

� MT5437: Fixed. DSD256: Recording in DSDIFF file format will generate inaccurate waveforms 

� MT4690: Fixed. Pyramix: playback stalls when playing multiple mxf audio files 

� Fixed. UPC/EAN code is mistakenly displayed with suffix 

� Fixed. Using the UPC in the output file name results in a leading zero is now suppressed 

 
 
Bugs fixed Pyramix v8.1 RC1 
� MT5450: Fixed. Mic/Preamp VS3 settings lost in some conditions 

� MT5448: Fixed. Background recorded: Editing while recording clip has bad length if stop before 

timeline update 

� MT5445: Fixed, Mic/PreAmp Lowpass and Phase are not controllable in some conditions 

� MT5444: Fixed. Waveforms not shown in Auto-Scale mode, depending of zoom ratio 

� MT5443: Fixed. Mixdown From DXD medias To DSDIFF result in empty small file 

� MT5442: Fixed. Background record in chase with Edit while recording: Project reload inaccurate 

� MT5440: Fixed. Library: Cut or replace duplicates name throughout the libraries 

� MT5435: Fixed. Mic/PreAmp settings not always updated when switching project 

� MT5439: Fixed. Pre Amps control using VCA group is not accurate 

� MT5429: Fixed. Adding CD markers in large project memory leak 

� MT5427: Fixed. Mixdown To DSDIFF will take count of the non selected Bus 

� MT5424: Fixed. Pyramix hang when renaming a timeline snapshot 

� MT5422: Fixed. OASIS security check can be unstable (loop consuming CPU) 

� MT5412: Fixed. Recording in DSF one file per track will crash Pyramix in a DSD128 or DXD project 

� MT5402: Fixed. Mixdown DXD subgroups : unable to assign path 

� MT5383: Fixed. Background Recorders warning if the Mixer is not a DSD compatible Mixer  

� MT5382: Fixed. Dubbing Mode doesn’t work in DSD 

� MT5328: Fixed. Monitor panel: Monitor/Talkback window shows none if we close or change the 

project 

� MT5317: Fixed. when adding subgroups, some do not have send 

� MT5314: Fixed. Asio Bridge I/O not seen in Mixer Route page also talkback+monitoring 

� MT5313: Fixed. Mixer: Bus Multi-Mono with groups cannot be changed (banking) 

� MT5309: Fixed. AMR & ASIO driver does not remove previous version when upgrading 

� MT5272: Fixed. Playback in loop, eventually will recue in the previous day. 

� MT5248: Fixed. Plugins automation might not reconnect when reopening project 

� MT5429: Fixed. Adding CD markers in large project memory leak 

� MT4460: Fixed. Eucon not detected on Win7 x64 (no longer need to install both x64 & x86 Eucon 

drivers) 

 
Bugs fixed Pyramix v8.1 Beta4 
� MT5436: Fixed. Non admin users cannot write in C:\MassCore_Ravenna.cfg 

� Fixed. Database conflict with ISRC entries 

� Fixed. Album publishing .wav file format will be corrupted if ISRC was present 

� Fixed. Inaccurate Renders DXD/DSD 

 

Bugs fixed Pyramix v8.1 Beta3  
� MT5420: Fixed. Crash adding a controller if some BG recorders are present 

� MT5419: Fixed. BG recorded BWF medias does not have proper length 

� MT5416: Fixed. Crash when renaming a snapshot drag to library 

� MT5401: Fixed. Green screen when shutting down Windows XP 

� MT5399: Fixed. Mic/Preamp input 1 cannot be controlled after a project load 

� MT5397: Fixed. PreAmps: Adding a stereo strip will connect the PreAmps inputs but not display 

the preamps button 

� MT5396: PreAmps: Gain addition on Stereo strips not accurate 

� MT5394: Fixed. Web Access: PreAmps Web page changes not updated on Pyramix Mixer 
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� MT5390: Fixed. BWF Mixdown will not take the correct timeline value. 

� MT5389: Fixed. AD8 low-cut filter has discontinuities at low frequency 

� MT5369: Fixed. Mixer PreAmps: keyboard arrow not working for Strip gain and VCA groups 

� MT5321: Fixed. Background record: Gray out the Delete Media option in the Media Manager during 

recording. 

� MT5340: Fixed. Pyramix v8.1 cannot be launched on XP (VS3ui.dll error) 

� MT5322: Fixed. Background record: Edit while recording Envelop does not grow up. 

� MT5300: Fixed. EasyConnect: Always on top option will hide pop up box 

� MT5250: Fixed. Automation vs. delay compensation, offset in bus output (new bus selector) 

� MT5199: Fixed. Sound Miner integration bugs 

� MT5158: Fixed. Drivers signing. Some driver certification fail driving to red popup during install 

� MT5106: Fixed. Automation: Not all carried to library snapshoot and retrieved 

 

 

Bugs fixed Pyramix v8.1 Beta2   
� MT5392: Fixed. Crash when adding strips in certain mixer 

� MT5391: Fixed. Delay Compensation not aligned in post Effects record mixer 

� MT5386: Fixed. MTFF TimeStamp not supported/implemented 

� MT5385: Fixed. MTFF One File per Track doesn’t mount properly 

� MT5371: Fixed. Pyramix crash on exit if the Monitor panel uses some Externals 

� MT5368: Fixed. Background record: Crash adding Background recorders and going to the settings 

� MT5367: Fixed. Background record: BWF single media do not in the Media Manager after recording 

� MT5364: Fixed. I/O & Sync Page at 352k8 must report DXD/DSD instead of DXD 

� MT5362: Fixed. Record Status window should not display red when in pause record 

� MT5355: Fixed. The Trimmer Player should not output TC 

� MT5353: Fixed. Background record: Pressing Chase on a BG recorder can hang application 

� MT5352: Fixed. Ravenna ASIO Cannot bind to MassCore NIC if user is not administrator 

� MT5346: Fixed. Background record: Settings opens a  new windows every time you press icon 

� MT5343: Fixed. Background record: and machine number can create crashes 
� MT5342: Fixed. Background record: Editing while recording media will be offline at project restart 

� MT5339: Fixed. Background record: Random crash when stopping a recorder 

� MT5337: Fixed. Background Recorders: Add warning when no track/strip is armed 

� MT5335: Fixed. PreAmps were not enabled in DSD project 

� MT5332: Fixed. Enabling VT will crash Pyramix 

� MT5331: Fixed. RAVENNA ASIO driver not binding correctly 

� MT5330: Fixed. Random crash on exit due to Background recorder active 

� MT5327: Fixed. Final Check: Loudness EBU-128 Metering not working under MassCore 
� MT5325: Fixed. Background record: Crash after a few seconds of record with Edit While Recording 

� MT5323: Fixed. Background record Monitoring from mixer confusion, could be better indicated 

� MT5320: Fixed. Create icons for RecStatut et TakeLogger 

� MT5319: Fixed. Background recorder chase problems 

� MT5318: Fixed. 9 pin remote not working when background recorder is the active machine 

� MT5316: Fixed. Background recorder can create a corrupted machine 

� MT5315: Fixed. Background recorder can get stuck and become un-stoppable 

� MT5312: Fixed. Transport: Crash when toggling between LTC and Recorder 1 

� MT5311: Fixed. Pull Down Pull Up setting should not be loaded in RAVENNA MassCore 

� MT5307: Fixed. DSD: Playback in reverse DSD256 media in DSD256 project generates noise. 

� MT5304: Fixed. DSD256 project: Record in MTFF will not display waveforms during recording. 

� MT5294: Fixed. Horus: loud click when going from DXD project to DSD 
� MT5293: Fixed. Mixer: Mic Pre by default shows Mic input, when Horus still in Line 

� MT5283: Fixed. Truncate the name for AAF Export (Project Convert/Consolidate/Pitch/Resample) 
� MT5282: Fixed. AAF Export : audio files generated are all tagged as 48K 

� MT5281: Fixed. Mixer inputs: Ravenna connection not always updated. 

� MT5278: Fixed. Background Recorder: Generated bwf name contains Uniq Extension twice 

� MT5256: Fixed. Switching from a created DSD project to a PCM project causes sample rate mixup 

� MT5207: Fixed. Final Check not working anymore after a Non-RealTime mixdown 

� MT5152: Fixed. Horus: not showing up online before 2 minutes, after start up/login 

� MT5127: Fixed. System: Potential RTX blue screen or automatic reboot at system shutdown 

� MT5040: Fixed. RAVENNA ASIO buffer size indicator wrong in VS3 ctrl panel 

� MT4126: Fixed. MassCore SMP: should not allow less than 2 cores to Windows 

� MT3632: Fixed. Display while recording: left part of the record clip without waveform 

� Fixed. Render potential offset in processed clips 
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Bugs fixed Pyramix v8.1 Beta1  
� MT4281: Fixed. Mixer small GUI corruption under Windows 7 (transport also) 

� MT5177: Fixed. Automation VCA: Enabling automation write can reset faders part of a VCA 

� MT5187: Fixed. Pyramix bars&beats. Problem with x86/x64 bars and beats location transfer 

� MT5213: Fixed. Library: crash if performing multiple "MT Interchange XML" export 

� MT5222: Fixed. ASIO RAVENNA : Unable to bind to NIC when non-admin user 

� MT5225: Fixed. We are not asked to save a project after some timeline edits. 

� MT5230: Fixed. VS3UIMixer: MTASIO Bridge lives conflict with regular MassCore Lives 

� MT5233: Fixed. Pyramix-VCube synchronizer lock time improvement 

� MT5237: Fixed. MassCore SMP, in RAVENNA Mode, doesn't use the first core for Audio Processing 

� MT5257: Fixed. Clicks in playback of non DSDIFF DSD64 file in a DXD project 

� MT5273: Fixed. Remove "Keep media library history" setting by default 

� MT5280: Fixed. Convert project not working in V8.1 Media handler error 

� MT5292: Fixed. RAVENNA Easy Connect: invalid codec error is not reported 

� Fixed: Mixer i/o connection improvements 

� Fixed: RAVENNA ASIO and Core Audio bugs 

� Fixed. The DSD/DXD Setting option “Ask for DSD/DXD conversion is by default disabled 

 

 

Bugs fixed Pyramix v8.0.12 HotFix 
� MT5215: Fixed. Pyramix hang mouse or Isis jog 

� MT5247: Fixed. Plugins automation might turn to Isolate when reopening project 

� MT5238: Fixed. Album Publishing crashes if both Contiguous and one file per track are enabled for 

the same output format 

� MT5240: Fixed. Pyramix created MP3 ABR (VBR) report wrong playback time on most MP3 players  

� MT5203: Fixed. DiscWrite: Cannot open SCSI device error preventing usage with USB Drives 

� MT5252: Fixed. Medias handled (JuceHandler e.g. mp3) have Media Name instead of Track Name 

� MT5212: Fixed. RAVENNA ASIO does not save configuration 

� MT5220: Fixed. Jog/Shuttle can remain blocked (cannot move slider) when using ASIO drivers 

� MT5221: Fixed. MassCore registry path error when starting Pyramix 

 
 

Bugs fixed Pyramix v8.0.11 HotFix 
� MT5216: Fixed. Pyramix Low memory warning error/RunTime error  

 

 

Bugs fixed Pyramix v8.0.10 HotFix 
� MT4747: Fixed. AMR key now present in MT Security panel 

� MT5041: Fixed. Digital Release or Mixdown hang if project is higher than 48K and MP3 SR set to 

no change 

� MT5098: Fixed. Corrupted automation and update VCA issues  
� MT5120: Fixed. Default Library.pml is not deleted after closing a project\ 

� MT5138: Fixed. Easy Connect: TimeCode text entries missing in the Hots side 

� MT5147: Fixed. AMR Drag & drop not always working (dll registration issue) 

� MT5149: Fixed. DSDIFF One File Per Track medias make Pyramix crash 

� MT5150: Fixed. MassCore RAVENNA: changing sampling rate lock improvement 

� MT5153: Fixed. Automation Undo not working from "A" track contextual menu ONLY IF 

automation track does not correspond to the connected strip 

� MT5154: Fixed. Record MTFF file format corruption on long files 

� MT5163: Fixed. Automation: Snapshots of Stereo clips to library not carried correctly 

� MT5164: Fixed. Pyramix may hang when recording automation if automation is displayed 

� MT5168: Fixed. Easy Connect: Make sure that CTRL clear connections removes all connections 

� MT5178: Fixed. CD/SACD Tab - CD-Text : remove Import >Cue Sheet File 

� MT5181: Fixed. Record in dubbing can potentially crash on stop 

� MT5182: Fixed. SonyP2 Play offset command produce an audio glitch 

� Fixed. Restored the lossless feature of MTFF file format handler 

� Fixed. Fixed DDP read problem with Album Publishing 
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� Fixed. Potential fixed crash when initializing CD drive 

� Fixed. fixed SCSI driver settings to avoid new default miniport driver introduced by last Gear API 

update 

� Fixed. Punch recording of auto-repro tracks connected to return strip causes recording clips to be 
randomly misplaced on the timeline. 
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Technical Notes & Known Issues 
 

PYRAMIX v8.1 
 
Technical Notes: 
MassCore 

� MassCore not supported on Core2Duo with Pyramix v8. Minimum requirement is a QuadCore. 

� MassCore is supported under Windows 7 and XP-SP3 (32 Bit only) 

� If your Core indicator in Pyramix is always overloading (red) 

 Recommendation:  

• The Hyper-Threading must be disabled in the Bios. If it was enabled you might have to un-

install RTX MassCore and re-install it 

• If under the Bios power options you have entries such as the Intel SpeedStep and CPU C 

State make sure that those options are disabled 

� We recommend that you do not use more than 65-70% of the Core resources, to avoid intense 

graphic refresh burst related problems. Three safe core zones have been set. Eventually this will 

be optimized further. 

• 0% to 65% Green zone (best performance) 

• 65% to 75% Orange zone (moderate risk) 

• 75% to100% Red zone (performance could be at risk if major screen redraws are initiated 

by the user).  

� If the Core indicator blinks (red), this will indicate a drop, only be concerned if the drop occurred 

during Playback/Mix down or record. To reset the Core drop simply do a Mouse click on the Core 

indicator, for more information please refer to the appropriate section in the User Manual.  

� If you have VST Core peaks users should increase their VST Engine Buffer size value, located 

under the Pyramix Settings. More information available in the User Manual. 

� External Insert plug-ins: The same input and output cannot be used in the External Insert plug-in 

and the Mixer at the same time, they are exclusive to either one. 

� MassCore: Core indicator will show a peak/overload after a save on large project or when 

rebuilding the Mixer (project open-close). Known as issue MT3113. Simply reset the core indicator 

by clicking on it. 

 

Mykerinos: 

� Since the Release of version 8.0, Pyramix systems are only available in either Native or MassCore 

versions. Mykerinos Technology will continue to be used as I/O, but the DSP mixing power on the 

cards officially becomes legacy technology. This doesn’t mean that your Mykerinos Based systems 

is obsolete as you can upgrade any Mykerinos system to MassCore without having to do anything 

but purchase a MassCore License *.  

* please consult the recommended minimum PC requirements for MassCore at 

http://www.merging.com/pages/pcconfig  

� Since Pyramix v8 the Mykerinos ASIO driver has been discontinued. We recommend that you use 

the MTASIO Bridge driver. 

 

General: 

� The Timezone time-stretch tool is no longer supported in Pyramix v8. Prosoniq MPEX4 or Dirac are 

recommended. Contact your local dealer. 

� The PureNotes Denoiser VST plug-in (developed by Flux) is no longer supported in Pyramix v8. 

Contact your local dealer. 

� The 1630 Import Module is no longer supported in Pyramix v8 

� Windows 8 has not been certified by Merging. 

� Merging does not recommend users to editing while recording when medias present in the timeline 

that are not at the same sampling rate as the project. This is so because a realtime SRC will also 

be processed causing potential performance problems. 

� Merging does not recommend the use models: Green, Eco series and Seagate.  

� Merging recommend users with External USB disk to have those disks configured to “Better 

Performance” under Windows disk properties, profiling option. 
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Known issues: 

 
� Pyramix v8.1 does not support Virtual Tape anymore 

� Pyramix v8.1 has a warning message of “Not Enough Streams available” this happens when 

reaching the maximum record inputs available. In such case we recommend that you reduce your 

inputs number count or disable the Background Recorder that are consuming inputs 

Known issue: If you afterwards get a constant Message Box “Re-activating Project” at each 

Playback start, close and re-open your project to avoid this. 

� MT5511: DSD Render function needs to unmount the medias for processing. Users will see their 

medias being offline during the processing stage. After the processing we will remount the medias 

folders. Be patient. 

� Dolby E comes as a separate installer and is no longer bundled into the Pyramix installer; please 

contact Merging Support if needed. The Dolby E - VST plug-in can be authorized through a 

Merging VST Key 

� Pyramix v8.1 projects are NOT compatible with the previous Pyramix Releases. In order to open 

such projects in an older Pyramix version please make sure that you perform the proper Save 

Special option. A Save Special “Save as Version 8.0” was added to the list 

� Pyramix v8.0 Libraries format are NOT compatible with the previous Pyramix Releases. In order to 

open such libraries in an older Pyramix version please make sure that you perform the proper 

Save library option. A Save “Save as Version 7.X” was added to the list 

� The Final Check Metering is not supported in DXD/DSD mode 

� Low Memory Condition Warning:  

A warning informs users when the system is reaching Low Memory Conditions. In order to save a 

project under such conditions Pyramix will switch to Save to Disk mode as not enough memory 

might be available otherwise. This warning was added in order to prevent a Runtime Error on 

Save.  

 

Note that the Save time in Save to Disk mode in Low Memory Condition might take a longer time 

since the memory is being dumped to disk in order to allow the users to save their projects. We 

recommend afterwards to exit and restart Pyramix in order to free all memory. 

 

This Low Memory warning threshold can be adjusted by the user if one wishes it to come earlier or 

later. With every systems and workflows being different, Merging leave you the ability to adjust 

when the Warning will show up. 

Procedure: 

• Close Pyramix 

• Type regedt32 in the run command 

• In the registry go to HKEY_CURRENT_USER\Software\Merging 

Technologies\Pyramix\Settings\Save to disk threshold (this key will only appear if at least 

one save was made using that version) 

• Default value in Decimal mode has been set to 15  

- The higher the value is set, the earlier the Low Memory warning will come 

- The lower the value is set, the riskier it is for you to encounter a Runtime Error at save 

(previous Pyramix versions value would have had this value set to 0) 

Merging is planning soon support 64 bit operating system; this will provide a very solid platform to 

accommodate the ever growing project size requirements of some of our users and significantly 

reduced the memory consumption of Pyramix when confronted with the task of loading enormous 

libraries with lots of automation present. 

 

� Cannot use DiscWrite with Pyramix:  

Workaround: Re-install Pyramix (maybe run clean up after un-installing Pyramix) or Re-install the 

Gear driver. Users can consult the Gear site for more details http://www.gearsoftware.com 

� Cannot install Pyramix Native: If you have a HASP error and rollback, make sure that you unplug 

your Merging Dongle from the system and try to re-install Pyramix 

� Timeline and Realtime Sampling Rate Conversion: clicks may occur when doing playback or 

mixdown in a region where 2 overlapping clips reference the same media with different sampling 

rate than project. 

Workaround: Convert those Medias to the project's sampling rate, prior to using such a workflow 

� ADR keyboard is by default disabled. To enable it you must download and run the proper Registry 

Key.  http://download.merging.com/beta/AssociatedTools/ADRKeyboard.zip 
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� Multiple projects opened simultaneously: We do not recommend users to have more than 8 

project opened at the same time (due to GDI object limitation). 

� The Render Tool will create a temp file for the CEDAR and Nova v0.99 in C:\  Be aware that 

Merging cannot change the Temp file patch of such third party Render. 

� Interchange: AAF non-embedded export to Pro Tools 7x could generate « Could not complete your 

request because an unexpected error happened while trying to find an audio media file’s format” 

error. We recommend to use AAF Embedded when exporting to ProTools 7. ProTools 8 is known to 

be working in such case. 

� Eucon/Euphonix v3.0 issues 

• Potential controller crash/hang when closing the settings 

• Crash at Pyramix exit when controller is active (mfc90u.dll) 

Note: Merging recommends that user use the v2 Eucon version 

� Merging RECOMMENDS that user use the Eucon/Euphonix v2.6.2 for accurate communication. The 

v2.7.1 has been known to have communication problems. 

 

 

Media Manager and Library recommendations and changed behaviors 

� The Database Location path is set under Settings>Application>Location>Default Database Location. 

Otherwise the database path will be C:\Documents and Settings\<User Name>\Application 

Data\Merging Technologies\Pyramix  

� For better performance Merging strongly recommends that you move the Database location on your 

fastest system Drive. SATA2 - 7200 rpm Disks are recommended and not necessarily C:\OS default 

drive (as a drive with less activity and more speed should be performing better) 

� Merging recommends that your Disk have the indexing disabled and that you make sure that the 

Power Management is set accordingly for better performance. 

� Disable File Indexing (XP + Vista + 7): 

1. Open “My computer”  

2. Right click on each drive and select “Properties” from dropdown menu 

3. Un-Check the indexing check box  

� Verify the Power Management: 

Go under Windows Control Panel and open Power options  

• XP Users: Set “Power Scheme” to “Always On” and set Turn off Hard disks to “Never” 

and System Standby to “Never”  

• MassCore users Under Vista & 7: Power plan should be “RTX – recommended”  

• Native Users: Make sure you select the “High Performance” power plan 

� For ultimate performance Merging recommends that you (not mandatory) 

� Set your Antivirus to off while running Pyramix 

� Set Windows Automatic-Update to “notify me” 

� Avoid active internet connection while running Pyramix  

� Keeping Mounted Folders when closing and restarting Pyramix can speed up your workflow: Set 

option under All Settings>Application>General> “Mount all Media folders that were Mounted at 

previous Application Exit” 

� You can clear the History of the Media Manager under the Media Manager>Media Folder menu, or 

that your disable the Keep Media Manager History option located in the Pyramix Settings, this will 

clear the History at each Pyramix exit.  

� Merging recommends Pyramix users save their project on a Disk were no OS resides for better 

performances (C:\ not recommended). 
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RAVENNA 
 

Technical Notes: 
� Windows 7 (32 bit) mandatory for MassCore RAVENNA (XP not supported) 

� VS3 Control Panel Ultra/Extra low latency are not supported in RAVENNA mode 

� Find the Recommended configuration for Pyramix v8 RAVENNA here 

http://www.merging.com/pages/pcconfig  

� The Horus RAVENNA interface is limited to 32 input Banks + 31 output Banks  

E.g. 32 banks of 8 inputs channels under Easy Connect equals a 256 inputs limit 

� For ultimate performance we recommend that under Easy Connect you enable only the necessary 

connections, as every extra RAVENNA connection will use some bandwidth (Core or Network) 

� The Network must be Layer 3 compliant and must be a Gigabit network  

� Merging has certified the Dell PowerConnect 2816 Network Switch for use with Horus – Ravenna 

� RAVENNA user should avoid connecting multiple Horus to any a router/Network not certified by 

Merging. Refer to the Merging RAVENNA Network Guide for all details on the certified RAVENNA 

switch and configuration http://www.merging.com/horus/download 

� Only RAVENNA devices can be connected to the Merging PCIe Ethernet Controller Card NET-MSC-

GBEX1. Avoid mixing up non-RAVENNA device on this network, like Controllers such as 

Tango/Isis/Euphonix or other network devices. The same will apply if you are connected to the 

Dell Power Connect 2816 certified for RAVENNA network use 

� Don’t connect a 100MB Ethernet device if the switch is not multicast; otherwise the flow control 

will reduce drastically the bandwidth. 

� When configuring the VS3 Control Panel it will not be possible to choose a mode where both 

Mykerinos and RAVENNA will function at the same time. User must either work in MassCore 

Mykerinos or MassCore/RAVENNA or Native 

� A RAVENNA ASIO driver is available for Horus users that wish to use their notebook GbE Network 

RJ-45 system socket. Refer to http://www.merging.com/horus/download 

 

 

Known issues: 
� Horus RAVENNA: Switching from MADI Standard (56) to MADI Extended (64) can generate small 

glitch, avoid doing so during realtime operations 

� Be aware that non-certified RAVENNA configurations might not capable of sustaining 384 I/O @ 

1FS (44.1/48 kHz). If you experience noise similar to static reduce the RAVENNA I/O count 

enabled in the RAVENNA Easy Connect 

� Merging recommends that RAVENNA users disable the Windows Firewall, as it can partially block 

some of the RAVENNA I/O connections 

� Peaks might show up under Pyramix Core section if you power OFF or disconnect the Horus. 

Recommendation: A valid connection an online Horus is always required if the Horus is PTP 

Master. Reset peaks by Mouse Clicking on the Core section. 

� Avoid changing a network address on your system or disconnecting Ethernet ports on your system 

when MassCore RAVENNA is running 

� Cannot use the ISIS since running RAVENNA with the Merging PCIe Ethernet Controller Card  NET-

MSC-GBEX1 

Recommendation: Refer to the ISIS support document below 

http://download.merging.com/beta/SupportTools/Docs/ISIS_Vista_or_7_dedicated_lan.pdf 

� DSD issues 

� Background Recorders: If the Mixer is not a DSD compatible Mixer (square mixer), the record 

fails., but no message displayed. We recommend users to create a DSD project prior to 

enabling and starting to work with Background Recorders in DSD. 

� When creating/opening a DSD project the Horus will not switch accordingly between 

64/128/256 this has to be done manually 

� Pyramix cannot convert a DSD project to another Bit Rate. (e.g. DSD256 project cannot be 

converted to a DSD64 project).  
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Connections: 
In order to create RAVENNA I/O connections please refer to the RAVENNA Easy Connect guide 

(installed along with Pyramix) 

 

Each Horus will then appear in your RAVENNA Easy Connect utility where you will see the name of 

each Horus online. You will be able to dispatch each Horus I/O connections with the RAVENNA Easy 

Connect utility. 

 
 

Troubleshooting: 
Sudden stoppage of the RAVENNA Easy Connect: 

If the RAVENNA Easy Connect utility ends up crashing or stopping you can simply launch it back from 

the Windows Start menu under Merging Technologies>RAVENNA Easy Connect. 

 
Windows Firewall: 

The Windows Firewall can block communication between MassCore and Horus. We recommend users 

to disable the Public Network Firewall 

Procedure: 

1. Go in Windows Control Panel > Windows Firewall. 

2. Click on “Turn Windows Firewall on or off” 

3. Go to the Public Network section and select “Turn Off Windows Firewall” 

 

Windows UAC: 

User should disabled the Windows User Account Control 

Procedure: 

1. Go in Windows Control Panel\All Control Panel Items\User Accounts 

2. Open the Change User Account Setting 

3. And set it to never notify 

 

Disable Antivirus: 

Merging also recommends users to disable their Antivirus, some Antivirus as Avast or Sophos  have 

been known to block the Horus discovery and RAVENNA I/O Connections 

 

 

 


