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1.1 Introduction
The Tutorial Manual serves a special role in guiding the first time users of the SVFLUX
software through a typical example problem. The example is "typical" in the sense that it is
not too rigorous on one hand and not too simple on the other hand.

The Tutorial Manual serves as a guide by: assisting the user with the input of data necessary
to solve the boundary value problem, ii.) explaining the relevance of the solution from an
engineering standpoint, and iii.) assisting with the visualization of the computer output. An
attempt has been made to ascertain and respond to questions most likely to be asked by
first time users of SVFLUX.

1.2 Earth Dam Example
The following example will introduce some of the features included in SVFLUX and will set up
a model  of a simple earth fill  dam. The purpose of this model  is  to determine the effects  a
clay core and filter will have on the final position of the  phreatic  surface  and  to  determine
the total flux that is passing through the dam. The model dimensions and material properties
are provided below.

Project: EarthDams

Model: Earth_Fill_Dam

Minimum authorization required: FULL 

Model Description and Geometry
                    

Dam Core Filter

X Y X Y X Y

0 0 24 0 40 0

40 0 24 10 40 -0.5

52 0 28 10 52 -0.5

28 12 28 0 52 0

24 12 24 0 40 0

20 10

0 0
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Material Properties 

Silt (Dam): ks=1.0E-07 Clay (Clay Core): ks=1.0E-09

Suction (kPa) Hydraulic Suction (kPa) Hydraulic

Conductivity (m/s) Conductivity (m/s)

37.9 1.13E-08 9.8359 1.03E-09

61.76 1.77E-09 81.0514 3.87E-12

82.8 3.72E-10 98.5279 9.58E-13

100.76 8.87E-11 149.2637 9.53E-13

130.84 2.18E-11

169.07 3.92E-12

200 1.00E-12

Sand (Filter): ks=1E-04   (No unsaturated soil properties)

Silt

Suction (kPa) VWC

0.5886 0.3604

3.306 0.3672

20.01 0.2434

50.03 0.1945

90.06 0.1564

150.1 0.1537

Saturated VWC n=0.3672

Boundary Conditions

Dam Region

X Y Boundary Condition Expression

0 0 Zero Flux

40 0 Continue

52 0 Continue

28 12 Continue

24 12 Continue

20 10 Head Expression 10

Filter Region

X Y Boundary Condition Expression

40 0 Zero Flux

40 -0.5 Head Expression -0.5 m

52 -0.5 Zero Flux

52 0 Continue
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1.2.1 Model Setup
In order to set up the model  described in the preceding section, the following steps  will  be
required. The steps fall under the general categories of:

a. Create model

b. Enter geometry

c. Specify initial conditions

d. Specify boundary conditions

e. Apply material properties

f. Specify model output

g. Run model

h. Visualize results

The details of these outlined steps are detailed in the following sections.

a. Create Model
Since FULL authorization is required for this tutorial, the user must perform the following
steps to ensure full authorization is activated:

1. Plug in the USB security key,

2. Go to the File > Authorization dialog on the SVOFFICE Manager.

3. Software should display full authorization. If not, it means that the security

codes provided by SoilVision Systems at the time of purchase have not yet

been entered. Please see the the Authorization section of the SVOFFICE User's

Manual for instructions on entering these codes.

The following steps are required to create the model:

1. Open the SVOFFICE Manager dialog.

2. Select "ALL" under the Applications combo box  and  "ALL"  for  the  Model  Origin

combo box.

3. Create a new project called UserTutorial by pressing the New  button next to the

list of projects.

4. Create  a  new model  called  Earth_Fill_Dam_User  by  pressing  the  New  button

next to the list of models. The new model  will be automatically added under the

recently created UserTutorial project. Use the settings below when creating this

new model.

5. Select the following:

· 2D for System, 

· Steady-State for Type, 

· Metric for Units, and 

· Seconds (s) for Time Units.
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The user should also set the World Coordinate System to ensure that the model will fit in the
drawing space. The World Coordinate System settings can be set under the World
Coordinate System tab on the Create Model dialog.
 

1. Access the View menu and select World Coordinate System.

2. Enter the World Coordinates System coordinates shown below into the dialog.

x-minimum = -5
y-minimum = -5
x-maximum = 55
y-maximum = 40

3. Click OK to close the dialog.

The  workspace  grid  spacing  needs  to  be  set  to  aid  in  defining  region  shapes.  The  filter
portion of  the  model  has  coordinates  of  a  precision  of  0.5m.  In  order  to  effectively  draw
geometry with this precision using the mouse, the grid spacing must be set to a maximum of
0.5.

1. Select View > Options from the menu. 

2. Enter 0.5 for both the horizontal and vertical spacing.

3. Click OK to close the dialog.

b. Enter Geometry
Model geometry is defined as a series of layers and can be either drawn by the user or
defined as a set of coordinates. Model Geometry can be imported from either .DXF files or
from existing models. 

This model will be divided into three regions, which are named Dam, Core, and Filter. Each
region  will  have  one  of  the  materials  specified  as  its  material  properties.  To  add  the
necessary regions follow these steps:

1. Open  the  regions  dialog  by  selecting  Model  >  Geometry  >  Regions  from  the

menu. 

2. Change the first  region name from R1 to Dam.  To  do  this,  highlight  the  name

and type new text.

3. Press the New button to add a second region and name it Core.

4. Click New to add the third material and name it Filter.

5. Click OK to close the dialog.

The shapes that define each material region will now be created. Note that when drawing a

geometric  shape,  information  will  be  added  to  the  region  that  is  current  in  the  Region

Selector. The Region Selector is at the top of the workspace. 

· Define the Dam

1. Ensure the Dam region is current in the region selector.
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2. Select Draw > Model Geometry > Polygon Region from the menu.

3. The cursor will now be changed to cross hairs.  

4. Move the cursor near (0,0) in the drawing space.  You can view the coordinates

of the current position the mouse is at in the status bar just above the command

line.

5. When the cursor is near the point, right click.  This will cause the cursor to snap

to the point (The SNAP and GRID options in the status bar must both be on).

6. To select the point as part of the shape left click on the point.

7. Now move the cursor near (40,0).  Right click to snap  the  cursor  to  the  exact

point and then left click on the point.  A line is now drawn from (0,0) to (40,0).

8. Now move the cursor near (52,0).  Right click to snap  the  cursor  to  the  exact

point and then left click on the point.  A line is now drawn from (40,0) to (52,0).

9. Move the cursor near the point (28,12).   Right  click  to  snap  the  cursor  to  the

point.  Left click on the point and a line is now drawn from (52,0) to (28,12).

10. Move the cursor near the point (24,12) and right click snapping the cursor to the

point.  Left click on the point to draw a line from (28,12) to (24,12).

11. Move the cursor near the point (20,10) and right click snapping the cursor to the

point.  Double click on the point to finish the shape.   A line is  now drawn from

(24,12)  to  (20,10)  and  the  shape  is  automatically  finished  by  SVFLUX  by

drawing a line from (20,10) back to the start point, (0,0).  

Repeat this process to define the Core and Filter regions according to the provided at the
start of this tutorial. The geometry for the model may be obtained in the spreadsheet
located here.

N O T E :
If an error is made when entering the region geometry the user may recover from

the error and start again by one of the following methods:

a. Press the escape (esc) key.
b. Select a region shape and press the delete key.
c. Use the Undo function on the Edit menu.

If all model geometry has been entered correctly the shape should look like the diagram at
the beginning of this tutorial.

c. Specify Initial Conditions
Initial  conditions  are  generally  associated  with  transient  model  runs.  Their  purpose  is  to
provide a reasonable starting point for the solver. In a steady-state model0, initial conditions
can  be  used  to  "precondition"  the  solver  to  allow  faster  convergence.  However,  this
"preconditioning" is  unnecessary for the current model.  Therefore,  the  user  should  set  the

http://www.soilvision.com/downloads/software/demos/svflux/docs/SVFluxTutorialData02.xls
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initial conditions to "None" using the following steps:

1. Select Model > Initial Conditions > Settings...

2. Select the None option.

3. Press OK to close the dialog.

d. Specify Boundary Conditions
Boundary conditions must be applied to region points. Once a boundary condition is  applied
to a boundary point the starting  point is  defined for that particular boundary condition. The
boundary condition will then extend over subsequent line segments around the edge of the
region in the direction in which the region shape was originally entered. Boundary conditions
remain  in  effect  around  a  shape  until  re-defined.  The  user  may  not  define  two  different
boundary conditions over the same line segment.

More  information  on  boundary  conditions  can  be  found  in  Menu  System >  Model  Menu  >
Boundary Conditions > 2D Boundary Conditions in your User's Manual.

Now that all of the regions and the model geometry have been successfully defined, the next
step is  to specify the boundary conditions. A head of 10 m will be defined on the upstream
face  of  the  Dam  region  with  the  Zero  Flux  condition  being  applied  to  the  remainder.  The
Core will be set to a Zero Flux condition by default and will not need to be altered. The Filter
will have a head of –0.5m at its base.  The steps for specifying the boundary conditions are
as follows:

· Dam

1. Select the Dam region in the region selector.

2. From the menu select Model > Boundaries > Boundary Conditions. The boundary

conditions dialog will open. By default the first boundary segment will be given a

No BC condition.

3. Select the point (20,10) from the list.

4. From  the  Boundary  Condition  drop-down  select  a  Head  Expression  boundary

condition. This will cause the Expression box to be enabled.

5. In the Constant/Expression box enter a head of 10.

6. Click OK to save the input Boundary Conditions and return to the workspace.

N O T E :
The Zero Flux boundary condition for the point (0,0) becomes the boundary

condition for the following line segments that have a Continue boundary condition until
a new boundary condition is specified. In this case the line segments from (0,0) to
(52,0), (52,0) to (28,12), (28,12) to (24,12), and (24,12) to (20,10) are all given a zero
flux boundary condition. By specifying a head of 10 at point (20,10) the boundary
condition for the line segment extending from (20,10) to (0,0) is set to a head equal to
10m.

· Filter

7. Select the Filter region in the region selector.
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8. From the menu select Model > Boundaries > Boundary Conditions  to  open  the

Boundaries dialog.

9. Select the point (40,-0.5) from the list.

10. In  the  Boundary  Condition  drop-down  select  a  Head  Expression  boundary

condition.

11. Enter the value -0.5 in the Constant/Expression box.

12. Select the point (52,-0.5) from the list.

13. In the Boundary Condition drop-down select a Zero Flux boundary condition.

14. Click OK to save the input Boundary Conditions and return to the workspace.

e. Apply Material Properties
The next step in defining the model is to enter the material properties for the three materials
that will be used in the model.  A clay is  defined for the core,  the silt will make up the dam,
and the filter will consist of a sand. This section will provide instructions on creating the clay
material. Repeat the process to add the other two materials.

1. Open the Materials dialog by selecting Model > Materials > Manager from the

menu.

2. Click the New... button to create a material. 

N O T E :
When a new material is created, you can specify the display color of the material

using the Fill Color box on the Material Properties menu. Any region that has a material
assigned to it will display that material's fill color.

3. Enter Silt for the material name in the dialog that appears. 

4. Press OK to close the dialog. The Material Properties dialog will open

automatically.

5. Move to the Hydraulic Conductivity tab.

6. Enter the ksat value of 1.000E-07 m/s.

7. Press the Data button found under the Unsaturated Hydraulic Conductivity

section.

8. Enter the laboratory data points as provided in the Earth Dam Example section

at the beginning of this tutorial.

9. Click the OK button to close the Hydraulic Conductivity Data dialog.

10. Select Modified Campbell in the Unsaturated Hydraulic Conductivity drop-down.

N O T E :
To view the hydraulic conductivity curve of the laboratory data press the Graph

button.

11. Press OK to close the dialog.
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12. Repeat these steps to create the clay and sand materials using the information

provided at the beginning of the tutorial.

SWCC material properties for the Silt material must be set next. These values can be found
at the beginning of this tutorial model. Follow these steps to set up the SWCC values for the
Silt material.

1. Select the Model > Materials > Manager to open the list of current materials,

2. Select the Silt and click the Properties button,

3. Select the SWCC tab and press the Data button,

4. Enter the table of values found at the beginning of this tutorial model, 

5. Once all of the values have been entered, press OK to accept the changes,

6. Enter the Saturated VWC value 0.3672,

7. In the SWCC area, select Fredlund & Xing Fit,

8. Click the Properties button to open the Fredlund & Xing fit dialog,

9. Click  the  Apply  Fit  button  to  have the  material  parameters  estimated  by  the

Fredlund & Xing method,

10. Click the OK button on all open dialogs to accept the entered information.

Once all material properties have been entered, we must apply the materials to the
corresponding regions.

1. Open  the  Region  Properties  dialog  by  selecting  Model  >  Geometry  >  Region

Properties from the menu.

2. Select the Dam region and assign the Silt material to this region.

3. Select the Core region and assign the Core Clay material to this region.

4. Select the Filter region and assign the Sand material to this region.

5. Press the OK button to accept the changes and close the dialog.

f. Specify Model Output

Flux sections are used to report the rate of flow across a portion of the model  for a steady
state analysis, and the rate and volume of flow moving across a portion of  the  model  in  a
transient analysis. For the current model a flux section will be created at the location shown
below.

1. Select Draw > Flux Section from the menu.
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2. Move the cursor to the point (40,0) and click on it.

3. To finish the Flux Section, move the cursor to the point (40,6) and double-click

on it. A blue line with an arrow on the end should be drawn across the dam.

4. Select Model > Reporting > Flux Sections from the menu. The Flux Section List

dialog will open.

5. Select Flux 1 from the list.

6. Click Properties  to open the Flux Section Properties dialog. This dialog displays

the properties of the current flux section which the user can update manually as

well as graphically. Press the OK buttons on the remaining dialogs.

7. Open the Plot Properties dialog by selecting Model > Reporting > Plot  Manager.

Select the Flux Sections tab. All available flux section reports will be presented

in  the  list  box.  Several  methods  (x,  y,  normal)  of  reporting  the  flux  will  be

present.  Click on the uppermost report (Variable is  "Flux") in  the  list  box,  and

click Properties.  Click Dam from the Restrict to Region drop-down.

8. Press OK to close the dialog.

9. Close the Plot Manager dialog.

10. Notice that the flux section label, 'Flux 1', is  partially  on the region boundary in

the workspace. To move the label location, select the textbox in the workspace

and drag it to the desired location.

N O T E :
Flux Section labels can be formatted in the same manner as regular textboxes.

Two levels of output may be specified: i) output (graphs,  contour  plots,  fluxes,  etc.)  which
are  displayed  during  model  solution,  and  ii)  output  which  is  written  to  a  standard  finite
element  file  for  viewing  with  AcuMesh  software.  Output  is  specified  in  the  following  two
dialogs in the software:

i)  Plot Manager: Output displayed during model solution.
ii) Output Manager: Standard finite element files written out for visualization in AcuMesh

or for initial condition input to other finite element packages.

PLOT MANAGER
The plot manager dialog is  first  opened to display appropriate solver graphs.  There are
many plot types that can be specified to visualize the results of the model.  A few will be
generated  for  this  tutorial  example  model,  including  a  plot  of  the  solution  mesh,
pressure contours, head contours, and gradient vectors.

1. Open the Plot  Manager  dialog  by  selecting  Model  >  Reporting  >  Plot  Manager

from the menu.
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2. The toolbar at the bottom left of the dialog contains a button for each plot type.

Click  on  the  Contour  button  to  begin  adding  the  first  contour  plot.  The  Plot

Properties dialog will open.

3. Enter the title 'Pressure'.

4. Select 'u' as the variable to plot from the drop-down.

5. Click OK to close the dialog and add the plot to the list.

6. Repeat steps 2 to 5 to create the plots shown in the above dialog. 

7. Click OK to close the Plot Manager and return to the workspace.

Alternatively,  the user may press the Add Default  Plots button and  typical  plots  will  be
added to the plot list.

OUTPUT FILES

1. Open  the  Output  Manager  dialog  by  selecting  Model  >  Reporting  >  Output

Manager from the menu.

2. The toolbar at the bottom left  corner  of  the  dialog  contains  a  button  for  each

output file type. Click on the ACUMESH  button  to  begin  adding  the  output  file.

The Output File Properties dialog will open.

3. Click OK to close the dialog and add the output file to the list.

4. Click OK to close the Output Manager and return to the workspace.

g. Run Model 
The next step is to analyze the model. Select Solve > Analyze from the menu. This action
will write the descriptor file and open the FlexPDE solver. The solver will automatically begin
solving the model.

After the model  has finished solving,  the results will be displayed in the dialog of thumbnail
plots within the FlexPDE solver. Right-click the mouse and select Maximize to enlarge any of
the thumbnail plots. This section will give a brief analysis for each plot that was generated.

These reports are intended to provide the user with low-quality graphs which  give  a  rough
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indication  of  the  results.  Creating  professional-quality  visualizations  of  the  results  can  be
accomplished with ACUMESH software, the use of which is described below.

The Flux through the model  is  displayed in the dialog of report showing a breakdown of the
X, Y, and Normal components of flow through the model.

FlexPDE will report the Flow information. For this model it is as follows:

X Component of Flow in (m^3/s)= 1.399 e-7
Y Component of Flow in (m^3/s)= 0.00
Normal Flow in (m^3/s)= 1.399 e-7

h. Visualize Results
The visual results for the current model may be examined by selecting the View > ACUMESH
menu option.

1.2.2 Results & Discussion
The following plots are typically desired for a seepage analysis. Each plot, as well as a brief
description, is displayed below.

· Solution Mesh
Once you have analyzed the model, the default display in ACUMESH displays the finite
element mesh used to obtain the solution.

The Mesh plot displays the finite-element mesh generated by the solver. The mesh is
automatically refined in critical areas such as the Dam – Filter contact where there is a
significant change in hydraulic conductivity.

The uncolored mesh should now be displayed in ACUMESH. In order to display contours of
pressure head the user must:

1. Select Plot > Contours from the menu.

2. Under the Regions tab, choose Select All.

3. Select 'u' as the Variable Name.

4. Press OK to close the dialog.

· Pressure Contours



SVFlux Tutorial Manual 18 38of

The most important contour in the above plot is the one that corresponds to zero
pressure. This contour represents the phreatic surface. All material that lies below this
line is saturated and all material that lies above this line is considered to be unsaturated.
The above design would be acceptable as the water table exits the dam at the beginning
of the filter. If the water table had extended to the toe of the dam, there would be
concern that the toe of the dam would become unstable due to piping failure.

The mesh can be turned off for certain regions through the following process:

1. Select Plot > Mesh from the menu.

2. Select 'Core' in the list and uncheck the checkbox.

3. Press OK to close the dialog.

· Flow Vectors
Flow vectors can be displayed through the following process:

1. Select Plot > Vectors from the menu.

2. Select Dam in the list and ensure the checkbox is checked.

3. Press OK to close the dialog.

Flow Vectors show both the direction and the magnitude of the flow at specific points in
the model. The low conductivity of the core causes the majority of the flow to go up and
over the core causing increased gradients in this area. The other area of interest is at
the filter. Vectors illustrate that flow is exiting the dam in this region.

· Head Contours
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As expected, most of the head is dissipated in the core of the dam. This is illustrated in
by how close the contours are in the core. The maximum head in the model occurs on
the upstream face of the dam and is equal to ten. This is expected, as this was the
boundary condition set on the upstream face of the dam. The lowest head occurs at the
filter and is equal to –0.5m.

The current visualization can be exported on a standardized format through the following
steps:

1. Select File > Export As from the menu.

2. Specify a file name.

3. Specify a file type.

1.3 2D Stochastic Example
A single run of a numerical model  is  often not sufficient.  SVFLUX  implements  the  ability  to
incorporate statistical uncertainty  into the input  of  material  properties.  This  tutorial  section
guides the user through the setup and execution of a model  implementing the stochastic or
statistical features available in SVFLUX. 

The earth dam example presented in Section 1 is  extended to incorporate a variation in the
slope of the  unsaturated portion  of  the  hydraulic  conductivity  curve.  The  current  example
makes  use  of  the  Modified  Campbell  method  of  estimating  the  unsaturated  hydraulic
conductivity. The slope of the unsaturated portion is  controlled by a “p”  parameter. Instead
of  specifying  a  single  value  for  this  parameter  a  Monte  Carlo  analysis  will  be  used  to
generate 50 runs of the  same model  varying  the  “p”  parameter  of  the  Modified  Campbell
estimation method.

Why do we want to do this? In this example we want to determine the influence of the slope
of the unsaturated hydraulic conductivity curve on the difference in flow through the core or
over the top of core. The unsaturated hydraulic conductivity curve is often not measured and
it is  useful to determine the sensitivity  of flow through various portions  of  the  dam  on  this
curve.

The final model is presented in the VerifySVFlux project, called EarthFillDamSto model.

Project: EarthDams
Model: Earth_Fill_Dam_Sto
Minimum authorization required: FULL 
   



SVFlux Tutorial Manual 20 38of

1.3.1 Model Setup
In order to set up the model  described in the preceding section, the following steps  will  be
required. The steps fall under the general categories of:

a. Create model

b. Specify sensitivity material properties

c. Specify model output

d. Run model

e. Visualize results

a. Create Model
Since FULL authorization is required for this tutorial, the user must perform the following
steps to ensure full authorization is activated:

1. Plug in the USB security key,

2. Go to the File > Authorization dialog on the SVOFFICE Manager.

3. Software should display full authorization. If not, it means that the security

codes provided by SoilVision Systems at the time of purchase have not yet

been entered. Please see the the Authorization section of the SVOFFICE User's

Manual for instructions on entering these codes.

In order to create the stochastic model,  save a copy  of  the  2D example  model  created  in
section 1. This is accomplished through the following steps:

1. Select the Tutorial project and Open the Earth_Fill_Dam model.

2. Select File > Save Model As.

3. Type the name User_EarthFillDamSto and click OK.

Now a new model  has been created and loaded into the workspace that will be modified to
include stochastic analysis.
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The second step is to describe the number of stages/runs that will be used in the analysis. A
series of  50  model  runs  will  be  performed  using  the  Monte  Carlo  analysis  technique.  The
user must first set the number of model stages to 50 by following these steps:

1. Open the Model > FEM Options dialog. 

2. Open the Advanced section of the FEM Options dialog. 

3. STAGES field should be set to 50 under the Stage Settings area of the dialog. 

4. Click OK to close the dialog and accept the changes.

b. Specify Sensitivity Material Properties
The next step that must occur is that the Modified Campbell “p” parameter will be staged. In
this example the parameter will be set to have a mean value of 5 and a standard deviation
of 2. This staging is accomplished through the following process:

1. Select Model > Materials > Manager to open the list of current materials,

2. Select the Silt material and click the Properties button,

3. Click the Stage Parameters button located in the lower left of the dialog,

4. Select the Mcampbell p parameter and click the Include button,

5. Select the Mcampbell p parameter again,

6. Click  the  Properties  button  and  select  Equation  option  from  the  Curve  Type

drop-down.

7. Press OK to close the Modified Campbell Estimation dialog,

8. Click the Stage Values button,

9. Click the Stage Distribution button,

10. Select Monte Carlo Normal as the distribution method,

11. Enter a mean of 5 and a standard deviation of 2 and click the OK button,

12. A list of 50 generated values should now be displayed in the list box.

13. Press OK on all remaining forms to close them.

The parameter has now been staged.

c. Specify Model Output
Two levels of output may be specified: i) output (graphs,  contour  plots,  fluxes,  etc.)  which
are  displayed  during  model  solution,  and  ii)  output  which  is  written  to  a  standard  finite
element  file  for  viewing  with  AcuMesh  software.  Output  is  specified  in  the  following  two
dialogs in the software:

i)  Plot Manager: Output displayed during model solution.
ii) Output Manager: Standard finite element files written out for visualization in AcuMesh

or for inputting to other finite element packages.

PLOT MANAGER
The plot manager dialog is first opened to display appropriate solver graphs. There are
many plot types that can be specified to visualize the results of the model. The user may
press the Add Default Plots button to add typical plots. Define the plots shown in the
below screenshot.
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Specify the following Zoom settings for the pressure zoomed contour plot:

X: 24.73
Y: 8.974
w: 4.936
h: 4.026

Specify the following Zoom settings for the kx zoomed contour plot:

X: 25.06
Y: 9.211
w: 4.278
h: 3.671

OUTPUT FILES
There are four output file types that can be specified to export the results of the model.
Two will be generated for this tutorial example model: a transfer file of heads, and a plot
to  transfer  the  results  to  ACUMESH.  A  default  ACUMESH  file  will  be  created  for  tis
example. The default file may be created by pressing the ACUEMSH button.

1. Open  the  Output  Manager  dialog  by  selecting  Model  >  Reporting  >  Output

Manager from the menu.

2. The toolbar at the bottom left  corner  of  the  dialog  contains  a  button  for  each

output file type. Click on the ACUMESH  button  to  begin  adding  the  output  file.

The Output File Properties dialog will open.

3. Enter the File Name ACUMESH.

4. Click the Output Options tab. Ensure that the Write File checkbox is selected.

5. Click OK to close the dialog and add the output file to the list.

6. Click  the  Settings  button  on  the  Output  Manager  dialog  to  open  the  Output

Settings dialog.

7. Ensure  the  Region  Separation  checkbox  is  checked;  press  OK  to  close  the

dialog. 
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8. Click OK to close the Output Manager and return to the workspace.

Since we are trying to determine  the  amount  of  flow through  different  portions  of  the
dam we will place flux sections at the right hand side of the dam core in addition to the
flux section already present near the filter.

The flux sections should have the following coordinates: Flux 2 (28,0) to (28,10), Flux 3
(28,10) to (28,12).

The flux sections may be drawn graphically or entered through the Model > Reporting >
Flux  Sections  menu  option.  Refer  to  Specifying  a  Flux  Section  in  this  manual  for
instructions on adding Flux Sections.

Each flux section must have their flows restricted to the Dam region. In order to do this,
complete the following steps:

1. Select Model > Reporting > Plot Manager from the menu.

2. Select the Boundary Flux tab.

3. Select FS: Flux 1 report plot and click Properties.

4. Select the Dam region in the Restrict to Region drop-down.

5. Repeat steps 3 and 4 for all Flux 1 history plots.

6. Click OK to close the Plot Manager and accept the above changes.

d. Run Model 
The next step is to analyze the model. Select Solve > Analyze from the menu. This action
will write the descriptor file and open the FlexPDE solver. The solver will automatically begin
solving the model.

e. Visualize Results
The visual results for the current model may be examined by selecting the  View > ACUMESH

menu option. The user may also view the results by pressing the ACUMESH icon  on the

process toolbar.

1.3.2 Results & Discussion
Selecting  Solve > Analyze  from the  menu  will  initiate  model  solution.  Attention  should  be
directed to the stage display in the finite element solver. Once a particular stage is  complete
the next stage will automatically be initiated.  The various flows through differing portions of
the earth dam may be seen in the output of the flux section history plots for flux sections 2
and 3.
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From these history plots it can be seen that the model  is  quite sensitive to the slope of the
unsaturated hydraulic conductivity curve.

In order to view the history graph on the Flux 3 Flux section in ACUMESH, follow these
instructions:

1. Select the Plot Manager Graphs dialog by selecting Graphs > Plot Manager.

2. Once this dialog opens, select the Flux Section tab and choose the Flux 3 history

plot.

3. The  graph  shown  above  should  now  appear.  You  can  format  the  axis  display

settings by choosing the Properties button, . Options on the scale,  labels,  and

gridlines are available for users to change the graph display to their liking.

1.4 3D Reservoir
The following example will introduce you to the three-dimensional SVFLUX modeling
environment. This example is used to investigate the flow and pressure conditions existing
within a slope due to a holding pond at the crest. The example is modeled using two regions,
two surfaces, and one material. The model data and material properties are provided below.

The purpose of this model is to determine the flow out of the reservoir.

Project: Ponds   
Model: Reservoir3D
Minimum authorization required: STUDENT 

Model Description and Geometry

A small holding pond of dimensions 27m wide and 24m long is created the top of the slope.
A slope of angle 45° begins 10m from the edge of the holding pond. The slope has a total
height of 11m and levels off for a distance of 3m.
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Material Properties
Tutorial Material - Reservoir3D: ksat = 2.512E-06 kPa

1.4.1 Model Setup
In order to set up the model  described in the preceding section, the following steps  will  be
required. The steps fall under the general categories of:

a. Create model

b. Enter geometry

c. Specify boundary conditions

d. Apply material properties

e. Specify model output

f. Run model

g. Visualize results

a. Create Model
The first step in defining a model  is  to decide the project under which the model  is  going to
be organized. If the project is  not yet included you must add the project before proceeding
with the model. In this case, the model is placed under a project called Tutorial. 

In order to add this project follow these steps:

1. Access  the  SVOFFICE  Manager  dialog.  If  a  project  named  Tutorial  already

exists, skip to the next section.

2. Click New in the upper right of the Projects section.   

3. The Create New Project dialog is  opened along with a prompt asking for a new
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Project Name.

4. Type UserTutorial as the new Project Name and press OK.

The Project Properties dialog is where information specific to each project is  stored. This will
include the Project Name, Project Folder, and Project Notes information.   

N O T E :
The Project Name is the only required information needed to define a project. The

rest of the fields are optional.

The dialog is opened ready to accept information.

It should be noted that once the project is defined it will be identified by the Project Name
throughout the rest of the program. Also, SVFLUX does not allow you to specify two projects
with the same Project Name. 

5. Fill out the dialog with the desired information.

6. To exit this dialog and return to  the  SVOFFICE Manager,  click  OK.  The  project

information is automatically saved upon entry.

If  the  project  is  not  yet  included,  you  must  add  the  project  before  proceeding  with  the
model, as detailed in the previous section.

When the SVOFFICE Manager dialog is  opened there will be a list of the projects that  have
been defined. To add a model to the UserTutorial project follow these steps:

1. Select the UserTutorial project from the Project Name list.

2. Press the New button under the 'Models' heading.

3. Enter User_Reservoir 3D in the Model Name box. 

4. Select SVFLUX as the Application.

5. Select  3D for System, Steady-State  for Type,  Metric for Units, and  Seconds  for

Time Units.

6. Click the OK button to save the model and close the New Model dialog.

7. The new model will automatically be opened in the workspace. 

The workspace grid spacing needs to be set to aid in defining region shapes. The geometry
data for this model has coordinates of a precision of 1m. In order to effectively draw
geometry with this precision using the mouse, the grid spacing must be set to a maximum of
1.

1. Select View > Options from the menu.

2. Enter 1 for both the horizontal and vertical spacing.

3. Click OK to close the dialog.

 

b. Enter Geometry
A  region  in  SVFLUX  is  the  basic  building  block  for  a  model.  A  region  represents  both  a
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physical  portion  of  material  being  modeled  and  a  visualization  area  in  the  SVFLUX  CAD
workspace. A region will have a set of geometric shapes that define its material boundaries.
Also, other modeling objects including features, flux sections, water tables, text,  and line art
can be defined on any given region.

This model  will be divided into two regions, which are named Slope and  Reservoir.  To  add
the necessary regions follow these steps:

1. Open  the  regions  dialog  by  selecting  Model  >  Geometry  >  Regions  from  the

menu.

2. Change the first  region name from R1  to Slope. To do this, highlight the  name

and type the new text.

3. Press the New button to add a second region.

4. Change the name of the second region to Reservoir.

5. Click OK to close the dialog.

The shapes that define each region will now be created. Note that when  drawing  geometry
shapes, the region that is  current in the Region Selector is  the  region the geometry will  be

added to. The Region Selector is at the top of the workspace. Refer to the 3D Example Model

Data section for the geometry points for each region.

· Define the Slope region

1. Select Slope in the Region Selector, found at the top of the workspace.

2. Select Draw > Model Geometry > Region Polygon from the menu.

3. Move the cursor near (0,0) in the drawing space. You can view the coordinates

of  the mouse's current position in the status bar just below the drawing space.

The SNAP and GRID options in the status bar must  both be On; OSNAP should

be Off.

4. To select the point as part of the shape left click on the point.

5. Now move the cursor near (14,0) and left click on the point. A line is  now drawn

from (0,0) to (14,0).

6. Repeat the process for the following coordinates: (24,0), (24,27), and (14,27).

7. For  the  final  point,  (0,27),  double-click  on  the  point  to  finish  the  shape.  The

shape is automatically finished by SVFLUX by drawing a line from (0,27) back to

the start point, (0,0). 

If the Main geometry has been entered correctly, the shape should be similar to the
following:
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N O T E :
If a mistake was made entering the coordinate points for a shape, edit the shape

using the Region Properties dialog (menu item Model > Geometry > Region Properties).

· Define the Reservoir

8. Select Reservoir in the Region Selector.

9. Select Draw > Model Geometry > Region Polygon from the menu.

10. Move the cursor near (0,10) in the drawing space. You can view the coordinates

of the current position the mouse is at in the status bar just below the drawing

space.

11. When the cursor is near the point, click the left mouse button. The cursor should

automatically snap to the point (0,10) as long as the cursor is close to the point,

the SNAP and GRID options in the status bar are both on, and the OSNAP option

is off.

12. Now move the cursor near (3,10). Left click on the point. A line is now drawn

from (0,10) to (3,10).

13. Repeat this process for the coordinate (3,17). If a mistake is made simply press

the delete key on the keyboard and start over.

14. For the final point, (0,17), double-click on the point to finish the shape. A line is
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now drawn from (3,17) to (0,17) and the shape is automatically finished by

SVFLUX by drawing a line from (0,17) back to the start point, (0,10).

N O T E :
At times it may be tricky to snap to a grid point that is near a line defined for a

region. Turn the object snap off by clicking on “OSNAP” in the status bar to alleviate this
problem.

This model consists of two surfaces and each will be defined by a different method. By
default every model initially has two surfaces. 

· Define Surface 1
This surface will be defined by providing a constant elevation.

1. Select Surface 1 in the Surface Selector found at the top of the workspace.

2. Select  Model  >  Geometry  >  Surface  Properties  from  the  menu  to  open  the

Surface Properties dialog.

3. For the  Surface  Definition  Option,  select  Expression  (Relative)  from  the  drop-

down.

4. Click on the Expression tab.

5. Enter a Surface Expression of 0.

6. Click OK to close the dialog.

· Define Surface 2
This  surface  will  be  defined  by  providing  a  grid  of  (X,Y)  points  and  corresponding
elevations.

7. Select Surface 2 in the Surface Selector.

8. Go to Model > Geometry >  Surface Properties  in the menu to open the Surface

Properties dialog.

9. Select  Elevations  Data  from  the  Definition  Options  drop-down  and  click  the

Define Grid button to set up the grid for the selected surface.

10. Click the Add Irregular button to open the Add Irregular X Gridlines dialog.

11. Enter 0, 2, 3, 14, 21, and 24.

12. Click OK to add the gridlines and close the dialog.

13. Select 10 from the list.

14. Press Delete; then click Yes to confirm the deletion.

15. Move to the Y Grid Lines tab and click the Add Irregular  button to open the Add

Irregular Y Gridlines dialog.

16. Enter 0, 10, 11, 16, 17, and 27.

17. Click OK to add the gridlines and close the dialog.

18. Press OK to close the  Define  Grid  dialog.  Leave  the  Surface  Properties  dialog

open.
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N O T E :
You can import XYZ data, paste surface data, or paste surface grid data in this

menu for faster data entry.

Now that the grid has been set up, elevations must be specified for all the grid points:

1. Select Elevation Data from the Surface Definition Options drop-down in the

Surface Properties dialog.

2. Enter the missing Z elevations as provided in the 3D Example Model Data section

at the end of this tutorial.

3. Press OK to close the dialog.

The grid for surface 2 can be made viewable in the workspace.

19. Select Model > Geometry > Surfaces from the menu.

20. Click the Grid check box for Surface 2. A check mark should appear in the box.

21. Click the Grid check box for Surface 1. The check mark should disappear.

22. Press OK to close the dialog.

c. Specify Initial Conditions
Initial conditions are generally associated with transient model runs. Their purpose is to
provide a reasonable starting point for the solver. In a steady-state model (such as the
model at hand), initial conditions can be used to "precondition" the solver to allow faster
convergence. However, this "preconditioning" is unnecessary for the current model.
Therefore, the user should set the initial conditions to "None" using the following steps.

1. Select Model > Initial Conditions > Settings...

2. Select the None option.

3. Press OK to close the dialog.

d. Specify Boundary Conditions
Boundary conditions must be applied to region points. Once a boundary condition is  applied
to a boundary point the starting  point is  defined for that particular boundary condition. The
boundary condition will then extend over subsequent line segments around the edge of the
region in the direction in which the region shape was originally entered. Boundary conditions
remain  in  effect  around  a  shape  until  re-defined.  The  user  cannot  define  two  different
boundary conditions over the same line segment.

More information on boundary conditions can be found in the Menu System > Model Menu >
Boundary Conditions > 2D Boundary Conditions in your User's Manual.

Now that all of the regions, surfaces, and materials have been successfully defined,  the next
step is  to specify the boundary conditions on the region shapes. A number of heads will be
defined  on  the  Slope region  segments,  with  the  Zero  Flux  condition  being  applied  to  the
remainder.  The  Reservoir  will  be  set  to  have a  head  of  10.5m  as  a  Surface  2  boundary
condition. The steps for specifying the boundary conditions include:
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1. Make sure your model is being viewed in 2D. To do this, click on the 2D button

found to the left side of the workspace.

2. Select Slope in the Region Selector.

3. Select Surface 1 in the Surface Selector, found at the top of the workspace.

4. From the menu select Model > Boundaries > Boundary Conditions. The boundary

conditions dialog will open  and  display  the  boundary  conditions  for  Surface  1.

These boundary conditions will extend from Surface 1 to Surface 2 over  Layer

1. Select  the Segment  Boundary  Conditions  tab.  By  default  the  first  boundary

segment will be given a Zero Flux condition.

5. Select the point (14,0) from the list.

6. From  the  Boundary  Condition  drop-down  select  a  Head  Expression  boundary

condition. This will cause the Constant/Expression box to be enabled.

7. In the Constant/Expression box enter a head of 7.

8. Select the point (14,27) from the list.

9. From the Boundary Condition drop-down select a Zero Flux boundary condition. 

10. Press the OK button to close the dialog.

Slope Region Boundary Condition Summary

X Y Boundary Condition Expression

0 0 Zero Flux

14 0 Head Expression 7

24 0 Continue

24 27 Continue

14 27 Zero Flux

0 27 Continue

N O T E :
The Head Expression boundary condition for the point (14,0) becomes the

boundary condition for the following line segments that have a Continue boundary
condition until a new boundary condition is specified.  In this case the line segments
from (14,0) to (14,27) are all given a Head Expression boundary condition. 

In order to set the Reservoir’s Surface 2 Boundary Condition to 10.5:

1. Select the “Reservoir” region in the Region Selector.

2. From the menu select Model > Boundaries > Boundary Conditions.

3. Select Surface 2 from the surface drop-down.

4. Click the Surface Boundary Conditions tab.

5. Select the Head Expression boundary condition, and enter a value of 10.5 in the
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Constant/Expression box.

6. Press the OK button to close the dialog.

e. Apply Material Properties
The next step in defining the model is to enter the material property for the material that will
be used in the model. It will be defined for both the slope and reservoir regions.

1. Open the Materials Manager dialog by selecting Model > Materials > Manager

from the menu.

2. Click the New button to create a material.

3. Enter Tutorial Soil  into the Material Name field. 

4. Press OK to close the dialog. The Material Properties dialog will open

automatically.

N O T E :
When a new material is created, you can specify the display color of the material

using the Fill Color box on the Material Properties menu. Any region that has a material

assigned to it will display that material's fill color.

5. Move to the Hydraulic Conductivity tab.

6. Enter the ksat value of 2.512E-06 m/s.

7. Select None from the Unsaturated Hydraulic Conductivity option group.

8. Press OK on both dialogs to return to the workspace.

Each region will cut through all  the layers in a model,  creating  a  separate  “block”  on  each
layer. Each block can be assigned a material or be left as void. A void area is  essentially air
space. In this model all blocks will be assigned a material.

1. Select Slope in the Region Selector.

2. Select Model > Materials > Region Materials  from the menu to open the Region

Materials dialog.

3. Select the Tutorial Material from the drop-down for Layer 1. 

4. Press OK to close the dialog.

5. Select Reservoir in the Region Selector.

6. Select Model > Materials > Region Materials  from the menu to open the Region

Materials dialog.

7. Select the Tutorial Soil material from the drop-down for Layer 1.

8. Close the dialog using the OK button.

f. Specify Model Output
Two levels of output may be specified: i) output (graphs,  contour  plots,  fluxes,  etc.)  which
are  displayed  during  model  solution,  and  ii)  output  which  is  written  to  a  standard  finite
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element  file  for  viewing  with  AcuMesh  software.  Output  is  specified  in  the  following  two
dialogs in the software:

i)  Plot Manager: Output displayed during model solution.
ii) Output Manager: Standard finite element files written out for visualization in AcuMesh

or for inputting to other finite element packages.

PLOT MANAGER
Now that the model is defined, it is necessary to specify the reports which will be created
by the solver such that the desired output from the model can be seen.

There are many plot types that can be specified to visualize the results of the model.  A
few will be  generated  for  this  tutorial  example  model  including  a  plot  of  the  pressure
contours, head contours, solution mesh, and gradient vectors.

1. Open the Plot  Manager  dialog  by  selecting  Model  >  Reporting  >  Plot  Manager

from the menu.

2. The toolbar at the bottom left  corner  of  the  dialog  contains  a  button  for  each

plot type. Click on the Contour button to begin adding the first  contour plot. The

Plot Properties dialog will open.

3. Enter the title pwp.

4. Select u as the variable to plot from the drop-down.

5. Move to the Projection tab.

6. Select Plane as the Projection Option.

7. Select Y from the Coordinate Direction drop-down.

8. Enter 13  in  the  Coordinate  field.  This  will  generate  a  2D slice  at  Y  =  13m  on

which the pore water pressures will be plotted.

9. Move to the Output Options tab. 

10. Select the PLOT output option. 

11. Click OK to close the Plot Properties dialog and add the plot to the list. The Plot

Manager dialog can remain open.
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12. Repeat  steps  2  to  11  to  create  the  plots  as  shown  in  the  screen  shot  above.

Note that the Vector and Mesh plots do not require the entry of a variable. 

13. Click OK to close the Plot Manager and return to the workspace.
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OUTPUT MANAGER

1. Open  the  Output  Manager  dialog  by  selecting  Model  >  Reporting  >  Output

Manager from the menu.

2. The toolbar at the bottom left  corner  of  the  dialog  contains  a  button  for  each

output file type. Click on the ACUMESH  button  to  begin  adding  the  output  file.

The Output File Properties dialog will open.

3. Click OK to close the dialog and add the output file to the list.

4. Click OK to close the Output Manager and return to the workspace.

Features  are  used  in  this  model  to  control  mesh  density  for  increased  resolution  at
selected slices.

To add the features:

1. Select the Reservoir region in the region selector.

2. Select Draw > Model Geometry > Feature Polyline from the menu.

3. With the mouse click  on the point (0,11). (The SNAP and GRID options must be

on in the workspace.)

4. Click on the point (2,11). 

5. Click on the point (2,16).

6. Double-click on the point (0,16) to finish the Feature.

g. Run Model 
The next step is to analyze the model. Select Solve > Analyze from the menu. This action
will write the descriptor file and open the FlexPDE solver. The solver will automatically begin
solving the model.

h. Visualize Results
The visual results for the current model may be examined by selecting the View > ACUMESH
menu option.

1.4.2 Results & Discussion
After the model  has finished solving,  the results will be displayed in the dialog of thumbnail
plots within the FlexPDE solver. Right-click the mouse and select Maximize to enlarge any of
the thumbnail plots. This section will give a brief analysis for each plot that was generated.

These reports are intended to provide the user with low-quality graphs which  give  a  rough
indication  of  the  results.  Creating  professional-quality  visualizations  of  the  results  can  be
accomplished with ACUMESH software, the use of which is described in the following section.

· Solution Mesh
The Mesh plot displays the  finite-element  mesh  generated  by  the  solver.  The  mesh  is
automatically refined in critical areas. Right-click on the plot and select Rotate to enable
the rotate window.
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· Pressure Contours
The  most  important  contour  in  the  above  plot  is  the  one  that  corresponds  to  zero
pressure. This contour represents  the phreatic  surface. All material that  lies  below  this
line is saturated and all material that lies above this line is considered to be unsaturated.
The plot indicates a gradual decrease in water pressure from the left  to the right in the
plot.
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· Head Contours
As expected, the head is 10.5m at the left of the plot where this condition was specified
as a boundary condition. The head decreases to 7m on the left edge of the plot where
the boundary condition was set to 7m.

· Flow Vectors
Flow Vectors show both the direction and the magnitude of the flow at specific points in
the model. Vectors illustrate that flow is from left to right in this view.

Once the model has been analyzed with the FlexPDE solver, it can be visualized using the
ACUMESH software. ACUMESH will read a .DAT file, which can be defined in the Output
Manager as described in previous sections of this tutorial. Once the .DAT file has been
created the model can be visualized utilizing the following steps:

1. Select the Results > ACUMESH menu item. 

2. The user will be asked to specify the .DAT file to read, as shown below.

3. Select the Res3DOut file and click Open.

The uncolored mesh should now be displayed in ACUMESH. In order to display contours of
pressure head the user must:

1. Select Plot > Contours from the menu.

2. Under the Regions tab, choose Select All.

3. Select 'u' as the Variable Name.

4. Press OK to close the dialog.

The mesh can be turned off for certain regions through the following process:

1. Select Plot > Mesh from the menu.

2. Select 'Core' in the list and uncheck the checkbox.

3. Press OK to close the dialog.

Flow vectors can be displayed through the following process:

1. Select Plot > Vectors from the menu.

2. Select Dam in the list and ensure the checkbox is checked.

3. Press OK to close the dialog.

The current visualization can be exported on a standardized format through the following
steps:

1. Select File > Export As from the menu.

2. Select a file name.

3. Specify a file type.
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1.4.3 Model Data
Surface Data for Tutorial – Reservoir3D:

Surface 2
X Y Z

0 0 11

0 10 11

0 11 10

0 16 10

0 17 11

0 27 11

2 0 11

2 10 11

2 11 10

2 16 10

2 17 11

2 27 11

3 0 11

3 10 11

3 11 11

3 16 11

3 17 11

3 27 11

14 0 11

14 10 11

14 11 11

14 16 11

14 17 11

14 27 11

21 0 4

21 10 4

21 11 4

21 16 4

21 17 4

21 27 4

24 0 4

24 10 4

24 11 4

24 16 4

24 17 4

24 27 4

Region shape data for Tutorial – Reservoir3D:
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Slope Region   Reservoir Region

X Y X Y

0 0 0 10

14 0 3 10

24 0 3 17

24 27 0 17

14 27

0 27
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