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Day 2 
 
First we will go through a demonstration of how to use Zonae Cogito to run Marxan 
and view the outputs. After the demonstration, you will work through the exercises 
below on your own. 
 
What is Zonae Cogito?  
Zonae Cogito (ZC) is software designed as a decision support system and database 
management system to supplement the Marxan software. It incorporates open-source 
GIS software components, and is a freely available software package.   
 
What can you do with ZC? 

• Edit Marxan parameters and input files. 
• Run Marxan analyses. 
• Interactively view the results of Marxan analyses 
• Interactively make changes to Marxan solutions 
• Calibrate Marxan parameters 
• Run the full range of Marxan software (including Marxan, Marxan with 

Zones, Threat Probability, and cluster analysis of Marxan solutions).  
• Use as the GIS for the C-Plan Conservation Planning System.  

 
See the ZC user manual for details (located in c:\MarxanIntroCourse\documents).  
 
Creating a backup database 
 
Before creating a new ZC project it is good practice to create a back up copy of all of 
your work.  This way if something happens or you make changes you want to roll 
back you’ll have a clean copy.   
 
v In the MarxanIntroCourse folder, create a new folder and name it backup.   
v Copy the entire contents of the Marxan_database folder into the backup folder.  
 
Creating a new ZC project 
 
Start Zonae Cogito (ZC) from the windows menu system like this: 
 
v Create a new folder in the MarxanIntroCourse folder. Name it “exercise1”. 
v Copy the entire contents of the MarxanDatabase folder into the exercise1 folder 
v Start > All Programs > Zonae Cogito > Zonae Cogito 
v If Zonae Cogito is not in the start menu. Browse to “C:\Program Files\Zonae 

Cogito” and double click on ZonaeCogito.exe to launch the software. 
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v From the ZC main menu select File  >  New Project to create a new ZC project.  

 
 
 
v Give your project a name e.g. “TestRun1” 

 
For now it is alright to use any name, but when you begin to develop more complex 
scenarios it is important to develop a naming convention that allows you to easily 
identify the scenario.  If you have many different scenarios, it is also good to keep a 
master list indicating the costs, targets, and other parameters for each scenario. 
 
v Tick the box next to “Include Marxan Database” and then use the browse button 

to navigate to and select the input.dat file in  
C:\MarxanIntroCourse\exercise1\MarxanDatabase\ 

 
We will not be including a c-plan project in our initial database.  
 
v Use the browse button next  to the “Locate GIS Layers for Display” window to 

navigate to the pulayer folder, and select the pulayer_tas.shp 
 

v Confirm that the pulayer_tas.shp is the file listed in the “Select Planning Unit 
Shapefile” drop down. 

 
v Select “PUID” from the drop down menu next to “Select Planning Unit Key 

Field”  
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v Click OK to generate the new ZC project. 
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Resizing the ZC windows 
 
When you first open ZC, you will see two windows, the GIS display window and the 
Marxan window.  You might also notice that ZC does not fill your entire desktop.  
 
v To resize ZC, double click on the maximize window  
v After maximizing, from the ZC menu select Window > Arrange side by side 
v You can also choose "Arrange top to bottom" instead if you need to 
 
 
You will probably also have noticed the GIS window in ZC is currently blank.  
Whenever you create a new project, the GIS window will appear blank until you have 
run Marxan for the first time.  At this point it is also a good idea to save the Marxan 
project you have just created.  
 
Saving a ZC project 
 
v To save the project, select File > Save from the main ZC menu.   
 
You will notice that whenever you create a new ZC project it will create a file 
projectx.zcp inside the MarxanDatabase folder.  This file can also be used to reopen a 
scenario, but it is best if you save the scenario with a name that reminds you what the 
scenario is.   After saving the scenario we are ready to run Marxan from ZC. 
 
Running Marxan 
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v To run Marxan, click “Run” in the Marxan Box  
 
After clicking run, you should see a process (see below). 
 

 
 

 
After the run is complete, your planning unit layer will appear in the GIS window. 
 
Viewing Marxan results 
 
v Results from an individual run can be displayed by selecting the run number from 

the drop down menu next to “Output to Map” in the GIS display 
v From the main menu select, Marxan > View Output > Summary > Report.   This 

will display the summary information for all runs. Look at the Missing Values 
field. This indicates how many of your conservation features do not meet their 
targets in that solution. Are your targets being met? 

v From the main menu select, Marxan > View Output > Best Solution > Report.  
This will open the target achievement report for the solution with the lowest 
objective function.  Look through this file to see if your targets have been met in 
the “best” solution. If they are not, check the MPM field- this indicates how close 
the target is to being met (1=100% met, 0.99= 99% met, etc.) 

v There are some other outputs you can explore here also. 
 
 
Independent work- Scenarios 
Make sure to start every new scenario with the following two steps: 

 
v Create a new folder with the scenario name 
v Copy the entire contents of the MarxanDatabase folder into the scenario folder. 
 
After you’ve created a new scenario you can safely edit your scenario.  Most Marxan 
parameters can be accessed through the Marxan window in ZC. 
 
Scenario 1 – Updating planning unit status 
 
v After you copy the database to create a new scenario, create a new ZC project. 
 
The database you made yesterday locked in all planning units that are currently 
reserved in Tasmania.  
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v Change the locked in status of the planning units you locked in yesterday to see 
what a reserve system might look like if you started without any previously 
reserved areas.  Hint: planning unit status information is contained in the pu.dat 
file.  

 
Status Number 
Available for inclusion in reserve system 0 
Included in starting seed and available 1 
Locked in 2 
Locked out 3 
 
v After trying the analysis with all planning units available, try locking out (setting 

the status to 3) a number of planning units and re-running the analysis.   
v Explore the output files to see if files are still achieving targets after you have 

locked out a group of planning units.  
v If they are not, try increasing the species penalty factor (spf) in the spec.dat file. 

As you increase the spf, more emphasis will be placed on meeting the 
conservation feature targets.  

 
Scenario 2 – Variable Boundary Length Modifier (BLM) 
Here we will explore how increasing the emphasis on compactness affects Marxan 
results.  
 
v After you copy the database to create a new scenario, create a new ZC project.  
v In the Marxan window, select BLM from the “Parameter to edit” drop down 

menu.    
 
v Choose a new value of BLM. The higher the BLM, the more “clumped” your 

solution will be. The parameter can be edited by changing the value in the  “Edit 
Value” field, and then saving the change by click “Save Parameter”  

 
 

  
 
 
v Experiment with several different BLM values- try to get to a level of clumping 

that you think might work for implementation and management of reserves. 
Compare the results to your original run with a BLM of 0.  
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Scenario 3 – Changing Targets 
 
v After you copy the database to create a new scenario, create a new ZC project. 
v Edit your targets in the spec file. Increase targets to all features to 50%.   
v Check to see if your targets are still being met, and compare with the 30% target 

results.  
v Experiment with different targets to see how that changes the solutions. 
 
 
Scenario 4 – Calibration 
 
In this scenario we will be looking at the calibration of the BLM within Marxan.  The 
calibration tool allows you to easily explore a range of values for each parameter.   
 
v After you copy the database to create a new scenario, create a new ZC project. 
 
v From the main menu select Marxan > Calibration (the window below will appear) 

 
 
 
v Select BLM from the Choose Input to Calibrate menu 

v Specify 10 values in the “Choose number of values” box 

v In the range of values, try 0 as a minimum value and 1000 as a maximum value.  

The “number of values” specifies the number of BLM values that will be tested, with 
different values selected in equal intervals from the range specified.  After the 
calibration runs are complete you will see a summary table similar to the table below.  
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v To use the graphing functions built into ZC select Text Table > Graph Table .  

v Graph Cost on the X-axis and Boundary Length on the Y-axis. (Hint: remove the 

check mark from the Minimum zero box) 



 10 

 
 
 
When choosing an appropriate BLM value, look for the steep areas on the graph 
where the boundary length is quickly reduced for a small increase in cost. If that value 
does not produce the desired level of clumping, shift to a higher BLM (knowing that 
this includes a trade-off in terms of cost).  
 
v Choose the value that looks appropriate from your graph, and run Marxan with the 

new value. Observe the change in the level of clumping. 
v If you’d like to experiment more with the calibration tool, try changing some of 

the targets, and recalibrating the SPF.  
 
 
Scenario 5 – Interacting with output 
 
There are instances where it is useful to alter a Marxan solution (to avoid a 
particularly contentious place, as an exercise when meeting with stakeholders, or to 
make boundaries implementable). The configuration editor in ZC allows users to 
make changes to Marxan solutions, and then generate target/cost summary reports 
based on the new configuration. In this way, you can see how the changes you have 
made impact how well the solution meets your targets, and how it impacts the cost of 
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the solution.  New configurations can also be sent back to Marxan for additional 
analysis.  
 
v After you copy the database to create a new scenario, create a new ZC project. 
v Ensure that the NUMREPS parameter is set to 100. 
v Run Marxan 
v From the Main menu select GIS > Edit Configurations 
 

 
 
v Enter a name for the new configuration 

v From the Seed configuration drop down select “Marxan Solution 1”  

The seed configuration allows you to load a Marxan result into the configuration 
editor.  
 

 
 
v From the main menus select GIS > Select with > Mouse 

v Use the mouse to highlight a group of planning units on the map.  

v Change the assign to status to “Reserved” and Click Save 
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You have just changed the status of these planning units to reserved.  
 
v Click “Report” to open the reporting tool 

 

 
 
v Tick the box next to all the reports you’d like to generate and click OK 
 
You can also select planning units based on attributes of the planning unit shapefile. 
 
v From the main menus select GIS > Select with > Query 
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v After creating your selection, click “new selection” to select those planning units.  
(the query above will select those planning units with a selection frequency of less 
than 25).  

v Assign the selection to a new status (not selected, reserved, excluded) and click 
Save. Generate new reports to see the impact of changing these planning units.  

  
 
Scenario 6 – Installing R and exploring cluster analysis 
 
Zonae Cogito is compatible with the free statistical computing and graphics software, 
R. You can download this software for free from the R website: http://www.r-
project.org/ The lab computers already have R installed. Zonae Cogito is configured 
to automatically run R when it is installed on your computer.  The outputs include a 3-
dimensional plot of the solution space, a 2 dimensional plot of the solution space, and 
a dendogram showing the dissimilarity of the Marxan solutions.  
 

Note: R is already installed on your lab computer.  

v Edit the Marxan input parameter file with a text editor and insert this parameter; 

“SAVESOLUTIONSMATRIX 3” 

v Launch R from the start menu 

v Install the required packages with this command; 

“install.packages(c('rgl','vegan','labdsv'))” 

v From the main menu in ZC select Marxan > Do Cluster analysis (or make sure 

that it is checked on) 

v Run Marxan, and the 3-D output will automatically appear 

v When R does not launch automatically, launch R and type this command at the 

command line; 

“source("C:/MarxanIntroCourse/exercise1/MarxanDatabase/script.R")” 

v To view the other R outputs, go directly to the scenario 6 output folder and view 

the output_2d_plot and output_dendogram images. 

 

End of Day 2 activities. For further activities, please see 

C:\MarxanIntroCourse\Extra_Activities 


