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Overview

1 .	 Description

HurryCover allows you to create perfectly sized book covers or 
dust jackets which you can easily re-adjust the dimensions, the 
spine, the back and/or front flaps whenever you want. If your 
document needs to be updated according to new measurements, 
HurryCover automatically moves the layout components the 
required distance and ensures that guides and fold marks always 
fit the correct dimensions.

 NOTE HurryCover supports usual InDesign measurement units: agates, 
ciceros, centimeters, inches, millimeters, picas. You can instantly 
switch from one to another. See Advanced tips and features, §2.

In addition, HurryCover lets you edit a set of metadata (title, 
author, description, keywords) and add page details in the slug 
area—such as finished width, spine thickness or contact name. 
This way you can be sure that your client and/or the printer have 
all reliable information directly shown in the final export.

2 .	 System requirements

•	 Mac OS X 10.6 or later, 
or Windows XP / Vista / 7 / 8 (x86 or x64 editions).

•	 800×600 pixel screen-resolution or greater.
•	 Adobe InDesign CS4, CS5, CS5.5, CS6 or CC. 

	   

3 .	 TRY vs. PRO version

You can download a free tryout version of HurryCover at: 
http://ww.indiscripts.com/blog/public/scripts/HurryCoverTry.zip. 
It offers most of the features of the PRO release, but it makes 
impossible to update a document (the Update button remains 
grayed out).

 NOTE We strongly encourage you to install and test the TRY version 
before you purchase the PRO license of the product. Always 
make sure that your system meets the requirements.
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The main dialog of 
HurryCover has a 
very similar look-
and-feel in both 
Mac OS and Windows 
environments. The 
following languages are 
available (depending on 
your InDesign locale):
• English (default)
• French
• German
• Spanish
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Getting started

1 .	 Before you install

HurryCover entirely resides in a single file: HurryCoverPro.jsx. 
When you download the file from your private link, however, 
it is originally zipped. 

The first step is to unzip the .zip file so you can place 
HurryCoverPro.jsx at the desired location (see below).

As a precaution before you go on, save your working files and 
restart InDesign in a clean session.

2 .	 Installing in Mac OS X

1 )	 In InDesign, open the Scripts panel as follows:
•	 CS4:  Window > Automation > Scripts.
•	 CS5, CS5.5, CS6 or CC:  Window > Utilities > Scripts.

2 )	 You see there two main folders: Application and User. Right-
click the User folder and pick “Reveal in Finder.”

3 )	 You should now see a Scripts Panel folder. Drag HurryCoverPro.jsx 
into there. Congratulations, HurryCover is now installed!

3 .	 Installing in Windows

1 )	 In InDesign, open the Scripts panel as follows:
•	 CS4:  Window > Automation > Scripts.
•	 CS5, CS5.5, CS6 or CC:  Window > Utilities > Scripts.

2 )	 You see there two main folders: Application and User. Right-
click the User folder and pick “Reveal in Explorer.”

3 )	 You should now see a Scripts Panel folder. Drag HurryCoverPro.jsx 
into there. Congratulations, HurryCover is now installed!

MAC OS X

RIGHT-CLICK CLICK

DRAG INTO

WINDOWS

RIGHT-CLICK
CLICK

DRAG INTO
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Getting started

4 .	 Installing an update

If you are notified that an update of the product is available, 
simply download the new package from your private link, then 
unzip and install the file HurryCoverPro.jsx over the previous one, 
i.e. at the same location.

The new version is instantly functional, and your global settings 
are all preserved.

5 .	 Running HurryCover from the Scripts panel

Once the installation is done, switch back to InDesign. You can 
run HurryCover from the Scripts panel as follows:

1 )	 In InDesign, display the Scripts panel via:
•	 Window > Automation > Scripts (CS4), or
•	 Window > Utilities > Scripts (CS5, CS5.5, CS6 or CC).

2 )	 Look for HurryCoverPro.jsx in the User folder, 
then double-click on it.

6 .	 Running HurryCover from the Indiscripts menu

To have HurryCover available in the InDesign’s menu bar, 
simply click the Indiscripts-menu button as shown in the below 
screenshot, then close the dialog box.

You can now run HurryCover going into:
  Indiscripts > HurryCover PRO
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INDISCRIPTS MENU 
TURNED OFF

INDISCRIPTS MENU 
TURNED ON

Tired of continually 
digging into the 
Scripts panel? 
Make HurryCover 
available in a 
dedicated menu!
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Getting started

7 .	 Create your first cover!

Basically, HurryCover allows you to build the complete template 
of a book cover, or a dust jacket, with perfectly measured areas 
for front and back cover, spine, optional flaps, bleed and slug. In 
addition, HurryCover creates all convenient guides, crop and 
fold marks which you want to have in your layout.

1 )	 Run HurryCover.

2 )	 In the main dimensions panel, type in the dimensions of the 
finished width, spine and height:

Finished width.

Cover’s spine.

Height.

Finished width refers to the width of the front cover—which is 
also the width of the back cover.

3 )	 If necessary, activate the flaps panel by clicking its check box, 
then type in the width of the front (resp. back) flap as well as the 
turn-in thickness:

Front flap’s width.

Back flap’s width.

Turn-in thickness.

•	 Typically, if you are preparing a standard 
dust jacket, the jacket is wrapped around 
the case bound book and the turn-in thick-
ness is correlated with the thickness of the 
cover material.

•	 By cons, gatefold soft covers (i. e. “French 
flaps”) only require a small adjustment 
thickness between the flap and the cover.

 NOTE By default, the front and back flap widths 
are linked. However, HurryCover allows you 
to unlink these values by turning off the link 
button (to the right of the field). This way you 
can treat flaps separately. Also, any field of 
the FLAPS panel can be individually set to 0 
in order to remove the corresponding area.

4 )	 In the bleed and slug panel, type in the width 
of the bleed area, the crop marks offset, and the 
total room of the slug area:

Bleed.

Offset applied to the marks.

Slug.

 NOTE By default, the marks offset is linked to the bleed. 
Again, you can unlink these values by turning 
off the link button (to the right of the field).
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Getting started

5 )	 Finally, click Create to generate the cover template.

A new InDesign document is then created having the following 
areas, guides and elements:

CUSTOM CROP MARKS SLUG AREA FOLD MARKS (SPINE AND FLAPS)
BLEED AREA

BACK FLAP FRONT FLAPBACK COVER FRONT COVER

TU
RN

-IN

TU
RN

-IN

SP
IN

E

FOLD GUIDES

PAGE DETAILS

HurryCover’s guides 
and marks are placed 
on a reserved layer, 
HC_GuidesAndMarks, 
to let you safely work 
on your own layer(s).
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Managing your cover

1 .	 Adjusting size(s)

What makes HurryCover really powerful is that you can edit the 
specific size of any area of your document after it was created 
and laid out. For example, if you need to increase the spine width 
of a book jacket due to a “last minute technical adjustment,” 
HurryCover will save you from recalculating all the related 
measurements. Even better, HurryCover will automatically and 
accordingly reposition the elements of your layout to make free 
room for the new spine width.

Proceed as follows:

1 )	 Open an InDesign document that was created with HurryCover.

 NOTE HurryCover 2.x cannot manage documents built with 
HurryCover 1.x (2007). To make a document compliant with 
the current product, see Advanced tips and features, §7.

2 )	 Run HurryCover. Note that the dialog box then displays the 
current dimensions of your document.

3 )	 Change any size in the main dimensions panel, the flaps panel, 
and/or the bleed and slug panel.

4 )	 Click Update.

 NOTE The Update button is only enabled in the PRO version.

A typical use of 
HurryCover is changing 
the spine width 
of the final jacket 
with no effort and 
perfect accuracy. 
You could resize as 
well the finished 
width, flaps, etc.
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Managing your cover

2 .	 Adding / removing spine

HurryCover supports templates with zero-width spine, which 
simply means “no spine.” Therefore, you can very easily add or 
remove this area by editing the spine field.

1 )	 With your document active in InDesign, run HurryCover.

2 )	 Click the    icon (or manually select the spine field).

3 )	 Enter the new width of the spine.

4 )	 Click Update.

3 .	 Adding / removing flap(s)

By the same logic the flaps (front and/or back flap) can be sepa-
rately added or removed by editing their respective width.

1 )	 With your document active in InDesign, run HurryCover.

2 )	 If necessary, unlink the flaps by clicking the link button to the 
right of the back flap field.

3 )	 Choose one or more of the following actions:

•	 Click the    icon (or manually select the field) to edit 
the front flap, then enter the new width (‘0’ is allowed).
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ADDING SPINE
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REMOVING SPINE
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REMOVING THE 
FRONT FLAP
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Managing your cover

•	 Click the    icon (or manually select the field) to edit 
the back flap, then enter the new width (‘0’ is allowed).

•	 Click the check box of the flaps panel to globally enable or 
disable the flaps, as shown below:

4 )	 Finally, click Update.

4 .	 Automatic repositioning

HurryCover has been designed to update your layout the most 
accurate way, considering the relationship between the cover 
template and the graphic elements of the document.

Suppose you have a rectangle within the bounds of the front flap. 
HurryCover will regard that rectangle as owned by the flap and 
will try to maintain its position relative to the fold. Thus, if you 
resize any area of your template (spine width, front cover, and/

or anything else), the object keeps its place in the flap—as illus-
trated by the orange rectangle in the figure below.

The underlying rule is that HurryCover attempts to preserve the 
distance to the most inner edge of the area the object belongs to. 
If the object overlaps multiple areas—as illustrated by the gray 
rectangle which meets both the front cover and the front flap—
then again the reference edge is assumed the most inner one.

 NOTE The above rule only applies to left-sided or right-sided objects. If 
an element is located within the book spine area and/or overlaps 
the central axis of the cover, then it will remain in place.

When the width of 
any area is modified, 
HurryCover repositions 
the objects in order 
to maintain the 
distance to their 
“reference edge.”

UPDATE
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Managing your cover

5 .	 Smart resize

In addition to automatic repositioning, HurryCover can readjust 
the width of every individual element (rectangle, oval, triangle, 
polygon, text frame…) whose visible bounds fit two vertical edges 
of the cover areas.

 NOTE Smart resize mechanism is enabled by default. You 
can disable this feature from the ADVANCED SETTINGS 
panel. See Advanced tips and features, §4.

The figure below shows how some simple objects are processed 
when their bounds match various reference edges.

In order to prevent unwanted modifications, the Smart resize 
feature is restrictive. The following conditions are all required:
•	 The frame of the object must be very close to each reference 

edge, according to a “snap zone” internally set to 0.5 pt.
•	 The object must be an individual page item (i.e. groups are 

ignored).
•	 The object must belong to a non-locked layer.

 NOTE Automatic repositioning and Smart resize mechanisms also apply to: 
• hidden objects, 
• objects that belong to an hidden layer, 
• individually locked objects. 
So only locked layers are globally ignored.

6 .	 Using marks and guides

The marks and guides panel provides a set 
of check boxes that let you turn on/off custom 
printer’s marks, guides and page details:

•	 Spine/flap marks (also referred to as “fold 
marks”) are custom solid lines added for 
the flaps and spine. They help the printer 
determine where to fold the paper.

When Smart resize is in 
action, every individual 
element that fits two 
vertical edges of the 
cover is automatically 
resized on Update.

UPDATE

My Title

My Title
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•	 Crop marks are basically similar to the InDesign’s built-in 
crop marks. (They help the printer determine where to trim 
the paper.) The benefit of using HurryCover’s crop marks is 
that they have the same offset, weight and length as spine/
flap marks. (If you prefer to use InDesign’s crop marks in 
the print out, turn off Crop marks in HurryCover and click 
Update.)

 NOTE Fold and crop marks always go outside the page boundary. 
The applied offset is specified in the  field, 
which by default is linked to the bleed offset  . 
Unlink those fields to specify a different offset. (However, keep in 
mind it is not recommended to have marks offset less than bleed.)

 NOTE Marks’ weight and length can be globally set from the ADVANCED 
SETTINGS panel. See Advanced tips and features, §4.

•	 Guides are InDesign’s guides for spine and flaps. 
Depending on your settings, HurryCover automatically 
creates guides to delineate each separate area of your cover, 
including the “turn-in” between the front (resp. back) cover 
and the front (resp. back) flap.

•	 Page details refers to an information block placed at the 
bottom of the page over the bleed area. It brings together all 
size details (Flat size, Finished width, Spine, Flaps, Turn-in) 
as well as the Contact field (see below Adding/updating meta-

data) and the last-modified date of the document.

 NOTE Both printer’s marks and page details use the [Registration] 
swatch. Also, outlines are used for page details so that 
no additional font is added in the document.

•	 On master page (not available in InDesign CS4) tells 
HurryCover to place any marks, guides and extras on a 
master. This way you can manage multiple variants of your 
cover from a single document—since updating the master 
will instantly update every child page.

 NOTE On master page is disabled in CS4 due to an InDesign 
issue related to rotated spread views.

All marks, guides and extras managed by HurryCover are placed 
on a separate layer, HC_GuidesAndMarks, which is locked. 
Although you can rename this layer to your liking, be 
careful not to remove it.

7 .	 Adding / updating metadata

Metadata is a set of background information about a document, 
such as title, description, author name, or keywords applied to it. 
This dataset is stored using the XMP standard, which facilitates 
the exchange of metadata between applications.

Using well worded metadata helps you streamline your workflow 
and organize your documents. When you export your artwork 
out of InDesign (PDF, IDML…) the metadata travels with the file. 



11

hC

H u r r y C o v e r  2 . 0  M a n ua  l

Managing your cover

This makes it easier for your document to be found and properly 
identified. For example, it may be important for your studio—
and/or for your clients—to make visible which designer worked 
on a certain document.

Use the Metadata panel to add (or edit) such background 
information:

1 )	 If necessary, activate the panel by clicking its check box.

2 )	 In the Title field, fill in a title for the document. This will match 
“Document Title” in InDesign’s File Information, and “Title” in 
Acrobat’s Document Properties.

3 )	 In the Author field, enter the author’s name, if relevant. This 
will match “Author” in both InDesign’s File Information and 
Acrobat’s Document Properties.

4 )	 In the Description field, enter a short description or subject. This 
will match “Description” in InDesign’s File Information, and 
“Subject” in Acrobat’s Document Properties.

 NOTE HurryCover does not support multi-line descriptions.

5 )	 In the Keywords field, enter a comma-separated list of keywords. 
This will match “Keywords” in both InDesign’s File Information 
and Acrobat’s Document Properties.

6 )	 HurryCover provides an extra field, Contact, which is not an 
actual XMP structure and therefore is not stored in metadata. 
Use it to make a name, e-mail address, phone number, or any 
additional data, visible in the page details block at the bottom 
of the page.

8 .	 Restoring the previous state of the document

If anything goes wrong once you click Update, you can glob-
ally undo all modifications processed by HurryCover. Just press 
Cmd Z, or go into Edit > Undo HurryCover. The document is 
then restored to its previous size and state.
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Advanced tips and features

1 .	 How do I change the size of the pasteboard?

To specify how far the pasteboard extends out from the slug 
area, simply enter values for Horizontal pasteboard margins and 
Vertical pasteboard margins:

Horizontal pasteboard margins. (Disabled in 
InDesign CS4.)
Vertical pasteboard margins.

2 .	 How do I specify units of measure?

Most of the fields in HurryCover require a unit of measure. 
By default, all values fit the current horizontal ruler unit set 
in InDesign. You can change this at any time in HurryCover 
through the “unit block”:

AG CI CM IN MM PC PT

Each button switches to a different unit:
•	 AG	 to specify  Agates
•	 CI	 to specify  Ciceros
•	 CM	 to specify  Centimeters
•	 IN	 to specify  Inches
•	 MM	 to specify  Millimeters
•	 PC	 to specify  Picas
•	 PT	 to specify  Points

When you click a button, HurryCover instantly converts and 
displays all values into the selected unit.

You can also temporarily override the current unit as you enter a 
value. For example, even if the unit block is set to PT (points), you 
can type a new value like “4mm” to specify millimeters. In such 
case, the field is changed into “11.34pt” as soon as you validate.

 NOTE HurryCover supports most of the notations available in InDesign, 
e.g.: 
• “1.23i”, “1.23in”, “1.23inches”, 
• “123mm”, “12.3cm”, “.123m”, 
• “1p6”, “1.5pc”, “1.5pica”, “18pt”, “18points” 
• “c6”, “.5ci”, “0.5cicero” 
• “12ag”, “12agates”

When a notation cannot be properly parsed, or would result in a 
wrong value, a short alert message popups while you are typing:

MAIN DIMENSIONS
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2p6

50p0

MARKS AND GUIDES

Spine/flap marks

Crop marks

Guides

Page details
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12p0
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22p0

16p0

1p0

BLEED AND SLUG

1p3

1p3

4p6
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The value must be 
between 1 pt and 3685 pt.

3 .	 How do I save my global preferences?

Similarly to how InDesign manages preferences, HurryCover 
makes a distinction between application-level and document-level 
settings. When you are updating a document that was created 
with HurryCover, settings visible in the main dialog match that 
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specific document and take priority over HurryCover’s default 
settings. In this scenario:
•	 The Update button applies settings to the active cover.
•	 The Create button applies settings to the newly created 

cover (the active cover remains unchanged).
•	 The Close button simply ignores changes and lets the active 

cover unchanged.

By contrast, if no document is available (or if the active document 
is not a valid cover), then the main dialog matches the default 
settings—i.e. preferences—of HurryCover. In this scenario:
•	 The Update button is disabled.
•	 The Create button applies settings to the newly created doc-

ument (the default settings remain unchanged).
•	 The Close button saves changes as new default settings.

Therefore the easiest way to set your usual preferences is to 
proceed as follows:

1 )	 In InDesign, close any document window.

2 )	 Run HurryCover.

3 )	 Enter your preferred settings for future book covers (size, flaps, 
options, metadata, etc.).

4 )	 Click Close.

4 .	 How do I access advanced settings?

HurryCover features a few additional preferences, referred to as 
“advanced settings”, which are responsible for the overall func-
tioning of the program.

To access advanced settings in HurryCover, click the gear icon 
at the right side of the Close button:
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Crop marks
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GO TO ADVANCED 

SETTINGS

The advanced settings panel then shows up. From there you 
can both:
•	 Change the weight and/or the length used for all crop and 

fold marks (see Managing your cover, §6);
•	 Turn on/off Smart resize (see Managing your cover, §5).

OKReset

ADVANCED SETTINGS

Smart resize

0.25ptMarks weight:

18ptMarks length:

ADVANCED 
SETTINGS window. 
• Click Reset to restore 
the defaults. 
• Click OK to validate 
your choices.
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5 .	 How do I deal with recurring works?

When you prepare book covers or jackets for a series, it may be 
convenient to establish a template for this series, then to reuse 
it as a starting point for each specific document. This way you 
don’t have to constantly re-create standard artworks, layout and 
contents—e.g. flap structure, backgrounds, shared logos, frames, 
barcode area, and so on.

As HurryCover manages InDesign templates as well as regular 
documents, it’s easy to streamline such workflow:

1 )	 Run HurryCover.

2 )	 Enter your preferred settings for the series (size, flaps, options, 
metadata, etc.).

3 )	 Click Create to generate a fresh preformatted template.

4 )	 Feed the template so that it contains the layout of a typical 
issue—including layers, grids, guides, placeholder frames, styles, 
swatches, graphics, texts, etc.

5 )	 Save your document as an InDesign template:
•	 Go into File > Save As, and specify a location and filename.
•	 Choose “InDesign CSX Template” for Format (Mac OS) or 

Save As Type (Windows), and then click Save.

Once you have a prepared template, you can start a new cover 
from that template whenever you want:

1 )	 In InDesign, go into File > Open.

2 )	 Locate and select your template.

3 )	 Select Open Normal (Mac OS) or Normal (Windows), then click 
Open.

4 )	 Run HurryCover, adjust the cover to your needs, then click 
Update.

5 )	 Save the document with its own name.

6 .	 Can I add extra guides in my jacket?

You may want to manage additional ruler guides for margins,  
hinges, gutters, safety zones, etc. As HurryCover has been 
designed to offer a simple and intuitive user interface, we did not 
integrate all technical parameters that could be required in your 
workflow. However, there is usually no issue in using custom 
guides in your document or template. Such guides will just be 
repositioned as well as other layout components.

 NOTE As a general rule, do not place your own guides 
on the layer dedicated to HurryCover.
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7 .	 How do I make existing documents compliant 
with HurryCover?

Since documents which was not originally created from 
HurryCover are not supported by the program, you may have 
to manually convert old book covers into the new format. Here 
are the basic steps involved in this task:

1 )	 Open the existing document in InDesign.

2 )	 Write down the inner dimensions of the book cover:
•	 finished width and spine width,
•	 height,
•	 bleed and slug,
•	 flaps and turn-in thickness, if relevant.

3 )	 Run HurryCover, then enter all the needed dimensions in the 
corresponding fields.

4 )	 Click Create.

5 )	 In InDesign, go into Window > Arrange > Tile. (So you get both 
the source and the destination document visible.)

6 )	 Activate the source document. If needed, hide/lock the layers 
you don’t want to copy. Also, make sure that all the required 
objects are visible and not locked.

7 )	 Open the Layers panel. From the flyout menu, select Paste 
Remembers Layers.

8 )	 Go into Edit > Select All, and copy the selection (Cmd C).

9 )	 Activate the destination document.

10 )	Go into Edit > Paste in Place.
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