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1 Requirements and installation

In order to run ANIMO, a desktop or laptop computer is needed with the following software installed:

• Java: see Section 1.1

• Cytoscape (www.cytoscape.org): see Section 1.2

• UPPAAL (www.uppaal.org): see Section 1.3

The software to run Java-based programs is provided for free by Oracle. More information is avail-
able on the java.com website. Cytoscape is an open source project released under the terms of the
GNU Lesser General Public License. UPPAAL is developed by a collaboration by the universities of
Uppsala (Sweden) and Aalborg (Denmark), and is free for non-commercial applications in academia
only.

All of these softwares work under Windows ( ), Mac-OS ( ) and all most common GNU/Linux ( )
distributions. If the requirements are already met, ANIMO can be directly installed following the
instructions in Section 1.4.
Note: when required to type something, the text to input will be represented “like this”: the
quotation marks are not intended to be typed.
In case of problems accessing a web site with Microsoft Internet Explorer, we advise to try with a
different web browser (such as Mozilla Firefox or Google Chrome) or to update Internet Explorer.

1.1 Java

1. In order to check that Java is installed, open a console

Windows 7: press Windows button and type “cmd”, then press Return. Previous versions:
in the Start menu find All programs → Accessories → Command Prompt.

Go to Applications → Utilities → Terminal.

Under Gnome, press Alt-F2, type “gnome-terminal”, then press Return. Under KDE,
press the KMenu button, type “konsole” and click Konsole. Under Unity, press the home
button (the one with the Ubuntu logo: ), type “terminal” and click the Terminal icon.

2. Type “java” and press Return. If a brief error message like “unknown command” is shown,
Java needs to be installed: please proceed to step 3. Otherwise, please continue to Section 1.2.

3. Point your web browser to java.com.
Click Free Java Download, then on Agree and Start Free Download.
If asked for permission to run the installer, grant that permission.
After the download, double click the installer and install Java following the guided steps.
To check that Java has been correctly installed, a web page is automatically opened at
the end of the installation process. Click on Verify Java version. If a Congratulations!
message is shown, Java has been successfully installed. Otherwise, please try again or
contact Java support.

Go to Applications → Utilities → Java Preferences.
If the Java Preferences window is shown, Java is already installed, otherwise the system
will prompt you to install it. Follow the instructions and Java will be correctly installed
at the end of the procedure.

If you run Ubuntu, open the Software centre, search for “java” and select OpenJDK Java
6 Runtime. An Install button will appear next to the name of the package: click that
button and Java will be correctly installed.
If you run another distribution, use your package manager in a similar way. If you
cannot find OpenJDK, there may be the possibility to install Oracle Java Development
Kit (JDK) instead.
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1.2 Cytoscape

Cytoscape can be found at the address www.cytoscape.org/download.php: an automatic installer
program can be downloaded. Please note that you need to register and accept Cytoscape’s terms
of use before being able to start the download. Choose the latest 2.x version (2.8.3, on the left
column), possibly using a platform specific installer. For Windows, you can choose 64bit only if you
know that your computer can run 64bit programs, otherwise it is safe to choose 32bit.
Please note that Cytoscape version 3 is currently not supported.

1.3 UPPAAL

1. Point your browser to www.uppaal.org.
Note: UPPAAL is free only for academic use. Information and contacts for commercial licenses
can be found on the web site.

2. Click the Download link, and choose the latest development version (at least 4.1) for your
operating system.

3. Fill in the required contact information and click the Accept and download button to download
UPPAAL.
Note: problems with the registration on UPPAAL website have been reported when using
some versions of Microsoft Internet Explorer. If the registration is unsuccessful, please consider
updating Internet Explorer or changing your web browser.

4. Unzip the downloaded file to a known location: UPPAAL will be installed there.

5. Complete UPPAAL installation.

Open the UPPAAL installation location in Finder, drop the UPPAAL.App icon in your
Applications folder, and copy the verifyta executable file to a known location. The
installation of UPPAAL is complete: go to Section 1.4.

Open a console (this was done in Sec. 1.1, step number 1), type “cd PATH_TO_THE_

UPPAAL_DIRECTORY” and press Return; PATH_TO_THE_UPPAAL_DIRECTORY is the path to
the directory where you installed UPPAAL. It can be for example “c:\Users\myuser\
Desktop\uppaal-4.1.15”, or “/home/myuser/programs/uppaal-4.1.15”.

Note: some Windows users may have access only to specific partitions (D:, Z:,. . . ): in
that case, please first change to the corresponding drive letter where the downloaded file
was extracted. For example: if UPPAAL is located in d:\myuser\Programs\uppaal-4.

1.15, the two commands to be entered are
“d:”
“cd \user\Programs\uppaal-4.1.15”

6. Type “java -jar uppaal.jar” and press Return.

7. The license for UPPAAL will be automatically acquired, and the main window of UPPAAL
user interface will appear: you may now close that window.

1.4 Installing ANIMO

1. ANIMO is free only for academic use. For commercial licenses, please contact us.

2. Run Cytoscape.

3. Click the menu command Plugins → Manage Plugins: the Manage Plugins window will open.

4. Select the Settings tab and press the Add button.
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5. Insert this Name: “ANIMO”, and this URL: “http://fmt.cs.utwente.nl/tools/animo/plugins.
xml” (please note: the “http://” is required), then confirm with OK. A development, less
stable version of ANIMO is also available: to try it, use the URL “http://fmt.cs.utwente.
nl/tools/animo/dev/plugins.xml” instead of the one given above.

6. From the Download Sites list in the upper part of the Manage Plugins window, select ANIMO
(you may need to scroll down: it should appear after Cytoscape).

7. The panel on the left shows a smaller list of plugins: under Available for Install → Analysis,
select ANIMO v1.38 (if you chose for the development version of ANIMO, the number will be
2.x).

8. Click the Install button. The ANIMO tool will be automatically downloaded and installed.

9. The tool will ask you to indicate the position of the verifyta executable, which is the tool
to verify Timed Automata models. You can find it in the bin (bin-Linux, bin-Win32, . . .
depending on your operating system) directory inside the UPPAAL installation directory, or

where it was copied at step 5 for in Section 1.3.

10. Click the Close button to close the Manage Plugins window.

11. ANIMO is correctly installed and ready to be used.
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2 ANIMO user’s manual

We will now present a step-by-step sequence to obtain an example model with ANIMO, which will
allow us to illustrate the main features of the tool.

2.1 Modelling a small network

1. Run Cytoscape.

2. If Cytoscape is already running and there are open documents, please make sure that the
current work is saved before proceeding.

3. From the File menu, select New → Session. Answer positively to the question “Current
session (all networks/attributes) will be lost. Do you want to continue?”.

4. From the File menu, select New → Network → Empty Network.

5. In the Control Panel find the Editor tab. If you cannot find it, click the black arrows on
the top right of the panel to search through the available tabs. Click the name of the tab to
activate it.

6. Add 5 nodes to the empty network by Ctrl-clicking on empty areas of the Network window.
Note: Ctrl-clicks are obtained as follows. While holding the Ctrl key down, click with the
left mouse button, then release the Ctrl key. The Ctrl key is usually located in the lower
left or lower right corner of the keyboard. Apple keyboards may have the symbol instead
of Ctrl.

7. The Edit reactant dialogue window is opened when a new node is added, or when you right
click an existing node and then select the [ANIMO] Edit reactant. . . item from the menu. Use
that window to set the properties of the nodes as indicated in Table S1, taking the setting in
Figure S1 for node A as reference. When the properties of a node have been inserted, confirm
the choice with the Save button.

Table S1: The settings for the nodes (signalling network components) in the example.

Name
Total act. Initial act.

Molecule type Enabled? Plotted?
levels level

A 15 15 Cytokine Yes No

B 15 0 Receptor Yes No

C 15 0 Other Yes No

D 100 0 Kinase Yes Yes

E 1 1 Phosphatase Yes No

8. In order to add edges to the network, make sure that the Editor tab is still active in the
Control Panel, and add the following edges by Ctrl-clicking the source and then clicking the
target: A → B, B → C, C → B, B → D, E → D.
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Figure S1: The Edit reactant window: modifying the properties of node A.

9. The Edit reaction dialogue window is opened when you add a new edge, or when you right
click an existing edge and then select the [ANIMO] Edit reaction. . . item from the menu. Use
that window to set the parameters of the edges as indicated in Table S2. The settings for the
edge A → B should reflect the ones shown in the Edit reaction window in Figure S2.
Note: In order to insert a qualitative parameter like the ones required by the example network,
click once the slider in the parameter box to activate it, and then move the slider to match
the requested value.

Table S2: The settings for the edges (interactions) in the example.

Interaction Influence Scenario Parameter value

A → B Activation 1 Medium

B → C Activation 1 Slow

C → B Inhibition 1 Fast

B → D Activation 1 Slow

E → D Inhibition 2 V. Slow

10. In the Control Panel activate the ANIMO tab by clicking its title.

11. Click the Choose seconds/step button. A new dialogue window will appear: you can safely
choose a time resolution of 1 second per step and click OK.

12. Click the Analyse network button.

13. After a few seconds the Results Panel should appear on the right, showing a plot of the activity
level of reactant D over a time course of 120 minutes. Figure S3 shows the resulting network
and graph plot.
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Figure S2: The Edit reaction window: modifying the properties of edge A → B.

2.1.1 Managing simulation data and activity levels plots

Each time a simulation result is obtained, a new tab is added to the Results Panel (see the right part
of Fig. S3) in which we identify three buttons, a plot of the activity levels of the selected reactants
and a time slider.

Clicking on the button Change title allows to select a new title for the tab: this can be useful e.g.
when comparing different simulations made on similar configurations of the same network. Button
Save simulation data. . . allows to save the simulation data of the current tab on a .sim file, which
can then be loaded and inspected in the future. The Load simulation data. . . button in the Control
Panel above the Simulation box can be used for this purpose. Please note that the best results
are obtained only when loading a .sim file when the Network window contains the same network
on which the simulation data are based. If no network is currently opened, a network will not be
opened by loading a .sim file. The Close button is used to close the currently displayed results tab.

Right clicking inside the graph area will bring up a menu that allows to perform some basic
operations with the graph and its data:

• Add data from CSV : superpose the graph with other data series found in a .csv (comma
separated values) file. This file type can be obtained for example by exporting data from the
default Excel format. If you want the data in the .csv file to be rescaled so that its maximum
Y value coincides with the maximum in the plot, the data file needs to contain a column
named (exactly) Number of levels, on the first row of which the maximum of the scale for the
.csv data needs to be put. For example, if the data in the .csv file are on a 0-100 scale, the
value for Number of levels will be 100.

• Save as PNG : save the graph as it is shown in a .png image file. This file format can be
opened by most image editors.

• Export visible as CSV : export to a .csv file all the series that are currently visible (i.e., not
hidden) in the graph.

• Clear Data: clear the contents of the graph, removing all series. This can be useful for plotting
a .csv file without superposing it to the current graph, or for loading a file in which all hidden
data where removed (exporting the visible graph to a .csv with the previous command).

• Graph interval : change the lower and upper bounds for X and Y axes.

• Zoom rectangle: zoom the graph around a user-chosen rectangular area. After selecting this
command the shape of the mouse cursor changes into a cross. The area of the plot to be
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Figure S3: The completed example, where also the feature that allows to view the activity levels of reactants at chosen
simulation times is demonstrated: the vertical red bar in the graph on the right can be moved through the slider under the
graph, and indicates the point in the time series on which the colouring of the nodes in the Network window is based. The
legends for colours and shapes can be found in the Legend panel.

7



zoomed can then be selected by dragging a rectangular selection around it (see the definition
of rectangular selection on page 8).

• Zoom extents: bring the zoom level back to default, cancelling the effects of any Zoom rectangle
command.

Whenever the result of one or more simulations is shown as a graph, it is possible to use the slider
under the graph to move through the entire simulation, showing the activity levels of all reactants
represented with different node colouring in the Network window on the left. For an example, see
Figure S3: the vertical red line in the graph represents the time instant on which the colours of the
nodes in the Network window are based, and can be moved with the slider over which the mouse
cursor is drawn.

2.2 Additional tips

2.2.1 Editing a network in Cytoscape

Nodes and arcs can be placed in the network as shown previously: with the Editor tab selected in
the Control Panel, Ctrl-click (click while holding the Ctrl or key) in an empty place to add a
node; Ctrl-click the source node and click the target node to add an arc. It is also possible to drag
and drop the node/arc icons from the Control Panel into the Network window.
Note: to perform drag and drop move the mouse cursor over the icon in the Control Panel, click
with the left mouse button and, without releasing the button, drag the mouse cursor on the Network
window where you want to place the symbol; then release the left mouse button.

In order to delete a node/edge, select it by clicking or grouping them in a larger rectangular
selection, and then press the Delete key on the keyboard or select the Edit → Delete Selected Nodes
and Edges menu command.
Note: in order to obtain a rectangular selection, left click in the Network window where the upper-
left corner of the rectangle should be and, without releasing the left mouse button, drag the mouse
cursor to where the lower-right corner of the rectangular selection should be; then release the left
mouse button. All the entities which were even partially touched by the rectangle are now selected.

Navigation inside the Network window can be performed by clicking and dragging the centre
mouse button, while zooming can be done by either rotating the mouse wheel or clicking and holding
the right mouse button while moving the mouse in a vertical direction.

Finally, note that the colours used to represent node activity can be changed using the VizMapper
interface provided by Cytoscape, changing the setting for Node colour, shown in Figure S4. To
change the node colours, activate the VizMapperTM tab in the Control Panel, and find the entry
named Node Colour in the Visual Mapping Browser box. Click the arrow-shaped icon directly to the
left of Node Colour : the current setting for the node colours should appear: click the coloured bar
to open the window shown in Figure S4. The activityRatio on which the node colouring is based is
the ratio between the current activity level of a node and its number of activity levels. The coloured
arrows pointing downward on the upper border of the coloured rectangle can be dragged along the
length of the [0, 1] interval, thus changing the point at which a particular colour appears. New
arrows can be added with the Add button, while clicking an arrow and pressing the Delete button
will remove one. To change the colour of a point in the interval, double click the corresponding
arrow, and a new window will open, allowing you to choose a new colour: clicking OK will accept
the new colour. The modifications made in the Gradient Editor for Node Colour window should be
automatically reflected in the model: when the gradient is as wanted, simply close the window. If
the node colours seem not to have been updated, please move the slider under an existing graph in
the Results Panel.

2.2.2 ANIMO features

Nodes and edges (and groups of nodes/edges highlighted via a rectangular selection) can be disabled
by choosing [ANIMO] Enable/disable from the right-click menu: they will be represented with less
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Figure S4: Changing the colours used to represent node activity in an ANIMO model.

saturated colours and can be re-enabled by performing the same action. Moreover, a node can be
enabled/disabled directly in its properties window, where it is also possible to add/remove the node
from the list of series appearing in the graph resulting from a simulation of the network by selecting
Plotted or Hidden (see also Figure S1): nodes that will be plotted are circled in blue. Every enabled
node will be taken into account when computing the evolution of the system, but only nodes marked
as Plotted will appear in a graph.

Each plot in an ANIMO Results tab contains by default a legend, which can be used to modify
which series are displayed and how they are displayed. Clicking with the central mouse button
on a series name will hide it from the graph, while the same centre-click the coloured line beside
the series name will change the colour of that series, cycling through a predefined set of available
colours. The entire legend can be hidden by clicking with the central mouse button anywhere on the
graph (not inside the legend), or it can be dragged around by clicking and holding the left mouse
button, releasing it when the preferred position is reached. Rotating the mouse wheel will allow the
thickness of all the graph lines, and the size of the text, to grow or decrease: this feature can be
useful when the window containing the graph is very large.

As the model is non-deterministic, i.e. its evolution will not be exactly the same for every single
simulation run, it is possible to ask ANIMO to perform a number of simulation runs in a batch,
plotting the averages of the activity levels over the runs together with a standard deviation value,
or showing a so-called overlay plot where all runs are plotted over each other. The controls that
allow to ask for multiple simulation runs can be found in the Control Panel, inside the Simulation
box.

Standard deviation may be represented in the graph: it is normally shown as vertical bars, but
its aspect can be cycled through five possibilities (vertical bars, shading, both bars and shading,
bars and symbols, none) by right-clicking the corresponding line in the legend. Symbols associated
to a representation of standard deviation can be changed by Shift-right-clicking (holding down the
Shift key, right click) on the corresponding line in the legend. Standard deviation values can be
obtained when asking for multiple simulations in the network analysis, but they can also be present
in a .csv file, e.g. when the file contains averages of experimental data. In a .csv file, the column
containing the standard deviation values for column A should be named A StdDev for the program
to recognize it and properly display the data series with the associated error values.

2.2.3 Parameter settings

The application of some basic strategies when setting the parameters for a network allows the
less experienced users to considerably shorten the modelling time. First of all, it is important to
proceed in a top-to-bottom order, trying to match a component to the corresponding data before
inserting the components downstream thereof. Second, when choosing the kinetic parameter for an
interaction, we advise to first use the qualitative settings (very slow, slow, medium, fast, very fast):
this allows to define the relative speeds of the interactions as soon as possible, leaving the more
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precise parameter setting procedure as a follow-up step. Finally, as can be seen from the parameter
settings of Section 2.1, in order to obtain a peak behaviour it is particularly important that a
negative feedback is present (as an example, see the interactions involving B and C in Tab. S2), and
that the inactivating interaction in the loop is faster than the ones activating the target node.

A final note on the seconds/step button. This button allows to define the time granularity of
the simulations, but it is not strictly necessary to choose a very precise value. If the current value
for seconds/step is too high (or too low) to allow the network to be properly simulated, ANIMO
will automatically choose (respectively) the highest (lowest) value that still allows to avoid rounding
problems. It will be possible to notice such a change in the value of time scale when the number on
the seconds/step button changes.

2.2.4 Updating ANIMO

To check whether a new version of ANIMO has been published, run Cytoscape and ask for an update
of all plug-ins via the menu command Plugins → Update Plugins. After some seconds during which
Cytoscape will contact all the providers of the installed plug-ins, the system should report the list
of updatable plug-ins.
Note: a window with the message Attempting to connect to XYZ. . . may appear and disappear
multiple times: it is the normal behaviour.

If an updated version of ANIMO is available, it will appear under the category Updatable Plugins
→ Analysis → ANIMO v1.38. If no plug-in can be updated, a message stating No updates available
for currently installed plug-ins. will be shown.
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