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Legal Notices

Copyright © 1999 by FORE Systems, Inc.

FORE Systems, Inc. makes no representations or warranties with respect to the
contents or use of this manual, and specifically disclaims any express or implied
warranties of merchantability or fitness for any particular purpose. Further, FORE
Systems, Inc. reserves the right to revise this publication and to make changes to
its content, at any time, without obligation to notify any person or entity of such
revisions or changes.

All rights reserved. No part of this work covered by copyright may be reproduced
in any form. Reproduction, adaptation, or translation without prior written per-
mission is prohibited, except as allowed under the copyright laws. The informa-
tion in this document is subject to change without notice. You must reproduce and
maintain the copyright notice on any copy you make or use of the Programs.

U.S. Government Restricted Rights. If you are licensing the Software on behalf of
the U.S. Government (“Government”), the following provisions apply to you. If
the Software is supplied to the Department of Defense (“DoD”), it is classified as
“Commercial Computer Software” under paragraph 252.227-7014 of the DoD Sup-
plement to the Federal Acquisition Regulations (“DFARS”) (or any successor reg-
ulations) and the Government is acquiring only the license rights granted herein
(the license rights customarily provided to non-Government users). If the Software
is supplied to any unit or agency of the Government other than DoD, it is classified
as “Restricted Computer Software” and the Government’s rights in the Software
are defined in paragraph 52.227-19 of the Federal Acquisition Regulations (“FAR”)
(or any successor regulations) or, in the cases of NASA, in paragraph 18.52.227-86
of the NASA Supplement to the FAR (or any successor regulations).

Trademark Notices
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FCC CLASS A NOTICE
WARNING: Changes or modifications to this unit not expressly approved by the
party responsible for compliance could void this user’s authority to operate this
equipment.

NOTE: This equipment has been tested and found to comply with the limits for a
Class A digital device, pursuant to Part 15 of the FCC Rules. These limits are de-
signed to provide reasonable protection against harmful interference when the
equipment is operated in a commercial environment. This equipment generates,
uses, and can radiate radio frequency energy and, if not installed and used in ac-
cordance with the instruction manual, may cause harmful interference to radio
communications. Operation of the equipment in a residential area is likely to cause
harmful interference in which case the user will be required to correct the interfer-
ence at his own expense.



DOC CLASS A NOTICE
This digital apparatus does not exceed Class A limits for radio noise emission for
a digital device as set out in the Radio Interference Regulations of the Canadian
Department of Communications.

Le present appareil numerique n’emet pas de bruits radioelectriques depassant les
limites applicables aux appareils numeriques de la class A prescrites dans le regle-
ment sur le brouillage radioelectrique edicte par le ministere des Communications
du Canada.

 NOTICE

Marking by the symbol  indicates compliance of this system to the EMC (Elec-
tromagnetic Compatibility) directive of the European Community and compliance
to the Low Voltage (Safety) Directive. Such marking is indicative that this system
meets or exceeds the following technical standards:

• EN 55022 - “Limits and Methods of Measurement of Radio Interference
Characteristics of Information Technology Equipment.”

• EN 50082-1 - “Electromagnetic compatibility - Generic immunity stan-
dard Part 1: Residential, commercial, and light industry.”

VCCI CLASS A NOTICE

This is a Class A product based on the standard of the Voluntary Control Council
for Interference by Information Technology Equipment (VCCI). If this equipment
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AUSTRALIA EMC COMPLIANCE
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Preface

This manual provides the information necessary to install, configure and effective-
ly use the ATM Uplink Module for the ES-2810 Ethernet switch.

If you have any questions or problems, please contact FORE Systems’ Technical
Assistance Center (TAC) using the methods described on page iv.

Chapter Summaries

This user guide is organized into the following chapters:

Chapter 1 - Introduction : Provides an overall description of the ATM Uplink
Module.

Chapter 2 - Installation : Provides information on unpacking, installing, and ca-
bling the ATM Uplink Module.

Chapter 3 - Upgrading Software and Firmware : Provides information on
upgrading FORE Stack View, switch firmware, and ATM Uplink Module firm-
ware.

Chapter 4 - Configuring the Module : Describes how to configure the ATM
Uplink Module using FORE Stack View 2.0.5 or greater. FORE Stack View versions
prior to 2.0.5 does not support the ATM Uplink Module.

Appendix A - Technical Specifications : Provides hardware and general op-
erating specifications for the multi-mode, single-mode, and UTP ATM Uplink
Modules.
ES-2810 ATM Uplink Module User Guide i



Preface  
Typographical Styles

This user guide uses different typefaces to represent different types of user input,
system responses, and GUI objects.

Specific elements of the GUI or dialog box, such as the name of a field, button, or
selectable item in a list are displayed in bold Palatino. For example:

• Click OK to proceed.
• The ELAN Properties dialog box appears.

Command line interaction, file names, and paths are displayed in Courier . User
input into text fields (in a GUI or command line interface) are displayed in bold
Courier . For example:

• Select Software  Update  and press Enter.
• Specify the es2810_5.2  file.
• Enter et1516  in the ELAN Name field.

Menu options are displayed in regular Palatino, with no special font attribute ap-
plied to them. Angle brackets (“>”) are used to separate menu options (specifying
submenus). For example:

• Select File>New>Shortcut.

Important Information Indicators

To call your attention to safety and otherwise important information that must be
reviewed to ensure correct and complete installation, as well as to avoid damage
to the FORE Systems product or to your system, FORE Systems utilizes the follow-
ing WARNING/CAUTION/NOTE indicators.

WARNING statements contain information that is critical to the safety of the oper-
ator and/or the system. Do not proceed beyond a WARNING statement until the
indicated conditions are fully understood or met. This information could prevent
serious injury to the operator, damage to the FORE Systems product, the system,
or currently loaded software, and is indicated as follows:

WARNING! Hazardous voltages are present. To reduce
the risk of electrical shock and danger to
personal health, follow the instructions
carefully.
ii ES-2810 ATM Uplink Module User Guide



Preface
CAUTION statements contain information that is important for proper installa-
tion/operation. Compliance with CAUTION statements can prevent possible
equipment damage and/or loss of data and are indicated as follows:

CAUTION You risk damaging your equipment and/or
software if you do not follow these
instructions. 

NOTE statements contain information that has been found important enough to be
called to the special attention of the operator and is set off from the text as follows:

NOTE
If you change the value of the LECS control
parameters while the LECS process is
running, the new values do not take effect
until the LECS process is stopped, and then
restarted.

Invisible Laser Warning Notice

The ATM Module contains a fiber optic port. All fiber optic interfaces contain a
Class 1 laser.

Class 1 lasers are defined as products which do not permit human access to laser
radiation in excess of the accessible limits of Class 1 for applicable wavelengths
and durations. These lasers are safe under reasonably foreseeable conditions of op-
eration.

WARNING! Do not stare into the beam or view these
beams with optical instruments.

Class 1 Laser Product:
This product conforms to
applicable requirements of
21 CFR 1040 at the date of
manufacture.
ES-2810 ATM Uplink Module User Guide iii



Preface  
Contacting FORE Technical Support

In the U.S.A., customers can reach FORE Systems’ Technical Assistance Center
(TAC) using any one of the following methods:

1. Select the “Support” link from FORE’s World Wide Web page:

http://www.fore.com/

2. Send questions, via e-mail, to:

support@fore.com

3. Telephone questions to “support” at:

800-671-FORE (3673)  or  724-742-6999

4. FAX questions to “support” at:

724-742-7900

Technical support for customers outside the United States should be handled
through the local distributor or via telephone at the following number:

+1 724-742-6999

No matter which method is used to reach the TAC, customers should be ready to
provide the following:

• A support contract ID number
• The serial number of each product in question
• All relevant information describing the problem or question
iv ES-2810 ATM Uplink Module User Guide



CHAPTER 1 Introduction

This chapter describes the ATM-1/155 ATM Uplink Module, which is an optional
component that can be installed in an ES-2810 Ethernet Switch. The module pro-
vides a data bridge between Ethernet and ATM ELANs. 

There are three types of ATM Uplink Modules available:

• 155 Mbps OC-3c/STM-1 multi-mode
• 155 Mbps OC-3c/STM-1 single-mode
• 155 Mbps OC-3c/STM-1 UTP

Figure 1 - ES-2810 with ATM Uplink Module

NOTE
For technical specifications, see Appendix A
on page A-1.

To differentiate the ATM Uplink Module from other modules used in the ES-2810
(Stack Interface Modules, Matrix Modules, etc), this manual refers to the ATM
Uplink Modules as ATM Modules.

NOTE
For information on the ES-2810 Ethernet
Switch, see the ES-2810 Ethernet Switch User’s
Manual.

1.1 Modes of Operation
The ATM Module can operate in two modes:

• Stand-alone mode: Used to provide a data bridge between a single
ES-2810 and an ATM switch on an ATM ELAN.

• Stack mode (default): Used to provide a data bridge between a
stack of ES-2810s (two or more switches) connected by a Matrix
Module and an ATM switch on an ATM ELAN.

SIMTX RXATM-Stack

StatusSIM
CPU

Stack
ATM-1/155-MMSC
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Introduction  
NOTE
Link aggregation (also known as load
balancing) is supported when two modules
are installed in a stack. The bandwidth from
these two modules is combined when they
are both connected to a single ATM switch.
This provides a 2 x 155 Mbps link between
the Ethernet network and the ATM ELAN.
For more information, see the ES-2810
Ethernet Switch User’s Manual. Failover is also
supported when two modules are installed in
a stack. In the event of an ATM uplink failure
on one module, all ATM traffic is sent via the
other operating module.

1.2 Front Panel Features
The front panel of an ATM Module features the following:

• Status LEDs
• ATM-Stack connector
• ATM uplink port (multi-mode, single-mode, or UTP) with transmit

and receive LEDs
• SIM connector

A front panel view of a multi-mode ATM Module is shown below. The features are
described in detail in the subsections that follow.

Figure 2 - Front Panel of a Multi-Mode ATM Module

NOTE
Multi-mode and single-mode versions have
SC fiber connectors. The UTP version
contains an RJ-45 fiber connector.

Status LEDs

ATM-Stack     SIM

ATM Port

Retaining Screws

Connector Connector

with Transmit
and Receive LEDs 
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Introduction
The three status LEDs on the left side of the ATM Module reflect the current state
of the module. Table 1 describes each LED.

1.2.1  ATM-Stack Connector

The 26-pin ATM-Stack connector adjacent to the Status LEDs is used to establish
the ATM uplink between the Ethernet network and the ATM ELAN. The port con-
nects to the Matrix Module in the stack.

1.2.2  ATM Uplink Port

The SC or RJ-45 ATM port provides the data bridge between the Ethernet stack and
a switch on an ATM ELAN. There is a transmit (TX) LED to the left of this port and
a receive (RX) LED to the right. Table 2 and Table 3 describe the states of the LEDs.

Table 1 - LED Description 

LED Label Color Meaning

SIM
Green SIM stack connection active (switch has active 

connection to the Matrix Module)

Off SIM stack connection not active

CPU

Green CPU active, no fault

Off CPU error during boot

Red CPU error while running

ATM-Stack
Green ATM uplink stack connection active (Uplink 

has active connection to the Matrix Module)

Off ATM uplink stack connection not active

Table 2 - ATM Port Transmit LED Description

LED Color Meaning

Green The port is transmitting to the ATM network.

Off The port is not transmitting to the ATM network or
no ATM network connection.

Table 3 - ATM Port Receive LED Description 

LED Color Meaning

Green The port is receiving cells from the ATM network

Off Not receiving cells, but carrier present and no alarm
condition detected

Red No carrier present

Yellow Alarm condition detected
ES-2810 ATM Uplink Module User Guide 1 - 3



Introduction  
1.2.3  Stack Interface Module Connector

The 26-pin Stack Interface Module (SIM) connector adjacent to the ATM port, en-
ables the module to be integrated into a stack. This connector allows the Ethernet
ports on the switch containing the ATM Module to connect to the Matrix Module
in the stack.
1 - 4 ES-2810 ATM Uplink Module User Guide



CHAPTER 2 Installation

This chapter describes the installation and cabling procedures for the ATM Mod-
ule. The chapter is organized into the following sections:

• Section 2.1 -  Unpacking and Checking Equipment
• Section 2.2 -  ESD Precautions
• Section 2.3 -  Installing the ATM Module
• Section 2.4 -  Removing an ATM Module
• Section 2.5 -  Cabling
• Section 2.6 -  Verifying ATM Module Operation

2.1 Unpacking and Checking Equipment
Upon receipt of, and before unpacking your ATM Module, inspect the package for
any damage that may have occurred during shipping. If the package shows any
signs of external damage or rough handling, notify your carrier’s representative.
When unpacking your ATM Module, be sure to keep all original packing materi-
als. They may be needed for storing, transporting, or returning the product.

NOTE
All products returned to FORE Systems,
under warranty, must be packed in their
original packing materials.

2.1.1  Checking the Package Contents

A complete inventory of your package should be performed before proceeding.
Check the contents of the ATM Module package against the packing slip and verify
that all listed items have been received.

If any of the items are missing or damaged, please contact FORE Systems’
Technical Assistance Center immediately, using one of the methods described in
the Preface of this manual.

CAUTION Static electricity can cause severe damage to
the sensitive electronic components on the
ATM Module. To avoid damage due to
electrostatic discharge, leave the ATM
Module in its electrostatic bag until you are
ready to install it.
ES-2810 ATM Uplink Module User Guide 2 - 1



Installation
2.2 ESD Precautions
The ATM Module’s printed circuit board is an Electrostatic Sensitive Device and
should be handled only in a static-free working area; otherwise, the printed circuit
board may fail or be degraded.

Static electricity can cause severe damage to the sensitive electronic components
on the module. To avoid damage from static electricity:

• Avoid touching components or circuitry on the module. Handle
the module by its edges or faceplate at all times, when possible.

• Ensure that the switch is grounded.
• Equalize any static charge difference between your body and the

switch by wearing a grounding wrist strap and attaching it to a
non-painted/non-isolated part of the grounded switch (back panel
for example).

2.3 Installing the ATM Module
Use the following procedure to install the ATM Module in your ES-2810:

NOTE
Make sure you have read the ESD
Precautions before handling the module.

NOTE
A maximum of two ATM Modules in two
separate switches can be installed in any
stack configuration. ATM Modules must be
installed in slot A of an ES-2810 switch.

WARNING! Modules are not designed to be installed in,
or removed from the switch while it is in
operation. You must power off the switch
before installing/removing a module.
2 -  2 ES-2810 ATM Uplink Module User Guide



Installation
1. Turn off the switch.
2. Remove the plate covering expansion slot A.

 

Figure 3 - Removing the Plate from Expansion Slot A

3. Insert the ATM Module into slot A. Place your thumbs just beneath the
screws on the front panel of the module and push firmly until the mod-
ule clicks into place. Secure the module using the retaining screws.

CAUTION Do not over torque the retaining screws
when securing the module. Doing so may
damage the screws.

Figure 4 - Installing the ATM Module into Slot A

4. Connect the cables to the module. For details, see Section 2.5.
5. Turn on the switch.
6. Verify the links using the LEDs. For details about the LEDs, see Chap-

ter 1.
7. Configure the module using FORE Stack View. See Chapter 4.
ES-2810 ATM Uplink Module User Guide 2 - 3



Installation
2.4 Removing an ATM Module
Use the following procedure to remove an ATM Module from your ES-2810:

WARNING! Modules are not designed to be installed in,
or removed from the switch while in
operation. You must power off the switch
before installing/removing a module.

1. Turn off the switch and remove the cables.
2. Unscrew the retaining screws to release the module from the switch.
3. Gently pull the module by the retaining screws to disengage the con-

nectors fully from the socket on the motherboard. Slide the module out
of the slot completely.

4. If you are not replacing the slot with another module, cover the empty
module slot with the plate and secure using the screws.

2.5 Cabling
The cable connections to the ATM Module depend on the operating mode in which
the module is to be used: stand-alone or stack.

2.5.1  Stand-Alone Mode Cabling

Once the ATM Module has been installed, use the following procedure to connect
the ATM Module in a single ES-2810 to an ATM switch:

1. Connect the ATM port on the ATM Module to an ATM switch on the
ATM ELAN. The cabling should look like the following:

Figure 5 - Stand-Alone Mode Cabling

2. Check the LEDs on the module to verify the ATM link:
- CPU LED should illuminate green and all other LEDs should

be off.
- Appropriate TX or RX LEDs (depending on whether you are

transmitting or receiving cells to/from the ATM network) for
the ATM port should illuminate green.

3. Once the module is installed and properly cabled, you can configure
the module using FORE Stack View. See Chapter 4.

To ATM Switch
ATM Port
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Installation
2.5.2  Stack Mode Cabling

Once the ATM Module is installed, use the following procedure to connect the
ATM Module in a stack configuration to an ATM switch:

NOTE
Depending on the number of switches in a
stack, up to two ATM Modules can be
supported. The ATM Module should only be
installed in slot A of an ES-2810 switch.

1. Connect the ATM Module to the Matrix Module as follows:
a. Connect the SIM connector on the ATM Module to one of the ports

on the Matrix Module.
b. Connect the ATM-Stack connector on the ATM Module to another

port on the Matrix Module.
2. Connect the ATM port on the ATM Module to an ATM switch on the

ATM network. The finished cabling should look similar to the
following:

Figure 6 - Stack Mode Cabling (2-switch stack)

3. Check the LEDs on the module to verify the ATM link:
- All LEDs should illuminate green.
- Appropriate TX or RX LEDs (depending on whether you are

transmitting or receiving cells to/from the ATM network) for
the ATM port should illuminate green.

4. If you want to install a second ATM Module in slot A of another switch
in the stack, repeat steps 1 through 3.

NOTE
If there are other switches in the stack, make
sure the Stack Interface Module on the other
switches connect to the Matrix Module. 

ATM-Stack
connected
to a port
on the
Matrix
Module

SIM connected to a port
on the Matrix Module

155 Mbps connection
to ATM ELAN
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Installation
NOTE
Link aggregation (also known as load
balancing) is supported when two modules
are installed in a stack. The bandwidth from
these two modules is combined when they
are both connected to a single ATM switch.
This provides a 2 x 155 Mbps link between
the Ethernet network and the ATM ELAN.
For more information, see the ES-2810
Ethernet Switch User’s Manual. Failover is also
supported when two modules are installed in
a stack. In the event of an ATM uplink failure
on one module, all ATM traffic is sent via the
other operating module.

The finished cabling should look similar to the following (depending
on how many switches are in your stack):

Figure 7 -  Cabling for Stack Configuration
(example of a stack with three switches)

5. Once the ATM Module is cabled correctly, you can configure the mod-
ule using FORE Stack View. See Chapter 4.

NOTE
If SIM cables are connected to or
disconnected from the ATM Module (or any
other media module) in the stack while the
switch is operational, this may cause the
ATM Module to reboot.

To ATM ELAN
ATM Uplink
Module

Matrix
Module

SIM
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Installation
2.6 Verifying ATM Module Operation
Once you have finished installing the ATM Module and turned on the switch,
check the following to ensure the module is working properly:

• After the boot process has completed, the CPU LED on the ATM
Module should illuminate green for stand-alone mode. All LEDs
should illuminate green in stack mode.

• The switch with the ATM Module becomes visible in FORE Stack
View (when switch is turned off, the entire switch disappears from
FORE Stack View).
ES-2810 ATM Uplink Module User Guide 2 - 7
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CHAPTER 3 Upgrading Software and 
Firmware

The following software is required to support the ATM Module in an ES-2810
Ethernet Switch:

• FORE Stack View (FSV) 2.0.5 or greater (see Section 3.1)
• Switch firmware version 2.5 or greater (see Section 3.2)
• ATM Module firmware version 5.2 or greater (see Section 3.3)

The upgrade files can be obtained from the CD that was shipped with your module
or from FORE Systems’ Technical Assistance Center (TAC) via the web. See the
Preface of this manual for information on how to access TACtics Online.

NOTE
It is highly recommended that all firmware
upgrades be completed via Ethernet-attached
TFTP or Bootp servers.

NOTE
When loading ATM Module firmware for the
first time (or upgrading switch firmware to
2.5 for the first time), you should use the
initial upgrade procedures outlined in the
ES-2810 ATM Uplink Module Release Notes.

NOTE
Make sure you have backed up your switch
configuration (via TFTP client or FSV) before
proceeding with the upgrade process. When
using FSV to backup the current
configuration of the switch
(Configuration>Backup to disk), use the
default path.

NOTE
When saving or restoring a switch/stack
configuration file, make sure that the server
is attached to the management VLAN/
ELAN. In instances where the management
VLAN/ELAN is not the switch default, you
may have to create the management VLAN/
ELAN manually through FSV, then restore
the configuration.
ES-2810 ATM Uplink Module User Guide 3 - 1



Upgrading Software and Firmware
3.1 Upgrading FORE Stack View
FORE Stack View (FSV) version 2.0.5 or greater supports the ATM Module. You
can obtain the FORE Stack View upgrade file via FORE Systems’ TACtics Online
or from the CD that was shipped with your ATM Module. Normally, the Setup
program for FSV will start automatically after you insert the CD in your CD ROM
drive. However, if it does not, use the standard Windows procedures for installing
programs.

The earlier FSV version must be removed in order to install the newer version. If
the setup program detects an older version of FSV on your computer, you are
prompted to automatically uninstall the older version. The uninstall program will
remove all components of the older FSV version from your computer and then in-
stall the newer version.

NOTE
For detailed information about FORE Stack
View, see the ES-2810 Ethernet Switch User’s
Manual or the FORE Stack View online help.

3.2 Upgrading Switch Firmware
Switch firmware version 2.5 or greater supports the ATM Module. Switch firm-
ware can be upgraded using one of the following methods:

• via FORE Stack View (recommended method)
• via Local Management (TFTP from the ES-2810 serial console)
• via Maintenance Mode

NOTE
Switches in a stack configuration should be
upgraded in descending order (i.e. 5, 4, 3, 2, 1
from top to bottom), otherwise the stack
must be rebooted after switch #1 is upgraded.

NOTE
For first time upgrades to version 2.5, you
must use the initial upgrade procedures
outlined in the ES-2810 ATM Uplink Module
Release Notes.
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3.2.1  Upgrading Switch Firmware Via FORE Stack View

FORE Stack View (FSV) includes an easy-to-use Firmware Upgrade Wizard. The
switch configuration remains intact when this upgrade procedure is used. To use
FSV to upgrade the switch firmware, you will need a Windows NT/95/98 client
running FSV. When FSV contacts the switch/stack, the front (interface side) of the
switch or stack is displayed. The switch/stack can be managed from this display.

NOTE
FSV has an internal TFTP server, so all TFTP
servers must be disabled before loading the
firmware.

NOTE
It is recommended to upgrade switch
firmware and ATM Module firmware
independently, with switch firmware
upgraded first. Although the same upgrade
wizard is used to upgrade both switch and
ATM Module firmware, this section covers
procedures for upgrading the switch
firmware only. For procedures on upgrading
ATM Module firmware, see Section 3.3.

1. From the main menu, select Device>Firmware or right click the switch
and select from the pop-up menu. The first FORE Stack View Upgrade
Wizard window displays.

NOTE
If you have a stack configuration, you are
first prompted to select the switch you want
to upgrade before the upgrade wizard
window displays. Highlight the switch and
select Options>Upgrade.
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NOTE
If there are two or more NICs in a PC, you are
prompted to select an IP address. Select an IP
address and click OK to proceed to the
upgrade wizard.

2. Click Next to continue with the upgrade wizard. You are prompted for
the switch firmware upgrade file.
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If the upgrade wizard cannot find a suitable version of the firmware to
install, the Firmware Not Found dialog box displays.

If the latest firmware is on a CD you must insert the CD and make sure
that it can be accessed correctly.
If you have saved the firmware on your computer, click Browse to
locate the correct switch firmware file.
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3. Locate the file and click Open. The location of where the upgrade file
resides displays in the Path text field.

4. Click OK. The selected upgrade file displays in the Upgrade file text
field.

5. Click Next to continue with the upgrade wizard. You are prompted for
the ATM Module firmware. The Do not upgrade option for ATM Mod-
ule firmware is selected by default. 

es2810_2.5
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NOTE
It is recommended to upgrade switch
firmware and ATM Module firmware
independently, upgrading switch firmware
first.

6. Make sure the Do not upgrade option has been selected and click Next.
The FORE Stack View software will launch a TFTP server utility, per-
form the upgrade, and reset the switch.
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A confirmation window displays, stating the upgrade has been com-
pleted and the switch has been reset. Click Finish.

NOTE
If an error is found, refer to the error tab in
FORE Stack View.

3.2.2  Upgrading Switch Firmware Via Local Management

Upgrading switch firmware via TFTP requires the presence of a TFTP server on the
network. During normal operation, the Console port will give access to a menu,
identical to the one accessible via a telnet connection to the switch.

NOTE
Upgrading switch firmware via the console
requires a TFTP server operating on an
Ethernet segment attached to the switch.

NOTE
Make sure you have backed up your switch
configuration (via TFTP client or FORE Stack
View) before proceeding with the upgrade.
When using FSV to backup the current
switch configuration (Configuration>Backup
to disk), use the default path.
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NOTE
When saving or restoring a switch/stack
configuration file, make sure that the server
is attached to the management VLAN/
ELAN. In instances where the management
VLAN/ELAN is not the switch default, you
may have to create the management VLAN/
ELAN manually through FSV, then restore
the configuration.

With a VT100- compatible terminal attached to the switch’s Console port:

1. Press Enter to display the Local Management login screen.
2. From the main menu, select Administrator  and press Enter. Select-

ing this will give you access to the configuration options.
3. When prompted for a password, press Enter. The Local Management

main menu screen displays.
4. Select Software  Update  and press Enter.
5. Select Load  Software  and press Enter.
6. If an ATM Module is detected, you are prompted to select a device to

update: switch  or ATM. The default is switch . Verify that switch  is
selected and press Enter to upgrade the switch. 

7. Launch your TFTP server. If this is a first time upgrade, specify the IP
address of the TFTP server and the filename of the software to be
loaded.
When prompted to load software and reset, enter Yes. The upgrade
process takes a few minutes.

8. If there are other switches in the stack, repeat steps 2 through 7 for the
remaining switches in the stack.

3.2.3  Upgrading Switch Firmware Via Maintenance Mode

Maintenance mode allows you to upgrade via TFTP or bootp. Maintenance mode
provides limited console functionality and is typically used when the switch soft-
ware is corrupted or not functioning properly.

CAUTION The software and configuration already
resident in FLASH will be lost in
maintenance mode. Loading software to the
switch in maintenance mode should only be
done when absolutely necessary.

NOTE
Make sure you have backed up your switch
configuration (via TFTP client or FORE Stack
View) before proceeding with the upgrade.
When using FSV to backup the current
switch configuration (Configuration>Backup
to disk), use the default path.
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NOTE
When saving or restoring a switch/stack
configuration file, make sure that the server
is attached to the management VLAN/
ELAN. In instances where the management
VLAN/ELAN is not the switch default, you
may have to create the management VLAN/
ELAN manually through FSV, then restore
the configuration.

NOTE
The ES-2810 is not operational while in
maintenance mode.

NOTE
The TFTP server cannot be ATM-attached
when trying to download code in
maintenance mode. Upgrading firmware via
the console requires a TFTP server operating
on an Ethernet segment, attached to the
switch.

NOTE
For stack configurations, you must upgrade
the switch containing the Matrix Module
first.

1. Press the RESET button on the switch for about 5 seconds until the sys-
tem LED flashes green quickly.

2. Attach a terminal to the serial port on the front panel.
3. Press Enter a couple of times to receive a command prompt.
4. Type help  to list all commands available while in maintenance mode.
5. Enter the following at the command prompt and then press Enter:

tftp< filemame ><IP address of the switch ><IP address of 
the TFTP server >

The TFTP server utility starts the upgrade process.
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3.3 Upgrading the ATM Module Firmware
You can use one of the following methods to upgrade ATM Module firmware:

• FORE Stack View (FSV)
• Local management via the Console port of the switch that contains

the ATM Module

NOTE
ATM Module firmware cannot be upgraded
from maintenance mode.

NOTE
When loading ATM Module firmware for the
first time (or upgrading switch firmware to
2.5 for the first time), you should use the
initial upgrade procedures outlined in the
ES-2810 ATM Uplink Module Release Notes.

3.3.1  Upgrading ATM Module Firmware Via FORE Stack View

FORE Stack View (FSV) includes an easy-to-use Firmware Upgrade Wizard. The
uplink configuration remains intact when this upgrade procedure is used. To use
FSV to upgrade the ATM Module firmware, you will need a Windows NT/95/98
client running FSV. When FSV contacts the switch or stack, the front (interface
side) of the switch or stack is displayed. The switch or stack can be managed from
this display. 

To upgrade the ATM Module firmware using FSV, complete the following steps:

NOTE
It is recommended to upgrade switch and
ATM Module firmware independently,
upgrading switch firmware first. Although
the same upgrade wizard is used to upgrade
both switch firmware and ATM Module
firmware, this section covers procedures for
upgrading the ATM Module firmware only.
For procedures on upgrading switch
firmware, see Section 3.2.

1. From the main menu, select Device>Firmware or right click the switch
and select from the pop-up menu. The FORE Stack View Upgrade Wiz-
ard displays.
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NOTE
If you have a stack configuration, you are
first prompted to select the switch you want
to upgrade before the upgrade wizard
window displays. Highlight the switch and
select Options>Upgrade.

NOTE
If there are two or more NICs in a PC, you are
prompted to select an IP address. Select an IP
address and click OK to proceed to the
upgrade wizard.
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2. Click Next to continue with the upgrade wizard. You are prompted for
the switch firmware upgrade file.

NOTE
It is recommended to perform switch
firmware and ATM Module firmware
independently, with the switch firmware
upgraded first.
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3. Click Cancel to skip the switch firmware upgrade at this time. The
Upgrade file text field is blank indicating that switch firmware
upgrade has not been selected.

4. Select the Do not upgrade option to skip the switch firmware upgrade
at this time. The Do not upgrade option for switch firmware is not
selected by default.

5. Click Next to continue with the upgrade wizard. You are now
prompted for the ATM Module firmware.
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6. The Do not upgrade option for ATM Module firmware is selected by
default (the Browse button will be disabled). De-select the Do not
upgrade option to proceed with the ATM Module firmware upgrade.
If the upgrade wizard cannot find a suitable version of the firmware to
install, you are prompted for the location of the ATM Module firmware
upgrade file.

7. Click Browse to select the ATM Module firmware upgrade file. You are
prompted to locate the ATM Module firmware upgrade file.

If the latest ATM Module firmware is on a CD you must insert the CD
and make sure that it can be accessed correctly.
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8. Locate the file and click Open. The location of where the upgrade file
resides displays in the Path text field.

9. Click OK to continue with the upgrade wizard. The selected upgrade
file displays in the Upgrade file text field 

2810atm5.2
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10. Click Next. The FORE Stack View software will launch a TFTP server
utility, perform the upgrade, and reset the switch.

11. After the upgrade has been completed and the switch has been reset, a
confirmation window displays. Click Finish.
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3.3.2  Upgrading ATM Module Firmware Via Local Management

During normal operation, the Console port will give access to a menu, identical to
the one accessible via a telnet connection to the switch. To upgrade the ATM Mod-
ule firmware from the console, complete the following:

NOTE
A local, Ethernet-attached TFTP server
should be used.

NOTE
Make sure to back up your switch
configuration (via TFTP client or FORE Stack
View) before upgrading. When using FORE
Stack View to backup the current switch
configuration (Configuration>Backup to
disk), use the default path.

NOTE
When saving or restoring a switch/stack
configuration file, make sure that the server
is attached to the management VLAN/
ELAN. In instances where the management
VLAN/ELAN is not the switch default, you
may have to create the management VLAN/
ELAN manually through FSV, then restore
the configuration.

1. With a VT100- compatible terminal attached to the switch’s Console
port, press Enter to display the Local Management login screen.

2. From the main menu, select Administrator  and press Enter. Select-
ing this will give you access to the configuration options.

3. When prompted for a password, press Enter. The Local Management
main menu screen displays.

4. Select Software  Update  and press Enter.
5. Select Load  Software  and press Enter.
6. If an ATM Module is detected, you are prompted to select a device to

update: switch  or ATM. The default is switch . Verify that ATM is
selected and press Enter to upgrade the ATM Module firmware.

7. Launch your TFTP server. If this is a first time upgrade, specify the IP
address of the TFTP server and the filename of the software to be
loaded.
When prompted to load software and reset, enter Yes. The upgrade
process takes a few minutes.

8. If there are two modules in the stack, repeat steps 2 through 7 for the
remaining module.
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CHAPTER 4 Configuring the Module

This chapter contains information on using FORE Stack View (FSV) to configure
the ATM Module. Information on mapping between virtual LANs (VLANs) and
ATM emulated LANs (ELANs) is also included.

This chapter is organized into the following sections:

• Section 4.1 -  Default Settings
• Section 4.2 -  Configuring the Port
• Section 4.3 -  VLAN/ELAN Mapping
• Section 4.4 -  Monitoring the ATM Module

NOTE
For detailed information on FORE Stack
View and VLANs, see the ES-2810 Ethernet
Switch User’s Manual or the FORE Stack View
on-line help.

4.1 Default Settings
Once installation and cabling is complete, and the switch has started successfully,
the ATM Module uses the following default settings:

• SONET framing
• Internal timing
• Unassigned cell insertion
• LECS automatically discovered
• Stack mode
• Spanning Tree per VLAN disabled
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4.2 Configuring the Port
FORE Stack View (FSV) uses SNMP to configure all the parameters on your switch,
or group of switches (stack), and monitors their activities. Once the ATM Module
has been installed and properly cabled, you can use FSV to do the following:

• Label the ATM Module (Section 4.2.1)
• Change the port mode settings (Section 4.2.2)
• Change the LECS address (Section 4.2.3)
• Change the mode (stand-alone or stack) in which the module is

running (Section 4.2.4)

4.2.1  Labelling the ATM Module

To help with identification and network management, you can label the ATM
Module. With the switch or stack displayed in FSV, complete the following steps
to assign a unique name to the module:

1. From the main menu, select Configuration>Port Setup or right-click
the ATM port and select from the pop-up menu. The Setup window
displays:

2. Select the General tab.
3. Enter a description of the port in the Description text field. Any char-

acter string up to 15 characters long is permitted.
4. Enter the port's location in the Location text field. This will identify the

port’s location and give details on its use, function and configuration.
A maximum of up to 15 characters is permitted.

5. Click OK when finished.
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4.2.2  Changing the Port Mode Settings

The options on the Port Mode tab allow you to change the framing, timing, and cell
insertion settings. The default setting are Framing: SONET, Timing: Internal, and
Cell insertion: Unassigned. To change the port mode settings, complete the follow-
ing steps:

1. With the ATM port selected from the FSV display, select Configura-
tion>Port Setup from the main menu or right-click the ATM port and
select from the pop-up menu. The Setup window displays.

2. Select the Port Mode tab.

3. Select the physical settings for the port to match those in the ATM
switch.

4. Click OK when finished.
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4.2.3  Changing the LAN Emulation Configuration Server Setting

By default, the switch uses the ATM Forum defined "well-known" address to con-
tact the LAN Emulation Configuration Server (LECS). To change the LECS, com-
plete the following steps:

1. With the ATM port selected from the display, select Configura-
tion>Port Setup from the main menu or right-click the ATM port and
select from the pop-up menu. The Setup window displays.

2. Select the LAN Emulation tab.

3. Select one of the following server options:
• Automatically discovered: Select this to contact the LECS using

the "well-known" address.
• NSAP: Select this to specify an LECS NSAP address. You must en-

ter the 20-byte NSAP address of the LECS in the text field.
4. Click OK when finished.
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4.2.4  Changing the Module Mode

The ATM Module can operate in stack or stand-alone mode. The default is stack
mode. Use of these modes depend on whether the ATM Module is connected to a
Matrix Module in a stack or only installed in a single switch. To change the oper-
ating mode, complete the following steps:

NOTE
Changing the module mode will
automatically save your configuration and
reset the switch. It is recommended to
backup the configuration to disk before
changing the mode.

NOTE
A switch with an ATM Module in stand-
alone mode will not be recognized as part of
a stack.

1. With the ATM port selected from the display, select Configura-
tion>Port Setup from the main menu or right-click the ATM port and
select from the pop-up menu. The Setup window displays.

2. Select the Module tab.

3. Select one of the following options:
• Stand-alone: ATM Module is connected to a switch.
• Stack mode: ATM Module is connected to a Matrix Module in a

stack. This is the default.
4. Click OK when finished.
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4.3 VLAN/ELAN Mapping
The ATM Module allows VLANs created on the switch to be extended out the
ATM interface to an ELAN where the ES-2810 acts as a proxy LEC device. The
ES-2810 supports port-based and MAC address-based VLAN assignment.

The switch is pre-configured with a VLAN named system  as the first VLAN in-
stance. A corresponding ELAN named default  also exists. When an ATM Mod-
ule is installed in the switch, it will become a part of the system  VLAN and will
automatically attempt to join the default  ELAN, and begin bridging traffic. The
ELAN name cannot be changed since it is confined by the VLAN name. To change
the name, delete the VLAN and re-create it before mapping it to an ELAN.

You can use FORE Stack View (FSV) to do the following:

• Create VLANs (see the ES-2810 Ethernet Switch User Manual)
• Map VLANs to ELANs on the ATM network (see Section 4.3.1)
• Enable Spanning Tree Protocol per VLAN (see Section 4.3.2)

4.3.1  Mapping VLANs to ELANs

The ES-2810 supports up to 16 VLANs on the Ethernet LAN which can be mapped
to ELANs on the ATM network. Figure 8 shows an example of VLANs mapped to
ELANs.

Figure 8 - An Example of VLANs Mapped to ELANs
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When two ATM Modules are installed in a stack, both modules will join the same
set of ELANs and provide load sharing and failover for each ELAN that they join.
Each ATM Module will provide connectivity to a subsection of the total number of
ATM clients on a given ELAN. Determining which module serves which clients is
based on the even/odd designation of the traffic’s destination MAC addresses.

NOTE
default  and system  ELAN/VLAN names
are not permitted. These names are reserved
by the network management systems, where
default  ELAN maps to system  VLAN.

NOTE
When an ATM Module is installed in an
ES-2810, any VLANs which could potentially
overlap with other VLANs cannot be
mapped to ATM ELANs. FORE Stack View
will not allow multiple potentially
overlapping VLANs to be mapped to ATM
ELANs.

NOTE
Make sure that LANE services for a given
ELAN already exist before mapping a VLAN
to an ATM ELAN.

To map existing VLANs using FSV, complete the following steps:

1. From the main menu, select Configuration>VLAN Setup. The VLAN
Setup dialog box displays:
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2. If an ATM Module is detected, the ELAN Mapping button displays.
Click ELAN Mapping. The following displays, listing the VLANs that
can be mapped to an ELAN.

3. Select the VLAN which should be mapped to an ELAN.
4. Click OK when finished.

4.3.2  Enabling Spanning Tree Protocol Per VLAN/ELAN

Spanning Tree Protocol (STP) can be enabled per VLAN/ELAN. STP provides
loop-free topology in a network environment that may have redundant paths. To
enable STP, complete the following steps:

NOTE
Only port-based VLANs are mapped when
this option is enabled. No MAC address-
based or IP policy-based VLANs are
permitted.

NOTE
Do not enable or disable spanning tree on
any stand-alone switch or stack of switches
containing an ATM Module through the local
user interface. Use only the spanning tree per
VLAN feature in FORE Stack View.
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1. From the main menu, select Configuration>VLAN Setup. The VLAN
Setup window displays.

2. Click Advanced. The VLAN Advanced window displays:
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3. Click STP/VLAN. The following dialog box displays:.

4. Select the Enabled option to enable spanning tree per VLAN. Span-
ning tree per VLAN is disabled by default.

5. Click OK when finished.

4.4 Monitoring the ATM Module
FORE Stack View (FSV) 2.0.5 or greater allows you to monitor the performance of
the ATM uplink port and also monitor the ELANs on the ATM LAN.

You can use FSV to do the following:

• View ATM statistics and uplink information (Section 4.4.1)
• Monitor the ATM port (Section 4.4.2)
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4.4.1  Viewing Port Details

The transmit and receive LEDs on the ATM Module can indicate whether there is
activity on the ATM port. To view ATM statistics and uplink information, com-
plete the following steps:

1. From the main menu, select Monitoring>Port Details, or right click on
the ATM port and select from the pop-up menu. The Details window
displays:

Each statistic displayed in the window is described as follows:

Statistic Description

AAL5 PDUs Transmitted Number of AAL5 protocol data units (PDUs)
transmitted to the ATM switch.

Received Number of AAL5 PDUs received from the
ATM network.

Dropped Number of AAL5 PDUs dropped

Total PDUs transmitted, received, and dropped for
AAL5

AAL5 Errors CS layer errors Number of AAL5 cells that have had Conver-
gence Sublayer (CS) protocol errors

PDU CS errors Number of AAL5 cells that have had PDU CS
errors

Carrier Carrier status: present (On) or no carrier
present (Off)

Cell Errors No VCI connection Indicates the number of cell dropped because
there was no connection for the VCI present
in the cell header.
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2. To view current uplink settings, select the Uplink tab. The following
displays:

3. Select File>Exit to exit from the window.

NOTE
No VCI errors will increment continuously if
connected to an ASX switch port that is using
SPANS signalling.

PMD Statistics Section BIP Number of Section Bit Interleaved Parity
(BIP) errors

Path BIP Number of Path BIP errors

Line BIP Number of Line BIP errors

Path FEBE Number of Path Far End Block Errors (FEBE)

Line FEBE Number of Line FEBEs

Corrected HCS Number of corrected Header Check Sequence
(HCS) errors

Uncorrected HCS Number of uncorrected HCS errors

Statistic Description
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4.4.2  Monitoring ELANs

You can view a list of all ELANs on the ATM LAN and view individual ELAN de-
tails. To monitor the performance of the ATM port, complete the following steps:

1. Right-click on the ATM port and select from the pop-up menu. The
ELAN Monitoring window displays:

2. On the ELAN Table tab, highlight the ELAN for which you want to
access details and select Options>Details or double-click the ELAN.
For a better overview, several of these windows may be open at the
same time.

The ATM Servers tab displays ATM server information such as LANE
server NSAP addresses and the ELAN status.
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3. Select the ARP Cache tab to view LE-ARP cache information such as
the MAC address to NSAP address mapping and VC type.

4. Select File>Exit to close the Details window.
5. From the ELAN Port Monitoring main window, select the ATM Status

tab to view UNI status and operating version.

6. Select File>Exit to close the window.
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APPENDIX A Technical Specifications

This appendix provides hardware and general specifications for the following
ATM Modules:

• 155 Mbps OC-3c/STM-1 multi-mode
• 155 Mbps OC-3c/STM-1 single-mode
• 155 Mbps OC-3c/STM-1 UTP

A.1 155 Mbps OC-3c/STM-1 MM

The following specifications apply to the 155 Mbps multi-mode ATM Module
(ATM-1/155 MMSC):

Description Specification

Number of Connections Three: 1 SIM connector, 1 ATM-Stack connector,
and one SONET/SDH ATM uplink port

ATM Uplink Data Rate 155.52 Mbps

Maximum Line Length SIM and ATM-Stack: 39 inches (1 meter)
ATM uplink port: ~2 km (2000 meters)

Connector Type SIM and ATM-Stack: 26-position shielded plug
ATM uplink port: duplex SC

Media Type SIM and ATM-Stack: stacking cable
ATM uplink port: multi-mode fiber (62.5/125
µm)

Table Size LE_ARP_CACHE at least 2000 addresses

VCC Support up to 4096 VCCs

Dimensions W: 5.9 in. (149 mm)
H: 1.5 in (37 mm)
D: 9.4 in. (238 mm)

Weight 9 ounces (.25 kg)

Framing STS-3c-STM-1

Timing Internal or from the incoming 8 KHz timing
marker

Optical Power -14 to -20 dBm transit power, -14 to -30 dBm
receive sensitivity, 0 to 10 dB path attenuation
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Wavelength 1,310 nm

Default Settings Mode: Stack; Framing: SONET; Timing: Internal;
Cell Insertion: Unassigned

Operating Temperature 0 to 55°C with 1 meter/second air flow (installed)

Storage Temperature -40 to 70°C (installed)

Operating Humidity 10% to 90% non-condensing at 40°C (installed)

Storage Humidity 10% to 90% of relative humidity (installed)

Description Specification
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A.2 155 Mbps OC-3c/STM-1 SM

The following specifications apply to the 155 Mbps single-mode ATM Module
(ATM-1/155 SMSC):

Description Specification

Number of Connections Three: 1 SIM connector, 1 ATM-Stack connector,
and 1 SONET/SDH ATM uplink port

ATM Uplink Data Rate 155.52 Mbps

Maximum Line Length SIM and ATM-Stack: 39 inches (1 meter)
ATM uplink: 10 km (10,000 meters)

Connector Type SIM and ATM-Stack: 26-position shielded plug
ATM uplink: duplex SC

Media Type SIM and ATM-Stack: stacking cable
ATM uplink: intermediate reach single-mode
fiber 

Table Size LE_ARP_CACHE at least 2000 addresses

VCC Support up to 4096 VCCs

Dimensions W: 5.9 in. (149 mm)
H: 1.5 in (37 mm)
D: 9.4 in. (238 mm)

Weight 9 ounces (.25 kg)

Framing STS-3c-STM-1

Timing Internal or from the incoming 8 KHz timing
marker

Optical Power -8 to -15 dBm transmit power, -8 to -28 dBm
receive sensitivity, 0 to 13 dB path attenuation

Wavelength 1,310 nm

Default Settings Mode: Stack; Framing: SONET; Timing: Internal;
Cell Insertion: Unassigned

Operating Temperature 0 to 55°C with 1 meter/second air flow (when
installed in ES-2810)

Storage Temperature -40 to 70°C (installed)

Operating Humidity 10% to 90% non-condensing at 40°C (installed)

Storage Humidity 10% to 90% of relative humidity (installed)
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Technical Specifications  
A.3 155 Mbps STS-3c/STM-1 UTP

The following specifications apply to the 155 Mbps UTP ATM module:

Description Specification

Number of Connections Three: 1 SIM connector, 1 ATM-Stack connector,
and 1 SONET/SDH uplink port

ATM Uplink Data Rate 155.52 Mbps

Maximum Line Length SIM and ATM-Stack: 39 inches (1 meter)
ATM uplink: 325 feet (100 meters)

Connector Type SIM and ATM-Stack: 26-position shielded plug
ATM uplink: RJ-45

Media Type SIM and ATM-Stack: Stacking Cable
ATM uplink: Category 5 Unshield Twisted Pair

Table Size LE_ARP_CACHE at least 2000 addresses

VCC Support up to 4096 VCCs

Dimensions W: 5.9 in. (149 mm)
H: 1.5 in (37 mm)
D: 9.4 in. (238 mm)

Weight 9 ounces (.25 kg)

Default Settings Mode: Stack mode; Framing: SONET; Timing:
Internal; Cell Insertion: Unassigned

Framing STS-3c-STM-1

Timing Internal or from the incoming 8 KHz timing
marker

Operating Temperature 0 to 55°C with 1 meter/second air flow (when
installed in ES-2810)

Storage Temperature -40 to 70°C (installed)

Operating Humidity 10% to 90% non-condensing at 40°C (installed)

Storage Humidity 10% to 90% of relative humidity (installed)
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Technical Specifications
A.3.1  155 Mbps UTP Pinout Specifications
155 Mbps UTP ATM uplink modules have a standard RJ-45 female connector and
use RJ-45 network equipment pinouts as illustrated in the table below:

Pin Number
Signal 

Mnemonic
Signal Name

1 RX+ Receive Data +

2 RX- Receive Data -

3 Not Used

4 Not Used

5 Not Used

6 Not Used

7 TX+ Transmit Data +

8 TX- Transmit Data -
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