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Chapter 1  
Using This Manual 

Introduction 
This manual explains how to use M-Trend, a program that allows the 
graphic or textual display of archived data in M-Trend formatted, 
Open Database Connectivity (ODBC) compliant databases. It 
describes the procedures used to establish a database connection, 
define query parameters, view the trend data, and save the parameters 
into M-Trend (.htv) files for later recall. 
This manual does not include information about the mechanisms used 
to collect and write the trend samples into the database. These 
mechanisms are specific to different products, which include the 
M-Trend display component. 

© May, 2000 Johnson Controls, Inc.
     Code No. LIT-6450010
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Key Concepts 
Chapter Organization 

Each chapter in the M-Trend User’s Manual is divided into five main 
sections: 

Table 1-1: Chapter Organization 
Section Description 
Introduction Briefly outlines the contents of the chapter. 

Key Concepts Describes background information necessary to 
perform or understand specific tasks. 

Procedure Overview Describes general steps for performing the 
tasks that are described in detail in the Detailed 
Procedures section. This section is geared 
toward users already experienced in using 
M-Trend who only need a reference. 

Detailed Procedures Describes in detail the steps needed to 
complete specific tasks described within the 
chapter. This section is geared toward users 
who are new to M-Trend. 

Troubleshooting Provides information on potential problems as 
well as methods for solving them. 

 
If a section is not necessary for a particular chapter, it is omitted. For 
example, this chapter, Using This Manual, does not contain a 
troubleshooting section. 

Online Help 
M-Trend software includes online Help. The Help screens may be 
accessed by selecting Help from the menu bar, by pressing the F1 key, 
or by pressing Alt+H. Help describes the basic procedures for 
performing functions within the M-Trend software. The online help 
system follows the basic conventions of Windows® 95 and 
Windows NT® help systems. 

Manual Conventions 
As in most Windows-based programs, sometimes there are multiple 
ways to perform the same tasks. This manual does not describe how to 
use both the mouse and the keyboard to perform the same step. In 
general, Microsoft® conventions are used to describe software 
features. 
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Chapter 2  
Introduction to M-Trend 

Introduction 
M-Trend is a program designed to query a database of archived trend 
samples, and display the query results in both graphical and textual 
formats. M-Trend allows the user to create and save trend documents 
containing these query and display characteristics for future reference. 
This chapter provides: 

• M-Trend hardware and software requirements 

• M-Trend data connection overview 

• M-Trend operation overview 

© June 18, 2004 Johnson Controls, Inc. 



 Introduction 2-2 

Key Concepts 
M-Trend Hardware and Software Requirements 

M-Trend may be run standalone or within an ActiveX® document 
container such as the M-Series Workstation or Microsoft® Internet 
Explorer 4.0. The minimum recommended Personal Computer (PC) 
components are: 

Product M-Graphics (MW-MGRAPH-0) 

Processor  

 Recommended Windows® 2000 Professional Operating System (OS) with Service Pack 4 or 
Windows XP Professional OS with Service Pack 1 
2.6 GHz Pentium® 4 processor 

 Tested and Approved Windows 2000 Professional OS 350 MHz Pentium III processor 

Random Access Memory (RAM) 

 Recommended Windows 2000 Professional OS and Windows XP Professional OS: 256 MB 

 Minimum Windows 2000 Professional OS and Windows XP Professional OS: 128 MB 

Bus Peripheral Component Interconnect (PCI) 

Hard Disk Capacity 40 GB minimum. (If running System Tools and an M-Series Workstation on 
the same computer, we recommend maintaining 600 MB of free space on 
your hard disk for virtual memory.) 

Monitor Super VGA (800 x 600), (1024 x 768), or (1280 x 1024) 

CD-ROM 4x or higher 
We recommend a CD-RW drive for making backups. 

Graphics Support VGA or SVGA 

Video Memory Minimum 2 MB VRAM that supports 16-bit (65,535) colors 

Required Software M3 Workstation Software (MW-M3WHCI-0) or M5 Workstation Software 
(MW-M5WHCI-0) 

Software Components ODBC Administrator and supporting files* 
Driver files for each database to be used with M-Trend* 
M-Historian databases containing the archived Trend samples to be 
queried* 

* Normally supplied during installation of the product, which creates and populates the database. 
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M-Trend Data Connection Overview 
Each M-Trend document consists of 1-32 Data Sources chosen by the 
user from a pool of all available archived data stored within the 
M-Historian database. A date/time range may be chosen for the 
display of data, and the user can manipulate the appearance of data, 
both in the graphical and textual formats. See Figure 2-1 for an 
overview of how M-Trend connects with data. 

Historian database
archived on
workstation.

Trend Collector

Writes samples to
Historian database.

M-Trend queries Historian
database for samples

through ODBC.

M-Trend displays graphic or
textual views of data in the

Historian database.

 

Figure 2-1: M-Trend Data Connection Overview 

M-Trend Operation Overview 
The M-Trend program is a display tool providing the functionality 
necessary to view any combination of archived data within an 
M-Historian database. The configuration, definition, and maintenance 
of the trend collection mechanism or the archive database is assumed 
to already be in place. 
See Figure 2-2 for an overview of the steps necessary to create and 
view an M-Trend document. 
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Start M-Trend.
See Getting Started  in this manual.

Connect to a Database.
See Connecting M-Trend to a Database

 in this manual.

Add Data Sources from the Connected Database
to the Trend document.

See Defining M-Trend Documents
in this manual.

Set options for Data Source,
Range, and Plot Style.

See Defining M-Trend Documents in this manual.

Save the Trend document.
See Getting Started  in this manual.

Repeat this
cycle for

interactive
diagnostics.

 

Figure 2-2: Using M-Trend Overview 
M-Trend provides the user with the ability to collectively display the 
historical data of globally distributed points throughout a site. Any 
designated trended Data Source collected within an M-Historian 
database can be visually tracked via one or more M-Trend documents. 
The data can be in the form of an analog or binary value (e.g., room 
temperature or online/offline). For example, an M-Trend document 
may be used to monitor the status of a fan device (on or off), or to 
compare the inside and outside air temperature over a period of time. 
The user has the flexibility to create, edit, and save individual 
M-Trend documents in (*.htv) files for later display. Each (*.htv) file 
stores all the information necessary to display the requested data 
samples both in graphical and textual format. 

M-Password 
M-Trend supports the restriction of certain user activity as established 
by the M-Password component. 
Refer to the M-Password Technical Bulletin (LIT-1153150) in the 
M3 Workstation Manual (FAN 1153) for more information. 
 

Metasys® is a registered trademark of Johnson Controls, Inc. 
All other marks herein are the marks of their respective owners. 
© 2004 Johnson Controls, Inc. 
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Chapter 3  
Getting Started 

Introduction 
M-Trend can be run as a standalone program or in an ActiveX 
document container. This chapter describes how to get started using 
M-Trend as a standalone program. 
This chapter describes how to: 

• start M-Trend 

• create a new M-Trend file 

• open an M-Trend file 

• zoom in on part of an M-Trend Graphic View 

• view detailed Trend sample information 

• save an M-Trend file 

• save an M-Trend file with a new name 

• print an M-Trend file 
This chapter assumes M-Trend is installed and you have defined and 
connected to an M-Historian database. 
For details in installing M-Trend, refer to your workstation installation 
documentation. 
For details on connecting to an M-Historian database or defining a 
connection to an M-Historian database, see the Connecting M-Trend to 
a Database chapter in this manual. 

© September, 2003 Johnson Controls, Inc.
      Code No. LIT-6450030 
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Key Concepts 
M-Trend Main Window 

Figure 3-1 shows the Main window of the M-Trend program. 
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Figure 3-1: M-Trend Main Window 

Table 3-1: Main Window Callouts 
Callout Name Description 
1 Title Bar Shows name of file and program. 
2 Main Menu Bar Shows top level of available menu selections. 
3 Toolbar Provides button access to commonly used 

tools. 
4 Data Display Area Area where graphs and tables are viewed. 
5 Status Bar Provides messages about actions being 

performed. 
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M-Trend Main Window Menus 
Table 3-2 describes M-Trend menus. 

Table 3-2: M-Trend Main Window Menu Options 
Menu Command Description 
File New Creates a new, blank M-Trend document. 
 Open  Opens an M-Trend document. 
 Save Saves the current M-Trend document with a .htv extension. 
 Save As Saves the current M-Trend document with a new name. 
 Print Prints the current M-Trend view. 
 Recent File List Lists recently opened M-Trend documents. 
 Exit Exits M-Trend. 
Edit Edit Trend Opens the M-Trend Definition dialog box. 
 Set Default Connection Determines or changes M-Historian database connection. 
 Undo Zoom If the current display has any zoom factor, this command 

returns to normal view. 
View Toolbar Toggles the display of the M-Trend toolbar. 
 Status Bar If checked, displays a status bar at the bottom of the screen. 
 Progress Indicator If checked, displays percentage completed when querying 

data. 
 View Graph If checked, data appears in a graphic format. 
 View Text If checked, data appears in a text format. 
 Point Symbols When View Graph is checked, this command adds unique 

symbols to each point on the graph. Not available in Text 
View. 

 Mark Data Points When View Graph is checked, this command marks each data 
point on the graph with a small point. Not available in Text 
View. 

 Grid Lines When View Text is checked, this command adds grid lines to 
the displayed table. Not available in Graphic View. 

Refresh Data Starts or restarts the current query. Query 
Cancel Query Cancels any query in progress. 

Help Help Topics Displays the Table of Contents for the online help system. 
 About M-Trend  Displays M-Trend version and copyright information. 
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M-Trend Main Window Toolbar 
Table 3-3 describes the M-Trend toolbar buttons. 

Table 3-3: M-Trend Toolbar Buttons 
Button Name Description 

 
New Creates a new blank Trend document. 

 
Open Opens the Open File document to allow the selection and opening of 

a saved Trend document. 

 
Save Saves the current document. If the document has been saved 

previously, it overwrites it; otherwise, the Save As dialog box 
appears. 

 
Copy Copies selected text to the clipboard in View Text mode. 

 
Print Prints the current graph or table. 

 
 

About Opens the M-Trend information box to display version and copyright. 

 
Graphic View Displays data in a graphic format. 

 
Text View Displays data as text in a table. 

 
 

Refresh Data Starts or restarts the current query. 

  
 

Cancel Query Cancels any query in progress. 

 
Edit View Opens the M-Trend Definition dialog box. 

 
Point Symbols Adds unique symbols to each point on the graph. 

 
Data Points Marks each data point on the graph with a small dot. 

 
Grid Lines Toggles the horizontal grid lines on or off in Text View. 

 
Auto Scroll If automatically updating data and in Text View, selecting this button 

keeps the table scrolled to the latest entry. 
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M-Trend Right-click Menu in Graphic View 
Table 3-4 lists menu options available in Graphic View by 
right-clicking the mouse. 

Table 3-4: Right-click Menu Options 
Menu Selection Description 
Edit Trend Opens the M-Trend Definition dialog box. 
Undo Zoom If the current view has any zoom factor, this command returns it to normal 

view. 
Point Symbols When View Graph is checked, this command adds unique symbols to 

each trended data point on the graph. Not available in Text View. 
Mark Data Points When View Graph is checked, this command marks each data point on 

the graph with a small point. Not available in Text View. 
Maximize Provides a full-screen view of the current Trend View. 
Print Prints the current Trend View. 
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Procedure Overview 
Table 3-5: Getting Started 
To Do This Follow These Steps: 
Start M-Trend On the Windows Start menu select 

Programs > Johnson Controls > M-Trend. 
Select the type of database connection. 
Click OK.  

Create a New M-Trend File On the File menu, click New. 
Open an M-Trend File On the File menu, click Open. Select a file. 

Click Open. 
Zoom in on Part of an M-Trend 
Graphic View 

Left-click the mouse on the graphic and drag 
over desired portion of graphic data. 

View Detailed Trend Sample 
Information 

With Trend data displayed in either Graphic 
View or Text View, move the cursor over a 
data point. Left-click to view Trend sample 
information about the data point you have 
selected. In Text View, you must select sample 
data other than the date and time. 

Save an M-Trend File On the File menu, click Save. Enter a name for 
the file. Click Save. 

Save an M-Trend File with a 
New Name 

On the File menu, click Save As. Type in a 
new name. Click Save. 

Print an M-Trend File On the File menu, click Print. The Print dialog 
box appears. Click OK. 
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Detailed Procedures 
These procedures assume you have already installed M-Trend, defined 
a connection to, and connected to an M-Historian database. For more 
information on connecting to a database, see the Connecting M-Trend 
to a Database chapter in this manual. 

Starting M-Trend 
To start M-Trend: 
1. On the Windows Start menu, select Programs > 

Johnson Controls > M-Trend. The M-Trend Database Connection 
Dialog screen appears (Figure 3-2). 

 

Figure 3-2: M-Trend Database Connection Dialog Screen 
2. Select the type of database connection. 
Note: Choose the DSN ODBC name that connects to the 

M-Historian Database file. For Johnson Controls installed 
servers, select either Access Historian or AspenTech®. 

3. Click OK. The M-Trend Main window appears. 

Creating a New M-Trend File 
To create a new M-Trend file: 
On the File menu, click New. 
Note: If you have made any changes to the current file you are 

prompted to save it. Otherwise a new, blank document 
appears. 
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Opening an M-Trend File 
To open an M-Trend file: 
1. On the File menu, click Open. The Open dialog box appears 

(Figure 3-3). 

 

Figure 3-3: File - Open Dialog Box 
2. Navigate to the directory where your file is saved and select a file 

or type the file name in the File name box. 
3. Click Open. 

Zooming In on Part of an M-Trend Graphic View 
To zoom in on part of an M-Trend Graphic View: 
1. Left-click and hold the mouse on Graphic View in Main window 

of M-Trend. 
2. Drag the mouse to draw a rectangle over the portion of graphic 

you wish to zoom in on. A magnifying glass cursor appears as you 
drag out the rectangle. See Figure 3-4. 

3. Release the mouse button. 
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Figure 3-4: Zooming In on a View 

Viewing Detailed Trend Sample Information 
Note: Metasys® System Trend samples taken at fixed 

predetermined intervals, starting at once per minute, may 
differ from the M-Trend view that displays Point History 
data every half-hour. While these two values should be close, 
they may not be the same because they are sampled by the 
different tasks in the Network Control Module (NCM). 

In addition, the delay between sampling can be greater if 
there are many objects in the NCM that have Point History 
enabled. This occurs because of the flurry of NCM activity at 
the top and bottom of the hour and each object's position in 
the Point History list. 

To view detailed Trend sample information: 
1. Move the cursor over a data point in the sample. In Graphic View, 

the cursor turns into a hand. In Text View, the cursor does not 
change. 

Note: You can mark the data points by selecting the data point icon 
or from the menu with right mouse click. 
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2. Left-click the mouse to display detailed sample information about 
the point you have selected. See Figure 3-5 for an example of the 
sample data point information label. 

 

Figure 3-5: Viewing Detailed Sample Information 
Table 3-6 contains a description of the fields in the detailed sample 
information. 

Table 3-6: Detailed Sample Information 
Name Description 
Data Source Name of the sample point being viewed 
Data Value Numerical measurement of the sample point being viewed 
Date/Time Date and time the sample was collected 
Reliability An indication of the likelihood of the sample being correct. Not 

available for aggregate data. 
Data Offset If offsetting the values on a piece of trended data, the value of the 

offset is indicated on the offset version of the data. 
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Saving an M-Trend File 
To save an M-Trend file: 
1. On the File menu, click Save. If the file is already named, it is 

saved with the current data. Otherwise, the Save As dialog box 
appears. 

2. Enter a file name in the file name box. 
3. Click Save. 

Saving an M-Trend File with a New Name 
To save an M-Trend file with a new name: 
1. On the File menu, click Save As…The Save As dialog box 

appears. 
2. Enter a name in the File Name box. 
3. Click Save. 
Note: If you select an existing name from the File name list box 

and click Save, all existing data in the selected file is 
overwritten with the data in the current file. 

Printing an M-Trend File 
To print an M-Trend file: 
1. On the File menu, click Print. The Print dialog box appears. 
2. Click OK. 
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Troubleshooting 
Table 3-7: M-Trend Troubleshooting 
Error/Condition Problem Solution 
There is no Johnson Controls 
directory under Program Files 
on the Windows Start button. 

M-Trend has been installed to a 
different program group or not 
installed. 

Determine if it is in another 
directory or install it. 

A saved file is opened and 
there is no graph displayed. 

Data is out of range of current 
settings. 

Ensure that the study range start 
and end times are valid. 
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Chapter 4  
Connecting M-Trend to a 
Database 

Introduction 
M-Trend displays graphical and textual views of data contained in an 
M-Trend formatted, ODBC compliant M-Historian database. The data 
contained in these databases is collected from other sources, such as 
supervisory controllers, and stored in an M-Historian database. In 
order to use the database with M-Trend, you must define an ODBC 
Data Source connection for the database that provides a link, or map, 
between M-Trend and the data to be viewed. 
This chapter describes how to: 

• connect M-Trend to a defined database 

• view the name of the current database 

© May, 2000 Johnson Controls, Inc.
     Code No. LIT-6450040 
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Key Concepts 
ODBC 

Open Database Connectivity (ODBC) provides an interface to allow 
M-Trend to make a standard set of requests for data regardless of the 
actual database package used. For example, historical data could be 
stored in the format used by Microsoft Access or by AspenTech. Using 
ODBC, M-Trend can view data stored in these databases, even though 
it has no knowledge of Access or AspenTech database formats. 
Each database used by M-Trend must be registered as an ODBC data 
source provider through the ODBC Administrator. Each ODBC 
compliant database package used by M-Trend must include software 
to register itself as an ODBC driver on the client PC. 
To view, add, or remove Data Source Names (DSN) select the New 
button from the M-Trend Database Connection dialog box. 

M-Historian Database 
Database where Trend data samples are archived. It can be saved in a 
site subdirectory. 

Data Source Name (DSN) 
A DSN file is used to define a connection to an archived database for 
M-Trend to access. When defining an ODBC data source for M-Trend, 
you are naming a link, or map, to the M-Historian database. 
There are three types of DSN in the ODBC administrator: User, 
System, and File. When using Windows NT databases such as 
AspenTech, you generally use a System DSN. 
User data sources can only be used on the current machine. System 
data sources are visible to all users, including NT Services. 

DSN File Definition 
Defining a DSN is the process of defining an open connection to allow 
third-party programs that are ODBC compliant (such as Microsoft 
Excel) to view data from a database of archived Trend samples. 

Data Source Connection 
Connecting to a Data Source refers to selecting the DSN, which points 
M-Trend to the database for the site you are viewing. A saved .htv file 
automatically reconnects to the defined DSN when opened. 
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M-Trend Database: New Button 
New connections may be created for Access Historian databases 
located on a remote computer or Access Historian databases stored on 
the local computer with location/names that are different from the 
default. Refer to Appendix A: Adding Database Connections for more 
details. 
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Procedure Overview 
Table 4-1: Connecting M-Trend to a Database 
To Do This Follow These Steps: 
Connect M-Trend to a Defined 
Database 

On the Windows Start menu, select 
Programs > Johnson Controls > M-Trend. 
From the M-Trend Edit menu, click on Set 
Default Connection. Select a defined data 
source connection from the M-Trend database 
Connection dialog box and click OK. Select 
Yes or No to make this your default database 
connection. 

View the Name of the Current 
Database 

From the M-Trend Edit menu, click on Edit 
Trend. The M-Trend Sample Database screen 
appears. The name of the current database is 
in the title bar of the dialog box to the right of 
the words M-Trend Sample Database. 



 Connecting M-Trend to a Database 4-5

Detailed Procedures 
Connecting M-Trend to a Defined Database 

To connect M-Trend to a defined database: 
Note: This procedure is for a local Access database using install 

defaults or an AspenTech with client installed. 

1. On the Windows Start menu, select Programs > 
Johnson Controls > M-Trend. 

2. From the M-Trend Edit menu, click on Set Default Connection. 
The M-Trend Database Connection Dialog screen appears  
(Figure 4-1). 

 

Figure 4-1: M-Trend Database Connection Dialog Screen 
3. Select the database you want to view with M-Trend. You may 

select any previously defined database connection. 
Note: For Johnson Controls installed servers, select either Access 

Historian or AspenTech. 

If you select a type of file rather than a defined database, for 
example Excel files in Figure 4-1, the ODBC Administrator 
program opens to request further information. 

4. Click OK. A dialog box appears asking whether to set this 
database connection as your default connection. 

5. Select Yes or No. 
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Note: Connecting M-Trend to a database does not cause Trend data 
to appear on your screen. To view Trend data, you must 
define the portion of the database you wish to view. This is 
done by selecting data sources from within your database 
and defining time ranges to view. For further information, 
see the Defining M-Trend Documents chapter in this manual. 

Viewing the Name of the Current Database 
1. From the M-Trend Edit menu, click on Edit Trend. 
2. The M-Trend Sample Database Dialog box appears. The name of 

the currently connected database appears in the title bar to the 
right of the words M-Trend Sample Database. 
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Chapter 5  
Defining M-Trend Documents 

Introduction 
M-Trend documents are defined subsections or views of the default 
database. A saved M-Trend document saves the settings used in a 
particular view so that they may be recalled at a later time. See the 
Getting Started chapter in this manual for further details. This chapter 
describes M-Trend definition, which determines the data sources to be 
displayed and how they appear. 
This chapter describes how to: 

• set the General options for an M-Trend document 

• select Data Sources for an M-Trend document 

• remove Data Sources from an M-Trend document 

• set Data Range for an M-Trend document 

• set Data Source Options for an M-Trend document 

• set Plot Style for an M-Trend document 

• set fonts and colors for an M-Trend document 

© May, 2000 Johnson Controls, Inc.
     Code No. LIT-6450050 
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Key Concepts 
M-Trend Definition 

The parameters in the M-Trend Edit Properties dialog box determine 
what data is displayed in an M-Trend document, and the way it is 
displayed. 

Data Source Tab: M-Trend Definition 
Select and remove individual data items available within the database 
in the Data Source tab. 

Add Button 
Allows you to select desired data sources for display from a list of 
available archived data. Data references can be selected more than 
once in the same query. This allows comparison of the same data 
source over different times using the offset function. 

Remove Button 
Removes unwanted data sources from the current trend view. It does 
not remove data sources or samples from the database. 

Data Source Name List Box 
The list box includes all items currently involved in the M-Trend query. 

Data Range Tab: M-Trend Definition 
Set the desired range of chronological data in the Data Range tab. Use 
the default date/time format provided, or use the wild card terms 
described in the Wild Card Terms section in this chapter. 

Study Range 
The Study Range specifies the range of data that is queried for display 
within the M-Trend document. The Study Range defaults to NOW-8H 
until NOW, which reflects the last 8 hours of samples. 

Refresh Rate 
The Refresh Rate specifies the length of time between database 
updates to the screen. This parameter is only enabled if a relative study 
range has been entered, for example, TODAY or NOW. 
Note: The display changes on screen refreshes only if new samples 

have been added to the Historian database since the last 
query. 
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Wild Card Terms 
M-Trend supports wild card terms when specifying a Study Range for 
data retrieval within the Historian database. Wild card terms allow you 
to easily specify relative time-based date ranges for the retrieval of 
data. The following wild card terms are used: 

• NOW - This keyword specifies the current date/time. The value is 
set at the exact time the database request is made. 

• TODAY - This keyword specifies the current date. If no time of 
day is specified, midnight is assumed. 

• D - This keyword indicates a specific number of days. Example: 
TODAY-8D indicates a date eight days prior to the current date. 

• H - This keyword indicates a specific number of hours. Example: 
NOW-3H indicates a time three hours before the current time. 

• M - This keyword indicates a specific number of minutes. 
Example: NOW-5H30M indicates a time 5 hours and 30 minutes 
prior to the current time. 

Time may also be specified either in the standard 12 hour, a.m./p.m. 
format or in 24-hour time. For example, 12/12/97 12:00:00 p.m. and 
12/12/97 23:00:00 are valid parameters. 
Note: Time and date formats allowed follow the regional time/date 

format setting in the Windows operating system. 

Data Source Options Tab: M-Trend Definition 

Data Source Name 
This drop-down box allows you to select one of the data sources you 
have added to your Trend document in the Data Source. 

Data Source Description 
Allows you to give a descriptive name to the data source that is 
selected in the Data Source Name list box. This description is then 
used as a label for the data source on graphs or tables. 

Units 
Allows you to label the value of units on the Y-axis in graphical view. 
The units specified are also included in the column label of text views. 

Time Offset 
The time offset feature allows you to shift the time line of a data 
source in order to compare different time ranges of the same data 
source, for example, to compare yesterday’s temperature to today’s. 
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Pen 
The Pen commands, Pen Style and Pen Color, allow you to customize 
the look of the plotted line for each individual data source. 

Aggregate Functions 
Aggregate functions, in databases that support them such as the 
AspenTech Historian, allow you to perform statistical functions on the 
data in an M-Trend query in order to allow various types of analysis of 
the data. You must set a data interval in order to use aggregate 
functions. The data interval allows you to set the amount of time 
between samples you are performing the aggregate functions on. 
M-Trend supports the following aggregate functions: 
All Data - Shows all available data. This is the default and is also the 
only available option for queries on databases that do not support 
aggregate functions. 
Average - Returns the average (arithmetic mean) of the values of the 
selected data source. 
Maximum - Returns the largest values in a set of values. 
Minimum - Returns the smallest values in a set of values. 
Range - Returns the difference between the Minimum and Maximum 
values in a set of values. 
Standard Deviation - Estimates standard deviation based on a 
sample. The standard deviation is a measure of how widely values are 
dispersed from the average value (the mean). 
Sum - Adds all the numbers in a range of data sources. 
Variance - Estimates variance based on a sample. 

Y Axis Range 
For stacked graphs, allows the override of calculated ranges. 

Plotting Methods 
Continuous plotting assumes a linear change in value between samples 
and draws a straight line between them. Discrete plotting follows the 
assumption that each sample is an event, that is, the value changes 
abruptly for each new sample, with the value staying constant until the 
next sample is plotted. In Figure 5-1 the same data source is plotted 
with continuous plotting (dark line) and discrete plotting (gray line). 
Note that the larger the sample you are looking at, the less apparent the 
differences are. 
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Figure 5-1: Continuous vs. Discrete Plotting 

Plot Style Tab: M-Trend Definition 
The Plot Style tab lists different plotting styles for each Y-axis used. 
The following plotting styles are available: 

• Area Graph 

• Bar Graph 

• Line Graph 

• Points Graph 

• Points + Line Graph 

• Points + Spline Graph 

• Spline Graph 

Mark Data Points 
This option marks each data point on the graph with a small dot. 
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Fonts/Colors Tab: M-Trend Definition 
Change the visual display of the graph in the Fonts/Colors tab. 

Font 
The Fonts/Colors tab allows you to change the fonts associated with 
all text displayed on the graph. You may also bold, italicize, or 
underline text for emphasis. 

Color 
The Fonts/Colors tab allows you to change various foreground and 
background colors. 

Query 
A request by M-Trend for information from the current database. The 
M-Trend document shows the results of the most recent query. 
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Procedure Overview 
Table 5-1: Defining M-Trend Documents 

To Do This Follow These Steps: 
Set General Options for an 
M-Trend Document 

On the Edit menu, select Edit Trend. Select 
the General tab. Fill in the fields. Click OK. 

Select the Data Sources for an 
M-Trend Document 

On the Edit menu, select Edit Trend. Select 
the Data Source tab. Click Browse. Select data 
sources from the list. Click Add. Click OK. 

Remove Data Sources from an 
M-Trend Document 

On the Edit menu, select Edit Trend. Select 
the Data Source tab. Select a data source 
from the list. Click Remove. Click OK. 

Set Data Range for an M-Trend 
Document 

On the Edit menu, select Edit Trend. Select 
the Data Range tab. Fill in the fields. Click OK. 

Set Data Source Options for an 
M-Trend Document 

On the Edit menu, select Edit Trend. Select 
the Data Source Options tab. Select a Data 
Source Name. Fill in the fields. Click OK. 

Set Plot Style for an M-Trend 
Document 

On the Edit menu, select Edit Trend. Select 
the Plot Style tab. Fill in the fields. Click OK. 

Set Fonts and Colors for an 
M-Trend Document 

On the Edit menu, select Edit Trend. Select 
the Fonts/Colors tab. Choose the fonts, font 
styles, and colors desired. Click OK. 
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Detailed Procedures 
The following procedures assume M-Trend is already connected to a 
Historian database. For instructions on connecting to a data source or 
information about data types in general, please refer to Connecting 
M-Trend to a Database in this manual. 

Setting General Options for an M-Trend Document 
To set the General options for an M-Trend document: 
1. On the Edit menu, select Edit Trend or click the Edit View icon. 

The M-Trend Definition dialog box appears (Figure 5-2). 

 

Figure 5-2: M-Trend Definition Dialog Box: General Tab 
2. Select the General tab. 
3. Fill in the fields using Table 5-2. 
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Table 5-2: General Tab 
Field Description 
Main Title Title displayed with M-Trend document when displayed. Default 

file name when saving document. 
Sub Title Additional heading to be associated with the given M-Trend 

document. 
Grid Lines: Show X axis grid lines. Toggles the horizontal grid lines in Graphic View. 
Grid Lines: Show Y axis grid lines. Toggles the vertical grid lines in Graphic View. 
Numeric Precision Determines precision of data by specifying the number of digits 

to be displayed after the decimal point. 
Y Axis Mode: Fixed Y axis Used to view individual data sources on the same graph. 
Y Axis Mode: Stacked Y axis Allows the viewing of separate data sources to compare sources 

of different scales. The first six data source names are graphed. 
Fixed Y Axis Range: High Allows the setting of an upper boundary for the Y axis. Data that 

is higher is truncated in the Graphic View. When set to Auto, the 
upper limit of the Y axis is based on available data. 

Fixed Y Axis Range: Low Allows the setting of a lower boundary for the Y axis. Data that is 
lower is truncated in the Graphic View. When set to Auto, the 
lower limit of the Y axis is based on available data. 

Load table at startup. Allows you to load both the graph and the table simultaneously. 
Default is unchecked, which loads graph only on startup. 

 
4. Click OK. 
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Selecting Data Sources for an M-Trend Document 
To select Data Sources for an M-Trend query: 
1. On the Edit menu, select Edit Trend or click the Edit View icon. 

The M-Trend Definition dialog box appears (Figure 5-2). 

 

Figure 5-3: M-Trend Definition Dialog Box: Data Source Tab 
2. Select the Data Source tab. Figure 5-3 shows a Data Source tab 

with several Data Source Names. 
3. Type the Data Source Name or click the Browse button for a list 

of available data sources (Figure 5-4). 
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Figure 5-4: Add Data Source Dialog Box 
4. Select up to 32 data sources and click Add. 
5. Click Done to return to the M-Trend Definition screen  

(Figure 5-3). 
Notes: Only the first six Data Source Names listed in the Data 

Source tab are shown in the graph. Samples from all 32 Data 
Sources are displayed in the text view. 
Data Source Names that do not appear in a graphical view 
because they are not in the first six listed on the Data Source 
tab can be repositioned so they do appear on the graph. 
Reposition them by selecting and dragging into the top six. 

You may select the same data source multiple times by 
clicking add more than once. 

6. Click OK in the M-Trend Definition dialog box. 
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Removing Data Sources for an M-Trend Document 
To remove Data Sources from an M-Trend query: 
1. On the Edit menu, select Edit Trend or click the Edit View icon. 

The M-Trend Definition dialog box appears (Figure 5-2). 
2. Select the Data Source tab. Figure 5-3 shows a Data Source tab 

with several Data Source Names. 
3. Select the data source you want removed and click Remove. 
4. When finished removing data sources, click OK. 
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Setting Data Range for an M-Trend Document 
To set the Data Range options for an M-Trend document: 
1. On the Edit menu, select Edit Trend or click the Edit View icon. 

The M-Trend Definition dialog box appears. 

 

Figure 5-5: M-Trend Definition Dialog Box: Data Range Tab 
2. Select the Data Range tab (Figure 5-5). 
3. Fill in the fields using actual dates and times or wild cards. See 

the Key Concepts section of this chapter for a discussion of 
available wild card terms. 

4. Set Refresh Rate to set the length of time between database 
updates to the screen. 
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Note: This parameter is only enabled when a relative study range is 
selected using wild cards such as Today or Now. The view 
changes only if new samples have been added to the 
database since the last time the query was requested. 

5. Click OK. 

Setting Data Source Options for an M-Trend Document 
To set the Data Source options for an M-Trend document: 
1. On the Edit menu, select Edit Trend or click the Edit View icon. 

The M-Trend Definition dialog box appears. 

 

Figure 5-6: M-Trend Definition Dialog Box: 
Data Source Options Tab 

2. Select the Data Source Options tab (Figure 5-6). 
3. Fill in the fields using Table 5-3. 
4. Click OK. 
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Table 5-3: Data Source Options Tab 
Field Description 
Data Source Name Drop down box that allows you to select which data source is 

currently available for editing. 
Data Source Description You may add text to represent the present data source. If text is 

entered, it replaces the data source name in the graph legend. 
Units Allows you to override the default engineering units. Units specified 

here are seen in both the graph and grid. 
Time Offset The time value entered for the time offset is subtracted from the 

current data range and plotted on it. For example, if the offset set to 
one day, the data from the day before is plotted on today’s time 
range. 
Note that to compare data from the same data source at different 
times, the offset version should be given the same name with 
different capitalization. That is “99.Outside Air” can be compared to 
an offset “99.outside air” to use the offset capability. 

Pen Style Allows you to set line options such as thickness and solid or dotted. 
Pen Color Specifies color of individual data sources in graph. 
Aggregate Functions: Function All Data - Shows all available data. 

Average - Returns the average (arithmetic mean) of the values of the 
selected data sources. 
Maximum - Returns the largest value in a set of values. 
Minimum - Returns the smallest number in a set of values. 
Range - Returns the difference between the Minimum and Maximum 
values in a set of values. 
Standard Deviation - Estimates standard deviation based on a 
sample. 
Sum – Adds all the numbers in a range of data sources. 
Variance - Estimates variance based on a sample. 

Aggregate Functions: Data Interval Determines the interval between samples on which the aggregate 
data is calculated. 

Y Axis Range: High For stacked graphs, allows override of the calculated ranges. 
Y Axis Range: Low For stacked graphs, allows override of the calculated ranges. 
Plotting Method: Continuous Data Assumes a linear change in value between samples and draws a 

straight line between them. 
Plotting Method: Discrete Data Shows each sample as an event, that is, the value changes abruptly 

for each new sample, with the value staying constant until the next 
sample is plotted. 
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Setting Plot Style for an M-Trend Document 
To set the Plot Style for an M-Trend document: 
1. On the Edit menu, select Edit Trend or click the Edit View icon. 

The M-Trend Definition dialog box appears. 

 

Figure 5-7: M-Trend Definition Dialog Box: Plot Style Tab 
2. Select the Plot Style tab (Figure 5-7). 
3. Select the Axis and Plot Style you want for the current document. 
4. Select Mark Data Points if you would like each data point to be 

marked with a small dot in Graphic View. 
5. Click OK. 



 Defining M-Trend Documents 5-17

Setting Fonts and Colors for an M-Trend Document 
To set the fonts and colors for an M-Trend document: 
1. On the Edit menu, select Edit Trend or click the Edit View icon. 

The M-Trend Definition dialog box appears. 

 

Figure 5-8: M-Trend Definition Dialog Box: 
Fonts/Colors Tab 

2. Select the Fonts/Colors tab (Figure 5-8). 
3. Select the fonts you want for the current document. Clicking on 

the browse button displays a list of available fonts and styles. 
4. Select bold, italic, or underline if desired. 
5. Click on a colored box in the colors section of the dialog box to 

open the color palette. Select a new color. 
6. Click OK. 
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Chapter 6  
M-Trend ActiveX Control 

Introduction 
The M-Trend ActiveX control allows you to create M-Trend graphs in 
ActiveX -compliant programs. Although there is a separate procedure 
for inserting the ActiveX control, the control object is connected to a 
database, defined, and edited in the same manner described in the rest 
of this manual. This chapter describes how to: 

• insert the M-Trend ActiveX control in an M-Graphics display 

• navigate to the M-Trend menus in an M-Trend ActiveX control in 
an M-Graphics display 

• save M-Trend parameters in an M-Graphics document 

© May, 2000 Johnson Controls, Inc.
      Code No. LIT-6450060 



 Operator’s Guide 6-2 

Key Concepts 
ActiveX 

A loosely defined set of technologies developed by Microsoft. 
ActiveX is an outgrowth of two other Microsoft technologies called 
OLE (Object Linking and Embedding) and COM (Component Object 
Model). ActiveX applies to a whole set of COM-based technologies. 
ActiveX is not a programming language, but rather a set of rules for 
how applications should share information. 

ActiveX Controls 
ActiveX controls represent a specific way of implementing ActiveX 
technologies. They can be used to provide limited functionality of an 
application, such as M-Trend, without having to have the entire 
program downloaded to a machine. 

M-Trend ActiveX Control 
An ActiveX control that allows the display of M-Trend graphs in 
M-Graphics displays, or in other ActiveX-compliant applications such 
as Internet Explorer 4. Using the M-Trend ActiveX control, a user can 
put multiple M-Trend graphs into an M-Graphics display. 
Note: The M-Trend ActiveX Control does not allow you to view 

M-Trend documents (.htv files) in other applications. 

When an M-Trend ActiveX control is created in an M-Graphics 
display, the information for the M-Trend graph is saved in the 
M-Graphics document. Therefore, instead of having a separate .htv file 
for the M-Trend information, the M-Trend information is accessed 
when the M-graphics document (.gdf file) is opened. 

M-Graphics 
An OPC (OLE for Process Controls) graphics package from 
Johnson Controls. Allows the user to create dynamic, animated 
graphics to represent the controls processes in a facility. 
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Expanded Right-click Menu in an M-Trend ActiveX Control 
When an M-Trend ActiveX control is inserted in an ActiveX 
compliant application, some of the menu options that are present in the 
M-Trend program menu bar are accessed through an expanded 
right-click menu (Figure 6-1). See Table 6-1 for a description of the 
options. 

 

Figure 6-1: M-Trend ActiveX Control: 
Expanded Right-click Options 

Table 6-1 describes the expanded right-click menu options used in the 
M-Trend ActiveX Control. 

Table 6-1: M-Trend ActiveX Control: Expanded Right-click Options 
Menu Selection Description 
Edit Trend Opens the M-Trend Definition dialog box. 

Undo Zoom If the current view has any zoom factor, this command returns it to 
normal view. 

Point Symbols When View Graph is checked, this command adds unique symbols to 
each trended data point on the graph. Not available in Text View. 

Mark Data Points When View Graph is checked, this command marks each data point 
on the graph with a small point. Not available in Text View. 

Progress Indicator When checked, provides a visual indication of percentage completed 
when querying data. 

Set Default Database Determines or changes the Historian database connection. 
Refresh Data Starts or restarts the current query. 
Cancel Query Cancels any query in progress. 



 Operator’s Guide 6-4 

Procedure Overview 
Table 6-2: M-Trend ActiveX Control 

To Do This Follow These Steps: 
Insert an M-Trend ActiveX 
Control in an M-Graphics 
Display 

On the M-Graphics Edit menu, select Insert 
New Object. The Insert Object dialog box 
appears. Choose Create Control. Scroll to and 
select Johnson Controls M-Trend Control. 
Select OK. 

Navigate to the M-Trend 
Menus in an M-Trend ActiveX 
Control in an M-Graphics 
Display 

Accessing the M-Trend Definition Dialog 
box: With M-Graphics in Configure mode, 
right-click the M-Trend ActiveX control. From 
the Johnson Controls M-Trend Control Object 
menu, select Properties. 
Accessing the expanded right-click menu 
for M-Trend ActiveX controls: With 
M-Graphics in Configure mode, right-click the 
M-Trend ActiveX control. From the Johnson 
Controls M-Trend Control Object menu, select 
Edit. A black line appears around the M-Trend 
ActiveX control. Right-click the M-Trend 
ActiveX control again to see the expanded 
right-click menu. 
With M-Graphics in Runtime mode, right-click 
the M-Trend ActiveX control. 

Save M-Trend Parameters in 
an M-Graphics Document 

After inserting the M-Trend ActiveX control, 
setting a database connection, and defining 
the M-Trend graph in an M-Graphics 
document, choose Save or Save As from the 
File menu. M-Graphics must be in Configure 
mode to access these menu selections. 
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Detailed Procedures 
Inserting an M-Trend ActiveX Control in an M-Graphics Display 

To insert an M-Trend ActiveX control into M-Graphics display: 
1. On the Edit menu, select Insert New Object. The Insert Object 

dialog box appears (Figure 6-2). 
2. Choose Create Control on the Insert Object dialog box. 
3. Scroll to and select Johnson Controls M-Trend Control. 

Add Control...

Insert Object ?

Create from ileF

Create ontrolC

Create ewN

Object Type:

Johnson Controls M-Graphics Control
InstallEngineCtl Object
Ikonic Menu Control

Label Object
LM Runtime Control
Macromedia Shockwave Director Co

Johnson Controls M-Trend Control

Result
Inserts a new Johnson Controls M-Trend Control
object into your document.

OK

Cancel

add_ctrl  

Figure 6-2: Insert Object Dialog Box 
4. Click OK. 
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Navigating to M-Trend Menus in an M-Trend ActiveX Control in an 
M-Graphics Display 

An M-Trend ActiveX Control in an M-Graphics display is connected 
to a database, defined, and edited in the same manner as described in 
the rest of this document. However, there are some differences in how 
you get to the menus and screens. Since there is no edit menu for  
M-Trend within M-Graphics, the default database connection is set 
through an expanded right-click menu. 

Accessing the M-Trend Definition Dialog Box 
1. With M-Graphics in Configure mode, right-click the M-Trend 

ActiveX control. A list of options appears (Figure 6-3). 
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Cu
opy
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Figure 6-3: Right-click Menu for an Unselected M-Trend 
ActiveX Control in an M-Graphics Display 

2. Select Properties (Figure 6-3) from the Johnson Controls M-Trend 
Control Object menu. The M-Trend Definition screen appears 
allowing you to define the M-Trend graph as described in 
Defining M-Trend Documents in this manual. 

Accessing the Expanded Right-click Menu for M-Trend 
ActiveX Controls 
1. With M-Graphics in Configure mode, right-click the M-Trend 

ActiveX control. A list of options appears (Figure 6-3). 
2. Select Edit (Figure 6-3) from the Johnson Controls M-Trend 

Control Object menu. A black line appears around the M-Trend 
ActiveX Control object. 

3. Right-click with the cursor over the M-Trend ActiveX control. 
The M-Trend ActiveX control’s right-click menu appears  
(Figure 6-4). 
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Note: The right-click menu in the M-Trend ActiveX control is an 
expanded set of the right-click menu when running the full 
M-Trend application. This is to allow the setting of 
necessary parameters that would be accessed through the 
main menu bar in the full M-Trend application. 

4. See Chapters 3 through 5 in this manual for details on setting 
M-Trend options. 

 

Figure 6-4: M-Trend ActiveX Control: 
Expanded Right-click Options 

Saving M-Trend Parameters in an M-Graphics Document 
To save M-Trend parameters in an M-Graphics document: 
1. Insert, set the database connection, and define the M-Trend graph 

as described in this manual. 
2. With M-Graphics in Configure mode, select save or save as from 

the file menu. 
3. Name your M-Graphics document and select OK. The parameters 

of your M-Trend graph are saved within the M-Graphics 
document. 
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Appendix A  
Adding Database Connections 

Introduction 
This appendix contains information about adding connections to 
databases created after the initial installation. You add connections to a 
database when you do not want to use the default. This chapter 
describes how to: 

• add new connections to a Microsoft Access Historian database 

• add new connections to a AspenTech Historian database 

© May, 2000  Johnson Controls, Inc.
      Code No. LIT-6450070 
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Key Concepts 
ODBC 

Open Database Connectivity (ODBC) provides an interface to allow 
M-Trend to make a standard set of requests for data regardless of the 
actual database package used. For example, historical data could be 
stored in the format used by Microsoft Access or by AspenTech. Using 
ODBC, M-Trend can view data stored in these databases, even though 
it has no knowledge of Access or AspenTech database formats. 
Each database used by M-Trend must be registered as an ODBC data 
source provider through the ODBC Administrator. Each ODBC 
compliant database package used by M-Trend must include software 
to register itself as an ODBC driver on the client PC. 
To view, add, or remove Data Source Names (DSN) select the New 
button from the M-Trend Database Connection dialog box.  

M-Historian Database 
Database where Trend data samples are archived. It can be saved in a 
site subdirectory. 

Data Source Name (DSN) 
A DSN file is used to define a connection to an archived database for 
M-Trend to access. When defining an ODBC data source for M-Trend, 
you are naming a link, or map, to the M-Historian database. 
There are three types of DSN in the ODBC administrator: User, 
System, and File. When using Windows NT databases such as 
AspenTech, you generally use a System DSN. 
User data sources can only be used on the current machine. System 
data sources are visible to all users, including NT Services. 

DSN File Definition 
Defining a DSN is the process of defining an open connection to allow 
third-party programs that are ODBC compliant (such as Microsoft 
Excel) to view data from a database of archived Trend samples. 

Data Source Connection 
Connecting to a Data Source refers to selecting the DSN, which points 
M-Trend to the database for the site you are viewing. A saved .htv file 
automatically reconnects to the defined DSN when opened. 
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Procedure Overview 
Table A-1: Connecting M-Trend to a Database 
To Do This Follow These Steps: 
Add New Connections to a 
Microsoft Access Historian 
Database 

From the M-Trend Edit menu, click on Set 
Default Connection. Click New. On the ODBC 
Data Source Administrator, choose the User 
tab. Click Add. Select a database driver for 
your data source. Click Finish. Enter a name 
and description for the data source connection 
you are defining. Click Select. Browse to, and 
select, the desired database. Click OK. Click 
OK again. 

Add New Connections to an 
AspenTech M-Historian 
Database 

From the M-Trend Edit menu, click on Set 
Default Connection. Click New. On the ODBC 
Data Source Administrator, choose the System 
tab. Click Add. Select a database driver for 
your data source. Click Finish. Enter a name 
and description for the data source connection 
you are defining. Click Select. Browse to, and 
select, the desired database. Click OK. Click 
OK again. 
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Detailed Procedures 
Adding New Connections to a Microsoft Access Historian Database 

To define a connection to a Microsoft Access Historian database: 
Note: For a remote Access database on another platform or a local 

Access base that did not use installed defaults. 

1. From the M-Trend Edit menu, click on Set Default Connection. 
The M-Trend Database Connection Dialog box appears  
(Figure 4-1). 

2. Click New… The ODBC Data Source Administrator dialog box 
appears (Figure A-1). 

 

Figure A-1: ODBC Data Source Administrator Dialog Box - 
System DSN Tab Selected 

3. Click Add. The Create New Data Source dialog box appears  
(Figure A-2). 



 Adding Database Connections A-5

 

Figure A-2: Create New Data Source Dialog Box 
4. Select the driver for the data source you are defining a connection 

for and click Finish. The ODBC Setup screen for the driver you 
select appears. 

Note: Choose Microsoft Access Driver if using Access Historian. 

 Figure A-3 shows the ODBC Microsoft Access 97 Setup screen 
when choosing a Microsoft Access Driver. 

 

Figure A-3: Microsoft Access 97 ODBC Driver Setup Screen 
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5. In the appropriate boxes, enter a Name and Description for the data 
source you are defining. The name you give your data source is the 
name that appears in the M-Trend Database Connection Dialog 
screen (Figure 4-1). This occurs when you click on Set Default 
Connection in the Edit menu after a connection is defined. 

6. Under the Database section of the ODBC Setup screen  
(Figure A-3), click on Select… The Select Database screen appears 
(Figure A-4). 

 

Figure A-4: Select Database Screen 
7. Browse to and select a data source, then click OK. The ODBC 

Setup screen reappears (Figure A-3). 
8. Click OK. The ODBC Data Source Administrator dialog box 

reappears (Figure A-1). The Database connection you just defined 
should be one of the user data sources listed. 

9. Click OK. The M-Trend database Connection Dialog screen 
reappears (Figure 4-1) with the database connection you just 
defined added to it. 

10. Select the defined database connection you wish to connect 
M-Trend to, and click OK. 

11. Answer Yes or No if you want this to be your default data 
connection. 

Note: Connecting to a Machine Data Source does not cause Trend 
data to appear on your screen. To view Trend data, you must 
define the portion of the database you wish to view. This is 
done by selecting data sources from within your database 
and defining time ranges to view. For further information, 
see the Defining M-Trend Documents chapter in this manual. 
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Adding New Connections to an AspenTech M-Historian Database 
To define a connection to an AspenTech M-Historian database: 
Note: For an AspenTech database that did not use the install 

defaults. Client already installed. 

1. From the M-Trend Edit menu, click on Set Default Connection. 
The M-Trend database Connection Dialog box appears  
(Figure 4-1). 

2. Click New… The ODBC Data Source Administrator dialog box 
appears. 

3. Select the System DSN tab. Figure A-5 shows the ODBC Data 
Source Administrator (with the System DSN tab selected). 

 

Figure A-5: ODBC Data Source Administrator Dialog Box - 
System DSN Tab Selected 

4. Click Add. The Create New Data Source dialog box appears  
(Figure A-6). 
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Figure A-6: Create New Data Source Dialog Box 
5. Select the driver for the data source you are defining a connection 

for and click Finish. The ODBC Setup screen for the driver you 
select appears. Figure A-7 shows the SQLplus Setup screen that 
appears when an AspenTech driver is selected. 

 

Figure A-7: SQLplus ODBC Setup Screen for 
AspenTech M-Historian Database 

6. In the appropriate boxes, enter a Name and Description for the data 
source you are defining. This is the name that appears in the M-
Trend database Connection Dialog screen (Figure 4-1). 

Note: You must define the TCP/IP Host and Port. 
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7. (This step is for Advanced users only; all others go to Step 9.) 
Click Advanced. The SQLplus Advanced Setup screen appears 
(Figure A-8). 

 

Figure A-8: SQLplus Advanced Setup 
8. Fill in the fields according to Table A-2 and click OK. The 

SQLplus ODBC Setup screen reappears (Figure A-7). 
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Table A-2: SQLplus Advanced Setup Fields 
Field Description 
Maximum Rows Maximum number of rows that is returned when a 

query is run. 
Timeout Maximum amount of time that the driver allows a query 

to continue before it aborts. 
Table list record If blank, allows access to all tables. When a list is 

entered, allows access to only the tables that appear 
in the list. 

Integers sent as 
Character 

Allows integer data to be returned either by integer 
value or by character strings. 

Reals sent as 
Character 

Allows Reals to be returned as either floating point 
values or character strings. 

Timestamp sent as 
Character 

Allows timestamps to be returned as either double 
precision values or character strings. Do not check 
this box if using a different time format than U.S. 
standard. 

“SELECT” returns 
fields in all repeat 
areas 

Controls the way the SELECT statement returns fields. 

Return ROWID as key 
field 

Returns AspenTech ROWID field with the query. 

Read-Only Sets the current connection to the database as read 
only. No writing permitted. Not applicable to M-Trend. 

 
9. Click OK. The ODBC Data Source Administrator dialog box 

reappears (Figure A-5). 
Note: The database connection you just defined should be one of 

the system data sources listed. 

10. Click OK. The M-Trend Database Connection Dialog screen 
reappears (Figure 4-1) with the database connection you just 
defined added to it. 

11. Select the defined database connection you wish to connect 
M-Trend to, and click OK. 

12. Answer Yes or No if you want this to be your default data 
connection. 

Note: Connecting to an ODBC Data Source does not cause Trend 
data to appear on your screen. To view Trend data, you must 
define the portion of the database you wish to view. This is 
done by selecting data sources from within your database 
and defining time ranges to view. For further information, 
see the Defining M-Trend Documents chapter in this manual. 
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