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RTT DeltaGen 10.0.2

The New Benchmark for Efficiency
RTT DeltaGen 10.0.2 sets new benchmarks for visualization workflows. 

The innovations of the latest release effect the entire product life cycle, from design 
to engineering to marketing and sales. 

With amazingly efficient data handling, visual perfection, the highest quality 
performance, extensive functionality and complete flexibility, RTT DeltaGen 10.0.2 
is the world's leading software solution for 3D visualization in realtime.



System requirements

These requirements represent the capacity required to run RTT DeltaGen and RTT 
DeltaView and also for processing the 3D scenes that will be loaded.

Only nVidia Quadro / Quadro FX graphics cards are currently capable of displaying 
all visual effects and shaders created with RTT software. This cannot be guaranteed 
with graphics cards from other manufacturers. 

See also the constantly updated information on our Internet site. 

Minimum Recommendation

General

Operating system RTT DeltaGen / DeltaView / DeltaBatch / DeltaTex
_ Windows 7 x64 Edition and Windows 7 32-bit
_ Windows XP x64 Edition (Service Pack 2)
_ Windows XP (Service Pack 3)
For license server only:
_ Sun Solaris 10 for SPARC 64 
_ Red Hat Enterprise Linux WS Release 4, 64-bit AMD 

Opteron Systems
Covise CFD Server (for using RTT RealFluid):
_ Windows XP x64 SP2 
_ Linux openSUSE 10.2

Monitor resolution RTT DeltaView: 1024 x 768
RTT DeltaGen: 1280 x 1024

RTT DeltaView: 1280 x 1024
RTT DeltaGen: 1680 x 1050

Supplementary 
software

Adobe Flash Player 9.0 
(for Presenter GUI and RTT PictureBook Browser)
Adobe Flash Player 11 Plug-in (Internet Explorer) for RTT 
DeltaTex1

Apple QuickTime Player (for QuickTimeVR export)
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System requirements

 

Workstation

RAM 2 3 GBytes
16 GByte for GPU RealTrace 

3 GBytes 
8 GByte for Windows XP x64
and Windows7 x64
For cluster installation with 
RTT Scale under 
Windows XP x64 and 
Windows 7 x64: 16GB

Processor Intel Core 2 Duo Intel Xeon DP or MP, Intel 
Core 2 Duo/Quad/Extreme 
with 3 GHz
Dual QuadCore for GPU 
RealTrace

Graphics card3 nVidia Quadro FX 4600 
(chipset G80 for RealTrace)
nVidia Quadro FX5600
for GPU RealTrace
Graphics-card with CUDA-
support for GPU Raytracing 
(min. nVidia Quadro FX 
5800)

nVidia Quadro FX 5800 
(chipset GT200)
nVidia Quadro 6000
(chipset GF100) for GPU 
RealTrace
G-Sync add-on card 
(for Powerwall setup)
GPU Raytracing: Use of 2 
Graphics cards 
recommended

Multi-GPU:
nVidia Quadro Plex Model IV (2 x FX 5600)
nVidia Quadro Plex 2200 D2 (2 x FX 5800)

Graphics driver Quadro FX and Quadro graphic cards      Version 270.71 

Network card For cluster installation with RTT Scale and 1Gigabit 
Ethernet:
_ Intel Gigabit CT Desktop Adapter
_ Intel Gigabit ET Dual Port Server Adapter
For cluster installation with RTT Scale and Infiniband:
_ Mellanox IpoIB Adapter

Network switch RTT Scale:
If you want to use multicast, the network switch must 
support multicast.

Minimum Recommendation
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System requirements
1 RTT DeltaTex 64 Bit needs a very recent version of Flashplayer 11 (64 Bit) to run, 
which can be downloaded using the following link:

http://download.macromedia.com/pub/labs/
flashplatformruntimes/flashplayer11/
flashplayer11_b2_install_win_ax64_080811.exe

2 MultiGPU option: The minimum of RAM corresponds to the maximum size of the 
graphic card memory used.

3 Systems with PCI-Ex16 support.

Laptop

RAM 2 GBytes 3 GBytes

Processor Pentium 4 Mobile Pentium M

Graphics card nVidia Quadro FX 1600 M nVidia Quadro FX 3600 M

Graphics driver Provided by respective laptop manufacturer. Always use 
the manufacturer's latest driver.

Camera connection

RTT DeltaTex WolfVision VZ series: USB or DVI frame-grabber card
Samsung SPD series: DVI frame-grabber card
Other cameras (support on inquiry only): USB

RTT RealView The Imaging Source DFK31AF03: FireWire
Logitech QuickCam Pro 9000: USB
Lumenera LU135C (or together with fisheye lens from 
Fujinon FE 185C 046 HA-1 for displaying reflections): USB
Canon HV30: FireWire or HDMI
Other cameras (support on inquiry only): USB

Minimum Recommendation
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New features

RTT DeltaGen 10.0.2

RTT Konverter

Several new import formats have been added. The following formats are now 
importable in RTT DeltaGen 10.0.2:

System Format Version RTT Konverter Remarks
In RTT DeltaGen und RTT DeltaView plus 
SGI Inventor IV

STL
VRML WRL
In RTT DeltaGen

PLMXML 4, 6 Contains th
structure 
information
module 

Catia V4 MODEL, EXP, 
DLV, session

4.x.x RTT DirectCatiaV4

Catia V5 CATPART, 
CATPRODUCT,
CGR

from R10 bis 
R20

RTT DirectCatiaV5

AliasStudio WIRE 12, 13, 13.5, 
2008, 2009, 
2010, 2011, 
2012

RTT DirectWire

MotionBuilder FBX RTT DirectFBX Only polygo
skin animat

Rhino 3DM 3.0, 4.0 RTT DirectRhino
Pro/Engineer PRT, ASM from 13 to 

Wildfire 5
RTT DirectProE
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New features

t-Nurbs 
PS Light 

eavy 
tadata

in that 
 imports 
Further read converters on request.

For the use of RTT converters an appropriate License is needed.

Import Dialogs

The import dialog for all importable formats has been consolidated. For every 
importable format it now shows only the options that are relevant for that format.

The function Unify surface normals has been dropped out of the import dialog, 
because it is executed by default since NURBS on demand have been introduced.

Pro/Engineer NEU from 13 to 
Wildfire 5

RTT DirectProE

AutoCAD DWG from 2.5 to 
2008

RTT 
DirectAutoCAD

IGES IGS, IGES from 5.2 to 
5.3

RTT DirectIges

STEP STP, STEP AP 203/AP 
214

RTT DirectStep

Unigraphics 
Parasolid

X_T up to V22 RTT 
DirectUnigraphics

JT-Open JT from 7.0 to 
9.5

RTT DirectJT Polygons, J
and XT-BRE
weight & H
weight, Me

NX PRT, ASM from 11 to 
NX7.5

RTT 
DirectUnigraphics

NX ARC, UNV up to NX5 RTT DirectIdeas
SolidWorks SLDPRT, 

SLDASM
up to 2011b RTT 

DirectSolidWorks
In Autodesk Maya
Maya CSB 7.0, 8.0, 8.5, 

2008 - 2012
RTT DirectMaya Maya plug-

exports and
CSB
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New features
It is still manually executable by choosing Geometry > Unify surface normals 
from the main menu.

The visibility handling has been simplified. Only the visible or all objects can be 
imported. The option to import only invisible objects has been dropped.

These changes also affect the Open with smartsteps and the Template import 
dialog.

Deltagen 10.0

File Handling

Recent Files
File > Recent files shows a list of recently opened files, which enables you to 
open them faster and more easily.

Template dialog window Smart steps dialog window
Realtime Technology AG 2011 Release Notes 7



New features
Object and geometry editing

Object editor

Multi selection edit

If you make a multiple selection, the object editor displays the values of all 
selected objects. For different object types, only the values the objects have in 
common are displayed for editing. 

You can edit values for multiple-selected objects simultaneously. For numeric 
values, you can enter an absolute and a relative value. If you enter a relative value, 
a formula is inserted following the field content (such as * 3 or - 1.5). This formula 
is then applied to all objects of the selection.

Scene tree
The scene tree now displays properties of objects:

_  Visibility

_  Is A-side

_  Override Look

_  High Quality Look

_  Light Object

You can change the order of the icons in the title bar by drag & drop; if you click 
the small triangle on the right of the icons in the title bar, a menu opens in which 
you can enable and disable individual icons.
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New features
The scene tree expansion control opens the scene tree only down to the shells/
wiresets to retain clarity and keep the memory requirements of the scene low. 

Camera

Look at object

The object editor of the camera now contains the new Look at object option. You 
use this option to define an object as a camera target.

You assign the target object by clicking the Pick Target icon and then selecting the 
target object, or by entering the target object in the adjacent text field. If you 
enable Look at Object, the camera remains pointed to this object during 
navigation, animation or variant switching.

Combine geometries
Geometry > Combine geometries converts NURBS data to the body/shell 
structure. However, in contrast to earlier versions, the NURBS data is not deleted.

To delete NURBS data, select Geometry > NURBS > Remove NURBS 
information. Bodies are then converted to groups and shells/wiresets to 
shapes.

You can still combine shapes that have the same look into a single shape.
Realtime Technology AG 2011 Release Notes 9



New features
Topology
The Topology dialog is now a separate, dockable dialog box.

Topology detection has been separated from tessellation which avoids unwanted 
new topology computations. 

The topology can be refined without making a completely new topology 
computation. This is done by pressing the Update Topology button.

The No topology function and the LOD options New topology for each LOD 
and New shared Topology for all LODs have been dropped.

In the Smartsteps dialog, the Hierarchy by Topology option has been dropped. 

Tessellation
In the Tessellation dialog, you can no longer select between different tessellation 
algorithms. The new tessellation method corresponds to the earlier Accurate II.  

Since the tessellation values are now stored in the objects, you can read out the 
tessellation values of the current selection. This allows you to use the same 
tessellation values that the object had before or to optimize the values. This works 
with body, shell, wireset, wire, and face objects.

Furthermore, you can now define and save your own presets or use the standard 
presets.

Fit UVs to Tessellation fits existing UV layouts to the tessellation. If this option is 
disabled, the UV layouts are deleted.

Converting older Accurate I Tolerance values

Tessellation values used in DeltaGen versions older than V10.0 for the Accurate I 
tessellator have to be adapted for use with the new tessellator. As a reference 
value, 50-70 percent of the original are valid.

If the UV layouts are not needed, disable Fit UVs to Tessellation when 
you import large files to increase processor performance. This saves a lot of 
time for tessellation.
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New features
An option for automating this conversion is provided in the context menu (open by 
right-clicking the input field of the tolerance value). If you select Convert former 
‘Accurate I’ value, the value shown in the input field is set to 55% of its original 
value.

 Click this icon next to the tolerance value for further information on converting 
Accurate I values.

Nurbs on demand

The handling of geometry data has been greatly improved. Instead of directly 
importing and later deleting the NURBS data, you can now save it in compressed 
form and retrieve it at any time during the work process. This means a few changes 
in the workflow, but has great advantages:

_ The scene tree is now clearer

_ More flexible workflow: e.g., you can retessellate objects at any time

If you use RTT DeltaBatch for tessellation, you can continue to use older 
configuration files. The tessellation values are then adapted automatically. 
An info dialog appears, informing you of this process. The configuration file 
is not modified, but it can be updated if you save it with the converted 
tessellation values.

When objects from pre 10.0.1-versions of DeltaGen, that contain uv-data, 
are re-tesselated, there is a possibility that the uv-layout will be destroyed. 
Therefore a dialog appears, which enables the user to decide wether the 
uv-layxout should be kept or deleted, or if the tessellation should be 
canceled completely.
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New features
_ Less memory used

_ Much shorter load times

_ By keeping the data in compressed form, you can retain the NURBS data for 
the complete preparation and processing phase.

Body/Shell/Faces structure

The new Nurbs management is based on a few new objects in the scene tree, but 
they are similar in handling to the old objects. The structure in the scene tree is 
now as follows:

Group

Represents (as before) a hierarchic grouping in which components are structured.

Body

Represents the actual component. You can, for example, make transformations at 
this level. It can consist of several part-geometries, the shells. 

Shell

Represents a group of shapes. You can edit the look at this level. The NURBS 
information of the shapes are available in the faces.

A shell can only contain faces. These faces are hidden by default. 

A shell can only exist in a body and can only be referenced by referencing the 
higher-level body.

Face

Represents the individual NURBS shapes. If you open a shell in the scene tree, the 
NURBS information is decompressed and the faces are displayed. However, a face 
cannot be transformed and cannot have its own look. For this, it needs a shell.

The NURBS data of the faces and wires exists in compressed form. It is 
automatically unpacked if operations such as tessellation are performed on it or if a 
shell or a wireset is opened in the scene tree so that the faces or  wires it 
contains become visible.

Both the toolbar of the scene tree and the Geometries > Nurbs menu contain the 
Close all shells and wiresets command. This function closes all shells and 
wiresets in the scene tree.

Wireset
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New features
A body for curve objects, the wires. It cannot contain any other objects.

A wireset can only exist in a body and can only be referenced by referencing the 
higher-level body.

Wire

A curve object containing NURBS information. A wire cannot be directly transformed 
and it cannot be assigned a look. This is inherited via the shell.

A/B-sides of faces/wires
In the previous workflow, hidden shapes were removed from the scene. You can 
now simply hide them (independent of the standard visibility). This means that 
you still have access to this data, even much later.

In the data preparation, these shapes are called A-side or B-side. A-sides are the 
visible and B-sides the invisible shapes.

Whether a face/wire is an A- or B-side can be set with the following steps:

_ The scene tree has a new column, Is A-side. If you check this column for 
faces/wires, this shape is interpreted as an A-side. If you disable this 
option, the object is treated as B-side.

_ The object editor has radio buttons for changing A to B. This option is also 
available for multiselections.

_ In the Geometry>NURBS>Set to A/B-side menu

_ In the context menu: NURBS>Set to A/B-side

You can switch A/B-sides to visible separately: View> Visibility > Show A/B-
sides. If you select View > Highlight B-sides, you can give the B-sides a special 
color. You can set the color for the Highlight mode under Preferences > 
Highlighting.

Loading/importing files
You can load CSB files created with older versions quite normally. The NURBS data 
and the scene tree structure are retained unchanged. To convert them to the new 
body/shell structure, you select Geometry > Combine . With File > 
Smartsteps, this can be done directly during loading.

Imported data from another file format is automatically converted to the new 
body/shell structure. The Struct by topology function was removed from the 
Import dialog since the topology assignment is now automatic.

Saving/exporting 
During saving, old NURBS data is not automatically converted to body/shells but 
retained. If you want to use NURBS data from DeltaGen 10.0 in older versions, you 
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New features
export is as Simple CSB: File > Export > All > All > Save as Type: Simple 
Cosmo binary

If you open data of Release 10.0 with a body/shell structure in an older 
DeltaGen version that does not support bodies/shells, you can no longer use the 
NURBS data in this version. However, the triangle nets and their shapes are shown.

For different workflows, only the A-sides or the B-sides of faces are needed (in 
part). To do justice to these workflows, there are extra export functions in the File 
> Export menu:

All > A-sides only: Saves the complete scene and removes the B-side faces/
wires during saving from the corresponding shells/wiresets

All > B-sides only: Saves the complete scene and removes the A-side faces/
wires during saving from the corresponding shells/wiresets and enables Is A-
side.

Selection > A-sides only: Saves the selection and removes the B-Side faces/
wires from the corresponding shells/wiresets when it is saved

Selection > B-sides only: Saves the selection and removes the A-side faces/
wires during saving from the corresponding shells/wiresets and enables Is A-
side.

Creating objects
You create the new object types in DeltaGen as follows:

Open the Scene > Create geometry> menu. 

_ Body object: Creates a new body object in the selected group

_ Shell object: Creates a new shell object in the selected body

_ Wireset object: Creates a new wireset object in the selected body

Shell/Wireset from selection: In the body in which the faces/wires are 
selected, creates a new shell/wireset and moves the selected faces/wires into 
it.

Copy/paste and drag & drop
To simplify the workflow with faces/wires, new shells are automatically created 
for copied/cut faces/wires when being inserted in a Body.

If you move or cut and paste a shell to another body, the shell and its faces lose 
their topology information.

If you move or cut and paste a face/wire to another shell, the moved objects are 
assigned the look of the shell.
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New features
New selection modes
You can select faces and wires with the new selection mode Select by face or 
wire in the viewer.

You can select bodies with Select by group.

You can select shells/wiresets with Select by object.

Lighting and shadows

The Look & Shadow menu has been improved and now provides the necessary 
functions more clearly. 

Global shadow
Global Shadow is computed not only in idle mode but also in real time during 
navigation or animations. A new option, Indirect illumination, is now available for 
simulating diffuse licht reflection (color bleeding).

 

Shadow intensity
Shadow intensity now has a new option for making precise settings for the 
transition of reflections and highlights in the darkened shadow area.
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New features
Split

Split adjusts the limit for hiding the specular parts and the reflection.

Split strength

Regulates the transition between visible reflections as well as highlights and the 
shadow area.   

Local surroundings
The quality of Image Based Lighting (IBL) was already greatly improved in Release 
9.6.1 and now comprises considerably more grades. This means that the display of 
the light distribution under OpenGL is more consistent with the display when using 
global illumination. 

Look editor

BTF measured material
BTF measured materials are very good for capturing light-dependent and focal-
point-dependent variations of materials and are therefore very suitable for textiles, 
leather, scarred surfaces, and velvet, as well as for paints with special color effects. 

This option only has an effect when "High quality shadow" is enabled. 

RTT DeltaGen 9.6 - Shininess 5.0 RTT DeltaGen 9.6.1 - Shininess 5.0
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New features
The look library that comes with RTT DeltaGen 10.0 contains several sample 
materials.

This extension of the look editor enables you to import measured materials and use 
them for visualization. RTT DeltaGen supports btf and cpa files.

Look library

Collections
You can now organize looks in collections in a look library.

You access the collections in the look library by opening the Collections menu. 
By default, the Show All menu entry is active, which displays all looks in the 
selected library. If you select another collection, only the looks of the selected 
collection are displayed.

To measure BTFs, you need material samples. The measurement size is 
about 10 x 10 cm, and the sample size should not exceed 29.7 x 21 cm. The 
sample should not have any scratches or unevennesses etc. You are 
welcome to contact RTT to make a BTF measurement.

Because of the high memory requirements of BTF materials, we 
recommend a powerful graphics card. BTF materials require a suitable UV 
layout for an optimal display. You may have to scale this with factor 200 to 
display the material with the correct dimensions.
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New features
Under Collections in the context menu, you can assign the selected look of a 
collection. If you select Add to new Collection, a new collection is generated 
containing the selected look.

Tools

Render export

Stereo Render Export

You can now display images and animations in stereo. The Render Export window 
now has a new element, the Stereoscopic area.

You can choose different stereo modes: 

Mono: no stereo output

Stereo left: Separate output of image for the left eye
Realtime Technology AG 2011 Release Notes 18



New features
Stereo right: Separate output of image for the right eye

Stereo anaglyph: Output with the red and green method.

Multiple selection is possible. You can specify a separate target folder for each 
image output.

Post Processor

Non-linear HDR tone mapping

Non-linear HDR tone mapping adapts the brightness with an algorithm especially 
designed for HDR.

UV editor

Selective unwrapping

If parts of a chart are selected, only this part area is unwrapped and the non-
selected objects retain their position.

Update unwrap

 If you are using the UV editor and assign "is A-side" to an object that already 
has the property "is B-side" without an existing UV layout, this computes the UV 
layout for the new object and adds it to the already opened UV layout.

Fly to

 displays the selected areas in the center of the UV editor window. If Scene 
selection is enabled, currently selected UV objects are also centered in the 3D 
viewer.

Normalize UVs

Select Transform > Normalize UVs to make a detailed distribution in the UV 
space (U/V direction, side ratio retained).

Animations

Animation Targets
The animation editor now has the following new animation targets:
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New features
_ 3D Note

_ Graphics Overlay

_ Text Overlay

You can animate the Visibility for these objects. To assign the animation, select 
Tools > Overlays > Edit > Animate Object or right-click the object and select 
Animate Object from the context menu.

You can also perform this animation with the Animation Network Editor (ANE). 

Animation Editor
You can now do frame-based work in the animation editor. 

For the time display of the timeline, you can now select Timecode, Frames or 
Seconds under Timeformat SMPTE. With the radio buttons below, you can define 
how existing key-frames are treated if the frame rate is changed:

Keep Key Times 

The key-frames remain at the same point in time, regardless of the frame rate. (A 
key-frame at the first second remains at the first second. This means that a key-
frame can end up between two frames). 

Move keys to next full frame

The key-frames remain at the same point in time, but are quantized to the next 
frame. (A key-frame at the first second can, for example, end up at 1,028 seconds, 
but the program prevents key-frames from lying between two frames).

Keep keys at current frame

The key-frames remain on the same frame but are shifted in time. A time scaling 
takes place. For example, if you change the frame rate from 25 to 30 fps, the 
animation speeds up. This time-scaling affects all animations in order to keep the 
timing of the scene consistent.
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New features
With the Snap option, you can define where new or shifted key-frames are placed. 

Visualizing the animation length

The length of an animation is now also visualized by a light-green line in the time-
line that stretches from the first to the last keyframe. This makes it easy to see 
whether an animation exceeds the time range currently visible in the editor.

Direct value input for key-frames

In the graph editor, you can enter values for key-frame parameters directly. 

If you click a key-frame anchor point, its numeric value is displayed top left. You 
can change this by direct entry in the field.
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New features
RTT RealTrace

Fast display mode

You can now automatically switch the render mode and get a much faster display 
during navigation and during animations.

Under Preferences > Realtrace, enable Render with lower quality during 
interaction for this purpose.

Under Fallback mode, you define behavior during navigation or animation:

Rasterization (Open GL)

Switches to OpenGL display

Raytracing

Pure ray-tracing without global illumination.

 Global Illumination

Global illumination and raytracing remain active.

In Raytracing and Global illumination, you can improve performance by enabling 
Use lower viewer resolution to reduce resolution during navigation or animation 
playback to the value set under Percentage of resolution.

RTT GPU RealTrace 
RTT RealTrace can now also be operated with pure GPU usage. For this purpose, 
select Preferences > RealTrace and then "GPU".

 

 

The graphics card must meet current system requirements and expects at 
least a Cuda 3.2 driver. If you cannot enable the GPU option, click the 
information icon and read the information shown there.

If GPU is selected as the mode for RTT RealTrace, GPU is also used for the 
computation of the RealLight shadow types Lightmap and interactive 
shadow.
The display of BTF-measured materials is currently not supported by GPU-
based RealTrace.
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New features
RTT DeltaBatch 10.0

Multicore support
All functions in DeltaBatch are now multicore-supported. This enormously reduces 
the conversion times of large data volumes, and other procedures such as 
Tessellate or combine are much faster.

To enable multicore support, you set the number of cores to be used at bottom left 
of the DeltaBatch dialog. 

The multicore option speeds up the process particularly if a large number of files 
have to be converted.

The selected number of cores should not exceed the actual number, since 
otherwise the performance can suffer.

Miscellaneous

Color Management
RTT DeltaGen now uses ICC monitor profiles to ensure the same color display on 
different monitors. 

Make settings under Preferences > Display Adaption. The default setting uses 
the Windows ICC profile, but with the Custom checkbox, you can select another 
profile whose path you specify in the adjacent input field.
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New features
Under Color Reproduction, there are two options of color handling besides the 
displayable color space:

absolute 

Cuts colors that cannot be displayed or sets them to the last displayable color value.

perceptual 

Tries to replace non-displayable colors according to human perception. 

In the Mark out-of-gamut colors checkbox, you mark areas whose color data is 
outside the range of displayable colors.

Tessellate on load
The tessellation parameters are no longer in a separate section of the Preferences. 
You can now select your own presets for the tessellation process. You can define 
these Presets in the Tessellate dialog. You select the tessellation presets in the 
Actions on Load panel of the Preferences. You can also define tessellation presets 
in the Smartsteps dialog.

Character set extension (Unicode)
In all object names and file names, you can now use Asiatic character sets 
(Unicode).

Templates
In the Templates dialog, you can no longer select the tessellation algorithm, and 
there is no longer any boundary information.

Surroundings
Due to the heavy load on the RAM, the following surroundings are not suitable for 
use on a 32-bit operating system:

_ Congress_hall

_ Monument_valley

_ Myvatn

_ Sunset_port
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New features
RTT converters 10.0
For the use of RTT converters an appropriate License is needed.

RTT DirectJT export

You can now export scenes in JT format. 

If you export a scene to a JT file: polygon and NURBS data, cameras, looks (no 
external CgFX shaders), structure data and metadata are saved.

RTT DirectFBX export

You can now export scenes in FBX format. 

If you export a scene to an FBX file: polygon data, NURBS, colors, UV coordinates, 
normals, transformations, textures, the structure, and the names of objects and 
scene elements are saved in the file.

RTT DirectIges

RTT Direct Iges supports no Unicode character sets (format-related).
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New features
RTT Scale 10.0
Clients without a dedicated graphics card can now also be used for RTT RealTrace 
with enabled CPU usage; a graphics card is needed for image display only.

Failsafe Reliability

If a client fails at the start of a cluster, the start sequence continues regardless for 
the other clients. If the failed client was to be used for display (Multidisplay), the 
render output assigned to it will be missing. If the client was to be used for image 
computation, the overall performance will suffer accordingly.

RTT Scale clients under Linux 

You can now install RTT Scale clients under Linux.

An installer for installing RTT Scale clients under Linux is provided on the software 
DVDs.

RTT Scale cluster installation 

Installing a cluster system places various demands on the infrastructure, as well as 
on hardware and software components. The setup requires basic knowledge in 
handling the components involved as well as the local environment conditions. The 
reinstallation of a system cannot therefore be completely covered by our software 
support. 

In general, we recommend that you request support from our Service department 
when installing RTT Scale systems. 

RTT Immersive 10.0

Configuration

The Configuration section has been greatly improved and now enables a simpler 
installation of the Immersive environment as well as easy access to operation, for 
example for presentation purposes.

Colored displays report the status of the configuration, showing you immediately 
whether a configuration is complete and can be used, or whether you still have to 
make settings.

To install a pure Linux or mixed Linux/Windows cluster, you should 
definitely apply to our Service department. Contact us under 
support@rtt.ag. 
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New features
Gamepad Navigation

A Gamepad can now be configured and used for easy, user-friendly navigation in 
VR scenes.

Collision detection
RTT DeltaGen can now detect collisions between any shaped objects. Single 
geometries (geometry nodes in the scene) as well as complete subtrees can be 
used. A collision or penetration between these objects is detected and can by 
displayed by coloring. In the example, the wheel of a vehicle is moved. If it collides 
with part of the bodywork, the wheel and the bodywork are colored red.  

You can also prevent a collision between two objects; in this case, the last collision-
free position is used for the moved object.

Open the simulation dialog with Tools > Simulation.
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New features
If the entry does not appear there, use the Modules & plug/ins dialog to load the 
plug-in rttSimulation.xml.

 

Select one or more objects in the scene tree and drag them to the the objects 
area. The objects are now added to the collision list.

Under Collision Feedback, define what happens if a collision is detected:

Highlight collisions colors the colliding objects red.

Prevent collision prevents a collision.

The delete button on the right deletes a selected object from collision detection. In 
the top right corner of the dialog, there are on/off buttons for enabling/disabling 
collision detection.

RTT Conferencing
The RTT Conferencing module is no longer available in Release 10.0.

RTT DeltaTex 10.0
With release 10.0.1 DeltaTex is available as a 64 Bit version. For the installation a 
full installer is needed, for DeltaTex 64 is not included in the 10.0.1 patch installer.

RTT DeltaTex 64 Bit needs a very recent version of Flashplayer 11 (64 Bit) 
to run, which can be downloaded using the following link:
http://download.macromedia.com/pub/labs/flashplatformruntimes/
flashplayer11/flashplayer11_b2_install_win_ax64_080811.exe
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Additional files

Surroundings

The following surroundings are new:

_ Elements

_ Light_walls

_ Myvatn

Surrounding Elements.rts
Realtime Technology AG 2011 Release Notes 29



Additional files
Under RTTSoftware\Release10.0.2\Surroundings\_Studio_images, 
you can find specimen reflection files for use with the HDR Lightstudio plug-in. 

These are in .hdr format for RTT DeltaGen and .hdi format for HDR Lightstudio and 
are best used with the black variant of the Studio surrounding.

The surroundings delivered also contain the respective reflection textures in 
latitude/longitude format for use with the HDR Lightstudio plug-in. 

Surrounding Light_walls.rts

Surrounding Myvatn.rts
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Additional files
See the table below for the surroundings that in addition to the two new ones are 
HDR-capable and suitable for the Pure ray tracing and Global illumination 
options.

surrounding name pure RT GI HDR 

Andalucian_mountain_pass X X X

Apartment X

Arena X X

Clean Room

Coast X X X

Congress Hall X X X

Elements X X

Factory

Field X X X

Hangar X X

Industrial

Light tunnel

Light_walls X

Lounge

Monument Valley X X X

Mountains X X

Myvatn X X X

Neutral

Nymphenburg X X X

Parking Area X X X

Speed tunnel

Studio X X

Sunset Port X X X

Terrace X X X

Toledoan_highway X X X

Urban City

Wind tunnel X
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Additional files
Surroundings in RTT DeltaGen Release 10.0.2
A summary of surroundings that come with RTT DeltaGen 10.0.2:

HDR-based surroundings
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Additional files
Artificial surroundings
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Additional files
Product surroundings
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Additional files
Surrounding textures for local surroundings and HDR 
Lightstudio plug-in
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RTT Software Services 

RTT Knowledgebase
An online knowledge base is available under support.rtt.ag, from which you can 
regularly retrieve updated information. 

You need your access data to be able to use this function.

To give you access, we just need one registration from you. You can do this by mail 
to login@rtt.ag. 

In this mail, you must mention 

_ Your name

_ Your company

_ as well as your company's mail address, 

in order to get a correct assignment.

RTT software services
On  softwareservices.rtt.ag you can find more information and video tutorials for 
the new RTT DeltaGen functions.

To release them for access, you have to register. They are normally released within 
one working day. When you register, specify

_ Your name

_ Your company

_ as well as your company's mail address, 

in order to get a correct assignment. 

If you already have access data for the RTT knowledge base, just use your current 
data for registering. 

http://support.rtt.ag
http://softwareservices.rtt.ag


Tested RTT Scale system setups

The following describes RTT Scale system setups tested by RTT in comprehensive 
tests. We laid particular emphasis on ensuring high visual quality and performance.

All setups are based on the current system requirements.

Note that other system setups require individual adaptations, e.g. configuration 
settings of network cards and network switches, to ensure the required speed, 
stability, and visual quality.

Intel-based network cards demonstrated a high and reliable network performance 
in our tests. In contrast, Broadcom-based network cards yielded only instable data 
transfer rates. 

If you want to use multicast configurations, the network switch must support 
multicast. Additionally, the support of jumbo frames (min. 9.6k, better: 18k) and a 
backplane with at least 150 MB/s per Port are recommended.

Setup: Workstation cluster I
This system setup was tested with RTT Scale Workstation and Powerwall 
configurations.

Master (Fujitsu Celsius R650)

Operating 
system

Windows XP 64-bit (Service Pack 2)

RAM 16 GBytes

Processor Intel Xeon X5460 

Graphics card nVidia Quadro FX 5800

Graphics driver Version 270.71

Network card Intel Pro 1000/EB

Network driver Version 9.13.41.0
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Tested RTT Scale system setups
Setup: Workstation cluster II
This system setup was tested with RTT Scale Workstation and Powerwall 
configurations.

4 x Workstations (Fujitsu Celsius R650)

Operating 
system

Windows XP 64-bit (Service Pack 2)

RAM 16 GBytes

Processor Intel Xeon X5470

Graphics card 2 x nVidia Quadro FX 5800

Graphics driver Version 270.71

Network card Intel Pro 1000/EB

Network driver Version 9.13.41.0

Display

Monitor HP LP2465, Resolution: 1920 x 1200

Network

Topology Gigabit Ethernet, Unicast or Multicast

Switch HP ProCurve 1400-8G

Master (HP xw8400)

Operating 
system

Windows XP 64-bit (Service Pack 2)

RAM 16 GBytes

Processor Intel Xeon X5460 

Graphics card nVidia QuadroPlex 1000 Model 4 (2 x Quadro FX 5600), 
GSync or nVidia Qouadro 6000

Graphics driver Version 270.71

Network card Intel Pro 1000/PT Server Adapter 

Network driver Version 9.12.36.0
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Tested RTT Scale system setups
Setup: Workstation cluster III
This system setup was tested with RTT Scale Workstation and Powerwall 
configurations.

4 x Workstations (HP xw8400)

Operating 
system

Windows XP 64-bit (Service Pack 2)

RAM 16 GBytes

Processor Intel Xeon X5470

Graphics card 2 x nVidia Quadro FX 5600 or nVidia Quadro 6000

Graphics driver Version 270.71

Network card Intel Pro 1000/PT Server Adapter

Network driver Version 9.12.36.0

Display

Monitor HP LP2465, Resolution: 1920 x 1200

Network

Topology Gigabit Ethernet, Unicast or Multicast

Switch HP ProCurve 1400-24G1

Master (Fujitsu Celsius R670)

Operating 
system

Windows XP 64-bit (Service Pack 2)

RAM 48 GBytes

Processor Intel Xeon X5590 

Graphics card nVidia Quadro FX 5800

Graphics driver Version 270.71

Network card Intel Pro 1000/EB

Network driver Version 9.12.16.0
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Tested RTT Scale system setups
Setup: Workstation cluster Infiniband I
This system setup was tested with RTT Scale Workstation and Powerwall 
configurations.

12 x Workstations (Fujitsu Celsius R670)

Operating 
system

Windows XP 64-bit (Service Pack 2)

RAM 48 GBytes

Processor Intel Xeon X5590

Graphics card nVidia Quadro FX 5800 or nVidia Quadro 6000

Graphics driver Version 270.71

Network card Intel Pro 1000/EB

Network driver Version 9.13.16.0

Display

Monitor HP LP2465, Resolution: 1920 x 1200

Network

Topology Gigabit Ethernet, Unicast or Multicast

Switch HP ProCurve 2848

Master (HP xw8400)

Operating 
system

Windows XP 64-bit (Service Pack 2)

RAM 16 GBytes

Processor Intel Xeon X5460 

Graphics card nVidia QuadroPlex 1000 Model 4 (2 x Quadro FX 5600) or 
nVidia Quadro 6000

Graphics driver Version 270.71

Network card Mellanox IpoIB Adapter

Network driver Version 2.0.0.3609
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Tested RTT Scale system setups
Setup: Workstation cluster Infiniband II
This system setup was tested with RTT Scale Workstation and Powerwall 
configurations.

4 x Workstations (Fujitsu Celsius R650)

Operating 
system

Windows XP 64-bit (Service Pack 2)

RAM 16 GBytes

Processor Intel Xeon X5470

Graphics card 2 x nVidia Quadro FX 5600

Graphics driver Version 270.71

Network card Mellanox IpoIB Adapter

Network driver Version 2.0.0.3609

Display

Monitor 1 x HP LP2465, Resolution: 1920 x 1200
1 x Samsung 244T, Resolution: 1920 x 1200

Network

Topology Infiniband

Switch Flextronics F-X430046

Master (Fujitsu Celsius R650)

Operating 
system

Windows XP 64-bit (Service Pack 2)

RAM 16 GBytes

Processor Intel Xeon X5460 

Graphics card nVidia Quadro FX 5800

Graphics driver Version 270.71

Network card Mellanox IpoIB Adapter

Network driver Version 2.0.7.4832
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Tested RTT Scale system setups
Setup: Cave
This system setup was tested with RTT Scale Cave configurations including passive 
stereo and tracking.

4 x Workstations (Fujitsu Celsius R650)

Operating 
system

Windows XP 64-bit (Service Pack 2)

RAM 16 GBytes

Processor Intel Xeon X5470

Graphics card 2 x nVidia Quadro FX 5800

Graphics driver Version 270.71

Network card Mellanox IpoIB Adapter

Network driver Version 2.0.7.4832

Display

Monitor HP LP2465, Resolution: 1920 x 1200

Network

Topology Infiniband

Switch Flextronics F-X430046

Master (Fujitsu Celsius R670)

Operating 
system

Windows XP 64-bit (Service Pack 2)

RAM 48 GBytes

Processor Intel Xeon X5590

Graphics card 2 x nVidia Quadro FX 5800 or nVidia Quadro 6000

Graphics driver Version 270.71

Network card Infiniband Mellanox IpoIB Adapter

Network driver Version 2.0.7.4832
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Tested RTT Scale system setups
4 x Workstations (Fujitsu Celsius R670)

Operating 
system

Windows XP 64-bit (Service Pack 2)

RAM 48 GBytes

Processor Intel Xeon X5590

Graphics card 2 x nVidia Quadro FX 5800 or nVidia Quadro 6000

Graphics driver Version 270.71

Network card Infiniband Mellanox IpoIB Adapter

Network driver Version 2.0.7.4832

Display

Control Monitor Samsung 244T, Resolution: 1920 x 1200

Digital 
Projection

2 x Cineo 3+ 1080, Resolution: 1920 x 1080

Network

Topology Infiniband

Switch Flextronics F-X430046
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