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Preface

About This Manual
This manual contains reference information for SmartModel Library users who are on
an NT platform. If you are on UNIX, refer to the Visual SmartBrowser User’s Manual
– UNIX version – since the NT version of the Visual SmartBrowser (VSB) tool operates
somewhat differently from the UNIX version.

The focus of this manual is on how to use the VSB tool to improve productivity when
working with SmartCircuit models of FPGA and CPLD devices. The manual does not
contain general information about SmartCircuit models or other types of SmartModel
Library models—that information is presented in the SmartModel Library User’s
Manual. For an application note that describes how to use VSB and the other
SmartCircuit debugging tools together to solve verification problems, refer to the
SmartModel Products Application Notes Manual.

Related Documents
For general information about SmartModel Library documentation, or to navigate to a
different online document, refer to the Guide to SmartModel Documentation. For the
latest information on supported platforms and simulators, refer to SmartModel Library
Supported Simulators and Platforms.

For detailed information about specific models in the SmartModel Library, use the
Browser tool ($LMC_HOME/bin/sl_browser) to access the online model datasheets.
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Manual Overview
This manual contains the following chapters and appendixes:

Typographical and Symbol Conventions
● Default UNIX prompt

Represented by a percent sign (%).

● User input (text entered by the user)

Shown in bold type, as in the following command line example:

% cd $LMC_HOME/hdl

● System-generated text (prompts, messages, files, reports)

Shown as in the following system message:

No Mismatches: 66 Vectors processed: 66 Possible

● Variables for which you supply a specific value

Shown in italic type, as in the following command line example:

% setenv LMC_HOME prod_dir

In this example, you substitute a specific name for prod_dir when you enter the
command.

● Command syntax

Choice among alternatives is shown with a vertical bar ( | ) as in the following
syntax example:

-effort_level low | medium | high

In this example, you must choose one of the three possibilities: low, medium, or
high.

Preface Describes the manual and lists the typographical
conventions and symbols used in it; tells how to get
technical assistance.

Chapter 1:
VSB Overview

Contains procedures for using the Visual
SmartBrowser (VSB).

Chapter 2:
Learning Visual
SmartBrowser

Contains a short tutorial that enables new users to
learn how to use the Visual SmartBrowser (VSB).
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Optional parameters are enclosed in square brackets ( [ ] ) as in the following
syntax example:

pin1 [pin2 ... pinN]

In this example, you must enter at least one pin name (pin1), but others are optional
([pin2 ... pinN]).

Getting Help
If you have a question while using Synopsys products, use the following resources:

1. Start with the available product documentation installed on your network or located
at the root level of your Synopsys CD-ROM. Every documentation set contains
overview information in the intro.pdf file.

Additional Synopsys documentation is available at this URL:

http://www.synopsys.com/products/lm/doc

Datasheets for models are available using the Model Directory:

http://www.synopsys.com/products/lm/modelDir.html

2. Visit the online Support Center at this URL:

http://www.synopsys.com/support/lm/support.html

This site gives you access to the following resources:

❍ SOLV-IT!, the Synopsys automated problem resolution system

❍ product-specific FAQs (frequently asked questions)

❍ lists of supported simulators and platforms

❍ the ability to open a support help call

❍ the ability to submit a delivery request for some product lines

3. If you still have questions, you can call the Support Center:

North American customers:
Call the Synopsys Eaglei and Logic Modeling Products Support Center hotline at
1-800-445-1888 (or 1-503-748-6920) from 6:30 AM to 5 PM Pacific Time, Monday
through Friday.

International customers:
Call your local sales office.

http://www.synopsys.com/products/lm/doc
http://www.synopsys.com/products/lm/modelDir.html
http://www.synopsys.com/support/lm/support.html
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The Synopsys Website
General information about Synopsys and its products is available at this URL:

http://www.synopsys.com

Synopsys Common Licensing (SCL) Document Set
Synopsys common licensing (SCL) software is delivered on a CD that is separate from
the tools that use this software to authorize their use. The SCL documentation set
includes the following publications, which are located in (root)/docs/scl on the SCL CD
and also available on the Synopsys FTP server (ftp://ftp.synopsys.com):

● Licensing QuickStart—(142K PDF file)
This booklet provides instructions for obtaining an electronic copy of your license
key file and for installing and configuring SCL on UNIX and Windows NT.

● Licensing Installation and Administration Guide—(2.08M PDF file)
This guide provides information about installation and configuration, key concepts,
examples of license key files, migration to SCL, maintenance, and troubleshooting.

You can find general SCL information on the Web at:

http://www.synopsys.com/keys

Comments?
To report errors or make suggestions, please send e-mail to:

doc@synopsys.com

To report an error that occurs on a specific page, select the entire page (including
headers and footers), and copy to the buffer. Then paste the buffer to the body of your
e-mail message. This will provide us with information to identify the source of the
problem.

ftp://ftp.synopsys.com/pub/SCL/LQS.pdf
ftp://ftp.synopsys.com/pub/SCL/LIAG.pdf
http://www.synopsys.com/keys
http://www.synopsys.com
mailto:doc@synopsys.com
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1
VSB Overview

This chapter presents information on how to use the VSB tool to improve productivity
when working with SmartCircuit models. This information is organized in the following
major sections:

● Multiple Views

● Main Window

● View and Tool Buttons

● Views and Tools

Introduction
Visual SmartBrowser (VSB) is a tool with a graphical user interface that you can use to
debug designs that incorporate SmartCircuit models of FPGA and CPLD devices. VSB
uses multiple different views of a device netlist to enable accurate diagnosis of design
problems.

VSB is part of a suite of SmartCircuit PLdebug tools that enable you to determine
relationships within your design, as illustrated in Figure 1. The PLdebug tools are:

● SmartCircuit Monitor. Enables you to observe any element in your design and
receive reports of any changes that occur on that element.

● Causal Tracing. Enables you to trace events in a simulation to see where a
problem is occurring or to trace the causes of a problem to their roots.

● SmartBrowser interactive tool. Enables you to traverse a design and obtain
information about any element in the design; has a batch mode.
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● Visual SmartBrowser. Graphically enables you to traverse a design for
information on the design elements; does not have a batch mode.

Figure 1: PLdebug Tools

Both the SmartBrowser interactive tool and the VSB enable you to find information
about the elements in a design. The VSB gives a visual conceptualization of the design,
whereas the SmartBrowser gives no visual clues to the design. Whether you should use
the SmartBrowser or the Visual SmartBrowser is primarily a question of preference and
possibly circumstances, such as the size of your design.

For more information on SmartCircuit models, SmartCircuit monitors, causal tracing, or
the non-graphical SmartBrowser interactive tool, refer to the SmartModel Library
User’s Manual.

SmartCircuit
Monitor

Causal
Tracing

SmartBrowser
Interactive Tool

Visual
SmartBrowser

PL debug Tools
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Multiple Views
Visual SmartBrowser reads a post-layout netlist (in the SmartCircuit .ccn format) and
represents the design in various graphical views as illustrated in Figure 2.

Figure 2: Various VSB Views and Tools
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● Hierarchy View. View the design as a tree-like structure of hierarchical blocks.

● Connection View. Expand and collapse circuit connections selectively. This
demand-driven approach has several benefits:

❍ Eliminates the need to display the entire schematic, reducing processing time

❍ Clears the designer’s view of unrelated nets and other circuit objects

❍ Shows how the semiconductor vendor (SCV) cells are actually connected
without the need to move up and down through the hierarchy

● Examine View. View an instance in detail and edit any timing or state information.

● Windows & Monitors tool. Create model command files (MCFs) for windowing
and monitoring internal nets and states during simulation.

Note�

Throughout this manual and the rest of the SmartModel Library
documentation, the term “instance” may mean: 1) the device itself, 2) any of
the hierarchy blocks making up the device, or 3) the vendor’s library cell
(leaf node). The surrounding text determines which usage is intended.
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Main Window
The Main window is the “command center” from which you control the Visual
SmartBrowser. Figure 3 illustrates the main window, which contains the following
elements:

● Menu bar

● Buttons to open the various views and tools

● View control pane with icons for all open views

● Optional status bar

Figure 3: VSB Main Window

Opening a Design
To open a design, include its file name on the command line when you start the Visual
SmartBrowser, as shown in the following example:

%$LMC_HOME%\bin\vsb design.ccn

Menu bar

Buttons for views and tools

Status barView control pane
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There is also a menu command that you can use to open a design belonging to the same
model, or re-open the current design (to toss any changes you may have made).

1. Choose File > Open, or press Ctrl+O.

2. Double-click on the netlist (.ccn) file you want to open.

Note�

Tools like VSB are “model-centric.” This means that the model you are
using determines the correct version of the tool to use for that particular
model version. Since the model name (for example, a1425_84) has already
been embedded into the .ccn file by smartccn, we recommend that you
invoke VSB on the command line by specifying the design.ccn, as shown in
the preceding example.

Displaying an Instance
To display the top-level (design) instance, click on the Create Hierarchy View
button.

Viewing a Circuit Object
To view a circuit object in Hierarchy, Connection, or Examine View, follow these steps:

1. Select the net, port, or instance in an active view or tool.

2. In the main window, click on the corresponding view or tool button. You can also
choose the corresponding command from the View or Tools menu.

Toggling the Status Bar
To toggle the display of the status bar in the main window, choose the following menu
item:

Options > Status Bar

Toggling Tool or Circuit Object Tips
To toggle the display of tool tips or circuit object tips in the main window, choose the
following menu item:

Options > Show Tool Tips

Options > Show Circuit Object Tips
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Bringing a View to the Foreground
To bring a view to the foreground, click on the corresponding icon in the view control
pane. You can also choose the view by name from the Window menu. If necessary, you
can click on the right and left arrow buttons to scroll more view icons into the view
control pane.

Raising and Iconifying Views
To raise or iconify all views, choose the following menu entries:

Window > Raise All Views

Window > Iconify All Views

Creating a Sparse Hierarchy View
To create a sparse hierarchy view, follow these steps:

1. If necessary, bring the appropriate Connection View to the foreground.

2. In the Connection View, use the Expand Selection, Collapse Selection, Hide
Selected Circuit Object, and/or Hide Unconnected Circuit Objects tools to display
the instances and ports of interest.

3. Click on the Create Sparse Hierarchy button.

A new Hierarchy View displays just the portion of the design hierarchy that contains
the ports and instances in the active Connection View.

Creating a Model Command File (MCF)
To create a model command file (MCF), follow these steps:

1. Click on the Show Windows & Monitors Tool button.

2. Specify the nets, states, and buses you want to window or monitor.

3. Click on the Save To File button.

For detailed instructions, refer to “Windows & Monitors Tool” on page 44.
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View and Tool Buttons
You can use the Visual SmartBrowser’s view and tool buttons to view a design netlist in
several different ways. Figure 4 illustrates the view and tool buttons used in VSB.

Figure 4: View and Tool Buttons

● Create Hierarchy View. Opens a Hierarchy View based on the selected circuit
object. (Same as View > Create Hierarchy View.)

● Create Connection View. Opens a Connection View based on the selected circuit
object. (Same as View > Create Connection View.)

● Create Examine View. Opens an Examine View based on the selected circuit
object. In this view you can see and edit timing and initial state values, along with
other details about the selected object. (Same as View > Create Examine View.)

● Show Global Selection Tool. Opens the Global Selection tool, in which you can
select nets, ports, and model instances by name. (Same as Tools > Show Global
Selection Tool.)

● Show Net Tags Tool. Opens the Net Tags tool, in which you can tag nets. Tags are
represented by different colors to make them easier to see. (Same as Tools > Show
Net Tags Tool.)

● Show Windows & Monitors Tool. Opens the Windows & Monitors tool, which
you can use to set up windows and monitors for nets, states, and buses. (Same as
Tools > Show Windows & Monitors Tool.)

● Causal Trace. Opens a Causal Trace window, which you can use to cut-and-paste
portions of your simulation output when you need to see cause reports in the LMC
Model Trace output.

Hierarchy View

Connection View

Examine View

Windows & MonitorsGlobal Selection

Net Tags Causal Trace
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View Control Pane
The view control pane is illustrated in Figure 5. You can click on any icon in the view
control pane to bring the corresponding view to the foreground. Click on the left and
right arrow buttons to scroll through the view control pane.

Figure 5: View Control Pane

Status Bar
The status bar displays the name, type, and scope of the selected net, port, or instance, as
illustrated in Figure 6. It also shows the state of the VSB tool, the current zoom level,
and whether the active design has been modified.

Figure 6: Status Bar

View control pane

Status bar
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Toggling the Status Bar Display
To toggle the status bar display, follow these steps:

● In the main window, choose Options > Status Bar.

● In a Hierarchy View or Connection View, do one of the following:

❍ Choose View > Status Bar.

❍ Click the right mouse button, and then choose View Controls > Status Bar.

Zoom Levels
You can use the zoom control buttons from the hierarchy and connections views to see
different levels of detail, as shown in Figure 7.

Figure 7: Zoom Control Buttons

Hierarchy View
In the hierarchy view, each port is labeled with its name and direction (for example, I, O,
or I/O). For the root (design) instance, symbol pin names are shown in parentheses next
to the port names. The zoom buttons work as follows:

● Zoom Detail. Each instance is labeled with its name and cell type, and the number
of contained instances and semiconductor vendor (SCV) cells.

● Zoom High. Each instance is labeled with its name and cell type.

● Zoom Medium. Each instance is labeled with its name and cell type.

● Zoom Low. Instances are not labeled, but circuit object tips show the name and cell
type of each instance. In this view, more of the hierarchy is visible, so it is easier to
see the overall topology and move about the instance tree.
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Connection View
In the Connection View, the zoom buttons work as follows:

● Detail.

❍ Each port of a hierarchical block is labeled with its name and direction (for
example, I, O, or I/O). For the root (design) instance, symbol pin names are
shown in parentheses beside the port names.

❍ Each SCV instance is labeled with its name and cell type. Input ports are shown
on the left side of the instance and output ports are shown on the right.

❍ Each port on an SCV instance is labeled with its name.

❍ Circuit object tips show the names of net connections.

● High.

❍ Each port of a hierarchical block is labeled with its name and direction (for
example, I, O, or I/O). For the root (design) instance, symbol pin names are
shown in parentheses beside the port names.

❍ Each SCV instance is labeled with its name and cell type.

❍ Ports on SCV instances are not labeled.

❍ Circuit object tips show the names of net connections.

● Medium.

❍ Ports are not labeled, but circuit object tips show the names of ports on
hierarchical blocks.

❍ Each SCV instance is labeled with its cell type, and circuit object tips show the
names of instances.

❍ Circuit object tips show the names of net connections.

● Low.

❍ Ports are not labeled, but circuit object tips show the names of ports on
hierarchical blocks.

❍ SCV instances are not labeled, but circuit object tips show the name and cell
type of each instance.

❍ Net connections are not displayed, but more of the Connection View is visible.
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Setting the Zoom Level
To set the zoom level, do one of the following:

● From the tool bar, click on a zoom level icon.

● With the right mouse button:

a. In the Hierarchy View or the Connection View, click the right mouse button and
select the Zoom command from the pop-up menu.

b. Choose a zoom level from the menu.
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Views and Tools
This section discusses the various VSB views and tools.

Hierarchy View
The Hierarchy View window displays the hierarchical location of the instances in a
design, as illustrated in Figure 8. The root instance is the design itself. The
semiconductor vendor (SCV) cells are located at the leaf nodes of a fully expanded
branch. Thus, a flat netlist has two levels: one for the design and one for all the SCV
cells.

Figure 8: Hierarchy View

Design instance

Hierarchy pane

Port pane

Tool bar

Status bar
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The Hierarchy View also contains a tool bar for common tasks and a list of ports
(I=input, O=output, I/O=bidirectional) for the selected instance. For the root (design)
instance, symbol pin names are shown in parentheses beside the port names. You can
use any port as a starting point for the generation of a new Connection View.

At the bottom of the Hierarchy View is an optional status bar.

Expanding a Hierarchical Block
To expand a hierarchical block, do one of the following:

● By selection:

a. In the hierarchy pane, select a non-leaf instance.

b. Click on the Expand Selection tool.

● By double-clicking on a non-leaf instance in the hierarchy pane.

Collapsing a Hierarchical Block
To collapse a hierarchical block, do one of the following:

● By selection:

a. In the hierarchy pane, select an expanded instance.

b. Click on the Collapse Selection tool.

● By double-clicking on the expanded instance.

Exploring Connections from a Port
To explore connections from a port, do one of the following:

● By selection:

a. From the list below the hierarchy pane, select the port.

b. In the main window, click on the Create Connection View button.

● By double-clicking on the port in the list.

A new Connection View displays the selected port or SCV instance.



Visual SmartBrowser User’s Manual – NT version Chapter 1: VSB Overview

February 2001 Synopsys, Inc. 25

�

Displaying Instance Details
To display details on an instance, do one of the following:

● By selection:

a. In the hierarchy pane, select the instance.

b. In the main window, click on the Create Examine View button.

● By double-clicking on a leaf (SCV) instance in the hierarchy pane.

In Examine View, you can also modify timing and initial state values for circuit
objects that include timing and state information.

Displaying the Top-Level Instance
To display the top-level (design) instance, follow these steps:

1. In the Hierarchy View or Connection View, click on the selected circuit object (or
on any unoccupied space) to cancel the current selection.

2. Click on the Create Hierarchy View button.

Hierarchy View Pop-Up Menu
You can use the Hierarchy View pop-up menu to perform various functions as shown in
Figure 9.

Figure 9: Hierarchy View Pop-Up Menu
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● Raise Application Shell Window. Brings the VSB main window to the top.

● Zoom. Displays several zoom levels.

❍ Detail. Each instance is labeled with its name and cell type, and the number of
contained instances and semiconductor vendor (SCV) cells.

❍ High. Each instance is labeled with its name and cell type.

❍ Medium. Each instance is labeled with its name and cell type.

❍ Low. Instances are not labeled, but circuit object tips show the name and cell
type of each instance. In this view, more of the hierarchy is visible, so it is easier
to see the overall topology and move about the instance tree.

● View Controls:

❍ Toolbar. Toggles display of the tool bar in the active Hierarchy View.

❍ Status Bar. Toggles display of status information in the active Hierarchy View.

❍ Iconify. Reduces the active Hierarchy View to an icon.

❍ Close this View. Closes the active Hierarchy View. (Same as the Close View
tool on the Hierarchy View Tool Bar.)

● Expand. Shows the hierarchy under the selected instance. (Same as the Expand
Selection tool on the Hierarchy View Tool Bar.)

● Collapse. Hides the hierarchy under the selected instance. (Same as the Collapse
Selection tool on the Hierarchy View Tool Bar.)

● Find. Centers the selected circuit object in the active Hierarchy View, if the view
contains the object.

Use this command after you select an object in another view or tool. (Same as the
Find Selection tool on the Hierarchy View Tool Bar.)

● Auto Find Selection. When possible, updates the active Hierarchy View
automatically to focus on the selected object.
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Hierarchy View Tool Bar
Figure 10 illustrates the tool bar buttons available in the Hierarchy View.

t

Figure 10: Hierarchy View Tool Bar Buttons

● Zoom Detail. Each instance is labeled with its name and cell type, and the number
of contained instances and semiconductor vendor (SCV) cells.

● Zoom High. Each instance is labeled with its name and cell type.

● Zoom Medium. Each instance is labeled with its name and cell type.

● Zoom Low. Instances are not labeled, but circuit object tips show the name and cell
type of each instance.

● Expand Selection. Shows the hierarchy under the selected instance. (Same as the
Expand command on the Hierarchy View Pop-Up Menu.)

● Collapse Selection. Hides the hierarchy under the selected instance. (Same as the
Collapse command on the Hierarchy View Pop-Up Menu.)

Change zoom

Expand button
Close the view

Collapse button

Find button

buttons
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● Find. Centers the selected object in the active Hierarchy View, if the view contains
the object. Use this command after you select an object in another view or tool.
(Same as the Find command on the Hierarchy View Pop-Up Menu.)

● Close. Closes the active Hierarchy View. (Same as the Close this View command
on the Hierarchy View Pop-Up Menu.)
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Connection View
In the Connection View (shown in Figure 11), you can trace connections through the
design. Select a port or a semiconductor vendor (SCV) instance and click on the Create
Connection View button to view associated input and output connections.

Figure 11: Connection View

Connection
pane

Tool bar

Status bar
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In the Connection View, ports on an instance include the following visual clues:

● A circle in the port indicates inverted input or output.

● Violet ports are connected to power and green ports are connected to ground.

The Connection View also contains a tool bar for common tasks and an optional status
bar.

Showing Port Drivers or Receivers
To show port drivers or receivers, do one of the following:

● By selection:

a. In Connection View, select the port.

b. Click on the Expand tool.

● By double-clicking on the port in Connection View.

You can continue expanding connections until you reach an SCV device pin.

Note�

An unconnected port displays no net connections when expanded.

Hiding Expanded Port Connections
To hide an expanded port's connections, do one of the following:

● By selection:

a. In Connection View, select the port.

b. Click on the Collapse tool.

● By double-clicking on the expanded port.

Note that the disconnected objects remain visible—to hide them, click on the Hide
Unconnected Objects tool.
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Hiding Individual Net Connections
To hide an individual net connection, select the net and click on the Hide Selected
Object tool (or press Delete).

Showing an Instance in the Connection View
To show an instance in the active Connection View, select the instance and choose Add
Current Selection from the Connection View pop-up menu.

Undoing a Wide Fan-In or Fan-Out
To undo a wide fan-in or fan-out, follow these steps:

1. Select the net into or out of the expanded port.

2. Click on the Hide Selected Object tool (or press Delete).

3. Click on the Hide Unconnected Circuit Objects tool.

Creating a Sparse Hierarchy View
To create a sparse Hierarchy View, follow these steps:

1. Use the Expand Selection, Collapse Selection, Hide Selected Circuit Object, and/or
Hide Unconnected Circuit Objects tools to display the instances and ports of
interest.

2. Click on the Create Sparse Hierarchy button.

A new Hierarchy View displays just the portion of the design hierarchy that contains the
ports and instances in the active Connection View.
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Connection View Pop-Up Menu
You can use the Connection View pop-up menu shown in Figure 12 to perform several
functions.

Figure 12: Connection View Pop-Up Menu

● Raise Application Shell Window. Brings the VSB main window to the top.

● Zoom. Displays several zoom levels: detail, high, medium, and low. (Similar to
the Zoom tools on the Connection View Tool Bar.)

● View Controls:

❍ Toolbar. Toggles display of the tool bar in the active Connection View.

❍ Status Bar. Toggles display of status information in the active Connection
View.

❍ Iconify. Reduces the active Connection View to an icon.

❍ Close. Closes the active Connection View. (Same as the Close tool on the
Connection View Tool Bar.)

● Expand. Shows the connections from the selected port. (Same as the Expand tool
on the Connection View Tool Bar.)
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● Collapse. Hides the connections from the selected port. Note that the disconnected
objects remain visible—to hide them, click the Hide Unconnected Objects tool.

(Same as the Collapse tool on the Connection View Tool Bar.)

● Find Current Selection. Centers the selected circuit object in the active
Connection View, if the view contains the object. Use this command after you select
an object in another view or tool. (Same as the Find tool on the Connection View
Tool Bar.)

● Add Current Selection. Adds an instance, selected in some other view, to the
active Connection View.

● Auto Find Selection. When possible, automatically updates the active Connection
View to focus on the selected object.

● Create Sparse Hierarchy View. Displays a portion of the design hierarchy
containing just the objects in the active Connection View.

● Hide Unconnected Objects. Hides objects in the active Connection View that are
not connected to any other object in the view. You can use this command to prepare
for creating a sparse hierarchy view.

● Hide Selected Object. Hides the selected object in the active Connection View.
You can use this command to prepare for creating a sparse hierarchy view.

● Show Scope Paths. Displays (below each instance) the path to the instance from
the root of the design.
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Connection View Tool Bar
Figure 13 illustrates the tool bar buttons available in the Connection View.

Figure 13: Connection View Tool Bar Buttons

● Zoom Detail. Each instance is labeled with its name and cell type, and the number
of contained instances and semiconductor vendor (SCV) cells.

● Zoom High. Each instance is labeled with its name and cell type.

● Zoom Medium. Each instance is labeled with its name and cell type.

● Zoom Low. Instances are not labeled, but circuit object tips show the name and cell
type of each instance.

Expand Selection

Close View

Collapse Selection

Find Selection
Create Sparse

Hierarchy

Hide Selected
Circuit Object

Hide Unconnected
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Change Zoom
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● Expand Selection. Shows the connections from the selected port. (Same as the
Expand command on the Connection View Pop-Up Menu.)

● Collapse Selection. Hides the connections from the selected port. Note that the
disconnected objects remain visible. (Same as the Collapse command on the
Connection View Pop-Up Menu.)

● Find. Centers the selected object in the active Connection View, if the view
contains the object. Use this command after you select an object in another view or
tool. (Same as the Find Current Selection command on the Connection View
Pop-Up Menu.)

● Create Sparse Hierarchy. Displays (in a new Hierarchy View) just the portion of
the design hierarchy that contains objects visible in the active Connection View.

● Hide Selected Object. Hides the selected circuit object in the active Connection
View.

● Hide Unconnected Objects. Hides circuit objects in the active Connection View
that are not connected to any other object in the view.

● Close. Closes the active Connection View. (Same as the Close this View command
on the Connection View Pop-Up Menu.)
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Examine View
In the Examine View window, you can view and modify detailed information about
model instances, as shown in Figure 14.

Figure 14: Examine View Window

Graphical Pane
This area shows port names and the connected nets. Right- and left-pointing triangles
indicate signal direction. Grey circles indicate port inversion. Power and ground labels
are also visible.

If the instance has timing or state information, the corresponding down arrow button
(Timing Form or State Form, below the graphical pane) is enabled. Click on a down
arrow button to show the corresponding form.

When the Timing Form is visible, you can click on a port name in the graphical pane to
highlight the timing parameters associated with that port.

Timing Form
The Timing Form contains a list of timing parameters on the left. Select a parameter to
view the following information:

● Name. The selected timing parameter.

● Description. A description of the timing parameter.

Graphical
pane

Timing form
button

State form
button
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● Timing Value Units. Specifies whether to display values in picoseconds,
nanoseconds, microseconds, or milliseconds; select one.

● Values in .ccn File. The min, typ, and max values for the selected timing
parameter, as stored in the .ccn file.

● Current Values. The min, typ, and max values for the selected timing parameter,
as modified but not yet saved to the .ccn file.

When the Timing Form is visible, you can click on a timing parameter in the parameter
list to highlight the associated ports in the graphical pane.

If you change the information on the Timing Form, click on the Accept Modification
button to record your changes.

State Form
The State Form contains a list of states on the left. Select a state to view the following
information:

● Name. The selected state.

● Description. A description of the selected state parameter.

● Value in .ccn File. The value of the selected state parameter, as stored in the .ccn
file.

● Current Value. The value of the selected state parameter, as modified but not yet
saved to the .ccn file.

● Bit Position. The offset of the last bit selected in the “Value in .ccn File” field.

If the state contains more than one bit, a slider appears below the Bit Position field.
Drag the slider, click on the right and left arrow buttons, or use the right and left
arrow keys to select a different bit.

To change a bit's value, select the bit and type the value you want it to have. Legal
characters are 0, 1, x (unknown), u (uninitialized), z (high-impedance), and
- (unspecified).

If you change the information on the State Form, click on the Accept Modification
button to record your changes.
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Examine View Pop-Up Menu
You can use the Examine View pop-up menu shown in Figure 15 to perform several
functions.

Figure 15: Examine View Pop-Up Menu

● Raise Application Shell Window. Brings the VSB main window to the top.

● View Controls:

❍ Iconify. Reduces the active Examine View to an icon.

❍ Close. Closes the active Examine View.
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Global Selection Tool
You can use the Global Selection dialog box to select an instance, net, or port by name.
You can also open this dialog box to see which circuit object is the global selection, as
shown in Figure 16.

Figure 16: Global Selection Tool

If you know the name of the circuit object you want to select, type the name in the
Circuit Object field and, if necessary, type the path to the circuit object in the Scope
field. Make sure the Object Type selection is correct.

If you know only a portion of the circuit object name or want to select from a list of
objects, you can browse the design. Click on the Select Global button to select the
specified instance, net, or port globally. The Browse Filter field recognizes regular
expressions and presents a list of all instances that match the pattern you specify in the
Browse Filter field.

Object
type:
Ports
Nets
Instances

Scope
of instance
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Browsing for an Object
To browse for an object, follow these steps:

1. In the Scope field, type the path to the circuit object you want to select.

2. In the Browse Filter field, type part of the object name, or type a regular expression
to specify one or more objects.

3. Click on the Browse Given Scope button (or press Enter while the Browse Filter
field has the focus).

Traversing the Hierarchy
To traverse the hierarchy, follow these steps:

1. Set the Object Type to Instances.

2. Set the Browse Filter field as needed.

3. Click on the Browse Given Scope button.

4. To move down the design hierarchy, double-click on an instance in the list.

5. To move up the design hierarchy, double-click on the “double dots” (..) at the top of
the list.

Note�

At the root of the design hierarchy, the list shows (Device: device-name),
rather than the double dots.

Regular Expressions
Use the Browse Filter field and the Browse Given Scope button in the Global Selection
tool to specify a character or string that appears anywhere in the found names; you can
use standard regular expression syntax in the Browse Filter field.

Matching a Character
To match a character, use any of the following syntax in the Browse Filter field and
press the Browse Given Scope button to activate it:

\specChar
Where specChar is one of the following:

\ [ ] ^ - . ? + * Matches the character literally; the backslash “escapes” the
special character.

char
Matches any other (non-special) character.
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[chars]
Matches any of the characters in the brackets.

[^chars]
Matches any character except those in the brackets.

[char1-char2]
Matches any of the characters in the range char1 to char2.

Examples:
[a-z] Matches any lowercase letter.
[0-9] Matches any digit.

[^char1-char2]
Matches any character outside the range char1 to char2.

. (period)
Matches any single character.

? (question mark)
Matches an optional preceding element.

Examples:
ab?c Matches abc and ac.
a[a-z]?c Matches ac, aac, abc, . . . , azc.

Matching a String
To match a string, use any of the following syntax in the Browse Filter field and press
the Browse Given Scope button to activate it:

+ (plus sign)
Matches one or more occurrences of the preceding element. For example:

ab+c Matches abc, abbc, abbbc, and so on.
A[a-z]+ Matches A followed by one or more lowercase letters.

* (asterisk)
Matches zero or more occurrences of the preceding element. For example:

ab*c” Matches ac, abc, abbc, abbbc, and so on.
X[123]* Matches X, optionally followed by any combination of

1s, 2s, and 3s.

You can also concatenate regular expressions to create a string. For example,
“A[a-z]+_Bus[0-9]*” matches A followed by one or more lowercase letters, then _Bus,
then zero or more digits (such as Addr_Bus00 and Address_Bus).
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Net Tags Tool
Use this Net Tags dialog box (shown in Figure 17) to tag specific nets and set the color
of the nets in Connection View. Displaying different nets in different colors can make it
easier to identify connection paths through a design.

Figure 17: Net Tags Tool

Tagging a Net
To tag a net, follow these steps:

1. In the Net Tags tool, select a color.

2. In Connection View, select a net.

While the pointer is a hand, every net you select is added to the list under the current
color choice.

3. When you finish tagging nets, click on the current color choice again or close the
Net Tags tool.
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Removing Tags from Nets
To remove the tag from one or more nets, follow these steps:

1. In the Net Tags tool, select the nets to untag.

2. Click on the Clear Selected Net Tags button.

To remove the tag from all the nets of a given color, click on the Clear List button under
the corresponding color choice list.
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Windows & Monitors Tool
You can use the Windows & Monitors dialog box (shown in Figure 18) to do the
following:

● Designate nets, states, and buses for windowing or monitoring

● Create and modify buses and aliases

● Create model command files (MCFs) for simulation

Figure 18: Windows & Monitors Tool
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The upper pane contains a graphical hierarchy of window and monitor types:

The graphical pane shows all the items of the selected type. When a bus is selected, the
Add Bus button changes to an Update Bus button as long as a bus is selected. For more
information, refer to “Creating and Editing Buses” on page 47.

The buttons to the right of the list have the following functions:

● Select Global. Makes the selected item (in the list) the global selection.

● Clear Selection. Removes the selected item from the list.

● Clear List. Removes all items from the list.

● Preview File. Opens a dialog that shows what the generated model command file
will look like.

● Save To File. Creates a model command file (MCF) containing the current
information on windows, monitors, and bus definitions.

● Illegal Chars. Specifies illegal characters for window and monitor names.

Windowing or Monitoring Nets and/or States
To window or monitor one or more nets and/or states, follow these steps:

1. Click on the Automatically Add New Selections button.

The cursor will turn into a cross-hair.

2. Choose the Nets and/or States check box(es) in the Object Type field.

3. Choose the Windows and/or Monitors check box(es) in the Add To field.

4. While the pointer is a cross-hair, select the net(s) and/or state(s) you want.

Every item you select is added to the appropriate window or monitor lists. Click on
the Automatically Add New Selections button again to turn off automatic addition.

Net Windows State Windows Bus Windows

Net Monitors State Monitors Bus Monitors



Chapter 1: VSB Overview Visual SmartBrowser User’s Manual – NT version

46 Synopsys, Inc. February 2001

�

Creating and Editing an Alias
To create an alias for a net or a state, follow these steps:

1. In the upper graphical pane, select a net.

2. In the Add Alias text box, enter the name of the alias for the net or state.

Note�

Visual SmartBrowser maps an alias to the appropriate name.

You can also perform in-place editing in the alias lists in order to add aliases, update
alias names, and perform parallel operations on buses:

1. Click inside a selected net.

2. Modify the name of the net to create a new alias; pressing the Return key or clicking
outside the edit box accepts the name modification, while pressing the Escape key
aborts the edit.

Clicking inside selected buses enables you to add a new bus, after which you can
click on the new bus in order to edit its name.

Removing Aliases
To remove an alias, follow these steps:

1. In the upper graphical pane, select the appropriate alias you want to remove.

2. Press the Clear Selection button to remove the alias.

Creating a Model Command File (MCF)
To create a model command file (MCF), follow these steps:

1. Click on the Save To File button.

2. Specify the path and name for the MCF.

Specifying Illegal Characters
To specify illegal characters for window and monitor names, follow these steps:

1. Click on the Illegal Chars button.

2. Clear the Illegal Chars and Substitute Chars fields.

3. Click on the OK button.
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Creating and Editing Buses
Following are procedures for using the Windows & Monitors tool to create and edit
buses.

Displaying Bus Elements
To display bus elements in the upper graphical pane at the top of the Windows &
Monitors tool, double-click on either Windows > Buses or Monitors > Buses.

Figure 19: Creating Buses in Windows & Monitors Tool
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Defining a Bus Name
To define a bus name, do one of the following:

● To specify a bus under either Windows > Buses or Monitors > Buses, do the
following

a. Select either Windows > Buses or Monitors > Buses.

b. In the Add Bus field, type the name of the bus you want to create, and press
Enter.

The bus nam is added to the appropriate list.

● To define a bus name for other net or state options:

a. In either the Windows > Buses or Monitors > Buses lists, select one of the
other (Nets or States) options.

b. In the Add Bus field, type the name of the appropriate bus, and press Enter.

The bus name is added to the Windows > Buses or Monitors > Buses list,
depending on whether the nets are designated for windowing or monitoring.

Note�

Visual SmartBrowser maps illegal characters in the bus name with the
specified substitute characters.

Reordering Elements in a Bus
To reorder the elements in a bus, follow these steps:

1. In the upper graphical pane under Windows > Buses or Monitors > Buses, select
the name of the bus.

2. Drag the bus name to the location where you want it.

Removing a Bus Element
To remove a bus element, follow these steps:

1. In the upper graphical pane under Windows > Buses or Monitors >Buses, select
the element to remove.

2. Click on the Clear Selection button.

To remove all the elements of a bus, follow these steps:

1. In the upper graphical pane under Windows > Buses or Monitors > Buses, select
the bus.

2. Click on the Clear List button.
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3. OK the message box that tells you the items will be deleted.

Renaming a Bus
To rename a bus, follow these steps:

1. In the upper graphical pane under Windows > Buses or Monitors > Buses, select
the bus.

2. Enter the new name of the bus in the Update Bus field.

Deleting a Bus Definition
To delete a bus definition, follow these steps:

1. In the upper graphical pane under Windows > Buses or Monitors > Buses, select
the bus.

2. Click on the Clear Selection button.

Specifying Illegal Characters
For window and monitor names, VSB normally defines the slash (/) as an illegal
character and substitutes it with an underscore (_).

Disabling Illegal Character Substitutions
To disable illegal character substitution, follow these steps:

1. In the Windows & Monitors tool, click on the Illegal Chars button.

2. Clear the Illegal Chars and Substitute Chars fields.

3. Click on the OK button.

Until you specify an illegal character, VSB does not create automatic aliases or
validate bus names. Existing aliases, however they were created, are not affected.

Defining Illegal Characters
To define illegal characters, follow these steps:

1. In the Windows & Monitors tool, click on the Illegal Chars button.

2. In the Illegal Chars field, type any characters not accepted by the target simulator.
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3. In the Substitute Chars field, type the characters that will replace them.
Substitutions are position-dependent.

To illustrate position-dependency, say you type “abcde” in the Illegal Chars field
and ABCDE in the Substitute Chars field. VSB creates an alias of A_nEt for a_net
and renames a_bus as A_Bus.

Note�

If you specify fewer characters in the Substitute Chars field than in the
Illegal Chars field, VSB replaces unmatched characters in the Substitute
Chars field with the last character specified in the Illegal Chars field.

4. Click on the OK button.

VSB uses the information in this dialog box to validate all existing net and bus
names and net aliases:

❍ If a net name contains illegal characters, VSB creates an alias for it, using
substitute characters.

❍ If a bus name contains illegal characters, VSB renames it, using substitute
characters.

❍ If an alias contains illegal characters, VSB maps the illegal character to the
correct character.

Visualizing a Setup or Hold Violation
Here is a sample setup violation error message generated by VSB:

Error: Violated setup constraint TSUD on D before CLK for cell /FA1A/df1
at time 27510.8 ns.

Actual setup time was 0.2 ns, specified minimum is 7.8 ns.
Model Id 0 Instance (A1010A_100-1) 27510.8 ns.

To find the point of violation noted in the error message, follow these steps:

1. Click on the Show Global Selection Tool button.

2. In the Circuit Object text field, enter the name of the object (df1) cited in the error
message. This is the string of characters following the last slash (/).

3. In the Scope text field, enter the path to the cited instance (/FA1A). This is the string
of characters preceding the last slash.

4. Make sure the Object Type is correct (Instances, in this example).
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5. Click on the Select Global button.

6. Click on the Create Connection View button.

7. Click on the Create Examine View button to check timing values.

Visualizing a Cause Report from a Simulation Run
Here is a sample cause report generated by the LMC Model Trace:

Trace: Triggering cause report from “FA1A_S”:
4028.5 ns 1->X on model port FA1A_S.
4028.5 ns 1->X on cell port /FA1A_S/U0/PAD, net FA1A_S.
4012.8 ns 1->X on cell port /I$4/U1/S, net N$8.
4002.7 ns 1->X on cell port /FA1A_CI/U0/Y, net N$6.
4000.0 ns 1->X on model port FA1A_CI.

Report completed.
Model Id 0 Instance (A1010A_100-1) 4028.5 ns.

To find out the underlying cause of the problem, open the cited port in Connection View
by either of these methods:

● Using the Show Global Selection button:

a. Click on the Show Global Selection button.

b. In the Circuit Object text field, enter the name of the port (FA1A_S) cited in the
cause report.

c. In the Scope text field, enter the path to the cited port (/).

d. Make sure the Object Type is set to Ports.

e. Click on the Select Global button.

f. Click on the Create Connection View button.

● From the Hierarchy View:

a. In Hierarchy View, select the root instance.

b. From the list of ports below the hierarchy pane, double-click on the port
(FA1A_S) cited in the cause report.

Next, trace the input signals following these steps:

1. In Connection View, double-click on the port to show the fan-in signals.

2. On the instance (/FA1A_S/U0) cited in the next line of the cause report,
double-click on the cited port (PAD).

3. On the instance (/I$4/U1) cited in the next line of the report, double-click on the
cited port (S).
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If necessary, use the scroll bar at the bottom of the connection pane to display
instances to the left.

4. On the instance /FA1A_CI/U0, double-click on port Y.

5. Follow net N$6 to input port FA1A_CI.

Visualizing an Effect Report from a Simulation Run
Here is a sample effect report generated by the LMC Model Trace:

Trace: Triggering effect report from ‘FA1A_A” at 4000.0 ns:
Model Id 0 Instance (A1010A_100-1) 4000.0 ns.

Trace: 4002.7 ns Effect 1->0 on cell port /FA1A_A/U0/Y, net N$2.
Model Id 0

Trace: 4013.1 ns Effect X->0 on cell port /I$4/U0/CO, net N$7.
Model Id 0

Trace: 4022.3 ns Effect X->0 on cell port /I$4/U1/S, net N$8.
Model Id 0

Trace: 4030.2 ns Effect X->0 on cell port /FA1A_CO/U0/PAD, net FA1A_CO.
Model Id 0

Trace: 4030.2 ns Effect X->0 on model port FA1A_CO.
Model Id 0

To find out the underlying cause of the problem, open the cited port in Connection View
using either of these methods:

● Using the Show Global Selection button:

a. Click on the Show Global Selection button.

b. In the Circuit Object text field, enter the name of the port (FA1A_A) cited in the
cause report.

c. In the Scope text field, enter the path to the cited port (/).

d. Make sure the Object Type is set to Ports.

e. Click on the Select Global button.

f. Click on the Create Connection View button.

● From the Hierarchy View:

a. In Hierarchy View, select the root instance.

b. From the list of ports below the hierarchy pane, double-click on the port
(FA1A_A) cited in the cause report.
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Next, trace the output signals:

1. In Connection View, double-click on the port to show the fan-out signals.

2. On the instance (/FA1A_A/U0) cited in the next line of the cause report,
double-click on the cited port (Y).

3. On the instance (/I$4/U0) cited in the next line of the report, double-click on the
cited port (CO).

If necessary, use the scroll bar at the bottom of the connection pane to display
instances to the right.

4. On the instance /I$4/U1, double-click on port S.

5. On the instance /FA1A_CO/U0, double-click on port PAD.

6. Follow net FA1A_CO to output port FA1A_CO.

Using Traces from a Simulation Run in Causal Trace
You can use the Causal Trace tool to cut-and-paste traces from a simulation in order to
look for cause-and-effect information for a model.

Here is an example of traces in a cause report generated from the simulation of a model:

LMC Model Trace in 'TB.DUT.CFPGA.SMARTMODEL'at 16100 ps:
Beginning cause report from "JDOE_FSRAMCE":
16.1 ns 0->X on cell port /U1287/$1I20.GTS.TRI/OUT, net FSRAMCE
16.1 ns 0->X on cell port /U1287/$1I20/OUT, net /U1287/$1I20.GTS.TRI
5.3 ns 0->X on cell port /FSRAMCE_INT_reg/OUT, net n3398
5.3 ns X->1 on cell port /FSRAMCE_INT_reg/CLK, net n2468
3.9 ns X->1 on cell port /U879;clkbuf/OUT, net n2468
0.0 ns X->1 on cell port /U879;clkio_buf/OUT, net U879;clkio_bufsig
0.0 ns X->1 on model port FCLOCK
Report completed.

To find out the underlying cause of the problem, do the following:

1. In the main window, click on the Causal Trace button.

2. Cut and paste the appropriate portion of your simulation output into the VSB Causal
Trace window.
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Figure 20: Causal Trace Tool

a. Click on the Show Trace button.

The VSB will parse the output, looking for cause reports in the LMC Model Trace
output. If it finds complete reports, it will open a new Connection View for the
report and show the cause and effect path

Viewing and Editing Instance Timing and Initial State
Values

To view timing and state information, follow these steps:

1. Display the instance in Examine View using one of these methods:

❍ In a Hierarchy View, double-click on the leaf instance.

❍ In a Connection View, double-click on the instance.

❍ Select the instance; then click on the Create Examine View button.

2. Click on the Timing Form or State Form down arrow to display the related
information.

Note�

The down arrows are enabled only if the selected instance includes the
corresponding timing and state information.

3. If you change the timing or state information, the Accept Modification button is
enabled. Click the button to record your changes.

LMC Model Trace in 'TB.DUT.CFPGA.SMARTMODEL'at 16100 ps:
Beginning cause report from "JDOE_FSRAMCE":
16.1 ns 0->X on cell port /U1287/$1I20.GTS.TRI/OUT, net
16.1 ns 0->X on cell port /U1287/$1I20/OUT, net /U1287/
5.3 ns 0->X on cell port /FSRAMCE_INT_reg/OUT, net
5.3 ns X->1 on cell port /FSRAMCE_INT_reg/CLK, net
3.9 ns X->1 on cell port /U879;clkbuf/OUT, net n2468
0.0 ns X->1 on cell port /U879;clkio_buf/OUT, net
0.0 ns X->1 on model port FCLOCK
Report completed.
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Selecting Circuit Objects
This section provides information on how to select circuit objects under different
circumstances.

● In a Hierarchy View, click on an instance or port to make it the global selection.

● In a Connection View, click on a net, port, or instance to make it the global
selection.

● In the Global Selection tool, select a port, net, or instance, and click on the Select
Global button.

● In the Net Tags tool, select a net, and click on the Select Global button.

● In the Windows & Monitors tool, select a net or instance, and click on the Select
Global button.

Menu Commands
The following sections list the different menus and the functions you can access from
them.

File Menu
The following commands are available from within the File menu:

● Open. Displays a dialog box in which you select a netlist file to open.

● Save As. Saves the active netlist file. This option is available when you change
timing or initial state values. Changes do not affect the design from which the netlist
file was created.

● file_name(s). Brings up a .ccn file that has been previously opened.

● Exit. Ends the active VSB session.

Options Menu
The following commands are available from within the Options menu:

● Toolbar. Toggles display of the tools icons that access the different windows.

● Status Bar. Toggles display of status information in the main window.

● Show Tool Tips. Toggles display of tool descriptions.

● Show Circuit Object Tips. Toggles display of circuit object descriptions.
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View Menu
The following commands are available from within the View menu:

● Hierarchy. Opens a Hierarchy View based on the selected object.

● Connection. Opens a Connection View based on the selected object.

● Examine. Opens an Examine View based on the selected object. You can use an
Examine View to edit timing and initial state values and view other details about the
selected object.

● Message Window. Opens a VSB message window in which you can see the
version of the VSB and any messages that the VSB reports.

Tools Menu
The following commands are available from within the Tools menu:

● Show Global Selection Tool. Opens the Global Selection tool, where you can
select nets, ports, and model instances by name.

● Show Net Tags Tool. Opens the Net Tags tool, where you can set tags (colors) for
specific nets.

● Show Windows & Monitors Tool. Opens the Windows & Monitors tool, where
you can set up windows and monitors for nets, states, and buses.

● Show Causal Trace Tool. Opens the Causal Trace tool in which you can cut and
paste a portion of your simulation output. VSB will parse the output, looking for
cause reports in the LMC Model Trace output and open a new Connection View to
show the cause and effect path.

Window Menu
The following commands are available from within the Window menu:

● Iconify All Windows. Reduces the main window and all Hierarchy, Connection,
and Examine View windows to icons. Also closes all tool windows.

● Iconify All Views. Reduces all Hierarchy, Connection, and Examine View
windows to icons.

● Raise All Views. Restores all Hierarchy, Connection, and Examine View windows.

● window_name. Brings the named window to the top. Each window name specifies
the view and the port or instance on which it is based.
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2
Learning Visual SmartBrowser

Introduction
The Visual SmartBrowser (VSB) enables you to improve your productivity when
working with SmartCircuit models of FPGA and CPLD devices. This chapter presents a
brief tutorial that you can use as the basis for learning how to use the VSB. You can use
the tutorial to learn how to:

● Work with a post-layout netlist (in the SmartCircuit .ccn format)

● Examine the design in various graphical views

● Define buses

● Specify circuit objects to window and monitor during simulation

● Create a model control file for simulation

Setting Up the Tutorial
You open a compiled design netlist (.ccn) file by starting VSB with the netlist file name
on the command line; VSB will not invoke without a file name. In this section, you will
use a file prepared specially for the tutorial. The file is located at:

%$LMC_HOME%\lib\data\vsb_tutorial.ccn

1. To begin the tutorial, open the sample netlist included in your SmartModel Library
installation using this command:

vsb %$LMC_HOME%\lib\data\vsb_tutorial.ccn

If you already have the VSB running and your current design is not
vsb_tutorial.cnn, re-invoke the VSB using the previous command.
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After VSB reads the tutorial design netlist, it briefly shows the number of instances
in the design and then creates a VSB Main Window that looks like this:

Note�

Some illustrations of the windows in this tutorial have been slightly altered
in order to make them less awkward on the page. If a window in your VSB
session comes up slightly different than what you see in an illustration, don’t
worry; the graphic has probably been adjusted.

Before you actually get started with the tutorial, here are some suggestions for arranging
your screen so you have more room to work:

1. Move the main window to the upper right corner of your screen.

2. If you are using this tutorial online in PDF format, move the tutorial window to the
lower right corner, and make it as tall as possible without covering the main
window.

3. Press the page button in the Acrobat Reader to turn off the bookmarks and
maximize your reading space.

4. Make the tutorial window about a third to a fourth of the overall screen width,
depending on the size of your monitor.

You can always adjust the windows to your liking later.
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Using the VSB
The main window is not only an entry point into your design when you invoke VSB, but
it provides you a means to display different windows that have specialized purposes. In
essence, the main window acts as a central control while you work in a VSB session.
When using the VSB, you will be able to use the main window to navigate back and
forth between these various windows.

Before bringing up any of these other windows, let’s look at the different functions
within the main window itself. First, you should know that the initial main window does
not display all tool buttons—such as the Connection View—when you invoke VSB; tool
buttons are context sensitive, relative to the current selection. The main window is
capable of displaying the following information:

● Menu bar—displays by default.

● Buttons to open the various views and tools—display by default, although some are
greyed out by default until an appropriate time.

● View control pane with icons for all open views—displays icons only when a
specialized window is open.

● Status bar—displays only if you choose the Options > Status Bar menu item.

Here is how the main window can look when you open different specialized windows
and display the Status Bar:

Menu Bar

Hierarchy View

Connection View

Examine View

Global Selection Tool

Net Tags Tool

Windows & Monitors Tool

View Control Pane

Button Button Button

Button

Button Button

Status BarIcons in View Control Pane

Causal Trace
Button
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Now that you are familiar with the different areas in the main window, let’s open a
Hierarchy View, which is a common first step when using VSB.

1. Click on the Create Hierarchy View button.

VSB displays the design in a new Hierarchy View.

This is the “root” instance or “design” instance. It represents the design described
by the netlist, and in VSB it is treated as a device. The instance is colored—
depending on your color map—because it is selected. Only one circuit object can be
selected at a time, so it’s called the global selection.

2.To deselect the instance, click on any
unoccupied space in the upper pane of
the Hierarchy View. Try it now. The
instance isn’t colored any more, because
it’s not selected.

3.Click on the instance now to reselect it.

You can see each port’s direction (I, O, or
I/O, as defined in the netlist), its name,
and—for the design instance—the
corresponding symbol pin name in
parentheses. For example, CLOCK_IR is
an input/output port that corresponds to
pin DP055 on the device symbol.

4.Click on the CLOCK_IR port now.

It turns color because it’s selected. But it’s
part of the instruction_register instance,
so the instance is still selected, too.

5.Click now on any unoccupied space in the
lower (port) pane to deselect the port.

Notice that the instance is still selected in
the upper (hierarchy) pane.

6.Click now on any unoccupied space in the
hierarchy pane to deselect the instance.

The instance is labeled with its cell type, its
name, and the number of instances—hierarchical blocks and semiconductor vendor
(SCV) instances—at the next level down.

Design Instance

Hierarchy Pane

Port Pane

Tool Bar

Status bar
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7. Double-click on the instance now to expand the hierarchy beneath it; you may need
to adjust the hierarchy pane to see more instances.

8. Drag the view divider down so more of the
hierarchy is visible.

9. Double-click on the instruction_cell instance
I$12 to expand it.

10. Scroll the Hierarchy View in order to see the
expanded hierarchy.

Two visual clues distinguish an SCV instance
from a hierarchical instance: 1) the SCV
instance is outlined in black, and 2) its label
shows that it contains 0 instances. The
instruction_cell instance named I$12 contains four SCV instances.

11. Double-click on the DFPC named I$12.

When you double-click on an SCV instance, VSB displays it in a new Examine
View; you can resize or move the Examine View window if it covers the tutorial or
another window.

View
Divider

Graphical
Pane

Timing Form
Button

State Form
Button
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This instance includes timing information.

12. Click on the Timing Form down-arrow button near the bottom of the Examine View.

13. In the upper (graphical) pane of the Examine View, click on the text label for each
input port (D, CLK, CLR, and PRE).

The timing parameters associated with each port are highlighted in the Timing list
as you select the port in the graphical pane.

14. Click on the TS_D_CLKNL0 timing parameter at the top of the Timing list.

VSB displays information about the parameter to the right of the list.

As shown, TS_D_CLKNL0 is the setup time on D before CLK. In the .ccn file, the
Min, Typ, and Max values for this instance are 1300, 3600, and 5200 ps,
respectively (as specified in the netlist). The current values show that the instance
has not been modified since the .ccn file was opened.

You can display these values in different units (ps, ns, us, or ms), and you can
change the values.

15. Change the minimum value from 1300 ps to 1.35 ns.

Note that your changes affect only this VSB session, unless you save the modified
netlist (.ccn) file. Even then, the changes do not affect the original design, just the
netlist.

As soon as you begin typing in the Min entry box, the Accept Modification button
becomes available. This button changes the value for this instance.

Timing
Parameters
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For this exercise, we’ll leave the values unchanged. (So do not click on the Accept
Modification button.)

Notice in the graphical pane above the Timing Form that the instance shows the
association between ports D and CLK by linking them together.

16. Click on some of the other parameters in the Timing list.

When you select a parameter in the Timing list, VSB shows you the associated
ports, as specified in the compiled netlist. Note that some manufacturers define port
delays in which timing information is associated with only one pin.

This instance also includes state information.

17. Click on the State Form down-arrow button.

Any state parameters for the instance are listed on the State Form.

18. Click on the STATE parameter in the list.

As shown, this is the internal state of a DFPC instance. Its default value is “u,” but
you can change the initial value for this instance. Valid bit values include: 0, 1,
x (unknown), u (uninitialized), z (high-impedance), and - (unspecified).

For a complex multiple-bit state value, as with a RAM device, you can find a
specific bit by dragging the Bit Position slider from right to left or clicking on the
arrow buttons beside the slider. VSB shows the current bit position above the slider.

State
parameter
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19. Enter a new value in the Current Value field.

As soon as you begin typing, the Accept Modification button becomes available.
Remember, we’ll leave the values unchanged for this exercise.

20. When you’re ready, click on the Close button in the I$12 Examine View.

Identifying Hierarchical and SCV Instances
There’s another difference between hierarchical instances and SCV instances.

1. In the Hierarchy View, click on the instruction_cell instance named I$12.

If the Hierarchy View is concealed somewhere, you can use the “TOP” icon in the
View Control Pane of the main window to pop it forward.

2. In the port pane, double-click on port
CLOCK_IR.

VSB creates a new Connection View based on
port CLOCK_IR. From there you can explore
the receivers connected to the port.

3. In the Connection View, click the right mouse
button to display the popup menu.

4. Choose the Raise Application Shell Window
command to bring the main window to the
top.

5. In the View Control pane of the main window,
click on the icon labeled TOP.

6. Click on the DFPC SCV instance named I$12.

7. In the port pane of the TOP Hierarchy View,
double-click on port D.

Because D is a port on an SCV instance,
there’s no underlying hierarchy; so the new Connection View is based on the
instance rather than the port.

8. Now explore the receivers connected to the DFPC instance I$12:

a. For this exercise, deselect the DFPC instance in the top Hierarchy View.
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b. In the Connection View of the DFPC I$12 instance, double-click on the Q port
button to expand it.

VSB shows another DFPC instance (I$6)
and an MX2 instance (I$4). The net
connection is shown in cyan, because it’s
the most recently expanded.

9.Double-click on the same port (Q on
I$12) to collapse it.

The fan-out connection is hidden, but
the instances remain.

10.Click on the net connection between
I$6 and I$4. It turns color because it’s
selected.

11.Click on the Hide Selected Object

tool.

12.Click on the Hide Unconnected Objects

tool.

That’s a fast way to undo a wide fan-in
or fan-out; but we need to see those
components to go on with the tutorial.

13.Double-click on the Q port again to
expand it.

14.Expand the Q port on I$6.

15. Expand the PAD port on the OUTBUF_0 instance named U0; scroll to the right to
see the DP046 port.
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You have traced the net connections all the way to I/O port INST_BIT1, which
corresponds to symbol pin DP046 on the design instance.

16. To see the whole connection path at once, choose Zoom High to zoom out from
Detail Zoom to High Zoom.

Determining the Scope of an Instance
Remember that the last expanded net is shown in cyan unless it is also the current global
selection. That makes connections easier to follow as you expand ports across the
design.

1. Reset the zoom level to Zoom Detail.

2. On the I$12 instance, expand the D port to show its drivers.

The Connection View pans to the left to bring the driver instance into view.

The new MX2 instance is named I$4, the same as another MX2 instance in this
Connection View.

Change Zoom Tool

Last
Expanded
Net
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3. Select the I$4 instance you just revealed.

In the status bar at the bottom of the Connection View, the scope of this instance is
shown as /I$12/.

4. Select the other I$4 instance, to the right of I$12.

The status bar shows its scope as /I$13/. It is part of a different hierarchical block.

In Detail Zoom, you can also display the scope of each instance:

5. In the Connection View, click the right mouse button.

6. From the pop-up menu, choose the Show Scope Paths command.

As you can see, some of the ports are green, indicating connection to ground. Ports
connected to power are red. These colors appear only after the port or instance has
been explored in Connection View, Hierarchy View, or Examine View.

Power and ground nets are not shown, even though the ports behave like other ports
on the instances. Unconnected ports, such as Y1 and Y2 on the OUTBUF_0
instance named U0, behave similarly.

Scope
Status

Ground
Port
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Creating a Sparse Hierarchy
Once the Connection View contains all the instances you are interested in, you can
create a Hierarchy View that contains only those instances. This can help you see the
hierarchical nature of a portion of the design without the clutter of unrelated instances.

1. In the I$12 Connection View, click on the Create Sparse Hierarchy tool.

If you zoom out, you can see that
the new sparse Hierarchy View
shows the same five SCV
instances as the Connection View.
As you select the various SCV
instances, they are selected in the
Connection View, too. Remember,
selection is global.

2. In the Hierarchy View you just
created, click on the Close tool.

3. Click on open space in the I$12
Connection View, so no circuit
object is selected.

Using Global Selection
So far, you’ve worked with Hierarchy
View, Connection View, and Examine
View. There are also three dialog tools
in VSB.

1. Bring the main window to the top.

2. Click on the Show Global Selection Tool icon.

In the Global Selection tool, you can move up and down the design hierarchy to find
a specific port, net, or instance by name.

3. In the Object Type area, choose Instances.

4. Click on the Browse Given Scope button.

SCV
Instances
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The list below the button shows all the instances in the current scope (as shown in
the Scope field, near the top of the Global Selection tool).

5. Scroll down the list and double-click on I$12 to move down that hierarchical
branch.

The Scope field shows /I$12/, and the list shows instances in that hierarchical block.

6.In the list, double-click on I$12.

I$12/ is added to the scope, but
it’s an SCV instance, so the list
doesn’t show any instances.
Instead, the list shows double
dots (..), representing the parent
hierarchical block.

7.Double-click on the double dots to
move back up the hierarchy a
level.

8.In the list, click on I$4.

9.Click on the Select Global button
next to the Object Type area.

10.Click on the Close button.

The SCV instance /I$12/I$4 is
selected in the I$12 Connection
View.

Note�

Once you’ve set the scope in the Global Selection tool, you can change the
Object Type and select a port or net just as easily, but we’ll stick with
instances for this exercise.

Scope with
I$12/I$12 instance

Shows there are no
instances below;
indicates a leaf
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Working with Circuit Object Tips
You may have noticed the text boxes that pop up when the pointer rests for a moment
over a net; these are called circuit object tips.

Circuit object tips provide information, not displayed at the current zoom level, about
nets and instances in the active view.

1. From the view control pane of the main window, bring the CLOCK_IR Connection
View to the top.

2. Expand the CLOCK_IR port.

3. Expand the Q port on each of the three DFPC instances in the column you just
exposed.

4. In the next column, expand the top output port (Q, Y, or PAD) on all six instances.

5. Set the zoom level to High.

6. Make the Connection View large enough that you can see all the connection paths.

Circuit Object Tip
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Now check some of the net connections by resetting the pointer briefly over the output
net connection from each of the six output ports you just expanded.

Three of the nets from those six output ports are named N$7. But the circuit object tips
include the scope of the net (if it differs from the scope of the active view), so you can
see that the nets are distinct.

This is especially useful at zoom levels where scope paths are not visible.

As mentioned earlier, the most recently expanded net connection is shown in cyan.
When you select a circuit object, it’s shown in the selection color. These visual aids are
transient; they change each time you expand a port or select a different circuit object.

Rest pointer on
each of
these net
connections
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Visually Identifying Nets with Net Tags
In a complex display like the one you’ve created in the active Connection View, it can
be helpful to assign different colors to specific nets.

1. Bring the main window to the top, and click on the Show Net Tags Tool
button.

2. Arrange the Net Tags tool and the Connection View from CLOCK_IR so you can
see them both completely; if necessary, you can resize the Net Tags tool.

3. In the Net Tags tool, click on the button labeled Tag Net white.

The pointer changes to a pointing hand.

As long as the pointer is a hand, every net you select is tagged with the current color
choice, but you do not change the global selection.

4. In the Connection View for CLOCK_IR, use circuit object tips to find the /I$12/N$7
net. (That's the output from one of the MX2 instances in the third column from the
left.)

5. Click on the /I$12/N$7 net to select it.

The net turns white.

6. In the Net Tags tool, click on Tag Net yellow.

7. In the Connection View for CLOCK_IR, find the /I$13/N$7 net, and select it. (It’s
the net from the other MX2 instance in the same column.)

Tag one more net:.

8. In the Net Tags tool, click on Tag Net green.

9. In the Connection View, select the N$7 net.

10. In the Net Tags tool, click on Tag Net green again.

The standard pointer returns.

As you can see, the net connections are much easier to follow now that they are
tagged. To learn a bit more about the Net Tags tool, continue with these steps:

11. Click on the Tag Net blue button.

12. In the Connection View, select four or five of the other net connections.
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You can see the nets added to the “blue” list as you select them in the Connection
View.

Now clear some nets from the list:

13. In the Net Tags tool, select a couple of nets from the list under Tag Net blue.

14. Make sure the nets in the other three lists are not selected.

15. Click on the Clear Selected Net Tags button.

As you can see in the Connection View, the nets are no longer tagged.

You can also clear an entire list at once.

16. In the Net Tags tool, click on the Clear List button under the list of nets tagged blue.

As with the Global Selection tool, you can change the global selection from within
the Net Tags tool:

17. Select the net from the list under Tag Net white.

18. Click on the Select Global button.

As you can see in the active Connection View, the white net is selected. (That’s why
it’s shown in the selection color, for now.)
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As long as the pointer is a hand, this is the only way you can change the global
selection. You stop tagging, and get back the standard pointer by clicking again on
the active Tag Net button (so that no button is pushed in) or by closing the Net Tags
tool.

19. In the Net Tags tool, click on the Close button.

Net in new
global selection
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Defining Windows and Monitors
There’s one more tool to learn about. With VSB, you can define windows and monitors
on nets, states and buses, and save them in a model control file for use during
simulation.

1. Bring the main window to the top, and click on the Show Windows & Monitors
Tool button.

2. From the hierarchy tree at the top of the Windows & Monitors tool, choose
Monitors > Buses.

3. In the Add Bus field, type N7_Bus, and press the Enter key (or Return).

4. In the hierarchy tree, select the bus you just created.
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5.In the Object Type area, click on the Nets
check box to turn it on.

6.Click on the Automatically Add New
Selections check box to turn it on.

The pointer changes to a cross-hair. As
long as the pointer is a cross-hair, any net
that you select globally is added to the
N7_Bus net. (Use the center of the
cross-hair to select circuit objects.)

7.Ensure that the Bus check box in the Add To
section is checked and make sure the
N7_Bus appears in the text field.

8.Bring the Connection View from
CLOCK_IR to the top.

9.Click on the /I$12/N$7, /I$13/N$7, and N$7
nets; they should be the colored nets
tagged using the Net Tags tool.

The N7_Bus in the hierarchy window of
the Windows & Monitors tool should now
be designated with a plus (+) sign.

10.Click on the “+” sign to expand the
N7_Bus.

11.Click on each of the tagged nets.

12.Select and hold one element in the list
while you drag it to a different position in
the list under the N7_Bus.

You can use the Select Global button to the
right of the list to set the global selection
to an element in the list. Remember,
selection is global; only one circuit object
can be selected at a time.

The Clear Selection button removes any selected elements from the list, and the
Clear List button removes all elements from the list.

13. Try those buttons to remove and clear selected elements in the N7_Bus list.

You can also window or monitor the states of instances that include state
information.

Cross-hair Pointer
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14. In the Element Editor area, click on the Window button.

15. For this exercise, make sure the States and Nets check boxes are pushed in the
Object Type area.

16. In the Add To area, uncheck the Bus box (if it isn’t already) and push the Windows
and Monitors check boxes.

17. In the Connection View from CLOCK_IR, select each of the six DFPC instances
using the cross-hair.

18. In the hierarchy list in the Windows & Monitors tool, select States under the tree.

State information for the six DFPC instances was added to the list as you selected
them, even though the State Windows list wasn’t displayed at the time.

Note�

If you had selected an instance without state information, nothing would
have been added to the State Windows list for that instance.

19. Now look at the Nets under the tree.

The list contains every net (except power and ground) connected to every port on
each of the six DFPC instances you selected.
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In this exercise, you added items to two lists at once, even though neither of the lists was
visible at the time. This is a powerful shortcut, and it is important to understand how to
use it:

While the pointer is a cross-hair, you add items to each list that corresponds to a
“pushed in” button in the Selection Adder area.

Saving Model Control Files (MCFs)
When you’re ready, you can save the window and monitor information to a model
control file for use during simulation.

1. Click on the Save To File button.

2. Set the Selection field to the name and path where you want to save the model
control file, using the filter and lists as needed.

3. For this tutorial, just click on the Cancel button; there is no real information to save.

Note�

If you like, you can use the Preview File button to view what the file would
look like before saving it; use the Page Down and Page Up keys on your
keyboard to navigate through the preview file.

Before you continue, turn off the Automatically Add New Selections function by
clicking on its button in the Windows & Monitors tool. The standard pointer returns.

In the Windows & Monitors tool, you can also create aliases and define substitutes for
characters your simulator does not accept. Refer to “Specifying Illegal Characters” on
page 49 for more information.

Changing Window Views
By now, you probably have a lot of open views and tools all over the screen, but that is
easy to fix

1. Raise the main window.

2. From the Windows pull-down menu, choose the Iconify All Views command.

All open views are reduced to icons—the main window remains.

Note�

The Iconify All Windows command reduces the main window, too; and it
closes the Global Selection, Net Tags, and Windows & Monitors tools.
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This concludes your introduction to Visual SmartBrowser; close the VSB main window
without saving anything. You will discover more features as you use VSB to speed the
design and debug process. If you are using this tutorial online, click on the Close button
above to close the tutorial.
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Index

A
Aliases

creating 46
editing 46
removing 46

B
Blocks

hierarchical, collapsing 24
hierarchical, expanding 24

Buses
creating 47
definitions, deleting 49
editing 47
elements, displaying 47
elements, removing 48
elements, reordering 48
monitors 45
names, defining 48
renaming 49
windows 45

Buttons
Close View 68
Create Hierarchy View, in tutorial 60
Create Sparse Hierarchy 68
Hide Selected Circuit Object 65
Hide Unconnected Circuit Objects 65
in Main window 15
Show Global Selection 68
Show Net Tags 72
Show Windows & Monitors 75
tool 18
view 18

C
Cause reports

from a simulation run 51, 53
Characters

illegal substitutions, disabling 49
illegal, defining 49

illegal, specifying 46, 49
matching 40

Circuit object tips
toggling 16

Circuit objects
selected, hiding 33, 35
unconnected, hiding 33, 35
viewing 16

Commands
menu 55
vsb 15

Connection 34
Connection view 14, 18, 21, 29

closing, from tool bar 35
instance, showing in 31
pop-up menu 32
showing port drivers 30
showing receivers 30
tool bar 34

Connections
collapse port, from pop-up menu 33
expand port, from pop-up menu 32
expanded port, hiding 30
exploring from a port 24
net, hiding 31

Control file
model, creating 17

Controls
view, from pop-up menu 26, 38

CPLD devices 11

D
Definitions

bus, deleting 49
Designs

opening 15
Detail zoom

in connection view 21
in hierarchy view 20, 26, 27, 34

Details
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instance, displaying 25
Devices

CPLD 11
FPGA 11

Displays
change from popup menu 32

Divider
view, in tutorial 61

Drivers
port, showing in Connection view 30

E
Elements

bus, displaying 47
bus, removing 48
bus, reordering in a 48

Examine view 14, 18, 36
pop-up menu 38

Expressions
regular 40

F
Fan-in

undoing 31
Fan-out

undoing 31
File menu 55
Files

model control, creating 17, 46
Forms

State 37
Timing 36

FPGA devices 11

G
Global selection tool 18, 39
Graphical pane 36

H
Hierarchy

blocks, collapsing 24
blocks, expanding 24

collapse tree, from pop-up menu 26
expand tree, from pop-up menu 26
traversing 40

Hierarchy view 14, 18, 20, 23
closing, from tool bar 28
pop-up menu 25
sparse, creating 31, 33, 35
tool bar 27

High zoom
in connection view 21
in hierarchy view 20, 26, 27, 34

Hold violations
visualizing 50

I
Illegal characters

defining 49
specifying 46, 49
substitutions, disabling 49

Instances
details, displaying 25
displaying 16
showing in connection view 31
timing, editing 54
timing, viewing 54
top-level, displaying 25

L
Levels

zoom 20
zoom, setting 22

Low zoom
in connection view 21
in hierarchy view 20, 26, 27, 34

M
Main window 15

elements 15
Medium zoom

in connection view 21
in hierarchy view 20, 26, 27, 34

Menu bar
in Main window 15
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Menus
commands 55
File 55
Options 55
pop-up menu, connection view 32
pop-up menu, examine view 38
pop-up menu, hierarchy view 25
Tools 56
View 56
Windows 56

Model control file
creating 17, 46

Models
SmartCircuit 11

Monitors
bus 45
net 45
state 45

N
Names

bus, defining 48
Net Tags tool 18
Nets

connections, hiding individual 31
monitoring 45
monitors 45
removing tags 43
tagging 42
tagging tool 42
windowing 45
windows 45

O
Objects

browsing for 40
circuit, viewing 16
selected circuit, hiding 33, 35
unconnected circuit, hiding 33, 35

Options menu 55

P
Panes

graphical 36
status 15, 19
status, toggling 16
status, toggling display 20
view control 15, 19

Paths
scope, showing 33

Ports
connections, hiding expanded 30
drivers, showing in Connection view 30
exploring connections from 24

R
Receivers

showing in Connection view 30
Reports

cause 51, 53

S
Scope path

showing 33
Selection

adding, from pop-up menu 33
collapsing, from tool bar 27, 35
expanding, from tool bar 27, 35
finding, from pop-up menu 26, 33
finding, from tool bar 28, 35
global, tool 39

Setup violations
visualizing 50

Show Windows & Monitors tool 18
Simulations

cause reports, visualizing 51, 53
SmartCircuit models

in VSB 11
Sparse hierarchy view

creating 17
State form 37
States

initial, editing 54
monitors 45
windows 45

Status pane 15, 19
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toggling 16
toggling display 20

Strings
matching 41

Substitutions
illegal characters, disabling 49

T
Tags

net 42
removing from nets 43

Timing
instance, editing 54
instance, viewing 54

Timing form 36
Tips

circuit object, toggling 16
tool, toggling 16

Tool bars
connection view 34
hierarchy view 27

Tool tips
toggling 16

Tools 23
buttons 18
Close View 68
Create Sparse Hierarchy View 68
Global Selection 18, 39
Hide Selected Circuit Object, in tutorial

65
Hide Unconnected Circuit Objects, in

tutorial 65
Net Tags 18, 42
Show Global Selection 68
Show Net Tags 72
Show Windows & Monitors 18, 75
vsb 15
Windows & Monitors 44
Windows & Monitors view 14

Tools menu 56

V
Values

initial state, editing 54
initial state, viewing 54
instance timing, editing 54
instance timing, viewing 54

View control pane 15, 19
View menu 56
Views 23

bringing to foreground 17
buttons 18
Connection 14, 18, 21, 29
Connection, pop-up menu 32
Connection, tool bar 34
controls, from pop-up menu 26, 38
divider, in tutorial 61
Examine 14, 18, 36
Examine, pop-up menu 38
Hierarchy 14, 18, 20, 23
Hierarchy, pop-up menu 25
Hierarchy, tool bar 27
iconifying 17
multiple 13
raising 17
sparse hierarchy, creating 17, 31, 33, 35
Windows & Monitors 14

Violations
hold, visualizing 50
setup, visualizing 50

vsb command 15

W
Windows

bus 45
main 15
net 45
shell, from pop-up menu 26, 32, 38
state 45

Windows & Monitors
tool 44
view 14

Windows menu 56

Z
Zoom
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levels, from pop-up menu 26, 32
Zoom level 20

setting 22
Zooms

detail, in connection view 21
detail, in hierarchy view 20, 26, 27, 34
high, in connection view 21
high, in hierarchy view 20, 26, 27, 34
low, in connection view 21
low, in hierarchy view 20, 26, 27, 34
medium, in connection view 21
medium, in hierarchy view 20, 26, 27, 34
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