
Hydra Nemesis 2.6 User’s Manual

Revision 2.6.2

Copyright © 2008, All Rights Reserved



Hydra Nemesis 2.6 User’s Manual

Table of Contents

Table of Contents.....................................................................................................................2

Disclaimers.............................................................................................................................12

Introduction............................................................................................................................13

Parts List.................................................................................................................................14

Hardware Installation.............................................................................................................15

Software Installation..............................................................................................................18

Getting Started........................................................................................................................26

Base Map................................................................................................................................39

Sensor Calibration..................................................................................................................43

Engine Start............................................................................................................................48

The Editing Screen.................................................................................................................52
Menu Bar............................................................................................................................52
Work Area..........................................................................................................................53
Maps and Setting Modules................................................................................................55
Status..................................................................................................................................57
Display...............................................................................................................................57
Map.....................................................................................................................................59
Map Data............................................................................................................................61
Edit Colors.........................................................................................................................62

3D Map Editing......................................................................................................................64
Track Point and Cursor......................................................................................................64
Navigation..........................................................................................................................64
Centering............................................................................................................................64
Editing................................................................................................................................64
Direct Entry........................................................................................................................65
Arithmetic Functions.........................................................................................................65
Seek....................................................................................................................................67
Multiple Selection..............................................................................................................67
Select All............................................................................................................................67
Copy...................................................................................................................................68
Interpolation.......................................................................................................................69
Clear Traces.......................................................................................................................70
Help....................................................................................................................................72

2D Map Editing......................................................................................................................74
Track Point and Cursor......................................................................................................74

2



Hydra Nemesis 2.6 User’s Manual

Navigation..........................................................................................................................74
Centering............................................................................................................................74
Editing................................................................................................................................74
Direct Entry........................................................................................................................75
Arithmetic Functions.........................................................................................................75
Seek....................................................................................................................................77
Multiple Selection..............................................................................................................77
Select All............................................................................................................................77
Reset Traces.......................................................................................................................77
Help....................................................................................................................................78

Settings Panel Editing............................................................................................................79
Panel Selection...................................................................................................................79
Parameter editing...............................................................................................................80
Display...............................................................................................................................81
Help....................................................................................................................................82

File Menu...............................................................................................................................83
Open From File..................................................................................................................83
Open from ECU.................................................................................................................84
Complete Verify From ECU..............................................................................................85
Fast Verify From ECU.......................................................................................................86
Save To File.......................................................................................................................87
Save to ECU.......................................................................................................................88
Exit.....................................................................................................................................90

3D Fuel Calibration................................................................................................................91
Base Fuel Table..................................................................................................................91
Anti-lag Fuel Trim.............................................................................................................91
Anti-lag Active Fuel Cut Cycles........................................................................................92
Auxiliary Fuel Trim...........................................................................................................93
VE.......................................................................................................................................93
Launch Fuel Cut Cycles.....................................................................................................95
Flat-shift Fuel Cut Cycles..................................................................................................96
Anti-lag Inactive Fuel Cut Cycles.....................................................................................97

3D Ignition Calibration..........................................................................................................98
Base Timing Table.............................................................................................................98
Anti-lag Ignition Trim........................................................................................................98
Anti-lag Ignition Cut Cycles..............................................................................................99
Auxiliary Ignition Trim......................................................................................................99
Backup Table...................................................................................................................100
Launch Ignition Cut Cycles.............................................................................................101
Flat-shift Ignition Cut Cycles..........................................................................................101

3



Hydra Nemesis 2.6 User’s Manual

3D Engine Calibration..........................................................................................................103
TPS:MAP Weight............................................................................................................103
Intake VCT Target...........................................................................................................104
Exhaust VCT Target........................................................................................................104
AFR/LABMDA Target....................................................................................................105
Programmed MAP...........................................................................................................106
Auxiliary AFR/LAMBDA Target...................................................................................107

2D Fuel Trims......................................................................................................................109
Coolant Temperature Fuel Trim......................................................................................109
Air Temperature Fuel Trim..............................................................................................109
Throttle Pump Enrichment...............................................................................................110
Tip In Enrichment............................................................................................................111
ISC Position Trim............................................................................................................111
Knocking Enrichment......................................................................................................112
Air Conditioner Enrichment Set......................................................................................112
Air Conditioner Enrichment Decay.................................................................................113

2D Ignition Trims.................................................................................................................114
Coolant Temperature Ignition Trim................................................................................114
Air Temperature Ignition Trim........................................................................................114
Ignition Upper Limit........................................................................................................115
Ignition Lower Limit........................................................................................................116
Air Conditioner On Ignition Trim Set.............................................................................116
Short Term Trim Ignition Trim.......................................................................................117

2D Engine Calibration..........................................................................................................118
Injector Response.............................................................................................................118
Injector Phasing................................................................................................................119
Knock Threshold..............................................................................................................119
Fuel Cut Lower Limit......................................................................................................120
Dwell................................................................................................................................121
Dwell Trim.......................................................................................................................121
Rapid Setup Trim.............................................................................................................122
Throttle Derivative Trim..................................................................................................123

2D Boost Control.................................................................................................................124
Boost Target.....................................................................................................................124
Boost Coolant Temperature Trim....................................................................................124
Boost Air Temperature Trim...........................................................................................125
Boost Throttle Trim.........................................................................................................126
Boost Upper Learn Limit.................................................................................................126
Maximum Boost...............................................................................................................127

4



Hydra Nemesis 2.6 User’s Manual

2D Idle Speed Control..........................................................................................................128
Idle Speed Target.............................................................................................................128
Upper Learn Limit...........................................................................................................128
Lower Learn Limit...........................................................................................................129
Air Conditioner On Upper Learn Limit...........................................................................130
Air Conditioner On Lower Learn Limit..........................................................................131
ISC Ignition Trim.............................................................................................................131
Air Conditioner On Trim.................................................................................................132
Power Steering Load Lower Learn Limit........................................................................132

2D Starting...........................................................................................................................134
Post Start Enrichment......................................................................................................134
Cranking Enrichment.......................................................................................................135
Post Start Enrichment Decay...........................................................................................135
Cranking Enrichment Decay............................................................................................136
Start Primer......................................................................................................................136

2D Closed Loop...................................................................................................................138
Closed Loop Upper Throttle Position Limit....................................................................138
Closed Loop Lower Throttle Position Limit...................................................................138
Narrow Closed Loop Proportional Gain..........................................................................139
Narrow Closed Loop Integral Gain.................................................................................139
Wideband Closed Loop Proportional Gain.....................................................................140
Wideband Closed Loop Integral Gain.............................................................................140
Start Delay........................................................................................................................141

2D Gear................................................................................................................................142
Vehicle Speed To Engine Speed Ratio Target................................................................142
Gear Ignition Trim...........................................................................................................143
Gear Fuel Trim.................................................................................................................144
Gear Trim Lower Load Limit..........................................................................................144
Traction Maximum Delta.................................................................................................145
Traction Ignition Cut Cycles...........................................................................................146
Traction Fuel Cut Cycles.................................................................................................146
Gear Boost Trim...............................................................................................................147

2D PWM...............................................................................................................................148

Comments.............................................................................................................................151

Passwords.............................................................................................................................153

3D PWM...............................................................................................................................155

Ignition Triggers...................................................................................................................156
Trigger Active Edge.........................................................................................................157
Trigger Type....................................................................................................................157

5



Hydra Nemesis 2.6 User’s Manual

Sync Type.........................................................................................................................158
Cylinders..........................................................................................................................158
Sequencer.........................................................................................................................158
Timing Reference Angle..................................................................................................159
VCTi Offset......................................................................................................................159
VCTe Offset.....................................................................................................................160
VCTi P-term.....................................................................................................................160
VCTi I-term......................................................................................................................160
VCTe P-term....................................................................................................................160
VCTe I-term.....................................................................................................................160

Sensor Type and Calibration................................................................................................162
External AFR Zero Calibration.......................................................................................163
External AFR Gradient Calibration.................................................................................163
External MAP Sensor Enable..........................................................................................164
UEGO Zero Calibration...................................................................................................164
UEGO Gradient Calibration............................................................................................164
CTS Type.........................................................................................................................164
ATS Type.........................................................................................................................165
Trigger Pull-Up Enable....................................................................................................165
Sync Pull-Up Enable........................................................................................................165

Idle Speed Control................................................................................................................166
Anti-lag ISC Position.......................................................................................................167
Moving Vehicle ISC Minimum.......................................................................................167
ISC Maximum Duty.........................................................................................................167
ISC Minimum Duty.........................................................................................................167
ISC Maximum Vacuum...................................................................................................168
ISC Stepper Steps............................................................................................................168
ISC P-term........................................................................................................................168
ISC I-term.........................................................................................................................168
ISC D-term.......................................................................................................................168
ISC AC Anticipate...........................................................................................................169

Ignition and RPM Limits.....................................................................................................170
Knock 1 Amplifier Enable...............................................................................................171
Knock 2 Amplifier Enable...............................................................................................171
Soft Rev Limit..................................................................................................................171
Maximum Knock Retard.................................................................................................171
Moving Launch Enable....................................................................................................172
Knock Retard Degrees Per...............................................................................................172
Waste Spark Enable.........................................................................................................172
Hard RPM Limit..............................................................................................................172

6



Hydra Nemesis 2.6 User’s Manual

Excessive Knock Events..................................................................................................172
Excessive Knock Threshold............................................................................................173
Backup Spark Lean Error Enable....................................................................................173
Direct Fire Enable............................................................................................................173
VCT Setup........................................................................................................................173
VCT Multiplexer Enable.................................................................................................174

Closed Loop Control............................................................................................................175
Closed Loop Enable.........................................................................................................176
Closed Loop Start Temperature.......................................................................................176
Left Module Sensor Source.............................................................................................176
Right Module Sensor Source...........................................................................................177
Long Term Trim Enable..................................................................................................177
Cylinder Bank..................................................................................................................177

PID Controls.........................................................................................................................179
Auxiliary Map Boost Trim..............................................................................................180
Input Follower P-term......................................................................................................180
Input Follower I-term.......................................................................................................180
Boost Control D-term......................................................................................................181
Boost Control P-term.......................................................................................................181
Boost Control I-term........................................................................................................181

Throttle Setup.......................................................................................................................182
Anti-lag Timeout..............................................................................................................183
Anti-lag Zero TPS Calibration.........................................................................................183
Zero TPS Calibration.......................................................................................................184
Closed Pedal Calibration.................................................................................................184
100% TPS Calibration.....................................................................................................184
TPS Pump Threshold.......................................................................................................184

Injection................................................................................................................................186
Dynamic Enleanment Coefficient...................................................................................187
Deceleration Cut Enable..................................................................................................187
MAP Pump Threshold.....................................................................................................188
Manifold Wetting Coefficient..........................................................................................188
Dynamic Enrichment Coefficient....................................................................................188
Injector Trims...................................................................................................................188
Staged Ratio.....................................................................................................................189
Maximum Main Duty......................................................................................................189
Crank Cut Fuel TPS Limit...............................................................................................189
Minimum Pulse................................................................................................................189

Setup Options.......................................................................................................................190

7



Hydra Nemesis 2.6 User’s Manual

Rapid Setup Trim Enable.................................................................................................191
Alpha-n Mixed Mode Enable..........................................................................................191
Sequential Injection Enable.............................................................................................191
Volumetric Efficiency Mode Enable...............................................................................192
Injector Flow....................................................................................................................192
Pump Primer Time...........................................................................................................192
Boost Control Threshold RPM........................................................................................192
Stepper ISC Valve Enable...............................................................................................192
Cycle Cut Recovery Time................................................................................................192

VSS & Gear Ratios..............................................................................................................194
VSS Input Calibration......................................................................................................195

Grid RPM Spread.................................................................................................................196
RPM Spread.....................................................................................................................197

Grid Load Spread.................................................................................................................198

I/O Options...........................................................................................................................200
PWM Frequency..............................................................................................................201

Output Configuration...........................................................................................................202
Output function................................................................................................................203
Injection............................................................................................................................204
On.....................................................................................................................................204
Turbo Timer.....................................................................................................................204
Thermo Fan......................................................................................................................204
Linear VCT......................................................................................................................204
Anti-Lag Valve................................................................................................................204
Staged Injection................................................................................................................204
A/C Clutch.......................................................................................................................205
User..................................................................................................................................205
Pulse Width Modulation..................................................................................................205
Off....................................................................................................................................205
ISCO.................................................................................................................................205
ISCC.................................................................................................................................205
Fuel Pump........................................................................................................................205
Check Engine...................................................................................................................206
Pin Assignments...............................................................................................................206

User Logic (single, AND)....................................................................................................207
User Type.........................................................................................................................208
User Variable...................................................................................................................209
Single User Logic Conditions..........................................................................................209
Dual AND User Logic Conditions..................................................................................210

8



Hydra Nemesis 2.6 User’s Manual

PWM Axes...........................................................................................................................211
2D PWM Map Variable...................................................................................................212
3D PWM Map Variable...................................................................................................214

Air Conditioner and Fans.....................................................................................................215
A/C RPM Limit................................................................................................................216
A/C Throttle Position Sensor Limit.................................................................................216
Thermofan On Temperature............................................................................................216
A/C Return Delay............................................................................................................216

User Logic (2xOR, 4xAND)................................................................................................217
User Type.........................................................................................................................218
User Variable...................................................................................................................219
Dual OR User Logic Conditions.....................................................................................219
Quad AND User Logic Conditions.................................................................................220

User Logic (4xANDOR)......................................................................................................221
User Type.........................................................................................................................222
User Variable...................................................................................................................223
Triple AND Single OR User Logic Conditions..............................................................223
Double AND Double OR User Logic Conditions...........................................................224

Auxiliary Input Configuration.............................................................................................226
Input Configuration..........................................................................................................227
AC High...........................................................................................................................227
AC Low............................................................................................................................228
Launch High.....................................................................................................................228
Launch Low.....................................................................................................................228
Anti-Lag High..................................................................................................................228
Anti-Lag Low...................................................................................................................228
Auxiliary High.................................................................................................................228
Auxiliary Low..................................................................................................................228
Input Follower..................................................................................................................229
Input Follower Feedback.................................................................................................229
Barometric GM 1 BAR....................................................................................................229
Barometric Honda............................................................................................................229
MAP GM 2 BAR.............................................................................................................229
MAP 5 BAR.....................................................................................................................229
Valet High........................................................................................................................229
Valet Low.........................................................................................................................230
Backup Ignition High.......................................................................................................230
Linear AFR.......................................................................................................................230
Steer Load High...............................................................................................................230
Steer Load Low................................................................................................................230

9



Hydra Nemesis 2.6 User’s Manual

Flat Shift High..................................................................................................................230
Flat Shift Low..................................................................................................................230
Traction High...................................................................................................................230
Traction Low....................................................................................................................231
FH.....................................................................................................................................231
FL.....................................................................................................................................231
Off....................................................................................................................................231
Pin Assignments...............................................................................................................231

Ignition Cylinder Trims.......................................................................................................232
Ignition Fire Trim............................................................................................................233

Settings Tools.......................................................................................................................234
TPS/PPS Calibrate...........................................................................................................234
Load Spread Tool.............................................................................................................235
RPM Spread Tool............................................................................................................237

Edit.......................................................................................................................................239
Select All..........................................................................................................................239

Comms..................................................................................................................................241
Connect............................................................................................................................241
Disconnect........................................................................................................................241

Preferences...........................................................................................................................242
Measurement Units..........................................................................................................242
Grid Centering..................................................................................................................242
Select Cell Mode..............................................................................................................243
Panel Mode.......................................................................................................................243
Auto Connect on Main Window......................................................................................243
Default COM Port............................................................................................................243
Hide Non-Critical Messages............................................................................................243
Rapid Logging..................................................................................................................243
Default View....................................................................................................................243
Fuel Type.........................................................................................................................243
Grid Load Direction.........................................................................................................244
VE Substring....................................................................................................................244
Substrings.........................................................................................................................244
COM Frequency...............................................................................................................244
Auto Sync.........................................................................................................................244
Auto Sync Method...........................................................................................................245
Saving Preferences...........................................................................................................245

Communications Statistics...................................................................................................246

Firmware Signature..............................................................................................................248

10



Hydra Nemesis 2.6 User’s Manual

Colors...................................................................................................................................249

Clear Traces..........................................................................................................................251
Clear Visit Traces............................................................................................................251
Clear Edit Traces..............................................................................................................251
Clear AFR Traces............................................................................................................252
Clear Knock Traces..........................................................................................................252

Log Data...............................................................................................................................254
Profiles.............................................................................................................................254
Data Collection................................................................................................................259
Data Export......................................................................................................................260
Raw Logs.........................................................................................................................261

Learn Data............................................................................................................................265
VE.....................................................................................................................................265
Programmed MAP...........................................................................................................266

Open From UNIX Emailed File...........................................................................................267

Import Map Fragment..........................................................................................................269

Import Default Injector Response Map...............................................................................274

Analyze Map........................................................................................................................276

Ram Dump...........................................................................................................................277

Migration Tools....................................................................................................................278
VE to Fuel Base Table.....................................................................................................278
Fuel Base Table to VE.....................................................................................................279

Activate Feature...................................................................................................................280

Arrange.................................................................................................................................282

Inputs....................................................................................................................................283

Fuel Multipliers....................................................................................................................285

Long Term Trim Table........................................................................................................287

Help......................................................................................................................................289
This Map..........................................................................................................................289
Tuning this map...............................................................................................................289
Hotkeys............................................................................................................................290
Diagrams..........................................................................................................................291
About................................................................................................................................291

11



Hydra Nemesis 2.6 User’s Manual

Disclaimers

The Hydra Nemesis 2.6 is an electronic fuel injection computer designed to control most 
modern four-cycle, internal combustion motors. The system is sold for off-road use only 
and is not legal for use on emissions controlled vehicles.

The Hydra Nemesis 2.6 software, hardware, firmware, templates, help files, diagrams and 
documentation is subject to change without notice. Although every effort is made to keep 
this document accurate, the manufacturer and its agents accept no responsibility for issues 
resulting from omissions or inaccuracies in this document.

The Hydra Nemesis 2.6 provides a high level of control over the operation of an internal 
combustion engine. The information in this document is intended as a reference for those 
familiar with the installation and calibration of electronic fuel injection systems. This 
document is not a replacement for a competent professional. Attempted calibration by an 
unqualified or inexperienced individual could result in severe damage to the engine or 
vehicle that the system is used to control. The manufacturer and its agents accept no 
responsibility for damage resulting from improper installation or calibration of the system.

Electronic fuel injection systems use high pressure fuel pumps and high energy ignition 
system. Should installation be attempted, be aware that these systems can cause serious and 
even fatal injuries if they are improperly serviced or modified. The manufacturer and its 
agents accept no responsibility for damage resulting from any modification or adjustments 
to any vehicle’s fuel or ignition system.

The Hydra Nemesis 2.6 system is covered by a one-year warranty period. This warranty 
period starts on the day the system is installed or thirty days after the purchase of this 
system, whichever comes first. The warranty covers only defects in materials or 
workmanship and applies only if the unit is properly installed by a qualified mechanic or 
engine management specialists in accordance with the manufacturer’s instructions. The 
warranty is void if the system or wiring harness is opened, modified or tampered with in 
any fashion or if installation is attempted on a vehicle which does not exactly match the 
application the system is intended to operate.

The warranty does not cover personal injury, property damage, towing, loss of use, lost 
income, labor and diagnostic charges, consequential damage, damage from backfires or 
misfires, damage from detonation, lean misses, cylinder washing, hydro-lock, engine 
overheating, physical shock, electrical shock, floods, earthquakes, act of god, misuse, water 
damage, improper handling, or any operation outside the specifications of the product.
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Introduction

Congratulations on your purchase of the Hydra Nemesis 2.6 engine management system. 
The purpose of this manual is to get you acquainted with the features and capabilities of 
your new system. You are strongly encouraged to read through this manual before you 
attempt to install and calibrate your Hydra Nemesis 2.6 unit. Although the base maps 
provided with your unit will most likely start and let you drive your vehicle, it is highly 
recommended that you hire a qualified engine management specialist to calibrate your new 
unit for your specific setup. A list of factory-trained Nemesis tuners and dealers is available 
online at http://www.hydraems.com under the Dealers link. Chances are that a qualified 
professional is available to assist you in your area.

If you found this manual in the software CD that came with your Hydra Nemesis 2.6 
system, then you are probably well versed in how to install and run application on your 
Windows© system. If not, then be aware that you will need a Windows© laptop to directly 
communicate and calibrate your Hydra Nemesis 2.6 system. If your intent is to let your 
local engine management expert install and calibrate the system for you and you have no 
interest in accessing any of the features of the Hydra Nemesis 2.6 system yourself, then 
you can stop reading now and turn everything over to your local specialist.

Properly calibrating an engine management system such as the Hydra Nemesis 2.6 system 
to control a high power engine safely under all possible conditions is a job that requires 
very specific training and experience. Unfortunately, this manual cannot provide all of the 
information required to turn an enthusiastic individual into a capable tuner. If you desire to 
take on the job of calibrating the Hydra Nemesis 2.6 system yourself, we encourage you to 
take advantage of the various books and courses available to familiarize you with the 
tuning process before you proceed.

Even if you are going to turn the task of properly and safely tuning the vehicle over to your 
local expert, the Hydra Nemesis 2.6 system can then be used to gain a much deeper 
understanding of how the engine operates under different conditions. For the weekend 
racer, the data logging capabilities of the Hydra Nemesis 2.6 can provide a treasure trove of 
information for additionally improving the operation of the motor under race conditions. 
Also, there may be other features that you may wish to experiment with and take advantage 
of on your own. If you fall in this category, this manual is targeted primarily to you.

Hydra EMS provides an online forum that can be used to gain additional information and 
insight on very specific Hydra-related features and issues. The forum can be accessed at 
http://www.hydraems.com/forums/ by simply following the instructions on setting up a 
user account. Please us the Search feature of the forum to determine if someone has 
already asked and received an answer to your question before starting a new thread.
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Parts List

Before installing your Hydra Nemesis 2.6 system, insure that you have all the required 
components. You should have:

• Hydra Nemesis 2.6 Unit
• Vehicle-specific Adapter Harness
• USB-to-serial Adapter
• Serial Cable
• L1H1 or L2H2 Wideband O2 Sensor (optional)
• Wideband Cable (optional)
• Software CD

Some applications may include additional brackets, sensors, cables, vacuum lines, tees, 
relays, grommets and adapters. Contact your Hydra EMS dealer if you are missing any of 
these items.
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Hardware Installation

This document does not cover the specifics of installing your Hydra Nemesis 2.6 system on 
your particular vehicle. If you have not received a separate set of specific installation 
instructions either directly from your Hydra EMS dealer, please make an effort at this time 
to take a quick tour of their website to see if specific installation instructions are posted or 
contact your Hydra EMS dealer to obtain specifics for your particular vehicle.

Generally, the first step in installing the Hydra Nemesis 2.6 unit is going to be gaining 
access to the vehicle’s factory engine control unit (ECU). This is where vehicle-specific 
instructions are going to come in particularly handy. Some cars hide this unit under the 
dash, other have it hidden away behind a panel in the engine compartment and still others 
squirrel it out of sight in a nook inside the trunk or under some panel. Late-model vehicles 
have so many different electronic boxes that it is essential that you either obtain the 
vehicle-specific installation directions or have access to the vehicle’s service manual to 
gain access to the right component.

Once the factory ECU is located, resist the temptation to unplug it from the vehicle until 
you first disconnect the battery to prevent any possibility of damaging the sensitive 
electronics in the car or in the Hydra Nemesis 2.6 unit by unplugging wires in a live 
system. This means that you need to be aware of any issues that may arise if the battery is 
disconnected. Some stereo and alarm systems require that specific codes or procedures be 
followed to re-activate them after battery power has been removed. Check the user’s 
manual for these devices so that you are familiar with what you will need to do to get them 
working again after the installation is complete and power is restored.

The next step is to locate the battery and disconnect the negative cable from the negative 
post of the battery. In most cases you will need a socket wrench or open ended wrench of 
the appropriate size to loosen the battery cable enough to allow you to pull it off the battery 
terminal. Once you remove the cable, tape it up with electrical tape or position it in such a 
way that there will be no chance of the cable contacting the battery terminal and re-
establishing power until you are ready to have that happen. Verify that electrical power is 
gone by switching on the headlights and determining that the lights do not come on.

Once electrical power is removed, it is safe to pull the plugs from the factory ECU 
connectors. Before you do so, take a close look at the vehicle-specific harness that came 
with your Hydra Nemesis 2.6 unit. Three of the plugs on the harness fit into the three 
connectors on the side of the unit. Now, pull the plugs from the factory ECU connectors 
and match them up against the connectors on the vehicle-specific harness and plug them in. 
If there is another set of plugs left over, then you have a jumper harness instead of a 
straight harness. A jumper harness is used on vehicles where the factory ECU must remain 
in place to perform some functions that the Hydra Nemesis 2.6 unit will not take over. If 
you have a jumper harness, go ahead and plug the remaining harness plugs into the factory 
ECU. Factory ECU connectors and plugs are designed so that it is nearly impossible to 
insert the wrong plug into the wrong connector.
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Once the harness is installed, you need to find a location for the Hydra Nemesis 2.6 unit. 
On straight harnesses, the factory ECU is often removed to make space for the unit. When 
a jumper harness is used, another location is used. If your vehicle-specific setup came with 
a bracket, Velcro® tape or a similar device to secure the unit, use it.

Before fully securing the Hydra Nemesis 2.6 unit, attach the serial cable to the serial port 
on the side of the unit and tighten the screws on the side of the serial connector to prevent 
the serial cable from slipping off. Take a close look at the area where the unit will be 
located and determine a suitable location to route the serial cable so that it will be 
accessible to pull out and attach to a laptop when the unit is ready for calibration. Often, 
the serial cable can be easily routed to the glove box or to a handy panel on the dashboard.

If a vacuum line was supplied with the Hydra Nemesis 2.6 unit, then one end of the 
vacuum line will need to be attached to the brass vacuum port on the same side of the unit 
that the serial cable is attached to. You will now need to find a way to route the other end 
of the vacuum line into the engine bay so that it can be attached to an intake manifold 
reference port. It is almost always the case that if the vacuum line has to cross a firewall 
that there will be a suitable grommet already covering a hole in the firewall that can be 
carefully modified to allow the vacuum line to route through the firewall. It is rare that a 
drill will be needed to make a new hole and if this appears to be the case then be very 
careful to not drill into an important wire harness or A/C Freon line. If a new hole is made, 
be sure to use a rubber grommet to protect the vacuum line from chaffing over time against 
the sharp metal edges of the hole.

If an optional wideband O2 cable and L1H1 or L2H2 sensor was purchased with the Hydra 
Nemesis 2.6 system, then it will be necessary to route the wideband cable to a suitable 
location in the exhaust system and then attach the connector of the wideband cable to the 
vehicle-specific harness. If there is not already an obvious connector on the vehicle-
specific harness for the wideband, refer to the vehicle-specific instructions for the 
wideband option for installation specifics. If the wideband cable has no connector to the 
vehicle-specific harness but instead has five small aluminum pins, then it will be necessary 
to attach these pins to the vehicle-specific harness plugs that connect to the Hydra Nemesis 
2.6 unit. These pins must be inserted into the plugs as follows:

Hydra Nemesis 2.6 Pin L1H1 Sensor L2H2 Sensor
Small Gray Plug B2 White Wire White wire
Small Gray Plug B1 Red Wire Gray Wire
Small Gray Plug B9 Yellow Wire Yellow Wire

Small Gray Plug A11 Black Wire Black Wire
Large Blue Plug D7 Orange Wire Blue Wire

The wideband cable colors may not match the colors on the wideband sensor. To determine 
which pin goes into which location, first determine from the colors of the five wires on 
your sensor which of the two sensors you have. Then, plug the sensor into the wideband 
cable and write down which sensor color translates into which color wire on the wideband 
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cable. Now, you should know which hole each of the five pins on the wideband cable goes 
to.

To insert the pins into the Hydra Nemesis 2.6 plugs, first pull the small gray plug out of the 
Hydra Nemesis 2.6 connector. With a small, flat-bladed screwdriver, carefully pry the blue 
plastic retaining clips off the back of the gray plug. At the corners of the plug, the pins will 
be labeled. On the small gray plug, looking from the side of the plug the wires enter into it, 
the top row will have an A12 label at the top left corner and an A1 label at the top right 
corner. Below these will be the bottom row with B12 labeled on the bottom left corner and 
B1 on the bottom right corner. The B1 hole is the hole nearest to the B1 label. The B2 hole 
is the hole immediately to the left of the B1 hole. The A11 hole is immediately to the right 
of the A12 hole which is just to the right of the A12 label. Once you have inserted the four 
pins in the appropriate holes on the small gray plug, carefully insert the blue plastic 
retaining clips back into the plug and push the plug back into the Hydra Nemesis 2.6 unit. 
Now repeat the process with the large blue plug and locate the D7 hole which will be seven 
holes to the right of the D1 label on the lower right corner of the plug.

Now that everything is properly attached to the Hydra Nemesis 2.6 vehicle-specific harness 
and unit, secure the unit using either the bracket(s) or other materials supplied. Be very 
careful to insure that the vacuum line, if used, is not kinked either near the brass port or 
anywhere along the route that it takes into the engine bay. Once the unit is secure and has 
no way of moving around as the vehicle is driven, direct your attention to the engine bay.

If a vacuum line was provided with the unit, it is essential to locate a direct port to the 
engine’s intake manifold and attach the vacuum line so that it receives the same vacuum or 
boost pressure that is in the intake manifold at all times. On most vehicles, there will be at 
least one or two vacuum ports with vacuum lines somewhere on the side or the bottom of 
the intake manifold. If such a port is located, use the vacuum tee supplied and tee the 
vacuum line from the Hydra Nemesis 2.6 unit into the existing line. On vehicles with 
turbochargers or superchargers, use the zip ties or clamps supplied to insure that the 
vacuum line and the tee will not blow off under boost.

Double check all your work. If everything appears to be properly attached, re-connect the 
ground cable to the negative terminal of the battery. You are now ready to set up the Hydra 
Nemesis 2.6 system using your laptop and start the car.
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Software Installation

The Nemesis Windows© laptop software is located in the software CD shipped with each 
Hydra Nemesis 2.6 unit. The software is also available for download on the Hydra EMS 
website.

If you have the software CD, insert the CD in your CD-ROM drive. Give the laptop a few 
seconds to read and recognize the CD. In some cases, a new window will open displaying 
the contents of the CD. If not, click on the Windows© Start box and then click on My 
Computer.

This will bring up an Windows© Explorer panel. Locate the DVD/CD-RW or CD-ROM 
drive icon in this panel and double-click it.
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The panel will now display the contents of the software CD. Locate the file named Setup 
or Setup.exe and double-click it.

If you do not have the software CD that came with your Hydra Nemesis 2.6 system, you 
can download it from the Hydra EMS website. To download the software, navigate your 
browser to http://www.hydraems.com and click on the Software link. Scroll down and 
locate the latest version of the 2.6 laptop software. Click on the link and your browser will 
prompt you to save the installation software:
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Click on the Save button to start the download process:

The browser will ask you to select a location for the installer. The default location is 
generally the Windows© Desktop and it is recommended that you save the installer. If the 
file name is something other than Setup.exe, change it to Setup.exe at this time. When you 
have selected the desired location and named the file properly, click the Save button to start 
the download process:

20



Hydra Nemesis 2.6 Users Manual

The download process can take up to several minutes depending on the speed of your 
internet connection. When the download completes, click the Open Folder button to open 
the folder with the downloaded file:

On most Windows© systems downloaded files are blocked and must be unblocked before 
they can be used. Locate the downloaded item named Setup or Setup.exe in the folder, 
right-click it and select Properties from the dropdown menu. If the file is blocked, then the 
properties screen will contain an Unblock button which you should click:

Then, click the Ok button to return to the folder. Now double-click the Setup or Setup.exe 
file:
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Either from the software CD or from the download, double-clicking the Setup or 
Setup.exe file will launch the Hydra Nemesis 2.6 laptop software installation program:

The first screen will indicate the exact version and revision numbers of the Hydra Nemesis 
2.6 laptop software that it will install on your computer. It is perfectly acceptable to install 
more than one version and revision of the laptop software on the same computer. You do 
not have to remove previous versions or revisions of the software that were already 
installed on your system. If you do not want the installation to continue, click the Cancel 
button. Otherwise, click the Next > button:
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The second screen allows you to change the folder into which the laptop software will be 
installed. It is recommended that the software be installed in the folder suggested by the 
installation program. If you need to change the folder, click the Browse… button. If you 
wish to return to the initial screen, click the < Back button. If you do not want the 
installation of the laptop software to continue, click the Cancel button. Otherwise, click the 
Next > button: 

The third screen allows you to choose the folder that the laptop software’s access shortcuts 
will be added to in the main Windows© start screen. The default folder is named to include 
the version and revision number of the software. Doing this will create a different top level 
folder under the main Windows© start screen for each version and revision of the software 
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you install. If you wish the shortcuts to all the versions and revisions of the laptop software 
to be grouped under a single folder, it is suggested that you click the Browse… button at 
this time to select or create an appropriate collective folder for all the versions of the laptop 
software you install. If you wish to return to the second screen, click the < Back button. If 
you do not want the installation of the laptop software to continue, click the Cancel button. 
Otherwise, click the Next > button:

The fourth screen shows the installation and start menu folder locations chosen in the 
previous two screens. If any changes are required, click the < Back button to return to the 
third screen. If you do not want the installation of the laptop software to continue, click the 
Cancel button. Otherwise, click the Install button:

The installation program will take a few moments to install the laptop software on the 
computer. A bar indicating the state of the progress and specific information about which 
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file is currently being extracted from the installation package will be shown. You can click 
the Cancel button at any time during this installation process to abort the installation and 
restore the computer to its original state prior to the start of the installation process. When 
the installation process is complete, the final installation screen will appear:

The laptop software installation process is now complete. Click the Finish button to close 
the final screen. You are now ready to proceed to using the Hydra Nemesis 2.6 laptop 
software to interface with your Hydra Nemesis 2.6 engine management system.
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Getting Started

To start the Hydra Nemesis 2.6 laptop software, go to the Windows© Start menu and 
select the installed software:

Note that the revision number may be different as new updated and revised versions of the 
laptop software are frequently released. To facilitate starting the laptop software if you are 
going to be using it often, create a shortcut for it on the Windows© desktop by right-
clicking the start menu item and selecting Send To->Desktop (create shortcut):

This will create an icon for the laptop software on the Windows© detop that you can 
double-click at any time to start the software:

After selecting to start the laptop software from either the Windows© Start menu or from 
an icon on the desktop, you should be immediately greeted with the laptop software 
loading screen:
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The loading screen will last for several seconds, after which the main window of the Hydra 
Nemesis 2.6 laptop software will open:

The laptop software is configured by default to attempt to connect to the Hydra Nemesis 
2.6 engine management system. If a serial communications port is not properly configured 
or selected in the laptop software, you will see the following error message:
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Click OK to view or edit maps and settings offline. The laptop software will remember the 
contents of the last file saved to disk and will start with those maps and settings loaded 
when you start the laptop software. The first time you run the software after installation, a 
default template set of maps and settings intended to run no engine in particular will be 
loaded into the laptop software.

Now that you are familiar with starting the laptop software, it is time to prepare to connect 
to a Hydra Nemesis 2.6 unit. To do so, you must set up a serial interface. Exit the laptop 
software by selecting File->Exit:

If your laptop has a built-in serial interface, it is recommended that you use this interface to 
communicate with the Hydra Nemesis 2.6 engine management system. If not, use the USB 
to Serial interface adapter supplied with your Hydra Nemesis 2.6 system. This interface is 
easy to install. Look on the side or back of your laptop and locate a USB port. These are 
thin rectangular holes that the flat plug on the end of the USB to Serial interface plugs into. 
Insert the plug on the interface into the USB port on the. An informational balloon will 
open on the lower-right hand corner of your laptop:

Windows© will automatically start the Found New Hardware Wizard to allow you to 
install the required driver for your new USB-to-Serial interface:
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Click the Install from a list or specific location (Advanced) radio button:

Then click Next > to continue:

This will open a second panel allowing you to indicate where you want the Found New 
Hardware Wizard to search for the driver software required to properly access the USB-
to-Serial interface:
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Click the Search removable media (floppy, CD-ROM…) checkbox:

Insert the software CD that came with your Hydra Nemesis 2.6 system in the CD-ROM 
drive and click Next > to continue:

The following panel will open and Windows© may take up to several minutes to search the 
storage devices on the laptop for an appropriate driver:
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Windows© will find the required USB to serial driver on the software CD and will ask you 
to verify that you wish to continue with its installation:

Click the Continue Anyway button. Widows© will backup the current driver 
configuration and install the new drivers:
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After a minute or two, the installation will complete:

Click the Finish button to close the wizard and anthoner informational balloon will open in 
the lower-right hand corner of the laptop screen indicating that the new hardware is 
installed and ready to use:
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Now you must determine which communications port the serial device has been assigned 
to and configure the laptop software to use it. Open the Windows© Control Panel by 
selecting Control Panel from the Start menu:

Double-click the System icon on the Control Panel screen:

This will open the System Properties panel. Click on the Hardware tab at the top of the 
System Properties panel:

This displays the Hardware properties panel. Click on the Device Manager button in this 
panel:

33



Hydra Nemesis 2.6 User’s Manual

This will open the Device Manager panel. Locate the Ports (COM & LPT) item and click 
the box with the plus sign immediately to the left of it:

This will expand the Ports (COM & LPT) list and show the COM port assignments:

Look at the port number assigned to the USB-to-Serial interface. In this case, the interface 
is assigned to COM8. If the interface is not assigned to one of the first six ports, COM1 
through COM6, then it will be necessary to reassign the interface to one of these ports.

34



Hydra Nemesis 2.6 Users Manual

If the interface needs to be reassigned, double click the USB-to-Serial icon in the device 
manager list:

This will open the properties panel for the USB-to-Serial interface:

Click the Port Settings tab to switch to the port settings. Click the Advanced button:
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This will open the advanced settings panel for the USB-to-Serial interface:

Select from the dropdown to the right on the COM Port Number label any one of the 
available communications ports labeled COM1 through COM6:

36



Hydra Nemesis 2.6 Users Manual

Click OK to complete the port re-assignment:

Start the laptop software once again and select Tools->System Tools->Preferences:

In the preferences panel that opens, click the radio button corresponding to the COM 
number the communications port is assigned to:

Also, select the ENABLED radio button for the AUTO CONNECT ON MAIN 
WINDOW preference:

Click the Save and exit button to complete the preferences setting:

Exit once again from the laptop software by selecting File->Exit:
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Locate the serial cable connected to the Hydra Nemesis 2.6 unit and connect it to the 
internal laptop serial connector or the USB-to-Serial interface you have installed. Power 
the Hydra Nemesis 2.6 unit by turning the ignition key to the ON position without 
attempting to start the engine.

Start the laptop software again. If the laptop software is properly communicating with the 
Hydra Nemesis 2.6, you will not see a failed communications message after a few seconds:

Instead, you will likely see a message indicating that the maps and settings in the Hydra 
Nemesis 2.6 unit do not match the current maps and settings in the laptop software:

This is normal and expected. Click the OK button. You can now proceed to the next 
section which walks you through the process of installing a base map into your Hydra 
Nemesis 2.6 unit.

If you continue to see a failed communications message and the ignition key is in the ON 
position, go back and review all of the steps relating to the installation and configuration of 
the serial communications interface and the settings of the preferences in the laptop 
software. If the problem persists, contact your Hydra EMS dealer for assistance.

38



Hydra Nemesis 2.6 Users Manual

Base Map

Before making any attempt to start the engine for the first time after installing your Hydra 
Nemesis 2.6 system, you must ensure that the unit contains a base map with maps and 
settings appropriate to your specific engine and vehicle and configuration.

Your Hydra EMS dealer can choose from several different methods of providing you with 
an appropriate base map. These include

• loading a base map into the Hydra Nemesis 2.6 unit before shipment,
• placing the base map on the software CD provided with the unit,
• placing the base map on their web site for download or
• sending the base map to you upon request via email.

If you are unsure of which method your Hydra EMS dealer selected, contact them for 
further assistance.

If a base map was loaded into the Hydra Nemesis 2.6 unit before shipment by your Hydra 
EMS dealer, the first step you should take after establishing communications with your 
Hydra Nemesis 2.6 unit is to open the base map in the ECU so that the laptop software has 
a copy of the base map. Select File->Open from ECU:

The laptop software will retrieve the base map loaded into the Hydra Nemesis 2.6 system 
by the Hydra EMS dealer.

Save a copy of the base map before making any changes to the maps and settings so that 
you can always return the Hydra Nemesis 2.6 unit back to its original state. To do this, 
select File->Save to file:
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This will open a file dialog box. Enter a name for the base map that you will be able to 
easily identify it by and click the Save button:

If the base map is provided on the software CD, insert the CD in your CD-ROM drive. 
Give the laptop a few seconds to read and recognize the CD. Select File->Open from file:

40



Hydra Nemesis 2.6 Users Manual

This will open a file dialog box. Click the My Computer icon:

Double-click the CD-ROM icon:
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Select the name of the base map that most closely matches your engine and vehicle 
configuration and double-click it. This will bring the maps and settings associated with the 
base map into the laptop software. To transfer this base map to the Hydra Nemesis 2.6 unit, 
select File->Save to ECU:

A progress bar will appear indicating that the maps and settings are being sent to the Hydra 
Nemesis 2.6 unit:

Once this is complete, save a copy of the base map on your laptop hard disk:

If the base map is emailed to you or downloaded from the Hydra EMS dealer’s website, 
follow the same procedure described for getting the base map from the software CD except 
that in the file open dialog you will navigate to the location on your laptop where you 
saved the emailed or downloaded base map.
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Sensor Calibration

Before attempting to start the engine with the base map, it is essential that several sensors 
be calibrated. One is the throttle position sensor and, if your engine uses a drive-by-wire 
throttle controlled by the Hydra Nemesis 2.6, the pedal position sensor.

Select Map Group->Settings 1:

This will bring up the settings panel. Select Tools->TPS/PPS calibrate:

This will open the TPS/PPS calibration panel:
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With your foot off the accelerator pedal, click the Calibrate zero TPS and Calibrate zero 
PPS buttons. Then, push the accelerator pedal as far as you are able to and, while holding it 
in that position, click the Calibrate wide open TPS button.

If an optional wideband O2 cable and L1H1 or L2H2 sensor was purchased with the Hydra 
Nemesis 2.6 system, it will need to be calibrated to insure that it provides accurate AFR 
readings. Select Tools->System tools->Preferences:

This will open the preferences panel. Click the GAS radio button on the FUEL TYPE 
option:

Click the Save and Exit button:
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Unplug the O2 sensor from the wideband cable. Return to the Settings 1 panel by selecting 
Map Group->Settings 1 and click on the down arrow of the panel selection dropdown:

In the dropdown selection panel that opens, click on the sensor type and calibration item:

Locate the AFR/L display at the bottom of the settings panel:

With the O2 sensor disconnected from the cable, the AFR/L display should read 14.7. If it 
reads higher than 14.7, reduce the value of the UEGO zero calibration number and click 
the Enter button immediately to the right of it:

If it reads less than 14.7, increase the value of the UEGO zero calibration number and 
click the Enter button. Continue this process until you find the value for the box that 
produces a 14.7 AFR/L reading with the O2 sensor disconnected.

The next step is to obtain a free air reading from the O2 sensor. If the O2 sensor is installed 
on an exhaust system that has operated in the last 24 hours, then the sensor should be 
removed from the exhaust to prevent any residual exhaust molecules from affecting the 
free air reading. Connect the sensor to the wideband cable. Wait three minutes for the 
heater in the sensor to bring the tip of the sensor to operating temperature. Carefully check 
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the sensor to insure that it is getting hot. If the tip remains cold, verify that the wideband 
cable is properly connected to the Hydra Nemesis 2.6 unit.

When the sensor reaches operating temperature it will settle on a reading. The AFR/L 
display at the bottom of the settings panel should read 21.5 in free air. If it reads 21.5 or 
more, reduce the value of the UEGO gradient calibration number and click the Enter 
button immediately to the right of it:

Continue this process until it reads less than 21.5. Once it reads less than 21.5, increase the 
value of the UEGO gradient calibration number and click the Enter button. Continue this 
process until you find the minimum value for the box that produces a steady 21.5 AFR 
reading with the O2 sensor in free air.

Insert the O2 sensor back into the exhaust system. Your wideband is now ready to use.

After calibrating your sensors, save your updated base map so that you will be able to 
initialize the Hydra Nemesis 2.6 unit back to the calibrated base map without having to re-
calibrate the sensors in the future. Also, the laptop software remembers the last set of maps 
and settings saved so getting into the habit of always saving after making any changes to 
the Hydra Nemesis 2.6 configuration settings will insure that the laptop software always 
starts up fully synchronized with the settings in the Hydra Nemesis 2.6 unit. Select File-
>Save to file:

This will open a save file dialog. Enter a name for the calibrated base map that you will be 
able to easily identify it by and click the Save button:
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Avoid using the same name as the original base file in case you should ever have to use the 
original base file in the future. It is always a good idea to save under a new file name 
otherwise you lose the benefits of versioning. If you continue to overwrite your changes 
under the same name, you have no way of going back two or three steps if you determine 
that you need to undo something that you have recently done.

There is no need to explicitly save the calibration changes to the Hydra Nemesis 2.6 unit. 
The changes made while the laptop is connected to the unit will automatically be saved and 
remembered by the unit. Since the laptop software always remembers the contents of the 
last maps and settings saved and automatically loads them the next time the laptop software 
is started, getting into the habit of saving any changes to a file before exiting the laptop 
software nearly eliminates the need to ever have to load the current maps and settings 
directly from the Hydra Nemesis 2.6 unit.
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Engine Start

The Hydra Nemesis 2.6 unit is now installed with a proper base map in place, the throttle, 
pedal and wideband sensors are calibrated and your laptop software is properly 
communicating with the unit. Before attempting to start the motor, it is advisable to make 
one quick check of all the engine sensors.

Select Tools->System tools->Preferences:

This will open the preferences panel. Click the DIGITAL radio button on the PANEL 
MODE option:

Also, if you prefer to see temperature, distance and pressure in English units, select the 
IMPERIAL radio button. If you prefer to see metric units, select the METRIC radio 
button:

Click the Save and exit button to complete the preferences setting:

The Display window contains the values of all of the important engine sensors:
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The BATT indicator shows the battery voltage. The Hydra Nemesis 2.6 unit needs a 
healthy battery to start the motor. If the voltage reading is not around 12.0 volts, the battery 
may not have enough of a charge to start the engine. If the battery voltage is low, it is 
recommended that a new battery be purchased or that the battery be removed from the 
vehicle and charged overnight on a battery charger. Using a high current jumper box to 
attempt to start the vehicle may cause damage to the Hydra Nemesis 2.6 unit and will void 
the warranty.

The AIR indicator shows the temperature of the air in the intake manifold. This value 
should be within several degrees of the actual ambient temperature if the engine has not 
been operated for several hours. If this indicator shows an extremely low or extremely high 
value and the current atmospheric conditions are mild, you should contact your Hydra EMS 
dealer for assistance.

The COOL indicator shows the temperature of the coolant in the cooling system. This 
value should be within several degrees of the actual ambient temperature if the engine has 
not been operated for several hours. If this indicator shows an extremely low or extremely 
high value and the current atmospheric conditions are mild, you should contact your Hydra 
EMS dealer for assistance.

The TPS indicator shows the position of the throttle as a percent value between fully 
closed (0%) and fully open (99.9%). Squeeze the accelerator pedal a few times to verify 
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that the throttle sensor is properly calibrated. If not, go back and repeat the throttle 
calibration process.

The VACUUM indicator shows the current barometric pressure when the engine is not 
running. Depending on the weather and your altitude this value can range from 0mmHg at 
sea level to 200mmHg at higher altitude.

The RPM indicator shows engine speed which should be zero until you attempt to start the 
motor.

If all the main engine sensors indicate reasonable values, you are ready to start the motor. 
Turn the key to the start position and crank the motor as you watch the RPM indicator. The 
RPM indicator should show a value between 150 to 250 RPMs while the starter is cranking 
the engine. If the RPM indicator remains at zero or shows very high or random values, 
then it is very likely that you do not have the proper base map installed on the Hydra 
Nemesis 2.6 unit. Contact your Hydra EMS dealer for assistance.

If your engine has been modified and is no longer close to the configuration expected by 
the base maps, it may take a few tries to get the motor started when it is cold. This means 
that fueling and cold start parameters will need further adjustment by a professional tuner.

If the engine appears to make no attempt to start, then you will have to contact your Hydra 
EMS dealer for further assistance. Before you do so, you will want to perform some basic 
tests which the dealer will ask you to perform anyways.

Check that you have fuel in the tank and fuel pressure in the fuel system. The easiest way 
to do this is to attach a fuel pressure gauge to the fuel system. If the vehicle does not have a 
dedicated fuel gauge, many vehicles have a Schrader valve, which looks very much like the 
valve that you have on each tire to add air or check air pressure, to facilitate getting a quick 
fuel pressure reading. Always use a fuel pressure gauge. A tire pressure gauge is not 
designed for taking a fuel pressure reading and may cause a fire. Fuel pressure should be 
between 30psi and 50psi (210kPa to 350kPa) on most vehicles while the engine is 
cranking.

Check that your ignition is producing spark. On vehicles with coils and coil wires, an old-
fashioned spark tester which is a glass tube with a small spark gap inside is the safest 
method of verifying spark. On newer vehicles with coil-on-plug ignitions, you will need to 
remove the coil and use a spark tester to determine if the ignition is producing a spark.

If the engine starts, let it run for a while and verify that the main engine sensors are 
reporting reasonable values.

The VACUUM indicator should show vacuum in the 300mmHg to 600mmHg range as 
soon as the engine starts and settles down to a steady idle. If the indicator continues to read 
the same pre-start atmospheric pressure, check the vacuum line between the intake 
manifold and the Hydra Nemesis 2.6 unit’s vacuum port.
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The COOL indicator should begin to show an increase in coolant temperature within 
seconds of engine start. Depending on the cooling system, you should see the coolant 
temperature rise to between 80C (176F) and 100C (212F) on most vehicles and level off.
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The Editing Screen

The editing screen consists of the menu bar and the main screen area which can contain one 
or more selection, editing and status windows. All the work done through the laptop 
software takes place in the editing screen, the child windows contained within it and the 
panels and settings screens that can be opened using the menus and navigation elements.

Menu Bar

The menu bar at the top of the screen provides eight lists of menu items to select from:

The File list allows you to open and save maps from either the Hydra Nemesis 2.6 unit or 
any of the laptop storage devices. It also allows you to exit the laptop software. Pressing 
alt-f also brings down the list of items available from the File menu.

The Map Group list allows you to select from the various available groups of maps and 
panels. This is one method of navigating to all of the maps and settings contained in a 
Hydra Nemesis 2.6 unit or file. Pressing alt-g also brings down the list of items available 
from the Map Group menu.

The Map list allows you to select from one of the maps in the current Map Group. The 
content of this list changes depending on the last Map Group selected. Pressing alt-m also 
brings down the list of items in the current Map menu.

The Edit list provides access to editing functions. Pressing alt-e also brings down the list 
of items available from the Edit menu.

The Comms list allows you to enable and disable the communications link with the Hydra 
Nemesis 2.6 unit. As we will later see, some functions can only be performed with 
communications between the laptop and the unit enabled and others can only be performed 
with the communications disabled. Pressing alt-c also brings down the list of items 
available from the Comms menu.

The Tools list provides access to several useful tools and panels. Pressing alt-t also brings 
down the list of items available from the Tools menu.

The View list allows for different default screen layouts to be selected. Pressing alt-v also 
brings down the list of items available from the View menu.

The Help list provides access to information about maps, hotkeys and various other useful 
information. Pressing alt-h also brings down the list of item available from the Help menu.
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Work Area

The remainder of the screen contains five child windows, all of which can be individually 
sized, moved, maximized and minimized. There are three default arrangements of these 
five windows that can be selected using the View->Arrange A, View->Arrange B  and 
View->Arrange C menu items:

The default preferred arrangement can also be set up on the preferences panel accessed by 
selecting the Tools->System Tools->Preferences menu item. Select the radio button 
corresponding to your preferred arrangement for the DEFAULT VIEW item:

Click the Save and exit button:

The laptop software will always start with your preferred arrangement. Also, the View-
>Arrange preferred menu item will arrange the windows to the preferred arrangement:

Each child window can be minimized by clicking on the leftmost of the three square icons 
on the top-right corner of the window:
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When minimized, the window disappears to the bottom-most edge of the main parent 
window and shows up only as a small tab. The leftmost of the three square icons on the 
right end of the tab can be clicked again to restore the child window back to the original 
location it occupied when it was minimized:

Each child window can be maximized by clicking on the middle of the three square icons 
on the top-right corner of each window or minimized window tab:

When maximized, the child window expands to cover the entire main parent window and 
the three icons move to the top, right corner of the main screen. The maximized window 
can be returned back to the original location it occupied when it was maximized by 
pressing the middle icon again.

Each child window can be dragged to any location on the main screen and even mostly off 
the main screen by clicking on the top title bar of the window and, while holding down the 
left mouse button, moving the window to the new location desired:
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Each child window can be adjusted to any desired size by clicking any edge of the window 
as the mouse cursor turns into a vertical, horizontal or diagonal adjustment arrow pair and 
holding down the left mouse button while moving the edge of the window to adjust the size 
of the window:

In some of the windows, making the window smaller than the contents of what it is 
displaying will cause horizontal and vertical scroll bars to appear so that the desired portion 
of the contents within that window can be moved into the visible portion of the window. To 
do this, use the left mouse button to click and drag the horizontal or vertical scroll handles 
to bring the desired content into view:

Maps and Setting Modules

The maps and setting modules child window contains a folder tree of the map groups that 
can also be selected using the Map Group menu item:
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Each map group can be expanded or contracted to show the maps within each group or hide 
them. To do this, click on the [+] or [-] icon that connects each map group item to the main 
trunk of the folder tree:

To select any of the maps or setting modules for editing, double click on the desired item. 
The purpose of this child window is to allow for the quick navigation between maps and 
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setting modules and to simplify the task of finding the desired map within the many map 
groups available.

Status

The status child window provides a short, running commentary on which child window 
currently has the editing focus (that is, which window is processing the keyboard input at 
the current time). It also indicates the state of the communication link between the laptop 
software and the Hydra Nemesis 2.6 unit:

Display

Several gauges are present in the display child window. These gauges indicate the current 
readings of the sensors connected to the Hydra Nemesis 2.6 unit and the state of some 
important parameters controlled by the unit.

These items can be displayed in either analog form or digital form. To indicate which form 
is preferred, select Tools->System tools->Preferences, set the radio button of the PANEL 
MODE item to either ANALOG or DIGITAL and click the Save and Exit button:

The display window provides the following information:
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• ADV is ignition timing advance in degrees BTDC,
• FUEL is injection pulse width in milliseconds,
• DUTY is injector duty cycles in percent,
• VSS is vehicle speed,
• O2LEFT is the raw voltage from the left narrowband oxygen sensor,
• O2RIGHT is the raw voltage from the right narrowband oxygen sensor,
• AFR is the reading from the O2 wideband sensor,
• BOOST is intake manifold boost gauge pressure,
• BATT is the voltage across the Hydra Nemesis 2.6 unit’s power pins,
• AIR is the air temperature sensor reading,
• COOL is the coolant temperature reading,
• STTLEFT is the left module short-term closed loop fuel trim,
• STTRIGHT is the right module short-term closed loop trim,
• TPS is the throttle opening value in percent,
• ISC is the idle speed control output in percent,
• KNOCK is the knock sensor voltage,
• RPM is engine speed and
• VACUUM is intake manifold absolute vacuum pressure.
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If the display window is fully maximized, additional dashboard gauge representations of 
some of the sensor values will also be displayed.

Map

The map child window displays a graphical representation of the currently selected map. 
The graph is either 2D or 3D depending on the type of map selected:
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The horizontal and vertical angles at which the graph is presented can be rotated for 
optimal viewing of any map using the horizontal and vertical scroll bars. Grab and move 
the horizontal angle and vertical angle widgets with the mouse and release you are finished 
to reposition the viewing angle:

60



Hydra Nemesis 2.6 Users Manual

Map Data

The map data window displays the selected map in a spreadsheet format. The spreadsheet 
is either 2D or 3D depending on the nature of the selected map:

For the main 3D maps, the x-axis usually indicates engine speed and the y-axis indicates 
engine load. In such cases engine speed always increases on each column towards the right. 
Engine load can be set to increase in either the up or down direction. To change the 
direction, select Tools->System Tools->Preferences and change the GRID LOAD 
DIRECTION setting:
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Edit Colors

If you wish to change the colors used to display the graph in the map window, you can 
select your own colors by selecting Tools->Viewing Tools->Colors:

This will open the color selection panel:

Background color is the color of the graph’s background.

Wire Graph color is the color of the lines used to draw the graph.

RPM band color is the color used to draw the graph line representing the current engine 
speed range that the motor is operating at.

MAP band color is the color used to draw the graph line representing the current load range 
that the motor is operating at.

Keyboard trim band color is the color used to draw the graph lines representing the current 
location of the editing cursor. Note that this color is also used to highlight the cell 
representing the current editing cursor location on the spreadsheet representation of the 
selected map.

Highlight color is the color used to indicate which areas of the map are multiply selected.
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To change the color of any of the items listed on the panel, click the item and a color panel 
will appear to allow you to select the new color:

Click the OK button to accept the new color or the Cancel button to keep the color for that 
item as it was. When all the color assignments are completed, press the Save button on the 
color selection panel to make the color selections permanent for future sessions of the 
laptop software or the OK button to make the color selection only for the current session.
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3D Map Editing

Many of the calibration maps are 3D. This sections explains how 3D maps can be edited.

Track Point and Cursor

There are two highlighted points. Yellow is used to indicate the current engine speed and 
load point that the motor is operating at. We will call this the track point. The other color is 
the keyboard trim color (purple by default unless you change it) and shows which cell 
changes will be applied to. We will call this the cursor:

Navigation

The four arrow keys move the cursor along the axes when either the map or the map data 
windows are selected. The arrow keys will behave as expected based on the window that is 
selected. This is particularly noticeable only if the down direction is chosen for load. In this 
case, the up and down arrows work in an opposite manner for the map window and the map 
data window.

Centering

The grid representation of the map will move to keep either the track point or the cursor 
visible depending on whether the load center or arrow center mode is selected. If load 
center is selected, the grid will move to keep the track point visible. If arrow center is 
selected, the grid will move to keep the cursor in view. The centering mode can be toggled 
when in the map window by pressing the L key. To select the default centering mode, 
select Tools->System tools->Preferences and chose the default GRID CENTERING 
option desired:

Editing

The page up and page down keys will increase and decrease the value of the cell at the 
current cursor location. The amount of change will depend on the map. If the shift key is 
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pressed when making the change, the values will change by the smallest resolution. If the 
shift is not pressed, the normal resolution amount will be used. The - and + keys can be 
used instead of the page up and page down keys. Once a cell value has been changed, it 
will be surrounded by brackets:

Direct Entry

The enter key brings up the direct numerical entry panel that allows you to type in a value 
directly into the cell at the current cursor location:

Either type a number using the keyboard or use the mouse to click the numeric buttons. 
Press enter when done to change the number at the cursor location or press the escape key 
to leave the value at the cursor location unchanged.

Arithmetic Functions

The four basic arithmetic functions can be applied to any cell. Press the A key to directly 
enter a value to add to the current cell:
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Press the S key to directly enter a value to subtract from the current cell:

Press the M key to directly enter a value by which to multiply the current cell:

Press the V key to directly enter a value by which to divide the current cell:
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Seek

The space bar or the F8 key can be used to move the cursor to the current track location.

Multiple Selection

A block of multiple cells can be selected by holding the ctrl key while moving the cursor 
with the arrow keys. The initial cursor location defines one corner of the rectangle of cells 
that will be selected. As the rectangle is expanded, the included cells will be highlighted in 
gray:

Once a block is selected, the page up, page down, direct entry and the arithmetic functions 
will operate on the entire block. If a large block is selected and the Hydra Nemesis 2.6 unit 
is connected and online, a small but noticeable time delay will occur after every operation.

Select All

The Edit->Select all menu item can be used to select all of the cells in a 3D map:
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Copy

The copy feature requires that a block of multiple cells first be selected across which the 
copy will take place. Once a block is selected, pressing the F key will copy the left edge 
values of the block forward across the remaining block of cells. Before the copy is 
performed, a panel showing the graphical impact of performing the copy will be displayed 
and the Ok button must be clicked to complete the copy or the Cancel button clicked to 
cancel the copy:

Similarly, pressing the B key will initiate a copy of the right edge values back across the 
remaining block of cells. Pressing the U key will initiate a copy of the bottom edge values 
upwards across the remaining block of cells. Pressing the D key will initiate a copy of the 
top edge of values downwards across the remaining block of cells.
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Interpolation

To interpolate a region of cells, select a block of multiple cells to perform interpolation 
across. The Y key will then interpolate across the load or y axis of the map. This will 
happen on each column of the grid in which the middle cells of the selected block will be 
adjusted so that the increase or decrease between the uppermost cell of each column in the 
selected block and the lowermost will be linear. Before the interpolation is performed, a 
panel showing the graphical impact of performing the interpolation will be displayed and 
the Ok button must be clicked to complete the interpolation or the Cancel button clicked to 
cancel it:

The X key will interpolate across the engine speed or x axis of the map. This will happen 
on each row of the grid in which the middle cells of the selected block will be adjusted so 
that the increase or decrease between the leftmost cell of each row in the selected block and 
the rightmost will be linear. Before the interpolation is performed, a panel showing the 
graphical impact of performing the interpolation will be displayed and the Ok button must 
be clicked to complete the interpolation or the Cancel button clicked to cancel it:
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Clear Traces

As the track point moves, it leaves a trace of shaded cell values to indicate which cells of 
the map have been used:

This trace can be reset by selecting Tools->Viewing tools->Clear visit traces:
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When editing changes are made to cells, the cell values are highlighted with brackets:

These brackets can be reset by selecting Tools->Viewing tools->Clear edit traces:

If the substrings preference is enabled the Base fuel table and VE table are annotated with 
traces suggesting the amount of fuel to increase or decrease to produce the AFR indicated 
in the AFR target table:
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These annotations can be reset by selecting Tools->Viewing tools->Clear AFR traces:

If the knock threshold is exceeded at any time while the base ignition map is selected, the 
cell closest to the point that knock is detected will be highlighted in red:

These knock traces can be reset by selecting Tools->Viewing tools->Clear knock traces:

Help

On every 3D map, you can select Help->This map to bring up a short information panel 
describing the purpose of the currently selected map:
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You can also select Help->Tuning this map to bring up an information panel providing 
hints about how to adjust the values on the map for best effect:

The Help->Hotkeys menu item will bring up a panel listing all the navigation and editing 
key functions:

The Help->About menu item will bring up a panel indicating the version of the laptop 
software:
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2D Map Editing

Many of the trim maps are 2D. This sections explains how 2D maps can be edited.

Track Point and Cursor

There are two highlighted points. Yellow is used to indicate the current operating point. We 
will call this the track point. The other color is the keyboard trim color (purple by default 
unless you change it) and shows which cell changes will be applied to. We will call this the 
cursor:

Navigation

The left and right arrow keys move the cursor along the map. The up and down arrows 
have no function on the 2D map.

Centering

The grid representation of the map will move to keep either the track point or the cursor 
visible depending on whether the load center or arrow center mode is selected. If load 
center is selected, the grid will move to keep the track point visible. If arrow center is 
selected, the grid will move to keep the cursor in view. The centering mode can be toggled 
when in the map window by pressing the L key. To select the default centering mode, 
select Tools->System tools->Preferences and chose the default GRID CENTERING 
option desired:

Editing

The page up and page down keys will increase and decrease the value of the cell at the 
current cursor location. The amount of change will depend on the map. If the shift key is 
pressed when making the change, the values will change by the smallest resolution. If the 
shift is not pressed, the normal resolution amount will be used. The - and + keys can be 
used instead of the page up and page down keys. Once a cell value has been changed, it 
will be surrounded in brackets:
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Direct Entry

The enter key brings up the direct numerical entry panel that allows you to type in a value 
directly into the cell at the current cursor location:

Either type a number using the keyboard or use the mouse to click the numeric buttons. 
Press enter when done to change the number at the cursor location or press the escape key 
to leave the value at the cursor location unchanged.

Arithmetic Functions

The four basic arithmetic functions can be applied to any cell. Press the A key to directly 
enter a value to add to the current cell:
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Press the S key to directly enter a value to subtract from the current cell:

Press the M key to directly enter a value by which to multiply the current cell:

Press the V key to directly enter a value by which to divide the current cell:
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Seek

The space bar or the F8 key can be used to move the cursor to the current track location.

Multiple Selection

A block of multiple cells can be selected by holding the ctrl key while moving the cursor 
with the arrow keys. The initial cursor location defines one end of the block of cells that 
will be selected. As the block is expanded, the included cells will be highlighted in gray:

Once a block is selected, the page up, page down, direct entry and the arithmetic functions 
will operate on the entire block.

Select All

The Edit->Select all menu item can be used to select all of the cells in a 2D map:

Reset Traces

When editing changes are made to cells, the cell values are highlighted with brackets:

These brackets can be reset by selecting Tools->Viewing tools->Clear edit traces:
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Help

On every 2D map, you can select Help->This map to bring up a short information panel 
describing the purpose of the currently selected map:

You can also select Help->Tuning this map to bring up an information panel providing 
hints about how to adjust the values on the map for best effect:
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Settings Panel Editing

Most of the Hydra Nemesis 2.6 parameters that are not maps are collected into logical 
groups within a settings panel to provide a way of viewing and editing these parameters. 
This section explains how settings panel items can be edited.

Panel Selection

A group of panels is selected from the Map Group menu item or from the Maps and 
Setting Modules window. Currently only the Settings 1 and Settings 2 map group contain 
settings panels:

At the top of each settings panel is a dropdown widget that allows quick selection of every 
logical group in the panel. To go to a particular logical group, left-click on the downward 
facing arrow button on the right side of the dropdown widget, use the mouse to scroll to the 
logical group and left-click the group name:

79



Hydra Nemesis 2.6 User’s Manual

The panel will then change to show all the parameters associated with that logical group.

A left and right arrow widget to the right of the panel selection dropdown also allows the 
next and previous logical group to be selected with a single click. This makes it easy to 
visit all the logical groups in a setting panel without individually choosing each one from 
the dropdown:

Parameter editing

Group parameters are represented either by numerical edit boxes, dropdown widgets, check 
boxes or radio buttons.

Numerical edit boxes show the current numeric value of the parameter and can be clicked 
with the mouse to allow you to replace or edit the numeric value with a new value. There is 
usually a button labeled Enter just to the right of each numerical edit box. This button 
must be clicked once the new value has been entered to send the new setting to the Hydra 
Nemesis 2.6 unit:

Dropdown widgets are used on parameters that can have one of a short list of possible 
settings. To change the setting on a dropdown parameter, left-click on the downward facing 
arrow button on the right side of the dropdown widget, use the mouse to scroll to the 
desired setting for the parameter and left-click on the setting. There is usually a button 
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labeled Enter just to the right of each dropdown parameter. This button must be clicked 
when a new setting has been selected to send it to the Hydra Nemesis 2.6 unit:

Check boxes are used to represent parameters that are either enabled or disabled. To enable 
the parameter, left-click on the box with the mouse until a check mark appears inside the 
box. To disable the parameter, left-click on the box with the mouse until the box is empty. 
There is usually a button labeled Enter just to the right of each check box parameter. This 
button must be clicked when a new setting has been selected to send it to the Hydra 
Nemesis 2.6 unit:

Radio buttons are used to represent parameters that can have two or more possible states. A 
radio button parameter has two or more round circles each with a label beside it to indicate 
the selection represented by that circle. The circle representing the selected state of the 
parameter will have a dot. To change the state of the parameter, left-click on the circle 
representing the state desired. The dot will move to the new state. There is usually a button 
labeled Enter just to the right of each radio button parameter. This button must be clicked 
when a new setting has been selected to send it to the Hydra Nemesis 2.6 unit:

Display

If communications with the Hydra Nemesis 2.6 unit are enabled, the bottom of each 
settings panel will display current sensor values:
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The PPSM value shows a numeric representation between 0 and 255 of the raw voltage on 
the pedal position (used only on drive-by-wire cars and not to be confused with throttle 
position) sensor. The TPSM value shows a numeric representation between 0 and 255 of 
the raw voltage on the throttle position sensor. The AFR/L value shows the AFR ratio for 
the current fuel type selected. The CTS value shows the coolant temperature. The ATS 
shows the air temperature. The AUX1 through AUX4 values show a numeric 
representation of the voltages on the first four auxiliary input pins. These are analog inputs 
with internal pull-to-power resistors. The AXU5 and AUX6 values show the state of these 
two auxiliary inputs which are digital with pull-to-ground resistors. The VSS value shows 
the calculated vehicle speed from the vehicle speed sensor. The last four values are 
reserved for future use.

Help

The Help on/off button on the panel will change the Enter buttons associated with each 
parameter into a Help button and back:

When the Enter buttons are switched to Help buttons, clicking the Help button opens a 
brief help panel giving more information about the effect of the parameter:
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File Menu

This section covers the functions accessed through the File menu item.

Open From File

The open from file option is used to bring a previously edited set of maps and settings from 
a file on a hard disk, CD-ROM, USB jump drive, SD card or any other storage device. 
When the laptop software is started, it automatically loads the maps and settings from the 
last file saved. To open a file, select File->Open from file:

This will open a file open dialog box which allows you to navigate to the device and folder 
that the file you wish to open resides in and select it:
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Hydra Nemesis 2.6 map files have an s26 extension in the Windows© operating 
environment. Older 2.1 and 2.5 versions of the Hydra Nemesis system used the s20 file 
extension. These older s20 files cannot be opened directly. To use them, you must use the 
import map fragment tool.

Open from ECU

The open from ECU option is used to bring the maps and settings currently stored in the 
Hydra Nemesis 2.6 unit connected to the laptop into the laptop software. To do this, select 
File->Open from ECU:

This option is only available when the laptop software is connected to the Hydra Nemesis 
2.6 unit. If the unit is not connected, this menu item will be grayed out:

When the open from ECU option is selected, a progress bar will appear showing the status 
of the transfer from the Hydra Nemesis 2.6 unit into the laptop software:
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When the transfer is complete, all of the maps and settings currently stored in the Hydra 
Nemesis 2.6 unit will be in the laptop software for editing and saving to a file on the 
laptop’s hard disk.

Because the laptop software always starts with the maps and settings of the last file saved, 
it is a good idea to save the maps and settings to a file after they are transferred from the 
Hydra Nemesis 2.6 unit and after any editing changes are made to the maps and settings 
with the unit connected. This way, there will be no need to transfer the maps and settings in 
the unit every time the laptop software is started.

When the laptop software is started and a connection is established with the Hydra Nemesis 
2.6 unit, a quick comparison of the current maps and settings in the laptop software will be 
made against the maps and settings stored in the unit. If there is not a match, the following 
message will appear:

If this message appears, either the contents of the unit must be transferred to the laptop or 
the contents of the laptop must be saved into the unit in order to ensure proper results.

Complete Verify From ECU

The compete verify from ECU option will transfer the maps and settings from the Hydra 
Nemesis 2.6 unit into the laptop software and do a full bit-by-bit comparison of each map 
and setting. This process takes a few minutes and even though it is more thorough and 
complete than performing a fast verify, it is very rarely required except in circumstances 
where absolute verification is required. A complete verification is started by selecting File-
>Complete verify from ECU:
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The contents of the Hydra Nemesis 2.6 unit will then be transferred to the laptop:

Once the complete verification is completed, the results will be presented:

Fast Verify From ECU

A fast verify from the ECU will perform a simple, but effective comparison of the 
checksums of the maps and settings on the Hydra Nemesis 2.6 unit against those on the 
laptop. While it is theoretically possible that this process may not catch a difference 
between the two, it is extremely unlikely that it would happen. To start a fast verification, 
select File->Fast verify from ECU:
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The verification process will then begin:

A notification message will appear only if the verification detects a difference in the maps 
and settings between the unit and the laptop.

Save To File

The save to file option is used to save the current set of maps and settings in the laptop to a 
file on any storage device. When the laptop software is started, it automatically loads the 
maps and settings from the last file saved. To save to a file, select File->Save to file:
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This will open a save as dialog box which allows you to navigate to the device and folder 
that you wish to save the file in and then give the file a name:

Click on the Save button to save the file after you have selected the device, folder and 
name for the file. Otherwise, click the Cancel button to cancel the save. Hydra Nemesis 2.6 
map files have an s26 extension in the Windows© operating environment. Older 2.1 and 
2.5 versions of the Hydra Nemesis system used the s20 file extension. You cannot save a 
2.6 file so that it can be opened and used using an older 2.1 or 2.5 system.

Although it is possible to select an existing file to save to, doing so will overwrite the 
contents of the file so that the maps and settings that were previously stored there are lost. 
If you are careful to choose unique and meaningful file names and save often, you will be 
able to quickly undo unwanted changes and easily go back to previous maps and settings.

Save to ECU

The save to ECU option is used to send the maps and settings currently in the laptop 
software to the Hydra Nemesis 2.6 unit connected to the laptop. To do this, select File-
>Save to ECU:
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This option is only available when the laptop software is connected to the Hydra Nemesis 
2.6 unit. If the unit is not connected, this menu item will be grayed out:

When the save to ECU option is selected, a progress bar will appear showing the status of 
the transfer from the laptop software to the Hydra Nemesis 2.6 unit:

Because the laptop software always starts with the maps and settings of the last file saved, 
it is a good idea to save the maps and settings to a file after they are transferred from the 
Hydra Nemesis 2.6 unit and after any editing changes are made to the maps and settings 
with the unit connected. This way, there will be no need to transfer the maps and settings 
from the unit every time the laptop software is started.

As long as the Hydra Nemesis 2.6 unit and the laptop remain connected, all editing changes 
are automatically sent to the system thus, the save to ECU feature is rarely needed except 
in rare cases where changes must be made offline.
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Exit

To exit from the laptop software, select File->Exit:

Because the laptop software always starts with the maps and settings of the last file saved, 
it is often a good idea to save the maps and settings in the laptop software to a file before 
exiting. By doing so, the Hydra Nemesis 2.6 unit and the laptop software will contains the 
same maps and settings the next time the laptop software is started and no time will be 
wasted transferring the maps and settings from the system to the laptop.
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3D Fuel Calibration

This section covers all of the 3D maps in the 3D Fuel Calibration map group. This map 
group is accessed by selecting Map Group->3D Fuel Calibration:

Base Fuel Table

The 3D base fuel table is accessed when the 3D Fuel Calibration map group is selected by 
selecting Map->Base fuel table:

The F3 key can also be used to quickly select the base fuel table. The 32 by 32 base fuel 
table indicates the base fueling value used by the Hydra Nemesis 2.6 unit to determine how 
long to pulse the injectors on every cylinder cycle when VE mode is not enabled. The base 
fuel map can define any injection pulse width between 0 and 40 milliseconds in 0.005 
millisecond increments. The x-axis of the map denotes current engine speed while the y-
axis denotes load in either manifold pressure when operating in standard speed density 
mode or in calculated manifold pressure when operating in alpha-n mode. Interpolation is 
automatically performed across both axes to determine the actual base fueling injector 
pulse width value.

Anti-lag Fuel Trim

The 3D anti-lag fuel trim table is accessed when the 3D Fuel Calibration map group is 
selected by selecting Map->Anti-lag fuel trim:
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This 32 by 32 map indicates how many milliseconds are added if the trim value is positive 
or subtracted if the trim value is negative from the base fuel value when anti-lag is 
externally requested. Values in this map can range between -10.2 ms enleanment to 10.2 
ms enrichment. The x-axis of the map denotes current engine speed while the y-axis 
denotes load in either manifold pressure when operating in standard speed density mode or 
in calculated manifold pressure when operating in alpha-n mode. Interpolation is 
automatically performed across both axes to determine the actual base fueling injector 
pulse width value.

Anti-lag Active Fuel Cut Cycles

The 3D anti-lag active fuel cut cycles table is accessed when the 3D Fuel Calibration map 
group is selected by selecting Map->Anti-lag active fuel cut cycles:

This is a 32 by 32 map whose x-axis uses the same engine speed points as the base fuel and 
anti-lag trim maps but whose y-axis is defined in terms of throttle opening percentage 
instead of load. Values in this map range from 0 to 96.9 and indicate the percentage of fuel 
injection events that will be cut from the otherwise normal operation of the motor while 
anti-lag is externally requested and the anti-lag active timer has not timed out. Cutting an 
injection event will transfer oxygen-rich air from the intake manifold into the exhaust 
manifold where, if unburned fuel is encountered, will produce large amounts of heat to 
keep a turbocharger spinning. Do not adjust this map unless you are well aware of the 
consequences.
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Auxiliary Fuel Trim

The 3D auxiliary fuel trim table is accessed when the 3D Fuel Calibration map group is 
selected by selecting Map->Auxiliary fuel trim:

This 32 by 32 map indicates how many milliseconds are added if the trim value is positive 
or subtracted if the trim value is negative from the base fuel value when auxiliary is 
externally requested. Values in this map can range between -10.2 ms enleanment to 10.2 
ms enrichment. The x-axis of the map denotes current engine speed while the y-axis 
denotes load in either manifold pressure when operating in standard speed density mode or 
in calculated manifold pressure when operating in alpha-n mode. Interpolation is 
automatically performed across both axes to determine the actual base fueling injector 
pulse width value.

VE

The 3D VE (Volumetric Efficiency) map is accessed when the 3D Fuel Calibration map 
group is selected by selecting Map->VE:

The F5 key can also be used to quickly select the VE map. The 32 by 32 VE map indicates 
the base fueling value used by the Hydra Nemesis 2.6 unit to determine how long to pulse 
the injectors on every cylinder cycle when VE mode is enabled. The VE map can define 
any volumetric efficiency from 0% to 255% in one percent increments. The x-axis of the 
map denotes current engine speed while the y-axis denotes load in either manifold pressure 
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when operating in standard speed density mode or in calculated manifold pressure when 
operating in alpha-n mode. Interpolation is automatically performed across both axes to 
determine the actual volumetric efficiency value.

In VE mode, fuel is calculated based on the theoretical basis provided by Boyle’s law. 
What the law tells us is that if we know the pressure and temperature of a precise volume 
of air, then we know exactly how many molecules of air we have. If we know how many 
molecules of air we have, then we can simply look at our target AFR map to determine 
how many molecules of fuel we need to inject to produce the desired ratio of air-to-fuel 
molecules. If we know how many molecules of fuel we need we can figure out how much 
volume of fuel we have to inject in the cylinder. If we know how much volume of fuel we 
need in the cylinder and we know the effective injection rate of the injectors then we can 
determine how long we have to open the injectors to properly fuel the motor.

Engines are not perfect air pumps that fill up with exactly 100% of the air that they 
displace from the intake manifold under every point in their operating range. For this 
reason, engine designers developed the term Volumetric Efficiency to specify what volume 
of air in the intake manifold will be pumped into the exhaust manifold every two 
revolutions of the motor (one full cycle on a 4-stroke engine) relative to the static 
displacement of the motor. For example, a motor with a VE of 75% and a displacement of 
two liters consumes 1.5 liters of the air charge in the intake manifold on every two 
revolutions of the crank. VE is not a constant. It changes depending on the load and speed 
of the motor.

The learn data tuning tool can be used on this table to perform auto tuning. Select Tools-
>Tuning Tools->Learn Data:

This feature is available only if the learn data function has been activated with a suitable 
software key purchased from your Hydra EMS dealer. This activation key is included in 
the cost of the O2 wideband option. When the learning feature is selected, the laptop 
software will make adjustments to the VE table so that the target AFR value indicated by 
the target AFR table matches the O2 wideband sensor value:
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Auto tuning should be used only in a controlled environment and only after the VE map 
has been tuned enough that there are no large AFR holes or spikes. Otherwise, the car may 
behave very erratically as these holes are partially filled or removed by the auto tuning 
function. Also, it is very important that closed loop fuel adjustments be disabled while the 
auto tune tool is in use. Otherwise, very strange and erratic results may be obtained as the 
closed loop and auto tuning tool fight to control the target AFR.

When the auto tuning session is complete, click the Ok button to save the changes made to 
the VE table and exit the learning feature.

Launch Fuel Cut Cycles

The 3D launch fuel cut cycles table is accessed when the 3D Fuel Calibration map group 
is selected by selecting Map->Launch fuel cut cycles:
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This is a 32 by 32 map whose x-axis uses the same engine speed points as the base fuel and 
fuel trim maps but whose y-axis is defined in terms of throttle opening percentage instead 
of load. Values in this map range from 0 to 96.9 and indicate the percentage of fuel 
injection events that will be cut from the otherwise normal operation of the motor while the 
launch request is active. Cutting an injection event will transfer oxygen-rich air from the 
intake manifold into the exhaust manifold where, if unburned fuel is encountered, will 
produce large amounts of heat to keep a turbocharger spinning. Do not adjust this map 
unless you are well aware of the consequences.

Flat-shift Fuel Cut Cycles

The 3D flat-shift fuel cut cycles table is accessed when the 3D Fuel Calibration map 
group is selected by selecting Map->Flat-shift fuel cut cycles:

This is a 32 by 32 map whose x-axis uses the same engine speed points as the base fuel and 
fuel trim maps but whose y-axis is defined in terms of throttle opening percentage instead 
of load. Values in this map range from 0 to 96.9 and indicate the percentage of fuel 
injection events that will be cut from the otherwise normal operation of the motor while the 
flat-shift request is active. Cutting an injection event will transfer oxygen-rich air from the 
intake manifold into the exhaust manifold where, if unburned fuel is encountered, will 
produce large amounts of heat to keep a turbocharger spinning. Do not adjust this map 
unless you are well aware of the consequences.
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Anti-lag Inactive Fuel Cut Cycles

The 3D anti-lag active fuel cut cycles table is accessed when the 3D Fuel Calibration map 
group is selected by selecting Map->Anti-lag inactive fuel cut cycles:

This is a 32 by 32 map whose x-axis uses the same engine speed points as the base fuel and 
anti-lag trim maps but whose y-axis is defined in terms of throttle opening percentage 
instead of load. Values in this map range from 0 to 96.9 and indicate the percentage of fuel 
injection events that will be cut from the otherwise normal operation of the motor while 
anti-lag is externally requested but the anti-lag active timer has timed out. Cutting an 
injection event will transfer oxygen-rich air from the intake manifold into the exhaust 
manifold where, if unburned fuel is encountered, will produce large amounts of heat to 
keep a turbocharger spinning. Do not adjust this map unless you are well aware of the 
consequences.
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3D Ignition Calibration

This section covers all of the 3D maps in the 3D Ignition Calibration map group. This 
map group is accessed by selecting Map Group->3D Ignition Calibration:

Base Timing Table

The 3D base timing table is accessed when the 3D Ignition Calibration map group is 
selected by selecting Map->Base timing table:

The F4 key can also be used to quickly select the base timing table. The 32 by 32 base 
timing table indicates the location in degrees the ignition is to fire the spark plug before 
reaching TDC for each cylinder event. The base timing map can define any degree between 
0 and 127.5 in one-half degree increments. The x-axis of the map denotes current engine 
speed while the y-axis denotes load in either manifold pressure when operating in standard 
speed density mode or in calculated manifold pressure when operating in alpha-n mode. 
Interpolation is automatically performed across both axes to determine the actual base 
timing value.

Anti-lag Ignition Trim

The 3D anti-lag ignition trim table is accessed when the 3D Ignition Calibration map 
group is selected by selecting Map->Anti-lag ignition trim:
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This is a 32 by 32 map whose x-axis uses the same engine speed points as the base fuel and 
timing maps but whose y-axis is defined in terms of throttle opening percentage instead of 
load. Values in this map range from -64 degrees to 63.5 degrees. This value is added to the 
base ignition value to determine base ignition timing. Interpolation is automatically 
performed across both axes to determine the actual trim timing value.

Anti-lag Ignition Cut Cycles

The 3D anti-lag ignition cut cycles table is accessed when the 3D Ignition Calibration 
map group is selected by selecting Map->Anti-lag ignition cut cycles:

This is a 32 by 32 map whose x-axis uses the same engine speed points as the base fuel and 
timing maps but whose y-axis is defined in terms of throttle opening percentage instead of 
load. Values in this map range from 0 to 96.9 and indicate the percentage of ignition events 
that will be cut from the otherwise normal operation of the motor while anti-lag is 
externally requested and the anti-lag active timer has not timed out. Cutting an ignition 
event will transfer unburned air fuel mixture into the exhaust manifold where it will 
produce large amounts of heat to keep a turbocharger spinning. Do not adjust this map 
unless you are well aware of the consequences.

Auxiliary Ignition Trim

The 3D anti-lag ignition cut cycles table is accessed when the 3D Ignition Calibration 
map group is selected by selecting Map->Auxiliary ignition trim:
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This 32 by 32 map indicates how many degrees are added if the trim value is positive or 
subtracted if the trim value is negative from the base timing value when auxiliary is 
externally requested. Values in this map can range between -64 degrees to 63.5 degrees in 
one-half degree increments. The x-axis of the map denotes current engine speed while the 
y-axis denotes load in either manifold pressure when operating in standard speed density 
mode or in calculated manifold pressure when operating in alpha-n mode. Interpolation is 
automatically performed across both axes to determine the actual base timing value.

Backup Table

The 3D backup table is accessed when the 3D Ignition Calibration map group is selected 
by selecting Map->Backup Table:

The 32 by 32 backup timing table indicates the location in degrees the ignition is to fire the 
spark plug before reaching TDC for each cylinder event. The backup timing map can 
define any degree between 0 and 127.5 in one-half degree increments. The x-axis of the 
map denotes current engine speed while the y-axis denotes load in either manifold pressure 
when operating in standard speed density mode or in calculated manifold pressure when 
operating in alpha-n mode. Interpolation is automatically performed across both axes to 
determine the actual base timing value.

The backup timing table can be selected in three ways:
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• externally through an configurable input request,
• by knock detection settings when excessive knock is indicated or
• by prolonged lean AFR conditions.

Launch Ignition Cut Cycles

The 3D launch ignition cut cycles table is accessed when the 3D Ignition Calibration map 
group is selected by selecting Map->Launch ignition cut cycles:

This is a 32 by 32 map whose x-axis uses the same engine speed points as the base fuel and 
timing maps but whose y-axis is defined in terms of throttle opening percentage instead of 
load. Values in this map range from 0 to 96.9 and indicate the percentage of ignition events 
that will be cut from the otherwise normal operation of the motor while launch request is 
active. Cutting an ignition event will transfer unburned air fuel mixture into the exhaust 
manifold where it will produce large amounts of heat to keep a turbocharger spinning. Do 
not adjust this map unless you are well aware of the consequences.

Flat-shift Ignition Cut Cycles

The 3D launch ignition cut cycles table is accessed when the 3D Ignition Calibration map 
group is selected by selecting Map->Flat-shift ignition cut cycles:
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This is a 32 by 32 map whose x-axis uses the same engine speed points as the base fuel and 
timing maps but whose y-axis is defined in terms of throttle opening percentage instead of 
load. Values in this map range from 0 to 96.9 and indicate the percentage of ignition events 
that will be cut from the otherwise normal operation of the motor while flat-shift request is 
active. Cutting an ignition event will transfer unburned air fuel mixture into the exhaust 
manifold where it will produce large amounts of heat to keep a turbocharger spinning. Do 
not adjust this map unless you are well aware of the consequences.
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3D Engine Calibration

This section covers all of the 3D maps in the 3D Engine Calibration map group. This map 
group is accessed by selecting Map Group->3D Engine Calibration:

TPS:MAP Weight

The 3D TPS:MAP weight table is accessed when the 3D Engine Calibration map group is 
selected by selecting Map->TPS:MAP weight:

This 32 by 32 map whose x-axis uses the same engine speed points as the base fuel and 
base timing maps but whose y-axis denotes throttle opening is used only when alpha-n 
mode is selected. The purpose of this map is to indicate how the calculated TPS load signal 
and the actual manifold pressure load signal should be blended to produce the load value 
that will be used to reference all 3D maps that use load as their y-axis value.

The load value used to access the 3D fuel, timing and engine calibration maps is:

load = TPS:MAP weight% × Programmed MAP + (100% - TPS:MAP weight%) × MAP

A value of 100 will cause the system to operate pure alpha-n at that throttle position and 
engine speed. A value of 0 will cause the system to operate pure speed density at that 
throttle position and engine speed. In between values produce a blend of alpha-n and speed 
density.
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Intake VCT Target

The 3D Intake VCT target table is accessed when the 3D Engine Calibration map group is 
selected by selecting Map->Intake VCT target:

This 32 by 32 map indicates the desired target location of the intake variable cam relative 
to a centerline position defined by the engine-specific ignition trigger. Negative values 
retard the cam from the centerline position while positive values advance it. The x-axis of 
the map denotes current engine speed while the y-axis denotes load in either manifold 
pressure when operating in standard speed density mode or in calculated manifold pressure 
when operating in alpha-n mode. Interpolation is automatically performed across both axes 
to determine the actual target value.

Some engines may be damaged if the cam is retarded or advanced beyond an allowable 
position. Do not adjust this map unless you are fully aware of the potential consequences. 
Also, this map indicates only the desired target setting. Actual setting is determined in most 
VTC motors by the available oil pressure. Not all settings are possible at all engine speed 
and load points and attempting to move the cam beyond the physical capabilities of the 
engine may result in poor and erratic performance.

Exhaust VCT Target

The 3D Exhaust VCT target table is accessed when the 3D Engine Calibration map group 
is selected by selecting Map->Exhaust VCT target:
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This 32 by 32 map indicates the desired target location of the exhaust variable cam relative 
to a centerline position defined by the engine-specific ignition trigger. Negative values 
retard the cam from the centerline position while positive values advance it. The x-axis of 
the map denotes current engine speed while the y-axis denotes load in either manifold 
pressure when operating in standard speed density mode or in calculated manifold pressure 
when operating in alpha-n mode. Interpolation is automatically performed across both axes 
to determine the actual target value.

Some engines may be damaged if the cam is retarded or advanced beyond an allowable 
position. Do not adjust this map unless you are fully aware of the potential consequences. 
Also, this map indicates only the desired target setting. Actual setting is determined in most 
VTC motors by the available oil pressure. Not all settings are possible at all engine speed 
and load points and attempting to move the cam beyond the physical capabilities of the 
engine may result in poor and erratic performance.

AFR/LABMDA Target

The 3D AFR/LAMBDA target table is accessed when the 3D Engine Calibration map 
group is selected by selecting Map->AFR/LAMBDA target:

This 32 by 32 map indicates the desired AFR or lambda target for every engine speed and 
load point that the engine might operate under. The meaning of the numbers depends on the 
fuel type settings in the preferences panel. The x-axis of the map denotes current engine 
speed while the y-axis denotes load in either manifold pressure when operating in standard 
speed density mode or in calculated manifold pressure when operating in alpha-n mode. 
Interpolation is automatically performed across both axes to determine the actual AFR 
target value.

This map is used for many purposes and it should be one of the first maps that is properly 
adjusted before any tuning is done. Do not make any changes to this map unless you are 
familiar with the proper fueling requirements of the motor. It is possible to damage an 
engine by either over or under fueling it.

When operating in VE mode, the values in this map along with cylinder displacement, 
injector flow rate and the VE table determine actual injector pulse width values. When 
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operating the engine, the base fuel table and VE maps will show the current target AFR as 
well as the current AFR reading from the O2 wideband sensor:

The TAFR label indicates the current target AFR interpolated from the AFR/LAMBDA 
target table while the AFR label indicates the current AFR reading from the wideband. 
This makes it easy to adjust the base fuel and VE maps under steady-state load without 
having to constantly think about the current engine speed and load point.

When closed loop mode is enabled and the selected sensor is the UEGO wideband sensor 
with the target table, the closed loop system will make fuel adjustments based on the 
current AFR target given in the AFR target table.

The auto tune feature will automatically adjust the VE table by comparing the actual AFR 
reading from the O2 wideband sensor against the current AFR target given in the 
AFR/LAMBDA target table.

Programmed MAP

The 3D programmed MAP table is accessed when the 3D Engine Calibration map group 
is selected by selecting Map->Programmed MAP:

This 32 by 32 map whose x-axis uses the same engine speed points as the base fuel and 
base timing maps but whose y-axis denotes throttle opening is used only when alpha-n 
mode is selected. The values on this map range from 0 to 102. They indicate the kPa value 
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to use at each engine speed point relative to the throttle opening. This value is then passed 
though the TPS:MAP weight table to produce the calculated load to access the fuel, timing 
and engine calibration maps when the Hydra Nemesis 2.6 unit is operating in alpha-n 
mode.

The learn data tuning tool can be used on this map to populate it with a real manifold 
pressure signal from the manifold pressure (MAP) sensor:

This feature is available only if the learn data function has been activated with a suitable 
software key purchased from your Hydra EMS dealer. This activation key is included in 
the cost of the O2 wideband option. Depending on the intake setup and aggressiveness of 
the cams, a large vacuum manifold may be required to produce a strong enough vacuum 
signal for learning. This manifold can then be removed or made much smaller after the 
learning is completed to provide a faster responding load signal for fuel and timing 
calculations.

Auxiliary AFR/LAMBDA Target

The 3D auxiliary AFR/LAMBDA target table is accessed when the 3D Engine 
Calibration map group is selected by selecting Map->AUX AFR/LAMBDA target:

This 32 by 32 map indicates the desired AFR or lambda target for every engine speed and 
load point that the engine might operate under when auxiliary is externally requested. The 
meaning of the numbers depends on the fuel type settings in the preferences panel. The x-
axis of the map denotes current engine speed while the y-axis denotes load in either 
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manifold pressure when operating in standard speed density mode or in calculated manifold 
pressure when operating in alpha-n mode. Interpolation is automatically performed across 
both axes to determine the actual AFR target value.
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2D Fuel Trims

This section covers all of the 2D maps in the 2D Fuel Trims map group. This map group is 
accessed by selecting Map Group->2D Fuel Trims:

Coolant Temperature Fuel Trim

The 2D coolant temperature fuel trim map is accessed when the 2D Fuel Trims map group 
is selected by selecting Map->Coolant temp fuel trim:

The coolant temperature trim map defines an enrichment added to the base fuel injection 
values from the point of engine start until the engine stops. The coolant temperature value 
will determine which point on the coolant temperature trim map will be used. The 
measurement units settings on the preferences panel will determine if the coolant 
temperature points will be shown in Celsius or Fahrenheit.

Air Temperature Fuel Trim

The 2D air temperature fuel trim map is accessed when the 2D Fuel Trims map group is 
selected by selecting Map->Air temp fuel trim:
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The air temperature trim map defines an enrichment added to the base fuel injection values 
from the point of engine start until the engine stops. The air temperature value will 
determine which point on the air temperature trim map will be used. This map is used to 
compensate for the density of air. Denser air contains more molecules per volume and thus 
requires more fuel to produce a desired AFR. The measurement units settings on the 
preferences panel will determine if the air temperature points will be shown in Celsius or 
Fahrenheit.

Throttle Pump Enrichment

The 2D throttle pump enrichment map is accessed when the 2D Fuel Trims map group is 
selected by selecting Map->Throttle pump enrichment:

The throttle pump map is used to inject extra fuel to compensate for the condensation effect 
present when an abrupt manifold pressure change takes place. The map indicates how 
much additional enrichment to add to the current base fuel injection value when a quick 
throttle or intake manifold pressure change is detected. The engine speed at the point the 
change is first detected determines which value of the throttle pump enrichment map to 
use. The throttle pump enrichment decays quickly over several cylinder events.

Throttle pump can be activated either by a quick change in throttle position or in the 
manifold pressure measurement or both. The TPS sensitivity threshold value determines 
the sensitivity to throttle position changes. A large value will make throttle pump 
enrichment very insensitive to throttle changes while a small value will increase sensitivity 
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to throttle changes. The MAP sensitivity threshold value determines the sensitivity to 
intake manifold pressure changes. A large value will make throttle pump enrichment very 
insensitive to intake manifold pressure changes while a small value will increase sensitivity 
to intake manifold pressure changes.

Most setups will function very well with just throttle sensitivity. Intake manifold pressure 
sensitivity should be added only in cases where a turbocharger spools so quickly that a lean 
condition is produced because of the same rapid change in manifold pressure that requires a 
throttle pump enrichment.

Tip In Enrichment

The 2D tip in enrichment map is accessed when the 2D Fuel Trims map group is selected 
by selecting Map->Tip in enrichment:

Tip in is a transitional enrichment similar to throttle pump enrichment except that tip in is 
triggered only by the throttle position sensor and only when the throttle transitions from the 
completely closed position to an open position. The engine speed at the point the throttle 
change is first detected determines which value of the tip in enrichment map to use. Tip in 
is used primarily to bring the motor out of the very lean deceleration fuel cut mode back to 
a torque producing state when the throttle is opened again after coasting in the closed state.

ISC Position Trim

The 2D tip in enrichment map is accessed when the 2D Fuel Trims map group is selected 
by selecting Map->ISC position trim:
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The ISC position trim map is used to compensate for the effect of the idle control valve in 
alpha-n mode. Without this trim map, the AFR will vary as the throttle position stays 
constant but the idle valve adjusts the air entering the motor. The ISC position computed to 
maintain the desired target speed determines which value of the ISC position trim map is 
used.

Knocking Enrichment

The 2D knocking enrichment map is accessed when the 2D Fuel Trims map group is 
selected by selecting Map->Knocking enrichment:

The knocking enrichment map indicates how much additional fuel beyond the calculated 
fuel to inject depending on how many degrees of knock response produced timing retard 
are currently in effect. A combination of more fuel and reduced timing is more effective at 
eliminating detonation than just reducing timing.

Air Conditioner Enrichment Set

The 2D air conditioner enrichment set map is accessed when the 2D Fuel Trims map 
group is selected by selecting Map->AC enrichment set:
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The air conditioner set enrichment map provides for a temporary, decaying fuel enrichment 
when the air conditioner compressor switches on to help the idle control system 
compensate for the sudden, instant load. This feature can, if carefully calibrated, make the 
A/C clutch engagement feel seamless. This map indicates how much extra fuel to add to 
the current fuel calculation when the A/C compressor is first switched on. The engine will 
often be able to use a little bit of extra fuel, particularly at lower engine speeds, to 
compensate for the brief drop in engine speed that happens while idling and cruising when 
the A/C compressor switches on. The engine speed at the point the A/C compressor is 
switched on determines which value of the enrichment map to use. The speed at which the 
extra fuel decays is determined by the air conditioner enrichment decay map.

Air Conditioner Enrichment Decay

The 2D air conditioner enrichment decay map is accessed when the 2D Fuel Trims map 
group is selected by selecting Map->AC enrichment decay:

The map indicates how the air conditioner enrichment set fuel trim decays at 2000 RPMs. 
The actual decay is based on cylinder cycles, so at 1000 RPMs, the decay would take twice 
as long as indicated and at 4000 RPMs the decay would take half as long as indicated. Each 
column indicates the percentage the initial fuel enrichment present over the cylinder events 
indicated. The first item in the table should be 100% or close to 100% and each successive 
value should decrease. Generally, the air conditioner fuel enrichment can be decayed rather 
quickly once the compressor comes up to speed.
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2D Ignition Trims

This section covers all of the 2D maps in the 2D Ignition Trims map group. This map 
group is accessed by selecting Map Group->2D Ignition Trims:

Coolant Temperature Ignition Trim

The 2D coolant temperature ignition trim map is accessed when the 2D Ignition Trims 
map group is selected by selecting Map->Coolant temp ignition trim:

The coolant temperature ignition trim map allows timing advance to be added or removed 
from the base timing advance value based on the coolant temperature value. The value 
indicates degrees of advance in one-half degree increments. Positive values increase timing 
advance to the base ignition timing. Negative values retard the base ignition timing. It is 
useful for giving the motor a couple extra degrees of advance to help bring the idle up 
when it is cold or to pull out a couple degrees of timing advance when the engine starts to 
overheat to protect it from damage. The coolant temperature value will determine which 
point on the coolant temperature ignition trim map will be used. The measurement units 
settings on the preferences panel will determine whether the coolant temperature points 
will be shown in Celsius or Fahrenheit.

Air Temperature Ignition Trim

The 2D air temperature ignition trim map is accessed when the 2D Ignition Trims map 
group is selected by selecting Map->Air temp ignition trim:
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The air temperature ignition trim map allows timing advance to be added or removed from 
the base timing advance value based on the air temperature value. The value indicates 
degrees of advance in one-half degree increments. Positive values increase timing advance 
to the base ignition timing. Negative values retard the base ignition timing. It is useful for 
pulling out a couple degrees of timing advance when the air intake temperatures on forced 
induction setups get very high to protect it from damage. The air temperature value will 
determine which point on the air temperature ignition trim map will be used. The 
measurement units settings on the preferences panel will determine whether the coolant 
temperature points will be shown in Celsius or Fahrenheit.

Ignition Upper Limit

The 2D ignition upper limit map is accessed when the 2D Ignition Trims map group is 
selected by selecting Map->Ignition upper limit:

The ignition upper limit map defines the maximum timing advance in degrees that will be 
allowed at any given engine speed regardless of the final calculation of the ignition base, 
offset and trim maps. This mechanism provides an extra level of safety to prevent potential 
engine damage due to unforeseen interactions or mistakes. The ignition upper limit should 
be set before any ignition timing advance calibration is attempted.
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Ignition Lower Limit

The 2D ignition lower limit map is accessed when the 2D Ignition Trims map group is 
selected by selecting Map->Ignition lower limit:

The ignition lower limit map defines the minimum timing advance in degrees that will be 
allowed at any given engine speed regardless of the final calculation of the ignition base, 
offset and trim maps. This mechanism provides an extra level of safety to prevent potential 
engine damage due to unforeseen interactions or mistakes. The ignition lower limit should 
be set before any ignition timing advance calibration is attempted. Of particular note when 
attempting to use ATDC timing for anti-lag effects: no ATDC ignition timing will occur 
unless the ignition lower limit map contains negative values.

Air Conditioner On Ignition Trim Set

The 2D air conditioner on ignition trim set map is accessed when the 2D Ignition Trims 
map group is selected by selecting Map->AC on ignition trim set:

The air conditioner on ignition trim map allows timing advance to be added or removed 
from the base timing advance value at the time that the air conditioner compressor is 
switched on and for some cylinder cycles afterwards. The value indicates degrees of 
advance in one-half degree increments. Positive values increase timing advance to the base 
ignition timing. Negative values retard the base ignition timing. It is useful for adding a 
couple degrees of timing advance to give the motor a little more torque, particularly at idle 
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and low engine speeds when the air conditioner compressor switches on. The map indicates 
how the air conditioner ignition trim operates at 2000 RPMs. The actual trim is based on 
cylinder cycles, so at 1000 RPMs, the trims would happen in twice the time indicated and 
at 4000 RPMs the trims would happen in half the time indicated.

Short Term Trim Ignition Trim

The 2D short term trim ignition trim map is accessed when the 2D Ignition Trims map 
group is selected by selecting Map->STT ignition trim:

The short term trim map allows the base ignition timing to be advanced if positive numbers 
are used and retarded if negative numbers are used based on the current value of the short 
term trim applied by the closed loop correction system. The middle 0% cell value is used 
when no short term correction is applied. The negative labeled cells to the left of the 0% 
cell indicate cells used when fuel is taken out by the closed loop system. The positive 
labeled cells to the right of the 0% cell indicate cells used when fuel is added by the closed 
loop system. By carefully adjusting ignition timing, the slight feeling of torque loss and 
torque gain that is felt in some vehicles under closed loop operation can be minimized or 
completely eliminated.
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2D Engine Calibration

This section covers all of the 2D maps in the 2D Engine Calibration map group. This map 
group is accessed by selecting Map Group->2D Engine Calibration:

Injector Response

The 2D injector response map is accessed when the 2D Engine Calibration map group is 
selected by selecting Map->Injector response:

The injector response map indicates how much injector pulse width in milliseconds to add 
to the final injector pulse width calculation to compensate for the injector opening time. 
During the opening time of the injector, no fuel is injected, so the time indicated by the 
injector response map covers what is commonly referred to as “dead time.” Injector 
opening times increase as voltage available to open the injector drops. The purpose of the 
injector response map is to compensate for the effects that the vehicle’s electrical system 
voltage has on the final injector pulse widths required to maintain the desired AFR. The 
injector pulse width value added to the final injector opening time is determined based on 
the voltage detected by the Hydra Nemesis 2.6 unit at the power supply pins of the unit. 
The import default injector response map tool can be used to initialize the injector response 
map with reasonable starting values.
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Injector Phasing

The 2D injector phasing map is accessed when the 2D Engine Calibration map group is 
selected by selecting Map->Injector phasing:

Injector phasing map defines where the injection pulses end when the sequential injection 
strategy is selected. The value in the map indicates the number of degrees before BDC on 
the intake stroke of the cylinder at which injection ends based on the current engine speed. 
For example, a value of 180 indicates that injection should end at TDC as the intake valve 
is starting to fully open. Generally, injection should complete well before the intake valve 
starts to close, otherwise, substantial amounts of fuel will condensate in the port waiting for 
the next value opening event and be wasted. At very high injector duty cycles, injector 
phasing has little effect because the injectors are open almost all the time.

Knock Threshold

The 2D knock threshold map is accessed when the 2D Engine Calibration map group is 
selected by selecting Map->Knock threshold:

The knock threshold map can also be accessed by pressing the F6 key. When the motor is 
in operation and the laptop is connected to the Hydra Nemesis 2.6 unit, this map shows a 
moving marker on the graph indicating the recent knock signal voltage versus engine 
speed:
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The purpose of the knock threshold map is to indicate to the knock signal value at each 
engine speed above which the signal is assumed to be real detonation versus normal engine 
noise. In order to determine the proper threshold setting, it is necessary to first set the 
threshold high enough to allow the car to be tuned without knock and then to either use the 
data logger or the signal display on the knock threshold map screen to determine how much 
knock voltage is present during knock-free operation. The threshold should then be set just 
slightly above this point.

Fuel Cut Lower Limit

The 2D fuel cut lower limit map is accessed when the 2D Engine Calibration map group 
is selected by selecting Map->Fuel cut lower limit:
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The fuel cut lower limit map determines the lowest engine speed at which deceleration fuel 
cut will be in effect based on the coolant temperature value. Generally, a cold engine might 
stall unless fuel is reinstated at a higher engine speed point. The measurement units settings 
on the preferences panel will determine whether the coolant temperature points will be 
shown in Celsius or Fahrenheit.

Dwell

The 2D dwell map is accessed when the 2D Engine Calibration map group is selected by 
selecting Map->Dwell:

The dwell map allows you to define the base length of the ignition timing pulse in 
milliseconds sent to the igniter determined by the voltage detected by the Hydra Nemesis 
2.6 unit on the power supply pins. Do not adjust this value unless you know exactly what 
you are doing as it is very easy to overheat and damage coils by applying an incorrect 
amount of dwell.

Dwell Trim

The 2D dwell trim map is accessed when the 2D Engine Calibration map group is 
selected by selecting Map->Dwell trim:

The dwell trim map allows the base dwell defined in the dwell map to be increased or 
decreased by the number of milliseconds indicated based on the current engine speed. Do 
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not adjust this value unless you know what you are doing as it is very easy to overheat and 
damage coils by applying an incorrect amount of dwell.

Rapid Setup Trim

The 2D dwell trim map is accessed when the 2D Engine Calibration map group is 
selected by selecting Map->Rapid setup trim:

The rapid setup trim map defines a percentage of fuel to add or remove from the base fuel 
calculation value based on the current manifold pressure. This map can be used to rapidly 
set up forced induction on a naturally aspirated motor. To do so, copy the zero vacuum 
base fuel table row up into the boost region of the fuel map:
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Then populate the rapid setup trim map to double fuel between zero vacuum (101kPa) and 
14.7psi (202kPa):

This is uses the fact that Boyles Law predicts that the number of molecules in a gas doubles 
if its pressure doubles while its volume stays constant. Since the number of air molecules 
double when the absolute pressure in the intake manifold doubles, then as you go from an 
absolute pressure of 101kPa to 202kPa the amount of fuel required doubles. This will 
generally be true in very efficient motors, but will always require some adjustment due to 
changes in volumetric efficiency.

To enable the rapid setup trim table, the rapid setup trim in the setup options settings panel 
must be enabled:

Throttle Derivative Trim

The 2D throttle derivative trim map is accessed when the 2D Engine Calibration map 
group is selected by selecting Map->Throttle derivative trim:

Throttle derivative trim map defines an instantaneous trim on the base fuel applied during a 
quick throttle transition. Unlike throttle and tip in enrichments, this trim can be negative as 
well as positive and it applies only while the throttle is in motion depending on how 
quickly it is moving. There is no decay on the throttle derivative trim and it disappears as 
suddenly as it appears.
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2D Boost Control

This section covers all of the 2D maps in the 2D Boost Control map group. This map 
group is accessed by selecting Map Group->2D Boost Control:

Boost Target

The 2D boost target map is accessed when the 2D Boost Control map group is selected by 
selecting Map->Boost target:

The boost target map can also be accessed by pressing the F7 key. This map allows a target 
boost to be selected based on engine speed. The Hydra Nemesis 2.6 unit can control boost 
on turbocharged motors if an appropriate boost control solenoid is connected to the system 
and the boost control parameters are properly calibrated. For more information regarding 
using the boost control system on your particular vehicle, contact your Hydra EMS dealer.

Boost Coolant Temperature Trim

The 2D boost coolant temperature trim map is accessed when the 2D Boost Control map 
group is selected by selecting Map->Boost trim [CTS]:
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The coolant boost trim map allows the boost target to be raised if positive values are 
indicated or lowered if negative values are indicated based on the coolant temperature. 
Generally, it is not a good idea to boost hard on a cold engine. The coolant boost trim can 
be used to bring down the target boost to the wastegate spring level until the engine has 
reached normal operating temperature. The measurement units settings on the preferences 
panel will determine whether the coolant temperature points will be shown in Celsius or 
Fahrenheit.

Boost Air Temperature Trim

The 2D boost air temperature trim map is accessed when the 2D Boost Control map group 
is selected by selecting Map->Boost trim [ATS]:

The air temperature boost trim map allows the boost target to be raised if positive values 
are indicated or lowered if negative values are indicated based on the air temperature. 
Generally, it is a good idea to bring down the target boost if the intercooler heat soaks and 
intake manifold air temperatures rise. The measurement units settings on the preferences 
panel will determine whether the air temperature points will be shown in Celsius or 
Fahrenheit.
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Boost Throttle Trim

The 2D boost throttle trim map is accessed when the 2D Boost Control map group is 
selected by selecting Map->Boost trim [TPS]:

The throttle trim map allows the boost target to be raised if positive values are indicated or 
lowered if negative values are indicated based on the throttle position. This can be used to 
set lower boost targets on part throttle settings.

Boost Upper Learn Limit

The 2D boost upper learn limit map is accessed when the 2D Boost Control map group is 
selected by selecting Map->Boost upper learn limit:

The boost upper learn limit map allows the feedback signal of the boost PID controller to 
be lowered at engine speeds that require less effort from the boost controller to maintain 
the target boost. This helps tone down the boost control system when the engine speed has 
surpassed the turbocharger’s boost threshold. When the driver makes a quick throttle 
opening beyond the boost threshold, boost climbs very quickly and there is little need for 
the boost controller to try to keep the wastegate completely closed to bring the boost up 
quickly as is the case below the boost threshold.
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Maximum Boost

The 2D maximum boost map is accessed when the 2D Boost Control map group is 
selected by selecting Map->Maximum boost:

The maximum boost map determines the intake manifold pressure at which overboost fuel 
cut initiates. If the manifold pressure exceeds the maximum boost indicated for the current 
engine speed, the injectors will be instantly closed and the motor will lose power for about 
a ¼ of a second. This can prevent engine damage if the system overboosts but only if the 
fuel and spark maps are set to give safe values at those load points and only if the fuel 
system can deliver sufficient fuel to keep the motor safe at those load points. For the 
purpose of boost control calibration, set the maximum boost values at least 3psi above the 
target boost values. The maximum boost settings cut fuel on overboost regardless of 
whether the Hydra Nemesis 2.6 unit is controlling the boost or some other mechanism is in 
place to do so.
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2D Idle Speed Control

This section covers all of the 2D maps in the 2D Idle Speed Control map group. This map 
group is accessed by selecting Map Group->2D Idle Speed Control:

Idle Speed Target

The 2D idle speed target map is accessed when the 2D Idle Speed Control map group is 
selected by selecting Map->Idle speed target:

The idle speed target map indicates the desired base idle speed depending on the coolant 
temperature sensor value. Usually, a cold engine will be allowed to idle a little higher to 
bring it up to operating temperature more quickly. The measurement units settings on the 
preferences panel will determine whether the coolant temperature points will be shown in 
Celsius or Fahrenheit.

Upper Learn Limit

The 2D upper learn limit map is accessed when the 2D Idle Speed Control map group is 
selected by selecting Map->Upper learn limit:
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The upper learn limit map sets the highest value that the idle PID controller can open the 
idle control motor to depending on the current coolant temperature sensor value. In some 
cases, it will be necessary to limit the maximum opening value of the idle control motor as 
the motor reaches operating temperature. The measurement units settings on the 
preferences panel will determine whether the coolant temperature points will be shown in 
Celsius or Fahrenheit.

When the motor is in operation and the laptop is connected to the Hydra Nemesis 2.6 unit, 
this map shows a marker indicating the current idle control learn position versus coolant 
temperature:

Lower Learn Limit

The 2D lower learn limit map is accessed when the 2D Idle Speed Control map group is 
selected by selecting Map->Lower learn limit:
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The lower learn limit map sets the lowest value that the idle PID controller can close the 
idle control motor to depending on the current coolant temperature sensor value. In some 
cases, it will be necessary to limit the minimum opening value of the idle control motor 
when the motor is cold. The measurement units settings on the preferences panel will 
determine whether the coolant temperature points will be shown in Celsius or Fahrenheit. 
When the motor is in operation and the laptop is connected to the Hydra Nemesis 2.6 unit, 
this map shows a marker indicating the current idle control learn position versus coolant 
temperature.

Air Conditioner On Upper Learn Limit

The 2D air conditioner on upper learn limit map is accessed when the 2D Idle Speed 
Control map group is selected by selecting Map->AC on upper learn limit:

The air conditioner on upper learn limit map sets the highest value that the idle PID 
controller can open the idle control motor to depending on the current coolant temperature 
sensor value when the A/C compressor is on. In some cases, it will be necessary to limit the 
maximum opening value of the idle control motor as the motor reaches operating 
temperature. The measurement units settings on the preferences panel will determine 
whether the coolant temperature points will be shown in Celsius or Fahrenheit. When the 
motor is in operation and the laptop is connected to the Hydra Nemesis 2.6 unit, this map 
shows a marker indicating the current idle control learn position versus coolant 
temperature.
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Air Conditioner On Lower Learn Limit

The 2D air conditioner on lower learn limit map is accessed when the 2D Idle Speed 
Control map group is selected by selecting Map->AC on lower learn limit:

The air conditioner on lower learn limit map sets the lowest value that the idle PID 
controller can close the idle control motor to depending on the current coolant temperature 
sensor value when the A/C compressor is on. In some cases, it will be necessary to limit the 
minimum opening value of the idle control motor when the motor is cold. The 
measurement units settings on the preferences panel will determine whether the coolant 
temperature points will be shown in Celsius or Fahrenheit. When the motor is in operation 
and the laptop is connected to the Hydra Nemesis 2.6 unit, this map shows a marker 
indicating the current idle control learn position versus coolant temperature.

ISC Ignition Trim

The 2D ISC ignition trim map is accessed when the 2D Idle Speed Control map group is 
selected by selecting Map->ISC ignition trim:

The ISC ignition trim map defines an adjustment to the base ignition timing calculation 
based on the current difference between the idle speed target and the actual idle speed. The 
ignition adjustment advances ignition timing if the value is positive and retards timing if 
the value is negative. A shallow, positive slope can be very useful in helping the motor 
better seek the desired idle speed target by adding some torque when the idle drops below 
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the idle target and lowering torque when engine speed rises above the idle target. In cases 
where no actual idle control motor is present, this map can still be used to help the motor 
stay at or near the desired idle speed target.

Air Conditioner On Trim

The 2D air conditioner on trim map is accessed when the 2D Idle Speed Control map 
group is selected by selecting Map->AC on trim:

The air conditioner on trim map indicates the additional engine speed added to the current 
idle speed target value when the A/C clutch request input is indicated based on the coolant 
temperature sensor value. This allows the idle speed target to be raised in conditions when 
the A/C compressor requires a slightly faster operating speed than normal idle allows. The 
measurement units settings on the preferences panel will determine whether the coolant 
temperature labels are shown in Celsius or Fahrenheit.

Power Steering Load Lower Learn Limit

The 2D power steering load lower learn limit map is accessed when the 2D Idle Speed 
Control map group is selected by selecting Map->PS LOAD Lower learn limit:

The power steering load lower learn limit map indicates the lowest value that the idle PID 
controller can close the idle control motor to depending on the current coolant temperature 
sensor value when the external power steering load request signal is active. In some cases, 
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it will be necessary to limit the minimum opening value of the idle control motor to raise 
idle under heavier load. The measurement units settings on the preferences panel will 
determine whether the coolant temperature points will be shown in Celsius or Fahrenheit. 
When the motor is in operation and the laptop is connected to the Hydra Nemesis 2.6 unit, 
this map shows a marker indicating the current idle control learn position versus coolant 
temperature.
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2D Starting

This section covers all of the 2D maps in the 2D Starting map group. This map group is 
accessed by selecting Map Group->2D Starting:

Post Start Enrichment

The 2D post start enrichment map is accessed when the 2D Starting map group is selected 
by selecting Map->Post start enrichment:

The post start enrichment map defines the initial fuel enrichment added to the base fuel 
values the moment engine speed rises above 250 RPMs. The coolant temperature value at 
the time engine speed rises above 250 RPMs will determine which point of the post start 
enrichment map will be used. The measurement units settings on the preferences panel will 
determine whether the coolant temperature points will be shown in Celsius or Fahrenheit. 
The post start enrichment value decays at the rate indicated by the post start enrichment 
decay map.
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Cranking Enrichment

The 2D cranking enrichment map is accessed when the 2D Starting map group is selected 
by selecting Map->Cranking enrichment:

The cranking enrichment map defines how much enrichment to add to the base fuel 
injection values while the engine is cranking. Normally, the engine will start with the base 
injection value indicated in the fuel maps in the zero vacuum, zero RPM cell. As the motor 
cranks, some vacuum and engine speed will be produced and new cells in the base fuel 
map will come into play. The cranking enrichment will take the current base fuel values 
and enrich them by the percentage indicated in the cranking enrichment map depending on 
the coolant temperature value. The measurement units settings on the preferences panel 
will determine whether the coolant temperature points will be shown in Celsius or 
Fahrenheit. The cranking enrichment value will apply constantly until the engine speed 
rises above 250 RPMs at which point the cranking enrichment will decay at the rate 
indicated by the cranking enrichment decay map and post start enrichment will begin.

Post Start Enrichment Decay

The 2D post start enrichment decay map is accessed when the 2D Starting map group is 
selected by selecting Map->Post start enrichment decay:

The post start enrichment decay map indicates how quickly the post start enrichment value 
decays over the 2000 cylinder events after post start enrichment starts. The map indicates 
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how much of the original post start enrichment is applied for the time intervals shown at 
2000 RPMs. The actual trim is based on cylinder cycles, so at 1000 RPMs, the decay 
would happen in twice the time indicated and at 4000 RPMs the decay would happen in 
half the time indicated.

Cranking Enrichment Decay

The 2D cranking enrichment decay map is accessed when the 2D Starting map group is 
selected by selecting Map->Cranking enrichment decay:

The cranking enrichment decay map indicates how quickly the cranking enrichment value 
decays over the 33 cylinder events after cranking enrichment ends. The map indicates how 
much of the original cranking enrichment is applied for the time intervals shown at 2000 
RPMs. The actual trim is based on cylinder cycles, so at 1000 RPMs, the decay would 
happen in twice the time indicated and at 4000 RPMs the decay would happen in half the 
time indicated.

Start Primer

The 2D start primer map is accessed when the 2D Starting map group is selected by 
selecting Map->Start primer:

The start primer map defines how long a pulse in milliseconds will be applied to the main 
injectors when the Hydra Nemesis 2.6 unit first detects the engine cranking. This initial 
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starting primer pulse douses the port or the manifold (depending on the placement of the 
injectors) in order to wet the area and so that condensation does not adsorb the first few 
cranking injection pulses. The start primer map references coolant temperature and allows 
for more fuel to be used to prime the engine on a cold versus a warm start. The 
measurement units settings on the preferences panel will determine whether the coolant 
temperature points will be shown in Celsius or Fahrenheit. Because this map indicates 
milliseconds some adjustment will likely need to be made when changing injector size.
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2D Closed Loop

This section covers all of the 2D maps in the 2D Closed Loop map group. This map group 
is accessed by selecting Map Group->2D Closed Loop:

Closed Loop Upper Throttle Position Limit

The 2D closed loop upper throttle position limit map is accessed when the 2D Closed 
Loop map group is selected by selecting Map->Closed loop upper tps limit:

The closed loop upper throttle position limit map determines the highest throttle position 
under which closed loop operation will be allowed based on current engine speed. Closed 
loop operation will stop at any point when the throttle position is above the indicated value 
for the current engine speed.

Closed Loop Lower Throttle Position Limit

The 2D closed loop lower throttle position limit map is accessed when the 2D Closed 
Loop map group is selected by selecting Map->Closed loop lower tps limit:
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The closed loop lower throttle position limit map determines the lowest throttle position 
under which closed loop operation will be allowed based on current engine speed. Closed 
loop operation will stop at any point when the throttle position is below the indicated value 
for the current engine speed.

Narrow Closed Loop Proportional Gain

The 2D narrow closed loop proportional gain map is accessed when the 2D Closed Loop 
map group is selected by selecting Map->Narrow closed loop P gain:

This map indicates the proportional term used by the narrowband closed loop PID 
controller to adjust the short term trim based on the position of the throttle. Narrowband 
closed loop operation is performed by a PID controller with the D term set to zero. Since 
the desired mode of operation for narrowband closed loop is a constant movement between 
a slightly rich and a slightly lean condition, the proportional value should be chosen to 
drive the narrowband controller into a slight amount of instability.

Narrow Closed Loop Integral Gain

The 2D narrow closed loop integral gain map is accessed when the 2D Closed Loop map 
group is selected by selecting Map->Narrow closed loop I gain:
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This map indicates the integral term used by the narrowband closed loop PID controller to 
adjust the short term trim based on the position of the throttle. Narrowband closed loop 
operation is performed by a PID controller with the D term set to zero. Since the desired 
mode of operation for narrowband closed loop is a constant movement between a slightly 
rich and a slightly lean condition, the integral value should be chosen to drive the 
narrowband controller into a slight amount of instability.

Wideband Closed Loop Proportional Gain

The 2D wideband closed loop proportional gain map is accessed when the 2D Closed 
Loop map group is selected by selecting Map->Wide closed loop P gain:

This map indicates the proportional term used by the wideband closed loop PID controller 
to adjust the short term trim based on the position of the throttle. Wideband closed loop 
operation is performed by a PID controller with the D term set to zero.

Wideband Closed Loop Integral Gain

The 2D wideband closed loop integral gain map is accessed when the 2D Closed Loop 
map group is selected by selecting Map->Wide closed loop I gain:
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This map indicates the integral term used by the wideband closed loop PID controller to 
adjust the short term trim based on the position of the throttle. Wideband closed loop 
operation is performed by a PID controller with the D term set to zero.

Start Delay

The 2D start delay map is accessed when the 2D Closed Loop map group is selected by 
selecting Map->Start delay:

The start delay map indicates how many engine cylinder cycles the closed loop system will 
wait to allow the O2 sensors time to warm up after engine start based on the coolant 
temperature sensor value at the time the engine started. A cylinder cycle on a 4-stroke 
engine is two crank revolutions, so a value of 1000 would indicate a delay of 2 minutes at 
1000 RPMs and 1 minute at 2000 RPMs. The measurement units settings on the 
preferences panel will determine whether the coolant temperature points will be shown in 
Celsius or Fahrenheit.

141



Hydra Nemesis 2.6 User’s Manual

2D Gear

This section covers all of the 2D maps in the 2D Gear map group. This map group is 
accessed by selecting Map Group->2D Gear:

Vehicle Speed To Engine Speed Ratio Target

The 2D vehicle speed to engine speed ratio target map is accessed when the 2D Gear map 
group is selected by selecting Map->VSS/RPM ratio target:

This map indicates the vehicle speed to engine speed ratio for each forward gear. To use 
this, the vehicle must have a vehicle speed sensor connected to the Hydra Nemesis 2.6 unit. 
The vehicle speed sensor must be properly calibrated before this map is adjusted. The 
values in this map must be adjusted to reflect the reading on the vehicle speed sensor when 
the car is in each gear and the engine speed is exactly 2000 RPMs. Only the first six cells 
of this map are used indicating first through sixth gear. When the motor is in operation and 
the laptop is connected to the Hydra Nemesis 2.6 unit, this map shows the current vehicle 
speed to engine speed ratio value so the process is as easy as changing the value of the cell 
corresponding to the current gear the vehicle is in so that it matches the indicated point:
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Gear Ignition Trim

The 2D gear ignition trim map is accessed when the 2D Gear map group is selected by 
selecting Map->Ignition trim:

The gear ignition trim map indicates how much timing to advance the base ignition timing 
if the value is positive or to retard the base ignition timing if the value is negative based on 
which gear the vehicle is in. This map should be set to zero until the vehicle speed to 
engine speed ratio map is properly adjusted. Only the first six cells of this map are used 
indicating first through sixth gear. This map can be used to reduce torque in lower gear on 
vehicles that are traction limited or to reduce timing to prevent knock when the engine is 
kept under sustained load in the higher gears.
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Gear Fuel Trim

The 2D gear ignition trim map is accessed when the 2D Gear map group is selected by 
selecting Map->Fuel trim:

The gear fuel trim map indicates the percentage of fuel to add to the base fuel calculation if 
the value is positive or to remove if the value is negative based on which gear the vehicle is 
in. This map should be set to zero until the vehicle speed to engine speed ratio map is 
properly adjusted. Only the first six cells of this map are used indicating first through sixth 
gear. This map can be used to prevent engine damage when the engine is kept under 
sustained load in the higher gears.

Gear Trim Lower Load Limit

The 2D gear trim lower load limit map is accessed when the 2D Gear map group is 
selected by selecting Map->Fuel trim lower load limit:

The gear trim lower load limit map indicates the load value in mmHg above which the 
ignition and fuel gear trims will be active for each gear. Below the gear trim limit, the 
ignition and fuel trims will not be applied. Only the first six cells of this map are used 
indicating first through sixth gear. This map is used to prevent gear ignition and fuel trims 
from affecting low load idling and cruising operation.

144



Hydra Nemesis 2.6 Users Manual

Traction Maximum Delta

The 2D traction maximum delta map is accessed when the 2D Gear map group is selected 
by selecting Map->Traction maximum delta:

The traction maximum delta map indicates the maximum vehicle speed increase allowed 
under each gear before the Hydra Nemesis 2.6 unit assumes that traction has been lost. For 
the traction control system to operate, the system vehicle speed sensor must read one of the 
driven wheels. This map cannot be adjusted until the vehicle speed to engine speed ratio 
map is properly adjusted. Only the first six cells of this map are used indicating first 
through sixth gear. The value in each cell indicates the maximum number of vehicle speed 
units that the vehicle can gain per second in each gear under full traction.

When the motor is in operation and the laptop is connected to the Hydra Nemesis 2.6 
system, this map shows a recent history of the vehicle speed delta values:

The history can facilitate the task of adjusting the maximum allowable vehicle speed delta 
per gear if the car is driven on a dry surface with very sticky tires so that no traction loss is 
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experienced. Once this is done, set the value just above the highest vehicle speed delta 
recorded in each gear.

Traction Ignition Cut Cycles

The 2D traction ignition cut cycles map is accessed when the 2D Gear map group is 
selected by selecting Map->Traction ignition cut cycles:

Once the traction maximum delta map is calibrated, any vehicle speed increase above the 
maximum for the current gear will cause the Hydra Nemesis 2.6 unit to cut ignition cycles 
as indicated by the traction ignition cut cycles map when the external traction control 
request is active. This map should be set to zero until the traction maximum delta map has 
been properly adjusted. This map indicates the percentage of ignition events that will be cut 
in each gear when the vehicle speed delta exceeds the maximum vehicle speed delta 
allowed in that gear. Only the first six cells of this map are used indicating first through 
sixth gear. Do not adjust this map unless you are fully aware of the consequences of cutting 
ignition cycles.

Traction Fuel Cut Cycles

The 2D traction fuel cut cycles map is accessed when the 2D Gear map group is selected 
by selecting Map->Traction fuel cut cycles:
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Once the traction maximum delta map is calibrated, any vehicle speed increase above the 
maximum for the current gear will cause the Hydra Nemesis 2.6 unit to cut fuel cycles as 
indicated by the traction fuel cut cycles map when the external traction control request is 
active. This map should be set to zero until the traction maximum delta map has been 
properly adjusted. This map indicates the percentage of injection events that will be cut in 
each gear when the vehicle speed delta exceeds the maximum vehicle speed delta allowed 
in that gear. Only the first six cells of this map are used indicating first through sixth gear. 
Do not adjust this map unless you are fully aware of the consequences of cutting injection 
cycles.

Gear Boost Trim

The 2D gear boost trim map is accessed when the 2D Gear map group is selected by 
selecting Map->Boost trim:

The gear boost trim map allows boost to be added if the value is positive or removed if the 
value is negative from the boost target based on the current gear selected. This map should 
be set to zero until the vehicle speed to engine speed ratio map is properly adjusted. Only 
the first six cells of this map are used indicating first through sixth gear. This feature is 
useful for lowering boost in lower gears on cars with limited traction or for lowering boost 
in high gear for setups expected to be under high load for long periods of time.
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2D PWM

This section covers the 2D maps in the 2D PWM map group. This map group is accessed 
by selecting Map Group->2D PWM:

There are eight 2D PWM maps, labeled PWM MAP1 through PWM MAP8. They can be 
accessed when the 2D PWM map group is selected by selecting Map->PWM MAP 1-8: 

PWM stands for Pulse Width Modulation. Every one of the configurable outputs on the 
Hydra Nemesis 2.6 unit can be assigned to one of the 2D PWM maps so that the duty cycle 
of the pulse is defined by the value in the PWM map.

A pulse width modulated signal has a base frequency. The Hydra Nemesis 2.6 unit can 
generate PWM signals in two different base frequencies, low frequency 30 Hz (cycles per 
second) and high frequency 800 Hz. The base frequency determines how many times per 
second the signal cycles through its on and off states. For the 30 Hz frequency, the signal 
will cycle every 33.3 milliseconds. For the 800 Hz frequency, the signal will cycle every 
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1.25 milliseconds. This is also known as the period of the frequency, which in seconds is 
always one divided by the frequency.

A PWM output signal is what is known as a square wave. A square wave cycles between 
being on and being off:

The PWM map defines the duty cycle of the PWM square wave:
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The duty cycle indicates the percentage of time that the square wave is on. A duty cycle of 
100%, means that the output stays on all the time. A duty cycle of 66% means that the 
output stays on for 66% of the period and then off for the remaining 34% of the period. A 
duty cycle of 50% means that the output is on for 50% of the period and off for the 
remaining 50% of the period. A duty cycle of 33% means that the output is on for 33% of 
the period and then off for the remaining 67% of the period. A duty cycle of 0% means that 
the output stays off all the time. Thus, by varying the desired duty cycle from 100% to 0% 
we can have the square wave stay on anywhere from the entire period to none of the period 
at all and every percentage in-between.

There are many useful things that can be done with a PWM output provided that the 
appropriate hardware is in place. The most common use of a PWM output is in controlling 
a solenoid. Solenoids can be used to control boost, water injection rates, nitrous, alcohol 
injection, oil pressure and air flow.

The 2D PWM maps allow the duty cycle of a PWM output to be varied based on the value 
of the x-axis variable selected for the PWM map. The x-axis variable for each 2D PWM 
map can be selected from the pwm axes settings panel. The appropriate labels 
corresponding to the variable selected as the x-axis will be shown in the 2D PWM map 
screen:

In this example, the controlling x-axis variable for the 2D PWM map is coolant 
temperature, therefore, the labels indicate temperature in the preferred units selected for 
temperature.

150



Hydra Nemesis 2.6 Users Manual

Comments

This section covers the comments map group. Every collection of maps and settings that 
can be saved in a file or in a Hydra Nemesis 2.6 unit can be annotated with comments that 
can be read at any time. The comments can contain anything that is of use to describe the 
maps and settings or explain particular details regarding them.

To access the comments panel, select Map Group->Comments:

This will open the comments panel:

This panel will let you add, remove or otherwise edit general comments. When you are 
finished editing the comments, select Comments->Save and exit to send the comments to 
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the Hydra Nemesis 2.6 unit. The software will also remind you that the comment will not 
be saved to a file until you do so using File->Save to file:

Once comments are added, the next time the comments panel is opened, it will show the 
version number of the laptop software under which the comments were last saved as well 
as the date and time the comments were saved:

To prevent the date and time from being updated, or if you do not wish to save any changes 
you made to the comments, select Comments->Exit without saving:
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Passwords

Passwords are an advanced feature provided to allow dealers and tuners to protect their 
intellectual property. It is not recommended that the password screen be accessed since it is 
possible to irretrievably lock out portions of your maps and settings.

Hydra EMS is not able to unlock any maps or settings intentionally or unintentionally 
locked out by a user, dealer or tuner with a password. Only by providing the original 
password used to lock out a map or setting can a locked map or setting be unlocked.

If a map or setting panel is password protected, the following message will appear when 
the map or setting panel is viewed:

The protected portions of the map or settings will not be displayed, but show up as blanks.

It is possible to reset a map or setting that is password protected, but doing so will return 
that map or setting to its default or zero state. If this is done, the reset portions of the map 
or settings will have to be completely re-programmed from scratch. The original password 
protected settings of the map or setting can not be accessed without knowing the password 
originally used to protect it.

To reset a password protected map or setting, select Map Group->Passwords:
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Then, click the RESET button for the map or setting that you wish to redo yourself from 
scratch:

Now that map or setting is set back to zeroes or to its default state and you must provide 
your own version.

Do not assign passwords or reset protected maps and settings unless you know exactly 
what you are doing.

Dealers, tuners and other individuals who wish to take advantage of the Hydra Nemesis 2.6 
password protection capabilities should contact Hydra EMS about signing up for the 
factory training course.
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3D PWM

This section covers the 3D maps in the 3D PWM map groups. These map groups are 
accessed by selecting Map Group->3D PWM 9-12:

There are four 3D PWM maps available, each with its own map group named 3D PWM 
9-12. A 3D map is almost identical in every way to a 2D map except that it has a y-axis 
variable in addition to an x-axis variable. All 3D PWM maps are 32 by 32 and the axes 
labels are shown when the map is selected just like the 2D PWM maps.

By adding a y-axis, the duty cycles of the output controlled by a 3D PWM map can vary 
based on the values of two variables instead of just one. This opens up additional 
capabilities beyond those provided by simpler 2D PWM map outputs. For example, if 
boost and engine speed are selected as the two axes variables, a water injection solenoid 
can be controlled so that flow increases based on both rising boost and increasing engine 
speed.
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Ignition Triggers

This section covers the ignition triggers logical group settings panel. To access this panel 
select Map Group->Settings 1:

Then select ignition triggers from the dropdown widget:

156



Hydra Nemesis 2.6 Users Manual

This will bring the ignition trigger logical group into the settings panel:

Trigger Active Edge

Trigger active edge indicates which edge of the square wave produced by the crank and 
cam signals the trigger code will sync relative to. These settings are defined as part of a 
trigger setup for a specific motor and should not be modified unless you are directed to by 
your Hydra EMS dealer.

The dropdown allows you to choose from all sixteen possible combinations of setting the 
crank and the cam to sync off the neither edge, the rising edge, the falling edge or both 
edges of the signal. OFF indicates neither edge, RISE indicates rising edge, FALL 
indicates falling edge, and ANY indicates either edge. The crank trigger edge setting is first 
followed by the cam trigger edge setting. Click the Enter button to the right of the 
dropdown when a new setting is selected.

Adjusting these settings can prevent the motor from starting. It may also allow the motor to 
start but change actual ignition timing so that it does not match the timing programmed into 
the timing advance maps. Do not adjust these settings without specific instructions to do so 
by a Hydra EMS dealer otherwise engine damage may result.

Trigger Type

Trigger type indicates which crank trigger style is installed on the motor. The Hydra 
Nemesis 2.6 unit has over two dozen crank trigger setups that it is pre-configured work 
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with. These settings are defined as part of a trigger setup for a specific motor and should 
not be modified unless you are directed to by your Hydra EMS dealer.

The dropdown allows you to choose from a list of possible crank trigger types. Click the 
Enter button to the right of the dropdown when a new setting is selected.

Adjusting this setting can prevent the motor from starting. It may also allow the motor to 
start but change actual ignition timing so that it does not match the timing programmed into 
the timing advance maps. Do not adjust these settings without specific instructions to do so 
by a Hydra EMS dealer otherwise engine damage may result.

Sync Type

Sync type indicates which cam trigger style is installed on the motor. The Hydra Nemesis 
2.6 unit has a dozen cam trigger setups that it is pre-configured work with. These settings 
are defined as part of a trigger setup for a specific motor and should not be modified unless 
you are directed to by your Hydra EMS dealer.

The dropdown allows you to choose from a list of possible cam trigger types. Click the 
Enter button to the right of the dropdown when a new setting is selected.

Adjusting this setting can prevent the motor from starting. It may also allow the motor to 
start but change actual ignition timing so that it does not match the timing programmed into 
the timing advance maps. Do not adjust these settings without specific instructions to do so 
by a Hydra EMS dealer otherwise engine damage may result.

Cylinders

Cylinders indicates the number of cylinders to control. In most cases it is exactly the same 
as the number of physical cylinders on the motor although in rare cases it may be half or 
double the number of physical cylinders. These settings are defined as part of a trigger 
setup for a specific motor and should not be modified unless you are directed to by your 
Hydra EMS dealer.

The edit box allows you to type in the number of cylinders to control. Click the Enter 
button to the right of the edit box when a new setting is selected.

Adjusting this setting can prevent the motor from starting. It may also allow the motor to 
start but change actual ignition timing so that it does not match the timing programmed into 
the timing advance maps. It may also have other, undesired damaging effects such as 
hydro-locking the motor or producing back-torque. Do not adjust these settings without 
specific instructions to do so by a Hydra EMS dealer otherwise engine damage may result.

Sequencer

Sequencer indicates which tooth on the cam signal the trigger will key on. This setting is 
defined as part of a trigger setup for a specific motor and should not be modified unless 
you are directed to by your Hydra EMS dealer.
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The edit box allows you to type in the sequencer value. Click the Enter button to the right 
of the edit box when a new setting is selected.

Adjusting this setting can prevent the motor from starting. It may also allow the motor to 
start but change actual ignition timing so that it does not match the timing programmed into 
the timing advance maps. It may also have other, undesired damaging effects such as 
hydro-locking the motor or producing back-torque. Do not adjust these settings without 
specific instructions to do so by a Hydra EMS dealer otherwise engine damage may result.

Timing Reference Angle

Timing reference angle indicates where TDC is assumed to be relative to the internal model 
of the trigger setup for the motor. This setting can be adjusted in most cases to allow the 
physical TDC mark to match with the internal Hydra Nemesis 2.6 unit’s TDC mark. On 
older motors with adjustable distributor bases, it is possible to match the physical ignition 
advance as measured with a timing light to the ignition advance value shown on the display 
window of the laptop software by adjusting the distributor position. On later model motors 
with no physical method to adjust the physical timing, you must adjust the timing reference 
angle so that the physical ignition advance measured with a timing light matches the 
ignition advance value shown on the display screen. To facilitate this process, it is 
recommended that the ignition advance map be modified around the idle region to a single 
timing advance value and that any ignition trim used to help maintain the idle target speed 
be zeroed. With the motor at normal operating temperature and a steady idle speed, attach 
an electronic timing light to the motor and validate using the timing marks on or near the 
crank pulley that the timing advance matches that shown in the display window. If the 
timing does not match, adjust the timing reference angle to bring the physical timing 
advance to the value shown on the display screen.

The edit box allows you to type in the timing reference angle. The value has a limited range 
that is acceptable depending on the trigger type selected. The range is adequate to bring the 
physical advance value to the displayed advance value if the motor is properly assembled. 
Click the Enter button to the right of the edit box when a new setting is selected.

VCTi Offset

VCTi offset indicates where the variable intake cam timing reference happens relative to 
the internal trigger position calculated by the Hydra Nemesis 2.6 unit based on the ignition 
trigger type selected. This setting is defined as part of a trigger setup for a specific motor 
and should not be modified unless you are directed to by your Hydra EMS dealer.

The edit box allows you to type in the offset value. Click the Enter button to the right of 
the edit box when a new setting is selected.

Adjusting this setting can prevent the motor from functioning properly. It may also have 
other, undesired damaging effects such as moving the cams to a position where the valves 
might catastrophically contact the top of the piston. Do not adjust these settings without 
specific instructions to do so by a Hydra EMS dealer otherwise engine damage may result.
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VCTe Offset

VCTe offset indicates where the variable exhaust cam timing reference happens relative to 
the internal trigger position calculated by the Hydra Nemesis 2.6 unit based on the ignition 
trigger type selected. This setting is defined as part of a trigger setup for a specific motor 
and should not be modified unless you are directed to by your Hydra EMS dealer.

The edit box allows you to type in the offset value. Click the Enter button to the right of 
the edit box when a new setting is selected.

Adjusting this setting can prevent the motor from functioning properly. It may also have 
other, undesired damaging effects such as moving the cams to a position where the valves 
might catastrophically contact the top of the piston. Do not adjust these settings without 
specific instructions to do so by a Hydra EMS dealer otherwise engine damage may result.

VCTi P-term

VCTi p-term indicates the proportional term of the PID controller that adjusts the variable 
intake signal so that the physical setting of the intake cam position closely tracks the 
desired target setting given in the Intake VCT Target 3D map.

The edit box allows you to type in the p-term value. Click the Enter button to the right of 
the edit box when a new setting is selected.

VCTi I-term

VCTi i-term indicates the integral term of the PID controller that adjusts the variable intake 
signal so that the physical setting of the intake cam position closely tracks the desired 
target setting given in the Intake VCT Target 3D map.

The edit box allows you to type in the i-term value. Click the Enter button to the right of 
the edit box when a new setting is selected.

VCTe P-term

VCTe p-term indicates the proportional term of the PID controller that adjusts the variable 
exhaust signal so that the physical setting of the exhaust cam position closely tracks the 
desired target setting given in the Exhaust VCT Target 3D map.

The edit box allows you to type in the p-term value. Click the Enter button to the right of 
the edit box when a new setting is selected.

VCTe I-term

VCTe i-term indicates the integral term of the PID controller that adjusts the variable 
exhaust signal so that the physical setting of the exhaust cam position closely tracks the 
desired target setting given in the Exhaust VCT Target 3D map.

160



Hydra Nemesis 2.6 Users Manual

The edit box allows you to type in the i-term value. Click the Enter button to the right of 
the edit box when a new setting is selected.
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Sensor Type and Calibration

This section covers the sensor type and calibration logical group settings panel. To access 
this panel select Map Group->Settings 1:

Then select sensor type and calibration from the dropdown widget:
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This will bring the sensor type and calibration logical group into the settings panel:

External AFR Zero Calibration

Ext. AFR zero calibration indicates the raw voltage point at which the linear 0-5 volt signal 
of the external wideband controller connected to the Hydra Nemesis 2.6 unit indicates a 
stoichiometric reading. Adjust this value when the external wideband is reading a 
stoichiometric signal, which is 14.7 gasoline AFR, so that the external AFR value 
displayed by the Nemesis shows 14.7 gasoline AFR. The external wideband must be 
connected to one of the four analog auxiliary inputs and the input must be configured to 
accept a linear 0-5 volt external wideband signal.

If the external AFR value displayed is greater than 14.7, reduce the Ext. AFR zero 
calibration value until the displayed value shows 14.7. If the external AFR value displayed 
is less than 14.7, increase the Ext. AFR zero calibration value until the displayed value 
shows 14.7. Click the Enter button to the right of the edit box when a new setting is 
selected.

External AFR Gradient Calibration

Ext. AFR gradient calibration indicates the raw voltage point at which the linear 0-5 volt 
signal of the external wideband controller connected to the Hydra Nemesis 2.6 unit 
indicates a free air reading. Adjust this value when the external wideband is reading a free 
air signal so that the external AFR value displayed indicates the same free air reading as the 
wideband controller display. The external wideband must be connected to one of the four 
analog auxiliary inputs and the input must be configured to accept a linear 0-5 volt external 
wideband signal.
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Always calibrate the Ext. AFR zero calibration value before adjusting the Ext. AFR 
gradient calibration value. If the external AFR value displayed is greater than the 
wideband reading, reduce the Ext. AFR gradient calibration value until the displayed 
value shows the same free air reading. If the external AFR value displayed is less than the 
wideband reading, increase the Ext. AFR zero calibration value until the displayed value 
shows the same free air reading. Click the Enter button to the right of the edit box when a 
new setting is selected.

External MAP Sensor Enable

External map sensor enable must be enabled for the Hydra Nemesis 2.6 unit to accept the 
manifold pressure signal from an external MAP sensor instead of the default internal MAP 
sensor. The external MAP sensor must be connected to one of the four analog auxiliary 
inputs and the input must be configured to accept an external MAP sensor signal.

If the box is unchecked, the internal MAP sensor will be enabled. If the box is checked and 
an analog auxiliary input is configured to accept an external MAP sensor signal, the 
external MAP sensor will be enabled. Click the Enter button to the right of the checkbox 
when a new setting is selected.

UEGO Zero Calibration

UEGO zero calibration indicates the stoichiometric point of the internal wideband 
controller. Adjust this value with the wideband O2 sensor unplugged from the wideband 
cable. If the AFR display indicates more than 14.7 AFR, increase the UEGO zero 
calibration value. If the AFR display indicates less than 14.7 AFR, reduce the UEGO zero 
calibration value. Click the Enter button to the right of the edit box when a new setting is 
selected.

UEGO Gradient Calibration

UEGO gradient calibration indicates the free air point of the internal wideband controller. 
Adjust the UEGO zero calibration value before adjusting this value. Pull the wideband O2 

sensor from the tailpipe and plug it into the wideband cable. Turn the ignition power on 
and allow several minutes for the sensor to heat up and reach operating temperature. If the 
AFR display indicates more than 21.5 AFR, reduce the UEGO gradient calibration value. 
If the AFR display indicates less than 21.5 AFR, increase the UEGO gradient calibration 
value. Use the smallest value that will display a constant 21.5 AFR. Click the Enter button 
to the right of the edit box when a new setting is selected.

CTS Type

CTS type indicates which type of coolant temperature sensor is connected to the Hydra 
Nemesis 2.6 unit. Note the coolant temperature value on the display window after the 
motor sits without running overnight. If the coolant temperature value is not within several 
degrees of the actual ambient temperature, the sensor type selected may be incorrect.
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Select the most appropriate coolant sensor type from the list available on the dropdown. 
Click the Enter button to the right of the dropdown when a new setting is selected.

Contact your Hydra EMS dealer if the coolant temperature reading on the display window 
is not within several degrees of the ambient temperature after the engine sits without 
running overnight. Choosing the improper sensor type for the coolant temperature sensor 
may cause the engine to run poorly and, in some cases, may cause severe engine damage.

ATS Type

ATS type indicates which type of air temperature sensor is connected to the Hydra Nemesis 
2.6 unit. Note the air temperature value on the display window after the motor sits without 
running overnight. If the air temperature value is not within several degrees of the actual 
ambient temperature, the sensor type selected may be incorrect.

Select the most appropriate air sensor type form the list available on the dropdown. Click 
the Enter button to the right of the dropdown when a new setting is selected.

Contact your Hydra EMS dealer if the air temperature reading on the display window is not 
within several degrees of the ambient temperature after the engine sits without running 
overnight. Choosing the improper sensor type for the air temperature sensor may cause the 
engine to run poorly and, in some cases, may cause severe engine damage.

Trigger Pull-Up Enable

Trigger pullup enable should be checked if the crank trigger sensor is a Hall effect type 
sensor. Otherwise, leave this box unchecked. Click the Enter button to the right of the 
checkbox when a new setting is selected.

Sync Pull-Up Enable

Sync pullup enable should be checked if the cam trigger sensor is a Hall effect type sensor. 
Otherwise, leave this box unchecked. Click the Enter button to the right of the checkbox 
when a new setting is selected.
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Idle Speed Control

This section covers the idle speed control logical group settings panel. To access this panel 
select Map Group->Settings 1:

Then select idle speed control from the dropdown widget:
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This will bring the idle speed control logical group into the settings panel:

Anti-lag ISC Position

Anti-lag ISC position indicates the position of the idle speed control valve will be forced to 
when anti-lag is requested. This is used to insure sufficient air enters the motor under anti-
lag to keep the turbocharger spooled. This must be used in conjunction with proper anti-lag 
fuel cut and ignition cut map values. Click the Enter button to the right of the edit box 
when a new setting is selected.

Moving Vehicle ISC Minimum

Moving vehicle ISC min indicates the minimum amount the idle control valve is allowed to 
close to when the vehicle speed sensor detects that the vehicle is still moving. This can be 
used to help bring the idle back to the desired point a little bit more smoothly as the car is 
braking. Click the Enter button to the right of the edit box when a new setting is selected.

ISC Maximum Duty

ISC max duty cycles is used to indicate the maximum duty cycle at which a 2-pin or 3-pin 
idle speed motor can be operated. This value, along with the ISC min duty value should 
generally be set to allow a physical range of at least 90% if not 100% full travel. It is 
recommended that this value be set at or near 100 to start with. Click the Enter button to 
the right of the edit box when a new setting is selected.

ISC Minimum Duty

ISC min duty cycles is used to indicate the minimum duty cycle at which a 2-pin or 3-pin 
idle speed motor can be operated. This value, along with the ISC min duty value should 
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generally be set to allow a physical range of at least 90% if not 100% of full travel. It is 
recommended that this value be set at or near zero to start with. If the ISC min duty value 
needs to be set high to keep the car from stalling, then the idle bypass screw should be 
opened further and the minimum value set lower, otherwise the idle control valve will not 
have sufficient range to provide the desired cold start and heavy accessory load idle targets. 
Click the Enter button to the right of the edit box when a new setting is selected.

ISC Maximum Vacuum

ISC max vacuum is used to keep the idle speed control valve closed while the vehicle is 
under full deceleration. This increases the feeling of engine braking under deceleration. 
This value is defined in mmHg regardless of the preferred units chosen. Set this value to 
the half-way point between normal idle vacuum and idle vacuum under full deceleration at 
4000 RPMs. Click the Enter button to the right of the edit box when a new setting is 
selected.

ISC Stepper Steps

ISC stepper steps indicates the number of idle control steps or detents available when a 4-
pin stepper motor valve is used. If this number is much smaller than the real number of 
steps available, the idle control motor will usually have too narrow a control range and will 
not be able to deliver the requested cold temperature or high load idle targets. If the number 
of steps is set much higher than the real number of steps available, the idle system may 
operate erratically and make large idle speed changes when only small ones are required. 
Click the Enter button to the right of the edit box when a new setting is selected.

ISC P-term

ISC P-term indicates the proportional term of the PID controller used to control idle speed. 
Set this value with ISC I-term and ISC D-term set to zero. Increase ISC P-term slowly 
until the point that idle becomes unstable. Set the final ISC P-term to a value about half of 
that at which idle becomes unstable. Click the Enter button to the right of the edit box 
when a new setting is selected.

ISC I-term

ISC I-term indicates the integral term of the PID controller used to control idle speed. Set 
this value after adjusting ISC P-term. If the idle speed does not move deliberately towards 
the target in the desired amount of time, increase ISC I-term gradually until the system 
moves as deliberately as desired. Click the Enter button to the right of the edit box when a 
new setting is selected.

ISC D-term

ISC D-term indicates the derivative term of the PID controller used to control idle speed. 
Set this value after adjusting ISC P-term and ISC I-term. If the idle experiences any 
instability after the ISC I-term is increased as needed, increase ISC D-term slightly to 
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reduce or eliminate the instability. Click the Enter button to the right of the edit box when 
a new setting is selected.

ISC AC Anticipate

ISC AC anticipate indicates how much more to open the idle control motor when an 
external air conditioner request is received. This allows the motor to start increasing speed 
just before the air conditioner clutch fully engages. Click the Enter button to the right of 
the edit box when a new setting is selected.
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Ignition and RPM Limits

This section covers the ignition and RPM limits logical group settings panel. To access this 
panel select Map Group->Settings 1:

Then select ignition and rpm limits from the dropdown widget:
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This will bring the ignition and RPM limits logical group into the settings panel:

Knock 1 Amplifier Enable

Knock 1 amplifier enable indicates if the raw knock sensor one signal requires additional 
amplification after it has been processed by the Hydra Nemesis 2.6 knock input circuit. 
This option should be enabled if the knock sensor voltage is very low even under high 
engine speed and load. To enable the amplifier, check the checkbox. To disable the 
amplifier, clear the checkbox. Click the Enter button to the right of the checkbox when a 
new setting is selected.

Knock 2 Amplifier Enable

Knock 2 amplifier enable indicates if the raw knock sensor two signal requires additional 
amplification after it has been processed by the Hydra Nemesis 2.6 knock input circuit. 
This option should be enabled if the knock sensor voltage is very low even under high 
engine speed and load. To enable the amplifier, check the checkbox. To disable the 
amplifier, clear the checkbox. Click the Enter button to the right of the checkbox when a 
new setting is selected.

Soft Rev Limit

Soft rev limit indicates the engine speed at which the soft rev limiter will start to take 
effect. The soft rev limiter begins to cut fuel events to reduce torque output and produce a 
“soft” limiting effect on engine speed. If Hard rpm limit is at or below Soft rev limit, no 
soft limiting will occur. Click the Enter button to the right of the edit box when a new 
setting is selected.

Maximum Knock Retard

Maximum knock retard indicates the maximum degrees of retard that the knock response 
system will apply when the knock signal value exceed the 2D Knock threshold map 
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settings. This value is needed to prevent too much ignition retard from potentially 
damaging the engine under a severe knock signal. Click the Enter button to the right of the 
edit box when a new setting is selected.

Moving Launch Enable

Moving launch enable allows the external launch request to remain active even when the 
vehicle speed sensor indicates that the vehicle is moving. If moving launch is not enabled, 
the external launch request is suppressed whenever the vehicle speed sensor indicates that 
the vehicle is in motion to prevent launch control from engaging between shifts when a 
clutch switch is used to trigger the external launch request. To allow launch request even 
when the vehicle is in motion, check this checkbox. Otherwise, clear this checkbox. Click 
the Enter button to the right of the checkbox when a new setting is selected.

Knock Retard Degrees Per

Knock retard degrees per indicates how many degrees of retard to apply to the current 
ignition advance value for every interval of time that the knock sensor voltage exceeds the 
2D Knock threshold map settings. Higher values will cause knock response to retard 
ignition advance more aggressively. Small values will result in a slower response to knock. 
A zero value will eliminate the immediate knock response feature of the Hydra Nemesis 
2.6 unit. Click the Enter button to the right of the edit box when a new setting is selected.

Waste Spark Enable

Waste spark enable activates the wasted spark ignition strategy in which a single double-
ended coil is used to supply spark to two cylinders. These cylinders are chosen so that they 
always arrive at TDC simultaneously, one at the end of the compression stroke and one at 
the end of the exhaust stroke. Both spark plugs fire simultaneously, but the cylinder at the 
end of the exhaust stroke has no compressed air fuel charge ready to light, so the spark is 
“wasted.” To select this strategy, check Waste spark enable. Enabling wasted spark on a 
single coil distributor motor will prevent the motor from working or cause it to run very 
poorly. Click the Enter button to the right of the checkbox when a new setting is selected.

Hard RPM Limit

Hard RPM limit indicates the engine speed at which all injection events will be cut, thus 
forcing the motor to stop producing torque and preventing it from spinning at a faster rate 
under its own power. Click the Enter button to the right of the edit box when a new setting 
is selected.

Excessive Knock Events

Excessive know events indicates the number of times that the knock voltage signal is 
allowed to go above the excessive knock threshold before the Hydra Nemesis 2.6 unit 
switches to the 3D backup ignition table. A small value will make the system more 
sensitive to excessive knock. A large value will make the system less sensitive to excessive 
knock. Click the Enter button to the right of the edit box when a new setting is selected.
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Excessive Knock Threshold

Excessive knock threshold indicates the raw knock sensor voltage above the knock 
threshold indicated in the 2D knock threshold map at which the knock signal is 
considered excessive. If the knock signal crosses above this threshold more than the 
number of times indicated by Excessive knock events, the Hydra Nemesis 2.6 unit will 
switch to the 3D backup ignition table. Click the Enter button to the right of the edit box 
when a new setting is selected.

Backup Spark Lean Error Enable

Backup spark lean error enable indicates whether the Hydra Nemesis 2.6 unit will switch to 
the 3D backup ignition table if the narrowband O2 signal stays lean for an extended period 
of time under normal closed loop operation. Check the checkbox to enable this feature. 
Clear the checkbox to disable this feature. Click the Enter button to the right of the 
checkbox when a new setting is selected.

Direct Fire Enable

Direct fire enable activates the direct fire ignition strategy in which a single coil is used per 
cylinder. To select this strategy, check Direct fire enable. Enabling direct fire on a single 
coil distributor or a wasted spark motor will prevent the motor from working or cause it to 
run very poorly. Click the Enter button to the right of the checkbox when a new setting is 
selected.

VCT Setup

VCT setup consists of eight radio button items that determine how variable cams are 
controlled. The first four radio button items allow the four VCT channels, two intake cam 
channels and two exhaust cam channels to be enabled and disabled. On a motor without 
VCT, all four VCT channels should be disabled. VCTi1 should be enabled if the motor has 
at least one variable intake cam. VCTi2 should also be enabled on V motors with variable 
intake cams on both banks. VCTe1 should be enabled if the motor has at least one variable 
exhaust cam. VCTe2 should also be enabled on V motors with variable exhaust cams on 
both banks. For each enabled channel, the output can be controlled via either a linear map 
that defines a PWM duty cycle based on the output of the PID controller for the type of 
cam controlled by the channel or the PWM duty cycle can be fine tuned through one of the 
3D PWM maps to handle a third variable such as coolant temperature (which is closely 
related to oil temperature) in cases where more accurate control of the cams is required. Do 
not change these settings or the settings of any of the 3D PWM maps assigned to control 
the VCT channels unless directed to by your Hydra EMS dealer. Changing the VCT setup 
configuration can cause the motor to run poorly in some cases and may even cause severe 
engine damage in extreme cases. Click the Enter button to the right of the radio button 
groups when a new setting is selected.
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VCT Multiplexer Enable

VCT multiplexer enable should be enabled on VCT motors that use more than just a single 
intake cam. Check the checkbox to enable the multiplexer. Clear the checkbox to disable 
the multiplexer. Do not change the VCT multiplexer enable setting unless directed to by 
your Hydra EMS dealer. Changing the VCT multiplexer enable configuration can cause the 
motor to run poorly in some cases and may even cause severe engine damage in extreme 
cases. Click the Enter button to the right of the checkbox when a new setting is selected.
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Closed Loop Control

This section covers the closed loop control logical group settings panel. To access this 
panel select Map Group->Settings 1:

Then select closed loop control from the dropdown widget:
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This will bring the closed loop control logical group into the settings panel:

Closed Loop Enable

Closed loop enable activates the closed loop fuel control modules. Check the checkbox to 
enable closed loop operation. Clear the checkbox to disable closed loop operation. Click 
the Enter button to the right of the checkbox when a new setting is selected.

Closed Loop Start Temperature

Closed loop start temp indicates the coolant temperature below which closed loop 
operation will be disabled. Some motors may need to run richer than the closed loop 
operating point until they reach a certain operating temperature. This value is given in 
Celsius regardless of the units indicated in the preferences panel. Click the Enter button to 
the right of the edit box when a new setting is selected.

Left Module Sensor Source

Left module sensor source indicates which sensor provides the input to the left closed loop 
module. The dropdown provides four different options. EGO Left selects the left 
narrowband sensor as the input source for the module and assumes stoichiometric AFR 
(14.7 gasoline) as the target AFR for closed loop. EGO Right selects the right narrowband 
sensor as the input source for the module and assumes stoichiometric AFR (14.7 gasoline) 
as the target AFR for closed loop. UEGO AFR selects the wideband controller as the input 
source for the module and assumes stoichiometric AFR (14.7 gasoline) as the target AFR 
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for closed loop. UEGO AFR TARGET selects the wideband controller as the input source 
for the module and selects the 3D AFR/Lambda  target table as the target AFR for closed 
loop control. Click the Enter button to the right of the dropdown when a new setting is 
selected.

Right Module Sensor Source

Right module sensor source indicates which sensor provides the input to the right closed 
loop module. The dropdown provides four different options. EGO Left selects the left 
narrowband sensor as the input source for the module and assumes stoichiometric AFR 
(14.7 gasoline) as the target AFR for closed loop. EGO Right selects the right narrowband 
sensor as the input source for the module and assumes stoichiometric AFR (14.7 gasoline) 
as the target AFR for closed loop. UEGO AFR selects the wideband controller as the input 
source for the module and assumes stoichiometric AFR (14.7 gasoline) as the target AFR 
for closed loop. UEGO AFR TARGET selects the wideband controller as the input source 
for the module and selects the 3D AFR/Lambda  target table as the target AFR for closed 
loop control. Click the Enter button to the right of the dropdown when a new setting is 
selected.

Long Term Trim Enable

LTT enable activates the long term learning feature. Under long term learning, an 
additional long term trim table is used to remember if the closed loop system is generally 
adding or subtracting fuel for each the various operating regions of the fuel map. The 
average short term trim values will be recorded and these will become the starting point for 
the closed loop modules as they enter each new region of the fuel table. Using the long 
term trim table makes the closed loop system more efficient when the base fuel table has 
been properly adjusted. To use the long term trim feature, check the checkbox. To disable 
the long term trim feature, clear the checkbox. Click the Enter button to the right of the 
checkbox when a new setting is selected.

Cylinder Bank

Cyl bank is a collection of eight radio buttons, each indicating which closed loop module, 
left or right, controls each cylinder on the motor. This must be properly configured 
particularly when a motor has one than one exhaust manifold and each manifold has a 
separate narrowband sensor.

The Hydra Nemesis 2.6 unit does not know the firing order of the engine. It will fire the 
injectors in order starting with 1 and going to the number of cylinders indicated in the 
Cylinders value on the ignition triggers logical group panel. The plug and play harness 
maps the Hydra Nemesis 2.6 cylinder number into the firing order. To assign the cylinders 
to the proper module controlled by the sensor affected by that cylinder, write down the 
engine’s firing order next to the Hydra Nemesis 2.6 firing order and then adjust the Hydra 
Nemesis 2.6 cylinder number corresponding to the physical cylinder number on the motor.

For example, if the engine firing order is 1-3-4-2:
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Physical Cylinder Hydra Nemesis 2.6 Cylinder

1 1

3 2

4 3

2 4

If physical cylinders 1 and 2 have their own exhaust manifold monitored by the left 
narrowband sensor assigned to the left module source, then Hydra Nemesis 2.6 cylinders 1 
and 4 should be assigned to the left module. If physical cylinders 3 and 4 have their own 
exhaust manifold monitored by the right narrowband sensor assigned to the right module 
source, then Hydra Nemesis 2.6 cylinders 2 and 3 should be assigned to the right module:

The Hydra Nemesis 2.6 cylinders that have no corresponding physical cylinders can be 
assigned to either module. Click the Enter button to the right of the radio buttons when a 
new setting is selected.
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PID Controls

This section covers the PID controls logical group settings panel. To access this panel 
select Map Group->Settings 1:

Then select PID controls from the dropdown widget:
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This will bring the closed loop control logical group into the settings panel:

Auxiliary Map Boost Trim

Aux map boost trim indicates how many pounds of boost will be added to, if the number is 
positive, or subtracted from, if the number is negative, the current base boost target value 
when the external auxiliary request is active. This allows a different boost level to be 
selected when the auxiliary fuel and ignition trim maps are active. The trim will raise the 
boost target if the value is positive or lower the boost value if the value is negative. The 
value shows pounds per square inch regardless of the units indicated in the preferences 
panel. Click the Enter button to the right of the edit box when a new setting is selected.

Input Follower P-term

Input follower P-term indicates the proportional term of the input follower PID controller. 
This controller can be used for many purposes, but most commonly it is used to adjust 
voltage on vehicles equipped with engine management controlled alternator voltage 
regulators to maintain proper charging voltage. Do not adjust this value unless directed to 
by a Hydra EMS dealer. In extreme cases, charging system failure or vehicle damage can 
result if this value is improperly adjusted. Click the Enter button to the right of the edit box 
when a new setting is selected.

Input Follower I-term

Input follower I-term indicates the integral term of the input follower PID controller. This 
controller can be used for many purposes, but most commonly it is used to adjust voltage 
on vehicles equipped with engine management controlled alternator voltage regulators to 
maintain proper charging voltage. Do not adjust this value unless directed to by a Hydra 
EMS dealer. In extreme cases, charging system failure or vehicle damage can result if this 
value is improperly adjusted. Click the Enter button to the right of the edit box when a new 
setting is selected.
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Boost Control D-term

Boost control D-term indicates the derivative term of the boost PID controller used to 
perform boost control. The PID controller compares the current boost target value to the 
actual manifold pressure value and produces the wastegate PID % value which can be 
assigned to a 2D PWM map used to control the duty cycle of a boost control solenoid. The 
wastegate PID % value will be high (in the 55-90% range) when the manifold pressure is 
much below the boost target, it will be medium (in the 45-55% range) when the manifold 
pressure is very close to the boost target and it will be low (in the 10-45% range) when the 
manifold pressure is much above the boost target. Click the Enter button to the right of the 
edit box when a new setting is selected.

Boost Control P-term

Boost control P-term indicates the proportional term of the boost PID controller used to 
perform boost control. The PID controller compares the current boost target value to the 
actual manifold pressure value and produces the wastegate PID % value which can be 
assigned to a 2D PWM map used to control the duty cycle of a boost control solenoid. The 
wastegate PID % value will be high (in the 55-90% range) when the manifold pressure is 
much below the boost target, it will be medium (in the 45-55% range) when the manifold 
pressure is very close to the boost target and it will be low (in the 10-45% range) when the 
manifold pressure is much above the boost target. Click the Enter button to the right of the 
edit box when a new setting is selected.

Boost Control I-term

Boost control I-term indicates the integral term of the boost PID controller used to perform 
boost control. The PID controller compares the current boost target value to the actual 
manifold pressure value and produces the wastegate PID % value which can be assigned 
to a 2D PWM map used to control the duty cycle of a boost control solenoid. The 
wastegate PID % value will be high (in the 55-90% range) when the manifold pressure is 
much below the boost target, it will be medium (in the 45-55% range) when the manifold 
pressure is very close to the boost target and it will be low (in the 10-45% range) when the 
manifold pressure is much above the boost target. Click the Enter button to the right of the 
edit box when a new setting is selected.
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Throttle Setup

This section covers the throttle setup logical group settings panel. To access this panel 
select Map Group->Settings 1:

Then select throttle setup from the dropdown widget:
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This will bring the throttle setup logical group into the settings panel:

Anti-lag Timeout

Anti-lag timeout indicates the maximum time in seconds that active anti-lag is permitted to 
run continuously. When an external anti-lag request is made, the anti-lag counter is reset 
and starts counting from zero seconds. From this time until the time the counter reaches the 
number of seconds indicated in Anti-lag timeout anti-lag ignition cut and anti-lag fuel cut 
events occur as indicated in the 3D Anti-lag active fuel cut cycles table and the 3D Anti-
lag ignition cut cycles table. After this point, fuel cut cycles will continue as long as the 
external anti-lag request is active as indicated by the 3D Anti-lag inactive fuel cut cycles 
table but all ignition cut events will stop. The anti-lag counter will not reset to zero until the 
external anti-lag request goes inactive. Click the Enter button to the right of the edit box 
when a new setting is selected.

Anti-lag Zero TPS Calibration

Anti-lag zero TPS calibration indicates the raw throttle position sensor voltage at or below 
which the throttle will be assumed to be fully closed when the external anti-lag request is 
active. It may differ from Zero TPS calibration if hardware is used to move the throttle 
stop point to increase the minimum amount of air entering the intake manifold during anti-
lag operation. If no special hardware exists, set this value to the Zero TPS calibration 
value. Otherwise, engage the anti-lag throttle stop mechanism and set the value to one or 
two above the value shown in the TPSM display at the bottom of the panel when the 
accelerator pedal is fully released:

Click the Enter button to the right of the edit box when a new setting is selected.
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Zero TPS Calibration

Zero TPS calibration indicates the raw throttle position sensor voltage at or below which 
the throttle is assumed to be fully closed under normal operation. Set this value to one or 
two above the value shown in the TPSM display at the bottom of the panel when the 
accelerator pedal is fully released:

Improperly setting this value may prevent idle control and deceleration fuel cut from 
operating properly. Click the Enter button to the right of the edit box when a new setting is 
selected.

Closed Pedal Calibration

Closed pedal calibration indicates the raw pedal position sensor voltage at or below which 
the accelerator pedal is assumed to be fully released. This value is used on drive-by-wire 
vehicles to determine when idle control must operate. Set this value to one or two above 
the value shown in the PPSM display at the bottom of the panel when the accelerator pedal 
is fully released:

Improperly setting this value may prevent idle control from operating properly. Click the 
Enter button to the right of the edit box when a new setting is selected.

100% TPS Calibration

100% TPS calibration indicates the raw throttle position sensor voltage at or above which 
the throttle is assumed to be wide open. Set this value to the value shown in the TPSM 
display at the bottom of the panel when the accelerator pedal is fully depressed:

Improperly setting this value may prevent the engine from starting. Click the Enter button 
to the right of the edit box when a new setting is selected.

TPS Pump Threshold

TPS pump threshold indicates how sensitive the Hydra Nemesis 2.6 unit is to throttle 
position changes in engaging the trims indicated in the 2D Throttle pump enrichment 
table. Smaller values make the system more sensitive to small throttle changes. Larger 
values make the system insensitive to small throttle changes. Typical values for most 
setups range from 30 to 40. Improperly setting the threshold can cause the engine to 
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hesitate and pop during throttle transitions. Click the Enter button to the right of the edit 
box when a new setting is selected.
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Injection

This section covers the injection logical group settings panel. To access this panel select 
Map Group->Settings 1:

Then select injection from the dropdown widget:
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This will bring the injection logical group into the settings panel:

Dynamic Enleanment Coefficient

Dynamic enleanment coefficient indicates how much fuel to trim from the base fueling 
value while engine speed is dropping. Fuel will be trimmed in proportion to how fast 
engine speed is dropping. Zero indicates that fuel will not be affected while engine speed is 
dropping. Larger values will remove more fuel while engine speed is dropping. Too large a 
value may cause the engine to idle poorly as AFR will be adversely affected during small 
idle speed corrections. Click the Enter button to the right of the edit box when a new 
setting is selected.

Deceleration Cut Enable

Decel cut enable indicates the status of deceleration fuel cut. Deceleration fuel cut will turn 
off the fuel injectors when the throttle is completely closed and engine speed is above the 
threshold indicated in the 2D Fuel cut lower limit table. This feature will save fuel and 
improve the feeling of engine braking. Check the checkbox to enable deceleration fuel cut. 
Clear the checkbox to disable deceleration fuel cut. Click the Enter button to the right of 
the checkbox when a new setting is selected.
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MAP Pump Threshold

MAP pump threshold indicates how sensitive the Hydra Nemesis 2.6 unit is to manifold 
boost pressure changes in engaging the trims indicated in the 2D Throttle pump 
enrichment table. Smaller values make the system more sensitive to small increases in 
boost. Larger values make the system insensitive to small increases in boost. Typical 
values for most setups range from 30 to 40. Improperly setting the threshold can cause the 
engine to hesitate during turbo spool-up. Click the Enter button to the right of the edit box 
when a new setting is selected.

Manifold Wetting Coefficient

Manifold wetting coefficient indicates how much fuel is lost to condensation against the 
port, runners and manifold. The value should generally be low for port injection and higher 
for throttle style injection setups. For standard port injection motors, a starting value of 40 
is appropriate. For throttle body injection setups, a starting value of 150 is suggested. The 
wetting coefficient affects how quickly throttle pump and tip in enrichments come on and 
decay. Click the Enter button to the right of the edit box when a new setting is selected.

Dynamic Enrichment Coefficient

Dynamic enrichment coefficient indicates how much fuel to add to the base fueling value 
while engine speed is rising. Fuel will be trimmed in proportion to how fast engine speed is 
rising. Zero indicates that fuel will not be affected while engine speed is rising. Larger 
values will add more fuel while engine speed is rising. Too large a value may cause the 
engine to idle poorly as AFR will be adversely affected during small idle speed corrections. 
Click the Enter button to the right of the edit box when a new setting is selected.

Injector Trims

Injector trims indicate the percentage of fuel to add if the trim value is positive or to 
remove if the trim value is negative from the base fueling for the specific cylinder 
indicated. This is sometimes needed in cases where air flow is slightly enhanced or 
restricted in a particular cylinder on a motor relative to the other cylinders.

The Hydra Nemesis 2.6 unit does not know the firing order of the engine. It will fire the 
injectors in order starting with 1 and going to the number of cylinders indicated in the 
Cylinders value on the ignition triggers logical group panel. The plug and play harness 
maps the Hydra Nemesis 2.6 cylinder number into firing order. To assign the trim value to 
the desired cylinder, write down the engine’s firing order next to the Hydra Nemesis 2.6 
firing order and then adjust the Hydra Nemesis 2.6 cylinder number corresponding to the 
physical cylinder number on the motor.

For example, if the engine firing order is 1-3-4-2:

Physical Cylinder Hydra Nemesis 2.6 Cylinder

1 1
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3 2

4 3

2 4

Thus, to add 1% more fuel to physical cylinder 3, set the value of Injector 2 trim to 1. 
Click the Enter button to the right of the edit box when a new setting is selected.

Staged Ratio

Staged ratio indicates the size of the staged injectors relative to the primary injectors in 
cases where staged fuel injectors are used. Set this value by calculating the primary injector 
flow divided by the secondary injector flow and multiply by one hundred. For example, if 
the primary injectors flow 440cc/min and the secondaries flow 550cc/min, you must enter 
(440 / 550) * 100 or 80. Click the Enter button to the right of the edit box when a new 
setting is selected.

Maximum Main Duty

Max main duty indicates the primary injector duty cycle in percent at which the Hydra 
Nemesis 2.6 unit will automatically switch over to the secondary injectors to provide more 
fuel flow. It is recommended that this value be set between 80-90. Click the Enter button 
to the right of the edit box when a new setting is selected.

Crank Cut Fuel TPS Limit

Crank cut fuel TPS limit indicates the percentage opening of the throttle above which fuel 
will not be injected during the cranking sequence. This value is useful to allow for a way to 
quickly clear a flooded engine by holding the throttle pedal down during cranking. It is 
recommended that this value be set between 85-95. Click the Enter button to the right of 
the edit box when a new setting is selected.

Minimum Pulse

Min pulse indicate the smallest injection pulse to use each injection event when the batch 
injection fuel strategy is used. The batch injection fuel strategy is used by default if the 
sequential fuel injection strategy is not enabled. In the batch injection strategy, two half-
length injection pulses are used every crank revolution to provide the full amount of the 
calculated fuel every two revolutions. When using large injectors, it may be impossible to 
meter out a small amount of fuel in two injection pulses. For this reason, if the calculated 
half-pulse pulse width becomes less than the minimum indicated pulse value, only one 
injection pulse will be used every two crank revolutions to deliver the required fuel. The 
minimum pulse value is used only under the batch injection strategy. Click the Enter 
button to the right of the edit box when a new setting is selected.
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Setup Options

This section covers the setup options logical group settings panel. To access this panel 
select Map Group->Settings 1:

Then select setup options from the dropdown widget:
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This will bring the setup options logical group into the settings panel:

Rapid Setup Trim Enable

Rapid setup trim enable indicates whether the values in the 2D Rapid setup trim table are 
applied to the fuel calculation. Check the checkbox to enable the Rapid setup trim table 
values. Clear the checkbox to disable the Rapid setup trim table values. Click the Enter 
button to the right of the checkbox when a new setting is selected.

Alpha-n Mixed Mode Enable

ALPHA-n mixed mode enable indicates whether the primary load signal will come from 
the manifold pressure sensor value or will be calculated from the 3D Programmed MAP 
and 3D TPS:MAP weight tables. Check the checkbox to operate in alpha-n mode. Clear 
the checkbox to operate in standard speed-density mode. Click the Enter button to the right 
of the checkbox when a new setting is selected.

Sequential Injection Enable

Sequential injection enable indicates whether the fueling strategy is sequential injection or 
batch injection. Check the checkbox to use the sequential injection strategy. Clear the 
checkbox to use the batch injection strategy. Click the Enter button to the right of the 
checkbox when a new setting is selected.
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Volumetric Efficiency Mode Enable

VE mode enable indicates whether the base fueling is calculated from the 3D Base fuel 
table or from the 3D VE table. Check the checkbox to calculate base fueling from the 3D 
VE table. Clear the checkbox to use the base injector pulse-widths indicated in the 3D 
Base fuel table. Click the Enter button to the right of the checkbox when a new setting is 
selected.

Injector Flow

Injector flow indicates the flow in cc/min of the primary injectors. To convert injectors 
whose rating is given in lbs/hr to cc/min, multiply the lbs/hr rating by 10.5. Be aware that 
most fuel injectors are rated for fuel flow at 300kPa (43.5psi) fuel pressure. If the base fuel 
pressure is set differently from the pressure the injector flow is rated for, the change in flow 
due to the base pressure difference must be determined and this the resultant flow must be 
indicated. This value is critical for proper operation when using VE mode. Click the Enter 
button to the right of the edit box when a new setting is selected.

Pump Primer Time

Pump primer time indicates how many seconds the fuel pump will be turned on when 
power is applied to the Hydra Nemesis 2.6 unit. This pressurizes the fuel system so that full 
fuel pressure will be available from the second the engine cranks. After the primer interval, 
the fuel pump will be switched on only when the engine is cranking or running. Click the 
Enter button to the right of the edit box when a new setting is selected.

Boost Control Threshold RPM

Boost control threshold RPM indicates the engine speed at which the boost PID controller 
starts to operate. If engine speed is below this value, the output of the PID controller will 
maintain the Wastegate PID (%) value at zero. Click the Enter button to the right of the 
edit box when a new setting is selected.

Stepper ISC Valve Enable

Stepper ISC valve enable indicates if the idle speed control motor is a four-pin stepper type 
motor. Check this checkbox if the idle motor is a four-pin stepper valve. Clear this 
checkbox otherwise. The Hydra Nemesis 2.6 unit must be ordered with the 4-pin stepper 
valve option to include the internal hardware configuration required to operate a 4-pin 
stepper valve motor. Contact your Hydra EMS dealer if you have a need to run a 4-pin 
stepper valve on a vehicle that normally does not come equipped from the factory with one. 
Click the Enter button to the right of the checkbox when a new setting is selected.

Cycle Cut Recovery Time

Cycle cut recover time indicates how much time in seconds will be required to transition 
from full 100% fuel and ignition cut to normal operation when anti-lag, launch control or 
flat shift modes are enabled. This recovery time allows for a smoother transition back to 
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normal operation. Click the Enter button to the right of the edit box when a new setting is 
selected.
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VSS & Gear Ratios

This section covers the vss & gear ratios logical group settings panel. To access this panel 
select Map Group->Settings 1:

Then select vss & gear ratios from the dropdown widget:
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This will bring the vss & gear ratios logical group into the settings panel:

VSS Input Calibration

VSS input cal indicates the conversion factor of the pulses produced by the vehicle speed 
sensor into the appropriate units used to indicate vehicle speed. If the vehicle is equipped 
with an appropriate vehicle speed sensor, adjust this value until the VSS value on the 
display window indicates the correct vehicle speed. If the displayed value is greater than 
the actual speed, reduce VSS input cal. If the displayed value is smaller than the actual 
speed, increase VSS input cal. VSS calibration must be performed before gear calibration 
and traction control calibration. Click the Enter button to the right of the edit box when a 
new setting is selected.
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Grid RPM Spread

This section covers the grid RPM spread logical group settings panel. To access this panel 
select Map Group->Settings 1:

Then select grid rpm spread from the dropdown widget:
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This will bring the grid rpm spread logical group into the settings panel:

RPM Spread

RPM spread indicates the difference between each engine speed point used to define the x-
axis of most of the 3D engine calibration maps. There are 32 monotonically increasing 
points that can be assigned to the RPM spread. The assignments are made by defining the 
31 ranges between the 32 points. Ranges are described as a number that is one-fifth the 
desired RPM difference between the two points. For example, a value of 10 defines 50 
RPMs and 100 defines 500 RPMs. The first point is fixed at 0 RPM. Click the Enter 
button to the right of the edit box when a new setting is selected.

In some cases, 32 points are more than is needed. In this case, a range of 255 can be 
specified following the last point desired. When this is done, the graph and grid 
representations of the maps will be shaded to represent which portions are used and which 
are not.

The RPM spread cannot be altered while the laptop software is connected to the Hydra 
Nemesis 2.6 unit. This is one of the few cases in which the change must be performed 
offline and the new settings explicitly saved to the unit.
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Grid Load Spread

This section covers the grid load spread logical group settings panel. To access this panel 
select Map Group->Settings 1:

Then select grid load spread from the dropdown widget:
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This will bring the grid load spread logical group into the settings panel:

Load spread indicates the difference between each load point used to define the y-axis of 
most of the 3D engine calibration maps. There are 32 monotonically increasing points that 
can be assigned to the load spread. The assignments are made by defining the 31 ranges 
between the 32 points. Ranges in the vacuum range are described as mm of mercury from 
the starting point of 760mmHg which is perfect vacuum. Once the load reaches the boost 
range, the value describes each 50th of a pound of boost. Click the Enter button to the right 
of the edit box when a new setting is selected.

In some cases, 32 points are more than is needed. In this case, a range of 255 can be 
specified following the last point desired. When this is done, the graph and grid 
representations of the maps will be shaded to represent which portions are used and which 
are not.

The load spread cannot be altered while the laptop software is connected to the Hydra 
Nemesis 2.6 unit. This is one of the few cases in which the change must be performed 
offline and the new settings explicitly saved to the unit.
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I/O Options

This section covers the I/O options logical group settings panel. To access this panel select 
Map Group->Settings 1:

Then select I/O options from the dropdown widget:
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This will bring the I/O options logical group into the settings panel:

PWM Frequency

PWM frequency indicates the base frequency used for each of the configurable output pins 
if that pin is assigned to a 2D or 3D PWM function. There are two sets of eight radio button 
pairs. For each configurable output pin, click on the 30 Hz radio button to select a low base 
frequency. Click on the 800 Hz radio button to select a high base frequency. Boost control 
solenoids need a low frequency setting to work properly. Idle control valves can often work 
with either frequency but tend to make audible noise unless they are operated at a high base 
frequency. Click the Enter button to the right of the group that the radio button belongs to 
when a new setting is selected.
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Output Configuration

This section covers the output configuration logical group settings panel. To access this 
panel select Map Group->Settings 1:

Then select output configuration from the dropdown widget:
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This will bring the output configuration logical group into the settings panel:

Output function

Output function indicates the function assigned to each of the configurable output pins on 
the Hydra Nemesis 2.6 unit. These include the eight injector outputs and the sixteen 
auxiliary output pins. Any of the injector outputs not required to drive an injector can be 
assigned to another function. Injector outputs are peak and hold outputs capable of sourcing 
high current for a short amount of time and then holding at a one amp maximum output 
current. The sixteen auxiliary output pins can source or sink up to about ½ amp of current. 
Never use an output to drive a high current device such as a fan motor directly. Doing so 
will destroy the output and void the warranty on the unit. When in doubt, always use a 
relay to switch current to a device. Small solenoids, relays and valves can be driven 
directly from an output.

Each vehicle plug and play harness and base map is configured to use several outputs for 
essential functions needed to properly run the supported configuration. Altering these 
essential output function can prevent the motor from starting or, in some cases, can cause 
severe engine damage. Do not alter the output configuration unless you understand which 
outputs you can use. For more information about your specific vehicle, contact your Hydra 
EMS dealer.

Before a configurable output can be used, it must be assigned a function to perform. This is 
done by setting the dropdown associated with each configurable output to the desired 
function. Click the Enter button to the right of the edit box when a new setting is selected.
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Injection

The injection function must be selected for the injector outputs that drive the primary 
injectors. This function is undefined if it is assigned to any output other than the injector 
outputs.

On

The on function forces the selected output to stay on. Use this to test new output 
configurations. Never assign this function to an output connected to an injector. Doing so 
may hydro-lock the motor causing severe damage.

Turbo Timer

The turbotimer function keeps the selected output on for the timer period indicated in the 
Turbo timer period item in the Setup options panel. This function can be used to keep 
the engine idling for a minimum specified time period to provide sufficient cooling time for 
a turbocharger.

Thermo Fan

The thermofan function keeps the selected output on when the coolant temperature is at or 
above the Thermofan on temp setting in the Air conditioner and fans panel. This 
function is often used to control an electric radiator fan.

Linear VCT

The linear VCT function is used to drive a variable cam control solenoid through the 
internal, fixed linear PWM function defined in the Hydra Nemesis 2.6 unit when the engine 
has a VCT setup and the linear VCT option is selected. This function can be used only on 
the configurable outputs that are internally configured to perform VCT control. These will 
be configured on the vehicle’s base map. Assigning this function to outputs not internally 
configured to perform VCT control is undefined.

Anti-Lag Valve

The anti-lag valve function keeps the selected output on when anti-lag is requested and the 
anti-lag timeout period has not expired. This can be used to operate a valve that flows more 
air into the intake or exhaust manifold during anti-lag operation.

Staged Injection

The staged injection function is selected for injector outputs used to drive staged injectors. 
This function can be used only on injectors outputs that are not used to drive the primary 
injectors. To use this function the Staged ratio and Max main duty values must be 
properly configured in the Injection panel.
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A/C Clutch

The AC clutch function is used to control an air conditioner clutch. The output will be on 
when an external AC request is active and the conditions required for AC compressor 
operation indicated in the Air conditioner and fans panel are met.

User

The user functions are used to define single or multiple condition functions that control the 
state of an output depending on the condition of internal and external variables. USER1 
through USER8 are single condition functions. USER9 through USER12 are double AND 
condition functions. USER13 through USER16 are dual OR condition functions. USER17 
and USER18 are quad AND condition functions. USER19 and USER20 are triple AND 
condition plus single OR condition functions. USER21 and USER22 are double AND 
condition plus double OR condition functions. USER23 and USER24 are quad OR 
condition functions. USER25 is a quad OR NOT condition function. USER26 is a quad 
AND NOT condition.

Pulse Width Modulation

The PWM functions are used to define a pulse width modulated output and assign the 
output to a specific 2D or 3D PWM map to determine the duty cycle of the PWM output. 
The base frequency of the output is determined by the setting indicated for the output pin 
that the PWM function is selected for on the I/O options panel. The PWM functions are 
only defined for the non-injector outputs.

Off

The off function keeps the output turned off. Use this to test new output configurations or 
to disable an output that is not required.

ISCO

The ISCO function is used to control a 2-pin idle control valve or the open side of a 3-pin 
idle control valve.

ISCC

The ISCC function is used to control the close side of a 3-pin idle control valve.

Fuel Pump

The fuel pump function is used to control a fuel pump. The output will be on to prime the 
fuel system when the Hydra Nemesis 2.6 unit is powered up and it will then stay off unless 
the motor is cranking or running. Never drive a fuel pump directly from an output pin. 
Connect the output to a relay that switches power to the fuel pump.
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Check Engine

The check engine function is used to control a small indicator light to indicate that the 
Hydra Nemesis 2.6 unit is powered up or that the backup ignition table is selected. The 
check engine output will be on when the engine is not running. The check engine output 
will switch on and off every second if the engine is running and the system has switched to 
the backup ignition table.

Pin Assignments

The outputs are assigned to the following pins on the Hydra Nemesis 2.6 unit connectors:

Name Pin Assignment Sources Comments

PWM1 A8 small blue ground Linear

PWM2 B7 small blue ground Linear

PWM3 A5 small blue ground Linear

PWM4 A9 small blue ground Linear

PWM5 B4 small grey power

PWM6 B3 small grey power

PWM8 A1 small blue power

PWM9 A2 small blue ground

PWM10 A3 small blue ground

PWM11 A4 small blue ground

PWM12 A11 small blue ground

PWM13 B6 small grey ground

PWM14 B5 small grey ground

PWM16 A6 small blue ground

PWM1 through PWM4 are linear outputs which are recommended for use in driving boost 
control solenoids and idle speed control valves. PWM5 through PWM8 source power 
instead of ground. PWM7 and PWM15 are reserved for future use. Do not attempt to 
source or sink more than ½ amp of current from any output pin. Doing so will damage the 
Hydra Nemesis 2.6 unit and void the warranty.
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User Logic (single, AND)

This section covers the user logic (single, AND) logical group settings panel. To access this 
panel select Map Group->Settings 1:

Then select user logic (single, AND) from the dropdown widget:
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This will bring the user logic (single, AND) logical group into the settings panel:

User Type

User type indicates the internal item or value that controls the condition. Select the type 
and comparison value from the user type dropdown. For every type, there is a greater than 
> or less than < comparison against the value chosen in the corresponding User variable 
field. Click the Enter button to the right of the dropdown when a new setting is selected. 
The types are as follows:

Type Description

coolant temp Coolant temperature sensor value in the preferred units

AFR/LMBD Internal wideband AFR reading in the preferred units

engine speed Current engine speed in RPM

tps Current throttle open position in percent

boost Intake manifold boost pressure in the preferred units

vehicle speed Vehicle speed in the units the VSS was calibrated

knock ramp Processed knock signal in volts

air temp Air temperature sensor value in the preferred units

duty cycle Injector duty cycle in percent

knock ret. Knock ignition retard in degrees
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wastegate PID Output of the boost control PID controller in percent

cell X X-axis column number of track cursor on main 3D maps

cell Y Y-axis column number of track cursor on main 3D maps

fuel pulse Final injector pulse width in milliseconds

vacuum Intake manifold vacuum pressure in the preferred units

advance Final ignition advance relative to TDC in degrees

O2 left Raw left narrowband sensor value in volts

O2 right Raw right narrowband sensor value in volts

baro External barometric sensor reading in the preferred units

aux n Raw auxiliary input value in volts

post start Current active post start fuel enrichment trim in percent

input follow Raw input follower value in volts

batt volts Voltage measured at the main positive power pin in volts

load Current load versus maximum measurable load in percent

load spread Current load relative to configured load spread in percent

rpm spread Current rpm relative to configured rpm spread in percent

stt left Current fuel trim produced by the left module in percent

vcti1 PID Output of first intake VCT PID controller in percent

vcti2 PID Output of second intake VCT PID controller in percent

vcte1 PID Output of first exhaust VCT PID controller in percent

vcte2 PID Output of second exhaust VCT PID controller in percent

raw tps Raw throttle position sensor value in 0 to 255 range

ext AFR/LMBD External wideband AFR reading in the preferred units

variable n Reserved for future expansion

User Variable

User variable completes the comparison indicated by the user type and condition . For 
example, if engine speed (rpm) > is chosen as the user type and 3800 is the indicated user 
variable, the condition will be true whenever engine speed is above 3800 RPM. Click the 
Enter button to the right of the edit box when a new value is selected.

Single User Logic Conditions

USER1 through USER8 are single user logic conditions. Any output assigned to one of 
these functions will be on when the single condition indicated by the User type and User 
variable selected for the user function is true. Otherwise, the output will be off.
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Dual AND User Logic Conditions

USER9 through USER12 are dual AND user logic conditions. They have two conditions, 
A and B. Any output assigned to one of these functions will be on when the conditions 
indicated by the User type and User variable items selected for the user function are both 
true. Otherwise the output will be off.

A condition B condition Output

false false off

false true off

true false off

true true on

210



Hydra Nemesis 2.6 Users Manual

PWM Axes

This section covers the PWM axes logical group settings panel. To access this panel select 
Map Group->Settings 1:

Then select pwm axes from the dropdown widget:
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This will bring the PWM axes logical group into the settings panel:

2D PWM Map Variable

The 2D PWM MAP n X-axis variable drop down indicates the variable used to determine 
which position of the 2D PWM map’s x-axis to access. Interpolation is used between the 
two closest labels on the actual x-axis to determine the final duty cycle. Click the Enter 
button to the right of the dropdown when a new setting is selected. The variables are as 
follows:

Variable Description

coolant temp Coolant temperature sensor value in the preferred units

AFR/LMBD Internal wideband AFR reading in the preferred units

engine speed Current engine speed in RPM

tps Current throttle open position in percent

boost Intake manifold boost pressure in the preferred units

vehicle speed Vehicle speed in the units the VSS was calibrated

knock ramp Processed knock signal in volts
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air temp Air temperature sensor value in the preferred units

duty cycle Injector duty cycle in percent

knock ret. Knock ignition retard in degrees

wastegate PID Output of the boost control PID controller in percent

cell X X-axis column number of track cursor on main 3D maps

cell Y Y-axis column number of track cursor on main 3D maps

fuel pulse Final injector pulse width in milliseconds

vacuum Intake manifold vacuum pressure in the preferred units

advance Final ignition advance relative to TDC in degrees

O2 left Raw left narrowband sensor value in volts

O2 right Raw right narrowband sensor value in volts

baro External barometric sensor reading in the preferred units

aux n Raw auxiliary input value in volts

post start Current active post start fuel enrichment trim in percent

input follow Raw input follower value in volts

batt volts Voltage measured at the main positive power pin in volts

load Current load versus maximum measurable load in percent

load spread Current load relative to configured load spread in percent

rpm spread Current rpm relative to configured rpm spread in percent

stt left Current fuel trim produced by the left module in percent

vcti1 PID Output of first intake VCT PID controller in percent

vcti2 PID Output of second intake VCT PID controller in percent

vcte1 PID Output of first exhaust VCT PID controller in percent

vcte2 PID Output of second exhaust VCT PID controller in percent

raw tps Raw throttle position sensor value in 0 to 255 range

ext AFR/LMBD External wideband AFR reading in the preferred units

variable n Reserved for future expansion

The appropriate labels corresponding to the variable selected as the x-axis will be shown in 
the 2D PWM map screen:

In this example, the x-axis variable for the 2D PWM map is coolant temperature, therefore, 
the labels indicate temperature in the preferred units for temperature.
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3D PWM Map Variable

The 3D PWM MAP n X-axis variable drop down indicates the variable used to determine 
which x-axis position of the 3D PWM map to access. The Y-axis variable drop down 
indicates which y-axis position of the 3D PWM map to access. Interpolation is used 
between the four closest labels on the actual x-axis and y-axis to determine the final duty 
cycle. Click the Enter button to the right of the dropdown when a new setting is selected. 
The variables available are identical to those available for the 2D PWM map x-axis 
selection.

The appropriate labels corresponding to the variables selected as the x-axis and y-axis will 
be shown in the 3D PWM map screen.
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Air Conditioner and Fans

This section covers the air conditioner and fans logical group settings panel. To access this 
panel select Map Group->Settings 1:

Then select air conditioner and fans from the dropdown widget:
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This will bring the air conditioner and fans logical group into the settings panel:

A/C RPM Limit

AC rpm limit indicates the engine speed above which the air conditioner clutch will not be 
engaged. If the indicated engine speed is exceeded, any output assigned to the AC 
CLUTCH function will be off. Click the Enter button to the right of the edit box when a 
new setting is selected.

A/C Throttle Position Sensor Limit

AC tps limit indicates the throttle position above which the air conditioner clutch will not 
be engaged. If the indicated throttle opening percent position is exceeded, any output 
assigned to the AC CLUTCH function will be off. Click the Enter button to the right of 
the edit box when a new setting is selected.

Thermofan On Temperature

Thermofan on temp indicates the coolant temperature in Celsius at which any output 
assigned to the THERMOFAN function will be switched on. The output will remain on 
until the coolant temperature drops below the indicated temperature. Click the Enter 
button to the right of the edit box when a new setting is selected.

A/C Return Delay

AC return delay indicates the minimum time interval in seconds during which the air 
conditioner clutch will remain off after it was last on. Many air conditioner systems require 
at least several seconds between compressor on cycles to prevent compressor damage. 
Click the Enter button to the right of the edit box when a new setting is selected.

216



Hydra Nemesis 2.6 Users Manual

User Logic (2xOR, 4xAND)

This section covers the user logic (2xOR, 4xAND) logical group settings panel. To access 
this panel select Map Group->Settings 2:

Then select user logic (2xOR, 4xAND) from the dropdown widget:
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This will bring the user logic (2xOR, 4xAND) logical group into the settings panel:

User Type

User type indicates the internal item or value that controls the condition. Select the type 
and comparison value from the user type dropdown. For every type, there is a greater than 
> or less than < comparison against the value chosen in the corresponding User variable 
field. Click the Enter button to the right of the dropdown when a new setting is selected. 
The types are as follows:

Type Description

coolant temp Coolant temperature sensor value in the preferred units

AFR/LMBD Internal wideband AFR reading in the preferred units

engine speed Current engine speed in RPM

tps Current throttle open position in percent

boost Intake manifold boost pressure in the preferred units

vehicle speed Vehicle speed in the units the VSS was calibrated

knock ramp Processed knock signal in volts

air temp Air temperature sensor value in the preferred units

duty cycle Injector duty cycle in percent

knock ret. Knock ignition retard in degrees
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wastegate PID Output of the boost control PID controller in percent

cell X X-axis column number of track cursor on main 3D maps

cell Y Y-axis column number of track cursor on main 3D maps

fuel pulse Final injector pulse width in milliseconds

vacuum Intake manifold vacuum pressure in the preferred units

advance Final ignition advance relative to TDC in degrees

O2 left Raw left narrowband sensor value in volts

O2 right Raw right narrowband sensor value in volts

baro External barometric sensor reading in the preferred units

aux n Raw auxiliary input value in volts

post start Current active post start fuel enrichment trim in percent

input follow Raw input follower value in volts

batt volts Voltage measured at the main positive power pin in volts

load Current load versus maximum measurable load in percent

load spread Current load relative to configured load spread in percent

rpm spread Current rpm relative to configured rpm spread in percent

stt left Current fuel trim produced by the left module in percent

vcti1 PID Output of first intake VCT PID controller in percent

vcti2 PID Output of second intake VCT PID controller in percent

vcte1 PID Output of first exhaust VCT PID controller in percent

vcte2 PID Output of second exhaust VCT PID controller in percent

raw tps Raw throttle position sensor value in 0 to 255 range

ext AFR/LMBD External wideband AFR reading in the preferred units

variable n Reserved for future expansion

User Variable

User variable completes the comparison indicated by the user type and condition . For 
example, if engine speed (rpm) > is chosen as the user type and 3800 is the indicated User 
variable, the condition will be true whenever engine speed is above 3800 RPM. Click the 
Enter button to the right of the edit box when a new value is selected.

Dual OR User Logic Conditions

USER13 through USER16 are dual OR user logic conditions. They have two conditions, A 
and B. Any output assigned to one of these functions will be on when either of the 
conditions indicated by the User type and User variable items selected for the user function 
are true. Otherwise the output will be off.
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A condition B condition Output

false false off

false true on

true false on

true true on

Quad AND User Logic Conditions

USER17 and USER18 are quad AND user logic conditions. They have four conditions, A, 
B, C and D. Any output assigned to one of these functions will be on when all of the 
conditions indicated by the User type and User variable items selected for the user function 
are true. Otherwise the output will be off.

A condition B condition C condition D condition Output

false false false false off

false false false true off

false false true false off

false false true true off

false true false false off

false true false true off

false true true false off

false true true true off

true false false false off

true false false true off

true false true false off

true false true true off

true true false false off

true true false true off

true true true false off

true true true true on
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User Logic (4xANDOR)

This section covers the user logic (4xANDOR) logical group settings panel. To access this 
panel select Map Group->Settings 2:

Then select user logic (4xANDOR) from the dropdown widget:
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This will bring the user logic (4xANDOR) logical group into the settings panel:

User Type

User type indicates the internal item or value that controls the condition. Select the type 
and comparison value from the user type dropdown. For every type, there is a greater than 
> or less than < comparison against the value chosen in the corresponding User variable 
field. Click the Enter button to the right of the dropdown when a new setting is selected. 
The types are as follows:

Type Description

coolant temp Coolant temperature sensor value in the preferred units

AFR/LMBD Internal wideband AFR reading in the preferred units

engine speed Current engine speed in RPM

tps Current throttle open position in percent

boost Intake manifold boost pressure in the preferred units

vehicle speed Vehicle speed in the units the VSS was calibrated

knock ramp Processed knock signal in volts

air temp Air temperature sensor value in the preferred units

duty cycle Injector duty cycle in percent

knock ret. Knock ignition retard in degrees
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wastegate PID Output of the boost control PID controller in percent

cell X X-axis column number of track cursor on main 3D maps

cell Y Y-axis column number of track cursor on main 3D maps

fuel pulse Final injector pulse width in milliseconds

vacuum Intake manifold vacuum pressure in the preferred units

advance Final ignition advance relative to TDC in degrees

O2 left Raw left narrowband sensor value in volts

O2 right Raw right narrowband sensor value in volts

baro External barometric sensor reading in the preferred units

aux n Raw auxiliary input value in volts

post start Current active post start fuel enrichment trim in percent

input follow Raw input follower value in volts

batt volts Voltage measured at the main positive power pin in volts

load Current load versus maximum measurable load in percent

load spread Current load relative to configured load spread in percent

rpm spread Current rpm relative to configured rpm spread in percent

stt left Current fuel trim produced by the left module in percent

vcti1 PID Output of first intake VCT PID controller in percent

vcti2 PID Output of second intake VCT PID controller in percent

vcte1 PID Output of first exhaust VCT PID controller in percent

vcte2 PID Output of second exhaust VCT PID controller in percent

raw tps Raw throttle position sensor value in 0 to 255 range

ext AFR/LMBD External wideband AFR reading in the preferred units

variable n Reserved for future expansion

User Variable

User variable completes the comparison indicated by the user type and condition . For 
example, if engine speed (rpm) > is chosen as the user type and 3800 is the indicated User 
variable, the condition will be true whenever engine speed is above 3800 RPM. Click the 
Enter button to the right of the edit box when a new value is selected.

Triple AND Single OR User Logic Conditions

USER19 and USER20 are triple AND, single OR user logic conditions. They have four 
conditions, A, B, C and D. Any output assigned to one of these functions will be on when 
either all of the AND conditions indicated by the User type and User variable items 
selected for the user function are true or if the single OR condition is true. Otherwise the 
output will be off.
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A condition B condition C condition D condition Output

false false false false off

false false false true on

false false true false off

false false true true on

false true false false off

false true false true on

false true true false off

false true true true on

true false false false off

true false false true on

true false true false off

true false true true on

true true false false off

true true false true on

true true true false on

true true true true on

Double AND Double OR User Logic Conditions

USER21 and USER22 are double AND, double OR user logic conditions. They have four 
conditions, A, B, C and D. Any output assigned to one of these functions will be on when 
either all of the AND conditions indicated by the User type and User variable items 
selected for the user function are true or if either of the OR conditions is true. Otherwise 
the output will be off.

A condition B condition C condition D condition Output

false false false false off

false false false true on

false false true false on

false false true true on

false true false false off

false true false true on

false true true false on

false true true true on

true false false false off

true false false true on
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true false true false off

true false true true on

true true false false on

true true false true on

true true true false on

true true true true on
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Auxiliary Input Configuration

This section covers the auxiliary input configuration logical group settings panel. To access 
this panel select Map Group->Settings 2:

Then select aux input configuration from the dropdown widget:
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This will bring the auxiliary input configuration logical group into the settings panel:

Input Configuration

AUX configuration indicates the function assigned to each of the auxiliary input pins on 
the Hydra Nemesis 2.6 unit. The system supports various external requests and inputs that 
can be connected to one of the input pins. The AUX configuration settings indicates how 
any input connected to the corresponding input pin will be treated by the system. In some 
cases, specific plug and play vehicle harnesses and base maps are configured to use 
specific inputs for essential vehicle functions. In such cases, altering the input 
configuration for the essential inputs may cause problems or even cause severe engine 
damage. Contact your Hydra EMS dealer before changing the configuration on any input. 
The input is configuring by selecting the desired function from the dropdown for the input. 
Click the Enter button to the right of the dropdown when a new setting is selected.

AC High

AC high indicates that the air conditioner clutch request will be active when the 
corresponding input pin is pulled high to battery voltage. This activates the A/C request 
which then enables any output whose function is set to AC CLUTCH if the conditions 
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indicated on the air conditioner and fans settings panel are met. It also switches the idle 
speed control system into A/C mode.

AC Low

AC low indicates that the air conditioner clutch request will be active when the 
corresponding input pin is pulled low to ground. This activates the A/C request which then 
enables any output whose function is set to AC CLUTCH if the conditions indicated on 
the air conditioner and fans settings panel are met. It also switches the idle speed control 
system into A/C mode.

Launch High

Launch high indicates that the launch request is active when the corresponding input pin is 
pulled high to battery voltage. This activates the launch fuel and ignition cycle cut maps.

Launch Low

Launch low indicates that the launch request is active when the corresponding input pin is 
pulled low to ground. This activates the launch fuel and ignition cycle cut maps.

Anti-Lag High

Anti-lag high indicates that the anti-lag request is active when the corresponding input pin 
is pulled high to battery voltage. This resets and starts the anti-lag timer and enables the 
anti-lag trim and cycle cut maps.

Anti-Lag Low

Anti-lag low indicates that the anti-lag request is active when the corresponding input pin is 
pulled low to ground. This resets and starts the anti-lag timer and enables the anti-lag trim 
and cycle cut maps.

Auxiliary High

Auxiliary maps high indicates that the auxiliary request is active when the corresponding 
input pin is pulled high to battery voltage. This enables the auxiliary trim maps and 
auxiliary boost trim.

Auxiliary Low

Auxiliary maps low indicates that the auxiliary request is active when the corresponding 
input pin is pulled low to ground. This enables the auxiliary trim maps and auxiliary boost 
trim.
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Input Follower

Input follower indicates that the input is connected to the drive-by-wire system and used to 
control the idle speed throttle setting. This is a special function that can only be used on 
specific inputs and only on systems configured with a drive-by-wire board.

Input Follower Feedback

Input follower feedback indicates that the input is used to provide a closed loop voltage 
regulator function required on some vehicles. This is a special function that can only be 
used on specific input and only on Hydra Nemesis 2.6 units configured with closed-loop 
voltage regulator circuitry.

Barometric GM 1 BAR

Baro GM 1 BAR indicates that the input is connected to a GM 1 BAR MAP sensor for use 
in performing barometric compensation in alpha-n fueling mode.

Barometric Honda

Baro Honda indicates that the input is connected to a Denso 1 BAR MAP sensor for use in 
performing barometric compensation in alpha-n fueling mode.

MAP GM 2 BAR

MAP GM 2 BAR indicates that the input is connected to a GM 2 BAR MAP sensor to 
provide a primary load signal. Additionally, the External map sensor enable checkbox in 
the sensors and calibration panel must be checked for the external sensor to supplant the 
internal MAP sensor.

MAP 5 BAR

MAP 5 BAR indicates that the input is connected to a Hydra 5 BAR MAP sensor to 
provide a primary load signal. Additionally, the External map sensor enable checkbox in 
the sensors and calibration panel must be checked for the external sensor to supplant the 
internal MAP sensor.

Valet High

Valet high indicates that the valet mode request is active when the corresponding input pin 
is pulled high to battery voltage. Valet mode severely limits the maximum engine speed 
and load allowed. Full injection and ignition cut will take place if any spirited driving is 
attempted.
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Valet Low

Valet low indicates that the valet mode request is active when the corresponding input pin 
is pulled low to ground. Valet mode severely limits the maximum engine speed and load 
allowed. Full injection and ignition cut will take place if any spirited driving is attempted.

Backup Ignition High

Backup ignition high indicates that the backup ignition mode request is active when the 
corresponding input pin is pulled high to battery voltage. The base ignition table will be 
ignored and the backup ignition table will provide the base ignition advance value.

Linear AFR

Linear AFR indicates that the output of a linear 0-5 volt wideband controller is connected 
to the corresponding input pin. This is required to feed an external wideband sensor into the 
Hydra Nemesis 2.6 unit for data logging. The signal will then need to be properly 
calibrated in the sensors and calibration panel.

Steer Load High

Steer load high indicates that the power steering load request is active when the 
corresponding input pin is pulled high to battery voltage. This can be used to configure the 
idle speed controller to increase idle speed in response to greater loads.

Steer Load Low

Steer load low indicates that the power steering load request is active when the 
corresponding input pin is pulled low to ground. This can be used to configure the idle 
speed controller to increase idle speed in response to greater loads.

Flat Shift High

Flat shift high indicates that the flat shift request is active when the corresponding input pin 
is pulled high to battery voltage. This will activate the flat shift fuel and ignition cut cycles.

Flat Shift Low

Flat shift low indicates that the flat shift request is active when the corresponding input pin 
is pulled low to ground. This will activate the flat shift fuel and ignition cut cycles.

Traction High

Traction high indicates that the traction request is active when the corresponding input pin 
is pulled high to battery voltage. This will activate the traction fuel and ignition cut cycles 
if vehicle speed delta surpasses the indicated threshold for each gear.
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Traction Low

Traction low indicates that the traction request is active when the corresponding input pin 
is pulled low to ground. This will activate the traction fuel and ignition cut cycles if vehicle 
speed delta surpasses the indicated threshold for each gear.

FH

FH indicates the function is reserved for future use.

FL

FL indicates the function is reserved for future use.

Off

Off indicates that the corresponding input pin has no internal function. The voltage value at 
the pin can still be used as a variable to control outputs, provide x-axis or y-axis values for 
the 2D and 3D PWM maps and for data logging.

Pin Assignments

The outputs are assigned to the following pins on the Hydra Nemesis 2.6 unit connectors:

Name Pin Assignment Unconnected State

AUX1 B3 small blue plug High

AUX2 B4 small blue plug High

AUX3 B1 small blue plug High

AUX4 C11 large blue plug High

AUX5 D13 large blue plug Low

AUX6 B12 small blue plug Low

AUX7 C6 large blue plug High

AUX8 C7 large blue plug High

AUX9 C8 large blue plug Low

AUX10 C9 large blue plug Low

AUX1 through AUX4 are analog inputs capable of recording raw analog voltages. These 
inputs must be used for external barometric sensors, MAP sensor and linear AFR inputs. 
The remaining inputs are suitable for digital high and low external switches only. AUX7 
through AUX10 are available as inputs only in systems not configured to control a 4-pin 
stepped motor idle control valve. AUX11 through AUX16 are reserved for future use. Each 
input has an internal resistor that pulls it high towards battery voltage or low towards 
ground when it is unconnected.
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Ignition Cylinder Trims

This section covers the ignition cylinder trims logical group settings panel. To access this 
panel select Map Group->Settings 2:

Then select ignition cyl trims from the dropdown widget:
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This will bring the ignition cylinder trims logical group into the settings panel:

Ignition Fire Trim

Ign fire trim indicates how many degrees the corresponding cylinder is advanced beyond 
the calculated ignition advance if the value is positive or retarded if the value is negative. 
This is sometimes needed if a particular cylinder will not accept as much ignition timing 
advance as the others.

The Hydra Nemesis 2.6 unit does not know the firing order of the engine. It will fire the 
coils in order starting with 1 and going to the number of cylinders indicated in the 
Cylinders value on the ignition triggers logical group panel. The plug and play harness 
maps the Hydra Nemesis 2.6 cylinder number into firing order. To assign the trim value to 
the desired cylinder, write down the engine’s firing order next to the Hydra Nemesis 2.6 
firing order and then adjust the Hydra Nemesis 2.6 cylinder number corresponding to the 
physical cylinder number on the motor.

For example, if the engine firing order is 1-3-4-2:

Physical Cylinder Hydra Nemesis 2.6 Cylinder

1 1

3 2

4 3

2 4

Thus, to add 1% more fuel to physical cylinder 3, set the value of Injector 2 trim to 1. 
Click the Enter button to the right of the edit box when a new setting is selected.
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Settings Tools

This section covers the tools menu item in the settings panel. To access this panel select 
Map Group->Settings 1:

The tools menu item is now available from the menu bar of the setting panel:

TPS/PPS Calibrate

The TPS/PPS settings tool facilitates the process of calibrating the throttle position and 
pedal position values in the throttle setup panel. To use the TPS/PPS calibration tools, 
select Tools->TPS/PPS calibrate:
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This will open the TPS/PPS calibration panel:

With your foot off the accelerator pedal, click the Calibrate zero TPS and Calibrate zero 
PPS buttons. Then, push the accelerator pedal as far as you are able to and, while holding it 
in that position, click the Calibrate wide open TPS button.

Load Spread Tool

The load spread settings tool facilitates the process of editing the grid load spread setting 
panel. Like the grid load spread panel, the load spread tool can only be used if the laptop 
software is not connected to the Hydra Nemesis 2.6 unit. To use the load spread tool, select 
Tools->Load spread tool:

If the Hydra Nemesis 2.6 unit is connected, a warning message show:
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Otherwise, the load spread tool panel will open:

The load spread tool automatically calculates the resulting load points in the pressure units 
selected in the preferences panel. Start with the first load spread point and adjust it until the 
first load point matches the desired load. Then, move on to the second load point. When 
you are finished, close the tool by clicking the X box on the top-right corner of the tool 
window:

The selected load spread values are now shown in the grid load spread panel. There is no 
need to click on the Enter buttons for the spread values that were changed.
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RPM Spread Tool

The RPM spread settings tool facilitates the process of editing the grid rpm spread setting 
panel. Like the grid rpm spread panel, the rpm spread tool can only be used if the laptop 
software is not connected to the Hydra Nemesis 2.6 unit. To use the rpm spread tool, select 
Tools->Rpm spread tool:

If the Hydra Nemesis 2.6 unit is not connected to the laptop software, the rpm spread tool 
panel will open:
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The rpm spread tool automatically calculates the resulting engine speed points. Start with 
the first Rpm spread point and adjust it until the first engine speed point matches the 
desired engine speed. Then, move on to the second engine speed point. When you are 
finished, close the tool by clicking the X box on the top-right corner of the tool window:

The selected Rpm spread values are now shown in the grid rpm spread panel. There is no 
need to click on the Enter buttons for the spread values that were changed.
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Edit

This section covers the functions accessed through the Edit menu item.

Select All

The Edit->Select all menu item can be used to select all of the cells in the current 2D or 
3D map:

This feature can be used to quickly apply an arithmetic function to an entire map. There are 
cases where this can be very useful. For example, if the fuel map is described in injector 
pulse width, it is relatively simple to quickly convert the base fuel table from one injector 
size to another. Press F3 to go to the base fuel table and select Edit->Select all to select all 
the cell in the fuel table:

Press M and multiply the entire fuel table by the ratio of the old injector size versus the 
new injector size. If the old injectors were 440cc/min and the new injectors are 550cc/min, 
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the multiplier is 440/550 or 0.8. Type 0.8 into the multiply by factor panel and click the 
enter button:

The base fuel table is now properly scaled to run with the new, larger injectors:
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Comms

This section covers the functions accessed through the Comms menu item.

Connect

Connect initiates communication between the laptop software and the Hydra Nemesis 2.6 
unit. If the laptop software is not connected to the unit, select Comms->Connect to initiate 
the connection:

Disconnect

Disconnect terminates communication between the laptop software and the Hydra Nemesis 
2.6 unit. If the laptop software is connected to the unit, select Comms->Disconnect to 
terminate the connection:

When communication between the laptop software and the Hydra Nemesis 2.6 unit is 
terminated, changes made to the maps and settings will not be sent to the system. This may 
cause the laptop and the Hydra Nemesis 2.6 unit to no longer be synched with each other. 
Nearly all editing changes can and should be made while the two systems are connected.

There are some cases were it will be necessary to disconnect from the Hydra Nemesis 2.6 
unit to make a drastic change. Editing the rpm or load grid panels is one such case. When 
this is required, it will be necessary to synch the Hydra Nemesis 2.6 unit back to the laptop 
software once the changes are made and communications are re-established.
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Preferences

This section covers the preference panel. To access the preferences panel, select Tools-
>System Tools->Preferences:

This will open the preferences panel:

Measurement Units

Measurement units indicate whether load, temperature and distance should be indicated in 
metric or imperial (English) units.

Grid Centering

Grid Centering indicates whether the map data window keeps the track point or the edit 
cursor visible. If load centering is selected, the track point will stay always visible in the 
map data window. If arrow is selected, the edit cursor will stay always visible in the map 
data window.
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Select Cell Mode

Select cell mode indicates if the edit cursor moves automatically with the current track 
point. If track is selected, the edit cursor automatically follows the track point. If hold is 
selected, the edit cursor moves only when the arrow keys are pressed.

Panel Mode

Panel Mode indicates whether the panel gauges in the display window are shown in analog 
or digital mode.

Auto Connect on Main Window

Auto Connect on Main Window indicates whether the laptop will automatically attempt to 
establish communications with a Hydra Nemesis 2.6 unit when the laptop software starts. If 
disabled, communications will not be established until Comms->Connect is selected.

Default COM Port

Default COM Port indicates which serial communication port is used to communicate with 
the Hydra Nemesis 2.6 unit. Only the first six ports are available for communication.

Hide Non-Critical Messages

Hide Non-Critical Messages indicates whether warning messages that are not very critical 
to the operation of the system should be displayed or kept hidden. This preference  should 
be enabled only by users who are very familiar with the system.

Rapid Logging

Rapid Logging indicates whether the data log sampling rate is fast or slow.

Default View

Default View indicates which of the three standard window arrangement schemes should 
be selected when the program starts and when View->Arrange preferred is selected.

Fuel Type

Fuel Type indicates what kind of fuel to display AFR values for. The options available are:

• GAS for standard gasoline AFR
• ETH for pure ethanol AFR
• MTH for pure methanol AFR
• E10 for standard gasoline with 10% ethanol AFR
• E85 for ethanol with 15% standard gasoline AFR
• LAMBDA for fuel-neutral lambda readings.
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Grid Load Direction

Grid Load Direction indicates whether load increases (up) or decreases (down) along the y-
axis of the main grid window.

VE Substring

VE Substring indicates what is displayed on the VE map if substrings are enabled. If 
AFRERROR is selected, the VE map will show how much of an increase or decrease the 
current track point requires to reach the desired AFR target. If MS is selected, the VE map 
will also indicate how many milliseconds of opening time correspond to the VE mode 
value for each cell.

Substrings

Substrings indicates if the feature suggesting how the much fuel needs to be adjusted on the 
fuel map or the VE map to reach the target AFR given the current wideband AFR reading 
is enabled. If disabled, no adjustment indication is given in these maps. This how the base 
fuel table appears with substrings enabled:

The inc x label indicates that the Hydra Nemesis 2.6 system recommends the cell be 
increased by x page up or + keystrokes. The dec x label indicates that the system 
recommends the cell be decreased by x page down or – keystrokes. For the substring 
feature to work, the target AFR/LAMBDA table must be properly set to indicate the true 
desired target AFR, the wideband O2 sensor must be connected and properly calibrated and 
the track point where the motor is operating must stay on a cell long enough for the system 
to get an accurate AFR reading to compare against the indicated target AFR.

COM Frequency

COM Frequency indicates the speed the laptop software will use to communicate with the 
Hydra Nemesis 2.6 unit. Selecting the fastest frequency may cause communication 
problems with some interfaces. If this happens, use the normal communication frequency.

Auto Sync

Auto sync indicates if the laptop software is allowed to take action if it determine that the 
software and the Hydra Nemesis 2.6 unit are out of sync because of a communications 
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error. If enabled, the auto sync feature will cause the laptop software to automatically sync 
up the base fuel and base ignition maps with the unit if a serial communications error takes 
place while editing. This feature is recommended only for very experienced users.

Auto Sync Method

Auto sync method indicates how the laptop auto syncs with the Hydra Nemesis 2.6 unit 
when a communication error occurs. If upload is selected, the laptop software reads the 
current configuration stored in the unit. If download is selected, the laptop sends the maps 
and settings in the laptop to the unit.

Saving Preferences

Click the Save and exit button to permanently save the current preferences setting:

Click the Ok button to apply the preferences only to the current laptop session:
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Communications Statistics

This section covers the communication statistics panel. To access the communication 
statistics panel, select Tools->System Tools->Com Stats:

This will open the communications statistics panel:

246



Hydra Nemesis 2.6 Users Manual

The communication statistics panel indicates how quickly the laptop software is able to 
communicate with the Hydra Nemesis 2.6 unit, which version of the firmware resides in 
the unit and if it is fully compatible with the current version of the laptop software you are 
using and what the yield of successful to unsuccessful communications messages is. If the 
yield is not above 95%, you are experiencing serious communications problems and the 
communications link between the laptop software and the Hydra Nemesis 2.6 unit is not 
very reliable.

Every failed attempt to send a message to the unit will be logged on the communications 
statistics screen with a time stamp. If the time stamps do not appear recent, click the Clear 
button on the bottom right corner of the panel to clear the failed message list:

If new failed attempt messages appear within a short period of time, the communications 
link is experiencing a problem.

To completely reset the statistics and start a new yield calculation, select Com stats-
>Reset stats:

To exit from the communications statistics panel, click the Exit button:

The laptop software will continue to collect failed messages and calculate the current yield 
value even when the panel is not open.
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Firmware Signature

This section covers the firmware signature panel. To access the firmware signature panel, 
select Tools->System Tools->Firmware version:

The laptop software will communicate with the Hydra Nemesis 2.6 unit and calculate the 
firmware signature of the current version of the firmware on the unit:

Depending on communications speed, it will take several seconds to half a minute to 
calculate the firmware signature. Once the calculation is complete, the firmware signature 
is displayed:

You will probably need to do this only in response to a request from your Hydra EMS 
dealer for your firmware signature. If so, write down all four numbers in the order they are 
shown and send this information back to your Hydra EMS dealer. Click on the box at the 
top right corner of the message box to close the firmware signature box:
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Colors

This section covers the colors panel which is used to define the colors to use in the map 
window. To access the colors panel, select Tools->Viewing Tools->Colors:

This will open the color selection panel:

Background color is the color of the graph’s background.

Wire Graph color is the color of the lines used to draw the graph.

RPM band color is the color used to draw the graph line representing the current engine 
speed range that the motor is operating at.

MAP band color is the color used to draw the graph line representing the current load range 
that the motor is operating at.

Keyboard trim band color is the color used to draw the graph lines representing the current 
location of the editing cursor. Note that this color is also used to highlight the cell 
representing the current editing cursor location on the spreadsheet representation of the 
selected map.

Highlight color is the color used to indicate which areas of the map are multiply selected.
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To change the color of any of the items listed on the panel, click the item and a color panel 
will appear to allow you to select the new color:

Click the Ok button to accept the new color or the Cancel button to keep the color for that 
item as it was. When all the color assignments are completed, press the Save button on the 
color selection panel to make the color selections permanent for future sessions of the 
laptop software or the Ok button to make the color selection only for the current session.

250



Hydra Nemesis 2.6 Users Manual

Clear Traces

This section covers the clear traces options which are used to clear the various cell 
indicators in the map data window. Traces are lingering indicators used on some 2D and 
3D maps to indicate something regarding the recent past.

Clear Visit Traces

As the track point moves, it leaves a trace of bolder cell values to indicate which cells of 
the map have been used:

This trace can be reset by selecting Tools->Viewing tools->Clear visit traces:

Clear Edit Traces

When editing changes are made to cells, the cell values are highlighted with brackets:
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These brackets can be reset by selecting Tools->Viewing tools->Clear edit traces:

Clear AFR Traces

If the substrings preference is enabled the Base fuel table and VE table are annotated with 
traces suggesting the amount of fuel to increase or decrease to produce the AFR indicated 
in the AFR target table:

These annotations can be reset by selecting Tools->Viewing tools->Clear AFR traces:

Clear Knock Traces

If the knock threshold is exceeded at any time while the base ignition map is selected, the 
cell closest to the point that knock is detected will be highlighted in red:
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These knock traces can be reset by selecting Tools->Viewing tools->Clear knock traces:

253



Hydra Nemesis 2.6 User’s Manual

Log Data

This section covers the log data panel which is used to perform data logging. To access the 
log data panel, select Tools->Tuning Tools->Log data:

This will open the log data panel:

Profiles

The log data panel allows up to sixteen separate variables to be logged at a sampling rate of 
roughly 16Hz for up to an hour. Before logging data, a profile must be either created using 
the profile setup widgets on the log data panel or loaded from a file holding a previously 
defined profile.
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To create a profile, select for each of the sixteen channels the variable to log for that 
channel. Select the variable for each channel using the dropdown containing the list of 
variables:

The variables that can be assigned to each channel are:

Variable Description

coolant temp Coolant temperature sensor value in the preferred units

AFR/LMBD Internal wideband AFR reading in the preferred units

engine speed Current engine speed in RPM

tps Current throttle open position in percent

boost Intake manifold boost pressure in the preferred units

vehicle speed Vehicle speed in the units the VSS was calibrated

knock ramp Processed knock signal in volts

air temp Air temperature sensor value in the preferred units

duty cycle Injector duty cycle in percent

knock ret. Knock ignition retard in degrees

wastegate PID Output of the boost control PID controller in percent

cell X X-axis column number of track cursor on main 3D maps

cell Y Y-axis column number of track cursor on main 3D maps

fuel pulse Final injector pulse width in milliseconds

vacuum Intake manifold vacuum pressure in the preferred units

advance Final ignition advance relative to TDC in degrees

O2 left Raw left narrowband sensor value in volts

O2 right Raw right narrowband sensor value in volts

baro External barometric sensor reading in the preferred units

aux n Raw auxiliary input value in volts

post start Current active post start fuel enrichment trim in percent

input follow Raw input follower value in volts

batt volts Voltage measured at the main positive power pin in volts
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load Current load versus maximum measurable load in percent

load spread Current load relative to configured load spread in percent

rpm spread Current rpm relative to configured rpm spread in percent

stt left Current fuel trim produced by the left module in percent

vcti1 PID Output of first intake VCT PID controller in percent

vcti2 PID Output of second intake VCT PID controller in percent

vcte1 PID Output of first exhaust VCT PID controller in percent

vcte2 PID Output of second exhaust VCT PID controller in percent

raw tps Raw throttle position sensor value in 0 to 255 range

ext AFR/LMBD External wideband AFR reading in the preferred units

variable n Reserved for future expansion

Each variable can also be plotted on the graph monitor on the logging screen. Under each 
dropdown there is a color selection tool to select which color to use to trace the channel 
value on the graph monitor:

Click on the right-facing arrow button to scroll through the colors available for the plot 
line. If no plot line is desired for a channel, click on the “none” button under the dropdown 
for the channel variable:

Once a profile is created, select File->Save profile to save the profile:
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This will open a file dialog box. Enter a name for the profile that you will be able to easily 
identify it by and click the Save button:

To avoid having to load a profile every time the laptop software is used to log data, it is a 
good idea to create a default profile. Select File->Save profile as default to make the 
current profile the default profile automatically loaded whenever the laptop software starts:

Select View->Show/hide setup to hide the profile setup widgets and make more room on 
the logging screen for the data grid. Select the same item again to bring the setup widgets 
back if you need to make changes to the profile again: 
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To use a profile created at an earlier time and saved, select File->Load profile:

This will open a file dialog box. Select the file containing the desired profile. The profile 
will be loaded from the file and the data buffer will be reset using the variables selected for 
each channel in the new profile:
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Data Collection

At the bottom of the logging screen, a progress bar will indicate how many minutes of the 
available hour have been logged and how many minutes remain:

At any time, the current logged data can be thrown away and the buffer cleared for another 
hour’s worth of data by clicking the Reset log buffer button:

To bring the data that has been collected in the logging buffer in the viewing grid, click the 
Populate grid button:

A progress bar will indicate the collection buffer is being moved to the display grid. Once 
complete, use the vertical and horizontal scroll bars to view the logged data in the grid:
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When logging is complete, the logging window can be exited by selecting the File->Exit 
menu item:

Logging is suspended when the logging window is dismissed, but the data buffer is not 
cleared and logging immediately resumes when the screen is re-entered.

Data Export

The data in the grid can be exported to a comma separated values file for examination at a 
later time or to allow other programs access to the data. Select File->Export CSV:

This will open a file dialog. Enter the name of the file that the data will be written to and 
click Ok to complete the export:
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Raw Logs

Select File->Export raw log to save the contents of the data buffer to an raw log file:

This will open a file dialog. Enter a name for the raw log file that will easily allow you to 
identify it later. Click the Save button to save the file:
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The File->Import raw log menu item to read the contents of a raw log file back into the 
viewing grid:

This will open a file dialog box. Select the raw log file to import and click Open:
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The laptop software must be disconnected from the Hydra Nemesis 2.6 unit in order to load 
a raw log file. Otherwise, the following message will be presented and the import will be 
cancelled:

The scroll bar on the grid buffer and the log fast forward and rewind buttons can then be 
used to play through the log and display it numerically and graphically in the grid:
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Learn Data

This section covers the learn data feature which is used to perform auto tuning. To access 
the learn data panel, select Tools->Tuning Tools->Learn data:

This feature is available only if the learn data function has been activated with a suitable 
software key purchased from your Hydra EMS dealer. This activation key is included in 
the cost of the O2 wideband option. If the learn data feature has not been activated, the 
menu item will be grayed out:

The learning function applies to the current 3D map selected. Most 3D maps do not have a 
learning feature. Selecting the learn data feature on any 3D or 2D map that does not have a 
learning mode produced the following message:

Currently, only the 3D VE table and 3D Programmed MAP table have a learning mode.

VE

If the learning feature is selected when the 3D VE table is selected, the laptop software will 
make adjustments to the VE table so that the target AFR value indicated by the target AFR 
table matches the O2 wideband sensor value:
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Auto tuning should be used only in a controlled environment and only after the VE map 
has been tuned enough that there are no large AFR holes or spikes. Otherwise, the car may 
behave very erratically as these holes are partially filled or removed by the auto tuning 
function. Also, it is very important that closed loop fuel adjustments be disabled while the 
auto tune tool is in use. Otherwise, very strange and erratic results may be obtained as the 
closed loop and auto tuning tool fight to control the target AFR.

When the auto tuning session is complete, click the Ok button to save the changes made to 
the VE table and exit the learning feature.

Programmed MAP

The learn data tuning tool can be used on this map to populate it with a real manifold 
pressure signal from the manifold pressure (MAP) sensor. Depending on the intake setup 
and aggressiveness of the cams, a large vacuum manifold may be required to produce a 
strong enough vacuum signal for learning. This manifold can then be removed or made 
much smaller after the learning is completed to provide a faster responding load signal for 
fuel and timing calculations.
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Open From UNIX Emailed File

This section covers the open from UNIX© emailed file feature which is used to open an 
s26 file that has been emailed through a mail program. To access this feature, select Tools-
>File Tools->Open from unix emailed file:

This will open a file open dialog:

Select the emailed file to open and click the Open button to open the file. Artifacts 
normally attached to the file when it is emailed will be automatically removed. This 
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process may not work in some cases and the most likely result is the following error 
message:

A more reliable way of sending maps and settings over email is to compress the file first 
send it to a compressed folder by right-clicking on the file in Windows© explorer:

Then right-click on the compressed (zip) folder and send it to the mailer:

This will prevent the mailer from corrupting the file in transit. The recipient will need to 
reverse the process by extracting the original file from the compressed folder and then 
opening it as a normal s26 file.
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Import Map Fragment

This section covers the import map fragment feature. To access the this feature, select 
Tools->File Tools->Import map fragment:

This will open the import file fragments dialog:
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This feature is available only when the laptop software is not connected to the Hydra 
Nemesis 2.6 unit. If the unit is connected to the laptop software, the import map fragment 
menu item will be grayed out:

Importing map fragments allows specific maps and settings from other files to be 
individually imported into the current maps and settings contained in the laptop software. It 
is also the only method to convert maps and settings from older Hydra Nemesis 2.1 and 2.5 
version files into the 2.6 system.

The first step in importing map fragments is to select the donor. Use the File menu item to 
select the appropriate donor file version:

If a version 2.6 file is selected, the open dialog box will allow you to open any s26 file 
from any storage device connected to the laptop. After selecting the desired donor file, 
click the Open button:
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The next step is selecting the maps and settings from the donor file to import into laptop. 
Click the [+] of the map group containing the map you wish to import:

This will expand the map group and show all of the maps belonging to that group:
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Double-click on any map or setting to add that item to the selected map fragments import 
list:

Continue the process until the all the desired maps and setting are added to the selected 
map fragments list. Double-clicking a second time on any selected map or setting will 
remove it from the selected map fragment list.

If all but one or two fragments are needed from a donor file, it is easier to click the Select 
All button to move all available maps and settings from the donor file and then double-
clicking just the fragments to not import. Click the Select none button to completely clear 
the selected map fragments list and start the selection process anew.

Click the Expand all button to expand all of the map groups in the selection panel. Click 
the Contract all button to contract all the groups back to their original display state.

When the selected map fragments list contains the maps and settings to import, click the 
Import list button and the selected maps and settings will be imported from the donor file.

If  a version 2.1 or 2.5 donor file is selected, the open dialog will allow you to open any s20 
file on any device connected to the laptop. If the Select All button is clicked when a version 
2.1 or 2.5 donor file is selected, the following message will appear:

Only the maps and setting available in the donor file will be added to the selected map 
fragments list. As with importing from a version 2.6 donor file, click the Import list button 
to import the older version maps and settings into the current laptop maps and settings. The 
maps and settings that do not exist in the earlier version donor files will be left untouched. 
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For this reason, it is essential to examine all the maps and settings after importing from an 
old version donor file and manually setting any maps and setting that may need attention. 
In particular, many items in the Settings 1 map groups do not transfer perfectly from older 
file versions and will be explicitly called out by the laptop software when the settings panel 
is selected. You will see several messages of the following nature when selecting Map 
Group->Settings 1 after importing an older version file:

Click Ok to continue through all the messages. Examine each setting panel looking for 
items highlighted in red:

All these items must be carefully checked, modified if required, and the Enter button 
associated with them must be clicked to un-highlight them.

Once the highlighted setting items are all verified, you can save the converted maps and 
settings to a version 2.6 file on the laptop and then re-establish a connection to the Hydra 
2.6 unit and save it to the ECU.
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Import Default Injector Response Map

This section covers the import default injector response map feature. To access the this 
feature, select Tools->File Tools->Import default injector response map:

This feature is available only when the laptop software is not connected to the Hydra 
Nemesis 2.6 unit. If the unit is connected to the laptop software, the import default injector 
response map menu item will be grayed out:

This feature allow the 2D Injector response map to be set up with a default starting 
calibration based on the known impedance of the injectors and any injector pack resistor 
present in the vehicle.

You will need an ohmmeter to determine the impedance of your injectors. Remove the clip 
from any one of your injectors and put the two probes from the ohmmeter against each of 
the pins on the injector. Write down the resistance value. If there is an injector resistor pack 
on the vehicle, unplug it and measure the resistance across one of the resistors in the pack. 
Add the resistor pack resistance to the injector resistance. This is the total effective 
impedance of the injector as seen by the Hydra Nemesis 2.6 unit.

From the import default map fragment panel, select the value that is closest to the total 
effective impedance measured and click the Load button:
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This will load the starting default injector response curve into the 2D Injector response 
map:

Once the default injector response curve is loaded, you can re-establish a connection to the 
Hydra 2.6 unit and save the new map to the ECU.
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Analyze Map

This section covers the analyze map feature. To access the this feature, select Tools->File 
Tools->Analyse map:

The analyze map feature will examine the current maps and setting in the laptop and make 
some basic evaluations regarding each of them. Any potential issues or items that deviate 
from the expected norm will be indicated in a series of messages such as the following:

It is a good idea to examine each map indicated by the messages. This feature is not 
intended to be a replacement for experience and good judgment. There will be cases where 
a properly calibrated map may produce a message. There will also be cases where poorly 
calibrated maps will not be called out.
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Ram Dump

This section covers the RAM dump feature. To access the this feature, select Tools-
>Analysis Tools->Ram dump:

This will open the analyze RAM dump panel:

This feature is intended specifically for analyzing and diagnosing vehicle to Hydra 
Nemesis 2.6 unit interaction issues. You should access this feature only under the guidance 
and direction of your Hydra EMS dealer.

Select Analyse->Exit to exit the analyze RAM dump panel:
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Migration Tools

This section covers the migration tools. These tools allow you to migrate a standard pulse 
width base fuel table to a VE table and vice-versa. These tools are only available when the 
laptop is not connected to the Hydra Nemesis 2.6 unit. Otherwise, the menu items to access 
these tools will be grayed out:

VE to Fuel Base Table

This feature allows a calibrated VE table to be migrated to the Base fuel table. The laptop 
software will calculate the resultant pulse width for very one of the 32 by 32 cells in the VE 
map based on the settings in the AFR/LAMBDA target table, Injector flow rate and 
Cylinder capacity.

To perform the conversion, select Tool->Migration tools->VE to Fuel Base Table:

The previous settings of the Base fuel table will be erased and replaced with the calculated 
pulse width values. If the Hydra Nemesis 2.6 unit was operating properly in VE mode, VE 
mode can be disabled and the unit will operate as before except the pulse width values will 
be taken from the base fuel table rather than calculated from the VE table.
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Fuel Base Table to VE

This feature allows a Base fuel table to be migrated to the VE table. The laptop software 
will calculate the VE corresponding to the indicated pulse width for very one of the 32 by 
32 cells in the Base fuel table provided the AFR/LAMBDA target table, Injector flow 
rate and Cylinder capacity reflect the proper operating condition of the motor.

To perform the conversion, select Tool->Migration tools->Fuel Base Table to VE:

This migration process is required if the Hydra Nemesis 2.6 unit is running in pulse width 
mode and the auto tuning process is needed. Since the auto tune process works only on the 
VE table, migration from and after the auto tuning process migration back to the Base fuel 
table is required. The migration process is also very useful if you are curious to determine 
what the real VE of the motor is even when the tuning has been done in pulse width mode. 
Remember that to get an accurate picture of the real volumetric efficiency of the motor, it is 
essential that the AFR/LAMBDA target table, Injector flow rate and Cylinder capacity 
reflect the actual operating condition of the motor.
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Activate Feature

This section covers the activate feature tool. The only optional feature on the laptop 
software is the enablement of the learn data feature which is used for auto tuning the VE 
table. The price of this feature is included with the wideband O2 option or it can be 
purchased separately from your Hydra EMS dealer. The activation of the learn data feature 
applies to the laptop that the laptop software is installed on. Once activated, the feature can 
be used on that laptop regardless of which Hydra Nemesis 2.6 unit it is connected to.

To use the activate feature, select Tools->Activate Feature->Learn Data:

This will open the activate feature panel:

Write down the number indicated in the Machine ID box exactly and email it to your Hydra 
EMS dealer for the Feature Activation Key. Click Cancel to exit the panel until the Feature 
Activation Key is obtained.
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When the Feature Activation Key is emailed to you for your laptop, go back into the 
activate feature panel, enter the Feature Activation Key exactly as it is given to you into the 
Feature Activation Key edit box and click the Ok button:

If the Feature Activation Key is entered incorrectly, the following message will appear:

Press the Ok button, re-enter your Feature Activation Key properly and try again.

If the Feature Activation Key is correct for your laptop, it will be accepted and the Tuning 
Tools->Learn data menu item will no longer be grayed out:
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Arrange

This section covers the default main windows arrangement feature. There are three default 
arrangements of the five main windows that can be selected using the View->Arrange A, 
View->Arrange B  and View->Arrange C menu items:

The default preferred arrangement can also be set up on the preferences panel accessed by 
selecting the Tools->System Tools->Preferences menu item. Select the radio button 
corresponding to your preferred arrangement for the DEFAULT VIEW item:

Click the Save and exit button:

The laptop software will always start with your preferred arrangement. Also, the View-
>Arrange preferred menu item will arrange the windows to the preferred arrangement:
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Inputs

This section covers the inputs status window feature. This feature can be accessed by 
selecting View->Inputs:

This will open the inputs status window:
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The inputs status window has three sections. The leftmost section shows the current digital 
status of each auxiliary input, which is going to be either high or low. AUX11 through 
AUX16 are reserved for future use even though they do not physically exist.

The middle section indicates for each request type if that request type is in use, which 
means that it is assigned to at least one auxiliary input.

The rightmost section indicates for each request type if that type is active. This is very 
useful in case where you wish to verify the status of a particular request. For example, if 
you set up an auxiliary input to a switch to perform a launch request, this section will easily 
allow you to verify that the request is active at the appropriate time.
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Fuel Multipliers

This section covers the fuel multipliers window feature. This feature can be accessed by 
selecting View->Fuel Multipliers:

This opens the fuel multipliers window:

The fuel multipliers window shows the fuel trim values from all of the fuel trim and 
enrichment maps. The indexed fuel value indicates the base fuel interpolated from the Base 
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fuel table or calculated from the VE table depending on the operational fueling mode 
selected. The corrected fuel value indicates the final calculated injection pulse value after 
all of the fuel trims are applied. This window is very useful for determining which fuel 
trims are currently having an effect on the final injector pulse width values.
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Long Term Trim Table

This section covers the long term trim table. This table can be accessed by selecting View-
>LTT table:

This opens the long term trim table:

The long term trim table indicates the current state of the long term learning feature of the 
closed loop fuel adjustment mechanism. The long term trim table is used to remember if 
the closed loop system is generally adding or subtracting fuel for each the various operating 
regions of the fuel map. The average short term trim values will be recorded and these will 
become the starting point for the closed loop modules as they enter each new region of the 
fuel table. Using the long term trim table makes the closed loop system more efficient 
when the base fuel table has been properly adjusted. If the long term trim feature is 
enabled, this table will show the long term trim adjustments calculated as the closed loop 
system operates.

It is possible to clear the long term trim table so that the long term trim values are all reset 
back to zero. To clear the long term trim table, select LTT->Clear LTT:
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To exit from the long term trim table, select LTT->Exit:
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Help

This section covers the help menu items.

This Map

On every 2D and 3D map, you can select Help->This map to bring up a short information 
panel describing the purpose of the currently selected map:

This will bring up an appropriate message panel:

Click the Ok button to continue.

Tuning this map

On every 2D and 3D map, you can select Help->Tuning this map to bring up an 
information panel providing hints about how to adjust the values on the map for best effect:

This will bring up an appropriate message panel:

289



Hydra Nemesis 2.6 User’s Manual

Click the Ok button to continue.

Hotkeys

The Help->Hotkeys menu item will bring up a panel listing all the navigation and editing 
key functions:

This will open the hotkeys panel:
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Click on the box at the top right corner of the screen to continue:

Diagrams

The Help->Diagrams feature is not yet implemented:

About

The Help->About menu item will bring up a panel indicating the version of the laptop 
software:

Will open this window:

Click the Ok button to continue.
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