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Preface 
This manual describes the usage of the STEP Assembly Manager (SAM). It contains the 
description how to store, modify and manage CATIA models and assembly structures and 
to exchange them via STEP. 

 

About this Manual 

This manual is intended for end users of the STEP Assembly Manager (SAM).  

 

Related Documents 

The following manuals contain information about installation and administration of the 
STEP Assembly Manager (SAM):  
 
Manual Title Version 

STEP Assembly Manager Installation and Administration Guide 5.8 
 

Organization 

This manual contains the following chapters: 

Chapter 1 gives an overview about SAM. 

Chapter 2 explains the menu items of the SAM PDM GUI and describes how to handle 
assembly structures and to exchange them via STEP. 

Chapter 3 explains the menu items of the SAM CATIA V4 function and describes how to 
modify the position of sub-assemblies. 

Chapter 4 explains the SAM CATIA V5 module. 

Glossary explains the terminology used in the context of SAM. 
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Conventions Used in this Manual 

This font  Is used for document titles and emphasis. 

 

Item 1 > Item 2 Is used to describe the menu path to reach a specific function 

 

 

This icon is used to identify tips and attention advises. 

 

 

This icon is used to identify CATIA related sections and actions. 

 

 

This icon is used to identify CATIA V5 related sections and actions. 

 

 
This icon is used to identify actions that need confirmation. 
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CHAPTER 1 

Overview 

SAM is an application that handles assembly data contained in STEP AP214 Files 

together with CATIA files (CATIA V4 models, CATIA V5 CATParts, CATProducts and 

CATDrawings). It consists of a CATIA V4 module (CATIA function), a CATIA V5 module 

and a separate PDM GUI that communicates with the CATIA modules. 

A STEP file used in the context of SAM contains information about the assembly structure 

and organizational data. Typically it refers to a number of CATIA files or other files, i.e. it 

does not contain any files, it just contains file names as shown in the figure below. In 

addition it contains transformation matrices describing the geometric relations between 

the CATIA files within the assembly structure. 

SAM CATIA function SAM PDM GUI

STEP

File

CATIA

Models

 

Figure 1: SAM CATIA function and SAM PDM GUI 

After a STEP File is loaded into the SAM PDM GUI, it displays the assembly structure and 

the documents and it tells the SAM CATIA module which CATIA files to load and how to 

place them. After the information is loaded into CATIA it is possible to change existing 

CATIA files and their placement and to create new CATIA files. This information can be 

synchronized with the SAM PDM GUI, so that the STEP file contains the updated 

information after saving it (e.g. new transformation matrices or new CATIA file 

references). 
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Getting started 

A typical scenario to use SAM is: 

• import a STEP file with an assembly structure referencing CATIA files 

• load the assembly structure with the CATIA files into CATIA 

• make some modifications in the assembly structure and in the CATIA files 

• export the modified assembly structure into a STEP file referencing updated CATIA 

files 

 

For this scenario, proceed as follows: 

• When working with CATIA V4: 

 

In CATIA V4 In the SAM PDM GUI 

Call CATIA function "SAM"  

SAM / Menu SAM PDM / YES: Start SAM 

� SAM PDM GUI pops up 

 

 Menu File / STEP Import: 

select STEP file and CATIA Map 

� CATIMP processes are submitted 

 After CATIMP processes are done: 

click right-hand mouse button on top-level 

node in the structure view / Expand Models 

SAM / Menu LOAD PDM / YES: Read 

� models are loaded into CATIA 

 

SAM / Menu MODIFY 

� modify model positions 

 

Use standard CATIA functions to modify the 

model contents 

 

SAM / Menu SAVE PDM  

� save modifications in models or structure 

or both 

 

 In the structure tree view: 

click right-hand mouse button on the 

models you want to export / Activate 

 Menu File / STEP Export: 

Type STEP file name  

� CATEXP processes are submitted and 

STEP file is created 
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• When working with CATIA V5: 

 

In CATIA V5 In the SAM PDM GUI 

Start Product Structure Workbench 

� SAM toolbar is displayed  

 

Click on "Start SAM PDM" icon in SAM 

toolbar 

� SAM PDM GUI pops up 

 

 Menu File / STEP Import: 

select STEP file and CATIA target directory 

� CATIA files are copied to target directory 

 After CATIA files are copied: 

click right-hand mouse button on top-level 

node in the structure view / Expand Models 

Click on "Read from SAM PDM" icon in 

SAM toolbar 

� CATIA files are loaded into CATIA 

 

Use standard CATIA functions to modify the 

CATIA file contents and positions 

 

Click on "Update SAM PDM" icon in SAM 

toolbar  

� save modifications in CATIA file contents 

and positions 

 

 In the structure tree view: 

click right-hand mouse button on the CATIA 

files you want to export / Activate 

 Menu File / STEP Export: 

Type STEP file name  

� STEP file is created and CATIA files are 

copied to the directory of the STEP file 

 

For a detailed description of the functionality and the user interactions, please see the 

following chapters. 

 

Note regarding CATEXP format: 

• When working with CATIA V4, the CATIA models are typically exchanged in CATEXP 

(CATIA export) format. At STEP import/export, SAM converts the models from/to 

CATEXP format using the CATIMP/CATEXP CATIA utilities. 

• When working with CATIA V5, the STEP data package may contain CATIA V5 

CATParts, CATProducts, CATDrawings and CATIA V4 models. If CATIA V4 models 

are included, they must be in CATIA model format (.model), as CATIA V5 does not 

support the CATEXP format. 
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CHAPTER 2 

The SAM PDM GUI 
This chapter describes the usage of the SAM PDM GUI. 

The SAM GUI has 4 modes: 

• Smaragd mode:  
Displays STEP files in a Smaragd like view, imported files have the ending .sma. 
SAM will use the Smaragd mode for STEP files that you receive from Daimler. 

• GDG mode:  
Displays STEP files in a GDG like view, imported files have the ending .gdg. 
SAM will use the GDG mode for STEP files that you receive from Renault's GDG 
system. 

• VPM mode:  
Displays STEP files in a VPM like view according to Renault's VPM 
customization, imported files have the ending .vpm. SAM will use the VPM mode 
for STEP files that you receive from Renault's VPM customization. 

• MSF mode:  
Displays STEP files in a view like MSF’s EDB system, imported files have the 
ending .msf. SAM will use the MSF mode for STEP files that you receive from 
MSF (Magna Steyr Fahrzeugtechnik). 

 
SAM will automatically select the proper view depending on the STEP file origin. 

To start the SAM PDM GUI, first call the SAM CATIA function and press the SAM PDM 
button. 

 

Loading Files 

Initially the SAM window is empty. To load a File, use the File menu in the SAM window 
(see Figure 2). 
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Figure 2: Opening Files with SAM 

There are two possibilities to open a file: 

• Step Import (if SAM runs with CATIA-V4):  
SAM reads a STEP File (*.stp) or a package containing STEP Files and CATIA 
models (*.tar.gz or *.tgz). The filename has to be specified in the STEP import dialog 
window as shown on the right of the figure above.  
 
If you run SAM with CATIA-V4, you need to specify a CATIA Map name where the 
models (and other files) should be copied after the conversion. If you type in a string 
into the Map filter field, only the maps that contain this string as substring will be 
displayed in the Catia Map drop down menu. 
The conversion resolves the references in the STEP file to the files and converts all 
referenced CATIA model files from CATIA Export format to native CATIA format 
(*.model) and copies them into the specified CATIA Map.  
 
When files are copied into maps that already exist in the map, an additional dialog 
box comes up, that lists all files that will be overwritten, if you select the “Overwrite All” 
button (see Figure 4, right-hand side). 
  
If you have already loaded data of the same type into SAM, you will be asked whether 
you want to merge the data in the opened file with the data which has already been 
loaded into SAM. If you select Merge, the data will be merged, otherwise the existing 
data will be deleted before loading the new data. 
 
If you press the OK (or Merge/Do not Merge) button , the CATIA import will start and a 
window will pop up that shows the conversion progress (see figure below). 
Optionally, you can save the messages displayed in the window into a file by selecting 
“Save log file”. Press “Continue” to finish the STEP import. 

 
Figure 3: CATIA file conversion window 
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• STEP Import (if SAM runs with CATIA-V5) 
If SAM runs with CATIA-V5, you can choose a directory where the referenced 
external files should be copied. If you do not choose a directory, the files will not 
be copied. Note that no conversion (as in CATIA-V4 mode) will be performed. 
 

 

Figure 4: STEP Import Dialog in CATIA-V5 mode 

• Open:  
SAM reads a SAM file (*.sma, *.gdg or *.vpm). A SAM file is produced when 
saving a STEP file. It contains references to already converted CATIA models, i.e. 
no CATIA model conversion needs to be done when it is opened. 
If you open a file and there is already data of the same type loaded into SAM, you 
will be asked whether you want to merge the data or whether the existing data 
should be deleted. 

 
Note regarding installation: Opening a package (*.tar.gz or *.tgz) requires that the 
commands "tar" and "gzip" are available in the path. 
Under Windows, this requirement is not fulfilled by default. In this case, the package first 
has to be manually opened, e. g. by WinZip. Then the STEP file that is included in the 
package can be loaded using SAM STEP Import. 
See also note in the installation manual with an internet link for some free UNIX tools on 
Windows. 

 
 

Merging Data 

If you do a STEP Import or an Open File and data is already loaded in SAM, you can 
choose to merge the existing data with the new data. Merging of data depends on the 
View and is therefore separately described for each view. 

Merging of Smaragd data 

If the new file contains a part with the same part number and same revision and 
sequence, the original part is replaced by the new part (including its documents and files). 
If the part number is the same, but revision or sequence are different, then an error is 
reported, because multiple versions of the same part are not allowed in sma-Files. All 
assembly relations are preserved, even if a part is replaced by a new one. Two assembly 
relations are merged only if the parent and the child part are the same and if the 
findnumbers of both relations exists and if they are equal. If the folders of a part have the 
same types and document description, the folder of the original part including its data is 
replaced by the new folder. 

If the environment variable SAM_PROPERTY=MANUAL_MERGE=1 is set, you will be asked 

in the “Confirm merge” window for 3 alternatives: 

• Merge automatically 

• Start manual merge 

• Do not merge 
With “Start manual merge”, you can compare the new and the potentially resulting merged 
structure before merging. Both structures are displayed in parallel in 2 sub-windows. 
Differences in the structures are graphically highlighted. In addition, single modifications 
can be accepted or reverted. 
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Merging of GDG data 

In GDG mode the following objects are merged: 

• Files if the file name is the same 

• GEO, P2D, F2D, GDC and M3D if the Number is the same 

• INS if Instance number, Revision, Sequence, Father Partnumber, Father revision, 
Father class, Son Partnumber, Son revision and Son class are the same 

• Compositions if Number, Revision and Sequence are the same 

• PIE, IND, OCI if Partnumber, Revision and Sequence are the same 
 
Unlike in the Smaragd case, in GDG-mode the original data is preserved and not replaced 
by the data in the second file. 

Merging of VPM data 

In VPM mode the following objects are merged: 

• Files if the Id, File name, Version and Directory is the same 

• Parts if the Partnumber and the Version are the same 

• Part relations if the parent and child parts are merged and if the Instance id is the 
same. 

Merging works like in GDG-Mode, i.e. if an object is merged, the attribute values of the 
original data are preserved. 

Merging of MSF data 

In MSF mode the following objects are merged: 

• Parts if the Document-Id, CAD-Art and CAD-Unterm. and Sheet No. are the same 

• Files if the data type is the same. 
If an object is merged, the attribute values of the new data is used. 
 
You will be asked in the “Confirm merge” window for 3 alternatives: 

• Merge automatically 

• Start manual merge 

• Do not merge 
Manual merge works like in Smaragd-Mode. 

Meaning of Symbols in Manual Merge Mode 

 Object does not exist in the original data set. Object will be added. 

 Object exists in the original data set, but it is not used in this place. 
 A usage relation will be added. 

 Object does no longer exist in the new data set and will therefore be deleted 

 Object exists in the new data set, but is not used in this place. The usage relation 
will be deleted. 

 Attribute values of the relation have been changed (e.g. position). 
Blue text: Attribute values are different. The concerned attribute names are marked in 
red color. 
Grey text: Object does not exist. 

 

 

Version Dependent File Management 

In SAM/Smargd and SAM/Public mode, version dependent file names are supported. 
When importing a STEP file, the reference external files are renamed and the version is 
appended to the file name to avoid that existing files (of older versions) are overwritten. 
When loading a file to CATIA, the files are copied to a temporary working directory and 
renamed to their original name. After the files have been changed in CATIA, they are 
copied back to the original directory, using the version dependent file name. 
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SAM/Smaragd creates version dependent file names according to the following rules: 

Type of File File Name Version Dependent File Name 

CATIA-V4  name.model name#sequence.model 

CATPart name.CATPart name#sequence.CATPart 

CATDrawing name.CATDrawin
g 

name#sequence.CATDrawing 

CATProduct name.CATProduct name#partrevision#partsequence#sequence.CATPro
duct 

Others name.suffix name.suffix 

 

In SAM/Public each files of all types will be renamed by appending the version of file (if it 
exists) before the file ending, separated by a hash (#) sign. (i.e. name#version.ending). 

The STEP-Export renames the files, so that the created STEP package contains the 
original file names again. 

 

Setting the location for new files 

NOTE: this option is only available in CATIA-V5 mode. 

If you want to add new CATIA files to the structure, or if new CATProduct files are 
automatically generated and added to the structure, SAM needs to know where to store 
these files. By default these files are stored in the same directory where the SAM structure 
file (*.sma/*.gdg) is located, but this directory can be manually set, by choosing File->Set 
new file location as shown in Figure 5. 

Once you set the location, it is stored in the SAM structure file (*.sma/*.gdg), so you do 
not need to set it again next time you open the file. 

 

Figure 5: Setting the location for new CATIA files 

 

Browsing and Editing Assembly Data 

After you loaded a file into SAM, the data is displayed in a tree view. Initially only the top-
level items are displayed. By double clicking one of the top-level items the tree expands 
one level and can be further expanded by double clicking the child items with a single 
mouse click on the expansion (+/-) symbols. 
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In Smaragd mode the expansion state of the tree can be saved automatically. To enable 
this feature, set “Options->Preferences->Save Tree Expansion State” to “Yes”. If the 
feature is enabled, the expansion state is saved in an extra file with ending “.bvs”. When 
you load a Smaragd file next time, the assembly structure tree is expanded in the same 
way as it was before. 

If you can click on a tree item with the right mouse button, a popup-menu will appear and 
you can select several levels of automatic expansion as shown in the figures below. 

 

Figure 6: SAM Tree Context Menu in GDG mode 

In GDG mode the following expand actions are supported: 

• Expand Assembly Structure:  
Expands all assembly components of the selected item. 

• Expand Documents  
Expands all assembly components and the documents related to the assemblies or 
parts. 

• Expand Models  
Like Expand Documents, but also expands the items (models) contained in the 
documents. 

• Expand All  
Expands all items (including the files contained in the models) 

 

 

Figure 7: SAM Tree Context Menu in Smaragd mode 

In Smaragd mode the following expand actions are supported: 

• One level assembly:  
Expands all direct assembly components of the selected item. 

• Multi level assembly  
Expands all assembly components 
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• Data  
Expands the models that are directly attached to the part 

• Models  
Expand all models that are attached to the part and all models attached to the parts in 
the assembly structure. 
  

Using the context menu, you can inspect and edit the attributes of the selected item and 
the attributes of the relation object between the item and its parent item. 

 

Figure 8: Edit Attributes Dialog Window  

Each tree item (parts, assembly, document, etc.) has attributes that are displayed if you 
open the "Has Attributes" tree node of the item. Alternatively you can switch to a different 
view, using the menu Select View => Attribute View, that displays all attributes on the right 
side of the window as shown in the figure below. 
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Figure 9: SAM Attribute View  

In GDG mode you can use the Select View menu to switch between a view that displays 
all revisions of parts and documents (which is the default view) and a view that displays 
the newest revisions only (Select View => Display Newest Revisions Only to switch to this 
view). 

 
In Smaragd mode you can use the Select View menu to switch between the normal view 
and an extended relationship view. In the extended relationship view the relations 
(containing the transformation matrices) are displayed as explicit nodes in the tree, see 
figure below. If “Options->Preferences->Save Tree Expansion State” is set “Yes”, the 
expansion state of the tree is kept when switching between different views. 

  

Figure 10: Normal view and extended relationship view (Smaragd mode only)  

NOTE: When loading an assembly structure into CATIA, SAM only transfers the structure 
and the models that are expanded (i.e. visible) in the tree, with the exception that CATIA 
files are loaded into CATIA if the document or model that contains them is visible. 
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Selecting Data 

By default, all models that are visible in the tree structure are sent to CATIA. In addition 
you can select specific models that you do not want to display in CATIA by clicking on the 
model with the right mouse button and choosing “Do not show in CATIA”. The model and 
its files will be marked by a red , i.e. the model is hidden for CATIA. By clicking again on 
the model and selecting “Show in CATIA”, the model will be transferred next time you 
reload the data in CATIA. 

Another way to select certain types of model, is the “Actions => CATIA Model Selection” 
menu: “Show all models” makes all hidden models unhidden. For Smaragd there are two 
menu entries to hide either 3D or 2D models, using “Show 3D-models only” or “Show 2D-
models only”.  

Models can also be hidden by the type of the document in which they are contained: 

For GDG this is done by using “Do not show ...” and selecting the document type that 
should not be displayed in CATIA. 

For Smaragd there are two menu entries “Show Part Description Primary models only” 
and “Show Part Desc. Sec. Models only”, to hide models that are contained in Primary 
Catia Part Description folders or Secondary Catia Part Description folders. 

 

 

Figure 11: Model Selection in SAM/Smaragd and SAM/GDG  

SAM/Smaragd: it is possible to control loading of deactivated models to CATIA. It can be 
achieved by selecting menu “Options->Preferences” and setting value of the „Load active 
CATIA Models only“ entry. Allowed values are „Yes/No“. 

 

Querying Data 

You can also expand the tree by searching for items with the Query menu. When opening 
the menu, all types that can be queried are displayed. After you have selected a type, the 
browser opens a dialog window where you can specify values you want to search for. If a 
field is empty or if it contains a * character, all values will match the query. Wildcards are 
supported using the * character. 
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Figure 12: Query Dialog 

With the dialog window shown in the figure above a search for all CATIA models that have 
a file name ending with .model will be started. After you pressed the OK button, all found 
tree nodes will be expanded and the Query window comes up as shown in the figure 
below. 

 

Figure 13: Query Window 

By clicking on the Yes button you can jump to the next result of the query. The 
corresponding item will be selected in the tree. By clicking No, the query aborts, by 
clicking All, all query results in the tree are selected. 

 

STEP File Header Section Information 

A STEP file always has a header section containing organizational data. If you want to see 
what is contained in this header section, open the menu Options => Show Header Info. 

 

Figure 14: Header Section Dialog Window 

A window will appear that displays the header section information of the STEP file which 
was imported last as shown in the figure above. 
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Functionality “Check Files” 

NOTE: This functionality is only available for SAM/Smaragd. 

The functionality Check Files checks if the CATIA-Models referenced by SAM are 
available in the local folder structure. For all file references the available meta data is 
checked concerning the availability of the physical files on the local disk. As result, a 
status notification is generated as documentation of the check. The notification can be 
stored as a log file. 

The following model types are checked:  

• Activated models (is everything available? Have all models which should be 
contained within a specific export package been imported?). 

• Deactivated models (are the deactivated models already available (e.g. as an 
Import Map) and have they been sent within another package in the scope of a 
specific order?). 

 

In a first step, it is checked whether the respective models are defined as activated or 
deactivated. The function Check Files checks the following possibilities: 

• A model is activated but is not found within the folder (File ACTIVE and NOT 
READABLE), 

• A model is deactivated and is not found within the folder (File NOT ACTIVE and 
NOT READABLE). 

• A model is deactivated but is found within the folder (File NOT ACTIVE), 
 

In order to visualize the respective status notification, the status window has to be 
activated (Menu View � Show Status). The function is then available in the menu File 
(File � Check Files). If one of the cases mentioned above occurs, a respective error 
message is generated („Errors Found“, Figure 15): 

 

Figure 15: Functionality Check Files 

Visualization in Main Window and Status Window 

The three cases described above are summarized in the following table: 

Event Message in status window 

case 1: model file is activated but is not 
found within the folder 

File ACTIVE and NOT READABLE: <file 
name> 

case 2: model file is deactivated and is 
not found within the folder 

File NOT ACTIVE and NOT READABLE: 
<file name> 

case 3: model file is deactivated but is File NOT ACTIVE: <file name> 
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found within the folder 
 

Case 1: File ACTIVE and NOT READABLE 

In the main window, all models that were not found are marked („File not found“); in the 
status window, the inconsistencies are displayed (Figure 16): 

 

Figure 16: File ACTIVE and NOT READABLE 

Case 2: File NOT ACTIVE and NOT READABLE 

In the main window, all models that were not found are marked („File not found“); in the 
status window, the inconsistencies are displayed (Figure 17): 

 

Figure 17: File NOT ACTIVE and NOT READABLE 

Fall 3: File NOT ACTIVE 

In the main window, all deactivated models are displayed in a different colour (pale); in the 
status window, the inconsistencies are displayed (Figure 18): 
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Figure 18: File NOT ACTIVE 

Save Notifications as Log File 

All information displayed in the status window can be saved as a log file. The respective 
functionality is available by clicking the right mouse button (context menu � Save Log). 

The log file for the cases described above has the following format: 

Thu, 14 Apr 2005 12:17:22 Errors found 
Thu, 14 Apr 2005 12:18:08 Information(1060): Start check file existence 
Thu, 14 Apr 2005 12:18:08 Information(1062):  
File NOT ACTIVE and NOT READABLE: A4000101801#0001#18#1.CATProduct 
 
Thu, 14 Apr 2005 12:18:08 Information(1069): End check file existence 
Thu, 14 Apr 2005 12:18:08 Errors found 
Thu, 14 Apr 2005 12:18:44 Information(1060): Start check file existence 
Thu, 14 Apr 2005 12:18:44 Warning(1061):  
File ACTIVE and NOT READABLE: A4000101801#0001#18#1.CATProduct 
 
Thu, 14 Apr 2005 12:18:44 Information(1063):  
File NOT ACTIVE: A4000101802#0001#18#1.CATProduct 
 
Thu, 14 Apr 2005 12:18:44 Information(1069): End check file existence 
Thu, 14 Apr 2005 12:18:44 Errors found 

 

The log file is saved with the suffix .log. 

 

 

Creating and Replacing CATIA Files in the Assembly Structure 

If you have loaded the data into CATIA, you can extend and modify the assembly 
structure data by changing the placement of existing CATIA files, by adding new CATIA 
files or replacing existing ones. Changing the placement of a CATIA file updates the 
transformation matrix attributes of the affected items in SAM. Adding or replacing new 
CATIA files requires some user interaction which is described in this section. 

When SAM is notified by CATIA that a new CATIA file should be added (for CATIA-V4 
mode see chapter 3, DOCUMENT CREATE, for CATIA-V5 mode see chapter 4, Create in 
SAM PDM), a window comes up for selecting the location of the CATIA file (see next 
Figure). The new CATIA file will be created as a child component of the selected node, if 
the node is a document. If the node is a file, it will replace the selected file. 



 

SAM User's Manual The SAM PDM GUI 25 

 

Figure 19: CATIA file destination selection 

After you selected the location of the new CATIA file, another window comes up for 
entering the data of the new CATIA file. 

 

Figure 20: Dialog Window to put in new CATIA model data 

In CATIA-V4 mode, the CATIA Map of the new model has to be specified. 

In CATIA-V5 mode, the directory of the new CATIA file (CATPart or CATDrawing) has to 
be specified. 

After entering the file name of the new CATIA file and the description, press the OK button 
and the CATIA file is displayed in the tree view. 

 

Adding existing Files to the Assembly Structure 

NOTE: This functionality is only available for SAM/Smaragd and SAM/GDG. 

To add an existing File to the assembly structure, open the context menu on a Smaragd 
Folder and choose “Edit Structure”. 
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In CATIA-V4 mode, choose “Add CATIA-V4 File” (only for SAM/Smaragd) to add a CATIA 
V4 model, or choose “Add File" to add files of other formats. 

In CATIA-V5 mode, the menu entry “Add CATIA-V4 File” does not exist. Choose “Add 
File" to add CATIA files or files of other formats. 

 

Figure 21: Context menu to add new files to Smaragd Folders 

If you open the context menu on a CATIA model or file and choose Edit Structure->Add 
(CATIA-V4) File, the existing file will be not added but replaced by the newly selected one. 

If you choose "Add CATIA-V4 File", a dialog window will appear to choose the CATIA Map 
and the CATIA-Model as shown in Figure 22. 

 

Figure 22: Adding existing CATIA-V4 Files 

If you choose "Add File", a dialog window will appear to enter the filename, its description 
and the type of the file as shown in Figure 23. 

 

Figure 23: Adding existing other Files 

In CATIA-V5 mode, the following CATIA file types can be specified: 

CATIA-V5 Part (CATPart) 

CATIA-V5 Product (CATProduct) 

CATIA-V5 Drawing (CATDrawing) 

Splitted CATIA Model (CATIA V4 model) 
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After selection “OK” in the dialog window, the file will be added to the structure. For CATIA 
files you need to reload the structure in CATIA to display it. 

 

 

Changing CATIA Maps or Directories 

NOTE: In CATIA-V4 mode, the CATIA models are stored in CATIA Maps. In CATIA-V5 
mode, the CATIA files are stored in directories. This section describes the functionality to 
change the CATIA Maps (CATIA-V4 mode). In CATIA-V5 mode, the functionality to 
change the directories for CATIA files and other files is analogous (use "Change directory" 
instead of "Change CATIA Map"). 

Description to change the CATIA Maps: 

After import, you can manually change the CATIA map for a file. There are three ways to 
do this in SAM: 

Open the context menu on a CATIA file and select Change CATIA Map. This will change 
the CATIA map for the selected file. 

Select one or more CATIA files with the left mouse button (holding the Control Key after 
having selected the first file) and select Change CATIA Map in the Action menu. This will 
change the CATIA maps for all selected files. 
NOTE: To change all CATIA Maps in a (sub-)assembly, expand the Assembly tree (using 
Expand All), select the first item of the assembly and click on the last item of the assembly 
holding the shift key. This will mark all items of the assembly. After that, use Change 
CATIA Map in the Action menu. 

Select Change All CATIA Maps in the Actions menu. This will change the CATIA maps for 
all files referenced by the STEP data. 

 

Figure 24: Changing CATIA maps 

After you have selected one of the above menu buttons, you have to choose the new 
CATIA map. In addition there are two options: 

Overwrite Models?: If this checkbox is switched on, existing models with the same name 
will be overwritten. 

Move?: If this checkbox is switched on, the model is moved from the original map to the 
new map, otherwise it is copied.  

NOTE: Before changing the map of a model, you should first save in CATIA using the 
SAM CATIA function. After you have changed the map, you should reload the structure in 
CATIA. 
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Creating and Editing the Assembly Structure 

If you want to change or prune the assembly structure, you can also use the context menu 
by clicking with the right mouse button on a part and selecting Edit Structure. Depending 
on the type of the part and its position in the assembly structure several actions that can 
be applied on the part are provided (see next figure): 

 

Figure 25: Part Actions 

• Delete Node:  
Deletes the usage of the part in the assembly structure. 

• Isolate Node:  
Delete all parts that are not sub-parts of the current part. The current part will become 
the new top-level part. 

• Path to Node:  
Delete all parts that are not members of the path from the current part to the toplevel 
assembly. 

• Delete Object:  
Deletes the part including all its usages in the assembly structure 

• Copy  
Copy the part to the clipboard, so that it can be pasted later. 
NOTE: Copying does not mean to copy the part instance, but to copy the usage of the 
part. If the part is pasted later, you will get a new usage of the part, not a new part. 

• Cut  
Delete the usage of the part, but put it into the clipboard so that it can be pasted later. 

• Paste  
Paste a copied or cut part so that it becomes a child part of the current part. 

• Create Part  
Create a new part that is a component of the Part on which the action was applied to. 
In Smaragd mode, the Create Part Menu contains sub menus for choosing the 
specific part type. 
NOTE: After the part has been created, you need to assign a valid part number. 
 

If you select more than one item (by holding the control key or shift key pressed when 
selecting an item with the left mouse button), you can use the Action menu to perform an 
action that is then applied to all selected items. 
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Smaragd mode specific actions 

You can use SAM to create new Smaragd assembly structure files (*.sma). To create 
such a file, choose menu button “File->Create New Smaragd File”.(see Figure 26). A file 
save dialog box will come up, so that you can choose the directory and name for the new 
file. After that, you will get a predefined structure with a part. You can then modify and 
extend this structure (see previous section). 

 

 

Figure 26: Creating new Smaragd files 

In Smaragd mode SAM supports actions for changing the type of parts and documents 
and editing the product structure. 

To change the type of a folder, click with the right mouse button on a folder, so that the 
context menu comes up as shown in the figure below. Select Change and choose the 
folder type you want to have. 

 

Figure 27: Changing the type of a Smaragd Folder 

In the same way you can change the type of Parts. 
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In addition, the following actions are available: 

• Create Folder  
Create a new folder attached to the part 

• Merge  
This action is only available if the part has more than one folder. In this case all 
folders except the first are deleted and the files contained in the deleted folders are 
attached to the remaining folder. 

• Split  
This action is available for folders containing more then one file. If you apply this 
action to a folder, a new folder will be created for each contained file. 

 
 

Functionality “Create Toplevel Arrangement” 

If a structure contains more than one toplevel element, an additional element can be 
created as superior element (one level above the existing elements). Therefore, the 
functionality Create Toplevel Arrangement is available in SAM. The functionality can be 
called from the menu Action. If a loaded structure consists of only one toplevel element, 
the functionality is deactivated. 

The following attributes are created in order to show the needed information: 

• Part Number 

• Nomenclature 

• Revision 

• Sequence 
 

An example is shown in  
Figure 28: 

 

 
Figure 28: Functionality Create Toplevel Arrangement 
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Saving and Exporting Data 

After you have imported and modified STEP data, you can save the file containing the 
assembly structure by using the File => Save or File => Save As menu entries. SAM 
saves the files in a native format which corresponds to the format of the originating 
system. However, this format is fit for saving data only, not for exporting and sending data 
back to the original sender. Once you have saved a file in native SAM format, you can 
open it again using the File => Open menu entry.  

If you want to export data and send it back, you first have to decide which (CATIA) files 
should be included and which not. In GDG mode only the CATIA models that have been 
created or replaced in the assembly structure will be included into the export package by 
default. In Smaragd mode, all models are activated by default. If you want to send only 
particular files, you can do this by activating or deactivating them. You can either do this 
globally by using the menu entries Action => Activation => Activate All Models or Action 
=> Activation => Deactivate All Models or Action => Activation => Deactivate Unchanged 
Files or you can do it for a particular file, model or document by clicking with the right 
mouse button on the item that should be (de)activated and selecting Activate or 
Deactivate in the context menu (see figure below). 

In Smaragd mode there is an additional sub menu to deactivate CATIA catalogue files (see “Special option for 
CATIA catalogues 

If the environment variable "SAM_SYNC_CATALOG_DIR" points to a CATIA catalogue 
directory, the catalogue parts will be handled in a special way at “Synchronize/Update”. 
Then each part in the CATIA structure will be checked whether it exists under the same 
name in the catalogue directory. If yes, it will be created in SAM-PDM as read-only (lock 
symbol) and deactivated (pale). 

How to define a default part class”, Page 64).  
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Figure 29: Activation of CATIA Files 

If an item is deactivated it changes its color. If you activate it again the color will change to 
the original color. If you (de)activate a document or a model all containing files will be 
(de)activated. 

If you want to send the data back, the activated CATIA files need to be converted into 
CATIA Export format (CATIA-V4 mode) and the assembly structure data has to be 
converted into STEP format. You can do this by selecting File => Step Export. After 
entering a file name and pressing the OK button, the CATIA export processes are started 
(CATIA-V4 mode), the results of the conversion are displayed in a similar window as for 
the import. In CATIA-V5 mode, the activated CATIA files are copied to the directory of the 
STEP file but not converted into CATIA export format. In GDG mode, after the conversion 
is finished the files will be packed into an archive (*.tar.gz) that contains the STEP file and 
all referenced external files that are to be included. 

Note regarding installation: Packing into an archive (*.tar.gz) requires that the commands 
"tar" and "gzip" are available in the path. 
Under Windows, this requirement is not fulfilled by default. In this case, the files created at 
STEP Export are copied into the specified target directory, but no archive is created. 
See also note in the installation manual with an internet link for some free UNIX tools on 
Windows. 

NOTE: Deactivated CATIA models are classified in the STEP file as "reference" to 
indicate that they are referenced but not included in the data package. 

(De)activation of a single file 
 

(De)activation of all or specific Files 
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Exporting Structures to 4DNavigator 

In GDG-Mode you can export a structure to 4DNavigator. Initially, the structure tree has to 
be expanded, so that all CATIA models that should be loaded into 4D-Navigator are 
visible in the tree. After that, choose File->Save As 4DNav Scene to create a wrl file 
(VRML) that can be loaded into 4DNavigator (see Figure 30). 

       

Figure 30: Export to 4DNavigator 

 

Read-Only Items 

A node in the tree may be marked as read-only. In this case its attributes cannot be 
modified and, if it is a CATIA file, it is read-only in CATIA (in CATIA-V4 mode, the CATIA 
model is loaded in "lock as passive" mode). If a node is read-only, it is marked by a small 
lock symbol as shown below. The read-only information is contained in the STEP file and 
cannot be removed by SAM. 

 

Figure 31: Read Only Parts and Models 

 

CATIA Model Locking 

If SAM is started in file locking mode, it provides functionality for checking in and checking 
out files and models. By default, all models and files are read-only. If you want to modify a 
CATIA model or a file, you need to check it out first. You can do this by clicking on the 
model icon with the right mouse button and choose “Check Out” in the context menu.  
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Figure 32: Checkout of CATIA Models 

After you checked out the model, it will be marked with a blue  and it is read-write. If you 
see a model marked with a red , somebody else has already checked out the model, and 
you cannot check it out, unless it is checked in by the one who has checked it out. For 
models that have been checked out by other users, the context menu contains an 
additional entry “Show Checkout Info”, if you select this, you will see who has checked out 
the file on which computer and when. 

When you have finished your work on the model, you can check it in so that other users 
can work on the model. 

 

Non CATIA File Handling 

If you open the context menu for a non CATIA File, it will show the entries “Open File”, 
“Copy File” and “Update File”.  

With “Open File”, you can start an application that is associated with this file type and view 
or edit the file.  

With “Copy File”, you can create a copy of the file in another directory, edit or change it 
and then update it, i.e. copying it back to its original location, using “Update File”. 

 

Copy Trafos (SAM/Smaragd) 

This function is only available in the "Extended Structure Display". 

In the context menu of a Trafo the menu item "Edit Structure" has a submenu that lets you 
copy the selected Trafo object into the buffer. 

 

Figure 33: Copy Trafo into the buffer 
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Through the menu "Paste" the currently selected Trafo will be replaced with the one 
copied into the buffer before. 

 

 

Figure 34: Paste Trafo from the buffer 

 

Figure 35: Inserted Trafo (original Trafo was replaced) 

 

Mirror Trafos (SAM/Smaragd) 

This function is only available in the "Extended Structure Display". 

In the context menu of a Trafo the menu item "Edit Structure" has 3 submenues "Mirror 
(X-Y plane)", "Mirror (Y-Z plane) and "Mirror (Z-X plane)". 

 

 

Figure 36: Context menu for the mirroring of a Trafo 

Through the choice of one of these submenues the Trafo will be mirrored by the selected 
plane and the Trafo type will be changed accordingly. 

 

 

Figure 37: Mirrored Trafo 



 

36 The SAM CATIA V4 Function SAM User's Manual 

CHAPTER 3 

The SAM CATIA V4 Function 
This chapter describes the functionality of the CATIA V4 module SAM together with the 
SAM PDM GUI. 

 

Menu structure in CATIA 

The following figure shows the menu structure of the SAM CATIA module. In this structure 
it is possible to see which menu items can be reached through this CATIA function. 

SAVE PDM

TRANSLAT

LOAD PDM

ROTATE

MOVE

LINE

SYMMETRY

AXIS

RELOAD

MOD POS

MODIFY

SAM

HELP

SAM PDM

TRAFO

REUSE

STORE

MOVE WP

DOCUMENT

DEFAULT

POSITION

RESYNC

GEOMETRY

ALL

CREATE

HL SAM

DOWN

UP

SET

POSITION

GEOMETRY

ALL

ACTIVE

 

Figure 38: SAM CATIA function menu structure 
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Usage of the SAM CATIA function 

The SAM function is designed conformably to the look and feel of the CATIA Motif user 
interface. If you are familiar with the CATIA user interface, you will be able to work with 
the SAM function just as well as usual. 

If any message appears on the status line, you can type  

/help 

on the CATIA command line to get more information about this message. 

To get help for the active menu point, you can type 

/samhelp.  

 

General  

The SAM function manages hierarchical assembly structures of CATIA models. 

Part

Relation

Root

 

Figure 39: Assembly structure in SAM 

In contrast to the flat session of the native CATIA, SAM uses a structured assembly. That 
means if you change a relation the total sub-assembly will change the position.   

It is also possible to use some CATIA models multiple times. If you change the geometry 
of a multiply used CATIA model, the other models will be resynchronized after a swap to 
another model.  

It is also possible to build in the same sub-assembly several times in one assembly 
structure. If there is a multiple use of a sub-assembly, the sub-assemblies will be 
automatically resynchronized.  
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SAM -> SAM PDM 

 

Start the SAM PDM GUI and bring it into the foreground. If the SAM PDM GUI is 
already running, then it is brought into the foreground. 

 
Confirm with YES 

 

  

 

SAM -> LOAD PDM 

 

Load the structure from the SAM PDM GUI 

 
Confirm with YES 

 

 

 

SAM -> SAVE PDM 

 

Read Assembly Items with SAM > LOAD PDM 

Modify the geometry or position information 

Write the modifications back with SAM > SAVE PDM > ALL 

 
After your confirmation a list of models that have been modified will come up in 
CATIA. If some models were active, but the user must not change these models, a 
status panel will pop up. It is not necessary to confirm this panel.  

Select the models you want to update. 

The selected models will be updated in the SAM structure.  

 

 

Figure 40: Dialog for SAVE PDM CATIA Models 
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Figure 41: Status Dialog before SAVE PDM 

 

 

SAVE PDM > ACTIVE 

This menu item updates the geometry information of the active model in CATIA on the 
disk. As a prerequisite the model must have been loaded from the SAM PDM GUI before. 

 

 

Read CATIA items with SAM > LOAD PDM 

Modify the geometry information 

Write the modifications back with SAM > SAVE PDM > ACTIVE 

 
After your confirmation the geometry information of the active model in CATIA will be 
updated. 

 

SAVE PDM > POSITION 

This menu item updates all position information changed in CATIA in the SAM structure. 
As a prerequisite the assembly must have been loaded from the SAM PDM GUI before. 

 

 

Read CATIA items with SAM > LOAD PDM 

Modify the position information 

Write the modifications back with SAM > SAVE PDM > POSITION 

 
After your confirmation all position information changed will be updated in the SAM 
structure. 

SAVE PDM > GEOMETRY / MODELS 

This menu item updates the geometry information of all activated models in CATIA in the 
SAM structure. As a prerequisite the models must have been loaded from the SAM PDM 
GUI before. 

 

 

Read CATIA items with SAM > LOAD PDM 

Modify the position information 

Write the modifications back with SAM > SAVE PDM > GEOMETRY 

 
After your confirmation a list of models that have been modified will come up in 
CATIA. If some models were active, but the user must not change these models, a 
status panel will pop up. It is not necessary to confirm this panel. 

Select the models you want to update. 

The selected models will be updated in the SAM structure. 
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Figure 42: Dialog for Update CATIA Models 

 

 

Figure 43: Status Dialog before Update 

 

 

 

 

SAM -> RELOAD 

This menu item reads CATIA models, CATIA documents and CATIA parts and 
assemblies placed in the SAM structure. 

It works the same way as the SAM > LOAD PDM function, but in difference to it all 
functions do not delete the current CATIA Session. All SAM > RELOAD functions leave 
non-SAM models unchanged. This means the designer is able to use models/assemblies 
from SAM in conjunction with other models, e.g. models loaded using the CATIA File 
Open… function. 

This function is also valuable in cases where you want to expand the assembly already 
loaded into the SAM PDM GUI in a different way (e.g. de-expand one sub tree and re-
expand another one instead). After RELOAD, CATIA will reflect the new situation shown 
in the SAM PDM GUI. 

Generally all SAM > RELOAD functions are much faster than the SAM > LOAD PDM 
because your current CATIA Session is only updated with the parts of the SAM PDM GUI 
content not yet loaded to CATIA. 

RELOAD > ALL 

All unsaved modifications (positions and models) will be updated with the original data 
from the SAM structure. RELOAD->ALL leaves non-SAM models untouched in the 
session. 
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RELOAD > GEOMETRY 

RELOAD->GEOMETRY updates the current CATIA Session with the SAM PDM GUI 
content. In addition RELOAD->GEOMETRY resets all changed and unsaved models to 
their original condition. RELOAD->GEOMETRY leaves modified positions untouched.  
RELOAD->GEOMETRY leaves non-SAM models untouched in the session. 

RELOAD > POSITION 

RELOAD->POSITION updates the current CATIA session with the SAM PDM GUI 
content. RELOAD->POSITION resets all changed and unsaved positions. RELOAD-
>POSITION leaves modified models untouched.  

RELOAD->POSITION leaves non-SAM models untouched in the session. 

RELOAD > RESYNC 

RELOAD->RESYNC updates the current CATIA session with the SAM PDM GUI content. 
Only models which are not already loaded in CATIA will be added to the current CATIA 
session. In difference to RELOAD->ALL RELOAD->RESYNC leaves your modified 
models and positions unchanged in your session. 

This is the fastest way to synchronize the contents of CATIA with the SAM PDM GUI. 
RELOAD->RESYNC leaves non-SAM models untouched in the CATIA Session. 

 

 

SAM -> DOCUMENT 

The menu item ‘DOCUMENT’ contains actions to insert the active model in CATIA into 
the SAM structure. 

DOCUMENT  > CREATE 

This menu item creates a SAM model from the model that is currently active in CATIA. 
A dialog window in the SAM PDM GUI appears and you can enter additional attributes 
(see chapter 2, Creating and Replacing CATIA Files). 

 

Design or load your local CATIA model 

In CATIA select SAM > DOCUMENT > CREATE 

 A SAM PDM GUI dialog window appears. 

Fill out the fields and press ‘OK’ 

A new model will be created in the SAM environment. 

 

 
Notice: 
If the active file was opened with File->Open in CATIA, it will be replaced by the 
new model registered in SAM. 
If the active model came from SAM the new model will be added to the CATIA 
Session and made the active model. 
So in both cases you can continue to work with the model and later update it in 
SAM.  

 
 

DOCUMENT > HL  SAM 

This menu item marks the selected model in the SAM PDM GUI (Highlight). This provides 
a link back from CATIA to the SAM PDM GUI. 
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Choose DOCUMENT > HL SAM 

Select the model you want to mark in the SAM PDM GUI 

 
After your confirmation the model will be marked in the SAM PDM GUI.  

 

 
Notice: 
In some cases, it is possible that CATIA crashes at a highlighting operation. 
So it is recommended to save before a highlighting operation.  

 

 

 

SAM -> MODIFY -> MOVE WP 

 MODIFY > MOVE  WP 

The work plane defines the level in a sub-tree of a hierarchical assembly relative to which 
modifications in the hierarchical assembly become effective. The relative location and 
rotation between a part and one of its sub-parts or sub-structures is defined by a 
relationship. If there is only one tree structure, then the first part of the tree becomes the 
root. If there are several trees or other models in CATIA, then a virtual root joins the 
independent models and sub-trees to one tree.  

 

Part

Relation

Root

 

Figure 44: Tree structure with one tree 
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Part

Relation

Virtual

Root

 

Figure 45: Tree structure with several trees and a virtual root 

It is only possible to transform the relationships between the active workplane and its 
direct sub-parts and its sub-structures. 

 

 

Part

Relation

Active Workplane

Changeable Relations
 

Figure 46: Active workplane in the tree structure 

 

 
The active work plane and the active model are different. If you want to edit a model 
you have to make it active.  

If you move or rotate a model in the structure by using the TRANSFOR Function 
then you do not change the relationship to the root structure element, but the 
geometry of the active model. 
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When working with SAM, the standard CATIA functionality to modify model 
positions in a multi-model structure (CATIA function MODELS) may not be used. 

This is very important. 

If you modify model positions by using the CATIA function MODELS, then these 
modifications will be lost as soon as you continue to work with SAM. 

 

There are several possibilities to choose the active work plane: 

MOVE WP > UP 

 
CONFIRM with YES 

Moving the Workplane up means that the Workplane will be a part in a higher layer of the 
structure, see in the figure below. The models below the active workplane are highlighted. 
If there is no higher layer a message will be displayed.  

1. 

1

2 3

6

7 8

54

 

Figure 47: Moving the Workplane ‘up’. 

MOVE WP > DOWN 

Moving the workplane down means that the active workplane crosses the tree-structure 
downwards, see in the figure below. The models below the active workplane are 
highlighted. If there is no lower workplane a message will be displayed. 

 

 
CONFIRM with YES 
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Figure 48: Moving the Workplane ‘down’. 

MOVE WP > SET 

Select Element:  

The active workplane and its sub-trees are highlighted.  

Or 

 
CONFIRM with YES 

 

Choose the new workplane from the list (the chosen part and its sub-trees are highlighted) 
and confirm with OK. 

 

Figure 49: Selection panel for the new workplane 
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SAM -> DEFAULT 

With the menu item "DEFAULT" you can switch the work plane functionality.  

 
If you do geometry transformations with the  MOD POS > ... function then it is 
necessary to have the right work plane active  

This panel allows you to select the way in which the work plane is activated.  

 

The default selection of the panel is Assembly. 

 

Figure 50: Default panel 

Geometry 

If you choose "Geometry", the MODIFY > MOD POS functions will change the position of 
the selected geometry (Model) instead of the Assembly. This option is only available if 
Geometry positions are supported in your customization of SAM.  

 Default Workplane 

If "Default Workplane" is chosen, the work plane is automatically set to the next higher 
assembly in the assembly tree when you select a model. 

 

Automaticly set Workplane 

Changeable  Relation 

Selected  Element 

 

Figure 51: Automatically set default work plane 
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Assembly 

If you choose "Assembly" you can set the work plane with the MODIFY > SET WP 
commands.  

Multiselection 

Choose Multiselection to apply MODIFY > MOD POS positioning to multiple Parts at once. 
The Parts to be positioned can be selected in a panel.  
Note that only the leaves of an assembly are displayed for selection. Also a part that 
occurs in the assembly both as a leaf and with subassemblies is not displayed for 
selection. 

To-do: 

 

Check SAM > DEFAULT  Multiselection 

SAM> MODIFY > MOD POS > ... 

 
Confirm to get a list of the selectable elements 

 

Select the elements to be transformed (The selected elements are highlighted red) 
and confirm with OK.  

 

In the figure below is possible to select part 1. It is impossible to select part 2, 
because it is not allowed to multiselect parts with sub-structures. If you drop all the 
sub-trees of part 2 out of CATIA then you also can multiselect part 2. After updating 
the changes you can RELOAD the dropped sub-structures. 

 

Do the transformation as described in SAM > MODIFY > MOD POS > ... 

 

 

Part 1

Part 1

Part 2

Part 1

Part 1

Part 2

 

Figure 52: Example for Multiselection 
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SAM -> MODIFY -> MOD POS 

MODIFY > MOD POS > TRANSLAT  

This menu item (Translate) translates the selected part in the direction indicated by the 
selected line, axis or from point to point. 

 

 

Read an assembly as described in chapter SAM > LOAD PDM 

Select workplane as described in chapter MODIFY > MOVE WP 

Select: MODIFY > MOD POS > TRANSLAT 

Select a part in a sub-tree of the current workplane (the selected tree will be 
highlighted red). 

 Select a vector or line (the selected line/vector will be highlighted red). You can also 
select a first and second point (a red highlighted vector between the 2 points will be 
created). 

 Enter a distance or select the second point. 

 Click at the vector or press the ENTER Button in order to change the transformation 
direction. 

 
Confirm with YES. 
The selected part will be translated. 

 

 

MODIFY > MOD POS > ROTATE 

This menu item rotates the selected part around an axis. 

 

 

Read an assembly as described in chapter SAM > LOAD PDM 

Select workplane as described in chapter MODIFY > MOVE WP 

Select: MODIFY > MOD POS > ROTATE 

Select a part in a sub-tree of the current workplane (the selected tree will be 
highlighted red). 

 Select an vector/line (the selected vector/line will be highlighted red). In addition a 
rotation angle occurs to visualize the rotation direction. 

 Enter an angle or  
Select a point/line/plane and a 2

nd
 point/line/plane. 

A rotation angle will be calculated and displayed. 

 
Confirm with YES. 
The selected part will be rotated. 

 

MODIFY > MOD POS > MOVE > AXIS 

This menu item moves the selected part from one coordinate system to another one. 

 

Read an assembly as described in chapter SAM > LOAD PDM 

Select workplane as described in chapter MODIFY > MOVE WP 
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Select: 

MODIFY > MOD POS > MOVE > AXIS  

Select a part in a sub-tree of the current workplane (the selected tree will be red 
highlighted) 

Or 

 
Confirm with YES 

Select part in list 

 Select first axis  

or  

create your axis by:  

Select a point to create the base 

Select another point, line, plane to create the x-axis (change direction by ENTER) 

Select another point, line or plane to create the y-axis (change direction by ENTER) 

Confirm with YES to create the z-axis 

 Select second axis  

or  

create your axis by:  

Select a point to create the base 

Select another point, line or plane to create the x-axis (change direction by ENTER) 

Select another point, line or plane to create the y-axis (change direction by ENTER) 

Confirm with YES to create the z-axis 

 Click at the vector or press the ENTER Button in order to change the transformation 
direction. 

 
Confirm with YES. 
The selected part will be moved to the second coordinate system. 

 

MODIFY > MOD POS > MOVE > SYMMETRY 

This menu item mirrors the selected part in relation to a 2D plane. 

 

 

Read an assembly as described in chapter SAM > LOAD PDM 

Select workplane as described in chapter MODIFY > MOVE WP 

Select: 

MODIFY > MOD POS > MOVE > SYMMETRY  

Select a part in a sub-tree of the current workplane (the selected tree will be 
highlighted red). 

 Select a plane (the selected plane will be highlighted red). 

 
Confirm with YES. 
The selected part will be mirrored. 
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MODIFY > MOD POS > MOVE > LINE 

This menu item moves a part. The relative position between the first selected line and the 
selected part is identical to the relative position between the second selected line and the 
part after the action is completed. 

 

 

Read an assembly as described in chapter SAM > LOAD PDM 

Select workplane as described in chapter MODIFY > MOVE WP 

Select: 

MODIFY > MOD POS > MOVE > LINE  

Select a part in a sub-tree of the current workplane (the selected tree will be 
highlighted red). 

 Select the first and second line (the selected lines will be highlighted red). 

 
Confirm with YES. 
The selected part will be moved. 

 

MODIFY > MOD POS > TRAFO   

The TRAFO functionality is to facilitate the work with all transformation routines of the 
SAM CATIA module. 
This function gives the user the ability to reuse a transformation once defined multiple 
times. To work with this function at least one transformation must have been performed 
before. 

MODIFY > MOD POS > TRAFO  > STORE 

This menu item stores the last transformation done (MODIFY > MOD POS> TRANSLATE 
/ ROTATE / MOVE). The stored transformation can be used on any other part (TRAFO > 
REUSE).  

 

Change the position of an assembly: SAM > MODIFY> MOD POS > MOVE > ... 

Select: 

MOD POS > TRAFO > STORE 

 
Confirm with YES. 
The last transformation part will be stored. 

 

MODIFY > MOD POS > TRAFO  > REUSE 

After you have stored a transformation, you can reuse it on any part you want. This menu 
item reuses the last stored transformation.  

 

Select work plane as described in chapter  SAM > MODIFY > MOVE WP 

Select a part in a sub-tree of the current workplane (the selected tree will be 
highlighted red). 

Select: 

MOD POS > TRAFO > REUSE 

 
Confirm with YES. 
The last transformation part will be reused on the highlighted part. 
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HELP 

To get help for SAM you have 2 possibilities: 

Click on SAM -> HELP, and the browser which was specified in the customization will 
appear in order to show the complete SAM user's manual. 

To get help for a specific menu point of the SAM CATIA module do the following: 

Activate the menu point for which you want to get the help. 

Select in the Help Drop Down menu “SAM Context Help” 

The browser which was specified in the customization will appear in order to show the 
Help chapter for the active menu point. 

 

 

 

 

Figure 53: SAM Context Help 

Please refer to the installation guide how to customize your default help viewer launching. 
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The Messages in CATIA 

In addition to the online help, it is also possible to get more information to the messages 
inside the CATIA session on the CATIA command line as following: 

 

/help 

 

Following the list of message numbers and their meaning 

Number Panel output Description 

20501 MODEL LOAD OK  Your model has been loaded successfully. 

20502 MODEL SAVE FINISHED  Your model has been saved successfully.   

20503 MODEL UPDATE FINISHED  Your model has been updated successfully.   

20504 LOAD OK  Your assembly is now loaded. 

20505 TEMPORARY ASSEMBLY LOAD OK  Your assembly is now loaded temporary. 

20506 ASSEMBLY UPDATE FINISHED  Your assembly has been successfully updated. 

20507 ASSEMBLY DROP FINISHED  Your DROP action has been successfully finished. 

20508 NO MODEL HAS BEEN CHANGED  No model or assembly has been changed since loading. 

20509 MODEL IS ALREADY IN MAP  The model you want to create is already in exchange 

map. So a overwriting would be performed and could 

cause lost of model data. 

20510 NO POSITION HAS BEEN CHANGED No position has been changed since loading. 

20600 INIT PDM MODULE  This is just a hint that the init process was started 

20605 INIT OK  This is just a hint that the init process was ok 

20606 REQUEST REFUSED  The request was refused because an EDM process is 

always pending. Please end the current action and try 

again. 

20610 CAN NOT ALLOCATE PANELFILES  The panel files can not be found, please consult your 

CATIA system administrator 

20615 ERROR IN PERSONAL ENVIRONMENT SCRIPT  Your private environment settings script is corrupt.  

Please contact your system administrator. 

20616 ERROR IN GENERAL ENVIRONMENT SCRIPT  The general environment settings script is corrupt.  

Please contact your system administrator. 

20620 FAILED TO OPEN THE LOGFILE  You have specified a log file in your setting. This 

log file cannot be opened. 

20625 TEMPORARY PART  You have selected a temporary part, which cannot be 

transformed in its position. 

20626 TEMPORARY MODEL  Your active model is a part of a temporary added 

document.  Such models can't be created or updated.  

Please swap back to the model loaded active if you 

wish to save it. 

20630 NO ASSEMBLY  You have selected a normal model that isn't a part of 

an assembly. 

20631 DROP ERROR  An error occurred while you tried to drop a model.  

This may happen, if a drop to an active model was 

performed.  To fix it, please change your work plane 

before DROP. 

20632 NO ASSEMBLY LOADED  Only one model is loaded! 

20633 NO MODEL LOADED  No model was loaded to perform this action. 

20634 SYMMETRY NOT ALLOWED Symmetry is allowed only for geometry position 

changing. 

Change the current working mode to geometry. 

20635 ACTIVE MODEL WRONG  The active model is inside of the subassembly 

selected for modification, Please swap to a model 

outside of this subassembly. 

20636 ALL MODELS IN READ ONLY ACCESS  Your active model is a temporary empty model; it is 

only used internally. Please swap to the model your 

selected action is related to. 

20637 ACTIVE MODEL WRONG  You tried to replace an assembly outside of your work 

plane.  Please change your work plane. 

20638 NO MODEL SELECTED  No model was selected.  Please change your work 

plane. 

20639 ACTIVE MODEL HAS NO FRAME  Your currently selected active model is not your 

first model below the root. Only the first root model 

contains valid drawing frame attributes! No plot 

sheet will be generated. 

20640 MODELNAME IS MISSING  You tried to save a model without a title.  Please 

setup a title for this model. 

20641 SOME MODEL(S) ARE NOT READABLE  CATIA was unable to read the following model(s): 
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20642 FAILED TO RENAME MODEL  The model RENAME function failed probably because of 

problems with your exchange map. 

20643 MODEL IS NOT READABLE  CATIA was unable to read the model C01 located in C02 

20644 FAILED TO SAVE MODEL  CATIA cannot save the active model in the PDM system.  

Check your access rights of this model in the PDM 

system. 

20645 FAILED TO UPDATE MODEL  CATIA cannot update the active model in the PDM 

system. 

20646 FAILED TO LOAD MODEL  CATIA cannot load the specified model. 

20648 MODEL UPDATE NOT POSSIBLE  You can't update a model that isn't loaded from PDM 

system. Please use CREATE to insert the model in PDM. 

20650 NO CORRECT MODEL FOUND  CATIA cannot handle this model in the PDM system. 

20653 NO WRITE ACCESS TO MODEL  You tried to write a model in read only mode.  You 

are not the owner of this model. 

20654 NO ROOT MODEL  The assembly you have loaded has no root or an empty 

root. 

20655 INCORRECT ASSEMBLY  Something is wrong with your assembly. 

20656 MODIFICATION NOT ALOWED  It isn't allowed to modify the selected model; this 

model is a part of root.  

20760 ACTION CANCELED  The action performed was canceled by EDM system. 

20761 MODEL HAS WRONG PROJECT  Some Models have incompatible project environment 

settings to your CATIA project.  Check your project 

environment. 

20762 ASSEMBLY PARTIALLY UPDATED  Your assembly has been successfully updated, For more 

information refer your EDM system. 

20763 MODEL PARTIALLY UPDATED  Some models of the splitted document couldn't be 

updated. 

20764 COMMUNICATION FAILED  Is your workbench open and initialized? 

20765 ACTION FAILED  The action performed was ended with an error. 

20800 PANEL ERROR  The panel function failed, check if the desired panel 

definition exists in the panel install directory. 

20801 NO INFO RETURNED  No info available for this model 

20810 NO VALID PLOT FORMAT ERROR  The ditto in current view isn't holding a valid plot 

format.  Please check the ditto. 

20811 PLOT FINISHED  The plot is finished. 

20812 PLOT IN PROGRESS  The plot is in progress. 

20900 PLOT FORMAT TYPE ERROR  The selected plot format is invalid. 

20910 CANNOT MOVE WORKPLANE  The work plane can't be moved in this direction.  The 

deepest or highest level in assembly structure has 

been reached. 

20911 FAILED TO CHANGE WORKPLANE  No valid document found to set the WP. 

20920 MODEL IN EXCHANGE MAP ALWAYS EXISTS  A model with such a name always exists in your 

exchange map. Please rename your model or check in 

the model in your exchange map first and retry. 

20921 NO MODEL HAS BEEN LOADED  Before something can be added temporary, a model must 

be loaded with the read function. 

20922 WARNING: MAP NOT FOUND IN DECL SERIES  The map path searched for is not defined yet in your 

declaration series. A new map will be created 

temporary. 

20923 NO MAP NAME FOR EXCHANGE MAP FOUND There is no MAP entry in your environment.  Please 

contact your system administrator. 

20924 NO VALID MAP PATH OR DLNAME FOUND  Couldn't find a valid entry in declaration series For 

the given search criteria.  Maybe the map you want to 

read from is invalid Please consult your CATIA system 

administrator. 

20930 SAME POINT SELECTED  Please select 3 different points.  

20931 WRONG VECTOR SELECTED  Please select the transformation vector to change the 

direction of current transformation.   

20932 SAME AXIS SELECTED  Please select 2 different axes. 

20940 SELECTED MODEL IS NOT IN ASSEMBLY  The selected model belongs not to an assembly loaded, 

so it can't be managed here.  Please use the standard 

CATIA functions 

20941 EXCHANNG MAP PATH DOES NOT EXIST  The specified exchange map does not exist Please 

contact your system administrator. 

20942 CHANGES TO RO MODELS NOT ALLOWED  Update a read only model. 

20943 MODEL DOES NOT EXIST  The model does not further exist in CATIA memory.  

The model was deleted. 

20944 MODEL WRITE WAS NOT SUCCESSFULL  The model could not be correctly written to Map.  

Maybe disk storage is low or NFS is poor.  Please 

contact your system administrator. 

20950 WARNING: CHANGES IN SUBASS  There are changes in the subassembly selected for 

DROP. All model and relation changes have been made 

in this subassembly will be lost if you continue.  If 

you are unsure save the assembly before DROP. No 

model or assembly to update.  The structure you have 

loaded contains no model. 

20960 NOTHING TO SAVE/UPDATE No model or assembly to update. 

The structure you have loaded contains no model. 
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20965 NO TRANSFORMATION STORED Before you are able to use this function you 

have to store the last transformation you have done. 

20966 NO VALID TRANSFORMATION FOUND Unable to found a valid transformation for reuse. 

First a position must be changed, to be able to store 

a transformation. 

20967 NO TRANSFORMATION DONE YET First a position must be changed, to be able to store 

a transformation. 

20970 NO HELP SYSTEM DEFINED  A help system (Netscape or mosaic) must be defined.  

Please contact your system administrator. 

20971 CAN NOT CONNECT TO HELP SYSTEM  Problems to connect to help system.  Please contact 

your system administrator. 

20972 NO HELP FILE FOUND  No or a wrong help file path was defined in your 

environment.  Please contact your system 

administrator. 

20973 MODEL IS NOT PART OF WORKPLANE  The model you've tried to change is not a part of a 

subassembly defined by the work plane.  Please reset 

your work plane. 

20974 FAILED TO READ STORAGE  Failed to read session data from application data.  

Please contact your system administrator. 

20975 MODEL NEED TO BE WRITTEN  Before you can add a new model to an assembly you 

have to save this model on file system. 

20976 CATIA SESSION HAS BEEN CHANGED Current CATIA session has been changed. 

Please redo your selections. 

20980 NO LICENSE NUMBER SET  No license number is set in environment.  Please 

contact your system administrator. 

20981 LICENSE INIT FAILED  Could not init license process.  Please contact your 

system administrator. 

20982 NO MORE FREE LICENSES  All available licenses are currently in use.  Retry 

later or contact your system administrator. 

20983 LICENSE EXPIRED  Your license has been expired.  Please contact your 

system administrator. 

20984 NO LICENSE FOR MODULE  No license installed for this module.  Please contact 

your system administrator. 

20985 DIFFERENT MACHINE TIMES  The LLD machine time differs from the GLD machine 

time.  Please contact your system administrator. 

20986 NO CONNECTION TO LLD  No connection to local license daemon.  Please 

contact your system administrator. 

20987 NO CONNECTION TO GLD  No connection to global license daemon.  Please 

contact your system administrator. 

20988 UNKNOWN LICENSE ERROR  Something is wrong with your license environment.  

Please contact your system administrator. 

20989 UNABLE TO START LLD Please check your license environment or contact your 

system administrator. 

20990 NO MODEL SELECTED  No model was selected. 

20991 NO MODEL FOUND  No model found. 

20992 NO POINT SELECTED  No point was selected. 

20993 SAME POINT SELECTED  Please select 3 different points. 

20994 POINTS ARE LYING ON ONE LINE  Please select at least one different point. 

20995 POINTS ARE IDENTICAL  Distance between two points is too small. 

20996 INVALID ANGLE VALUE  Input angle is less than angular tolerance.  Invalid 

value for defining rotation. 
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CHAPTER 4 

The SAM CATIA V5 Module 
This chapter describes the functionality of the CATIA V5 module SAM together with the 
SAM PDM GUI. 

 

 

SAM Toolbar 

The following figure shows the toolbar of the SAM CATIA module. Descriptions of the 
toolbar and the command icons follow the diagram. 

Read from SAM PDM

Update  SAM PDM

Start SAM PDM

Update  Position in SAM PDM

Create in SAM PDM

Highlight in Workbench

 

Figure 54: SAM Toolbar in CATIA V5 

The icon ‘Create in SAM PDM’ is only active if you are working with a CATPart in a 
CATPart-specific Workbench or with a CATDrawing in a CATDrawing-specific 
Workbench.  

 

 

SAM toolbar: Start SAM PDM 

 

 Click on the ‘Start SAM PDM’  icon . 

The SAM PDM GUI is started and brought into the foreground. If the SAM PDM GUI 
is already running, then it is brought into the foreground. 
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SAM toolbar: Read from SAM PDM 

 

 Click on ‘Read from SAM PDM’ icon . 

The structure displayed and expanded in the SAM PDM GUI is loaded into CATIA. 

 

When a PDM structure is loaded into CATIA, the part structure is mapped to a 
CATProduct  structure. 

CATProducts that are already existing in the assembly structure in the SAM PDM GUI are 
loaded into CATIA. For parts that do not yet have a CATProduct, a CATProduct is created 
on the fly and loaded in CATIA. The CATParts referred by the CATProducts are also 
loaded into CATIA. If the PDM structure also contains CATIA V4 models, they are also 
loaded into the structure in CATIA V5. So, the resulting CATIA V5 structure can contain 
both CATParts and CATIA V4 models. Position information is taken from the PDM 
structure. The transformation matrices in the CATProducts are updated accordingly. 

In the GDG view, only the CATProducts that are attached to "GDG Composition" objects 
are CATProduct files. All other CATProducts except the top-level CATProduct are CATIA 
"components". 

In the Smaragd view, all CATProducts are CATProduct files. 

The CATIA files that are to be loaded into CATIA are at first copied into the SAM 
"exchange map" directory and then loaded from there into CATIA. 

 

 

In the CATIA V5 options (Tools/Options/General/General, Referenced Documents), 
the "Load referenced documents" checkbox has to be activated. 

 

 

In the CATIA V5 options (Tools/Options/General/Document, Linked Document 
Localization), the "folder of the pointing document" has to be high priority. 

Thus, CATIA will be able to load the files following the links contained in the 
CATProduct and CATDrawing files, even if the links have full path names 
corresponding to the directory where they were saved before importing them with 
SAM. 

The pure file name components in the path names are not changed by SAM. 

 

If a CATProduct loaded from the SAM PDM GUI contains a link (instance) to a part 
(CATPart or CATProduct) that does not correspond to the PDM structure, then CATIA will 
try to resolve this link in the CATProduct at load-time, will not find the missing part, and 
will represent the missing part with a broken-link icon (greyed out – meaning hidden, see 
CATIA Hide/Show operation). In the case that the part is existing in the PDM structure to 
be loaded but the instance name contained in the CATProduct does not correspond to the 
PDM structure, this instance of the part will also be represented by a greyed out icon 
(hidden). 

Some of the PDM attributes are mapped to CATIA V5 properties (Part Number, Revision, 
Nomenclature and Instance Name) for the CATProducts and CATParts. 

If the assembly structure in the SAM PDM GUI also contains CATDrawings, they are also 
loaded into CATIA. Each CATDrawing is displayed in a separate CATIA Drafting 
workbench window. 
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Figure 55: Sample structure loaded by SAM 

 

Special option: Add SAM structure to an already loaded structure 

In case of the environment variable setting 
"CMI_ENABLE_USEROOTASCMIWORKBENCH=ON" there may be in the CATIA V5 
options (Tools/Options/General/Compatibility/CMI) an additional checkbox "Use existing 
Product as temporary CMI Workbench Product". If you activate this checkbox (if existing) 
and the checkbox "Use one temporary product window for all CMI Workbench contents", 
then SAM will add the structure from the SAM PDM GUI to the already existing product 
structure in CATIA, if there is already a CATIA product structure existing that was not 
loaded by SAM. 

 
Warning: 
If these checkboxes are activated, the functionalities for saving a structure from 
CATIA to SAM PDM like “Update SAM PDM”, “Update Position in SAM PDM” or 
“Update Part in SAM PDM” (see below) are not supported.  

 

Special option: Single part modus 

In case of the environment variable setting 
"CMI_ENABLE_SINGLEPARTMODUS_READ=ON" there will be in the CATIA V5 options 
(Tools/Options/General/Compatibility/CMI) an additional checkbox "Single Part Modus". If 
you activate this checkbox, then SAM will load each CATPart from the SAM PDM GUI in a 
single CATIA Part Design workbench window (without CATProduct structure). 
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SAM toolbar: Update SAM PDM 

 

 

Modify the contents in CATIA and the positions in the CATIA product structure. 

Click on ‘Update SAM PDM’ icon  to write the modifications back. 

 

The CATIA files loaded by SAM (except temporary CATProducts if used) are saved in the 
"exchange map" directory and in their original directories. 

The positional information in the current CATIA product structure (transformation matrices 
and CATProduct files - if used) is updated in the SAM PDM GUI. 

 

Figure 56: Information messages at "Update SAM PDM" 

The current CATProduct structure is scanned and checked whether it is consistent with 
the structure in the SAM PDM GUI. If it contains CATProduct sub-assemblies or 
CATParts that don't correspond to the SAM PDM assembly structure, these changes are 
rejected. 

 

Figure 57: Error messages at "Update SAM PDM" if structure is not consistent 
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Special option: Select modified transformation matrices 

In case of the environment variable setting 
"CMI_ENABLE_UPDATEPOSITIONDIALOG=ON" you can select at the "Update SAM 
PDM" operation which of the modified transformation matrices are to be saved. 

If this environment variable is not set, then all modified transformation matrices will be 
saved at the "Update SAM PDM" operation. 

 

 

SAM toolbar: Update Position in SAM PDM 

 

 

Modify the positions in the CATIA product structure. 

Click on ‘Update Position in SAM PDM’ icon  to write the position information 

back. 

 

The positional information in the current CATIA product structure (transformation 
matrices) is updated in the SAM PDM GUI. 

The difference to the "Update SAM PDM" operation described above is that the CATIA 
files are not saved. 

 

Figure 58: Information messages at "Update Position in SAM PDM" 

 

 

SAM toolbar: Highlight in Workbench 

 

 

In CATIA, select a CATPart or CATIA V4 model that was loaded by SAM (click on 
the geometry or on the CATPart/model instance in the CATIA specification tree). 

Click on ‘Highlight in Workbench’   icon. 

The selected CATPart/model instance will be highlighted in the SAM PDM GUI. 
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SAM toolbar: Create in SAM PDM 

 

With this toolbar button a CATPart or CATDrawing currently set active in CATIA V5 can 
be created in SAM. 

 

Design or load your CATPart or CATDrawing. 

Click on ‘Create in SAM PDM’ icon . 

In the SAM PDM GUI, a create dialog window appears to enable the user to set 
additional attributes (see chapter 2, Creating and Replacing CATIA Files). 

The CATPart or CATDrawing will be saved in the specified directory and it will be 
included in the SAM PDM structure at the specified node. 

 

 

The "Create in SAM PDM" operation is available only if the CATPart or 
CATDrawing has been opened in a separate Part Design or Drafting Workbench 
window in CATIA V5. 

 

After the "Create in SAM PDM" operation, you can close the Part Design or Drafting 
Workbench window. 

To load the updated structure with the new CATPart or CATDrawing from the SAM PDM 
GUI into CATIA, click on the "Read from SAM PDM" icon. 

 

 

SAM toolbar: Synchronize SAM 

In case of the environment variable setting "SAM_ENABLE_SYNCHRONIZECMD=ON" 
the “Synchronize/Update“ functionality is active. The SAM toolbar displays the 
“Synchronize SAM“ icon in addition. 

 

Figure 59: SAM Toolbar with “Synchronize SAM” 

The “Synchronize/Update“ functionality is available in the Smaragd mode only. 

With “Synchronize/Update” you can take over a CATProduct structure from CATIA V5 into 
a PDM structure in the SAM PDM GUI. The dialog has 2 phases: In phase 1 “Validate” 
you select for each CATProduct the type of the respective part to be created in the SAM 
PDM structure. In phase 2 “Synchronize” the CATProduct structure with the CATIA 
product properties is taken over into the SAM PDM structure step by step, allowing you to 
edit the attributes of the parts to be created. The CATIA files with their CATIA product 
properties are renamed accordingly so that the CATIA structure remains consistent. 

Example: The small assembly listed below is given as a CATProduct structure in CATIA 
V5 and is to be taken over into a SAM PDM structure using “Synchronize/Update”. 

Step 1: Load CATProduct structure in CATIA. 

Step 2: Start SAM PDM GUI. The “new file location” in SAM PDM must point to a valid 
directory as, during the synchronize dialog, the CATIA files in the structure are copied into 
this directory. 
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Step 3: Phase “Validate”. Click on the “Synchronize SAM” icon in the SAM toolbar. The 
“Synchronize/Update” dialog is started, beginning with the CATIA window “SAM 
Synchronize Structure”. Select a CATProduct in the window and click on “Edit PDM-Part 
category”. For each CATProduct you have to select the type (“category”) of the part to be 
created. 

 

Figure 60: SAM Synchronize step 3 before selecting the part category 

Step 4: Phase “Validate”. When you have selected the “category” for all CATProducts, 
confirm by clicking on “Validate operations”. 

Step 5: Phase “Synchronize”. Click on “Synchronize” to start the 2
nd

 dialog phase. The 
CATIA structure is traversed bottom up step by step. Here it starts with a CATPart. For 
this, an additional SAM PDM window pops up where you can edit the CATPart attributes 
for SAM PDM. The CATIA product properties are used as default values for Part Number 
and Description. 

Step 6: Phase “Synchronize”. If the parent CATProduct has several child CATParts, then 
the dialog continues with one of these CATParts (does not occur in this example). 
Otherwise the dialog continues with the parent CATProduct. For this, an additional SAM 
PDM window pops up where you can edit the part attributes for SAM PDM. The CATPart 
Part Number edited before is used as default value for the Part Number of the part. After 
this the CATIA structure traversing is continued until the top-level CATProduct is reached. 
The structure tree in the SAM PDM GUI is continuously updated. 
Once you confirm with “Always OK” in the additional SAM PDM window, the rest of the 
CATIA structure will be automatically traversed. 
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Figure 61: SAM Synchronize step 4 after “Validate operations” 

 

Figure 62: SAM Synchronize step 5: edit CATPart attributes 
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Figure 63: SAM Synchronize step 6: edit part attributes 

Step 7: At the end of the synchronize dialog the top-level part is displayed in the SAM 
PDM GUI. You can expand it to display the complete structure. Before you go on working 
with the structure, you should first save it (save / save as) and load it again (open) in the 
SAM PDM GUI. By this, the CATIA files that were saved in the “new file location” are 
renamed once more so that they get version dependent file names according to the SAM 
Smaragd mode. Then you can go on working with the created structure in SAM as 
normal. 

 

Figure 64: SAM Synchronize step 7: created structure loaded again from SAM 
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Step 8: You can load the created structure from SAM into CATIA as usual. You can 
change the structure in CATIA with normal CATIA means, e. g. add, move or delete an 
instance or modify a geometrical position. Then you can update the changed structure 
into SAM-PDM by repeating the “Synchronize/Update” dialog from step 3. 

You can repeat the sequence from step 3 to step 8 several times. Please note that, after 
having changed the structure in CATIA, you have to do “Synchronize/Update” before you 
change the structure in SAM-PDM. On the other hand, after having changed the structure 
in SAM-PDM, you first have to load from SAM to CATIA before you change the structure 
in CATIA. If you exit the SAM PDM GUI during a running CATIA session, you first have to 
start it again, open the saved structure and load it to CATIA before you continue your work 
in CATIA. 

Special option for CATIA catalogues 

If the environment variable "SAM_SYNC_CATALOG_DIR" points to a CATIA catalogue 
directory, the catalogue parts will be handled in a special way at “Synchronize/Update”. 
Then each part in the CATIA structure will be checked whether it exists under the same 
name in the catalogue directory. If yes, it will be created in SAM-PDM as read-only (lock 
symbol) and deactivated (pale). 

How to define a default part class 

You can define a default part class for the parts to be created in the Smaragd view by 
“Synchronize/Update” so that you don’t have to select the type (“category”) of the part to 
be created for each CATProduct in the CATIA window “SAM Synchronize Structure” in the 
“Synchronize/Update” dialog (see step 3 above). 

In the configuration file defined by the environment variable 
“CMI_CONFIGURATION_FILE” (see installation manual), edit the line that contains 
"PartCategories Default".  Replace “NOTSET” by the short name of the respective 

part class, and replace “ON” by “OFF. 

Example: Original line: 

<PartCategories Default="NOTSET" UserMustSelectNonDefault="ON"> 
 

Edited line: 

<PartCategories Default="QRY_J0PRTVER_MB" UserMustSelectNonDefault="OFF"> 
 

This defines “Query Part Version Mercedes-Benz ” as default part class. 

 

 

SAM toolbar: Creates/Attaches an Archive 

In case of the environment variable setting "SAM_ENABLE_ATTARCHIVECMD=ON" the 
“Creates/Attaches an Archive“ functionality is active. The SAM toolbar displays this icon in 
addition. 

 

 

Figure 65: SAM Toolbar with “Creates/Attaches an Archive” 

The “Creates/Attaches an Archive“ functionality is available in the GDG mode only. 

This operation enables to create in SAM a “CMI archive”. This is a data object in the SAM 
PDM structure that contains a CATIA product structure. 
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Precondition: First you load from SAM PDM in the GDG mode a structure which contains 
an empty composition. The empty composition is represented as a CATProduct in the 
CATIA product structure. Using CATIA standard functionality, you can add in the CATIA 
product structure below this “composition CATProduct” a component (CATProduct, 
CATPart etc.) which may contain further components. 

Now you can pack this structure below the “composition CATProduct” into a CMI archive, 
using the “Creates/Attaches an Archive“ functionality. To do this, you select in the CATIA 
product structure the “composition CATProduct” as the current structure level (blue 
background, see following figure) and the component immediately below the “composition 
CATProduct” as the active element (orange background, see following figure). Then you 
click on the “Creates/Attaches an Archive“ icon in the SAM toolbar. 

 

 

Figure 66: Create CMI archive 

Then you select in the SAM PDM GUI the directory where to save the CMI archive file. 
Then, as the result, the CMI archive appears in the SAM PDM structure. 

When you load the SAM PDM structure with the CMI archive back to CATIA, the CMI 
archive will automatically be unpacked. 

 

 

 

SAM toolbar: Update Part in SAM PDM 

In case of the environment variable setting "SAM_ENABLE_UPDATEGEO=ON" the 
“Update Part in SAM PDM“ functionality is active. The SAM toolbar displays this icon in 
addition. 
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Figure 67: SAM Toolbar with “Update Part in SAM PDM” 

This operation enables to save modified CATPart files. 

The difference to the "Update SAM PDM" operation described above is that no 
modifications in the CATIA product structure (e. g. position information – transformation 
matrices) will be saved. 

 

 

SAM toolbar: Delete PDM Context 

In case of the environment variable setting 
"SAM_ENABLE_DELETEPDMCONTEXT=ON" the “Delete PDM Context“ functionality is 
active. The SAM toolbar displays this icon in addition. 

 

 

 

Figure 68: SAM Toolbar with “Delete PDM Context” 

This function allows the user to handle data loaded by SAM as new data or as data loaded 
from a local store. This function causes the loss of any PDM meta information of any 
loaded file. 
 
This function is useful in combination with “SAM Synchronize” if you want to make CATIA 
“forget” that a “SAM Synchronize” operation has already been done, e. g. in the following 
scenario: 
First use “SAM Synchronize” to save a CATIA structure in SAM PDM. Then use “Delete 
PDM Context“ to make CATIA “forget” that the CATIA structure already has been 
synchronized. Then modify the CATIA structure. Then use “SAM Synchronize” again to 
save the modified CATIA structure in another SAM PDM structure. 
 
 

 

CATIA model directories 

The following figure shows the CATIA model directories in SAM for CATIA V5. 



 

SAM User's Manual The SAM CATIA V5 Module 67 

STEP
AP214

CC06

STEP
AP214

CC06

STEP
AP214

CC06

STEP
AP214

CC06

Exchange
map

D
a

ta
 e

x
c
h

a
n

g
e

 t
o

o
l

Incoming

data

STEP
AP214

CC06

STEP
AP214

CC06

STEP
AP214

CC06

STEP
AP214

CC06

outgoing
data

SAM V5

vault

any CATIA
V5 map

New file
location

Load /
save

1 per user

1 per structure

Many (1 per model)

Legend:

New

CATProducts

May be

identical

STEP
import

STEP
export

Create / add
model

Load /

save
Smaragd view:

version substring

 

 

Figure 69: CATIA model directories in SAM for CATIA V5 
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Glossary 
 

Administrator 

Person who configures the system, inserts users, manages users permissions and 
maintains the database.  

AP214 

Application Protocol 214 "Core Data for Automotive Mechanical Design Processes", part 
of STEP. SAM uses STEP AP214 as the data exchange format for assembly structures. 

Browser 

Window that displays icons representing objects. 

Dialog Window 

Window in which the user enters information. 

GII 

Graphics Interactive Interface. The GII is a powerful programming tool, which completes 
the Open System Access to the CATIA environment. 

GUI 

Graphical User Interface. User interface of a software application that operates with a 
graphics screen and a mouse. 

Icon 

Graphical representation of an object. 

List View 

Style of browser window in which objects are viewed as small icons in a list with attribute 
values in columns.  

Object 

An item or relationship. 

PDM 

Product data management. PDM systems typically handle product data like assembly 
structures, organizational data etc. 

Pop-Up Menu 

The menu that appears when the user points an icon and holds the right mouse button 
pressed. 

STEP 

Standard for the exchange of product model data. International Standard ISO 10303. 

Tree View 

Style of browser window in which objects are displayed as relationships in horizontal 
branches. 

 


