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11 ttff.. ffaacciilliittyy BBaacckkggrroouunndd

tf. facility is a premises register that contains detailed information on entities such as sites, 
buildings, blocks and spaces. This data can be fully integrated with other modules such as 
Suitability, Sufficiency, DAA (Disability Access Audit) and Hazards, amongst others. There is 
also the capability to link documents and drawings, including linking CAD drawings to import 
data in to the system. 

tf. facility enables you to easily manage the information entered, it provides full reporting and 
analysis, and automates and facilitates the tasks involved in managing a variety of 
establishments. 

tf. facility has been developed to conform to DfES requirements and therefore a number of 
standard outputs have been developed which will streamline the production of electronic data 
exchange. 

The system also makes extensive use of Microsoft products such as Word and Excel to output 
data quickly and easily. We therefore recommend that you ensure that these products are 
available on the managing of user permissions and system security. 
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22 IInnttrroodduuccttiioonn ttoo tthhee HHaazzaarrddss MMoodduullee

The Hazards module is designed to accommodate a collection of registers defined by a 
particular hazard. The most common use of our hazard register is for tracking and recording 
the presence of Asbestos Containing Materials (ACM’s). This has been developed in conjunction 
with the recommendations of MDHS 100 (correct at time of print – 2002). Other hazard types 
can be set up by the systems administrator e.g. confined space, IT equipment. For the 
purposes of this manual we will use the asbestos register as an example and show example 
data from MDHS 100. 

Before using the Hazards module it is a pre-requisite that you are familiar with the standard 
features of tf. facility. An outline of interface rules and system functions can be found under 
the Introduction to tf. facility section of the Asset Management Manual. 

The module requires that the property register contain data so that a hazard can be associated 
with a particular building or room.  The module enables you to record, monitor and maintain 
hazards associated with properties or assets. 

Hazard Surveys are carried out at Block level.  Any hazards detected or presumed are 
recorded during the survey.  Sample, Action, Risk Assessment and Inspection details can be 
documented against a hazard.  It is also possible to record instances of No Hazards found in a 
room or No Access to a room. 

The hazard information is recorded and accessed via the main screen of tf. facility. The 
Hazards module can be found on the tree structure in the left hand pane of the screen. Figure 
2.1 shows an example of the structure. 

Figure 2.1 

 

Each level of the tree can be accessed by the plus buttons to the left of the modules. The 
Hazards module on the tree may consist of one or more Survey Types (e.g. Asbestos, Confined 
Spaces). 
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The first level below the type is Surveys, where the main surveys are contained. Each status 
folder (A – New, B – Issued, C – QA and D – Complete) enables the management of the 
surveys. For example a Survey is created at the A – New status, then moved to B – Issued 
where the data collected is then entered. The survey can then be moved to C – QA if the survey 
is to be verified and to D – Complete when the survey data is complete. See section 3.6 of the 
Hazards Module manual for more details on moving the surveys between each status. 

The Register folder on the tree structure contains a complete list of all the Hazards recorded 
against the Survey Type, while the Actions folder shows every Action recorded. 

 

Hint 

The first one hundred records are displayed on the list views (Register and Actions folders) in 
the right hand pane of the screen. When this is exceeded More and All buttons will be apparent 
at the top right of the pane. Use these buttons to view any additional records. 

 



© The Technology Forge 2007  Page 8 of 48 
Hazards Handheld User  Manual 

33 SSyysstteemm CCoonnvveennttiioonnss

3.1 Handheld Screen 
 

The handheld Hazard Survey module follows a standard set of user interface rules. This 
enhances usability and reduces the time taken to learn the software. The module is broken 
down into logical sections that have areas for entering and manipulating data. 

At the top of each screen is a title that shows you what the current form relates to. 
 

3.2 Pick Lists 

The handheld module makes extensive use of pre formatted data lists (pick lists). These ensure 
a quick and consistent means of gathering data. These lists appear as a ‘black triangle’ on the 
right of the field and pressing the screen on one of these triangles will show a list of acceptable 
choices for the data field (see fig 3.2.1). 

 

Figure 3.2.1 

Selecting one of these options will populate the field next to the black triangle. 
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3.3 Action Buttons 

The handheld module adopts the convention of buttons to create a new record, save a record 
or to delete a record. 

 

3.4 Free Text Fields  

Whenever a large amount of text is needed, the system will allow you to enter it free hand into 
the field e.g. comments. This field is displayed as a large white box. 
 

3.5 Closing a Screen 

An Ok icon is visible at the top right of every screen (see fig 3.5.1). Tapping on this button 
closes the current screen and returns to the previous screen. 

Figure 3.5.1 
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3.6 List Views 

When using the system there are occasions when a list of data items will be shown on the 
screen e.g. a list of rooms. Highlighting one of the items in the list, with the stylus, makes it 
the active selection (see fig 3.6.1). 

 

Figure 3.6.1 

If the list has a scroll bar down the right hand side, it indicates that there are more entries on 
this list than can be shown. Pressing the arrow on the scroll bar will move the list up or down 
(depending on the way the arrow is pointing). 

 

3.7 Text Entry using Transcriber 

Transcriber recognises words and phrases written in cursive, print, mixed print, cursive styles, 
numbers and combinations of symbols. This method allows you write anywhere on the screen 
using the stylus. To access this method, click on the black triangle in the bottom right of the 
screen. This will list the different methods available for entering text, select transcriber with the 
stylus. 
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3.8 Text Entry with the Keyboard 

An alternative to using transcriber is to use the inbuilt pop-up keyboard. To access the 
keyboard, click on the black triangle in the bottom right of the screen. This will list the 
different methods available for entering text, select keyboard with the stylus (see fig 3.8.1). 

This will load the keyboard. Enter text by tapping on the required letter using the stylus.  

Figure 3.8.1 

It is also possible to access numbers and special characters through this mechanism by 
selecting the 123 key in the top left hand corner of the keyboard. 

To hide the keyboard, click the symbol in the bottom right hand corner. 
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44 HHaazzaarrdd SSuurrvveeyyss

4.1 Introduction 

Hazard Surveys are carried out at Block level.  When created, a Hazard Survey form holds all 
survey details and hazard items recorded during the survey. 

4.2 Creating a Hazard Survey 

Select the Hazard Type by operating the plus button to the left of the Hazards module on the 
property Tree. Select the Surveys folder via the plus button for the hazard type (e.g. asbestos). 
Highlight the A - New status level, then with the mouse in the right pane, right click the mouse 
and select New from the context sensitive menu (see figure 4.2.1). 

Figure 4.2.1 

Using the plus buttons, select a Block from the tree on the Select Block form via the plus 
buttons and click OK. This will activate the Hazard Survey form (see figure 4.2.2).  

Note: Use the Search field at the bottom of the form by entering your criteria and selecting the 
ellipsis button. 
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Figure 4.2.2 

 

On the Details tab enter the Survey Ref. This field is auto-populated with (NEW) when a new 
hazard survey is created. Each survey must have a unique survey ref. and is a mandatory field. 
Enter a Client Ref No if desired, this is optional.  

Choose a Survey Type from the pick list. This is also a mandatory field. Select a Surveyor via 
the ellipsis button. This is a mandatory field. Select a Sampler if desired.  

The Survey Date will be automatically populated with today’s date. This can be changed to 
another date. If the date is left blank it will be automatically defaulted to today’s date. Enter 
any notes in the Comments text box. 

Note: All the mandatory fields must be completed before a survey can be sent  to the 
handheld. However once sent to the handheld the fields can be amended and then retrieved 
back to the PC (see section 6.1 for amending the survey details and section 10 for retrieving 
surveys). 

4.3 Creating Multiple Surveys 

Surveys can be created in multiple to make the process of sending the surveys to the handhelds 
quicker. Surveys can also be sent to the handhelds in multiple, see section 5 for more details 
on how to do this. 

To create multiple surveys, select New to open the Select Block form (as explained in section 
4.2). Use the plus buttons to expand the levels to see the blocks for the properties that the 
surveys are to be created for. Then while holding down the Ctrl key on the keyboard use the 
mouse to select each block. 

Figure 4.3.1 shows an example of multi-selected blocks. Click OK to create the surveys. A 
message will confirm how many surveys have been created. All surveys created in a batch will 
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have the Survey Ref. (New). However, these will need to be changed to a unique number before 
the surveys can be sent down to the handhelds. 

Figure 4.3.1 

4.4 History Tab 

The History tab (fig 4.4.1) records when the survey is amended. For example, when the date 
and time that the survey record was created. It also records when No Access or No Hazard 
records are added or removed and for which room. This enables rooms to be audited, e.g. if a 
room once had no access, but now a Hazard has been recorded against it, this will be 
detectable on the History tab. 
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Figure 4.4.1 

Note: If a survey with existing data (e.g. Hazard, No Hazard and No Access records) has been 
sent down to the handheld to be updated then any amendments made to these records will be 
shown on the History tab on the PC. For example if a No Access record is cleared on the 
handheld and updated with a hazard the room removed will be on the History tab. 

4.5 Editing a Hazard Survey 

To edit a Hazard Survey, select the survey from the list view on the main tf. facility screen. 
Highlight the survey in the right pane, right click the mouse and select Edit from the context 
sensitive menu. This will open the Hazard Survey form. 

When amendments to the data are made the Save button is enabled. Make the necessary 
changes to the form and operate the Save button. Close the form. 

4.6 Deleting a Hazard Survey 

To delete a Hazard Survey, select the item from the status on the list view. Right click the 
mouse and select Delete from the context sensitive menu. 

Note: A Hazard Survey cannot be deleted until all the records attached to the survey have 
been deleted. 
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55 SSeennddiinngg HHaazzaarrdd SSuurrvveeyyss

Before the Hazards module can be used on the handheld, Hazard Surveys need to be sent 
from the main application. Once the survey(s) have been created at the A – New status (see 
section 4.2) they can be sent to the handheld. 

IMPORTANT: When surveys are sent to the handhelds, it will overwrite any surveys currently on 
the handheld. Make sure any surveys have been retrieved or backed-up (see sections 9 and 10) 
before sending further surveys. Also when surveys have been sent to the handheld, do not 
under any circumstances delete the survey on the PC or the survey will not be able to be 
retrieved from the handheld. 

 
Make sure the handheld is connected. Highlight the survey(s) in the right hand pane, then with 
the mouse in the right hand pane, right click the mouse and select Send to Handheld from the 
context sensitive menu (see figure 5.1) 

Figure 5.1 

It is possible to send more than one survey down to the handheld at any one time. To do this, 
use the Ctrl or Shift keys on the keyboard to highlight the surveys then select the Send to 
Handheld from the context sensitive menu. 

Hint 

Holding down the Ctrl key whilst selecting surveys from the list enables surveys to be multi-
selected one by one, whilst holding down the Shift key will select a group of surveys. For 
example select a survey then select another further down the list and all the surveys between 
the two will also be selected. 
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The transfer will take place automatically first on the PC and then on the handheld. All surveys 
sent to the handheld will be apparent on the handheld. 

Note: Whenever new surveys are transferred to the handheld this will overwrite any existing 
data. Any surveys on the handheld should be backed up (see section 9) or be retrieved back on 
to the PC before anymore are sent down. 

 
Any Surveys sent to the handheld will automatically move from the A – New status folder on 
the PC to B – Issued.

Note: It is possible to send surveys to the handheld, which already contain data (e.g. Hazard,
No Hazard and No Access records) so that the survey(s) can be updated. 
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66 PPeerrffoorrmmiinngg HHaazzaarrdd SSuurrvveeyyss

6.1 Starting a Survey 

When the survey(s) have been transferred the Hazards application will be open on the 
handheld and the Start button active (see figure 6.1.1). The application can also be accessed 
on the handheld via the Start button on the Programs screen. When accessing the program in 
this way, tap on the tfHazard icon to open the application. 

Figure 6.1.1 

Tap on the Start button and any surveys on the handheld will be displayed on the Survey List 
screen (figure 6.1.2). 

Figure 6.1.2 
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Highlight the survey from the list by tapping on it with the stylus before selecting any options. 
Once a survey is highlighted, it is then possible to add hazard details to the survey and to add 
or amend the survey details. When a Survey is highlighted the school and the block codes and 
descriptions will be displayed towards the bottom of the screen. 
 

6.1.1 Survey Detail 

To add or amend the survey details tap on the Detail button on the survey list screen. This will 
activate the Survey Detail screen (see figure 6.1.3). 

Figure 6.1.3 

 

This screen will display any information entered on to the Survey before it was sent down to the 
handheld. Data can be entered or amended on the Details, Comments or Comments 2 tabs. 
When the screen has been updated tap on the Save icon at the bottom left of the screen, then 
tap the Ok button to leave the screen and return to the Survey List.
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6.1.2 Room List 

Highlight a survey then tap on the Room(s) button on the Survey List screen to activate the 
Rooms List (see figure 6.1.4). 

Figure 6.1.4 

 

The list displays every room within the block that has been selected. The room data is 
automatically transferred to the handheld when the survey is sent down. 

The Room List also indicates any hazard details recorded against the room: Hazard (see 
section 6.2), No Hazard (see section 6.3) and No Access (see section 6.4). 

Each record is indicated by an icon against the room: 

Hazard: 

No Hazard: 

No Access: 
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6.1.3 Room Filter 

 
Every room in the block is automatically displayed, but the list can be filtered either by 
selecting the room Type from the pick list or entering the room code in the Code field. Once 
the criteria has been entered, tap on the Filter button and the room list will display the 
selection. 

From the Room List it is possible to add Hazard details (see sections 6.2 – 6.4. It is also 
possible to add new rooms or to amend existing room data (see section 8). 

To add a Hazard to a room, tap on a Survey on the Survey List then on the Rooms button to 
activate the Rooms List (shown in figure 6.1.4). Section 6.2 explains how to create a Hazard 
against a room. 

To exit the Room List Tap on the Ok icon to return to the Survey List.

6.1.4 Hazard List 

Highlight a survey and then tap on the Hazards button to activate the Hazard List (see figure 
6.1.5). This list will show any hazards that have been recorded against the survey. It is also 
possible to add hazards from this screen (see section 6.2 on how to do this).  

Figure 6.1.5 

Each Hazard on the list can be identified by a icon. 

To exit the Hazard List tap on the Ok icon to return to the Survey List.

6.1.5 Deleting a Hazard Survey 
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To delete a Survey select a survey from the Survey List, then tap on the File menu on the 
toolbar. Choose the Delete Survey option from the menu. Alternatively hold down the stylus 
on a Survey on the Survey List and select Delete Survey from the Context Sensitive Menu 
(figure 6.1.6). 

Figure 6.1.6 

Note: Only surveys created on the handheld can be deleted. It is not possible to delete surveys 
that have been sent down to the handheld. See section 7.2 for creating surveys on the 
handheld. 
 

6.2 Adding a Hazard 

There are two ways to add a hazard to a survey on the handheld. The first way is to enter 
hazards on a room-by-room basis. The second is to add a hazard via the Hazard List:

To add a hazard to a room, tap on a survey on the Survey List then on the Rooms button to 
activate the Rooms List (shown in figure 6.1.4). 

Tap on a room and then select the New Hazard button. 

To add a Hazard via the Hazard List select the Hazards button from the Hazard Survey List, 
which will produce the Hazard List (shown in figure 6.1.5). Tap on the File menu on the 
toolbar and select New.

Either of the above options will display the Hazard screen (figure 6.2.1). 
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Figure 6.2.1 

6.2.1 Hazard Details 

 
Select a room via the ellipsis button. Tap on a room and then the Select button. This is an 
optional field. If the Hazard has been added via the rooms list then this field will be 
automatically populated with the room. This field can be left blank and then the Hazard will be 
recorded against the block itself instead of an individual room. 

The ID will be automatically populated by a number in sequence with any other Hazards that 
have been recorded. This is an optional field and can be amended or deleted. 

Tap on the checkbox if a Label has been attached. Enter a Description of the hazard. This is 
an optional field. 

The Status field will automatically be set to Presumed but may be changed by selecting 
another option from the pick list. Enter a Position if desired. This is an optional field. 

Once the information is completed on the Details tab, tap on the Save icon at the bottom left 
of the screen. 
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6.2.2 Risk 

 

Tap on the Risk tab to enter details regarding the Risk Assessment (figure 6.2.4). 

 

Figure 6.2.4 

 

Tap on a Category on the list and then choose a Sub-Category from the pick list. Selecting 
Sub-Categories is optional. Each category determines which Sub-Categories appear in the pick 
list. 

The Overall Assessment at the top of the screen will be automatically populated dependent on 
the sub-categories that have been selected. Enter any Comments if necessary then tap of the 
Save Icon to save the details. 
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6.2.3 Material 

 

Tap on the Material tab to enter additional details of the Hazard (see figure 6.2.3). All fields on 
this tab are optional. 

Figure 6.2.3 

Enter a Quantity and a unit of measure from the pick list if desired. Select a Material from the 
pick list. Only when a Material is chosen will the Sub-Type list be populated. The Sub-Type list 
is dependant on which option is selected from the Material pick list.  

Enter any Comments if necessary. Once all data has been entered on the tab, tap on the Save 
icon. 
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6.2.4 Sample 

 
The Sample tab (fig 6.2.2) allows data regarding the sample to be entered (if not taken on site 
then this data can be updated when the survey has been retrieved on to the PC). 

Figure 6.2.2 

All fields on this tab are optional, however the Sample Required field must have a value and is 
defaulted to No unless it is updated.  

A Sample Required (Yes, No, Taken) can be selected via the pick list. Enter a Sample ID and 
Origin if desired. Choose a Sampled On date via the pick list, which will activate a calendar to 
allow a date to be chosen. A Sampled By can be chosen from the pick list. If any fields have 
been amended on this tab, tap on the Save button to save the changes. 

 



© The Technology Forge 2007  Page 27 of 48 
Hazards Handheld User  Manual 

6.2.5 Action 

 

Tapping with the stylus on the Action tab will list any Actions recorded against the Hazard 
(see figure 6.2.5). 

Figure 6.2.5 

To add an Action, tap on the New button. This will activate the Hazard Action screen ([figure 
6.2.6). 
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Figure 6.2.6  

Select an Action from the pick list (mandatory). Select a Target Date from the pick list 
(optional). This will activate a calendar to choose a date (see figure 6.2.7). 

Figure 6.2.7 

The remaining fields are optional. Select an appropriate Price Band from the pick list and enter 
a Cost, if necessary. Choose a Priority, enter a Responsible Party and choose the action 
Owner if desired. 

It is also possible to enter details once the action has been carried out. Again these fields are 
entirely optional, but the Completed checkbox may be ticked and an Actual date for the 
completion can be selected from the pick list. 
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6.2.6 Comments Tab 

 
Enter any comments regarding the action in the textbox on the Comments tab (figure 6.2.8). 

Figure 6.2.8 

 

When all the required action details have been entered tap on the Save icon to save the screen 
and then tap on the OK button to return to the Action tab. When the action is saved it will be 
given an automatic Action ID, which will be updated when retrieved to the PC to comply with 
the ID sequence set on the PC. 
 

6.2.7 Editing an Action 

 

To edit an action, highlight the action from the list on the Action tab of the Hazard form. Tap 
on the Edit button and the Hazard Action form (shown in figure 6.2.5) will be activated. Make 
the necessary amendments then tap on the Save Icon to save the changes. Tap on the Ok 
button to return to the Action tab of the Hazard form. 
 

6.2.8 Deleting an Action 

 
To delete an action, highlight the action from the list on the Action tab of the Hazard form. 
Tap on the Delete button and a message will ask to confirm the deletion. Select Yes and the 
action will be deleted. 
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6.2.9 User 

The User tab on the Hazard screen lists all the user defined fields (figure 6.2.9). These can be 
created on the PC by the System Administrator. 

Figure 6.2.9 

6.2.10 Copying a Hazard 

 

It is possible to copy an existing Hazard Item to create a new one. This makes the process of 
entering Hazards quicker than entering a new Hazard each time. 

To make a copy go to the Hazard List (from the Survey List screen) and highlight the Hazard 
that is to be copied. Select the file menu and tap on the Copy option (see fig 6.2.10). A Copy of 
the Hazard will then be displayed. Enter/Amend the data on the tabs as necessary. Once this 
copy has been saved it will be added as a new hazard along with the original on the Hazard list. 
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6.2.11 Editing a Hazard 

 
To edit a hazard, select make sure the correct survey has been selected from the Survey List 
(shown in figure 6.1.2). Tap on the Hazards button to list all the hazards attached to the 
survey. To edit a hazard either tap on the File menu and select Edit or alternatively hold the 
stylus down on the hazard and select Edit from the context sensitive menu (figure 6.2.11) 

Figure 6.2.11 

Either option will produce the Hazard screen. Amend the data on the appropriate tabs and then 
tap on the Save icon to save the form. Tab Ok to return to the Hazard List. Then tap of Ok 
again to return to the Survey List.

6.2.12 Deleting a Hazard 
 

To delete a hazard, select make sure the correct survey has been selected from the Survey List 
(shown in figure 6.1.2). Tap on the Hazards button to list all the hazards attached to the 
Survey. To delete a Hazard either tap on the File menu and select Delete or alternatively hold 
the stylus down on the hazard and select Delete from the context sensitive menu (figure 
6.2.10). A message will ask to confirm deletion. Say Yes and the Hazard record will be deleted. 

A Hazard can also be deleted at any stage of recording the hazard. When on the Hazard screen 
a Delete icon will be apparent on the toolbar to the right of the Save icon (shown in Figure 
6.2.8). Tap on the Delete button during any stage on the Hazard screen and a message will 
ask to confirm deletion. Say Yes and the hazard record will be deleted. 

 



© The Technology Forge 2007  Page 32 of 48 
Hazards Handheld User  Manual 

6.3 Adding No Hazard Records 

It may be possible when carrying out the survey to identify rooms where it is certain that there 
is no hazard. To add a No Hazard record highlight the survey on the Survey List screen and 
select the Room(s) button (as shown in figure 6.1.2). Tap on the room with no hazard then tap 
on the No Hazard button to activate the No Hazard screen figure (6.3.1). 

Figure 6.3.1 

The Room code and Room Description will be automatically populated. Enter any Comments 
if desired. This is an optional field. Tap on the Ok button on the screen, and it will return to the 
Room list. A No Hazard record is indicated by the following icon .

6.3.1 Deleting a No Hazard record 

 
To delete a No Hazard record, tap on the room from the list. Then either tap on the File menu 
and select Clear Status or hold down the stylus and select Clear Status from the context 
sensitive menu. A message will ask to confirm the deletion. Say Yes and the status of No 
Hazard on the room will be deleted.  

Note: If the Survey had any No Hazard records against it before it was sent down to the 
handheld, then it will be noted on the History tab on the PC that the No Hazard record has 
been deleted on the handheld (see section 4.4). 
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6.4 Adding No Access Records 

It may be possible when carrying out the survey to record rooms where there is no access. To 
add a No Access record highlight the survey on the Survey List screen and select the Room(s) 
button (as shown in figure 6.1.2). Tap on the room with no access then tap on the No Access 
button to activate the No Access screen figure (6.4.1). 

Figure 6.4.1 

The Room code and Room Description will be automatically populated. Enter any Comments 
if desired. This is an optional field. Tap on the Ok button on the screen, and it will return to the 

Room list. A No Access record is indicated by the following icon .
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6.4.1 Inaccessible Areas 

 
It is also possible to record areas within a room, such as a locked cupboard on the survey.  

Highlight the survey from the Room(s) list and then select the Room(s) button. Tap on the file 
menu and select Inaccessible Areas. This will activate the Inaccessible Areas screen (figure 
6.4.2). 

Figure 6.4.2 

Enter the details as appropriate in the textbox then tap on the OK button. This will return to 
the Room(s) List.

Alternatively, highlight the survey from the Survey List screen then tap on the Details button. 
This will activate the Survey Detail screen. Tap on the Comments tab and complete the 
Inaccessible Areas textbox as necessary. 

Entering the Inaccessible Areas data in both of the above locations will be transferred to the 
other. 
 

6.4.2 Deleting a No Access record 

 
To delete a No Access record, tap on the room from the list. Then either tap on the File menu 
and select Clear Status or hold down the stylus and select Clear Status from the context 
sensitive menu. A message will ask to confirm the deletion. Say Yes and the status of No 
Access on the room will be deleted. 

Note: If the Survey had any No Access records against it before it was sent down to the 
handheld, then it will be noted on the History tab on the PC that the No Hazard record has 
been deleted on the handheld (see section 4.4). 
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77 BBlloocckkss

7.1 Amending Block Details 

When performing a hazard survey, it is possible to amend the details of the block that is being 
surveyed. 

To edit a block, tap on the block from the Survey List, then tap on the File menu and choose 
the Edit Block option (see figure 7.1.1). 

Figure 7.1.1 

The Block Details screen will be activated (see figure 7.1.2). The screen will show the details of 
the Block, which were sent down to the handheld when the survey(s) were transferred. 
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Figure 7.1.2 

Amend the details as necessary. Tap on the Save icon to save the changes, then on the Ok icon 
at the top right of the screen to return to the Survey List. 

Any changes will be retrieved into the main database on the PC (see section on Retrieving 
Surveys. 
 

7.2 Creating a New Block 

When on site with the handheld, it may be necessary to create a New Block to survey. To do 
this tap on the File menu and then on New Block on the Survey List tab (shown in figure 
7.1.1). This will activate the Block Details form (shown in figure 7.1.2). 

Enter a Code and a Name for the Block. These are both mandatory fields. Select the remaining 
fields from the pick lists, if desired. All these fields are optional. 

Tap on the Save icon to save the new block and then on the Ok button to return to the Survey 
List. When Ok is tapped, a message will confirm that a new survey has been created and it will 
auto-number this survey with a survey ref. Tap the Ok button on the message box. The Survey 
Ref can be changed on the PC, once the survey(s) have been retrieved (see section on 
Retrieving Surveys). 

 

7.2.1 Surveying a New Block 

 
There are two ways to add a hazard to a new block: 

If hazards are to be recorded against rooms, the rooms will need to be created before hazards 
can be added. Hazards can then be added via the rooms list (sections 8.2 and 8.3 explain how 
to add rooms via the Room(s) List). 

Alternatively, Hazards can be added via the Hazards button on the Survey List and either 
assigned to a room or against the Block (section 6.2 explains how to do this). 

Either Way, it is mandatory that the Survey Details are entered before a Hazard is created 
against a new Block. To ensure that this data is entered a message will be produced and a 
Hazard cannot be added until the required information (Survey Type and Surveyor) have been 
inputted. See section 6.1 on adding the Survey Details.

For adding No Hazard and No Access records against a new block, rooms must be created, as 
it is mandatory to select a room when adding either of these records. 
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7.3 Deleting a Block 

It is not possible to delete an existing block on the handheld. If a new block is created (see 
above) then it can be deleted by deleting the survey (see section 4.6 on how to do this). 

Note: To delete a survey created on the handheld, records against the block (new Rooms,
Hazard, No Hazard and No Access records) must be deleted first. 
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88 RRoooommss

8.1 Amending Room Details 

When performing a hazard survey, it is possible to amend the details of the block that is being 
surveyed. 

To amend the details of a room tap on the Room(s) button on the Survey List screen (shown in 
figure 6.1.2). This will activate the Room List (shown in figure 6.1.4). 

Tap on a room then either select Edit Room from the File menu or hold down the stylus on a 
room on the list and select Edit Room from the context sensitive menu. Either option will 
activate the Room Details screen (figure 8.1.1). 

Figure 8.1.1 

Amend the details as appropriate then tap on the Save icon to save the changes. Tap on the Ok 
button to return to the Room List.

8.2 Creating a New Room 

When on site with the handheld, it may be necessary to create a new room to record hazard 
details against. Either select New Room from the File menu or hold down the stylus on a room 
on the list and select New Room from the context sensitive menu. Either option will activate 
the Room Details screen (shown in figure 8.1.1).  

Enter a Code, Description and Room Type. These are mandatory fields. Enter a Floor Area is 
desired. This is optional. Save the room by tapping on the Save icon, then tap on the Ok button 
to return to the Room List.
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8.3 Creating a New Room Range 

If there are many rooms to create for the block that is to be surveyed, the New Rooms Range 
allows multiple rooms of the same type to be created. To create a new room range, either 
select New Room Range from the File menu or hold down the stylus on a room on the list and 
select New Room Range from the context sensitive menu. Either option will activate the New 
Room Range screen (figure 8.3.1). 

 

Figure 8.3.1 

The Prefix field will be automatically populated with the Code for the Building and the Mask 
field with three zeros. This will mean that any rooms that are created in this range will all have 
a code beginning with the prefix and then be three digits long (e.g. ABC001). 

The Prefix and the Mask fields can be changed. Only zeros can be entered into the Mask field. 
The Pad Nos. checkbox is automatically ticked to indicate that the Mask is in use. If the mask 
is not required un-tick the box. The Prefix can also be deleted if required.  

Enter a Start and an End number for the range of rooms you wish to create. These fields will be 
automatically populated with 1 and 10 respectively. 

Select a Type from the pick list. This is a mandatory field and will be applied to all the rooms 
created in the range. The types can be amended if necessary once the rooms have been created 
(see section 8.1). 

When satisfied with the selection, tap on the Preview button. This will activate the Room List 
tab and show a preview of the rooms (figure 8.3.2). To create the Rooms tap on the Create 
Room(S) button. The selection can be changed by tapping on the Details tab. 

 



© The Technology Forge 2007  Page 40 of 48 
Hazards Handheld User  Manual 

Figure 8.3.2 

 

When the rooms are created a message will confirm how many rooms have been added. Tap on 
the Ok button to return to the Room List and the new room(s) will be added. The room details 
can then be amended if necessary (see section 8.1). 

 

8.4 Deleting a Room 

A room can only be deleted if it has been created on the handheld. To delete a room either 
select Delete Room from the File menu or highlight a room hold down the stylus and select 
Delete Room from the context Sensitive menu. 
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99 BBaacckkiinngg--UUpp aanndd RReessttoorriinngg DDaattaa oonn tthhee HHaannddhheelldd

There are two ways of backing up and restoring data on the handheld: on the file store of the 
handheld, or on an external memory card (e.g. Secure Digital or Compact Flash Jacket). 

Both operate using the same method. 

Hazard data can be backed up or restored via the Tools menu on the Survey List screen (shown 
in figure 6.1.2). 
 

9.1 Backing-Up the data 

Select Backup from the Tools menu on the Survey List screen. This will load the Backup Data 
screen (figure 9.1.1) 

Figure 9.1.1 

 

Select an option (e.g. File Store or Storage Card) from the pick list and press Backup. Once 
the backup is complete a warning message will be displayed indicating that the backup was 
successful. Note that 3 files will be saved but stored under one file name. 

Once the data has been backed up it will be stored in the File Store or external memory card 
and given the date and time that the backup took place. Click OK to return the Hazard 
program.  
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9.2 Restoring Data  

Select Restore from the Tools menu on the Survey List screen. This will load the Restore Data 
screen (figure 9.2.1). 

 

Figure 9.2.1 

 

Select Storage Card from the pick list. A list of all data that has been backed up will be 
displayed. Highlight the data you wish to restore and press the Restore button. A warning 
message will be displayed asking you to confirm you wish to overwrite any existing data on the 
handheld. Click Yes to proceed.  

A warning message will be displayed confirming that the data (consisting of 3 files) has been 
successfully restored. Click OK to return the Hazard program. 

To remove data from the file store or memory card highlight the data and press the Delete 
button. 
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1100 RReettrriieevviinngg aa HHaazzaarrdd SSuurrvveeyy

Before retrieving it is important to make sure that the Hazards application has been exited on 
the handheld before the transfer takes place. 

To Retrieve the Hazard Surveys from the handheld, select the B – Issued folder on the PC. With 
the mouse in the right hand pane, right click and select Retrieve From Handheld from the 
context sensitive menu (figure 10.1). 

Figure 10.1 

This will activate the first step of the retrieval wizard (figure 10.2). 

Figure 10.2 
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It is possible to retrieve the data from a file if using the TF web transfer program, however 
when retrieving from the handheld choose the default option (From Handheld Device). Click 
on the Next button to retrieve the surveys. 

Check the handheld is connected properly and then select the Next button. The retrieve 
process will begin on both the PC and the handheld. 

When the exporting process has finished the next step will be activated (figure 10.3). 

 

Figure 10.3 

Step 2 shows all the surveys found on the handheld. This includes any new blocks that have 
also been created, but may not have been surveyed. Any new blocks created will be added to 
the property register. Each survey will have a tick next to it. If you don’t wish to import a survey 
into the database on the PC, un-tick the checkbox and it won’t be imported. 

When new surveys are created on the handhelds they are given an auto-number as a Survey 
Ref. If two or more handhelds have been used to create new blocks they may have been 
assigned the Same Survey Ref on the handhelds. If this is the case, when the surveys from both 
handhelds are retrieved, if a Survey Ref is a duplicate it will be given a new survey ref. A 
message will inform you of the new survey ref. It can then be changed in the survey on the PC, 
if necessary. 

Click on Next. The next Step will show any new blocks created or amended on the handheld 
(figure 10.4) 
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Figure 10.4 

 
There is the option to match any new blocks created on the handheld to an existing block in 
the database on the PC (Match Block). Alternatively select the Create New Block button if it is 
a new block or cancel the screen shown below and the block will be added as a new block once 
the Next button is pressed. 

Return to the Block list to be added and cick on the Update Matched Blocks checkbox to 
import the changes and on the Update Amended Blocks if you wish to import any blocks 
where the details have been amended. 

Click on Next. The next Step will show any new rooms created or amended on the handheld 
(figure 10.5) 
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Figure 10.5 

 
Again there is the option to match any new rooms created on the handheld to an existing room 
in the database on the PC. To do this select a room and then the Match Room button. An 
additional form will be activated and will enable you to match to an existing room. 

If Rooms are not matched to existing rooms they will automatically be created as new rooms: 

Tick on the Update Matched Rooms checkbox to import the changes and on the Update 
Amended Rooms if you wish to import any rooms where the details have been amended. 

Click on Next and the data will be imported into the database on the PC (Figure 10.6). 
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Figure 10.6 

 
Press Finish once all the options have completed (Done). If any blocks or rooms have been 
added or amended, check these details in the Property Register. Also check the Surveys (the 
survey refs may need updating if there were new surveys created on the handheld). 

Once on the PC the records collected via the handheld will be displayed on the appropriate tabs 
(see section 4 and the Hazards Module Manual for more details). The data can be checked and 
amended on the PC after the survey(s) have been retrieved.
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