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cont act   t he  aut hor  by emai l  and t he f i x or  f eat ur e wi l l  be most
cer t ai nl y i nt egr at ed i nt o t he  of f i c i al  r el ease of  LabJ.

However  t he LabJ package cannot  be di st r i but ed as par t  of  anot her
pr ogr am package.  Par t i cul ar l y t he aut hor  s t r i c t l y  f or bi d t he  MDL
I nf or mat i on Syst ems,  I nc.  and i t s af f i l i at ed compani es t o i ncl ude
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i n pr ovi di ng t he LabJ as i nt egr at ed par t  of  anot her  package,  t hi s
must  be negot i at ed.

The  aut hor  assumes no r esponsi bi l i t y f or  er r or s or  mal f unct i ons,
or  f or  damages r esul t i ng f r om t he use of  t he pr ogr ams.

* )    LabJ   r equi r es   use   of    pr opr i et ar y  sof t war e  pr ogr ams
I SI S( t m) / Dr aw and I SI S( t m) / Base  f r om  MDL  I nf or mat i on  Syst ems,
I nc.  ( " MDL" ) ,  whi ch ar e avai l abl e under  t he appr opr i at e l i censi ng
agr eement s f r om MDL f r om ht t p: / / www. mdl i . com.   MDL and i t s af f i l -
i at ed compani es ar e i n no way associ at ed wi t h,  nor  do any of  t hem
endor se LabJ,  nor  does your  use of  I SI S/ Dr aw and/ or  I SI S/ Base i m-
pl y any such associ at i on or  endor sement .

Li nux  i s  a  r egi st er ed  t r ademar k of  Li nus Tor val ds;   MDL i s a
r egi st er ed t r ademar k i n t he Uni t ed St at es,  and I SI S i s  a  t r ade-
mar k  of   MDL I nf or mat i on Syst ems,  I nc. ;   I SI S/ Dr aw and I SI S/ Base
ar e ( c)  MDL I nf or mat i on Syst ems,  I nc.   Al l  Ri ght s Reser ved.
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Introduction
LabJ (Laboratory Journal, electronic laboratory notebook, ELN)
stores chemical information and assists in planning chemical
reactions. It calculates information such as molecular weights,
moles, reactant amounts and volumes, percent yields and more.
Notes (procedures, results, references, comments, graphics, etc.)
can be attached to the LabJ records. LabJ can be also used to
store various data of synthesized compounds, such as melting
and boiling points, spectral data as well as unlimited number of
custom fields for your specific needs.

LabJ is realized as a database file (labj.db) for MDL
ISIS/Base™ program. Reaction drawings and (sub)structure
searches use the ISIS/Draw™ module.

Description Following is a brief overview of the most prominent features of
LabJ:

� LabJ is a calculations and database program (a.k.a
electronic laboratory notebook, ELN) for organic
chemists. It can be used, e.g. in:
✴ classical organic synthesis (incl. total synthesis)
✴ screening for catalysts, optimization, etc.
✴ parallel and automated synthesis
✴ solid support synthesis� Chemical reactions can be easily introduced graphically
by drawing them in ISIS/Draw™ module.� LabJ eliminates most of the tedious work of calculating
chemical reaction data such as molecular formulas and
weights of reactants and products, amounts and volumes
of the reactants and yields of products. Calculations are
based on graphical reaction and choosed scale, stoichi-
ometry and purity of reagents. Volumes of reactants are
calculated based on either reagents’ density or molarity
(M [mol/L]).� Because LabJ uses ISIS/Base™ program as a "database
engine" all records can be easily stored and searched. If
you want to re-examine or scale-up a reaction simply
retrieve an existing record, duplicate it, change one or
more values (incl. reagents), and everything is recalcu-
lated.� All records in a LabJ database are sequenced in numeric
order based on reaction number (e.g. KG-1023).
Simillary, all products (and fractions) can be logically
labelled based on reaction number (e.g. KG-1023-1-3).� You can browse through the database page by page or
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search for a record by reaction number, reaction
scheme, (sub)structure, analytical data, procedure,
keywords and much more. This search tool generates a
list that can be browsed, printed (as separated pages or
in tabular form) or saved as a new LabJ database.� LabJ prints records in a form of Reaction Page, Report
Page, Tabular Form, and various Analytical Forms (e.g.
for IR, NMR and MS departments), as well as virtually
unlimited number of custom forms for your specific
needs.

Bugs LabJ was originally written for my own use and a lot of it is
messy, so ideas on how to clean it up would be great. You are
welcome to read the database structure (source code of LabJ)
and to try to modify it and save as your own LabJ Database.
Please send bug descriptions, suggestions, new LabJ files or
successful stories to grela@technologist.com (cf.
Copyright)

Copyright This program is free software; you can redistribute it and/or
modify it under the terms of the GNU General Public License
as published by the Free Software Foundation; either version 2
of the License, or (at your option) any later version.
This program is distributed in the hope that it will be useful but WITHOUT
ANY WARRANTY; without even the implied warranty of MERCHANT-
ABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
General Public License for more details. You should have received a copy
of the GNU General Public License along with this program; if not, write
to the Free Software Foundation, Inc., 59 Temple Place, Suite 330, Boston,
MA 02111-1307, USA.

Installation

System Requirements For using LabJ program the ISIS/Desktop™ (ISIS/Base™ and
ISIS/Draw™) software package is needed. Please contact MDL
Information Systems, Inc. for more information.
Currently, you can use LabJ with ISIS/Base™ 1.x and 2.x
(recommended) for Microsoft Windows 3.x, 95, 98, 2000 and
NT, Apple Macintosh and IRIX SGI. It is also possible to use
LabJ under Linux with Microsoft Windows emulator, such as
WABI™ and Win4Lin™.

Download The newest version of the package can be downloaded from
http://zinc.ichf.edu.pl/labj/.
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Installation � Get "labj1x.zip" (for ISIS/Base 1.x) or "labj2x.zip" (for
ISIS/Base 2.x) from http://zinc.ichf.edu.pl/labj/. � Use "unzip *.zip" command (DOS) to extract the
"labj.db" file from the archive. Alternatively you can
use any GUI program, like WinZip (Windows) to extract
the archive file.� Start ISIS/Base program and open the "labj.db" file.

Using LabJ

A Brief Lesson This chapter explains how to use LabJ on your computer:

� Opening the labj.db file.� Retrieving existing records� Browsing records� Retrieving forms

Use this procedure to open LabJ:

� Start ISIS/Base.� Choose File > Open Database.� Change to the directory (Mac=folder) where the labj.db
file is located.� Click the name of the labj.db (Mac=labj) file to open.� Click OK (Mac=Open).

You will see a default  form in the ISIS/Base window. A form
is required for searching or to register data in the database. In
LabJ electronic notebook a form called “DATA INPUT —
MMOLS” is used as a default form. Consult APPENDIX A for
a detailed description of fields in “DATA INPUT” form.

� Choose Search > Retrieve All to retrieve all existing
records. LabJ database contains five sample reactions.
Click the [

�
] [ � ] buttons or use Up and Down cursor keys

to move between records.

For browsing and printing records a separate form is provided,
called “DATA BROWSE”. Consult APPENDIX B for a detailed
description of fields in “DATA BROWSE” form. To retrieve a
form:� Choose File > Open Form.� Click the name of an appropriate form for data entry.
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� (Optional) To make this form the default form you see
when you open the current database, click Set Default
Form.� Click OK. You see the selected form in the window.

Registration of Reac-
tion

This chapter shows you how to register new records or edit
existing records in the laboratory notebook.

To register a new reaction or changes to an existing record in
a LabJ database, you typically complete the following steps in
the order shown:

Hint: Regularly make backups of your LabJ database.

✤ Opening the LabJ database

� Start ISIS/Base. � Open the LabJ database: Choose File > Open Database.� Click labj.db (Mac=labj). The database opens. You see
the default data-entry form in the LabJ database win-
dow.� Choose Search > Retrieve All to retrieve all existing
records

� Use  button to display the last record.

✤ Creating a new record

Before you enter data onto a form, you must create a new
record:

� Click the Update button.� Choose Edit > New Record. ISIS/Base assigns a new
record number that appears in the “ID” box (cf. Figure
1). The ID Number is a unique number that ISIS/Base
automatically assigns when it creates a new record. You
can change the ID number before the record is regis-
tered but not after. For LabJ typical use, do not change
the default ID number.� According to the scale of the planned reaction use
default form “DATA INPUT MMOLS” (for reactions of
scale <0.1 mol) or open a form called “DATA INPUT

MOLS” if reaction scale ≥0.1 mol. See page 3 for how
to open forms.
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✤ Entering a reaction onto the form

In this example, you will calculate the reaction between one
equivalent of phenol and one equivalent of NaH and a slight
excess of allyl bromide (1:1:1.2), producing one equivalent of
corresponding ether in a scale of 1 mmol.

To enter the reaction onto the form:

� Select the box that is connected to the reaction field. It
is the large box on the top, called “REACTION” (Figure
1).� Click the ISIS/Draw Transfer icon at the top of the
ISIS/Base toolbar to start ISIS/Draw. Alternatively, you
can double-click inside the “REACTION” box.� Draw the reaction scheme in ISIS/Draw.

Hint: To learn how to speed-up drawing process consult Help
> ISIS/Draw Contents > QUICK START. See page 12 for details.

� Click the ISIS/Base Transfer icon at the top of the
ISIS/Draw toolbar to transfer the reaction into the
structure box in the ISIS/Base form.� Choose Database > End Update to register the new
record.

You will see a reaction scheme and reagents’ formulas and
formula weights in the ISIS/Base window (Figure 1).

✤ Calculating stoichiometry of the reaction

� Select the spreadsheet that is connected to the stoichi-
ometry of the reagents. It is the first big yellow table,
called “SUBSTRATES” (Figure 1).� Click the first cell in the column called “RATIO”. Type
1 in the first cell of the “RATIO” column. Enter 1 and
1.2 in the second and third cell in this column.

� In this example, you calculate the reaction in a scale of
1 mmol. Click the first cell in the column called
“SCALE”. Type 0.001 in the first cell of the “SCALE”
column. Usually the values used in this column are the
same for all substrates and products and are equal to the
scale of the reaction. Therefore type 0.001 in the
second and third cell in this column.



REACTION

OH

+ NaH +

Br
O

GRL-GA-

# Formula FW Ratio Scale [mol] Quant. [mmol] Th. Weight
[mg]

Pract. Amt.:
[g] or [mL]

g   =1
mL=0

Excess Volume
[mL]

density
[g/mL]

Molarity
[mol/L]

Purity
[%]

Notes

C12H14O 174.24 0 0 1 0 0 100
HNa 24.00 0 0 1 0 0 100

C3H5Br 120.98 0 0 1 0 0 100

# Formula FW Ratio Scale [mol] Th. Yield [mmol] Th. Yield [mg] P. Yield [g] Purity [%] P. Yield [mmol] P. Yield
[%]

Notes

C15H18O 214.31 0 0 100 0 0

DATE

LabJournal v. 2.3.1 (c) K. Grela 1996-2000 Electronic Laboratory Notebook-- Data Input Form  - MMOLS --

KEYWORDS

PGE2
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ID

104
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Figure 1.

Hint. To speed-up typing you can use Edit > Copy and Paste
from the menu, or [Ctrl+C], [Ctrl+V] from the keyboard.

� Select the spreadsheet connected to the stoichiometry of
the products. It is the second yellow table, called
“PRODUCTS” (Figure 1).� Click the first cell in the column called “RATIO”. Type
1.

� Select the first cell in the column called “SCALE”. Type
0.001

� Choose Database > End Update to update the new data
into the LabJ.

You will see amounts of reagents and product(s) in the
“QUANT.” (= calculated amounts in millimols), “TH. WEIGHT”
(= calculated amounts in milligrams), and “TH. YIELD” (= yield
of theory) columns (Figure 2). 



# Formula FW Ratio Scale [mol] Quant. [mmol] Th. Weight
[mg]

Pract. Amt.:
[g] or [mL]

g   =1
mL=0

Excess Volume
[mL]

density
[g/mL]

Molarity
[mol/L]

Purity
[%]

Notes

C12H14O 174.24 1.000 0.001000000 1.00000 174.24 1 0 0 100
HNa 24.00 1.000 0.001000000 1.00000 24.00 1 0 0 100

C3H5Br 120.98 1.200 0.001000000 1.20000 145.18 1 0 0 100

# Formula FW Ratio Scale [mol] Th. Yield [mmol] Th. Yield [mg] P. Yield [g] Purity [%] P. Yield [mmol] P. Yield
[%]

Notes

C15H18O 214.31 1.000 0.0010000000 1.00000 214.31 100 0 0
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Figure 2.

✤ Calculating amounts of the reagents (incl. reagents
volumes)

� Select the “SUBSTRATES” table.� Click the second cell in the column called “PURITY”. In
this example, the NaH is used as a 40 wt.% suspension
in mineral oil. Therefore type 40 in this cell.

� Click the third cell in the column called “DENSITY”.
Type 1.398 (the density of allyl bromide).

� Choose Database > End Update to update the new data
into the LabJ.

You will see new weight of NaH suspension in the “TH.
WEIGHT” cell and a volume (in mL) of allylbromide in the
“VOLUME” cell (Figure 3).

� Review all of the data for the “DATA INPUT” form and
correct any mistakes. To correct mistakes, click in the
box that contains the error (double-click in case of the
“REACTION” box).

✤ Executing the reaction

Weigh out the reagents and start the reaction. In the event, you
use different amounts of reagents than you calculated before,
you should input the real amounts of reagents used.



# Formula FW Ratio Scale [mol] Quant. [mmol] Th. Weight
[mg]

Pract. Amt.:
[g] or [mL]

g   =1
mL=0

Excess Volume
[mL]

density
[g/mL]

Molarity
[mol/L]

Purity
[%]

Notes

C12H14O 174.24 1.000 0.001000000 1.00000 174.24 1 0 0 100
HNa 24.00 1.000 0.001000000 1.00000 60.00 1 0 0 40.0 Fluka, 40% wt.

C3H5Br 120.98 1.200 0.001000000 1.20000 145.18 1 0 0.104 1.398 100 Aldrich

# Formula FW Ratio Scale [mol] Th. Yield [mmol] Th. Yield [mg] P. Yield [g] Purity [%] P. Yield [mmol] P. Yield
[%]

Notes

C15H18O 214.31 1.000 0.0010000000 1.00000 214.31 100 0 0
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Figure 3.

� Select the “SUBSTRATES” table.� Click the cell in the column called “PRACT. AMT.”. In
this example, type 0.175 in the first cell. That means
that you have used exactly the calculated amount of
phenol.� Click the second cell in the column called “PRACT.
AMT.” Type 0.0650 (you have added a slight excess
of sodium hydride).� Click the third cell in the column called “PRACT. AMT.”
Type 0.1 (allylbromide was added neat by a micro-
syringe). Because the value of 0.1 corresponds to the
volume of allylbromide, you have to change the number
in the next column from 1 to 0 (1=g, 0=mL). 

� Choose Database > End Update to update the new data
into the LabJ.

You will see the calculated excess of the reagents in the
“EXCESS” column (Figure 4).

✤ Finishing the reaction

� Select the box connected to the description of of the
reaction. It is the big box, called “PROCEDURE” (AP-
PENDIX A). Note the reaction conditions, additions of
reagents, temperature etc. Describe the work-up proce-
dure and the isolation and purification of product(s).� Choose Database > End Update to update the new data
into the LabJ.



# Formula FW Ratio Scale [mol] Quant. [mmol] Th. Weight
[mg]

Pract. Amt.:
[g] or [mL]

g   =1
mL=0

Excess Volume
[mL]

density
[g/mL]

Molarity
[mol/L]

Purity
[%]

Notes

C12H14O 174.24 1.000 0.001000000 1.00000 174.24 0.17500 1 1.004 0 100
HNa 24.00 1.000 0.001000000 1.00000 60.00 0.06500 1 1.083 0 40.0 Fluka, 40% wt.

C3H5Br 120.98 1.200 0.001000000 1.20000 145.18 0.10000 0 0.962 0.104 1.398 100 Aldrich

# Formula FW Ratio Scale [mol] Th. Yield [mmol] Th. Yield [mg] P. Yield [g] Purity [%] P. Yield [mmol] P. Yield
[%]

Notes

C15H18O 214.31 1.000 0.0010000000 1.00000 214.31 100 0 0
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Figure 4.

✤ Calculating the yield of product(s) (incl. product purity)

� Select the “PRODUCTS” table.� Click the cell in the “P. YIELD” column. In this exam
ple, the yield of an analytically pure product is 198 mg.
Therefore, type 0.198 in this cell.

� Choose Database > End Update to calculate the yield.

You will see the yield of product (calculated as mmols and %
of theory) in the “P. YIELD” cells (Figure 5).

✤ Tracking the fractions/samples

To describe different fractions obtained during product isolation
and purification you can fill a special table. You can also use
this table to track sample flow  (Figure 6).

� Select the box that is connected to the FRACTIONS field.
It is the large table on the bottom, called “FR. #” (cf. 
APPENDIX A and B).� Choose Edit > New Record. ISIS/Base creates a new sub-
record (row) that appears in the “FR. #” table.� Select the newly created row in this table and type
fraction number and weight, fraction description, etc. � Repeat above steps for each sample/fraction.� Choose Database > End Update to register the new
record (Figure 6).



# Formula FW Ratio Scale [mol] Quant. [mmol] Th. Weight
[mg]

Pract. Amt.:
[g] or [mL]

g   =1
mL=0

Excess Volume
[mL]

density
[g/mL]

Molarity
[mol/L]

Purity
[%]

Notes

C12H14O 174.24 1.000 0.001000000 1.00000 174.24 0.17500 1 1.004 0 100
HNa 24.00 1.000 0.001000000 1.00000 60.00 0.06500 1 1.083 0 40.0 Fluka, 40% wt.

C3H5Br 120.98 1.200 0.001000000 1.20000 145.18 0.10000 0 0.962 0.104 1.398 100 Aldrich

# Formula FW Ratio Scale [mol] Th. Yield [mmol] Th. Yield [mg] P. Yield [g] Purity [%] P. Yield [mmol] P. Yield
[%]

Notes

C15H18O 214.31 1.000 0.0010000000 1.00000 214.31 0.1980 100 0.923895 92
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Figure 5.

Hint: You can delete a existing row in the “FR. #” table:

� Click the row you want to delete.� Choose Edit > Delete Record. ISIS/Base deletes one sub-
record (row).� Choose Database > End Update to update changes.

✤ Inserting additional data

In the sample forms used in the LabJ notebook, each form box
has a label that describes the type of data to enter. To enter
additional data (chemist’s and experiment code, keywords, date,
conditions, and notes) see APPENDIX A and B.

✤ Registering the record into the LabJ database

When you complete the data entry for one reaction, you can
finally register the record into the database.

� Choose Database > End Update. The data is registered as
a new record that can be retrieved in a search.� (Optional) to close the database, choose File > Close
Database.



Fr. # Quant. Descripton Anal. Data, Identification

1 0.198g Fractions 22-29 in column chrom. (hexan:EtOAc 9:1). Pure product. TLC, NMR, MS
SR 50mg GRL-GA-104-01 -> to Sample Repository of MPI
BY 10mg GRL-GA-104-01 -> to Bayer GmbH (Wuppertal) bio
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Figure 6.

Advanced Caution: Make a backup of your LabJ database before you
begin.

Hint: Logging Database Transactions.
Activate the database journal to log transactions for a database
during registration. When you register new records during data
entry, ISIS/Base creates the  log file using the name of the
database with a .log file extension. The  log file is saved in the
same directory (Mac=folder) as the database.  Each transaction
is added to the end of the log file until you delete the file.
View or print the log file using a word processor. 
The ISIS/Base transaction log records database transactions that
occur during registration. The log is a text (ASCII) file that
you can view or print later. The log file records:

� Registration of new records� Updating of existing records� Deletion of existing records� Date and time each operation occurred.

Use this procedure to instruct ISIS/Base to log database
transactions that  occur during registration for the LabJ
database:

� If the LabJ database is open, close the database. To do
so, choose File > Close Database.� Choose File > Configure Database. The File Open dialog
box appears.� Double-click the name “labj.db” (Mac=”labj”).
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� Ensure that the Log database transactions setting is On.� Click OK. 

Backup and delete the transaction-log file after you view or 
print the transactions. Each time that you register data for the
database, information is appended to the end of the file and it
can quickly increase in file size.

Note: Data types.
Each field in the LabJ database has restrictions on the type of
data it stores. If you enter the wrong type of data for a field, a
warning message appears. For example, if you enter text for a
field that expects a number, you see the message "Error in
data format, a (n) Real value was expected." To view the
database fields and their field types, choose Database > View
Definition.

Note: Formula and Molecular Weight.
LabJ automatically calculates data for the “FORMULA” and
Formula Weight (“FW”) boxes when you register the reaction.
For future reference, you can enter a molecular weight instead
of having the program calculate it for you, but you cannot enter
a formula.

Getting Help The ISIS/Desktop online help has detailed examples and
step-by-step instructions to help you complete your tasks in the
LabJ program:

� To use the ISIS/Desktop online help. To access Help,
choose Help > ISIS/Desktop Contents. Then, choose How
to Use ISIS/Desktop Help. This gives you full details on
using the ISIS/Desktop online help.� To learn how to draw. To quickly learn how to draw
structures, reactions, objects, and text for use as search
queries, records in a database, or to insert in a docu-
ment, see Help > ISIS/Draw Contents > QUICK START.� To learn how to search. To see a complete list of all
the searches that you can do in ISIS/Base, see Help >
ISIS/Base Search Types. � To learn about creating and editing forms. To learn
how to create or edit forms to view search results or to
enter data into a form to register as new records in a
database, choose Help > ISIS/Base Contents > Creating and
Editing FORMS.
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� To find out more about ISIS applications. To find
out more about the following ISIS applications:
File-format conversion, ISIS Reaction Database Access
System, SAR Table, or the Add-in Manager, choose
Help > ISIS/Desktop Contents > ISIS Overview and Docu-
mentation.

Searching LabJ

With LabJ you can search for a record by reaction number,
reaction scheme, (sub)structure, analytical data, procedure,
keywords and much more. To see a complete list of all the
searches that you can do in ISIS/Base, see Help > ISIS/Base
Search Types.

Example (searching by reaction/structure):

� Click the Query button (if not highlighted).� (Optional) To remove all data from the form, choose
Edit > Clear Data > Form.� Select the “REACTION” box (if not highlighted).� Do one of the following:
*  Draw a new query.
* Import a query from a rxnfile.*)

* Restore a query that you previously saved as an
object in the database.*)

*) see Help > ISIS/Base Search Types for details (page 12).

To draw a new query:

� Transfer to ISIS/Draw. Select the “REACTION” box.
Click the ISIS/Draw Transfer icon at the top of the
ISIS/Base toolbar to start ISIS/Draw. Alternatively, you
can double-click inside the “REACTION” box.� Draw the query in ISIS/Draw.

Hint: To learn how to speed-up drawing process consult Help
> ISIS/Draw Contents > QUICK START. See page 12 for details.

� Click the ISIS/Base Transfer icon at the top of the
ISIS/Draw toolbar to transfer the molecule into the
reaction box in the ISIS/Base form.�  Choose Search > Current Rxn.
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sample query

sample query

�  Click the Browse mode (if not highlighted). You see
the first record displayed on the boxes and tables in
your form.� To see how many records you retrieved, click the 
“REACTION” box (if not selected) and check the status
bar.� Use [

�
] and [ � ] buttons to display the record that you

want to view.

This search tool generates a list that can be saved, browsed,
printed (as separated pages or in tabular form) or exported as
a new LabJ database.

�  Click the Browse mode (if not highlighted).� Choose List > Save.� Click the List Name box and enter a name for the list
(without a file-name extension).� (Optional) To save the query with the same name as the
list name, you require this setting: Save query under the
same name.� Do one of the following:
* To store the list as a permanent database object, you

require this setting: �  Permanent.
* To delete the list when you close the database, you

require this setting: �  Permanent.� Click OK.

Editing Existing Re
cords

This chapter shows you how to edit or delete existing records
in the LabJ laboratory notebook.

To change an existing record in a LabJ database, you typically
complete the following steps in the order shown:

Hint: Regularly make backups of your LabJ database.

✤ Locating a record to change

� Start ISIS/Base. � Open the LabJ database: Choose File > Open Database.� Click labj.db (Mac=labj). The database opens. You see
the default data-entry form in the LabJ database win-
dow.
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� Do one of the following:
* (Optional) choose Search > Retrieve All to retrieve all

existing records, and then select a record you want
to change using navigation bar.

* (Optional) search for records to change by a specific
reaction, (sub)structure, keywords etc. (see page 13
for reference). To see a complete list of all the
searches that you can do in ISIS/Base, see Help >
ISIS/Base Search Types.

✤ Editing a record

� Click the Update button.� To change a data, click in the box that contains the data
(double-click in case of the “REACTION” box).  See
chapter “Registration of Reaction”, page 4, for more
information.� Choose Database > End Update to update the new record.

✤ Deleting a record

Caution: Make a backup of your LabJ database before you
begin.

� Click the Update button.� Select the “REACTION” box.� Choose Edit > Delete Record. ISIS/Base deletes one
record of your LabJ notebook.

✤ Editing a reaction manually

When you draw a reaction LabJ automatically registers all
substrates and products into the appropriate tables. You can
also manually add or delete a reagent in the  “SUBSTRATES”
spreadsheet.  Similarly you can manually add or delete 
products in the “PRODUCTS” spreadsheet. You will see changes
only in “SUBSTRATES” or “PRODUCTS” tables, but not in the 
“REACTION” box.

Caution: Make a backup of your LabJ database before you
begin.
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To add a new reagent or product:

� Select the row after which you want to add a new sub-
record in the “SUBSTRATES” or “PRODUCTS” spread-
sheet.� Choose Edit > New Record. ISIS/Base creates a new sub-
record (row) that appears in the table.� Select the newly created row and type a Formula
Weight (but not a Formula!), ratio, scale, etc. See
chapter “Registration of Reaction”, page 4, for more
information.� Choose Database > End Update to update the new record.

To delete an existing reagent or product:� Click the row you want to delete in the “SUBSTRATES”
or “PRODUCTS” spreadsheet.� Choose Edit > Delete Record. ISIS/Base deletes one sub-
record (row).� Choose Database > End Update to update changes.

Hint: You can also add or delete rows in the “FR. #” table.  
See chapter “Registration of Reaction”, page 4, for more
information.

✤ Updating the changed record into the LabJ

When you complete data entry for one reaction you can update
the record into the database.

� Choose Database > End Update.� (Optional) to close the database, choose File > Close
Database.

Modifying LabJ
LabJ can display or print records in a form of Reaction Page,
Report Page, Tabular Form, and various Analytical Forms (e.g.
for IR, NMR and MS departments), as well as virtually
unlimited number of custom forms for your specific needs.

To learn how to create or edit forms to view search results or
to enter data into a database, choose Help > ISIS/Base Contents
> Creating and Editing FORMS.
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Figure 7.

Creating and Editing
Forms

This procedure will show you how to create or edit a form.

Hint: You can Undo many of the changes that you make when
you edit a form.

Caution: Make a backup of your LabJ database before you
begin.

� Click the Forms button.� Do one of the following:
* (Optional) create display/ new box, create a new

table, or create a new column in an existing
table.

* (Optional) change the field that is connected to
a box or column.

* (Optional) edit one of the following:
- Boxes, or Columns, or Tables
- Box labels or column headings
- Chemical display of structures
- Text or numeric data display
- Lines or Text
- Entire form� Do one of the following:

* To save a new form or an existing form under
the same name, choose File > Save Form. For
new forms only, enter a name and an optional
description for the form. 

* To save an existing form under a new name,
choose File > Save Form As. Enter a name and an
optional description for the form. � Click OK. The form is saved inside the database and

you will not see it as a separate form file on disk.

Example.

In this example you will change the default chemist’s code
(e.g. “GRL-GA-”, Figure 7). Use this procedure to set a default
string for this code.

� Click the Forms button.� Select a box that is connected to a chemist’s code (field
“Name”).  It is a blue box on the right top of the
default form (see APPENDIX A and B).� Choose Object > Box Properties, and then click the
Function tab.
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� Click the Default data box, and choose String.� Type a new chemist’s code, e.g. “PRR-PA-”
� Click OK.� Choose File > Save Form.

Anatomy of 
LabJ

You are welcome to read the database structure (source code
of LabJ) and to try to modify it and save as your own LabJ
Database. To find out more about the ISIS/Base features
choose Help > ISIS/Desktop Contents > ISIS Overview and Docu-
mentation. 

Table 1.  The LabJ database structure.
0  RXN                                  Parent
1   RXNREGNO                            Integer
2   RXNSTRUCTURE                        Reaction
3   VARIATION                           Parent
4    VARIATION_NO                       Integer
5    REACTANT                           Parent
6     REACTANT_NO                       Integer
7     LIST_OF_REACTANTS                 Integer
8    PRODUCT                            Parent
9     PRODUCT_NO                        Integer
10    LIST_OF_PRODUCTS                  Integer
11  REACTANT_LINK                       Parent
12   LIST_OF_REACTANTS                  Integer
13   REACTANT_NO                        Integer
14   MOL                                Parent
15    REF_REAGNT                        Real
16    MOLREGNO                          Integer
17    MOLSTRUCTURE                      Structure
18    *fmla_MOLSTRUCTURE                Formula
19    *mol.weight_MOLSTRUCTURE          Real
20    CORP_ID[20]                       Fixed Text
21    REACT_EQ                          Real
22    REACT_n                           Real
23    REACT_m                           Real
24    REACT_V                           Real
25    REACT_d                           Real
26    REACT_P                           Real
59    REACT_DESC[64]                    Fixed Text
60    REACT_Molarity                    Real
62    REACT_mP                          Real
63    REACT_Exs                         Real
79    REACT_Exs_Unit                    Integer
27  PRODUCT_LINK                        Parent
28   LIST_OF_PRODUCTS                   Integer
29   PRODUCT_NO                         Integer
30   MOL                                Parent
31    MOLREGNO                          Integer
32    MOLSTRUCTURE                      Structure
33    *fmla_MOLSTRUCTURE                Formula
34    *mol.weight_MOLSTRUCTURE          Real
35    CORP_ID[20]                       Fixed Text
36    PROD_EQ                           Real
37    PROD_nT                           Real
38    PROD_mT                           Real
39    PROD_mP                           Real
40    PROD_nP                           Real
41    PROD_YIELD                        Real
42    PROD_DESC                         Variable Text
43    REF_PRODUCT                       Real
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44    PROD_PP                           Real
64    PROD_ANAL                         Variable Text
77    PROD_NAME                         Variable Text
45  DATE[10]                            Fixed Text
46  GDH#                                Integer
47  PROC                                Variable Text
48  ANAL                                Parent
49   FRACTION_NO                        Variable Text
74   FRACTION_DESCR                     Variable Text
75   FRACTION_QUANT                     Variable Text
76   FRACTION_ANAL                      Variable Text
54  RESULTS                             Variable Text
55  RXNCOND                             Variable Text
56  RXNCOND#                            Variable Text
57  RESULTS_SKETCH                      Sketch
58  KEYWORDS                            Variable Text
61  YIELD[10]                           Fixed Text
78  NAME[07]                            Fixed Text
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Notes
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A mixture of A, B and CHCl2 (dry, 2 mL) in toluene (dry, 10 mL, c[1]= 0.01M) was stirred at 80°C (t/o 85°) for 5 hr under 
argon atmosphere. Then the mixture was evaporated, and the residue was subjected to the CC (EH 7.5%).

i) PhMe/CH2Cl2 (c[A]=0.01M), 16h, 80°C
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[a]20/D : -188.2° (0.78, CHCl3)
TLC
NMR
MS
HRMS
IR

C26H42O4Si 446.71

(3S,11aR,14R,14aR)-14-{[1-(tert-butyl)-1,1-dimethylsilyl]oxy}-3-pentyl-9,10-didehydro-6,7,8,11,11a,13,14,14a-octahydro-3H-cyclopenta[e]oxacyclotri
decine-5,12-dione
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# Formula FW Ratio Scale [mol] Quant. [mmol]
Th. Weight

[mg]
Pract. Amt.:
[g] or [mL]

g   =1
mL=0 Excess

Volume
[mL]

density
[g/mL]

Molarity
[mol/L]

Purity
[%] Notes

A C30H48O4Si 500.80 1.000 0.000100000 0.10000 50.08 0.05280 1 1.054 0 100 GRL-GA-039-02

B C36H54MoN3 624.79 0.075 0.000100000 0.00750 4.69 0.00500 1 1.066 0 100

# Formula FW Ratio Scale [mol] Th. Yield [mmol] Th. Yield [mg] P. Yield [g] Purity [%] P. Yield [mmol] P. Yield
[%]

Notes

1 C26H42O4Si 446.71 1.054 0.0001000000 0.10540 47.08 0.0328 100 0.073426 70
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Name of Product
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