Reference:
Revision:
Architecture:
Board:

Product Version:

STM32Java

Build Your First Java Application
On STM324291-EVAL

Getting Started

/4

life.augmented

TLT-0695-MAN-JavaGettingStarted-STM324291-EVAL
B

STM32JavaF4

STM32429I-EVAL

1.3.2




STM32Java: Build Your First Java Application On STM32429I-EVAL [Getting Started]

Confidentiality & Intellectual Property

All right reserved. Information, technical data and tutorials contained in this document are
confidential, secret and IS2T S.A. Proprietary under Copyright Law. Without any written permission
from IS2T S.A., copying or sending parts of the document or the entire document by any means to
third parties is not permitted including but not limited to electronic communication, photocopies,
mechanical reproduction systems. Granted authorizations for using parts of the document or the entire
document do not mean they give public full access rights.

IceTea®, IS2T®, MicroJvm®, MicroEJ®, S3™, SNI™, SOAR®, Drag Emb'Drop™, IceOS®,
Shielded Plug™ and all associated logos are trademarks or registered trademarks of IS2T S.A. in
France, Europe, United States or others Countries.

Java™ is Sun Microsystems' trademark for a technology for developing application software and
deploying it in crossplatform, networked environments. When it is used in this documentation without
adding the ™ symbol, it includes implementations of the technology by companies other than Sun.

Java™, all Java-based marks and all related logos are trademarks or registered trademarks of Sun
Microsystems Inc, in the United States and other Countries.

Other trademarks are proprietary of their authors.




STM32Java: Build Your First Java Application On STM32429I-EVAL [Getting Started]

Table of Contents

R 01004 L1 Lot o) AU UP PP PUPPPPRIN 5
1.1. Intended AUIENICE ....cooeeeeeeeeeeeeeeeeeeeeeee e e e e e e e e e e e e e e e e e e e e e e e e e e e 5
12 SCOPE ettt ettt et e et e e et e e et e e et e e et e e et e eaaaanns 5
1.3, PIEIEQUISITES .eevvuunreiiiiieretitieeeetiiaeeerttiaeeetttueeeerunseeeananeseeesnnssesesnnssesssnnseessnnnseesssnnssensnnnns 5
1.4, TerMINOIOZY ..oviiiiiiiiiiiiiiii e e e e e e e e e e e e e e e e e e e e e ee s 5
2. Product ReISITAtiOn ........ccevuuuiiieieieieiiiiiiieeeeeeeeeeeiiiteeeeeeeeeeetraansaeeeseeesnnannnnnaseseseressssnnnaeesaaenenes 7
3. OVEIVIEW .ttt ettt ettt ettt ettt ettt et et et et et see e e ee e e et e s e st s eseeeeeeeseeesenesenenenenenanennnes 8
3.1 PIALOTIIIS ...vteitieeeeeieitet ettt e ettt e e e e e ettt et e e e e e e s abbb bt e e eeeeeeaaabbteeeeeeeeas 8
3.2. STM32429T-EVAL KICKSTATt ..eueevriiiieeeeieeeciiieeeee e eeeiieteee e e e e e eiieeee e e e e e s s ennneeeeeeens 8
4. Run an Example on the Simulated Java Platform (SimJPF) ........cccccccviiiiiiiiiiiiiiiieee, 9
4.1. Create EXAMPIE .....ccoouuuuiieeiiiiiiiiiiieee e e e eeeettesee e e e e eeeetateaaeeeeeaeeesssannnaaeseeasessssnnnnaaeaeanens 9
4.2, RUN EXAIMPLE ...ttt nes 10
5. Run the Example on the STM324291-EVAL Board (EmbJPF) ...........cccoooiiii . 11
5.1. Compile Java APPLCAtION .cceiiiiiiiiiiiiiiiiiii 11
5.2. STLink STM32Java Programming TOOI ..............uuvuuuuuvuuuururererurnrerereererrernneeererenenenee. 11
ST T I 11 Tl 1 B0 1o 12
TN 5] 0721114 1 - PSP PP PRPPPRPPRS 13
6.1. STM32429I-EVAL Technical SpecifiCations ............ceeevvrerereeeeeeereereeeeeereeeeererererererenen. 13
6.2. BOArd SELUD ..oooeviiiiiiiiiiiiie e 13
6.3. Demos INStAllation ...........eeiiiiiriiiiieee ettt e ettt e e e e e 14
7. DOCUMENT HISTOTY eeerrniiieeeeieiiiiiiiieee ettt ettt e e e e et e tteb e e s e eeeeteetaaaeeeeeeereensnnnannnns 15




STM32Java: Build Your First Java Application On STM32429I-EVAL [Getting Started]

List of Figures

1.1.
2.1.
3.1.
4.1.
4.2.
4.3.
5.1.
5.2
6.1.
6.2.

PLatfOrm FIOW ...ceeiiiiiiiitee ettt e e e ettt e e e e e e e abbeteeeeeeeenns 6
STM32Java WEICOME PAGE ....ceeiiiiiiiiiiiiiiiiiiiiitiiititititeeteetteeetteteeeeeeeteeeeeeeeeeaeeeeeseeeseaeeeeeseseeenes 7
Available PIAtfOITIS ....cceiiiiiiiiiiiiieiee ettt ettt e e e e e et e e e e e s e 8
New STM32Java Example Project (DA 1) .uuuueeeeiiiiiieiiiiiiieeeeeeeeeeiiiiieeeeeeeeeeeeeninnesesaessessnenns 9
New STM32Java Example Project (Page 2) ....ceeeeeeemieruereeteeeeeeiiiiiiieeeeeeeeeseinrereeeeessssnannene 10
MVC Example on the SIMulator ..........ccoeeviiiiiiiiii e, 10
STLink STM32Java Tl WINAOW ... s 11
STLink STM32Java Tool configuration WindOW ................eeevveererererurererererererererererererer.. 11
SETIAL CADIE ... 13
Board CONFIGUIATION .....uueeiiiiii s 14

List of Tables

6.1.

STM32429I-EVAL Technical SpecifiCations .........cccieieieiiiiiiiiiiiiiiieieceeeeeeeeeeeeeeeeeeeeee e e ee e 13




STM32Java: Build Your First Java Application On STM32429I-EVAL [Getting Started]

1 Introduction

1.1 Intended Audience

The intended audience for this document are developers who wish to develop their first Java application
with STM32Java. Notes:

e This document is for STM324291-EVAL board.

 This document is not a user guide for the C development environment used for the final application
link. Please consult the supplier of the C development environment for more information.

* Please visit the website http://www.stm32java.com for more information about STM32Java products
(platforms, videos, examples, application notes, etc.).

1.2 Scope
This document describes, step by step, how to start your development with STM32Java:
* Register your product.

* Understand the package.

* Run aJava application on the simulation platform (SimJPF) and on the embedded platform (EmbJPF).

1.3 Prerequisites

» PC with Windows XP or later.

» The STM32Java environment must be installed.
* STM324291-EVAL board.

» The ST-LINK utility (normally installed as part of the STM32Java installation).

1.4 Terminology

A Java platform (JPF) is a library that, at a minimum, embeds a JVM (the MicroJvm® virtual machine
from IS2T), some native libraries (also called firmware, or drivers, or BSP), and some Java libraries that
characterize an application domain. Depending on these libraries, some specific tools are provided too.

Every embedded JPF (EmbJPF) has a sibling platform that simulates it on a PC, called the SimJPF. The
SimJPF exactly mimics the semantics of the JPF. The SimJPF can be extended with Mocks to simulate
the native (C, Ada, asm, ...) code of the JPF, such as drivers, or to connect hardware to the workstation.

Mocks can feed the SimJPF with real external stimuli, so that the Java application can behave as if it
was running on the EmbJPF. SimJPF allows the design and functional testing of an embedded Java
application in a development environment.

STM32Java provides a kickstart Java Platform Guide that ease starting with Java on a dedicated micro-
controller. Directly out of the box, one can write Java code without needing to write any low-level code
(such as code to port the JPF to specific hardware). The supplied kickstart JPF uses the STM32429I-
EVAL board , from which most peripherals are accessible, including display, touchscreen, LEDs, but-
tons.

The kickstart JPF comes with documented Java samples which newcomers may start from.
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MicroEJ® SDK

Application software

Java Virtual Machine
+ Embedded Libraries
+ BSP Library

Executable Binary
{-elf, hex, .out...)

Hardware

Figure 1.1. Platform Flow
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2 Product Registration

The development version of STM32Java uses hardware activation keys.
* Open STM32Java.

* Open welcome page: Help > Welcome.

E MicroE) - STM32ave - o EN
Fie Edt Uigste Seych Project Bun Window Help
E Welcome L fiy e

Welcome to STM32Java

e Getting Started

.r;«;‘ Manage Licenses
©e
v/ B Trvout Java Examples

L View Documentation

E: Manage Platforms q

ﬁ Create New Project

Figure 2.1. STM32Java Welcome Page

* Insert your USB dongle.

* Press the Manage Licenses button. Hardware dongles are automatically detected when the
STM32Java preferences main page is shown.

* Click on Refresh when a new hardware dongle is plugged in.

@ Note
The STM32Java preferences page is also accessible from the menu window > Preferences
> STM32Java.
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3 Overview

3.1 Platforms
Several Java platforms (JPF) are pre-installed in STM32Java.

* Open STM32Java.
» Open the welcome page: Help > Welcome.

* Press the Manage Platforms button.

E Preferences = @
type filter text Available Platforms SoDo o
» General =
Add or remove platforms.
> Ant
L CfC++ Platforms and Packs:
» Help Name Version License Select All
» Install/Update Platform XXX J ————
) E P Deselect All
» Java
4 MicroE) Import..
Available Platforms .
Front Panel Designer SIS
Naming Convention G
» Plug-in Development
» Run/Debug — —
Restore Defaults Ar
> Team hd = =
P
@ [ o ][ cance

Figure 3.1. Available Platforms

This Available Platforms page shows all platforms installed in STM32Java. Each platform has its own
characteristics and specific behavior.

@ Note

» The Available Platforms page is automatically populated by the work-in-progress JPFs.

» The Available Platforms page is also accessible from the menu window > Preferences
> STM32Java > Available Platforms.

3.2 STM32429I-EVAL KickStart

This Java platform has been designed to run on a specific microcontroller architecture and on a specific
board. Here the ARM Cortex-M4 architecture and the STM32429I-EVAL board. The Section 5, “Run
the Example on the STM324291-EV AL Board (EmbJPF)” uses this platform to run your first Java ap-
plication.
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4 Run an Example on the Simulated Java Platform (SimJPF)

The aim of this chapter is to create a simple Java application from a built-in example. This example
will initially be run on the simulator (SimJPF) of the platform created in the previous chapter. Then,
in the next chapter, this application will be compiled and deployed on the STM324291-EVAL board
using the EmbJPF.

4.1 Create Example

* Open STM32Java.

» Open the welcome page: Help > Welcome.

* Press the Try out Java Examples button to open the New Java Example Project wizard.
* Select the Java platform STM324291-EVAL KickStart from the combo box.

* Select the example Examples > MicroUI > MVC.

Mew MicroE) Example Project =] “

Select an Example P !1

Target
JPE: | Platform Y]

a | [ Samples -

> = BON

- = ECOM-COMM

> B EDC

=i Getting Started

> B MWT

4 = MicroUl
1= Check Input Events
== Filters
1= Fonts
1= Hello World
= Images
= LCD
1= LEDs
1= Layers

| .

This example shows how to create and use a MVC design pattern

’_
\?
[==]
%
W

Cancel

Figure 4.1. New STM32Java Example Project (page 1)

* Click on Next. The next page suggests a name for the new project.
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Mew MicroE) Example Project - oIEH
Create a MicroEJ Project —
Enter a project name.

Project Name: | MyMVCSample |

® < Back Next > Cancel

Figure 4.2. New STM32Java Example Project (page 2)

* Click on Finish. The selected example is imported into a project with the given name. The main class
(the Java class which contains the main() method, here: MV CDemo.java) is automatically opened.

S Note
Note: The New Java Example Project wizard is also accessible from the menu File > New
> Java Example.

4.2 Run Example

* Open the run dialog (Run > Run configurations...) and select the STM32Java launcher
MyMVCSample SimJPF.

* Click on Run: the application starts. It is executed on the simulator (SimJPF) of the selected JPF
(STM324291-EVAL KickStart). A picture of the board appears. The result of the execution is shown
on the display of the board. The touchscreen can be used to adjust the division of the screen areas.

L STME24290EVAL - o KN

Figure 4.3. MVC Example on the Simulator
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5 Run the Example on the STM32429I-EVAL Board (EmbJPF)

5.1 Compile Java Application

* Open the run dialog (Run > Run configurations...) and select the MicroEJ launcher MyMmvCcSample
EmbJPF.

* Click Run: the application is compiled, and the compilation result (an ELF file) is copied into a well-

known location in the project example. The STLink Tool has to be used to load the program on the
board.

5.2 STLink STM32Java Programming Tool
The aim of this section is to program a binary on the STM324291-EV AL board.

5.2.1 Prerequisites

+ Install STLink Utility software on your machine.

5.2.2 Launch STLink STM32Java Programming Tool

Click on Run > Run Configurations.... Then open sub menu of MicroEJ Tool and select the
STM32Java Tool launcher MyMmvCSample Program STM32429I-EVAL.

E' Run Configurations @
Create, manage, and run configurations (A
<
EEIEE RS Name: Deploy
type filter text % Execution it Configuration| =4 JRE| = Common
- EJ MicroE) Application Target =
 [Ei MicroE Tool Pratorm: [Plat ‘
E Deploy atform: latform
Execution
Settings:STLink Deployment -
Deploy a binary file on STM32xxGEVAL boards using the STLink probe. =
Options
Output folder: ${workspace_loc}/MyExample Browse.
7] Clean intermediate files Verbose
@ Run Close

Figure 5.1. STLink STM32Java Tool window

Click on configuration tab and ajust the setting if necessary.

E/ Run Configurations =
Create, manage, and run configurations (A
® STLink > The entry ™out, "bin’, "hex’ or "srec file” must be specified.
TRX|B 3~ Name: Deploy
| Ltype filter text & Execution [ Configuration . =4 JRE| = Common
||| »EJ Microk) Application STink Java Application Definition
||| & MicroE) Tool
Ei Deploy out, bin’,"hex' or "srec file: | Browse.
STlink Settings
STLink Utility installation directory: C:\Program Files (x86)\STMicroelectronics\STh Browse.
W
Apply Revert
@ Run Close

Figure 5.2. STLink STM32Java Tool configuration window
Click on Run to program the binary. The application downloads.

At the end of the execution the following message appeared:

11
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Flash programming complete successfully.

5.3 Launch Group
To compile again the application and program it on STM324291-EVAL there are two possibilities:

» Launch again the steps described in previous chapters (Compile and Program)
* Oruse a Launch Group launcher to perform the last two steps in one click.

A Launch Group launcher allows to call several launchers consequently. The idea is to create a new
Launch Group which will call the two last previous launchers.

The example already provides a Launch Group launcher which performs these calls: Click on Run >
Run Configurations.... Then open sub menu of Launch Group and select the MicroEJ Tool launcher
MyMVCSample Build and Program STM32429I-EVAL.

Click on Run to compile and program the binary.

12
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6 Appendix

6.1 STM32429I-EVAL Technical Specifications

The following table illustrates some board features used by the Java platform. It doesn't list all board
features (such as all available memories on the board).

MCU architecture Cortex-M4 (STM32F429NIH6)
MCU Clock speed 180MHz (225 DMIPS)
Internal Flash 2 MBytes
Internal RAM 128 KBytes
External RAM 8 MBytes (SDRAM)

Table 6.1. STM32429I-EVAL Technical Specifications

6.2 Board Setup
This section explains how to configure and connect the STM324291-EVAL board .

6.2.1 Jumpers and Switches

Set all jumpers and switches to their default settings: please refer to the STM324291-EVAL documen-
tation (STMicroelectronics documentation: User manual STM324291-EVAL evaluation board).

6.2.2 Power Supply

Select your power supply mode: please refer to the STM32429I-EVAL documentation (STMicroelec-
tronics documentation: UM 1668 User manual STM324291-EV AL evaluation board).

6.2.3 PC-Board Connection

Plug a serial cable between the PC and the board USART 1 connector (CN8). Note the PC's COM port,
it will be used later in the application launcher. This allows all traces to be received from the board and

printed on the console.

Use a simple serial cable with only data lines (crossed) and signal ground. See the illustration below :

ajewal 6 4a

DB 9 female

Figure 6.1. Serial Cable

13



STM32Java: Build Your First Java Application On STM32429I-EVAL [Getting Started]

6.2.4 Summary

ST-LINK/V2
connector

Figure 6.2. Board configuration

6.3 Demos Installation

This chapter explains how to install extra demos and application notes. They have to be imported as a
standard Eclipse project archive file:

* Go to the website http://www.stm32java.com/portal/?q=resources/demos.
» Download zip files containing one or more demos.

* Open STM32Java.

* Open the wizard Import: File > Import.

e Select the item General > Existing Projects into Workspace.

* Click on Next.

* Select the downloaded zip file.

14



STM32Java: Build Your First Java Application On STM32429I-EVAL [Getting Started]

7 Document History

Date Revision Description

November 29th 2013 A First release

May 22th 2014 B

STM32Java 3.0.0 compatibility
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