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Welcome! 
Thank you for choosing Gradience TimeClock 2007!  This application replaces mechanical time 
clocks, eliminating hand correcting and tallying of time cards and dramatically reducing payroll 
preparation time. 
   
 Gradience TimeClock features include: 
  

Easy clocking in/out using keyboard, swipe card and fingerprint reader. 
TC Remote software provides access to remote terminals swipe and punch entries. 
Detailed time and date stamping of all entries, including employee and supervisor changes 
Instant knowledge of employee status through a virtual in/out board 
Fully customizable work schedules, rounding rules, overtime settings and more 
Data export function to major payroll provider software 
Direct transfer of time card runs into employee time sheets in QuickBooks Pro and Premier 

Editions 2003 and higher 
Flexible security access for employee and managers alike 
Integration with other Gradience programs simplifies data entry  

  
When combined with Gradience Attendance 2007, this powerful tool provides a comprehensive 
time and attendance tracking system for your business. 
  

Gradience TimeClock 2007 - New Features 
Gradience TimeClock 2007 has a number of new features designed to improve your productivity 
and improve timekeeping.  We've added the following features to help you become more efficient, 
and hope TimeClock will help streamline your timekeeping operations! 
 
New features in TimeClock 2007 include: 

• Store and Forward - Provides the ability for time stations to work off network.  In past 
versions, constant network connectivity was required for time stations.  This feature allows 
time stations to run off network, and then synchronize information once connected to the 
network. 

• New Reporting System - The new reporting system allows for improved print handling, 
exports, and custom features, plus contains additional reports. 

• Shared Features - Features under the User Security Features Tab are shared among 
Gradience Attendance, Records and TimeClock. For instance, Locations and 
Departments are common to all three programs, as are Global Settings. 

• Job Codes - Assigns job codes to employees.  This feature allows you to track codes for 
employees working in different business areas.  

• Shift Differential - Allows for expanded usage of shifts information. 
• Intranet - Track employee time (log in and log out functionality) using an intranet browser 

system. 
• Fingerprint Reader support - TimeClock now allows the use of fingerprint readers for 

clock in/out purposes. 
• Improved Product Key handling - You can now enter your product key during the 

software installation process. 
• Automatic updates - Gradience can now be set to automatically check for updates via the 

Internet. 

  



Unlocking the Demo       
You can unlock your demo copy after a new installation, or after you have already installed the 
program.      
  
New Installation 
  
You can unlock your installation immediately, or run any Gradience application in Demo mode. 
Here’s how: 

• During the installation of any Gradience application, you will be prompted to enter your 
license key in the Product Key window. 

• Enter the key in the Key field if you have it, or click Next to continue installing the 
application to run Gradience in Demo mode. 

• After running the applications in Demo mode, you will periodically be reminded of the 
Demo trial period remaining and given the option to purchase Gradience Attendance, 
Records, or TimeClock. 

Previous Installation   

If you have already installed the demo of Attendance, you can unlock it by following the steps 
listed here. 

• Open Gradience Attendance. 
• Select Alter Current Product License from the Help menu. 
• Select EDIT for the program you want to unlock and enter the Product Key you received 

with your purchase. This will be located inside of the QuickStart Guide and/or sent to your 
e-mail address. 

• Click OK. If the confirmation message does not appear, verify that you entered the correct 
key. The Product Key is not case sensitive. 

Note: There is a different product key for each Gradience product. 
  

System Requirements  
Minimum 

Windows XP Home (SP2), Windows XP Professional (SP2), Windows 2000 Professional 
Pentium III or Higher Processor 
128 MB available RAM (Random Access Memory) 
30 MB available hard disk space 
Access to a CD-ROM drive 
SVGA monitor with 800 x 600, 16-bit color depth or higher 

Recommended 

Windows XP Professional (SP2), Windows 2000 Professional, Windows 2003 Server or Windows 
Vista 
Pentium IV or Higher Processor 
512 MB available RAM (Random Access Memory) 
60 MB available hard disk space CD-ROM drive 
SVGA monitor with 1024 x 768, High Color or higher 
 Windows-compatible graphics quality printer 



Network Requirements        
The following network requirements apply to TimeClock: 
  

• Windows-based Server or PC –       The included database is not compatible with a 
non-Windows-based operating system, such as Novell. However, you may run the 
database on a Windows-based server or PC connected to a non-Windows based 
network.     

• A static (persistent) IP address so that the database will be always connected to the 
client application. 

• Proper user license – The database will only allow the purchased number of users to be 
connected at any one time to the database. Wide-Area Networks (WAN) require a WAN 
license based on the number of geographic locations. The Product Key is affixed to the 
inside cover of the QuickStart Guide. 

• CD-ROM drive or access to our software downloads area 
on www.gradiencesupport.com.    

   

License Options         
Gradience products have similar licensing schemes.  The options currently available are: 
  

• Basic – Only one user can run the program at a time.   
• Professional – Up to five users can run the program at the same time when connected 

to a single, common database. 
• Enterprise – Site License – Any number of users can run the program at the same time 

when connected to a single, common database from a single site (location).    
• Wide Area Network (WAN) –   licenses for multiple locations are also available. Please 

call for more information. 
   

Installing from the CD Menu         
To begin installing Gradience follow these steps: 

1. Close ALL running programs.  
2. Insert the Gradience CD-ROM into the appropriate drive of your computer.  
3. The menu will appear. Select which product you want to install. (If the installation menu 

does not appear, click Start > Run. The Run dialog will appear. In the dialog box type        
D:\setup.exe where D: is the letter of your CD-ROM drive. Click OK or press Enter. ) 

4. Once the installation procedure begins, follow the on-screen instructions to install the 
software. See Setup Types below for more information. It is recommended that you 
accept the default setting for each step of the install process. If you are installing the 
software in a network environment (Client-Server Installation), you should consult your 
network administrator prior to installation. You must have proper network rights in 
Windows 2000 and XP in order to install Gradience software. 

5. When installation is complete, the Gradience program group will be added to your Start 
menu and a Gradience TimeClock icon will be on your desktop. 

   

http://www.gradiencesupport.com/


 

Setup Types        
• STANDALONE: Use this option if you are installing to a standalone computer. This will 

install the application files (TimeClock Admin and TimeStation) and database files to your 
local drive.  

• SERVER: This is the first of two steps in the Client-Server Installation, either for true 
client-server configurations or peer-to-peer network that may be using a workstation PC 
for the database. Choose this option to install the database and application files 
(TimeClock Admin and TimeStation) on the Server and before installing the Client 
application to PC workstations. 

• CLIENT: This is the second step in the Client-Server installation. This will install the 
application files (TimeClock Admin and TimeStation) and ask for the Server Name and 
Database Path. 

   
After clicking on a Setup Type, you will have the following options: 
 

• EXPRESS: We recommended that you select this option if you are installing or upgrading 
Gradience for the first time. This will take you through the installation process with 
minimum user intervention.  

• CUSTOM: This option is for Advanced Users who have specific installation needs, such 
as installing just the Time Station program on a client.  

   
NOTE:  A Client-Server Installation is recommended. The database is more secure than if you 
install it on a Standalone computer, especially when installing Gradience TimeClock. When 
running Gradience TimeClock on a Standalone computer, you run the risk of someone changing 
the clock settings and creating false time card entries. With a Client-Server Installation, the 
database and time are pulled from the server, not from the client workstation. 

Installing Gradience TimeClock 
This section explains how to install Gradience TimeClock to a Network or Standalone computer 
and answers frequently asked questions about installing.  
   
Gradience TimeClock can be installed on a single standalone workstation or a network for 
database sharing among several users, depending on your needs.  
   
Regardless of which license you purchased, you may install the database to a network directory 
for the purpose of backup. Please consult your network administrator before installing to a 
network directory.  
   

Network Installation – (Client-Server)        
Installing a Client-Server setup is a two-step process. You will need to install to the Server first 
and then to the Workstation(s).  
   
To install to a network requires these items: 

• Windows-based Server or PC – The included database is not compatible with a non-
Windows-based operating system, such as Novell. However, you may run the database 
on a Windows-based server or PC connected to a Non-Windows based network.   

• A static (persistent) IP address so that the database will be always connected to the 
client application. 



• Proper user license – The database will only allow the purchased number of users to be 
connected at any one time to the database. Wide-Area Networks (WAN) require a WAN 
license based on the number of geographic locations. The Product Key is affixed to the 
inside cover of the CD sleeve. 

• CD-ROM drive or access to our software product downloads area on       
www.gradiencesupport.com. 

   
NOTE: Gradience cannot provide technical assistance with setting up or maintaining your 
computer network. Please consult your computer manufacturer or network administrator before 
contacting Gradience Technical Support. 
   

Server Installation Instructions 
Install to the Server first by following these instructions: 

1. Insert the Gradience CD on the Server. (Follow the CD Menu Instructions above.) 
2. At the Setup Type, select  Server. Click Next.  
3. Select Express. Click Next.  
4. IMPORTANT STEP!: Write down the Server Name and Database Path EXACTLY as they 

appear on the screen.  
5. Click “I have written this information down.” Click Close.  
6. Click Next at the Current Settings screen. This will install the program files to the Server.  
7. Click Finish. This will start the installation of the database files.  
8. Click Next, then the  I Agree button if you agree to the license.  
9. After the installation, click Finish.   
10. Follow the installation instructions for the Client Workstation. 

   
NOTE:  You only have to run the Server installation once. Then you may install multiple 
Clients for the Gradience Version of Attendance, Records, or Time Clock, if purchased, or run as 
a demo. 
   

Client Workstation Installation Instructions 
Install to the Client Workstation by following these instructions.  

1. Insert the Gradience CD on the Client Workstation. (Follow the CD Menu Instructions 
above.) 

2. Select Client as the Setup type.  
3. Select Express, and then click Next.  
4. Enter the Server Name and Database Path exactly as you wrote down from Step 4 of the 

Server Installation. Then Click Next.  
5. Click Next at the Current Settings screen. This will install the program files to the Server.  
6. Click Finish. This will start the installation of the needed files to run the database.  
7. Click Next, then the I Agree button if you agree to the license.  
8. After the installation, click Finish.  
9. Install the Client for any other Gradience versions. (You do not have to install to the Server 

again.) You may also install to other Workstations, if needed.  
10. Double-click on the desktop application shortcut; the default Login and Password are 

ADMIN. 
   

http://www.gradiencesupport.com/


 

Standalone Computer Installation Instructions       
Installing to a Standalone Computer requires these items: 

• Product Key - Printed on the inside of the QuickStart Guide that came with your 
purchase.  

• The Gradience Version CD-ROM or Program Update from our web site. 
• A Computer running a Windows-based operating system.  

   
Installing to a Standalone Computer is quick and easy. Follow these steps: 

1. Insert the Gradience CD on Standalone Computer. (Follow the CD Menu Instructions 
above.) 

2. Select Standalone as the Setup Type.  
3. Click on Express, then click Next.  
4. Click Next at the Current Settings screen. This will install the program files.  
5. Click Finish. This will start the installation of the database files.  
6. Click Next, then the I Agree button if you agree to the license.  
7. After the installation, click Finish.  
8. Double-click on the desktop application shortcut; the default Login and Password are 

ADMIN. 
IMPORTANT NOTE FOR VERSION 6 AND EARLIER USERS 

Gradience TimeClock does not share the same database with Version 6 or earlier of Attendance 
and Records. You will need the Gradience Version to share the database among the three 
separate programs. For this reason, you should also upgrade Records to the Gradience Version 
at the same time as Attendance; otherwise, you may create multiple non-synchronized 
databases. 
   

Quick Note About Peer-to-Peer Installations        
A peer-to-peer connection allows you to share information between two computers without the 
need of a formal client-server connection. The peer-to-peer connection must be in place 
before following these instructions. See your Network Administrator for more details on setting 
up this type of connection.  
   
On the host computer (the one on which you wish the database to reside), follow the instructions 
above for a Server installation. Write down the Server Name and Database Path when prompted. 
Note: The Server installation will install both the software client application and database files to 
the host computer. Then install the application Client on the other computer that will be sharing 
the information, entering the Server Name and Database Path when prompted. 
   

Upgrading from Version 8 to Gradience 2007 
If you’re upgrading from version 8 to Gradience 2007, we recommend backing up your current 
data first, then simply run the installation program for Gradience 2007. Your database will be 
automatically converted the first time you start the program. 
   



 

Upgrading from Version 7 to Gradience 2007 
If you’re upgrading from version 7 to Gradience, simply install Gradience 2007 on top of version 
7. Opening Gradience for the first time will update the database to Gradience. The Gradience 
program must have exclusive use of the database to perform the update. Because all Gradience 
programs share the same database, you must upgrade all programs from Version 7 to Gradience 
at once. Using a version 7 application with a Gradience database could result in data loss. 
   
Version 6 and Below 
  
If you’re upgrading from version 6 or below, you will need to upgrade to version 6 (if not already 
installed), and then convert the data to Gradience. Version 6 is on the Gradience CD under the 
BIN\Legacy directory.  Please contact Technical Support for more details on this procedure. 

Before You Begin       
You should have the following information available: 

1. Location and Department names 
2. User Information (managers, supervisors, administrative assistants and others who will 

have access to the data) 
3. Employee Data (Employee Name, Hire Date, Work Status (full or part time), Active Status 

(Active, Inactive, or Terminated), Location and Department, Day Work Hours and Week 
Hours). You will need additional information about employee schedules, overtime and 
rounding rules, payroll categories and codes, etc., to fully set up Gradience TimeClock. 

Navigating the Management Windows 
Gradience TimeClock is now easier to navigate than ever before. The main parts of the 
Gradience user interface are the Menu Bar, Program Bar, Feature Column, Employee Select 
Column, Selected Feature Pane and the Recent Features Pane. 

Menu Bar 
The menu bar includes the following options: 
Menu Description 
  
File  

Maintenance -   Backup Database– Backs up the Gradience database. 
Export TimeClock Data -  
Import Data – Imports basic data into the database. 
Export Data – Exports basic data from the database. 
Delete – Deletes current employee record. 
Exit – Closes program. 
 [Employee Name(s)] – The last seven employees that have been entered or edited will 
show here for quick navigation back to their record. 

   
View  

Filter Page – This option allows you to filter by Active, Inactive, Terminated, Full and 
Part Time Status. 
Open Reminders – Shows open reminders that have not been resolved and whose date 
has not passed.  
Checklist – Shows the Checklist for getting started.  
Welcome – Shows the Welcome Screen.  

   
Settings 
   

User Security – This screen allows you to set up user access. 
Global Preferences – This feature allows you to set up settings that affect features 
within the program.  

http://www.gradiencesupport.com/


   
   

Guest Users – This option is for users who want to set up access to the database using 
a third party tool, such as Crystal Reports.  
Reason Codes – This allows you to set specific reasons when entering paid time for an 
employee.  
Locations Departments – This feature allows you to create your locations and 
departments. 
Messages – These messages will be seen when employees clock in and out.  
Work Schedules – Work Schedules allows you to set rounding rules (grace period) for 
employees clocking in/out.  
Time Difference – If you have multiple sites in different time zones, this option will allow 
you to set the difference in time for each computer connected to the database. 

Reports There are 12 different reports from basic employee information to viewing time cards and 
tracking deleted time clock entries (See Using Reports). You may also customize a 
report to fit most needs through Custom Reports. 

 
Menu Description 
  
Help  

Contents – This brings up the Help File for Gradience TimeClock. Note: Internet Explorer 
4.x and above needs to be installed for this option to work. 
System Information – This gives you information about your computer, database path, 
and other information that is needed when speaking to Technical Support team. 
About – This shows the version number, type of license (Single User, five user, 10 user or 
Unlimited), and User Login Name. A link to the Technical Support site is also located here. 
Alter Current Product License – This allows you to enter a new Product Key Code.  

   

Feature Column 
The Feature Column includes the following options:  
Button Description 
Employee 
Detail 

Employee Detail allows you to add new employees and edit employee 
information. This screen is shared between Gradience Attendance, Confidential 
Employee Record and TimeClock.  

In / Out 
Board 

In/Out Board allows you to view the clock in/out status of employees at a glance.  

Reminders Reminders allows you to view, edit and create reminders. 
TimeClock 
Access 

TimeClock Access allows you to set up employee access to clock in/out. You may 
give employee access to create, edit and/or delete their own time entries. 

TimeClock 
Entries 

TimeClock Entries allow you to maintain employee time entries. You may view, 
add, delete and edit time entries as needed.   

Time Card 
Runs 

Time Card Runs allow you to view, print or export time cards  

   

Toolbar 
The Toolbar contains buttons that allow navigation between feature records and allows editing of 
employee information.   

   

 



Starting Gradience TimeClock        
Gradience TimeClock consists of two applications: the main application - Gradience TimeClock 
Admin- where administrative work is done, such as setting up logins, editing time cards and 
printing time card runs; and a separate application called the   Gradience TimeStation, where 
your employees clock in and out. 
   
NOTE: Separating the Admin and TimeStation applications is new to Version 8. In the previous 
version of TimeClock you had to go through the clock in/out screen to log into the Admin 
application. 
   

To start the TimeStation, click Start > Programs > Gradience > TimeStation or double-
click the program icon on the computer where your employees will clock in/out. 
   
The TimeStation is where your employees will clock in and out. Employees may clock in and out 
using the keyboard or swipe card with magnetic stripe reader or TC Remote Terminal. 

Opening the Management Screen        
The Management screen allows you to view and edit employee time entries, run reports, and set 
program options. If you have the Gradience TimeClock (full program) installed on the same 
computer where user can clock in / out, you will have the option to log into the management 
screen by clicking Management > Management Login. Or you may get to it by clicking Start >   
Programs > Gradience > TimeClock.  
   
NOTE: A Management (Administrator) Login is different from an Employee Login. A Management 
Login allows access to set up screens, time card entries and reports; Employee Login only allows 
employees to clock in/out and manage their individual time entries. 
   

Logging into the Management screen 
A user login is different from an employee login. An employee login (set under TimeClock 
Access) will only have access to the   My TimeClock feature and to clock in and out. A   user 
login (set under User Security) will allow managers, supervisors, and other administrators access 
to setup and maintain Gradience TimeClock.  
   

Login and Password 
If you’re logging in for the first time, the default user login is Admin, and the default password is        
Admin. For security purposes, we highly recommend changing this password after you log into 
the Management screen.  
   

Gradience TimeClock Checklist         
For first time users, the Gradience TimeClock Checklist will appear. If you do not want this 
window to appear at startup, click I am finished with the checklist. To show this window from 
within Gradience TimeClock, choose View > Checklist.  
   
 
 
 



The Checklist shows in order the sections that you should complete to get up and running quickly.  
   

• Change the Admin password by going to Settings > User Security. We highly recommend 
changing the Admin password even if there aren’t other users. If needed, set up access 
for others who will need to help you set up the program. If you need to give access to 
specific locations and departments, or individual employees, set these up first and then 
come back to User Security and complete security access. (See Setting Security Rights.) 

• Create Locations and Departments (Creating Locations & Departments.)  
• Set up Global Preferences. (Setting Up Global Preferences .) 
• Set up preferences (Setting Up TimeClock Preferences.) 
• Set up Reason Codes (Setting Up Reason Codes.) 
• Create Work Schedules (Creating and Editing Work Schedules.) 
• Add Employees (Adding a New Employee.) 
• Assign TimeClock Access (Assigning TimeClock Access.) 
• (Optional) Setting Up Gradience for Time Zone Differences (Dealing with Time Zone 

Differences) 

Changing the Admin Password        
The Admin login and password allows access to all features within Gradience. Changing the 
Admin password is quick and easy, and allows for greater security.   
   
NOTE: The password should be one that you will easily remember but not easily guessed by 
those who know you. A combination of letters and numbers (no spaces or special characters) at 
least 8 characters long will make a good password. 
   
To change the Admin password, follow these steps: 

1. From within Gradience, go to Settings > User Security. 
2. Enter a new password in the Password block. Then enter the password once more in the 

Verify Password block.  
3. Click Save. 

The next time you log in, you may use the new password.  

Creating Locations & Departments        
Locations and Departments are required and must be assigned to each of your Employees (See 
Adding New Employees to assign Location/Department to employees). 
   
Note: When setting up Locations and Departments for the first time, a Location must be set up 
first, and then you may assign a Department to that Location.   



Setting up Locations and Departments 

Setting up Locations and Departments is a critical task and must be performed before you can 
proceed with other data entry steps. During the process, you will create Locations first, and then 
Departments afterward. Departments can then be assigned to Locations. Follow these steps: 

1. Click on Settings and then Locations and Departments. 
2. Click New and then select the New Location? menu item. 
3. Enter the location name.   
4. Click OK. If a helpful tip message box appears, read the tip and click OK to proceed. 
5. Click New again to create other locations.   
6. Now, click New and select the New Department? Item.   
7. Enter the Department name.   
8. Click OK.    
9. Repeat the above steps as necessary for new locations and departments.  
10. After all Locations and Departments are created, click the + sign next to the Location in the 

right pane.   
11. Assign Departments by selecting (placing a check in) the box next to the Department 

name.  
 

NOTE: As you add more locations and departments, you will see that each location has ALL of 
the departments you have created. However, only those departments that you assign to a 
location will show up when assigning them on other screens. You may not remove a Department 
from a Location if an Employee is still assigned to that Location/Department combination. After 
adding and editing locations and departments, you may need to restart Gradience Attendance 
before the changes become available for selection.   
   

Setting Up Global Preferences         
Global Preferences allows you to control your default program settings, such as Company Info, 
Report Options, and specific program options.   
   
Before editing any of the Global Settings, you must first click the EDIT button. See below for 
detailed information on each tab. 
   

Company Info Tab  
The Company Information screen allows you to enter your company name, address and logo. We 
recommend entering the company name and logo as these will print out on Reports.   
Feature Description 
Company Name (Recommended) This will display on the report heading.  
Address, City, State, Zip and 
County 

(Optional)  

Remove Current Logo This allows you to unselect the current logo. 
Assign New Logo This allows you to select a new logo. This logo will display on the 

top left of reports. 
Save Logo to disk This allows you to save the current logo to disk or to your hard 

drive.  
   



Editing Company Info 
Follow these instructions to edit the company info: 

1. After clicking on Settings, Global Preferences click Edit.  
2. Enter Information as needed.  
3. Click Save.  

   

Adding a Company Logo 
If you have your company logo available in a bitmap (. bmp) or jpeg (.jpg) file format, you can 
have this logo appear on reports. Gradience supports .bmp and .jpg file formats not to exceed 
200x200 pixels in size. The logo will appear in the top left when you print a report. 
   
To add a company logo, follow these steps: 

1. Click Assign New Logo.  
2. Navigate to the directory where the company logo is located. It can be in a .bmp or .jpg 

format no bigger than 200x200 pixels in size.  
3. Click on the logo and then click on Open to select it.  
4. Click the Save button.  

   

Saving Logo to Disk 
You may save the logo to a directory on a disk or hard drive. When you add a logo within 
Gradience, the logo is actually saved within the database file.  
   

General Settings Tab 
The General Settings screen allows you to enter the default hours in a day that employees will be 
assigned and allows use of the Forgotten Password Utility. This screen also allows settings for 
Forced Writes to Firebird and prompting to backup on exit.  
   
Feature  Description 
Epoch 
Setting 

We strongly recommend keeping the default settings. This setting will allow the 
Gradience program to appropriately interpret any two-digit year entered that is 
between 1920 and 2019. For example, with the default Epoch setting of 1920: 
1.   If you enter a date (such as in the Hire Date field) of 03/05/01, the program will 

interpret this as 03/05/2001. 
2.   If you enter a date of 03/05/18, the program will interpret this as 03/05/1918.  
Note: If you need to enter a year prior to 1920 or after 2019 in a date field within 
the program, you may enter the year as a four-digit number.  

Default Hours
in a Day 

 These are the default hours that will be assigned when creating a new employee. 
The Day Hours on the Employee Detail screen will be filled in automatically with 
these default hours when a new employee is created.   

National ID 
Number 
Format /Label 

Selecting one of these options will allow you to set the mask for the National ID 
Number Format. The default mask is set to the USA SSN format. With this 
selected, whenever you enter a new employee, the dashes will automatically 
come up in the xxx-xx-xxxx format. The label is the title that will appear on the 
Employee Detail screen. 

   
Feature Description 
Allow use of 
Forgotten 

This option allows access to a utility that can be used, only with assistance from 
Technical Support, to gain access into the Gradience program. In order to use 



Password 
Utility 

this feature, we require that a statement on a company letterhead and signed by 
a supervisor, be sent by fax or mail stating that the user is allowed full access 
into the program. We keep statements on file. Call Technical Support if you 
have forgotten or lost your Gradience password. 

   
Forced Writes 
for Interbase 

·    If running the Gradience database on a Standalone computer, this option will 
help to keep the database more stable. A Workstation is more prone to lock 
up or crash than a Server. If the Gradience database is installed on a 
Workstation and the program is open at the time the computer locks up or 
crashes, the database is prone to becoming corrupt and possibly not able to 
be repaired. A computer lockup or crash can be attributed to several things, 
including having too many programs open at the same time than what your 
computer memory can handle.  

·    If the database is installed on a Workstation or Standalone computer, we 
recommend keeping this option checked. The performance may lag a little, 
but unless you have more than 800 employees, you may not even notice it. 
We also recommend having a current backup, created within Gradience or 
DB Monitor, available. If the database is installed on a Server, normally a 
backup of the whole Server is created on a daily or regular basis. We still 
recommend setting up Scheduled backups within DB Monitor, but having 
this option checked is not as important on a Server. 

  
Prompt for 
backup on Exit  

This option allows you to turn on or off the message prompting for backup when 
you close out of the program. Backups are very important. We recommend that 
you turn this feature off only if you have scheduled backups within the DB 
Monitor.  

Report Options Tab 
The Report Options settings affect how reports will appear by default.  
Feature Description 
Print Preview  Toggles (turns on and off) showing preview first before printing. 
Header Bold  Toggles bolding for Header Title 
Header Line  Toggles putting a line under the Header Title 
Header Shade Toggles shading for Location or Department title row 
Data Line Toggles lines to separate data information 
Print SSN Toggles ability to show Social Security Numbers  
Print Picture  Toggles ability to print Picture on printout 
Print Totals  Toggles whether or not Totals show up on reports 
   

Editing Report Options 
To Edit Report Options, follow these steps: 

1. Click EDIT.  
2. Choose an option by clicking in the box.  
3. Click Save.  

   

Attendance Tab 
The Attendance Tab will only show if Attendance is installed. Please see the Gradience 
Attendance manual for more details on this feature. 
   



Setting Up TimeClock Preferences         
The TimeClock Tab allows you to set global settings for Gradience TimeClock. This will also allow 
you to enable Attendance and TimeClock code sharing.  
Feature Description 
Time Format This allows you to set the time to display in military style or 12-hour style. 
In/Out Board Settings a.   Enabled– This allows the user to view the In/Out Board from the main 

screen. 
b.   Display Time – This will show the clock in/out time for the employee. 
c.   Require Login – This causes the In/Out Board to require a login and 

password. 
Time Display Rate This causes the main clock to be viewed in seconds or minutes. 
Attendance Code 
Sharing   
(See Setting Up 
Attendance Code 
Sharing for detailed 
information.) 
   
   

If you have Gradience Attendance installed, the following options will be 
available:  
a.   Enable Code Sharing - This will allow hours worked and paid time off 

codes to be shared between Gradience Attendance and TimeClock. 
For example, if a code “V” for Paid Vacation of 8 hours is entered on 
the Calendar in Gradience Attendance, this time will also be entered 
into Gradience TimeClock as a manual time entry of 8 hours.  

Feature Description 
Attendance Code 
Sharing (Cont.) 

b.   Enable Hours Worked Transactions Relation - (Enable Code 
Sharing must be checked for this option to be available.) This allows 
the “W” code (Hours Worked) entry in Gradience Attendance to be 
entered as a manual time entry in Gradience TimeClock.  

b.   Reported Payroll Description Columns - Reason Code = Payroll 
Code Description = Related Attendance Absence Code.  

Note: Reason Codes and Payroll Code Descriptions must be set up 
before assigning the Reported Payroll Description Columns. (See Setting 
Up Reason Codes .) 

Sync with the server 
every 120 second(s) 

This is how often the client will synchronize the main clock with the 
server.  

User must 
login/punch within 30 
second(s)  

Once a user enters the first character into the login screen, a countdown 
timer starts. If a user doesn’t finish entering his or her login and password 
within the allotted time, the screen will reset the main clock screen.  

Enable Swipe Card 
Usage 

This allows you to enable the use of swipe cards. (Swipe cards and swipe 
card reader required.) 

Require Password 
when Swiping 

Users will be required to enter a password when swiping in. 

Enable “Auto 
Clocking” 

This enables the “smart” clocking feature. When users clock in the first 
time, the program clocks them in. The next time the user will be clocked  
out and so on. If 13 or more hours pass between punches, this feature 
will be reset and will take the next punch as an In punch.  

Require Password for 
manual Employee 
Login 

Users will be required to enter a password when clocking in/out.  

Require Password for 
access to My 
TimeClock 

Users will be required to enter a password when going into the My 
TimeClock feature.  

Request confirmation 
if user is double 
clocking 

Double clocking is defined as two In punches or two Out punches in a 
row. If a user tries to clock in/out twice in a row (within a 13-hour period), 
a message box will pop up asking for confirmation. 



Setting Up Reason Codes          
You may get to Reason codes by going to Settings > Reason Codes. 
   
When you make a change to a punch entry, you are required to enter a reason for the change. All 
changes, such as deleting or editing a punch entry, are tracked and recorded. Reason Codes 
allow you to create these reasons customized for your company. There are different types of 
reasons:  
Feature Description 
Use for Punch 
Changes 

Reasons you would use when   making a change to a punch. For example, 
you might enter a punch time for an employee because he or she forgot to 
punch in. (The reason would be Forgot to Punch.)  

Use For Deleted 
Entries 

Reasons you would use when deleting a punch or time entry. For example, 
you would delete a punch or time entry because someone punched in twice. 
(The reason would be User Error.)  

Use For Time 
Entries (Manual 
Time Entries) 

Reasons you would use when   entering a manual time entry. For example, 
you may want to enter 8 hours of Paid Vacation for an employee. (The reason 
would be Paid Vacation.) This reason is also associated to Gradience 
Attendance, if code sharing is checked. 

   
Typical reason codes could be Forgot a Punch, User Error, or Computer Down. For example, if 
the new employee, Josh, came in at 8:30 AM and forgot to clock in, Josh’s supervisor would 
need to create a punch entry for 8:30 AM so that Josh gets credit for that time.  
 
Feature  Description 
Reason Code This is the name of the reason (PTO, Sick, Personal, User 

Error, etc). 
Enabled When checked, this allows the reason code to show up when 

editing time on the TimeClock Entries screen. 
Use for Punch Changes These are Reason Codes that you want to see when you're 

doing a manual punch (Clock In or Out) change. A punch 
change changes or adds a specific punch in/out time entry. 
This is different from giving a full or partial day (see          Use 
for Time Entries below). 

Use for Deleted Changes Whenever you delete an entry, you'll need to enter a reason. 
These are the Reason Codes that you want to show up when 
DELETING an entry. 

Use for Time Entries These are reasons that you only want to see when entering a 
manual time entry, such as Vacation, Personal, Sick, etc. A 
manual time entry is normally entered to give a full or partial 
day. For example, you might enter 4 or 8 hours of time for an 
employee that is on Vacation. These reasons are different 
from giving a single entry for punching in or out for a specific 
time (see Use for Punch Changes above).  

Count Towards Overtime 
Calculations 

When checked, this setting tells TimeClock to count time 
under this Reason Code towards overtime.   

Payroll Code Description (Optional) Enter a Payroll Code Description. This description 
will show up on the Time Card Runs report. If a Payroll Code 
Description is not entered, time will be shown in the “Other” 
column on reports. 

Payroll Code Number (Optional) Enter your company’s Payroll Code Number. This 
payroll code number will show up when exporting time card 
runs. 

Related Attendance Absence 
Code -This option will only be 

This allows an Absence Code from Gradience Attendance to 
be directly related to a Reason Code in Gradience TimeClock. 



available if the Enable Code 
Sharing is checked (under Global 
Preferences > TimeClock Tab).  

When an absence or time worked code is entered on the 
Attendance Calendar, this entry will be entered in TimeClock 
according to the related Reason Code. Similarly, when you 
create a manual entry with a Reason Code in TimeClock, an 
Absence Code appears on the Attendance calendar screen. 

   

Creating a New Reason Code 
To create a new reason, follow these steps:  

1. Go to Settings > Reason  Codes. 
2. Click New. 
3. Enter a reason for the following: 

Reasons you would use when making a change to a punch.  
Reasons you would use when deleting a punch or time entry.  
Reasons you would use when entering a manual time entry.  

 
NOTE: You can select multiple uses for a reason code. For example, when using the reason 
code “Off Site,” you may want to be able to select this when entering a punch change or when 
entering a full or partial amount of time. 
 

4. Select Enabled. This will allow the reason to be selected when making changes. 
5. Click Save.  

Work Schedules        
You may get to Work Schedules by going to Settings > Work Schedules. 
   
There are some things in life that nobody has control over that may make an employee late for 
work. Many companies give a grace period to employees when punching in or out to cover these 
occasional events. Setting up a Work Schedule allows you to give a grace period from 2 to 60 
minutes. You may run an Exceptions report to show if employees are abusing this right.   
   
Schedule is not set up or assigned, employees will be clocked in/out with no rounding or overtime 
rules. You will also not be able to run the Punch Exceptions Report.  
   
Under Work Schedules, you may also set up overtime and punch schedules and rules that 
govern how to handle shifts that go over midnight into another day. You will need to set up your 
rounding rule (Work Schedule) and assign that rule to each employee. The most common 
rounding rules of 6, 10, and 15 minutes have already been set up for you.  
   
To set up your rounding rules, go to the Settings menu, then Work Schedules. (See Create and 
Edit Work Schedules for detailed instructions on setting up Work Schedules.) 
   
To assign a Work Schedule to an employee, go to the TimeClock Access Feature, then Current 
Work Schedule. (See Assigning TimeClock Access.) 
   

Printing Work Schedules 
You may print all current Work Schedules by going to Settings > Work Schedules and clicking 
on the Printer icon.  
   



Printing Employee Assigned Worked Schedules 
To print the work schedules are assigned to employees, go to Reports > Work Schedule 
Assignments. 
   

Adding Employees        
You may get to the Employee Detail Feature by selecting Employee Detail under the Feature 
Column. 
   
All employees are entered through the Employee Detail screen. From here, you can enter their 
names, Social Security Numbers (optional), Hire Dates, Job Titles, and other pertinent 
information. This information is shared between Gradience Attendance, Records and TimeClock. 
This means that when you enter this information in one program, you’ll be able to see it in the 
other Gradience programs. 
   

Required Fields 
The following fields are required: First Name,   Last Name,   Hire Date,   Work Status,   
Employment Status,   Location,   Department, and   Day Hours. SSN is not required in 
Gradience, but may be required when exporting Time Card Runs for certain payroll programs. 
   
To add a new employee, click New. (See Required Fields.) Click Save after entering employee 
information.   
NOTE: Locations and departments must be set up before entering new employees. (See 
Locations/Departments to set these up.) 
   

Assigning TimeClock Access        
In order to allow employees to clock in and out, Enable Employee TimeClock Access will need 
to be checked under   TimeClock Access. You may also give employees access to create, edit 
and/or delete their own time entries.  
   
To assign access to an employee, follow these steps: 

1. Select the employee that you want to allow to clock in/out by clicking on his or her name in 
the browse window.  

2. Select the TimeClock Access button. 
3. Enter a login name. The employee will use this to login to clock in/out and to gain access 

to the My TimeClock feature.   My TimeClock allows employees to see their time entries.  
4. Enter a password, and enter it again in the Verify Password block.  

See Also:  Giving Employee's Access (Managing Employee Records)
Setting up Employee Access (Fingerprint Set Up)
   



 

 

 

Creating TimeClock Messages        
To get to the TimeClock Messages screen, go to Settings > Messages. 
   
This screen allows you to enter messages that employees will see when they clock in or out. You 
may even set how long the message will stay on the screen.  
   
To display a message, type your message in the message block for either Clock In or Clock Out 
Message, then click Save.  

   
NOTE: The Clock In message will display whenever an employee clocks in, and the Clock 
Out message will display whenever an employee clocks out. For example, when an 
employee clocks in to begin the workday, the Clock In message will display. This same 
message will display when the employee clocks in from lunch.   

   
Reminders 
   
The Reminders feature will show you all open (unresolved) reminders and allow you to create, 
delete and resolve reminders. If you have created a reminder it will show up when you first open 
the program, starting on the reminder date. Reminders will continue to display until you click 
Resolve.  
   
Reminders Tool Bar and Pane Layout 

       
Tool Bar 
  
First-Prior-Next-Last arrows – navigates through selected reminders 
New – Creates a new reminder 
Edit – Allows you to make changes to a reminder 
Save – Saves reminder 
Cancel – Cancels current changes 
Delete – Deletes selected reminder 
Print – Lets you print the Reminders report for selected employees 
Help – Brings up help for this screen 
   
Pane Layout 
Reminder Date – Date reminder should first display 
Title – Heading of reminder 
Resolved – Checkbox displays checked for resolved or unchecked for open (unresolved) 
Employee Name – Displays name of employee that reminder is associated with 
User – Displays name of user that reminder will display for 
Description – The purpose of the reminder shows here 
   
 
 



Filters 
 
User – Allows you to view reminders associated with specific users (must have access to 
Reminders, Assign Users under User Security) 
Show Resolved – Displays Resolved reminders only 
Show Unresolved – Displays Unresolved (open) reminders only 
   
Creating a New Reminder 
   
There are two types of reminders in Gradience:  

• One Time Reminders – These are reminders that are only meant to remind you of a 
one-time event, such as filing an Absence Report at the end of the year.  

• Recurring Reminders – These remind you of the following recurring events:  
o Anniversaries (Gradience Attendance) 
o Birthdays, Performance Reviews, and I-9 Renewals (available if Gradience 

Records is also installed) 
   
Setting a Reminder 
   
One Time Reminder 

1. Click on Reminders from the Features Column.  
2. Click New.  
3. Select (check) One Time Reminder.  
4. Enter a Title and Reminder Date 
5. If you want the reminder to be associated with specific employees, select the checkbox 

“Assign to all selected (checked) employees.” This is optional and will create a separate 
reminder that is associated with each employee.  

6. If you selected the checkbox in Step 5, you will need to select (check) any employees that 
this reminder is about in the Employee Select Column. Otherwise, skip to the next step.  

7. By default, the User’s name will default to the login that was used to enter the program. 
Change this if you want the reminder to come up for another user, or you may select 
Global which allows the reminder to come up for all users logging in. Note: You must have 
access to Reminders, Assign Users and Reminders, Assign Global under User Security to 
be able to change this option.  

8. Enter a description of the reminder, if needed. 
9. Click Save. 

  
Recurring Reminder 

1. To create a recurring reminder, follow these steps: 
2. Select Reminders from the feature list. 
3. Click New. 
4. Select (check) Recurring Reminder. 
5. Select the type of reminder: Anniversary, Birthday, Performance Review, or I-9 Renewal. 
6. Select a Through Date (when do you want to stop the reminder from occurring). 
7. Select how many days you want to be reminded before the event. 
8. By default, the User’s name will default to the login that was used to enter the program. 

Change this if you want the reminder to come up for another user, or you may select 
Global, which allows the reminder to come up for all users logging in. Note: You must have 
access to Reminders, Assign Users and Reminders, Assign Global under User Security to 
be able to change this option. 

9. Enter a description of the reminder, if needed. 
10. Click Save. 

 
 



Deleting Reminders 
   
Reminders are deleted from the Main Reminders screen by clicking on the Delete icon.  
   
Editing Reminders 
   
There are two ways to edit reminders:  

1. Main Reminders screen - From the main Reminders screen you can edit the following 
columns just by clicking in the field: Reminder Date, Title, Resolved and Description. 

2. Edit Reminders screen - Clicking on Edit from the main Reminders screen will bring up 
the Edit Reminder screen. You may also double-click on the title of a reminder. The Edit 
Reminders screen allows you to change the Title, Reminder Date, User and Description.  

Note: If you need to change the Employee Name that this reminder is about, you’ll need 
to delete the reminder and then re-add it. 

   
Open Reminders 
   
Open reminders will appear for the user they are assigned unless the Global option is checked. If 
a reminder is marked with Global, then it will show for all users. You may view open reminders by 
opening the program or selecting Reminders from the feature list.  
   
Note: If you have security access to “Reminders, Assign Users” (See User Security), you may 
view reminders set up by other users. You may also resolve reminders from the Open Reminders 
screen.  

Dealing with Time Zone Differences        
If you have departments in different time zones that are connected to the same Gradience 
database, you can set up Gradience to account for the time differences. Without this feature, all 
punch times, whether in different time zones or not, will have the time of the Server where the 
database resides.  
   
An example of using Time Difference: If the main server is in Florida, and someone clocks in from 
Utah (2 hours behind), the punch time would be recorded at Utah’s time, like it should.  
   
To get to Time Difference, go to Settings > Time Difference. 
   
To set up computer time differences, follow these steps: 

1. Have each computer open Gradience TimeClock (and then exit) at least once before 
continuing. Each computer should be connected to the same database. They do not have 
to sign into the Manager’s Section; just open Gradience TimeClock to the first screen 
with the clock.  

2. Setting the time difference should be done from the main server where the database 
resides. From Settings > Time Difference, you should see the name of each computer.  

3. Enter a Difference Reason for each computer. The reason could be the department 
name, state or anything else to remind you where that computer is located. Computer 
names will not always be descriptive. 

4. Enter the time difference. Enter time zones behind you with a number to include the 
minus sign.  

5. Click Save. 



Any punches from the different time zones will be clocked in at their respective times.  

TimeClock & Attendance Code Sharing 
Gradience TimeClock and Gradience Attendance can be fully integrated. This means that 
absence codes (paid time off) entered in Attendance are also automatically entered into 
TimeClock, such as Vacation.  
   
Example: Linda takes a vacation day; her supervisor enters this time as a Vacation (Reason 
Code) in Gradience TimeClock so that she is paid for that day. With Gradience integration set up, 
this time will also show on the calendar in Attendance as a V – Paid Vacation day. 
   

Setting Up Attendance Code Sharing       
Provided you own Gradience Attendance 2007, you can set up code sharing between TimeClock 
and Attendance.  Perform the following steps in the order listed:  

1. Enable Attendance Code Sharing in the Global Settings window > TimeClock tab 
2. Set up Reason Codes 
3. Set up Payroll Code Descriptions 
4. Set up Related Attendance Absence Codes 

Enable Attendance Code Sharing  
The first step is to enable (turn on) the Attendance integration. You would do this from Settings > 
Global Preferences > Global Settings window > TimeClock Tab.  
   

1. Under Attendance Code Sharing on the TimeClock Tab, click    Enable Code Sharing. 
2. You may also select Enable Hours Worked Transactions Relation if you are going to 

enter Hours Worked (W Code) on the calendar in Attendance. With this option selected, 
when a W Code is entered on the calendar screen the time will also be automatically 
entered in TimeClock.  

Set Up Reason Codes  
(See Setting Up Reasons Codes for detailed information) 
After turning on the Attendance Code Sharing, the next step is to set up Reason Codes. You may 
already have Reason Codes set up; if so, go to the next step of setting up payroll code 
descriptions. Reason Codes allow you to select specific reasons when entering a manual time 
entry. Some examples of Reason Codes are: Vacation, Sick, Personal, Computer Down, 
Corrected Time Entry, etc.  
   
Example: Using the example above where Linda takes a vacation day, when the supervisor 
enters a manual entry in TimeClock to record the time off, the time is entered as 8 hours and the 
reason code is Vacation.  
Feature Description 
Reason Codes Reason Codes are required reasons when changing a punch entry or 

entering a manual entry.  
Payroll Codes Payroll Codes are descriptions that will show on reports and are 

related to Reason Codes and Absence Codes. 
Related Attendance 
Absence Codes 

Related Absence Codes will allow absences that are entered on the 
Calendar screen to also be reported in TimeClock.  

   
   
To set up Reason Codes, go to Settings > Reason Codes. 



   
When entering a manual time entry, whether correcting an entry, or entering time for someone 
out on vacation, requires a reason. The three types of reasons are: Punch Changes (making a 
change to a punch time entry), Manual time entries (entering a time entry for 8 hours Vacation, 
etc.), and Deleted time entries.  
   
The Reason Code window can be broken down into 3 parts: Reason Code, Payroll Code 
Description, and Related Attendance Absence Code.  

Set Up Payroll Code Descriptions and Numbers 
(See Set Up Payroll Code Descriptions for detailed information.) 
A Payroll Code Description is related to a Reason Code and Absence Code. The Payroll Code is 
the description that will show up on reports (such as the Time Card Runs report).  
   
Example: A   Reason Code of Vacation is set up. When someone takes a vacation day, a 
manual entry (from the TimeClock Entries screen) is created and given the Reason of Vacation. A   
Payroll Code Description of Paid Vacation is set up relating it to the   Reason Code (Vacation). 
When a time card report is run it will show the Payroll Code Description of Paid Vacation (the 
Payroll Code is what will appear on reports). When that manual entry with the Vacation Reason 
Code is created, it will also create an entry on the Calendar in Gradience Attendance under the 
V- Paid Vacation absence code.   
   

Set Up Payroll Description Columns for Reports 
When running a report, such as the Time Card Runs report, only two payroll descriptions will 
show, along with Regular Hours and Overtime hours, due to space constraints. If there are any 
other payroll code descriptions, they will show up in the Other Column. The Time Card Runs 
(Extended) report will show all payroll descriptions in a column format.  
   
After setting up the Payroll Code Descriptions, you’ll be able to set up which two payroll codes 
you’ll want to see, in addition to Regular Hours and Overtime Hours; time for all other payroll 
codes will be combined into the Other Column.   
   
To set up the two Payroll Description Columns, follow these steps: 

1. Go to Settings > Global Preferences > TimeClock Tab. Payroll Description Columns 
for Reports, locate    First Column and    Second Column. 

2. Click on the drop-down arrow for First Column and select which payroll code you’ll like to 
show up on the Time Card Runs report.  

3. Then click on the drop-down arrow for Second Column and select another payroll code. 
4. Click Save. 
5. Close all the way out of the program and open it back up to refresh the data.  

   

Set Up Attendance Absence Codes 
Once the Attendance Integration is enabled, you’ll be able to relate Reason Codes in TimeClock 
to Absence Codes in Attendance. When you enter an Absence Code onto the Calendar that is 
related to a Reason Code, this will create an entry in TimeClock.  
 
 
 
   



Example: We have a    Reason Code of Vacation =    Payroll Code Description of Paid 
Vacation    = Related Attendance Absence Code of V – Paid Vacation; when entering a    V 
Code on the Calendar of 8 hours, this time will automatically be entered in TimeClock as 8 hours 
of    Vacation (Reason Code). And this time will be shown on the Time Card Run report as 8 
hours of    Paid Vacation(Payroll Code Description). 
   
With code sharing set up, this is how it will work: 
   
From the Calendar screen, we enter a V – Paid Vacation day (Related Absence Code) on June 
5, 2002. 
   
From the TimeClock Entries screen, we can see it reports the 7 hours as Paid Vacation (Payroll 
Code Description).   
   
If we double-click on the Changed By Date at the bottom of the TimeClock Entries screen, we can 
see Vacation as the Reason for Change (Reason Code). 
   
And we can see that it shows our columns of Paid Vacation (First Column) and Paid Personal 
(Second Column) with 16 hours Paid Vacation showing for Neil Adams.  
   
And it will work the opposite way if we enter a manual entry in TimeClock, it will display in 
Attendance. 

Setting Security Rights 
Due to the confidential nature of information stored in Gradience TimeClock, security is always 
turned on.  This will help prevent unauthorized persons from accessing critical employee data. 
The use of security is required, and setting up access to TimeClock and any other Gradience 
programs you have should be the second thing you do. The first thing you should do is set up 
Locations and Departments.   
   
You may set up access for managers to view only their departments and/or view specific 
employees from other departments. You may also set up employees to have read-only access to 
their records.  
   
Managers Access (User) Vs. Employee Access 
There are two main levels of security to Gradience TimeClock: Employee Level and Manager (or 
Administrator Level). An employee can be given access to clock in/out and even to create, edit, or 
delete his or her own time entries. Access for employees are given from TimeClock Access. 
Managers, Supervisors or Administrative Assistants are given user access through User 
Security. This allows managers to be given access to select features within the TimeClock 
management screens.  

User Security        

User Security for the Detail Tab  
The Detail Tab has features that are common to the Gradience programs. Common Features 
refer to features that are shared among Gradience Attendance, Records and TimeClock. For 
example, the Detail Tab and Locations/Departments are common to all three programs. Even if 
you only have one of the listed programs you will need to follow these instructions to set up user 
access rights.  
Search For This allows searches by User Name. 
Save As This allows you to create new user log ins based on access rights of another user. 



The User Security window has the following features: 
Feature* Description 
Employee Record 
Access 

This allows access to view, add or delete employee records.  

Detail This allows access to the Detail Tab on the main screen.  
View SSN This allows access to view Social Security Numbers.  
Run Reports This allows access to run reports.  
Reminders This allows access to add and delete reminders.  
Reminders, Assign 
Global 

This allows access to assign reminders as Global.  

Reminders, Assign 
Users 

This allows access to assign reminders to other users.  

User Security This allows access to add, edit, and delete users and user access.  
Location/Department 
Maint 

This allows access to assign location/department access for users.  

Global Preferences This allows access to edit global preferences.  
Database Monitor This allows access to the DB Monitor.  
Database Backup This allows access to Backup from the DB Monitor.  
Database Restore This allows access to Restore from the DB Monitor.  
Alter Product License This allows access to change the Product License.  
Conversion This allows access to run the Conversion Utility.  
Custom Reports  This allows access to create/edit customized reports.  
Import This allows access to import data. 
Export This allows access to export data.  
Guest Users  This allows access to set up Guest Users to manipulate the data from 

another program, such as Crystal Reports.  
* The above features are shared between Gradience Attendance, Records and TimeClock. This 
means that the Detail screen under User Security is the same screen in all three programs.  
   

TimeClock Tab        
Feature  Description 
TimeClock 
Entries  

This allows access to the TimeClock Entries screen. 

TimeClock 
Access  

This allows access to the TimeClock Access screen. 

Work Schedules  This allows access to the Work Schedules screen. (See Setting up a Work 
Schedule.) 

Time Card Runs  This allows access to the Time Card Runs screen.  
Feature  Description 
TimeClock 
Settings  

This allows access to the TimeClock Settings screen. 

Messages This allows access to the TimeClock Messages screen.  
Time Codes  This allows access to the Time Codes screen.  
In/Out Board  This allows access to the In/Out Board. 
Export Data  This allows access to Export Data from the reports.   
   
   
   
Setting Up a User for Security Access    
When setting up a new user, you’ll need to make sure you set access rights under the User 
Security Detail Tab, Location/Department Tab and the appropriate program tab.  



Setting up access to common features (Detail tab).  
 

1. Click New from User Security > Detail screen.  
2. Enter Log In and Password (letters and numbers only) and user’s Full Name.  
3. Select options for Displaying Reminder Alarms and Hints for this login.  
4. Select Yes to allow the user to begin logging in after giving access. Setting this option to 

NO is a good security measure when users are out of the office for a number of days.   
5. Select what type of Feature Access users will have by clicking in the Feature Access 

Rights block.   
6. Clicking on the arrow will allow you to select from the following: 

 
• NO ACCESS – No access to selected feature 
• READ ONLY – This allows user to view only, he or she cannot make any changes 
• READ WRITE – This allows user to view, add, and edit; no deleting allowed 
• READ WRITE DELETE – This allows user full editing rights  
• YES – This allows access  
• NO – No access to feature 
 

7.      Click Save.  
 
User Security for the Attendance Tab 
 
The Attendance Tab will only be shown if Gradience Attendance is installed. Please see the 
Gradience Attendance manual’s User Security section for more information. 
 
User Security for the Records tab        
 
The Records Tab will only be shown if Gradience Records is installed. Please see the Gradience 
Records manual’s User Security section for more information. Once you have followed the above 
steps, the user can log in with their login and password with their assigned access rights.  
 
Tip: You may click Save As from the User Security screen if you already have a user with 
access rights you want to copy and give to another user. The selected user must be highlighted 
first. See Also: Setting up a User for Security Access        
 
When setting up a new user, you’ll need to make sure you set access rights under the User 
Security Detail Tab, Location/Department Tab and the appropriate program tab.    
 
Setting up access to common features (Detail tab).  
 

1. Click New from User Security > Detail screen.  
2. Enter Log In and Password (letters and numbers only) and user’s Full Name.  
3. Select options for Displaying Reminder Alarms and Hints for this login.  
4. Select Yes to allow the user to begin logging in after giving access. Setting this option to 

NO is a good security measure when users are out of the office for a number of days.   
5. Select what type of Feature Access users will have by clicking in the Feature Access 

Rights block.   
6. Clicking on the arrow will allow you to select from the following:  

• NO ACCESS– No access to selected feature 
• READ ONLY– This allows user to view only, he or she cannot make any changes 
• READ WRITE– This allows user to view, add, and edit; no deleting allowed 
• READ WRITE DELETE– This allows user full editing rights  
• YES– This allows access  



• NO– No access to feature 

7. Click Save. User Security for the Records tab        

The Records Tab will only be shown if Gradience Records is installed. Please see the Gradience 
Records manual’s User Security section for more information. Once you have followed the above 
steps, the user can log in with their login and password with their assigned access rights.  
   
Tip: You may click Save As from the User Security screen if you already have a user with 
access rights you want to copy and give to another user. The selected user must be highlighted 
first. 
   
See Also: Setting up user access for use w/ Fingerprint Reader

Clocking In/Out 
There are two ways to clock in and out of Gradience TimeClock, and both are described below. 
You can use a keyboard or a magnetic swipe card using a card reader. Gradience TimeClock 
may be installed on one or two central computers or on all of your employees’ computers so they 
may clock in/out from their desk.  
   
Note: Employees use the Gradience TimeStation to clock in/out while managers and supervisors 
use the Gradience TimeClock Admin portion of the program to manage employee time.  
   
We have made clocking in/out as easy as possible. Employees clock in and out from the 
Gradience TimeStation application. Employees may clock in using the keyboard or using a 
magnetic stripe card (swipe card) and card reader.  
   
Using a swipe card and card reader allows for faster clocking in/out, but may not always be cost 
effective. You may install Gradience TimeStation on your employee’s computers and allow them 
to clock in/out from their desks. (See the Software License Agreement at the front of the manual.) 
   
See Also: Clocking In/Out using the Fingerprint Reader

Clocking In Using the Keyboard        
Before being able to clock in and out, an employee must have TimeClock access. (See Assigning 
TimeClock Access.) To clock in using the keyboard, employees would enter their logins and 
passwords and click on Clock In (F5) or Clock Out (F8).  
   
Employees that are given time clock access also have access to the My TimeClock feature. My 
TimeClock allows employees to see their own time cards. If given the proper rights, employees 
may also create, edit and delete their own time entries within My TimeClock.  
   

Clocking In Using Swipe Card and Card Reader        
If you have a magnetic stripe card reader and cards, purchased separately, it will log employees 
in/out and allow them to get into My TimeClock without having to enter a login and password.  
 
As an added security feature, you may require that an employee enter a password, even while usi
ng a swipe card.  This may cut down on an employee clocking in/out for another employee.  



Remote Terminals        
This section explains how our program works with remote terminals. A remote terminal is a data 
collection station that looks like a 10-key pad with a magnetic stripe card reader attached. The 
remote terminal is connected by a network cable that allows you to have a small data collection 
station in areas where you don’t want or need to have a full computer and monitor setup.  
   
A remote terminal collects the data (such as someone clocking in/out) and sends the information 
to the database where it processes the data through stored procedures. In other words, it does all 
the processing at the Server where the database resides. The remote terminal has a live 
connection to the Server, so if the Server goes down, employees will not be able to clock in or out 
until the Server connection is restored.  
   

Setting Up a Remote Terminal        
To set up a remote terminal you will need the following: 

• One or more TimeClock Remote hardware clocking stations  
• Gradience Remote Terminal Program 
• Gradience TimeClock Program 
• Static IP Address 

   
The Remote Terminal Program allows you to enter an IP Address of the Remote Terminal.  
   
You can set up the remote terminal anywhere you can setup a connection to the network.  
   
Setting the IP Address on a remote terminal 

1. Have your Network Administrator set up a static IP Address for each remote terminal you 
plan to implement. NOTE:  Technical Support cannot assist in setting this up.  

2. Connect the Remote Terminal to your network through an Ethernet cable 

TimeClock Ethernet Terminal 
TimeClock Ethernet Terminals are small, low cost data collection devices that communicate with 
Gradience TimeClock over a TCP/IP network. The network interface supports both 10BaseT and 
100BaseT Ethernet connections. The operator interface consists of an LCD display and 
membrane switch keypad with additional operator input options for barcode, mag-stripe, and 
auxiliary RS-232 serial port.  
   
Theory of Operation 
When the TimeClock Remote terminal is connected to an Ethernet network it functions similar to 
a “dumb” terminal. The host software can send commands and displayable messages to the 
terminal via the network. User input is entered at the keypad or mag-stripe reader and is sent to 
the host software. To minimize network traffic, the user input is transferred as complete strings 
instead of character by character. Strings are terminated by the “Enter” key and terminated with 
the ASCII <CR> & <LF> characters. The mag-stripe input automatically includes the “Enter” 
function. 
   
Terminal Emulation 
The ET214 terminal has two (2) emulation modes, the “Virtual Terminal Command” (VTC) mode 
and the “ANSI Emulation Mode”. The VTC mode provides a unique but simple protocol that 
eliminates the need to know all the particulars of the lower level ANSI protocol. The ANSI 
emulation mode is a subset of the standard ANSI terminal protocol that supports most of the 



standard display manipulation command set. For more information on these emulation modes 
see the “Software Interface” section. 
   
Network Interface 
The TimeClock Remote terminal connects to a 10BaseT or 100BaseT hub via a standard RJ-45 
Ethernet cable. From a network perspective, it occupies a single “socket” at a specified TCP/IP 
address and port number. The device must be configured with a unique IP address, net mask, 
and port number BEFORE it is installed on the network (see “Network Configuration Mode”). The 
host software communicates with the terminal by establishing a connection with the terminal and 
then sending and receiving ASCII text command strings. 
   
Operator Interface 
The TimeClock Remote includes an LCD display and a numeric keypad as the primary operator 
console interface. In addition, the terminal may include optional barcode and/or mag-stripe input 
readers and an auxiliary RS-232 serial port for connection of a serial input device. 
   
Display 
The TimeClock Remote display is a two (2) line by twenty four (24) column LCD character 
display. It can display the 96 standard ASCII characters and 96 non-standard symbols in a 5 x 7 
dot matrix font. The cursor position is identified by a blinking box and can be positioned under 
software control. A display back light is available as an option for low light installations. 
   
Keypad 
The TimeClock Remote operator keyboard consists of a four (4) row by six (6) column membrane 
switch keypad. Two (2) shift keys (“S1” &    “S2”) are provided to generate upper case alpha 
characters and several special characters. The keypad also includes “IN” and “OUT” keys for 
manually clocking in/out and “YES” and “NO” keys for answering program questions.  
   
Default Alpha/Numeric Mode 
   
   
The shift keys ("S1" & “S2") are used to expand the number of ASCII characters that can be 
generated by the keypad. Holding down a shift key and pressing one of the other 22 keys 
generates an alternate ASCII character. For example, holding down         "S2" and pressing the         
"7" key generates the ASCII "B" code. In addition, holding down both shift keys and pressing a 
function key results in a special local terminal function. The following table shows the assigned 
local terminal functions. 
Key Combination Local Function 
Pressing Bottom Row 
Character 

Enters the bottom character. For example, pressing “7” enters the 
number “7” on the keypad. 

S1 & [top left character] Enters the top left character. For example, pressing “S1” & “A” enters 
the letter “A” on the keypad.  

S2 & [top right character] Enters the top left character. For example, pressing “S2” & “B” enters 
the letter “B” on the keypad.  

S1 & S2 + IN Enter Network Configuration Mode 
S1 & S2 + OUT Enter Configuration Mode 
S1 & S2 + Cancel Reboot Terminal – Reboot requires reconnecting through the TC 

Remote program 
   



Setup & Configuration 
It is strongly recommended that you read these instructions on setting up and configuring the 
TimeClock Remote terminal BEFORE attempting to install it.  
   
The TimeClock Remote terminal must be configured for Gradience TimeClock BEFORE it can be 
installed and used on the network. Configuration parameters can be modified through the 
operator console and are saved in non-volatile memory. Network communication parameters are 
entered with the “Network Configuration Mode” and the console parameters are modified with the 
“Console Configuration Mode”. 
   
Configuring the TimeClock Remote terminal is done in three steps: 

1. Configuring the Network Configuration. 
2. Configuring the Console Configuration. 
3. Setting Up the TC Remote program. 

   
Network Configuration Mode 
The Network Configuration Mode is used to configure the TimeClock Remote communications 
parameters. These parameters must be set BEFORE the terminal is installed on the network. 
Holding down the “S1” & “S2” shift keys and pressing the “IN” key will start this mode. A menu 
will be displayed and pressing the “2” key will allow access to the network parameters. The 
display will present a series of configuration parameters and their current values. A value can be 
changed using the keypad and pressing the “Enter” key. After the last parameter is entered the 
values are saved in memory and the menu is display again. Exit from the “Network Configuration 
Mode” is accomplished by pressing the “Enter” key at the menu.  
   
The following table summarizes the “Network Configuration Mode” parameters and the VTC 
command names used to change them. NOTE: Only the MYIP, NETMASK, and MODE 
parameters need to be configured to work with Gradience TimeClock. 
 
Name Default 

Value 
Description 

MYIP 192.168.168.50 Defines the unique network address of this terminal. This value must 
be set BEFORE installing the device on a network. The default value 
may NOT be appropriate and a new address should be obtained from 
the network administrator. 

NETMASK 255.255.255.0 Defines the network mask for the IP address. This value must be set 
BEFORE installing the device on a network. The default value may 
NOT be appropriate and a new value should be 
obtained from the network administrator. 

 
Name Default 

Value 
Description 

GATEWAY 0.0.0.0 Can be set to the address of a router or gateway if the network 
extends to multiple segments. This value must be set BEFORE 
installing the device on a network. The default value may NOT be 
appropriate and a new address should be obtained from the network 
administrator. 

TCPPORT 1070 Defines the primary TCP/IP port number used for this terminal. This 
value must be set BEFORE installing the device on a network. In most 
cases, the default value will be acceptable. However, it may NOT be 
appropriate and a new port number should be obtained from the 
network administrator. It should be set to 23 for a “telnet terminal” 



application. 
SERVER 0.0.0.0 Defines a TCP/IP address for a server application. This value must be 

set BEFORE installing the device on a network. Normally, this value is 
set to 0.0.0.0 which causes the terminal operate as a “server” and 
connects with a host computer running a “client” application. If this 
value is set to any other IP address the terminal will operate as a 
“client” and will attempt to automatically connect to a host computer 
“server” application. 

AUXPORT 9600,0,8,1,1 Defines the communications format for the aux serial port. The 
parameter string consists of five (5) integer value fields and has the 
following format: 
Baud, parity, data bits, stop bits, xoff Where: 
Baud = standard baud rates in the range of 110 – 57600 
Parity = 0 (none), 1 (even), 2 (odd) 
Data bits = 7 or 8 
Stop bits = 1 or 2 
Xoff = xon/xoff protocol (0=disable, 1=enable) 

MODE 1 Defines terminal emulation mode. The two (2) valid emulation modes 
are as follows: 
1 = VTC Mode (default) 
2 = ANSI Mode (Gradience setting) 

MYMAC 0050C2163007 This command will return a 12 character hexadecimal string 
representing the Ethernet hardware address. It is read only and can 
not be used to change the hardware address. 

  

My TimeClock        
My TimeClock allows employees to view their time card history, and, if given rights, can create, 
edit and delete their time card entries. An employee can log into My TimeClock by clicking on the   
My TimeClock button, or pressing the F9 key). The password for   My TimeClock is the same 
one used when clocking in/out. (See TimeClock Access for setting up employee’s login and 
password.)  
   
Tip: Employees may log into   My TimeClock using their swipe card at the My TimeClock login 
screen. 
   

Employee Review/Edit toolbar 
If given the proper rights, an employee may have access to New, Edit, and Delete. This will allow 
them to manage their own time cards. All changes and deletions are tracked and managers may 
run reports against these changes.  
   

 
   

Creating a New Time Entry 
You must be given rights to this feature. Clicking New, from the TimeClock Entries screen, will 
give you the New Entry window with the following options:  
   



 
   
After clicking on New, you’ll be given the choice of Clock In / Clock Out or Enter Hours.   
   
Selecting Clock In/Clock Out will allow you to enter a manual punch entry just as if an employee 
had clocked in or out. For example, you may enter a manual punch entry of 05:15 PM for a 
specific date.  
   
Feature Description 
Reason for 
Change 

A Reason is required for Creating a Manual TimeClock Entry or Entering Hours 
for a Date. 

Date This is the date of the punch entry. 
Punched This designates In or Out of the punch. 
Time This is the time of the punch entry. 
Work Date This is the Work Date that the punch refers to. 
Comments Comments are not required but may be helpful when reading a reason at a 

later date. 
   
Selecting Enter Hours will allow you to give a set amount of hours for a given date. For example, 
you may enter a manual time entry of 8 hours Vacation.  
Feature Description 
Reason for Change A Reason is required for Creating a Manual TimeClock Entry or Entering 

Hours for a Date. 
Feature Description 
Date This is the date the employee will get credit for.  
Work Date This is the Work Date that the punch refers to. 
Hours  This allows you to enter specific hours for a date, such as 8 hours for a 

Vacation day. The Date, Hours and Reason for New Entry fields are 
required. 

Count towards 
overtime calculations 

Designates entry to count towards overtime. 

Comments Comments are not required but may be helpful when reading a reason 
at a later date. 

   

Date Versus Work Date 
When creating a new time entry, there are two date fields: Date and Work Date. The Work Date 
represents the date the entry is counted towards. Normally, you won’t need to change the Work 
Date unless you have work shifts that cross over midnight. For example, Josh starts work and 
clocks in at 8 PM on Monday night. He gets off work at 4 AM on Tuesday morning, but forgets to 
clock out. A manual time entry is created for him punching him out at 4 AM; the Work Date is of 
the previous date (the actual date Josh started work). The program knew that Josh had clocked in 
at 8 PM the previous day and since he had not gone over 13 hours between punches it counted 
the OUT punch to the previous date. 
   



Editing a Time Entry  
Edit allows you to change an existing entry. You must be given rights to have this feature. 
Remember that the Reason for Change block is required and tracked. Editing a time entry is 
similar to creating a new entry except you only have the choice to change a punch time entry. 
   

Deleting a Time Entry 
Delete will erase the selected time entry and record the deletion. All changes and deletions are 
recorded and tracked. To view deleted time entries, go to Reports > Deleted TimeClock 
Entries.  
   

Printing an Employee Time Card 
Print allows you to print an employee time card for the selected date range.  
   

Getting Help 
Help allows you to bring up the help file for this screen. 
   

Time Card Entries 
The time card entries have the following coding: 
Feature Description 
Blue band A blue band designates the selected entry. 
White band A white band designates an IN punch. 
Teal band 
(bluish 
green) 

A teal band designates an OUT punch. 

Gray band A gray band designates a manual entry was given for a set amount of hours. For 
example, Josh took 8 hours of Vacation on 3/15/2002 and a manual entry was 
entered for his time.  

Plus (+) 
Sign 

A plus (+) sign designates a punch was changed or manual entry was entered. 

Asterisk (*) An asterisk (*) designates that there is a double-punch; either two IN punches or 
two OUT punches together. Action should be taken on this type of entry of either 
adding a new entry or correcting an existing entry. Hours cannot be calculated for a 
double-punch entry.  

   
CAUTION: If you see an asterisk (*) next to a time entry this means that some type of action 
should be taken, such as correcting a punch.  
   
   
   
Tip: Right-clicking on an entry will show you the rounding rules (Work Schedule Rules) for that 
entry. 
   



Employee and Manager Access Levels 
There are two main levels of security to Gradience TimeClock: Employee Level and Manager (or 
Administrator Level).  
   
Employee Level Access – This only allows access to Clock In/Out and access to the My 
TimeClock feature, which will allow individuals access to their time card histories. This also will 
allow them to create new time entries, edit existing entries, and/or delete their existing entries. 
Access to the In/Out Board may also be given. (See Employee’s TimeClock Access.) Setting 
up employee level access consists of setting up access on the TimeClock Access screen. 
   
Manager Level Access – This will allow managers access to selected employee time card 
entries. They may create, edit, and delete entries for these employees. They’ll also have access 
to the In/Out Board. Managers at least may have access to everything or only a few 
Administration screens. Having one Manager Login that has access to everything is required. You 
may create other Manager Logins that have partial access to the Administration screens they 
need. For example, a payroll administrator may only need access to View/Edit Employee’s Time 
Card Entries, Create & Edit Work Schedules and to Time Card Runs. The other screens would be 
set for No Access. (See User Security.) 
   

Feature Column        
The Feature Column allow you to navigate from screen to screen.  
Feature Description 
Employee 
Detail 

This screen allows you to enter and edit employee data. 

In/Out Board The In/Out Board allows you to see, at a glance, employees who are in and out. 
Reminders  Provides ability to set reminders for employees. 
Reports  Brings up a list of reports available for previewing and printing. 
  TimeClock 
Access 

This allows you to set employee logins and passwords, work Schedules, and 
access to the In/Out board 

TimeClock 
Entries 

This allows you to view, create, edit and delete time card entries. If you have 
access to view and edit entries, you have access to all records. 

Time Card 
Runs 

This allows you to run time card reports and lock down time cards so that no 
other editing can be done. 

 

TimeClock Entries        
The TimeClock Entries feature allows you to maintain employee time entries. You may create 
new entries, as well as edit or delete time entries. You may also print out employee time cards 
from here.  
   
All changes (edits or deletions) are recorded and tracked. Selecting Show Changes will allow 
you to view entries that have been edited. A plus sign (+) to the right-side of an entry denotes a 
entry has been modified.    
   
   
Tip: Double-clicking on an entry in the changed window (at the bottom) will bring up details of the 
entry. 
   



TimeClock Entries Toolbar 
From the TimeClock Entries screen Managers have access rights to create, edit, or delete 
employee time entries.    
   

Creating a New Time Entry 
You must be given rights to this feature. Clicking New, from the TimeClock Entries feature, will 
give you the New Entry window with the following options:  
   

 
   
After clicking on New from the TimeClock Entries screen, you’ll be given the choice of Clock In / 
Clock Out or   Enter Hours.   
   
Selecting Clock In/Clock Out will allow you to enter a manual punch entry just as if an employee 
had clocked in or out. For example, you may enter a manual punch entry of 05:15 PM for a 
specific date.  
Feature Description 
Reason for 
Change 

A Reason is required for Creating a Manual TimeClock Entry or Entering Hours 
for a Date. 

Date This is the date of the punch entry. 
Punched This designates In or Out of the punch. 
Time This is the time of the punch entry. 
Work Date This is the Work Date that the punch refers to.  
Comments Comments are not required but may be helpful when reading a reason at a 

later date. 
   
Selecting Enter Hours will allow you to give a set amount of hours for a given date. For example, 
you may enter a manual time entry of 8 hours Vacation.  
Feature Description 
Reason for Change A Reason is required for Creating a Manual TimeClock Entry or Entering 

Hours for a Date. 
Feature Description 
Date This is the date the employee will get credit for.  
Work Date This is the Work Date that the punch refers to.  
Hours  This allows you to enter specific hours for a date, such as 8 hours for a 

Vacation day. The Date, Hours and Reason for New Entry fields are 
required. 

Count towards 
overtime calculations 

Designates entry to count towards overtime. 

Comments Comments are not required but may be helpful when reading a reason 
at a later date. 

   



Date Versus Work Date 
When creating a new time entry, there are two date fields: Date and Work Date. The Work Date 
represents the date the entry is counted towards. Normally, you won’t need to change the Work 
Date unless you have work shifts that cross over midnight. For example, Josh starts work and 
clocks in at 8 PM on Monday night. He gets off work at 4 AM on Tuesday morning, but forgets to 
clock out. A manual time entry is created for him punching him out at 4 AM; the Work Date is of 
the previous date (the actual date Josh started work). The program knew that Josh had clocked in 
at 8 PM the previous day and since he had not gone over 13 hours between punches it counted 
the OUT punch to the previous date. 
   

Editing a Time Entry  
Edit allows you to change an existing entry. You must be given rights to have this feature. 
Remember that the Reason for Change is required and tracked. Editing a time entry is similar to 
creating a new entry except you only have the choice to change a punch time entry. 
   

Deleting a Time Entry 
Delete will erase the selected time entry and record the deletion. All changes and deletions are 
recorded and tracked. To view deleted time entries, go to Reports > Deleted TimeClock Entries.  
   

Printing an Employee Time Card 
Print allows you to print an employee time card for the selected date range.  
   

Getting Help 
Help allows you to bring up the help file for this screen. 
   

Time Card Entries 
The time card entries have the following coding: 
Feature Description 
Blue band A blue band designates the selected entry. 
White band A white band designates an IN punch. 
Teal band 
(bluish 
green) 

A teal band designates an OUT punch. 

Gray band A gray band designates a manual entry was given for a set amount of hours . For 
example, Josh took 8 hours of Vacation on 3/15/2002 and a manual entry was 
entered for his time.  

Plus (+) 
Sign 

A plus (+) sign designates a punch was changed or manual entry was entered. 

Asterisk (*) An asterisk (*) designates that there is a double-punch; either two IN punches or 
two OUT punches together. Action should be taken on this type of entry of either 
adding a new entry or correcting an existing entry. Hours cannot be calculated for a 
double-punch entry.  

   
CAUTION: If you see an asterisk (*) next to a time entry this means that some type of action 
should be taken, such as correcting a punch.  



   
Tip: Right-clicking on an entry will show you the rounding rules (Work Schedule Rules) for that 
entry. 
   

IN/OUT BOARD        
The In/Out Board allows you to see, at a glance, employees who are in and out. The In/Out Board 
will refresh itself if the Auto Update feature is checked, otherwise, clicking the Refresh button will 
update the board.  
Feature Description 
Auto update every __ 
minute(s)  

This allows you to set how often this board should update for you.      
Note: This is not a “live” board and will only be updated by the Auto 
Update or pressing Refresh. 

Feature Description 
In/Out Employees  This allows you to see employees who are In or Out at a glance. 
Refresh Clicking this button will refresh the list. 
Help This gives you help regarding the current screen. 
Color-coding: a.   Green – denotes employees who are clocked IN. 

b.   Teal (bluish-green) – denotes employees who are clocked OUT.  
   
Administrators can have access to view all locations and departments or only specific locations 
and departments depending on their security access rights. Employees may be given access to 
all locations and departments or their specific location and/or department or no access to the 
In/Out Board. (See In/Out Board Access under TimeClock Access.) 
   

Adding a New Employee        
Click Employee Detail Feature column. 
   
The Employee Detail screen allows you to add, edit, and delete employees, and, if installed, 
shares common screens with Attendance (Category Assignments) and Records (EEO and 
Personal Contacts). To add a new employee, follow these steps: 

1. Click from the Employee  Browse or Employee Detail screen. 
2. As a minimum, enter First Name, Last Name, Hire Date, Employment Status, Work Status, 

and Location and Department. These fields are required. (To set up locations and 
departments, see Locations and Departments under Administration.)  

3. Click Save.  
   
NOTE:  The SSN is not required when entering an employee in Gradience. However, when 
exporting time card entries, if one of the selected payroll formats requires the SSN, you will need 
to enter it before exporting. 
    

Deleting an Employee        
   
CAUTION: This will delete ALL information on the current employee including any records 
in Gradience Attendance  and Gradience Records. 
   
To delete an employee, and all associated records, follow these steps: 

1. From Employee Detail, select an employee by clicking on his or her name. 



2. Select File > Delete Employee. 
3. Click Yes to the “Are You Sure?” message.  

   

Giving Employees Access to Clock In  
Click TimeClock Access from the Feature Column. 
   
The TimeClock Access screen allows you to set up employee logins/passwords, swipe card 
access, individual access to create, edit and delete their time card entries, assign Work 
Schedules, and employee In/Out Board access. A manager or administrator will always have 
access to the In/Out Board screen.  
Feature  Description 
Employee, Location, 
Department  

This is shown to make it easier when assigning access. 

Search By  This allows you to search by Last Name, First Name, SSN or ID. 
Search For  Entering one character at a time will do an incremental search. For 

example, entering the letter “K” will bring up the names which start with 
K. Adding an L will search out names with KL and so on.   

TimeClock Identification 
(Changing Employee 
Password) 

TimeClock Identification allows you to change the selected employee’s 
Login and Password. Just enter the new Login and password and click on 
Save to change. 

Swipe Card ID  For the Swipe Card ID option, you’ll need a magnetic swipe card or bar 
code reader and pre-encoded cards. To assign a pre-encoded swipe 
card, click on Update/Change, then swipe the card through the swipe 
card reader. If an employee has an assigned swipe card ID number, you 
will also have the option to Clear/Delete.  

TimeClock Access  
   

TimeClock Access assigns employee options for: 
a.   Enable Employee TimeClock Access – This allows the selected 

employee to clock in and out. This is required to be selected if the 
employee is allowed to clock in/out.  

Feature  Description 
TimeClock Access (cont.) b.   Can create their own TimeClock Entries – gives employee the ability 

to create TimeClock entries. 
c.   Can Edit their own TimeClock Entries – gives employee the ability to 

edit TimeClock entries. 
d.   Can Delete their own TimeClock Entries – gives employee the ability 

to delete existing entries. 
Current Work Schedule 
Note: To create a Work 
Schedule, see Chapter 8- 
Creating and Editing Work 
Schedules. 

Current Work Schedule allows you to assign a Work Schedule for 
rounding and reporting purposes.  
b.   Clear allows you to remove this work schedule from an employee.  
c.   History allows you to view changes to an employees work schedule. 

This also allows you to edit the Start Date.  
In/Out Board Access  In/Out Board Access allows you to assign an employee access to see 

None, All employees, or employees by Location or department. (See the 
In/Out Board topic.) 

   
See Also: Setting up Employee Access (Fingerprint Set Up)



Employees Not Rounding on the Correct Work Schedule  
       
Employees may be assigned different rounding rules over the course of their employment. Every 
time an employee is given a new work schedule, he or she gets a new Start Date from which the 
current work schedule begins. A new work schedule will only round from the Start Date going 
forward. Any punches before this date will not be rounded on this schedule.  
   
There are times when you may need to change the start date for rounding calculations. For 
example, if an employee was accidentally assigned the wrong work schedule for a week where 
the work schedule assigned was rounding him/her at 10-minutes instead of at 6-minutes, you 
would want to change to the new work schedule and have the program calculate all past punch 
entries.  
   
The work schedule start date is edited through the History Tab on the TimeClock Access 
screen. For example, if the start date is 11/5/01, rounding will only occur from this date forward. 
Any punches before this date will not be rounded on this schedule.  
   
CAUTION: Editing the Work Schedule date may affect punches for the current employee that 
have already been paid for.   
   

Changing an Employee’s Work Schedule Date 
Changing an employee’s work schedule date and having the program re-calculate according to 
the new work schedule is a two-step process: 
   
First Step (Change the Work Schedule Start Date) 

1. From TimeClock Access, click on History (Current Work Schedule). 
2. On the Work Schedule History screen, double-click on the Start Date you want to 

change. For example, if you want to change the Start Date of 04/18/2002 to 05/01/2002, 
double clicking directly on the 04/18/2002 date will bring up an edit box. 

3. Enter the Start Date of the new work schedule. 
4. Leave the Ending Date blank if this is the most current Start Date.  
5. Click Save. 
6. If you need to have time punches recalculated according to the new work schedule, go to 

the Second Step below; otherwise, punches may not have their time calculated correctly. 
   
Second Step (Recalculate the Punch Time Entries)  
You’ll need to edit any punch time entries that need to be recalculated and click Save. The act of 
clicking the Save button will recalculate the selected punch time entry according to the new work 
schedule.   

1. From TimeClock Entries, select the employee and the punch time you wish to re-
calculate.  

2. You may select the punch time entry either by double clicking on the punch entry or by 
highlighting it (by clicking once on the entry) and selecting the Edit icon.  

3. Do not change the date or time. Select a     Reason for Change. (You cannot save an 
entry without selecting a reason.) 

4. Click Save.  
5. Repeat the above steps for any punches that need to be re-calculated.  

Clicking Save will re-calculate the punch time entry according to the work schedule. For example, 
if you changed this employee’s work schedule from 10-minute rounding to 6-minute rounding, 
then saved any punch entries that fell within the Start Date, their punch entries would be 
recalculated. 
   



   

Creating and Editing Work Schedules 
This section will allow you to set up your work schedule rules and define your daily work hours for 
reporting purposes. 
   
As a rule, many businesses allow a grace period for employees when clocking in or out. This 
allows for time variations on clocks, watches and time devices throughout a company. Rounding 
time also makes calculating payable time easier.  
   

Rounding Explained         
Gradience TimeClock can automatically round off in 2, 3, 4, 5, 6, 10, 12, 15, 20, 30 and 60-minute 
time slices, and it will calculate the time in decimals, unlike many mechanical time clocks. This 
saves time by not having to convert the minutes to decimals. Note: If you don’t round, then select 
the Generic – No Rounding rule. 
   
TimeClock rules can be assigned to individuals or groups. Rules are usually defined for punching 
IN early or late, and OUT early or late. 
   
EXAMPLE 
Here is an example of rounding using the 15-minute rule: 
   
Richard comes in a few minutes early and clocks in at 07:55. 
Tanya is running late and clocks in at 08:04. 
   
Using the 15-minute rule, both Richard and Tanya’s payable time would be clocked in at 08:00. 
Their time was rounded to the nearest 15-minute mark. The next 15-minute mark would be 08:15, 
then 08:30, and so on.  
   
However, using the 6-minute rule and the above clock-in times, Richard’s payable time would be 
clocked in at 07:54. The next 6-minute mark for Richard would be 08:00. Tanya’s payable time 
would be clocked in at 08:06. The next 6-minute mark would be 08:12, 08:18, and so on. Their 
time was rounded to the nearest 6-minute mark. 
   
Gradience TimeClock comes with three commonly used rounding rules: 6-minute, 10- minute and 
15-minute generic rules that are set up to round to the nearest mark. You may choose one of 
these and rename it or set up your own.  
   

Work Schedule Rounding Rules  
Go to Settings > Work Schedules. 
   
The program comes with three commonly used rounding rules. You may use one of these and 
rename it or create your own.  
   
 
 
 
 
 



 
The Rounding Rules Tab has the following features: 
Rounding Rules  Description 
Work Schedule 
Name  

Name the Work Schedule here.  

Time Credited in 
__ Minute 
Increments  

This allows you to select rules for increments up to 60 minutes (increments 
must be divisible by 60).  

Rounding When the Time Credited in __ Minute Increments is selected, the default 
rounding is set to round to the nearest credited increment. You may change 
this setting to fit your needs. Use the Rounding Example to test your 
changes. 

Rounding Example This allows you to see how your rounding will affect true clocking in/out 
punches. Set the Hour and Minute to test how rounding will affect punch 
times. 

     
The Overtime and Punch Schedule Tab has the following features: 
Overtime and Punch 
Schedules 

Description 

Payroll work week starts 
on… 

This determines the day that your work week begins on, which is 
defined as the start of the pay week.  

This Schedule Qualifies 
for DAILY Overtime after 
__ Hours  

Select this option if your policy is to give overtime after working so 
many hours on a     DAILY basis. (For example, anything over 10 
hours daily is considered overtime.) 

This Schedule Qualifies 
for WEEKLY overtime 
after __ Hours  

Select this option if your policy is to give overtime on a     WEEKLY 
basis. (For example, anything over 40 hours weekly is considered 
overtime.)  

Daily Schedule  This allows you to set up daily schedules that can be reported on. 
(For example, if you wanted to know who was 15 minutes or more 
late on Mondays, you could run an Exceptions report.)  

This is a Workday This designates the selected day as a regular workday. 
This is an Overtime Day This designates the selected day as an overtime day. 
Quick Copy Schedule 
From 

After you set up the first workday, this allows you to copy it to the 
next workday so you don’t have to re-enter the same hours. 

New Time Entry This allows you to enter a new entry for your employees daily work 
schedule.  

Delete Time Entry This allows you to erase an entry.  

Shifts Crossing Midnight        
You only need to set up the rules for Shifts Crossing Midnight if you have employees that work 
past midnight. This allows the Work Day to be defined. 
Feature  Description 
Report time to     
NEXT DAY on or 
after _____. 

This allows you to set the time punches’ Work Date to the next day. For 
example, if the night shift starts work at 10 PM on Monday night, but the 
entire shift (10PM – 6 AM) is counted for working on Tuesday, then you 
would select this option.  

Report time to 
PRIOR DAY on or 
before ____. 

This allows you to set the time punches’ Work Date to the previous day. For 
example, if the night shift starts at 2 AM on Tuesday but the entire shift is 
counted for working on Monday, then you would select this option.  

Maximum expected 
hours for lunch 
break ____.  

We recommend leaving this option at the default 3.5 hours. This option is for 
punches that cross midnight and allows for employee’s to be counted on the 
correct work day when working long or double shifts.  

Shifts   



   

More About Rounding        
Gradience TimeClock rounding is based on three points: 
 

1. What you select for Time Credited in Minute Increments 
2. What you set for Clocking In and Out rounding 
3. Assigning the Work Schedule to an employee through TimeClock Access.   

 
Gradience TimeClock automatically rounds to the nearest mark based on your choice of minute 
increments. Gradience TimeClock will round up or down at about the halfway mark. For example, 
if you’re using Gradience TimeClock to credit in 6-minute increments, then the program will round 
up AFTER 3 minutes and round down before this time. The key word is   After. The program will 
ROUND UP AFTER however many minutes you select.  
   
Gradience TimeClock allows you to select rounding up to the designated credited amount, minus 
one minute. If you choose to credit in 6-minute increments then you could choose from 1 to 5 
minutes for rounding. If you choose to credit in 10-minute increments then you could choose from 
1 to 9 minutes for rounding and so on. 
   

TIP: If in doubt, use the Round Test to see how the time will be rounded. 
   

Setting Up a Work Schedule        
Setting up a Work Schedule allows your employee’s punch times to be rounded and allows you 
to report on various settings according to the Work Schedule. For example, if you wanted to know 
who was clocking in late on Mondays for the month of June, you could run an Exceptions Report. 
All employees that clock in/out must be assigned a Work Schedule for rounding and reporting 
purposes.  
   
To set up your work schedule, follow these steps: 

1. Click New. 
2. Enter a descriptive work schedule name. 
3. Select how your time is credited for rounding purposes. 
4. If you round to the nearest mark, you may leave the defaults in the Rounding block as they 

are. If, however, you round nearer or farther from the nearest mark, then you may change 
the rounding to suit your needs. 

5. Check how the program will round for you by entering a clock in/out time in the Rounding 
Example block. If the time isn’t rounding the way you want, then change the Rounding 
time and check it again. 

6. Select whether this work schedule qualifies for DAILY overtime and after how many hours.  
7. Select whether this work schedule qualifies for WEEKLY overtime and after how many 

hours. 
   

Setting up the Daily Schedule        
To define the daily schedule, follow these steps: 
   

1. Select a day of the workweek and specify if it is a Workday and/or an Overtime Day. An 
Overtime Day is any day that is automatically counted as overtime such as Saturday or 
Sunday.  

2. Click New Time Entry:  



2.1. Enter what time employees on this work schedule would normally start work. Press 
the TAB key or click New Time Entry to go to the next row. 

2.2. Enter what time the employees would normally break for lunch. Press the TAB key 
to go to the next row. 

2.3. Enter what time the employees would normally come back from lunch. Press the 
TAB key to go to the next row. 

2.4. Enter what time the employees would normally leave for the day. 
3. Click on the next day and enter their start and end time for this day. You may also use 

the Quick Copy Schedule feature to copy the previous day’s entry. Click Save to save 
this work schedule. 

   
Remember to assign a work schedule to each employee under TimeClock Access; without an 
assignment, employee entries and overtime will not follow the work schedule rules. This can 
result in payroll errors. 

Preparing Time Card Runs  
Time cards are prepared by the Payroll Administrator or other designated person who can run 
time card reports or export this data to your payroll program. The person who has access to Time 
Card Runs can lock out employees and other managers from making any changes to specific 
date ranges and save this information so that changes cannot be made to time that has already 
been paid for.  
   

Viewing Time Card Data        
When viewing time card data, keep in mind that overtime will only show if you have set up a Work 
Schedule and assigned it to your employees. The Work Schedule will have rules regarding 
overtime and what day your Work Week starts on. See Work Schedules.  
   

Frequently Asked Questions 
Q: I’ve created a time card run covering 8 days. For one employee it shows 59 hours of 
worked time, but 0 hours of overtime. Why is this? 
A: The start of your Workweek (set in the Work Schedule) determines the week for overtime. 
Check to make sure you have a Work Schedule assigned for this employee by going to   
TimeClock Access > Current Work Schedule. If there is one, go   to Settings > Work 
Schedules and make sure the assigned Work Schedule has the appropriate Overtime settings. If 
the overtime settings aren’t set up, then go to Work Schedules and create one before assigning 
it. (See   Creating Work Schedules for detailed information.)  
   
For Example: If a time card run is created to include Randy from (Wed) May 8, 2002 through 
(Thur) May 16, 2002 and it shows that he worked 59 hours during this time, this doesn’t 
necessarily mean he has overtime. Weekly overtime, if any, is calculated on the last day worked 
of the workweek. Daily overtime, if any, will be calculated on the same day worked. 
   
   
May 
2002 
Sun Mon Tue Wed Thur Fri Sat 
         1  2  3  4 
5 6 7 8 9 10 11 
12 13 14 15 16 17 18 
19 20 21 22 23 24 25 



26 27 28 29 30 31    
   
Assuming our Workweek starts on Sunday, the date range of May 8 – May 16 covers two 
separate Workweeks. (Workweek1: May 5 – May 11 and       Workweek2: May 12 – May 18.) If 
Randy does not work overtime on a daily basis or for the whole workweek, he won’t have any 
overtime. But, if he does work overtime for Workweek1, it will be calculated for that Friday (May 
10) and be included on the report. Overtime worked for Workweek2 will not be reported unless 
Friday, May 17 is included.    
 
Factors involved in calculating overtime: 

1. What is the Workweek Start Day? (Sunday? If the workweek starts on Sunday, this would 
mean the workweek is from Sunday through Saturday every week.) 

2. Do your employee’s receive overtime based on time worked on a daily basis? 
(Example:Daily time worked over 10 hours receive overtime.) 

3. Do your employee’s receive overtime based on time worked on a weekly basis? 
(Example:Weekly time worked over 40 hours receive overtime.) 

4. When was the Work Schedule assigned to the employee? 
 

Overtime Description 
Daily 
Overtime 

Overtime will be posted on the       day the employee goes over the amount of hours 
set for Daily Overtime on the Work Schedule. (Example: if > 10 hours daily is 
considered overtime; if employee works more than 10 hours on Tue, overtime will be 
shown same day.) 

Weekly 
Overtime 

Overtime will be posted on the       last day worked on the workweek. (Example:if > 
40 hours a week is considered overtime; if employee works Mon – Fri, overtime will 
be shown on Fri.) 

   

Exporting TimeClock Data        
You may export time entry data two different ways in Gradience TimeClock. The first way is from 
the Export feature under Time Card Runs. The other way is from Export TimeClock Data under 
the File menu.  
Export Type Description 
Export TimeClock 
Data 

Exports hours worked and general employee information to a .csv file. This is 
a general export found under the File menu. 

Time Card Runs 
Export 

This is a specific export feature that exports to several different payroll 
formats. 

   
   

Time Card Runs Export 
From Time Card Runs Export you may export to a text file into the following Payroll formats: 

• ADP/PC Payroll for Windows 
• Paychex 
• PaycomOnline 
• PayAmerica 
• QuickBooks Pro and Premier Editions 2003 and above 
• RDE (Summit Payroll Express) 
• Rapid Payroll 
• UltiPro 

Please call or email Technical Support for other formats. 



   
* - Gradience TimeClock is integrated with QuickBooks. When you click on Export, the time data 
is automatically transferred into QuickBooks. (See QuickBooks Integration below.) 
   

QuickBooks Integration 
Gradience TimeClock can import time data directly into QuickBooks Pro and Premier Editions 
2003 and/or 2004. To import from Gradience TimeClock you will need to set up QuickBooks for 
the following: 

to view Weekly TimeSheets 
Appropriate Payroll Items that correspond with Gradience TimeClock 

   
NOTE: Gradience TimeClock and QuickBooks should be set up prior to performing the following 
steps. 
   
The following steps will set up Gradience TimeClock to import directly into QuickBooks: 

1. Open QuickBooks. 
2. Open Gradience TimeClock. Check your version number by going to Help > About. You 

should have at least v1.4.1.1 or higher before continuing.  
3. From within Gradience TimeClock go to Time Card Runs and select Export. 
4. If QuickBooks isn’t an option in the left column, hold down Ctrl-Alt-Q to display it. 
5. Click Open QuickBooks. This will bring up a QuickBooks message asking: Do you want 

this application to access your QuickBooks Company File?  
6. Select “Yes, Always” or “Yes, This Time” to allow access. Click Yes if you receive the 

Confirm to Proceed message. Note: if you select “Yes, This Time”, the next time you open 
QuickBooks from Gradience TimeClock it will ask you again for access. 

7. Click back on Gradience TimeClock. You should see two columns which may be filled in 
with data already. The Payroll Code column is codes related to Gradience. The Payroll 
Item codes are related to QuickBooks. You’ll need to relate the appropriate Payroll Code 
from Gradience to the Payroll Item code in QuickBooks. The Gradience Payroll Codes 
should be displaying. Clicking in the corresponding row for the QuickBooks Item code will 
bring up a drop down box. 

8. Click Save after making any changes. 
9. Click Export. 

   

Exporting TimeClock Data 
From File > Export TimeClock Data, you may export hours worked and general employee 
information to a .csv file which can be opened in MS Excel or other spreadsheet programs.  
   
The TimeClock Export feature allows you to export the following data: 
     Last Name      Location 
     First Name      Department 
     Middle Name      Punch Hours 
     SSN      Punch Changes
     Date of Birth    

 
 
 
 
 
   



Features Description 
Export Type Single File – Exports Employee Data and Hours Worked to a single 

file. If Export Punch Changes is selected, it will export to a 
separate file in addition to the Hours Worked.  

Relational File – Exports Employee Data and Hours Worked to two 
separate files. If Export Punch Changes is selected, it will export to 
another separate file.  

Export This exports the data once you have settings complete. 
Select Employee to 
Export  

This allows you to select specific employees, locations and/or departments
to export. 

Hire Range Filter  This allows you to filter on a specific hire date range.  
Job Status Filter  This allows you to filter on full and part time. 
Employee Status 
Filter  

This allows you to filter on Active, Inactive or Terminated employees.  

Select Employee 
Data Fields to 
Export 

Available Fields - This is the list of fields to choose from. 
Fields to Export (In Export Order) – These are the fields chosen. 

Export TimeClock 
Data  

Export Hours Worked for Period – This allows you to select a date 
range for time card data for the selected employee(s). 

Export Punch Changes – This allows you to export punch changes. 
   
To export this data, follow these steps: 

1. From the File menu, select Export TimeClock Data. 
2. Select the export type: Single File or Relational. 
3. Expand the tree, if necessary, and select the employees to export. 
4. Select the data fields to export by either double-clicking on the file or selecting the file and 

clicking on the arrow pointing to the right. 
5. If needed, select the Export Hours Worked option with a date range. 
6. If Export Hours Worked is selected you can select to Export Punch Changes option. 
7. Click Export.  

Using Reports 
Gradience TimeClock includes several powerful reports to help you manage employees and 
prepare for payroll.  For additional reports, please try Gradience Records, which offers you the 
power of additional employee information tracking.  
   

Report List        
Here is a list of the reports you can run: 

• Employee Summary Report 
• Employee Anniversary Report 
• Hours Worked Report 
• Deleted Time Entries Report 
• Work Schedule Assignments Report 
• Exceptions Report  
• Time Cards Report 
• Time Card Runs Report 
• Time Card Runs Extended Report 
• Reminders Report 
• ID Badges 
• Table Listings 

   



Report Interface Features        
The following features are available on each report interface: 
Feature Description 

This allows you to see how the report will show when printed. Preview 
This prints the report.  Print 
This allows you to set printer options. Printer Setup  
This will allow you to view help regarding this screen. Help 
This exits the report interface. Close 

Grouping Options This allows you to group on Location and Department. 
This allows you to display SSN. Display Options  
This allows you to not export headers.  Export Options  

   

Employee Summary Report        
   
The Employee Summary Report is a quick overview of your employees 
showing SSN, date of hire, title, active status, and full/part time status. 

   

Employee Anniversary Report        
   

 The Employee Anniversary Report shows the anniversary date of employees according to the 
selected date range.   
   

Hours Worked Report        
   
The Hours Worked Report shows regular hours, overtime hours and 
total hours. You may select specific employees by date range.  

   



Deleted TimeClock Entries Report        
   
The Deleted TimeClock Entries Report shows entries that were 
deleted along with the reason, comments and login name of the person 
deleting the record. 

   

Work Schedules Assignments Report        
   
The Work Schedules Assignments Report shows which work 
schedule each employee is on and when it was assigned.  

  

Exceptions (Punch)        
Exceptions are broken down into two separate reports: Punch Exceptions and Hours Exceptions. 
The Punch Exceptions report allows you to report on early or late clock in and out punches. You 
may even report on actual clock in/out time or on the rounded time.  
   
NOTE: Your employees must be assigned to a Work Schedule with the daily hours set up to 
properly view this report.  
   
The following are other options that are available on the Punch Exceptions Report. For a list of 
features not listed here, please see Report Interface Features above. 
Feature Description 

This allows you to set a date range for the report. Report Date Range  
This allows you to report on Reported (actual punch time) or 
Rounded time.  

Time Used For Report  

This allows you to view how early or late, in minutes to report on.   Punch Exceptions in 
Minutes  

This allows you to filter on a selected work schedule. Work Schedule(s)  
This allows you to filter on specific days. Week Day(s)  

   



Exceptions – (Hours)        
The Hours Exceptions Report allow you to report on hours over or under by day, week or month. 
This report can be used to monitor which employees may be near overtime.  
   
NOTE: Employees must be assigned to a Work Schedule with the daily hours set up to properly 
view this report.  
   

   
The following are other options that are available on the Punch Exceptions Report. For a list of 
features not listed here, please see Report Interface Features. 
 
Feature Description  

This allows you to set a date range for the report. Report Date Range  
This allows you to report on total hours over or under by day, week, or 
month, and to filter on a work schedule.  

Time Exceptions in 
hours  

This allows you to filter on a selected work schedule. Work Schedules  
   
   
   

Time Cards Report    
 
The Time Cards Report shows punch times and 
manual punch entries for each employee 
according to the selected work date range. 
Changes made to an entry can be printed along 
with employee and supervisor signature 
blocks.     

 
NOTE: Punch entries with an asterisk (*) to the right of the entry require attention. It means that 
double in or out punches have been made and need corrected.  
   



Time Card Runs Report        
The Time Card Runs Report shows totals of regular time, overtime, 
and the First and Second Column descriptions for Reported Payroll 
Description Columns under Settings > Global Preferences > Time Clock 
Tab in a “column” format.   

NOTE: The Time Card Runs Report will only report   regular time,   overtime, and the payroll 
descriptions for   First and   SecondColumns under the Global Preferences > TimeClock Tab. 
All other reasons will fall under the “Other” column.  
   
To print a report, follow these steps: 

1. From the Reports menu, select the appropriate report. 
2. Select any options necessary from the filter and options settings. 
3. Under Select a Time Card Run, select a run.      Note: Runs must be created through the 

Time Card Runs Tab. 
4. Click Preview to see the report on the screen before printing.  

  

Time Card Runs (Extended)        
The Time Card Runs (Extended) Report will print regular time, overtime, and all Payroll Code 
Descriptions in a “row” format. If you have more than two payroll code descriptions (for example, 
Vacation, Sick, and Personal), this report will allow you to view all payroll code descriptions set 
up under     Settings > Reason Codes – Payroll Code Description.  

 

   

ID Badges        
You may create ID Badges for use with Gradience TimeClock or company identification. There are 4 
types of ID Badges: Employee, Temporary, Guest or without a title.    

Layout 
The Layout Tab allows you to select what features will be on the ID Badge. For example, if you 
want the badge title to read Guest instead of Employee, you can select Guest under the Badge 
Title. 

Barcode 
The Barcode Tab allows you to select the type of Barcode that will be printed. If you’re not sure 
which type to use, we recommend keeping the default barcode type of Code 39. Gradience uses 
the Employee ID as the Barcode number. If an employee doesn’t have an Employee ID number, 
a barcode will not print out on the label.   
   



Print Stock 
The Print Stock Tab allows you to select the label type. The Gradience ID Badge type can be 
requested through our sales team and is specifically designed to work with Gradience TimeClock 
and Gradience Confidential Employee Record.  
   

Label Adjustments 
Printers are not created equally; some may print the labels too far to the right or left. The Label 
Adjustments Tab allows you to move the labels to the left or right and up or down, to 
accommodate quirky printers. Normally, you shouldn’t need to adjust the labels to the right and 
left, or up and down, but it’s there in case you need it.  
 
Feature Description  

When using the       Left Offset, positive numbers will offset the label to the 
right and negative numbers will offset the label to the left.  

Left Offset 

When using the       Top Offset, positive numbers will move the labels down, 
and negative numbers will move the labels up.  

Top Offset 

The       Picture Offset allows you to stretch the picture by using positive 
numbers and negative numbers will squish the picture, if needed.  

Picture Offset  

The       Save Label Adjustments button allows you to save your current 
settings.  

Save Label 
Adjustment 
   
   

Table Listings        
Table Listings allows you to print user access rights (User Security), Locations and 
Departments, which departments are assigned to locations (Assigned Departments), and 
Reason Code information.  
  

 
 
Table Listings are mainly used by Technical Support in assisting you with any issues but can be 
useful when setting up. For example, if you want to see what departments are assigned to 
locations, you can print a listing of Assigned Departments.  



Backing Up  
How often should you backup? 
Every company is different regarding their backup needs. One thing to remember is, “it’s not if 
your computer is going to crash, but when.” They have made great strides in making computers 
more reliable, but that just makes the time longer before something may happen to your 
computer.  
   
The following pertains to any data on your computer and not just your Gradience program. Ask 
yourself this question, “If my computer were to crash right now, how long would it take to re-
create (reenter) all of my data without a backup?” Then ask yourself, “If I had to restore from a 
backup, would I be okay with last week’s backup, where I have to reenter a week’s worth of 
data? Would I be okay with restoring a backup from 3 days ago? 
   
When restoring your data, the information will only be as current as your last backup. So, if you 
did a backup two weeks ago and had to restore this backup, you would need to reenter the data 
that didn’t get backed up.     
   
Back up after you make changes to your employee records.  
It is recommended that you back up your database after making any significant changes to 
records. For example, any time you enter several employees or input many changes to absence 
information would be a good time to back up. You may also set up the DB Monitor to 
automatically back up at assigned times.  
   
Rotate backups and store backup copies offsite.  
A good backup routine is to have at least three sets of backups covering different days of the 
week.  This practice is called rotation and reduces your risk of data loss. It is also a good 
practice to always keep one copy offsite in case of a fire or flood. Consult your system 
administrator for your company policy regarding data storage.  
   
A Restore is when you recover from a backup. There are three different uses for the restore 
feature. A Restore may only be done through the DB Monitor.   

1. To overwrite the current data with archived data 
2. To recover from a hardware crash 
3. To move information onto a new computer 

   
Please keep in mind that when you restore data, your information will only be as current as the 
backup you are restoring from.   
   
IMPORTANT NOTE 
The backup file may only be saved to the Server or Standalone Computer where the database 
resides.  The backup creates a zipped file with an extension of .gbk.  
   

Creating a manual backup from within Gradience 
To perform a manual backup from within the Gradience program, follow these steps: 

1. From within Gradience, go to File > Maintenance > Backup > Backup Database. 
2. If you are running the backup utility from the Server or at a local PC where the database 

resides (Standalone), you will have the option to select where you want to backup to. If you 
are running the backup utility from a Client (Gradience client install), it will automatically 
run the backup, saving the data where the database resides.  



Creating a manual backup from within DB Monitor 
To perform a manual backup from within DB Monitor, follow these steps: 

1. Open the DB Monitor program by going to Start > Programs >  Gradience, and clicking 
on   DB Monitor.  

2. Enter your login and password. If you do not have access to the DB Monitor Backup 
feature, you will need to see your Administrator.  

3. Click the Backup Tab.  
4. Click Yes to the message, “Do you want to perform a sweep after the backup 

completes?”      | 
Note: A Sweep is a maintenance feature that keeps the database working at peak 
performance.  

5. Click OK at the Select Directory screen. It is highly recommended that you keep the 
default location.       
Note: You may only back up to the Server or standalone computer where the database 
resides.  

6. Click Close when the backup is complete.  
   

Scheduling Automatic Backups 
To create a scheduled backup, follow these steps: 

1. Open the DB Monitor program by going to Start > Programs >Gradience and clicking on   
DB Monitor.  

2. Enter your login and password. If you do not have access to the DB Monitor Backup 
feature, you will need to see your Administrator.  

3. Click the Backup Tab.  
4. Click New Backup.  
5. Enter the Backup Type by selecting Daily, Weekly or Monthly.  
6. Enter the military time when you would like the backup to take place.   
7. It is recommended to keep the other default settings of Performing Sweep and the path of 

the backup. A different backup will be created for each scheduled backup.  Note: The 
name of the backup will be: [Type]_Backup_[mm-dd-yyyy]_[time] to distinguish it from 
other backups. For example, Weekly_Backup_08-02-2001_2300, or 
Monthly_Backup_09_01_2001_1700.  

8. Click Save. The backup will be performed within a minute of the scheduled time.      Note: 
The Server or standalone computer where the database is located must be turned on for 
the backup to complete. If the computer is not on at the scheduled time, the DB monitor 
will try to create the backup the next time it is opened.   

Restoring from a Backup 
Remember, restoring a backup will overwrite all data in the current database.   Restore may only 
be run from the DB Monitor on the Server or standalone computer. To restore, follow these 
steps: 

1. Go to the Server where the database files are located. (Restore cannot be done from a 
Workstation.) 

2. Open the DB Monitor program by going to Start,   Programs, Gradience, and clicking on   
DB Monitor.  

3. Enter your login and password. If you do not have access to the DB Monitor Restore 
feature, you will need to see your Administrator.  

4. Click the Restore Tab.  
5. Click the database to restore.  
6. Click Browse and double-click the backup you wish to restore.  
7. Click Start, Restore.  
8. After Restore is complete, click Hide to minimize the DB Monitor.   



You may open the program to see your restored data. Backing Up        
   

DB Monitor  
Go to Start > Programs >  Gradience > DB Monitor. 
   
The DB Monitor allows you to change the Server Name and Database Path, Backup and Restore 
your database, view database information and clear inactive connections. It will also show you 
what Gradience version each client computer is running. This is good to make sure everyone is 
on the same program versions.  
 
Feature Description 
Settings This allows you to change the Server Name and Database Path.  
Backup This allows you to set up a backup schedule or backup now. See above for creating 

a backup. 
Backup 
History 

This shows all backups completed. You will need to manually delete old backups 
from within Windows Explorer. 

Restore This can only be done from the same drive where the database resides. For 
example, if the database was located on a Server, the restore could only be done 
FROM the Server, not from the Client Workstation. See above for steps on 
restoring. 

Information This allows you to view how many users are connected to the database and where 
the current database is located. The Server Version information is the version of 
Interbase (database).  

Statistics This gives information on the database. Normally, you will not need this information. 
 
Feature Description 
Connections This allows you to view who is connected and any inactive connections that need to 

be cleared.  
   

Clearing Connections 
Go to Start > Program Files > Gradience and select   DB Monitor.  
   
To clear a connection, follow these steps: 

1. Make sure that all users are out of all Gradience programs. 
2. From the Connections Tab of the       DB Monitor, click on the       Refresh button and 

make sure that all Computer Names have a “N” under Active Connections. 
3. Click Clear Inactive Connections. This will clear all connections listed with an “N” under 

Active Connections. 

Performing Maintenance and Repairing the Database  
      
The DB Maint is different from the DB Monitor. The DB Monitor utility allows you to view current 
connections, backup and restore, and view backup history. The DB Maint utility allows you to 
perform maintenance and attempt to repair a corrupted database.  

   

DB Maintenance Utility         
To run the DB Maint utility, go to Start > Programs > Gradience > Maintenance > DB Maint. 



   
The DB Maint utility allows you to perform the following:  

1. Perform periodic maintenance on the database to keep it at top performance. 
2. Attempt to repair the database when corrupted. 

   

Maintenance 
We recommend that you periodically perform maintenance on the Gradience database (about 
once a month) by running the Gradience maintenance utility called DB Maint. DB Maint will 
perform some maintenance procedures on the Gradience database to keep it running at top 
speed.  
   
CAUTION: The DB Maint should not be used as a replacement for a good backup schedule. The 
database may become corrupted beyond repair that can be quickly recovered by a current 
backup. We strongly encourage running backups within Gradience or DB Monitor, even if the 
database is on a Server that gets the whole drive backed up daily or on a Standalone computer.  

   

Database Repair 
If you can’t open the Gradience program, we recommend running the DB Maint utility. It will 
attempt to repair a corrupted database. If the utility does not repair the database, please save 
screenshots of the error messages and contact Technical Support.  
   

Running the DB Maint Utility 
Whether performing monthly maintenance or attempting to repair the database, you would follow 
the same steps to run the DB Maint utility. 

1. Go to Start > Programs > Gradience > Maintenance > DB Maint. 
2. After clicking on DB Maint, click on Start to run the utility program.  
3. After the utility finishes, click Close to exit. 
4. Open the Gradience program.  

   
NOTE: The DB Maint may take several minutes to run, especially on large databases. Please be 
patient. 
   
CAUTION: Running the DB Maint utility requires exclusive use; everyone must be out of any 
Gradience programs. Any changes made to system during the running of the DB Maint utility will 
be lost.    

DB Maint Features 
The DB Maint utility has the following features: 
Features Description 
Start Begins the maintenance or repair. 
Cancel Stops the maintenance or repair process.  
Print Prints the error message(s). The Print button will not appear unless there are errors. 
Copy Copies the error message(s) to the clipboard. This will allow you to paste it into an 

email. The        Copy button will not appear unless there are errors.  
Close Exits the DB Maint utility. 
   



NOTE: The DB Maint utility will attempt to repair the database that the hrware.ini file points to. 
(Go to   Start > Run, and enter:   hrware.ini. Locate [HRWARE] in brackets and see the Server 
name and Path for the directory of the Gradience database.) 

Custom Reports 
From any report feature (and after selecting filters and options such as Date ranges, Location and 
Department groupings, etc.) you can begin the process of creating a custom report.  Custom 
Reports are a function of the FastReport™ engine built into Gradience.  The purpose of this 
tutorial is to take you through the process for creating a custom report, editing some basic 
information inside FastReport, and then showing you the outcome.  For a full tutorial on working 
with FastReport, please see the FastReport documentation. 

Custom Reports give the user the option to present data from the original (template) report in new 
and exciting ways.  How it works is the “default” Gradience report (called a “template” inside the 
application) is used as a base for the new custom report.  The user can always start a new report 
from scratch, but it is usually easier to create a new report by modifying a copy of the original 
template. 

To create a custom report based on an existing report, you would click the Save As button and 
select a new name for the report.  You would then proceed to edit the new “copy” of the report.  
To edit an existing report, select the report and click the Edit button.  If you attempt to edit the 
“Default” report, a new name will be automatically assigned. 

To create a custom report, follow these steps: 

1. For this example, we will use the original Attendance Detail report as a template to create 
a new (custom) version of the report. Start by navigating to Reports > Attendance Detail.  

2.  Locate and click the Custom Report icon near the top right of the pane.  
3. A new window titled Custom Reports – Attendance Detail will appear (shown below).  As 

you can see, the current report name (in grayed out text) is Attendance Detail Template.  



 

4. A Custom Sort can be selected by using the drop down selection in the Custom Sort 
Fields section. Custom Sort Fields work by allowing you to select a field which will be used 
to sort the records on your custom report.  Some built-in examples include LastName and 
EmployeeID, and ReportDefault appears as the default selection when you create your 
first custom report (you will probably want to change the default selection).  Click Edit first, 
then click the (+) button to the right of the dropdown to edit a Custom Sort field or create a 
new one. 

5. A Custom Filter can be selected by using the drop down selection in the custom filter 
section.  Since you have already activated editing for items in this window, you can go 
ahead and click the (+) button to the right of the dropdown to edit Custom Filters or create 
new ones. 

6. By clicking the View Data button, you can see the results of any changes made to the 
sorts or filters.  This can be very helpful when creating your own custom reports because 
you will be able to “preview” your report before you actually begin editing it in FastReport. 



 

7. After previewing your data, click Close in the viewer window to return to the Custom 
Reports window. 

8. If the report you wish to customize is not highlighted in the ReportName section, select the 
desired report now. 

9. Clicking New or Edit will bring you into the FastReport custom report designer.  While in 
the designer you will have the option to save the report as another name or save it to an 
external FastReport 3 (.fr3) file.  You will also have the option to open a previously created 
FastReport file and save it in your database.  See Help / Help Contents while in the 
designer for more information. 

 



10. Once you are finished editing your custom report in the designer, click File > Save, Save 
As, or Exit to close the report to return to Gradience. 

Importing and Exporting Data 
The import function allows you to add new data from a text file into the Gradience program. 
Conversely, the export function allows you to export data from the Gradience program. 
   
The software that you export your data from must be able to export the required information to a 
Tab delimited or fixed length text file. See the required import fields. Please note that we cannot 
provide support for other software program(s). Please contact the software vendor or 
manufacturer for more information on how to export data from your other software. 
   

   

Features        
Feature Description 
Load 
File 

Loads the selected file into the data window. 

Test  This tab will not highlight until a file is loaded. This checks for blank records and ensures 
that the department and location names that are being imported are already in the 
database.  

Import This tab imports the file into the database.  
Help This brings up the Help file pertaining to Importing. 
Close This closes the Import screen and takes you back to the main screen. 
 
Feature Description 
Import File  This allows you to enter the path or navigate to the file you will be importing.  
File Type  This allows you to select the file type.  

a.   Tab Delimited – We recommend exporting or importing as this type of file.  
b.   Fixed Length – Gradience may export or import fields with a fixed length.  

Skip First Line  This will take out the first row, in case you have headers. 
Check 
Duplicates  

This allows you to check for duplicates against the import file and the files 
already in the database. 

   

Required Fields        
The following are required fields for importing: 

• Last Name 
• First Name 
• Location – name must be in the Gradience database prior to importing 
• Department - name must be in the database prior to importing 
• Date of Hire 
• Full/Part Time 
• Active Status (Active, Inactive, or Terminated) 

 
NOTE: Location and Department names must be created within the Gradience program BEFORE 
importing! 
   



Importing        
To import your information, follow these steps: 
   
From within the program click File > Import. 

1. Enter the path of the file or click on the  to navigate to it.  
2. Select Tab Delimited or    Fixed Length. This should correspond with the way the import 

file was saved.  
3. Select Skip First Line if you have title headings. Do not select Yes if you don’t have title 

headings or you may lose the first line of data.  
4. Click Load File to preview the file. At this point you should check that all column headings 

match the fields that will be imported.    
   

Note: The column titles above: SSN, Lastname, Firstname, and Middlename; check each column 
to make sure the appropriate data is in the correct column. For example, the SSN number should 
have an 11-digit number, plus two hyphens. 
   

5. Select which fields to check for duplicates in the Check Duplicates box. Duplicates will be 
checked during the Test File phase. 

6. Click Test File. This checks for blank required fields, and in the case of Location and 
Department, it checks to make sure that the name of the Location and Department has 
already been set up within the program.  

   
CAUTION:  If duplicates are detected and you click on Import, these fields will be imported into 
the program.  
   

7. Once it passes the Test portion, you will be able to click on Import File.  

Exporting        
The export feature is used to transfer basic employee information into a text file that you can 
open in any word processor or spreadsheet application. Only the basic information (see Field 
Layout) will be exported.  
To export your information, follow these steps: 

1. Click File > Export. 
2. Select Tab Limited or    Fixed Length for the Export File Type. 
3. Enter a path and file name or keep the default name. 
4. Click Export.  

Your export file will be created as the file designated in the file block. You may rename the file, 
but we recommend keeping the file extension of .txt. After exporting, you may open the file from 
within any other spreadsheet or word processor program.  
   
NOTE: Only the information in the Field Layout will be available for export.  
   

   

Export TimeClock Data        
The TimeClock Export feature allows you to export the following data: 
     Last Name      Location 
     First Name      Department 
     Middle Name      Punch Hours 
     SSN      Punch Changes 
     Date of Birth    



Feature Description 
Export Type Single File – Exports Employee Data and Hours Worked to a single file. If 

Export Punch Changes is selected, it will export to a separate file.  
Relational File – Exports Employee Data and Hours Worked to two 
separate files. If Export Punch Changes is selected, it will export to 
another separate file.  

Export This allows you to export the data. 
Select Employee to 
Export  

This allows you to select specific employees, locations and/or departments 
to export. 

Hire Range Filter  This allows you to filter on a specific hire date range.  
Job Status Filter  This allows you to filter on full and part time. 
Employee Status 
Filter  

This allows you to filter on Active, Inactive or Terminated employees.  

Select Employee Data 
Fields to Export 

Available Fields – This is the list of fields to choose from. 
Fields to Export (In Export Order) – This is the chosen field. 

Export TimeClock 
Data 

Export Hours Worked for Period – This allows you to select a date range 
for time card data for the selected employee(s). 
Export Punch Changes – This allows you to export punch changes. 

   
To export data, follow these steps: 

1. From the File menu, select   Export TimeClock Data. 
2. Select the export type: Single File or Relational. 
3. Expand the tree, if necessary, and select the employees to export. 
4. Select the data fields to export by either double-clicking on the file, or selecting the file and 

clicking on the arrow pointing to the right. 
5. If needed, select the Export Hours Worked option with a date range. 
6. If Export Hours Worked is selected you can select to Export Punch Changes option. 
7. Click Export.  

Getting Help 
There are several ways to get help throughout the program.  
   

Sample Database  
A sample company (called a tutorial database) is provided so that you may view the different 
screens with sample data already filled in. It is recommended that you use the program with the 
tutorial database in order to get a feel for the program without having to worry about altering live 
data. When you are in the tutorial database, no changes are made to your live database. To open 
the tutorial database select Start > Programs > Gradience > Data. 

 
The Help Menu 
From the Help menu, select      Contents. A listing of help topics is displayed. Select the Book 
that interests you (using a double-click) and then double-click the topic you wish to display.  
   

The F1 Key 
Pressing the F1 key is another way to obtain help within the program. From most areas of the 
program, pressing      F1 will display the topic associated for that screen.  
   



Searching for Help 
You can search for Help two different ways using the Help File.  
Method 1 – From the Help menu, select Search for Help on. The Help Topics Index will appear. 
Select the Topic that interests you.  
   
Method 2 – From the      Help menu, select Contents. Click the Find Tab. If you have not used 
this feature before, the Find Setup Wizard will walk you through setting up the search index.  
Once the search index has been created, type in the Keywords you would like to search for and 
the results will be displayed.  
   
A list of typical errors or messages that were known at the time of publication are listed in 
Appendix B - Troubleshooting.  
   
For more complete information, please refer to one of the following: 

• Readme. txt file located in the C:\Program Files\ Gradience\Common program 
directory.  

• Help File located in C:\Program Files\Gradience\Common   or accessible from the Start 
Menu.  

• Internet Site: www.gradiencesupport.com 
   
   

Before Contacting Technical Support        
Please follow these guidelines before contacting Technical Support: 

• Remember Gradience does not support setting up networks or computer configurations.  
• If you are having problems with your computer, try rebooting first to see if that corrects 

the issue.  
• If you are getting an error message, please write down the whole message or take a 

screen shot of it. Pressing the PrintScrn button on your keyboard will copy the screen to 
the clipboard; you may then open MS Word or WordPad and paste it to the document. 
From here you may print it out.   

• If you are having problems with our program (getting error messages, program locking 
up, other strange things happening), please write down the steps to recreate the issue. 
This will speed things up when talking with a support representative.  

• To get help in a timely manner, check the manual (Troubleshooting section), help files 
within the program, and our Web site at www.gradiencesupport.com for known issues, 
and help on using the program.   

• If you do have to call, be near the PC and have the following information available: 
  

o Gradience Account Number 
o Program Name 
o Program Version Number (you may find this by going to Help > About from 

within the program) 
o Full error message and steps to recreate, if possible.  

Contacting Technical Support        
Technical Support for Gradience TimeClock is available as follows: 
Internet: www.gradiencesupport.com
E-Mail Requests: techsupport@gradiencesupport.com
Phone Requests: 888-925-7740 (8:30 a.m. to 6:00 p.m., EST, Monday-Friday)   

http://www.gradiencesupport.com/
http://www.gradiencesupport.com/
http://www.gradiencesupport.com/
mailto:techsupport@gradiencesupport.com


Troubleshooting 
Here are the most common issues that you may experience when using Gradience.  
   

• Unable to connect to Interbase Server 
• Getting SQL Parse Error: EOF in String Detected message when logging in 
• Unable to install on a Win NT or 2000 system 
• Exceeded the authorized user count 
• Moving database from one location to another 
• Installing Gradience files to another drive other than c:\ 
• Installing Update from one location 

Frequently Asked Questions        
Q: Can I map the drive to the database as I did in Version 6 of your other software? 
A: No. There is no mapping involved. If the database is on a network drive, the Client Workstation 
communicates to the Server through TCP/IP. When you enter the path for the Server, it must be 
“as seen” from the Server. (For example, if the Server Name is Server 1 and the Gradience 
Database Path on the Server is: 
C:\Program Files\Gradience\Data\HRWARE.GDB 
then this is what will be entered (EXACTLY) when installing to a Client Workstation.  
   
Q: What do I need to know before installing to a network drive? 
A: Installing the database to the network and the program files to a Client Workstation(s) is a two-
step process. You’ll need to install onto the Server (must be physically at the Server), and then to 
the Client Workstation(s). Keep these things in mind: 

1. No drive mapping is involved.  
2. TCP/IP must be installed at the Client and Server if database is on the Server.  
3. When installing to the Server, you will be prompted to write down or print out the Server 

name and database path. Make sure you write these down EXACTLY as shown. You 
cannot install to the Server from the Client. When installing to the Client and when 
prompted for the Server name and database path, enter these in EXACTLY as shown from 
the Server install. NO DRIVE MAPPING IS NEEDED. 

4. After installing check to make sure you can run the program from the Server. If you’re 
having problems connecting to the database, check to make sure you have System – Full 
Control on the Gradience folder. 

   
Q: What is the difference between the TimeStation and the TimeClock Admin? 
A: The TimeStation is where your employees clock in/out from and is usually installed on a 
computer(s) in a convenient location accessible to employees. This computer can also have a 
swipe card reader attached to make clocking in/out easier. The    TimeClock Admin is for 
managers and supervisors. This is where administrative work is done, such as setting up 
TimeClock access, and editing and printing time cards. 
   
Q: What type of install (Standalone, Server, or Client) should I perform? 
A: We recommend putting the database on the Server and the program on a Client Workstation. 
A Server has a less likely chance of locking up or crashing and allows the database to remain 
stable. A Client-Server installation requires 1) installing to a Server, and then 2) installing the 
Client(s).  
   
Q: There isn’t room on the C:\ drive on the Server. Can I install the database files and 
Firebird (Db Engine) files to another drive other than C:\? 
A: Yes. Follow these steps: 



1. When installing Gradience to the Server, install the program and database files first. Select 
Custom after the Setup type and click Next. This will give you the choice of where to install 
the program and database files.  

2. After you click on Finish, it will prompt you to install Firebird, the database engine. Click 
Cancel to quit the installation process at this point. 

3. Using Windows Explorer, navigate on the Gradience CD to the   BIN\Firebird folder and 
run the  install file. This will allow you to install Firebird to a physical drive.  

   
NOTE: The Gradience files need to reside on a physical drive, not a mapped drive. 

   

Unable to connect to Interbase Server              
Users affected 
Gradience Attendance 
Gradience Records 
Gradience TimeClock 
   
Issue 
When launching one of the programs above the following message may be encountered: 
   
"This program was unable to connect to your Firebird / Interbase Server. This is likely due to the 
fact that the default Interbase User Account has been change. Please provide a User Name and 
Password with Administrative Privileges to Interbase." 
   
Description 
Users may encounter this issue for one of the following reasons: 
If running from a Server: 

1. If you're using an NT server and trying to install the database files to a drive other than C:\, 
permissions to the database folder may be incorrect. 

2. If running from a Standalone Computer: 
3. Interbase Guardian may be shut down 
4. If running from a Client Workstation: 
5. Incorrect Server Name and/or Database Path 
6. Client needs to have TCP/IP installed 
7. Server may be down 

 
Possible Resolution 

1. If running Gradience from a Server and encountering the above issue, try each of these 
solutions: 

2. Check your permissions for the Database folder. Full Control access must be given to 
System for the database folder. You may add to the Permissions by going through 
Windows NT Explorer and going to Properties by right-clicking the database folder. 

3. Check to make sure Interbase Guardian (or Interbase Manager) is running. 
4. On a Win 95/98 system there will be an icon in the system tray (next to the clock). The icon 

graphic appears as a gray tower with a green flag. When you put your mouse over the icon 
it will read, "Interbase Guardian". This icon will not appear on a Win NT/2000 system. You 
may check to see if it is running on a Win 95/98/NT/2000 system by clicking on Start, 
Settings, Control Panel and clicking on the Interbase Manager. If it is not running click on 
Start (from within the Interbase Manager), then try to open the Gradience application 
again. 

5. If encountering the message when running from a Client Workstation, try this: 
6. Check the Server Name and Database Path by going to the Server, opening the 

Gradience application and clicking on Help, System Information and printing out this 
information from the TechSupport Tab. (If you don't have the TechSupport Tab then you 



have an earlier version of Gradience and will need to do a screenshot of the System 
Information screen and Current Users screen and print them out.)  

7. Once you have the Server information, go to the Client Workstation that you cannot 
connect to the Server with. From the Workstation, click on Start, Run, and enter: 
HRWARE.INI. Verify that the Server Name and Database path are the same. 

   
NOTE: The printout of the Server Name and Database path you were asked to print or write down 
when installing the Server side must be exactly the same when entering this information on the 
Client Workstation(s)!  
   

8. The Client needs to have TCP/IP installed. 
9. This is done through the Network Neighborhood Properties. Please see your Network 

Administrator if you need more assistance in setting this up. 
   
If everything is the same on the Client as it is on the Server and you're still unable to connect then 
try this: 
   
If your Server has a static IP Address, try entering this for the Server name when installing to the 
Client Workstation. 
   

10. If running from a Client Workstation and you went through the steps above and it didn't fix 
the issue check with your MIS or Network Administrator regarding the status of the Server. 

   

Getting SQL Parse Error: EOF in String Detected              
      
Issue: Getting an error message when logging in. Receive the following error message when 
logging in: SQL Parse Error: EOF in String Detected 
   
Description: This is caused when pressing the comma key ( ‘ ) and Enter key at the same  
   
Possible Resolution(s):  
Avoid pressing the comma and Enter key at the same time.   

Unable to install on a Windows 2000 system              
Issue: Doesn’t finish installation 
   
Description: This usually happens if you do not have full administrator rights on the Windows 
2000 computer. 
   
Possible Resolution(s): 
Make sure you have full administrator rights before installing.  

Exceeded the authorized user count              
Issue: 
You have exceeded the authorized user count. Your product license allows up to [number of 
licensed users] simultaneous users. There are # connections at this time. 
   
The # connections is a number greater than one that changes each time you close and reenter 
the program. 
   



Description: 
Users may experience this issue when closing the program by clicking Exit under the File menu. 
Users who exit the program by clicking the close window icon in the top right corner will not 
experience the problem, but we still recommend downloading and installing the latest update.  
   
Possible Resolution: 
Download and install the latest Gradience program from our Updates area on our Web site at: 
www.gradiencesupport.com. 
   
Please follow the installation instructions. After downloading and installing the update follow the 
steps below to clear the connections. 

1. Close Gradience and any other Gradience Programs that are open. 
2. Open DB Monitor and log in, if it is not already running. The DB Monitor resides on the 

computer where the Gradience database is installed. 
3. Click the Connections button. 
4. Click the Refresh button to verify all connections are "N" (not active).   
5. If all connections are "N", then Click the Clear Inactive Connections button, this will reset 

the connections.  
6. If you wish to close the DB Monitor (not recommended if you have automatic database 

backups scheduled), right-mouse click on the icon Gradience Database Monitor located in 
the system tray area, select Shutdown Database Monitor, and click OK to close DB 
Monitor. 

7. Otherwise, click the Hide button. 

Moving Database from One Location to Another 
Issue: 
Need to move your Gradience database from one computer (or drive) to another.  
   
Description: 
You may need to move the Gradience database because of receiving a new computer, new 
operating system, or running out of disk space among other reasons.  
   
Possible Resolution: 
The easiest way to move the database is to make a backup of your current database, install 
Gradience on the new computer, and restore the database. Follow the detailed instructions 
below:  

1. From the current database backup your files from within the Gradience program by going 
to File > Maintenance > Backup Database or using the DB Monitor (go to Start > 
Programs >Gradience > Maintenance > DB Monitor > Backup). Put this file in a 
location where you can get to it from the new computer. For example, onto a shared 
network drive or Zip Drive.  

2. On the new computer, whether installing to a Standalone Computer or Client-Server 
environment, we recommend installing Gradience using Custom as the Setup Type and 
Server as the Install Type. This will put a blank database at that location. Restore the 
database (from Step 1) using the DB Monitor. When restoring, you can only restore from 
the computer where the database resides. You will not have the option in the DB Monitor 
to restore from a Client Workstation. Note: When going through as a Server Install, this will 
give you the Server Name and Database Path. Write this information down or print it out if 
you have client workstations that need to connect to the database.  

3. To point the Client Workstation(s), if applicable, to the new location launch the Gradience 
program from the Client and enter the Server Name and Database Path (from Step 2) 
when it asks for it.  
 

http://www.gradiencesupport.com/


Please contact Technical Support if you’re having problems installing or connecting to the 
database. Note: Technical Support cannot assist you with Network issues, such as setting up 
network access rights or checking your TCP/IP connection, but they may be able to give 
suggestions to common issues. 
   

Installing Gradience Files to Another Drive Other than 
C:\ 
Issue: 
Installing Gradience files to another drive other than the C:\ drive 
   
Description: 
Sometimes installing to the C:\ drive is not feasible. It may not have much space left or it’s not 
meant for database files.  
   
Possible Resolution: 
When installing Gradience there are three different sets of files that get installed: Program Files, 
Database Files and Database Engine Files (Interbase). When choosing Custom Install, you may 
select the location for the Program and Database Files that get installed at the same time. 
Interbase will automatically install to the c:\ drive after you click on the first Finish button. If this is 
okay, then you only need to follow Step 1 below and click on Finish. Otherwise, if you also want 
to install Interbase to another drive, then follow all of the below steps: 

1. Run the installation of the selected Gradience program (such as Gradience Attendance , 
Records or TimeClock. When going through the installation process, choose Custom for 
the Installation Type. For the next two screens (Program Files and Database Files 
Location), click Browse to choose where to install them.  

2. Stop at the point where it says FINISH. Do not click on it. Leave the install window open at 
this screen. Open Windows Explorer and go to the Windows Temp directory. 

3. From the Windows Temp directory locate (or do a search for) IBWin32setup.exe. 
4. Double-click on this file to start the installation process. This will install the database 

engine files (Interbase) and give you the ability to install these files to another drive other 
than C:\.  

Install Update from One Location  
Issue: 
When a new update is released, you must install at each client workstation(s) and at the 
database server. These instructions will show you how to set up the Gradience folders to only 
install the new update once from one central location.  
   
Description: 
Setting up one shared directory for the program files will make updates quicker and easier.  
   
Possible Resolution: 
These instructions will explain how to set up the Gradience program files in one shared location 
to make updating easier: 
   
1. Copy the Gradience installation file(s) to a shared directory. The Server and all 

workstations that will have (or already have) Gradience installed should have access to this 
shared directory on the network. If you downloaded the Gradience update from our Web site 
(www.gradiencesupport.com), then you will only have one file. If you have an Gradience CD 
then you will need to copy the appropriate Gradience program keeping all of it’s folders intact. 

http://www.gradiencesupport.com/


For example, while navigating the Gradience CD through Windows Explorer, under the   BIN 
folder, you would copy the Atcon70 folder to the shared directory.  

2. From the Server (or computer where the database resides), navigate to the shared directory, 
and run the Server installation (even if the Gradience program is already installed on the 
Server) by following these steps: 
2.1. At the Setup Type, select Server. Click Next. 
2.2. At the Installation Type, select Custom. Click Next. 
2.3. At Select  Components, leave the defaults. Click Next. 
2.4. At Program Files Location, click Browse and navigate to the Shared directory. Add   

\Gradience   to the end of the Path. 
2.5. At the HRWare Database  Files Location, click Next. 
2.6. Write down or print the Server Name and path. These will be needed for the Client 

installs. Click Close, then Next. This will install the Server files. 
2.7. If the Interbase install starts up, click Next to install it, otherwise, go to Step 2.8. 
2.8. Go to Client Workstation. 

3. From the Client Workstation, navigate to the shared directory, and run the Gradience 
installation (even if the Gradience program is already installed on the Workstation) by 
following these steps:  
3.1. At the Setup Type, select Client. Click Next. 
3.2. At the Installation Type, select Custom. Click Next.  
3.3. At Select Components, leave the defaults. Click Next. 
3.4. At the Program Files Location, click Browse, and navigate to the \Gradience shared 

directory created during the Server install. Click Next. 
3.5. At the Database Server Information screen, enter the Server name and database path 

exactly as shown from the Server install.  
3.6. Click Next. This will install the program files. 
3.7. Follow the above steps for any other Client Workstations that will have Gradience 

installed. 
   
When the above steps are completed once, then when you need to install an update, only 
steps 1 & 2 (2.1—2.7) need to be completed. All users must exit the Gradience program(s) before 
updating. All of the shortcuts on the Client Workstations will be pointed to the shared directory 
that will be updated when the Server install is completed. 
   

USB Fingerprint (BIO) Reader Setup Guide 
This document covers the following for setting up (enrolling) User and Employee fingerprints for 
use with the USB Fingerprint Reader and TimeClock application:  
   

Pre-setup Requirements
User Access Vs. Employee Access
Setting up User Access for use with the Fingerprint Reader
Logging into the TimeClock Administration using the Fingerprint Reader
Setting up Employee Access for use with the Fingerprint Reader
Clocking in/out with the Fingerprint Reader
Logging into MyTimeClock with the Fingerprint Reader
Maintenance

Pre-setup Requirements 
The following should be completed prior to setting up the USB Fingerprint Reader:  
   
Time Clock Application installed (MyBiz 2.3.x.x or Gradience 8.3.x.x and above) 
Device Driver for the USB Fingerprint Reader installed 



USB Fingerprint Reader connected 

User Access Vs. Employee Access 
User Access - is given to Supervisors and Managers and to any one else who will need access to 
set up or maintain the program. User Access is set up through the     User Security feature.   
Employee Access - is given to those employees who will be clocking in and out. Employee 
Access is set up through the  TimeClock Access feature. 

Setting up User Access for use with the Fingerprint 
Reader 

1. From within the TimeClock Administration, go to Settings, then   User Security.  
2. Either select a user from the list or create a new user. 
3. Under the Fingerprint heading, click on the Add button and follow the onscreen 

instructions. 
4. Click the Save button when completed. 

Logging into the TimeClock Administration using the 
Fingerprint Reader 

1. Close out and launch TimeClock Administration to get to the login screen. 
2. At the login screen, you may log in by fingerprint any time the “Fingerprint Scanner 

Ready…” message is displaying. The Fingerprint Scanner will become inactive after 90 
seconds. 

Setting up Employee Access for use with the Fingerprint 
Reader 

1. From within the TimeClock Administration, go to TimeClock Access. 
2. Select an employee to edit. 
3. Under the Fingerprint heading, click on the Add button and follow the onscreen 

instructions. 
4. Under the TimeClock Access heading, place a checkmark in the Enable Employee 

TimeClock Access checkbox. If unchecked, the selected employee will not have access to 
clock in/out.  

5. Click the Save button when completed. 

Clocking in/out using the Fingerprint Reader 
A learning curve is not involved in clocking in and out with the Fingerprint Reader.  

1. Connect the USB Fingerprint Reader to the same computer where the TimeStation is 
running. 

2. Employee’s clock in/out by placing their finger on the Fingerprint Reader at any time when 
the TimeStation is running.  

Logging into My TimeClock with the Fingerprint Reader 
1. From the TimeStation screen, click on the My TimeClock button or press   F9.  
2. At the login screen, you may log in by fingerprint any time the “Fingerprint Scanner 

Ready…” message is displaying.  

Maintenance 
Using a non-scratch cloth clean the lens of the Fingerprint Reader as needed.  
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The above marks in gray designate minutes with the decimal equivalent below them. Semi-gray 
designate minutes that are equally divisible by 60.  
   
The formula for getting the decimal number is minutes divided by 60.  
   
Gradience TimeClock  automatically converts the time entry minutes to decimals. For example, if 
Joe had worked 8 hrs and 30 minutes, Gradience TimeClock would show this as 8.5 hrs. This 
makes it easier for payroll purposes. 
   

Import / Export File Format 
   
You may import and export only the fields on the Field Layout page. There are two different 
formats that you may use: Tab Delimited and Fixed Length.  
   
For a Tab Delimited format you may use any program that allows you to save as Tab Delimited. 
Excel and Access are two that will allow this. This is the easiest format. 
   
When entering your information into a spreadsheet such as Excel, you will need to follow the 
order of the field names according to the Field Layout page.  
   
For example, the columns should have SSN first, then Last Name, First Name, etc. Also, you will 
need to leave a blank column for any fields that you will leave blank. For example, following the 
format on the Field Layout page, we create a Tab Delimited file with the fields: SSN, Last Name,        
First Name, [blank column for Middle Initial field],  Location,  Department, Date of Hire,  



Full/Part Time, [blank column for Title field], [blank column for Employee Code field] and        
Active Status. All of the fields in bold are required. We would still need to have a blank column 
for MI, Title and Employee Code in the order of the fields.  
   
For a Fixed Length format, you may use the DOS Editor or any other editor that shows you the 
field length. The lengths of each field must correspond to the Length column under the Field 
Layout page. We recommend using the Tab Delimited format.  
   
   
The following is the field layout for importing text files into Gradience Attendance. Fields shown in 
bold type are required and all import text files must include them. 
   
Field NameLengthFormat 
Social Security Number 11 123-45-6789  
Lastname 20 up to 20 characters 
First Name 20 up to 20 characters 
Middle Name 20 up to 20 characters 
Location 50 up to 50 characters 
Department 50 up to 50 characters 
Date Of Hire 10 MM/DD/YYYY (slashes required)
Full/Part Time 1 Full-Time or Part-Time (only) 
Title 30 up to 30 characters or numbers 
Employee Code 14 up to 14 characters of numbers 
Active Status  10 Active, Inactive, Terminated 
   
If you have Records installed, your text file can also include the following fields: 
Date of Birth 10 MM/DD/YYYY (slashes required) 
Address 1 30 up to 30 characters or numbers 
Address 2 30 up to 30 characters or numbers 
Home Phone 30 800-123-4567 (dashes required) 
City 30 up to 30 characters or numbers 
State (2 character) 2 2 characters, i.e., FL 
Zip Code 15 33325-1234 (-1234 can be omitted) 
Salutation 5 Mr. – Ms. – Mrs. – Dr. (only) 
Employee Security Level 16 up to 16 characters or numbers 
Race 25 Must match a valid race on the detail tab. 
EEO Category 25 Must match a valid category on the detail tab.
Sex M/F 1 M or F only 
Driver’s License Number 15 up to 15 characters or numbers 
I9 Renewal Date 10 MM/DD/YYYY (slashes required) 
Veteran Status 25 Disabled - Vietnam Era - Other Veteran –  
Office Phone & Ext. 30 800-123-4567 Ext. 123  
Fax 30 800-123-4567  
Email address 30 up to 30 characters or numbers 
Address Effective Date 10 MM/DD/YYYY (slashes required) 
   
   
   
   



 

Magnetic Stripe Card Specifications        
This information is if you are going to utilize a card reader.  
Keyboard Wedge – The reader may be a magnetic stripe card or bar code reader. We have 

tested with a keyboard wedge, which the keyboard connects into the reader and then to the 
computer. 

Formats: ISO 7811, AAMVA, and CA DMV. 
Cards must be pre-encoded (on one track only) with up to 24 alphanumeric characters on track 1, 

2 or 3, with a single carriage return at the end. 
If you have a technical question, please contact Technical Support at (888) 925- 7740. 
  

Standard Time Vs Military Time 
The following chart is for reference. 
Standard Time Military Time 
12 pm               1200 hrs 
12:30 pm 1230 hrs 
1 pm                  1300 hrs 
2 pm                  1400 hrs 
3 pm                  1500 hrs 
4 pm                  1600 hrs 
5 pm                  1700 hrs 
6 pm                  1800 hrs 
7 pm                  1900 hrs 
8 pm                  2000 hrs 
9 pm                  2100 hrs 
10 pm                2200 hrs 
11 pm                2300 hrs 
12 am                2400 hrs 
1 am                  0100 hrs 
2 am                  0200 hrs 
3 am                  0300 hrs 
4 am                  0400 hrs 
5 am                  0500 hrs 
6 am                  0600 hrs 
7 am                  0700 hrs 
8 am                  0800 hrs 
9 am                  0900 hrs 
10 am                1000 hrs 
11 am                1100 hrs 
   
   

ET215 Terminal Quick Start 
Overview 
This is a QUICK START document for use with the TimeClock Remote Ethernet Terminal. It will 
help the first time user get a terminal installed and communicating rapidly. It is strongly 
recommended that this documentation is reviewed BEFORE installation of the terminal is 
attempted. 



   
It is assumed that the user has a host computer with the TCP/IP network protocol installed and 
the computer is connected to the Ethernet network. It is also assumed that the installer is familiar 
with network fundamentals such as IP address and port number. The Gradience TimeClock 
Remote program is required to remotely configure and test the terminal over the network.  
   
TimeClock Remote Configuration 
The terminal must be configured with a valid IP address BEFORE it can be installed on the 
network. Initially this process is accomplished using the keypad & display. Once it is configured 
properly and installed on the network, it can be reconfigured over the network using the 
Gradience TimeClock Remote program. 

1. Attach the power adapter to the terminal and plug the adapter into a power receptacle. 
2. The terminal should “beep” three (3) times and then display the “Offline” message. 
3. Hold down the “S1” & “S2” keys and then press the “IN” key to enter the configuration 

mode. A menu will be display, press the “2” key to modify the configuration parameters. 
4. The default IP address will be displayed. In most cases the default IP address 

(192.168.168.50) will have to be changed. Use the keypad to modify the IP address value 
and press the “Enter” key. 

5. The default network mask will be displayed next. Change this if you have a network mask 
and press the “Enter” key.  

6. The other setup parameters are presented one at a time on the terminal display. Press 
“Enter” until you get to MODE. Change the Mode parameter to 2. The default values for 
the others should be valid for most applications and can be accepted by simply pressing 
the “Enter” key.  

7. When all of the setup parameters have been entered, the terminal will return to the 
configuration menu. Press the “Enter” key to exit the configuration mode. The “Offline” 
message will be displayed. 

8. At this point the terminal can be powered down and is ready for installation. 
   
Installation 
   
Once the TimeClock Remote has been configured, it can be installed on the network. 

1. Connect the terminal (RJ-45) to a 10/100BaseT Ethernet hub (or switch) with a standard 
Ethernet cable.  

2. When power is applied one of the network status LED indicators should light. 
3. Start the TimeClock Remote program on the host Windows PC computer and login by 

going to File > User Login. 
4. Click File > New Terminal to create a new terminal connection. The Terminal Name is 

what will display under Help > System Information on any Gradience program. Select the 
TimeClock Remote (or the appropriate Terminal Type) and enter the IP address and the 
Port Number (default is 1070). 

5. Select Connect at Startup and press Connect. The TimeClock Remote program will display 
Connected and the Terminal will respond with the date and time. This indicates the 
Terminal is communicating over the network and is ready to accept commands. 

6. Data can be entered on the TimeClock Remote keypad by pressing the numeric keys and 
then pressing the “Enter” key. The entered message will appear on the telnet client 
screen.  

7. If the TimeClock Remote is equipped with a card reader (mag-stripe) the decoded output 
can be displayed. 

 
Optional digital I/O functions can also be tested using the RELAY, INPUTS, and COUNTER 
commands. 
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