
SirieTMS™ version 2.8.06 (Standalone concept) 

SOFTWARE USER MANUAL 

 

A) Pop-up Dialog Messages 

 

Database initialization 

 

When running for the first time, a database has to be initialized first because anything could happen. Once the database has been 

successfully initialized, all you have to do is press ‘OK’ and restart SirieTMS™. 

 

SirieTMS Login dialog 

 

This is the login screen for SirieTMS™. For the default username and password, please refer to the information that has been provided 

to you upon purchase. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



B) Main Page 

 

 

This is the default main screen. 

 

 

 

 

 

 



C) Menu Functions 

 

File > Change Password 

 

The username for the login is fixed so it is non-changeable. However, the password could be change. 

 

File > Company Info 

 

The report header consists of 3 lines which will hold the Company Name, Company Address and Telephone & Fax No. It is not 

necessary for you to key in just your company name only under the Company Name field. You could add your company registration no. 

or anything that you wish for it to appear at the header section of the report. 

 

As for the second section, each time recorder comes with a unique serial and keying them in will provide better management of time 

recorders especially when there’s more than one in use. 

 

 



Help > Registration Info 

 

This is where you enter in the CD-Key provided to you in order to activate your copy of SirieTMS™. However, you are only allowed to 

register if the correct dongle is detected, otherwise you would not be able to register. So, make sure you have the correct dongle 

attached and the correct CD-Key. 

 

D) Admin Data 

 

Admin Data > Department Setting 

 

Here is where you specify the department. And the department will then be assigned to the employees. Please take note that, 

department that is still attached to at least 1 employee will not be allow to be deleted. 

 

 

 

 



Admin Data > Shift Setting 

 

Shift Name: the name/description of the current shift.  

Currently, there’re only 20 slots of shifts available.  

Start of working time and end of working time represent the start and end of the normal working hour shift. And the lunch break will be 

deducted from the amount of time when the report is generated. When ”Pre-allocated Lunch Break __Minutes” checked, the specified 

lunch minutes will be deducted from the overall working time for that particular employee in that particular day. 

 

Admin Data > Leave Setting 

 

The descriptions here will be used when doing manual adjustment for employees that applied for either paid leave or unpaid leave. The 

fixed fields are used during payroll posting.



Admin Data > Calendar 

Here is where you can set which date of the year will be regarded as holiday; so when doing the reports, SirieTMS™ will take into 

account of those dates specified. 

 

 

Admin Data > Employee Setting @ Employee Details 

 

 

 

Card No.: should only consist of numbers and it must strictly be 8 digits. 

 

Employee Code: And it is advisable to use only numbers for employee code and the maximum code length are 8 digits. 



 

Display message 1 & Display message 2: SirieTMS™ Time Recorder allows 2 lines of message to be displayed when an employee 

touches his card and here is where you specify what should be displayed for that particular employee. Both fields are optional. 

 

Display mode: in order for to display message 1 & 2, all Messages should be selected under display mode. The other options are Card 

Number only, this will only show the card number on the time recorder; if Employee Code only, time recorder will only show the 

employee code. 

 

Picture box: In order to attach a picture to a particular employee, all you need to do is just click on the blank box and a file browser 

dialog will prompt out for you to select the picture. 

 

Payment Type: This setting is mainly used when you post the data to payroll. It is to differentiate between employees that are being 

paid hourly or monthly. 

The others are self-explanatory. 

 

Admin Data > Employee Setting @ Shift Details 

 

Under this “Shift Details” for each employee, you can preset the weekly work schedule for that particular employee. It means an 

employee will be able to have 7 different work schedules for that whole week (weekly schedule). 

 



Admin Data > Employee Setting @ Change Shift 

 

An employee who wishes to change shift will be able to do so under the “Change Shift” functions. Just select the date that the 

employee wishes to change and then select the new shift under “Change To Shift”. A remark could also be specified to give further 

explanation as to why that particular employee wishes to change shift. 

Admin Data > Master Card Setting 

 

Master card is specified for the purpose of getting the data into the SD Card from the time recorder. In order to retrieve data from the 

Time Recorder, you need a master card to access it.  

In order set in a master card, all you need to do is click on the “Read A Card” button and touch the card that you wish to set it as a 

master card onto the time recorder (make sure the time recorder is attached and switched on) 

The rest of the fields are the same as described earlier in “Employee Setting”.



Admin Data > Temporary Card Setting 

`  

 

The procedure here is almost the same as Master Card Setting. The only difference is the additional “Description” field for you to 

specify the use of that particular temporary card be it for a visitor use or something else. 

 

E) Attendance Report 

Attendance Report > Personal Report 

 

This is where you get your personal report done. There are basically 3 functions here under personal report. The first one is the 

“Manual Adjustment”, the second is “Generate Report” and the third is “Preview/Print Report”. 

Each of these 3 functions will be discussed in a details on the following pages. 

 



Attendance Report > Personal Report > Manual Adjustment Selection Dialog 

 

This is the dialog screen that you will first see when you click “Manual Adjustment” on the personal report screen. It basically asks you 

which employee’s transactions that you would like to adjust manually and also the period of the adjustment will take place. 

 

 

 

Attendance Report > Personal Report > Manual Adjustment Selection Dialog > Manual Adjustment 

 

This is the ‘Manual Adjustment” screen. 

Practically in manual adjustment, you can only insert new time stamps. You are unable to delete time stamps that were collected from 

the time recorder. You can delete time stamps that were manually inserted but not the time stamps that were collected from the time 

recorder. 

There are 2 types of pre-set time stamps that you can insert manually into the database. The first one is the leave’s time stamps which 

come as a pair. When an employee took a paid leave, you specify the period of hours that he is going to get “paid for”. And if it’s an 

unpaid leave, just select which kind of unpaid leave should the employee be put under from the drop down list. 

Single record time stamp insertion is normally used when an employee forgot to punch-in or out, or if the employee forgot to bring the 

card, you can punch it manually for that particular employee. 



Attendance Report > Personal Report > Report Viewer 

 

 

This is what it looks like when you click on the “Preview/Print Report” button on the main personal report screen. Notice the blank space 

on the top of the report above the horizontal line. This is where the information you already keyed-in into “Company Info” (see earlier 

screen at the top). It consist the “Company Name”, “Company Address” and “Phone & Fax No” lines. Of course, you could put in 

anything you like. 

To print the report, just click the printer icon, the second icon from the left at the top. 

To export the report to a different format, click the “Export” button, the far left icon and choose the desired format that you wish to export 

to. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



F) System Maintenance 

 

System Maintenance > Hardware Setting 

 

Working Directory: This is the working directory where the files and data would be stored in. It is recommended that you do not 

change the working directory path. 

 

Record Files Directory: The directory/folder would be located inside the working directory path specified earlier. This directory 

temporarily stores the data that is being transferred from the SD Card into the database (Attendance Report > Get Data) 

 

Record Backup Directory: Every time after a “Get Data” session, all the files from the SD Card that were transferred into the database 

will be put into this directory as a backup. 

 

Time Recorder Directory: This specifies the directory of the time recorder. 

 

Default Display Mode: Here is where you specify the default display mode. You could change it under each individual setting in the 

Employee Setting, Master Card Setting and Temporary Card Setting. 

 

Last Maintained Time: Last maintained time shows you when is the last time you maintained the database, i.e, when is the last time 

you clear some records from it using the “Clear Record Till” function. 

 

Current Record Amount: This specifies the number of time stamps that contain in the database. 

 

First Record Date: The first time stamp in the database. 

Last Record Date: The last time stamp in the database. 

 

 

 

System Maintenance > Card/Machine ID Upload 



 

Here is where you upload the card data into the time recorder. Click “Upload To Time Recorder” and wait for the data transfer process to 

complete. Once completed, a message will prompt out to inform you. If the “Upload To Time Recorder” button is disabled, just click 

“Browse Database (PC)” and the “Upload To Time Recorder” button will be enabled back again. 

“Browse Time Recorder” will list out the current data that is available in the time recorder. 

Note: Make sure the time recorder is properly attached and switched on. 

 

System Maintenance > Clear Memory 

 

Clear memory will clear all the time stamps that are available in the time recorder. It will NOT clear the card data but only the time 



stamps data. If you wish to see the time stamp data, just click the “Connect” button and scroll on the vertical or horizontal scroll. 

Horizontal scroll: To navigate the date 

Vertical scroll: To navigate the data for the selected date. 

Once the memory has been cleared, it is NOT recoverable. So make sure you have made all the necessary backup before proceeding 

with this. 

 

System Maintenance > Company Setup 

 

Adjust controller’s display name, and set a menu password in order to manage the controller‘s setting. 

User can set the controller’s display name and menu password in Company Setup - by selecting the controller ID and enter the name 

for the particular controller, follow by entering the menu password. Click “Transfer” to start the upload process.  

 

System Maintenance > Initialize Controller 

 

The Initialize Controller is to set up the controller and door setting. Each controller has a unique controller id and IP Address. 

Furthermore, one controller can control minimum of 1 doors and maximum of 4 doors. If the controller selects to control 1 door, one 

door id and name will be listed on the door list which is under the particular controller id and the door id must be unique. In addition, 

door’s use mark is use to control which door or controller can be used by user. 

 



Set Type:  State how many door can be controlled by that particular controller. One controller can only control 1 door, 2 doors or 4 

doors. 

 

CommPort:   Communication port 

  

CommType: Consists of two Communication Type, TCP/IP and RS-485.Different controller model uses different communication type. 

• Controller model <AD370W > - TCP/IP 

• Controller model <AD370> - RS 485 

 

IPAddress: Internet Protocol or IP addresses, KACS will base on the controller’s IP address stated on Initialize Controller Page to 

control the controller. 

 

Use mark: The door is using 

                  The door is not using 

 

**Note: 

To connect the computer to the controller 

1. Find out what is the Controller IP Address from Controller. (e.g. 192.168.0.147) 

   (Step: Menu>System>Set TCP/IP>IP address) 

2. Choose TCP/IP for “CommType”. 

3. Double Click the IPAddress column in order to insert the IP address.(e.g. 192.168.0.147) 

 

According to the requirement, enter the value and all the settings will be saved automatically. 

Add Controller/Door: Add new controller or door. 

 

One controller only can control a maximum of 4 doors. So, one controller id only can consist of maximum 4 door id. If one controller 

adds more than 4 doors, an error message will be shown. 

 

 

By default, controller id and door id will be shown while new ID that is still available. All you need to do is to click “Add” button to save 

the setting. 

 



Delete Controller/Door: Delete controller or door. 

 

Select which controller id or door id that you want to delete, and then click “Delete” button to delete that particular record from KACS. 

 

Refresh: Refresh the Initialize Controller information after proceed Add Controller/Door or Delete Controller/Door function. 

 

System Maintenance > Register Deregister Setup 

 

Assign card id and Access rights to the employee that has already recorded on personnel (i.e. Personnel Information Maintenance). 

**Note: - Employee who had ticked “Resignation mark” on Personnel Information Maintenance will not be registered. 

             - When the Access Right Status is “False”, it means that the user has not register the particular employee to the controller.  

             - When the Access Right Status is “True”, it means that the user has registered the particular employee to the employee. 

 

Search: Search personnel record by using Personnel ID, Personnel Name or Card ID. 

 

Add:  Assign selected Controller ID and Door ID to the selected employee. 

 

Delete: Delete the selected Access Right. If the user deletes the Access Right when the status is “True”, the system will prompt out a 

message to remind user to click the “Upload” button to deregister the Access Right from the controller. 

**Note: Only one Access Right record will be deleted. 

 

 

User can search employee record by entering the employee’s personnel id, and then click “S” button to start searching. Use the same 

procedure to search employee’s record by using personnel name and card id. 



Register One 

Register the selected employee(s) access rights to the controller. 

           

 

Search: Search employee record by using their Personnel ID/Name, Department and Card No. 

**Note: If the Personnel ID/ Name , Department or Card No. is not entered or selected before click “Search” button, all the employees 

record will be display on source list. 

 

Reset All: Reset all the setting including Personnel ID/Name, Department, Card No., Source List, and Selected List. 

 

Register One: Register the Access Rights for the selected employee(s) to the controller. 

 

Step 1: Search the employee by using their Personnel ID/Name, Department and Card No.  

Step 2: Select the employee from Source list to Selected List. 

Step 3: Click the employee record on the selected list to check their Access Rights. The Access Rights will be display on the Access 

Rights’ table. 

Step 4: A confirmation message will prompt out, click “Yes” to register selected records, or click “No” to cancel this function. 

 

* An error message will prompt out if none of the employee is selected before clicking” Register One” button.  

 

Source 

List 

Selected 

List 

Event 

List 

Access Rights 

Table 



Deregister One: Deregister the Access Rights for the selected employee(s) from the controller. 

 

Step 1: Select the employee(s) who wants to be deregister to the selected list 

Step 2: Click “Deregister One” to deregister the selected employee(s). 

Step 3: A confirmation message will prompt out, click “Yes” to deregister selected record(s), or click “No” to cancel this function. 

 

 

 

 

 

 Exit Register Deregister Setup Form. 

 

Register All 

Register all the Access Rights for all employees whose controller’s status is false. 

 

After assigning the card id and access rights to all employees, you can register them to the controller based on their access right 

assigned previously by using “Register All” function. 

 

Click “Register All” button on Register Deregister setup, and then system will prompt out a message to confirm this action, click “Yes” 

to proceed. After that, “Register All” form will prompt out, click “Start” button in order to begin the register all function. Click “Cancel” 

button to stop register or click “Exit” button to exit “Register All” form. 



 

Event list box will display the situation after doing the registration;  

 

Example message: 

 

(Device: Controller ID - Controller Name - IP Address - Register Status - Action date and time) 

 

Register Status’ list: 

I. Registered successfully- The particular controller’s record had been registered successfully. 

II. Communication Error- The particular controller is not connected with KACS. 

III. Invalid Value- The particular controller’s record is not a valid value. 

IV. Parameter is not hexadecimal - The particular controller’s record parameter is not in hexadecimal format. 

V. Not match parameter length - The particular controller’s record parameter length (e.g. Card No) does not match the format. 

VI. Not supported type- The particular controller’s record type (e.g Date format) is not supported by the system. 

VII. Operation Error- Controller’s operation error.  

    (e.g. Operation error will occur when user deregister the unregistered Card.)  

VIII. Registered failed. Unknown error - The particular controller’s record had not registered successfully because of unknown error 

(i.e. exception error). 

 

 

At Access Rights table, controller’s status will change to “true” for those controllers have been registered successfully. 

 

 

 

Event list  



Deregister All 

Deregister all the Access Rights for all employees from all controllers. 

 (** Note: All records in controller will be cleared.) 

 

Click “DeRegister All” button on Register Deregister setup and then system will prompt out a message to confirm this action, click 

“Yes” to proceed next. After that “DeRegister All” form will prompt out, click “Start” button in order to begin Deregister All function. 

Click “Cancel” button to stop deregister or click “Exit” button to exit “Deregister All” form. 

 

Event list box will display the situation after the deregister has been done;  

Example message: 

 

(Device: Controller ID - Controller Name - IP Address   DeRegister Status - Action date and time) 

 

*Register Status’ list: 

I. Cleared successfully- The particular controller’s record has been deregistered successfully. 

II. Communication Error- The particular controller is not connected with KACS. 

III. Invalid Value- The particular controller’s record is not a valid value. 

IV. Parameter is not hexadecimal- The particular controller’s record parameter is not in hexadecimal format. 

V. Does not match parameter length- The particular controller’s record parameter length (e.g. Card No) does not match the format. 

VI. Not supported type- The particular controller’s record/data type(e.g Date format) is not supported by the system. 

VII. Operation Error- Controller’s operation error. 

    (e.g. Operation error will occur when user deregister the unregistered Card.)  

VIII. Deregistered failed. Unknown error- The particular controller’s record had not been deregistered successfully because of 

unknown error (i.e. exception error). 

 

At Access Rights table, controller’s status will change to “false” for those controllers that have been registered successfully. 

Even list  



G) Miscellaneous > Get Data 

 

Here is where you transfer the data from the SD Card into SirieTMS™’ database. All you have to do is just plug in the USB SD Card 

Reader and select the drive that is assigned to the USB SD Card Reader. Once you have done that, you should see a list of files 

(provided you have transferred the data from the Time Recorder into the SD Card). Below is the format of the filename that you should 

have; 

 

[ AMYYMMDD.Hmm ] 

A: The fixed Starting Code ”A” 

M: Machine ID from A to Z. 

YY: Year 00-99 ex.:05 for year 2005 

MM: Month 01-12 

DD: Date 01-31 

H: The unit of Hour in which the file is created ex. “3” stands for 3 or 13 O’clock. *For distinguishing one from more than one files in a 

day! 

mm: Minute 00-59 

Once you have selected all the files on the left-hand side, just press “Copy” to copy it to the right-hand side. And after you have done 

that, just click  “To Database” and all the data will be inserted into the database. To remove, just select the files to remove and press 

“Remove”. 

 

 

 



Miscellaneous > Data Inquiry 

 

Data inquiry is to browse the database of all the time transactions that has been stored inside the database. 

There are 2 types of data inquiry here. One is to inquire the local database. This is the database that stores all the other information, i.e. 

the employee details and etc. 

The second type is to inquire the data file that is extracted from the “Time Recorder” (the files that was mentioned earlier under the 

section “Get Data”) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Miscellaneous > Group Change 

 

Shift 

Group change shift is basically same as the “Change Shift” function under Employee Setting. The only difference is that, instead of 

changing a shift for 1 particular person at 1 particular date. Group change shift allows you to change shifts for several people at a time, 

in a range of time. 

Usually people would use this functions when they are having a particular busy week and all the employees have to work overtime. So 

it would be easier to change their shift to another shift that would better accommodate the overtime. 

 

 



Miscellaneous ����Real Time Monitoring 

 Collect Transaction data from the controller(s) shown at controller list box on the spot. 

 

**Note: The controller which has ticked the Use Mark on Initialize Controller will only be shown in the Controller Status box. 

 

Step 1: Click “Start Monitoring” button.  

i. Check the controller’s status displayed on controller list. (i.e. Check whether the controller is connected or disconnected to the 

system) 

ii. Collect the transaction data on the spot. 

 

Step 2: Click “Stop Monitoring” button.  

Stop checking the controller’s status or collect transaction data. 

Controller list 

Box. 

**Note:  

(C)-Connected 

 


