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EU Declaration of Conformity  
This is to certify that the accompanying product, identified with the CE mark, complies 
with requirements of the Electromagnetic Compatibility Directives. 

 

Model name: LBP HR  

Year CE mark affixed: 2007 

Type of equipment: An optical beam intensity CCD profiler intended to be installed in a 
Host Computer. The device is constructed from a sensor head with an attached cable  
to the computer via USB 2.0  and control software. 

Has been tested and was found to comply with the requirements of: 

 

• EN 55022 Class B: “Information technology equipment – Radio disturbance 
characteristics – Limits and methods of measurement” (1998 + A1:2000 + 
A2:2003). 

• EN 50024: “Information technology equipment – Immunity characteristics – Limits 
and methods of measurement” (1998 + A1:2001 + A2:2003). 

• IEC 61000: “Electromagnetic Compatibility (EMC)”, 

Part 3. “Limits”; 

Section 3. “”Limitation of voltage changes, voltage fluctuations and flicker in public 
low-voltage supply systems, for equipment with rated current < 16A per phase and 
not subjected to conditional connection” (1995 + A1:2001). 
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Warranty 
Newport Corporation warrants that this product will be free from defects in material and 
workmanship and will comply with Newport’s published specifications at the time of sale 
for a period of one year from date of shipment. If found to be defective during the 
warranty period, the product will either be repaired or replaced at Newport’s option. 

To exercise this warranty, write or call your Newport office or representative, or contact 
Newport headquarters in Irvine, California. You will be given prompt assistance and 
return instructions. Send the product, freight prepaid, to the indicated service facility. 
Repairs will be made and the instrument returned freight prepaid. Repaired products 
are warranted for the reminder of the original warranty period or 90 days, whichever 
first occurs. 

Limitation of Warranty 

The above warranties do not apply to products which have been repaired or modified 
without Newport’s written approval, or products subjected to unusual physical, thermal 
or electrical stress, improper installation, misuse, abuse, accident or negligence in use, 
storage, transportation or handling. This warranty also does not apply to fuses, 
batteries, or damage from battery leakage. 

THIS WARRANTY IS IN LIEU OF ALL OTHER WARRANTIES, EXPRESSED OR 
IMPLIED, INCLUDING ANY IMPLIED WARRANTY OF MERCHNATABILITY OR 
FITNESS FOR A PARTICULAR USE. NEWPORT CORPORATION SHALL NOT BE 
LIABLE FOR ANY INDIRECT, SPECIAL, OR CONSEQUENTIAL DAMAGES 
RESULTING FROM THE PURCHASE OR USE OF ITS PRODUCTS. 

First printing 2007  

 2007 by Newport Corporation, Irvine, CA. All rights reserved. No part of this manual 
may be reproduced or copied without the prior written approval of Newport Corporation. 

This manual has been provided for information only and product specifications are 
subject to change without notice. Any change will be reflected in future printings. 

Newport Corporation 

1791 Deere Avenue 

Irvine, CA 92606 

USA 
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Confidentiality & Proprietary Rights 
Reservation of Title: 
The Newport programs and all materials furnished or produced in connection with them 
(“Related Materials”) contain trade secrets of Newport and are for use only in the manner 
expressly permitted. Newport claims and reserves all rights and benefits afforded under law 
in the Programs provided by Newport Corporation. 

Newport shall retain full ownership of Intellectual Property Rights in and to all development, 
process, align or assembly technologies developed and other derivative work than may be 
developed by Newport. Customer shall not challenge, or cause any third party to challenge 
the rights of Newport. 

Preservation of Secrecy and Confidentiality and Restrictions to Access: 

Customer shall protect the Newport Programs and Related Materials as trade secrets of 
Newport, and shall devote its best effects to ensure that all its personnel protect the 
Newport Programs as trade secrets of Newport Corporation. Customer shall not at any time 
disclose Newport’s trade secrets to any other person, firm, organization, or employee than 
does not need (consistent with Customer’s right of use hereunder) to obtain access to the 
Newport Programs and Related Materials. These restrictions shall not apply to information 
(1) generally known to the public or obtainable from public source; (2) readily apparent from 
the keyboard operation, visual display, or output reports of the Programs; (3) previously in 
the possession of Customer or subsequently developed or acquired without reliance on the 
Newport Programs; or (4) approved by Newport for release without restriction. 

Service Information 

This section contains information regarding factory service for the source. The user should 
not attempt any maintenance or service of the system or optional equipment beyond the 
procedures outlined in this manual. Any problem that cannot be resolved should be referred 
to Newport Corporation. 
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Technical Support Contacts 
 
 North America & Asia    Europe 

Newport Corporation Service Dept.  Newport/Mcro-Controle S.A. 

1791 Deere Ave.    Zone Industrielle 

Irvine, CA 92606     45340 Beaune la Rolande. France 

Telephone: (949) 253-1694   Telephone: (33) 02 38 40 51 49 

Telephone: (800) 222-6440 x31694 

 

 Asia – Newport Opto-Electronics Technologies 

253 Aidu Road, Bold #3, Flr 3, Sec C, 

Shanghai 200131, China 

Telephone: +86-21-5046 2300 

Fax: +86-21-5046 2323 

 

Newport Corporation Calling Procedure 

If there are any defects in material or workmanship or a failure to meet specifications, 
promptly notify Newport’s Returns Department by calling 1-800-222-6440 or by visiting our 
website at www.newport.com/returns within the warranty period to obtain a Return Material 
Authorization Number (RMA#). Return the product to Newport Corporation, freight 
prepaid, clearly marked with the RMA# and  we will repair or replace it at our discretion. 
Newport is not responsible for damage occurring in transit and is not obligated to accept 
products returned without an RMA#. 

E-mail: rma.service@newport.com 

When calling Newport Corporation, please provide the customer care representative with 
the following information: 

• Your Contact Information 
• Serial number or original order number 
• Description of problem (i.e., hardware or software) 

 
To help our Technical Support Representative diagnose your problem, please note the 

following conditions: 
• Is the system used for manufacturing or research and development? 
• What was the state of the system right before the problem? 
• Have you seen this problem before? If so, how often? 
• Can the system continue to operate with this problem? Or is the system non-

operational? 
• Can you identify anything that was different before this problem occurred? 
 

http://www.newport.com/returns
mailto:rma.service@newport.com
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1.0 Introduction 
This manual describes briefly the main capabilities of the LBP HR – high resolution 
Laser Beam Profiler System with 12 bit resolution.  
The LBP HR system is a beam diagnostics measurement system for real-time 
measurement of CW or Pulsed laser beams. It provides an extensive range of 
graphical presentations and analysis capabilities of laser beam parameters, such as: 
beam width, shape, position, power, and intensity profiles. 

 

The LBP HR is based on a USB 2.0 CCD Camera, software driven device, which can 
be connected to a Notebook (or Desktop) computer via the High Speed USB 2.0 port. 

Software version is user-friendly systems that present graphical and numerical 
information for intuitive interpretation of data in real-time.  

Some applications for the LBP HR system, include:  

• Laser beam optimization 

• Quality control 

• Gaussian fit analysis 

• Beam alignment 

Main Software Features 

The LBP HR system software features include: 

• Customer set pass/fail criteria 

• Zooming 

• Average 

• User set threshold levels 

• Data logging to a text file (up to 99 hours) 

• Shutter and gain software controllable 
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• Trigger level software controllable for pulsed lasers 

• Video with playback for future analysis 

• Tile images in matrix format 

• Printing of text and pictures 

• Full on line Help routine 

 
 

 

 

 

2.0 Overview 
A basic LBP HR system includes the following items: 

A CCD detector head: 
LBP HR - a camera head for the 350-1310 nm wavelength range. The system comes 

with a camera, a standard USB 2.0 cable, a post, a set of 3xND-FILT in 
housing and 1xNG10 filter in housing, power supply 6V DC, software on 
CD disk, carrying case. 

Accessories: 

SAM1 - Beam sampler (ration 3x10(-3)) 

SAM2 - Beam sampler (ration 1x10(-6)) 

RDC - Beam Reducer (ration 2.5x1) 

MountB - Mounting base 

ND-FILT - 1/8ND filter, M37x0.75 

NG-Filters - 1.6mm thick Schott colored filter in mount with adaptor, type: NG10 
(optional) 

Acc-Set – Full set of accessories 

 

 

Windows Software 
The installation and application software comes on a CD disk. OS supported are 
Windows XP/Vista.   
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User Manual  
The user manual contains the same information as the On-line Help in the software. A 
README.TXT in the installation disk may have corrections to the manual and the on-
line help. The user manual is saved as a PDF file on the software CD. 

 

Mounting Post 
 The post is 105 mm long with 8-32 thread and is used for mounting the detector  
 head. 
 

QC test and calibration certificate. 
 
 
 
2.1 Revision History 

 Any new editions of this manual will incorporate all material updated since the previous 
edition. Update packages issued between editions contain replacement and/or 
additional pages to be appended to the current edition. A “ReadMe.TXT” file is provided 
during the installation and may contain additions or corrections to the manual or the 
help file. 

The manual printing date indicates its current edition. Updates and corrections to the 
current edition will be indicated. 

- July 2007 – Revision 1.0 

 
 

 

2.2 Precautions 
The LBP HR system is a precision instrument and in normal usage will provide years of 
trouble free operation. However, several precautions must be taken to ensure proper 
function of the devices. 

• The instrument must not be subjected to physical abuse. If the detector head is 
dropped it might be damaged. 

• Temperature and moisture extremes can also damage the instruments. Make sure 
there is adequate ventilation for the host computer. 

• Make sure you have a backup copy for the system CD disk, and that the software 
CD is protected from long term, direct exposure to sunlight and heat. 

• When not in use, keep the Detector head and filter wheel inside the carrying case to 
prevent dust from accumulating on the sensor and the filters.  

• Filters are provided with each LBP HR head. Dust, scratches and other types of 
contamination will degrade the accuracy of the system. Please keep unused filters 
in a storage case. Please be gentle when handling these fragile items.  
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• Laser Safety Rules: Please comply with all relevant laser safety procedures and 
precautions when using this device. The instrument will reflect a portion of the laser 
light. The resulting diffuse and specular reflections may be dangerous. 

 
Contact Newport Corporation if you have any additional questions. 

 

 

 

 

 

 

 

 

3.0 Theory of Operation 
The main technologies available for laser beam diagnostics are:  

• Using spatial cameras as the beam characterization system. 

• Using moving mechanical slit, or knife-edges to scan across the incoming beam. 

 

The main advantage of the mechanical scanning devices over a camera type laser 
beam profiler is the large dynamic range that allows accurate measurements of beams 
with both high and low intensities. On the other hand, camera type laser beam profilers 
are excellent for fast and detailed analysis of laser beam intensity profiles, but are 
limited in their accuracy due to a relatively low dynamic range. 

 

The LBP HR Solution 

The LBP HR overcomes the limited dynamic range of a camera type beam profiler and 
accurately measures faint laser beam structures by sampling the beam several times. 
Each measurement is performed at a different attenuation or electronic shutter speed. 

The LBP HR analyzes both continuous wave (CW) and pulsed lasers, and accepts a 
wide range of input powers. 

The video beam images are digitized with a 12 or 8-bit resolution (1024 or 256 digital 
levels) video capture. The digitized beam images are then stored in memory where a 
variety of analysis can be performed on the stored images. The images are then 
displayed on the VGA monitor according to the user-selected format.  

Additional functions provide the ability to print information, transmit data via an RS-232 
link to another computer, and control numerous video and calibration functions 
including shutter speed and camera gain. 
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Technology 
The LBP HR uses a USB 2.0 video camera to image, capture, store, and perform two-
dimensional intensity distribution analysis on laser beams. 

CCD camera laser beam profilers are based on a mosaic of two-dimensional detectors 
called pixels. The two-dimensional mosaic-like detector instantly records the amount of 
energy impending on its surface, thus recording the optical pattern of the laser beam. 
The intensity distribution of the laser beam is recorded pixel-by-pixel and displayed as 
a two-dimensional topographic map or a three-dimensional isometric view. 

The advantages of a CCD based laser beam profiler is fully utilized by powerful 
software that displays any structure larger than one pixel in vivid colors, calculates the 
beam distribution and profile as well as total beam intensity distribution, in order to 
allow full analysis of the laser beam’s characteristics.
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4.0 Specifications 
This section describes the technical and system performance specifications. 

Item Specification 
Camera type Monochrome interline transfer 1.4 Mega-Pixel CCD ½” format 

Sensor active area: 7.6mm wide x 6.2mm high.  

Pixel size 4.65 µm (H) X 4.65 µm (V) 

Spectral Response: 350 - 1310nm 

Weight: 165 gr. 

Power consumption: 6V, 4 Watts 

Accessories included: 3X ND 1/8 filter in housing and 1xNG10 in housing, adaptor ring for 
filters. 

 One X 8/32 threaded mounting hole 

Trigger in: Female RCA connector jack 4.5V square wave TTL output  

PC interface: High Speed USB 2.0 (480Mbits/sec) 

RS232: Data out 

Operating temperature: 0ºc to 50ºc 

Minimum host system 
requirements 

Pentium IV, 2.4GHz 512MB RAM  

 100MB HDD free 

 64MB 24bit color VGA card, resolution 1024X768  

 One free High Speed USB 2.0 port 

 One CD ROM any type 

 Windows XP/Vista  

CE compliance  

 

System Performance  with 
Software: 

 

Dynamic Range: Up to 60dB not including filters. 

Shutter speeds: 1µs to 0.6 sec 

Software controlled gain 1dB to 23dB 

Maximum frame rate 25Hz 

Sensitivity: ~5nW/cm² at 633nm  

~60µW/mm² at 1310nm  

Saturation intensity: ~2mW/cm²  

Damage threshold 50W/cm² with all filters installed.  

Operation with pulsed laser Ability to capture and replay pictures and statistics from a slowly 
pulsing laser (1-100Hz) while filtering out frames with no laser pulse. 

Hardware Triggering In pulsed mode, sliding bar control allows setting of threshold so as to 
display only frames with captured pulses. 
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Figure 1 Camera Dimensions 
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Figure 2 Accessories combination 

 

 

 
Figure 3 Full accessories set 

 
1-LBP HR, 2-MountB, 3-SAM2, 4-Filter Wheel, 5-RDC,                
6–NG filters and adapter, 7-ND-FILT 
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5.0 Quick Reference 
This chapter provides brief instructions for operating your LBP HR. Full explanations of 
these various operations can be found throughout this manual. 

 
To install the LBP HR USB 2.0 version: 
1.  Check Hardware Requirements   

2. Follow Software installation   

3. Connect the LBP HR CCD camera into a Hi-Speed USB 2.0 -compliant port.. 
4. Connect the power supply cable to the LBP HR USB 2.0 camera via the 6V jack and 

plug the power supply into the surge-protector outlet. 

6.  Follow Hardware installation – USB 2.0 Camera 
 

To configure the LBP HR hardware and software: 
1. Open the Settings menu and select Hardware Setup. 

2. Click each tab and enter your hardware information in each window. 

3. Repeat steps 1 and 2 for Software Setup. 

 

To set up the laser beam mode: 
1. From Hardware Setup, select either CW or Pulsed. 

2. If Pulsed is selected, then the  icon is displayed at the Control Toolbar. Select a 
shutter speed that enables an acceptable saturation level. 

3. If the image is still saturated at the fastest shutter speed, attach ND filters to the CCD 
camera until an acceptable saturation level is reached. 

4. Further adjust the intensity level using the gain control  

5.  Adjust the trigger level using the  icon until you get a steady reading. 
It is best to move to the right until triggering stops, and then move back a little. 

 
To measure the beam width: 
1. Open the Settings menu and select System Setup. 

2. Select the Profiles tab. 

3. Set the three clip levels values. 

4. Read the beam width values from the Measurement Data box or from Statistics 
window. 

5. To view more detailed statistics, click  to open the statistics window. 
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To select the profile type:  
On the Control Toolbar, click  for Sum Profiles or  for Line Profiles. 

 
To view the centroid and/or beam peak: 
1. Click  on the Control Toolbar for a 2D display. 

2. Click  on the Control Toolbar to view the centroid. 

 

 
To freeze the screen graphics: 
Click  on the Control Toolbar.  

To return to real-time measurement mode, click  on the Control Toolbar.  

 
To print various screens: 
1. To print the entire screen, open the File menu and select Print Screen. 

2. To print the view area only, open the File menu and select Print Frame. 

 
To save screen graphics: 
1. Open the Options menu and select Save image File. A sub-menu displays. 

2. Select the screen section to be saved: Frame, Statistics or Full Screen. The Save 
image File window displays. Select either a BMP or JPG file type. 

3. Enter a filename for the saved screen graphic and click OK. 

To save X-Y profiles: 
1.   Open the Options menu and select Save data in text file. A sub-menu displays. 

2.   Select profiles. 

3. Enter a filename for the saved file and click Save. 

 
To view and print a file: 
1. Click  on the Control Toolbar. The View File window displays. 

2. In the Files of Type field, select the file type for the file you want to view. 

3. Select the file and click OK. 

4. Click on print if you want to print the file. 
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To test a laser beam: 
1. Click  on the Control Toolbar. The Analysis Toolbar displays. 

2. To run the test, click  on the Analysis Toolbar. The Test window displays the test 
results. 

3. To save the current test result in a bitmap or test file, click Save in the Test window. 

 

To calculate a beam elliptical footprint: 
1. From the Control Toolbar, click  to freeze the screen. 

2. From the Control Toolbar, click . The Analysis Toolbar displays. 

3. From the Analysis Toolbar, click . The LBP HR calculates the best-fit ellipse and 
displays it as a dotted white ellipse just around the edges of the measured ellipse. The 
best-fit ellipse parameters are displayed below the Analysis Toolbar. 

 
To measure the distance between two points on the beam image: 
1. From the Control Toolbar, click  to freeze the screen. 

2. From the Control Toolbar, click . The Analysis Toolbar displays. 

3. From the Analysis Toolbar, click .  

4. Select the first point by placing the cursor on the beam image and click the left mouse 
button. Drag the mouse to the second point on the beam image and click the left mouse 
button. A straight line is drawn between these two points and the line distance 
calculation is displayed below the Analysis toolbar. 

 
To create a data log: 
1. From the Control Toolbar, click  to setup the data log. The Log Setup window 

displays. 

2. Enter the information in the Log Setup window and click OK. 

3. From the Control Toolbar, click   to start the data log function. 

4. To view the data log file, open the File menu and select View File. Select the data log 
file you want to view and click Open. 

 
To create a video: 
1. Open the Settings menu and select Video Properties…. The Video Properties window 

displays. 

2. Enter your information and click OK. 
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3. Click  on the Control Toolbar. 

 
To play a video file: 
1. Click  on the Control Toolbar. The Playback Toolbar displays. 

2. Click  on the Playback Toolbar. The Open Video File dialog displays. 

3. From the Open Video File dialog, select the video file you want to view and click Open. 
The video file displays. 

4. Use the Playback Toolbar buttons to play the video. 

5.   Click  to close the video file. 

 
To work with still images: 
1. To capture a still image, click  on the Control Toolbar. 

2. To view a single still image, position the cursor on the still image icon at the Status Bar 
and click the left mouse button. 

3. To close an opened still image click the close button in the upper right corner of the 
image window. If you want to save the still image, click Yes in the Still Image window. 

 
To measure two beam’s centroids simultaneously: 

1. From the Control Toolbar, click  to select the first Region of Interest. 

2. Move the small rectangle marking  to the first beam presentation on the screen, 
magnify or shrink it to the proper size by graphical means (using the mouse). 

3. From the Control Toolbar, click  to select the second Region of Interest. 

4. Move the small rectangle marking  to the second beam presentation on the screen, 
magnify or shrink it to the proper size by graphical means (using the mouse). 

 
To work with snapshot files: 
1. To create a snapshot file, open the Options menu and select Save Snapshot. The 

Save Snapshot File window displays. Enter a filename for the snapshot file and click 
OK.  

2. To view a snapshot file, open the View menu and select Snapshot. The Load 
Snapshot File window displays. Select a snapshot file and click OK. The snapshot file 
displays. Analyze the measured results by activating the system tools. 

3. To close a Snapshot file, open the View menu and select Snapshot. The LBP HR 
restores real-time measurement displays. 
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To transmit serial data over an RS-232 link: 
1. Open the File menu and select Link Setup.  

2. Click the General tab and enter your information. 

3. Select the Port Settings tab, enter your information and click OK. 

4. Connect the LBP HR computer to another computer using a null-modem cable. 

5. Enable the receiving program to receive the file/data. 

6. Open the File menu and select Start Link. If you are transmitting data, the LBP HR 
automatically starts sending the data. A link-in-progress message displays in the menu 
bar. 

7. If you are transmitting a file, the Link File window displays. Select the file you want to 
send and click OK. A link-in-progress message displays in the menu bar.  

 

 
 
5.1 Software General Layout 
This section covers the basic layout of the LBP HR software. 

The LBP HR window display consists of display and control elements similar to most 
Windows applications along with elements specific to LBP HR interface. 

 

5.1.1 Title Bar 
The title bar displays the name “LBP HR USB 2.0”, and followed by the CCD detector SN. 

 

5.1.2 Menu Bar 

 
The Menu Bar lists menus available for LBP HR system. The menus contain commands 
and other sub-menus or dialog boxes to be displayed which provide controls of various 
functions: graphics, analysis, setup configurations. All functions can be activated via the 
menus, some functions can also be activated via the Tool Bar. 
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    Figure 4 General software layout 

 

5.1.3 Control Toolbar 
The Tool Bar consists of various icon buttons, which are small symbols that provide quick 
access alternatives to using menus or keyboard equivalent keys to perform various 
functions. To activate a tool button, place the mouse over the button and click the Left  

mouse button. The button will change both color and shadow to designate the fact that this 
function is activated. This is an example of ToolBar (buttons activated): 

 

To view the function of each icon button, place the mouse cursor on the icon and wait 
momentarily, a brief function description will appear near the icon. 

 

5.1.4 View Area 
The View Area is used to view all the LBP HR graphical presentations, such as: beam 
image, intensity profiles, 2D/3D or Position presentation, as well as summary table of 
measurement results and statistics table. 

 

5.1.5 Status Bar 
The status bar is located at the bottom of the LBP HR window. It indicates the current status 
of some operational parameters, such as presentation of date and time, average level, 
zooming level, Null status, Power reading, and up to 12 Still images taken. The Status Bar 
enables a fast access to system’s setup screens for setting up the average level, the zoom, 
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the null parameter as well as the power calibration: if the mouse cursor is placed at one of 
these parameters and then double-clicked the appropriate setup screen appears. 

Also. If the mouse cursor is placed at any one of the Still Image icons and double-clicked 
the image is then magnified. 

 
 

5.1.6 User Area 
The User Area is used to view beam centroid’s presentation, as well as a summary table of 
measurement data, including the beam width reading at 3 different clip levels and the 
Gaussian fit profile at these levels as well as the correlation factor. 
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6.0 Installation 
This chapter provides instructions for installing the hardware and software for the LBP HR 
system. 

 

  

6.1 Hardware Requirements 
 To run the LBP HR USB 2.0 system, the computer system must meet the following 

minimum requirements: 

Item Minimum Requirements Recommended Requirements 

CPU Pentium 4, 2.4 GHz Pentium 4, GHz 

System RAM 128MB RAM 512 MB RAM 

Hard disk 100MB HD free  

CD ROM drive Any type  

Operating system Windows XP/Vista  

Mouse Microsoft mouse or equivalent  

VGA display 1024 x 768 resolution 1600 x 1200 resolution 

VGA card 16MB 16 bit color 64MB 16 bit color 

USB Port One free High Speed USB 2.0  
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6.2 Software Installation 

Important Note:  Please install the USB 2.0 camera driver before 
connecting the LBP HR USB 2.0 camera to your computer! 

 
Perform Software Installation. Only after you click “Finish” to complete the software 
installation procedure, continue with the Hardware Installation. 
 

 1.Insert the LBP HR CD disk in the CD drive. 
 

 

 
 

 
-  A Welcome screen appears when beginning the software installation routine. Click Next. 
-  Insert your User Name, Company Name and System S/N (appearing on the system CD). 
-  The following screen is a Registration Confirmation. Click Yes in order to confirm. If you 

click No, the software will return back to a previous prompt. 
Now provide the full path for installation of the LBP HR USB 2.0 system software: 
More information about the exact folder for the software and branching in existing folder 
for LBP HR USB 2.0 system software can be done in the Select Program Folder prompt. 
Click the Next button to proceed. 

-  Copying files routine. Click Next button. At this stage the system copies all files from the   
CD-ROM to the selected directory in your computer. There is a graphical presentation 
showing the amount of data copied to the system disk. If the Cancel button is pressed the 
installation is aborted. 

 
- For Windows Vista: 
 

 
  Figure 5 Windows Update 
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  Figure 6 Download and Install Updates 
 
 
 Press “I Accept” button for install update. 
 

  
 

    Figure 7 Update installation status 
 

 
 



  

 28

  
 
   Figure 8 Installation complete 
 

- Setup Complete. 
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6.3 Hardware Installation LBP HR USB 2.0 Camera 
Plug the LBP HR USB 2.0 camera into a Hi-Speed USB 2.0 port. 

The USB 2.0 device will be detected and the New Hardware Wizard will launch. 

 

 

 

6.3.1 Windows XP 
1. The following message is displayed 

 
   Figure 9 Found new hardware wizard 

 
 

 

 

 

 

 

 

 

 

 

 

 
  Figure 10 Welcome screen. Press Next to continue. 
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Figure 11 Alert, press Continue Anyway. 

 
Figure 12 Installing… 
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Figure 13 Complete installation screen 

 

 

 

 

 

 

 

 
Figure 14 Press Next to continue. 
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Figure 15 Press Continue Anyway. 

 
Figure 16 Installing… 
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Figure 17 Complete installation screen 

 

 
Figure 18 New Hardware ready to use 

After completion of USB device installation, when the device is configured successfully one 
can check under System Properties, Device Manager Tab and see that under imaging 
devices the “DO USB 2.0 HR Camera” is listed. 
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Figure 19 Drivers installed list (DO USB 2.0 HR Camera) 

 

6.3.2 Windows Vista 
The following message is displayed 
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Figure 20 Installing device driver software 

 

 
Figure 21 Windows Vista Security 
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Figure 22 Windows Vista Security 

 

 

 
Figure 23 Devices are ready to use 

 

After completion of USB device installation, when the device is configured successfully one 
can check under System Properties, Device Manager Tab and see that under imaging 
devices the “DO USB 2.0 HR Camera” is listed. 
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Figure 24 Drivers installed list (DO USB 2.0 HR Camera) 
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6.4 Running the Software     
Make sure hardware is installed properly. (See Hardware Installation ).  

Boot the computer. 

From the Start Menu, select Programs, then choose LBP HR USB 2.0 folder, and then 
click on the LBP HR USB 2.0 program. Alternatively, you can activate the software by 
placing the mouse cursor at the LBP HR USB 2.0 Icon  and click the mouse button 
twice. 

To end a LBP HR session, open the File menu and select Exit. 

The LBP HR saves all current setup parameters when you exit a session. 

 
Possible Errors that indicate an interface conflict: 
There are a few common symptoms, which point to an interface conflict: 

* System Lock-up during software startup. 

* There is no picture displayed on the screen 

* Displayed measurements are sporadic and erroneous. 
If your symptoms match one of those presented above, or if the LBP HR System was 
working at one time and has now stopped working, check for conflicts with other devices in 
the same computer. 

 
If it has no affect and no new software of any kind has been installed since the LBP HR 
System last worked and the computer has not been moved, contact Newport Inc. for 
immediate support. 

More information about Installation problems in the Troubleshooting section. 
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7.0 Setting Up the LBP HR 
This chapter provides instructions for setting up the LBP HR system. Before you can accurately use 
the LBP HR you must do the following: 

• Configure the hardware 

• Configure the software 

• Configure your continuous or pulsed laser beam 

The LBP HR installs a configuration file called: “LBP HR USB 2.0.ini “ in the LBP HR USB 2.0 
working directory. All system setup parameters are saved in this file, including all setup 
modifications introduced during the last session. When you start the system software, the setup 
parameters in the INI file are automatically loaded. 

7.1 Configuring the Hardware 
To configure the hardware, open the Settings menu and select Hardware Setup. The Hardware 
Setup window displays. 

7.1.1 Hardware Setup - Settings 
From the Settings tab, you can configure the following information: 

• Type of connected camera equipment  

• Input connector 

• Image display 

• Shutter control 

• Gain control 

 
Figure 25 Hardware Setup - Settings Tab Selected 

To configure the hardware settings: 

1. Click the Settings tab. 
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2. Enter your information according to the descriptions below. 

3. Click OK. 

Input Type of video connection: 

• Composite - RCA-style video connector. 
• S-Video - S-Video input connector. 

• Digital Camera - This is the default setting for the LBP HR camera.. 
Flip Frame Flips the image presentation by 180 degrees. 

To flip the image presentation, select Horizontal or Vertical. 
Gain Sets the Gain level manually, values range is 1-23dB. 

                                 
Auto Gain function offers an automatic gain setting, best fitted to the work 
condition. 

Shutter The built-in electronic shutter controls the integration time of each frame. 
By activating the shutter you control the amount of collected light similar to 
the way a mechanical shutter controls the exposure time in a regular 
photographic camera. You select the required shutter speed to prevent 
saturation and distortion of the measured beam profile. This option is 
significant for continuous laser beams only. 

The shutter speed is set manually and is only selectable if you are using 
the LBP HR USB2 camera. Automatic value setting is a future option. 

The possible shutter speeds range from 0.001 to 613 millisecond.  

To configure the shutter speed: 
1. Unselect Auto. 
2. Drag the slide bar along the “shutter scale” to select a shutter speed. 

                                  
Auto Shutter function offers an automatic shutter setting, best fitted to the 
work condition 
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7.1.2 Hardware Setup - Laser 
Laser configuration allows you to specify the type of laser used and define the synchronization. 

 

 

 

 
 

 

 

 

 

 

 

 

 

Figure 26 Hardware Setup - Laser Tab Selected 

 

To configure the laser information: 
Type - select one of the laser types.  

1. Click the Laser tab in Settings, then click CW or Pulsed and then OK. When Pulsed 
mode is selected, the  icon is displayed at the Control Toolbar and next to it the 
Trigger Control Bar for setting up the Trigger level. 

Single shot event -  Capture and look at a single shot event. When single shot is activated, the 
freeze button acts as a run/stop button and can be toggled between Run  
where the system is ready to capture and freeze the next active frame and 
Stop  where system is frozen with the single shot frame, which has been 
captured. 

Trigger -  Select the graphical presentation’s background color. You can choose 
either internal or ex and white (mono). 

Internal Trigger Control - This function sets the minimum signal level at which images will be 
displayed on the screen. It ensures that with pulsed lasers, only frames with 
images will be displayed.  

 Hardware Input. 
 RCA connector (see Fig.1. page 10)  
 Delay: image latency 148 µsec. 
 Shutter exposure: >= (Delay + Pulse width) 
 
Upon selecting the required parameter value, press OK to confirm the selection, press Cancel to 
abort. 
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7.1.3 Hardware Setup - Optical Scaling and Resolution 
If you are using external optics to reduce or expand the beam size, then set the scaling factor 
accordingly. After this is done, all values measured by the CCD will be multiplied or divided by the 
value chosen.  

For example, if you are using an optical attachment which reduces the beam size by a factor of 2, 
choose 2 as the scaling factor and all values read by the camera will be multiplied by 2 to give the 
true size instead of the size as it is projected on the camera. 

 
Figure 27 Hardware Setup - Resolution Tab 

To set optical scaling:  

1. Set the scaling to multiply or divide as needed 

2. If using an external optics, one needs to select the appropriate option in Optical Scaling 
Factor (toggle between Multiply option and Divide option). Then select the appropriate 
Factor parameter accordingly.  

 

Resolution 

The resolution setting is only necessary if you are not using the LBP HR camera. These 
values are the resolution parameters (in microns per pixel) of your non-LBP HR camera.  

The LBP HR camera uses the default values shown in the Horizontal and Vertical fields. 
Please note that the Automatic settings for USB Camera field is checked. 

To configure the resolution: 

1. Click the Resolution tab.  

2. If you are using the LBP HR camera, select Automatic settings for USB camera. 

3. If you are not using the LBP HR camera, enter your camera’s resolution parameters.  

4. Click OK. 
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7.1.4 Power Calibration 
The power calibration function allows you to enter a power value as a "base" power level. 
The power calculation sets the total summed intensity of all the pixels in the subsequent 
captured samples to be proportional to this value. 

 
 Figure 28 Power Calibration window 

To configure the power settings: 

1. Open the Options menu and select Calibrations u Power. 

2. Follow the on-screen instructions. 

3. Enter the power value of your laser beam as measured by a reference power meter.  

4. Click Calibration. 

5. Click OK. 

 

The power reading itself is viewed at the Status Bar. 

 

Note: If you place the mouse cursor at the Power field located at the Status Bar and double 
click the mouse right button you get the Power Calibration Screen.
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7.2 Configuring the Software 
To configure the software, open the Settings menu and select System Setup. The System 
Setup window displays. 

7.2.1 System Setup - Settings 
From the Settings tab, you can configure the following information: 

• Averaged consecutive measurements. 

• Zoom On/Off and setting up the zooming level. 

• Set display presentation 

• Set color or monochrome display for the View Area. 

• Number of still image bitmap files taken during the Still Image function. This is useful 
only for cases of Pulsed Lasers. This parameter will determine the # of images that will 
be captured once the Still Image function is activated. 

 
Figure 29 System Setup - Settings Tab Selected  

 

To configure the system settings: 

1. Click the Settings tab. 

2. Enter your information according to the descriptions below. 

3. Click OK.
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Average Used to smooth the data display of quickly varying sources. 

When using a beam with a significant amount of jitters, set this feature on. 
The LBP HR takes a user defined number of successive measurements. 
These measurements are averaged and displayed.  

For example, you choose a value of 10, ten consecutive measurements 
are averaged and the result is displayed. When an eleventh measurement 
is taken, the first measurement value is dropped and the second through 
the eleventh are averaged, etc. 

Because a successive averaging technique is employed, the window 
display update rate is only slightly affected, if at all. 

 NOTE:  The Average function only affects the numerical data and 
not the picture. The picture is not averaged. 

To smooth the data display: 

1. Select On/Off to activate. Or, 

From the Status Bar, click . The System Setup window 
displays. 

2. Enter a successive measurement value. Possible values are 1-20 
where 1 means no averaging and each measured value is displayed. 

Zoom Enables magnification of the image displayed in the view area.  

When zooming in or out, the system centers the plot as close as possible 
over the current crosshair cursor position. 

To magnify the image: 

1. Select On/Off from the Control Toolbar, click . Or, 

From the Status Bar, click . The System 
Setup window displays. 

2. If Zoom is On set the Zoom level required by pressing on the Up/Down 
arrow buttons (select the magnification you desire, 100% is normal size). 

Set Images Sets the number of still image bitmap files that the system takes during 
pulsed laser operations. 

If, for example, you input 4 and select the still image function, the system 
captures and saves the next 4 still images.  

The set images function is disabled for continuous lasers.  

To set the number of still image bitmap files, enter a set image value. 
Possible values are 1 - 12. 
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Display Toggles between a 2D, 3D or Position graphical presentation in the view 
area. 

To select the graphical presentation: 

1. Select 2D, 3D or Pos Or, 
From the Control Toolbar, click  for a 2D display,  for a 3D 

display or for  Position display. Or, 

Open the View menu and select Display u 2D, 3D or Position 

Color Select the graphical presentation’s background color. You can choose 
either colored or black and white (mono). 

To select the background, select Color or Mono. 
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7.2.2 System Setup - Profiles  
Profiles setup allows you to control the display in the profiles area. 

You can control the following displays: 

• Profile type display 

• Gaussian / Top Hat profile 

• Clip levels  

• Angle of rotation at which the X-Y cross-section profiles are cut. 

 
Figure 30 System Setup - Profiles Tab Selected  

 

To configure the profiles: 

1. Click the Profiles tab. 

2. Enter your information according to the descriptions below. 

3. Click OK. 



  

 48

Profile Type The following methods for profiles calculations are available: 

• Sum Profiles - Displays the two orthogonal profiles, one along the 
vertical axis and one along the horizontal axis. Each profile is 
composed of a summation of rows and columns at a beam cross-
section. 

• Line Profiles - Displays the contour of the beam along a line parallel to 
the vertical axis and a line parallel to the horizontal axis. The two lines, 
along which these contours are displayed, are designated as a cross 
hair cursor. The cross hair cursor can be moved along the image 
screen, so that the displayed profile is the cross section line profile 
located by the cursor. 

To select the profile calculation method: 
1. Select Sum or Line. Or, 

From the Control Toolbar, click  for Sum Profiles or  for Line 
Profiles. Or, 

Open the View menu and select Profiles u Sum or Line. 

To select the angle at which you want to cut the X, Y profiles: 

Click on the On/Off of Rotate Angle and select the angle desired from –45  
to +45 degrees. The allowed increments are 0.1 degree. 
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View Controls the following profile displays: 

• AutoScale On/Off – Displays the profiles using the full height of the 
profile window. 
When Auto Scale is not selected, the beam peak can be observed as it 
changes which can be advantageous during a focusing process. The 
peak intensity changes may be observed as a function of the focus, 
showing the variations in beam’s peak with respect to the changes in 
beam size. 

 
• The Gaussian fit profile shows how closely the measured beam profile 

matches a Gaussian profile. The Gaussian fit profile is displayed on top 
of both the vertical and horizontal profiles in red. 
The Gaussian Fit is a least-squares fit of a Gaussian equation to the 
cross section beam profiles. The correlation coefficient is the 
normalized sum of the fit residuals. The following equation is used for 
the Gaussian Fit calculation: 

                  I = Ve ^ [-(x-c)/σ ] ² 
Where 
I = the intensity of a pixel at location x 
V = the maximum intensity of the fitted Gaussian curve (Peak Intensity) 
C = the center of the Gaussian fit peak (Centroid) 
σ = the radius of the Gaussian fit curve at the 1/e² intensity level 
(diameter) 

 
• Gaussian/Top Hat selects between Gaussian or Top Hat calculation 

and display. The display of the best fit Gaussian or Top Hat profile is 
overlaid in red on top of the profiles in real time 

To configure the profile view, select the desired options. 
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Clip Levels Sets the levels at which the width of the vertical profile and horizontal 
profile are measured by the system. 

A clip level defines the percentage of the peak intensity profile at which the 
beam is measured. For example, a clip level of 50% indicates that the 
beam is to be measured at its full width at half maximum (FWHM), 
whereas a clip level of 13.5% measures the beam at a point, which is 
13.5% of the profile peak. The 13.5% level corresponds to the 1/e2 point of 
a Gaussian profile. 

Both the horizontal and vertical profile windows display the width of the 
beam at three clip levels simultaneously. 

There are three clip levels represented by solid horizontal lines 
superimposed on the profiles. The default clip levels are 80%, 50% and 
13.5%. 

The three clip levels are labeled I, II and III.  

To change the clip levels: 

1. Enter a value in the Clip Level field. The clip levels values are in 0.1% 
increments. Or, 

1. In the profiles area, position the cursor just above (or below) the width 
level bar you want to change. 

2. Press the left mouse button and drag the line up or down, while 
watching the change in the clip level setting on the profile presentation. 
The new clip levels can be seen in the Measurement Data window. 
When performing this operation it is helpful to size the profiles area as 
large as possible. 

Rotate 
Angle 

This option is available only when Line Profile option is enabled. 

Click on the On/Off of Rotate Angle and select the angle desired from –45  
to +45 degrees. The allowed increments are 0.1 degree. Alternatively, 
select the required value for angle rotation via the Control ToolBar, using 

the  icon. 
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7.2.3 System Setup - Projection  
Projection setup allows you to control the display of the image area. 

Displays you control include: 

• Wire density 

• Rotation function 

 
Figure 31 System Setup - Projection Tab Selected  

 
To configure the projection: 

1. Click the Projection tab. 

2. Enter your information according to the descriptions below. 

3. Click OK. 
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Wire 
Density 

Controls the graphical presentation of the 3D plot by means of line density. 
There are three wire densities to choose from: Low, Medium and High. 
High density displays the best graphics for the 3D image, as the color lines 
are condensed, but as the graphics become more complex, it takes more 
time to draw the image on the screen. 

To set the Wire density, select the desired wire density. 

Rotation& 
Tilt 

This function is used to change the viewing angle of a 3D graphics 
presentation. This enables you to view the angles around the beam’s main 
axis as well as to flip the displayed image. 

• Auto Rotate On/Off - When Auto Rotate is On, the image is rotated 
about the optical axis or azimuth of the 3D display. The amount of 
rotation (viewing angle) is defined by the Step parameter (in degrees). 
Possible values for Step are 1 through 30 degrees. When Auto Rotate 
is on, Rotate Angle is disabled.  

• Rotate Angle (°) - Sets the viewing angle of the 3D projection display. 
Possible values are 1 through 360 degrees in 1 degrees increments.  

• Horizontal Tilt (°) - Sets the tilt viewing angle of the 3D projection (from 
a top view to a side view). The values range from 0 to 90 degrees in 1 
degree increments. 

To set automatic rotation: 

1. Select AutoRotate On/Off. 
2. In the Step field, enter the viewing angle. 
To set manual rotation: 

1. Deselect AutoRotate On/Off. 
2. In the Rotate Angle (°) field, enter the viewing angle. 
To set manual tilt: 
1. In the Horizontal Tilt (°) field, enter the tilt angle. Or, 
2. Place the cursor over the image and press the left mouse button. The 

cursor changes shape. 
Drag the cursor along the view area. The 3D plot rotates around the 
image main axis and flips from top view to a side view of the image. 
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7.2.4 System Setup - Position  
The Position setup defines the attributes for the beam centroid calculation & disply. 

 
Figure 32 System Setup - Position Tab Selected 

 
To configure the Position features: 

1. Click the Position tab. 

2. Enter your information according to the descriptions below. 

3. Click OK. 

Data Data is used to toggle between Absolute and Relative modes of position, 
where the default is Absolute. 
When Relative is selected then all the position centroid data will be 
calculated versus the Cross Line center. 
The Relative point coordinates can be set by graphical means, by dragging 
the Cross Line center to any requested location over the View Area. 

Radius Controls the numerical calculation of the position function. 
Some applications require a calculation of the radius of beam 
centroid deviations. In this case the R parameter is calculated 
as follows: 
 
√ (X² + Y²) 
Mark the Radius parameter as On in order to enable the 
Radius function.  
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7.2.5 System Setup - Power  
The Power setup allows the user to configure the power measurement capability to suit a 
particular set of needs. 

 
Figure 33 System Setup - Power Tab Selected 

 
To configure the Power features: 

4. Click the Power tab. 

5. Enter your information according to the descriptions below. 

6. Click OK. 

Wavelength The wavelength value is used by the Power function to correct the sensor 
reading for the selected wavelength response. 

This option should be used to input the wavelength (in nanometers) of the 
laser source used in the current measurement session. 

The system will recalculate the beam power value and correct the display 
accordingly. The wavelength can be entered in 1-nanometer increments 
from the data entry box. Possible values for wavelength are: 350 - 1100 
nm. 

Filter Filter option is used in order to inform the system which filter file to use in 
the current session 

Pre-Load a Filter file to the system via Load … button, after physically 
installing the filter in front of the detector. A file list is displayed, presenting 
all the available Filter files to choose from (all files having extension name 
*.FLT).  
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7.2.6 Configuring a Continuous Laser Beam 

When using a continuous laser beam, attenuate powerful laser beams by selecting a 
combination of shorter shutter speeds and attaching the ND filters to the LBP HR camera 
until the saturation level is acceptable. Refer to Hardware Setup - Shutter and Using 
Filters topics for more information. 

 

To configure a continuous laser beam: 

1. Open the Settings menu and select Hardware Setup. 

2. Click the Laser tab and select the CW radio button in the Type field. 

3. From the Control Panel, select a shutter speed in the shutter field that enables an 
acceptable saturation level. 

4. From the Control Panel, select a gain level in the gain field that enables an acceptable 
saturation level. 

5. If the image is still saturated at the fastest shutter speed or gain selected, attach ND 
filters to the LBP HR camera until an acceptable saturation level is reached. 

7.2.7 Setting the Ambient Light Suppression (CW lasers) 

The Null function allows you to subtract off background and display the correct power value. 

When null calibration is off, the power value displayed in the measurement data or statistics 
window is the total power incident on the detector surface. When null calibration is on, the 
power value displayed does not contain the ambient light. 

You should perform the null calibration function during your set up routine. During the null 
calibration routine, a message is displayed at the top right side of the screen, which reads: 
Null Calibration. 

To calibrate the ambient light suppression: 

1. Open the Options menu and select Calibration u Null. Or, 

From the Status Bar, click . 

A message displays instructing you to turn off your laser beam. 

2. Turn off or block your laser and click OK. The system now measures the ambient light 
level. Note that the power reading in the Measurement Data area is now zero. 

3. Turn on or unblock your laser. The Null button on the Status Bar changes to 
. 

 

7.2.8 Configuring a Pulsed Laser Beam 

When using a pulsed laser beam: 

- Attenuate powerful laser beams by attaching the ND filters to the LBP HR camera until an 
acceptable saturation level is reached. Refer to Using Filters topic for more information. 

- Set the gain setting to the optimum for displaying a full dynamic range without saturation 
(white on the image). 
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- Set the trigger level. This allows you to measure slowly pulsing lasers without displaying 
blank frames.  

To configure a pulsed laser beam: 

1. Select Pulse option via Hardware Setup Settings. The  icon will further be displayed 

at the Control ToolBar and just next to it the Trigger control panel . 

2. Select the slowest shutter speed (1/50s). 

3. Attach ND filters to the CCD camera until an acceptable saturation level is reached. 

4. Further adjust the intensity level using the gain control  

5. Adjust the trigger level using the  icon until you get a steady reading. It 
is best to move to the right until triggering stops, then move back a little. 

 

7.2.9 Using Filters 

When setting up your system, use the three calibrated optical filters (ND filters) supplied 
with the LBP HR system to attenuate powerful beams. By doing so the amount of energy, 
which the LBP HR camera is sensing, is significantly smaller. The use of filters is especially 
significant when operating a pulsed laser beam. 

 

To attenuate powerful-pulsed laser beams, attach filters to the LBP HR camera until the 
saturation level is acceptable. The LBP HR camera is supplied with the following filters: 
3xND filters in housing (1/8 ND filter, M37x0.75), and 1xNG10 1.6mm thick Schott colored 
filter NG10. Optional filters include NG4 or NG9 Schott colored filters 1.6mm thick. 

See curves of optical filters in Appendix section.  You can order more filters if desired. 

The filter type is marked on the filter housing according to the following schematics: 

No Filter NG 4 NG 9 NG 10  
 

   Figure 34 Filter type marking 

To attenuate powerful continuous laser beams, select a combination of shorter shutter 
speeds and attaching filters to the LBP HR camera until the saturation level is 
acceptable.  

Refer to Configuring a continuous Laser Beam for more information.     
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7.2.10 Using the Filter Wheel 

Rotate the Filter wheel manually and make sure 
the required filter is placed at the bottom 
position. 

Place the mouse cursor over the required filter to 
be used, and click left mouse button. 

The filter wheel will rotate accordingly and place 
the selected filter at the bottom position (in front 
of the CCD sensor). 

The name of the selected filter is displayed at 
the status bar.  

From now on the software will include the filter 
transmission curve in the power calculation. 

 

   

Figure 35 Filter Wheel 
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8.0 General description of Software  
This chapter discusses the following LBP HR operations: 
• Viewing Beam Profiles and Width 
• Viewing the Centroid 
• Viewing the 2D / 3D / Pos presentations 
• Viewing Power 
• Viewing the Beam Peak 
• Viewing Measurement Data 
• Viewing the Statistics 
• Freezing Screen Graphics 
• Printing Screen Displays 
• Saving Screen Graphics 
• Working with Stored Files 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Figure 36 LBP HR Application window 
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8.1 Viewing Beam Profiles and Width 

Two types of profiles are being displayed by LBP HR: 

Sum Profiles- Displays the two orthogonal, one along the vertical axis and one along the 
horizontal axis. Each profile is composed of a summation of rows and columns at a beam 
cross-section. 

Line Profiles- Displays the beam contour along a line parallel to the vertical and horizontal 
axes. These two orthogonal lines are designated as a cross hair cursor on the image plane 
and can be moved along the working area. 

1. To select the profile calculation method: 

From the Control Toolbar, click  for Sum Profiles or  for Line Profiles. Or, 

Open the View menu and select Profiles u Sum or Line. 

 

 
Figure 37 Horizontal Profile 

Beam widths are digitally displayed for any three user selected clip levels. 

A Gaussian fit profile can be overlaid on profiles in real time, while the correlation and fit 
values are displayed digitally.  This function determines how closely the measured beam 
profile matches a theoretical Gaussian profile. The Gaussian fit profile is in red. The percent 
correlation and width comparisons utilize the currently selected clip levels. 

Two vertical bars can be moved along the horizontal axis, designating the distance (in 
microns) along this axis. This is a useful feature for tracing and measuring of beam 
phenomena at certain locations. 

The comparison data is displayed in the Measurement Data Box. A top hat profile 
presentation and fit is also available. 

    
Figure 38 Measurement Data. 
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8.2 Viewing the Centroid 
The Centroid is the beam intensity center of gravity.  

The LBP HR determines the location of the beam centroid by summing the intensities of all 
image pixels in both horizontal and vertical axes, and computing the center of gravity of the 
beam intensity. The pixel coordinates at this location define the centroid. The horizontal (H) 
and vertical (V) coordinates of the Centroid are computed using the following formula: 

H = ∑{h * i(h,v)} / I 

V = ∑{v * i(h,v)} / I 
Where i(h,v) =  the intensity at location (h,v) and I = the total intensity taken over the total 
area. The centroid calculation is displayed in the User Area window and also in the 
Statistics window.  

The LBP HR enables you to display the centroid in the view area when a 2D image is 
displayed. The centroid is located where the horizontal and vertical profiles cross in the view 
area. Two additional regions of interest (ROI) can be defined by the user and displayed at 
the Statistics table, thus enabling the user to monitor up to 3 beams’ centorids 
simultaneously. 

To display the centroid in the view area: 

1. From the Control Toolbar, click  for a 2D display. 

2. From the Control Toolbar, click  for a sum profiles display 

3. Open the View menu and select CrossLine -Centroid. 
.The ROI function selects a region of interest within the total CCD detector area.  
To activate the ROI press the appropriate ROI button on the Control ToolBar. The ROI 
region is defined by a square, the color of which is identical to the numerical presentation at 
the User Area, as well as to the ROI tool button color. The user can control the size of the 
ROI and its location by graphical means using the mouse. 
 

 

 Figure 39: ROI’s representation 
The software calculates the centroid of the beam, which resides inside the ROI area only, 
disregarding the energy outside of this region. Thus, the result of the beam centroid 
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calculation will be displayed in the appropriate ROI area at the User Area. In case the 
Radius parameter is set On at the Position Setup – Position tab, then there is an additional 
calculation and display of the R value, which is the radius of beam centroid with regards to 
the cross line. 

 
Note: The default ROI is the total centroid of the energy impending on the entire CCD 
area. 

 
The user can change this default by graphical means, by dragging the ROI frame to the 
location and size at the screen, which is of interest.  

The default setting of the system when it boots up is the entire CCD area is being 
considered the area main region of interest and the beam centroid calculation is performed 
over the entire CCD area. This default can also be changed by graphical means, the same 
way both other ROI’s borders and location can be set. 

In order to resume the default setting, double click on the mouse Left button. 
 

Position Data in User Area 
The User Area displays four numerical results. There are 
two types of presentations, according to the system setup 
setting: 
Beam centroid (X, Y), which is the beam centroid location 
calculated over the entire CCD area.  
Cross Line coordinates (X, Y) displaying either the CCD 
center of origin (CCD Center option), or the cross line 
coordinates at any point over the CCD View Area (Free 
option), or the beam centroid coordinates or any offset 
value with respect to the centroid 
(Centroid option) 
ROI 1: the beam centroid (X, Y) in the 
defined Region of Interest 1. 
ROI 2: the beam centroid (X, Y) in the 
defined Region of Interest 2. 

   In each one of the above listed 
presentations (Centroid, ROI1 and ROI2) 
a third line can appear, marked as “R” 
and stands for the Radius calculation 
(squared-root of X²+Y²). This calculation 
and presentation appear when the Radius 
parameter is set on in the System Setup – Position tab. 

 
       Figure 40: Position Data Calculation 

 

8.3 Beam Finding Module – Target 
A special feature, which facilitates finding your area of 
interest within the total CCD area. It is derived from 
the high-resolution CCD feature, where the resolution 
is much higher, than the screen display capabilities. 
Your area of interest is clearly displayed as a small 
rectangular frame within a picture representing the 
CCD module. Move the small rectangle frame to 
explore other portions of the CCD. 
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8.4 Viewing the 2D / 3D Presentations 

The projection function provides either a 2D or a 3D plot of the beam intensity profile. A 
zooming feature enables magnification of the displayed image. It is possible to control the 
3D plot wire density. 

To display the 2D presentation in the view area: 

From the Control Toolbar, click  for a 2D display. 

To display the 3D presentation in the view area: 

From the Control Toolbar, click  for a 3D display. 

The 3D image can be rotated along the vertical and horizontal axes, as well as be flipped, 
using the following routine. This feature enables the user to view the beam image from 
various angles around the beam: 

- Place the mouse cursor over the 3D image 

- Hold the left mouse button down 

- Drag the mouse while pressing the left mouse button. You can move the cursor 
up/down or left/right. The image will rotate accordingly. 

   
Figure 41 3D Plot – Side View  Figure 42 3D Plot – Top View 

 
Figure 43 3D Plot with projected images 

 

If beam is weak even when shutter is wide-open then increase the gain. If beam is very 
weak and color is dark even at the maximum shutter opening and gain, then optimize the 
color with the side panel. To optimize beam image place mouse cursor at the color bar and 
click the right mouse button. Return to default color bar press left mouse button once. (See 
illustrations below). 
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Figure 44 Weak beam               Figure 45 Weak beam with optimized color 

8.5 Viewing Power  

The Beam Power is displayed as a digital readout at the status bar, as well as at the right-
hand screen panel, where there is also a display of the "Z" digital value in a specific cursor 
location (in 8 bits or 12 bits) 

 

Figure 46 Power Windows 

Alternatively, a needle-type display is available with additional features like: changing power 
measuring units, averaging, loading a predefined filter file, ambient light suppression. 

A power calibration function allows the user enter a "base" power value. In subsequent 
captured images the summer intensity of all pixels will be proportional to this value. 

Power Setup allows the user to configure the power measurement capability to suit a 
particular set of needs required for the operation of the Power meter function 

 

Power Setup is selected from the Setup button at the Power window panel. Power Setup 
includes the following options: Settings and Zoom & Limits Tabs. 



  

 64

 
Figure 47 Power Setup - Settings 

 

Settings Tab options are: 

 

Wavelength:  For setting the wavelength of the laser in use. 

Power Average: For averaging the power reading, by smoothing the display. 

 

 
Figure 48 Power Setup – Zoom & Limits 

 

Zoom & Limits Tab options are: 

Power Zoom:  For magnifying the measurement area , in order to are easily detect small 
variations in beam power. 

Limits:  For setting an area within the needle graph display, to warn the user if 
power drifts outside the zone. 
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8.6 Viewing Position  
The beam centroid is continuously monitored relative to the center of CCD head. Three 
Region of Interest (ROI) can be defined by the user, thus enabling monitor of up to 3 beams 
centroids simultaneously. The display includes the values X and Y (in µm) as well as R, 
which is the distance from the CCD center. 

 

 
Trace On/Off feature enables beam centroid tracking. Reticule type targets can be laid out 
on the position screen, for ease of positioning analysis. The following targets can be 
selected from Control panel, including: Cross, Circle, Square, multiple circles and multiple 
squares. 

         

Figure 49 Target Control 

Chart position function is used to display changes in in the position (X and Y) with time with 
auto scaling and saving capabilities. 

 

 
Figure 50 Chart position 
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8.7 Viewing the Beam Peak 

The beam peak calculation provides the position of the peak intensity in the captured beam 
image.  

The beam peak intensity location is found by searching all the pixels in a scanned sample 
for the maximum digital intensity level. The location of the pixel with maximum intensity is 
the peak location. It is possible that more than one pixel is found at the maximum intensity 
signal. In this case, the peak location will be the peak intensity pixel which is found first. The 
search is conducted by scanning the image from left to right, top to bottom.  

The beam peak calculation is displayed in the Statistics window. Refer to Viewing the 
Statistics topics for more information. 

The LBP HR enables you to display the beam peak in the view area when a 2D image is 
displayed. The beam peak is located where the two diagonal black lines cross in the view 
area. Two additional regions of interest (ROI) can be defined by the user and displayed at 
the Statistics table, thus enabling the user to monitor up to 3 beams’ beam peaks 
simultaneously. 

To display the beam peak in the view area: 

1. From the Control Toolbar, click  for a 2D display. 

2. From the Control Toolbar, click  for a sum profiles display. 

Open the View menu and select Beam Peak.  

8.8 Viewing Measurement Data 

The LBP HR enables you to view real-time measurement data. The measurement data 
includes: 

• The beam width measurements at 3 selected clip levels for measured beam and 
Gaussian profile 

• The correlation factor to the ideal Gaussian beam 

 

The Measurement Data window is located by default in the User area, but you can move it 
anywhere on the screen. 
The Measurement Data window contains the following information: 

Width The width comparisons of measured beam and Gaussian beam are 
located at the current selected clip levels (µm). 

Correlation The deformation calculation from the ideal Gaussian beam (%). 

Given a theoretical curve (G) and a set of data points from a beam 
profile (P), where each data set is composed of points for j=0, 1, 2, … N. 
The correlation coefficient is derived from the following steps: 
1. S = Integral [ (P-G)²]  

where S = the integration of the squared differences between the two 
curves. 

2. So = Integral [(G)²] 
where So = the deformation at each point from the average, Dj. 

3. C = 100 * { 1 – [SQRT (3/S-So)]} 
where C = the fit coefficient percentage. 
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The beam column displays the laser beam’s readings. The Gaussian column displays the 
data of the ideal Gaussian profile. 

These measurement results are calculated and displayed for both the Horizontal and the 
Vertical profile. 

The Measurement Data window can be viewed off-line in stored snapshot images for further 
analysis. Refer to Creating / Viewing Snapshot Files. 

To view the Measurement Data window: 

1. If the Statistics window is displayed, open the View menu and select Statistics. Or, 

From the Control Toolbar, click . 
The Statistics window is not displayed. 

 NOTE:  When the Statistics window displays, the Measurement Data window is hidden. 

 
To move the Measurement Data window: 

1. Position the cursor on the blank area on the top corner of the Measurement Data 
window. 

2. Press the left mouse button and drag the Measurement Data window to the desired 
location. 

8.9 Saving and Viewing the numerical data of the profiles 

The LBP HR allows you to save, view and print the numerical values of the X and Y profiles 
for later analysis. 

To View the numerical data of the X and Y profiles: 

3. Place the X and Y crosshairs at the angle and position you desire. 

4. Press Options menu, Save data in text file, Profiles option. 

5. Name the text file and save with the TXT extension. The data will be saved as a text file 
with the relative X and Y intensity vs. pixel number. The setup data will be saved at the 
same time. 

6. To view the data, press File menu, View file option and the view file window will open. 
Under Files of type select snapshot files and double click on the desired TXT file. If you 
want to print the file when open, press Print. 

 

 

8.10 Viewing the Statistics 

The information in the Statistics window is useful for analyzing beam stability related 
characteristics. The statistics can help you monitor fluctuations and beam stability of the 
images captured and stored in the data buffer or analyze the warm-up characteristics when 
measuring beam-pointing stability.  

• Current - the actual measurement values  

• MIN - the minimum measured value  
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• MAX - the maximum measured value  

• AVER - the average value 

• STD - the standard deviation 

 

 

 
Figure 51 Statistics Window 

To view the Statistics window: 

1. Open the View menu and select Statistics. Or, 

From the Control Toolbar, click . 
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You can reset the parameters in the statistics window to initiate a new statistics calculation 
session. To reset the parameters in the Statistics window, press the Reset button. 

 NOTE:  When the Statistics window displays, the Measurement Data window is 
hidden. 

8.11 Freezing Screen Graphics 
It is possible to freeze the last image display and its measured data for further analysis 
using the Analysis function. You can perform the following functions on the frozen data: 

• Calculating a beam footprint (refer to page 64) 

• Measuring distances between two points (refer to page 65) 

• Viewing the measurement data (refer to page 57)  

• Viewing the Statistics (refer to page 59) 

 

When the LBP HR is in freeze mode, a message displays on the top left-hand side of the 
screen, which reads: Freeze Mode. 

To freeze the screen graphics: 

1. Open the Options menu and select Freeze Mode. Or, 

Click  on the Control Toolbar. A Freeze Mode message appears on the menu bar. 
 
To return to real-time measurement mode: 

1. Open the Options menu and select Freeze Mode. Or, 

Click  on the Control Toolbar. The Freeze Mode message disappears from the 
menu bar. 

 
 

8.12 Printing Screen Displays 
This section describes how to print: 

• The LBP HR window 

• The view area (2D/3D image only) 

To print the LBP HR window, open the File menu and select Print Screen. 

To print the view area, open the File menu and select Print Frame. 
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8.13 Saving Screen Graphics 
The LBP HR’s screen graphics are saved as image files, which you can view, edit or print at 
a later time. 

To save screen graphics: 

1. Open the Options menu and select Save Image File. A sub-menu displays. 
2. Select the screen section to be saved: Frame (view area), Profiles, Statistics or Full 

Screen. The Save Image File window displays. 

3. Enter a filename and file extension (BMP or JPG) for the saved screen graphic. 

4. Click OK. 

 NOTE:  You can only save graphics, which appear in the LBP HR window. For example, if 
the Statistics window is not displayed, the Statistics option is disabled. 

 

8.14 Working with saved Files 
You can view or print stored LBP HR files. 

Viewing Files 
To view a file: 

1. Open the File menu and select View File, Or 

Click , from the Control Toolbar. 

The View File window displays. 

2. In the Files of Type field, select the file type. 

3. Select the file. Click OK. 

Printing Files 
LBP HR provides you with the ability to print a saved text or image file. 

To print a text or bitmap file: 

1. Open the File menu and select Print, Or 

From the Control Toolbar, click . 

2. Select the file type for the file you want to print Text or Image. If you select Text, the 
Print Text File window displays. If you select Image, a menu appears for selecting  
Print Image File window (select BMP or JPG file). 

3. Select the file you want to print. Click OK. 
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9.0 Analysis Functions 
This chapter includes the following: 

• Testing the beam 

• Calculating a beam elliptical footprint 

• Measuring distances 

9.1 Test 
LBP HR provides a test routine, which allows you to test a laser beam based on user 
defined pass/fail criteria. The test results are calculated for any one of the following user-
selected parameters: 

• Centroid Horizontal (µm) 

• Centroid Vertical (µm) 

• Width Horizontal (µm) at the lowest clip level 

• Width Vertical (µm) at the lowest clip level 

• Gaussian Width Horizontal (µm) at the lowest clip level 

• Gaussian Width Vertical (µm) at the lowest clip level 

• Correlation Horizontal (%) 

• Correlation Vertical (%) 

• Power (mW) 

 

To test a laser beam: 

1. Open the View menu and select Toolbars u Analysis. Or, 

From the Control Toolbar, click . 

The Analysis Toolbar displays. 

2. To run the test, click  on the Analysis Toolbar.  

3. Select the parameters to include in the test and set the minimum and maximum values 
for these parameters. 

4. Enter your test related information. 

5. Click Test button to perform a test routine. 
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Figure 52 Test window 

The test window displays the beam’s test results based on the parameters entered in the 
Test window.  

To save the current test results in a bitmap or test file, click Save in the Test window. 

To print the current test results, click Print in the Test window. 

To close Test window click  on the Analysis Toolbar. 

 

9.2 Calculating a Beam Footprint 
Analyzing a laser beam frequently requires a definition of beam elliptical footprint in the 
profile cross-section plane, and beam angular orientation with respect to the camera axis. 
The ellipse function calculates the best-fit ellipsoid for the examined beam. The major and 
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minor axes of the fit ellipse are calculated by determining the distance from the centroid 
(center of the beam) to the ellipse. Also, the orientation (Theta θ) is a measure of the 
orientation of the major axes of the fit. Theta is measured from the positive X-axis and 
varies between +90° and –90°. 

To use the ellipse function the image must be frozen. The LBP HR can now calculate the 
best-fit ellipse and display it as a dotted white ellipse just around the edges of the measured 
ellipse. The best-fit ellipse parameters are also calculated and displayed. 
To calculate a beam elliptical footprint: 

1. Open the Options menu and select Freeze Mode. Or, 

From the Control Toolbar, click . 

2. Open the View menu and select Toolbars u Analysis. Or, 

Click  from the Control Toolbar. 

The Analysis Toolbar displays. 

3. From the Analysis Toolbar, click . The LBP HR calculates the best-fit ellipse and 
displays it as a dotted white ellipse just around the edges of the measured ellipse. The 
best-fit ellipse parameters are displayed below the Analysis Toolbar (see below). 

 
Figure 53 Best fit Ellipse 
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9.3 Measuring Distances 
The LBP HR can accurately measure distances between any two points on the beam 
image. You select the end points and the LBP HR calculates and displays the results.  

To measure the distance between two points on the beam image: 

1. Open the Options menu and select Freeze Mode. Or, 

From the Control Toolbar, click . 

2. Open the View menu and select Toolbars u Analysis. Or, 

From the Control Toolbar, click . 

The Analysis Toolbar displays. 

3. From the Analysis Toolbar, click .  

4. Select the first point by placing the cursor on the beam image and click the left mouse 
button. 

5. Drag the mouse to the second point on the beam image and click the left mouse button. 
A straight line is drawn between these two points and the line distance calculation is 
displayed below the Analysis toolbar. 

 
Figure 54 Measuring Distances Between two Points 
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10.0 Saving Data Log files 
This chapter describes how to create a data log.  

All the data collected by the LBP HR can be saved in a file with a .LOG extension. The data 
log files are stored in ASCII format so they can be easily printed, viewed, and analyzed by 
other programs. Refer to an example of the contents of a data log file (below). 

The data log file contains general information including system parameters at the time of the 
log operation, such as the amount of averaging used, shutter level, Null (Offset) indication, 
zooming parameter and the size of the picture frame. 

Additionally, at the lowest selected clip level beam width measurements for the horizontal 
and vertical profiles, centroid indication, as well as the power level value are displayed. 

The end of the data log file contains a statistics summary of all the measured parameters, 
including the minimum measured value, maximum measured value, average measured 
value, as well as the standard deviation for each parameter. 

10.1 Setting Up the Data Log Function 
This setup screen allows the user to customize the Log operation to suit a particular need: 
the duration of an experiment, the rate of data saving into file, and the Log filename can be 
input by this setup screen. Also, data can be saved either to a Log file or to Excel file for 
further analysis at a later stage. 
To setup the data log function: 

1. Open the File menu and select Log Setup. Or,  

From the Control Toolbar, click . The Log Setup window displays  

 
             Figure 55 Log Setup  
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                  1. Logtype:   LOG file or Excel file 

 2. File Name: Providing the system with a filename where Log data will be saved. 
Activate Button Browse... in order to provide the system with a filename via the standard 
Windows File Input interface box. 

 
Note:  When LOG file type was selected, all data collected will be saved in a file name 

*.LOG, which is a text file and can be imported into other programs. When Excel file 
type was selected, all data collected will be saved in a file name *.XLS. 

3.Click OK. 

 

 
Figure 56 Log Setup – Settings Tab 

 

 

Interval Configures the time interval between consecutive measurements.  

To configure the time interval between consecutive measurements, enter 
the time. The number of hours, minutes and seconds must each be 
entered separately. 

Duration Defines the duration of the data log function. The data log function ends 
automatically at the end of the duration; however, you can stop the data 
log function prematurely (refer to Stop Data Logging).  

To configure the duration of the data log function, enter the amount of 
time. The number of hours, minutes and seconds must each be entered 
separately. 
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Log Type Provide the system with a method to control the data logging operation: 

Time:  Save measurements for a pre-defined duration, the interval 
between the saved measurements is also defined prior to saving. 

Points: Save a certain amount of measurements taken at the system’s 
data capturing rate, the exact figure is entered at the points field to the 
right of this option. 
Manual: Save a certain measurement to the file by pressing the 
SpaceBar. This method is called “Event oriented”, meaning once the 
user observes a certain measurement on the screen he can control the 
system to save this exact measurement data to the file, rather than other 
methods of stream data saving. 

 

10.2 Start Data Logging  
The LBP HR collects the laser beam’s data in the configured data log. While the data log 
function is in progress, a message displays on the top left side of the screen, which reads: 
Log in Progress. 

To start the data log function: 

1. Open the File menu and select Start Log. Or, 

From the Control Toolbar, click . 

 

10.3 Stop Data Logging  
The data log function automatically terminates after the user-preset time is reached. 
However, you can stop the function at any time. 

To stop the data log function: 

1. Open the File menu and select Stop Log. Or, 

From the Control Toolbar, click . 

 

10.4 Viewing Data Log Files 
To view the data log file: 

1. Open the File menu and select View File. 

2. Select the data log file you want to view. 

3. Click Open. The Data Log displays. 
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Figure 57 Data Log File example 
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11.0 Creating / Viewing a Video 
This chapter describes how to create and view a video file. The recording program enables 
recording and saving a continuous set of images from a single LBP HR camera source. The 
video is saved in a file with the extension .AVI. 

11.1 Initializing the Video Parameters 
To initialize the video parameters: 

1. Open the Settings menu and select Video Properties…. The Video Properties window 
displays. 

 

2. Enter your information 
according to the 
descriptions below. 

3. Click OK. 

 

 

 

 

 

 

 

Figure 58 Video Properties 

 

Video Time 
Limit 

Sets a time limit for the video recording. 

To set the video time limit: 

1. Select Enable Time Limit. 
2. Enter the time limit in minutes and seconds. 

Permanent 
Video File 

This setting allows you to specify the filename and path, where the 
recorded video is saved. For best results, if you have multiple hard 
drives, this file should be located on the fastest hard disk drive or the 
disk drive with the most available free space. 

You can also use this setting to limit the video to a selected amount of 
memory. 

To specify a location for the video file, enter the file name and path. 

To limit the video to a selected amount of memory: 

1. Deselect Enable Time Limit check box in the Video Time Limit 
field. 

2. Enter memory size (in Mbytes) in the Size field. 

 



  

 80

11.2 Record a Video file 
When you record a video, the video is saved in the file you specified in the Video Properties 
window. If you don’t want to overwrite this file, you must change the file name before 
recording a new video. 

During video recording, a message at the top of the screen indicates the recording 
operation. When the LBP HR is recording a video, a message displays on the top left side of 

the screen, which reads: , and during recording the Status Bar 
presents the following pattern:  

You can change the setup parameters while recording your video (refer to Initializing the 
Video Parameters). 

To record a video: 

1. Open the Options menu and select Record Video. A checkmark is placed beside this 
option. Or, 

Click  from the Control Toolbar. 

 

11.3 Stop the Video Recording 
The video recording automatically terminates after the user-preset time is reached. 
However, you can stop recording at any time. When recording terminates, it is automatically 
saved in the file you specified during video setup. 

To stop the video recording: 

1. Open the Options menu and select Record Video. The checkmark is removed from this 
option. Or, 

Click  from the Control Toolbar. 

 When video recording is terminated the following message is displayed: 

 
Figure 59 Stop video recording 

 
 

 

11.4 Play a Video File 
During a video playback routine, the LBP HR displays a digital presentation of the time 
elapsed since the video began, as well as the number of the frame being displayed. 
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To play a video, open the video file you want to see and use the following buttons on the 
Playback Toolbar to play your video: 

 
Play Plays the recorded video file. 

 
Stop Stops the playback of the video file once it is started. 

 
Rewind Rewinds the current video one frame backwards. 

 
Forward Fast-forwards the current video one frame. 

 
Open Opens a video file. 

 
Close Closes an open video file. 

There is a slide bar in the middle of the Playback Toolbar, which moves in accordance with 
the video’s progress. It is also possible to use this slide bar to rewind the video to its starting 
point, or to bring it to the end of the video. 

 

To play a video file: 

1. Open the View menu and select Toolbars u Playback. Or, 

Click  from the Control Toolbar. 

The Playback Toolbar displays. 

2. Click  on the Playback Toolbar. The Open Video File dialog displays. 

3. From the Open Video File dialog, select the video file you want to view.  

4. Click Open. The video file displays. 

5. Use the Playback Toolbar buttons as defined above to play the video. 

6. Click  to close the video file. 

 

 
 
 
 
 
 
 
12.0 Saving / Viewing Still Images 
This chapter describes how to capture and view high quality digital images with LBP HR 
system. A still image is captured by digitizing a single video frame. The still images can be 
saved as bitmaps. 
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The captured image is displayed as an icon on the Status Bar with a number assigned to it. 
If you are using a pulsed laser, you can set the number of bitmap files that the system 
captures when performing a still image operation. The LBP HR can capture up to 12 still 
images during one session. 

 

12.1 Capturing a Still Image 
To capture a still image: 

1. Open the Options menu and select Still Images. Or, 

Click  on the Control Toolbar. 

The image is captured and an icon is placed on the Status Bar. 

First Still Image

Second Still Image

Third Still Image

 
Figure 60 Status Bar with Still Image Icons 

 

 

12.2 Viewing a Still Image 
To view a single still image, click the still image icon on the Status Bar. 

To close the magnified still image, click  in the upper right corner of the image window.  
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12.3 Tile Images  
You can view a single still image or all your still images in a matrix (refer to the following  

figure). When viewing the still images in a matrix, you can select a single still image to  

magnify for details.  

 
    Fig. 61: Tile Images window 

To view a single still image, click the still image icon on the Status Bar, as explained in 
previous section. 

To view the still images in a matrix, open the Options menu and select Tile Images.  

To magnify a still image in a matrix, click one of the tile images. To close the magnified still 
image, click  in the upper right corner of the image window. The still image remains in the 
matrix. 

 

12.4 Saving / Closing Still Images 
When you close a still image you must either save it or discard it. If you close a still image 
matrix and choose to save it, each of the images in the matrix are saved as separate bitmap 
files. The bitmap filenames are created by the LBP HR and consist of the image number, 
day, hour, minutes and seconds (n_ddhhmmss.bmp). 

To close an opened still image or still image matrix: 

1. Click  in the upper right corner of the image window. The Still Image window 
displays. 

2. If you want to save the still image, click Yes in the Still Image window. 

To close all captured images at once, open the Options menu and select Close All Images. 
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13.0 Creating / Viewing Snapshot Files 
Snapshot files enable you to create and view a pre-saved snapshot image for analysis and 
in-depth study of a beam measurement frame stored in the system’s memory. 

When you view a saved snapshot file you can analyze the measured results by activating 
system tools, such as:  

• Viewing measurement data  

• Change profiles clip levels  

• Explore 2D contour or 3D isometric plots  

• Perform Beam Analysis. 

When the LBP HR displays the snapshot file, a message displays on the top left side of the 
screen, which reads: Snapshot in progress. The LBP HR does not display real-time 
measurements and the screen is frozen. 

 

13.1 Creating a Snapshot File 
The snapshot image is captured as soon as you select the Save Snapshot option. You then 
save the snapshot image as an .SNP file. The snapshot file is saved in binary format and 
can only be processed by this application. 

To create a snapshot file: 

1. Open the Options menu and select Save Snapshot. The Save Snapshot File window 
displays. 

2. Enter a filename for the snapshot file.  

3. Click OK. 

 

13.2 Viewing a Snapshot File 
To view a snapshot file: 

1. Open the View menu and select Snapshot. The Load Snapshot File window displays. 

2. Select a snapshot file.  

3. Click Open. The snapshot file displays. 

 

13.3 Closing a Snapshot File 
To close a Snapshot file, open the View menu and select Snapshot. The LBP HR restores 
real-time measurement displays, or click  in the upper right corner of the image window. 
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14.0 RS232 Communication 
The LBP HR enables you to operate an RS-232 communication link for serial data 
transmission. 

Any displayed data or pre-saved log file can be transmitted via the RS-232 communication 
link. Another computer can receive the data using a program that can communicate over a 
COM Port like Windows Hyper Terminal program. 

While the link function is in progress, a  message displays on the top 
right corner of the Menu Bar. 

Transmitting serial data requires the following steps: 

• Setting up the parameters needed for the link transmission. 

• Making a null modem cable for connecting the two computers. 

• Starting the link transmission. 

• Terminating the link transmission. 

 

14.1 Setting Up for RS232 

The LBP HR allows you to configure a particular set of parameters needed for the RS-232 
transmission.  

To configure the RS-232 link: 

1. Open the File menu and select Link Setup. The Link Setup window displays. 

2. Click the General tab. 

 
Figure 62 Link Setup - General Tab Selected 
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3. Complete the information as described below. 

Port Sets the computer communication port through which the data is 
transmitted over the RS-232 link. The possible values for Port are 1 
through 4, for COM1 through COM4 respectively. 

Transmit Select one of the radio buttons: 

• File - transmits a pre-saved text file. 
• Data - transmits real-time measurements. The data is sent in the 

sequence and format of the saved data in the text (ASCII) file. 

4. Click the Port Settings tab. 

 
Figure 63 Link Setup - Port Settings Tab Selected 

5. Complete the information as described below. These settings must match the settings 
on the receiving computer. 

Frequency Sets the transmission rate for the RS-232 link. The possible values for 
Frequency are: 110, 300, 600, 1200, 2400, 9600, 14400, 19200, 
38400, 57600, 115200. 

Data Bit Determines the number of bits used for the RS-232 transmission. The 
possible values are: 4, 5, 6, 7, and 8.  

Parity Bit Determines whether or not a parity bit is transmitted. The possible 
values are: None, Odd, Even, Space, Mark.  

Stop Bit Determines the number of stop bits transmitted. The possible values 
are: 1 or 2.  

6. Click OK. 
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14.2 Making a Null Modem Cable 
A null modem cable can be made from a standard RS-232 cable by connecting the pins on 
one end of the cable to the pins on the other end as shown below.  

Null modem cable with 25 pins on both sides: 

 25 Pin Side 25 Pin Side 

 FG  1                                      1   FG 

 TD    2                                       2   TD 

 RD    3                                       3   RD 

 RTS  4                                       4   RTS 

 CTS  5                                       5   CTS 

 SG    7                                       7   SG 

 DSR   6                                       6   DSR 

 DCD   8                                       8   DCD  
 DTR  20                                      20  DTR 
 

Null modem cable with 9 pins on both sides: 

 9 Pin Side                                               9 Pin Side 

 DCD 1                                       1    DCD 

 RD  2                                             2    RD 

 TD   3                                             3    TD 

 DTR  4                                            4    DTR 

 SG   5                                            5    SG 

 DSR  6                                              6    DSR 

 RTS  7                                              7    RTS 

 CTS  8                                              8    CTS 
 (RI)   9                                              9  Unused (RI) 

 

 Figure 64 Null Modem cable 
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14.3 Starting an RS-232 Link Transmission 
The file (or measured data) is transmitted in the background while the system continues to 
capture data. When the LBP HR is transmitting data, a message displays on the top left side 
of the screen, which reads: Link in progress. 

If you transmit a file, the contents of the file are sent. 

If you transmit real time data, the following information is sent:  

• Time of measurement 

• Beam Centroid (H) 

• Beam Centroid (V) 

• Beam Peak (H) 

• Beam Peak (V) 

• Width (H) 

• Width (V) 

• Power 

To transmit files over an RS-232 link: 
1. Connect the LBP HR computer to another computer using a null modem cable. 

2. Enable the receiving program to receive the file/data. 

3. Open the File menu and select Start Link. 

4. If you are transmitting data the LBP HR immediately starts sending measured data via 
the RS-232 link. A “link in progress” message displays on the Menu Bar. Proceed to 
Terminating an RS232 link. 

5. If you are transmitting a file, the Link File window displays. Select the file you want to 
send. A  message displays on the Menu Bar. 

6. Click OK. 

 

14.4 Terminating an RS-232 Link Transmission 
When transmitting a file, the RS-232 link transmission is automatically terminated upon 
completion of the transmission. However, if you are transmitting data, or you want to 
terminate your file transmission, you can manually terminate a transmission in progress. 

To stop a transmission in progress, open the File menu and select Stop Link.  
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15.0 Troubleshooting  
If, after reading this chapter and reviewing relevant portions of the user manual or on-line 
help, you still have a question, refer to Customer Support on page 85. 

15.1 Common Operating Problems 
The following are some common problems and possible solutions: 

Problem Possible Solution 

Display Problems:  

• No picture appears on the 
screen 

• If you are using a camera other than the one 
provided by the LBP HR System, make sure it is 
turned on. 

• Check the Settings parameters (refer to Setting Up 
the LBP HR). 

If this does not correct the problem: 

• If using Windows XP/Vista, refer to Windows 
XP/Vista Installation. 

Other Windows applications 
run slowly, or appear to be 
interrupted 

Because the LBP HR System must constantly collect 
and analyze data, it might not work well with all 
Windows applications. If you want to use another 
application while the LBP HR System is running, select 
About from the Help menu. This will cause the LBP HR 
to pause the data collection. Now run your other 
application. 

System Locks-up During 
Software Startup 

• If using Windows XP/Vista, refer to Windows 
XP/Vista Installation. 

The following error message 
displays:  

“Hardware error #1: Cannot 
find the USB Camera” 

 

 

 

 

Possible problems include: 

•   Check proper connection of USB camera 

•   Unsuccessful installation of the USB camera – check 
installation via Windows Device Manager. See more 
details at the Software Installation – LBP HR USB 
2.0 camera. 

•   Problem with video card hardware – contact your 
provider 

 

The following error message 
displays:  

“Video Device Error” 

•   Contact factory for Service 
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Problem Possible Solution 

Display does not update fast 
enough 

The display update rate of a particular computer is 
influenced by a variety of factors: 

• CPU Speed 
• Computer RAM 
• Video Card 
• Video RAM 
• Screen resolution 
• Screen color depth  
• Other applications open at the same time 

Refer to Hardware Requirements to see if your 
computer meets minimum requirements. Upgrade your 
computer hardware or close other opened applications. 

The power value in the 
Measurement Data window is 
not correct 

Verify that: 

• The Power Calibration is set (refer to Configuring 
Hardware topic). 

• The Null Calibration is performed (refer to Setting 
the Ambient Light Suppression (CW lasers).  

• The LBP HR camera is not saturated (refer to Using 
Filters). 

Image is seen, but appears 
faint (weak intensity) 

• Try setting a smaller shutter speed or Gain value in 
order to improve the image presentation (refer to 
Configuring the Hardware, Shutter option or Gain.  

• Use the Zoom option to magnify the image display 
(refer to Configuring the Software, option Zoom). 

Screen image is frozen, no 
real-time measurements 

• Verify that the Freeze option is not activated, by 
checking the menu bar for a “freeze” message (refer 
to Freezing Screen Graphics). 

• Verify that the Snapshot option is not activated, by 
checking the menu bar for a “snapshot” message 
(refer to Creating / Viewing Snapshot files. 

The image in the view area 
does not fully display 

If the Zoom option is greater than 100%: 

• Use the scroll bars to reach the main image 
presentation display.  

• Reduce the Zoom value to 100%. 
The Control Toolbar is not 
complete 

You must use a 1024 x 768 resolution screen in order 
to fully view all the graphics. 

You can still operate the system using the menu 
commands for activating the hidden Control Toolbar 
icons. 
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16.0 A P P E N D I X 
 

1. NG4 filter transmittance & curve 

2. NG9 filter transmittance & curve 

3. NG10 filter transmittance & curve 

4.    ActiveX Software 
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NG 4    
Diameter 12,7 mm  

Thickness 1,6 mm   

    

    

Wavelength-nm  Transmission-%  

350  0.353  

360  1.767  

370  3.89  

380  3.866  

390  8.864  

400  12.014  

410  12.274  

420  12.659  

430  13.459  

440  13.25  

450  14.276  

460  15.416  

470  15.369  

480  14.809  

490  14.304  

500  14.039  

510  13.985  

520  14.23  

530  14.68  

540  15.153  

550  15.267  

560  14.955  

570  14.377  

580  13.772  

590  13.439  
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Wavelength-nm  Transmission-%  

600  13.574  

610  13.898  

620  14.223  

630  14.342  

640  14.282  

650  14.388  

660  14.885  

670  16.003  

680  17.803  

690  19.871  

700  21.517  

710  22.503  

720  23.025  

730  23.256  

740  23.304  

750  23.211  

760  23.032  

770  22.776  

780  22.51  

790  22.197  

800  21.865  

810  21.507  

820  21.171  

830  20.809  

840  20.45  

850  20.092  

860  19.754  

870  19.401  

880  19.088  

890  18.738  



  

 94

Wavelength-nm  Transmission-%  

900  18.385  

910  18.078  

920  17.766  

930  17.459  

940  17.179  

950  16.905  

960  16.637  

970  16.404  

980  16.19  

990  15.984  

1000  15.807  

1010  15.644  

1020  15.493  

1030  15.364  

1040  15.271  

1050  15.191  

1060  15.169  

1070  15.121  

1080  15.072  

1090  15.129  

1100  15.125  
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NG 9   

Thickness 1,6 mm +/- 0,1 mm 

Diameter 12.7mm   

   

Wavelength-nm  Transmission-% 

350  0.002 

360  0.001 

370  0 

380  0.008 

390  0.049 

400  0.117 

410  0.159 

420  0.196 

430  0.241 

440  0.244 

450  0.294 

460  0.366 

470  0.378 

480  0.362 

490  0.342 

500  0.335 

510  0.327 

520  0.332 

530  0.345 

540  0.362 

550  0.365 

560  0.361 

570  0.35 

580  0.34 

590  0.344 
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Wavelength-nm  Transmission-% 

600  0.367 

610  0.402 

620  0.446 

630  0.485 

640  0.523 

650  0.575 

660  0.654 

670  0.781 

680  0.978 

690  1.236 

700  1.517 

710  1.787 

720  2.033 

730  2.252 

740  2.454 

750  2.633 

760  2.802 

770  2.962 

780  3.086 

790  3.204 

800  3.31 

810  3.395 

820  3.456 

830  3.502 

840  3.53 

850  3.542 

860  3.548 

870  3.53 

880  3.515 

890  3.489 
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Wavelength-nm  Transmission-% 

900  3.453 

910  3.421 

920  3.396 

930  3.364 

940  3.333 

1000  3.268 

1010  3.278 

1020  3.298 

1030  3.317 

1040  3.347 

1050  3.374 

1060  3.423 

1070  3.486 

1080  3.522 

1090  3.602 

1100  3.675 
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Type :  NG10   

Thickness 1,6 mm   

Diameter  12,7 mm   
Wavelength-nm Transmission-%   

350 0.000   

360 0.000   

370 0.000   

380 0.008   

390 0.000   

400 0.000   

410 0.003   

420 0.000   

430 0.001   

440 0.007   

450 0.011   

460 0.017   

470 0.020   

480 0.016   

490 0.016   

500 0.022   

510 0.016   

520 0.015   

530 0.017   

540 0.021   

550 0.020   

560 0.019   

570 0.018   

580 0.019   

590 0.018   

600 0.021   

610 0.024   
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Wavelength-nm Transmission-% 

620 0.030   

630 0.031   

640 0.037   

650 0.043   

660 0.054   

670 0.073   

680 0.107   

690 0.152   

700 0.206   

710 0.259   

720 0.313   

730 0.369   

740 0.429   

750 0.485   

760 0.545   

770 0.608   

780 0.671   

790 0.726   

800 0.788   

810 0.845   

820 0.904   

830 0.942   

840 0.984   

850 1.023   

860 1.062   

870 1.084   

880 1.112   

890 1.135   

900 1.153   

910 1.169   

920 1.189   
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Wavelength-nm Transmission-%   
930 1.209   

940 1.225   

950 1.249   

960 1.273   

970 1.297   

980 1.333   

990 1.360   

1000 1.393   

1010 1.431   

1020 1.471   

1030 1.510   

1040 1.558   

1050 1.603   

1060 1.653   

1070 1.717   

1080 1.776   

1090 1.801   

1100 1.904   
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Active X Software (for Windows XP) 
 

Introduction 
 
As mentioned in previous chapters, the Newport LBP HR is a full capture and analysis 
application with sophisticated capabilities. However, many customers have special analysis 
demands and tools, yet are lacking data collection capabilities. In order to meet this 
demand, the LBP HR can act as an ActiveX server. This allows system integrators to 
integrate the LBP HR’s data capture capabilities with legacy analysis packages. 

 

This has been tested in LabVIEW 7.0 (National Instruments) as well as Visual Basic 6.0 
(Microsoft). In practice, these controls can be used in any environment that allows 
interaction with ActiveX servers (although it hasn’t been tested with tools other than those 
mentioned). 
 
 
Registration 
 
The ActiveX controls will be registered the first time that the LBP HR software application is 
run. 
 

 
 

Examples 
 

Examples of a LabVIEW and a Visual Basic application are provided with the installation 
CD disk. All examples assume a rudimentary knowledge of the respective development 
platforms. 
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Active X Details  
 
Types 

1) ccdUpdated 
a. Flag used to inform calling application if camera has made a new measurement 

(used with the DataUpdated property). Also used on startup to inform calling 
application that the camera has been initialized (used with the SettingsUpdated 
property) 

b. Values 
i. ccdNotUpdated  = 0   (Settings/Data not yet updated) 
ii. ccdUpdatedSusccessful = 1  (Settings/Data have been updated) 
iii. ccdFailed = -1   (Failed to set up initial settings) 

 
 
Events (in Visual Basic only) 
 
Note: Events can only be used in Visual Basic applications. In order to use events, the 
EventsEnabled property (described below) must be set to TRUE. 
 

1) DataUpdated: LBP HR has made a new measurement 
2) ShutterChanged: Shutter setting has been updated 
3) GainChanged: Gain setting used by hardware has been updated 
4) ErrorMessage: LBP HR is reporting an operational error (as a code and as a text 

message).  
 
 
 
Properties 
 

1) ShutterTable 
a. Used to get the shutter table used by the camera hardware 

2) Shutter 
a. Used to get or set the shutter time of the camera 
b. Used Shutter value from array values of the Shutter Table 

3) GainTable 
a. Used to get the gain table used by the camera hardware 

4) Gain 
a. Used to get or set the gain used by the camera hardware 
b. Used Gain value from array values of the Gain Table  

5) SizeCapture 
a. Used to get or set the size of the capture screen 
b. Used with the ccdSize type described above 

6) ClipLevel 
a. Used to get or set the Clip Levels of the profiles 

7) EnableEvents 
a. Used to enable Visual Basic events. This is compatible with Visual Basic 

applications that used simple broadcast events.  
b. Default is set to FALSE (no Visual Basic events) 

8) SettingsUpdated 
a. Used on startup to inform the calling application that the LBP HR has finished its 

initialization 
b. Used with the ccdUpdated type described above 

9) DataUpdated 
a. Used by non-Visual Basic applications. 
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b. Set to 0 by calling application to request new measurement from the LBP HR 
c. Set to 1 by LBP HR to inform calling application that a new measurement has been 

made and processed 
 
 

 
Methods 
 

1) HideForm 
a. When launched, the LBP HR window is displayed. This property allows the window 

to be hidden without affecting measurements, thereby freeing the screen for the 
calling application. 

2) ShowForm 
a. Allows LBP HR window to be displayed 

3) GetCentroid 
a. Returns horizontal and vertical centroid in a 2 elements array 
b. Values are in microns 

4) GetPeak 
a. Returns horizontal and vertical Beam peak in a 2 elements array 
b. Values are in microns 

5) GetBeamWidths 
a. Returns array of horizontal and vertical beamwidths at all 3 clip levels 
b. First 3 elements are horizontal beamwidths at clip levels 1,2, and 3 
c. Second 3 elements are vertical beamwidths at clip levels 1,2, and 3 
d. Values are in microns 

6) GetGaussWidths 
a. Returns array of horizontal and vertical gaussian widths at all 3 clip levels 
b. First 3 elements are horizontal gaussian widths at clip levels 1,2, and 3 
c. Second 3 elements are vertical gaussian widths at clip levels 1,2, and 3 
d. Values are in microns 

7) GetGaussCorrelation 
a. Returns horizontal and vertical correlation in a 2 elements array 
b. Values are in percent 

8) GetColorMaxAmplitude 
a. Return highest pixel intensity measured 
b. Value is between 0.0 and 100.0 

9) GetAmplitudeVectorX 
a. Returns horizontal profile as array with values from 0.0 to 100.0 
b. Array length is a function of capture size 

10) GetAmplitudeVectorY 
a. Returns vertical profile as array with values from 0.0 to 100.0 
b. Array length is a function of capture size 

11) GetMatrix 
a. Returns input matrix array from CCD detector with values from 0 to 255 
b. Array length is a function of capture size 

12) GetPower 
a. Returns power measured in milliwatts 
b. If LBP HR wasn’t calibrated for power, returns 0. 
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