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 Important Information

Warranty
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the event that technical or typographical errors exist, National Instruments reserves the right to make changes to subsequent editions of this document 
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Instruments be liable for any damages arising out of or related to this document or the information contained in it.
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MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR NEGLIGENCE ON THE PART OF NATIONAL 
INSTRUMENTS SHALL BE LIMITED TO THE AMOUNT THERETOFORE PAID BY THE CUSTOMER. NATIONAL INSTRUMENTS WILL NOT BE LIABLE FOR DAMAGES RESULTING 
FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF. This limitation of 
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performance due to causes beyond its reasonable control. The warranty provided herein does not cover damages, defects, malfunctions, or service 
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reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, 
recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National 
Instruments Corporation.

National Instruments respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other 
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National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation. Refer to the Terms of Use section 
on ni.com/legal for more information about National Instruments trademarks.

FireWire® is the registered trademark of Apple Computer, Inc. Other product and company names mentioned herein are trademarks or trade names 
of their respective companies.

Members of the National Instruments Alliance Partner Program are business entities independent from National Instruments and have no agency, 
partnership, or joint-venture relationship with National Instruments.
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For patents covering National Instruments products, refer to the appropriate location: Help»Patents in your software, the patents.txt file 
on your CD, or ni.com/patents.
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About This Manual

The Measurement Studio User Manual introduces the concepts associated 
with the Measurement Studio class libraries and development tools. This 
manual assumes that you have a general working knowledge of Microsoft 
Visual Studio, including .NET Windows, ASP.NET, and MFC.

How To Use this Manual
Measurement Studio 8.0.1 includes two CDs—one with support for Visual 
Studio .NET 2003 and Visual Studio 2005 and one with support for Visual 
Studio 6.0. This manual documents the Measurement Studio for Visual 
Studio 2003/2005 CD. The Measurement Studio support for Visual Studio 
.NET 2003 and Visual Studio 2005 CD includes separate, parallel sets of 
class libraries, integration features, and support documentation for 
developing with Visual Studio .NET 2003 and Visual Studio 2005. For help 
with Visual Studio 6.0, refer to the Measurement Studio Support for Visual 
Studio 6.0 Readme located on the Measurement Studio for Visual 
Studio 6.0 CD.

The Measurement Studio User Manual is organized into five chapters. 
Chapter 1, Introduction to Measurement Studio, is an overview of 
Measurement Studio. This chapter includes installation and deployment 
requirements, installation instructions, and a list of Measurement Studio 
resources. Chapter 2, Measurement Studio .NET Class Libraries, and 
Chapter 3, Measurement Studio Visual C++ Class Libraries, include 
information about the .NET class libraries and the Visual C++ class 
libraries, respectively. Chapter 4, Measurement Studio Integrated Tools 
and Features, includes information on using Measurement Studio tools and 
features integrated into the Visual Studio environment. Chapter 5, Getting 
Started with Measurement Studio, includes walthroughs that guide you 
through step-by-step instructions on how to develop with Measurement 
Studio features.

Use this manual as a starting point to learn about Measurement Studio. 
Refer to the NI Measurement Studio Help within the Visual Studio 
environment for function reference and detailed information about the 
Measurement Studio class libraries, wizards, assistants, and other features.
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Conventions
The following conventions appear in this manual:

<> Text enclosed in angle brackets represents directory names and parts of 
paths that may vary on different computers, such as <Windows\System>.

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click on in the software, 
such as menu items and dialog box options. Bold text also denotes class 
library member names or emphasis.

italic Italic text denotes parameters, variables, cross-references, or an 
introduction to a key concept. Italic text also denotes text that is a 
placeholder for a word or value that you must supply.

monospace Text in this font denotes text or characters that you enter from the keyboard, 
sections of code, programming examples, and syntax examples. This font 
also is used for the proper names of disk drives, paths, directories, 
programs, device names, filenames and extensions, and code excerpts.
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1
Introduction to Measurement 
Studio

Measurement Studio is an integrated suite of tools and class libraries that 
are designed for developers using Microsoft .NET Windows, ASP.NET, 
and MFC to develop measurement and automation applications.

Measurement Studio dramatically reduces application development time 
through object-oriented measurement hardware interfaces, advanced 
analysis libraries, scientific user interface controls for Windows and Web 
applications, measurement data networking, wizards, interactive code 
designers, and highly extensible .NET and Visual C++ classes. You can use 
Measurement Studio to develop a complete measurement and automation 
application that includes data acquisition, analysis, and presentation 
functionalities.

Measurement Studio 8.0.1 Professional and Enterprise packages include 
two CDs—one CD with support for Visual Studio .NET 2003 and Visual 
Studio 2005 and one CD with support for Visual Studio 6.0. The 
Measurement Studio 8.0.1 Standard package includes one CD with support 
for Visual Studio .NET 2003 and Visual Studio 2005.

This manual documents the Measurement Studio for Visual Studio 
2003/2005 CD. The Measurement Studio for Visual Studio 2003/2005 CD 
includes separate, parallel sets of class libraries, integration features, and 
support documentation for developing with Visual Studio .NET 2003 and 
Visual Studio 2005. For help with Visual Studio 6.0, refer to the 
Measurement Studio Support for Visual Studio 6.0 Readme located on the 
Measurement Studio for Visual Studio 6.0 CD.
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Installation Requirements
To install Measurement Studio, your computer must have the following:

• Microsoft Windows 2000/XP/XP x641

• Microsoft .NET Framework 1.1 for Visual Studio .NET 2003 or 
Microsoft .NET Framework 2.0 for Visual Studio 2005 (required only 
for the Measurement Studio .NET class libraries)

• Standard, Professional, Enterprise Developer, Enterprise Architect, or 
Academic edition of Microsoft Visual Studio .NET 2003 and Standard, 
Professional, or Team System edition of Microsoft Visual Studio 2005 
(required to use the Measurement Studio integrated tools) or Visual 
C#, Visual Basic, or Visual Web Developer Express Editions of 
Microsoft Visual Studio 20052

• Intel Pentium II class processor, 733 MHz or higher

• Video display—800 × 600, 256 colors (16-bit color recommended for 
user interface controls)

• Minimum of 256 MB of RAM (512 MB or higher recommended)

• Minimum of 405 MB of free hard disk space for Visual Studio .NET 
2003 support and minimum of 385 MB of free hard disk space for 
Visual Studio 2005 support

• Microsoft-compatible mouse

• Microsoft Internet Explorer 6.0 or later

Optional Installation—In order for links from Measurement Studio help 
topics to .NET Framework help topics to work, you must install the 
Microsoft .NET Framework SDK 1.1 for Visual Studio .NET 2003 or 
Microsoft .NET Framework SDK 2.0 for Visual Studio 2005.

1   You cannot use Measurement Studio class libraries in 64-bit applications. You can, however, use Measurement Studio class 
libraries in 32-bit applications and run those applications on XP x64, provided that all drivers you use in the applications 
support XP x64. Current NI driver support for XP x64 is limited.

2   Measurement Studio integration tools are not supported in the Visual Studio 2005 Express Editions. Measurement Studio does 
not support Visual C++ Express Edition. Measurement Studio Visual C++ class libraries extend Microsoft Foundation Classes 
(MFC). Visual C++ Express Edition does not support MFC.
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Deployment Requirements
To deploy an application built with Measurement Studio .NET class 
libraries, the target computer must have a Windows 2000/XP/XP x641 
operating system and the .NET Framework version 1.1 for Visual Studio 
.NET 2003 or the .NET Framework version 2.0 for Visual Studio 2005.

To deploy an application built with Measurement Studio Visual C++ class 
libraries, the target computer must have a Windows 2000/XP/XP x641 
operating system.

Notes about Installing Measurement Studio 8.0.1 Over Previous 
Versions of Measurement Studio

If you install Measurement Studio 8.0.1 on a machine that has 
Measurement Studio 7.x installed, the installer replaces Measurement 
Studio 7.x functionality, including class libraries. The Measurement Studio 
7.x assemblies remain in the global assembly cache (GAC); therefore, 
applications that reference the Measurement Studio 7.x version continue to 
use Measurement Studio 7.x .NET assemblies.

The default directory for Measurement Studio 8.0.1 support for Visual 
Studio .NET 2003 (Program Files\NationalInstruments\
MeasurementStudioVS2003) is different than the default directory for 
Measurement Studio 7.0 (Program Files\NationalInstruments\
MeasurementStudio70). If Measurement Studio 7.0 is installed on your 
machine when you install Measurement Studio 8.0.1, Measurement Studio 
8.0.1 installs to the 7.0 directory. If you prefer to install Measurement 
Studio 8.0.1 to the default 8.0.1 directory, you must first uninstall all 
Measurement Studio class libraries, including class libraries installed with 
National Instruments driver software, such as NI-VISA, NI-488.2, and 
NI-DAQmx.

Measurement Studio supports side-by-side installation of version 6.0 and 
8.0.1. You must install Measurement Studio 6.0 and 8.0.1 to different 
directories.

1   You cannot use Measurement Studio class libraries in 64-bit applications. You can, however, use Measurement Studio class 
libraries in 32-bit applications and run those applications on XP x64, provided that all drivers you use in the applications 
support XP x64. Current NI driver support for XP x64 is limited.
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Installing Measurement Studio
Complete the following steps to install Measurement Studio. These steps 
describe a typical installation. Please review carefully all additional 
licensing and warning dialog boxes.

Note There are separate installers for Measurement Studio support for Visual Studio 
.NET 2003 and Measurement Studio support for Visual Studio 2005. Repeat the 
installation instructions to install support for both.

1. Insert the Measurement Studio CD into the CD drive. autorun.exe 
automatically starts. If it does not automatically start, double-click the 
autorun.exe icon.

2. Click Install NI Measurement Studio for Visual Studio .NET 2003 
or click Install NI Measurement Studio for Visual Studio 2005.

3. Enter the serial number. You can find your serial number on the 
Certificate of Ownership card that you received with Measurement 
Studio. Click Next.

4. Review the information in the Product Information dialog box and 
click Next.

5. Click Next to install all NI software to the default installation 
directory, or click Browse to select a different installation directory. 
You must install Measurement Studio to a local drive. Click Next.

Note The option to browse for an installation location is valid only if you have not already 
installed any Measurement Studio features. If you have any Measurement Studio features 
installed, then Measurement Studio installs to the same root directory to which you 
installed other Measurement Studio features.

6. From the feature tree, select the features you want to install. To change 
the Measurement Studio installation directory, select the first feature in 
the list and click Browse. Click Next.

7. Review the license agreement and select I accept the License 
Agreement(s). Click Next.

8. In the Installation Summary dialog box, review the features you 
selected. Click Next.

Note Step 8 starts the installation of Measurement Studio. Be aware that when the installer 
indicates that it is removing backup files, this is a normal operation. The installer may take 
several minutes to complete this step.
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9. If prompted, insert the Device Drivers CD and select Rescan Drive. If 
not prompted, go to step 14 on this list.

10. From the feature tree, select the Device Drivers components you want 
to install. To change a driver installation directory, select the driver and 
click Browse. Click Next.

11. In the Product Information dialog box, carefully review important 
information about the features you are installing. Click Next.

12. Review the license agreement and select I accept the License 
Agreement(s). Click Next.

13. In the Installation Summary dialog box, review the features you 
selected. Click Next.

14. Click the Register button to register Measurement Studio now, and 
click Next to complete the installation.

15. If prompted, click the appropriate restart option. If you did not install 
a component that requires a restart, you will not be prompted to restart.

Measurement Studio Package Comparison Chart
Table 1-1 lists the features included in the Standard, Professional, and 
Enterprise packages of Measurement Studio. Refer to ni.com/mstudio 
for more information about the functionality and features included with 
each Measurement Studio package, including Visual C++ functionality.

Table 1-1.  Measurement Studio Package Comparison Chart for Visual C# and Visual Basic .NET

Feature Standard Edition Professional Edition Enterprise Edition

Project Wizards ✔ ✔ ✔

Windows Forms User 
Interface Controls

✔ ✔ ✔

Standard Analysis 
Libraries1

✔ ✔ ✔

GPIB Class Libraries2 ✔ ✔ ✔

VISA Class Libraries2 ✔ ✔ ✔

NI-DAQmx Class 
Libraries2

✔ ✔ ✔

.NET Instrument 
Driver Wizard

✔ ✔ ✔
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User Interface 
DataSocket Binding

✔ ✔ ✔

Web Forms User 
Interface Controls

✔ ✔

ActiveX Controls for 
Visual Basic 6.0

✔ ✔

MFC and ActiveX 
Controls for Visual 
C++ 6.0

✔ ✔

Professional Analysis 
Libraries3

✔ ✔

3D Graph for Visual 
C++

✔ ✔

DataSocket Server ✔ ✔

DataSocket Library ✔ ✔

Parameter Assistant ✔ ✔

Instrument I/O 
Assistant2

✔ ✔

DAQ Assistant2 ✔ ✔

Enterprise Analysis 
Libraries4

✔

NI-Reports ✔

NI TestStand 
Integration

✔

Table 1-1.  Measurement Studio Package Comparison Chart for Visual C# and Visual Basic .NET (Continued) 

Feature Standard Edition Professional Edition Enterprise Edition
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Measurement Studio Resources
As you work with Measurement Studio, you might need to consult other 
resources. For detailed Measurement Studio help, including function 
reference and in-depth documentation on developing with Measurement 
Studio, refer to the NI Measurement Studio Help within the Visual Studio 
environment. The NI Measurement Studio Help is fully integrated with the 
Visual Studio help. You must have Visual Studio installed to view the 
online help, and you must have the Microsoft .NET Framework SDK 1.1 
for Visual Studio .NET 2003 or the Microsoft .NET Framework SDK 2.0 
for Visual Studio 2005 installed in order for links from Measurement 
Studio help topics to .NET Framework help topics to work. You can launch 
the NI Measurement Studio Help in the following ways:

• From the Windows Start menu, select Start»All Programs»
National Instruments»<Measurement Studio>»Measurement 
Studio Documentation. The help launches in a stand-alone help 
viewer.

• From Visual Studio, select Help»Contents to view the Visual Studio 
table of contents. The NI Measurement Studio Help is listed in the table 
of contents.

• From Visual Studio, select Measurement Studio»NI Measurement 
Studio Help. The help launches within the application.

Tip As you work through this manual, you will see italicized references to relevant help 
topics. To find these topics, use the table of contents in the NI Measurement Studio Help.

LabWindows™/CVI™ 
Full Development 
System (FDS)

✔

1 Refer to the Standard Analysis section of Chapter 2, Measurement Studio .NET Class Libraries, for a list of the 
functionality included in the Standard Analysis class library.

2 Included with the Device Drivers CD.

3 Refer to the Professional Analysis section of Chapter 2, Measurement Studio .NET Class Libraries, for a list of the 
functionality included in the Professional Analysis class library.

4 Refer to the Enterprise Analysis section of Chapter 2, Measurement Studio .NET Class Libraries, for a list of the 
functionality included in the Enterprise Analysis class library.

Table 1-1.  Measurement Studio Package Comparison Chart for Visual C# and Visual Basic .NET (Continued) 

Feature Standard Edition Professional Edition Enterprise Edition
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The following resources also are available to provide you with information 
about Measurement Studio.

• Examples—Measurement Studio installs examples to the following 
paths:

– Visual Basic .NET or Visual C#—Program Files\National 

Instruments\<MeasurementStudio>\DotNET\Examples

– Visual C++—Program Files\National 

Instruments\<MeasurementStudio>\VCNET\Examples

• NI Technical Support—Refer to Appendix A, Technical Support and 
Professional Services, for more information.

• Measurement Studio Web site, ni.com/mstudio—Contains 
Measurement Studio news, support, downloads, white papers, product 
tutorials, and evaluation software.

• NI Developer Zone, zone.ni.com—Provides access to online 
example programs, tutorials, technical news, and a Discussion Forum 
where you can participate in Measurement Studio discussion forums 
for Visual Basic 6.0, Visual C++, and .NET languages.

• Measurement Studio .NET Class Hierarchy Chart and Measurement 
Studio Visual C++ Class Hierarchy Chart—Provide overviews of 
class relationships within class libraries. Charts are included with all 
Measurement Studio packages and are posted online on the Manuals 
page at ni.com/manuals.
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2
Measurement Studio .NET Class 
Libraries

This chapter provides overview information about the .NET class libraries 
included with Measurement Studio support for Visual Studio .NET 2003 
and Visual Studio 2005. Refer to the Using the Measurement Studio .NET 
Class Libraries section of the NI Measurement Studio Help for detailed 
information about these libraries. Refer to Chapter 5, Getting Started with 
Measurement Studio, for step-by-step instructions on developing 
applications with these libraries.

Measurement Studio Support for Visual Studio .NET 
2003 Class Library Overview

Measurement Studio provides .NET class libraries that you can use to 
develop complete measurement and automation applications in Visual 
Basic .NET and Visual C#.

Measurement Studio includes the following .NET class libraries:

• Analysis

• Common

• DataSocket

• NI-488.2

• NI-DAQmx

• NI-VISA

• User Interface

Refer to the following sections for information about each Measurement 
Studio .NET class library.
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Analysis
The Measurement Studio Analysis .NET class library is in the 
NationalInstruments.Analysis namespace. The Analysis class 
library includes a set of classes that provides various digital signal 
processing, signal filtering, signal generation, peak detection, and other 
general mathematical functionality. Use this library to analyze acquired 
data or to generate data.

The functionality included in the Analysis library varies based on the 
Measurement Studio package you purchased. Refer to the following 
sections for information about the Standard, Professional, and Enterprise 
Analysis class libraries.

Standard Analysis
The Standard Analysis class library, which ships with Measurement Studio 
Standard Edition, includes the sawtooth, sine, square, triangle, and basic 
function wave generators.

Professional Analysis
The Professional Analysis class library, which ships with Measurement 
Studio Professional Edition, includes the Standard Analysis functionality 
as well as the following functionality:

• Bessel, Chebyshev, Inverse Chebyshev, Windowed, Kaiser, and 
Elliptic Low, High, Bandpass, and Bandstop filters

• Signal processing functions such as convolution, deconvolution, 
correlation, decimation, integration, and differentiation

• FFT, Inverse FFT, Real FFT, Fast Hartley, Inverse Fast Hartley, Fast 
Hilbert, Inverse Fast Hilbert, DST, Inverse DST, DCT, and Inverse 
DCT transformations

• Linear algebra functions such as determinant, check positive 
definiteness, calculate dot product, and other various matrix functions

• Scaled and unscaled windowing classes

• Common statistical functions such as mean, median, mode, and 
variance

• Exponential, linear, and polynomial curve fitting functions

• Signal generation functions
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Enterprise Analysis
The Enterprise Analysis class library, which ships with Measurement 
Studio Enterprise Edition, includes the Standard and Professional Analysis 
functionality as well as the following advanced functionality:

• EquiRipple filters

• Linear algebra functions such as forward and back substitution, 
LU factorization, Cholesky factorization, Schur decomposition, and 
Hessenberg decomposition

• Probability and analysis of variance

• Sinc, impulse, pulse, ramp, and chirp patterns

• General least squares fit, power fit, log fit, Gauss fit, cubic spline fit, 
and interpolation functions

• Special functions

Refer to Table 2-1 to determine the type of measurements available in the 
Professional and Enterprise Analysis .NET libraries.

Table 2-1.  Analysis .NET Library Measurement Types Included in the 
Professional and Enterprise Packages

Analysis .NET Library Professional Package Enterprise Package

Measurements

AC and DC Estimator ✔

Amplitude and Phase 
Spectrum

✔

Auto Power Spectrum ✔

Cross Power Spectrum ✔

Harmonic Analyzer ✔

Impulse Response Function ✔ ✔

Network Functions (avg) ✔ ✔

Power and Frequency Estimate ✔

Scaled Time Domain Window ✔

Spectrum Unit Conversion ✔

Transfer Function ✔
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Signal Generation

Arbitrary Wave ✔ ✔

Chirp Pattern ✔ ✔

Gaussian White Noise ✔ ✔

Impulse Pattern ✔

Pulse Pattern ✔

Ramp Pattern ✔

Sawtooth Wave ✔

Sinc Pattern ✔

Sine Pattern ✔ ✔

Sine Wave ✔ ✔

Square Wave ✔ ✔

Triangle Wave ✔ ✔

Uniform White Noise ✔ ✔

Windowing

Blackman Window ✔ ✔

Blackman-Harris Window ✔ ✔

Blackman-Nuttall Window ✔ ✔

Cosine Tapered window ✔ ✔

Dolph-Chebyshev Window ✔ ✔

Exact Blackman Window ✔ ✔

Exponential Window ✔ ✔

Flat Top Window ✔ ✔

Force Window ✔ ✔

Gauss Window ✔ ✔

Table 2-1.  Analysis .NET Library Measurement Types Included in the 
Professional and Enterprise Packages (Continued)

Analysis .NET Library Professional Package Enterprise Package
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General Cosine Window ✔ ✔

Hamming Window ✔ ✔

Hanning Window ✔ ✔

Kaiser Window ✔ ✔

Scaled Time Domain Windows ✔ ✔

Symmetric Time Domain 
Windows

✔ ✔

Triangle Window ✔ ✔

Filters

Bessel ✔ ✔

Butterworth ✔ ✔

Cascade ✔ ✔

Chebyshev ✔ ✔

Elliptic ✔ ✔

Equiripple ✔

FIR ✔ ✔

FIR Windowed ✔ ✔

IIR Cascade ✔ ✔

IIR ✔ ✔

Inverse Chebyshev ✔ ✔

Kaiser ✔ ✔

Signal Processing

Autocorrelation ✔ ✔

Convolution ✔ ✔

Cross Power ✔ ✔

Table 2-1.  Analysis .NET Library Measurement Types Included in the 
Professional and Enterprise Packages (Continued)

Analysis .NET Library Professional Package Enterprise Package
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Cross Correlation ✔ ✔

Decimate ✔ ✔

Deconvolution ✔ ✔

Derivative x(t) ✔ ✔

Discrete Cosine Transform ✔ ✔

Discrete Sine Transform ✔ ✔

Fast Hilbert Transform ✔ ✔

Fast Hartley Transform ✔ ✔

Integral x(t) ✔ ✔

Inverse Real and Complex Fast 
Fourier Transform (FFT)

✔ ✔

Inverse Fast Hilbert Transform ✔ ✔

Inverse Fast Hartley Transform ✔ ✔

Peak Detection ✔ ✔

Power Spectrum ✔ ✔

Pulse Parameters ✔ ✔

Real and Complex FFT ✔ ✔

Threshold Peak Detector ✔ ✔

Unwrap Phase ✔

Linear Algebra

Back Transform Eigenvectors ✔

Backward Substitution ✔

Cholesky Factorization ✔

Complex Back Transform 
Eigenvectors

✔

Table 2-1.  Analysis .NET Library Measurement Types Included in the 
Professional and Enterprise Packages (Continued)

Analysis .NET Library Professional Package Enterprise Package
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Complex Cholesky 
Factorization

✔

Complex Determinant ✔ ✔

Complex Dot Product ✔ ✔

Complex Eigenvectors and 
Eigenvalues

✔

Complex General Eigen AB ✔

Complex Hessenberg 
Decomposition

✔

Complex Inverse Matrix ✔

Complex Linear Equations ✔

Complex LU Factorization ✔

Complex Matrix Balance ✔

Complex Matrix Condition 
Number

✔ ✔

Complex Matrix Norm ✔ ✔

Complex Matrix Rank ✔ ✔

Complex Outer Product ✔ ✔

Complex Pseudo Inverse 
Matrix

✔ ✔

Complex QR Factorization ✔

Complex QR Factorization 
with Pivot Matrix

✔

Complex QR Factorization 
with Pivot Vector

✔

Complex QZ Decomposition ✔

Complex Schur 
Decomposition

✔

Table 2-1.  Analysis .NET Library Measurement Types Included in the 
Professional and Enterprise Packages (Continued)

Analysis .NET Library Professional Package Enterprise Package
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Complex Solve Linear 
Equations (Multiple Right 
Hand)

✔

Complex Solve Linear 
Equations (Single Right Hand)

✔

Complex SVD Factorization ✔

Complex Vector Norm ✔

Determinant ✔ ✔

Dot Product ✔ ✔

Forward Substitution ✔

General Eigen AB ✔

Hessenberg Decomposition ✔

Inverse Matrix ✔ ✔

Linear Equations ✔

LU Factorization ✔

Matrix Balance ✔

Matrix Condition Number ✔ ✔

Matrix Multiplication ✔ ✔

Matrix Norm ✔ ✔

Matrix Rank ✔ ✔

Outer Product ✔ ✔

Pseudo Inverse Matrix ✔ ✔

QR Factorization ✔

QR Factorization with Pivot 
Matrix

✔

QR Factorization with Pivot 
Vector

✔

Table 2-1.  Analysis .NET Library Measurement Types Included in the 
Professional and Enterprise Packages (Continued)

Analysis .NET Library Professional Package Enterprise Package
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QZ Decomposition ✔

Schur Decomposition ✔

Special Matrix ✔ ✔

Solve Linear Equations 
(Multiple Right Hand)

✔

Solve Linear Equations 
(Single Right Hand)

✔

SVD Factorization ✔

Test Positive Definite Matrix ✔ ✔

Trace ✔ ✔

Transpose ✔ ✔

Array and Numeric Operations

1D and 2D Array Arithmetic ✔ ✔

1D and 2D Linear Evaluation ✔ ✔

1D and 2D Polynomial 
Evaluation

✔ ✔

1D Polar to Rectangular ✔ ✔

1D Rectangular to Polar ✔ ✔

Scale 1D and 2D ✔ ✔

Find Polynomial Roots ✔ ✔

Complex Number Arithmetic ✔ ✔

Curve Fitting

Cubic Spline Fit ✔

Exponential Fit ✔ ✔

Exponential Fit Interval ✔

Gauss Fit ✔

Table 2-1.  Analysis .NET Library Measurement Types Included in the 
Professional and Enterprise Packages (Continued)

Analysis .NET Library Professional Package Enterprise Package
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Gauss Fit Interval ✔

General Least Squares Fit ✔

Goodness of Fit ✔

Linear Fit ✔ ✔

Linear Fit Interval ✔

Logarithm Fit ✔

Logarithm Fit Interval ✔

Nonlinear Fit ✔

Polynomial Fit ✔ ✔

Power Fit ✔

Power Fit Interval ✔

Remove Outliers ✔

Statistics

1D, 2D, and 3D ANOVA ✔

Chi-Square Distribution ✔

erf(x) and erfc(x) ✔

F-Distribution ✔

Histogram ✔ ✔

Inverse Chi-Square 
Distribution

✔

Inverse F-Distribution ✔

Inverse Normal Distribution ✔

Inverse T-Distribution ✔

Mean ✔ ✔

Median and Mode ✔ ✔

Table 2-1.  Analysis .NET Library Measurement Types Included in the 
Professional and Enterprise Packages (Continued)

Analysis .NET Library Professional Package Enterprise Package
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Moment about Mean ✔ ✔

Normal Distribution ✔

Polynomial Interpolation ✔

RMS ✔ ✔

Spline Interpolant ✔

Spline Interpolation ✔

Standard Deviation ✔ ✔

T-Distribution ✔

Variance ✔

Special Functions

Airy ✔

Bessel 1st ✔

Bessel 2nd ✔

Beta ✔

Complimentary Gamma ✔

Cosine Integral ✔

Dawson’s Integral ✔

Dilogarithm ✔

Elliptic 1st ✔

Elliptic 2nd ✔

Exponential Integral ✔

Factorial ✔

Fresnel Integrals ✔

Gamma ✔

Gauss HyperGeometric ✔

Table 2-1.  Analysis .NET Library Measurement Types Included in the 
Professional and Enterprise Packages (Continued)

Analysis .NET Library Professional Package Enterprise Package
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Hyperbolic Cosine Integral ✔

Hyperbolic Sine Integral ✔

Incomplete Beta ✔

Incomplete Elliptic 1st ✔

Incomplete Elliptic 2nd ✔

Incomplete Gamma ✔

Jacobian Elliptic Function ✔

Kelvin 1st ✔

Kelvin 2nd ✔

Kummer ✔

Logarithm of Factorial ✔

Modified Bessel 1st ✔

Modified Bessel 2nd ✔

Parabolic Cylinder ✔

Psi ✔

Sine Integral ✔

Spherical Bessel 1st ✔

Spherical Bessel 2nd ✔

Stirling ✔

Struve ✔

Tricomi ✔

Zeta ✔

Table 2-1.  Analysis .NET Library Measurement Types Included in the 
Professional and Enterprise Packages (Continued)

Analysis .NET Library Professional Package Enterprise Package
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Tip For more information about analyzing or generating data with the Analysis class 
library, refer to the Using the Measurement Studio Analysis .NET Library topic in the 
NI Measurement Studio Help. For more information about the functionality included in the 
Analysis class library, visit ni.com/analysis and select Analysis in Measurement 
Studio.

Common
The Measurement Studio Common .NET class library is in the 
NationalInstruments namespace. The Common class library provides 
a set of classes that facilitates the exchange of data between the acquisition, 
analysis, and user interface portions of your application. The Common 
class library includes the following features:

• A ComplexDouble data type. This data type represents a complex 
number of type Double that is composed of a real part and an 
imaginary part.

• A DigitalWaveform data type. This data type represents a set of 
digital states that are grouped by samples or signals.

• An AnalogWaveform data type. This data type represents an analog 
signal that varies over time.

• A DataConverter class that converts data from one data type to 
another data type, such as converting an array of integers to an array of 
doubles.

• An EngineeringFormatInfo class that defines a custom formatter 
to format numeric values as strings with engineering notation and 
International System of Units (SI) prefixes and symbols.

Tip For more detailed information about the Common class library, refer to the 
National Instruments section in the NI Measurement Studio Help.

DataSocket
The Measurement Studio DataSocket .NET class library is in the 
NationalInstruments.Net namespace. Use the DataSocket class 
library to transfer live measurement data over the Internet or an intranet, 
between applications on the same computer, and to and from files. Use the 
classes in the DataSocket class library to perform the following operations:

• Read and write data between different data sources and targets.

• Use a single, simple API to communicate with several types of servers, 
including DataSocket Servers (dstp:), Web servers (http:), file 
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transfer protocol servers (ftp:), file systems (file:), and OLE for 
Process Control (opc:) servers.

• Specify data sources and targets using a URL, the same way you access 
Web pages in a Web browser.

• Use DataSocket Transfer Protocol (DSTP) to exchange different types 
of data.

• Expose DataSocket data items as data sources that you can bind to 
properties of a Windows Forms control.

• Interactively browse to quickly locate and select data items on other 
computers and servers.

Tip For more detailed information about the DataSocket class library, refer to the Using 
the Measurement Studio DataSocket .NET Library section in the NI Measurement Studio 
Help.

NI-488.2
The Measurement Studio NI-488.2 .NET class library is in the 
NationalInstruments.NI4882 namespace. This class library is 
included when you install the NI-488.2 driver. The NI-488.2 class library 
includes a set of classes for communicating with GPIB instruments, 
controlling GPIB devices, and acquiring GPIB status information. Use this 
library to design code that communicates with and controls instruments on 
a GPIB interface. Use the NI-488.2 class library to configure and 
communicate with GPIB devices using the Device and Board classes.

Tip For more detailed information about the NI-488.2 class library, refer to the Using the 
Measurement Studio NI-488.2 .NET Library section in the NI Measurement Studio Help. 
For more information about GPIB, visit ni.com/gpib.

NI-DAQmx
The Measurement Studio NI-DAQmx .NET class library is in the 
NationalInstruments.DAQmx namespace. This class library is 
included when you install the NI-DAQmx driver. Use the NI-DAQmx class 
library to communicate with and control NI data acquisition (DAQ) 
devices.

Note Some DAQ devices are not currently supported by the NI-DAQmx driver. Refer to 
the NI-DAQ Readme for a complete listing of supported hardware.
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Use the NI-DAQmx class library to perform the following types of tasks:

• Analog signal measurement

• Analog signal generation

• Digital I/O

• Counting and timing

• Pulse generation

• Signal switching

Tip For information about easily creating an NI-DAQmx application, refer to the Creating 
a Measurement Studio NI-DAQmx Application section of Chapter 4, Measurement Studio 
Integrated Tools and Features, or the Walkthrough: Creating a Measurement Studio 
NI-DAQmx Application in Visual Studio 2005 and Walkthrough: Creating a Measurement 
Studio NI-DAQmx Application in Visual Studio .NET 2003 sections of Chapter 5, Getting 
Started with Measurement Studio. For more information about DAQ, visit ni.com/daq.

NI-VISA
The Measurement Studio NI-VISA .NET class library is in the 
NationalInstruments.VisaNS namespace. This class library is 
included when you install the NI-VISA driver. The NI-VISA class library 
includes a set of classes that provides a rich, object-oriented interface to the 
NI-VISA driver. Use this library to quickly create bus-independent and/or 
bus-specific instrument control applications.

The NI-VISA class library supports formatted I/O operations, locking, 
event handling, and interface-specific extensions. With this class library 
you can access the functionality available in NI-VISA for communicating 
with message-based and register-based instruments using the following 
interfaces:

• GPIB

• IEEE 1394

• PXI

• Serial (RS-232 and RS-485)

• TCP/IP

• USB

• VXI

Tip For information about easily creating a Measurement Studio NI-VISA application 
using the Instrument I/O Assistant, refer to the Creating a Measurement Studio Instrument 
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Control Application section in Chapter 4, Measurement Studio Integrated Tools and 
Features, or the Walkthrough: Creating a Measurement Studio Instrument I/O Application 
in Visual Studio .NET 2003 and Walkthrough: Creating a Measurement Studio Instrument 
I/O Application in Visual Studio 2005 sections of Chapter 5, Getting Started with 
Measurement Studio. For more information about NI-VISA, visit ni.com/visa.

User Interface
The Measurement Studio user interface controls are in the Windows Forms 
and Web Forms .NET class libraries. Refer to Table 2-2 for the UI controls 
provided by Measurement Studio.

Table 2-2.  Measurement Studio User Interface Controls

User Interface 
Controls

Visual Studio 2005
Visual Studio 

.NET 2003

Windows Forms Web Forms Windows Forms

Waveform graph ✔ ✔ ✔

Scatter graph ✔ ✔ ✔

Digital waveform 
graph

✔ ✔ ✔

Complex graph ✔ ✔ ✔

Legend ✔ ✔ ✔

Knob ✔ ✔ ✔

Gauge ✔ ✔ ✔

Meter ✔ ✔ ✔

Slide ✔ ✔ ✔

Thermometer ✔ ✔ ✔

Tank ✔ ✔ ✔

Numeric edit ✔ ✔ ✔

Switch ✔ ✔ ✔

LED ✔ ✔ ✔

Property editor ✔ ✔



Chapter 2 Measurement Studio .NET Class Libraries

© National Instruments Corporation 2-17 Measurement Studio User Manual

Windows Forms Controls
The Windows Forms .NET class library is in the 
NationalInstruments.UI.WindowsForms namespace. The Windows 
Forms class library encapsulates the following Measurement Studio user 
interface controls:

• Waveform graph

• Scatter graph

• Digital waveform graph

• Complex graph

• Legend

• Knob

• Gauge

• Meter

• Slide

• Thermometer

• Tank

• Numeric edit

• Switch

• LED

• Property editor

Use this class library to add measurement-specific user interface controls 
to your application. You can configure the controls programmatically at 
design time, through the Properties window in the Windows Forms 
Designer, or at run time with the property editor control. The following 
sections describe each of the Measurement Studio Windows Forms user 
interface controls.

Array controls ✔

AutoRefresh control ✔

Table 2-2.  Measurement Studio User Interface Controls (Continued)

User Interface 
Controls

Visual Studio 2005
Visual Studio 

.NET 2003
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Tip For more information about easily using the .NET user interface controls, refer 
to the Using the Measurement Studio Windows Forms .NET Controls section in the 
NI Measurement Studio Help.

Waveform Graph and Scatter Graph Controls
Use the Measurement Studio waveform graph and scatter graph controls, as 
shown in Figure 2-1, to display two-dimensional data on a Windows Forms 
user interface. Use the waveform graph to display two-dimensional linear 
data. You explicitly specify each value in one dimension and provide an 
initial value and interval to implicitly specify the values in the other 
dimension. Use the scatter graph to display two-dimensional linear or 
nonlinear data. You explicitly specify each value in both dimensions.

Figure 2-1.  Windows Forms Waveform Graph Control with Cursors and Windows 
Forms Scatter Graph Control with XY Point Annotation; Both Graphs Have 

Corresponding Legends
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With the waveform graph and scatter graph controls and the classes that 
interface with the controls, you can perform the following operations:

Plot Operations
• Plot and chart data.

• Configure a graph to contain multiple plots to show separate but 
related data on the same graph.

• Draw lines or fills from a plot to an X value, Y value, or another plot.

• Specify plots in the scatter graph control as X and Y data. Specify plots 
in the waveform graph control as X or Y data and optionally with date 
and time scaling.

• Use the extensible plot and plot area drawing capabilities and events to 
customize the graph appearance.

• Use plot data tooltips to display X and Y coordinates when a user 
hovers the mouse over a data point.

• Create custom point and line styles for plots.

• Specify anti-aliased plots for plot lines.

Axis Operations
• Configure a graph to include multiple axes or independent ranges so 

that plot data fits the graph plot area.

• Configure the axis modes to fixed, exact autoscaling, loose 
autoscaling, strip chart, or scope chart.

• Use logarithmic axes with configurable bases.

• Interactively change the range of an axis and invert the axis at run time 
by clicking on the axis end labels.

Cursor Operations
• Use cursors to identify key points in plots and the plot area.

• Configure cursor snap modes to be fixed, floating, nearest point, or to 
plot.

• Use cursor labels to display X and Y data coordinates that the cursor 
crosshair points to, and customize the text font and colors of the label.

• Create custom point and line styles for cursors.
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Annotation Operations
• Configure text labels, arrows, and drawing shapes to annotate a point 

anywhere in the plot area of the graph.

• Configure range area, text labels, and arrows to annotate a range in the 
plot area of the graph.

Additional Operations
• Pan and zoom interactively.

• Configure major, minor, and custom divisions and origin lines.

• Copy the graph as a BMP, GIF, JPEG, or PNG image to the clipboard 
or a file.

Tip For more information about using the waveform and scatter graph controls, refer to 
the Using the Measurement Studio Windows Forms Scatter and Waveform Graph .NET 
Controls section in the NI Measurement Studio Help.

Digital Waveform Graph Control
Use the Measurement Studio digital waveform graph control, as shown in 
Figure 2-2, to display DigitalWaveform data on a Windows Forms user 
interface.

Figure 2-2.  Windows Forms Digital Graph Control
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With the digital waveform graph control and the classes that interface with 
the control, you can perform the following operations:

Plot Operations
• Plot digital waveform data. Data values can represent up to eight 

different digital states.

• Configure plot labels on the y-axis.

• Configure plot templates to customize plots that are implicitly created 
from plotted data.

• Specify anti-aliased digital plots.

• Expand and collapse signal plots interactively.

Waveform Sample and Signal State Operations
• Simultaneously display waveforms and signals or display signals only.

• Create custom waveform sample and signal state styles.

• Configure sample and state labels.

• Create custom waveform sample and signal state labels.

Axis Operations
• Configure the axis modes to fixed, exact autoscaling, or loose 

autoscaling.

• Interactively change the range of an axis and invert the axis at run time 
by clicking on the axis end labels.

Additional Operations
• Display data in sample or time mode.

• Pan with scroll bars.

• Configure the style and mode of scroll bars.

• Create custom scroll bars.

• Pan and zoom interactively.

• Configure major, minor, and custom divisions.

• Copy the graph as a BMP, GIF, JPEG, or PNG image to the clipboard 
or a file.



Chapter 2 Measurement Studio .NET Class Libraries

Measurement Studio User Manual 2-22 ni.com

Tip For more information about using the digital waveform graph control, refer to the 
Using the Measurement Studio Windows Forms Digital Waveform Graph .NET Control 
section in the NI Measurement Studio Help.

Complex Graph Control
Use the Measurement Studio complex graph control, as shown in 
Figure 2-3, to display ComplexDouble data on a Windows Forms user 
interface. A ComplexDouble consists of a real part and an imaginary part.

Figure 2-3.  Windows Forms Complex Graph Control with Arrows Indicating the 
Direction of the Complex Data

With the complex graph control and the classes that interface with the 
control, you can perform the following operations:

Plot Operations
• Plot and chart ComplexDouble data.

• Configure a graph to contain multiple plots to show separate but 
related data on the same graph.

• Draw lines or fills from a plot to an X value, Y value, or another plot.

• Use the extensible plot and plot area drawing capabilities and events to 
customize the graph appearance.

• Configure the plot to display arrows. The arrows indicate the direction 
of the complex data.

• Create custom point and line styles for plots.

• Specify anti-aliased plots for plot lines.
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Axis Operations
• Configure a graph to include multiple axes or independent ranges so 

that plot data fits the graph plot area.

• Configure the axis modes to fixed, exact autoscaling, loose 
autoscaling, strip chart, or scope chart.

• Interactively change the range of an axis and invert the axis at run time 
by clicking on the axis end labels.

Additional Operations
• Pan and zoom interactively.

• Configure major, minor, and custom divisions and origin lines.

• Copy the graph as a BMP, GIF, JPEG, or PNG image to the clipboard 
or a file.

Tip For more information about using the complex graph control, refer to the Using 
the Measurement Studio Windows Forms Complex Graph .NET Control section in the 
NI Measurement Studio Help.

Legend Control
Use the Measurement Studio legend control, as shown in Figure 2-1, to 
display symbols and descriptions for a specific set of elements of another 
object, such as the plots or cursors of a graph. When you associate the 
legend control with another object, any changes you make to that object are 
automatically reflected in the legend. For example, if you associate the 
legend control with the plots of a graph, any changes you make in the plots 
collection editor are automatically reflected in the legend.

Tip For more information about using the legend control, refer to the Using the 
Measurement Studio Windows Forms Legend .NET Control section in the NI Measurement 
Studio Help.

Numeric Controls
Use the Measurement Studio numeric controls to display numerical 
information, on a Windows Forms user interface, with the look of scientific 
instruments. The numeric controls include a knob, gauge, meter, slide, 
thermometer, and tank. The following sections describe operations 
available with the controls and the classes that interface with them.
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With all of the numeric controls and the classes that interface with them, 
you can perform the following operations:

• Configure the scale to be linear or logarithmic and toggle the visibility 
of the scale.

• Fill the scale and configure the range, color, dimensions, and style of 
the fill.

• Connect to the Measurement Studio .NET numeric edit control so that 
if you change the value of one control, it changes the value of the other 
control.

• Customize the appearance of the control using 3D lab styles or classic 
2D styles and change the color and length of ticks and labels.

• Configure the format of value labels to engineering or date/time.

Use the Measurement Studio knob, gauge, and meter controls, as shown in 
Figure 2-4, to input and display numeric data on your user interface.

Figure 2-4.  Windows Forms Knob, Gauge, and Meter Controls

With the knob, gauge, and meter controls and the classes that interface with 
the controls, you can perform the following operations:

• Specify the start and sweep angle of the arc programmatically or from 
the Properties window.

• Use automatic division spacing, custom divisions, and invert the scale.

Use the Measurement Studio slide, tank, and thermometer controls, as 
shown in Figure 2-5, to input and display numeric data on your interface.
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Figure 2-5.  Windows Forms Slide, Tank, and Thermometer Controls

With the slide, tank, and thermometer controls and the classes that interface 
with them, you can perform the following operations:

• Fill to the minimum or maximum value of the scale.

• Position the scale horizontally with left, right, or both and position the 
scale vertically with top, bottom, or both.

Tip For more information about using the Windows Forms knob, gauge, meter, slide, 
tank, or thermometer controls, refer to the Knob, Gauge, Meter, Slide, Tank, or 
Thermometer Class sections in the NI Measurement Studio Help.

Numeric Edit Control
Use the Measurement Studio numeric edit control, as shown in Figure 2-6, 
to display numeric values and to provide a way by which end users can edit 
numeric values. Typically, you use a numeric edit control to input or display 
double numerical data instead of using a Windows Forms TextBox or 
NumericUpDown control.

Figure 2-6.  Windows Forms Numeric Edit Control

With the numeric edit control and the classes that interface with the control 
you can perform the following operations:

• Use up/down buttons for easy incrementing and decrementing.



Chapter 2 Measurement Studio .NET Class Libraries

Measurement Studio User Manual 2-26 ni.com

• Perform range checking.

• Set the minimum range value to negative infinity and the maximum 
range value to positive infinity.

• Create custom formats or use built-in numeric formats including 
generic, engineering, and simple double.

• Connect to a Measurement Studio numeric control so that if you 
change the value of one control, it changes the value of the other 
control.

• Set the coercion mode property to discrete or continuous values. This 
property configures the control to allow entry or display of either a 
discrete set of values or any value.

• Set the interaction mode to keyboard and mouse, keyboard only, 
mouse only, or none.

Tip For more information about using the Windows Forms numeric edit control, refer to 
the NumericEdit Class section in the NI Measurement Studio Help.

Switch and LED Controls
Use the Measurement Studio switch and LED controls as Boolean controls 
on a Windows Forms user interface. You typically use a switch control, as 
shown in Figure 2-7, to receive and control Boolean input on an application 
user interface.

Figure 2-7.  Windows Forms Switch Control in Vertical Toggle 3D Style

You typically use an LED control, as shown in Figure 2-8, to indicate a 
Boolean value on an application user interface.

Figure 2-8.  Windows Forms LED Control in Square 3D Style
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With the switch and LED controls and the classes that interface with the 
controls, you can perform the following operations:

• Receive notification before or after the state of the control changes.

• Configure how the control behaves when you click it with the mouse 
or press the spacebar when the control has focus.

• Configure the appearance of the control.

• Make the control background transparent.

• Configure the LED control to blink while it is on or off and configure 
the rate at which the LED control blinks.

Tip For more information about using the switch and LED controls, refer to the Using 
the Measurement Studio Windows Forms Switch and LED .NET Controls section in the 
NI Measurement Studio Help.

Property Editor Control
Use the Measurement Studio property editor control, as shown in 
Figure 2-9, to configure properties for Windows Forms controls at run time.

Figure 2-9.  Windows Forms Property Editor Control for the Windows Forms Knob 
Control Scale Arc Property
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With the property editor control and the classes that interface with the 
control, you can perform the following operations:

• Edit any .NET type at run time, including collections.

• Edit expandable properties that represent nested properties of another 
object, such as major divisions of an axis.

• Create custom editors and type converters for properties.

• Connect to a Windows Forms control so that if you change the value 
of a property of the control, the property editor will update to reflect 
the change.

• Configure the display mode as a visual representation of the value, 
text-only, or both.

• Set the interaction mode to edit values or indicator.

Tip For more information about using the property editor control, refer to the Using the 
Measurement Studio Windows Forms Property Editor Control topic in the NI Measurement 
Studio Help.

Measurement Studio Support for Visual Studio 2005 
Class Library Overview

Measurement Studio support for Visual Studio 2005 includes all of the 
features and functionality described in the Measurement Studio Support for 
Visual Studio .NET 2003 Class Library Overview section as well as the 
following additional user interface features and functionality:

• Windows Forms array controls

• ASP.NET Web Forms controls

Windows Forms Array Controls
You can create an array of Measurement Studio controls that behave as a 
single unit. For example, you can use these array controls to visualize and 
control ports of a digital line or values of an array. Measurement Studio 
includes switch, LED, and numeric edit array controls. You can create 
control arrays of other controls if those controls meet the constraints of the 
generic type parameter TControl.
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Switch and LED Array Controls
Use the Measurement Studio switch and LED array controls as an array of 
Boolean controls on a Windows Forms user interface. You typically use a 
switch array control, as shown in Figure 2-10, to control ports of a digital 
line or values of an array. You typically use an LED array control, also 
shown in Figure 2-10, to visualize ports of a digital line or values of an 
array.

Figure 2-10.  Windows Forms Switch and LED Array Controls

With the switch and LED array controls and the classes that interface with 
the controls, you can perform the following operations:

• Set values by passing an array of data.

• Modify the number of controls displayed based on the length of the 
specified values.

• Receive notification before or after the state of the control changes.

• Configure how the control behaves when you click it with the mouse 
or press the spacebar when the control has focus.

• Configure the appearance of the control.

• Make the control background transparent.

• Configure the LED controls to blink while they are on or off and 
configure the rate at which the LED controls blink.

Tip For more information about using the switch and LED array controls, refer to the 
Using the Measurement Studio Windows Forms Control Array .NET Controls topic in the 
NI Measurement Studio Help.
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Numeric Edit Array Control
Use the Measurement Studio numeric edit array control, as shown in 
Figure 2-11, to control and visualize values of an array of double values.

Figure 2-11.  Numeric Edit Array control

With the numeric edit array control and the classes that interface with the 
control you can perform the following operations:

• Set values by passing an array of data.

• Modify the number of controls displayed based on the length of the 
array of values you specify.

• Use up/down buttons for easy incrementing and decrementing.

• Perform range checking.

• Set the minimum range value to negative infinity and the maximum 
range value to positive infinity.

• Create custom formats or use built-in numeric formats including 
generic, engineering, and simple double.

• Connect to a numeric control so that if you change the value of one 
control, it changes the value of the other control.

• Set the coercion mode property to discrete or continuous values. This 
property configures the control to allow entry or display of either a 
discrete set of values or any value.

• Set the interaction mode to keyboard and mouse, keyboard only, 
mouse only, or none.

• Use the edit box to select text programmatically and to validate text 
values.

Tip For more information about using the numeric edit array control, refer to the Using 
the Measurement Studio Windows Forms Control Array .NET Controls topic in the 
NI Measurement Studio Help.
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ASP.NET Web Forms Controls
The Measurement Studio ASP.NET user interface controls are in the Web 
Forms .NET class library. The Web Forms .NET class library is in the 
NationalInstruments.UI.WebForms namespace. The Web Forms 
class library encapsulates the following Measurement Studio user interface 
controls:

• Waveform graph

• Scatter graph

• Digital waveform graph

• Complex graph

• Legend

• Knob

• Gauge

• Meter

• Slide

• Thermometer

• Tank

• Numeric edit

• Switch

• LED

• AutoRefresh

Use this class library to add measurement-specific user interface controls 
to your Web application. You can configure the controls programmatically 
at design time or through the Properties window in the Web Forms 
Designer. 

The Measurement Studio ASP.NET Web Forms controls are designed to 
provide a rich user interface experience through the web browser. The 
browsers are divided into two broad categories: uplevel and downlevel. 
Uplevel browsers include recent versions of Microsoft Internet Explorer 
and Mozilla Firefox. All other browsers are downlevel browsers.

The following sections describe each of the Measurement Studio Web 
Forms user interface controls.
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Waveform Graph and Scatter Graph Controls
Use the Measurement Studio waveform graph and scatter graph controls, as 
shown in Figure 2-12, to display two-dimensional data on a Web-based 
user interface. Use the waveform graph to display two-dimensional linear 
data. You explicitly specify each value in one dimension and provide an 
initial value and interval to implicitly specify the values in the other 
dimension. Use the scatter graph to display two-dimensional linear or 
nonlinear data. You explicitly specify each value in both dimensions.

Figure 2-12.  Web Forms Waveform Graph and Scatter Graph Controls; 
Both Graphs Have Corresponding Legends

With the waveform graph and scatter graph controls and the classes that 
interface with the controls, you can perform the following operations:

Plot Operations
• Plot and chart data.

• Configure a graph to contain multiple plots to show separate but 
related data on the same graph.

• Draw lines or fills from a plot to an X value, Y value, or another plot.
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• Specify plots in the scatter graph control as X and Y data. Specify plots 
in the waveform graph control as X or Y data and optionally with date 
and time scaling.

• Use the extensible plot and plot area drawing capabilities and events to 
customize the graph appearance.

• Create custom point and line styles for plots.

• Specify anti-aliased plots for plot lines.

Axis Operations
• Configure a graph to include multiple axes or independent ranges so 

that plot data fits the graph plot area.

• Configure the axis modes to fixed, exact autoscaling, loose 
autoscaling, strip chart, or scope chart.

• Use logarithmic axes with configurable bases.

• Interactively change the range of an axis and invert the axis at run time 
by clicking on the axis end labels.

Cursor Operations
• Use cursors to identify key points in plots and the plot area.

• Configure cursor snap modes to be floating, nearest point, or to plot.

• Use cursor labels to display X and Y data coordinates that the cursor 
crosshair points to, and customize the text font and colors of the label.

• Create custom point and line styles for cursors.

Annotation Operations
• Configure text labels, arrows, and drawing shapes to annotate a point 

anywhere in the plot area of the graph.

• Configure range area, text labels, and arrows to annotate a range in the 
plot area of the graph.

Additional Operations
• Zoom interactively.

• Specify the image format of the control as BMP, GIF, JPEG, or PNG.

• Configure major, minor, and custom divisions and origin lines.
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Tip For more information about using the waveform and scatter graph controls, refer to 
the Using the Measurement Studio Web Forms Scatter and Waveform Graph .NET Controls 
section in the NI Measurement Studio Help.

Digital Waveform Graph Control
Use the Measurement Studio digital waveform graph control, as shown in 
Figure 2-13, to display DigitalWaveform data in an ASP.NET Web 
application.

Figure 2-13.  Web Forms Digital Graph Control

With the digital waveform graph control and the classes that interface with 
the control, you can perform the following operations:

Plot Operations
• Plot digital waveform data, including digital signal state data and 

timing information.
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• Configure plot labels on the y-axis.

• Configure plot templates to customize plots that are implicitly created 
from plotted data.

• Specify anti-aliased digital plots.

• Expand and collapse signal plots interactively.

Waveform Sample and Signal State Operations
• Simultaneously display waveforms and signals or display signals only.

• Create custom waveform sample and signal state styles.

• Configure waveform sample and signal state labels.

• Create custom waveform sample and signal state labels.

Axis Operations
• Configure the axis modes to fixed, exact autoscaling, or loose 

autoscaling.

• Interactively change the range of an axis and invert the axis at run time 
by clicking on the axis end labels.

Additional Operations
• Display data in sample or time mode.

• Configure the style and mode of scroll bars.

• Create custom scroll bars.

• Zoom interactively.

• Specify the image format of the control as BMP, GIF, JPEG, or PNG.

• Configure major, minor, and custom divisions.

Tip For more information about using the digital waveform graph control, refer to the 
Using the Measurement Studio Web Forms Digital Waveform Graph .NET Control section 
in the NI Measurement Studio Help.

Complex Graph Control
Use the Measurement Studio complex graph control, as shown in 
Figure 2-14, to display ComplexDouble data on a ASP.NET Web 
application. A ComplexDouble consists of a real part and an imaginary 
part.
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Figure 2-14.  Web Forms Complex Graph Control

With the complex graph control and the classes that interface with the 
control, you can perform the following operations:

Plot Operations
• Plot and chart ComplexDouble data.

• Configure a graph to contain multiple plots to show separate but 
related data on the same graph.

• Draw lines or fills from a plot to an X value, Y value, or another plot.

• Use the extensible plot and plot area drawing capabilities and events to 
customize the graph appearance.

• Configure the plot to display arrows. The arrows indicate the direction 
of the complex data.

• Create custom point and line styles for plots.

• Specify anti-aliased plots for plot lines.

Axis Operations
• Configure a graph to include multiple axes or independent ranges so 

that plot data fits the graph plot area.

• Configure the axis modes to fixed, exact autoscaling, loose 
autoscaling, strip chart, or scope chart.
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• Interactively change the range of an axis and invert the axis at run time 
by clicking on the axis end labels.

Additional Operations
• Zoom interactively.

• Specify the image format of the control as BMP, GIF, JPEG, or PNG.

• Configure major, minor, and custom divisions and origin lines.

Tip For more information about using the complex graph control, refer to the Using 
the Measurement Studio Web Forms Complex Graph .NET Control section in the 
NI Measurement Studio Help.

Legend Control
Use the Measurement Studio legend control, as shown in Figure 2-12, to 
display symbols and descriptions for a specific set of elements of another 
object, such as the plots or cursors of a graph. When you associate the 
legend control with another object, any changes you make to that object are 
automatically reflected in the legend. For example, if you associate the 
legend control with the plots of a graph, any changes you make in the plots 
collection editor are automatically reflected in the legend.

Tip For more information about using the legend control, refer to the Using the 
Measurement Studio Web Forms Legend .NET Control section in the NI Measurement 
Studio Help.

Numeric Controls
Use the Measurement Studio numeric controls to display numerical 
information, in an ASP.NET Web application, with the look of scientific 
instruments. The numeric controls include a knob, gauge, meter, slide, 
thermometer, and tank. The following sections describe operations 
available with the controls and the classes that interface with them.

With all of the numeric controls and the classes that interface with them, 
you can perform the following operations:

• Configure the scale to be linear or logarithmic and toggle the visibility 
of the scale.

• Fill the scale and configure the range, color, dimensions, and style of 
the fill.
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• Connect to a Measurement Studio .NET numeric edit control so that if 
you change the value of one control, it changes the value of the other 
control.

• Customize the appearance of the control using 3D lab styles or classic 
2D styles and change the color and length of ticks and labels.

• Configure the format of value labels to engineering or date/time.

• Specify the image format of the control as BMP, GIF, JPEG, or PNG.

• Interactively change the range of an axis and invert the axis at run time 
by clicking on the axis end labels.

Use the Measurement Studio knob, gauge, and meter controls, as shown in 
Figure 2-15, to input and display numeric data on your user interface.

Figure 2-15.  Web Forms Knob, Gauge, and Meter Controls

With the knob, gauge, and meter controls and the classes that interface with 
the controls, you can perform the following operations:

• Specify the start and sweep angle of the arc programmatically or from 
the Properties window.

• Use automatic division spacing, custom divisions, and invert the scale.
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Use the Measurement Studio slide, tank, and thermometer controls, as 
shown in Figure 2-16, to input and display numeric data on your interface.

Figure 2-16.  Web Forms Slide, Tank, and Thermometer Controls

With the slide, tank, and thermometer controls and the classes that interface 
with them, you can perform the following operations:

• Fill to the minimum or maximum value of the scale.

• Position the scale horizontally with left, right, or both and position the 
scale vertically with top, bottom, or both.

Tip For more information about using the Web Forms knob, gauge, meter, slide, tank, or 
thermometer controls, refer to the Knob, Gauge, Meter, Slide, Tank, or Thermometer Class 
sections in the NI Measurement Studio Help.
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Numeric Edit Control
Use the Measurement Studio numeric edit control, as shown in Figure 2-17, 
to display numeric values and to provide a way by which end users can edit 
numeric values. Typically, you use a numeric edit control to input or display 
double numerical data instead of using a Web Forms TextBox control.

Figure 2-17.  Web Forms Numeric Edit Control

With the numeric edit control and the classes that interface with the control 
you can perform the following operations:

• Perform range checking.

• Set the minimum range value to negative infinity and the maximum 
range value to positive infinity.

• Create custom formats or use built-in numeric formats including 
generic, engineering, and simple double.

• Connect to a Measurement Studio numeric control so that if you 
change the value of one control, it changes the value of the other 
control.

• Set the coercion mode property to discrete or continuous values. This 
property configures the control to allow entry or display of either a 
discrete set of values or any value.

• Validate and format data without posting back to the Web server.

Tip For more information about using the Web Forms numeric edit control, refer to the 
NumericEdit Class section in the NI Measurement Studio Help.
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Switch and LED Controls
Use the Measurement Studio switch and LED controls as Boolean controls 
in an ASP.NET Web application. You typically use a switch control to 
receive and control Boolean input in an ASP.NET Web application. You 
typically use an LED control to indicate a Boolean value in an ASP.NET 
Web application. The switch and LED controls are shown in Figure 2-18.

Figure 2-18.  Web Forms Switch Control in Vertical Toggle 3D Style and Web Forms 
LED Control in Square 3D Style

With the switch and LED controls and the classes that interface with the 
controls, you can perform the following operations:

• Receive notification before or after the state of the control changes.

• Specify the image format of the control as BMP, GIF, JPEG, or PNG.

Tip For more information about using the switch and LED controls, refer to the Using 
the Measurement Studio Web Forms Switch and LED .NET Controls section in the 
NI Measurement Studio Help.

AutoRefresh Control
Use the AutoRefresh control to update a Web control or a group of Web 
controls on the client at a specified interval.

The AutoRefresh control renders JavaScript on the client to create a timer 
in the browser. When the timer elapses, the AutoRefresh updates the 
controls in the AutoRefresh group. For downlevel browsers, the controls 
update via postback.For uplevel browsers, the client-side script rendered by 
the AutoRefresh control uses a client callback to update the associated 
controls on the client without posting the page back to the server.
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3
Measurement Studio Visual C++ 
Class Libraries

This chapter provides overview information about the Visual C++ class 
libraries that are available with Measurement Studio. Measurement Studio 
Visual C++ support for Visual Studio .NET 2003 and Visual Studio 2005 
is the same, except where noted. Refer to the Using the Measurement 
Studio Visual C++ Class Libraries section of the NI Measurement Studio 
Help for detailed information about these libraries.

Measurement Studio Visual C++ Class Library Overview
Measurement Studio provides libraries of MFC-based classes that you can 
use to develop complete measurement and automation applications in 
Visual C++.

Measurement Studio includes the following Visual C++ class libraries:

• 3D Graph

• Analysis

• Common

• DataSocket

• Instrument Drivers

• LabVIEW Real-Time Interface1

• Microsoft Excel Interface

• Microsoft Word Interface

• NI-488.2

• NI-DAQmx

• NI-Reports

1   The Measurement Studio LabVIEW Real-Time C++ class library is not supported in Visual Studio 2005. You must use Visual 
Studio 6.0 or Visual Studio .NET 2003 to use the Measurement Studio LabVIEW Real-Time C++ class library. The LabVIEW 
RT DLLs you create with the Measurement Studio LabVIEW RT Interface Visual C++ class library work only with LabVIEW 
Real-Time Module 6.0 or later.
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• NI-VISA

• User Interface

• Utility

Refer to the following sections for information about each Measurement 
Studio Visual C++ class library.

ActiveX Controls in Visual C++
ActiveX controls are specialized COM servers that implement a specific set 
of interfaces. The Measurement Studio Visual C++ button, graph, knob, 
numeric edit, slide, and 3D graph are ActiveX controls. Measurement 
Studio includes classes that provide native C++ interfaces to the ActiveX 
controls. For example, the CNiGraph class provides an interface to the 
CWGraph ActiveX graph control.

The Measurement Studio classes that provide interfaces to the 
Measurement Studio ActiveX controls simplify using ActiveX controls in 
Visual C++ interfaces and programs. The features that simplify this process 
include overloaded functions, the ability to call the control from any thread, 
and automatic data type translations.

3D Graph Control
Use the Measurement Studio ActiveX 3D graph control, as shown in 
Figure 3-1, to plot three-dimensional data. The 3D graph is included only 
in the Measurement Studio Enterprise and Professional packages.

Figure 3-1.  ActiveX 3D Graph Control
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With the Measurement Studio ActiveX 3D graph control and the classes 
that interface with the control, you can perform the following operations:

Plot Operations
• Plot three-dimensional data, including curves and surfaces.

• Use multiple plot styles—point-line, line-point, hidden-line, contour, 
surface, surface-line, surface-contour, and surface-normal.

• Create multiple plots with individual properties, such as name, line and 
point style, width, and base value.

• Configure the control to render directly to OpenGL-enabled hardware 
accelerator cards.

• Bind the control to a DataSocket Server to enable automatic read and 
write functionality.

Additional Operations
• Configure the axes using customizable ticks, labels, value pairs, and 

captions.

• Use legends and plane projections.

• Use cartesian, cylindrical, and spherical coordinate systems.

• Customize the control using color maps, transparency, and lighting.

• Display in orthographic and perspective views.

• Use built-in format styles for labels including scientific, symbolic 
engineering, scaling, time, and date.

• Rotate, pan, and zoom interactively.

Tip For information about easily creating graphs with the 3D graph control library, refer 
to the 3D Graph Visual C++ Class Library Overview topic in the NI Measurement Studio 
Help.

Analysis
The Analysis class library includes a set of classes that provides various 
digital signal processing, signal filtering, signal generation, peak detection, 
and other general mathematical functionality. Use this library to analyze 
acquired data or to generate data.

The functionality included in the Analysis library varies based on the 
Measurement Studio package you purchased. Refer to the following 
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sections for information about the Standard, Professional, and Enterprise 
Analysis class libraries.

Standard Analysis
The Standard Analysis class library, which ships with Measurement Studio 
Standard Edition, includes the sawtooth, sine, square, triangle, and basic 
function wave generators.

Professional Analysis
The Professional Analysis class library, which ships with Measurement 
Studio Professional Edition, includes the Standard Analysis functionality 
as well as the following functionality:

• Bessel, Chebyshev, Inverse Chebyshev, Windowed, Kaiser, and 
Elliptic Low, High, Bandpass, and Bandstop filters

• Signal processing functions such as convolution, deconvolution, 
correlation, decimation, integration, and differentiation

• FFT, Inverse FFT, Real FFT, Fast Hartley, Inverse Fast Hartley, Fast 
Hilbert, Inverse Fast Hilbert, DST, Inverse DST, DCT, and Inverse 
DCT transformations

• Linear algebra functions such as determinant, check positive 
definiteness, calculate dot product, and other various matrix methods

• Scaled and unscaled windowing classes

• Common statistical functions such as mean, median, mode, and 
variance

• Exponential, linear, and polynomial curve fitting functions

• Signal generation functions

Enterprise Analysis
The Enterprise Analysis class library, which ships with Measurement 
Studio Enterprise Edition, includes the Standard and Professional Analysis 
functionality as well as the following advanced functionality:

• EquiRipple filters

• Linear algebra functions such as forward and back substitution, 
LU factorization, Cholesky factorization, Schur decomposition, and 
Hessenberg decomposition

• Probability and analysis of variance

• Sinc, impulse, pulse, ramp, and chirp patterns
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• General least squares fit, power fit, log fit, Gauss Fit, cubic spline fit, 
and interpolation functions

• Special functions

Refer to Table 3-1 to determine the type of measurements available in the 
Professional and Enterprise Analysis Visual C++ libraries.

Table 3-1.  Analysis Visual C++ Library Measurement Types included in the 
Professional and Enterprise Packages

Analysis Visual C++ Library Professional Package Enterprise Package

Measurements

AC and DC Estimator ✔

Amplitude and Phase 
Spectrum

✔

Auto Power Spectrum ✔

Cross Power Spectrum ✔

Harmonic Analyzer ✔

Impulse Response Function ✔ ✔

Network Functions (avg) ✔ ✔

Power and Frequency Estimate ✔

Scaled Time Domain Window ✔

Spectrum Unit Conversion ✔

Transfer Function ✔

Signal Generation

Arbitrary Wave ✔ ✔

Chirp Pattern ✔ ✔

Gaussian White Noise ✔ ✔

Impulse Pattern ✔

Pulse Pattern ✔

Ramp Pattern ✔

Sawtooth Wave ✔
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Sinc Pattern ✔

Sine Pattern ✔

Sine Wave ✔ ✔

Square Wave ✔ ✔

Triangle Wave ✔ ✔

Uniform White Noise ✔ ✔

Windowing

Blackman Window ✔ ✔

Blackman-Harris Window ✔ ✔

Blackman-Nuttall Window ✔ ✔

Cosine Tapered Window ✔ ✔

Dolph-Chebyshev Window ✔ ✔

Exact Blackman Window ✔ ✔

Exponential Window ✔ ✔

Flat Top Window ✔ ✔

Force Window ✔ ✔

Gauss Window ✔ ✔

General Cosine Window ✔ ✔

Hamming Window ✔ ✔

Hanning Window ✔ ✔

Kaiser Window ✔ ✔

Scaled Time Domain Windows ✔ ✔

Symmetric Time Domain 
Windows

✔ ✔

Triangle Window ✔ ✔

Table 3-1.  Analysis Visual C++ Library Measurement Types included in the 
Professional and Enterprise Packages (Continued)

Analysis Visual C++ Library Professional Package Enterprise Package
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Filters

Bessel ✔ ✔

Butterworth ✔ ✔

Cascade ✔ ✔

Chebyshev ✔ ✔

Elliptic ✔ ✔

Equiripple ✔

FIR ✔ ✔

FIR Windowed ✔ ✔

IIR Cascade ✔ ✔

IIR ✔ ✔

Inverse Chebyshev ✔ ✔

Kaiser ✔ ✔

Signal Processing

Autocorrelation ✔ ✔

Convolution ✔ ✔

Cross Power ✔ ✔

Cross Correlation ✔ ✔

Decimate ✔ ✔

Deconvolution ✔ ✔

Derivative x(t) ✔ ✔

Discrete Cosine Transform ✔ ✔

Discrete Sine Transform ✔ ✔

Fast Hilbert Transform ✔ ✔

Fast Hartley Transform ✔ ✔

Table 3-1.  Analysis Visual C++ Library Measurement Types included in the 
Professional and Enterprise Packages (Continued)

Analysis Visual C++ Library Professional Package Enterprise Package
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Integral x(t) ✔ ✔

Inverse Real and Complex Fast 
Fourier Transform (FFT)

✔ ✔

Inverse Fast Hilbert Transform ✔ ✔

Inverse Fast Hartley Transform ✔ ✔

Peak Detection ✔ ✔

Power Spectrum ✔ ✔

Pulse Parameters ✔ ✔

Real and Complex FFT ✔ ✔

Threshold Peak Detector ✔ ✔

Unwrap Phase ✔ ✔

Linear Algebra

Back Transform Eigenvectors ✔

Backward Substitution ✔

Cholesky Factorization ✔

Complex Back Transform 
Eigenvectors

✔

Complex Cholesky 
Factorization

✔

Complex Determinant ✔ ✔

Complex Dot Product ✔ ✔

Complex Eigenvectors and 
Eigenvalues

✔

Complex General Eigen AB ✔

Complex Hessenberg 
Decomposition

✔

Complex Inverse Matrix ✔

Table 3-1.  Analysis Visual C++ Library Measurement Types included in the 
Professional and Enterprise Packages (Continued)

Analysis Visual C++ Library Professional Package Enterprise Package
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Complex Linear Equations ✔

Complex LU Factorization ✔

Complex Matrix Balance ✔

Complex Matrix Condition 
Number

✔ ✔

Complex Matrix Norm ✔ ✔

Complex Matrix Rank ✔ ✔

Complex Outer Product ✔ ✔

Complex Pseudo Inverse 
Matrix

✔ ✔

Complex QR Factorization ✔

Complex QR Factorization 
with Pivot Matrix

✔

Complex QR Factorization 
with Pivot Vector

✔

Complex QZ Decomposition ✔

Complex Schur 
Decomposition

✔

Complex Solve Linear 
Equations (Multiple Right 
Hand)

✔

Complex Solve Linear 
Equations (Single Right Hand)

✔

Complex SVD Factorization ✔

Complex Vector Norm ✔

Determinant ✔ ✔

Dot Product ✔ ✔

Forward Substitution ✔

Table 3-1.  Analysis Visual C++ Library Measurement Types included in the 
Professional and Enterprise Packages (Continued)

Analysis Visual C++ Library Professional Package Enterprise Package



Chapter 3 Measurement Studio Visual C++ Class Libraries

Measurement Studio User Manual 3-10 ni.com

General Eigen AB ✔

Hessenberg Decomposition ✔

Inverse Matrix ✔ ✔

Linear Equations ✔

LU Factorization ✔

Matrix Balance ✔

Matrix Condition Number ✔ ✔

Matrix Multiplication ✔ ✔

Matrix Norm ✔ ✔

Matrix Rank ✔ ✔

Outer Product ✔ ✔

Pseudo Inverse Matrix ✔ ✔

QR Factorization ✔

QR Factorization with Pivot 
Matrix

✔

QR Factorization with Pivot 
Vector

✔

QZ Decomposition ✔

Schur Decomposition ✔

Solve Linear Equations 
(Multiple Right Hand)

✔

Solve Linear Equations 
(Single Right Hand)

✔

Special Matrix ✔ ✔

SVD Factorization ✔

Test Positive Definite Matrix ✔ ✔

Trace ✔ ✔

Table 3-1.  Analysis Visual C++ Library Measurement Types included in the 
Professional and Enterprise Packages (Continued)

Analysis Visual C++ Library Professional Package Enterprise Package
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Transpose ✔ ✔

Array and Numeric Operations

1D and 2D Array Arithmetic ✔ ✔

1D and 2D Linear Evaluation ✔ ✔

1D and 2D Polynomial 
Evaluation

✔ ✔

1D Polar to Rectangular ✔ ✔

1D Rectangular to Polar ✔ ✔

Complex Number Arithmetic ✔ ✔

Find Polynomial Roots ✔ ✔

Scale 1D and 2D ✔ ✔

Curve Fitting

Cubic Spline Fit ✔

Exponential Fit ✔ ✔

Exponential Fit Interval ✔

Gauss Fit ✔

Gauss Fit Interval ✔

General Least Squares Fit ✔

Goodness of Fit ✔

Linear Fit ✔ ✔

Linear Fit Interval ✔

Logarithm Fit ✔

Logarithm Fit Interval ✔

Nonlinear Fit ✔

Polynomial Fit ✔ ✔

Table 3-1.  Analysis Visual C++ Library Measurement Types included in the 
Professional and Enterprise Packages (Continued)

Analysis Visual C++ Library Professional Package Enterprise Package
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Power Fit ✔

Power Fit Interval ✔

Remove Outliers ✔

Statistics

1D, 2D, and 3D ANOVA ✔

Chi-Square Distribution ✔

erf(x) and erfc(x) ✔

F-Distribution ✔

Histogram ✔ ✔

Inverse Chi-Square 
Distribution

✔

Inverse F-Distribution ✔

Inverse Normal Distribution ✔

Inverse T-Distribution ✔

Mean ✔ ✔

Median and Mode ✔ ✔

Moment about Mean ✔ ✔

Normal Distribution ✔

Polynomial Interpolation ✔

RMS ✔ ✔

Spline Interpolant ✔

Spline Interpolation ✔

Standard Deviation ✔ ✔

T-Distribution ✔

Variance ✔

Table 3-1.  Analysis Visual C++ Library Measurement Types included in the 
Professional and Enterprise Packages (Continued)

Analysis Visual C++ Library Professional Package Enterprise Package
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Special Functions

Airy ✔

Bessel 1st ✔

Bessel 2nd ✔

Beta ✔

Complimentary Gamma ✔

Cosine Integral ✔

Dawson’s Integral ✔

Dilogarithm ✔

Elliptic 1st ✔

Elliptic 2nd ✔

Exponential Integral ✔

Factorial ✔

Fresnel Integrals ✔

Gamma ✔

Gauss HyperGeometric ✔

Hyperbolic Cosine Integral ✔

Hyperbolic Sine Integral ✔

Incomplete Beta ✔

Incomplete Elliptic 1st ✔

Incomplete Elliptic 2nd ✔

Incomplete Gamma ✔

Jacobian Elliptic Function ✔

Kelvin 1st ✔

Kelvin 2nd ✔

Table 3-1.  Analysis Visual C++ Library Measurement Types included in the 
Professional and Enterprise Packages (Continued)

Analysis Visual C++ Library Professional Package Enterprise Package
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Tip For more information about analyzing or generating data with the Analysis 
class library, refer to the Analysis Visual C++ Class Library Overview topic in the 
NI Measurement Studio Help. For more information about the functionality included in the 
Analysis class library, visit ni.com/analysis and select Analysis in Measurement 
Studio.

Common
The Measurement Studio Common Visual C++ class library provides data 
types and classes that other Measurement Studio Visual C++ class libraries 
use. The classes that are implemented natively in Visual C++ include the 
CNiVector and CNiMatrix classes.

The Common class library includes the following data types:

• CNiScalarVector—Implements a vector object that contains scalar 
numbers.

Kummer ✔

Logarithm of Factorial ✔

Modified Bessel 1st ✔

Modified Bessel 2nd ✔

Parabolic Cylinder ✔

Psi ✔

Sine Integral ✔

Spherical Bessel 1st ✔

Spherical Bessel 2nd ✔

Stirling ✔

Struve ✔

Tricomi ✔

Zeta ✔

Table 3-1.  Analysis Visual C++ Library Measurement Types included in the 
Professional and Enterprise Packages (Continued)

Analysis Visual C++ Library Professional Package Enterprise Package
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• CNiScalarMatrix—Implements a matrix object that contains scalar 
numbers.

• CNiString—Extends the MFC CString class with streaming 
operators for a variety of data types and with various other string 
manipulation functions.

• CNiScalarVector—Implements a vector object that contains scalar 
numbers.

• CNiVariant—Extends the MFC COleVariant class with additional 
constructors and assignment operators for CNiComplex-, CNiVector-, 
and CNiMatrix-derived objects and with cast operators to convert 
CNiVariant objects to a variety of other object types.

• CNiException—Extends the MFC CException class and serves as 
the base class for many Measurement Studio exceptions.

• CNiRegKey—Encapsulates the interface to the Windows registry. Use 
this class and related classes to open and create keys, get keys, and get 
values associated with those keys.

Tip For more detailed information about the Common class library, refer to the Common 
Visual C++ Class Library Overview topic in the NI Measurement Studio Help.

DataSocket
Use the Measurement Studio DataSocket Visual C++ class library to 
transfer live measurement data over the Internet or an intranet, between 
applications on the same computer, and to and from files. Use the classes 
in the DataSocket Visual C++ class library to perform the following 
operations:

• Read and write data between different data sources and targets.

• Use a single, simple API to communicate with several types of servers, 
including DataSocket Servers (dstp:), Web servers (http:), file 
transfer protocol servers (ftp:), file systems (file:), and OLE for 
Process Control (opc:) servers.

• Specify data sources and targets using a URL, the same way you access 
Web pages in a Web browser.

• Use DataSocket Transfer Protocol (DSTP) to exchange different types 
of data.

• Interactively browse to quickly locate and select data items on other 
computers and servers.
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Tip For more information about using DataSocket, refer to the DataSocket Visual C++ 
Class Library Overview topic in the NI Measurement Studio Help.

Instrument Drivers
Measurement Studio includes a set of class libraries that provides Visual 
C++ classes that you can use to program instruments, such as digital 
multimeters and oscilloscopes. These Visual C++ classes provide Visual 
C++ interfaces to ANSI C DLL-based Interchangeable Virtual Instrument 
(IVI) class drivers. Each Measurement Studio instrument driver class 
library includes a set of Visual C++ classes that interfaces to a single IVI 
driver. The Measurement Studio Visual C++ classes provide enhancements 
to the ANSI C interface, such as automatic data type translation and 
organization of properties and methods into a logical hierarchy. Each class 
driver provides a consistent interface to a particular type of device. 
Measurement Studio includes the following class driver class libraries:

• IviDcPwr—Provides an interface to the IVI DC power supply class 
driver. CNiIviDcPwr is the top-level class of this class library.

• IviDmm—Provides an interface to the IVI DMM class driver. 
CNiIviDmm is the top-level class of this class library.

• IviFgen—Provides an interface to the IVI arbitrary waveform 
generator class driver. CNiIviFgen is the top-level class of this class 
library.

• IviScope—Provides an interface to the IVI oscilloscope class driver. 
CNiIviScope is the top-level class of this class library.

• IviSwitch—Provides an interface to the IVI switch class driver. 
CNiIviSwtch is the top-level class of this class library.

LabVIEW Real-Time Interface
Use the Measurement Studio LabVIEW Real-Time Interface Visual C++ 
class library to read from and write to shared memory on a LabVIEW 
Real-Time Series processor board. Use shared memory to pass data 
between LabVIEW Real-Time VIs and your application. Use this class 
library both from an application that runs on the host machine and from a 
DLL that you download to the board.

Note The Measurement Studio LabVIEW Real-Time C++ class library is not supported 
in Visual Studio 2005. You must use Visual Studio .NET 2003 to use the Measurement 
Studio LabVIEW Real-Time Visual C++ class library. The LabVIEW Real-Time DLLs 
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you create with the Measurement Studio LabVIEW RT Interface Visual C++ class library 
work only with LabVIEW Real-Time Module 6.0 or later.

Tip For more information about using the LabVIEW Real-Time Module, refer to the 
LabVIEW Real-Time Interface Visual C++ Class Library Overview topic in the 
NI Measurement Studio Help. For more information about the LabVIEW Real-Time 
Module, visit ni.com/labviewrealtime.

Microsoft Excel Interface
Use the Measurement Studio Excel Visual C++ class library to 
automatically create Excel spreadsheets and charts from within 
measurement and automation applications. Use the Microsoft Excel 
Interface class library to perform offline processing of the measurement 
and automation data you acquire and analyze using other Measurement 
Studio Visual C++ classes. This class library is included only in the 
Measurement Studio Enterprise package.

Tip For more information about using the Measurement Studio Excel Visual C++ 
class library to create applications that present data in Microsoft Excel format, refer to 
the Microsoft Excel Interface Visual C++ Class Library Overview topic in the 
NI Measurement Studio Help.

Microsoft Word Interface
Use the Measurement Studio Microsoft Word Interface Visual C++ class 
library to automatically create Word documents from within measurement 
and automation applications. Use the Microsoft Word Interface class 
library to perform offline processing of the measurement and automation 
data you acquire and analyze using other Measurement Studio Visual C++ 
classes. This class library is included only in the Measurement Studio 
Enterprise package.

Tip For more information about using the Measurement Studio Word Visual C++ class 
library to create applications that present data in Microsoft Word, refer to the Microsoft 
Word Interface Visual C++ Class Library Overview topic in the NI Measurement Studio 
Help.
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NI-488.2
Use the Measurement Studio NI-488.2 Visual C++ class library to 
communicate with and control instruments on a GPIB interface. This class 
library is included when you install the NI-488.2 driver. Use this class 
library to configure and communicate with GPIB devices using the Device 
and Board classes.

You can use the NI-488.2 class library to create programs that interface 
with a device that is using GPIB and/or programs that interface with the 
GPIB device directly.

Tip For information about using the NI-488.2 Visual C++ class library, refer to the 
NI-488.2/GPIB Visual C++ Class Library Overview topic in the NI Measurement Studio 
Help. For more information about GPIB, visit ni.com/gpib.

NI-DAQmx
Use the Measurement Studio NI-DAQmx Visual C++ class library to 
communicate with and control an NI data acquisition (DAQ) device. This 
class library is included when you install the NI-DAQmx driver.

Note Some DAQ devices are not currently supported by the NI-DAQmx driver. Refer to 
the NI-DAQ Readme for a complete listing of supported hardware.

Use the NI-DAQmx class library to perform the following types of tasks:

• Analog signal measurement

• Analog signal generation

• Digital I/O

• Counting and timing

• Pulse generation

• Signal switching

Tip For information about easily creating an NI-DAQmx application using the DAQ 
Assistant, refer to the Creating a Measurement Studio NI-DAQmx Application section of 
Chapter 4, Measurement Studio Integrated Tools and Features or the Walkthrough: 
Creating a Measurement Studio NI-DAQmx Application in Visual Studio .NET 2003 and 
Walkthrough: Creating a Measurement Studio NI-DAQmx Application in Visual Studio 
2005 sections of Chapter 5, Getting Started with Measurement Studio. For more 
information about DAQ, visit ni.com/daq.
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NI-Reports
Use the Measurement Studio NI-Reports Visual C++ class library to 
generate printed reports from Measurement Studio Visual C++ 
applications. This class library is included only in the Measurement Studio 
Enterprise package.

Tip For information about generating printed reports using the NI-Reports class library, 
refer to the NI-Reports Visual C++ Class Library Overview topic in the NI Measurement 
Studio Help.

NI-VISA
The Measurement Studio NI-VISA Visual C++ class library includes 
Visual C++ classes that provide an object-oriented interface to the 
NI-VISA driver. This class library is included when you install the 
NI-VISA driver. Use the NI-VISA class library to quickly create 
bus-independent and/or bus-specific instrument control applications.

The NI-VISA class library supports I/O operations, locking, event 
handling, and interface-specific extensions. With this class library, you can 
access the functionality available in NI-VISA for communicating with 
message-based and register-based instruments using the following 
interfaces:

• GPIB

• PXI

• Serial (RS-232 and RS-485)

• TCP/IP

• USB

• VXI

Tip For information about easily creating a Measurement Studio NI-VISA application 
using the Instrument I/O Assistant, refer to the Creating a Measurement Studio Instrument 
Control Application section of Chapter 4, Measurement Studio Integrated Tools and 
Features or the Walkthrough: Creating a Measurement Studio Instrument I/O Application 
in Visual Studio .NET 2003 and Walkthrough: Creating a Measurement Studio Instrument 
I/O Application in Visual Studio 2005 sections of Chapter 5, Getting Started with 
Measurement Studio. For more information about NI-VISA, visit ni.com/visa.
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User Interface
Use the Measurement Studio User Interface Visual C++ class library to add 
user interface controls to your application. You can configure the user 
interface controls programmatically or through the property pages in the 
Visual C++ resource editor. Measurement Studio includes the following 
Visual C++ user interface controls:

• Button

• Graph

• Knob

• Numeric edit

• Slide

The following sections describe each of the Measurement Studio Visual 
C++ user interface controls.

Button Control
Use the Measurement Studio ActiveX button control, as shown in 
Figure 3-2, for different Boolean displays, such as on/off or true/false. 
Typically, you use buttons to input or display Boolean information or 
initiate an action in a program. The CNiButton class provides the Visual 
C++ interface to the ActiveX button control.

Figure 3-2.  ActiveX Button Control

With the button control and the classes that interface with the control, you 
can perform the following operations:

• Configure how the control behaves when you click it with the mouse 
or press the spacebar when the control has focus.

• Configure how the button control appears using button styles. You can 
configure the button control to appear as a push button, LED, or 
switch.
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• Bind properties to a DataSocket source or target. You use binding to 
read property values from a source and write property values to a 
target.

Tip For more information about easily using the button control, refer to the Using the 
Measurement Studio Button Visual C++ Control section in the NI Measurement Studio 
Help.

Graph Control
Use the Measurement Studio ActiveX graph control, as shown in 
Figure 3-3, to plot and chart two-dimensional data. The CNiGraph class 
provides the Visual C++ interface to the ActiveX graph control.

Figure 3-3.  ActiveX Graph Control

With the graph control and the classes that interface with the control, you 
can perform the following operations:

Plot Operations
• Plot and chart data.

• Configure a graph to contain multiple plots to show separate but 
related data on the same graph.

• Configure a graph to include multiple Y axes so that plot data fits the 
graph plot area.

• Use cursors and annotations to identify key points in plots and the plot 
area.
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Axis Operations
• Use the CNiAxis class to interface to a single axis of a graph control. 

This feature allows you to modify the appearance and behavior of the 
axis.

• Automatically label axes with log or inverted numeric scales.

• Configure the axis modes for manual scaling or autoscaling.

Additional Operations
• Configure cursor snap modes to be fixed, floating, nearest point, and 

to plot.

• Pan and zoom interactively.

• Configure the graph for fixed, strip, or scope charting.

• Customize the graph by using ticks, labels, and value pairs.

• Bind properties to a DataSocket source or target. You use binding to 
read property values from a source and write property values to a 
target.

Tip For more information about easily using the graph control, refer to the Using the 
Measurement Studio Graph Visual C++ Control section in the NI Measurement Studio 
Help.

Knob Control
Use the Measurement Studio ActiveX knob control, as shown in 
Figure 3-4, to display numerical information. The CNiKnob class provides 
the Visual C++ interface to the ActiveX knob control.
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Figure 3-4.  ActiveX Knob Control with Knob, Dial, and Meter Styles

With the knob control and the classes that interface with the control, you 
can perform the following operations:

• Use different display styles—knobs, dials, and meters.

• Use multiple control pointers, each representing one scalar value. A 
control pointer indicates the current value of the knob.

• Use the CNiAxis class to interface to a single axis of a knob control. 
This feature allows you to modify the appearance and behavior of the 
axis.

• Automatically label axes with log or inverted numeric scales and 
continuous or discrete values.

• Customize the knob by using ticks, labels, and value pairs.

• Bind properties to a DataSocket source or target. You use binding to 
read property values from a source and write property values to a 
target.

Tip For more information about easily using the knob control, refer to the Using the 
Measurement Studio Knob Visual C++ Control section in the NI Measurement Studio 
Help.

Numeric Edit Control
Use the Measurement Studio ActiveX numeric edit control, as shown in 
Figure 3-5, to display numeric values and provide a way by which end users 
can edit numeric values. Typically, you use a numeric edit control to input 
or display numerical data instead of using a text box. The CNiNumEdit 
class provides the Visual C++ interface to the ActiveX numeric edit control.



Chapter 3 Measurement Studio Visual C++ Class Libraries

Measurement Studio User Manual 3-24 ni.com

Figure 3-5.  ActiveX Numeric Edit Control

With the numeric edit control and the classes that interface with the control, 
you can perform the following operations:

• Use built-in numeric format styles, including scientific, symbolic 
engineering, scaling, time, and date.

• Perform range checking.

• Bind properties to a DataSocket source or target. You use binding to 
read property values from a source and write property values to a 
target.

Tip For more information about easily using the numeric edit control, refer to the Using 
the Measurement Studio Numeric Edit Visual C++ Control section in the NI Measurement 
Studio Help.

Slide Control
Use the Measurement Studio ActiveX slide control, as shown in Figure 3-6, 
to display numerical data. CNiSlide is the class that provides the Visual 
C++ interface to the ActiveX slide control.

Figure 3-6.  ActiveX Slide Control
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With the slide control and the classes that interface with the control, you 
can perform the following operations:

• Use different display styles—vertical, horizontal, tank, and 
thermometer.

• Use the CNiAxis class to interface to a single axis of a slide control. 
This ability allows you to modify the appearance and behavior of the 
axis.

• Use multiple control pointers, each one representing one scalar value.

• Automatically label axes with log or inverted numeric scales and 
continuous or discrete values.

• Customize the slide by using ticks, labels, and value pairs.

• Bind properties to a DataSocket source or target. You use binding to 
read property values from a source and write property values to a 
target.

Tip For more information about easily using the slide control, refer to the Using the 
Measurement Studio Slide Visual C++ Control section in the NI Measurement Studio Help.

Utility
Use the Measurement Studio Utility Visual C++ class library to easily 
access Windows operating system functionality. Table 3-2 lists classes in 
the Utility class library and their functionality.

Table 3-2.  Utility Class Names and Functionalities

Utility Class Functionality

CNiFile CNiFile extends the MFC CStdioFile class by adding 
streaming operators for standard Visual C++ data types. 
In addition, a variety of class static functions add the 
ability to manipulate file, path, directory, and drive 
attributes.

CNiSound CNiSound encapsulates an interface for generating 
synchronous and asynchronous tones at specific 
frequencies.
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Tip For more information about using the Utility class library, refer to the Utility Visual 
C++ Class Library Overview section in the NI Measurement Studio Help.

CNiSystem CNiSystem provides the following functionality:

• Getting and setting system preferences

• Displaying help files

• Getting input for the keyboard

CNiSystemTrayIcon CNiSystemTrayIcon encapsulates the interface to the 
system tray area that displays changes in the status of an 
application. The CNiSystemTrayIcon class includes 
the following features:

• Icons—You can place an icon in the system tray to 
notify the user of changes in an application status.

• String tooltips—You can associate a string tooltip with 
an icon and display the tooltip when the user hovers 
over the icon.

• Shortcut menus—You can associate a shortcut menu 
with an icon and display the shortcut menu when the 
user right-clicks the icon.

• Overridable event handling.

CNiTempFile CNiTempFile extends the functionality of CNiFile to 
add temporary file creation and manipulation.

CNiTimer CNiTimer objects use the Windows multimedia timer to 
generate high-resolution, asynchronous tick events. 
Respond to tick events when you want to perform an 
action at a discrete interval. Additionally, you can count 
the tick events to calculate elapsed time. The CNiTimer 
class also contains static functions you can use to delay 
for a period of time or to determine elapsed time between 
two points in your program.

Table 3-2.  Utility Class Names and Functionalities (Continued)

Utility Class Functionality
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4
Measurement Studio Integrated 
Tools and Features

When you use Measurement Studio in the Visual Studio environment, you 
have access to measurement and automation tools and features for .NET 
Windows, ASP.NET, and MFC. These integrated tools and features are 
designed to help you quickly and easily build measurement and automation 
applications. These integrated tools are included in support for both Visual 
Studio .NET 2003 and Visual Studio 2005.

This chapter includes the following sections to help you develop 
applications with Measurement Studio:

• Measurement Studio Menu

• Creating a Measurement Studio Project

• Creating a Measurement Studio NI-DAQmx Application

• Creating a Measurement Studio Instrument Control Application

• Adding or Removing Measurement Studio Class Libraries

• Selecting a Measurement Studio Parameter Value

• Calling Instrument Drivers from .NET Languages

Refer to the Developing with Measurement Studio section in the NI 
Measurement Studio Help for more information about the functionality of 
these tools and features.

Measurement Studio Menu
The Measurement Studio menu provides an easy way to access the 
following National Instruments resources and tools:

• Parameter Assistant—Use the Measurement Studio Parameter 
Assistant to discover and insert valid parameter values for various 
Measurement Studio class libraries, such as NI-DAQmx, NI-488.2, 
and NI-VISA methods. The Parameter Assistant is available only if 
you have Measurement Studio class libraries installed that use 
parameter values.
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• Add/Remove Class Libraries Wizard—Use the Measurement 
Studio Add/Remove Class Libraries wizard to add or remove 
Measurement Studio class libraries or assemblies in existing Visual 
Basic .NET, Visual C#, or Visual C++ projects. Select Measurement 
Studio»View .NET Class Library Wizard to access this menu item 
in Visual Studio 2005.

• Project Conversion Wizard—Use the Project Conversion wizard to 
convert Measurement Studio 1.0 and 6.0 Visual C++ projects to the 
current version installed on your machine. This menu item is available 
only in Visual Studio .NET 2003.

• National Instruments Tools»Measurement & Automation 
Explorer (MAX)—Use MAX to configure NI hardware; add new 
channels, interfaces, and tasks; execute system diagnostics; and view 
devices and instruments connected to the system. Select NI Tools»
Measurement & Automation Explorer (MAX) to access this menu 
item in Visual Studio 2005. The MAX menu option is available only if 
you have MAX installed.

• National Instruments Tools»NI Spy—Use NI Spy to monitor, 
record, and display National Instruments API calls made by instrument 
connectivity applications. Use NI Spy to quickly locate and analyze 
any erroneous National Instruments API calls that an application 
makes and verify that the communication with an instrument is correct. 
Select NI Tools»NI Spy to access this menu item in Visual Studio 
2005. The NI Spy menu item is available only if you have NI Spy 
installed.

• Discussion Forums—Use NI Discussion Forums at forums.ni.com 
to participate in discussion forums and exchange code with 
measurement and automation developers around the world. Select 
Measurement Studio Online Resources»Discussion Forums to 
access this menu item in Visual Studio 2005.

• Instrument Driver Network—Use the NI Instrument Driver Network 
at ni.com/idnet as a central resource for downloading, developing, 
and submitting instrument drivers. Select Measurement Studio 
Online Resources»Instrument Driver Network to access this menu 
item in Visual Studio 2005.

• Search Technical Support—Use NI Technical Support at 
ni.com/support to find support resources available for most 
products, including software drivers and updates, KnowledgeBase 
articles, product manuals, step-by-step troubleshooting wizards, 
conformity documentation, example code, tutorials and application 
notes, instrument drivers, discussion forums, and a measurement 
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glossary. Select Measurement Studio Online Resources»Search 
Technical Support to access this menu item in Visual Studio 2005.

• NI Measurement Studio Help—Use the NI Measurement Studio 
Help to access detailed Measurement Studio help, including function 
reference, walkthroughs, and conceptual topic documentation on 
developing with Measurement Studio.

• Additional Online Resources»Measurement Studio Home 
Page—Use the Measurement Studio Web site at ni.com/mstudio to 
find Measurement Studio news, support, downloads, and evaluation 
software. Select Measurement Studio Online Resources»
Measurement Studio Home Page to access this menu item in Visual 
Studio 2005.

• Additional Online Resources»Measurement Encyclopedia—Use 
the online NI Measurement Encyclopedia to find information on 
measurement principles, standards organizations, and a wide range of 
technology and measurement terms. Select Measurement Studio 
Online Resources»Measurement Encyclopedia to access this menu 
item in Visual Studio 2005.

• Preferences—Use the Measurement Studio Preferences dialog box to 
configure Measurement Studio settings, such as conversion options 
and add-in preferences. Select Tools»Options to access this menu item 
in Visual Studio 2005.

• Patents—Use the Patents dialog box to view information about 
NI patents.

• Licenses—Use the Licenses dialog box to view information about 
NI licenses.

• About NI Measurement Studio—Use the NI Measurement Studio 
About box to view version information.

Tip For more information about the resources included in the Measurement Studio menu, 
refer to the Measurement Studio Menu topic in the NI Measurement Studio Help.

Creating a Measurement Studio Project
Measurement Studio includes class library and application templates that 
you can use to quickly create measurement applications with Visual Basic 
.NET, Visual C#, ASP.NET, and Visual C++. Refer to the following 
sections, Walkthrough: Creating an Application with Windows Forms 
Controls and Analysis or Walkthrough: Creating an Application with Web 
Forms Controls and Analysis, for step-by-step instructions on how to create 
a Measurement Studio project. Use the Visual Studio New Project dialog 
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box, as shown in Figure 4-1, to access these templates and to create 
projects. You can create the following projects in Measurement Studio:

• Measurement Studio Visual Basic .NET project

• Measurement Studio Visual C# project

• Measurement Studio ASP.NET project

• Measurement Studio Visual C++ project

• Measurement Studio Visual C++ project with LabWindows/CVI 
libraries

Figure 4-1.  New Project dialog box in Visual Studio 2005

Tip For more information about using project templates to create a new Measurement 
Studio project, refer to the Creating a New Measurement Studio Project section in the 
NI Measurement Studio Help.

Note For information about converting Measurement Studio projects, refer to the 
Converting Measurement Studio Projects section in the NI Measurement Studio Help.
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Adding or Removing Measurement Studio Class 
Libraries

To add or remove Measurement Studio class libraries from a project, use 
the Measurement Studio Add/Remove Class Libraries wizard on the 
Measurement Studio menu. This wizard provides an interface, as shown in 
Figure 4-2, that you can use to select the Measurement Studio class 
libraries you want to add to or remove from a project.

When you exit the wizard, the wizard adds or removes the appropriate 
references to or from the project, thus adding or removing the functionality 
associated with the class library.

Figure 4-2.  Measurement Studio Add/Remove Class Libraries Wizard 
for Visual Studio 2005

Tip For more information about using the Add/Remove Class Libraries wizard to add or 
remove Measurement Studio class libraries, refer to the Adding or Removing Measurement 
Studio Class Libraries section in the NI Measurement Studio Help.
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Creating a Measurement Studio NI-DAQmx Application
To create a Measurement Studio NI-DAQmx application, use the DAQ 
Assistant. The DAQ Assistant integrates into Visual Studio as a code 
designer. Use the Add New Item wizard to add an NI-DAQmx task to your 
project, and use the DAQ Assistant user interface, as shown in Figure 4-3, 
to interactively create and configure the NI-DAQmx task. The DAQ 
Assistant automatically generates a Visual Basic .NET, Visual C#, or 
Visual C++ class that includes the functionality you configure in the user 
interface.

For step-by-step instructions on how to create DAQ applications, refer to 
the Walkthrough: Creating a Measurement Studio NI-DAQmx Application 
in Visual Studio .NET 2003 and Walkthrough: Creating a Measurement 
Studio NI-DAQmx Application in Visual Studio 2005 sections in Chapter 5, 
Getting Started with Measurement Studio.
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Figure 4-3.  DAQ Assistant

The DAQ Assistant interactively assists you in performing the following 
operations:

• Creating an NI-DAQmx task class

• Configuring an NI-DAQmx task class

• Generating a Visual Basic .NET, Visual C#, or Visual C++ class that 
includes the functionality you configure in the user interface

• Generating code that uses an NI-DAQmx task class

• Using an NI-DAQmx task class in a project
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• Generating a .NET DAQ component that uses the task to provide 
appropriate operations for your measurement type. The DAQ 
component is available in Visual Studio 2005 only.

Tip For more information about using the DAQ Assistant to create a Measurement Studio 
NI-DAQmx application, refer to the Creating a Measurement Studio DAQ Application 
section in the NI Measurement Studio Help.

Creating an NI-DAQmx User Control in Visual Studio .NET 2003
You can create an NI-DAQmx .NET user control with Measurement Studio 
that provides a default graphical user interface to an NI-DAQmx task. 
The NI-DAQmx User Control wizard wraps a configured NI-DAQmx task 
class in a user-friendly control. You can drop the generated user control 
from the Visual Studio Toolbox onto a form and use it just as you use any 
Windows Forms control. The NI-DAQmx user control is available only in 
Visual Studio .NET 2003.

Tip For more information on how to create a user control, refer to the Using a DAQmx 
Task Class in a Project topic in the NI Measurement Studio Help.

Creating an NI-DAQmx User Interface in Visual Studio 2005
Using the Configure DAQ Component UI wizard, as shown in Figure 4-4, 
you can customize and preview a user interface and code for your task. The 
wizard also generates event handlers and code to acquire data and present 
it on your generated user interface. The Configure DAQ Component UI 
wizard is available only in Visual Studio 2005.
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Figure 4-4.  Configure DAQ Component UI wizard

Tip For more information on how to create an NI-DAQmx user interface, refer to the 
Using a .NET DAQ Component in a Project topic in the NI Measurement Studio Help.

Creating NI-DAQmx User Code in Visual C++
You can create NI-DAQmx user code in Visual C++. The DAQmx User 
Code wizard wraps the configured DAQmx task class in a user-friendly 
class and creates a dialog that provides an example of using the new class.

You can use the user code in two different ways. You can call the DoModal 
function on the new dialog class, or you can use the user-friendly wrapper 
class directly in your code by calling the class programmatically.

To use the user code directly, create an instance of the DAQmx user code 
class and call the appropriate function in your source code. You can create 
an instance of the user code directly in source code, just as you create an 
instance of any class directly in source code. Declare a variable of the 
appropriate type and use it directly. The .h file for the user-friendly 
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wrapper for the DAQmx task class contains additional information on using 
the user code. 

Tip For more information on how to create user code, refer to the Using a DAQmx Task 
Class in a Project topic in the NI Measurement Studio Help.

Creating a Measurement Studio Instrument Control 
Application

To create a Measurement Studio instrument control application, use the 
Instrument I/O Assistant. The Instrument I/O Assistant for Visual Studio 
2005, as shown in Figure 4-5, integrates into Visual Studio as a code 
designer. Use the Add New Item wizard to add an instrumentation task to 
your project, and use the Instrument I/O Assistant user interface to create 
and configure the instrumentation task. The Instrument I/O Assistant 
generates a Visual Basic .NET, Visual C#, or Visual C++ class that includes 
the functionality you configure in the user interface. Use this assistant to 
help you write code that communicates with devices such as serial, 
Ethernet, or GPIB instruments.

For step-by-step instructions on how to use the Instrument I/O Assistant, 
refer to the Walkthrough: Creating a Measurement Studio Instrument I/O 
Application in Visual Studio .NET 2003 and Walkthrough: Creating a 
Measurement Studio Instrument I/O Application in Visual Studio 2005 
sections of Chapter 5, Getting Started with Measurement Studio.
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Figure 4-5.  Instrument I/O Assistant

The Instrument I/O Assistant aids you in performing the following 
operations:

• Creating an instrumentation task class

• Configuring an instrumentation task class to communicate with an 
instrument and parse data you receive from the instrument

Tip For more information about using the Instrument I/O Assistant to create a 
Measurement Studio instrument control application, refer to the Creating a Measurement 
Studio Instrument Control Application section of the NI Measurement Studio Help.
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Selecting a Measurement Studio Parameter Value
To access I/O devices or resources, you must specify string constants or 
scalar values for many method parameters and property values. Use the 
Measurement Studio Parameter Assistant, on the Measurement Studio 
menu, to discover and insert into your code valid parameter values for 
methods and various Measurement Studio class libraries, such as 
NI-DAQmx, NI-488.2, and NI-VISA.

With the Parameter Assistant, you can select the correct parameter value for 
a device or resource, as shown in Figure 4-6, based on your current system 
configuration. Click the Insert Selected Item button on the Parameter 
Assistant to insert the value into the current location in the active source 
file.

Figure 4-6.  Measurement Studio Parameter Assistant

Tip For information about using the Measurement Studio Parameter Assistant to select a 
parameter value, refer to the Selecting a Measurement Studio Parameter Value section in 
the NI Measurement Studio Help.

Calling Instrument Drivers from .NET Languages
To use an IVI or VXI plug&play instrument driver with a C DLL in a 
Measurement Studio .NET application, use the Measurement Studio .NET 
Instrument Driver wizard to create .NET entry points to the C DLL 
functions you need to call from your application. Use the Add New Item 
wizard to select the .NET Instrument Driver Wizard.
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The Measurement Studio .NET Instrument Driver wizard, as shown in 
Figure 4-7, generates a .NET wrapper class for calling into IVI, VXI 
plug&play, and legacy instrument drivers based on the instrument driver 
function panel, header file, and an optional .sub file for IVI drivers. The 
wizard can generate both Visual C# and Visual Basic .NET source code. 
After completing the wizard, a new instrument driver wrapper class is 
added to your project and opened in the source code editor.

Figure 4-7.  Launching the Measurement Studio .NET Instrument Driver Wizard from 
the Add New Item Wizard

Tip For information about the .NET instrument driver wizard, refer to the Using 
Instrument Drivers in Measurement Studio Applications section in the NI Measurement 
Studio Help.
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5
Getting Started with 
Measurement Studio

The following sections include overview information and step-by-step 
instructions on developing applications with Measurement Studio tools and 
features. Refer to the Developing with Measurement Studio section and the 
Getting Started with the Measurement Studio Class Libraries section of the 
NI Measurement Studio Help for more information about the functionality 
of these tools and features.

Measurement Studio Walkthroughs for Visual 
Studio .NET 2003

Use the following walkthroughs to help you develop applications with 
Measurement Studio in Visual Studio .NET 2003:

• Walkthrough: Creating a Measurement Studio Application with 
Windows Forms Controls and Analysis in Visual Studio .NET 2003

• Walkthrough: Creating a Measurement Studio NI-DAQmx 
Application in Visual Studio .NET 2003

• Walkthrough: Creating a Measurement Studio Instrument I/O 
Application in Visual Studio .NET 2003
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Walkthrough: Creating a Measurement Studio 
Application with Windows Forms Controls and Analysis 
in Visual Studio .NET 2003

Measurement Studio includes user interface controls, such as a waveform 
graph control and a gauge control, and analysis functionality such as signal 
generation and mathematical functions. This walkthrough is designed to 
help you learn how to add analysis and presentation functionality to a 
Windows Forms application by taking you through the following steps:

• Setting up the project—Using the Measurement Studio Application 
Wizard, you will create a new project that references the Measurement 
Studio Analysis class library and Windows Forms controls.

• Adding user interface controls to the project—Using the Toolbox 
and the Properties window, you will add and configure user interface 
controls, including a button, waveform graph, legend, gauge, and 
numeric edit.

• Generating, plotting, and analyzing the data—Using 
NationalInstruments.Analysis.SignalGeneration.White

NoiseSignal and 
NationalInstruments.Analysis.Math.Statistics.Mean, 
you will generate data, plot the generated data on a waveform graph, 
and calculate the mean of the data.

• Customizing the user interface—Using the Collection Editor and 
Auto Format dialog boxes, you will display the mean value on the 
gauge and the numeric edit, as well as customize your user interface.

Before You Begin

The following components are required to complete this walkthrough:

• Microsoft Visual Studio .NET 2003

• Measurement Studio (Professional or Enterprise package)

Setting up the project

1. Select Start»All Programs»Microsoft Visual Studio .NET 2003»
Microsoft Visual Studio .NET 2003.
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2. Select File»New»Project. The New Project dialog box launches.

3. In the Project Types pane, expand the Measurement Studio Projects 
folder. Select Visual Basic Projects or Visual C# Projects, depending 
on which language you want to create the project in.

4. In the Templates pane, select Windows Application. Specify 
MyMeasurementStudioProject for Name and specify a Location 
of your choice.

5. Click OK. The Measurement Studio Application Wizard launches.
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6. Select Analysis and Windows Forms User Interface Controls.

Tip If you are working with an existing project, you can access the Add Class Libraries 
dialog box by selecting Measurement Studio»Add/Remove Class Libraries Wizard.

7. Click Finish to display Form1 in the Windows Forms Designer.
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Adding user interface controls to the project

In this section, you will build a user interface that looks like Form1 in the 
following screenshot.

1. Select View»Toolbox to display the Toolbox. The toolbox contains 
components and controls that you can add to your project.

2. Select the Windows Forms tab. The Windows Forms tab contains 
controls and components included in the System.Windows.Forms 
namespace.

3. Select the Button control and drag and drop it onto the form.

4. Right-click the button and select Properties to display the Properties 
window. You configure the properties of the control in the Properties 
window.

5. The Text property is highlighted. Type Start for the button text.

6. Select the Measurement Studio .NET Tools tab on the Toolbox.
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7. Select the WaveformGraph control and drag and drop it onto the 
form.

8. Right-click the waveform graph and select Edit Plots to display the 
WaveformPlot Collection Editor dialog box. You use the 
WaveformPlot Collection Editor to add or remove plots and to 
configure plot properties.
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9. Type Plot for the Name. Click OK.

10. Before you add the legend and gauge controls, you need to resize the 
form to accommodate them. Select the form and use the double-sided 
arrow to resize it.

11. Select the Legend control and drag and drop it onto the form.

12. Select the NumericEdit control and drag and drop it onto the form.

13. Select the Gauge control and drag and drop it onto the form.

14. Right-click the gauge and select Properties to display the Properties 
window.

15. Type gauge for the name of the gauge.
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The following screenshot shows Form1 with the user controls.

Generating, plotting, and analyzing the data

1. Double-click the button control to display the Form1 code, with the 
cursor inside the click event handler of the button control.

2. Add the following code to generate random data, plot the data, 
calculate the mean of the data, and display the mean on the gauge.

[VB.NET]

' Declare and initialize an instance of WhiteNoiseSignal.
Dim whiteNoise As New WhiteNoiseSignal()
' Store the generated data in a double array named data.
Dim data As Double() = whiteNoise.Generate(1000.0, 256)
' Use the PlotY method to plot the data.
Plot.PlotY(data)
' Use the Mean method to calculate the mean of the data.
Dim mean As Double = Statistics.Mean(data)
' Display the mean on the gauge.
gauge.Value = mean

[C#]

// Declare and initialize an instance of WhiteNoiseSignal.
WhiteNoiseSignal whiteNoise = new WhiteNoiseSignal();

    
// Store the generated data in a double array named data.
double[] data = whiteNoise.Generate(1000.0, 256);
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// Use the PlotY method to plot the data.
Plot.PlotY(data);

    
// Use the Mean method to calculate the mean of the data.
double mean = Statistics.Mean(data);

        
// Display the mean on the gauge.
gauge.Value = mean;

Customizing your user interface

1. Right-click the legend and select Edit Items to display the LegendItem 
Collection Editor dialog box. You use the LegendItem Collection 
Editor to add or remove legend items and to configure legend item 
properties.

2. Select Plot in the Source drop-down list and enter Signal in the Text 
box. Click OK. Now that you have specified a legend item for the plot, 
changes you make to the plot will be reflected on the legend.

3. Right-click the graph and select Auto Format to display the Auto 
Format dialog box. The Auto Format dialog box provides a set of 
pre-configured control styles. When you select a style and click OK, 
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the Auto Format feature configures the appropriate control properties 
to reflect the style you chose.

4. Select Points Only. Click OK. Notice that the legend changed 
automatically to match the formatting of the graph.

5. Right-click the gauge and select Auto Format to display the Auto 
Format dialog box.

6. Select Dark and click OK.

7. Right-click the gauge and select Properties to display the Properties 
Window.

8. Set the Range property for the gauge with the drop-down Range type 
editor. Type -0.2 for the minimum value and type 0.2 for the 
maximum value.

9. Right-click the numeric edit and select Properties to display the 
Properties window.

10. Select Gauge in the Source drop-down list. Setting the Source 
property to the gauge allows two-way binding between the controls.

11. Deselect ArrowKeys, Buttons, and Text for the InteractionMode 
property of the numeric edit control. Deselecting these interaction 
modes makes the numeric edit an indicator. The numeric edit control 
only displays the calculated mean.
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12. Select the Format Mode property and in the Numeric Edit Format 
Mode Editor dialog box, change the Precision to 4.

13. Select File»Save Form1.cs to save your application.

14. Select Debug»Start Without Debugging to run the application.

15. After your program builds and runs, click Start. Notice the graph 
shows the data plot, and the gauge and the numeric edit display the 
mean of the data.

The following screenshot shows Form1 with customization.

Walkthrough: Creating a Measurement Studio 
NI-DAQmx Application in Visual Studio .NET 2003

This walkthrough is designed to help you learn how to create an 
NI-DAQmx application by taking you through the following steps:

• Setting up the project—Using the Measurement Studio Application 
Wizard, you will create a new project that references the NI-DAQmx 
assembly and launches the DAQ Assistant to create an NI-DAQmx 
task.

• Configuring your task—Using the DAQ Assistant, you will 
interactively configure and save your task. The wizard then generates 
code to reflect your configuration settings.

• Creating a custom UI control and source code for the task—Using 
the Add New Item wizard, you will create a custom NI-DAQmx user 
control that uses the task you just configured to automatically plot the 
DAQ signal.
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• Acquiring data—To begin acquiring data from the DAQ device or 
simulated device, you will drop the custom UI control onto a form and 
run your application. The DAQ signal automatically begins plotting 
data onto your control.

Before You Begin

The following components are required to complete this walkthrough:

• Visual Studio .NET 2003

• Measurement Studio (Professional or Enterprise package)

• NI-DAQmx 7.4 or later

• NI-DAQmx-supported DAQ device or simulated device

For information about installing and configuring your DAQ device, refer to 
the DAQ Getting Started Guide. You can also use simulation to complete 
this walkthrough. For information on how to create an NI-DAQmx 
simulated device, refer to Creating NI-DAQmx Simulated Devices in the 
Measurement & Automation Explorer Help for NI-DAQmx. To open this 
help, select Start»All Programs»National Instruments»Measurement 
& Automation. In Measurement & Automation Explorer (MAX), select 
Help»Help Topics»NI-DAQmx»MAX Help for NI-DAQmx. For the 
purposes of this walkthrough, the NI PCI-6280 device of the M Series DAQ 
family is recommended.

To set up the project

1. Open Visual Studio from Start»All Programs»Microsoft Visual 
Studio .NET 2003»Microsoft Visual Studio .NET 2003.

2. Select File»New»Project. The New Project dialog box launches.

3. In the Project Types pane, expand the Measurement Studio Projects 
folder. Select Visual Basic Projects or Visual C# Projects, depending 
on which language you want to create the project in. Code generation 
works in both languages.
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4. In the Templates pane, select Windows Application. Specify 
MyDAQmxProject for Name and specify a Location of your choice. 
Click OK. The Measurement Studio Application Wizard launches.
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5. In the Add Class Libraries dialog box, ensure that DAQmx Library 
and Windows Forms User Interface Controls are selected. When 
you select these libraries, the Measurement Studio Application Wizard 
automatically adds references to the appropriate class libraries. Click 
Next.

Tip If you are working with an existing project, you can access the Add Class Libraries 
dialog box by selecting Measurement Studio»Add/Remove Class Libraries Wizard.
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6. In the Add Tasks dialog box, you can configure the Measurement 
Studio Application Wizard to add a task to your project using the DAQ 
Assistant. Select Launch the DAQmx Assistant to create a DAQmx 
task and specify MyDAQmxTask.mxb for the File Name. This file 
name is the name used for the class that is generated later in this 
walkthrough. For more information, click the Configuring a DAQmx 
Task Class link to access the help. Click Finish.

The Measurement Studio Application Wizard automatically sets up 
your data acquisition project and launches the DAQmx Task Wizard.
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7. In the New DAQmx Task dialog box, you can choose either to create a 
new task or copy a global task that was created in MAX. For more 
information, refer to Creating an NI-DAQmx Task from an Existing 
Task in MAX. For this walkthrough, select New Item and click Next.

Tip If you are working with an existing project, you can access the New DAQmx Task 
dialog box by selecting Project»Add New Item.

8. Review the information in the New DAQmx Task Summary dialog box 
and click Finish. The DAQ Assistant launches, starting with the Create 
New dialog box.
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To configure your task

1. In the Create New dialog box of the DAQ Assistant, you can begin to 
interactively define your DAQ task. Select Analog Input as the 
measurement type for your task.

2. Next, select Voltage.
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3. In the Supported Physical Channels tree, select the physical channel, 
such as ai1, on the DAQ device to which you connected the voltage 
signal. Click Finish.

Note You can also use simulation in this walkthrough. For more information, refer to 
Creating NI-DAQmx Simulated Devices in the Measurement & Automation Explorer Help 
for NI-DAQmx.

4. After the DAQ Assistant configuration window opens within the 
Visual Studio environment, select the MyDAQmxTask.mxb tab. If the 
embedded DAQ Assistant help is not open by default, click the Show 
Help button in the upper-right corner of the window to display the 
help.
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5. To complete the DAQ configuration, select the N Samples Acquisition 
Mode in the Task Timing tab.  For more information on timing, refer 
to Timing in the NI-DAQmx Help.

6. Next, click the Test button to launch the test panel for your task. The 
test runs automatically.  You can use test panels in the DAQ Assistant 
to test the task and make sure you connected the signal properly.  If 
necessary, you can modify the settings before any code is generated.

7. Click the Close button when you are done.
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8. Right-click the MyDAQmxTask.mxb tab and select Save 
MyDAQmxTask.mxb. Saving the .mxb file causes the DAQ Assistant 
to regenerate the class so that any changes you made are automatically 
reflected.

9. The class contains source code that corresponds to the configuration 
information that is stored in the .mxb file. To view this code, 
right-click the .mxb file in the Solution Explorer and select View 
Code. If the Solution Explorer is not open, select View»
Solution Explorer.

Notice that the call to ConfigureSampleClock has a sample mode set to 
finite. This mode is what you selected in the previous step 5. For more 
information on this step, refer to Generating Code for a DAQmx Task Class 
topic in the NI Measurement Studio Help.

Your NI-DAQmx task is now configured and ready to use in a project.
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To create a custom UI control and source code for the task

1. Select Project»Add New Item. The Add New Item dialog box 
launches.

2. In the Categories pane of the Add New Item dialog box, expand the 
Measurement Studio folder and select Assistants.

3. In the Templates pane, select DAQmx User Control. Specify 
MyDAQmxUserControl for Name and click Open.

4. In the Select DAQmx Task dialog box, select Project Task and then 
select MyDAQmxProject.MyDAQmxTask from the drop-down 
menu. This binds the NI-DAQmx user control with the task that you 
just created. A project task is used for classes that are created using the 
DAQ Assistant from Visual Studio. A global task is used for tasks that 
are created and saved in MAX. For more information, refer to Creating 
Tasks and Channels in the Measurement & Automation Explorer Help 
for NI-DAQmx. Click Next.
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5. Review the information in the New DAQmx Task Summary and click 
Finish.

Measurement Studio generates and adds a class named 
MyDAQmxUserControl to your project. A new user control is placed 
in the My User Controls tab of the Visual Studio toolbox and opened 
in the Windows Forms Designer. The user control is designed to be 
used either as a user interface element, or if a user interface is not 
needed, to be directly called from source code.

6. Right-click MyDAQmxUserControl.cs in the Solution Explorer and 
select View Code. Browse through the code that is opened in the 
MyDAQmxUserControl.cs tab.  Notice that, in addition to providing 
a custom UI for the task, the DAQ Assistant has generated all the 
source code needed to run your task, including the CreateTask, 
CleanupTask, and Read methods.

7. Select Build»Build Solution to build the solution so that the 
environment can recognize the control. This step is a requirement of 
user controls in Visual Studio.
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To acquire data

1. Select the Form1.cs[Design] tab so that you can place UI controls on 
the form.

2. In the Visual Studio Toolbox, select MyDAQmxUserControl from 
the My User Controls tab, and drag it to Form1.

Tip If you receive a user control error message when you drop the 
MyDAQmxUserControl on Form1, ensure that you have first compiled the project by 
selecting Build»Build Solution.

3. Press <F5> to run the application.
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4. After you have started the application, click the Read button to begin 
acquiring data from your DAQ device.

What’s Next

To learn more about tasks, channels, and other NI-DAQmx concepts, 
refer to the NI-DAQmx Help located at Start»All Programs»
National Instruments»NI-DAQ»NI-DAQmx Help.

For more information about creating and using tasks in Measurement 
Studio, refer to Using the Measurement Studio NI-DAQmx .NET Library 
section in the NI Measurement Studio Help. 

You can also look at examples that ship with NI-DAQmx. Refer to 
Measurement Studio NI-DAQmx .NET Examples in the NI Measurement 
Studio Help for the locations of these examples.

Walkthrough: Creating a Measurement Studio 
Instrument I/O Application in Visual Studio .NET 2003

The National Instruments Instrument I/O Assistant organizes instrument 
communication for a serial, Ethernet, or GPIB instrument into ordered 
steps. This walkthrough is designed to help you learn how to build an 
instrument I/O application by taking you through the following steps:

• Setting up the project—Using the Measurement Studio Application 
Wizard, you will create a new project that references the VisaNS 
assembly and launches the Instrument I/O Assistant to create a VisaNS 
task.



Chapter 5 Getting Started with Measurement Studio

© National Instruments Corporation 5-25 Measurement Studio User Manual

• Performing a query on the instrument—Using the Instrument I/O 
Assistant, you will write a command to an instrument and read the 
instrument response.

• Displaying Instrument I/O Assistant data on your UI—Using text 
box and button controls, you will create a Windows Forms application 
to display the Instrument I/O Assistant data.

Before You Begin

The following components are required to complete this walkthrough:

• Visual Studio .NET 2003

• Measurement Studio (Professional or Enterprise package)

• National Instruments Device Driver CD

• Message-based instrument on a supported VISA bus, such as GPIB or 
Serial

Note For more information about the Instrument I/O Assistant, refer to the NI Instrument 
I/O Assistant Help by selecting the Show Help button inside the assistant.

Setting up the project

1. Open Visual Studio from Start»All Programs»Microsoft Visual 
Studio .NET 2003»Microsoft Visual Studio .NET 2003.

2. Select File»New»Project. The New Project dialog box launches.
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3. In the Project Types pane, expand the Measurement Studio Projects 
folder. Select Visual Basic Projects or Visual C# Projects, depending 
on which language you want to create the project in. This walkthrough 
refers to Visual C#, but Visual Basic .NET users can follow the same 
process.

4. In the Templates pane, select Windows Application. Specify 
MyIIOAProject for Name and select a Location of your choice.
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5. Click OK. The Measurement Studio Application Wizard launches.

Tip If you are working with an existing project, you can access the Add Class Libraries 
dialog box by selecting Measurement Studio»Add/Remove Class Libraries Wizard.

6. In the Application Wizard dialog box, select Windows Forms User 
Interface Controls and VisaNS Library. The wizard automatically 
adds references to the appropriate class libraries and sets up the project 
for you.

7. Click Next.
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8. Select Launch the Instrument I/O Assistant to create a VisaNS 
Task. This option adds a new Instrument I/O Assistant task to your 
project. Each task consists of a collection of related instrument 
communication operations that you want your application to perform 
together. For more information, click the Configuring a VisaNS 
Instrumentation Task Class link to access the help.

 

Tip If you are working with an existing project, you can access the Add Tasks dialog box 
by selecting Project»Add New Item.

9. Click Finish. The Instrument I/O Assistant automatically launches.

Performing a query on the instrument

1. The Select Instrument step automatically appears in the Step 
Sequence window when you launch the Instrument I/O Assistant. 
Select the instrument you want to communicate with or the port your 
instrument is connected to from the Select an instrument drop-down 
listbox.
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2. Select Add Step and then select Query and Parse from the expanded 
list. You use a Query and Parse step to write a command to an 
instrument and to read the instrument response at once.

3. Enter the command *idn? and click Run this step. The *idn? 
command is a standard instrument command for querying an 
instrument’s identification information. If your instrument does not 
support the *idn? command, refer to the documentation for the 
instrument for more information about the instrument’s command set.

4. Click Auto parse to parse the instrument’s response. The Auto parse 
button automatically parses binary block data and ASCII text. Refer to 
the Parsing an Instrument Response topic in the Instrument I/O 
Assistant Help for information about how the assistant parses different 
data formats.

5. If there are more than two tokens in the token list, remove them for this 
example. To remove a token, right-click on the token in the Response 
Window and select Remove.
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6. Click Token. In the Token name text box, enter Vendor to rename the 
first token. You use this name to reference the token in your 
application.

7. Rename Token2 to Device.

8. Select File»Save to save your task.

9. Select View»Solution Explorer to display the Solution Explorer.

10. Click the Show All Files icon.

11. Double-click the VisaNSTask1.cs file to view the code that the 
Instrument I/O Assistant generated for you.

Displaying Instrument I/O Assistant data on your user interface

1. Double-click Form1.cs in the Solution Explorer to open your main 
application form.

2. Select View»Toolbox to display the Toolbox.

3. Select the WindowsForms tab on the Toolbox.
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4. Select the Button control and drag and drop it onto the form.

5. Select the TextBox control and drag and drop it onto the form. Repeat 
this step to add a second text box to the form. The following screenshot 
shows the controls on the form.

6. Double-click the Button control to display the Form1 code, with the 
cursor inside the click event handler of the button control.

7. Add the following code to display the vendor and model name of your 
instrument in the text boxes:

[VB.NET]

' Declare variable values for vendor and model
Dim vendor, model As String
' Declare an instance of VisaNSTask
Dim mytask As New VisaNSTask1()
' Display the data in the text boxes                   
mytask.Run(vendor, model)
textBox1.Text = vendor
textBox2.Text = model

[C#]

{
// Declare variable values for vendor and model
string vendor, model;
                
// Declare an instance of VisaNSTask
VisaNSTask1 mytask = new VisaNSTask1();
                
// Display the data in the text boxes                   
mytask.Run (out vendor, out model);
textBox1.Text = vendor;
textBox2.Text = model;                

}
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8. Press <F5> to build the application.

9. Click the button on the form to run the task. The following screenshot 
shows the controls on the form, with sample returned data.

Note Although this walkthrough only covers the use of a simple Query and Parse step, 
the Instrument I/O Assistant offers additional features, such as independent Write and 
Read and Parse steps and advanced parsing capabilities. The following screenshot shows 
the Instrument I/O Assistant’s ability to scale and parse IEEE long definite block data.



Chapter 5 Getting Started with Measurement Studio

© National Instruments Corporation 5-33 Measurement Studio User Manual

Measurement Studio Walkthroughs for 
Visual Studio 2005

Use the following walkthroughs to help you develop Measurement Studio 
applications in Visual Studio 2005:

• Walkthrough: Creating a Measurement Studio Application with 
Windows Forms Controls and Analysis in Visual Studio 2005

• Walkthrough: Creating a Measurement Studio Application with Web 
Forms Controls and Analysis in Visual Studio 2005



Chapter 5 Getting Started with Measurement Studio

Measurement Studio User Manual 5-34 ni.com

• Walkthrough: Creating a Measurement Studio NI-DAQmx 
Application in Visual Studio 2005

• Walkthrough: Creating a Measurement Studio Instrument I/O 
Application in Visual Studio 2005

Walkthrough: Creating a Measurement Studio 
Application with Windows Forms Controls and Analysis 
in Visual Studio 2005

Measurement Studio includes user interface controls, such as a waveform 
graph control and a gauge control, and analysis functionality such as signal 
generation and mathematical functions. This walkthrough is designed to 
help you learn how to add analysis and presentation functionality to a 
Windows Forms application by taking you through the following steps:

• Setting up the project—Using the Measurement Studio Application 
Wizard, you will create a new project that references the Measurement 
Studio Analysis class library and Windows Forms controls.

• Adding user interface controls to the project—Using the Toolbox, 
smart tags, and the Properties window, you will add and configure a 
button, waveform graph, legend, gauge, and numeric edit user 
interface control.

• Generating, plotting, and analyzing the data—Using 
NationalInstruments.Analysis.SignalGeneration.White

NoiseSignal and 
NationalInstruments.Analysis.Math.Statistics.Mean, 
you will generate data, plot the generated data on a waveform graph, 
and calculate the mean of the data.

• Customizing the user interface—Using smart tags and the Collection 
Editor and Auto Format dialog boxes, you will display the mean value 
on the gauge and the numeric edit, as well as customize your user 
interface.

Before You Begin

The following components are required to complete this walkthrough:

• Microsoft Visual Studio 2005

• Measurement Studio (Professional or Enterprise package)
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Setting up the project

1. Select Start»All Programs»Microsoft Visual Studio 2005»
Microsoft Visual Studio 2005.

2. Select File»New»Project. The New Project dialog box launches.

3. In the Project Types pane, select Measurement Studio under Visual 
C# or Visual Basic, depending on which language you want to create 
the project in.

4. In the Templates pane, select NI Windows Application. Specify 
MyMeasurementStudioProject for Name and specify a Location 
of your choice.

5. Click OK. The Measurement Studio Application Wizard launches.
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6. Select Analysis and Windows Forms User Interface Controls.

Tip If you are working with an existing project, you can access the Add/Remove Class 
Libraries dialog box by selecting Measurement Studio»View .NET Class Library 
Wizard.

7. Click Finish to display Form1 in the Windows Forms Designer.
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Adding user interface controls to the project

In this section, you will build a user interface that looks like Form1 in the 
following screenshot.

1. Select View»Toolbox to display the Toolbox. The toolbox contains 
components and controls that you can add to your project.

2. Expand the All Windows Forms group. The All Windows Forms 
group contains controls and components included in the 
System.Windows.Forms namespace.

3. Select the Button control and drag and drop it onto the form.

4. Right-click the button and select Properties to display the Properties 
window. You configure the properties of the control in the Properties 
window.

5. The Text property will be highlighted. Type Start for the button text.

6. Expand the Measurement Studio group in the Toolbox.
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7. Select the WaveformGraph control and drag and drop it onto the 
form.

8. Right-click the waveform graph and select Edit Plots to display 
the WaveformPlot Collection Editor dialog box. You use the 
WaveformPlot Collection Editor to add or remove plots and to 
configure plot properties.
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Note You can also access the WaveformPlot Collection Editor dialog box by clicking the 
waveform graph smart tag. You access the smart tag by right-clicking the arrow button in 
the upper right hand corner of the control.

9. Type Plot for the Name. Click OK.

10. Before you add the Measurement Studio legend, numeric edit, and 
gauge controls, you need to resize the form to accommodate them. 
Select the form and use the double-sided arrow to resize it.

11. Select the Legend control and drag and drop it onto the form.

12. Select the NumericEdit control and drag and drop it onto the form.

13. Select the Gauge control and drag and drop it onto the form.

14. Click the gauge smart tag to display the Gauge Tasks. You access the 
smart tag by right-clicking the arrow button in the upper right corner 
of the control.

15. Type gauge for the name of the gauge.
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The following screenshot shows Form1 with the user controls.
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Generating, plotting, and analyzing the data

1. Double-click the button control to display the Form1 code, with the 
cursor inside the click event handler of the button control.

2. Add the following code to generate random data, plot the data, 
calculate the mean of the data, and display the mean on the gauge.

[VB.NET]

' Declare and initialize an instance of WhiteNoiseSignal.
Dim whiteNoise As New WhiteNoiseSignal()
' Store the generated data in a double array named data.
Dim data As Double() = whiteNoise.Generate(1000.0, 256)
' Use the PlotY method to plot the data.
Plot.PlotY(data)
' Use the Mean method to calculate the mean of the data.
Dim mean As Double = Statistics.Mean(data)
' Display the mean on the gauge.
gauge.Value = mean

[C#]

// Declare and initialize an instance of WhiteNoiseSignal.
WhiteNoiseSignal whiteNoise = new WhiteNoiseSignal();

    
// Store the generated data in a double array named data.
double[] data = whiteNoise.Generate(1000.0, 256);

                
             

// Use the PlotY method to plot the data.
Plot.PlotY(data);

    
// Use the Mean method to calculate the mean of the data.
double mean = Statistics.Mean(data);

        
// Display the mean on the gauge.
gauge.Value = mean;
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Customizing your user interface

1. Right-click the legend and select Edit Items to display the LegendItem 
Collection Editor dialog box. You use the LegendItem Collection 
Editor to add or remove legend items and to configure legend item 
properties.

2. Select Plot in the Source drop-down list and enter Signal in the Text 
box. Click OK. Now that you have specified a legend item for the plot, 
changes you make to the plot are reflected on the legend.

3. Right-click the graph and select Auto Format to display the Auto 
Format dialog box. The Auto Format dialog box provides a set of 
pre-configured control styles. When you select a style and click OK, 
the Auto Format feature configures the appropriate control properties 
to reflect the style you chose.
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4. Select Points Only. Click OK. Notice that the legend changed 
automatically to match the formatting of the graph.

5. Click the gauge smart tag to display the Gauge Tasks.

6. Select Auto Format to display the Auto Format dialog box.

7. Select Dark and click OK.

8. Right-click the gauge and select Properties to display the Properties 
window.

9. Set the Range property for the gauge with the drop-down Range type 
editor. Type -0.2 for the minimum value and type 0.2 for the 
maximum value.

10. Click the numeric edit smart tag to display the Numeric Edit Tasks.

11. Select Gauge in the Source drop-down list. Setting the Source 
property to the gauge allows two-way binding between the controls.

12. Deselect ArrowKeys, Buttons, and Text for the InteractionMode 
property of the numeric edit control. Deselecting these interaction 
modes makes the numeric edit an indicator. The numeric edit control 
only displays the calculated mean.

13. Select the Format Mode property and in the Numeric Edit Format 
Mode Editor dialog box, change the Precision to 4 to show four 
decimal places of precision.

14. Select File»Save Form1.cs to save your application.
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15. Select Debug»Start Without Debugging to run the application.

16. After your program builds and runs, click Start. Notice the graph 
shows the data plot, and the gauge and the numeric edit display the 
mean of the data.

The following screenshot shows Form1 with customization.

Walkthrough: Creating a Measurement Studio 
Application with Web Forms Controls and Analysis in 
Visual Studio 2005

Measurement Studio includes user interface controls, such as a waveform 
graph control and a gauge control, and analysis functionality such as signal 
generation and mathematical functions. This walkthrough is designed to 
help you learn how to add analysis and presentation functionality to a Web 
Forms application by taking you through the following steps:

• Setting up the project—Using the Measurement Studio Application 
Wizard, you will create a new project that references the Measurement 
Studio Analysis class library and Web Forms controls.

• Adding user interface controls to the project—Using the Toolbox 
and the Properties window, you will add and configure a button, 
waveform graph, legend, gauge, and numeric edit user interface 
control.
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• Generating, plotting, and analyzing the data—Using 
NationalInstruments.Analysis.SignalGeneration.White

NoiseSignal and 
NationalInstruments.Analysis.Math.Statistics.Mean, 
you will generate data, plot the generated data on a waveform graph, 
and calculate the mean of the data.

• Customizing the user interface—Using the Collection Editor and 
Auto Format dialog boxes, you will display the mean value on the 
gauge and the numeric edit, as well as customize your user interface.

Before You Begin

The following components are required to complete this walkthrough:

• Microsoft Visual Studio 2005

• Measurement Studio (Professional or Enterprise package)

Setting up the project

1. Select Start»All Programs»Microsoft Visual Studio 2005»
Microsoft Visual Studio 2005.

2. Select File»New»Web Site. The New Web Site dialog box launches.
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3. In the Templates pane, select Measurement Studio ASP.NET Web 
Site. Select File System and specify a file path of your choice.

4. Use the drop-down box to select Visual C# or Visual Basic, depending 
on which language you want to create the project in.

5. Click OK. The Measurement Studio ASP.NET Web Site Wizard 
launches.

6. Select Analysis and Web Forms User Interface Controls.

Tip If you are working with an existing project, you can access the Measurement Studio 
ASP.NET Web Site Wizard dialog box by selecting Measurement Studio»View .NET 
Class Library Wizard.

7. Click Finish to display Default.aspx in the Web Forms Designer.

8. You can rename the title of your Web page. Click inside the <title> 
tag and rename the title to Measurement Studio Web Forms 
Controls and Analysis Walkthrough.
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Adding user interface controls to the project

In this section, you will build a Web page that looks like the following 
screenshot.

1. Select View»Toolbox to display the Toolbox. The toolbox contains 
components and controls that you can add to your project. 

2. Click Design to switch from Source View to Design View.

3. Select View»Toolbox to display the Toolbox. The toolbox contains 
components and controls that you can add to your project.

4. Expand the HTML group on the Toolbox. Select the Table control in 
the toolbox and drag and drop it onto the form. You use the table cells 
to arrange the user interface controls on your Web page, as shown in 
the previous screenshot.

5. Expand the Standard group on the Toolbox. The Standard group 
contains ASP.NET server controls included in the System.Web.UI 
namespace. 

6. Select the Button control in the toolbox and drag and drop it into a 
table cell.

7. Right-click the button and select Properties to display the Properties 
window. You configure the properties of the control in the Properties 
window.
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8. Scroll to the Text property in the Properties window. Type Start for 
the button text.

9. Select the Measurement Studio tab on the Toolbox.

10. Select the WaveformGraph control and drag and drop it into a table 
cell. 

11. On the waveform graph smart tag, type graph for the name of the 
waveform graph ID. 

Tip You access the smart tag by right-clicking the arrow button in the upper right corner 
of the control.

12. Select the Legend control and drag and drop it into a table cell.

13. Select the NumericEdit control and drag and drop it into a table cell.
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14. On the numeric edit smart tag, type numericedit for the Name of the 
numeric edit ID. 

15. Select the Gauge control and drag and drop it into a table cell.

16. On the gauge smart tag, type gauge for the Name of the gauge ID.
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The following screenshot shows the Web page with the user controls.

Generating, plotting, and analyzing the data

1. Double-click the button control to display the Default.aspx.cs 
code, with the cursor inside the click event handler of the button 
control.

2. Add the following code to generate random data, plot the data, 
calculate the mean of the data, and display the mean on the gauge.

[VB.NET]

' Declare and initialize an instance of WhiteNoiseSignal.
Dim whiteNoise As New WhiteNoiseSignal()
' Store the generated data in a double array named data.
Dim data As Double() = whiteNoise.Generate(1000.0, 256)
' Use the PlotY method to plot the data.
Plot.PlotY(data)
' Use the Mean method to calculate the mean of the data.
Dim mean As Double = Statistics.Mean(data)
' Display the mean on the gauge.
gauge.Value = mean

[C#]

// Declare and initialize an instance of WhiteNoiseSignal.
WhiteNoiseSignal whiteNoise = new WhiteNoiseSignal();
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// Store the generated data in a double array named data.
double[] data = whiteNoise.Generate(1000.0, 256);

                
             

// Use the PlotY method to plot the data.
Plot.PlotY(data);

    
// Use the Mean method to calculate the mean of the data.
double mean = Statistics.Mean(data);

        
// Display the mean on the gauge.
gauge.Value = mean;

Customizing your user interface

1. Select the Default.aspx tab to return to the Web Forms Designer. 

2. Right-click the legend and select Edit Items to display the LegendItem 
Collection Editor dialog box. You use the LegendItem Collection 
Editor to add or remove legend items and to configure legend item 
properties.

3. Select graph, Plots[0] in the Source drop-down list and enter Signal 
in the Text box. Click OK. Now that you have specified a legend item 
for the plot, changes you make to the plot are reflected on the legend.
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4. Right-click the graph and select Auto Format to display the Auto 
Format dialog box. The Auto Format dialog box provides a set of 
pre-configured control styles. When you select a style and click OK, 
the Auto Format feature configures the appropriate control properties 
to reflect the style you chose.

5. Select Points Only. Click OK. Notice that the legend changed 
automatically to match the formatting of the graph.

6. Right-click the gauge and select Auto Format to display the Auto 
Format dialog box.

7. Select Dark and click OK.

8. Right-click the gauge and select Properties to display the Properties 
window.

9. Set the Range property for the gauge with the drop-down Range type 
editor. Type -0.2 for the minimum value and type 0.2 for the 
maximum value.

10. Right-click the numeric edit and select Properties to display the 
Properties window.

11. Select Gauge in the Source drop-down list. Setting the Source 
property to the gauge allows two-way binding between the controls.

12. Deselect ArrowKeys, Buttons, and Text for the InteractionMode 
property of the numeric edit control. Deselecting these interaction 
modes makes the numeric edit an indicator. 
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13. Select the Format Mode property and in the Numeric Edit Format 
Mode Editor dialog box, change the Precision to 4.

14. Select File»Save Form1.cs to save your application.

15. Select Debug»Start Without Debugging to run the application.

16. After your program builds and runs, click Start. Notice the graph 
shows the data plot, and the gauge and the numeric edit display the 
mean of the data.

The following screenshot shows the Web page with customization.

Walkthrough: Creating a Measurement Studio 
NI-DAQmx Application in Visual Studio 2005

This walkthrough is designed to help you learn how to create an 
NI-DAQmx application by taking you through the following steps:

• Setting up the project—Using the Measurement Studio DAQ 
Application Wizard, you will create a new project that references the 
NI-DAQmx assembly and launches the DAQ Assistant to create an 
NI-DAQmx task.

• Configuring your task—Using the DAQ Assistant, you will 
interactively configure and save your task. The wizard then generates 
code to reflect your configuration settings. The wizard also generates 
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a component that provides common operations for your task and 
integration with the Windows Forms designer.

• Creating a custom user interface for the task—Using the DAQ 
Component UI generation wizard, you will create a custom user 
interface that uses the DAQ component you created to automatically 
plot the DAQ signal.

Before You Begin

The following components are required to complete this walkthrough:

• Visual Studio 2005

• Measurement Studio (Professional or Enterprise package)

• NI-DAQmx 8.1 or later

• NI-DAQmx-supported DAQ device or simulated device

For information about installing and configuring your DAQ device, refer to 
the DAQ Getting Started Guide. You can also use simulation to complete 
this walkthrough. For information on how to create an NI-DAQmx 
simulated device, refer to Creating NI-DAQmx Simulated Devices in the 
Measurement & Automation Explorer Help for NI-DAQmx. To open this 
help, select Start»All Programs»National Instruments»Measurement 
& Automation. In Measurement & Automation Explorer (MAX), select 
Help»Help Topics»NI-DAQmx»MAX Help for NI-DAQmx. For the 
purposes of this walkthrough, the NI PCI-6280 device of the M Series DAQ 
family is recommended.

To set up the project

1. Open Visual Studio from Start»All Programs»Microsoft Visual 
Studio 2005»Microsoft Visual Studio 2005.

2. Select File»New»Project. The New Project dialog box launches.

3. In the Project types pane, expand the Visual C# or Visual Basic node, 
depending on which language you want to create the project in, and 
select Measurement Studio. Code generation works in both 
languages.
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4. In the Templates pane, select NI DAQmx Windows Application. 
Specify MyDAQmxProject for Name and specify a Location of your 
choice. Click OK. The Measurement Studio DAQ Application Wizard 
launches.
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5. In the Add DAQ Component dialog box, you can choose to create a 
new project task, create a new MAX task, create a reference to a MAX 
task, copy a MAX task to a project task, or copy an existing .mxb.  For 
this walkthrough, select Create a new project task and click Finish.

The Measurement Studio DAQ Application Wizard automatically sets up 
your data acquisition project and launches the DAQ Assistant.

Tip If you are working with an existing project, you can access the Add DAQ Component 
dialog box by selecting Project»Add New Item.
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To configure your task

1. In the Create New dialog box of the DAQ Assistant, you can begin to 
interactively define your DAQ task. Select Analog Input as the 
measurement type for your task.

2. Next, select Voltage.

3. From the Supported Physical Channels tree in the Physical tab, 
select the physical channel, such as ai1, on the DAQ device to which 
you connected the voltage signal. Click Finish.
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Note You can also use simulation in this walkthrough. For more information, refer to 
Creating NI-DAQmx Simulated Devices in the Measurement & Automation Explorer Help 
for NI-DAQmx.

4. In the Edit DAQ Task dialog box, you can edit the configuration of 
your DAQ task.  If the embedded DAQ Assistant help is not open by 
default, click the Show Help button in the upper-right corner of the 
window to display the help.
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5. To complete the DAQ configuration, select the N Samples Acquisition 
Mode in the Task Timing tab.  For more information on timing, refer 
to Timing in the NI-DAQmx Help.
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6. Next, click the Test button in the toolbar near the top of the Edit DAQ 
Task dialog box to launch the test panel for your task. The test runs 
automatically. You can use test panels in the DAQ Assistant to test the 
task and make sure you connected the signal properly. If necessary, 
you can modify the settings before any code is generated.

7. Click the Close button when you are done.

8. Click the Finish button in the Edit DAQ Task dialog box to complete 
the configuration of your DAQ task and launch the Configure DAQ 
Component UI wizard.
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To create a custom user interface for the task

1. In the Configure DAQ Component UI wizard, you can customize and 
preview a user interface and code for your task.
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2. Click Finish to generate the task user interface in your project form.

The wizard also generates event handlers and code to acquire data and 
present it on your generated user interface.
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3. Press <F5> to run the application.

4. After you have started the application, click the Read button to begin 
acquiring data from your DAQ device.

What’s Next

To learn more about tasks, channels, and other NI-DAQmx concepts, refer 
to the NI-DAQmx Help located at Start»All Programs»
National Instruments»NI-DAQ»NI-DAQmx Help.

For more information about creating and using tasks in Measurement 
Studio, refer to the Using the Measurement Studio NI-DAQmx .NET 
Library section in the NI Measurement Studio Help.

You can also look at examples that ship with NI-DAQmx. Refer to the 
Measurement Studio NI-DAQmx .NET Examples topic in the 
NI Measurement Studio Help for the locations of these examples.
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Walkthrough: Creating a Measurement Studio 
Instrument I/O Application in Visual Studio 2005

The National Instruments Instrument I/O Assistant organizes instrument 
communication for a serial, Ethernet, or GPIB instrument into ordered 
steps. This walkthrough is designed to help you learn how to build an 
instrument I/O application by taking you through the following steps:

• Setting up the project—Using the Measurement Studio Application 
Wizard, you will create a new project that references the VisaNS 
assembly and launches the Instrument I/O Assistant to create a VisaNS 
task.

• Performing a query on the instrument—Using the Instrument I/O 
Assistant, you will write a command to an instrument and read the 
instrument response.

• Displaying Instrument I/O Assistant data on your UI—Using text 
box and button controls, you will create a Windows Forms application 
to display the Instrument I/O Assistant data.

Before You Begin

The following components are required to complete this walkthrough:

• Visual Studio 2005

• Measurement Studio (Professional or Enterprise package)

• National Instruments Device Driver CD

• Message-based instrument on a supported VISA bus, such as GPIB or 
Serial

Note For more information about the Instrument I/O Assistant, refer to the NI Instrument 
I/O Assistant Help by selecting the Show Help button inside the assistant.

Setting up the project

1. Open Visual Studio from Start»All Programs»Microsoft Visual 
Studio 2005»Microsoft Visual Studio 2005.
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2. Select File»New»Project. The New Project dialog box launches.

3. In the Project Types pane, expand the Measurement Studio Projects 
folder. Select Visual Basic Projects or Visual C# Projects, depending 
on which language you want to use. This walkthrough refers to Visual 
C#, but Visual Basic .NET users can follow the same process.

4. In the Templates pane, select NI VISA Windows Application. 
Specify MyIIOAProject for Name and select a Location of your 
choice.

5. Click OK. Your project opens in Visual Studio with a VisaTask.mxb 
file and references to NationalInstruments.VisaNS, 
NationalInstruments.WindowsForms, and 
NationalInstruments.Common created for you.

6. Select View»Solution Explorer to display the Solution Explorer. 
Double-click the VisaTask.mxb in the Solution Explorer to launch the 
Instrument I/O Assistant.
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Performing a query on the instrument

1. The Select Instrument step automatically appears in the Step 
Sequence window when you launch the Instrument I/O Assistant. 
Select the instrument you want to communicate with or the port to 
which your instrument is connected from the Select an instrument 
drop-down listbox.

2. Select Add Step and then select Query and Parse from the expanded 
list. You use a Query and Parse step to both write a command to an 
instrument and read the instrument’s response.

3. Enter the command *idn? and click Run this step. The *idn? 
command is a standard instrument command for querying an 
instrument’s identification information. If your instrument does not 
support the *idn? command, refer to the documentation for the 
instrument for more information about the instrument’s command set.

4. Click Auto parse to parse the instrument’s response. The Auto parse 
button automatically parses binary block data and ASCII text. Refer to 
the Parsing an Instrument Response topic in the Instrument I/O 
Assistant Help for information about how the assistant parses different 
data formats.

5. If there are more than two tokens in the token list, remove them for this 
example. To remove a token, right-click it in the Response Window 
and select Remove. If there is only one token in the token list, you can 
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split the token into two tokens for this example. Refer to Parsing an 
Instrument Response in the Instrument I/O Assistant Help for 
information about how to manually parse the data.

6. In the Token name text box, enter Vendor to rename the first token. 
You use this name to reference the token in your application.

7. Rename Token2 to Device, by using the instructions from step 6.

8. Select File»Save to save your task.

9. Select View»Solution Explorer to display the Solution Explorer.

10. Click the Show All Files icon and expand the VisaTask.mxb node.

11. Double-click the VisaTask.cs file to view the code that the 
Instrument I/O Assistant generated for you.

Displaying Instrument I/O Assistant data on your user interface

1. Double-click Form1.cs in the Solution Explorer to open your main 
application form.
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2. Select View»Toolbox to display the Toolbox.

3. Select the WindowsForms tab on the Toolbox.

4. Select the Button control and drag and drop it onto the form.

5. Select the TextBox control and drag and drop it onto the form. Repeat 
this step to add a second text box to the form. The following screenshot 
shows the controls on the form:

6. Double-click the Button control to display the Form1 code, with the 
cursor inside the click event handler of the button control.

7. Add the following code to display the vendor and model name of your 
instrument in the text boxes:

[VB.NET]

' Declare an instance of VisaTask
Dim myTask As New VisaTask()
Dim results As VisaTaskResults

'Display the data in the text boxes
results = myTask.Run()
textBox1.Text = results.Vendor
textBox2.Text = results.Device

[C#]

//Declare an instance of VisaTask
VisaTask myTask = new VisaTask();

//Display the data in the text boxes
VisaTaskResults results = myTask.Run();
textBox1.Text = results.Vendor;
textBox2.Text = results.Device;

8. Press <F5> to build the application.

9. Click the button on the form to run the task. The following screenshot 
shows the controls on the form, with sample returned data.
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Note Althought this walkthrough only covers the use of a simple Query and Parse step, 
the Instrument I/O Assistant offers additional capabilities, such as independent Write and 
Read and Parse steps and advanced parsing capabilities. The following screenshot shows 
the Instrument I/O Assistant’s ability to scale and parse IEEE long definite block data.
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A
Technical Support and 
Professional Services

Visit the following sections of the National Instruments Web site at 
ni.com for technical support and professional services:

• Support—Online technical support resources at ni.com/support 
include the following:

– Self-Help Resources—For answers and solutions, visit the 
award-winning National Instruments Web site for software drivers 
and updates, a searchable KnowledgeBase, product manuals, 
step-by-step troubleshooting wizards, thousands of example 
programs, tutorials, application notes, instrument drivers, and 
so on.

– Free Technical Support—All registered users receive free Basic 
Service, which includes access to hundreds of Application 
Engineers worldwide in the NI Developer Exchange at 
ni.com/exchange. National Instruments Application Engineers 
make sure every question receives an answer.

For information about other technical support options in your 
area, visit ni.com/services or contact your local office at 
ni.com/contact. 

• Training and Certification—Visit ni.com/training for 
self-paced training, eLearning virtual classrooms, interactive CDs, 
and Certification program information. You also can register for 
instructor-led, hands-on courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, National Instruments 
Alliance Partner members can help. To learn more, call your local 
NI office or visit ni.com/alliance.

If you searched ni.com and could not find the answers you need, contact 
your local office or NI corporate headquarters. Phone numbers for our 
worldwide offices are listed at the front of this manual. You also can visit 
the Worldwide Offices section of ni.com/niglobal to access the branch 
office Web sites, which provide up-to-date contact information, support 
phone numbers, email addresses, and current events.
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Glossary

A

ActiveX Set of Microsoft technologies for reusable software components. Formerly 
called OLE.

ActiveX control Reusable software component that adds functionality to any ActiveX 
control container through exposed properties, methods, and events. The 
Measurement Studio data acquisition, user interface, and analysis controls 
are examples of ActiveX controls.

ActiveX control 
container

Development environment that fully supports ActiveX controls and 
integrates them into its own environment using COM. An ActiveX control 
container enables you to specify how ActiveX controls interact with the 
environment through environment properties. Visual Basic is an example of 
an ActiveX control container.

analog I/O Reading or writing data in continuously variable physical quantities, such 
as voltage or current.

annotate Adding text, arrows, or shapes to describe or highlight a point or region on 
a graph.

ANSI C C programming language defined by the American National Standards 
Institute.

API Application Programming Interface. A specification of software functions 
and their input and return parameters.

array control An array of Measurement Studio user interface controls that behave as a 
single unit.

assembly A collection of one or more files that are versioned and deployed as a unit. 
An assembly is the primary building block of a .NET Framework 
application. All managed types and resources are contained within an 
assembly and are marked either as accessible only within the assembly or 
as accessible from code in other assemblies.

asynchronous Function that begins an operation and returns control to the program prior 
to the completion or termination of the operation.
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B

button A control used to input or display Boolean information or to initiate an 
action in a program.

C

channel 1. Physical—a terminal or pin at which you can measure or generate an 
analog or digital signal. A single physical channel can include more than 
one terminal, as in the case of a differential analog input channel or a digital 
port of eight lines. The name used for a counter physical channel is an 
exception because that physical channel name is not the name of the 
terminal where the counter measures or generates the digital signal. 

2. Virtual—a collection of property settings that can include a name, a 
physical channel, input terminal connections, the type of measurement or 
generation, and scaling information. You can define NI-DAQmx virtual 
channels outside a task (global) or inside a task (local). Configuring virtual 
channels is optional in Traditional NI-DAQ and earlier versions, but is 
integral to every measurement you take in NI-DAQmx. In Traditional 
NI-DAQ, you configure virtual channels in MAX. In NI-DAQmx, you can 
configure virtual channels in either MAX or in a program, and you can 
configure channels as part of a task or separately. 

3. Switch—a switch channel represents any connection point on a switch. 
It may be made up of one or more signal wires (commonly one, two, or 
four), depending on the switch topology. A virtual channel cannot be 
created with a switch channel. Switch channels may be used only in the 
NI-DAQmx Switch functions and VIs.

chart To append new data points to the end of an existing plot over time.

client callback In Web Forms, page calls back to the server without fully posting back. 
Callbacks are asynchronous and are accomplished with XML-HTTP. 
Client callbacks do not include postback data, and they do not force the 
page to refresh. Client callbacks do require a browser that supports the 
XML-HTTP protocol.

CodeBuilder LabWindows/CVI feature that creates code based on a .uir file to connect 
your GUI to the rest of your program. This code can be compiled and run 
as soon as it is created.
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coercion Automatic conversion that Measurement Studio controls perform to change 
the numeric representation of a data element.

COM Component Object Model. Microsoft specification for architecting and 
developing reusable software components.

complex graph A control that displays a ComplexDouble data type; the ComplexDouble 
data type represents a complex number of type Double that is composed of 
a real part and an imaginary part.

context-sensitive help Help for dialog boxes, the controls in dialog boxes, and keywords in source 
code that you can access with the key or a Help button, or by clicking the 
link that appears in the Dynamic Help window in Visual Studio.

control 1. ActiveX control. See ActiveX control.

 2. Object for entering, displaying, or manipulating data on a user interface.

counter/timer I/O Reading or writing data based on high-precision timing through a counter 
or timer. By combining a counter with a highly accurate clock, you can 
create a wide variety of timing and counting applications, such as 
monitoring and analyzing digital waveforms and generating complex 
square waves.

cursor Flashing rectangle that shows where you may enter text on the screen. If 
you have a mouse installed, there is a rectangular mouse cursor, or pointer.

cursor label Text object used to display X and Y coordinates that a cursor crosshair 
points to on a graph.

D

DAQ Data acquisition. Process of acquiring data, typically from A/D or digital 
input plug-in boards.

DAQ Assistant A graphical interface for configuring measurement tasks, channels, and 
scales.

DAQ device A device that acquires or generates data and can contain multiple channels 
and conversion devices. DAQ devices include plug-in devices, PCMCIA 
cards, and DAQPad devices, which connect to a computer USB or 1394 
(FireWire®) port. SCXI modules are considered DAQ devices.
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DataSocket Technology that simplifies live data exchange between applications and 
HTTP, FTP, OPC, logos (Lookout objects) and file servers over the Internet. 
It provides one common API to a number of different communication 
protocols.

device An instrument or controller you can access as a single entity that controls 
or monitors real-world I/O points. A device is often connected to a host 
computer through some type of communication network. See also DAQ 
device and measurement device.

digital I/O Reading or writing digital representations of data in discrete units (the 
binary digits 1 and 0). Digital information is either on or off.

digital waveform 
graph

A control that displays DigitalWaveform data on a Windows Forms or 
Web Forms user interface; the DigitalWaveform data type represents a 
set of digital states that are grouped by samples or signals.

distribution Ability to install programs you develop with Measurement Studio to others 
working on different computers.

DLL Dynamic Link Library. A library of functions that link to a program and 
load at run time rather than being compiled into the program. Loading 
libraries only when they are needed saves memory in software applications.

DMM Digital Multimeter. A common measurement instrument that measures 
resistance, current, and voltage in a wide variety of applications.

downlevel browser Previous generation Web browser with limited client interaction. See also 
uplevel browser.

driver Software that controls a specific hardware device, such as a data acquisition 
board or GPIB interface board. See also instrument driver.

DSTP DataSocket Transfer Protocol. Protocol based on TCP/IP to exchange data 
directly between two applications using DataSocket clients. Data is passed 
through a DataSocket Server between the applications.
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E

Ethernet Standard connection type for networks, where computers are connected by 
coaxial or twisted-pair cable.

event Object-generated response to some action or change in state, such as a 
mouse click or a completed acquisition. The event calls an event procedure 
that processes the event.

executable Program file with a .exe extension that you can run independently of the 
development environment in which it was created.

F

form Window or area on the screen on which you place controls and indicators 
to create the user interface for your program.

front panel Interactive user interface of a virtual instrument. Modeled after the front 
panel of physical instruments, it is composed of switches, slides, meters, 
graphs, charts, gauges, LEDs, and other controls and indicators.

FTP File Transfer Protocol. Protocol based on TCP/IP to exchange files between 
computers.

G

gauge A control used to input or display numerical data.

GPIB General Purpose Interface Bus. The standard bus used for controlling 
electronic instruments with a computer. Also called IEEE 488 bus because 
it is defined by ANSI/IEEE Standards 488-1978, 488.1-1987, and 
488.2-1987.

graph A 2D or 3D display of one or more plots.

H

HTTP HyperText Transfer Protocol. Protocol based on TCP/IP, which is used to 
download Web pages from an HTTP server to a Web browser.
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I

IEEE 488 Shortened notation for ANSI/IEEE Standards 488-1978, 488.1-1987, and 
488.2-1987. See also GPIB.

IMAQ Vision National Instruments image acquisition and analysis software that you can 
use to acquire images from National Instruments image acquisition 
(IMAQ) boards, display them in your program, perform interactive viewer 
operations, and analyze the images to extract information.

indicator A control in read-only mode.

installer Software program that copies program, system, and other necessary files to 
computers.

instrument driver Library of functions to control and use one specific physical instrument. 
Also a set of functions that adds specific functionality to an application.

Instrument I/O 
Assistant

Assists in writing code to communicate with devices such as serial, 
Ethernet, or GPIB instruments. The Instrument I/O Assistant provides a 
user interface within the Visual Studio environment. You use the 
Instrument I/O Assistant to interactively write commands to a device, read 
data that the device returns, and specify how to parse the response.

interface Connection between one or more of the following: hardware, software, and 
the user. For example, hardware interfaces connect two other pieces of 
hardware.

IVI Interchangeable Virtual Instruments. A technology involving standard 
programming interfaces for classes of instruments, such as oscilloscopes, 
DMMs, and function generators, that results in hardware-independent 
instrument drivers. The IVI standard programming interfaces have been 
defined by the IVI Foundation, an industry consortium. Refer to 
www.ivifoundation.org for more information.

K

knob A control used to input or display numerical data.
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L

LabVIEW Laboratory Virtual Instrument Engineering Workbench. Graphical 
development environment used for developing test and measurement 
applications.

LabWindows/CVI ANSI C development environment for building test and measurement 
applications.

LED Light-Emitting Diode. An indicator that emits a light when current passes 
through it. For example, an LED shows if your computer or printer is turned 
on.

legend A control that displays symbols and descriptions for a specific set of 
elements of another object, such as the plots or cursors of a graph.

M

matrix A rectangular array of numbers or mathematical elements that represent the 
coefficients in a system of linear equations.

MB Megabytes of memory.

Measurement & 
Automation Explorer 
(MAX)

National Instruments tool for configuring your National Instruments 
hardware and driver software; executing system diagnostics; adding new 
devices, interfaces, and virtual channels; and viewing devices and 
instruments connected to your system.

measurement device DAQ devices such as the E Series multifunction I/O (MIO) devices, SCXI 
signal conditioning modules, and switch modules.

Measurement Studio National Instruments software that includes tools to build measurement 
applications in Visual Basic .NET, Visual C#, and Visual C++.

meter A control used to input or display numerical data.

method Function that performs a specific action on or with an object. The operation 
of the method often depends on the values of the object properties.

MFC Microsoft Foundation Class. A framework for programming in Microsoft 
Windows, MFC provides code for managing windows, menus, and dialog 
boxes; performing basic input/output; storing collections of data objects; 
and more.
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N

NI-488.2 Driver-level software to control and communicate with National 
Instruments GPIB hardware.

NI-DAQ Driver-level software to control and communicate with DAQ hardware. 
NI-DAQ is an extensive library of VIs and functions you can call from an 
application development environment (ADE) to program all the features of 
an NI measurement device, such as configuring, acquiring and generating 
data from, and sending data to the device.

NI-DAQmx The latest NI-DAQ driver with new VIs, functions, and development tools 
for controlling measurement devices. The advantages of NI-DAQmx over 
earlier versions of NI-DAQ include the DAQ Assistant for configuring 
channels and measurement tasks for your device for use in LabVIEW, 
LabWindows/CVI, and Measurement Studio; increased performance such 
as faster single-point analog I/O; and a simpler API for creating DAQ 
applications using fewer functions and VIs than earlier versions of 
NI-DAQ.

NI-IMAQ Driver-level software to control and communicate with National 
Instruments image acquisition hardware.

numeric edit A control used to display and edit numeric values.

O

OCX OLE Control eXtension. Another name for ActiveX controls, reflected by 
the .ocx file extension of ActiveX control files.

OLE Object Linking and Embedding. See also ActiveX.

OPC OLE for Process Control. An industry standard based on ActiveX and 
COM technologies that enables you to create a single client application 
that can communicate with disparate devices. Refer to 
www.opcfoundation.org for more information.

oscilloscope Measurement instrument widely used in high-speed testing applications, 
such as telecommunication physical layer testing, video testing, and high-
speed digital design verification.
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P

PCI Peripheral Component Interconnect. High-performance expansion bus 
architecture commonly found in PCs.

PID Proportional-Integral-Derivative. A three-term control mechanism 
combining proportional, integral, and derivative control. You might use a 
PID algorithm to control processes such as heating and cooling systems, 
fluid level monitoring, flow control, and pressure control.

plot 1. Trace (data line) on a graph representing the data in one row or column 
of an array. 

2. To display a new set of data while deleting any previous data on the 
graph.

point Structure that contains two 16-bit integers that represent horizontal and 
vertical coordinates.

postback The process in which a Web page sends data back to the same page on the 
server.

property Attribute that defines the appearance or state of an object. The property can 
be a specific value or another object with its own properties and methods. 
For example, a value property is the color (property) of a plot (object), 
while an object property is a specific Y axis (property) on a graph (object). 
The Y axis itself is another object with properties, such as minimum and 
maximum values.

property editor A control used to configure properties for Windows Forms controls at run 
time.

property pages Window or dialog box that displays current configuration information and 
allows users to modify the configuration.

PXI PCI eXtensions for Instrumentation. Rugged, open platform for modular 
instrumentation with specialized mechanical, electrical, and software 
features. Refer to www.pxisa.org for more information.
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R

range Region between the limits within which a quantity is measured, received, 
or transmitted. The range is expressed by stating the lower and upper range 
values.

S

scalar Number that a point on a scale can represent. The number is a single value 
as opposed to an array.

scale Part of graph, chart, and some numeric controls and indicators that contains 
a series of marks or points at known intervals to denote units of measure.

scatter graph A control that displays two-dimensional data on a Windows Forms or Web 
Forms user interface; displays a graph of X and Y data pairs.

scope See oscilloscope.

serial Standard serial bus on a computer used to communicate with instruments. 
Also known as RS-232.

slide A control used to input or display numerical data.

slider Moveable part of a slide control.

smart tag A glyph attached to a Measurement Studio control or component that 
exposes commonly performed tasks.

switch A control used to receive and control Boolean input in an application user 
interface.

synchronous Property or operation that begins and returns control to the program only 
when the operation is complete.

T

tank A control used to input or display numerical data.

task NI-DAQmx—a set of channels and the channel configurations, timing, and 
triggering, and other details that define a measurement or generation you 
want to perform.
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TCP/IP Transmission Control Protocol/Internet Protocol. A standard format for 
transferring data in packets from one computer to another. The two parts of 
TCP/IP are TCP, which deals with the construction of data pockets, and IP, 
which routes them from computer to computer.

TestStand Ready-to-run test executive from National Instruments for organizing, 
controlling, and executing your automated prototype, validation, or 
manufacturing test systems.

thermometer A control used to input or display numerical data.

U

UI User Interface.

uplevel browser Recent generation Web browser that supports rich client interaction and 
functionality. See also downlevel browser.

V

vector 1D array.

virtual instrument (VI) Program in Measurement Studio that models the appearance and function 
of a physical instrument.

VISA Driver-software architecture developed by National Instruments to unify 
instrumentation software for serial, GPIB, and VXI instruments or 
controllers. It has been accepted as a standard for VXI by the 
VXIplug&play Systems Alliance.

VXI VME eXtension for Instrumentation. Instrumentation architecture and bus 
based on the VME standard. Used in high-end test applications.

W

waveform graph A control that displays two-dimensional data on a Windows Forms or Web 
Forms user interface; displays data that is uniformly spaced in one 
dimension.
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Index

A
ActiveX controls in Visual C++, 3-2
Add/Remove Class Libraries wizard, 4-5
adding or removing Measurement Studio 

class libraries, 4-5
Analysis

.NET class library
Array and Numeric Operations 

(table), 2-9
Curve Fitting (table), 2-9
Enterprise Analysis, 2-3
Filters (table), 2-5
Linear Algebra (table), 2-6
Measurements (table), 2-3
Professional Analysis, 2-2
Signal Generation (table), 2-4
Signal Processing (table), 2-5
Standard Analysis, 2-2
Statistics (table), 2-10
Windowing (table), 2-4

Visual C++ class library, 3-3
Array and Numeric Operations 

(table), 3-11
Curve Fitting (table), 3-11
Enterprise Analysis, 3-4
Filters (table), 3-7
Linear Algebra (table), 3-8
Measurements (table), 3-5
Professional Analysis, 3-4
Signal Generation (table), 3-5
Signal Processing (table), 3-7
Standard Analysis, 3-4
Statistics (table), 3-12
Windowing (table), 3-6

AutoRefresh control, 2-41

B
button control, 3-20

C
calling Instrument Drivers from .NET 

languages, 4-12
class driver class libraries

IviDcPwr, 3-16
IviDmm, 3-16
IviFgen, 3-16
IviScope, 3-16
IviSwitch, 3-16

Common
.NET class library, 2-13
Visual C++ class library, 3-14

complex graph control, 2-22, 2-35
conventions used in the manual, x
creating

Measurement Studio Application with 
Web Forms Controls and Analysis in 
Visual Studio 2005 (walkthrough), 5-44

Measurement Studio Application with 
Windows Forms Controls and Analysis 
(walkthrough), 5-2

Measurement Studio Application with 
Windows Forms Controls and Analysis 
in Visual Studio 2005 
(walkthrough), 5-34

Measurement Studio Instrument I/O 
Application (walkthrough), 5-24, 5-64

Measurement Studio NI-488.2 or 
NI-VISA application, 4-10

Measurement Studio NI-DAQmx 
application, 4-6

Measurement Studio NI-DAQmx 
Application (walkthrough), 5-11
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Measurement Studio NI-DAQmx 
Application in Visual Studio 2005 
(walkthrough), 5-53

new Measurement Studio project, 4-3
NI-DAQmx user control, 4-8
NI-DAQmx user interface, 4-8, 4-9

D
DAQ Assistant, 4-6
data acquisition (DAQ), 2-14, 3-18
DataSocket

.NET class library, 2-13
deployment requirements, 1-3
developing with Measurement Studio, 4-1
diagnostic tools (NI resources), A-1
digital waveform graph control, 2-20, 2-34
documentation

conventions used in the manual, x
how to use manual set, ix
NI resources, A-1

drivers (NI resources), A-1

E
examples (NI resources), A-1

G
gauge control, 2-23, 2-37
graph control

3D, 3-2
ActiveX, 3-21
complex, 2-22, 2-35
digital waveform, 2-20, 2-34
scatter, 2-18, 2-32
waveform, 2-18, 2-32

H
help

NI Measurement Studio Help, 1-7
technical support, A-1

how to use manual set, ix

I
installation

optional, 1-2
requirements, 1-2

instrument driver wizard, .NET, 4-12
instrument drivers (NI resources), A-1
Instrument Drivers Visual C++ class library, 

3-16
Instrument I/O Assistant, 4-10

K
knob

.NET control, 2-24

.NET Web Forms control, 2-38
Visual C++ control, 3-22

KnowledgeBase, A-1

L
LabVIEW Real-Time Interface Visual C++ 

class library, 3-16
LED array control, 2-29
LED control, 2-26, 2-41
legend control, 2-23, 2-37

M
Measurement & Automation Explorer 

(MAX), 4-2
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Measurement Studio
developing with, 4-1
home page, 4-3
Menu, 4-1
package comparison chart, 1-5
Preferences, 4-3
resources, 1-7

meter control, 2-24, 2-38
Microsoft Excel Interface Visual C++ class 

library, 3-17
Microsoft Word Interface Visual C++ class 

library, 3-17

N
National Instruments support 

and services, A-1
.NET class libraries

Analysis, 2-2
Common, 2-13
NI-488.2, 2-14
NI-DAQmx, 2-14
NI-VISA, 2-15
overview, 2-1, 2-28
User Interface, 2-16, 2-31
deployment requirements, 1-3

NI DAQ Assistant, 4-6
NI Discussion Forums, 4-2
NI Instrument Driver Network, 4-2
NI Measurement Encyclopedia, 4-3
NI Spy, 4-2
NI support and services, A-1
NI-488.2

creating a 488.2 application, 4-10
.NET class library, 2-14
Visual C++ class library, 3-18

NI-DAQmx
creating a DAQ application, 4-6
.NET class library, 2-14
Visual C++ class library, 3-18

NI-Reports Visual C++ class library, 3-19
NI-VISA

creating a VISA application, 4-10
.NET class library, 2-15
Visual C++ class library, 3-19

numeric controls, 2-23, 2-37
numeric edit

.NET control, 2-25, 2-40
Visual C++ control, 3-23

O
overview

.NET class libraries, 2-1, 2-28
Visual C++ class libraries, 3-1

P
Parameter Assistant, 4-12
programming examples (NI resources), A-1
project conversion wizard, 4-2
project templates, 4-3
property editor control, 2-27

R
requirements

distribution, 1-3
installation, 1-2

S
scatter graph control, 2-18, 2-32
selecting a Measurement Studio parameter 

value, 4-12
slide control

.NET, 2-25, 2-39
Visual C++, 3-24

software (NI resources), A-1
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