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1 Introduction

This is the user’s manual for the ARCS Integrated Development Environ-

ment or AIDE. AIDE is a ready-to-use graphical user interface that can

be used to control your system. AIDE also provides a project builder for

creating, compiling and organizing your control applications.

It is advised that you read Sec. 2 even if you do not plan on using AIDE.

That section provides an overview of the system, key terms, and a sum-

mary of the system capabilities.

Conventions: Describe document conventions here:

� This is a BUTTON to push.

� Selecting a menu item under a top-level menu entry is denoted by:

menu entry ➜ menu item
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2 Overview of ARCS Control System

Even if you do not plan to use AIDE, it will be helpful to read this

section as it discusses key terms and descriptions of the system.

� Hardware - ARCS Lightning DSP Board. Also referred to as the con-

troller hardware or just controller.

� Hardware Host. - The computer that houses the ARCS Lightning DSP

Board.

� Controlling Functions (what you can do with the system) include:

– Develop and organize application code for the hardware (Project

Builder).

– Load an application to the hardware.

– Start/stop application.

– Monitor DSP variables during run-time.

– Adjust DSP variables during run-time.

– Data acquisition

– Data plotting.

– Check communication between the Hardware Host and Hard-

ware.

– Link and coordinate Remote Processes (Remote Mode only).

Controlling Functions can be performed from the hardware host itself

or from another computer on the network.

� The Hardware Host can be in one of two modes:

1. Local Mode - Controlling Functions can be performed only from

the Hardware Host itself. No networking is involved or permit-

ted. This typical configuration of a PC-based motion controller is

shown in Fig. 1.
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FIGURE 1: Stand-Alone Controller System: ARCS Local Mode

2. Remote Mode - Activates ARCS remote distributed capability in

the form of a client/server architecture, thus enabling network-

ing among the clients and server. This is illustrated in Fig. 2.

FIGURE 2: Distributed Controller System: ARCS Remote Mode

In Remote Mode , the Hardware Host acts as a server to:

– A Controlling Client which can perform full Controlling Func-

tions. The Controlling Client may be on the same computer

as the Hardware Host server or on a different computer in the

network.

– One or more Monitoring Clients. Monitoring Client(s) give

users on other computer(s) in the network the ability to ob-

serve, but not control, what is going on in the system. A Mon-

itoring Client can just monitor DSP variables during run-time

and do data plotting.
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– Any number of Remote Processes . These processes broad-

cast/publish information that is picked up and used by the

Hardware Host server and the application running on its ARCS

Lightning DSP Board. A Remote Process may be running on

the same computer as the Hardware Host server or on a dif-

ferent computer.

Note: A Remote Process can publish information to more

than one Hardware Host server.

Note also that while the Hardware Host acts as a server to the

above clients, it, in turn, can act as a Remote Process to other

servers, thus creating a very powerful and sophisticated dis-

tributed network.

2.1 Advantages to ARCS Remote Mode

The possibilities are virtually limitless, but here are just a few ways to take

advantage of Remote Mode capabilities:

� Remote Servicing and Repair - Diagnose and fix problems from a sin-

gle location in the network.

� Remote Monitoring - Authorized agents may monitor the exposed

components of the controller. An agent may be a person, such as a

factory supervisory who wishes to check the current machine through-

put or an agent could be an application which monitors multiple ma-

chines and stores the results in a database.

� Remote Process Coordination - the idea here as illustrated in Fig. 2 is

that the controller hardware may need to take some action or, in some

way, modify its response based on the results of another process.

This other, remote process could be another controller hardware, a
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vision application, a database-driven application, or any other pro-

cess. For example, suppose you have inspection equipment running

at another computer. If the equipment detects that a part is defective

it can broadcast that information to the server and your controller

can make the appropriate adjustments.
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3 Launching AIDE

This section describes how to launch AIDE. . AIDE can be used to control

your system and/or for project building.

☞ Tip: You should be launching AIDE from the com-

puter you will be using to perform Controlling Function-

ality (see Sec. 2). Recall, when in Remote Mode, you

can have the Controlling Client reside on the Hardware

Host or on a different computer in your network.

1. From the Start Menu, Select AIDE as shown in Fig. 3.

2. If your machine has been configured for more than one TCP/IP net-

work, you will be presented with a screen showing your computer’s IP

(Internet Protocol) addresses corresponding to each of the networks

to which it can connect, as shown in Fig. 4. Select the network con-

nection you will be using for network communication for your control

system. Note: this screen is relevant only if you plan to take advan-

tage of ARCS Remote, Distributed capabilities.

3. Next, choose the desired mode for the Hardware Host, Local Mode or

Remote Mode, as shown in Fig. 5 and follow the steps given in the

appropriate subsection of this manual to continue launching AIDE.

FIGURE 3: AIDE Start Menu Entry
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FIGURE 4: Which network do you wish to use?

FIGURE 5: In which mode, Local Mode or Remote Mode , do you wish the
Hardware Host to be?

3.1 Local Mode

(Note: for Remote Mode operations, see Sec. 3.2).

Your initial display will be the Host Control panel, as shown in Fig. 6
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FIGURE 6: Initial Screen for Local Operations

3.2 Remote Mode

The first screen that will be displayed is the Network Configurator, as

shown in Fig. 7. It shows you as the Controlling Client. If you intend

to use only the Project Builder function at this computer, you can skip this

screen as well as the steps outlined in Sec. 3.2.1

FIGURE 7: Initial Screen for Remote Mode Operations
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3.2.1 Connecting the Controlling Client to the Hardware Host server

◆◆ Caution: If it hasn’t already been started, start the

server at the Hardware Host. This can be done by one

of two methods. Either method must be done on the

Hardware Host computer itself:

� Start Server Method 1: press the Hardware Host

selection as illustrated in Fig. 8. The message as

shown in Fig. 9 indicates that the server has been

successfully started. If you do not get this mes-

sage, it may be that the server was already started.

� Start Server Method 2: Go to the ARCS root direc-

tory. The root directory was specified during the

ARCS installation (See ARCS Installation Guide).

From the ARCS root directory, type and enter the

command: HdwHostApp. The message as shown

in Fig. 9 indicates that the server has been suc-

cessfully started. If, instead, you receive an er-

ror message, it may be that the server was already

started.

FIGURE 8: HdwHostApp Start Menu Entry

1. Register the Hardware Host server as follows:

(a) Double click in the center of the Network Configurator screen.
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FIGURE 9: Server at hardware host successfully started

(b) Fill in the fields of the dialog box (Fig. 10) as follows:

� Type “HdwHost” in the field labeled “Name”.

� Enter the URL of the Hardware Host in the field labeled la-

beled “URL”.

� Select “HdwHost” in the field labeled “NodeType”.

� Select the number of Remote Processes that this Hardware

Host server can take information from in the field labeled

“Receiving Clients”.

� If this Hardware Host can also be a Remote Process to an-

other Hardware Host Server, check the box labeled “ProvideR-

emoteNode”.

� Click OK when you are done.

If the registration of the Hardware Host Server is successful, the

HdwHost block with the corresponding URL will appear (see ex-

ample shown in Fig. 11). The blocks may be moved around by

pointing the mouse pointer to the interior of the block and hold-

ing down the left mouse button. Drag the block to the desired

location and then double click on the block again to finalize on

the new position.

If the Hardware Host has not been successfully registered (the
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FIGURE 10: Registering Hardware Host Server Dialog

FIGURE 11: Example showing Hardware Host Server successfully regis-
tered

HdwHost block does not appear), this could mean that the hard-

ware host server has not been started or the URL was incorrectly

specified or the TCP/IP connection to the network that you said

you would use is not currently active.

2. Next, connect the Controlling Client to the Hardware Host server by

placing the mouse pointer directly over the right connector of the

HdwHost block. Click and drag a line over to the left connector of

the Controlling Client block. Release mouse. After the hour glass

disappears, the line connecting the two blocks should remain intact,

as shown in Fig. 12. Note if the ”HostControl” tab on this screen is
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not lit after the line is intact, it means that the Hardware Host is

not available for your control. For example, someone else may be

controlling the hardware host.

FIGURE 12: HdwHost connection completed

3.3 User Preferences

You may wish to configure your system to start with specific locations

for different files. These locations can be changed by either editing the file

“arcsware.props” (in either the current directory or in your home directory)

or by using the interface. To use the interface, select File➜ Preferences...

as shown in Fig. 13. The dialog box shown in Fig. 14 is displayed. Any

changes made in this dialog box will take effect the next time this program

is run.

✍ Note: An initial “arcsware.props” file was created

during system installation. Refer to ARCS Lightning

Hardware and Software Installation Manual.

Now you are ready to run existing control applications or create new ap-

plications.
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FIGURE 13: Selecting the Aide Preferences

FIGURE 14: Changing the Aide Preferences
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4 Project Builder

You will see several panels displayed on top of the AIDE Graphical User

Interface. In this section, we will focus on the Project Builder which helps

you create control programs and compile them. Due to the wide variety of

preferences in editors and their wide availability, the AIDE does not have

any internal editing capability. You should just use the editor which you

are most comfortable.

Click on the “Project Builder” Tab on the screen. You will see the Project

Builder screen as shown in Fig. 15. The “My Projects” directory you see

on the left is where you can create new projects and save them. A typical

project may consist of several files containing source files (C code), header

files (.h extension) or library files (.lib extension).

FIGURE 15: Project Builder start-up screen

Your first task is to add a new project. Select Project➜ Add Project from

the menu as shown in Fig. 16.

You will be prompted for the name of the new project as shown below

(Fig. 17). In this example, the name of the project is test-dsp. The project
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FIGURE 16: Adding a project

name is the name given to the executable, for example, test-dsp.out.

FIGURE 17: Naming a new project

When you enter the project name and hit “OK”, you will see the project

test-dsp show up in the directory tree structure as shown below (Fig. 18).

Notice that there are 3 sub-directories that are automatically created for

the project: one each for the source, header, and library files.
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FIGURE 18: Recently created project

✍ Note: The default location for these files is specified in the

“arcsware.props” file, specifically in the “Programming Files”

entry. See Sec. 3.3 for details on configuration. The stan-

dard header files, libraries, and default linker command file

are found in the “dsp” directory within the ARCS root direc-

tory.

By clicking on the dot next to the project name, you can expand the direc-

tory (to see all sub-directories) or close them. The “Tool Message” will also

display the project added message.

Now that you have created a new project, you are ready to add files to this

project. Select (highlight) the project you wish to add files to and go to the

menubar on top and select Project➜ Add File as shown in Fig. 19.
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FIGURE 19: Adding files to your project

In the screen below (Fig. 20), you will see the source file test-dsp.c being

added from the directory called arcs-client. Type or select the name of the

file and click Open .

FIGURE 20: Selecting the file to add

Note that the system automatically defaults to “Files of type = Source (*.c)”

as shown below. You may want to set it to either “Files of all type” or the

specific header or library files.
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☞ Tip: By using the file extension convention, the system

will guarantee that all files are properly added to the build

specification.

The Tool Message window will display the message indicating the file has

been added as seen in Fig. 21.

FIGURE 21: File successfully added

You can add other files to this project as needed. In the screen shown in

Fig. 22 several header and library files have also been added. Remember

that by clicking on the dot you can expand the tree associated with any

directory or sub-directory.

By highlighting a particular file (test-dsp.c in Fig. 22), and clicking the

right mouse button you can display the options available for operations

on that file as shown in Fig. 22. In this case, Compile has been selected

for compiling test-dsp.c. The messages from the compiler are shown in the

Tool Message window.

If your compilation is unsuccessful, as is the case in Fig. 23 shown be-

low, examine the Tool Message screen where the compiler messages are

reported. The screen in Fig. 23 below shows that the compilation is unsuc-
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FIGURE 22: Compiling the selected source file

cessful because the include file, interrupt.h, (the cursor points the specific

message) could not be found.

FIGURE 23: Unsuccessful compilation

Now, the missing header file is added to the project. The various tool

actions can, alternatively, be reached from the the menubar. In Fig. 24, the

project, test-dsp, is selected and Project➜ Build is chosen to complete

the compilation and linking process.
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FIGURE 24: Starting the build

The results of the build process are shown in the Tool Message window

shown in Fig. 25. A successful build is indicated, pointed to by the cursor.

FIGURE 25: Project build results

When you have finished, you can save the entire project tree using the

File➜ Save command on the menubar as shown in Fig. 26, for future

use.
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FIGURE 26: Project tree save menu

◆◆ Caution: The save operation only saves the paths to the

files in your project. If you move your files, the links will no

longer work. When opening a project tree (File➜ Open com-

mand), relocated files will not be found and not be added to

the projects. A message in the Tool Message Window will be

provided.

☞ Tip: Instead of creating a project from scratch, modify an

existing project. Simply load a saved project tree, rename the

project (select the project, right-click the mouse, and chose

“Rename ...”), and add/remove the required files. Finally, use

File➜ Save As ... to save your “new” project.
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5 Host Control

This section describes the ”Host Control” tab. You can perform the follow-

ing operations when you select this tab:

� Load an application to the ARCS Lightning DSP Board (i.e. to the

Hardware).

� Start/Stop an application.

� Check communication between the Hardware Host and Hardware.

When you select the ”Host Control” tab you will see a screen as shown in

Fig. 27.

FIGURE 27: Initial Host Control Screen

In the Applications panel of this screen, you will notice that the only en-

abled button is Add . This is because there is no application currently

loaded to the ARCS Lightning DSP Board.
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5.1 Loading an Application

Loading an application to the ARCS Lightning DSP Board is a two step

process: (1) Add the application to the Application List if it is not already

there and (2) Load/set the application.

1. Add application to Applications List

When you add an application to the Applications List, a copy of the

code is sent over to the Hardware Host. One of the advantages of

having an Application List is that any user who becomes the current

Controlling Client of this Hardware Host will be able to use any appli-

cation in this list. This advantage is available when Hardware Host is

in Remote Mode .

To add an application, select from your directory the application you

want to add. Then press Add to add the application to the list. In

Fig. 28, the file test-dsp.out is selected from the directory arcs-client.

✍ Note: If you are running the system in Remote Mode and

there was a previous Controlling Client user, there may be ap-

plications already in the Application List, or a ”Current App”,

or even an application currently running. You, as the current

Controlling Client user, will be able to use these applications

even though you do not have direct access to the executables

or the source files.

☞ Tip: If you are operating in Remote Mode and do not wish

other users to use your applications when your session is fin-

ished, Stop your running application, if any, and Remove

your applications from the Application List prior to conclud-

ing your session.

You can continue to add other applications to the list. In Fig. 29,

three applications have been selected. As you add each application,
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FIGURE 28: Selecting an application to add to the Application List

the message window will display the message,

Application added: <application name>.

FIGURE 29: Additional applications in the Application List

2. Load the application to the ARCS Lightning DSP Board (i.e. Set the

current application)

(a) First ensure that the hardware is ready to run an application.

Press Reboot in the ”Operations” panel You will see the follow-
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ing message in the message window:

Hardware has been rebooted.

(b) You may wish to check the communication between the hardware

host and hardware (see Sec. ??).

(c) Select one of the applications in the Application List for loading

(i.e., set the current application) To do this highlight the applica-

tion (e.g., test-dsp.out in Fig. 31 ) and press Load . The message

in the window will indicate the change, example below:

Current application changed: test-dsp.

FIGURE 30: Checking Communication between Hardware Host and Hard-
ware.



26 5 HOST CONTROL

FIGURE 31: Set the Current App.

As soon as you load an application, it is ready to execute and thus the

Start is enabled.

5.2 Starting/Stopping an Application

You can now start the application that has been loaded to the ARCS Light-

ning DSP Board by pressing Start . Once the application is running, you

can stop it by pressing Stop . This is shown in Fig. 32.

5.3 Check Communication Between the Hardware Host

and Hardware

You may do this whenever the Check is enabled. Press Check - this

allows you to check the communication between the Hardware Host and

ARCS Lightning DSP Board. If everything is working well, you should see

the message in the window:

Communication is working well.
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FIGURE 32: Starting the Application.

Controller is running the KERNEL

This is shown in Fig. 30. If an application is running when you make the

check, the message will also indicate this.

5.4 About Update

This handy feature is best described by the example given in Sec. 9
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6 On-Line Data

This section describes the ”On-Line Data” tab. You can perform the fol-

lowing operations when you select this tab:

� Monitor DSP variables during run-time.

� Adjust DSP variables during run-time.

� Plot Data

When you click the tab, you will see the screen as shown below in Fig. 33.

FIGURE 33: Initial On-Line Data Screen.

Double click on the “Available Symbols”- your host PC name will be dis-

played. Expand the directory by double clicking, until you see the source

file that the controller is executing (in the example here, this is test-dsp.c).

Expand the test-dsp.c file by clicking on the dot to its left, and all available

variables will be displayed (in the example these are pi, amp1, myValue,

etc.) as shown in Fig. 34.

An ”available” variable may then be selected for monitoring or adjusting.
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FIGURE 34: Listing available variables in the application.

6.1 Monitor DSP variables during run-time

To select a variable for monitoring, click on the variable in the ”Available”

list (myValue in Fig. 35) and then click on the double arrows ( >> ) in the

”Monitored Parameters” panel.

FIGURE 35: Selecting a variable for monitoring.

The selected variable is removed from the ”Available” list and now appears

in the ”Monitored Parameters” panel as shown in Fig. 36.
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FIGURE 36: Monitored variable.

You can continue adding other variables for monitoring as shown Fig. 37.

You can also remove variables by selecting the variable from the ”Moni-

tored Parameters” panel and clicking on the << (see Fig. 37). This will put

the variable back on the ”Available” list. Once on the ”Available” list, the

variable can be selected again for monitoring or adjustment.

FIGURE 37: Removing a parameter for monitoring.

There is an additional step for variables of type pointer or array, as shown

in Fig. 38.
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FIGURE 38: Selecting a variable of type pointer or array.

☞ Tip: If access is only required for the 0
th element,

use the Assume Zero Offset menu button shown

below. This will avoid the additional dialog box.

◆◆ Caution: There is no boundary check made for

pointers or arrays. Incorrectly accessing (read or write)

memory can CRASH the controller card. So make sure

you are specifying the correct offset location.

✍ Note: Since more than one parameter can be ac-

cessed via a single array or pointer, the symbol IS NOT

removed from the available list when an entry is estab-

lish for either monitoring or adjusting.

At any time, the Start button can be pressed. If the application is run-

ning, the monitored variables will be displayed immediately as shown in
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Fig. 39. Otherwise, the data will be displayed when the application is

started.

6.2 Adjust DSP variables during run-time

You can change the value of a variable ”on the fly” i.e., as the application

is running.

To select a variable for adjustment, click on the variable in the ”Available”

list and then click on the double arrows ( >> ) in the ”Adjustable Parame-

ters” panel. The selected variable is removed from the ”Available” list and

will then appear in the ”Adjustable Parameters” panel

In Fig. 39, the variable run is added to the Adjustable Parameter panel.

Other variables can be added or removed from either the Monitor or Ad-

justable Panels at anytime. Removing a variable means putting it back

on the ”Available” list. Once on the ”Available” list it can be selected for

monitoring or adjustment.

FIGURE 39: Adding variable for adjustment.

To change the variable, do the following:
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1. Highlight the variable in the ”Adjustable Parameters” panel.

2. Click on the variable’s Value.

3. Type in the new value and hit Enter(Fig. 40).

4. IMPORTANT: press Set in order for the change to take effect (Fig. 41)

(alternatively, you can hit Enter twice).

FIGURE 40: Changing the value of an adjustable variable.

FIGURE 41: Setting the value of an adjustable parameter.
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6.3 Plotting Data

You can plot the values of a monitored variable. The ”Update(sec)” field

in the ”Monitored Parameters” panel is the rate at which the variable is

sampled for plotting. This rate can be changed.

Fig. 42 (a), (b) and (c) show how the plots change as the sampling interval

(”Update(sec)”) goes from 1.0 sec. to 0.2 sec.

(a) Update: 1.0 sec (b) Update: 1.0s→0.2s (c) Update: 0.2 sec

FIGURE 42: Plots illustrating “Update” time

To plot, select the variable in the ”Monitored Parameters” panel, and right-

click the mouse button. There are two plot options: ”Plot” and ”Advanced

Plot” (Fig. 43); Selecting ”Plot” will use the plot configurations specified in

the Tools menu, option ”Plot Config...”

When ”Advanced Plot” is selected, you can tailor the plot for this monitored

variable variable. The screen shown in Fig. 44 will be displayed. ”Advanced

Plot” allows you to tailor your plot



AIDE User’s Manual 35

FIGURE 43: Plotting a monitored variable.

FIGURE 44: Options available in Advanced Plot.
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7 Data Acquisition

The AIDE provides a built-in interface for the data acquisition system

which may be compiled into a particular application program. Please see

the “Programmer’s Reference” for details on building programs with the

data acquisition module.

The first step to acquire data is to enable the “Data Acquisition” panel.

This step is shown in Fig. 45. Simply select the check box area of the Data

Acquisition menu entry. Also, the application program MUST be started

prior to configuring the data acquisition.

FIGURE 45: Enabling data acquisition

The tab of “Data Acquisition” panel will now indicate an active panel. By

selecting this panel, one sees a layout similar to the “On-Line Data” panel.

Again, all exposed variables can be seen in the “Available Symbols” tree

by selecting the desired folders. The interesting module for the example

program is shown in Fig. 46.

Similarly, you can choose the desired variables for data acquisition; Fig. 47

shows two variables selected: wave and execTime. Next, the specifications

for data acquisition need to be adjusted. The acquisition can be keyed or

triggered from either of the two timer-based interrupts. Note, a call to the

data acquisition module in the interrupt service routine (ISR) is required

(details are provided in the “Programmer’s Reference”). Period is used to

specify the number of ISR executions between data acquisitions. In this ex-

ample, the timer, channel #0 is set to generate an interrupt every 10 mSec.

By setting the period to 1, data is acquired every 10 mSec. If the period is
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FIGURE 46: Example available symbols.

set to 12, data would be acquired every 120 mSec. Finally, the “No. Points”

is set. This value specifies the number of times the data is measured and

recorded. After the specification is complete, press Configure to setup

the data acquisition specification.

FIGURE 47: Configuring data acquisition

It is possible that insufficient heap space was made available for the de-

sired amount of data to be acquired. In this case, dialog will be displayed

indicating the problem, as shown in Fig. 48. There are two possible solu-
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tions:

1. Reduce the number of points to be acquired.

2. Re-link the application program with more heap space.

The “Programmer’s Reference” contains details on estimating the required

space and adjusting the available heap space.

FIGURE 48: Failure of data acquisition configuration

When the configuration is successful, the Start is enabled as shown in

Fig. 49. Now, the acquisition may be started at any time by “pressing”

Start .
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FIGURE 49: Successful data acquisition configuration

Immediately, upon data acquisition start, data is acquired. AIDE enables

the Stop button, shown in Fig. 50. This button will terminate the data

acquisition without completing the specified number of points.

FIGURE 50: Stopping data acquisition

After acquisition begins, AIDE periodically queries the dsp application

program to determine when acquisition has terminated. Note, termina-

tion can occur if either the specified data has been collected or because a

stop command has been issued. Once termination has been detected, the
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Save button is enabled as seen in Fig. 51.

FIGURE 51: Saving data from acquisition

A familiar file dialog box (Fig. 52) is provided to specify the file name and

location for the data.

FIGURE 52: Dialog box for data file

A sample of the data collected from this program is shown in Fig. 53. The

first column of data is the time relative to the start of the acquisition.

The parameters are columnated in the order in which they appear on the

specification table.
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0.0 -0.6566624 2.0599999E-5
0.01 -0.6791898 4.15E-5
0.02 -0.70179075 4.15E-5
0.03 -0.7230322 4.15E-5
0.04 -0.7442636 4.15E-5
0.049999997 -0.7641387 4.15E-5
0.06 -0.7833135 4.15E-5
0.06999999 -0.80235374 4.15E-5
0.08 -0.820052 4.15E-5
0.089999996 -0.83753276 4.15E-5

FIGURE 53: Sample data acquisition result
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8 Miscellaneous Operations

In this section, some of the various operations which round out a complete

development environment are briefly described.

8.1 Controlling Displays

The “Look and Feel” of the system can be adjusted on the fly. The “Look

and Feel” refers to the windowing operating system which AIDE will re-

semble. Currently, AIDE will behave like either a win32 system (Windows

95/98/NT) or a Motif windowing system. AIDE also supports Javasoft’s

neutral scheme, “Metal”. Fig. 54 shows how to select the look and feel.

FIGURE 54: “Look and Feel”

The ability to clear out the message consoles in both the Host Control

and the Project Builder views has been provided. This can be done with

the menu sequences, View ➜ Clear messages➜ Hardware or View ➜ Clear

messages➜ Tool , respectively. This view is shown in Fig. 55.

FIGURE 55: Clearing message windows
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8.2 Saving and Restoring

AIDE has the capability to save and restore its local operational state.

This is done via the File➜ Save orFile➜ Save As ... sequences, shown

in Fig. 56. Note, this works only if one of the following views is current:

Host Control, On-Line Data, or Data Acquisition.

FIGURE 56: Selecting run-time save

Assuming that the save configuration has not been previously established

(more on this to follow), a Save Options dialog is displayed, shown in

Fig. 57. There are two ways one can interact with this dialog. First, there

are a number of predefined save types, selected with the radio buttons.

For example, Online Configuration will save all of the parameters in

the monitor and adjustment table plus the update rate.

FIGURE 57: Run-time save dialog box



44 8 MISCELLANEOUS OPERATIONS

☞ Tip: When in doubt, use Workspace . This will save

every setting with the exception of networked connec-

tions (this capability is planned for a future release.

Much fine control over the aspects to be saved is possible with

Select ... . In this case, the various check boxes are enabled. The sys-

tem will control the availability of individual check boxes for consistency.

For example, Plots will not be able if either Monitored Parameters or

Adjustable Parameters is not selected.

Restoring from a file is easy. First, be sure to have one of these views

current: Host Control, On-Line Data, or Data Acquisition. Next, use the

menu sequence: File➜ Open .... This can be seen in Fig. 56. Using

the file dialog box, select the desired configuration file. The system will

automatically be configured.

Once a file has been saved or the system restored in a session, the configu-

ration has been established for future saves. This means that the aspects

to be saved and the file to save it in are set. For example, if the sys-

tem defaults and the applications are loaded from a file config07.cfg, this

will be the assumed information for future save operations. Therefore, if

File➜ Save is selected, the current defaults and the current registered ap-

plications will be saved in config07.cfg, replacing the previous information.

If File➜ Save As ... is chosen, the configuration will be the starting

point, however, you will be provided the dialogs to modify these settings.

☞ Tip: Starting condition: The starting condition of

the interface is determined by a file .default located

in the Configuration Files directory. This will hold the

screen size and location, the default plot specification,

and the current look and feel of the interface.
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8.3 Printing

Some printing capability is available. Text-oriented views from the Host

Control, On-Line Data, and Project Builder can be printed. Also, the plots

can be printed (gray-scale version). Fig. 58 shows the different printing

options. Note, the current plot is the plot which had the window focus

last.

FIGURE 58: Printing from AIDE
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9 Modifying the application

During development, you may want to modify your application. There are

three steps to accomplish this:

1. Modify your source files.

2. Rebuild your project.

3. Update your application.

For this example, we have been using an application which generates a

sine wave. Now, we introduce a new parameter, freq, so that the fre-

quency can be adjusted via the “On-Line Data” Panel. Again, use your

favorite editor to modify your file. After you have modified a file, highlight

it. The file is updated by using the menu (Project➜ Update File or using

the right mouse button to click Update as shown in Fig. 59.

FIGURE 59: File Update

The update is reflected in the message window through the File Updated

message, shown in Fig. 60. Now, the project can be compiled or built as

shown previously.
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FIGURE 60: Successfully updated file

☞ Tip: Update acts on the currently selected file or folder.

Therefore, the entire project can be updated by selecting the

project (test-dsp in this example) and pressing update . This

action will cause all files which are part of the project to be

reloaded.

Now, go to the ”Host Control” panel (click on ”Host Control” tab) and, high-

light test-dsp in the Applications panel (see Fig. 61), and click Update .

This will ensure that the latest updates are reflected in AIDE.

✍ Note: You cannot Update an application while it is run-

ning. Use the Stop or Reboot buttons first, then you are

free to update. If you attempt to Update while the appli-

cation is running, the interface will refuse your request and

provide an appropriate warning message.

As seen in Fig. 62, the new display of ”Available Parameters” now shows

the new variable, freq.
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FIGURE 61: Updating the Current Application

FIGURE 62: New variable, freq, from modification
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10 Linking Remote Processes

Linking an external process to the application running on the ARCS Light-

ning DSP Board can be easily performed

The main steps to link are summarized below:

1. Activate the Remote Process .

2. Launch AIDE (in Remote Mode ). Start the Hardware Host server and

connect the Controlling Client to it.

3. Load (but do not yet start) the desired application to the ARCS Light-

ning DSP Board.

4. Connect the Remote Process to the Hardware Host server.

5. Link variables of the Remote Process to variables in the application

program. Linking a variable means that the value of the Remote Pro-

cess variable will be synchronized with the value of the corresponding

application variable.

6. Start the application on the ARCS Lightning DSP Board.

The details of each step are described below. Unless otherwise specified,

these steps should be issued on the Controlling Client computer.

1. Activating Remote Process .

The activating steps must be issued on the computer the Remote

Process will execute: (For details on how to write a Java program

for the Remote Process interface, refer to the Programmers Reference

Manual.)

(a) A java remote process service must be established so that it can

broadcast/publish variables from any Remote Processes execut-
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ing on that computer. Start the RMI service that comes with JRE

by executing the rmiregistry exec.

(b) For each Remote Process to be activated on this computer, type

java<classname>, where ”classname” is the Remote Process java

class name.

2. Launching AIDE

Follow the steps in Section 3, Section 3.2, and Section 3.2.1.

3. Loading (but not yet starting) the Application to ARCS Lightning DSP

Board

Refer to Section 5

◆◆ Caution: Important! Do not press the Start button yet.

4. Connect Remote Process to Hardware Host server

Go back to the Network Configurator panel and follow the steps be-

low:

(a) Double click on an empty space in the screen. This will bring up a

dialog box as shown in Fig. 10, except now you will be registering

the Remote Process instead of the Hardware Host server.

� Type the name of the Remote Process in the field labeled

“Name”.

� Enter the URL of the computer on which the Remote Process

will be executing in the field labeled “URL”.

� Select “RemoteNode” in the field labeled “NodeType”.

� Ignore the remaining fields of the dialog box.

� Click OK when you are done.

A block with the named Remote Process will appear on the screen.

If it does not, you may want to check the TCP/IP connection that

you are using for control communication.
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(b) Next, connect the Remote Process to the Hardware Host server

by placing the mouse pointer directly over the left connector of

the HdwHost block. Click and drag a line over to the right con-

nector of the Remote Process block. Release mouse. After the

hour glass disappears, the line connecting the two blocks should

remain intact, as shown in Fig. 63. Note also the Remote Node

Configurator selection tab is now enabled. If not, try drawing and

dragging the line again.

FIGURE 63: Remote Node Connection Screen

5. Linking Remote Process variables to Application Variables

Variables published by the Remote Process can be linked to any

global variables of the application running on the ARCS Lightning

DSP Board. (see Programmer’s Reference Manual for details.) The

maximum rate of synchronization can be specified in milliseconds

in a field named REMOTE NODE UPDATE in the arcsware.props file.

Arcware.props is created during the ARCS installation. This rate is

a maximum rate, bounded further by network traffic and processor

load.
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(a) Click on the RemoteNode Configurator selection tab. As shown

in Fig. 64. The left portion of the panel entitled RemodeNode

Parm shows the variables of the Remote Process. The untitled

right portion of the panel shows all the available (global) variables

from the application. Highlight the Remote Process variable of

interest, then highlight the desired application variable. Press

Add/Change . The application variable will appear in the App

Symbol panel showing that the Remote Process variable and the

application variable will be linked.

(b) After all the selections are done, press Link Now to finalize the

linkage.

FIGURE 64: Remote Process variable and Host Application Variable Link-
age

6. Starting Application on Host

The application is now ready to be used together with the Remote Pro-

cess. Go back to the Host Control Panel. Press Start to start the

application. The variables in the host application are now automat-

ically updated by the remote variables. For details, please refer to
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Section 5.
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