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Chapter 1: Introduction 
 
Thank you for choosing Invoke Technologies, Inc.’s Check 21 Taskmaster as 
your Check 21 solution.  Check 21 Taskmaster is the fastest, easiest, and most 
useful tool on the market for working with DSTU X9.37/X9.100-180 files.  The 
Check 21 Taskmaster gives you the following capabilities: 

• View check images in the conventional hierarchy. 
• Examine detailed item information. 
• Search for items by item number or amount. 
• Print substitute checks (IRDs). 
• Edit record fields. 
• Utilize a custom plug-in to convert data into X9.37/X9.100-180 for archival, 

research and transmission. 
 

 
1.1 Common Terminology 
 
This section will list common terms or phrases that will be used throughout the 
manual.   
 
Capture - Reading and storing data from the check MICR line to enable the 
funds represented by the check to move between banks and their customers. 

Check 21 Act (CTA) - Check Clearing for the 21st Century Act.  

Check Image: - An electronic or digital image of an original check that is created 
by a depositor, a Bank or other participant in the check collection process. Check 
images can be exchanged electronically by banks, printed for customer 
statement purposes, displayed on Internet banking websites, and used to create 
substitute checks.  

Endorsement - Information used to record the transfer of a negotiable 
instrument from one holder to another. Endorsements are placed on the check by 
payee(s), by the Bank of First Deposit, and by Banks subsequently handling the 
check. Electronically associated endorsements may also accompany electronic 
check records without being physically placed on the check. Endorsements are 
used to track the routing of the check in electronic or paper form.  

Image - A digital representation of all or part of an original check or substitute 
check. 

MICR (Magnetic Ink Character Recognition) Line - Numbers printed in 
magnetic ink near the bottom of the front of the check to facilitate automated 
processing. These numbers identify the Bank the check is drawn on, the account 
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at that Bank, the amount of the check and other information. The position and 
content of the MICR line are governed by X9 industry standards.  

Substitute Check - A paper reproduction of the original check that: (1)Contains 
an image of the front and back of the original check; (2)Bears a MICR line 
containing all the information appearing on the MICR line of the original check, 
except as provided under generally applicable industry standards for substitute 
checks to facilitate the processing of substitute checks (regulations may contain 
exceptions); (3)Conforms, in paper stock, dimension, and otherwise, with 
generally applicable industry standards for substitute checks; and (4)Is suitable 
for automated processing in the same manner as the original check. Also called 
Image Replacement Document (IRD). This term is used by the Accredited 
Standards Committee in the technical specification for substitute checks (X9.90).  

1.2 File Hierarchy 

Files are broken down into the following conventional hierarchy: 

File> Cash Letter> Bundle> Item 

1.3 System Requirements 

Minimum System Requirements – PC Compatible 200MHz or faster processor 
(600MHz recommended), Windows XP Professional, XP Home, 2003 Server, 
128 MB RAM (256 MB RAM recommended), 240 MB free disk space.  ***.NET 
v2.0 framework (available for download from www.microsoft.com/downloads 

Optional:   

• Approved scanner (e.g. Canon CR-55) 
• MICR-enabled printer 

 

Chapter 2: Installation 

This Chapter will guide you through the installation of Check 21 Taskmaster.   

Starting the Installation 

Place the Check 21 Taskmaster CD into your CD-ROM drive. Open the file and 
extract the attached zip file. (If you were emailed the application you may extract 
directly from the email.) Double click on the “setup.exe” file.   
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Welcome Screen 

You will now be presented with the opening welcome screen.  Please click Next 
to proceed. 

 

License Agreement 

The next step is the Check 21 Taskmaster License Agreement.  Please read the 
agreement carefully. 

 

To continue with the installation, you must check the “I Agree” box.  Click Next to 
proceed to the next step.  Clicking I Do Not Agree will end the installation 
process.   
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Customer Information 

You will now be presented with the Customer Information Screen. Please fill in 
the appropriate information.  You will need to enter the serial number that was 
provided to you upon purchase.   

 

After entering the necessary information, click Next to proceed. 

Select Installation Folder 

The next step is to determine where you install the software on your computer.  It 
is strongly recommended that you choose the default location. 
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You will also choose who will be allowed access to the program on this 
computer. When finished, click Next.  

Confirm Installation 

The installer is ready to begin, simply click Next to install Check 21 Taskmaster.   

Installation Complete 

The installation of Check 21 Taskmaster is now complete.  

Importing License Files 

 In some versions of Check 21 Taskmaster a license file may be required for 
activation.  Upon opening the application you will be presented with a screen 
asking for a valid license file. 

 

 Please contact your Invoke Technologies Sales Representative with your 
Product ID and the Installation ID provided.  The Sales Representative will then 
email you with a license file unique to your computer.  Click Import License File 
to import the license.  You will then be asked to close out the application.  Upon 
reopening, you will have full access to Check 21 Taskmaster.  You are now 
ready to begin working with X9.37/X9.100-180 files! 

Additional Plug-in Installation 

To install any additional plug-ins (e.g. Canon CR-55 Check Scanner), simply 
extract all files from the plug-in zip files (e.g. “Canon_CR55_v2.2.0b.zip”)  to the 
installed location of the previous installation, the Check 21 Taskmaster folder 
(“C\Program Files\Invoke Technologies\Check 21 Taskmaster”). 
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Chapter 3:  Using Check 21 Taskmaster 

This chapter will help you use the Check 21 Taskmaster.  To run the Check 21 
Taskmaster either click on the desktop icon or go to: 

Start>Programs>Invoke Technologies, Inc>Check 21 Taskmaster 

3.1 Opening Items 

To open an X9.37/X9.100-180 file, click the Open icon in the top left corner, or 
go to the File menu and choose Open.  Choose an X9.37 or X9.100-180 file and 
click Open.   

 

 

3.2 Viewing Items 

To view an X9.37/X9.100-180 file after it has been opened, click on the 
Expansion symbol (+) next to the File name, Cash Letter, and Bundle, all the way 
down to the individual Item.  Click on Image to view front and back images.  Click 
on Image View Detail Record to view image details.   
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3.3 Viewing Records 

Records can be viewed by clicking on the appropriate record in the hierarchy. 

 

3.4 Searching for Items 

To search for an item, go to Edit and choose Find.  A new box will open allowing 
you to choose to search by either item number or amount.  Fill in the boxes and 
click Find Next.  The Check 21 Taskmaster will automatically locate the items. 
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3.5 Printing Substitute Checks (IRDs) 

To print a substitute check, click on the item you wish to print.  Then click the 
print icon, or go to File>Print IRDs.  A standard print window will open.  Select 
the options you want and hit OK. 

 

A new window will open asking for information about the IRD creator.  You will 
need to choose whether the item is a Substitute Check, a Photocopy in Lieu, or a 
Notice in Lieu of Return.  If you are also the truncator or your endorsement 
already exists you will need to check the boxes indicating this.  You may also 
need to input your Routing Number as Creator and/or a sequence number.   

 

***Please note: To print valid IRDs, you will need to use a printer equipped with 
MICR-ink 
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3.6 Editing Records  

To edit a record field, simply choose the record to be edited, and double-click on 
the desired field.  Make any necessary changes and then hit Enter.  To save 
these changes, go to File>Save.   

3.7 Importing Items 

To import items from a Check 21 Taskmaster-compatible device, it is necessary 
to have the custom plug-in for this device.  To import, turn on your scanner and 
make sure it is selected in the drop-down box at the top of the Check 21 
Taskmaster.  Click the Import icon located next to the device name. 

 

A new box, Import Parameters, will pop up, in which you will have to provide 
information.  Fields marked with an asterisk (*) are required.  Fields are required 
in the File, Cash Letter, Bundle, and Item Parameter fields.   

 

These fields will assure that the proper endorsements are marked upon the item.  
When all require fields are filled, place your items in the scanner and click Start.  
The items will then begin scanning.   
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When finished scanning, click Done.     

3.8 Appending to Files 

Check 21 Taskmaster’s File Append function allows you add on to files you 
saved earlier.  To Append click on the Import icon.  A pop-up will appear asking 
if you would like to append to the current file. 

 

Select Yes and you will be presented with the Import Parameters screen.  Verify 
that all the information is correct and import the items as described above.  When 
you are finished, save the appended file.   

3.9 MICR Keying 

To be a valid X9.37/X9.100-180 file, certain information must be input into the 
file.  The Check 21 Taskmaster includes a handy keying tool to assist in this.  To 
utilize this tool go to Tools > MICR Keying.  This will open a new window 
displaying two MICR lines, an Original line (as read by the scanner) and a 
Corrected line. 
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Use this window to double check the MICR line and input the item amount.  To 
move on to the next item simply click Next.  This will take you to the next item in 
sequence.   

   Auxiliary On-Us Field 

  External Processing Code (EPC) Field 

      Routing Number Field 

  On-Us Field 

     Amount Field 

Should you discover you have made an error on an item, simply click Cancel, 
find the item and correct it in the method described below.  When you return to 
the MICR Keying tool, it will pick up where you left off.   

***Please Note: Following keying, the Check 21 Taskmaster will automatically 
calculate the total amounts for each Bundle, Cash Letter, and File, and display 
them in their respective Control Records.   

3.10 Verifying Data 

Items in blue should be checked for accuracy. 

Items in red require an input (if not using the MICR keying function.  If you are 
using this function, double check these fields for accuracy.) 
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3.10.1 Required Fields 

If you intend on transmitting the imported images, you must supply additional 
information.   

3.10.2 Information for File Control Record 

In this record, you must check the accuracy of the Cash Letter Count, the Total 
Record Count, and the Total Item Count.  Any necessary changes can be made 
by double-clicking the field, correcting the field, and hitting Enter.  You must also 
input the File Total Amount.  To do this, double-click on the amount. Enter the 
File Total Amount as a 16-digit amount, with no dollar signs ($) or decimal points.  
For example, $7230.20 will be entered as 0000000000723020.  Then hit Enter to 
make the change.   

 

 

3.10.3 Information for Cash Letter Control Record 

In this record, you must check the accuracy of the Bundle Count, the Items within 
the Cash Letter Count, and the Images within the Cash Letter.  You must also 
input the Cash Letter Total Amount.  To do this, double-click on the amount. Any 
necessary changes can be made by double-clicking the field, correcting the field, 
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and hitting Enter.   Enter the Cash Letter Amount as a 14-digit amount, with no 
dollar signs ($) or decimal points.  For example, $7230.20 will be entered as 
00000000723020.  Then hit Enter to make the change.   

 

3.10.4 Information for the Bundle Control Record 

In this record, you must check the accuracy of the Items within Bundle Count, 
and the Images within the Bundle Count.  You must also input the Bundle Total 
Amount and the MICR Valid Total Amount.  To do this, double-click on the 
amount. Any necessary changes can be made by double-clicking the field, 
correcting the field, and hitting Enter.   Enter the amounts as a 12-digit amount, 
with no dollar signs ($) or decimal points.  For example, $7230.20 will be entered 
as 000000723020.  Then hit Enter to make the change.   

3.10.5 Information for the Check Detail Record 

For this record, you must check the MICR line values for the Payor Bank Routing 
Number and the Auxiliary On-Us field (if applicable).  The On-Us field should also 
be verified.  Should any corrections be necessary, correct the field and hit Enter.    
***Please note:  no On-Us symbols are used, the only non-numeric symbol is the 
forward slash (/) used to separate the account number from the check sequence 
number.   

The Item Amount should be entered as a 10-digit amount at this time.   
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3.10.6 Check Detail Addendum A Record 
 
Three more fields must be filled in to provide a valid file that may be turned into a 
Substitute Check (IRD).  These fields are the Bank of First Deposit (BOFD) 
Routing Number, the BOFD Business (Endorsement) Date (entered as 
YYYYMMDD), and the BOFD Item Sequence Number. 
 
 
3.10.7 Optional Information 
 
There are several other fields in each record type that are optional.  These may 
be manipulated in the same way as other fields, as you so desire.   
 
3.10.8 Saving Changes 
 
All changes must be saved before they become permanent. To save, go to 
File>Save.    
 
***Please Note: The file must be saved as an X9.37 file, e.g. sample.x937  
 

 
Chapter 4:  Company Information 
 
Technical Support 
 
For technical support, please call (816)569-0131 or email 
support@invoketech.com 
 
 
InvokeTech.com 
 
Please visit http://www.invoketech.com for the latest Check 21 products and 
information. 
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Chapter 5: Troubleshooting 
 
I can’t see any files in Check 21 Taskmaster. 
 
Are you working with X9.37/X9.100-180 files?  To use the Check 21 Taskmaster 
you must be using files in this format.  Have you opened the files using Check 21 
Taskmaster?  Go to File> Open and choose and X9.37 or X9.100-180 file to work 
with.   
 
I can’t use my scanner to import into Check 21 Taskmaster. 
 
Have you installed the scanner’s API?  If you are using a scanner compatible 
with Silver Bullet’s Ranger API, install Ranger and then copy the necessary .dll 
files into the Check 21 Taskmaster’s Program file (usually C:\Program 
Files\Invoke Technologies\Check 21 Taskmaster). 
 
When I try to import items, the Import Parameters window opens briefly, 
and then closes. 
 
Is your scanner turned on?  Is it properly connected to your computer? Check 
these and try again. 
 
When I try to print IRDs I receive a message about an invalid date. 
 
Check that item’s Check Detail Addendum A Record.  Is the BOFD Business 
(Endorsement) Date in the proper YYYYMMDD format?  Have you included the 
Bank of First Deposit (BOFD) Routing Number?   
 
I can’t find the items I was working on. 
 
Maybe you’re looking in the wrong location.  Go to Start> Search.  In the “All or 
part of the file name” field, type .x937.  This will locate all X9.37 files on your 
computer.  Did you save the items?  Like a basic Windows application, data must 
be saved.   
 
The institution I’m forwarding files on to rejects the files I send as MICR 
data errors. 
 
Sometimes due to poor check quality or a dirty scanner, MICR lines will read 
incorrectly.  Use the MICR keying function to check and correct MICR data, or go 
to the Check Detail Record of a particular item and make any necessary 
changes.   
 


