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F1J1 AND KNIME






1.1 Aim

The aim of this session is to familiarise you with Image]/Fiji and KNIME. This introduction
session will be followed by three hands-on practical sessions on how to use these two tools
for analysis of microscopy data and we will have a closer look at different Fiji functions and
plugins, and several KNIME workflows.

1.2 Fiji

Fiji stands for “Fiji Is Just Image]". Image] is a public domain image processing and anal-
ysis program written in Java. It is freely available (http://imagej.nih.gov/i7/
index.html) and used by many scientists all over the world. There is a very active
ImageJ community and Image] is continuously improved. Fiji is a distribution of Image]J
together with Java, Java 3D and a lot of plugins organized into a coherent menu structure.

During this session we will have an introduction on the use of Image]J/Fiji for digital
image processing for life sciences, and also on how to write macros to analyze the data and
how to reuse code. So during the practical sessions you will write code using the macro
language but programming knowledge is not strictly required to follow the course.

Please refer to the homepage of Fiji for detailed documentation and user manual.
Additional handouts for the material used in this course will be distributed during the
session.

1.2.1 Installation and updates

After downloading Fiji installer, please follow the instructions from the Fiji page (http:
//fiji.sc/Installation) toinstall Fiji on your computer.

Fiji has an automatic update system invoked each time when you start Fiji, if there
are newly available updates. You can also configure your own updates by calling [Help
-> Update Fiji], and after checking for details, an ImageJ Updater window will
appear with the list of items to be updated or installed (Fig. 1.1 top). If you would like
to exclude/include specific items to be checked for update, or if you would like to add
new sites that are not listed, you could click Manage Update Site to configure them
(Fig. 1.1 bottom).

1.2.2 Plugins

Apart from the official plugins, there are many amazing plugins from a large community
contribution. Normally you need to download a specific plugin from their website, and
then copy it into the Fiji plugins folder. For example, for one plugin we will be using in this
course, 3D Image]J Suite (a package of multiple plugins): we can install it by downloading
thebundle fromhttp://imagejdocu.tudor.lu/lib/exe/fetch.php?media=
plugin:stacks:3d_1i7J_suite:mcib3d-suite.zip and unzipping itin the plu-
gins folder. And when we restart Fiji, the plugin should be found at [P1ugins -> 3D].
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FIGURE 1.1: Fiji Updater.

1.3 KNIME: Konstanz Information Miner

KNIME features a user friendly graphical interface which enables basic users to create
workflows for data analysis in a highly efficient manner. Each plugin is represented as a
graphical node which can be configured individually and connected with other nodes.

KNIME in general is a large data mining platform including diverse libraries for data
explorationlikeR (http://www.r-project.org/),Weka (http://www.cs.waikato.
ac.nz/ml/weka/), clustering, network mining, machine learning and many others en-
abling you to process multi-dimensional data tables in a highly sophisticated manner.

The basic idea is that - independent from the task - any kind of data is represented as data
points within a data table. In case of life science applications, e.g. image analysis, the data
points are indicated by features like intensity, size, shape, ... of objects.

KNIP (KNIME Image Processing) is a large image processing repository within KNIME
which is based on the ImageJ2 (http://developer.imagej.net /) image process-
ing library (ImgLib2: http://fiji.sc/wiki/index.php/ImgLib2). Functional-
ities as provided by Image]J/Fiji are executable within KNIME and there exists a strong
collaboration between KNIP and Image]J/Fiji.

Due to the possibility to create workflows, KNIME is suitable for data pipelines of any
kind incl. high-throughput data processing.
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1.3.1 Installation

You can download KNIME from here: http://www.knime.org/downloads/overview.
If you have problems with installation, we will install it during an installation session to-
gether. Additional repositories will be needed to be installed for running image processing
applications.

¢ Execute the KNIME download file in a directory of your choice

¢ Start knime.exe

You will be asked about the workspace-directory (this is the directory, where your
workflows will be saved by default). Choose a directory and enable 'Use this as the default
and do not ask again’.

¢ In the next dialog window click Open KNIME workbench. This is the KNIME
-desktop where you can configure and run your workflows

e Goto[Help > Install New Software...]andopenthelink“Available
Software Sites". Enable the three software sites as depicted in the image be-
low.

e Goto [File > Install KNIME Extensions...] and install the following
plugins:

1. KNIME Distance Matrix

2. KNIME External Tool Support

3. KNIME HTML/PDF Writer

4. KNIME Math Expression (JEP)

5. KNIME Nodes to create KNIME Quick Forms

6. KNIME XLS Support

7. KNIME XML-Processing

8. KNIME HCS Tools

9. KNIME Community Contributions - Imaging (entire package!)

-
e

KNIME Decision Tree Ensembles

—
—

. KNIME Textprocessing
12. KNIME Virtual Nodes

¢ ReStart knime.exe

z
=
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FIGURE 1.2: Snapshot of installation window: Available Software Sites.

1.4 Resources

Fiji related:

¢ CMCIImage] Coursepage: http://cmci.embl.de/documents/ijcourses

e CMCI Macro programming in Image] Textbook: https://github.com/cmci/
ij_textbook2/blob/master/CMCImacrocourse.pdf?raw=true

* Fluorescence image analysis introduction:http://blogs.qub.ac.uk/ccbg/
fluorescence-image—analysis—intro/

e mailinglist: imagej@list.nih.gov

e KNIP: KNIME Image Processing: http://tech.knime.org/community/image-

processing
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2.1 Aim

In this session, we will count spots in image regions, with two different methods using Fiji
and KNIME.

2.2 Introduction

In microscopy images, counting the number of objects is a rather common practice. When
the density of objects in the image is low and the objects are well separated from each
other, it is possible to count objects by first segmenting the objects and then perform a
morphological operation called connected components analysis. However, as the density
of the objects increases, such approach underestimates the number of objects due to
under-segmentation of clustered objects.

Dataset In this session, we will use the example image, Hela cells, in the Session3 folder
of the course material. You can also find it directly from Fiji sample data. This is a 16-
bits/channel composite color image of Hela cells with red lysosomes,

and blue nucleus. We will count the number of lysosomes in the whole image, find their
distributions in e.g. cell nucleus or user-defined regions of arbitrary shape.

2.3 AFiji solution

Before doing anything with Fiji, let’s first turn on the later-to-be your favorite function
Image] command recorder (P1ugins —-> Macros —-> Record). It magically records
operation you will be doing with Fiji, which can be turned into a macro script either directly
or with some modifications.

If you would like to get the image directly from Fiji, then click on [File->OpenSam
ples->HelaCells]. Since we are interested in counting red lysosomes spots (Fig. 2.1),
lets first split the channels using [Image —> Color -> Split Channels]. Or, just

openthe Cl1-hela-cells.tif from the session folder.
" L1 i eclismt -aEn - 1 e el 2 -aEn . Kessren L1 nete ceizin - aEN

FIGURE 2.1: (left) The lysosome channel of the Hela cells image from Fiji sample data. (middle)
estimated background using Gaussian smoothing. (right) The original image after subtracting the
background estimate.
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2.3.1 Detecting objects
2.3.1.1 Detecting and counting nucleus

Let’s first select the nucleus channel image C3-hela-cells.tif (Fig. 2.2), since we
are interested in the lysosomes inside the cell nucleus. This is a relatively “clean” image,
to detect the nucleus we can try just thresholding and play with different methods and
choose the best one, e.g. Triangle. Notice that the thresholded binary image is most
likely not exactly what we want, but with small objects and possibly holes (Fig. 2.3). In
such situations, a morphological opening operation can be used to clean up small ob-
jects. And for filling holes, a morphological closing operation can do the job. In this
case, we need morphological opening, which is completed in two steps: a [Process
-> Filters -> Minimumn]followedbya[Process -> Filters -> Maximum].
In order to bring the object shape back to its original size, the Radius value for both
filters should take the same value, e.g. 5.0 for this image. We can rename the image as
“nucleus_mask".

Question: How the operations of morphological closing can be done?

3 = EN

FIGURE 2.2: Nucleus channel FIGURE 2.3: Thresholded FIGURE 2.4: Cleaned mask

Now we can count the nucleus using [Analyze —-> Analyze Particles], even
though it is pretty easy to check by eye that there are 4 nucleus. We will set the options
Size,Circularity, Showto: 0-Infinity, 0-1, and Count Masks, respectively,
and verify thatAdd to ManagerisuncheckedwhileIn situ Showischecked. Then
we can click OK. In order to visualize the counted objects better, we could change the
lookup table (LUT) option, using [Image -> Lookup Tables] options. If you like,
we can also use the LUT file provided in your Session3 folder, “Random.lut". It should be
copied to the Image]J LUT folder. Once copied you should be able to find it in the Lookup
Tables list and apply it (see Fig. 2.4). This is because when the option Count Masks is
chosen, the mask image will result in an image with a different pixel value for each object.
If we toggle the mouse cursor in the object regions, we will find their values, or object
label or ID, displayed in the main Fiji menu. In this case, they should be 1-4 (and with zero
background).

2.3.1.2 Detecting lyososome spots

In the image Cl-hela-cells.tif, the blob-like highly-contrasted lysosomes spots
exist in some cloud-shape background. So the first step is to estimate and subtract the
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background. Since we need to subtract images, let’s first make a copy of the image by
running [Image -> Duplicate]. A typical approximation of such background is a
much smoothed version of the image. So we could try the following choices and see which
suits the best:

e runa Gaussian smoothing ((Process —> Filters —> Gaussian Blur])with
alarge Sigma value (e.g. 6.00) on the duplicated image.

¢ apply a morphological opening to the image. This operation is done through a Min-
imum filter ([Process -> Filters -> Minimum]) followed by a Maximum
filter ([Process —-> Filters -> Maximum])withthesameRadius (e.g. 6.00).
These filters have a Preview mode, which is helpful for choosing the satisfactory
parameter(s) for the filters.

SLOdS ONILLNNOD — ¢ H4LdVHD

Once having a good approximation of the background, we can subtract it from the original
image using [Process —> Image Calculator]with Subtract Operation. Al-
ternatively, instead of first estimating and then subtracting background from the original
image, we can also run [Process -> Filters -> Unsharp Mask] with a small
Sigma value (e.g. 1.00) and large Mask Weight value (e.g. 0.9) directly. And we should
be able to remove quite some cloud-like background signal and enhance signals of lyso-
somes.

Next, we will extract objects from the resultant “background-free" image. A first try
can always be getting the binary mask after a thresholding. For example, we can try
[Image —> Adjust —> Threshold]withthe Ot sumethod or other ones. And then
click Apply after we are satisfied with the thresholding to get a binary mask image. We
could see that from this image (Fig. 2.5 left), some spatially close spots are connected
and thus regarded as one object. So we would need to correct this undersegmentation
behavior. One common solution is to run [Process —-> Binary —-> Watershed].
As we see in Fig. 2.5 middle, it separates some clustered spots (indicated in red circles)
by a line with one-pixel width. It should be noted that the watershed method does not
always do the magic, and it works better for objects with more regular shapes and sizes.
After we managed to create a mask with one separate object for each spot, we could start
identifying each object. First, let’s run [Analyze -> Analyze Particles], After
verifying whether Size, Circularity, Show options are set to: 0-Infinity, 0-1,
and Nothing, respectively, and also Add to Manager is checked, then we can click
OK. A new window similar to Fig. 2.5 right should appear. The numbers indicate the object
(or ROI) ID. Let’s rename this image as e.g. “spots" using [Image —-> Rename]. And in
the ROI Manager window we can find the list of all objects.

2.3.2 Counting spots

We will practice counting the spots that we just extracted from the lysosomes channel in
two types of regions: nucleus and regions enclosed by mitochondria.

11



FIGURE 2.5: (left) The binary mask obtained from thresholding the background subtracted image.
(middle) The binary mask after applying a watershed operation so as to separate obvious connected
spots. (right) The labeled objects in the binary mask.

2.3.2.1 counting spots in nucleus

The trick to achieve this is to apply the lysosome ROIs to the counted nucleus mask

image, and then check the intensity of each ROI in this mask image, since the back-
ground and the four nucleus have different IDs. So let’s first go to [Analyze —-> Set
Measurements] and check only the Min & max gray wvalue and uncheck the rest.
Because we are interested in the maximum intensity value in each ROL

Question: Why are we interested in the maximum intensity value in each ROI?

We need to select the “nucleus_mask" window, and highlight all the listed lysosome ROIs
intheROI Manager window. Thenapply[Image —-> Overlay -> From ROI Manager].
Your nucleus mask image should look like Fig. 2.6.

Then we can measure the parameters we just set, by clicking Measure in the ROI
Manager window. The Results window is shown with three columns: object/ROI ID,
minimum intensity and maximum intensity. Now if we click [Results -> Distribution]
in the same Results window, and select Max as Parameter, and set specify bins
and range to 5 and 0-5, respectively, a Max Distribution window should appear
(see Fig. 2.7) with five bins/bars, whose heights indicate the number of ROIs with their
maximum intensity value between the range of each histogram bin. As we know that the
mask has intensity range 0-4, if the histogram bins are chosen such that each bin represents
the intensity range for each nucleus and the background (i.e. 1 intensity level per histogram
bin in this case), the histogram does the counting for us. That’s the reason for specified
values for bins and range.

In order to see the exact number of each counts, we can click List in the histogram
window, and a two-column table similar to Fig. 2.7 will appear with the intensity value
column indicating the nucleus ID, and the count column showing the number of ROIs.

2.3.2.2 counting spots in regions where mitochondria also presents

Similarly, if we are interested in counting spots in the regions covered by mitochondria,
we can perform similar steps but on the mitochondria channel (C2-hela-cells.tif).
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Instead of using some filters to extract such regions, we will practice with manually draw-
ing a contour of the region of interest using the Freehand selections tool (see Fig. 2.8).
In previous steps, the counting was done through computing histogram from the labeled
mask image. Similarly, a mask image is needed here. So we will create a new mask image
from the manual selection. There are many options to do so, and a few of them are listed
below:

* A new image of the same size is created using [File -> New -> Image] and
renamed as “mito_mask". It will create a black image, and when we run [Edit—->S
election->RestoreSelection], the manually drawn region contour on the
mitochondria channel will be “translated" to the new image. Then the pixel values
inside this region should be modified to distinguish it from the dark background,
using:

- the command [Edit -> Fill]. The filled region will have a value higher
than the zero background, e.g. 85 (see this image in Fig. 2.9).

- thecommand [Process -> Math -> Add], and we can decide which value
to add to the new image for the selected region.

¢ After manually drawn region, we run [Edit->Selection—->CreateMask], a
new binary image with the same dimension is created, with the manually drawn
region highlighted (i.e. 255) and the rest being 0.

The next steps are similar to what we have done in the previous section thus please
refer to it for detailed descriptions. One example result is shown in Fig. 2.10. Please note
that since there are only two values in the image (0 and 85), then we could have many
histogram bin distribution options, as long as 0 and 85 are in separate bins.

In case of multiple regions to be measured, we could hold the “shift" key while drawing
multiple regions, and thenrun [Edit->Selection->CreateMask]. Oruse[Process
-> Math -> Add] each time after drawing one region. If different values are added for
each region, then a labeled mask image is created directly.

2.3.3 Convert the recorded commands into a macro script

We will clean up the commands recorded from the beginning so as it becomes a reusable
macro script for other datasets. Actually if it makes things easier, you could clean it parts
by parts throughout the recording period, which we will be doing so during the session.
Cleaning up mostly involves: deleting mistaken commands, specifying selections like se-
lected windows or images, replacing certain parameter settings by variables with values
specified once manually or through programming. We will gradually practice this during
the whole course.

The macro code obtained and cleaned up from the Image] command recorder (P1ugins
-> Macros —> Record) is provided in the Session3 folder.
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2.4 KNIME solution

This session is divided in two parts: The first one [ Session3a_SpotsInNuclei ] detects
nuclei and spots inside the nuclei without taking care of surrounding regions, i.e. mi-
tochondria. The second one [ Session3b_SpotsInNucleiSurroundings | provides the full
solution including spots in mitochondria.
Nomenclature: In the following, the expression node-name || configl | config2

| ... defines a KNIME -node and the corresponding configuration. Please note,

that only configurations which differ from the default node configuration are mentioned.

Apart from that the full node details will not be described. For this please have a look at

the node description of the KNIME software.

2.4.1 Spotsin nuclei

Open the workflow [ Session3a_SpotsInNuclei ].

A5 0: Sessienla_SpotslnMuclei £

4}
hell

FIGURE 2.11: KNIME workflow *Session3a_SpotsInNuclei*.

After injecting the images into the workflow via the Image Reader node, the
Column to Grid || Grid Column Count: 2 node transfers the table from a
[1 column / 2 rows] into a [2 columns / 1 row] table. This procedure enables to rename the
two images column wise into *Spots Channel* and *Nuclei Channel*.

Within the Image Processing MetaNode we use two different branches and methods
resp. to segment the images:

* Nuclei as performed in the INTRO session

* Spots are detected using the node Spot Detection || enable wavelet
level 0...:2 | disable wavelet level 1... | disable wavelet
level 2...

We then combine the results of this first image processing step using the Joiner
node. The result looks as follows (Fig. 2.13):

Since we are interested in spots within the nuclei we can merge the two labeled im-
ages *Compose Labeling(Bitmask)* (nuclei) and *Spots Channel_thresh* (spots) using the
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FIGURE 2.12: Content of the Image Procesing MetaNode: The upper branch segments the nuclei.
The lower branch calculates spots segments.

Spec - Columns: 3 | Properties | Flow Variables|
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Rowd . .

FIGURE 2.13: Result of the Image Processing MetaNode.

Labeling Arithmetic || Method: Merge node.Resultingwe obtainan over-
lay between the segmented spots and nuclei (Fig. 2.14):
Using anew functionalityinthe Image Segment Features || Segment Settings:

enable xAppend labels of overlapping segmentss* node allows usto ex-
tract information about objects which overlap. In our case these are the spots within the
nuclei. The information is listed in the results table of the Image Segment Features
node in the *LabelDependencies* column. L.e. that a segment (=spot) with Label xxx in the
first image overlaps with a segment (=nucleus) of the second image in case of a positive
*LabelDependency* entry.

The following Row Filter node filters out the positive matches of *LabelDepen-
dencies* providing the result as follows (after executing the visualization steps) (Fig. 2.17):

After that we perform some basic statistics and obtain the overall results from the
image processing (Fig. 2.18):

The table lists the *Image Name*, the *spot labels*, the spot coordinates *[ X ]* and
*[ 'Y ]*, the spot *Area*, *Max* and *Mean* spot intensity and the *LabelDependencies*
enabling to assign each spot to the corresponding nucleus. In addition, the table contains
the *Bitmasks* and *Source Labeling* of each of the spots in case that you are interested
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FIGURE 2.14: Result of the Labeling Arithmetic node: Overlay of the nuclei and spots
segments.

. S—— | '= % |
Dialog - 0:1046 - Image Segment Features(Calculate features) — = J

File

Column selection | Segment Settings | Features | Flow Variables I Memory Policy
Settings

Append labels of overlapping segments
[ ©verlapping segments do NOT need to completely overlap
Append segment information

Filter on seq...

| :OR =

Filter averlap...

| [+ Jor ~

[ ok J[ sy [ cance |[®@

FIGURE 2.15: Configuration dialog of the Image Segment Features node. The *Append
lables of overlapping segments* flag provides information if a spot is located in a nucleus.

in visualizations.
Within the last step we perform some basic statistics *per object* / *per image* using
the GroupBy || ... node in order to obtain final numbers (Fig. 2.19):

For a graphical representation of the results we can e.g. usethe Histogram nodes
(Fig. 2.20):
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Table "default” -Rows: 332 | spec - Columns: 9 | Properties | Fiow Variables|

I Bimask [ § Label | S Source Labeling § LabelDependendies D Centroi... [ P Centroi... | D NumPix [ D Max | D Mean
55 Shela-cels. tfisour 3667 84.667 5 352 539.333
% i Shela-cels. tsour a5 872 [ 855 l660.
4 33 lir 3-hela-cells. tif;sourc 158.333 86.667 15 942 743.533
158 S-hela-cells. tif;sour 661 389 337.4
sl |34 hela-cels tfisour: 309,579 |1,8%5 1,316.658
RoW07158 }EE 3-helacels. tf;sour: 96 }E 189
Row0#33 39 3-hela-cells. tif;sourc 300.25 368 313
Row0#157 157 3-hela—cels. tif;sourc 543 828 628
Rowd#156 155 Shela-cels. tf;sour Nucleus_4 189 s58 745.923
37 i S-hela-cels. tif;soure 138.817 513 667167
155 3-hela-cells. tif;sourc 547.867 219.533 15 2,395 ILJFZZ
|38 S-hela-cells. tif;sour 333 88 1 302 302
Row0=154 154 3-hela-cells. tfsour Nudleus_4 189 218 1 610 610
Row0=152 152 3hela-cells. tifsour 117,167 219.833 18 1,798 1,365.833
153 3-hela—cels. tif;sourc 126,533 220,133 15 2,008 1,493.533
Row0#150 150 3-hela—cels. tif;sourc ,512 MNudeus_3 3418 215.5 0 891 548.7
Rowd#151 151 i Shela-cels. tsource=;di 512
43 i Shela-cels. tfsource=;di 512
%2 S hela-cels. tf;sourt 512
41 Shela-cels. tf;sourt 512
40 Fhela-cels. tfisour 512
202 hela-cels. tfisour 512
203 3-hela—cels. tif;sourc ,512
204 3-hela—cels. tif;source=;dimensions =672,512
205 i Shela-cels. i source=;d 512
Ll [200 i 3-hela-cells. if;soure i 512 517.93 [280.744 43 [2.863 2,057.442
[01 S-hela-cells. tif;sour 512 580.333 |275.667 3 [a12 350.333
o g e SGH Tren = o e 03 T Trea ms

FIGURE 2.16: Result table of the Image Segment Features node: The column *LabelDe-
pendencies* provides the information if a spot is located in a nucleus (of label x).

FIGURE 2.17: Outcome of the visualization steps: Overlay of image raw data and identified spots
within the nuclei.

Now we can proceed and extend the workflow towards the detection of spots within
mitochondria, i.e. nuclei surroundings.
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Table “defoult” - Rows: 35 | spec - Columns: 10 | Properties | Flow Variables|
Ron D § Image .. | § Spotla...| D [X] D (Y] D Aea D Maxnt...| D Meanl I_!_l._ﬁ Bitmask | § LabelD... |Sec Source Labeling
Cahelacells_|156 189 220,231 3 858 (745,923 Nucleus 4 3-helaCell 512
Cahelacells 154 189 218 il 510 610 Nucleus_4 3-helaCell 512
Cahela-cells_|150 ] 2155 w N 50,7 Nucleus 3 3-helaelk 512
Cahelacells 164 [508 2 1 608 l60s Nucleus_2 3-helaelk 512
Row0#219  [c3helacels 219 T71% By 7 [771 /640,357 Nucleus 4 3-helaelk 512
Row0#313  [C3helacels 313 376667 435.333 3 [t210 = Nudleus_12 3-helaelk 512
Cohelacells_|170 11451 235.667 2L 1,978 [158805 ' Nodeus_4 3-hela-celk i 512
Chelacells_|228 FLIRET) 341333 s 687 lgg £ Nodeus_# 3-hela—celk o 512
Chelacells_|326 7.8 w744 5 354 3616 [Nodeus_12 3-hela—celk o 512
Chelacells_|185 12833 2,167 iz }917 /825 417 Nodeus_# 3-hela—celk o 512 @)
Chelacells_|180 150.667 250.75 iz 555 7785 ] INodeus_% 3hela-cell o 512 o]
Cohelacells_[112 510 174 1 176 176 [Nudeus_2 3-hela-celk 512
Row0#118 _ [c3helacels |118 509,538 182.885 3 2,094 1474077} [Nudeus_2 3-hela-celk 512 %
Row0#83 C3helacells 83 503.273 141.091 i 877 /646364 i [Nudeus_2 3-hela-celk 512 =
Row086 C3helacells |86 288 144.25 8 775 73175 INodleus_3 3 hela-celk 512 =
ROWDZ72 Cahelacels |72 313 122 1 301 [301 [Nudeus_3 3-hela cell ,512 =
Row0#136  [Ca3-helacells Pse 509.143 196,714 7 |420 [370.143 [Nudleus_2 3-hela-cel ,512
Row0#63 C3-helacells |63 276.5 112 2 |20 |2s3 [Nudleus_3 3-hela-cel ,512 S
ROW0F143  [C3helacels |143 354 208 il 736 736 ucleus_3 3-helaell 512 |
Cahela-cells 09 1 505 505 Nucleus_2 3-helael 512
Cahela-cells 211 2 584 67.5 Nuleus_2 3-helaelk 512 e)
Cahela-cells 353214 409,071 1 959 [756.193 B Nudleus_12 3-helaelk 512
Cahela-cells %05 1 571 571 Nudleus_12 3-helaelk 512 o
Cahela-cells a7 i 629 l629 Nudleus_12 =C3-hela—cells tfjsource=jdmensions =672,512 =
3 helacells 325 ) 1,058 [B37.5 [Nodeus_12 3-hela—cell o 512 z
Rowd#277 __[Crhelaels F_ﬂ 01286 7 516 [#i0.az ucleus_12 3-hela—celk o 512 —
Chelacels 50 156.077 I 1,341 [1,003 Nodeus_2 3-hela—celk o 512 =
Chelacells |57 429621 6 2,285 ie67.212 K [Nodeus_12 3-hela—celk o 512 z
C3helacels |11 252,667 g 3 /698 Nucleus_4 S-hela-cclk 512 o]
Chela-cells 1 514 514 INudeus_% 3-hela-celk 512 w
Chela-cells 3 555 519.333 [Nudeus_12 3-hela-celk 512 -]
Chela-cells i 1,496 1,143,091 [Nudeus_12 3-hela-celk 512 o
Chela-cells 1 40+ 404 [Nudeus_12 3-helacelk 512 (X, —
Cahela-cells 17 1176 962,234 Nucleus_12 3-helaell 512,000 (%]
Cahela-cells il 77 177 Nucleus_12 3-helaCell 512,000

FIGURE 2.18: Result ofthe Column Resorter node.

File
able "default™ - Rows:

Spec - Columns: 3 I Properties I Flow Variables

Row ID S Image... | § Mudeus | #Spots

Row0 C3-helacells |Nudeus_12 (13

Rowl C3-hela-cells  |Nudeus_2 [

Row2 C3-hela-cells  |Nucleus_3 5

Row3 C3-hela-cells  |Nudeus_4 9
File
iTable "default” - Rows: 1 | Spec - Columns: 4 | Properties | Flow Variables|

Row ID S Image ... | D Mean (I...| D Mean (... | | #Spots

. Rowd C3-hela-cels  [696.618 3.943 35

FIGURE 2.19: Overall results.

2.4.2 Spotsin nuclei surroundings

Open the workflow [ Session3b_SpotsInNucleiSurroundings ].

The only difference is given by an additional branch in the Image Processing MetaN-
ode which is defined by the Voronoi Segmentation node (Fig.2.21):

The Voronoi Segmentation || ... node is normally used to segment
cytoplasm regions based on certain intensity levels.

However, we can use this node to detect the mitochondria areas. As input the node
requires for a mask which acts as the region where surroundings have to be detected
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Histogram View - 0:1058 - Histogram B

File

)
!

Nucteus_12 Nucleus 2 Nusteus_3 Nucleus_4

Settings | Bin settings | Visuaization settings | Detais|

Binning column: Nudeus

FIGURE 2.20: Histogram of the outcome of the upper GroupBy node. Shown is the number of
spots per nucleus.

A 0: Session] i1b ¢ |45 0719 - Image. ng 3

FIGURE 2.21: The modified Image Processing MetaNode. The additional branch (including the
Voronoi Segmentation node)segments the nucleisurroundings based on the mitochondria
intensity.

(*Seed regions* in the configuration dialog). In our case this mask is given by the nucleus
segmentation. The corresponding surrounding (Voronoi-) regions are calculated by using
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the image raw data of the mitochondria channel which contains the information of the

pixel intensity values (Fig. 2.22): _
Dialog - 0:719:541 - Voronoi Segmentation(Segme.. == |

File

Options | Figw Variables I Memory Policy |

Image to work on: !:,E Mytochondria Channel
Seed regions: _Sr: Compose Labeling(Bitma...
Background threshold: | 400

[¥] Fill hioles

Result column 'Complete segmentation -

Dimension Selection [ X .] [ ¥ .] [ z .l I Channel .l [ Time .l

QK l I Apply ] [ Cancel l

FIGURE 2.22: Configuration dialog of the Voronoi Segmentation node.

Bychangingthe Voronoi Segmentation || Background threshold
values the surrounding region of interest can be defined based on intensity values of the
image raw data. The result of the Voronoi Segmentation node looks as follows
with the surrounding regions/segments in the last column (Fig. 2.23):

I Mytochondria Channel

S Segmentation

Row ID Spr Compose Labeling(Bitmask)

ar ‘ .

FIGURE 2.23: Result of the Voronoio Segmentation node: The Voronoi regions, i.e. nuclei
surroundings are depicted in the last column.

Accordingly to session 1a, we can run the following nodes in order to finalize the story.
Please note that the label *Nucleus_x* in the *LabelDependencies* column now stands for
the entire Voronoi region, i.e. surroundings plus corresponding nucleus!

2.5 Tips and tools

¢ Search for commands in Fiji: select Fiji general interface, then hit the “L" key (or
sometimes in MAC OS “command+L" key)
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¢ ImageJ command recorder: Plugins -> Macros —> Record

2.6 Groups close by which work on similar problems

¢ Prof. Fred Hamprecht’s group, Multidimensional Image Processing Group (http:
//hci.iwr.uni-heidelberg.de/MIP/),located at HCI, Speyererstr. 6
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2D+TIME TRACKING






3.1 Aim

In this session, we will perform 2D+time tracking on objects of interest with two different
methods: Fiji and KNIME. And further tracking results analysis of plotting trajectory on
image and drawing displacement or velocity plot will also be done.

3.2 Introduction

Time-lapse experiments play a crucial role in current biomedical research on e.g. sig-
naling pathways, drug discovery and developmental biology. Such experiments yield a
very large number of images and objects such as cells, thus reliable cell tracking in time-
lapse microscopic image sequences is an important prerequisite for further quantitative
analysis.

Dataset The dataset we will use (“mitocheck_small.tif") is kindly provided by the pub-
licly available database of the MitoCheck project (http://www.mitocheck.org/).
One of the focuses of the MitoCheck project is on accurate detection of mitosis (cell divi-
sion). Please refer to [1] for more details of this project.

3.3 AFiji solution

Let’s load the “mitocheck_small.tif" 2D+time image. The very first step is to segment, or
identify, objects (cell nucleus in this case) in each time frames. This step can be done by
first smoothing a bit the stack to homogenize a bit the intensity within each object using
[Process -> Filters -> Gaussian Blur] by a Sigma value of e.g. 2.0. Please
note that although we are smoothing the whole stack, this 2D filter applies to each slice, or
time frame, independently. Since the background is quite clean, a simple thresholding is
probably good enough to segment the objects. You can choose your favorite thresholding
method and set the best threshold value, e.g. with the Default or the Moments method,
and with min and max threshold value set to 15 and 255, respectively. Probably there will
be merged objects, sowe canrun [Process —-> Binary -> Watershed]to splitthe
most obviously wrongly-merged ones. We could also run [Process —-> Filters ->
Minimum] with Sigma of 1.0 to shrink a little bit the obtained binary mask. This is to avoid
merging of close neighboring objects in 3D in further steps, and also to correct possible
dilation of objects due to the Gaussian blur filter. If we wish, a second Watershed operation
can be applied afterwards to further split potential wrong merges.

Suppose that we have so far obtained a binary stack containing the segmented cell
nucleus. Next, we will track, or link, the same object in consecutive time frames. The
final result will be a label stack where each object is identified (filled) by a unique label
along time (indicated by a distinct gray level intensity value). The strategy we employ
here is based on the overlap of the same object in temporal space between two con-
secutive time frames. If we consider time as the third dimension, cell spatial overlap
along time translates to the connected parts in the third dimension of a 3D object. And
Fiji’s [Analyze -> 3D Objects Counter] does the job of finding such connected
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FIGURE 3.1: An example MitoCheck image (first frame) and the first five frames of the tracked
objects (in different colors), using our Fiji solution, overlaid on the original image stack.

components in 3D. This function works similarly as the 2D one we are familiar by now -
[Analyze -> Analyze Particles]. It canidentify and count 3D objects in a stack,
quantify each object’s properties (see the full list in [Analyze -> 3D OC Options])
in a table, and generate maps of specified results representations. Once the 3D objects
are 3D labeled, we can apply the Random LUT in the [Image -> Lookup Tables]
to visualize better individual objects. We could also merge the label stack with the origi-
nal stack to check results, using [Image -> Color —-> Merge Channels]. Youcan
specify the two stacks in two of the available channels. And by unchecking the option
"Ignore source LUT", it allows keeping the random LUT in the label channel thus
colored IDs after merging. In Fig. 3.1 the first five frames of the objects (with their identity
labels shown in random color) are shown.

Please note that the method we use here works properly only in cases: where single
objects has spatial overlap in temporal space between any two consecutive time frames;
and also a single object at a later time point does not overlap multiple objects at an ear-
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lier time point. If there is no overlap, or connection between two consecutive frames, then
a new label will be assigned to the same object in the latter frame, since it is considered
as another object just showing up. One example can be found in Fig. 3.1. The two objects
colored in orange and purple at the upper right corner of the last frame are split from the
purple one in the previous frame. So both should haven been assigned the same identify
(i.e. purple), but since the orange one has no overlap with its previous time frame, a new
identity is assigned instead.

3.3.1 Other possibilities to solve tracking problem

An alternative to the 3D Object Counter could be Plugins -> Process -> Find
Connected Regions. It sometimes could be faster than the 3D Object Counter and
sometimes has better options (like starting from a point selection), but also lacks some
flexibility.

There are other advanced tracking tools (included in Fiji or downloadable as Fiji Plug-
ins) available suchas [Plugins -> Mosaic -> Particle Tracker 2D/3D]'and
[Plugins -> Tracking -> TrackMate]. These trackers are however optimized
for spot-like particle tracking, the linking is hence performed over a list of spot positions
(spots detected in each frame). The tracking can be either straightforward (e.g. linking a
spot to the closest spot in the next frame), or with algorithms that can handle cases when
splitting and merging events occur.

If the cells, or objects of interest, resemble ellipsoids and are sufficiently separated
these trackers might perform well provided the parameters are properly adjusted. For
a densely packed scenario, or for more irregular object shapes, a possible strategy is to
firstly perform a specific segmentation and generate a map showing for instance the ob-
jects centroids, and then apply the spot tracker on the centroids maps. For those who
are interested in, an example on multicellular movement in Drosophila with detailed ex-
planation can be found in the Biolmage Data Analysis Course at EuBIAS 2013 (http:
//eubias2013.irbbarcelona.org/bias-2-course).

3.4 Tracking analysis in Fiji: plot trajectory, displacement, or velocity

Once the objects are correctly identified and tracked along time, we could do some further
analysis such as extracting trajectories (Fig. 3.3) and calculating displacements and veloc-
ities (Fig. 3.4). We will now find out how to do this in Fiji. In this practice, we will write our
own Macro script. By now, we are at ease with the great function Plugins -> Macros
—-> Record. Next we will try to take advantage of some Image]J built-in functions. Please
note that the plotting functionality in Fiji is probably not amongst the most powerful and
versatile ones, but it still can manage basic demands. We would like to introduce it as a
quick checking means before going for more complex scenes.

Let’s treat each object as a rigid body, meaning that everywhere inside the object has
exactly the same dynamic behavior. Therefore, we could simplify the problem and look at
just one specific point of the object. Good candidates could be the centroid and center of

ldownload site: http://mosaic.mpi-cbg.de/Downloads/Mosaic_ToolSuite. jar
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FIGURE 3.2: Example Results window of the first slice/frame showing the requested measure-
ments values from all objects in this slice.

mass. Let’s take the centroid as example for illustration. The task now is to obtain a list of
the centroid coordinates in every slice where the object of interest is present. This means
that each slice of the original stack should be processed individually. Beware to process
the correct slice/time and record it to the correct time indices of centroid coordinates. To
this purpose, use the built-in macro function setSlice(). A for loop could be implemented
to go through all the slices, using nSlices, a built-in macro function returning the value
of the number of slices (or frames) of the active stack. In order to obtain object centroid
coordinates, we could use the Analyze Particles command to extract objects and
checkthe CentroiditemintheAnalyze -> Set Measurements optionswindow.
Additionally, in order to know which extracted centroids is the current object we are inter-
ested in, we should also check Min & max gray value in the same Analyze —->
Set Measurements options window. Since in previous steps we have identified the
objects over time through assigning each object a unique intensity value as its label ID,
then by checking the min or max gray value of this label image tells us which object cen-
troid we should be look for in each slice. When we run Analyze -> Measure or click
Measure directly in the ROI Manager window, the checked measurements items will
be displayed in a table shown in the Results window (Fig. 3.2). In order to retrieve the
table information, the built-in functions getResult and nResults can help, where getRe-
sult(“Column", row) returns a measurement from the Result s table of in total nResults
rows. For example in Fig. 3.2, getResult(“X", 16) will return value 161.52, which is the
value of the last but also the nResults®! row (where nResults=17 but it is indexed as 16
since the first row has index of 0). Once we identify an object with its ID specified by the
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intensity value in the label image, we can go through the objects list in the current slice
and look for it, using an if sentence to check this condition by comparing the ID values -
“Max" value (in this case “Min" or “Mean" values are also fine since they have the same
value). And once the condition is met, the centroid coordinates can be obtained by getting
the Columns “X" and “Y".

The following piece of the source code shows the corresponding part that implements
the steps described above. The mentioned built-in functions are highlighted in brown
color. Please note that we clean up the Results table and the ROI Manager after
finishing checking each slice.

//The object of interest, specified by "objID"
objID = 16;

//Define and initialize an array with a time flag for each frame, whether
the object "objID" is shown

objShowTime = newArray(nSlices);

Array.fill (objShowTime, 0);

//Define and initialize two arrays to store the centroid coordinates in X
and Y axes

objCenterX = newArray(nSlices);
Array.fill (objCenterX,-1);
objCenterY = newArray(nSlices);

Array.fill (objCenterY,-1);

//Check the measurements options, i.e. min & max gray value and centroid
run ("Set Measurements...", " min centroid redirect=None decimal=2");

for (i=1;i<=nSlices;i++)
{
//Select the binary mask stack image, with image ID "cpID", and get the
slice i
selectImage (cpID);
setSlice(1i);
//analyze the regions of each object in slice i, and add the regions to
roiManager, to obtain ROI selection
run ("Analyze Particles...", "size=0-Infinity circularity=0.00-1.00 show=
Nothing add");

//We would like to measure the min/max gray value in the object label
image so as to get object "objID"

selectImage (1blID);

setSlice(1i);

roiManager ("Measure") ;

//Going through all the shown objects in the current slice to look for the
object with "objID"
for (3j=0; j<nResults; j++)
{
current_objID=getResult ("Max", 3Jj);
if (current_objID==0bjID)
{
print (current_objID);
objShowTime [i-1]=1;
objCenterX[i-1]=getResult ("X", 3J);
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)

objCenterY[i-1]=getResult ("Y", 3J);
}
}

//Clean up, for each slice, the Results table and also the ROI Manager
run ("Clear Results");

selectWindow ("ROI Manager");

run ("Close");

3.4.1 Plot trajectories on image

In this exercise, we aim at practicing Image]J built-in functions to extract measurements
from the Results table and further plot object trajectory on image. For illustration, the
simplest situation of plotting one trajectory from a single object at a time is considered.

In Fiji, we could use the built-in function makeLine in order to plot the trajectory
of the centroid positions overlaid on the image (e.g. the first frame or the first frame
when the object shows up). Since this function only takes integer pixel positions, the
function floor is used to always take the integer part of the coordinates and omit the
decimal part. The code below realizes the trajectory we want to plot. It should be inside
a for loop since it prints the trajectory segment by segment between two consecutive
centroids. The Properties command configures the line appearance. And we need
the ROI Manager to keep every line segment on display. Is there any special attention
we should pay to the ROI Manager?

makelLine (floor (objCenterX[i-1]), floor (objCenterY[i-1]), floor (objCenterX[i]),
floor (objCenterY[i]));

run ("Properties... ", "name=[] position=none stroke=Red width=2");

roiManager ("Add") ;

An alternative is the makeSelection built-in function with polyline type, which
does not need to plot line segment by segment but rakes the coordinates arrays.

Fig. 3.3 shows four examples of trajectories overlaid on the mask image. The source
code can be found in the Session4 folder (“Tracking measurements.ijm"). How fo plot
multiple trajectories in one goal is left for those who are interested to practice yourselves
after the course. Also, The Fiji built-in functions “Overlay" is an alternative to display
trajectories. We will also leave it for your own exploration.

3.4.2 Plot displacements or velocity

Examining the object displacements or velocity changes is another interesting measure-
ment for tracking studies. Since we have already obtained the centroid position at each
time frame, then the displacement of the centroid point from one time point to the next is
the distance between the two positions. The displacement is the square root of the sum of
squared difference between each coordinates of the points, which is calculated as shown
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FIGURE 3.3: Example trajectories (marked in red lines) of object centroid movements.

in line 3 of the code below, in our case. The built-in function sgrt calculates the square
root of a given number. The displacements over time can be stored in an array, “disp",
which starts with one array element and keeps growing. This is because we do not expect
to know in advance the temporal span of each object. Line 6-13 shows how the array
element grows. In the code a flag “arrayOK" is used, what is its use?

disp = newArray(l);
arrayOK = false;

current_disp = sgrt( (objCenterX[i]-objCenterX[i-1]) x (objCenterX[i]-
objCenterX[i-1]) + (objCenterY[i]-objCenterY[i-1]) * (objCenterY[i]-
objCenterY[i-1]) );

//store the current displacement into the arry "disp"

if (arrayOK)

disp = Array.concat (disp,current_disp);

rray.fill (disp, current_disp);
arrayOK = true;

And if the time interval is known, the displacement divided by the time interval gives the
velocity. Image]J offers the Plot functions to create a window showing a plot. Use it like
this:

//Set the right time frame xCoord for the plot.

//startFr and endFr mark the frames when the current object shows up and
finishes

xCoord = newArray (endFr-startFr+l);

for (i=startFr;i<=endFr; i++)

{

xCoord[i-startFr]=1i;

ot.create ("Fancier Plot", "Frame", "Displacements (pixel)");
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//Set the display range of each axis.

//maxY is the maximum displacement of the current object from array disp
Plot.setLimits (0, nSlices, 0, maxY+1l);

Plot.setLineWidth (2);

Plot.setColor ("lightGray");

Plot.add("line", xCoord, disp);

Plot.setColor ("red");

Plot.add("circles", xCoord, disp);

Plot.show();

And Fig. 3.4 shows four examples of such plots from the corresponding objects shown in
Fig. 3.3. Despite of the noisy profile, the differences in terms of amplitude and pattern are

discernible.
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FIGURE 3.4: Example displacements of centroids from the four objects as in Fig. 3.3 (order:
right and top to bottom).

3.5 KNIME solution

Open the workflow [ Session4_Tracking ]:

3.5.1 Image processing

By default the loaded image data provides the dimensions X, Y, Z. We can use the
Image Metadata || Label of dimension 2:
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FIGURE 3.5: Image Processing part of the KNIME workflow “Session4_Tracking".

the metadata subset *Z* to *Time* (Z is our tracking, i.e. time dimension). After ap-
plying basic and already known image processing steps the Connected Component
Analysis node is used in the same configuration compared to the sessions before,
meaning that each object is identified separately plane by plane (Z / Time dimension). In
order to obtain the object tracks we have to identify the same objects between different
planes, i.e. we have to assign the same label for an object during Z / Time. This can be
done using the LAPTracker node (Fig. 3.6):

Dialog - 0:2 - LAPTracker (TrackMate) TRACKING I) [E=N N

ONDIOVYL HNIL+(J¢ — € HdLdVHD

File

Options | Advanced | Column Settings | Flow Variables | Memary Policy

Basic

Algorithm MurkresKuhn = |
Maximum Object Distance 15,05
Tracking Dimension Time

Splitting
[7] Allow Spltting
Max Distance | 15,05
Merging
[#] Allow Merging

Max Distance 15,0 %

Gap-Closing

[] Allow Gap Closing
Max Distance | 10,05

Max GAP Size (Frames) 5p

ok [ sy ][ concal

FIGURE 3.6: Configuration dialog of the LAPTracker node.
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The configuration is very simple. The tracking dimension has to be set to *Time* and
since we have to deal with dividing objects (nuclei) we have to enable the *Allow Splitting*
and *Allow Merging* flags. The *Allow Gap Closing* flag considers objects which are not
visible continuously during time (e.g. out of focus or outside the ROI for a certain number
of Z planes / Time Points). You can set the maximum distance you would like an object
to allow to displace during this time (*Max Distance*) and the number of maximum time
points the object is not visible (*Max GAP Size (Frames)*).

Please note: Choose your settings very accurate! The best is to try different settings
and to check which setting fits best to your data set / objects.

By comparing the outcome of the Connected Component Analysis and LAPTracker
nodes you can directly see the difference in the object’s / label assignment. The Connected
Component Analysis node provides different labels (cp. colors) for the same nu-
cleus between different time points. In contrast, the same nucleus has the same label in
the outcome of the LAPTracker node, i.e. this objectis tracked during Z / Time.

FIGURE 3.7: Result of the Connected Component Analysis node: The nuclei have differ-
ent labels (cp. colors) between different time points (left: time point 1; right: time point 2), i.e. the
objects are considered as being different.

FIGURE 3.8: Result of the LAPTracker node: The nuclei have the same label (cp. colors)
between different time points (left: time point 1; right: time point 2), i.e. the objects are considered
as being identical and thus tracked during Z / Time.
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With the outcome of the LAPTracker node we now obtained the tracking of the
nuclei.

Please note: In case that an object divides into two parts, the LAPTracker node
assigns two new labels to these segments, i.e. that we do not have access to information
related to e.g. cell division time points. This can be solved by including the Add-On
solution of the workflow (see below: 3) Add-On solution: a closer look).

In the following MetaNodes *Features | QC* we calculate the object features of the 2D (
Connected Component Analysis node)and2D+Time ( LAPTracker node)
segmentation.

Basically we are finished. Witha (e.g.) Segment Feature node the trackscould
be identified and written to a table.

Nevertheless, we are in addition interested in the object displacement and velocity,
i.e. that we need the object information for each time point for the corresponding object
track. This processing step is performed via the following *PostProcessing* MetaNode:

The entire information is already accessible in the result of the Connected Component
Analysis and LAPTracker node respectively. We simply have to combine this
information in a reasonable way:

The single time point information can be extracted easily by applying the Image
Segment Features node to the 2D segmentation.

The information of the (different labeled) segments correspond to a certain track and
can be extracted by combining the 2D and 2D+Time segmentation using the Labeling
Arithmetic node. Againwe usethe concept of *LabelDependencies* withinthe Image
Segment Features node. Resultingwe obtain alist containing the information which
2D label (object) corresponds to which 2D+Time track (Fig. 3.9):

ONDIOVYL HNIL+(J¢ — € HdLdVHD

Row ID § Label [Single Time Point] | § TRACKID D X [Single Time Point] D Y [Single Time Foint] | D Time [... | D Max [Si.. | D Mean[...
mitocheck_sm... [2D0_171 [TRACKING-I Track: 11 120.855 115.701 10 82 44604
mitocheck_sm. [TRACKING-I_Track: 17 181.647 119.579 10 46 27.754
mitocheck. EACIGNG'I_TrEdc: 23 142.758 80,226 10 81 44.285
mitocheck. [TRACKING-I_Track: 10 122.331 272.47 20 83 [36.462
mitocheck_s [TRACKING-I_Track: 174.877 286,542 20 &6 37.386
mitocheck_sm... [TRACKING-I_Track: 1 39,57 224,114 12 42 26,432
mitocheck_sm.. [TRACKING-I _Track: 13 176.416 157.292 8 25 19.885
mitocheck_sm... [TRACKING-I_Track: 31 194.748 1245.913 20 56 [33.773
mitocheck_sm... EACIGNG'I_TrEdc: S 196.907 195.385 5 81 52.071
mitocheck_sm... [TRACKING-I_Track: 18 261.441 1202.01 12 46 31.62
mitocheck_sm... [TRACKING-I_Track: 3 115.441 206,433 14 “ 25.607
mitocheck_sm... [TRACKING-I_Track: 18 250,744 204,719 21 53 35.005
mitocheck_sm.. [TRACKING-I Track: 7 71.506 133.931 8 33 27.416
mitocheck_sm. [TRACKING-I_Track: 8 63.562 182.81 5 £ 24.538
mitocheck_sm. EACIGNG'I_TrEdc: 19 1254.374 1247.642 20 54 [33.969
mitocheck_ [TRACKING-I_Track: 5 1212.159 193.785 12 77 44.307

[TRACKING-I_Track: 1 38.483 222,841 14 43 26.656

[TRACKING-I_Track: 3 116.47 l206.501 21 57 32.125

k. [TRACKING-I _Track: 17 187.981 123.038 8 47 32.1

mitocheck_sm... |2D_641 EACIGNG'I_T[EM(: 24 193.401 1213.938 14 50 32.033
mitocheck_sm...|2D_505 ACKING-I_Track: 0 66.321 1251149 20 45 27.746
mitocheck_sm... |2D_268 [TRACKING-I_Track: 12 126.364 166.558 8 83 53.385
mitocheck_sm... [20_504 [TRACKING-I_Track: 1 145,296 219.176 21 52 32.74
mitocheck_sm... [2D_267 [TRACKING-I_Track: 15 272,648 142,398 8 57 37.466
mitocheck_sm... [2D_507 [TRACKING-I Track: 2 224.993 255.601 20 73 37.619
mitocheck_sm... |2D_266 ACKING-I_Track: 24 191.27 1207.078 12 57 E.?SE
mitocheck_sm...|2D_506 ACKING-I_Track: 4 153.471 232.333 21 43 ‘2&.581
mitocheck sm...|2D 265 [TRACKING-T Track: 14 216.993 142,438 ] 34 l25

FIGURE 3.9: Outcome of the Column Rename node in the PostProcessing MetaNode: The
column *Label [Single TimePoint]* provides the information for every time point. The column
*TRACK ID* lists the corresponding object track.

After that we combine the two results using the Joiner || Joiner Setting:
Label , TRACK ID nodeandwe end up with atable containing the full results of the
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image processing part (Fig. 3.10):

1 Bimask | S Label [single Time Point] | D X[Snd... | D ¥ [singl.. | D Tme[si...| D % [Cen...| D Y[Cen...| D Tme[... | D X [Dim... | D ¥ [Dim... | D MexIs...| D Mean[... | D Maxint.
mitocheck_sm... TRACKING-L_Track: 0 219 54199 ama 0 64,341 L 9 40 34 31 22568 57
mitocheck_sm... TRACKING-I_Track: 0 8 f60.162 256,341 1 64,341 L s lao 54 2 1887 57
mitocheck_sm... TRACKING1_Track: 0 _a2 62.504 RE 3 64,341 i s lao 54 2 0925 57
mitocheck_sm... TRACKING-L Track: 0 256 67.718 s 3 l64.341 s1e o la0 34 2 208 57
mitocheck_sm... TRACKING-L_Track: 0 D241 60,111 223 fa 64,341 sLme o lao 34 2 2385 57
mitocheck_sm... TRACKING-L_Track: 0 256 69.632 e 5 64,341 sue 9 40 34 31 23101 57
mitocheck_sm... TRACKING-I_Track: 0 0_115 lsa.585 51027 6 64,341 L s lao 54 2 22813 57
mitocheck_sm... TRACKING-1_Track: 0 >_137 6a.735 22003 f7 l64.391 1 s lao 54 31 23.475 57
mitocheck_sm... TRACKING-I Track: 0 2262 67.05 251544 8 64,341 siise s a0 34 2 2348 57
mitocheck_sm... TRACKING-L_Track: 0 D_164 69,158 25107 8 64,391 sLe o lao 3 3 23505 57
mitocheck_sm... TRACKING-L_Track: 0 D_191 68.2% 250,213 10 64,341 EREER) 40 34 3 2277 57
mitocheck_sm... TRACKING-]_Track: 0 D 224 65,727 .97 1 64,341 PERE ) 40 34 37 3273 57
mitocheck_sm... TRACKING-1_Track: 0 277 66.228 2,645 12 64,391 1 s lao 54 35 25442 57
mitocheck_sm... TRACKING-I_Track: 0 033 f66.323 250,169 13 64,391 1 s lao 54 37 5016 57
mitocheck_sm... TRACKING-L Track: 0 D 645 6361 b7 14 64,341 sie o la0 34 la1 26.181 57
mitocheck_sm... TRACKING-L_Track: 0 2_341 66,121 247.670 15 l64.341 sLe o lao 34 0 27.681 57
mitocheck_sm... TRACKING-L_Track: 0 _383 65.769 w874 [16 64,341 5119 [ 40 34 41 25621 57
mitocheck_sm... TRACKING-I_Track: 0 20_3%6 63.439 pa1e |17 64,341 L s lao 54 las XS 57
mitocheck_sm... TRACKING-1_Track: 0 0_20 sa017 w001 |18 64,341 1 s lao 54 las 26.308 57

FIGURE 3.10: Resulting table of the image processing part: Object tracks (column: *Label*) with
corresponding information for each time point (column: *Label [Single TimePoint]*).

3.5.2 Statistics: Calculating object displacement and velocity

Statistics: Disance M

. Displacemen
- Velocity = . / fa} ey et =

Grouply  CormReame  Mahfomus  ColummResori Foni

S b >

FIGURE 3.11: Statistics part of the KNIME workflow *Session4_Tracking*.

As a result of the image processing part we have the information of the object tracks
and the corresponding information for each time point of each of the object tracks. In
order to identify object movement we calculate the X, Y displacements between consec-
utive time points individual for each object track. This can be done by using loops: The
Group Loop Start || Include: =*Label* node picks outthe rows contain-
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ing the same label, i.e. object track, and loops over each object (Check the output of the
Group Loop Start node).

In order to calculate the displacement we can (e.g.) use so called *Distance Matrix*
nodes. Thisis a group of three nodes: The pair Numeric Distances || Include:

X [Single TimePoint] | Include Y [Single TimePoint] and Distance

Matrix Calculate provides the distance in Euclidean space between each row, i.e.
in our case between each time point. Withthe Distance Matrix Pair Extractor
node we obtain a list containing two columns for the objects (i.e. single time point label)
and the distance (X, Y) between each of these time points.

Row ID S Objectl | § Object2 | D Distance
RowD 2D_19 2D_89 6.711
Rowel 2D_19 2D _42 2.534
Row2 2D_19 2D_56 14.133
Rowe3 2D_19 2D_244 15.438
Row4 2D_19 2D 96 16.95
Row5 D19 2D 115 17.79
Rowo 20_19 20_137 17.232
Row7 2D_19 2D_292 15.077
Rowd 2D_19 2D_164 17.129
Rows 2D_19 2D_191 16.804
Row 10 2D_19 2D_224 14.9
Rowll 2D_19 D 277 15.499
Rowld 2D_19 2D_330 15.251
Rowl3 2D_19 2D_645 13.476
Row 14 2D_19 2D_341 16.732
Row15 2D_19 2D_333 15.655
Row 15 2D_19 2D_396 14.37

FIGURE 3.12: Outcome of the Distance Matrix Pair Extractor node.

Since we are only interested in the distance between two consecutive object move-
ments, we only need the first value of each of the objects in the *Object1* column. This can
simply be done usinga GroupBy || Options: «Distancex: First node
(Fig. 3.13):

After that we perform some post-processing and obtain the final results via the two
output ports of the Loop End node: The upper port lists the information per single
time point for each of the object tracks; the lower port lists the results per track.

3.5.3 Add-On solution: A closer look

This part will not be explained in detail! (For the interested user)
The main idea is the following: In this data set we have objects which divide. Now it
could be of great interest to assign *root* and *daughter* cells, meaning to identify which
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Row ID 5 Objectl | D XY [ Displacement between TimePoints ]
Row3 2D_19 6.711
Row2o 2D_89 2.839
Rowl3 2D_42 5.2494
Row13 2D_56 1.393
Rows 2D_244 2.871
Row27 2D_96 1.406
Rowd 2D_115 107
Row1l 2D_137 2. 794
Rows 2D_292 2.154
Row2 2D_164 1.248
Row4 2D_191 2.54
Row5 20_224 0,502
Row?7 2D_277 0.532
Rowg 2D_330 2.742
RowZl 2D_645 3.27
Rowi10 2D_341 1.245
Rowll 2D_383 2.375
Rowl2 2D_396 1.679
Rowl4 2D_440 2.747
Rowl15 2D_450 1.818
Rowlpg 2D_505 2,499
Rowl7 2D_523 1.653
Row19 2D_579 5.598
Row20 2D_589 2,348
Row22 2D_Boo 1.207
Row24 2D_754 1.323
Row25 2D_804 2,495
Row23 2D_710 1.852

FIGURE 3.13: Result table of the displacement calculation: The column X, Y [...] lists the displace-
ment in X, Y between the *Object* with label x, i.e. to the next consecutive time point.

FIGURE 3.14: Add-On part of the KNIME workflow *Session4_Tracking*.

object is a result of a cell division process.

The mostimportant step is done by usingthe Connected Component Analysis
| | Dimensions: X, Y, Time node. In this configuration this node acts like the
LAPTracker node; with one important difference: The labels of dividing objects stay
the same! By combining this information with the information of the 2D ( Connected
Component Analysis node) and 2D+Time ( LAPTracker node) of the upper
branch, we finally obtain our *root* and *daughter* cells; cp. outcome of *Final Results*
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FIGURE 3.15: Final results table.

3.6 Tips and tools

¢ Image] Built-in Macro Functions: http://rsbweb.nih.gov/1ij/developer/
macro/functions.html

 Built-in functions used: getDimensions, getStatistics, newArray, Array.fill, Array.concatenate,
setSlice, nSlices, nResults, getResult, makeLine, Plot

¢ EuBIAS 2013 - Biolmage Data Analysis Course: http://eubias2013.irbbarcelona.
org/bias—2-course
3.7 Groups close by which work on similar problems

¢ Dr. Karl Rohr’s group, Biomedical Computer Vision Group (http://www.bioquant.
uni-heidelberg.de/?1d=322), located at Bioquant

¢ Prof. Fred Hamprecht’s group, Multidimensional Image Processing Group (http:
//hci.iwr.uni-heidelberg.de/MIP/),located at HCI, Speyererstr. 6

¢ Dr. Christian Conrad’s group, Intelligent Imaging Group (http://ibios.dkfz.

de/tbi/index.php/intelligent—-imaging/people/94—-cconrad),lo-
cated at Bioquant
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3D OBJECT BASED COLOCALIZATION
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4.1 Aim

In this project we will first segment objects of interest; then implement an Image] macro
to analyze 3D object based colocalization; finally how the colocalization results can be
visualized will be discussed.

4.2 Introduction

| Image) 3D Viewer =8 B Image) 3D Viewer = B8
File Edit View Add Landmarks Help File Edit View Add Lendmarks Help

FIGURE 4.1: The Hela cells dataset (with two channels) from two views.

Subcellular structures interact in numerous ways, which depend on spatial proximity

or spatial correlations between the interacting structures. Colocalization analysis aims at
finding such correlations, providing hints of potential interactions. If the structures only
have simple spatial overlap with one another, it is called cooccurrence; If they not only
overlap but also codistribute in proportion, it is then correlation. Colocalization may be
evaluated visually, quantitatively, and statistically:
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1. It may be identified by superimposing two images and inspecting the appearance

of the combined color. For example, colocalization of red and green structures can
appear yellow. However, this intuitive method can work only when the intensity
levels of the two images are similar (see a detailed example in [2]). Scatter plot of
pixel intensities from the two images also qualitatively indicates colocalization, e.g.
the points form a straight line if the two structures correlate. But visual evaluation
does not tell the degree of colocalization, nor if it is true colocalization at all.

. In general, two categories of quantitative approaches to colocalization analysis can

be found: intensity based correlation methods and object based methods. Intensity
based methods compute global measures about colocalization, using the correla-
tion information of intensities of two channels. Several review papers have been
published during the last decade, where coefficients’ meaning, interpretation, guide



of use, and examples for colocalization are given [1, 2, 8]. Tools for quantifying
these measures can be found in many image analysis open-source and commercial
software packages, to name just a few: Fiji’s JACoP plugin and Coloc 2, CellProfiler,
BiolmageXD, Huygens, Imaris, Metamorph, Volocity. Most object-based colocaliza-
tion methods first segment and identify objects, and then account for objects’ inter-
distances to analyze possible colocalization. Usually, two objects are considered
colocalized, if the centroids of the objects are within certain distance [1, 5], or if two
objects with certain percentage of area/volume overlap [6, 7].

3. Colocalization studies generally should perform some statistical analysis, in order
to interpret whether the found cooccurrence or correlation is just a random coinci-
dence or a true colocalization. A common method is Monte-Carlo simulations [3]
but it is computationally expensive. Recently a new analytical statistics method
based on Ripley’s K function is proposed and included as an Icy plugin, StatColoc [4].

Dataset: Virologists often need to answer the questions of when and where the viral
replication happens and the relevant virus-host interactions. The dataset (see Fig. 4.1 fop
as an example) we are using in this session is Hela cells imaged with a Spinning disk
microscope. Z serial images were acquired in three channels, from which two are used:
channel 1 (C1, red) shows viral DNA in high contrast and channel 3 (C3, green) shows viral
particles in high contrast (a viral structural protein). The high contrast signals either come
from synthetic dyes or fluorescent protein. The goal is to identify the viral particles that
have synthesized viral DNA indicating such structures represent replicating viral particles
and potentially the viral replication sites. Thus, the identification can be achieved through
a colocalization analysis between the objects in these two channels.

4.3 KNIME solution

Open the workflow [ Session5_Colocalisation_NonPointLike | (Fig. 4.2):

4.3.1 Image processing

The *Image PreProcessing* part combines the raw data to 3D data stacks for further pro-
cessing. Within *Image Processing* we use already known, straight forward methods to
segment the spots. Important to mention is, that due to the quality of the image raw
data we here use the Local Thresholding node with subsequent morphologi-
cal operations in order to remove noise. This procedure turned out to fit best for this
data set. Alternatives would be the well-known Global Thresholder or Spot
Detection nodes.
The result of the image processing part looks as follows (Fig. 4.3):

4.3.2 Identify colocalizations and corresponding spot areas

In order to identify colocalizations it would be enough to use the already known Labeling
Arithmetic || Labeling Operation Method: AND nodewhichreturnsonly
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FIGURE  4.2: Image  Processing part of the KNIME workflow  “Ses-
sion5_Colocalisation_NonPointLike".

Bt Channel1 It Channel3 Stz Seamentation Channel 1 Sr¢ Seamentation Channel3

FIGURE 4.3: Result table of the image processing part including the image raw data and segmented
spots in 3D.
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FIGURE 4.4: Statistics part of the KNIME workflow “Session5_Colocalisation_NonPointLike".
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the segments which are overlapping between the two data stacks (upper branch).

However, we are in addition interested in the overlapping regions in terms of areas. L.e.,
that we have to identify the corresponding spot regions of the two channels which colocal-
ize. Forthiswe useagainthe Labeling Arithmetic || Labeling Operation
Method: DIFFERENCE node applyingthe configuration *DIFFERENCE*. This oper-
ation returns the regions which do NOT overlap and thus provides the information we are
interested in. By using the *LabelDependencies* feature we can now identify the non-
overlapping regions of the colocalizing spots.

It turns out that some regions have multiple colocalizations (Fig. 4.5):

Filtered - 0:1139 - Row Filter(Colocalising) Le
File
Table “default” -Rows: 43 | Spec - Columns: 8 | Properties | Flow Variables|
Row ID !lE Bitmask s Label Scc Source Labeling s LabelDependendies D Centroid X D Centroid ¥ D Centroid Z D Num Pix

RowD#Chann... Channel-1_1081 |Lsbeling[name=Ima... [channel-3_523 18.5% 114,154 5 E]
Row0#Chann... Channel-1_1153 Labeling[name =Ima. .. |Channel-3_948 68.659 280.747 7.022 91
Row0#Chann.., [~ Channel-1_1056 Labeling[name =Ima. .. |Channel-3_31 122,296 36.025 5.346 81
Row0#Chann.. Channel-1_101 Labeling[name=Ima... |Channel-3_1001;Channel-3_494 141.8 |71.588 4.282 185
RowO#Chann... Channel 3523 |Labeling[name=Ima. .. [Channel 1_1081 19.7 117.953 4533 [z0
Rowd#Chann... Channel 1_27 Labeinglname=Ima... [Channel-3_14;Channel 3_725 159.054 19361 5.325 82
Rowd#Chann... Channel-1_34 Labeinglname=Ima... [Channel-3_22 177.01% [25.7%8 2867 211
Row0#Chann... Channel-1_37 Labeling[name=Ima. .. |Channel-3_25 122.8 28.429 3.171 |70
Row0#Chann... Channel-1_391 Labeling[name =Ima. .. |Channel-3_395 1263.386 95.114 3.868 114
Row0=Chann. .. W Channel-1_142 Labeling[name=Ima. .. [Channel-3_643 310.805 111.283 ) Es
RowO#Chann... [ Channel 1_175 __|Labeling[name=1ma... [Channel 3_124 296.609 136,884 1087 63
Rowd#Chann... [ Channel3_328 |Labeling[name=Ima... [channel 1613 175.304 225163 2728 a2
Rowd#Chann... Channel-1 255 |Labeling[name=Ima... [Channel-3_133 193.231 227825 2151 185
Row0#Chann... Channel-3_32 Labeling[name =Ima. .. |Channel-1_51 136.233 36.7 1.067 30
Row0#Chann... Channel-3_31 Labeling[name=Ima. .. |Channel-1_1056 19.291 35.4 2.345 55
Row0#Chann.. Channel-3_486 Labeling[name=Ima. .. [Channel-1_717 132.278 54.5 3.722 18

Channel-3_60 Labeling[name=Ima. . (Channel-1_381 171 70 1 15
Channel-1_233  |Labeing[name=Ima... [Channel-3_L71 293.05 (202,056 1389 3
| Channel-3.485  |Labeing[name=Ima... [Channel-1_381 17172 74.52 3.4 |25
RowozChann... P Channel-3_434 Labeling[name =Im: 141.622 73.244 3.822 145
Row0#Chann... Channel-3_727 Labeling[name=Ima... |Channel-1_1212 208,742 20.129 5.903 31
Row0#Chann.. Channel-3_725 Labeling[name=Ima. .. [Channel-1_27 189.429 16.786 6.538 E
RowDZChann... Channel-1 381 |Labeing[name=Ima... (Channel-3_60;Channel-3_195 170.354 7184 203 33
Row0#Chann... Channel-3_742  |Labeing[name=Ima... [Channel-1_892 65.455 60,455 5,652 22
RowD#Chann... Channel-3.948  |Labeing[name=Ima... [Channel-1_L153 68.842 280,211 7 13
Row0#Chann... Channel-1_619 Labeling[name =Ima. .. |Channel-3_328 176.5 1226 2 8
Row0#Chann... Channel-1_717 Labeling[name=Ima. .. |Channel-3_486 135.6 53.76 4.2 125
Row0#Chann.. Channel-1_211 Labeling[name =Ima... |Channel-3_148 112.933 169.68 3.68 75
{ MW Rowozchann... Channel-3_183 |Labeing[name=Ima... (Channel-1_255 190.573 (226,136 1548 46
Row0#Chann... Channel-1.852  |Labeing[name=Ima... [Channel-3_742 626 [8.76 5.12 25
RowD#Chann... Channel-3_171 |Labeing[name=Ima... [Channel-1_233 293,143 200,857 2214 3
Row0#Chann... Channel-3_25 Labeling[name=Ima. .. [Channel-1_37 124.935 31.281 4.699 153
Row0#Chann... Channel-3_22 Labeling[name=Ima. .. [Channel-1_34 176.811 27 1.919 37
RowD#Chann... Channel-3_1001 __|Labeing[name=Ima... |Channel-1_101 141238 [73.357 8143 2
RowDZChann... Channel-3_1002 _|Labeing[name=Ima... [Channel-1_247 171 74 7 H
Row0#Chann... Channel-3_14 Labeling[name=Ima... [Channel-1_27 189.387 16,419 1161 51
RowD#Chann... Channel-3.643  |Labeing[name=Ima... [Channel-1_142 315.75 117.25 5.353 3
Row0#Chann... Channel-1_51 Labeling[name=Ima. .. [Channel-3_32 137.222 39 1.167 18
Row0#Chann... P Channel-3_148 Labeling[name=Ima... |Channel-1_211 113.048 169.202 3.029 104
RowD#Chann... Channel-1_1247 __|Labeing[name=Ima... |Channel-3_1002 170 72 65 10
RowDZChann... Channel-3_i24 _|Labeing[name=Ima... (Channel-1_L75 297.25 135.75 15 20
RowD#Chann... Channel-3_385  |Labeing[name=Ima... [Channel-1_391 %3.3 [e5.883 5.133 60
Row0#Chann... [ Channel-1_1212  |Labeling[name=Ima. .. Channel-3_727 210,581 |17.698 7.372 J43

FIGURE 4.5: Multiple colocalizations: See column “LabelDependencies".

To simplify the story, we only focus on one colocalization partner. By usingthe Cell
Splitter node we split the column *LabelDependencies* into two new columns with
separated label entries *LabelDependencies_Arr[0]* and *LabelDependencies_Arr[1]* and
consider only *LabelDependencies_Arr[0]* in the following.

The two branches are then combined by the Joiner node and resulting we obtain
a table including the colocalization regions and the corresponding spot areas of the two
channels (Fig. 4.6):

By performing some basic post-processing we obtain the final results including the
spot labels, the colocalization region and the corresponding areas.
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FIGURE 4.6: Result of the Joiner node after combining the two branches.

4.3.3 Add-On: Point-like colocalization

Very often we have to deal with point-like objects or the information needed can be de-
fined by the distance of the center of mass of the objects. In this case a very simple solution
can be applied:

Open the workflow [ Session5_Colocalisation_NonPointLike PointLike | (Fig. 4.7):

45 0: Session3.Colocalistion. NonPointike, PointLike 3

R =
i = = = = = = e
B T E

FIGURE 4.7: Statistics part of the KNIME workflow *Session5_Colocalisation_NonPointLike_PointLike*.

We simply calculate the X, Y, Z coordinates of the spots via the Image Segment
Features nodes and use the same method as applied in the tracking session by using
*Distance Matrix*. We can define a colocalization radius of e.g. 5 by configuring the
Distance Matrix Pair Extractor || Create pair for values: <=5
node (Fig. 4.8):

The final result table provides the following colocalizing objects (cp. result table: non-
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FIGURE 4.8: Configuration dialog of the Distance Matrix Pair Extractor node: De-
fine a colocalization radius of (e.g.) 5 by simply creating pairs for values <= 5.

point-like solution!) (Fig. 4.9):

Table "default” - Rows: 33 | Spec - Columns: 8 | Properties | Flow Variables
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Row ID § Objectl § Object2 D Distance between Objects | [ Max D Mean D NumPix |B, Bitmask | Ses Source Labeling
Row22 Row0... (Channel-1_101 _[Channel-3_494 | 1.728 1,910 1,220.847 |85 L
Channel-1_101  [Channel-3_1001 |4.283 1,910 1,220.847  [85 L
.. (Channel-1_1081  |Channel-3_523 4.057 1,974 |785.359 139 L
. |Channel-1_1153 (Channel-3_948 0.567 5,951 1,286.901 91 L
. |[Channel-1_1212__|Channel 3.085 2,007 1,035.88% |43 2 L
(Channel 435 1,030 778.2 10 L
B \Channel-3_: 2.291 1,030 778.2 10 L
.. Channel-1_143__|Channel 3.453 2,239 1,523.75 |28 L
..[Channel-1_175  [Channel-3_124  |1.367 8,640 2,031813 |68 2 L
Channel-1 202 [Channel-3_137  [4.735 1,256 674.754 57 i L
Channel-1 211 [Channel3_148_ 0.816 4,366 1,673.6 75 L
Channel-1212  [Chamnel-3_152  |3.963 1,692 1,167.471 |17 F L
Channel-1 227 [Channel-3_157  |4.22 2,153 1,236.702 |47 L
. Channel-1_233 (Channel-3_171 1.458 1,234 |743.222 136 L
. [Channel-i251  [Chamnel3_328  [3.046 1,035 727.6 5 L
..|Channel-1 355 |Channel-3_183  [3.656 331 1,663.742 186 L
269 (Channel-3_191 |4.555 1,339 |767.982 55 L
27 [Channel3_725  |4.13 1,45 727.024 83 L
..|Channel-1 37 |Channel-3_14  [3.665 1,445 727,024 83 L
..|Channel-1_34 \Channel-3_22 4.036 15,132 5,119,498 211 L
Channel137  [Chamnel3_25  |3.877 1,945 926,514 70 L
Channel-1_381  [Chamnel3.60  |2.201 2,668 1,802.63 33 L
Channel-1 381  [Channel-3 485  [3.282 2,668 1,802.636 133 L
Channel-1 391 |Channel-3_395  |1.483 3,198 1,873.25¢ 114 i L
Channel-151  [Chamnel3_32  |2.506 1,070 [825.389 8 L
..|Channel-1 561 [Channel-3.85  |4.724 4733 1,575.735 |83 L
.. [Channel-1_562 (Channel 1,451 1807.08 50 L
(Channel-3_¢ 4,325 2022125 |31 i L
B \Channel- 2,205 1,105.58 I3 il L
..|Channel-1_sa0 \Channel- 2,205 1,105.58 63 i L
.. [Channel-1591  [Channel3_782 |3.742 1,489 1,206.% 5 L
Channel-1615  [Chamnel-3_328  |2.577 1,171 54125 3 L
Channel-1 71 (Channel-3_485  |4.638 1,377 1,065.4 5 L
Channel-1 717 |Channel3 992 |4.305 1,425 [758.32 25 L
Channel-1717  [Chamnel-3_486  |3.437 1,425 [756.32 |25 L
_RowD... [Channel-1_ 718 |Channel-3_1213 [3.778 3,937 1,142.682 |85 L
) | .|channel-1 892 |Channel-3 742 [3.367 1,239 70024 25 L
Row4_Row0... (Channel-1 535 [Channel-3_782  |3.867 2,504 1,785.557 |63 L

FIGURE 4.9: Final result table of the point-like colocalization.
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4.4 Writing our own Image] macro for fully automatic colocalization

Many of you may have already been using tools e.g. the Image]J plugin JACoP [1], Coloc2!
for either object- or intensity-based colocalization analysis. Here, we will not use any of
these, but try to write our own macro for fully automatic colocalization so that we could
establish our own protocols and control settings, and at the same time practice more with
macro scripting.

We have practiced in the previous sessions with: the function [Plugins —-> Macros
—> Record] to track the sequential operations that have been applied; cleaning up and
converting the recorded macro commands to a functional macro file; and even a few
Image]J built-in functions. In this session, we will exploit a little bit more ImageJ Macro
scripting, e.g. use more and different functions, construct a parameter setting interface
window, etc.

In order to help better understanding the steps during the object-based colocaliza-
tion, we will first use a synthetic dataset to test and build up the macro. And once our
macro program is working, we will test it on the segmented dataset from the previous step.
Fig. 4.10 shows two 3D views of the synthetic dataset with two channels, where channel
1 (red) has six objects and channel 2 (blue) seven. Each object in channel 1 has different
level of spatial overlap with one of the objects in channel 2. The synthetic dataset can be

found in the Session5 folder (C1_syn and C2_syn).
L2} Image) 3D Viewer = B8 L2} Image) 3D Viewer = B

File Edit View Add Lendmarks Help

File Edit View Add Lendmarks Help

FIGURE 4.10: Synthetic 3D dataset from two views.

4.4.1 Filtering objects by size

Often the segmentation contains objects that are not interesting for us such as noise or
other structures. Since object-based methods concern individual objects, then we should
apply some filtering criteria in order to discard them for further analysis. Such criteria
could be, for example:

¢ (3D/2D/1D) size range of the object-of-interest (in each channel)

lnttp://fidi.sc/Coloc_2
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* object shape, e.g. circularity’, compactness®

¢ object location

It should be mentioned that this step greatly influences the colocalization measurements.
We will discuss only size related filtering here. Our strategy consists of two steps: filtering
in 3D, and then in 2D.

4.4.1.1 Filtering by 3D sizes

As we have already learned from the previous session, 3D Objects Counter is able
to do this. We can open the macro file “S4_filtering.ijm" and add steps in. After
running it, we will be asked to specify the directories where the images from two channels
are, and also a directory to store results. After that, we will see a window with many
parameters to setup. Let’s skip these first, and comment on them at later steps. So now let’s
select the image of channel 1, and then run [Analyze —> 3D Object Counter],in
the popup window there are two parameters of our interest, Min and Max in the Size
filter field. Let’s suppose that the object of interest should have a size of minimum 3
voxels and maximum 10 voxels in each of the three dimensions, resulting in object volume
of size Min=27 and Max=1000. This filtering step removes the smallest object from both
channels. Although they may seem to overlap with objects in the other channel, they are
likely to be e.g. noise and their spatial co-occurrence could be coming from randomly
distributed particles/noises that are close to each other by chance. Since in this session
we may have to produce many intermediate images, so it might be a good practice to
rename these intermediate images. And if they will not be used any further, they might
as well just be closed by running [File -> Close].

4.4.1.2 Filtering by 2D sizes

You may have noticed that this filtering criteria is not sufficient to remove the large object
in channel 1 (Fig. 4.11 left). This is because e.g. the object is very thin in one or two axes
and large in other(s) thus the total 3D size may be within the size range of the object of
interest. In this case, it makes sense to have another filtering but in 2D rather than in 3D.

Option #1: For example, one possibility is to set a size range in the XY plane, and if
needed also a maximum spanning size in the Z axis. In order to do this, we will use
[Analyze -> Analyze Particles] and its Size parameter setting. So similarly
we could set the value to be e.g. 9-100. Also, distinct size range can be employed for each
channel if needed. Additionally, for some applications, the parameter Circularity
could also be used. Since we would like to obtain the filtered image, thus “Masks" will be
chosen to Show. Note that the Analyze Particles function works on binary images

2 Circularity measures how round, or circular-shape like, the object is. In Fiji, the range of this parameter is
between 0 and 1. The more roundish the object, the closer to 1 the circularity.

3Compactness is a property that measures how bounded all points in the object are, e.g. within some fixed
distance of each other, surface-area to volume ratio. In Fiji, we can find such measurements options from the
downloadable plugininPlugins -> 3D -> 3D Manager Options.
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FIGURE 4.11: Synthetic 3D dataset after first filtering in 3D (left), then also in 2D (middle), and the
overlapping regions after the filtering steps (right).

only, then we first need to convert the label image by the 3D Object Counter, which is a
label image. A simple thresholding should work, since the label starts at 1. Normally the
binary image after thresholding has value 0 and 255. Sometimes, a binary image of value
0 and 1 makes further analysis easier. To do so, we could divide every pixel by this image’s
non-zero value, i.e. 255, using [Process —-> Math -> Divide].

Question: What should we do if the 2D filtering is to be done in the XZ plane?

If the axes are swapped, so as the original XZ plane will be the new XY plane, then we
could apply the same procedure on the axes-swapped image. This can be done with e.g.
[Plugins -> Transform —-> TransformJ —-> TransformJ Rotate], whichap-
plies to the image a rotation transform around the three main axes. Please note that if the
image to be processed is large, this will not be the optimal solution as it will be both time
and computation expensive to apply a transform and interpolate the whole image. A faster
optioncouldbe [Plugins -> Transform -> TransformJ -> TransformJ Turn].
The advantage of using this plugin rather than the more generally applicable [P1lugins
-> Transform —> TransformJ —-> TransformJ Rotate]isthatitdoesnotin-
volve interpolation of image values but merely a reordering of the image elements. As a
result, it generally requires much less computation time, and does not affect image quality.

Option #2: Another possibility, probably the easier option in many cases, is the erosion
+ dilation operations in 3D. In this case, we would only want to erode and then dilate in
one dimension - the one where object-to-be-removed is thin. Let’s try it, Process ->
Filters —-> Minimum 3DandthenProcess -> Filters —-> Maximum 3Dwith
the same radius settings in each dimension. We will set both X and Y radius to 0 and
try with Z radius being 3.0, because the large object in Channel 1 is thin in Z axis. In
general it should work - provided the filter radius is not smaller than the object radius
along its smallest dimension, then the object should disappear and not return. This also
gives the possibility to filter anisotropically considering the fact that in many microscopy
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images the Z spacing is larger than pixel size in then XY plane. Note that the erode/dilate
alternative inthe Plugins —-> Process submenu will not work, because the filter size
is not adjustable). On the other hand, please keep in mind that the erode and dilate
operations may modify object shape, especially when objects are not roundish blob-like.

Depending on specific applications, more filtering steps can be applied before or after
the previous size filtering, such as shape or location. In this session we will not discuss in
details and assume the size filtering is sufficient for our task (Fig. 4.11 middle).

4.4.2 Finding spatial overlapping objects in both channels

In order to find colocalized objects, we will first find the overlapping (or shared) parts of
the two filtered channels, and then identify the corresponding objects in each channel
that contain these overlapping regions. To achieve this, what do we need to do? There are
multiple ways, all of which involve:

* in each channel, label the objects so as to identify them;

¢ in each channel, calculate the volume (in voxels) of each object;
e compute the objects’ overlapping regions of the two channels;

¢ calculate the volume of each overlapping region.

« find the labels of objects in each channel that overlap with some object in the other
channel

These tasks could be done with the help of [Analyze —-> 3D Object Counter]and
[Plugins -> 3D -> 3D Manager].

We could see that in both channels, the overlapping region has value higher than
zero; while the rest of the two images have either one or both channels with zero back-
ground. Therefore if we multiply the two images, only the overlapping regions will show
values higher than zero. So we can run [Process -> Image Calculator], set the
object maps of from the two channels as Image 1 and Image 2,andsetMultiply as
Operation. Let’s call the obtained multiplicative image as “SharedMask". Fig. 4.11 right
shows the 3D view of the overlapping regions after the filtering steps. Note that the images
of both channels that contain objects filtered by size are binary images of values 0 and 1,
thus the "SharedMask" is also a binary image of values 0 and 1.

Now, if we add the “SharedMask" to the filtered binary images of each channel, the
two resultant images would give background zero value, all the objects in each channel
value 1, except where the overlaps is, i.e. 2. Then when using “3D hysteresis thresholding"
plugin, only regions with value >= a low threshold (i.e. 1) that also contain value >= a high
threshold (i.e. 2) are extracted, i.e. the objects containing the overlaps. Therefore, we have
obtained also one image per channel, which contains only objects that overlap with some
object in the other channel.

Since we define the object volume overlap ratio as the colocalization criteria, objects
and their volume values in both channels and the SharedMask should be calculated. We
need to make sure in [Analyze —-> 3D OC Options], to check the option of “Nb
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of Obj. voxels" (if we count voxels) or “Volume" (number of voxels multiplying
voxel size). If the voxel size is not set, by default it is 1 for each dimension, thus these
two parameters give the same value. After running the 3D Objects Counter, the
resultant Object map gives each object a unique non-zero label and the background
the zero label. Also, the measurements will be shown in a table. You may recall that in
3D OC Options menu, if “Store results within a table named after the image (macro
friendly)" is not checked, the results are stored in the Results table. This way we could
use the built-in macro functions nResults and getResult to access items in the table.
Let’s do this again, with the following code:

11ts);
t,;;_*_”): "),.

ObjVolume_chl = ne rray (nRe
print ("ObjVolume_chl ("+nRe

ul

3| for (1=0;i<nResults;i++) {

ObjVolume_chl[i] = getResult ("Nb of obj. voxels", 1i);
print (ObjVolume_chl[i]);
}

This code first creates a new array, ObjVolume_chl, so as to store all objects’ volumes in
the current channel. It is then filled with the values obtained from the Result s table. For
checking the code we could also print the array. Similar arrays and object labels should be
created for the other channel and the SharedMask.

So far we have obtained the objects’ labels and volume values in each channel and
the “SharedMask" image. The next task will be to identify the labels of each object pair
that overlap, in order to further find out their corresponding overlap volume ratio. Before
jumping into the next part, let’s ask ourselves a question - does our problem involve ana-
lyzing individual colocalized objects, or rather a global measure that tells something about
colocalized objects as a whole? If the answer to your problem is the later, then we could
skip the remaining of this section and the following one. Instead, probably some nice
tools could do the job for us. For example as mentioned previously, the ImageJ plugin
JACoP [1] offers measures, e.g. Mander’s Coefficients, Overlap Coefficient, and object-
based methods. We will not provide detailed descriptions on how to work with them here,
please refer to their corresponding online documentation.

If you are interested in studying individual colocalized objects and their further char-
acteristics, such as their spatial distribution, shape, size, etc, we will go on to the next task
of identifying in each channel which objects overlap with objects in the other channel.
Since we know the overlapping regions, then we just need to look at the same regions
in each of the two channels to get these objects that have overlapping parts in the other
channel. We have used ROI Manager before, now we will use another function from
the plugins we installed: [Plugins -> 3D -> 3D Manager]. It plays a similar role
as the ROI Manager but in 3D. So the first thing is to add the 3D overlapping regions
into the 3D Manager so that we could use them for further measurements, and also for
inspecting the same regions on other images such as the label images. To do so, we will
use the following code?:

4Note that the “Ext" is a built-in function added by plugins using the MacroExtension interface.
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run ("3D Manager");
Ext.Manager3D_AddImage () ;
Ext .Manager3D_SelectAll () ;

After adding the 3D overlapping regions into the 3D Manager, we will select the object
label image of channel 2 so as to find out the corresponding label values for every overlap-
ping region. Similar to what we have done before, we can measure the maximum intensity
value of each region from the label image in channel 2. So we will check 3D Manager
Options and select the Maximum gray wvalue. And then click the Quantif_3Din
the 3D Manager window. It will give a window named “3D quantif", with a column
named as “Max". This column stores the maximum gray values of each region in 3D
Manager from the label image in channel 2. Since it is not the usual “Results"” table,
we can't use the nResults and getResult built-in functions to access the contents
of this table. How do we obtain the objects in each channel that have these overlapping
regions? There are many ways to achieve this, but let’s see how to extract information
from any table, in this case a table named “3D quantif". The following code shows an
example of how we can get one column’s items from a table that is not the Fiji default
Results table:

shareObjLabelInCh2 = newArray (numSharedObjects) ;

selectWindow ("3D quantif");

tbl getInfo ("window.contents");
tblLines = split (tbl, "\n");
1dx=0;

5| for (i=1; i<= numSharedObjects; i++) {

lineA = split (strA[i], "\t");
shareObjLabelInCh2[idx]=1ineA[2];
}

where (in lines 3-4) “tbl" stores everything in the “3D quantif" table as string, and we
can get each item from the table by two “split" operations: first into lines through the
line break “\n" (as in line 4) and then into separate items through the tab or column break
“\t" (asinline 7). shareObjLabellnChZ2 is an array of size numSharedObjects, the number
of overlapping regions, which stores the object labels that contain the corresponding over-
lap part in channel 2. Of course, there is now a built-in function IJ. renameResults
available (if you have Image]J version 1.46 or later) that changes the title of a results table
from one to another. Thus, we can always change the name of any table to “Results" and
then use the easier built-in functions nResults and getResults to get table contents.

4.4.3 Filtering the colocalization objects by volume overlap percentage
criteria

We have finally arrived to the stage that we are ready to select “real" colocalized objects
from the candidates. As we will use the volume overlap criteria, let’s first calculate the
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volume overlap ratio. There may be several ways to define the ratio, we will use e.g. the
ratio between the overlapping region and the volume of the smaller of the two objects.
In order to not complicate the problem too much, we will assume that objects in one of
the channels have smaller size. This could be a reasonable assumption in many biological
applications. The following code realizes the process of determining the colocalization
using such selection criteria, assuming the channel with smaller objects is channel 2. A
new image stack, “SharedMask Filtered", is created and filled with the overlapping regions
that have volume size larger than the specified percent of the corresponding object in
channel 2:

selectImage ("Objects map of Shared Mask");
run ("3D Manager");
Ext .Manager3D_AddImage () ;
newImage ("SharedMask Filtered", "8-bit black", width, height, slices);
for (j=0; j<numSharedObjects; j++) {
objLabelInC2 = shareObjLabelInCh2[j];
voRatio=0bjVolume_shared[j]/ObjVolume_ch2[objLabelInC2-1];
print ("volume overlap ratio of "+3j+"th object in channel 2 is: "+voRatio+"
= "+ObjVolume_shared[j]+"/"+0bjVolume_ch2[objLabelInC2-11]);

//select the objects that have volume overlapping higher than a user
specified ratio, ‘‘volOverlap"
if (voRatio>volOverlap) {
numColocObjects=numColocObjects+1;
Ext .Manager3D_Select (J);
Ext .Manager3D_FillStack(1l,1,1);
}

where “numColocObjects" gives the total number of colocalization object pairs, “voRa-
tio" computes the volume overlap ratio, and “volOverlap" is a user-specified threshold
that discards objects with lower overlap ratio. Manager3D_FillStack fills the newly
created image with the selected 3D region. For each region, the values filled can be all
the same, or a different one as label. The final colocalized objects in each channel can
be obtained using again the 3D Hysteresis Thresholding, as we have done pre-
viously, but with the newly created overlapping regions image, “SharedMask Filter". In
the synthetic example, the four candidate objects have volume overlap ratio of: 0.11, 0.51,
0.25, and 1 (see Fig. 4.12 left). And if we specify “volOverlap" to be, e.g. 0.2, 0.3, 0.52,
the final “real" colocalization results differ, as shown in the three images on the right side,
respectively, in Fig. 4.12.

4.4.4 Visualizing results (optional)

To better examine 3D data, Fiji offers [Plugins —-> 3D Viewer] to visualize rendered
volumes, surfaces, or orthogonal slices. After opening the “3D Viewer" window, images
can be loaded using either [File —-> Open] (for any image on disk) or [Add —> From
Image] (for images already loaded in Fiji). Multiple images can be loaded. For overlap-

ping images, we could modify image’s transparencyby [Edit -> Change transparencyl.
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FIGURE 4.12: (left) Candidate colocalization objects from the two channels, the number next to
each object pair shows the volume overlap ratio compared to the blue channel objects. (middle-left
- right) Determined colocalization object pairs using specified ratio threshold of: 0.2, 0.3, and 0.52,
respectively.

Image brightness can be changed using [Edit —-> Transfer Function -> RGBA].
There are many more possibilities to control and edit the visualization properties, we will
leave this as a homework for you to exploit further. Examples of visualizing 3D data using
this viewer can be found in many figures in this session such as Fig. 4.11, 4.12, 4.14.

4.4.5 Testing the macro on Hela cells with viral replication

The pipeline of operations we came up with can now be assembled to a complete macro
to process the original Hela cells stacks.

Segmenting spots. There are multiple tools for detecting spot-like structures, including
the two methods we have used in the spots counting session. Alternatively, a learning
based method is also suitable, where we can train a classifier that can “pick" objects of
interest out of other structures in the same image. A popular free software tool is ilastik
(www.1ilastik.org). Inorder to better segment images, some preprocessing steps can
be applied. A typical step is deconvolution and background subtraction. In Fiji, you can
find several plugins for these tasks to try on your images, such as:

magel 3D Viewer - N
o
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e Parallel Iterative Deconvolution (fi ji.sc/Parallel_TIterative_Deconvolution),

where the point spread function (PSF) can be estimated using the Diffraction PSF 3D
plugin (fiJ1i.sc/Diffraction_PSF_3D) (for our images, you can try to select
“WPL" as Method, and use 20 or more iterations; PSF estimation needs media re-
fractive index, numerical aperture, wavelength and pixel spacing. You can also find
“PSF_C1.tif" and “PSF_C3.tif" for the two channels, estimated from the Diffraction
PSF 3D plugin.) An example can be found in Fig. 4.13.

¢ To further remove background noise, youcantry [Process —-> Subtract Background]

(for our images, the rolling ball radius can be set to 10 pixels)
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FIGURE 4.13: Example images before (fop) and after (bottom) deconvolution.

So now when we try to analyze the Hela cell images, the parameters used for the
synthetic dataset may not be applicable anymore. Of course we could manually modify
each value through the entire macro file we made. But this is not efficient. So it is better
to use variables for these parameters, and specify them e.g. in the beginning of the macro
code.

After the macro is “parameterized”, we can specify values. For this dataset, let’s set the
threshold to be 0.5 for both channels, and 3D object sizes to be [5, 500], and maximum 2D
object sizes in XY plane are 150 (for channel 1) and 50 (for channel 2). And volume overlap

58



ratio threshold can be any value between 0 and 1. Fig. 4.14 shows a few example results of

the Hela cell images.
B Image] 3D Viewer = B B Image) 3D Viewer - oIEd

File Edit View Add Landmarks Help File Edit View Add Landmarks Help

7 Image) 3D Viewer = = B Image) 3D Viewer - BN
File Edit View Add Landmarks Help File Edit View Add Landmarks Help
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FIGURE 4.14: Colocalized objects in channel 1 (red) and channel 2 (green), together with all filtered
objects in channel 1 (white with transparency) using the specified ratio thresholds: 0.01, 0.1, 0.2,
and 0.3. Their corresponding number of determined colocalization objects are: 25, 14, 9, and 9,
respectively.

Please note that for a complete colocalization analysis, further examination steps
are needed such as accuracy evaluation, robustness evaluation, and reliability evalua-
tion like comparing to random events. These are out of the scope of this session thus
not discussed here.
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4.4.6 Setting up a parameter interface (optional)

You may find modifying parameters inside the source code of the macro not an elegant
usage. If you are willing, constructing a simple user interface window for parameters is
made very easy in Fiji. The Dialog. * functions offers a practical dialog box/window
with just a few lines of code. An example is shown in Fig. 4.15, with the code on the left
side and the generated dialog window the right side. Please note that the parameters that
fetch the values from the dialog should be specified following the same top-down order
as the dialog. Now we can create customized dialog window for the parameters that we
would like user to specify.

(] Dialog Window Title “
1 Dialog.create("Dialog Window Title");
2D .addNumber("Probability map threshold: ", @.5); Probability map threshold: m
ddMes 'H
.addNumbe nimum 3D object size (in voxels): ™, 5);
.addNumbe Volume overlap for colocalization: ", @.2); Minimum 3D object size (invoxels) |5

Volume overlap for colocalization:  |0.200

10 thres_pm chl
11 min3DObjsSiz
12 wolOverlap

13 Display3D = Di eckbox(); o e

™ Display in 3D Viewer?

FIGURE 4.15: An example of creating a dialog window for parameters to be specified by users.

In case you do not have time to write up the complete macro during the session, a
possible solution is provided in your Session5 folder (colocalization. ijm).

4.5 Tips and tools

¢ Image] Built-in Macro Functions: http://rsbweb.nih.gov/ij/developer/
macro/functions.html

¢ 3DImage] Suite: download: http://imagejdocu.tudor.lu/lib/exe/fetch.
php?media=plugin:stacks:3d_1i7j_suite:mcib3d-suite.zipandun-
zipping itin your plugins folder. Detailed description of the plugin: http://image jdocu.
tudor.lu/doku.php?id=plugin:stacks:3d_1i]j_suite:start.

* JACoP (includes object-based method): http://imagejdocu.tudor.lu/doku.
php?id=plugin:analysis:jacop_2.0:just_another_colocalization_
plugin:start

e Math-Clinic Short Tutorials: http://cellnetmcweb.bioquant.uni-heidelberg.
de/index.php/Short_Tutorials
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4.6 Groups close by which work on similar problems

¢ Dr. Holger Erfle’s group, ViroQuant (http: //www.bioquant .uni-heidelberg.
de/technology-platforms/viroquant—-cellnetworks—-rnai-screening-
facility/contact.html), located at Bioquant

¢ Dr. Karl Rohr’s group, Biomedical Computer Vision Group (http://www.bioquant.

uni-heidelberg.de/?1d=322), located at Bioquant -
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To list just a few Biolmage Analysis related tutorials, slides, online documentations,
online books...

Fiji online documentation: http://fiji.sc/Documentation
Image] User Guide: http://rsbweb.nih.gov/ij/docs/guide/146.html

EuBIAS 2013 - Biolmage Data Analysis Course: http://eubias2013.irbbarcelona.
org/bias—2-course

CMCIImage] Coursepage: http://cmci.embl.de/documents/ijcourses

CMCI Macro programming in Image]J Textbook: https://github.com/cmci/
ij_textbook2/blob/master/CMCImacrocourse.pdf?raw=true

Image] macro programming: http://www.matdat.life.ku.dk/ia/sessions/
sessionl2-4up.pdf

Fluorescence image analysis introduction:http://blogs.qub.ac.uk/ccbg/
fluorescence-image—analysis—intro/

3D/4D image reconstruction using Image]J/Fiji: http://www.encite.org/html/
img/pool/7_3D_image_reconstructions_pll5-144.pdf

Math-Clinic Biolmage Analysis events page: http://cellnetmcweb.bioquant.
uni-heidelberg.de/index.php/BioImage_Analysis

Biolmage Information Index: http://biii.info/
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