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Feedback .......................................................................................................... 8 
 
 

Typographical Conventions 

The following kinds of formatting in the text identify special information. 

Formatting convention Type of Information Example 

Special Bold Items you must select, such as 
menu options, command 
buttons, or items in a list. 

Go to the QoS tab. 

Titles of chapters, sections, 
and subsections. 

Read the Basic Administration 
chapter. 

Italics Used to emphasize the 
importance of a point, to 
introduce a term or to 
designate a command line 
placeholder, which is to be 
replaced with a real name or 
value. 

The system supports the so 
called wildcard character 
search. 

Monospace The names of style sheet 
selectors, files and directories, 
and CSS fragments. 

The license file is called 

license.key. 

Preface 
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Preformatted Bold What you type, contrasted with 
on-screen computer output. 

Unix/Linux: 

# cd /root/rpms/php 

Windows: 

>cd %myfolder% 

Preformatted On-screen computer output in 
your command-line sessions; 
source code in XML, C++, or 
other programming languages. 

Unix/Linux: 

# ls –al /files 

total 14470 

Windows: 

>ping localhost 

Reply from 127.0.0.1: 

bytes=32 time<1ms 

TTL=128 

 
 

Feedback 

If you have found an error in this guide, or if you have suggestions or ideas on how to 
improve this guide, please send your feedback using the online form at 
http://www.parallels.com/en/support/usersdoc/. Please include in your report the guide's title, 
chapter and section titles, and the fragment of text in which you have found an error. 
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Logging In to Parallels Plesk Panel 

 To log in to your Parallels Plesk Panel: 

1. Open your web browser, and in the address bar type the URL where 
your Parallels Plesk Panel is located (for example, 
https://your.domain.com:8443). 

2. Press ENTER.  

Parallels Plesk Panel login screen will open. 

3. Type the login name and password your provider gave you into the 
Login and Password boxes, respectively.  

Your login name would be your domain name. 

4. If you log in for the first time, select the language for your control panel 
from the Interface language drop-down box.  

If you had previously specified the interface language and saved it in your interface 
preferences, leave the User default value selected. 

5. Click Login. 
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Becoming Familiar with Parallels Plesk 
Panel 

When you log in to the Parallels Plesk Panel, it shows your Home page with shortcuts 
to the operations you frequently perform. 

 

The top banner area provides access to the following functions: 

 My account. This is where you can select a language and theme for your control 
panel and change your contact information. 

 Switch user. This is where you can switch between user accounts. This shortcut is 
shown only when single sign-on technology is enabled on the server. 

 Log out. This is where you close your session when you have finished working with 
control panel.  

The navigation pane on the left provides access to the following sets of functions: 

 Home. This is where you start working with the control panel. Most of the operations 
you might need to perform are accessible from this area. 

 Mail. This is where you perform operations on e-mail accounts. You can accomplish 
the following tasks from this area of the control panel: 

 Set up and manage mailboxes. 

 Set up mailing lists, automatic responses, mail forwarders. 

 Applications. This is where you can view and install applications on your Web site. 
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 Settings. This is where you specify settings for the Web site hosting service and 
Web statistics. 

 Global Account. This shortcut appears in your Parallels Plesk Panel when the single 
sign-on capabilities are switched on on the hosting server. Single sign-on 
technology allows you to log in to different Parallels products using a single global 
login name and password. This shortcut is used for changing the global login 
settings. 

 Help Desk. This is the help desk system integrated with your control panel. If you see 
this shortcut in the navigation pane, then it is likely that your provider uses it; so you 
can use it to report your problems to provider's technical support staff. If this link is 
not shown in your Panel, then it means that your provider does not use the built-in 
Help Desk. In such a case, you should use other means to contact your provider 
when you need assistance. 

 Help. Provides context sensitive help. 

To see information about a tool or an item on the page, hover the cursor over an item, 
without clicking it, and a small hover box appears with supplementary information 
regarding the item being hovered over. 

 

If your hosting plan includes the Web site creation and management service using 
Parallels Plesk Sitebuilder, the following shortcuts are also shown in your control 
panel's navigation pane under the Sitebuilder Administration group: 

 Home page. This provides shortcuts to the task-oriented wizards. Here you can 
perform any operations on your account and Web site through the Sitebuilder 
system. For more information, see 
http://download1.parallels.com/SiteBuilder/4.5.0/doc/site_owner/en_US/html/using_
desktop_interface.htm. 

 Sites. Here you can add and manage sites. For more information, see 
http://download1.parallels.com/SiteBuilder/4.5.0/doc/site_owner/en_US/html/manag
ing_sites.htm. 

The main working area on the right provides access to the tools available for the 
current section of the control panel selected in the navigation pane. Additional 
operations are accessible from drop-down menus that open when you click group titles. 

 

http://download1.parallels.com/SiteBuilder/4.5.0/doc/site_owner/en_US/html/using_desktop_interface.htm
http://download1.parallels.com/SiteBuilder/4.5.0/doc/site_owner/en_US/html/using_desktop_interface.htm
http://download1.parallels.com/SiteBuilder/4.5.0/doc/site_owner/en_US/html/managing_sites.htm
http://download1.parallels.com/SiteBuilder/4.5.0/doc/site_owner/en_US/html/managing_sites.htm
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To navigate through Parallels Plesk Panel, you can use a path bar: a chain of links that 
appears in the right part of the screen, below the banner area. 

 

To the right of the path bar, there are Favorites and Visited Pages menus. The Visited 
Pages menu keeps the shortcuts to the recently visited control panel screens. These 
shortcuts are added automatically. The Favorites menu keeps the shortcuts to the 
screens that you manually add to favorites. For information about working with 
shortcuts in the Favorites menu, see the section Customizing Your Home Page (on 
page 18). 

To return to a previous screen, use the shortcuts in the path bar, or the Up Level icon in 
the upper-right corner of the screen. 

When changing settings for an e-mail account, you can quickly select another e-mail 
account whose settings you also want to change. To do this, click a small arrow icon 
located to the right of the e-mail address.  

 

This will open a list of e-mail addresses that you can select. 

 

To sort a list by a certain parameter in ascending or descending order, click on the 
parameter's title in the column heading. The order of sorting will be indicated by a small 
triangle displayed next to the parameter's title. 
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Changing Your Contact Information and 
Password 

 If you need to update your contact information, or change password: 

1. On your Home page, click Personal Data. 

2. Update your information as required, or type a new password, and click 
OK.  

 If you forgot your password: 

1. In your web browser‘s address bar, type the URL where your Parallels 
Plesk Panel is located. For example, https://your.domain.com:8443. 

2. Press ENTER.  

Parallels Plesk Panel login screen will open. 

3. Click the Forgot your password? link. 

4. Type your domain name into the Login box, and type your e-mail 
address registered in the system into the E-mail box.  

5. Click OK.  

Your password will be sent to your e-mail address. 

 



 

  
 

Global Account is a single sign-on (SSO) technology feature that allows you to log in to 
different Parallels products using a single global login and password. If you have 
several accounts in Parallels Plesk Panel, you can connect them all to a global account 
and switch between these accounts without entering a password every time. You can 
also connect all your accounts in other Parallels products to your global account and 
switch between them without providing credentials. 

In this chapter: 

Creating a Global Account ................................................................................. 14 
Connecting Local Accounts To Your Global Account ......................................... 15 
Switching Between Accounts ............................................................................ 16 
Changing Global Account Password ................................................................. 16 
Disconnecting Local Accounts From Global Account ......................................... 16 
 
 

Creating a Global Account 

After you create a global account and connect local accounts to it, you will be able to 
choose from any account connected to your global account when logging in under your 
global account. 

 To create a global account: 

1. Log in to Parallels Plesk Panel, go to Global Account and click Connect To 
Global Account. 

2. Select Create new global account and provide the login and password for 
your global account. 

3. Click OK. 

Your global account is active now, so you can proceed with connecting other accounts 
to it. Refer to the section Connecting Local Accounts to Your Global Account (on page 
15) for more information. 
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Connecting Local Accounts To Your 
Global Account 

 To connect a local Parallels Plesk Panel account to your global account: 

1. Log in to Parallels Plesk Panel under the local account you want to 
connect. 

2. Go to Global Account and click Connect To Global Account. 

3. Make sure that Use existing global account option is selected and provide 
the login and password for the global account you want to connect to. 

4. Click OK. 

Repeat steps 1-4 for other local accounts as necessary. 

 To connect an account in another product with SSO support to your 
global account: 

1. Log in to software product with SSO support under the account you 
want to connect. 

2. Follow the instructions on connecting to a global account in respective 
software product documentation. Make sure that you provide the 
credentials for the existing global account when you are asked to. 

Repeat steps 1-2 for other accounts or products as necessary. 

Note. Different software products may use different names for the Global Account 
feature, such as Federated Identity or Global Login. Refer to respective software 
product documentation for more information. 

After you have connected all required accounts to your global account, you can log in 
under your global account all the time in any product where you have a local account 
connected to your global account. You will be shown the list of local accounts 
connected to your global account every time you log in under it, so you can choose 
which account you would like to use now. You can switch to another account any time 
you want. Refer to the section Switching Between Accounts for more information. 
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Switching Between Accounts 

 To switch to another account: 

1. Click Switch User in the upper right corner. 

2. Select the account you want to switch to: 

 Choose the required local account from the list of accounts connected to your 
global account 

or 

 Select Specify credentials for another account and provide login and password for a 
local account not connected to your global account or to another global account. 
You can also specify the language for your control panel from the Interface 
language menu. If you had previously specified the interface language for that 
account and saved it in its interface preferences, leave the Default value 
selected. 

3. Click OK. 

 

Changing Global Account Password 

 To change password of your global account: 

1. Log in to Parallels Plesk Panel under your global account or any local 
account connected to it. 

2. Go to Global Account and click Change Password. 

3. Enter your old and new passwords, and click OK. 

 

Disconnecting Local Accounts From 
Global Account 

 To disconnect a local account from your global account: 

1. Log in to Parallels Plesk Panel under the local account you want to 
disconnect. 
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2. Go to Global Account and click Disconnect From Global Account. 

3. Confirm the disconnection and click OK. 

Repeat steps 1-3 for other local accounts as necessary. 
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Customizing Your Home Page 

 To add or remove items from the Home page: 

1. Go to Home > Domains > Domain group title menu > Customize Home page. 

2. Specify what domain information and statistics should be shown on the 
Home page by selecting the corresponding items check boxes.  

3. Specify what actions should be shown on the Home page. The Selected 
actions lists show the tasks for which shortcuts are already placed on the 
Home page. The Available actions lists show the tasks for which you do 
not yet have shortcuts on your Home page. 

 To add a shortcut to the Home page, select the required tasks in the Available 
actions list and click Add >>. 

 To remove a shortcut from the Home page, select the task that you do not need 
in the Selected actions list and click << Remove. 

4. Specify what actions should be shown in the drop-down menus on the 
Home page by selecting the corresponding check boxes.  

5. Click OK. 

 To add shortcuts to control panel screens to the Favorites menu on the 
Home page: 

1. Navigate to the control panel screen you need. 

2. In the Favorites menu, select Add to Favorites. 

 To edit shortcut descriptions in the Favorites menu on the Home page: 

1. On your Home page, open the Favorites menu. 

C H A P T E R  3  

Customizing Your Control Panel 



 

 Customizing Your Control Panel 19 

 

2. Place the mouse pointer over the shortcut you need and click Edit 
favorite's name. 

3. Type the shortcut title and description and click Save. 

 To remove shortcuts from the Favorites menu: 

1. On the Home page, open the Favorites menu. 

2. Place the mouse pointer over the shortcut you want to remove and click 
Remove from favorites. 

Setting Interface Language and Skin for 
Your Control Panel 

 To select an interface language and theme (skin) for your control panel: 

1. On your Home page, click Interface Preferences. 

2. Select the desired interface language and skin from the respective 
menus.  

Parallels Plesk Panel‘s interface has been translated to a number of  languages, so 
if you do not see your own language in the list, ask your provider to install the 
respective language pack. 

3. Click OK. 

Adding and Removing Hyperlink Buttons 

 To add a custom hyperlink button to your Parallels Plesk Panel: 

1. Go to Home > Custom Buttons, and click Create Custom Button. 

2. Specify properties of the button: 

 Type the text that will show on your button in the Button label field. 

 Choose the location for your button. To place it in the right frame of your Home 
page, select the Domain Administration page value as the location. To place it in 
the left frame (navigation pane) of your control panel, select the Navigation pane 
value. 

 Specify the priority of the button. Parallels Plesk Panel will arrange your custom 
buttons on the control panel in accordance with the priority you define: the lower 
the number – the higher is priority. Buttons are placed in the left-to-right order. 
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 To use an image for a button background, type the path to its location or click 
Browse to browse for the desired file. It is recommended that you use a 16x16 
pixels GIF or JPEG image for a button to be placed in the navigation pane, and 
32x32 pixels GIF or JPEG image for buttons placed in the main frame. 

 Type the hyperlink of your choice to be attached to the button into the URL field. 

 Using the check boxes, specify whether to include the data, such as domain id 
and domain name to be transferred within the URL. These data can be used for 
processing by external web applications. 

 In the Context help tip contents input field, type in the help tip that will be displayed 
when you hover the mouse pointer over the button. 

 Select the Open URL in the control panel check box if you wish the destination URL 
to be opened in the control panel's right frame, otherwise leave this check box 
unchecked to open the URL in a separate browser window. 

 If you wish to make this button visible to the mailbox users with access to control 
panel, select the Visible to all sub-logins check box. 

3. Click OK to complete creation. 

 To remove a hyperlink button from your Parallels Plesk Panel: 

1. Go to Home > Custom Buttons. 

2. Select a check box corresponding to the button that you want to remove 
and click Remove. 

 

 



 

  
 

 To review or select the hosting features available for your account (if your 
provider delegated the permission to manage the hosting options for your 
account): 

1. On your Home page, click Web Hosting Settings. 

2. View or change your hosting options: 

 IP Address. Your domain can be hosted on either exclusive IP address or shared 
IP address. Choose an address from your service provider's IP addresses pool. 

 Certificate. Shows the information about an SSL certificate used by your site. 

 SSL support. Secure Sockets Layer encryption is generally used for protecting 
transfer of sensitive data during online transactions on e-commerce Web sites 
that run on dedicated IP addresses. SSL certificates that participate in the 
encryption process are usually applied to a single domain name on a single IP 
address, therefore, each site that needs SSL protection must be hosted on a 
dedicated IP address. An exception to this is subdomains, which you can 
protect with a wildcard certificate. Installing an SSL certificate on a Web server 
that hosts several web sites with different domain names on a single IP address 
(shared or name-based hosting) is technically possible, however, it is not 
recommended: the encryption will be provided, but users will get warning 
messages on attempt to connect to the secure site. To allow SSL encryption for 
Web sites, select the SSL support check box. 

 Use a single directory for housing SSL and non-SSL content (available only for Linux 
hosting). By default, when users publish their sites through their FTP accounts, 
they need to upload the web content that should be accessible via secure 

connections to the httpsdocs directory, and the content that should be 

accessible via plain HTTP, to the httpdocs directory. For the convenience of  

publishing all content through a single location – httpdocs directory, select the 

Use a single directory for housing SSL and non-SSL content check box. 

 FTP login and FTP password. Specify the user name and password that will be 
used for publishing the site to the server through FTP. Retype the password into 
the Confirm Password box. 

 Hard disk quota. Specify the amount of disk space in megabytes allocated to the 
web space for this site. This is the so-called hard quota that will not allow writing 
more files to the web space when the limit is reached. At attempt to write files, 
users will get the "Out of disk space" error. Hard quotas should be enabled in 
the server's operating system, so if you see the "Hard disk quota is not 
supported" notice to the right of the Hard disk quota field, but would like to use the 
hard quotas, contact your provider or the server administrator and ask to enable 
the hard quotas. 
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 Shell access to server with FTP user's credentials (available only for Linux hosting) or 
Access to system (available only for Windows hosting). This allows you to upload 
securely web content to the server through a Secure Socket Shell connection, 
however, allowing shell access also poses a potential threat to the server 
security, so we recommend that you do not allow shell access. Leave the 
Forbidden option selected. 

 Microsoft FrontPage support. Microsoft FrontPage is a popular web site authoring 
tool. To enable users to publish and modify their sites through Microsoft 
FrontPage, select the Microsoft FrontPage support and Microsoft FrontPage over SSL 
support check boxes, set the Microsoft FrontPage authoring option to allowed, and 
specify the FrontPage Administrator's login and password. 

 Services, or support for programming and scripting languages supported by your 
hosting environment. Specify which of the following  programming and scripting 
languages should be interpreted, executed or otherwise processed by the web 
server: Active Server Pages (ASP), Server Side Includes (SSI), PHP hypertext 
preprocessor (PHP), Common Gateway Interface (CGI), Fast Common 
Gateway Interface (FastCGI), Perl, Python, ColdFusion and Miva scripting 
required for running Miva e-commerce solutions. 

 Web statistics. To allow you to view the information on the number of people 
visited your site and the pages of the site they viewed, select the required 
program from Web statistics menu (AWStats is recommended) and select the 
accessible via password protected directory /plesk-stat/webstat check box. This will 
install the statistics program which will generate reports and place them into the 
password protected directory. You will then be able to access Web statistics at 
the URL: https://your-domain.com/plesk-stat/webstat using your FTP account 
login and password. 

Note: When you switch from one statistics program to another, all reports 
created by the previously used statistics program are deleted and new 
reports are created in accordance with the information read from log files 
kept on the server. This means that if you configured the system (at Log 
Manager > Log Rotation) so as to keep log files only for the last month, then 
Web statistics will be available only for the last month.    

 Custom error documents. When visitors coming to your site request pages that the 
web server cannot find, the web server generates and displays a standard 
HTML page with an error message. If you wish to create your own error pages 
and use them on your web server, select the Custom error documents check box. 

 Additional write/modify permissions (available only for Windows hosting). This 
option is required if Web applications under a domain will be using a file-based 

database (like Jet) located in the root of httpdocs or httpsdocs folders. 

Please note that selecting this option might seriously compromise the Web site 
security. 

 Use dedicated IIS application pool (available only for Windows hosting). This option 
enables the use of dedicated IIS application pool for Web applications on a 
domain. Using dedicated IIS application pool dramatically improves the stability 
of domain Web applications due to worker process isolation mode. This mode 
gives each Web site hosted on the server the possibility to allocate a separate 
process pool for execution of its Web applications. This way, malfunction in one 
application will not cause stopping of all the others. This is especially useful 
when you are using shared hosting package. 
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3. Click OK. 

  

In this chapter: 

Viewing the Resource Allotments for Your Account ........................................... 23 
Viewing the Permissions for Operations You Can Perform through the Control Panel
 .......................................................................................................................... 25 
 

Viewing the Resource Allotments for Your 
Account 

 To view the amounts of resources your Web site and e-mail accounts can 
consume: 

1. Go to Home > Resource Usage. 

2. The resource allotments are listed as follows: 

 Disk space. The total amount of disk space allocated to your hosting account. 
This amount is measured in megabytes. It includes disk space occupied by all 
files related to this domain/Web site: Web site contents, databases, 
applications, mailboxes, log files and backup files. 

 Maximum amount of traffic. Displays the amount of data in megabytes that can be 
transferred from your Web site during a month. 

 Maximum number of subdomains. The number of subdomains that can be hosted 
under your domain. 

 Maximum number of domain aliases. The number of additional alternative domain 
names that you can use for your site. 

 Maximum number of Web users. Shows the number of personal web pages that you 
can host for other users under your domain. This service is mostly used in 
educational institutions that host non-commercial personal pages of their 
students and staff. These pages usually have web addresses like http://your-
domain.com/~username. If the Allow the Web users scripting check box is 
selected, execution of scripts embedded in personal web pages is allowed. See 
the Hosting Personal Web Pages on Your Web Server section for details. 

 Maximum number of additional Microsoft FrontPage accounts (available only for 
Windows hosting). Displays the maximum number of additional Microsoft 
FrontPage accounts you can create on your domain. 

 Maximum number of FTP accounts (available only for Windows-based hosting). 
Displays the maximum number of FTP accounts you can create on your domain. 

 Maximum number of mailboxes. Shows the number of mailboxes that can be hosted 
in your domain. 
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 Maximum number of mail redirects. Shows the number of mail forwarders that can 
be used in your domain. 

 Maximum number of mail groups. Shows the maximum number of mail groups that 
can be used in your domain. 

 Maximum number of mail autoresponders. Displays the number of automatic 
responses that can be set up in your domain. 

 Maximum number of mailing lists. Shows the number of mailing lists that you can 
run in a domain. The mailing lists are served by the GNU Mailman software, 
which may or may not be installed on the server. If it is not installed and you 
would like to use it, ask your service provider to install it.  

 Mailbox quota. Displays the amount of disk space in kilobytes that is allocated for 
storing e-mail messages and autoresponder attachment files to each mailbox in 
your domain.  

 Maximum number of databases (available only for Linux hosting). Displays the 
number of databases that can be hosted in your domain. 

 Maximum number of MySQL databases and Maximum number of Microsoft SQL server 
databases (available only for Windows hosting). Displays the maximum number 
of MySQL and Microsoft SQL Server databases that can be used by your 
domain. 

 MySQL databases quota and Microsoft SQL databases quota (available only for 
Windows hosting). Displays the maximum disk space amount in megabytes that 
MySQL and Microsoft SQL Server databases used by your domain can occupy. 

 Maximum number of ODBC connections (available only for Windows hosting). 
Displays the total number of ODBC connections that can be used by your 
domain. 

 Maximum number of ColdFusion DSN connections (available only for Windows 
hosting). Displays the total number of ColdFusion DSN connections that can be 
used by your domain. 

 Maximum number of Java applications. Displays the maximum number of Java 
applications or applets that you can install in a domain. 

 Maximum number of shared SSL links (available only for Windows hosting). Displays 
the total number of shared SSL links that can be used on your domain. 

 Validity period. Shows the term for a hosting account. At the end of the term, your 
domain/web site will be suspended, its Web, FTP and mail services will no 
longer be accessible to the Internet users, and you will not be able to log in to 
the control panel.  

3. Click OK. 
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Viewing the Permissions for Operations 
You Can Perform through the Control 
Panel 

 To view the permissions for operations you can perform through your 
control panel: 

1. Go to Home > Domain Administrator Access. 

2. The permissions are listed in the Permissions group: 

 Physical hosting management. Shows whether you can fully control hosting 
account for your Web site. If it says No, then you can only change FTP password 
for accessing your Web space. 

 Hosting performance management. Shows whether you can limit bandwidth usage 
and number of connections to your Web site. 

 FTP password management. Shows whether you are allowed to change your 
credentials for access to Web space through FTP. 

 Management of access to server over SSH (available only for Linux hosting) or 
Management of access to server over Remote Desktop (available only for Windows 
hosting). Shows whether you can access the server through Secure Shell (for 
Linux hosting) or Remote Desktop (for Windows hosting) protocols. 

 Hard disk quota assignment. Shows whether you can set up the hard quota on disk 
space allocated to your site. 

 Subdomains management. Shows whether you can set up, modify and remove 
subdomains in your domain. 

 Domain aliases management. Shows whether you can set up additional alternative 
domain names for your Web site. 

 Log rotation management. Shows whether you can adjust the cleanup and 
recycling of processed log files for your site. 

 Anonymous FTP management. Shows whether you can have an FTP directory 
where all users could download and upload files without the need to enter login 
and  password. A Web site should reside on a dedicated IP address in order to 
use anonymous FTP service. 

 FTP accounts management (available only for Windows-based hosting). Shows 
whether you can create and manage FTP accounts. 

 Scheduler management. Shows whether you can schedule tasks in the system. 
Scheduled tasks can be used for running scripts or utilities on schedule. 

 DNS zone management. Shows whether you can manage the DNS zone of your 
domain. 

 Java applications management. Shows whether you can install Java applications 
and applets on your Web site through the control panel. 
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 Web statistics management. Shows whether you can manage Web statistics for 
this site. 

 Mailing lists management. Shows whether you can use mailing lists provided by the 
GNU Mailman software. 

 Spam filter management. Shows whether you can use spam filter provided by the 
SpamAssassin software. 

 Antivirus management. Shows whether you can use server-side antivirus 
protection for filtering incoming and outgoing mail. 

 Backup and restore functions. Shows whether you can use the control panel's 
facilities to backup and restore your site. Scheduled and on-demand backups 
are supported. 

 Ability to use Sitebuilder. Shows whether you can use Sitebuilder for creating and 
editing your site. 

 IIS application pool management (available only for Windows hosting). Shows 
whether you can manage your IIS application pool. 

 Additional write/modify permissions management (available only for Windows 
hosting). Shows whether you can manage additional write/modify permissions 
for your site. These permissions are required if your Web applications are using 

a file-based database (like Jet) located in the root of httpdocs or httpsdocs 

folders. 

 Home page management. Shows whether you can customize and manage your 
Home page. 

 Ability to select a database server. Shows whether you can select a database server 
of each type for creating your databases, not only use the default database 
server. 

3. Click OK. 

 

 



 

  
 

Once you have registered your domain name, constructed your Web site, and 
purchased a hosting package from your hosting service provider, you can: 

 Publish your site to your web space on the provider‘s server, 

 Deploy databases and applications that your web server will be using, 

 Secure data transfer with Secure Sockets Layer encryption and restrict access to 
web server resources with password protection. 
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Creating and Publishing Your Site 

If your hosting plan includes the Web site creation and management service using 
Sitebuilder, you can create and publish Web sites using Sitebuilder. Or you can create 
your site content (Web pages, scripts and graphic files that compose your site) on your 
home or office computer and then publish it to the server in any of the following ways: 

 Through FTP connection (most common and easiest way) 

 Through control panel's file manager 

 Through Secure Shell connection (only for users of Linux and FreeBSD operating 
systems) 

 Through Adobe Dreamweaver or Microsoft FrontPage software (only for users of 
Microsoft Windows operating systems) 

 

In this section: 

Creating and Publishing Web Sites Using Sitebuilder ........................................ 28 
Publishing a Site Through FTP .......................................................................... 29 
Publishing a Site Through Parallels Plesk Panel's File Manager ....................... 31 
Publishing a Site Through SSH Connection ...................................................... 32 
Publishing a Site From Microsoft FrontPage (Windows Hosting) ....................... 32 
Using Additional Microsoft FrontPage Accounts (Windows Hosting) ................. 35 
Changing Microsoft FrontPage Settings (Windows Hosting) .............................. 36 
Publishing a Site From Adobe Dreamweaver .................................................... 37 
 
 

Creating and Publishing Web Sites Using Sitebuilder 

 To start creating a Web site using Sitebuilder: 

1. On your Home page, click Edit in Sitebuilder. The Sitebuilder wizard 
opens. 

2. Select the Create your site option and click Next at the bottom of the 
screen. 

For further instructions on creating or editing your site, refer to the online Sitebuilder 
Wizard user's guide at  
http://download1.parallels.com/SiteBuilder/4.5.0/doc/user/en_US/html/index.htm. 
 

http://download1.parallels.com/SiteBuilder/4.5.0/doc/user/en_US/html/index.htm
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Publishing a Site Through FTP 

 To upload your site through FTP: 

1. Connect to the server with an FTP client program, using FTP account 
credentials your provider gave you. The FTP address should be 
ftp://your-domain-name.com, where your-domain-name.com is your 
site's Internet address. 

Enable the passive mode if you are behind a firewall. 

2. Upload files and directories that should be accessible through HTTP 

protocol to the httpdocs directory, and files/directories that should be 

transferred securely over SSL protocol to the httpsdocs directory.  

3. Place your CGI scripts into the cgi-bin directory. 

4. Close your FTP session. 

 

In this section: 

Changing Your FTP Account Credentials .......................................................... 29 
Using Additional FTP Accounts (Windows Hosting)........................................... 29 
 
 

Changing Your FTP Account Credentials 

 To change the user name and password for accessing your FTP account: 

1. On your Home page, click Web Hosting Settings. 

2. Specify the new FTP login name and password. 

3. Click OK. 

 
 

Using Additional FTP Accounts (Windows Hosting) 

If you are working on your web site together with someone else or host subdomains for 
other users, you might want to create additional FTP accounts. 

In this section: 

Creating Additional FTP Accounts (Windows Hosting) ...................................... 30 
Changing Settings of Additional FTP Accounts ................................................. 30 
Removing Additional FTP Accounts .................................................................. 31 
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Creating Additional FTP Accounts (Windows Hosting) 

 To create a new additional FTP account: 

1. Go to Home > FTP Accounts. 

2. On the FTP Accounts tab, click Create FTP Account.  

3. Specify the FTP account name in the appropriate field. 

4. Specify the Home directory by clicking  and select the directory 

required. Alternatively, you can specify the path in the input field. 

5. Type the new password into the New password and Confirm password 
boxes. 

6. Specify what FTP user can do with files and folders, and how much disk 
space on the server he or she can occupy: 

 To limit the amount of disk space, clear the Unlimited check box next to the Hard 
disk quota box, and type the amount of disk space in megabytes. 

 To allow the FTP user to view the contents of the home directory and download 
files from it, select the Read permission check box.    

 To allow the FTP user to create, view, rename and delete directories in the 
home directory, select the Write permission check box. 

If you do not grant any permissions, a connection to the FTP account will be 
made, but the contents of the home directory will not be shown to the user. 

7. Click OK. A new FTP account will be added. 

 
 

Changing Settings of Additional FTP Accounts 

 To change the properties of an additional FTP account:  

1. Go to Home > FTP Accounts.   

2. On the FTP Accounts tab click the required FTP account name in the list. 

3. Specify the changes as required and click OK.  
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Removing Additional FTP Accounts 

 To remove an additional FTP account: 

1. Go to Home > FTP Accounts. 

2. On the FTP Accounts tab, select the check box corresponding to the FTP 
account name you want to remove and click Remove. 

3. Confirm removal and click OK.  The FTP account will be removed. 

 

Publishing a Site Through Parallels Plesk Panel's File 
Manager 

 To upload files through control panel's file manager: 

1. On your Home page, click File Manager. 

2. Create and upload files and directories.  

Place the files and directories that should be accessible via HTTP protocol to the 

httpdocs directory, and files/directories that should be transferred securely over 

SSL protocol to the httpsdocs directory. Place your CGI scripts into the cgi-bin 

directory. 

 To create a new directory within your current location, click Add New Directory. 

 To create new files in the required directory, click Add New File, in the File creation 
section specify the file name, select the Use html template check box, if you want 
file manager to insert some basic html tags to the new file, and click OK. A page 
will open allowing you to enter the content or html-formatted source of a new 
file. After you are done, click OK. 

 To upload a file from the local machine, click Add New File, specify the path to its 
location in the File source box (or use the Browse button to locate the file), and 
click OK. 

 To edit a Web page in the built-in visual editor (available only to users of 

Microsoft Internet Explorer), click . When editing an HTML file, Plesk opens 
internal WYSIWYG editor by default. If you want to edit the source code of the 
HTML file, click HTML. To return back to WYSIWYG mode, click Design. 

 To edit the source code of a file, click . 

 To view the file, click . 

 To rename a file or directory, click . Type in a new name and click OK. 

 To copy or move a file or directory to another location, select the required file or 
directory using the appropriate check box, and click Copy/Move. Specify the 
destination for the file or directory to be copied or renamed to, then click Copy to 
copy, or Move to move it. 
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 To update the file or directory creation date, click Change timestamp. The time 
stamp will be updated with the current local time. 

 To remove a file or directory, select the corresponding check box, and click 
Remove. Confirm removal and click OK.  

When you upload Web content through File Manager or FTP, your control panel 
automatically sets the appropriate access permissions for files and directories. If you 
need to change the permissions for files and directories, refer to the sections: 

Setting File and Directory Access Permissions (Linux hosting) (see page 67). 

Setting File and Directory Access Permissions (Windows hosting) (see page 67). 

Publishing a Site Through SSH Connection 

If your are using a Linux or FreeBSD operating system on your local computer and 

have access to server shell, use the ‗scp‘ command to copy files and directories to the 

server: scp your_file_name login@remoteserver.com:path to copy files, 

and scp –r your_directory_name login@remoteserver.com:path to copy 

entire directories. 

After publishing, you will be able to work with files and directories on your account 
using SSH terminal web application integrated in your Parallels Plesk Panel (Home > 
SSH Terminal). 

Publishing a Site From Microsoft FrontPage (Windows 
Hosting) 

Microsoft FrontPage deals with two kinds of Web sites: disk-based and server-based. 
In short, a disk-based site is a FrontPage Web site you create on your local hard disk 
and then later publish to a Web server. A server-based site is one you create and work 
with directly on a Web server, without the extra step of publishing. This section 
provides you with instructions on publishing only disk-based web sites. 

You can publish disk-based web sites either through FTP or HTTP. If your server is 
running FrontPage Server Extensions, you would publish your site to an HTTP location. 
For example: http://your-domain.com/MyWebSite. If your server supports FTP, you 
would publish to an FTP location. For example: ftp://ftp.your-domain.com/myFolder. 

To find out which publishing method your server supports, contact your hosting 
company, or your IT department. 

After publishing, you can manage your site through FrontPage Server Extensions.  

 To access FrontPage Server Extensions management interface: 

1. Log in to Parallels Plesk Panel. 
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2. To manage a site, which is not protected by SSL, open the Web Site 
group title menu, and click Frontpage Webadmin. To manage an SSL-
enabled site, open the Web Site group title menu, and click Frontpage SSL 
Webadmin. 

3. Type your FrontPage administrator‘s login name and password, and 
click OK. 

For instructions on using FrontPage server extensions, see online help (Frontpage 
Webadmin > Help) or visit Microsoft Web site. 

In this section: 

Publishing Sites From Microsoft FrontPage Through FTP ................................. 33 
Publishing Sites From Microsoft FrontPage Through HTTP .............................. 34 
 

Publishing Sites From Microsoft FrontPage Through FTP 

If you are publishing from a computer at work, ask your IT department, help desk, or 
network administrator if you are allowed to publish with FTP beyond a firewall. Also ask 
if you need to install special software that allows you to publish beyond the firewall. 

 To publish files through FTP: 

1. Open Microsoft FrontPage. 

2. Open a Microsoft  FrontPage Web site: open File menu and select the 
Open Site item. 

3. Go to Remote Web site view: click the Web Site tab, and then the Remote Web 
Site button at the bottom of the window. 

4. Set up your Remote Web Site Properties: 

 Click the Remote Web Site Properties button in the upper-right corner of the 
window. 

 Select FTP as the remote Web server. 

 In the Remote Web site location box, type your host name (e.g., ftp://ftp.your-
domain.com) 

 In the FTP directory box, type your FTP directory if your hosting company 
provided one. Leave it blank if they did not specify one. 

 Select the Use Passive FTP check box if your computer or network is protected by 
a firewall.  

5. Click OK to connect to the remote site.  

The Remote Web site view will show files that you have in your local and remote 
sites. 

6. Click the Publish Web site button in the lower-right corner of the window. 
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Publishing Sites From Microsoft FrontPage Through HTTP 

 To publish files through HTTP on a server that supports FrontPage Server 
Extensions: 

1. Open your FrontPage program. 

2. Open a FrontPage Web site: open File menu and select the Open Site 
item. 

3. Go to Remote Web site view: click the Web Site tab, and then the Remote Web 
Site button at the bottom of the window. 

4. Click the Remote Web Site Properties button in the upper-right corner of the 
window. 

5. On the Remote Web Site tab, under Remote Web server type, click FrontPage or 
SharePoint Services. 

6. In the Remote Web site location box, type the Internet address, including 
the protocol, of the remote Web site that you want to publish folders 
and files to — for example, http://www.your-domain.com — or click 
Browse to locate the site. 

7. Do any of the following:  

 To use Secure Sockets Layer (SSL) for establishing a secure communications 
channel to prevent the interception of critical information, click Encryption 
connection required (SSL). To use SSL connections on your Web server, the 
server must be configured with a security certificate from a recognized certificate 
authority. If the server does not support SSL, clear this check box. Otherwise, 
you will not be able to publish folders and files to the remote Web site. 

 To remove specific types of code from Web pages as they are being published, 
on the Optimize HTML tab, select the options you want. 

 To change the default options for publishing, on the Publishing tab, select the 
options you want. 

8. Click OK to connect to the remote site.  

The Remote Web site view will show files that you have in your local and remote sites. 

9. Click the Publish Web site button in the lower-right corner of the window. 
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Using Additional Microsoft FrontPage Accounts 
(Windows Hosting) 

If you are working on your web site together with someone else or host subdomains for 
other users, you might want to create additional Microsoft FrontPage accounts. 

In this section: 

Creating Additional Microsoft FrontPage Accounts ............................................ 35 
Changing Settings of Additional Microsoft FrontPage Accounts ........................ 35 
Removing Additional Microsoft FrontPage Accounts ......................................... 36 
 

Creating Additional Microsoft FrontPage Accounts 

 To create an additional Microsoft FrontPage account: 

1. On your Home page, open the Web Site group title menu, and click 
FrontPage Management. 

2. Click Add New FrontPage Account. 

3. Specify the login and password for this account. 

4. If you wish to limit the amount of disk space that can be used by this 
account, clear the Unlimited check box and type the desired value in 
megabytes into the Hard disk quota box. 

When the specified limit is exceeded, the account owner will not be able to add files 
to his or her Web space. 

5. Click OK to finish the creation of an additional Microsoft FrontPage 
account. 

 

Changing Settings of Additional Microsoft FrontPage Accounts 

 To change settings for an additional Microsoft FrontPage account: 

1. On your Home page, open the Web Site group title menu, and click 
FrontPage Management. 

2. Click the required account in the list. 

3. Specify new login and password for this account. 

4. Adjust the limit on the amount of disk space that can be used by this 
account by specifying the new limit in the Hard disk quota box.  
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When the specified limit is exceeded, the account owner will not be able to add files 
to his or her Web space. 

5. Click OK to save changes. 

 

Removing Additional Microsoft FrontPage Accounts 

 To remove an additional Microsoft FrontPage account: 

1. On your Home page, open the Web Site group title menu, and click 
FrontPage Management. 

2. Select the check box corresponding to the account you want to remove. 

3. Click Remove. 

4. Confirm the removal and click OK. 

 

Changing Microsoft FrontPage Settings (Windows 
Hosting) 

If you want Microsoft FrontPage to use its own IIS Index Server to build the full-text 
index of your Web site. 

 To make Microsoft FrontPage use its own IIS Index Server: 

1. On your Home page, open the Web Site group title menu, and click 
FrontPage Management. 

2. Click Preferences. 

3. Select Use the IIS Index Server check box and click OK. 

If you use FrontPage forms that submit information by e-mail on your site, you may 
want to specify the following preferences: 

 SMTP mail server that will be used for sending mail. By default, SMTP server specified in 
the domain's DNS zone is used for sending mail. If no SMTP server is specified in 
the zone, then FrontPage uses the mail service running on the server where the 
domain (site) is hosted. 

 Sender's e-mail address. By default, domain owner's e-mail address is used. If the 
domain owner's e-mail address is not specified in domain owner's profile, then 
FrontPage uses the e-mail address of the client, to whom the domain belongs. If the 
client's e-mail address is not specified in the client's profile, then the server 
administrator's e-mail address is used. 



 

 Setting Up And Maintaining Your Web Site 37 

 

 To change the preferences: 

1. On your Home page, open the Web Site group title menu, and click 
FrontPage Management. 

2. Click Preferences. 

3. Under Mail Settings specify the SMTP server and the e-mail address you 
want to use, and then click OK.   

 

Publishing a Site From Adobe Dreamweaver 

Before publishing a site from Dreamweaver, you need to define the site properties, that 
is, you need to tell Dreamweaver where your site files are located on your computer, 
and to specify the server to which you want to publish the site. 

 To define a site in Dreamweaver: 

1. From the Site menu, choose New Site. The Site Definition screen opens. 

2. Click the Advanced tab. 

3. In the Local Info category, specify the following: 

 Site name. This will show in Web browser‘s title bar. 

 Local root folder. This is the folder on your computer where all of your site files 

are stored. For example c:\My Site 

 Default images folder. Specify the folder where your site‘s graphic files are stored. 

For example c:\My Site\images 

 HTTP address. Specify your domain name. For example, http://your-
domain.com 

4. From the Category menu, select the Remote Info item. 

5. From the Access menu, select the FTP option. Most likely, your server 
supports publishing through FTP (File Transfer Protocol, commonly 
used for transferring files over the Internet). 

6. Specify the following settings: 

 FTP host. Type your FTP host name without the ftp:// prefix. For example, 

your-domain.com. 

 Host directory. Specify the directory on the server where your site will reside. In 

most cases, this is httpdocs. 

 Login and password. Specify the login name and password that your provider 
gave you. 

 Use passive FTP. Select this option only if your computer is behind a firewall. 
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7. To ensure that you specified the correct login and password, and that 
Dreamweaver can connect to the server, click the Test button. 

8. To save the settings, click OK. 

 To publish your site: 

1. Open your site in Dreamweaver. 

2. From the Site menu, select the Put option (or press Ctrl+Shift+U 
simultaneously). 

 
 

Previewing Your Site 

Once you published your site to your web space, you may want to make sure that it 
functions properly in the actual hosting environment. You can preview your site through 
your favorite Web browser, even if the information on your domain name has not yet 
propagated in the Domain Name System. Note that Adobe Flash and CGI scripts will 
not work during preview. Also, site preview does not work for Web sites and Web 
pages that include absolute paths to other files (like <a 
href="http://domain.tld/image.gif">). 

To preview your site, on your Home page, click Site Preview. 
 

Configuring ASP.NET (Windows Hosting) 

ASP.NET is a flexible set of tools and web development technologies that allows you to 
employ a number of  applications based on ASP.NET framework. Parallels Plesk Panel 
supports both 1.1.x and 2.0.x versions of the .NET framework and allows configuring 
most of its settings. 

In this section: 

Configuring ASP.NET for Your Domain ............................................................. 39 
Configuring ASP.NET for Virtual Directories ...................................................... 41 
Restoring Default ASP.NET Configuration ........................................................ 43 
Changing .NET Framework Version for Your Domain ....................................... 43 
Changing .NET Framework Version for Virtual Directories ................................ 44 
 
 



 

 Setting Up And Maintaining Your Web Site 39 

 

Configuring ASP.NET for Your Domain 

Most ASP.NET configuration settings that commonly need to be customized in order 
for ASP.NET applications to function in a desirable way can be edited through Parallels 
Plesk Panel. 

 To configure ASP.NET for a domain: 

1. Go to Home > ASP.NET Settings. 

2. Set up the strings that determine database connection data for 
ASP.NET applications which use databases. This option is available 
only for ASP.NET 2.0.x. 

When you open the ASP.NET configuration page for the first time, sample 
connection parameters with common constructions are displayed. You can then 
delete them and specify your own strings. 

 To add a string, enter the required data into the Name and Connection Parameters 

input fields and click  next to them. 

 To remove a string, click  next to it. 

3. Set up custom error messages that will be returned by ASP.NET 
applications in the Custom Error Settings field: 

 To set the custom error messages mode, select an appropriate option from the 
Custom error mode menu: 

 On - custom error messages are enabled. 

 Off - custom error messages are disabled and detailed errors are to be 
shown. 

 RemoteOnly - custom error messages are displayed only to remote clients, 
and ASP.NET errors are shown to the local host. 

 To add a new custom error message (which will be applied unless the Off mode 
was selected), enter the values in the Status Code and Redirect URL fields, and 

click . 

 Status Code defines the HTTP status code resulting in redirection to the error 
page. 

 Redirect URL defines the web address of the error page presenting 
information about the error to the client. 

Due to possible conflicts, you cannot add a new custom error message with an 
error code that already exists, but you can redefine the URL for the existing 
code. 

 To remove a custom error message from the list, click  next to it. 

4. Configure compilation settings in the Compilation and Debugging field: 

 To determine the programming language to be used as default in dynamic 
compilation files, choose an entry from Page default language list. 
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 To enable compiling retail binaries, leave the Switch on debugging check box 
empty. 

 To enable compiling debug binaries, select the Switch on debugging check box. In 
this case, the source code fragments containing error will be shown in a 
diagnostic page message. 

Note. When running applications in debug mode, a memory and/or performance 
overhead occurs. It is recommended to use debugging when testing an application 
and to disable it before deploying the application into production scenario. 

5. Configure encoding settings for ASP.NET applications in the Globalization 
Settings section: 

 To set an adopted encoding of all incoming requests, enter an encoding value 
into the Request encoding field (default is utf-8). 

 To set an adopted encoding of all responses, enter an encoding value into the 
Response encoding field (default is utf-8). 

 To set an encoding which must be used by default for parsing of .aspx, .asmx, 

and .asax files, enter an encoding value into the File encoding field (default is 

Windows-1252). 

 To set a culture which must be used by default for processing incoming web 
requests, select an appropriate item from the Culture list. 

 To set a culture which must be used by default when processing searches for a 
locale-dependent resource, select an appropriate item from the UI Culture list. 

6. Set a code access security trust level for ASP.NET applications in the 
Code Access Security field. 

CAS trust level is a security zone to which applications execution is assigned, 
defining what server resources the applications will have access to. 

Important. When an assembly is assigned a trust level that is too low, it does not 
function correctly. For more information on the permissions levels see 
http://msdn.microsoft.com/library/en-
us/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010. 

7. Enable the usage of the auxiliary scripts in the Script Library Settings field. 
Specifying the script library settings is necessary if the validation web 
controls are used on your web site. This option is available only for 
ASP.NET 1.1.x. 

 If you need to use auxiliary scripts (specifically, scripts implementing objects for 
validating input data), provide the settings for .NET framework script library. To 
do so, enter the path beginning with the domain root directory preceded by the 
forward slash into the Path to Microsoft script library field, or click the folder icon 
next to the Path to Microsoft script library field and browse for the required location. 

 To initiate the auto-installation of files containing the scripts to the specified 
location, select the Install check box. If the files already exist there, they will be 
rewritten. 

8. Set client session parameters in the Session Settings field: 

http://msdn.microsoft.com/library/en-us/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010
http://msdn.microsoft.com/library/en-us/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010
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 To set up the default authentication mode for applications, select an appropriate 
item from the Authentication mode list. Windows authentication mode should be 
selected if any form of IIS authentication is used. 

 To set up time that a session can idle before it is abandoned, enter appropriate 
number minutes into the Session timeout field. 

9. Click OK to apply all changes. 

Note: Parallels Plesk Panel supports separate configurations for different versions of 
the .NET framework (1.1.x and 2.0.x). 

Configuring ASP.NET for Virtual Directories 

To improve the performance of ASP.NET-based web applications, Parallels Plesk 
Panel allows using individual settings of .NET framework per virtual directory. 

 To configure ASP.NET for a virtual directory: 

1. Go to Home > Virtual Directories. 

2. Browse to the required directory and enter it.  

3. Click ASP.NET Settings. 

4. Set up the strings that determine database connection data for 
ASP.NET applications which use databases. This option is available 
only for ASP.NET 2.0.x. 

When you open the ASP.NET configuration page for the first time, sample 
connection parameters with common constructions are displayed. You can then 
delete them and specify your own strings. 

 To add a string, enter the required data into the Name and Connection Parameters 

input fields and click  next to them. 

 To remove a string, click  next to it. 

5. Set up custom error messages that will be returned by ASP.NET 
applications in the Custom Error Settings field: 

 To set the custom error messages mode, select an appropriate option from the 
Custom error mode menu: 

 On - custom error messages are enabled. 

 Off - custom error messages are disabled and detailed errors are to be 
shown. 

 RemoteOnly - custom error messages are displayed only to remote clients, 
and ASP.NET errors are shown to the local host. 

 To add a new custom error message (which will be applied unless the Off mode 
was selected), enter the values in the Status Code and Redirect URL fields, and 

click . 
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 Status Code defines the HTTP status code resulting in redirection to the error 
page. 

 Redirect URL defines the web address of the error page presenting 
information about the error to the client. 

Due to possible conflicts, you cannot add a new custom error message with an 
error code that already exists, but you can redefine the URL for the existing 
code. 

 To remove a custom error message from the list, click  next to it. 

6. Configure compilation settings in the Compilation and Debugging field: 

 To determine the programming language to be used as default in dynamic 
compilation files, choose an entry from Page default language list. 

 To enable compiling retail binaries, leave the Switch on debugging check box 
empty. 

 To enable compiling debug binaries, select the Switch on  debugging check box. 
In this case, the source code fragments containing error will be shown in a 
diagnostic page message. 

Note. When running applications in debug mode, a memory and/or performance 
overhead occurs. It is recommended to use debugging when testing an application 
and to disable it before deploying the application into production scenario. 

7. Configure encoding settings for ASP.NET applications in the Globalization 
Settings section: 

 To set an adopted encoding of all incoming requests, enter an encoding value 
into the Request encoding field (default is utf-8). 

 To set an adopted encoding of all responses, enter an encoding value into the 
Response encoding field (default is utf-8). 

 To set an encoding which must be used by default for parsing of .aspx, .asmx, 

and .asax files, enter an encoding value into the File encoding field (default is 

Windows-1252). 

 To set a culture which must be used by default for processing incoming web 
requests, select an appropriate item from the Culture list. 

 To set a culture which must be used by default when processing searches for a 
locale-dependent resource, select an appropriate item from the UI Culture list. 

8. Set a code access security trust level for ASP.NET applications in the 
Code Access Security field. 

CAS trust level is a security zone to which applications execution is assigned, 
defining what server resources the applications will have access to. 

Important. When an assembly is assigned a trust level that is too low, it does not 
function correctly. For more information on the permissions levels see 
http://msdn.microsoft.com/library/en-
us/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010. 

http://msdn.microsoft.com/library/en-us/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010
http://msdn.microsoft.com/library/en-us/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010
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9. Enable the usage of the auxiliary scripts in the Script Library Settings field. 
Specifying the script library settings is necessary if the validation web 
controls are used on your web site. This option is available only for 
ASP.NET 1.1.x. 

 If you need to use auxiliary scripts (specifically, scripts implementing objects for 
validating input data), provide the settings for .NET framework script library. To 
do so, enter the path beginning with the domain root directory preceded by the 
forward slash into the Path to Microsoft script library field, or click the folder icon 
next to the Path to Microsoft script library field and browse for the required location. 

 To initiate the auto-installation of files containing the scripts to the specified 
location, select the Install check box. If the files already exist there, they will be 
rewritten. 

10. Set client session parameters in the Session Settings field: 

 To set up the default authentication mode for applications, select an appropriate 
item from the Authentication mode list. Windows authentication mode should be 
selected if any form of IIS authentication is used. 

 To set up time that a session can idle before it is abandoned, enter appropriate 
number minutes into the Session timeout field. 

11. Click OK to apply all changes. 

Note: Parallels Plesk Panel supports separate configurations for different versions of 

the .NET framework (1.1.x and 2.0.x). 

Restoring Default ASP.NET Configuration 

 To restore the default ASP.NET configuration: 

1. Go to Home > ASP.NET Settings. 

2. Click Set to Default. 

3. Confirm the restoring and click OK. 

 

Changing .NET Framework Version for Your Domain 

 To change the version of .NET framework used by your domain: 

1. Go to Home > ASP.NET Settings. 

2. Click Change Version in the Tools group. If this button is absent, only one 
version of .NET framework is available. You can see the version 
number in the Framework Version field. 

3. Select the required version number and click OK. 
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4. Click OK to save changes. 

 
 

Changing .NET Framework Version for Virtual 
Directories 

In order to provide running ASP.NET applications which use different .NET framework 
versions within a domain, Parallels Plesk Panel allows setting up the framework 
version per virtual (web) directory, where the applications are deployed.  

 To choose the version of .NET framework for a virtual (web) directory: 

1. Go to Home > Virtual Directories. 

2. Enter the required web directory and click ASP.NET Settings in the Tools 
group. 

3. Select the required .NET framework version and adjust other settings 
as necessary. 

4. Click OK. 

 
 

Setting PHP Version for a Domain 
(Windows Hosting) 

 To set PHP version for a domain:  

1. Go to Home > PHP Settings. 

2. Choose the required version of PHP and click OK. 
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Deploying Databases 

If your web server incorporates data processing applications or is designed to generate 
web pages dynamically, you will likely need a database for storing and retrieving data. 
You can either create a new database for your site or import the data from your 
previously backed up MySQL, PostgreSQL, or Microsoft SQL database. 

In this section: 

Creating or Importing a Database ...................................................................... 46 
Creating a Database User Account ................................................................... 47 
Changing Password of a Database User ........................................................... 47 
Removing a Database User Account ................................................................. 47 
Removing a Database ....................................................................................... 48 
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Creating or Importing a Database 

 To create a new database on your hosting account: 

1. On your Home page, click Databases. 

2. Click Add New Database. 

3. Enter a name for the database.  

We recommend that you choose a name that starts with a Latin alphabet symbol 
and comprises only alphanumeric and underscore symbols (up to 64 symbols).  

4. Select the database type that you are going to use: MySQL, 
PostgreSQL or Microsoft SQL Server. 

5. Select the database server of the selected type from the list. Click OK. 

6. To set up database administrator‘s credentials, click Add New Database 
User. 

7. Type a user name and a password that will be used for accessing the 
contents of the database. 

8. Click OK.   

 To import an existing database: 

1. On your Home page, click Databases. 

2. Click Add New Database. 

3. Enter a name for the database.  

We recommend that you choose a name that starts with a Latin alphabet symbol 
and comprises only alphanumeric and underscore symbols (up to 64 symbols).  

4. Select the database type that you are going to use: MySQL, 
PostgreSQL or Microsoft SQL Server. Click OK. 

5. To set up database administrator‘s credentials, click Add New Database 
User. 

6. Type a user name and a password that will be used for accessing the 
contents of the database. Click OK. 

7. Click the DB WebAdmin icon in the Tools group.  

An interface to phpMyAdmin, phpPgAdmin, or ASPEnterpriseManager database 
management tool will open in a separate browser window. 

If you have a MySQL database: 

a. Click Query window in the left frame, click the Import files tab,  

b. Select the text file that contains the data and click Go. 
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c. Click the Insert data from a text file link. 

If you have a MS SQL database: 

a. Click the name of your database in the left frame 

b. Click Query (the magnifying glass button) 

c. Copy the text of your script into the text area and click Run Query. 

To manage your databases and their contents, use your favorite MySQL, PostgreSQL, 
or Microsoft SQL Server client or the Web based database management tool 
accessible from Parallels Plesk Panel (Home > Databases > database name > DB 
WebAdmin). 

Creating a Database User Account 

If you collaborate with other people on managing a Web site and wish to give them 
access to the database, you should create separate user accounts for them. 

 To create a database user account: 

1. Go to Home > Databases > database name, and click Add New Database User. 

2. Type a user name and a password that will be used for accessing the 
contents of the database. Click OK. 

 

Changing Password of a Database User 

 To change password for a database user: 

1. Go to Home > Databases > database name > database user’s name. 

2. Type a new password and click OK. 

 

Removing a Database User Account 

 To remove a database user account:  

1. Go to Home > Databases > database name.  

2. Select a check box corresponding to the user account that you want to 
remove. 

3. Click Remove. Next, confirm removing and click OK.  
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Removing a Database 

 To remove a database with its contents: 

1. On your Home page, click Databases. 

2. Select a check box corresponding to the database that you wish to 
remove.  

If the required check box appears grayed out, this means that this database is used 
by a Web application and you can remove it only by uninstalling the respective 
application. 

3. Click Remove. Confirm removal and click OK. 

 

Accessing Data From External Databases 
(Windows Hosting) 

If you want to access data from an external database management system, you should 
create ODBC connections through Parallels Plesk Panel. 

In this section: 

Creating ODBC Connections to External Databases ......................................... 48 
Changing Settings Of Existing ODBC Connections ........................................... 49 
Removing Connections to External Databases .................................................. 49 
 

Creating ODBC Connections to External Databases 

To let your Web applications use external databases for storing the data, you need to 
create connections to these external databases. 

 To create an ODBC connection to an external database: 

1. On your Home page, click ODBC Data Sources. 

2. Click Add New ODBC DSN. 

3. Specify the ODBC connection name and description in the 
corresponding fields. 

4. Select the required driver in the Driver field. 

5. Click OK. 



 

 Setting Up And Maintaining Your Web Site 49 

 

6. Choose the appropriate options on the driver configuration screen. 
Typically, you should specify the path to the database, user credentials 
and other connection options, depending on the selected driver.  

7. Click Test to check whether the connection will function properly with 
provided settings. Click Finish to complete the creation. 

 

Changing Settings Of Existing ODBC Connections 

 To change settings of an existing ODBC connection: 

1. On your Home page, click ODBC Data Sources. 

2. Click the required connection name in the list. 

3. Change the settings as needed. 

4. Click Test to check whether the connection will function properly with 
new settings. Click Finish to save changes. 

 

Removing Connections to External Databases 

 To remove a redundant ODBC connection: 

1. On your Home page, click ODBC Data Sources. 

2. Select the check box corresponding to a connection you want to 
remove. 

3. Click Remove, confirm the removal and click OK. 

 

Configuring Data Source Names for 
Adobe ColdFusion (Windows Hosting) 

If you are using Adobe ColdFusion, you can configure data source names (DSNs) for 
ColdFusion through Parallels Plesk Panel. Data source names allow your ColdFusion 
Web applications to use local and remote databases for processing and storing 
application data. 
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In this section: 

Creating a New Data Source Name .................................................................. 50 
Changing Settings of a Data Source Name ....................................................... 50 
Removing a Data Source Name ........................................................................ 51 
 
 

Creating a New Data Source Name 

 To create a new Data Source Name for Adobe ColdFusion on your 
domain: 

1. On your Home page, go to ColdFusion DSN and click Add New ColdFusion 
DSN. 

2. Specify the data source name and select the required driver for this 
data source in the Driver menu. Click Next >>. 

3. Choose the appropriate options on the driver configuration screen. 
Typically, you should specify the path to the database, user credentials 
and other connection options, depending on the selected driver. Refer 
to Adobe ColdFusion documentation for more information on the driver 
configuration options. 

4. Click OK to finish. 

 
 

Changing Settings of a Data Source Name 

 To change the settings Data Source Name for Adobe ColdFusion on your 
domain: 

1. On your Home page, go to ColdFusion DSN and click the required data 
source name in the list. 

2. Specify the data source name and select the required driver for this 
data source in the Driver menu. Click Next >>. 

3. Choose the appropriate options on the driver configuration screen. 
Typically, you should specify the path to the database, user credentials 
and other connection options, depending on the selected driver. Refer 
to Adobe ColdFusion documentation for more information on the driver 
configuration options. 

4. Click OK. 
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Removing a Data Source Name 

 To remove a redundant ColdFusion DSN connection: 

1. On your Home page, click ColdFusion DSN. 

2. Select the check box corresponding to a DSN connection you want to 
remove. 

3. Click Remove, confirm the removal and click OK. 

 

Installing Applications 

To enhance your Web site with valuable features, such as guest books, forums, hit 
counters, photo galleries, and e-commerce solutions, you can install the respective 
applications from control panel's application vault (Home > Web Applications). The 
number and variety of available applications depend on your provider‘s policy and your 
hosting plan. 

 To install an application on your site: 

1. On your Home page, click Web Applications.  

A list of applications installed on your site will be displayed.  

2. Click Add New Application. 

3. In the left menu, select a category to which the application you need 
belongs. 

4. Select the required application in the list, and then click Install. 

5. Some applications will display a license agreement. Read the license 
agreement carefully, and if you agree with it, select the I agree check box 
and click Next >>. 

6. Specify whether you wish to create a hyperlink to the application and 
place it in the control panel. 

7. Specify the installation preferences and other information that may be 
required by the application (the requirements may vary among 
applications). Click Install. 

8. If you have chosen to create a hyperlink button inside your Parallels 
Plesk Panel, specify its properties: 

 Type the text that will show on your button in the Button label box. 
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 Choose the location for your button. To place it in the right frame of your Home 
page, select the Domain Administration page value as the location. To place it in 
the left frame (navigation pane) of your control panel, select the Navigation pane 
value.    

 Specify the priority of the button. Parallels Plesk Panel will arrange your custom 
buttons on the control panel in accordance with the priority you define: the lower 
the number – the higher is priority. Buttons are placed in the left-to-right order. 

 To use an image for a button background, type the path to its location or click 
Browse to browse for the desired file. It is recommended that you use a 16x16 
pixels GIF or JPEG image for a button to be placed in the navigation pane, and 
32x32 pixels GIF or JPEG image for buttons placed in the main frame. 

 Type the hyperlink to be attached to the button into the URL box. 

 Using the check boxes, specify whether to include the data, such as domain id 
and domain name to be transferred within the URL. These data can be used for 
processing by external web applications. 

 In the Context help tip contents input field, type in the help tip that will be displayed 
when you hover the mouse pointer over the button. 

 Select the Open URL in the control panel check box if you wish the destination URL 
to be opened in the control panel's right frame, otherwise leave this check box 
unchecked to open the URL in a separate browser window. 

 If you wish to make this button visible to the e-mail users whom you granted 
access to control panel, select the Visible to all sub-logins check box. 

 Click OK to complete creation. 

Now the application is installed and you can insert a link to this application into the web 
pages of your site, for example, on your Home page. Otherwise, you and your users 
will have to access this application by typing its URL, which can be long enough to 
remember. 

 To access the Web interface of an application, do any of the following: 

 Type the URL in your browser. For example: http://your-domain.com/forum/. 

 Go to Home > Web Applications, and click an icon , corresponding to the 
application. 

 If you chose to add a hyperlink button to your Parallels Plesk Panel during 
installation of an application, then on your Home page, click the respective 
button in the Custom buttons group or navigation pane. 

 To reconfigure an application, change the application administrator‘s password, or 
to install a license key for a commercial application, go to Home > Web Applications, 

and click an icon , corresponding to the application. 

 To upgrade an application to a newer version (if it is available on the server), go to 
Home > Web Applications, and click a corresponding shortcut in the U column. 

 To remove an application, go to Home > Web Applications, and select a check box 
corresponding to the application that you no longer need. Then click Remove. The 
application and its databases will be removed from the server. 
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In this section: 

Installing Java Web Applications ....................................................................... 53 
Installing Ruby Web Applications (Linux Hosting) .............................................. 54 
 

Installing Java Web Applications 

You can install Java Web application packages in the Web archive format (WAR). 
These Java applications are not distributed with Parallels Plesk Panel, therefore you 
should obtain them separately. 

 To install a Java Web application: 

1. From your Home page, go to Home > Web Applications > Java Applications 
and click Switch On. 

This will start the Tomcat service, which provides an environment for Java code to 
run in cooperation with a web server. 

2. Click Install New Application. 

3. Specify the path to an application package you wish to install (this can 
be an application package in WAR format saved on your computer‘s 
hard drive), or click Browse to navigate to it, then click OK. 

Now the application is installed and the respective entry is added to the list of installed 
Java applications (Home > Web Applications > Java Applications). 

 To access the web interface of a Java Web application, do any of the 
following: 

 From your Home page, go to Home > Web Applications > Java Applications, and click a 
respective hyperlink in the Path column. 

 Type the URL in your browser. For example: http://your-
domain.com:9080/storefront/. 

 To stop, start or restart a Java Web application: 

1. From your Home page, go to Home > Web Applications > Java Applications 
tab. A list of installed applications will open. 

2. Locate an application on the list, and use the icons in the right part of 
the list to perform the required operations: 

 To start an application, click the icon . 

 To stop an application, click the icon . 

 To restart an application, click the icon . 
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 To uninstall a Java Web application: 

1. From your Home page, go to Home > Web Applications > Java Applications. 

2. Select a check box corresponding to the application that you no longer 
need. Click Remove, confirm the removal and click OK.  

The application will be uninstalled and its databases removed from the server. 

Installing Ruby Web Applications (Linux Hosting) 

You can install on your site custom Web applications developed in the Ruby 
programming language. 

 To install on your site an application written in Ruby: 

1. Go to Domains > domain name > Web Hosting Settings. 

2. Select the CGI and FastCGI check boxes, and click OK. 

3. Connect to your FTP account, change to the /httpdocs directory, and 

create a subdirectory where the application files will reside. Let's call 

this directory  <your_application>, for illustration purposes. 

4. Upload the application files to the httpdocs/<your_application> 

directory. 

5. Locate the readme file in the application directory. Follow the 

instructions from this file to install the application. Note that installation 
of additional Ruby modules or operating system components may be 
required. In such a case, contact your hosting service provider or  
server administrator for assistance. 

6. Log in to the server shell over SSH and issue the command cd 
/<path_to_virtual_hosts>/<your_domain_name>/httpdocs; 

mv <your_application> <your_application>.real; ln -s 

<your_application>.real/public <your_application>   

where <path_to_virtual_hosts> is the path to the directory with virtual host 
configuration files, <your_domain_name> is the name of your domain, and 
<your_application> is the directory where your Ruby application is located.  

If you do not have access to server shell, ask your server administrator or hosting 
service provider to perform this step for you.  

7. Create a file with name .htaccess in the directory 

<your_domain_name>/httpdocs/<your_application>/public, open it with 
a text editor of your choice and add the following lines into the file: 

AddHandler fcgid-script .fcgi 

Options +FollowSymLinks +ExecCGI 

RewriteEngine On 

RewriteBase /<your_application> 
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RewriteRule ^$ index.html [QSA] 

RewriteRule ^([^.]+)$ $1.html [QSA] 

RewriteCond %{REQUEST_FILENAME} !-f 

RewriteRule ^(.*)$ dispatch.fcgi [QSA,L] 

ErrorDocument 500 "<h2>Application error</h2>Rails 

application failed to start properly" 

8. Save the file. 

9. Make sure that the proper path to the Ruby interpreter is specified in 

the file public/dispatch.fcgi: issue the commands head -n1 

dispatch.fcgi and which ruby. The both commands must return 

identical values.   

Now the Web application will be accessible at the following URL: http://your-
domain.com/your_application. 
 

Using IIS Application Pool (Windows 
Hosting) 

IIS Application Pool contains all your web applications. If your service provider has 
given you a dedicated IIS application pool, it allows you to have a level of isolation 
between your web applications and web applications used by other domain owners that 
host their web sites on the same server. Because each application pool runs 
independently, errors in one application pool will not affect the applications running in 
other application pools. 

By default, the application pool is enabled.  

To stop all applications running in the application pool, click IIS Application Pool on your 
Home page and click Stop. 

To start all applications in the application pool, click IIS Application Pool on your Home 
page and click Start. 

To restart all applications running in the application pool, click IIS Application Pool on 
your Home page and click Recycle. This can be handy if some applications are known 
to have memory leaks or become unstable after working for a long time. 

In this section: 

Setting Up IIS Application Pool .......................................................................... 56 
Disabling IIS Application Pool ............................................................................ 56 
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Setting Up IIS Application Pool 

 To enable IIS application pool for a domain: 

1. Click IIS Application Pool on your Home page. 

2. Click Switch On. 

3. To limit the amount of CPU resources that your application pool can 
use, select the Switch on CPU monitoring check box and provide a number 
(in percents) in the Maximum CPU use (%) field. 

4. Click OK. 

Once you enable the application pool, all your web applications will be using it. 
 

Disabling IIS Application Pool 

 To disable IIS application pool for a domain: 

1. Click IIS Application Pool on your Home page. 

2. Click Switch Off. 

3. Click OK. 
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Securing Online Transactions on Your 
Site With SSL Encryption 

If you are running an e-commerce business, you need to secure transactions between 
your customers and your site. To prevent the valuable data, such as credit card 
numbers and other personally identifiable information from stealing, you should use the 
Secure Sockets Layer protocol, which encrypts all data and transfers them securely 
over the SSL connection. And even if someone intercepts the data for malicious intent, 
they will not be able to decrypt and use them. 

To implement the Secure Sockets Layer protocol on your web server, you should 
purchase an SSL certificate from a reputable certificate vendor (these vendors are 
called Certificate Authorities), and then install this certificate on your site. To enable 
SSL protection, you must host your site on a dedicated IP address, which is not shared 
among other web sites. 

There are numerous certificate authorities to choose from. When considering one, pay 
attention to reputation and credibility of the CA. Knowing how long they have been in 
business and how many customers they have will help you make the right choice. 

Your Parallels Plesk Panel provides facilities for purchasing SSL certificates from 
Comodo, GeoTrust, Inc and GoDaddy. 

In this section: 

Obtaining and Installing SSL Certificates from Comodo, GeoTrust, Inc. or GoDaddy
 .......................................................................................................................... 58 
Obtaining and Installing SSL Certificates from Other Certification Authorities.... 59 
Creating and Installing Free Self-signed SSL Certificate ................................... 60 
Uninstalling a Certificate from Your Site ............................................................ 61 
Using SSL Certificate Shared By Another Domain (Windows Hosting Only) ..... 61 
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Obtaining and Installing SSL Certificates from Comodo, 
GeoTrust, Inc. or GoDaddy 

 To purchase an SSL certificate through MyPleskCom online store and 
secure your site: 

1. Go to Home > SSL Certificates and click Add SSL Certificate. 

2. Specify the certificate properties: 

 Certificate name. This will help you identify this certificate in the repository. 

 Encryption level. Choose the encryption level of your SSL certificate. We 
recommend that you choose a value more than 1024 bit. 

 Specify your location and organization name. The values you enter should not 
exceed the length of 64 symbols. 

 Specify the domain name for which you wish to purchase an SSL certificate. 
This should be a fully qualified domain name. Example: www.your-domain.com 

 Enter the domain administrator's e-mail address. 

3. Make sure that all the provided information is correct and accurate, as it 
will be used to generate your private key. Click Buy SSL Certificate.  

Your private key and certificate signing request will be generated — do not delete 
them. MyPlesk.com login page will open in a new browser window. 

4. Register or login to an existing MyPlesk.com account and you will be 
taken step by step through the certificate purchase procedure. 

5. Choose the type of certificate that you wish to purchase. 

6. Click Proceed to Buy and order the certificate.  

7. In the Approver E-Mail drop-down box, please select the correct 
Approver e-mail.  

The approver e-mail is an e-mail address that can confirm that certificate for 
specific domain name was requested by an authorized person. 

Once your certificate request is processed, you will be sent a confirmation e-mail. 
After you confirm, the SSL certificate will be sent to your e-mail. 

8. When you receive your SSL certificate, save it on your local machine or 
network. 

9. Return to the SSL Certificates repository (Home > SSL Certificates). 

10. Click Browse and navigate to the location of the saved certificate.  

11. Select the saved certificate, and then click Send File.  

This will upload and install the certificate against the corresponding private key. 

12. Return to your Home page and click Web Hosting Settings. 
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13. Select the SSL certificate that you wish to install from the Certificate 
drop-down box.  

If there is no Certificate drop-down box on the screen, this means that you are on a 
shared hosting account; therefore, you need to upgrade your hosting package and 
purchase a dedicated IP address from your hosting provider. 

14. Select the SSL support check box and click OK. 

 

Obtaining and Installing SSL Certificates from Other 
Certification Authorities 

 To secure your site with an SSL certificate from other certificate 
authorities: 

1. Go to Home > SSL Certificates and click Add SSL Certificate. 

2. Specify the certificate properties: 

 Certificate name. This will help you identify this certificate in the repository. 

 Encryption level. Choose the encryption level of your SSL certificate. We 
recommend that you choose a value more than 1024 bit. 

 Specify your location and organization name. The values you enter should not 
exceed the length of 64 symbols. 

 Specify the domain name for which you wish to purchase an SSL certificate. 
This should be a fully qualified domain name. Example: www.your-domain.com 

 Enter the domain administrator's e-mail address. 

3. Make sure that all the provided information is correct and accurate, as it 
will be used to generate your private key. Click Request. 

 Your private key and certificate signing request will be generated and stored in the 
repository. 

4. In the list of certificates, click the name of the certificate you need. A 
page showing the certificate properties opens. 

5. Locate the CSR section on the page, and copy the text that starts with the 
line -----BEGIN CERTIFICATE REQUEST----- and ends with the line -----END 
CERTIFICATE REQUEST----- to the clipboard. 

6. Visit the Web site of the certification authority from which you want to 
purchase an SSL certificate, and follow the links on their site to start a 
certificate ordering procedure. When you are prompted to specify CSR 
text, paste the data from the clipboard into the online form and click 
Continue. The certification authority will create an SSL certificate in 
accordance with the information you supplied. 
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7. When you receive your SSL certificate, save it on your local machine or 
network. 

8. Return to the SSL Certificates repository (Home > SSL Certificates). 

9. Click Browse in the middle of the page and navigate to the location of the 
saved certificate.  

10. Select it, and then click Send File.  

This will upload and install the certificate against the corresponding private key. 

11. Return to your Home page and click Web Hosting Settings. 

12. Select the SSL certificate that you wish to install from the Certificate 
drop-down box.  

If there is no Certificate drop-down box on the screen, this means that you are on a 
shared hosting account; therefore, you need to upgrade your hosting package and 
purchase a dedicated IP address from your hosting provider. 

13. Select the SSL support check box and click OK. 

 

Creating and Installing Free Self-signed SSL Certificate 

If you do not want to purchase SSL certificates, but still need to secure your site, you 
can create a self-signed certificate and install it on your web server. This will provide 
data encryption; however, your customers‘ browsers will show warning messages 
telling that your certificate is not issued by a recognized authority. Thus, using self-
signed certificates is not recommended as it will not instill confidence in customers, and 
is likely to adversely affect your online sales. 

 To secure your site with a self-signed SSL certificate: 

1. Go to Home > SSL Certificates and click Add New Certificate. 

2. Specify the certificate properties: 

 Certificate name. This will help you identify this certificate in the repository. 

 Encryption level. Choose the encryption level of your SSL certificate. We 
recommend that you choose a value more than 1024 bit. 

 Specify your location and organization name. The values you enter should not 
exceed the length of 64 symbols. 

 Specify the domain name for which you wish to generate an SSL certificate. 
This should be a fully qualified domain name. Example: www.your-domain.com. 

 Enter the domain administrator's e-mail address. 

3. Click Self-Signed.  

Your certificate will be generated and stored in the repository. 

4. Return to your Home page and click Web Hosting Settings. 
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5. Select the self-signed SSL certificate from the Certificate drop-down box.  

If there is no Certificate drop-down box on the screen, this means that you are on a 
shared hosting account; therefore, you need to upgrade your hosting package and 
purchase a dedicated IP address from your hosting provider. 

6. Select the SSL support check box and click OK. 

 

Uninstalling a Certificate from Your Site 

 To uninstall a certificate from your site and disable SSL protection: 

1. Make sure that the certificate you want to remove is not used at the 
moment.  

a. On your Home page, click Web Hosting Settings.  

b. The Certificate drop-down box indicates which SSL certificate is 
currently used.  

c. If the certificate that you want to remove is currently in use, you 
should first release it by selecting another certificate in the 
Certificate drop-down box, and clicking OK.  

2. Remove the certificate from repository.  

a. To permanently remove the certificate from repository, on your 
Home page, click SSL Certificates.  

b. Select a check box corresponding to the certificate that you no 
longer need and click Remove. Confirm removal and click OK. 

3. Disable SSL support if you no longer need it.  

a. On your Home page, click Web Hosting Settings.  

b. Clear the SSL support check box and click OK. 

 

Using SSL Certificate Shared By Another Domain 
(Windows Hosting Only) 

Shared SSL is a means of securing the access to your site with SSL (Secure Sockets 
Layer) without purchasing your own SSL certificate. Web sites that employ shared SSL 
are, in fact, using the certificate shared by another domain. The domain that shares its 
SSL certificate with others is called Master SSL Domain. 

Note. In order to use shared SSL, the Master SSL Domain should be set by your 
server administrator. 
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 To use SSL certificate of the Master SSL Domain, enabling shared SSL 
use: 

1. Click Shared SSL on your Home page. 

2. Select the Switch on shared SSL check box.  

3. Specify the virtual directory name in the corresponding input field. The 
virtual directory with the supplied name will be created on the Master 
SSL Domain. This directory will be used for accessing your site through 
SSL. 

For example, let us suppose that you have a domain named mydomain.com, 
Master SSL Domain is defined as master_ssl_domain.com, and the virtual directory 

name you supplied is my_virtual_dir. In this case, to access your site through 

SSL, you need to use the following address: 
https://master_ssl_domain.com/my_virtual_dir.  

Note. You cannot use your domain name (e.g., mydomain.com) to access your site 
via SSL if you are using shared SSL. 

4. Select the directory where protected content is located on your domain. 
The documents within specified directory will be accessible only 

through SSL. You can only choose either httpdocs or httpsdocs as 

a target directory. 

5. To make your domain accessible via SSL only, select the Require SSL 
check box. 

6. Click OK. 

 

 To stop using SSL certificate of the Master SSL Domain, disabling shared 
SSL use: 

1. Click Shared SSL on your Home page. 

2. Clear the Switch on shared SSL check box. 

3. Click OK. 
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Restricting Bandwidth Usage for Sites 

To avoid excessive usage of bandwidth, which can lead to resources overage, you can 
limit bandwidth usage for a site. 

 To limit the bandwidth for a site: 

1. Go to Home > Bandwidth Limiting. 

2. Select the Switch on bandwidth limiting check box. 

3. Specify the maximum speed (measured in KB per second) that a 
domain can share between all its connections in the Maximum bandwidth 
usage (KB/S) field. 

4. Click OK. 

 
 

Restricting the Amount of Simultaneous 
Connections to Sites 

To avoid Denial Of Service attacks and to prevent excessive usage of bandwidth, you 
can set a limit of maximum number of simultaneous Web connections your domain can 
have. 

 To limit the maximum number of simultaneous connections to a Web site: 

1. Go to Home >  Bandwidth Limiting. 

2. Select the Switch on connections limiting check box.  

3. Specify the maximum number of simultaneous connections in the 
Connections limited to field. 

4. Click OK. 
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Protecting Sites From Bandwidth Stealing 
(Windows Hosting) 

Hotlinking (also called file leeching, remote linking, direct linking, bandwidth stealing or 
bandwidth banditism) is a term used for describing a situation when a Web page of one 
domain owner is directly linking to images (or other multimedia files) on the Web pages 
of another domain owner, usually using an <IMG> tag. If your domains are hotlinked, 
you may face the problem of excessive bandwidth usage.  

 To protect a domain from hotlinking:  

1. Go to Home > Hotlink Protection. 

2. Click Switch On to enable the protection from hotlinking.  

3. Specify the extensions of files you wish to be protected from hotlinking 
(for example, jpg, bmp, and so on) in the Protected files extensions field. 
When listing several file extensions, separate them with spaces.  

4. Click OK. 

 
 

Restricting Access to Web Server's 
Resources With Password Protection 

If you have directories in your site that only authorized users should see, restrict 
access to these directories with password protection. 

In this section: 

Protecting a Resource ....................................................................................... 65 
Adding and Removing Authorized Users ........................................................... 66 
Unprotecting a Resource ................................................................................... 66 
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Protecting a Resource 

 To password protect a directory in your site and to specify authorized 
users: 

1. On your Home page, click Password Protected Directories. 

2. Click Add New Directory. 

3. Specify the path to the directory that you wish to password protect in 
the Directory name box.  

This can be any directory existing in your site, for example: /private. If the 

directory that you would like to protect has not yet been created, specify the path 
and the directory name – Parallels Plesk Panel will create it for you. 

4. Specify in what location (also called document root) your password 
protected directory resides or will reside (available only for Linux 
hosting).  

For example: 

 To protect the httpdocs/private directory, type '/private' in the Directory name 

box and select the Non-SSL check box. 

 To protect the httpsdocs/private directory, type '/private' in the Directory 

name box and select the SSL check box. 

 To protect your CGI scripts stored in the cgi-bin directory, leave the '/' value 

in the Directory name box and select the cgi-bin check box. Make sure there are 
no white spaces after the slash symbol; otherwise, a protected directory will be 
created with the name consisting of white spaces.  

5. In the Header Text box, type a resource description or a welcoming 
message that your users will see when they visit your protected area. 

6. Click OK.  

The directory you specified will be protected. 

7. To add authorized users, click Add New User. 

8. Specify the login name and password that will be used for accessing 
the protected area.  

The password should be from 5 to 14 symbols in length.  

9. Click OK. 

10. To add more authorized users for this protected resource, repeat the 
steps 7 and 8. 
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Adding and Removing Authorized Users 

 To add an authorized user of a protected directory: 

1. Go to Home > Password Protected Directories > directory name. 

2. Click Add New User.  

3. Specify the login name and password that will be used for accessing 
the protected area.  

The password should be from 5 to 14 symbols in length. 

4. Click OK. 

 To change password for an authorized user of a protected directory: 

1. Go to Home > Password Protected Directories > directory name.  

A list of authorized users will open. 

2. Click on the user‘s name. 

3. Specify the new password and re-type it for confirmation. 

4. Click OK. 

 To revoke a permission to access the protected directory from a user: 

1. Go to Home > Password Protected Directories > directory name.  

A list of authorized users will open. 

2. Select a check box corresponding to the user‘s name. 

3. Click Remove.  

4. Confirm the operation and click OK. 

 

Unprotecting a Resource 

 To remove password protection and make the resource available to the 
public: 

1. Go to Home > Password Protected Directories.  

A list of password protected directories will open. 

2. Select a check box corresponding to the name of the directory, from 
which you want to remove protection. 

3. Click Remove.  
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The protection will be removed and the contents of the directory will be accessible to 
the public without restrictions. 
 

Setting File and Directory Access 
Permissions (Linux Hosting) 

 To review or change the permissions set for files and directories: 

Go to Home > File Manager. 

The permissions are represented as three sets of symbols, for example, 'rwx rwx r--'. 
The first set tells what the owner of the file or directory can do with it; the second tells 
what the user group, the file or directory belongs to, can do with the file or directory; the 
third set indicates what other users (the rest of the world, i.e. Internet users visiting a 
site) can do with the file or directory. R means the permission to read the file or 
directory, W means the permission to write to the file or directory, and X means the 
permission to execute the file or look inside the directory. 

To modify permissions for a file or directory, in the Permissions column, click the 
respective hyperlink representing the set of permissions. Modify the permissions as 
desired and click OK. 

 

Setting File and Directory Access 
Permissions (Windows Hosting) 

Parallels Plesk Panel provides setting up file and folder access permissions, including 
defining special permissions and permissions inheritance, similarly to the way it is 
presented in Windows interface. 

Note. For security reasons, permissions for Administrators, SYSTEM and Parallels 

Plesk Panel Domain Administrator cannot be changed or removed. 

 

In this section: 

Setting and Changing Access Permissions for Groups and Users ..................... 68 
Removing Access Permissions from Groups and Users .................................... 68 
Setting Up Access Permissions Inheritance for Files and Folders ..................... 69 
Setting, Changing and Removing Special Access Permissions ......................... 69 
Setting Access Permissions for Virtual Directories ............................................ 70 
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Setting and Changing Access Permissions for Groups 
and Users 

 To set or change access permissions for a group or user: 

1. Go to Home > File Manager. 

2. Click  corresponding to the required file or folder. 

 To change or remove permissions from a group or user, click the required name 
in the Group or user names list. 

 To set permissions for a group or user, which is not in the Group or user names 
list, select the required user/group name from the drop-down box located above 

the list and click : the user/group appears in the list. Select it. 

3. To allow or deny permissions to a selected group/user, select the Allow 
or Deny check boxes corresponding to permissions listed under 
Permissions for [user/group name]. 

Note. If check boxes in Allow and/or Deny columns are shaded, it means that the 

corresponding permissions are inherited from a parent folder. 

 To deny the permission, which are inherited from a parent object as allowed, 
select the required check boxes under Deny. This will override inherited 
permissions for this file/folder. 

 To allow the permission, which are inherited from a parent object as denied, 
clear the Allow inheritable permissions from the parent to propagate to this object and all 
child objects. Include these with entries explicitly defined here check box: this removes 
the inherited permissions. Then select the required check boxes under Allow and 
Deny. 

4. Click OK. 

 

Removing Access Permissions from Groups and Users 

 To remove access permissions from a group or user: 

1. Go to Home > File Manager. 

2. Click  corresponding to the required file or folder. 

3. Select the required name in the Group or user names list and click  next 
to it. 

Note: The  icons appear unavailable for entries with permissions inherited from a 
parent object. 

4. Select the required entry. 
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5. Clear the Allow inheritable permissions from the parent to propagate to this object 
and all child objects. Include these with entries explicitly defined here check box. 

6. Select the entry again and click . 

7. Click OK. 

 

Setting Up Access Permissions Inheritance for Files 
and Folders 

 To set up access permissions inheritance for files and folders: 

1. Go to Home > File Manager. 

2. Click an icon  corresponding to the required file or folder. 

3. To make the file/folder inherit permissions from a parent folder (if it 
does not), select the Allow inheritable permissions from the parent to propagate 
to this object and all child objects. Include these with entries explicitly defined here 
check box. 

4. To make the files and folders, which are contained in this folder, inherit 
the folder permissions defined here, select the Replace permission entries 
on all child objects with entries shown here that apply to child objects check box. 

5. Click OK. 

 

Setting, Changing and Removing Special Access 
Permissions 

You can also set, change and remove special permissions including advanced 
management of folder permissions inheritance. In Advanced permissions management 
mode, several permission entries can be associated with a single group or user, each 
containing different set of permissions. Also, the list of permissions in Advanced mode is 
more detailed and gives more opportunities for fine-tuning file/folder permissions. It 
contains permissions that cannot be seen in Microsoft Windows interface, but present 
combinations of native Microsoft Windows permissions. They are Read Control, Write 
Control, and Execute Control. 

 To set, change or remove file/folder special permissions: 

1. Go to Home > File Manager. 

2. Click an icon  corresponding to the required file or folder. 

3. Click Advanced. 
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 To create a permission entry for a group or user, select the required name from 

the Group or user names list and click . 

 To set or change file/folder permissions for a group or user, select the required 
name from the Group or user names list, select the required Allow and Deny check 
boxes corresponding to permissions listed under Permissions for [group/user 
name]. 

 To remove a permission entry for a group or user, select the required name from 

the Group or user names list and click . 

 To make child objects of a folder inherit its permissions defined under 
Permissions for [group/user name], select the Replace permission entries on all child 
objects with entries shown here that apply to child objects check box, and select check 
boxes in the Apply onto: list which correspond to objects you want to inherit the 
permissions. 

4. Click OK. 

 
 

Setting Access Permissions for Virtual Directories 

Access permissions can also be applied to virtual (Web) directories. 

 To set access permissions for a virtual directory:  

1. Go to Home > Virtual Directories. 

2. Navigate the web site structure and click the required directory.  

3. Click Permissions in the Tools group and set access permissions for this 
virtual directory, as described in the sections above. 
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Organizing Your Site Structure With 
Subdomains 

Subdomains are additional domain names that enable you to: 

 Organize logically the structure of your web site 

 Host additional web sites or parts of your web site on the same server without the 
need to pay for registration of additional domain names 

An example of using subdomains: 

You have a web site your-product.com dedicated to promoting your software product. 
For publishing user‘s guides, tutorials and list of frequently asked questions, you can 
organize the subdomain 'userdocs' so that your users will be able to access online user 
documentation directly by visiting the domain name userdocs.your-product.com. 

In this section: 

Setting Up Subdomains (Linux Hosting) ............................................................ 72 
Setting Up Subdomains (Windows Hosting) ...................................................... 73 
Removing Subdomains ..................................................................................... 75 
 
 



 

72 Setting Up And Maintaining Your Web Site 

 

Setting Up Subdomains (Linux Hosting) 

 To set up a subdomain: 

1. On your Home page, click Subdomains. 

2. Click Add New Subdomain. 

3. Type the subdomain name as desired.  

This can be, for example, a topic of your site, organization department, or any other 
combination of letters, numbers and hyphens (up to 63 characters in length). The 
subdomain name must begin with an alphabet character. Subdomain names are 
case insensitive.   

4. If this subdomain will require secure transactions, select the SSL support 
check box.  

Then, the SSL certificate installed under the parent domain will be used for 
encrypting transactions. By default, when you publish the site, you need to upload 
the web content that should be accessible via secure connections to the 

httpsdocs directory, and the content that should be accessible via plain HTTP, to 

the httpdocs directory. For your convenience, you can choose to publish all 

content through a single location – httpdocs directory. To do this, select the 

option Use a single directory for housing SSL and non-SSL content. 

5. If this subdomain will hold a part of your own Web site that you manage 
on your own, leave the Use the FTP user account of the parent domain option 
selected. If this subdomain will hold a separate web site that will belong 
to or will be managed by another person, select the Create a separate user 
account for this subdomain option, and specify the login name and 
password that will be used for accessing the web space through FTP 
and publishing web site content. 

6. If you wish to limit the amount of disk space that can be occupied by 
web content under this subdomain, type the desired value in megabytes 
into the Hard disk quota box.  

When the specified limit is exceeded, you will not be able to add files to the web 
space, and editing existing files may corrupt them. 

7. Specify the programming languages in which your web site is 
developed.  

Otherwise, your web site may not function properly. For example, if your web site is 
written mainly in ASP and uses some applications written in PHP, such as those 
from the Application Vault, select the ASP support and PHP support check boxes. 

8. To complete the setup, click OK.  

It may take up to 48 hours for the information on new subdomain to spread in the 
Domain Name System and become available to the Internet users.  

To publish web content to the subdomain‘s web space, follow the instruction presented 
in the Creating and Publishing Your Site (see page 28) section. 
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Setting Up Subdomains (Windows Hosting) 

 To set up a subdomain: 

1. Click Subdomains on your Home page. 

2. Click Add New Subdomain. 

3. Select the required Hosting type and click OK: 

 Select Physical hosting to create a virtual host for the domain. 

 Select Subdomain on subfolder to create a virtual subdomain.  Subdomain on 
subfolder will use physical structure of the domain. The creation of a separate 
FTP user account will not be possible: the FTP user account of the domain will 
be used.     

4. Type the subdomain name as required. This can be, for example, a 
topic of a site, organization department, or any other combination of 
letters, numbers and hyphens (up to 63 characters in length). To add 
the WWW prefix, select the appropriate check box. 

The subdomain name must begin with an alphabet character. Subdomain names 
are case insensitive. 

5. If you are creating subdomain on subfolder, specify the physical 
location for the subdomain files in the Site home directory field: 

 Clear the Create physical directory for subdomain check box and specify the existing 

directory to the right of httpdocs field. You can click  to browse for the required 
directory, select it and click OK. 

 Leave the Create physical directory for subdomain check box selected to create a 
corresponding physical directory with the same name as the subdomain. 

6. If you are creating subdomain with physical hosting, specify the FTP 
user account for it: 

 If this subdomain will hold a part of your own Web site that you manage on your 
own, leave the Use the FTP user account of the main domain option selected.  

 If this subdomain will hold a separate web site that will belong to or will be 
managed by another person, select the Create a separate user account for this 
subdomain option, and specify the login name and password that will be used for 
accessing the web space through FTP and publishing web site content. Specify 
the hard disc quota in the appropriate field in megabytes or leave the Unlimited 
check box selected. When the specified limit is exceeded, you will not be able to 
add files to the web space, and editing existing files may corrupt them. 

7. If you wish to limit the amount of disk space that can be occupied by 
web content under this subdomain, type the desired value in megabytes 
into the Hard disk quota box.  

When the specified limit is exceeded, you will not be able to add files to the web 
space, and editing existing files may corrupt them. 
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8. Leave the Publish site with SiteBuilder check box selected to be able to 
access SiteBuilder and build web site through your Parallels Plesk 
Panel interface. When the Publish site with SiteBuilder option is selected, a 
site will be created in SiteBuilder. All publishing parameters will be set 
in the paths predefined: for subdomain with Physical hosting - 
/subdomains/SUBDOMAINNAME/httpdocs/sitebuilder; for subdomain 
with Subdomain on subfolder - /httpdocs/SUBDOMAINNAME/. 

9. If you want to enable Microsoft FrontPage support, select the appropriate 
check box. Enable or disable Remote Microsoft FrontPage authoring by 
selecting the appropriate option.    

10. Specify the programming languages support in the Services group by 
selecting the required languages. Use select all or clear all to select or 
clear all of the languages available. 

If the ASP.NET support is disabled on the domain for which you are creating 
subdomain, it is also unavailable on Subdomain on subfolder. In case the ASP.NET 
support is enabled on the domain, the ASP.NET is available for subdomain created 
on a subfolder.  

11. To allow you to view the information on the number of people visited the 
site and the pages of the site they viewed, select a module in Web 
statistics drop-down menu and select the accessible via password protected 
directory /plesk-stat/webstat check box, if required. This will install the 
selected statistical software module, which will generate reports and 
place them into the password protected directory. The subdomain 
administrator will then be able to access Web statistics at the URL: 
https://subdomain.domain.com/plesk-stat/webstat using their FTP 
account login and password. 

Note. If you change the FTP credentials, web statistics access credentials do not 
change. The original login and password specified upon the subdomain creation 
should always be used for accessing password-protected web statistics directory. 

12. Select the Additional write/modify permissions option if this subdomain's web 
applications will use a file-based database (like Jet) located in the root 

of httpdocs or httpsdocs folders. Please note that selecting this 

option might seriously compromise the web site security. 

13. To complete the setup, click OK. It may take up to 48 hours for the 
information on new subdomain to spread in the Domain Name System 
and become available to the Internet users. 

To publish web content to the subdomain‘s web space, follow the instruction presented 
in the Creating and Publishing Your Site (see page 28) section. 

To preview the web content published under the subdomain, on your Home page, click 

Subdomains, and then click the  icon corresponding to the subdomain name. 
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Removing Subdomains 

 To remove a subdomain with its web content: 

1. On your Home page, click Subdomains. 

2. Select a check box corresponding to the subdomain name that you wish 
to remove.   

3. Click Remove. Confirm removal and click OK. 

The subdomain configuration and its web content will be removed from the server. 
 

Setting Up Additional Domain Names for a 
Site (Domain Aliases) 

If you have registered with a domain name registrar several domain names that you 
would like to point to the same Web site that you host on this server, you should set up 
domain aliases, as described in this chapter. 

In this section: 

Setting Up a Domain Alias ................................................................................. 76 
Modifying Properties of a Domain Alias ............................................................. 76 
Removing a Domain Alias ................................................................................. 77 
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Setting Up a Domain Alias 

 To set up a domain alias: 

1. On your Home page, click Domain Aliases. 

2. Click Add Domain Alias. 

3. Type the desired domain alias name, for example alias.com.  

Domain aliases can comprise letters, digits and hyphens. Each part of the domain 
alias between dots should not be longer than 63 symbols. 

4. Select the Synchronize DNS zone with the primary domain check box if you 
want the domain alias to use the same DNS zone resource records as 
in primary domain. With this setting, any subsequent changes in 
resource records of the primary domain's zone will be applied to the 
DNS zone of this domain alias.    

5. Select the Mail check box, if you want e-mail directed at the e-mail 
addresses under the domain alias to be redirected to the e-mail 
addresses under your original domain name. 

Example: You have an e-mail address mail@yourdomain.com. You have set up an 
alias for your domain name, for example, alias.com. If you want to receive mail to 
your mailbox mail@yourdomain.com when it is sent to mail@alias.com, select the 
Mail check box. 

6. Select the Web check box. Otherwise, the Web server will not serve the 
Web content to users coming to your site by typing the domain alias in 
their browsers. 

7. If you use hosting services based on a Linux platform, and you have 
Java applications installed on your site that you want to make 
accessible through the domain alias, select the Java Web applications 
check box. 

8. Click OK. 

 

Modifying Properties of a Domain Alias 

 To change the properties of an alias:  

1. Go to Home > Domain Aliases > alias name. 

2. Change the properties and click OK. 
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 To modify resource records in the DNS zone of a domain alias: 

1. Go to Home > Domain Aliases > alias name > DNS Settings. 

2. Add, edit or remove the resource records as required: 

 To add a resource record to the zone, click Add New Record. Specify the required 
values and click OK to write the values to the zone. 

 To modify a resource record, under the Host column, click a hyperlink 
corresponding to the record you need. 

 To remove a record, select a check box corresponding to the record you wish to 
remove and click Remove. 

To learn more about DNS resource records modification and other DNS-related 
options, refer to the Customizing DNS Zone Configuration for Your Domain and the 
Serving Your Site with External Domain Name Servers sections. 
 

Removing a Domain Alias 

 To remove an alias from a domain:  

1. Go to Home > Domain Aliases. 

2. Select a check box corresponding to the domain alias that you want to 
remove. 

3. Click Remove. Confirm removal and click OK. 
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Using Virtual Directories (Windows 
Hosting) 

A virtual directory in Parallels Plesk Panel is a link to existing physical directory that is 
present on the server's hard disk. Virtual directories can have a number of specific 
settings like custom ASP.NET configuration, access permissions, URL password 
protection, and so on. 

Since any virtual directory can have its own settings, including customized ASP.NET 
configuration, virtual directories are very useful in setting up your web applications, 
especially those written in ASP.NET. For example, if you have three web applications 
that use ASP.NET version 1.1, and you need to install one web application that uses 
ASP.NET version 2.0, you can create a virtual directory for the ASP.NET 2.0 
application, configure ASP.NET settings for this directory, enabling version 2.0 only for 
this directory, and successfully install the required application. 

Virtual directories can also be used as aliases. For example, you have a web 
application installed on your domain 'example.com' in the physical folder 

'/my_data/web_apps/forum'. To access this web application, users need to type 

'example.com/my_data/web_apps/forum', which is hard to remember and too 

long to type. You can create virtual directory 'forum' in the root of your virtual host, and 

link this virtual directory to '/my_data/web_apps/forum', so users who want to 

access the web application have to type 'example.com/forum' , which is much 

shorter and easier to remember. 

 To open a virtual directory in your browser:  

1. Go to Home > Virtual Directories. 

2. Click the  icon corresponding to the directory you wish to open. 

 

In this section: 

Creating Virtual Directories ................................................................................ 79 
Changing Virtual Directory Settings ................................................................... 80 
Adding and Removing MIME Types .................................................................. 82 
Setting PHP Version for Virtual Directories ........................................................ 85 
Removing Virtual Directories ............................................................................. 85 
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Creating Virtual Directories 

 To create a new virtual directory on a domain: 

1. Go to Home > Virtual Directories. You are in your Web site root now. 

2. Navigate to the directory in which you want to create a new virtual 
directory. 

3. Click Create Virtual Directory. 

Note: To create a physical directory instead of virtual directory, click Create Directory, 
specify the name of the directory and click OK. 

4. Specify the required parameters: 

 Name - specify the virtual directory name. 

 Path - specify the virtual directory path: 

 Select the Create physical directory with the same name as virtual directory check 
box to automatically create a physical directory with the same name as the 
virtual directory you are creating. 

 Clear the Create physical directory with the same name as virtual directory check 
box and specify the path in the field to select the physical directory that 
already exists. 

 Script source access - select this check box to allow users to access source code 
if either Read or Write permissions are set. Source code includes scripts in ASP 
applications. 

 Read permission - select this check box to allow users to read files or directories 
and their associated properties. 

 Write permission - select this check box to allow users to upload files and their 
associated properties to the virtual directory or to change content in a write-
enabled file. Write access is allowed only if browser supports the PUT feature of 
the HTTP 1.1 protocol. 

 Directory browsing - select this check box to allow users to see a hypertext listing 
of the files and subdirectories in the virtual directory.  

 Log visits - select this check box if you want to store the information about visits 
of the virtual directory. 

 Create application - select this check box to make the Web directory an IIS 
Application. The directory becomes logically independent from the rest of the 
Web site. 

 Execute permissions - select the appropriate program execution level allowed for 
the virtual directory. 

 None - allow access only to static files such as HTML or image files. 

 Scripts only - allow running scripts only, not executables. 

 Scripts and Executables - remove all restrictions so that all file types can be 
executed. 
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 ASP Settings - set specific settings for ASP-based Web applications. 

 If you are using ASP-based applications that cannot operate correctly under 
data transfer restrictions currently set by IIS, clear the Defined by parent 
directory check box corresponding to the field you want to change and type in 
the required number. 

 If you want to enable debugging of ASP applications on the server side, 
clear the corresponding Defined by parent directory check box and select the 
Enable ASP server-side script debugging check box.  

 If you want to enable debugging of ASP applications on the client side, clear 
the corresponding Defined by parent directory check box and select the Enable 
ASP client-side script debugging check box.  

Note that if you are trying to change ASP Settings for the root Web directory, the 
default check box names will be Defined by IIS instead of Defined by parent 
directory. 

5. Click OK to complete the creation. 

 To set access permissions for a virtual directory: 

1. Go to Home > Web Directories. 

2. Click the  icon corresponding to the directory you wish to open, and 
set the access permissions for this directory and all its files.  

Refer to the Setting File and Directory Access Permissions (Windows Hosting) (see 
page 67) section for more information on setting access permissions. 

 To configure ASP.NET for a virtual directory:  

1. Go to Home > Web Directories. 

2. Browse to the required directory and enter it.  

3. Click ASP.NET Settings and set the options accordingly. 

Refer to the Configuring ASP.NET for Virtual Directories (see page 41) section for 
more information on configuring ASP.NET. 

Changing Virtual Directory Settings 

 To change preferences of an existing virtual directory on a domain: 

1. Go to Home > Virtual Directories. 

2. Find the directory which preferences you wish to change, and click , 
or click Directory Access Permissions in the required directory. 

3. Change the preferences of the virtual directory: 

 Name - specify virtual directory name. 

 Path - specify the path to the physical directory which virtual directory is linked 
to. 
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 Script source access - select this check box to allow users to access source code 
if either Read or Write permissions are set. Source code includes scripts in ASP 
applications. 

 Read permission - select this check box to allow users to read files or directories 
and their associated properties. 

 Write permission - select this check box to allow users to upload files and their 
associated properties to the virtual directory or to change content in a write-
enabled file. Write access is allowed only if browser supports the PUT feature of 
the HTTP 1.1 protocol. 

 Directory browsing - select this check box to allow users to see a hypertext listing 
of the files and subdirectories in the virtual directory.  

 Log visits - select this check box if you want to store the information about visits 
of the virtual directory. 

 Create application - select this check box to make the web directory an IIS 
Application. The directory becomes logically independent from the rest of the 
web-site. 

 Execute permissions - select the appropriate program execution level allowed for 
the virtual directory. 

None - allow access only to static files such as HTML or image files. 

Scripts only - allow running scripts only, not executables. 

Scripts and Executables - remove all restrictions so that all file types can be 
executed. 

 Allow to use parent paths - select this check box to allow using double period in the 
pathname when referring to a folder above the current web directory. This 
makes users able to move up the folder tree without knowing the folder name or 
the whereabouts in the hierarchy. If the option is selected, parent path 
directories should not have the Execute permission check box selected in their 
preferences, so that applications do not have the ability of unauthorized running 
of programs in the parent paths. 

 Allow application execution in MTA (multi-threaded apartment) mode - select this check 
box to allow the application execution in multi-threaded apartment (MTA) mode. 
Otherwise the application will run in a single-threaded apartment (STA) mode. 
Using STA, each application pool is executed in a dedicated process. With 
MTA, several concurrent application pools are executed in one thread which can 
increase performance in some cases. 

 Use default documents - select this check box to allow the use of default 
documents for the current web directory. The default document is sent when 
users access the directory on the Web without a specific file name (for example, 
using 'http://www.parallels.com' as opposed to 
'http://www.parallels.com/index.html'). If this check box is cleared and the 
Directory browsing check box is selected, the Web server returns a folder listing. If 
this check box is cleared and the Directory browsing check box is cleared as well, 
the Web server returns an "Access Forbidden" error message. 

 Default documents search order - specifies the order in which IIS searches for the 
default document, sending user the first available file it finds. If no match is 
found, IIS behaves as in the cases when the default content page is disabled. 
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 Allow anonymous access - select this check box if you want to make the directory 
public so that web users could access it without authentication. 

 Require SSL - select this check box to enable SSL-only access to the folder. 

 ASP Settings - set specific settings for ASP-based web applications. 

 If you are using ASP-based applications that cannot operate correctly under 
data transfer restrictions currently set by IIS, clear the Defined by parent 
directory check box corresponding to the field you want to change and type in 
the required number. 

 If you want to enable debugging of ASP applications on the server side, 
clear the corresponding Defined by parent directory check box and select the 
Enable ASP server-side script debugging check box.  

 If you want to enable debugging of ASP applications on the client side, clear 
the corresponding Defined by parent directory check box and select the Enable 
ASP client-side script debugging check box.  

Note that if you are trying to change ASP Settings for the root web directory, 
the default check box names will be Defined by IIS.instead of Defined by parent 
directory. 

4. Click OK to save changes. 

 To change access permissions for a virtual directory: 

1. Go to Domains > domain name > Virtual Directories. 

2. Click the  icon corresponding to the directory you wish to open, and 
change the access permissions for this directory and all its files.  

Refer to the Setting File and Directory Access Permissions (Windows Hosting) (see 
page 67) section for more information on setting access permissions. 

 To reconfigure ASP.NET for a virtual directory:  

1. Go to Domains > domain name > Virtual Directories. 

2. Browse to the required directory and enter it.  

3. Click ASP.NET Settings and change the options accordingly. 

Refer to the Configuring ASP.NET for Virtual Directories (see page 41) section for 
more information on configuring ASP.NET. 

Adding and Removing MIME Types 

Multipurpose Internet Mail Exchange (MIME) types instruct a Web browser or mail 
application how to handle files received from a server. For example, when a Web 
browser requests an item on a server, it also requests the MIME type of the object. 
Some MIME types, like graphics, can be displayed inside the browser. Others, such as 
word processing documents, require an external helper application to be displayed. 
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When a web server delivers a Web page to a client Web browser, it also sends the 
MIME type of the data it is sending. If there is an attached or embedded file in a 
specific format, IIS also tells the client application the MIME type of the embedded or 
attached file. The client application then knows how to process or display the data 
being received from IIS. 

IIS can only operate files of registered MIME types. These types could be defined both 
on the global IIS level and on the domain or virtual directory level. Globally defined 
MIME types are inherited by all the domains and virtual directories while ones defined 
on the domain or virtual directory level are used only for the area where they are 
defined. Otherwise, if the web server receives request for a file with unregistered MIME 
type, it returns the 404.3 (Not Found) error. 

In this section: 

Adding MIME Types .......................................................................................... 83 
Changing MIME Types ...................................................................................... 84 
Removing MIME Types ..................................................................................... 84 
 
 

Adding MIME Types 

 To add a new MIME type for a virtual directory on your domain: 

1. Go to Home > Virtual Directories. 

2. Navigate to the required virtual directory and enter it. 

3. Select the MIME Types tab. 

4. Click Add MIME Type. 

 Type the file name extension in the Extension field. File name extention should 
begin with a dot (.), or a wildcard (*) to serve all files regardless of file name 
extension. 

 Specify the file content type in the Content field.  

 You can either select the appropriate value from the list or define a new content 
type. To do this, select Custom... and enter the content type in the input box 
provided. 

5. Click OK to finish the creation. 
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Changing MIME Types 

 To edit an existing MIME type for a virtual directory on your domain: 

1. Go to Home > Virtual Directories. 

2. Navigate to the required virtual directory and enter it. 

3. Select the MIME Types tab. 

4. Select the required MIME type in the list. 

 Type the file name extension in the Extension field. File name extention should 
begin with a dot (.), or a wildcard (*) to serve all files regardless of file name 
extension. 

 Specify the file content type in the Content field.  

 You can either select the appropriate value from the list or define a new content 
type. To do this, select Custom... and enter the content type in the input box 
provided. 

5. Click OK to save changes. 

 
 

Removing MIME Types 

 To remove a MIME type for a virtual directory on your domain: 

1. Go to Home > Virtual Directories. 

2. Navigate to the required virtual directory and enter it. 

3. Select the MIME Types tab. 

4. Select the check box corresponding to the MIME type you want to 
remove.  

5. Click Remove. 

6. Confirm removal and click OK. 
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Setting PHP Version for Virtual Directories 

 To set PHP version for a virtual directory:  

1. Go to Home > Virtual Directories. 

2. Click PHP Settings. 

3. Choose the required version of PHP and click OK. 

 
 

Removing Virtual Directories 

 To remove an existing virtual directory: 

1. Go to Home > Virtual Directories. 

2. Select the check box corresponding to the directory you wish to 
remove. 

3. Click Remove. 

4. Confirm the removal and click OK. 
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Hosting Personal Web Pages on Your 
Web Server 

You can host on your Web server personal Web pages for individuals who do not need 
their own domain names. This service is popular with educational institutions that host 
non-commercial personal pages of their students and staff. 

These pages usually have Web addresses like http://your-domain.com/~username. 

 To accommodate a personal Web page on your server, allocate a separate 
Web space and set up an FTP account for publishing: 

1. On your Home page, click Web Users. 

2. Click Preferences. 

3. If you wish to allow execution of scripts embedded in personal web 
pages, select the Allow the web users scripting check box. 

4. Click OK.  

The settings you have defined at the step 3 are common for all personal Web 
pages you might host on your Web server. Therefore, you will not need to perform 
steps 2 to 4 next time you set up a Web space for a personal Web page. 

5. Click Add New Web User. 

6. Specify a user name and password that will be used for accessing the 
Web space through FTP and publishing the Web page.  

You can use only lowercase alphanumeric, hyphen and underscore symbols in user 
name. The user name should begin with an alphabet character. It cannot contain 
white spaces. The password cannot contain quotation marks, white space, user's 
login name, and should be between 5 and 14 characters in length.   

7. If you wish to limit the amount of disk space that can be occupied by the 
Web page content, clear the Unlimited check box and type the desired 
value in megabytes into the Hard disk quota box.  

When the specified limit is exceeded, the Web page owner will not be able to add 
files to his or her Web space. 

8. Specify the programming languages that should be supported for the 
Web page.  

For example, if the Web page is written in PHP, select the PHP support check box. 

9.  Click OK. 

Now you can tell your user the FTP account credentials, so that he or she can publish 
their Web page. 
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In this section: 

Changing FTP Password for a Web Page Owner .............................................. 87 
Allocating More Disk Space to the Web Page Owner ........................................ 87 
Removing Web Page Owner's Account ............................................................. 87 
 
 

Changing FTP Password for a Web Page Owner 

 To change FTP password for a web page owner: 

1. Go to Home > Web Users > user name. 

2. Type the new password into the New password and Confirm password 
boxes. 

3. Click OK. 

 
 

Allocating More Disk Space to the Web Page Owner 

 To allocate more disk space to the web page owner: 

1. Go to Home > Web Users > user name. 

2. Type the amount of disk space in megabytes into the Hard disk quota box. 

3. Click OK. 

 
 

Removing Web Page Owner's Account 

 To remove a web page owner’s account together with his or her web page: 

1. On your Home page, click Web Users. 

2. Select a check box to the right of the user name you wish to remove.  

3. Click Remove. Confirm removal and click OK. 
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Setting Up Anonymous FTP Access to the 
Server 

If you host your site on a dedicated IP address, you can set up a directory within the 
site, where other users will be able to anonymously download or upload files through 
FTP. Once anonymous FTP is enabled, the users will be able to log in to the 
ftp://ftp.your-domain.com with the "anonymous" login name and any password. 

 To allow anonymous FTP access: 

1. On your Home page, click Anonymous FTP. 

2. To activate anonymous FTP service, click Switch On. 

3. To set up a welcoming message to be displayed when users log in to 
FTP site, select the Display login message check box and type the 
message text in the input field as desired.  

Note that not all FTP clients display welcoming messages. 

4. To allow visitors to upload files to the /incoming directory, select the 
Allow uploading to incoming directory check box. 

5. To allow users to create subdirectories in the /incoming directory, select 
the Allow creation of directories in the incoming directory check box. 

6. To allow downloading files from the /incoming directory, select the Allow 
downloading from the incoming directory check box. 

7. To limit the amount of disk space that can be occupied by uploaded 
files, clear the Unlimited check box corresponding to the Limit disk space in 
the incoming directory option, and specify the amount in kilobytes.  

This is the hard quota: the users will not be able to add more files to the directory 
when the limit is reached. 

8. To limit the number of simultaneous connections to the anonymous FTP 
server, clear  the Unlimited check box corresponding to the  Limit number of 
simultaneous connections option and specify the number of allowed 
connections. 

9. To limit the bandwidth for anonymous FTP connections, clear the 
Unlimited check box corresponding to the Limit download bandwidth for this 
virtual FTP domain option and enter the maximum bandwidth in kilobytes 
per second. 

10. Click OK. 

 To modify settings for anonymous FTP server or switch it off: 

1. On your Home page, click Anonymous FTP. 
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2. Adjust the settings as required and click OK, or click the Switch Off icon in 
the Tools group to switch off the anonymous FTP service. 

 

Customizing Web Server Error Messages 
(Linux Hosting) 

When visitors coming to your site request pages that the web server cannot find, the 
web server generates and displays a standard HTML page with an error message. The 
standard error messages may inform of problems, but they do not usually say how to 
resolve them or how to get the lost visitor on his way, and they also look dull. 

You may want to create your own error pages and use them on your web server. With 
Parallels Plesk Panel you can customize the following error messages: 

 400 Bad File Request. Usually means the syntax used in the URL is incorrect (for 
example, uppercase letter should be lowercase letter; wrong punctuation marks). 

 401 Unauthorized. Server is looking for some encryption key from the client and is not 
getting it. Also, wrong password may have been entered. 

 403 Forbidden/Access denied. Similar to 401; a special permission is needed to access 
the site - a password and/or username if it is a registration issue. 

 404 Not Found. Server cannot find the requested file. File has either been moved or 
deleted, or the wrong URL or document name was entered. This is the most 
common error. 

 405 Method Not Allowed. The method specified in the Request-Line is not allowed for 
the resource identified by the Request-URI. 

 406 Not Acceptable. The resource identified by the request is only capable of 
generating response entities which have content characteristics not acceptable 
according to the accept headers sent in the request. 

 407 Proxy Authentication Required. This code is similar to 401 (Unauthorized), but 
indicates that the client must first authenticate itself with the proxy.  

 412 Precondition Failed. The precondition given in one or more of the request-header 
fields evaluated to false when it was tested on the server. This response code 
allows the client to place preconditions on the current resource metainformation 
(header field data) and thus prevent the requested method from being applied to a 
resource other than the one intended. 

 414 Request-URI Too Long. The server is refusing to service the request because the 
Request-URI is longer than the server is willing to interpret. This rare condition is 
only likely to occur when a client has improperly converted a POST request to a 
GET request with long query information, when the client has descended into a URI 
"black hole" of redirection (e.g., a redirected URI prefix that points to a suffix of 
itself), or when the server is under attack by a client attempting to exploit security 
holes present in some servers using fixed-length buffers for reading or manipulating 
the Request-URI. 
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 415 Unsupported Media Type. The server is refusing to service the request because 
the entity of the request is in a format not supported by the requested resource for 
the requested method. 

 500 Internal Server Error. Could not retrieve the HTML document because of server-
configuration problems. 

 501 Not Implemented. The server does not support the functionality required to fulfill 
the request. This is the appropriate response when the server does not recognize 
the request method and is not capable of supporting it for any resource. 

 502 Bad Gateway. The server, while acting as a gateway or proxy, received an invalid 
response from the upstream server it accessed in attempting to fulfill the request. 

 To configure Parallels Plesk Panel’s Web server to show your custom 
error pages: 

1. Switch on support for custom error documents through Parallels Plesk 
Panel. On your Home page, click Web Hosting Settings, select the Custom 
error documents check box and click OK. 

2. Connect to your FTP account on the Parallels Plesk Panel server, and 

go to the error_docs directory. 

3. Edit or replace the respective files. Be sure to preserve the correct file 
names: 

 400 Bad File Request - bad_request.html 

 401 Unauthorized - unauthorized.html 

 403 Forbidden/Access denied - forbidden.html 

 404 Not Found - not_found.html 

 405 Method Not Allowed - method_not_allowed.html 

 406 Not Acceptable - not_acceptable.html 

 407 Proxy Authentication Required - 
proxy_authentication_required.html 

 412 Precondition Failed - precondition_failed.html 

 414 Request-URI Too Long - request-uri_too_long.html 

 415 Unsupported Media Type - unsupported_media_type.html 

 500 Internal Server Error - internal_server_error.html 

 501 Not Implemented - not_implemented.html 

 502 Bad Gateway - bad_gateway.html 

4. Wait for a few hours till your Web server is restarted. After that, the 
Web server will start using your error documents. 
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Customizing Web Server Error Messages 
(Windows Hosting) 

When visitors coming to a site request pages that the Web server cannot find, the Web 
server generates and displays a standard HTML page with an error message. The 
standard error messages may inform of problems, but they do not usually say how to 
resolve them or how to get the lost visitor on his way, and they also look dull. 

You may want to create your own error pages and use them on your Web server. The 
following error messages are the ones customized most often: 

 400 Bad File Request. Usually means the syntax used in the URL is incorrect (e.g., 
uppercase letter should be lowercase letter; wrong punctuation marks). 

 401 Unauthorized. Server is looking for some encryption key from the client and is 
not getting it. Also, wrong password may have been entered. 

 403 Forbidden/Access denied. Similar to 401; a special permission is needed to 
access the site – a password and/or username if it is a registration issue. 

 404 Not Found. Server cannot find the requested file. File has either been moved or 
deleted, or the wrong URL or document name was entered. This is the most 
common error. 

 500 Internal Server Error. Could not retrieve the HTML document because of 
server-configuration problems. 

 To configure Parallels Plesk Panel’s Web server to show custom error 
pages for a domain: 

1. Switch on support for custom error documents through Parallels Plesk 
Panel.  

a. Go to Home > Web Hosting Settings.  

b. Select the Custom error documents check box.  

c. Click OK. 

2. Go to Home > Virtual Directories to see the list of error documents for the 
root Web directory (error documents located here are used for all 
domain Web pages). If you want to customize error pages for a certain 
Web directory, go to that directory. 

3. Click Error Documents tab and click the required error document in the list. 

 To use the default document provided by IIS for this error page, select Default in 
the Type menu. 

 To use a custom HTML document already located in the error_docs directory 

on a domain, select File in the Type menu and specify the file name in the 
Location field.  
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 To use a custom HTML document located in directory other than error_docs 

on a domain, select URL in the Type menu and enter the path to your document 
in the Location field. The path should be relative to the virtual host root (that is, 

<vhosts>\<domain>\httpdocs). 

For example, you have created a file forbidden_403_1.html and saved it in 

the my_errors directory located in the httpdocs. To use this file as an error 

document, the following path should be entered in the Location filed: 

/my_errors/forbidden_403_1.html. 

Note. You can use both FTP and File Manager to upload your custom error 
document to the server. By default, all error documents are stored in the 

/vhosts/your-domain.com/error_docs/ directory (located in C:\InetPub 

by default). 

4. Once the Web server is restarted, it will start using your error 
documents. 

 
 

Customizing DNS Zone Configuration for 
Your Domain 

Your control panel automatically creates DNS zone for your domain in accordance with 
the configuration preset defined by your provider. The domain name should work fine 
with the automatic configuration, however if you need to perform custom modifications 
in the domain name zone, you can do that through your control panel. 

To view the resource records in a DNS zone of your domain, go to Home > DNS Settings 
(in the Web Site group). A screen will show all resource records for your domain. 

Note: Here you can update the DNS zone with multiple changes in DNS records at 
once, and then confirm the changes by clicking the Apply button. Unconfirmed changes 
will not be saved. 

To learn about modifying resource records in the DNS zone of a domain alias, refer to 
the Setting Up Additional Domain Names for a Site (Domain Aliases) section. 

In this section: 

Adding Resource Records ................................................................................. 93 
Modifying Resource Records ............................................................................ 94 
Removing Resource Records ............................................................................ 95 
Restoring the Original Zone Configuration ......................................................... 95 
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Adding Resource Records 

 To add a new resource record to the zone: 

1. Go to Home > DNS Settings (in the Web Site group). 

2. Click Add New Record in the Tools group. 

3. Select a resource record type, and specify the appropriate data: 

 For an A record you will need to enter the domain name for which you wish to 
create an A record. If you are simply defining an A record for your domain, then 
you should leave the available field empty. If you are defining an A record for a 
name server then you will need to input the appropriate entry for the given name 
server (ie. ns1). Then, you need to enter the appropriate IP address to which to 
associate the domain name. 

 For a NS record, you will need to enter the domain name for which you wish to 
create the NS record. If you are defining an NS record for your domain, then you 
will leave the available field blank. Then enter the appropriate name server 
name in the field provided. You will need to enter the complete name (i.e. 
ns1.mynameserver.com). 

 For a MX record, you will need to enter the domain for which you are creating 
the MX record. For your domain, you would simply leave the available field 
blank. You will then need to enter your mail exchanger, this is the name of the 
mail server. If you are running a remote mail server named 
'mail.myhostname.com' then you would simply enter 'mail.myhostname.com' 
into the field provided. You will then need to set the priority for the mail 
exchanger. Select the priority using the drop-down box: 0 is the highest and 50 
is the lowest. Keep in mind you would also need to add the appropriate A 
record, and/or CNAME if applicable for the remote mail exchange server. 

 For a CNAME record, you will need to first enter the alias domain name for 
which you wish to create the CNAME record. You then need to enter the domain 
name within which you want the alias to reside. Any domain name can be 
entered. It does not need to reside on the same server. 

 For a PTR record you will first enter the IP address/mask for which you wish to 
define the pointer. Then enter the appropriate domain name for this IP to be 
translated to. 

 For a TXT record, you will be able to enter an arbitrary text string, which could 
be a description or an SPF record. 

4. Click OK to submit the data. 

Note: When you are finished with modifying DNS records of the DNS zone, confirm the 
changes by clicking the Apply button on the DNS zone screen (DNS Settings). 
Unconfirmed changes will not be saved. 
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Modifying Resource Records 

 To modify the properties of a resource record: 

1. Go to Home > DNS Settings (in the Web Site group). 

2. Click the hyperlink in the Host column corresponding to the resource 
record you want to modify. 

3. Modify the record as required and click OK. 

 To modify entries in the Start of Authority (SOA) record for a domain: 

1. Go to Home > DNS Settings (in the Web Site group) > SOA Record. 

2. Specify the desired values: 

 TTL. This is the amount of time that other DNS servers should store the record in 
a cache. Parallels Plesk Panel sets the default value of one day. 

 Refresh. This is how often the secondary name servers check with the primary 
name server to see if any changes have been made to the domain's zone file. 
Parallels Plesk Panel sets the default value of three hours. 

 Retry. This is the time a secondary server waits before retrying a failed zone 
transfer. This time is typically less than the refresh interval. Parallels Plesk 
Panel sets the default value of one hour. 

 Expire. This is the time before a secondary server stops responding to queries, 
after a lapsed refresh interval where the zone was not refreshed or updated. 
Parallels Plesk Panel sets the default value of one week. 

 Minimum. This is the time a secondary server should cache a negative response. 
Parallels Plesk Panel sets the default value of three hours. 

3. Click OK. 

Usage of serial number format recommended by IETF and RIPE is mandatory for many 
domains registered in some high-level DNS zones, mostly European ones. If your 
domain is registered in one of these zones and your registrar refuses your SOA serial 
number, using serial number format recommended by IETF and RIPE should resolve 
this issue. 

Parallels Plesk Panel servers use UNIX timestamp syntax for configuring DNS zones. 
UNIX timestamp is the number of seconds since January 1, 1970 (Unix Epoch). The 
32-bit timestamp will overflow by July 8, 2038. 

RIPE recommends using YYYYMMDDNN format, where YYYY is year (four digits), MM 
is month (two digits), DD is day of month (two digits) and NN is version per day (two 
digits). The YYYYMMDDNN format won't overflow until the year 4294. 
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 To change the Start of Authority (SOA) serial number format to 
YYYYMMDDNN for a domain: 

1. Go to Home > DNS Settings (in the Web Site group) > SOA Record. 

2. Select the Use serial number format recommended by IETF and RIPE check box. 

Note: See the sample of SOA serial number generated with the selected format. If 
the resulting number is less, than the current zone number, the modification may 
cause temporary malfunction of DNS for this domain. Zone updates may be 
invisible to Internet users for some time. 

3. Click OK.  

Removing Resource Records 

 To remove a resource record from the zone: 

1. Go to Home > DNS Settings (in the Web Site group). 

2. Select a check box corresponding to the record you wish to remove. 

3. Click Remove. Confirm removal and click OK. 

Note: When you are finished with modifying DNS records of the DNS zone, confirm the 
changes by clicking the Apply button on the DNS zone screen (DNS Settings). 
Unconfirmed changes will not be saved. 

Restoring the Original Zone Configuration 

 To restore the original zone configuration in accordance with the 
configuration preset defined by your provider: 

1. Go to Home > DNS Settings (in the Web Site group). 

2. In the IP address drop-down box, select the IP address to be used for 
restoring the zone, specify whether a www alias is required for the 
domain, and click the Default button. The zone configuration will be 
recreated. 

 To restore the default Start of Authority (SOA) serial number format (UNIX 
timestamp) for a domain: 

1. Go to Home > DNS Settings (in the Web Site group) > SOA Record. 

2. Clear the Use serial number format recommended by IETF and RIPE check box. 



 

96 Setting Up And Maintaining Your Web Site 

 

Note: See the sample of SOA serial number generated with the selected format. If 
the resulting number is less, than the current zone number, the modification may 
cause temporary malfunction of DNS for this domain. Zone updates may be 
invisible to Internet users for some time. 

3. Click OK.  

 

Serving Your Site with External Domain 
Name Servers 

If you host a Web site on this server and have a standalone DNS server acting as a 
primary (master) name server for your site, you may want to set up your control panel's 
DNS server to function as a secondary (slave) name server. 

 To make the control panel's DNS server act as a secondary name server: 

1. Go to Home > DNS Settings (in the Web Site group). 

2. Click Switch DNS Service Mode. 

3. Click Add Record, specify the IP address of the primary (master) DNS 
server, and click OK. 

 To make the control panel’s DNS server act as a primary for a zone: 

1. Go to Home > DNS Settings (in the Web Site group). 

2. Click Switch DNS Service Mode. The original resource records for the zone 
will be restored. 

If you host a web site on this server and rely entirely on other machines to perform the 
Domain Name Service for your site (there are two external name servers - a primary 
and a secondary), switch off the control panel‘s DNS service for each site served by 
external name servers. 

 To switch off the control panel’s DNS service for a site served by an 
external name server: 

1. Go to Home > DNS Settings (in the Web Site group). 

2. Click Switch Off the DNS Service. Turning the DNS service off for the zone 
will refresh the screen, so that only a list of name servers remains. 

Note: The listed name server records have no effect on the system. They are only 
presented on the screen as clickable links to give you a chance to validate the 
configuration of the zone maintained on the external authoritative name servers. 
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 To validate the configuration of a zone maintained on authoritative name 
servers: 

1. Go to Home > DNS Settings (in the Web Site group). 

2. Add the entries pointing to the appropriate name servers that are 
authoritative for the zone to the list of DNS records: click Add Record, 
specify a name server, and click OK. Repeat this for each name server 
you would like to test.  

3. The records will appear in the list. 

4. Click on the records that you have just created. Parallels Plesk Panel 
will retrieve the zone file from a remote name server and check the 
resource records to make sure that domain‘s resources are properly 
resolved.  

The results will be interpreted and displayed on the screen. 

 

Changing Web Hosting Type from 
Physical to Forwarding 

If you hosted a site on the server with virtual (or physical) hosting account, and now 
you need only domain forwarding service for that site because it has been moved to 
another server, you should reconfigure the hosting account. 

Before changing hosting configuration for a site that was previously on a physical 
hosting account, make sure that you have a local copy of your site because all files and 
directories related to a site are removed from the server when hosting type is changed. 

 To reconfigure a hosting account: 

1. Go to Home > Web Site group title menu > Change Hosting Type. 

2. Select the Forwarding option, and then select the type of forwarding: 
Frame forwarding or Standard forwarding.  

With standard forwarding, a user is redirected to the site and the actual site's URL 
is shown in the user's browser, so the user always knows that he or she is 
redirected to another URL. With frame forwarding, a user is redirected to the site 
without knowing that the site actually resides at another location, therefore, Frame 
forwarding should be preferred. 

3. Specify the destination URL: the current Web site address that you 
would like this domain to point to. 

4. Click OK. 

 



 

  
 

You can use a number of different e-mail services with a single e-mail account. For 
example, you can have an e-mail address that will accept mail as any standard 
mailbox, forward to a number of recipients, and send an automatic response to the 
original message sender. 
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Creating Mailboxes 

If you wish to have an e-mail address associated with your site, like yourname@your-
domain.com, you should create a mailbox. 

 To create your mailbox associated with your site: 

1. Go to Home > Create Mail Account. 

2. Your domain name is shown to the right of @ sign, so you only need to 
specify the desired name for the mailbox.  

This can be, for example, your first name and last name separated by a dot, a 
department name, or any other text in Latin symbols. The name should be short 
enough to remember. It can comprise alphanumeric, dash, dot and underscore 
symbols. 

3. Specify a password that you will use for accessing your mailbox.  

4. Make sure that a check mark is present in the Mailbox check box. 

5. Click OK. 

Now your mailbox is created on the provider‘s server, and you can set up your favorite 
e-mail program so as to receive and send e-mail messages through your new mailbox. 

 To create mailboxes for other users: 

1. Go to Home > Create Mail Account. 

2. Your domain name is shown to the right of @ sign, so you only need to 
specify the desired name for the mailbox.  

This can be, for example, user‘s first name and last name separated by a dot, a 
department name, or any other text in Latin symbols. The name should be short 
enough to remember. It can comprise alphanumeric, dash dot and underscore 
symbols. 

3. Specify a password that mailbox owner will use for accessing his or her 
mailbox. 

4. Specify the settings related to the appearance of user's control panel, if 
desired: interface language, theme (skin), the limit on number of 
characters that can appear on custom buttons placed into the control 
panel by the mailbox owner. 

5. Leave the Allow multiple sessions check box selected to allow the mailbox 
owner to have several simultaneous sessions in the control panel.  

6. Leave the Prevent users from working with the control panel until interface screens 
are completely loaded check box selected. 

This will forbid users from submitting data or performing operations until the control 
panel is ready to accept them. 
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7. Make sure that a check mark is present in the Mailbox check box. 

8. If required, limit the amount of disk space that this mailbox and it's 
autoresponder attachment files can use. To do this, under Mailbox quota 
select the Enter size option and type the desired value in kilobytes. 

9. Click OK. 

10. To allow the mailbox owner configure and use spam filter and antivirus, 
click Permissions, select the respective check boxes and click OK. 

Now, the mailbox is created, and a separate e-mail administration panel has been set 
up in Parallels Plesk Panel. To enter it, the mailbox owner should visit the URL 
https://your-domain.com:8443, type his or her e-mail address into the Login box, type 
the password for the mailbox into the Password box, and then click Login. 
 

Accessing Your Mail 

There are two ways to access a mailbox for sending and receiving e-mail messages: 

 Set up and use an e-mail client program on your computer. 

 Use a Web browser to connect to the webmail interface. 

 To enable access to the webmail interface: 

1. Go to Home > Mail group title menu > Mail Settings. 

2. From the Webmail menu, select the webmail program that you want to 
use. 

3. Click OK. 

Note: Activation and deactivation of webmail for your domain involves modifications in 
DNS zone, therefore, there is actually a certain delay present when activating and 
deactivating webmail due to the speed of DNS registration mechanisms. 

 To access webmail: 

In a Web browser, visit the URL webmail.example.com, where example.com is the 
Internet address of your website. When prompted, specify your full e-mail address as 
the username (for example, mail@example.com), and specify the password that you 
use for logging in to the Panel. 

In this section: 

Setting Up Microsoft Office Outlook 2007 .......................................................... 101 
Setting Up Microsoft Outlook Express 6 ............................................................ 104 
Setting Up Mozilla Thunderbird ......................................................................... 108 
Setting Up Apple Mail ........................................................................................ 113 
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Setting Up Microsoft Office Outlook 2007 

 To set up Microsoft Office Outlook 2007: 

1. Open Microsoft Office Outlook. 

2. Go to Tools > Account Settings. 

3. On the E-mail tab, click New. 

4. Leave the option Microsoft Exchange, POP3, IMAP, or HTTP selected. Click 
Next. 

 

5. Select the check box Manually configure server settings or additional server 
types. Click Next. 
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6. Select the Internet E-mail option and click Next. 
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7. Specify the following: 

 Your name. 

 Your e-mail address. 

 Account type. If you want to keep copies of messages on the server, select the 
IMAP option. If you do not want to keep any messages on the server, select the 
POP3 option. 

 Incoming mail server. Type your domain name. For example, example.com. 

 Outgoing mail server. Type your domain name. For example, example.com. 

 Username for logging in to the mailbox. Specify your full e-mail address. 

 Password for logging in to the mailbox. Most likely, this password coincides with 
the password you use for logging in to the Panel. 

 

8. Click Next. 

9. Click Finish. 
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Setting Up Microsoft Outlook Express 6 

The instructions provided in this section were verified against Microsoft Outlook 
Express 6. They might not work with earlier or later versions of Microsoft Outlook 
Express. 

 To set up Microsoft Outlook Express: 

1. Open Microsoft Outlook Express. 

2. Go to Tools > Accounts. 

3. Click the Add button and select the Mail item. 

4. Enter your name as you want it to appear in any messages you send, 
and click Next. 

 

5. Type your e-mail address, and click Next. 
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6. Specify the following settings: 

 Protocol of your incoming mail server. 

If you want to keep copies of messages on the server, select the IMAP option. If 
you do not want to keep any messages on the server, select the POP3 option. 

 Incoming mail server. Specify your website's Internet address. 

 Outgoing mail server. Specify your website's Internet address. 
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7. Click Next. 

8. Specify the following: 

 Your account name. Type your e-mail address in the Account name box. 

 Your password. Most likely, this password coincides with the password you use 
for logging in to the Panel. 

 Remember password check box. Leave it selected if you do not want to be 
prompted to enter password each time your e-mail program connects to the mail 
server to check for new mail, and click Next. 
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9. To complete setting up your e-mail program, click Finish. 
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Setting Up Mozilla Thunderbird 

The instructions provided in this section were verified against Mozilla Thunderbird 2. 
They might not work with earlier or later versions of Mozilla Thunderbird. 

 To set up Mozilla Thunderbird: 

1. Open Mozilla Thunderbird. 

2. Go to Tools > Account Settings. 

3. Click Add Account.  

The Account Wizard opens. 

4. Leave the Email account option selected, and click Next. 

 

5. Specify the following: 

 Your name, as you want it to appear in any messages you send. 

 Your e-mail address. 
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6. Click Next. 

7. Specify the following: 

 Protocol of your incoming mail server. 

If you want to keep copies of messages on the server, select the IMAP option. If 
you do not want to keep any messages on the server, select the POP3 option. 

 Incoming server address. Specify your website's Internet address. 

 Outgoing server address. Specify your website's Internet address. 
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8. Click Next. 

9. In the Incoming User Name box, specify your full e-mail address. 
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10. Click Next. 

11. Enter the name by which you would like to refer to this account (for 
example, Work Account) and click Next. 
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12. Verify that the information you entered is correct, and click Finish. 

13. Click OK to close the Account Settings wizard. 
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Setting Up Apple Mail 

The instructions provided in this section were verified against Apple Mail 3.6 (Leopard). 
They might not work with earlier or later versions of Apple Mail. 

 To set up Apple Mail: 

1. Run Apple Mail. 

If you run it for the first time and do not have any mail accounts configured in it, skip 
the next step: Apple Mail will take you directly to creating one. 

2. Open the Adding Mail Account wizard: 

a. Click Mail > Preferences.... 

b. Select the Accounts tab. 

c. Click the + button at the bottom left corner. 

3. Enter the account information: 

 Your full name 

 Your full e-mail address 

 The password you use to log in to the Panel.  

 

4. Click Continue. 

5. Fill in the following incoming mail server information: 

 Account Type: select whether you want to use IMAP or POP protocol. Selecting 
IMAP lets you keep messages on the server. 
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 Incoming Mail Server: type in the name of domain which serves your mail (which 
follows the @ sign in your e-mail address). 

 User Name: enter your full e-mail address.  

 Password: leave it auto-completed (Apple Mail takes it from the previous step). 

 

6. Click Continue. 

7. (Optional) Specify the incoming mail security options: 

a. Select the Use Secure Sockets Layer (SSL) check box. 

b. Select the authentication method. 

Keep the default method if you are not sure which to select. 

Apple Mail displays this setup screen only if a mail server bundled with the Panel 
supports SSL for the selected account type (POP or IMAP). 
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8. Click Continue. 

9. Fill in the following outgoing mail server information: 

 Outgoing Mail Server: type in the name of domain which serves your mail (which 
follows the @ sign in your e-mail address). 

 Use only this server: selected. 

 Use Authentication: selected. 

 User Name: enter your full e-mail address.  

 Password: leave it auto-completed (Apple Mail takes it from the previous step). 
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10. Click Continue. 

Apple Mail displays overall description of the mail account that is going to be 
created. 

11. Select the Take account online check box and click Create. 
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Protecting Mailboxes From Spam 

To protect your mailbox from undesirable correspondence, do not publish your e-mail 
address on Internet forums and switch on the server-side spam filter provided by the 
SpamAssassin software. Also ask your provider to switch on protection from spam and 
phishing based on DomainKeys. 

DomainKeys is based on sender authentication. When an e-mail claims to originate 
from a certain domain, DomainKeys provides a mechanism by which the recipient 
system can credibly determine that the e-mail did in fact originate from a person or 
system authorized to send e-mail for that domain. If the sender verification fails, the 
recipient system discards such e-mail messages. Verification of incoming mail can be 
switched on only by your provider; however, if server policy allows, you can switch on 
signing of e-mail messages that are sent from your domain: Home > Mail group title 
menu > Mail Settings > Use DomainKeys spam protection system to sign outgoing e-mail 
messages option. 

If you use a Linux-based hosting account, then you can also use the spam protection 
based on greylisting. Greylisting is a spam protection system which works as follows: 
For every e-mail message that comes to the server, sender's and receiver's e-mail 
addresses are recorded in a database. When a message comes for the first time, its 
sender and receiver addresses are not listed in the database yet, and the server 
temporarily rejects the message with an SMTP error code. If the mail is legitimate and 
the sending server is properly configured, it will try sending e-mail again and the 
message will be accepted. If the message is sent by a spammer, then mail sending will 
not be retried: spammers usually send mail in bulk to thousands of recipients and do 
not bother with resending. 

The greylisting protection system also takes into account the server-wide and per-user 
black and white lists of e-mail senders: e-mail from the white-listed senders is accepted 
without passing through the greylisting check, and mail from the black-listed senders is 
always rejected.      

When the greylisting support components are installed on the server, then greylisting is 
automatically switched on for all domains. You can switch off and on greylisting 
protection for your domain through Parallels Plesk Panel (at Home > Mail group title 
menu > Mail Settings > Switch on greylisting spam protection for all mail accounts under this 
domain option). When you need to publish your e-mail address, you may want to create 
a disposable e-mail address - e-mail alias - for your primary e-mail address, and 
publish it instead. All messages sent to the e-mail alias will come into your mailbox. 
Once you start getting spam, remove that alias and create another one. If you have a 
mailbox at another domain or mail server, you may want to set up a disposable e-mail 
forwarder. 

In this section: 

Setting Up Additional Disposable E-mail Addresses for Your Mailbox (E-mail Aliases)
 .......................................................................................................................... 118 
Setting Up Spam Filter ...................................................................................... 118 
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Setting Up Additional Disposable E-mail Addresses for 
Your Mailbox (E-mail Aliases) 

 To set up an e-mail alias for a mailbox: 

1. Go to Home > Mail Accounts > e-mail address > Add New Mail Alias. 

2. Type a desired name and click OK. 

The messages addressed to your additional e-mail address (e-mail alias) will get to 

your mailbox. You can see the list of currently used mail aliases by clicking  Show 
Aliases in the list of mail accounts under the domain. 

 To remove an e-mail alias from a mailbox: 

1. Go to Home > Mail Accounts > e-mail address. 

2. Select the check box corresponding to the alias that you wish to 
remove, and click Remove. Confirm the removal and click OK. 

 
 

Setting Up Spam Filter 

If you receive undesirable correspondence to an e-mail address that you cannot or do 
not want to remove, consider setting up spam filter for your mailbox. To do this, 

 Enable SpamAssassin spam filter on your hosting account, if supported by your 
provider, and 

 Install spam filtering software of your choice to work with e-mail program on your 
home or office computer. 

 

In this section: 

Switching On SpamAssassin Spam Filter .......................................................... 119 
Improving Accuracy of Spam Detection ............................................................. 120 
Clearing Spam Filter's Database ....................................................................... 121 
Switching Off Spam Filter .................................................................................. 121 
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Switching On SpamAssassin Spam Filter 

 To switch on spam filtering for a mailbox: 

1. Go to Home > Mail Accounts > e-mail address > Spam Filtering. 

2. Configure the following settings as desired: 

 Switch on SpamAssassin spam filtering. Select this option to switch on spam 
protection. 

 The number of points a message must score to be considered spam. This setting 
adjusts spam filter sensitivity. SpamAssassin performs a number of different 
tests on contents and subject line of each message. As a result, each message 
scores a number of points. The higher the number, the more likely a message is 
spam. For example, a message containing the text string ―BUY VIAGRA AT 
LOW PRICE!!!‖ in Subject line and message body scores 8.3 points. By default, 
the filter sensitivity is set so that all messages that score 7 or more points are 
classified as spam. 

 If you receive lots of spam messages with the current setting, to make filter 
more sensitive, try setting a lesser value in the The score that a message must 
receive to qualify as spam box; for example, 6.  

 If you are missing your e-mails because your spam filter thinks they are junk, 
try reducing filter sensitivity by setting a higher value in the The score that a 
message must receive to qualify as spam box. 

Note: To further improve spam filter accuracy, you may want to train your spam 

filter on e-mail messages you receive (see the instructions on improving 
accuracy of spam detection in the following section).  

 What to do with spam mail. If you are sure that your spam filter is accurate, you 
may want to set the filter to automatically delete all incoming messages 
recognized as spam. To do this, select the Delete option. If you wish to filter mail 
with the software on your local computer, select the Mark as spam and store in 
mailbox option, and then specify how spam filter should mark the messages 
recognized as spam. ―X-Spam-Flag: YES‖ and ―X-Spam-Status: Yes‖ headers 
are added to the message source by default, and if you want, the spam filter will 
also include a specific text string to the beginning of Subject line. To include a 
desired combination of symbols or words to the message subject, type it into the 
Add the following text to the beginning of subject of each message recognized as spam 
box. If you do not want the spam filter to modify message subject, leave this box 
blank. If you want to include into the subject line the number of points that 
messages score, type _SCORE_ in this box. 

 Spam detection alert text. If you want spam filter to include a text into e-mail 
messages marked as spam, type the text into this box.   

 Trusted languages and locales. E-mail messages written in the specified languages 
and with the defined character sets will pass the spam filter and will not be 
marked as spam. 

3. Click OK to save the settings. 
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4. If you do not want to receive e-mail from specific domains or individual 
senders, click the Black List tab, and then add the respective entries to 
the spam filter‘s black list: 

 To add entries to the black list, click Add Addresses. If you have a list of entries 
stored in a file, click Browse to specify it, and then click OK. Otherwise, select the 
From List option, and type the e-mail addresses into the E-mail addresses box. 
Place each address in one row, or separate addresses with a coma, a colon, or 
a white space. You can use an asterisk (*) as a substitute for a number of 
letters, and question mark (?) as a substitute for a single letter. For example: 
address@spammers.net, user?@spammers.net, *@spammers.net. Specifying 
*@spammers.net will block the entire mail domain spammers.net. To save the 
entries you added, click OK, then confirm adding, and click OK again. 

 To remove entries from the black list, under the Black List tab, select the entries 
and click Remove. Confirm removal and click OK.  

5. If you want to be sure that you will not miss e-mail from specific 
senders, click the White List tab, and then add e-mail addresses or entire 
domains to the spam filter‘s white list: 

 To add entries to the white list, click Add Addresses. If you have a list of entries 
stored in a file, click Browse to specify it, and then click OK. Otherwise, select the 
From List option, and type the e-mail addresses into the E-mail addresses box. 
Place each address in one row, or separate addresses with a coma, a colon, or 
a white space. You can use an asterisk (*) as a substitute for a number of 
letters, and question mark (?) as a substitute for a single letter. For example: 
address@mycompany.com, user?@mycompany.com, *@mycompany.com. 
Specifying *@mycompany.com will add to the white list all e-mail addresses that 
are under the mycompany.com mail domain. To save the entries you added, 
click OK, then confirm adding, and click OK again. 

 To remove entries from the white list, under the White List tab, select the entries 
and click Remove. Confirm removal and click OK. 

6. Once finished with setting up the spam filter, click OK. 

 

Improving Accuracy of Spam Detection 

You can improve accuracy of spam detection by training the spam filter on the e-mail 
messages that you have in your mailbox.  

 To improve accuracy of spam detection: 

1. Go to Home > Mail Accounts > e-mail address > Spam Filtering > Training.  

Note: In Parallels Plesk Panel for Linux/Unix platforms, each message is 
accompanied by an icon in the left column, which tells if a message is recognized 

as spam - , non-spam - , or not recognized at all - . If you have already 
trained your spam filter on a message and the results were recorded in the spam 

filter‘s database, an icon  is shown in the right column. 

2. Train the spam filter.  
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In most cases, you can tell if a message is spam by looking at its subject line and 
sender‘s name. If they do not give you any clue, try looking inside the message 
using your e-mail program or webmail interface. 

 To mark a message as spam, select the corresponding check box and click ‘It’s 
Spam!’. 

 To mark a message as not spam, select the corresponding check box and click 
‘It’s Not Spam’. 

 To remove any information on a given message from the spam filter database, 
select the corresponding check box and click ‘Forget It’. 

3. Once finished with training, you can remove spam e-mails from your 
mailbox using your e-mail program or webmail interface. 

 
 

Clearing Spam Filter's Database 

If you have accidentally made your spam filter learn a great number of spam e-mails as 
non-spam or vice versa, your spam filter will likely produce incorrect results. In this 
case, clear the spam filter's database and then repeat training. 

 To clear spam filter’s database: 

1. Go to Home > Mail Accounts > e-mail address > Spam Filtering. 

2. Click the Training tab. 

3. Click the Clear button. 

 
 

Switching Off Spam Filter 

 To switch off spam filtering for a mailbox: 

1. Go to Home > Mail Accounts > e-mail address > Spam Filtering. 

2. Clear the Switch on SpamAssassin spam filtering check box and click OK. 
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Protecting Mailboxes From Viruses 

To defend your system from viruses, do not open suspicious e-mail attachments, 
enable anti-virus protection on the server side, if this service is provided by your 
hosting company, and be sure to have a firewall and anti-virus software installed on 
your personal computer. Also keep your operating system up-to-date and timely install 
security hotfixes and patches. 

In this section: 

Switching On Anti-virus Protection .................................................................... 122 
Switching Off Anti-virus Protection .................................................................... 122 
 
 

Switching On Anti-virus Protection 

 To switch on anti-virus protection for a mailbox: 

1. Go to Home > Mail Accounts > e-mail address > Virus Protection. 

2. Choose the desired mail scanning mode. You can switch on scanning 
for incoming mail, outgoing mail, or both. 

Note: If Kaspersky Antivirus is used on the server, then you can use the Scanning 
settings icon to adjust scanning settings. To view the information about scanning 
settings, click the Help shortcut in the navigation pane. 

3. Click OK. 

 
 

Switching Off Anti-virus Protection 

 To switch off anti-virus protection for a mailbox: 

1. Go to Home > Mail Accounts > e-mail address > Virus Protection. 

2. Select the Do not scan for viruses option and click OK. 
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Suspending and Unsuspending Mailboxes 

 To temporarily suspend e-mail services for a mailbox: 

1. Go to Home > Mail Accounts > e-mail address > Mailbox. 

2. Clear the Mailbox check box. 

3. Click OK. 

 To resume e-mail services for a suspended mailbox: 

1. Go to Home > Mail Accounts > e-mail address > Mailbox. 

2. Select the Mailbox check box. 

3. Click OK. 

 To temporarily suspend e-mail services for all mailboxes in your domain: 

1. Go to Home > Mail Accounts. 

2. Click Switch Off in the Tools group. 

 To resume e-mail services for all mailboxes in your domain: 

1. Go to Home > Mail Accounts. 

2. Click Switch On in the Tools group. 

 
 

Removing Mailboxes 

 To remove a mailbox: 

1. Go to Home > Mail Accounts. 

2. Select a check box corresponding to the mailbox that you wish to 
remove. 

3. Click Remove. Confirm removal and click OK. 
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Setting Up Mail Forwarding to a Single E-
mail Address 

 To set up an e-mail address that will accept mail and forward it to another 
e-mail address: 

1. Go to Home > Create Redirect. 

2. Select an e-mail address that you would like to turn into a mail 
forwarder, or click Add New Mail Account to set up new e-mail address. 

3. Click Next >>. 

The domain name is shown to the right of @ sign, so you only need to type the 
name. This can be, for example, your first name and last name separated by a dot, 
a department name, or any other text in Latin symbols. The name should be short 
enough to remember. It can comprise alphanumeric, dash, dot, and underscore 
symbols. 

4. Select the Redirect check box and type the destination e-mail address to 
which you would like to forward e-mail. 

5. Click Finish. 

 

Suspending and Unsuspending Mail Forwarders 

 To suspend a mail forwarder: 

1. Go to Home > Mail Accounts > e-mail address > Redirect. 

2. Clear the Redirect check box. 

3. Click OK. 

 To unsuspend a mail forwarder: 

1. Go to Home > Mail Accounts > e-mail address > Redirect. 

2. Select the Redirect check box. 

3. Click OK. 
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Setting Up Mail Forwarding to Multiple E-
mail Addresses 

 To set up an e-mail address that will accept mail and forward it to multiple 
other e-mail addresses: 

1. Go to Home > Mail Accounts > e-mail address > Mail Group. 

2. Click Add New Member. 

You should add at least one e-mail address before enabling mail forwarding to 
several e-mail addresses. 

3. Enter the desired external e-mail address into the E-mail input box or 
select one or more of the listed mail accounts using check boxes.  

4. Click OK. 

5. Click Switch On. 

In this section: 

Adding and Removing Recipient Addresses ...................................................... 125 
Switching off Mail Forwarding to Multiple E-mail Addresses .............................. 126 

 

Adding and Removing Recipient Addresses 

 To add an external e-mail address to the list of mail accounts that receive 
forwarded e-mail correspondence: 

1. Go to Home > Mail Accounts > e-mail address > Mail Group. 

2. Click Add New Member. 

3. Enter the desired external e-mail address into the E-mail input field. 

4. Click OK. 

 To remove an external e-mail address from the list of mail accounts that 
receive forwarded e-mail correspondence: 

1. Go to Home > Mail Accounts > e-mail address > Mail Group. 

2. Select the check box corresponding to the mail account you wish to 
remove from the list. 

3. Click Remove. Confirm removal and click OK. 
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 To add an e-mail address registered on the server to the list of mail 
accounts that receive forwarded e-mail correspondence: 

1. Go to Home > Mail Accounts > e-mail address > Groups. 

2. Select the required multiple e-mail forwarder in the Available mail groups 
list. 

3. Click Add >>. 

4. Click OK. 

An e-mail address registered on your server can also be added to the subscription list 
using the procedure for adding an external e-mail address (see above). 

 To remove an e-mail address registered on your server from the list of 
mail accounts that receive forwarded e-mail correspondence: 

1. Go to Home > Mail Accounts > e-mail address > Groups. 

2. Select the required multiple e-mail forwarder in the Member of the following 
mail groups list. 

3. Click << Remove. 

4. Click OK. 

An e-mail address registered on your server can also be removed from the subscription 
list using the procedure for removing an external e-mail address (see above). 

Switching off Mail Forwarding to Multiple E-mail 
Addresses 

 To disable the e-mail forwarding to several e-mail addresses: 

1. Go to Home > Mail Accounts > e-mail address  > Mail Group. 

2. Click Switch Off. 

 

Removing Mail Forwarders 

 To remove a mail forwarder: 

1. On your Home page, click Mail Accounts. 
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2. Select a check box corresponding to the mail forwarder that you wish to 
remove. 

3. Click Remove. Confirm removal and click OK. 

 

Setting Up Automatic Reply 

If you are going on vacation and will not be able to check your mail for a while, you may 
want to leave a vacation notice that will be automatically sent to your correspondents 
once they send e-mail to your address. This is done with automatic reply facility, also 
referred to as autoresponder. Aside from vacation notices, organizations can use 
automatic replies to notify customers that their orders or technical support requests 
were received and will soon be processed. Automatic replies can include prewritten 
messages in plain text or HTML format, and they can contain attached files as well. 

 To set up automatic reply for a mailbox: 

1. Go to Home > Mail Accounts > e-mail address > Autoresponders. 

2. If you are not going to attach any files to the automatic reply, proceed to 
the step 5. To attach a file to the automatic reply:  

a. Click the Attachment Files icon in the Tools group.  

b. Click Browse to locate the file, and once selected, click Send File.  

The file will be added to the attachment files storage, and you will be able to 
attach this file to a number of different automatic replies.  

c. Once finished, click Up Level and proceed to the next step. 

3. Click the Add New Autoresponder icon in the Tools group. 

4. Configure the automatic reply: 

a. Type a name for this automatic reply into the Autoresponder name 
box.  

For example, 'Vacation notice'. 

b. If you want your incoming mail to be forwarded to another e-mail 
address while you are away, specify an e-mail address in the 
Upon automatic response, forward the original message to the specified e-
mail box. 

c. If you want this automatic reply to be sent in reply to any 
incoming e-mail message, in the Conditions group, leave the 
always respond option selected. If you wish to automatically reply 
only to e-mail messages that contain specific words in the 
message text or subject line, select the appropriate option, and 
type the word combination in the input box. 
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d. By default, the subject line of incoming e-mail will be inserted 
into the automated reply. To use a custom subject, type it into 
the Reply subject input box. 

e. As your correspondents may not figure out that the message 
they received from you was an automatic response, they may 
want to respond to your auto-reply. So, you should specify your 
e-mail address as the Return address, otherwise, their messages 
will be directed at the autoresponder‘s address. 

f. Specify the automatic reply message format (plain text or HTML) 
and character encoding (UTF-8 is recommended). If you use 
HTML tags in your auto-reply message, you should select the 
HTML option. 

g. Type your message in the Reply with text field. 

h. To limit the number of automated responses per day to the 
same e-mail address, enter the desired number in the 
respective input box under Limits.  

The default setting is to respond no more than ten times in one day to the same 
e-mail address. 

i. To reduce mail server load, you may want to limit the number of 
unique addresses that the autoresponder will remember. To do 
this, enter the desired number into the Store up to box. 

j. Attach your files, if needed. To do this, click the  Add New 
Attachment button, select the check box corresponding to the file 
that you previously uploaded to the attachment storage, and 
click OK. To remove an attached file from the automatic reply, 
select the corresponding check box, and click Remove. 

5. Click OK. 

6. Click the Switch On icon in the Tools group. 

 

Switching off Automatic Reply 

 To switch off an automatic reply for a mailbox: 

1. Go to Home > Mail Accounts > e-mail address > Autoresponders. 

2. Click Switch Off. 

The automatic reply is now switched off. Its configuration is not deleted from the control 
panel, so the next time you need to use this automatic reply, repeat the above 
procedure, clicking Switch On on the last step. 
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 To delete an automatic reply configuration that you no longer need: 

1. Go to Home > Mail Accounts > e-mail address > Autoresponders. 

2. Select a check box corresponding to the configuration name, and click 
Remove. Confirm the removal and click OK. 

 

Setting Up Site-wide Preferences for 
Handling Mail to Nonexistent Users 

When somebody sends an e-mail message to an e-mail address that does not exist 
under your domain, the mail server, by default accepts mail, processes it, and when it 
finds out that there is no such a recipient under the domain, it returns the mail back to 
sender with the ―this address no longer accepts mail‖ notice. You can choose to: 

 Continue returning all such mail back to senders (Bounce or Bounce with message 
option), 

 Forward all such mail to the specified e-mail address (Forward to address option), 

 Forward all such mail to another mail server with the specified IP address, if you 
are on Windows-based hosting (Redirect to external mail server with IP address option), 

 Reject such mail without accepting it and without notifying senders (Reject option).  

This setting can decrease mail server load caused by a large amount of spam, 
which is often sent to randomly generated user names. However, for spammers, 
this can somewhat speed up scanning your mail server for valid e-mail addresses. 

 To configure the site-wide settings for handling mail to nonexistent users:  

1. Go to Home > Mail group title menu > Mail Settings. 

2. Select the required option and specify the information as required. 

3. Click OK. 

 

Introducing Changes to a Number of Mail 
Accounts at Once 

 To introduce similar changes to a number of mail accounts at once: 

1. Go to Home > Mail Accounts. 
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2. Select the check boxes corresponding to the mail accounts whose 
settings you want to modify. 

3. Click  Modify. 

4. Adjust the settings as necessary: 

 Select Switch on to enable the corresponding option for the selected mail 
accounts. 

 Select Switch off to disable the corresponding option for the selected mail 
accounts. 

 Leave Do not change selected if you do not want to change the corresponding 
option. 

5. Click OK. 

 

Maintaining Mailing Lists 

If you wish to deliver offers and promotions to your customers, run a newsletter, or 
inform visitors of your site of recent updates, you should set up a mailing list on your 
site and subscribe your users to it or invite them to subscribe themselves. 

Mailing list is a convenient way to reach a number of readers at once: it contains a list 
of e-mail addresses, which are combined under a single e-mail address, to which you 
post your information or a newsletter. 

In this section: 

Setting Up a Mailing List .................................................................................... 130 
Subscribing and Unsubscribing Users ............................................................... 131 
Posting to Your Mailing List ............................................................................... 132 
Removing Mailing Lists ..................................................................................... 132 
 

Setting Up a Mailing List 

 To set up a mailing list: 

1. Go to Home > Mailing lists. 

2. Click the Switch On icon in the Tools group to start up the mailing list 
service. 

3. Click Add New Mailing List. 

4. Specify the desired name for the mailing list.  
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This can be, for example, a department name, a topic of the mailing list, or any 
other text in Latin symbols. The name should be short enough to remember. It can 
comprise alphanumeric, dash, dot and underscore symbols. 

5. Specify the password that will be used for administering the mailing list.  

6. Specify the mailing list administrator‘s e-mail. 

7. Leave the Notify administrator of the mailing list creation check box selected. 

You will receive instructions on using and managing the mailing list at the 
administrator‘s e-mail you specified. Keep that message for your records. 

8. Click OK. 

 To configure the mailing list: 

1. Go to Home > Mailing lists. 

2. Click the icon  next to the desired mailing list‘s e-mail address.  

A login screen opens. 

3. Type the list administrator‘s password and click Let me in …. 

 Alternately, you can access the mailing list configuration the following 
way (on Linux hosting): 

1. In your Web browser, enter the following URL: http://lists.your-
domain.com/mailman/admin/listname (where your-domain.com is your 
domain name, and listname is the name of the mailing list (that is, the 
left part of the mailing list‘s e-mail address before the @ sign).  

A login screen opens.  

2. Type the list administrator‘s password and click Let me in …. 

To post a newsletter issue or other information to the mailing list, send it by e-mail to 
the mailing list‘s e-mail address. All subscribed users will receive it. 

Subscribing and Unsubscribing Users 

 To subscribe users to mailing list: 

1. Go to Home > Mailing lists > mailing list name and click Add New Member. 

2. Specify user‘s e-mail address. 

3. Click OK. 

 To unsubscribe users from mailing list:  

1. Go to Home > Mailing lists > mailing list name. 

2. Select a check box to the left of the user‘s e-mail address. 
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3. Click Remove. Confirm removal and click OK. 
 

Posting to Your Mailing List 

To post a newsletter issue or other information to the mailing list, send it by e-mail to 
the mailing list‘s e-mail address. All subscribed users will receive it. 
 

Removing Mailing Lists 

 To remove a mailing list from site: 

1. Go to Home > Mailing lists. 

2. Select a check box corresponding to the mailing list that you wish to 
remove. 

3. Click Remove. Confirm removal and click OK. 

 

 



 

  
 

 To choose the statistical program you want (Webalizer or AWStats): 

1. On your Home page, click Web Hosting Settings. 

2. Select the statistical package you need from the Web statistics menu 
(AWStats is recommended), and select the accessible via password protected 
directory /plesk-stat/webstat check box.  

This will install the statistical software of your choice, which will generate reports 
and place them into the password protected directory. You will then be able to 
access Web statistics at the URL: https://your-domain.com/plesk-stat/webstat using 
your FTP account login and password. 

3. Click OK. 

Note: When you switch from one statistical program to another, all reports generated 

by the previously used statistical program are removed from the server.   

 To find out how many people visited a site, from what countries, and what 
pages of the site they viewed: 

1. Go to Home > Web Statistics. 

2. View the statistics for the web pages or files downloaded from or 
uploaded to specific areas of your site: 

 To view the statistics for web pages transferred from your site over hypertext 
transfer protocol (HTTP), click Web Stats. 

 To view the statistics for web pages transferred from your site over secure 
hypertext transfer protocol (HTTPS), click Web Stats SSL. 

 To view statistics for files transferred over file transfer protocol (FTP), click FTP 
Stats. 

 To view statistics for files transferred via anonymous FTP, click Anon.FTP Stats. 

 To view the bandwidth usage by months, click Traffic History. 

 To view the bandwidth usage by FTP, Web and mail services in this domain, 
click Traffic. 

Note: If you use Webalizer statistical package on your account, you can customize 
the graphical reports shown by Webalizer. For instructions, refer to the Adjusting 
Preferences for Web Statistics Presentation by Webalizer section. 

Alternately, you can view the Web statistics for a site by visiting the following URL: 
https://your-domain.com/plesk-stat/webstat. When prompted for username and 
password, specify the credentials for your FTP account. 

C H A P T E R  7  

Viewing Usage Statistics for Your Site 
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Common operations on reports: 

 To get more details, select the Full Report option from the Report drop-down menu. 

 To adjust the amount of information presented in a report, click Customize, and then 
modify an existing report template (to do this, click a report template name) or 
create a new report template (to do this, click  Add New Layout). Next, specify how 
much information you want in each section of the report: select None if you do not 
want any information, select Summary if you want a concise overview, or select Full if 
you need a detailed report. Select the Use as default report check box and click OK. 
To delete a custom report layout, select the check box corresponding to the report 
layout name and click Remove.  

 To print the report, click Print. A report will open in a separate browser window. 
Select the File > Print option from the browser's menu to print the report. 

 To send the report by e-mail, type the recipient's e-mail address into the input box 
located to the right of the Report group and click Send by E-mail. If you are the 
recipient, then you do not need to specify an e-mail address: the system assumes 
by default that you are the report recipient and specifies your e-mail address 
registered with your control panel account. 

 To have the reports automatically generated and delivered by e-mail on a daily, 
weekly, or monthly basis, click Report Delivery and follow the instructions supplied in 
the Automating Report Generation and Delivery by E-mail section. 
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Adjusting Preferences for Web Statistics 
Presentation by Webalizer 

By default, statistical utility counts and reports the requests for web pages and other 
files made from your own site – by your web pages. So, when a user‘s browser 
requests from your site a single web page that contains references to other files, such 
as scripts, cascading style sheets, media files, and the like, the statistical utility reports 
these references to files as if they were visits to your web page. Thus, with the default 
settings your usage statistics is inaccurate. 

You may want to: 

 Hide these internal references, and references from other sites. 

 Group references from a number of sites, so as to show them as if they originated 
from a single location. 

 Hide direct requests. Direct requests are sent to your web server when users 
access your site by typing the URL in their browsers. 
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Hiding and Unhiding Internal References from Your and 
Other Sites 

 To hide the internal references or references from other sites: 

1. Go to Home > Web Statistics > Preferences. 

2. Click Hide Entries. 

3. In the Entry type drop-down box, leave the Referrer value selected. 

4. In the Referrer field, type the domain name from which you do not want 
the referrers shown in web statistics reports.  

You can use the '*' wildcard character to specify a part of domain name. 

5. Click OK. 

 To unhide references: 

1. Go to Home > Web Statistics > Preferences. 

2. Select the check boxes corresponding to the entries you wish to unhide 
and click Remove. 

3. Confirm the operation and click OK. 

 

Grouping and Ungrouping References from Other Sites 

 To group references from a specific site: 

1. Go to Home > Web Statistics > Preferences > Grouped referrers tab > Group 
Referrers. 

2. Type the group name that you wish to be shown for all referrers on the 
specific site. 

3. In the Referrer input box, specify the site (domain name) from which all 
referrers should be grouped.  

You can use the '*' wildcard character to specify a part of domain name. 

4. Click OK. 

 To ungroup references from a specific site: 

1. Go to Home > Web Statistics > Preferences > Grouped referrers tab. All referrer 
group names will be presented in a list. 
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2. Select the check box corresponding to the required group name and 
click Remove. 

3. Confirm the operation and click OK. 

 

Hiding and Unhiding Direct Requests 

 To hide direct requests: 

1. Go to Home > Web Statistics > Preferences. 

2. Click Hide Entries. 

3. In the Entry type drop-down box, select the Direct request value. 

4. Click OK. 

 To unhide direct requests: 

1. Go to Home > Web Statistics > Preferences. All hidden entries will be 
presented in a list. 

2. Select the check box corresponding to the Direct request entry and click 
Remove. 

3. Confirm the operation and click OK. 

 

Automating Report Generation and 
Delivery by E-mail 

 To receive detailed reports on your domain on a regular basis: 

1. Go to Home > Statistics group title menu > My Web Site Report > Layouts > 
report type > Report Delivery > New Delivery Schedule. 

2. To receive the report to your e-mail address registered with the system, 
select the the domain administrator value from the Deliver to drop-down 
menu. To receive the report to another e-mail address, select the e-mail 
address I specify option and type the e-mail address.  

3. Select the delivery interval from the Delivery frequency drop-down menu. 
You can have the report delivered each day, each week, or each month. 

4. Click OK. 
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 To change the delivery schedule for a detailed domain/web site report: 

1. Go to Home > Statistics group title menu > My Web Site Report > Layouts > 
report type > Report Delivery. 

2. Under the Frequency column, click a hyperlink corresponding to the 
delivery schedule you would like to change. 

3. Adjust the settings as required and click OK. 

 To stop receiving the account status reports: 

1. Go to Home > Statistics group title menu > My Web Site Report > Layouts > 
report type > Report Delivery. 

2. Select a check box corresponding to the delivery schedule and click 
Remove. Confirm removal and click OK. 

 

Viewing Log Files and Configuring 
Recycling of Log Files 

All connections to the Web server and requests for files that were not found on the 
server are registered in log files. These log files are analyzed by the statistical utilities 
running on the server, which then present graphical reports on demand. You may want 
to download these log files to your computer for processing by third-party statistical 
utilities, or view their contents for web server debugging purposes. 

 To prevent these log files from growing too large, you should enable 
automatic cleanup and recycling of log files: 

1. Go to Home > Log Manager > Log Rotation and click Switch On in the Tools 
group. 

2. Specify when to recycle log files and how many instances of each log 
file to store on the server. Also specify whether they should be 
compressed and sent to an e-mail address after processing. 

3. Click OK. 

 To view the contents of a log file or download it to your computer: 

1. Go to Home > Log Manager. A list of log files opens. 

2. Do any of the following: 

 To specify the number of lines from the end of the log file that you would like to 
view, type a number into the input box under the Preferences group. 
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 To view the contents of a log file, click its file name.  

 To download a file to your computer, click the icon  corresponding to the file you 
need.  

 To remove a processed log file from the server, select a corresponding check box, 
click Remove, confirm removal and click OK. 

 

 



 

  
 

With the current version of backup and restore utilities installed with your control panel, 
you can: 

 Back up your domain (Web site). The backup archive will include all data related to 
your account (except for resource allotments and permissions to perform operations 
within the control panel), domain (web site) and mail services, including the 
contents of mailboxes, Horde Turba address book contact lists, anti-spam and anti-
virus settings. 

 Schedule backups.  

 Restore your data from backup archives. 

You can access your backup repository via your Home page (Home > Backup Manager). 

In this chapter: 
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Configuring Control Panel for Using FTP 
Repository 

 If you are going to use an FTP server for storing backup files, you should 
set up the control panel appropriately: 

1. Go to Home > Backup Manager > Personal FTP Repository Settings. 

2. Specify the following settings: 

 FTP server's IP address or host name. 

 Directory on the server, where you want to store backup files. 

 User name and password for access to the FTP account. 

3. Click OK. 
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Backing Up Your Domain 

 To back up your domain (Web site): 

1. Go to Home > Backup Manager. 

2. Click Back Up. 

3. Specify the following: 

 Backup file name prefix and description. You cannot specify an arbitrary file 
name, however, you can set the control panel to add a prefix to backup file 
names. Note that the control panel automatically adds the date and time of 
backup file creation (in Universal Time) to backup file names. 

 Splitting of the backup file. To create a multivolume backup, select the 
respective check box and specify volume size in megabytes. 

 Location where to store the backup file. Select the repository where you would 
like to store the backup file. 

 What data to back up. You can back up only Web hosting settings, or the Web 
hosting settings and all site content. 

 E-mail notification on backup completion. If you want to send an e-mail notice 
on the backup completion, type the required e-mail address. 

 Suspend the Web site until backing up is finished. If you do not want anybody to 
make any changes to the site content or settings during backing up, select the 
corresponding check box. 

4. Click Back Up. The backup process will start and the progress will be 
shown under the Current Back Up Tasks tab. You can use the Refresh button 
to update the information on the screen. 

When backing up is finished, the backup file will be saved to the repository you 
selected, and will be accessible either from the FTP server, or from the location  Home > 
Backup Manager. 

Backing Up Databases (Windows Hosting) 

 To back up a database: 

1. Go to Home > Databases. 

2. Select a check box corresponding to the database you want to back up 
and click Back Up. 

3. Specify the name of the backup file and click OK. 
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4. If you want to download the resulting backup file, click the file name on 
the next page after the backup process was finished. Specify the 
location where you want to save the file and click Save.  

5. Click OK. 

 To back up all databases on your domain: 

1. Go to Home > Backup Manager > Database Backup Repository, make sure that 
All domain repositories is selected in the Database field, and click Back Up. 

2. Specify the name of the backup file and click OK. 

3. If you want to download the resulting backup file, click the file name on 
the next page after the backup process was finished. Specify the 
location where you want to save the file and click Save.  

4. Click OK. 

 
 

Scheduling Backups 

 To schedule backup of your domain (Web site): 

1. Go to Home > Backup Manager. 

2. Click Scheduled Backup Settings. 

3. Select the Activate this backup task check box and specify the following: 

 When and how often to run the backup. 

 Backup file name. 

 Splitting of the backup file. To create a multivolume backup, select the 
respective check box and specify volume size in megabytes. Note that volume 
size cannot exceed 4095 megabytes. 

 Location where to store the backup file. Select the repository where you would 
like to store the backup file. 

 Maximum number of backup files stored in the repository. Type a number if you 
want to recycle backup files: When this limit is reached, the oldest backup files 
are removed. 

 E-mail notification on backing up errors. If you want to send an e-mail notice 
when something goes wrong during backing up, type the e-mail address you 
need. 

 What data to back up. You can back up only the Web hosting settings, or the 
Web hosting settings and Web site content. 

4. Click OK. 
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Restoring Data From Backup Archives 

 To restore your domain (Web site): 

1. Go to Home > Backup Manager. 

2. Click the backup file name you need. 

3. Specify the following settings: 

 Types of data to be restored. 

 Suspend domain (Web site) until restoration task is completed. Select this if you want 
to avoid possible conflicts that may occur when users modify site content or 
settings while they are being restored. 

 Send an e-mail notice when restoration task is completed. Type your e-mail address if 
you want the control panel to notify you when restoring is completed. 

 Conflicts resolution policy. Specify what to do if any conflicts occur during 
restoration. 

4. Click Restore. 

In case if any errors or conflicts occur during restoration of data, the wizard will 
prompt you to select an appropriate resolution. Follow the instructions provided on 
the screen to complete the wizard. 

Note: The Overwrite data restoring mode means that all objects will be restored 
from the backup files regardless of their current presence in the system. The 
Overwrite mode works as follows: 

 If an object or settings from the backup file are not present in the Parallels Plesk 
Panel, then they are created or set in the Parallels Plesk Panel. 

 If an object or settings from the backup file are present in the Parallels Plesk 
Panel, then the object or settings from the backup file replace the corresponding 
object or settings that are present in the Parallels Plesk Panel. 

 If an object or settings are present in the Parallels Plesk Panel, but are missing 
from the backup file, then the object or settings currently present in the Parallels 
Plesk Panel are not changed. 

 

Restoring Databases 

 If the database already exists and you only need to restore its contents: 

1. Go to Home > Databases > database name > Database Backup Repository, select 
the required backup file from the list and click Restore. 
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If you do not have the backup file on your server, you can upload the backup file to 
the server repository from your local machine. Refer to Uploading Database Backup 
Files To Server section for more information.  

2. Confirm the restoration by selecting the corresponding check box and 
click OK. 

If you are restoring MS SQL database, there is a possibility that some database 
users will be orphaned. In order to provide the ability to access and use the 
database for these users, you need to repair them. Refer to Recovering Orphaned 
Database Users section for more information. 

 If the database does not exist and you need to recreate it from scratch: 

1. Go to Home > Databases and click Add New Database. 

2. Specify the database name, type and server for the database you are 
restoring. 

Note. You can specify a new database name, but you must choose the correct 
database type: for example, if you are trying to restore a MySQL database, choose 
MySQL database type. 

3. Select the Restore database from backup file check box. 

4. Specify the location of the database backup file. You can upload a 
backup file from your local machine or specify a file located on the 
server. 

5. Provide the default username and password for the restored database. 

6. Click OK. 

If you are restoring MS SQL database, there is a possibility that some database 
users will be orphaned. In order to provide the ability to access and use the 
database for these users, you need to repair them. Refer to Recovering Orphaned 
Database Users section for more information. 

 

Recovering Orphaned Database Users 

If you are restoring an MS SQL database, there is a possibility that some database 
users will be orphaned. In order to provide the ability to access and use the database 
for these users, you need to repair them.  

 To check if a database has orphaned users: 

1. Go to Home > Databases > database name. 

2. If you see a warning saying that there are several orphaned users that 
should be repaired in order to function properly, you have orphaned 
users who need to be repaired. 
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 To repair orphaned users: 

1. Go to Home > Databases > database name and click the Repair button 
corresponding to the orphaned user you want to repair. 

2. Provide a password for this user and click Repair. 

If a user is supposed to be a system user without a password, run repair with empty 
password field. 

3. Repeat steps 1-2 as necessary to repair all orphaned users. 

 
 

Maintaining Your Backup Files Repository 

This section provides instructions on: 

 Uploading backup files stored on another computer. 

 Downloading backup files to another computer. 

 Removing redundant backup files from the backup repository. 
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Uploading Backup Files to Server 

 To upload a backup file to the control panel's backup repository: 

1. Go to Home > Backup Manager. 

2. Click Upload Files to Server Repository. 

3. Click Browse and select the required backup file. 

4. Click OK. 

The backup file will be uploaded to the backup repository. 
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Downloading Backup Files from Server 

 To download a backup file from the control panel's backup repository: 

1. Go to Home > Backup Manager. 

2. Click an icon  corresponding to the backup file you wish to download. 

3. Select the location where you wish to save the backup file and click 
Save. 

The backup file will be downloaded from the backup repository. 

Removing Backup Files from Server 

 To remove a backup file from the control panel's backup repository: 

1. Go to Home > Backup Manager. 

2. Select a check box corresponding to the backup file you wish to 
remove. 

3. Click Remove.  

4. Confirm removal and click OK. 

 

Maintaining Database Backup Files 
Repository (Windows Hosting) 

Your database backup files are stored in your own database backup repository, 
accessible by going to Home > Backup Manager > Database Backup Repository. Each 
database has its own backup files repository. To see backup files for a specific 
database, select the required database from the Database menu. By default, the 
database backup repository shows backup files for all databases on a domain. 

In the database backup repository you can: 

 Upload database backup files stored on another computer 

 Download database backup files to another computer 

 Remove redundant database backup files from database backup repository 
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Uploading Database Backup Files To Server 

 To upload a backup file to backup repository: 

1. Go to Home > Backup Manager > Database Backup Repository and click Upload 
Backup File. 

2. Select the database in which repository you want to upload the backup 
file to in the Database name menu.  

3. Click Browse... and select the required backup file. 

4. Leave the Restore database backup immediately upon uploading check box 
selected if you want the database contents to be restored immediately 
after the backup file is uploaded. 

5. Click OK. 

The database backup file will be uploaded to the backup repository of the specified 
database. 

Downloading Database Backup Files From Server 

 To download a backup file from backup repository: 

1. Go to Domains > domain name > Backup > Database Backup Repository. 

2. Select the database which backup files you want to browse in the 
Database menu. Leave All domain databases selected if you want to browse 
backup files of all databases on a domain. 

3. Click an icon  corresponding to the database backup file you want to 
download 

4. Select the location where you want to save the backup file and click 
Save. 

The backup file will be downloaded from the backup repository. 

Removing Database Backup Files From Server 

 To download a backup file from backup repository: 

1. Go to Home > Backup Manager > Database Backup Repository. 

2. Select the database which backup files you want to browse in the 
Database menu. Leave All domain databases selected if you want to browse 
backup files of all databases on a domain. 
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3. Select a check box corresponding to the database backup file you wish 

to remove. Click  Remove, confirm removal and click OK. 

 

 



 

  
 

If you need to run scripts on your site at specific time, use the task scheduler on your 
provider's server to make the system automatically run the scripts for you. 

In this chapter: 

Scheduling a Task (Linux Hosting) .................................................................... 149 
Scheduling a Task (Windows Hosting) .............................................................. 150 
Suspending and Resuming Execution of Tasks ................................................. 151 
Canceling a Task .............................................................................................. 151 
 

Scheduling a Task (Linux Hosting) 

 To schedule a task: 

1. On your Home page, click Scheduled Tasks. 

2. Select the system user account on whose behalf the task will be 
executed. 

3. Click Schedule New Task. 

4. Specify when to run your command. 

 Minute - enter the value from 0 to 59 

 Hour - enter the value from 0 to 23 

 Day of the Month - enter the value from 1 to 31 

 Month - enter the value from 1 to 12, or select the month from a drop-down box 

 Day of the Week - enter the value from 0 to 6 (0 for Sunday), or select the day of 
the week from a drop-down box 

You can schedule the time using the UNIX crontab entry format. In this format, you 
can 

 enter several values separated by commas. Two numbers separated by a 
hyphen mean an inclusive range. For example, to run a task on the 4th, 5th, 6th, 
and 20th of a month, type 4-6,20. 

 insert an asterisk to specify all values allowed for this field. For example, to run 
a task daily, type * in the Day of the Month text box. 

To schedule the task to run every Nth period, enter the combination */N, where N is 
the legal value for this field (minute, hour, day, month). For example, */15 in the 
Minute field schedules the task to start every 15 minutes.  
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You can type the contracted names of months and days of the week, which are the 
first three letters: Aug, Jul, Mon, Sat, etc. However, the contracted names cannot 
be separated with commas or used together with numbers. 

5. Specify which command to run. Type it into the Command input box. 

For example, if you want to run the backup creation task at the specified time and 
have the backup file sent to your e-mail, you need to specify the following command 
in the Command input box: 

/usr/local/psa/admin/sbin/backupmng 

6. Click OK. 

 

Scheduling a Task (Windows Hosting) 

 To schedule a task for a domain: 

1. Go to Home > Scheduled Tasks > Schedule New Task. 

2. Input a name for your task in the Description field. 

3. In Scheduler notification, specify whether the scheduler should notify you 
when it runs this task. The following options are available: 

 Do not send - do not notify you. 

 Send to the default e-mail - send the notification to your default e-mail address. 

 Send to the e-mail I specify - send the notification to the e-mail specified in the 
corresponding field. After selecting this option, you need to input the required e-
mail in the field on the right. 

4. Specify which command to run. Type it into the Path to executable file input 
box. If you need to run the command with certain options, type them in 
the Arguments field. 

 For example, if you want to run the statistics calculation task to count disc space 
and see more detailed information for the example.com and example.net 
domains, you need to specify the following path in the Path to executable file input 
box: 

C:\Program Files\Parallels\Plesk\admin\bin\statistics.exe 

and the following options in the Arguments field: 

--disk-usage --process-domains=example.com, example.net –

verbose 

 If you want to run your own php script using the task scheduler, you need to 
specify the following path in the Path to executable file input box: 

C:\Program Files 

(x86)\Parallels\Plesk\Additional\PleskPHP5\php.exe 

and specify the script location in the Arguments field: 
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C:\Inetpub\vhosts\mydomain.tld\httpdocs\myscript.php 

5. Select the appropriate priority in the Task priority field. Task priority can 
be set to Low, Normal or High. 

6. Specify when to run your command by selecting the appropriate check 
boxes in the Hours, Days of Month, Months or Days of Week fields. 

7. Click OK to schedule the task or click Run Now to schedule the task and 
immediately run it. 

 

Suspending and Resuming Execution of 
Tasks 

 To temporarily suspend execution of scheduled task: 

1. On your Home page, click Scheduled Tasks. 

2. Select the system user account on whose behalf the task is executed. 

3. Locate the task that you want to suspend and click the command name. 

4. Clear the Switched on check box and click OK. 

 To resume execution of scheduled task: 

1. On your Home page, click Scheduled Tasks. 

2. Select the system user account on whose behalf the task is executed. 

3. Locate the task whose execution you want to resume and click the 
command name. 

4. Select the Switched on check box and click OK. 

 

Canceling a Task 

 To cancel a task: 

1. On your Home page, click Scheduled Tasks.  

2. Select the system user account on whose behalf the task is executed. 

3. Select a check box to the left of the task that you want to cancel and 
click Remove. Confirm removal and click OK. 
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Monitoring Connections to FTP Service 

Your Parallels Plesk Panel can show active FTP sessions only when any of the 
following FTP server programs is installed on the hosting server: 

 Microsoft FTP 7.0 (Windows hosting) 

 Gene6 FTP Server (Windows hosting) 

 Serv-U FTP Server (Windows hosting) 

 ProFTPd (Linux/UNIX hosting) 

 To find out who is connected to your server via FTP, in what directories 
they currently are and what files they are uploading to or downloading 
from the server: 

1. Go to Home > Active Sessions. 

2. Click the FTP Sessions tab. All sessions including yours will be presented 
and the following details will be displayed: 

 Type. The type of user who established the session:  

 for users not registered with the control panel. 

 for anonymous FTP users. 

 for domain or web site administrators. 

 for subdomain administrators. 

 for web users (owners of personal web pages without individual domain 
names). 

 Status. The current status of FTP connection. 

 FTP user login. The login name used for access to FTP account. 

 Domain name. The domain the FTP user is currently connected to. 
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 Current location. The directory the FTP user is currently at. 

 File name. The file name being operated on. 

 Speed. Transfer speed in kilobytes. 

 Progress, %. The file transfer operation progress in percentage. 

 IP address. The IP address from which the FTP account is accessed. 

 Logon time. The time lapsed since the moment user logged in. 

 Idle time. The time that user was not doing anything while being connected to the 
server through FTP. 

3. To refresh the list of FTP sessions, click Refresh. 

4. To end a session, select the respective check box and click Remove. 

 
 

Monitoring Connections to Control Panel 

 To find out who of your customers is logged in to the control panel at the 
moment: 

1. Go to Home > Active Sessions. All sessions including yours will be 
presented and the following details will be displayed: 

 Type. A type of control panel user who established the session:  

 for domain or Web site owner. 

 for mailbox owner. 

 Login. The login name the user is logged in as. 

 IP address. The IP address from which the control panel is accessed. 

 Logon time. The date and time when the user logged in to the control panel. 

 Idle time. The time that user was not doing anything in the control panel while 
being logged in. 

2. To refresh the list of user sessions, click Refresh. 

3. To end a user session, select the respective check box and click 
Remove, then confirm removal and click OK. 

 

 



 

  
 

he remote desktop (RDP) access feature allows you to remotely login to the Parallels 
Plesk Panel server and interact with it via standard Microsoft Windows desktop 
interface. 

 To access the server via Remote Desktop interface: 

1. Go to Home > Remote Desktop. 

2. Set up screen resolution for the session in the  Screen resolution for terminal 
session menu. 

Note: Higher resolutions are more taxing for your connection, decreasing the 
interaction speed and spending more bandwidth. 

3. Choose the connection method according to your browser: 

 Microsoft RDP ActiveX - recommended to use with Internet Explorer browser, 
since it may not work with other browsers. When you use this method for the 
first time, your browser will automatically install the required ActiveX component, 
if Internet Explorer security settings permit this. If your browser displays security 
alerts, try to temporarily lower security measures in the browser options. 

 properoJavaRDP - recommended to use with Netscape, Mozilla, or Firefox 
browsers, since it may not work with Internet Explorer. Only 8.0 and higher 
versions of Opera are supported. This component requires Java Runtime 
Environment (JRE) to be installed on your system. If you do not have JRE, you 
can download it from  http://java.sun.com/j2se/1.5.0/download.jsp (version 1.4 
and higher) and install it before using the remote desktop feature.  

Note: You don't need to install JDK (Java Development Kit) in order for the 

RDP feature to work. 

If you use Internet Explorer or Mozilla, you should open the Terminal Services 
Configuration console in the Microsoft Windows (Start > Administrative Tasks), and 
set the Licensing option to Per user on the Server Settings screen. 

4. Click OK. A new window will open with an area where your interaction 
with the server's desktop will take place. 

5. Log in to the system. By default, Parallels Plesk Panel uses the 
domain's FTP/Microsoft FrontPage login. You can supply any valid login 
and password.  

6. After logging in to the system you can start working with it as with 
regular Windows desktop. 
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To finish your Remote Desktop session: 

 Close the browser window with the remote desktop session. This way, the session 
you had will be detached from your desktop, but it will keep running on the server, 
so when you log in there next time, you will see the remote desktop in the state you 
left it, 

or 

 Select Start > Log off if you want to quit the session permanently (all running 
sessions consume the server's resources). 

 

 



 

  
 

If your service provider offers a Help Desk solution integrated with the control panel, 
then you can use it to report your problems to your provider‘s technical support staff. 

Note: If there is no Help Desk link in the navigation pane of your Panel, then it means 
that Help Desk is not available. In such a case, you should use other means to contact 
your hosting service provider when you need assistance. 

In this chapter: 

Submitting a Problem Report to Your Service Provider ..................................... 156 
Commenting and Closing Your Trouble Ticket .................................................. 157 
 
 

Submitting a Problem Report to Your 
Service Provider 

 To submit a new problem report to your service provider: 

1. Go to Help Desk > Add New Ticket. 

Note: If there is no Help Desk link in the navigation pane of your Panel, then it 
means that Help Desk is not available. In such a case, you should use other means 
to contact your hosting service provider when you need assistance. 

2. Type the ticket subject, select the category the issue is related to, and 
type in the problem description. 

3. Click OK.  

The ticket is now submitted to the system and sent to your provider. You will be notified 
by e-mail when the issue is resolved. 
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Commenting and Closing Your Trouble 
Ticket 

 To post a new comment or to close a ticket: 

1. Click the Help Desk shortcut in the navigation pane. 

2. Locate the ticket you need and click its subject or identification number. 

3. To close, reopen or post a comment to the ticket, select the operation 
you would like to perform from the Ticket Event drop-down box, and type 
a new comment into the New Comment input field if required. 

4. Click OK to submit. 
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