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Welcome to Oloneo HDRengine. 

  

Additional Resources 

Along with this user manual, there is a variety of other resources you can use to find out more about 

Oloneo HDRengine. 

  

Oloneo Website 

For general information, updates and technical support, as well as the latest news on Oloneo 

HDRengine, go to: 

 http://www.oloneo.com 

  

Inside the application 

Video tutorials can be found in the Help Workspace. 

  

Flickr forum 

The official forum for discussing about Oloneo HDRengine is hosted on Flickr. The forum is monitored by 

Oloneo so this is the place to easily interact with the development team. Visit: 

 http://www.flickr.com/groups/oloneohdrenginetalk/ 

  

http://www.oloneo.com/
http://www.flickr.com/groups/oloneohdrenginetalk/
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Overview: Main Features 

  

Introduction 

HDRengine simplifies the process of creating and editing high-quality HDR images by offering an easy-to-

use, intuitive workflow along with a full range of real-time tone mapping tools and options. Whether 

using multiple bracketed exposures or a single photo, HDRengine allows you to easily recover lost details 

in overexposed areas of a photo, restore low-light areas in underexposed photos, or create infinite 

variations of an image, from the most realistic look to the utmost creative tone-mapping style, without 

compromising details and color appearance. 

  

Accessible and fast 

Presets and automated tools: be productive instantly 

Beginners will feel comfortable instantly thanks to a wide range of presets and HDR styles that can be 

previewed and applied in real-time. HDRengine also features many automated tools such as Auto Tone 

Mapper, auto contrast or auto alignment to rush the whole HDR process. 

  

Blazing performance: revolutionary real-time HDR for a unique creative experience 

HDRengine features the fastest HDR engines available today, allowing full real-time tone mapping and 

HDR manipulations, whether working with multiple exposures or a single photo. Real-time HDR means 

more time being creative and less time waiting for an image to refresh or a tool to respond. 

  

Single image HDR: make your best shots even better 

While HDRengine makes the tone mapping of bracketed exposures a very simple task, photographers 

can also dramatically enhance an existing single view by using a large selection of HDR effects along with 

highlights, shadows, brightness, contrast, saturation and even white balance controls. 

  

Intuitive and responsive: easy to learn and master 

HDRengine is an intuitive HDR application, easy to learn and master: the application’s responsive, 

elegant interface offers a well-organized and efficient workflow so each step of the HDR process is 

extremely easy to understand. Other notable features include instant raw previews and image 

thumbnails, full, real-time edition history with animated replay and help videos directly accessible from 

within the application. 
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Accurate and Pro 

Best imaging technologies: no compromise on quality and precision 

While aimed at beginners and amateurs, HDRengine share the same high-end image editing 

technologies and color model used in Oloneo PhotoEngine, the company’s flagship application for 

professional HDR and image processing. This full real-time, 32-bit floating-point per channel (96-bit per 

pixel), ultra-wide gamut, full resolution and non-destructive image-editing engine is combined with 

Oloneo’s unique color model to guarantee photographers against any loss of image data and quality 

during the HDR process. 

  

State-of-the-art HDR: make an impact with professional looking images 

HDRengine offers the best possible tools to create spectacular, professional quality HDR images: three 

tone mapping engines, auto-exposure correction with fine-tuning, auto-contrast, ghost removal tools, 

auto-align, auto-orientation, and more. 

  

Full raw and image file support 

HDRengine handles over 380 different RAW photo formats, with thumbnail and preservation of key EXIF 

metadata, as well as the popular JPEG and TIFF file formats (export and import). 
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Overview: the User Interface 

  

Introduction 

HDRengine uses a tabbed interface to allow you to focus on the task at hand. There are three main tasks 

grouped in three Workspaces: 

 Browsing files and creating projects in the Browse Workspace 
 Editing an image in the Edit Workspace 
 Getting help in the Help Workspace  

The Browse Workspace 

This is where HDRengine starts. Use the Browse Workspace to: 

 Display and browse your photos 
 Select photos 
 Create an HDR ToneMap project 
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The Edit Workspace 

HDRengine switches to the Edit Workspace after loading or creating a new project. Use the Edit 

Workspace to: 

 Edit your photos 
 Save the current project 
 Export the edited photo 
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The Help Workspace 

The Help Workspace is where you get help on Oloneo HDRengine. Use the Edit Workspace to: 

 Watch tutorial videos 
 Read the user manual 
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Managing the Workspaces 

HDRengine automatically switches from workspace to workspace when needed. You can also select 

which Workspace is displayed at any time. 

  

Selecting the Workspace to be displayed: 

 Click on the Browse, Edit or Help buttons located in the top menu bar 
 Or, select Browse, Edit or Help in the Tools menu 
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The Browse Workspace 

  

Overview 

The Browse Workspace is where you display your photos and create new projects. 

  

There are five main areas in the Browse Workspace: 

 1: Browsing toolbar where you select the directory to be displayed 
 2: Photo thumbnails of the currently displayed directory 
 3: Image Info panel showing the currently selected photo 
 4: Project creation panels 
 5: Recent Projects toolbar and panel 
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The Browsing toolbar 

The Browsing toolbar allows you to select the folder displayed by HDRengine and to set the size of 

thumbnails. 

There are multiple ways to select an image folder: 

 Direct selection using the system File or Folder Dialog 
 Selecting a recently browsed folder 
 Typing the path of the folder 

  

 

  

Selecting a folder: 

 Click on the “…” button 
 Using the system File Dialog navigate to a folder containing image files 
 Select a file then click the Open button 
 HDRengine starts displaying the thumbnails 

  

 

  

Selecting a folder using the menu: 

 Click on the Down Arrow button 
 Click on Browse (Using File Dialog) ... 
 Or, click on Browse (Using Folder Dialog) ... 
 Using the File or Folder Dialog, navigate to your image folder 
 Close the dialog 
 HDRengine starts displaying the thumbnails 
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Selecting a recent folder using the menu: 

 Click on the Down Arrow button 
 Select one of the listed folders 
 HDRengine starts displaying the thumbnails 

  

 

  

Editing the folder path: 

 Click in the address bar 
 Type or cut and paste the path to your folder 
 Press the Return or Enter key to validate 
 HDRengine starts displaying the thumbnails 

  

 

  

Setting the thumbnail size: 

 Click and drag the slider located at the right of the Browsing toolbar 

  

 

  

The Thumbnail list 

After selecting a folder, HDRengine displays the photos and project files contained in the folder. There 

are two file categories: 

 HDRengine Project files, displayed on a blue background 
 Image files, displayed on a gray background with the file extension displayed at the top left 

corner 
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Opening a project file: 

 Double click on the Project file thumbnail 
 HDRengine switches to the Edit Workspace and load the project 

  

Opening a Single JPEG, TIFF or Raw file: 

 Double click on the file thumbnail 
 HDRengine switches to the Edit Workspace and load the image 

  

Selecting several image files: 

 Scroll the thumbnail list until you see the set of photos you want to use 
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 Click on the first photo in the set 
 Shift-Click on the last photo in the set 

Or: 

 Scroll the thumbnail list until you see the set of photos you want to use 
 Control-Click on each photo 

  

A green frame is displayed around the selected photos. You can create a new project after selecting the 

images. Read the following chapters to learn how to create an HDR ToneMap project from the selected 

images. 

  

  

The Image Info panel 

The Image Info panel displays key Exif data of the selected photo. 
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The project creation panels 

Several panels located at the right of the screen allow you to create new HDRengine projects. Read the 

following chapter to learn how to create an HDR ToneMap project. 

  

 

  

The Recent Projects panel 

All the projects that you create or edit are automatically added to the Recent Projects panel located at 

the bottom of the screen. This panel allows you to quickly open and edit a recent project without having 

to locate the folder where the project file is stored. 
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Opening a recent project file: 

 Double click on a project thumbnail located in the Recent Projects panel 
 HDRengine switches to the Edit Workspace and load the project 

  

Setting the number of displayed files: 

 Click on the menu located at the top left of the Recent Projects panel 
 Select the number of files to be displayed 
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The Edit Workspace 

  

Overview 

The Edit Workspace is where you edit your photos and projects. 

  

There are five main areas in the Browse Workspace: 

 1: Edited image 
 2: Image Info panel 
 3: Image toolbar 
 4: Image setting panels 
 5: Timeline panel 
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The edited image 

The displayed image is not just a preview. This is the final image with all the settings 

applied.  HDRengine has the unique capability of displaying in real time all your changes including Tone 

Mapping. 

  

Seeing the image at full resolution: 

 Click anywhere in the image 
 Click again to zoom back 

  

Panning the image at full resolution: 

 Click anywhere in the image to zoom 
 Click and drag to pan the image 

  

The Info panel 

The Info panel displays the image histogram and the RGB values of the pixel currently under the mouse 

pointer. The histogram is updated in real time and is always up to date. 
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The Image toolbar 

The Image toolbar is located at the top of the image. It allows you to zoom, rotate, flip the image and set 

the white balance. 

  

 

  

Seeing the image at full resolution: 

 Click on the button located at the left of the Image toolbar 
 Click again to zoom back 

  

 

  

Rotating the image: 

 Click on the second or third button located in the Image toolbar 

  

 

  

Flipping the image: 

 Click on the fourth or fifth button located in the Image toolbar 
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Using the white balance tool: 

 Click on the Eye Dropper button located in the Image toolbar 
 Click anywhere in the picture to set the neutral point. 
 When done, click again on the Eye Dropper button to turn it off 

  

 

  

The image setting panels 

The panels located at the right allow you to edit the image settings. The available settings depend on the 

type of project you are working on. Read the following chapters to learn how to edit an HDR ToneMap 

project. 
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The Timeline panel 

Everything you do is automatically recorded in the Timeline panel located at the left of the screen. You 

can click on a Timeline level to go back in time and see the image at a previous step of the edition 

process. To learn more about the timeline read: HDR ToneMap: the timeline. 
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The Help Workspace 

  

Use the Help Workspace to learn how to use Oloneo HDRengine. 

  

 

  

Watching a video tutorial: 

 Click on one of the links located in the Video Tutorials panel 
 HDRengine opens a new web page in your default web browser and displays the video 

  

Reading the user manual in a web browser: 

 Click on the Open Page in Browser button located at the top 
 HDRengine opens a new web page in your default web browser 
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User Interface Main Controls 

  

Overview 

HDRengine uses several User Interface Controls that are important to master. These main controls 

appear in many places in the user interface. The main controls are: 

 Setting panels 
 Sliders 
 Color Wheels 

  

The Setting Panel 

The Setting Panel is a box that groups related settings. Panels have three main areas: 

 1: Title bar 
 2: Video Help button 
 3: Contents box 

  

You can hide and reveal the contents of a Setting Panel. 
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Hiding the contents: 

 Double click on the Title Bar located at the top of the panel 
 Double click again to unhide 

  

 

  

Getting help: 

 Click on the Video Help button located at the top right of the panel 
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The Slider 

The slider allows you to edit a setting using the mouse pointer, the keyboard or by entering a value. 

  

 

  

Dragging the cursor: 

 Click on the blue slider cursor 
 Drag to change the value 

  

 

  

Dragging the cursor with high accuracy: 

 Hold the Control-key 
 Click on the blue slider cursor 
 Drag to change the value 

  

Moving the cursor with the keyboard: 

 Click on the blue slider cursor 
 Press the keyboard arrows to move the cursor 

  

Entering a value: 

 Click in the numeric box located at the right of the slider 
 Type the value 
 Press the Enter, Return or Tab key to validate 
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Resetting a slider to default value: 

 Double-click the numeric box 
 The slider returns to its default value 
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The Color Wheel 

The slider allows you to quickly select the tint and saturation of a color. There are three parts in the 

color wheel: 

 1: Tint wheel 
 2: Saturation bar 
 3: Color preview 

  

 

  

Setting the color saturation: 

 Click on the cursor located in the horizontal bar 
 Drag to change the value 

  

 

  

Setting the tint: 

 Click on the cursor located in the circular part 
 Drag to change the value 
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File Drag and Drop 

  

Instead of using the Browse Workspace to select or open files, you can directly drag and drop images 

from the Windows Explorer to HDRengine. 

  

Drag and Drop images to the Image Selection panel: 

 Locate your files using the Windows Explorer 
 Select the images, start drag 
 Drop over the Image Selection Panel in the Browse Workspace 

  

You can drag and drop JPEG, TIFF or Raw photos to the Image Selection Panel. 
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Drag and Drop images to the Browse Workspace: 

 Locate your file using the Windows Explorer 
 Select one image or project file, start drag 
 Drop over Edit Workspace 

  

You can drag and drop JPEG, TIFF, Raw photos and project files to the Edit Workspace. 
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HDR ToneMap: Creating a Project 

  

Overview 

An HDR ToneMap project requires two or more photos. For better results the photos must share the 

same aperture and same ISO. Each of the photos should show the same scene taken at different shutter 

speeds.  

  

The easiest way to achieve that is to set your camera in Aperture Priority mode (Av or A mode) and 

enable the bracketing feature. The three or more photos should cover the entire dynamic range of the 

photographed scene. In other words: 

 The photo with the shortest shutter speed should not contain overexposed highlights 
 The photo with the longest shutter speed should not contain underexposed shadows 

  

A good starting point is to take three photos spaced of 2 EV (Exposure Value). For instance: 

 Photo 1: -2EV, 1/1000s 
 Photo 2:   0EV, 1/250s 
 Photo 3: +2EV, 1/60s 

  

Scenes with a very high dynamic range may require more than three photos.  

  

For high quality results, it is recommended to reduce the Exposure Value and increase the number of 

photos. For instance: 

 Photo 1: -2EV, 1/1000s 
 Photo 2: -1EV, 1/500s 
 Photo 3:   0EV, 1/250s 
 Photo 4: +1EV, 1/125s 
 Photo 5: +2EV, 1/60s 
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Creating the project is done in four steps: 

 Step 1: locating the folder containing the photos 
 Step 2: selecting a set of bracketed photos 
 Step 3: adding the set to the Project Image Selection panel 
 Step 4: creating the project 
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Step 1, locating the photos 

In order to create a new HDR ToneMap project, you have to first display the photos needed for the 

project in the Browse Workspace. 

  

 

Selecting a folder and displaying the thumbnails: 

 Return in the Browse Workspace 
 Click on the “...” button located in the top Browsing toolbar 
 Using the File Dialog, navigate to the folder containing your photos 
 Click on the Open button 

  

The Browse Workspace now displays the photos contained in the folder you just selected. 
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Step 2, selecting the photos 

 

  

Selecting photos: 

 Scroll the thumbnail list until you see the set of photos you want to use 
 Click on the first photo in the set 
 Shift-Click on the last photo in the set 

Or: 

 Scroll the thumbnail list until you see the set of photos you want to use 
 Control-Click on each photo 

  

A green frame is displayed around the selected photos. 
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Step 3, adding the photos to the project selection panel 

Add the photos selected at the previous step to the Project Image Selection panel. 

Adding photos to the Project Image Selection panel: 

 Select the images as explained in step 2 above 
 Click on the Add button located at the bottom of the Project Image Selection panel 

  

 

  

If the panel already contains photos from a previous project, you have first to clear the Project Image 

Selection list. 

Removing all photos from the Project Image Selection panel: 

 Click the Clear button located at the bottom of the Project Image Selection panel 

Removing one photo from the Project Image Selection panel: 

 Click on one of the small thumbnails located in the Project Image Selection list 
 Click on the Remove button located at the bottom of panel 

  

You are now ready to create an HDR ToneMap project. 
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Step 4, creating the HDR ToneMap project 

At this point, HDRengine can create the HDR ToneMap Project. The HDR ToneMap panel should display: 

“Ready to create HDR ToneMap Project!” 

  

 

  

HDR ToneMap projects have two options: Auto Align and Ghost Removal. 

  

What is Auto Align? 

If you are not using a tripod the camera may move when bracketing. The Auto Align feature attempts to 

align the photos when assembling the images. 

  

When to use Auto Align? 

Use Auto Align only when taking photos handheld. Never use Auto Align when using a tripod. The 

additional processing always slightly degrades the resulting image. For high quality results, use a tripod 

and turn Auto Align off. 

  

What is Ghost Removal? 

The Ghost Removal feature attempts to detect and remove moving peoples and objects in a set of 

photos.  

  

When to use Ghost Removal? 

Use Ghost Removal only when photographing non static scenes such as: crowds, cars, trees in windy 

condition, waves, etc. Never use Ghost Removal for static scenes such as: architecture, real estate, 

interior design, etc. The additional processing always slightly degrades the resulting image. 

  

How to help the Ghost Removal feature? 

Ghost Removal is a very complex technology and may fail. For instance, it is not possible to remove 
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several moving objects when they overlap across several photos. The reason is that none of the photos 

contains the background. The best way to avoid issues is to increase the number of photos. Instead of 

taking just one set of bracketed photos, you can take two. Though the exposures remain the same for 

the two sets, the additional images give HDRengine more data to work with. 

  

What is the difference between Ghost Removal Method 1 and Method 2? 

The two methods use very different approaches to detect and remove moving objects. In most cases, 

Method 2 is superior to Method 1 especially with photos containing many moving objects. By default, it 

is recommended to use Method 2. If Method 2 fails, try Method 1. 

  

Enabling Auto Align: 

 Click on the Auto Align checkbox located in the HDR ToneMap panel 
 Click again on the checkbox to turn it off 

  

 

  

Enabling Ghost Removal: 

 Click on the Ghost Removal menu located in the HDR ToneMap panel 
 Select Method 1 or Method 2 
 Select No Ghost Removal to turn it off 
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After choosing the HDR ToneMap options, you are ready to create the project. 

  

Creating the HDR ToneMap project: 

 Click the Create HDR ToneMap Project button located at the bottom of the HDR ToneMap panel 

  

HDRengine automatically switches to the Edit Workspace and starts loading the photos. 

  

What to do when the HDR ToneMap panel displays an error message? 

When your photos do not contain Exif data or have missing Exif data, the HDR ToneMap Panel will 

display an information message such as: “Shutter speed values are required to build an HDR ToneMap 

Project”. 

  

If this happens you can enter missing data by hand. The Project Image Selection panel works like a small 

spreadsheet. You can click in any cells to enter a missing value. 

  

Manually setting missing data: 

 Click in the cell with the missing value in the Project Image Selection panel 
 Type the missing Shutter Speed, F-Number or ISO value 
 Press the Tab key to validate 
 Repeat until all missing values are entered 
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HDR ToneMap: Single Raw Processing 

  

Overview 

HDR ToneMap is also a powerful Raw processing tool. Tone mapping can greatly improve a single Raw 

photo. In addition to Raw files, HDR ToneMap can be created from a single TIFF or JPEG file. 

  

Single files supported by HDR ToneMap: 

 Raw Photo 
 8-bit or 16-bit TIFF image 
 JPEG image 

  

How to create an HDR ToneMap from a single file: 

 Step 1: locate the folder containing the photo 
 Step 2: double click the photo thumbnail 

  

Step 1, locating the photo 

In order to create a new HDR ToneMap project, you have to first display the folder containing the photo 

you want to process. 

  

 

Selecting a folder and displaying the thumbnails: 

 Return in the Browse Workspace 
 Click on the “...” button located in the top Browsing toolbar 
 Using the File Dialog, navigate to the folder containing your photos 
 Click on the Open button 

  

The Browse Workspace now displays the photos contained in the folder you just selected. 
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Step 2, creating the project 

Simply double-click on the photo thumbnail to create the project. 

Creating an HDR Project from a single file: 

 Scroll the thumbnail list until you see the photo you want to use 
 Double-click on the photo thumbnail 

  

HDRengine automatically switches to the Edit Workspace and starts loading the photo. Read the next 

chapter to learn how to edit an HDR ToneMap project. 

  

Using the file menu 

You can also create an HDR ToneMap project with the File menu. 

Opening a file with the File menu: 

 Press Ctrl-O or select Open... in the File menu 
 In the File Dialog, set the filter to the type of file you want to open: JPEG, TIFF, RAW or All 
 Using the File Dialog, locate the file  
 Click on the OK button 

  

 

  

HDRengine automatically switches to the Edit Workspace and starts loading the photo. Read the next 

chapter to learn how to edit an HDR ToneMap project. 
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HDR ToneMap: Editing a Project 

  

Overview 

To learn how to create an HDR ToneMap project read the previous chapter. After creating or loading a 

project, the image is displayed in the Edit Workspace with default settings. 

  

 

  

When editing an HDR ToneMap project the Edit Workspace contains three main areas: 

 1:  the Timeline and Presets panels on the left of the screen  
 2:  the edited image 
 3:  the Tone Mapping and image settings on the right 

To edit the image simply click and drag the various sliders located in the right panels. HDRengine 

automatically updates the image in real-time.  
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HDR ToneMap: Tone Mapping tools 

  

HDRengine offers three Tone Mapping tools: 

 Auto Tone Mapper 
 Local Tone Mapper 
 Global Tone Mapper 

  

What is the Auto Tone Mapper? 

The Auto Tone Mapper uses a single slider to control all the Tone Mapping effects. It uses sophisticated 

algorithms that control Tone Mapping, exposure, contrast, brightness and saturation parameters in a 

fully automated way. Except setting the overall strength of the effect, you have no additional controls.  

  

If you are new to HDR and Tone Mapping, it is probably where you want to start. If you are experienced, 

use the Local Tone Mapper tool which offers more detailed controls.  

  

What is the Local Tone Mapper? 

The Local Tone Mapper is a default Tone Mapping tool. It offers a right balance between control and 

complexity. 

  

What is the Global Tone Mapper? 

The Global Tone Mapper offers an entirely different approach to Tone Mapping. Use it for medium 

dynamic range images and when you are looking for natural results. Images produced with the Global 

Tone Mapper tend to be soft with low contrast. 

  

What is the best tool to use? 

All of them! HDRengine always work in real time. You can switch instantly from one tool to the other. 

Whether an expert user or not, try not to stick to a single workflow. Explore the possibilities: you will be 

pleased by what you discover! 
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Selecting the Tone Mapping tool: 

 Click on the Menu located at the top of the High Dynamic Tone Mapping panel 
 Select the tool you want to use 

  

 

  

HDRengine immediately updates the image and displays the options of the selected tool. 

  

Remark: 

You can entirely turn off the Tone Mapping module by selecting None. Use this option when you want to 

edit the image the traditional way using exposure, brightness and contrast while still benefiting from the 

high precision of the 96-bit per pixel rendering engine. 

  

  



Oloneo HDRengine 

 

44 

HDR ToneMap: Auto Tone Mapper 

  

Overview 

The Auto Tone Mapper works in an entirely automated way. Use it if you are new to HDR and Tone 

Mapping. With only one setting to play with, it is fun and easy to use. When you have gained more 

experience, you can switch to the Local Tone Mapper which gives more control. 

  

The Auto Tone Mapper settings are displayed in the High Dynamic Tone Mapping panel when Auto Tone 

Mapper is selected in the menu located at the top.  
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Using the Auto Tone Mapper 

The Auto Tone Mapper is easy to use. Simply drag the Strength slider and watch the image change in 

real time. 

  

Editing the Tone mapping setting: 

 Drag the Strength slider 

  

 

  

Strength value range: 

 0 to 100: low Tone Mapping effect, medium high light recovery, natural image 
 100 to 150: medium Tone Mapping effect, full highlight and shadow recovery, natural image 
 150 to 200: high Tone Mapping effect, full highlight and shadow recovery, detail increase 
 200 to 300: extreme Tone Mapping effect, unnatural image 
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HDR ToneMap: Local Tone Mapper 

  

Overview 

The Local Tone Mapper is the default Tone Mapping tool. It is selected by default when creating a new 

project. 

The Local Tone Mapper settings are displayed in the High Dynamic Tone Mapping panel when Local 

Tone Mapper is selected in the menu located at the top. The settings are grouped in three categories: 

 Tone Mapping settings 
 Exposure settings 
 Contrast settings 

  

 

  

Main Tone Mapping settings 

The main Tone Mapping settings are controlled by the TM Strength and Detail Strength sliders. 

  

Editing the Tone mapping settings: 

 Drag the TM Strength slider 
 Drag the Detail Strength slider 
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What is TM Strength? 

TM Strength stands for Tone Mapping Strength. It is the Tone Mapping master control. Increase the 

value to reduce global image contrast while keeping the detail contrast unchanged.  The higher the 

value the more you will recover burned highlights and underexposed shadows. 

  

TM Strength values: 

By default the value is 0 meaning no Tone Mapping. The image is displayed “as is”. For most images, use 

values from 0 to 65. In this range, Tone Mapping varies from low to fairly high while maintaining a 

natural image. For special effects, use values from 65 to 100. Around 85 the Tone Mapping becomes 

extreme with global contrast near to zero. High values usually require an increase in Detail Strength. 

Summary: 

 0: default value, no Tone Mapping 
 0 to 65: regular range, low to high Tone Mapping, natural rendering 
 65 to 100: high to extreme Tone Mapping, special effects 

  

TM Strength value can become negative?! 

Absolutely and it is a unique feature! For negative values, HDRengine switches to a special mode and 

applies an Anti-Tone Mapping to the image. This mode is usually needed for very peculiar applications 

such as artificially increasing the Dynamic Range of a low dynamic image or for special effects. 

  

Anti-Tone Mapping can bring interesting effects to black and white photos. With it, you can easily add a 

film noir effect to your black and white photos. 
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What is Detail Strength? 

Detail Strength controls the detail contrast (also called micro contrast). Increasing its value will increase 

details visibility.   

  

Detail Strength values: 

By default the value is 0 meaning that the image details are unchanged. For most images, leave the 

value to zero or slightly increase it up to 100. In this range, detail contrast varies from low to medium 

and maintains a natural image. For special effects, use values from 100 to 300. High values are useful to 

create busy images with a high level of detail (the “grunge effect”). 

  

Summary: 

 0: default value, image details are unchanged 
 0 to 100: regular range, low to medium details, natural rendering 
 100 to 300: medium to extreme details, special effects 

  

Detail Strength value can become negative?! 

Yes and it is again a unique feature! For negative values, HDRengine actually removes details from the 

image. At -100, all image details are removed. Use this special value range for impressionist effects, to 

simulate old photos, to create soft, ethereal black and white photos, etc. 
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Exposure settings 

Exposure settings are controlled by the Auto-Exposure checkbox and the Exposure and Fine Exposure 

sliders. 

  

Editing the Exposure settings: 

 Turn on or off Auto-Exposure by clicking the Auto-Exposure checkbox 
 Drag the Exposure slider 
 Drag the Fine Exposure slider 

  

 

  

What is Auto-Exposure? 

By default, HDRengine automatically computes the best possible exposure. The exposure is changed 

when you modify the TM Strength and Detail Strength values. In most cases, leave the Auto-Exposure 

enabled.  

  

Auto-Exposure may fail when working with photos incorrectly bracketed or with severely underexposed 

images. In that case, disable Auto-Exposure and set the exposure manually with the Exposure and Fine 

Exposure sliders. 

  

What is Exposure and Fine Exposure? 

The Exposure and Fine Exposure sliders allow you to correct the exposure that was automatically 

computed by HDRengine. For most images, the Exposure slider should remain unchanged unless you 

disable Auto-Exposure. Use the Fine Exposure to fine tune exposure after using TM Strength and Detail 

Strength. 
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Contrast settings 

Contrast settings are controlled by the Auto-Contrast checkbox and the Contrast slider. 

  

Editing the Contrast settings: 

 Turn on or off Auto-Contrast by clicking the Auto-Contrast checkbox 
 Drag the Contrast slider 

  

 

  

What is Auto-Contrast? 

By default, HDRengine automatically computes the best possible contrast. The contrast is changed when 

you modify the TM Strength and Detail Strength values. You should leave the Auto-Contrast enabled in 

most situations.  

  

Auto-Contrast may fail when working with photos incorrectly bracketed or with severely underexposed 

images. In that case, disable Auto-Contrast and set the contrast manually with the Contrast slider. 

  

What is Contrast? 

The Contrast slider allows you to correct the contrast that was automatically computed by HDRengine. 

Use the Contrast slider to fine tune contrast after using TM Strength and Detail Strength. 
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HDR ToneMap: Global Tone Mapper 

  

Overview 

The Global Tone Mapper offers an entirely different approach to Tone Mapping. Use it for medium 

dynamic range images and when you are looking for natural results. Images produced with the Global 

Tone Mapper tend be soft with low contrast. 

  

The Global Tone Mapper settings are displayed in the High Dynamic Tone Mapping panel when Global 

Tone Mapper is selected in the menu located at the top. The settings are: 

 Strength 
 Compression 

  

 

  

Working with the Global Tone Mapper 

The Global Tone Mapper works in two steps: 

 Highlight recovery with the Strength slider 
 Shadow recovery with the Compression slider 

  

Step 1: Highlight recovery 

Increase the Strength value to reveal details in the highlights. 

  

Step 2: Shadow recovery 

Increase the Compression slider to reveal details in the shadows. 
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Remark: 

The Global Tone Mapper works best with medium dynamic range photos. Use it when you want a soft 

and natural Tone Mapping effect. As the effect is much lighter than the other Tone Mapping tools, the 

image will tend to have a low contrast. Use the Low Dynamic Tone panel to modify Exposure, Brightness 

and Contrast. 

  

Editing the settings: 

 Drag the Strength slider 
 Drag the Compression slider 
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HDR ToneMap: the Natural HDR Mode 

  

Overview 

The Natural HDR Mode is the result of years of research in Tone Mapping, image processing, color 

theory and psychophysiology. This feature is unique to Oloneo HDRengine. Unlike other products, the 

Natural HDR Mode is not just based on mathematical algorithms. It is a mix of sophisticated algorithms 

and empirical corrections based on how humans perceive color, brightness and contrast. 

  

In order to get always the most natural results, the Natural HDR Mode is actually built-in HDRengine and 

always running.  The Natural HDR Mode checkbox allows you to turn the effect entirely on or partially 

off. 

  

Using the Natural HDR Mode 

  

Enabling or disabling the Natural HDR Mode: 

 Click on the Enable checkbox located in the Natural HDR Mode panel 

  

 

  

When to use the Natural HDR Mode? 

Most images can benefit from the Natural HDR Mode when you are looking for a natural result. 

  

Natural HDR Mode and Raw processing: 

The Natural HDR Mode combined with light Tone Mapping can have a dramatic effect on your Raw 

photos. Try it, you won’t be disappointed! 
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When not to use the Natural HDR Mode? 

Turn it off when you want to create images with very high contrast and saturation. 

  

When working with Raw photos of monochromatic scenes or with muted colors, the Natural HDR Mode 

may apply too strong a correction. 

  

How come the Natural HDR Mode has no effect on my photo? 

The effect is highly dependent on the photo and the settings you are using. HDRengine may find that the 

particular setting and photo you are using do not need a correction to look natural. Also, the effect can 

be quite subtle and imperceptible at first glance. The Natural HDR Mode is usually more obvious on 

photos with saturated colors and fairly high Tone Mapping settings. 
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HDR ToneMap: Basic Image Settings 

  

Low Dynamic Tone settings 

When you are done with Tone Mapping, you can start working on general image settings: Brightness, 

Contrast, Saturation and White Balance. 

  

Editing key image settings: 

 Scroll the panels located on the right of the screen to display the Low Dynamic Tone panel 
 Click and drag the Exposure, Brightness, Contrast and Saturation sliders. 
 For high precision edition, hold Control-Key while dragging a slider. 
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Editing white balance: 

 Scroll the panels located on the right of the screen to display the Low Dynamic Tone panel 
 Use the Temperature, Tint sliders, Color Wheel or the Illuminant local menu. 

  

 

Setting white balance with the Eye Dropper: 

 Click on the Eye Dropper icon located in the top tool bar 
 Click anywhere in the picture to set the neutral point. 
 When done, click again on the Eye Dropper icon to turn it off 
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HDR ToneMap: Presets 

  

HDRengine includes over 40 factory presets. Use this preset library to quickly modify all the settings of 

an image and apply special effects. The Preset panel is located at the bottom left corner of the screen. 

  

Using presets is also a good way to learn how to use HDRengine. Apply a preset and then look at the 

various image settings.  

  

 

  

The Preset panel allows you to: 

 Preview a preset 
 Apply a preset 
 Sort presets 
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Previewing a preset: 

 Move the mouse pointer without clicking over any preset located in the Preset panel 
 HDRengine immediately updates the image with the preset settings 
 Move the pointer away to restore the current settings 
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Applying a preset: 

 Click on a preset located in the Preset panel 

  

 

  

  

Sorting presets: 

 Click on the Category Menu located at the top of the Preset panel 
 Select a category 
 Select the All category to show all presets 
 Select the Favorite category to show your favorite presets 
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HDR ToneMap: the Timeline 

  

As with all HDRengine projects, everything you do is automatically recorded in the Timeline panel 

located at the left of the screen. You can click on a Timeline level to go back in time and see the image at 

a previous step of the edition process. 

  

 

  

The Timeline is saved in the HDRengine project files (.rcd). Your changes are never lost. By reloading the 

project file later on, you will recover all your edition history. 
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Selecting a previous level in the Timeline: 

 The latest change is displayed at the top of the Timeline list 
 The original image is displayed at the bottom of the list 
 Click anywhere in the list to restart from a previous step. All steps above the selected level will 

be deleted at the next change (in case of a mistake, this can be undone by pressing Control-Z) 
 To restart from scratch, select the first level at the bottom 

  

 

  

It is worth spending a bit of time mastering the Timeline! The Timeline can greatly increase your 

productivity later on. 

  

HDRengine also works as a regular application with undo/redo: 

 Press Control-Z or use the Edit > Undo menu to undo a change 
 Press Control-Y or use the Edit > Redo menu to redo 
 To undo several changes, press Control-Z several times 
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Comparing images with the Timeline: 

 Check the Interactive Preview checkbox located at the top of the Timeline panel 
 Move the mouse pointer, without clicking, over any Timeline levels 
 HDRengine immediately updates the image based on the level’s settings 
 By moving the mouse pointer up and down along the Timeline panel you can visually compare 

different image settings. 
 By moving the mouse pointer inside and outside of the Timeline panel you can visually compare 

the current settings with a previous one, including the original picture (last line at the bottom of 
the Timeline). 
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Adding a version: 

 Click on a level in the Timeline list 
 Click the Add Version button located at the top of the Timeline panel 

 
 

Re-playing the Timeline: 

 Click the Play! button located at the top of the Timeline panel 
 Press the Escape key to stop the animation. 

 

You have worked hard on that project! Enjoy watching all your changes in one short animation.  
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HDR ToneMap: Saving and Exporting 

  

If you plan to work again on the current project, it is critical to save the project as a HDRengine project 

file (.rcd file). If you do not plan to work again on the project, you can simply export the final image 

without saving the HDRengine project (not recommended). 

  

The HDRengine project file provides the following benefits: 

 Full edition history (Timeline) is saved and restored at next load 
 Nondestructive edition. The HDRengine project file contains a reference to your original photos: 

your original photos are never modified by the application 
 Project files are small and are saved instantaneously 

  

Saving the project: 

 Press Ctrl-S or select Save in the File menu 
 The current project file is overwritten with the current settings 
 When the project file is new, a file dialog will appear to allow you to name the project file 
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Renaming and saving the project: 

 Press Ctrl-Shift-S or select Save As... in the File menu 
 In the File Dialog, select: HDRengine file (*.rcd) 
 Enter the file name 
 Click the Save button 

 

In order to further edit the image in another tool, to publish it online or other tasks, you need to export 

it in a standard format.  

  

Exporting to TIFF or JPEG: 

 Press Ctrl-Shift-S or select Save As… in the File menu 
 In the File Dialog, select: TIFF (*.tif) or JPEG (*.jpg) 
 Enter the file name 
 Click the Save button 
 Select  the TIFF or JPEG settings 
 Click the OK button 
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Direct export to TIFF: 

 Press Ctrl-T or select Export > To Tiff... in the File menu 
 Enter the file name 
 Click the Save button 
 Select  the TIFF settings 
 Click the OK button 
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Direct export to JPEG: 

 Press Ctrl-J or select Export > To Jpeg... in the File menu 
 Enter the file name 
 Click the Save button 
 Select the JPEG settings 
 Click the OK button 

  

 

  

Exporting directly to an external editor: 

 Press Ctrl-E or select Export To My Tool... in the File menu 
 Enter the file name 
 Click the Save button 
 Select the save settings 
 Click the OK button 
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By default HDRengine exports to Adobe® Photoshop ®. You can select a different external editor by 

selecting External Editor Preferences... in the Edit menu. 

  

To learn more about export options, read: Image Export Options. 
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Export Options 

  

Overview 

When you are done with your image editing, it is time to export your work in a standard image file 

format. Exporting the image allows you to further edit the image in another tool, to publish it online or 

other tasks. 

  

HDRengine can export images in the JPEG and TIFF formats. 

  

Exporting to JPEG 

The JPEG should only be used when exporting an image for web publishing. Use the TIFF format if you 

plan to archive your image or edit it in another tool. 

  

Exporting to JPEG: 

 Press Ctrl-J or select Export > To Jpeg… in the File menu 
 Enter the file name 
 Click the Save button 
 Select the JPEG settings 
 Click the OK button 
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During the export process HDRengine displays the JPEG Options dialog. 

  

 

  

Selecting the Color Space: 

 Click the Color Space menu 
 Select the sRGB, Adobe RGB or ProPhoto RGB option 

  

As JPEG is an 8-bit file format, it is recommended to only use the sRGB or Adobe RGB color space. 

  

Selecting the Resolution: 

 Enter the resolution 
 Select the pixels/inch or pixels/cm unit 

  

The Resolution does not change the image pixel size (the width and height remains unchanged). The 

resolution sets the physical size of the printed image. 
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Selecting the Quality: 

 Click and drag the Quality slider 

  

The Quality defines the level of compression of the JPEG file. The lower the value, the lower the file size 

will be. It is recommended to use a value of 80 or higher for an adequate quality. 

  

Setting the Artist Info: 

 Check the Add Artist Info checkbox to add your name and copyright to the image file 
 Enter your name 
 Enter your copyright 

  

The copyright and artist name data are stored in the relevant image Exif fields. 

  

Exporting to TIFF 

The TIFF format is the recommended file format for exporting images from HDRengine. TIFF images are 

using a lossless compression method that entirely preserves the image quality. 

  

If you plan to edit the image in another tool, the recommended settings are: 

 Color space: ProPhoto RGB 
 Bit Depth: 16-bit 
 Compression: None or LZW (both methods are lossless) 

  

Exporting to TIFF: 

 Press Ctrl-T or select Export > To Tiff… in the File menu 
 Enter the file name 
 Click the Save button 
 Select  the TIFF settings 
 Click the OK button 
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During the export process HDRengine displays the TIFF Options dialog. 

  

 

  

Selecting the Color Space: 

 Click the Color Space menu 
 Select the sRGB, Adobe RGB or ProPhoto RGB option 
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Selecting the Bit Depth : 

 Click the Bit Depth menu. 
 Select the 16 bits/component or 8 bits/component for a depth of 16 or 8 bits per channel. 

  

Selecting the Resolution: 

 Enter the resolution 
 Select the pixels/inch or pixels/cm unit 

  

The Resolution does not change the image pixel size (the width and height remains unchanged). The 

resolution sets the physical size of the printed image. 

  

Selecting the Compression: 

 Click the Compression menu 
 Select the LZW or None option 

  

Setting the Artist Info: 

 Check the Add Artist Info checkbox to add your name and copyright to the image file 
 Enter your name 
 Enter your copyright 

  

The copyright and artist name data are stored in the relevant image Exif fields. 
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Color Management 

  

Overview 

Oloneo HDRengine is a fully color managed application. From input to output, HDRengine keeps track of 

the various color spaces used and automatically applies the required color transformations. The 

application also converts the displayed image using your display color profile. HDRengine is compatible 

with most ICC files created by display calibration devices. 

  

Display Preferences 

By default, HDRengine automatically locates and uses your display color profile. You can turn off this 

feature or choose a custom color profile. Unless you have specific reasons to do so, you should not 

modify the display color profile settings. 
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Showing the Display Color Profile Settings dialog: 

 Select Display Preferences... in the Edit menu 

  

Turning off display color management: 

 Open the Display Color Profile Settings dialog 
 Check the Use sRGB Color Space button 
 Click the OK button 

  

Using a custom display color profile: 

 Open the Display Color Profile Settings dialog 
 Check the Use Custom ICC Profile button 
 Click the Browse... button 
 Select an ICC file 
 Close the file dialog 
 Click the OK button 

  

Restoring the default display color management: 

 Open the Display Color Profile Settings dialog 
 Check the Use Monitor Color Profile button 
 Click the OK button 
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External Editor Preferences 

  

Oloneo HDRengine can export the edited image to an external image editing tool. By default HDRengine 

exports to Adobe® Photoshop®.  

  

 

  

Selecting an external editing tool: 

 Select External Editor Preferences... in the Edit menu 
 Click the Choose... button 
 Select an application (.exe) 
 Close the file dialog 
 Click the OK button 

  

Choosing the export file format: 

 Select External Editor Preferences... in the Edit menu 
 Click the File Type menu 
 Select TIFF or JPEG 
 Click the OK button 
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Legal Notices 

  

© Copyright Oloneo 2011. 

  

Oloneo, the Oloneo logo, Oloneo PhotoEngine, Oloneo HDRengine, HDR ReLight, HDR ToneMap, HDR 

DeNoise, Color Curve Equalizer and Natural HDR are either registered trademarks or trademarks of 

Oloneo SAS. 

  

Adobe, the Adobe logo, Lightroom and Photoshop are either registered trademarks or trademarks of 

Adobe Systems Incorporated in the United States and/or other countries.  

  

All other trademarks belong to their respective owners. 
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