
Fedora 13

User Guide
Using Fedora 13 for common desktop computing tasks

Fedora Documentation Project



User Guide

Fedora 13 User Guide
Using Fedora 13 for common desktop computing tasks
Edition 1.0

Author Fedora Documentation Project docs@lists.fedoraproject.org

Copyright © 2010 Red Hat, Inc. and others.

The text of and illustrations in this document are licensed by Red Hat under a Creative Commons
Attribution–Share Alike 3.0 Unported license ("CC-BY-SA"). An explanation of CC-BY-SA is available
at http://creativecommons.org/licenses/by-sa/3.0/. The original authors of this document, and Red Hat,
designate the Fedora Project as the "Attribution Party" for purposes of CC-BY-SA. In accordance with
CC-BY-SA, if you distribute this document or an adaptation of it, you must provide the URL for the
original version.

Red Hat, as the licensor of this document, waives the right to enforce, and agrees not to assert,
Section 4d of CC-BY-SA to the fullest extent permitted by applicable law.

Red Hat, Red Hat Enterprise Linux, the Shadowman logo, JBoss, MetaMatrix, Fedora, the Infinity
Logo, and RHCE are trademarks of Red Hat, Inc., registered in the United States and other countries.

For guidelines on the permitted uses of the Fedora trademarks, refer to https://fedoraproject.org/wiki/
Legal:Trademark_guidelines.

Linux® is the registered trademark of Linus Torvalds in the United States and other countries.

Java® is a registered trademark of Oracle and/or its affiliates.

XFS® is a trademark of Silicon Graphics International Corp. or its subsidiaries in the United States
and/or other countries.

All other trademarks are the property of their respective owners.

The Fedora User Guide is focused on the end-user looking to accomplish standard desktop computer
user tasks, such as browsing the web, reading and sending email, and doing office productivity work.

mailto:docs@lists.fedoraproject.org
http://creativecommons.org/licenses/by-sa/3.0/
https://fedoraproject.org/wiki/Legal:Trademark_guidelines
https://fedoraproject.org/wiki/Legal:Trademark_guidelines


iii

Preface                                                                                                                                      vii
1. Document Conventions ..................................................................................................  vii

1.1. Typographic Conventions ....................................................................................  vii
1.2. Pull-quote Conventions .......................................................................................  viii
1.3. Notes and Warnings ............................................................................................  ix

2. We Need Feedback! ....................................................................................................... ix

Introduction                                                                                                                                xi
1. Purpose and Audience ...................................................................................................  xi
2. About this document ....................................................................................................... xi

1. The Fedora desktops                                                                                                              1

2. Logging into the desktop                                                                                                        3
2.1. Logging in  ..................................................................................................................  3
2.2. Logging in: a technical explanation  ..............................................................................  4
2.3. I Cannot Login: help!  ................................................................................................... 4

3. Tour of the GNOME desktop                                                                                                   5
3.1. The GNOME Desktop  .................................................................................................  5

3.1.1. The Top Menu Panel  ........................................................................................  5
3.1.2. The desktop area  ...........................................................................................  10
3.1.3. The window list panel  .....................................................................................  11

4. Tour of the KDE desktop                                                                                                      13
4.1. The KDE desktop .......................................................................................................  13
4.2. The KDE desktop area ...............................................................................................  14
4.3. The KDE panel ..........................................................................................................  14

4.3.1. The Kickoff Application Launcher ......................................................................  15

5. Tour of the Xfce desktop                                                                                                      17
5.1. The Xfce 4 desktop ....................................................................................................  17

5.1.1. The Xfce 4 menu panel ...................................................................................  18
5.1.2. The Xfce 4 desktop area .................................................................................. 19

6. Media                                                                                                                                     21
6.1. ISO images ................................................................................................................  21
6.2. Writing CDs or DVDs .................................................................................................  21

6.2.1. Using CD/DVD Creator to burn media in GNOME ..............................................  22
6.2.2. Using K3b to burn media in KDE ...................................................................... 22
6.2.3. Using Brasero in GNOME ................................................................................  23

6.3. Making bootable USB media ....................................................................................... 23
6.3.1. USB image creation in Windows ....................................................................... 24
6.3.2. USB image creation in Fedora .........................................................................  24

7. Connecting to the Internet                                                                                                    27
7.1. The Network Manager Applet ...................................................................................... 27
7.2. The Network Manager window ....................................................................................  27
7.3. Wireless connections ..................................................................................................  28
7.4. Mobile Broadband ......................................................................................................  29

7.4.1. Create a Mobile Broadband network connection ................................................  29
7.4.2. Setup a Mobile Broadband connection ..............................................................  30

7.5. Wired connections ......................................................................................................  30
7.5.1. Wired Tab .......................................................................................................  30
7.5.2. 802.1x Tab ......................................................................................................  30



User Guide

iv

7.5.3. IPv4 Tab .........................................................................................................  30
7.6. VPN connections ........................................................................................................ 31
7.7. xDSL connections ......................................................................................................  31
7.8. Network Manager in a CLI ..........................................................................................  32

7.8.1. nmcli ...............................................................................................................  32
7.8.2. nm-tools ..........................................................................................................  32

8. Accessing the Web                                                                                                               35
8.1. Browsing web pages ..................................................................................................  35

8.1.1. Using Firefox ...................................................................................................  35
8.1.2. Using Konqueror .............................................................................................. 36

8.2. Transferring files ......................................................................................................... 37
8.2.1. Using FileZilla .................................................................................................. 37
8.2.2. FTP on the command line ................................................................................  38

9. Communications                                                                                                                   41
9.1. Evolution ....................................................................................................................  41

9.1.1. Configuring Evolution .......................................................................................  41
9.1.2. Using Evolution ...............................................................................................  42

9.2. Thunderbird ................................................................................................................ 42
9.2.1. Configuring Thunderbird ...................................................................................  42
9.2.2. Moving your Thunderbird profile data from Windows to Fedora ...........................  43
9.2.3. Using Thunderbird ...........................................................................................  45

9.3. Claws Mail .................................................................................................................  45
9.3.1. Configuring Claws Mail ....................................................................................  46
9.3.2. Using Claws Mail ............................................................................................. 46

9.4. Kmail .........................................................................................................................  47
9.4.1. Configuring Kmail ............................................................................................  47
9.4.2. Using Kmail ..................................................................................................... 47

9.5. Empathy ....................................................................................................................  47
9.5.1. Configuring Empathy ........................................................................................ 48
9.5.2. Using Empathy ................................................................................................  48

9.6. Pidgin ........................................................................................................................  48
9.6.1. Configuring Pidgin ...........................................................................................  49
9.6.2. Using Pidgin ....................................................................................................  49

9.7. Kopete .......................................................................................................................  50
9.7.1. Configuring Kopete ..........................................................................................  50

9.8. XChat ........................................................................................................................  50
9.8.1. Configuring XChat ...........................................................................................  50
9.8.2. Using XChat ....................................................................................................  51

9.9. Konversation ..............................................................................................................  51
9.9.1. Configuring Konversation .................................................................................  51
9.9.2. Using Konversation .......................................................................................... 51

9.10. ChatZilla ..................................................................................................................  52
9.10.1. Installing ChatZilla .......................................................................................... 52
9.10.2. Configuring ChatZilla ...................................................................................... 52
9.10.3. Using ChatZilla ..............................................................................................  52

10. Office Applications                                                                                                              55
10.1. Office Suites Overview .............................................................................................. 55
10.2. Word Processing ......................................................................................................  55

10.2.1. OpenOffice.org Writer ..................................................................................... 56
10.2.2. KWord ...........................................................................................................  56



v

10.2.3. Abiword .........................................................................................................  56
10.3. Spreadsheets ...........................................................................................................  57

10.3.1. OpenOffice.org Calc ....................................................................................... 57
10.3.2. KSpread ........................................................................................................  57
10.3.3. Gnumeric ......................................................................................................  58

10.4. Presentations ...........................................................................................................  58
10.4.1. OpenOffice.org Impress .................................................................................. 58
10.4.2. KPresenter ....................................................................................................  59

10.5. gLabels ....................................................................................................................  59

11. Financial software                                                                                                               61
11.1. GnuCash ..................................................................................................................  61

11.1.1. Configuring GnuCash .....................................................................................  61
11.1.2. Using GnuCash .............................................................................................  62
11.1.3. Setting up online banking ...............................................................................  62

11.2. KMyMoney ...............................................................................................................  63
11.2.1. Configuring KMyMoney ..................................................................................  63
11.2.2. Setting up online banking ...............................................................................  64

12. Playing multimedia                                                                                                              65
12.1. The Fedora Project's approach to multimedia support .................................................  65
12.2. Cheese Webcam Booth ............................................................................................  66

12.2.1. Using Cheese Webcam Booth ........................................................................  66
12.3. Rhythmbox Music Player ..........................................................................................  66

12.3.1. Using Rhythmbox Music Player ......................................................................  66
12.4. Audio CD Extractor (Sound Juicer) ............................................................................  67

12.4.1. Using Sound Juicer ........................................................................................ 67
12.5. Sound Recorder .......................................................................................................  68

12.5.1. Using Sound Recorder ...................................................................................  68
12.6. Totem Movie Player ..................................................................................................  68

12.6.1. Using Totem Movie Player .............................................................................. 68
12.7. GNOME multimedia applications ...............................................................................  69

12.7.1. CD/DVD Creator ............................................................................................  69
12.8. GNOME multimedia applications in the repository ....................................................... 70

12.8.1. Brasero .........................................................................................................  70
12.8.2. GNOMEBaker ................................................................................................ 70

12.9. KDE multimedia applications .....................................................................................  70
12.9.1. Amarok .........................................................................................................  70
12.9.2. Dragon Player ...............................................................................................  71
12.9.3. JuK ...............................................................................................................  71
12.9.4. Kaffeine .........................................................................................................  72
12.9.5. KMix .............................................................................................................  73
12.9.6. KsCD ............................................................................................................  73

12.10. Multimedia applications in the repository ..................................................................  74
12.10.1. K3b .............................................................................................................  74

12.11. MP3 players ...........................................................................................................  74
12.11.1. Grip .............................................................................................................  74
12.11.2. iPod connectivity ..........................................................................................  75

12.12. Further information .................................................................................................  75

13. Playing games                                                                                                                     77
13.1. Default GNOME games ............................................................................................  77
13.2. Default KDE games ..................................................................................................  77



User Guide

vi

14. Managing photos                                                                                                                 79
14.1. Connecting Your camera ...........................................................................................  79
14.2. Managing photos on the GNOME desktop .................................................................  79

14.2.1. Organizing and viewing photos .......................................................................  79
14.3. Managing photos on the KDE desktop .......................................................................  80

14.3.1. Importing photos with digiKam ........................................................................  80
14.3.2. Organising photos with digiKam ...................................................................... 81

15. Sharing your desktop                                                                                                          83
15.1. GNOME ...................................................................................................................  83
15.2. KDE .........................................................................................................................  84
15.3. Other desktops .........................................................................................................  84

16. Customizing the desktop                                                                                                    85
16.1. Changing the theme  ................................................................................................  85

16.1.1. Changing the theme in GNOME .....................................................................  85
16.1.2. Changing the theme in KDE ...........................................................................  85

16.2. Changing the background .........................................................................................  85
16.2.1. Changing the background in GNOME .............................................................  85
16.2.2. Changing the background in KDE ...................................................................  86

16.3. Customizing file browsing behavior  ........................................................................... 86
16.3.1. Customizing file browsing behavior in GNOME ................................................  86
16.3.2. Customizing file browsing behavior in KDE ......................................................  86

16.4. Customizing input methods .......................................................................................  86
16.5. Compiz-Fusion  ........................................................................................................  87
16.6. Widgets> .................................................................................................................. 87

16.6.1. GDesklets ...................................................................................................... 87
16.6.2. KDE plasmoids ..............................................................................................  88

17. Managing software                                                                                                              89
17.1. Using PackageKit .....................................................................................................  89

17.1.1. Installing software ..........................................................................................  89
17.1.2. Removing software ........................................................................................  89

17.2. Using the command line interface .............................................................................. 90
17.2.1. Installing software ..........................................................................................  90
17.2.2. Removing software ........................................................................................  91

17.3. Advanced Yum .........................................................................................................  91
17.3.1. Installing new software with Yum ....................................................................  93
17.3.2. Updating software with Yum ...........................................................................  94
17.3.3. Removing software with Yum .........................................................................  94

A. Contributors                                                                                                                          95

B. Revision History                                                                                                                   97



vii

Preface

1. Document Conventions
This manual uses several conventions to highlight certain words and phrases and draw attention to
specific pieces of information.

In PDF and paper editions, this manual uses typefaces drawn from the Liberation Fonts1 set. The
Liberation Fonts set is also used in HTML editions if the set is installed on your system. If not,
alternative but equivalent typefaces are displayed. Note: Red Hat Enterprise Linux 5 and later includes
the Liberation Fonts set by default.

1.1. Typographic Conventions
Four typographic conventions are used to call attention to specific words and phrases. These
conventions, and the circumstances they apply to, are as follows.

Mono-spaced Bold

Used to highlight system input, including shell commands, file names and paths. Also used to highlight
keycaps and key combinations. For example:

To see the contents of the file my_next_bestselling_novel in your current
working directory, enter the cat my_next_bestselling_novel command at the
shell prompt and press Enter to execute the command.

The above includes a file name, a shell command and a keycap, all presented in mono-spaced bold
and all distinguishable thanks to context.

Key combinations can be distinguished from keycaps by the hyphen connecting each part of a key
combination. For example:

Press Enter to execute the command.

Press Ctrl+Alt+F1 to switch to the first virtual terminal. Press Ctrl+Alt+F7 to
return to your X-Windows session.

The first paragraph highlights the particular keycap to press. The second highlights two key
combinations (each a set of three keycaps with each set pressed simultaneously).

If source code is discussed, class names, methods, functions, variable names and returned values
mentioned within a paragraph will be presented as above, in mono-spaced bold. For example:

File-related classes include filesystem for file systems, file for files, and dir for
directories. Each class has its own associated set of permissions.

Proportional Bold

This denotes words or phrases encountered on a system, including application names; dialog box text;
labeled buttons; check-box and radio button labels; menu titles and sub-menu titles. For example:

1 https://fedorahosted.org/liberation-fonts/

https://fedorahosted.org/liberation-fonts/
https://fedorahosted.org/liberation-fonts/
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Choose System → Preferences → Mouse from the main menu bar to launch Mouse
Preferences. In the Buttons tab, click the Left-handed mouse check box and click
Close to switch the primary mouse button from the left to the right (making the mouse
suitable for use in the left hand).

To insert a special character into a gedit file, choose Applications → Accessories
→ Character Map from the main menu bar. Next, choose Search → Find… from the
Character Map menu bar, type the name of the character in the Search field and click
Next. The character you sought will be highlighted in the Character Table. Double-
click this highlighted character to place it in the Text to copy field and then click the

Copy button. Now switch back to your document and choose Edit → Paste from the
gedit menu bar.

The above text includes application names; system-wide menu names and items; application-specific
menu names; and buttons and text found within a GUI interface, all presented in proportional bold and
all distinguishable by context.

Mono-spaced Bold Italic or Proportional Bold Italic

Whether mono-spaced bold or proportional bold, the addition of italics indicates replaceable or
variable text. Italics denotes text you do not input literally or displayed text that changes depending on
circumstance. For example:

To connect to a remote machine using ssh, type ssh username@domain.name at
a shell prompt. If the remote machine is example.com and your username on that
machine is john, type ssh john@example.com.

The mount -o remount file-system command remounts the named file
system. For example, to remount the /home file system, the command is mount -o
remount /home.

To see the version of a currently installed package, use the rpm -q package
command. It will return a result as follows: package-version-release.

Note the words in bold italics above — username, domain.name, file-system, package, version and
release. Each word is a placeholder, either for text you enter when issuing a command or for text
displayed by the system.

Aside from standard usage for presenting the title of a work, italics denotes the first use of a new and
important term. For example:

Publican is a DocBook publishing system.

1.2. Pull-quote Conventions
Terminal output and source code listings are set off visually from the surrounding text.

Output sent to a terminal is set in mono-spaced roman and presented thus:

books        Desktop   documentation  drafts  mss    photos   stuff  svn
books_tests  Desktop1  downloads      images  notes  scripts  svgs
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Source-code listings are also set in mono-spaced roman but add syntax highlighting as follows:

package org.jboss.book.jca.ex1;

import javax.naming.InitialContext;

public class ExClient
{
   public static void main(String args[]) 
       throws Exception
   {
      InitialContext iniCtx = new InitialContext();
      Object         ref    = iniCtx.lookup("EchoBean");
      EchoHome       home   = (EchoHome) ref;
      Echo           echo   = home.create();

      System.out.println("Created Echo");

      System.out.println("Echo.echo('Hello') = " + echo.echo("Hello"));
   }
}

1.3. Notes and Warnings
Finally, we use three visual styles to draw attention to information that might otherwise be overlooked.

Note
Notes are tips, shortcuts or alternative approaches to the task at hand. Ignoring a note
should have no negative consequences, but you might miss out on a trick that makes your
life easier.

Important
Important boxes detail things that are easily missed: configuration changes that only
apply to the current session, or services that need restarting before an update will apply.
Ignoring a box labeled 'Important' won't cause data loss but may cause irritation and
frustration.

Warning
Warnings should not be ignored. Ignoring warnings will most likely cause data loss.

2. We Need Feedback!
If you find a typographical error in this manual, or if you have thought of a way to make this manual
better, we would love to hear from you! Please submit a report in Bugzilla: http://bugzilla.redhat.com/
bugzilla/ against the product Fedora Documentation.

When submitting a bug report, be sure to mention the manual's identifier: user-guide

http://bugzilla.redhat.com/bugzilla/
http://bugzilla.redhat.com/bugzilla/
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If you have a suggestion for improving the documentation, try to be as specific as possible when
describing it. If you have found an error, please include the section number and some of the
surrounding text so we can find it easily.
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Introduction

1. Purpose and Audience
Welcome to the Fedora 13 User Guide! This guide is intended for users who have a working Fedora
13 system and are able to use a mouse and keyboard.

The purpose of this guide is twofold. First, it aims to orient new users with Linux or Fedora specific
conventions and methods that they may not already be familiar with, even if they are comfortable
using computers. Simultaneously, this document guides the user through carrying out common
desktop tasks including (but not limited to) setting up email, using an office suite, and managing
software.

Underneath all of this, the User Guide also diverges into basic command-line alternatives for many of
the presented methods (like installing software) to help the newer user become familiar with using a
terminal, and it points to more advanced guides for tasks that the ambitious user may be interested in
but which are not immediately within the scope of this guide.

2. About this document
Volunteer contributors from the Fedora Documentation Project create this guide for each release of
Fedora. If you have questions or suggestions about Fedora's documentation, or if you would like to
help document Fedora, please visit the Fedora Documentation Project web site1.

For assistance installing Fedora 13, please read the Fedora 13 Installation Guide, available from http://
docs.fedoraproject.org/install-guide/f13/2.

Thank you for choosing Fedora.

1 https://fedoraproject.org/wiki/DocsProject
2 http://docs.fedoraproject.org/install-guide/f/

https://fedoraproject.org/wiki/DocsProject
http://docs.fedoraproject.org/install-guide/f/
http://docs.fedoraproject.org/install-guide/f/
https://fedoraproject.org/wiki/DocsProject
http://docs.fedoraproject.org/install-guide/f/
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The Fedora desktops
In contrast to most proprietary operating systems, Fedora 13 has several desktop environments or
desktops that can display and launch available applications and manage the overall appearance of the
screen. The desktop environment is sometimes referred to as the Graphical User Interface (GUI).

Three widely-used desktops included with Fedora 13 are:
• GNOME, which focuses on simplicity

• KDE, which includes a large collection of applications and customization features

• Xfce, a desktop with low hardware requirements, suitable for older computers

More Desktop Environments Exist!
Fedora's extensive repository of software offers other desktops as well, such as Fluxbox1

(minimalist desktop), Sugar2 (the desktop environment for the OLPC XO), and LXDE3.
To learn how to browse and install software from the repository, refer to Chapter 17,
Managing software

With few exceptions, applications included with a particular desktop environment run in other
environments too. For instance, the OpenOffice.org office suite runs on all three major desktop
environments.

Some applications are created specifically for a particular desktop environment. For example, each
major desktop has a preferred text editor. GNOME uses Gedit and KDE supplies Kwrite, but you can
install and use these in either environment.

Fedora provides a wide choice of applications to browse the World Wide Web, create documents, and
display and edit photos. This guide describes the most commonly installed applications on the most
common desktop environments, as well as the useful alternatives.
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Logging into the desktop
This section of the Fedora User Guide explains how to identify yourself (or log in) to your system.
During the post-installation process, you created an identity with a user name and a password, called
an account. If you have forgotten any of your user account details, refer to Section 2.3, “ I Cannot
Login: help! ”. For additional information about the login process, refer to the section Section 2.2, “
Logging in: a technical explanation ”.

2.1.  Logging in
When you restart or turn on your computer, it goes through a process called booting. During the boot
process, your computer hardware powers on, performs a series of self-tests, and loads the operating
system. Immediately after the computer has finished booting, the login screen appears. The login
screen displays one or more user names, depending on the number of user accounts present.

To log in to your account
1. Enter your username, using one of the following methods:

• Type your username and then press the Enter key. The username is case sensitive
(capitalization matters; A is not the same as a).

• Click on your username in the list of choices.

2. Custimize your desktop environment

This step is optional
You do not normally need to choose a desktop, lauguage, or keyboard. If you skip this
step, Fedora will load the default environments for your computer.

Use the pull down menues at the bottom of the screen to change you desktop language or
keyboard layout. To use a desktop environment other than the default choice, use the Sessions
combo box on the bottom of the screen to select the desktop you wish to load before you enter
your password. The default is usually GNOME; refer to Chapter 1, The Fedora desktops for other
choices. Note: The Sessions combo box will be shown only if more than one desktop environment
is installed.

3. Enter your password in the text box and press the Enter key. Like your username, your password
is case sensitive.

Keep your password secret!
To keep your password secret, the password field displays a dot for every character
entered. As with any password, keep your account password private. Do not share it
with anyone or write it down in plain view.

4. The desktop environment now loads. In some desktop environments, a small box containing a
logo and some icons called a splash screen may temporarily appear. When your splash screen
(if you have one) disappears, your desktop is ready for use. You can now launch applications to
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access the Internet, manage files, and play media. These tasks are described in the following
chapters.

2.2.  Logging in: a technical explanation
Fedora is a multi-user operating system. Multiple users, each with different access privileges, can be
logged into the computer at the same time.

During installation, you provided a password for the system administrator account, sometimes called
the superuser. The user name for this account is root.

After installation, Fedora asked you to set up a normal user account. Use that account, or any
other such normal account, for daily use of the system, and the root account for administrative and
maintenance tasks.

This design has many benefits:
• Limited privileges reduce the possibility of doing significant damage to the entire system.

• Each user account has individual settings.

• Each user account maintains its data separate and private from others.

• A problem in one user account does not put the entire system at risk.

Do not log in as root!
Do not use the root account for routine purposes. A normal user account can run all the
desktop applications, and greatly increases your security and safety. Applications that
require root privileges prompt you for the root password when they need it. There is no
need to log in as root to use them.

2.3.  I Cannot Login: help!
A common mistake during login is accidentally having the Caps Lock key turned on. This situation
can cause the login process to fail because usernames and passwords are case sensitive. If problems
persist, re-enter your username and password a few times to ensure that you have typed them
correctly.

Recovering the password for a user account is not a difficult process, but it is beyond the scope of this
guide. You may wish to ask for help on user forums or chat rooms for further assistance.
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Tour of the GNOME desktop
This chapter introduces the GNOME desktop in Fedora. The desktop becomes easier to use after you
know some of the common terminology used, beginning with the GNOME desktop.

If you installed Fedora 13 from the Fedora 13 Live image, whether for Intel or compatible (i686) or
64-bit (x86_64), GNOME is the installed desktop. You can find details of two alternative desktops in
Chapter 4, Tour of the KDE desktop and Chapter 5, Tour of the Xfce desktop.

3.1.  The GNOME Desktop

Figure 3.1. The GNOME Desktop

The GNOME Desktop has three distinct areas. From top to bottom, they are:
• the Top Menu Panel (the gray bar at the top).

• the Desktop Area (the workspace area in the center that fills most of the screen).

• the Window List Panel (the gray bar at the bottom).

3.1.1.  The Top Menu Panel
This panel stretches across the top of the screen. The left side contains:
• the Applications Menu.

• the Places Menu.
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• the System Menu.

• Program Icons for the default email program, web browser, and reminder notes. Users may add
additional program icons.

The right side of the Panel is home to:
• the Notification area.

• a Volume Control and Sound Preferences applet.

• the Network Manager applet.

• the User Switch area.

• a Clock and Calendar applet.

Function description
If you hold the mouse pointer over the menu text or an icon, a brief description of its
function appears. If you click one of these icons, that application starts.

3.1.1.1.  The Applications menu
This menu contains a categorized list of installed applications, which are updated as necessary when
software is installed or removed. When you click on Applications a drop-down list appears. The
default list installed is:
• Accessories

• Games

• Graphics

• Internet

• Office

• Sound & Video

• System Tools

Other common menu items added with additional software include:
• Education

• Other

• Programming

3.1.1.2.  The Places menu
This menu is divided into four subsections.
• The first subsection allows quick access to commonly accessed folders, and makes it easy to keep

your file system organized. clicking on these links will open Nautilus, the default graphical file
manager of GNOME. These links are:
• Home Folder where your personal files are kept by default.
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• Desktop, a folder within your Home Folder where the files and folders that appear on your
desktop are stored.

• Documents, a folder within your Home Folder intended as a place for you to store documents,
such as those that you might have created with a word processor or spreadsheet program.

• Music, a folder within your Home Folder intended as a place for you to store music files.

• Pictures, a folder within your Home Folder intended as a place for you to store photographs
and other pictures.

• Videos, a folder within your Home Folder intended as a place for you to store videos.

• Download, a folder within your Home Folder intended as a place for you to store miscellaneous
files that you have downloaded from the Internet.

• Bookmark, a list of folders that you have bookmarked in Nautilus.

• The second subsection allows quick access to:
• the Computer window, which allows you to browse the computer's files and all data storage

attached to the computer.

• The third section provides links to tools that help you browse and manage network locations.
• Network allows you to view the networks that your computer is attached to, and to access files

and other resources available through those networks.

• Connect to Server allows you to create connections to public or local networks.

• The fourth section helps you quickly access any file on the system.
• Search for files allows you to search for files stored on your computer.

• Recent Documents lists the documents and folders recently accessed.

3.1.1.3.  The System menu
This menu is divided into three subsections.
• The first provides access to configuration tools.

• The Preferences menu contains tools that affect only your account, and only require normal user
access. These links include:
• About Me stores details about yourself that you can share with other people as an electronic

business card.

• Appearance customizes the appearance of your desktop, including the background picture.

• Assistive Technologies lets you choose software to magnify portions of the screen or to read
the contents of screens to you.

• Bluetooth configures Bluetooth devices to work with your computer

• Color Profiles to manage, install and generate color profiles.

• Desktop Effects enables or disables special visual effects for the desktop.

• File Management controls how files and folders are presented to you.
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• Input Method allows you to choose methods to input languages whose writing systems do not
use an alphabet, such as some Indic and East Asian languages.

• Keyboard specifies the type of keyboard that you use with this computer.

• Keyboard Shortcuts sets key combinations to perform certain tasks within certain programs,
or within the desktop environment more generally.

• Messaging and VoIP Accounts Configure accounts for Empathy instant messaging client and
VoIP application

• Monitors sets the resolution and other details of your display.

• Mouse configures the buttons and other controls on your mouse.

• Network Authentication configure Kerberos Network Authentication preferences.

• Network Connections displays your computer's network connections and allows you to
configure them.

• Network Proxy allows you to specify a proxy server for your computer.

• Personal File Sharing lets you share your documents and other files with other users of this
computer or with users of other computers over a network.

• Power Management configures your computer to perform differently under different power
settings.

• Preferred Applications lets you choose which applications you prefer to use for particular
tasks.

• Remote Desktop permits you or other people to access your computer's desktop from a
remote location over a network connection.

• Screensaver sets your screensaver.

• Seahorse-Preferences allows you to set the cipher-key's properties.

• Software Updates specifies how you would like your computer to handle software updates
when they become available.

• Sound lets you choose sounds to accompany actions or events on your computer.

• Startup Applications chooses applications to start automatically when you log in.

• The Administration menu contains tools that affect the whole system and require root access.
These tools prompt for the root password when launched.
• Add/Remove Software lets you change the software installed on the system.

• Authentication allows you to control how the system verifies users who attempt to log in.

• Bootloader lets you choose your default boot entry and the time the boot message is
displayed.

• Date and Time permits the system date and time to be changed.
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• Firewall link lets you setup and configure a firewall for your computer.

• Language allows you to change the default language.

• Logical Volume Management lets you configure the LVM in a graphical setting.

• Network permits configuration of your network connections and devices.

• Network Device Control lets you monitor and control your network devices.

• Printing allows you to configure your printers.

• SELinux Management allows you to change security settings that protect your computer.

• Services lets you decide which services will run when the system starts.

• Update System looks for software updates at your selected software sources.

• Users and Groups allows you to add or remove users and groups.

• The second section provides access to the help documentation, along with information about the
Fedora project, the GNOME project and information about your computer and its operating system.
• Help is the guide for questions about GNOME.

• About This Computer provides basic information about your computer and links to the process
and resource monitor.

• The third section contains entries to
• Lock Screen starts the screen saver or blanks the screen. It will ask for your password to restore

your session to the screen.

• Log Out of the current session.

• Shut Down gives you options to Hibernate, Restart, or Shut Down your computer.

Root password
When your computer asks for your root password it means you are entering an area that
changes your system's operation or performance. Beware of the messages the program
generates and be sure you really want to make the changes.

3.1.1.4.  Application launchers
The series of icons next to the menus provide quick access to commonly used applications. These
icons are called launchers.

The icon for Mozilla Firefox, a web browser.
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The icon for Evolution, a mail client and personal information manager.

The icon for Gnote, note-taking software.

To add more launchers to a panel, right-click on the panel and select Add to Panel. You can also add
launchers that are in the Applications menu. Right click on the application you want to add and select
Add this launcher to panel.

3.1.1.5.  The Notification area
The Notification area displays icons that alert you to new events taking place on your computer. For
example, your email program might display an icon here to indicate the arrival of new email, or your
printer software might display an icon here to indicate that a document is now printing.

3.1.1.6.  Volume control
The volume control allows you to quickly change the overall volume of sound on your computer.
Click the icon to show a slider, and then use the mouse to drag the slider to the desired volume. If
you double-click the icon, a volume control window appears in which you can separately change the
volume of different sound sources.

3.1.1.7. Network Manager applet
The Network Manager applet allows you to quickly connect and disconnect from available networks,
both wired and wireless. Left click on the applet to see what connections are enabled or available.
If you choose to connect to a connection, say a wireless connection in a coffee shop, you also have
the option to save those settings and automatically connect when you return. Right click on the
applet to enable and disable network devices or to edit or remove saved connections. See Chapter 7,
Connecting to the Internet for more information.

3.1.1.8.  The user switch area
If you click the current username located next to the clock, a list of available users appears. To switch
to a different user account, select the username.

3.1.1.9.  Clock and calendar
To access the calendar, click the clock on the right hand side of the panel. When you double-click a
date, the Evolution personal information manager opens. There is also a weather feature. Click the
edit button to modify or add locations to be displayed.

3.1.2.  The desktop area
The default desktop area, or workspace, contains three icons:
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• the Computer icon. If you double-click this icon, a window appears that contains available storage

devices on the computer. These are also listed in the Places  →  Computer menu.

• the Home icon, which represents the location where all of the logged in user's files, such as music,
movies, and documents, are stored by default. There is a different home directory for each user, and
users cannot access each other's home directories by default.

• the Trash icon. Normally, when you choose to delete a file, it is not permanently removed from your
system. Instead, it is sent to the trash folder, which you can access from this icon. To permanently
remove a file from your system, you must empty the trash. To empty the trash, right-click the icon
and select Empty Trash.

Permanently deleting files
To bypass the trash and permanently delete a file, hold down the Shift key when
deleting the file.

The Fedora Live CD desktop also includes an icon for installing Fedora to your hard disk. Additional
icons may appear depending on your system. For example, inserting a USB stick will cause an icon to
appear for accessing the stick.

3.1.2.1.  Using the desktop
Right-click on the desktop area for a menu of actions related to the desktop area. For example, the
Change Desktop Background action lets you choose a different image or photograph to display on
the desktop. Add program icons to your desktop by a left click on the program's icon and select Add
this launcher to desktop.

3.1.3.  The window list panel
This panel has three components:
• Any open applications appear as button icons in the middle part of the window list panel. It shows all

application windows in use on the desktop workspace, whether they are visible or hidden. A hidden
window button appears with a white background. The currently selected application window button
has a gray background, and is said to have focus. Usually, this is the application whose window is
on top of all the others on the screen. To switch from one running application to another using the
mouse, click on the desired application's button in the panel.

Use the key combination Alt+Tab to switch between open
windows
Holding down the Alt key and pressing the Tab key will open a small window
containing icons of all of your open windows. Repeatedly pressing the Tab key cycles
through the icons. Release both keys on your selection to pull it to the front

• The Workspace Switcher is the group of squares situated on the far right. They allow you to
move between workspaces. Workspaces have long been a feature of UNIX and Linux desktop
environments. Each workspace provides a separate desktop where applications can be organized,
and a corresponding window list panel. By default there are four workspaces available. To change
this number, right-click on the workspace switcher and choose preferences.
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Switching between workspaces
Use the key combination Ctrl+Alt+Left Arrow or Ctrl+Alt+Right Arrow to
switch between workspaces.

Hold down the Ctrl and Alt keys and press either the Left Arrow key or Right
Arrow key to cycle through the available workspaces on your system.

• The Trash icon on the right end of the window list panel works the same way as the Trash icon
in the desktop area. If you delete a file, it is moved to this location. A right click on the Trash icon
brings up the options to Open the folder, Empty Trash, Remove from Panel, and Lock to Panel.
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Tour of the KDE desktop
This chapter introduces the KDE desktop in Fedora 13. It is easier to explain how to use the desktop
throughout this guide after explaining some of the common terminology used with the KDE desktop.

4.1. The KDE desktop
If you installed Fedora 13 from the Fedora 13 KDE Live CD, KDE is the default desktop on your
computer. If you installed Fedora 13 from the Fedora DVD, your the default desktop is GNOME, and
KDE is available as an option at the login screen. Chapter 3, Tour of the GNOME desktop describes
the GNOME desktop.

Figure 4.1. The KDE desktop

The KDE desktop has two main areas:
• The desktop area

• The KDE panel

The layout and location of these items can be customized, but the term used for each of them remains
the same.

The desktop area is the large space where windows are displayed. Icons for the Home folder and
Trash are located in the top left corner of this area, within a tinted area that represents the contents of
a folder (in this case, the Desktop folder).
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The KDE panel is located at the bottom, and spans the entire width of the screen. It features the
Kickoff Application Launcher, Device Notifier and application launchers, displays the running
applications as buttons, and gives access to the workplace switcher, calendar, and the clock.

The following sections describe the KDE desktop area and the KDE panel in further detail.

4.2. The KDE desktop area
Before any additional icons are added to it, the desktop area is fairly empty and contains only a
translucent area that represents the contents of the Desktop Folder at the top left of the screen,
and a single desktop widget (Notes — a place where you can type reminder notes to yourself) at the
bottom right. The Desktop Folder area contains icons for Home folder and Trash. You can add
icons to the desktop for applications or places by finding them in the Kickoff Application Launcher
menu, right-clicking them and clicking Add to Desktop.

Right-clicking on the desktop presents a menu of actions related to the desktop area. For example,
selecting Appearance Settings lets you change the desktop background and visual theme. You can
also change the appearance of your desktop by clicking the plasma toolbox at the top right corner of
the screen.

4.3. The KDE panel
By default, the KDE panel extends the full width of the bottom part of the screen and contains the
following controls, called widgets:
• the Kickoff Application Launcher. In Fedora 13, this is represented by an icon of the Fedora

"Infinity" logo. The Kickoff Application Launcher gives you access to software and storage
locations on your computer, as well as allowing you to perform system-related tasks. It is described
in more detail in Section 4.3.1, “The Kickoff Application Launcher”.

• the Pager, which allows you to switch between multiple desktops on your computer. Multiple
desktops (or workspaces) have long been a feature of UNIX and Linux desktop environments.
Each desktop provides a separate view with different applications running in it. Four desktops are
configured by default. Clicking on one of the faded workspaces will change to that workspace, or
you can switch between them by holding down the Alt key on your keyboard and pressing the F1,

F2, F3, or F4 key. To add more desktops, right-click on the Pager, then click Pager Settings →
Configure Desktops....

• the Task Manager, which displays buttons for any applications that are running. Clicking on one of
these buttons brings that application to the foreground of your current view.

Use the key combination Alt+Tab to switch between open
windows
Holding down the Alt key and pressing the Tab key will open a small window
containing icons of all of your open windows. Repeatedly pressing the Tab key cycles
through the icons. Release both keys on your selection to pull it to the front

• the System Tray, which shows Klipper (a clipboard tool) and displays status notifications, such as
the status of network connections or remaining battery power.
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• a clock. Click on the clock to see a calendar, or right-click on it to change the way that the panel
displays the time and date.

• the plasma toolbox for the panel. Clicking here allows you to change the size and proportions of the
panel, and to re-arrange the order of the widgets that it displays.

4.3.1. The Kickoff Application Launcher
The Kickoff Application Launcher contains:

• Favorites – your favorite applications and places. Right click on an application or folder icon to add
it to this list. The initial list consists of:
• Web Browser – Konqueror, the default web browser installed with KDE.

• System Settings, which allows you to personalize your computer.

• File Manager, which allows you to browse files and folders on your computer. The default file
manager installed with KDE is Dolphin

• Applications – the applications installed on your computer, sorted into the following groups:
• Administration

• Development

• Education

• Games

• Graphics

• Internet

• Multimedia

• Office

• Settings

• System

• Utilities

• Find Files/Folders

• Help

• Personal Files

• Computer – information about your computer, and links to important places on it.
• Run Command, which allows you to launch a piece of software by typing its name.

• Home, your Home folder, the default storage location for your documents and media files.

• Network, which displays information about your network connections and allows you to change
network settings.
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• Root, the folder that contains every other file and folder in your file system.

Warning
Do not move or delete items from this folder unless you are certain that you
understand what you are doing. If you move or delete items within this folder, you
might damage your installation of Fedora to the point where it can no longer function.

• Trash, which holds files and folders that you have deleted from your system.

• Recently Used – applications and documents that you used recently.

• Leave – options to finish working with your computer.
• Logout ends your session, but leaves the computer running.

• Lock leaves you logged in, but blanks the screen and prevents interaction with the computer until
you type in your password.

• Switch User leaves you logged in, but lets another user log in to the computer.

• Suspend to Disk pauses your computer without logging out.

• Restart restarts your computer.

• Shutdown turns off your computer.
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Tour of the Xfce desktop
This chapter introduces the Xfce 4 desktop in Fedora. It is easier to explain how to use the desktop
after explaining some of the common terminology used with the Xfce 4 desktop.

5.1. The Xfce 4 desktop
One common reason for using the Xfce 4 desktop is to provide a feature-rich desktop environment for
a desktop computer or a laptop with limited memory.

Figure 5.1. The Xfce desktop

The Xfce 4 desktop has two distinct areas. From top to bottom, the areas are:
• the desktop area.

• the menu panel.

The layout and location of these items can be customized, but the term used for each of them remains
the same.

The desktop area occupies most of the screen. The Filesystem, Home Directory, and Trash icons
are located in the top left corner of this area.

The menu panel is located at the bottom of the screen. On the left part of the panel it contains a
number of default icons that start software applications. On the right of the panel, from left to right,
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there is a Notification Area, a Trash button, a Workspace Switcher, a Show Desktop button, a
Clock, and Switch User and Action buttons. In between the two sets of icons there is a Task List.

The following sections discuss the Xfce 4 menu panel and desktop area in further detail.

5.1.1. The Xfce 4 menu panel
This panel contains a number of launchers for common software. To customize the appearance of a
launcher, right-click on it and select Properties.

• Applications contains all the programs.

• Command Prompt opens the console.

• Editor opens Mousepad, a generic text editor.

• File Manager opens Thunar, a file manager program.

• Web Browser opens Firefox, a popular web browser.

• Notification Area displays notices and applets from various applications, for example the network
and power managers.

• Trash gives access to the Trash directory.

• Workspace Switcher allows you to switch to other workspaces. Four workspaces are provided by
default.

• Show Desktop minimizes all open windows to show a clear work area.

• Clock is a generic clock that can be modified by right clicking on it.

• Switch User/Action are the buttons on which you click to swich to a different user, log out, restart,
and shutdown Xfce.

The Applications button consists of several components:
• Run Program...

• Terminal

• File Manager

• Web Browser

• Preferences

• Administration

• Accessories

• Development

• Games

• Graphics

• Multimedia
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• Network

• Office

• Other

• System

• Help, About, and Quit buttons.

Open applications appear as button icons in the middle part of the menu panel, known as the Task
List.

The application window that has focus appears as a depressed button. Usually, this is the application
whose window is on top of all others currently on the screen. To switch from one running application to
another, click on the desired application's button in the task list.

Use the key combination Alt+Tab to switch between open
windows
Holding down the Alt key while you tap the Tab key allows you to cycle through all open
applications.

Customize the clock by right-clicking the clock on the right hand side of the panel and choose
Properties. Properties allows you to:
• change to or from a digital clock style.

• change the clock's display to and from a 12 and 24 hour format.

• change the date format.

Change the appearance of the panel by right-clicking on it and selecting Customize Panel.... To add
new items, right-click on the area where the new item should appear and select Add New Items....

5.1.2. The Xfce 4 desktop area
Before any additional icons are added to the desktop, the desktop area contains three icons by
default:
• Filesystem – this contains all mounted volumes (or disks) on the computer; all of these are also

available by clicking on the Applications menu and selecting Filesystem.

• Home – this is where all files - such as music, movies and documents - belonging to the logged-in
user are stored by default. There is a different home directory for each user and users cannot by
default access each others' home directories.

• Trash – deleted files are moved here. Empty the Trash folder by right-clicking the Trash icon and
clicking Empty Trash.

Permanently deleting files
To permanently delete a file, and bypass the file's move to Trash, hold down the Shift
key when deleting the file.
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Right-clicking on the desktop presents a menu of actions related to the desktop area. For example,
clicking on Desktop Settings... lets you choose a different image or photograph to display on the
desktop.
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Media
When you insert or connect media such as a CD, DVD, hard drive, or flash drive, to your computer,
the desktop enviroments in Fedora automatically recognizes the media and make it available for use.
An icon is placed on your desktop and in the Places menu in GNOME. On the KDE desktop an icon is
placed in the bottom panel next to the pager.

In GNOME you should unmount media before removing it from the computer. To do this, right-click
on the device's icon and then select Unmount Volume or Eject, depending on what type of media
you are using. During this process any remaining changes to the data on the media are written to the
device, allowing safe removal without data loss. If you remove media without unmounting it first, you
could cause data to be corrupted or lost.

There are several multi-media applications available for GNOME and KDE desktops. These
applications will run in either Fedora desktop environment. To install software packages not already
installed, refer to Chapter 17, Managing software. You can install applications either by using the
PackageKit application or on the command line by using Yum.

6.1. ISO images
The instructions in this chapter refer to image files at various points. In this context, an image file (or
disc image) is an archive file of an optical disc, in a format defined by the International Organization
for Standardization (ISO). ISO image files typically have an .iso extension. The name ISO is
taken from the ISO 9660 file system used with CD-ROM media, but an ISO image can also contain
Universal Disk Format (UDF) file system because UDF is backward-compatible with ISO 9660. An
ISO image includes all the data of files contained on the archived CD or DVD. They are stored in an
uncompressed format.

In addition to data of the files it also contains all the file system metadata, including boot code,
structures, and attributes. ISO images do not support multi-track, thus they cannot be used for audio
CDs, VCD, and hybrid audio CDs.

6.2. Writing CDs or DVDs
Fedora includes support for writing to CDs and DVDs. This means that you can permanently burn files
to CDs or DVDs for backup, file transport, or any other reason.

Required hardware
Not all optical drives (CD or DVD drives) are equipped to burn new media. An easy way
to check whether that you can burn optical media is to look at the front of your disc drive.
It should indicate the drive's capabilities. You can also look up the model of your drive on
line. An even easier way is to simply try burning a disc; chances are, if you cannot select
the option for burning discs, it is not a problem with Fedora; your drive simply does not
support this operation.
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6.2.1. Using CD/DVD Creator to burn media in GNOME

To open CD/DVD Creator
To open CD/DVD Creator, select Applications  →  System Tools  →  CD/DVD Creator. The help

manual can be accessed by pressing the F1 key or clicking Help  →  Contents on the top menu bar.

To create a data disc:
1. Drag the files and folders that you want to write to CD or DVD to the CD/DVD Creator folder.

2. Insert a writeable CD or DVD into your writer device. Doing this step first usually opens the CD/
DVD Creator automatically or prompt you to choose an application. If not, you can configure the

CD/DVD Creator to open automatically by going to any Nautilus window and selecting Edit  → 
Preferences and on the Media tab select what applications should start with each media type.
Also be sure that the Browse media when inserted box is checked.

3. Click the Write to Disc button, or choose File  →  Write to CD/DVD.

Here you can choose write to your CD or DVD, or to a File Image. An image file (ISO) is a normal
file that will be saved to your computer and you can write to a CD later.

If you are copying regular data you can type a name for your CD or DVD in the Disc name
window and select a write speed from the drop-down under Write Options. You will also see the
size of your data that will be written to the disc.

4. Press the Write button to burn your data to the CD or DVD.

To burn an image file
To write a disc image to a CD or DVD, right-click the disc image file, then choose Write to disk...
from the menu to burn the image using CD/DVD Creator. When you burn a a disc image, you cannot
choose the disc name or write speed.

To make a copy of a CD or DVD
1. Insert the disc you want to copy.

2. Right-click on the CD icon, and choose Copy Disc.

3. Follow the Write to Disc dialogue as above. If you have only one optical drive, the program will
first create a file on your computer. CD/DVD Creator will eject the original disk, and ask you to
change it for a blank disk on which to burn.

6.2.2. Using K3b to burn media in KDE
K3b is included on the Live-KDE media but is not installed by default from the Gnome Live CD or the
DVD. If you do not have access to the Internet, you can use the Fedora DVD to install K3b. After you
install K3b, using one of the methods described above, launch the program by clicking the Kickoff
Application Launcher  →  Applications  →  Multimedia  →  K3b.

When the application opens the action buttons are displayed at the bottom of the window:
• New Data CD Project
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• New Audio CD Project

• Copy Medium...

• More actions...

To add files to your K3b project, drag the files into the project pane at the bottom of the screen.
Everything in this project pane will be burned to your optical medium.

When you are ready to burn the files or folders to disk click the Burn button. If you need to delay
burning the media, you can use the menus at the top to save your work and return at a later time.

To burn an ISO image file, use the Tools  →  Burn Image. Navigate to and select the .iso image, then
click the Start button.

6.2.3. Using Brasero in GNOME
Brasero is the default GNOME application for burning audio and video media. It can also be used as
an alternative to CD/DVD Creator to backup data or to burn an ISO image. Launch the program by

clicking Applications  →  Sound and Video  →  Brasero.

When first launched, the left side of Brasero features buttons to create a new project. This can be
an audio project, data project, video project, or it can be a project to copy a disk or burn an image.
Once you choose a new project type, Brasero will provide instructions for that project. For example, to

burn and Audio CD, click the Audio Project button or select Project  →  New Project  →  New Audio
Project. On the following screen click the plus icon to add open a file browser and select files for the
project.

When you are ready to burn your CD/DVD, select the image or media at the bottom of the application
and click the Burn... button. If you need to delay burning your media, you can save your project and
return to it later. Use the Project menu for these options.

6.3. Making bootable USB media
With the liveusb-creator tool, you can set up USB media to hold a bootable copy of Fedora. This
allows you to run Fedora on a computer without making any changes to the computer's hard drive, as
long as the computer is capable of booting from USB media, and is set up to do so.

To create a bootable copy of Fedora on USB media, you will need:
• a USB media device with at least 1 GB of free space on it. USB media often comes in the form of

flash devices sometimes called pen drives, thumb disks, or keys; or as an externally connected hard
disk device. Almost all media of this type is formatted as a vfat file system. You can create bootable
USB media on media formatted as ext2, ext3, or vfat.

The Fedora installation will occupy around 1 GB. Beyond this, you might want to allocate space for
Fedora to store files such as documents or software installations. These documents and programs
will be available to you every time you start a computer with this USB media device, since they are
stored on the device itself and not on the computer to which it is attached. This feature is a major
advantage of running Fedora from Live USB media rather than from a Live CD.
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USB Image Writing is Non-destructive
Existing data on the media is not harmed and there is no need to repartition or reformat
your media. However, it is always a good idea to back up important data before
performing sensitive disk operations.

Unusual USB media
In a few cases with oddly formatted or partitioned USB media, the image writing may
fail.

• a copy of the Fedora Live CD or Fedora KDE Live CD, or a connection to the Internet. The liveusb-
creator tool copies the files from a Fedora Live CD or Fedora KDE Live CD to create bootable USB
media. If you do not have a Fedora Live CD or Fedora KDE Live CD, liveusb-creator can download
a CD image from the Internet. However, because this CD image is a very large file, you might find
this approach impractical if you do not have a broadband Internet connection.

• the liveusb-creator tool, for Fedora or Microsoft Windows. Instructions for obtaining this tool appear
in the following sections specific to each operating system.

6.3.1. USB image creation in Windows
1. Download the liveusb-creator program for Microsoft Windows at http://fedorahosted.org/liveusb-

creator.

2. Follow the instructions given at the site and in the liveusb-creator program to create the bootable
USB media.

6.3.2. USB image creation in Fedora
You can install liveusb-creator by clicking on System  →  Administration  →  Add/Remove
Software, then searching for liveusb-creator and installing it.

You can also install the application from the command line with the following command:

# yum install liveusb-creator

To open liveusb-creator click on Applications  →  System Tools  →  liveusb-creator. To create live
USB media,
1. Enter the root password if prompted.

2. Choose whether to Use existing Live CD and specify its location on your comptuer, or to
Download Fedora and select a file from the drop-down menu.

3. Select your Target Device for your Fedora installation, such as a USB memory stick.

4. select how much Persistent Storage you want. This is space that Fedora can use to hold
documents and other files.

http://fedorahosted.org/liveusb-creator
http://fedorahosted.org/liveusb-creator
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After you have made all of your choices just press the Create Live USB button to start the process.

Visit the liveusb-creator web page1 or the Fedora Wiki How to Create a Live USB2 page for more
information.

Another option to create a USB Image is:

Advanced usage
This content is written for the more advanced user. It assumes that you are comfortable
with the command line and have a relatively good knowledge of Linux terminology. It is
probably not necessary to using Fedora as a desktop user, but can help a desktop user
expand his or her knowledge base and face more complicated troubleshooting issues.

1. Install the ''livecd-tools package'' on your system with the following command:

su -c 'yum -y install livecd-tools'

2. Plug in your USB media.

3. Find the device name for your USB media. If the media has a volume name, look up the name in /
dev/disk/by-label or use findfs

su -c 'findfs LABEL="MyLabel"'

If the media does not have a volume name, or you do not know it, use blkid or consult the /
var/log/messages log for details:

su -c 'less /var/log/messages'

4. Use the livecd-iso-to-disk command to write the ISO image to the media:

su -c 'livecd-iso-to-disk the_image.iso /dev/sdX1'

Replace sdX1 with the device name for the partition on the USB media. Most flash drives and
external hard disks use only one partition. If you have changed this behavior or have oddly
partitioned media, you may need to consult other sources of help.

1 http://fedorahosted.org/liveusb-creator
2 http://fedoraproject.org/wiki/How_to_create_and_use_Live_USB

http://fedorahosted.org/liveusb-creator
http://fedoraproject.org/wiki/How_to_create_and_use_Live_USB
http://fedorahosted.org/liveusb-creator
http://fedoraproject.org/wiki/How_to_create_and_use_Live_USB
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Connecting to the Internet

7.1. The Network Manager Applet
Network Manager has been the default network configuration application for the GNOME desktop
since Fedora 11. This application can be used to configure a wide variety of network devices
and connections that allow you to access the Internet. Network Manager is used to configure
all your network connections from wired to wireless network as well as xDSL, VPN, and mobile
broadband with extended support for Bluetooth DUN. And if you don't know about DNS, DHCP or
pppoe, Network Manager does it all for you. If you use your computer at home, and have an xDSL
connection that is already working, you do not need to configure anything. Just connect to the wired
network. With a wireless or broadband connection, the steps needed to setup them are simple and
easy to do, just a few clicks and fill in your personal information.

Network Manager executes automatically when you start your session and it is visible in GNOME as
the nm-applet icon on the top right of the desktop. If you move the mouse over it, it shows the active
connection.

Left-clicking on the icon provides a context sensitive menu divided in three sections. The first section
shows the active connection or connections along with an option to Disconnect The second section
views the other available connections. Switch to one of them with a simple click and the previous one
closes automatically. The VPN Connections submenu provides option to configure or disconnect to a
VPN.

Right clicking on the nm-applet show another context sensitive menu that allows you to Enable
Networking and if available Enable Wireless or Enable Mobile Broadband. You can also Enable
Notifications as well as view the Connection Information or Edit Connections... When editing
connections, Network Manager opens in a new window, in which you configure the network devices
and connections. The About option provides information about the project and the people that created
the application, with a link to the Project Web-Site1 .

Just like its GNOME counterpart, KDE provides an applet interface for NetworkManager, known as
KNetworkManager. This application development was started by Novell2 and provides an integrated
QT-based experience with similar usage and configuration as its GNOME counterpart, nm-applet.

For more information on Network Manager , you can refer to:

• Network Manager Project Web-Site3

• Network Manager FAQ4

• Network Manager in Fedora 135 overview and interview with Dan Williams.

• Fedora 13 Release Notes6

7.2. The Network Manager window
To access to the Network Manager window to setup your network devices and connections, right-click
on the Network Manager applet icon then select Edit Connections....

1 http://live.gnome.org/NetworkManager/
2 http://www.novell.com

http://live.gnome.org/NetworkManager/
http://www.novell.com
http://live.gnome.org/NetworkManager/
http://live.gnome.org/DarrenAlbers/NetworkManagerFAQ
https://fedoraproject.org/wiki/NetworkManager_in_Fedora_13
http://docs.fedoraproject.org/
http://live.gnome.org/NetworkManager/
http://www.novell.com
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Be root to save your configurations
Before creating your new configuration, the application opens a window to confirm your
operation. To continue enter the root password.

When editing, in the Network Manager window, you will find these items:

• Connection name : A user-readable connection identifier/name

• Connect automatically : If checked, Network Manager will activate this connection when its
network resources are available. If unchecked, the connection must be manually activated by you.

• Available to all users : If checked, Network Manager gives all users access to this network
connection.

Additional tabs vary depending on the type of Internet connection.

7.3. Wireless connections
The most common items you should fill in, when using a wireless connection will appear in the
Wireless Tab:

• SSID : The SSID of the WiFi network

• Mode The available modes are: Infrastructure (default), Ad Hoc

• BSSID : If specified, directs the device to only associate with the given access point. This capability
is highly driver dependent and not supported by all devices.  Note: this property does not control the
BSSID used when creating an Ad Hoc network.

The Wireless Security tab allows you to choose no security or to specify one of the following security
methods:

• WEP 40/128-bit Key : Your WEP personal key

• WEP 128-bit Passphrase : The passphrase to decipher your WEP

• LEAP :

• Dynamic WEAP (802.1x) :

• WPA & WPA2 Personal : Your WPA personal key

• WPA & WPA2 Enterprise :

The IPv4-Settings tab configures DHCP or static Internet settings. View Section 7.5.3, “IPv4 Tab” with
wired connections below for more information or see the Wireless Guide at docs.fedoraproject.org7.

The IPv6 Settings tab similarly allows the configuration of IPv6 addresses with DHCP or static
settings.

7 http://docs.fedoraproject.org/

http://docs.fedoraproject.org/
http://docs.fedoraproject.org/
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7.4. Mobile Broadband
In Fedora 13, once your card is inserted, you can easily create a Mobile Broadband connection, as
indicated below. For many mobile broadband cards, Network Manager can visualize in the NM applet
icon, cellular signal strength and technology, and listen for signal strength changes or poll modem-
manager for such changes while connected. In this way, you are able to know when the device has a
signal and if it is roaming or not.

Network Manager in Fedora 13, uses the gnome-bluetooth plugin to help to configure your Mobile
Broadband with the service provider. Also, if you have a Bluetooth adapter and a mobile phone
(GPRS) that supports Bluetooth DUN, you can pair the phone with the computer, and let Network
Manager recognize your mobile phone; at the end of the pairing process you'll see a screen with
checkbox that says Access the Internet using your mobile phone. After checking that box, a
progress indicator will appear and say Detecting phone configuration.

Supported Mobile Broadband
For a list of supported devices, look at NetworkManager - Mobile Broadband8 , on the
gnome.org site. If your device is not supported, please contact the  mailing list 9 with
information on your device.

7.4.1. Create a Mobile Broadband network connection
Right-click on the Network Manager applet Icon and select Edit Connections... then select the
Mobile Broadband tab, and click on the Add button. A wizard will open that will assist you in the
configuration and ask for information about your provider. Specifically, you should know:

• Broadband Provider's name

• Broadband Billing Plan name

• Broadband Billing Plan APN (Access Point Name)

The wizard displays:

1. An information page that let you choose, if more than one are available, the Mobile device to
configure.

2. A page where you select the Provider's Country

3. A page where you select your Provider

4. A summary page of your selections.

Then you need to Section 7.4.2, “Setup a Mobile Broadband connection” .

My Service Provider is not listed
If your Service Provider, or plan (ie, APN) is not listed, you can submit additional
information to Bugzilla10 , or Bugzilla Gnome11 and tell us your provider name, your
country, the common name of your plan, and the APN you use.

http://live.gnome.org/NetworkManager/MobileBroadband
http://mail.gnome.org/mailman/listinfo/networkmanager-list
https://bugzilla.redhat.com/
https://bugzilla.gnome.org/enter_bug.cgi
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7.4.2. Setup a Mobile Broadband connection
Enter your information for the Mobile Broadband connection in following tabs.

• The Mobile Broadband tab specifies the number to dial when establishing a PPP data session with
the GSM-based mobile broadband network. In most cases, leave the number blank and a number
selecting the APN will be used automatically when required. The tab also specifies the username
and password used to authenticate with the network, if required. Note that many providers do not
require a username or accept any username.

• The PPP-Settings tab is used to configure the authentication and compression methods. In most
cases the defaults are sufficient and the provider's PPP servers will support all authentication
methods. Point-to-point encryption is not enabled by default but can be selected on this tab.

• The IPv4 Settings tab configures the Internet settings automatically (default), automatically for the
addresses but manually for DNS settings, or completely manually.

7.5. Wired connections
For wired connections, a common user, generally, doesn't need to do any configuration. Most users
use DHCP to obtain all configuration information from the network.

7.5.1. Wired Tab
• Mac Address : The HW address of your network card. When the system boots, it recognizes the

network card and its HW address. If you need to know the Mac Address of an interface, open a
terminal and run ip link

$ ip link show eth0
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:23:8b:dc:ae:67 brd ff:ff:ff:ff:ff:ff

• MTU (Maximum Transmission Unit): If non-zero, the card transmits packets of the specified size or
smaller, breaking larger packets up into multiple Ethernet frames. You could set this to Automatic
and les the system determine the MTU for you.

7.5.2. 802.1x Tab
Use this tab if you want cipher your Ethernet communications (default is unset)

7.5.3. IPv4 Tab
• Automatic (DHCP) : Specifying this method, then the O.S. does it all for you (default)

• Automatic (DHCP) addresses only : Specifying this method, then only automatic DHCP is used
and at least one IP address must be given in the DNS servers entry.

• Manual : Specifying this method, static IP addressing is used and at least one IP address must be
given in the DNS servers entry.

• Link-Local Only : Specifying this method, a link-local address in the 169.254/16 range will be
assigned to the interface.
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• Shared to other computers : Specifying this method, (indicating that this connection will provide
network access to other computers) then the interface is assigned an address in the 10.42.x.1/24
range and a DHCP and forwarding DNS server are started, and the interface is NAT-ed to the
current default network connection.

• DNS Servers : List of DNS servers. For the Automatic (DHCP) method, these DNS servers are
appended to those (if any) returned by automatic configuration. DNS servers cannot be used with
the Shared to other computers or Link-Local Only methods as there is no usptream network. In
Automatic (DHCP) addresses only and Manual methods, these DNS servers are used as the only
DNS servers for this connection.

• Search domains : List of DNS search domains. For the Automatic (DHCP) method, these search
domains are appended to those returned by automatic configuration. Search domains cannot be
used with the Shared to other computers or Link-Local Only methods as there is no upstream
network. In Automatic (DHCP) addresses only and Manual methods, these search domains are
used as the only search domains for this connection.

• Routes... : Fowarding table or routing table. Each IPv4 route structure is composed of 4 32-bit
values; the first, Address being the destination IPv4 network; the second, Netmask the destination
network, the third, Gateway being the next-hop if any, and the fourth, Metric being the route metric.
For the Automatic (DHCP) method, given IP routes are appended to those returned by automatic
configuration. Routes cannot be used with the Shared to other computers or Link-Local Only
methods as there is no upstream network.

• DHCP client ID : The local machine which the DHCP server may use to customize the DHCP lease
and options.

7.6. VPN connections
Here are some items, depending on the VPN connection type, required when configuring a VPN
connection:

The VPN tab allows you to specify the Gateway, Type, Username, and CA Certificate.

The IPv4 Settings tab configures the Internet settings automatically (default), automatically for the
addresses but manually for DNS settings, or completely manually.

7.7. xDSL connections
The items generally used in the xDSL connections are:

• On the xDSL tab specify the Username and if needed, the Password used to authenticate with the
Service Provider. For most providers, the Service entry should be left blank.

• PPP-Settings tab: default values.

• Wired tab: View Section 7.5.1, “Wired Tab”

• The IPv4 Settings Tab configures the Internet settings automatically (default), automatically for the
addresses but manually for DNS settings, or completely manually.
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7.8. Network Manager in a CLI
For those users who prefer the command line, Fedora 13 introduces two new tools for managing
networks with Network Manager at the command line.

7.8.1. nmcli
nmcli , is the console command that makes Network Manager available in a console. nmcli has the
following format: nmcli [OPTIONS] OBJECT { COMMAND | help }.

• OPTIONS: allows you to view the output in terse -t or pretty -p mode.

• OBJECT: can be nm (NetworkManager status), con (NetworkManager connections) or dev (devices
managed by NetworkManager)

• COMMAND: is the action on OBJECT

Type nmcli OBJECT help to see a list of the available actions. For example when OBJECT is nm ,
the COMMAND are:

nmcli nm help
Usage: nmcli nm { COMMAND | help }

 COMMAND := { status | sleep | wakeup | wifi | wwan }

  status
  sleep
  wakeup
  wifi [on|off]
  wwan [on|off]

So, running nmcli nm status , we have:

NM running:               running
NM state:                 connected
NM wireless hardware:     enabled
NM wireless:              enabled
NM WWAN hardware:         enabled
NM WWAN:                  enabled

Refer to man NetworkManager for more information.

7.8.2. nm-tools
The nm-tool utility provides information about NetworkManager, device, and wireless networks. For
example:

$ nm-tool
NetworkManager Tool

State: connected
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- Device: eth0  [System eth0] --------------------------------------------------
  Type:              Wired
  Driver:            8139too
  State:             connected
  Default:           yes
  HW Address:        00:21:C0:C1:B3:29

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties

    Carrier:         on

  IPv4 Settings:
    Address:         192.137.1.2
    Prefix:          24 (255.255.255.0)
    Gateway:         192.137.1.1

    DNS:             192.137.1.1
$
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Accessing the Web
For Fedora, Mozilla Firefox is the default web browser when using GNOME, and Konqueror is the
default web browser when using KDE. These broweser are used to access the Internet (World Wide
Web). There are many other browsers available to suit different users' needs. Dillo is an example of a
lightweight browser, and browsers such as lynx, w3m, and elinks are console based.

Besides being standards-compliant web browsers, Firefox and Konqueror have many features
beyond basic web browsing. This chapter explains how to use some of the more popular features, and
provides links to further information.

The Internet can also be used to transfer files. This chapter covers different methods of doing this
using graphical applications as well as the command line. If you wish to transfer files using email,
please refer to Chapter 9, Communications . This is often the best choice for smaller files such as
pictures and documents.

8.1. Browsing web pages
Firefox and Konqueror are the suggested web browsers for most users. If you require a more
lightweight browser (especially if you are using a slower system), you may want to try Dillo. If you are
using the command line, then you may want to use lynx, w3m, or elinks. None of these programs
are installed in Fedora by default, but can be installed using the instructions in Chapter 17, Managing
software.

8.1.1. Using Firefox
To start Firefox in GNOME, select Applications → Internet → Firefox Web Browser or use the

menu panel icon. To start Firefox in KDE, select KMenu  →  Applications  →  Internet  →  Firefox
Web Browser.

Firefox has many more features than discussed here; you can find more information on Firefox at the
Mozilla Firefox website: http://www.mozilla.org/support/firefox/.

8.1.1.1. Navigating the web
Fedora starts Firefox with a default home page that has links to useful Fedora-related sites.
Navigate to other web pages by typing the web address – also called the univeral resource locator,
or URL – into the long navigation bar across the top of the Firefox window, replacing http://
start.fedoraproject.org.

If you do not know the URL, enter a keyword (or words) into the search bar to the right of the
navigation bar, then press the Enter key. The search engine used to perform your search can be
changed by left-clicking the logo in the search box. You will be presented with a list of options including
Google, Yahoo, eBay, Amazon, and Creative Commons.

Like other web browsers, Firefox makes it possible to save the address for a web page for future
reference, by adding it to a list of bookmarks. Use the key combination Ctrl+D to bookmark a page
you are viewing. To manage bookmarks, use the Bookmark menu from the top of the Firefox window.
You can also create a live bookmark (a feed) that automatically checks for updates from a page with
an RSS or Atom feed. If a feed is available for a particular web page, there will be an orange icon at
the right hand edge of the address bar while you are visiting that page. Left click the feed icon and a
preview of the feed is displayed. Select the method you would like to use to subscribe to the feed.

http://www.mozilla.org/support/firefox/
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Use your favorite feed reader
Firefox can use a number of popular web-based options for subscribing to feeds, such
as Bloglines, My Yahoo, and Google Reader, as well as Firefox's own live bookmarks.
Another option is to use a stand-alone, desktop feed reader, such as Liferea.

8.1.1.2. Tabs
Open a new tab with Ctrl+T. A blank page is presented and a new bar is available under the
navigation bar showing all open tabs; to switch between them left-click the desired tab. To close a tab
you can either right click to access the context menu or press the red "X" on the tab.

Navigating a large number of open tabs can be difficult. To make it easier, use the arrow icon on the
right hand side of the tabs toolbar. Click this to reveal a list of all open tabs that you can switch to by
clicking on the relevant item.

8.1.1.3. Extensions
Firefox is designed to be moderately fast and lightweight. As a result, some functionality found in
other browsers may not be available by default. To solve this problem the Firefox team made the
browser extensible, so it is easy to create and integrate extensions that add new functionality to the
browser.

To manage and install extensions, plug-ins, and themes, select the Tools  →  Add-ons menu entry.
New extensions are found by visiting Mozilla's Firefox add-on site at https://addons.mozilla.org/en-US/
firefox/. To install an extension from this site follow the Add to Firefox link, and when prompted click
Install Now.

Themes, plug-ins and search engines
Firefox can also be extended by adding new search engines to the search box, installing
new themes to customize the look, and installing new plug-ins allowing the use of Java
and other web technologies. All of these can be found at Mozilla's Firefox add-ons site.

8.1.2. Using Konqueror
To start Konqueror in KDE, select KMenu  →  Applications  →  Internet  →  Konqueror. To start

Konqueror in GNOME, select Applications  →  Internet  →  Konqueror.

Konqueror on the GNOME and Xfce desktops
Konqueror is installed by default with the KDE desktop, but not the GNOME or Xfce
desktops. If you want to use Konqueror on the GNOME or Xfce desktops, you will need
to install it first. Refer to Chapter 17, Managing software for instructions on adding new
software to your system.

https://addons.mozilla.org/en-US/firefox/
https://addons.mozilla.org/en-US/firefox/
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8.2. Transferring files

Advanced Usage
This content is written for the more advanced user. It assumes that you are comfortable
with the command line and have a relatively good knowledge of Linux terminology. It is
probably not necessary while using Fedora as a desktop user, but can help a desktop user
expand his or her knowledge base and face more complicated troubleshooting issues.

Fedora includes several programs for transferring files between different computers on the same
network (or on the Internet). One of the most common methods is called the File Transfer Protocol
(FTP). There are several graphical programs available to use FTP, including FileZilla and gFTP. You
can also use the command line utilities ftp, lftp, and sftp.

FTP is insecure
If you are transferring files over a public network (such as the Internet), you may not want
to use FTP. FTP transfers can be easily intercepted, and FTP data is not encrypted. For
more security, use SFTP, which encrypts your data over SSH.

8.2.1. Using FileZilla
FileZilla, an application with a simple, graphical interface, allows you to use the FTP protocol to
transfer files over a network (and the Internet). Like many FTP applications, it has two important
panes: a file browser for your local machine, and a file browser for the remote machine. This way, you
can browse to a file on a remote server and drag-and-drop it to a folder on your local machine.

To install FileZilla, refer to Chapter 17, Managing software. You can install FileZilla by either using
PackageKit or on the command line using Yum. More information about FileZilla is available at http://
filezilla-project.org/.

FTP with web browsers
If you do not need to send a file, but only retrieve it, you can use Firefox, Konqueror,
and many other web browsers. Just browse to the ftp server in the address bar,
and make sure to specify that you want to use FTP. Generically, you would type
ftp://ftp.server.com, where ftp.server.com is the address of the FTP server.

8.2.1.1. Connecting to a server
To connect to an FTP server in FileZilla, you must add the server to your Site Manager. You can open
the Site Manager dialog in three ways:
• Click on File  →  Site Manager

• Click the first icon to the left on the tool bar

• Use the keyboard shortcut Ctrl+S

http://filezilla-project.org/
http://filezilla-project.org/
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Click the New Site button when the Site Manager dialog is open. In the text entry box under My Sites
(on the left side of the dialog), enter the name you want to use to refer to this new server. This name
does not have any technical implications; choose something convenient for you.

On the right side of the dialog box, you will need to enter the following information:
Host

This is the address of the server. If the server has a URL (such as ftp.server.com), you can
type it in here. If you do not have a this, you will need to type in the IP address. An IP address is of
the form A.B.C.D, where A, B, C, and D are integer values between 0 and 255 (inclusive).

Port
Only enter a value in this field if the server you want to connect to is not using the default ports
(port 21 for FTP, port 22 for SFTP).

Servertype
Choose either FTP, SFTP, FTPS, or FTPES. Note that this section only discusses FTP and SFTP.

Logontype
This field allows you to choose how you will authenticate with the server. This information should
be provided to you by the server administrator.

User, Password, Account
These fields are only active when certain Logontypes are used. If active, you should use them for
your username, password, and account on the remote server.

Comments
This field has no technical relevance. It may be convenient for you to make a note of something
about the server here.

When you have filled out the fields, click OK to close the Site Manager or Connect to close the Site
Manager and connect to the FTP server immediately. Clicking Cancel will ignore any changes you
made to the Site Manager and close the dialog.

To connect to servers already added to Site Manager, open Site Manager and click on the server you
want to connect to, and then click Connect.

8.2.1.2. Transferring files
Once connected successfully, status messages (in most cases) will appear in the top pane. The right-
hand file browser pane will also display the contents of the directory.

To transfer a file, simply drag-and-drop it from one browser pane into the folder of the other browser

pane. To disconnect from the server, press Control+D or select Server → Disconnect .

8.2.2. FTP on the command line
To use the ftp program, type ftp in the command line prompt. You should be put into an FTP shell
that looks like this:

ftp>
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Type help to get a list of commands, and help command for a simple description of that command.
This guide will only cover a fraction of these commands; refer to the ftp manual page for further
details.

8.2.2.1. Connecting to an FTP server
Use the open command to connect to an FTP server. The syntax for this is open  ftp.server.com
port where ftp.server.com is the server you want to connect to. Only specify a port if you are
connecting to a server that uses a non-default port(the default is 21). Alternatively, you can connect to
an FTP server as you start the ftp program. To do this, use the syntax ftp ftp.server.com port,
where the port option is optional.

8.2.2.2. Downloading and Sending files
FTP is used to retrieve a file from a public server. Use the get file command, where file is the
name or path of the file you want to retrieve. Use the pwd command to determine which directory you
are currently in, and the ls command to view all files in that directory. Use the cd command to change
directories.

Use the put file command to send a file to the server, where file is the name or path of the file you
want to send. Use the lcd command to view all files in your local directory (not the remote server).
You can also type lcd directory to change to a new directory on your local machine.

8.2.2.3. SFTP on the command line
Secure FTP (SFTP), is an encrypted version of FTP. It connects to a remote server through a secure
socket layer using SSH. This means that it is a much more secure solution than traditional FTP. Use
the command sftp to start the client. The syntax is similar to that of FTP.

8.2.2.4. Secure copy (SCP)
The scp command is another option for transferring files between two computers via SSH. scp
attempts to use the same syntax as the traditional copy command (cp), but differs in that you can
specify remote servers. The following is an example of using scp to send a file to a remote server,
type:

$ scp localFile user@server:/destination/directory/

You can similarly fetch a file:

$ scp user@server:/path/to/wantedfile destinationFile

Or even between two remote servers:

$ scp user1@server1:/path/to/source user2@server2:/path/to/destination

In every case that you access a remote server, you will be prompted for your credentials (such as a
username and password).
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Communications
Fedora can be used to send electronic mail and communicate in real time with people around the
world through instant messaging and chat rooms. In GNOME, Evolution is used to send electronic
mail (email) by default. Evolution can also be used as a personal information manager, or PIM. You
can maintain a calendar, manage a list of tasks, and keep an address book of contacts.

In KDE, Kmail is used to send email by default. While Kmail does not include a calendar, a calendar
application called KOrganizer is included as part of the KDE PIM suite. There is also an application
called Kontact which groups KMail, Korganizer and other KDE PIM tools into a single interface
(comparable with GNOME's Evolution).

Thunderbird is an open-source mail client maintained by Mozilla. It is very extensible, with an online
plug-in library akin to Mozilla Firefox. Claws Mail is a more lightweight email client and news reader,
which is also extensible via additional plug-ins. Claws Mail only supports plain text emails by default.

Empathy and Kopete are both Instant Messaging (IM) programs that allow you to talk to people in
real-time using chat networks like AIM, Yahoo! Messenger, or Gmail chat. XChat is Fedora's default
graphical IRC client and Konversation is the default IRC client for KDE. ChatZilla is an IRC client
installed and used via the FireFox web browser. These clients can all connect to IRC servers which
provide chat rooms for people around the world to discuss specific topics.

9.1. Evolution
Evolution is a full featured email program. In addition to email, Evolution features a personal
information manager (PIM), a calendar, task manager and an address book for your contacts.
More documentation for Evolution is available at: http://www.gnome.org/projects/evolution/
documentation.shtml

9.1.1. Configuring Evolution
To configure an email account:
1. Start Evolution

• in GNOME, click Applications → Office → Evolution on the top menu bar.

• in KDE, click the Kickoff Application Launcher → Applications → Office → Groupware
Suite menu entry.

2. Running the software for the first time displays the Evolution Setup Assistant wizard. After the
initial welcome screen you will have an opportunity to restore Evolution from a backup or click the
Forward button to continue and answer questions with information provided by your ISP or email
provider.
• The Identity screen relates to personal information about the account, including Name,

Organization, and Email Address. There is also a Reply-To field, which will allow you to
specify that recipients of mail from this account can reply to a different email address than the
one that sent the email.

• The Receiving Email and Sending Email screens both require information from the e-mail
provider. There are many server types available from the pull down menu. The most common
protocols for receiving email are IMAP and POP. If your provider support IMAPs, choose IMAP
as the Server Type then select an encryption method from the Security settings.

http://www.gnome.org/projects/evolution/documentation.shtml
http://www.gnome.org/projects/evolution/documentation.shtml
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To add a new account in the future, or to modify an existing account, launch the preferences dialog

from the Edit → Preferences menu. In the dialog that appears, press the Add button to launch the
Evolution Account Assistant again.

9.1.2. Using Evolution
Evolution allows you to create, store and send email by clicking the appropriate buttons located on
the top toolbar. Use the mouse to hover over each icon for a pop-up description of each button. You
can also use the pull down menus to find each action as well as keyboard shortcuts for those actions.
These actions include creating New email messages, Send/Receive queued emails, replying to the
sender of an email or replying to all recipients of an email, printing an email, deleting an email, and
moving to the next or previous email in the folder. There are also buttons to mark an email as Junk or
Not Junk.

Do not miss important emails
Check your Junk folder frequently as you begin with Evolution and if needed, mark items
that are Not Junk. Evolution will learn what is Junk and what is Not Junk with each item
that you mark.

In the lower left section of Evolution are buttons to switch from the default email tasks to other
tasks including Contacts, Calendar, Memos, and Tasks. As you select each of these components of
Evolution the toolbar at the top will adjust to provide buttons for the most common actions.

Using Contacts in emails
As you read an email, right click on the sender's email address and select Add to
Address Book.... This will add an entry to your contacts. When sending an email, click
the To: or CC: buttons to select recipients from your contacts.

9.2. Thunderbird
Thunderbird Is Mozilla's email application. To install Thunderbird, refer to Chapter 17, Managing
software You can install Thunderbird by either using the PackageKit or on the command line by
using Yum. More information about Thunderbird is available at: http://www.mozilla.org/support/
thunderbird/. You can find add-ons for Thunderbird at: https://addons.mozilla.org/en-US/thunderbird1.

9.2.1. Configuring Thunderbird
To configure your email account you will need the email information provided by your ISP or email
provider.

1. Open Thunderbird:
• in GNOME, click Applications → Internet → Thunderbird on the top menu bar.

• in KDE, click Kickoff Application Launcher → Applications → Internet → Email menu entry.

1 https://addons.mozilla.org/en-US/thunderbird/

http://www.mozilla.org/support/thunderbird/
http://www.mozilla.org/support/thunderbird/
https://addons.mozilla.org/en-US/thunderbird/
https://addons.mozilla.org/en-US/thunderbird/
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2. The first time you start Thunderbird the Account Wizard opens to guide you through the setup of

your account. If the Account Wizard does not open, select File → New → Mail Account... in the
main window to open the wizard.

3. Fill in your name, email address, and password, and click Continue.

4. Thunderbird will attempt to detect your account settings automatically. If the automatic detection
is successful, your account settings will appear.

5. If Thunderbird fails to automatically detect the account settings, enter the names of the Incoming
and Outgoing servers. Choose POP or IMAP, and the appropriate secure setting if required.
Select 'Re-test configuration'.

6. When Thunderbird has detected your account, select Create Account. Now Thunderbird
connects to the server to download your email messages.

7. If the download fails, your email account may require secure connections. In this case, select Edit
→ Account Settings → Server Settings and select your secure setting. Often the setting is SSL,
but this information should be provided by your email service.

9.2.2. Moving your Thunderbird profile data from Windows to
Fedora
The Thunderbird data profile folder contains your email messages, addresses, and program settings.
To move your profile data from Windows to Fedora requires that the data folder be copied to a CD/
DVD, memory stick, or other mobile media. If you have set up multiple accounts in Thunderbird, they
can be moved as well, one at a time, following these steps:
1. Find your profile data folder

• In Windows 2000 or Windows XP, click Start → My Computer → Local Disk (C:) →
Documents and Settings → YourUserName → Application Data → Thunderbird →
Profiles. The profile data folder looks like xxxxx.default, where xxxxx is a sequence of
random numbers and letters.

If you cannot find the Application Data folder
If you cannot find the Application Data folder, go to the top menu and select:

Tools → Folder Options → View and check the box Show Hidden Files and
Folders.

If you still cannot find the folder, click: Start → Run, type %AppData% and press
Enter.

• In Windows Vista, click Start → Computer → C: → Users → YourUserName → AppData
→ Roaming → Thunderbird → Profiles. The profile data folder looks like xxxxx.default,
where xxxxx is a sequence of random numbers and letters.
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If you cannot find the Application Data folder
If you cannot find the Application Data folder, click Start → Control Panel →
Classic View → Folder Options → View and check the box Show Hidden Files
and Folders.

If you still cannot find the folder, click: Start, type %AppData% into the Start Search
box and press Enter.

2.Copy your profile data folder to removable media
Right click on the profile data folder and select: Send To → CD/DVD or memory stick. Then
press the Back button until you arrive at My Computer and check to make sure the folder was
saved to the media.

3. Copy your profile data folder to Fedora

Set up your email account or email accounts first
To move the folder to Fedora you need to have your email account, or accounts, set
up in Thunderbird on your Fedora installation. When you set up an email account,
Thunderbird creates the profile data folder for that account. If this folder does not yet
exist, you do not yet have a destination for the copy of the folder on your removable
media. Refer to Section 9.2.1, “Configuring Thunderbird”.

a. Open the Thunderbird profile data folder in Fedora:
• In GNOME, click Places → Home Folder to open Nautilus. Next check the box under View

to show hidden files and navigate to .thunderbird → xxxxxx.default, where xxxxxx is a
random sequence of letters and numbers. Note that this sequence will be different from the
sequence that you saw in your Thunderbird installation on Windows.

If you cannot find the .thunderbird folder
If your Fedora installation originally had an early version of Thunderbird
installed on it, your profile data folder might be under .mozilla-
thunderbird instead of .thunderbird.

If you cannot find either a .thunderbird or .mozilla-thunderbird folder
within your Home Folder, press Ctrl+H to display Hidden Files.

• In KDE, click Kickoff Application Launcher → Computer → Home. Once Dolphin starts,

show hidden files from the View menu, then navigate to .thunderbird → xxxxxx.default,
where xxxxxx is a random sequence of letters and numbers. Note that this sequence will
be different from the sequence that you saw in your Thunderbird installation on Windows.
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If you cannot find the .thunderbird folder
If your Fedora installation originally had an early version of Thunderbird
installed on it, your profile data folder might be under .mozilla-
thunderbird instead of .thunderbird

If you cannot find either a .thunderbird or .mozilla-thunderbird folder
within your Home Folder, press Alt+. to display Hidden Files.

b. In the xxxxxx.default folder, press Ctrl+A to select all files and folders, then press
Delete to move them to the Trash. The folder should now be empty.

c. Plug in the media containing the folder you copied from Windows.

d. Open the media and click on the xxxxxx.default folder saved from Windows to open it.

Click Edit → Select All → Edit → Copy

e. Move back to the empty xxxxxx.default window and click Edit → Paste.

f. Start Thunderbird and verify that you can see the email messages, addresses, and settings
from your Thunderbird installation on Windows.

9.2.3. Using Thunderbird
The first time you press the Get mail button you are asked for your password. Type in your password
and press Enter or click the Ok button. You might want to check the box Use Password Manager to
remember this password. If you do, Thunderbird will automatically check your email without asking
for your password in the future. Before choosing this option, remember that there is always some risk
associated with storing a password. If your password and setup was correct, Thunderbird will now
download your email messages from the server.

Thunderbird allows you to download and create email by clicking the appropriate buttons located
on the toolbar at the top of the screen. Get Mail prompts Thunderbird to send and receive all email.
Write opens a new email message dialog box. Address Book opens the email addresses you have
on file. Tag Color-codes messages that are important or need follow-up.

Click on an email to view it in the message pane. Double-clicking on an email will open it in a new tab.
Buttons at the top right of the email message give access to various functions. In addition to Reply,
Reply All, Forward, and Delete, Archive compresses the message and stores it in the Archive, Junk
marks the email as junk, and Other Actions provides access to other options, including Save as...
and Print.

9.3. Claws Mail
Claws Mail is an email client and news reader built to be lightweight and easy to operate. Claws
Mail features mostly basic functionality, but plugins can be used to add many of the features found
in Evolution and Microsoft Office Outlook. To install Claws Mail, refer to Chapter 17, Managing
software. You can install Claws Mail by either using PackageKit or on the command line by using
Yum. More information about Claws Mail is available at: http://www.claws-mail.org/.

http://www.claws-mail.org/
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9.3.1. Configuring Claws Mail
To configure your email account you will need the email information provided by your Internet service
or email provider

1. Open Claws Mail:
• in GNOME, click on Applications → Internet → Claws Mail.

• in KDE, click the Kickoff Application Launcher → Applications → Internet → Claws Mail
menu entry for Claws Mail.

2. The first time you start Claws Mail the Claws Mail Wizard appears and will guide you through the
set up of your account:

3. After the welcome screen, follow the dialogs to fill in your name, (sometimes it is guessed from the
operating system) and your email address.

4. On the next page choose a protocol and enter details of how to retrieve your mail:
POP3

Enter the server address, username, and password. Also select encryption in needed when
connecting to your provider. If you do not enter your password here you will be prompted for it
each time it is needed.

IMAP
Enter the server address, username, password, encryption, and IMAP server directory.
The password is optional, if you do not provide it here you will be prompted for it each time it
is needed. The IMAP server directory is also optional, often it is not needed and can be left
empty.

Local mbox file
Enter the location of your local mailbox spool file. Values such as /var/mail/username or
/var/spool/mail/username are common, username is your system login.

5. On the next page enter the address of your SMTP (Outgoing) server. Also fill in any authentication
and encryption information that your provider requires for sending email.

6. If you chose either POP3 or Local mbox file, the next page will the show the default where it will
save your mail.

7. Click on the Save button to finish the configuration.

9.3.2. Using Claws Mail
Claws Mail allows you to create, store and send email by clicking the appropriate buttons located on
the toolbar. Retrieving your email can be done from the toolbar button named Get mail or from the
Receive submenu of the Message menu.

From the Tools menu you can collect addresses for the address book, configure filters, and manage
certificates. The Configuration lets you configure accounts, filters, templates, actions, and tags.

Claws Mail by default is a lightweight and fast email client that handles plain text email only. With the
addition of plugins Claws Mail can also render HTML email, handle vCalendar messaging, integrate
with spamassasin, or report spam to various locations. Fedora packages many plugins as separate
packages. To install additional plugins refer to Chapter 17, Managing software. You can install plugins
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by either using PackageKit or on the command line by using Yum. Use the search features to locate
claws-mail-plugin-* packages. Additional plugins can also be found at http://www.claws-mail.org/
plugins.php

9.4. Kmail
Kmail is the standard email client used in KDE it is installed by default from the Fedora KDE Live CD

and is also included in the DVD. To start Kmail in KDE, click the Kickoff Application Launcher →

Applications → Internet → Mail Client menu entry for Kmail, or in GNOME, click Applications →

Internet → Kmail in GNOME.

9.4.1. Configuring Kmail
Running the software for the first time displays a wizard to configure mail accounts or cancel and
create an account later.

Using IMAPs or POPs with KMail
If your email provider requires the use of a secure connection such as IMAPs, you may
need to configure the account at a later time. Not all configuration options are available
through the connection wizard.

The dialog boxes will prompt you through:
• choosing an account type such as IMAP or POP

• specifying your account information including real name, email address, and organization,

• providing login information for your email account

• specifying server information for incoming and outgoing email

Finally, KDE may ask you to set a password for KDEWallet which manages account passwords
across the KDE Internet applications.

To add a new account in the future, or to modify an existing account, click Settings → Configure
Kmail. In the dialog that appears, select Accounts then press the Add button to add an account or
Modify to modify an existing account.

9.4.2. Using Kmail
Kmail allows you to create, store and send email by clicking the appropriate buttons located on the
toolbar or by selecting the appropriate menu options. From the pull down menus, specifically the Tools
menu, you can also manage the address book, configure encryption, and edit "Out of Office" replies.
From the Settings you can configure filters, shortcuts, toolbars, accounts, and more. The Help menu
provides access to the KMail Handbook, a KMail Introduction, and a "Tip of the Day" feature.

9.5. Empathy
Empathy is an instant messaging (IM) client that can access Gmail, MSN, AOL, Yahoo!, Jabber, and
other IM and chat networks. Empathy is the default instant messaging client for the GNOME desktop.
For further information please refer to: http://live.gnome.org/Empathy.

http://www.claws-mail.org/plugins.php
http://www.claws-mail.org/plugins.php
http://live.gnome.org/Empathy
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9.5.1. Configuring Empathy
To start and configure Empathy, select Applications → Internet → Empathy IM Client from the

menu panel in GNOME or the Kickoff Application Launcher → Applications → Internet → IM
Client menu entry for Empathy in KDE.

Starting Empathy for the first time goes directly into the Messaging and VoIP Accounts Assistant
dialog. Choose to configure Empathy to use an existing account, create a new account, or see people
online nearby.

Fedora does not register all accounts
Many IM networks require you to create an account before you can use them. In many
of these cases, you cannot create the account in Empathy and will normally need to
visit the website of the network to create an account. For example, you cannot use
Empathy to create a Yahoo Instant Messenger account. Instead, you much first visit
http://messenger.yahoo.com to set up the account, then access it using Empathy.

To configure Empathy to use an existing account follow these steps:
1. Select Edit → Accounts to bring up the Messaging and VoIP Account Assistant dialog, select

the Yes, I'll enter my account details now button and click Forward.

2. Click the drop-down menu to show the available protocols and select the network appropriate for
the account being created.

3. Enter details for the selected account, including Screen name and Password. Click on the Apply
button to add the account to the account list and return to the main window.

To modify, delete, or add additional account, select Edit → Accounts from the main menu. Highlight
an account to modify or delete or click the Add... button to configure an additional account.

9.5.2. Using Empathy
You can use the menus or double click on a Buddy to start a conversation. All supported protocols
are available at the same time within Empathy. If you have setup several accounts, such as Yahoo,
Google Talk, and AIM accounts, then all of your contacts for each of these accounts will be available to
chat with at the same time, in the same contact list. Each conversation that is started with have menu
options appropriate for the protocol of that account.

Select Edit → Preferences to customize themes, notifications, sounds, and more. The Room menu

allows you to join a chat room. If you want to temporarily disable an account, select Edit → Accounts,
select the account to disable, and uncheck the enabled box. Your account settings will be saved and
you can enable the account at any time.

9.6. Pidgin
Pidgin is an instant messaging (IM) client that can access Gmail, MSN, AOL, Yahoo!, Jabber, and
other IM and chat networks. For further information please refer to: http://www.pidgin.im

In previous versions of Fedora, Pidgin was the default instant messaging program. If you upgrade
Fedora from a previous version you will still have Pidgin installed and configured. If you have a fresh

http://messenger.yahoo.com
http://www.pidgin.im
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install of Fedora, Empathy is the default IM client. See Section 9.5, “Empathy” for more information.
To install Pidgin, refer to Chapter 17, Managing software You can install Pidgin by either using the
PackageKit or on the command line by using Yum.

9.6.1. Configuring Pidgin
To start and configure Pidgin, select Applications → Internet → Pidgin Internet Messenger from

the menu panel in GNOME or the Kickoff Application Launcher → Applications → Internet →
Instant Messenger menu entry for Pidgin in KDE.

Starting Pidgin for the first time goes directly into the Accounts dialog. To configure a new account
follow these steps:
1. Click on the Add button to bring up the Add Account dialog.

2. In the Add Account window, under Login Options, click on the right side of the Protocol drop-
down menu to show the available protocols and select the network appropriate for the account
being created.

3. Enter details for the selected account, including Screen name, Password, and Alias. Select
Remember password if desired. Click on the Save button to add the account to the account list.

4. Once the account is added, the Accounts window displays the new account.

5. New accounts can be added in the future by navigating to the Accounts → Manage Accounts
menu entry in the main Pidgin window.

9.6.2. Using Pidgin
All supported protocols are available at the same time within Pidgin. If you have setup several
accounts in Pidgin, such as Yahoo, Google Talk, and AIM accounts, then all of your contacts for each
of these accounts will be available to chat with at the same time, in the same contact list.

For more information see: http://developer.pidgin.im/wiki/Using%20Pidgin

Not all features supported
Pidgin does not support some features of the included protocols. Pidgin is useful for
chatting via text across different IM protocols, but not all the features in each IM system
are supported. For example, video is not supported at this time.

Fedora does not register all accounts
Many IM networks require you to create an account before you can use them. In many
of these cases, you cannot create the account in Pidgin and will normally need to
visit the website of the network to create an account. For example, you cannot use
Pidgin to create a Yahoo Instant Messenger account. Instead, you much first visit http://
messenger.yahoo.com to set up the account, then access it using Pidgin.

http://developer.pidgin.im/wiki/Using%20Pidgin
http://messenger.yahoo.com
http://messenger.yahoo.com
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9.7. Kopete
Kopete is the Instant Messenger installed in KDE by default. To start the program in KDE, click the

Kickoff Application Launcher  →  Applications  →  Internet  →  Instant Messenger menu entry

for Kopete. In GNOME, click Kopete can be found in Applications → Internet → Kopete. For further
documentation on Kopete, refer to: http://kopete.kde.org/

9.7.1. Configuring Kopete
To configure an account in Kopete select Settings → Configure... then click Add Account. Follow
the dialog questions to choose a messaging service from the list then specify the account information
for that service. Make sure to fill out the details on the other tabs. Once the account is added, click
Next and choose the option to connect to the service and then click Finish.

Kopete comes with a wide range of messaging services such as:
• AIM

• Bonjour

• GroupWise

• ICQ

• Jabber

• Meanwhile

• WLM Messenger

• Testbed

• WinPopup

• Yahoo

You can add accounts for these services to Kopete using the steps above.

9.8. XChat
XChat is an IRC chat program. It allows you to join multiple IRC channels (chat rooms) at the same
time, talk publicly, private one-on-one conversations and is capable of transferring files. To install
Xchat, refer to Chapter 17, Managing software You can install Xchat by either using the PackageKit
or on the command line by using Yum. More information is available at http://xchat.org/.

9.8.1. Configuring XChat
1. When you open XChat the XChat: Network List window appears. Fill in your choices for your

Nick name, username and realname. Your username can be anything you like.

2. Now choose a network to join from the Networks window. Select the one you want by clicking it.
For example, most Fedora projects use the FreeNode network to host chat rooms.

3. Select Edit which opens another window listing the network you selected. For now make sure the
box Use global user information is checked. Go down to the Favorite Channels field and type

http://kopete.kde.org/
http://xchat.org/
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in the channel you want to join. You can also click on the small button to the right of the field which
will bring up a window where you can Add, Remove and Edit your channels . Most networks
require # placed before the name of the channel. For example, #fedora-doc is where you ask
about writing and updating this and other documentation. The #fedora chat room is a good place
to find help using fedora.

4. Click the Close button.

5. Select Connect and you are connected to your channel.

9.8.2. Using XChat
On the top menu bar select Applications  → Internet  → XChat IRC. Click the Connect button and
you are attached to the networks and channels that you selected above.

You can configure your preferences for XChat while attached to the network. On the top menu bar

select Settings  → Preferences and choose your text, background and sound preferences. You can
also configure alerts and logging. Once logging to the disk is enabled in the preferences, right click on
the channel name and and select Settings to enable or disable logging for an individual channel.

XChat defaults to showing each channel as a tab. Either right click the channel name or select Xchat
and click Detach to view a channel in a separate window.

9.9. Konversation
Konversation is the default IRC application for the KDE Desktop. You can find details at http://
konversation.kde.org/.

9.9.1. Configuring Konversation
To configure Konversation select:
1. Kickoff Application Launcher → Applications → Internet → IRC Client.

2. The Servers List window pops up and has a default network listed. Select New or click on the
default network then select Edit.
a. Type in your chosen network in the Network Name: field.

b. Under Identity click Edit and add your user names.

c. Check the box Connect on application start-up to attach automatically when you open
Konversation

3. In the Auto Join Channels window:
a. Click on the default channel listed then Edit or just click the Add button to ad your choice.

b. Type in your desired channels, and passwords if needed, then click the Ok button.

4. You are returned to the Edit Network window. Select the Ok button. Now click the Connect
button at the bottom right in the Servers List window to attach to the network and your channels.

9.9.2. Using Konversation
Choose Kickoff Application Launcher → Applications → Internet → IRC Client.

http://konversation.kde.org/
http://konversation.kde.org/
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If you selected the Connect on application startup then Konversation will automatically attach to
your networks and channels.

To customize colors, highlighting, logging, and more, select Settings → Configure Konversation

9.10. ChatZilla
ChatZilla is an IRC chat program from Mozilla. It is easy to use and is a highly extensible IRC
client. It has all the usual features including a built-in list of standard networks, easy searching and
sorting of available channels, logging, DCC chat and file transfers. For more information go to http://
chatzilla.hacksrus.com/faq/.

9.10.1. Installing ChatZilla
You can install ChatZilla using Firefox.
1. Launch Firefox and from the top menu bar select Tools → Add-ons .

2. In the box to the left of the Browse All Add-ons link, type ChatZilla and press Enter.

3. Select Add to FireFox then Install Now. You may get a message to re-start Firefox.

9.10.2. Configuring ChatZilla
1. Open Firefox.

2. On the top menu bar click Tools → Chatzilla.

3. The ChatZilla window opens where you will see the word *Client* as a tab near the bottom. In the
main window are welcome messages with links to additional help and at the bottom of that window
are links to a few of the most popular Networks. If your Network is among them just click on the
link and ChatZilla will attach to it as a new tab.

4. To configure your chosen networks so they automatically connect, go to Chatzilla →
Preferences, make sure that Global Settings is selected and choose the Startup tab. Scroll
down to the Auto-connect URLs window, click Add, and type in your network. For example,
irc://your.network, click OK to add the entry then Ok to exit the preferences window.

5. To configure channels in a network so they automatically connect, select Chatzilla → Preferences
then select the Network and click on the Lists tab. To automatically join a channel, click Add by
the Auto-Perform box and type /join #your-channel then click OK. Add any username to the
Nickname list or the Notify List then click Ok to save all changes.

9.10.3. Using ChatZilla
1. Open Firefox.

2. On the top menu bar click Tools → Chatzilla and you will automatically attach to your networks
and channels.

http://chatzilla.hacksrus.com/faq/
http://chatzilla.hacksrus.com/faq/
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Note
It is not necessary to have your channels connect when you start ChatZilla. Once you

have attached to your networks you can select IRC → Join channel and type in your
favorite channel, or part of it in the Quick Search box. Then click on the Join button when
your channel appears in the box. But you will have to do these steps each time unless you
setup ChatZilla to attach automatically
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Office Applications
In today's communication-oriented world, the ability to create, view, and edit content-rich documents
is an important feature of any operating system. In Fedora, you have the option to select from many of
options when it comes to document and spreadsheet editing.

In Windows, you may have been familiar with the Microsoft Office suite of products. Programs like
Microsoft Word, Excel, and Publisher all have multiple counterparts in the realm of free software. Each
of these free and open source products has a distinct flavor; some are minimalistic with few options
and a simplistic interface, some are feature-rich with capacities even beyond proprietary options,
and many others fall in between these extremes. This chapter will help you survey your options and
choose the right application for you.

10.1. Office Suites Overview
One of the most popular opensource Office Suites is OpenOffice.org. This suite is included with
Fedora and is also available for many other operating systems including Windows. Documentation
for OpenOffice.org is available at http://documentation.openoffice.org/. The OpenOffice.org team
has provided exceptional documentation in the form of an OpenOffice.org manual, entire documents
devoted to using Writer and Impress, and several smaller documentation sets that should answer
any questions you might have about their software. There are also many tutorials available at http://
wiki.services.openoffice.org/wiki/Documentation/Tutorials.

The KOffice suite is optimized for the KDE desktop environment. The KOffice applications also
create documents and files in open standards formats including OpenDocument (.ODF), Rich Text
Format (.RTF), and HTML. Officially, the KOffice FAQ recommends using .RTF or .PDF formats for
compatibility with Microsoft Word.1 KOffice does support Microsoft file formats, but there are issues
with compatibility. For the most up-to-date information on all of KOffice's program offerings, visit the
official KOffice site at http://www.koffice.org/. This site also includes detailed documentation and help
for each individual KOffice program.

GNOME does not provide a suite but instead a number of individual office applications optimized for
GNOME. For more information on using these applications refer to http://live.gnome.org/GnomeOffice

Remember that any office application or suite will run on any Fedora desktop environment. Once

installed, all office tools are available from the Applications →  Office menu in GNOME, the Kickoff
Application Launcher  →  Applications  →  Office menu in KDE, or as icons located in the menu
bar or on the desktop. To install any Office suite or application, refer to Chapter 17, Managing
software. You can install them by either using the PackageKit application or on the command line by
using Yum.

10.2. Word Processing
A word processor is an extension of the classic text editor. While text editors can write and store words
and sentences to files, word processors take this a step further by allowing the user to format his work
with colors and fonts. Word processors also allow users to format the way a document will appear
on the printed page by managing page margins, paper size, and document orientation (portrait or
landscape).

http://www.koffice.org/faq/#AretherefiltersforOpenOfficeWriterMSWordStarWriterRTF

http://documentation.openoffice.org/
http://wiki.services.openoffice.org/wiki/Documentation/Tutorials
http://wiki.services.openoffice.org/wiki/Documentation/Tutorials
http://www.koffice.org/
http://live.gnome.org/GnomeOffice
http://www.koffice.org/faq/#AretherefiltersforOpenOfficeWriterMSWordStarWriterRTF
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This section will explore the popular word processors available in Fedora, and help you become
familiar with the abilities and usage of each.

10.2.1. OpenOffice.org Writer
Writer is the word processing component of OpenOffice.org. Writer is arguably the most powerful
of the open source word processors in the sense that it has the most features. Writer, like all of
OpenOffice.org, is available for most operating systems including Linux, OS X, and Windows.

If you have used a word processor before, Writer may seem immediately familiar to you. The interface
displays a large page where you can type your document, and there are several toolbars across the
top of the window with which you can choose formatting options and advanced features like mail
merging or embeddable media.

From the View menu you can customize which toolbars are visible. Some toolbars will appear as
needed. For example, when a table is inserted, a floating toolbar with options to manage the table

appears. For more information, read Writer's documentation online2 or under Help  →  Contents.

10.2.2. KWord
KWord is the KOffice word processing program. Open KWord by selecting the Kickoff Application
Launcher → Office → Word Processor entry for KWord.

The first window contains options for opening New, Recent or Existing documents, the type of
Template for a new document, as well as a menu bar.

On the menu bar,
• choose File to create a New file, Open, Close or Import a file, or Quit the application.

• choose the Settings drop-down menu select Show Toolbar, Configure Shortcuts or Configure
Toolbars.

• click Helpto open the KWord Handbook or Report a Bug. You can also access the KWord
Handbook by pressing the F1 key.

After selecting a template click the Use This Template button and check the box Always use this
template if you want to make it the program default.

The next window has two menu panels on the top, the document work area on the left, and several
dockers on the right. The Tools Options docker provides text style edits such as bold, italic, and font
type, size, and color. Other Dockers provide shapes, statistics, and tools. Configure dockers and
toolbars from the Settings pull down menu.

The bottom panel shows the number of pages in the document, which page is in the work area window
and the Zoom in percentage.

10.2.3. Abiword
Abiword is a word processor with many of the everyday capabilities of OpenOffice.org Writer or
Microsoft Word, but the omission of some advanced but less used features makes it significantly more
lightweight. Since Abiword does not depend on the Java virtual machine like Writer does, you may find

2 http://www.openoffice.org/product/writer.html

http://www.openoffice.org/product/writer.html
http://www.openoffice.org/product/writer.html
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that it runs more quickly on older machines. Abiword's interface is similar to that of Writer and most
other word processors.

For more information, use Abiword's built-in help or open the online manual at http://
www.abisource.com/support/manual/.

10.3. Spreadsheets
Spreadsheets are commonly used to lay out data in a grid format or for tracking simple financial
information. All of the spreadsheets discussed in this section have the ability to merge cells, split
screens, format text, and define formulas and macros. They also all have some advanced features for
automatic calculations, projections, graphs, and importing of raw data.

10.3.1. OpenOffice.org Calc
Calc is the intuitive, flexible, yet powerful spreadsheet program in the OpenOffice.org suite. When
started, Calc presents a new untitled document with menu and toolbars across the top. On the bottom
are tabs for each sheet and notations of your current location and zoom level.

From the View menu you can customize which toolbars are visible. The Tools and Data menus
allow for advanced data manipulation such as solving optimization problems, creating scenarios
for comparison, and pull in raw data from other databases. For more information, read Calc's

documentation online3 or under Help → Contents.

10.3.2. KSpread
KSpread is the KOffice spreadsheet program. Open KSpread by selecting the Kickoff Application
Launcher → Office → Spreadsheet entry for KSpread.

The first window contains options for opening Recent or Existing documents, the type of Template for
creating a new document, as well as a menu bar.

On the menu bar,
• choose File to create a New file, Open, Close or Import a file, or Quit the application.

• choose the Settings drop-down menu to select Toolbars Shown, Configure Shortcuts or
Configure Toolbars.

• Click Helpto open the KSpread Handbook or Report a Bug. You can also access the KSpread
Handbook by pressing the F1 key.

After selecting a template click the Use This Template button and check the box Always use this
template if you want to make it the program default.

The next window has two toolbar panels on the top, the spreadsheet, spreadsheet tabs running along
the bottom, and dockers on either side with additional tools. Select which toolbars and dockers are
visible from the Settings menu item at the top. You can now add data and formulas, merge cells,
change fonts and colors, insert charts and more.

The row of icons under the top menu bar contains the most frequently used functions plus a few icons
for data manipulation.

3 http://www.openoffice.org/product/calc.html

http://www.abisource.com/support/manual/
http://www.abisource.com/support/manual/
http://www.openoffice.org/product/calc.html
http://www.openoffice.org/product/calc.html
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Several Dockers surround the spreadsheet. The Tool Options shows the contents of the cell and
allows for adding formulas. There are also Styles and Shapes dockers visible by default.

The panel at the bottom shows in bold which spreadsheet is currently selected and how many
worksheets are in the file. Worksheets can be added with a right mouse click on a worksheet tab. This
pop-up window allows Rename the Sheet, Insert, Remove, Hide or Show the Sheet and provides
access to Sheet Properties.

A KSpread tutorial is available at http://docs.kde.org/development/en/koffice/kspread/. You can
download pre-formatted templates and scripts from http://kde-files.org/index.php?xcontentmode=611

10.3.3. Gnumeric
Gnumeric is a spreadsheet optimized for the GNOME desktop. Gnumeric is a good spreadsheet
alternative for those that needs a program which uses less memory then the larger OpenOffice.org or
KOffice suites. In exchange for a lightweight program, Gnumeric has fewer toolbars and not all other
spreadsheet formats can be imported. Gnumeric does have solver, scenario, and simulation tools but
other advanced tools which can be applied to very large sets of data may not be supported.

Start Gnumeric by clicking on Applications  →  Office  →  Gnumeric Spreadsheet in GNOME or

the Kickoff Application Launcher  →  Applications  →  Office  →  Spreadsheet menu entry for
Gnumeric in KDE.

A tutorial on using Gnumeric is available from http://projects.gnome.org/gnumeric/doc/chapter-quick-
start.shtml.

10.4. Presentations
A Presentation program is designed to assist a speaker and energize the audience. Both
OpenOffice.org Impress and KOffice KPresenter offer the ability to create dynamic presentation
containing not only text but also animations, images, sounds, and more.

10.4.1. OpenOffice.org Impress
OpenOffice.org Impress is used to create multimedia presentations. Like many other presentation
programs, Impress supports 2D and 3D clip art, special effects, and animation. Like all OpenOffice.org
components, Impress can import or save as other presentation formats.

When Impress is first opened a presentation wizard launches to assist in the initial layout of a new
presentation. You can open an existing presentation, start an empty presentation, or work on a new
presentation from a template. For new presentations, the wizard then offers a choice of backgrounds
and output mediums followed by a choice of slide transition and presentation types. Finally, when
creating a new presentation, the wizard asks for some basic idea to start your title page. With a
template, the wizard will also offer a choice of pages to include.

Once a presentation is opened, toolbars are placed around the main slide. You can customize which
toolbars are visible from the View menu. Each toolbar can also be undocked and placed in different

locations. For more information, read Impress's documentation online4 or under Help → Contents.

4 http://www.openoffice.org/product/impress.html

http://docs.kde.org/development/en/koffice/kspread/
http://kde-files.org/index.php?xcontentmode=611
http://projects.gnome.org/gnumeric/doc/chapter-quick-start.shtml
http://projects.gnome.org/gnumeric/doc/chapter-quick-start.shtml
http://www.openoffice.org/product/impress.html
http://www.openoffice.org/product/impress.html
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10.4.2. KPresenter
KPresenter is the KOffice application for creating and performing presentations.

Open KPresenter by selecting the Kickoff Application Launcher > Office > Presentation entry for
KPresenter.

The first window contains options for opening Recent or Existing documents, the type of Template or
Screen Presentation you want, as well as a menu bar.

On the menu bar,
• choose File to create a New file, Open or Import a file, or Quit the application.

• choose the Settings drop-down menu select Show Toolbar, Configure Shortcuts or Configure
Toolbars.

• click Helpto open the KPresenter Handbook or Report a Bug. You can also access the KPresenter
Handbook by pressing the F1 key.

After selecting a template click the Use This Template button and check the box Always use this
template if you want to make it the program default.

The next window has two menu panels on the top, a workspace , and a number of dockers with
additional tools. From the top menu, choose Settings to customize which Dockers are visible or
customize the Toolbar or Shortcuts. You presentation can not be created with styles, shapes, text in
different fonts or colors, images, and more.

A KPresenter tutorial is available at http://docs.kde.org/development/en/koffice/kpresenter/. You can
download pre-formatted templates from http://kde-files.org/index.php?xcontentmode=612

10.5. gLabels
gLabels is a light-weight GNOME application for creating labels, business cards, and labels for CD
and DVDs.

Start gLabels by clicking on Applications  →  Office  →  gLabels Label Designer in GNOME or

Kickoff Application Launcher  →  Applications  →  Office  →  gLabels Label Designer in KDE.

When you open a new file from the icon or the menus at the top, you will have a chance to choose a
template for your labels. From the menus or toolbars you can then add objects such as text, box, line,
ellipse, images, or barcodes. You can then resize, move,or align the objects. You can customize the
view, magnification, and toolbars. The panel at the bottom of the work window allows you to configure
the appearance of your data, such as font selection, alignment, bolding, and italics, as well as text and
line color.

For more information on using gLabels, refer to the gLabels website at http://glabels.sourceforge.net/.

http://docs.kde.org/development/en/koffice/kpresenter/
http://kde-files.org/index.php?xcontentmode=612
http://glabels.sourceforge.net/
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Financial software
Fedora offers software financial software for both the GNOME and KDE environments. GnuCash
is the financial software recommended for users with the GNOME desktop environment, and
KMyMoney is recommended financial software for the KDE environment. Although each financial
software application is recommended for a specific desktop environment, remember both will work
on any Fedora desktop environment. Both applications can be used for personal and business, and
configured for online banking.

GnuCash and KMyMoney are not installed by default from the Live or Install DVD. If you do not
have access to the Internet, you can install them from the Fedora Install DVD. Refer to Chapter 17,
Managing software for instructions. You can install them by either using the PackageKit application or
on the command line by using Yum.

11.1. GnuCash
GnuCash allows you to track personal and business bank accounts, stocks, income and expenses,
and is based on double-entry accounting principles.

For additional help using the application, refer to http://www.gnucash.org/docs.phtml documents1.

11.1.1. Configuring GnuCash
To configure GnuCash:
1. Start GnuCash by clicking Applications  →  Office  →  Gnucash Finance Management. Click

the Close button to close the Tip of the Day window.

2. From the Welcome Window select which wizard you want to open and click the OK button.

3. Select Create a new set of accounts and click the Forward button on the New Account
Hierarchy Setup window.

4. Choose your curency and click the Forward button.

5. Select all of the boxes next to the accounts you want to create in the Categories window, then
push the Forward button.

6. Follow the directions in the Setup selected accounts window, then click Forward.

7. Click the Apply button to finish your account setup.

8. To import a Quicken .qif file, select the box then press the Forward button.

9. Select the .qif file to load and click the Forward button.

10. Now you have the option to load more QIF files for additional accounts. Select the Forward
button.

11. Pressing the Forward button guides you through Matching QIF accounts with GnuCash
account, Matching QIF categories with GnuCash accounts, and currency selection.

12. Click the Apply button to import your data, or the Back button to review your matchings.

1 http://www.gnucash.org/docs.phtml

http://www.gnucash.org/docs.phtml
http://www.gnucash.org/docs.phtml
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11.1.2. Using GnuCash
Open GnuCash by selecting Applications  →  Office  →  GnuCash on the top menu panel. The
Accounts tab opens.

The top menu bar allows you to manipulate your accounts. You can:
• Edit, Delete and Create new accounts.

• Set Preferences.

• Schedule Transactions.

• Do transfers.

• Reconcile an account.

• Enter Stock Splits.

• Add Customers, Vendors, and Employees for a business.

• Set Reminders.

• Generate Reports.

• Setup Online Banking.

• Edit Prices of inventory.

• Access the General Ledger.

Double click on an account to bring up a check book type register for that account. The top menu bar
changes to allow manipulation of transactions. This menu includes the options above, plus you can:
• Change the view of the ledger from Basic Ledger to Auto-Split Ledger, Transaction Journal, or

Double Entry.

• Cut, Copy, Paste, Duplicate, Delete, Void, and Enter transactions.

• Set Billing Terms for customers.

• Create Bills, Invoices, and Vouchers.

11.1.3. Setting up online banking
Online banking setup begins from the Accounts window or the Register.
1. On the top menu bar select Tools  →  Online Banking Setup.

2. The Initial Online Banking Setup window lists what you need to complete the setup.

3. Click the Forward button.

4. Select the Start AqBanking Wizard in the Start Online Banking Wizard window.

5. The Configuration window Intro provides a summary of what you can do.

6. Type in the information required in the Users, Accounts, and Backends tabs on the top of the
window.
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7. Select the OFX-Direct Bbackend if you are not sure which one to use.

8. You may need to call your bank to get their server URL. If you chose the OFX-Direct backend it is
likely their URL is https://ofx.yourbank.com/.

9. Return to the Start Online Banking Wizard and click the Forward button.

10. Check the appropriate boxes under the New? column to match the bank accounts with your
GnuCash accounts.

11. Click the Forward button.

12. Click the Apply button to finish.

13. To download your bank transactions select the Accounts or Register tab then: Actions  → 

Online Actions  →  Get Transactions or   →  Get Balance and fill in the information asked for to
complete the operation.

11.2. KMyMoney
KMyMoney Is a double entry accounting software package, for personal and small business use.

For additional help using KMyMoney, refer to http://kmymoney2.sourceforge.net/faq.html.

11.2.1. Configuring KMyMoney
1. Open KMyMoney by selecting Kickoff Application Launcher  →  Applications  →  Office  → 

Personal Finance Manager.

2. Click the Next button on the Welcome to KMyMoney screen.

3. Type in the information and press Next.

4. Select your currency and click Next.

5. Now type in the information for your bank account. Then select Next again.

6. Find your country and click on the + next to its name.

7. Select the type of account you want setup, then click Next. You can select multiple types of
accounts.

8. Press the Next button.

9. You can keep the default path where KMyMoney will save your files, type in a path, or browse by
clicking the button maked with a small folder on the right of the path window.

10. Click the Finish button and your Home window opens.

11. Open the account register by clicking on your account's link in Your Financial Summary window.

12. Click the Show KMyMoney welcome page link at the bottom to:
• Get started and setup my accounts.

• Use an existing KMyMoney data file.

http://kmymoney2.sourceforge.net/faq.html
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• Learn how to use KMyMoney.

• Visit the KMyMoney Website.

• Get help from the KMyMoney community

• See What's New in this Version.

11.2.2. Setting up online banking
1. Click the Institutions icon on the left panel to make sure your bank information is linked to your

new account.

2. Highlight your account under the bank in the main window.

3. On the top menu, choose Account  →  Map Account and the program will load a list of financial
institutions in the Online Banking Account Setup window.

4. Type the name of your bank in the Search bar, or scroll down the list to find it.

5. Click on your bank's name to select it then press the Next button.

6. Fill in your Username and Password.

7. Choose an option for Identify as and click the Next button.

8. This window shows the accounts you have available at the bank. Click on the whichever one you
want to link to your KMyMoney account and click Next.

9. Click the Finish button to complete the setup.

10. Press the blue icon on the top menu to Update the Account or select Account  →  Account
update also on the top menu bar.

11. The program connects to your bank and the Account selection window asks you to which
KMyMoney account you want to download information. You also have the option here to Create a
new account.

12. Select your account and click Ok.

13. The Statement stats - KMyMoney window summarizes the information downloaded. Click the
OK button.

14. Click the Ledger icon on the left menu panel to see the loaded information.
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Playing multimedia

Media formats not supported by default in Fedora
Because of licensing and patent encumbrances, Fedora cannot ship with certain audio
and video playing capabilities, known as codecs. An example is the MP3 codec. Refer to
Section 12.1, “The Fedora Project's approach to multimedia support” for more information.

Fedora includes several tools for listening to audio and viewing video on both the GNOME and
KDE desktops. These applications will run in either Fedora desktop environment. To install software
packages not already installed, refer to Chapter 17, Managing software. You can install applications by
either using the PackageKit application or on the command line by using Yum

Fedora provides the following applications for audio and video by default:
• Amarok is a music player that features tools for organizing music, CDs, Internet radio stations, and

more, and is included in KDE by default.

• Brasero is an application for copying and making audio, video, and data CDs and DVDs in
GNOME.

• Cheese Webcam Booth takes photos and videos with your webcam is installed in GNOME and
KDE.

• Dragon Player is a simple video player in KDE.

• JuK is a collection and playlist manager as well as a music player installed in KDE.

• Kaffeine is an application for viewing videos in KDE.

• KMix is a Sound Mixer for KDE.

• KsCD is an application for listening to audio CDs in KDE.

• Rhythmbox is a music player that features tools for organizing and listening to music, CDs, Internet
radio stations, and more, and is included in GNOME and KDE by default.

• Sound Juicer is an application for converting CDs to music files (also known as ripping) in GNOME
and KDE.

• Sound Recorder can record and play .flac, .oga (OGG audio), and .wav sound files.

• Totem Movie Player is an application for viewing videos in GNOME and KDE.

To open these programs, in the GNOME desktop, click on their entries in the Applications → Sound
and Video menu in the top menu bar. In the KDE desktop, click on their entries in the Kickoff
Application Launcher → Applications → Multimedia menu.

12.1. The Fedora Project's approach to multimedia support
In short, the Fedora Project encourages the use of open formats in place of restricted ones.
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Fedora includes complete support for many freely-distributable formats. These include the Ogg media,
Vorbis audio, Theora video, Speex audio, and FLAC audio formats. These freely-distributable formats
are not encumbered by patent or license restrictions, and provide powerful and flexible alternatives
to popular yet restricted formats such as MP3 that are not legally distributable with Fedora. For more
information, refer to the Fedora Multimedia wiki at https://fedoraproject.org/wiki/Multimedia.

12.2. Cheese Webcam Booth
Cheese Webcam Booth takes photos and videos with your webcam.

12.2.1. Using Cheese Webcam Booth
The top menu provides the following operations and options:
• Selecting Cheese you can choose to turn on the Countdown timer, Take a photo or Record,

depending on if you selected Photo or Video button, see the Fullscreen, and Quit the application.

• Edit lets you turn on Effects, Move to Trash, Move All to Trash, and change the Preferences.

• Clicking on Help > Contents, or pressing F1, opens the Cheese Manual.

The tabs, between the windows, are shortcuts of the choices in top menu.

More information is available on the Cheese website at http://www.gnome.org/projects/cheese

12.3. Rhythmbox Music Player
Rhythmbox Music Player plays CDs, internet radio, and is a music collection manager.

The first time you launch the Rhythmbox Music Player, an assistant will help you import your music.
On the second panel of the assistant, click the Browse button and select the folder where your music
is stored, normally in your home directory under Music.

12.3.1. Using Rhythmbox Music Player
The main functions of the Rhythmbox Music Player window are:
• The top panel Menubar which has all of the menus to perform tasks. Press F1 or click Help →

Contents on the menubar to open the manual.

• The second Toolbar panel accesses the player functions and provides details about the track that
is playing.

• A Time Slider, under the Toolbar panel, displays the position of the read of a track and allows you
to jump to another part of a track.

• In the left window the Source List lets you access your music library, internet radio, internet,
your portable music player, your playlists, and CDs. This consists of:
• The Rhythmbox Music Player library, where all of the imported tracks are saved.

• The Radio with internet radio stations.

• Podcasts.

• Online Stores:

https://fedoraproject.org/wiki/Multimedia
http://www.gnome.org/projects/cheese
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• All Playlists (normal and smart).

• Audio CDs inserted into the computer's drives.

• Portable players, such as an MP3 player, plugged in to your computer.

If you have a wheel mouse you can adjust the volume by placing the cursor on the volume icon and
turning the wheel.

In the Browser, the rectangle window right of the Source List, you can browse and filter the Library
tracks by genre, artist, or album name. It also provides a Search function.

The Tracks list is the bottom window and contains the lists of the tracks that belong to the source you
selected.

The Statusbar is the panel that runs along the bottom that displays information about the source you
selected.

Visit the Rhythmbox website at http://projects.gnome.org/rhythmbox/ for more information.

12.4. Audio CD Extractor (Sound Juicer)
Audio CD Extractor (Sound Juicer) lets you extract the audio from CDs and convert them to audio
files your computer can play. This program also plays CDs.

12.4.1. Using Sound Juicer
To enter track data, insert an audio CD and Sound Juicer will locate and retrieve the data from
MusicBrainz (a free service). If MusicBrainz cannot match the CD you have the option to enter
the track information manually. The notifier will also ask you if you want to submit your album to
the MusicBrainz database. You will need to open a MusicBrainz account to submit albums to their
database.

To enter track data manually:
1. Fill in the text boxes for the title, artist, year, and genre of the CD.

2. Below that is a list of the audio tracks on the CD. You can determine the track title and artist for
each track.

To edit the title of a track, first select the track, then click on the title. When you have finished entering
the title, press the Enter key. Each track of the CD is automatically updated if they matched the artist
before the edit.

Extracting Track Data:
1. Select the tracks you want to save by clicking on the boxes in front of the tracks. You can also use

Edit → Select All or Edit → Deselect All.

2. Click the Extract button. This will change to a Stop button when the program begins to extract the
data. You will see an icon next to the track being extracting.

Press F1, or Help → Contents to see the manual.

For more information see the Sound Juicer website at http://burtonini.com/blog/computers/sound-juicer

http://projects.gnome.org/rhythmbox/
http://burtonini.com/blog/computers/sound-juicer
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12.5. Sound Recorder
Sound Recorder can record and play .flac, .oga (OGG audio), and .wav sound files.

12.5.1. Using Sound Recorder
• From the top menu select File → New, or press the New button on the second panel.

• On the Record as drop-down menu choose what type of file you want to record to.

• Press the red Record button or select Control → Record from the top menu to start recording.

• Press the Stop button or use Control → Stop, on the top menu, to end the recording.

• Press the Play button or Control → Play to start the play-back.

• To open the audio mixer select File → Open Volume Control.

• To save your file choose File → Save As, and name your sound file.

• You can play an existing sound file by clicking the Open button, or selecting File → Open on the top

menu, choose the file and click the Open button. Now press the Play button, or select Control →
Play, to play the selected file.

• Selecting File → Properties displays information about the current sound file.

• Access the Sound Recorder manual by choosing Help → Contents or press the F1 key.

12.6. Totem Movie Player
Totem Movie Player plays DVDs, CDs, and VCDs.

12.6.1. Using Totem Movie Player
• To open an audio or video, file, select Movie → Open Select the file you want and click the Add

button. You can also drag a file in to the Totem Movie Player window. If Totem Movie Player
displays error messages when you try to play a file, refer to the information about codecs at http://
www.gnome.org/projects/totem/#codecs.

• Click Movie → Open Location to open a file by URL location.

• Movie → Play Disc will play a DVD, VCD, or CD.

• Movie → Eject will eject the disc.

• Under the Eject option is the Playlist.

• Movie → Play and Movie → Pause will play or pause the disc.

• Choosing Movie → Properties opens the sidebar which displays the properties of the file.

http://www.gnome.org/projects/totem/#codecs
http://www.gnome.org/projects/totem/#codecs
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• From the Edit menu you can Take a Screenshot or Create a Screenshot Gallery, turn the Repeat
Mode or Shuffle Mode on or off, Clear the playlist, configure Plugins and set Preferences.

• View allows you to go to Fullscreen, Fit Window to Movie, set the Aspect Ratio, Switch Angles,
Show Controls, Subtitles, and show, or hide, the Sidebar.

• Go will let you go to the DVD, Title, Audio, Angle and Chapter menus, the Next Chapter or Movie
the Previous Chapter or Movie, Skip to a track, and Skip Forward or Backwards.

• The Sound drop-down menu lets you change Language and turn the Volume Up or Down.

• You can open the manual by selecting Help → Contents or pressing the F1 key.

For more information visit the Totem Movie Player website at http://projects.gnome.org/totem/.

12.7. GNOME multimedia applications

12.7.1. CD/DVD Creator
CD/DVD Creator is a CD and DVD burner.

12.7.1.1. Using CD/DVD Creator
To open select System → CD/DVD Creator. You can access the Help manual can be accessed by

pressing the F1 key or clicking Help → Contents on the top menu bar.

To create a data disc:
1. Drag the files and folders, that you want to write to CD or DVD, to the CD/DVD Creator folder.

2. Insert a writeable CD or DVD into your writer device. Doing this step first usually opens the CD/
DVD Creator automatically. You can configure the CD/DVD Creator to open automatically by

going to System → Preferences → Hardware → Multimedia Systems Selector and on the
Audio and Video tabs select Autodetect from the drop-down menu.

3. Click the Write to Disc button, or choose File → Write to CD/DVD. Choose to write to your CD/
DVD or to a File Image. An image file (ISO) is a normal file that will be saved to your computer
and you can write to a CD later.

You can type a name for your CD or DVD in the Disc name window and select a Write speed
from the drop-down under Write Options. You will also see the size of your data that will be
written to the disc.

4. Press the Write button to copy your data to the CD/DVD.

To write a disc image to a CD/DVD, right-click on the Disc Image File, then choose Write to Disc
from the popup menu.

To make a copy of a CD or DVD
1. Insert the disc you want to copy.

2. Choose Places → CD/DVD Creator from the top panel menu bar.

http://projects.gnome.org/totem/
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3. Right-click on the CD icon, and choose Copy Disc.

4. Follow the Write to Disc dialogue as above.

If you have only one write drive the program will first create a file on your computer. The original
disk will be ejected, and ask you to change it for a blank disk to copy on.

12.8. GNOME multimedia applications in the repository
These applications are not usually installed by default but are in the repository. To install these
packages, refer to Chapter 17, Managing software. You can install applications by either using
PackageKit or on the command line by using Yum.

12.8.1. Brasero
Brasero can burn music or data to a CD. Refer to Section 6.2.3, “Using Brasero in GNOME” or the
Brasero website at http://projects.gnome.org/brasero for more information.

12.8.2. GNOMEBaker
GNOMEBaker can burn music or data to a CD. the GNOMEBaker website at http://www.biddell.co.uk/
gnomebaker.php for more information.

12.9. KDE multimedia applications
The KDE desktop groups multimedia applications together in the Kickoff Application Launcher >
Applications > Multimedia menu.

12.9.1. Amarok
Amarok is a CD player and music collection manager. For more information refer to the Amarok
website at http://amarok.kde.org/

12.9.1.1. Using Amarok
• Click Play Media to play existing sound files, go to a Previous Track, Play/Pause, Stop go to the

Next Track or Quit the application.

• Playlist lets you Add Media, Add Stream, Save Playlist, Undo, Redo, Clear Playlist, Repeat and
choose Random play.

• Tools lets you access the Cover Manager Script Manager and to Update Collection.

• Under Settings you can Configure Shortcuts and Configure Amarok.

• Clicking Help > Amarok Handbook, or pressing the F1 key opens the manual.

• On the left side of the application window you can select the Files you want to play, Playlist,
Collections or access the internet for music, podcasts and radio stations. Details about your
selection are displayed in the window to the right.

• The bottom center icons are: + adds a widget, - deletes a widget, the arrows let you go to a
Previous or Next Group, and you can Zoom in or out.

http://projects.gnome.org/brasero
http://www.biddell.co.uk/gnomebaker.php
http://www.biddell.co.uk/gnomebaker.php
http://amarok.kde.org/
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• In the Playlist window you can do a Search, go to the Next or Previous selection, and Search
Preferences. The options along the bottom allow you to Clear Playlist, Show Active Track, Undo,
Redo, Save a Playlist, and Export a Playlist As.

12.9.2. Dragon Player
Dragon Player is a simple video player. For more information refer to the Dragon Player website at
http://dragonplayer.org/

12.9.2.1. Using Dragon Player
• When you first open Dragon Player a pop-up window asks what you would like to Play File or Play

Disc. If you choose one of these the program loads the file. You can also Close the window or Quit
the application.

• Selecting Play > Play Media allows you to play a DVD, VCD, or Video File, Play/Pause lets you
pause and re-start the movie, Stop will stop the playback, and Quit closes the application.

• The Settings menu lets you choose the Full Screen Mode, Aspect Ratio, Subtitles, Audio
Channels, to Configure Shortcuts and Toolbars or to Show Toolbar.

• Help > Dragon Player Handbook, or pressing the F1 key, opens the manual.

12.9.3. JuK
JuK is a collection and playlist manager as well as a music player. For more information refer to the
JuK website at http://developer.kde.org/~wheeler/juk.html

12.9.3.1. Using JuK
• When the application opens you can choose to Add or Remove a Folder, and Import playlists,

from the pop-up window.

• Selecting File on the top menu bar, you can choose to open a New file, Open an existing file,
Add Folder, Rename, Edit, Search, Duplicate, Reload, Remove Save, Save As or Quit the
application.

• Edit allows you to Undo, Cut, Copy, Paste, Clear or Select All.

• Under View you can configure JuK to Show the Search Bar, Show Tag Editor, Show History,
Show Play Queue or Columns, Resize Playlist Columns Manually and View Modes (Default,
Compact or Tree).

• From the Player drop list you select to Random Play, Loop Playlist, Play, Pause, Stop, Next,
Previous and Play the Next Album.

• Tagger lets you Save or Delete tags, Refresh, Guess Tag Information open the Cover Manager
and Rename a File.

• From the Settings menu you can choose which Toolbars to display, Show Splash Screen on
Startup, Dock in System Tray, Stay in System Tray on Close, Open Track Announcement, Tag
Guesser, File Renamer and Configure Shortcuts or Toolbars.

http://dragonplayer.org/
http://developer.kde.org/~wheeler/juk.html
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• The second menu panel displays icons of the most used commands, which are also located in the
top menu bar.

• The right window is home to your collection or playlist.

• The main window displays information about the file, such as: Track Name, Artist, Album, Cover,
Track, Genre, Year and Length.

• To open the manual select Help > JuK Handbook or press the F1 key.

12.9.4. Kaffeine
Kaffeine is a media player that can play streaming content, DVBs, DVDs, and CDs. To get
streaming content over the web, you need a Mozilla plug-in for the program, which is available
from http://sourceforge.net/project/downloading.php?groupname=kaffeine&filename=kaffeine-
mozilla-0.2.tar.bz2&use_mirror=internap. For more information about Kaffeine generally, refer to the
JuK website at http://kaffeine.kde.org/

12.9.4.1. Using Kaffeine Media Player
The first window that opens contains five shortcut icons:
• Play Playlist takes you to a current playlist.

• Audio CD encoding will help you rip tracks from a CD.

• Play Audio CD plays a CD.

• Play DVD plays a DVD.

• Play VCD plays a VCD.

On the left side of the window are four small icons:
• The KDE icon on top brings up the first window, wherever you are in the program.

• The Kaffeine icon opens the Player Window.

• Clicking the next icon opens the Playlist.

• The disc icon takes you to the Play CD window that lists the details of the CD.

The toolbar along the bottom of this window allows you to Play, Pause, Skip Backward or Forward,
Stop, and Adjust the Volume.

The top menu panel has:
• File which allows you to Open a File, URL or Directory, Open a DVD, VCD, Audio CD and

Network Broadcasting. You can also Save Stream, Save a Screenshot, Quit with Options, or
Quit.

• From the View menu you have the options for the Full Screen Mode, Minimal Mode, Toggle
Playlist/Player, Enable Auto Resize or Keep Original Aspect.

• Selecting Player gives you the option to Play, Pause, Stop, go to the Next track or Previous track,
Fast Forward, Slow Motion, and Jump to Position. You can also Navigate a DVD, CD, Video,
configure Subtitles, access Track Info and enable or disable Plugins.

http://sourceforge.net/project/downloading.php?groupname=kaffeine&filename=kaffeine-mozilla-0.2.tar.bz2&use_mirror=internap
http://sourceforge.net/project/downloading.php?groupname=kaffeine&filename=kaffeine-mozilla-0.2.tar.bz2&use_mirror=internap
http://kaffeine.kde.org/
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• The Playlist drop-down lets you Shuffle, Repeat, Download covers, Clear Current Playlist, start
a New Playlist, Import, Save or Remove a Playlist.

• Settings allow you to select a Player Engine (Xine or GStreamer), choose the Toolbars,
Configure Shortcuts, Toolbars and Kaffeine Player, and to set xine Engine Paramenters.

• Clicking Help > Kaffeine Player Handbook or pressing the F1 key, opens the manual.

12.9.5. KMix
KMix is a sound mixer that allows you to control volume settings for sound inputs to and outputs
from your computer. For more information refer to the KMix website at http://docs.kde.org/stable/en/
kdemultimedia/kmix/index.html

12.9.5.1. Using KMix Sound Mixer
The application window has three sections with different controls: Output, Input and Switches. These
sections contain volume sliders, switches for enabling/disabling record or playback, and multiple-
choice selectors.
• Output controls are playback-related, like the Master volume control.

• Input controls are recording-related, like Capture.

• Switches has all controls allowing you to switch some functionalities ON or OFF (like Mic Boost
(+20dB)), and multiple-choice controls (like Mic Select: Mic1 or Mic2).

KMix also features LEDs.
• Green for playback

• Red for recording

• Yellow is for special soundcard functions

Most of these controls have a context menu, you can access by a right mouse click on the icon.
• For Split Channels the right slider controls right side volume, and the left controls left side volume.

• Muted can be on or off.

• You can select Hide to hide this device

To configure KMix from the menubar choose Preferences > Use Settings > Configure KMix The
options are:
• Dock into panel will dock in the systray when pressing the window Close button.

• Show labels will display labels for each of the sound devices.

• Show lines to mark positions on the sliders.

12.9.6. KsCD
KsCD is a simple CD player.

12.9.6.1. Using KsCD
The button cluster on the left side contains:

http://docs.kde.org/stable/en/kdemultimedia/kmix/index.html
http://docs.kde.org/stable/en/kdemultimedia/kmix/index.html
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• Play in the center.

• Previous to the left.

• Next on the right side.

• Stop on the bottom.

• Eject on the top.

The center window displays information about the file being played.

The icons along the bottom allow you to setup Random play, Loop, Tracklist, and Mute.

The three buttons on the top and center right are:
• Volume control – place your cursor on the white dot, hold down the right mouse key and drag it to

the desired level.

• The - button lets you minimize KsCD.

• The X icon closes the application.

12.10. Multimedia applications in the repository
The applications below are not usually installed by default but are in the repository. To install these
packages, please read Chapter 17, Managing software. You can install applications either by using the
PackageKit application or on the command line by using Yum.

12.10.1. K3b
K3b is a CD and DVD burning application. Refer to Section 6.2.2, “Using K3b to burn media in KDE”
or the K3b website at http://www.k3b.org/ for more information.

12.11. MP3 players
Personal digital media players can be used to store and listen to music away from a computer. These
are often referred to as MP3 players, which is a potentially misleading name. Not all of these players
use MP3 files to store music.

Many MP3 players can be mounted as storage mediums, and music can be added to them just like a
file can be added to any other disk. See Chapter 6, Media for more information.

Some players, however, require special applications to transfer music.

12.11.1. Grip
Grip is a CD player and a ripper for the GNOME desktop. It provides an automated frontend for MP3,
and other audio format, encoders, letting you transform the disc straight into MP3s. Internet disc
lookups are supported for retrieving track information. Details are available on the Grip website at
http://nostatic.org/grip/doc/index.html

Grip is not installed by default but it is in the repository for installation with either using the
PackageKit application or on the command line by using Yum. Refer to Chapter 17, Managing
software for more information.

http://www.k3b.org/
http://nostatic.org/grip/doc/index.html
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12.11.2. iPod connectivity
There are several high-quality tools available for Linux users to manage media content on the iPod.
Among them are gtkpod, YamiPod, and tools built into media players such as AmaroK, Rhythmbox,
and Banshee.

Gtkpod is not installed by default from the Live-CD or the DVD. If you do not have access to the
Internet, you can use the Fedora DVD to install Gtkpod. You can install applications by using
PackageKit , or on the command line by using Yum. Refer to Chapter 17, Managing software for
more information.

Start Gtkpod by clicking Applications → Music and Video → gtkpod in GNOME or Kickoff
Application Launcher → Applications → Multimedia → iPod Manager.

For further help on iPod support through Gtkpod, refer to the Gtkpod website at http://
www.gtkpod.org/about.html.

12.12. Further information
For more information on freely-distributable formats and how to use them, refer to the Xiph.Org
Foundation's web site at http://www.xiph.org

http://www.gtkpod.org/about.html
http://www.gtkpod.org/about.html
http://www.xiph.org
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Playing games
A Fedora installation includes a selection of games by default. You can also select additional game
packages during or after installation. To install new games on your Fedora system, refer to Chapter 17,
Managing software. Most packages have games as part of their name. You can find more information
about games for Fedora at https://fedoraproject.org/wiki/Games. For more information about the
games in this list, refer to the Help menu within each individual game.

You do not need to switch desktops to play games
You can play KDE games while logged into GNOME and GNOME games while logged
into KDE. Graphical environment components are very modular. When you install the
game packs any dependencies will also be installed. You may need additional packages
to view the online help.

13.1. Default GNOME games
Many GNOME games are not installed by default from the Live-CD or the DVD. If you do not have
access to the Internet, you can use the Fedora DVD to install them, either using the PackageKit
application or on the command line by using Yum. Refer to Chapter 17, Managing software for help
installing new software. Be sure to also install the separate Help Files for gnome-games which
provides the instruction for playing each game.

With the Help Files for gnome-games installed, use the menus to navigate to System  →  Help  → 
Games to view a list of the available games. There is a brief description along with a link to details

about playing each game. The detailed instructions can also be found from the Help  →  Contents
menu in each game.

There are a handful of small games in the basic GNOME games pack.
Aisle Riot Solitaire

is a collection of solitare card games.

Iagno
is a A Reversi-like disk flipping game.

Mines
is a clone of a popular puzzle game.

Sudoku
is popular logic puzzle where you place numbers in a grid.

Additional games are in a package called gnome-games-extra. These games provide a variety of
styles and genres including board games such as Chess, card games such as Freecell, puzzle games
such as Klotski, arcade games such as Robots, and tile matching games such as Mahjongg. These
are only a sampling of the games provided.

13.2. Default KDE games
Many KDE games are not installed by default from the Live-CD or the DVD. If you do not have access
to the Internet, you can use the Fedora DVD to install them, either using the PackageKit application

https://fedoraproject.org/wiki/Games
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or on the command line by using Yum. Refer to Chapter 17, Managing software for help installing new
software. The kdegames package contains games for the current version of KDE and the kdegames3
package contains additional games which have not yet been ported to KDE4.

The KDE games pack includes popular games similar to those provided by the GNOME games pack
such as Kfourinline, Kbots, Ksudoku, Kreversi, and many more. A sampling of other games included in
the KDE games pack that may not be in other game packs include:
Bomber

An arcade bombing game

Kapman
Pac-man type game

KAtomic
Fun and educational game built around molecular geometry

KBlackBox
Find the balls hidden in the black box by shooting laser beams

KGoldrunner
A Lode Runner type of game

KJumpingCube
A territory capture game

KNetWalk
A network construction game

Kolf
A little mini-golf game

Kollision
A ball dodging game

Konquest
A galactic space game

KSquares
Connect the dots to make squares

Kubarick
3D game based on Rubik's Cube

LSkat
A card game

Shisen-Sho
A mahjongg like game
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Managing photos
Most USB-compatible cameras will work automatically with Fedora and require very little configuration.
If your digital camera offers a choice of USB connection types, set the camera's USB setting to PTP,
or point-to-point mode. Consult your camera's user manual to determine if this option is available and
how to choose it. If it is not available, the default settings should be sufficient.

14.1. Connecting Your camera
To connect the camera to your Fedora system:
1. Make sure your camera is powered off.

2. Connect a USB cable from the camera to your computer.

3. If your camera requires you to select a knob or dial setting before connecting it to a computer,
make that selection now.

4. Power the camera on.

When your camera powers on, Fedora will recognise the device and launch any software that you
have configured to import and manage photos, for example the Shotwell Photo Manager on the
GNOME desktop or the digiKam photo management program on the KDE desktop.

14.2. Managing photos on the GNOME desktop
After your camera powers on, an informational window should appear on your desktop. From the drop-
down menu you can select:
• Open with Shotwell Photo Manager. When the Shotwell window appears, select your camera

in the left hand pane. When Shotwell asks if it can unmount the camera from the filesystem, click
Unmount. Your photos will appear in the main pane. Select the photos you want to import and
choose Import Selected, or choose Import All.

• Open folder to view the files in the file manager.

• Open with Other Application and select the appropriate application.

If you decide you do not want to import photos, click the Do Nothing button. If you do not want to see
this dialog each time you connect a camera, you can select the Always perform this action option in
conjunction with any option to make the choice permanent.

Other ways of accessing your photos are:
• Click on the desktop device icon that contains the photos.

• Click Places on the top menu bar, and then click the camera or other device that stores your photos.

14.2.1. Organizing and viewing photos
If you have imported your photos using Shotwell, click on Photos in the left hand pane to view them.
You can use Shotwell's powerful event and tagging features to group your photos and make them
easier to manage.
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14.2.1.1. Categorising by Event
When you import your photos, Shotwell looks for information embedded by the camera in the images
indicating the time and date at which they were taken. You can then browse your photos by date by
clicking on Events in the left hand pane. A single photo representing all the photos taken on each date
will appear in the main pane. Double-click on a specific date to see all the photos taken on that date.

You can rename each event to something more appropriate by right-clicking on the date in either pane
- for example, 'Fri 25 Dec 2009' can become 'Christmas Day'. You can also merge events into longer
timeframes - for example, 'Christmas Eve', 'Christmas Day' and 'Boxing Day' can be merged into a
single event called 'Christmas'.

14.2.1.2. Categorizing by Tag
You can add tags to your photos by selecting them in the main pane and choosing Tags  →  Add
Tags.... To add more than one tag at once, enter them as a comma-separated list, without spaces.

Once you have added your tags, a new menu option called Tags will appear in the left hand pane.
Click on a tag name to see all the photos under that tag. You can modify, rename and remove tags by
selecting the appropriate option in the Tags menu.

14.2.1.3. Publishing Photos to the Web
You can publish your photos to Facebook, Flickr or Picassa Web Albums from within Shotwell. Select
the photos you want to publish in the main pane and click Publish in the bottom bar, or choose File 
→  Publish... in the top menu bar. A dialog box will appear in which you can select the service you
want to publish to, and log in if you are not already logged in.

When you log in via Shotwell for the first time, you must allow Shotwell Connect to be enabled on
your account. Once this has been set up, you will be given options regarding the size and viewing
permissions of the uploaded photos. Select your desired options and choose Publish. Your photos will
now be uploaded to your online account.

14.3. Managing photos on the KDE desktop
The KDE desktop uses digiKam to import and organize your photos. DigiKam also provides image
editing features through the showFoto program.

When you turn on a camera connected to your computer, or plug in device containing photos such
as a USB flash drive, Fedora will notify you by opening a window from the Device Notifier located at
the left of the KDE panel. If you do not see a window, click the Device Notifier to open the window
manually. You should see the camera or other storage device listed in the window. Click on the device,
and a dialog box will open to ask What do you want to do?. Click Download Photos with digiKam
and OK.

14.3.1. Importing photos with digiKam
When you first start digiKam, it prompts you for a default location in which to store your photos, and
will suggest the Pictures folder inside your Home folder. It will also ask for a location to store a
database that it will create to store information about your photos. DigiKam will use this database
to help you organise and manage your photos and will again suggest the Pictures folder as the
location for this database. For both the default picture location and the database location, you can type
in the name of a folder on your computer, browse to a folder by clicking on the folder icon, or accept
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the defaults. When you have made your choices, click OK and the main digiKam window will open,
together with a separate window to show you the files on the camera or storage device.

In this dialog, you can select or deselect photos to import by clicking on the corresponding thumbnail.
To select all photos, click any photo and then press the key combination Ctrl+A. To deselect all
photos, press Ctrl+Shift+A. Once you have selected all the photos that you want to import, click
the Download Selected button. To cancel the import process before you begin the download, close
the window. To cancel the process once the download is underway, click the Cancel button.

DigiKam asks you for a name for this group of pictures, which it calls an album. Either click on an
existing album on the list, or click New Album and provide a name for the album. DigiKam will
suggest the current date as a name for the album, but you might want to choose a name that will
better help you to remember the subject of these photos. When you have selected an album, click OK
and digiKam will import the photos to your computer.

To clear the photos from your camera, click Image  →  Delete Selected to delete just the images you

imported to your computer, or click Image  →  Delete All to delete all images from your camera.

14.3.2. Organising photos with digiKam
A tag is a piece of information that you add to digiKam's database that helps you to identify a photo
again in future. For example, you might tag a photo with the names of the people who appear in it, the
location at which that the photo was taken, or the name of an occasion.

To tag an image, right-click on it, then click Apply Tag, then place checks against one or more tags
from the list. To add a new tag to the list, click Add New Tag and then apply it to the photo. When
digiKam displays the image in future, any tags that you have applied will appear below the picture.
Applying tags does not alter the photo itself, and you will not damage your photo by tagging it.
DigiKam stores tags separately from the photos.

To search for images with a particular tag, click the Search button, type the tag into the search box,
and press Enter. DigiKam will display all the images to which you have applied that tag.
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Sharing your desktop

Use this capability carefully
Remote desktop sharing can be a serious security risk. You should leave it turned on only
when needed and should not leave it active.

Fedora lets you share your desktop remotely across a network, so that a user at a different computer
can view and – with your permission – interact with your computer. This is useful for receiving
technical support from a remote location or for demonstrating a desktop feature to another user. You
may also find it to be a useful way to remotely access files on your desktop from another computer.

Fedora uses a method called Virtual Networking Computing (VNC) to enable remote desktop sharing.
Therefore, the remote viewer must use VNC as well. Apple OS X uses VNC by default, but Microsoft
Windows uses a different method to share desktops, called Remote Desktop Connection (RDC).
To access your Fedora desktop from a computer with a Microsoft Windows operating system, that
computer will need a VNC viewer. TightVNC is a free and open-source VNC program available for
Linux and Microsoft Windows from http://www.tightvnc.com/.

15.1. GNOME
To activate desktop sharing, select System  →  Preferences  →  Remote Desktop from the user
menu. This opens the Remote Desktop Preferences window.

To share your desktop securely:
1. Under Sharing, tick the box labeled Allow other users to view your desktop.

2. Next, tick the box next to Allow other users to control your desktop.

3. Under Security, tick the box next to You must confim each access to this machine.

4. Next, check Require the user to enter this password and enter a password. This should not be
your account's password; pick a new password that you will only reveal to the remove viewer.

5. Finally, click on the Close button.

Be sure to inform the person performing remote technical support or remote viewing the assigned
password. When the person connects to your desktop, click on the Yes button when asked for
confirmation.

Once the remote viewing feature is no longer needed, turn off desktop sharing:
1. Select System  →  Preferences  →  Remote Desktop.

2. Uncheck the Allow other users to view your desktop box.

3. Click the Close button.

http://www.tightvnc.com/
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15.2. KDE
To activate desktop sharing in KDE, select Kickoff Application Launcher  →  Applications  → 

System  →  Desktop Sharing. This opens the Desktop Sharing control module window. There are
two methods by which you can share your desktop:
• You can create an invitation. By default, invitations are only valid for one hour. This lessens the

chance of forgetting to disable Desktop Sharing, and is a good option if you only need it enabled
temporarily.

• You can leave Desktop Sharing turned on at all times.

To create a Desktop Sharing invitation, open the Desktop Sharing window as described above, click
New Personal Invitation and give the information to the person you want to invite. Alternatively you
can share the same information via email by clicking on New Email Invitation.

If you want to have Desktop Sharing running at all times:
• In the Desktop Sharing window, click Configure  →  Security then check the box Allow uninvited

connections.

• Next, check Confirm uninvited connections before accepting (optional, but recommended).

• If you wish to approve each connection individually check Ask before accepting connections

• A password should be set for security; enter one in the Uninvited connections password: box.
This should not be your user account password.

• Select the Network tab at the top of the window, check Use default port and make a note of the
port listed.

• Finally, click on the Apply button followed by the OK button.

The person connecting to your computer remotely will need your IP address or hostname, followed by
a : and the port number that you noted above. When the person connects to your desktop, click on
the Yes button when asked for confirmation.

Once the remote viewing feature is no longer needed, turn off desktop sharing:
1. Select Kickoff Application Launcher  →  Applications  →  System  →  Desktop Sharing.

2. Uncheck the Allow uninvited connections box.

3. Click the Apply button.

15.3. Other desktops
Various desktop environments may offer their own graphical assistants for desktop sharing, but the
VNC server program can be used from the command line to accomplish this task on almost any
desktop environment. Setting up this service is beyond the scope of this guide.
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Customizing the desktop
Fedora allows you to customize the "look and feel" of your desktop environment. All of the settings that
determine the appearance of your desktop are referred to collectively as a theme.

16.1. Changing the theme
Most desktop environments, including GNOME and KDE, allow you to install new themes to tweak
the appearance of the desktop. The process for installing a theme varies for each desktop. You can
find the process for installing themes under GNOME and KDE in this chapter, and most desktop
environments include installation instructions in their own documentation.

16.1.1. Changing the theme in GNOME
To change the desktop theme, choose System  →  Preferences  →  Appearance. The Appearance
Preferences window appears with the Theme tab selected. To change the theme, select one from the
list, the theme will be applied automatically.

Fedora's repositories include many other themes that you can install, in the gnome-themes-extra
package. You can install gnome-themes-extra by either using the PackageKit or on the command line
by using Yum. Refer to Chapter 17, Managing software for instructions.

When the gnome-themes-extra is installed on your computer, the themes can be selected by using the
Appearance program described in this section.

16.1.2. Changing the theme in KDE
By default KDE uses Oxygen as its theme, with many more available from http://www.kde-look.org/.

To change the theme, click Kickoff Application Launcher  →  Computer  →  System Settings  → 
Appearance. Expand the Appearance item and click Style.

To change the theme, select one from the list and click the Apply button at the bottom of the window.

You can download additional icons and themes for KDE by installing the kdeartwork-icons and
kdeartwork packages. You can install these packages by either using the PackageKit or on the
command line by using Yum. Refer to Chapter 17, Managing software for instructions.

16.2. Changing the background

16.2.1. Changing the background in GNOME
To change the background image on your desktop, right-click on an empty area of the desktop, and
select the Change Desktop Background option. The Appearance Preferences window appears
with the Background tab selected. To change your desktop background, choose a new image from
the list. You can add your own images by clicking the Add button.

To set a color or gradient, select Vertical gradient and make your choice of Solid color, Horizontal
gradient, or Vertical gradient. Then click the color bars next to the gradient window and select the
colors you want.

http://www.kde-look.org/
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16.2.2. Changing the background in KDE
To change the background in KDE, right click an empty area of the desktop, and select the Desktop
Activity Settings option. When the Desktop Setting - Plasma Workspace window appears, you
can select a new wallpaper style from the drop-down menus, or get new ones by clicking the Get New
Wallpapers... button.

16.3. Customizing file browsing behavior

16.3.1. Customizing file browsing behavior in GNOME
By default, GNOME uses the Nautilus file manager. New in Fedora 13, Nautilus defaults to opening in
Browser mode which use one window with Forward and Back buttons. You can change this behavior
to the previous default where a new window is opened each time you open a folder.

To change this, double-click on Computer on the desktop, click Edit and then Preferences. You can

also select Places  →  Computer  →  Edit  →  Preferences from the menu panel. Click the Behavior
tab and click on the box next to the text Open each folder in its own window.

To install a program that modifies several aspects of using Nautilus. Install Gtweakui which enables
you to modify your GNOME desktop quickly and easily.

Applications  →  Add/Remove Software then searching for gtweakui will provide the program to

install. The program's location can be found under System  →  Preferences.

16.3.2. Customizing file browsing behavior in KDE
By default, KDE uses the Dolphin file manager. To modify the appearance of Dolphin windows, open

the program by clicking the Kickoff Application Launcher  →  Applications  →  System  →  File
Manager icon for Dolphin. At the top of the Dolphin window, click Settings  →  Configure Dolphin.
The tabs in the Dolphin Preferences window allow you to specify the folder that Dolphin displays
when it starts, the size of the icons it displays, the font it uses to label icons, and many other options.

16.4. Customizing input methods
For many people, there is a need to switch between input methods such as Japanese or Chinese
character sets. This is handled in Fedora 13 by ibus. The default keyboard shortcut to enable and
disable input methods is Control+Space. Once enabled, the default keyboard shortcut to cycle
through input methods is Alt+Shift.

To enable, disable, or select the type of input method in GNOME, click System  →  Preferences  → 

Input Method or in KDE, click Kickoff Application Launcher  →  Applications  →  Settings  → 
Input Method. You can also get to these settings from the command line with im-chooser. Once
enabled, configure the preferences by clicking the Input Method Preferences button. The first tab
allows you to customize the keyboard shortcuts. The second tab allows you to add and remove input
methods and set the prefered input method. The third tab has advanced settings. You can customize
preferences later by right clicking the ibus applet and selecting Preferences or from the command line
with ibus-setup.
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16.5. Compiz-Fusion
The Compiz Fusion Project brings 3D desktop visual effects that improve usability of the X Window
System and provide increased productivity though plugins and themes contributed by the community
giving a rich desktop experience.

Note
There may be problems with running Compiz Fusion if you do not have a 3D-capable
video card.

The Fedora Project does not enable Compiz Fusion by default and therefore, if you want to use it,
you will need to install it first. Refer to Chapter 17, Managing software for instructions on managing
software. You will need the compiz-gnome or compiz-kde depending on which desktop you use.

When you have installed Compiz Fusion, you can launch the program by selecting System  → 

Preferences  →  Desktop Effects in GNOME or Kickoff Application Launcher  →  Applications  →
Settings  →  Compiz Switcher in KDE.

16.6. Widgets>

16.6.1. GDesklets
GDesklets are Calendar, Weather, and Quote of the day widgets for the GNOME desktop. To install

them go to Applications  →  Add/Remove Software then go to the Search tab and search for
gdesklets. GDesklets is the program that needs to be installed and the other programs listed are the
plugins. You will need to install both GDesklets and the GDesklets-goodweather plugin. They can
also be installed by using Yum at the command line.

When you have installed the software, you can access GDesklets by going to Applications  → 

Accessories  →  Gdesklets. This will load up a program with all available plugins. Select the
uncategorized category and double-click GoodWeather Display.

After a few moments the the desklet will appear on the desktop and allow you to move it to a preferred
location on the desktop.

Note
Where you initially place it is not important. The desklet can be moved at any time by
right-clicking on the desklet and choosing move desklet

To configure the the weather gdesklet, right-click and select configure desklet. A dialog will appear
with general settings. Modifying the location can be done by going to http://www.weather.com/. At
the very top of the weather.com website is a search box for local weather information. Type in the
location. After searching the code for the location will be found in the url. For example, the weather for
Perth, Australia is at the following link:http://www.weather.com/outlook/travel/businesstraveler/local/
ASXX0089?from=search_city.

http://www.weather.com/
http://www.weather.com/outlook/travel/businesstraveler/local/ASXX0089?from=search_city
http://www.weather.com/outlook/travel/businesstraveler/local/ASXX0089?from=search_city
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To use that information, note the location code – in this example, ASXX0089 – enter it into the weather
desklet, and select Close button. The weather information will be available after the next update
interval.

To get additional plugins visit http://gdesklets.de/

16.6.2. KDE plasmoids
Plasmoids are widgets for the KDE desktop. You can add plasmoids by clicking the plasma toolbox
icon located at the top right of the desktop or right-hand edge of the panel and then clicking Add
Widgets.... You can also add plasmoids by right-clicking on the desktop and panel and clicking Add
Widgets....

When you install the KDE desktop, a number of plasmoids are installed on your system by default,
although most of them are not visible until you add them to your desktop or panel. These include
various clocks, calendars, small games, and widgets that present you with information about the
status of your computer hardware or about multimedia files as you play them. When you click the Add
Widgets... menu option, the plasma toolbox presents you with a list of the widgets currently available
to you, along with short descriptions of each one. The plasma toolbox also gives you the option to
Get New Widgets either by downloading from KDE-Look.org, or by installing ones that you have
previously downloaded and saved to your computer.

http://gdesklets.de/
KDE-Look.org
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Managing software

17.1. Using PackageKit
Fedora 13 uses a program called PackageKit to graphically assist the user with installing and
removing software. Any application from the Fedora repositories, including the ones described in this
user guide, can be installed with the following method.

17.1.1. Installing software
Here is how to install software using Add/Remove Software in the GNOME desktop environment.

Click System  →  Administration  →  Add/Remove Software. This will open the Add/Remove
Software application.

In the Search Box with the magnifying glass icon, type the name of the application you wish to install.
If you are unsure of the specific application you need to install, you can also type keywords in this box,
just like you would for an internet search engine.

Next, click the Find button – The message Querying appears in the lower left corner breifly and then
zero or more listings will appear that match your search query.

Tick the box next to the description of the application or applications you wish to install. The message
Downloading repository information appears in the lower left corner. The window area
below the list of packages contains additional information about the selected software.

Select any additional packages to install or remove at this time by changing tick boxes next to the
package name.

Finally, click the Apply button. This starts the installation process and concurrently installs or removes
any additional packages where you modified the tick box. Follow any prompts to install additional
packages.

Unless an error is displayed, the application is now installed (or removed) on your computer.

17.1.2. Removing software
To remove software using PackageKit, you should follow the standard installation procedure,
but untick boxes beside the programs you wish to uninstall instead of ticking boxes to install new
programs.

Click System  →  Administration  →  Add/Remove Software. This will open the Add/Remove
Software application.

In the Search Box with the magnifying glass icon, type the name of the application you wish to
remove. If you are unsure of the specific application you need to remove, you can also type keywords
in this box, just like you would for an internet search engine.

Next, click the Find button. The message Querying appears in the lower left corner briefly then zero
or more listings will appear that match your search query.

Untick the box next to the description of the application or applications you wish to remove.
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Software Installed Outside of PackageKit
If the box is already unticked, then the program is probably not already installed. If you
are sure that you have selected the right application, but it still appears to not be installed,
then it may have been installed using a method other than PackageKit. If, for example,
the program was compiled and installed from source, then it may not register as installed
in PackageKit. If this is the case, you will need to find an alternate method of removing it.
If it was installed from source, you may find more information in the source distribution's
Readme file.

The message Downloading repository information appears in the lower left corner. The
window area below the list of packages contains additional information about the selected software.

Select any additional packages to install or remove at this time by changing tick boxes next to the
package name.

Finally, click the Apply button. This starts the removal process and concurrently installs or removes
any additional packages where you modified the tick box. Follow any prompts to remove additional
packages, such as dependencies that only your newly uninstalled program relied upon.

Unless an error is displayed, the application is now removed from your computer.

17.2. Using the command line interface
Another way to install or remove an application is to use the command line and Yum, the Yellowdog
Update Manager. This can be a much faster process than the PackageKit method, but requires the
user to use the command line. If this feels uncomfortable, the PackageKit method may be a more
familiar way to manage software.

17.2.1. Installing software
Click Applications  →  System Tools →  Terminal to open the command line.

Type:

su -c 'yum install application'

Where application is the name of the program you wish to install.

If you are unsure of the exact name of your desired installation, you can search your installed
repositories for a keyword:

su -c 'yum search keyword'

Where keyword is the word you wish to search for among the names and descriptions of programs in
the available repositories.

After using the yum install command, you will be prompted for the computer's root password. Type
in the root password and press Enter. You will not see the password as you type. The terminal will
start giving information about the application, and end with Is this ok [y/N]:. Oftentimes, the
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installation of an application will require that other programs, called dependencies, are installed as
well. These are programs or utilities upon which your selected application relies.

If you wish to continue installation after seeing the dependencies and their disk space requirements
(which may be unexpectedly considerable), type:

y

The terminal downloads the necessary files and completes the installation of your application.

17.2.2. Removing software
Click Applications  →  System Tools  →  Terminal to open the command line.

Type:

su -c 'yum remove application'

Where application is the name of the program you wish to remove.

If you are unsure of the exact name of your desired installation, you can search your installed
repositories for a keyword:

su -c 'yum search keyword'

Where keyword is the word you wish to search for among the names and descriptions of programs in
the available repositories.

After using the yum remove command, you will be prompted for the computer's root password. Type
in the root password and press Enter. You will not see the password as you type. The terminal will
start giving information about the application, and end with Is this ok [y/N]:. If dependencies
that were installed with the application are unneeded by other applications, you may be prompted to
remove these as well.

If you wish to continue the software removal, type:

y

The terminal deletes the necessary files and completes the removal of your application.

17.3. Advanced Yum

Advanced usage
This content is written for the more advanced user. It assumes that you are comfortable
with the command line and have a relatively good knowledge of Linux terminology. It is
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probably not necessary to using Fedora as a desktop user, but can help a desktop user
expand their knowledge base and face more complicated troubleshooting issues.

Use the Yum utility to modify the software on your system in four ways:

• to install new software from package repositories.

• to install new software from an individual package file.

• to update existing software on your system.

• to remove unwanted software from your system.

Installing Software from a Package File
The Yum commands shown in this section use repositories as package sources. Yum can
also install software from an individual package file. This advanced usage is beyond the
scope of this Guide.

To use Yum, specify a function and one or more packages or package groups. Each section below
gives some examples.

For each operation, Yum downloads the latest package information from the configured repositories.
If your system uses a slow network connection yum may require several seconds to download the
repository indexes and the header files for each package.

The Yum utility searches these data files to determine the best set of actions to produce the required
result, and displays the transaction for you to approve. The transaction may include the installation,
update, or removal of additional packages, in order to resolve software dependencies.

This is an example of the transaction for installing tsclient:

=============================================================================
Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
tsclient                i386       0.132-6          base              247 k
Installing for dependencies:
rdesktop                i386       1.4.0-2          base              107 k

Transaction Summary
=============================================================================
Install      2 Package(s)
Update       0 Package(s)
Remove       0 Package(s)
Total download size: 355 k
Is this ok [y/N] :

Example 17.1. Format of Yum transaction reports

Review the list of changes, and then press Y to accept and begin the process. If you press N or Enter
, Yum does not download or change any packages, and will exit.
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Package Versions
The Yum utility only displays and uses the newest version of each package, unless you
specify an older version.

The Yum utility also imports the repository public key if it is not already installed on the rpm keyring.
For more information on keys and keyrings, refer to the Fedora Security Guide.

This is an example of the public key import:

warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
public key not available for tsclient-0.132-6.i386.rpm
Retrieving GPG key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
Importing GPG key 0x4F2A6FD2 "Fedora Project <fedora@redhat.com>"
Is this ok [y/N] :

Example 17.2. Format of Yum public key import

Check the public key, and then press Y to import the key and authorize the key for use. If you press N
or Enter, Yum stops without installing any packages. Ensure that you trust any key's owner before
accepting it.

To ensure that downloaded packages are genuine, Yum verifies the digital signature of each package
against the public key of the provider. Once all of the packages required for the transaction are
successfully downloaded and verified, yum applies them to your system.

Transaction Log
Every completed transaction records the affected packages in the log file /var/log/
yum.log. You may only read this file with root access.

17.3.1. Installing new software with Yum
To install a generic package my-package, enter the command:  su -c 'yum install my-
package'  Enter the password for the root account when prompted.

To install a package group PackageGroup, enter the command:  su -c 'yum groupinstall
"PackageGroup"'  Enter the password for the root account when prompted. Examples of package
groups include MySQL Database and Authoring and Publishing.

New Services require Activation
When you install a service, Fedora does not activate or start it. To configure a new service

to run on bootup, choose System  →  Administration  →  Services from the top desktop
panel, or use the chkconfig and service command-line utilities. See the man pages
for more details.
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17.3.2. Updating software with Yum
To update the generic package my-package to the latest version, type:  su -c 'yum update my-
package'  Enter the password for the root account when prompted.

New Software Versions Require Reloading
If a piece of software is in use when you update it, the old version remains active until the
application or service is restarted. Kernel updates take effect when you reboot the system.

Kernel Packages
Kernel packages remain on the system after they have been superseded by newer
versions. This enables you to boot your system with an older kernel if an error occurs with
the current kernel. To minimize maintenance, yum automatically removes obsolete kernel
packages from your system, retaining only the current kernel and the previous version.

To update all of the packages in the package group PackageGroup, enter the command:  su -c
'yum groupupdate "PackageGroup"'  Enter the password for the root account when prompted.

Updating the Entire System
To update all of the packages on your Fedora system, use the command: su -c 'yum
update' Enter the password for the root account when prompted.

17.3.3. Removing software with Yum

Data and Configuration File Retention
The removal process leaves user data in place but may remove configuration files in some
cases. If a package removal does not include the configuration file, and you reinstall the
package later, it may reuse the old configuration file.

To remove software, Yum examines your system for both the specified software, and any software
which claims it as a dependency. The transaction to remove the software deletes both the software
and the dependencies.

To remove the generic package my-package from your system, use the command:  su -c 'yum
remove my-package'  Enter the password for the root account when prompted.

To remove all of the packages in the package group PackageGroup, enter the command:  su -c
'yum groupremove "PackageGroup"'  Enter the password for the root account when prompted.
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