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1 Welcome to FTS

Welcome to Frontline Test System (FTS). The design of FTS allows you to conduct data
analysis of protocols using your personal computer. The FTS interface is easy to use without
training, but we recommend you read the online Help to take maximum advantage of all the
features.

We designed the online Help System with complete explanations and easy to use systematic
instructions. Access the online Help by choosing Help Topics from the Help menu, or by
pressing the F1 key on any window.
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2 Getting Started

2.1 Opening Frontline Bluetooth low energy Analyzer

On product installation, the installer creates a folder on the windows desktop labeled
Frontline Bluetooth low energy Analyzer.

1. Double-click the Frontline Bluetooth low energy Analyzer desktop folder

This opens a standard Windows file folder window.

Mame - | Swe| Twpe | Date Modiied I
23 Dptional Components FleFokder  1/15/20091.31 PH
5 etup FisFolder  1/15/20091:31 PH
%Em Fibe Viwer IKB Shotcut  1/15/20091:31 PM

Fibeticn Dlsloon IoN Sney AnoEs] 2K Shortcuwt  1/15/20091.31 PM
B Ouack-Stent Giuade 2KB Shotowt 141522009131 PM

2. Double-click on Frontline Bluetooth low energy Analyzer and the Chose Protocol to
Analyze dialog appears.

Choose Protocol to Analpre, ..

= 3 | Blustooth low enegy Sniffing
{2 Bhsetooth low ereigy
=3 High Speed Senal Srafing [optional]
HCE - BLSP
HCI - B4
HE1 - HaDs
HEl - M5
H5U
= =y USE HCI H2 Sniffing
Faw USE packets - ISE ComPrcbe Il [optianal]
: LI5E ComProbe || [optional)
= o5 Vihual Eri‘!ng
) FT5 Side
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Note: You can also open the application by selecting Start > All Programs > Frontline
Bluetooth low energy Analyzer (Verstion #) > Frontline Bluetooth low energy Analyzer.

This dialog lists all the methods FBLEA supports in a tree control.

Two buttons appear at the bottom of the dialog; Run and Cancel.

Fun starts FTS using the selected protocol stack.

closes the dialog and exits the user back to the desktop.

3. Expand the folder and select the data capture method that matches your configuration.

Creating a Shortcut

A checkbox labeled Create Shortcut When Run is located near the bottom of the dialog.
This box is un-checked by default. Select this checkbox, and the system creates a shortcut
for the selected method, and places it in the FBLEA desktop folder and in the start menu
when you click the Run button. This function allows you the option to create a shortcut icon
that can be placed on the desktop. In the future, simply double-click the shortcut to start the
analyzer in the associated protocol.

2.2 Control Window

The analyzer displays information in multiple windows, with each window presenting a
different type of information. The Control window provides access to each window as well
as a brief overview of the data in the capture file. Each icon on the toolbar represents a
different data analysis function.

Because the Control window can get lost behind other windows, every window has a Home

icon that brings the Control window back to the front. Just click on the Home icon to
restore the Control window.

When running the Capture File Viewer, the Control window toolbar and menus contain only
those selections needed to open a capture file and display the About box. Once a capture file
is opened, the analyzer limits Control window functions to those that are useful for
analyzing data contained in the current file. Because you cannot capture data while using
Capture File Viewer, data capture functions are unavailable. For example, when viewing
Ethernet data, the Signal Display is not available. The title bar of the Control window
displays the name of the currently open file. The status line (below the toolbar) shows the
configuration settings that were in use when the capture file was created.
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2.3 Low Energy Control Window Toolbar

Available options are in color, while unavailable options are grayed out. All toolbar icons
have corresponding menu items. Toolbar icon displays vary according to operating mode
and/or data displayed.

Open File - Opens a capture file.

/0 Settings - Opens the /0 Settings dialog.

Start Capture - Begins data capture to disk.

E @ 3 [

Stop Capture - Available after data capture has started. Click to stop data
capture. Data can be reviewed and saved, but no new data can be captured.

Clear - Clears or saves the capture file.

Event Display - (framed data only) Opens a Event Display, with the currently
selected bytes highlighted.

Frame Display - (framed data only) Opens a Frame Display, with the frame of
the currently selected bytes highlighted.

Protocol Navigator - (framed data only) Opens the Protocol Navigator window,
with the currently selected frame highlighted.

& @ 8 v~

Audio Extraction - Opens the Audio Extraction dialog.

2.4 Drop-Down Menus

The menus that you see on the Control Window and dialogs like Frame Display and Event
Display vary depending on whether the data is being captured live or whether you are
looking at a .cfa file. You will see File, View, Live, Options, Window, and Help. Most of the
options are self explanatory.

e Many of the File menu items are standard Windows type commands: Open, Close,
Save, Recent Files, etc. There are two exceptions:

¢ Recreate Companion File. This option is available when you are working
with decoders. If you change a decoder while working with data, you can
use Recreate Companion File to recreate the .frm file, the companion file to
the .cfa file. Recreating the .frm file helps ensure that the decoders will work

properly.
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¢ Reload Decoders. When Reload Decoders is clicked, the plug-ins are reset
and received frames are redecoded.

e Under the View menu you can choose which FTS windows are available to open.
e Live contains commands that used in capturing data.
e Under Options you have opportunities to set/modify various system settings.

e The Window menu displays the open FTS dialogs and standard options like
Cascade, Minimize, Tile, etc.

e Within the Help menu you can open the electronic Help file, About FTS, and access
the FTS web site for additional help.

2.5 Configuration Information on the Control Window

The Configuration bar (just below the toolbar) displays the hardware configuration and may
include I/0 settings. It also provides such things as name of the network card, address
information, ports in use, etc. If the analyzer cannot find the MAC Address, it lists zeroes
after the NIC name.

2.6 Status Information on the Control Window

The Status bar located just below the Configuration bar on the Control window provides a
quick look at current activity in the analyzer.

e Capture Status displays Not Active, Paused or Running and refers to the state of data
capture.

o0 Not Active means that the analyzer is not currently capturing data
0 Paused means that data capture has been suspended

0 Running means that the analyzer is actively capturing data.

)}
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e 9% Used

0 The next item shows how much of the buffer or capture file has been filled.
For example, if you are capturing to disk and have specified a 200K capture
file, the bar graph tells you how much of the capture file has been used.
When the graph reaches 100%, capture either stops or the file begins to
overwrite the oldest data, depending on the choices you made in the System
Settings.

e Utilization/Events

0 The second half of the status bar gives the current utilization and total
number of events seen on the network. This is the total number of events
monitored, not the total number of events captured. The analyzer is always
monitoring the circuit, even when data is not actively being captured. These
graphs allow you to keep an eye on what is happening on the circuit, without
requiring you to capture data.

2.7 Frame Information on the Control Window

Frame Decoder information is located just below the Status bar on the Control window. It
displays two pieces of information.

IF-:ur Help Press F1 Frame Decoder (233 fps)  BEaleEE R EESS Tn]n ks

e Frame Decoder (233 fps) displays the number of frames per second being
decoded. You can toggle this display on/off with Ctrl-D, but it is available only
during a live capture.

e #132911 displays the total frames decoded.
e 100% displays the percentage of buffer space used.

2.8 Determining Master and Slave

In Bluetooth®, the device that initiates the connection is always the master at connection
time. You only need to know the master and slave at connection time when setting up the

[/0 Settings. Afterwards a role switch may occur, but the analyzer automatically follows the
role switch.

Role Switches
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After the connection has been made, a role switch can take place. A good example of why
this happens would be when a mouse connects to the PC. The mouse initiates the
connection, so it is the master. After the connection is made, a role switch occurs so that the
PC becomes the master and the mouse becomes a slave. The role switch takes place because
the PC may be working with multiple devices at the same time, and as such, the PC would
not be a slave of more than one device.

Let us say that a piconet exists between a PC and a keyboard with the PC a master. If the
mouse wants to become a member of the piconet it initiates the connection. Since the
mouse initiated the connection, it is the master of a new piconet and the PC is the slave. The
PC is still the master of the piconet between the PC and keyboard. A role switch now occurs
between the PC and the mouse, and the PC is now the master of a piconet with two slaves:
the mouse and keyboard.

2.9 Using more than one additional ComProbe® when sniffing a
link

There will be instances when you will want to use one or more additional ComProbe when
sniffing an FTS4BT a Low Energy Analyzer link. The procedure for doing that appears
below

4. Locate the file Bluetooth air.personality, which will be in C:\Program Files\Frontline
Test System II\Frontline FTS4BT [version #]\App Data\Decoders\Bluetooth.

5. Find the section titled [Personality' FTS4BT Generic Scatternet]

6. Locate the line:CmdLine="/mem=FTS4BT=generic" "/dspath=.\btcpds.exe"
"/Mode=Scatternet”

7. On the end of that, add "/dsnum=n", where n is the number of packet sniffers you need
to use.

For example, if you wanted to use three packet sniffers, the line would read:

CmdLine="/mem=FTS4BT=generic" "/dspath=.\btcpds.exe"
"/Mode=Scatternet” "/dsnum=3"

8. Save the file.

Note: Be sure to include the quotes.
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2.10 Minimizing Windows

Windows can be minimized individually or as a group when the Control window is
minimized.

To minimize windows as a group:

1. Go to the Window menu on the Control @ window

2. Select Minimize Control Minimizes All. The analyzer puts a check next to the menu
item, indicating that when the Control window is minimized, all windows are
minimized.

Select the menu item again to deactivate this feature.

4. The windows minimize to the top of the operating system Task Bar.
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3 low energy Configuration Settings

3.1 Status

The Status dialog is one of the three tabs that appear when you first start the Bluetooth®
low energy Analyzer.

‘. Bluetooth low encrgy datasource

Fiz View Bhetooth bow enesge  Help
@ O+,
N

Status |10 Sattings | Hardware Settings |

Master: N
Sl Hode
Current Long
Term Key:
[Ho Bhstocth ow energy ComProbes connected,

Chutsrying o firmware ids

FisHC Opan( ) (dewics - 1]
FieHCa: Open() [device - 2]
FiabHCl: Openi) (devics - 3)
FleHCI: Open) [devics - 4]
Fimished querying 1or Brmmaang s

Note: You can also access these three dialogs by selecting I/O Settings or Hardware
Settings from the Options menu on the Control Window toolbar.

Status is strictly a display dialog. You cannot change/add data on this dialog.
There are two pieces of information on this display.

e The device addresses for the active Bluetooth devices are displayed for the Master
and Slave. You select the device addresses on the 10 Settings dialog. The Status will
display None, Random, or Public.

e The Current Long Term Key is displayed.

e The current firmware IDs for the four transports are displayed.

11
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Toolbar Options.

e Start button @ to begin sniffing. All settings are saved automatically when you
start sniffing.

e Stop Sniffing ™ button to stop the sniffing.

e Save button E to save the configuration. All settings are saved automatically
when you start sniffing.

Menu Options:

e File: Save I/0 Settings, Save hardware Settings, Exit

e View: Toolbars (hides or displays toolbar)

e Bluetooth low energy: Start Sniffing and Stop Sniffing

e Help: Help (opens help file), About Bluetooth low energy

3.2 Bluetooth® low energy Analyzer - Hardware Settings

The Hardware Settings dialog is one of the three tabs that appear when you first start the
Bluetooth® low energy Analyzer.

¥ Bluetooth low energy dalasource E| o E|

File View Bluetooth low energy  Help

@ ll Lﬁ
Status | [0 Settings | Hardware Settings
FLEOR11 - Refrash Device List
Firmvesare Yershn:

1 oxifsf

12
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Note: You can also access these three dialogs by selecting 1/0 Settings or Hardware
Settings from the Options menu on the Control Window toolbar.

There are two pieces of information on this display.

e Hardware Settings identifies the label for the ComProbe(s) that are attached in a
drop-down list.

e The current firmware is displayed under Firmware Version.
If you want to load the latest firmware, you select the Update Firmware button.

Toolbar Options.

e Start button @ to begin sniffing. All settings are saved automatically when you
start sniffing.

e Pause button to stop the sniffing

e Save button E to save the configuration. All settings are saved automatically
when you start sniffing.

Menu Options:

e File: Save I/0 Settings, Save hardware Settings, Exit
e View: Toolbars (hides or displays toolar)
e Bluetooth low energy: Start Sniffing and Stop Sniffing

e Help: Help (opens help file), About Bluetooth low energy

3.3 Bluetooth® low energy Analyzer - Update Firmware

When you select the Update Firmware on the Hardware Settings, the Update Bluetooth
low energy ComProbe firmware dialog appears. You use this dialog to update your
ComProbe with the latest firmware.

Note: There are two ways to update firmware: (1) via USB or (2) parallel port.

e USBis the most common method for updating the firmware.

13
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e You can also use the parallel port (a converter is included with the FBLEA software)
, but the port on the PC must be a true parallel port, which is rare in current PC’s.
Using the parallel port does not require installing any drivers.

Update Bluetooth low energy ComProbe firmmware

Trarsport | USB 3P (183531)

Fils UsiULP stack_ursigrisd. ooy

Stabus:  Ready

|
e

There are several important concepts to remember in respect to updating firmware.

e You must do this process three (3) times to completely update the ComProbe's
firmware.

e You must not remove any connections to the ComProbe while the firmware is being
updated. If you do, the following error message appears.

M Bluetooth low energy datasource

!E i vk, Feendeves Ay CORNCions Lo the ComProbe whils the firmsvars update & in progress!

[ o ]

1. Make sure the cabling is attached to port 1 on the ComProbe

Transport

Transport displays the ID number for the transport device(s) that you have connected. The
device(s) will either be a USB to SPI converter or a SPI to LPT converter.

2. Select the file location that contains the firmware update by clicking the Browse button.

The firmware update file is located at: C:\Program Files\ Frontline Test System I\ Frontline
Bluetooth low energy Analyzer [version #]\ Bluetooth low energy ComProbe Firmware\Drivers

After you select the file you are ready to complete the download.

14
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3. Select Flash Device.

The download begins, with the Status bar displaying the progress. When the download is
complete, you can check the firmware version by checking the Status dialog.

It's very important that you perform this update a total of three times to completely update
the ComProbe's firmware. If the firmware versions are not the same, you will not be able to
start sniffing.

3.4 1/0 Settings

3.4.1 Bluetooth® Low Energy Analyzer - [/O Settings

The 10 Settings dialog is one of the three tabs that appear when you first start the
Bluetooth® low energy Analyzer.

¥ Bluctooth low encrgy datasource
Fie View Blueiooth low eneigy  Help

UL

Status 10 Settings | Hardware Settings |
Addresses:

Masher:
r | Hone |

Save: swa |

£ [ Hene F |

Pairing:
PIN [ 008 dats: |

Enscryplion:
Long Term Key: |
Cipkions:
W Data Whitening

W Sniffer Clagnostics

Note: You can also access these three dialogs by selecting I/O Settings or Hardware
Settings from the Options menu on the Control Window toolbar.

1. Select an address for the Master device from the drop-down list.

15
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You have three options for the Master address.
¢ You can select None, which assigns no address to the Master

¢ You can select an address, then check the Random checkbox, which assigns a
Random label to the adddress.

e You can select an address, then leave the Random checkbox unchecked, with assigns
a Public label to the address.

2. Select an address for the Slave device from the drop-down list.

You have three options for the Slave address.
e You can select None, which assigns no address to the Slave.

e You can select an address, then check the Random checkbox, which assigns a
Random label to the address.

¢ You can select an address, then leave the Random checkbox unchecked, with assigns
a Public label to the address.

Note: You can select the Swap button to swap the chosen address for the Master and Slave.

3. Enter a PIN or out-of-band (OOB) value for Pairing.

This is extra information that can make the pairing process more efficient and consistent.
Click here to learn more about the possible Pairing values.

4. Enter the Long Term Key for the Encryption.

Data Whitening - Data whitening is done in order to randomize the data from highly
redundant patterns and to minimize DC bias in the packet.

5. Select the checkbox to activate Data Whitening.

Sniffer Diagnostics - When this is checked, some diagnostic data from the ComProbe® is
captured and stored in the .cfa file. This is useful when a .cfa file is sent to Frontline for
analysis and diagnosis. Technical support may ask you to check this option when you are
experiencing issues with Frontline Bluetooth low energy Analyzer.

6. Select the checkbox to activate Sniffer Diagnostics.

16



frontline

Debug Communications Faster!sv

Toolbar Options.

e Start button @ to start sniffing. All settings are saved automatically when you
start sniffing.

e Pause button to stop the sniffing

e Save button E to save the configuration. All settings are saved automatically when
you start sniffing.

Menu Options:

e File: Save I/0 Settings, Save hardware Settings, Exit
e View: Toolbars (hides or displays toolar)
e Bluetooth low energy: Start Sniffing and Stop Sniffing

e Help: Help (opens help file), About Bluetooth low energy

3.4.2 Extended Inquiry Response

Extended Inquiry Response (EIR) is a tab that appears automatically on the Frame Display
window when you capture data.
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EIR displays extensive information about the Bluetooth® devices that are discovered as
data is being captured. Before the EIR tab was created, this type of information was not
available until a connection was made to a device. Therefore, EIR can be used to determine
whether a connection can/should be made to a device prior to making the connection.

Note: If a Bluetooth® device does not support Extended Inquiry Response, the tab displays
Received Signal Strength Indication (RSSI) data, which is less extensive than EIR data.

1/0 Settings

3.4.3 Selecting a Custom Protocol Stack

To change the protocol stack:

1. Click on the Custom Protocol Stack button % to start the Protocol Stack Wizard.

If you are capturing framed data but did not select a protocol stack before capturing, your
data needs to be framed. To frame your data, complete the following steps:

1. Select a protocol stack.

2. Go to the Control window and choose Reframe from the File menu. See Reframing a
Function for more information.
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3.4.4 1/0 Settings Dialog in Capture File Viewer

The /0 Settings dialog only appears when viewing serial data. It displays the settings that
were in effect when the file was captured. The window looks different depending on
whether you are viewing asynchronous or synchronous data.

When using capture file viewer, the /0 Settings dialog is grayed out except for the Custom
Protocol Stack button and the Names button.

The analyzer knows which protocols were used when the file was captured, and
automatically decodes the data in the file according to those protocols. If you need to change
the protocol, click the Custom Protocol Stack button to create a custom stack.

Click the Names button to change the labels for errors, control signals and the sides
displayed in the other windows of the analyzer.

3.4.5 Saving Configurations

3.4.5.1Saving a Configuration to a File

1. Setup your configuration on the I/0 Settings window.

2. Ifaconfiguration is already open and you have altered it, go to the File menu and choose
Save As; otherwise, click on the Save Settings icon.

3. Inthe File name box, type a name for your configuration. You do not need to add an
extension. the system adds a .cfg extension automatically.

4. By default, the analyzer saves the configuration in the My Configurations directory.
Choose a different directory to save the configuration elsewhere. Click here to see how
to change the default location for configurations.

5. Click on Save.

If you make a new configuration and do not save it, the system asks you if you want to save
your configuration when you exit the program. If you want to save your configuration,
choose Save and the Save File dialog box appears. If you do not want to save your
configuration, choose Cancel.

3.4.5.2 Opening a Saved Configuration File

1. Click on the Open Configuration icon, or choose Open Configuration from the File menu
on the [/0 Settings dialog. If other configurations have been used recently, a menu
listing the last four configurations used is displayed.

2. Select a recent configuration file, or choose Open to load an unlisted configuration.

3. Ifyou have saved your configurations in the default directory, they are listed in the
window. Choose a different directory if your configurations are saved elsewhere.

4. Select the configuration you want to use, and click on Open.
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Configurations are saved with a .cfg extension, and are located in the C:\Program
Files\Common Files\FTE\My Configurations directory by default.

The name of the open configuration file is displayed at the top of the Set I/O Configuration
window. If no configuration file is open, "Untitled" is displayed.

3.5 Port Assignments

3.5.1 Adding or Changing Port Assignments

The analyzer autotraverses the stack from TCP, UDP and IPX based on the source or
destination port number. Many systems use user-defined port numbers for both standard
and custom protocols. Here’s how to tell the analyzer about a custom port assignment on
the system you are monitoring.

Add a New Port Assignment

1. Choose Set Initial Decoder Parameters from the Options menu on the Control @
window.

2. Click the TCP tab (or UDP or IPX for those protocols).
3. Choose the Single Port radio button, and enter the port number in the Port Number box.
4. Inthe Protocol drop-down list, choose the protocol to traverse to.

5. Click the Add button. The system adds new entry to the bottom of the port number list.

Modify an Existing Port Assignment

1. Choose Set Initial Decoder Parameters from the Options menu on the Control window.
2. Click the TCP tab (or UDP or IPX for those protocols).

3. Select (click on and highlight) the port assignment to modify.

4. Change the port number and/or choose the protocol to traverse to.

5. Click the Modify button. The system displays the changes in port number list.

6. You can also specify a range of ports. Select the Port Range radio button and specify the
starting and ending port numbers. The range is inclusive.

7. Toremove an entry, select the entry and click Delete.

Two considerations are:
e The analyzer traverses an entry if either the source or destination port match

e The analyzer processes port number entries in order from top to bottom

20



frontline

Debug Communications Faster!sv

If you need to move an entry to ensure it is processed before or after another entry, select
the entry in the list and then click the Move Up or Move Down buttons.

3.6 Decoder Parameters

Some protocol decoders have user-defined parameters. These are protocols where some
information cannot be discovered by looking at the data and must be entered by the user in
order for the decoder to correctly decode the data. For example, such information might be
a field where the length is either 3 or 4 bytes, and which length is being used is a system
option.

If you have decoders loaded which require decoder parameters, a window with one tab for
every decoder that requires parameters appears the first time the decoder is loaded.

For help on setting the parameters, click the Help button on each tab to get help information
specific to that decoder.

If you need to change the parameters later,

e Choose Set Initial Decoder Parameters from the Options menu on the Control, Frame
Display or Protocol Navigator windows.

e Each entry in the Set Initial Decoder Parameters dialog takes effect from the
beginning of the capture onward or until redefined in the Set Subsequent Decoder
Parameters dialog.

The Set Subsequent Decoder Parameters dialog allows the user to override an existing
parameter at any frame in the capture where the parameter is used.

If you have a parameter in effect and wish to change that parameter
e Select the frame where the change should take effect

e Select Set Subsequent Decoder Parameters from the Options menu, and make the
needed changes.

e Each entry in the Set Subsequent Decoder Parameters dialog takes effect from the
specified frame onward or until redefined in this dialog on a later frame.

If you do not have decoders loaded that require parameters, the menu item does not appear
and you don't need to worry about this feature.

3.6.1 A2DP Decoder Parameters

3.6.1.1Selecting A2DP Decoder Parameters

The decoding of SBC frames in the A2DP decoder can be slow if the analyzer decodes all the
parts (the header, the scale factor and the audio samples) of the frame in detail. You can
increase the decoding speed by decoding only the header fields and not all the parts if they
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are not required. You can select the detail-level of decoding using the Set Initial Decoder
Parameters dialog.

Note: By default the decoder decodes only the header fields of the frame.

1. Select Set Initial Decoder Parameters from the Options menu on the Control window, the
Frame Display window, or the Protocol Navigator window to display the Set Initial
Decoder Parameters dialog.

2. Click on the AZDP tab.
3. Choose the desired decoding method.

4. Click the OK button to apply the selection and exit the Set Initial Decoder Parameters
dialog.

3.6.2 Security Parameters

3.6.2.1 Security Key

On the Set Initial Decoder Parameters dialog, the security tab allows specifying a key for
software decryption of 802.11 frames. One can enter two types of keys. The types are a
WPA (Wi-Fi Protected Access) pre-shared key and a WEP (Wired Equivalent Privacy) key.

To access this dialog:

1. Go to the Options menu on the Control window and choose Set Initial Decoder
Parameters.

2. Select the Security tab.

There are three types of types of encrypted data on the security tab, each one selectable via
aradio button.

e WPA, WPA2 (Wi-Fi Protected Access), and WEP (Wired Equivalent Privacy) data
that is transmitted over a Wi-Fi communications link. There are two values you
have to enter for the WPA/WPA2 and WEP to be decrypted properly.

e The Bluetoothe alternative MAC/PHY (AMP) enables Bluetooth to support data
rates up to 24Mbps by using additional wireless radio technologies.

e The Pre-Shared Key: The third way is to specify the pre-shared key in its raw hex
forum. Thisisa 32 byte hex number.
Note: When you use WPA/WPAZ2, the Pre-Shared key is generated automatically.

Depending on which Encrypted Data type you select, the options for entering data on the
rest of the dialog varies.
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3.6.3 AVDTP Decoder Parameters

There may be times when the context for decoding a frame is missing. For example, if the
analyzer captured a response frame but did not capture the command frame, then the
decode for the response may be incomplete. The Set Initial Decoder Parameters dialog
provides a means to supply the context for any frame. The dialog allows the user to define
any number of parameters and save them in a Parameter Template for later use.

The Template function provides the capacity to create multiple templates that contain
different parameters. This capability allows the user to maintain individual templates for
each Bluetooth® network monitored. Applying a template containing only those parameters
necessary to decode transmissions particular to an individual network, enhances the
efficiency of the analyzer to decode data.

Each entry in the Set Initial Decoder Parameters dialog takes effect from the beginning of
the capture onward or until redefined in the Set Subsequent Decoder Parameters dialog.
The AVDTP Set Initial Decoder Parameters dialog requires the following user inputs to
complete a Parameter:

e Data Source Number
When only one data source is employed, set this parameter to 0 (zero), otherwise,
set to the desired data source

e Device Role
This identifies the role of the device initiating the frame (master or slave)

e L2CAP Channel
The channel number 0 through 78
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AVDTP Carries
Select the protocol that AVDTP traverses to from the following:

e AVDTP Signaling

e AVDTP Media

e AVDTP Reporting
e AVDTP Recovery

e -Raw Data-

3.6.3.1
Selecting and Applying an AVDTP Parameter Template

Select Set Initial Decoder Parameters from the Options menu on the Control @

window, the Frame Display @window, or the Protocol Navigator window to
display the Set Initial Decoder Parameters dialog.

Click on the AVDTP tab

The dialog displays the content of the most recently selected Parameter Template in the
Initial Connections list at the top of the tab. If the template displayed is the desired
template, then skip to step 4. If it is not, then continue with step 3.

Click the Open File icon at the top of the dialog and select the desired template from the
Popup list.

The system displays the content of the selected template in the Initial Connections list at
the top of the dialog.

Click the OK button to apply the selected template and exit the Set Initial Decoder
Parameters dialog.

3.6.3.2AVDTP Parameters

3.6.3.2.1 ADDING AN AVDTP PARAMETER

This procedure adds one or more parameters to an existing Parameter Template. To create
a new template, see Adding a Parameter Template.
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window, the Frame Display EI window, or the Protocol Navigator window to
display the Set Initial Decoder Parameters dialog.

Select Set Initial Decoder Parameters from the Options menu on the Control

Click on the AVDTP tab.

The dialog displays the most recently selected template content in the Initial Connections
list at the top of the tab. If the parameter must reside in another template, then click the
Open File button and select the desired template from the Popup list.
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Enter the Data Source Number.
When only one data source is employed, set this parameter to 0 (zero), otherwise, set to
the desired data source

Select the Device Role.
This identifies the role of the device initiating the frame (master or slave)

Enter the L2CAP Channel.
Enter the channel number 0 through 78, it can be entered as a decimal or a hexadecimal.

Select the protocol AVDTP Carries.
Select the protocol that AVDTP traverses to from the list

Click the Add button.
The system displays the new parameter in the Initial Connection window. Repeat steps 3
through 8 until all desired parameters are added.

Click the Save icon at the top of the dialog to display the Save As dialog.

Ensure that the name of the template is listed in the Save As text box and click Ok.
The system displays a dialog asking for confirmation of the change to the existing
template

Click the Yes button.
The system saves the new parameter to the template and closes the Save As dialog.

Click the Ok button on the Set Initial Decoder Parameters dialog to apply the template
and close the dialog.

3.6.3.2.2 DELETING AN AVDTP PARAMETER

window, the Frame Display @ window, or the Protocol Navigator @ window to
display the Set Initial Decoder Parameters dialog.

Click on the AVDTP tab.

The dialog displays the most recently selected Parameter Template content in the Initial
Connection list at the top of the tab. If the parameter marked for deletion resides in
another template, then click the Open File icon and select the desired template from the
Popup list.

Select Set Initial Decoder Parameters from the Options menu on the Control

Select (click on and highlight) the parameter marked for deletion from the Initial
Connection list and click the Delete button at the bottom of the Set Initial Decoder
Parameters dialog.

The system removes the selected parameter from the Initial Connection list.
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4. Click the Save icon at the top of the dialog to display the Save As dialog.

5. Ensure that the name of the template is listed in the Save As text box and click Ok.
The system displays a dialog asking for confirmation of the change to the existing
template.

6. Click the Yes button.
The system saves the template and closes the Save As dialog.

7. Click the Ok button on the Set Initial Decoder Parameters dialog to apply the template
and close the dialog.

3.6.3.3 AVDTP Parameter Templates

3.6.3.3.1 ADDING AN AVDTP PARAMETER TEMPLATE

This procedure adds a Parameter Template to the system and saves it for later use. A
template is a collection of parameters required to completely decode communications
between multiple devices. To add a parameter to an existing template, see Adding a
Parameter.

@

window, the Frame Displayg| window, or the Protocol Navigator @ window to
display the Set Initial Decoder Parameters dialog.

1. Select Set Initial Decoder Parameters from the Options menu on the Control

2. Click on the AVDTP tab.
The dialog displays the most recently selected template content in the Initial Connections
list at the top of the tab.

3. Click the Reset to Defaults button at the top of the dialog to clear the Initial Connections
list.

4. Enter the Data Source Number.
When only one data source is employed, set this parameter to 0 (zero), otherwise, set to
the desired data source.

5. Select the Device Role.
This identifies the role of the device initiating the frame (master or slave).

6. Enter the L2CAP Channel
Enter the channel number 0 through 78, it can be entered as a decimal or a hexadecimal.

7. Select the AVDTP Carries
Select the protocol that AVDTP traverses to from the list.

8. Click the Add button.
The system displays the new parameter in the Initial Connections window. Repeat steps
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4 through 9 until all desired parameters are added.
Click the Save button at the top of the dialog to display the Save As dialog.

Enter a name for the new template and click Ok.
The system saves the template and closes the Save As dialog.

Click the Ok button on the Set Initial Decoder Parameters dialog to apply the template
and close the dialog.

3.6.3.3.2 DELETING AN AVDTP PARAMETER TEMPLATE

window, the Frame Displayg| window, or the Protocol Navigator @ window to
display the Set Initial Decoder Parameters dialog.

Select Set Initial Decoder Parameters from the Options menu on the Control

Click on the AVDTP tab
The dialog displays the most recently selected Parameter Template content in the Initial
Connections list at the top of the tab.

Click the Delete button at the top of the dialog.
The system displays the Delete dialog with a list of saved templates.

Select (click on and highlight) the template marked for deletion and click the Delete
button on the Delete dialog.

The system removes the selected template from the list of saved templates.

Click the Ok button on the Delete dialog to complete the deletion process and close the
Delete dialog.

Click the Ok button on the Set Initial Decoder Parameters dialog to apply the deletion and
close the dialog.

3.6.3.4 AVDTP Missing Decode Information

3.6.3.4.1 AVDTP MISSING DECODE INFORMATION

The analyzer usually determines the protocol carried in an AVDTP payload by monitoring
previous traffic. However, when this fails to occur, the Missing Decoding Information
Detected dialog appears and requests that the user supply the missing information.

The following are the most common among the many possible reasons for a failure to
determine the traversal:

O the capture session started after transmission of the vital information

0 the analyzer incorrectly received a frame with the traversal information
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0 the communication monitored takes place between two players with
implicit information not included in the transmission

In any case, either view the AVDTP payload of this frame (and other frames with the same
channel) as hex data, or assist the analyzer by selecting a protocol using this dialog.

Note that you may use the rest of the analyzer without addressing this dialog. Additional
information gathered during the capture session may help you decide how to respond to the
request for decoding information.

If you are not sure of the payload carried by the subject frame, look at the raw data shown
under “data” in the detail pane on the frame display. You may notice something that hints as
to the profile in use.

In addition, look at some of the frames following the one in question. The data may not be
recognizable to the analyzer at the current point due to connection setup, but might be
discovered later on in the capture.

3.6.3.5AVDTP Override Decode Information

3.6.3.5.1 AVDTP OVERRIDE DECODE INFORMATION

The Set Subsequent Decoder Parameters dialog allows the user to override an existing
parameter at any frame in the capture where the parameter is used.
If you have a parameter in effect and wish to change that parameter:

1. Select the frame where the change should take effect

2. Select Set Subsequent Decoder Parameters from the Options menu, or by selecting a
frame in the frame display and choosing from the right-click pop-up menu, and make the
needed changes.

3. Select the rule you wish to modify from the list of rules.

4. Choose the protocol the selected item carries from the drop-down list, and click OK.

Each entry in the Set Subsequent Decoder Parameters dialog takes effect from the specified
frame onward or until redefined in this dialog on a later frame.

Note: If the capture has no user defined overrides, then the system displays a dialog stating
that no user defined overrides exist.

3.6.4 L2CAP Decoder Parameters

There may be times when the context for decoding a frame is missing. For example, if the
analyzer captured a response frame but did not capture the command frame, then the
decode for the response may be incomplete. The Set Initial Decoder Parameters dialog
provides a means to supply the context for any frame. The system allows the user to define
any number of parameters and save them in a Parameter Template for later use. To access
this dialog:
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1. Select Set Initial Decoder Parameters from the Options menu on the Control @

window, the Frame DisplayEI window, or the Protocol Navigator window to
display the Set Initial Decoder Parameters dialog.

For more on setting parameters, see Selecting and Applying an L2CAP Parameter Template.

The Template function provides the capacity to create multiple templates that contain
different parameters. This capability allows the user to maintain individual templates for
each Bluetooth® network monitored. Applying a template containing only those parameters
necessary to decode transmissions particular to an individual network, enhances the
efficiency of the analyzer to decode data.

Each entry in the Set Initial Decoder Parameters dialog takes effect from the beginning of
the capture onward or until redefined in the Set Subsequent Decoder Parameters dialog.

The L2CAP Set Initial Decoder Parameters dialog requires the following user inputs to
complete a Parameter :

e Stream
This identifies the role of the device initiating the frame (master or slave)

e Channel ID
The channel number 0 through 78

¢ Connection Handle
This is the actual physical connection values for the devices

e Data Source Number
When only one data source is employed, set this parameter to 0 (zero), otherwise,
set to the desired data source

e C(Carries (PSM)
Select the protocol that L2ZCAP traverses to from the following:

e AMP Manager
e AMP Test Manager

e SDP

e RFCOMM

e TCS

e LPMP

e BNEP

e HCRP Control
e HCRP Data

e HID

e AVCTP

e AVDTP
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e CMTP
e MCAP Control
e I[EEEP1107320601

e -Raw Data-

3.6.4.1Selecting and Applying an L2ZCAP Parameter Template

@

window, the Frame Displayg| window, or the Protocol Navigator window to
display the Set Initial Decoder Parameters dialog.

Click on the L2CAP tab

The dialog displays the content of the most recently selected Parameter Template in the
Initial Connections list at the top of the tab. If the template displayed is the desired
template , then skip to step 4. If it is not, then continue with step 3.

Select Set Initial Decoder Parameters from the Options menu on the Control

Click the Open File icon at the top of the dialog and select the desired template from the
Popup list.

The system displays the content of the selected template in the Initial Connections list at
the top of the dialog.

Click the OK button to apply the selected template and exit the Set Initial Decoder
Parameters dialog.

3.6.4.2L2CAP Parameters

3.6.4.2.1 ADDING AN L2CAP PARAMETER

This procedure adds one or more parameters to an existing Parameter Template. To create
a new template, see Adding a Parameter Template.

30

Select Set Initial Decoder Parameters from the Options menu on the Control window

@ , the Frame Display window @, or the Protocol Navigator window to display
the Set Initial Decoder Parameters dialog.

Click on the L2CAP tab.

The dialog displays the most recently selected template content in the Initial Connections
list at the top of the tab. If the parameter must reside in another template , then click the
Open File icon and select the desired template from the Popup list.

Select the Stream.
This identifies the role of the device initiating the frame (master or slave).

Enter the Channel ID.
Enter the channel number 0 through 78, it can be entered as a decimal or a hexadecimal.
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Enter the Connection Handle.
This is the L2CAP address.

Enter the Data Source Number.
When only one data source is employed, set this parameter to 0 (zero), otherwise, set to
the desired data source.

Select the Carries (PSM).
Select the protocol that L2CAP traverses to from the list.

Click the Add button.
The system displays the new parameter in the Initial Connection window. Repeat steps 3
through 8 until all desired parameters are added.

Click the Save icon at the top of the dialog to display the Save As dialog.

Ensure that the name of the template is listed in the Save As text box and click Ok.
The system displays a dialog asking for confirmation of the change to the existing
template.

Click the Yes button.
The system saves the new parameter to the template and closes the Save As dialog.

Click the Ok button on the Set Initial Decoder Parameters dialog to apply the template
and close the dialog.

3.6.4.2.2 DELETING AN L2CAP PARAMETER

window, the Frame Displayg| window, or the Protocol Navigator @ window to
display the Set Initial Decoder Parameters dialog.

Click on the L2CAP tab.

The dialog displays the most recently selected Parameter Template content in the Initial
Connection list at the top of the tab. If the parameter marked for deletion resides in
another template, then click the Open File icon and select the desired template from the
Popup list.

Select Set Initial Decoder Parameters from the Options menu on the Control

Select (click on and highlight) the parameter marked for deletion from the Initial
Connection list and click the Delete button at the bottom of the Set Initial Decoder
Parameters dialog.

The system removes the selected parameter from the Initial Connection list.

Click the Save icon at the top of the dialog to display the Save As dialog.

Ensure that the name of the template is listed in the Save As text box and click Ok.
The system displays a dialog asking for confirmation of the change to the existing
template.
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6. Click the Yes button.
The system saves the template and closes the Save As dialog.

7. Click the Ok button on the Set Initial Decoder Parameters dialog to apply the template
and close the dialog.

3.6.4.3 L2CAP Parameter Templates

3.6.4.3.1 ADDING AN L2CAP PARAMETER TEMPLATE

This procedure adds a Parameter Template to the system and saves it for later use. A
template is a collection of parameters required to completely decode communications
between multiple devices. To add a parameter to an existing template, see Adding a

Parameter.

window, the Frame Display EI window, or the Protocol Navigator @ window to
display the Set Initial Decoder Parameters dialog.

1. Select Set Initial Decoder Parameters from the Options menu on the Control

2. Click on the L2CAP tab.
The dialog displays the most recently selected template content in the Initial Connections
list at the top of the tab.

3. Click the Reset to Defaults icon at the top of the dialog to clear the Initial Connections
list.

4. Select the Stream.
This identifies the role of the device initiating the frame (master or slave).

5. Enter the Channel ID.
Enter the channel number 0 through 78, it can be entered as a decimal or a hexadecimal.

6. Enter the Connection Handle.
This is the L2CAP address.

7. Enter the Data Source Number.
When only one data source is employed, set this parameter to 0 (zero), otherwise, set to
the desired data source.

8. Select the Carries (PSM).
Select the protocol that L2CAP traverses to from the list.

9. Click the Add button.
The system displays the new parameter in the Initial Connections window. Repeat steps
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4 through 9 until all desired parameters are added.
Click the Save icon at the top of the dialog to display the Save As dialog.

Enter a name for the new template and click Ok.
The system saves the template and closes the Save As dialog.

Click the Ok button on the Set Initial Decoder Parameters dialog to apply the template
and close the dialog.

3.6.4.3.2 DELETING AN L2CAP PARAMETER TEMPLATE

Select Set Initial Decoder Parameters from the Options menu on the Control @
window, the Frame Display@ window, or the Protocol Navigator @ window to
display the Set Initial Decoder Parameters dialog.

Click on the LZCAP tab
The dialog displays the most recently selected Parameter Template content in the Initial
Connections list at the top of the tab.

Click the Delete button at the top of the dialog.
The system displays the Delete dialog with a list of saved templates.

Select (click on and highlight) the template marked for deletion and click the Delete
button on the Delete dialog.

The system removes the selected template from the list of saved templates.

Click the Ok button on the Delete dialog to complete the deletion process and close the
Delete dialog.

Click the Ok button on the Set Initial Decoder Parameters dialog to apply the deletion and
close the dialog.

3.6.4.4L2CAP Missing Decode Information

FTS4BT usually determines the protocol carried in an L2ZCAP payload by monitoring
previous traffic. However, when this fails to occur, the Missing Decoding Information
Detected dialog appears and requests that the user supply the missing information.

The following are the most common among the many possible reasons for a failure to
determine the traversal:

the capture session started after transmission of the vital information

the analyzer incorrectly received a frame with the traversal information

the communication monitored takes place between two players with implicit
information not included in the transmission
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In any case, either view the L2ZCAP payload of this frame (and other frames with the same
LT_ADDR and CID that originate from the same side) as hex data, or assist the analyzer by
selecting a protocol using this dialog.

Note that you may use the rest of the analyzer without addressing this dialog. Additional
information gathered during the capture session may help you decide how to respond to the
request for decoding information.

If you are not sure of the payload carried by the subject frame, look at the raw data shown
under “data” in the detail pane on the frame display. You may notice something that hints as
to the profile in use.

Most often, the first LZCAP session in a connection is for SDP. If the data you are looking at
seems to be in the first connection, selecting SDP in the dialog may yield useful results.

In addition, look at some of the frames following the one in question. The data may not be
recognizable to the analyzer at the current point due to connection setup, but might be
discovered later on in the capture.

3.6.4.5L2CAP Override Decode Information

The Set Subsequent Decoder Parameters dialog allows the user to override an existing
parameter at any frame in the capture where the parameter is used.

If you have a parameter in effect and wish to change that parameter:
1. Select the frame where the change should take effect

2. Select Set Subsequent Decoder Parameters from the Options menu, or by selecting a
frame in the frame display and choosing from the right-click pop-up menu, and make the
needed changes.

3. Select the rule you wish to modify from the list of rules.
4. Then choose the protocol the selected item carries from the drop-down list, and click OK.

5. Each entry in the Set Subsequent Decoder Parameters dialog takes effect from the
specified frame onward or until redefined in this dialog on a later frame.

Note: If the capture has no user defined overrides, then the system displays a dialog stating
that no user defined overrides exist.

3.6.5 RFCOMM Decoder Parameters

There may be times when the context for decoding a frame is missing. For example, if the
analyzer captured a response frame, but did not capture the command frame, then the
decode for the response may be incomplete. The Set Initial Decoder Parameters dialog
provides a means to supply the context for any frame. The system allows the user to define
any number of parameters and save them in Parameter Templates for later use.
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@

window, the Frame Displayg| window, or the Protocol Navigator window to
display the Set Initial Decoder Parameters dialog.

1. Select Set Initial Decoder Parameters from the Options menu on the Control

For more on setting parameters, see Selecting and Applying an RECOMM Parameter
Template.

The Template function provides the capacity to create multiple templates that contain
different parameters. This capability allows the user to maintain individual templates for
each Bluetooth® network monitored. Applying a template containing only those parameters
necessary to decode transmissions particular to an individual network, enhances the
efficiency of the analyzer to decode data.

Each entry in the Set Initial Decoder Parameters dialog takes effect from the beginning of
the capture onward or until redefined in the Set Subsequent Decoder Parameters dialog.

The RFCOMM Set Initial Decoder Parameters dialog requires the following user inputs to
complete a parameter:

e Stream
This identifies the role of the device initiating the frame (master or slave)

e Server Channel
The channel number 0 through 78

e DLCI
This is the Data Link Connection Identifier, and identifies the ongoing connection
between a client and a server

e Data Source Number
When only one data source is employed, set this parameter to 0 (zero), otherwise,
set to the desired data source

e C(Carries (UUID)
Select from the list to apply the Universal Unique Identifier (UUID) of the application
layer that RFCOMM traverses to from the following:

e OBEX

e SPP

e encap asyncPPP
e Headset

¢ FAX

e Hands Free
e SIM Access
e VCP
e UDI

e -Raw Data-
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3.6.5.1Selecting and Applying an RFCOMM Parameter Template

Select Set Initial Decoder Parameters from the Options menu on the Control

@ window, the Frame Display @window, or the Protocol Navigator @ window to
display the Set Initial Decoder Parameters dialog.

Click on the RFCOMM tab

The dialog displays the content of the most recently selected template in the Initial
Connections list at the top of the tab. If the template displayed is the desired Connection
Set, then skip to step 4. If it is not, then continue with step 3.

Click the Open File icon at the top of the dialog and select the desired template from the
Popup list.

The system displays the content of the selected template in the Initial Connections list at
the top of the dialog.

Click the OK button to apply the selected template and exits the Set Initial Decoder
Parameters dialog.

3.6.5.2RFCOMM Parameters

3.6.5.2.1 ADDING AN RFCOMM PARAMETER

This procedure adds one or more parameters to an existing template. To create a new
template, see Adding a Parameter Template.
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Select Set Initial Decoder Parameters from the Options menu on the Control @

window, the Frame Display@ window, or the Protocol Navigator @ window to
display the Set Initial Decoder Parameters dialog.

Click on the RFCOMM tab.

The dialog displays the most recently selected template content in the Initial Connections
list at the top of the tab. If the parameter must reside in another template, then click the
Open File icon and select the desired template from the Popup list.

Select the Stream.
This identifies the role of the device initiating the frame (master or slave).

Enter the Server Channel.
Enter the channel number 0 through 78, it can be entered as a decimal or a hexadecimal.

Enter the DLCI.
This is the Data Link Connection Identifier, and identifies the ongoing connection
between a client and a server.

Enter the Data Source Number.
When only one data source is employed, set this parameter to 0 (zero), otherwise, set to
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the desired data source.

Select the Carries (UUID).
Select the application layer that RFCOMM traverses to from the list to apply the
Universal Unique Identifier for the necessary application layer.

Click the Add button.
The system displays the new parameter in the Initial Connection window. Repeat steps 3
through 8 until all desired parameters are added.

Click the Save icon at the top of the dialog to display the Save As dialog.

Ensure that the name of the template is listed in the Save As text box and click Ok.
The system displays a dialog asking for confirmation of the change to the existing
template.

Click the Yes button.
The system saves the new parameter to the template and closes the Save As dialog.

Click the Ok button on the Set Initial Decoder Parameters dialog to apply the template
and close the dialog.

3.6.5.2.2 DELETING AN RFCOMM PARAMETER

@

window, the Frame Display @ window, or the Protocol Navigator @ window to
display the Set Initial Decoder Parameters dialog.

Click on the RFCOMM tab.

The dialog displays the most recently selected template content in the Initial Connection
list at the top of the tab. If the parameter marked for deletion resides in another
template, then click the Open File icon and select the desired template from the Popup
list.

Select Set Initial Decoder Parameters from the Options menu on the Control

Select (click on and highlight) the parameter marked for deletion from the Initial
Connection list and click the Delete button at the bottom of the Set Initial Decoder
Parameters dialog.

The system removes the selected parameter from the Initial Connection list.

Click the Save icon at the top of the dialog to display the Save As dialog.

Ensure that the name of the template is listed in the Save As text box and click Ok.
The system displays a dialog asking for confirmation of the change to the existing
template.

Click the Yes button.
The system saves the template and closes the Save As dialog.
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7. Click the Ok button on the Set Initial Decoder Parameters dialog to apply the template

and close the dialog.

3.6.5.3RFCOMM Parameter Templates

3.6.5.3.1 ADDING AN RFCOMM PARAMETER TEMPLATE

This procedure adds a template to the system and saves it for later use. A template is a
collection of parameters required to completely decode communications between multiple
devices. To add a parameter to an existing template, see Adding a Parameter.
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@

window, the Frame Display EI window, or the Protocol Navigator @ window to
display the Set Initial Decoder Parameters dialog.

Select Set Initial Decoder Parameters from the Options menu on the Control

Click on the RFCOMM tab.
The dialog displays the most recently selected template content in the Initial Connections
list at the top of the tab.

Click the Reset to Defaults icon at the top of the dialog to clear the Initial Connections list.

Select the Stream.
This identifies the role of the device initiating the frame (master or slave).

Enter the Server Channel.
Enter the channel number 0 through 78, it can be entered as a decimal or a hexadecimal.

Enter the DLCI.
This is the Data Link Connection Identifier, and identifies the ongoing connection
between a client and a server.

Enter the Data Source Number.
When only one data source is employed, set this parameter to 0 (zero), otherwise, set to
the desired data source.

Select the Carries (UUID).
Select the application layer that RFCOMM traverses to from the list to apply the
Universal Unique Identifier for the necessary application layer.

Click the Add button.
The system displays the new parameter in the Initial Connections window. Repeat steps
4 through 9 until all desired parameters are added.
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Click the Save icon at the top of the dialog to display the Save As dialog.

Enter a name for the new template and click Ok.
The system saves the template and closes the Save As dialog.

Click the Ok button on the Set Initial Decoder Parameters dialog to apply the template
and close the dialog.

3.6.5.3.2 DELETING AN RFCOMM PARAMETER TEMPLATE
Select Set Initial Decoder Parameters from the Options menu on the Control
@ window, the Frame Display @ window, or the Protocol Navigator @ window
to display the Set Initial Decoder Parameters dialog.

Click on the RFCOMM tab
The dialog displays the most recently selected template content in the Initial Connections
list at the top of the tab.

Click the Delete icon at the top of the dialog.
The system displays the Delete dialog with a list of saved templates.

Select (click on and highlight) the template marked for deletion and click the Delete
button on the Delete dialog.

The system removes the selected template from the list of saved templates.

Click the Ok button on the Delete dialog to complete the deletion process and close the
Delete dialog.

Click the Ok button on the Set Initial Decoder Parameters dialog to apply the deletion and
close the dialog.

3.6.5.4RFCOMM Missing Decode Information

3.6.5.4.1 RFCOMM MISSING DECODE INFORMATION

FTS4BT usually determines the protocol carried in an RFCOMM payload by monitoring
previous traffic. However, when this fails to occur, the Missing Decoding Information
Detected dialog appears and requests that the user supply the missing information.

The following are the most common among the many possible reasons for a failure to
determine the traversal:

The capture session started after transmission of the vital information

The analyzer incorrectly received a frame with the traversal information

The communication monitored takes place between two players with implicit
information not included in the transmission

In any case, either view the RFCOMM payload of this frame (and other frames with the same
channel) as hex data, or assist the analyzer by selecting a protocol using this dialog.
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Note that you may use the rest of the analyzer without addressing this dialog. Additional
information gathered during the capture session may help you decide how to respond to the
request for decoding information.

If you are not sure of the payload carried by the subject frame, look at the raw data shown
under “data” in the detail pane on the frame display. You may notice something that hints as
to the profile in use.

In addition, look at some of the frames following the one in question. The data may not be
recognizable to the analyzer at the current point due to connection setup, but might be
discovered later on in the capture.

3.6.5.5RFCOMM Override Decode Information

3.6.5.5.1 RFCOMM OVERRIDE DECODE INFORMATION

The Set Subsequent Decoder Parameters dialog allows the user to override an existing
parameter at any frame in the capture where the parameter is used.

If you have a parameter in effect and wish to change that parameter:

1. Select the frame where the change should take effect, and select Set Subsequent Decoder
Parameters from the Options menu, or by selecting a frame in the frame display and
choosing from the right-click pop-up menu, and make the needed changes.

2. Select the rule you wish to modify from the list of rules.
3. Choose the protocol the selected item carries from the drop-down list, and click OK.

4. Each entry in the Set Subsequent Decoder Parameters dialog takes effect from the
specified frame onward or until redefined in this dialog on a later frame.

Note: If the capture has no user defined overrides, then the system displays a dialog stating
that no user defined overrides exist.

3.6.6 USB Decoder Parameters

There may be times when the context for decoding a frame is missing. For example, if the
analyzer captured a response frame, but did not capture the command frame, then the
decode for the response may be incomplete. The Set Initial Decoder Parameters dialog
provides a means to supply the context for any frame. The system allows the user to define
any number of parameters and save them in templates for later use.

@

window, the Frame Displayg| window, or the Protocol Navigator window to
display the Set Initial Decoder Parameters dialog.

1. Select Set Initial Decoder Parameters from the Options menu on the Control

The USB Template function provides the capacity to create multiple templates that contain
different parameters. This capability allows the user to maintain individual templates for
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each USB network monitored. Applying a template containing only those parameters
necessary to decode transmissions particular to an individual network, enhances the
efficiency of the analyzer to decode data.

Each entry in the Set Initial Decoder Parameters dialog takes effect from the beginning of
the capture onward or until redefined in the Set Subsequent Decoder Parameters dialog.
The USB Set Initial Decoder Parameters dialog requires the following user inputs to
complete a parameter:

Function Address (Range: 1-127)
This is the decimal address of the USB port that connects the device to the computer.

End Point Address (Range: 1-15)
This is the decimal address of the operation within the device.

USB Carrying
Select from the list to apply the USB application

3.6.6.1Selecting and Applying a USB Parameter Template

@

window, the Frame Displayg| window, or the Protocol Navigator @ window to
display the Set Initial Decoder Parameters dialog.

Click on the USB tab

The dialog displays the content of the most recently selected template in the Initial
Connections list at the top of the tab. If the template displayed is the desired template,
then skip step 3 and go to step 4. If it is not, then continue with step 3.

Select Set Initial Decoder Parameters from the Options menu on the Control

Click the Open File icon at the top of the dialog and select the desired template from the
Popup list.

The system displays the content of the selected template in the Initial Connections list at
the top of the dialog.

Click the OK button to apply the selected template and exit the Set Initial Decoder
Parameters dialog.

3.6.6.2USB Parameters

3.6.6.2.1 ADDING A USB PARAMETER

This procedure adds one or more parameters to an existing template. To create a new
template, see Adding a Parameter Template.

@

window, the Frame Displayg| window, or the Protocol Navigator @ window to

Select Set Initial Decoder Parameters from the Options menu on the Control
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display the Set Initial Decoder Parameters dialog.
Click on the USB tab.
The dialog displays the most recently selected template content in the Initial Connections

list at the top of the tab. If the parameter must reside in another template, then click the
Open File icon and select the desired template from the Popup list.

Enter the Function Address (Range: 1-127)
This is the decimal address of the USB port that connects the device to the computer.

Enter the End Point Address (Range: 1-15)
This is the decimal address of the operation within the device.

Select the USB Application from the list of applications.

Click the Add button
The system displays the new parameter in the Initial Connection window. Repeat steps 3
through 6 until all desired parameters are added.

Click the Save icon at the top of the dialog to display the Save As dialog.

Ensure that the name of the template is listed in the Save As text box and click Ok.
The system displays a dialog asking for confirmation of the change to the existing
template.

Click the Yes button.
The system saves the new parameter to the template and closes the Save As dialog.

Click the Ok button on the Set Initial Decoder Parameters dialog to apply the template
and close the dialog.

3.6.6.2.2 DELETING A USB PARAMETER

window, the Frame Display @window, or the Protocol Navigator window to
display the Set Initial Decoder Parameters dialog.

Select Set Initial Decoder Parameters from the Options menu on the Control

Click on the USB tab.

The dialog displays the most recently selected template content in the Initial Connection
list at the top of the tab. If the parameter marked for deletion resides in another
template, then click the Open File icon and select the desired template from the Popup
list.

Select (click on and highlight) the parameter marked for deletion from the Initial
Connection list and click the Delete button at the bottom of the Set Initial Decoder
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Parameters dialog.
The system removes the selected parameter from the Initial Connection list.

4. Click the Save icon at the top of the dialog to display the Save As dialog.

5. Ensure that the name of the template is listed in the Save As text box and click Ok.
The system displays a dialog asking for confirmation of the change to the existing
template.

6. Click the Yes button.
The system saves the template and closes the Save As dialog.

7. Click the Ok button on the Set Initial Decoder Parameters dialog to apply the template
and close the dialog.

3.6.6.3 USB Parameter Templates

3.6.6.3.1 ADDING A USB PARAMETER TEMPLATE

This procedure adds a template to the system and saves it for later use. A template is a
collection of parameters required to completely decode communications between multiple
devices. To add a parameter to an existing template, see Adding a Parameter.

1. Select Set Initial Decoder Parameters from the Options menu on the Control @

window, the Frame Displayg| window, or the Protocol Navigator @ window to
display the Set Initial Decoder Parameters dialog.

2. Click on the USB tab.
The dialog displays the most recently selected template content in the Initial Connections
list at the top of the tab.

3. Click the Reset to Defaults icon at the top of the dialog to clear the Initial Connections list.

4. Enter the Function Address (Range: 1-127).
This is the decimal address of the USB port that connects the device to the computer.

5. Enter the End Point Address (Range: 1-15).
This is the decimal address of the operation within the device.

6. Select the USB Application from the USB Carrying drop-down list.

7. Click the Add button.
The system displays the new parameter in the Initial Connections window. Repeat steps
4 through 7 until all desired parameters are added.

8. Click the Save icon at the top of the dialog to display the Save As dialog.
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Enter a name for the new template and click Ok.
The system saves the template and closes the Save As dialog.

Click the Ok button on the Set Initial Decoder Parameters dialog to apply the template
and close the dialog.

3.6.6.3.2 DELETING A USB PARAMETER TEMPLATE

Select Set Initial Decoder Parameters from the Options menu on the Control @

window, the Frame Display@ window, or the Protocol Navigator window to
display the Set Initial Decoder Parameters dialog.

Click on the USB tab
The dialog displays the most recently selected template content in the Initial Connections
list at the top of the tab.

Click the Delete icon at the top of the dialog.
The system displays the Delete dialog with a list of saved templates.

Select (click on and highlight) the template marked for deletion and click the Delete
button on the Delete dialog.

The system removes the selected template from the list of saved templates.

Click the Ok button on the Delete dialog to complete the deletion process and close the
Delete dialog.

Click the Ok button on the Set Initial Decoder Parameters dialog to apply the deletion and
close the dialog.

3.6.6.4 USB Missing Decode Information

The system usually determines the protocol carried in an USB payload by monitoring
previous traffic. However, when this fails to occur, the Missing Decoding Information
Detected dialog appears and requests that the user supply the missing information.

The following are the most common among the many possible reasons for a failure to
determine the traversal:

the capture session started after transmission of the vital information
the analyzer incorrectly received a frame with the traversal information

the communication monitored takes place between two players with implicit

information not included in the transmission

In any case, either view the USB payload of this frame (and other frames with the same
address) as hex data, or assist the analyzer by selecting a protocol using this dialog.
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Note that you may use the rest of the analyzer without addressing this dialog. Additional
information gathered during the capture session may help you decide how to respond to the
request for decoding information.

If you are not sure of the payload carried by the subject frame, look at the raw data shown
under “data” in the detail pane on the frame display. You may notice something that hints as
to the profile in use.

In addition, look at some of the frames following the one in question. The data may not be
recognizable to the analyzer at the current point due to connection setup, but might be
discovered later on in the capture.

3.6.6.5USB Override Decode Information

The Set Subsequent Decoder Parameters is a selection from the Options menu on the Frame
Displays dialog. This option allows the user to override an existing parameter at any frame
in the capture where the parameter is used.

If you have a parameter in effect and wish to change that parameter :

1. Select the frame where the change should take effect.

2. Select Set Subsequent Decoder Parameters from the Options menu, or by selecting a
frame in the frame display and choosing from the right-click pop-up menu, and make the
needed changes.

3. Select the rule you wish to modify from the list of rules.
4. Choose the protocol the selected item carries from the drop-down list, and click OK.

5. Each entry in the Set Subsequent Decoder Parameters dialog takes effect from the
specified frame onward or until redefined in this dialog on a later frame.

Note: If the capture has no user defined overrides, then the system displays a dialog stating
that no user defined overrides exist.

3.6.7 Decoder Parameter Templates

3.6.7.1 Adding a New or Saving an Existing Template

A template is a collection of parameters required to completely decode communications
between multiple devices. This procedure adds a template to the system and saves it for
later use:

1. Click the Save button at the top of the Set Initial Decoder Parameters dialog to display
the Save As dialog.

2. Enter a name for the new template and click Ok.

The system saves the template and closes the Save As dialog.
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3. Click the Ok button on the Set Initial Decoder Parameters dialog to apply the template
and close the dialog.

Save Changes to a Template
This procedure saves changes to parameters in an existing template.

1. After making changes to parameter settings in a user defined template, click the Save
button at the top of the Set Initial Decoder Parameters dialog to display the Save As
dialog.

2. Ensure that the name of the template is listed in the Save As text box and click Ok.

The system displays a dialog asking for confirmation of the change to the existing template.

3. Click the Yes button.

The system saves the parameter changes to the template and closes the Save As dialog.

4. Click the Ok button on the Set Initial Decoder Parameters dialog to apply the template
and close the dialog.

3.6.7.2 Deleting a Template

1. After opening the Set Initial Decoder Parameters dialog click the Delete button at the top
of the dialog.

The system displays the Delete dialog with a list of saved templates.

2. Select (click on and highlight) the template marked for deletion and click the Delete
button on the Delete dialog.

The system removes the selected template from the list of saved templates.

3. Click the Ok button on the Delete dialog to complete the deletion process and close the
Delete dialog.

4. Click the Ok button on the Set Initial Decoder Parameters dialog to apply the deletion
and close the dialog.

3.7 Spy Mode

Spy Mode lets you run the analyzer on a computer, and "spy" on the data going in and out of
a COM port or internal modem. This means that you can run both the analyzer and a
communications application on the same computer, and use the analyzer to monitor the
conversation between the application and another device. Since internal modems look like
COM ports to the computer, the analyzer can monitor data passing through an internal
modem as well as a regular COM port.

There are some limitations on using Spy Mode. the analyzer uses a custom version of the
standard serial device driver in order to "spy"” on COM ports and internal modems. This
means that the analyzer must be started before the communications application to ensure
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that the analyzer's driver is being used by both the analyzer and the application. As a
corollary, the port you are monitoring must normally use the standard serial driver, and not
a custom driver.

To enter Spy Mode, you must follow the steps below in the order given.

1. Startthe analyzer. The analyzer must be started before the application you are
monitoring is started, or the application does not use the correct driver and the analyzer
is not able to monitor the port.

From the Options menu on the Control window, choose Hardware Settings.
Click on the radio button labeled Spy.
Select the COM port you want to monitor.

Exit the Hardware Settings window.

o 1o wN

Start the application. Be sure to have the application use the same COM port as the one
chosen for the analyzer.

N

Monitor data.

8. Close your application when finished. If you want to monitor another application, repeat
steps 6 - 8.

9. C(lose the analyzer.

It is important to follow the steps in the order given because this ensures that the analyzer's
driver is the one being used by the application you are monitoring. Please note that the
analyzer's driver is designed to behave like the standard serial driver when used by any
other application. However, because it is not the standard serial driver, total compatibility
cannot be guaranteed. See The FTS Serial Driver for more information.

The use of FIFO buffers may cause incorrectly sequenced data when in Spy Mode. See FIFOs
and Spy Mode for more information.

3.7.1 FIFOs and Spy

The 8250 UART generates an interrupt every time a byte enters the UART. If the UART is
receiving data at a high rate of speed, it generates frequent interrupts which the central
processor has to deal with, leaving the central processor less time for other tasks. If the
central processor cannot retrieve the bytes quickly enough, data is lost as new data
overwrites the information stored in the UART. The solution to this problem was the
development of new UART chips that had buffers.

The 16550 UART, one of the most common UARTSs currently in use, has a 16 byte buffer. The
buffer operates on the First In, First Out (FIFO) principle. The first byte in the buffer is the
first byte to go out of the buffer. The buffer allows the UART to store bytes until a specified
number of bytes have come in, at which point it generates an interrupt telling the central
processor to retrieve the data. The ability to store bytes means that the UART is not
generating as many interrupts, giving the central processor more time for other tasks.
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There are two problems with the buffering system and Spy mode. One is that data may not
be timestamped accurately, and the other is that control signal states may not be correct.
the analyzer timestamps the byte and records the state of the control signals at the time it
retrieves the byte from the UART. If the buffers are being used, an interrupt is generated
until several bytes have already come in, possibly resulting in incorrect timestamps and
signal states.

The analyzer solves the problem by telling the UART to generate an interrupt every time a
byte comes in, but the analyzer cannot do this when operating in Spy mode. In Spy mode,
the application being monitored has control of the UART and specifies how the buffers is
used. The result is that the captured data may not be completely accurate.

If you are using Spy mode, we recommend turning off the FIFOs on the UART if accurate
recording of timestamps or control signal states is important.

3.7.2 Turning Off the FIFO Buffers

In Windows XP
1. Click on the Start button and choose Control Panel.

2. Click on the Performance and Maintenance selection, then the System selection.
OR:
Simply right click the My Computer icon on your desktop and select Properties from the
Popup menu.

3. On the System Properties dialog, click on the Hardware tab, then click the Device Manager
button.

4. Expand the Ports section, and double-click on the port you want to change to open the
Port Properties.

5. Click the Port Settings tab on the Communications Port Properties dialog, followed by the
Advanced button.

6. Un-check the box labeled Use FIFO buffers (requires 16550 compatible UART).
7. Click OK on all windows to close the windows.

8. Follow this same process to turn the FIFOs back on.
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4 Protocol Stacks

4.1 Protocol Stack Wizard

The Protocol Stack wizard is where you define the protocol stack you want the analyzer to
use when decoding frames.

To start the wizard:
1. Choose Protocol Stack from the Options menu on the Control window or click the
Protocol Stack icon = on the Frame Display.

2. Select a protocol stack from the list, and click Finish. Click for information on how the
analyzer auto-traverses the protocol stack.

Most stacks are pre-defined here. If you have special requirements and need to set up a
custom stack, see Creating a Custom Stack.

1. Ifyou select a custom stack (i.e. one that was defined by a user and not included with the
analyzer), the Remove Selected Item From List button becomes active.

2. Click the Remove button to remove the stack from the list. You cannot remove stacks
provided with the analyzer. If you remove a custom stack, you need to define it again in
order to get it back.

If you are changing the protocol stack for a capture file, you may need to reframe. See
Reframing for more information.

You cannot select a stack or change an existing one for a capture file loaded into the Capture
File Viewer (the Capture File Viewer is used only for viewing capture files and cannot
capture data). Protocol Stack changes can only be made from a live session.

Note for BCSP:

If you are using the BCSP protocol stack, you must connect the analyzer to the circuit such
that the data on the DTE line comes from the host, and data on the DCE line comes from the
controller. Click here

Note for Modbus RTU:

If you are using the Modbus RTU protocol stack, you must select either Modbus RTU Master
or Modbus RTU Slave depending on where the analyzer taps into the circuit. Click here for
more information.

Note for Modbus TCP:

If you are using Modbus TCP over Ethernet, you need to set up a node database giving the IP
addresses for the Master and Slave devices. Click here for more information.

Note for Data Highway Plus (DH+):
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There are special hardware and software configuration instructions for setting up the
DL3000 DHM device used to tap into the Data Highway Plus network. Click here for more
information.

Note for IEC 870-5-101:

You need to give the decoder information on the sizes of some fields and whether or not
other fields are present. There are all system configurable options and therefore the
decoder has no way of knowing this information from the data. Click here for more
information.

Note for DeviceNet

You need to install the DeviceNet card before beginning data capture. Then you need to
setup the device in the Hardware Settings window, and optionally select any capture filters.

DeviceNet Card Installation Instructions

DeviceNet Device Setup

DeviceNet Capture Filters

4.2 Information Screen

The second screen of the Protocol Stack Wizard gives information to help you decide if you
need to define a custom stack or if a pre-defined stack has what you need.

4.3 How the Analyzer Auto-traverses the Protocol Stack

In the course of doing service discovery, devices ask for and receive a Protocol Descriptor
List defining which protocol stacks the device supports. It also includes information on
which PSM to use in L2CAP, or the channel number for RFCOMM, or the port number for
TCP or UDP. The description below talks about how the analyzer auto-traverses from
L2CAP using a dynamically assigned PSM, but the principle is the same for RFCOMM
channel numbers and TCP/UDP port numbers.

The analyzer looks for SDP Service Attribute Responses or Service Search Attribute
Responses carrying protocol descriptor lists. If the analyzer sees L2CAP listed with a PSM, it
stores the PSM and the UUID for the next protocol in the list.

After the SDP session is over, the analyzer looks at the PSM in the L2CAP Connect frames
that follow. If the PSM matches one the analyzer has stored, the analyzer stores the source
channel ID and destination channel ID, and associates those channel IDs with the PSM and
UUID for the next protocol. Thereafter, when the analyzer sees L2ZCAP frames using those
channel IDs, it can look them up in its table and know what the next protocol is.

In order for the analyzer to be able to auto-traverse using a dynamically assigned PSM, it
has to have seen the SDP session giving the Protocol Descriptor Lists, and the subsequent
L2CAP connection using the PSM and identifying the source and channel IDs. If the analyzer
misses any of this process, it is not able to auto-traverse. It stops decoding at the L2ZCAP
layer.
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For L2CAP frames carrying a known PSM (0x0001 for SDP, for example, or 0x0003 for
RFCOMM), the analyzer looks for Connect frames and stores the PSM along with the
associated source and destination channel IDs. In this case the analyzer does not need to see
the SDP process, but does need to see the L2ZCAP connection process, giving the source and
destination channel IDs.

4.4 Creating and Removing a Custom Stack

To create a custom stack:

1. Choose Protocol Stack from the Options menu on the Control window or click the

-
Protocol Stack icon = on the Frame Display.
2. Select Build Your Own from the list and click Next.

3. The system displays an information screen that may help you decide if you need to
define your own custom stack. Defining a custom stack means that the analyzer uses the
stack for every frame. Frames that do not conform to the stack are decoded incorrectly.

Click Next to continue.

Select Protocols

1. Selecta protocol from the list on the left.

2. Click the right arrow button to move it to the Protocol Decode Stack box on the right, or
double-click the protocol to move it to the right.

3. Toremove a protocol from the stack, double-click it or select it and click the left arrow
button.

4. Ifyouneed to change the order of the protocols in the stack, select the protocol you
want to move, and click on the Move Up and Move Down buttons until the protocol is in
the correct position.

5. The lowest layer protocol is at the top of the list, with higher layer protocols listed
underneath.

Auto-traversal (Have the analyzer Determine Higher Layers)

If you need to define just a few layers of the protocol stack, and the remaining layers can be
determined based on the lower layers:

1. Click the All additional stack layers can be determined automatically button.

2. Ifyour protocol stack is complete and there are no additional layers, click the There are
no additional stack layers button.

3. Ifyou select this option, the analyzer uses the stack you defined for every frame. Frames
that do use this stack are decoded incorrectly.

Save the Stack
To save your stack:
1. Click the Add To Predefined List button.

2. Give the stack a name, and click Add.
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In the future, the stack appears in the Protocol Stack List on the first screen of the Protocol
Stack wizard.

Remove a Stack
To remove the stack:
1. Selectitin the first screen and click Remove Selected Item From List.

2. Ifyouremove the stack, you must to recreate it if you need to use it again.

Note:

If you do not save your custom stack, it does appear in the predefined list, but applies to the
frames in the current session. However, it is discarded at the end of the session.

4.5 Saving User Defined Stacks

You can create protocol stacks for one time use that disappear at the end of the session. If
you want to use the stack again in a subsequent session, then you need to recreate it.
However, if you save the stack, then it is available every time you start the analyzer, until
you delete it.

The Add To Predefined Stack List dialog allows the user to save a custom stack for future use.

1. After creating a custom stack using the Protocol Stack Wizard, click the Add To
Predefined List button on the last screen of the wizard.

Add To Predefined Stack List EL
Curert Protocol Stack:
Etheiriet
cAicitional Lapers ae Cancel
Automatically
Dhebestrmed::

I e
e

Your newly defined stack appears in the Current Protocol Stack pane on the left.

2. Simply enter a name for the stack and click Add.

The name of the stack now appears as a selection in the Select a Protocol Stack dialog.

4.6 Reframing
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If you need to change the protocol stack used to interpret a capture file and the framing is
different in the new stack, you need to reframe in order for the protocol decode to be
correct. You can also use Reframe to frame unframed data. The original capture file is not
altered during this process.

Note: You cannot reframe from the Capture File Viewer (accessed by selecting Capture File
Viewer or Load Capture File to start the software and used only for viewing capture files).

To reframe your data, load your capture file, select a protocol stack, and then select Reframe
from the File menu on the Control window. Reframe is only available if the frame recognizer
used to capture the data is different from the current frame recognizer.

In addition to choosing to Reframe, you can also be prompted to Reframe by the Protocol
Stack Wizard.

1. Load your capture file by choosing Open from the File menu on the Control window, and
select the file to load.

2. Select the protocol stack by choosing Protocol Stack from the Options menu on the
Control window, select the desired stack and click Finish.

3. [Ifyou selected a protocol stack that includes a frame recognizer different from the one
used to capture your data, the Protocol Stack Wizard asks you if you want to reframe
your data. Choose Yes.

4. The analyzer adds frame markers to your data, puts the framed data into a new file, and
opens the new file. The original capture file is not altered.

See Unframing for instructions on removing framing from data.

4.7 Unframing

This function removes start-of-frame and end-of-frame markers from your data. The
original capture file is not altered during this process.

You cannot unframe from the Capture File Viewer (accessed by selecting Capture File
Viewer or Load Capture File to start the software and used only for viewing capture files).

To manually unframe your data, select Unframe from the File menu on the Control window.
Unframe is only available if a protocol stack was used to capture the data and there is
currently no protocol stack selected.

In addition to choosing to Unframe, you can also be prompted to Unframe by the Protocol
Stack Wizard.

1. Load your capture file. To do this, choose Open from the File menu on the Control
window, and select the file to load.

2. Remove the protocol stack. To do this, choose Protocol Stack from the Options menu on
the Control window, select None from the list, and click Finish.
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3. The Protocol Stack Wizard asks you if you want to unframe your data and put it into a
new file. Choose Yes.

4. The system removes the frame markers from your data, puts the unframed data into a
new file, and opens the new file. The original capture file is not altered.

See Reframing for instructions on framing unframed data.

4.8 Providing Context For Decoding When Frame Information Is
Missing

There may be times when you need to provide information to the analyzer because the
context for decoding a frame is missing. For example, if the analyzer captured a response
frame, but did not capture the command frame indicating the command.

The analyzer provides a way for you to supply the context for any frame, provided the
decoder supports it. (The decoder writer has to include support for this feature in the
decoder, so not all decoders support it. Note that not all decoders require this feature.)

If the decoder supports user-provided context, three items are active on the Options menu
of the Control Window, Frame Display and Protocol Navigator windows. These items are Set
Initial Decoder Parameters, Automatically Request Missing Decoding Information, and Set
Subsequent Decoder Parameters. (These items are not present if no decoder is loaded that
supports this feature.)

Set Initial Decoder Parameters is used to provide required information to decoders that is
not context dependent but instead tends to be system options for the protocol.

Choose Set Initial Decoder Parameters in order to provide initial context to the analyzer for
a decoder. A dialog appears that shows the data for which you can provide information.

If you need to change this information for a particular frame :
1. Right-click on the frame in the Frame Display window
2. Choose Provide <context name>.

Alternatively, you can choose Set Subsequent Decoder Parameter from the Options menu.
3. This brings up a dialog showing all the places where context data was overridden.

4. Ifyou know that information is missing, you can't provide it, and you don't want to see
dialogs asking for it, un-check Automatically Request Missing Decoding Information.

5. When unchecked, the analyzer doesn't bother you with dialogs asking for frame
information that you don't have. In this situation, the analyzer decodes each frame until
it cannot go further and then simply stop decoding.

54



frontline

Debug Communications Faster!sv

5 Capturing Data

5.1 Capturing Data

Note: Data Capture is not available in Viewer mode.

1. Click the Start Capture icon o to begin capturing to a file. This icon is located on the

Control ﬁl, Event Display ﬁ ,and Frame Displayg| windows.

2. Files are placed in My Capture Files by default and have a .cfa extension. Choose
Directories from the Options menu on the Control window to change the default file
location.

3. Watch the status bar on the Control window to monitor how full the file is. When the file
is full, it begins to wrap, which means the oldest data will be overwritten by new data.

4. Click the Stop icon B to temporarily stop data capture. Click the Start Capture icon
again to resume capture. Stopping capture means no data will be added to the capture
file until capture is resumed, but the previously captured date remains in the file.

T4
5. To clear captured data, click the Clear icon =%.

e Ifyou select Clear after selecting Stop, a dialog appears asking whether you
want to save the data.

e You can click Save File and enter a file name when prompted .
e Ifyou choose Do Not Save, all data will be cleared.
e Ifyou choose Cancel, the dialog closes with no changes.
e Ifyou select the Clear icon while a capture is occurring:
e The capture stops.
e Adialog appears asking if you want to save the capture

e You can select Yes and save the capture or select No and close the
dialog. In either case, the existing capture file is cleared and a new
capture file is started.

e Ifyou choose Cancel, the dialog closes with no changes.

To change the size of the capture file, choose System Settings from the Options menu on the
Control window.
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6 Analyzing Byte Level Data

6.1 Event Display

To open this window

Click the Event Display icon »"ﬁ) on the Control window toolbar.

The Event Display window provides detailed information about every captured event.
Events include data bytes, data related information such as start-of-frame and end-of-frame
flags, and the analyzer information, such as when the Data Capture Was Paused. Data bytes
are displayed in hex on the left side of the window, with the corresponding ASCII character
on the right.

Click on an event to find out more about it. The three status lines at the bottom of the
window are updated with information such as the time the event occurred (for data bytes,

the time the byte was captured), the value of the byte in Hex, Decimal, Octal, and Binary, any
errors associated with the byte, and more.

Events with errors are shown in red to make them easy to spot.

When capturing data live, the analyzer continually updates the Event Display as data is

captured. Make sure the Lock icon % is displayed on the toolbar to prevent the display
from updating (Clicking on the icon again will unlock the display). While locked, you can
review your data, run searches, determine delta time intervals between bytes, and check
CRCs. To resume updating the display, click the Lock icon again.

g
You can have more than one Event Display open at a time. Click the Duplicate View icon ¥
to create a second, independent Event Display window. You can lock one copy of the Event

Display and analyze your data, while the second Event Display updates as new data is
captured.

6.2 The Event Display Toolbar

‘@ Home - Brings the Control window to the front.
6 Open File - Opens a capture file.

@ Start Capture - Begins data capture to disk.

B Stop Capture - Closes a capture file and stops data capture to disk.
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Save - Prompts user for a file name. If the user supplies a name, a .cfa file is
saved.

Clear- Discards the temporary file and clears the display.

Lock - In the Lock state, the window is locked so you can review a portion of
data. Data capture continues in the background. Clicking on the Lock icon
unlocks the window.

Unlock - In the Unlock state, the screen fills in the data captured since the
screen lock and moves down to display incoming data again. Clicking on the
Unlock icon locks the window.

Duplicate View - Creates a second Event Display window identical to the first.

Frame Display - (framed data only) Brings up a Frame Display, with the frame
of the currently selected bytes highlighted.

Focus Protocol Navigator - (framed data only) Brings up the Protocol
Navigator window, with the currently selected frame highlighted.

Display Capture Notes - Brings up the Capture Notes window where you can
view or add notes to the capture file.

Add/Modify Bookmark - Add a new or modify an existing bookmark.

Display All Bookmarks - Shows all bookmarks and lets you move between
bookmarks.

Find - Search for errors, string patterns, special events and more.

Go To - Opens the Go To dialog, where you can specify which event number to
go to.

CRC - Change the algorithm and seed value used to calculate CRCs. To calculate
a CRC, select a byte range, and the CRC appears in the status lines at the
bottom of the Event Display.
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D Mixed Sides - (Serial data only) By default, the analyzer shows data with the
DTE side above the DCE side. This is called DTE over DCE format. DTE data has a
white background and DCE data has a gray background. The analyzer can also
display data in mixed side format. In this format, the analyzer does not separate
DTE data from DCE data but shows all data on the same line as it comes in. DTE
data is still shown with a white background and DCE data with a gray
background so that you can distinguish between the two. The benefit of using
this format is that more data fits onto one screen.

A Character Only - The analyzer shows both the number (hex, binary, etc.) data
and the character (ASCII, EBCDIC or BAUDOT) data on the same screen. If you
do not wish to see the hex characters, click on the Character Only button. Click
again to go back to both number and character mode.

1 Number Only - Controls whether the analyzer displays data in both character
and number format, or just number format. Click once to show only numeric
values, and again to show both character and numeric values.

All Events - Controls whether the analyzer shows all events in the window, or
only data bytes. Events include control signal changes and framing information.

Timestamping Options - Brings up the timestamping options window which
has options for customizing the display and capture of timestamps.

6.3 Opening Multiple Event Display Windows

5
Click the Duplicate View icon ¥ from the Event Display toolbar to open a second Event
Display window.

You can open as many Event Display windows as you like. Each Event Display is
independent of the others and can show different data, use a different radix or character set,
or be frozen or live.

The Event Display windows are numbered in the title bar. If you have multiple Event

Displays open, click on the Event Display icon 5@ on the Control window toolbar to show
a list of all the Event Displays currently open. Select a window from the list to bring it to the
front.

6.4 Calculating CRCs or FCSs

The cyclic redundancy check (CRC) is a function on the Event Display window used to
produce a checksum. The frame check sequence (FCS) are the extra checksum characters
added to a frame to detect errors.
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1. Open the Event Display ¢  window.

2. Click and drag to select the data you want to generate a CRC for.

3. Click on the CRCicon J L

4. Inthe CRC dialog box, click on the down arrow to show the list of choices for CRC
algorithms. Choose an algorithm to use. Choose CRC 32 (Ethernet). Choose CRC 32
(Ethernet) for Ethernet data or the appropriate CRC type for serial data.

5. Enter a seed value in hexadecimal if desired.

6. Click OK to generate the CRC. It appears in the byte information lines at the bottom of
the Event Display window. Whenever you select a range of data, a CRC using the
algorithm you selected is calculated automatically.

"CRC!" in Ethernet data

Ethernet network cards do not normally send the CRC with the frame to the upper layers of
the system. The hardware on the card checks that the CRC is correct and then throws it
away. FTS marks the place where the CRC would be in the data with "CRC!". When viewing
Ethernet capture files made with other programs, the CRC may or may not be included,
depending on the specifications of the capturing software/hardware.

Reversed CRCs on the Event Display with Ethernet data

The CRC calculated in the Event Display window is reversed from the CRC shown in the
data. CRCs are calculated in network data order from Most Significant Byte (MSB) to Least
Significant Byte (LSB). The Ethernet specification says to send data in host data order (LSB
to MSB). Therefore the CRC as captured in the data is the reverse of the CRC as calculated.

Example: If the CRC in the data is shown as 00 01 02 03, the Event Display calculated the
CRC and show it in the status lines as 03 02 01 00. This is correct.
Calculating CRC for interwoven data

FTS calculates the CRC for either side of the interwoven data. Which side it calculates is
determined by the first byte selected. If the first byte is from one side, then FTS calculates
the CRC for just the bytes on that side. If the first byte is from the other side, then FTS
calculates the CRC for just the bytes on that side.

Incorrect results with CRC16 for serial data

If you are calculating CRCs using the CRC16 algorithm and the CRCs do not match what you
know they should be, try CRC16rev. What hardware often calls CRC16 is what software
calls CRC16rev.

6.5 Calculating Delta Times and Data Rates
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1. Click on the Event Display icon ¢ on the Control window to open the Event Display
window.

2. Use the mouse to select the data you want to calculate a delta time and rate for.

3. The Event Display window displays the delta time and the data rate in the status lines at
the bottom of the window.

6.6 Switching Between Live Update and Review Mode

The Event Display and Frame Display windows can update to display new data during live
capture, or be frozen to allow data analysis. By default, the Event Display continually
updates with new data, and the Frame Display is locked.

i

1. Make sure the Lock icon is active so the display is locked and unable to scroll.

2. Click the Unlock ' 1 icon again to resume live update.

The analyzer continues to capture data in the background while the display is locked. Upon
resuming live update, the display updates with the latest data.

You can have more than one Event Display or Frame Display window open at a time. Click
e

the Duplicate View icon d to open additional Event or Frame Display windows. The

Lock/Resume function is independent on each window. This means that you can have two

Event Display windows open simultaneously, and one window can be locked while the
other continues to update.

6.7 Data Formats and Symbols

6.7.1 Switching Between Viewing All Events and Viewing Data Events

By default, the analyzer on the Event Display dialog shows all events.
This includes:

e Data bytes

e Start-of-frame

e End-of-frame characters

e Data Captured Was Paused.

|
Click on the Display All Events icon * to remove the non-data events. Click again to display
all events.
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See List of All Event Symbols for a list of all the special events shown in the analyzer and
what they mean.

6.7.2 Switching Between Hex, Decimal, Octal or Binary

On the Event Display window the analyzer displays data in Hex by default. There are several
ways to change the radix used to display data.

1. Go to the View menu and select the radix you want. A check mark next to the radix
indicates which set is currently being used.

2. Right-click on the "Hex" header label and choose a different radix.

If you want to see only the numerical values, click on the Numbers Only icon 1 on the
Event Display toolbar.

6.7.3 Switching Between ASCII, EBCDIC, and Baudot

On the Event Display window, the analyzer displays data in ASCII by default. There are
several ways to change the character set used to display data.

1. Go to the View menu and select the character set you want. A check mark next to the
character set indicates which set is currently being used.

2. Right-click on the "ASCII" header label and choose a different character set.

If you want to see only characters, click on the Characters Only icon A on the Event
Display toolbar.

6.7.4
Viewing Only ASCII (or EBCDIC or Baudot)

On the Event Display toolbar you can choose to view data in ASCII, EBCDIC, or Baudot
format only.

1. Click on the Characters Only icon A on the Event Display toolbar.

To add the numerical values back to the display:

1. Click the Characters Only icon again.

6.7.5 Viewing Only Hex (Or Decimal or Octal or Binary)

On the Event Display toolbar you can choose to view data as numeric only.

1. Click on the Numbers Only icon 1 on the Event Display toolbar.
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To display the characters back to the display:
1. Click the Number Only icon again.

6.7.6 Selecting Mixed Channel/Sides

If you want to get more data on the Event Display window, you can switch to mixed sides
mode. This mode puts all the data together on the same line. Data from one side is shown on
a white background and data from the other is shown on a gray background.

1. Click once on the Mixed Sides icon D to put the display in mixed sides mode.
2. Click again to return to side over side mode.

3. You can right click on the labels in the center of the data display window to change
between mixed and side over side modes.

4. Choose Display Sides Together to go to Mixed Sides Mode or Display Sides Separately to
go to side over side mode.

6.7.7 List of All Event Symbols

By default, the Event Display shows all events, which includes control signal changes, start
and end of frame characters and flow control changes. If you want to see only the data

I
bytes, click on the All Events button = . Click again to display all events.

Click on a symbol, and the analyzer displays the symbol name and sometimes additional
information in the status lines at the bottom of the Event Display window. For example,
clicking on a control signal change symbol displays which signal(s) changed.

In addition to data bytes, the events shown are (in alphabetical order):
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Abort

Broken Frame - The frame did not end when the analyzer expected it to.
This occurs most often with protocols where the framing is indicated by a
specific character, control signal change, or other data related event.

Buffer Overflow - Indicates a buffer overflow error. A buffer overflow
always causes a broken frame.

Control Signal Change - One or more control signals changed state. Click on
the symbol, and the analyzer displays which signal(s) changed at the
bottom of the Event Display window.

Data Capture Paused - The Pause icon was clicked, pausing data capture.
No data is recorded while capture is paused.

Data Capture Resumed - The Pause icon was clicked again, resuming data
capture.

Dropped Frames - Some number of frames were lost. Click on the symbol,
and the analyzer displays many frames were lost at the bottom of the
Event Display window.

End of Frame - Marks the end of a frame.

Flow Control Active - An event occurred which caused flow control to
become active (i.e. caused the analyzer to stop transmitting data) Events
which activate flow control are signal changes or the receipt of an XON
character.

Flow Control Inactive - An event occurred which caused flow control to
become inactive (i.e. caused the analyzer to transmit data). Events which
deactivate flow control are signal changes or the receipt of an XOFF
character.

Frame Recognizer Change - A lowest layer protocol was selected or
removed here, causing the frame recognizer to be turned off or on.
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6.7.8 Font Size

The font size can be changed on several windows. Changing the font size on one window
does not affect the font size on any other window.

To change the font size:

1. Click on Options, and select Change the Font Size.
2. Choose a font size from the list.

3. Click OK.
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7 Analyzing Protocol Decodes

7.1 Frame Display Window

7.1.1 Frame Display Window

To open this window

Click the Frame Display icon on the Control window toolbar, or select Frame Display
from the Window menu.

Frame Display Panes

The Frame Display window is used to view all frame related information. It is composed of a
number of different sections or "panes”, where each pane shows a different type of
information about a frame. The image below gives the name of each pane. Click on the links
below the image to learn more about each pane.

Summary Pane

The Summary Pane displays a one line summary of each frame for every protocol
found in the data, and can be sorted by field for every protocol. Click here for an
explanation of the symbols next to the frame numbers.

Decode Pane

The Detail Pane displays a detailed decode of the highlighted frame. Fields selected
in the Decode pane have the appropriate bit(s) or byte(s) selected in the Radix,
Binary, Character and Event panes.

Radix Pane

The Radix Pane displays the logical data bytes in the selected frame in either
hexadecimal, decimal or octal.

Binary Pane
The Binary Pane displays a binary representation of the logical data bytes.

Character Pane

The Character Pane displays the character representation of the logical data bytes in
either ASCII, EBCDIC or Baudot.

Event Pane

The Event Pane displays the physical data bytes in the frame, as received on the
network.

By default, all panes except the Event pane are displayed when the Frame Display is first
opened.

Protocol Tabs
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The Frame Display adds a tab to the top of the Summary Pane for every protocol found in
the in the data. You can click on these tabs to filter on the protocol. Select the Unfiltered tab
to display all protocols. The Unfiltered tab is automatically selected when multiple protocols
are being filtered-in using other filtering methods.

Comparing Frames

If you need to compare frames, you can open additional Frame Display windows by clicking

5
on the Duplicate View icon J . You can have as many Frame Display windows open at a
time as you wish.

7.1.2 Frame Display Toolbar

The buttons that appear in the Frame Display window vary according to the particular
configuration of the analyzer.
@ Home - Brings the Control window to the front.

’_53 Open File - Opens a capture file.

/0 Settings - Opens the /0 Settings dialog.

o8

Start Capture - Begins data capture to a user designated file.

E @

Stop Capture - Closes a capture file and stops data capture to disk.

Save - Save the currently selected bytes or the entire buffer to file.

il

Clear- Discards the temporary file and clears the display.

Event Display - Brings the Event Display window to the front.
Protocol Navigator - Brings the Protocol Navigator window to the front.

Statistics - Brings the Statistics window to the front. This icon does not display
in this location when running the analyzer in Air Sniffer. See Packet Error Rate
Statistics below.

E ® © &

Signal Display - Opens the Signal Display. This icon does not display when
running the analyzer in Air Sniffer.



© @

E E W &8 d «

& E o B )

v

frontline

Debug Communications Faster!sv

Breakout Box - Opens the Breakout Box dialog.
Duplicate View - Creates a second Frame Display window identical to the first.

Apply/Modify Display Filters - Opens the Display Filter dialog.

Quick Protocol Filter - brings up a dialog box where you can filter or hide one
or more protocol layers.

Find - Search for errors, string patterns, special events and more.

Display Capture Notes - Brings up the Capture Notes window where you can
view or add notes to the capture file.

Add/Modify Bookmark - Add a new or modify an existing bookmark.

Display All Bookmarks - Shows all bookmarks and lets you move between
bookmarks.

Protocol Stack - brings up the Protocol Stack Wizard where you can change the
stack used to decode framed data

Reload Decoders - When Reload Decoders is clicked, the plug-ins are reset and
received frames are redecoded. For example, If the first frame occurs more
than 10 minutes in the past, the 10-minute utilization graph stays blank until a
frame from 10 minutes ago or less is decoded.

Packet Timeline - Opens the Packet Timeline display.
Extract Data - Opens the Extract Data dialog.

Packet Error Rate Statistics - Opens the Packet Error Rate Statistics display.

Audio Extraction - Opens the Audio Extraction dialog.

Pie Chart - This icon displays a chart that displays the number of frames with
and without errors.

Network View - Opens the Network View Window.

Dashboard - Opens the Dashboard Dialog

69



frontline

Debug Communications Faster!sv

Filter: Text giving the filter currently in use. If no filter is being used, the text reads "All
Frames" which means that nothing is filtered out. To see the text of the entire filter, place
the cursor over the text and a ToolTip pops up with the full text of the filter.

The following icons all change how the panes are arranged on the Frame Display. Additional
layouts are listed in the View menu.
E Show Default Panes - Returns the panes to their default settings.

Show Only Summary Pane - Displays only the Summary pane.

Toggle Expanded Decode Pane - Makes the Decode pane taller and the
Summary pane narrower.

Toggle Display Freeze - Prevents the display from updating.

Go To Frame - Opens the Go To dialog, where you can specify which event
number to go to.

First Frame - Moves to the first frame in the buffer.

Previous Frame - Moves to the previous frame in the buffer.

Next Frame - Moves to the next frame in the buffer.

Last Frame - Moves to the last frame in the buffer.

Q00 e=HI[

Note that if the frames are sorted in other than ascending frame number order, the order of
the frames in the buffer is the sorted order. Therefore the last frame in the buffer may not
have the last frame number.

Summary drop-down box

Lists all the protocols found in the data in the file. This box does not list all the protocol
decoders available to the analyzer, merely the protocols found in the data. Selecting a
protocol from the list changes the Summary pane to display summary information for that
protocol. When a FBLEA predefined Named Filter (like Nulls and Polls) is selected, the
Summary drop-down is disabled.

Text with Protocol Stack

To the right of the Summary Layer box is some text giving the protocol stack currently in
use.
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7.1.3 Frame Display Status Bar

The Frame Display Status bar appears at the bottom of the Frame Display. It contains the
following information:

e Total Frames: The total number of frames in the capture buffer or capture file in
real-time

e Frames Filtered In: The total number of frames displayed in the filtered results from
user applied filters in real-time

e Frame #s Selected: Displays the frame number or numbers of selected (highlighted)
frames, and the total number of selected frames in parentheses

7.1.4 Hiding and Revealing Protocol Layers in the Frame Display

Hiding protocol layers refers to the ability to prevent a layer from being displayed on the
Decode pane. Hidden layers remain hidden for every frame where the layer is present, and
can be revealed again at any time. You can hide as many layers as you wish.

Note: Hiding from the Frame Display affects only the data shown in the Frame Display and
not any information in any other window.

There are two ways to hide a layer.

1. Right-click on the layer in the Decode pane, and choose Hide [protocol name] Layer In
All Frames.

2. Click the Set Protocol Filtering button on the Summary pane toolbar. In the Protocols to
Hide box on the right, check the protocol layer(s) you want hidden. Click OK when
finished.

To reveal a hidden protocol layer:
1. Right-click anywhere in the Decode pane

2. Choose Show [protocol name] Layer from the right-click menu, or click the Set Protocol
Filtering button and un-check the layer or layers you want revealed.

7.1.5 Physical vs. Logical Byte Display

The Event Display window and Event Pane in the Frame Display window show the physical
bytes. In other words, they show the actual data as it appeared on the circuit. The Radix,
Binary and Character panes in the Frame Display window show the logical data, or the
resulting byte values after escape codes or other character altering codes have been applied
(a process called frame transformation).

As an example, bytes with a value of less than 0x20 (the Ox indicates a hexadecimal value)
cannot be transmitted in Async PPP. To get around this, a 0x7d is transmitted before the
byte. The 0x7d says to take the next byte and subtract 0x20 to obtain the true value. In this
situation, the Event pane displays 0x7d 0x23, while the Radix pane displays 0x03.

71



frontline

Debug Communications Faster!sv
7.1.6 Sorting Frames

By default, frames are sorted in ascending numerical sequence by frame number. Click on a
column header in the Summary pane to sort the frames by that column. For example, to sort
the frames by size, click on the Frame Size column header.

An embossed triangle next to the header name indicates which column the frames are
sorted by. The direction of the triangle indicates whether the frames are in ascending or
descending order, with up being ascending.

Note that it may take some time to sort large numbers of frames.

7.1.7 Synchronizing the Event and Frame Displays

The Frame Display is synchronized with the Event Display. Click on a frame in the Frame
Display and the corresponding bytes is highlighted in the Event Display. Each Frame Display
has its own Event Display.

As an example, here's what happens if the following sequence of events occurs.

1. Click on the Frame Display icon @ in Control window toolbar to open the Frame
Display.

e
2. Click on the Duplicate View icon ﬁ to create Frame Display #2.

3. Click on Event Display icon éED in Frame Display #2. Event Display #2 opens. This
Event Display is labeled #2, even though there is no original Event Display, to indicate
that it is synchronized with Frame Display #2.

4. Click on a frame in Frame Display #2. The corresponding bytes are highlighted in Event
Display #2.

5. Click on a frame in the original Frame Display. Event Display #2 does not change.

7.1.8 Working With Multiple Frame Displays

Multiple Frame Displays are useful for comparing two frames side by side. They are also
useful for comparing all frames against a filtered subset or two filtered subsets against each
other.

5
e To create a second Frame Display, click the Duplicate View icon ¥ on the Frame
Display toolbar.

This creates another Frame Display window. You can have as many Frame Displays open as
you wish. Each Frame Display is given a number in the title bar to distinguish it from the
others.

e Tonavigate between multiple Frame Displays, click on the Frame Display icon EI
in the Control window toolbar.
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A drop-down list appears, listing all the currently open Frame Displays.

e Select the one you want from the list and it comes to the front.

Note: When you create a filter in one Frame Display, that filter does not automatically
appear in other Frame Display windows. You must use the Hide/Reveal feature to
display a filter created in one Frame Display in different Frame Display window.

7.1.9 Working With Panes

When the Frame Display first opens, all panes are displayed except the Event pane. The
panes include:

e Toview all the panes, select Show All Panes from the View menu.

e The Toggle Expand Decode Pane icon Dj makes the decode pane longer to view
lengthy decodes better.

e The Show Default Panes icon E returns the Frame Display to its default settings.

e The Show only Summary Pane icon D displays on the Summary Pane.

1. Toclose a pane, right-click on the pane and select Hide This Pane from the pop-up menu,
or de-select Show [Pane Name] from the View menu.

2. To open a pane, right-click on the any pane and highlight Show Hidden Panes from the
pop-up menu and select the pane from the fly-out menu, or select Show [Pane Name]
from the View menu.

3. Toresize a pane, place the cursor over the pane border until a double-arrow cursor
appears. Click and drag on the pane border to resize the pane.

7.1.10 The Panes in the Frame Display

7.1.10.1 Summary Pane

The Summary pane D displays a one-line summary of every frame in a capture buffer or
file, including frame number, timestamp, length and basic protocol information. The
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protocol information included for each frame depends on the protocol selected in the
summary layer box (located directly below the main toolbar).

On a two-channel circuit, the background color of the one-line summary indicates whether
the frame came from the DTE or the DCE device. Frames with a white background come
from the DTE device, frames with a gray background come from the DCE device.

The Summary pane in FTS4USB displays a one-line summary of every transaction in a
capture buffer or file. Whenever there is a transaction it is shown on a single line instead of
showing the separate messages that comprise the transaction. The Msg column in that case
says “Transaction”.

Each message in a transaction contains a packet identifier (PID). All of the PIDs in a
transaction are shown in the transaction line.

All IN transactions (i.e. transactions that contain an IN token message) are shown with a
purple background. All other transactions and all non-transactions are shown with a white
background. IN transactions have special coloring because that is the only place where the
primary data flow is from a device to the Host.

The protocol information included for each frame depends on the protocol selected in the
summary layer box (located directly below the main toolbar).

Frame numbers in red indicate errors, either physical (byte-level) or frame errors. If the
error is a frame error in the displayed protocol layer, the bytes where the error occurred is
displayed in red. The Decode Pane gives precise information as to the type of error and
where it occurred.

The Summary pane is synchronized with the other panes in this window. Click on a frame in
the Summary pane, and the bytes for that frame is highlighted in the Event pane while the
Decode pane displays the full decode for that frame. Any other panes which are being
viewed are updated accordingly. If you use one pane to select a subset of the frame, then
only that subset of the frame is highlighted in the other panes.

Use the navigation icons, keyboard or mouse to move through the frames. The icons @
and @ move you to the first and last frames in the buffer, respectively. Use the Go To

icon ! to move to a specific frame number.

7.1.10.2 Customizing Fields in the Summary Pane
You can modify the Summary Pane in Frame Display.

Changing Column Widths
To change the width of a column:

1. Place the cursor over the right column divider until the cursor changes to a solid double
arrow.

2. Click and drag the divider to the desired width.

3. To auto-size the columns, double-click on the column dividers.
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Hiding Columns
To hide a column:
1. Drag the right divider of the column all the way to the left.
2. The cursor changes to a split double arrow when a hidden column is present.

3. To show the hidden column, place the cursor over the divider until it changes to a split
double arrow, then click and drag the cursor to the right.

4. The Frame Size, Timestamp, and Delta columns can be hidden by right-clicking on the
header and selecting Show Frame Size Column, Show Timestamp Column, or Show Delta
Column. Follow the same procedure to display the columns again.

Moving Columns - Changing Column Order
To move a column :
1. Click and hold on the column header
2. Dragthe mouse over the header row.
3. A small white triangle indicates where the column is moved to.
4

When the triangle is in the desired location, release the mouse.

Restoring Default Column Settings

To restore columns to their default locations, their default widths, and show any hidden
columns

1. Right-click on any column header and choose Restore Default Column Widths, or select
Restore Default Column Widths from the Format menu.

7.1.10.3 Frame Symbols in the Summary Pane

A green dot means the frame was decoded successfully, and the protocol listed in
the Summary Layer drop-down box exists in the frame. No dot means the frame
was decoded successfully, but the protocol listed in the Summary Layer drop-
down box does not exist in the frame.

A green circle means the frame was not fully decoded. There are several reasons
why this might happen.

One reason is that the frame compiler hasn't caught up to that frame yet. It takes
some time for the analyzer to compile and decode frames. Frame compilation
also has a lower priority than other tasks, such as capturing data. If the analyzer
is busy capturing data, frame compilation may fall behind. When the analyzer
catches up, the green circle changes to either a green dot or no dot.

Another reason is if some data in the frame is context dependent and we don't
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have the context. An example is a compressed header where the first frame gives
the complete header, and subsequent frames just give information on what has
changed. If the analyzer does not capture the first frame with the complete
header, it cannot decode subsequent frames with partial header information.

[ A magenta triangle indicates that a bookmark is associated with this frame. Any
comments associated with the bookmark appear in the column next to the
bookmark symbol.

7.1.10.4 Frame Display - Right Click Filtering

In Frame Display, protocols are displayed as tabs in the Summary Pane. When you select a
tab, the protocol layers are displayed. The layers vary depending on the protocol.

You can create additional protocol tabs that highlight specific layers in the Summary Pane
using the Filtering Results dialog.

Note: The Filtering Results dialog is not available for all layers because the
information within those layers is not sortable, like time.

To use the Filtering Results dialog:

1. Right-click on a value in the Summary Pane. For example, the "S" for Slave under Role
2. Onthe drop-down list select Filter in "Name = Value"

Note: The "Name" and "Value" change depending on the layer.
The Filtering Results dialog appears.

3. Enter a name for the Filter.
4. Select OK.

A new protocol tab with the Filter Name you just created appears in the Summary Pane.
The new tab displays data specific to the layer you selected.

7.1.10.5 Decode Pane

The Decode pane (aka detail pane) I:D is a post-process display that provides a detailed
decode of each frame transaction (sometimes referred to as a frame). The decode is
presented in a layered format that can be expanded and collapsed depending on which layer
or layers you are most interested in. Click on the plus sign to expand a layer. The plus sign
changes to a minus sign. Click on the minus sign to collapse a layer. Select Show All or Show
Layers from the Format menu to expand or collapse all the layers. Layers retain their
expanded or collapsed state between frames.
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Protocol layers can be hidden, preventing them from being displayed on the Decode pane.
Right-click on any protocol layer and choose Hide [protocol name] from the right-click
menu.

In a USB transaction, all messages that comprise the transaction are shown together in the
detail pane. The color coding that is applied to layers when the detail pane displays a single
message is applied to both layers and messages when the detail pane displays a transaction.
To keep the distinction between layers and messages clear, each header of each message in
the detail pane ends with the word “Message” or “Messages”. The latter is used because data
and handshake messages are shown as a single color-coded entry

Each protocol layer is represented by a color, which is used to highlight the bytes that
belong to that protocol layer in the Event, Radix, Binary and Character Panes. The colors are
not assigned to a protocol, but are assigned to the layer.

The Event, Radix, Binary, Character and Decode panes are all synchronized with one
another. Clicking on an element in any one of the panes highlights the corresponding
element in all the other panes.

Click the Toggle Expand Decode Pane icon I:D to make the Decode pane taller. This allows
for more of a lengthy decode to be viewed without needing to scroll.

7.1.10.6 Radix or Hexadecimal Pane

The Radix pane displays the logical bytes in the frame in either hexadecimal, decimal or
octal. The radix can be changed from the Format menu, or by right-clicking on the pane and
choosing Hexadecimal, Decimal or Octal.

Because the Radix pane displays the logical bytes rather than the physical bytes, the data in
the Radix pane may be different from that in the Event pane. See Physical vs. Logical Byte
Display for more information.

Colors are used to show which protocol layer each byte belongs to. The colors correspond to
the layers listed in the Decode pane.

The Event, Radix, Binary, Character and Decode panes are all synchronized with one
another. Clicking on an element in any one of the panes highlights the corresponding
element in all the other panes.

7.1.10.7
7.1.10.8 Character Pane

The Character pane represents the logical bytes in the frame in ASCII, EBCDIC or Baudot.
The character set can be changed from the Format menu, or by right-clicking on the pane
and choosing the appropriate character set.

Because the Character pane displays the logical bytes rather than the physical bytes, the
data in the Character pane may be different from that in the Event pane. See Physical vs.
Logical Byte Display for more information.
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Colors are used to show which protocol layer each byte belongs to. The colors correspond to
the layers listed in the Decode pane.

The Event, Radix, Binary, Character and Decode panes are all synchronized with one
another. Clicking on an element in any one of the panes highlights the corresponding
element in all the other panes.

7.1.10.9
Binary Pane

The Binary pane displays the logical bytes in the frame in binary. This pane is synchronized
with the Decode pane so that individual bit fields can be highlighted.

Because the Binary pane displays the logical bytes rather than the physical bytes, the data in
the Binary pane may be different from that in the Event pane. See Physical vs. Logical Byte
Display for more information.

Colors are used to show which protocol layer each byte belongs to. The colors correspond to
the layers listed in the Decode pane.

The Event, Radix, Binary, Character and Decode panes are all synchronized with one
another. Clicking on an element in any one of the panes highlights the corresponding
element in all the other panes.

7.1.10.10 Event Pane

The Event pane shows the physical bytes in the frame. You can choose between displaying

only the data events or displaying all events by clicking the All Events icon ' #

Displaying all events means that special events, such as Start of Frame/End of Frame and
any signal change events, are displayed as special symbols within the data.

The status lines at the bottom of the pane give the same information as the status lines in
the Event Display window. This includes physical data errors, control signal changes (if
appropriate), and timestamps.

Because the Event pane displays the physical bytes rather than the logical bytes, the data in
the Event pane may be different from that in the Radix, Binary and Character panes. See
Physical vs. Logical Byte Display for more information.

Colors are used to show which protocol layer each byte belongs to. The colors correspond
to the layers listed in the Decode pane.

The Event, Radix, Binary, Character and Decode panes are all synchronized with one
another. Clicking on an element in any one of the panes highlights the corresponding
element in all the other panes.
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7.1.11 Protocol Layer Colors

7.1.11.1 Data Byte Color Notation

The color of the data in the panes specifies which layer of the protocol stack the data is
from. All data from the first layer is bright blue, the data from the second layer is green, the
third layer is pink, etc. The protocol name for each layer in the Decode pane is in the same
color. Note that the colors refer to the layer, not to a specific protocol. In some situations, a
protocol may be in two different colors in two different frames, depending on where it is in
the stack. You can change the default colors for each layer.

Red is reserved for bytes or frames with errors. In the Summary pane, frame numbers in
red mean there is an error in the frame. This could be a physical error in a data byte or an
error in the protocol decode. Bytes in red in the Radix, Character, Binary and Event panes
mean there is a physical error associated with the byte.

Searching for Frame (Decode) Errors
Searching for Data Errors

7.1.11.2 Red Frame Numbers and Bytes

Red is reserved for bytes or frames with errors. In the Summary pane, frame numbers in
red mean there is an error in the frame. This could be a physical error in a data byte or an
error in the protocol decode. Bytes in red in the Radix, Character, Binary and Event panes
mean there is a physical error associated with the byte.

Searching for Frame (Decode) Errors
Searching for Data Errors

7.1.11.3 Changing Protocol Layer Colors

You can differentiate different protocol layers in the Decode, Event, Radix, Binary and
Character panes.

1. Choose Select Colors from the Options menu to change the colors used

2. To change a color, click on the arrow next to each layer and select a new color.

7.1.12 Protocol Filtering from the Frame Display

7.1.12.1 Easy Protocol Filtering

There are two types of easy protocol filtering. The first method lets you filter on the
protocol shown in the Summary pane, and the second lets you filter on any protocol
discovered on the network so far.

Filtering On the Summary Layer Protocol
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Quick Filtering on a Protocol Layer / Filtering on all Frames with Errors

7.1.12.2 Filtering On the Summary Layer Protocol

To filter on the protocol in the Summary in the Frame Display window pane:
1. Select the tab of the desired protocol, or open the Summary Layer combo box.
2. Select the desired protocol.

3. To filter on a different layer, just select another tab, or change the layer selection in the
combo box.

7.1.12.3 Quick Filtering on a Protocol Layer

1. To filter on any protocol layer, open either the Frame Display or Protocol Navigator
window.

2. On the Frame Display window, click the starred Quick Filtering icon g or select
"Quick Filtering" from the Filter menu.

This opens a dialog that lists all the protocols discovered so far. The protocols displayed
change depending on the data received.

The box on the left is Protocols To Filter In.

¢ When you select the checkbox for a protocol in the Protocols to Filter In, the
Summary Pane will only display those frames that contain data from that protocol.

If you filter on more than one protocol, the result are all frames that contain at least one of
those protocols. For example, if you filter on IP and IPX NetBIOS, you receive all frames that
contain either IP or IPX NetBIOS (or both). A Quick Filter tab then appears on the Frame
Display labeled Quick Filter. Changing the filter definition on the Quick Filter dialog changes
the filter applied on the Quick Filter tab. Quick filters are persistent during the session, but
are discarded when the session is closed.

The box in the center is the Protocols To Hide.

e When you select the checkbox for a protocol in the Protocols To Hide, data for that
protocol will not appear in the Decode, Binary, Radix, and Character Panes. The
frames containing that type data will still appear in the Summary Pane, but not in
the Decode, Binary, Radix, and Character Panes.

The box on the right is the Named Filters. It contains filters that you create using the
Named Filter and Set Condition dialogs.

e When you select the checkbox for the Name Filters, a tab appears on the Summary
Pane that displays the frame containing the specific data identified in the filter. The
named Filter tab remains on the Frame Display Summary Pane unless you hide it
using the Hide/Show Display Filters dialog.
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With FBLEA, the Configured BT Low energy devices and Exclude NULLSs and POLLs are
default named filters.

1. Check the small box next to the name of each protocol you want to filter in, hide, or
Named Filter to display.

2. Then click OK.

Creating a Display Filter
Creating a Named Display Filter with a right click menu

Hiding and Revealing Display Filters
Deleting Saved Display Filters

7.1.12.4 Filtering on all Frames with Errors from the Frame Display

To filter on all frames with errors:

1. Open the Frame Display @window.

2. Click the starred Quick Filter icon ? or select "Quick Filtering" from the Filter menu
3. Check the box for All Frames With Errors in the "Protocols to filter in" pane, and click OK.

4. The system creates a tab on the Frame Display labeled Quick Filter that displays the
results of the All Frames With Errors filter.

7.1.12.5 Frame Display - Right Click Filtering

In Frame Display, protocols are displayed as tabs in the Summary Pane. When you select a
tab, the protocol layers are displayed. The layers vary depending on the protocol.

You can create additional protocol tabs that highlight specific layers in the Summary Pane
using the Filtering Results dialog.

Note: The Filtering Results dialog is not available for all layers because the
information within those layers is not sortable, like time.

To use the Filtering Results dialog:

1. Right-click on a value in the Summary Pane. For example, the "S" for Slave under Role
2. Onthe drop-down list select Filter in "Name = Value"

Note: The "Name" and "Value" change depending on the layer.
The Filtering Results dialog appears.

3. Enter a name for the Filter.
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4. Select OK.

A new protocol tab with the Filter Name you just created appears in the Summary Pane. The
new tab displays data specific to the layer you selected.

7.2 Protocol Navigator Window

7.2.1 Protocol Navigator

The Protocol Navigator displays the decode for more than one frame at a time, and has
several features for controlling which frames and/or parts of frames are displayed. The
main part of the window displays the decode for multiple frames. When you first open the
window, every protocol layer of every frame is collapsed. By expanding the protocols, the
Protocol Navigator displays the equivalent of the Decode pane on the Frame Display, with
the added convenience of displaying multiple frame decodes in one place.

Click the Protocol Navigator icon @ to display the Protocol Navigator.

There are three methods for controlling the display in the Protocol Navigator;
expanding/collapsing protocols, filtering, and hiding.

7.2.2 Protocol Navigator Toolbar

The buttons that appear in the Protocol Navigator window vary according to the particular
configuration of the analyzer.
.@ Home - Brings the Control window to the front.

E Open File - Opens a capture file.

/0 Settings - Opens the /0 Settings dialog.

&8

Start Capture - Begins data capture to a user designated file.

Stop Capture - Closes a capture file and stops data capture to disk.

E @

Save - Save the currently selected bytes or the entire buffer to file.

il

ié Clear- Discards the temporary file and clears the display.

P Event Display - Brings the Event Display window to the front.
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Frame Display - (framed data only) Opens a Frame Display, with the frame of
the currently selected bytes highlighted.

Breakout Box - Opens the Breakout Box dialog.
Duplicate View - Creates a second Frame Display window identical to the first.

Apply/Modify Display Filters - Opens the Display Filter dialog.

Quick Protocol Filter - brings up a dialog box where you can filter or hide one
or more protocol layers.

Find - Search for errors, string patterns, special events and more.

Display Capture Notes - Brings up the Capture Notes window where you can
view or add notes to the capture file.

Add/Modify Bookmark - Add a new or modify an existing bookmark.

Display All Bookmarks - Shows all bookmarks and lets you move between
bookmarks.

Protocol Stack - brings up the Protocol Stack Wizard where you can change the
stack used to decode framed data

Reload Decoders - When Reload Decoders is clicked, the plug-ins are reset and
received frames are redecoded. For example, If the first frame occurs more
than 10 minutes in the past, the 10-minute utilization graph stays blank until a
frame from 10 minutes ago or less is decoded.
Packet Timeline - Opens the Packet Timeline display.
Extract Data - Opens the Extract Data dialog.
Packet Error Rate Statistics - Opens the Packet Error Rate Statistics display.
Audio Extraction - Opens the Audio Extraction dialog.

Network View - Opens the Network View Window.

Dashboard - Opens the Dashboard Dialog
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The following icons all change how the panes are arranged on Protocol Navigator.
Additional layouts are listed in the View menu.

@ First Frame - Moves to the first frame in the buffer.
o Previous Frame - Moves to the previous frame in the buffer.
@ Next Frame - Moves to the next frame in the buffer.

@ Last Frame - Moves to the last frame in the buffer.

7.2.3 Protocol Navigator Status Bar

The Protocol Navigator Status bar appears at the bottom of the Protocol Navigator. It
contains the following information:

e Total Frames: The total number of frames in the capture buffer or capture file in
real-time

e Frames Filtered In: The total number of frames displayed in the filtered results from
user applied filters in real-time

e Frame #s Selected: Displays the frame number(s) of selected (highlighted) frames,
and the total number of selected frames in parentheses.

7.2.4 The Difference Between Filtering and Hiding

You can filter on one or more protocol layers. The filter is inclusive, which means that
filtering on a protocol means that only frames that contain that protocol are shown in the
window. Frames that do not contain the protocol do not appear. You can filter on one
protocol or several. (Filtering on the Protocol Navigator window is display filtering only.)

Hiding means that the selected layer is not displayed in the window, even though it may be
present in the frame. This allows you to zoom in on a particular layer by hiding every layer
but the one of interest.

An example using the IP stack may help to illustrate the difference. Assume that you only
want to see frames that have TCP in them. You create a filter on TCP. The results displayed
in the Protocol Navigator (or Frame Display) window have only those frames that carry
TCP.

Now you're ready to look at the TCP decode in your frames. You don't care about what has
happened at the IP layer or any other layer, so you hide everything but TCP. The window
shows just the TCP decode for each frame. With those two steps, you've eliminated looking
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at any frame that doesn't have TCP in it, and you've narrowed down what you see to just the
TCP decode.

7.2.5 Hiding and Revealing Protocol Layers in the Protocol Navigator

Hiding means that the selected protocol is not displayed in the window, even though it may
be present in the frame. This allows you to zoom in on a particular protocol by hiding every
protocol but the one of interest. This is especially effective when all the layers are expanded.

Note: Hiding affects only the view in the Protocol Navigator and not the view in any
other window.

There are two ways to hide a protocol in the Protocol Navigator window :
1. Right-click on the protocol and choose Hide [Protocol Layer Name].

2. There are three panes on the left side of the window. The middle box is the Hidden From
View pane. Check the boxes next to the protocols you want to hide.

To reveal a hidden protocol:

1. Right-click anywhere in the main window

2. Select the protocol you want to show from the right-click menu, or un-check the box
next to the protocol name in the Hidden From View pane.

When one or more layers are hidden, a note appears at the top of the Protocol Navigator
saying, "Some layers are hidden. Right-click to see." This warns you that some layers are
hidden.

Two special options are All But the Last Layer and All Special Information Nodes.

e All But the Last Layer hides all layers in each frame except for the last one,
regardless of which protocol is present in the last layer.

o All Special Information Nodes hides the information line present in some protocol
decoders.

7.2.6 Filtering on a Protocol Layer

You can filter on one or more protocol layers. The filter is inclusive which means only
frames matching the filter you select are shown in the window. Frames that do not contain
the protocol do not appear. You can filter on one protocol or several.

On the left side of the Protocol Navigator window are three panes. The top pane is the
Frames Filtered In pane. In the pane is a list of all the protocols seen so far on the circuit.

1. Check the boxes next to the names of the protocols you want to filter in.
The data on the right side of the screen matches the filtering selected.
Three additional filters available are:

e All Frames With Bookmarks - filters in all frames with a bookmark associated with
them.
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e All Frames With Errors - filters in all frames with errors.

e All Special Information Nodes - filters in all special information nodes .

7.2.7 Filtering on all Frames with Errors from the Protocol Navigator

To filter on all frames with errors :

1. Open the Protocol Navigator @ window.
2. Check the All Frames With Errors box in the top pane on the left side of the window.

3. Toremove the filter, un-check the box.

7.2.8 Expanding and Collapsing Protocol Layers

You can expand any collapsed frame or protocol layer by clicking on the plus sign next to
the frame number or protocol name. Expanding a protocol layer in one frame expands it for
all frames.

1. To collapse alayer or frame, click on the minus sign next to the frame number or
protocol name.

What do you want to see?

Everything Choose Show All from the Format menu.

Everything for just one Click the plus sign next to the frame you want to see. Then

frame click the plus signs next to each protocol name to see the full
decode.

Just the stack for each Choose Show Frames AND Show Protocol Stack When Frame

frame Is Completely Collapsed from the Format menu. This makes

the display look similar to the following:

Frame 1: Len=104 Ethernet->IP -> TCP
Frame 2: Len=98 Ethernet->IP -> TCP -> NBSS

Just the stack without Choose Show Layers AND un-check Show Summary Decode
summary information When Detailed Decode Is Collapsed on the Format menu.
This makes the display look similar to the following:

Frame 1: Len=104

+ Ethernet:
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+ [Pv4:
+ TCP:
Frame 2:  Len=98
+ Ethernet:
+ [Pv4:
+ TCP:
+ NBSS:
Just the stack Choose Show Layers AND Show Summary Decode When
including summary Detailed Decode Is Collapsed from the Format menu. This
information makes the display look similar to the following:
Frame 1:  Len=104
+ Ethernet: --- Dest. Address: BROADCAST Source Address: XYZ etc.
+ IPv4: --- Protocol: TCP Length: 80 etc.
+ TCP: --- Source Port: 9988 Destination Port: NETBIOS etc.
Frame 2:  Len=98

+ Ethernet: --- Dest. Address: etc.

+ [Pv4: --- Protocol: TCP Length: 56 etc.

+ TCP: --- Source Port: NETBIOS Destination Port: 9988 etc.
+ NBSS: --- Length: 23 Fragment: Entire Message

The full decode for a Click on the plus sign next to the protocol name. This

protocol layer

expands just that protocol in every frame.

The decode for just Choose Collapse All Nodes AND Show Last Layer When
the last layer in each Frame is Completely Collapsed from the Tree menu.

frame
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8 Statistics

8.1 Statistics

Statistics displays vary according product configuration. Select the help topics that apply to
the mode you are running.

Serial and USB Statistics
Air Sniffer Statistics

8.2 Statistics Window

NOTE: This information applies when running FTS4BT in any of the following modes or
when viewing a capture file created using any of these modes:

e High Speed Serial HCI
e High Speed UART (HSU)
e USBHCI

To open the Statistics window, click the Statistics icon H] on the Control window toolbar,
or choose Statistics from the View menu on the Control window.

The Statistics window supplies basic information about the data on the network. When
reviewing a capture file, the Statistics window shows a summary of the data in the file.

The analyzer monitors the network and collects statistics all the time, even when data is not

actively being captured. Activate the Lock icon
i

Click the Unlock icon 1] again to resume updating. The analyzer continues to monitor

network traffic while the Statistics window is locked, so you may see the numbers jump

right after updating has resumed, reflecting all the statistics that were gathered while the

window was locked.

to stop the window from updating.

Tell me more about:

The difference between the Session, Resettable and Buffer Tabs

What the statistics mean

How Do I:

Changing the font size
Changing the timestamping resolution
Switching between absolute and relative timestamps

Viewing a chart of the Frame Sizes or Errors Table
Copying the information in the Statistics window to a file
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Changing the Frame Size Ranges or add a Range

8.3 Session, Resettable and Capture File Tabs

The Session and Resettable tabs are parts of the Statistics window.

NOTE: This information applies when running FTS4BT in any of the following modes or
when viewing a capture file created using any of these modes:

e High Speed Serial HCI
e High Speed UART (HSU)
e USBHCI

Information about all data collected since the analyzer was started is shown in the Session
tab. The Session tab cannot be reset; in this sense, it is like the odometer on a car. The
odometer on a car shows you all the miles driven since the car was built, and the Session tab
shows you all the data collected since the analyzer was started.

If you think of the Session tab as the odometer, then the Resettable tab is the trip odometer.
It can be reset, and allows you to record statistics for a new "trip". In this way you can
effectively start a new session without having to restart the analyzer. If the Reset button
was pressed during the capture, then the numbers on this tab differs from the numbers on
the Session tab.

The Capture File tab shows information on the data that is currently in the capture. If the
capture file had become full, the analyzer began to overwrite the oldest data and put new
data in its place. This is called "wrapping". If the file wrapped, the numbers on the Capture
File tab is smaller than those on the Session tab.

Occasionally some of the statistics read n/a, for Not Available. This happens for various
reasons. For example, many of the items on the Capture File tab become not available (n/a)
if the buffer becomes full and wraps. When this happens, the analyzer can no longer provide
accurate statistics for the data in the file, because some of the data that the statistics are
based on has been lost.

8.4 Copying Statistics To The Clipboard

NOTE: This information applies when running FTS4BT in any of the following modes or
when viewing a capture file created using any of these modes:

e High Speed Serial HCI
e High Speed UART (HSU)
e USBHCI

To copy the information from an individual table to the clipboard (where it can be pasted
into any application),

1. Choose the name of the table from the Edit menu.

2. To copy the contents of all the tables, choose Copy All to Clipboard.
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8.5 Graphs

8.5.1 Statistics Graphs

Open the Statistics window and click on the picture of a graph L on the table header, or
choose the graph name from the Graph menu on the Statistics window.

The Frame Sizes Graph window has Session, Resettable and Buffer tabs that correspond to
the tabs on the Statistics window. Each tab shows the data that corresponds to the
appropriate tab on the Statistics window.

The Frame Sizes Graph window displays the number of frames of each length in either a pie

(o]

chart or bar graph format. Click the Pie icon to display a pie chart, and click the Bar

icon M‘ to display a bar graph.
For networks with more than one side, the analyzer displays one graph for each side. To
view the aggregate of all sides, click the Aggregate icon %

See Also

Switching between viewing percents or actual values

Viewing data values in the legend

Changing the window refresh rate

Printing the graphs

8.5.2 Printing Graphs

1. Click the Printicon % to print the graph. The analyzer prints exactly what is shown
on the window.

8.5.3 Changing the Graph Refresh Rate

The graphs window refreshes once every second.

To change the refresh rate:

1. Click the Options icon {{3 on the Statistics window.
2. Enter a new refresh rate in milliseconds in the Time Interval (ms) text box.
8.5.4 Viewing Percentages or Values

On the Statistics window you can view data expressed as a percentage.
1. Open the Statistics window

2. Select the graph to display.

91



frontline

Debug Communications Faster!sv

On the graph window,
%
3. Click the Percentages icon #@ to view data expressed as a percentage.
4. Click the Percentages icon again to view the actual number of items of each type.
5. Click the Show Data Grid icon E to view both the number and percentage of the

total for each item. The analyzer places a grid in the legend.

8.6 Information on Tables

8.6.1 Octets Per Second Table

NOTE: This information applies when running FTS4BT in any of the following modes or
when viewing a capture file created using any of these modes:

e High Speed Serial HCI
e High Speed UART (HSU)

e USBHCI
Speed maximum speed of the network expressed in megabits
Current current number of octets per second
Average average number of octets per second
Peak highest number of octets per second

8.6.2 Buffer Information Table

NOTE: This information applies when running FTS4BT in any of the following modes or
when viewing a capture file created using any of these modes:

e High Speed Serial HCI
e High Speed UART (HSU)
e USBHCI

These errors do not indicate problems on the network, but rather indicate that FTS was not
able to keep up with the amount of incoming data. They usually indicate that a faster PC was
needed. See Performance Notes for more information.

Driver The number of times the analyzer lost frames because it could not retrieve
Buffer them from the driver buffer fast enough.
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Overflow

The remaining three items are for Ethernet data only.

Frames The number of frames lost because the analyzer driver could not retrieve
Missed, them from the NDIS buffers before they were overwritten by new,

No incoming frames.

Buffer

Receive The number of times that frames are lost because NDIS could not retrieve

Overrun data quickly enough from the buffer on the network card.

Frames The number of frames lost due to driver buffer overflows.
Lost
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9 low energy Timeline

9.1 low energy Timeline Introduction

The Bluetooth® low energy Timeline displays packet information with an emphasis on
temporal information and payload throughput. The timeline also provides selected
information from the Frame Display and the Protocol Navigator.

The timelines provide a rich set of diverse information about low energy packets, both
individually and as a range. Information is conveyed using text, color, packet size, and
position.

B Burisalh brw ereegy Timelosr @ corfguird devioen oty

§ ==

EIIEIIEIIEHEIIE:EIFIEHZI--

You access the Timeline by selecting Bluetooth low energy Timeline from the View menu or

by pressing the Bluetooth low energy Timeline icon on the Control Window toolbar,
Frame Display, or Protocol Navigator.

Select one of the links below to learn more about the Bluetooth low energy Timeline.

Packet Depiction
Navigating and Selecting Data

Button Bar

Menu Bar
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Visual Elements

Zooming

Throughput Display

Average Throughput Indicators
One Second Throughput Indicators

Throughput Graph
Discontinuities

Legend

9.2 Bluetooth® low energy Timeline Packet Depiction

The timeline shows Bluetooth packets within a specific period of time.

The time segments flow left to right and down, following a complete row across.
Then you move down to the next row, go across, then down the to next row, just
like reading a book, upper left corner to lower right corner.

e Within each row are three radio possibilities: 2, 1 ,and 0. Packets are placed on 2, 1,
or 0 depending on which radio they came in on.

¢ Placing the mouse pointer on a packet displays information about that packet in an
information box.

e Selecting a packet by clicking on it shows information about that packet above the
timeline.

e You can select multiple packets by dragging within the timeline or by holding the
SHIFT key down while arrowing.

e Using the mouse scroll wheel scrolls the timeline vertically

e You can also zoom by using a right click (which displays specific magnification
values), using the + and - Zoom tools, or by selecting a value from the Zoom menu.

e Packet length indicates duration

9.3 Navigating and Selecting Data

96



frontline

Debug Communications Faster!sv

e Buttons, menu items, and keystrokes can be used to go to the next or previous
packet, next or previous invalid interframe spacing (IFS), next or previous error
packet, and the first or last packet.

e Asingle packet is selected either by clicking on it, navigating to it, or selecting it in
the Frame Display.

e Selecting Previous Packet with a packet that is currently not visible, places it in the
top row (i.e. the display scrolls up just enough to make it visible).

e Selecting Next Packet with a packet that is currently not visible, places it in the
bottom row (i.e. the display scrolls down just enough to make it visible).

e Multiple packets are selected either by dragging the mouse or by holding down the
shift key while navigating or clicking.

e When a single packet is selected in the timeline it is also becomes selected in the
Frame Display. When multiple packets are selected in the timeline, only one of them
is selected in the Frame Display.

e The left arrow key goes to the previous packet. The right arrow key goes to the next
packet. The Ctrl-left arrow key goes to the previous error packet. The Ctrl-right
arrow key goes to the next error packet.

9.4 Button Bar

The button bar contains the following:

‘i‘ﬁ Lock - The Lock button only appears in live mode and is automatically
depressed when the user scrolls.

Unlock

First Packet
Previous Packet
Next Packet

Last Packet

*+ © 0 0 0 =

Previous Interframe Spacing (IFS) Error

e Interframe Spacing is considered valid if it is within 150 ps + or - 2us

o Ifthe Interframe Spacing is less than 148 us or greater than 152 us but
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less than or equal to 300 ps, it is considered an IFS error.
l# Next Interframe Spacing (IFS) Error
e Interframe Spacing is considered valid if it is within 150 ps + or - 2us

o Ifthe Interframe Spacing is less than 148 us or greater than 152 ps but
less than or equal to 300 us, it is considered an IFS error.

us

Previous Error Packet

Next Error Packet

Zoom In - Click on the icon each time to zoom in from 5.0625 s to 7.5 ms.
Zoom Out - Click on the icon each time to zoom out from 7.5 ms to 5.0625 s.

Reset - The Reset button appears only in live mode. Reset causes all packet
data up to that point to be deleted from the Packet Timeline display. This does
not affect the data in the Frame Display or Protocol Navigator. Resetting the
display may be useful when the most recent throughput values are of interest.

¢ P P I 1

9.5 Menu Bar

The menu bar contains the following:

File Menu:

Toolbar
Status Bar

Toggle Display Lock (available only in
live mode)

Reset (available only in live mode)

Exit

Zoom Menu: Keyboard
Shortcuts:

Zoom In Ctrl+Plus
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Zoom Out Ctrl+Minus
Zoom In Tool

Zoom Out Tool

Selection Tool

7.5 ms ( 6 1.25 ms time internals(3x 2))

22.5ms (18 1.25 ms time internals (6 x 3))

90 ms (72 1.25 ms time intervals (12 x 6))

202.5 ms (1.62 1.25 ms time intervals (18 x 9))
360 ms (288 1.25 ms time intervals (24 x 12))
562.5 ms (450 1.25 ms time intervals (30 x 15))
810 ms (648 1.25 ms time intervals (36 x 18))
1.1025 s (882 1.25 ms time intervals (42 x 21))
1.44 s (1152 1.25 ms time intervals 948 x 24))
1.8225 s (1458 1.25 ms intervals ((54 x 27))
2.255 (1800 1.25 ms time intervals (60 x 30))
2.7255 s (2178 1.25 ms time intervals (66 x 33))
3.24 s (2592 1.25 ms time intervals (72 x 36))
3.8025 s (3042 1.25 ms time intervals (78x39))
4.41 s (3528 1.25 ms time intervals (84x42))

5.0625 s (4050 1.25 ms time intervals (90x45))

Navigate Menu: Keyboard Shortcuts:
First Packet Home

Last Packet End

Previous Packet Left Arrow

Next Packet Right Arrow
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Previous Invalid IFS
Packet

Next Invalid IFS
Packet

Previous Error
Packet

Next Error Packet
Selected Packet

Lock (available only
in live mode)

Help Menu:
Help Topics

About

Ctrl+Left Arrow

Ctrl+Right Arrow
Enter

L

9.6 Visual Elements

frontline

Debug Communications Faster!sv

The low energy Timeline consists of the following visual elements:

¢ Rows

e Time Markers

Time markers indicated by vertical blue lines are shown with a width of
1.25 ms. These are provided to help visualize the timescale and are also
useful when using dual-mode chips that do BR/EDR and LE at the same
time. Time markers snap to the beginning of the first data packet by
default, but they can be snapped to the beginning or end of any packet
by right-clicking on a packet and selecting Align Time Marker to

Beginning of Packet or Align Time Marker to End of Packet.

e 2,1,and 0 labels

Within each row,2, 1, and 0 radio labels indicate which radio the packet
is from.
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¢ Timestamp

The timestamp of beginning of each row is shown underneath each row.

e Packet Info Line
The packet info line appears just above the timeline and displays
information for the currently selected packet(s).
When you select multiple packets, the information includes:
e Gap = duration between the end of the first packet and
the beginning of the last packet.

e Timestamp Delta = Duration between the beginnings of
the first and last packet.

e Span = Duration between the beginning of the first packet
and the end of the last packet

¢ Floating Information Window (aka Tooltip)
The information window displays when the mouse cursor hovers on a
packet. It persists as long as the mouse cursor stays on the packet.

¢ Discontinuities

Discontinuities are indicated by cross-hatched slots. See the
Discontinuities section.

e Zoom Tools

Zoom tools zoom in or out while maintaining the position on the screen
of the area under the zoom tool. This makes it possible to zoom in or out
for a specific packet or area of the timeline. See the “Zooming” section.

e Packet Status

Packet status is indicated by color codes. A thick red border indicates a
CRC error. A thick dark red border indicates a decryption error. A thick
magenta border indicates an invalid IFS.

¢ Right-Click Menu.

The right-click menu provides zooming and tool selection and time
marker alignment.

e Graphical Packet Depiction
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Each packet within the visible range is graphically depicted. See the
“Packet Depiction” section.

¢ Swap Button

The Swap button switches the position of the Timeline and the
Throughput graph.

¢ Show Running Average

Selecting this check box shows a running average in the Throughput
Over Time graph as an orange line

9.7 Zooming

Zoom features can be accessed from the Zoom menu, clicking a zoom tool on the toolbar, or
by right clicking on the Timeline window.

A couple of things to remember about Zooming.

e Zoom tools accessed using the right click menu allow you to maintain the current
position on the screen and precisely zoom in to a specific packet.

e Selecting a Zoom icon (+ or -) on the toolbar does not change the pointer to a Zoom
Tool. Each distinct click only zooms in our out.

e Zoom tools accessed from the Zoom Menu have a pointer in the upper-left corner
which is useful for specifying the zoom location and bringing up a tool tip of a
specific packet.

9.8 Throughput Displays

Throughput is payload over time. There are 3 categories of throughput:

e Average
e 1-second
e Graph

In computing throughput, packets that have a CRC error are excluded. (thick red border).

9.9 Packet Throughput
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The following figure depicts the Average and 1 Second Packet Throughput displays. This
display appears when you select Packet Throughput at the Throughput Graph.

Awverage Packet Throughput
559,164 Bits/5ec

1 Second Packet Throughput
B,720 Bit=r=ec

Width = peak = 559,164

e Average Packet Throughput is the total packet size over the entire session divided
by the total time. Total time is calculated by taking the difference in timestamps
between the first and last packet.

e 1-Second Packet Throughput is the total packet size over the most recent one
second of duration.

e Width = peak =: This displays the maximum throughput seen so far.

e Ahorizontal bar indicates percentage of max seen up to that point, and text gives the
actual throughput.

9.10Payload Throughput

The following figure depicts the Average/ One Second Payload Throughput display. This
display appears when you select Payload Throughput at the Throughput Graph.

Awerage Pavload Throughput
261 376 Bitzizec

1 Second Payload Throughput
3,240 BitzrSec

Width = peak = 261 376

e Average Payload Throughput is the total payload over the entire session divided by
the total time.

e 1-second throughputis not an average. Since it’s not an average, it behaves
differently than average throughput. In particular, while average throughput can be
very large with only a couple of packets (since it's dividing small packet or payload
size by small time), 1-second throughput is very small (since it counts only what it
sees and doesn't try to extrapolate).

e Width = peak =: This displays the maximum throughput seen so far.

9.11Packet/Payload Throughput
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The following figure depicts the Average and 1 Second Packet Packet and Payload
Throughput displays. This display appears when you select Both at the Throughput Graph.

Awerage Packet Throughput
554,164 Bitzizec

BAyerage Papload Throughput
261 376 Bitzizec

1 Second Packet Throughput
6,720 Bit=r=ec

1 Second Payload Throughput
3,240 Bitsr=ec

Width = peak = 559,164

e Average Packet Throughput is the total packet size over the entire session divided
by the total time. Total time is calculated by taking the difference in timestamps
between the first and last packet.

e Average Payload Throughput is the total payload over the entire session divided by
the total time.

e 1-Second Packet Throughput is the total packet size over the most recent one
second of duration.

e 1-Second Payload Throughput is not an average. Since it’s not an average, it
behaves differently than average throughput. In particular, while average
throughput can be very large with only a couple of packets (since it’s dividing small
packet or payload size by small time), 1-second throughput is very small (since it
counts only what it sees and doesn't try to extrapolate).

e Width = peak =: This displays the maximum throughput seen so far.

9.12Throughput Graph

9.13

The following figure depicts the Throughput Graph (Throughput Over Time).
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The Swap Button

The Swap button switches the position of the Timeline and the Throughput graph.

e Selecting Packet Throughput displays just the Packet Throughput in graph form
and displays the Average and 1 Second Packet Throughput on the left side of the
dialog. The y-axis numbers appear in blue.

e Selecting Payload Throughput displays just the Payload Throughout in graph form
and displays the Average and 1 Second Payload Throughput on the left side of the
dialog.. The y-axis numbers appear in green.

e Selecting Both displays both Packet and Payload Throughput. The y-axis numbers
appear in blue.

e Packet Throughput = Blue
e Payload Throughput = Green

¢ Selecting Configured Devices displays data only from devices that you have
configured in Frame Display or where the LA-DATA layer exists.

e Selecting All Devices displays data from all available devices.

The bottom of the graph shows a beginning time and an ending time. The beginning time is
relative to the start of the session and is initially 0. When packets start wrapping out it
becomes the relative time offset of the first available packet. The ending time is always the
total time of the session.

Discontinuities are indicated by vertical dashed lines.

A green viewport indicates the time range corresponding to the visible timeline. The
viewport can be moved by clicking elsewhere in the graph or by dragging it. Whenever it is
moved, the timeline scrolls to match. When the timestamp range in the timeline changes,
the viewport moves and resizes as necessary to match.

Show Running Average

Selecting this check box shows a running average in the Throughput graph as an orange
line.

9.14 Discontinuities

The following figure depicts a Discontinuity between two packets.
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Timestamp: 112002008 1004956 133439 AM (+0/00375)

| ]

Timestamp: 112002009 1004556 137189 AM (+0.0075) :

To keep the timeline and the throughput graph manageable, big jumps in the clock are not
represented linearly. Instead, they are shown as discontinuities. A discontinuity is said to
exist when the clock goes forward more than 4.01 seconds or backwards any amount. A
discontinuity is indicated by a cross-hatched slot in the timeline and a corresponding
vertical dashed line in the throughput graph.

The reason that the discontinuity trigger is set at 4.01 seconds is because the maximum
connection interval time is four (4) seconds.

9.15Legend

This legend identifies the color coding found in the timeline.
| A (Advertining) fEESTEE

[ Acv (Scansing) Side 2
[ Adv initiatory [ Master
[ Adwv itnknewny ] Steave
Deatas | Start)
E it { Cort) E EI:;:I'::I:)QCHH
Opata Empty) b3y gps
] mata ity
B Data (Unknown) (] Selected
[ unkrezrem: A Discorntinuity

e When you select a packet in the timeline, items in the legend that relate to the
packet are highlighted.

¢ A Bold highlight indicates that the packet that has been seen in the timeline.
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10 Data Extraction

10.1Data Extraction

The Data Extraction @ plug-in allows you to extract files that were transferred over
various protocols. You can also choose to have the files opened automatically as long as you
have applications able to read the files.

To extract data, select the Extract Data menu item from the View menu on the Control
window. When you select this item a settings dialog appears that allows you to define how
the system extracts the data.

A status dialog displays the progress and important information concerning the extraction.

10.2Data Extraction Settings

The Data/Audio Extraction % plug-in allows you to extract files that were transferred
over Bluetooth® profiles.

1. Choose a checkboxe(s) on left side of the dialog to identify from which profiles you
want to extract data.

It's important to note that if there is no data for the profile(s) you select, no extracted file is
created.

2. Ifyou want to open the file(s) automatically after they are extracted, select the Open
File(s) After Extraction checkbox.
Note: This does not work for SCO/eSCO.

3. Click on a radio button to write the streams as Two Mono Files or as One Stereo
File. This is for SCO/eSCO only.

4. Select the checkbox if you want to convert A-Law and p-law to Linear PCM.
CVSD are always converted to Linear PCM. You may choose to convert to Linear
PCM since more media players accept this format.

5. Select the Add silence packets to insert the silence packets (dummy packets) for the
reserved empty slots into the extracted file. If this option is not selected, the audio
packets are extracted without inserting the silence packets for the reserved empty
slots. This is for SCO/eSCO only.

6. Select Extract.
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A Save As dialog appears.

Save As
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The application will assign a file name and file type for each profile you select in Step 1
above. A separate file for each profile will be created, but only for those profiles with

available data.

7. Select alocation for the file(s).
8. Click Save.
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11 Find

11.1Starting a Search

You can search your data in several different ways. Some types of searches are relevant only
for framed data and is not offered if the data is not framed. Other types of searches are
available depending on the type of data being viewed.

To Begin a Search

1. Open a capture file, or capture some data to search.
2. Open the Event Display ﬁ or Frame Display EI window.

Click on the Find icon ﬂﬂ or choose Find from the Edit menu.

4. The Find window has a tab for each type of search. Click on the appropriate tab for
the type of search you want to do.

5. Select the parameters for your search, and click Find Next. Find Next looks for the
next occurrence of the search criteria, while Find Previous looks for an earlier
occurrence of the search criteria.

6. Press F3 to repeat the last search.

Search results are highlighted in the Event or Frame Displays, or both if appropriate. The
selection in the Event Display appears on the third line down from the top of the window by
default: this value can be changed.

Types of Searches

String or Pattern in the Data
String or Pattern in the Protocol Decode - (framed data only)

Byte Error - such as parity or framing errors (serial data only)
Frame Error - such as a CRC error an FCS error or an error in the decode (framed data only)

Control Signal Changes - (serial data only)
Time (move to data captured at a specific time or move through the data by time interval)

Special Event
Go To a Specific Byte or Frame Number

Go to a Bookmark
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11.2Using Go To

This type of search allows you to go to a particular frame or event, or to move through the
data X number of events or frames at a time. You can move either forward or backwards
through the data.

To access the Go To function:

1. Select Go To from the Edit menu on the Frame Display, Event Display, or the Protocol

Navigator. You can also click the Find icon ﬂﬂ on the toolbar
2. The system displays the Find dialog with the Go To tab selected.

Diecods | Pattesn | Tene | GoTo | Specasl Events | Bookemark

©FimsNuaber] |1 love Ecrmind)

() Dusts E vesrik Misnbees | Move Back
Henyeddelind et J

) ANEveris Numbes

% Heb

Note: The tabs displayed on the Find dialog depend on the product you are running and the
content of the capture file or buffer you are viewing.

To go to a particular frame :
1. Select the Frame Number radio button
2. Type the frame number in the box.
3. Click the Go To button.
4

To move forward or backward a set number of frames, type in the number of frames you
want to move

5. Then click the Move Forward or Move Back button.

To go to a particular event :

1. Select the Data Event Number or All Events Number radio button.
2. Type the number of event in the box.

3. Click the Go To button.
4

To move forward or backwards through the data, type in the number of events that you
want to move each time.
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5. Then click on the Move Forward or Move Backward button.

6. For example, to move forward 10 events, type the number 10 in the box, and then click
on Move Forward. Each time you click on Move Forward, FTS moves forward 10 events.

See Event Numbering for why the Data Event Number and All Events Number may be

|
different. As a general rule, if you have the Show All Events icon * depressed on the Event
Display window or Frame Display Event pane, choose All Events Number. If the Show All
Events button is up, choose Data Event Number.

Starting a Search

11.3Searching for Control Signal Changes

Control signal searching allows you to search for changes in control signal states for one or
more control signals. You can also search for a specific state involving one or more control
signals, with the option to ignore those control signals whose states you don’t care about.

The analyzer takes the current selected byte as its initial condition when running searches
that rely on finding events where control signals changed.

To access the control signal search function

1. Select Find from the Edit menu on the Frame Display, Event Display, or the Protocol

Navigator. You may choose to click the Find icon from one of the toolbars

2. Click on the Signal tab of the Find dialog.

Decode | Pattesn Tene | GoTo| Specisl Everds | 5908l |Emor | Boc 4 F

Semch lof event whese
5 /Dne o more of these| O co moee of these
_l:"hﬂw

D-:hunoed froem on ho off
"y One o more of these OTI-.:M@ [Fde'm-m

= changed iom off bo on bt thes slabe :i
Help

WRTS
EICTS
#DSR
=0OTR
=D
Gl

Note:
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The tabs displayed on the Find dialog depend on the product you are running and the
content of the capture file you are viewing.
Selecting Control Signals to Search

The section with the check boxes allows you to specify which control signals the analyzer
should pay attention to when doing the search. The analyzer pays attention to any control
signal with a check mark.

e (lick on a box to place a check mark next to a control signal
e (lick again to uncheck the box

e By default, the analyzer searches all control signals, which means all boxes start out
checked.

For example, if you are only interested in finding changes in RTS and CTS, you would check
those two boxes and uncheck all the other boxes. This tells the analyzer to look only at the
RTS and CTS lines when running the search. The other signals are ignored.

Searching for On, Off, or Changed States

The first three options are all fairly similar, and are described together. These options are
searching for an event where:

e One or more control signals changed
e One or more control signals changed from off to on
e One or more control signals changed from on to off

Searching for an event where one or more signals changed means that the analyzer looks at
every control signal that you checked, and see if any one of those signals changed state at
any time.

If you want to look at just one control signal:
e Check the box for the signal.
e Uncheck all the other boxes.
e Choose to search for an event where one or more signals changed.

e The analyzer notes the state of the selected signal at the point in the buffer where
the cursor is, search the buffer, and stop when it finds an event where RTS changed
state.

e Ifthe end of the buffer is reached before an event is found, the analyzer tells you
that no matches were found.

Searching for events where control signals changed state from off to on, or vice versa, is
most useful if the signals are usually in one state, and you want to search for occasions
where they changed state.

For example,
e IfDTRis supposed to be on all the time but you suspect that DTR is being dropped

e Tell the analyzer to look only at DTR by checking the DTR box and unchecking the
others

e Do asearch for where one or more control signals changed from on to off.
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The analyzer would search the DTR signal and stop at the first event where DTR
dropped from on to off.

Searching for an Exact State

To search for an exact state means that the analyzer finds events that match exactly the
state of the control signals that you specify.

First, choose to search for an event where your choices exactly describe the state.

This changes the normal check boxes to a series of radio buttons labeled On, Off and
Don’t Care for each control signal.

Choose which state you want each control signal to be in.
Choose Don’t Care to have the analyzer ignore the state of a control signal.

When you click Find Next, the analyzer searches for an event that exactly matches
the conditions selected, beginning from the currently selected event.

If the end of the buffer is reached before a match is found, the analyzer asks you if
you want to continue searching from the beginning.

If you want to be sure to search the entire buffer, place your cursor on the first
event in the buffer.

Starting a Search

11.4Searching for Data Errors

The analyzer can search for several types of data errors. You can choose which errors you
want to search for and whether to search the DTE or DCE data or both. Bytes with errors are
shown in red in the Event Display window, making it easy to find errors visually when
looking through the data.

To access the data errors search function

1. Select Find from the Edit menu on the Frame Display, Event Display, or the Protocol

Navigator. You may choose to select the Find icon from one of the toolbars

2. Click on the Error tab of the Find dialog.
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Note:

The tabs displayed on the Find dialog depend on the product you are running and the
content of the capture file you are viewing.
Selecting Which Errors to Search

The section with the check boxes allows you to choose which errors the analyzer should
look for. Click on a box to check or un-check it

If you want to search only for overrun errors
e check the overrun box
e un-check the other boxes.

To search for all types of errors

e check all boxes

Searching for Error Conditions

The first three options are all fairly similar, and are described together. These options are
searching for an event where:

e one or more error conditions changed
e one or more error conditions occurred
e one or more error conditions were off (i.e. no errors occurred)
The most common search is looking for a few scattered errors in otherwise clean data.
To do this type of search:
e choose to search for an event where one or more error conditions occurred
e choose which errors to look for

e By default, the analyzer looks for all types of errors.
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In contrast, searching for an event where one or more error conditions were off means that
the analyzer looks for an event where the errors were not present.

For example, if you have data that is full of framing errors, and you know that somewhere in
your 20 megabyte capture file the framing got straightened out, you could choose to search
for an event where one or more error conditions were off, and choose to search only for
framing. The analyzer searches the file, and finds the point at which framing errors stopped
occurring.

Searching for an event where the error conditions changed means that the analyzer
searches the data and stop at every point where the error condition changed from on to off,
or off to on.

For example, if you have data where sometimes the framing is wrong and sometimes right,
you would choose to search framing errors where the error condition changed. This first
takes you to the point where the framing errors stopped occurring. When you click Find
Next, the analyzer stops at the point when the errors began occurring again.

The analyzer takes the current selected byte as its initial condition when running searches
that rely on finding events where error conditions changed. The analyzer searches until it
finds an event where error conditions changed or it reaches the end of the buffer, at which
point the analyzer tells you that there are no more events found in the buffer. If you are
searching for an exact match, the analyzer asks you if you want to continue searching from
the beginning of the buffer.

Searching for Exact Error Conditions

To search for an exact state means that the analyzer finds events that exactly match the
error conditions that you specify.

e Select the "This exactly describes the state" radio button.

e This changes the normal check boxes to a series of radio buttons labeled On, Off and
Don’t Care for each error.

¢ On means that the error occurred
e Off means that the error did not occur

e Don’t Care means that the analyzer ignores that error condition.

Select the appropriate state for each type of error.

Example:

If you need to find an event where just an overrun error occurred, but not any other type of
error, you would choose overrun error to be On, and set all other errors to Off. This causes
the analyzer to look for an event where only an overrun error occurred.

If you want to look for events where overrun errors occurred, and other errors may have
also occurred but it really doesn’t matter if they did or not, choose overrun to be On, and set
the others to Don’t Care. The analyzer ignores any other type of error, and find events
where overrun errors occurred.

To find the next error, click the Find Next button. To find an error that occurred earlier in
the buffer to where you are, click the Find Previous button.
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Starting a Search

11.5Searching for Frame Errors

There are several options for error searching:

o Search for All Errors finds frame errors as well as frames with byte-level errors
(such as parity or CRC errors).

e Search for Frame Errors Only finds Frame specific errors, such as Frame Check
errors.

e Search for Information Frame only searches Information Frames

To access the search within decodes function:

1. Select Find from the Edit menu on the Frame Display, Event Display, or the Protocol

Navigator. You may choose to select the Find icon Eﬂ from one of the toolbars
2. Click on the Decode tab of the Find dialog.

3. Click the appropriate radio button for the type of search you want to perform or enter a
value

4. Click Find Next.

Decode | Patem | Time | GoTo Specisl Events | Bookmark

(%) Seach For Siring In Decods [Cligreve case

w Furd Fravvacass
() Smmch For il Emoes
() Seach For FramaElrlE% Oiriy
(7 Search For Information Frames
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Note:

The tabs displayed on the Find dialog depend on the product you are running and the
content of the capture file you are viewing.

11.6Searching for Special Events

The analyzer inserts or marks events other than data bytes in the data stream.

For example, the analyzer inserts start-of-frame and end-of-frame markers into framed
data, marking where each frame begins and ends. If a hardware error occurs, the analyzer
shows this using a special event marker.

To access the search for special events function:

1. Select Find from the Edit menu on the Frame Display, Event Display, or the Protocol

i

Navigator. You may choose to select the Find icon from one of the toolbars

2. Click on the Special Events tab of the Find dialog.
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3. Check the event or events you want to look for in the list of special events.

4, Click Find Next.

Note:

The tabs displayed on the Find dialog depend on the product you are running and the
content of the capture file you are viewing.

e Notall special events are relevant to all types of data. For example, control signal
changes are relevant only to serial data and not to Ethernet data.

For a list of all special events and their meanings, see List of All Event Symbols.

Starting a Search

11.7Searching within Decodes

Searching within decodes lets you to do a string search on the data in the Decode Pane of
the Frame Display window.

You can search one or both sides of the circuit, and your search can include wildcards. You
can use characters, hex or binary digits, wildcards or a combination of any of the formats
when entering your string.

To access the search within decodes function:

1. Select Find from the Edit menu on the Frame Display, Event Display, or the Protocol

i}

Navigator. You may choose to select the Find icon from one of the toolbars.
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2. Click on the Decode tab of the Find dialog.
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11.8Side Restrictions
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The tabs displayed on the Find dialog depend on the product you are running and the
content of the capture file you are viewing.

Side Restriction means that the analyzer looks for a pattern coming wholly from the DTE or
DCE side. If you choose to search without regard for data origin, the analyzer looks for a
pattern coming from one or both sides.

For example, if you choose to search for the pattern ABC and you choose to search without
regard for data origin, the analyzer finds all three instances of ABC shown below.
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The first pattern, with the A and the C coming from the DTE device and the B coming from
the DCE is a good example of how using a side restriction differs from searching without
regard to data origin. While searching without regard for data origin finds all three patterns,
searching using a side restriction never finds the first pattern, because it does not come
wholly from one side or the other.

If you choose to search for the pattern ABC, and you restrict the search to just the DTE side,
the analyzer finds the following pattern:

=1 Event Display QEE

Fle Edt View Formab Options Window Help
A CHES2 A3 L 4% B

Ewerd Number | ] A
DTE

W
Ewert 16 to 42 of 6,425 (27 events)
Rate Dweta CRCOTE CRC DCE
— Mo Timestamg — | -- No Tamestamp -- 9¢ 35

| For Help Press Fl

In this example, the analyzer finds only the second pattern (highlighted above) because we
restricted the search to just the DTE side. The first pattern doesn't qualify because it is split
between the DTE and DCE sides, and the third pattern, though whole, comes from just the
DCE side.

If we choose both the DTE and the DCE sides in the above example, then the analyzer finds
the second pattern followed by the third pattern, but not the first pattern. This is because
each side has one instance in which the whole pattern can be found. The analyzer
completely searches the DTE side first, followed by the DCE side.

Side Restriction is available for pattern and error searching.
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11.9Searching by Signal

You can search using information originating from the Breakout Box.

1. Select one or more of the checkboxes for Pin 1, 2, 3, or 4.
Click here to learn more about the Breakout Box and Pins 1 - 4.

2. Select one of the four radio buttons to choose the condition that must be met in the
search

¥ Find - USB ComProbe || Sniffer
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3. Click Find Next to locate the next occurrence of the search criteria or Find Previous to
locate an earlier occurrence of the search criteria.

11.10 Changing Where the Search Lands

When doing a search in the analyzer, the byte or bytes matching the search criteria are
highlighted in the Event Display. The first selected byte appears on the third line of the
display.

To change the line on which the first selected byte appears:
1. Open fts.ini (located in the C:\Program Files\Common Files\FTE)
2. Go to the [CVEventDisplay] section
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3. Change the value for SelectionOffset.

4. If you want the selection to land on the top line of the display, change the SelectionOffset
to 0 (zero).

11.11 Subtleties of Timestamp Searching

Timestamping can be turned on and off while data is being captured. As a result, the capture
buffer may have some data with a timestamp, and some data without. When doing a search
by timestamp, the analyzer ignores all data without a timestamp.

Starting a Search

11.12 Entering Search Patterns (String Searches)

11.12.1 Searching by Pattern

Search by Pattern lets you perform a traditional string search. You can combine any of the
formats when entering your string, and your search can include wildcards. You can search
one or both sides of a circuit containing interwoven data such as serial communication.

To access the search by pattern function:

1. Select Find from the Edit menu on the Frame Display, Event Display, or the Protocol

Navigator. You can also click the Find icon ﬂﬂ from one of the toolbars.
2. Click on the Pattern tab of the Find dialog.
® Find EBX
Decode | Patten | Time | GoTo| Special Events | Bookmark
Pattem: v
Enter: Hex values as $ux [ ignore case Find P
Binary values as &bbbbbbbb

Control characters as “c
7 matches any byte, or hex of binary digit
To enter $8°7 ar \, prefic with character \
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Note:

The tabs displayed on the Find dialog depend on the product you are running and the
content of the capture file you are viewing.

11.12.2 Entering Characters

Various characters are used when creating a search string on the Find dialog. You can enter
any character from a character set, with the following exceptions: \$&”"?. These characters
are used as prefixes to let you to enter hex, binary, control or wildcard characters.

1. Place the cursor in the Pattern box and type in your string.
2. Click Find Next in order to find the next occurrence of the string.

3. Click on Find Next as many times as necessary until the analyzer has searched all the
data.

4. Clicking on Find Previous searches the buffer backwards.

The escape character is the backslash \. Use this character when you want to search for one
of the above restricted characters. For example, to search for a $, you enter \$. To search
for a\, enter \\.

Check Ignore Case to do a case-insensitive search.
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11.12.3 Entering Hex or Binary

Hex or Binary values are used when creating a search string on the Find dialog.
To enter a hex value :

1. Enter a $ followed by two hex digits.

2. For example, to search for hex 00 01, enter $00$01.
3. Ifyou need to specify the $ as a character, use \$.
4

The $ symbol tells the analyzer that the following characters are hex digits

To enter a binary value:

e The & symbol tells the analyzer that a binary number comes next. For example, to
search for binary 00001111, you would use &00001111.

e Ifyou need to specify the & as a character, use \ &.

11.12.4 Control Characters

Various control characters are used when creating a search string on the Find dialog. You
can enter any character from a character set, with the following exceptions: \$&"?. These
characters are unavailable. The ” (caret) is used to enter the control characters Ctrl-A
through Ctrl-Z and Ctrl-@,[,\ ],- when using the ASCII character set. For example, *A
specifies Ctrl-A ($01) and *@ specifies ASCII NUL ($00).

If you need to specify the * as a character, use \".

Note that neither the * character nor control characters exist in Baudot, so attempts to
search for the ” character results in an error message. The * character exists in EBCDIC, but
control characters do not. A search for A in EBCDIC matches any occurrence of *A
($5F$C1). You do not need to use the escape character to search for a * character in EBCDIC.

11.12.5 Wildcard Character

A wildcard can be used when creating a search string on the Find dialog.

The wildcard character is the question mark (?). The analyzer supports wildcard searching
at the byte, nibble and bit level. Wildcards can be used in place of characters, hex digits, and
binary digits. If you need to search for a ?, you can use \?.

11.12.6 Examples of Search Strings

In the Find function on the Frame Display, Event Display, or Protocol Navigator, you can
search for any single byte in the range of hex $10 through $1F, type $1?.
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&1111117? searches for binary numbers beginning with 111111 and ending with any
combination of 1and 0. 11111100,11111101,11111110,and 11111111 are all strings that
match the search criteria.

To search for any four character string which starts with an L and ends with an ES, type
L?ES.

You can combine formats in one string. For example, another way to specify a search for the

11.13 Searching by Time

11.13.1 Searching by Time

The analyzer can search by time in two different ways.
e Absolute

An absolute timestamp search means that the analyzer searches for an event at the
exact date and time specified. If no event is found at that time, the analyzer goes to
the nearest event either before or after the selected time, based on the "Go to the
timestamp" selection.

e Relative

A relative search means that the analyzer begins searching from whatever event you
are currently on, and search for the next event a specific amount of time away.

Note that the analyzer skips some special events that do not have timestamps, such as frame
markers. Data events that do not have timestamps because timestamping was turned off
either before or during capture are also skipped.

To access the search by time function:

1. Select Find from the Edit menu on the Frame Display, Event Display, or the Protocol

Navigator. You may choose to select the Find icon ﬂﬂ from one of the toolbars.
2. Click on the Time tab of the Find dialog.

3. Use the "Search for" radio buttons at the top of the dialog to indicate the search type
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Note:

The tabs displayed on the Find dialog depend on the product you are running and the
content of the capture file you are viewing.

11.13.2 Searching with Absolute Timestamp

To access the search by time function:

1. Select Find from the Edit menu on the Frame Display, Event Display, or the Protocol

Navigator. You may also select the Find icon Eﬂ from one of the toolbars

2. Click on the Time tab of the Find dialog.

Note: The tabs displayed on the Find dialog depend on the product you are running and the
content of the capture file you are viewing.

3. Specify the time to search for by using the counters in the middle of the window.
e Click on the arrows next to each item to increase or decrease the value of

each counter.

e By default, the counters display the timestamp of the first event in the file

4. After selecting the time, click on the Go To button to start the search.
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Sometimes there can be more than one event with the same timestamp. The system
highlights all events with the specified timestamp.

11.13.3 Searching with Relative Timestamp

To access the search by time function:

1. Select Find from the Edit menu on the Frame Display, Event Display, or the Protocol

Navigator. You can also select the Find icon ﬂﬂ from one of the toolbars.

2. Click on the Time tab of the Find dialog.

¥ Find g@@
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For Help Press Fl

Note: The tabs displayed on the Find dialog depend on the product you are running and the
content of the capture file or buffer you are viewing.

3. Click on the event in the Event Display window that you want to begin the search from.
The event must have a timestamp in order for relative timestamp search to work.

4. In the Find dialog, use the counters in the middle of the window to specify the time
interval you want to jump.
You can specify intervals in days, hours, minutes, seconds, and fractions of a second, or
any combination of these.

5. When you have specified the time interval you want to use, click on the Move Forward
or Move Backward buttons to start the search from the current event.

127



frontline

Debug Communications Faster!sv

For example, to search for an event occurring 10 seconds after the currently selected event,
choose to do a relative timestamp search, use 10 seconds for your time interval, and click on
Move Forward.

As with absolute timestamping, the analyzer highlights all events with the specified
timestamp.

11.13.4
Choosing "On or Before" or "On or After"

The analyzer searches for an event that matches the time specified. If no event is found at
the time specified, the analyzer goes to the nearest event either before or after the specified
time. Choose whether to have the analyzer go to the nearest event before the specified time
or after the specified time by clicking the appropriate radio button in the "Go to the
timestamp" box.

If you are searching forward in the buffer, you usually want to choose the "On or After"
button. If you choose the "On or Before" option, it may be that the analyzer finishes the
search and not move from the current byte, if that byte happens to be the closest match.
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12 Bookmarks

12.1Bookmarks

e Bookmarks are a way to mark frames or events in a capture file. You can search for
bookmarks and move quickly between bookmarks.

e Bookmarks appear as a magenta triangle next to the frame number in the Frame
Display window. Any comment associated with the bookmark appears in the
Bookmark column.

e  When you add or change a bookmark, you are asked if you want to save your
changes when you close the capture file, and given the option of saving the
bookmarks to the current file or to a new one. See Confirming CFA Changes for more
information.

12.2 Adding, Modifying or Deleting a Bookmark

You can Add, Modify, or Delete a Bookmark from the Add Bookmark dialog from the Frame
Display, Event Display, or the Protocol Navigator.

Add:
1. Select the frame or event you want to bookmark.

2. Select Add or Modify Bookmark from the Edit menu on the Frame Display, Event Display,

or the Protocol Navigator. Or simply select the Add or Modify Bookmark u icon on
one of the toolbars.

3. Inthe dialog box, add a comment if you wish.

4. Click OK.

You can also add a bookmark by right-clicking on the frame and choosing Add Bookmark
from the right-click menu.

Modify and Delete:

1. Select the frame or event with the bookmark to be edited.

2. Select Add or Modify Bookmark from the Edit menu on the Frame Display@, Event
Display 4@ , or the Protocol Navigator . Or simply select the Add or Modify

Bookmark u icon on one of the toolbars.
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3. To modify a bookmark, change the comment in the dialog box and click OK.
4. To delete a bookmark, click the Delete button.

You can also modify or delete a bookmark by right-clicking on the frame and choosing
Modify Bookmark from the right-click menu.

12.3Displaying All and Moving Between Bookmarks

There are two ways to move between bookmarks.

1. Pressthe F2 key to move to the next frame or event with a bookmark.

2. Click the Display All Bookmarks icon . Select the bookmark you want to move to
and click the Go To button, or simply double-click on the bookmark. Click the Move
Forward and Move Back buttons to cycle through the bookmarks.

- BX

Decods | Pattern | Time | GoTo| Specisl Events | Bockmark
Eﬂ: LARLS mza‘ag% 1?.?;32?3?;455 PM ok ond

e To delete a bookmark, select it and click the Delete button.
¢ To modify a bookmark, select it and click the Modify button.
e Click Remove All to delete all the bookmarks.
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13 Filtering

13.1Difference Between Ethernet Capture Filters and Display
Filters

There are two types of filters: Display filters and Ethernet capture filters.

An Ethernet capture filter looks at frames when they are first captured. If the frame satisfies
the filter criteria, the frame is kept and put in the capture buffer. If the frame does not
satisfy the filter criteria, it is thrown away. Data that is filtered out using an Ethernet
capture filter cannot be recovered. Only one Ethernet capture filter can be active at a time.
Capture filtering is not available in serial products yet.

A display filter looks at frames that have already been captured. It looks at every frame in
the capture buffer and displays those that match the filter criteria. Frames that do not match
the filter criteria are not displayed. Unlike an Ethernet capture filter, where data that does
not match is thrown away, all the data is kept when using a display filter. The filter just
displays a subset of the data. Multiple display filters can be used simultaneously, and
different windows can be displaying data using different filters.

13.2Display Filters

13.2.1 About Display Filters

Display filters allow a user to look at a subset of captured data without affecting the capture
content. There are three general classes of display filters:

e Protocol Filters
e Named Filters
e Quick Filters

Protocol Filters

Protocol filters test for the existence of a specific single layer. The system creates a protocol
filter for each decoder that is loaded if that layer is encountered in a capture session.

There are also three special purpose filters that are treated as protocol filters:
e All Frames with Errors
e All Frames with Bookmarks

e All Special Information Nodes

Named Filters
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e Named filters test for anything other than simple single layer existence. Named
filters can be constructed that test for the existence of multiple layers, field values in
layers, frame sizes, etc., as well as combinations of those things. Named filters are
persistent across sessions.

¢ Named filters are user-defined. User-defined filters persist in a template file. User
defined filters can be deleted.

Quick Filters

e Quick Filters are combinations of Protocol Filters and/or Named Filters that are
displayed on the Quick Filter tab.

e Quick Filters cannot be saved and do not persist across sessions.

e Quick Filters are created on the Quick Filter Dialog or through filter selection on the
Protocol Navigator.

13.2.2 Including and Excluding Radio Buttons

All filter dialog boxes contain an "Include" and an "Exclude"” radio button. These buttons are
mutually exclusive. The "Include/Exclude" selection becomes part of the filter definition,
and appears as part of the filter description displayed to the right of the Toolbar.

Include:

A filter constructed with the "Include” button selected, returns a data set that includes
frames that meet the conditions defined by the filter and omits frames that do not.

Exclude:

A filter constructed with the "Exclude” button selected, returns a data set that excludes
frames that meet the conditions defined by the filter and consists of frames that do not.

13.2.3 Creating a Display Filter

There are two steps to using a display filter. Define the filter conditions, and then apply the
filter to the data set. The system combines both filter definition and application in one
dialog.

1. Click the Display Filters icon ? on either the Protocol Navigator or the Frame

Display @window or select Apply/Modify Display Filters from the Filter menu to open
the Set Condition dialog box.

2. Select Include or Exclude to
3. Select the initial condition for the filter from the drop-down list.

4. Set the parameters for the selected condition in the fields provided. The fields that
appear in the dialog box are dependent upon the previous selection. Continue to enter
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the requested parameters in the fields provided until the condition statement is
complete.

5. Click OK. The system displays the Save Named Condition dialog. Provide a name for the
filter condition or accept the default name provided by the system and click OK.
Prohibited characters are left bracket '[', right bracket '] and equal sign '=". The Set
Condition dialog box closes, creates a tab on the Frame Display with the filter name, and
applies the filter.

The filter appears in the Quick Filtering and Hiding Protocols dialog also.

When a display filter is applied, a description of the filter appears to the right of the toolbar
in both the Protocol Navigator and the Frame Display windows.

Notes:

The system requires naming and saving of all filters created by the user.

The OK button on the Set Condition dialog box is unavailable (grayed out) until the condition
selections are complete.

When you have multiple Frame Display windows with a display filter or filters, those filter
do not automatically appear in other Frame Display windows. You must use the
Hide/Reveal feature to display a filter created in one Frame Display in different Frame
Display window.

13.2.4 Named Display Filters

You can create a unique display filter by selecting a data type on the Frame Display and
using a right click menu. When you create a Name Filter, it appears in the Quick Filtering
dialog, where you can use it do customize the data you see in the Frame Display panes.

1. Select a frame in the Frame Display Summary Pane.

2. Right click in the one of the data columns in the Summary Pane: CRC, NESN, DS, Packet
Success, Ethertype, Source Address, etc.

3. Select Filter in (data type)

The Filtering Results dialog appears.

4. Enter a name for the filter

5. Select OK.

The filter you just created appears in the Named Filters section of the Quick Filtering dialog.
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13.2.5 Using Compound Display Filters

Compound filters use Boolean logic to create complex and precise filters. There are three
primary Boolean logic operators: AND, OR, and NOT.

The AND operator narrows the filter, the OR operator broadens the filter, and the NOT
operator excludes conditions from the filtered results. Include parentheses in a compound
filter to nest condition sets within larger condition sets, and force the filter-processing
order.

There are two steps to using a compound filter. Define the filter conditions, and then apply
the filter to the data set. The analyzer combines both filter definition and application in one
dialog.

1. Click the Display Filters icon ? on either the Protocol Navigator or the Frame Display
window or select "Apply/Modify Display Filters" from the filter menu to open the Set
Condition dialog box.

2. Click the Advanced button on the Set Condition dialog box.
3. Select the initial condition for the filter from the combo box.

4. Set the parameters for the selected condition in the fields provided. The fields that
appear in the dialog box are dependent upon the previous selection. Continue to enter
the requested parameters in the fields provided until the conditions statement is
complete.

5. Click the Plus icon ﬂ on the left side of the dialog box and repeat steps 3 and 4 for the
next condition. Continue adding conditions until your filter is complete.
6. Include parentheses as needed and set the Boolean operators.

7. Click OK. The system displays the Save Named Condition dialog. Provide a name for the
filter condition or accept the default name provided by the system and click OK. The Set
Condition dialog box closes, creates a tab on the Frame Display with the filter name, and
applies the filter.

When a display filter is applied, a description of the filter appears to the right of the toolbar
in both the Protocol Navigator and the Frame Display windows.

Note:

Use the Up ﬂand Down ﬂarrow icons on the left side of the dialog box to order your

conditions, and the Delete button E to delete conditions from your filter.

The OK button on the Set Condition dialog box is unavailable (grayed out) until the condition
selections are complete.

13.2.6 Defining Node and Conversation Filters
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There are two steps to using Node and Conversation display filter. Define the filter
conditions, and then apply the filter to the data set. The analyzer combines both filter
definition and application in one dialog.

1. Click the Display Filters icon ? on either the Protocol Navigator or the Frame Display
window or select "Apply/Modify Display Filters" from the filter menu to open the Set
Condition dialog box.

2. Choose "frames with the conversation" as the initial condition from the Select combo
box.

3. Select an address type from the Type combo box (The address type selection populates
both Address combo boxes with node address in the data set that match the type
selection).

4. Select a node address from the first Address combo box.

5. Choose a direction arrow from the Direction box. The left arrow filters on all frames
where the top node address is the destination, the right arrow filters on all frames
where the top node address is the source, and the double arrow filters on all frames
where the top node address is either the source or the destination.

6. If you want to filter on just one node address, skip step 7 & 8, and continue with step 9.

7. If you want to filter on traffic going between two address nodes (i.e. a conversation),
select an address type for the second node address from the Type combo box.

8. Select a node address from the second Address combo box.

9. Click OK. The Set Condition dialog box closes and the analyzer applies the filter.

When a display filter is applied, a description of the filter appears to the right of the toolbar
in both the Protocol Navigator and the Frame Display windows.
Note:

The OK button is unavailable (grayed out) until the condition selections are complete.

13.2.7 Using Advanced Display Filtering Techniques

Intermediate to advanced users, with a solid knowledge of filter definition and application
may find it useful to create some of the more common filters "on the fly" using the advanced
filtering techniques.

Choose one of the panes in either the Frame Display or Protocol Navigator windows:

1. Place the cursor over a parameter you wish to filter on such as a node address or
protocol type, and right click.

2. A pop up menu appears with selections for filtering.
3. Select the filter.

4. The system either closes the menu and applies the filter, or displays the Set Conditions
dialog box with the known parameters filled in and the additional options available to
complete the conditions statement.
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13.2.8 Deleting and Hiding Display Filters

13.2.8.1 The Difference Between Deleting and Hiding Display Filters

If you wish to remove a filter from the system permanently, then use the Delete procedure.
However, if all you want to do is remove a filter as a means to un-clutter the display, then
use the Hide procedure.

Deleting a saved filter removes the filter from the current session and all subsequent
sessions. In order to retrieve a deleted filter, the user must recreate it using the Set
Conditions dialog.

Hiding a filter merely removes the filter from the display. A hidden filter can be reapplied
using the Show/Hide procedure.

13.2.8.2 Deleting Saved Display Filters

1. Select Delete Display Filters from the Filter menu in either the Protocol Navigator @ or

the Frame Display @window to open the Delete Named Condition dialog. The system
displays the Delete Named Condition dialog with a list of all user defined filters.

2. Select the filter to be deleted from the drop-down list.
3. Click the Delete button.
4. Click OK. The Delete Named Condition dialog box closes and the system deletes the filter.

13.2.8.3 Hiding/Revealing a Display Filter

1. Select "Hide/Show Display Filters" from the filter menu on either the Protocol Navigator

@ or the Frame Display @window to open the Hide/Show dialog. The system
displays the Hide/Show dialog with a list of all user defined filters.

2. Select the filter to be hidden from the combo box.
3. Click the Hide button.

4. Click OK. The Hide/Show dialog box closes, and the system hides the filter and removes
the filter tab from the Frame Display.

Revealing a Hidden Display Filter

There are several ways to reveal a hidden filter. One can open the Quick Filter dialog and
check the box next to the hidden filter, or check the box next the hidden filter in the Protocol
Navigator display.

Perform the following actions to reveal a hidden filter:

1. Select "Hide/Show Display Filters" from the filter menu in either the Protocol Navigator

@ or the Frame Display @window to open the Hide/Show dialog. The system
displays the Hide/Show dialog with a list of all user defined filters.
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2. Select the filter to be revealed from the combo box.
3. Click the Show button.

4. Click OK. The Hide/Show dialog box closes and the system reveals the filter and adds the
filter tab to the Frame Display.

Note: When you have multiple Frame Display windows with a display filter or filters, those
filter do not automatically appear in other Frame Display windows. You must use the
Hide/Reveal feature to display a filter created in one Frame Display in different Frame
Display window.

13.2.9 Editing Filters

13.2.9.1 Modifying a Condition in a Filter

1. Click the Display Filters icon ? on either the Protocol Navigator @ or the Frame

Display @window or select "Apply/Modify Display Filters" from the Filter menu to
open the Set Condition dialog box. The Set Condition dialog box displays the current filter
definition. To display another filter, click the Open icon, and select the filter from the
Popup list of all the saved filters.

2. Edit the desired parameter of the condition.
Because the required fields for a condition statement depend upon previously selected
parameters, the Set Condition dialog box may display additional fields that were not
present in the original filter. In the event this occurs, continue to enter the requested
parameters in the fields provided until the condition statement is complete.

3. Click OK. The system displays the Save Named Condition dialog. Ensure that the filter
name is displayed in the text box at the top of the dialog, and click OK. (If you choose to
create an additional filter, then provide a new name for the filter condition or accept the
default name provided by the system and click OK.) The Set Condition dialog box closes,
and the system applies the modified filter.

Note:

When a display filter is applied, a description of the filter appears to the right of the toolbar
in both the Protocol Navigator and the Frame Display windows.

The OK button on the Set Condition dialog box is unavailable (grayed out) until the condition
selections are complete.

13.2.9.2 Deleting a Condition in a Filter

1. Click the Display Filters icon ? on either the Protocol Navigator or the Frame Display
window or select "Apply/Modify Display Filters" from the Filter menu to open the Set
Condition dialog box. The Set Condition dialog box displays the current filter definition.
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To display another filter, click the Open icon, and select the filter from the Popup list of
all the saved filters.

Select the desired condition from the filter definition.
Click the Delete icon.

Edit the Boolean operators and parentheses as needed.

AT SR

Click OK. The system displays the Save Named Condition dialog. Ensure that the filter
name is displayed in the text box at the top of the dialog, and click OK. (If you choose to
create an additional filter, then provide a new name for the filter condition or accept the
default name provided by the system and click OK.) The Set Condition dialog box closes,
and the system applies the modified filter.

Note:

When a display filter is applied, a description of the filter appears to the right of the toolbar
in both the Protocol Navigator and the Frame Display windows.

The OK button on the Set Condition dialog box is unavailable (grayed out) until the condition
selections are complete.

13.2.9.3 Renaming a Display Filter

1. Select "Rename Display Filters" from the Filter menu in either the Protocol Navigator

@ or the Frame Display @window to open the Rename Filter dialog. The system
displays the Rename Filter dialog with a list of all user defined filters.

2. Select the filter to be renamed from the combo box.
3. Enter a new name for the filter in the text box.

4. Click OK. The Rename Filter dialog box closes and the system renames the filter.

13.3Protocol Filtering from the Frame Display

13.3.1 Easy Protocol Filtering

There are two types of easy protocol filtering. The first method lets you filter on the
protocol shown in the Summary pane, and the second lets you filter on any protocol
discovered on the network so far.

13.3.2 Filtering On the Summary Layer Protocol

To filter on the protocol in the Summary in the Frame Display window pane:
1. Select the tab of the desired protocol, or open the Summary Layer combo box.

2. Select the desired protocol.
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3. Tofilter on a different layer, just select another tab, or change the layer selection in the
combo box.

13.3.3 Quick Filtering on a Protocol Layer

1. To filter on any protocol layer, open either the Frame Display or Protocol Navigator
window.

2. On the Frame Display window, click the starred Quick Filtering icon g or select
"Quick Filtering" from the Filter menu.

This opens a dialog that lists all the protocols discovered so far. The protocols displayed
change depending on the data received.

The box on the left is Protocols To Filter In.

e When you select the checkbox for a protocol in the Protocols to Filter In, the
Summary Pane will only display those frames that contain data from that protocol.

If you filter on more than one protocol, the result are all frames that contain at least one of
those protocols. For example, if you filter on IP and IPX NetBIOS, you receive all frames that
contain either IP or IPX NetBIOS (or both). A Quick Filter tab then appears on the Frame
Display labeled Quick Filter. Changing the filter definition on the Quick Filter dialog changes
the filter applied on the Quick Filter tab. Quick filters are persistent during the session, but
are discarded when the session is closed.

The box in the center is the Protocols To Hide.

e When you select the checkbox for a protocol in the Protocols To Hide, data for that
protocol will not appear in the Decode, Binary, Radix, and Character Panes. The
frames containing that type data will still appear in the Summary Pane, but not in
the Decode, Binary, Radix, and Character Panes.

The box on the right is the Named Filters. It contains filters that you create using the
Named Filter and Set Condition dialogs.

e When you select the checkbox for the Name Filters, a tab appears on the Summary
Pane that displays the frame containing the specific data identified in the filter. The
named Filter tab remains on the Frame Display Summary Pane unless you hide it
using the Hide/Show Display Filters dialog.

With FBLEA, the Configured BT Low energy devices and Exclude NULLSs and POLLs are
default named filters.
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3. Check the small box next to the name of each protocol you want to filter in, hide, or
Named Filter to display.

4. Then click OK.

13.3.4 Filtering on all Frames with Errors from the Frame Display
To filter on all frames with errors:

1. Open the Frame Display EIwindow.
2. Click the starred Quick Filter icon ? or select "Quick Filtering" from the Filter menu

3. Check the box for All Frames With Errors in the "Protocols to filter in" pane, and click OK.

4. The system creates a tab on the Frame Display labeled Quick Filter that displays the
results of the All Frames With Errors filter.

13.4Protocol Filtering from the Protocol Navigator

13.4.1 Filtering on a Protocol Layer

You can filter on one or more protocol layers. The filter is inclusive which means only
frames matching the filter you select are shown in the window. Frames that do not contain
the protocol do not appear. You can filter on one protocol or several.

On the left side of the Protocol Navigator window are three panes. The top pane is the
Frames Filtered In pane. In the pane is a list of all the protocols seen so far on the circuit.

1. Check the boxes next to the names of the protocols you want to filter in.

The data on the right side of the screen matches the filtering selected.

Three additional filters available are:

e All Frames With Bookmarks - filters in all frames with a bookmark associated with
them.

e All Frames With Errors - filters in all frames with errors.

e All Special Information Nodes - filters in all special information nodes .

13.4.2 Filtering on all Frames with Bookmarks
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To filter on all frames with bookmarks:

1. Open the Protocol Navigator window.
2. Check the All Frames With Bookmarks box in the top pane on the left side of the window.

3. Toremove the filter, un-check the box.

13.4.3 Filtering on all Frames with Errors from the Protocol Navigator

To filter on all frames with errors :

1. Open the Protocol Navigator window.
2. Check the All Frames With Errors box in the top pane on the left side of the window.

3. Toremove the filter, un-check the box.

13.4.4 Filtering on all Frames with Special Information Nodes

To filter on all frames with special information nodes:

1. Open the Protocol Navigator window.

2. Check the All Special Information Nodes box in the top pane on the left side of the
window.

3. Toremove the filter, un-check the box.

13.4.5
Named Filters

You can create, modify, and delete filters using the Filter menu items on the Protocol
Navigator and Frame Display dialogs.

If you create a Named filter using the Filters dialog, the filter appears in the Named Frame
Filters pane in the bottom left corner of the Protocol Navigator window.

1. Check the boxes next to the names of the filters you want to use.

141



frontline

Debug Communications Faster!sv

Note that using a named filter affects the contents of the Frame Display window as well.
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14 Saving Data

14.1Saving Your Data

You can save all or part of a capture file. You can also load a previously saved capture file,
and save a portion of that file to another file. This feature is useful if someone else needs to
see only a portion of the data in your capture file.

On the Control toolbar you can set up to capture a single file or series of files. Click here to

see those settings.

There are two ways to save portions or all of the data collected during a data capture. Click
here to see how to capture data.

14.2Saving the Entire Capture File using File > Save or the Save
icon

This option is only available when you select Single File from the Capture Mode on System

Settings. Click here to learn more about selecting Save options from System Settings.

1. Ifyou are capturing data, click on the Stop icon to stop data capture. You cannot
save data to file while it is being captured.

2. Open the Event Display or Frame Display window.
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3. Click the Save icon, or select Save from the File menu.
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4. Type a filename in the File name box at the bottom of the screen.
5. Browse to select a specific directory. Otherwise your file is saved in the default capture
file directory.
6. When you are finished, click OK.

14.3Saving the Entire Capture File with Save Selection

1. Ifyouare capturing data, click on the Stop icon

save data to file while it is being captured.
2. Open the Event Display ~— or Frame Display | Iwindow.
3. Rightclickin the data
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Select Save Selection or Save As from the right click menu
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Click on the radio button labeled Entire File.

Choose to save Events or Frames. Choosing to save Events saves the entire contents of
the capture file. Choosing to save Frames does not save all events in the capture file.

Type a filename in the Save As box at the bottom of the screen. Click the Browse icon to
browse to a specific directory. Otherwise your file is saved in the default capture file
directory.

When you are finished, click OK.

14.4Saving a Portion of a Capture File

1.

If you are capturing data, click on the Stop icon to pause data capture. You cannot
save data to a file while it is being captured.

Open the Event Display & or Frame Display Window@, depending on whether you
want to specify a range in bytes or in frames.

Select the portion of the data that you want to save. Click and drag to select data, or click
on the first item, move to the last item and Shift+Click to select the entire range, or use
the Shift key with the keyboard arrows or the navigation icons in the Frame Display
toolbar. If the range you want to save is too large to select, note the numbers of the first
and last item in the range.

Right click in the data
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5. Select Save Selection or Save As from the right click menu
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6. Click on the radio button labeled Selection. If you selected a range, make sure the
starting and ending numbers are correct. To specify a range, type the numbers of the
first and last items in the range in the boxes.

7. Select either Events or Frames to indicate whether the numbers are event or frame
numbers.

8. Type a filename in the Save As box at the bottom of the screen. Click the Browse icon to
browse to a specific directory. Otherwise your file is saved in the default capture file
directory.

9. Click OK when you are finished.

14.5Confirm Capture File (CFA) Changes

This dialog appears when you close a capture file after changing the Notes, the protocol
stack, or bookmarks. The dialog lists information that was added or changed and allows you
to select which information to save, and whether to save it to the current file or to a new

one.

Changes made to the file appear in a list in the left pane. You can click on each item to see
details in the right pane about what was changed for each item. You simply check the boxes
next to the changes you want to keep. Once you decide what changes to keep, select one of
the following:
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Save To This File - Saves the changes you have made to the current capture file.
Save As - Saves the changes to a new file.

Cancel the Close Operation - Closes the file and returns you back to the display. No
changes are saved.

Discard Changes - Closes the file without saving any of the changes made to the
notes, bookmarks, or protocol stack.
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14.6 Adding Comments to a Capture File

The Notes feature allows you to add comments to a CFA file. These comments can be used
for many purposes. For example, you can list the setup used to create the capture file,
record why the file is useful to keep, or include notes to another person detailing which
frames to look at and why. (Bookmarks are another useful way to record information about
individual frames.)

To open the Notes window :

1. Click the Show Notes icon U . This icon is present on the toolbars of the Frame Display

@, the Protocol Navigator , as well as the Event Display ¢ . Notes can be
selected from the Edit menu on one of these windows.

2. Type your comments in the large edit box on the Notes window. The Cut, Copy, Paste,
Undo and Redo features are all supported.

3. Click the thumbtack icon B to keep the Notes window on top of any other windows.
4. When you're done adding comments, close the window.

5. When you close the capture file, you are asked to confirm the changes to the capture file.
See Confirming Capture File (CFA) Changes for more information.
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15 Loading and Importing Capture Files

15.1Loading a Capture File

From the Control Window:
1. Go to the File menu.
2. Choose a file from the recently used file list.

3. [Ifthe file is not in the File menu list, select Open Capture File from the File menu or

simply click on the Open icon 6 on the Toolbar.
4. Capture files have a .cfa extension. Browse if necessary to find your capture file.

5. Click on your file, and then click Open.

15.2Importing Capture Files

1. From the Control Window ﬁ, go to the File menu and select Open Capture File or click
on the Open icon on the Toolbar.

2. Change the Files of Type box to All Importable File Types or All Supported File Types.
Select the file and click Open.

The analyzer automatically converts the file to the analyzer's format while keeping the
original file in its original format. You can save the file in the analyzer's format, close the file
without saving it in the analyzer's format, or have the analyzer automatically save the file in
the analyzer's format (see the System Settings to set this option). All of these options keep
your original file untouched.

When you first open the file, the analyzer brings up the Protocol Stack window and ask you
what protocol decodes, if any, you want to use. You must choose a protocol decode at this
point for the analyzer to decode the data in the file. If you open a file without using any
decodes, and decide later that you want to apply a decode, choose Reframe from the File
menu on the Control window.

At present, the analyzer supports the following file types:

e Frontline Serialtest* Async and Serialtest ComProbe® for DOS - requires the
.byt for data and the .tim for timestamps (see note on importing DOS timestamps).

¢ Greenleaf ViewComm* 3.0 for DOS - requires the .byt for data and the .tim for
timestamps (see note on importing DOS timestamps).

e Frontline Ethertest* for DOS - requires 3 files: filename.cap, filename.ca0 and
filename.cal.
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o Sniffer Type 1 - supports files with the .enc extension. Does not support Sniffer
files with a .cap extension.

e Snoop or Sun Snoop - files with a .cap extension based on RFC 1761. For file
format, see http://www.fags.org/rfcs/rfc1761.html.

e Shomiti Surveyor files in Snoop format - files with a .cap extension. For file
format, contact Technical Support.

e CATC Merlin - files with a .csv extension. Files must be exported with a specific
format. See File Format for Merlin Files for information.

e CATC Chief - files with a .txt extension.

15.3Converting Timestamps

Serialtest for DOS uses a timebase of Pacific Standard Time during non daylight savings time
hours and Pacific Daylight Time during daylight savings time hours. The analyzer always
uses Greenwich Mean Time (also known as Universal Time Coordinates).

When importing a Serialtest for DOS file, the analyzer must determine if the file was
recorded during daylight savings time or not before converting the timestamps. Because the
rules for determining this can change, it is possible for the analyzer to convert the
timestamps incorrectly, resulting in timestamps that are off by one hour.

15.4 Adding Comments to a Capture File

The Notes feature allows you to add comments to a CFA file. These comments can be used
for many purposes. For example, you can list the setup used to create the capture file,
record why the file is useful to keep, or include notes to another person detailing which
frames to look at and why. (Bookmarks are another useful way to record information about
individual frames.)

To open the Notes window :

i
1. Click the Show Notes icon LH . This icon is present on the toolbars of the Frame Display

EI, the Protocol Navigator , as well as the Event Display & Notes can be
selected from the Edit menu on one of these windows.

2. Type your comments in the large edit box on the Notes window. The Cut, Copy, Paste,
Undo and Redo features are all supported.

_.k_j

3. Click the thumbtack icon to keep the Notes window on top of any other windows.

4. When you're done adding comments, close the window.
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5. When you close the capture file, you are asked to confirm the changes to the capture file.

See Confirming Capture File (CFA) Changes for more information.

15.5File Format for Merlin Files

FTS imports Merlin’s export files that have been exported with Merlin’s default settings.
These files should have an extension of ".csv".

It is possible with the Merlin software to hide or change a field’s format. If you do this
before exporting the Merlin file then FTS may have trouble importing the file.

If you are experiencing problems importing Merlin files, then check to make sure that no
fields were hidden and that the default field formats were being used, when the file was
exported from Merlin.
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16 Printing

16.1Printing from the Frame Display/HTML Export

The Frame Display Print dialog and the Frame Display HTML Export are very similar. This
topic discusses both dialogs.

The Frame Display Print dialog is directly below. The Frame Display HTML Export is
located midway in this discussion.

About Frame Display Print

The Frame Display Print feature provides the user with the option to print the entire
capture buffer or the current selection. When Print Preview is selected, the output displays
in a browser print preview window, where the user can select from the standard print
options. The output file format is in html, and uses the Microsoft Web Browser Control print
options for background colors and images (see below).
Print Background Colors Using Internet Explorer

1. Open the Tools menu on the browser menu bar
Select “Internet Options...” menu entry.

Click Advanced tab.

Check “Print background colors and images” under the Printing section

v N

Click the Apply button, then click OK

Configure the Print File Range in the Frame Display Print Dialog

Selecting more than one frame in the Frame Display window defaults the radio button in the
Frame Display Print dialog to Selection and allows the user to choose the All radio button.
When only one frame is selected, the All radio button in the Frame Display Print dialog is
selected.

How to Print Frame Display Data

1. Select Print or Print Preview from the File menu on the Frame Display window to display
the Frame Display Print dialog. Select Print if you just want to print your data to your
default printer. Select Print Preview if you want access to printer options.

2. Choose to include the Summary Pane (check the box) in the print output. The summary
Pane appears at the beginning of the printed output in tabular format. If you select All
layers in the Detail Section, the Data Bytes option becomes available.

3. Inthe Detail Section, choose to exclude the decode from the Detail Pane in the Frame
Display, or include All Layers or Selected Layers Only. If you choose to include selected
layers, then select (click on and highlight) the layers from the list box. Click on selected
layers in the list to de-select, or click the Reset button to de-select all selected layers.
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CAUTION: Decode layers printout expanded regardless of the state of the Detail
Pane in the Frame Display at the time of the request to print. This can produce a
print output consisting of hundreds of pages or more. We recommend that you
use Print Preview to determine the number of pages in your print output prior to

printing.
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Select the range of frames to include All or Selection in the Frame Range section of the
Frame Display Print dialog.

Choosing All prints all of the frames in the capture file or buffer. If more than 1000 frames
in the Frame Range, All will be disabled. You can still select more than 1000 frames using
the Selection option, but when printing more than 1000 frames, there is the possibility that
Print will not work properly.

Choosing Selection prints only the frames you select in the Frame Display window.

Note: Selecting the Delete File deletes the temporary html file that was used
during printing..

4. Click the OK button.

If you chose Print Preview, the system displays your data in a browser print preview display
with options for printing such as page orientation and paper size. You can also use your
Printer Preferences dialog to make some of these selections. When printing your data, the
analyzer creates an html file and prints the path to the file at the bottom of the page. This
file can be opened in your browser, however, it may appear different than the printed
version.
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16.2Frame Display HTML Export

The Frame Display HTML Export feature provides the user with the option to export the
entire capture buffer to an .html file.

How to export display data to an .html file

1. Select HTML Export from the File menu on the Frame Display window to display the
Frame Display HTML Export.
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2. Choose to include the Summary Pane (check the box) in the .html output. If you select
All layers in the Detail Section, the Data Bytes option becomes available.

3. Inthe Detail Section, choose to exclude the decode from the Detail Pane in the Frame
Display, or include All Layers or Selected Layers Only. If you choose to include selected
layers, then select (click on and highlight) the layers from the list box. Click on selected
layers in the list to de-select, or click the Reset button to de-select all selected layers.

4. Select the range of frames to include All or Selection in the Frame Range section of the
dialog.

Choosing Selection includes only the frames you select in the Frame Display window.

Note: If the file size is too big, the Frame Range, All, will not be available. It will be grayed
out.

5. Click the OK button.

The Save As dialog appears.
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6. Enter a name for the file you want to save.
Note: There is no need to choose a file type. The file is saved as a .htm.
7. Select Save

The file is saved as a .htm file in the file location you chose.

16.3Printing from the Event Display

About Event Display Print

The Event Display Print feature provides the user with the option to print either the entire
capture buffer or the current selection. When Print Preview is selected, the output displays
in a browser print preview window where the user can select from the standard print
options. The output file format is in html, and uses the Microsoft Web Browser Control print
options for background colors and images (see below).
Print Background Colors Using Internet Explorer

1. Open the Tools menu on the browser menu bar
Select “Internet Options...” menu entry.

Click Advanced tab.

Check “Print background colors and images” under the Printing section

ik W

Click the Apply button, then click OK

The Event Display Print feature uses the current format of the Event Display as specified by
the user.
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Note: See About Event Display for an explanation on formatting the Event Display prior to
initiating the print feature.

Configure the Print File Range in the Event Display Print Dialog

Selecting more than one event in the Event Display window defaults the radio button in the
Event Display Print dialog to Selection and allows the user to choose the All radio button.
When only one event is selected (can’t have None selected), the All radio button in the Event
Display Print dialog is selected.

How to Print Event Display Data to a Browser

1. Select Print or Print Preview from the File menu on the Event Display window to display
the Event Display Print dialog. Select Print if you just want to print your data to your
default printer. Select Print Preview if you want access to printer options.

2. Select the range of events to include from either All or Selection in the Event Range
section of the Event Display Print dialog. Choosing All prints all of the events in the
capture file or buffer. Choosing Selection prints only the selected events in the Event
Display window.

Note: In order to prevent a Print crash, you cannot select All if there are
more than 100,000 events in the capture buffer.

Note: See Configure the Print File Range in the Event Display Print Dialog above for an
explanation of these selections
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3. Click the OK button.

If you chose Print Preview, the system displays your data in a browser print preview display
with options for printing such as page orientation and paper size. You can also use your
Printer Preferences dialog to make some of these selections. When printing your data, the
analyzer creates an html file and prints the path to the file at the bottom of the page. This
file can be opened in your browser, however, it may appear different than the printed
version.
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16.4Print Preview

Print Preview gives a preview of how the data looks printed. You can scroll through the
pages and zoom in on the data to get a closer look. The line of buttons across the top of the
window controls the functions of the window.

To open the Print Preview window:
1. Choose Print Preview from the File menu in any window that supports printing.

2. Choose to include the Summary Pane (check the box) in the print output. The summary
Pane appears at the beginning of the printed output in tabular format. If you select All
layers in the Detail Section, the Data Bytes option becomes available.

3. Inthe Detail Section, choose to exclude the decode from the Detail Pane in the Frame
Display, or include All Layers or Selected Layers Only. If you choose to include selected
layers, then select (click on and highlight) the layers from the list box. Click on selected
layers in the list to de-select, or click the Reset button to de-select all selected layers.

CAUTION: Decode layers printout expanded regardless of the state of the Detail Pane in the
Frame Display at the time of the request to print. This can produce a print output consisting
of hundreds of pages or more. We recommend that you use Print Preview to determine the
number of pages in your print output prior to printing.
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4. Select the range of frames to include All or Selection in the Frame Range section of the
Frame Display Print dialog.

Choosing All prints all of the frames in the capture file or buffer. If there are more than

1000 frames in the capture file or buffer, All will not be available.

Choosing Selection prints only the selected frames in the Frame Display window.

Note: See Configure the Print File Range in the Frame Display Print Dialog above for an
explanation of these selections.
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Note: Selecting the Delete File deletes the temporary html file that was used
during printing..

5. Click the OK button.

You can print directly from the Print Preview window.

Next Page shows you how the next page in your data looks
Prev Page takes you back to the previous page.

Two Page changes the display to show two pages of data. When in the Two Page
display, the button reads One Page. Click on the One Page button to return to
viewing one page.

Zoom In and Zoom Out allow you to change the magnification of the pages. Click on
Zoom In to increase the magnification, and on Zoom Out to decrease the
magnification. When you have reached the limit in either direction, the buttons is
grayed out.

You can also zoom in and out by clicking on the page itself. When the cursor looks
like a magnifying glass, you can click on the page to increase the magnification.
When you have reached the top level of magnification, the cursor changes back to an
arrow. Click on the page to return to normal magnification.

Click on the Close button to return to the regular display.
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17 Exporting

17.1Export

You can dump the contents of the Summary pane on the Frame Display into a Comma
Separated File (CSV).

To access this feature:

1. Right click on the Summary Pane
2. Select the Export menu item

3. Enter a file name
4

Select Save

Another option to access quick export is :
1. Click on the File menu
2. Choose Export
3. Enter a file name
4

Select Save

Exporting Event Display to a File
Export Filter Out

Exporting Baudot

17.2Export Filter Out

You can filter out data you don't want or need in your text file.

(This option is available only for serial data.) In the Filter Out box, choose which side to
filter out: the DTE data, the DCE data or neither side (don't filter any data.) For example, if
you choose the radio button for DTE data, the DTE data would be filtered out of your export
file and the file would contain only the DCE data.

You can also filter out Special Events (which is everything that is not a data byte, such as
control signal changes and Set I/0 events), Non-printable characters or both. If you choose
to filter out Special Events, your export file would contain only the data bytes. Filtering out
the non-printable characters means that your export file would contain only special events
and data bytes classified as printable. In ASCII, printable characters are those with hex
values between $20 and $7e.
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17.3Exporting Event Display to a File

About Event Display Export

The Event Display Export feature provides the following options:
e Export either the entire capture buffer or the current selection
e Qutput file format as text, CSV, html, or bin.

The Event Display Export feature uses the current format of the Event Display as specified
by the user.

Note: See About Event Display for an explanation on formatting the Event Display prior to
initiating the export feature.

Accessing the Event Display Export Dialog

Selecting Export Events... from the File menu in the Event Display brings up the following
dialog:

5
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Configure the Export File Range in the Event Display Export Dialog

e Selecting more than one event in the Event Display window defaults the radio
button in the Event Display Export dialog to Selection and allows the user to choose
the All radio button.

e When only one event is selected (something must be selected), the All radio button
in the Event Display Export dialog is selected by default.

e Sideis used to determine whether you want to export data from a DCE/DTE,
Slave/Master, Host/Function device or both.
How to Export Event Display Data to a File

1. Select Export Events... from the File menu on the Event Display window to display the
Event Display Export dialog.
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Enter a file path and name, or click the browser button to display the Windows Save As
dialog and navigate to the desired storage location.

Select a file type from the Save as type: drop-down List Menu on the Event Display
Export dialog.

Select from among the following file formats:

Text File (*.txt)
CSV File (*.csv)

HTML File (*.html)

Binary File (*.bin)

Select the range of events to include in the file from either All or Selection in the Event
Range section of the Event Display Export dialog.

Note: See Configure the Export File Range in the Event Display Export Dialog above for
an explanation of these selections.

Select a Side, either Host, Function, or Both

Click Save.

17.4Exporting Baudot

When exporting Baudot, you need to be able to determine the state of the shift character. In
a text export, the state of the shift bit can be determined by the data in the Character field.
When letters is active, the character field shows letters and vice versa.

17.5HTML Export

The Frame Display HTML Export feature provides the user with the option to export the
entire capture buffer to an .html file.

How to export display data to an .html file

Select HTML Export from the File menu on the Frame Display window to display the
Frame Display HTML Export.
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2. Choose to include the Summary Pane (check the box) in the .html output. If you select
All layers in the Detail Section, the Data Bytes option becomes available.

3. In the Detail Section, choose to exclude the decode from the Detail Pane in the Frame
Display, or include All Layers or Selected Layers Only. If you choose to include selected
layers, then select (click on and highlight) the layers from the list box. Click on selected
layers in the list to de-select, or click the Reset button to de-select all selected layers.

4. Select the range of frames to include All or Selection in the Frame Range section of the

dialog.

Choosing Selection includes only the frames you select in the Frame Display window.

Note: If the file size is too big, the Frame Range, All, will not be available. It will be grayed

out.

5. Click the OK button.

The Save As dialog appears.
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6. Enter a name for the file you want to save.

Note: There is not need to choose a file type. The file is saved as a .htm.

7. Select Save
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18 System Settings and Program Options

18.1System Settings

Open the System Settings window by choosing System Settings from the Options menu on
the Control window. To enable a setting, click in the box next to the setting to place a
checkmark in the box. To disable a setting, click in the box to remove the checkmark. When
viewing a capture file, settings related to data capture are grayed out.

System Settings E
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Capture Mode
e Series of files

This option lets you capture to a series of files. The size of each file is no larger than
the number given in File Size (in K),which has a maximum limit of approximately
176,000KB (1.7 GB) or 1/2 of the available hard disk space, whichever is smaller.
The name of each file is the name you give it in the Name box followed by the date,
time and a number. The date and time are when the series was opened. The number
increments with each file. This guarantees unique file names are created.

Set the maximum number of files in the series in the Maximum number of files box.
The next file starts when the currently open file is full. If you want to start a new file
on a periodic basis, check the box for Start new file after and put in the number of
hours after which a new file is started. Note that if the currently open file becomes
full before the time limit has been reached, a new file is opened immediately rather
than lose data.

Capturing stops if the maximum number of files has been used unless Wrap Files has
been checked. If Wrap Files has been checked the analyzer erases the oldest file in
the series and make a new file.

e Single File
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This option allows the analyzer to capture data to a file without prompting you for a
file name each time. The size of each file is not larger than the number given in File
Size (in K). The name of each file is the name you give it in the Name box followed by
the date and time. The date and time are when the series was opened.

Common Options

168

Restart Capturing After Saving or Clearing Capture File

If the Automatically Restart feature is enabled, the analyzer restarts capture to the
file immediately after the file is closed.

Wrap File
When enabled, the analyzer wraps the file when it becomes full. The oldest events are
moved out of the file to make room for new events. Any events moved out of the file

are lost. When disabled, the analyzer stops capture when the file becomes full. Either
reset the file or close your capture file to continue.

File Size (in K)

Enter the maximum size of the capture file, which is 176,000 KB, or 1/2 of the
available hard drive space, whichever is smaller. If you enter a number larger than
the maximum allowable size, the analyzer will display the allowable size.

Default
Enter a name for the capture file in the Default text box. Each saved file will begin
with this name.

Append Series Start/Date & File Number
Select this radio button to automatically append a start date (yyyy-mm-dd_hhmmss)
and file number (001) when capturing a series of files.

Append File Start Date/Time
Select this radio button to automatically append a start date (yyyy-mm-dd_hhmmss)
when capturing a single file.

Start up

Opens the Program Start up Options window. Start up options let you choose
whether to start data capture immediately on opening the analyzer.

Advanced

Opens the Advanced System Options window. The Advanced Settings should only be
changed on advice of technical support.
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18.2System Settings - Disabled/Enabled Options

Some of the System Settings options are disabled depending upon the status of the data
capture session.

e Asthe default, all the options on the System Settings dialog are enabled.

¢ Once the user begins to capture data by selecting the Start Capture button, some of
the options on the System Settings dialog are disabled until the user stops data
capture and either saves or erases the captured data.

e The user can go into the Startup Options and Advanced System Options on the
System Settings dialog and make changes to the settings at any time.

18.3Bluetooth ComProbe Maintenance

The Bluetooth® ComProbe® Maintenance Utility is used to configure Bluetooth ComProbes
and to upgrade the firmware. Bluetooth ComProbes should be upgraded to the newest
firmware release to take advantage of new features and fixes.

Upgrading Your Bluetooth ComProbe

To start the Bluetooth ComProbe Maintenance Utility:

1. Open the FTS4BT desktop folder > Setup folder.

2. Double click the shortcut to the utility.
OR

1. From your Windows operating system click Start > Programs > FTS4BT [version#] >
Setup > Bluetooth ComProbe Maintenance Utility.

The main dialog appears.

2. Connect the ComProbe to the PC

3. Click on the Select Device button.
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To avoid mistakes, we recommended that only one ComProbe be connected at a time.
Also, it is very important that you do not remove any connections to the ComProbe
while the firmware update is in progress!

4. Select Yes.

Older ComProbes will display an error indicating the ComProbe is older and needs
replacing. Note that when you do this, the [Device Information], [Check Configuration] and
[Update Firmware] buttons should become available. [Update Firmware] will not be
accessible if you are using an older ComProbe®.

5. Select the Update Firmware button.

The utility will display a dialog titled “Select the firmware file to download”. There may be
more than one firmware file with extension “.dfu” in the directory. The version number of
the firmware will be in the name of the file.

6. Please select the version you want (typically you should choose the highest version
number).

7. Then press the Open button.

When the update is complete, a dialog appears confirming the download.

8. Press the OK button.

18.4Advanced System Options

These parameters affect fundamental aspects of the software, and it is unlikely that you
ever have to change them. If you do change them and need to return them to their original
values, the default value is listed in parentheses to the right of the value box.

Most technical support problems are not related to these parameters, and as changing them
could have serious consequences for the performance of the analyzer, we strongly
recommend contacting technical support before changing any of these parameters.

To access the Advanced System Options:

1. Go to the Control @ window.
2. Choose System Settings from the Options menu.

3. On the System Settings window, click the Advanced button.

¢ Driver Receive Buffer Size in Kbytes

This is the size of the buffer used by the driver to store incoming data. This value is
expressed in Kbytes.

e Driver Action Queue Size In Operating System Pages
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This is the size of the buffer used by the driver to store data to be transmitted. This
value is expressed in operating system pages.

Frame Completion Timeout in Seconds

This is the number of seconds that the analyzer waits to receive data on a side while
in the midst of receiving a frame on that side.

If no data comes in on that side for longer than the specified number of seconds, an
"aborted frame" event is added to the Event Display and the analyzer resumes
decoding incoming data. This can occur when capturing interwoven data (DTE and
DCE) and one side stops transmitting in the middle of a frame.

Aborted frames (just like broken frames and regular frames) are decoded and
displayed in the Frame Display. If you experience aborted frames and suspect that
your framed data may have pauses in it that exceed the specified timeout time, then
you may want to increase that value.

The range for this value is from 0 to 999,999 seconds. Setting it to zero disables the
timeout feature.

Note: This option is disabled when capturing data over Ethernet networks.

18.5 Changing Default File Locations

The analyzer saves user files in specific locations by default. Capture files are placed in the
My Capture Files directory and configurations are put in My Configurations. These locations
are set at installation.

Follow the steps below to change the default locations.

@

1. Choose Directories from the Options menu on the Control
Locations window.

window to open the File

2. Select the default location you wish to change.
3. Click Modify.

4. Browse to a new location.

5. Click OK.

6. Click OK when finished.

Note: If a user sets the My Decoders directory such that it is up-directory from an
installation path, multiple instances of a personality entry may be detected, which causes a
failure when trying to launch FTS. For example, if an FTS product is installed at C:\FTS
Stuff\My Products\Frontline FTS4BT w.x.y.z, then "My Decoders" cannot be set to any of
the following:

C:\
C:\FTS Stuff
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e C:\FTS Stuff\My Products

e C:\FTS Stuff\My Products\Frontline FTS4BT w.x.y.z

e  C:\FTS Stuff\My Products\Frontline FTS4BT w.x.y.zZ\App Data

e C:\FTS Stuff\My Products\Frontline FTS4BT w.x.y.zZ\App Data\Decoders

e ortoany directory that already exists under C:\FTS Stuff\My Products\Frontline
FTS4BT w.x.y.zZ\App Data\Decoders

Default Capture File Folder Checkbox

If the “Use Last Opened Folder for Capture Files” checkbox is checked, then the system
automatically changes the default location for saving capture files each time you open a file
from or save a file to a new location. For example, let's say the default location for saving
capture files is Drive A > Folder A. Now you select the “Use Last Opened Folder for
Capture Files” checkbox. The next time, however, you open a capture file from a different
location, Folder B > Removable Flash Drive. Now when you save the capture file, it will
be saved to Folder B > Removable Flash Drive. Also, all subsequent files will be saved to
that location. This remains true until you open a file from or save a file to a different
location.

There is one caveat to this scenario, however. Let's say you have selected "Use Last Opened
Folder for Capture Files" and opened a file from a location other than the default directory.
All subsequent capture files will be saved to that location. Suppose, however, the next time
you want to save a capture file, the new file location is not available because the directory
structure has changed: a folder has been moved, a drive has been reassigned, a flash drive
has been disconnected, etc. In the case of a "lost" directory structure, subsequent capture
files will be saved to the default location. FTS will always try to save a file to the folder
where the last file was opened from or saved to, if “Use Last Opened Folder for Capture
Files” is checked. If, however, the location is not accessible, files are saved to the default
directory that is set at installation.

If the checkbox is unchecked, then the system always defaults to the directory listed in the
File Locations dialog.

18.6Selecting Start Up Options

1. To open this window:

2. Choose System Settings from the Options menu on the Control @ window.
3. On the System Settings window, click the Start Up button.

4. Choose one of the options to determine if the analyzer starts data capture immediately
on starting up or not.
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Don't start capturing immediately.

This is the default setting. The analyzer begins monitoring data but does not begin

capturing data until the Start Capture 9 icon on the Control, Event Display or Frame
Display windows is clicked.

Start capturing to a file immediately.

When the analyzer starts up, it immediately opens a capture file and begin data capture to

it. This is the equivalent of clicking the Start Capture @ icon. The file is given a name based
on the settings for capturing to a file or series of files in the System Settings window.
Start capturing immediately to the following file:

Enter a filename in the box below this option. When the analyzer starts up, it immediately
begins data capture to that file. If the file already exists, the data in it is overwritten.

Use this capture filter:

The drop down box lists all named filters. Select one that you want to use immediately on
start up.

18.7Names

The Names dialog is used to change the names of objects and events that appear in various
displays.

1. To open the Names dialog, choose Names from the Options menu on the Control
window. Changes to the Names are used throughout the program.

To change a name, click on the name given in the current column, and then click again to
modify the name (a slow double-click). To restore the default values, click the Defaults
button. The names used in the system fall into one of three general categories.

Because of variations associated with different types of communications, the Names dialog
may display all or only a subset of the following categories:

e Sides

The Sides section allows you to give each side on a network more descriptive names.
This is useful on network with more than one side.

e Errors

This section allows you to change the error names. The errors listed are appropriate
for the type of circuit/network you are monitoring.

e Signals

Signals refers to the six control signals used in RS-232 data communications, and
may not apply to the type of communications you are monitoring.

FTS4USB has four Control Signals: Pin 1, Pin 2, Pin 3, and Pin 4.
Default Labels and their Meaning
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Label Control Signal

RTS Request to Send

CTS Clear to Send

DSR Data Set Ready

DTR Data Terminal Ready
CD Carrier Detect

RI Ring Indicator

If you are used to different abbreviations for the same signals, you can change them
in this section. For example, if you normally refer to Carrier Detect as DCD, highlight
CD and type in DCD.

18.8Timestamping

18.8.1 Timestamping Options
The Timestamping Options window allows you to enable or disable timestamping, and
change the resolution of the timestamps for both capture and display purposes.
To open this window:
1. Choose System Settings from the Options menu on the Control window.

2. Click the Set Timestamp Format button.

OR

1. Click the Timestamping Options icon from either the Event Display or Statistics
window.

OR

1. Click the Timestamping Options icon from the Event Display window.

18.8.2 Enabling/Disabling Timestamping
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Choose System Settings from the Options menu on the Control window, and click the
Timestamping Options button, or click the click the Timestamping Options icon

from either the Event Display ¢ or Statistics H] window.

Check the Store Timestamps box to enable timestamping. Remove the check to disable
timestamping. If you disable timestamping, you are not able to do delta or rate
calculations.

18.8.3 Switching Between Relative and Absolute Time

With Timestamping you can choose to employ Relative Time or Absolute time.

1.

Choose System Settings from the Options menu on the Control window, and click the

e

Timestamping Options button, or click the click the Timestamping Options icon '

from either the Event Display ¢ or Statistics H] window.

Go to the Display Options section at the bottom of the window and find the Display
Relative Timestamps checkbox.

Check the box to switch the display to relative timestamps. Remove the check to return
to absolute timestamps.

Note: The options in this section affect only how the timestamps are displayed on the screen,
not how the timestamps are recorded in the capture file.

Display Raw Timestamp Value shows the timestamp as the total time in hundred
nanoseconds from a specific point in time.

Display Relative Timestamps shows the timestamp as the amount of time that has
passed since the first byte was captured. It works just like a stop watch in that
the timestamp for the first byte is 0:00:00.0000 and all subsequent timestamps
increment from there. The timestamp is recorded as the actual time, so you can flip
back and forth between relative and actual time as needed.

Selecting both values displays the total time in nanoseconds from the start of the
capture as opposed to a specific point in time.

Selecting neither value displays the actual chronological time.

When you select Relative Timestamp, you can set the number of digits to display using the
up or down arrows on the numeric list.
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18.8.4 Changing the Timestamping Resolution

This option affects the resolution of the timestamp stored in the capture file. The default
timestamp is 10 milliseconds. This value is determined by the operating system and is the
smallest "normal" resolutions possible.

It is also possible to use "high resolution” timestamping. High resolution timestamp values
are marked by an asterisk as high resolution in the drop down list. To change timestamping
resolutions:

1. Choose System Settings from the Options menu on the Control @ window, and click

the Timestamping Options button, or click the click the Timestamping Options icon

from either the Event Display ¢ or Statistics H] window.

2. Go to the Capture Options section of the window.

3. Change the resolution listed in the Storage Resolution box. Note that if you change the
resolution, you need to exit the analyzer and restart in order for the change to take
effect.

18.8.5 Displaying Fractions of a Second

1. Choose System Settings from the Options menu on the Control @ window, and click

the Timestamping Options button, or click the click the Timestamping Options icon

from either the Event Display ¢ or Statistics H] window.

2. Go to the Display Options section at the bottom of the window, and find the Number of
Digits to Display box.

3. Click on the arrows to change the number. You can display between 0 and 6 digits to the
right of the decimal point.

The options in this section affect only how the timestamps are displayed on the screen, not
the resolution used to capture the data.

18.8.6 Converting Timestamps
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Serialtest for DOS uses a timebase of Pacific Standard Time during non daylight savings time
hours and Pacific Daylight Time during daylight savings time hours. The analyzer always
uses Greenwich Mean Time (also known as Universal Time Coordinates).

When importing a Serialtest for DOS file, the analyzer must determine if the file was
recorded during daylight savings time or not before converting the timestamps. Because the
rules for determining this can change, it is possible for the analyzer to convert the
timestamps incorrectly, resulting in timestamps that are off by one hour.

18.8.7 Performance Issues For High Resolution Timestamps

There are two things to be aware of when using high resolution timestamps. The first is that
high resolution timestamps take up more space in the capture file because more bits are
required to store the timestamp. Also, more timestamps need to be stored than at normal
resolutions. The second issue is that using high resolution timestamping may affect
performance on slower machines

For example, if 10 bytes of data are captured in 10 milliseconds at a rate of 1 byte per
millisecond, and the timestamp resolution is 10 milliseconds, then only one timestamp
needs to be stored for the 10 bytes of data. If the resolution is 1 millisecond, then 10
timestamps need to be stored, one for each byte of data. If you have two capture files, both
of the same size, but one was captured using normal resolution timestamping and the other
using high resolution, the normal resolution file has more data events in it, because less
room is used to store timestamps.

You can increase the size of your capture file in the System Settings.
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19 Technical Information

19.1Contacting Technical Support

Technical support is available in several ways. The online help system provides answers to
many user related questions. Frontline's website has documentation on common problems,
as well as software upgrades and utilities to use with our products.

On the Web: http://www.fte.com/support/default.as

Email: tech support@fte.com

If you need to talk to a technical support representative, support is available between 9am
and 5pm, U.S. Eastern time, Monday through Friday. Technical support is not available on
U.S. national holidays.

Phone: +1 (434) 984-4500
Fax: +1 (434)984-4505

19.2Technical Information

The following information is provided to assist you with troubleshooting problems with this
analyzer.

Performance Notes
Ethernet Performance Notes

Synchronous Serial Performance Notes
Asynchronous Serial Performance Notes

Ring Indicator
The FTS Serial Driver

Contacting Technical Support
Contacting Technical Support

Miscellaneous Helpful Information
ASCII Codes

EBCDIC Codes

Baudot Codes

Communication Control Characters
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19.3Performance Notes

As a software-based product, the speed of your computer’s processor affects the analyzer’s

performance. Buffer overflow errors are an indicator that the analyzer is unable to keep up

with the data. The information below describes what happens to the data as it arrives, what
the error means, and how various aspects of the analyzer affect performance. Also included
are suggestions on how to improve performance.

The analyzer's driver takes data from the driver and counts each byte as they are put into
the driver’s buffer. The analyzer's driver tells the user interface that data is ready to be
processed. The analyzer takes the data from the driver’s buffer and puts the data into the
capture buffer.

Driver Buffer Overflows occur when the user interface does not retrieve frames from the
driver quickly enough. Buffer overflows are indicated in the Event Display window by a plus
sign within a circle. Clicking on the buffer overflow symbol displays how many frames have
been lost.

There are several things that you can do to try and solve this problem.

e Use capture filters to filter out data you don't need to see. Capture filters reduce the
amount of data processed by the analyzer. (Ethernet Only)

e C(Close all other programs that are doing work while the analyzer is running. Refrain
from doing searches in the Event Display window or other processor intensive
activities while the analyzer is capturing data.

e Timestamping takes up processor time, primarily not in timestamping the data, but
in writing the timestamp to the file. Try turning off timestamping from the
Timestamping Options window.

e For Driver Buffer Overflows, change the size of the driver buffer. This value is
changed from the Advanced System Settings. Go to the Control Window and choose
System Settings from the Options menu. Click on the Advanced button. Find the
value Driver Receive Buffer Size in Operating System Pages. Take the number listed
there and double it.

e The analyzer’s number one priority is capturing data; updating windows is
secondary. However, updating windows still takes a certain amount of processor
time, and may cause the analyzer to lose data while the window is being updated.
Some windows require more processing time than others because the information
being displayed in them is constantly changing. Refrain from displaying data live in
the Event Display and Frame Display windows. The analyzer can capture data with
no windows other than the Control window open.

e Ifyou are still experiencing buffer overflows after trying all of the above options,
then you need to use a faster PC. Changing Where the Search Lands

When doing a search in the analyzer, the byte or bytes matching the search criteria are
highlighted in the Event Display. The first selected byte appears on the third line of the
display.

To change the line on which the first selected byte appears:
1. Open fts.ini (located in the C:\Program Files\Common Files\FTE)
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2. Go to the [CVEventDisplay] section
Change the value for SelectionOffset.

4. If you want the selection to land on the top line of the display, change the
SelectionOffset to 0 (zero).

19.4Progress Bars

The analyzer uses progress bars to indicate the progress of a number of different processes.
Some progress bars (such as the filtering progress bar) remain visible, while others are
hidden.

The title on the progress bar indicates the process underway.

19.5Event Numbering

This section talks about how events are numbered when they are first captured and how
this affects the display windows in the analyzer. The information in this section applies to
frame numbering as well.

When the analyzer captures an event, it gives the event a number. If the event is a data byte
event, it receives a byte number in addition to an event number. There are usually more
events than bytes, with the result is that a byte might be listed as Event 10 of 16 when
viewing all events, and Byte 8 of 11 when viewing only the data bytes.

The numbers assigned to events that are wrapped out of the buffer are not reassigned. In
other words, when event number 1 is wrapped out of the buffer, event number 2 is not
renumbered to event 1. This means that the first event in the buffer may be listed as event
11520 of 16334, because events 1-11519 have been wrapped out of the buffer. Since row
numbers refer to the event numbers, they work the same way. In the above example, the
first row would be listed as 2d00 (which is hex for 11520.)

The advantage of not renumbering events is that you can save a portion of a capture file,
send it to a colleague, and tell your colleague to look at a particular event. Since the events
are not renumbered, your colleague’s file use the same event numbers that your file does.

19.6File Format for Merlin Files

FTS imports Merlin’s export files that have been exported with Merlin’s default settings.
These files should have an extension of ".csv".

It is possible with the Merlin software to hide or change a field’s format. If you do this
before exporting the Merlin file then FTS may have trouble importing the file.

If you are experiencing problems importing Merlin files, then check to make sure that no
fields were hidden and that the default field formats were being used, when the file was
exported from Merlin.
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19.7Known Issues with the Source BD_ADDR Field

The data contained in the Source BD_ADDR field has the potential to be inaccurate.

A number of factors associated with wireless communication such as complex usage
scenarios, or dropped data packets due to poor RF reception contribute to incorrect
information periodically appearing in this field. Due to the nature of wireless
communication, it is not always possible for the analyzer, or any device, to determine the
BD_ADDR of the communicating devices on the network.

Users should keep in mind that the data contained in the Source BD_ADDR field should be
used as a guide and not an absolute.

19.8 Useful Character Tables

19.8.1 ASCII Codes

hex| #0 | %1 | 2 | x3 | xd | «5 | o6 | x7 | xB | «9 | xA [ xB | 2C | xD | xE | xF
Ox |NUL|SOH| STX| ETX [ECT|ENQIACKIBEL| BS | HT | LF | VT | FF I CR [ S0 | S

1x |DLE|DC1|DC2| DC3 | DC4 |NAK|SYN|ETB[CAN| EM |SUB|ESC| FS | GS | RS | US
I b #15 | %| & ' { ) G + . = . !

3| 0 1 213[(4]|]5)6|7 |89 - ¢ | =] = ?

4 |g@ | Al B)JCIDIEJF|G|H ] JIK]JTLIM| N[O

Sl prlalrlIs|TIUlVIWX]IYlZ]l 1]V ] »

Bx | ° E b [= d 8 flaglh i i k I m| n| o

x|l p iq r § t i ¥ | w | x ¥ z { | 1 ~ |DEL

19.8.2 Baudot Codes
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[DEC [ HEX | LETTERS | FIGURES |
0 | 00 |BLANK (UL BLANK MUL
1| @ E 3
7 | o2 LF LF
EE A :

4 | o4 sP sP
5 | 05 S BEL
6 | 06 [ B
7 | o7 U 7
8 | o8 (] CR
9 ] [1] §
10 | 0A R 4
11 | 0B J :
[FEN N .
13 | oD F I
14 | OE C :
15 | OF K {
16 10 T 5
17 | 11 I -
|| 12 L ]
19 | 13 [T 2
20 | 14 H #
21 | 15 ¥ B
2 | 18 P 0
=l KR Q 1
24 | 18 0 g
2= | 19 B H
% | 1A G L
27 | 18 | FIGURES | FIGURES
28 | 1C M

29 10 x /
o | 1E v .
31 | 1F | LETTERS | LETTERS

19.8.3 EBCDIC Codes

hex

=0

¥ | 22 | «3

x%d

X

xB

xC

x0

xE

xF

Ox

HUL

SOH| 5T

PF LC

DEL

Shihd

FF

CR

50

3

1%

DLE

DC1|DC2| ™

RES B3

IL

CAN

cC

cul

IFS

IG5

IRS

s

2x

0s

S0S| FS

==

BYE ETB|

[ESC

M

cu2

|EnG

ALK

BEL

3x

SYN|

PN | RS | UC

EQT

cu3

SUB

4x

3P

Sx

Bx

&

x

Bx

Sx

3 |=
]

A

=
=
i'l:l-'.

Pl

=]

Bx

Cx

Dx

T S

Ex

Fx

[=] ] S

L L) et o)
|||

i | |0
(<[ Z)m
m|E O™

= | 2| O

L=l e ] e o

|| 70| —
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Listed below in alphabetical order are the expanded text meanings for common ANSI
communication control characters, and two-character system abbreviation for each one.

183



frontline

Debug Communications Faster!sv

Some abbreviations have forward slash characters between the two letters. This is to
differentiate the abbreviations for a control character from a hex number. For example, the
abbreviation for Form Feed is listed as F/F, to differentiate it from the hex number FF.

Abbreviation Control Text
Character

AK ACK Acknowledge

BL BEL Bell

BS BS Backspace

CN CAN Cancel

CR CR Carriage
Return

D/1-4 DC1-4 Device
Control 1-4

D/E DEL Delete

DL DLE Data Link
Escape

EM EM End of
Medium

EQ ENQ Enquiry

ET EOT End of
Transmission

E/C ESC Escape

E/B ETB End of
Transmission
Block

EX ETX End of Text

F/F FF Form Feed

FS FS File
Separator

GS GS Group
Separator
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HT HT Horizontal
Tabulation

LF LF Line Feed

NK NAK Negative
Acknowledge

NU NUL Null

RS RS Record
Separator

SI SI Shift In

SO SO Shift Out

SH SOH Start of
Heading

SX STX Start of Text

SB SUB Substitute

SY SYN Synchronous
Idle

usS usS Unit
Separator

VT VT Vertical
Tabulation

19.9The Serial Driver
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19.9.1 The FTS Serial Driver

FTS uses custom versions of the standard Windows serial drivers in order to capture data.
These drivers are usually installed during the routine product installation. However, if you
need to install the serial driver after FTS has already been installed, please refer to the

instructions available in the Setup folder installed under Start | Programs | [Product Name

and version #] | Setup | How to Install the FTS Serial Driver.

19.10

Frame Decoder
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Frame Decoder is for the development of add-on components to extend the functionality of
your FTS protocol analyzer. Those add-on components are generally used to decode
existing or custom protocols. The core of each such “decoder” is a program that defines how
the protocol data are to be broken up into fields and displayed in the Frame Display window
of the analyzer software. The DecoderScript Manual provides instruction on how to create
custom decoders and use them just like any of the decoders supplied with the protocol
analyzer. You can also apply this knowledge to modify decoders supplied with the protocol
analyzer.

For more information about Frame Decoder, consult the DecoderScript Manual located in
the desktop folder under Optional Components, or simply select Start [ Programs [ Frontline
[Product Name and Version Number] | Optional Components | DecoderScript Manual.
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20 Index

A

A2DP Decoder Parameters - 21
About Display Filters - 131
About Statistics - 89
Absolute Time - 175
Absolute Timestamp Search - 126
Add a New or Save an Existing Template - 45
Adding a New Predefined Stack - 51
Adding Comments To A Capture File - 147, 150
Advanced Display Filtering Techniques - 135
Apply Capture Filters - 131, 132
Apply Display Filters - 131, 132, 134, 135, 136, 137,
138
ASCII - 62, 123
character set - 182
removing the numbers on the Event Display - 62
searching for ASCII strings - 123
viewing data in - 62
ASCII Codes - 182
ASCIl Pane - 77
Automatically Request Missing Decoding Information
-54
Auto-Sizing Column Widths - 74
Auto-traversal - 51
AVDTP - 24, 25, 26, 27, 28
AVDTP Override Decode Information - 28
AVDTP Parameter - 24, 25
Add - 24
Delete - 25
AVDTP Parameter Template - 24, 26, 27
Add - 26
Apply - 24
Delete - 27

Bookmarks - 129, 130, 140
Boolean - 134, 137
Buffer - 144

Buffer Tabs - 90
Byte - 78, 181

B

Bar Charts - 91

Baudot - 62, 163

Baudot Codes - 182

BD_ADDR - 182

Binary - 122, 124

Binary Pane - 78

Bluetooth low energy Analyzer - Update Firmware -
13

Bluetooth low energy Analyzer Hardware Settings - 12

Bluetooth low energy 10 Settings - 15

C

Calculating Data Rates and Delta Times - 60
Capture Buffer - 144
Capture File - 144, 146, 147, 150
changing default location of - 171
loading - 149
removing framing markers - 53
saving - 144
Capture Filters - 131
CFAfile - 146, 147, 150
Changing Default File Locations - 171
Character - 122,123
Character Pane - 77
Character Set - 62, 182, 183
Character Strings in Searching - 123
Characters Per Second Table - 91
Color of Data Bytes - 79
Colors - 79
Column Width - 74
Comma Separated File - 161
Compound Display Filters - 134
Confirm CFA Changes - 146
Context For Decoding - 54
Control Characters - 124
Control Signals - 173
Control Window - 6, 9
Configuration Information - 6
Conversation Filters - 134
Copying Statistics - 90
CSV Files - 161
Custom Protocol Stack - 51
Custom Stack - 51
Customizing Fields in the Summary Pane - 74

D

Data - 60, 143, 144

Data Byte Color Denotation - 79
Data Extraction - 107

Data Rates - 60

Decode Pane - 76
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Decodes - 54, 67, 76, 118

Default File Locations - 171

Delete a Template - 46

Deleting Display Filters - 136

Delta Times - 60

Difference Between Ethernet Capture Filters - 131
Direction - 134

Directories - 171

Disabling - 174

Display Filters - 131, 136, 137, 138
Display Options - 176

Dots - 75

Driver - 185

Duplicate View - 59, 72
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Frame Display - Right Click Filtering - 76, 81
Freeze - 61
FTS Serial Driver - 185

G

Graph Refresh Rate - 91
Graphs - 91
Green Dots in Summary Pane - 75

E

Easy Protocol Filtering - 79, 138
EBCDIC - 62

EBCDIC Codes - 183
Enabling/Disabling Timestamping - 174
Errors - 79, 81, 86, 140, 141, 173
Event Display - 72, 156, 162

Event Display Export - 162

Event Display Print - 156

Event Numbering - 181

Event Pane - 78
Exclude - 132
Exclude Radio Buttons - 132
Expand All/Collapse All - 76
Expand Decode Pane - 73
Export

Export Baudot - 163

Export Events... - 162

Export Filter Out - 161

H

Hex - 124

Hexadecimal - 77

Hiding - 84

Hiding Display Filters - 136

Hiding Layers - 85

High Resolution Timestamping - 176, 177

1/0 Settings - 7

Include - 132
Include/Exclude - 132
Information Screen - 50

F

Field Width - 74

File - 143, 144, 149

File Format Required for Merlin Capture Files - 151,
181

File Locations - 171

Filtering - 80, 138, 141

Filters - 79, 80, 81, 84, 86, 131, 132, 134, 135, 136,
137,138, 140, 141

Find - 118, 122, 123, 124, 125, 126, 127, 128

Font Size - 65

Fractions Of A Second - 176

Frame Display - 67,71, 72,73, 74,75, 76, 77,78, 79
Frame Display Status Bar - 71
Frame Display Window - 67
Frame Symbols - 75
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L2CAP - 30, 31, 32,33
L2CAP Parameter - 30, 31
Add - 30
Delete - 31
L2CAP Parameter Template - 30, 32, 33
Add - 32
Delete - 33
Layer - 85
Layer Colors - 79
Live Update - 61
Low Energy Timeline
Average Throughput Indicators - 102
Button Bar/Legend - 97
Discontinuities - 105
Legend - 106
Navigating and Selecting Data - 96
Once Second Throughput Indicators - 103
Throughput Display - 102
Throughput Graph - 104
Timeline Menu Bar - 98
Timeline Packet Depiction - 96
Visual Elements - 100



Zooming - 102

M

Master - 7

Menus - 5

Merlin Files - 151, 181
Minimizing - 9

Missing Decode Information - 27, 39
Mixed Channel/Sides - 63
Mixed Sides Mode - 63

Modem Lead Names - 173
Modify Display Filters - 137, 138
Multiple Event Displays - 59
Multiple Frame Displays - 72
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Protocol Stack - 51, 52

Q

Quick Export - 161
Quick Filtering - 81, 140

N

Named Filters - 141
Names - 173

Node Filters - 134
Nonprintables - 161
Notes - 147, 150
Numbers - 181

(0]

Octets Per Second Table - 92
Open - 59
Open Capture File - 149
Options - 172,174
Override Decode Information - 28, 40
Overriding Frame Information - 54

R

Radix - 77
Red Frame Numbers - 79
Relative Time - 125, 175
Relative Timestamp Search - 127
Remove
Bookmarks - 129
Columns - 74
Filters - 136
Framing Markers - 53
Renaming - 138
Reset Panes - 73
Resetable Tab - 90
Resolution - 176
Revealing Display Filters - 136
Revealing Layers - 85
Revealing Protocol Layers - 85
RFCOMM - 36, 37, 38, 39, 40
RFCOMM Missing Decode Information - 39
RFCOMM Override Decode Information - 40
RFCOMM Parameter - 37
Delete - 37
RFCOMM Parameter Template - 36, 38, 39
Add - 38
Apply - 36
Delete - 39

P

Panes - 73
Pattern - 122
Percentages - 91

Performance Issues For High Resolution Timestamps -

177
Performance Notes - 180
Physical Errors - 79
Pie Charts - 91
Printing - 91, 156
Printing from the Frame Display - 153
Progress Bars - 181
Protocol
Protocol Layer Colors - 79
Protocol Navigator - 82

S

Save - 132, 143, 144
Save As - 143
Saving - 143, 144
Display Filter - 132
Saving the Capture File using File > Save or the Save
icon - 143
Search - 118, 122, 123, 124, 125, 126, 127, 128, 130
binary value - 122
bookmarks - 130
character string - 122
control characters - 124
entering character strings - 123
hex or binary characters - 124
hex pattern - 122
pattern - 122
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strings in decodes - 118
timestamp - 125
wildcards - 122
Serial Driver - 185
Sides - 173
Slave - 7
Sorting Frames - 72
Source BD_ADDR - 182
Source BD_ADDR Field - 182
Start Up Options - 172
Statistics - 89
Statistics Graphs - 91
Summary Layer Protocol - 80, 138
Summary Pane - 74, 75
Synchronization - 72
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