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1.0 General Information

1.0 GENERAL INFORMATION

1.1 Software Overview

iVision-PM Image Processing and Measurement
Software is a general software in image capturing,
image processing, and in geometric measurement.

1.2 System Requirements

System: IBM compatible PC with Windows XP, Windows Vista, or Windows 7 32-bit operating system.
1GHz CPU and 512MB RAM or higher are recommended due to the intensive calculation in image
processing. At least two USB2.0 ports are required with one for the USB license key and another for the
USB camera (if needed).

1.3 Main Features

1.3.1 Image capturing
Image capturing with USB cameras that are DirectShow compatible, or through standard image files

1.3.2 Image processing and measurement
Rich set of image processing utilities. Geometric measurement functions.

1.4 Standard Features

1.4.1 Geometric Measurement

System provides the tools to draw and measure common geometric shapes such as lines, angles, 4-point
angles (for missing or hidden vertexes), rectangles, circles, elipses, and polygons. Note that the
measurement assumes the system is calibrated.

1.4.2 Image Processing

System provides arich set of image processing tools for advanced users. The standard tools in the system
include adjusting Brightness, Contrast, Gamma, and Histogram Level, and the Sharpen, Smooth, Invert,
and Convert to Grey functions. On grey scale images, system provides various advanced tools in
filtering and finding edges, as well as some standard tools in morphological operations such as
Open,Close,Dilation,Erosion, Skeletonize,and Flood Fill.

1.4.3 Document Entry

On an image, system provides a document editor to enter/edit documents with contents either in smple
plain text format or in advanced HTML format with objects including tables, list, and images.
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1.4.4 Album Management

System allows user manage multiple images in an abum which can be saved to and opened from an
album file. The images can have the standard geometric shapes and the documents as entered by user as
described above.

1.4.5 Printing With Magnification
System can print the image with user specified magnification if it is calibrated.
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2.0 Software Installation

2.0 SOFTWARE INSTALLATION

2.1 Installation Overview

iVision software is modular in architecture. It consists of the application platform and upon which the
application modules. The following components are installed in iVison-HB: 1) Microsoft VC++
redistributable package since iVision is developed with MSVC; 2) iVision software platform; 3) Related
hardware drivers in the package such as the camera driver; 4) iVision application modules such as
iVision-PM.

2.2 Installation Instructions

Double-click the installer file 1Vision_v1.0.0 WIN32 XP_TZXXXXXX instaler.exe to start the
installation process, and answer “Yes' at all the prompts in the camera driver installation, where
TZXXXXXX isthe USB license key ID. Note to change the drive in installation directory if other than
the default D: drive. Also note that if installation error message “11 Camera 02 DirectX registration failed”
shows up in the installation process, then it is necessary to manually register the camera DirectX driver
after the installation process by running (double-clicking) the reg.bat in the iVision installation folder
(D:\Intelligent Instruments\iVision_v1.0.0\Drivers\ll_Camera 02\DirectX).
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3.0 GETTING STARTED

3.1 Camera Setup

It is necessary to set up the USB camerafor the system at the first time use and these steps can be totally
skipped at later use.

3.1.1 Cameradriver installation

When the USB camerais plugged in at the first time use after iVision isinstalled, depending on the
computer operation system the computer may ask to install the cameradriver either manually or
automatically. Answer “automatic” since the cameradriver is already pre-installed during installation.

3.1.2 Camera selection

Open iVision, select menu I mage Capture ->Open captur e window to invoke the “M edia Capture”
window. Then go to menu Devices and select |1 Camera 02 or another applicable camera. Note that the
following setup instructions apply to |1 Camera 02 only, and different cameras have different parameter
configurations.

5| Media Capture A@ﬁﬂ

File [Devices] Options  Capture

Integrated Camera

v | 1 Camera02

Microphone (2- High Definition

3.1.3 Image resolution setup

On Media Capture window, select menu Options -> Video Capture Pin... to bring up the camera video
format setup Properties dialog and select desired resolution on Video Format under For mat tab.

| Media Capture AEI&IQ W——l—-— ﬁ
= Dewice Fovmsat
File Devices [ Optiom Capture —
\ E— Vides Pormar [ EPICUOIPICTOR = |
o ] Cwilfat Tundewn
MPEGE Suarnl Conrdanatos
Stwrd] Conrdapatag F

Video Capture Filter...

Enll Cosrdinatas

Video Capture Pin...
EsdT Cosrdinatan
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3.1.4 Camera parameter setup

On Media Capture window, select menu Options -> Video Capture Filter ... to bring up the camera
parameters setup Properties dialog. Under tab Plugin, click button Plugin, select menu Plugin
Manager ... to invoke the Plugin Manager dialog. Make sure all the plugin components are checked.
i

rr'mpe-bes

Cortral | Caplirn i‘\-ulll

Flugin Baagar
e ] Phugin Mansger_.
Sante Funcesan Cantnal
Inage Canvent
Plugins Manager (HV1351UCT)
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1 Isage Convart
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wied in SelLARE wuts PERellon parssstar
[ ok Cancal | Cow

Finally go back to Media Capture window, and select menu Preview, camera video preview should
appear on both Media Capture window and iVision main window. Select menu Options -> Video
Capture Filter... to bring up the camera parameter setup Properties dialog again and adjust the A/D ->
Change Level under Capture tab, and the Shutter->Speed and the Gain->Gain parameters under
Control tab for the best quality image capture. Note the Units selection in Shutter speed.

Exit iVision, the above camera settings should be saved and there is no need to do the setup when iVision
is opened the next time.

r
— — a
Control Capture lPIugin ] Control lCapture] Plugin ]
Snap Mode Shutter
Snap Rate [17.477745 r
TR hete Speed 1 IDDD: 21 Reset
Snap Speed |QEEE i .
ExposureMode J Units |ms j
Snap Mode |Continuatic™
Gain
Trigger Polarity |High ¥| Strobe Polarity |[High ~ I~
@efm 1) 127 1o Reset
) ——————
Ll 4
AD ’—
Change Lewel ADC_LEVELZ + Black Lewel |picabled - y 4
—-255 255 Blanking
BFlack Level — o — 2038 ,—
| Horizon )g— u Hesat
E 2022
EiaE ey —— T
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3.2 Starting the application

3.2.1 Graphical User Interface (GUI) setup

Layouts: Different application moduleiniVision hasitsown GUI .  If GUI of other application module
is shown, select menu View->Clear image process view to clear the GUI. User may adjust general GUI
dimensions such as splitter dimensions, table column widths etc and these new settings will be kept by the
application.

Configurations: Many other GUI settings such as menu orders can be configured in the Configuration
Settings dialog through menu File -> View/Edit configurations...

1
T e —— —

- —
Language: To choose a different GUI language, go to menu Help and select menu Language. Choose the
new language and the application will exit. After restarting the application the new language will take
effect.

3.2.2 Camera calibration

Image stitching and extended focus imaging do not need camera calibration. If the function of geometric
measurement is not to be used in the system then this section can be skipped. However to get
guantitative geometric measurement from the cameraimage it is necessary to calibrate the camera to
obtain the conversion from pixel locations to their object physical locations. There are two methodsto
calibrate the camerainiVision.

1) Manual calibration

Manual calibration simply calculates the linear scale between the pixel distance and the physical distance
of two pointsonimage. Place the calibration ruler or grid under the camera, start video preview by
selecting menu I mage Capture -> Preview, move the ruler or camerato make sure the lines are
approximately aligned in preview and snap an image by selecting menu I mage Capture -> Capture
Image.

Select menu Calibration -> Manual calibration, hold down the mouse and drag from one line to another
line with known and adequate separation distance and then release mouse.
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[

A dialog will prompt user for the known physical distance between the dragged start and end linesand a
name for the calibration.  After the manual calibration is done, system will prompt user whether to load
the done calibration or not. In any case user can load the named calibration by selecting menu
Calibration->Calibration viewer and load the calibration from there.
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2) Automatic calibration

Automatic calibration is much more complex in process but more convenient in usage. It automatically
finds the cross points on the grid image, map them to their physically locations and obtain the true 2-D
mapping between a physical location and its pixel location viainterpolation.

In stead of acalibration ruler, a calibration grid is needed to do the automatic calibration.  First select
menu Calibration->Auto calibration settings to set up the X&Y line distance, unit etc. If thelinesin
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image will be darker than the background then Invert Image needs to be checked. Snap an image with the
grid approximately aligned.  Select menu Calibration->Automatic calibration to perform the automatic
calibration after which the system will locate and mark most of the cross points of the grid image.

' % Automatic Calibration Settings

Length Unit  mm
Enter Calibration Mame

Grid Interval X 1

Grid Interval ¥ 1 guto_testl

Invert Image Ok I [ Cancel

-
5| Automatic Calibration g
S

Do you want to load the calibration?

~ e
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3.3 Appendix: Using the standard features

3.3.1 Geometric Measurement

Select any one of the sub-menus on the menu GeoM easure, the geometric measurement main interface
will appear. Draw the standard geometric shapes on the image and their measurement results will be
displayed on the data table on the right and on the shapes for some shape types. User may edit a shape
by click selecting the shape and mouse dragging on one of its control points, and the corresponding
measurement results will be automatically updated.

wp oy e | i Ly A (e s

3.3.2 Image Processing
Select menu Preprocess and its sub-menus to access the image processing tools.

3.3.3 Document Entry

Push on the Add text A tool button, or select Add text sub-menu under GeoM easure, then click on the
image, enter text at the small text entry box. To edit the text or to enter complex HTML format
documents, double click on the text to invoke the document editor.

* Vision 100 - EdH Autochepe Properties - T

soame Lexd o siar with

] ..htmhrl Text shgnment [Center | Text type [HTML r...“rl.é.'u.

Cocd | = ]

To edit thetext in HTML format, select HTML on Text type. To insert table, list, or image, click on the
tool buttons at the right bottom.  The tool buttons to change font, text color, and text alignment lie at the
left bottom.
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3.3.4 Album Management

To view the album, select menu View->Image Album. To change image display size in abum, move
the splitter.  Album can be docked in the main window and it can be floated also.

Double-click on the image will copy the image into the album, and conversely double-click on the
image on the album will copy it to the image panel

To open/save album file go to menu File

To reorder the images in album, drag an image with its frame and drop it to position

To remove an image or images on album, click or right mouse popup menu Select All to select and
press the Delete key

3.3.5 Printing With Magnification

Connect to the printer first and select menu File->Print... to bring up the printing dialog. Select or
enter the desired magnification at the bottom, the image print size will change accordingly in preview.
User may enter text (can bein HTML format to include tables,lists,images etc) under user input and the
text will be saved for next printing. Analysisresult tables and statistics summaries can be checked for
printing. And all the above elements to be printed have options in printing locations in either top,
bottom,left, and right.  The textbox widths can be limited by their width inputs.
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