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Getting Started 

Welcome to SmartDraw! 
SmartDraw is the easy-to-use program that lets anyone draw great-looking charts, 

diagrams, presentation graphics, and more. You don't have to be an artist to get 

great results with SmartDraw. 

Ready-made SmartTemplates help you get started and thousands of built-in 

SmartDraw symbols provide a nearly unlimited selection of objects and graphics you 

can use in your drawings. SmartDraw automatically aligns your shapes, symbols, 

lines, and text for a perfect appearance and the ready-made Design Themes can 

create a professional-looking color scheme for your entire drawing with just a click 

of the mouse.  

SmartDraw works as a stand-alone program, and also with Microsoft Office and 

other programs that support Object Linking and Embedding (OLE).  You can insert a 

SmartDraw drawing directly into Microsoft Word or PowerPoint with a simple copy-

and-paste. You can also insert Office documents, like graphs, equations, and 

spreadsheets into your SmartDraw drawings. 

Installing SmartDraw 
Before you can run SmartDraw, you must install it by running the Setup Program. 

There are two ways to get the setup program file:  

By downloading over the Internet 

On a CD 

Internet Download 
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Anyone can freely download the SmartDraw Trial Edition from www.smartdraw.com. 

You can also download full versions of any SmartDraw program that you have 

purchased. 

In either case, the file you download to your computer is an installation program.  

You must run it to install SmartDraw onto your system.  

The simplest way to do this is to download the file to your desktop. This creates an 

icon on your Windows desktop. You can then run the install program by double 

clicking on its desktop icon. Alternately, you can run the installation program using 

the Run command under the Windows Start menu. 

CD 

If you purchased SmartDraw on a CD, all you have to do is put the disc in your 

computer’s CD drive, and the setup program, setup.exe, will start automatically. If 

this does not happen, you must run setup.exe manually. 

The easiest way to do this is to use the Run command, found by pressing the 

Windows Start button. You will be prompted for the name of the program you want 

to run. If you placed the SmartDraw CD in your computer’s Drive D, for example, just 

type: 

D:\SETUP 

Then simply follow the directions displayed by the Setup program.  

Installing SmartDraw on a Network 
To install SmartDraw on a network, simply install it on the server in the normal way 

described above. For each client that will have access to the server, create a 

shortcut (or icon) for SmartDraw on the client system and run the program once. 

SmartDraw will install itself properly on the client system. 

You must have a workgroup license to share one copy of SmartDraw between 

multiple users on a network.  

SmartDraw will not run from a network drive unless you have a workgroup license. 

SmartDraw counts the number of different users that have accessed the program 

on the network (not including the server itself) and limits the number of unique users 

to the number of licenses you have purchased. If a user has accessed the program 

but no longer needs to use it, you can free that user's license using the network 

administration features under the License command. 
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See SmartDraw Licenses for more information 

The Document Browser  
The Document Browser is the first screen that appears each time you run SmartDraw. 

 
The Document Browser 

In the document browser you can do two things: 

Create a New Document 

Open an Existing Document 

 

Creating a New Document 

By default, when SmartDraw is opened, the Document Browser shows a list of 

drawing Categories in the left column, with thumbnail images of SmartTemplates 

from the currently selected category in the preview area, located at the center of 

the screen. 
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You can browse through the categories by clicking on them in the left column, or 

Template List.  

Open a SmartTemplate to begin a new drawing by clicking on its image in the 

preview area. 

Opening an Existing Document 

Usually when you start SmartDraw the Document Browser will show your most 

recently saved Existing Documents to choose from.  If you want to open an existing 

document, but the Document Browser is showing the New Document screen 

instead, click My SmartDraw Documents at the top of the Template List. 

Click on the thumbnail image of any of the existing documents to open it. 

If the document you want is not displayed, you can click the Browse button to find it 

on your computer. 

Getting Help 
There are three basic Help resources in SmartDraw:  

SmartHelp Panels 

The Help Tab 

Help in Dialogs 

SmartHelp 

As you work, SmartDraw offers context-sensitive instructions in the SmartHelp panel 

at the right side of the screen.  To close that panel, click the close button (X) in its 

title bar.  To reopen it, click the SmartHelp button at the top right corner of the 

Drawing Area (where the SmartHelp panel normally appears.) 
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A SmartHelp Panel 

The Help Tab 

The Help Tab, at the top right side of the Main Toolbar, offers Help and information 

about your SmartDraw program.  

 

 

 User Guide - This User Guide, which you are reading, provides extensive, 

detailed documentation of SmartDraw’s functions. Unlike the SmartHelp panels at 

the right side of the Drawing Area, which are "How to Draw" tutorials for specific 

kinds of drawings, this User Guide explains the technical functions common to the 

entire program. 

 Tech Support Provides information on getting technical support from 

SmartDraw.com. 
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Update checks for program updates, fixes, or new program content. 

 About displays information about your particular copy of SmartDraw, including 

its version number and serial number. 

 License allows you to view and manage your SmartDraw license(s). 

Help in Dialogs 

Dialogs are the little screens that pop up to ask you a question, provide information, 

or take input from you. All dialogs contain a Help button. Pressing this button, or 

typing the F1 key, opens the Help system to the section that describes that dialog’s 

functions. 

 
Getting Help in a Dialog 

Creating a New Document  
 

When SmartDraw is already Running 

  To create a new document when the SmartDraw program is already running, 

click the SmartDraw Button in the upper lefthand corner, then click New (Ctrl + N). 

This will opens the Document Browser showing you the SmartTemplates you can use 

to create a new document. 
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Select a category in the left column Template List and then click on a 

SmartTemplate thumbnail image in the preview area to open it. 

The new document will open in a new instance of the SmartDraw program window 

with its own program button in the Windows Taskbar at the bottom of your screen. 

When You Open SmartDraw 

Usually when you start SmartDraw, the Document Browser will show your most 

recently saved Existing Documents to choose from.  

If you want to create a new document, click on a Category on the Template List of 

the Document Browser window. 

The Document Browser will then display the thumbnails for that Category, where you 

can choose a SmartTemplate to start your new document. 

 

Closing and Saving Documents 
Closing Documents 
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 You may close the current document by using the Close command on the More 

menu under the Document tab, or by clicking the close button (X) on the Drawing 

Area Toolbar. 

Clicking the Close Button (X) at the top right of the entire program window will exit 

that instance of the entire program, not just the current document. 

If you have made changes since you last saved your drawing, you are reminded to 

save your document before the window closes. 

Saving Documents 

 You can save drawings to a file on your hard disk by clicking on the SmartDraw 

Button in the top left corner of the screen, then selecting the Save or the Save As 

command from the menu. 

New drawings must be given a name before they are saved. You do this with the 

standard Save Dialog you see in all Windows programs. 

 
The Save Dialog 

For drawings that have been saved, and already have a file name, the Save As 

command can be used to save the drawing to a different file name. The Save 

command, by contrast, always saves the drawing to the same file name. 

Choosing Save as Template from the SmartDraw Button menu saves the current 

drawing as a SmartDraw Template. This is the same as a normal file but with the 

extension SDT. When template files are opened, an untitled copy is made and the 

template is left unopened and unaltered. When you save a file as a template, your 

original drawing is also preserved with its current .SDR file name.  
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Documents and Windows  
Each time you open a SmartDraw document, it opens a new instance of the 

SmartDraw program, with its own Program Button in the Windows Taskbar at the 

bottom of the screen. (In this way it behaves just like Microsoft Word, Excel, and 

other Office programs). 

To switch between different open SmartDraw documents, click the Taskbar button 

for the one you want to make Active and view on the screen. 

All program commands and actions apply only to the drawing in the currently 

Active SmartDraw program window.  

Right Mouse Button Menus  
Clicking with the right mouse button in the Drawing Area displays a context-sensitive 

menu which is specific to the area of the screen or the object that you clicked on.  

The right-click menus provide convenient shortcuts to many of the features found on 

the Toolbars. 

 

The Main Toolbar  
 

The Main Toolbar lies at the top of the SmartDraw program window.  It consists of 

Tabs containing Groups of commands, with the group name indicated on a Group 

title bar below the command buttons.  

  Dialog Launcher If the Group title bar contains this, you can click on it, which 

causes a dialog with more options to appear. 

 

 

The Main Toolbar 

Tabs, such as Home and Table, appear at the right side of the toolbar depending on 

which tab is selected.  
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The Table Tab 

 

The SmartPanel 
 

The SmartPanel lies at the left side of the SmartDraw Program Window, and contains 

tools specific to a particular kind of template, such as Flowcharts.   

 
The Flowchart SmartPanel 
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The SmartDraw Button 

  Clicking on the SmartDraw Button, located in the top left corner, provides you 

with a menu of options.  

  New (Ctrl+N)   - Open the template selection screen to begin a new document. 

  Open (Ctrl+O) - Choose from a list of previously saved documents to open. 

  Save (Ctrl+S) - Save your document. 

  Save As - Save the document using a different file name or format. 

  Save As Template - Save the document as a SmartDraw template.  

  Print (Ctrl+P) - Print your document. Displays the Print Dialog to select the 

printer, number of copies, and other properties before printing. 

   Print Preview - See how your printed document will look. 

  Export as Graphic -Export drawings in a number of common graphics formats, 

such as JPG, EMF and many others. 

  Email - Open a new email message in your default email program and 

automatically attach the current SmartDraw document. 

  Publish to Web - Share files and publish your SmartDraw documents as web 

pages. 

  Spelling - Change the way SmartDraw checks the spelling in your documents. 

  Libraries - Open, create, or automatically build symbol libraries. 

  SmartDraw Options - Set the properties (such as line linking and shape linking) of 

your document, and general SmartDraw options. 
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  Select New Template - Go back to the Document Browser to select a different 

template. 

  File Conversion Wizard - Automatically convert files from other programs into 

SmartDraw files. 

  Close Document (Ctrl+W) - Close this document.  Does not close other open 

SmartDraw documents. 

   Close SmartDraw (Alt + F4) - Quit the entire program. 

The Home Tab 
Each of the Groups in the Home tab has sets of commands represented by buttons 

and menus. 

The Clipboard Group 

 
 

  Click the arrow below Paste for more options: 

-  Paste (Ctrl+V) - Paste the last objects that were cut or copied (from SmartDraw 

or another program) onto this page. 

-  Paste Special - Choose which method to use in pasting an object from another 

program. 

-  Duplicate - Make a duplicate copy of the selected object or objects. 

  Cut (Ctrl+X) - Delete the selected object or objects from the page. 

  Copy (Ctrl+C) - Copy the selected object or objects so they can be pasted 

somewhere else. 

  Format Painter- Copy the formatting from one object or block of text and apply 

it to another. 
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The Tools Group 

 

 Select Tool - Choose to select Multiple Objects, select all Objects, all Shapes, or 

all Lines in the document. 

  Text Tool - Click on a shape to open it for text entry, or in the background to 

create a new Background Text Object.  

  Shape Tool - Click in the drawing to add the currently active shape.  To change 

the currently active shape, click the down arrow below the tool and select a new 

one from the menu. 

  Line Tool - Use the pencil cursor to draw a line.  You can change the type of line 

the tool draws by clicking the down arrow to its right and choosing from the menu. 

  Arrowhead Tool - Add arrowheads to a selected line, or set the default 

arrowhead style for future lines. 

 

The Theme Group 

 
 

Use a Theme to change the entire look of the document with a single click. 

  Scroll Up/Down Buttons - Scroll up or down to view more themes. 

  Open Gallery Button - Select a Theme from the gallery. 

 

The Shape Style Group 
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  Quick Styles- Apply a predefined style to selected objects. 

  Fill - Fill a selected object with a color, texture, or gradient. 

 Line- Change the thickness, fill, or style of a line. 

 Effects - Apply special effects like glow and shadow to selected objects 

 

The Font Group 

 
 

  Font - Change the font for a selected object or block of text. 

  Font Size - Change the font size for a selected object or document. 

  Bold - Make the selected text bold. 

  Italic - Italicize the selected text. 

  Underline - Underline the selected text. 

  Subscript - Make the selected text a subscript. 

  Superscript - Make the selected text a superscript. 

   Text Color - Change the color of selected text. 

  Insert Symbol - Insert a standard text symbol into your drawing or into a selected 

object. 

  Font Dialog Launcher - Open the Font dialog for further customization of text in 

your document. 
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The Paragraph Group 

 
 

  Bullets - Add bullets to selected text. 

 Alignment- Align the selected text, or the text within a selected object. (Note: 

Depending on your screen width, you may see six separate alignment buttons, or 

one button with a drop-down list of six options.) 

 Spacing - Increase or decrease the spacing between lines of text. 

 Direction - Change the orientation of text one a selected line. 

 

The Design Tab 
 

Each of the Groups in the Design tab has sets of commands represented by buttons 

and menus. 

The Position & Size Group 

 
 

  Height Menu - Change the height of a selected object. 

  Width Menu - Change the width of a selected object. 

  Dialog Launcher - Open a dialog to edit position and size. 

 

The Shape Layout Group 
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  Align - Align the edges of selected objects with a target object (the last one 

selected). 

  Rotate - Rotate an object or group of selected objects. 

  Group - Group or Ungroup selected Objects. 

 Bring to Front - Bring the selected object or objects to the front of all other objects 

on the screen. 

  Send to Back - Place the selected object or objects behind all other objects on 

the screen. 

  Flip - Flip the object around its horizontal or vertical axis. 

  Make Same - Make selected objects the same size in width, height, or both. 

  Space Evenly - Space selected objects evenly on the page, vertically, 

horizontally, or both. 

 

The Shape Properties Group 

 
 

  Change Shape - Select from a menu: 

-   Change Shape - Choose a new shape for the selected objects. 

-   Edit Shape Outline - Manually adjust a selected shape’s outline. 

   Change Line - Select from a menu: 
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-   Change Line Shape - Select a new shape for the selected line. 

  Connection Points - Change the points at which a line or another shape can 

anchor to the selected shape. 

  Text Entry - Open a dialog providing several types of options for entering text into 

shapes. 

  Dimensions - Open a dialog with options for how and when the dimensions of 

the selected object(s) are displayed. 

 Dialog Launcher - Open a dialog with options for resizing, linking, printing, and 

more. 

 

The OLE Group 

 
 

 Links - Manage linked OLE objects in your document. 

 Object - Manage an OLE object that has been imported from another program 

to SmartDraw. 

 

The Insert Tab 
 

The Insert Group in the Insert tab has a set of commands represented by buttons 

and menus. 

The Insert Group 

 
 

  Insert Table - Insert a table into your drawing or into a selected object. 
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  Insert Picture - Insert a picture into your drawing or into a selected object 

  Insert Chart - Insert a chart into the work area. 

  Insert Map - Import a Map Powered by Google. 

  Insert Web Page - Import a Web Page into the work area. 

   Insert Hyperlink - Add a hyperlink from a selected object to a webpage, 

document, program, or SmartDraw file. 

    More - Insert other kinds of objects into your drawing. 

 

The Page Tab 
Each of the Groups in the Page tab has sets of commands represented by buttons 

and menus. 

The Page Style Group 

 

  Background - Change the background color (or texture or picture) for the 

document. 

 

The Page Setup Group 

 
 

  Orientation - Switch between portrait and landscape page layouts.  

  Margins - Set the margins for the pages in your document. 
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  Layers - Add layers to your document, or change the properties of layers.  

  Work Area - Control the number of pages in the document. 

  Center in Work Area - Center the entire drawing on the page, or on multiple 

pages. 

 

The Rulers & Grid Group 

 
 

  Scale - Set the scale for your document. 

  Snaps - Select how an image anchors to the work area grid. 

  Show/Hide Rulers - Make the rulers at the edge of the drawing area 

visible or invisible. 

  Grid - Make the invisible grid visible. 

  Use Snaps - Determine whether objects snap to the grid. 

 

The Find & Replace Group 

 
 

  Find - Search for words or phrases used in the text of your document. 

  Replace - Search for words or phrases used in the text of your document, then 

replace each occurrence with a new word or phrase. 



SmartDraw 2009 User's GuideUser’s Guide Getting Started ••••  27 

The Table Tab 
Each of the Groups in the Table tab has sets of commands represented by buttons 

and menus. 

The Insert Table Group 

 
 

  Insert Table - Insert a table into your drawing or into a selected object. 

  Number of Rows - Select a number from the menu. 

  Number of Columns - Select a number from the menu. 

 

The Rows & Columns Group 

 
 

  Delete Row /Column - Delete the contents of a row or column, or completely 

remove the row or column from your table. 

  Insert Left - Insert a column to the left of the selected cell. 

  Insert Right - Insert a column to the right of the selected cell. 

  Insert Above - Insert a row above the selected cell. 

  Insert Below - Insert a row below the selected cell. 

  Join Cells - Join selected table cells into a single cell. 

  Split Cells - Split a selected table cell (or cells) into two cells. 

  Distribute - Space rows or columns evenly. 
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The Table Style Group 

 
 

  Format Table - Apply advanced formatting to your table. 

  Fill - Fill a selected object with a color, texture, or gradient. 

  Line - Change the thickness, fill, or style of a line or border. 

   Effects - Apply special effects like glow and shadow to selected objects 

 

The Data Group 

 

  Autofill - Automatically fill a row or column in the table with a series of numbers 

or dates. 

  Convert Shape to Table - Fill the interior of a shape with a table.  

  Convert Table to Text - Create a single text object containing all the text from the 

table. 

  Text Editing - Lock the text in selected table cells so that it can’t be 

changed. 

 

The Chart Tab 
Each of the Groups in the Chart tab has sets of commands represented by buttons 

and menus. 

The Insert Chart Group 
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  Insert New Chart - Select a chart type from the menu. 

  Insert Chart From File - Browse your computer for an existing chart. 

  Insert Chart From Clipboard - Insert a copied chart. 

 

The Chart Type Group 

 
 

  Bar Chart - Switch your current data to a Bar Chart format. 

  Pie Chart - Switch a category of your current data to a Pie Chart format. 

  Stacked Bar Chart - Switch your current data to a Stacked Bar Chart format. 

  Line Chart - Switch your current data to a Line Chart format. 

  Linear Chart - Switch a category of your current data to a Linear Chart format 

 

The Chart Data Group 

 
 

  Add Series - Add a data series to your chart. 
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  Add Category - Add a series category to your chart. 

  Show Data - Display a table containing the data depicted by the chart. 

  Swap Series & Categories - Switch the display of series and categories. 

  Pie Data - Choose which category to display in a pie chart. 

 

The Labels Group 

 
 

  Data - Select the manner in which data is displayed on your chart. 

  Horizontal Axis - Select the manner in which the values for the horizontal axis 

are displayed. 

  Vertical Axis - Select the manner in which the values for the vertical axis are 

displayed. 

 

The Layout Group 

 
 

  Axis - Select whether or not the axes are displayed. 

  Grid - Select which parts of the grid are visible. 

  Legend - Determine which parts of a legend are displayed. 
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  Rotate Chart - Select which quadrant the chart is in. 

  Max - Set the maximum of the vertical axis. 

  Min - Set the minimum of the vertical axis. 

 

The Style Group 

 
 

  Fill Type - Select a fill color, texture, gradient, or image. 

 

The Picture Tab 
Each of the Groups in the Picture tab has sets of commands represented by buttons 

and menus. 

The Get Images Group 

 
 

  From Camera - Import Images straight from a camera linked to your computer. 

  Picture Folder - Open an entire folder of pictures. 

  Open Picture - Open one picture. 

  Capture Web Image - Take a screen shot of a web page. 
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The Picture Size Group 

 
 

  Pan & Zoom - Change your view of the image. 

  Crop - Crop your image to remove any unnecessary regions. 

  Trim to Shape - Cut an image to fit in a shape. 

 

The Exposure Group 

 
 

  Brightness - Adjust the brightness of the image. 

  Contrast - Adjust the contrast of the image. 

 

The PowerPoint Tab 
The PowerPoint tab allows you to animate your SmartDraw drawing before it is 

exported to PowerPoint.   

 

Many SmartDraw templates have an inherent sequence already set, to turn this 

animation off, uncheck the “Include Animation” box available in the Export Group. 
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The Animation group allows you to set how your SmartDraw drawing is displayed by 

allowing you to apply a Step number to each object in SmartDraw.  Begin by 

assigning the objects you want to display with 1 all the way down to 16.   

Use the Preview button to see how the drawing will animate in PowerPoint. Use the 

Next and Previous buttons to navigate through the animation. 

The Help Tab 
The Help tab has a series of commands represented by buttons. 

 
 

  Tech Support - Contact technical support. 

  Updates - Check for SmartDraw program updates and new content. 

  User Guide - Open the PDF version of the SmartDraw user guide. 

  About - Information about this copy of SmartDraw. 

  License - View the license(s) for this copy of SmartDraw. 

The Work Area Toolbar 
The Work Area Toolbar lies below the Main Toolbar and above the Work Area.  

 
 

The Work Area Toolbar 
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  Zoom Tool - Click in the drawing to increase the magnification.  Hold Ctrl and 

click to decrease the magnification.  To choose a specific magnification, click the 

down arrow and select from the list. 

  Rulers - Show or hide the rulers at the edge of the work area.  

One-Click Common Control Buttons 
The One-Click Common Control Buttons are located at the top left side of the 

SmartDraw Program Window. 

 

  Undo (Ctrl+Z) - Undo your last action. 

  Redo (Ctrl+Y) - Redo the last action (only available after you use Undo). Works up 

to 100 steps back. 

  New (Ctrl+N)   - Open the template selection screen to begin a new 

document. 

  Save (Ctrl+S) - Save your document. 

  PDF Export - Exports and saves your drawing as a PDF (Adobe Acrobat) 

document. 

  Microsoft Word Export - Inserts your SmartDraw document into Microsoft Word as 

an OLE object. 

  Microsoft PowerPoint Export - Inserts your SmartDraw document into Microsoft 

PowerPoint as an OLE object. 

  Microsoft Excel Export - Inserts your SmartDraw document into Microsoft Excel as 

an OLE object. 

 

Rulers and Grids  
Rulers 
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 For some drawing types, rulers automatically appear along the top and 

left edges of the work area.  For other types they are hidden.  In either case, you 

can show or hide the rulers by clicking on the Show Rulers button on the Page Tab. 

 
Work area with rulers showing 

The Status Bar in the lower-right corner of the document window displays the 

coordinates of the cursor, and the dimensions of any currently selected shape, in 

the units of the ruler. 

Clicking in a ruler displays a temporary dotted line, called a Guide, which follows the 

position of the cursor. This can be used to measure the position of an object in the 

drawing. Clicking in the upper left corner, where the two rulers meet, and then 

dragging your mouse into the drawing area, displays two of these lines forming a 

cross hair guide. 

The Grid 

 
The Work Area with Rulers and Grid Showing 

 

  The divisions on the ruler define the spacing of a grid that underlies the 

drawing area. You can show or hide the grid using the Show Grid command on the 

Page tab.  The same grid (whether visible or not) controls the spacing of the Grid 

Snaps.  
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You can print the grid with your drawing if you like: click the SmartDraw Button, then 

click Print and check Print the Grid in the Print Dialog.   

Undo and Redo 
  Almost any change you make to a drawing can be undone using the Undo 

command, at the top left of the SmartDraw Program Window.  Ctrl-Z is the shortcut 

keystroke for Undo. 

  After you undo an operation, the Redo button becomes active. Using Redo 

returns the program to its state before the undo command was used.   Ctrl-Y is the 

shortcut keystroke for Redo  

You can undo and redo up to 100 steps back.  

 If the button is gray, there is no previous state to return to. 

Storing Two or More Drawings in the Same Document 
Because SmartDraw supports multiple pages per document, you may be tempted 

to put separate drawings on different pages in the same document. 

Don’t do this! Store each independent drawing in its own document. 

The multiple page feature of SmartDraw is intended to allow you to draw one large 

drawing that requires more than a single page. It is not intended to allow you to put 

6 different flowcharts in one file. Commands like Center Drawing on Page and Print 

on One Page assume that the contents of a file are one drawing. There is nothing to 

gain by storing multiple drawings in one file. Put all drawings you want to print 

separately in their own drawing file. 

If you have already put more than one drawing in the same file, it is easy to 

separate them by using Copy and Paste to place them into new files. 

Tool Default Settings 
If you change the characteristics of an object in your drawing (such as the fill color 

of a shape, or the thickness of a line) the next object you draw will have those 

characteristics.   

The few exceptions to this rule are specialized settings that you are unlikely to want 

as a default. 
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If you choose to, you can set your own custom default settings for new documents. 

This is described in the Creating Custom SmartTemplates section under Designing 

SmartTemplates. 

Exiting SmartDraw  
You can exit and close any running copy of the SmartDraw program by clicking the 

Close Button (X) at the upper right corner of the SmartDraw program window. 

You can also use the keyboard shortcut Alt F4. Before the program quits, you are 

prompted to save any open drawings that have been changed.  
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The Left Panel 

The Left Panel 
The Left Panel, at the left side of the Work Area, displays the SmartPanel and Library 

Tabs. 
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The Left Panel 

 

The SmartPanel Tab 

The SmartPanel contains buttons and commands relevant to a specific template 

category.  All of these commands can be found elsewhere in the program window, 

such as the Main Toolbar, but the SmartPanel is designed to make creating the 

specified drawing fast and easy.  Each SmartPanel contains a SmartHelp Button at 

the bottom to guide you through creating your drawing. 

When necessary, the SmartPanel contains a small Symbol Library Gallery containing 

a selection of libraries that are pertinent to the diagram type.  In some SmartPanels, 

like the Landscape Design above, the Libraries are topped by Library Selector 

Buttons that you can click on to quickly switch between libraries.  In other 

SmartPanels, such as the one below, there is a Library Selector Menu. 
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A SmartPanel Symbol Library Gallery with a Library Selector Menu 

 

The Symbol Library Tab 

When you open a SmartTemplate, the Left Panel will by default be opened with the 

SmartPanel showing.  To switch to the Symbol Library, simply click on the Library tab 

at the top of the Left Panel. 
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The Symbol Library 

Usually, the SmartPanel will have a symbol library when symbols are necessary or 

recommended for a particular SmartTemplate, so the Library tab is not an absolute 

necessity.  However, the Library tab is available for all SmartTemplates, so you may 

wish to use it when there is no library on the SmartPanel. 

The Library Tab has a Library Selector Menu just like that of the SmartPanel.  You can 

click on the menu to view and switch libraries.   

Searching the Symbol Libraries 
Opening the More Symbols Dialog 

In the SmartPanel, you can click the More Library Selector button and select More... 

if there are buttons, or you can click the Library Selector Menu and select More... if 

there is a menu.   

In the Library Tab, click the Library Selector Menu and select More.... 
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The More Symbols Dialog will appear. 

Using the Search Bar 

At the top of the More Symbols Dialog is the symbols Search Bar. Typing a word into 

this bar and pressing the Enter Key, or clicking on the Search button, searches the 

SmartDraw symbol libraries for symbols that match that word. 

 
The Search Bar 

When the search is completed search results will be displayed in the Search Results 

folder in the Explorer Tree. 

The Explorer Tree is the column of yellow folders in the left side of the More Symbols 

dialog box.  It shows a list of all the currently installed SmartDraw Symbol Libraries. 
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Results of a Search 

The Search Results folder contains temporary shortcuts to the actual libraries, so 

when that folder is cleared, the real libraries remain in their normal locations. 

In addition to the words in its name, every SmartDraw symbol can contain keywords 

that describe its content. These too are searched.  

You can enter more than one word into the Search Bar, separated by spaces or 

commas. SmartDraw finds matches for libraries that contain all of the words that you 

specify. (In Boolean terms, the search is an AND search). If you want to make it an 

OR search, you can type Keyword OR Keyword, and SmartDraw will find any of the 

keywords that you type.  

The search is not case-sensitive. (It doesn’t matter if the words are in capital letters). 

Partial matches are found as long as the word begins with the search word. For 

example, if you searched for Form, matches would be found for Forms and Formula 

but not Perform. 

The word-search index is rebuilt automatically when changes are made to the 

symbol libraries, but if you suspect trouble with the index, you can force it to be 

rebuilt by holding down the CTRL key as you click on the "Search" button. 

Browsing for Symbols 

In addition to the keyword search, you can also browse through the Symbol Libraries 

using the Explorer Tree in the More Symbols Dialog. 
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Clicking on the name of a folder, or the plus sign beside it, opens that folder.  

Clicking it a second time closes the folder.  

To open a symbol library, double click it or click once on it, and then click the Open 

Library button at the bottom of the dialog box. 

Opening Symbol Libraries  
   SmartDraw Symbol Libraries appear as red, gray, and white icons within the 

folders of the Explorer Tree, at the left side of the More Symbols dialog box. 

When you click on a library, its contents are displayed in the right side of the More 

Symbols dialog box. 

 
When you find the desired symbol library in the Explorer tree, you can open it by 

double clicking it, or clicking the Open Library button at the bottom of the dialog 

box. 
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The open library will appear in the Library Tab and the SmartPanel Tab (if there is a 

Symbol Library Gallery) of the Left Panel. 

Explorer Favorites 
The Symbol Explorer Tree appears s in the left column of the More Symbols dialog 

box. At the top of the symbol Explorer tree is a folder called My Favorites.  

 

 

You can drag Symbol Libraries from other sections of the Explorer tree into Favorites 

to have them readily available. 

Your Favorites folder contains a short cut to any library you add to it. It does not 

create a copy of the library or move it from its original location.  You can delete 

library short cuts from Favorites without deleting the libraries themselves. 

You can create your own sub-categories inside Favorites by right-clicking on the 

folder. You can also drag icons (and sub-folders) from one Favorites sub-folder to 

another.  

Your Favorites folder is stored in your personal preferences and is not shared with 

any other user on a network installation. 
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Symbol Explorer Right Mouse Button Menus 
 In the More Symbols dialog box, right-clicking on the symbol library icons in the 

Explorer Tree displays a context-sensitive menu (one that depends on the location 

of the icon clicked-on). 

Normal Symbol Library Icons 

Right clicking on a library icon lets you open it, add it to your favorites, or display a 

Preview that stays up until you click somewhere else. 

Favorite Library Icons 

Right-clicking on a library icon in the My Favorites folder lets you open it, remove it 

from your favorites, or display a Preview that stays up until you click somewhere else. 

The Favorites Folder 

Right clicking on the Favorites folder lets you clear all favorites. 

Favorites Sub-Folders 

Right clicking on a Favorites sub-folder lets you create your own sub-folder within it. If 

the sub-folder is one you created, you can also delete it and rename it. 

SmartDraw Explorer 

Right-clicking on the SmartDraw Explorer folder at the top of the tree offers you more 

information about it. 

Refreshing the Symbol Explorer Tree 
In the left column of the More Symbols dialog box, closing the SmartDraw Explorer 

folder at the top of the Symbol Explorer tree and then re-opening it causes the tree 

structure to be rebuilt.  

You need not do this unless you think some installed libraries are failing to appear in 

the tree.  Your next search will rebuild the word index. 

Sometimes installing new Symbol Libraries will cause the Explorer tree to refresh itself 

automatically. 
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Library Previews and On-Demand Installation  
Your Symbol Explorer Tree (in the More Symbols dialog box) may contain Previews of 

some Symbol Libraries that are not yet installed.  

These previews provide the benefits of having SmartDraw’s complete catalog of 

symbol libraries available for searching, while using about 1% of the disk space 

required by the full libraries if completely installed. 

A preview is a small copy of a symbol library file that contains only the preview 

image (the small thumbnail image you see when you browse through the Explorer 

tree). Previews let you browse and search the library catalog as if it were completely 

installed on your system.  Previews are shown in the tree with white instead of red 

icons. 

  

 

When you attempt to open a symbol library preview, the library will automatically 

begin downloading from the web. 

You must have access to FTP to install libraries from the SmartDraw web site. Inside 

some corporations, this service is blocked. Talk to your network administrator if you 

have difficulties. 
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Licensed and Unlicensed Content  
All of the SmartDraw library symbols and drawing templates (collectively called 

content) available to you in your purchased SmartDraw program will be licensed to 

you, and you will have full use of them. If you installed previews of some content in 

your Symbol Libraries for which you do not have a license, you will get a license error 

warning if you try to open them.  You can license such content by upgrading to a 

higher version of SmartDraw.  
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Drawing with SmartDraw 

Selecting a SmartTemplate 
SmartTemplates are the ready-made templates that you use to create any type of 

drawing in SmartDraw.   

Each SmartTemplate is designed for one particular type of drawing, and it’s 

important to choose a template that matches the type of drawing you intend to 

create.   

When you create a new document in SmartDraw you’ll see the Document Browser 

screen. 

 

 

Choosing a Template from the Document Browser 
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Choose a SmartTemplate by clicking on the image of the one you want to open. 

If none of the templates exactly match the kind of drawing you want to create, pick 

the one most similar.  

Each template (even the blank ones) has special settings for grid snaps, line-linking, 

and other crucial attributes that make it easy to draw a particular type of diagram 

— or very difficult if you choose the wrong type of template. 

Browsing the Template Categories 

At the left side of the Document Browser is the Category List. You can expand each 

category by clicking on its name, to display its subcategories. 

 

 
Template Categories 

 

In the preview area in the center of the Document Browser you see the template 

Previews: small images of the templates that you can browse through.  
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The thumbnail images are divided into subcategories, one above another.  You can 

view the thumbnail subcategories by scrolling down the thumbnail list. 

SmartTemplates vs. Examples 

Some of these thumbnail images represent true SmartTemplates, which are starting 

points for making drawings. 

Others are Examples, which are educational illustrations of finished diagrams.   

You can open and modify the examples exactly as if they were drawings you 

created. You may find that some examples are similar enough to the drawings you 

want to make that you can use them as starting points. 

See also Creating Custom SmartTemplates. 

See also Searching for SmartTemplates 

See also SmartTemplate Favorites 
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Searching for SmartTemplates 
You can search for SmartTemplates and Examples (which we will collectively call 

templates ) using the Template Search Box at the top of the Document Brower. 

Typing a word into this box and clicking on the Search button (or pressing Enter) 

searches all of your templates for those that match that keyword. 

 

 
The Template Search Bar 

In addition to searching the words in the templates’ names, SmartDraw also 

searches through keywords associated with each template.  

You can enter more than one word into the Search Box, separated by spaces or 

commas. SmartDraw finds matches for templates that contain all of the words that 

you specify. (In Boolean terms, the search is an AND search). If you want to make it 

an OR search, you can type Keyword OR Keyword, and SmartDraw will find any of 

the keywords that you type.  

The search is not case-sensitive. (It doesn’t matter if the words are in capital letters). 

Partial matches are found as long as the word begins with the search word. For 

example, if you searched for Form, matches would be found for Forms and Formula 

but not Perform. 

The search results appear in the Search Results folder near the top of the template 

category list. The results of your last search will be available there until you conduct 

a new search. 

SmartTemplate Favorites 
If you right click on a SmartTemplate or Example (which we will collectively call 

templates) in the Document Browser, you can add it to My Favorites, which appears 

near the top of the category list. 
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The Favorites category contains short cuts to the actual templates. The original 

templates still reside in their original locations, and removing them from Favorites 

does not delete the actual templates. 

You can remove a template from My Favorites by right clicking on its name in the 

My Favorites folder, and selecting Remove from Favorites.  Choosing Clear Favorites 

will remove all templates from the favorites category. 

 

SmartTemplate Previews and On-Demand Installation 
Some of the SmartTemplates and Examples (which we will collectively call 

templates) shown in the Document Browser may be Previews of templates that are 

not yet installed.  

These previews provide the benefits of having SmartDraw’s complete catalog of 

templates available for browsing, while using a tiny fraction of the disk space 

required to install all of the actual templates. 

The preview thumbnail image looks identical to an installed template thumbnail.  But 

when you try to open a preview, the template will automatically install the actual 

template from the web. 

You must have access to FTP to install templates from the SmartDraw web site. Inside 

some corporations, this service is blocked. Talk to your network administrator if you 

have difficulties. 
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Adding Objects to Your Drawing  
A SmartDraw drawing is made up of shapes, lines, and sometimes ready-made 

graphic symbols like clip art. All of these are called Objects. 

You can always add shapes and lines to your drawing by using the buttons on the 

Home Tab.  

 
The Line and Shape buttons on the Home Tab 

With some drawing types you will find specialized buttons for adding shapes and 

lines on the custom SmartPanel for that drawing, found at the left site of the 

SmartDraw Program Window.  Details of using each SmartPanel are presented in the 

SmartHelp panel displayed at the right side of the screen as you draw. 

Adding Symbols 

You add Symbols to your drawing by taking them from the Symbol Libraries in the 

SmartPanel or Library Tabs of the Left Panel. 

 
A Symbol Library in the Left Panel 

 

There are two ways to add library symbols to your drawing: 

1. Click and Stamp 

To stamp an object from a symbol library on your page: click once on the symbol 

icon in the library window, and then click in the page where you want to place it. 

When you click on a symbol in the library, your cursor looks like an old-fashioned 

rubber stamp, and it carries a rectangle indicating the outline of the object as you 
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move it over the drawing area.  When it is in the desired position, click once to 

place it there. 

 
Ready to stamp a Symbol 

2. Drag and Drop 

To drag and drop a symbol from a library: click a symbol icon in the library window, 

hold the mouse button down, drag it to the Drawing Area, and release.   

 

 
Drag and drop a symbol 

 

Drawing Lines  

 You draw lines using the Line Tool in the Tools group of the Home tab.  To select 

the type of line, click the down arrow and choose from the menu. 
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A SmartPanel Line Button 

For some drawing types, a customized Add Lines button appears on the custom 

SmartPanel at the left side of the SmartDraw Program Window, and provides a 

shortcut to this function.  Based on the drawing type, this button may have different 

default settings so that you can draw lines typical to that type of drawing 

To draw a line, click on the line tool. Your cursor becomes a pencil.  Click down in 

the drawing area, drag the mouse to draw the line, and release.  After drawing the 

line, you can use the black selections handles on it to adjust its shape. 

The Line Tool contains seven types of lines: 

 

Straight Line 

 A Straight Line can be drawn at any angle, but it will snap to perfectly horizontal 

or vertical directions if drawn close to these directions.   If you want a line just a few 

degrees off from horizontal or vertical, you can use the Rotate command on the 

Arrange group to specify its angle precisely. (Note: lines snap to the Grid just as 

shapes do.  For more information see Using Grid Snaps.) 

 

Curved Line 

 A Curved Line connects any two points with an arc of a circle. After drawing the 

curved line, the degree of curvature can be adjusted using the special handle at its 

center, and its endpoints can be positioned using the handles there. 

 
Adjusting the curvature of a Curved Line 

Shape Connector Line 

  The Shape Connector  is designed to connect two objects. It attaches itself 

perpendicularly to each object and travels from point A to point B in straight 
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segments with 90-degree turns. (Don’t worry if it flops around while you’re drawing it. 

When you finally anchor it, it will fall neatly into place.)  

 
A Shape Connector Line connecting two shapes 

For the segmented line to attach properly, you must have Allow Lines to Link turned 

on in the SmartDraw Options under the SmartDraw Button. 

Moving the attached objects causes the segmented line to change its shape to 

maintain its position relative to each object. Segmented lines can have from 1 to 5 

segments, depending on the arrangement of the shapes linked. 

Curved Connector Line 

  The Curved Connector Line behaves exactly like the Shape Connector Line, but 

instead of having square corners, it travels from point A to point B in a smooth curve. 

 
 

A Curved Connector Line connecting two shapes 

Freehand Line 

  The Freehand Line draws like a pen on paper.  Click in the drawing area and 

drag the mouse to create a line of any random shape.  See Drawing Freeform 

Shapes and Lines. 

Polygon Line 

  The Polygon Line draws a continuous line made of straight segments.  Each time 

you click in the work area, a new segment is added, until you either close the shape 

by returning to the starting point, or press Esc to stop.  See Drawing Freeform Shapes 

and Lines. 

Wall Line 

  The Wall Line is used to create walls in Floor Plans. 
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Changing the Shape of a Line 
Any existing line on the page can be changed to a different type of line by clicking 

on it to select it, clicking Change Line in the Design tab, and choosing Change Line 

Shape from the menu. 

 
The Change Line Shape menu 

 

In addition to the types mentioned in Drawing Lines, you can change a line shape 

to any of the shapes shown in the menu above. 

Many of these line shapes are also offered in special configurations, such as being 

constrained to vertical or horizontal positions or a fixed number of segments. 

You can also use the Flip command on the Design tab to create additional 

variations. 

(Note: The Shape of a line should not be confused with the appearance or Style of 

the line. See Changing the Appearance of Lines.) 

Line Hops 
Line hops are used in flowcharts and engineering diagrams to indicate lines that 

cross without intersecting. 
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Line hops work only for lines created with the Straight Line, Curved Line, Shape 

Connector and Curved Shape Connector tools on The Work Area Toolbar. (Not for 

Automatic Org Chart connectors or shapes created with the Freehand Drawing 

tools.) 

You can turn line hops on or off for a document by right-clicking on the line to bring 

up the Line Hops dialog. 

 

 
The Line Hops Dialog 

  For some drawing types, a Line Hops button appears on the SmartPanel at the 

left side of the SmartDraw Program Window.  This provides a shortcut to launching 

the Line Hops dialog. 

For line hops to appear, the Line Hops feature must be turned on for the whole 

document (by choosing the Show button in the Line Hops dialog), and for the 

individual line you have clicked on (by checking Show hops where this line crosses 

over other lines.) 

The style (round or square) and size (small, medium, or large) of the line hops are set 

for the entire document, not for individual hops. 

If the line being hopped over is a double line (from the Line Style menu), or simply 

two single lines drawn close together, the hopping line will make just one hop 

spanning both lines. 
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Line hops rely on the Front-to-Back order to know which one is on top. The line in 

front will have the hop (bend) in it.  If your preferred line does not have the hop, 

you’ll need to bring it to the front by selecting it and choosing Bring to Front from the 

Design tab. See Changing the Front-to-Back Order. 

A line may have no more than 32 hops. If the position of a line hop conflicts with an 

arrowhead, the arrowhead overrules the hop. 

Selecting Objects  
Before you can move, stretch, color, or manipulate an object or piece of text on 

your page, you must select it.  

 The Selection Tool (in the Tools group of the Home tab) is your normal cursor.  To 

select an object on the page, click on it once with the Selection tool.  

Shapes filled with transparent color must be clicked on their border to be selected. 

Shapes filled with a color (even white) can be clicked anywhere in their interiors as 

well. 

A selected object has black Selection Handles at the corners. By dragging these 

handles, you can stretch or resize the object. 

 
Growing an object 

 

A selected object also has a Rotation Handle. By dragging the rotation handle, a 

shape or line can be rotated to any angle. 

    
If several objects are selected, the last one selected has solid (black) handles and is 

called the Target Object. Other selected objects are shown with hollow handles. The 

target object is called the target because, when you use certain commands such 
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as Align and Make Same Size, the other selected objects are aligned or re-sized to 

match it. 

 
Selecting an object by clicking on it de-selects all other selected objects unless you 

hold the Shift or Ctrl key down while you click. With the Shift or Ctrl key held down, 

clicking a second time on any object de-selects it. 

Selecting Text 

You can select text in your drawing in one of two ways: You can click on the object 

(including a background text object) that contains the text, which implicitly selects 

the whole piece of text inside the object for editing.  Or you can double-click on the 

actual text inside any object, which opens the text for editing and places the cursor 

in the clicked position.  In this case, the cursor changes to a typical text-insertion 

cursor, which you can drag to highlight parts of the text for making changes. 

See also Selecting Multiple Objects 

For special instructions on selecting text in Table Cells, see Selecting Table Cells. 

 

Selecting Multiple Objects  
 

There are four ways to select several objects at one time: 

1) Hold the Shift Key down while clicking on each object in turn with the normal 

selection tool  .  

2) Choose the Multiple Selection Tool  in the Select Drop Menu in the Home tab and 

click on a series of objects, one after another, to select them all. Clicking in the 

background of the drawing cancels the Multiple Selection session. 

3) Trace an imaginary box around the group of objects with the mouse.  Click in an 

empty area of the page, hold the mouse button down, and drag the mouse until 

the dotted box encloses the objects you want to select. Then release. All of the 

objects inside the box will be selected. 
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"Boxing" with mouse 

      

 
All objects selected 

Holding the Shift key down while drawing the box adds the enclosed objects to any 

existing selection. 

Boxing (sometimes called rubber-banding) is useful for deleting unwanted objects 

from your page.  Simply trace a box around the area you want to delete, and then 

press the delete key. 

4) Select All - On the Home tab, choose Select, and choose to select (a) all the Lines 

in a drawing, (b) all the Shapes in the drawing, or (c) all the Objects (i.e. everything). 

See also Selecting Objects 

See also Selecting with the Tab Key 

Selecting with the Tab Key 
If no objects in your drawing are selected, pressing the Tab key selects the first one.  

If one or more objects are already selected, pressing the Tab key moves the 

selection from the currently selected object to the next created object in the 

drawing. 
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Selecting the next object with the Tab key 

Pressing Shift-Tab reverses direction and selects the previous object in the drawing. 

Selection Difficulties 

Sometimes, it’s hard to click on the object that you want because other objects lie 

on top (or in front) of it. There are two ways to overcome this: 

You can select the objects on top and use the Send to Back command under the 

Design tab. 

Alternately, you can drag a box around the objects, selecting them all. Shift-clicking 

on the objects in the front now de-selects them, leaving only the object you want 

still selected. 

Once selected, the colors, borders and other attributes of objects can be changed 

using the menu commands. Selected objects can also be cut, copied and 

duplicated. Typing from the keyboard when a shape is selected adds text to it. 

These actions are described in detail elsewhere. 

The Tab order is controlled by the Front to Back Order of the objects.  See Changing 

the Front to Back Order. 

Moving Objects 
Moving Objects with the Mouse 

You can move an object simply by clicking on it and dragging it with the mouse 

while keeping the mouse button pressed down. An outline of the object follows the 

mouse as you move it. 



SmartDraw 2009 User's GuideUser’s Guide Drawing with SmartDraw ••••  64 

 

If you hold the Shift key  down while you use the mouse to move an object, it moves 

only horizontally or vertically. 

Moving a Group of Objects 

If more than one object is selected, clicking and dragging on any one of them 

moves all the selected objects as a group. If an object is linked to another (with 

certain kinds of linking) moving one of the objects will move the other.  

When a Group of objects (that has been created with the Group command) is 

moved, an outline of the rectangle that encloses the group follows the mouse.  

Moving Objects with the Arrow Keys 

You can use the arrow keys to move objects very precisely. Typing an arrow key 

moves a selected object by one screen pixel (1\100 of an inch at normal viewing 

magnification) with each keystroke. The arrows move the objects on-screen 

according to their direction: up, down, right, and left. If more than one object is 

selected, all are moved.  

Aligning Objects 

The Align command on the Design tab aligns all selected objects with the selected 

target object.  See Aligning Objects. 

Spacing Objects Evenly 

The Space Evenly command on the Design tab positions all selected objects to 

have equal distances between them.  See Spacing Objects Evenly. 

Centering the Drawing on the Work Area 

The Center in Work Area command on the Page tab moves all the objects in the 

drawing so that they are centered in the minimum number of pages needed to print 

them. See Centering the Drawing . 

See also The Position and Size Dialog 

Re-Sizing Objects 
Resizing with the Mouse 

To change the size or shape of an object, click on it to select it, and then click on 

one of the grow handles (black squares) and hold the mouse button down. 

Dragging the mouse drags the handle and changes the size of the object. 
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Growing an object by dragging a handle 

Only one object at a time can be resized this way. 

Proportional and Non-Proportional Growth 

Some standard shapes, like rectangles and many of the library symbols, can be 

sized to any proportion. Others, such as the standard circle, maintain their 

proportions when re-sized.  

The side handles on a shape, such as a rectangle, will stretch the object only in the 

direction perpendicular to that side. Handles at the corners stretch the object all 

directions simultaneously.  

Proportional shapes (like circles) have no handles on their sides, and their corner 

handles grow the shape proportionately. 

For shapes that can be stretched to any proportion, such as rectangles, holding 

down the Ctrl key while dragging with the mouse makes a perfectly regular version 

of that shape (for example a square in the case of a rectangle and a circle in the 

case of an oval).  

Holding the Shift Key while resizing forces a shape to grow proportionally.   However, 

for shapes that can normally be sized only proportionally, holding down the Shift Key 

while dragging with the mouse allows them to be sized non-proportionally.  

Some of the standard shapes found in the Standard Shapes Library have a special 

"smart" resizing property by which some key components keep their original 

proportions, even while the rest of the shape is resized. The arrow shape is one 

example: the arrowhead keeps its original shape even when the whole shape is 

elongated. 

 

Some Freeform polygon shapes have additional, special growth and resizing 

properties. See Creating Closed Freeform Shapes for more details. 

Sizing with the Arrow Keys 
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You can use the arrow keys to resize a shape very precisely. Pressing an arrow key, 

while holding down the Shift Key, increases or decreases the size of the object by 

one screen pixel (1\100 of an inch at normal viewing magnification) with each 

keystroke. The right and down arrows increase the size at the right and bottom. The 

left and up arrows decrease the size at the right and bottom. 

If you have selected more than one object, the resizing affects all of them. 

Make Same Size 

The Make Same command on the Design tab can be used to make all selected 

objects the same size as the selected target object. See Making Objects the Same 

Size. 

Resizing Grouped Objects 

Objects may be combined into Groups. When grouped they may be sized 

proportionately as a single object. See Grouping and Ungrouping Objects. 

See also The Position and Size Dialog 

The Shape Properties Dialog  
The Shape Properties Dialog allows you to change the resizing, linking, and many 

other behaviors of a shape.   

To open the Shape Properties Dialog for a selected shape by clicking Shape Outline 

on the Design tab. 
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Shape Properties Dialog 

 

The properties you set in this dialog affect only the selected shape on the page, not 

the master copy of the shape on the toolbar or in a symbol library. 

There are four choices of sizing behavior: 

1. Proportionally- The object has four growth handles (one at each corner) and 

maintains its proportions when re-sized. Imported images (and many library symbols) 

are initially set to resize proportionally. 

2. Horizontally Only- The object has only two growth handles and can be resized 

only in the horizontal direction.  

3. Vertically Only - The object has only two growth handles and can be resized only 

in the vertical direction.  

4. No restrictions - The object can grow in all directions without maintaining 

proportions. These objects have eight growth handles, four on the corners and four 

on the sides. 
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If the shape is a Freeform polygon, checking the box labeled Allow sides to be 

independently adjusted causes dimension labels to appear on all sides of the shape. 

Otherwise, the dimensions shown are those of the invisible rectangle that encloses a 

shape. 

Show Dimensions allows you to add automatic Length Labels to the sides of the 

shape, which change dynamically to display the current length in the units 

displayed on the rulers. You can choose whether the shape will show its dimensions 

Always, Never, or Only When Selected. 

Show Area displays the calculated area of a shape, in its center, in the units of the 

rulers. This command only works for the 24 native toolbar shapes and for polygons 

created with the Freeform drawing tools. 

Allow Shapes to Link to Borders allows you to position a shape so that it attaches to 

another shape’s border, via its attachment point (usually in the center). 

Allow Shape to Link to Cells in Tables permits the shape to be positioned on a table 

cell, where it will attach and "stick". See Shape-Linking in Tables. 

The Do not check spelling check box turns off (or on) spelling correction for the text 

inside this particular shape. This is useful if you want to keep spelling correction 

turned on for your drawing in general, but want it off for a particular shape that 

contains a proper name or some other unusual text. When you group objects, 

spelling correction is turned off for text inside the group. You can turn it back on 

again with this setting. 

Print as Transparent will make the selected shape transparent when you print your 

drawing. 

When an image is dragged onto a shape, Allow Image Drop permits the image to 

be dropped into the shape to make one object. 

The Position and Size Dialog 
You can specify the exact size and position of an object using the Position and Size 

Dialog. The values are in the same coordinate system as the rulers.  

You can open this dialog by (a) selecting an object and then clicking the Position 

and Size Dialog Launcher (  ) on the Design tab, or (b) right-clicking on the object 

and selecting Position and Size from the menu. 
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The Position and Size Dialog 

 

You can specify the coordinates of the left, top, right, and bottom of the object in 

the units shown.  

Changing the left and top values also changes the right and bottom, shifting them 

to maintain the same width and height. 

The two radio buttons control whether changing the object's bottom or right value 

changes the object’s size (by leaving the left and top unchanged) or changes the 

object’s position (by changing the left and top to maintain the dimensions). 

The position dialog for a line, unlike that for shapes, allows you to enter the length of 

the line. 

Also, to help you position objects, the Status Bar in the lower-right corner of the 

document window displays the coordinates of the cursor and the dimensions of any 

currently selected object. 

Rotating Objects 
Shapes, symbols, text, straight lines, and curved lines can be rotated to any angle.   

You can do this manually by dragging the rotation handle (which looks like a small 

circle) on a selected object. The cursor changes to the "rotation" shape when 

positioned over a rotation handle. 

 
A Rotation Handle 
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Click on the rotation handle and drag with mouse.  The shape rotates around its 

center point. 

 
Rotating a Shape 

When the Snap to Grid feature is turned on, the angle of rotation snaps in 

increments of 15 degrees (15, 30, 45 and so on.).  

The Rotate Command 

You can also rotate objects using the Rotate command on the Design tab.  

Choose one of the standard options, or pick Custom to bring up the Set Rotation 

Angle Dialog. 

 

 
Set Rotation Angle Dialog 

 

Rotating Multiple Objects 

The rotation command will affect all selected objects. This allows you to rotate a 

group of objects all at once.  

When you have selected several objects, the angle shown by default in the Set 

Rotation Angle dialog is the one associated with the last object selected (known as 

the Target Object), if that object has already been rotated.  

This allows you to align the any number of objects to match the angle of another 

object. While holding the Shift key down, select the objects that you wish to align, 

selecting the Target Object last. Then choose Rotate from the Design tab, then 
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Custom. The default angle shown will match the rotation of the Target Object, and 

clicking OK will rotate the other objects to match it. 

You can rotate straight or curved lines, shapes, library symbols, and most imported 

images. You cannot rotate the Shape Connecting (segmented) Lines, bitmap 

images, and the Automatic Connector Lines used in Org Charts. 

Objects linked to others do not rotate. (Since they cannot maintain their link if they 

do.) However, you can rotate a shape or line before you link it to another. Objects 

that cannot rotate do not have a rotation handle. 

When an object is rotated, the text associated with it rotates too. 

 

 
Rotated Shapes with Text 

Flipping Objects 
All objects, except bitmap images, can be flipped horizontally or vertically. 

Horizontal flipping reverses an object as if it were reflected in a mirror next to it. 

 
Horizontal Flipping 
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Vertical flipping reverses an object as if it were reflected in a mirror above or below 

it. 

 
Vertical Flipping 

 

Text you have entered into the object is unaffected by flipping. 

You can use Flipping to generate additional line shapes from those available on the 

Change Connector Shape and Change Line Shape menus. 

 

 
Changing a Connector Shape with the Flip Command 

Deleting Objects 
Delete objects from the page by selecting them and then typing either the Delete 

key, or the Backspace key.  

See also Selecting Objects 

See also Selecting Multiple Objects 

Duplicating Objects 
The Duplicate command under the Paste button in the Home tab makes a copy of 

the selected object and adds it to the page, offset by a small distance from the 

original object. 
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Duplicating Two Selected Objects at Once 

The duplicate object (or objects) appears on the page in its selected state.  If you 

immediately click on the new object and move it, without deselecting it first, the 

new distance between it and the original is used as the default offset for any further 

duplications.  You can use this feature to create neat rows and columns of evenly 

spaced objects. 

The illustration below shows the steps involved in making a column of evenly spaced 

lines. 
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Changing the Appearance of a 
Drawing  

Changing the Appearance of Shapes 
Shapes are closed polygon objects with lines around their borders and a fill-able 

area inside.  

The Standard Shapes available from the Shape Tool on the Home tab and closed 

shapes drawn with the Polygon Line and Freehand Line tools on the Drawing Area 

Toolbar, are all considered Shapes. 

The Home tab contains commands to change the fill color, fill texture, and border 

style of selected shapes on the page. 

The Fill Command 

The Fill command changes the fill color or texture inside a selected shape. This fill will 

then become the default for any new shape added to the page. Imported digital 

images and library symbols that are not re-colorable are not affected by fill color.  
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The Fill Menu 

  The fill color can be transparent, which means that the background of the 

drawing shows through the shape. (Note: To select a shape with a transparent fill 

you must click on its border.) 

  You can also pick from any of the 16 million colors supported by Windows using 

the More Fill Colors command on the Fill menu.  

  The Gradient Fill creates a fill color that grades smoothly from one color to 

another.  If you want to create a custom gradient fill, see Defining Your Own 

Gradient Fills. 

  A Fill Texture can be a pattern or image such as a photograph.  In addition to 

the ready-made textures found under the menu, you can import any image of your 

own to create a custom texture, using Add Texture in the Select a Texture dialog 

box. See Changing Texture Properties. 
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  Hatch patterns fill a shape will a pattern of monochrome lines or dots.  The color 

of the hatch matches the shape border color and is set by the Line command on 

the Design tab. See Changing the Appearance of Shape Borders. 

Quick Styles 

  You can quickly change the fill and other properties of a shape all at once by 

choosing one of the ready-made Quick Styles shown in the left part of the Design 

tab. 

Changing the Appearance of Shape Borders 
Shapes have a border around their edge.  The color and style of the border are set 

using the Line command on the Design tab. 

The border can be filled with color or texture just like a shape.  Its style may be 

dotted, dashed, or solid, double-lined, in a choice of several different thicknesses. 

When the thickness is changed the borders grow towards the center of the shape. 

Shapes may have no border (None). These shapes must have a different fill color 

from the background or they will not be visible. 

Border Fills 

The fill color and texture of a border behave just like the fill of a shape but they 

apply to the inside of the shape border itself.  See Changing the Appearance of 

Shapes for a description of fill properties. 

Border Thickness 

The Thickness menu appears under the Line button in the Shape Styles group of the 

Home tab and it changes the border thickness of a selected shape. 

 
The Thickness Menu 

Dashed Borders 
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The Dashes menu appears under the Line button on theShape Styles group of the 

Home tab. 

You can choose a variety of dashed line styles for a shape border.  The double-line 

style is also found on this menu. 

 
The Dashes Menu 

 

Changing Texture Properties 
The Properties and Edit commands in the Select a Texture Dialog box allow you to 

modify new and existing textures.  To find this dialog box, on the Home tab click Fill, 

then Texture, then More Textures. 

The Properties button allows you to permanently change the default settings for the 

selected texture.  The Edit button only changes the properties of the current 

selected object leaving the default texture settings available. 

Using the Properties or Edit button brings up the Set Texture Application Parameters 

dialog box. 
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Texture Dialog 

Scale 

You can scale a texture two ways: 1) Size the texture to a percentage of its normal 

size, or 2) Scale the width of the texture to an exact size in the units of the rulers. 

You can adjust the scale percentage between 25% and 400%. 

In a floor plan with the default 1\4-inch scale (where 4 ft equals one inch on the 

screen), setting the scale of the texture to be 1 foot across would give you 4 tiles 

representing 4 feet on the screen.  The word ‘tile’ here does not refer to floor tile, but 

to the square of texture shown in the dialog. 

Alignment 

By default, a texture will align with the top left of the page. You can change the 

texture alignment to begin at the: Top Left, Top Center, Top Right, Center Left, 

Center, Center Right, Bottom Left, Bottom Center, or Bottom Right of either the page 

or the shape the texture fills. 
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The built-in textures will repeat in a seamless continuous pattern.  Any textures you 

create or import may show discontinuities at the edges of the tiles unless you design 

them specifically to tile together seamlessly. 

 

Change Shape 
The actual shape of a selected shape on the page object can be changed to any 

of the other 24 standard shapes, using the Change Shape menu found under 

Change Shape on the Design tab.  

 
Change Shape Menu 

Any selected shapes are converted to the shape chosen from this menu. The 

command has no effect on library symbols or images. 

As a shortcut to this command, you can quickly change one shape to another by 

right-clicking on the shape and choosing Change Shape from the right-click menu. 

Adjusting Shapes 
Many of the standard shapes available from the Drawing Area Toolbar have 

properties that can be can be adjusted.  

For example, you can adjust the degree of roundness of rounded rectangles, or the 

angle between the vertical and horizontal sides of a parallelogram. 

These shapes have a special hollow, diamond-shaped Adjustment Handles when 

selected. 
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Adjusting a Shape 

To adjust one of these shapes, click and drag on the diamond-shaped handle.  A 

dotted outline shows the effect of your change. When you release the mouse 

button, the shape changes its outline to match the dotted image. 

Editing Shape Outlines 
Shapes can be completely decomposed into their component lines and curves and 

then modified using the Edit Shape Outline command under Change Shape on the 

Design tab. 

 You can stretch or bend the lines and curves of the shape and then rejoin it to 

create a new custom shape. See Editing the Outline of Shapes in the freehand 

drawing section. 

 
Editing the Outline of a Shape 

Changing the Appearance of Lines 
The Lines command on the Shape Styles group of the Home tab controls the 

appearance of lines on your page.   

A line can be filled with color or texture just like a shape.  Its style may be dotted, 

dashed, or solid, double-lined, in a choice of several different thicknesses.  

 
A Line filled with a colored hatch pattern 

Line Fills 

The fill color and texture of a line behave just like the fill of a shape.  See Changing 

the Appearance of Shapes for a description of fill properties. 

Line Thickness 
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The Thickness menu appears under the Line button in the Shape Styles group of the 

Home tab. 

 

 
Thickness Menu 

Dashed Lines 

The Dashes menu appears under the Line button in the Shape Styles group of the 

Home tab.  The double-line style is also found on this menu. 

 
The Dashes Menu 

 

Arrowheads  

You can add arrowheads to either or both ends of any line. The standard 

arrowheads are always at your fingertips on the Drawing Area Toolbar, and there 

are 35 specialized arrowhead styles if you need more options  

 To add arrowheads to a selected line, click the Arrowheads Tool on the Home tab 

and choose a position (left, right or both) from the menu.  
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Custom Arrowheads 

The Custom command on the Arrowheads menu opens the Arrowheads Dialog, 

where you can choose from 35 different styles.  You can also set the arrowhead Size 

and Displacement with this function. For details see Custom Arrowheads. 

See also Changing the Shape of a Line 

Custom Arrowheads  
The Custom arrowheads command appears on the Arrowheads menu, found under 

Arrowheads on the Home tab.  

Here you can choose from 35 different styles and apply them to either end of a 

selected line.  You can also set the arrowhead Size and Displacement. 

 
The Arrowheads Dialog 

Left (Top) 

Clicking on one of the 36 style buttons changes the type of arrowhead that will 

appear on the left end (or top end if vertical) of the lines currently selected. A 

preview appears in the preview window. The None selection results in no arrowhead 

at the left end. 

Right (Bottom) 

Clicking on one of the 36 style buttons changes the type of arrowhead that will 

appear on the right end (or bottom end if vertical) of the lines currently selected. A 
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preview appears in the preview window. The None selection results in no arrowhead 

at the right end. 

Displacement 

You can specify whether the line touches a shape or falls a little short. If the line is 

displaced, it does not appear to touch the shape but still remains linked to it. This 

property can be controlled independently for each end of a line, and does not 

apply to ends with no arrowhead. 

Size 

Clicking one of the three size buttons sets the size of the arrows on both ends of the 

line. 

Arrowheads in the Center of Lines 

Three of the arrowhead styles place an arrowhead at the center of the line instead 

of at the end. 

 
Centered Arrowheads 

Lines with Different Arrowhead Settings 

If you have several lines selected, and their arrowheads have different properties, 

the arrowhead dialog will show no existing setting for those properties. For example, 

if two lines have different right arrows, no right-arrow buttons will appear to be 

highlighted when the dialog is displayed. If you leave the style buttons un-pushed, 

but you push one of the size buttons, then, when you press the OK button, both 

arrowheads will change size but they will retain their unique right arrow styles. 

Once assigned, an arrowhead remains fixed on the end to which it was assigned, 

despite any later changes in the line’s direction. 

Dimensioning: Showing Line Length 
You can add an automatic Length Label to any line, and it will change dynamically 

to display the current length in the units of the rulers. 
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To show the dimensions of a selected line, choose Show Dimensions from either the 

Change Line or Change Shape menu on the Design tab.  

This brings up the Show Dimensions dialog. 

 
The Show Dimensions Dialog 

You can specify whether the line will show its dimension Always, Never, or Only 

When Selected. 

The Show options are defined as follows: 

1. The distance between the end points of a line means the shortest straight distance 

between the two endpoints, regardless of the actual path of the line.  For example, 

if the line is an Arc, or a segmented line, the actual path of the line will usually be 

longer than the straight distance between its end points. 

2. The total length of the line is the sum of all its segments along its actual path.   (The 

exception to this is the Shape Connector Line, which shows the length of its 

horizontal segment, so that it can easily be used as a call-out length marker.) 

3. The length of each line segment labels each segment with its own separate 

dimension label. 

The length label appears just above the line. For curved or segmented lines, if the 

end points setting is used, the label is shown along an imaginary straight line 

between the end points. 

See also Shape Dimensions and Area under The Shape Properties Dialog.  

Changing the Background  
The Background command on the Page tab sets the background of the entire 

document. The background can be a color, texture, or gradient, just like the fill color 
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of a shape.  See  Changing the Appearance of Shapes for a description of the Fill 

menu, which behaves identically. 

Images exported from a document with a transparent background have 

transparent backgrounds themselves, and they acquire the background color of 

the document that receives them (whether in SmartDraw or another program.) 

Drawings with white, or other colored or textured, backgrounds export images that 

have opaque backgrounds, no matter where they are displayed. 

The background color is also affected when you choose a Theme on the Home tab. 

Using the Format Painter 
  You can copy the appearance of a shape or line and transfer it to another 

object using the Format Painter tool on Home tab.  

First select the shape or line that you want to copy the format from. Then click 

Format Painter on the Home tab. Then click the object you want to apply the format 

to. It will change its appearance to match the object you originally selected and 

the Format Painter button will become deselected. 

 
Using the Format Painter 

You can change the appearance of several objects, one after another, if you hold 

the Shift key down when you first click on the Format Painter button. This makes the 

button stay selected as you click on several objects one at a time.  

You can also apply the same appearance to several objects at the same time by 

tracing a selection box around them with the mouse while the Format Painter button 

is selected.  

The format painter transfers the color, border, pattern, and text settings from one 

shape to another. With lines, it also copies the arrowhead style.  

The format painter also works with background text objects and in tables. 
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Design Effects  

  The Effects command on the on the Home Tab allows you to apply stylistic 

effects to a selected object on your page. 

 
The Glow Effect 

Effects include: 

Shadow 

Reflection 

Glow 

Bevel 

Gloss 

Some effects can be applied in combination (for example an object can have 

Gloss and Shadow), but others are mutually exclusive (for example, you cannot 

have a Reflection and a Shadow at the same time.) 

Effect Defaults 

Applying an Effect to an object sets a new default Effect style for future objects 

added to the drawing.  This will remain the default, appearing on each new object, 

until you change or remove it from an object to establish a new default. 

 

Themes  

 
The Theme group on the Home tab allows you to apply a coordinated, professional-

looking visual style to your entire document all at once.  
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A Theme specifies the colors and textures of the background, shapes, borders, lines, 

text, and shadows in the document. 

 

 
The Theme Gallery 

 

Clicking the lowest arrow on the right side of the Theme group on the Home tab 

displays the Theme gallery. To select a Theme, click on its thumbnail icon in the 

Theme gallery.  You can also click on one of the three thumbnails displayed in the 

group. 

See also Overriding Themes for Specific Objects 

Overriding Themes for Specific Objects 
After applying a Theme to your entire drawing, all the objects will match that 

Theme. 

However, you can override the Theme for any particular object in the drawing by 

selecting it and using the commands on the Home tab to change its appearance. 

Once you override the Theme for an object, that object remains overridden in that 

document.  Furthermore, it sets the default for new objects added to the document. 

They will display your override style rather than the default Theme style. 
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For example, a box may be blue in the current Theme, but if you fill it with red, any 

future shapes added to this drawing will be red, until you change the default again. 

You can force all of the objects, even overridden ones, in the document to revert to 

the original Theme by temporarily switching to a different Theme, then switching 

back to your desired one.  This resets all the objects to that Theme. 

Working with Text 

Creating Text  
You can create text: 

In the standard Shapes that are available from the Shape button on the Home tab. 

Inside or adjacent to most library symbols. 

Inside Table cells. 

As Background Text Objects, freestanding pieces of text that you can drag and 

position where you want. 

  The basic way to create text is to use the Text Tool on the Home tab. 

Entering Text in Shapes 

Shapes are made to contain text and carry it with them when the shape is moved. 

A shape can be opened for text entry by: 

Selecting (clicking on) it and starting to type. 

Double clicking on the text area inside the shape. 

Pressing the text button (A) on the toolbar and clicking once on the shape.  

After entering the text, click in the page background to finish. 
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Entering Text in Library Symbols 

Many Library Symbols can contain text.  Some hold the text inside the symbol, and 

others position it outside, (above, below, beside) the symbol by default. For more 

information see Changing the Settings for a Symbol. 

Background Text  

You create Background Text Objects by clicking the Text Tool then clicking in an 

empty part of the drawing background and typing.  After typing the text, click in an 

empty part of the drawing background to finish.  The text object can then be 

dragged to any position you want.  For details, see Entering Background Text 

Text Editing 

When a shape, symbol, or background text object is opened for text entry or 

editing, the standard Windows insertion point appears. This is a flashing vertical line.  

All of the normal conventions for Windows text editing apply: Dragging with the 

mouse selects text (which is then shown in inverted color). Selected text can be cut, 

deleted or copied. The font, size, style and color of selected text can be changed 

using commands on the Home tab on the Main Toolbar. 

Aligning Text   
Whether text is inside a shape, or freestanding as a text object, you can set its 

alignment with the Alignment command on the Home tab.  

 
Align Text 

Simply choose one of the nine options from that menu. 

Alignment affects both the way text is displayed within the object, and the way the 

object grows when text is added.  Different alignments may be applied to individual 

paragraphs within the same object. 

Changing the alignment of a background text object often has little noticeable 

effect because the text fits inside its (invisible) bounding shape exactly. Changing its 

alignment to right or left has no visible effect when the text is already touching both 

sides of its bounding shape. However, the direction that the background text object 

will grow when text is added is affected. 
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Automatic Text Resizing 
As you add text inside one of the standard Shapes available from the Home tab, the 

text wraps inside it until the shape is full.  Then, as you enter more text, the size of the 

shape grows automatically to accommodate more text. 

 
The way an object grows to accommodate more text is determined by both the 

alignment of the text in the object, and the sizing rules specified for that object in 

the Text Entry Properties dialog box. 

Text Entry Properties 
You can change the text entry properties for a selected object by choosing Text 

Entry on the Design tab. 

This opens the Text Entry Properties dialog box.  
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Text Entry Properties dialog box 

This dialog allows to you to set: 

The way objects grow as you add text 

The gap between the edge of the object and the text it contains 

How to begin text entry by clicking with the mouse. 

Text Sizing Rules  

There are three different ways objects can grow as you add text. 

1. Horizontally and Vertically 

The object grows so as to maintain its proportions. 

 
Horizontal and Vertical Text Sizing 

2. Horizontally 
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This is the default for background text objects and for the text that appears below or 

above image-objects and library symbols. New text is added on the current line. 

New lines occur only when the Enter Key is typed. 

 
Horizontal Text Sizing 

3. Vertically 

This is the default for most shapes.  The width of the object stays constant, and the 

object grows vertically as new lines are added. 

 
Vertical Text Sizing 

Effect of Text Alignment 

As an object grows according to these rules, it maintains a fixed point based on its 

text alignment. If text inside an object is centered, the center of the object remains 

fixed and the object grows outward from the center. An object with left-aligned text 

remains fixed at its left edge and grows on the right. Objects with top-justified text 

grow downward, and so on. 

Allowing Text to Shrink 

You can force the text inside an object to attempt to shrink before it causes the 

object to grow,  by checking Allow Text to Shrink. You can specify the minimum size 

that the text will shrink to before it forces the object to grow. 

Text Margins 

The gap between the edge of the text inside an object and the inside edge of the 

object border is set using the Text Margins control. It is adjustable in increments of 

1\100 of an inch and defaults to 2.  

Text Entry and Mouse Clicks 

The three Allow Text Editing with a... choices allow you to  set whether a single-click 

or a double-click on an object opens it for text editing, or whether it can be opened 

for text editing at all. 



SmartDraw 2009 User's GuideUser’s Guide Working with Text ••••  93 

Most objects require a double-click for text editing. (A single click is used to move 

and select them.) Tables, on the other hand, normally require only a single click to 

begin editing in a given table cell. 

Do not allow text editing prevents anyone from changing the text in an object or a 

cell in a table. It is used extensively in forms to prevent users from accidentally 

changing the field labels while filling in the blank spaces on the form.  

Text Entry and the Enter Key 

Normally, typing the Enter Key inserts a new line into the text you are editing. Opting 

to have the Enter key Tab to the next shape... causes an Enter Key to behave like 

the Tab Key and move you to the next shape in the drawing, or the next cell within a 

table. In this case Shift- Enter moves back, just like Shift-Tab does normally. This can 

be a useful setting for forms. 

To add a new line while in this mode hold the Ctrl Key while you type the Enter Key. 

Defaults 

All of the settings you make in the Text Entry Properties dialog for an object become 

the defaults for newly created objects, with the important exception of the mouse-

clicks setting. 

Entering Background Text  

  When the Text Tool on the Home tab is selected, clicking in the empty 

background of the page starts a text entry session. The text you type creates a new 

object called a Background Text Object.  

This is a rectangle shape with an invisible border and a transparent fill. The text 

resides in this invisible object. 

Background text objects behave like other rectangular shapes. You can select them 

for editing by clicking on them. You can drag them from place to place, or change 

their properties (fill color, border color, font, etc.) using the commands on the Main 

Toolbar.  

Unique Properties of Text Objects 

Text objects do have some properties that differ from normal objects. They align with 

the Grid Snaps along the baseline of the first line of text, not their center or top-left 

corner like other objects.  
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Text Objects are automatically removed from the drawing if all their text contents 

are deleted, so that your drawing does not become littered with invisible empty text 

objects. 

Text Entry and the Tab Key 
If you are entering text into an object, typing the Tab key selects the next object in 

the drawing according to the tab order and opens it for text editing. Shift-Tab does 

the same in the reverse order. 

You can use this feature to enter text in your objects the way you would fill in a form: 

Double-click on the first object and enter text. Then tab to the next object, enter 

text, tab again and so on. 

If you are entering text in a table, the Tab key moves you to the next text entry field 

in the table. Once you reach the last table field, a tab takes you to the next object.  

You can enter a tab character into an object by typing Ctrl-alt-tab. 

See also: The Tab Order in Changing the Front-to-Back Order. 

Attaching Text to Lines  
You can attach text directly to lines, and it remains attached when you move the 

line.  

Simply select a line and begin typing. A Background Text Object will be created 

and attached to the line, typically in the center. 

You can set the orientation of the text by choosing Direction on the Home tab. 

 
Text attached to a line 

 

To change the position of the text on the line, use the Text Alignment commands on 

the Home tab.  
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Text Alignment and Lines 

 

You can change the alignment while either the line, or the text, is selected. 

By default, text lying centered on the line has an opaque background that hides the 

line underneath. When text is added below or above the line, the text is given a 

transparent background so that the line shows through.  

You can show the line through the text by selecting the text object itself and 

changing its fill color to transparent, using the Fill button on the Home tab.  

Setting the Text Position for Imported Objects 

Similarly to lines, imported objects can have text attached to them, and it can be 

placed in various positions.  You use the Text Alignment command to position it, the 

same way you do for lines.  You simply select the object and choose one of the Text 

Alignment options on the Home tab.  

See also: Dimensioning: Showing Line Length 

Changing Text Fonts, Size and Style 
You can change the font, size and style of selected text using commands on the 

Home tab. 

 
The Font Group 

Any time you change the text properties, it sets a new default for future text added 

to this drawing. 

Font 

 This shows a list of all True Type fonts in the system. If none is 

highlighted, the range of text or objects selected has more than one font. Leaving 

this list un-selected will result in no change to the font. 

Size 
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 This shows a list of sizes for the selected font. If the size you want is not listed 

you may type it in the size field. If no size is highlighted, the range of text or objects 

selected has more than one size. Leaving this list un-highlighted will result in no 

change to the size. 

Style  

 The commands for Bold, Italic, and Underline change the selected text to 

that style. 

Superscript\Subscript 

  Clicking one of these commands changes the selected text to a superscript or 

subscript. 

 If you prefer, you can also change the text properties using the old-fashioned 

Font dialog box, by clicking the down-arrow on the Font group titlebar to reveal 

more commands. 

See also The Global Default Font. 

Changing Text Color 
  You can change the color of selected text using the Text Color command button 

on the Text tab. 
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The Text Color Menu 

You can also use a Texture or a Gradient as your text color, by choosing one of 

those options from the Text Color menu. 

The Global Default Font 
Under certain conditions, when you change the font of a piece of text, you establish 

a new Global Default Font, which is stored in your personal settings.  This font will 

become the automatic font for new text in your drawing, and it will even replace 

the font of existing text in new templates that you open. 

Setting the Global Default Font 

The global default font is updated any time you select an object, or all of the text in 

a text block that you are editing, and change the font. The new font is stored as 

your new global default font. 

Special rules apply to the size of the default font:   
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1. Your personal font size is only updated when the document font size is set 

between 8 and 14. 

2. Only text and cells with the default font AND a point size between 8 and 14 are 

changed to your personal font size.  Note: A symbol font can never become your 

personal font. 

Object Shrinking Due to Deleting Text 
If an object has been forced to grow from its original size by having text entered in it, 

then it may shrink again when some or all of that text is deleted. 

The object remembers its "real" size (the size it was set to before the text forced it to 

change) so that it can return to it. 

Inserting Text Symbols 
You can insert one of the standard Text Symbols that are available in most Windows 

fonts into any object containing text. 

On the Home tab, click , then choose a symbol from the Insert Symbol dialog box. 

 
The Insert Symbol Dialog 

You select a symbol by clicking on it and pressing OK, or by double-clicking on it.  

If the font drop-down list shows "Normal Text", the typeface of the inserted character 

is the same as the current font. If a specific font is selected, the inserted symbol has 

this font. 

You can add new fonts, or remove them from the list, using the Add Font and 

Remove Font buttons.  
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Special Characters 
SmartDraw supports text entry of the following special characters: 

Tab. You can enter a tab character by typing Ctrl-Alt-Tab. (Normally tabs move you 

from one object to another) 

Hard Space. Typing Ctrl-Space enters a hard space. This joins two words so that they 

cannot be separated by word wrapping. Hard spaces are also not hidden at the 

end of lines when they wrap, like normal spaces are. 

Soft Hyphen. Typing Ctrl-hyphen enters a soft hyphen. This is invisible but allows a 

word to be split there by word wrapping, in which case it shows as a hyphen at the 

end of the line. 

Bulleted Text 
  You can apply bullets to a selected block of text by clicking the Bullets command 

button on the Home tab. 

Choose one of the nine bullet styles from the gallery to apply it to your text. 

 
Bullets can be applied to all the text inside an object at once by selecting the entire 

object, or to individual paragraphs by opening the object for text editing (usually by 

double clicking in it) and selecting just those paragraphs.  

Real-Time Spelling Correction  
SmartDraw can check the spelling of your text as you enter it if Check Spelling While 

You Type is turned on in the Spellcheck menu under the SmartDraw Button. Un-

checking this option turns off real-time checking. On slower computers, turning off 

spelling correction while you type will speed up text editing. 

With spelling checking turned on, any misspelled words are underlined with a wavy 

red line. 
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Misspelled words are underlined with red wavy lines. 

Right clicking on the misspelled word shows a menu with alternative spellings and 

other commands. 

 
Right-clicking on a misspelled word. 

If you select one of the alternative spellings, the word is replaced with this selection. 

The other commands: 

Ignore All. Ignores the word for this session. 

Add. Adds the word to your user dictionary, so that it is considered correct in all 

future sessions. 

Auto Correct. Adds the word to your user dictionary along with the misspelling, so 

that if you use that misspelling again, SmartDraw will correct it for you automatically. 

Spelling. This shows the The Check-Spelling Dialog box. 

The Check-Spelling Dialog 
You can check the spelling of an entire document (or just the selected text or 

objects) interactively using the Check-Spelling Dialog. 
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You can reach this Dialog by clicking the SmartDraw Button, selecting Spellcheck, 

and then clicking on Check Spelling Now. 

When you use this command to check spelling interactively, either the selected 

range of text, or the selected object(s), is checked first. You are then given the 

opportunity to continue to correct spelling in the rest of the document. 

 
The Check-Spelling Dialog box 

The Check Spelling Dialog has the following controls: 

Not in dictionary 

Indicates that a misspelled word was detected. The word is considered misspelled 

because it could not be located in any open dictionaries. You can type the correct 

word in this box and hit Change, or choose one of the suggested words below it. 

Doubled Word 

Identifies a word that appears twice in a row.  To ignore this instance click Ignore, or 

to delete the second occurrence of the word, hit Delete. 

Suggestions 

Contains a list of suggested replacements for the word reported as misspelled. This 

list is filled in automatically when a misspelled word is detected. Subsequent presses 

of the Suggest button may yield more suggestions. A word highlighted in this list will 

be substituted for the misspelled word by clicking the Change button. 

Add Words To  

This specifies which user dictionary words will be added to when you select the Add 

button. The Add Words To list shows all user dictionaries currently open. You can 

open or close other dictionaries via the Dictionaries dialog, which is accessible by 

selecting the Dictionaries button. 

Ignore 
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Causes this occurrence of a misspelled word to be skipped. If the same misspelled 

word appears later, it will be reported. 

Ignore All 

Causes this and all further occurrences of this misspelled word to be skipped. You 

might use this button if the word reported as a misspelling is actually spelled 

correctly. If the word is one you use frequently, you may wish add it to your 

dictionary by selecting the Add button. 

Add 

This adds the reported word to the dictionary that is currently selected in the Add 

Words To list. Use the Add button if a correctly spelled word you use often is reported 

as a misspelling (e.g., your family name). If the word is not used frequently, you may 

want to select the Ignore or Ignore All buttons instead. 

Change 

Causes the reported word to be replaced with the highlighted word in the 

Suggestions box, or a word you have typed in the Not in Dictionary box to replace 

the misspelled word. Only this occurrence of the reported word is replaced. If you 

want this and all following occurrences of the word replaced, select the Change All 

button. 

Change All 

Causes this and all following occurrences of the reported word to be replaced with 

the new word. If you want only this occurrence of the word to be replaced, use the 

Change button. If the reported word is one you frequently misspell, you might 

consider adding it to the dictionary. 

Suggest 

Search more thoroughly for suggested replacements for the current misspelled 

word. Each time you press the Suggest button, a "deeper" search is made. The 

Suggest button is disabled once all possible suggestions have been located. 

Undo 

This cancels the last spelling change made. 

Options 

Opens the Options dialog box, where you can set spelling-checker options. 

Dictionaries... 



SmartDraw 2009 User's GuideUser’s Guide Working with Text ••••  103 

Opens the Dictionaries dialog box, where you can open or close user dictionaries, 

and to edit the contents of user dictionaries. 

Help... 

Opens the SmartDraw user guide with additional information on using the spell 

ccheck feature. 

Cancel 

Stops the current spell-checking operation. 

Selecting a Spelling Language 
You can specify the language used to check your spelling by selecting Spelling 

Language in the Spellcheck menu under the SmartDraw Button. 

By default, American and British English are shown on the submenu. The currently 

selected one is shown with a check mark. The language selection applies to 

SmartDraw as a whole, not just the document that you are working on. If you would 

like to add another language, click More Languages to download it.  SmartDraw 

supports the following languages. 

American English 

British English 

Brazilian Portuguese 

Danish 

Dutch 

Finnish 

French 

German 

Norwegian 

Italian 

Spanish 

Swedish 
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These dictionaries are installed with the SmartDraw CD, or via download from 

http://www.smartdraw.com/dictionaries.htm. 

Dictionary Organization 

The language dictionaries are stored in the Spelling folder inside the SmartDraw 

program folder. Each language has its own folder inside the Spelling folder. All users 

on a network share these dictionaries. 

The custom dictionaries that users edit are stored in a folder inside their Windows 

folder called SmartDraw. Each user on a network has separate personal custom 

dictionaries. 

The Spelling Dictionaries 
Pressing the Dictionaries button in the Check-Spelling dialog, or using the Spelling 

Dictionary command on the Spellcheck submenu of the SmartDraw Button, opens 

the Spelling Dictionaries Dialog. This allows you to manage your own custom 

dictionaries, where your own private words (like your name, special acronyms, etc.) 

are stored. 

 
The Spelling Dictionaries Dialog box 

The Dictionary Dialog has the following controls: 

Words  

This contains the list of words in the currently selected user dictionary, as well as the 

currently selected word. 
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Other Word 

This contains an alternate word associated with the currently selected word. The 

other word is used in the Auto change and Conditionally change actions to supply a 

replacement word. You can enter phrases of more than one word in the Other Word 

box, but the total length should be limited to 63 characters. 

Action 

The action tells the spelling checker what to do when it finds a word in the 

dictionary. The following actions can be selected: 

Auto change (use case of checked word) 

Automatically replace a word with the Other Word as soon as you type it.  For 

example, if you often type recieve instead of receive, you might enter the word 

recieve with receive as the Other Word and set Auto change (use case of checked 

word) as the action. The spelling checker will then automatically correct recieve 

wherever it appears. If recieve were capitalized (Recieve) the spelling checker 

would automatically replace it with Receive. Note that the replacement is made 

automatically only if the Auto Change option is enabled (see the Spelling Options 

Dialog for information on the Auto Change option). 

Auto change (use case of other word) 

Automatically replace a word with the Other Word as soon as you type it, without 

considering the case of the replaced word. This action is useful for automatically 

expanding abbreviations. For example, you could enter the word TBD with to be 

determined as the other word and Auto change (use case of other word) as the 

action. The spelling checker will automatically replace TBD with to be determined 

wherever it appears. 

Conditionally change (use case of checked word) 

This action is the same as Auto change (use case of checked word) above, except 

that the replacement is only suggested by the Check-Spelling dialog. It does not 

happen automatically. 

Conditionally change (use case of other word) 

This is like Auto change (use case of other word) but is only suggested by the Check-

Spelling dialog.  It does not happen automatically. 

Exclude (treat as misspelled) 
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This action tells the spelling checker that the word is misspelled, even if it is listed in 

another dictionary. Words marked with this action will never be offered as 

suggestions for misspelled words, and they will be reported as misspellings when they 

are encountered by the spelling checker. Note that the spelling checker looks up 

words in user dictionaries in the order in which the dictionary files appear in the Files 

list. If you want to exclude a word, make sure it doesn't appear in a previous user 

dictionary. 

Ignore (skip) 

This action tells the spelling checker that the word is spelled correctly, and can be 

skipped over. This is the most common action. 

Add Word 

Adds the word entered in the Words box to the currently selected dictionary. The 

currently selected action and other word are associated with the word. You can use 

the Add Word button to change the action or other word associated with an 

existing word. Note that the Add Word button is enabled only when a word is typed 

in the Words box. The words you add may contain nearly any character, but only 

words that contain embedded periods should have trailing periods (e.g., U.S.A. is 

OK, but USA. is not). 

Delete Word 

This causes the word appearing in the Words box to be removed from the currently 

selected dictionary. The associated Action and Other Word are also removed. 

Files 

This contains the list of open dictionary files. When you select a dictionary file from 

the list, its contents are displayed in the Words list. 

Add File 

This opens a user dictionary file. When you select the Add File button, a dialog 

appears which you can use to select the dictionary file to open. The set of open 

dictionary files is remembered, so once you add a dictionary file you don't need to 

add it again. If you need to create a new user dictionary, use the New button. You 

can open other applications' user dictionary files, including those of Microsoft Office.  

Your Office user dictionary is usually called custom.dic. Search for this file and add it 

to the file list and you can share a common list of your personal words with 

SmartDraw. 

Remove File  
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This closes the currently selected dictionary file. Closed dictionaries are not checked 

during a spelling check. Although the file is closed, it is not deleted. Closed 

dictionary files can be later reopened using the Add File button. 

New File  

This creates a new user dictionary file. When you select the New button, a dialog 

appears which you can use to specify attributes of the new dictionary. 

Export  

This saves the contents of the currently selected dictionary to a text file. When you 

select the Export button, a dialog appears which you can use to select the name of 

the text file to which words in the dictionary will be exported. The words are written 

to the file one per line. 

Import  

This adds the words contained within a text file to the currently selected dictionary. 

When you select the Import button, a dialog appears which you can use to select 

the text file to be imported. Each word in the selected file is loaded into the 

dictionary. 

Language 

This displays the language (e.g., English, or French, etc.) of the words in the currently 

selected dictionary. 

New Dictionary Dialog  

You can use the New Dictionary Dialog to specify the attributes of a new user 

dictionary. 

File Name 

Contains the name of the disk file used to hold the new dictionary's contents. You 

can enter a name here or use the Browse button to display a dialog showing the 

names of other dictionary files. 

Browse 

Displays a dialog, which shows the names of other user dictionary files. You can use 

the dialog to view the names of existing dictionary files, and to enter the name of 

the new dictionary file. 

Language 
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Specifies the language (e.g., French, English) of the words the new user dictionary 

will contain. If the language you want to use is not listed, select "Other. " 

OK 

Closes the New Dictionary Dialog and creates the new dictionary. 

Cancel 

Closes the New Dictionary Dialog without creating a new dictionary. 

Spelling Options  
The Spelling Options command opens the Spelling Options Dialog box. This lets you 

specify several options that affect the way the spelling checker operates. 

 
Spelling Options Dialog 

Ignore Capitalized Words 

When enabled, any words beginning with a capital letter are ignored (i.e., are 

skipped over without being checked). You might enable this option if the text being 

checked contains many proper names. 

Ignore All-Caps Words 

When enabled, any words consisting entirely of capital letters are ignored. You 

might enable this option if the text being checked contains many acronyms. 
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Ignore Words with Numbers 

When enabled, any words containing embedded digits are ignored. Examples of 

such words include Win95 and Q4.  

Ignore Words with Mixed Case 

When enabled, any words containing an unusual mixture of upper- and lower-case 

letters are ignored. Examples of such words include SmartDraw and Caps Lock.  

Ignore Domain Names 

When enabled, any words containing a domain name will be ignored.  You might 

have this checked if the text being checked contains email addresses or websites. 

Report Doubled Words 

When enabled, any word appearing twice in a row is reported via the Check 

Spelling Dialog. 

Case Sensitive 

When enabled, a distinction is made between capitalized and non-capitalized 

words. For example, canada is considered different from Canada, so canada would 

be reported as a misspelling. When the option is disabled, canada and Canada are 

considered identical. Note that the performance of the spelling checker will be 

reduced if this option is disabled. 

Phonetic Suggestions 

When enabled, suggestions are made on the basis of phonetic (sounds-like) 

similarity to the misspelled word. This option tends to improve suggestions for badly 

misspelled words. Enabling this option will increase the time required to locate 

suggestions. Note that either this option or the Typographical Suggestions option 

must be enabled or no suggestions will be offered. 

Typographical Suggestions 

When enabled, suggestions are made on the basis of typographical (looks-like) 

similarity to the misspelled word. This option is appropriate for people who are 

generally good spellers. Note that either this option or the Phonetic Suggestions 

option must be enabled or no suggestions will be offered. 

Suggest Split Word 
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When enabled, two separate words will be suggested as a replacement for a 

misspelling containing two joined words. For example, is the would be suggested as 

a replacement for isthe. 

Auto Correct 

When enabled, words marked with Auto Change actions will automatically be 

changed to their specified replacements. When disabled, you will be prompted 

before the words are changed. 

Suggestions 

Determines the speed and accuracy of the initial search for suggested 

replacements for misspelled words. When a misspelled word is detected, a search is 

automatically made for suggestions. This option controls the speed and accuracy of 

this automatic search. Pressing the Suggest button in the Check-Spelling dialog 

causes an increasingly more accurate (but slower) search for suggestions, with each 

successive click. 

OK 

Closes the Spelling Options Dialog and returns you to your document. 

Help 

Opens the help topic associated with spelling options. 

Cancel 

Closes the Spelling Options Dialog. 

Find and Replace  
As with most text-editing programs, SmartDraw can find any word or string of words 

in your drawing, and if you like, replace it with a different word or words.  

The Find and Replace commands appear on the Page tab. 

 
Clicking either the Find button or the Replace button displays the Find and Replace 

Dialog. 
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Find and Replace Dialog 

You can enter any target string into this dialog. If you press the Find Next button, 

SmartDraw will search for a match. Once a match is found, it is highlighted and 

scrolled into view. Pressing Find Next again finds the next occurrence. 

Initially only the selected range of text is searched. This is either the selected range 

of text within an object, or the selected object(s) or table. Once all selected 

instances of the target word have been examined, you are then given an 

opportunity to search the remainder of the drawing. 

Normally SmartDraw searches for the target string without regard to upper or lower 

case, and it will report matches that are not whole words. For example, if you search 

for mary it will find Maryanne. You can change this behavior by checking the 

appropriate boxes in the dialog.  

Match case causes SmartDraw to find matches only when the case of the 

characters in the drawing also matches the target. 

Match whole word only causes SmartDraw to ignore matches when the target 

appears as part of another word. 

Replacing Words 

If you click on the Replace button in the Find and Replace Dialog, or select the 

Replace command  under the Edit Menu, the dialog opens out to its expanded 

form. 

 
Expanded Find and Replace Dialog 

 

If the target string is highlighted in your drawing, pressing the Replace button will 

replace the target with the replacement string and then go on to find the next 

match. Pressing Replace again replaces the next match and so on. 



SmartDraw 2009 User's GuideUser’s Guide Using Tables ••••  112 

 

You can replace all instances (initially in your selected range and then in the entire 

document) automatically by pressing the Replace All button. 

‘Find Next’ Menu Command 

After you close the Find and Replace dialog, your target and replacement strings 

(and checkbox settings) are remembered (even between sessions). You can find 

the next instance of the current target string at any time without showing the Find 

and Replace Dialog, by using the Find Next command under the Edit Menu. 

The shortcut to the Find Next command is the F3 key. Holding the Shift key down and 

typing F3 finds the previous match. The search order of objects is the same as their 

tabbing order in the drawing. 

Using Tables 

What are Tables? 
Normally, text entered into a SmartDraw object occupies a single text entry area 

that fills the object. However, SmartDraw also supports Tables, which contain 

multiple text-entry areas within a single shape. 

The text-entry areas are separated by Grid Lines, so the table looks something like a 

spreadsheet. 

 
Normal Shape 
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Table 

Each text entry area (or cell) acts like a separate shape as far as text entry is 

concerned. Each cell can have its own text alignment and background color, and 

the text inside shrinks or grows independently of other cells.  

Adding Tables to a Drawing 

  You can add a new table to your drawing by clicking Insert Table on the Table 

tab. 

This displays the Table Gallery containing nine ready-made table configurations, 

plus a Define option to define your own table. 

 
Insert Table Menu 

Clicking one of the ready-made options inserts a table of that type into your 

drawing.  Clicking Define opens the Add New Table dialog box where you can 

specify your own custom table parameters. 
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The Add New Table Dialog 

The Add New Table Dialog shows a list of pre-defined table formats. Clicking the 

name of one of them displays a preview of it on the right.   

You can specify the number of rows and columns in your table by changing the 

numbers in the Parameters boxes. 

Clicking OK adds a new table of the specified format to your drawing. 

 

Converting a Shape to a Table 
Some existing shapes can be converted into tables by the Convert to Table 

command on the Table tab.  

This command only becomes active when a convertible shape is selected in the 

drawing. 

This command opens the Convert Shape to Table dialog box, where you can 

specify the properties of the table.  

At the left you see a list of pre-defined table formats. Clicking name of one of them 

displays a preview on the right.   

You can specify the number of rows and columns in your table by changing the 

numbers in the Parameters boxes. Pressing OK converts the shape to the table.  

Any text already inside the shape is placed in the first cell of the table.  

Non-rectangular shapes may also contain tables: 
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Different shapes containing the same 2x2 table 

 

Convert to Table works with any of the standard shapes available from the Shape 

button on the Home tab, some shapes in the libraries, and with any custom shapes 

created with The Polygon Tool and The Freehand Drawing Tool.  Other shapes and 

symbols cannot be converted to tables. 

See also Converting a Table to Text 

Converting a Table to Text 
You can change a table into a normal shape that has a single text-entry area using 

the Convert to Text command on the Table tab.  

Any text contained in the table cells is joined together as one text block inside the 

new shape. 

See also Converting a Shape to a Table 

Table Rows, Columns and Cells 
Tables are composed of rows and columns of cells.  

Typically the cells in each row or column are lined up to form a perfectly regular 

grid, but this need not be the case.  Cells can be joined and split to create nearly 

any kind of table structure you can imagine. 

Each cell is an independent rectangular area that may have its own text, 

background color, and other attributes.  

The dividers between the cells, called Grid lines, are like the borders of shapes. They 

may have their own thickness, color, and pattern. Grid lines may also be hidden, so 

they are invisible, even though they still exist to separate the cells. Some examples of 

table formats are shown below. 
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Different Table Formats 

Note that columns may differ in width, and rows may differ in height. Cells may span 

many rows or columns.  These irregular formats are created by joining and splitting 

table cells, or by moving small segments of the Grid lines. 

See Also Joining and Splitting Table Cells 

See also Moving Table Cell Dividers (Gridlines) 

Formatting Tables  

  You can change the appearance and cell arrangements of an existing table 

on your page by choosing Format Table  from the Table tab.  

This opens the Format Table dialog box, which functions just like the Convert Shape 

to Table Dialog Box. 

Adding Table Formats of Your Own  
When you use the Format Table command to modify an existing table, the new, 

resulting format is added to the Table list and shown in the dialog as [Current 

Settings].  

Adding Text to Tables  
By default, table cells are opened for text editing with just one click of the mouse.  

You can change this for a selected table by selecting Text Entry in the Shape 

Properties group of the Design tab. 
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If you created your table by converting an existing shape, then, by default, double-

clicking is required for text entry. This can be changed to a single click using the Text 

Entry command in the Shape Properties group of the Design tab. 

Text entry in a table cell behaves exactly the same way as text entry in a standard 

rectangular shape. 

Preventing Changes to Text in Table Cells 

Sometimes you may want to prevent text in a cell from being changed (or to 

prevent text being entered into a cell at all). This is common in forms, where you 

may want to lock a text label, while leaving the adjacent cell open for the user to 

type in. 

You can prevent text editing on a cell-by-cell basis using the Text Editing command 

in the Table tab. The setting will be applied to any highlighted cells. Using the 

command toggles the ability to edit text on and off for the selected cells. 

Text Resizing and Tables 

If you enter a large amount of text, the cell will be forced to grow. To maintain the 

row and column arrangements of the table, the cell’s entire row or column will also 

grow. 

All the cells in a table follow the text resizing rules of the overall shape that contains 

the table. Those properties are controlled by choosing Text Entry on the Design tab 

while the shape is selected (you do that by clicking on its border at the edge of the 

table.) 

By default, shapes containing tables are set to grow vertically as text is added. This 

means that text wraps within a cell, and rows get taller as text is added. 

Shapes containing tables can be set, using their Text Entry Properties, to grow 

horizontally or proportionately as text is added. Horizontal growth means that 

columns (and tables) get wider as text is entered.  

 
Text Sizing in Tables 
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Moving Around in the Table 
When you are entering text into a cell, typing the Tab key moves the text insertion 

point to the next cell to the right. If the cell is at the end of a row, the insertion points 

wrap around to the first cell on the row below. Shift-Tab does the reverse.  

The Up and Down arrow keys also move the insertion point up and down rows within 

a column.  

The Right and Left arrow keys move the insertion point left and right within the text of 

the current cell, but to the left and right cell respectively if the cell contains no text. 

Note that cells with the No Text Editing attribute (under the More menu of the Table 

tab) are skipped when moving the insertion point with the tab key.  This is particularly 

useful in forms, where you can use this to lock the cells containing fixed information, 

such as labels or prompts, so users automatically skip those cells when tabbing 

through the form. 

Selecting Table Cells 
Clicking and dragging the mouse within a table, when the text insertion cursor is 

active, selects a range of cells, highlighting their centers with black, just as in Excel® 

and other spreadsheets.  (The insertion cursor is the typical text-insertion cursor that 

looks like the letter I.) 

 
Selected table cells 

If the table is configured for single-click text entry, the text insertion cursor appears 

automatically when your mouse hovers over the table cells.  If it is set for double-

click text entry, you must click twice on a cell to get the text insertion cursor.  

 Rows and columns can also be selected by clicking at the leftmost or topmost 

edge of the table. When a click would select a row or column, the cursor is 

displayed as a wide arrow (shown at left).  
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Selecting the overall shape that contains the table (by clicking on its border) 

selects all the cells and grid lines in the table. The cursor appears as the normal 

selection tool (shown at left) when a click would result in the selection of the entire 

shape, rather than specific cells. 

   Clicking anywhere in the table with the Multiple Selection tool always selects 

the shape containing the table, including all cells and grid lines within it. 

Holding the Ctrl key down while clicking on a cell allows you to select several 

individual cells one at a time. Ctrl-clicking on a selected cell de-selects it. 

Holding the Shift key down while clicking on a cell extends the selection rectangle 

from the Anchor cell to the clicked cell. The anchor cell is the one that was first 

selected.  This is the typical behavior of Shift-click found in many programs you are 

used to. 

Once a cell is selected, the selection can be moved using the arrow keys. Holding 

the Shift key down while pressing an arrow key extends the selection in that 

direction, just like shift-clicking does. Tabbing also moves the cell selection. 

Changing the Appearance of Table Cells  
When a cell is selected (either by clicking in it to open it for text editing, or by 

highlighting it by dragging the mouse), you can change its appearance with the 

commands on the Table Style group on the Table tab. 

 
Choosing Fill opens a menu identical to the Fill menu on the Home tab, which is 

described in Changing the Appearance of Shapes.  The selected color or texture is 

applied to the selected table cells. 

Choosing Line opens a menu identical to the Line menu in the Shape Styles group of 

the Home tab, which is described in Changing the Appearance of Lines. The 

selected color or style is applied to the grid lines around any selected cells in the 

table, or to all grid lines if the entire table is selected.  (It does not change the table 

border. To do that, you would click on the border to select the entire table shape, 

then use the Line command on the Design tab.). 
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Choosing Effects opens a menu identical to the Effects menu on the Home tab, 

which is described in Design Effects.  The selected effect will be applied to the 

selected cells. 

Changing the Appearance of Text 

The commands in the Home tab can be applied to any selected cells in a table, or 

to all the cells if the table shape itself is selected. 

Selecting Table Grid Lines 
You can select individual Grid Lines, or parts of a Grid Line, in your table to change 

their properties.  

  When a mouse click would result in the selection of a Grid Line, the cursor 

becomes two parallel lines with arrows indicating the directions in which the Grid 

Line can be dragged. 

Clicking on a Grid Line selects it. Selected Grid Lines are shown as green dotted 

lines. Once a Grid Line has been selected, you can extend the selection range by 

shift- clicking on lines parallel to it. Ctrl-clicking adds just the line clicked-on to the 

selection range. 

You can change the attributes of the selected Grid Lines with the commands under 

the Line button on the Table tab.  

Partially Selecting Row and Column Grid Lines 

Normally, when you click on a table Grid Line, the entire Grid Line for that row or 

column is selected. If you hold the Alt key down while clicking, however, only the 

segment of the Grid Line touching that cell is selected. Alt clicking on additional 

Grid Line segments adds them to the selection. Holding down both the Alt and Ctrl 

keys toggles the Selection State of a Grid Line segment on or off. 

This feature lets you change the properties of separate parts of a row or column Grid 

Line, and more importantly, allows parts of them to be moved independently. 

See also: Moving Table Grid Lines 

Moving Table Grid Lines 
In tables, clicking on a Grid Line not only selects it, but also allows you to move it. 

You can increase or decrease the width of columns and the heights of rows by 

dragging the Grid Lines with the mouse. 
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When you move whole column Grid Lines, only the width of the column to the left of 

the Grid Line is affected. The columns to the right remain the same size. The table 

grows wider or narrower to accommodate the change in width of that column. 

 The same principle applies to whole row Grid Lines, where the space above the row 

is affected by moving the Grid Line. 

Using the Alt key to select a segment of a column Grid Line allows the small selected 

segment to be moved, changing the width of the immediately adjoining cells. This is 

one way to create tables with cell arrangements that are more complicated than 

regular rows and columns. 

 
Alt-Drag just the top row column Grid Line 

 

 
When column Grid Lines are moved while holding down the Alt key, the cell to one 

side of the Grid Line becomes narrower as the one on the other side becomes 

wider. The width of the overall table remains unaffected, unless forced to grow to 

maintain a minimum width for a column. 

Changing the Rightmost Column and Bottommost Row 

The far right and bottom edges of the table border behave like Grid Lines and can 

be dragged with the mouse. The Grid Line cursor appears just inside these edges 

when you place the mouse over them (unlike interior Grid Lines, where it appears 

directly on top of the Grid Line). Dragging on this "phantom" Grid Line changes the 

width of the rightmost column, or height of the bottom row. 

Grid Snaps and Table Grid Lines 

If grid-snaps are turned on (under Grid on the Page tab), the invisible page Grid 

affects the position of cell Grid Lines. When the snaps are active, row heights snap to 

whole line heights, as determined by the height of the first line in the table, and 

column Grid Lines snap to the lines of the invisible grid. This makes it easy to re-align 

column Grid Lines that have been separated by dividing cells or by dragging partial 

Grid Lines. 

See also: Selecting Table Cell Dividers (Grid Lines) 
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Spacing Table Rows and Columns Evenly 

 
The Space Rows Evenly and Space Columns Evenly commands, under Distribute of 

the Table tab, make all the rows or columns in the table the same height or width, 

while changing the size of the table as little as possible. 

If any cells contain text, spacing evenly may require making all of the rows or 

columns the same size as the largest existing row or column containing text. 

Resizing the Table Object  
Resizing the object (rectangle, circle, etc.) that contains the table stretches or 

shrinks the table as a whole to fit the new dimensions of the object.  

The object containing the table cannot be reduced in height to less than the 

minimum required height of all the rows (which is specified by the table’s text 

properties).  You can quickly minimize a table’s height by using the mouse to shrink 

its bounding object vertically as far as it will go. (Click on the border of the table to 

select its bounding object, then use the black selection handles to resize it). 

Holding the Shift key down while resizing the table object with a corner selection-

handle will scale the entire object proportionately. 

Joining and Splitting Table Cells 
The Join Cells and Split Cells commands, on the Table tab, allow you to create 

complex table structures. 

The Join Cells command joins the currently selected cells into one cell, combining 

any text in those cells into a single block of text. When cells from multiple rows are 

selected, cells adjacent to each other in the same row are joined first. Cells 

adjacent to each other in the same column are joined only if they have no selected 

neighbors in the same row. 

Joining cells in the same row simply removes the Grid Line(s) between them.  

 
Joining Cells in a Row 
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Joining cells in the same column creates a single cell that spans the rows containing 

the selected cells. Cells that span more than one row always span a whole number 

of rows. It is not possible to create a cell that lies partially in a row. 

 
Joining Cells in a column 

 
 

The Split Cells command does the reverse of Join Cells. If a cell spans more than 

one row, splitting creates a cell for each row spanned. Any text in the split cell is 

placed in the top, or left, cell.  

If all the selected cells lie within one row, then the Split command splits each cell 

into two adjacent cells occupying the same space as the original cell. A vertical 

Grid Line is added between the two new cells. 

 

 

See also Selecting Table Cells 

Inserting Table Rows, Columns and Cells  
You can insert columns in your table using the Insert Left or Insert Right and rows 

using the Insert Above or Insert Below commands on the Table tab. 
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You can choose to insert a row Above or Below the selected row (the row where 

your cursor is, or where you have a cell highlighted.) 

 
Before Insert Row Above 

 

 
After Insert Row Above 

 

You can insert a column to the left or right of a selected column. 

 
Before Insert Column on Left 

 

 
After Insert Column on Left 

  

Deleting Table Rows and Columns 
The Delete commands on the Table tab give you two options: 
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Remove Row/Column - Remove the entire row or column of cells from the table. 

Delete Contents of Row/Column - Remove only the text and other contents (such as 

images) from the row or column. 

Deleting, Copying and Pasting Text in Tables 
With a single keystroke you can delete the contents (text or graphic) of a selected 

table cell, without removing the cell itself. Pressing the Backspace or Delete key 

erases the contents in all selected cells. 

The content of selected cells can be copied to the clipboard using the Copy or Cut 

commands on the Home tab. Pasting the content back into a SmartDraw table 

preserves its row and column arrangement along with font, alignment and other 

text attributes.  You can even paste the table data from SmartDraw into another 

program, such as an Excel spreadsheet or Word table, and it will retain its tabular 

format. 

The reverse also works.  Pasting tabular data from another program into a 

SmartDraw table preserves the row and column arrangements of the data, placing 

each field in its appropriate cell. This allows data from spreadsheets and other 

programs that generate tabular data to be formatted as a table in SmartDraw. 

Changing the Appearance of a Table  
To change the cell color, pattern, borders, or grid lines in a table, select the desired 

cells, rows, or columns and then use the commands in the Table Style group on the 

Table tab. 

To change the appearance of text in table cells, select the cells and then use the 

commands the Home tab.  
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Selecting the entire object (the overall shape) containing a table implicitly selects all 

the cells and Grid Lines in the table, and any changes to the properties apply to the 

entire table. 

Note that to change the Grid Lines you use the commands on the Table menu, but 

to change the border of the entire selected table (its bounding object) you use the 

Line button on the Home tab. 

Line-Linking In Tables  
Lines can be linked to table cells, a feature particularly useful in creating Gantt 

Charts and Timelines, which are based on tables. 

If you draw a line on top of your table (using the Straight Line, Curved Line, Shape 

Connector, or Curved Connector tools) the end points of the line will link to the 

table cells.   

Now, if the table is moved, stretched, rotated, or reformatted, the line automatically 

moves with the cells it is attached to.  The line itself can be bent or otherwise 

reconfigured, and its endpoints will remain locked in place in their table cells. 

In the example below, the red line with the arrowhead was drawn on top of the 

table and the line was allowed to link to the table cells.   

 
A line linked to table cells 

Then the Insert Column command was used to add a new column to the left of the 

middle one. The line automatically stretched to stay attached to the original cells to 

which it was linked. 

 
The same table after ‘Insert Column’ 

The endpoints of the line can be linked at three different vertical positions with 

respect to a table row: the top, center, or bottom of the row. (Linking to the top or 

bottom places the line directly on top of the row Grid Line).   

Within the columns, the endpoints of the line can be linked to any position along the 

horizontal axis (in other words, the horizontal linking points are continuous). 
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You can also link one end of a line to a table cell and the other end to a shape 

outside the table.  This effectively treats the table cell as one object and the outside 

shape as another, and in that respect is similar to the normal practice of Linking a 

Line to a Shape. 

See also Shape-Linking in Tables. 

Shape-Linking in Tables 
As with Line-Linking In Tables , shapes can be linked to table cells. This is commonly 

used in Gantt Charts, Timelines, and Calendars, which are based on tables, but 

applies to any SmartDraw table. 

You can use this property in two ways: 

1. Small shapes, such as the symbols used in some types of matrix, can be linked and 

"stuck" to the table cells within which they lie. For example, the red and green 

symbols in the illustration below are shapes linked to table cells. 

 
Shapes and lines linked to table cells 

For a shape to be able to link to table cells, Allow Shape to Link to Cells in Tables 

must be turned on for that particular selected shape in its Shape Properties under 

the Shape Outline menu on the Design tab.  Some shapes (such as Resource & Task 

Matrix symbols) are already set this way.  For other shapes, you may need to set it 

manually if you want to link them to a table cell. 

2. Table cells can also be indirectly linked to shapes outside the table by drawing a 

line between them. This effectively treats the table cell as one object and the 

outside shape as another, and in that respect is similar to the normal practice of 

Linking a Line to a Shape. 
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AutoFill in Tables 
The row and column headers in a table are frequently a series of numbers, months 

or days. SmartDraw can create these series for you automatically, with the AutoFill 

command on the More menu of the Table tab. 

 
The AutoFill Dialog 

To use Autofill, you must have first selected a row, column, or cell in the table to 

indicate where you want the fill to take place. 

SmartDraw will automatically enter the series of number, days, etc., across a range 

of rows or columns, beginning with the first selected cell. 

There are six types of Autofills: Numbers, Days of the Week, Date Range 

(Month/Day), Months, Years, or a Constant value.  

For Days of the Week and Months, the sequence can begin at any value, and it 

repeats until the Number of Values is reached. A checkbox lets you choose 

between full and abbreviated names for the days or months. A preview appears 

showing the current selections. 

For years and other series of numbers, a prefix and/or suffix can be added to the 

Autofill values.  

The radio button at the bottom of the dialog box indicates whether to insert the 

series across the row containing the currently selected cell or down its column. 
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Adding Photos (or Other Images) to Tables  
You can insert a digital photo or other kind of bitmap image into a table cell. 

 
A Photo inserted into a Table Cell 

There are three ways to insert a photo (or other bitmap image) into a table: 

Copy the image in another program and Paste it into the table cell (the cell must be 

selected or have your cursor positioned in it so SmartDraw knows where to Paste the 

image.)   

Select a table cell by highlighting it with the mouse, and then click Picture on the 

Insert tab.  Browse to find the image on your computer, and it will be inserted into 

the table.   

Right-click in a table cell and choose Insert Picture from the menu. 

Pictures Cropped by Table Cells 

If the picture you insert is larger than the table cell, you will see the picture cropped 

(cut off at the edges) by the cell. 

 
Even it if looks cropped the whole picture is still there.  If you expand the rows or 

columns by dragging the gridlines or joining cells, you can see the rest of the picture. 
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See also Moving Table Grid Lines 

See also Joining and Splitting Table Cells 

Arranging Objects 

Arranging Objects  
SmartDraw provides easy, automatic shortcuts to help you arrange the objects in 

your drawing.   

With a few mouse clicks you can align them, make them equally sized, or make 

them evenly spaced. You can rotate, flip, and position them in many different ways.  

These commands appear on the Design tab. 

Using Grid Snaps to Align Objects 
Beneath the work area  lies a grid of imaginary lines spaced at the interval of the 

smallest increments on the rulers.  

When the Grid Snaps function is active, the centers or edges of objects 

automatically align themselves with the grid as they are drawn, moved, or resized 

with the mouse.  

This makes aligning your objects easy: You simply drag them with the mouse and let 

them "stick" where they want.   
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You control the functions of the Grid using the Grid commands on the Page tab. 

 
The Grid Menu 

Show Grid - This displays the normally invisible grid on the screen.  (Note: Even 

though it appears on screen the grid will not print with your drawing unless you 

check the Print the Grid checkbox in Page Setup on the More menu of the Page 

tab.) 

Snap to Top Left Edge of Shape - The top and left edges of your objects will align 

themselves with the Grid. 

Snap to Center of Shape - The centers of your objects will align themselves with the 

Grid. 

The Center setting works best when lines are used to link shapes together, as in 

flowcharting. The Edges setting works best when the edges of shapes must line up, 

as in a form or a floor plan. 

Do Not Snap to Grid - The grid snap function is turned off for this particular drawing.  

Objects move freely, ignoring the grid. 

Note: When you move or resize objects by using the arrow keys, they do not align 

with the Grid snaps. This makes it easy to make fine adjustments in position without 

turning the snaps off. 

Aligning Objects 

  The Align command, on the Design tab of the Main Toolbar, aligns the edges of 

selected objects with a target object.  

 
The Align Menu 
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The target object is the last one selected when you select a series of objects. You 

can recognize it by its solid black handles. The other selected objects have hollow 

handles.  

The Align Lefts and Rights commands align the left or right edges of the selected 

objects with the left or right edge of the target object. 

 
Align Lefts Command 

 

Aligning the Tops and Bottoms works similarly. 

Align Centers aligns the midpoints between the left and right edges of the objects. 

Align Middles aligns the midpoints between the top and bottom of the object. 

Making Objects the Same Size 
  You can automatically resize several objects to be identical in height, width, or 

both using the Make Same Size command on the Design tab. 

 

 
The Make Same Size Menu 

Like the Align command, Make Same Size defines the last object selected in a series 

as the target object.  The target object has black section handles. 
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Make Same Size Command 

 

Objects that can only shrink or grow proportionally, such as squares and circles, 

maintain their proportions when using this command. 

Spacing Objects Evenly 
  The Space Evenly command, on the Design tab, arranges three or more 

selected objects to have equal space between them.  

 
The Space Evenly Menu 

Horizontally - Spaces objects equally in the horizontal direction only. 

Vertically - Spaces objects equally in the vertical direction only. 

Both - Spaces objects evenly in both directions at the same time.  

Centering the Drawing in the Work Area 
  The Center in Work Area command on the Page tab moves all the objects in the 

drawing so that they are centered in the minimum number of pages needed to print 

them.   

This command applies to all objects, not just selected objects. 

The entire drawing is also moved to the top-left of the drawing area, if needed.  

If your drawing does not fit on one page, you can still print it on a single page by 

checking the Print on One Page check box in the Print dialog. This will shrink your 

entire drawing proportionally to fit on one printed page. It will not change the size of 

the actual drawing, only the printed output. 
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Changing the Front-to-Back Order 
Every object on the page is either "in front of" or "behind" any other given object, 

depending on the order in which they were created, or the layer in which they lie.  

You can change the front-to-back order of the objects in your drawing using the 

Bring to Front or Send to Back commands on the Design tab. 

 
Bringing the rectangle to Front 

Bring to Front moves any selected objects in front of the non-selected objects. Send 

to Back does the reverse. 

 
Send to Back 

If your drawing has multiple layers, using Bring to Front will move the object to the 

top layer. Using Send to Back will move it to the bottom layer. 

These commands have no visible effect unless objects overlap one another, but 

they always affect operations that depend on front to back order, such as selecting 

objects with the Tab key. 

See also Changing the Order of Objects within a Layer 

The Tab Order 
The order in which objects become selected as you type the Tab key is called the 

Tab Order.  

The tab order is the order in which objects were created, unless you use the Bring to 

Front or Send to Back commands to change this order. 
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See also Changing the Front to Back Order 

See also Changing the Order of Objects within a Layer 

Locking Objects  
With the Lock Object command, you can lock an object to avoid accidentally 

moving or altering it.   

To lock an object, right-click on it and choose Lock Object from the right-click 

menu. 

 
When selected, a locked object has gray handles instead of black to indicate its 

locked status. 

Locking objects is useful if you want to place an object behind others and don't 

want to accidentally move it while clicking on the objects in front of it. Locked 

objects cannot be opened for text editing. However, their properties (color etc.) 

can be changed using the menu commands. 

Grouping and Ungrouping Objects 

 Two or more objects may be combined into a single unit using the Group 

command on the Design tab. The Ungroup command, in the same location, 

reverses this operation. 

Group Hierarchy 

Groups can have hierarchy.  For example, in the illustration below, the two 

rectangles are first grouped together.  Then the three ovals are grouped together.  

Finally these two groups are grouped together into one large group.  If you Ungroup 

the large group, you will have two small groups, not five individual objects. Then you 

could Ungroup the small groups to separate the objects.   



SmartDraw 2009 User's GuideUser’s Guide Arranging Objects ••••  136 

 

 
Grouping 

To group two or more objects, select each object with the multiple selection tool 

and then click Group from the Design tab. 

Properties of Groups 

No individual objects in a group can be edited. 

Clicking on any member of a group selects the group. 

Objects whose position is determined by links to other objects are automatically 

included in groups 

Moving any part of the group moves all members of the group. 

Sizing the group sizes all members of the group. 

Rotation rotates the group as if it were a single object. 

Duplicating, copying and pasting applies to the group as a whole 

Locked objects cannot be included in groups 

Groups cannot be flipped 

Hyperlinks are not accessible in a group; however they are maintained upon 

ungrouping 

Ungrouping Imported Objects 

You can also group and ungroup most imported objects into native SmartDraw 

objects. This is described in Ungrouping Imported Images in the section on using 

SmartDraw with other programs. 

Adding Groups to Symbol Libraries 

You can add a grouped object to a symbol library by dragging it onto a library 

window, like any other object. Groups retain their properties as library symbols, and 
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are drawn as a grouped object when placed in a drawing. See Adding New 

Symbols to a Library. 
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Using Layers 

Using Layers 
SmartDraw allows you to define more than one Layer in your drawing.   

A layer is an invisible plane that contains its own shapes, lines, symbols and other 

drawing objects. You can think of it as a stack of transparent sheets of paper with 

objects drawn on them. 

Every drawing starts with one layer, called the Default layer.  

Each layer has a unique name, and any layer can be moved within the layer stack 

to lie above or below any other layer. Objects in higher layers lie visually "above" 

objects in the lower layers. 

You create and manage additional layers using the Layers command menu on the 

Page tab. 

 
Layers are typically used to make complex diagrams like floor plans, where, for 

example, the walls may be in a different layer from the furniture or the wiring.  

You can selectively hide or reveal layers to isolate aspects of the drawing for 

viewing and printing. 
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Defining Layers 
You manage the properties of layers in your drawing using Define Layers dialog box, 

available by clicking Define Layers, on the Layers menu of the Page tab. 

 

 
The Define Layers Dialog 

Adding Layers 

Each new drawing starts out with just one layer, called the Default Layer. You can 

add a new layer by clicking Layers on the Page tab, then New Layer. (You can also 

add a new layer in the Define Layers dialog box.) After you name the layer, it is 

added to the stack, above the existing layers. 

Re-Naming Layers 

You can name a layer (including the Default Layer) anything you like by clicking on 

the name of the Layer in the Define Layers dialog box and then pressing the Edit 

Layer button. 

Layer Properties - Visible and Clickable 
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Layers have two properties: Visible and Clickable. The settings of these properties 

are shown with check boxes in the columns to the right of the layer name in the 

Define Layers dialog.  

If the Visible box for a layer is unchecked, then all objects in this layer are hidden, 

both on-screen and when printed. If the Clickable box is unchecked then, even if 

the objects are visible, they behave as if they are part of the drawing background; 

they cannot be moved, deleted or changed in any way. Layers that are not visible 

are also not clickable. 

The fourth column in the layer list shows how many objects in the drawing are 

currently assigned to this layer. 

Note that when only one layer is present it is active and locked in the clickable and 

visble states.  Adding a layer will unlock these options for all layers.   

Moving Objects Between Layers 

In a multi-layer drawing, any selected object can be assigned to any layer using the 

Move Object To Layer command on the Layers menu of the Page tab. 

Moving Objects within their Own Default Layer 

You can move selected objects to the front or back of their current layer using the 

two commands at the bottom of the Layers menu on the Page tab. 

Changing the Layer Order 

The layers appear in your drawing in the same order (top to bottom) that they 

appear in the Define Layers dialog box.  The layer at the top of the list is the topmost 

(or front most) layer in the drawing. This means that objects assigned to this layer lie 

in front of (and may hide) objects in the lower layers. Similarly, objects assigned to 

the second layer lie in front of objects assigned to the third layer and so on. 

You can adjust the position of a layer in the stack by selecting it in the list and then 

clicking on the Move Layer Up and Move Layer Down buttons in the dialog. 

Showing All Layers 

If you want to quickly make all your layers visible, you can use the Show All Layers 

command on the Layers menu of the Page tab. If a checkmark appears beside this 

command, all your layers are already visible. 

Removing Layers 
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You can remove a layer from the drawing by selecting its name in the Define Layers 

dialog box and pressing the Remove Layer button. Any objects assigned to this layer 

are automatically re-assigned to the top layer. 

See also: The Layer Tabs 

The Layer Tabs 
If more than one layer exists in your drawing, then Layer Tabs appear at the bottom 

of the drawing window. 

 
Each tab represents one layer.  The active layer tab is white and the inactive layer 

tabs are blue.   

Clicking once on a tab makes that layer active. Double-clicking on a tab opens the 

Define Layers dialog.  

Small icons on each tab indicate the layer properties. The eye appears if the layer is 

set to be visible. A red X appears over the eye if the layer is set to be invisible. 

A lock icon appears if the layer is set to be non-clickable. 

Clicking on the small down arrow below these icons brings up a menu that allows 

you to change the layer properties. Right-clicking on the Layer Tab brings up the 

same menu. 

The active layer is always clickable and visible (even if only temporarily). 

If you want to quickly make all your layers visible, you can use the Show All Layers 

command on the Layers menu of the Page tab. If a checkmark appears beside this 

command, all your layers are already visible. 

If the number of layer tabs exceeds the space available at the bottom of the 

drawing area, scroll buttons appear at the left of the tabs, allowing you to scroll left 

and right through the layers. 

The maximum number of layers in a drawing is 32. 

The Active Layer 
The layer with the currently selected Tab is the Active Layer.  
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The active layer is always visible and clickable (even if only temporarily). All newly 

created objects are normally assigned to the active layer automatically. There are 

only three exceptions to this rule: 

Objects created with the Duplicate command remain in the layer of the object that 

was duplicated. 

Objects Copied and Pasted within a drawing stay in the layer they were copied 

from. 

Objects Copied and Pasted from one drawing to another remain in their respective 

layer only if the destination drawing has a layer with the same name as the original 

layer. Otherwise they are assigned to the active layer. 

If you want to work on a particular layer, you can make it active by clicking on its 

Layer Tab at the bottom of the drawing window.  

See also The Layer Tabs 

Moving Objects Between Layers  
Any selected object can be moved to another layer, or moved to the top or 

bottom within its own layer.  

The Move Object to Layer command, on the Layers menu of the Page tab, will 

move the currently selected object to the layer that you specify on the drop-down 

list.   

 
Move Object to Layer Menu 

The list shows all the layers in their top-to-bottom (front-to-back) order. If all of the 

selected objects are currently assigned to the same layer, the name of this layer is 

checked. 

You can also bring a selected object to the front or back of its own current layer, 

using the Bring to Front of Layer and Send to Back of Layer commands on this menu. 

If you move an object to a layer that is not visible or clickable, the object itself will no 

longer be visible or clickable. 
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The Move Object to Layer command also appears on the right-click menu for any 

selected object. 

Changing the Order of Objects Within a Layer 
The Bring to Front and Send to Back commands on the Arrange group of the Main 

Toolbar send a selected object to the front or back of all objects in all layers.  

This may result in moving the object to a different layer from the one it is currently in. 

To move a selected object to the front or back of its own current layer, use the Bring 

to Front of Layer and Send to Back of Layer commands on the Layers menu of the 

Page tab. 

Linking Lines and Shapes  

Linking a Line to a Shape 
The ability to link lines to shapes lies at the core of many drawings types, including 

flowcharts, engineering schematics, mind maps, and many more.  It allows you to 

connect two shapes with a line that will stretch like a rubber band to stay 

connected when you move one of the shapes. 

You can link lines to shapes if Allow Lines to Link is turned on (in Options, under the 

SmartDraw Button). 

To connect two shapes with a line, click on the Line Tool  on the Home tab and 

release.  

Now your cursor looks like a pencil.  Touch the pencil to the edge of one shape and 

click down with the mouse.  Drag the pencil to the edge of another shape, and 

release.    
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Starting a Line from a Shape 

 

 
Anchoring a Line to a Shape 

When the end of the line approaches the shape's border, a series of round solid 

circles appear on the shape, indicating the points on the border where the line may 

link. These are called Shape Connection Points.   

 The end of the line then snaps to the closest connection point and the mouse 

cursor becomes an "anchor". Releasing the mouse while in this state links the line to 

the shape. 

The line is like a rubber band that stretches or shrinks to stay connected to the 

shapes as they are moved 

 
Lines stay connected when shapes are moved 

See also Shape Connection Points. 

Breaking a Line Link 

To unlink the line, reverse the process. First, select the line by clicking on it.  A round 

handle appears where the line attaches to the shape. Grab that round handle and 

drag it away from the shape to break the link.  
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When only one end of a line is linked to a shape you can also break the link by 

simply moving the line (by dragging it) away from the shape. Deleting an object 

linked to a line also breaks the link. 

Line Linking and Flowcharts 

Linking lines to shapes is essential to creating flowcharts. By connecting your shapes 

with linked lines you can move and rearrange the shapes in your flowchart without 

breaking the flow lines. 

In a typical flowchart, you’ll want to link the line to the center of the side of a shape. 

The flowchart drawing templates are set up so that the centers of the shapes snap 

to the grid (see the Grid command on the Page tab).  If you link your lines to the 

centers of the sides, all your lines will be straight. 

On the other hand, if you draw a floor plan (or any other drawing where the 

alignment of edges is more important than centers), then you’ll want the edges to 

snap to the grid. You can specify this in the Snaps settings on the Page tab. 

Linking Lines To Table Cells 

You can link lines directly to individual cells in tables, which is useful for drawings 

such as Time Lines and Gantt charts. See Line-Linking In Tables . 

Shape Connection Points 
Shapes and symbols can have either Fixed, Continuous, or Custom Connection 

Points. 

You can modify the connection points for any shape in your drawing by selecting 

the shape and clicking Connection Points on the Design tab. 
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The Connection Points Dialog 

Only the standard shapes available from the Shape Tool on the Home tab have 

Default (fixed) connection points, which lie as follows: four at the corners of the 

shape, four in the center of the sides, and one between each of these points. These 

default points are ideal for drawing flowcharts, org charts, and similar diagrams. 

Any closed shape (whether a standard toolbar shape or some other closed 

polygon) can be set to have Continuous Connection Points, allowing you to link lines 

or other objects to any location on the perimeter of your shape. In addition to 

flexibility, Continuous Connection Points allow you to connect a very large number 

of lines to the same side of a shape. 

Any shape or symbol can be set to have Custom Connection Points, which allows 

you to add, remove, or reposition Connection Points at will. Most library symbols only 

have Custom Connection Points and cannot be set to Default or Continuous 

(though there are exceptions, such as the closed polygons mentioned above). 

The number of Default or Custom Connection Points on any shape may not exceed 

16.  Continuous Connection Points are essentially infinite. 

Modifying the Connection Points for a symbol on your page only modifies that single 

instance of that object. It does not modify the master copy of that shape in the 

symbol libraries.  However, you can permanently alter the Connection Points for a 
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library symbol using the Edit Symbol function, accessed by right-clicking the symbol 

in the symbol library.  You may want to make a copy of the symbol and modify that 

one, so that you don’t lose the properties of the original. 

The Shape Attachment Point 

Each shape or symbol also has an Attachment Point, usually at its center, which 

determines where it will link if attached to a line, or attached to another shape’s 

border, or to a table cell.  You can move the attachment point using the 

Connection Points dialog, where the Attachment Point is shown as a diamond. 

As with Connection Points, modifying the Attachment Point for a shape or symbol on 

your page only modifies that single instance of that object. It does not modify the 

master copy of that object in the symbol libraries.  However, you can permanently 

alter the Attachment Point for a library symbol using the Edit Symbol function, 

accessed by right-clicking the symbol in the symbol library.  You may want to make 

a copy of the symbol and modify that one, so you don’t lose the properties of the 

original. 

See also: 

Modifying Connection Points 

Linking a Line to a Shape 

Linking Shapes to Each Other 

Changing the Settings for a Symbol 

Modifying Connection Points 
You can modify the positions the connection points on a shape or symbol already in 

your drawing using Choose Connection Points dialog box (found by selecting the 

shape and clicking Connection Points in the Design tab). 

Each Connection Point is shown as a small black square, and when it is selected it 

looks like a black circle. 
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The Attachment Point is shown as a small black diamond, and when it is selected it 

looks like a large black diamond. 

Moving the Connection Points 

You can drag the connection points with the mouse to a new location within the 

boundaries of the shape, or you can type the four arrow keys to move a selected 

point. 

In the Custom mode, the preview shows a grid background.  You can cause the 

connection points to snap to the grid as you move them by checking the Use Snaps 

box. 

Adding and Deleting Connection Points 

When a point is selected, you can delete it by typing the backspace or delete key. 

The Attachment point (diamond) cannot be deleted. 

You can add a new point by holding Ctrl while you click on the shape.  Each shape 

can have a maximum of 16 connection points. 

Holding down Ctrl and using the arrow keys moves the selection from one point to 

another.  
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Modifying the Connections Points in the Library 

Modifying the Connection Points for a shape or symbol on your page only modifies 

that single instance of that object. It does not modify the master copy of that object 

in the symbol libraries.  However, you can permanently alter the Connections Points 

for a library symbol using the Edit Symbol function, accessed by right-clicking the 

symbol in the symbol library window.  Automatic Settings must be unchecked to 

modify the points. You may want to make a copy of the symbol and modify that 

one, so you don’t lose the properties of the original. 

See also: 

Linking a Line to a Shape 

Changing the Settings for a Symbol 

Linked Targets and Linked Objects 
In any linking relationship (such as that between a line and a shape), one object is 

called the Linked Target and the other the Linked Object. Using the example of a 

line linked to a shape (as in a flowchart), the object that shows connection points 

(the shape) is the Linked Target, and the object linked to it (in this case the line) is 

the Linked Object. 

 
A Linked Target (shape) and Linked Object (line) 

 

The Linked Target usually controls the position of the linked object. If the linked 

target is moved, the linked object either moves or re-sizes itself to maintain the link. 

Lines can have one or two targets (one at each end). A line with one linked target 

(i.e., only linked to something at one end), will move when the target object is 

moved. With two targets (i.e., both ends of the line are linked to objects), the line will 

stretch or shrink to maintain the connection when one target object is moved. 

When a line that is linked to one target is moved, the link is broken. When a line that 

is linked to two target objects is moved, all three are moved as a group. 
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Turning Linking On and Off 
You can turn the linking behavior of lines and shapes on and off. This is useful when 

you want to draw a detailed picture, and you don't want objects that are close to 

others "grabbing" them and linking to them.  

The Allow Lines to Link command, found under Options under the SmartDraw Button, 

turns on or off the ability of lines to link to other objects. The templates for drawing 

flowcharts and similar drawings have this setting turned on by default. 

Similarly, the Allow Shapes to Link command turns on or off the ability of shapes to 

link to other shapes. Shape-linking is used more seldom than line-linking, so in most 

drawing types this is turned off by default. 

See also Linking a Line to a Shape 

See also Linking Shapes to Lines 

Linking Shapes to Lines 
Allowing shapes to link to lines should not be confused with allowing lines to link to 

shapes.  It is essentially the reverse process. When Allow Shapes to Link to Lines 

(found in Options under the SmartDraw Button) is turned on, the line becomes the 

Linked Target and the Shape (or a library symbol) becomes the Linked Object.  

Shapes link to lines via one attachment point, usually in the center of the shape. You 

link a shape to a line by dragging it over the line so that its attachment point draws 

near the line. As the shape’s attachment point comes into contact with the line, the 

cursor changes to the anchor shape and the attachment point becomes 

highlighted as a black dot. 

Releasing the mouse leaves the shape linked to the line. If the line is moved the 

shape follows. 

The linked shape can be dragged along the line like a bead sliding on a string. 

 

When the Line Shows Through the Linked Shape 

Sometimes when a shape links to a line, the line appears to show through the shape. 

This usually means the line lies in front of the shape. Selecting the shape and using 

the Bring To Front command on the Design tab reverses their order. 
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Line in Front of Shape 

 
Shape in Front of Line 

 

Orienting Shapes and Text on a Line  

The orientation of a Shape (or text) linked to a line is controlled by the Direction 

command on the Home tab. 

To use this setting: 

You must have a piece of text attached to a line, or a shape linked to the line. 

You must select the Line (not the text or shape) by clicking on it. 

Now use the Direction command:  

 
When the line is set to Align along the Direction of the Line, a shape rotates to follow 

the direction of the line. 

 
Align along the direction of the line 

 

When the alignment is set to Horizontal, the shape or text object maintains its own 

angle of rotation and can be rotated independently of the direction of the line. 

 
Horizontal 

See also Attaching Text to Lines. 
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Linking Shapes to Each Other 
When Allow Shapes to Link is turned on (in Options under the SmartDraw Button) one 

shape can be linked to another shape. 

When shapes link to each other, any of the Shape Connection Points on the linked 

shape can snap to any of the connection points on the target shape. Shapes can 

only link to one target shape at a time. 

This feature is useful if you want to attach a background text object to a shape 

(without putting the text literally inside the shape) so that it follows the shape around 

when the shape is moved or re-sized.  

See also Linking Shapes to Shape Borders. 

See also Linked Targets and Linked Objects 

Linking Shapes to Shape Borders 
Since a shape border is essentially like a line, one shape can be linked to another 

shape’s border by its Attachment Point in the same way that shapes can link to lines.   

For a shape to link to another shape’s border, the following conditions must be true: 

The shape whose border will be linked to must be a polygon shape created with the 

Polygon Line tool on the Home tab. 

Allow Shapes to Link to Lines must be turned on (found under Options under the 

SmartDraw Button.) 

The shape which will be linked to the border of the other must have Allow Shape to 

Link to Borders turned on inThe Shape Properties Dialog box (found on the Shape 

Outline command on the Design tab.) 

See also Linking Shapes to Lines. 

Linking Lines to Each Other 
Lines can be linked to other lines by dragging the endpoint of one line to any point 

on another line and letting it attach, similarly to the way lines link to shapes.  

For lines to link, Allow Lines to Link must be turned on (found under Options under the 

SmartDraw Button).  
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This is useful for creating branched networks of lines that remain attached when their 

target objects (whether shapes or lines) change size or move.   

If two lines are connected to the same Connection Point on the border of a shape, 

the second line will preferentially connect to the shape and not the other line. 

Joining Lines to Each Other 
In addition to the ability to be Linked (which makes one line stick to another where 

they touch), lines can be Joined to become a single new line, or to create a closed 

Shape.   

When lines are joined in this way, they behave like those drawn with the Polygon 

Line tool. 

For lines to be able to join, the Allow Lines to Join command must be turned on in 

SmartDraw Options on the More menu under the Document group. 

With this command turned on, two lines can be joined by dragging the endpoint of 

one to the endpoint of another, or by starting to draw a new line with the cursor 

positioned over the endpoint of another. 

When two lines are ready to join, a circle appears around the tip of the line 

drawing (pen) cursor. 

If lines are joined into a continuous closed loop, they fuse into a Shape, which can 

be filled with color and which has all the properties of other SmartDraw native 

shapes. 

See also: Drawing Freeform Lines and Shapes. 
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Automatic Connector Lines 

Using Automatic Connector Lines 
One of the most powerful features of SmartDraw is the use of Automatic Connector 

Lines to create regular arrangements of shapes. Automatic connectors are a type 

of Line, so the Line commands apply to them. They are primarily used in Org Charts, 

but also show up in family trees, fishbone diagrams, mind maps, some network 

diagrams, and even occasionally flowcharts.  

 
Using Automatic Connectors 

Automatic Connectors are special "intelligent" lines that can attach themselves to 

shapes, symbols, and even other lines. A connector is programmed to arrange the 

objects linked to it in a particular pattern.  

As new objects are linked to the connector, the other objects already linked to it 

adjust to accommodate the new one and maintain the pre-programmed 

arrangement. In the example below, a new shape is added to an organizational 

chart connector. 
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Adding a new shape to a Connector 

The new shape (tan) is dropped between the two existing shapes, and the 

connector automatically adjusts to insert it between them. 

When drawing Org Charts, the Org Chart SmartPanel contains buttons for adding 

employees, assistants, and co-managers that will automatically format the Org 

Chart in the proper manner. 

Changing an Automatic Connector’s Shape 
You can change the shape (configuration) of an existing Automatic Connector 

using the Branch Style Button, which is usually present in the SmartPanel for the 

template types with Automatic Connectors. 

 
Change Connector Shape 

Also typically located on the SmartPanels of these types of diagram are controls for 

changing the Chart Direction and Box Format. 

The Flip command, found on the Design tab, can also be used to create additional 

variations of these shapes. However, if any objects are already attached to the 

connector, you may need to remove them before flipping it, and then reattach 

them. 
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Adding Objects to an Automatic Connector 
When you draw Org Charts and other similar diagrams, the SmartPanel contains 

buttons for adding boxes that does this automatically for you.  The directions on the 

buttons indicate the location of the new box with respect to the selected box. 

 
A Group from the Org Chart SmartPanel 

But you can also add boxes or object to an Automatic Connector manually, as 

described below.  This is useful when you need to move a box or branch from one 

connector to another. 

When you move an object or a line close to an automatic connector, "ghost" 

connection points appear and a rectangular outline near the connector indicates 

the position where the object will be linked if you release it.  

Releasing the mouse links the object to the automatic connector.  

 
Linking to an Automatic Connector 

Dragging an object away from the automatic connector disconnects it, and then 

the objects still linked to the connector move together to fill the space. 
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Breaking a Link to an Automatic Connector 

Dragging a shape from one connection point to another changes the order of the 

shapes. 

 
Re-arranging a Link to an Automatic Connector 

Adjusting Automatic Connector Spacing 
An Automatic Connector Line normally spaces the boxes attached to it evenly. By 

clicking on the line to select it, you get growth handles that allow you to adjust the 

dimensions of the connector. 

Clicking and dragging on the round, black handle at the top of a branch removes 

the entire branch from the box it is attached to. In the figure below, this would mean 

that the entire branch and its three boxes would be detached from the upper box. 

Clicking and dragging the diamond on a vertical line will slide that line left and right 

on the branch below it.  In the figure below, this would mean that the upper box 

and its vertical branch would slide on the horizontal line. 

Clicking and dragging the black, square handle connecting the vertical line to the 

horizontal line will grow the vertical line. 

The diamond handles on the horizontal line will change the spacing only of the two 

boxes it is between, causing irregular spacing in the boxes. 
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The square, black handles on the corners of the branch will change the width of the 

horizontal line while maintaining regular spacing between the boxes. 

The square, black handles at the junction of a box and a line will lengthen the line. 

These relationships are shown in the figure below. 

 
Grow Handles  

Changing an Automatic Connector’s Appearance 
An automatic connector has the same attributes as a line, so the Line button on the 

Home tab can be used to set its thickness, color, and style.  

Automatic connectors can also have arrowheads of any type.  

Automatic Connectors cannot have text directly attached to them (see Attaching 

Text to Lines) and cannot be rotated. 

 

Linking Automatic Connectors to Each Other 
Automatic connectors can be linked to each other to create elaborate hierarchies. 
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Organization Chart with Two Connectors 

 

In the illustration above, the connector that holds the four smaller shapes (at the 

bottom) is linked to the higher connector that holds the two larger shapes. This 

connector is in turn linked to the top (manager) shape. 

To attach a connector to another: 

Place a second automatic connector object (from the library) on the page 

beneath the first one. 

Remove the top (manager) box from the lower connector, if it has one. 

Drag the end of the lower connector’s vertical line up until it attaches to the top 

connector line, or to a particular box on the top connector, above it. 
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Linking the lower connector line to the box above it 

 

Locking an Automatic Connector  
Sometimes an automatic connector will try to grab an object (or another 

connector) that you are trying to place independently on the page. To prevent this, 

you can temporarily lock the grabbing connector, allowing you to move or position 

your other objects freely. 

To lock a connector, right-click on it, then choose Lock Object from the right-click 

menu. This will turn the connector’s handles from black to gray, and you will no 

longer be able to resize or otherwise adjust it until you unlock it again.    

While locked, the connector will not try to grab objects placed near it. 

 
A locked connector has gray handles. 

 

Importing Org Charts from Data Files 
SmartDraw can automatically draw (or update) an org chart from an imported 

data file. This function is available only from the Import Chart from Data command 

on the More menu of the Org Chart SmartPanel. 
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You can import a file having either of two structures: 

A tab-indented text file 

An ID-formatted text file (where hierarchy is indicated by supervisor names or ID 

numbers). This is the format used by Org Plus®. 

In either of these file types, the fields can be separated by any one of a number of 

delimiters, including tabs, commas, colons, dashes and many others available from 

the Field Separator drop-down list in the Import Org Chart dialog.  A line break 

(CR\\LF) indicates the end of each record. 

The text file can have any extension, but SmartDraw will automatically browse for 

*.TXT and *.CSV (the default Excel comma-separated format). 

Automatic Chart Updating 

SmartDraw can automatically update your existing org chart by re-importing an 

updated data file.  All formatting in the existing chart (color scheme, style, font, etc.) 

is preserved during an update.   

How to Import an Org Chart from a Data File 

When you click the Import Chart from Data command on the Advanced Options 

menu of the Org Chart SmartPanel, the Org Chart Import dialog appears. 
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The Org Chart Import Dialog 

Field Parsing Options  

Get Field Labels from First Row: If your chart has labels such as "Name" "Title" etc., in 

the first row, SmartDraw can use them to identify the fields in the chart.  If it does not 

have field titles, uncheck this option. 

Show Labels in Org Chart – Allows you to display or hide the field labels (if any) in the 

finished chart. 

Field Separator – Allows you to specify the character that separates the fields in your 

data file, such as "comma, " "tab", etc.  (If the list of records to be imported, at the 

bottom of this dialog, looks jumbled, be sure to check that the right separator is 

chosen here.) You can place quotes around field data if you need to use your 

delimiter character (such as a comma) in that field.  

Record Sorting Options 

SmartDraw will try to detect the hierarchical sorting and select the appropriate 

option for you.  If it cannot, you can specify the sorting manually. The two options 

are: 

1) Assume Hierarchy from Indentation – If your file uses indentation (by any delimiter) 

to indicate hierarchy, select this option.  Example: 
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A file using Tab indentation 

 

2) Create Hierarchy by Matching – This is the traditional "Org Plus®" method, in which 

a name or ID number in each record is matched to a supervisor name or ID number 

in another record. Example: 

 

Matching Fields 

If you choose Create Hierarchy by Matching you must indicate which fields match 

to with which.   SmartDraw will try to figure this out for you.  If it cannot, you can 

manually specify the field matching using the drop-down lists. 

 
Choosing Fields to match for Import 

 
Matched fields ready for import 

Field Import Options 

You can choose whether any given field will be imported and, if so, whether it will 

be visible in the org chart. 
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Field Import Options 

 

Click on the colored arrow next to the field name on the gray header buttons to 

choose one of the three options for that field: 

View Field in Org Chart 

Hide Field in Org Chart 

Do Not Import Field   

You can also specify the font and color of the field names using the controls on this 

menu. 

Rules and Behavior of the Org Chart Import Function 

The Org Chart Import function interprets the data file according to the following 

rules: 

The import will delete any non-shape objects (such as images or symbols) linked to a 

Connector. 

If no Connector line is found in the document, SmartDraw will create a new one 

using a default box shape to contain the data records. 

The fields in each data record (unless hidden or not imported) will be stacked one 

atop another in the boxes. Each box is a Table, and each field occupies a separate 

cell in the table.  

An imported Org Chart always has the Automatically Space Boxes option (on the 

More menu of the Org Chart SmartPanel) turned on. 

Exporting Org Charts to Data Files 
The  Export Org Chart to Data function relies on many of the same functions found in 

the Import Chart from Data command (only in reverse), so a careful reading of that 

section will help you understand the export behavior. 
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This function is available only from the Export Chart to Data command on the 

Advanced Options menu of the Org Chart SmartPanel. 

Rules and Behaviors of the Org Chart Export: 

Exporting creates a text file with tab-indented hierarchy, commas as field 

separators, and a line break (CR\LF) at the end of each record. 

Each position (box) in the chart produces one record. 

Field Names are exported to the first record of the text file if any box in the chart has 

visible field names.    

All data fields are exported, with the following exceptions: 

If a field was globally hidden on import, it will be invisible in the chart, but appended 

as the last field in each record on export. 

If a box contains multiple rows of text with line breaks (CR\LF) between rows, each 

row will be exported as a separate field, as if it were in a table cell. If the text is 

simply one long string wrapped into several rows, it will export as one field. 

Empty table cells (fields) are exported as a delimiter. 

If a box contains no text and no table, it is skipped. 

If a document contains two or more separate org charts (separate Automatic 

Connector trees), only one will be exported at a time, either (a) the chart 

containing an object that is selected, or (b) if nothing is selected, the chart that was 

created first. 
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Symbol Libraries  

Symbol Library Windows 
SmartDraw contains hundreds of Symbol Libraries - ready-made collections of 

shapes, objects, and graphics that you can add to your drawings. 

Each type of drawing (flowcharts, maps, calendars, etc.) comes with its own unique 

set of symbol libraries. 

Symbol Library Windows 

A symbol library appears in a window containing icons that represent various 

symbols. 

An open symbol library window can appear in three different locations on your 

screen. 

- A small group in the SmartPanel 

- Docked in the Left Panel (the normal position) 

- As a Floating Window 

Libraries in the SmartPanel 

Diagram types that typically require the use of symbols and shapes have a Symbol 

Library Gallery in their SmartPanel, so this is the Library you will likely use most often.  

This Gallery will be customized to fit the specific needs of the diagram type.  For 

example, the Flowcharts Gallery has buttons along the bottom for adding a linked 

shape above, below, to the left, or to the right of the selected shape.   
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Some Galleries have Library Selector Drop Menus at the top (such as Flowcharts, 

although most galleries do not have the buttons along the bottom), while others 

have Library Selector Buttons (such as Landscape Design). 

You can open additional libraries using the More commands, either found as a 

button or a choice on the selector menu.  For more on this, see Searching the 

Symbol Libraries.  

Libraries Docked in the Left Panel 

Even if the SmartPanel does not have a library, the Left Panel still contains the Library 

tab. 
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You can open as many libraries as you wish.  To switch between them, click on the 

Library Selector Menu and select a different library.  To add a symbol from a docked 

library to your drawing, just click on it, then click in the work area to place it there. 

See also Searching the Symbol Libraries 

See also Adding Objects to Your Drawing. 

Floating Libraries 

A symbol library can "float" over your drawing area, allowing you to drag it from 

place to place. Up to 16 library windows can be open at the same time, each 

showing the contents of a different library.  

To make a library that is docked in the Left Panel float, right click in the library 

window and choose Detach Library.  
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Floating Library Window 

To re-dock a floating library, just drag it back to the Left Panel. 

  When you click the minimize button at the top right of the floating window, it 

shrinks the library to a minimized window at the bottom of your screen. This is useful if 

you want to temporarily move a library window out of the way without docking it at 

the side of the screen. 

Adding Symbols to a Drawing 

To add a symbol from a library to your drawing, click on one of the symbols in the 

open library then click in your drawing to add it there. Alternatatively, you can click 

and drag a symbol from the library into the drawing.  

Automatic Scaling of Symbols 
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Some symbols have the property of automatically re-sizing themselves based on the 

current ruler settings as they are added to a drawing.  For example, if a drawing has 

rulers set so that one screen inch is equivalent to 48 inches, then a 36-inch desk 

symbol will be sized automatically to be 0.75 inches when added to the drawing. 

This is useful in floor plans and other scaled drawings. See Changing the Settings for 

a Symbol. 

Removing a Symbol from a Library 

You can remove a symbol from a library by right-clicking on it in the library window, 

and then selecting Remove Symbol. 

Changing the Settings of Symbols in a Library 

You can permanently change the settings (properties) of a symbol in a library by 

right-clicking on the symbol and choosing Edit Symbol from the right-click menu. See 

Changing the Settings for a Symbol 

 

 

Automatic vs. Metafile Symbols 
 

Symbol Types 

There are two types of symbols in the SmartDraw Symbol libraries: Automatic and 

Metafile.  

Automatic symbols are native SmartDraw objects (such as the standard shapes 

found on the Home Tab). Metafile symbols are images in Enhanced Metafile Format 

(EMF) or Windows Metafile format (WMF). 

Both types have similar properties when added to a SmartDraw document: They 

can be rotated, flipped, colored, typed into, and manipulated in many of the same 

ways.  

But only automatic symbols have all the special properties of the native SmartDraw 

shapes, including the ability to be decomposed into freeform shapes.  
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Changing the Settings for a Symbol  
Each SmartDraw symbol has dozens of properties that you can customize using the 

Edit Symbol dialog. You can open this dialog for any symbol by right-clicking on that 

symbol in an open library window (not in the work area) and choosing Edit Symbol 

from the right-click menu. 

These properties include everything from the way the symbol can change color, to 

the way objects connect to it, the way text appears in it, the way it can be resized, 

and much more. 

 
The Edit Symbol Dialog 

Automatic Settings 

If Automatic Settings is checked in the Edit Symbol dialog, the symbol was originally 

created with SmartDraw and will behave as a native SmartDraw object when 

added to a drawing. You cannot override the properties of a symbol with 

Automatic Settings checked. 

If the box is unchecked, or if you uncheck it, the symbol behaves like an imported 

image. You can set its properties (width, height, resizing behavior and text entry). 

Symbols created in SmartDraw itself can be set to be either Automatic or non-

Automatic.  
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Symbols created outside SmartDraw cannot have automatic settings, so for these 

symbols the Automatic checkbox is disabled. 

Preferred Size 

The width and height fields in the Edit Symbol dialog control the size of the symbol 

when it is added to the page. If the Grow setting is Proportional, changing one 

dimension changes the other, to maintain the original proportions. 

This setting is disabled (gray) for automatic symbols composed of more than one 

native object, since their original size is always maintained. 

There are two ways to set the preferred size that a symbol takes when added to a 

drawing: Use Fixed Size and Scale to Ruler Settings. 

If Use Fixed Size is selected, the shape is sized to exactly the width and the height 

specified on the screen, regardless of the rulers’ settings for the drawing. Your 

Windows control panel sets the units of this measurement. If your system is set to use 

metric units the dimensions are in centimeters, otherwise they are in inches. 

If Scale to Ruler Settings is selected, the symbol will scale to the size dictated by the 

ruler settings of the drawing. For example, if you set the preferred size for the symbol 

to be 1.0 meter, and you add the symbol to a drawing with a ruler scale of 1.0 meter 

to the inch, the symbol will be drawn 1.0 inch long on the screen. However, if you 

add the symbol to a different drawing with a scale of 0.1 meters to the inch, the 

symbol will be drawn 10 inches long. 

Scale to Ruler Settings is useful for drawing scaled drawings like floor plans. 

Grow 

The four Grow settings in the Edit Symbol dialog control the way you can resize the 

symbol. These settings are inactive for Automatic symbols. 

Proportional drawings have only four growth handles (one at each corner) and 

maintain their proportions when re-sized. 

Horizontal Only symbols have two growth handles and can be re-sized only 

horizontally.  

Vertical Only symbols have two grow handles and can be re-sized only vertically. 

No restrictions allows the symbol to grow in all directions without maintaining its 

proportions. These symbols have the usual 8 growth handles on the four sides and 

four corners. 
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You can change these settings for a single instance of a symbol that is already on 

your page by clicking on the Dialog Launcher for the Shape Properties group on the 

Design tab.  Doing this will not change the master copy of that symbol in the library. 

Enter Text 

Using the Text settings in the Edit Symbol dialog, you can change the way text 

appears in a symbol. This text can be Inside the symbol as in the standard toolbar 

shapes, or Above or Below it. The fourth choice, No text, means that the symbol will 

not allow text entry at all. 

If Enter Text Inside is selected in the Edit Symbol dialog, four margin lines appear on 

the symbol Image window. These lines set the boundaries of the text area. You 

should adjust them to keep your text inside the symbol. 

You can adjust the text margin lines by clicking on the square handles at either end 

or dragging. By default, the lines are set to create the smallest text entry area 

possible. Drag them to expand it, but keep the text area inside the boundaries of 

the symbol. When text is entered Above or Below the symbol, the margin lines are 

ignored. 

The Text settings are inactive for Automatic symbols.  

Changing the Way Symbols Attach to Lines 

In the Edit Symbol dialog you can adjust the Attachment Point where the symbol 

would be attached to a line if placed on top of one. The attachment point looks like 

a hollow diamond (usually in the center of the symbol). You can use the Across and 

Down settings to place it by specifying a percentage from the top-left of the shape. 

Or you can manually drag the attachment point with the mouse.  

Grouped symbols cannot have Attachment Points. 

See also Modifying Connection Points. 

Adjusting Connection Points in the Image Window  

The image window in the Edit Symbol dialog shows the symbol image against a grid 

of green lines. A dotted border shows the edges of the rectangle that encloses the 

symbol. 

A non-automatic symbol  has 16 Connection Points. These are the points at which 

lines and other shapes will link to this symbol.  Automatic symbols don’t show the 

connection points because theirs can’t be adjusted. 
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Each line-linking Connection Point appears as a small black square, and when 

selected as a black circle. 

The Attachment Point appears as a small black diamond, and when it selected as a 

large black diamond. 

You can drag a connection point with the mouse to a new location within the 

boundaries of the shape, or you can type the four arrow keys to move one that 

you’ve selected by clicking on it..  

To be active, connection points must lie outside the text margin lines (whether the 

text setting is Inside or not). 

Adding and Deleting Connection Points 

You can delete a selected Connection Point in the Image window of the Edit 

Symbol dialog by typing the backspace or delete key. The Attachment point 

(diamond) cannot be deleted. 

You can add a new point by holding Ctrl while you click.  Each symbol can have a 

maximum of 16 connection points. 

Holding down Ctrl and using the arrow keys moves the selection from one point to 

another.  

Dragging a Connection Point outside the boundaries of the symbol deletes it. 

See also: 

Shape Connection Points 

Linking a Line to a Shape 

Change Colors 

Checking the Change Colors box in the Edit Symbol dialog allows SmartDraw to 

automatically change the fill color, line color, border color and other properties of a 

symbol the moment it is added to a drawing, in order to conform with an existing 

color scheme in that drawing.  

If Change Colors is turned off, the symbol behaves like an imported image. 

SmartDraw cannot adapt it to the color scheme of the existing drawing. For 

example, applying a border style places a border around the entire symbol but 

does not change the look of the lines making up the symbol itself, which cannot be 

overridden. Also, the symbol retains its original linking properties and other settings, 

instead of being overridden by the current default settings for that drawing.  
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When Change Colors is turned on, the color of the lines and borders follow the 

current Line Color setting. The fill follows the Fill Color. Transparent fills are not 

affected by the fill color. 

The substitution of colors for lines, fills etc. may not work for all symbols. If the symbol 

contains bitmapped images these may be unaffected by checking the color box. 

If you turn on Change Colors, you should experiment with a copy of the symbol to 

see how it is affected. If the result is unsatisfactory, return to the dialog and un-check 

the box again. 

When a symbol is set to Automatic, the colors and other properties will always 

change to adopt the current color scheme in the drawing. Only native SmartDraw 

shapes can have the Automatic setting. 

Symbol Name and Keywords 

Each symbol should have a unique name in the Edit Symbol dialog. The names are 

searched when you Search for symbols in the left panel. 

You can also assign keywords to symbols to help locate them in a search. Put a 

semicolon after the symbol name, then list your keywords, each separated by a 

space. Any words after the semicolon do not appear on the symbol buttons shown 

in the library window. 

You can add names in different languages, by dropping the language menu beside 

the name box. By default, the Search function will look for names matching the 

current language setting of your SmartDraw program. If a native name is not 

present, English is used. 

Adding New Symbols to a Library 
Adding Symbols from SmartDraw 

Adding new symbols to libraries is a simple Drag and Drop operation. Any object, or 

collection of objects, dragged from the SmartDraw page and dropped onto a 

library window can become a new symbol.  

  When you drag a symbol over an open library window, the cursor changes to 

the Library Drop Cursor. If you release the mouse button, the Edit Symbol dialog 

appears. The new symbol appears in the Image window. Pressing OK adds the 

objects to the library as a new symbol. 



SmartDraw 2009 User's GuideUser’s Guide Symbol Libraries ••••  176 

 

Before pressing OK, you should specify the settings for your symbol. You may want to 

leave them as is, but you should always give the symbols a unique name. For details 

on symbol settings, see Changing the Settings for a Symbol. 

Entire groups or arrangements of objects can be stored and retrieved in libraries as 

one unit, so you can use symbol libraries as a scrapbook for pieces of diagrams you 

might want to reuse. 

Adding a Symbol from Another Program to a Library 

You can use almost any Windows drawing program to create a new symbol. You 

first need to Copy the symbol to the clipboard in the other program using its Copy 

command.  

Then paste it on your page in SmartDraw, and drag it to an open symbol library in 

the left panel. 

Images from other programs cannot have Automatic settings. 

See Changing the Settings for a Symbol. 

Transferring Symbols between Libraries 
Copying a symbol from one library to another is a simple drag-and-drop procedure.  

Open the two libraries that you want to copy symbols between.  Place the symbol 

you want to copy on the page, and then drag it into the other library. 

Alternately, you can make one of the libraries float by right clicking in its 

background and choosing Detach Library. Then simply drag the symbol with the 

mouse from one library window to the other. 

  When releasing the mouse would result in copying the symbol to another 

library, the cursor will change to the Drop Library Symbol cursor. 

You can use this feature to collect the symbols you use most often into one or two 

libraries for easy access. You can also use it to sort the order of the symbols in the 

library by dragging them in the order you want to a new library. 

Sorting Library Symbols 

If you drag a symbol from one library to another it will enter the symbol sequence in 

the position where you drop it. 
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If you drag an object from a drawing directly into a library, it will appear at the end 

of the symbols sequence. 

You can rearrange the order of the symbols in a library by holding the Ctrl key while 

dragging them with the mouse from one location to another. 

Creating a New Symbol Library  
You can create your own symbol libraries by clicking the SmartDraw Button and 

clicking Create Library under Library. 

This opens the Create a New Symbol Library dialog. 

 
The Create a New Symbol Dialog 

Your library will be saved in the My Symbols folder in the Symbol Explorer Tree which 

appears in the left side of the More Symbols dialog.  This is the dialog you see when 

you Browse for more symbols using the More command of a Library Selector. 

 

 
You can create a sub-category in My Symbols by selecting the Create New 

Category button. The subcategory appears immediately in The Explorer Tree, and 

the new library opens as a floating library window above you drawing.  You can 

dock the floating library in the left panel if you like by dragging it there. 
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Your new library window, because it is empty, will have no symbol buttons. You can 

add symbols to the new library by dragging them from the page, from other 

SmartDraw drawings, or other symbol libraries. 

See Adding New Symbols to a Library 

See Transferring Symbols between Libraries 

The Library Builder Wizard  
The Library Builder Wizard converts graphics files in many popular formats into 

SmartDraw libraries. It can convert an entire folder of graphics files into one or more 

libraries, or even convert a file tree of many folders into many libraries organized into 

categories. 

The Library Builder Wizard is ideal for converting your clip art files into SmartDraw 

symbols. It can convert thousands of images in just a few minutes. 

Open the Library Builder Wizard by clicking the SmartDraw Button, then selecting 

Library Builder Wizard under Library. 
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The Library Builder Wizard 

The five steps to converting files in the Wizard: 

STEP 1: Choose the File Format 

Select the file format of the graphics files that you want to import. Files in scaleable 

formats like Windows Metafiles (WMF, EMF), Postscript, and AutoCAD formats make 

better SmartDraw symbols than non-scaleable bitmapped files like BMP, JPG and 

GIF. 

STEP 2: Select the Files to Convert 

Use the Browse button to select the folder containing the files you want to convert.  

You have two options in converting the files: 

1) Selecting Convert all of the files in this folder into one library, will convert any files 

specified in that folder into a new library with the same name as that folder. For 

example, if you are converting 20 WMF files from a folder called Garden Tools, these 

will be converted into one library called Garden Tools. 
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If there are more than 100 files in the folder selected, then two or more libraries will 

be created. They will be numbered: Garden Tools-1, Garden Tools-2 and so on. 

2) Selecting Convert all of the files in this folder’s subfolders into multiple libraries will 

convert any files of the selected type in the specified folder’s subfolders into 

separate libraries, each with the same name as their subfolder. 

For example, if the Tools folder is selected, and it contains three subfolders called 

Garden Tools, Garage Tools and Woodshop Tools, three libraries called Garden 

Tools, Garage Tools and Woodshop Tools will be created.  

If the subfolders like Garden Tools themselves contain subfolders, then files in these 

subfolders will also be converted into libraries with their subfolder name and so on: 

The whole folder tree starting with the folder selected will be converted into a 

matching tree of libraries. 

STEP 3: Select the Category for the New Libraries 

Use the Browse button to select the library category that will contain your newly 

created library.  For example, if you choose ClipArt & Flyers\Tools as the category, 

using our earlier example, the new library Garden Tools will be created in this 

category and will appear there as an icon in the symbol Explorer Tree. 

If you choose to generate a tree of libraries, by selecting Convert all of the files in 

this folder’s subfolders into multiple libraries in STEP 2, the whole tree will be added to 

the category you choose. 

STEP 4: Select the Symbol Properties 

You can also specify the properties of the symbols in the new library by clicking on 

the Properties button in STEP 4. This displays the Set Symbol Properties Dialog. 

 
Set Symbol Properties Dialog 
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You can choose how the symbols will grow, where text will be attached to it, and 

whether it will respond to color changes. These settings are explained in more detail 

in the Changing the Settings for a Symbol section. 

STEP 5: Convert the Files 

The final step is to press the Convert Files button to begin the conversion process. 

You can watch the libraries being built, symbol-by-symbol. Once the conversion is 

completed, the symbol Explorer Tree updates itself and expands to show the new 

libraries. 

Sharing Libraries on a Network 
Symbol Libraries can be shared by multiple users on a network.  

When a library is opened by more than one user, all users after the first one to open 

the library view it as read-only.  

Only the first user to open the library has write permission. Read-only libraries cannot 

be edited, and symbols cannot be added or removed. 
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Drawing Freeform Shapes and 
Lines 

Drawing Freeform Lines and Shapes  
You can use freeform drawing to create lines or shapes of any design you like.  

There are two freeform drawing tools found under the Line Tool on the Home tab. 

  The Freehand Line 

  The Polygon Line 

 
See The Polygon Line Tool 

See The Freehand Line Tool 

The Polygon Line Tool 
  The Polygon Line Tool draws a line or shape consisting of continuous straight line 

segments.   

Select the Polygon Line from the Line Tool menu on the Home tab.  
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Then click in the drawing area to start your first segment. Move the mouse to the 

point where you want that segment to end, and click again.  

Continue this process, adding a new segment for each point that you click.  

 
Drawing with the Polygon Tool 

You can terminate the drawing operation by clicking with the right mouse button, 

typing the Escape Key or by double-clicking. If you double-click, the end of your 

line is automatically joined to the beginning to make a closed shape. If you right-

click or hit Escape, the ends of the line are not automatically joined unless you 

specifically click on the starting point of the line. 

 
A Closed Shape and a Freeform Line 

Each segment in the line or shape you draw with the Polygon tool is initially a straight 

line with a diamond-shaped adjustment handle in the center. If you click on the 

adjustment handle you can drag the segment to become a parabolic curve.  

You can also click on the square growth handles at the end of each segment and 

change the shape of your object. Using these handles, and some of the 
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additionaloutline-modification properties, you can draw just about any kind of 

shape or line. 

 
Using the Adjustment Handles 

The Freehand Line Tool 
  The Freehand Line tool draws a line or shape consisting of a smooth continuous 

line.  Using this tool is like drawing with a pen. 

Select the Freehand Line from the Line Tool menu on the Drawing Area Toolbar.  

 
Then click in the drawing area to start your line. Draw with the mouse while holding 

the left button down as if you were using a pen.  You can make sharp corners or 

smooth curves. To stop drawing, release the mouse button. 

Continue this process, adding a new segment for each point that you click. 

 
Drawing with the Freehand Line Tool 

SmartDraw automatically smoothes the line you draw to fit a series of curved line 

segments.   

To draw straight line segments hold down the Shift Key while you draw. Releasing 

the key restores the pen to its continuous drawing mode. 
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If you return to your starting point, the line will join to create a closed shape, which 

can be filled with color like the other geometric shapes available on the toolbar. 

Joining Freeform Lines to Each Other 
You’ve seen that the Freeform line tools can be used to draw continuous lines or 

even closed shapes. 

But what if you have an existing line already on the page that you want to join (not 

link) to another to create a continuous line?  Or to close a shape?  Or if you want to 

use one of the other line tools (straight line, curved line, etc.) to draw a closed 

shape? 

For existing lines, or non-freeform lines, to be able to join continuously or create close 

shapes, you must turn on Allow Lines to Join in Options under the SmartDraw Button. 

 

When this setting is turned on, and when your mouse is positioned so that one 

line segment will join to the end of another, a circle appears around the end of the 

pen cursor. 

 
If you click and draw at that point the new line will be joined to the previous one. 

You can join one line to another in two ways: 

While you draw the second line (as shown above). 

By dragging the end handle of one existing line to the end handle of another. 

If you drag the end handle of a multi-segment freeform line to its own other end you 

create a closed shape. 
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Freeform lines can be composed of four kinds of segments depending on the line 

tool you use to draw each section. 

Straight Lines are drawn with the straight line tool or Shape Connector Tool. 

Circular Curves are drawn Curved Line Tool. 

Parabolic Curves are drawn with the freeform drawing tools. 

Quarter Ellipses are drawn by right-clicking on the line segment and using the 

Change Line Segment Shape command on the right-click menu to select a Quarter 

Elipse. 

 
The Freeform Line Segment Types 

 

By using combinations of these line types and adjusting them with the adjustment 

handles, you can shape a line just about any way you want. 

You can always change any segment to one of the other shapes by right-clicking 

on the line segment and using the Change Line Segment Shape command on the 

right-click menu 

Separating Joined Lines 

You can detach joined lines by right-clicking on the freeform line and using the Split 

Into Two Lines command on the right-click menu. The line is split at the corner growth 

handle adjacent to the point at which you clicked. 

If you’ve joined your line into a closed shape, to separate it you must select it then 

use Edit Shape Outline under Change Shape of the Design tab.  Once you have 

clicked Edit Shape Outline, you can right click on the line as before and select Split 

Into Two Lines. 
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Creating Closed Freeform Shapes 
When drawing with the  Freeform Line tools, if you connect the end of the freeform 

line to its starting point, the shape becomes closed. (If you hold the Ctrl Key down 

this automatic closing feature is overridden). 

You can also close an existing freeform line into a shape by selecting it, then clicking 

on the growth handle at one end and dragging it with the mouse to connect to the 

other end.  In addition,  if Allow Lines to Join is turned on, you can also connect the 

ends of a line by drawing a new line segment between them to close the shape. 

 When your line is ready to join another, the cursor changes to the Join Line 

cursor, with a circle around the end of the pen. 

 
Joining the Ends of a Line to Make a New Shape 

 

You can continue to adjust the outline of a shape created this way by clicking on its 

growth handles and adjustment handles while it is selected after closing it. 

Like other shapes, you can type into it, fill it with colors, and change the 

appearance of its border and so on. 

You can also edit the outline of the shape by using the Edit Shape Outline command 

from Change Shape of the Design tab. 

See Drawing Freeform Lines and Shapes. 

See Editing the Outlines of Shapes 
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Flexible Reshaping of Freeform Shapes 
Closed freeform shapes (technically called polygons) have a unique reshaping 

property that is not available on other, simpler shapes. 

When selected, a freeform shape has an extra set of growth handles, called 

reshaping handles, which appear as black diamonds, one in the middle of each 

segment of the polygon. (For curved segments, the diamond appears on the 

imaginary straight line between the two ends of the segment). 

 
Additional Reshaping Handles on Freeform Shapes 

 

The reshaping handle allows that side of the shape to be extended in a direction 

perpendicular to the side of the shape. 

This reshaping property allows you to extend one "wing" or protuberance of a shape, 

and without distorting the proportions of the other parts of the shape. 

As an example of how this may be useful, consider the floor plan of an L-shaped 

room.  If you want to extend one wing of the L shape without altering the other 

wing, you can pull on the diamond reshaping handle to extend the desired section 

without altering the other part of the room. 

 
Reshaping one part of a freeform shape 

 

This reshaping behavior is unique to polygon shapes created with the Freeform 

Drawing Tools, or by editing the outline of the standard shapes found on The Work 

Area Toolbar, which turns them into freeform polygons. 

See Drawing Freeform Lines and Shapes. 
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Editing the Outline of Shapes 
 

You can edit the outline of any of the standard shapes found in the Shape Tool on 

theHome Tab, or any shape created using the Freeform line tools. 

To edit the outline of a shape, select the shape and then use the Edit Shape Outline 

command on the Change Shape menu of the Design tab.   

If the shape was created with freeform drawing (or has been edited before) you 

can also click on the border of the selected shape with the Ctrl Key held down as a 

shortcut outline-editing mode.  

Control Points appear at the junctions of the outline segments, and Curve 

Adjustment Handles appear on or near each curved segment. 

 
Edit Shape Outline 

During the editing session, any text inside the shape is hidden, and if the shape has 

been rotated or flipped it reverts temporarily to its "remembered" original orientation.  

It will return to its proper orientation when the editing is finished. 

You can adjust the outline of the shape by dragging the control points and 

adjustment handles with the mouse. You can also add and remove controls points, 

and change the shape of the individual line segments, as described below. 

Inserting New Line Segments in Freeform Shapes 

When you are Editing the Outline of Shapes, if you right-click on a segment of the 

shape, a menu appears. The command Add Control Point on this menu divides the 

segment at the point of the right-click into two line segments by adding a new 

control point. You can also add control points by holding down the Ctrl Key and 

clicking anywhere on the outline. 

 
Inserting a Line Segment by creating a new Control Point 
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Removing Line Segments 

When you right-click on the outline of a freeform shape, you can choose the 

Remove Line Segment command. This does not leave a gap in the side of the 

shape; it simply removes the control point at the end of the segment, and the shape 

closes to fill the gap. This is the reverse of inserting a segment. Alternatively, you can 

remove a control point (the black square at the junction of two segments) by 

selecting it with a Ctrl-click and typing the Delete Key. 

 
 

Changing the Shape of Line Segments 

When you right-click on a line segment in a freeform shape, you can modify the 

shape of that segment by choosing from the list of four shapes under Change Line 

Segment Shape: 

Parabola 

Circular Arc  

Quarter of an Ellipse 

Line 

All freeform shape outlines are made up of these four basic types of line segments.  

Curves drawn with the freeform drawing tools are made of parabolas by default. 

Outlines drawn with the other line types may consist of any combination of these 

types.  
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A Freeform Shape Using Circular Arcs 

 

Quarter-ellipses are good for making 90-degree curves. 

 
Editing Shapes Using Quarter Ellipses 

 

Changing a Freeform Shape Back to a Line 

When a shape is already in the outline-editing mode, right-clicking on it reveals the 

Split Into Two Lines command. This breaks the closed shape into a line (shaped 

exactly like the shape was), deleting any text it may contain, and removing any 

properties (such as fill color) unique to closed shapes.  

Shortcuts for Editing Shape Outlines 
There are several Ctrl Key shortcuts for editing the outlines of freeform shapes: 

Entering Outline Editing Mode 

Holding down the Ctrl Key and clicking on a shape that is already selected will put it 

into outline editing mode without the use of the Edit Shape Outline command, as 
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long as the shape was created with freeform drawing, or has been in an outline-

editing mode before.  

Adding Control Points 

Holding down the Ctrl Key and clicking on a shape that is already in outline-editing 

mode adds a new control point at that location.  

Selecting and Deleting Control Points 

In Outline Editing Mode, Ctrl-clicking on a control point (the black square handle at 

the junction of two segments) selects the control point. Selected control points are 

green. Typing the Delete Key removes the selected control point.  

See Editing the Outline of Shapes 

See Drawing Freeform Lines and Shapes 
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Viewing and Printing  

The Drawing Area 
If you are running Windows 2000, XP, or Vista, the SmartDraw work area or "page" is 

actually a huge space that can accommodate a drawing up to 100,000 by 100,000 

inches.   

If your drawing requires only a single page, you may never see the additional 

pages, which appear when an object extends or is placed beyond the edge of the 

first page. 

You can define the size and properties of the drawing area using the Work Area 

command on the Page tab.  
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The Set Work Area Dialog 

The drawing area is divided into "tiles" (single pages) equal in size to the printable 

area of the printer paper currently selected.  The tile in the top left corner is page 1, 

and the pages are numbered consecutively to the right before wrapping to the 

second row. In the preview, pages used by the drawing are shown in white, and 

unused pages in gray. 

Remove Blank Pages deletes any empty pages and moves the drawing to the top 

or left of the occupied area.  

You can choose whether to define the drawing area in inches (or centimeters if your 

rulers are set to metric units), rather than pages, by checking the appropriate box. 

Otherwise the drawing area is a multiple of whole pages. 

Under Windows 95, 98 and ME, the box labeled Limit the image size to 50x50 Inches 

is automatically selected, since the drawing area can be no larger than this.  Under 

newer operating systems, you can check this box if you want to limit the size to 

50x50, perhaps in order to exchange drawings with users of old operating systems. 
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If Allow the drawing area to grow automatically is checked, then each time an 

object in your drawing is placed outside the current boundaries, a new page is 

added to accommodate it. 

See Portrait vs. Landscape Pages. 

See Setting the Page Margins 

Portrait vs. Landscape Pages 

  You can change the way your drawing prints on a page from tall (portrait) to 

wide (landscape) using the Orientation command on the Page tab. 

Setting the Page Margins 
If your drawing occupies more than one page, an ideal printer would print to the 

edge of each sheet of paper so that the drawing could be pieced together 

afterwards to form one continuous sheet. However, almost all printers have a gap, 

between ¼ inch and ½ inch, at the edge of each page, into which they cannot 

print. SmartDraw takes this margin into account. 

You can set the margins for each page of your drawing by clicking Margins on the 

Page tab. You can choose a fixed amount for each edge of the page or choose to 

use the minimum margins possible for your particular printer.  

 
The Margins Menu 

Clicking Define opens the Page Setup Dialog. 
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This minimum setting is the best choice when you want to paste multiple pages 

together to make a large chart. 

Fixed margins are the best choice when you choose the Print on One Page option. 

This lets you control the margins for your single page of output. 

Changing the View (Zoom) 
  The View is the magnification at which you view the drawing area.   You 

control the View using the Zoom Tool found on the Work Area Toolbar. 
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You open the View Settings menu by clicking on the % figure next to the Zoom Tool 

icon.  

The settings Fit to Window, Fit to Page, 50%, 75%, 100%, 150%, 200%, 400%, and 

Custom… control the View. 100% shows objects at their natural size. The other 

settings make objects look smaller or bigger than they really are.  

Choosing Custom... opens the Set Window Zoom Dialog. You can use this to set the 

scale to any values between 5% and 1000%. 

 
Set Window Zoom Dialog 

Since all SmartDraw drawings can occupy an extraordinarily large area, unless your 

drawing is very large you normally work only with a small part of this potential area, 

up in the top left corner. Page 1 is the top-left page in the drawing area.  

 If your drawing requires only a single page, you may never see the additional 

pages, which appear when an object extends or is placed beyond the edge of the 

first page. 

The Fit to Page selection scales the window to show at least one complete page. 

Fit to Window will scale the view of your entire drawing, no matter how many pages 

it may contain, to be displayed within the work area onscreen.  

These Zoom settings have no effect on the size of objects in the drawing when they 

are printed out, only as viewed on the screen. 

As you change the view, SmartDraw attempts to keep all of your objects in the 

visible part of your window. If this is not possible, it tries to keep all selected objects in 

view. If this is not possible, it tries to keep the center of the selected set of objects 

centered in the window. 

Zoom by Clicking 

  You can quickly change the magnification by clicking the Zoom tool icon, then 

clicking in the page to zoom in, or right-clicking to zoom out.   
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See also Setting the Ruler Scale. 

Setting the Ruler Scale  
 

 For some drawing types, rulers automatically appear along the top and left edges 

of the work area.  For other types they are hidden.  In either case, you can show or 

hide the rulers by clicking Show Rulers on the Page tab. 

 

Changing the Ruler Scale 

You can change the ruler scale by clicking Scale on the Page tab and selecting a 

scale from the menu. 

 
There are four ready-made options and a Custom command to define your own 

scale. The Floor Plan settings use the standard scales for floor plans. 

Standard - One drawing inch equals one inch on the screen. 

Floor Plan (Standard) - 4 feet in the drawing equals one inch on the screen. 

Metric - One drawing cm equals one cm on the screen. 

Floor Plan (Metric) - 0.5 meters equals one cm on the screen. 

The Custom option opens the Set Rulers and Grids dialog. 
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Set Rulers and Grid Dialog 

Entering a value for Show sets the ruler scale, in units per inch or centimeter on the 

screen, depending on which setting you choose. 

You specify the number of subdivisions per inch or centimeter using the drop-down 

list in the Divisions box. 

The rulers can be hidden by checking or un-checking the Hide and Show checkbox 

in the dialog.  This has the same effect as the equivalent command on the Page 

tab. 

Set the position of 0 on the rulers (the origin) 

You can set the origin (the zero point) of the rulers, by specifying the distance from 

the top left corner of the page. 

Alternatively, you can set the origin manually by holding down the Ctrl key and 

clicking the ruler at your desired zero-point, or by double-clicking the ruler at that 

point. 

Double clicking in the small square at the top left where the rulers intersect resets the 

origin back to the top-left. 

Ruler Guides 
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Clicking in a ruler displays a temporary dotted line, called a Guide, which follows the 

position of the cursor. This can be used to measure the position of an object in the 

drawing, or to see if two objects are aligned. Clicking in the upper left corner, where 

the two rulers meet, and then dragging the cursor into the drawing area, displays 

two of these lines as a cross-hair guide.  

Snaps 

The Snaps setting, at the bottom of this dialog, controls the way objects align 

themselves with the grid. In some types of drawings (like flowcharts) center snapping 

is best, while in others (like floor plans) edge snapping is best.  By default the snaps 

are set appropriately based on the type of drawing template you opened, so 

change them with caution. 

Coordinates in Status Bar 

The Status Bar in the lower-right corner of the document window displays the X and 

Y coordinates of the cursor, and the dimensions of any currently selected shape, in 

the units of the ruler. 

 
The Status Bar 

Printing 

  To print your document, click the Smartdraw Button at the top left of the 

program window, then click Print. This opens the Print Dialog where you can specify 

how to print your drawing. 

Printing Multiple Page Drawings 

Although SmartDraw has a very large potential Work Area, it prints only those pages 

that your drawing actually touches. If your drawing lies completely within one page, 

only that page is printed. If your drawing extends across a page boundary, it is 

printed on two or more pages.   
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Multiple Page Drawing 

In the illustration above, four pages are printed, marked 1, 2, 3, and 4. The top-left 

page of the array of pages that contain the drawing is printed as page 1. The 

remaining pages are then printed, starting with the page to the right of page 1, and 

proceeding from top left to bottom right across each row. 

When a page range is specified in the Print dialog, the page numbering follows this 

scheme. For example, to print the bottom right page only, in the example above, 

you would specify a range of page 4 through 4. 

SmartDraw takes the page margin settings into account and shows the printable 

area of each page with dotted lines on your screen. 

Printing on One Page 
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Even if your drawing takes up more than one page on the screen, you can still print 

it on one sheet of paper by checking the Print on One Page box inThe Print Dialog.  

Printing Large Diagrams and Posters 
By checking both the Print on One Page and Scale Up to Fit Page boxes in thePrint 

Dialog, you can print your drawing at nearly any size, if you have access to a large-

format printer 

Page Setup 
The Define command, on the Margins menu of the Page tab, opens the Page Setup 

Dialog, where you can specify the properties of your pages. Many of the settings are 

identical to those in thePrint Dialog.  

Page Setup includes: 

Page orientation 

Paper size 

Printer 

Printer properties 

Printing Options  

Page Margins 

Print to Large Format 

The Page Setup properties are unique to each drawing. If you change a printer 

property using this command it will affect only the current drawing. Changes will 

have no effect on any other program, any other drawing, or on the global printer 

settings. 
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The Page Setup Dialog 

Printer Settings 

The printer assigned to a particular drawing may be either the Default or a Specific 

printer. You select the Name of the printer using the drop-down list. 

The Default printer is the one currently specified in the Windows Control Panel. If the 

printer assigned to a drawing is set to the default, its assigned printer changes to the 

new default each time you change the default printer in Windows, either by using 

the Control Panel or by moving the drawing to a different computer. New drawings 

are set to the default printer when they are created. 
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If you assign a Specific (non-default) printer to that drawing, then the next time you 

print that drawing, the same printer will be selected. If this printer is no longer 

available, you are prompted to select another. 

See Setting the Page Margins 

Overlap 

Checking the checkbox marked Allow 1\6" Overlap... causes a small strip of each 

page to be printed again on the pages that surround it (on multiple page 

drawings). This makes it easier to paste together the pages of large drawings.  

Options 

Selecting the checkboxes in the Options section allows you to define preferences for 

printing your drawing.  For more information on printing your drawing and applying 

these options see The Print Dialog section. 

Print Preview 

  The Print Preview command on the Document group of the Main Toolbar 

displays a preview of how your document will look when printed. 

Multiple Page Previews 

If your drawing will print on more than one page you must scroll down to see each 

additional page.  The page indicator at the top left of the preview window say 

"Page 1 of 2, " for example, to let you know which page you are viewing. 
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Print Preview Mode 

The command buttons in the Preview Window are: 

Print - Opens the Print Dialog to print the drawing. 

Page Setup - Opens the Page Setup dialog. You can use the Page Setup dialog to 

change the size and shape of your paper and immediately see the results in the 

Print Preview. You can also test the Print on One Page option and see the results on 

the preview. 

Orientation - Switches the page orientation to Portrait or Landscape. 

To leave the Print Preview mode, click the Close button (x) on the same bar as the 

command buttons. 

The Print Dialog 

  Clicking Print under the SmartDraw Button of the Main Toolbar opens the Print 

Dialog, where you can specify the printing properties of your document and send it 

to the printer. 
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The Print Dialog 

Selecting the Printer 

The name of the currently selected printer appears in the Printer box at top left. You 

can switch to a different printer using the drop down list. 

Selecting the Range of Pages to Print 

All - Prints all pages that contain the drawing. Extra blank pages (if any) will not print. 

Pages - Prints a range of pages specified by their page numbers. 

Selection - Prints only the pages that contain selected objects. 

Printing Multiple Copies 
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You can print multiple copies of your selected pages by entering the number in the 

Copies field. 

Print on One Page 

Checking this box causes the entire drawing to be scaled down and printed on a 

single page. This affects only the printed drawing, and will not change the view of 

the drawing on your screen or the size of the actual drawing. 

Scale Up to Fit Page 

Checking this box enlarges the drawing to fill the printable area of the page. If you 

have a large format printer, you can use this print poster size images. 

Print to Scale 

Checking this box allows you to specify a scale for printing your drawing.  This is 

particularly useful for scaled drawings such as floor plans.  Using this option opens 

the Set Printing Scale dialog: 

 
The Set Printing Scale Dialog 

You have the option to (a) scale your drawing by a percentage, (b) specify the 

scale in printed inches per drawing ruler-inch, or (c) fit the drawing to a fixed 

number of pages. 

The scaling percentage can be a minimum of 1% and a maximum of 1000%. 

Print Page Footers 

Checking this box prints a footer showing the name of the drawing, the number of 

the page, and the current date and time at the bottom of each page. 

Define Footer 
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This button only appears when the Print Page Footer box is checked. Pressing it 

opens the Define Footer Dialog. 

 
The Define Footer Dialog 

Position specifies how far above the bottom of the page to print the footer. 

Font displays the standard Windows Font Dialog, where you can specify the style 

and size of the text. 

Print the Grid 

Checking this box causes the (normally invisible) Grid to print on the page with your 

drawing.  On color printers, the grid will print in green. 

Print to File 

Checking this box causes the printed image of the drawing to be stored in a file on 

disk instead of being sent to the printer. 

E-mailing a Drawing 

  You can e-mail a drawing directly from SmartDraw without having to leave the 

program. 

Select Email from the SmartDraw Button.  

Your default e-mail program will automatically open with the drawing attached.   
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Publishing To The Web  

Exporting to HTML Files 
You can export your drawing to HTML files ready for web posting. Any hyperlinks in 

the drawing will remain active in the HTML files. 

To export, choose HTML File from the Publish command under the SmartDraw Button.  

This opens the Export to HMTL Files Dialog. 

 
The Export to HTML Files Dialog 

When SmartDraw exports to an HTML file it also includes a GIF, PNG or a JPG file with 

the same name followed by _img.  

For example, if you export to Flowchart.htm, a bitmapped file called 

Flowchart_img.gif (or png or jpg) is also created. You must upload both files (using 

any FTP software of your choice) to your web server in order to view the exported 

image in a web browser. You should always upload all of the files that SmartDraw 

places in your selected export folder. 

If you check the Include Hyperlinks box when exporting to HTML files, any hyperlinks 

you’ve created in your drawing are preserved, including links to non-html 

documents, files, and programs. You are responsible for making any necessary 

hyperlinked files available on your web site. 
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Exporting to a Bitmap File 
An alternate method of publishing your SmartDraw document to the web (instead 

ofHTML files) is to export it as a web-compatible bitmap image (such as JPG) and 

then embed that image in an HTML file of your own creation. 

You can export a bitmap file using the Export command under the SmartDraw 

Button. Select the type of file you would like to export to from the menu. 

Most web browsers will display only GIF, PNG and JPG formats. When you export to 

a bitmap you are presented with the The Export Bitmap Dialog where you can set 

the parameters of your image. 

See The Export Bitmap Dialog 

The Export Bitmap Dialog 
SmartDraw can export many bitmapped file formats including BMP, TIFF, GIF, JPG, 

PNG, and others. All of these formats represent an image as a pattern of colored 

dots, called a bitmap. 

The number of dots per inch is called its resolution. The number of different colors 

that each dot can represent is called its color depth.  The greater the resolution and 

color depth of a bitmap, the better it looks, but the more memory and disk space it 

occupies.  

When you prepare to save your exported image, you first name it in a dialog much 

like a Save dialog, then the Export Bitmap Dialog appears: 



SmartDraw 2009 User's GuideUser’s Guide Publishing To The Web ••••  211 

 
Export Bitmap Dialog 

You can specify the width and height of the bitmap in pixels (dots), screen inches, or 

printer inches. Separately, you can specify the color depth, but your options there 

may be limited by the type of format you are exporting. 

Since bitmaps don’t scale well after they are created, you should export the image 

at the size you actually plan to use it. 

For example, if you are exporting your drawing as a GIF for a web page, and you 

want the web image to be 400 dots (or pixels) on the screen, then enter 400 in the 

first row of the Width Column. The other width and height values will all change 

accordingly. The height changes because the drawing is always scaled 

proportionally. 

You can specify the Maximum Colors from the drop-down list at the bottom.  

However, many image formats have specific color depths that you can’t change. 

For example a GIF always has 256 colors. 

The dialog shows the memory (RAM) required for the exported image. If this number 

exceeds 32,000 most systems will not be able to export the bitmap. If you have 

trouble exporting large bitmaps, try shutting down other programs to free up 

additional memory, or reduce the resolution or color depth. 

GIF Export Options 

When exporting a GIF, you have the option to specify a background color that will 

become transparent when viewed with most web browsers. You can also choose 
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between interlaced and non-interlaced formats. Interlaced images display more 

quickly than non-interlaced, but take longer to come into focus.  

To set these options, click the Transparent button at the bottom of the Export GIF 

dialog, to open the GIF Format Options Dialog.  

 
GIF Format Options Dialog 

Hyperlinking to Files and Web Pages 

  By using the Hyperlink command on the Insert tab, you can hyperlink objects 

in your SmartDraw drawing to: 

Another SmartDraw drawing file 

A web address (URL) 

Another program’s document (such as a Word document) 

A program command line (to run a program) 

To create a hyperlink, Select the text or object on the page that you want hyperlink 

and then choose Hyperlink from the Insert tab.  

This opens the Hyperlink Dialog. 
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The Hyperlink Dialog 

Specify the type of file or location you want to link to in Type of Link. 

Enter the file name, web URL, or program command line in the box at the top. You 

can use the Browse button to search for a particular file on your computer. 

The Appearance of Hyperlinks in Your Drawing 

Hyperlinked text appears blue and underlined. However, this formatting will not 

show when you print the document or export to standard graphic formats (unless 

you use the Publish to Web function with hyperlinks preserved). Clicking on the blue 

text in the drawing opens the linked file or URL. 

 
A Text Hyperlink 

Hyperlinked Shapes, Lines and other Objects display a small blue box containing a 

plus sign (+). 

 
The Hyperlink Symbol 

Clicking on this symbol opens the linked file or URL. 

You can edit or remove a hyperlink by selecting it and choosing Hyperlink from the 

Insert tab. 

For more information on hyperlinking, see Using Hyperlinks. 
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Using Hyperlinks 
Nested Drawings 

You can use hyperlinking to create hierarchical or "nested" drawings that let you 

"drill down" for more detail. 

For example, suppose you are creating a flowchart for a process that includes one 

very complex step. On your summary (or high-level) flowchart, you can represent 

the complex step by a single shape and then hyperlink the shape to a detailed 

flowchart illustrating the complex process.  

Creating Web Sites  

You can use hyperlinks between drawings to create a parallel set of interlinked web 

pages (essentially a complete web site). If you check both Include Hyperlinks and 

Also Export other SmartDraw drawings linked to this one in the Export to HTML Files 

dialog, SmartDraw will export all of the linked drawings as a set of interlinked web 

pages. 

Web Site Mapping 

The ability to hyperlink a symbol to a web page URL makes it easy to draw a 

flowchart representing the structure of a web site. Each symbol in the drawing can 

be linked to the web page it represents. 

When you export the drawing to HTML, the hyperlinks stay active and you have a 

clickable map of the web site. 

Hyperlinking Notes and Background Information 

You can attach a page of notes to any object in your drawing by hyperlinking to a 

word-processing document.  For example, in a network diagram, you could attach 

a document that shows the make, model, serial numbers, and history of a given 

piece of hardware, linked to its symbol in the drawing. Clicking on the symbol opens 

its document. 

Limitations to Hyperlinking 

Hyperlinks to programs and documents located on your computer are not retained 

when you export the drawing to HTML.  These links are only present when viewing 

the drawing in the SmartDraw Program.   

If you want to create hyperlinks to documents and programs in your HTML 

document, the document and\\or program needs to first be available on the 

website.  Once the files are available, obtain the web page address 
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(http:\\\\www. ) and use this address in combination with the "Web Page" 

hyperlink. 

Using SmartDraw with MS Word, 
PowerPoint and Other Programs 

Inserting Drawings into to Microsoft Word  
The instructions below for transferring drawings into Microsoft Word also apply to 

PowerPoint, Excel, the other MS Office Suite programs, and many other software 

programs as well. 

 

Copy and Paste 

The easiest way to transfer SmartDraw drawings to Microsoft Word is to simply copy 

the drawing in SmartDraw (using the Copy command on the Edit tab) and then 

paste it into an open Word document. 

Using the Export Commands in SmartDraw 

Alternatively, you can export your SmartDraw drawing into Word or other Office 

programs using the buttons on the Export tab in SmartDraw.  Exporting this way 

automatically opens the Office program and then inserts your SmartDraw drawing 

into a new document in that program. 

The Quick Export Buttons at the top left of the SmartDraw program window provide 

a shortcut to exporting to Office, and to PDF (Adobe Acrobat) documents. 

Using the Insert Command in Word 

You need not actually run SmartDraw at all in order to insert a SmartDraw drawing 

into a Word document (or a PowerPoint slide, etc.) Word has an Insert Object 
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command on the Text group of its Insert tab. You can use this command to insert a 

SmartDraw drawing directly into your Word document.  

When you use the Word Insert Command, Word automatically launches SmartDraw 

so that you can select, modify, or create the drawing your want to insert. 

When you opt to insert a New Drawing, the last type you picked from the Create 

New Document screen in SmartDraw is created by default.  

Drag and Drop 

You can also drag selected parts of a drawing from SmartDraw into Word or other 

office programs. Unless you hold down the Ctrl key while you do this, the selection 

will be deleted from the drawing after it is transferred to Word. This conforms to the 

standard Windows conventions. 

See also Understanding OLE (Object Linking and Embedding) 

Understanding OLE (Object Linking and Embedding) 
Because Word (and all Office Programs) is an OLE Client and SmartDraw is an OLE 

Server, Word stores all of the SmartDraw drawing information in its document when 

you paste, not just the picture you see. This is called Embedding. A copy of your 

SmartDraw drawing is embedded in the Word document. 

If you double-click on the SmartDraw drawing in Word, it will re-open in SmartDraw 

and you can edit it.  

An alternate way of transferring a SmartDraw drawing to Word is to Copy the 

drawing in SmartDraw and then paste an OLE Link using Word’s Paste Special 

command. If you choose to paste a link, the picture you see is transferred to Word 

along with the name of the SmartDraw file it came from - but not the entire 

SmartDraw file itself. 

If you double-click on the linked SmartDraw drawing in Word it opens the original 

SmartDraw file allowing you to edit it, just as with an embedded drawing. OLE 

Linking is useful if you want just one copy of your drawing to be shared between 

several documents. When you embed a drawing, changing the embedded copy 

does not change any other copy. When you paste an OLE link, changing the 

original drawing changes all the linked copies of that same drawing, even if they 

are in multiple documents. 

See also Editing OLE Objects that have been Inserted into SmartDraw 
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Inserting Drawings Into PowerPoint, Excel, and Other 
Programs 

Inserting SmartDraw drawings into Microsoft PowerPoint, Excel, and any other OLE 

Client programs, works exactly as described in the section about Microsoft Word.  

Transferring Objects from Word, Excel, and other 
Programs to SmartDraw  

In addition to being an OLE server, SmartDraw is also an OLE Client, (just like Word, 

PowerPoint, Excel, etc). 

This means that when you paste images from other programs that are OLE servers 

(such as Word, PowerPoint, Excel, etc.) into SmartDraw, they become embedded or 

linked OLE objects that can be re-opened and edited by their parent programs. 

For example, if you paste a graph from Excel into a SmartDraw drawing, both the 

image of the graph and the underlying Excel file structure are stored in the 

SmartDraw drawing. Double clicking on the graph in SmartDraw opens it again in 

Excel for editing. 

On the SmartDraw page, the images you paste from Office behave just like 

SmartDraw library symbols. You can link lines to them, flip them, rotate them, and 

resize them.  

OLE Objects in SmartDraw Libraries 

If you add an OLE object from another program (such as Excel) to a SmartDraw 

symbol library, it retains its OLE nature and its connection to the parent program. This 

way you can create libraries of live objects that can be opened and edited in their 

parent programs while remaining stored in SmartDraw for future use. 

OLE objects from the following programs can be inserted into SmartDraw using the 

Insert tab and its More menu in SmartDraw: 

MS Word 

MS Excel 

MS PowerPoint 

MS Graphs 
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MS Equations 

MS WordArt 

Prism Graphs 

Insert Object - Allows you to select an OLE object to insert from any one of the 

countless other OLE server programs. See Inserting Objects Into SmartDraw with the 

Insert Command 

See also Editing OLE Objects that have been Inserted into SmartDraw 

Editing OLE Objects that have been Inserted into 
SmartDraw 

When you have inserted an Object from an OLE server program (such as Microsoft 

Word, Excel, Graph, etc.) into your drawing, it remains a live OLE object linked to its 

source program. 

You can re-open the object from within SmartDraw, so that any changes you make 

to it in the original program will be updated in your SmartDraw drawing. 

To edit the OLE object, select it on your page, then click Objects on the Design tab 

and select Open.  

This will open the object in its source program for editing. When you exit that 

program the changes will be updated in the SmartDraw drawing. 

You can also open the object in its source program by double-clicking on it in 

SmartDraw. 

Converting an Embedded OLE Object 

You can convert an embedded OLE object from another program to a different 

type of OLE object without having to re-insert it.  Select the object on the page, 

then click Objects on the Design tab.  In the submenu choose Convert and select 

the type of object you want to convert it to. 

See also: Adding Office Objects to SmartDraw with Paste and Paste Special 
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Adding Office Objects to SmartDraw with Paste and 
Paste Special 

In addition to using the Insert Commands buttons, you can also Paste an object from 

Microsoft Office, or other OLE Server programs, into SmartDraw. When you do this, 

SmartDraw makes its own copy of the imported object and stores it in the drawing 

as an embedded object. 

On the other hand, if you paste using the Paste Special command under the Paste 

menu of the Home tab in SmartDraw, you can choose between several different 

ways of pasting your Office object into your drawing. Using this command displays 

the Paste Special Dialog.  

 
Paste Special Dialog 

The dialog shows a list of formats under the As heading. When you select the first 

format at the top of the list (depending on the program you copied the object 

from) you may be offered the choice of Paste or Paste Link. Pasting a Link pastes the 

picture of the object, and the name of the file it came from, into your SmartDraw 

drawing. Whenever you change the contents of this linked Office program file, 

SmartDraw will automatically update the picture to reflect the changes. 

Choosing the second item in the As list (Picture) only gives you the option to Paste 

(not to Paste Link). In this case, pasting the Office object into your drawing just 

transfers a picture into SmartDraw without the underlying link to the original file. If 

you paste just an image and then change the original Office file, you’ll need to 

paste it into SmartDraw again if you want to update the image. 
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Managing OLE Object Links 
When an OLE Linked object is selected on your page, the Links command under the 

More menu of the Edit tab opens the Links Dialog. 

 
The Links Dialog 

The list shows all of the linked OLE objects in your drawing. You can change the 

parameters of the item selected in the list by using the buttons on the right.  

Update Now causes SmartDraw to get the latest image from the linked file.  

Open Source opens the file associated with the link.   

Change Source lets your fix a link that has been broken because the original file has 

moved. 

Break Link breaks the OLE link, making the object a simple picture object that no 

longer updates. 

 

Inserting Objects into SmartDraw with the Insert 
Command 

You can also add OLE objects to SmartDraw with the Insert Object command on 

the More menu of the Insert tab in SmartDraw. This opens the Insert Object Dialog. 
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Insert Object Dialog (Create New) 

When the Create New button is selected, the list shows all of the different types of 

objects, from other programs, that can be inserted into your SmartDraw drawing. To 

create a new object (such as an Equation from the Microsoft Equation editor, for 

example), select one of the items in the list and click OK. 

When the Create from File button is selected the dialog appears and shown below: 

 
Insert Object Dialog (Create from File) 

This allows you to pick an existing file on your system and insert it into your drawing as 

an embedded or linked object. 

See also Understanding OLE (Object Linking and Embedding) 
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Inserting Pictures into Drawings 

  You can insert a Picture or photo (such as a JPG, GIF, PNG or other bitmap 

image) into your drawing by choosing Picture on the Insert tab and browsing to 

locate the picture on your computer.   

Unless you have already selected a place for the picture to go (such as a selected 

shape or a table cell) it will be placed near the upper left corner of your SmartDraw 

drawing by default.  You can then drag it to any position you like. 

You can also insert a picture into an existing Picture Placeholder on some of the 

ready-made SmartTemplates.  The Placeholders are temporary images meant to be 

replaced by your real images. Double click on the placeholder to open the Browse 

dialog, and then browse to the picture the same way you would using the Insert 

command. 

Double-clicking on any existing bitmap picture in a drawing also opens the Browse 

dialog, and any photo you choose replaces the one you clicked on.  The same 

happens if you use the Picture command on the Insert tab while an existing picture 

is selected on the page. 

You can delete a Picture, or a Picture Placeholder, from the page like any other 

object, by clicking on it to select it and pressing the delete key. 

How Cut, Copy, and Paste Work in SmartDraw  
You can exchange information between SmartDraw documents, and between 

SmartDraw and other programs, using the clipboard and the standard Edit 

commands: Cut, Copy and Paste.  

The clipboard is a place that Windows temporarily stores text, pictures and other 

data that have been copied so that they can be transferred to another document 

or program with the Paste command. 

Cut and Copy 

The Copy command transfers the drawing, or a selected part of it, to the clipboard.  

When nothing is selected, a representation of the whole drawing is copied to the 

clipboard (as a metafile). This drawing can then be pasted into other programs, 

including the Microsoft Office Suite (Word, Excel, etc.) and many others. 
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When one or more objects are selected on your page, the Copy command copies 

just those shapes and lines to the clipboard. They can be pasted back into a 

SmartDraw drawing, or pasted into another program.  

Cut is a combination of Clear and Copy. It first copies any selected objects to the 

clipboard, and then deletes them from your page. 

Paste 

If the clipboard contains objects copied from SmartDraw, using Paste adds these to 

the current drawing. If the clipboard contains an image from another program, it is 

pasted into the drawing as an Image Object.  

See also Understanding OLE (Object Linking and Embedding)Understanding OLE 

(Object Linking and Embedding) 

See also Properties of Imported Image Objects 

 

Properties of Imported Image Objects 
When images from other programs are imported or pasted into SmartDraw they 

become Image Objects. These can be thought of as rectangular shapes, with an 

invisible border, and the image inside. 

An image object can be moved, resized, or rotated like any other SmartDraw 

object. Normally when you resize them they maintain their proportions. However, if 

you hold the Shift Key, you can resize them to any proportion. Like other shapes, you 

can change an image object’s sizing behavior using the Shape Properties Dialog 

Launcher on the Design tab.  

When you try to type text into image objects, the text goes below the object (as a 

linked background text object), instead of inside. 

Attempting to change the color or border of an image object may either add a 

border around its entire bounding rectangle, or change the colors in the image 

itself, depending on the Change Colors setting in the Edit Symbol dialog.  

Some imported image objects can be decomposed into native SmartDraw objects 

using the Ungroup command on the Arrange group of the Main Toolbar.  
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File Formats that can be Imported 
You can import images from other programs into  SmartDraw using the Picture 

command on the Insert tab. This opens the Import Dialog, where you specify the 

type of file and its location. 

SmartDraw can import the following vector formats: 

Windows Metafile 

Enhanced Metafile 

Encapsulated Postscript (EPS) 

AutoCAD (DXF)   

CGM 

HPGL 

PDF 

Adobe Illustrator  

MicroGrafx Draw 

DWG (AutoCAD) 

CDR (Corel Draw) 

SmartDraw can import the following Bitmap formats: 

BMP 

PC PaintBrush (PCX) 

GIF 

JPG 

PNG 

TIFF 

When objects are imported they become Image Objects. 
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Ungrouping Imported Images 
Imported vector Image Objects can be ungrouped into native SmartDraw objects.  

(Imported bitmap images cannot).  

Vector objects are stored in EMF (Enhanced Metafile) format.  

To ungroup a selected imported object, use the Ungroup command under Group 

on the Design tab. (If the ungroup command is gray, then your selected image is 

probably a bitmap that cannot be ungrouped.) 

The Ungroup command opens the Separate Drawing dialog.  

 
Separate Drawing Dialog 

SmartDraw has to make many assumptions to convert metafile images into native 

SmartDraw objects, such as joining shapes to the end of lines as arrowheads, 

combining lines of text into paragraphs, placing text inside shapes, and joining line 

segments together into one segmented line. Since other drawing programs often 

use structures that SmartDraw does not, and vice versa, these assumptions are 

based on empirical rules and are not always perfect. If you have imported images 

that do not convert well, please contact SmartDraw Technical Support.  We are 

always working to improve the conversion algorithms. 

 

Defaults 

Selecting Flowcharts and similar drawings automatically selects the best separation 

settings for decomposing imported flowcharts and similar images. The Freehand and 

complex drawings choice does the same for freehand drawings. The individual 
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settings in each case are explained below. You can specify the individual settings 

manually, if you like, regardless of which default is selected.   

Combine text into paragraphs 

Text from imported images consists of single line strings, where each string has one 

typeface. If this box is checked SmartDraw will attempt to combine these strings into 

one paragraph. The setting for single or double space indicates how much space 

SmartDraw should allow between lines before it terminates one text block and 

creates another. 

Place text inside existing shapes 

When this box is checked, the text blocks detected by SmartDraw’s conversion 

process are placed inside any shapes that they appear to lie on top of. SmartDraw 

will try to detect and duplicate the alignment of the text inside the original shape. 

Convert small shapes at the end of lines into arrowheads 

With this box checked SmartDraw attempts to recognize arrowheads at the end of 

lines. 

Separate segmented lines into individual line objects 

With this box checked, SmartDraw will treat perpendicular lines that could be 

interpreted as a segmented line instead into separate lines. 

Separate curves and other sequences of lines into many individual objects. 

Freehand drawings often have many complex curves. These can be decomposed 

into hundreds (and sometimes thousands) of tiny SmartDraw lines, or left combined 

as a single curve. Checking this box forces their decomposition into many short 

straight lines. This will be appropriate only in rare cases.  

Opening Files Created with Other Flowchart Programs  
SmartDraw can intelligently disassemble files from other flowchart programs (such as 

Visio, Flowcharter, etc) and turn them into usable SmartDraw charts.  (Note that this 

process cannot be perfect, since other programs often contain objects that 

SmartDraw does not, and vice versa).  

To convert a flowchart to SmartDraw format, first save it from the original program in 

Windows Metafile (WMF) or Enhanced Metafile (EMF) format using the program’s 

own export or save command. Then you can open the foreign file in SmartDraw 

using the Import Object Command on the More menu of the SmartDraw Insert tab. 
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When the file opens, the Separate Drawing dialog appears. The settings for 

conversion of flowcharts are already selected, but this gives you an opportunity to 

adjust them if your drawing does not convert well with the default settings.  

Press OK and the drawing is converted to native SmartDraw shapes and lines. You 

can then make any needed adjustments or repairs by hand to complete the 

conversion process. 

The File Conversion Wizard 
The SmartDraw File Conversion Wizard is designed to make it easy for you to join the 

thousands of users who have switched from another competing product to 

SmartDraw. 

It can be used to automatically convert dozens or even hundreds of files created 

with Visio, Flowcharter, and other programs into SmartDraw files all at once. 

To convert files using this Wizard, the program you are converting from must be 

installed on your system, because the wizard uses that program as part of the 

conversion process.  

First select the File Conversion Wizard from the SmartDraw Button.  
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File Conversion Wizard 

Follow these steps to convert the files to SmartDraw format: 

STEP 1 

Use the drop-down list to select the type of file you want to convert (Visio, 

Flowcharter, etc). You can choose Other to convert a format that is not listed. For 

any format you choose, the source program must be present on your computer, 

and this program must be an OLE server (most major software programs are). The 

Wizard will warn you if you choose a format that does not meet these criteria. 

STEP 2 

Identify the file or files that you want to convert. You can convert all the files in a 

particular folder, or just one file. Before you choose to convert all the files in a folder 

you might want to convert one of them as a test. 

STEP 3 

Start the conversion process. As the Wizard converts your files you may see activity 

from the program that created the files and from SmartDraw itself. It typically takes 

between 10 and 60 seconds to convert each file. The converted files are stored in 
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the same folder as the original files with the same name, but with a SmartDraw SDR 

file extension. For example, if you have a Visio file:  

C:\MyDrawings\flowchart.vsd 

The Wizard will create a corresponding SmartDraw file: 

C:\MyDrawings\flowchart.sdr 

If the Visio file has multiple pages, the Wizard will create a SmartDraw file for each 

page: 

C:\MyDrawings\flowchart-Page1.sdr 

C:\MyDrawings\flowchart-Page2.sdr 

...and so on 

Fine Tuning the File Conversion 

The Wizard extracts a Windows metafile from each of the files to be converted. Then 

it decomposes the metafile into native SmartDraw objects. By default, the settings 

for this decomposition are optimized for converting flowcharts and similar diagrams. 

You can adjust these settings by pressing the Fine Tuning button in the Wizard dialog 

to display the Separate Drawing dialog. 

Exporting Drawings 
SmartDraw can export drawings in several standard Windows file formats using the 

Export command under the SmartDraw Button 

In addition to the files shown on the face of the tab, you can open the More menu 

by clicking the down arrow to reveal more formats.  

SmartDraw can export the following vector formats: 

Windows Metafile (WMF) 

Enhanced Metafile (WMF) 

Encapsulated Postscript (EPS) 

AutoCAD (DXF)   

CGM 

HPGL 
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PDF 

Adobe Illustrator  

MicroGrafx Draw 

SmartDraw can export the following Bitmap formats: 

BMP 

PC PaintBrush (PCX) 

GIF 

JPG 

PNG 

TIFF 

 

Vector vs. Bitmap Files 

Vector formats consist of mathmatically defined lines and curves that can be 

resized without degradation. They retain their sharpness when they are scaled or 

printed. SmartDraw’s native objects are vector objects. 

Bitmaps are patterns of dots. They consume large amounts of memory and often 

become jagged or unattractive when resized. Bitmaps are commonly used in web 

pages, but otherwise they are not the best format for transferring SmartDraw 

drawings to other programs.  

Instead, vector formats like Windows Metafile format (the original 16-bit Windows 

metafile format) and the Enhanced Metafile format (32-bit revision of the WMF 

format) are almost universally shared among Windows programs and are a much 

better choice for sharing SmartDraw drawings. 
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Tablet PC 

Introduction 
When SmartDraw is installed on a Tablet PC or Tablet enabled computer, the Main 

Toolbar will have additional features to make better use of the Tablet PC stylus. The 

rest of the user interface appears the same as the rest of this manual. How you use 

those features, however, may be accomplished in different ways when using a 

Tablet PC stylus.  

There are many varieties of Tablet enabled computers on the market. The type of 

stylus they use, however, does not vary all that much. For instance, some varieties 

support a button on the top of the stylus that act as an eraser. Others may have a 

button on the side to erase. Most are programmable in some way. Refer to your 

Tablet PC owner’s manual to fully understand how your particular Tablet PC stylus 

works.  

Throughout this section we will use new terminology to describe using a Tablet PC 

stylus. Instead of clicking (for a mouse), we will say "tap" to describe tapping a stylus 

on the screen where you want the click to occur. Instead of "click and drag", we will 

say "press and drag".  Instead of "right-click", we will say "right-tap". 

Tablet PC and the Main Toolbar  
 

Interaction with the Main Toolbar remains unchanged. Using the Tablet Pen, you 

can select/use the main toolbar commands just like a mouse. You will notice a new 

tab called Ink that only appears if you have a Tablet enabled PC. 

The Main Toolbar for a Tablet PC 
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The Ink Tab 

 
The Ink tab deals entirely with annotations that are made on top of a drawing. These 

annotations are completely separate from the base drawing and can be turned on 

and off easily. They are ideal for instructing the author of the drawing how to make 

edits. They can also be used to add comments or highlight areas during 

presentations. The Ink group has the following choices: 

  Pen - Select a pen from the gallery and begin adding annotation to your 

document. You have a choice of black, blue or red ballpoint or felt tip pens. 

  Highlighter - Select a highlighter from the gallery and begin highlighting objects 

in your document. Unlike the pen, a highlighter is translucent so that objects behind 

are not hidden. You have a choice of yellow, turquoise or pink highlighters. 

  Eraser - Turns on the erase tool. Tap on previously added annotation to erase it 

from the document. You have a choice of small, medium or large erasers. In 

addition you can choose stroke, which erases a contiguous annotation with one 

tap. 

  Color - Choose a custom color from the gallery for your pen or highlighter. 

  Thickness - Select or change the thickness of your ink. 

  Select - Press and drag stylus on your document to draw a selection ring. 

  Hide Ink - Tap to hide your ink. Tap the Ink Tab to unhide your ink. 

Normal Drawing with the Stylus 
There are two types of drawings that you can perform using the Tablet PC stylus. 

First, is the normal type of drawing that you would do using a mouse. Second, is 

adding annotations on top of your drawing. These annotations are completely 
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separate from the base drawing and can be turned on and off, either on the screen 

and/or for the printed output.  

For normal drawing, the stylus is used just like a mouse. There are a few new 

concepts to get used to, however. Instead of clicking a mouse, you tap the stylus on 

the screen where you want the click to occur. Instead of "click and drag", you 

position the stylus close to the screen until you see the icon change to a dragging 

icon then press and drag. Instead of "right-clicking", you press and hold the side bar 

on the stylus, then tap where you want the right-click to occur. Consult your Tablet 

PC manual for more stylus controls. 

Annotations with the Stylus 
When you click on the Ink tab, the mouse and/or stylus will no longer be able to 

change the base drawing on the page. Instead, you will be able to add notes, 

highlight areas, and draw freehand on top of the base drawing. These annotations 

can be turned on and off anytime without affecting the base drawing. This is very 

helpful, for instance, if you want to export your drawing without annotations yet 

retain the annotations for SmartDraw.  

Tap    Hide Ink, export your document, then tap the Ink tab to show the 

annotations once more. Note that if you do not hide the ink before you export, the 

annotations will become an integral part of the drawing in the exported file. 

To print your document without annotations, simply uncheck the box in the Print 

dialog labeled  Print Tablet PC Ink.  

If your Tablet PC stylus is pressure-sensitive, the annotations you write will vary in 

thickness depending on the amount of pressure you exert.  

The maximum thickness is determined by the  Thickness selected in the Ink tab. 

Annotations can be moved and/or resized by tapping the  Select icon and 

drawing a selection ring around the annotation.  

 

 

 

General Notes About Text Editing with the Stylus 
There are several options to create text using a Tablet PC stylus. Tablet PCs normally 

come with many different ways to create text. Consult your Tablet PC user manual 
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on its abilities for creating and editing text. SmartDraw supports the following 

abilities: If your Tablet PC comes with a keyboard, it can be used to create text. If 

your Tablet PC supports optical character recognition using the Tablet PC stylus, it 

can be used to create text. If your Tablet PC has an on-screen keyboard, it can be 

used to create text. If your Tablet PC supports voice recognition, it can be used to 

create text. Most Tablet PCs come with these features and throughout this section 

we will assume yours does as well. 

Adding Text by Writing with the Stylus 
The Tablet PC stylus can be used to write or print words and characters using several 

different approaches. First, you can write or print directly inside a text box using the 

stylus. A couple of seconds after you stop writing, the Tablet PC will perform an 

Optical Character Recognition (OCR) on what was just written. The results will be 

entered into the text box. Additional writing will be appended to any text already in 

the text box.  

For instance, if you add a text box by tapping on the  Text Tool on the Home tab 

and tap the stylus on the page where you want the text to begin, you will get a 

blank text box that looks like: 

 
Using the Tablet Pen, try printing "123" inside the text box as shown on the left below. 

After a couple of seconds, the drawing should disappear and 123 should be 

entered into the box as seen in the example on the right. 

  
OCR usually works well when it comes to interpreting numbers from letters. For 

instance, if you print "IDEAL" like the example on the left below, the result should look 

like the example on the right. 
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You can also print lower case letters as shown in the example on the left below to 

get the result shown on the right. 

 
You can also write words as shown in the example on the left below to get the result 

shown on the right. 

 
The same type of text box is used for any objects that have fields where text can be 

entered. When you tap outside of the text box, the large box will disappear and the 

text will appear inside the proper text field of the object. 

For example, if you are creating an Org Chart and want to add text you would 

double-tap on one of the boxes. You might see something like the following: 

 
If you have tapped Hide Ink on the Ink tab, you will have to tap the Ink tab again in 

order to add text in this manner. 

For this example, we will write "Marketing" using the stylus. 
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The writing will be automatically replaced with text like this: 

 
Tap outside the text box to see the text added to the field like this: 

 

 

Adding Text Using the On-screen Keyboard 
Add a text box by tapping on the   Text Tool on the Home tab and tap the stylus 

on the page where you want the text to begin, you will get a blank text box like the 

one shown on the left below. When hovering the Tablet Pen over the text box, you 

should see an icon appear inside the text box like the one shown on the right. 

 
Tapping on the icon will bring up the on-screen keyboard. It may look something like 

the following: 
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Using the stylus, you can tap on the keyboard to enter/edit text, then tap  to 

close the on-screen keyboard. 

The left side of the on-screen keyboard has buttons to change the keyboard into 

two different styles of writing input. The first one looks like the following: 

 
As shown in the picture above, as you write characters using the stylus, a preview of 

the text will show up just under the line. If the interpretation is correct you tap the 

Insert button to insert the text into the box. 

The second style of writing input looks like the following:  

 
It has sections on the line so you can be more precise for individual characters and 

spacing. It also has the additional capability of changing a single character if the 

OCR program makes a mistake. For instance, if you write 123 but the computer 

thinks you wrote 1L3, then you can change the L to a 2 like this:  
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Adding Text Using Speech Recognition 
Using speech recognition usually requires some setup on your Tablet PC before 

attempting to use it. Access the Speech setup in the Control Panel to adjust the 

microphone and train your speech for recognition. Once the computer is trained for 

your speech, you can activate the speech recognition from the on-screen 

keyboard by tapping the  Tools and Options icon. 

 
 

By checking  , you can select  for saying text or  for saying 

commands, such as Tab, Enter, Backspace, Delete. 
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Customizing SmartDraw 

Creating Custom SmartTemplates 
A SmartTemplate is a "starting point" for making a particular kind of drawing. The 

built-in SmartTemplates appear in the Document Browser. You can create and save 

your own custom  SmartTemplates that will appear in the Document Browser under 

My Templates. 

When you Create a New Document by opening a template, SmartDraw makes a 

copy of the template for you to work with.  The original template remains 

untouched and available for future use. 

To create a SmartTemplate, save your drawing using the Save As Template 

command under the SmartDraw Button.  Instead of SDR, a template has the file 

extension SDT. 

The Save as Template dialog prompts you to name your template. You can also 

add keywords, separated by commas, that you think may be useful later when 

searching for the template. 

You can create a sub-category inside My Templates by selecting the Create New 

Category button. 

Clicking OK saves your drawing as a new template, and, if appropriate, creates the 

new category. This is reflected immediately in the Document Browser. 

Designing SmartTemplates 
Your custom SmartTemplate does more than just save a drawing as a starting point 

for future use.  It also saves all the default settings of that particular document. 

Those default settings include: 
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Snap-to-grid alignment 

Line- and Shape-linking settings 

The Design Theme 

Line and border thickness 

Font 

Rulers and their scale 

Page orientation and size 

Zoom level 

It’s important to create your template by starting with the right type of drawing that 

you want to create with it in the future, so that those saved settings are appropriate. 

For example, if you want to use the custom template to create Org Charts, start with 

an Org Chart SmartTemplate in the first place to create it. 

Defining Your Own Menu Colors  
If you choose More Fill Colors from any SmartDraw color menu, you’ll see the Color 

Dialog, which allows you to choose from any of the 16 million possible Windows 

colors.  

 
The Color Dialog 
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You can define a custom color using the slider control to set the brightness and 

dragging the crosshair in the window to select the hue. Your currently defined color 

shows in the Color|Solid box. 

Alternatively, you can enter an explicit RGB or HSL value for the color in the 

designated fields. 

Once you have specified your custom color, click OK to apply it to the selected 

object in your drawing. 

After you define a new color, it appears in the Recent Colors section in the color 

menus, so that you can quickly access to it for future use. 

Defining Your Own Gradient Fills  
You can create your own custom gradient fill colors. 

On the Home tab, click Fill, then Gradient, then More Gradients. 

This opens the Gradient Fill Dialog where you can choose from one of the existing 

Color Schemes or create your own and save it for future use. 

 
The Gradient Fill Dialog 

A gradient fill is defined by two colors and the direction that the colors change. The 

two colors are selected using the color controls labeled One and Two at the bottom 

of the dialog. The direction of the fill is shown on the 16 buttons above the Colors 
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box. Clicking one of the buttons selects this fill direction. Clicking OK applies the 

gradient fill to the currently selected object(s). 

If you have an object selected for which you have previously defined a custom 

gradient fill, when you open the gradient menu again, the color #1 of your custom 

fill will be used to create the Light and Dark Variations. 
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SmartDraw Licenses 

SmartDraw Licenses 
SmartDraw will not run without a license. The license is created when the program is 

installed with a valid serial number. You can inspect the licenses installed on your 

system by selecting the License command on the Help tab. 

 
SmartDraw Licenses Dialog 

The SmartDraw Licenses dialog displays a list of all the SmartDraw licenses installed 

on your system. 

Workgroup Licenses 
The SmartDraw workgroup license allows ten or more computers to access 

SmartDraw on a network.  For example, a 10-Seat license permits 10 different 

computers, (other than the server itself) to access the program.  

SmartDraw records the identity of each computer that runs the program, and it will 

allow no more computers to access it after the licensed number has been reached. 
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The list of computers that have used SmartDraw is maintained on the server and can 

be inspected and edited there by selecting the Licenses command on the Help 

tab, to display the Network Administration Dialog. 

 
TheSmartDraw Network User Administration Dialog 

The number of seats supported by all network licenses installed is shown at the top of 

the dialog, along with the number of users (computers) that have run this networked 

copy of SmartDraw. 

SmartDraw counts the number of computers that have accessed it by recording the 

serial numbers of their hard disks. 

If a user has run SmartDraw accidentally or no longer needs access, you can disable 

that account by clicking on the user’s name and setting the status to Disabled using 

the buttons at the bottom. This frees a license for use by another computer. You can 

also use this technique to disable old hard disk serial numbers when computers are 

replaced or upgraded with new drives. 

As a security measure, these changes can only be made while logged on to the 

server itself. 
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Adding Additional Network Licenses 
You can add licenses to an existing network installation by purchasing more online 

at SmartDraw.com, or by contacting SmartDraw sales at 1-800-817-4238. 

When you purchase additional licenses, running the installation program on the 

network server automatically adds the new licenses and increases the total 

available. For example, if you purchase two 10-seat licenses and install each in the 

same program folder, the single shared copy of SmartDraw will permit 20 seats. 
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Technical Support and 
Troubleshooting 

SmartDraw Tech Support Knowledge Base 
For instant, 24-hour information about the most common user questions, visit the 

SmartDraw Knowledge Base at: 

http://www.smartdraw.com/support/knowledgebase/index.aspx  

How to Get Technical Support 
Technical support is available to all SmartDraw users - including trial users.   

 To access technical support from the SmartDraw program click the Tech 

Support button on the Help tab. 

To contact support on the web go to: 

http://www.smartdraw.com/support/contact.htm 

 

Other Ways to Get Technical Support 

By e-mail to: support@smartdraw.com 

Call (858) 225-3300 between 8 AM and 5 PM USA Pacific time. 

When reporting a problem, please include the following information: 

1) Your system configuration (version of Windows, printer, display type etc.) 

2) A description of how to reproduce the problem. 
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3) A sample file that exhibits the problem (if possible). 

Downloading the Latest Version 

  We frequently offer free updates that include bug fixes and new features. To 

check for updates click the Updates button on the Help tab. 

Or visit the SmartDraw support web page and click the link that says Free Updates. 

http://www.smartdraw.com/support/updates.htm 
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How to Order SmartDraw 

How to Order SmartDraw 
When your trial period expires, you can continue working by purchasing the full 

version of SmartDraw, which will replace your Trial Edition. Any drawings you created 

with the Trial Edition will be preserved, and you can open them with the full version.   

SmartDraw offers deep discounts for multiple copy purchases and multi-seat 

licenses.  For more information, please visit: 

http://www.smartdraw.com/buyinfo/volume/index.htm 

Learn more about the various options for purchasing SmartDraw by choosing a topic 

below: 

Activation 

Order Online 

Order by Phone 

Order By Fax or Mail 

Order Internationally 

Activation 
You can activate your trial version of SmartDraw by clicking the Buy button on the 

Buy tab and purchasing the full program. 

Clicking this button enables you to conduct a secure, online purchase that 

activates your trial copy. Activation means there’s no need to download anything 

further or wait for any media to arrive to continue working. You simply make your 

purchase, and pick up where you left off. 
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Activation removes all restrictions on printing and editing, and removes any 

watermarks from every document you made with your trial version. At the time of 

activation you can also order an optional CD and Quick Start Guide to be shipped 

to you.   

If you have any questions or prefer to place your order over the phone, you can 

always call SmartDraw.com directly at 1-800-817-4238 (in the US and Canada) or 

858-225-3300 (outside the US). 

If you wish to purchase SmartDraw with a Company Purchase Order, print out an 

order form and mail or fax the order form with a copy of the Purchase Order.  

SmartDraw.com only accepts Purchase Orders from entities in the US and Canada. 

See Order By Fax or Mail for more information. 

Return to How to Order SmartDraw 

 

Order Online 
Visit www.smartdraw.com and order online with a credit card. You can download 

your software immediately and order an optional CD and Quick Start Guide to be 

shipped to you.   

If you have any questions or prefer to place your order over the phone, you can 

always call SmartDraw.com directly at 1-800-817-4238 (in the US and Canada) or 

858-225-3300 (outside the US). 

If you wish to purchase SmartDraw with a Company Purchase Order, print out an 

order form and mail or fax the order form with a copy of the Purchase Order.  

SmartDraw.com only accepts Purchase Orders from entities in the US and Canada. 

See Order By Fax or Mail for more information. 

Return to How to Order SmartDraw 

Order by Phone 
Call: 

1-800-817-4238 within the US and Canada, or call  

858-225-3300 outside the US 
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You can order by phone and still receive the benefits of downloading the product 

immediately after purchase. You can also order the optional CD if you like. 

 SmartDraw.com does not accept Purchase Orders by phone.  If you wish to 

purchase SmartDraw with a Company Purchase Order, print out an order form and 

mail or fax the order form with a copy of the Purchase Order.  SmartDraw.com only 

accepts Purchase Orders from recognized entities in the US and Canada. 

See Order By Fax or Mail for more information. 

Return to How to Order SmartDraw 

Order By Fax or Mail  
Visit http://www.smartdraw.com/buyinfo/forms/index.htm for the latest up to date 

order forms.  Fill out the order form and fax it to: 

858-549-2830 

If sending a check, please mail the check and order form to: 

 SmartDraw.com 

 9909 Mira Mesa Blvd 

 San Diego, CA 92131 

 USA 

If you have any questions or prefer to place your order over the phone, you can 

always call SmartDraw.com directly at 1-800-817-4238 (in the US and Canada) or 

858-225-3300 (outside the US). 

If you wish to purchase SmartDraw with a Company Purchase Order, print an order 

form and mail or fax the order form with a copy of the Purchase Order.  

SmartDraw.com only accepts Purchase Orders from entities in the US and Canada. 

Return to How to Order SmartDraw 

Order Internationally 
SmartDraw.com has distributors all over the world. 



SmartDraw 2009 User's GuideUser’s Guide How to Order SmartDraw ••••  251 

 
You can also call SmartDraw.com at 1-800-817-4238 (in the US and Canada) or 858-

225-3300 (outside the US) for more information.  

Return to How to Order SmartDraw 

 

Money Back Guarantee 
Should you decide to purchase, SmartDraw offers a 30-day Money Back Guarantee 

on all products if you are not satisfied with the application. 
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SmartDraw License Agreement 

SmartDraw Software License Agreement (Purchased 
Copy) 

IMPORTANT:  CAREFULLY READ THIS LICENSE AGREEMENT ("LICENSE") BEFORE USING 

THIS PRODUCT.   THIS LICENSE IS AN INTEGRAL PART OF THE SALES AGREEMENT UNDER 

WHICH YOU HAVE PURCHASED A LICENSE TO USE SMARTDRAW.COM’S SOFTWARE 

PRODUCT (the "Sales Agreement").   

* YOUR INSTALLATION, COPYING, OR USE OF THIS PRODUCT INDICATES YOUR 

ACCEPTANCE OF THIS LICENSE, AND THAT YOU AGREE TO BE BOUND BY AND 

COMPLY WITH ALL OF ITS TERMS.  

* IF YOU HAVE PURCHASED THE PRODUCT ON BEHALF OF ANY ORGANIZATION, 

COMPANY OR OTHER ENTITY, YOU REPRESENT AND WARRANT THAT YOU HAVE FULL 

AUTHORITY TO ENTER INTO THIS LICENSE AND THE SALE AGREEMENT ON BEHALF OF 

SUCH ENTITY.  ALL REFERENCES HEREIN TO "YOU" SHALL APPLY TO SUCH ENTITY. 

* IF YOU DO NOT AGREE TO ALL OF THE TERMS AND CONDITIONS OF THIS LICENSE, 

THEN: (A) DO NOT COPY, INSTALL, OR USE THIS PRODUCT, AND (B) RETURN THE 

COMPLETE PRODUCT TO SMARTDRAW.COM IMMEDIATELY FOR A REFUND OF THE 

LICENSE FEES THAT YOU HAVE PAID. 

A. DEFINITIONS:   

SmartDraw.com is also referred to in this License as "we" or "us. "   

The "Product" consists of: (1) all materials with which this License is packaged or 

otherwise supplied by SmartDraw.com, which may include, but are not limited to, 

computer program(s), software, and code; the Images (as defined below); 

templates; symbols; text; accompanying printed materials; and "online" or electronic 

documentation, and (2) any Maintenance Releases and Upgrades (each as 

defined below) and any other supplemental software code and supporting 
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materials which may be provided to you as part of support services provided or 

authorized by SmartDraw.com for the Product. 

An "Upgrade" is a new version of the Product, and is identified by the numeral to the 

left of the decimal point following the name of the Product.  A "Maintenance 

Release" is a software update to an existing version of the Product that is identified 

by the numeral to the right of the decimal point following the name of the Product.    

For example, in "Product 2.1", "1" is the Maintenance Release number and "2" is the 

Upgrade number. SmartDraw.com has the right, its sole discretion, to determine 

whether a particular change or addition to the Product is an Upgrade or a 

Maintenance Release. 

 

B. SCOPE OF LICENSE.  SmartDraw.com hereby grants you a non-exclusive, non-

transferable license (without the right to sublicense) to use the Product in 

accordance with all of the terms and conditions of this License and the Sales 

Agreement.    SmartDraw.com offers several different types of licenses for the 

Product:   

1.  Single User License.  If you purchased a single-user license, you may install and 

use one copy of the Product on a single computer (the "Primary Computer").  

Subject to the terms and conditions of this License, you may make one (1) other 

copy of the Product and install it on another computer, provided the second 

computer is used exclusively by you.  The two installations may not be used at the 

same time, and the second installation may not still be used after the time you no 

longer own the Primary Computer on which the Product is installed.  Your right to use 

the Product is perpetual (provided that this License is not terminated as specified 

elsewhere herein).   You have the right to receive, free of charge, all Maintenance 

Releases for the version of the Product that you originally purchased.  You do not 

have the right to receive free Upgrades, but you may be entitled to a discount on 

our standard fee for Upgrades, if so provided in your Sales Agreement. 

2.  Workgroup Multi-Seat License.  If you purchased a workgroup multi-seat license, 

you may install the Product on more than one computer, or install the Product on a 

network server so that multiple computers can access it, in either case up to the limit 

set forth in the Sales Agreement.  The Product may be installed on a network server, 

provided that the number of computers that access the Product via that server or 

otherwise does not exceed the number of computers specified in your Sales 

Agreement.  For example, if your Sales Agreement specifies a workgroup multi-seat 

license for 100 computers, the Product may be installed: (a) on a network server 

where it will be accessible by no more than 100 different computers connected to 

the network served by that server, or (b) on up to 100 individual PC's, or (c) or on 
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some combination of both (a) and (b), provided that the total number of PC's that 

access the Product does not exceed 100. Your right to use the Product is perpetual 

(provided that this License is not terminated as specified elsewhere herein).  You 

have the right to receive, free of charge, all Maintenance Releases for the version of 

the Product that you originally purchased.  You do not have the right to receive free 

Upgrades, but you may be entitled to a discount on our standard fee for Upgrades, 

if so provided in your Sales Agreement. 

3.  Workgroup Concurrent-User License.  If you purchased a workgroup concurrent-

user license, you may install the Product on a network server, where the number of 

PC's that access the Product simultaneously does not exceed the number of users 

specified in your Sales Agreement. Your right to use the Product is perpetual 

(provided that this License is not terminated as specified elsewhere herein).  You 

have the right to receive, free of charge, all Maintenance Releases for the version of 

the Product that you originally purchased.  You do not have the right to receive free 

Upgrades, but you may be entitled to a discount on our standard fee for Upgrades, 

if so provided in your Sales Agreement. 

4. Freedom Site License.   

 a. Full "Freedom" license.  If you purchased a "Freedom" site license, you 

may install any number of copies of the Product, but only on computers owned by 

your company/organization, for use strictly by your employees and agents.  While 

you may install the Product on any number of computers without violating the 

license, you acknowledge that additional fees will be assessed, pursuant to the 

Sales Agreement, if you install the Product on more computers than the quantity 

listed in the Sales Agreement.  Such fees shall be determined at the end of each 12-

month period, and shall be assessed for the subsequent 12-month period. Your 

employees and agents may install a copy of the Product on their personally owned 

home computers, provided that they use the Product for your internal business 

purposes only, and not for their own personal use.  You are responsible for the 

compliance of your employees and agents with the terms of this License.  Your right 

to install and use the Product is valid only during the limited term specified in your 

Sales Agreement.  The term will automatically renew for consecutive 12-month 

periods unless you provide written notice to cancel the license at least 30 days prior 

to the expiration of the term.  You acknowledge that the Product is designed to 

cease to function on the expiration date if the license term is cancelled.  You have 

the right to receive, free of charge, all Maintenance Releases and Upgrades that 

we make generally available during your license term. 

 b. "Departmental Freedom" License.  If you purchased a "Departmental 

Freedom" license, all Full "Freedom" site license terms apply, as set forth above in 

Section 4(a).  In addition, you represent and warrant that at the time you purchased 
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the “Departmental Freedom” license, the group, department, company or other 

organization (the "Unit") utilizing the Product was comprised of no more than 20 

individuals.  During each 12-month period of the "Departmental Freedom" license, 

such Unit may increase in size to over 20 individuals without violating the terms of the 

license.  However, you acknowledge that additional fees will be assessed, pursuant 

to the Sales Agreement, for Units comprised of over 20 individuals.  Such fees shall be 

determined at the end of each 12-month period, and shall be assessed for the 

subsequent 12-month period.  

5.  Student License.  If you purchased a Student License, you must be a full-time 

student, at a post-secondary school level.  You are authorized to use this license only 

in your studies or for your personal use, and not for commercial or business use. 

6.  Limited Edition.  If you purchased a Limited Edition, you are authorized only to use 

the SmartTemplates and examples accessed from one button on the Template 

Browser. For example, if you purchased a Limited Edition to use for Calendars you 

may only use the templates shown in the Template Browser when the Calendar 

button is selected. 

7. Backup copy.  Regardless of the type of license that you have purchased, you 

may make one (1) copy of the Product for archive or backup purposes. 

C. YOU MAY NOT:   

1. install, use, distribute or copy the Product except as expressly permitted in this 

License.  

2. translate, reverse engineer, decompile, or disassemble the Product, except to the 

extent, if any, that such activities are clearly and expressly permitted by applicable 

law despite such restrictions. 

3. sell, transfer, rent, lease or assign the Product, or allow any third party to benefit 

from or access the Product on a "service bureau, " hosted application, or similar 

basis. 

4. modify the Product, merge the Product as part of any other product or collection 

of products, or create derivative works derived from the Product or any component 

thereof, without the prior written consent of SmartDraw.com. 

5.  use the Product, or any of its components, to create any product that competes 

with the Product or any of its components. 

6.  transfer the Product or your rights under this License to someone else. 

7. permit others to perform any of the activities restricted by this Paragraph C. 
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In addition, in no event do we authorize you or anyone else to use the Product in 

applications or systems where the Product's failure to perform can reasonably be 

expected to result in significant physical injury, property damage, or loss of life, 

including but not limited to use in hazardous environments requiring fail-safe 

performance, such as in the operation of nuclear facilities, aircraft navigation or 

communication systems, air traffic control, direct life support machines, or weapons 

systems.  The Product is not fault-tolerant and is not designed, manufactured or 

intended for any such use.  Any such use is entirely at your own risk, and you agree 

to defend, indemnify and hold SmartDraw.com, and its principals, shareholders, 

officers, employees, affiliates, contractors, affiliates, and licensors, harmless from any 

and all claims or losses relating to such unauthorized use. 

 

D. TERM:   

If you purchased a "Freedom" site license, your license to use the Product is for a 

limited time period, as specified on your Sales Agreement.  In all events, your rights 

regarding the Product under this License shall remain in effect only as long as you 

are in full compliance with the terms and conditions of this License and the Sales 

Agreement, and shall terminate automatically if you fail to comply with any such 

terms or conditions.  You agree, upon termination, to destroy all copies of the 

Product received, made or used by you in connection with this License.  Paragraphs 

D, E, F, G and H and your indemnity obligations hereunder shall survive the 

expiration or termination for any reason of this Agreement.   

 

E. OWNERSHIP 

All patents, copyrights, trademarks, trade secrets and other intellectual property 

and other proprietary rights in the Product are and shall remain in SmartDraw.com or 

its licensors.  The source code of the Product and all information regarding the 

design, structure or internal operation of the Product are valuable trade secrets of 

SmartDraw.com or its licensors ("Confidential Information"). To the extent, if any, to 

which you learn any Confidential Information, you shall not sell, transfer, publish, 

disclose, display, or otherwise permit access by any third party to, the Confidential 

Information.   The restrictions set forth in this Paragraph E do not apply to information 

that was publicly known prior to the time you received it, or which becomes known 

to you through no violation of any obligation of confidentiality on the part of you or 

any third party.  SmartDraw makes use of GNU GhostScript, an open-source 

interpreter for the PostScript language and the PDF file format.  It is distributed under 

the GNU General Public License.  You may obtain the source code for GNU 

GhostScript from http://www.gnu.org/software/ghostscript/ghostscript.html. 
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You shall ensure that any copies of the Product that you make or have made 

pursuant to this License bear all copyright and other proprietary notices contained 

in or affixed to the copy or copies of the Product as created and packaged by us.  

All rights of any kind in the Product that are not expressly granted in this License are 

entirely and exclusively reserved to SmartDraw.com or its licensors.  

 

F. SERIAL NUMBER 

This License has a unique serial number, which is Confidential Information.  Publishing 

this serial number or disclosing it to any third party will be deemed a material breach 

of this License. 

 

G. LIMITED WARRANTY; EXCLUSIONS OF LIABILITY:    

 

1.  THE PROVISIONS OF THIS PARAGRAPH G APPLY TO THE MAXIMUM EXTENT 

PERMITTED BY APPLICABLE LAW.  YOU MAY HAVE OTHER RIGHTS, WHICH VARY FROM 

STATE TO STATE AND COUNTRY TO COUNTRY. 

2.  FOR A PERIOD OF 30 DAYS FOLLOWING YOUR PURCHASE OF THE PRODUCT (THE 

“WARRANTY PERIOD”), SMARTDRAW.COM WARRANTS THAT THE PRODUCT SHALL 

COMPLY IN ALL MATERIAL RESPECTS WITH ITS WRITTEN SPECIFICATIONS AND THAT ANY 

MEDIA UPON WHICH THE PRODUCT IS PROVIDED SHALL BE FREE OF MATERIAL 

DEFECTS.   SMARTDRAW.COM’S SOLE LIABILITY, AND YOUR SOLE REMEDY, FOR ANY 

BREACH OF THE FOREGOING WARRANTY SHALL BE THE REPAIR OR REPLACEMENT OF 

THE PRODUCT OR MEDIA, AS APPLICABLE, OR THE REFUND OF ANY AMOUNTS PAID BY 

YOU FOR THE PURCHASE OF THE PRODUCT LICENSE.  ALL WARRANTY CLAIMS MUST BE 

MADE DURING THE WARRANTY PERIOD. 

3.  EXCEPT AS EXPRESSLY PROVIDED IN PARAGRAPH G(2), THE PRODUCT IS PROVIDED 

TO YOU "AS IS" WITHOUT WARRANTY OF ANY KIND. SMARTDRAW.COM DOES NOT 

WARRANT THAT THE PRODUCT WILL MEET YOUR REQUIREMENTS, OR THAT THE 

OPERATION OF THE PRODUCT WILL BE UNINTERRUPTED OR ERROR FREE. THE ENTIRE 

RISK AS TO THE RESULTS AND PERFORMANCE OF THE PRODUCT IS ASSUMED BY YOU.  

SMARTDRAW.COM DOES NOT MAKE, AND HEREBY DISCLAIMS ANY IMPLIED 

WARRANTIES OF NONINFRINGEMENT, MERCHANTABILITY AND FITNESS FOR A 

PARTICULAR PURPOSE.  NO ORAL OR WRITTEN INFORMATION OR ADVICE GIVEN BY 

SMARTDRAW.COM, ITS DEALERS, DISTRIBUTORS, AGENTS OR EMPLOYEES SHALL 

CREATE A WARRANTY OR IN ANY WAY INCREASE THE SCOPE OF THE WARRANTY SET 



SmartDraw 2009 User's GuideUser’s Guide SmartDraw License Agreement ••••  258 

 

FORTH IN PARAGRAPH G(2), AND YOU MAY NOT RELY ON ANY SUCH INFORMATION 

OR ADVICE.  

NEITHER SMARTDRAW.COM, ITS PRINCIPALS, SHAREHOLDERS, OFFICERS, EMPLOYEES, 

CONTRACTORS, AFFILIATES, LICENSORS, NOR ANYONE ELSE WHO HAS BEEN 

INVOLVED IN THE CREATION, PRODUCTION OR DELIVERY OF THE PRODUCT, SHALL BE 

LIABLE FOR ANY LOSS BUSINESS INTERRUPTION, OR LOSS OF BUSINESS, DATA OR USE 

OF COMPUTER SYSTEMS, REGARDLESS OF HOW THE FOREGOING DAMAGES ARE 

CHARACTERIZED, OR FOR ANY INDIRECT, CONSEQUENTIAL, INCIDENTAL OR PUNITIVE 

DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PRODUCT, EVEN IF 

SMARTDRAW.COM HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. THE 

LIMITATIONS SET FORTH ABOVE SHALL BE DEEMED TO APPLY TO THE MAXIMUM EXTENT 

PERMITTED BY APPLICABLE LAW AND NOTWITHSTANDING THE FAILURE OF THE 

ESSENTIAL PURPOSE OF ANY LIMITED REMEDIES.  SMARTDRAW.COM’S AGGREGATE 

LIABILITY HEREUNDER SHALL BE LIMITED TO THE AMOUNT ACTUALLY PAID BY YOU FOR 

THE PRODUCT UNDER A FREEDOM SITE LICENSE IN THE ONE YEAR PERIOD PRIOR TO 

SUCH LIABILITY ARISING FOR THE PRODUCT, OR, IF YOU HAVE A SINGLE-USER, 

WORKGROUP MULTI-SEAT OR WORKGROUP CONCURRENT USER LICENSE, THE INITIAL 

FEE THAT YOU ACTUALLY PAID FOR THE PRODUCT.  YOU ACKNOWLEDGE AND AGREE 

THAT YOU HAVE FULLY CONSIDERED THE FOREGOING ALLOCATION OF RISK AND FIND 

IT REASONABLE, AND THAT THE FOREGOING LIMITATIONS AND EXCLUSIONS ARE AN 

ESSENTIAL BASIS OF THE BARGAIN BETWEEN YOU AND SMARTDRAW.COM. 

H. GENERAL:   

This License, together with the Sales Agreement, forms the entire agreement 

between you and us regarding the subject matter set forth herein, superseding any 

other agreement or discussions, oral or written, and may not be changed except by 

a signed agreement. This License shall be governed by and construed in 

accordance with the laws of the State of California, excluding that body of law 

applicable to choice of law and excluding the United Nations Convention on 

Contracts for the International Sale of Goods and any legislation implementing such 

Convention. If any provision of this License is declared by a Court of competent 

jurisdiction to be invalid, illegal, or unenforceable, such provision shall be severed 

from the License and the other provisions shall remain in full force and effect.  The 

prevailing party in any action to enforce or interpret this License agreement shall be 

entitled to recover its costs and expenses, including attorneys' fees.   

You agree to the exclusive jurisdiction of, and venue in, the state and federal courts 

located in San Diego, California, USA for any dispute or matter relating to, arising 

from or connected with this License agreement.  Notwithstanding the foregoing, 

SmartDraw.com shall have the right to seek injunctive relief and the enforcement of 

judgments in any court of competent jurisdiction.  Any waiver by us of any violation 
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of this License by you shall not constitute, nor contribute to, a waiver by us of any 

other or future violation of the same provision, or any other provision, of this License. 

The parties acknowledge and agree that no third party (including but not limited to 

your customers, clients or licensees) shall have any rights, either against us or our 

licensors, as a third party beneficiary of any rights, licenses, products or services 

granted or provided by us to you hereunder.  SmartDraw.com may freely assign or 

delegate this Agreement, in whole or in part.  This License is personal to you, and 

you agree not to assign or delegate, in whole or in part, this License or any of your 

rights or obligations hereunder.  Any assignment in violation of the forgoing 

restrictions shall be considered null and void.    

U.S. Government Users.  All software included in the Product and provided to the 

U.S. Government, including its civilian and military agencies, is commercial 

computer software that was developed at private expense prior to its provision to 

any U.S. Government entity.  Subject to any applicable regulations set out in the FAR 

or DFARS (and any superseding regulations), the Product is provided with the 

commercial license rights and restrictions described elsewhere in this Agreement.  

For Department of Defense agencies, the restrictions set forth in the "Technical Data 

- Commercial items" clause at DFARS 252.227-7015 (Nov 1995) shall also apply.  

Contractor/manufacturer is SmartDraw.com, 9909 Mira Mesa Blvd., San Diego, CA  

92131.   

You agree that your use of the Product shall comply with all applicable laws and 

regulations.  Without limiting the foregoing, you understand that the Product is 

subject to the export control laws and regulations of the U.S. or other applicable 

jurisdictions.  You agree that you will not export or re-export the Product in violation 

of such laws or regulations.  

You agree that SmartDraw.com or its designee may inspect your facilities, servers 

and computers to ensure that you are using the most recent version of the Product 

and to verify that you are in full compliance with this License (the "Inspection").  Such 

Inspection may be conducted by use of remote software monitoring tools.  During 

the course of the Inspection, SmartDraw.com or its designee will not access any 

information other than the number of computers running the Product and the 

version number of the Product.  All information and materials shall be treated as 

confidential, and will not be shared with any third parties without your written 

consent. 

 

FURTHER RESTRICTIONS ON THE USE OF CLIPART, SYMBOLS, TEMPLATES, PHOTO 

OBJECTS AND PHOTOGRAPHIC IMAGES 
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This Product contains numerous clipart, symbols, templates and photo images 

(collectively referred to as the "Images"), which are either owned by 

SmartDraw.com or its licensors.  As a user of this Product, you are free to use, modify 

and publish the Images as part of your own work product, subject to all of the 

restrictions set out below and elsewhere herein, and any additional conditions 

described in the credits dialog of certain symbol libraries.  If you are uncertain as to 

whether your intended use is in compliance with the Guidelines set out below, we 

recommend that you seek the advice of your own attorney or legal counsel.  

SmartDraw.com will not provide you with an opinion as to whether your use is in 

compliance with these Guidelines. 

A.  YOU MAY, subject to any restrictions set out below and elsewhere herein: 

1. incorporate any Image(s) into your own original work and publish, display and 

distribute your work in any media.  You may not, however, resell, sublicense or 

otherwise make available the Image(s) for use or distribution separately or 

detached from your own work product or web page.   For example, the Image(s) 

may be used as part of a web page design, but may not be made available for 

downloading separately or in a format designed or intended for permanent storage 

or re-use by others.  Similarly, clients may be provided with copies of the Image(s) 

(including digital files) as an integral part of your work product, but may not be 

provided with the Image(s) or permitted to use the Image(s) separately or as part of 

any other product. 

2. make one (1) copy of the Image(s) as incorporated in the Product for backup or 

archival purposes. 

B.  YOU MAY NOT 

1. create scandalous, obscene, defamatory or immoral works using the Image(s), 

nor use the Image(s) for any purpose that is prohibited by law. 

2. use or permit the use of the Image(s) or any part thereof as a trademark or service 

mark, or claim any proprietary rights of any sort in the Image(s) or any part thereof. 

3. use the Image(s) in electronic format, on-line or in multimedia applications unless 

the Image(s) are incorporated for viewing purposes only, and no permission is given 

to those viewing the Images to download and/or save the Image(s) for any reason. 

4. rent, lease, sublicense or lend the Image(s), or a copy thereof, to another person 

or legal entity.   

5. use any Image(s) except as expressly permitted by this License. 
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6. use any Image(s) that relate to identifiable individuals, products or entities in any 

manner that suggests their association with, or endorsement of, any product or 

service. 

7. make a modification to a licensed image which would remove embedded 

copyright information from the image. 

You acknowledge that neither SmartDraw.com, nor its principals, shareholders, 

officers, employees,  contractors, affiliates, or licensors, are liable for any offensive, 

harmful, illegal, indecent, incorrect, incomplete or inaccurate data, information or 

materials either comprising, part of, or associated with any Image or collection of 

Images.  You agree to defend, indemnify and hold harmless SmartDraw.com and its 

principals, shareholders, officers, employees, contractors, affiliates, and licensors, 

from any and all third party claims and damages arising from your breach of any of 

the restrictions set forth herein.  

 

 

[BY CLICKING ON THE "I ACCEPT" BUTTON BELOW, YOU ACKNOWLEDGE THAT YOUR 

ARE BOUND BY THE TERMS OF THIS LICENSE AND THE SALE AGREEMENT.  IF YOU ARE 

PURCHASING THE PRODUCT ON BEHALF OF ANY ORGANIZATION, COMPANY OR 

OTHER ENTITY, YOU REPRESENT AND WARRANT THAT YOU HAVE FULL AUTHORITY TO 

ENTER INTO THIS LICENSE AND THE SALE AGREEMENT ON BEHALF OF SUCH ENTITY.] 

SmartDraw Software License Agreement (Trial Edition) 
IMPORTANT:  THIS LICENSE AGREEMENT ("LICENSE") APPLIES TO YOUR DOWNLOADING 

AND USE OF THE FREE, TRIAL VERSION OF THIS SOFTWARE PRODUCT.  CAREFULLY READ 

THIS LICENSE BEFORE USING THIS TRIAL VERSION PRODUCT.    

* YOUR INSTALLATION, COPYING, OR USE OF THIS TRIAL VERSION PRODUCT INDICATES 

YOUR ACCEPTANCE OF THIS LICENSE, AND THAT YOU AGREE TO BE BOUND BY AND 

COMPLY WITH ALL OF ITS TERMS.  

* IF YOU ARE DOWNLOADING OR USING THE TRIAL VERSION PRODUCT ON BEHALF OF 

ANY ORGANIZATION, COMPANY OR OTHER ENTITY, YOU REPRESENT AND WARRANT 

THAT YOU HAVE FULL AUTHORITY TO ENTER INTO THIS LICENSE ON BEHALF OF SUCH 

ENTITY.  ALL REFERENCES HEREIN TO “YOU” SHALL APPLY TO SUCH ENTITY. 

* IF YOU DO NOT AGREE TO ALL OF THE TERMS AND CONDITIONS OF THIS LICENSE, 

THEN DO NOT DOWNLOAD, COPY, INSTALL, OR USE THIS TRIAL VERSION PRODUCT. 
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A. DEFINITIONS:   

 

SmartDraw.com is also referred to in this License as "we" or "us. "  

The "Trial Version Product" consists of all materials made available by 

SmartDraw.com for downloading under this License, which may include, but are not 

limited to, computer program(s), software, and code; the Images (as defined 

below); templates; symbols; text; accompanying printed materials; and "online" or 

electronic documentation.   

B. SCOPE OF LICENSE.  SmartDraw.com hereby grants you a non-exclusive, non-

transferable license (without the right to sublicense) to use the Trial Version Product 

in accordance with all of the terms and conditions of this License.  You may use the 

Trial Version Product solely on a trial basis to determine whether or not you want to 

purchase a license to use the full version of this product.  You acknowledge that 

your license to use the Trial Version Product is temporary and that the Trial Version 

Product is designed to limit both how long you can use it for free and what you can 

do with it.  In particular, the Trial Version Product supplied to you under this License 

may contain the following features and limitations: 

1. Certain functions of the Trial Version Product, such as editing a document, 

may cease to operate after a period of time or after a certain number of uses of the 

Trial Version Product.  Any documents created with the Trial Version Product will, 

however, be fully usable again once a license for the full version of the product is 

purchased. 

2. Printed documents may contain a watermark.  However, if you purchase a 

license to the full version of this product, this watermark will not appear - even on 

documents created with the Trial Version Product. 

3. The number of print-outs that you can make may be limited.  When you 

attempt to print, you are warned about the print limitation and informed about the 

number of print-outs you have remaining. 

4. Certain features available in the full version of this product may not be 

available in the Trial Version Product. 

C. YOU MAY NOT:   

1. install, use, distribute or copy the Trial Version Product except as expressly 

permitted in this License.  
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2. attempt to defeat any use restriction incorporated into the Trial Version Product, 

or translate, reverse engineer, decompile, or disassemble the Trial Version Product, 

except to the extent, if any, that such activities are clearly and expressly permitted 

by applicable law despite such restrictions. 

3. sell, transfer, rent, lease or assign the Trial Version Product, or allow any third party 

to benefit from or access the Trial Version Product on a "service bureau, "hosted 

application, or similar basis. 

4. modify the Trial Version Product, merge the Trial Version Product as part of any 

other product or collection of products, or create derivative works derived from the 

Trial Version Product or any component thereof, without the prior written consent of 

SmartDraw.com. 

5.  use the Trial Version Product, or any of its components, to create any product 

that competes with the Trial Version Product, the full version of this product, or any of 

their components. 

6.  transfer the Trial Version Product or your rights under this License to someone else. 

7. permit others to perform any of the activities restricted by this Paragraph C. 

In addition, in no event do we authorize you or anyone else to use the Trial Version 

Product in applications or systems where the Trial Version Product's failure to perform 

could reasonably be expected to result in significant physical injury, property 

damage, or loss of life, including but not limited to use in hazardous environments 

requiring fail-safe performance, such as in the operation of nuclear facilities, aircraft 

navigation or communication systems, air traffic control, direct life support 

machines, or weapons systems.  The Trial Version Product is not fault-tolerant and is 

not designed, manufactured or intended for any such use.  Any such use is entirely 

at your own risk, and you agree to defend, indemnify and hold SmartDraw.com, 

and its principals, shareholders, officers, employees, affiliates, contractors, and 

licensors, harmless from any and all claims or losses relating to such unauthorized 

use. 

D. TERM:   

Your license to use the Trial Version Product expires when the Trial Version Product 

ceases to function, as further described in Paragraph B.  In all events, this License 

shall remain in effect only as long as you are in full compliance with all of its terms 

and conditions, and shall terminate automatically if you fail to comply with any such 

terms or conditions.  Upon the expiration or termination of this License, you shall 

have no right to make any further use of the Trial Version Product, and you agree to 

destroy all copies of the Trial Version Product received, made or used by you in 
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connection with this License.  Paragraphs D, E, F, and G and your indemnity 

obligations hereunder shall survive the expiration or termination for any reason of this 

License.   

E. OWNERSHIP 

All patents, copyrights, trademarks, trade secrets and other intellectual property 

and other proprietary rights in the Trial Version Product are and shall remain in 

SmartDraw.com or its licensors.  The source code of the Trial Version Product and all 

information regarding the design, structure or internal operation of the Trial Version 

Product are valuable trade secrets of SmartDraw.com or its licensors ("Confidential 

Information"). To the extent, if any, to which you learn any Confidential Information, 

you shall not sell, transfer, publish, disclose, display, or otherwise permit access by 

any third party to, the Confidential Information.   The restrictions set forth in this 

Paragraph E do not apply to information that was publicly known prior to the time 

you received it, or which becomes known to you through no violation of any 

obligation of confidentiality on the part of you or any third party. SmartDraw makes 

use of GNU GhostScript, an open-source interpreter for the PostScript language and 

the PDF file format.  It is distributed under the GNU General Public License.  You may 

obtain the source code for GNU GhostScript from 

http://www.gnu.org/software/ghostscript/ghostscript.html. 

You shall not remove any copyright or other proprietary notices contained in or 

displayed on the Trial Version Product.  All rights of any kind in the Trial Version 

Product that are not expressly granted in this License are entirely and exclusively 

reserved to SmartDraw.com or its licensors.  

F. LIMITED WARRANTY; EXCLUSIONS OF LIABILITY:    

1.  THE PROVISIONS OF THIS PARAGRAPH F APPLY TO THE MAXIMUM EXTENT 

PERMITTED BY APPLICABLE LAW.  YOU MAY HAVE OTHER RIGHTS, WHICH VARY FROM 

STATE TO STATE AND COUNTRY TO COUNTRY. 

2.  THE TRIAL VERSION PRODUCT IS PROVIDED TO YOU FREE OF CHARGE AND "AS IS" 

WITHOUT WARRANTY OF ANY KIND.  SMARTDRAW.COM DOES NOT WARRANT THAT 

THE TRIAL VERSION PRODUCT WILL MEET YOUR REQUIREMENTS, OR THAT THE 

OPERATION OF THE TRIAL VERSION PRODUCT WILL BE UNINTERRUPTED OR ERROR FREE. 

THE ENTIRE RISK AS TO THE RESULTS AND PERFORMANCE OF THE TRIAL VERSION 

PRODUCT IS ASSUMED BY YOU.  SMARTDRAW.COM DOES NOT MAKE, AND HEREBY 

DISCLAIMS ANY IMPLIED WARRANTIES OF NONINFRINGEMENT, MERCHANTABILITY AND 

FITNESS FOR A PARTICULAR PURPOSE.  NO ORAL OR WRITTEN INFORMATION OR 

ADVICE GIVEN BY SMARTDRAW.COM, ITS DEALERS, DISTRIBUTORS, AGENTS OR 

EMPLOYEES SHALL CREATE A WARRANTY AND YOU MAY NOT RELY ON ANY SUCH 

INFORMATION OR ADVICE.  
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NEITHER SMARTDRAW.COM, ITS PRINCIPALS, SHAREHOLDERS, OFFICERS, EMPLOYEES, 

CONTRACTORS, AFFILIATES, LICENSORS, NOR ANYONE ELSE WHO HAS BEEN 

INVOLVED IN THE CREATION, PRODUCTION OR DELIVERY OF THE TRIAL VERSION 

PRODUCT, SHALL BE LIABLE FOR ANY BUSINESS INTERRUPTION, OR LOSS OF BUSINESS, 

DATA OR USE OF COMPUTER SYSTEMS, REGARDLESS OF HOW THE FOREGOING 

DAMAGES ARE CHARACTERIZED, OR FOR ANY DIRECT, INDIRECT, CONSEQUENTIAL, 

INCIDENTAL, PUNITIVE OR ANY OTHER DAMAGES ARISING OUT OF THE USE OR 

INABILITY TO USE THE TRIAL VERSION PRODUCT, EVEN IF SMARTDRAW.COM HAS BEEN 

ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. THE LIMITATIONS SET FORTH ABOVE 

SHALL BE DEEMED TO APPLY TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE 

LAW.  YOU ACKNOWLEDGE AND AGREE THAT YOU HAVE FULLY CONSIDERED THE 

FOREGOING ALLOCATION OF RISK AND FIND IT REASONABLE IN LIGHT OF THE FACT 

THAT THE TRIAL VERSION PRODUCT IS SUPPLIED TO YOU FREE OF CHARGE, AND THAT 

THE FOREGOING LIMITATIONS AND EXCLUSIONS ARE AN ESSENTIAL BASIS OF THE 

BARGAIN BETWEEN YOU AND SMARTDRAW.COM. 

G. GENERAL:   

This License forms the entire agreement between you and us regarding the subject 

matter set forth herein, superseding any other agreement or discussions, oral or 

written, and may not be changed except by a signed agreement. This License shall 

be governed by and construed in accordance with the laws of the State of 

California, excluding that body of law applicable to choice of law and excluding 

the United Nations Convention on Contracts for the International Sale of Goods and 

any legislation implementing such Convention. If any provision of this License is 

declared by a Court of competent jurisdiction to be invalid, illegal, or 

unenforceable, such provision shall be severed from the License and the other 

provisions shall remain in full force and effect.  The prevailing party in any action to 

enforce or interpret this License shall be entitled to recover its costs and expenses, 

including attorneys' fees.   

You agree to the exclusive jurisdiction of, and venue in, the state and federal courts 

located in San Diego, California, USA for any dispute or matter relating to, arising 

from or connected with this License.  Notwithstanding the foregoing, 

SmartDraw.com shall have the right to seek injunctive relief and the enforcement of 

judgments in any court of competent jurisdiction.  Any waiver by us of any violation 

of this License by you shall not constitute, nor contribute to, a waiver by us of any 

other or future violation of the same provision, or any other provision, of this License. 

The parties acknowledge and agree that no third party (including but not limited to 

your customers, clients or licensees) shall have any rights, either against us or our 

licensors, as a third party beneficiary of any rights, licenses, products or services 

granted or provided by us to you hereunder.  SmartDraw.com may freely assign or 
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delegate this License, in whole or in part.  This License is personal to you, and you 

agree not to assign or delegate, in whole or in part, this License or any of your rights 

or obligations hereunder.  Any assignment in violation of the forgoing restrictions 

shall be considered null and void.    

U.S. Government Users.  All software included in the Trial Version Product and 

provided to the U.S. Government, including its civilian and military agencies, is 

commercial computer software that was developed at private expense prior to its 

provision to any U.S. Government entity.  Subject to any applicable regulations set 

out in the FAR or DFARS (and any superseding regulations), the Trial Version Product 

is provided with the commercial license rights and restrictions described elsewhere 

in this License.  For Department of Defense agencies, the restrictions set forth in the 

"Technical Data - Commercial items" clause at DFARS 252.227-7015 (Nov 1995) shall 

also apply.  Contractor/manufacturer is SmartDraw.com, 9909 Mira Mesa Blvd. San 

Diego, CA  92131.   

You agree that your use of the Trial Version Product shall comply with all applicable 

laws and regulations.  Without limiting the foregoing, you understand that the Trial 

Version Product is subject to the export control laws and regulations of the U.S. or 

other applicable jurisdictions.  You agree that you will not export or re-export the 

Trial Version Product in violation of such laws or regulations.  

SmartDraw.com reserves the right to inspect your facilities, servers and computers to 

ensure that you are in full compliance with this License.  You agree that 

SmartDraw.com has the right to access and inspect your facilities, servers and 

computers for the foregoing purpose, including by using remote software monitoring 

tools without further notice to you. 

FURTHER RESTRICTIONS ON THE USE OF CLIPART, SYMBOLS, TEMPLATES, PHOTO 

OBJECTS AND PHOTOGRAPHIC IMAGES 

This Trial Version Product contains numerous clipart, symbols, templates and photo 

images (collectively referred to as the "Images"), which are owned by 

SmartDraw.com or its licensors.  As a user of this Trial Version Product, you are free to 

use, modify and publish the Images as part of your own work product, subject to all 

of the restrictions set out below and elsewhere herein, and any additional conditions 

described in the credits dialog of certain symbol libraries.  If you are uncertain as to 

whether your intended use is in compliance with the guidelines set out below, we 

recommend that you seek the advice of your own attorney or legal counsel.  

SmartDraw.com will not provide you with an opinion as to whether your use is in 

compliance with these guidelines. 

A.  YOU MAY, subject to any restrictions set out below and elsewhere herein, 

incorporate any Image(s) into your own original work and publish, display and 
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distribute your work in any media.  You may not, however, resell, sublicense or 

otherwise make available the Image(s) for use or distribution separately or 

detached from your own work product or web page.   For example, the Image(s) 

may be used as part of a web page design, but may not be made available for 

downloading separately or in a format designed or intended for permanent storage 

or re-use by others.  Similarly, clients may be provided with copies of the Image(s) 

(including digital files) as an integral part of your work product, but may not be 

provided with the Image(s) or permitted to use the Image(s) separately or as part of 

any other product. 

B.  YOU MAY NOT 

1. create scandalous, obscene, defamatory or immoral works using the Image(s), 

nor use the Image(s) for any purpose that is prohibited by law. 

2. use or permit the use of the Image(s) or any part thereof as a trademark or service 

mark, or claim any proprietary rights of any sort in the Image(s) or any part thereof. 

3. use the Image(s) in electronic format, on-line or in multimedia applications unless 

the Image(s) are incorporated for viewing purposes only, and no permission is given 

to those viewing the Images to download and/or save the Image(s) for any reason. 

4. rent, lease, sublicense or lend the Image(s), or a copy thereof, to another person 

or legal entity.   

5. use any Image(s) except as expressly permitted by this License. 

6. use any Image(s) that relate to identifiable individuals, products or entities in any 

manner that suggests their association with, or endorsement of, any product or 

service.  

7. make a modification to a licensed image which would remove embedded 

copyright information from the image. 

You acknowledge that neither SmartDraw.com, nor its principals, shareholders, 

officers, employees,  contractors, affiliates, or licensors, are liable for any offensive, 

harmful, illegal, indecent, incorrect, incomplete or inaccurate data, information or 

materials either comprising, part of, or associated with any Image or collection of 

Images.  You agree to defend, indemnify and hold harmless SmartDraw.com and its 

principals, shareholders, officers, employees,  contractors, affiliates, and licensors, 

from any and all third party claims and damages arising from your breach of any of 

the restrictions set forth herein.  

[BY CLICKING ON THE "I ACCEPT" BUTTON BELOW, YOU ACKNOWLEDGE THAT YOUR 

ARE BOUND BY THE TERMS OF THIS LICENSE.  IF YOU DOWNLOAD OR USE THE TRIAL 
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VERSION PRODUCT ON BEHALF OF ANY ORGANIZATION, COMPANY OR OTHER ENTITY, 

YOU REPRESENT AND WARRANT THAT YOU HAVE FULL AUTHORITY TO ENTER INTO THIS 

LICENSE ON BEHALF OF SUCH ENTITY.] 

SmartDrawNet Terms and Conditions 
At SmartDrawNet, users of either SmartDraw Photo or SmartDraw software can 

upload, edit, and organize their SmartDraw images at a location on the World Wide 

Web (that user's "Image Site"), and then share their images with their friends, family 

and colleagues.  SmartDrawNet is owned and operated by SmartDraw.com, A 

California Corporation, ("SmartDraw.com"). 

 

If you access or use either SmartDrawNet, any Image Site on SmartDrawNet, or any 

of services, materials or features appearing on SmartDrawNet or any Image Site, 

then you agree automatically to all of the terms and conditions below, including but 

not limited to agreeing to SmartDraw.com's Privacy Policy (collectively, the 

"Agreement").   

 

It is important that you read the Agreement.  If you do not accept any term or 

condition of the Agreement, you may indicate this only by not seeking access to 

SmartDrawNet.   

 

Please review the Agreement periodically, as it may be frequently revised and 

updated, at SmartDraw.com's sole discretion.    

Terms and Conditions 

 

Change of Terms or Conditions.  SmartDraw.com may change any term or condition 

of this Agreement, and change or discontinue any service or access previously 

offered or provided, upon notice posted in any area of SmartDrawNet reserved or 

created by SmartDraw.com for such purpose.  SmartDraw.com will use reasonable 

efforts to inform you of such changes through e-mail, bulletins or other comparable 

means, but you are responsible to check for SmartDraw.com's postings of such 

changes. 
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Creating and Maintaining an Image Site 

This Section 3 applies only to those with an Image Site at SmartDrawNet, except that 

the definitions in this Section apply throughout the Agreement. 

 

Age Requirement.  You must be at least 13 years of age to access or use 

SmartDrawNet.  

 

Image Storage.  You may store up to a total of 20MB of images on SmartDrawNet, 

for use at the Image Site established in connection with your account.  If you 

attempt to upload images exceeding this limit, you will be required to remove 

previously uploaded images before SmartDrawNet will accept new images.  All 

images, data and files transmitted or uploaded to SmartDrawNet for use in 

connection with Image Sites is referred to as "Content." 

 

Inactive Accounts.  If your account is inactive for more than 180 days, your account 

may be cancelled at SmartDraw.com's discretion.  SmartDraw.com will send you an 

e-mail message alerting you to the impending cancellation.  If SmartDraw.com 

receives no response within 30 days afterwards, SmartDraw.com may terminate your 

account, and remove or discard any images you may have stored.  Your account 

will be deemed "inactive" over a given period if SmartDraw.com determines that 

during that period, you did not add to or change any of the images on your Image 

Site, nor otherwise change your Image Site in any significant way.  Nothing in the 

foregoing shall limit SmartDraw.com's authority to remove any or all of your Content 

from SmartDrawNet at any time or terminate your account, with or without notice to 

you. 

 

Registration.  You may not set up or maintain an Image Site unless you have an 

active account for that purpose with SmartDraw.com.  In order to create such an 

account, you must register your copy of the SmartDraw or SmartDraw Photo 

software with SmartDraw.com, and submit to SmartDraw.com your correct name, e-

mail address and serial number for your software copy.  

 

No Restricted Content.  You may not transmit or upload, or cause to be transmitted 

or uploaded,  Restricted Content (as described below) to your Image Site or 

elsewhere on SmartDrawNet.  All content on SmartDrawNet is subject to review by 

SmartDraw.com, but SmartDraw.com has no obligation to examine all or any part of 

the submitted content.  SmartDraw.com may delete or remove any Content on 

SmartDrawNet in whole or part at any time, for any reason, without notice, 
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regardless of whether it qualifies as "Restricted Content." 

 

Restricted Content includes, but is not limited to: 

 

Content that is threatening, abusive, obscene, pornographic, defamatory, 

objectionable or inappropriate.  

Content that infringes or violates any copyright, trademark, patent or confidential 

agreement. 

Content that violates applicable state or federal law, or applicable orders or 

judgments of any government authorities. 

Content that promotes or assists in illegal activity.  

Content that in any way exploits or harms minors.  

Content intended for, or involved in, advertising or commercial solicitations. 

Content sent either from an anonymous or false address, or from a person or source 

whose description does not wholly correspond with the description of the account 

holder as recorded in SmartDraw.com's records. 

Content that contains software viruses, worms, Trojan horses or other dangerous 

code, corrupt files, or any other content which may alter, impair, or affect access to 

SmartDrawNet, or any materials or information on SmartDrawNet, or any other 

system reachable through or via SmartDrawNet 

Links to any of the foregoing content.  

 

 

Your Responsibility.  You are responsible for all of your activities on SmartDrawNet, 

and any and all Content that you submit, or cause to be submitted, to 

SmartDrawNet.  

 

No Infringement.  You hereby represent that each upload and\\or transmission by 

you of Content or any other materials to SmartDrawNet, and complete public or 

private display of any such Content or other materials on your Image Site or 

anywhere else on SmartDrawNet, does not and shall not violate or infringe any 

copyright, trademark right, patent right, trade secret right, or other right of any other 

person or entity. 
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Ownership.  You hereby represent that you are the owner of all Content and other 

materials you may cause to be uploaded or transmitted to SmartDrawNet, or that 

you have all necessary licenses for all uses to which such Content and other 

materials may be applied after upload or transmission. 

 

Backup Copies.  You are solely responsible for keeping copies of all of your Content 

and all of your other materials and data.  SmartDraw.com has no obligation to 

retain any copies of any Content that you upload or transmit, nor to retain any 

copies of your Image Site in whole or part. 

 

Misuse of Account.  You shall be fully responsible to SmartDraw.com for any and all 

use and misuse of any account assigned to or for you, whether by you or any other 

person or entity, regardless of whether such use or misuse is due to accident, 

recklessness, negligence, or deliberate act or omission, or without fault whatsoever.  

Such responsibility will include, but not be limited to, full indemnity for all injury, loss or 

damage incurred by SmartDraw.com in connection with such use or misuse, as 

further detailed in the Indemnity section below. 

 

Third-Party Products.  SmartDraw.com may make third-party products available 

through SmartDrawNet for use in connection with your Image Site. If you wish to take 

advantage of third-party offers or services, you must agree to any terms and 

conditions imposed by the third party vendor. 

 

Account Termination and Removal of Content.  At the sole discretion of 

SmartDraw.com, your account may be terminated and your Content may be 

removed or deleted without notice for, among other things: 

 

Conduct that violates this Agreement or the spirit of this Agreement. 

Conduct that violates SmartDraw.com's Copyright Policy. 

Conduct that violates SmartDraw.com's Privacy Policy. 

Conduct that impairs in any manner the operability or stability of SmartDrawNet. 

Conduct that violates SmartDraw.com's Restricted Content Policy. 
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In addition, SmartDraw.com may terminate your account and\\or remove your 

Content, with or without notice, at any time without cause.  If SmartDraw.com elects 

to explain or describe any reasons for terminating your account or removing your 

Content, this shall not affect or limit SmartDraw.com's power and right to terminate 

your account or remove your Content without cause, including action by 

SmartDraw.com without cause at the same time as, or at any different time from, 

any "for cause" action by SmartDraw.com. 

 

SmartDraw.com shall not be liable to you for any termination of your access to the 

site. 

 

Image Site Rules.  If you choose to implement any rules that apply to visitors to your 

Image Site, then: (i) any and all such rules are subject to review by SmartDraw.com, 

at SmartDraw.com's sole discretion, (ii) if SmartDraw.com requires, at its sole 

discretion, that any such rule be changed or deleted, you will immediately make 

such change or deletion, and (iii) no such rule may conflict with, violate, or be 

inconsistent with this Agreement, any SmartDraw.com or SmartDrawNet policy, or 

any applicable laws. 

 

Privacy Policy.  You accept and agree to all aspects of SmartDrawNet's Privacy 

Policy, as published on SmartDrawNet.  The Privacy Policy may be changed from 

time to time at SmartDraw.com's sole discretion, provided that any change that 

increases access to your information by person or entities outside Smartdraw.com's 

business organization shall not apply to your information that was provided before 

such change.  SmartDraw.com shall give reasonable advance notice of all changes 

to the Privacy Policy whenever practicable through notices displayed on 

SmartDrawNet. 

 

Scope of Access.  You agree to receive and use all services, data and products on 

SmartDrawNet in strict accordance with this Agreement, and all other rules, 

limitations, conditions, protocols and procedures as may be prescribed or endorsed 

by SmartDraw.com from time to time.  In no event may you seek any kind of access 

to, within or through SmartDrawNet beyond the level and kind of access expressly 

and knowingly authorized and provided by SmartDrawNet, nor may you use 

SmartDrawNet or any other SmartDraw.com system or facility to gain unauthorized 

access to the systems, information, materials or property of SmartDraw.com or 

anyone else.  If you nonetheless seek or gain such access, you shall be conclusively 

deemed to be exceeding your authorized access to SmartDrawNet for all purposes 
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under the law, and in violation of this Agreement. 

 

SmartDrawNet System Rules.  You agree to comply fully with any and all rules and 

terms that SmartDraw.com may prescribe from time to time for use of SmartDrawNet 

("System Rules").  System Rules include all rules posted by SmartDraw.com in one or 

more special areas of SmartDrawNet set aside for System Rules, plus all other rules, 

warnings, disclaimers and notices that SmartDraw.com may post at various points 

around SmartDrawNet.  Some System Rules extend the provisions of this Agreement, 

others cover areas not touched by this Agreement.  In any event, if you violate any 

System Rule, it shall be deemed a violation of this Agreement. 

 

Your Limited Use Rights.  You may download and use Content and any other 

information received through SmartDrawNet within your own personal computer or 

terminal, provided you legally obtained such information, and subject to any 

restrictions by the owner of, or legitimate claimants against, such information.  You 

may not use any of the Content or other information received through 

SmartDrawNet for any other purpose, including but not limited to distributing, 

modifying, transmitting, displaying, performing or otherwise exploit any such 

Information, except where any such activity is expressly and clearly authorized to 

you by the owner of such information. 

 

Problem Transmissions.  A transmission by you shall be considered a "Problem 

Transmission" if it, in SmartDraw.com's opinion, is or may be: (i) in conflict with any of 

your warranties, representations or undertakings in this Agreement, (ii) illegal, or (iii) 

harmful in any manner either to SmartDraw.com or third parties.   If at any time 

SmartDraw.com discovers that all or any part of a transmission by you is or may be a 

Problem Transmission, then SmartDraw.com may act upon and dispose of such 

Problem Transmission as it deems prudent under the circumstances in its sole 

discretion, including but not limited to destroying all or any part of the Problem 

Transmission, returning all or any part of the Problem Transmission to you, holding all 

or any part of the Problem Transmission as potential evidence, and turning over all or 

any part of the Problem Transmission over to any government agent or authority, 

and monitoring other messages or transmissions from you or others where 

SmartDraw.com deems such monitoring necessary or helpful to protect itself or 

others.  SmartDraw.com shall use good faith best efforts to avoid intruding upon your 

privacy  when possible, though in no event shall such obligations apply so as to 

place SmartDraw.com or other persons or entities at possible legal or other risk 

relating to your transmissions or your other activities. 
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Disclaimer Of Warranty.  All Content and other information and materials received or 

available through SmartDrawNet and any Image Site are provided on an "As Is" 

basis without warranties of any kind, either express or implied, including, but not 

limited to, any implied warranties of merchantability, fitness for a particular purpose, 

title and non-infringement.  Neither SmartDraw.com nor any other supplier of 

information, products or services at SmartDrawNet makes any warranty that 

SmartDrawNet or any products or services at SmartDrawNet will be available without 

interruption, timely, secure, or error free, nor that SmartDrawNet or any products or 

services at SmartDrawNet is free of viruses or other harmful software, data or 

materials. 

 

Assumption of Risk.  You understand that your access to and use of SmartDrawNet, 

or any Content, products or services at SmartDrawNet, is entirely at your own risk. If 

you are dissatisfied with or injured by any of SmartDrawNet's Content, products or 

services, your sole remedy is to discontinue your access to and use of such Content, 

product or service. 

 

Third Party Sites.  You acknowledge that SmartDraw.com has no control whatsoever 

over the contents of third party web sites that link to or from SmartDrawNet or any 

Image Site.  SmartDraw.com makes no assurance whatever that such third party 

content will be accurate, legal and\\or inoffensive. Furthermore, SmartDraw.com 

does not endorse the content of any third party web site, whether or not it is linked 

to SmartDrawNet, nor can SmartDraw.com warrant that such third party sites 

and\\or content will not contain viruses or otherwise impact your computer. You 

understand and agree that neither SmartDraw.com, nor its owners, executives, 

employees or affiliated entities shall be responsible for damages or losses resulting 

from your use or accessing of any third party web sites or any of the content, 

services, products or features contained therein. 

 

Damage to Equipment or Data.  Neither SmartDraw.com nor its owners, executives, 

employees, officers, directors or affiliated entities shall be responsible for any of the 

following: (a) damage caused to your computer or viruses which may affect your 

computer as a result of accessing SmartDrawNet or any Image Site, or utilizing any 

of the services, data or products at SmartDrawNet; or (b) any damage or loss to any 

of your data, files or correspondence posted, housed, or stored on SmartDraw.com's 

computer systems or servers. 
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User Generated Content.   SmartDraw.com is not responsible to any third party for 

any injuries or damage caused by user generated Content, including but not limited 

to all Image Sites and all Content on Image Sites.  You acknowledge that: (a) none 

of the user generated Content on SmartDrawNet, including without limitation web 

pages, photos, artwork, images, articles, text, links, and data files, necessarily 

represents the view or opinions of SmartDraw.com, and (b) SmartDraw.com has no 

policy or business practice of previewing of user generated Content prior to its 

appearance on SmartDrawNet. 

 

Limitation of Liability.  To the fullest extent permitted by applicable law, under no 

circumstances shall SmartDraw.com be liable to you, or anyone claiming under or 

through you, for any indirect, incidental, special or consequential damages, 

including, but not limited to, damages for loss of profits, use, data or other 

intangibles, even if SmartDraw.com has been advised of the possibility of such 

damages, that result from the use, or inability to use, SmartDrawNet or any products 

or services at SmartDrawNet, from any changes to SmartDrawNet or any products or 

services at SmartDrawNet, from information, data or other materials available on 

SmartDrawNet, or from alteration of, or any access to, your transmissions, data, or 

information regarding your activities at SmartDrawNet or any Image Site. Some 

jurisdictions do not allow the limitation or exclusion of incidental, consequential or 

other types of damages, so some of the above limitations may not apply to you. 

 

 Indemnity.  You agree to indemnify, defend and hold harmless SmartDraw.com 

and its officers, directors, employees, agents, licensors, suppliers and third-party 

information providers, from and against any and all losses, claims, proceedings, 

judgments, orders, expenses, damages and costs (including reasonable attorneys' 

fees and costs) resulting from or relating to: (a) any violation of your obligations, (b) 

the falsity or alleged falsity of any of your representations, or (c) any activity related 

to your account (including but not limited to any negligent or wrongful conduct) by 

you or any other person accessing the services using your account. 

 

  General. 

 

Assignment.  You may not assign or delegate any of your rights or obligations under 

this Agreement without the prior written consent of SmartDraw.com. 

  

Notices.  All notices to you may be sent to your e-mail address, and\\or street 

address, and\\or any other location for which SmartDraw.com has contact 
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information for you.  All notices to SmartDraw.com shall be in writing and shall be 

forwarded by registered or certified mail or by overnight express courier requiring 

signature of the recipient to complete delivery, and sent to SmartDraw.com at the 

following address: 

 

SmartDraw.com 

9909 Mira Mesa Blvd.  

San Diego, CA 92131 

Phone: 800-768-3729 (toll-free) 

Phone: 858-225-3300 

Fax: 858-225-3390 

E-mail: mail@smartdraw.com 

 

Notices sent by registered or certified mail shall be deemed delivered seven (7) 

business days after mailing; notices sent by express courier shall be deemed 

delivered the next business day after they are given to the courier by the notifying 

party; notices sent to you by e-mail shall be deemed delivered within one (1) hour 

after they are sent by SmartDraw.com.  

 

Governing law.  All matters relating to this Agreement will be governed by the laws 

of the State of California, U.S.A., without regard to California's choice-of-law rules. 

Exclusive jurisdiction and proper venue for all proceedings relating to this Agreement 

shall be in courts and other fora located in the State of California, U.S.A., and you 

hereby consents to such jurisdiction and venue. 

 

Waiver.  The failure of either SmartDraw.com or you to insist upon strict performance 

of any provision of this Agreement shall in no way constitute a waiver of future 

violations of the same or any other provision. 

 

Severability.  If any part, term or provision of this Agreement shall be held illegal, 

unenforceable or in conflict with any law of a federal, state or local government 

having jurisdiction over this Agreement, the validity of the remaining portions or 

provisions shall not be affected thereby.  

 

Force majeure.  No party shall be in default if failure to perform any obligation 

hereunder is caused solely by supervening conditions beyond that party's control, 

including acts of God, civil commotion, strikes, labor disputes or governmental 

demands or requirements.  
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Entire Agreement. You acknowledge that you have read this Agreement, 

understand it, and agree to be bound by your terms. You further agree that this 

Agreement is the complete and exclusive statement of agreement and supersedes 

all proposals, oral or written, understandings, representations, conditions, warranties, 

covenants, purchase orders and all other communications with Smartdraw.com 

relating to this Agreement. No additional terms, whether consistent or inconsistent 

with those contained in this Agreement, shall be binding on either party absent 

mutual and prior specific written consent. 

 

Survival.  All provisions of this Agreement relating to post termination actions and 

indemnities, and your obligation to pay all amounts due for services rendered by 

SmartDraw.com, shall survive any termination or expiration of this Agreement.  

 

Headings.  The headings in this Agreement are intended for convenience of 

reference and shall not affect its interpretation. 

 

No Third Party Beneficiaries.  There shall be no third party beneficiaries of any of 

SmartDraw.com's undertakings, representations or warranties in this Agreement. 

 


