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Intro
The Cumulus® Digital Asset Management System provides powerful

tools for archiving, managing and marketing your digital files.

Cumulus can store any type of digital media assets, including all types

of documents, images, audio, video, layouts from publishing pro-

grams, presentations, and PDF files. Once assets are stored, Cumulus

becomes a central media repository from which you can view, locate,

search, organize, copy, move, categorize, and otherwise manipulate

the cataloged assets. Once you've settled on a process for storing and

retrieving your digital assets that works for you, the process can be

automated, further enhancing the efficiency of your workflows. 
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Canto Cumulus Single User
Canto offers different editions of Cumulus. Canto Single User is the perfect stand-
alone central media repository to efficiently catalog, organize and reuse any type 
of digital file.
This guide covers the functionality of the Canto Cumulus Single User Edition. How 
to install Canto Cumulus Single User is described in a separate Installation Guide.
• Special functions – Learn the basics of working with the Cumulus URL Asset-

Store Module and find out how Cumulus supports MS Office documents or 
RAW Images. (See “Specialized Usage chapter, starting on page 85.)

• Catalog management – Describes how catalogs manage the media assets 
stored on your system, how to define the properties of individual catalogs 
and how to maintain the catalog files (copy, compress, back up, divide, 
merge, etc.). (See “Managing Catalogs” chapter, starting on page 141.)

Cross-Platform Issues
Cumulus is a cross-platform application, meaning that it runs on Windows® and 
Mac® OS X (Macintosh®) systems. Though the program’s features are identical in 
each version, portions of the user interface differ due to operating system or key-
board conventions. These differences are denoted or explained when necessary 
and assumed otherwise (e.g., the difference between “maximizing” a window in 
Windows, and “zooming” a window in the Mac OS X is not explained).

This icon denotes what pertains to Mac OS X only.
This icon denotes what pertains to Windows only.

User Interface Item Conventions
To differentiate user interface items – buttons, menus, text fields, etc. – from sur-
rounding text, those items are displayed in bold. For example:

“Click the Open button.”
To differentiate menu hierarchies, the > character is used. For example:

“Select File > Open to open a file.”
This example means to select the Open item from the File menu.

Understanding Cumulus
To get started with Cumulus, you need to understand only a few basic concepts. 
Cumulus creates special files called catalogs, which Cumulus uses to keep track 
of your valuable assets. As you catalog your assets, Cumulus creates special cata-
log entries called records that represent the assets to be managed. Each record 
contains vital searchable information about the asset it represents. To make 
searching and retrieving records easier, Cumulus lets you organize and classify 
records into logical groups called categories. Any individual set of records com-
prises a collection. A collection is a way of looking at catalog(s).

Assets
An asset in Cumulus is simply any one cataloged file or data stream. A video clip, 
an audio clip, an image, or a page layout document are examples of files that are 
commonly cataloged in Cumulus. But the word file suggests an asset that is 
stored on a digital medium like a hard-disk or CD-ROM. What if the asset is a 
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record in a database? This is not a file per se, but as far as Cumulus is concerned, 
it is a data stream that can be cataloged, kept track of and accessed. 

Catalogs
Like a filing cabinet, Cumulus catalogs serve as storage locations for asset collec-
tions. You can have as many catalogs as you like. Catalogs are cross-platform 
compatible, so it doesn’t matter what type of computer is used to create a cata-
log. For more information, see “Catalogs”.

Collections
Collections are like snapshots from your open catalog(s). When you work with 
your assets in Cumulus, you’re viewing a constantly changing group of records. 
Without collections, each view of this group would be lost as soon as it is was 
changed. Collections, however, enable you to capture any particular set of 
records and save it as you see it - all without disrupting your workflow. Once you 
see something you like or could use again, save it as a collection and recall it 
whenever you need it. You can even send your collection as an attachment to an 
e-mail message in one easy step.
A collection also acts as your temporary workspace in Cumulus, meaning that 
changes made to your collections do not affect the content of your catalogs. 
Even deleting a record from a collection does not remove it from the catalog 
(unless you really want it to, which you can do, too). For more information, see 
“Collections”. 

Categories
Like folders in a filing cabinet, Cumulus categories serve to organize assets (files). 
But here the similarities end. Assets can appear in any number of Cumulus cate-
gories at the sametime. For more information, see “Categories”. 

Records
Records represent assets. Each record represents one asset. Records hold infor-
mation on the asset, such as file size, type, location, creation date, and much 
more. Cumulus allows the creation of customizable record fields, which can con-
tain almost any sort of information you desire. Since these user-defined record 
fields are also fully searchable, you can tailor Cumulus to fit your requirements.
It’s very important to draw the distinction between records and assets. Records 
are part of Cumulus catalogs; assets are not. Records represent assets. For more 
information, see “Assets/Records”.
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Explore Cumulus
In order to exploit the potential of Cumulus fully, it’s necessary to pro-

ceed from a strong foundation. It’s a good idea to know the meaning

and capabilities of the features you’re using in Cumulus and how

they’re related. This section contains an overview of the Cumulus

interface and describes the basic components of Cumulus in more

detail – catalogs, collections, records, and categories.
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verview: The Cumulus User Interface
e Cumulus main window, your workspace, is the Collection window. It provides two main panes, the Category

ane and the Record pane. Additional panes, e.g. the Info pane, can be activated.

Main Toolbar – provides icons for some of the most popular functions and for modifying the workspace. For details refe
to the tooltips that appear when hovering with the mouse over an icon.

Category Pane – displays categories. Each Cumulus catalog is represented by a main category which has by default 
three subcategories. These correlate with the Category Tabs.
The top bar of the Category pane indicates the total number of categories in all open catalogs, the number of currently 
visible categories and the number of selected ones (if any).
Additionally, the Category pane top bar contains three icons:

indicates the active category search options; opens the Search & Sort preferences 
opens a menu to change the Category View Set
closes the Category pane

Record Pane – displays the records of cataloged assets..
The top bar of the Record pane indicates the total number of records in all open catalogs, the number of currently visible
records and the number of selected ones (if any).
Additionally, the Record pane top bar contains icons and selection lists:

displays and/or activates filters
toggles the sort order (ascending/descending)

displays the current sorting criteria; 
clicking on the arrow opens a selection list of available sorting criteria (record fields)
displays the current Record View Set; 
clicking on the arrow opens a selection list of available Record View Sets

opens/closes a subpane of the Record pane (for more information, see page 80.)

Status Bar – contains icons for toggling the display of additional panes and one icon to change the order of the left 
side panes:

opens a menu to mange the workspace
hides/shows the Category pane
shows/hides the Information pane (providing further information on the selected record)
shows/hides the Category Information pane (providing information to the selected category)
shows/hides the Thumbnail pane
shows/hides the Preview pane
shows/hides the Calendar pane
All panes listed above are displayed on the left side of the Record pane.
shows/hides the Collection Basket pane on the right side of the Record pane
opens a dialog to rearrange the order in which the panes on the left side are displayed.

2 3

4
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Catalogs
A Cumulus catalog is a group of records that, together, represent the assets you 
want to manage. Each asset is represented by one record. There is no limit to the 
number of different media file formats that can be represented in one catalog. 
One of the greatest features of Cumulus is its ability to catalog any digital asset, 
in addition to the file formats directly supported. 
A catalog has a database file at its core. The way you work with the information 
in this file can be extensively customized. 
When you catalog assets, the catalog settings determine how and what sort of 
information Cumulus extracts, creates and stores on the assets as metadata in 
the record fields and category fields.
Each catalog can have its own distinct properties. Any changes made to the catalog 
settings affect the way information is stored on all of that catalog’s assets.  To set 
up a catalog to store information in addition to or differently from the default set-
tings, fields can be added to the catalog either by activating them from the list 
of fields that Cumulus supports or by defining your own custom fields. 

Catalog Size and Performance
As catalogs increase in size, so do the requirements they place on computer 
hardware. It takes more processing power to work with 200,000 records than it 
does with 200. It also takes more RAM to hold the larger catalog in memory. 

NOTE: The unique way Cumulus searches for records prevents large catalogs 
from slowing down the search speed.

There is virtually no limit to the size of a catalog file (up to 1 TB). Most users will 
find it best to split catalogs for organizational and performance reasons. The 
actual number of records that can be stored in a catalog and the catalog’s actual 
file size is determined by the size of each record. (See “Record Size,” p. 21.)

Catalog Scope
Catalogs can include records for as many different asset types as you like. But you 
may find it best to have different asset formats cataloged independently. For 
example, it might not make sense to have your image assets in the same catalog 
as your audio clips, though it is possible. 
On the other hand, don’t limit the scope of each catalog too much. For example, 
when you’re looking for an image to use on a Web page, do you care if it’s in GIF 
or JPEG format? Separating similar asset types by specific file format can be 
inconvenient when searching. Cumulus cannot search through catalogs that 
aren’t open. If each of your image file formats has its own catalog, they’ll all have 
to be open if you want to search through all of them. Remember, you can use 
Cumulus’ categories or built-in information fields to find files based on format, 
projects in which they were used, or status, for example.

Things You Can Do with Catalogs
• Backup. (See “Backing Up Catalogs,” p. 163.)
• Change catalog setting. 

(See “Catalog Settings,” p. 142.)
• Compress. (See “Compressing Catalogs,” p. 162.)
• Copy a catalog. (See “Copying Catalogs,” p. 164.)
• Create a new catalog. (See “Creating Catalogs,” p. 159.)
• Delete a catalog. (See “Deleting Catalogs,” p. 164.)
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• Divide a catalog into smaller catalogs. (See “Dividing Catalogs,” p. 165.)
• Open an existing catalog. (See “Open Catalog,” p. 170.)
• Rename a catalog. (See “Renaming Catalogs,” p. 164.)
• Repair a damaged catalog. (See “Repairing Catalogs,” p. 164.)
• Search through a catalog. (See “Searching,” p. 32.)
• Set the catalog’s properties as defaults. (See “Repairing Catalogs,” p. 164.)
• Update catalogs from earlier Cumulus versions. (See “Migrating Catalogs,” 

p. 165.)

Adding Assets to Catalogs
The term cataloging describes the process of importing and storing information 
about your digital assets. This information, called metadata, is the data associated 
with a digital asset beyond the actual file data itself. So, while the words you type 
in a Microsoft Word file constitute the file’s data, the file’s name, size, location, 
author, creation date etc. are examples of the file’s metadata.
Some metadata is added to assets automatically by the software used to create 
or edit the asset. This is the case with the most common file metadata, such as 
size and modification date. But, depending on the creating software (or hard-
ware), additional metadata can be embedded, too. This is the case with digital 
cameras that embed photo shoot dates, camera type, lens aperture and shutter 
speed, and even the GPS coordinates of the shot location into the files. 
Additional metadata can be added after the asset has been cataloged. An asset's 
metadata serves as the basis for how you find the asset, so it’s important that 
your DAM system enables you to create as much metadata as you need. For 
example, if you need to find photographs based on the photographer’s name, 
you want to make sure photographer names are included in the metadata stored 
for your photograph assets. If you need to find a Microsoft Word file that includes 
a certain text phrase, is associated with a given fiscal year's revenue, and edited 
within the last month, the proper metadata enables that too. A complete DAM 
solution like Cumulus can also enable you to automatically find all images used 
in that document, and even find the PDFs that were later generated from it.
With regard to file formats, Cumulus can catalog any type of digital asset and 
offers enhanced support for the most popular formats. The term “enhanced sup-
port” means different things, depending on the file format in question. For exam-
ple, Cumulus offers enhanced support for Adobe® InDesign® and QuarkXPress® 
files by enabling you to preview individual layout pages right from within 
Cumulus. Enhanced support for Microsoft® PowerPoint files enables you to actu-
ally generate new PowerPoint presentations—right from within Cumulus—
using assets and PowerPoint slides cataloged in Cumulus. Enhanced support for 
Microsoft® Word, Excel, Illustrator and PDF files includes extracting text that's 
included inside the files and making it searchable catalog metadata. So, not only 
can you find the files in Cumulus based on metadata—file name, modification 
date, production status, etc.—you can also find some files based on their actual 
contents. 
When you catalog digital assets, Cumulus performs a number of behind-the-
scenes tasks in order to generate an asset record that best represents the asset. 
It’s easiest to think of these tasks as a series of steps through which the asset 
flows during the cataloging process. They are:
• Filters
• Metadata Extraction
• Field Linking
• Metadata Templates
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• Central Asset Storage Options
• Asset Handling Sets

Filters   
Filters provide “knowledge” of a given asset type to Cumulus. They are, in fact, 
what enables the program to offer enhanced metadata support for so many file 
formats. For example, the JPEG filter knows to parse incoming JPEG assets for 
information common to that file type, such as horizontal and vertical dimensions 
(and much more). The MP3 filter extracts audio-related metadata, such as length 
and sample rate. Filters are like plug-ins—they can be added, activated and 
deactivated at any time. The Cumulus SDK (software development kit) enables 
others to create custom filters.

Metadata Extraction 
As mentioned, all file formats include at least a basic set of metadata that 
Cumulus captures during the cataloging process. For many file formats, this core 
information is the only metadata captured during cataloging. Some formats, 
however, store extensive metadata right “inside” the file itself through the use of 
metadata standards called XMP, IPTC and EXIF. Popular formats that support one 
or more of these standards include JPEG, PDF and TIFF.
Many applications enable users to “stuff” metadata directly into files using these 
standards. During the cataloging process, Cumulus copies this data into the asset 
record, making it easily searchable. (Cumulus can also write data back into some 
“metadata fat” file formats.)
Metadata can also come from sources other than assets, such as databases or 
financial systems. Cumulus enables you to import metadata originating from 
sources like these into your catalogs through a menu command. This offers a 
great way to synchronize your Cumulus catalogs with other systems, such as 
product databases or financial systems. 
For example, say you have a database that contains details about each of your 
products—UPC codes, color options, sizes, etc.—and you use Cumulus to keep 
track of product photographs used for packaging, online sales and advertising. 
By importing the product data into Cumulus, you can perform the same searches 
for product images as you can for product information.
This is a workflow example already in use successfully at Cumulus installations 
now. One customer produces weekly fliers that showcase sale items. UPC codes 
for products to be featured are sent to the graphics department who then use 
Cumulus to find acceptable product images. This ensures the correct image is 
used for each product in the advertisements. (If you’ve ever seen a weekly mailer 
that describes one product, but shows another, you can understand the value of 
this workflow.)
Category trees can also be constructed based on imported data. This makes it 
easy to create an organizational structure that’s familiar to your employees: just 
provide Cumulus with a text file that represents your current organization struc-
ture, and the category tree is created for you automatically. The import function 
can also make upgrading to Cumulus from other DAM systems much easier.
No matter what the origin, Cumulus stores all metadata in catalog fields. A 
default set of fields is provided with each newly created catalog, and you can also 
define any number or type of custom fields you need. Later, you’ll read about the 
various field types available in Cumulus.
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Field Linking 
Cumulus can map and copy the metadata found inside your assets to appropri-
ate fields inside your Cumulus catalogs. So, for example, the contents of the 
“Notes” field in the asset can be copied to the “Notes” field in the catalog. 
You can also define field links of your own, in case you want to override default 
mappings, or create new ones. This is especially helpful when you want certain 
fields in your catalog to serve the same purpose for different asset types. 
For example, say you work with video in both QuickTime and Windows Media 
formats. QuickTime includes a standard metadata field for video that's called 
“Writer.” Windows Media, on the other hand, includes a field called “Author.” You 
could have fields in your catalogs for both, but then you'd have to include both 
when searching for that information. A more convenient way to go about this 
would be to choose one of those field names for your Cumulus catalog and use 
field linking to map the contents of the other field to that field. That way Quick-
Time “Writer” and Windows Media “Author” metadata are stored in the same cat-
alog field, making searching a breeze.
Asset metadata fields can also be field-linked to generate Cumulus categories. 
This is handy if your assets contain metadata keywords that you want translated 
into Cumulus categories. Cumulus can even generate category trees that emu-
late the folder structure the asset was found in. If your current folder structures 
are based on hierarchies that enhance your workflow, this option offers a great 
way to get instant category trees that will be familiar to users.

Collections
A collection is Cumulus-speak for a set of records from any one catalog or even 
multiple catalogs. It is a way of looking at your catalog(s) – the way that you look 
at it at any given time. Whenever you work with assets in the record and category 
panes – which make up the Collection window – you’re creating or modifying 
collections. When you view the records in any category, you’re looking at a col-
lection. When you view the results of a search, you’re also looking at a collection. 
The same is true for individual records you’ve dragged and dropped into the win-
dow – any ‘snapshot’ of your catalog can comprise a collection. A collection acts 
as your temporary workspace in Cumulus, and you can also save it as a file.
While a collection can contain all records in a single catalog or all in a single cat-
egory, it is neither one nor the other. A collection can also contain – and here is 
where its advantages become obvious – the results of a search (either as a new 
collection or replacement of the current collection), or any records you drag and 
drop into the Collection window. Any individual set comprises a collection. The 
records in one collection may even belong to different catalogs.
Once saved, a collection file remembers the records it contains and the Record 
View Set used. A collection file also keeps track of column width of the Details 
View.
Assume, for example, that you have a catalog containing thousands of records 
organized neatly into categories. Your latest project, however, only requires 
assets from four of those categories, and from those it only requires the image 
files. You could first run a search to pull all image files from those four categories. 
Then you could select a Record View Set and emphasize the exact information 
you need for this project. Save the collection, and from now on you can simply 
open the collection containing the records you really need – while the entire cat-
alog remains available to you in the background. You could then e-mail the col-
lection to in-house members of the project team.
A collection, whether saved or unsaved, is always connected to its catalog(s). 
When a collection is open, the catalog(s) storing the records of the collection are 



EXPLORE CUMULUS –  COLLECTIONS 17
also open. In order to open a particular collection, you must have access to its 
catalog(s). If a record is removed from a catalog, it is removed from any of the col-
lections it was in. Similarly, if you delete a category, it is deleted not only from one 
collection, but also from the catalog.
You can, however, delete a record from the collection without deleting it from 
the catalog – as long as you press only the DEL key. But if you press both 

Command / Control and DEL, the record will be removed from both col-
lection and catalog (see “Delete,” p. 178, for more information).

Working with Collections
Collections can be customized and then saved, so that your particular prefer-
ences for a special set of records can be recalled. A collection file remembers the 
records it contains, the Record View Set used and the column width of the Details 
View.
As collections are such flexible and malleable creatures, it might be a good idea 
to save your special collection once you have configured it. This is because an 
unsaved collection with its specific configuration is not automatically saved when 
you close it. And as soon as your collection changes – which can happen quite 
often – any unsaved changes are lost. Saving a collection is easily done via File > 
Save Collection As. A dialog appears for you to choose the name and location for 
the collection file. Once a collection is saved, it is easy to open via File > Open Col-
lection
When you create a new collection via File > New Collection, it can either be 
empty or contain the currently selected records. However, concerning the view, 
the new collection will be a copy of the active collection. In other words, the col-
ors, fonts, and fields of the new collection will be the same as the previous one. 
From here, you can proceed to make any changes you like while retaining the old 
collection in the background. You might want to save your new collection after 
you have assembled the desired records and carefully arranged them.
Collections stored with previous Cumulus versions can be imported (File > 
Import  > Collections.) To store collections at any location, you can use the 
export function (File > Export  > Collections.) 
For sending a collection via email to another user, a special export function is 
provided (File > Export  > Mail Collection To.) However, don’t forget: Since a col-
lection is always connected to catalog(s), it is necessary for the recipient to have 
access to the catalog(s) ‘serving’ the collection.
To make use of a collection you received, you use the import function. 

Things You Can Do with Collections
• Create a new collection. (See “New Collection,” p. 170)
• Open an existing collection. (See “Open Collection,” p. 171.)
• Save a collection. (See “Save Collection As,” p. 171 and “Save Collection,” 

p. 171.)
• Search through a collection. (See “Searching,” p. 32.)
• Send a collection by e-mail. (See “Export,” p. 174.)
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Assets/Records
In Cumulus, each asset is represented by one record. Cumulus is able to catalog 
every sort of digital asset such as Photoshop® image files, video clips, sound clips, 
or QuarkXPress® page layouts. However, a digital asset can also be a spreadsheet 
file or even a data stream such as an entry in a data bank that Cumulus is keeping 
track of for you. Records can contain a thumbnail image of the asset. Records can 
(and should) be categorized for easy maintenance and searching. (See “Catego-
ries,” p. 24, for more information.)
Records are not actual copies of the asset. They merely "point" to the original file. 
This saves disk space and avoids confusion caused by maintaining multiple cop-
ies of an asset. Records contain information on the assets, which is called meta-
data. Using metadata makes it possible for Cumulus to track your assets and find 
their records at lightning-speed. A record is the sum of metadata stored on an 
asset. The metadata is kept in Record Fields.
Canto is setting the pace in the asset management field with its TAG files, which 
hold all of the information that can be viewed in the Asset Information applica-
tion – and more. TAG files have been developed by Canto to be the standard file 
format for the storage of metadata in the field of asset management. Cumulus 
can create TAG files when cataloging assets from a location where the user is 
allowed to save files. For how to activate this option, see “Browse for Assets,” 
p. 171.
All records contain at least some searchable information in their record fields on 
the asset file they represent. Generally, the range of information each record 
includes depends on the kind of asset represented.
However, Cumulus makes it possible to determine precisely what sort of infor-
mation should be kept on assets. Remember, this can be defined differently for 
each catalog as each catalog has its own properties. It is the catalog settings that 
determine what information is stored on the assets in the record fields. 
As it comes ‘out of the box,’ Cumulus has many record fields ready to be filled 
while cataloging, depending on the nature of the asset. Not all of the record 
fields that Cumulus supports are activated with Cumulus’ default settings. 

Asset Information
The information stored on an asset can be viewed and edited in the Information 
view or in the Information window. 
What you see depends on:
• the fields selected to be displayed in the current Record View Set.
• the fields of the catalog the asset is cataloged in and whether these fields 

contain any information or not.

TIP: 
The View Set you select should match with the catalog(s) you use it 
with. For example, if you have a special catalog for images that 
includes all fields that are important for images and you use a View Set 
that was designed for audio files, you may not see much information. 
If the catalog does not contain the fields that are selected for display 
in the View Set, no information can be displayed.

TIP: 
You can easily access the preferences of Record View Sets by selecting 
the Customize entry in the list for selecting Record View Sets. This 
entry opens the preferences for the current Record View Set.
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To change to the Information View, click  on the toolbar.
To open the Asset Information window for an asset:

1. Select the record of the asset of which you want to see the information.

2. Select Metadata > Information or click  on the toolbar. The Asset infor-
mation window opens.

Once the Asset Information window is open you can use the arrow buttons to 
load other records into the window. For more details on the Information win-
dow, see “Information Window,” p. 28.

Field Types
Information on assets can be viewed and accessed via record fields and informa-
tion on categories can be viewed and accessed via category fields. Cumulus can 
store different kinds of information. Consequently, Cumulus features many dif-
ferent field types for storing information. The different field types are (the exam-
ples are drawn from the default record fields):
• String – Can be used to store textual information (e.g. Notes). 
• Boolean – Great for on/off, yes/no options. Displays as a check box (e.g. Don’t 

Delete Record).
• Integer – Any non-fractional number up to 32 bits (e.g., non-decimal num-

bers as a price of $2).
• Real – Any number up to 64 bits (e.g., a decimal number such as a price of 

$2.99).
• Long – Can store 64-bit integer numbers. 
• Data Size – size in bytes (can store 32-bit values up to 4 GB) 
• Data Size (Long) – size in bytes (can store more than 4 GB values up to 64-bit 

values)
• Date – Any valid date (day and time) later than 1970 entered in the format of 

your computer’s system settings (e.g., Record Modification Date).
• Date only – any valid date for any day entered in the format of your com-

puter’s system settings.
• Time only – Any valid time of day entered in the format hh:mm:ss. Optionally 

you can also enter milliseconds by employing a dot as separator: 
hh:mm:ss.123

• Length – in inches – displayed in the measurement you have chosen in your 
User Settings for the Cumulus application.

• Resolution – in dots per inch.
• Binary – Not user-editable; administered by custom asset information appli-

cations, which can manipulate and store binary data for further automation.
• Asset Reference – Special binary field used for asset references only. Not 

user-editable.
• Picture – Pictures can be pasted into these fields (e.g., Thumbnail).
• String List – This field type supports lists, such as menus, which can make 

data entry easier. The items in the list can be defined by the user (e.g., Status). 
• Audio – Can store voice annotations that can be recorded directly into the 

computer or come from the assets themselves.
• Label – Enables users to label records by assigning colors. 
• Rating – Enables users to rate assets or records. 
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• Table – Special field type that can include other metadata fields. This field 
type was designed for special usage purposes, e.g. the user comments added 
to a preview are managed by such a field. The fields included in a Table field 
can be configured to be searchable and sortable.

Asset Types Supported
Cumulus can catalog any kind of digital asset you throw at it. Moreover, it directly 
supports file formats with specially developed filters. (See “Asset Format Sup-
port,” p. 122, for details on supported formats.) Visit Canto’s website 
(www.canto.com) for news, updates and downloads, including new file filters as 
they are developed (for registered users only).

Editing Asset Information
In general, you can edit the information stored on an asset. But you can only edit 
information which is stored in record fields you are allowed to edit.
To edit the information stored on an asset:

1. Select a Record View Set that displays the information you want to edit in 
the Information View or the Asset Information window. 

2. Select the record you want to edit and change to Information View or open 
the Asset Information window.

3. Click the field you want to edit.

Fields with white backgrounds can be edited. If a field has a gray back-
ground, then it cannot be edited. (Either you are not allowed to edit or the 
field is not editable in general.)

4. Make your changes.

5. Click  to save your changes.

If you want to edit further records in the collection, you can use the arrow icons 
to load a new record.

Editing a String Field in Multiple Records 
If you are about to edit the content of a string field for multiple records at once 
and one or more records already contain text in the field you want to edit, 
Cumulus will ask you how to handle the new text.

Editing Fields with Validators
If a catalog contains fields with validators and one or more of these fields contain 
invalid values, or if mandatory fields have no value at all, a validator pane is dis-
played at the bottom of the Information Window or Information View, and the 
respective fields are marked with a special icon.
The message(s) displayed in the validator pane can be different for each field, 
depending on the settings defined by the administrator. Clicking on a message 
immediately activates the field with the erroneous value, even if it is not visible 
in the first place. As soon as you enter a correct value, both the special icon and 
the message disappear.
As long as a record contains invalid field values, it can not be saved. Either you fill 
in appropriate values in all of these fields, or any changes made to the record will 
be discarded.
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Using a Metadata Template
To add information to the metadata information that is stored on an asset, you 
can employ a Metadata Template. Metadata Templates can be set up by any 
user. For a description on how to set up Metadata Templates, see “Metadata 
Templates,” p. 129.
To make use of such a template, you can either use it while cataloging (along 
with the Prefiller Utility, see page 172) or apply the metadata information to the 
records of already cataloged assets.
There are different methods through which you can apply information from 
Metadata Templates to records of cataloged assets:
• Select one or more records and then select Metadata > Assign Metadata 

From Template. A list containing all your Metadata Templates is displayed. 
Select the desired one. 
NOTE: When using this method all fields that are included in the catalog 
of the record and that are set in the Metadata Template will be filled with 
the values of the selected Metadata Template. The changes are immedi-
ately saved with the record. 

• Open the Asset Information window and then click . 
NOTE: When using this method all fields that are included in the Asset 
Information window (and that you are allowed to edit), and that are set 
in the Metadata Template will be filled with the values of the selected 
Metadata Template. Note that these changes will not be saved until you 
do so. 

• Open the IPTC Information window and then click . 
NOTE: When using this method all fields that are included in the IPTC 
Information window (and that you are allowed to edit), and that are set 
in the Metadata Template will be filled with the values of the selected 
Metadata Template. Note that these changes will not be saved until you 
do so. 

TIP: 
If you have the appropriate permissions, you can easily access the 
preferences of Metadata Templates by selecting the Customize entry 
in the list for selecting Metadata Template. This entry opens the pref-
erences for the current Metadata Template. 

Record Size
In general, a record’s size can depend on several factors:
• The size and quality setting of the thumbnail (if you choose to include one).
• The amount of text and notes stored in various record fields.
• The asset format the record represents. (Different assets generally require dif-

ferent amounts of data to describe them.)
• The amount of additional information you include in the record (such as 

voice annotation).
The customizability of Cumulus means that you can determine what information 
is stored on the assets in a particular catalog. If catalog size is a concern, there are 
a few catalog settings to keep in mind. These settings can affect the size of the 
records cataloged. 
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Renaming Records
Records are named as the assets they represent by default. Sometimes asset 
names are not what you would like them to be. For renaming assets (and their 
records) Cumulus provides a special function. (See “Rename,” p. 198, for details.) 
However, you can also rename the record only. Though there is no menu item 
specifically for this use, renaming records is easy:

1. Select the record to be renamed.

2. Select Metadata > Information. The Asset Information window opens, 
which shows information on the asset.

3. Find and change the record’s name in the Record Name field.

4. Click  to save your changes.

If you want to edit more records in the collection, you can use the arrow icons in 
the Information window toolbar to load a new record. 

Editing a Record’s Category Assignments
Also found within the default Asset Information window is a list of the categories 
currently assigned to the record. From this list you can remove category assign-
ments or add new ones. 
To remove a record’s category assignment:

1. Select the record whose category assignments you want to change.

2. Select Metadata > Information. The Asset Information window opens, 
which shows information on the asset.

3. Select the category you wish to remove and press the DEL key.

4. Click  to save your changes.

If you want to edit more records in the collection, you can use the arrow icons in 
the Information window’s toolbar to load a new record. After deleting a category 
in the category pane, all assignments to this category are automatically deleted 
as well.
There are different ways to add a category assignment to a record, or to assign a 
record to a category, depending on your perspective. The perhaps most intuitive 
way is by dragging and dropping the category to the record, or the record to the 
category. (See “Editing a Record’s Category Assignments,” p. 22.) It is also possible 
to add a category assignment to a record via the Asset Information window, 
which displays a list of the categories the record is associated with.
To add a category assignment to this list:

1. Select the record whose category assignments you want to change.

2. Select Metadata > Information. The Asset Information window opens, 
which shows information on the asset. If necessary, drag this window aside 
so that you can also see the Category pane of the Collection window.

3. Click the category in question in the Category pane.

4. Drag the category to the categories list in the Asset Information window. 
The category is assigned to the record.
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5. Click  to save your changes.

If you want to edit more records in the collection, you can use the arrow icons to 
load a new record. 

Things You Can Do with Records
• Assign a record to a category. (See “Editing a Record’s Category Assign-

ments,” p. 22.)
• Change a record’s category assignments. (See “Editing a Record’s Category 

Assignments,” p. 22.)
• Copy/Cut and Paste records between catalogs and/or collections. (Record 

categories are copied along with records.)
• Create a new record (same as cataloging assets). (See “Browse for Assets,” 

p. 171.)
• Delete a record and (optionally) its asset. (See “Delete,” p. 178.)
• Drag and drop a record into another drag and drop-supporting application. 

Dragging a record copies the asset into the target document. You may prefer, 
instead, to place the asset manually and access it by reference.

• Export records. (See “Export,” p. 174) 
• Import records. (See “Import,” p. 173.)
• Optimize a records’ preview icon. (See “Optimize Thumbnail,” p. 193.)
• Print records. (See “Print,” p. 175.)
• Rename a record. (See “Renaming Records,” p. 22.)
• Rotate a record’s preview icon. (See “Rotate Thumbnail,” p. 193.)
• Search for specific records. (See “Searching,” p. 32.)
• Update a record to reflect an edited asset. (See “Update Record,” p. 191.)
• Update a record to reflect a relocated asset. (See “Update Record,” p. 191.)

NOTE: It’s very important to keep records in sync with their associated 
asset files. If you move an asset after cataloging it, be sure to update its 
record by using the menu item. (See “Update Asset Reference(s),” p. 199.)  

• View and optionally edit a record’s asset information. (See “Asset Informa-
tion,” p. 18, for details.)

Things You Can Do with Assets
Cumulus is also able to help you manage your original assets. Cataloged assets 
can be copied, deleted, moved, printed – all from the Cumulus interface using 
the Asset menu commands. And when you copy, delete or move an asset, 
Cumulus takes care of its TAG file at the same time, treating it accordingly. For fur-
ther information on TAG files, see “Options While Cataloging,” p. 172.
• Convert the asset to another file format. (See “Convert To,” p. 197)
• Copy the asset into another application by dragging the record into the 

application.
• Create copies of the assets in another location. (See “Copy To,” p. 197.)
• Customize the display of the information on an asset. (See “Record View 

Sets,” p. 105.)
• Delete an asset. (See “Delete,” p. 178.)
• Move assets. (See “Move To,” p. 198.)
• Open assets using the application they were created with or another appli-

cation. (See “Edit With,” p. 196.)
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• Preview a record’s asset. (See “Preview,” p. 195.)
• Print assets using the application they were created with or another applica-

tion. (See “Print With,” p. 196.)
• Send your assets by e-mail. (See “Mail To,” p. 197.)
• Rename assets. (See “Rename,” p. 198.)
• Show information on an asset. (See “Asset Information,” p. 18.)
• Show the location of the asset. (See “Show Location,” p. 198.)
• Show a preview image of the asset. (See “Preview,” p. 195.)

Categories
Cumulus categories are used to organize records, much like folders are used to 
organize files in a traditional filing cabinet. But the asset can appear in any num-
ber of Cumulus categories at the same time. They are similar in purpose to key-
words used in other programs. 
Simply double-clicking on a category is the most direct method of searching in 
Cumulus. All records assigned to that category are displayed. You can also use 
the category list to find contents of two or more categories at a time. Other 
options for category list searching include the ability to see the contents of cat-
egories in the tree either above or below the one you double click. (See “Search 
& Sort Tab,” p. 102, for more detailed information.)
To make organizing easier, Cumulus provides multiple tabs: Instead of having all 
categories appear in one category pane, categories can be created and dis-
played in separate tabs. 
• The Keyword tab contains those categories that are created with the inten-

tion of organizing the assets via keywords. These categories may be created 
manually by the user or automatically by Cumulus Filters and AssetStores. 

• The Sources tab will display the automatically created categories that resem-
ble the folder or directory hierarchy in which the assets reside. 

• Use the Categories tab to create your own individual category hierarchy – a 
hierarchy that suits your specific needs. 

• The All tab gives you an overview on all categories contained in the current 
collection. In the All tab the other tabs are denoted as categories with names 
that begin with a $ sign. 
NOTE: Do not rename or move these special categories.

Categories can be nested within one another. The highest hierarchical category 
level is the category representing a catalog. It has no categories above it. A cate-
gory that nests other categories is also denoted by a blue arrow. A square 
denotes a category that does not nest any other category. To expand a category 
in order to see its subcategories, click on its arrow. Use drag and drop to move 
categories to where you want them inside the hierarchie of the category repre-
senting a catalog. The categories that you create can be easily moved to other 
locations at any time. 
The Category pane displays all available categories. To check the categories a 
record is assigned to, open the Asset Information window and check the entries 
in the Categories field. (For information on how to edit, see “Editing a Record’s 
Category Assignments,” p. 22.) 

Category Types
Cumulus offers different types of categories: Normal Categories, Related Catego-
ries and Folder Categories. These category types have the following characteris-
tics:
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• Normal Categories can be created by the user at any position in the category 
hierarchy. We recommend creating individual categories either in the Cate-
gories or the Keyword tab.

• Related Categories are aliases of existing categories which can be created by 
the user. They can be placed in any position in the category hierarchy. Com-
plete alternate catalog hierarchies can be built using related categories. 

• Folder Categories are automatically created by Cumulus during the catalog-
ing process. These automatically created categories resemble the folder or 
directory hierarchy in which the assets reside. The Source tab displays them 
all. They are created by default but this option can be disabled 

Creating Categories
If you’ve been snooping around the Cumulus menu bar, you can probably guess 
how to create a new category.
To create a category:

1. Click the category in which the new category should be nested.

2. Select Metadata > New Category or New Related Category. This creates a 
category nested in the selected category.

3. Rename the new category. (Category names can be up to 255 characters in 
length.)

You can easily change the category hierarchies by clicking a category and drag-
ging it on top of another category. This places the category inside the other cat-
egory. To move a category to the top level of a catalog, drop it on the category 
representing the catalog. 

NOTE: In the All tab, never change the hierarchy for the categories with 
names that begin with a $ sign as they denote the category tabs. 

Renaming categories is easy:

1. Double-click the category’s name (not its icon). Its name will be selected for 
editing. 

2. Edit the name. (Category names can be up to 255 characters long.)

Custom Ordering of Categories
By default, the categories displayed in the category pane are sorted alphabeti-
cally. As this may not always be the most convenient solution, the order of the 
categories can be changed manually by dragging a category to a different place 
in the category tree, e.g. to have frequently used categories shown on top of the 
category tree.
Custom ordering of categories only works if 
• the respective catalog contains the category field Custom Order,
• the Enable/Show Language Specific Category Sorting and Custom Order-

ing option is activated in the used Category View Set,
A custom-ordered category tree is displayed in that order only for users that 
employ a Category View Set with the Enable/Show Language Specific Cate-
gory Sorting and Custom Ordering option activated. Elsewise the category tree 
is displayed in the default order. 
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To manually change the order of categories:

1. Drag any category with the mouse to the position where you want to have 
it.  

A thin black line indicates where it will be placed when you release the 
mouse button.

To override custom ordering and re-establish the alphabetic sorting of catego-
ries:

1. Right-click into a category level that you want to sort alphabetically and 
select Sort by Name from the shortcut menu. 

The respective level of categories is sorted alphabetically.

NOTE: Sorting categories by name only affects the current level. If subcatego-
ries have a custom order, they will retain it. Thus you can sort any level in your 
category tree either by name or manually as you need it, independent of any 
other level.

Category Fields
Category fields are used for information that relates to all records assigned to that 
category, or they can be used to store additional information on the category 
itself. A significant difference between record fields and category fields is that 
category fields are not searchable.
Category fields can be activated and set up in the Catalog Settings.

Category Information Window
Information on categories can be viewed in the Category Information window. 
What you see depends on:
• the fields selected to be displayed in the Category View Set defined for the 

Category tab the selected category resides in.
• the fields of the catalog the selected category resides in and whether these 

fields contain any information or not.

TIP: Access Preferences 
You can easily access the preferences of Category View Sets by select-
ing the Customize entry in the list for selecting Category View Sets. 
This entry opens the preferences for the current Category View Set.

To open the Category Information window:

1. Click once on a category to select it.

2. Select Metadata > Information. The information window for the selected 
category appears.

The information on categories can be viewed and accessed via category fields. 
What category fields are displayed and also how the category fields are displayed 
depends on the selected View Set. 
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Once the Category Information window is opened, you can use the arrow but-
tons to load other categories into the window. For more details on the Informa-
tion window, see “Information Window,” p. 28.

Editing Category Information
To edit the information stored on a category:

1. Load the category you want to edit into the Category Information window.

2. Click the field you want to edit.

Fields with white backgrounds can be edited. If a field has a gray back-
ground, then it cannot be edited. (Either you are not allowed to edit or the 
field is not editable in general.) 

3. Make your changes.

4. Click  to save your changes.

If you want to edit more categories, you can use the arrow icons of the Informa-
tion window’s toolbar to load another category.

Categories and Auto-cataloging
Cumulus can auto-catalog the contents of folders that are represented by folder 
categories in Cumulus. Any new assets saved to this folder will be cataloged peri-
odically, depending on how often you would like this done. This feature can be 
customized to be performed anything from hourly to daily to weekly. It is per-
formed on the machine you are working at. 
To make use of this feature:

1. Click the Sources category tab. The categories representing folders that can 
be used for auto-cataloging are displayed.

2. Select the category representing the folder you want to have auto-cata-
loged.

3. Select File > Add Assets to Catalog >Setup Auto Cataloging.
OR
Open the context menu by clicking the right mouse button /  Control 
key + mouse button and select Setup Auto Cataloging. 

The Auto Cataloging dialog is opened.

4. Activate the Use AutoSync on Category option.

5. Define the performance options:

• Select the Asset Handling Set for the auto-cataloging.
NOTE: You should select an Asset Handling Set with the Skip Dupli-
cates option activated for cataloging. Otherwise all assets in the folder 
will be cataloged again and again with each run. 

• Under Next Start, enter date and time when the function should be per-
formed.

• Under Period, enter the regularity time interval you want the function to 
be performed. For example: to start it once a day enter 24:00 

6. Click OK.
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NOTE: With this version of Cumulus the Auto Cataloging feature works only 
for folders that were created when cataloging was performed on the same 
operating system you are working with. You can check this with the informa-
tion in the Category Type field. A category of the type Directory Category can 
only be auto-cataloged when you are working under Windows. And a cate-
gory of the type Directory Category Mac can only be auto-cataloged when 
you are working under Mac OS X.

If you want to use this feature with catalogs created with former versions of 
Cumulus you have to add the following category fields to the catalog:
• AutoSync Asset Handling Set
• AutoSync Next Start
• AutoSync On
• AutoSync Period
• AutoSync User
• Folder Reference

Things You Can Do with Categories
• Assign a category to a record. (See “Editing a Record’s Category Assign-

ments,” p. 22.)
• Create a new category. (“New Category,” p. 195, and “New Related Category,” 

p. 195.)
• Create a related category. (See “New Related Category,” p. 195.)
• Delete a category. (See “Editing a Record’s Category Assignments,” p. 22.)
• Export categories. (See “Export,” p. 174.)
• Import categories. (See “Import,” p. 173.)
• Move a category inside or outside another category. (See “Creating Catego-

ries,” p. 25.)
• Remove a category assignment from a record. (See “Editing a Record’s Cate-

gory Assignments,” p. 22.)
• Rename a category. (See “Creating Categories,” p. 25.)
• Show or hide categories. (See “Collection Basket Pane,” p. 181.)
• Use AutoSync on categories. (See “Categories and Auto-cataloging,” p. 27.)

Information Window 
The information stored on an asset or category can be viewed and edited in the 
Information window. What you see depends on:
• the fields selected to be displayed in the current View Set.
• the fields of the corresponding catalog and whether these fields contain any 

information or not. 

ormation Window
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Find Assets
If you can’t find it, you can’t use it. With Cumulus it is easy to find the

assets you are looking for as Cumulus provides easy and powerful

search capabilities. These are described in this chapter.
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Searching
Cumulus provides several ways to search for records: searching by category, 
quick searching and searching with the Find window. Depending on the size of 
your catalogs and the complexity of your search requirements, you may find one 
way better suited to your needs.

Searching for Records By Category
The simplest form of searching for records is simply double-clicking on a cate-
gory in the Category pane. This quickly finds all of the records that are associated 
with that category. You can also select more than one category to see all the 
records associated with the set.
To quickly view the records assigned to categories,  hold down  Alt /  both  
Alt+Cmd  and press an arrow key (up, down, left or right). 
There are several Preference options that affect the way category list searching 
works. (See “Search & Sort Tab,” p. 102, for more detailed information.)

Searching with Quicksearch
To perform a Quicksearch in all catalogs open in the current collection, simply 
enter a search term (e.g. a name or a number) into the toolbar’s search field and 
click the icon or press Enter. 
With Quicksearch, Cumulus by default looks for the search term in the following 
record fields only:  Record Name, Document Text, Notes, Keywords, and Catego-
ries. The result of the Quicksearch shows all records for which the search term is 
contained in any one of these fields.
The selection of fields used by Quicksearch can be changed in the User Settings 
section of the Preferences dialog (see “Search & Sort Tab,” p. 102, for details). 
Quicksearch performs a “contains” search for all included String fields and String 
List fields and an “is” search for all included Integer fields. 

Search Options
If you enter two or more terms into the Quicksearch field, Cumulus combines 
these terms with “and”. Entering Canto Cumulus will result in all records that con-
tain Canto AND Cumulus in any of the searched record fields.
To use a term that consists of more than one string,  you have to enclose the 
strings with  double quotation marks.  Quicksearch handles the strings in quota-
tion marks as one search term. Entering “Canto Cumulus” will result in all records 
that contain the string Canto Cumulus (i.e. the words Canto and Cumulus sepa-
rated by a space) in any of the searched record fields.
To combine search terms with “or” rather than with “and”, you have to separate 
them with two pipes (||). Entering Canto || Cumulus  will result in all records  con-
taining either Canto or Cumulus or both.
To search for records that do not contain certain terms in any of the searched 
record fields,  you have to prepend the terms with a  minus symbol (-). Entering 
Cumulus -Cloud  will result in all records that contain Cumulus, but do not contain 
Cloud .
To search for one of the special characters you have to put a backslash in front; 
e.g. \- to find the minus symbol,  \&& to find && or \/ to find /. 

NOTE: If the Categories field is included in Quicksearch, the search results also 
depend on the settings specified under Category Search Also Finds Records 
of (Preferences > User Settings > Application > Search & Sort). (See “Search & 
Sort Tab,” p. 102, for details.) 
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The Quicksearch Menu
The Quicksearch menu is displayed by clicking the arrow button next to the 
magnifying glass icon.  

Besides a section displaying previously used search terms, and a section display-
ing saved search queries (see “Saving and Loading Search Queries,” p. 40), the 
Quicksearch menu provides the following entries:
• Find – Searches in all catalogs open int the current collection; replaces the 

current collection with the search result. (Equivalent to the magnifying glass 
icon.) 

• Find in Collection – Searches in the currently displayed collection only, e.g. 
in the result of a previous search. Handy for narrowing down search results.

• Find and Add to Collection – Searches in all open catalogs; adds the search 
result to the currently displayed collection. Handy for broadening a search 
result.

• Find All Records – All records of all open catalogs are displayed. (Equivalent 
to clicking the icon or pressing  Enter on an empty search field).

• Clear Quicksearch List – Deletes the previously used search terms.
• Find Window – Opens the Find window (See “Searching with the Find Win-

dow,” below, for details.)

Searching with the Find Window
The Find Window reveals the true search power of Cumulus. Complex search set-
ups (queries) can be constructed to find virtually any type of data stored for an 
asset. Boolean operators (and, or) increase the query possibilities even further. 
Different search methods let you define the search area (either all records of all 
catalogs opened in the current collection or only the records contained in the 
current collection.) The matches can either be added to the current collection, 
replace the records in the current collection or comprise a new collection of their 
own. 

A description of the Find window and a comprehensive listing of searchable 
fields are listed in the overviews “Overview: The Find Window,” p. 34 and “Over-
view: Sample Search Options,” p. 35. 

The Quicksearch menu 

Section with previously 
used search terms

Section with saved 
search queries
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BACKGROUND INFORMATION:  Window Connected to Collection
When a Find window is opened, it is connected to the active collec-
tion or catalog window. That’s why the name of the source window is 
displayed in the title of the Find window. It is important to be aware of 
this fact, when you use an open Find window for multiple searches – 
especially, if you decide to have the search results displayed in a new 
collection. Be aware of this fact when using the following search 
methods: 
– Find in Current Collection: the contents of the source window 
defines the ’search area’ 
– Find and Add to Current Collection: the matches of the search are 
added to the contents of the source window

erview: The Find Window 
open the Find window: Select Find > Find Records  

Displays the name of the collection/catalog(s) that will be 
searched by the query in this Find window and that is 
referred to as ’current collection’. 
Search criteria.
Search operator.
Search value.
NOTE: You can search for whole words, not just for match-
ing strings – if the Record field set as search criteria is acti-
vated for word-searching. Enclose the word you are 
searching for in single  quotation marks and Cumulus will 
only find the records that contain the exact word. For exam-
ple searching for  copy will find records containing the 
words copy as well as copyright, copyhold, copyfree and 
so on. Searching for ‘copy’ will find records containing the 
word copy only.
Inserts a new search condition before the current one.
Inserts a new search condition after the current one.

NOTE: The order of search conditions is important when you
connect search conditions with the Boolean operator “or”. (F
more details, see “Sequence of Search Conditions,” p. 37.)
7 Will search all open catalogs of the current collection.
8 Will search the current collection only.
9 Found records/categories are added to the current collec

tion.
10 Found records/categories replace the current collection.
11 Found records/categories will comprise a new collection
12 Displays help text.
13 Opens the Advanced Find windows for entering nested qu

ries.
14 All records/categories of those catalogs opened in the cu

rent collection will be shown.
15 Starts the search.
16 Opens a menu for saving or loading queries. (For more 

details, see “Saving and Loading Search Queries,” p. 40.)

NOTE: Cumulus search options are NOT case sensitive. 
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Using the Find Window 
All example searches on the following pages are based on the Sample catalog.

Simple Searches
To set up a simple search (as opposed to a compound search, described on 
page 36):

1. Click Find > Find Records or Find Categories to open the Find window.

2. Select a search criterion from the Criteria list. This menu lists all record or 
category fields activated for searching.

3. Select an operator from the Operator menu. This menu lists all operators 
that are possible for the field type of the field selected as criteria. 

erview: Sample Search Options 
ria Field 

Type
Oper-
ator

Searches for Sample Data/Instructions

ories Special Records associated with specified category. Type category name or drag category  onto Value field. Use drag me
if catalog has multiple categories of the same name. Current Sear
Preferences settings affect results. (See “Search & Sort Tab,” p. 102)

bnail Special Similar thumbnails. Compares brightness and 
contrast.

Type record name or drag record thumbnail onto Value field.

ntal Res-
n

Real Dot-per-inch resolution of an image asset file. 200, 300

ata Size Integer The asset file size. (Not the record size.) 1024 KB (use KB for kilobytes)
24 MB (use MB for megabytes)

Creation Date  The date the asset was created. 11/22/97

Mode String List  The color mode of an image. Select from Value list.

ging String The name of the user who cataloged the asset. Clint, Carolyn

String Records with a group of characters in the Notes 
field that matches criteria. 

Any line of text. For example, “ball” finds ball, balloon and basebal
rights res” finds “All rights reserved.”

d /Cate-
ame

String The name of the record /category. Balloon, Clouds, Gun Shot / Illustration, Aircraft, Sounds

a

b

c
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ield Type Categories Thumbnail Date, Real, 
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String 
List*

String*

* The menu options for this 
field type may differ depend-
ing on the field properties.
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4. Either select a value from the Value list, type a value in, or drag an appropri-
ate object onto the field. (Appropriate objects can be either thumbnails or 
categories.)

5. Leave the default search method Search in All Open Catalogs. This method 
searches all catalogs included in the current collection.

6. Click New Collection so that the records found will be displayed in a new 
collection of their own.

7. Click Find.

Compound Searches
In larger catalogs, finding records with a single search criterion may not be effi-
cient. To avoid sifting through tens of thousands of records, you may need to use 
more than one search criterion. For example, you may be looking for a photo-
graphic image in EPS format. 
Cumulus lets you do this in two different ways:
• You can enter a compound search (more than one search criterion), OR
• You can narrow the results of a simple or compound search. (See “Narrowing 

the Search,” p. 38.)
Building a compound search isn’t much more difficult than building a simple 
search. You just have to think in terms of what you are asking Cumulus to do, and 
then translate that request into the search fields. For example, your request, in 
English, might read:

“I need all records in the Photographs category that have ‘tree’ somewhere in 
their names.”

Translated into Cumulus-speak, this becomes:
• Category is Photographs and Record Name contains tree.
Now let’s break it down into separate search statements, called “conditions.”
• Category is Photographs
In our first condition, Category is our search criterion, is  our operator, and Pho-
tographs is the value we’re searching for. This tells Cumulus that the records we 
want are all in the Photographs category. This alone would find the records 
we’re looking for, but if our catalog contained thousands of images in the Pho-
tographs category, we’d spend quite a bit of time browsing through them all.
• and
This next little bit is very important. This is a Boolean operator that tells Cumulus 
how to consider the previous and next search conditions. By selecting and, we 
tell Cumulus that the records we want must match both conditions of our com-
pound search. Another option here is or, which would tell Cumulus that the 
records we want only need to match one of the conditions.
• Record Name contains tree
In the second condition of the search, we help Cumulus narrow the search 
results by giving it part of the record name that we want. We use the operator 
contains instead of is because we’re looking for records that have ‘tree’ any-
where in their names. Is would require that the record be called exactly ‘tree,’ 
with no variation.

Value
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In the Find window, the field values will construct a sentence similar to the one 
we just broke down. When you can see each condition on a line by itself, it’s eas-
ier to visualize the results of the request.
Setting up each condition in a compound search is the same as setting up a sim-
ple search. The only additional steps are adding a new line of search fields, and 
specifying the Boolean connector between each condition. 
Here’s how:

1. Click Find > Find Records to open the Find window.

2. Set up the first condition of the search as:

3. Click  to reveal a second set of fields.

4. Select and from the Boolean list, if it’s not already selected.

5. Set up the second condition of the search so that the window looks like this:

6. Leave the default search method Find in All Open Catalogs. This method 
searches all catalogs included in the current collection.

7. Click Create New Collection so that the records found will be displayed in a 
new collection of their own.

8. Click Find. The search finds two images: “Sunset with Tree” and “Tree in Win-
ter.”

Additional conditions may be added to further refine the search. Add and delete 
conditions using the following buttons:
•  Inserts a new search condition before the current condition. (The current 

condition is the line in which a field is highlighted or the flashing cursor I-
beam is found. Click in any field to make that line the current condition.)

•  Inserts a new search condition after the current condition.
•  Deletes the current condition. This is not undoable!

Sequence of Search Conditions
When performing a Find window search Cumulus performs one search condi-
tion after the other. The Boolean and and or operators define how Cumulus has 
to connect the previous and next search conditions. The operator and defines 
that the records must match both conditions. The operator or defines that the 
records need to match one of the conditions only. If you have more than two 
search conditions in a search query, a condition connected with and will search 
the matches of the previous condition and reduce this result – whereas a condi-
tion combined with or will search the entire ’search area’ (as defined under 
Search Method) and add the new matches to the previous matches. 



38 CANTO® CUMULUS SINGLE USER GUIDE
SPECIAL TECH INFORMATION:  Nested Queries
If you want to enclose search conditions in brackets and set up nested 
queries, you must use the Find window in advanced mode. See “Using 
the Find Window in Advanced Mode,” p. 41, for details.

Examples
Search Query A: 

Category is Photographs 
and 
Record Name contains penguin
and 
Record Name contains balloon

First, Cumulus will search for all records that are assigned to the category Photo-
graphs and then, second, the result will be refined by searching for records that 
contain penguin in their names. Third, this result will be refined by searching for 
records that contain balloon in their names. 
In the Sample Catalog the final result of this search query is:
• Penguin Balloon.psd
Search Query B: 

Condition 1: Category is Photographs 
and 
Condition 2: Record Name contains penguin
or 
Condition 3: Record Name contains balloon

First Cumulus will search for all records that are assigned to the category Photo-
graphs and then, second, the result will be refined by searching for records that 
contain penguin in their names. Third, the ’search area’ (as defined under Search 
Method) will be searched for records that contain balloon in their names and the 
matches will be added to the results of the previous conditions. 
In the Sample Catalog the final result of this search query is: 
• Penguins.jpg
• Penguin Balloon.PSD
• Balloon Race.BMP

Narrowing the Search
If the results you get from either a simple or compound search are too broad, 
Cumulus can help. The search method Find In Current Collection allows you to 
search through the set of records contained in the current collection, instead of 
the entire catalogs of the current collection, thereby reducing the number of 
records found.
Using our example from the compound search section, we’ll perform the same 
search using the search method Find In Current Collection.

1. Make sure that the active window contains the collection of records you 
want to be searched.

2. Click Find > Find Records to open the Find window.
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3. Set up the first part of the search as:

4. Leave the default search method Find in All Open Catalogs. 

5. Click Update Current Collection so that the records found will replace those 
in the current collection. 

6. Click Find. Cumulus finds all records in the Photographs category.

7. Now change those same fields to:

8. Click Find In Current Collection as the search method. 

9. Click Current Collection so that the records found will replace those in the 
current collection. 

10. Click Find. Cumulus searches through the ten records found in the first 
search and narrows the set of records down to just two images: “Sunset with 
Tree” and “Tree in Winter.”

If it helps, you might want to think of Narrow Current Collection as an and Bool-
ean operator. That is, after your first search, you conduct another search with dif-
ferent search criteria, and the final results are the same as from the 
corresponding compound search using and. In the example above, the same 
final results were achieved with the compound search previously conducted.

Broadening the Search
If the results you get from either a simple or compound search are too narrow, 
Cumulus can be of assistance again. The search method Find and Add to Cur-
rent Collection adds the results of a subsequent search to the records contained 
in the current collection.
Let’s conduct an example search using the Find and Add to Current Collection 
search method:

1. If the Find window is not open, click Find > Find Records to open it.

2. Set up the first part of the search as:

3. Leave the default search method Find in All Open Catalogs for this first step.
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4. Click Create New Collection so that the records found will be displayed in a 
new collection of their own.

5. Click Find. Cumulus finds four records: “Camels in India,” “Indian Camel,” 
“Indian Music,” and “Sunset with Tree.”

6. Now use the same search criteria, but change the search method to:

7. Click Find and Add to Current Collection as the search method.

8. Click Update Current Collection so that the records found will supersede 
the current collection.

9. Click Find. The record “Map” is added to the four records found with the pre-
vious search, and your current collection is comprised of five records.

This search method can be seen as an or Boolean operator. That is, after your first 
search, you conduct another search using a different criteria, and the final results 
are the same as from the corresponding compound search using or.

Saving and Loading Search Queries
Although Cumulus remembers your search set-ups if you leave them open when 
you quit Cumulus, you can also save search set-ups, called queries. This prevents 
you from having to rebuild them each time you need them. It also ensures that 
your searches are consistent from session to session, which is important for some 
purposes. Cumulus query files can be used on any supported platform. You can 
store and load queries for quick retrieval.
To save the current query: 

1. Click the  button and select Save.

A dialog appears in which you can name the query.

2. Type a name for the query in the Query Name field.

If you want the query to be available for other users, activate the Share 
Query option.

3. Click Save.

The query is stored in one of the two special query files Cumulus provides – one 
for the individual queries of a user and the other one for shared queries.  
To load a query:

1. Click the  button. A menu containing entries for all queries that are avail-
able to you is displayed. 

2. Select the entry for the desired query file.

If you want to store a query as a separate file anywhere in the file system, you 
have to export it:

1. Click the  button. 
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2. Select Export. A dialog appears from which you can save the current query 
anywhere in the file system.

3. Select a location.

4. Click the button Save.

To load such an exported query file you have to import it:

1. Click the  button. 

2. Select Import. A dialog appears from which you can select a query.

3. Select a query file.

4. Click the button Open.

Things You Can Do with Searches/Queries
• Create a new search condition. (See “Compound Searches,” p. 36.)
• Load search queries. (See “Saving and Loading Search Queries,” p. 40.)
• Save search queries. (See “Saving and Loading Search Queries,” p. 40.)

Using the Find Window in Advanced Mode
This mode is designed for advanced users only who know how to set up search 
queries that are of greater technical depth. In standard mode, the Find window 
combines search conditions in a sequence for a complex query, whereas in 
advanced mode, the Find window allows you to set up nested queries. If you are 
working in a multilingual environment, the advanced mode provides another 
advantage as the queries that are set up in this mode are language independent.
To switch the Find window to advanced mode, click the Advanced Mode button 
in the Find window. In advanced mode the Find window looks like this:

In the edit field you can enter any combination of search criteria, operators, val-
ues, and Boolean operators. This description explains the possibilities. It is pro-
vided in English only.

NOTE: If the edit field was empty before you switched to the advanced mode, 
the field will contain the search query set up in standard mode.

Record fields that can be used as search criteria are displayed when you click the 
Fields button. This list displays all fields contained in the current collection that 
are indexed for search. If you select an item in this list, it is inserted in the edit field 
of the Advanced Find window at the current cursor position.
The symbols you can use for search combinations are displayed when you click 
the Symbols button. 
If you select an item in this list, it is inserted in the edit field at the current cursor 
position – exception: If you have marked a selection and then choose the “com-
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bine” symbol, the “combine” symbol will wrap the selection (opening bracket at 
the start and closing bracket at the end of the selection).
You can also set up a query in standard mode first and then switch to advanced 
mode. When switching back to standard mode by clicking the Simple Mode 
button, the query will be the same as before switching to the advanced mode. 
Note that it does not reflect the changes made in advanced mode. When chang-
ing back to advanced mode, the query set up in this mode is displayed again.

Searching for Categories
!Certain Cumulus configurations enable you to search for categories as well. They 
provide two Find Windows: one to search for categories and one to search for 
records. But both look and work the same.
The difference is the result of your search. The categories found as a result of your 
search are displayed in the Category pane. The found categories are displayed 
and can be used. The categories above the found categories are also displayed – 
they are displayed for orientation only.
The categories found as a result of your search can either replace the categories of 
the current collection or comprise a new collection of their own. 

NOTE: The result also depends on the Live Filtering options the Cumulus 
Administrator may have set for you. 
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User Live Filtering
User live filtering enables you to set parameters that serve as a filter for all the 
records you find. Easily hide the file formats you don’t need, make sure what you 
see has been approved for use, or any other combination you need. Save your 
filters and even share them with others.

With User Live Filtering activated, the records on your Record pane get ’filtered’ 
by conditions you set up. 
You activate and deactivate User Live Filtering via the Filter icon in the Record 
pane top bar. 

As long as filtering is active, any further search operation – Quicksearch, Category 
Search, whatever – will only take into account the collection as defined by the 
filter criteria, not the whole catalog. Accordingly, the Find All Records command 
will only find records that match the filter criteria.

Adding Filters 
Create filters to quickly find files. For example, you can create a filter to find all files 
in a specific workflow state, a filter to limit the results you see in the Cumulus win-
dow to certain file types or to just those assets that belong to a certain client. 
Conditions define the criteria that files must meet to be included in filter results. 
You can combine multiple conditions to perform more complex filtering. 
To add a filter condition:

1. If filtering is not activated, click the Filter icon. 

2. Click the plus sign icon. A list of record fields opens. 

The list contains all record fields that are contained in the catalogs opened in 
the current collection and that have Include Field in Find and Filter Options 
activated in their properties. 
NOTE: Record Fields Offered as Criteria
Per filter a record field can only be used once as a criteria for a condition. 
This means that a record field already used for a condition is not offered in 
the list when adding a new condition. 

3. Select the record field you want to function as criteria. 

The Define Filter Condition dialog opens.

Depending on the field type of the field you selected as search criteria, the 
options differ. 

4. Set the criteria records must meet to pass the filter. For information on the 
different options, see “Using Filters,” p. 44.

5. Click OK to save your settings and activate the filter condition.
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Managing Filters
To add additional filter conditions, repeat steps 2-5. 

To edit an existing filter condition, maximize the pane (  ) and click the pencil 
icon.

To remove a filter condition, click the minus sign icon in the maximized pane.
To remove all filter conditions at once, from the Manage Filters menu select 
Remove all Conditions. Note that conditions not saved as filter will be lost. 

Saving Filters
Use Manage Filters menu to save the active filter conditions as a filter under a 
name. Saved filters are added to the menu and can be used any time you need 
them. You can share them with others.

1. Click the Manage Filters icon to open the menu.

2. Select the Save Filter option. The Save Filter dialog opens. 

3. Enter a Filter name. Make sure you use a descriptive name. 

4. Click OK to save the filter. 

An entry for this filter is added to the Manage Filters menu.

Using Filters 
You can filter the records of a collection window to display specific records only. 
Use the Manage Filters menu to select the desired filter. 

1. Click the Manage Filters icon ( ) to open the menu.

2. The available filters are listed at the bottom of the menu. The menu displays 
all shared filters in addition to private filters that you created.

3. Select the desired filter. 

Only the records of assets that meet the filter criteria are displayed. 

Deleting Filters
Use the Manage Filters menu to delete filters you need longer.

1. Click the Manage Filters icon to open the menu.
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2. Select the Delete Filter option. The Delete Filter dialog opens. It lists the 
available filters.

3.  Select the filter you want to delete.

4. Click OK to delete the filter. The entry for this filter is deleted from the Man-
age Filters menu.

Configuring Filters 
Filters comprise one or multiple conditions. 

Defining Conditions in General
Conditions are criteria that records must meet to be included in filter results. 
Depending on the field type of the field you selected as criteria, the options differ. 
For most of them you first have to decide on one of the three main options – 
either on one of the simple ones:
• Has value – Record will be included in the filter result if the field contains 

something.
• Has no value – Record will be included in the filter result if the field is empty.
Or the third one which offers further options that allow a precise description:
• Matches / Does not match (for most types) OR 

Contain / Does not contain (String lists only) OR
Is assigned to (Categories field only)

The further ’sub-options’ depend on the field type and range from general 
search criteria to exact matches with existing values. For most types the option 
From existing values is offered. It enables you to search for exact matches with 
existing values. 

Field Type Specific Condition Options
The options offered as conditions depend on the type of the field you have 
selected as search criteria.

String 
Limits filter results to records with: Text that matches or does not match specific 
text string or a regular expression
Select a matching option:
• Select Matches to search for records that contain the text.
• Select Does not match to search for records that do not contain the text.
Select the type of value to search for and enter or select the value: 
• Select Custom value to search for a text string you define. Enter the string 

and select the search operator.
• Select From existing values to search for exact matches with existing values. 

Once you have activated this option, existing values are displayed which you 
can select to be searched for.

String List
Limits filter results to records with values, such as workflow states, that contain or 
do not contain any or all of the values selected. 
Select an option to indicate if the results contain the selected values:
• Select Contains the following items to search for records that contain the val-

ues.
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• Select Does not contain the following items to search for records that do not 
contain the values.

Select the value(s) to search for: 
• Select Restrict to existing values to search for exact matches with existing 

values. Once you have activated this option, existing values are displayed 
which you can select to be searched for.

Long & Integer, Real & Data Size
Limits filter results to records with: numbers that match or do not match a num-
ber or numbers in a range. Integer restrictions, which are based on non-decimal 
numbers, limit results to records that contain or do not contain numbers in a 
range or list.
Select a matching option:
• Select Matches to search for records that contain the numbers.
• Select Does not match to search for records that do not contain the num-

bers.
Select the type of value to be searched for, and enter or select the value: 
• Select Range to search a range of values. Enter the From and to values.
• Select Any of the following numbers to search for multiple numbers. Enter 

the numbers to be searched for, separated by semicolons.

TIP: Greater Range
You can search for ranges greater than or less than a specific value. 
Leave the From field empty to search for matches less than the value 
in the to field. Leave the to field empty to search for matches greater 
than the value in the From field.

• Select From existing values to search for exact matches with existing values. 
Once you have activated this option, existing values are displayed which you 
can select to be searched for.

Time Only & Date Only 
Limits filter results to records with: Time data or dates that match or do not match 
a specific date, date range, or time period. 
Select a matching option:
• Select Matches to search for records that contain the selected dates. 
• Select Does not match to search for records that do not contain the selected 

dates.
Select the type of value to be searched for and enter or select the value: 
• Select Range to search a specific date/time range. Enter the range in the 

From and through fields.
• Select Any of the following dates/times to search for multiple statements. 

Enter the time data to be searched for, separated by semicolons.

TIP: Greater Range
You can search for ranges greater than or less than a specific value. 
Leave the From field empty to search for matches less than the value 
in the to field. Leave the to field empty to search for matches greater 
than the value in the From field.

• Select From existing values to search for exact matches with existing values. 
Once you have activated this option existing, values are displayed which you 
can select to be searched for.



FIND ASSETS –  USER LIVE FILTERING 47
Date/Time
Limits filter results to records with: Dates that match or do not match a specific 
date, date range, or time period. 
Date range restrictions limit results to records that contain or do not contain a 
date range, date/time range, or time period.
Select an option to indicate if the results meet the specified dates and times:
• Select Matches to search for records that contain the selected dates and 

times. 
• Select Does not match to search for records that do not contain the selected 

dates and times.
Select the time period to search.
• Select From date to search a specific date range. Enter the range.

TIP: Greater Range
You can search for ranges greater or less than a specific value. Leave 
the From field empty to search for matches less than the value in the 
to field. Leave the to field empty to search for matches greater than 
the value in the From field.

• Select From date/time to search a specific date/time range. Enter the range. 
This option is only available for date/time fields.

• Select a time period option to search a specific period, such as last week or 
last year. This option is only available for date fields that include the time, 
such as event date/time fields.

• Select In the to search a specified number of days, weeks, months, or years 
before or after the current date. Select Last or Next, enter a number, and 
select the time period.

• Select From existing values to search for exact matches with existing values. 
Once you have activated this option, existing values are displayed which you 
can select to be searched for.

Boolean
Limits filter results to records with: True or false set  
Select an option.

Categories
Limits filter results to records that are assigned to any or all categories selected. 
Check the categories to be searched for. Note that the categories available under 
Is Assigned To depend on the tab currently selected in the Category pane.
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Use Assets
If you intend to do anything more than simply browsing through cat-

alogs, you should read this section. It describes how to use, present

and share your cataloged assets. This is followed by a few simple

guidelines that will ensure your workflow is as efficient as possible.
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Drag and Drop
Cumulus does not only support drag and drop in the Cumulus application and 
for cataloging. From within Cumulus you can drag and drop assets into other 
applications that support drag and drop. Under Mac OS you have to press the 
ALT key when starting dragging. 

Copying Assets
You can drag and drop a record into another drag and drop-supporting applica-
tion. Dragging a record copies the asset into the target document. Dragging a 
record into the Windows Explorer or the Mac OS X Finder copies the asset into 
the selected folder.

NOTE: It is not recommended to use drag and drop for copying a large num-
ber of files, because this may seriously impact the performance of your system 
and the available disk space. To copy a large number of files, use the Copy to 
menu command instead.
The reason for this is that both methods are handled in different ways inter-
nally. With the Copy to menu command, Cumulus creates a temporary file for 
each asset which is deleted as soon as the asset is copied. On the other hand, 
with drag and drop, temporary files of all selected assets are created before the 
first asset is copied, and these temporary files are not deleted until a new copy 
process via drag & drop is started, or Cumulus is closed.

Copying Categories and Associated Assets
Categories can be dragged and dropped – along with the assets associated with 
each category – into the Windows Explorer or the Mac OS X Finder. When you 
drop the categories, Cumulus creates a folder with the same name as the cate-
gory and copies the assets to that folder. If the category contains subcategories, 
subfolders will be created and the assets assigned to these subcategories are 
copied to the corresponding subfolders.
This option may be handy for collecting production files for output (assuming 
the files all have at least one common category, such as project name).
To copy categories and associated assets:

1. Select one or more categories that you want to copy along with the associ-
ated asset files.

2. Drag and drop the selected categories into the target application. 

NOTE: If you use this way of copying assets, any associated metadata files 
(e.g. TAG files) will not be copied even if the corresponding metadata 
modules are activated.

A folder named as the category is created containing the asset assigned.

You also have the option of copying only the asset files associated with selected 
categories (see “Copy Assets Assigned to Category To,” p. 197).

Using Asset Actions
Cumulus Asset Actions simplify your daily workflow needs. An Asset Action refers 
to a combination of certain functions and can be saved under a chosen name. 
Whenever you wish to perform this combination of functions, all you have to do 
is select the corresponding Action and it will be done. You can perform an Asset 
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Action either on selected records or when mailing assets. To perform an Asset 
Action on records selected in the Record pane, you employ the menu item Asset 
> Perform Asset Action. (For details, see below.) To perform an Asset Action on 
records in the Collection Basket pane, you employ the Collection Basket’s tool-
bar. (For details, see “Outputting the Collection Basket’s Contents,” p. 182. 
These Asset Actions can be defined in your User Settings in the Preferences dia-
log – for a description, see “Cumulus Asset Actions,” p. 124. 
To perform an Asset Action on records in the Record pane:

1. Select one or more records.

2. Select Asset > Perform Asset Action. A submenu opens that lists the avail-
able Actions.

3. Select the desired Asset Action.

Depending on how the action is defined dialogs for the included modules 
may show up. Make your selection and click the appropriate buttons. The 
Actions will be performed on the selected records.

Progress information is displayed on those actions that take a certain 
amount of time.

If the selected Asset Action failed to be performed on certain assets, theses assets 
are listed as soon as the Asset Action is completed, together with the respective 
error messages. 
Clicking Reveal in collection displays these assets in a collection of its own for 
further processing.
Clicking Ignore closes the window without any further action.

Mailing Your Assets
Cumulus also lets you e-mail the assets themselves, so that you can easily share 
them with people who don’t have access to your Cumulus catalogs. You can use 
Cumulus’ powerful search and display features to find just the right assets, and 
then send them off with a single command.
To e-mail assets from within Cumulus:

1. Select one or more records whose assets you want to mail.

2. Select Asset > Mail To. A dialog opens prompting whether you want to 
send the original asset or to have a Cumulus Action performed on the 
asset(s) before it is sent.

3. Select the desired option (and if you decided on an Action, the desired 
Action) and click OK.

Cumulus launches your e-mail application (in case you have more than 
one, offers you a menu to select) / launches your default e-mail applica-
tion and attaches the selected asset(s) to an outgoing message. (If you 
decided on an Action, the result of the Action will also be saved as defined 
for the delivering module of the Action.)

Previewing Assets 
Cumulus provides several ways of previewing assets:
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• Preview pane
• Preview view
• Preview window
• Fullscreen Preview
• Fullscreen Slide Show
Viewing an asset in Preview view or window lets you add user comments to it. In 
Fullscreen Preview you can compare up to six different assets and add labels and 
ratings. The Fullscreen Slide Show displays assets as fullscreen previews in a slide 
show. The Preview pane can be opened additionally at the left side of a collec-
tion window. 

Preview View and Window
The records’ assets must be available to display.
Previews can be zoomed in or out and displayed in different sizes using the win-
dow’s toolbar or menu options. (See “Overview: Toolbars for Previews”, below, 
and see “Zoom In,” p. 187, and “Zoom Out,” p. 187.) 
The default size of the preview display can be set in the User Settings. (See “Over-
view: User Settings (2) – Display Tab,” p. 103). 

verview: Toolbars for Previews
oolbar for 

Select tool: Use to select an area of the preview.
Handtool: Use to move around the preview so you view all 
areas of it. (Works only if the preview is larger than the win-
dow.)
NOTE: Toggling between Hand Tool and Select Tool! Acti-
vating the Hand Tool deactivates the Select Tool and vice 
versa.
Not available with Single User
Not available with Single User.
Not available with Single User.
Not available with Single User
Rotates the preview 90° counter-clockwise
Rotates the preview 180° 
Rotates the preview 90° clockwise

0 Zooms in the preview.
1 Zooms out the preview.
IP: Independent from the selected tool, using the ALT key in 
onjunction with the mouse lets you move the image inside the 
review window . 
2 Shows preview in original size.

13 Fits preview to window.
14 Shows preview in fullscreen.

TIP:  If you have a fullscreen preview, you can use the 
mouse scroll wheel to get the next or previous asset 
displayed. 

15 If activated, the displayed preview follows the selec-
tion in the collection window (same behavior as the 
Information Window). If not activated, the displayed 
preview remains independent from the selection in 
the collection window and must be changed manu-
ally.

16 Closes the window.
17 Shows the preview of the first record from the current 

collection.
18 Shows the preview of the previous record from the 

current collection.
19 Shows the preview of the next record from the current 

collection.
20 Shows the preview of the last record from the current 

collection.
21 Displays the current Record View Set; clicking on the 

arrow opens a selection list of available Record View 
Sets.

1 2 3 5 6 7 8 20104 9 1312 14 15 16 1711

Preview Window

Preview View

19 2118 19
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You can copy all or part of a preview to the Clipboard. To select a portion of the 
preview image:

1. Click the Select Tool ( ) on the toolbar and then click and hold the mouse 
down in the upper left hand corner of the region you want to copy.

2. Drag the mouse to the lower right of the region. A box is drawn around the 
selected area.

3. Press Command / Control and c to have the selected portion on the 
Clipboard.

The selected portion of the preview is on the Clipboard and may be pasted into 
other applications. Remember, this is a copy of the preview image, not the actual 
asset. 
A selected portion of a preview can also be zoomed in:

1. Click the Select Tool ( ) on the toolbar and then click and hold the mouse 
down in the upper left hand corner of the region you want to zoom in.

2. Drag the mouse to the lower right of the region. A box is drawn around the 
selected area.

3. Click the Zoom in icon ( ) on the toolbar to have the selected portion fill in 
the entire size of the Preview window.

Multi-page Previews 
Multi-page previews are available for the following file formats: GIF, InDesign, 
JPEG, PCX, PDF, PowerPoint Presentations, Photoshop, Quark XPress, and TIFF. 
For InDesign a multi-page preview can be provided only if one of the following 
requirements is fulfilled:
• A Cumulus Metadata file (TAG file) is available which was created by the 

Cumulus Plug-in for Adobe InDesign
OR

• The corresponding XPV file is available (and a licensed HELIOS Image Server 
accessible in the network).

For Quark XPress a multi-page preview can be provided only if one of the follow-
ing requirements is fulfilled:
• The corresponding XPV file is available (and a licensed HELIOS Image Server 

accessible in the network) 
OR

• The Cumulus DDS Companion is installed and configured in the Cumulus 
Quark DDS Filter 
OR

• Under Mac OS: Quark XPress is installed.

NOTE: The preview always shows the current status of an asset. So the num-
ber of pages/slides might differ from those cataloged as contained sub assets 
if the asset has changed and the records were not updated. 
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Fullscreen Preview
The Fullscreen Preview window offers an interactive display of up to six different 
assets at once, making it easy to pick the perfect one each time – compare qual-
ity, sharpness, composition, etc. 

Opening the Window
Select the records of the assets you want to have displayed in the window and 
select Asset > Fullscreen Preview.

Using the Window
You can have record fields displayed. What is displayed along with the previews 
depends on the selected Record View Set and its setting for the Preview window. 
(For a description on how to configure the view of the Preview window see 
“Record View Sets,” p. 105.) Always displayed on the statusbar and not depend-
ing on the selected Record View Set are the fields Record Name, Label and Rating 
(if contained in the catalog.)

Linking Panels
In Fullscreen Previews of multiple assets, two or more panels can be linked 
together for synchronous zooming, rotating and panning.
To link panels:

1. Click the icon on the statusbar of every panel you want to link, OR

CTRL-click /  CMD-click any of the  icons to link all panels in the 
fullscreen preview.

In linked panels, the  icon is highlighted.
To unlink panels, i.e. to exclude them from synchronous zooming, rotating and 
panning:

1. Click the highlighted  icon of every panel you want to unlink, OR

CTRL-click /  CMD-click any of the  icons to unlink all panels in the 
fullscreen preview.

NOTE: In fullscreen previews of single assets, the  icon is not displayed. 

Displaying the Info Window
Ready “slide on” access to the Info Window makes metadata edits easy. Move 
your mouse pointer to the left edge of the screen and the Info window will show 
up. Click the pin icon to dock it so it will stay when you change the mouse pointer 
position.
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Using the Toolbar
Move your mouse pointer to the bottom of the window and its toolbar pops up. 

Displaying a Command Overview
Position your mouse pointer on the question mark icon to have a list of available 
commands and keyboard shortcuts is displayed. Click on the question mark to 
access the Cumulus help system. 

Marking Assets
In the Fullscreen Preview window you can mark assets by using labels and rat-
ings. 
Color labels are set using the square symbol. Clicking on this icon opens a list of 
available labels. Select the label you want to mark the asset with. 
You can also mark assets using star ratings. Use the shortcuts CTRL+ALT+1-5 / 

ALT + CMD+ 1-5 to set the rating. See “Labeling,” p. 77, for more about labels; 
see “Rating Assets,” p. 78 for ratings.

Fullscreen Preview Toolbar Items

1 Shows the preview of the first record from the current collection.
2 Shows the preview of the previous record from the current collection.
3 Shows the preview of the next record from the current collection.
4 Shows the preview of the last record from the current collection.
5 Shows/hides statusbar (comprising label, rating, rotating & zooming icons.)
6 Mouse over: Display list of available commands / Click: Open help system
7 Closes the window.

1 2 4 653 7
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Adjusting Preview Size
The magnify glass icons of the statusbar let you scale how an asset is displayed 
within each preview area (panel). To zoom in on a preview image, you also use 
the + (plus) and - (minus) key shortcuts. 

Rotating Previews
The rotation icons of the statusbar let you rotate a preview 90° clockwise or coun-
ter-clockwise.

Next and Previous Assets
You can use the arrow icons of the toolbar or the PAGE DOWN and PAGE UP key 
to load assets in the window. When there is more than one asset on-screen, the 
asset that is changed is the one that is marked as selected by a  light green border 
and a big check mark symbol. If none is selected, the entire group of previewed 
assets is replaced by the next group. If one is selected, the PAGE DOWN key 
changes the asset to the next one in the collection and the PAGE UP key changes 
it to the previous one. You can also use the mouse wheel to scroll through.

TIP: 
If multiple assets are displayed in the Preview window, a single asset 
can be loaded into more than one preview area, enabling you to pan, 
zoom and examine it in detail. To load another preview in a preview 
area, select the preview area and use ALT+Mouse Wheel.

NOTE: Linked preview images are navigation locked, i.e. they never change 
position and can’t be replaced with other assets via the PAGE UP / PAGE 
DOWN keys or scroll wheel navigation.

Comparing Previews
Any two selected preview images can be automatically compared by Cumulus, 
with a visual representation of the comparison result displayed in the Fullscreen 
Preview. For details, see “Preview Comparison,” p. 57

Fullscreen Slide Show
Shows assets as fullscreen previews in a slide show. You can load the assets man-
ually or run them in a loop.

Opening the Window
Select the records of the assets you want to have displayed in the slide show and 
select Asset > Fullscreen Slide Show.

Using the Window
You can have record fields displayed. What is displayed along with the previews 
depends on the selected Record View Set and its setting for the Preview window. 
(For a description on how to configure the view of the Preview window see 
“Record View Sets,” p. 105.)
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Using the Toolbar
Move your mouse pointer to the bottom of the window and its toolbar pops up

Displaying a Command Overview
Position your mouse pointer on the question mark icon and a list of available 
commands and keyborad shortcuts is displayed. Clicking on the question mark 
accesses the entire Cumulus help system. 

Preview Comparison
Cumulus provides a smart option that allows you to compare two image assets. 
A visual representation of the comparison result as well as the previews of the 
compared assets are presented in fullscreen preview. 
The comparison is done on a pixel-by-pixel base, i.e. any pixel in the preview of 
an asset is compared to the according pixel in the preview of the other asset. The 

Fullscreen Slide Show Toolbar Items

1 Shows the preview of the first record from the current collection.
2 Shows the preview of the previous record from the current collec-

tion.
3 Shows the preview of the next record from the current collection.
4 Shows the preview of the last record from the current collection.
5 Displays how many seconds each slide (asset’s preview) will be 

displayed in a looping slide show. You can enter the number of 
seconds you want.

6 Stops/starts the loop.

7 Shows/hides statusbar (Statusbar comprises 
of label, rating, rotating & zooming icons.)

8 Mouse over: Display list of available com-
mands / Click : Open help system

9 Closes the fullscreen slide show.

1 3 42 5 6 7 8 9
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comparison result is computed – and displayed – as the difference of the RGB 
values of the corresponding pixels. Pixels that are identical in both images 
appear as black in the comparison result.
If the two images to be compared have the same aspect ratio but different sizes, 
the larger one is scaled down to the size of the smaller one. If the images differ 
both in size and aspect ratio, they are overlaid centered.
Compare Previews is especially useful for detecting subtle differences in appar-
ently identical image assets.

Starting the Comparison
The preview comparison can be startet either from the collection window, or 
from the fullscreen preview.

1. In the collection window, select the records of the two assets you want to 
compare, then select Asset > Compare Previews.

OR

In a Fullscreen Preview of multiple assets, select the previews of the two 
assets you want to compare, then open the context menu (with the right 

mouse button /  Control key + mouse) and select Compare.

Using the Window
A fullscreen preview comprising a comparison result behaves the same way and 
offers the same options as any fullscreen preview (see “Fullscreen Preview,” 
p. 54.) 
The statusbar of the panel with the resulting image displays the title Comparison 
Result and the current zoom factor. 
By default, the comparison result and the two previews of the compared assets 
are linked for all zooming, rotating and panning commands, i.e each zooming or 
panning operation in either panel is performed on the other two panels at the 
same time and in the same way (see “Linking Panels,” p. 54).
Comparison results can only be viewed, but not saved, rated, or labeled. And of 
course, there is no metadata for the comparison result to be displayed.
To get rid of the comparison result and possibly restore the preview image that 
was displayed previously in that panel, select the compare image, then open the 
context menu (with the right mouse button /  Control key + mouse) and 
select Reset Compare Panel.

Repurposing Assets
Cumulus provides several ways for you to repurpose your cataloged assets. The 
following sections describe how you can do this making use of Cumulus Con-
verter module.

Converting Image Assets
The Pixel Image Converter enables you to convert any cataloged pixel image into 
the different formats on the fly, e.g. JPEG, TIFF, BMP, GIF, ScitexCT, PNG, PCX, and 
PDF. It also lets you resize the image and convert it into another color space.
With Cumulus, the images can also be cropped, rotated or flipped, Sharpen and 
Blur filters can be applied for the image processing. The sequence of the conver-
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sion processes is cropping first, then resizing and after that applying a filter. 
Finally the image is saved in the specified color space and output format.
To convert image assets into another format:

1. Select the record(s) representing the image asset(s) to be converted.

2. Select Asset > Convert To menu command.

The Browse for Folder dialog opens for choosing a destination for the con-
verted asset.

3. Select the folder and click Open / OK.

A dialog opens for choosing the converter. The dialog lists the Asset Proces-
sors available to you. Available to you for converting are the Asset Processors 
that are activated in the Asset Handling Set which is chosen for Asset Access 
in your User Settings. 

4. Select Pixel Image Converter as Asset Converter. 

The Pixel Image Converter Parameter dialog opens.

5. Choose your settings. For details, see “Pixel Image Converter Parameters,” 
p. 59.

6. Click OK.

The selected image asset(s) will be converted and the resulting images will be 
stored in the selected destination.

Pixel Image Converter Parameters
For the conversion you can define parameters referring to:
• Image Size
• Image Processing
• Output Format 

Image Size
You can not only determine the image size (in pixel as well as inches, cm or per-
cent). You can also have the image cropped before it is scaled to the dimension 
defined by width and height. 
• Alternate Source Resolution

If you want to use the image with a resolution different from the stored orig-
inal, activate the User Alternate Source Resolution option.

• Crop Area 
Cropping refers to cutting down an image by cutting away unwanted parts 
at the edges. You specify left, top, right, bottom margins to be cropped off 
the source image. 
The cropping function can be used to trim the edges of an image. Enter the 
size of the edges to be removed. Define the measurement under Units.
NOTE: If you use an alternate source resolution, be aware that this resolu-
tion is the basis for any cropping in inches or cm measurements.

• Scale Dimension 
The values for width, height and resolution determine the size of the con-
verted image. The image size can be specified in pixel dimensions or print 
dimensions. And you can decide to have the image converted either to an 
individual size or to a fixed size, the maximum of which is defined by a 
bounding box. The result depends on the selections set for the conversion:
• Work at

If you want to specify the size in inches or cm and have the software calcu-
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lating the pixel dimension automatically depending on the set resolution, 
select Document Size. If this option is activated, the entered values deter-
mine the print dimensions.
If you want to specify the pixel dimension (not caring about print size), 
select Image Size. 
Note that the final output size depends on the output device’s settings 
(e.g. dpi of printer).

TIP: 
Working at Image Size is useful when preparing images for online dis-
tribution. Keep in mind that changing pixel dimensions affects not 
only the size of an image on-screen but also its image quality and its 
printed characteristics – either its printed dimensions or its image res-
olution. 

• Constrain Proportions
To maintain the current proportions of width to height, activate this 
option. (This option is not available if you have selected multiple records 
for converting or if you are defining a Cumulus Action.)

TIP: 
To keep the proportions if you have selected multiple records or if you 
are defining a Cumulus Action we recommend you to specify height 
and width in percent. 

• Use Size as Bounding Box
If this option is activated, the size defines the bounding box into which the 
images has to fit. The image will be resized proportionally to fit the size of 
the bounding box. No dimension of the converted image will exceed the 
size of the box. When using this option, the proportions of the images are 
always constrained and that’s why the Constrain Proportions option is not 
available.
If you want images that are smaller than the size of the bounding box to 
be enlarged to this size, activate the Enlarge Smaller Images option. 

TIP: 
To define the size for a box you want to fit for portrait and landscape 
images, make it a square. Then the longest edge of an image (height 
or width) will be resized to the entered value and the shorter edge will 
be resized according to the proportions of the image. 

You can choose different units of measurement. To enter values as percent-
ages of the current dimensions, choose Percent as the unit of measurement.

Image Processing
With the conversion the image can be processed. You can have a filter run, rotate 
and flip the image. Select the desired processing options.
• Filter 

To have a filter run with the conversion, select a filter type and the radius 
range for the filter (small, medium, large.) The radius determines how far the 
filter considers surrounding pixels that affect the filter action. The following 
filters are available:
• Average Blur filter

Softens an image. It smooths transitions by averaging the color values of 
surrounding pixels. Eliminates noise where significant color transitions 
occur in an image. 
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• Median Filter
Reduces noise in an image by blending the brightness of pixels. The filter 
adapts the brightness of pixels to the median brightness value of the sur-
rounding pixels. 

• Gaussian filter
Works similarly to the Blur filter but uses a weighted average of the color 
values of the surrounding pixels. The weighting is generated using the 
Gaussian bell-shaped curve that is generated. 

TIP: 
The Blur as well as the Gaussian filter decreases high-frequency details 
and can produce a hazy effect. 

• Sharpen filter
Increases the visual sharpness of images by increasing the contrast at 
edges. 

TIP: 
Applying the Sharpen filter is recommended when scaling up images 
to keep their visual sharpness as high as possible. 

• Unsharp Mask Filter
Makes images appear sharper by increasing the contrast of small bright-
ness changes.

• Add Noise Filter
Applies random pixels to an image, simulating distortion or noise. You can 
also use the Add Noise filter to give a more realistic look to heavily 
retouched areas. 

• Rotation 
You may rotate the image by selecting image rotation degrees.
0 no rotation
90 to rotate the image clockwise by a quarter-turn
180 to rotate the image by a half-turn
270 to rotate the image counterclockwise by a quarter-turn.

• Flip 
– activate horizontal to flip the image along the vertical axis.
– activate vertical to flip the image along the horizontal axis.

Output Format
For the output you can define the following parameters:
• Color Space

Select the desired color space for the converted image. The available color 
spaces depend on the selected file format (e.g. GIF, PNG, PCX, and BMP do 
not support CMYK.)
NOTE: ICC Profile Embedded
The ICC profile of an original image will be embedded in the converted 
asset if the color space is not changed and the output file format supports 
ICC profiles. 

• File Format
Select the file format for the converted image. Depending on the selected file 
format, the available further parameters for the output format may differ. 

• Compression
Select a compression scheme that is supported for the selected file format. 
(This version of the Pixel Image Converter provides a compression scheme 
for TIFF only.)
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• Quality (JPEG)
For JPEG and PDF files only, select the desired quality.

• Store IPTC Information
To store IPTC metadata within TIFF and JPEG images, activate this option.

• Store XMP Information
To store XMP metadata within TIFF, JPEG, PNG, and PDF files, activate this 
option.

The selected asset(s) will be converted and stored under the name of the original 
asset in the selected destination. The Pixel Image Converter will automatically 
add the correct File Type and Creator / file extension to the file name. The 
name will be extended by a number if a file with that name already exits at the 
selected destination.

Watermarking Assets
With the ever increasing number of digital assets, digital watermarking has 
become an important topic. Watermarking helps you to protect your intellectual 
properties. Protect your images by adding watermarks.
Digital watermarking is a technology for embedding information into digital 
assets. In general, information for protecting copyrights is embedded as a water-
mark. A watermarked image can prove its origin, thereby protecting copyright. A 
watermark also discourages the making of illegal copies.

BACKGROUND INFORMATION:  
Watermarking can serve many different purposes from tamper proof-
ing to authentication. Three major aspects in the protection of digital 
assets have been pointed out, each of them with different require-
ments: first copyright protection, protecting ownership and usage 
rights; secondly tamper-proofing, aiming at checking document 
integrity; and thirdly authentication, the purpose of which is to check 
the authenticity of a document. While robust watermarks are typically 
used for copyright protection, fragile or semi-fragile watermarks are 
proposed to ensure tamper proofing and authentication.

For embedding watermarks, Cumulus provides the Watermark AssetProcessor. It 
enables you to embed visible watermarks into following pixel image formats: 
JPEG, TIFF, BMP, GIF, PNG, and PCX. It creates a copy of a cataloged asset with the 
digital watermark embedded. 

Watermarking Parameters
You can provide both an image and text for your watermark. The position of the 
text can be set in the properties. You can provide just the image or just the text. 
Or a combination of the two.

Visible Image 
As a watermark image you can use most common pixel image formats, e.g. JPEG, 
PNG, and TIF. If an animated image file is supplied, the first frame will be used as 
the watermark image. You can either type in or browse to find the watermark 
image file.
You define the opacity of the watermark from 0 to 100. If you set the opacity to 
0, the watermark image will be totally transparent and you will not be able to see 
it. If you set it to 50, the watermark will be semi-transparent. The watermark will 
be completely opaque (solid) if the opacity level is set to 100. 
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Under Image Position, you define the area where the watermark image should 
be placed. The position of the watermark image within the resulting image is 
defined by anchor points.
You can control the size of the watermark image by scaling it. When scaling, pro-
portions are constrained, and the images will be scaled to provide the maximum 
overlay. Small watermark images will be enlarged and large ones will be made 
smaller. You can also define to have only small images enlarged. Following scal-
ing options are available: 
• At long edge – The watermark image is scaled at its long edge. The long 

edge will be scaled to fit the source image and with proportions constrained 
the short edge will be scaled accordingly.

• At short edge – The watermark image is scaled at its short edge. The short 
edge will be scaled to fit the source image and with proportions constrained 
the long edge will be scaled accordingly.

• Fit to image size – The watermark image is scaled to fit the size of the image, 
depending on the image orientation (portrait or landscape). 

• Scale up only – A watermark image that is smaller than the source image is 
enlarged to provide the maximum overlay. Proportions are constrained.

NOTE: If you do not activate the scale option, watermark images larger than 
the source image will be cropped. 

The Previously selected image field will display an image only if the watermark-
ing parameters are defined for an Asset Action. Then the watermarking image 
will be provided by the Cumulus Server and the field displays a preview of the 
image that was transferred by the Cumulus Server.

Visible Text
The visible text can be entered by you and/or taken from a Cumulusrecord field. 
Using a record field enables you to have individual watermarks when batch pro-
cessing images. 
To include a record value as text, select the desired field from the Record field 
drop-down list and click Append. The corresponding placeholder entry will be 
inserted at the end of the Content field.
You are allowed to enter multiple lines of text in the Content field. Enter \n for 
carriage return. You can also type special characters (like ©, ®, etc.). They will be 
rendered properly in the processed images. 
You can control the position of the text. You can specify the Horizontal Position 
(Left, Center, and Right) and Vertical Position (Top, Middle, and Bottom) of the 
text. 
You define the opacity of the watermark from 0 to 100. If you set the opacity to 
0, the watermark will be totally transparent and you will not be able to see it. If 
you set it to 50, the watermark will be semi-transparent. The watermark will be 
completely opaque (solid) if the opacity level is set to 100. 
You can choose the font, style, size and color of the text. To have the text fit best 
to the image size independently of the font size setting, activate the Fit text to 
image size option.
Under Text Position, you define the area where the watermark text should be 
placed. The position of the text within the resulting image is defined by anchor 
points.

Employing Custom Record Fields 
The drop-down list for selecting a record field displays the Cumulus standard 
fields only. If you want to include a custom field, you must enter the GUID (Glob-
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ally Unique Identifier) of the field into the Content field of the Watermark Assset-
Processor Parameter dialog.
To find out the GUID open the Properties of the field ( Cumulus / Edit > 
Preferences > Catalog Settings) and on the General tab double-click the field 
name of the field Field Name.  
This copies the GUID to the clipboard and you can paste it. A Cumulus GUID is 
composed of exactly 38 characters and looks like this: 
{af4b2e12-5f6a-11d2-8f20-0000c0e166dc}

Embedding Watermarks into Image Assets
You embed watermarks into image assets by employing the Convert menu com-
mand or by including the Watermark AssetProcessor in a Cumulus Asset Action. 
(For information on how to include an Asset Processor in an Asset Action, see 
“Cumulus Asset Actions,” p. 124.) 
To watermark image assets via the Convert menu command:

1. Select the record(s) representing the image asset(s) to be watermarked.

2. Select Asset > Convert To menu command.

The Browse for Folder dialog opens for choosing a destination folder for the 
watermarked asset(s). 

3. Select the folder and click Open / OK.

A dialog opens for choosing the converter. The dialog lists the Asset Proces-
sors available to you. Available to you for converting are the Asset Processors 
that are activated in the Asset Handling Set which is chosen for Asset Access 
in your User Settings. 

4. Select Watermark AssetProcessor as Asset Converter. 

The parameter dialog opens. 

5. Make your settings. For details, see “Watermarking Parameters,” p. 62.

6. Click OK.

The selected image asset(s) will be converted and the resulting images will be 
stored in the selected destination.

Creating ZIP Archives
The ZIP AssetProcessor compresses assets into Zip archives. 
To compress cataloged assets into Zip archives:

1. Select the record(s) representing the asset(s) to be compressed.

2. Select Asset > Convert To menu command.

The Browse for Folder dialog opens for choosing a destination for the ZIP 
asset.

3. Select the folder and click Open / OK.

A dialog opens for choosing the converter. The dialog lists the Asset Proces-
sors available to you. Available to you for converting are the Asset Processors 
that are activated in the Asset Handling Set which is chosen for Asset Access 
in your User Settings. 

4. Select ZIP AssetProcessor as Asset Converter. 

The ZIP AssetProcessor Parameter dialog opens.

5. Select the parameters for the conversion:
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• Under Archive Name you have to choose a name for your ZIP asset. The 
ZIP AssetProcessor will automatically add the extension ".zip" to the file 
name. On Mac OS this means that the name can be up to 27 characters in 
length without the extension.
NOTE: If you choose an existing ZIP asset as archive name, the ZIP 
AssetProcessor will update the already contained assets and append 
new assets.

• Under Use Character Encoding you can define the character encoding 
used to save the file name(s) in the ZIP file. The default is your local system 
encoding – the encoding of the computer you are working with (this 
encoding would be used by WinZip and StuffIt also). The character encod-
ing chosen should account for the language and the operating system of 
the computer where the ZIP is to be unpacked. Find some common 
encoding recommendations listed below.
– Windows and West European languages: WinLatin1
– Windows and East European languages: WinLatin2
– Windows and 2 byte character encoding (e.g. Japanese): WinJapanese
– Mac OS X: UTF8
– Mac OS 9 and West European languages: MacRoman
– Mac OS 9 and 2 byte character encoding (e.g. Japanese): MacJapanese
– Mac OS 9 and Russian: MacRussian
– UNIX: Ask the person you will provide the ZIP archive with, which encod-
ing is needed.

• Under Macintosh Resource Support you can define how to support Mac-
intosh resources. 
– Activating the Store as MacBinary Format option determines the assets 
to be stored including the Mac OS resource fork, data fork and finder infor-
mation (e.g. File Type/Creator). This option should only be activated, if the 
file will definitely be extracted under Mac OS, as the MacBinary format 
often cannot be extracted properly under Windows or UNIX.
– Activating the Store as Mac OS X archive compatible option saves the 
files in the same structure as in an archive created with the Finder of Mac 
OS X (10.3 or later). 
NOTE: If you have activated the Macintosh Resource Support with 
the option Store as Mac OS X archive compatible, the character 
encoding is always UTF-8.

6. Click OK.

The selected asset(s) will be compressed and the ZIP asset stored in the selected 
destination.

WebAlbum
Cumulus WebAlbum enables Cumulus to output selected images’ records as a 
Web-ready album. This album is based on static HTML pages, complete with 
thumbnails, scaled versions of images and links to the original assets. You can use 
different skins for the layout and functionality of your album, such as those pro-
vided by Canto or other providers (e.g. by JAlbum), or those you develop your-
self. WebAlbum takes the selected records and converts their assets to files 
suitable for display on the Web. This includes the automatic creation of copies of 
the assets in the Web-ready JPEG image file format. You have full control of 
album design through the use of skins. WebAlbum will create thumbnails of your 
images and display them in index pages in HTML. WebAlbum can also produce 
slide shows of your images for easy navigation.
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An album created with Cumulus WebAlbum can be uploaded on any common 
Web server (no special system requirements) and can be viewed with any stan-
dard Web browser. You can also use WebAlbum to create local albums on your 
hard disk or on CD-ROM. 
If you are looking for more features for your album uploaded on the Web than 
Cumulus WebAlbum provides (e.g. search functions, non-static pages, e-com-
merce), then have a look at the Cumulus Internet solutions that Canto provides. 
For details on all of Canto's Digital Asset Management products and services go 
to: www.canto.com

Creating an Album
When you create an album, WebAlbum uses the records you selected and:
• generates thumbnails in JPEG format (e.g. used for index pages) – always
• generates scaled images in JPEG format (e.g. used for slide pages) – if a cor-

responding option is activated
• copies the original assets to a defined output folder for the upload – if a cor-

responding option is activated
Furthermore WebAlbum generates:
• index page(s) – always
• slide pages – if a corresponding option is activated. Depending on the acti-

vated option, slides contain selected record fields’ information and scaled 
images or original assets.

To create an album:

1. Select the records of those images you want your album to consist of.

2. Select Asset > Create WebAlbum.

A dialog for configuring your album opens. Now you can either configure a 
new layout for your album or use a saved one by clicking the  (Open) 
button.

3. Configure the album.

Three sections provide access to the configuration options:

The General Section

• Title: Enter a title for your album. Where this title is displayed depends on 
the selected skin.

• Output Location: Define the folder to hold the output of your configured 
album. This should be an empty folder when you start creating a new 
album.

• Output Options:
Make Slides – Enable this option, if you want your album to include slides 
(scaled images and contents of the selected record fields). If the selected 
skin supports these functions, next/previous buttons are provided to dis-
play the slides.
Upload via FTP – Enable this option if you want your album to be 
uploaded onto the Web directly after creation.
NOTE: This option can only be enabled if the settings on the FTP tab 
were tested and did not show any errors.

• Link Options: Decide on one of the options (for further information on 
these options, see the section “Provided Skins and Link/Output Options”, 
below.)
Link to Originals – Clicking on a thumbnail will display the original asset. 
Link to Originals through Scaled Images – Clicking on a thumbnail will dis-
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play the slide including the scaled image and clicking on this image will 
display the original.
NOTE: Albums that include links to the original are quite large in size. 

Link to Scaled Images Only – Clicking on a thumbnail will display the 
scaled image without any further link to the original.

• Image Size & Quality
Thumbnails – Select or enter the size for the thumbnails (left field) and 
select the compression quality (right field).
Images – Select or enter the size for the scaled images (left field) and select 
the compression quality (right field).
NOTE: Images will maintain aspect ratio and constrain their propor-
tions.

• Page Layout (valid only if the skin interprets these values)
Columns – Enter the number of columns for the index page(s).
Rows – Enter the number of rows for the index page(s).

• Image Order: Select the record field you want used for alphabetical sorting 
of the thumbnails.
Reverse Sorting Order – If this options is enabled the sorting order is Z to A 
or 9 to 0

• Skin
Name – Select the skin you want to use for this album. The selected skin 
defines the overall appearance of your album: layout and functionality.
Style – Select a style (e.g. color theme and look) for the above selected skin.
Automatically load Skin Settings – Enable this option, if you want the 
selected skin’s layout hints to be loaded automatically (valid only if there 
are any hints provided with the selected skin).

The Fields Section

Use the Add button to add the fields of the contents you want to include 
with the slides.
Use the arrow buttons to place the fields in order.

The FTP Section

• FTP Settings 
FTP Server – Enter the name of the FTP server you want to upload the 
album to. 
Port – If it is not the standard FTP port number 21, enter the required port 
number of the FTP server you want to upload the album to.
User Name – Enter the user name of the FTP account. 
Password – Enter the password of the FTP account. 
Path – Enter the directory on the FTP server you want to upload the album 
to. Enter at least a slash (/) but be aware that an existing index.html will be 
overwritten.
Passive Mode – Enable this option if you expect any trouble when con-
necting through a firewall. 
Overwrite Existing Files – If this option is enabled, existing files will be 
overwritten when uploading a new album. If not enabled, existing files will 
not be overwritten with the new version.

To test your FTP settings you can click the Test Settings button. Only in 
cases where the settings do not include any errors, you can enable the 
Upload via FTP option on the General tab.

4. Click Start to create your album. 

If you have changed any setting of the album layout or if it is a new album 
layout, you are asked whether you want to save your changes. If it is a new 
album layout you want to save, you are asked to enter a name for it.
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If the folder you defined under Output Location contains any files, you are 
asked whether this folder should be cleared. We recommend selecting Yes. 
If you select Yes, all files and subfolders in the output folder will be deleted 
before the new output files are created. If you select No, HTML files with the 
same names as the newly created ones will be overwritten and new copies 
of the assets will be added. If you select Cancel, the creation of your new 
album will be canceled.

The output files of your album are created in the folder you defined under 
Output Location. Start the index.html page in that folder to see (and test) 
your album.

You can save your album layout configuration by clicking the  (Save) button. If 
you want to save it under another name, click the (Save As) button. 

NOTE: You may select records of any file formats to create an album – not 
only images. However, in this case you should not include slides but use links 
that point directly to the originals.

Provided Skins and Link/Output Options
The album design is controlled by skins. Canto provides different skins for 
Cumulus WebAlbum. The skin named “Canto” supports the following output 
depending on the selected link and output options:

~~~
~~~
~~~
~~~

Index page with thumbnail 
overview

Slide page with field information 
and scaled image

Original asset 

Link Option “Link to Originals through Scaled Images” (Output Option “Make Slides” ignored)

~~~
~~~
~~~
~~~

Index page with thumbnail overview Slide page with field information and original asset

Link Option “Link to Originals” (Output Option “Make Slides” activated)

Index page with thumbnail overview Original asset 

Link Option “Link to Originals” (Output Option “Make Slides” not acti-
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Preferences
Within the Preferences dialog of your Cumulus application, you can define the 
startup settings for WebAlbum. WebAlbum can either be started with a new and 
empty album layout or with the last album layout you used.
To set WebAlbum to open the last album layout used when starting:

1. Select Cumulus / Edit > Preferences. The Preferences dialog window 
opens. 

2. Select User Settings and click WebAlbum on the General tab.

3. Enable the checkbox.

4. Click Apply to save your changes and select the next preference you want to 
edit.
OR 
Click OK to save your changes and close the Preferences window.

Customize
You can easily customize your album by using different skins. You can either 
develop your own skins or use skins created by other providers. Check Canto’s 
website (Products & Services > EJaPs > EJaP Exchange Forum) from time to time 
to see if new skins have been developed that you could use.
A skin consists of a folder that contains subfolders for images included in the skin 
itself (the res folder) and cascading style sheets (the styles folder) as well as files 
that define special pages, e.g. the index pages and the slide pages. The About 
text file will inform you if the skin contains any extraordinary functions or defini-
tions.
The skins provided with Canto can be found in the skins folder inside the web-
album folder. The webalbum folder is located in the ejp folder in your Canto 
installation folder.

~~~
~~~
~~~
~~~

Index page with thumbnail overview Slide page with field information and scaled image

Link Option: “Link to Scaled Images Only” (Output Option “Make Slides” activated)

Index page with thumbnail overview Scaled image

Link Option “Link to Scaled Images Only” (Output Option “Make Slides” not activated)
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It is easy to customize the fonts (type, size and color) and the background colors 
of a skin by editing the cascading style sheet (.css). If you want to develop your 
own skins, you have to know how to do it on your own. Canto cannot give you 
any support for developing skins. 

TIP: Cumulus WebAlbum and JAlbum
You may use JAlbum skins with Cumulus WebAlbum. If you want to 
use JAlbum skins, you have to replace </ja: and <ja: with </wa: and 
<wa: in the index.htt and slide.htt files. Then test the skin. The follow-
ing skins seem to work with Cumulus WebAlbum: Mamba, Film, XP, 
and CameraGeek. 
You may look at the JAlbum skin repository site, the site that is 
intended to act as a central area where makers of skins for JAlbum can 
share their skins with others: http://jrepository.engblom.org 
However, note that Cumulus WebAlbum does not support all JAlbum 
skin possibilities. 

 Importing and Exporting
Cumulus can export and import records, categories and collections. Collections 
can only be imported and exported in Cumulus exchange file formats whereas 
records and categories can also be exported to and imported from XML files. 
Exported catalog metadata in XML files can be used by other programs as well 
as on other platforms. Paired with the metadata import options Cumulus offers, 
you have a complete metadata “round-tripping” solution to make integrations 
with your other systems easy.
Cumulus supports XSL Transformations (XSLT). XSLT is a programming language 
for transforming XML documents into other XML documents. XSLT was 
designed to be used with XSL, which is a stylesheet language for XML. With the 
Cumulus export function XSLT can be used for example to place images and 
metadata in InDesign documents.
Importing and exporting data with Cumulus is easy, but there are a few things to 
be aware of in order to avoid unexpected results, which are explained below.

Cumulus Exchange File Formats
XML is the recommened export format. But for special purposes Cumulus can 
also export and import records, categories and collections in special Cumulus 
exchange file formats. These files can be used on any supported Cumulus plat-
form. But note that records and categories do not support the Cumulus 8 Table 
fields. Canto recommends you use these formats only for special purposes con-
cerning Cumulus versions prior to 8. The Cumulus exchange file formats are:
• Categories – Cumulus exports categories in a Cumulus Category Exchange 

File. The file name extension is .cce
• Records – Cumulus exports records in a Cumulus Record Exchange File. The 

file name extension is .cre
• Collections – Cumulus exports collections in a Cumulus Collection Exchange 

File. The file name extension is .cfe
Exporting data in this format can be used for transferring data between catalogs 
for archiving category listings. These archive files can be imported into any other 
catalog when you need them. (You could do the same thing with records, but it’s 
probably more convenient just to keep copies of the records in catalogs.) 
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Character Encoding for Export
When exporting information in Cumulus exchange file formats, you can employ 
different character encoding. You should base your decision on how the 
exported file is to be used. Universal Encoding (UTF-8: Unicode characters coded 
as 8-Bit Transformation Form) makes sure that special characters are transferred 
correctly across platforms. Choose this format only if you want to use the 
exported file on another operating system.

Maintaining Category Assignments
The most important thing to know when you are exporting records to be 
imported into another catalog, is whether the new catalog already has the cate-
gories to which the records are assigned. If it does not, the categories assigned 
to the imported records will be created. But categories of the type “Folder” lose 
their type (assignment to the Source tab). They are created as normal categories. 
If you want to keep the type of these categories, you must first export and import 
the categories. 
Remember that it may be easier just to drag and drop records from one catalog 
to another, if both the source and destination catalogs are available to you. If they 
are not, or you are moving thousands of records at a time, then the export/
import route is the way to go.

Exporting and Importing Records and Categories 
The exporting and importing process is pretty much the same, regardless of the 
data type. Exporting goes like this:

1. Find and select the items you wish to export. (See “Searching,” p. 32, if 
needed, for a refresher on how to find records.)

2. Select File > Export and then the appropriate export option:

• Selected Records – Exports the currently selected records. (This menu 
item is disabled if no records are selected.)

• All Records – Exports all records of the active collection. If you want to 
export all records of the catalog(s) included in the collection, you have to 
perform Find > Find All Records first.

• Selected Categories – Exports the currently selected categories in the 
active collection. (This menu item is disabled if no categories are selected.)

• All Categories – Exports all categories of the Category pane. 
3. Select the export format. Note that the XML format is recommended for 

most purposes. This format enables Cumulus to export from multiple cata-
logs and supports data from Cumulus Table fields.

• When exporting records into an XML file, a check box offers the option to 
have the export file compressed (*.zxml) . Another check box offers to 
enable XSL transformation by applying an XSLT stylesheet which describes 
the rules for the transformation.

• When exporting selected categories, a check box offers the option to 
export the subcategories as well. 

4. Click the  button for browsing for the location where the export file 
should be saved. 

5. Select the location, name the export file and click Save. Note that Cumulus 
will add the correct file extension.

6. Click Next. If you are exporting into XML, you can select the fields that con-
tain the values to be included in the export file.
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7. Make your selections and click Start. Messages inform you of the export pro-
cess. 

8. When you get the message that the process is finished, click Finish to close 
the dialog.

Importing is just as easy:

1. Select File > Import.

2. If you have multiple catalogs open in one window, select the catalog to 
which you want to import the data.

3. Click the  button for browsing to the location where the file to be 
imported resides. 

4. Select the file and click OK. 

5. Select the appropriate file format. Note that the XML format will also work for 
zipped XML files (*.zxml).

NOTE: Importing Categories
If a category in the import file has the same name as an existing category 
at the same hierarchy level, the category is not imported.

6. Click Next to start the import. Messages inform you of the import process. 

7. When you get the message that the process is complete, click Finish to 
close the dialog.

Importing and Exporting Collections 
Collections stored with previous Cumulus versions on the computer running the 
Client application can be imported (File > Import  > Collections.) To store collec-
tions at any location other than the Cumulus Server, you can use the export func-
tion (File > Export  > Collections.) 
For sending a collection via email to another user, a special export function is 
provided (File > Export  > Mail Collection To.) With Cumulus 6.x this function 
was provided under Collection > Mail To. However, don’t forget: Since a collection 
is always connected to catalog(s), it is necessary for the recipient to have access to 
the catalog(s) ‘serving’ the collection.
To make use of a collection you received, you use the import function. 

Importing from Text/CSV Files 
The Cumulus Importer utility enables the import of metadata from other data-
base systems into Cumulus catalogs. The metadata can be imported from text 
files (separated by delimiters.) You can assign the information to Cumulus fields. 
The data can be imported into record or category fields, into string list fields as 
values, or into the category tree, which enables the Importer to create hierarchi-
cal categories. The configuration for an import process can be saved as an Import 
Configuration Set. 
There are different types of import destinations available with the Cumulus 
Importer:
• Import of Categories into the Category Tree 

You can import data from an import file as categories to a Cumulus catalog. 
You specify the field of the import file which data is to be imported as cate-
gories. And you specify the hierarchy level where they shall be inserted.
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• Import of Metadata into Record Fields
You can import data from an import file into record fields of a Cumulus cata-
log. You define relations between a record field and a field of the import file. 
Furthermore, you can create new records (records that are not related to 
assets) for entries in the import file that do not correspond to already existing 
records in the current catalog.

• Import of Metadata into Category Fields (Enterprise only)
You can import data from an import file into category fields of a Cumulus cat-
alog. You define relations between a category field and the field of the import 
file. The procedure is identical to the procedure necessary when importing 
information into record fields. Furthermore, you can create new categories 
for entries in the import file that do not correspond to already existing cate-
gories in the current catalog.

• Import of Values to String List Fields
You can import data from an import file as values into the properties of a 
string list field. The values can be imported to any category or record field of 
the type String List. It is not necessary that the newly created list entries are 
assigned to records. 

Delimiters 
A lot of database systems use the tabulator as the field delimiter (even Cumulus 
while exporting data from a catalog). If your import text file uses another character 
as field separator, you can choose or enter another delimiter. Also, the delimiter 
for category levels can be set to any character.

Definition of Additional Information
For the import you can define additional information that is imported prior to the 
text that comes from the import file. The additional information may increase the 
readability of information in a field

EXAMPLE: Additional Text
If you import a lot of different data into the same text field, it might be 
helpful to define additional text that is imported prior to the informa-
tion from the import file. For example, if you want to import the price 
of a product into the notes field and your import file contains the fig-
ures only, you can define additional information like Price Euro: that is 
added to the text before importing it into the Cumulus catalog. After 
the import the notes field looks like this: Price Euro: 99

Running an Import Process from a Text File
IMPORTANT! Before you start importing information into a Cumulus catalog using 
the Cumulus Importer utility, you should make a safety copy. Make sure a current 
safety copy of the catalog exists before you go ahead and change the metadata in the 
catalog. There is no UNDO function for the import available. You can only go back to 
the initial version of the catalog if there is safety copy available that you can open 
instead of the changed catalog. 

To set up an Import Configuration Set and run an import process:

1. Open the Cumulus catalog, to which you want to import the information.

2. Select File > Import > From Text/CSV File. This opens a dialog that leads 
you through the steps required.
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3. Choose whether you want to create a new set or load an existing one. 
To select an existing one, open the list with the arrow down button. This lists 
all sets that are available for you.

4. Click Next.

5. If you decided to load an existing set, go on reading with step 7.

If you are creating a new set, a dialog opens to choose the type of import 
destination – where you want to put the data. 

For information on the different types see above.

6. Select the destination and click Next. 

This dialog lets you select the file you want to import from, choose the 
appropriate delimiter and the encoding of the import file.

7. Determine the import file, the delimiter its data contains and its encoding. 
You can see how the text is affected in the Data Preview below. 

• File
Choose the file you want to import the data from. Use the  button to 
browse for the file.

• Delimiter 
A lot of database systems use the tabulator as the field delimiter (even 
Cumulus while exporting data from a catalog). If your import file uses 
another character as separator, you can choose or enter another delimiter. 

• Character Encoding
Select the character encoding of the import file.

• Import Field Indentifier
Lists the field indentifiers from the chosen import file as interpreted using 
the defined delimiter.

• Import Field Value
Displays what the values of a field will look like. Use the arrow buttons to 
page through the data. 

8. If this is how you want to import the data, click Next.

The next steps depend on the selected destination type.

See below for further information. In any case you, have to add entries for 
the fields to be imported. Use the Add button to do so. Use the Remove 
button to remove entries for fields.

If no more configurations are required, a Start button is displayed.

NOTE: Now you can save your Import Configuration set for the data 
import in an import scheme file by clicking the Save as button. This set 
holds information about the field assignments, the name of the import 
file and the appropriate delimiters. 

9. Click Start. The data will be imported.

Import to Category Tree
If you want to import data as categories to the Category Tree of a Cumulus cata-
log, you must specify the import field which holds the data to be imported as cat-
egories and the hierarchy level where you want the categories to be inserted. 
• Delimiter for Category Hierarchy 

What delimiter separates your category levels? By default, Cumulus uses a 
colon as separator for indicating the levels in the category hierarchy. If your 
import file uses a different character, enter the appropriate delimiter. 

• Skip First Line
Often the first line of the import file does not contain information that you 



USE ASSETS – IMPORTING AND EXPORTING 75
want to import. You can disable the import of the data of the first line by acti-
vating the Skip First Line option.

• Import Field Pattern Preview
Displays how the data will be imported.

• Parent Category
Displays the category to which the data from the import field will go as sub-
categories. See below on how to define the parent categories.

• Import Field Pattern 
Lists the fields from which the values should be imported as categories. You 
can insert additional information by clicking in the field’s entry in this column.
If you want to import data from more than one field, use a right/alternate 
mouse click in a field’s entry in this column to get a list for selecting additional 
fields.

To add field entries, click the Add button. This displays a dialog that lets you: 
• Determine a parent category. You can import the categories as subcatego-

ries of a specific category. Determine this category either by entering the cat-
egory hierarchy data for the parent category or by using the currently 
selected category in the category pane. When entering the category hierar-
chy data you must use the displayed delimiter. 

• Select the field that contains the values to be imported as categories
The Import Field Value column displays how the data will be imported. Use the 
arrow buttons to page through the data.
To have your selected field added to the selection of Import Fields, click OK. This 
brings you back to the main dialog. 

Import to Records/Categories
If you want to import data into a record field of the Cumulus catalog, you have 
to define a relation between the import text file and the Cumulus catalog by 
specifying one or more relations. In most cases, it will be the Asset Name to 
determine the record and in addition to that multiple relations that determine 
from which import field the data should be imported to which Cumulus field.) 

NOTE: You can assign fields of the import file to the Cumulus record field Cat-
egories. Then the affected Cumulus records will be assigned to these catego-
ries.

If you want to import information into category fields of the Cumulus catalog, 
you have to define a relation between a category field and the field of the import 
file. The procedure is identical to the procedure necessary when importing infor-
mation into record fields.
• Skip First Line

Often the first line of the import file does not contain information that you 
want to import (e.g., column titles). You can disable the import of the data of 
the first line by activating the Skip First Line option.

• Create new records/categories for lines that do not correspond to existing 
records/categories.
Activating this option initiates the creation of a new record (without a related 
asset) or a new category for each line in the import file that does not corre-
spond to an already existing record/category.

• Import Field Pattern Preview
Displays how the data will be imported.

• Import Field Pattern 
Lists the fields from which the values should be imported. You can insert 
additional information by clicking in the field’s entry in this column.
If you want to import data from more than one field, use a right/alternate 
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mouse click in the field’s entry in this column to get a list for selecting addi-
tional fields.

• Relation
If you want to import data into a record or category field of the Cumulus cat-
alog, you have to specify relations between the field of the import file and the 
Cumulus field. 
Two different relation types can be specified
= (equals) – The Cumulus Importer will only import the data if the value of 
the Cumulus field is equal to the value of the Import Field. This relation type 
is used to perform the search for the appropriate records.
-> (insert) – The Cumulus Importer will import the data of the Import field 
specified in the left hand column to the Cumulus field specified in the right 
hand column. 
NOTE: If you import data without identifying corresponding records by a 
= (equals) relation, the Cumulus Importer utility will create new records 
that are not assigned to any assets. You may do so if, for example, you 
want to import metadata for assets that are not cataloged yet. The corre-
sponding assets may be assigned to the records later. 

• Cumulus Field
Lists the Cumulus Fields into which the data of the import field shall be 
imported. As soon as a new Import Field entry is added, the field’s entry in this 
column is filled with the first field of the list of available Cumulus Fields 
(record or category field – depending on the destination type you have cho-
sen for the Import Configuration set.) Click in the field’s entry in this column 
to select the desired Cumulus Field.

• Fill Mode
Displays how the field will be filled. For String fields, you can define whether 
you want the imported values to replace the existing value or to be added to 
the existing text (before or after.) Click in the field’s entry in this column to 
select the desired mode

Only if you are importing data to the Categories field of records (to assign records 
to categories), you must determine the delimiter that is used to separate the cat-
egory levels. 
To add field entries, click the Add button. This displays a dialog that lets you 
select the field that contains the metadata to be imported.
The Import Field Value column displays how the data will be imported. Use the 
arrow buttons to page through the data.
To have your selected field added to the selection of Import Fields, click OK. This 
brings you back to the main dialog. 

Import to String List Fields
If you want to import data as values of a String List field of the Cumulus catalog, 
you have to specify the assignments between the import fields and the Cumulus 
String List fields.
• Skip First Line

Often the first line of the import file does not contain information that you 
want to import. You can disable the import of the data of the first line by acti-
vating the Skip First Line option.

• Import Field Pattern Preview
Displays how the data will be imported.

• Import Field Pattern 
Lists the fields from which the values should be imported. You can insert 
additional information by clicking in a field’s entry in this column.
If you want to import data from more than one field, use a right/alternate 
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mouse click in a field’s entry in this column to get a list for selecting additional 
fields.

• Cumulus Field
Lists the Cumulus Fields into which the data of the import field shall be 
imported. As soon as a new Import Field entry is added, the field’s entry in this 
column is filled with the first field of the list of available Cumulus Fields. Click 
in the field’s entry in this column to select the desired Cumulus Field.

To add field entries, click the Add button. This displays a dialog that lets you 
select a field that contains the values to be imported.
The Import Field Value column displays how the data will be imported. Use the 
arrow buttons to page through the data.
To have your selected field added to the selection of Import Fields, click OK. This 
brings you back to the main dialog. 

Workflow Enhancements
Cumulus provides several possibilities to enhance your workflow. The next sec-
tion describes how to use color labels and star ratings to quickly organize, sort, 
and filter your files.  

Labeling 
The record field type Label enables users to label records by assigning colors. 
Each Cumulus catalog provides a standard Label field but the user can add more 
fields of this type. For any field of this type the user can define a color range. The 
Label Editor tab of this field type’s properties window lets you determine the 
label colors. Additional colors can be defined by a color picker value. 
Label fields can be displayed in all views. For certain views you can select the col-
ors of a specific label field to be the background of the entire record or of the 
record’s name. 
Of course a label field itself can also be included in a view. To set up views that 
display labeling: Cumulus / Edit >  Preferences  > Record View Sets.
The labeling color for a record can be set in the Information window via list selec-
tion or by a menu item via the Asset menu. 
The menu item Assign Label will be available only if the effects of assigning the 
label can be immediately seen by the user. This means that it is available only if 
at least one label field is included in the catalog AND if at least one label field is 
included in the current view or set as background for records (entire record or 
record name) in the current view.
The menu item will assign the label set as background of the current view. If no 
label is set as background or for views where a label cannot be set as back-
ground, the menu item will assign the label from the first field of type Label from 
the current view. (The order refers to the field list of the view settings in the Pref-
erences dialog.) 
In the Information window, the field will be displayed as a drop-down list. The 
current color is displayed and the available colors are included in the hidden list. 
To select a color, open the list and select the desired label color. To remove a 
label, open the list and select the no value entry.
When printing labeled records, the label marks are printed as displayed (if the 
Label field is included in the fields to be printed.)
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NOTE: Multiple Labeling Systems!
Each catalog can have its individual labeling system. However, be careful 
using multiple labeling systems. If you work with several catalogs in one col-
lection, you might not like to have different colors caused by individual label-
ing systems for the different catalogs. Label fields with the same name 
included in multiple catalogs but with their colors defined differently might 
cause confusion. The records will always show the label colors set for the cat-
alog they derive from. But if you have multiple records selected that come from 
different catalogs with different labeling systems the Assign Label menu item 
is of course disabled. 

You can search for labeled records and save such searches as search queries.

NOTE: Changing Label Color
Each label's value is defined by the label color. So, if you change a label color, 
make sure any saved queries that refer to the label are updated to use the new 
color value.

Rating Assets
The rating system enables you (and your co-workers) to rate assets from 1 to 5. 
Rating values are searchable, so when you want to find your best assets, it's easy 
to do so. Each Cumulus catalog provides a standard Rating field (field name and 
type: Rating) but more fields of this type can be added.  
Ratings are displayed by star icons. A rating field can be displayed in Details View, 
Thumbnail View, Info View and in the Information window. The rating value for a 
record can be set in the Information window via clicking or by a menu item via 
the Metadata menu. The menu item employs the first field of type Rating from 
the current view. (The order refers to the field list of the view settings in the Pref-
erences dialog.)
In the Information window, clicking on a star in the rating row sets the rating 
value immediately to the selected value. Clicking close left of the first star 
removes the value. 
When printing rated records, the rating marks are printed as displayed (if the Rat-
ing field is included in the fields to be printed). 

Managing Related Assets
Cumulus can manage related assets. With Cumulus versions prior to 7 there was 
no user interface to show this and any relations between assets were defined by 
program modules only (AssetStore modules or the AXR feature). Since version 7 
Cumulus offers enhanced management for related assets by providing a user 
interface that displays these relations and also enables the user to determine 
relations between assets. 

Relationships
Relations can be different, there are hierarchical and flat relations. In a hierarchical 
relations one is special, it might be the master or the preferred one, it might be 
the source... The different types of hierarchical relations between assets sup-
ported by Cumulus are:

1. Contain – An asset contains other assets: e.g. a Zip archive, a PowerPoint pre-
sentation that contains slides, a Quark XPress or PDF document that con-
tains pages.
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2. References – An asset includes references to other assets: e.g. a PowerPoint 
presentation or a Quark XPress document that includes references to the 
images on the slides/pages.

3. Variants – Assets derive from the same source asset: e.g. the PDF of a Word 
document, an image stored in different file formats or renditions of an image 
(for example cropped or with a filter employed.)

4. Alternates – assets that you want to group concerning a certain topic and 
for which you have a preferred one that you want to represent the others. 
(For example, you have a series of images on the same topic and the pre-
ferred one is the one you decided to use for your current project.)

In addition to hierarchical relations you might want to determine groups of 
’equal’ assets. Assets that you want to group concerning a certain topic, theme 
or task but to which you don’t want to designate a preferred member. Cumulus 
offers support for this demand: assign the assets to the same category. However, 
this well-known way of defining groups is included in the Cumulus management 
for related assets (referred to as relation type 5). 

How does Cumulus Know about Relations between Assets?

1. Contain – The Cumulus Asset Storage modules detect if an asset contains 
other assets when the asset is cataloged.

2. References – The Cumulus AXR (Asset Cross References) function detects if 
an asset includes references to other assets when the asset is cataloged.

3. Variants – The user can determine that an asset derives from a source asset 
or Cumulus can ascertain that automatically if the deriving asset was created 
using a Cumulus function.(For a description on how to determine such a 
relation, see “Assigning Variants,” p. 83.)

4. Alternates – The user can create groups of alternate assets. An asset is deter-
mined as an alternate by assigning it to the ’preferred alternate’. (For a 
description on how to determine such a relation, see “Assigning Alternates,” 
p. 82.)

The information on an asset’s relations is stored in the asset’s record.

Different Relations between Assets
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SPECIAL TECH INFORMATION:  
The information on an asset’s relations is stored in the record fields 
Related Master Assets and Related Sub Assets. The field Related Sub 
Assets stores the information which assets are contained, referenced, 
deriving, or alternates. Whereas the field Related Master Assets stores 
the information in which other assets the asset is contained in, refer-
enced by, derives from, or which asset is its preferred alternate.

There can be several relations between assets.

How does Cumulus Display Relations between Assets?
In a split view: an additional pane can be opened up below the Record pane. The 
additional pane displays the records that are related to the record selected in the 
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to find out about the different relations between the 
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 are contained. 
es reference images.

One slide is also source of a variant.

Most images are referenced.
Some images are sources of variants.
A lot of images are variants.
One image is a variant and also the source of another variant.
And that’s why there is one image that has a variant source as 
well as a top level variant source.

Last but not least:
One image is a preferred alternate in a group of four alter-
nates.
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main Record pane. How the assets of the additional pane are related to the 
selected record is determined by the display option that is set for the additional 
pane. 
So, having related assets displayed is as easy as: select a record, open up a sub-
pane and select what you want to see in it. 
You can select multiple assets in the upper pane and you can open up multiple 
sub-panes. Each sub-pane will display those assets that are related to the selec-
tion in its upper pane. How they are related is determined by the selected display 
option.If the selection in the upper pane changes, the content of the sub-pane 
is synchronized. It changes simultaneously.
To open up a new sub-pane: Click the  button of the current sub-pane. To 
close a sub-pane: Click the  button of the pane. To refresh the display of a 
sub-pane: Click the  button of the pane. 

TIP: Resizing Panes
You can resize the panes by pressing the ALT / Option key and 
dragging the split bar. (Just clicking the split bar will resize the main 
pane and the sub-pane of the dragged split bar only.) 
Collapsing: Pressing the ALT / Option key and double-clicking in 
a pane’s statusbar will collapse the pane so that the statusbar only is 
displayed and the pane above will fill the area. (Just double-clicking 
lets the pane above remain its size and the main pane will be 
enlarged.) A double-click on the statusbar of the main pane (topmost 
pane) will collapse all panes below.
Expanding: Pressing the ALT / Option key and double-clicking in 
a collapsed pane’s statusbar will expand the pane again – using space 
from the above pane. (If you just click it – without the ALT / 

Option key – the pane will be expanded using space from the main 
window.) A double-click on the statusbar of the collapsed main pane 
will expand all panes below.
Minimizing: Double-clicking a pane’s split bar minimizes the pane or 
resizes it again.

For each pane you can choose the view, the sorting direction and an option for 
the content to be displayed. How the displayed assets are related to the asset 
selected in the upper pane is chosen from a menu that offers the following 
options by default:
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The list options can be renamed, configured and assigned to specific users. The 
list options are configured via Sub-Pane Filter definitions. So you can customize 
it in wording and include search strategies for individual tasks. Sub-Pane Filters 
are created and edited in the Preference dialog window ( Cumulus / Edit > 
Preferences  > Sub-Pane Filters.) For details on how to set up a Sub-Pane Filter, 
see “Sub-Pane Filters,” p. 139. The availability of Sub-Pane Filters for users is 
defined with the User Manager in the each user’s properties.
You can get information on the different relations of an asset in the Info view or 
Asset Info window. If the fields Related Sub Assets and Related Master Assets 
are added to the corresponding view settings (and given more than 1 line), for 
each type of relation a tab is provided that displays the names of the related 
assets.

What else do you need to know? 
In the split view, Cumulus can only display related assets that are cataloged to 
the same catalog as the one selected. That’s why it is recommended that you use 
a simple collection and not a multi-catalog collection when your work includes 
the relation aspect.

Assigning Alternates
You can manually group alternates of assets. When you group them as alternates 
you have to determine one as the preferred alternate. 
Select the records of the assets you want to become alternates and select Meta-
data > Assign Alternates. Then a message prompts you to select the preferred 
alternate. From the selected records select the one you want to be the preferred 
alternate and click OK.
To delete such relations you must delete the corresponding entries in the 
Related Sub Assets and Related Master Assets fields from the Alternates tab in 
the Information window or view.
To get the alternates of an asset listed, use the split view and an according list 
option (Sub-Pane Filter). For more information, see “How does Cumulus Display 
Relations between Assets?,” p. 80.

RELA-
TION 
TYPE

Display options are: 

0 Selected Asset

1  Contained Pages/Slides
Contained Assets
Container Asset

2 All Referenced Assets
Referencing Documents
Referencing Pages/Slides

3 All Variants
Variant Source 
Top Level Variant Source 

4 – All Alternates
– Preferred Alternates

5 – Assets Assigned to the Same Categories
– Assets Assigned to at least One Same Category
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Assigning Variants
You can manually assign variants to an asset. The asset you assign them to is 
called the source of the variant. 
Select the records of the assets you want to assign as variants to a source asset 
and select Metadata > Assign Variants. Then a message prompts you to select 
the source. Select the record you want to be the one assigned as the source of 
the variants and click OK.
To delete such relations you must delete the corresponding entries in the Related 
Sub Assets and Related Master Assets fields from the Variants tab in the Infor-
mation window or view.
To get the variants of an asset listed, use the split view and an according list 
option (Sub-Pane Filter). For more information, see “How does Cumulus Display 
Relations between Assets?,” p. 80.

Working Smart
Following a few simple guidelines will ensure your workflow is as efficient as pos-
sible. 

Develop an Effective File Naming Convention
Even though Cumulus makes it easy to keep track of assets with its thumbnail 
previews and wealth of search options, there is no substitute for a well planned 
filing system. There will be times when you must access files without the conve-
nience of the Cumulus interface. For example, when writing scripts to enable 
Cumulus to automate the workflow, a consistent and predictable filing system 
can not only save many hours of script debugging, but it can also enable func-
tionality that might not otherwise be possible.
How you name your files will depend on how you use them. A news agency may 
decide to name incoming news stories prefixed with the current date and affixed 
with the file type:

2003-06-01-ElectionResults.txt
2003-06-01-ElectionResults.tif

Using the date in this order lists the files chronologically when sorted alphabeti-
cally. It also makes it easier for Cumulus scripts to select files based on a date 
range.
A Web design group may chose to include an image’s file size in its name to 
make entering HTML size tags more convenient:

MainPageBanner200x50.gif
Or, to use this manual as an example, file names for screen shots of menus and 
dialogs each begin with either “M_” or “W_” to identify the platform from which 
the images come. For example, the file name for the Mac OS X File menu is:

M_FileMenu.tif
It’s Windows counterpart is called:

W_FileMenu.tif
Using the two file name prefixes not only helps differentiate the files at a glance, 
but also helps to make the filing system more predictable. From this one exam-
ple, you can probably guess the file names of most images in this document. 
Consistency and predictability are key to developing a naming convention that 
will serve you well.
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Develop an Effective Folder Naming Convention
Apply an equally clear naming convention to your folder (directory) structures. 
Cumulus can use your folder hierarchy to create categories when cataloging 
assets. This is a real time saver if your folder structure helps to identify your assets. 
Some users may choose to store assets in folders based on file type rather than 
project name. A sound clip of audience applause, for example, may be used in 
many projects, but it will always be a sound clip. You can use Cumulus’ catego-
ries to associate assets with one or more projects.

Cross-Platform Catalog Use
Though the catalogs that Cumulus creates are completely cross-platform com-
patible, it is up to you to use a catalog file naming convention compatible with 
each platform on which you plan to use your catalogs.
Keep in mind that catalog names and catalog file names are two different things. 
For cross-platform purposes, you need only be concerned with catalog file 
names. (See “Renaming Catalogs,” p. 164, for catalog naming information.)
Consult your operating system’s documentation for details on the range of char-
acters that can be used. In the meantime, here is one important tip: 
• Windows uses a backslash (\) to differentiate folder hierarchies. Mac OS X 

users should avoid using this character in their catalog names. (The Mac OS 
X uses a colon (:) to differentiate folder hierarchies, but this character is not 
allowed in file names on either platform, so it is of no real concern.)

Characters that are safe for use on all Cumulus platforms include all upper and 
lowercase letters, all numbers, the hyphen (-), and the underscore ( _ ).



Specialized Usage
This chapter covers Cumulus functions that help you with special

tasks. It includes descriptions on how to work the URL AssetStore and

how Cumulus supports you working with images by providing a spe-

cial IPTC Information window and maintaining raw image formats of

digital cameras.
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Using URL AssetStore
This chapter covers the basics of working with Cumulus URL AssetStore Module. 
It describes how to catalog assets from FTP or HTTP servers and how to work with 
them in Cumulus. Although the records of URL-cataloged assets behave just like 
any record which has been cataloged through the supported file systems – 
working with the assets themselves from within Cumulus is slightly different. 
This chapter also describes how to copy or move cataloged assets to FTP servers 
and how to set up the Central Asset Location for a catalog on an FTP server.

Cataloging Assets from FTP or HTTP Servers
If you want to catalog from FTP or HTTP servers or to work with URL-cataloged 
assets, you must use an Asset Handling Set that has the Asset Storage Module 
supporting URL activated. If you want an Asset Handling Set to neither work with 
URL-cataloged assets nor to catalog from FTP or HTTP servers, you may want to 
deactivate the URL AssetStore Module. For details on how to activate or deacti-
vate an Asset Storage module for an Asset Handling Set, see “(De)activating Asset 
Handling Modules,” p. 118.
There are two ways to catalog assets from FTP or HTTP servers: via menu item and 
with drag and drop. Let’s start with the menu item method. And remember: You 
need a fully licensed version of the URL AssetStore Module to catalog from FTP 
or HTTP servers.

NOTE: TAG Files!
Cumulus can create TAG files on an FTP server while cataloging, if the Asset 
Storage module Cumulus Metadata Support is activated for the employed 
Asset Handling Set and the user, who catalogs, is allowed to save files on this 
FTP server. 

Cataloging Assets via Menu Command
You can catalog employing any valid URL pointing to a file and starting with ftp:/
/ or http://. But you may not use localhost as IP address. You may even catalog a 
folder but only if it is on an FTP server.

NOTE: User Authentication
Some FTP or HTTP servers require user authentication. In this case, the host 
address must be prefixed with a user name and password like “user:pass-
word@host”. For example, the complete URL then looks like “ftp://
smith:secret@server.com/path/file”. 

To catalog assets from FTP or HTTP servers via menu command:

1. Open the catalog to which you want to add the assets.

2. Select File > Add Assets To Catalog . 

If you are prompted to select an Asset Handling Set for this cataloging pro-
cess, make sure, you select an Asset Handling Set that has the URL Asset-
Store activated.

If multiple Asset Storage Modules are activated in the employed Asset Han-
dling Set a dialog appears. This lists the available Asset Storage Modules. 
One is the URL AssetStore, and others include the file system you are cur-
rently using (such as the Windows or Mac OS File System, among others).

3. Select the URL AssetStore and click OK. 

A window appears which asks for an URL.

4. Enter the URL for the asset file (or folder – on FTP only) you want to catalog.
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A window appears that shows the status of the cataloging process. 
After a moment, a thumbnail for the asset appears, indicating that the cata-
loging process was successful and a record has been created for the asset.

NOTE: If you catalog many or huge files, you can save time by deactivating 
the display of the cataloging progress. Before you start cataloging, disable the 
Show Progress Bar (General section of an Asset Handling Set definition, 
under While Cataloging). 

Cataloging Assets via Drag and Drop
To catalog assets from FTP or HTTP servers via drag and drop:

1. Open the catalog to which you want to add the assets.

2. Launch your Web browser application.

3. Navigate to the asset, FTP folder or Web page which you want to catalog.

4. Select the link for the asset or FTP folder and drag it into the Cumulus Collec-
tion window. 

The progress information window appears and records are created for each 
of the assets.
If you are prompted to select an Asset Handling Set for this cataloging pro-
cess, make sure you select an Asset Handling Set that has the URL AssetStore 
activated.

Working with URL-cataloged Assets
Certain functions in Cumulus work slightly different for assets stored on FTP or 
HTTP servers. The following sections describe only these slightly different func-
tions. All of these functions are options of the Asset menu. If you open, print or 
mail an URL-cataloged asset, Cumulus first makes a copy of the asset. 
To work with assets stored on FTP or HTTP servers you need to employ an Asset 
Handling Set with URL Support activated.

NOTE: If assets were cataloged from FTP or HTTP servers requiring a user 
authentication, the Cumulus application knows about this protection. When 
you access such an asset, Cumulus will ask you to enter user name and pass-
word. During the same session Cumulus remembers the entered name and 
password and will not ask you again if you access an asset from this FTP or 
HTTP server. 

Opening Assets 
You can open an asset stored on an FTP or HTTP server with either the applica-
tion that created the asset, or another application of your choice. Applications 
you choose are added to the menu. You can add up to four. The fifth addition 
replaces the first, and so on. You cannot manually delete any of the added appli-
cations. 
To open an URL-cataloged asset from another application:

1. Select the record whose asset you would like to open.

2. Select Asset > Edit With and select the desired application from the sub-
menu.
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A dialog appears from which you can select a location for the copy of the 
asset.

3. Choose the desired location and click OK.

Cumulus copies the asset to the specified location and opens it with the 
chosen application.

Printing Assets 
You can print an asset stored on an FTP or HTTP server with either the application 
that created the asset, or another application of your choice. Applications you 
choose are added to the menu. You can add up to four. The fifth addition 
replaces the first, and so on. You cannot manually delete any of the added appli-
cations. 
To print an URL-cataloged asset from another application:

1. Select the record whose asset you would like to print.

2. Select Asset > Print With and select the desired application from the sub-
menu.

A dialog appears from which you can select a location for the copy of the 
asset.

3. Choose the desired location and click OK.

Cumulus copies the asset to the specified location and prints it with the 
chosen application.

Mailing Assets 
As with other assets you can also attach an asset stored on an FTP or HTTP server 
to an outgoing e-mail message. 
To mail an URL-cataloged asset:

1. Select the record whose asset you would like to send as an e-mail attach-
ment.

2. Select Asset > Mail To.

A dialog appears from which you can select a location for the copy of the 
asset.

3. Choose the desired location and click OK.

Cumulus copies the asset to the specified location and asks you to select 
an e-mail application / launches your default e-mail application and 
attaches the selected asset(s) to an outgoing message.

Storing Assets on FTP Servers
The URL AssetStore Module also enables you to upload cataloged assets to FTP 
servers by using the Cumulus menu commands. It also allows you to employ FTP 
servers as the Central Asset Locations for catalogs.
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Moving an Asset to an FTP Location
To move an asset to an FTP location:

1. Select the record whose asset you would like to move.

2. Select Asset > Move To.

The Select Asset Storage Module dialog opens which lists all available Asset 
Storage Modules. 

3. Select the URL AssetStore and click OK. A window for entering an URL 
opens.

4. Enter a valid FTP-URL and click OK.

Cumulus moves the asset to the selected location and updates the refer-
ence of the selected record. 

Copying an Asset to an FTP Location
To copy an asset to an FTP location:

1. Select the record whose asset you would like to copy.

2. Select Asset > Copy To.

The Select Asset Storage Module dialog opens which lists all available Asset 
Storage Modules. 

3. Select the URL AssetStore and click OK. A window for entering a URL opens.

4. Enter a valid FTP-URL and click OK.

Cumulus copies the asset to the selected location. 

Central Asset Location on FTP Server
Each individual catalog can be configured, so that Cumulus saves a copy of each 
cataloged asset to a specific location (called a ’Central Asset Location’). This 
option allows for the quickest possible way to locate and track a catalog’s assets. 
The URL AssetStore Module enables you to employ an FTP server as a Central 
Asset Location for a catalog.
To set a URL as Central Asset Location:

1. Make sure the collection window containing the catalog is the active win-
dow in Cumulus.

2. Select Cumulus / Edit > Preferences. 

3. Click Catalog Settings.

The Catalog Settings window is displayed. If the active collection window 
contains more than one catalog, select the catalog you want to edit under 
Catalogs.

4. Click General. This tab includes the options on central asset location. 

Three situations are possible. The following describes the actions necessary 
for each situation.

• When the Central Asset Location Option is active and only its settings need 
to be changed, you can continue with step 5 below. 

• When a Central Asset Location is defined but not active, enable the desired 
option and continue with step 5 below. 
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• When configuring a Central Asset Location for the first time, enable the 
desired option. The Select Asset Storage Module dialog opens and you can 
skip step 5. 

5. Click Browse to choose the location.

The Select Asset Storage Module dialog opens which lists all available Asset 
Storage Modules. 

6. Select the URL AssetStore and click OK. A window for entering an URL 
opens.

7. Enter a valid URL of an existing FTP directory and click OK.

8. Click Apply to save your changes.

Working with Images
Cumulus provides special functions for users who work with images: 
• The Cumulus Image Editor makes self-service image processing easy for any-

one.
• The IPTC Information window lets you easily view and edit metadata. 
• The Digital Camera Raw Filter enables Cumulus to capture information when 

cataloging raw image formats and to preview raw image formats. 
These special functions are described in the following sections. For a description 
on how to convert cataloged images, see “Converting Image Assets,” p. 58.

Editing Images
The Cumulus Image Editor makes self-service image processing easy for anyone. 
Get the quick edits you need of your cataloged images. Cumulus offers image 
cropping as well as calibration tools that can enhance the color, sharpness and 
brightness of your images.

Image Editor
The features of the Image Editor apply to any asset that can be previewed in 
Cumulus. Start the Image Editor by selecting Asset > Image Editor.
Use the slider of the Navigator to zoom in and out the selected image. Clicking 
on the icons at the edges of the slider also zooms in and out. Double-clicking the 
navigation image optimizes the display size of the image for the window size of 
the Image Editor. The statusbar at the bottom of the window displays the zoom 
factor, the size of the image, its color space and color mode.
The various tools for image editing are offered on the toolbar. Click the icons to 
activate a tool and see its options.
#14369, #13380 - Imho reicht diese “Sparversion” der Beschreibung hier erst 
mal aus. Später kann das immer noch in aller Ausführlichkeit & voller Schön-
heit beschrieben werden.
FTo save the image modifications performed with any of the tools described in 
the following sections, click the Save icon (  ) in the Image Editor toolbar. 
Then you may define the file format and color space (and compression rate or 
image quality, if applicable for the chosen file format) for the edited image. The 
following options for saving a file are offered:
• Save as new asset – creates a new asset and, if desired, assigns it as variant 

to the original asset
• Overwrite asset – replaces the original asset with the modified file
• Export to file system – saves the modified file to any place on your file system
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IMPORTANT! Embedded digital photo metadata (IPTC, XMP or EXIF) that may have 
existed in the original file, will not be saved with the edited image. 

The following sections describe how each of the Image Editor tools work. 

Cropping
The Crop tool is used to reduce the visible area of an image. 
To begin cropping, click the image and draw a box around the desired area. 
Before accepting the crop, you can adjust the edges of the selection to fall 
exactly on the desired location. Simply place the cursor over one of the four side 
handles and drag to the desired location. While adjusting the cropped area, you 
can review the coordinates of the crop in the fields on the right.
You can also enter the desired size of the area to be cropped. This is useful for 
cropping an image for specific print or screen sizes, such as 4x6 or 640x480. If you 
enter a size, a box according to the dimensions is displayed and can be dragged 
over the image. To add sizes click the  button.
You can adjust the unit of dimension by selecting pixels, inches or centimeters in 
the Unit pull-down menu.
Select the resolution for the cropped area from the Resolution pull-down menu.
Click Crop to accept the crop.
Click Cancel to exit the Crop tool.

Rotating
The Rotate tool is used to adjust the angle of an image. You can rotate by 90 
degrees clockwise and counter clockwise, and by 180 degrees. You can flip the 
image horizontally (along the vertical axis) and vertically (along the horizontal 
axis.)

TIP: 
If you want to rotate JPEG images, you might prefer to use the Trans-
form JPEG Original command in the Asset menu.

Click the button for the desired rotation.

Adjusting Brightness and Contrast, Gamma and Colors
This tool offers to adjust the tonal range of your images through brightness and 
contrast, the gamma value and colors.
Select the desired adjustment from the pull down menu. Depending on the 
selected adjustment., you are offered different options.
To see the result of your modifications in real time, activate the Live Preview 
option.
Click Apply to accept the adjustments.
Click Cancel to exit the tool.

Brightness and Contrast
It can help to correct blurry images and bring out fine details in tone. Dragging 
the sliders to the left decreases the levels of brightness and contrast; dragging 
them to the right increases the levels.
When Preserve Color option is activated, you can change brightness and con-
trast without losing color. (Only the brightness information of the image is 
affected by the modification, the color shades are left unchanged.) 
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Gamma 
The gamma value of an image affects the way how its colors are perceived.
Dragging the slider to the left decreases gamma value; dragging it to the right 
increases the value.

Color
The options offered depend on the color space of the asset. 
Dragging the sliders to the left decreases the levels; dragging them to the right 
increases the levels.

Resizing
The Resize tool is used to change the size of an image. To resize an image, define 
the new width and height in the corresponding fields. To maintain the current 
proportions of width to height, activate the Keep Proportions option.
The original resolution of images is not affected by resizing with Cumulus.
Click Apply to accept the resizing.
Click Cancel to exit the tool.

Applying Filters
Select a filter type from the pull down menu. Depending on the filter type you 
can define the strength and the radius range for the filter (1-100.) The radius 
determines how far the filter considers surrounding pixels that affect the filter 
action. Select the radius according to the image resolution.
The following filters are available:
• Average Blur Filter 

Softens an image. It smoothes transitions by averaging the color values of 
surrounding pixels. Eliminates noise where significant color transitions occur 
in an image. 

• Median Filter
Reduces noise in an image by blending the brightness of pixels. The filter 
adapts the brightness of pixels to the median brightness value of the sur-
rounding pixels. 

• Gauss Filter
Works similarly to the Average Blur filter but uses a weighted average of the 
color values of the surrounding pixels. The weighting is determined using the 
Gaussian bell-shaped curve that is generated. 

TIP: 
The Average Blur as well as the Gaussian filter decrease high-fre-
quency details and can produce a hazy effect.

• Sharp Filter
Increases the visual sharpness of images by increasing the contrast at edges. 

TIP: 
Applying the Sharp filter is recommended when scaling up images to 
keep their visual sharpness as high as possible. 

• Unsharp Mask Filter
Makes images appear sharper by increasing the contrast of small brightness 
changes.

• Add Noise Filter
Applies random pixels to an image, simulating distortion or noise. You can 
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also use the Add Noise filter to give a more realistic look to heavily retouched 
areas. 

To see the result of your modifications, you can activate the Live Preview option. 
To avoid time consuming live preview recalculations, you should activate this 
option after you changed the filter parameter values. 
Click Apply to have the filter applied.
Click Cancel to exit the tool.

Using the IPTC Information Window
This section covers the basics of working with IPTC metadata and the IPTC Infor-
mation window.

Preparation Steps
In order to make use of Cumulus IPTC data management capabilities, some prep-
arations have to be made. The Cumulus catalogs in which you want to store IPTC 
data from assets have to be prepared. If you want to capture IPTC data from 
assets and to write back IPTC data to assets, the Asset Handling Set(s) and the cat-
alog(s) managing these assets must be prepared for this feature. IPTC record 
fields have to be added to the catalog(s) and their properties have to be enabled 
for field linking. The Writing back Metadata  option must be activated in the Asset 
Handling Sets used to handle the assets containing IPTC data. 
Cumulus provides a script to help make the process of preparation easy: Prepare 
Catalog For IPTC (found in the Administration submenu of the File menu; see 
“Prepare Catalog,” p. 176 for details). As image files often contain IPTC and XMP 
metadata, we recommend preparing the catalog for XMP as well. In order to 
know what you should be aware of when working with IPTC and XMP metadata, 
see the note that follows the description on how to prepare catalogs for meta-
data in your Cumulus edition’s user guide.

IPTC Information Window
This Information window is specially designed for displaying and editing the IPTC 
data of assets. Cumulus can read IPTC metadata information while cataloging. 
You can view and edit this metadata and Cumulus can write your changes back 
to the asset. Cumulus' management of IPTC information conforms with the IPTC 
standard. Being considered the industry standard, its specifications are available 
to the public. Adobe Photoshop also partially uses this standard, meaning that 
text in images captioned in Photoshop’s File Info will be displayed in the IPTC 
Information window. Photoshop only uses some of the available fields the IPTC 
standard comprises. Note that even if the other fields are not displayed in Photo-
shop, they are interchangeable between Cumulus and Photoshop.

NOTE: IPTC Data back to Assets
If you want to write back IPTC data to assets, your Cataloging Options (entry 
for the IPTC filter activated) and the catalog managing these assets must be 
prepared for this feature. IPTC record fields have to be added and their proper-
ties have to be enabled for field linking. Furthermore, writing back metadata 
must be enabled in the the Writing back Metadata  section of the Asset Han-
dling Set employed for asset access ( (Preferences > Asset Handling Sets > 
Asset Access).  Cumulus provides a utility to help make the preparation pro-
cess easy: Prepare Catalog For IPTC (found in the Administration submenu 
of the File menu; see “Prepare Catalog,” p. 176 for details). The IPTC data will be 
written back to the asset when any record information is changed.
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Over
The IPT nding 
on the 

To ope
To open the IPTC Information window:

1. Click once on a record to select it.

2. Select Metadata > IPTC Information. The IPTC Information window for the 
selected asset’s record opens.

If you selected more than one record before selecting IPTC Information, the 
IPTC Information window will be opened for the selected records and will 
display only values that the selected records have in common. To see or edit 
the IPTC data of one record only, use the arrow buttons.

Once the IPTC Information window is open, you can use the arrow buttons to 
load other records of the current collection into the window. 
Information can be added by entering text into the field or selecting from lists – so 
called 'quicklists'. Some fields provide prepared lists for immediate use. For some 
fields these quicklists are preset and contain values laid down by the IPTC norm. 
Due to IPTC standards, the preset quicklists for some of the fields can't be edited. 
The quicklists for all other fields can be edited.
To open or edit a quicklist for a field, make a right /alternate mouse click in the 
field. This opens a drop-down list for selecting a value. The fields for which you 
can edit the corresponding quicklist provide an entry Edit Quicklist. If you select 
this entry, a dialog for editing the quicklist opens. See “Editing Quicklists,” below, 
for details.
See the following overview of the options available from the IPTC Information 
window. .

view: The IPTC Information Window
C Information window provides access to the IPTC data stored on an asset. The field contents are editable depe
field type and the properties set for it. 

n the IPTC Information window: Select a record first and then select Metadata > IPTC Information 



SPECIALIZED USAGE –  WORKING WITH IMAGES 95

pends 
rd field 

y and 

ns a 
 field. 
aced 
entries 

lay of 

 entry 
pens. 

t is not 
 this 

n.

 Quick-

 Quick-

ta.

llow 
rs and 

u to 

nter a 
 by typ-
. You 

racter 
s. 
 Due to 
 per-

ming a 
u enter 

st. You 
o edit 

escrip-
ition).

Over

1

5 6
1 Name of the field (as defined in the IPTC Standard).
2 Content of the field for the selected record.

If the field background is dark gray it cannot be edited (editable or not de
on the field type and whether Allow User to Edit is checked in the reco
properties).

3 If a field is not included in the catalog, the field’s background is dark gra
displays “Field missing”.

4 An alternate mouse click (Windows: right click; Mac OS: CTRL-click) ope
quicklist for selecting a value. Clicking the desired value copies it to the
When selecting from a quicklist, all previous text in the field will be repl
(except in the Keywords and Supplemental categories fields where new 
will be added to the existing entries). 
NOTE: If a quicklist contains more than ten values for one field, the disp
the value is split into submenus.
The fields for which you can edit the corresponding quicklist provide an
Edit Quicklist. If you select this entry, a dialog for editing the quicklist o
(See “Editing Quicklists,” p. 96 for details.) If a field contains a value tha
included in the quicklist yet, an entry Add to Quicklist is provided. Use
entry to add the current entry of the field to the quicklist.

5 Saves the changes.
6 Loads the first record from the collection window’s current selection.
7 Loads the previous record from the collection window’s current selectio
8 Loads the next record from the collection window’s current selection.
9 Loads the last record from the collection window’s current selection.
10 Opens a dialog for importing a quicklist. (See “Exporting and Importing

lists,” p. 96 for details.)
11 Opens a dialog for exporting a quicklist. (See “Exporting and Importing

lists,” p. 96 for details.)
12 Lets you choose a Metadata Template to apply pre-configured metada
13 Saves the changes and closes the windows.
14 Closes the IPTC Information window without saving changes.
15 Saves the changes without closing the window.

The letters mark a few examples of the various field types.
A  Most of the fields in the IPTC Information window are text fields. They a

you to enter text of one or more words. You can enter characters, numbe
special characters. The Caption and Special Instructions fields allow yo
enter several lines of text.

B  Keywords and Supplemental Categories: These fields allow you to e
number of entries consisting of one or more words. You enter a keyword
ing the word and then pressing the Enter key or clicking the Add button
can then start typing the next entry immediately. 

C IPTC Category and Country Code: These fields can only contain a 3-cha
abbreviation. The corresponding quicklist only lets you add 3 character

D These Date fields only allow values that are laid down by the IPTC norm.
this, you can only choose one of the standardized values for them after
forming a right mouse click /alternate mouse click. 

E These Time fields can either be filled from the menu opened after perfor
right mouse click /alternate mouse click or by entering a time value. If yo
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F Urgency and Object Cycle: These are record fields of the type String Li
can select a value from the list opened after clicking the arrow button. T
the provided values, you have to edit the record field properties (for a d
tion on how to do this, see the Administrator Guide of your Cumulus Ed
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Editing Quicklists
The list displays the current values for the corresponding field. You can edit or 
delete these values or add new values to the list.
To add a new value: 
Enter the new value in the field above the list and press the Enter key or click the 
Add button. You can then start typing the next entry immediately.
To edit a value: 
Select the value. The value will be displayed in the field above the list. Edit the 
value in this field and then click Replace. The value in the field will replace the 
selected value in the list.
To delete a value: 
Select the value in the list and click Delete.

Exporting and Importing Quicklists
Once you have adapted a quicklist to suit your needs, you may want to save it for 
special purposes or provide other users with. That’s why Cumulus offers you the 
option of exporting and importing quicklists. When exporting a quicklist, it is saved 
into a document of the type QLS File (file extension: qls). To make use of such an 
exported quicklist with the IPTC window, you have to import this list by opening 
the document it is saved to.
To export a quicklist (saving it to a document): 

1. Select the  button in the IPTC Information window. 

The standard dialog for selecting a location and saving a file opens.

2. Enter a name, select a location and click Save. 

Now the list is saved and can be imported.
To import a quicklist:

1. Select the  button in the IPTC Information window. 

2. The standard dialog for choosing a file opens. 

3. Select the desired list and click Open. 

Your quicklist will then be available in the IPTC Information window. 

Working with Raw Images
Cumulus supports raw image formats of a wide array of digital cameras. You can 
find and organize raw image formats efficiently. Cumulus can extract metadata 
of raw image formats and store it in Cumulus catalogs. Additionally, EXIF infor-
mation (camera settings, date, aperture and shutter speed etc.), and depending 
on the camera model, annotations and GPS are also captured when cataloging. 
Even Canon thumbnail files (THM) are supported. Converting assets stored in raw 
image format to JPEG and TIFF images on-the-fly is a breeze with Cumulus. 
The Digital Camera Raw Filter enables Cumulus to capture information when cat-
aloging raw image formats and to preview raw image formats. The captured 
information will be stored in Cumulus record fields. 
The Digital Camera Raw Filter can capture metadata from the different raw 
image formats defined by leading camera manufacturers, namely, Canon, Fuji, 
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Kodak, Minolta, Nikon, Olympus, Sigma, Sinar and Sony. Check Canto’s website 
for a detailed list of which cameras are supported.
Most cameras supporting Canon CRW files create additional thumbnail files 
(THM files). The Canon Raw Metadata Support enables Cumulus to capture meta-
data from these files and to manage these files. For more information, see “Canon 
DC Raw Image & Thumbnail File,” p. 98

Cataloging Raw Image Formats
When cataloging raw image formats, your catalogs and Asset Handling Sets have 
to be prepared for this. The catalogs in which you want to manage your raw 
images must provide the corresponding record fields to store the special raw 
image information and the Asset Handling Sets you want to employ must have 
the Digital Camera Raw Filter activated. Its format entries must be in a certain 
sequence to achieve best results. 

Captured Information
When cataloging, the Digital Camera Raw Filter can capture the following infor-
mation from your raw images:

Of course the filter can only capture the information contained in the cataloged 
images. The captured information will be stored in Cumulus record fields. The 
corresponding record fields have to be included in the catalog to which you 
want to add the raw images.
Some of the fields above may not be active in the catalog to which you want to 
add the raw images. To include them in a catalog, you have to add the corre-
sponding fields to the Record Fields in the Catalog Settings dialog before cata-
loging your documents or updating your records. (For details on how to add 
record field to a catalog, .)  

Format Entry Order
The Digital Camera Raw Filter is the only Cumulus filter that can read raw images. 
However, the entry numbers of the formats supported by this filter are important. 
When cataloging, Cumulus starts searching for matching formats at the lowest 
entry number. It employs the formats according to their entry numbers (lowest 
entry number first). If you want the Digital Camera Raw Filter to be employed for 
assets, check the order of the format entries in the Asset Handling Set you use for 
cataloging.
In order to ensure the Digital Camera Raw Filter works ideally for cataloging 
assets, you have to move the entries for the formats supported by it up in the list, 
so that they are at least before the first format supported by the TIFF Filter. The 
Sinar DC Raw Image Format should have a lower entry number than the first for-
mat supported by the Photoshop Filter.
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Defining Filter Properties
The Digital Camera Raw Filter allows you to define properties for the different for-
mats supported by this filter.
• Canon DC Raw Image (extension: crw, Mac File Type: CCDR)
• Fuji DC Raw Image (extension: raf, Mac File Type: RAF *)
• Kodak DC Raw Image (extension: dcr, Mac File Type: KDCR)
• Minolta DC Raw Image (extension: mrw, Mac File Type: MRW *)
• Nikon DC Raw Image (extension: nef, Mac File Type: NEF *)
• Olympus DC Raw Image (extension: orf, Mac File Type: ORF *)
• Sigma DC Raw Image (extension: x3f, Mac File Type: FOVb)
• Sinar DC Raw Image (extension: sti, Mac File Type: TIFF)
• Sony DC Raw Image (extension: srf, Mac File Type: SRF *)

* Mac File Types with 3 characters only end with a space
These properties are important for cataloging and previewing. For cataloging 
they are important only if you have activated the option Entire Asset under Cre-
ate Thumbnail from on the Thumbnail tab of the Asset Handling Set employed 
for cataloging. Then the values set for the color settings and the color interpola-
tion are used for creating the thumbnail.
For the previewing of each of the formats, you can define the source for a pre-
view (thumbnail or entire image). If the source for the thumbnail to be created 
or the preview to be shown is the entire asset, the color settings and the color 
interpolation can be set.
For details on how to define these properties, see the Cumulus Filters Guide.

Canon DC Raw Image & Thumbnail File
Most cameras supporting Canon CRW files create additional thumbnail files. 
Along with a 160 x 120 JPEG thumbnail of the original image in the associated 
CRW file, these files contain the EXIF information and optionally IPTC information. 
They always have the same name as the original CRW file, but with a THM file 
extension.
Cumulus supports these THM files. If the Canon Raw Metadata Support is acti-
vated in the Asset Handling Set employed for the CRW image, the THM files are 
treated as follows:
• If an image of this format is cataloged, the associated THM file will not be cat-

aloged but the information it contains will be captured by Cumulus and 
stored in the record for the image.
NOTE: If the Canon Raw Metadata Support is activated when cataloging, 
you get a list displayed that informs you of the THM files that have not 
been cataloged.

• If you employ Cumulus to manage the cataloged image (copy, move, e-mail 
or delete), the associated THM file will be processed as well. Only when you 
employ the special copy function to select a category and then copying the 
associated assets by dragging this category on your desktop, the THM files 
will not be copied as well. 

• If you rename the assets employing the Cumulus Rename To function, the 
THM files will not be renamed as well.

The Canon Raw Metadata Support is activated by default. If you want to deacti-
vate it for certain Asset Handling Sets, see “(De)activating Asset Handling Mod-
ules,” p. 118.



Customize Cumulus
A little up-front planning can save countless hours of work and frustra-

tion further down the road. This section explains the setting up of pref-

erences to suit your needs and also offers some information on Asset

Handling modules and Asset Format support.
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Preferences 
There is no best way to use Cumulus. Many aspects of the program can be 
changed to adapt to your way of managing your assets. Fundamental changes 
can be made by modifying the preferences. 

 For details on the different sets or settings see: 

• “User Settings,” p. 100
• “Record View Sets,” p. 105
• “Category View Sets,” p. 110
• “Asset Handling Sets,” p. 113
• “Cumulus Asset Actions,” p. 124
• “Metadata Templates,” p. 129
• “Print Templates,” p. 132
• “Sub-Pane Filters,” p. 139

TIP: Properties for Sets, Templates and Actions
Clicking on the  icon opens the Properties dialog of the selected 
set, template or action – offering two tabs. The Description tab  allows 
you to enter a display name and a description for the item in each lan-
guage supported by Cumulus. The Sharing tab allows you to define 
whether you want to share an item with others. And if you want to 
share, you may define specific users or roles that are allowed to use the 
item.

User Settings
The User Settings of the Cumulus Preferences provides access to your individual 
user settings.
//The User Settings section of the Preferences window contains tabs that separate 
sections. Beneath each tab are one or more sections that further organize options 
available. See the following overview on the options available.

Overviews on User Settings
For detailed information on the options available, see the following overviews. 
The “Overview User Setting (1)” gives informations on all options except the Dis-
play tab. The multifaceted option of the Display tab are described in the “Over-
view User Setting (2)” 
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Record View Sets
Cumulus offers different views for records. The following views are defined in a 
Record View Set:
• Thumbnail View
• Report View
• Details View
• Info View 
• Asset Info Window 
• Palette Mode
• Preview View
• Preview Window
View Sets make it easy for you to switch between different views that are set up 
for certain formats or tasks. Once View Sets have been appropriately defined to 
meet differing demands, you can switch between them with just a mouse click.
You can extensively customize most views.

Overview on Customization Options
For Thumbnail, Details and Information view as well as for Asset Information win-
dow and Palette Mode you can decide which record fields are displayed, their 
order and how they are displayed: font type, style, size, and color. You can also 
choose a background color for most of the views.

For some views you can even choose to use the color of a Label field as back-
ground color. For many views you can select the spacing around it and whether 
the record is displayed within a frame. For certain views you can also define that 
the field names are displayed along with the field values. 
For Preview view and Preview window you can choose a background color. For 
Preview window you can choose whether and how the values (and names) of 
record fields should be displayed. 
For each view set you can define the view that is to be displayed when the view set 
is selected. As soon as you have selected a view set from the drop-down list, the 
view will switch. This action is not activated by default. To activate this feature for a 
view set, you have to activate this option in the Set Properties section and then 
select the desired starting view. 
Whether all views will change when changing the Record View Set or only the 
current one is determined by each user individually in her/his User Settings. (For 
details, see see “Overview: User Settings (2) – Display Tab,” p. 103.)

Record View Sets and Multilingual Working Environment
For users working in a multilingual working environment certain view settings 
offer an Allow language switch for multilingual fields option. This option 
enables users to switch the language in which multilingual metadata fields are 
displayed. If this option is not activated, multilingual fields are always displayed 
in the language of the field that was added to the view.

Creating and Editing Record View Sets
You can either change existing View Sets or create new ones.  
Record View Sets are created and edited in the Preference dialog window 
( Cumulus / Edit > Preferences > Record View Set.)
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To change an existing set:

1. Select Cumulus / Edit > Preferences. 

2. Click Record View Sets.

3. Under Set, select the view set you want to edit.

4. Click the icon for the view you want to change.

5. Make the changes. For details see

• “Adding a Field to a Record View,” p. 107
• “Changing the Properties of a Displayed Field,” p. 109

6. Click Apply to save your changes.

TIP: Customize Entry in List for Selecting 
If you have the appropriate permissions, you can easily access the 
preferences of Record View Sets by selecting the Customize entry in 
the list for selecting Record View Sets (e.g. in the Collection window or 
the Asset Information window). This entry opens the preferences for 
the current Record View Set.

A new view set is created by duplicating an existing one and adapting its set-
tings:

1. Select Cumulus / Edit > Preferences. 

2. Click Record View Sets.

3. Under Set, select the set to use as a basis for the new one.

4. Click the Duplicate button.

The Name and Settings dialog opens.

5. Enter a name for the new view set, and optionally

• Activate the Allow Sharing option, if you want this view set to be available 
to other users.

• Activate Copy display names only, if you also want to take over the lan-
guage-specific display names from the original (not recommended for 
new view sets).

• Activate Copy description only, if you also want to take over the descrip-
tions specified for other languages from the original (not recommended 
for new view sets).

6. Click OK.

7. Define the new view set. (For details see “Adding a Field to a Record View,” 
p. 107, and “Changing the Properties of a Displayed Field,” p. 109.)

8. Click Apply to save your changes.

Setting A Default Record View Set
You can define one view set to be the default view set. This default view set will 
be used in case no other set is available or the selected set is not accessible. For 
example, a set that is stored with a collection was deleted after the collection had 
been saved. The default view set is denoted by bold characters in the list for 
selecting a view set.
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To set the default view set:

1. Select Cumulus / Edit > Preferences. 

2. Click Record View Sets.

3. Under Set, select the view set you want to be the default one. 

4. Click the Set as Default button.

5. Click Apply to save your changes.

Adding a Field to a Record View
To add a field to one of the views:

1. Select Cumulus / Edit > Preferences.

2. Click Record View Sets.

3. Under Set, select the view set you want to edit.

4. Click the icon of the view to which you want to add a field.

A list of fields that are shown in the selected view is displayed.

5. Optionally: select the entry of the field after which you want to place the 
new field. If no entry ist selected, new fields will be added at the bottom of 
the list. (A field’s position can be adjusted anytime with the buttons on the 
right side.)

6. Click the Add button.

The Add Fields to View window appears, providing two tabs:

• The Fields tab, displaying a list of all fields contained in the catalogs of the 
active collection that are not yet included in the view. 

• The Modules tab, displaying the nodes: Catalogs, Modules and Lan-
guages.
– The Catalogs nodes expands to a list of all catalogs open in the active col-
lection. Clicking the plus sign in front of a catalog’s name displays all fields 
contained in that catalog, but not yet included in the view. Either select the 
name of a catalog to add all contained fields, or select the individual fields 
you want to add.
– The Modules node expands to a list of all Cumulus modules that provide 
fields. Clicking the plus sign in front of a module’s name displays the fields 
supported by the respective module but not yet included in the view. Either 
select the name of a module to add all fields supported by that module, or  
select the individual fields tyou want to add.
– The Languages node  expands to a list of all languages configured for 
string field values. Clicking the plus sign in front of a language name dis-
plays the fields that support values in the respective language, but are not 
yet included in the view. Either select the name of a language’s  to add all 
respective fields, or  select the individual language-specific fields you want 
to add.
Additionally, all language independent fields that are not yet included in the 
view are listed and can be added.

7. Select the field(s) you want to add.

8. Click OK to add the field(s) to the list of shown fields. 

9. Click OK or Apply. Your changes take immediate effect.
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TIP: Copying/Replacing The Fields From Another View
You can copy the fields included in one view to another view of the 
same Record View Set or you can replace all fields. Select the icon for 
the view you want to have the same fields as another view and use the 
alternate (right) mouse button to open a context menu. Select first the 
desired function and the view from which you want to copy the fields.

Adding a Separator to a View
Separators in views can make it clear to users which metadata fields belong 
together. Users can close a separator to hide its fields and make metadata editing 
much easier on views that contain many fields. You can add as many separators 
as you need, and make it easy to focus on only the fields that matter at the 
moment.
The Asset and the Category Info window as well as Info view support a delimiter 
element that allows to group fields. 
You can add and remove a separator just as any other  field.
To add a separator to an Info window or Info view:

1. Select Cumulus / Edit > Preferences.

2. Click Record View Sets or Category View Sets.

3. Under Set, select the view set you want to edit.

4. Click the icon for the view to which you want to add the separator.

A list of fields shown in the selected view is displayed.

5. Select the entry for the field after which you want to place the separator.

6. Click the Add Separator button. A dialog for entering a name for the separa-
tor is opened.

7. Enter a name and click OK.

The separator is added to the view. 

To change the properties of a separator:

1. Select Cumulus / Edit > Preferences. 

2. Click Record View Sets or Category View Sets.

3. Under Set, select the view set you want to edit.

4. Click the icon for the view you want to edit.

5. Select the entry for the separator whose properties you want to change.

6. Click the Properties button.

This opens a dialog for defining the font attributes and changing the name 
of the separator.

7. Make your selections.

8. Click OK to assign the selected properties to the separator. 

9. Click the Apply button. The separator will be displayed according to your 
settings. 
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Changing the Properties of a Displayed Field
The properties of a displayed field define the font (type, style, size, and color) 
used to display the field contents. 

To change the display properties of a field: 

1. Select Cumulus / Edit > Preferences. 

2. Click Record View Sets.

3. Under Set, select the view set you want to edit.

4. Click the icon for the view you want to edit.

5. Select the entry for the field whose properties you want to change.

6. Click the Properties button.

This opens a dialog for defining the font attributes and – depending on the 
field type – additional properties.
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7. Make your selections. The options differ depending on the field type. (See 
“Additional Display Properties for Different Field Types,” p. 110, for more 
information on additional properties.)

8. Click OK to assign the selected properties to the field. 

9. Click the Apply button. The field is displayed according to your settings. 

Additional Display Properties for Different Field Types
In addition to choosing the font, the Properties dialog offers different options 
depending on the field type:
• String Fields – With Info View or Info Window only

You can define the number of lines to display the contents of the field. For 
String List fields you can define the number of lines as well as display options. 
For String List fields that do not allow multi-select, you can decide to have the 
values displayed as drop-down list or radio buttons. 

• String Fields – Scroll Bar Display for Info View/Window on Mac OS!
To have a scroll bar available for a String field in Info View or Info Window, 
you need to give it at least 5 lines.

• Picture Fields – With Info Window, Thumbnail, Report and Info View
Icons can be displayed to quickly inform about embedded metadata (e.g. 
EXIF, IPTC and XMP data as well as included color profiles, available versions 
or multi-page assets). 

• Categories Field – With Info Window and Info View only
The language of Category tabs in the Asset Info window and in the Info view 
can be set via the Properties dialog of the Categories field. The set language 
governs the names of the Category tabs as well as the names of the catego-
ries displayed in the tabs. To specify a preferred language for the names acti-
vate Preferred language and select the desired language from the list. To 
automatically have displayed the language chosen in the View menu select 
As defined in View Menu. 

Category View Sets
A Category View Set defines the display options for the Category Information 
window and the Category pane display. For each tab you can define different dis-
play options.
Category View Sets are created and edited in the Preference dialog window 
( Cumulus / Edit > Preferences  > Category View Set.)
To change a Category View Set:

1. Select Cumulus / Edit > Preferences. 

2. Click Category View Sets.

3. Under Set, select the tab whose view set you want to edit.

4. Make the changes. 

For details on changes for the Category Info window see: 

• “Adding a Field to the Category Info Window,” p. 111
• “Changing the Properties of a Displayed Field,” p. 112
For details on changes for the Category pane see: 

• “Changing the Category Pane Display,” p. 112
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5. Click Apply to save your changes.

Category Info Window
You can add fields to the display and change the properties of a displayed field.

Adding a Field to the Category Info Window
To add a field to a Category Information window:

1. Select Cumulus / Edit > Preferences. 

2. Click Category View Sets.

3. Under Set, select the view set you want to edit.

4. Click Category Info Window.

A list of fields that are shown in the Category Info window is displayed.

5. Optionally: select the entry of the field after which you want to place the 
new field. If no entry ist selected, new fields will be added at the bottom of 
the list. (A field’s position can be adjusted anytime with the buttons on the 
right side.)

6. Click the Add button. 

The Add Fields to View window appears, providing two tabs:

• The Fields tab, displaying a list of all category fields contained in the catalogs 
of the active collection that are not yet included in the Category Info window. 

• The Modules tab, displaying the nodes Catalogs, Modules and Lan-
guages.
– The Catalogs nodes expands to a list of all catalogs open in the active col-
lection. Clicking the plus sign in front of a catalog’s name displays all fields 
contained in that catalog, but not yet included in the Category Info win-
dow. Either select the name of a catalog to add all fields contained in that 
catalog, or select the individual fields you want to add.
– The Modules node expands to a list of all Cumulus modules that provide 
fields. Clicking the plus sign in front of a module’s name displays the fields 
supported by the respective module but not yet included in the Category 
Info window. Either select the name of a module to add all fields supported 
by the module, or  select the individual fields you want to add.
– The Languages node  expands to a list of all languages configured for 
string field values. Clicking the plus sign in front of a language name dis-
plays the fields that support values in the respective language, but are not 
yet included in the Category Info window. Either select the name of a lan-
guage’s  to add all respective fields, or  select the individual language-spe-
cific fields you want to add.
Additionally, all language independent fields that are not yet included in the 
view are listed and can be added.

7. Select the field(s) you want to add.

8. Click OK to add the field(s) to the list of shown fields. 

9. Click OK or Apply.  Your changes take immediate effect.
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Changing the Properties of a Displayed Field
The properties of a displayed field define the font (type, style, size, and color) 
used to display the field contents.

To change the display properties of a field: 

1. Select Cumulus / Edit > Preferences. 

2. Click Category View Sets.

3. Under Set, select the tab whose view set you want to edit.

4. Click Category Info Window.

5. Select the entry for the field whose properties you want to change.

6. Click the Properties button.

This opens a dialog for defining the font attributes and – depending on the 
field type – additional properties.

7. Make your selections.

8. Click OK to assign the selected properties to the field. 

9. Click the Apply button. The field is displayed according to your settings. 

Category View Sets and Multilingual Working Environment
For users working in a multilingual working environment view settings offer an 
Allow language switch for multilingual fields option. This option enables users 
to switch the language in which multilingual metadata fields are displayed. If this 
option is not activated, multilingual fields are always displayed in the language 
of the field that was added to the view.

Changing the Category Pane Display
To set up the display of the Category Tree to your needs you can select a back-
ground color and define the font type, size and color.
To change the display: 

1. Select Cumulus / Edit > Preferences. 

2. Click Category View Sets.

3. Under Set, select the tab whose view set you want to edit.

4. Click Category Pane.

5. Make your selections:

• To change the background color, click the  button next to the Back-
ground Color field.

• To change the font, click the  button next to the Font field.
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• To change the default display of the category pane, you can enable/dis-
able various display options. You can activate the option to display the 
number of records assigned to the category right next to the category 
name. You can decide which tabs are to be displayed and which tab will 
be displayed when the current view set is selected by a user. 
For details on options only important if working in a multilingual environ-
ment see “Category Pane and Multilingual Working Environment,” p. 113

6. Click the Apply button. The Category pane is displayed according to your 
settings. 

Category Pane and Multilingual Working Environment
For users working in a multilingual working environment the settings for the Cat-
egory pane offer following options:

• To allow sorting of categories according to the rules of a specific language 
and to enable the display of a manually re-ordered category tree, activate 
Enable/View language specific category sorting and custom ordering. 
NOTE: Language-specific sorting is performed either according to the 
rules of the application language or according to the rules of the 
selected preferred language, if a preferred language is specified. 

• To specify a preferred language for the display of categories, activate Pre-
ferred language and select the desired language from the list. To automat-
ically have displayed the language chosen in the View menu select As 
defined in View Menu.

• If for any reason the name of a category is not available in the preferred lan-
guage, it is displayed in the base language. To have additonally displayed 
the name of the used base language, activate the If not available ... option.

Asset Handling Sets
An Asset Handling Set affects how Cumulus deals with your assets – during the 
cataloging process and when accessing assets. The options of a set are not spe-
cific to any one catalog. 
In the Asset Handling Sets section of the Cumulus Preferences you can define dif-
ferent Asset Handling Sets. When a certain set is used depends on the individual 
user settings defined by the user. 
In the User settings of the Cumulus Preferences, each user can define one Asset 
Handling Set for the cataloging done in all catalogs and one Asset Handling Set 
for the asset access done in all catalogs. Each user can also assign different Asset 
Handling Sets to different catalogs (even different ones for cataloging and asset 
access). And each user can define to be asked for an Asset Handling Set when 
cataloging assets. (See “Overview: Asset Handling Sets,” p. 115 for details.) You 
can either change existing sets or create new ones. 
Asset Handling Sets are created and edited in the Preference dialog window 
( Cumulus / Edit > Preferences > Asset Handling Set.)

Editing An Asset Handling Set
To change an existing Asset Handling Set:

1. Select Cumulus / Edit > Preferences. 

2. Click Asset Handling Sets.
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3. Under Set, select the set you want to edit.

4. Make the changes. 

5. Click Apply to save your changes.

See “Overview: Asset Handling Sets,” p. 115, for an overview of the options avail-
able for Asset Handling Sets. 
Of all the various settings available within an Asset Handling Set, those concern-
ing Asset Storage modules are described in detail in the section “Asset Handling 
Modules,” p. 118. Asset Formats are described in the section “Asset Format Sup-
port,” p. 122.

Creating An Asset Handling Set
A new Asset Handling Set is created by duplicating an existing one and adapting 
its settings:

1. Select Cumulus / Edit > Preferences. 

2. Click Asset Handling Sets.

3. Under Set, select the set to use as a basis for the new one.

4. Click the Duplicate button.

The Name and Settings dialog opens.

5. Enter a name for the new set, and optionally

• Activate the Allow Sharing option, if you want this set to be available to 
other users.

• Activate Copy display names only, if you also want to take over the lan-
guage-specific display names from the original (not recommended for 
new sets).

• Activate Copy description only, if you also want to take over the descrip-
tions specified for other languages from the original (not recommended 
for new sets).

6. Click OK.

7. Define the new set. (See “Overview: Asset Handling Sets,” p. 115, for an over-
view of the options available.)

8. Click Apply to save your changes.

Setting A Default Asset Handling Set
You can define one Asset Handling Set to be the default set. This default set will 
be used:
• when the set defined in the User Settings is not available.
• when records are imported.
The default set is denoted by bold characters in the list for selecting a set. 
To determine the default set:

1. Select Cumulus / Edit > Preferences. 

2. Click Asset Handling Sets.

3. Under Set, select the set you want as default. 

4. Click the Set as Default button.
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5. Click Apply to save your changes.

Thumbnail Size and Quality 
The thumbnail size and quality that you select when setting up an Asset Han-
dling Set influences the size of a typical record and thus Cumulus’ overall perfor-
mance. Since Cumulus uses JPEG compression for grayscale and color 
thumbnails, the size of individual records varies depending on the thumbnail 
content. Higher quality thumbnails typically create larger records.
For example, a catalog containing 4,000 records and normal thumbnail quality 
(i.e., 128 x 128 pixels) yields a catalog that is approximately 50 MB in size. The 
same catalog with high thumbnail quality (i.e., 192 x 192 pixels) is 70 MB in size.
To find out how much space thumbnails take up in a catalog, first select the 
thumbnail size and thumbnail quality on the General tab. As you make your 
selections, the disk space required for each thumbnail (in bytes) is displayed in 
the Thumbnail Preview area.

erview: Asset Handling Sets 
t Handling Sets control the way the records of newly cataloged assets are created and how cataloged asset a
ssed. The Asset Handling Sets defined here can be selected in the User Settings dialog or within dialogs whe
loging or accessing assets.

mbnails Tab 
te Thumbnails from
ome programs can save images with embedded thumbnails. 
his option uses those thumbnails, if available, instead of cre-
ting new ones. Stored thumbnails may differ in size.
ses embedded thumbnails, if available and large enough (the 
inimum is the size defined in the section below, see # 4).

reates thumbnail images of the entire asset’s content. These 
humbnails are of best quality, but this option slows the cata-
oging process. If a thumbnail cannot be created, the stored 
humbnail is used. 
mbnail Size
elects default thumbnail size for all newly cataloged assets. 
urrent records’ thumbnails can be adjusted to the new size by 
pdating the record. (See “Update Record,” p. 191.)

imize Thumbnail
qualizes the thumbnail images for newly cataloged assets 
utomatically. This can also be done afterwards. (See “Opti-
ize Thumbnail,” p. 193.)

lity
ets thumbnail quality for the different color modes: Line art 

NORMAL=2 color / HIGH=4 color), grayscale (NORMAL=8-bit 
rayscale, more compression / HIGH=8-bit grayscale, less com-
ression), Color (NORMAL=24-bit color, more compression / 
IGH=24-bit color, less compression.) 
OTE: High-quality thumbnails make records larger.

Thumbnail Preview
7 Displays the thumbnail quality and the disk space 

required for each thumbnail (in bytes) according to th
selected options.
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loging Tab 
n Cataloging
umulus adds new records but doesn’t update existing records 
hose assets have changed.
umulus adds new records and updates those records whose 
ssets have changed.
umulus updates existing records only. No new records are 
dded.

 only – Asset Duplicates Handling
hen cataloging, if Cumulus finds an asset that has already 

een cataloged, a duplicate record is created for the asset.
OTE: This is possible only when Add Only is selected, other-
ise Cumulus thinks you’re trying to update the existing 

ecord.) 
hen cataloging, if Cumulus finds an asset that has already 

een cataloged, it does not create a duplicate record.

Operating System Shortcuts/Aliases/Links
6 Cumulus resolves any links/shortcuts/aliases found in 

selected assets being cataloged. This enables Cumulu
catalog the asset that the shortcut/alias points to.

7 Links/shortcuts/aliases are not resolved and assets the
represent are not cataloged.

 Options
o function with Single User.

tral Asset Location
opies all newly cataloged assets to a central location specified 

n the Catalog Settings and makes the newly created record ref-
rence the copied asset. If you enable the Delete Original 
sset option, the asset will be deleted at its original location 
fter it was copied to the central location. Can be overridden by 

he Catalog Settings.
his is the “off” position for #9. Assets are cataloged normally 
nd not copied to a central location.
o function with Single User.
umulus also copies assets that are contained in a cataloged 
sset to the Central Asset Location – as discrete assets. Requires 
n activated corresponding AssetStore that can detect this 

elation and extract sub-assets that can be saved as discrete 
ssets. (Appropriate AssetStores are available e.g for PDF, Pow-
rPoint, Zip, and Quark XPress documents.) /

Adding Metadata 
13 Define the view set used for the Metadata Editor. The fie

included in the Information window of this set define 
what can be edited with the Metadata Editor.

14 Assigns a Metadata Template to the Asset Handling S
This template will be used when an asset is cataloged w
the Asset Handling Set. If this option is activated, you c
select the Metadata Template to be assigned. 

15 Metadata Editor will be activated when new assets ar
cataloged and new records get created.

16 Metadata Editor will be activated when records are 
updated.

t Access Tab 
ing back Metadata 
ecord-field content is never written back.
ecord-field content is written back to assets if possible.

f activated, the asset modification date will be updated when 
ecord-field content is written back to an asset.
f activated, record-field content is written back to external 

etadata container only, e.g sidecar files, without modifying 
he assets.
ecord-field content is written back to assets if possible, dialogs 
ay appear while resolving connection to assets.

ssing Versions
o function with Single User.
o function with Single User.

erview: Asset Handling Sets 
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et Formats Tab 
list in this tab displays all formats configured for the selected 
t Handling Set. Formats, that are supported by filters that are 
nstalled on the machine you are working with, are displayed in 
s. You can click on each column heading to re-sort the list by 

 field. A green marker indicates formats that are active. Deacti-
d formats are indicated by red markers. Activate and deactivate 
ats for the selected Asset Handling Set using the button #6. 
utomatically adds formats supported by newly installed fil-

ers to the list and activates them.
ll formats will be cataloged. For unknown formats (not listed), 

he Cumulus Generic filter will be used. If this option is not acti-
ated, only those formats which are listed and activated in the 

ist will be cataloged.
pens the properties window for the format. (Only available if 

he filter provides any properties.)
pens a dialog displaying available formats that are not 

ncluded in the list.
emoves a format from the list. You can add it again using the 
dd button, but then it is appended to the list. 
ctivates/deactivates the selected format for the selected Asset 
andling Set.
hese buttons change the selected entry’s position in the list. 
hen cataloging assets Cumulus uses the filters in the order of 

he entry numbers of formats they support. This is important if 
ou have multiple filters for the same file type. Starting from the 
op: move to top of list, move before current position, move 
ehind current position, and move to end of list. (Disabled if no 

ilter is selected.)

Active formats are indicated by a green marker to the left 
the format. Formats that have been deactivated have a re
marker to their left.
Formats that are indicated by italics are currently not sup
ported (not installed on the machine you are working on), 
are included in the list so they will be activated in that posit
when the filter is available.

ules Tab 
Modules tab includes multiple icons that provide access to the 
rent modules. Asset Storage, Asset Processor and Metadata 
ules can be activated for the selected Asset Handling Set. 
etails on the Asset Storage, Asset Processor and Metadata 
ules, see “Asset Handling Modules,” p. 118.
isplays a window that shows the version of the module. 
pens the properties window for the format. (Only available if 

he module provides any properties.)
ctivates/deactivates the selected module for the selected 
sset Handling Set.
e modules are indicated by a green marker. Modules that 
 been deactivated have a red marker.
ules that are indicated by italics are currently not supported 
 installed on the machine you are working on.)

er Filter you can see the Filter Modules that are available on 
achine you are working on. Modules that are indicated by 

s are currently not supported (not installed on the machine 
are working on.)

isplays a window that shows the version of the module. 
pens the properties window for the format. (Only if available.)

erview: Asset Handling Sets 
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Asset Handling Modules
When cataloging and accessing assets, Cumulus uses different modules: Asset 
Storage, Asset Processor, Metadata and Filter modules. 
• Asset Storage modules manage the asset’s storage (the access to its loca-

tion), whereas a Filter module analyzes the asset’s contents. For example, if 
you catalog a file from the file system of your computer, the Asset Storage 
module manages the access to the file system of your computer, and the 
employed filter reads the file’s content.

• Asset Processor and Metadata modules are special modules for special 
tasks, e.g. to handle DCS (Desktop Color Separation) files and OPI (Open Pre-
press Interface).

• Cumulus Filters extract file-type specific metadata from assets. This informa-
tion can include color mode, resolution, file type, font names, etc., depending 
on the type of asset. 
Users who are allowed to define Asset Handling Sets can create their own Fil-
ter format options for specific file types (see “Extending Generic Filter 
Options,” p. 123), and Canto is always updating existing Filters and creating 
new ones. Check Canto’s Website (www.canto.com) for the latest Filter ver-
sions.

Cumulus makes it possible for you to determine precisely what sort of informa-
tion should be kept on the assets. This can be defined differently for each catalog 
as each catalog has its own properties. It is the catalog properties that determine 
what information is stored on the assets in the record fields. (For further informa-
tion, see “Catalog Settings,” p. 142.) Linking metadata fields to record fields 
“feeds” the record with asset metadata during cataloging. The link can work in 
both directions—if supported by the corresponding Filter or Asset Storage Mod-
ule—meaning that you can also write modified record field contents back to 
asset fields. By default, all Cumulus-supported record fields are linked to the 
matching asset fields. This also applies to fields that are included with Cumulus 
but not activated by default in every catalog. When you set up a catalog, you can 
define how these asset fields (from both Asset Storage modules and Filters) 
should be linked to the catalog’s record fields. You can also define how to link the 
custom fields you define to asset metadata. 
If you want to learn more about Cumulus’ various modules, what they do and 
how they are configured to customize Cumulus to your specific workflow, then 
please continue reading the following sections that describe these modules.

(De)activating Asset Handling Modules
Depending on your workflow requirements, you may not need to use some of 
these Asset Handling modules. If, for example, you are not using services from a 
prepress service provider and do not have access to an OPI server, you should 
deactivate the OPI System Support. Deactivating modules which are not needed 
for your specific workflow enhances productivity by freeing up Cumulus’ 
resources and speeding up the cataloging process. To meet individual workflow 
requirements Asset Storage, Asset Processor and Metadata modules can be acti-
vated and deactivated for each Asset Handling Set individually. 
To activate or deactivate an Asset Handling module for an Asset Handling Set:

1. Launch your Cumulus application and open any one catalog.

2. Select Cumulus / Edit > Preferences. 

3. Click Asset Handling Sets.

4. Under Set, select the set you want to edit.
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5. Click Modules and select the icon for the module type.

6. Select the desired module and click the Activate /Deactivate button.

7. Click Apply or OK to save your changes.

Now the module is (de)activated for the selected Asset Handling Set.

Asset Storage Modules
The Asset Storage module manages the access to files. To catalog a file from the 
file system of a computer, the Asset Storage module for that computer’s operat-
ing system must be activated for the Asset-Handling Set used. It must also be 
activated to enable you to access this file. If you are working in a cross platform 
environment you should have the Asset Storage modules for the other platforms 
activated as well so that you can access assets that are stored on other operating 
systems.

Mac OS File System AssetStore
This Asset Storage module manages the access to files accessible from a Mac OS 
computer. You can define the following properties:
• Preferred Resolving Method – If By Alias with Pathname Fallback is 

enabled, Cumulus will resolve the asset reference using the alias first and if 
this fails then using the pathname. If By Pathname with Alias Fallback is 
enabled, Cumulus will resolve the asset reference using the pathname first 
and if this fails the alias. But if By Pathname is enabled, you can avoid a fall-
back by enabling the option No Fallback. Then only the pathname will be 
used for resolving the asset reference.

• Alias Search Method – If Fast Search is enabled, Cumulus will only search at 
the original location. If Extensive Search is enabled, Cumulus will also search 
all mounted volumes in case the file wasn’t found at the original location.

• Mount Dialogs – Dialogs prompted by the operating system when mount-
ing volumes can either be shown or suppressed. If you choose Suppress, fail-
ures might occur, when mounting volumes (especially removable volumes 
such as CD-ROMs), is required for Cumulus functions such as previewing, 
copying and transferring. That’s why you should only choose the Suppress 
option if you are working in a network environment and want to avoid all dia-
logs about mounting when accessing the server. In case the server can’t be 
mounted you will access the assets via Server Client Asset Transfer. It is highly 
recommended to choose the Show option.

MacBinary AssetStore
The Mac Binary AssetStore enables Cumulus to catalog MacBinary converted 
assets even on Windows machines. In addition to creating a record for the entire 
BIN file, it creates records for the compressed file in the BIN file. (No properties to 
be defined.)

TAR AssetStore
The TAR AssetStore enables Cumulus to catalog and access assets compressed 
within TAR archive files. It automatically catalogs all files in a TAR file. In addition 
to creating a record for the entire TAR file, it creates records for each file included 
in the TAR file - even for files in a TAR file within another TAR file. The Cumulus 
TAR AssetStore supports Bzip2, gzip and uncompressed TAR files.
The TAR AssetStore automatically creates categories when cataloging TAR files. 
On the Categories tab, under a category named tar for each cataloged TAR file, a 
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category is created named after the TAR file (e.g. sample.tar). If a TAR file contains 
another TAR file, a subcategory named after this additional file will also be cre-
ated. 
You can define the character encoding used to create the TAR file that is to be 
unpacked by the TAR AssetStore. To know for sure, you should ask the person 
who packed it. If you aren’t sure the character encoding used to pack the TAR file, 
you should use the default: Local Encoding

UNIX File System AssetStore
This Asset Storage module manages the access to files accessible from a UNIX 
computer. (No properties to be defined.)

URL AssetStore
This Asset Storage module manages the access to files accessible from FTP or 
HTTP servers. (No properties to be defined.) For more information, see “Using URL 
AssetStore,” p. 86.

Windows File System AssetStore
This Asset Storage module manages the access to files accessible from a Win-
dows computer. You can define the resolving method for assets stored on CD 
ROMs. If enabled, Cumulus checks for the CD-ROM label.

ZIP AssetStore
The ZIP AssetStore enables Cumulus to catalog and access assets compressed 
within ZIP files. It automatically catalogs all files in a ZIP file. In addition to creating 
a record for the entire ZIP file, it creates records for each of the compressed files 
in the ZIP file - even for files in a ZIP file within another ZIP file. The Cumulus ZIP 
AssetStore has been tested with ZIP compressed assets created with WinZip®, 
PKZIP® and WinRAR.
The ZIP AssetStore automatically creates categories when cataloging ZIP files. On 
the Categories tab, under a category named Zip for each cataloged ZIP file, a cat-
egory is created named after the ZIP file (e.g. sample.zip). If a ZIP file contains 
another ZIP file, a subcategory named after this additional file will also be created. 
If any files contained within a ZIP file are archived with subfolder references, the 
ZIP AssetStore creates a category tree resembling this subfolder structure. (No 
properties to be defined.)

NOTE: Password Protected ZIP Files 
If the ZIP file to be cataloged contains a password protected file, Cumulus will 
ask you for the password. Cumulus remembers this password and if there is 
another password protected file within a ZIP file, it will try the password for 
that file. If it doesn’t fit, Cumulus will also ask you for the password to that file. 
Then you can either type in the password and the file will be cataloged, or skip 
the password request and file will not be cataloged. The passwords are also 
requested for any preview of a password protected asset. Cumulus remembers 
passwords only for as long as the current session. 

You can define the character encoding used to create the ZIP file that is to be 
unpacked by the ZIP AssetStore. To know for sure you should ask the person who 
packed it. If you don’t know for sure the character encoding used to pack the ZIP 
file, you should use the default: DOS Latin US
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Asset Processor Modules
Asset Processor modules enable Cumulus to perform processes on cataloged 
assets, e.g. to convert them.

Pixel Image Converter
The Pixel Image Converter enables Cumulus to convert any cataloged pixel 
image into the different formats on the fly: e.g. JPEG, TIFF, BMP, GIF, ScitexCT, 
PNG, PCX, and PDF. (No properties to be defined.) For more information on how 
to use the Pixel Image Converter, see “Converting Image Assets,” p. 58.

Thumbnail Provider
The Thumbnail Provider is used with Cumulus Actions only. It provides the 
thumbnail stored in the asset’s record for a Cumulus Action. Using the thumbnail 
that is stored in the record might be faster than having the asset converted, e.g 
with the Pixel Image Converter. (No properties to be defined.)

Watermark AssetProcessor
The Watermark AssetProcessor enables you to embed digital watermarks into 
the following pixel image formats: JPEG, TIFF, BMP, GIF, PNG, and PCX. You can 
embed visible text and image watermarks. For more information on the proces-
sor and on how to use it, see “Watermarking Assets,” p. 62.

ZIP Asset Processor
The ZIP AssetProcessor enables Cumulus to compress cataloged assets into Zip 
archives. (No properties to be defined.) For more information on how to use the 
ZIP AssetProcessor, see “Creating ZIP Archives,” p. 64.

Metadata Modules
The Metadata modules are used for retrieving and managing special metadata 
information.

Canon Raw Metadata Support
Most cameras supporting Canon CRW files create additional thumbnail files 
(THM files). The Canon Raw Metadata Support module enables Cumulus to cap-
ture metadata from these files and to manage these files. For more information, 
see “Canon DC Raw Image & Thumbnail File,” p. 98

Cumulus Metadata Support
The module Cumulus Metadata Support supports the storing of an asset’s 
metadata in a separate TAG file for each asset. This makes it possible for stored 
metadata to be used externally (e.g. by other applications). Only if the Cumulus 
Metadata Support module is activated, will Cumulus be able to create a TAG file 
for each asset cataloged. (For further information on TAG files, see “Assets/
Records,” p. 18 and “Browse for Assets,” p. 171.) You can define the following 
properties for the Cumulus Metadata Support:
• Never – If a TAG file exists, Cumulus Metadata Support will read it, but no TAG 

files will be created. 
• Only if Metadata Exists – If metadata in a TAG file exists, it will be updated.
• Always – A TAG file for metadata will be created and continuously updated.
For Directory Categories, Folder TAG files can be created. Remember, Directory 
Categories are automatically created and resemble the folder hierarchy in which 
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the assets reside. The Folder TAG file for a Directory Category is called Cumulus 
Metadata.tag and resides in the corresponding folder. If the Cumulus Metadata 
Support is activated and the option Always is enabled, a Folder TAG file will be 
created as soon as you change the Category information of a Directory Category.
Folder TAG files are also created if you Drag & Drop a category to your Desktop 
or if you employ the menu item Copy Assets Assigned to Category To (for 
details, see “Copy Assets Assigned to Category To,” p. 197). And note that if you 
use this way of copying assets, the TAG files associated to the assets themselves 
will not be copied even if the Cumulus Metadata Support module is activated.

XMP Metadata Support
The XMP Metadata Support module enables Cumulus to manage XMP files (e.g. 
Adobe Sidecar). (No properties to be defined.)

Asset Format Support
Probably one of the first questions you had about Cumulus was “What kinds of 
assets does it support?” Plain and simple, Cumulus supports all kinds of assets, in 
one way or another.
Enhanced support is offered for most popular formats, meaning that Cumulus is 
aware of them and knows what information to extract from them. Others are 
supported only to the extent that they can be added to a catalog, assigned to 
categories, and searched, but no preview or automatic in-depth asset informa-
tion is available. And in some rare cases, an asset’s record will feature a thumbnail 
on one platform, but not on another. For an overview on Cumulus enhanced for-
mat support see Canto’s website.
Cumulus uses what are called filters to help it catalog the contents of an asset. 
Cumulus tells these filters what information to look for in that asset type so that 
it can become part of the asset’s record. Cumulus comes with a number of filters 
that can capture detailed information about particular assets. You can also create 
your own format support for assets that are not particularly supported. 
To see the list of file formats with enhanced support:

1. Select Cumulus / Edit > Preferences. 

2. Click Asset Handling Sets.

3. Click Asset Formats. The list of all supported file formats is displayed.

Active formats are indicated by a green marker to the left of the format. Formats 
that have been deactivated have a red marker to their left.
Formats that are indicated by italics are currently not supported (not installed on 
the machine you are working on), but are included in the list so they will be acti-
vated at that position when the filter is available.
When cataloging, Cumulus starts searching for matching formats at the lowest 
entry number. It employs the filters in the order in which the formats they sup-
port are found. If you are not satisfied with the result of cataloging certain asset 
types, check the order of the formats (and the filter that support these formats). 
The format entry that is supported by a filter that best suits your needs may come 
later in the order than other matching filters. 
Use the arrow buttons to the right of the list to change the order of the entries.

http://www.canto.com/en/docs/cumulus/CumulusCoreEnhancedMetadataSupport.pdf
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NOTE: Record Field Linking
If the Read One option in the Record Field Properties is activated for the field 
link, only the metadata read by the first matching filter will be stored within the 
record. (For information on record field linking, see page 153.) 

If you only want to use a few of the formats on the list for the selected Asset Han-
dling Set, you can disable the others to increase program performance. 

Adding Formats to the Asset Formats List
To add new or not used formats to the Asset Formats list to have them available 
for Asset Handling Sets: 

1. On the Asset Formats tab click Add.The Add Format dialog opens. It dis-
plays a list of all Cumulus modules that provide formats which are not 
included in the Asset Formats list. If you click the plus sign in front of a mod-
ule’s entry, the list expands and displays the formats supported by this 
selected module. You can either select a module’s entry itself and all formats 
supported by the module will be added. Or you can expand the list and 
select a certain format to be added.

2. Select the format(s) you want to add and click OK. 

New formats are placed at the end of the list by default. Use the arrow buttons 
to the right of the list to move the format, if necessary.

Changing Format Options
Some filters have options that you can change. The range of options depends on 
the filter. 
To access a filter’s options:

1. Select Cumulus / Edit > Preferences and then click Asset Handling 
Sets. 

2. Click Asset Formats. The list of all supported file formats is displayed.

3. Select the entry for the desired format in the list. If the filter supporting it has 
options that you can change,  Properties is activated.

4. Click Properties. The Filter Setup dialog is opened.

5. Make your selections and click OK.

Extending Generic Filter Options
Cumulus can catalog any digital asset. If Catalog Unknown Formats (below the 
list of asset formats) is activated and Cumulus encounters an asset for which no 
specific filter is available, then it uses its Generic Filter. You can expand the 
Cumulus Generic Filter’s capabilities to create your “own formats.” For assets that 
don’t have specific format provided by Cumulus, you can define a thumbnail for 
the asset format by using the Generic Filter. 
If you use formats that you’ve created on your own, check the Canto Website 
from time to time to see if a filter has been developed that supports this format 
and you could use.
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To set up a new format:

1. Select Cumulus / Edit > Preferences and then click Asset Handling 
Sets. 

2. Click the Modules tab and then on the Filter icon to see the list of installed 
filters.

3. Select the Generic Filter in the list and click Properties. The window to set 
up the properties for the new format appears.

4. Enter your format’s file name extension in the File Extension field. Do not 
enter the period.

5. Type a name for the format in the File Format field. If your system is 
aware of the asset type, its name may be entered for you.

6. Enter the Mac OS file type in the Mac OS File Type field. The file type will 
always be 4 characters in length.

7. Enter the file format identifier (typically the mime type) in the File Format 
Identifier field.

8. Choose the kind of thumbnail you want to be displayed for the assets. You 
can use either the asset’s Finder / Windows Explorer icon, a thumbnail 
generated by an external application, or an image that you specify.

If you want to specify a thumbnail image to be used for the assets of the 
specified format, activate the Static Thumbnail option, which enables the 
Browse button. Then click the Browse button to select an image. You can 
use any JPEG file as a static thumbnail. The image is resized, if necessary, and 
pasted into the thumbnail image area. Each asset cataloged with this format 
will use this image as its thumbnail.

9. Click OK to save your new format. 

To have the new format available for Asset Handling Sets you have to add it to 
the Asset Formats list: 

1. Click the Asset Formats tab and click Add.The Add Format dialog opens.

2. Expand the Generic Filter entry by clicking on the plus sign on its left. The 
formats available are displayed.

3. Select the format you want to add and click OK. 

New formats are placed at the end of the list by default. Use the arrow buttons 
to the right of the list to move the format, if necessary.

TIP: 
If anything goes wrong while cataloging, check the file extension!

Cumulus Asset Actions
Cumulus Actions simplify daily workflow needs. An Asset Action refers to a com-
bination of certain functions and can be saved under a chosen name. Whenever 
you wish to perform this combination of functions, all you need to do is select 
the corresponding action and it will be done. An Asset Action can include three 
different types of functions: Processing, Packing, Delivering
Firstly, you can have the selected assets processed, then you decide whether the 
result of this process should be packed into one file and finally, you define where 
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this file should be delivered. By default the delivery destination is the file system 
and the only packing possibility is the ZIP AssetStore. 
• Processing

Defining a processing module for an Action is optional. Processing modules 
will always produce as many files as records were selected for the Action. For 
processing, a list of possible modules is provided from which you can choose 
the module you want to use. (For descriptions of the modules, see “Asset Pro-
cessor Modules,” p. 121.) If you select more than one processing module for 
an Action, the sequence is important. 
NOTE: The sequence of the processing modules must make sense. For 
example, having the Zip AssetProcessor as the first processing module 
and then using the Pixel Image Converter to produce JPEG files does not 
make any sense. However, doing it the other way around is fine. Then you 
will get one ZIP file for each selected record and each ZIP file will contain a 
JPEG image. 

• Packing
Packing modules pack the selected assets (or the files resulting from the pro-
cessing) into one file. For example: if you have selected Pixel Image Converter 
for processing (to produce TIFF files) and then Zip AssetProcessor for packing, 
the result will be TIFF files for each selected record packed in one Zip file. 
Another example that might sound odd but also might make sense in certain 
circumstances: if you have selected the Zip AssetProcessor for processing as 
well as for packing, the result will be Zip files for each selected record packed 
in one easy to handle Zip file. 
NOTE: The sequence of the processing modules must make sense. For 
example, having the Zip AssetProcessor as the first packing module and 
then using the PDF Page Merge AssetProcessor does not make any sense. 
However, doing it the other way around is fine. Then you will get one PDF 
compressed into a ZIP archive. 

• Delivering
Defining a delivering module for an Action is not optional. You have to define 
a delivering module for every Action. 

• Asset Handling Set
You can also select a specific Asset Handling Set to be used for the Action. If 
you don’t specify one, the Asset Handling Set will be used that is defined in 
the User Settings of the user who uses the Action. As this Asset Handling Set 
might have some modules not activated that are needed for the action, we 
recommend selecting a certain Asset Handling Set.  And it should correctly 
support the modules chosen for the Action.

See “Overview: Cumulus Asset Actions,” p. 127, for an overview of the options 
available for a Cumulus Action. 
You can either change existing Actions or create new ones. Asset Actions are cre-
ated and edited in the Preference dialog window ( Cumulus / Edit > Pref-
erences  > Asset Actions.)

Creating an Asset Action
A new Asset Action is created by duplicating an existing one and adapting its set-
tings: 

1. Select Cumulus / Edit > Preferences. 

2. Click Asset Actions.

3. Under Action, select the Action to use as a basis for the new one.
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4. Click the Duplicate button.

The  Name and Settings dialog opens.

5. Enter a name for the new Action, and optionally –

• Activate the Allow Sharing option, if you want this action to be available 
to other users.

• Activate Copy display names only, if you also want to take over the lan-
guage-specific display names from the original (not recommended for 
new Asset Actions).

• Activate Copy description only, if you also want to take over the descrip-
tions specified for other languages from the original (not recommended 
for new Asset Actions).

6. Click OK.

7. Define the new Action. (See “Overview: Cumulus Asset Actions,” p. 127, for 
an overview of the options available.)

8. Click Apply to save your changes.

Editing an Asset Action
To change an existing Asset Action:

1. Select Cumulus / Edit > Preferences. 

2. Click Asset Actions.

3. Under Action, select the Cumulus Action you want to edit.

4. Make the changes. 

5. Click Apply to save your changes.

See “Overview: Cumulus Asset Actions,” p. 127, for an overview of the options 
available for Actions. 

TIP: 
You can easily access the preferences of Cumulus Actions by selecting 
the Customize entry in the submenu for selecting an Action. This 
entry opens the preferences for the current Action.

Setting A Default Asset Action
You can define one Asset Action to be the default. This default is not used with 
any standard function of this Cumulus version but may be used by any additional 
function, e.g. provided by a third party partner.
The default Asset Action is denoted by bold characters in the list for selecting the 
Action. To set the default Action:

1. Select Cumulus / Edit > Preferences. 

2. Click Asset Actions.

3. Under Action, select the Action you want as default. 

4. Click the Set as Default button.

5. Click Apply to save your changes.
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Metadata Templates
Metadata Templates are used to add information to the metadata information 
that is stored on an asset. To make use of such a template, you can either use it 
while cataloging (along with an Asset Handling Set or the Prefiller Utility) or apply 
the metadata information to records of already cataloged assets. For a descrip-
tion on how to use Metadata Templates to apply metadata information to the 
records of already cataloged assets, see “Using a Metadata Template,” p. 21. For 
a description on how to use Metadata Templates while cataloging, see “Employ-
ing the Metadata Editor,” p. 172.
For defining a Metadata Template you can select record fields that should be 
filled when the Metadata Template is employed. These record fields can be all 
available field types except Binary fields. Clicking the Add button reveals a list of 
all available fields (provided by filters or by currently opened catalogs). For each 
field added to the template, you can enter a value. For String fields you can also 
define whether you want the new text to replace the existing value or to be 
appended to the existing text. Clicking in a String field’s entry in the column Fill 
Mode allows you to select the desired mode. For all other field types, the entered 
value will replace the existing value. For date field types, the current date is 
shown initially. illustrating the date format  to be entered. A date may be entered 
manually in the given format or selected with a date picker.
To have a field filled when the Metadata Template is used, the Use option for the 
field must be enabled.
You can either change existing templates or create new ones.
Metadata Templates are created and edited in the Preference dialog window 
( Cumulus / Edit > Preferences > Metadata Templates.)

Creating A Metadata Template
A new Metadata Template is created by duplicating an existing one and adapt-
ing its settings:

1. Select Cumulus / Edit > Preferences. 

2. Click Metadata Templates.

3. Under Metadata Template, select the Metadata Template to be used as the 
basis for the new one.

4. Click the Duplicate button. The  Name and Settings dialog opens.

5. Enter a name for the new template and optionally 

• Activate the Allow Sharing option, if you want this template to be avail-
able to other users.

• Activate Copy display names only, if you also want to take over the lan-
guage-specific display names from the original (not recommended for 
new templates).

• Activate Copy description only, if you also want to take over the descrip-
tions specified for other languages from the original (not recommended 
for new templates).

6. Click OK.

7. Define the new Metadata Template. (See “Overview: Metadata Templates,” 
p. 131, for an overview of the options available.)

8. Click Apply to save your changes.
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Editing A Metadata Template
To change an existing Metadata Template:

1. Select Cumulus / Edit > Preferences. 

2. Click Metadata Templates.

3. Under Metadata Template, select the template you want to edit.

4. Make the changes. (See “Overview: Metadata Templates,” p. 131, for an over-
view of the options available.)

5. Click Apply to save your changes.

TIP: 
You can easily access the preferences of Metadata Templates by 
selecting the Customize entry in the list for selecting Metadata Tem-
plate (e.g. in the Asset Information window). This entry opens the pref-
erences for the current Metadata Template.

Setting A Default Metadata Template
You can define one Metadata Template to be the default template. This default 
is not used with any standard function of this Cumulus version but may be used 
by any additional function, e.g. provided by a third party partner.
The default set is denoted by bold characters in the list for selecting a set. To set 
the default set:

1. Select Cumulus / Edit > Preferences. 

2. Click Metadata Templates.

3. Under Metadata Template, select the template you want as default. 

4. Click the Set as Default button.

5. Click Apply to save your changes.
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Print Templates 
Cumulus provides enhanced print options for printing records. The different 
combination of print options can be combined and saved as Print Templates. 
Print Templates make it easy to select print options that are set up for certain 
views or tasks. Once Print Templates have been appropriately defined to meet 
differing demands, the user can easily select them for printing records.
If you have the appropriate rights, you can extensively customize most tem-
plates. There are Print Templates for individual use and templates that are shared 
with other users. Shared templates are displayed in italics. 
A Print Template defines how records will be printed. Print Templates include 
definitions for the document layout (page size and orientation, as well as mar-
gins) and the layout of the records to be printed. To serve as print layout for the 
records, you can either use a Record View Set or define advanced print settings. 
The advanced print settings allow you to specify how the printed records will 
appear on the page. They include options for: 
• the grid to be used (e.g number of rows and columns)
• the thumbnail (e.g. alignment and resolution)
• the fields to be included in the print-out of each record (including font selec-

tion)
• the header and footer text (including font selection)
• PDF creation (PDF security settings)
When defining advanced print settings for a Print Template, a Preview function 
enables you to check the result of your settings. You can see just what a page 
looks like before deciding to save the template.
Print Templates can be used when printing records (File > Print.)
Print Templates are created and edited in the Preference dialog window 
( Cumulus / Edit > Preferences  > Print Templates.)

Creating and Editing a Print Template
A new Print Template is created by duplicating an existing one and adapting its 
settings:

1. Select Cumulus / Edit > Preferences. 

2. Click Print Templates.

3. Under Template, select the Print Template to be used as the basis for the 
new one.

4. Click the Duplicate button. The  Name and Settings dialog opens.

5. Enter a name for the new template and optionally –

• Activate the Allow Sharing option, if you want this template to be avail-
able to other users.

• Activate Copy display names only, if you also want to take over the lan-
guage-specific display names from the original (not recommended for 
new print templates).

• Activate Copy description only, if you also want to take over the descrip-
tions specified for other languages from the original (not recommended 
for new print templates).

6. Click OK.

7. Define the new Print Template. (See “Print Templates,” p. 132, for an over-
view of the options available.) TIP: If you define advanced print settings, use 
the Preview function to check your settings before you save them.
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8. Click Apply to save your changes.

TIP: Previewing a Print Template including Live Previews of Images
If you want to check the result of your settings with live previews of 
images, you should select these images before you open the prefer-
ence dialog. Select at least as many images as needed to fill the 
intended grid cells of one page.

To change an existing Print Template:

1. Select Cumulus / Edit > Preferences. 

2. Click Print Templates.

3. Under Template, select the template you want to edit.

4. Make the changes. (See “Print Templates,” p. 132, for an overview of the 
options available.) TIP: If you define advanced print settings, use the Preview 
function to check your settings before you save them. 

5. Click Apply to save your changes.

Setting A Default Print Template
You can define one Print Template to be the default template. This default is not 
required by any standard function of this version of Cumulus, but may be used 
by additional functions, such as those developed by third party partners. The 
default template is denoted by bold characters in the list for selecting a tem-
plate. 
To set the default template:

1. Select Cumulus / Edit > Preferences. 

2. Click Print Templates.

3. Under Template, select the template you want as default. This should be a 
shared template (denoted by italics).

4. Click the Set as Default button.

5. Click Apply to save your changes.
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erview: Print Templates
int Template stores a specific combination of print options. It can be used when printing records. Print Templa
reated and edited in the Preference dialog window ( Cumulus / Edit  > Preferences  > Print Template

isplays the selected Print Template.
isplays a list of available Print Templates for selection. 
pens the Properties dialog for the selected template – 
roviding two tabs. On the Description tab you may enter 
r modify language-specific display names and descrip-

ions. The Sharing tab allows you to define whether you 
ant to share the template with others. Additionally you 
ay restrict the usage to specific users or roles.
pens a dialog to create a new Print Template by copying 

he selected one.
pens a dialog to rename the selected Print Template.
eletes the selected Print Template.
ets the selected Print Template as default.

ument Settings
Document Settings tab defines the layout for the entire 
ment.
aper Setup settings define the paper size: either a stan-
ard size or a custom size for which the width, height and 
easurement unit can be defined.
OTE: The Units selected here refer to all measurements 
f the template.

9 Orientation defines the orientation for the output (portrait 
landscape).

10 Margins settings define the margins for the page layout.

ut
Layout tab defines the layout for the printed records. You 
either use a Record View Set for the layout, or define 
nced print settings.

f activated, a Record View Set is used for the layout.
f Record View Set Defines Layout is activated, you can 
hoose:
he current Record View is used for layout. 
 specific Record View from a a specific Record View Set is 
sed for layout. You can select the Record View Set and the 
iew to be used.
E: If a Record View Set defines the layout and if you have 
ated the print option Print Entire Assets as Thumb-

s in the Printing tab and set the thumbnail size to 1024 in 
isplay tab of your User Settings, the records’ thumbnails 
e printed in high-resolution, so the printouts can serve as 

act sheets. This may take a while as each of the thumb-
 has to be created.

f activated, you can define Advanced Print Settings for 
he layout.
f Advanced Print Settings Define Layout is activated, 
ou can:
elect the item you want to define for layout.

For an overview on the Advanced Print Settings, see “Overview
Print Templates – Advanced Print Settings,” p. 136.

For an overview on the margin settings, see “Overview: Print Te
plates – Margin Settings,” p. 135
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verview: Print Templates – Margin Settings
his example shows a page layout whose grid is set to two columns and two rows. Which makes four cells 
rinted on a page. The grid shrinks to fit into the space left by the defined margins and spacing. The size of the
ells depends on the size of the grid. Each image, regardless of size, is scaled in proportion to fit to one cell. The
pace left in a cell can be used to show field information. 
his example indicates the margins and spacing you can define by arrows. The height of the header and footer is defined by

e text (font and lines) entered in the Header & Footer section. 
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iew: Print Templates – Advanced Print Settings
e a Print Template, select Cumulus / Edit  > Preferences  > Print Templates.
ced Print Settings Define Layout is activated on the Layout tab, you can define various layout options. The o
ped by topic items and represented by icons. Select the corresponding icon to define your layout.

etermines how many records can be printed on one page. 
er of columns and rows defines the amount (and size) of 
 cell contains a record. The grid shrinks to fit into the space 
 defined margins and spacing. For an overview of the mar-
pacing, see “Overview: Print Templates – Margin Settings,” 

al Options are:
round Color: Determines the background color for the 

 pages except the areas around the image and for the field 
ation. (See also below.)

 Border around Each Cell: Activate this option to have a 
 drawn around each cell.

ge, regardless of size, is scaled in proportion to fit to one cell. 
ment: Determines the alignment point for the image with 
t to the cell.
round Color: see below
 Margin: see “Overview: Print Templates – Margin Set-

” p. 135.
ntire Assets at: Determines whether the entire asset should 
d for printing and the highest resolution an image should 

nted with. (The resolution for the printout cannot be higher 
hat of the original.) 
 the thumbnails is faster but using the entire assets lets you 
e the dpi and so you can decide on the quality. Using the 
 assets also lets you choose the JPEG quality.
humbnails: Determines whether the thumbnail should be 
or printing an image. 
 Assset Action: Activate this option to select an Asset 
 to be performed, e.g. to watermark printed thumbnail

 Border around each Image: Activate this option to have a 
 drawn around each image.

Fields
Under Fields Shown define the fields which values you wan
included in the printout. 
To add fields click the Add button. This opens a list of availab
To define the display properties of a field, select the field and
Properties button. 
Properties concerning the layout of all displayed fields are se
Additional Properties.
• Alignment: Determines the display position for record fi

ues – depending on Show Field Names activated or not
Field Names is activated, the alignment point is the endi
longest field name.

• Align to Image: Determines the display position with re
the image. 

• Margin to Image, Outer Margin and Line Spacing: see
view: Print Templates – Margin Settings,” p. 135.

• Background Color: see below
• Show Field Names: Activate this option to have the field

displayed along with the field value.

NOTE: Space for Displaying Field Information
Each image is scaled in proportion to fit to one cell. Only the s
in a cell is used to show field information. Take this into consi
when selecting the fields and defining their display propertie
image takes precedence over the field information. If an imag
cell, the record field information will not be shown.

Background Colors
Background colors are defined by settings on the Grid, Imag
Fields tab.

Grid Image 
Fields



CUSTOMIZE CUMULUS –  SETTING A DEFAULT PRINT TEMPLATE 137

Header a
The head
througho
ual text a
the catalo

1 Open
text.

2 Applie
3 Applie
4 Applie
5 Open

or a sm
Autom
such a
You c
name
comp
NOTE
footer
%proj
placeh
plate.

ment 
lected in 

t it.
ft on the 

ns,” 

mplate. 
 (by 

 your 

tion to 
wever, 

 be time 

ages! If 
s of 

 prefer-
the 

Overv
PDF Print Options
Cumulus requires no additional software to generate print output as PDF. The 
generated PDF documents can even include links to access the records via Inter-
net. 
To allow the creation of a PDF document, you must activate the Allow PDF Print-
ing option in a Print Template. This enables a user to choose the Print to PDF 
option when the template is selected for printing. If the user chooses Print to 
PDF and the Allow changes to PDF settings when printing option was set in 
template, the dialog PDF Print Settings opens where several PDF options can be 
determined. The further PDF Print Options set in the template serve as pre-set-
tings which can be changed in this dialog.
For PDF creation the following options can be pre-set in a Print Template:
• webclientwebclientEnable PDF Security

When creating PDF files you can use password security to add restrictions 
that can prevent a file from being opened, printed or edited. Passwords can 
only be set when creating the PDF document. (For details, see “Record Print-
ing to PDF with Cumulus,” p. 138.) For details on the PDF security options that 
can be pre-set with a Print Template, see table below.

nd Footer
er and footer are printed at the top or bottom of each page 
ut the print output. Headers and footers can include individ-
nd automatic text – for example, page numbers, the date, 
g's name, or the user name. The text can be formatted.

s a dialog for defining the font attributes for the selected 

s bold formatting to the selected text.
s italic formatting attribute to the selected text.
s underline formatting to the selected text.

 a menu to select a placeholder for inserting automatic text 
all image at cursor position in the header or footer text. 
atic text is provided for common header or footer items, 

s running total page numbers (Page 1 of 10), time and date. 
an also include the name(s) of the catalog(s), the Login 
 of the user who uses the Print template or the name of the 
uter running your Cumulus application.
: You can also define your own placeholders for headers and 
s. If you enter a word beginning with the % character (e.g. 
ect), Cumulus will open a dialog that asks you to fill this 
older when a print process is started that uses this tem-

6 Ruler that displays the tab stop positions and right docu
margin. The measurement unit for the ruler is the unit se
the Document Settings.
To insert a tab stop, click on the position where you wan
To move a tab stop, drag the tab marker to the right or le
horizontal ruler.

PDF Options 
For an overview on the various options, see “PDF Print Optio
p. 137.

Preview
Provides a preview reflecting the current status of the print te
Use this function to check your settings before you save them
clicking Apply or OK .) 
TIP: Resize the Preference window to see the preview sized to
needs. 

• Use Live Previews of Selected Records: Activate this op
see the defined template with live previews of images. Ho
depending on the images’ sizes and resolutions this may
consuming.

TIP: Previewing a Print Template including Live Previews of Im
you want to check the result of your settings with live preview
images, you should select these images before you open the
ence dialog. Select at least as many images as needed to fill 
intended grid cells of one page. 

iew: Print Templates – Advanced Print Settings

1 2 3 4
5

6

6
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PDF security options that can be pre-set in a Cumulus Print Template are:

Record Printing to PDF with Cumulus
For printing records Cumulus offers the possibility to print to PDF. To generate 
print output as PDF no additional software is required. The PDF documents can 
even include links to access the records via the Internet. 
To make use of the Cumulus PDF printing feature you have to use a Print Tem-
plate for printing that uses the advanced print settings which are set to allow 
printing to PDF. 
If you select a Print Template for printing records that allows PDF printing, you 
can choose to have the output saved as a PDF file. 
If the Print to PDF File and the Allow changes to PDF settings when printing 
options were set in template, clicking on the Print button opens the PDF Print 
Settings dialog. The various options are pre-set as defined in the current Print 
Template. Only the password options are not pre-set to prevent them to be set 
by mistake or/and nobody can remember the passwords.

PDF Security
PDF security can be compared with home security. Just as you lock your doors to 
prevent others from entering your house without permission, you may use the 
various security features to “lock” PDF documents. For example, you can add 
passwords to restrict users from opening a PDF document, or they can prevent 
users from printing or editing a document. 
A PDF file can have two kinds of password: a Document Open password and a 
Permissions password. If you are restricting printing and editing, you should add 
a Document Open password to enhance security. 
• Opening the document with the correct Permissions password allows full 

access to the document. This unlimited access includes the ability to change 
the document’s passwords and access permissions. 

• Opening the document with the correct Document Open password allows 
additional operations to be performed according to the set PDF security 
options.

With Enable PDF Security activated but Document Open and Permissions pass-
words not specified, the document will be encrypted, with user-level access, and 
a random Permissions password is generated; the user will not be prompted for 
a password, but nobody can have full access to the document.

F Security Option If the option is activated, users can 

llow Printing in High Resolution print the document in any resolution

llow Printing in Low Resolution print the document at resolution no higher than 150-dpi 

llow Document Changes change the document (including assembling and filling in forms as we
as adding digital signatures)

llow Document Assembly assemble the document (insert, rotate, or delete pages as well as create
bookmarks or thumbnail pages), even if Allow Document Changes is 
not set.

llow Content Copying or Extraction copy and extract document’s contents (text and graphics)

llow Content Copying or Extraction 
r Screen Readers

use screen reader devices for copying or extracting document’s con-
tents only. Visually impaired users are allowed to read the document 
with screen reader devices in any case. This option adds the permission
to copy and extract.

llow Modifying Annotations can add and edit comments as well as form fields and digital signature

llow Filling in Forms and Signing fill in forms and add digital signatures only. 
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With Enable PDF Security activated but only the Document Open password 
specified, a random Permissions password is generated, the document will be 
encrypted and the user will be prompted for a password. Again, nobody can 
have full access to the document. If both passwords are specified, the document 
will be encrypted and the user will be prompted for a password; depending on 
the password entered, the user can have full access, or only restricted access to 
the document. 
For details on the other options, see “PDF Security Option,” p. 138.

Sub-Pane Filters
Sub-Pane Filters provide enhanced support for managing related assets. The panes 
of the split view display certain assets only. Assets that are related to the assets 
selected in the main pane. Which assets are displayed is determined by the option 
selected in the pane’s display drop-down list. This option defines how they are 
related. Sub-Pane Filters make it easy to set up such options. Each Sub-Pane Filter is 
a list option in the sub-panes’ display list. Cumulus provides various pre-configured 
Sub-Pane Filters that should suffice most needs but you can also create your own 
Sub-Pane Filters. 
Sub-Pane Filters are created and edited in the Preference dialog window 
( Cumulus / Edit > Preferences > Sub-Pane Filters.)

Creating and Editing a Sub-Pane Filter
A new Sub-Pane Filter is created by duplicating an existing one and adapting its 
settings:

1. Select Cumulus / Edit > Preferences. 

2. Click Sub-Pane Filters.

3. Under Filter, select the Sub-Pane Filter to be used as a basis for the new one.

4. Click the Duplicate button. The  Name and Settings dialog opens.

5. Enter a name for the new filter and  optionally

• Activate the Allow Sharing option, if you want this filter to be available to 
other users.

• Activate Copy display names only, if you also want to take over the lan-
guage-specific display names from the original (not recommended for 
new sub-pane filters).

• Activate Copy description only, if you also want to take over the descrip-
tions specified for other languages from the original (not recommended 
for new sub-pane filters).

6. Click OK.

7. Define the new Sub-Pane Filter. The settings define what will be displayed in 
a sub-pane for related assets view.

Choose the relation between the selected record(s) and the records dis-
played in the sub-pane by selecting a relation type from the drop-down list. 
For details on relations types, see “Relationships,” p. 78.)

Then choose the level of relation. To have all

• First Level only: Only directly related, contained or referenced assets are 
displayed. (Example use: to see the assets contained in a ZIP file only and 
not the assets that may be contained in these assets.) 

• Last Level only: (Example use: Remember, an image can be a variant of a 
source but it itself is also the source of another variant. But you don’t care 
whether the selected record in the main pane is a variant of another vari-
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ant. You are only interested in the top level variant source (the origin) and 
that’s what you want to see in the sub-pane.)

• All Related Assets: The records of all related assets are displayed regardless 
of whether the relation is direct or indirect.

If you want to have only Pages and Slides or Video shots displayed in the 
sub-pane, activate the Further ... option and select include only from the 
drop-down list. Then activate the asset type that you want to be displayed 
only.

If you don’t want to have Pages and Slides or Video shots displayed in the 
sub-pane, activate the Further ... option and select exclude from the drop-
down list. Then activate the asset type that you don’t want to be displayed.

If you want the displayed result to be based on selected records only, you can 
include a record query in the settings of the Sub-Pane Filter. To do so, activate 
the Use Additional Query option. The Use Query and Use File buttons are 
enabled. Click the Use Query or Use File button. A dialog for selecting the 
corresponding query will open. Select the query you want to apply as filter 
option and click OK/Select. The query is saved with the filter settings and the 
search conditions of the query are displayed. Note that the data of the query is 
saved with the Sub-Pane Filter and if you change the query later on, the Sub-
Pane Filter will not be changed accordingly.

NOTE:  If you cannot open the default folder for storing queries, it may 
be due to its folder properties. If the folder properties are set to Hidden, 
this folder cannot be addressed by the Select dialog. Then you either have 
to change the folder properties or save the queries to another location 
that you can access. 

8. Click Apply to save your changes.

To change an existing Sub-Pane Filter:

1. Select Cumulus / Edit > Preferences. 

2. Click Sub-Pane Filters.

3. Under Filter, select the one you want to edit.

4. Make the changes. 

5. Click Apply to save your changes.

Setting A Default Sub-Pane Filter
You can define one Sub-Pane Filter to be the default. This default is not required 
by any standard function of this version of Cumulus, but may be used by addi-
tional functions, such as those developed by third party partners. The Sub-Pane 
Filter is denoted by bold characters in the list for selecting a filter. 
To set the default Sub-Pane Filter:

1. Select Cumulus / Edit > Preferences. 

2. Click Sub-Pane Filters.

3. Under Filter, select the one you want as default. 

4. Click the Set as Default button.

5. Click Apply to save your changes.



Managing Catalogs
This section describes how to set the catalog settings to suit your

needs and offers some suggestions for effective cataloging strategies,

also it covers some catalog maintenance issues.
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Catalog Settings
Fundamental changes can be made to each catalog by modifying its settings. 
These settings have no effect on catalogs other than on the one for which they 
are set. It’s important to consider a catalog’s settings when the catalog is new, 
before you add records to it. 
To access the settings of a catalog: 

1. Make sure the collection window containing the catalog is the active win-
dow in Cumulus. If you have more than one catalog opened in the active 
collection window, the Catalog Settings window provides a list from which 
you can select the catalog you want to modify. 

2. Select Cumulus / Edit > Preferences. 

3. Click Catalog Settings.

The Catalog Settings window is displayed. If the active collection window 
contains more than one catalog, select the catalog you want to modify 
under Catalogs.

The settings for the selected catalog are displayed in the Catalog Settings 
window.

The Catalog Settings window controls several important factors that come into 
play while managing assets. The options are divided into the following sections:
• General – Catalog location and name, sharing options and options on a cen-

tral location for the assets.
• Record Fields – Displays the record fields that the catalog contains. You can 

add or delete fields and customize selected fields. This allows you to organize 
the information that can be stored on an asset in its record. Remember, meta-
data retrieved from assets while cataloging can only be stored if the corre-
sponding record fields are included in the catalog.

• Category Fields – Displays the category fields that the catalog contains. You 
can add or delete fields and customize the fields.

See “Overview: Catalog Settings”, below, for an overview of the options available 
from this window.
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verview: Catalog Settings
he Catalog Settings window has three sections that provide access to each of its options. The options that are
t from this window are specific to the active/selected catalog. They have no effect on other catalogs.

eneral Section 
atalog

Catalog file name, as seen from the Windows desk-
top/ Mac OS Finder (not editable from here).
Catalog name. Defaults to file name, can be 
changed. (See “Renaming Catalogs,” p. 164, for 
details. 
Displays the catalog format 
Displays the catalog size (actual size/maximum 
size).
Prevents the creation of new categories that share 
names with existing categories.
Activates journaling for the catalog. (See “Journal-
ing Catalogs,” p. 158)

haring
No function with Single User.
No function with Single User.

opy Asset to Central Location
If activated, newly cataloged assets can or will be 
copied to the selected Central Asset Location – 
depending on the selected mode. 

0 Displays the selected Central Asset Location
1 Opens a dialog for selecting the Central Asset Loca-

tion.

12 Opens a dialog for selecting the mode for copying asset to the
Central Asset Location.
– As Set in Asset Handling Set – the Asset Handling Set 
employed for cataloging decides if assets are copied to the 
selected Central Location.
– Always – Assets are always copied to the selected Central 
Location, regardless of the Asset Handling Set settings.

NOTE: Duplicates control with Central Asset Location!
For controlling duplicates with Central Asset Location activated, 
the record fields Original Asset Identifier, Original Asset Name and
Original Asset Reference are required. You have to add these fields
to catalogs with Central Asset Location activated if you also want
duplicates control. 

ecord and Category Fields Section
Field name.
Field type.
Overview on how the field is used for sorting and 
searching.
Overview on whether the user may edit the content 
of the field. Checkboxes may be activated/deacti-
vated directly.
Overview on whether a field is a mandatory field, or 
whether the field value is checked by a validator. 
Checkboxes for display only!
Overview on the value mode
Opens a menu for selecting the columns to be dis-
played on this tab.
Opens dialog for defining field properties. For details 
see “Overview: Field Properties,” p. 147.
NOTE: Catalog Name, Record ID and Category ID are 
so-called virtual fields. These fields are meant to be 
used for display and processing purposes only. 
Therefore you cannot define their properties. 

9 Opens dialog for selecting the field to be added.
10 Removes the selected field from the list.
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Employing a Central Asset Location
A Central Asset Location is a single storage location used to store specific digital 
assets. Employing a Central Asset Location ensures your assets remain accessible 
to all, and can more easily be accounted for. Cumulus lets you choose between 
different types of Central Asset Locations:
• File System – Any standard file system location can be used as a Central Asset 

Location. The most common example is a network file server. This type is sup-
ported by the Asset Storage Modules for the operating systems.

• Internet (FTP) Servers – If you need to keep files accessible from an Internet FTP 
server, you can choose an FTP server as Central Asset Location. This option is 
less popular for works-in-progress because of performance and other limita-
tions associated with this type of server access; but when archiving assets, 
this option can be ideal. This type is supported by the URL AssetStore.

A Central Asset Location is chosen as a catalog property setting. Each catalog can 
have its own Central Asset Location. What the best choice is depends on how the 
catalog is used. For more best practice information on Central Asset Locations, 
see the tutorial “Understanding Central Asset Locations in Cumulus” from 
Canto's “Exploring Series.”
To configure a catalog to employ a Central Asset Location:

1. Make sure the collection window containing the catalog is the active win-
dow in Cumulus.

2. Select Cumulus / Edit > Preferences. 

3. Click Catalog Settings.

The Catalog Settings window is displayed. If the active collection window 
contains more than one catalog, select the catalog you want to edit under 
Catalogs.

4. Click General.

5. Under Copy Assets to Central Location, enable Use Central Asset Location.

The next step is to choose where to store the copies and which Asset Stor-
age module you want to use.

6. Click Browse. The Choose an Asset Storage Module dialog opens. 

7. Select the desired module and click OK. The next steps depend on the 
selected module:

• Selecting the URL AssetStore opens a dialog for entering a URL.
Enter a valid URL of an existing FTP directory and click OK.

• Selecting a File System AssetStore opens a dialog to select a folder. 
Browse for the folder you want the asset to be stored in and then click OK. 
A further dialog appears offering options for the automatic creation of sub-
folders:
None: All cataloged assets are stored in the same folder
By Date: Subfolders are created on a daily basis. Assets cataloged on the 
same day are stored in the same folder. If two or more assets have identical 
file names, a unique identifier will be added to the file name.
By Unique Identifier: Every cataloged Asset gets it’s own folder and 
unique path where it is stored within the Central Asset Location.
Select the desired option and click OK.

8. Select the mode for copying assets to the central asset storage location cho-
sen above. The mode determines when the Central Asset Location is used:

http://www.canto.com/en/docs/exploring/Exploring-CentralAssetLocationsInCumulus7.pdf
http://www.canto.com/en/docs/exploring/Exploring-CentralAssetLocationsInCumulus7.pdf
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• As Set in Asset Handling Set – the Asset Handling Set employed for cata-
loging decides if assets are copied to the selected Central Location.

• Always – Assets are always copied to the selected Central Location, regard-
less of the Asset Handling Set used.

9. Click Apply to save your changes and select the next catalog you want to set 
up for a Central Asset Location.
OR 
Click OK to save your changes and close the Preferences window.

When users catalog assets to this catalog from now on, the asset can be copied 
or will be copied to the selected Central Asset Location.

NOTE: Central Asset Locations and Asset Handling Sets
Every Asset Handling Set that is to be used with a Central Asset Location (for 
cataloging or access), must be configured with the Central Asset Location’s 
corresponding asset storage module activated. So, activate the Mac OS and 
Windows AssetStore modules for file system locations, the URL AssetStore for 
FTP locations. 

Customizing Field Properties 
The properties of a catalog field can be extensively customized. You can define:
• whether the field can be edited
• whether the field values should be based on formulas
• whether and how the field is indexed for sorting and searching
• whether and how the record field is linked with the asset and its metadata 

fields
To access the properties of a record field: 

1. Make sure the collection window containing the catalog is the active win-
dow in Cumulus.

2. Select Cumulus / Edit > Preferences. 

3. Click Catalog Settings.

The Catalog Settings window is displayed. If the active collection window 
contains more than one catalog, select the catalog you want to edit under 
Catalogs.

4. Click Record Fields or Category Fields. This displays a list of the current 
record or category fields included in the catalog.

5. Select the entry for the field whose properties you want to change.

6. Check the Sorting, Contain Search and User Editable options for the field 
and activate the desired options. (See “Record and Category Fields Section,” 
p. 143, for all available options.)

7. Click the Properties button. This brings up a dialog in which you can set the 
properties for the field. The properties depend on the field type. (See “Over-
view: Field Properties,” p. 147, for all available options.)

8. Define the properties as you want them. 

9. Click OK to close the Field Properties window. This brings you back to the 
fields list. 
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TIP: Editing Field Properties of Multiple Record Fields At Once
Certain field properties can be activated or deactivated for multiple 
fields at once. On the record fields list, select the fields and use the 
alternate (right) mouse button to open a context menu. The menu 
options match the field properties you can (de)activate for multiple 
fields at once. 
Selecting a menu item opens a submenu that offers Enable and Dis-
able options. Select the desired option and the field property will be 
enabled/disabled for your selection of fields. If your selection of fields 
includes a field type that does not have the selected property, this field 
will just be ignored.
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verview: Field Properties
he Field Properties window reflects the field type. Most properties are the same but certain field types, e.g. an 
udio field cannot be used for indexing and an initial value does not make any sense. That’s why the properties 
ialog for this field type does not provide these fields.

eneral Tab
ield Properties

Field name. You can use this field to edit a field’s name.
Opens the Field Name Editor to enter/edit the display 
names and, if desired,  descriptions of the fields in other lan-
guages. Language-specific names will be displayed accord-
ing to the selected application language. The according 
field description will be displayed as the field’s tool tip in the 
information window, information view and information 
pane. Useful in multilingual environments.
Displays the Field type. 
With String List Fields only: If activated, the users can select 
multiple values for this field in the Info View or the Informa-
tion window. The values are displayed with check boxes.
NOTE: Whether this option is activated or not influences the 
available indexing options. If activated, the field can be 
indexed for contain-searching but not for sorting. 
No function with Single User!

6 No function with Single User!
7 No function with Single User!
8 No function with Single User!
9 No function with Single User!

ndexing
he options available depend on the field type.
0 Field can be used for sorting and searching. (Equivalent to 

the Sort/Search check box in the Field List column.)
1 The index for sorting records can be set language depen-

dent. Depending on the language selected for running the 
Client application the sorting will follow the rules of the lan-
guage. Activate the languages your users run the Client 
application in. Then a language specific sorting index will 
be created for each of the selected languages. And if the Cli-
ent application is started in one of these languages, a lan-
guage specific sorting of records can be provided.

2 Field can be used for searching by means of the operators 
“contain” or “doesn’t contain.” (Equivalent to the Contain-
Search check box in the Field List column.)

3 If activated, searching the contents of String fields can be 
speeded up significantly. Use this option with care because 
it enlarges the catalog size. The optimization of the search 
index requires more memory in the catalog and therefore 
activating this option is only recommended for fields with 
little data content.

4 If activated, Cumulus provides an additional search func-
tion for the Find window and the Advanced Find window. 
You can search for whole words, not just for matching 
strings. Enclose the word you are searching for in single 
quotation marks and Cumulus will only find the records 
that contain the exact word. 

For example searching for copy will find records con-
taining the words copy as well as copyright, copy-
hold, copyfree and so on. Searching for ‘copy’ will 
find records containing the word copy only

15 No function with Single User!

dditional Options
6 Field will be included in the Record pane’s drop-down list for 

sorting
7 Field will be offered as search criteria in the drop-down lists 

of Find windows and filter definitions.
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ield Values Tab
he values of fields can either be defined by the user or be based 
n formulas.

If activated, the field value can be defined by the user.
Fills the field with an initial value (as defined in the field to 
the right). (See “Initial Value for Fields,” p. 149, for details.)
Allows a user to edit the field contents. (Equivalent to the 
User Editable check box in the Field List column.) 
If activated, the field must be filled with a value when meta-
data are edited. In the Information window or view, empty 
mandatory fields are marked with a special icon and a vali-
dator pane is displayed. Changed metadata can only be 
saved if all required fields are filled in.
No function with Single User.
No function with Single User.
No function with Single User.
 If activated, the field values are based on the formulas 
defined below. For details on how to define such formulas, 
see “Field Formulas,” p. 149.

tring List Editor Tab
his tab is provided for String List fields only. See “Editing a String List Field,” p. 157, for details.)

ield Linking Tab
inking

When cataloging assets, the selected record field will be 
filled automatically. (Read One: only the first matching field 
will be used).
When updating records, the selected record field will be 
filled automatically. (Read One: only the first matching field 
will be used).
NOTE: Do not activate this option if you want to keep the 
additional information you have entered. 
Before updating records, existing values will be removed 
from the selected record field. Allows to refresh the field’s 
contents from new asset values, without accumulating 
unnecessary metadata in the field.
Any changes in field contents will be written back to the 
asset, if the file format and the filter for the asset format sup-
port this function and if Always or Silently is enabled under 
Writing Metadata to Assets in the Asset Handling Set used. 
NOTE: Only if this option is activated for IPTC fields the IPTC 
information edited in Cumulus can be written back. 

ink Matching Fields
List of fields with the same GUID (globally unique identifier) 
or name and type that can fill data into the record field. If 
activated the asset field will fill the record field.
Activates/deactivates the selected field for matching.
If a new Filter module is added that provides any matching 
fields, these fields will be added and activated automati-
cally.

Also Link Following Fields
8 List of fields that are also linked. Use the Add/Remove

buttons to add/remove fields to/from this list.
9 Opens a dialog to select the field to be added.
10 Removes the selected field from the list.

eferenced Tab
rovides an overview of the View Sets, Metadata Templates and Print Templates that bear a reference to the field.

verview: Field Properties
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Defining Field Values
The values of fields can either be defined by the user or be based on formulas. If 
defined by the user, a field can have an initial value and you can allow users to 
edit it or even force them to edit it (mandatory fields).

Initial Value for Fields
To add a default text to a field (e.g. the Notes field) of all newly cataloged assets 
in a certain catalog, you have to enable the option Initial Value for the field and 
enter the text you want to have as default. If the asset’s metadata already contain 
a value for this field, the initial value will be ignored.
As the initial value of a String List field must be one of the terms you entered for 
the String List, you do not enter the initial value but select a term from the list 
provided when clicking the button next to the field.
The initial value of a Boolean field is “false” if the Active option is not checked. If 
you activate this option, the initial value is set to “true”. 

Mandatory Fields 
If the Mandatory Field option is activated for a field, the field must be filled with 
metadata when the metadata are edited. If windows or views which allow the 
editing of metadata contain empty mandatory fields, these fields are marked 
with a special icon and a validator pane is displayed at the bottom of the Infor-
mation Window or Information View. Changes to the metadata can only be 
saved if all required fields are filled in. 
The Mandatory Field option is available for the following field types: Data Size, 
Date, Date Only, Integer, Label, Length, Long, Rating, Real, Resolution, String, 
String List, Time Only.

NOTE: With automatic cataloging the mandatory option attribute is not con-
sidered valid but as soon as a user edits any metadata of a record that includes 
an empty mandatory field and is going to save the changes, a message 
reminds him/her when the record is saved. 

Table Fields
Table fields are special field type that can include other metadata fields. The 
properties of Table fields differ from other field types. 
This field type serves as the basis for the statistics and commenting available in 
Cumulus, and can serve as the foundation for new capabilities. For more infor-
mation on Table fields, contact Canto. 

Field Formulas
Cumulus field values can be determined by formulas that are authored as part of 
a field’s properties. A formula can be as simple as the concatenation of two field 
values into a single string, or as complex as if-then decision making. 
Formulas can be assigned to record and category fields. Values for existing 
records and categories are calculated (or recalculated) when the record or cate-
gory’s metadata is saved after an edit. Formulas are executed during cataloging 
operations for newly created asset records and categories.
Field formulas offer many significant benefits:
Metadata display versatility Used in conjunction with “display only” metadata 
fields you add to your catalogs, field formulas enable you to provide users with 
data displays formatted in more meaningful ways. 
Example: A video’s Duration field might contain the value “25.566.” Even when 
displayed using the field’s label, the user sees “Duration: 25.566,” which could be 
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more clear. A simple field formula can round that value and display it with adja-
cent strings that tell a more complete story: “Length: 26 seconds.”
This also permits you to do away with including field name labels in thumbnail 
views by adding labels only to the fields that need them. In the image shown, 
neither the asset record name (top) nor the format field (bottom) require field 
name labels because their values make clear what the field is used for. By using 
a formula to make the Duration field’s value more clear, three lines of vertical 
space are saved that would ordinarily be required for field names.
Another usage example would be to combine the values of the fields Horizontal 
Pixels, Vertical Pixels and the appropriate resolution field to provide a single line of 
commonly used information:
“2400 x 1200 @ 300 DPI”
This single formula, applied to the properties of a string field you add to your cat-
alog, saves you a full 5 lines of vertical space in your thumbnail display. The added 
string field ensures that each field’s original value remains intact.
Calculations Field values can be calculated to provide useful, searchable meta-
data values that would not otherwise exist in your catalogs without manual data 
entry. Example: say you have a field for Cost Per Use. Another field, Times Used, 
tracks how many times you’ve used the particular asset. A third field, Total Cost of 
Use, uses a simple multiplication formula to offer a sum of the total costs associ-
ated with the asset.
Workflow monitoring and guidance Field formulas can also set values in asset 
records that are later used as “flags” by managers, Live Filtering or Scheduler 
actions for further consideration. 
Metadata Write-back Flexibility The flexibility of the Cumulus architecture 
makes it possible (and easy) to use metadata taxonomies and field types that 
cannot be written back to assets because of the “string only” limitation of most 
metadata standards. You can circumvent this limitation in many cases by using 
formulas in conjunction with Cumulus’s Field Linking. By adding special “meta-
data write back” fields to your catalogs, you can add formulas that concatenate 
the contents of several fields (or fields with data types incompatible with write-
back operations, such as string lists) and “field link” them for write-back to your 
assets. 
Category information not conventionally available Categories don’t have auto-
matic creation or modification date fields associated with them. In addition, 
there is no conventional way to determine which user created a category, or last 
modified its metadata. Field formulas make it possible (and easy) to track all this 
information and more. 
Generate printer-friendly reports Setting up formula-filled fields that you use on 
print templates offers you a great way to output metadata in formats suitable for 
review by others. Formulas enable you to combine metadata fields that would 
otherwise be “report hostile,” such as string lists, Booleans, and labels and ratings, 
into strings that fit nicely onto printed pages. Formulas also enable you to manip-
ulate metadata that you intend to export from Cumulus for use in other systems.

Syntax Overview
A field formula is an expression that returns a single value, which can be of type 
number, real, boolean, string, date, date only or time only. The constant value null 
can also be returned to represent an empty field value.
When applying operators on two values of different types, one or both values are 
converted into a compatible type. Example: (“Cumulus ” + 7.5) results in the 
string “Cumulus 7.5” because 7.5 is converted to a string before the + operator is 
applied. 
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If an error occurs, the field’s value is set according to settings you determine 
while authoring the formula. (See “Multiplying the values of two catalog fields,” 
below, for details.) If no error occurs, the resulting value is automatically con-
verted to match the field’s type.
The arithmetic operators available are a subset of those available in program-
ming languages such as C, Java, or Java Script.

Formal Syntax
expression = bool_expression [ "?" expression ":" expression ]

bool_expression = { "!" bool_expression } | { comparison [ { "||" | "&&" 
} bool_expression ] }

comparison = expression { "<" | "<=" | "==" | "!=" | ">=" | ">" } 
expression

calculation = expression { "+" | "-" | "*" | "/" | "%" } expression

factor = function | value | true | false

function = identifier "(" [param [ "," param ] ] ")"

Function Reference
The Cumulus formula editor includes an in-line help reference that describes 
each function and how it can be used. The functions available may increase with 
each release of the software, so to be sure the information available is up to date, 
no function overview is provided in this guide. 
See “In-line Help,” below, for details.

Formula Examples
The following formula examples rely on specific catalog fields. If using these for-
mulas in your catalogs, make sure you substitute the same field names with fields 
from your own catalogs.

Adding text labels, formatting output and rounding numeric values
Catalog field: disp_Duration (String)
"Length: " + String(fieldValue("Duration") , "%.1f")+ " seconds"

Duration field value: 3.467
Output: “Length: 3.5 seconds”
This formula takes the real value in the catalog’s Duration field, rounds it to a sin-
gle decimal place, and surrounds the resulting value with text strings. 
The "%.1f" portion of this formula will be familiar to those who have worked 
with the printf function available in many programming languages. Cumulus 
supports the following printf formatting options:

In addition, you may use the new line escape character "\n" within a string to 
force a line break where needed:
"Vertical: " + fieldvalue("Vertical Pixels") + "\n" +

"Horizontal: " + fieldvalue("Horizontal Pixels")

Data Type Supported Example

String s %-20.20s

Integer d, I, o, u, x, X %d

Real e, E, f, g, G %5.2f
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Multiplying the values of two catalog fields
Catalog field: disp_Megapixels (String)
fieldvalue("Horizontal Pixels") * fieldvalue("Vertical Pixels") / 
(1024*1024) + “ megapixels”

Horizontal Pixels field value: 3456
Vertical Pixels field value: 2304
Output: “7 megapixels”
This formula multiples the values of the Horizontal Pixel and Vertical Pixel fields, 
divides that value by 1,048,576 in order to get the number of megapixels in an 
image, and appends that value with a text string that describes the result.

If-then decision making
Catalog field: disp_Orientation (String)
(fieldvalue("Horizontal Pixel") == null || fieldvalue("Vertical Pixel") 
== null) ? "N/A" : ((fieldvalue("Horizontal Pixel") > 
fieldvalue("Vertical Pixel")) ? "Landscape" : (fieldvalue("Horizontal 
Pixel") < fieldvalue("Vertical Pixel") ? "Portrait" : "Square"))

Horizontal Pixels field value: 2400
Vertical Pixels field value: 1200
Output: “Landscape”
This formula compares values found in the Horizontal Pixel and Vertical Pixel 
fields. If the Horizontal Pixel value is larger, the image is determined to be “Land-
scape.” If smaller, it’s “Portrait.” If the two values are the same, the image is 
“Square.”

The Field Formula Editor
The field formula editor can be found under the Field Values tab of both the Cat-
egory and Record Field Properties windows.
When using a field formula, a field’s value cannot be edited directly by users. For 
this reason, the window uses radio buttons to permit either “user generated” or 
“formula based” values.
The main text area of the formula editor is where you’ll define your formulas. The 
interface elements of the editor are: 

Construct your formulas in the text field provided. Take advantage of the Fields 
and Functions drop-down lists to save time and help you avoid syntax errors 
introduced by simple typos. 
Choose your preferred option for error handling. An error occurs when for what-
ever reason your formula cannot be executed. Errors can include syntax issues in 
the formula itself, or problems evaluating field data used in the formula.
When you click OK to dismiss the Field Properties window, your formula is saved 
and activated. 

Formula Editor

1 The formula editing field 
2 List containing all catalog fields
3 List containing all functions
4 Option for not changing field value on for-

mula error
5 Option for clearing field value on formula 

error.
6 Option for using a fallback string value on 

formula error 
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NOTE: The order in which fields are calculated cannot be determined abso-
lutely. For this reason, take care when creating formulas that are dependent 
on other field values also based on formulas. If needed, consider “wrapping” 
one field’s formula into the formula of another field, thereby forcing the order 
of calculation. Example:
Field "A" formula: fieldvalue("B") * 1.5
Field "B" formula: fieldvalue("Image Height") + 3.0
This may result in unexpected results if field "A" is evaluated before field "B". The 
solution is to include the field "B" formula in the formula of field "A":
Field "A" formula: (fieldvalue("Image Height") + 3.0) * 1.5

In-line Help
An in-line function and syntax reference is built into the formula editor. This fea-
ture provides a handy reference that will save you time and help you avoid syn-
tax errors.
Three types of in-line help are available:
• Syntax reference – See an example of the syntax used with a function.
• Usage reference – See information about the purpose of a function, the value 

it returns, and a usage example.
• Autocompletion – See a menu list of functions whose names match charac-

ters you’ve typed.
To activate in-line help:

1. Click to place your cursor within the function’s name in the formula editing 
field.

2. Type CTRL p (syntax reference) or CTRL q (usage reference). The usage refer-
ence help window that appears may be resized as needed.

Both windows disappear when another key is pressed or the mouse is 
clicked in the Formula editing field itself. (Hint: Escape, Shift, CTRL or ALT are 
good keys to use to dismiss the window because they don’t introduce any 
new characters into the Formula field.)

3. For function name autocomplete assistance, type the first few characters of 
a function’s name and press CTRL-Spacebar to see a list of functions whose 
names match the characters you’ve typed.

Field Linking 
Some asset formats (e.g., JPEG) can store metadata. Cumulus can read, store and 
manage this metadata by linking it to record fields. The record fields are provided 
by the Cumulus application, the Asset Storage modules, Metadata modules, and 
the filters. 
You can decide when the linking should happen (when cataloging assets and/
or updating records), and whether changes to the metadata should be written 
back to the asset. Changed metadata can only be written back if this function is 
supported by the file format, the filter and Asset Storage module used for access-
ing the asset.
If the record field’s type is String, you can also decide whether the linking applies 
to all or only the first matching asset field. If the Read All option is activated, the 
values of the linked fields are read consecutively. Under Link Matching Fields, all 
fields which “feed” the field are listed – fields that have the same GUID (Globally 
Unique Identifier) or name and type. If the Read All option is activated, Cumulus 
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will fill the record field with the data from all activated modules. If a module is 
deactivated, its data are “ignored” by Cumulus. 

NOTE: Field Linking Checks for Field Types
In addition to its own type, a field may be linked to certain other field types 
only.
– Integer fields accept: String, Boolean, Real
– Real fields accept: String, Boolean, Integer
– Boolean fields accept: String, Integer, Real
– Date fields accept: String
– String List fields accept: String
– String fields accept: Boolean (true, false), Integer, Real, Date, String List (exact 
string matching)
– Binary fields accept: Audio, Picture

Automatic Creation of Folder Categories 
The fields linked to Categories record field are responsible for the automatic cre-
ation of folder categories in a catalog Under which tab (master category) such a 
folder category is created, is defined under Category Target. You can change the 
default target by clicking into the field and selecting another tab..
If you don’t want automatically created folder categories in a catalog, you have 
to deactivate the corresponding modules. 
To avoid the automatic creation of folder categories you have to change the 
default linking of the Categories field:

1. Make sure the collection window containing the catalog is the active win-
dow in Cumulus.

2. Select Cumulus / Edit > Preferences. 

3. Click Catalog Settings.

The Catalog Settings window is displayed. If the active collection window 
contains more than one catalog, select the catalog you want to edit under 
Catalogs.

4. Click Record Fields.

5. Select the field named Categories and click the Properties button. 

6. Click Field Linking.

7. Select the module which to be deactivated (the one that should not create 
categories during the cataloging process. e.g. Windows or Mac OS File Sys-
tem AssetStore).

8. Click Deactivate. 

9. Click OK. This brings you back to the fields list. 

10. Click Apply to save your changes. If you now catalog assets employing this 
module, no directory categories will be automatically created and assigned 
to the record.

Adding Fields
To store information in addition to or different from the default settings, you can 
add fields to the catalog either by activating them from the list of fields that 
Cumulus supports or by defining a custom field.
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To add a record or category field:

1. Make sure the collection window containing the catalog is the active win-
dow in Cumulus.

2. Select Cumulus / Edit > Preferences. 

3. Click Catalog Settings.

The Catalog Settings window is displayed. If the active collection window 
contains more than one catalog, select the catalog you want to edit under 
Catalogs.

4. Click Record Fields or Category Fields. This displays a list of the current 
record or category fields included in the catalog.

5. Click the Add Field button. This opens the dialog Add Field. 

This dialog provides three tabs. Two of them can be used to add fields that 
Cumulus supports, but that are not currently in the catalog. You can either 
select the field to be added from an alphabetically sorted list or from a tree 
structure that lists the fields sorted by the module that provide the fields. 

• The Modules tab, displaying nodes: Catalogs, Catalog Templates, Mod-
ules and Languages.
– The Catalogs nodes expands to a list of all catalogs open in the active col-
lection. Clicking the plus sign in front of a catalog’s name displays all fields 
of that catalog that are not included in the catalog you want to edit. Either 
select the name of a catalog to add all contained fields, or select the indi-
vidual fields you want to add.
NOTE: If the Catalog node includes the catalog that you are editing 
itself, this catalog contains table fields (e.g. Asset Usage History). Table 
fields introduce a second level into the catalog, as they themselves con-
tain fields, which may or may not be contained in the top level, or in 
any other table field, too. At any level of the catalog – top level or table 
field level – the Catalog node offers the fields, that in fact belong to this 
catalog, but not to the current level.

– The Catalog Templates nodes expands to a list of all available catalog 
templates. Clicking the plus sign in front of a catalog’s name displays all 
fields of that catalog template that are not included in the catalog you want 
to edit. Either select the name of a catalog template to add all contained 
fields, or select the individual fields you want to add.
– The Modules node expands to a list of all Cumulus modules that provide 
fields. Clicking the plus sign in front of a module’s name displays the fields 
supported by the respective module that are not included in the catalog 
you want to edit. Either select the name of a module to add all fields sup-
ported by that module, or select the individual fields you want to add.
– The Languages node expands to a list of all languages configured for 
string field values. Clicking the plus sign in front of a language name dis-
plays the fields that support values in the respective language that are not 
included in the catalog you want to edit. Either select the name of a lan-
guage’s to add all respective fields, or select individual fields to be added.
Additionally, all language independent fields that are not included in the 
catalog are listed and can be added.

• The Fields tab displays a list of all the fields that are not yet included in the 
catalog.

The third tab, the Custom Field tab, enables you to define your own custom 
fields so you can store information in addition to fields that Cumulus sup-
ports. See “Creating a Custom Field,” below, for details.
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6. Select the field(s) you want to add.

7. Click OK. This brings you back to the fields list. 

8. Click Apply to save your changes.

NOTE: If you want this field to be shown in a view, you have to customize the 
corresponding view set and add this field. (See “Adding a Field to a Record 
View,” p. 107, for details.)

Creating a Custom Field
To set up a catalog to store information in addition to fields that Cumulus sup-
ports, you can define your own custom fields.

NOTE: Same Custom Field for Multiple Catalogs
If you have created a custom field for one catalog, you can easily copy this field 
to another catalog. If multiple catalogs are opened in the same window, 
Cumulus will display the custom record fields of all these open catalogs in the 
list of the Fields tab. You can select a custom field of another catalog and add 
it to the current catalog. We recommend using this way of adding the same 
custom field to several catalogs, as only then will the field have the same GUID 
(Globally Unique Identifier) in different catalogs. And only when the GUID is 
the same, a custom field can be used for searching in different catalogs. 
Another advantage is that fields of the type String List already include the 
entries that have been made. 

To add a custom field:

1. Make sure the collection window containing the catalog is the active win-
dow in Cumulus.

2. Select Cumulus / Edit > Preferences. 

3. Click Catalog Settings.

The Catalog Settings window is displayed. If the active collection window 
contains more than one catalog, select the catalog you want to edit under 
Catalogs.

4. Click Record Fields or Category Fields. This displays a list of the current 
record or category fields included in the catalog. 

5. Click the Add Field button. This brings up a dialog in which you can add a 
new field. 

6. Click the Custom Field tab. 

7. Enter a name for the field and select the type of field. (See “Field Types,” p. 19, 
for information on field types.)

8. Click OK. The new field is added to the list of fields included in the catalog. 

9. Define the field properties. 

• In the list you can activate certain options
– Sorting
– Contain Search 
– User Editable: If this is not checked, the field contents cannot be modi-
fied.

• In the Field Properties dialog you can define more options for the field. 
Select the field’s entry in the list and click the Properties button. The 
options available from the Field Properties dialog depend on the field type. 
For details, see “Overview: Field Properties,” p. 147.
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10. Click OK to close the Field Properties window. This brings you back to the 
fields list.

11. Click Apply to save your changes.

If you want this field to be shown in a view, you have to customize the corre-
sponding view set and add this field. (See “Adding a Field to a Record View,” 
p. 107, for details.)

Editing a String List Field 
To edit the entries of a String List field, the Field Properties dialog for the field 
must be displayed. The String List Editor tab lets you view and edit the terms of 
the selected String List.
Each term has an ID and can be stored in multiple languages. This is only impor-
tant when working in a multilingual environment. If you want users who open 
the catalog with another language version of Cumulus to see the term in this lan-
guage, you have to store the translation of this term. Depending on the language 
version of Cumulus, the term in the corresponding column will be displayed.
The String List Editor tab lets you edit an existing entry, add a new term or delete 
an existing term by using the corresponding buttons. Save any changes you 
make with the OK button of Field Properties window. They are valid as soon as 
you click the Apply button to save your Catalog Settings.
To edit a term of a String List field, just select its entry in the list and double-click 
the term you want to edit.
To create a new term for a String List field:

1. Click Add. 

2. Enter the new term in the dialog that appears and click OK.

The new term appears in each language field of the list. 

If you are working in a multilingual environment, you can now double-click the 
field for a language and enter the translation for the term. A user will only have 
the terms of one language displayed. The language a user gets displayed initially 
depends on the language defined during the installation, but can be changed by 
the user anytime.
You can edit a term of a String List field at any time:

1. Select the entry for the term you wish to edit.

2. Double-click the term in the language you want to edit in and type the new 
term in the field.

The term will be changed in all records that use it when you have saved the 
changes and closed the Properties window.

You can define the sorting of the terms of a String List field. You can select differ-
ent sorting modes for a String List field:
• Alphabetical (default sorting mode) 

The terms of the String List field will be displayed sorted alphabetically 
according to the rules of the language of the application (e.g the Cumulus 
Client). This sorting mode is useful for e.g. keywords.

• Content
The terms of the String List field will be displayed as sorted in this list – inde-
pendent from the language defined for the user. This sorting mode is useful 



158 CANTO® CUMULUS SINGLE USER GUIDE
for e.g. status descriptions. Use the arrow buttons to the right of the list to 
change the order of the entries.

• Language Specific
This mode allows you to define different sort orders for different languages. 
This sorting mode is useful for e.g. country selection where depending on 
language, different countries should appear on top of the list.

The sorting mode displayed for the String List field in the Select Mode field is the 
active mode, once you click OK for the Field Properties dialog.
If you want to define a sorting mode other than alphabetical: 

1. Select the Sorting Mode.

2. In case you decided on the Content sorting mode, use the arrow button on 
the right to define the order of the terms.

3. In case you decided on the Language Specific sorting mode, select a lan-
guage and then use the arrow button on the right to define the display 
order of the terms of the selected language. Repeat this for each language.

You can delete an entry that you no longer need and replace it with another 
entry. 
To delete an entry:

1. Select the entry you wish to delete.

2. Click Remove. 

Cumulus prompts you to assign a new entry to those records or categories 
and displays a list of terms (in the language that is defined for you as 
Cumulus user).

3. Select a replacement entry from the list and click OK. The new entry is 
assigned to all records previously associated with the deleted entry. This 
may take a while, depending on the number of records that require reas-
signment.

Securing Catalogs 
To prevent an unforeseen technical mishap from damaging or destroying your 
catalogs you should have a strategy. Cumulus offers the following mechanisms 
to preserve catalog data in case of a failure:
• Backing up 
• Journaling 
Canto recommends you to backup your catalogs regularly and in addition, to 
avoid losing changes made to a catalog after the most recent backup, employ 
either catalog journaling or mirroring as a second mechanism. Which mechanism 
is best depends on your needs. 
The advantage of journaling is that you can immediately continue working after 
a failure. 

Journaling Catalogs
Journaling Cumulus catalogs improves data security. A journaling catalog logs 
changes to a journal (special circular log files) before actually writing them to the 
catalog. Such a journal is used to repair any inconsistencies that occur as a result 
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of an improper shutdown. In the event of an improper shutdown, a given set of 
changes may have either been fully committed to the catalog (i.e., written to the 
hard disk), in which case there is no problem, or the changes will have been 
marked as not yet fully committed, in which case the system will read the journal, 
which can be rolled up to the most recent point of data consistency. 

SPECIAL TECH INFORMATION:  Cumulus Catalog Journal
A Cumulus catalog journal consists of 5 circular log files named as the 
catalog file with the extension .redo. These log files are saved along 
with the catalog file in the same folder. Each of these files has an initial 
size of 20 MB and the files can become quite large. The required space 
differs; as rule of thumb: twice the size of the catalog file is recom-
mended. 

IMPORTANT! Copying or Moving Journaling Catalogs
When copying, moving or backing up a catalog externally, the journal of the catalog 
(all 5 *.redo log files) must be included, e.g. copied or moved along with the catalog 
file. 

IMPORTANT! Using Backup Files Created by Cumulus
If you want to replace a damaged catalog file of a journaling catalog with a backup 
file created by Cumulus, you must delete the journal of the catalog (all 5 *.redo log 
files) before you copy and/or rename the backup file. 

You activate journaling for a catalog in the Catalog Settings ( Cumulus / 
Edit > Preferences > Catalog Settings > General.)

New Catalogs
You may create as many new catalogs you need. 

Creating Catalogs
To create a new catalog:

1. Select File > New Catalog. 

If available you can use a catalog template for the new catalog.

Select the desired template and click OK.
(For more information on catalog template, see “Catalog Templates,” p. 160.)

2. Select a location for the new catalog and enter a name.

3. You can have the new catalog opened in a separate window or in the win-
dow of the current collection. Activate the desired option.

4. Click Save. The new catalog is opened.
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Catalog Templates
You can define templates that you can use to create new catalogs, prepare exist-
ing catalogs for specific usage or even update older catalogs. There’s no faster 
way to get new catalogs up and running, or to consistently replicate updates 
made to one catalog on another catalog. Create new, pre-configured image 
databases, video catalogs, PDF archives and more, from a single menu item – no 
more redundant catalog tweaking necessary!

Creating and Editing a Catalog Template
To create a new Catalog Template you can save the settings of an existing cata-
log as Catalog Template or duplicate a template.
To create a new Catalog Template by duplicating an existing one and adapting 
its settings:

1. Select Cumulus / Edit > Preferences. 

2. Click Catalog Templates.

3. Under Template, select the Catalog Template to be used as a basis for the 
new one.

4. Click the Duplicate button. The Name and Settings dialog opens.

5. Enter a name for the new template, and optionally

• Activate the Allow Sharing option, if you want this view set to be available 
to other users.

• Activate Copy display names only, if you also want to take over the lan-
guage-specific display names from the original (not recommended for 
new catalog templates).

• Activate Copy description only, if you also want to take over the descrip-
tions specified for other languages from the original (not recommended 
for new catalog templates).

6. Click OK. The Catalog Template window is displayed.

7. Define the new Catalog Template. 

8. Click Apply to save your changes.

To create a new Catalog Template by saving the settings of an existing catalog 
as Catalog Template:

1. Select Cumulus / Edit > Preferences. 

2. Click Catalog Settings.

3. Under Catalog, select the Catalog to be used as a basis for the new Catalog 
Template.

4. Click the Save as Catalog Template button. The Name and Settings dialog 
opens.

5. Enter a name for the new template, and optionally

• Activate the Allow Sharing option, if you want this view set to be available 
to other users.

• Leave Copy display names activated, if want to take over the display 
names specified for other languages from the original.

• Leave Copy description activated, if you want to take over the descriptions 
specified for other languages from the original
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6. Click OK. 

To change an existing Catalog Template:

1. Select Cumulus / Edit > Preferences. 

2. Click Catalog Templates.

3. Under Template, select the template you want to edit. The settings for the 
selected template are displayed in the Catalog Template window.

4. Make your changes. 

5. Click Apply to save your changes.

The Catalog Template Window
The Catalog Template window controls several important factors that come into 
play while managing assets. The options are divided into the following sections:
• General – Options for Catalog Templates

– Keep Category Names Unique – Prevents the creation of new categories 
that share names with existing categories.
– Use Journaling – Activates journaling for the catalog. (See “Journaling Cat-
alogs,” p. 158)
– Use Template for Catalog Creation – Makes the template appear in the 
Get Catalog Template dialog when creating a new catalog. So do not acti-
vate this option, if you want to use a Catalog Template for preparing other 
catalogs only. 

• Record Fields – Displays the record fields that a new catalog will contain. You 
can add or delete fields and customize selected fields. This allows you to 
organize the information that can be stored on an asset in its record. Remem-
ber, metadata retrieved from assets while cataloging can only be stored if the 
corresponding record fields are included in the catalog. For details on how to 
add and configure record fields, see the corresponding descriptions in the 
chapter “Catalog Settings,” p. 142.

• Category Fields – Displays the category fields that a new catalog will contain. 
You can add or delete fields and customize the fields. For details on how to 
add and configure category fields, see the corresponding descriptions in the 
chapter “Catalog Settings,” p. 142.

TIP: Using Catalog Templates to Update Older Catalogs
You can use Catalog Templates to provide specific catalog fields for 
other catalogs. When adding fields to a catalog, click on Modules and 
you are also offered the fields of Catalog Templates.

Catalog Maintenance 
Taking regular care of your catalogs ensures not only the best performance, but 
also your data security.

Catalog Size and Performance
The biggest factor affecting catalog size is the number of records in the catalog. 
There is no hard limit on the number of records that a catalog can hold, but cat-
alog files cannot be larger than four gigabytes (e.g. Enterprise) /one terabyte in 
size (e.g. standard Workgroup). 



162 CANTO® CUMULUS SINGLE USER GUIDE
As multiple catalogs can be opened in one window, an advantage of this is that 
it makes it easier to search for an asset. The beauty of smaller catalogs is that, the 
time required to repair, restructure or reorganize a catalog is reduced tremen-
dously. Furthermore, if a particular catalog is being repaired or restructured, the 
assets in the other catalogs will be unaffected and can still be accessed.
Search times, however, are not affected by catalog size. 

Record Size
The actual number of records you can fit into the catalog size limit depends on 
the individual records’ sizes. Factors that determine a record’s size include:
• The type of asset the record represents. Different asset types have different 

information that needs to be stored to identify them, so their records use 
varying amounts of catalog space. For example, a video clip uses space for 
frame rate and total frame number fields that a simple image doesn’t require.

• The amount of text in the record’s Notes field. All those characters in the 
Notes field have to be stored somewhere! If you add 1k worth of text, you add 
1k to the record size. Multiply that times a thousand or so records and you 
have added an entire megabyte to your catalog’s size.

• The record’s thumbnail size and quality. Larger and higher quality thumb-
nail images take up more space. (See “User Settings,” p. 100, and “Catalog Set-
tings,” p. 142, for information on thumbnail settings.)

Typically, your catalogs will never reach the maximum size. If they do, you’ll need 
to divide them. (See “Dividing Catalogs,” p. 165.)

Speeding Up Cataloging
As a catalog grows, the time required to catalog new assets increases. There are 
a few tricks for Asset Handling Sets that you can do to increase performance 
when cataloging large amounts of assets at once:
• Choose Catalog Duplicates on the Cataloging tab. This option prevents 

Cumulus from having to “think” too much about what it is cataloging. (See 
“Overview: Asset Handling Sets,” p. 115, for details.) 

• Deactivate any asset formats that you don’t need. (See “Asset Format Sup-
port,” p. 122, for details.) 

Compressing Catalogs
Compressing a catalog when it comes close to its maximum size. You can check 
the actual and maximum catalog size in the Catalogs Settings. 

NOTE: Deleted Records in Cumulus versions prior to 8
When records are deleted from catalogs, with Cumulus versions prior to 8 they 
could optionally remain a part of the catalog in case you need to retrieve 
them. These not-quite deleted records take up space. You can delete them per-
manently by compressing the catalog. 

To compress a catalog:

1. Make sure the catalog you want to compress is the active window in 
Cumulus. If you have more than one catalog opened in the active window, 
you will be asked to select the catalog.

2. Select File > Administration > Compress Catalog. (Only active if the catalog 
is not yet compressed as much as possible.) You are warned that compress-
ing the catalog will permanently remove the deleted records.
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3. Click OK to compress the catalog.

Backing Up Catalogs
The value and usefulness of a Cumulus catalog increases exponentially as the 
catalog grows. To prevent an unforeseen technical mishap from damaging or 
destroying your catalogs (and your work schedule), consider regular and fre-
quent backups.
It’s important to remember that backing up a Cumulus catalog does not back up 
the catalog records’ associated asset files. Make sure that all your important files 
are included in your regular backups.
There are different ways of backing up a catalog:
• Any backup software program
• With the Cumulus Backup feature
The first way may be the quickest and most convenient, particularly if you already 
use a backup software program. A Cumulus catalog, being just another file on 
your computer, can be copied to other volumes, or included in a network or 
automated backup. Catalogs should be closed before they are copied to other 
volumes to ensure that all changes are safely saved. However, you can back up 
an open catalog, if you employ the Cumulus Backup feature.
To back up a catalog using the Backup feature with Single User:

1. Make sure the catalog you want to back up is the active window in Cumulus. 
If you have more than one catalog opened in the active window, you will be 
asked to select the catalog.

2. Select File > Administration > Backup Catalog. The Backup window opens. 

3. Select a location for the backup and enter a name.

The name for the backup catalog file defaults to the same name as the origi-
nal catalog file with the file name extension .bak. You may also choose the 
file name extension .ccf. There is no difference in format, but then you may 
need to choose a different name or a special backup location to avoid con-
fusions with the original catalog. 

4. Click Save. The catalog is saved to disk.

Preparing Catalogs for Special Metadata
If you want to capture IPTC, XMP or EXIF data from assets (and to write back such 
data to assets), the catalog(s) managing these assets and the Asset Handling 
Set(s) to be used must be prepared. Cumulus provides special functions for this. 
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File > Administration > Prepare Catalog opens a submenu with options for pre-
paring catalogs to manage different standard metadata formats.For more details, 
see “Prepare Catalog,” p. 176. 

Copying Catalogs
The Backup function described above is Cumulus’ mechanism for copying cata-
logs in their ready-to-use state. You can also use the conventional ways of copy-
ing files on your computing platform to make copies of Cumulus catalogs. 
Remember, copying catalogs does not copy the associated asset files. 

Repairing Catalogs
If a catalog becomes damaged, Cumulus may be able to rebuild it. When you try 
to open a damaged catalog, Cumulus asks to repair it. You can also initiate the 
repair process for local catalogs from within the program by selecting File > 
Administration > Rebuild Catalog. 
Catalogs are most commonly damaged by power failures or shutting off the 
power to your computer while a catalog is open. (Selecting the standard Shut 
Down menu item to turn off your computer is safe, even when a catalog is open.)

Renaming Catalogs
Cumulus catalogs actually have two names:
• One is the name of the catalog file, as you see it from your computer’s desk-

top. This is called the catalog file name.
• The other is the name of the catalog, as seen in the catalog window’s title bar. 

This is simply called the catalog name.
When a catalog is first created, the catalog name defaults to the same name as 
the catalog file. Newly created catalogs are named the same as their file names 
by default, but the catalog name can be changed at any time. 
To change a catalog name (what you see in the catalog window):

1. Make sure the collection window containing the catalog is the active win-
dow in Cumulus.

2. Select Cumulus / Edit > Preferences. 

3. Click Catalog Settings.

The Catalog Settings window is displayed. If the active collection window 
contains more than one catalog, select the catalog you want to edit under 
Catalogs.

4. Click General. You’ll see a field labeled Name.

5. Enter a new name for the catalog in the Name field and click OK. The 
change is saved and the window closes.

You change a catalog’s file name (what you see from your computer’s desktop) 
as you would any other file. 

Deleting Catalogs
Unlike deleting records, deleting catalogs is not undoable. (Unless you have a 
disk utility program that makes recovering deleted files possible.) Cumulus has 
no built-in mechanism for deleting catalogs. Delete catalogs as you would any 
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other file on your computer. Remember that assets are not deleted with catalogs. 
Catalogs must be closed to be deleted.

Dividing Catalogs
At some point you may wish to divide the contents of one catalog into smaller 
catalogs. Reasons for doing so include:
• The catalog has grown close to its maximum size (e.g. 4 gigabytes).
• Your computer can no longer accommodate the number of records in the 

catalog effectively (processor or RAM limitations).
• The contents of the catalog have become too diverse to be usefully catego-

rized in one catalog.
Like many operations in Cumulus, there is more than one way to divide a catalog. 
The first way is best suited to smaller numbers of records.
To divide a catalog using drag and drop:

1. Make sure the catalog from which you wish to divide is the active window in 
Cumulus.

2. Create or open the catalog you wish to move records into in a separate win-
dow. Arrange the catalog windows so that you can see both.

3. Search for the records you wish to move to the new catalog, using any of 
Cumulus’ search options. (See “Searching,” p. 32.)

4. Click on or near a thumbnail in the original catalog and select Edit > Select 
All to select the records. (At this point you could cut and paste the records 
between the catalogs as one way of moving them, which would save you 
the step of deleting the old records in the old catalog.)

5. Click on the thumbnail of any of the selected records and drag the set into 
the new catalog window. The records are copied. The copied records’ cate-
gories are created in the new catalog. 

NOTE: Cumulus doesn’t consider copying records from one catalog to 
another as “cataloging assets.” Therefore, the Asset Handling Sets have no 
effect on this action. 

6. You can optionally delete the records from the old catalog by first clicking 
on the old catalog’s window to activate it, and then selecting Edit > Delete 
before the selection of records has changed.

Migrating Catalogs
Catalogs from versions prior to Cumulus 6 cannot be migrated within 
Cumulus 8. If you need to migrate Catalogs from versions prior to Cumulus 6, 
please contact your Cumulus support. 
When you first open a Cumulus 6 or 7 catalog with Cumulus 8, it is prepared to 
be used with Cumulus 8. You can immediately start working with it. 
However, you need to explicitly migrate a Cumulus 6 or 7 catalog file to 
Cumulus 8 if 
• Integer or Long Integer field values are used for sorting
A catalog’s type and size can be viewed in its Catalog Settings window 
( Cumulus / Edit > Preferences > Catalog Settings > General tab.)
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Catalogs created with Cumulus 6 or 7 can be easily migrated to Cumulus . How-
ever, Canto recommends you always make a backup catalog and then use this 
backup version of the catalog for migration.
To migrate a Cumulus 6 or 7 catalog:

1. Select File > Administration > Migrate Catalog. A dialog for selecting a cat-
alog appears. 

2. Select the Cumulus catalog you want to migrate and click Open. 

3. Select a name and location for the migrated Cumulus catalog and click 
Save. A progress bar appears to indicate the status of the conversion.

Once the progress bar disappears, your catalog has been migrated to the 
current Cumulus catalog format and saved in the location you selected.

NOTE: If problems occur during a catalog migration, try repairing the catalog 
using your former Cumulus version. Choose the Repair option under the 
Administration menu and then try the migration again. 

Archiving Information
Many organizations maintain several catalogs: one catalog for production assets 
and a second catalog to manage archives. With Cumulus you can also take your 
assets off-line, update the file references, and still be able to search and retrieve 
them. 
In general, archiving assets involves the following steps:

1. Copy and/or move the assets you wish to archive to the other media. 

2. Merge the records you wish to archive into an archival catalog by first copy-
ing the categories and then the records. 

3. Update all asset references in the archive catalog. 

4. If desired, delete the records you archived from your production catalog.

The Importance of Updating Asset References
Cumulus tracks the location of media assets through asset references. Whenever 
you move an asset, you must update the asset reference to reflect the new loca-
tion. 

About Archiving on CD-ROM
Like other read-only media, creating an archive on CD-ROM requires that all infor-
mation be set up correctly in advance. When creating archives on CD-ROM, 
remember the following:
• Create a temporary “staging” volume/drive and give it the same name as the 

final CD-ROM disc.
• Copy and/or move the catalogs and assets you wish to archive to the staging 

volume/drive. 
• Update all file references. The file references within each record must point 

to the assets located on the staging volume/drive.
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• Burn a new CD that contains the contents of the temporary volume/drive. 
Remember that the CD must have the same name as the staging volume/
drive.

Creating Hybrid CD-ROMs
Differences between the Windows and Mac OS operating systems present some 
distinct challenges when archiving to external media such as CD-ROM. To avoid 
problems in locating information on hybrid CD-ROMs, remember to use one of 
the following file system combinations:
• a hybrid CD-ROM containing an ISO 9660 file system with Joliet extension as 

well as a Mac OS HFS file system
• an ISO 9660 CD-ROM without extensions 
Because of operating system naming restrictions, the use of other file system 
combinations can lead to problems when finding files on either platform.
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Menu Reference
This section serves as a road map to the entire Cumulus product from

the perspective of the user interface. Explanations are given for each

of the program’s menus and toolbars. 
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 The Cumulus Menu

About Cumulus
Displays a dialog that shows the version of Cumulus you’re using. It also provides 
a button that launches your default Web browser and initiates a connection to 
the Canto Website. This requires an Internet connection.

Preferences
Opens the Preferences window, from which you can set all preferences. (See 
“Customize Cumulus,” p. 99, for details.)

Quit Cumulus
Quits Cumulus.

The File Menu

New Catalog
Creates a new catalog. If available you can use a catalog template for the new 
catalog. (For more information see “Catalog Templates,” p. 160.) A dialog is dis-
played for you to name the new catalog and choose a location for saving it. Then 
you can have the new catalog opened in a separate window or in the window of 
the current collection. Activate the desired option.

Open Catalog
Opens a dialog that lets browse for a catalog file.
When opening a catalog you either open it in a separate window or in the win-
dow of the current collection. Activate the desired option.

Open Recent Catalog
Opens a submenu that lists all catalogs opened recently. Selecting the entry for 
a catalog will open it. The submenu also includes an entry that allows you to clear 
the list of recently opened catalogs. 

Close
Closes the active window, e.g. the Collection, Preview, Record or Category Infor-
mation window.

New Collection
Opens a submenu with two options for creating a new collection: 
• From Selection – The new collection will contain the currently selected 

records.
• Empty – The new collection will be empty.
For more information on collections see “Collections,” p. 16.
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Open Collection
Opens a dialog to choose one of the collections you saved.
For more information on collections see “Collections,” p. 16.

Save Collection
Saves the collection as it is shown.
For more information on collections see “Collections,” p. 16.

Save Collection As
Saves the collection as it is shown under a new name. A dialog is displayed for 
you to name the new collection. Enter a name for the collection and if you want 
the collection to be available for other users, activate the Share Collection 
option.
For more information on collections see “Collections,” p. 16.
wsCopy URL for Other Purposes

Add Catalog to Collection
Opens a dialog to select another catalog to be opened within the current collec-
tion.
For more information on collections see “Collections,” p. 16.

Remove Catalog from Collection
Opens a dialog which lists the open catalogs and lets you choose the catalog to 
be removed from the current collection.
For more information on collections see “Collections,” p. 16.

Save
Saves any changes depending on the active window; e.g. the Record or Category 
Information window.

Add Assets to Catalog
Open a submenu with following menu options:

Browse for Assets 
Opens a dialog in which you can browse for assets you want to add to a catalog 
(in Cumulus-speak: you want to “catalog”.) Depending on your individual set-
tings several options for cataloging might be offered to you before the dialog for 
selecting the assets is opened.
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BACKGROUND INFORMATION:  
“Cataloging assets” is Cumulus-speak for adding media files to your 
catalog. There are several ways to catalog assets: via menu item, con-
text menu and with drag and drop. As you catalog your assets, 
Cumulus creates special catalog entries called records that represent 
the assets to be managed. Each record contains vital searchable infor-
mation about the asset it represents. 
How Cumulus deals with your assets during the cataloging process 
depends on the Asset Handling Set used. Asset Handling Sets define 
many aspect of asset handling, including which Asset Stores and Fil-
ters should be used, where the assets should be stored when cata-
loged, and which metadata template (if any) should be automatically 
applied. 

TIP: Cataloging Asset via Drag & Drop
You also catalog assets by dragging them from an Explorer/Finder 
window into the Cumulus window.

Options While Cataloging
Several options for the cataloging process are possible – most of them depend 
on the selections made in your User Settings ( Cumulus / Edit > Prefer-
ences > User Settings > General or Asset Handling.) 

Showing Progress Dialog
If activated in the User Settings, a progress dialog is shown while Cumulus is cat-
aloging the assets. With Cumulus, you can have multiple cataloging processes 
running simultaneously and you can go on working with Cumulus while catalog-
ing. With a Cumulus Client under Mac OS X you see an icon for each of the pro-
cesses.

Selecting Asset Handling Set
If you have activated the option Show dialog when cataloging in the Asset Han-
dling section of your User Settings, you will be prompted to select an Asset Han-
dling Set for each cataloging process. 
Make sure the selected Asset Handling Set fits to the catalog you want to add the 
assets to. 
In the list of Asset Handling Sets, you can use the Customize option to access the 
preferences of the selected Asset Handling Set. (See “Overview: Asset Handling 
Sets,” p. 115 for details on how to set up Asset Handling Sets.)

Selecting Catalog
If you have multiple catalogs open in one window, you are prompted to select 
the catalog to which you want to add the assets. 
If you have activated the option Show dialog while cataloging in your User Set-
tings and have multiple catalogs open in one window you are prompted to 
select the catalog to which you want to add the assets and select an Asset Han-
dling Set for this cataloging process. Make sure the selected catalog and the 
selected Asset Handling Set match.  

Employing the Metadata Editor 
If the Asset Handling Set you use, has the Show Metadata Editor for New Records 
activated, a dialog is displayed when cataloging assets.It allows you to add meta-
data information to the records of those assets you are just cataloging. (The fields 
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displayed depend on the Record View Set that was selected for the Metadata 
Editor in the settings of the Asset Handling Set.) You can use a Metadata Tem-
plate and/or manually enter metadata information.
If you don’t want to add any of your own information to the current asset’s 
record, select the Skip button. 

Creating TAG Files 
If you catalog assets from a location where you are allowed to save files, Cumulus 
can create a TAG file for each cataloged asset. The file has the same name as the 
asset with the extension .tag added and is saved in the folder where the asset 
resides. TAG files are a standard exchange file format for metadata information 
on the asset. TAG files hold all of the information that can be viewed in the Asset 
Information – and more. For example, if a particular asset has been cataloged 
into different catalogs, this information is part of that asset’s TAG file.
If you want Cumulus to create these TAG files while cataloging, use an Asset Han-
dling Set that has an activated asset storage module Cumulus Metadata Sup-
port (properties set to Always).

New Empty Record
Creates an empty record. Opens a Dialog where you can specify the catalog to 
which the record is added, as well as the Asset Handling Set to be used with the 
new record. You can assign metadata and an asset to such a record later on. 

TIP: 
To assign an asset to an empty record later on, use the Change Asset 
Reference function.

Assign Asset to Record
Only available if one – and only one – record is selected that has no asset 
assigned to.
Opens a dialog to select the asset to be assigned to the record. Subsequently, the 
asset is cataloged and assigned to the selected record. (If applicable, the asset is 
also copied or moved to a Central Asset Location.) Optionally – depending on 
what is specified for the current catalog in the User Settings – a dialog for select-
ing an Asset Handling Set is displayed first.

Recatalog Category Folder
Synchronizes the content of the selected folder category with the contents of 
the folder represented by this category. This option compares the contents of 
the folder and Cumulus: files that are new in the folder are automatically cata-
loged. (Available for folder categories only.) 

Setup Auto Cataloging
Opens a dialog to define auto cataloging for the selected category. (See “Cate-
gories and Auto-cataloging,” p. 27, for details.) (Available for folder categories 
only.)

Import
Opens a submenu with several menu options. Each opens a dialog in which you 
can select an appropriate file type for import. The various file types are listed by 
the import type below:
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• Assets – Lets you add assets to catalogs. After selecting an Asset Handling 
Set, a dialog opens to browse for the assets you want to add. For a description 
on how to go on see “Browse for Assets,” p. 171.

• Records – Lets you import records that were exported to XML files or to 
Cumulus Record Exchange Files. If you have multiple catalogs open in one 
window, you are prompted to select the catalog to which you want to import 
the records. The imported records are appended to the active collection. 

• Categories – Lets you import categories that were exported to XML files or 
Cumulus Category Exchange Files. If you have multiple catalogs open in one 
window, you are prompted to select the catalog to which you want to import 
the categories. The imported categories are appended to the active/selected 
catalog. If a category in the import file has the same name as an existing cat-
egory, the category is not imported. 

• Collection – Lets you import collections stored with previous Cumulus ver-
sions on the computer running the Client application and collections sent to 
you via email. If you have multiple catalogs open in one window, you are 
prompted to select the catalog which you want to import the collection to.

• From Text/CSV File – Lets you import metadata from text files (separated by 
delimiters.) As a comma is a very common delimiter, such files are also called 
Comma Separated Value (CSV) files. This import option enables you to import 
metadata from other database systems into Cumulus catalogs. 

For detailed information on importing, see “Importing and Exporting,” p. 70.

Export
Opens a submenu with several export options. Each opens a dialog in which you 
can name an appropriate file type for export. All exported files can be used on 
any supported Cumulus platform. The options are explained below:
• Selected Records – Exports the currently selected records. (This menu item 

is disabled if no records are selected.)
• All Records – Exports all records of the active collection. If you want to export 

all records of the catalog(s) included in the collection, you have to perform 
Find > Find All Records first.

• Selected Categories – Exports the currently selected categories in the active 
collection. (This menu item is disabled if no categories are selected.)

• All Categories – Exports all categories of the Category pane. 
• Collections – To store collections in any location other than the Cumulus 

Server, 
• Mail Collection To – Sends a collection via email to another user. However, 

don’t forget: Since a collection is always connected to catalog(s), it is necessary 
for the recipient to have access to the catalog(s) ‘serving’ the collection. To make 
use of a collection you received via email you use the import function.

For detailed information on exporting, see “Importing and Exporting,” p. 70.

Page Setup
This menu item opens a standard page setup window from which you can con-
figure your printing options. The options available to you will depend on your 
system configuration. See your computer’s operating system manual for details.
Under Mac OS, the Preview button allows you to view the printed output before 
it gets sent to your printer. Under Windows, Cumulus provides a Print Preview 
menu item.
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 Print Preview
This option allows you to view the print output before it gets sent to your printer. 
The output options are taken from the current print settings.

Print
Opens a submenu with the following menu options: 
• Selected – Prints selected items (records, categories or preview sections) – 

depending on the active window or pane. 
• All – Prints all items – depending on the active window or pane. 
The print function is context sensitive (meaning that what is printed depends on 
the position of the cursor). If the active window or pane is: 
• the category pane, the categories (all or selected) will be printed as they 

appear in the Category window. Make sure to expand the category list if you 
want to see all the subcategories in the print out. 

• the record pane and thumbnail or details view is the current view mode, the 
records (selected or all of the active collection) are printed using Print Tem-
plates. (For more information on Print Templates, see “Print Templates,” 
p. 132.)

• the record pane and information view is the current view mode, the informa-
tion displayed will be printed.

• an information window, the information displayed in the window will be 
printed.

• a preview window, the preview will be printed – in case it is available as a 
pixel image (e.g. JPEG, TIF or GIF). The preview will be printed in the size of 
the paper selected under Page Setup. This may take a while! 
If your intention is to print the actual asset, instead of its record or preview, 
see “Print With,” p. 196, for details.

Administration
Opens a submenu with several administration options.Descriptions on how to 
use the administrative functions for catalogs see “Catalog Maintenance,” p. 161.  

Switch Application Language
Opens a dialog to select a different language for your Cumulus application’s user 
interface. Expand the list to see the languages Cumulus supports.
Languages marked in bold already provide a localized user interface. For all other 
languages, an English user interface is displayed, but specific writing capabilities 
for the selected language are supported. This applies to the category tree, input 
fields and Quicksearch function.
Select the desired language and click OK. You must quit the Cumulus application 
and start it again before the language switch takes effect. If the selected lan-
guage is not available on your computer, the Cumulus application language will 
default to English.
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Prepare Catalog
Opens a submenu with options for preparing catalogs to manage different stan-
dard metadata formats. 
• For IPTC

IPTC (International Press Telecommunication Council) is a standard for digital 
text applied to an image. Applications used for professional imaging support 
IPTC; e.g. the text information in Photoshop is a subset of the IPTC informa-
tion. 
Cumulus can read IPTC metadata information while cataloging. You can view 
and edit this metadata and Cumulus can write your changes back to the 
asset. Reading and writing back IPTC data is possible for assets of the follow-
ing formats: JPEG, TIFF, PSD, and EPS. (For more information on writing back 
metadata, see “Write back Metadata,” p. 191”.)
If you want to capture IPTC data from assets and to write back IPTC data to 
assets, the Asset Handling Set(s) and the catalog(s) managing these assets 
must be prepared for this feature. IPTC record fields have to be added to the 
catalog(s) and their properties have to be enabled for field linking. The Writ-
ing back Metadata option must be activated in the Asset Handling Sets used 
to handle the assets containing IPTC data. 
The function makes the process of preparation easy. Follow the on-screen 
instructions.
NOTE: To view the captured metadata, the corresponding record fields 
must be included in one of your Record View Sets. If none of your Record 
View Sets provide a view that includes the fields, you have to add these 
fields to one view of at least one Record View Set. For a description on how 
to add fields to a view, see “Adding a Field to a Record View,” p. 107. 

• For EXIF
EXIF (Exchangeable Image File Format) is a standard for storing interchange-
able information in image files, especially those using JPEG compression. 
Most digital cameras now use the EXIF format. Cumulus can read EXIF meta-
data information while cataloging. You can view and edit this metadata.
If you want a catalog to store EXIF information on assets, you have to add the 
EXIF record fields to this catalog. This function does it for you. Follow the on-
screen instructions.
NOTE: To view the captured metadata, the corresponding record fields 
must be included in one of your Record View Sets. If none of your Record 
View Sets provide a view that includes the fields, you have to add these 
fields to one view of at least one Record View Set. For a description on how 
to add fields to a view, see “Adding a Field to a Record View,” p. 107. 

• For XMP
Adobe’s XMP (Extensible Metadata Platform) is a labeling technology that 
allows you to embed metadata into the asset itself. With an XMP-enabled 
application (e.g. all applications of Adobe Creative Suite), information about 
a project can be captured during the content creation process and embed-
ded within the file and into a content management system. 
Cumulus can read XMP metadata information while cataloging from assets 
of the following formats: PDF, JPEG, DNG, TIFF and Adobe Photoshop, Illustra-
tor and InDesign files. You can view and edit this metadata and Cumulus can 
write your changes back to the asset. Writing back XMP data is only possible 
for assets of the following formats: JPEG, DNG, TIFF, and PSD. (For more infor-
mation on writing back metadata, see “Write back Metadata,” p. 191”.)
If you want to capture XMP data from assets and to write back XMP data to 
assets, the Asset Handling Set(s) and the catalog(s) managing these assets 
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must be prepared for this feature. XMP record fields have to be added to the 
catalog(s) and their properties have to be enabled for field linking. The Writ-
ing back Metadata option must be activated in the Asset Handling Sets used 
to handle the assets containing XMP data. 
The function makes the process of preparation easy. Follow the on-screen 
instructions.
NOTE: To view the captured metadata, the corresponding record fields 
must be included in one of your Record View Sets. If none of your Record 
View Sets provide a view that includes the fields, you have to add these 
fields to one view of at least one Record View Set. For a description on how 
to add fields to a view, see “Adding a Field to a Record View,” p. 107. 

Rebuild Catalog
Opens a dialog in which you can repair (rebuild) the active catalog. 

Backup Catalog
Opens a dialog in which you can save a backup copy of the active catalog. 

Compress Catalog
Opens a dialog in which you can compress the active catalog. (Disabled if the 
catalog is already compressed as much as possible.) 

Migrate Catalog 
Open a dialog to convert older Cumulus catalogs into a format compatible with 
the latest Cumulus version. 

Exit
Quits Cumulus.

The Edit Menu

Undo
Allows you to undo some of the errors you may have made while entering text 
into fields. It reverts to the former text entry. It works for string fields of the Infor-
mation window or view, for the Quicksearch entry field and when renaming cat-
egories. (Disabled if not available.)
Note that this function is limited to revert text entries, it will not reverse any func-
tions. 

Cut
Removes the current item or text selection and places it on the Clipboard so that 
it can be pasted elsewhere.

Copy
Copies the current item or text selection and places it on the Clipboard so that it 
can be pasted elsewhere.
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Paste
Places the contents of the Clipboard into the current location or text insertion 
point.

Delete
Deletes the selected records or categories from the catalog after confirmation of 
the action. (Disabled if no records or categories are selected.)
The confirmation dialog for deleting records offers two options: to delete the 
record only or to delete the record and its associated asset, too. This is not undo-
able. Make sure that you no longer need an asset or that you have a copy else-
where before deleting one. 
If you decided to have the asset deleted as well but the asset cannot be deleted 
(e.g. because it is read-only access), the record will not be deleted either. Note 
that records that represent assets stored on CDs will be deleted.

NOTE: Deleting Related Assets
If the record to be deleted represents a preferred alternate or a variant source 
you will get an informing message that also lets you cancel the process. 

Select All
Selects all objects or text. The type of selection depends on which window is 
active and whether you have clicked inside a text area.

Deselect All
Cancels any previous selection.

Preview Tools
Opens a submenu that lets you toggle between Hand tool and Select tool and 
that offers functions for the comment tool. For more information on these tools, 
see “Overview: Toolbars for Previews,” p. 52. (Disabled if no Preview window or 
view is activated.)

Preferences
Opens the Preferences window, from which you can set all preferences. (See 
“Customize Cumulus,” p. 99, for details.)

The View Menu

Palette Mode
Changes the view of the Cumulus application to palette mode and back. In Pal-
ette Mode, the thumbnails and the contents of record fields are displayed as 
defined in selected view set. 
In palette mode the Cumulus application will shrink to a palette that can conve-
niently be used with another application. That way you can easily drag and drop 
cataloged assets into other applications. All open collections will be changed to 
palette mode. They are displayed on top of each other. The Palette Mode win-
dow can be resized to fit your needs (and all display changes will be kept when 
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you reopen the palette mode). All Cumulus functions remain available; to display 
the menus select Menu. 

Toolbar
Offers a submenu to select the size of the toolbar and options to toggle the tool-
bar on and off. 

Statusbar
Toggles the statusbar on and off. 

Workspace
Opens a submenu with options that let you toggle panes of your workspace on 
and off:

Several menu options enable you to open (and close) additional panes in the 
current Collection window and to save this combination of panes as a work-
space. A workspace saves even more information. It includes:
• window size
• window location
• visible panes
• view sets selected for each pane.
Below these menu options you will find more options if any saved layouts are 
available for you.
The additional panes will be displayed at the bottom of the Category pane.

TIP: Resizing Panes
You can resize the panes by pressing the ALT / Option key and 
dragging the split bar. (Just clicking the split bar will resize the top-
most pane and the sub-pane of the dragged split bar only.) 
Collapsing: Pressing the ALT / Option key and double-clicking in 
a pane’s statusbar will collapse the pane so that the statusbar is dis-
played only and the pane above will fill the area. (Just double-clicking 
lets the pane above retain its size and the topmost pane will be 
enlarged.) A double-click on the statusbar of the topmost pane will 
collapse all panes below.
Expanding: Pressing the ALT / Option key and double-clicking in 
a collapsed pane’s statusbar will expand the pane again – using space 
from the above pane. (If you just click it – without the ALT / 

Option key – the pane will be expanded using space from the top-
most pane.) A double-click on the statusbar of the collapsed topmost 
pane will expand all panes below.
Minimizing: Double-clicking a pane’s split bar minimizes the pane or 
resizes it again.
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Calendar Pane
Toggles the Calendar pane on and off. 
Use the Calendar pane to search for records by date. Dates that correspond 
records are highlighted. If you move the cursor over a highlighted date, a tooltip 
shows the number of corresponding records in all catalogs open in the current 
collection. 
Clicking on the  icon opens a menu with the following options:
• Record View Set – to change the used Record View Set
• Calendar Mode – to toggle between Month mode and Year mode. In month 

mode, you can select a single day or multiple days of the month or an entire 
month for searching. In year mode, you can select a single month or multiple 
months of the year or an entire year for searching.

• Field – to select the record field to which the highlighted items in the Calen-
dar pane correspond, e.g. Asset Creation Date, Asset Modification Date, 
Record Creation Date, etc. You can select from all date fields and date-only 
fields that are indexed for searching in the currently open catalogs. 

If you move the cursor over the  icon, a tooltip shows the current settings.
Select a day/month by a single click on any highlighted item. With a  Ctrl-click 
/ Command-click, the selection is increased or reduced by single items. With 
Shift-click, the selection is increased or reduced by a range of items. 
Double-clicking any highlighted date or the month/year title starts a record 
search. Double-clicking a date inside a multiple date selection, finds all records 
belonging to any of the selected days/months. The search result will replace the 
current selection in the record main pane.
If you hold the Ctrl key while double-clicking a highlighted item in year view, it 
switches to the specified month displayed in month view.
The Calendar pane has its own toolbar.

Category Pane
Toggles the Category pane on and off. (Menu equivalent to the toolbar icon.)

Category Information Pane
Toggles the Category Information pane on and off. The Category Information 
pane displays information about the selected category. Which fields are dis-
played in the Category Information pane depends on the settings in the current 
Category View Set.

Calendar Pane Toolbar Items

1 Switches to current month/year
2 Switches to the previous year
3 Switches to the previous month (disabled in year mode)
4 Switches to next month (disabled in year mode)
5 Switches to next year
6 Opens a menu with following options:

– Record View Set.
– Calendar Mode (month/year)
– Field 

7 Minimizes the pane.
8 Closes the pane.

7 81 2 4 653
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Collection Basket Pane
Toggles the Collection Basket pane on and off. The Collection Basket that 
enables you to gather and sort records for one-click access and optional process-
ing.
The Collection Basket only slightly differs in function from regular collections. For 
this reason, most of the functions available while working with standard collec-
tions—changing view sets, saving and sharing contents, resorting, etc.—are also 
available from within the Collection Basket.
The Collection Basket pane appears on the right side of the main collection win-
dow and has its own toolbar.

Changing the Appearance and Size of the Collection Basket
The appearance of the Collection Basket can be changed using many of the 
same options you know from standard collections:
• Thumbnails and Details — Use the toolbar icons for changing the Collection 

Basket between thumbnail and detail views. (Make sure the Collection Basket 
is the active pane before making the change.)

• Record View Sets — Use the Record View Set menu found under the  icon 
located at the top of the Collection Basket pane to choose from the available 
record view sets. 

• Thumbnail Size — Use the standard thumbnail resizing icon located on the 
toolbar to adjust the size of Collection Basket thumbnails. You’ll also notice 
that when you reduce the width of the Basket using the vertical bar, the 
thumbnails scale down in size to remain visible.

In addition, you can resize the Collection Basket by dragging the bar that divides 
the main collection and Collection Basket panes. Double-clicking this bar mini-
mizes the pane or resizes it again.

Working with the Collection Basket’s Contents

Moving Asset Records Into the Basket
Add asset records to the Collection Basket from the main collection window 
using drag & drop. Select one or more records and drag them into the Basket. 
You can add as many records at a time as you need, and you can add additional 
records at any time thereafter.

Removing Asset Records from the Basket
Select one or more records inside the Collection Basket and press the DEL key on 
your keyboard to remove them from the Basket. The items are removed from the 
Basket, but not from the main collection or catalog.
Optionally, you can use the menu command Find > Remove Record from Col-
lection.

Collection Basket Pane Toolbar Items

1 Lets you choose an action as output option (action) for Col-
lection Basket contents

2 Replaces the main collection window contents with the 
contents of the Collection Basket

3 Clears the Collection Basket
4 Lets you choose a record view set, sort field and sort order 

for the Collection Basket contents
5 Closes the Collection Basket

1 2 4 53
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Rearranging the Order of Asset Records in the Basket
As you would in any other collection window, you can drag thumbnails around 
in the Collection Basket to rearrange them. You can also sort the contents of the 
Basket using the Sort By menu found under the  icon located at the top of the 
Collection Basket pane. (Use the Sort Direction menu to reverse the sort.)

Outputting the Collection Basket’s Contents
The  icon open a list from which you can select an output option for the con-
tents of the Collection Basket. Ilists the asset actions available, and also includes 
several standard Cumulus functions, such as emailing, creating Web albums and 
printing thumbnails.
Choose an asset action and then use the buttons provided to choose whether 
you intend to output the entire contents of the Collection Basket or just the 
selected items. 
Once you make your selection and click OK, the Collection Basket passes the list 
of assets to the selected action. Then the asset action is processing. At that point, 
you might see the user interface of the active module and can set parameters for 
the processing. (Or, if you’ve chosen an asset action that is configured for no user 
interaction, you will not see any further windows.)
• For information on asset actions, see “Using Asset Actions,” p. 50.
• For information on the Mail To function, see “Mailing Your Assets,” p. 51.
• For information on the Web Album function, see “WebAlbum,” p. 65.

Replacing the Main Collection with the Collection Basket Contents
If you ever want to replace the contents of the main collection pane with the 
contents of the Collection Basket, click the  icon. The main collection is 
updated. There is no “undo” for this operation, so make sure you intend to 
replace the main collection’s contents when you click this icon.

Clearing and Closing the Collection Basket
Clear the contents of the Collection Basket using the  icon at the top of the 
Collection Basket. There is no “undo” for this operation, so make sure you intend 
to clear the basket’s contents when you click this icon.
Click  to close the Collection Basket window. Closing the Collection Baskets 
does not clear it’s contents – when you reopen the Basket, the contents appear 
as you left them. 

NOTE: If your User Settings have the Re-open Collections and Catalogs 
option activated, the contents of your Collection Basket will reappear the next 
time you open that same catalog (or set of catalogs), even when using the 
Web Clients. But if you open a different catalog in the interim, the contents of 
the Collection Basket are deleted. 

Information Pane
Toggles the Information pane on and off. The Information pane displays informa-
tion about the record(s) selected in the current collection. Which fields are dis-
played in the Information pane depends on the settings for the Info View of the 
current Record View Set.

tion Basket output options 
e asset actions and other 

res familiar to Cumulus 
.
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Preview Pane
Toggles the Preview pane on and off. The Preview pane displays the record 
selected in the active record pane in Preview View. This means that the display 
depends on the selected Record View Set. 

Sub-Pane for Relations
Opens a sub-pane below the active record or closes it. The sub-pane displays 
records or other information that are related to the selected record as defined in 
the active Sub-Pane Filter.

Thumbnail Pane
Toggles the Thumbnail pane on and off. The Thumbnail pane displays the record 
selected in the active record pane as thumbnail.

Save Current as Default Workspace
Saves the current layout as your default workspace for collection windows.

Use Default Workspace
Applies the saved default workspace as layout for the current collection window.

Save Current Workspace As
Opens a dialog that allows saving the current workspace under a selectable 
name. Enter a name for the workspace .
A saved layout includes:
• window size
• window location
• visible panes
• view sets selected for each pane.

Manage Workspace 
Opens a dialog displaying all available workspaces (in alphabetic order). You can 
select one and apply it to the current collection window by clicking Open.
You can also delete workspace layouts via this dialog. Select the entry and click 
Delete. Note that shared Workspaces can be deleted by the Cumulus Administra-
tor only.

Preview Pane Toolbar Items

1 Shows first page of preview (available with 
multi-page previews*)

2 Shows previous page of preview (available with 
multi-page previews*)

3 Shows next page of preview (available with 
multi-page previews*)

4 Shows last page of preview (available with 
multi-page previews*)

5 Opens a list for selecting a Record View Set.
6 Closes the pane.
* For more information on multi-page previews, see 
“Multi-page Previews,” p. 53
TIP: The preview images can be resized using the 
zoom slider in the main toolbar 

1 2 4 653
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Thumbnails
Activates Thumbnail View: Displays records as thumbnails and the contents of 
record fields as defined in the selected view set. (Menu equivalent to the toolbar 
icon.) Once this view mode is active, you can use the zoom slider to change the 
size of the thumbnails or use predefined sizes via menu (View > Thumbnail 
Sizes).

Details
Activates Details View: Displays records in a sorted text list as defined and the 
contents of record fields as defined in the selected view set. (Menu equivalent to 
the toolbar icon.)

Information
Activates Information View: Displays metadata information stored with the 
record. The displayed fields are defined by the selected view set. (Menu equiva-
lent to the toolbar icon.)

Preview
Activates Preview View: Displays records as previews. The records’ assets must be 
accessible to display the preview. Once this view mode is active, you can select 
different sizes for the previews. (Menu equivalent to the toolbar icon.)

TIP: 
The preview image can be resized using the zoom slider.

Report
Activates Report View: Displays thumbnail and metadata information in horizon-
tal order (a sort of hybrid between the Details and Info View modes.) It offers a 
convenient way to display the contents of text fields that contain lots of informa-
tion. Can display as many lines as needed for quick browsing. (Menu equivalent 
to the toolbar icon.)

TIP: 
The thumbnails can be resized using the zoom slider.

Record View Set
Opens a submenu with the available Record View Sets. For more information on 
Record View Sets, see “Record View Sets,” p. 105. (Disabled unless a record is 
selected.)

TIP: 
You can easily access the preferences of Record View Sets by selecting 
the Customize entry in the list for selecting Record View Sets. This 
entry opens the preferences for the current Record View Set.
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Category View Set
Opens a submenu with the available Category View Sets. For more information 
on Category View Sets, see “Category View Sets,” p. 110. (Disabled unless a cate-
gory is selected.)

TIP: 
You can easily access the preferences of Category View Sets by select-
ing the Customize entry in the list for selecting Category View Sets. 
This entry opens the preferences for the current Category View Set.

Preview/Thumbnail Sizes
Opens a submenu to select the size of thumbnails or previews.

Small 
Displays records as small thumbnails/previews (default 64 x 64 pixel). You can 
change the default size. (See “User Settings,” p. 100, for details.) 

Medium 
Displays records as medium thumbnails (default 128 x 128 pixel). You can 
change the default size. (See “User Settings,” p. 100, for details.) 

Large Thumbnail/Preview
Displays records as large thumbnails (default 256 x 256 pixel)/previews. You can 
change the default size. (See “User Settings,” p. 100, for details.) 

Sort By
Opens a list of the available fields of the current collection. Select the field you 
want to determine the sorting of. (Menu equivalent to the statusbar field.) 

NOTE: The selected field should be one with the most records containing 
information – otherwise you will be quite unhappy with the sorting. 

TIP: Unsorted
The option Unsorted will display the records in the order they were 
cataloged. You can sort by two fields. In Details view Cumulus lets you 
select a second field as sorting criteria. Click the column header for the 
field you want to use as first sorting criteria and then Shift-click the col-
umn header you want to use as second sorting criteria. If you switch 
to other views, the sorting will remain until you change the sorting. 

Sort Direction
Opens a submenu that provides two options for the direction of the sort order:
• Sort Ascending – Sorts the records in an A to Z (0-9) direction.
• Sort Descending – Sorts the records in a Z to A (9-0) direction.

Details view allows sorting by two fields: The first sorting criteria is 
indicated by a single arrow the second by a double arrow. 
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(Menu equivalent to the statusbar icon.)

Language for Field Values
Opens a submenu that provides the possibility to switch the language in which 
multilingual metadata fields are displayed.
The first entry in the menu is Application Language which is also the default. If 
Application Language is selected, multilingual fields are always displayed in the 
language of the application (see “Switch Application Language,” p. 175). 
If the language for field values is set to a language that is not defined for a mul-
tilingual field, this field displayed in its base language instead.
Changing the language for field values takes immediate effect.

Prerequisites and Additional Hints
The Language for Field Values function only works if the currently open catalog 
contains record fields and/or category fields that are enabled for multi language 
support.
Additionally, the following prerequisites must be met:
• To allow language switching for metadata fields, the Allow language switch 

for multilingual fields option must be activated in the preferences of the 
current View Set’s active view. If this option is not activated, multilingual fields 
are always displayed in the language of the field that was added to the view. 

• To allow language switching in the Category pane, the Preferred Language 
option must be activated and set to As defined in View menu in the Cate-
gory Pane preferences of the current Category View Set. If the Preferred Lan-
guage option is not activated, multilingual categories are always displayed in 
their base language.

There is one more issue with the category pane.
Instead of coupling the language of the Category pane to the selection made in 
the View menu. you may as well select a language to always be used with the 
category pane, independent of the language used for other metadata fields. 
Activate the Preferred Language option in the Category Pane preferences and 
select the desired language.

Category Pane and the Categories Field: Making the Language Consistent
If your Category pane is set to a language different from the language of other 
multilingual fields, you may nevertheless want to have the categories displayed 
always in the same language, both in the Category pane and in any specific View 
of your View Sets.
For example, you may have a German Category pane, whereas multilingual fields 
are set to be displayed in English. If category assignments of an asset are dis-
played in the Info View or the Asset Info Window, you would expect to see Ger-
man category names here, as in the Category pane. However, according to the 
language settings for multilingual fields, they are displayed in English.
To solve this inconsistency and always have the same category language used 
both in the Category pane and in the Categories field displayed in a record view, 
open the Record View Set preferences, select the desired View Set and View and 
make sure that the Preferred Language settings in the Properties of the Cate-
gories field are identical to the Preferred Language settings of the Category 
pane.

NOTE: This has to be done individually for every View in every View Set where 
the Categories field is displayed.
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Go To
Opens a submenu for navigation. The available options depend on the current 
focus.

Preview
Opens a submenu for preview display options. (Disabled if no Preview window 
or view is activated.)

Zoom In
Doubles the size of a preview image. Preview images can be increased to eight 
times or 800% of their original size. (Disabled if no Preview window is activated.)

Zoom Out
Halves the size of a preview image. Preview images can be reduced to one eighth 
or 12.5% of their original size. (Disabled if no Preview window is activated.)

Fit to Window
Resizes the Preview window to fit inside the main Cumulus window. Can be set 
as default, see “User Settings,” p. 100, for details. (Disabled if no Preview window 
is activated.)

Fit Width to Window
Resizes the Preview window to fit the width of the main Cumulus window. Can 
be set as default, see “User Settings,” p. 100, for details. (Disabled if no Preview 
window is activated.)

Fit Height to Window
Resizes the Preview window to fit the height of the main Cumulus window. Can 
be set as default, see “User Settings,” p. 100, for details. (Disabled if no Preview 
window is activated.)

Full Screen
Displays a preview using the whole screen. (Disabled if no Preview window is 
activated.)
TIP: 
To view multiple assets at once, use Asset > Fullscreen Preview. 

Categories
Opens a submenu. 

Expand
Expands the selected categories to reveal subcategories. This works the same 
way as clicking on the arrow icon to the left of the parent category. (Disabled if 
no parent categories are selected.)
TIP: To expand all categories under a parent category, press the ALT / 

Option key when clicking on the category arrow icon.
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Expand All
Expands all parent categories to reveal subcategories. (Disabled if all parent cat-
egories are already expanded.)

Collapse
Collapses the selected parent categories to hide subcategories. This works the 
same way as clicking on the arrow down icon to the left of the parent category. 
(Disabled if no expanded parent categories are selected.)
TIP: To collapse all categories under a parent category, press the ALT / 

Option key when clicking on the category arrow icon.

Collapse All
Collapses all parent categories to hide subcategories. (Disabled if all parent cate-
gories are already collapsed.)

The Find Menu

Find Records
Opens or activates the Record Find window. (See “Searching with the Find Win-
dow,” p. 33, for details.)

Find All Records
Resets the current selection of records to the entire contents of the catalog(s) 
opened in the collection. This is useful after a search operation has reduced the 
number of visible records.

Find Records by Query
Opens a list for selecting a record query that will be performed immediately. (Dis-
abled unless at least one record query is saved.)

Find Records Assigned to Categories 
Finds all records that are associated with the selected categories. This is the 
menu equivalent to double-clicking on categories. (Disabled unless one or more 
categories are selected.) 

Find Duplicates
Searches the current collection for records with the same record name (the 
assets and asset names may be different). The search result will replace the cur-
rent collection. 

NOTE: This function may take a while. Hence, we suggest that you put up a 
collection that fits this search before starting this function. 

Find Records with Invalid Field Values
Checks all records of the current collection for any field value that is invalid 
according to the defined field validators. 
This function will find any record with invalid field values, even if the field in ques-
tion is not displayed in the current Record View Set.
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NOTE: You may also check for invalid records on a regular base using the 
scheduler action Find Invalid Items.

Find Offline Assets
Searches the current collection for records with asset references that cannot be 
resolved. The search result will replace the current collection. 

NOTE: This function may take a while. Hence, we suggest that you put up a 
collection that fits this search before starting this function. 

Invert Collection
Searches for all records (of the catalogs opened in the collection) that are not 
contained in the current collection and replaces the current collection with this 
search result. With one click you can obtain all records that are not currently 
shown.

Find Categories 
Opens or activates the Category Find window.

Find All Categories
Resets the current selection of categories to the entire contents of the catalog. 
This is useful after a search operation has reduced the number of visible catego-
ries.

Find Categories by Query
Opens a list for selecting a category query that will be performed immediately. 
(Disabled unless at least one category query is saved.)

Show Original Category
Finds and highlights the original category of a selected related category. (See 
“Category Types,” p. 24.)

Show Related Categories
Finds and highlights the selected category’s related category or categories. (Dis-
abled unless a category is selected.) 

Show Categories Containing
Opens a dialog. In this dialog you can type a string of text that you would like to 
search for in all category names of the active catalog. Categories whose names 
contain the text string are highlighted. Related categories are included in the 
search.
For example: Typing “oa” would find categories called “Boats” and “Oasis.” 

Remove from Collection
Removes the record/category from the current collection but not from the catalog. 
(See “Delete,” p. 178, for deleting a record/category from a catalog.)
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The Metadata Menu

Information
Depending on the active pane this menu item opens the Asset Information win-
dow or the Category Information window for the selected record/category.
Category Information window – For further information, see “Category Informa-
tion Window,” p. 26. 
Asset Information window (Menu equivalent to the toolbar icon.) – For further 
information, see “Asset Information,” p. 18, and “Editing Asset Information,” p. 20.)

Viewing and Editing Multiple Records 
If you have selected multiple records before opening the Asset Information win-
dow, you can change the field values for multiple records at once. But this is only 
possible, if in your User Settings for the Display of the Asset Information window 
the option Only One Window is activated and Display values identical for all 
selected records is checked. 
If the asset information of multiple records is shown in one window, only field 
contents which have the same values are displayed. So the Asset Reference and 
Thumbnail fields will always be empty. Check boxes (Boolean fields) with differ-
ent values appear gray. The field Categories only displays categories that the 
selected records have in common. All other field types are displayed with no 
value if there are different values for fields.
Fields with different values do not show a value but can be edited – this also 
applies to gray (neutral) check boxes. If you add an additional category, this cat-
egory is added to the set of categories for each record.
If you add any text to a field that already contains values for one of the selected 
assets, you are asked whether you want the new text to replace the existing value 
or to be appended to the existing text.

IPTC Information
Opens the IPTC Information window that provides special access to the IPTC 
information on the asset(s) stored in the selected record(s). (Disabled when no 
record is selected.) See “Using the IPTC Information Window,” p. 93, for details. 
For a description on how to prepare a catalog for IPTC, see “For IPTC,” p. 176.

Bulk Edit
Opens a dialog to edit metadata of previously selected records. 
The Bulk Edit dialog shows the same fields as the Asset Information Window of 
the current Record View Set – but only if they are user editable.
For each field you can decide how its value is dealt with (default: Keep Current 
Value). Click the icon on the left to have the available options displayed and to 
choose from them. Note that these options vary slightly according to the type of 
field selected.
You can either choose an editing option and then enter the desired value, or you 
can start with entering a value (which automatically turns the editing options to 
Replace Current Value) and select the desired editing option later.
However, with the Categories field the first step is always to select the desired 
editing option and then to use drag & drop or the Add and Remove buttons to 
configure a set of categories to be assigned to or removed from the record.



MENU REFERENCE –  THE METADATA MENU 191
NOTE: Be carefully with the Replace Current Value and the Clear Current 
Value options! These options delete all existing category assignments and 
cannot be undone. 

Employing MetadataTemplates
You can use the metadata template icon in the lower left corner of the Bulk Edit 
dialog to prefill the fields with values from a selected metadata template. You 
may then edit theses values as necessary.

NOTE: Regardless of the actual content of the metadata template, only values 
for fields that are included in the Bulk Edit dialog are taken into account. 

Update Record
Opens a submenu with functions to refresh the selected records with the asset’s 
up-to-date information. This can be necessary if catalog settings have changed, 
but also if assets have been modified since they were cataloged. Records of 
unavailable assets cannot be updated. (The menu item is disabled if no records 
are selected.)

Update Updates the selected records according to the settings specified in the Prefer-
ences (User Settings > General > Application > When Updating). Depending 
on the settings specified for the current catalog (User Settings > Asset Handling), 
you may be prompted to select an Asset Handling Set.

Advanced Opens a dialog to specify settings for the current update process. The settings 
defined in this dialog will not affect the settings defined in the Preferences.
Define the settings according to your needs, then click OK to perform the 
update.

NOTE: If the Asset Handling Set used for the update does not provide the cor-
rect settings for creating records for pages/slides (e.g. because the required 
Asset Storage Module is not activated), the records representing the individual 
pages will be deleted. Because this might not be the intended result, Cumulus 
shows a list of the records that are to be deleted. Either confirm the deletion, or 
cancel the complete update process, or select single records on this list to con-
firm their deletion only. 

Update Formula Fields
Updates all fields containing formulas in the selected records, no matter whether 
these fields are currently displayed or not. A dialog is displayed which lets you 
choose whether the Record Modification Date should be changed accordingly 
or not. (By default, the Record Modification Date is not changed.)

Write back Metadata 
Writes metadata from the selected records back to the related assets or metadata 
container, e.g. XMP files. Opens a dialog to specify an appropriate Asset Handling 
Set and optionally to select the metadata fields that should be written back. (Dis-
abled if no Asset Handling set is available that has enabled the writing back 
metadata option.) 
When writing back metadata to assets, be aware of the following:
• Metadata can be written back to assets only

• if the assets are not write protected or stored on a write protected volume 
or media.

• if Cumulus has direct access to the assets (no Server/Client Asset Transfer).



192 CANTO® CUMULUS SINGLE USER GUIDE
• Some IPTC and XMP metadata fields overlap. All assets that have been edited 
with applications of the Adobe Creative Suite contain both IPTC and XMP 
metadata. When writing back metadata to such assets, make sure that both 
the Cumulus IPTC and the XMP filter are activated. If not, the IPTC and XMP 
data stored in the asset might differ.

NOTE: Captured IPTC and XMP metadata!
As some image files contain IPTC as well XMP metadata in different blocks, and 
some metadata information is stored in both blocks, the metadata captured 
by different applications might differ. Some applications give priority to XMP 
(e.g. Adobe Creative Suite). With a standard installation, Cumulus captures 
IPTC metadata prior to XMP. If you want to alter the priority to XMP, you have 
to change the order of the formats for the Asset Handling Set employed for cat-
aloging. In the Asset Formats list of the Asset Handling Set, the entry for the 
Extensible Metadata Platform format supported by the XMP filter has to have 
a lower entry number than the first format supported by the IPTC filter. This is 
due to the fact that Cumulus starts searching for matching formats at the low-
est entry number. (See “Asset Format Support,” p. 122, for further details.) 

Assign Metadata From Template 
Open a dialog to select the metadata template to be used for filling. For further 
information, see “Using a Metadata Template,” p. 21. 

Find And Replace Metadata
Finds certain information stored on assets in selected records and replaces it with 
information entered by the user. 

1. Select one or more records.

2. Select Metadata > Find And Replace Metadata. A dialog opens.

3. Select the field that stores the information you want replaced. Clicking the 
arrow button reveals a list of all editable String fields of all open catalogs.

4. Enter the text to be replaced in the Text to find field.

5. Enter the replacement text in the field Replace with.

NOTE: You may enter \n for a line break. 

FOR SPECIALISTS ONLY: If you activate the Use Regular Expression check-
box, you can enter regular expressions (Perl 5 like) in the Text to find and 
Replace with fields. For a description on using regular expressions, please 
refer to the special literature available in book stores and on the Web.

6. Click Start. Cumulus starts to search for the entered text in the selected field 
of the selected records. You will get a notice for each of the selected records 
whether the text was replaced or not. Replacements are not necessary if the 
text to be replaced wasn’t contained in the selected field or if a record is 
stored in a catalog that does not provide the selected field.

7. Click Close to finish.

Assign Label
Opens a submenu for selecting the labeling you want to assign to the select 
record(s). (Disabled if no Labeling field is included in the catalog or if the effects 
of assigning the label cannot be immediately seen by the user.) For more infor-
mation, see “Labeling,” p. 77. 
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Assign Rating 
Opens a submenu for selecting the rating you want to assign to the select 
record(s). You can rate assets from 1 to 5. (Disabled, if no Rating field is included 
in the catalog.) For more information, see “Rating Assets,” p. 78. 

Assign Categories
Assigns a selection of records to a selection of categories, or vice versa. (This is 
the opposite of “Detach Categories.’)  

NOTE: If you have a large number of records (more than 500) you want to 
assign, it is better that you use this function rather than drag and drop. 

1. Select one or more records.

2. Select one or more categories to which you want to assign the selected 
records.

3. Select Metadata > Assign Categories. The records are assigned to each of 
the categories in the selection.

Detach Categories
Detaches a selection of records from a selection of categories, or vice versa. (This 
is the opposite of “Assign Categories’.) 

1. Select one or more records.

2. Select one or more categories which you want to detach from the selected 
records.

3. Select Metadata > Detach Categories. The records are detached from each 
of the categories in the selection.

Optimize Thumbnail
Equalizes the appearance of the selected records’ thumbnails. This is useful for 
thumbnails that are too dark, too light, or lacking contrast. The action cannot be 
undone, but you can force-update the record to get back the original thumbnail. 
(Disabled if no records are selected.) (See “Update Record,” p. 191, for information 
on updating a record, including its thumbnail.)

Rotate Preview
Rotates the selected preview’s images in one of three ways:
• 90° clockwise
• 90° counter-clockwise
• 180° 
(Available only in Preview view or when the Preview window is open.)

Rotate Thumbnail
Rotates the selected records’ thumbnail images in one of three ways:
• 90° clockwise
• 90° counter-clockwise
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• 180° 
(Disabled if no records are selected.)
The record field Thumbnail Rotation saves the rotation value for a rotated 
thumbnail. The rotated thumbnail will be used for previewing, printing, export-
ing to HTML and creating slide shows.

NOTE: Catalogs Created with Versions Prior to Cumulus 5.5!
If the field Thumbnail Rotation (for storing the rotation value) should be 
available with catalogs that have been created with previous versions, this 
record field has to be added to the catalog. The field is then empty. There are 
two ways to fill it out:
– Either, open the Asset Information window and enter the according value 
(degree of rotation) manually.
– Or, select Metadata > Update Record. This will set the thumbnail back to 
the asset's orientation. Then rotate the thumbnail again. The value of the rota-
tion will then be stored in the Thumbnail Rotation field. 

Assign Variants
Assigns variants to an asset. The asset to which other assets are assigned is called 
the source of the variant. 

1. Select the records of the assets you want to assign as variants to a source 
asset

2. Select Metadata > Assign as Variants. Then a message prompts you to 
select the source. 

3. Select the record you want to be assigned as the source of the variants and 
click OK.

To have the variants of an asset displayed, open a subpane and select a corresponding 
Sub-Pane Filter. For more information on asset relations, see “Managing Related 
Assets,” p. 78.

Assign Alternates
Assigns alternates to assets and lets you define a preferred alternate. 

1. Select the records of the assets you want to become alternates.

2. Select Metadata > Assign Alternates. Then a message prompts you to 
select the preferred alternate.

3. From the selected records, select the one you want to be the preferred alter-
nate and click OK.

To have the alternates of an asset displayed, open a subpane and select a correspond-
ing Sub-Pane Filter. For more information on asset relations, see “Managing Related 
Assets,” p. 78.

Show Related
Opens a submenu displaying the available sub-pane filters. Once you have cho-
sen a filter, a sup-pane displays the records of related assets according to the 
selected sub-pane filter.
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New Category
Creates a category under the currently selected category, named “Category”. This 
name can be changed immediately to a more fitting one. (Disabled unless a sin-
gle category is selected.)

New Related Category
Makes a related category for each of the currently selected categories. (Disabled 
unless one or more categories are selected.) (See “Category Types,” p. 24.)

The Asset Menu

Preview
Opens a Preview window for each selected record. The records’ assets must be 
available to display the Preview window. (Menu equivalent to the toolbar icon.)
The contents of the window opened depends on the asset type and on the 
active Record View Set. (For a description on how to configure the view of the 
Preview window see “Record View Sets,” p. 105.)
Image previews can be zoomed in or out and displayed in different sizes and you 
can add user comments. For more information, see “Preview View and Window,” 
p. 52.

Fullscreen Preview
Shows assets as fullscreen previews. You can display up to six different assets at 
once. The records’ assets must be available to display. 
What is displayed depends on the asset type and on the active Record View Set. 
(For a description on how to configure the view of the Preview window see 
“Record View Sets,” p. 105.)
For more information, see “Fullscreen Preview,” p. 54.

Fullscreen Slide Show
Shows assets as fullscreen previews in a slide show. The records’ assets must be 
available to display. (Menu equivalent to the toolbar icon.)
What is displayed depends on the asset type and on the active Record View Set. 
(For a description on how to configure the view of the Preview window see 
“Record View Sets,” p. 105.)
For more information, see “Fullscreen Slide Show,” p. 56.

Image Editor
Opens the selected image asset in a special window that allows you to edit the 
image. The Image Editor offers image cropping as well as calibration tools that 
can enhance the color, sharpness and brightness of your images. For details see 
“Editing Images,” p. 90. 

Compare Previews
Opens the selected two image assets along with a comparison image in 
fullscreen view. For details see “Comparing Previews,” p. 56. (Disabled if less or 
more than two records are selected.)



196 CANTO® CUMULUS SINGLE USER GUIDE
View With
Opens a submenu with options for choosing an application for viewing the 
selected asset. (Disabled if no records are selected.)

Creating Application
Opens the selected records’ assets with the application that created the assets (if it 
is known and available).

Other
Opens a dialog to choose an application with which to view the selected records’ 
assets. 

Customize
Lets you customize the options in the View With menu. You can add and delete 
applications. 

Edit With
Opens a submenu with options for choosing an application for opening and 
editing the selected asset. (Disabled if no records are selected.)

Creating Application
Opens the selected records’ assets with the application that created the assets (if it 
is known and available) and lets you edit the asset.

Other
Opens a dialog to choose an application with which to open and edit the selected 
records’ assets. 

Customize
Lets you customize the options in the Edit With menu. You can add and delete 
applications. 

Print With
Opens submenu with options for choosing an application. (Disabled if no 
records are selected.)

Creating Application
Prints the selected records’ assets with the application that created the assets (if 
it’s known and available.)

Other 
Opens a dialog to choose an application with which to print the selected records’ 
assets. 

Customize
Lets you customize the options in the Print With menu. You can add and delete 
applications. 
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Perform Asset Action
Opens a submenu that lists Cumulus Assets Actions. Selecting an Action from 
that submenu will perform it. For further information, see “Using Asset Actions,” 
p. 50.

TIP: 
You can easily access the preferences of Asset Actions by selecting the 
Customize entry in the submenu for selecting an Action. This entry 
opens the preferences for the current Action.

Convert To
Opens a dialog for converting the asset associated with the selected record to 
another file format. The target formats depend on the availability of Cumulus 
Converter modules. Before you decide on the Converter module, you specify the 
location for the converted file.
The offered modules depend on the AssetProcessor modules activated for the 
Asset Handling Set selected for asset access in your user settings. Following Con-
verter modules are available:
• Pixel Image Converter (For more information, see “Converting Image Assets,” 

p. 58)
• Watermark AssetProcessor (For more information, see “Watermarking 

Assets,” p. 62)
• ZIP AssetProcessor (For more information, See “Creating ZIP Archives,” p. 64.)

NOTE: If you have selected multiple assets' records, the chosen settings will be 
applied to convert all selected assets. 

Mail To
Use this option to attach an asset to an outgoing e-mail message. Cumulus 

launches your e-mail application (in case you have more than one, offers you 
a menu to select) / launches your default e-mail application.

Copy To
Copies the selected records’ assets to the location specified in the dialog that 
appears. The original assets are left alone. (Disabled if no records are selected.)

Copy Assets Assigned to Category To 
Opens a dialog in which you can choose a destination. Cumulus then copies the 
assets of records that are associated with the selected categories to the location 
you selected. The assets are saved in folders named for the categories selected.
This option is handy for collecting production files for output (assuming the files 
all have at least one common category, such as project name). (Disabled if no cat-
egory is selected.)

Duplicate Asset and Record
Duplicates the asset of the selected record and the record itself. A dialog appears 
in which you can choose a name and set several options for the new asset and 
record
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Activate Copy Record Metadata to copy the metadata from the original to the 
duplicated record, except creation date and modification date.
Activate Update Record to update the metadata in the duplicated record from 
the duplicated asset.
Activate Assign as Variant to assign the duplicated asset as a variant to the orig-
inal asset.
Activate Assign as Alternate to assign the duplicated asset as an alternate to the 
original asset.

Create WebAlbum
Opens a dialog in which you can create a Web Album. For further information, 
see “WebAlbum,” p. 65.

Show Location
Locates the selected records’ assets and displays them in the Mac OS X Finder or 
Windows Explorer. (Disabled if no records are selected.)

TIP: Show Location of Folder Category
The context menu for categories offers a similar function for folder cat-
egories. The selected category’s folder is displayed, e.g., in the 
Mac OS X Finder or Windows Explorer. (Disabled if no folder category 
is selected.)

Move To
Copies the selected records’ assets to the location specified in the dialog that 
appears and updates the records’ asset references to point to the new location. 
The original assets are deleted. (Disabled if no records are selected.)

Rename
Opens a submenu. 

Single
Opens a dialog to rename the asset represented by the selected record. If asset 
name and record name are the same, the record name will be changed accord-
ing to the asset name.

Batch 
Opens a dialog to rename one or multiple assets represented by the selected 
records. If asset name and record name are the same, the record name will be 
changed according to the asset name.
The list on the left offers different name components for the new asset name(s). 
The list on the right displays the name components used for the renaming. 
Select the component you want to use in the left list and click the arrow button. 
The selected components are displayed in the right list. Each selected compo-
nent has to be defined before you can start the renaming. To define a compo-
nent, select it in the right list and click Properties. For each component, a 
different window is opened to define its properties. 
The result of your definitions is displayed under Preview. Once your definitions 
are as you like them, you have to decide what you want Cumulus to do if the 



MENU REFERENCE –  THE ASSET MENU 199
name or one of the names created according to your definitions already exists in 
the folder where the asset to be renamed resides. Cumulus can either skip the 
renaming of this asset or add an auto number to the name of the renamed 
assets. 
If any assets can not be renamed (due to e.g. no writing rights or not writable 
storage media), a new category is created named Rename – Skipped Assets and 
inside a subcategory indicating date and time of the process to which the assets 
are assigned.
The definitions you made for renaming can be saved as a set. Using the icons, 
you can save the definitions as a set or open a saved set for renaming of the 
selected records. You can also open an existing set, modify it and then save it 
under a new name by using the Save As icon.

Update Asset Reference(s)
Updates the path used to find the selected asset files, e.g when assets have been 
moved. Asset references can only be updated if the assets are available. (Disabled 
if no records are selected.)
Opens a dialog to specify how to proceed if asset references cannot be resolved:

• Assign record to special category – Records with unresolvable asset refer-
ences are assigned to a special category named Update reference -Skipped 
Assets and can be processed later. All other records are properly updated.

• Ask for asset location – The update process stops on every unresolvable 
asset reference and asks for the appropriate location

• Skip record – Records with unresolvable asset references are ignored. All 
other records are properly updated.

 Change Asset Reference
Opens a submenu. 
This function allows you to update selected records to reflect a new location of 
their assets. This is useful if you have cataloged assets from a remote drive or vol-
ume that has since been renamed or have simply moved cataloged assets to a 
new location (and did not use Cumulus for moving them). Without this function, 
the records would still “point” to the old asset paths. This function does not over-
write, move or otherwise affect asset files at all. You can either change the asset 
reference for a single asset by selecting an asset or you change the asset refer-
ences for multiple assets through a batch process.

Select Single
Opens a dialog to browse for the asset that should be represented by the 
selected record.
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Batch 

1. Select the records that still point to the old location of the assets.

2. Select Asset > Change Asset Reference. 

3. Select Batch. 

A dialog appears asking you for the new location. The new location is 
defined in relation to the old location stored as asset reference.

• Server/Volume (under Windows only)
In case the assets now reside on another location in the Network, you have 
to activate the Network Option and then: 
a) if the assets now reside on another server (but a volume with the same 
name), activate the New Server option and enter the name of this new 
server into the field on the left.
b) if the assets now reside on another volume (but still on the same server), 
activate the New Volume option and enter the name of this new volume 
into the field on the left.
c) if the assets now reside on another server and another volume, activate 
both the New Server and the New Volume option and enter the names 
into the corresponding fields on the left.
In case the assets now reside on another local location, you have to acti-
vate the Local Option and then if the assets now reside on another drive, 
activate the New Drive option and select this new drive.

• Volume (under Mac OS X only)
In case the assets now reside on another volume, activate the New Volume 
option and select this new volume.

• Folder Settings
– Activate the Keep Existent option if the assets now reside in the same 
directory structure as they did before.
– Activate the None option if the assets now reside directly in the volume/
drive selected above (and not in any subdirectories).
– Activate the Add Parent option if the assets now reside in the same direc-
tory structure as they did before but this structure is now nested into 
another. The Add Parent option lets you enter the path of the directory 
that now nests the “old” directory structure.
– Activate the New option if the assets now reside in just one new directory 
(and not in any subdirectories). The New option lets you browse for the 
new directory by clicking the  button.

4. After you select the options you want, click Start. 

The application searches for the assets represented by the selected records in the 
new location and updates the records to the new location. If an asset is not found 
in the new location, a new category is created named Change Reference – 
Skipped Assets and inside a subcategory indicating date and time of the process 
to which the asset is assigned.

Transform JPEG Original
Opens a submenu that allows you to rotate or flip the original asset if the asset is 
a JPEG file you have direct access to. The transformation will transverse the JPEG 
lossless. 
The Advanced item opens a dialog to specify further settings.
Along with the transformation of the asset, its record will be updated as well. The 
thumbnail will be updated and resemble the transformed asset – regardless of 
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whether the thumbnail was rotated before. The following record fields will be 
updated with the new values: Horizontal Pixel, Horizontal Resolution, Image 
Height, Image Width, Thumbnail Height, Thumbnail Rotation, Thumbnail Width, 
Vertical Pixel, and Vertical Resolution.

The Help Menu

Contents and Index
Opens the table of contents and searchable index window for Cumulus’ online 
help system. 

NOTE: The Cumulus help system is based on HTML pages that can be viewed 
with any standard Web browser. However, if you employ any pop up blockers, 
the display of the help system may not be possible. 

Source
Opens a submenu that offers the options for the source of the Cumulus help sys-
tem you use. Select the desired:

Online
Cumulus help comes from the Canto website, where the latest updates will 
always be available. (This requires an Internet connection.)

Local
Cumulus help comes from your hard drive – if you had it installed with your 
Cumulus application. 

About 
Displays a dialog that shows the version of Cumulus you’re using. You can get 
detailed version information by clicking the More button. It also provides a but-
ton that launches your default Web browser and initiates a connection to the 
Canto Web site. This requires an Internet connection. (See the Microsoft Win-
dows documentation for information on setting your default Web browser.)

License 
Presents a dialog in which you can view and edit your Canto Cumulus Single User 
license information. 
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Keyboard Shortcuts
This appendix gives a list of keyboard shortcuts to common menu

commands and options. 
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Windows Mac OS X

Collection Window – Record Pane
Thumbnail View Ctrl+1 Cmd+1

Details View Ctrl+2 Cmd+2

Information View Ctrl+3 Cmd+3

Preview View Ctrl+4 Cmd+4

Open Information window Ctrl+I Cmd+I

Open IPTC Information window Ctrl+Shift+I Cmd+Shift+I

Open Preview window Ctrl+Y Cmd+Y

Open Fullscreen Preview window Ctrl+Shift+Y Cmd+Shift+Y

Open Record Find window Ctrl+F Cmd+F

Show location Ctrl+R Cmd+R

Open asset with creating application Ctrl+E Cmd+E

Connect to server Ctrl+Shift+O Shift+Cmd+O

Open catalog Ctrl+O Cmd+O

Catalog assets Ctrl+B Cmd+B

Print Ctrl+P Cmd+P

Display all records Ctrl+G Cmd+G

Select all Ctrl+A Cmd+A

Deselect all items Ctrl+Shift+A Shift+Cmd+A

Deselect one item Ctrl+spacebar     ---

Hide Cumulus     --- Cmd+H

Hide others     --- Alt+Cmd+H

New empty collection Ctrl+Shift+N Shift+Cmd+N

Close collection window Ctrl+F4 Cmd+W

Exit Cumulus Alt+F4 Cmd+Q

Undo Ctrl+Z Cmd+Z

Cut Ctrl+X Cmd+X

Copy Ctrl+C Cmd+C

Paste Ctrl+V Cmd+V

Edit Preferences Ctrl+, Cmd+,

Delete record from catalog Ctrl+Del Cmd+Del

Remove record from collection Del Del

Delete record from catalog without asking (same com-
mand as Cut)

Shift+Del Cmd+X

Assign rating: 1 star Ctrl+Alt+1 Alt+Cmd+1

Assign rating: 2 stars Ctrl+Alt+2 Alt+Cmd+2

Assign rating: 3 stars Ctrl+Alt+3 Alt+Cmd+3

Assign rating: 4 stars Ctrl+Alt+4 Alt+Cmd+4

Assign rating: 5 stars Ctrl+Alt+5 Alt+Cmd+5

Assign rating: no stars (no value) Ctrl+Alt+N Alt+Cmd+N

Start/quit Palette Mode Shift+Ctrl+P Shift+Cmd+P

For Thumbnail display

– use next larger size + +

– use next smaller size  - -

– rotate 90° clockwise Ctrl+Alt+R Alt+Cmd+R

– rotate 90° counterclockwise Ctrl+Shift+R Shift+Cmd+R

– rotate 180° Ctrl+Alt+Shift+R Shift+Alt+ Cmd+R

Change to next window Ctrl+Tab/Ctrl+F6  – – –

Thumbnail view 
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Go to previous record arrow left arrow left

Go to next record arrow right arrow right

Go to record above arrow up arrow up

Go to record below arrow down arrow down

Details view: 

Go to previous record arrow up arrow up

Go to next record arrow down arrow down

Go to first page (unmarked) Alt+Home Alt+Home

Go to previous page (unmarked) Alt+arrow left Alt+arrow left

Go to next page (unmarked) Alt+arrow right Alt+arrow right

Go to last page (unmarked) Alt+End Alt+End

Go to first page (marked) Home Home

Go to previous page (marked) PgUp PgUp

Go to next page (marked) PgDn PgDn

Go to last page (marked) End End

Assign categories Ctrl+Shift+5 Shift+Cmd+5

Detach categories Ctrl+Shift+6 Shift+Cmd+6

When dragging & dropping an OPI file into another applica-
tion:
– place high resolution file 
– place low resolution file

– – –
– – –

Alt+H
Alt+L

Toggle: category and record pane Tab Tab

Collection Window – Category Pane
Create new category Ctrl+J Cmd+J

Expand all categories Ctrl+Alt+X Alt+Cmd+X

Collapse all categories Ctrl+Alt+C Alt+Cmd+C

Category search for previous category Alt+arrow up Alt+arrow up

Category search for next category Alt+arrow down Alt+arrow down

Category search for selected category Enter Enter

Enterprise: Remove categories from collection 
Workgroup: Delete categories

Del Del

Delete categories Ctrl+Del Cmd+Del

With collapsed category: 
Go to category of next higher level 
With expanded category:
Collapse category

arrow left arrow left

With collapsed category: 
Expand category 
With expanded category:
Go to next subcategory

arrow right arrow right

Go to previous category arrow up arrow up

Go to next category arrow down arrow down

Go to first category (unmarked) Ctrl+Home Cmd+Home

Go to previous category page (unmarked) Ctrl+PgUp Cmd+PgUp

Go to next category page (unmarked) Ctrl+PgDn Cmd+PgDn

Go to last category (unmarked) Ctrl+End Cmd+End

Go to first category (marked) Home Home

Go to previous category page (marked) PgUp PgUp

Go to next category page (marked) PgDn PgDn

Go to last category (marked) End End

Collection Window
Show/hide Category pane Ctrl+F3 Cmd+F3

Show/hide Information pane Ctrl+F7 Cmd+F7

Windows Mac OS X



206 CANTO® CUMULUS SINGLE USER GUIDE
Show/hide Category Information pane Ctrl+F8 Cmd+F8

Show/hide Thumbnail pane Ctrl+F9 Cmd+F9

Show/hide Preview pane Ctrl+F10 Cmd+F10

Show/hide Calendar pane Ctrl+F11 Cmd+F11

Show/hide Collection Basket pane Ctrl+F12 Cmd+F12

Use Default Workspace Ctrl+F1 Cmd+F1

Assign categories Ctrl+Shift+5 Cmd+Shift+5

Detach categories Ctrl+Shift+6 Cmd+Shift+5

Information Window / View/Pane
Save changes Ctrl+S Cmd+S

Print Information window Ctrl+P Cmd+P

Load information on

– first record in collection Alt+Home – – – 

– on next record in collection Alt+arrow right – – – 

– on previous record in collection Alt+arrow left – – – 

– on last record in collection Alt+End – – – 

Go to next field Tab Tab

Go to previous field Shift+Tab Shift+Tab

Preview Window and Preview Fullscreen
Load preview of

– first record in collection Home Home

– previous record in collection PgUp /
Alt+arrow left

PgUp /
Alt+arrow left

– next record in collection PgDn /
Alt+arrow right

PgDn /
Alt+arrow right

– last record in collection End End

100% display Alt+Ctrl+0 Alt+Cmd+0

Fit to main window Ctrl+0 Cmd+0

Zoom in Ctrl++ Cmd++

Zoom out Ctrl+- Cmd+-

Scroll in preview arrow keys arrow keys

Preview Window only
Print preview Ctrl+P Cmd+P

Edit with creating application Ctrl+E Cmd+E

Preview Fullscreen only
Start/stop loop spacebar spacebar

Close fullscreen mode Escape Escape

Multi-page Previews
Load first page of preview Alt+Shift+Home Alt+Shift+ Home

Load previous page of preview Alt+Shift+arrow left Alt+Shift+ arrow left

Load next page of preview Alt+Shift+arrow right Alt+Shift+ arrow right

Load last page of preview Alt+Shift+End Alt+Shift+End

Windows Mac OS X



Glossary
This Glossary offers an alphabetical listing of terms and phrases used

throughout this manual and Cumulus.
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Action 
Function or combination of certain functions. Cumulus provides different types 
of actions. See also Asset Action.

Asset
A general term describing any type of digital media (including graphic, page lay-
out, presentation, sound, and video files) that has value to its owner. 

Asset Action
Combination of certain functions saved under a chosen name that is performed 
on assets in Cumulus. 

Asset Handling Module
When cataloging and accessing assets, Cumulus uses different modules: Asset 
Storage, Asset Processor, Metadata and Filter modules. 

Asset Handling Set
A setting that defines how assets are handled – during the cataloging process 
and when accessing assets.

Asset Information
The information about an asset as stored in the record associated with the asset.

Asset Information window
A special window that displays the information about a cataloged asset. This 
information is stored in the asset’s record. (See also Record.) Cumulus also pro-
vides an Information View and an Information Pane.

Asset Reference
The mechanism by which Cumulus tracks the actual location of an asset man-
aged in a Cumulus catalog.

AXR (Asset Cross References)
Automatic detection of usage and cross-references of assets within Cumulus. 
Cumulus is able to detect links and placed assets in compound documents such 
as QuarkXPress, EPS, Adobe InDesign, and Illustrator (version 8, 9) as well as 
Microsoft Word and PowerPoint documents. 

Boolean
A system of logic based on two possible values: true or false. Cumulus uses the 
Boolean operators "and" and "or" to combine search conditions.

Cache
A temporary storage area where frequently accessed data can be stored for rapid 
access.

Catalog
A special file (with the extension .ccf ) that Cumulus creates to manage cataloged 
assets. See also Asset and Cumulus Catalog File.

Catalog file name
Name of the special file for a catalog (  with the extension .ccf). The catalog 
name defaults to this file name (without the extension). The catalog name can 
be changed without changing the catalog file name. See also Cumulus Catalog 
File.
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Cataloging
The process by which a user adds one or more assets to a catalog. 

Category
Cumulus categories are used to organize records, much like folders are used to 
organize files in a traditional filing cabinet. But the asset can appear in any num-
ber of Cumulus categories at one time. They are similar in purpose to keywords 
used in other programs. See also Folder category and Related category.

Category Information window
A special window that displays the information about categories.

Category Exchange File
See Cumulus Category Exchange File. 

Category pane
Located on the left side of the Collection window. The Category pane displays 
category names in a hierarchical list. Multiple tabs are provided so that categories 
can be created and displayed in separate tabs.

Category View Set 
A setting that defines the display options for the Category Information window. 
For each tab different display options can be set.

Central asset location
A central asset location is a single storage location used to store certaindigital 
assets. Employing a central asset location ensures your assets remain accessible 
to all, and can more easily be accounted for.

Client
A computer user who accesses a server application (such as the Cumulus Server) 
across a network.

Collection
Any set of records from any one catalog, including their display properties. A col-
lection can be saved (see Cumulus Collection File) and opened again. A collec-
tion – whether saved or unsaved – is always connected to its catalog. In order to 
open a particular collection you must have access to its catalog.

Collection window
A window featuring two panes (Category pane and Record pane) that function 
as the central user interface. 

Compound search
A search query consisting of two or more search conditions.

Context menu
Also called shortcut menu. A menu that opens when clicking the right mouse 
button /  Control key + mouse button. The available options are related to the 
selected object.

Cumulus 
An indispensable digital asset management system for organizing and manag-
ing digital assets. See also Asset.
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There are different editions of Cumulus designed to meet the needs of anyone 
who wants to keep track of their digital media. 

Cumulus application window
The main Cumulus window containing the menu bar, the toolbar, the statusbar, 
and – as “child” window(s) – the Collection window(s) with various panes.

Cumulus Action
See Asset Action.

Cumulus Catalog File
A special file(with the extension .ccf) that Cumulus creates to manage cataloged 
assets (digital media).

Cumulus Category Exchange File
A file (  with the extension .cce) that Cumulus creates when exporting category 
information.

Cumulus Collection File
A special file (  with the extension .cfe) that Cumulus creates to manage saved 
collections.

Cumulus Record Exchange File
A special file (  with the extension .cre) that Cumulus creates when exporting 
record information.

Details view
Each record appears in the Record pane as a text listing that includes fields you 
can define (e.g., record name, file format, resolution, etc.). See also Thumbnail 
view.

Drag and Drop
A way to move user-interface objects by dragging them with the mouse and 
dropping them into targets.

EJaP
Embedded Java PlugIn. Technology that provides unlimited possibilities to add 
new functionality or to integrate Cumulus into workflows. EJaPs are Java code 
that runs within the Cumulus application. 

EJSP
Embedded Server Plug-In. Technology that provides possibilities to add new 
functionality, or to integrate Cumulus into workflows. ESPs are similar to EJaPs 
(Embedded Java PlugIn). Whereas EJaPs are Java code that runs within the 
Cumulus application, ESPs are Java code that runs at the Cumulus Server. 

EXIF
Exchangeable Image File Format. Standard for storing interchangeable informa-
tion in image files, especially those using JPEG compression. Most digital cam-
eras now use the EXIF format. The format is part of the DCF standard created by 
JEIDA (Japan Electronics and Information Technology Industries Association) to 
encourage inter-operability between imaging devices. Cumulus can read EXIF 
metadata information while cataloging. You can view and edit this metadata. 
See also Metadata.
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Filters
Software utilities that Cumulus uses to capture information about an asset dur-
ing the cataloging process. For more information on the availability of new file 
filters, please see the Canto Website (www.canto.com).

Find window
Cumulus tool that enables users to search catalogs for records or categories that 
match search conditions.

Folder category
Folder categories are automatically created by Cumulus during the cataloging 
process. These automatically created categories resemble the folder or directory 
hierarchy in which the assets reside. They are identified by a smaller folder in their 
icons. They are created by default but this option can be disabled.

FTP
File Transfer Protocol. A standard Internet protocol, which is the simplest way to 
exchange files between computers on the Internet. 

HTTP
HyperText Transfer Protocol. A standard Internet protocol, which is the protocol 
most often used in the World Wide Web to transfer information between servers 
and browsers.

Information window
Special windows that display the information about records or catagories. See 
also Asset Information window,  and Category Information window.

IPTC 
International Press Telecommunication Council. Standard for digital text applied 
to an image. Applications used for professional imaging, support IPTC; e.g. the 
text information in Photoshop is a subset of the IPTC information. Cumulus can 
read IPTC metadata information while cataloging. You can view and edit this 
metadata and Cumulus can write your changes back to the asset. See also Meta-
data.

IPTC Information window
A special window that displays the IPTC information about a cataloged asset. This 
information is stored in the asset’s record. 

Java Server Page
Java Server Page (JSP) is a technology for controlling the content or appearance 
of Web pages through the use of servlets, small programs that are specified in 
the Web page and run on the Web server to modify the Web page before it is 
sent to the user who requested it. 

Media file
Any electronic or digital media file (including graphic, page layout, presentation, 
sound and video files). See also Asset.

Menubar
Appearing at the top of the Cumulus application window, the menubar houses 
menus that contain every program command.
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Metadata
Metadata is any data that helps to describe the content or characteristics of an 
asset. It is the information stored with each asset—such as file name, location, 
etc. Different types of assets have different metadata fields: an image file, for 
example, would contain information on color and resolution, while an audio file 
would have a field for the playback duration.

Palette Mode
View mode that is specially designed for using Cumulus with another applica-
tion, e.g. a desktop publishing application. In palette mode the Cumulus applica-
tion shrinks to a palette that can conveniently be used with another application. 
That way you can easily drag and drop cataloged assets into other applications. 

Path/Pathname
A description of the location where a file is stored on a computer hard drive, 
server, or removable medium (such as CD-ROM, Syquest, Zip, Jaz, or MO car-
tridges).

Preview
A special program mode in which you can examine cataloged assets such as 
video clips, sound files, and image files.

Query
A combination of search conditions. Queries can be saved to disk and loaded 
into the Find window.

Quicklist
A list containing default field values to fill in fields. In Cumulus, available with the 
IPTC Information window.

Record
The actual catalog entry Cumulus creates when an asset is added to a catalog. 
Records store valuable information about an asset, such as the file name, file loca-
tion, file type, resolution, etc. 

Record Exchange File
See Cumulus Record Exchange file.

Record pane
Located on the right side of the Collection window, the Record pane displays 
records as thumbnails or plain text. See also Record, Thumbnail view and Details 
view.

Related category
An alias of an existing category that acts as a virtual cross reference to the original 
category. You can use related categories to place multiple instances of the same 
category under various parent categories, without having to copy the entire con-
tents of the category. By default, the names of related categories are displayed in 
italics with a “(related)” appendix. 

Record View Set
A setting that defines how records are displayed in the different view modes 
Cumulus provides: Thumbnail View, Details View, Info View and Information win-
dow.
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Resolution
The number of pixels per inch in any graphic file format. Higher-resolution files 
have a higher number of pixels per inch than lower-resolution files. Working with 
higher-resolution files usually requires more memory and hard disk space than 
working with lower-resolution files.

Script
A list of instructions executed by a computer. Scripts are used by Cumulus to per-
form complex tasks automatically.

Simple search
A search query consisting of one search condition.

Skin
A term for the particular way in which information is arranged and displayed on 
a computer screen.

Statusbar
A bar providing descriptions on category/record status.

TAG file
The Cumulus Metadata Exchange file format, which Cumulus can create when 
cataloging assets from a location where you are allowed to save files. The file has 
the same name as the asset ( with the extension .tag). TAG files can hold all 
information that can be viewed in the Asset Information window – and more. For 
example, if a particular asset has been cataloged into different catalogs, this infor-
mation is part of that asset’s TAG file. 

Thumbnail
A miniature display of a cataloged asset.

Thumbnail view
The record appears with a miniature display of the cataloged asset in the Record 
pane.

Toolbar
A standard program tool that offers buttons as shortcuts to commonly used 
commands.

Tooltip
A small floating descriptive window that appears above a toolbar button when 
the cursor is positioned over it.

URL
Uniform Resource Locator. The address of a file (resource) accessible on the Inter-
net. 

XMP
Extensible Metadata Platform. Adobe’s XMP™ is a labeling technology that allows 
you to embed metadata into the asset itself. With an XMP-enabled application 
(e.g. all applications of Adobe Creative Suite), information about a project can be 
captured during the content creation process and embedded within the file and 
into a content management system. Cumulus can read XMP metadata informa-
tion while cataloging. You can view and edit this metadata and Cumulus can 
write your changes back to the asset. See also Metadata.
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A
About Cumulus (menu item) 170, 201

Action (menu item) 197

Actions See Asset Actions

Activating
Asset Handling modules 118
Central Asset Location 143

Add Catalog to Collection (menu item) 171

Adding
assets to catalogs See Cataloging
category fields to a catalog 154
record fields to a catalog 154

Alternates 79
assign 82
preferred 79

Alternates tab 82

Application language, switch 175

Archival
explained 166
on CD-ROM 166

Asset Actions
defining 126
editing definition 126
overview 127
setting as default 126
using 50

Asset Cross References
relation types 79

Asset Formats 122
creating 123
of Asset Handling Set 117

Asset Handling Modules 115
activating and deactivating 118
Cumulus Metadata Support 121
Mac OS File System AssetStore 119
MacBinary AssetStore 119
Pixel Image Converter 121
TAR AssetStore 119
UNIX File System 120
URL Support 120
Video AssetSore 120
Watermark Asset Processor 121
Windows File System 120
XMP Support 122

Zip Asset Processor 121
ZIP AssetStore 120

Asset Handling Sets 113
Asset Access tab 116
Asset Formats tab 117
Cataloging tab 116
creating a new one 114
defining 113
editing definition 113
overview 115
selected in User Settings 102
selecting 102
setting as default 114
Thumbnails tab 115

Asset Information 18
editing 20
field types 19
window overview 28

Asset Processor Modules 121
offered when converting 102

Asset References
changing 199

Asset Storage Modules 119

Assets 18
alternates 79

assign 82
archiving 166
cataloging 171

duplicate control during cataloging 116
from FTP or HTTP servers 86

converting 197
copying 197

based on category 197
to an FTP location 89
while cataloging 116

creating own formats 123
deleting 178
different types affecting catalog size 162
drag & drop 50
explained 8
file naming conventions 83
folder/directory naming conventions 84
formats supported 122
fullscreen previews 195
mailing 197

URL-cataloged 88
menu options 195
moving

to an FTP location 89
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to specified location 198
opening for viewing with specified application 196
opening Information window 19
opening URL-cataloged 87
opening with specified application 196
previews 184

zoom in 187
zoom out 187

printing
URL-cataloged 88
with specified application 196

rating 78
relation types 78
renaming 198
resampling 197
Things You Can Do with 23
variants 79

assign 83

Assign Categories (menu item) 193

Auto-cataloging 27

Automatic folder categories, avoiding 154

AXR
relation types 79

B
Backup (menu item) 177

Batch
changing asset references 200
renaming assets 198

Bulk Edit (menu item) 190

C
Calendar pane 180

Calendar Pane (menu item) 180

Canon Raw Metadata Support 98

Canon THM files 98

Catalog Assets (menu item) 171

Catalog Settings
customizing 142
employing a Central Asset Location 144

Catalog Templates 160
creating a new one 160
editing definition 161
using for updating/preparing existing catalogs 161

Cataloging
adding assets via menu item 171
Asset Handling Set

selecting 102
assets from FTP or HTTP servers 86
automatic via folder category 27
copying assets to central location automatically 116
defining Asset Handling Set for 115
increase performance 162
Prefiller options 101

Catalogs 13
archiving 166
assets

adding via menu option 171
select Asset Handling Set 171

backing up 163, 177
Catalog Settings (overview) 143
closing 170
compressing 162, 177
converting to other database engine 165
copying 164
damage prevention 164
deleting 164
dividing 165
explained 9
journaling vs. mirroring 158
maintenance 161
maximum number of records 162
naming 164

catalog names vs. catalog file names 84, 164
legal cross-platform characters 84
renaming 143

new 170
opening 170
opening recent 170
performance issues 13
preparing for EXIF 176
preparing for IPTC 176
preparing for XMP 176
rebuilding 177
reducing size by dividing 165
removing from collections 171
repairing 164
scope of 13
securing 158
settings 142
showing all categories 189
showing all records 188
size, factors affecting 13
Things You Can Do with 13
thumbnail size options 115
updating with Catalog Templates 161

Categories 24
assigning multiple 193
auto-cataloging 27
avoiding automatic folder categories 154
collapsing all 188
collapsing selected 188
copying associated assets 197
deleting from catalog 178
detaching multiple 193
dragging and dropping associated assets 50
editing a record’s category assignments 22
editing information 27
expanding all 188
expanding selected 187
explained 9
exporting 174
fields 26
find names containing 189
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importing 173
information 190
Information pane 180
merging 177
naming (length limit) 25
new 25
opening Information window 26
printing 175
removing records’ category assignments 22
renaming 25
searching for 42
searching with 188
show original for related 189
show related 189
showing all of a catalog 189
showing and hiding 180
synchronizing 173
Things You Can Do with 28
types 24
visible, number of 12

Category Fields
adding to a catalog 154
adding to a view 111
creating 156
defining display properties 112
field types 19

Category Information
window overview 28

Category Information Pane (menu item) 180

Category Tabs
displaying selected 113

Category View Set (menu item) 185

Category View Sets 110
defining 110
editing definition 110

Central Asset Location
activating 143
copying assets to during cataloging 116
employing 144
fields required for Duplicates Control 143
on FTP server 89

Change Asset Reference (menu item) 199

Character Encoding
for Export 71
for ZIP files 65

Close (menu item) 170

Collapse (menu item) 188

Collapse All (menu item) 188

Collapsing
categories 188
panes 81, 179

Collection Basket Pane
show 181

Collection window
delete workspace 183
save default layout 183
save layout as 183
use default layout 183
use layout 183

Collection Window Layout See Workspace

Collections 16
explained 9
inverting 189
new 170
opening 171
removing catalogs from 171
saving 171
saving as 171
showing all categories of entire catalog 189
showing all records of entire catalog 188
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options 101
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URL-cataloged assets 88

Program performance
settings that affect 161

Program performance concerns
catalog size 13
cataloging progress bar, disabling 101
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virtual 143
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Record View Sets 105
creating a new one 106
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selecting in Information window 29
setting as default 107
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archiving 166
asset references, updating 23
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cataloging duplicate control during 116
category assignments, editing 22
copying between catalogs 23, 165
deleting from catalog 178
detaching categories 193
duplicates while cataloging 116
editing metadata of multiple at once 190
editing multiple 29
explained 9
exporting 174
finding duplicates 188
importing 173
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printing 175
relationship to assets 9, 18
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showing all of a catalog 188
Size considerations 21
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Things You Can Do with 23
thumbnail size 115
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View Sets 105
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Regular expression 192
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Removing
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format from Asset Handling Set 117
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Rename (menu item) 198
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Repurposing assets 57
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Rotating
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Searching 32
accessing the Category Find window 189
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broadening search results 39
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compound (more than one condition) 36
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Find window 34
Find window (advanced mode) 41
Find window (simple mode) 33
finding category names containing 189
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loading search queries 40
methods

broadening 39
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narrowing search results 38
Operator 35
options 102
performing a selected category query 189
performing a selected query 188
Preferences 32
Quicksearch 32
sample search options overview 35
saving search queries 40
Things You Can Do with Queries 41
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Selecting
Asset Handling Sets in User Settings 102
Record View Sets in Information window 29
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Show Preview Pane (menu item) 183
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Slide shows
displaying fullscreen previews as 195

Sort By (menu item) 185

Sort Direction (menu item) 185
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direction 185
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User Settings options for 102

Source (menu item) 201

Split View 80
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icons explained 12

String List fields 19
editing 157

Sub-Pane Filters
creating a new one 139
editing definition 140
setting as default 140

Switch Application Language (menu item) 175

Synchronize Now (menu item) 173
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on FTP servers 86

TAR AssetStore 119

Things You Can Do with
Assets 23
Catalogs 13
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Records 23
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THM files 98
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Thumbnails
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options for creation 115
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Thumbnails (menu item) 184

Toolbar (menu item) 179

Transform JPEG Original (menu item) 200
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Undo (menu item) 177
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Update Record (menu item) 191

Updating
asset references 199
records 191

URL AssetStore 86

Use Default Workspace (menu item) 183

Use Workspace (menu item) 183

User Authentication
while cataloging from FTP or HTTP servers 86
while working with URL-cataloged assets 87

User Guide
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User Interface
Information window 28
IPTC Information window 94
The Find Window 34
User Settings - Display (overview) 103
User Settings (overview 1) 101

User Live Filtering 43

User Settings 100
Asset Handling options 102
Asset Handling tab 102
Cataloging Prefiller options 101
Display tab 103
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defining 110
for records
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View With (menu item) 196
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Details View 184
Information View 184
Preview View 184
Report View 184
Thumbnail View 184
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play 29
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Watermark Asset Processor 121

parameters 62
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images 62
parameters 62
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Windows
fullscreen preview 54
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XMP Support 122
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