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Atlantic Associates grants you a non-exclusive license to use this copy of the 
program and accompanying materials according to the following terms:

You may:

a) use this program on only one computer at a time.
b) make one (1) copy of the program in machine readable form solely for 
backup purposes, provided that you reproduce all proprietary notices on the 
copy.
c) physically transfer the program from one computer to another, provided 
that the program is used on only one computer at a time; and
d) transfer the program onto a hard disk only for use as described above pro-
vided that you can immediately prove ownership of the original diskettes.

You may not:

a) use the program in a network unless you pay for a separate license for each 
terminal or workstation from which the program will be accessed;
b) modify, translate, reverse engineer, decompile, disassemble, create deriva-
tive works based on, or copy (except for the backup copy) the program or 
accompanying materials;
c) rent, transfer or grant any rights in the program in any form or accom-
panying materials to any person or corporation without the prior written 
consent of Atlantic Associates which, if given, is subject to the conferee's 
consent to the terms and conditions of this license; or
d) remove any proprietary notices, labels or marks on the program and ac-
companying materials.

This license is not a sale.  Title and copyrights to the program, accompany-
ing materials and any copy made by you remain with Atlantic Associates.

Unauthorized copying of the program or the accompanying materials, or 
failure to comply with the above restrictions will result in automatic termina-
tion of this license and will make available to Atlantic Associates other legal 
remedies.  Upon termination you will destroy or return to Atlantic Associates 
the program, accompanying materials and any copies.

THE PROGRAM ACCOMPANYING MATERIALS ARE PROVIDED "AS 
IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IM-
PLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRAN-
TIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE.

Atlantic Associates does not warrant that the functions contained in the 
program will meet your requirements or that the operation will be uninter-
rupted or error free.  The entire risk as to the use, quality, and performance of 
the program is with you.  Should the program prove defective, you, and not 
Atlantic Associates, assume the entire cost of any necessary repair.
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ClassManager™ is a full featured class management system 
designed to perform the core business functions necessary to 
run a successful class based organization.  Data, within Class-
Manager™, is maintained in thirteen main data tables:

1.  Account - account or individual information including 
address 1, address 2, city, state, zip, phone numbers, referral 
source, previous enrolled, status, interest, balance due, related 
notes, created and modified dates, etc.

2.  Student - information about the student registrant, i.e., 
Name, age, reg fee expiration date, program interest, school, 
student notes recorded at the time of registration, etc.

3.  Instructor - names and specific addresses of instructors.  
Used by the application in setting up classes as well as prepar-
ing calendars of all upcoming classes.

5.  Program - this table is used to store information regarding 
the different programs that are established at a school.

6.  Class - all relevant information about classes, practices, 
i.e., dates, times, meeting days, class level, room assignment, 
designated instructor, fee, drop out date, drop reason, etc.

7.  Registration - the actual record detailing entry of a student 
into an activity such as a class, team, etc.

8.  Users - information detailing the actual users of Class-
Manager including special user read/write privileges, group 
access, passwords, etc.

9.  Payment - used to store information on payments by inv#, 
check and pay date, check#, account#, amount, etc.

10.  Product - used to store information on items that are sold 
by the school.

11.  Product Sale - the table that maintains information on all 
products that are sold by the school and is linked to the ac-
count table.

12.  Reg Fee - records information on all students who have 
paid or are due to pay their annual fees.  Used also by the ac-
count table for collecting annual registration fees.

13.  Set Up - this table establishes the unique business rules 
that a school will use such as late payment fees, reg fee dis-
counts for multiple students, no class days, etc.

About
ClassMan-
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ClassManager™ Organization:

ClassManager™ is organized on a two tier model.  This two 
tier relationship is that of Account - Student.  This means 
that an account such as the Williams family would have one 
account record in ClassManager™ and possibly multiple 
student records.  Attached to each of these accounts will be 
students who will attend events offered by the Boston Gym-
nastics Academy.  Through organizing and presenting the data 
in ClassManager™ this way it is easy to see the relationships 
between accounts  and students and thus be able to more ef-
ficiently manage those accounts and students as they partici-
pate in the activities of Boston Gymnastics.  The organization 
of ClassManager™ is presented graphically below (Figure 
P.1). 

Accounts

Student
Student

Student

Registra-

Reg Fee

Prod Sale

Two
Tier
Model Program

Classes

Statements
Payments

Products
Instructors

Notes
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Atlantic Associates is a custom software development firm 
specializing in the small business office automation market.  
Atlantic Associates was established in 1989.

Atlantic Associates is a registered Microsoft, Apple and 4th 
Dimension™ software development firm.

Technical support is available free for 30 days after the regis-
tration of ClassManager™.  Technical support hours are from 
8:30 A.M. - 6:00 P.M.  Monday-Friday, (Eastern Standard 
Time)   Voice  (978) 443-0560    Fax  (978) 443-1664.

Support is also available through the Internet.

Internet Addresses:    Info@atlantic-associates.com

The demo data file comes with twelve accounts, twenty stu-
dents, eight instructors, twelve classess, nineteen registionss, 
twelve statements and six payments.  The demo data™ file is 
supplied so that you may experiment with ClassManager™ 
without entering data.  It is important to note that any data 
created with this demo is limited to a maximum of twenty 
Account records.

The purpose of this demo is to give you an overview of 
the capabilities of ClassManager™.  It does not cover all 
features.  Please explore other areas of the program that 
are not covered.

About
Atlantic
Associates

E-Mail
Address

A Word
About This
Demo

Technical
Support
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Chapter 1
Installing The Demo
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Class Manager™ will run on computers configured with the 
Windows 98, 2000 and XP operating systems with a mini-
mum of a Pentium III processor.  ClassManager™ also runs 
on all Macintosh OS computers with a minimum of a Pow-
erPC processor.

Both PC and Macintosh computers should have a minimum of 
256 Megabytes of Random Access Memory (RAM).  Class-
Manager™ is preconfigured to utilize 64 Megabytes of RAM.

Note:  Allocating more memory to ClassManager™ will 
enhance program performance.

Users with Monitors Preference set to Millions/Thousands 
of colors are advised to change the Control Panel Monitor 
Preference setting to 256 colors, otherwise they must allocate 
additional memory to ClassManager™.

Please set your monitor on the PC to 800 by 600 pixels by 
going to Start > Settings > Control Panel > Display > 
Settings.  On the Mac select Control Panels > Monitors & 
Sound and do the same.  This will allow ClassManager™ 
display its Table Selection Palette to the right of the windows 
that will appear when you select different tables.

ClassManager™ comes on one CD or can be downloaded 
from our web site at www.atlantic-associates.com:   The 
ClassManager™ package contains:

1.  Demo Manual Version 5.0

2.  Program

3.  Program Datasheet

Memory
Required

What
is in the
Package

OS System
Configu-
rations

Monitor
Settings
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To install ClassManager™

1.  Start your computer.

2.  Download the ClassManager demo application.

3.  On the PC, double-click on the SetupCM.exe icon.   Fol-
low instructions as they appear.

4.  On the Macintosh, double click on the CD disk icon and 
then double-click on the ClassManager™ icon. Follow in-
structions as they appear.

5. This manual is for use by both Windows and Macintosh 
users.  The illustrated screens are identical throughout the 
application for both the PC and the Mac with the excep-
tion that the Mac has a close box at the top left part of an 
open window whereas Windows  has its close box at the top 
right.  Other than these two differences everything else is 
the same in terms of how you operate ClassManager™.

On-Screen Help

1.  In addition to this Demo Manual there is an on-screen help 
system built into the program.

2.   Clicking the     button that appears on the Print, Find,  
Sort, Import, Export, Table Selection, Preferences, etc.  
dialogs will automatically launch Adobe acrobat and will 
display a pdf version of the ClassManager User Manual.

.

Installation

Help
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Chapter 2
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Accessing
ClassMan-

Log-In Dia-
log

Table Selec-
tion Palette

To start ClassManager™:

1.  Double-click the ClassManager 5.0 shortcut on the desk-
top of the PC.  On the Mac,  double-click the CM 5.0comp 
icon.  This loads the program and sample data. The first object 
that will appear is a Password dialog screen as depicted below 
(Figure 2.1).

 

Figure 2.1

1.  Enter administrator in the User Name field.
2.  Enter admin in the Password field and click Connect.
3.  ClassManager™ will then display the Table Selection 
Palette (Figure 2.2). 
4.  Click once on any of the tables on the palette and a List 
View of the selected table will be displayed.

Figure 2.2
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Moving Between Tables:

ClassManager™ offers several ways to move between tables 
and view data, i.e., clicking on the palette, using File > Open 
Table on the menu bar, and double-clicking on subform win-
dows.  Below you will find an example of one way to move 
to each of the tables and view all the records in each table in 
either list or form view.  Begin at the palette of ClassMan-
ager™.

To View a List of All Accounts:

1.  Click on Account on the palette.

2.  You should now be viewing the List View of all the 
Accounts in the demo file.  The Window title should have 
changed to "Account: 12 of 12". (Figure 2.3)

Figure 2.3

Moving Be-
tween Files

To View an Individual Account Record:

1.  Double-click on the first Account record.
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2.  The selected account will now be displayed in the Account 
Form View of the record (Figure 2.4).

Figure 2.4

To Add a Student Record:

1.  If still in the above account record, click once in the 
Students subform window and then double-click on First 
Name in the subform window.  This will move you from the 
Account Table to the Student Table and allow you to enter a 
new student in the Student Form View.

2.  This screen can be repeated for adding additional students 
to the same account.  Double-clicking on First Name from the 
Account form view produces a blank Student form that can 
be used to enter data about a new student.

The Student form view (Figure 2.5) consists of three sections:

a.  General Student Information
b.  Student Notes
c.  Registration and Product Sales subform windows

Exercise:

1.  Enter a new Account Name, Address, City, State, Zip, 
Phone Numbers, etc. by clicking New from the Account List 

Adding New 
Students

Exercise
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Figure 2.5

Adding Reg-
istrations

Figure 2.6

2.  Double-click in the Student Subform Window on the Ac-
count form to create a new student record. This will cause a 
new student record to be automatically created  (Figure 2.5).

3.  After you have entered the new student's name informa-
tion, click Save and then double-click on Student Name in 
the Registration subform window.  This will display a new 
registration form (Figure 2.6) view.  After entering the infor-
mation click the Save button.
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Charging 
Membership 
Fees

4.  Double-click on an class from the list displayed at the bot-
tom of the screen and observe how the selected class informa-
tion auto-fills the student registration record.

Note:  The Re-Register check box is used at the end of each 
billing cycle to determine if the student should be automati-
cally registered in the next upcoming period.  This feature 
allow for the one-button reregistering of all students by using 
the Tools > Special Functions > Roll Over Sessions feature.

5.  If the student is being registered after classes have started 
click the Prorate button and the class fee will be recalculated. 

6.  After clicking the Save button, the system will check if 
the student has an active reg fee record.  If not, it will present 
a dialog box (Figure 2.7) that will ask if a reg fee should be 
charged.

7.  If a reg fee is to be charged it will appear on the state-
ment along with the fee for the selected class and the product 
charges for any products that have been purchased.

8.  You have now created an Account and Student record, reg-
istered a student and charged the annual reg fee.  Later,  you 
will sell a product to a student.

Figure 2.7

Prorating 
Class Fees
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Moving
Students

Transfering Students:

1.  A common requirement in any school is to move students 
who have already been registered in a class to another class. 
ClassManager performs this complex process very easily. 
To move a student, double-click on an existing registration 
record as it appears in a registration subform window on a 
student form view. This will cause the registration record to 
be displayed (Figure 2.8).  Next click on the Transfer button 
on the top of the window (Figure 2.9)

Figure 2.9

Figure 2.8
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2.  A new display will appear over the registration record 
which will allow you to select the class that the student will 
be transferred to.  Double-click on the desired class and then 
click OK.  This will cause the previously selected class to 
be changed.  Also, the student will now be removed from the 
previous class list and will be placed on the new class list that 
the student has been moved to and the class counts and class 
lists will be updated as appropriate.

3.  If the new class has a different class fee than the previous 
class, the necessary financial changes will be posted to the ac-
count as either a credit or debit entry.

Trial/Waiting Lists:

1.  When a class has reached the maximum amout of student 
allowed, such as 12 students per class in the demo database 
table,  ClassManager will allow you to continue to register 
students in the class, however, they will be entered as Waiting 
List students.  This means that though their name will appear 
on the individual Waiting List Reports, no financial charges 
will be recorded in the database.  Once a place opens up as a 
result of either a student dropping a class or through a transfer 
you may then go to the Waiting List registration record and 
click on the Register button at the top of the screen to change 
the registration to a regular registration which will cause fees 
to be charged.

Figure 2.10
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Selling 
Products

Charging For Products Sold:

1.  From the Student form view, double-click on the heading 
Product in the Product Sale subform window.

2.  This will then display the Product Sale form view (Figure 
2.11)

Figure 2.11
3.  Select the product that the student wants by clicking on the 
Name popup object, double-click the desired item and then 
enter the quantity of product that is to be purchased.

4.  Click Save and this will cause the product sale to be writ-
ten to the Product Sale table for later billing.

5.  From the menu bar at the top of the screen select File > 
Open Table > Product. 

6. Once in the Product List View, click New in order to add 
some of your school's products to the list of products sold by 
the demo school.  Any changes you make will immediately be 
accessible in the Product Name popup selection menu when 
you return to the Products Sale form.
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Instructors

2.  Enter in information for a new instructor.  Note that this in-
formation will be used later in the Class Table where you will 
use a popup list to assign instructors to teach different classes.

3.  The instructor information will also be used by the applica-
tion in the Registration form when you select classes.  You 
will see the program name, day, time, place availability, etc. 
of the class as well as the name of the instructor who will be 
teaching the class.

4.  Additionally, this information will be used by the Class 
Calendar that can show calendars of classes broken down by 
instructor, program, date, etc.

5. Using the Instructor information, it is also possible to 
prepare reports with the Report and Quick Report Editors that 
shows the student body reported by Instructor. This can be 
most valuable when determining the attrition rate of students 
based on assigned instructor.

Figure 2.12

Adding instructors:

1.  From the palette, click the Instructor button.  This will 
bring up the Instructor List View.  To add a new instructor 
click the Add Record button  (Figure 2.12).
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Billing

Figure 2.13

Printing Statements:

1.  Printing statements can be performed immediately after 
creating a billable item or they can be produced in a batch 
mode at the end of the day, week, month, session, etc.  Click 
Account on the palette then click amd highlight the Janice 
Adams account.  Now from the menu bar at the top of the 
screen click Select > Show Subset. This will change the 
selection of records to only that of the Adams account.

2.  Click the Print icon on the tool bar and when the Report 
Manager dialog appears (Figure 2.13) select Statement Open 
Item  and then click the Preview button to see a screen view 
of the Adams statement Item (Figure 2.14).

3. To print, preview or email statements just click the ap-
propriate button the Report Manager dialog.  You will be 
presented with the standard Print Selection dialogs (Figure 
2.14) where you are asked how many copies you would like 
and whether the printed object should be in landscape or por-
trait orientation.  Make your selections and then click OK on 
the PC or Print on the Mac.  A statement will then be printed 
like the one depicted below (Figure 2.15)
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Figure 2.14

4. After statements have been distributed you will next need to 
enter payments into ClassManager™.

Figure 2.15
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Figure 2.17

3. As payments are recorded through the Payment Form, the 
Account records will be updated as will the Accounts Receiv-
able report and the Balance field that appears on the Account 
Form View.

4. To print out the Payments Report go to the Payment List 
View. Click Edit > Select All on the menu bar and then click 
the Print button on the Payment List View.  This will bring up 
the Print Dialog.  Select Payment Detailed and then make the 
necessary choices on the printer dialogs that will be displayed.  
The Payments Report will then be printed on your printer or 
will be printed to the screen of your monitor (Figure 2.18).  
Remember that prior to printing you may wish to perform a 
search on only one month's payment, i.e., May.

Payments

Entering Payments:

1. Payments are entered into ClassManager™ by clicking 
Payment on the palette and then by clicking the Add Record 
icon on the tool bar when the Payment List View is presented.

2. Payments may be entered either as a single entry or in a 
batch mode by entering dozens of payments at a time.     (Fig-
ure 2.17)
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Accounts Receivable:

1. If at any time you wish to see the status of all accounts in 
an Accounts Receivable report (Figure 2.19), click Account 
on the palette, click Edit > Select All on the menu bar or 
perform a specific search and then click Print on the Account 
List view and select  Aged Accounts.  The following report 
will print:

Accounts 
Receivable

Figure 2.19

Figure 2.18
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Searching with ClassManager™

1.  Searching can be performed three ways:

a.  Quick Find
b.  Query Editor
c.  Query by Formula

For purposes of this demo we will cover only the Quick Find 
and Query Editor features.

Using Quick Find:

1.  If not already there, go back to the Student List View.

2.  Click the Query icon on the tool bar at the top of the 
screen.

3.  This will cause the Quick Find dialog to appear (Figure 
2.20)

4.  Enter "Mod" and click the Query button.  Quick find 
searches only one table at a time and is meant for rapid single 
table type searches.  Also, you do not have to put in the 
complete name of a field, it will find all values beginning with 

Searching

Figure 2.20
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Figure 2.21

Using the Query Editor:

1.  The Query Editor (Figure 2.21) is meant for more complex 
queries than can be performed with Quick Find.  It has the 
advantage of being able to search across tables, i.e.,  from Ac-
count to Student so that many different types of queries can be 
performed  For this example we want to find all of the students 
attending the Lafayette school.

2.  Select Student on the palette and then click the Query icon 
at the top of the screen and when the Quick Find editor ap-
pears select the Detail button.

3.  Scroll down the list of Available fields until School ap-
pears and then click on School.  Next click is equal to in the 
Comparisons list and below in Value enter Lafayette as the 
school name.  Click Query to perform the query.

4.  The Query Editor will now find all students at the Lafayette 
school and will display those students in a list view that you 
may print, sort, export, graph or use in another query.

Search
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At this point you have learned how to enter and access data 
that has been either manually entered or imported into Class-
Manager™, including selecting records and creating Account 
and Student records.

To Print the Data Entered:Printing

(Figure 2.22).

2.  Select the Format you wish to use.

3.  Click OK

4.  One or more Printer dialog boxes may appear. 

The Print command can be accessed on all lists 
and forms.

1.  Click the Print icon that appears on the Tool 
Bar of various lists and forms.  After choosing the 
Print command you will see the Print dialogs.

Figure 2.22

Print
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Sorting

To Sort Records:
The Sort function can be accessed from all the 
List Views.

1.  Click the Sort icon on the tool bar.
2.  After choosing the Sort function you will see the Quick 
Sort Editor dialog (Figure 2.23).

Figure 2.23

4.  The Quick Sort dialog allows you to select sort order by 
clicking on the field names in the dialog, however, like Quick 
Find it is meant to be used for sorting only in a single table 
and therefore is to be used in rather simple sorts.

5.  To perform more complex sorts you should click the De-
tail button on the Quick Sort dialog in order to bring up the 
Sort Editor (Figure 2.24)

6.  To perform a multi-table sort, locate and then click on the 
field that you want the sort to be based on, i.e., Account.

7.  Click on the arrow-within-a-box if you want the sort to be 
decending.  The arrow should be pointed up for ascending.

8.  Click on another field, i.e. Status if you want a two level 
sort to be performed.

9.  Click Order by to begin sort.

10.  Your screen will display the records in the new sorted

Sort



Page 31

Figure 2.25

1.  The Chart Editor can be accessed from any 
List View by clicking on the Chart Icon on the 
tool bar.

Charting

order.  If you click the Print icon, you will get the Order By 
dialog again to sort a printed report..

Creating Visual Reports:
Figure 2.24

Sort

Chart
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Figure 2.26

5.  To create additonal charts remember to first click on the 
item you wish to have charted, i.e., Sex, School, City, Status, 
Interest, Class, Payment Type, Referral Source, Pay Method, 
etc. and then click "Counter."

6.  The Chart Editor can be used to chart literally hundreds 
of different business situations and can produce results that 
are easier to understand that regular numeric reports.

The Chart Wizard allows you to select a chart type and to 
prepare two-dimensional charts.

To Display a Chart:

1.  Go to the palette and click Student and then on the menu 
bar click the Tools > Special Functions > Chart Editor.

2.  Select Chart Editor from the displayed print list.

3.  After the Chart Editor appears, click on the far left School/
Student.  This will display the Chart Wizard (Figure 2.25).  
Click on the Pie Chart and then on the Data Selection Tab.  
Next select Student from the pop-up list and double-click 
Program and Counter from the list and click OK.

4.  Select Chart on the tool bar and then Values > Position > 
Outside    Display > Category & Percent click OK.
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Reports:

1.  Throughout ClassManager™ you will find reports that are 
attached to the form and list view of the various tables or can 
be accessed from the SuperReport or Quick Editor.

2.  Some of these reports are:

     Acount Report                             Statement Report

     Aged Accounts                            Membership Report

     Student Report                            Statements

     Instructor Report                         Reg Fee Revenue

     Payment Report                          Picture Class List

     Class Report                                Scheduling Report

     Class Lists                                   Attendance Report

     Class List w/Balances                 Waiting List Report

     Class Openings Report               Instructor Schedule

     Class Revenue Report                 Drop Report

     Revenue Category Report           Transfer Report

     Product Reports                          Monthly Calendar

     Product Sales Report                  Class Calendar

     Program Report                          Instructor Calendar

     Bank Deposit Report                  Program Calendar

     Birthday Report                          Labels 3 x 10

     Class Income Report                   Instructor Efficiency

     Class Loading Report                 Duplicate Report

     Credit Report                              USAG Member Report
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Chapter 3
Additional Features
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In this chapter we will briefly outline some of the additional 
features you will find in ClassManager™.  Explore these fea-
tures on your own or call Technical Support for more details.

Administrative Tasks

Administrative tasks include adding and deleting instruc-
tors, checking and reviewing duplicates that might have been 
manually entered, editing the Product table, reassigning in-
structors, exporting records for a direct mail campaign (Figure 
3.1), adding and deleting passwords (Figure 3.2)  and rolling 
over registrations and classes at the end of a session prior to 
billing all students for the upcoming period.

Automatic Zip Code Lookup

ClassManager™ will automatically look up the correct city 
and state when you enter the appropriate Zip Code.

Class Assignment

When you select an class for a new student entry, ClassMan-
ager™ will automatically enter the appropriate class informa-
tion as well as all the necessary financial information.

Label Editor

The Label Editor (Figure 3.3) is a powerful tool that allows 
the user to create custom label templates.  Labels may be 
printed from the Label Editor by selecting the Label Icon 
from the Account, Student or Instructor List Views.

Report Editor

The Report Editor is a powerful ClassManager™ tool that 
allows the user to create custom report templates (Figure 3.4).  
This editor can produce more complex reports than is possible 
when using the Quick Report Editor and permits the user to 
make use of the the databases language.

Additional 
Features
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Figure 3.2

Export

Password

Figure 3.1
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Figure 3.4

Label

SuperReport

Figure 3.3

Choice List

Throughout ClassManager™ you will find a number of Choice 
List that the user can tab into or click on to make a selection, 
i.e., Referred By, Status, Interest on the Account Form and 
School, Session and Status on the Student Form.  If you wish 
to change the choices just click on the Menu Bar File > Ad-
ministration > List Editor.  This will cause the List Editor 
to be displayed where you may add, delete or insert your own 
entries (Figure 3.5).

Figure 
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Popup

Figure 3.5

Global Updates of Records

In many cases it is necessary to make global changes to 
a table such as changing 1,500 records from one status to 
another, i.e., changing records that have a condition of active 
to inactive.  This type of mass change can be accomplished by 
using the Modify Record feature (Figure 3.6).  Like the Quick 
Report and SuperReport Editors, the Apply Formula Editor 
can make use of the 4D language thereby greatly extending 
the power of this editor to modify data tables in many differ-
ent ways.

Formula

Figure 3.6
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System Setup

One of the first tasks you will have after installing ClassMan-
ager™ is to setup the application to meet the specific business 
rules that you have established for you school.  To see how 
this is done in ClassManager™, select File > Open Table > 
Set Up and review the System Setup (Figures 3.6 - 3.10) that 
has been established for the demo school.  Remember to click 
the Next Record icon to see page two through five.

Figure 3.6

Figure 3.7
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Figure 3.8

Figure 3.9

Note that ClassManager™ allows you the options of billing 
on a session and monthly basis at the same time, i.e., classes 
on a 12 week session basis and teams on a monthly basis.  
ClassManager can also be configured to bill on an hourly 
basis (Figure 3.9).  If the hourly system is used you cannot 
use the Session or Monthly systems.  Lastly, see Figure 3.10. 
This entry form is used to enter information about you school 
which will appear at the top of the invoice form.
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Figure 3.10

Spell Checking

All of the note boxes that appear in ClassManager™ on 
the Account, Student, Class, Instructor, Product, Payment, 
windows, etc. make use of an automatic spell checker which 
will appear if the spell checker detects that a word has been 
incorrectly spelled.  The spell checker works like any checker 
found in a word processor and can be dismissed by clicking 
the Done button.

Figure 3.11

Email

Email can be access in ClassManager by clicking on the enve-
lope icon on the menu bar on the Account list view and input 
form.  If you select multiple accounts, i.e., 300 accounts, all 
300 accounts will receive an individual email.
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Quick Report Editor

1.  The Quick Report Editor is a powerful tool that allows the 
user to create custom reports (Figure 3.12).  Using the Quick 
Report Editor, a user can report across table relations and thus 
create any possible combination of reports.  An example of 
the use of the Quick Report Editor might be to search for all 
accounts in your general area whose children are in the 2 to 
10 year old age bracket.  The Quick Editor would then print a 
listing of these accounts.

2.  To create this report go to the Account List View, select all 
records by clicking Edit and Select All on the Menu Bar and 
select Query at the top of the List View screen.

3. Once in the Find dialog click Detail to bring up the Query 
Editor.  In the Query Editor click on the Available fields 
Popup and select Student.  Now click DOB is is greater 
than or equal to and enter the value 01/01/90.  Click below 
on Add Line  and then enter again  DOB is less than or 
equal to and enter the value 01/01/96. Click Query and the 
search result of nine accounts with children of the searched 
for age will appear.

4. Next on the tool bar click the Quick Report icon.  Once 
in the Quick Report Editor drag First Name, Last Name, Ad-
dress, Apt, City, State, Zip, Home Phone and Emerg Phone 
to the top of the report screen.  Click on the menu bar File > 
Header & Footers... and enter in the Center Header box the 
title Account Report.

5.  Click OK to return to the Quick Report Editor. Now click 
File > Print from the menu bar in order to print out your 
report.

6.  If you wish you can sort on various fields in the report by 
first highlighting a field column and then by clicking the Sort 
check box in the Column area at the top of the editor.  There 
are many other capabilites that the Quick Report Editor has 
which are explained in detail in the User Manual that comes 
with ClassManager™.
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Figure 3.12

Quick
Report

Word 
Processor Customized Letters:

ClassManager™ can be configured with a custom Word Pro-
cessor .  It can be very useful for printing hundreds of letters 
used to solicit new accounts.  The word processor is easy to 
use and extremely powerful.  To prepare a series of letters do 
the following:

1.  Click Account on the palette to display the Account Table.  
Click on the Query icon and then Detail to select the Query 
Editor.

2.  Click Status, "is equal to"  and then enter Prospect in the 
value field and then click Query.

3.  On the menu bar select the Letters icon.  The Document 
Manager dialog will now be displayed showing preformatted 
letters.

4.  Click Membership Drive letter on the dialog and then 
click the Preview button to see a screen Preview of the letter.

5.  To print letters just click the Print button and select your 
appropriate printer.
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Calendar:

The calendar function allows you to display or print, in a 
30 day calendar, class information by month, program or 
instructor.  To view or print the calendar select the Calendar 
cion on the tool bar  (Figure 3.14).

Figure 3.13

Calendar

Word
Processor

Figure 3.14
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Figure 3.15

Import
Editor

Importing and Exporting Data
ClassManager™ imports database information using the 
Import Editor.  This should only be performed by the Data-
base Administrator since the potential exist for overwriting of 
existing information. The ClassManager™ Import Editor is 
easy to use and imports data rapidly.

Spreadsheet

In addition to the above discussed techniques for searching  
and reporting on data in ClassManager™, the application can 
also have a built-in spreadsheet.  Click on Payment on the 
menu bar and then click the Spreadsheet icon. 

Figure 3.16
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Duplicate Checking
One of the major objectives for any database system is to 
maintain a clean database free of duplicate records.  Often 
this is very hard to do if records are imported from an outside 
source.  When records are imported it is often necessary to 
dedup the target file after the records have been brought in 
through the use of a special duplicate checking procedure.  
This capability is provided in ClassManager™ through select-
ing on the menu bar  Tools > Special FunctionS. > Find 
Duplicates  (Figure 3.17).  The result of running this routine 
is a list of duplicate records that can be selectively deleted so 
as to purge the database of unwanted duplicates (Figure 3.18).

Figure 3.17

Figure 3.18
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EXAMPLE REPORTS
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Chapter 4
Creating A New Data File
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If you have not done so, we highly recommend that you 
familiarize yourself with ClassManager™ by going through 
Chapter 2 - Quick Tour, before creating your own data file.

Before creating your own data file, experiment using the 
demo data and at least some of the functions in ClassMan-
ager™.

A new data file can only be created while launching Class-
Manager™.

Note: To prevent accidental entry of live data into the demo 
file we recommend removing the Sample Data file, called 
CM_5sd.4DD and CM_5sd.4DR before creating a new data 
file.

To Create a New Data File:

1.  Launch ClassManager™.

2.  After entering your User Name and Password, hold down 
the Alt button and click Connection.

3.  You will now see the Open Data File dialog. (Figure 4.1)

4.  Click the New... button.

5. You will now see the New data file dialog (Figure 4.2).

6.  Enter the name you want to give the new data file.

7.  Click Save.

Creating 
Your
Own
Data
File

Open
Data
File

Figure 4.1



Page 53

Figure 4.2

ClassManager™ will create the data file on the selected hard 
drive and then continue to load and run.  Since this is a new 
data file, the Account, Student, Instructor, Program, Class, 
Registration, Product, Product Sale, Reg Fee, Payment, Setup, 
etc. tables will be empty and it will be necessary for you to 
enter your own data in order to use ClassManager™.

Initial Setup

1.  Click on File > Open Table.. on the menu bar and click on 
Setup in the Table Selection dialog to establish the business 
rules that your school will use with ClassManager™.

2.  Next, select Program from the Table Selection dialog to 
establish your school's Programs, then double-click on the 
Classes subform window in Program to establish the dates 
and times of the classes.

3.  You can now select the Account item on the palette and 
choose Add Record to begin entering your own information.

Congratulations!  You have now completed 
the minimum steps for creating a working 
ClassManager™ Data File.
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ClassManager™
 Price List

Product Demonstration Kit                                               Free

Single User                                                                                
ClassManager™ Single-User System                          $ 1,995

Multi-User*
ClassManager™ 2-User System                                  $ 2,995
ClassManager™ 3-User System                                     3,995
ClassManager™ 4-User System                                     4,995
ClassManager™ 5-User System                                     5,995
ClassManager™ 6-User System                                     6,995

Options
CM Word Processor per license                                   $   295
CM SpreadSheet per license                                             295
Customization Services                                          Per Quote

Support
First 30 days is included in the purchase price

Basic Monthly Support
Unlimited phone & email support
Single-User per license                                                    $  85
Multi-User per license                                                          65
Comprehensive Monthly Support
Includes unlimited support & all upgrades
Single-User per license                                                   $ 125
Multi-User license                                                                85

Prices are effective January 1, 2002 and are subject to change without notice.  
All prices are quoted in US dollars.  Sales taxes will be added for all states and 
provinces where they are in effect.
*Requires the separate purchase of the 4D Server engine
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Monthly Purchase Schedule2                                                   

Single User                                                                
                                                                                                 
ClassManager™ One-User 12 Months                          $  325
ClassManager™ One-User 24 Months                          $  250
ClassManager™ One-User 36 Months                          $  210

2 User Client/Server                                                                 
                                                                                                 
ClassManager™ Two-User 12 Months                          $  600
ClassManager™ Two-User 24 Months                          $  455
ClassManager™ Two-User 36 Months                          $  395

3 User Client/Server                                                                 
                                                                                                 
ClassManager™ Three-User 12 Months                        $  815
ClassManager™ Three-User 24 Months                        $  595
ClassManager™ Three-User 36 Months                        $  565

4 User Client/Server                                                                 
                                                                                                 
ClassManager™ Four-User 12 Months                          $  998
ClassManager™ Four-User 24 Months                          $  750
ClassManager™ Four-User 36 Months                          $  695

5 User Client/Server                                                                 
                                                                                                 
ClassManager™ Five-User 12 Months                          $1246
ClassManager™ Five-User 24 Months                          $  948
ClassManager™ Five-User 36 Months                          $  895

6 User Client/Server                                                                 
                                                                                                 
ClassManager™ Six-User 12 Months                            $1460
ClassManager™ Six-User 24 Months                            $1085
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