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1.0 GENERAL INFORMATION 

1.1 Software Overview 
 

iVision-GR grain size analysis software is used in 
automatically finding grains and calculating the average grain 
size on digital images. Two methods, by grain contours and 
by cross points, are provided in the calculation. 

1.2 System Requirements 
 
System: IBM compatible PC with Windows XP, Windows 
Vista, or Windows 7 32-bit operating system. 1GHz CPU and 512MB RAM or higher are recommended 
due to the intensive calculation in image processing. At least two USB2.0 ports are required with one for 
the USB license key and another for the USB camera (if needed). 

1.3 Main Features 

1.3.1 Grain size analysis 
To automatically find grains and calculate their average grain diameter. 

1.3.2 Camera calibration 
To calibrate camera either in manual mode or in automatic mode 
 

1.4 Standard Features 

1.4.1 Geometric Measurement 
System provides the tools to draw and measure common geometric shapes such as lines, angles, 4-point 
angles (for missing or hidden vertexes), rectangles, circles, ellipses, and polygons.  Note that the 
measurement assumes the system is calibrated. 

1.4.2 Image Processing 
System provides a rich set of image processing tools for advanced users. The standard tools in the system 
include adjusting Brightness, Contrast, Gamma, and Histogram Level, and the Sharpen, Smooth, Invert, 
and Convert to Grey functions.  On grey scale images, system provides various advanced tools in 
filtering and finding edges, as well as some standard tools in morphological operations such as 
Open,Close,Dilation,Erosion, Skeletonize,and Flood Fill. 

1.4.3 Document Entry 
On an image, system provides a document editor to enter/edit documents with contents either in simple 
plain text format or in advanced HTML format with objects including tables, list, and images. 
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1.4.4 Album Management 
System allows user manage multiple images in an album which can be saved to and opened from an 
album file. The images can have the standard geometric shapes and the documents as entered by user as 
described above. 

1.4.5 Printing With Magnification 
System can print the image with user specified magnification if the camera is calibrated. 
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2.0 SOFTWARE INSTALLATION 

2.1 Installation Overview 
 
iVision software is modular in architecture. It consists of the application platform and upon which the 
application modules.  The following components are installed in iVision-GR: 1) Microsoft VC++ 
redistributable package since iVision is developed with MSVC; 2) iVision software platform; 3) Related 
hardware drivers in the package such as the camera driver; 4) iVision application modules such as 
iVision-GR. 

2.2 Installation Instructions 
 
Double-click the installer file iVision_v1.0.0_WIN32_XP_TZXXXXXX_installer.exe to start the 
installation process, and answer “Yes” at all the prompts in the camera driver installation, where 
TZXXXXXX is the USB license key ID.  Note to change the drive in installation directory if other than 
the default D: drive. Also note that if installation error message “II Camera 02 DirectX registration failed” 
shows up in the installation process, then it is necessary to manually register the camera DirectX driver 
after the installation process by running (double-clicking) the reg.bat in the iVision installation folder 
(D:\Intelligent Instruments\iVision_v1.0.0\Drivers\II_Camera_02\DirectX).
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3.0 GETTING STARTED 

3.1 Camera Setup 
It is necessary to set up the USB camera for the system at the first time use and these steps can be totally 
skipped at later use. 

3.1.1 Camera driver installation 
When the USB camera is plugged in at the first time use after iVision is installed, depending on the 
computer operation system the computer may ask to install the camera driver either manually or 
automatically.  Answer “automatic” since the camera driver is already pre-installed during installation. 

3.1.2 Camera selection 
Open iVision, select menu Image Capture ->Open capture window to invoke the “Media Capture” 
window.  Then go to menu Devices and select II Camera 02 or another applicable camera. Note that the 
following setup instructions apply to II Camera 02 only, and different cameras have different parameter 
configurations. 

 

3.1.3 Image resolution setup 
On Media Capture window, select menu Options -> Video Capture Pin… to bring up the camera video 
format setup Properties dialog and select desired resolution on Video Format under Format tab. 
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3.1.4 Camera parameter setup 
On Media Capture window, select menu Options -> Video Capture Filter… to bring up the camera 
parameters setup Properties dialog. Under tab Plugin, click button Plugin, select menu Plugin 
Manager… to invoke the Plugin Manager dialog. Make sure all the plugin components are checked. 
 

  
 
Finally go back to Media Capture window, and select menu Preview, camera video preview should 
appear on both Media Capture window and iVision main window. Select menu Options -> Video 
Capture Filter… to bring up the camera parameter setup Properties dialog again and adjust the A/D -> 
Change Level under Capture tab, and the Shutter->Speed and the Gain->Gain parameters under 
Control tab for the best quality image capture. Note the Units selection in Shutter speed. 
 
Exit iVision, the above camera settings should be saved and there is no need to do the setup when iVision 
is opened the next time. 
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3.2 Starting the application 

3.2.1 Graphical User Interface (GUI) setup 
Layouts: Different application module in iVision has its own GUI . Select menu Grain->Contour or 
Cross analysis to bring out the main interface, depending on which method to calculate the average grain 
size. 
 

 
 
Configurations: Many other GUI settings such as menu orders can be configured in the Configuration 
Settings dialog through menu File -> View/Edit configurations… 
 

 
 

Language: To choose a different GUI language, go to menu Help and select menu Language. Choose the 
new language and the application will exit.  After restarting the application the new language will take 
effect. 
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3.2.2 Camera calibration 
To get quantitative geometric measurement from the camera image it is necessary to calibrate the camera 
to obtain the conversion from pixel locations to their object physical locations. There are two methods to 
calibrate the camera in iVision. 
 
a) Manual calibration 
Manual calibration simply calculates the linear scale between the pixel distance and the physical distance 
of two points on image.  Place the calibration ruler or grid under the camera, start video preview by 
selecting menu Image Capture -> Preview, move the ruler or camera to make sure the lines are 
approximately aligned in preview and snap an image by selecting menu Image Capture -> Capture 
Image.  
 
Select menu Calibration -> Manual calibration, hold down the mouse and drag from one line to another 
line with known and adequate separation distance and then release mouse.  
 

 
 
A dialog will prompt user for the known physical distance between the dragged start and end lines and a 
name for the calibration.  After the manual calibration is done, system will prompt user whether to load 
the done calibration or not.  In any case user can load the named calibration by selecting menu 
Calibration->Calibration viewer and load the calibration from there. 
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b) Automatic calibration 
Automatic calibration is much more complex in process but more convenient in usage.  It automatically 
finds the cross points on the grid image, map them to their physically locations and obtain the true 2-D 
mapping between a physical location and its pixel location via interpolation. 
 
In stead of a calibration ruler, a calibration grid is needed to do the automatic calibration.  First select 
menu Calibration->Auto calibration settings to set up the X&Y line distance, unit etc.  If the lines in 
image will be darker than the background then Invert Image needs to be checked. Snap an image with the 
grid approximately aligned.  Select menu Calibration->Automatic calibration to perform the automatic 
calibration after which the system will locate and mark most of the cross points of the grid image. 
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3.3 Analysis by contours 

3.3.1 Settings 
If the (UI)user interface of grain contour analysis is not shown, select menu Grain->Contour to bring it 
out. Under tab Settings, set Object pixels threshold which is the minimum number of pixels for an object 
in the image to be analyzed. If it is too small then nuisance little objects will be taken into account, 
otherwise if it too large then the desired objects may be ignored. Check or uncheck “Count grains at 
image borders” depending on whether or not to count those grains at image borders. User may change the 
contour color under the settings. 

3.3.2 Automatic analysis 
1. Image capture: If needed, select menu Capture->Video preview to get preview, then select Snap 

image to get an image from the camera. 

2. Automatic analysis: On the main UI, click on the Automatic Measurement tool button ,iVision 
will automatically find the contours of the grains. The contour of each found grain will be displayed 
on the image. 

 
3. Manual correction: After a manual correction, the analysis results will be updated automatically. 
a) Dimension: Click to select the object to be corrected. Mouse drag move a vertex on the contour to 

match the contour with the real grain. 
b) Delete: Click to select the object (or CTRL click to select multiple objects) to be deleted, hit Delete 

key on the keyboard or click the Remove selected button on the UI. 
c) Merge: Click and CTRL click to select two grain contours that have touching (or close to touching) 

edges, under the Manual correction tab click the Merge button, then the mouse icon will become 
cross to let user position the mouse. At each end of the touching edge of the two grain contours to be 
merged, click on both sides with total of 4 clicks to define the edge to merge, and the two grains 
contours will be merged. 

d) Split: Click to select the object, under the Manual correction tab click the Split button, click on 
two points (outside of the grain) to define the splitting line and the grain contour will be split. 

e) Add: To add a grain contour, under the Manual correction tab click the Add button, click on the 
real grain to make a polygon contour(note to click on the first point at the end to form a polygon). 

4. Generate report: Click on Generate report tool button  to generate a Word document report. 
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3.4 Analysis by cross points 

3.4.1 Settings 
If the main UI of Cross distance analysis is not shown, select menu Grain->Cross distance to bring it out. 
The parameter Grain edge threshold defines the threshold value in finding the grain edges. 

3.4.2 Automatic analysis 
1. Image capture: If needed, select menu Capture->Video preview to get preview, then select Snap 

image to get an image from the camera. 

2. Automatic analysis: On the main UI, click on the tool button Add line or Add circle , and 

draw the base lines and /or circles on the image. Click on toll button Find cross points , the 
software will automatically find the cross points on the base lines and circles that cross with the grain 
edges, and calculate the average distance between the cross points and hence the average grain 
diameter. 

 
3. Manual correction: Like in the analysis by contours, after a manual correction the analysis results 

will be updated automatically. 
a) Add: To add cross points that are missed out, click on Add cross points tool button , the cursor 

will become a cross to let user position the mouse, click on the locations to add the cross points. 
After adding is completed click on the tool button to finish. 

b) Delete: To delete a cross point, drag mouse to select the point and hit the Delete key. To delete a 
base line or circle and the cross points on it, click on the line or circle to select and hit the Delete key. 

c) Classification: Each cross point can be manually classified (counted) either as 0.5(green),1(red),or 
1.5(blue) to take into account.  Drag mouse to select the cross point, right click to bring out the 
popup menu to classify. Note that in the cases of base lines, as required the two cross points at both 
ends are automatically classified as 0.5. 

4. Generate report: Click on Generate report tool button  to generate a Word document report 
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3.5 Appendix: Using the standard features 

3.5.1 Geometric measurement 
Select any one of the sub-menus on the menu GeoMeasure, the geometric measurement main interface 
will appear.  Draw the standard geometric shapes on the image and their measurement results will be 
displayed on the data table on the right and on the shapes for some shape types.  User may edit a shape 
by click selecting the shape and mouse dragging on one of its control points, and the corresponding 
measurement results will be automatically updated. 
 

 
 

3.5.2 Image processing 
Select menu Preprocess and its sub-menus to access the image processing tools. 

3.5.3 Document entry 
Push on the Add text tool button, or select Add text sub-menu under GeoMeasure, then click on the 
image, enter text at the small text entry box. To edit the text or to enter complex HTML format 
documents, double click on the text to invoke the document editor. 

 
 



 
3.0 Getting Started 

 

User’s Manual   Page 3-9 
 

To edit the text in HTML format, select HTML on Text type. To insert table, list, or image, click on the 
tool buttons at the right bottom.  The tool buttons to change font, text color, and text alignment lie at the 
left bottom. 

3.5.4 Album management 
 To view the album, select menu View->Image Album. To change image display size in album, move 

the splitter.  Album can be docked in the main window and it can be floated also. 
 Double-click on the image will copy the image into the album, and conversely double-click on the 

image on the album will copy it to the image panel 
 To open/save album file go to menu File 
 To reorder the images in album, drag an image with its frame and drop it to position 
 To remove an image or images on album, click to select and press the Delete key 

 

 

3.5.5 Printing with magnification 
Connect to the printer first and select menu File->Print… to bring up the printing dialog.  Select or 
enter the desired magnification at the bottom, the image print size will change accordingly in preview. 
User may enter text (can be in HTML format to include tables,lists,images etc) under user input and the 
text will be saved for next printing.  Analysis result tables and statistics summaries can be checked for 
printing. And all the above elements to be printed have options in printing locations in either top, 
bottom,left, and right.  The textbox widths can be limited by their width inputs. 
 

 


