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About the Reform Tracker Plug-in 

 The Reform Tracker plugin allows for seamless Printer and MFP monitoring.  

There are two main components which are the monitoring and reporting.  The 

monitoring component is able to retrieve information about print jobs such as the 

number of black and white/color pages, the amount of copies, time and date printed 

and a various amount of user information.  The reporting component is able to 

intelligently gather this data about the print jobs and compile it into user friendly 

reports.  Also, if using MOST enabled MFPs, the Reform Tracker is able to configure and 

lock functions based on devices or LDAP users and groups.  It can also monitor and limit 

the number of black and white/color copies made. 

 

System Requirements 
• Reform 12 Enterprise or Reform 12 PDC  

• MOST Plugin 

• Reform Tracker Plugin  

• For Evaluation and Demonstration: Windows XP, Windows 2003 Server, 

Windows Vista, Windows 7 or Windows 2008 Server (64 Bit Operating Systems are 

Supported) 

• For Production Systems: Windows 2003 Server or Windows 2008 Server (64 Bit 

Operating Systems are Supported) 

• Microsoft Visual Studio Report Viewer(Installed with Reform Tracker installation 

if not present on the current system) 

• Microsoft SQL Server (SQL Server Express will be automatically installed by the 

MOST installer) 

• Microsoft .NET Framework 2.0 (installed automatically)  

Microsoft SQL Express 2005 (installed automatically) 

 

All required Reform software downloads can be found at www.fabsoft.com >> 

Downloads section. 

 

 

Installation 

To install the Reform Tracker plugin to your existing Reform 12 installation, you will 

need to download and run the ReformTracker installation executable.  

 

 

http://www.fabsoft.com/
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Step through the prompts and accept the User License Agreement. The installation will 

begin.  Allow the installation to complete and then read on to the next section to learn 

how to set up MOST to use the Reform Tracker plugin.   

 

The default installation directory for Reform 12 and its plugins is C:\Program 

Files\Reform…\.  If you have changed the path during the Reform installation routine, 

or if you are using a 64 bit operating system, please refer to the appropriate path 

instead of the default one referenced throughout this documentation.  

 

 

Importing MOST Screen  

Please refer to the MOST manual for more information regarding MOST terminology, 

MOST Setup, and Connection Test. 

 
To import MOST screens for Reform Tracker, Go to Start > Programs > 

Reform…>Reform_Tracker > Install MOST Screen 

 

 
 

If not already open, MOST Designer will appear.  You will be prompted if you want to 

Import Tracker into MOST.  Click Yes. If asked if you want to overwrite files, click Yes.  

 

 
 

You can leave MOST Designer open as it will be used in the following section. 
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Configuring MFP to use Reform Tracker 
(Before attempting to configure the Reform Tracker, MOST should be setup and 

working.  It is also highly recommended that LDAP be enabled and working in the MOST 

Manager) 

1. Go to Start>Programs>Reform…>MOST>Install to MFPs. 

 
 

2. Go to Edit>MOST Settings… Go to the Device tab and set Copy Counter = True, and 

check all the lock functions. Click Save. 

 

 

a. The Copy Counter setting enables the MFP to have control over users’ 

copying habits.  If set to True, you must enter the MFP’s username and 
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password. The MFP Username and Password should be the same as the 

credentials used to log into the MFP’s Web Image Monitor.  

b. The Lock Function settings allow you to lock down the MFP until a user logs 

in to MOST.  Each user that logs into MOST can have access to different 

functions such as copying, faxing, scanning and access to the document 

server.  By default, all users will be locked out of the functions that you 

select until the user or group is configured using the Workflow Designer. 

 

3. Now we need to update the settings by (re)installing MOST on the MFP. At the main 

MFP Control Center window you can enter a start and stop IP range to scan your 

network for MFPs.  If an MFP is found click Next. 

 

 

 

4. A window appears with two tabs: Installed and Not installed.  Depending on whether 

MOST has already been installed on the MFP it found, it will appear on the 

appropriate tab.   

 
 

5. For the demonstration, we already have MOST installed on the MFP so we will be 

doing an Update.  Click on Update MOST to update MOST in the MFP with the new 
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settings from the Control Center. (If you were installing MOST for the first on the 

MFP, you would need to click Install MOST from the Not Installed tab).  Once the 

MOST installation is complete, close the MFP Control Center.  You can now proceed 

with configuring the Reform Tracker.  

Reform Tracker Services with MOST 

Reform Tracker Service 

The Reform Tracker Script Process service is installed with Reform Tracker.  The 

installation routine sets it to start manually.  If using the Reform Tracker to monitor 

MFP’s with MOST installed, this service must be started and set to Automatic.  It is also 

recommended to run this service as a domain account with administrative privileges on 

the local computer in order to successfully access your LDAP system. To view this 

service, go to Control Panel>Administrative Tools>Services. 

 

 
 

Right click on Reform Tracker Script Process and go to Properties. 

 

 
In the General tab, select Automatic in the Startup Type option.   
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To change the service log on account, go to the Logon tab.  Here, fill out the credentials 

for an administrative account.  Click OK when complete.   

 
 

You will be asked to restart the service after clicking OK.  Please do so by right clicking 

on the service and going to Restart or simply by stopping and starting the service. 
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Automated Reports and Limits Service 

The Reform Tracker plugin allows you to configure an automated reporting system.  The 

RM_Tracker Automation service is in charge of generating and emailing these reports.  

The service is installed by Reform Tracker and is set to start automatically.  It runs every 

6 hours and checks if there are any reports to be generated and/or limits to be reset. 

Using the Workflow Designer, you can configure an unlimited number of reports which 

are then generated and emailed out (if configured) by the service.  This service also 

allows you to automatically reset limits monthly, quarterly or yearly depending on the 

needs of your organization.  The schedule for resetting limits automatically is configured 

using the Workflow Designer as well.   

 

To ensure the service is running, go to Control Panel>Administrative Tools>Services 

and look for RM_Tracker Automation.  The startup type should be automatic and the 

status should say started.   

   

 
 

It is recommended that this service be run as a domain account with administrative 

privileges on the local computer.  To do so, please follow the same steps as the Reform 

Tracker Script Process service above. 

Configuring Lock Functions and Limits 

The Workflow designer is used to configure the users/groups and Device limits. 

1. To open it, go to Start>Programs>Reform…> Workflow Designer. 

 

2. Go to File>New>Document Restrictions and click Ok. 
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3. You will now notice that your Inputs, Processes and Outputs have been populated. 

 

 

4. We can now start adding the necessary components to the workflow.  First, drag 

and drop a User or Group object onto the workflow by clicking and holding your 

mouse on User or Group and then moving your mouse over to the workflow and 

releasing the mouse button.  
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*You will be prompted with the following dialog: 

 
 

5. Enter a description for the object you just added.  This is done by typing in the 

provided box.  You can leave the default value and click Finish. This will take you 

back to your workflow. 

6. Now you are ready to configure “User or Group 1”.  To do so, right click on the 

newly added object and select “Configuration…” or simply double-click on it. 
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7. You are now presented with the Setup window.  Here you can search for the user 

or group you want to configure limits and locking for.  For the demonstration, we 

will be adding the group Domain Users.  We will also specify that each user within 

this group will receive their own individual limit. Since users can be part of multiple 

groups, limits are configured based on the user’s Primary Group within LDAP. 

 

Individual Limits If Joe and Bill are in the Domain Users 

group. Each of them have their own 

limit.  If Joe scans, it will not reduce 

Bill’s remaining scans. (Each user in 

Domain Users has their own limit.) 

Non Individual Limits If Joe and Bill are in the Sales group. 

Their entire group has one limit.  If Joe 

scans, it will reduce Bill’s remaining 

scans. (The entire Sales group has a 

single limit.) 

 

8. When searching, you can limit the results by entering domain users into the first 

field or you can leave it blank to show all groups.  In the Domain field, type in the 

domain. Click Finish to begin the search.   

 

 
 

 

9. Your search results will display and we can now choose the group we want to 

configure. Select Domain Users and click Finish. 



Reform Tracker For MOST  13 

 

 

                                                                                                                                                                                                                                                           Reform Tracker  

 

 

10. To continue the Reform Tracker workflow, we want to add and configure the MFP 

Restrictions object.  We use the same drag and drop procedure as with the “User 

Or Group 1” (see step 4).  Take your mouse and drag the “MOST MFP Restrictions” 

object from under Process onto the workflow somewhere below your Input.  Once 

you release your mouse, you will be prompted to describe “MOST MFP 

Restrictions”.  Leave the default value in the box and then click Finish. 

11. Once you click Finish, you are taken back to your workflow.  Your MOST MFP 

Restrictions 1 will have a Red Caption because it is not yet configured. To configure 

MOST MFP Restrictions 1, you must first connect it to “User or Group 1”.  To do 

so, first select the “Add Connector” button from the menu bar.  Next, drag your 

mouse from the small “x” underneath “User or Group 1” to the small “x” above 

“MOST MFP Restrictions 1” as pictured below. When the connection is complete, 

the connecter will turn black (if red, connection has not been made correctly, try 

again) and the “MOST MFP Restrictions 1” caption will turn green. 
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12. You will be prompted to configure MOST MFP Restrictions 1 upon completing the 

connection.  Click Yes.   If you select No, you can still double click on the MOST 

MFP Restrictions 1 object or rightclick and select “Configuration” to configure it. 

 

 
 

 

13. Check the functions that you want to unlock for the users when they login.  This 

wizard will also show you the currently configured settings, if any exist. For this 

demonstration, we will be unlocking Copying and Faxing for the Domain Users 

group.  Check ON the boxes next to the appropriate functions and click Next. 

 

 
 

14. Next we have the option to allow black copies to be made when users are not 

logged into MOST.  To use this feature, either the IP or Serial number of the MFP 

must be entered.  Multiple IPs/Serials can be configured using comma separated 

values.  For the demonstration, we will not being using this option.  Click Next. 
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15. Here we can configure monthly, quarterly or yearly copying limits for the Domain 

Users group (The Reform Tracker Script Process service must be running to enable 

copy limits, please see the services section of this manual).  Enter a value for 

black/white pages and for color pages (we enter 5 Black/White and 1 Color for 

demonstration).  Check the box at the bottom titled “Schedule automated resetting 

of copy limits”.  Click Next. 

 

 
 

16. This is where you choose how often you will be resetting the copying limits (The 

Tracker Automation service must be running, see the Services section of this 

manual).  It is recommended to select the first day of the current month if using the 

monthly limits approach.  This will ensure that when the next month arrives, limits 

will be reset automatically to their original values.  For example, if today was 

1/15/2009, you would set the date to 1/1/2009.  On 2/1/2009, the limits would be 

reset to their original values.  Click Next. 
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17. Click Finish. 

 
 

18. You have completed configuring your simple Reform Tracker workflow.  Your 2 

objects (“User or Group 1” and “MOST MFP Restrictions 1”) should all be green 

meaning they have been successfully configured and the workflow is ready to be 

created. 
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19. No changes have been made to your system as of now.  You can still go back and 

make any necessary adjustments to any part of the workflow.  To save the 

configurations, the workflow must be executed.  This is done by clicking the 

“Execute” button  on the menu bar.   After execution, you will be 

notified about what has taken place.  Click OK. 

 

 

 

20. The workflow can be saved by going to File>Save for future reference and 

adjustments.  You may keep it as the tutorial continues in the next section with 

adding the Report object. 

21. Login to the MFP with a Domain User’s account (We use a Color MFP for 

demonstration purposes).   

22. After logging in, try accessing some of the other functions on the MFP.  Since 

Faxing and Copying were unlocked (and the Copy limit is not 0), you should be able 

to navigate through those 2 functions.  Since we did not unlock Scanner and 

Document Server, you should not be able to access these functions.  At this point 

you have access to the Copy function since we set the Color copies to 1 and 

black/white to 5.  To demonstrate Color copy lockout, make 1 color copy and then 

proceed to logout.  Log back in with the same credentials.  Go to the Copy function.  

You should still be able to make Black/White copies but the Color option is locked 

out.   

 

Configuring the Report Object (Optional) 

1. This tutorial continues the previously configured workflow consisting of a Domain 

Users input and MOST MFP Restrictions process.  The Report output can also be 

added and configured to provide automated reporting (The RM Tracker 

Automation service must be running, see the services section of this report for 

more information).  To begin, drag and drop a Report object somewhere 

underneath the MOST MFP Restrictions 1 object.  
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2. You will be prompted to describe the object.  The description is important in this 

case as it will be used to save the data needed to process the report automatically.  

If adding more than one Report object, the descriptions should be different so that 

the two reports do not over write each other. Enter “Weekly Report 1” and click 

Finish. 

 

3. You are now taken back to your workflow.  We must now connect the “MFP 

Restrictions 1” object to “Weekly Report 1” using the arrow connector.  Select “Add 

Connector” from the menu bar and then drag an arrow from the “MFP Restrictions 

1” object to “Weekly Report 1” object as shown below.  
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4. You will be prompted to configure the “Weekly Report 1” object. Click Yes. If you 

select No, you can still double click on the “Weekly Report 1” object or rightclick 

and select “Configuration” to configure it. 

 
 

5. The first thing we want to configure is the type of report that is going to be run.  Use 

the browse button  to select a report.  Select User Summary.rdlc and click Open. 
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6. Use the drop down to select the time period the report should display.  Select 

Month to Date. 

 
 

7. Leave the output directory blank as it is optional.  Click Next.  

 
 

8.  At this point, we can select a column to filter the report by.  For the demonstration, 

we will select the User Login Name column and enter the user’s name. Click Next. 



Reform Tracker For MOST  21 

 

 

                                                                                                                                                                                                                                                           Reform Tracker  

 
 

9. Now you can choose the starting date and frequency to generate and email your 

report. The Reform Automation service will check this date daily and decided 

whether a report should be generated or not.  Since we are configuring a weekly 

report, we will choose “Every Week” as the frequency option.  We also want this 

report emailed so we check On the “Email this report” checkbox.  Click Next.    

 

 
 

10. Enter your email information and click Next. 
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11. Enter a subject and body for your weekly email. Click Next. 

 
12. You have completed configuring the Report object.  Click Finish. 
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13. All your objects have been configured and their captions should be green. 

 
 

14.  To save the configurations, the workflow must be executed (Everything configured 

in the other objects will overwrite any previously executed settings).  This is done 

by clicking the “Execute” button  on the menu bar.   After execution, you 

will be notified about what has taken place.  Click OK. 

 

 

15. Your settings have saved and all automated processes will be carried out as 

scheduled.  If you want to quickly test the report you created, stop and start the 

RM_Tracker_Automation service (see the appropriate section of this manual for 

more information).  Since the date you configured is over a week ago, it will email 

you the report once the service is started. 
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Generating Reports Manually 

The Tracker Reporting tool is used to view detailed information about copies made at a 

MOST enabled MFP which is running the Reform Tracker plugin. 

 

1.  Run Tracker Reporting by going to 

Start>Program>Reform..>Reform_Tracker>Tracker Reporting. 

 

 
 

 

2. Step 1: Define Data Range.  This is the time period for which the report will retrieve 

data.  There are two ways to configure the date range: 

i. Select Manually Select Dates 

ii. Selecting one of the available predefined date ranges (Year to Date, 

Month to Date ,etc) 
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3. Step 2: Filter Data.  Click the Refresh Filter Data.  This will populate the different 

users, locations, devices, job types etc.   

 

 
 

4. Click the drop down box for User’s Name.  Here you will see all the users that have 

made copies at a MOST enabled MFP with the Reform Tracker plugin.  Select a user 

from the list. 

 

 
 

5. Step 3: Get Data.  Click the Retrieve Data button to access all the information 

related to the filters that were setup in the previous step. 

 

 
 

6. Step 4: Pick Report.  Notice that you will now have access to a list of various reports 

that can be displayed.  Use the drop drown box to select the User Summary report 

from the list. 
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7. Step 5: Retrieve Report.  Click the Generate Report button. 

 

 
 

8. On the right hand side of your screen, you will see a “Report is being generated” 

message. 

 
 

9. The report will now display the user’s MFP usage.  It breaks up their copy jobs into 

black and white and color categories.   
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10. To see more detailed usage for this user, click anywhere on the bar graph. (Detailed 

usage is only available for the User Summary Report) 
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11. In order to view the detailed report, click the small + button next to the user’s name. 

 
 

12. This will display a detailed report for the user.  Information such as the time of their 

copy jobs, MFP serial number and the number of black and white/color pages. 

NOTE: Document Preview(View Document Column) is not available for copy 

tracking.  Only applies to tracking Print jobs. 

 

 
 

13. You have completed the generating reports tutorial.  Please feel free to view some 

other reports from the report list.   

 

Maintenance 
There are certain directories and SQL tables that need to be monitored for growth along 

with the MOST plug-in for Reform 12.  As a system processes more and more jobs, the 

size of these directories and SQL tables can grow very quickly.  Overall system 

performance can be affected by the large amounts of space that the files may take up.  

Also, there exists a 4GB database limit if using the Microsoft SQL Server Express 2005 

supplied with this installation. Obsolete files/database entries should be deleted 

according to your needs and file retention specifications.  It is recommended to monitor 

the following directories and SQL tables for growth: 

 

Directories: 

C:\Program Files\Reform…\Backups\ 

 

SQL Tables: 

Reform_Tracker_MFP_Lock 

Reform_Tracker_MFP_Copy_Limits 
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